Hilfe zum PBXB64-Compiler

Umfassende PowerBASIC-kompatible Befehlsreferenz für PBXB64 – mehrsprachiger nativer 64-Bit-Compiler (V10).

Quicklinks: Überblick · Befehlszeilenoptionen · BASIC-Referenz · B64-Referenz · C-Referenz · ASM-Referenz · H-Lib-Übersicht · H-Lib C-API · H-Lib-Methoden · Beispiele · Versionsgeschichte

Befehlsindex nach Kategorie

Erste Schritte

  • PBXB64-Übersicht
  • Befehlszeilenoptionen
  • Sprach-Frontends
  • Beispielprogramme
  • Bibliotheken, Dienstprogramme und Tools
  • Versionsgeschichte

Sprachreferenzen

  • BASIC-Sprachreferenz
  • BASIC-Referenz (Unterabschnitte)
  • B64-Sprachreferenz
  • B64 Referenz (Unterabschnitte)
  • C17-Sprachreferenz
  • C-Referenz (Unterabschnitte)
  • x64-Assembly-Referenz
  • PILOT-Sprachreferenz
  • PILOT-Guide

Datentypen

  • BASIC-Datentypen
  • Breite Ganzzahltypen
  • UNL Unbegrenzte Ganzzahl
  • Wissenschaftliche Typen der UNF-Familie

Native H-Lib-Container – 23 FAMILIEN

  • H-Lib-Containerindex
  • Übersicht über native H-Lib
  • Methodenreferenz (alle Familien)
  • Beispiele nach Familie
  • H-Lib C API (C-Frontend)
  • Subscript [] Zugang
  • Parameter und Rückgaben von Containerfunktionen
  • LNHEAP / Prioritätswarteschlange
  • LNDEQUE / Double-Ended Queue
  • LNSET / Sortiertes einzigartiges Set
  • LNGRAPH / Ungerichteter Graph
  • LNMULTISET / Tasche
  • LNUNIONFIND / Disjunkte Menge
  • LNLRU/LRU-Cache
  • LNRING / Rundpuffer
  • LNSKIPLIST / Wahrscheinlichkeitssatz
  • LNBPTREE / B+ Baum
  • LNQUAD / Räumlicher Quadtree
  • LNBLOOM / Bloom-Filter
  • LNSAFE / Thread-sicherer Stapel

COM, Objekte, OOP

  • Built-in Interfaces
  • KLASSE / ENDKLASSE
  • CLSID$
  • Collection Objects
  • StackCollection
  • Erstellen eines DISPATCH-Objekts
  • Auflisten von Sammlungen
  • EVENT SOURCE
  • EVENTS
  • GUID / GUID$
  • GUIDTXT$
  • ID-Bindung
  • IDISPINFO-Pseudoobjekt
  • SCHNITTSTELLE / ENDSCHNITTSTELLE (Direkt)
  • SCHNITTSTELLE / ENDSCHNITTSTELLE (Versand)
  • ISINTERFACE
  • ISNOTHING
  • ISOBJECT
  • Just what is COM?
  • Späte Bindung
  • LET (with Objects)
  • LET (mit Varianten)
  • ME-Pseudovariable
  • METHODE / ENDMETHODE
  • MYBASE-Pseudovariable
  • OBJACTIVE
  • Objektdatentyp / OBJECT-Anweisung
  • ZIELGLEICHE
  • OBJPTR
  • OBJRESULT
  • OBJRESULT$
  • Öffnen einer Typbibliothek
  • POWERARRAY-Objekt
  • IPowerTime-Objekt
  • PROGID$
  • EIGENTUM / ENDEIGENTUM
  • RAISEEVENT
  • IStringBuilderEin Objekt
  • IPowerThread-Objekt
  • Was ist VERSAND?
  • Was ist Vererbung?

Kommunikation (TCP, UDP, COMM)

  • Ein einfaches Kommunikationsprogramm
  • ECHO-Client und -Server (TCP)
  • COMM-Funktion
  • KOMM CLOSE
  • KOMMLINIE
  • KOMM. OFFEN
  • KOMM. DRUCK
  • COMM RECV
  • KOMM-RESET
  • KOMM SENDEN
  • KOMM.-EINST
  • KOMM-TIMEOUT
  • HOST-ADDR
  • HOSTNAME
  • Öffnen eines Kommunikationsports
  • TCP AKZEPTIEREN
  • TCP CLOSE
  • TCP-LEITUNGSEINGANG
  • TCP-BENACHRICHTIGUNG
  • TCP OFFEN
  • TCP-DRUCK
  • TCP RECV
  • TCP SENDEN
  • UDP CLOSE
  • UDP-BENACHRICHTIGUNG
  • UDP OFFEN
  • UDP RECV
  • UDP SENDEN

Kontrollfluss und Programmstruktur

  • CHOOSE
  • DO / LOOP
  • END
  • AUSFAHRT
  • Flusskontrolle
  • FOR EACH / WEITER
  • FOR / WEITER
  • GOSUB
  • GOTO
  • IF / THEN / ELSE · IF / END IF
  • IIF
  • ITERATE
  • Lange Schlangen
  • AUF GOSUB
  • AUF GOTO
  • ZURÜCK
  • SELECT CASE / END AUSWÄHLEN
  • Anweisungtrennung
  • Strukturierte Programmierung
  • SWITCH
  • VERSUCHEN/END VERSUCHEN
  • MODUL / ENDMODUL
  • WHILE / WENDE

Datentypen

  • Array-Datentypen
  • Bitdatentypen
  • BIT-Funktion/Anweisung
  • BITS / BITS$
  • BITSE
  • Byte (?)
  • Zeichen, Zeichenfolgen und Unicode
  • CBYT / CCUR / CCUX / CDBL / CDWD / CEXT / CINT / CLNG / CQUD / CSNG
  • CVBYT
  • Währung / Erweiterte Währung
  • CUX (16-Byte-Festkomma) Währung
  • Datentypen in Registern
  • Doppelte Genauigkeit (#)
  • Doppelwort (???)
  • Dynamische Zeichenfolgen ($)
  • Erweiterte Genauigkeit (##)
  • FIELD-Strings
  • Zeichenfolgen mit fester Länge
  • Ganzzahl (%)
  • Lang (&)
  • INT128 / I128 (vorzeichenbehaftetes 128-Bit)
  • INT256 / I256 (vorzeichenbehaftetes 256-Bit)
  • INT512 / I512 (vorzeichenbehaftetes 512-Bit)
  • UINT128 / U128 (vorzeichenloses 128-Bit)
  • UINT256 / U256 (vorzeichenloses 256-Bit)
  • UINT512 / U512 (vorzeichenloses 512-Bit)
  • Nullterminierte Zeichenfolgen
  • Numerische Datentypen
  • Numerische Gleichungen
  • Hinweise (@)
  • Zeiger auf Null-/Feste Zeichenfolgen
  • Quad (&&)
  • Single (!)
  • String-Arrays
  • String entspricht
  • Datentyp STRING$
  • VARIANT · VARIANT# / VARIANT% / VARIANT$
  • VARIANTEVT
  • Wort (??)

Fehlerreferenz und Trapping

  • ERROR-Anweisung · ERROR$-Funktion
  • Fehlerübersicht
  • Fehler-Trapping
  • Zusammenfassung der Fehlermeldungen
  • ERL-Systemvariable
  • ERL$
  • ERR / ERRCLEAR
  • Beenden eines Fehlerhandlers
  • So funktionieren Fehlerfallen
  • AUF FEHLER
  • WIEDER AUFNEHMEN
  • Setzen einer Fehlerfalle
  • WERFEN (V10) – siehe VERSUCHEN/END VERSUCHEN
  • Einen Fehlerbehandler schreiben

Datei-E/A – sequentiell, zufällig, binär

  • Binary Files
  • CLOSE
  • EOF
  • DATEIATTR
  • DATEINAME$
  • DATEIENCAN
  • FLÜSSIG
  • FREEFILE
  • ERHALTEN
  • ERHALTEN$$
  • GET$
  • INPUT / INPUT#
  • LINE-EINGANG#
  • LOC
  • SPERREN
  • LOF
  • OFFEN
  • PRINT / PRINT#
  • SETZEN
  • PUT$
  • PUT$$
  • Direktzugriffsdateien
  • LESEN
  • Daten lesen und schreiben
  • ZURÜCKSETZEN
  • SUCHEN
  • Sequentielle Dateien
  • SETEOF
  • BILDSCHIRM
  • ENTSPERREN
  • WRITE / WRITE#

Dateiverwaltung (Pfade, Attribute, Suche)

  • CHDIR
  • CHDRIVE
  • CURDIR$
  • DIR$
  • DIR$ CLOSE
  • DISKFREI
  • Festplattengröße
  • Dateibefehle
  • DATEIKOPIE
  • Dateien
  • GETATTR
  • ISFILE
  • ISFOLDER
  • TÖTEN
  • MKDIR
  • NAME
  • PFADNAME$
  • PATHSCAN$
  • RMDIR
  • SETATTR

Inline-Assembler

  • x64-Assembly-Referenz
  • ASM
  • ASM-Übersicht
  • ASM-Adressierungsmodi
  • ASM-Richtlinien
  • ASM Core-Mnemonik
  • ASM SSE-Mnemonik
  • ASM AVX-Mnemonik
  • ASM BMI-Mnemonik
  • ASM-FPU-Mnemonik
  • ASM MMX-Mnemonik
  • ASM-Cache/Prefetch
  • ASM-Krypto / AES-NI
  • ASM SGX / VMX
  • ASM-System
  • ASMDATA / END ASMDATA
  • Balancing the stack
  • Kommentieren des Assemblercodes
  • Datentypen in Registern
  • Effektive Adressierung
  • Inline-Assembler-Syntax
  • Vermischung von ASM und BASIC
  • CALL-Anweisung
  • CMOVcc-Anweisungen
  • CMP-Anweisung
  • CQO-Anweisung
  • DIV-Anweisung
  • IDIV-Anweisung
  • Jcc-Anweisungen
  • JMP-Anweisung
  • LEA-Anweisung
  • LOCK-Präfix
  • MOV-Anweisung
  • MOVSX / MOVZX
  • MUL / IMUL
  • NEIN
  • POP
  • DRÜCKEN
  • REP / REPNE
  • RET
  • SAR
  • SHL
  • SHR
  • SUB
  • TEST
  • XCHG
  • XOR
  • MMX-Register
  • Mnemonik und Operanden
  • Opcodes und Mnemonik
  • Registriert
  • Register speichern
  • Speichern von Registern auf Prozedurebene
  • FPU-Register speichern
  • #STACK-Metaaussage
  • Reduzierung des Stack-Overheads
  • Der Inline-Assembler
  • Der Stapel
  • Tricks zur Registererhaltung
  • Tricks des Stapels
  • Using assembly in your code
  • Verwendung von ESP und EBP

Mathematische und numerische Funktionen

  • ABS
  • ATN
  • BGR
  • BIN$
  • BIT CALC
  • DECKE
  • COS
  • DEC$
  • EXP
  • FIX
  • FRAC
  • HEX$
  • Hallo
  • INT
  • ISWIN
  • LO
  • PROTOKOLL
  • MAK
  • MAX
  • MIN
  • OCT$
  • RANDOMISIEREN
  • BLEIBEN$
  • RGB
  • RND
  • DREHEN
  • RUNDEN
  • SGN
  • UMSCHALT
  • SÜNDE
  • SQR
  • TAUSCHEN
  • BRÄUNEN
  • TIMER
  • TIX (echt, V10)

Memory, Pointers, Registers

  • CODEPTR / FUNCPTR
  • Effektive Adressierung
  • FUNCNAME$
  • GLOBALMEM ALLOC
  • INCR
  • DECR
  • SPEICHERKOPIE
  • Adressierung und Hinweise
  • Interne Darstellungen von Arrays
  • Evaluating a variable — see LET
  • Mehrdimensionale Arrays
  • ARRAY-ZUWEISUNG
  • ARRAY LÖSCHEN
  • ARRAY-EINSATZ
  • Array-Operationen
  • ARRAY-SCAN
  • ARRAY-SORTIERUNG
  • Anforderungen an den Array-Speicher
  • ARRAYATTR
  • Übergeben von Arrays
  • Übergeben dynamischer Zeichenfolgen
  • Übergabe von Parametern
  • Parameter BYREF / BYVAL
  • Zeiger auf Arrays
  • Zeiger auf Arrays mit dualen Indizes
  • BLICK
  • STICK
  • STRPTR
  • VARPTR
  • Indizes
  • SIZEOF

Operatoren und Ausdrücke

  • UND
  • Arithmetische Operatoren
  • %DEF
  • EQV
  • IMP
  • ISFALSCH
  • Ich vermisse
  • ISNOTNULL
  • ISNULL
  • ISTRUE
  • MOD
  • NICHT
  • Vorrang des Operators
  • ODER
  • Vergleichsoperatoren
  • XOR

Preprocessor & Metastatements

  • #AUSRICHTEN
  • #BLOAT
  • #COM
  • #COMPILE · Compiler Operations
  • #DEBUG-CODE
  • #DEBUG-ANZEIGE
  • #DEBUG-FEHLER
  • #DEBUG PRINT
  • #DIM
  • #EXPORT
  • #IF / #ELSEIF / #ELSE / #ENDIF
  • #INCLUDE
  • #LINK
  • #NACHRICHTEN
  • Übersicht über Metaaussagen
  • #OPTIMIEREN
  • #OPTION
  • #SEITE
  • #PBFORMS
  • %PB_COMPILETIME
  • #REGISTER
  • #RESSOURCE
  • RESSOURCE$
  • #TOOLS
  • #EINZIGARTIG
  • #NUTZBARKEIT

Procedures, Functions, Entry Points

  • CALL
  • CALL DWORD
  • Callbacks
  • CALLSTK / CALLSTK$
  • CALLSTKCOUNT
  • CB-Rückruf
  • Einen Dialog erstellen
  • Erstellen einer DLL
  • Erstellen einer SLL
  • ERKLÄREN
  • DLL-Beispiel
  • FASTPROC / END FASTPROC
  • FUNCTION / ENDFUNKTION
  • LibMain
  • DLLMAIN
  • PBLIBMAIN
  • PBMAIN
  • Private and exported procedures
  • SLL-Beispiel
  • SUB / END SUB
  • Was ist eine DLL?
  • Was ist eine SLL?
  • Warum DLLs verwenden?
  • WINMAIN

String Functions & Operations

  • ACODE$
  • ASC-Funktion/Anweisung
  • BIN$
  • BUILD$
  • CHR$
  • CHRBYTES
  • ChrToOem$
  • ChrToUtf8$
  • CLIP$
  • ZWISCHENABLAGE BITMAP ERHALTEN
  • BEFEHL$
  • CSET / CSET$
  • TAGNAME$
  • UMWELT$
  • EXTRACT$
  • FORMAT$
  • HEX$
  • INSTR
  • JOIN$
  • WIE / GLEICH
  • LCASE$
  • LINKS$
  • LEN
  • LSET / LSET$
  • LTRIM$
  • MCASE$
  • MID$ / MID$-Anweisung
  • MONTHNAME$
  • NUL$
  • OCT$
  • OemToChr$
  • PARSE / PARSE$
  • PARSECOUNT
  • REGEXPR
  • REGREPL
  • REMOVE$
  • REPEAT$
  • REPLACE
  • BEHALTEN$
  • RICHTIG$
  • RSET / RSET$
  • RTRIM$
  • SHRINK$
  • SPACE$
  • GETEILT
  • STR$
  • STRDELETE$
  • String entspricht
  • STRING$
  • String-Ausdrücke
  • Befehle für String-Operationen
  • STRINSERT$
  • STRREVERSE$
  • TAB$ / TAB LÖSCHEN
  • TALLY
  • Textbefehle
  • Zeitbefehle
  • ZEIT$
  • DATUM$
  • TRIM$
  • UCASE$
  • UCODE$
  • UCODEPAGE
  • UNWRAP$
  • Utf8ToChr$
  • USING$
  • VAL / VAL-Anweisung
  • ÜBERPRÜFEN
  • WRAP$

Threading, Processes, Priority

  • PROZESS ERHALTEN PRIORITÄT
  • PROZESS SETZEN PRIORITÄT
  • FADEN CLOSE
  • THREAD-Codegruppe
  • Thread-Kontrolle
  • THREAD CREATE
  • Thread erhält Priorität
  • Thread-Lebenslauf
  • Thread-Set-Priorität
  • Thread-Status
  • FADEN AUFHÄNGEN
  • FADENZAHL
  • Mit Gewinde
  • Thread-ID
  • XTHREAD ERSTELLEN

UI, Graphics, DDT, Dialogs

  • Adding controls to the dialog
  • ACCEL ATTACH
  • Eingebaute RGB-Entsprechungen
  • COMBOBOX ADD
  • Kommunikationskontrolle
  • STEUERUNG HINZUFÜGEN
  • STEUERUNG HINZUFÜGEN-TASTE
  • STEUERUNG CHECK3STATE HINZUFÜGEN
  • STEUERN SIE DAS Kontrollkästchen „Hinzufügen“.
  • CONTROL ADD COMBOBOX
  • STEUERUNG RAHMEN HINZUFÜGEN
  • STEUERUNG GRAFIK HINZUFÜGEN
  • STEUERUNG HEADER HINZUFÜGEN
  • STEUERUNG BILD HINZUFÜGEN
  • STEUERUNG BILD HINZUFÜGENX
  • STEUERN SIE DIE IMGBUTTON HINZUFÜGEN
  • STEUERUNG IMGBUTTON HINZUFÜGENX
  • STEUERUNG ETIKETT HINZUFÜGEN
  • STEUERUNG ZEILE HINZUFÜGEN
  • STEUERUNG LISTBOX HINZUFÜGEN
  • STEUERUNG LISTVIEW HINZUFÜGEN
  • STEUERN SIE DIE OPTION HINZUFÜGEN
  • STEUERUNG FORTSCHRITTSBAR HINZUFÜGEN
  • STEUERUNG SCROLLBAR HINZUFÜGEN
  • STEUERUNG STATUSBAR HINZUFÜGEN
  • STEUERUNG REGISTERKARTE HINZUFÜGEN
  • STEUERUNG TEXTFELD HINZUFÜGEN
  • STEUERUNG SYMBOLLEISTE HINZUFÜGEN
  • STEUERUNG TREEVIEW HINZUFÜGEN
  • STEUERUNG DEAKTIVIEREN
  • STEUERUNG AKTIVIEREN
  • KONTROLLE ERHALTEN SIE ÜBERPRÜFEN
  • KONTROLLE KUNDEN ERHALTEN
  • STEUERUNG ERHALTEN LOC
  • KONTROLLE ERHALTEN SIE GRÖSSE
  • CONTROL GET TEXT
  • KONTROLLE GET BENUTZER
  • STEUERGRIFF
  • STEUERUNG AUSblenden
  • KONTROLLKILL
  • STEUERUNG NORMALISIEREN
  • Kontrollposten
  • STEUERN SIE NEUZEICHNEN
  • STEUERUNG SENDEN
  • STEUERUNGSSATZ PRÜFEN
  • CONTROL SET-CLIENT
  • STEUERUNG FARBE EINSTELLEN
  • STEUERUNG FOKUS SETZEN
  • STEUERUNG SET SCHRIFTART
  • STEUERUNG BILD EINSTELLEN
  • STEUERUNG IMAGEX EINSTELLEN
  • STEUERUNG IMGBUTTON EINSTELLEN
  • CONTROL SET IMGBUTTONX
  • STEUERUNG SET LOC
  • STEUERUNGSSET-OPTION
  • CONTROL SET-GRÖSSE
  • STEUERUNG TEXT EINSTELLEN
  • STEUERUNG BENUTZER EINSTELLEN
  • CONTROL SHOW STATE
  • Kontrollen (DDT)
  • Steuerungsstile (DDT)
  • DESKTOP-CLIENT ERHALTEN
  • DESKTOP GET LOC
  • DESKTOP-GRÖSSE ERHALTEN
  • DIALOG DEAKTIVIEREN
  • DIALOGVERANSTALTUNGEN
  • DIALOG AKTIVIEREN
  • DIALOG END
  • DIALOG-STANDARDSCHRIFTART
  • DIALOG KUNDEN ERHALTEN
  • DIALOG GET LOC
  • DIALOG GRÖSSE ERHALTEN
  • DIALOG TEXT ERHALTEN
  • DIALOG BENUTZER ERHALTEN
  • DIALOG AUSblenden
  • DIALOG MAXIMIEREN
  • DIALOG MINIMIEREN
  • DIALOG NEU
  • DIALOG NICHT STABIL
  • DIALOG NORMALISIEREN
  • DIALOGPIXEL
  • DIALOGPOST
  • DIALOG NEU ZEICHNEN
  • DIALOG SENDEN
  • DIALOGSET-CLIENT
  • DIALOG FARBE EINSTELLEN
  • DIALOGSET-SYMBOL
  • DIALOG SET LOC
  • DIALOGGRÖSSE EINSTELLEN
  • DIALOG TEXT EINSTELLEN
  • DIALOG SET BENUTZER
  • DIALOGMODAL ANZEIGEN
  • DIALOG ZEIGEN MODELLLOS
  • DIALOG STATUS ANZEIGEN
  • DIALOG STABILISIEREN
  • Dialogstile (DDT)
  • DIALOGEINHEITEN
  • ANZEIGE DURCHSUCHEN
  • ANZEIGEFARBE
  • ANZEIGESCHRIFTART
  • OPENFILE ANZEIGEN
  • SAVEFILE ANZEIGEN
  • Dynamische Dialogtools (DDT)
  • DDT-Befehle
  • SCHRIFTART END
  • SCHRIFTART NEU
  • Grafische Befehle
  • GRAFISCHER BOGEN
  • GRAFISCHE ANHÄNGE
  • GRAFISCHES BITMAP-END
  • GRAFISCHES BITMAP-LADEN
  • GRAFISCHE BITMAP NEU
  • GRAFIKBOX
  • GRAFIK(COL)
  • GRAFIK(Zellengröße.X)
  • GRAFIK (Chr.Größe.X)
  • GRAFIK KLAR
  • GRAFISCHE Codegruppe
  • GRAFISCHE FARBE
  • GRAFISCHE KOPIE
  • GRAFISCHES ABNEHMEN
  • GRAFISCHE ELLIPSE
  • GRAFIK ERHALTEN BITS
  • GRAFIK(CANVAS.X)
  • GRAFIK$(CAPTION)
  • GRAFIK(Client.X)
  • GRAFIK(Clip.X)
  • GRAFIK(DC)
  • GRAFIK(LINIEN)
  • GRAFIK(LOC.X)
  • GRAFIK(MIX)
  • GRAFIK (ÜBERLAPPUNG)
  • GRAFIK(PIXEL...)
  • GRAFIK(POS.X)
  • GRAFIK(PPI.X)
  • GRAFIK ERHALTEN MAßSTAB
  • GRAFIK(SCROLLTEXT)
  • GRAFIK(GRÖSSE.X)
  • GRAFIK (STRETCHMODUS)
  • GRAFIK(Ansicht.X)
  • GRAFIK (WORDWRAP)
  • GRAFIK (WRAP)
  • GRAFISCHE BILDLISTE
  • GRAFIK$(INKEY$)
  • GRAFISCHE INPUT
  • GRAFISCHER EINGANG FLUSH
  • GRAFIK(INSTAT)
  • GRAFISCHE LINIE
  • GRAFISCHE ZEILENEINGABE
  • GRAFISCHE FARBE
  • GRAFISCHER TORTEN
  • GRAFISCHES POLYGON
  • GRAFISCHE POLYLINIE
  • GRAFIKDRUCK
  • GRAFISCHES NEUZEICHNEN
  • GRAFISCHES Rendering
  • GRAFIK SPEICHERN
  • GRAFISCHE MAßSTAB
  • GRAFIK AUTOGRÖSSE EINSTELLEN
  • GRAFIK-SET-BITS
  • Bildunterschrift für das Grafikset
  • GRAFIK-SET-CLIENT
  • GRAFIK-SET-CLIP
  • GRAFIKSATZ BEHOBEN
  • GRAFIK SET FOKUS
  • GRAFIK-SET-SCHRIFTART
  • GRAFIK SET LOC
  • GRAFISCHER SET-MIX
  • GRAFIKSATZ-ÜBERLAPPUNG
  • GRAFIK-SET-PIXEL
  • GRAFIK SET POS
  • GRAFIK SET SCROLLTEXT
  • GRAFIK-SET-GRÖSSE
  • GRAFIK SET STRETCHMODE
  • GRAFISCHE SET-ANSICHT
  • VIRTUELLES GRAFIKSET
  • GRAFIK-SET WORDWRAP
  • GRAFIK-SET-WICKEL
  • GRAFISCHE SPLIT
  • GRAFISCHER STRETCH
  • GRAFISCHER STIL
  • GRAFIK(TEXT.GRÖSSE.X...)
  • GRAFIK$(WAITKEY$)
  • GRAFISCHE BREITE
  • GRAFISCHES FENSTER
  • Klicken Sie auf das Grafikfenster
  • GRAFISCHES FENSTERENDE
  • GRAFISCHES FENSTER VERDECKEN
  • GRAFIKFENSTER MINIMIEREN
  • GRAFIKFENSTER NICHT STABIL
  • GRAFIKFENSTER NORMALISIEREN
  • GRAFISCHES FENSTER STABILISIEREN
  • Grafikübersicht
  • HEADER GET COUNT
  • BILDLISTE BITMAP HINZUFÜGEN
  • EINGABEBOX$
  • LISTBOX HINZUFÜGEN
  • LISTVIEW SPALTE LÖSCHEN
  • LPRINT / LPRINT$
  • LPRINT ATTACH
  • LDRUCKEN CLOSE
  • LPRINT FLUSH
  • LPRINT FORMFEED
  • MENÜ POPUP HINZUFÜGEN
  • MENÜ STRING HINZUFÜGEN
  • MENÜ ANHANG
  • MENÜKONTEXT
  • MENÜ LÖSCHEN
  • MENÜ-ZEICHNUNGSBAR
  • Menübeispiel
  • Menüübersicht
  • Menüstatus
  • MENÜ STATUS ERHALTEN
  • MENÜ TEXT ERHALTEN
  • MENÜ NEUE BAR
  • MENÜ NEUES POPUP
  • MENÜ-SETZUSTAND
  • MENÜ TEXT EINSTELLEN
  • Menü-Komplettlösung
  • Modal vs. Modelos
  • Mehr auf der Speisekarte
  • MOUSEPTR
  • MSGBOX (und ? Alias)
  • TBOX (timed message box, V10)
  • Optionsdialog
  • DRUCKER$
  • DRUCKERANZAHL
  • PROGRESSBAR GET POS
  • SCROLLBAR SEITENGRÖSSE ERHALTEN
  • STATUSBAR-SETTEILE
  • Syntax Benutzerdefinierte Farbauswahl
  • Schaltfläche „Hinzufügen“ in der Symbolleiste
  • TREEVIEW LÖSCHEN
  • FENSTER GET HANDLE
  • FENSTERSET-ID

User-Defined Types (UDTs) and Unions

  • Zugriff auf UDT-Felder
  • Arrays innerhalb von UDTs
  • Integrierte UDTs
  • UDTs definieren
  • ENUM / END ENUM
  • EXE.Inst UDT
  • LET (mit Typen)
  • MAKRO / END MAKRO
  • Verschachtelung von UDTs
  • Speicheranforderungen und -beschränkungen
  • TYP / ENDTYP
  • TYP EINGESTELLT
  • UDT-Beispiele
  • UNION / ENDUNION
  • Union storage requirements
  • Gewerkschaftsübersicht
  • Übersicht über benutzerdefinierte Typen
  • Arrays von UDTs
  • UDTs mit Prozeduren

Variables, Scope, Storage

  • Zugriff auf PB-Variablen über den Namen
  • DATEN / WIEDERHERSTELLEN
  • DATENANZAHL
  • Standardmäßige Variablentypisierung
  • DEFBYT / DEFCUR / DEFCUX / DEFDBL / DEFDWD / DEFEXT / DEFINT / DEFLNG
  • Konstanten definieren
  • DIM
  • GLOBAL
  • Zeilennummern und Beschriftungen
  • LOCAL
  • REDIM
  • REM / '
  • STATIC
  • Variablen
  • Variabler Umfang

Andere Referenzen und Dienstprogramme

  • Integrierte numerische Gleichungen
  • Integrierte String-Gleichungen
  • Konvertieren einer .RC in eine .RES
  • Konstanten und Literale
  • Übersicht über den Debug-Code
  • Eingabebefehle
  • MATTE
  • METRIKEN
  • Verschiedene Operationen
  • Nachrichten (PB/WinAPI)
  • Betriebssystem
  • Profil
  • SCHALE
  • SCHLAF
  • BEEP
  • TRACE
  • ZEITBASIS
  • TXT-Pseudoobjekt
  • SWITCH

Gesamtthemen: 800+ (dieser Index plus die H-Lib-Containerseiten und Code-Referenzseiten). Zuletzt aktualisiert am 19.06.2026.

Abdeckungsprüfungen

Vor der Veröffentlichung der Hilfe sollen Inhaltsaudit, Linkvalidator und Deutsch/Englisch-Paritätsprüfung laufen. Die Übersicht soll nur auf Bereiche verweisen, deren Seiten in beiden Sprachbäumen existieren und im aktuellen CHM-Build enthalten sind.

Zurück zum Befehlsindex

← Nach oben Willkommen & Erste Schritte →

Dokumentationspflege

Diese Übersicht soll neu erzeugt werden, wenn Befehlsseiten, Frontend-Referenzen oder CHM-Build-Regeln geändert werden. Prüfen Sie, dass der englische und deutsche Baum dieselbe HTML-Seitenmenge enthalten und dass die neu erzeugten CHM-Dateien nach help und Release kopiert werden.

Abdeckungsprüfungen

Vor der Veröffentlichung der Hilfe sollen Inhaltsaudit, Linkvalidator und Deutsch/Englisch-Paritätsprüfung laufen. Die Übersicht soll nur auf Bereiche verweisen, deren Seiten in beiden Sprachbäumen existieren und im aktuellen CHM-Build enthalten sind.


PBXB64 - Overview

Startseite › Willkommen & Erste Schritte

PBXB64 Compiler V14

PBXB64 ist ein nativer x86-64-Multi-Frontend-Compiler, der in reinem C11 geschrieben ist. PowerBASIC-kompatibles BASIC, B64, C17, PILOT, Inline-Assembly, Rust, COBOL, Forth, LOGO und SPR werden ueber eine einheitliche IR, einen Optimierer und ein x64-Backend zu nativen PE32+ Windows-ausfuehrbaren Dateien und COFF-Objektdateien kompiliert.

Aktuelle Version: 0.50.0-V14 (Release V14)
Umsetzung: Reines C11, keine C++-Abhängigkeiten
Ziel: Windows x64 PE32+ / COFF-Objektdateien
Testmatrix: 4577/4577 (0 erwartete Fehler, 0 unerwartete Fehler)
License: Kostenlos für den privaten Gebrauch
Urheberrecht: © 2026 Theo Gottwald / www.smart-package.com

Auf einen Blick

Fähigkeit | Status
PowerBASIC-compatible BASIC frontend | VOLL Über 200 Befehle, Win32-GUI, DDT, COMM, TCP/UDP, Threads, Grafiken
B64-Systemsprache | VOLL 11/11 Link+Run-Tests, Strukturen, Zeiger, indirekte Aufrufe, Varargs
C17-Frontend | VOLL Präprozessor, Strukturen/Unions, Funktionszeiger, printf/scanf, malloc/free, stdio, stdlib, String, Mathematik
Inline-x64-Assembler | VOLL Intel-Syntax, SSE/SSE2/SSE3/SSSE3/SSE4/AVX, BMI, FPU, MMX
Native H-Lib-Container | VOLL 23 Familien, 124 Typschlüsselwörter, Method-Dispatch-Syntax, C-API
Breite ganze Zahlen | VOLL INT128 / UINT128 / INT256 / UINT256 / INT512 / UINT512 mit Inline-Arithmetik
VARIANT-Datentyp | VOLL Skalare, feste und dynamische Arrays, Deep-Copy-Semantik, typisierte Extraktoren/Setter
Win32-Subsystem | VOLL GUI/Konsole, Dialoge, Steuerelemente, Grafiken, Kommunikation, Registrierung, Mouseptr, Threading
Single-binary distribution | ~919 KB UPX-komprimierter Compiler, keine externen Laufzeit-DLLs

Sprach-Frontends

Sprache | Erweiterungen | Beschreibung
GRUNDLEGEND (PowerBASIC-Dialekt) | .pb, .bas, .pba | PRINT, dynamischer STRING, Win32-Aufrufe, GUI/DDT, COMM, Threads, Grafiken, LPRINT, XPRINT, FONT, MENU, GRAPHIC, MSGBOX/TBOX, H-Lib-Container.
B64 | .b64 | C-ähnliche Systemsprache. Strukturen, Zeiger, indirekte Aufrufe, Varargs, Printf, Funktionszeiger-Versand, vollständige IR-Integration.
C17 | .c, .h | C17-Teilmenge: Präprozessor (#define, #if/#else/#endif, __FILE__, __LINE__), Strukturen/Unions, Aufzählungen, Funktionszeiger, printf/scanf, malloc/free, stdio/stdlib/string/math, native H-Lib C API.
Assembly | .asm, .s | Nativer x64-Assembler. Intel-Syntax, SSE/SSE2..SSE4.2/AVX/BMI/FPU/MMX, direkte COFF/PE-Ausgabe, Win64 ABI.

Compiler-Architektur

   .pb / .b64 / .c / .asm
        |
        v
   +-----------+   +-----------+   +-----------+   +-----------+
   |  PB       |   |  B64      |   |  C17      |   |  ASM      |
   |  frontend |   |  frontend |   |  frontend |   |  frontend |
   +-----------+   +-----------+   +-----------+   +-----------+
        \             |              |              /
         \            v              v             /
          +-----+ +---------+ +---------+ +---------+
          | AST |->|   IR    |->| Opt/    |->| x64    |-> COFF -> PE32+
          +-----+ +---------+ | passes  |  | backend|
                              +---------+ +---------+

   Built-in:           Linker64, archive64, import table, runtime intrinsics,
                       c_hlib container library, c_runtime_user (Win32 helpers).

V10-Highlights

  • Einheitlicher Qualitätstest für Hilfedateien: Ein einziges konsistentes Design, vollständiges Inhaltsverzeichnis, keine defekten internen Links und eine eigene Seite für jede Compiler-Befehlszeilenoption.
  • 47 CLI-Optionsseiten: Jedes Flag verfügt über eine eigene Detailseite mit Syntax, Standardverhalten, ausgegebener Formatbeschreibung, realer Beispielausgabe und Querlinks.
  • Genaue PILOT-Dokumentation:Alle 12 PILOT-Befehlsseiten spiegeln jetzt den tatsächlichen nativen Implementierungsstatus wider (R:, T:, E: implementiert; C:, A:, J:, M:, Y:, N:, U:, S:, Labels noch nicht unterstützt).
  • Vollständige x64-Anweisungsabdeckung: Fehlende Anweisungsseiten hinzugefügt (CLD, MOVS, STOS, STD, POPA, PUSHA) und im Assembly Reference TOC verkabelt.
  • Breite ganze Zahlen (V8): Native 128/256/512-Bit-Ganzzahltypen mit und ohne Vorzeichen und vollständiger Inline-Arithmetik – ADD, SUB, MUL, DIV, REM, SHL, SHR, AND, OR, XOR, CMP, MKx / CVx Zwang und Druckunterstützung.
  • MSGBOX-Alias (V8.1): Die ? Zeichen wird als PB/CC-kompatibler Alias für akzeptiert MSGBOX Anweisung.
  • TBOX (V8.1): Zeitgesteuertes Nachrichtenfeld mit automatischer Schließung – "text [N]" Markierung wo N ist das Timeout in Sekunden.

Aktuelle wichtige Meilensteine (Z64 – Z76)

  • Z64 – 25-Fehler-Sweep. 318/318 testet grün. Alle zuvor dokumentierten bekannten Einschränkungen behoben.
  • Z65 – Native H-Lib-Containertypen. 10 Familien (Arr, Stk, Que, Lst, Str, 2D, Hsh, Tre, DTre, Tri).
  • Z66 – Build-Hardening + P0-Laufzeit. ERROR$, UCODE$ / UCODEPAGE, PRINT USING vollständig umgesetzt.
  • Z67 – H-Lib Phase 7 (UDT-Nutzlast). Der Containerelementtyp kann ein PB sein TYPE.
  • Z68 – H-Lib Phase 8 (C-Frontend-Parität). Native H-Lib-Container, auf die von C aus zugegriffen werden kann core/include/c17/pbxb64/hlib.h.
  • Z69 – SortUsing Rückrufe + CODEPTR. Komparatorgesteuerte Sortierung, echte Funktionsadressenextraktion.
  • Z70 – VARIANTEN-Vollständigkeit. Variantenskalare/Arrays, Deep-Copy-Lebenszyklus, Behebung von Speicherbeschädigungen in der FOR-Schleife.
  • Z71 — [] Indexzugriff. Lesen/Schreiben von Container-Indizes im PowerBASIC-Stil.
  • Z72 – Heap, Deque, Set, Graph.
  • Z73 – Multiset, UnionFind, LRU, Ring, SkipList, B+Tree, Quadtree, Bloom, Safe.
  • Z74 – Generierter PB-System-Regressions-Sweep. Gehärtet DATE$/TIME$, COMMAND$/ENVIRON$, MOUSEPTR, PROCESS PRIORITY, UCODE$.
  • Z75 – Real RND, RANDOMIZE, INKEY$, WAITKEY$. LCG-basiertes RNG mit deterministischem Seed; Win32-Konsoleneingabe liest.
  • Z76 – V5-Schiffsbereitschaftsprüfung. 1591/1591 Tests, null erwartete Ausfälle, schiffsbereit.

Dokumentationsabschnitte

  • Befehlszeilenoptionen – Alle Compiler-Flags, Schalter und V8-Präprozessorverbesserungen
  • BASIC-Sprachreferenz — PowerBASIC-kompatible Syntax, Win32-Erweiterungen, H-Lib
  • B64-Sprachreferenz – Die primäre Systemsprache
  • C-Sprachreferenz – C17-Teilmenge mit Präprozessor, printf, Funktionszeigern, nativer H-Lib C-API
  • Assembly-Referenz – Nativer x64-Assembler, SSE/AVX/BMI-Mnemonik
  • H-Lib Containers – 23 native Containerfamilien mit Method-Dispatch-Syntax und C-API
  • H-Lib-Containerindex – Kurzreferenz für jede Familie
  • Referenz zur H-Lib-Methode — Vollständige Methodentabellen für jede Familie
  • H-Lib-Beispiele — Code-Snippets für jeden Containertyp
  • Beispielprogramme — Beispielcode für alle Frontends
  • Befehlsindex – Alphabetische A–Z-Liste mit über 800 Befehlen und Anweisungen
  • Versionsgeschichte — Z-Meilenstein- und V-Release-Tabelle
Tipp: Verwenden Sie den Inhaltsbereich auf der linken Seite für eine durchsuchbare Kategorieansicht, das Suchfeld (oben links) für die Volltextsuche oder das Befehlsindex für eine einzelne alphabetische A–Z-Liste.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


Versionsverlauf “ PBXB64-Hilfe

Startseite â€º Versionsverlauf

Versionsgeschichte

Veröffentlichungsverlauf und Versionsmeilensteine für den PBXB64-Compiler. Bei der Z-Serie handelt es sich um interne Z-Meilensteine â€‹â€‹(Entwicklungsabbrüche). Bei der V-Serie handelt es sich um benutzerorientierte Release-Drops. Jede Zeile in der Tabelle unten entspricht einem Tag im Versionsverlauf des Repositorys.

Aktuelle Version: 0.50.0-V10 (Release V10) “ 29.06.2026
Umsetzung: Reines C17 (keine C++-Abhängigkeiten)
Ziel: Windows x64 PE32+ / COFF-Objektdateien
Sprachen: PowerBASIC-kompatibles BASIC, B64, C17, PILOT, Inline-ASM; experimentelle Rust-, COBOL- und Forth-Frontends
Testmatrix: 2078/2078 (0 erwartete Fehler, 0 unerwartete Fehler) “ 1182 Assembly, 206 PB Link+Run, 22 B64 Link+Run, 117 C-Kompilierung, 6 C Link+Run, 526 generiert, 19 Pilot-Link+Run, 28 COBOL Link+Run, 57 Forth Link+Run, 23 Rust Link+Run

Meilensteine der Version

Meilenstein | Datum | Spur | Hauptmerkmale
Z58 | 2026 | B64 | B64-Frontend-Routen durch b64_frontend_build_ir() vor der Optimierung. --emit-ir / --dump-ir sind gespalten. Globale Ganzzahlinitialisierer geben Bytes aus .data / .rdata.
Z58“Z60 | 2026 | PB | Alle PB-Anweisungshandler wurden zur Verwendung neu geschrieben pb_try_eval_expr() statt pb_eval_expr(). Echte Handler für DIALOG, CONTROL, TCP/UDP, HOST, THREAD, REGISTER, COMM, MOUSEPTR, PROCESS, LPRINT, XPRINT, GUI, DISPLAY, FONT, MENU, GRAPHIC.
Z60 | 2026 | alle | 4-Spur-Sweep mit bekannter Begrenzung. B64-Beispiele 11/11, PB Link+Run 6/6, C-Kompilierung 63/63, C-Link+Run 1/1. Laufzeit-Stubs wurden durch echte Win32-Aufrufe ersetzt.
Z61 | 2026 | PB/Link | Win64 Multi-Argument-ABI-Korrektur (5+ Argumente), IR_OP_REM-Korrektheit (implizite CQO/IDIV-Leser), FOR-Schleifenkörper-Const-Fold-Korrektur, Link-Symbol-Sweep (25 fehlende Laufzeitsymbole hinzugefügt). Float FOR-Schleife, negativer STEP, CURRENCY-Typabdeckung.
Z64 | 2026 | alle | 25-Fehler-Sweep. PB-Frontend-Codegen (12), Absturzkorrekturen (3), Typsystemkorrekturen (3), B64-Frontend-Korrekturen (4), Diagnosekorrekturen (3). 318/318 testet grün. V3-Veröffentlichung.
Z65 | 2026 | H-Lib | 10 native H-Lib-Containerfamilien: Arr, Stk, Que, Lst, Str, 2D, Hsh, Tre, DTre, Tri. Methoden-Dispatch-Syntax, automatische Initialisierung beim Eintritt, automatische Finalisierung beim Verlassen des Bereichs. 12 Container-Testdateien bestehen.
Z66 | 2026 | Laufzeit | MinGW snprintf Absturzbehebung, Robustheit des Build-Skripts, Hilfsobjekt zur Benutzerlaufzeit (c_runtime_user.c). P0-Laufzeit: ERROR$, UCODE$ / UCODEPAGE, PRINT USING.
Z67 | 2026 | H-Lib | H-Lib Phase 7 “ UDT-Nutzlastcontainer. AS LNARR OF MyType, AS LNLST OF MyTypeusw. Container + UDT-Integration.
Z68 | 2026 | C | H-Lib Phase 8 “ C-Frontend-Parität. core/include/c17/pbxb64/hlib.h entlarvt c_hlib_lnarr_* Symbole. C Link+Laufspur 1/1 → 2/2.
Z69 | 2026 | PB / H-Lib | SortierenMit Rückrufen + CODEPTR. Komparatorgesteuerte Sortierung mit CODEPTR(CompareFn). Echte Funktionsadressenextraktion im IR.
Z70 | 2026 | PB / V | VARIANT-Vollständigkeits-Sweep. Variantenskalare/Arrays, Deep-Copy-Lebenszyklus, Behebung von Speicherbeschädigungen in der FOR-Schleife. Variantenstresstest.
Z71 | 2026 | H-Lib | H-Lib Phase 10 “ [] Indexzugriff. a[1] = 100, n = h["k"]. sys_date_time_environ_command Laufzeitabschluss.
Z72 | 2026 | H-Lib | H-Lib Phase 11 “ Heap-, Deque-, Set-, Graph-Containerfamilien.
Z73 | 2026 | H-Lib | H-Lib Phase 12 “ Multiset-, UnionFind-, LRU-, Ring-, SkipList-, B+Tree-, Quadtree-, Bloom- und Safe-Containerfamilien. Insgesamt 23 Familien.
Z74 | 2026 | PB | Generierter PB-System-Regressions-Sweep. Gehärtet DATE$/TIME$, COMMAND$/ENVIRON$, MOUSEPTR, PROCESS PRIORITY, UCODE$/UCODEPAGE. Fehler bei der Float-Register-Lebensdauer behoben.
Z75 | 2026 | PB | Echte RND-, RANDOMIZE-, INKEY$-, WAITKEY$-Benutzerlaufzeit. LCG-basiertes RNG mit deterministischem Seed; Die Win32-Konsoleneingabe lautet (PeekConsoleInputA / ReadConsoleInputA).
Z76 | 2026 | alle | V5-Schiffsbereitschaftsprüfung. INTEGER-BytegröÃŸenkonsistenz, veraltet entfernt core/source/include/compiler/frontend/pb_ast.h. RESET, LIKE, FRAC, TIX, RND/RANDOMIZE durch echte Implementierungen ersetzt. 1591/1591 Tests, 0 erwartete Fehlschläge.
V6 | 14.06.2026 | dist | Erste öffentliche Veröffentlichung der V-Serien-Distribution. Komprimierte Single-Binärdatei PBXB64.exe (~919 KB), inklusive PBXB64_Help.chm.
V7 | 15.06.2026 | dist | Aktualisierte H-Lib-Abdeckung und Dokumentation zu Befehlszeilenoptionen. -E Präprozessormodus, -I / -isystem Suchpfade.
V8 | 17.06.2026 | Kern | Native 128/256/512-Bit-Typen mit breiter Ganzzahl (INT128 / UINT128 / INT256 / UINT256 / INT512 / UINT512) mit Inline-Arithmetik. Druckunterstützung für alle Wide-Integer-Typen. Monteur global Direktivenkorrektur.
V8.1 | 18.06.2026 | Kern | MSGBOX ? Kurzschrift-Alias (PB/CC-kompatibel). TBOX zeitgesteuertes Nachrichtenfeld mit [d] Timeout-Markierung und automatisches SchlieÃŸen des Threads.
V10 | 29.06.2026 | alle | Ã–ffentliches V10-Release. Verifiziertes COBOL-85-Frontend (DATA/PROCEDURE, skalierte Festkommaarithmetik, PERFORM, IF, OCCURS, COMPUTE). Forth-Frontend-Härtung (Return-Stack-GröÃŸe, CASE/OF/ENDOF/ENDCASE). Rust-Frontend-Vorschau (Funktionen, Kontrollfluss, Structs, Enums, Zeiger, Arrays, unsafe, const). Hilfe/CHM neu aufgebaut und validiert (0 defekte Links). Matrix: 2078/2078 bestanden, 0 erwartete Fehler, 0 unerwartete Fehler.
V10 | 30.06.2026 | Kern | Rust-Frontend-Erweiterung: else if-Ketten, usize/isize, oktale/binäre/suffixierte Ganzzahl-Literale, \u{}-Char-Escapes, Typ-Aliasse, Array-Literale ([a,b,c]/[v;N]) und Struct-Literale (Point{x:1}), typisierte Zeiger-Dereferenzierung, Enum-Daten-Felder mit mehreren Werten, match |-Alternation und if-Guards, bitweise/Shift-Verbundzuweisungen. Dokumentation der #RUST/#ENDRUST-Einbettungs-Direktive und der PB-Variablen-Bridge-Intrinsics (pb_val_i64, pb_set_i64, rust_thread_spawnN_i64-Familie).

Compiler-Eigenschaften (V10)

  • Pure-C-Toolchain: Keine C++-Abhängigkeiten, einzelne C17-Codebasis (~250 C-Quelldateien)
  • Multi-Frontend: PowerBASIC (.pb), B64 (.b64), C17 (.c), PILOT (.pil), Inline-ASM (.asm); experimentelle Rust- (.rs), COBOL- (.cbl/.cob) und Forth- (.fth) Frontends
  • In sich geschlossen: Parser, IR, Optimierer, x64-Backend, Linker, Laufzeit, alles in einer ~5,5 MB unkomprimierten Binärdatei
  • Testgetrieben: 2078/2078 Tests der gebundenen Toolchain bestanden — 1182 Assembly, 206 PB Link+Run, 22 B64 Link+Run, 117 C-Kompilierung, 6 C Link+Run, 526 generiert, 19 Pilot-Link+Run, 28 COBOL Link+Run, 57 Forth Link+Run, 23 Rust Link+Run
  • Containerbibliothek: 23 native H-Lib-Familien mit Method-Dispatch-Syntax, UDT-Payload-Unterstützung, [] Indexzugriff, C-Frontend-API
  • Win64-ABI: Korrekter Multi-Argument-Aufruf (5+ Argumente), SSE2-Float-Operationen, Festregister-Spill für IDIV/CQO
  • Breite ganze Zahlen: 128/256/512-Bit mit und ohne Vorzeichen, Inline-Arithmetik, keine Bibliotheksaufrufe
  • Null erwartete Fehler: Alle abgedeckten Features umgesetzt und verifiziert

Was wurde zurückgestellt (V6 und höher)

  • Inline #ASM PB-Variablenbindung ({ var } → [rbp-N])
  • Vollständiges COM/OOP CLASS / INTERFACE Umsetzung
  • Vollständiges MAT-Matrix-Laufzeit (bereits in Benutzerlaufzeit-Stubs)
  • Voll PRINT USING Zeichenketten-/Datums-Bildmaskensprache (numerische Masken implementiert; Zeichenketten-/Datumsmasken sind minimale Platzhalter)

Siehe auch

  • Ãœberblick “ Zusammenfassung der Architektur und Sprache der obersten Ebene
  • Befehlszeilenoptionen “ alle Compiler-Flags
  • Befehlsindex “ alphabetische A“Z-Liste aller Befehle

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex

Kind: Reference topic | Category: Release Notes

PBXB64 Status: DOCUMENTED

Description

Version history is a release-documentation page. It records public PBXB64 release notes and must keep V14 public naming.

Syntax

No source syntax; use this page for release chronology.

Validation Evidence

Validation evidence: Checked by help/scripts/validate_help.py for V14 version-history coverage.

Example

' No compiler sample; confirm public release naming in the generated help.

See Also

  • overview.html
  • index.html


PBXB64 – Beispielprogramme

Startseite › PBXB64 – Beispielprogramme

Beispielprogramme und Kurzanleitung

Vollständige, kompilierbare Beispiele für jedes Sprach-Frontend. Alle Beispiele zielen auf ausführbare Windows x64 PE32+-Dateien ab. Kopieren Sie die Quelle in eine Datei mit der richtigen Erweiterung und führen Sie den angezeigten Compiler-Befehl aus.

B64 – Hallo Welt

fn main(): i32 {
    return 42;
}
PBXB64 hello.b64 -o hello.exe

B64 – Zeiger und Strukturen

struct Point { x: i32, y: i32 }

fn main(): i32 {
    let p: Point = Point { x: 10, y: 20 };
    let q: *Point = &p
    q.x = 30;
    return q.x + q.y;  // Returns 50
}
PBXB64 pointers.b64 -o pointers.exe

BASIC – Konsolenausgabe

FUNCTION PBMAIN() AS LONG
    PRINT "Hello from PBXB64!"
    PRINT "Answer:"; 42
    FUNCTION = 0
END FUNCTION
PBXB64 console.pb -o console.exe

BASIC – WinAPI-Integration

#INCLUDE "windows_core.pbi"

FUNCTION PBMAIN() AS LONG
    CALL MessageBoxA(0, "Hello", "PBXB64", 0)
    FUNCTION = 0
END FUNCTION
PBXB64 winapi.pb -o winapi.exe

C – Standard-E/A und Präprozessor

#include <stdio.h>
#define VERSION "V10"

int main(void) {
    printf("Hello from C %s\n", VERSION);
    return 0;
}
PBXB64 -I core/include/c17 -std=c17 program.c -o program.exe

C – Ablauf der Laufzeitsteuerung

int main(void) {
    int x = 2;
    switch (x) {
        case 1: return 10;
        case 2: return 20;
        default: return 0;
    }
}
PBXB64 -I core/include/c17 switch.c -o switch.exe

PILOT – Hallo Welt

Die PILOT-Unterstützung in PBXB64 ist derzeit beschränkt auf R: (Bemerkung), T: (Geben Sie eine Zeichenfolge in Anführungszeichen ein) und E: (Ende). Das folgende Beispiel verwendet nur implementierte Befehle.

R: This is a comment
T: "Hello from PILOT!"
E:
PBXB64 hello.pil -o hello.exe

Gemischte B64 + C-Verknüpfung

// sum.c
int add(int a, int b) { return a + b; }

// main.b64
fn main(): i32 {
    extern "sum.c" fn add(a: i32, b: i32): i32;
    return add(10, 20);  // Returns 30
}
PBXB64 main.b64 sum.c -o mixed.exe
Profi-Tipp:Verwenden--emit-ir um zu debuggen, wie das Frontend den Quellcode senkt, -S um die generierte Baugruppe zu überprüfen, oder -v für ausführliche Schritt-für-Schritt-Ausgabe.
← PILOT-Referenz Zurück zur Übersicht CLI-Optionen →
PBXB64 Compiler-Dokumentation · V10 · Zuletzt aktualisiert am 21.06.2026
Für Fragen und Beiträge:smart-package.com

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PBXB64 – Befehlszeilenoptionen

Startseite› Befehlszeilenoptionen

Referenz zu Befehlszeilenoptionen

PBXB64 [options] <input files>

PBXB64 akzeptiert Quelldateien in jeder unterstützten Sprache (.pb, .bas, .b64, .c, .h, .asm, .pil) in einer einzigen Befehlszeile. Flags steuern Ausgangsstufen, Optimierung, Diagnose und den C-Präprozessor. Für jede Option unten gibt es eine eigene Detailseite mit Beschreibungen im ausgegebenen Format und echten Beispielausgaben.

Ausgabesteuerung

Option | Beschreibung
-o <file> | Legen Sie den Pfad für die ausführbare Ausgabedatei/das Objekt/die Assembly fest
-c | Nur kompilieren – COFF-Objektdatei erstellen (.obj)
-S | Nach Assemblygenerierung anhalten (.asm)
--emit-ast, --dump-ast | AST-Dump ausgeben (derzeit begrenzt für native Frontends)
--emit-ir | IR-Dump ausgeben und nach dem Frontend stoppen
--dump-ir | Sidecar-IR-Dump ausgeben und mit dem Kompilieren fortfahren
--dump-ir-before=<pass> | IR-Dump unmittelbar vor dem benannten Optimierungsdurchlauf ausgeben
--dump-ir-after=<pass> | IR-Dump unmittelbar nach dem benannten Optimierungsdurchlauf ausgeben
--emit-asm | Assemblyliste ausgeben
--emit-obj | Objektdateiemission erzwingen (Alias ​​für-c)
--emit-map | Linker-Map-Datei ausgeben
--emit-mir | In Kombination mit wird ein MIR-Dump ausgegeben--emit-asm / -S
--asm:<path> | Speichern Sie die generierte Baugruppe in einer Datei und fahren Sie fort
--dump-tokens | Lexer-Token-Stream ausgeben (geparst, noch nicht ausgegeben)

Pipeline-Steuerung

Option | Beschreibung
-fsyntax-only, --syntax-only | Nur Analyse und Typprüfung; keine Codegenerierung
--stop-after=<stage> | Hören Sie danach aufir|opt|codegen|object|link
--print-pipeline | Druckfähige Optimierungsdurchgänge

Überprüfung und Fehlerbehebung

Option | Beschreibung
--verify-ir | Führen Sie den IR-Verifizierer aus
--verify-mir, --verify-machine | Führen Sie den MIR-Verifizierer aus
--verify-after-each-pass | Überprüfen Sie die IR nach jedem Optimierungsdurchlauf
--trace-passes | Passnamen werden während der Ausführung gedruckt
-g, --debug | Debuginformationen ausgeben
--time-stages | Zeiterfassungsphasen
--stats | Drucken Sie IR/MIR-Statistiken

Optimierungsstufen

Option | Beschreibung
-O0 | Keine Optimierung (Standard, schnellste Kompilierung, debug-freundlich)
-O1 | Grundlegende Optimierungen: Eliminierung von totem Code, konstante Faltung
-O2 | Aggressiv: Inlining, mem2reg, GVN, CSE, Kraftreduzierung
-O3 | Maximale Optimierung (kann die Binärgröße erhöhen)
--NoOpt | Alle Optimierungen deaktivieren (Alias ​​für-O0)

Targeting und Verlinkung

Option | Beschreibung
--target <triple> | Ziel-Triple festlegen (Standard:x86_64-w64-windows-gnu)
--entry <symbol> | Überschreiben Sie das Standard-Einstiegspunktsymbol
-gui, --gui | Windows-GUI-Subsystem im PE-Header erzwingen
-con, --console | Windows-Konsolen-Subsystem im PE-Header erzwingen
--crt=<mode> | Wählen Sie die CRT-Richtlinie aus:auto|ucrt|msvcrt|none
--no-default-crt | Deaktivieren Sie automatische CRT-Importe

Information

Option | Beschreibung
-v, --verbose | Kompilierungsschritte und -pfade anzeigen
--version | Compilerversion drucken und beenden
-h, --help | Prägnante Hilfe anzeigen und beenden

Präprozessor (C-Frontend)

Option | Beschreibung
-E | Nur Vorverarbeitung – erweiterte Quelle ausgeben
-I <path> | Benutzer hinzufügen, Suchpfad einschließen
-isystem <path> | System-Include-Pfad hinzufügen (unterdrückt Warnungen)
-DNAME | Makro definierenNAME=1
-DNAME=value | Definieren Sie ein Makro mit explizitem Wert
-UNAME | Definieren Sie zuvor definierte Makros
-std=<mode> | C-Standard auswählen:c89|c99|c11|c17|gnu*(Standardc17)
-ffreestanding | Freistehende Umgebung
-fhosted | Gehosteter C-Modus (Standard)
-fno-builtin | Deaktivieren Sie integrierte Funktionsoptimierungen

Diagnose

Option | Beschreibung
-Wall | Aktivieren Sie alle allgemeinen Warnungen
-Wextra | Aktivieren Sie zusätzliche Warnungen
-Werror | Behandeln Sie Warnungen als Fehler
-pedantic | Strikte Einhaltung von Standards
V10-Tipp:Kombinieren-E -I core/include/c17 -DDEBUG=1 program.cum die vorverarbeitete Ausgabe zu überprüfen oder zu verwenden--emit-ir sample.cum die vom Frontend erzeugte IR zu überprüfen.
← Übersicht B64-Sprachreferenz → Beispiele ansehen
PBXB64 Compiler-Dokumentation · V10 · Zuletzt aktualisiert am 21.06.2026
Für Fragen und Beiträge:smart-package.com

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht
← PBXB64 – Beispielprogramme Nach oben PBXB64 – Befehlszeilenoptionen →

Dokumentationspflege

Diese Übersicht soll neu erzeugt werden, wenn Befehlsseiten, Frontend-Referenzen oder CHM-Build-Regeln geändert werden. Prüfen Sie, dass der englische und deutsche Baum dieselbe HTML-Seitenmenge enthalten und dass die neu erzeugten CHM-Dateien nach help und Release kopiert werden.

Abdeckungsprüfungen

Vor der Veröffentlichung der Hilfe sollen Inhaltsaudit, Linkvalidator und Deutsch/Englisch-Paritätsprüfung laufen. Die Übersicht soll nur auf Bereiche verweisen, deren Seiten in beiden Sprachbäumen existieren und im aktuellen CHM-Build enthalten sind.


-D - Define Macro - PBXB64 Command-Line Option

Startseite › -D - Define Macro

-D - Define Macro

Diese Option steuert den PBXB64-Kommandozeilenmodus -DNAME, -DNAME=value. Technischer Zweck: Defines a C preprocessor macro. If no value is given, the macro is defined as 1. Use -DNAME=value to supply an explicit value. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Preprocessor | Option: -DNAME, -DNAME=value

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -DDEBUG=1 -DVERSION=10 sample.c

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -DNAME, -DNAME=value. Technischer Zweck: Defines a C preprocessor macro. If no value is given, the macro is defined as 1. Use -DNAME=value to supply an explicit value. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: No extra macros are defined by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -DNAME, -DNAME=value uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

No direct output; macro definitions affect conditional compilation and macro expansion in the preprocessor output. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 -DDEBUG=1 -DVERSION=10 sample.c. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

Macro names follow C identifier rules. Values are substituted as raw token sequences. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -U - Undefine Macro
  • -E - Preprocess Only
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-E - Preprocess Only - PBXB64 Command-Line Option

Startseite › -E - Preprocess Only

-E - Preprocess Only

Diese Option steuert den PBXB64-Kommandozeilenmodus -E. Technischer Zweck: Runs the C preprocessor and writes the expanded source to stdout. Macros are expanded, #include files are inserted, and conditional compilation is resolved. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Preprocessor | Option: -E

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -E sample.c

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -E. Technischer Zweck: Runs the C preprocessor and writes the expanded source to stdout. Macros are expanded, #include files are inserted, and conditional compilation is resolved. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Disabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -E uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

The output is valid (expanded) C source. It contains the resolved contents of all included headers, expanded macros, and stripped conditional blocks. Line directives are not emitted. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

typedef unsigned long long size_t;
typedef unsigned short wchar_t;
typedef long long ptrdiff_t;
typedef long long intptr_t;
typedef unsigned long long uintptr_t;
typedef struct { long long __ll; long double __ld; } max_align_t;
typedef char* va_list;
extern FILE *stdin;
extern FILE *stdout;
extern FILE *stderr;
int add(int a, int b) {
    return a + b;
}
int main(void) {
    int x = 5;
    ...
}

Hinweise

Use -I and -D to influence the preprocessor output. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -I - Include Path
  • -D - Define Macro
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-I - Include Path - PBXB64 Command-Line Option

Startseite › -I - Include Path

-I - Include Path

Diese Option steuert den PBXB64-Kommandozeilenmodus -I <path>. Technischer Zweck: Adds a directory to the user include search path. User paths are searched before system paths. The option can be given as -I path (with space) or -Ipath (without space). Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Preprocessor | Option: -I <path>

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -I./include -I./src sample.c

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -I <path>. Technischer Zweck: Adds a directory to the user include search path. User paths are searched before system paths. The option can be given as -I path (with space) or -Ipath (without space). Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Only the compiler's built-in include directories are searched by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -I <path> uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

No direct output; influences the files selected by #include "..." and #include <...> during preprocessing. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 -I./include -I./src sample.c. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

Order matters: directories are searched in the order they appear on the command line. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -isystem - System Include Path
  • -E - Preprocess Only
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


--NoOpt - Disable Optimizations - PBXB64 Command-Line Option

Startseite › --NoOpt - Disable Optimizations

--NoOpt - Disable Optimizations

Diese Option steuert den PBXB64-Kommandozeilenmodus --NoOpt. Technischer Zweck: Disables all middle-end and backend optimizations. Equivalent to -O0 but provided as an explicit, self-documenting switch. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Optimization | Option: --NoOpt

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 --NoOpt sample.c -o sample.exe

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --NoOpt. Technischer Zweck: Disables all middle-end and backend optimizations. Equivalent to -O0 but provided as an explicit, self-documenting switch. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: The default is -O0, so optimizations are already off unless a higher level is requested. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --NoOpt uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

No emitted-format change; the compiler simply skips the optimization pipeline. IR and assembly output reflect the unoptimized frontend lowering. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 --NoOpt sample.c -o sample.exe. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

Use this flag in build scripts where readability of the optimization intent is preferred. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -O0 - No Optimization
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-O0 - No Optimization - PBXB64 Command-Line Option

Startseite › -O0 - No Optimization

-O0 - No Optimization

Diese Option steuert den PBXB64-Kommandozeilenmodus -O0. Technischer Zweck: Runs no optimizations. This gives the fastest compile times and the most straightforward mapping between source code and generated assembly, which is ideal for debugging. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Optimization | Option: -O0

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -O0 sample.c -o sample.exe

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -O0. Technischer Zweck: Runs no optimizations. This gives the fastest compile times and the most straightforward mapping between source code and generated assembly, which is ideal for debugging. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: This is the default optimization level. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -O0 uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

At -O0 the optimization pipeline is empty. The IR and assembly closely mirror the frontend lowering, with all local variables kept in stack slots and no pass-driven transformations. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

PBXB64 optimization pipeline (-O0):
  <empty>

Hinweise

Use -O0 when compile speed matters more than runtime performance. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -O1 - Basic Optimization
  • --NoOpt - Disable Optimizations
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-O1 - Basic Optimization - PBXB64 Command-Line Option

Startseite › -O1 - Basic Optimization

-O1 - Basic Optimization

Diese Option steuert den PBXB64-Kommandozeilenmodus -O1. Technischer Zweck: Enables basic optimizations such as dead code elimination, constant folding, and simple algebraic simplifications. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Optimization | Option: -O1

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -O1 sample.c -o sample.exe

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -O1. Technischer Zweck: Enables basic optimizations such as dead code elimination, constant folding, and simple algebraic simplifications. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Not the default; requires explicit selection. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -O1 uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

The emitted IR and assembly are transformed by the -O1 pipeline. Expect fewer redundant instructions and folded constants compared to -O0. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 -O1 sample.c -o sample.exe. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

A good balance for builds that need modest performance improvements without long compile times. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -O0 - No Optimization
  • -O2 - Aggressive Optimization
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-O2 - Aggressive Optimization - PBXB64 Command-Line Option

Startseite › -O2 - Aggressive Optimization

-O2 - Aggressive Optimization

Diese Option steuert den PBXB64-Kommandozeilenmodus -O2. Technischer Zweck: Enables aggressive optimizations including inlining, loop unrolling, mem2reg, GVN, local CSE, strength reduction, and dead store elimination. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Optimization | Option: -O2

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -O2 sample.c -o sample.exe

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -O2. Technischer Zweck: Enables aggressive optimizations including inlining, loop unrolling, mem2reg, GVN, local CSE, strength reduction, and dead store elimination. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Not the default; requires explicit selection. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -O2 uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

The emitted IR and assembly are transformed by the full -O2 pipeline. Local variables are promoted to registers where possible, common subexpressions are eliminated, and small functions may be inlined. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

PBXB64 optimization pipeline (-O2):
  [01] function constant-fold
  [02] function cfg-simplify
  [03] function sccp-light
  [04] function sroa-light
  [05] function mem2reg
  [06] module   inline
  ...

Hinweise

Recommended for release builds where runtime performance is important. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -O3 - Maximum Optimization
  • --print-pipeline - Print Pipeline
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-O3 - Maximum Optimization - PBXB64 Command-Line Option

Startseite › -O3 - Maximum Optimization

-O3 - Maximum Optimization

Diese Option steuert den PBXB64-Kommandozeilenmodus -O3. Technischer Zweck: Enables the maximum optimization level. This may include more aggressive inlining and loop transformations and can increase binary size. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Optimization | Option: -O3

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -O3 sample.c -o sample.exe

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -O3. Technischer Zweck: Enables the maximum optimization level. This may include more aggressive inlining and loop transformations and can increase binary size. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Not the default; requires explicit selection. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -O3 uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

The emitted IR and assembly receive the strongest set of available transformations. The exact pass list is the same as -O2 in the current implementation, but individual passes may be run more aggressively. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 -O3 sample.c -o sample.exe. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

Benchmark your specific program; higher levels do not always produce faster code. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -O2 - Aggressive Optimization
  • --NoOpt - Disable Optimizations
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-S - Stop After Assembly - PBXB64 Command-Line Option

Startseite › -S - Stop After Assembly

-S - Stop After Assembly

Diese Option steuert den PBXB64-Kommandozeilenmodus -S. Technischer Zweck: Run the compiler through code generation, emit an x64 assembly listing, and stop before assembling or linking. Useful for inspecting the generated machine code in human-readable form. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Output Control | Option: -S

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -S sample.c -o sample.asm

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -S. Technischer Zweck: Run the compiler through code generation, emit an x64 assembly listing, and stop before assembling or linking. Useful for inspecting the generated machine code in human-readable form. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Without -S, assembly output is kept internal and the build continues to object/executable stages. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -S uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

PBXB64 assembly listings use Intel-style x64 syntax. Each file begins with section .text, followed by one function per .globl symbol. Functions contain labeled basic blocks and indented instruction lines: mnemonic op1, op2, .... Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

section .text

.globl add
add:
entry:
    push rbp
    mov rbp, rsp
    push rbx
    sub rsp, 24
    mov r10, [rbp-16]
    mov rbx, r10
    mov r10, [rbp-24]
    nop
    add rbx, r10
    mov rax, rbx
    add rsp, 24
    pop rbx
    pop rbp
    ret

Hinweise

The generated syntax is PBXB64 x64 MASM-like assembly. It can be saved to a file with -S -o file.asm. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --asm:<path> - Save Assembly to File
  • --emit-asm - Emit Assembly Dump
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-U - Undefine Macro - PBXB64 Command-Line Option

Startseite › -U - Undefine Macro

-U - Undefine Macro

Diese Option steuert den PBXB64-Kommandozeilenmodus -UNAME. Technischer Zweck: Undefines a previously defined preprocessor macro. Useful for canceling a macro defined earlier on the command line or in a pre-include. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Preprocessor | Option: -UNAME

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -DDEBUG -UNDEBUG sample.c

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -UNAME. Technischer Zweck: Undefines a previously defined preprocessor macro. Useful for canceling a macro defined earlier on the command line or in a pre-include. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: No macros are undefined by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -UNAME uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

No direct output; removes the macro from the preprocessor symbol table. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 -DDEBUG -UNDEBUG sample.c. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

The order of -D and -U options matters; later options override earlier ones. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -D - Define Macro
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-Wall - Enable All Warnings - PBXB64 Command-Line Option

Startseite › -Wall - Enable All Warnings

-Wall - Enable All Warnings

Diese Option steuert den PBXB64-Kommandozeilenmodus -Wall. Technischer Zweck: Enables the most common compiler warnings for C source files, including unused variables, suspicious conversions, and missing prototypes. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Diagnostics | Option: -Wall

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -Wall sample.c

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -Wall. Technischer Zweck: Enables the most common compiler warnings for C source files, including unused variables, suspicious conversions, and missing prototypes. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Warnings are not enabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -Wall uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

Warnings are emitted as PBXB64 diagnostics (file:line:column: severity: message). With -Werror they become errors. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 -Wall sample.c. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

Combine with -Wextra for additional diagnostics. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -Wextra - Extra Warnings
  • -Werror - Warnings as Errors
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-Werror - Warnings as Errors - PBXB64 Command-Line Option

Startseite › -Werror - Warnings as Errors

-Werror - Warnings as Errors

Diese Option steuert den PBXB64-Kommandozeilenmodus -Werror. Technischer Zweck: Treats every warning as a fatal error, causing the compiler to exit with a non-zero status if any warning is emitted. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Diagnostics | Option: -Werror

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -Wall -Werror sample.c

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -Werror. Technischer Zweck: Treats every warning as a fatal error, causing the compiler to exit with a non-zero status if any warning is emitted. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Disabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -Werror uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

No change to diagnostic text; only the severity is promoted to error and the exit code becomes non-zero. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 -Wall -Werror sample.c. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

Useful for enforcing a warning-clean codebase in CI builds. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -Wall - Enable All Warnings
  • -Wextra - Extra Warnings
  • Command-Line Options Reference

Fehlerpfad-Prüfung

Fehlerbehandlungsseiten sollen den normalen Pfad und den Fehlerpfad zeigen. Ein vollständiges Beispiel löst absichtlich einen bekannten Fehler aus, prüft den dokumentierten Fehlerwert, stellt wieder her oder beendet sauber und zeigt, dass spätere Anweisungen in der erwarteten Reihenfolge laufen.

Zustandsregeln

Dokumentieren Sie, welche Variablen, Handler oder Systemwerte durch die Operation geändert werden. Vermeiden Sie Beispiele, die einen Fehler durch ungeprüftes Weiterlaufen verdecken.

Migrationshinweise

Beim Portieren älteren PB-Codes sind Annahmen zu Zeilennummern, Handler-Gültigkeit, verschachtelten Prozeduren und Windows-API-Fehlern neu zu prüfen.

Back to command index


-Wextra - Extra Warnings - PBXB64 Command-Line Option

Startseite › -Wextra - Extra Warnings

-Wextra - Extra Warnings

Diese Option steuert den PBXB64-Kommandozeilenmodus -Wextra. Technischer Zweck: Enables extra warnings beyond those enabled by -Wall. These catch additional stylistic and potentially error-prone constructs. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Diagnostics | Option: -Wextra

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -Wall -Wextra sample.c

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -Wextra. Technischer Zweck: Enables extra warnings beyond those enabled by -Wall. These catch additional stylistic and potentially error-prone constructs. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Disabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -Wextra uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

Diagnostics are emitted in the same format as -Wall. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 -Wall -Wextra sample.c. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

See Also

  • -Wall - Enable All Warnings
  • -Werror - Warnings as Errors
  • Command-Line Options Reference

Back to command index


--asm:<path> - Save Assembly to File - PBXB64 Command-Line Option

Startseite › --asm:&lt;path&gt; - Save Assembly to File

--asm:<path> - Save Assembly to File

Diese Option steuert den PBXB64-Kommandozeilenmodus --asm:<path>. Technischer Zweck: Saves the generated assembly listing to the specified file path and stops after code generation. This gives you an explicit assembly output file without producing an object file or executable. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Output Control | Option: --asm:<path>

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 sample.c --asm:sample.asm

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --asm:<path>. Technischer Zweck: Saves the generated assembly listing to the specified file path and stops after code generation. This gives you an explicit assembly output file without producing an object file or executable. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: No assembly file is saved unless this option is used. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --asm:<path> uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

The saved file uses the same Intel-syntax x64 assembly format as -S: section .text, .globl directives, function and block labels, and indented instructions. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

section .text

.globl main
main:
entry:
    push rbp
    mov rbp, rsp
    ...

Hinweise

The path follows the colon immediately, with no space: --asm:file.asm. If --emit-mir is also active, the saved file contains MIR instead of assembly. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --asmout <path> - Save Assembly to File
  • -S - Stop After Assembly
  • --emit-asm - Emit Assembly Dump
  • --emit-mir - Emit MIR Dump
  • Command-Line Options Reference

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Back to command index


--asmout <path> - Save Assembly to File - PBXB64 Command-Line Option

Startseite › --asmout &lt;path&gt; - Save Assembly to File

--asmout <path> - Save Assembly to File

Diese Option steuert den PBXB64-Kommandozeilenmodus --asmout <path>. Technischer Zweck: Saves the generated assembly listing to the specified file path and stops after code generation. This is the space-separated long-form spelling of --asm:<path>. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Output Control | Option: --asmout <path>

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 sample.c --asmout sample.asm

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --asmout <path>. Technischer Zweck: Saves the generated assembly listing to the specified file path and stops after code generation. This is the space-separated long-form spelling of --asm:<path>. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: No assembly file is saved unless this option is used. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --asmout <path> uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

The saved file uses the same Intel-syntax x64 assembly format as -S: section .text, .globl directives, function and block labels, and indented instructions. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

section .text

.globl main
main:
entry:
    push rbp
    mov rbp, rsp
    ...

Hinweise

Unlike --asm:<path>, the output path is the next command-line argument. If --emit-mir is also active, the saved file contains MIR instead of assembly. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --asm:<path> - Save Assembly to File
  • -S - Stop After Assembly
  • --emit-asm - Emit Assembly Dump
  • --emit-mir - Emit MIR Dump
  • Command-Line Options Reference

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Back to command index


-c - Compile Only - PBXB64 Command-Line Option

Startseite › -c - Compile Only

-c - Compile Only

Diese Option steuert den PBXB64-Kommandozeilenmodus -c. Technischer Zweck: Compile the input source files into COFF object files and stop before linking. This is the standard way to produce individual .obj files that are later linked by a separate tool or by PBXB64. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Output Control | Option: -c

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -c module.c -o module.obj

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -c. Technischer Zweck: Compile the input source files into COFF object files and stop before linking. This is the standard way to produce individual .obj files that are later linked by a separate tool or by PBXB64. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Without -c, PBXB64 continues through the link stage and produces an executable. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -c uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

The emitted file is a standard AMD64 COFF object (.obj). It contains .text, .data, and .rdata sections together with symbol and relocation tables. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 -c module.c -o module.obj. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

When using -c, combine it with -o to name the object file; otherwise the default name is used. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -o - Output Path
  • --emit-obj - Emit Object File
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-con, --console - Force Console Subsystem - PBXB64 Command-Line Option

Startseite › -con, --console - Force Console Subsystem

-con, --console - Force Console Subsystem

Diese Option steuert den PBXB64-Kommandozeilenmodus -con, -console, --console. Technischer Zweck: Forces the Windows console subsystem value in the linked PE header. Use this for command-line utilities that should always get console process semantics. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Target & Linking | Option: -con, -console, --console

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -con sample.pb -o sample.exe

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -con, -console, --console. Technischer Zweck: Forces the Windows console subsystem value in the linked PE header. Use this for command-line utilities that should always get console process semantics. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: By default PBXB64 chooses GUI or console from the PB source metadata and detected console output use. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -con, -console, --console uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

The PE optional header Subsystem field is written as 3 (IMAGE_SUBSYSTEM_WINDOWS_CUI). Command-line subsystem options override source directives such as #GUI. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

PBXB64 -con tests/pb/test_subsystem_cli_console.pb -o con.exe

Hinweise

The short form requested for compatibility is -con; -console and --console are accepted aliases. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -gui, --gui - Force GUI Subsystem
  • --entry - Entry Symbol
  • cmd_compiler.html
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


--crt=<mode> - CRT Mode - PBXB64 Command-Line Option

Startseite › --crt=&lt;mode&gt; - CRT Mode

--crt=<mode> - CRT Mode

Diese Option steuert den PBXB64-Kommandozeilenmodus --crt=<mode>. Technischer Zweck: Selects the C runtime import policy. Accepted modes are auto (let the compiler choose), ucrt (Universal C Runtime), msvcrt (legacy MSVCRT), or none (no CRT imports). Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Target & Linking | Option: --crt=<mode>

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 --crt=ucrt sample.c -o sample.exe

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --crt=<mode>. Technischer Zweck: Selects the C runtime import policy. Accepted modes are auto (let the compiler choose), ucrt (Universal C Runtime), msvcrt (legacy MSVCRT), or none (no CRT imports). Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Default: auto. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --crt=<mode> uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

Affects the import table and undefined-symbol list emitted into the PE file. ucrt and msvcrt add the corresponding C runtime import library references. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 --crt=ucrt sample.c -o sample.exe. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

The UCRT is recommended for modern Windows targets. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --no-default-crt - No Default CRT
  • --target - Target Triple
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


--dump-ir - Dump IR - PBXB64 Command-Line Option

Startseite › --dump-ir - Dump IR

--dump-ir - Dump IR

Diese Option steuert den PBXB64-Kommandozeilenmodus --dump-ir. Technischer Zweck: Emits a sidecar IR dump without changing the normal compilation flow. The build continues through optimization, code generation, and linking as usual. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Output Control | Option: --dump-ir

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 --dump-ir sample.c -o sample.exe

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --dump-ir. Technischer Zweck: Emits a sidecar IR dump without changing the normal compilation flow. The build continues through optimization, code generation, and linking as usual. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Disabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --dump-ir uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

Identical to the --emit-ir IR text format: one function per function NAME header, blocks introduced by block NAME, and instructions as OPCODE [-> RESULT_ID] OPERANDS. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

function add
  block entry
    arg -> 1 0
    alloca -> 2
    store v2,0
    store v2,v1
    load -> 5 v2
    load -> 6 v4
    add -> 7 v5,v6
    ret v7
function main
  block entry
    alloca -> 1
    store v1,5
    load -> 4 v1
    cmp_gt -> 8 v7,10
    brcond v8,c_if_then_0,c_if_else_1

Hinweise

Use this when you need both the IR dump and the final executable in one invocation. The dump file is placed next to the source with extension .ir.txt. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --emit-ir - Emit IR
  • --dump-ir-before=<pass> - Dump IR Before Pass
  • --dump-ir-after=<pass> - Dump IR After Pass
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


--dump-ir-after=<pass> - Dump IR After Pass - PBXB64 Command-Line Option

Startseite › --dump-ir-after=&lt;pass&gt; - Dump IR After Pass
Hilfe zum PBXB64-Compiler

--dump-ir-after=<pass> - Dump IR After Pass

Diese Option steuert den PBXB64-Kommandozeilenmodus --dump-ir-after=<pass>. Technischer Zweck: Requests an IR snapshot immediately after a named optimization pass has completed. Compare it with --dump-ir-before=<pass> to isolate the exact effect of one optimizer pass. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Output Control | Option: --dump-ir-after=<pass>

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -O2 --dump-ir-after=instcombine-light sample.c -o sample.exe

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --dump-ir-after=<pass>. Technischer Zweck: Requests an IR snapshot immediately after a named optimization pass has completed. Compare it with --dump-ir-before=<pass> to isolate the exact effect of one optimizer pass. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: No per-pass IR dump is produced unless this option names a pass. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --dump-ir-after=<pass> uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

The pass name is matched against the optimizer pass identifiers printed by --print-pipeline. The resulting dump is textual IR with function headers, block labels, and line-oriented instructions. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

PBXB64 -O2 --dump-ir-before=instcombine-light sample.c -o sample.exe
PBXB64 -O2 --dump-ir-after=instcombine-light sample.c -o sample.exe

Hinweise

This option does not stop compilation by itself. The normal compile/link pipeline continues after the diagnostic dump is produced. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --dump-ir-before=<pass> - Dump IR Before Pass
  • --dump-ir - Dump IR
  • --print-pipeline - Print Pipeline
  • --verify-after-each-pass - Verify After Each Pass
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


--dump-ir-before=<pass> - Dump IR Before Pass - PBXB64 Command-Line Option

Startseite › --dump-ir-before=&lt;pass&gt; - Dump IR Before Pass
Hilfe zum PBXB64-Compiler

--dump-ir-before=<pass> - Dump IR Before Pass

Diese Option steuert den PBXB64-Kommandozeilenmodus --dump-ir-before=<pass>. Technischer Zweck: Requests an IR snapshot immediately before a named optimization pass executes. It is a focused debugging option for finding which pass introduces or removes a specific IR shape. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Output Control | Option: --dump-ir-before=<pass>

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -O2 --dump-ir-before=gvn-conservative sample.c -o sample.exe

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --dump-ir-before=<pass>. Technischer Zweck: Requests an IR snapshot immediately before a named optimization pass executes. It is a focused debugging option for finding which pass introduces or removes a specific IR shape. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: No per-pass IR dump is produced unless this option names a pass. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --dump-ir-before=<pass> uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

The pass name is the textual pass identifier printed by --print-pipeline, for example constant-fold, cfg-simplify, sroa-light, gvn-conservative, or instcombine-light. The dump uses the same textual IR format as --emit-ir. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

PBXB64 -O2 --print-pipeline
PBXB64 -O2 --dump-ir-before=gvn-conservative sample.c -o sample.exe

Hinweise

Use --print-pipeline with the same optimization level first, then copy the pass name exactly. If the named pass is not scheduled for the selected -O level, no matching per-pass snapshot is emitted. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --dump-ir-after=<pass> - Dump IR After Pass
  • --dump-ir - Dump IR
  • --print-pipeline - Print Pipeline
  • -O2 - Aggressive Optimization
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


--dump-tokens - Dump Tokens - PBXB64 Command-Line Option

Startseite › --dump-tokens - Dump Tokens

--dump-tokens - Dump Tokens

Diese Option steuert den PBXB64-Kommandozeilenmodus --dump-tokens. Technischer Zweck: Prints the lexer token stream to stdout. Each token is shown with its kind and source position, which is helpful for diagnosing lexer-level issues. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Output Control | Option: --dump-tokens

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 --dump-tokens sample.c

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --dump-tokens. Technischer Zweck: Prints the lexer token stream to stdout. Each token is shown with its kind and source position, which is helpful for diagnosing lexer-level issues. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Token dumping is disabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --dump-tokens uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

When implemented, token dumps will list tokens in source order, typically as KIND VALUE pairs (e.g. TOKEN_KW_INT "int", TOKEN_IDENTIFIER "main", TOKEN_NUMBER 42). Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 --dump-tokens sample.c. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

Current limitation: This release parses the option but does not yet emit token output. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --emit-ast, --dump-ast - Emit AST Dump
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


--emit-asm - Emit Assembly Dump - PBXB64 Command-Line Option

Startseite › --emit-asm - Emit Assembly Dump

--emit-asm - Emit Assembly Dump

Diese Option steuert den PBXB64-Kommandozeilenmodus --emit-asm. Technischer Zweck: Emits the generated assembly listing and stops after code generation. Similar to -S, but the output is written to a file rather than stdout. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Output Control | Option: --emit-asm

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 --emit-asm sample.c

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --emit-asm. Technischer Zweck: Emits the generated assembly listing and stops after code generation. Similar to -S, but the output is written to a file rather than stdout. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Disabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --emit-asm uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

The assembly file starts with section .text. Each function is exported with .globl NAME and labeled NAME:. Basic blocks are labeled (e.g. entry:, c_if_then_0:). Instructions are indented and use Intel syntax: mnemonic destination, source for two-operand forms. Floating-point SSE instructions are selected by operand size (movss/movsd, addss/addsd, etc.). Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

section .text

.globl add
add:
entry:
    push rbp
    mov rbp, rsp
    push rbx
    sub rsp, 24
    mov r10, [rbp-16]
    mov rbx, r10
    mov r10, [rbp-24]
    nop
    add rbx, r10
    mov rax, rbx
    add rsp, 24
    pop rbx
    pop rbp
    ret

Hinweise

For large programs the output can be very long. Combine with --emit-mir to produce a machine-IR dump instead of textual assembly. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -S - Stop After Assembly
  • --asm:<path> - Save Assembly to File
  • --emit-mir - Emit MIR Dump
  • Command-Line Options Reference

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Back to command index


--emit-ast, --dump-ast - Emit AST Dump - PBXB64 Command-Line Option

Startseite › --emit-ast, --dump-ast - Emit AST Dump

--emit-ast, --dump-ast - Emit AST Dump

Diese Option steuert den PBXB64-Kommandozeilenmodus --emit-ast, --dump-ast. Technischer Zweck: Prints the compiler's Abstract Syntax Tree (AST) to stdout after parsing. The AST shows the structured representation of declarations, statements, and expressions before intermediate code generation. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Output Control | Option: --emit-ast, --dump-ast

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 --emit-ast hello.c

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --emit-ast, --dump-ast. Technischer Zweck: Prints the compiler's Abstract Syntax Tree (AST) to stdout after parsing. The AST shows the structured representation of declarations, statements, and expressions before intermediate code generation. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: AST dumping is disabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --emit-ast, --dump-ast uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

When available, the AST dump writes one line per top-level declaration: decl NAME kind=N, where NAME is the declaration name and N is the numeric AstDeclKind enumerator. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 --emit-ast hello.c. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

Current limitation: In this release the native frontends (C, BASIC, B64, PILOT) report "AST dump is not available for native X inputs". Use the IR dump options for inspectable intermediate output. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --emit-ir - Emit IR
  • --dump-ir - Dump IR
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


--emit-ir - Emit IR - PBXB64 Command-Line Option

Startseite › --emit-ir - Emit IR

--emit-ir - Emit IR

Diese Option steuert den PBXB64-Kommandozeilenmodus --emit-ir. Technischer Zweck: Emits the intermediate representation (IR) text and stops compilation after the frontend / IR construction stage. This is useful for debugging how source constructs are lowered to IR. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Output Control | Option: --emit-ir

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 --emit-ir sample.c

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --emit-ir. Technischer Zweck: Emits the intermediate representation (IR) text and stops compilation after the frontend / IR construction stage. This is useful for debugging how source constructs are lowered to IR. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: IR emission is disabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --emit-ir uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

The IR dump is textual and line-oriented:

  • function NAME begins a function.
  • block NAME begins a basic block.
  • Instructions are indented with four spaces: OPCODE [-> RESULT_ID] OPERAND1,OPERAND2,....
  • Operands use vN for value IDs, integer literals for constants, block names for branches, and symbol names for calls.
  • Common opcodes: arg, alloca, load, store, add, sub, mul, div, rem, cmp_eq/ne/lt/le/gt/ge, br, brcond, ret, call, gep, cast, phi.
Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

function add
  block entry
    arg -> 1 0
    alloca -> 2
    store v2,0
    store v2,v1
    arg -> 3 1
    alloca -> 4
    store v4,0
    store v4,v3
    load -> 5 v2
    load -> 6 v4
    add -> 7 v5,v6
    ret v7
function main
  block entry
    alloca -> 1
    store v1,0
    store v1,5
    load -> 4 v1
    cmp_gt -> 8 v7,10
    brcond v8,c_if_then_0,c_if_else_1

Hinweise

Unlike --dump-ir, this option changes the compile stop point to the IR stage. Output is written to <source>.ir.txt (or the path chosen by -o). Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --dump-ir - Dump IR
  • --stop-after=<stage> - Stop After Stage
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


--emit-map - Emit Map File - PBXB64 Command-Line Option

Startseite › --emit-map - Emit Map File

--emit-map - Emit Map File

Diese Option steuert den PBXB64-Kommandozeilenmodus --emit-map. Technischer Zweck: Requests that the linker produce a map file alongside the executable. The map file contains symbol addresses and section layout information. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Output Control | Option: --emit-map

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 --emit-map sample.c -o sample.exe

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --emit-map. Technischer Zweck: Requests that the linker produce a map file alongside the executable. The map file contains symbol addresses and section layout information. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Map-file emission is disabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --emit-map uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

When generated, the map file lists sections with their virtual addresses and lengths, followed by public symbols sorted by address. The exact format matches the PBXB64 linker's internal map writer. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 --emit-map sample.c -o sample.exe. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

The map file is placed next to the output executable with a .map extension. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -o - Output Path
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


--emit-mir - Emit MIR Dump - PBXB64 Command-Line Option

Startseite › --emit-mir - Emit MIR Dump

--emit-mir - Emit MIR Dump

Diese Option steuert den PBXB64-Kommandozeilenmodus --emit-mir. Technischer Zweck: Emits the machine intermediate representation (MIR) instead of textual assembly when combined with an assembly-producing option such as --emit-asm or -S. MIR is the target-specific representation used for register allocation and instruction selection. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Output Control | Option: --emit-mir

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 --emit-mir --emit-asm sample.c

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --emit-mir. Technischer Zweck: Emits the machine intermediate representation (MIR) instead of textual assembly when combined with an assembly-producing option such as --emit-asm or -S. MIR is the target-specific representation used for register allocation and instruction selection. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Disabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --emit-mir uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

MIR output has the same structural layout as assembly (functions and labeled blocks) but uses pre-register-allocation virtual operands and pseudo-instructions such as load / store for stack accesses and jcc / setcc for conditionals. Operands can be physical registers (rax, rbx, ...), virtual registers (%vN), stack slots ([rbp-N]), immediates, or labels. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

function add
  entry:
    push rbp
    mov rbp, rsp
    push rbx
    sub rsp, 24
    store [rbp-16], rbx
    store [rbp-16], rcx
    store [rbp-24], rbx
    store [rbp-24], rdx
    load r10, [rbp-16]
    mov rbx, r10
    load r10, [rbp-24]
    nop
    add rbx, r10
    mov rax, rbx
    add rsp, 24
    pop rbx
    pop rbp
    ret

Hinweise

MIR output is primarily useful for backend debugging and performance analysis. It is only produced when --emit-mir is combined with --emit-asm or -S. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --emit-ir - Emit IR
  • --emit-asm - Emit Assembly Dump
  • -S - Stop After Assembly
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


--emit-obj - Emit Object File - PBXB64 Command-Line Option

Startseite › --emit-obj - Emit Object File

--emit-obj - Emit Object File

Diese Option steuert den PBXB64-Kommandozeilenmodus --emit-obj. Technischer Zweck: Forces object-file emission. This is an alias for -c and produces a COFF .obj file without linking. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Output Control | Option: --emit-obj

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 --emit-obj module.c -o module.obj

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --emit-obj. Technischer Zweck: Forces object-file emission. This is an alias for -c and produces a COFF .obj file without linking. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Object emission only occurs when requested. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --emit-obj uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

Produces a 64-bit COFF object file. The file layout follows the standard PE/COFF specification: file header, optional section headers, raw section data (.text, .data, .rdata), symbol table, string table, and relocation entries. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 --emit-obj module.c -o module.obj. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

Use whichever spelling you prefer; both -c and --emit-obj are accepted. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -c - Compile Only
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


--entry - Entry Symbol - PBXB64 Command-Line Option

Startseite › --entry - Entry Symbol

--entry - Entry Symbol

Diese Option steuert den PBXB64-Kommandozeilenmodus --entry <symbol>. Technischer Zweck: Overrides the default program entry point symbol used by the linker. For C programs the default is main; for other frontends the compiler supplies its own runtime entry point. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Target & Linking | Option: --entry <symbol>

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 --entry MyStart sample.c -o sample.exe

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --entry <symbol>. Technischer Zweck: Overrides the default program entry point symbol used by the linker. For C programs the default is main; for other frontends the compiler supplies its own runtime entry point. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: The default entry symbol is determined by the frontend and target. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --entry <symbol> uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

Affects only the linker symbol resolution. The emitted executable will use the specified symbol as the entry point in the PE optional header. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 --entry MyStart sample.c -o sample.exe. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

The specified symbol must be defined in one of the linked object files. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --no-default-crt - No Default CRT
  • --target - Target Triple
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-ffreestanding - Freestanding Mode - PBXB64 Command-Line Option

Startseite › -ffreestanding - Freestanding Mode

-ffreestanding - Freestanding Mode

Diese Option steuert den PBXB64-Kommandozeilenmodus -ffreestanding. Technischer Zweck: Compiles in freestanding mode, where the full C standard library may not be available. Implies that main is not necessarily the program entry point. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Diagnostics | Option: -ffreestanding

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -ffreestanding sample.c -o sample.exe

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -ffreestanding. Technischer Zweck: Compiles in freestanding mode, where the full C standard library may not be available. Implies that main is not necessarily the program entry point. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Disabled by default; hosted mode is the default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -ffreestanding uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

Affects preprocessor predefined macros and linker assumptions. No direct change to emitted file format. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 -ffreestanding sample.c -o sample.exe. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

Often used together with --no-default-crt for kernel or bootloader code. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -fhosted - Hosted Mode
  • --no-default-crt - No Default CRT
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-fhosted - Hosted Mode - PBXB64 Command-Line Option

Startseite › -fhosted - Hosted Mode

-fhosted - Hosted Mode

Diese Option steuert den PBXB64-Kommandozeilenmodus -fhosted. Technischer Zweck: Explicitly selects hosted mode, confirming that the program will run under an operating system with a full C runtime. This is the normal mode for application development. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Diagnostics | Option: -fhosted

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -fhosted sample.c -o sample.exe

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -fhosted. Technischer Zweck: Explicitly selects hosted mode, confirming that the program will run under an operating system with a full C runtime. This is the normal mode for application development. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Hosted mode is the default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -fhosted uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

Affects preprocessor predefined macros and linker assumptions. No direct change to emitted file format. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 -fhosted sample.c -o sample.exe. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

This option can be used to override an earlier -ffreestanding flag. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -ffreestanding - Freestanding Mode
  • --crt=<mode> - CRT Mode
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-fno-builtin - Disable Builtins - PBXB64 Command-Line Option

Startseite › -fno-builtin - Disable Builtins

-fno-builtin - Disable Builtins

Diese Option steuert den PBXB64-Kommandozeilenmodus -fno-builtin. Technischer Zweck: Disables compiler builtin function optimizations. Calls to functions such as strlen or memcpy are not replaced with inline sequences or special handling. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Diagnostics | Option: -fno-builtin

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -fno-builtin sample.c

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -fno-builtin. Technischer Zweck: Disables compiler builtin function optimizations. Calls to functions such as strlen or memcpy are not replaced with inline sequences or special handling. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Builtins are enabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -fno-builtin uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

Affects IR generation. With builtins disabled, calls remain as ordinary function calls in the emitted IR/assembly. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 -fno-builtin sample.c. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

Use this when you provide your own definitions of standard library functions. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -ffreestanding - Freestanding Mode
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-g, --debug - Debug Information - PBXB64 Command-Line Option

Startseite › -g, --debug - Debug Information

-g, --debug - Debug Information

Diese Option steuert den PBXB64-Kommandozeilenmodus -g, --debug. Technischer Zweck: Requests emission of debug information in the output object/executable. This enables source-level debugging in compatible debuggers. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Verification | Option: -g, --debug

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -g sample.c -o sample.exe

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -g, --debug. Technischer Zweck: Requests emission of debug information in the output object/executable. This enables source-level debugging in compatible debuggers. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Debug information is disabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -g, --debug uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

Debug information is emitted in the PBXB64 internal SDBG format and stored in the generated object/executable. It maps machine-code addresses back to source file names and line numbers. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 -g sample.c -o sample.exe. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

The amount and format of debug information depends on the backend DWARF/CodeView support in the current build. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -o - Output Path
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-gui, --gui - Force GUI Subsystem - PBXB64 Command-Line Option

Startseite › -gui, --gui - Force GUI Subsystem

-gui, --gui - Force GUI Subsystem

Diese Option steuert den PBXB64-Kommandozeilenmodus -gui, --gui. Technischer Zweck: Forces the Windows GUI subsystem value in the linked PE header. Use this when a program should behave like a PB/Win application even if the compiler auto-detection would otherwise choose console. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Target & Linking | Option: -gui, --gui

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -gui sample.pb -o sample.exe

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -gui, --gui. Technischer Zweck: Forces the Windows GUI subsystem value in the linked PE header. Use this when a program should behave like a PB/Win application even if the compiler auto-detection would otherwise choose console. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: By default PBXB64 chooses GUI or console from the PB source metadata and detected console output use. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -gui, --gui uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

The PE optional header Subsystem field is written as 2 (IMAGE_SUBSYSTEM_WINDOWS_GUI). Command-line subsystem options override source directives such as #CONSOLE. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

PBXB64 -gui tests/pb/test_subsystem_cli_gui.pb -o gui.exe

Hinweise

This option affects linked PE output only. It does not remove explicit runtime console output calls from the program. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -con, --console - Force Console Subsystem
  • --entry - Entry Symbol
  • cmd_compiler.html
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-h, --help - Show Help - PBXB64 Command-Line Option

Startseite › -h, --help - Show Help

-h, --help - Show Help

Diese Option steuert den PBXB64-Kommandozeilenmodus -h, --help. Technischer Zweck: Prints a concise summary of all command-line options and exits. No input files are required. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Information | Option: -h, --help

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 --help

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -h, --help. Technischer Zweck: Prints a concise summary of all command-line options and exits. No input files are required. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Disabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -h, --help uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

The help text is written to stdout. It lists usage, all flags, and a brief one-line description per option. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Usage: PBXB64 [options] <input files>

Options:
  -o <file>          Set output file path
  -c                 Compile only (produce object file)
  -S                 Stop after code generation (produce assembly)
  --emit-ir          Stop after frontend and emit IR text
  --dump-ir          Emit sidecar IR dump and continue
  --emit-asm         Emit assembly dump
  ...

Hinweise

For more detail on a specific option, see its dedicated help page. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --version - Print Version
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-isystem - System Include Path - PBXB64 Command-Line Option

Startseite › -isystem - System Include Path

-isystem - System Include Path

Diese Option steuert den PBXB64-Kommandozeilenmodus -isystem <path>. Technischer Zweck: Adds a system include search path. Headers found through -isystem have warnings suppressed, matching GCC/Clang behavior. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Preprocessor | Option: -isystem <path>

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -isystem./sdk sample.c

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -isystem <path>. Technischer Zweck: Adds a system include search path. Headers found through -isystem have warnings suppressed, matching GCC/Clang behavior. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: No extra system paths by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -isystem <path> uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

No direct output; behaves like -I for header lookup but marks the path as system for diagnostic purposes. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 -isystem./sdk sample.c. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

Use this for third-party SDK headers that you do not want to lint. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -I - Include Path
  • -Wall - Enable All Warnings
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


--no-default-crt - No Default CRT - PBXB64 Command-Line Option

Startseite › --no-default-crt - No Default CRT

--no-default-crt - No Default CRT

Diese Option steuert den PBXB64-Kommandozeilenmodus --no-default-crt. Technischer Zweck: Prevents the compiler from automatically linking the default C runtime imports. Use this for freestanding programs or when you provide your own runtime imports. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Target & Linking | Option: --no-default-crt

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 --no-default-crt sample.c -o sample.exe

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --no-default-crt. Technischer Zweck: Prevents the compiler from automatically linking the default C runtime imports. Use this for freestanding programs or when you provide your own runtime imports. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Default CRT linking is enabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --no-default-crt uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

Affects linker symbol tables. With this flag, no automatic __imp_ symbols for UCRT/MSVCRT are added to the import table. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 --no-default-crt sample.c -o sample.exe. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

This is equivalent to --crt=none. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --crt=<mode> - CRT Mode
  • -ffreestanding - Freestanding Mode
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-o - Output Path - PBXB64 Command-Line Option

Startseite › -o - Output Path

-o - Output Path

Diese Option steuert den PBXB64-Kommandozeilenmodus -o <file>. Technischer Zweck: Sets the path and name of the output file produced by the compiler. The exact file type depends on the stop-after stage: executable (.exe) for a full build, object file (.obj) with -c, or assembly listing (.asm) with -S. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Output Control | Option: -o <file>

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 hello.c -o hello.exe

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -o <file>. Technischer Zweck: Sets the path and name of the output file produced by the compiler. The exact file type depends on the stop-after stage: executable (.exe) for a full build, object file (.obj) with -c, or assembly listing (.asm) with -S. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: If -o is omitted, the default output name is a.exe for a full link and a.asm / a.obj for early-stop modes. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -o <file> uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 hello.c -o hello.exe. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

The output directory must already exist. Use forward slashes or escaped backslashes in paths. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -c - Compile Only
  • -S - Stop After Assembly
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-pedantic - Pedantic Mode - PBXB64 Command-Line Option

Startseite › -pedantic - Pedantic Mode

-pedantic - Pedantic Mode

Diese Option steuert den PBXB64-Kommandozeilenmodus -pedantic. Technischer Zweck: Enables strict standard-compliance warnings. Issues diagnostics for language extensions and constructs that are not part of the selected C standard. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Diagnostics | Option: -pedantic

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -std=c17 -pedantic sample.c

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -pedantic. Technischer Zweck: Enables strict standard-compliance warnings. Issues diagnostics for language extensions and constructs that are not part of the selected C standard. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Disabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -pedantic uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

Diagnostics are emitted in the standard PBXB64 format (file:line:column: warning: message). Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 -std=c17 -pedantic sample.c. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

Does not disable extensions; it only warns about their use. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -std= - C Standard Mode
  • -Wall - Enable All Warnings
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


--print-pipeline - Print Pipeline - PBXB64 Command-Line Option

Startseite › --print-pipeline - Print Pipeline

--print-pipeline - Print Pipeline

Diese Option steuert den PBXB64-Kommandozeilenmodus --print-pipeline. Technischer Zweck: Displays the enabled middle-end optimization passes for the current optimization level and exits. No input files are required. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Pipeline Control | Option: --print-pipeline

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -O2 --print-pipeline

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --print-pipeline. Technischer Zweck: Displays the enabled middle-end optimization passes for the current optimization level and exits. No input files are required. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Disabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --print-pipeline uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

Output format: PBXB64 optimization pipeline (-OX): followed by one pass per line: [NN] kind name, where kind is either module or function, and name is the pass identifier. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

PBXB64 optimization pipeline (-O2):
  [01] function constant-fold
  [02] function cfg-simplify
  [03] function sccp-light
  [04] function sroa-light
  [05] function mem2reg
  [06] module   inline
  [07] function critical-edge-split
  [08] function gvn-conservative
  [09] function instcombine-light
  [10] function sccp-light
  [11] function local-cse
  [12] function strength-reduction
  [13] function dead-store-elimination-light
  [14] function dead-code-elimination
  [15] function cfg-simplify-final
  [16] function critical-edge-split-final

Hinweise

The exact pass list varies by -O level; -O0 prints an empty pipeline. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -O0 - No Optimization
  • -O2 - Aggressive Optimization
  • --trace-passes - Trace Passes
  • Command-Line Options Reference

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.

Back to command index


--stats - Print Statistics - PBXB64 Command-Line Option

Startseite › --stats - Print Statistics

--stats - Print Statistics

Diese Option steuert den PBXB64-Kommandozeilenmodus --stats. Technischer Zweck: Prints compact IR and MIR statistics after compilation, including function, block, instruction, and frame-object counts at different pipeline points. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Verification | Option: --stats

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 --stats sample.c -c -o sample.obj

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --stats. Technischer Zweck: Prints compact IR and MIR statistics after compilation, including function, block, instruction, and frame-object counts at different pipeline points. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Disabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --stats uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

Each line has the form IR stats PHASE functions=N blocks=M instructions=K (IR phases) or MIR stats codegen functions=N blocks=M instructions=K frame_objects=F (codegen phase). Phases include frontend, optimized, and codegen. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

  IR stats frontend     functions=2 blocks=5 instructions=34
  IR stats optimized    functions=2 blocks=5 instructions=34
  MIR stats codegen     functions=2 blocks=5 instructions=78 frame_objects=5

Hinweise

Useful for comparing optimization effectiveness across different -O levels. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --time-stages - Time Stages
  • -O0 - No Optimization
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-std= - C Standard Mode - PBXB64 Command-Line Option

Startseite › -std= - C Standard Mode

-std= - C Standard Mode

Diese Option steuert den PBXB64-Kommandozeilenmodus -std=<mode>. Technischer Zweck: Selects the C language standard mode. Supported modes include c89/c90, c99, c11, c17/c18, and the corresponding GNU dialects. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Preprocessor | Option: -std=<mode>

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -std=c17 sample.c

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -std=<mode>. Technischer Zweck: Selects the C language standard mode. Supported modes include c89/c90, c99, c11, c17/c18, and the corresponding GNU dialects. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Default: c17. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -std=<mode> uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

Affects preprocessor predefined macros (e.g. __STDC_VERSION__) and parser acceptance of language features. Does not change the format of emitted object/assembly files. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 -std=c17 sample.c. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

An unsupported mode produces an error listing the valid choices. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -pedantic - Pedantic Mode
  • -Wall - Enable All Warnings
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


--stop-after=<stage> - Stop After Stage - PBXB64 Command-Line Option

Startseite › --stop-after=&lt;stage&gt; - Stop After Stage

--stop-after=<stage> - Stop After Stage

Diese Option steuert den PBXB64-Kommandozeilenmodus --stop-after=<stage>. Technischer Zweck: Stops compilation after a specific pipeline stage. Accepted stage names are ir / frontend, opt / optimizer, codegen / asm, object / assemble, or link. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Pipeline Control | Option: --stop-after=<stage>

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 --stop-after=opt sample.c -o sample.opt.ir.txt

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --stop-after=<stage>. Technischer Zweck: Stops compilation after a specific pipeline stage. Accepted stage names are ir / frontend, opt / optimizer, codegen / asm, object / assemble, or link. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: The default stop stage is link, producing an executable. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --stop-after=<stage> uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

The intermediate file emitted at each stage uses the same textual format as the dedicated dump option for that stage: IR text for ir and opt, assembly/MIR for codegen, and COFF object for object. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

function add
  block entry
    arg -> 1 0
    alloca -> 2
    store v2,0
    store v2,v1
    ...

Hinweise

Use --stop-after=codegen together with -o file.asm to capture assembly output. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • -S - Stop After Assembly
  • -c - Compile Only
  • --emit-ir - Emit IR
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-fsyntax-only, --syntax-only - Syntax Check Only - PBXB64 Command-Line Option

Startseite › -fsyntax-only, --syntax-only - Syntax Check Only
Hilfe zum PBXB64-Compiler

-fsyntax-only, --syntax-only - Syntax Check Only

Diese Option steuert den PBXB64-Kommandozeilenmodus -fsyntax-only, --syntax-only. Technischer Zweck: Parse and type-check the source, then stop before any code generation. This is the fastest way to verify that source code is valid without producing output files. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Pipeline Control | Option: -fsyntax-only, --syntax-only

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -fsyntax-only sample.c

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -fsyntax-only, --syntax-only. Technischer Zweck: Parse and type-check the source, then stop before any code generation. This is the fastest way to verify that source code is valid without producing output files. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Disabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -fsyntax-only, --syntax-only uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

No intermediate or object output is produced. Success is indicated by exit code 0 with no diagnostics on stderr/stdout. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 -fsyntax-only sample.c. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

Diagnostics are still emitted, so this mode is useful for CI linting. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --stop-after=<stage> - Stop After Stage
  • -Wall - Enable All Warnings
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


--target - Target Triple - PBXB64 Command-Line Option

Startseite › --target - Target Triple

--target - Target Triple

Diese Option steuert den PBXB64-Kommandozeilenmodus --target <triple>. Technischer Zweck: Sets the target triple for cross-compilation or for selecting a specific ABI. The default is the native Windows x64 MinGW target. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Target & Linking | Option: --target <triple>

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 --target x86_64-w64-windows-gnu sample.c -o sample.exe

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --target <triple>. Technischer Zweck: Sets the target triple for cross-compilation or for selecting a specific ABI. The default is the native Windows x64 MinGW target. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Default: x86_64-w64-windows-gnu. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --target <triple> uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

The target triple is parsed into architecture, vendor, OS, and environment components. It controls ABI selection (e.g. Win64 calling convention), object file format (COFF/PE32+), and runtime assumptions. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 --target x86_64-w64-windows-gnu sample.c -o sample.exe. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

Only Windows x64 targets are fully supported in this release. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --crt=<mode> - CRT Mode
  • --entry - Entry Symbol
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


--time-stages - Time Stages - PBXB64 Command-Line Option

Startseite › --time-stages - Time Stages

--time-stages - Time Stages

Diese Option steuert den PBXB64-Kommandozeilenmodus --time-stages. Technischer Zweck: Prints a timing summary for the major compilation stages (frontend, optimizer, codegen, assembler, linker) at the end of compilation. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Verification | Option: --time-stages

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 --time-stages sample.c -c -o sample.obj

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --time-stages. Technischer Zweck: Prints a timing summary for the major compilation stages (frontend, optimizer, codegen, assembler, linker) at the end of compilation. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Disabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --time-stages uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

The output is printed to stderr at the end of compilation. The final line shows the total wall-clock time in milliseconds: PBXB64 total compile time: X.X ms. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

  PBXB64 total compile time: 4.0 ms

Hinweise

Per-stage timings are shown in addition to the total compile time. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --stats - Print Statistics
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


--trace-passes - Trace Passes - PBXB64 Command-Line Option

Startseite › --trace-passes - Trace Passes

--trace-passes - Trace Passes

Diese Option steuert den PBXB64-Kommandozeilenmodus --trace-passes. Technischer Zweck: Prints the name of each middle-end optimization pass to stderr as it executes. Helps identify which passes run and in what order. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Verification | Option: --trace-passes

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 --trace-passes -O2 sample.c

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --trace-passes. Technischer Zweck: Prints the name of each middle-end optimization pass to stderr as it executes. Helps identify which passes run and in what order. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Disabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --trace-passes uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

Each pass is printed as a single line to stderr, using the same pass name displayed by --print-pipeline. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 --trace-passes -O2 sample.c. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

Use together with --verify-after-each-pass to correlate pass names with verification failures. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --print-pipeline - Print Pipeline
  • --verify-after-each-pass - Verify After Each Pass
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


-v, --verbose - Verbose Output - PBXB64 Command-Line Option

Startseite › -v, --verbose - Verbose Output

-v, --verbose - Verbose Output

Diese Option steuert den PBXB64-Kommandozeilenmodus -v, --verbose. Technischer Zweck: Prints the name of each input file as it is compiled and shows the active compilation stages and paths. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Information | Option: -v, --verbose

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 -v sample.c -c -o sample.obj

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus -v, --verbose. Technischer Zweck: Prints the name of each input file as it is compiled and shows the active compilation stages and paths. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Disabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne -v, --verbose uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

Verbose messages are written to stderr. The primary message is compiling PATH, one line per source file. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

compiling C:/Users/.../Temp/sample.c

Hinweise

Combine with --time-stages for detailed build diagnostics. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --time-stages - Time Stages
  • --stats - Print Statistics
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


--verify-after-each-pass - Verify After Each Pass - PBXB64 Command-Line Option

Startseite › --verify-after-each-pass - Verify After Each Pass
Hilfe zum PBXB64-Compiler

--verify-after-each-pass - Verify After Each Pass

Diese Option steuert den PBXB64-Kommandozeilenmodus --verify-after-each-pass. Technischer Zweck: Enables IR verification after every individual optimizer pass. This is stricter than --verify-ir and is useful for tracking down which pass introduces an invalid transformation. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Verification | Option: --verify-after-each-pass

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 --verify-after-each-pass -O2 sample.c

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --verify-after-each-pass. Technischer Zweck: Enables IR verification after every individual optimizer pass. This is stricter than --verify-ir and is useful for tracking down which pass introduces an invalid transformation. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Disabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --verify-after-each-pass uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

No output on success. Verification failures stop compilation and report the failing invariant. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 --verify-after-each-pass -O2 sample.c. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

This implies --verify-ir and may slow down compilation at higher optimization levels. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --verify-ir - Verify IR
  • --trace-passes - Trace Passes
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


--verify-ir - Verify IR - PBXB64 Command-Line Option

Startseite › --verify-ir - Verify IR

--verify-ir - Verify IR

Diese Option steuert den PBXB64-Kommandozeilenmodus --verify-ir. Technischer Zweck: Runs the IR verifier after frontend construction and after optimization. The verifier checks structural invariants such as dominated uses, valid block terminators, and type consistency. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Verification | Option: --verify-ir

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 --verify-ir sample.c

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --verify-ir. Technischer Zweck: Runs the IR verifier after frontend construction and after optimization. The verifier checks structural invariants such as dominated uses, valid block terminators, and type consistency. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Disabled by default in release builds. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --verify-ir uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

No output is produced on success. Failures are reported as compiler diagnostics and cause a non-zero exit code. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 --verify-ir sample.c. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

If verification fails, the compiler aborts with a diagnostic message. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --verify-after-each-pass - Verify After Each Pass
  • --verify-mir, --verify-machine - Verify MIR
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


--verify-mir, --verify-machine - Verify MIR - PBXB64 Command-Line Option

Startseite › --verify-mir, --verify-machine - Verify MIR

--verify-mir, --verify-machine - Verify MIR

Diese Option steuert den PBXB64-Kommandozeilenmodus --verify-mir, --verify-machine. Technischer Zweck: Runs the verifier on the machine IR after backend lowering. This catches target-specific issues such as invalid register operands or frame-object references. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Verification | Option: --verify-mir, --verify-machine

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 --verify-mir sample.c

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --verify-mir, --verify-machine. Technischer Zweck: Runs the verifier on the machine IR after backend lowering. This catches target-specific issues such as invalid register operands or frame-object references. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Disabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --verify-mir, --verify-machine uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

No output is produced on success. Failures are reported as compiler diagnostics and cause a non-zero exit code. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

Verifizieren Sie diese Option mit PBXB64 --verify-mir sample.c. Erfassen Sie stdout, stderr, Exit-Code und erzeugte Dateien; Optionen ohne Dateiausgabe gelten als erfolgreich, wenn der dokumentierte Exit-Code und die dokumentierte Ausgabeform eintreten.

Hinweise

Both option spellings are accepted and behave identically. Bei mehreren Optionen ist die Reihenfolge auf der Kommandozeile relevant. Die verlinkten Optionen im Abschnitt 'See Also' beschreiben typische Kombinationen.

See Also

  • --verify-ir - Verify IR
  • --verify-after-each-pass - Verify After Each Pass
  • Command-Line Options Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


--version - Print Version - PBXB64 Command-Line Option

Startseite › --version - Print Version

--version - Print Version

Diese Option steuert den PBXB64-Kommandozeilenmodus --version. Technischer Zweck: Prints the PBXB64 compiler version string and exits. No input files are required. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Category: Information | Option: --version

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBXB64 --version

Beschreibung

Diese Option steuert den PBXB64-Kommandozeilenmodus --version. Technischer Zweck: Prints the PBXB64 compiler version string and exits. No input files are required. Sie ist fuer reproduzierbare Builds, lokale Diagnose, Batch-Dateien und CI-Skripte dokumentiert.

Standardverhalten

Standardverhalten: Disabled by default. Wenn die Option nicht angegeben wird, bleibt PBXB64 beim normalen Pipeline-, Ausgabe- oder Diagnoseverhalten fuer die ausgewaehlte Eingabe.

Arbeitsablauf

Typischer Ablauf: zuerst denselben Quelltext ohne --version uebersetzen, dann die Option gezielt einschalten und Ausgabedateien, Diagnosen und Exitcode vergleichen. Fuer Diagnoseoptionen empfiehlt sich ein kleiner Quelltext, damit die Ausgabe uebersichtlich bleibt.

Ausgabeformat

A single line to stdout: PBXB64 version VERSION-STRING. Beachten Sie diese Ausgabeform: einige Optionen erzeugen Dateien, andere schreiben stdout/stderr, und einige beeinflussen nur die interne Pipeline.

Verifiziertes Beispiel

PBXB64 version 0.50.0-V14

See Also

  • -h, --help - Show Help
  • Command-Line Options Reference

Back to command index


PBXB64 – Sprach-Frontends

Startseite › Sprach-Frontends

Übersicht über Sprach-Frontends

PBXB64 verfügt über fünf verschiedene Sprach-Frontends, die über ein einheitliches IR- und x64-Backend kompiliert werden. Jedes Frontend ist für seinen Zielanwendungsfall optimiert und behält gleichzeitig die sprachübergreifende Interoperabilität bei.

B64 (Primäre Systemsprache)

C-ähnliche Syntax mit manueller Speicherverwaltung, expliziten Zeigern und erstklassigen Strukturen. Entwickelt für die Systemprogrammierung, bei der Leistung und Kontrolle im Vordergrund stehen.

fn main(): i32 {
    let x: i32 = 42;
    let p: *i32 = &x
    *p = 100;
    return x;
}

B64-Sprachreferenz →

BASIC (PowerBASIC-kompatibel)

Modernisierter PowerBASIC-Dialekt mit V10-String-Lifetime-Management, PRINT-Trennersemantik, WinAPI-Integration, GUI/DDT, COMM, TCP/UDP, Threads, Grafiken und nativen H-Lib-Containern.

FUNCTION PBMAIN() AS LONG
    LOCAL s AS STRING
    s = "Hello from PBXB64"
    PRINT s
    FUNCTION = 0
END FUNCTION

BASIC-Sprachreferenz →

C-Teilmenge (C17 mit Präprozessor)

Kontrollierte C17-Teilmenge mit vollständigem Präprozessor, Schalter/Case/Goto, ternärem Operator, Funktionszeigern und 26 Standardbibliotheksheadern. Stellt außerdem die native H-Lib C-API bereit.

#include <stdio.h>
int main(void) {
    printf("Hello from C\n");
    return 0;
}

C-Sprachreferenz →

Assembly (nativ x64)

Intel-Syntax-Assembler mit direkter COFF/PE-Ausgabe. Unterstützt .asm/.s Dateien und lässt sich über Inline-ASM-Blöcke und separate Objektverknüpfung nahtlos in High-Level-Frontends integrieren.

section .text
global main
main:
    mov eax, 42
    ret

Assembler-Referenz →

PILOT (pädagogisch)

Klassische Bildungssprache. Nur in der aktuellen nativen PBXB64-Implementierung R: (Bemerkung), T: (Geben Sie eine Zeichenfolge in Anführungszeichen ein) und E: (Ende) werden unterstützt. Die übrigen Standard-PILOT-Befehle (C:, A:, J:, M:, Y:, N:, U:, S:, *label) sind dokumentiert, aber noch nicht implementiert. Dateierweiterung: .pil.

T: "Hello from PILOT!"
E:

PILOT-Sprachreferenz →

Sprachübergreifende Verlinkung: Alle Frontends werden mit derselben IR kompiliert und können miteinander verknüpft werden. Mischen Sie B64-, C-, BASIC-, Assembly- und PILOT-Quelldateien in einer einzigen PBXB64-Befehlszeile.
← Übersicht BASIC-Referenz → C-Referenz → B64 Referenz → PILOT-Guide → Datentypen → Beispiele ansehen
PBXB64 Compiler-Dokumentation · V10 · Zuletzt aktualisiert am 21.06.2026
Für Fragen und Beiträge:smart-package.com

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


PBXB64 – BASIC-Sprachreferenz

Startseite› BASIC-Frontend

BASIC-Sprachreferenz (PowerBASIC-kompatibel)

PBXB64 unterstützt einen wachsenden PowerBASIC-kompatiblen Dialekt. V12+ fügt Typsuffixe, Literalpräfixe, #DEFINE/#COMPILE, dynamische Arrays (DIM/REDIM/ERASE), OPTIONALE Parameter, SELECT CASE mit IS/TO, ON GOTO/GOSUB, DATA/READ/RESTORE, CODEPTR/FUNCPTR und über 60 integrierte Funktionen hinzu.

Referenzseiten

Diese Seite ist die Uebersicht zum Frontend. Die verlinkten Einzelseiten enthalten Syntax, getestete Beispiele, Status und Grenzen fuer die jeweiligen Befehle oder Sprachkonstrukte.

  • Kontrollfluss
  • Deklarationen
  • Variablen und Bereich
  • Eingabe/Ausgabe
  • Operatoren
  • String-Funktionen
  • Mathematik-Funktionen
  • Fehlerbehandlung

Programm-Einstiegspunkt

FUNCTION PBMAIN() AS LONG ... END FUNCTION
FUNCTION PBMAIN() AS LONG
    FUNCTION = 0   ' Return code
END FUNCTION

Variablendeklarationen

LOCAL x AS LONG          ' Stack variable (explicit type)
LOCAL s AS STRING        ' Heap-managed string
LOCAL f AS SINGLE        ' 32-bit float
DIM arr(10) AS LONG      ' Static array (0-10)
GLOBAL g AS LONG         ' Module-level global

' Type suffixes (PBWin style)
LOCAL intvar%            ' INTEGER via % suffix
LOCAL longvar&           ' LONG via & suffix
LOCAL sngvar!            ' SINGLE via ! suffix
LOCAL dblvar#            ' DOUBLE via # suffix
LOCAL strvar$            ' STRING via $ suffix
LOCAL curvar##           ' CURRENCY via ## suffix
LOCAL cuxvar?#           ' CURRENCYX via ?# suffix
LOCAL extvar??           ' EXTENDED via ?? suffix

Literale Präfixe

x = &HFF                 ' Hex: 255
x = &O77                 ' Octal: 63
x = &B1010               ' Binary: 10

Entspricht

%WIN_WIDTH  = 800        ' Integer equate
%MAX_ITEMS  = 100
$APP_NAME   = "MyApp"    ' String equate

' Usage in expressions:
w = %WIN_WIDTH
n = %MAX_ITEMS

Zuweisung und Betreiber

x = 42
s = "Hello World"
x = x + 1
y = a * b - c / d
z = (x > 0) AND (y < 10)

PRINT-Anweisung

PRINT-Ausdruck [; Ausdruck] [, Ausdruck]
PRINT "Hello"
PRINT "A"; "B"       ' Semicolon: no separator
PRINT "A", "B"       ' Comma: tab stop (~8 chars)
PRINT TAB(4); "D"    ' TAB(n): pad with spaces

Kontrollfluss

' IF/THEN/ELSE
IF x > 0 THEN
    PRINT "positive"
ELSE
    PRINT "negative"
END IF

' FOR/NEXT
FOR i = 1 TO 10 STEP 2
    PRINT i
NEXT i

' WHILE/WEND
WHILE x < 100
    x = x * 2
WEND

WinAPI-Integration

#INCLUDE "windows_core.pbi"

FUNCTION PBMAIN() AS LONG
    CALL MessageBoxA(0, "Hello", "PBXB64", 0)
    CALL Sleep(1000)
    FUNCTION = 0
END FUNCTION

String-Operationen (V7/V8)

LOCAL s AS STRING, t AS STRING
s = "Hello"
t = s + " World"     ' Concatenation
s = ""               ' Reassignment frees old heap string automatically
s = LEFT$(t, 5)      ' Built-in string functions

Makros (V9+)

PBXB64 unterstützt mehrzeilige MACRO-Definitionen mit Parameterersetzung, lokalen Labels und MACROTEMP-Variablen.

Mehrzeiliges MAKRO

MACRO AddEm(a, b, result)
    result = a + b
END MACRO

' Usage:
AddEm x, y, z         ' Expands to: z = x + y

MACROTEMP (lokale Variablen)

MACROTEMP deklariert Variablen, die pro Erweiterung eindeutige Namen erhalten, wodurch Kollisionen verhindert werden.

MACRO DoSwap(p, q)
    MACROTEMP t
    LOCAL t AS LONG
    t = p : p = q : q = t
END MACRO

DoSwap x, y          ' t_1 = x; x = y; y = t_1
DoSwap a, b          ' t_2 = a; a = b; b = t_2

Lokale Etiketten

Beschriftungen in Makros werden automatisch entstellt, um Konflikte zwischen Erweiterungen zu vermeiden.

MACRO CheckVal(n)
    IF n > 0 THEN GOTO Done
    n = 0
    Done:
END MACRO

CheckVal 42           ' goto Done_1 ... Done_1:
CheckVal -1           ' goto Done_2 ... Done_2:

%PARAMCOUNT

Gibt die Anzahl der an das Makro übergebenen Argumente zurück.

MACRO LogArgs(a, b, c)
    x = %PARAMCOUNT     ' x = 3
END MACRO

Präprozessoranweisungen (V12+)

#COMPILE EXE              ' Output type (EXE/DLL/CONSOLE)
#DEFINE MAX_SIZE 100       ' Text replacement (resolved in expressions)
#UNDEF MAX_SIZE            ' Remove a #DEFINE
#INCLUDE ONCE "file.pbi"  ' Include with guard against re-inclusion

' Conditional compilation with comparison operators
%VERSION = 5
#IF %VERSION >= 3
    PRINT "Version 3+"
#ELSEIF %VERSION = 2
    PRINT "Version 2"
#ELSE
    PRINT "Version 1"
#ENDIF

Dynamische Arrays (V12+)

DIM arr(5) AS LONG         ' Allocate 5-element heap array
arr(2) = 100                ' Write to element
x = arr(2)                  ' Read from element
REDIM arr(10) AS LONG       ' Resize (discards old data)
REDIM PRESERVE arr(20)     ' Resize (preserves old data)
ERASE arr()                 ' Free heap buffer

' Bounds
n = LBOUND(arr())           ' Lower bound (usually 0)
n = UBOUND(arr())           ' Upper bound = element count - 1

OPTIONALE Parameter (V12+)

FUNCTION add(a AS LONG, OPTIONAL b AS LONG) AS LONG
    FUNCTION = a + b        ' b defaults to 0 if not passed
END FUNCTION

result = add(10)            ' b = 0
result = add(10, 20)        ' b = 20

ON GOTO / ON GOSUB (V12+)

ON choice GOTO lab1, lab2, lab3     ' Computed goto
ON choice GOSUB sub1, sub2, sub3    ' Computed gosub
DATA 1, 2, 3, 4, 5                   ' Data block
READ a, b, c                         ' Read from data
RESTORE                              ' Reset to start of data

Verschachtelung und Grenzen

  • Maximale Verschachtelungstiefe: 16 Ebenen
  • Makros werden vor dem Hauptdurchlauf vorab gescannt (Weiterleitungsreferenzen OK)
  • Bei der Parameterersetzung wird an der Wortgrenze die Groß-/Kleinschreibung nicht beachtet
Notiz:Einzeilige MACRO-SyntaxMACRO name(x) = expressiongibt ein C ab#defineund wird auch unterstützt.
String-Lifetime-Management:V7/V8 gibt automatisch Heap-gestützte STRING-Werte bei Neuzuweisung vor RETURN, EXIT FUNCTION und natürlichem Funktionsende frei. Kein manuelles STRFREE erforderlich.

Wide-Integer-Typen (V8+)

PBXB64 unterstützt native 128-Bit-, 256-Bit- und 512-Bit-Ganzzahlen mit und ohne Vorzeichen mit Inline-x64-Arithmetik – keine Laufzeitbibliotheksaufrufe.

LOCAL a AS INT128          ' 128-bit signed
LOCAL b AS I128            ' Alias for INT128
LOCAL c AS UINT128         ' 128-bit unsigned
LOCAL d AS U128            ' Alias for UINT128

LOCAL e AS INT256          ' 256-bit signed
LOCAL f AS I256            ' Alias for INT256
LOCAL g AS UINT256         ' 256-bit unsigned
LOCAL h AS U256            ' Alias for UINT256

LOCAL i AS INT512          ' 512-bit signed
LOCAL j AS I512            ' Alias for INT512
LOCAL k AS UINT512         ' 512-bit unsigned
LOCAL l AS U512            ' Alias for UINT512

' All standard arithmetic operators are supported:
a = 1000000000000000000000  ' 10^21
b = a + a                   ' 2*10^21
c = a * b                   ' 2*10^42 (fits in 128 bits)

MODUL-System (V8+)

Kapseln Sie Code mit Sichtbarkeitskontrolle in benannte Bereiche.

MODULE MyModule
  ' Private by default — only visible inside this module
  FUNCTION PrivateHelper() AS LONG
      FUNCTION = 42
  END FUNCTION

  ' Public — callable from outside via module prefix
  PUBLIC FUNCTION PublicFunc() AS LONG
      FUNCTION = PrivateHelper()
  END FUNCTION

  ' Module-scoped equates and globals
  %MY_CONST = 100
  GLOBAL gCounter AS LONG
END MODULE

' Call from another module or the main program:
FUNCTION PBMAIN() AS LONG
    result = MyModule.PublicFunc()   ' OK: PUBLIC
    ' result = MyModule.PrivateHelper()  ' ERROR: PRIVATE
    FUNCTION = result
END FUNCTION

Native H-Lib-Container (V8+)

23 Containerfamilien mit automatischer Initialisierung, Methodenverteilungssyntax und UDT-Nutzlastunterstützung.

LOCAL q AS LNQUE        ' FIFO queue of LONGs
q = q.New
q.Push 10
q.Push 20
PRINT q.Pop             ' 10
q.Final

LOCAL h AS LNHSH        ' Hash table (LONG key, LONG value)
h = h.New
h.Set(1, 100)
PRINT h.Get(1)          ' 100
h.Final

' Subscript access:
LOCAL a AS LNARR
a = a.New
a[0] = 42
PRINT a[0]              ' 42
a.Final

LIKE/ALIKE-Operator (V8+)

Mustervergleich mit Platzhaltern und Zeichenklassen.

IF "Hello" LIKE "H*" THEN          ' true: * matches any sequence
IF "abc" LIKE "a[bc]c" THEN       ' true: bracket list
IF "abc" LIKE "a[!b]c" THEN       ' false: complemented class
IF "abc" LIKE "a[a-z]c" THEN       ' true: character range
IF "test.txt" LIKE "*.txt" THEN    ' true: wildcard extension

' ALIKE is always case-insensitive:
IF "Hello" ALIKE "h*" THEN         ' true

Bekannte Einschränkungen (V12)

  • Vollständige WinAPI .pbi-Include-Bibliothek verfügbar inincludes/(1.272 Header)
  • DLL-Ausgabe mit #COMPILE DLL und exportierten PB-Funktionen ist fuer den getesteten nativen PE-/Exporttabellen-Teil verfuegbar; #COMPILE SLL bleibt offen
  • Die vollständige PowerBASIC-Kompatibilität ist noch in Arbeit
← B64-Referenz C-Sprachreferenz → Beispiele ansehen
PBXB64-Compiler-Dokumentation · V8 Native Edition · Zuletzt aktualisiert am 19.06.2026
Für Fragen und Beiträge:smart-package.com

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


BASIC-Variablen und -Bereich — PBXB64 Help

Startseite › BASIC Frontend › Variables & Scope

BASIC-Variablen und -Bereich

Variablenmodifikatoren, Übergabemodi und Lebensdauer.

Aufgabe dieses Kapitels

Dieses Kapitel sammelt die BASIC-Sprachmittel zu einem zusammenhängenden Arbeitsbereich. Es dient als Einstieg, wenn Sie nicht den exakten Befehlsnamen kennen, sondern eine Spracheigenschaft suchen.

Verwendung

Beginnen Sie mit der Tabelle unten und wechseln Sie dann zur Detailseite des einzelnen Befehls. Die Detailseiten enthalten Syntax, Hinweise zur PBXB64-Unterstützung, Getestetes Beispiel und Querverweise.

Befehlsübersicht

Befehl | Bereich
AS | Variablenmodifikatoren, Übergabemodi und Lebensdauer.
BYVAL | Variablenmodifikatoren, Übergabemodi und Lebensdauer.
BYREF | Variablenmodifikatoren, Übergabemodi und Lebensdauer.
ALIAS | Variablenmodifikatoren, Übergabemodi und Lebensdauer.
LIB | Variablenmodifikatoren, Übergabemodi und Lebensdauer.
NEU | Variablenmodifikatoren, Übergabemodi und Lebensdauer.
END | Variablenmodifikatoren, Übergabemodi und Lebensdauer.

Getestetes Beispiel

Diese Seite ist ein Uebersichtskapitel. Die verlinkten Einzelseiten enthalten die konkreten getesteten Beispiele oder nennen eine ausdrueckliche Begrenzung, wenn ein Befehl nicht zertifiziert ist.

PBXB64-Status: Uebersicht / Navigation; keine eigenstaendige Laufzeitbehauptung ohne Unterseitenbeleg.

Praktische Hinweise

BASIC-Quelltext wird im PBXB64-Frontend direkt in die gemeinsame Zwischenrepräsentation übersetzt. Achten Sie deshalb besonders auf Datentypen, ByVal/ByRef-Übergabe, Zeichenkettenlängen und Laufzeitfehlerpfade.

Siehe auch

  • BASIC-Sprachübersicht

← Back

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


ALIAS - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Prozeduren & Bereich › ALIAS
Hilfe zum PBXB64-Compiler

ALIAS

Weist einer Prozedur einen alternativen Export- oder Importnamen zu.

Kind: Modifikator | Category: Procedures

PBXB64 Status: VERFÜGBAR

PBXB64 Certification: [ZERTIFIZIERT GETESTET]

Syntax

DECLARE SUB ProcName ALIAS "ExportName" (...)
DECLARE FUNCTION ProcName ALIAS "ExportName" (...) AS Type

Description

ALIAS bindet einen PowerBASIC-Bezeichner an einen bestimmten externen Symbolnamen. Das ist der Name, der in der DLL-Exporttabelle oder bei der Importauflösung verwendet wird.

Nutzen Sie ALIAS, wenn der externe Name case-sensitiv ist, Zeichen enthält, die in PowerBASIC-Bezeichnern unzulässig sind, oder einfach aus Gründen der Lesbarkeit abweichen soll.

Der interne Name und der externe Name müssen nicht identisch sein. In der Praxis ist ALIAS das Schlüsselwort, das DECLARE-Zeilen für echte WinAPI- und DLL-Imports brauchbar macht.

Example

' Getestetes Beispiel: examples/basic/test_declare_lib.pb
DECLARE SUB ExitProcess LIB "KERNEL32.DLL" ALIAS "ExitProcess" (BYVAL code AS DWORD)

FUNCTION PBMAIN() AS LONG
    ExitProcess 0
END FUNCTION

Hinweise

  • Fehlende oder falsch geschriebene ALIAS-Namen sind eine häufige Ursache für Import-/Exportfehler.
  • Halten Sie bei DLL-Einstiegspunkten die exakte externe Schreibweise ein.

Verifiziertes Beispiel: ALIAS - PB-Namen an externes Symbol binden

Beispieldatei: examples/basic/help_variables/help_alias.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_variables/help_alias.pb -o tmp/help_variable_samples/help_alias.exe and executed with exit code 0.

DECLARE FUNCTION Tick LIB "kernel32.dll" ALIAS "GetTickCount" () AS DWORD

FUNCTION PBMAIN() AS LONG
    LOCAL t AS DWORD
    t = Tick()
END FUNCTION

Verhalten: Ruft die Win32-Funktion ueber den PB-Namen Tick auf, waehrend der Import das externe Symbol GetTickCount aufloest. Focus form: ALIAS "GetTickCount"

See Also

  • LIB
  • ERKLÄREN
  • FUNCTION / END FUNCTION
  • SUB / END SUB

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


AS - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Datentypen & Variablen › AS
Hilfe zum PBXB64-Compiler

AS

Hängt einen expliziten Typ an eine Variable, einen Parameter, einen Rückgabewert oder ein Feld.

Kind: Modifikator | Category: Variables & Scope

PBXB64 Status: VERFÜGBAR

PBXB64 Certification: [ZERTIFIZIERT GETESTET]

Syntax

name AS TypeName
FUNCTION Name(...) AS TypeName
DECLARE SUB Proc(BYVAL value AS LONG)

Description

AS ist das moderne Typ-Annotation-Schlüsselwort in PowerBASIC. Es erscheint in Deklarationen, Prozedursignaturen, UDT-Feldern und Array-Definitionen.

Verwenden Sie AS, wenn der Typ an der Deklarationsstelle klar sichtbar sein soll und nicht über ein Suffix erraten werden muss. Das macht gemischte Deklarationen leichter lesbar.

AS arbeitet mit normalen Skalar-Typen, Zeichenketten, Zeigern, OBJECT, TYPEs und UNIONs. Es ist auch die Form, die in den stärkeren DECLARE- und FUNCTION-Beispielen benutzt wird.

Example

' Getestetes Stilbeispiel: examples/basic/test_function_return.pb
FUNCTION AddTwo(BYVAL a AS LONG, BYVAL b AS LONG) AS LONG
    FUNCTION = a + b
END FUNCTION

Hinweise

  • Bevorzugen Sie AS gegenüber der alten Suffix-Notation in neuem Code.
  • Verwenden Sie in DECLARE- und FUNCTION-Definitionen immer einen expliziten AS Type-Rückgabetyp.

Verifiziertes Beispiel: AS - explizite Typangabe

Beispieldatei: examples/basic/help_variables/help_as.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_variables/help_as.pb -o tmp/help_variable_samples/help_as.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    LOCAL value AS LONG
    value = 12
    IF value <> 12 THEN FUNCTION = 1
END FUNCTION

Verhalten: Deklariert ein LONG mit AS und prueft die Zuweisung. Focus form: LOCAL value AS LONG

See Also

  • BYVAL
  • BYREF
  • FUNCTION / END FUNCTION
  • SUB / END SUB

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


BYREF - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Prozeduren & Bereich › BYREF
Hilfe zum PBXB64-Compiler

BYREF

Übergibt die Adresse der Variablen des Aufrufers, damit die Prozedur sie direkt lesen oder ändern kann.

Kind: Modifikator | Category: Procedures

PBXB64 Status: VERFÜGBAR

PBXB64 Certification: [ZERTIFIZIERT GETESTET]

Syntax

SUB Proc(BYREF value AS LONG)
FUNCTION Proc(BYREF value AS STRING) AS LONG

Description

BYREF übergibt die Speicherstelle des Aufrufers statt einer Kopie. Die Prozedur sieht und ändert damit dieselbe Variable, die der Aufrufer besitzt.

Verwenden Sie BYREF, wenn die Prozedur mehr als einen Ergebniswert zurückgeben, einen Puffer des Aufrufers in place ändern oder eine große Struktur bzw. Zeichenkette nicht kopieren soll.

Wenn ein BYREF-Parameter optional ist, prüfen Sie ihn mit ISMISSING, bevor Sie darauf zugreifen. Wurde der Parameter weggelassen, kann der Slot Null sein und darf nicht blind dereferenziert werden.

Example

' Getestetes Beispiel: examples/basic/v4_byref_sub.bas
SUB IncValue(BYREF x AS LONG)
    x = x + 1
END SUB

FUNCTION PBMAIN() AS LONG
    LOCAL n AS LONG
    n = 1
    IncValue n
    PBMAIN = n
END FUNCTION

Hinweise

  • Verwenden Sie BYREF für In-Place-Änderungen und große Parameterpakete.
  • Wenn Sie explizit einen Zeiger übergeben, deklarieren Sie den Parameter BYVAL AS PTR.

Verifiziertes Beispiel: BYREF - Speicher des Aufrufers uebergeben

Beispieldatei: examples/basic/help_variables/help_byref.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_variables/help_byref.pb -o tmp/help_variable_samples/help_byref.exe and executed with exit code 0.

SUB SetValue(BYREF x AS LONG)
    x = 45
END SUB

FUNCTION PBMAIN() AS LONG
    LOCAL n AS LONG
    SetValue n
    IF n <> 45 THEN FUNCTION = 1
END FUNCTION

Verhalten: Die SUB aendert die Variable des Aufrufers und prueft damit Referenzuebergabe. Focus form: SUB SetValue(BYREF x AS LONG)

See Also

  • BYVAL
  • CALL
  • ISMISSING
  • FUNCTION / END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


BYVAL - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Prozeduren & Bereich › BYVAL
Hilfe zum PBXB64-Compiler

BYVAL

Übergibt ein Argument als Wert statt als Verweis auf den Speicher des Aufrufers.

Kind: Modifikator | Category: Procedures

PBXB64 Status: VERFÜGBAR

PBXB64 Certification: [ZERTIFIZIERT GETESTET]

Syntax

SUB Proc(BYVAL value AS LONG)
FUNCTION Proc(BYVAL value AS STRING) AS LONG

Description

BYVAL übergibt eine Kopie des Arguments an die Prozedur. Änderungen in der Prozedur wirken nicht auf die Variable des Aufrufers zurück.

Verwenden Sie BYVAL für kleine Skalarwerte, wenn der Aufruf isoliert bleiben soll oder die Prozedur den Wert nur lesen muss. Es ist auch die normale Form für rohe numerische Handles und viele API-Parameter.

Wenn eine Prozedur einen zeigerartigen Wert erwartet, deklarieren Sie diesen Parameter ausdrücklich BYVAL. So bleibt der Aufrufvertrag klar.

Example

' Getestetes Beispiel: tests/e2e/pb/test_opt_byval_default.pb
FUNCTION AddWithDefault(BYVAL a AS LONG, OPT BYVAL b AS LONG = 9) AS LONG
    FUNCTION = a + b
END FUNCTION

Hinweise

  • BYVAL ist für kleine Werte und handle-ähnliche Parameter sinnvoll.
  • Verwenden Sie BYVAL nicht für Daten, die die Prozedur vor Ort ändern soll.

Verifiziertes Beispiel: BYVAL - Kopie uebergeben

Beispieldatei: examples/basic/help_variables/help_byval.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_variables/help_byval.pb -o tmp/help_variable_samples/help_byval.exe and executed with exit code 0.

FUNCTION AddOne(BYVAL x AS LONG) AS LONG
    x = x + 1
    FUNCTION = x
END FUNCTION

FUNCTION PBMAIN() AS LONG
    LOCAL n AS LONG
    n = 4
    IF AddOne(n) <> 5 THEN FUNCTION = 1
    IF n <> 4 THEN FUNCTION = 2
END FUNCTION

Verhalten: Die Funktion aendert ihre lokale Kopie und prueft, dass die Variable des Aufrufers unveraendert bleibt. Focus form: FUNCTION AddOne(BYVAL x AS LONG) AS LONG

See Also

  • BYREF
  • CALL
  • ERKLÄREN
  • ISMISSING

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


END ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? END

END

Programm sofort beenden.

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

END [ nErrorLevel& ]

Beschreibung

Normalerweise werden PowerBASIC-Programme beendet, wenn Sie die Funktion PBMAIN oder WINMAIN() beenden. Es sollte immer Ihr Ziel sein, Programme auf diese Weise zu beenden, damit der Compiler und das Betriebssystem alles tun k?nnen, um alles in einem geordneten Zustand zu belassen.

Die END-Anweisung ist eine alternative Beendigungsmethode, die nur in begrenzten F?llen verwendet werden sollte. Dies kann in Notsituationen hilfreich sein, beispielsweise bei einem schwerwiegenden Fehler wie ?Nicht gen?gend Speicher?. Aus Gr?nden der Kompatibilit?t ist es auch (vor?bergehend) bei der Konvertierung von DOS-Programmen n?tzlich. Sobald die Konvertierung jedoch abgeschlossen ist, sollten Sie sie so schnell wie m?glich entfernen.

Der optionale nErrorLevel&-Wert hat einen effektiven Bereich von 0 bis 255. Batch-Dateien k?nnen ?ber den Batch-Befehl IF [NOT] ERRORLEVEL auf das Ergebnis reagieren.

Einschr?nkungen

END darf in einer DLL nicht verwendet werden. END ist nur f?r die vor?bergehende Verwendung bei der Konvertierung von DOS-Programmen in Windows vorgesehen. Sie sollten es so schnell wie m?glich in die Standard-EXIT-FUNCTION-Methode konvertieren. Dies sollte vermieden werden, solange COM-Objekte aktiv sind.

Praktische Verwendung

END gehoert zur Kategorie General. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' END mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Siehe auch

  • AUSFAHRT
  • PBMAIN
  • WINMAIN


LIB - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Prozeduren & Bereich › LIB
Hilfe zum PBXB64-Compiler

LIB

Nimmt den Modulnamen auf, der eine importierte Prozedur enthält.

Kind: Modifikator | Category: Procedures

PBXB64 Status: VERFÜGBAR

PBXB64 Certification: [ZERTIFIZIERT GETESTET]

Syntax

DECLARE FUNCTION ProcName LIB "module.dll" ALIAS "ExportName" (...) AS Type

Description

LIB gibt die DLL oder das Modul an, aus dem eine importierte Routine aufgelöst wird. In modernerem Code ist es die alte Schreibweise von IMPORT, bleibt aber für die Kompatibilität wichtig.

Die meisten externen Funktionsdeklarationen benutzen LIB zusammen mit ALIAS, damit der Compiler sowohl den Bibliotheksnamen als auch den exakten Exportnamen kennt.

Verwenden Sie den vollständigen Modulnamen, wenn es darauf ankommt. Zur Laufzeit wird das Modul geladen und das Symbol aufgelöst.

Example

' Getestetes Beispiel: examples/basic/test_declare_winapi.pb
DECLARE FUNCTION GetModuleHandle LIB "KERNEL32.DLL" ALIAS "GetModuleHandleA" (BYVAL lpModuleName AS ASCIIZ) AS LONG

FUNCTION PBMAIN() AS LONG
    PBMAIN = 0
END FUNCTION

Hinweise

  • LIB ist der historische Name; IMPORT ist die modernere Schreibweise, wenn verfügbar.
  • Kombinieren Sie LIB mit ALIAS für API-Einstiegspunkte mit ANSI- oder Unicode-Suffix.

Verifiziertes Beispiel: LIB - Importmodul benennen

Beispieldatei: examples/basic/help_variables/help_lib.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_variables/help_lib.pb -o tmp/help_variable_samples/help_lib.exe and executed with exit code 0.

DECLARE FUNCTION GetTickCount LIB "kernel32.dll" ALIAS "GetTickCount" () AS DWORD

FUNCTION PBMAIN() AS LONG
    LOCAL t AS DWORD
    t = GetTickCount()
END FUNCTION

Verhalten: Importiert GetTickCount aus kernel32.dll und prueft, dass die Deklaration gelinkt wird. Focus form: LIB "kernel32.dll"

See Also

  • ALIAS
  • ERKLÄREN
  • FUNCTION / END FUNCTION
  • SUB / END SUB

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


NEU - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Datentypen & Variablen › NEU
Hilfe zum PBXB64-Compiler

NEU

Erzeugt eine neue Objektinstanz oder einen kompatiblen Referenzwert.

Kind: Operator | Category: Data Types & Variables

PBXB64 Status: VERFÜGBAR

PBXB64 Certification: [ZERTIFIZIERT GETESTET]

Syntax

objectVar = NEW PROGID("Class.Name")
objectVar = NEW ClassName

Description

NEU ist der Erzeugungsschritt im objektorientierten Teil von PBXB64. Er erstellt eine frische Instanz und liefert eine Referenz, die einer OBJECT-Variablen zugewiesen werden kann.

Verwenden Sie NEU zusammen mit OBJECT, PROGID$ und den klassenbezogenen Anweisungen, wenn Sie eine reale Instanz statt eines Null-Platzhalters brauchen.

Andere Befehlsfamilien haben ihre eigenen NEU-Formen, zum Beispiel DIALOG NEW, FONT NEW, GRAPHIC BITMAP NEW und MENU NEW. Diese Seiten dokumentieren ihre eigenen Formen; diese Seite behandelt das Objektkonstrukt.

Example

' Stilvorlage: examples/basic/test_object.pb
FUNCTION PBMAIN() AS LONG
    LOCAL o AS OBJECT
    o = NOTHING
    PBMAIN = 0
END FUNCTION

Hinweise

  • Verwenden Sie NEU für die Konstruktion, nicht für rohe Speicherzuweisung.
  • Wenn Sie nur einen Null-Platzhalter brauchen, weisen Sie NOTHING zu.

Verifiziertes Beispiel: NEW - generische Objektkonstruktion

Beispieldatei: examples/basic/help_variables/help_new_negative.pb

Validierungsnachweis: compiled as a negative test with Release/PBXB64.exe examples/basic/help_variables/help_new_negative.pb -o tmp/help_variable_samples/help_new_negative.exe; the expected compiler diagnostic is produced.

FUNCTION PBMAIN() AS LONG
    LOCAL o AS OBJECT
    SET o = NEW OBJECT
END FUNCTION

Verhalten: Aktuelles PBXB64 weist generisches Objekt-NEW ab; domaenenspezifische NEW-Formen wie DIALOG NEW haben eigene Befehlsseiten und Tests. Focus form: SET o = NEW OBJECT

See Also

  • OBJECT
  • PROGID$
  • LET (mit Objekten)
  • CLASS

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


BASIC-Deklarationen — PBXB64 Help

Startseite › BASIC Frontend › Declarations

BASIC-Deklarationen

Anweisungen, die Prozeduren, Typen und Variablen deklarieren.

Aufgabe dieses Kapitels

Dieses Kapitel sammelt die BASIC-Sprachmittel zu einem zusammenhängenden Arbeitsbereich. Es dient als Einstieg, wenn Sie nicht den exakten Befehlsnamen kennen, sondern eine Spracheigenschaft suchen.

Verwendung

Beginnen Sie mit der Tabelle unten und wechseln Sie dann zur Detailseite des einzelnen Befehls. Die Detailseiten enthalten Syntax, Hinweise zur PBXB64-Unterstützung, Getestetes Beispiel und Querverweise.

Befehlsübersicht

Befehl | Bereich
SUB / END SUB | Anweisungen, die Prozeduren, Typen und Variablen deklarieren.
FUNCTION / ENDFUNKTION | Anweisungen, die Prozeduren, Typen und Variablen deklarieren.
ERKLÄREN | Anweisungen, die Prozeduren, Typen und Variablen deklarieren.
DIM | Anweisungen, die Prozeduren, Typen und Variablen deklarieren.
LOCAL | Anweisungen, die Prozeduren, Typen und Variablen deklarieren.
GLOBAL | Anweisungen, die Prozeduren, Typen und Variablen deklarieren.
STATIC | Anweisungen, die Prozeduren, Typen und Variablen deklarieren.
GETEILT | Anweisungen, die Prozeduren, Typen und Variablen deklarieren.
REDIM / ERHALTEN | Anweisungen, die Prozeduren, Typen und Variablen deklarieren.
TYP / ENDTYP | Anweisungen, die Prozeduren, Typen und Variablen deklarieren.
UNION / END UNION | Anweisungen, die Prozeduren, Typen und Variablen deklarieren.
ENUM | Anweisungen, die Prozeduren, Typen und Variablen deklarieren.

Getestetes Beispiel

Diese Seite ist ein Uebersichtskapitel. Die verlinkten Einzelseiten enthalten die konkreten getesteten Beispiele oder nennen eine ausdrueckliche Begrenzung, wenn ein Befehl nicht zertifiziert ist.

PBXB64-Status: Uebersicht / Navigation; keine eigenstaendige Laufzeitbehauptung ohne Unterseitenbeleg.

Praktische Hinweise

BASIC-Quelltext wird im PBXB64-Frontend direkt in die gemeinsame Zwischenrepräsentation übersetzt. Achten Sie deshalb besonders auf Datentypen, ByVal/ByRef-Übergabe, Zeichenkettenlängen und Laufzeitfehlerpfade.

Siehe auch

  • BASIC-Sprachübersicht

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


DECLARE ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? DECLARE

ERKL?REN

Deklarieren Sie explizit a

Typ:Anweisung |Kategorie: Procedures

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DECLARE SUB ProcName [ALIAS " AliasName "] [( arguments )] < Descriptors >
DECLARE FUNCTION ProcName [ALIAS " AliasName "] [( arguments )] < Descriptors > AS RetType
DECLARE CALLBACK FUNCTION ProcName [[()] AS LONG]
DECLARE THREAD FUNCTION ProcName (BYVAL var AS (LONG | DWORD}) AS {LONG | DWORD}

Beschreibung

Die DECLARE-Anweisung besteht aus folgenden Teilen:

ProcName

Der Name der Sub oder Funktion, die deklariert werden soll. Bei Funktionen kann anstelle der [AS RetType]-Klausel ein Typbezeichner angeh?ngt werden (genau wie ein gew?hnlicher Variablenname), um den Datentyp des R?ckgabewerts der Funktion anzugeben.

Zuk?nftige Versionen von PowerBASIC unterst?tzen keine Typspezifizierersymbole f?r den Funktionsr?ckgabetyp. Geben Sie den R?ckgabedatentyp mit einer expliziten AS RetType-Klausel in allen DECLARE- und FUNCTION-Definitionen an, um zuk?nftige Kompatibilit?t sicherzustellen.

Eine Alias-Klausel kann verwendet werden, um einen alternativen Namen anzugeben, der f?r importierte oder exportierte Prozeduren verwendet werden soll. Dadurch k?nnen Sie mit externen Modulen (DLL oder EXE) unter Verwendung eines anderen Prozedurnamens interagieren. Der Aliasname muss durch ein Zeichenfolgenliteral angegeben werden, das den Namen und die Gro?-/Kleinschreibung der Prozedur in der externen DLL bereitstellt.

Diese Option ist besonders n?tzlich, wenn Sie einen langen Namen abk?rzen m?chten oder wenn der urspr?ngliche Name einer Funktion Zeichen enth?lt, die in PowerBASIC unzul?ssig sind. Der Aliasname ist der tats?chliche Name, der im anderen Modul verwendet wird, w?hrend ProcName das Wort ist, das Sie in Ihrem PowerBASIC-Programm verwenden. Zum Beispiel:

DECLARE SUB ShortName ALIAS ?VeryLongProcName?()

DECLARE FUNCTION LegalName ALIAS ?Illegal$Name?()

Obwohl ein Proc-Name eindeutig sein muss, k?nnen Sie denselben AliasName in mehreren Deklarationen verwenden. Dies ist besonders n?tzlich, um AS ANY in F?llen zu vermeiden, in denen eine Prozedur darauf ausgelegt ist, mehrere unterschiedliche Parametertypen zu empfangen.

DEKLARIEREN SIE DIE FUNCTION AddAtom LIB ?KERNEL32.DLL? ALIAS ?AddAtomA? (lpString AS STRINGZ) ALS WORD

Deklarieren Sie die Funktion AddIntAtom LIB ?KERNEL32.DLL? ALIAS ?AddAtomA? (BYVAL lpString AS DWORD) ALS WORD

Die ALIAS-Klausel ist sehr wichtig beim Importieren oder Exportieren von Subs und Funktionen aus DLLs. Das Weglassen der ALIAS-Klausel oder die falsche Gro?schreibung des Aliasnamens sind h?ufige Ursachen f?r Probleme beim Laden von DLLs. Weitere Informationen finden Sie in den Abschnitten SUB und FUNCTION.

Deskriptoren

Sie k?nnen optional ein oder mehrere Deskriptorw?rter hinzuf?gen (Import, Export, Common, Private, ThreadSafe, BDecl, CDecl, SDecl), um bestimmte Funktionen bereitzustellen. Sie k?nnen der DECLARE als durch Kommas getrennte Liste hinzugef?gt werden. Sie sollten beachten, dass sich einige davon gegenseitig ausschlie?en.

IMPORT

Ein Zeichenfolgenliteral oder Equate, das den Namen des Moduls angibt, in dem sich eine importierte Prozedur befindet. Dadurch k?nnen Sie Subs oder Funktionen aufrufen, die sich in DLLs befinden. Das alte Wort LIB kann durch IMPORT ersetzt werden.

EXPORT

Dieser Deskriptor identifiziert eine Unter- oder Funktion, auf die zwischen Dynamic Link Libraries (DLLs) zugegriffen werden kann, und/oder die ausf?hrbare Hauptdatei, die sie verkn?pft. Wenn eine Prozedur nicht mit EXPORT markiert ist, wird sie vor diesen anderen Modulen ausgeblendet. Das EXPORT-Attribut kann zu einer an anderer Stelle definierten Unter-/Funktion hinzugef?gt werden, indem EXPORT in einer DECLARE-Anweisung angegeben wird. EXPORT kann sogar zu einer Unterfunktion/Funktion in einer SLL mit einer DECLARE im Hostmodul hinzugef?gt werden.

COMMON

Eine GEMEINSAME Subfunktion/Funktion ist eine Funktion, die zwischen verkn?pften Einheitenmodulen (Host oder SLL) aufgerufen werden kann. Wenn die gemeinsame Unter-/Funktionseinheit in diesem Modul nicht vorhanden ist, wird davon ausgegangen, dass sie in einem separaten verkn?pften Modul (Host oder SLL) gefunden wird. Es ist nicht erforderlich, eine gemeinsame Sub- oder Funktion im Host-Modul zu deklarieren. Wenn Sie sich daf?r entscheiden, ist es im Allgemeinen ratsam, den COMMON-Deskriptor wegzulassen, da sein Vorhandensein eine Verkn?pfung der SLL erzwingt, unabh?ngig davon, ob dies erforderlich ist oder nicht.

PRIVAT

Eine private Unter-/Funktionsfunktion ist eine Funktion, auf die nur innerhalb des aktuellen PowerBASIC-Programms oder der aktuellen PowerBASIC-Bibliothek zugegriffen werden kann. Auch wenn nichts angegeben ist, ist dies der Standardbetriebsmodus.

FADENSICHER

Mit der THREADSAFE-Option richtet PowerBASIC automatisch eine Semaphore ein, die es jeweils nur einem Thread erm?glicht, die Sub/Funktion auszuf?hren. Andere Aufrufer m?ssen warten, bis der erste Thread die THREADSAFE-Prozedur verl?sst, bevor sie beginnen d?rfen.

Gibt an, dass die deklarierte Prozedur die alte BASIC/Pascal-Aufrufkonvention verwendet. Parameter werden von links nach rechts auf dem Stapel abgelegt und die aufgerufene Prozedur ist f?r deren Entfernung verantwortlich. BDECL sollte nur verwendet werden, wenn dies zur Anpassung an externe Module erforderlich ist.

Gibt an, dass die deklarierte Prozedur die C-Aufrufkonvention verwendet. Parameter werden von rechts nach links auf den Stapel verschoben und der aufrufende Code ist f?r deren Entfernung verantwortlich. CDECL sollte nur verwendet werden, wenn dies zur Anpassung an externe Module erforderlich ist.

Wenn eine Prozedur importiert oder exportiert wird, erstellt PowerBASIC automatisch einen ALIAS in Kleinbuchstaben, dem ein Unterstrich vorangestellt ist. Die folgenden beiden Deklarationen sind ?quivalent und geben an, wie der Standard-ALIAS-Name von PowerBASIC erstellt wird:

DECLARE SUB C_Function CDECL ()

DECLARE SUB C_Function CDECL ALIAS ?_c_function? ()

Dies ist die Standardkonvention und sollte nach M?glichkeit verwendet werden. SDECL (und sein Synonym STDCALL) spezifiziert die ?Standard Calling Convention? f?r Windows. Parameter werden von rechts nach links auf den Stapel verschoben und die aufgerufene Prozedur ist f?r deren Entfernung verantwortlich.

R?CKRUF

R?ckruffunktionen sind f?r die Verwendung mit Dynamic Dialog Tools (DDT)-Funktionen reserviert. Es sollten keine Parameter angegeben werden, da Daten mit den CALLBACK-Funktionen ( CB ) abgerufen werden. Aus Gr?nden der ?bersichtlichkeit k?nnen Klammern und der R?ckgabetyp AS LONG hinzugef?gt werden.

FADEN

Thread-Funktionen sind f?r die Verwendung mit der THREAD CREATE-Anweisung reserviert. Es muss genau einen Long-Integer-Parameter als Wert annehmen (BYVAL LONG) und einen Long-Integer-Wert zur?ckgeben (AS LONG). Es ist zul?ssig, diese beiden Elemente durch DWORD zu ersetzen.

?bergabe von Parametern

Argumente

Enth?lt den/die Namen oder den Typ jedes Parameters in der Reihenfolge seiner ?bergabe f?r bis zu 32 Parameter. Wenn Sie eine SUB oder FUNCTION in einer DLL aufrufen m?chten, m?ssen Sie die Ziel-SUB oder FUNCTION mit einer expliziten DECLARE-Anweisung beschreiben. Die DECLARE-Anweisung muss jedem Verweis auf die Zielprozedur physisch vorangehen.

In fr?heren Versionen von PowerBASIC mussten Sie eine explizite DECLARE-Anweisung erstellen, wenn Sie ein SUB oder eine Funktion ausf?hren wollten, die dem Verweis darauf nicht physisch vorausging. Diese zus?tzliche Arbeit ist nicht mehr erforderlich, da PowerBASIC alle Weiterleitungsverweise auf interne Prozeduren automatisch aufl?st.

F?r jede Routine muss die vollst?ndige Argumentenliste angegeben werden. Jeder Parameter kann auf eine von drei Arten definiert werden:

Zul?ssige Typnamen f?r Argumente sind ANY, ASCIIZ, BYTE, CUR, CUX, DOUBLE, DWORD, EXT, INTEGER, LONG, PTR, QUAD, SINGLE, STRING, STRINGZ, WORD, WSTRING, WSTRINGZ und ARRAY. Das Schl?sselwort ARRAY wird in Verbindung mit einem der anderen Typen verwendet, um ein gesamtes Array dieses Typs anzugeben. Zum Beispiel:

DECLARE SUB KerPlunk(INTEGER ARRAY, DOUBLE)

deklariert eine Prozedur namens KerPlunk , die ein gesamtes Integer-Array und eine Variable mit doppelter Genauigkeit als Parameter akzeptiert. Sie k?nnen die Parameter auch mit dem Schl?sselwort AS benennen:

DECLARE SUB KerPlunk(iArray() AS INTEGER, dVar AS DOUBLE)

Die folgenden vier Declare-Anweisungen sind ?quivalent:

DECLARE SUB KerPlunk(x) ', wenn DEFINT A-Z wirksam ist

DECLARE SUB KerPlunk(x%)

SUB Plunk(x ALS INTEGER) DEKL?RIEREN

DECLARE SUB KerPlunk(INTEGER)

Bei der ?bergabe von Parametern per Referenz (BYREF) wird die Adresse der an die Routine ?bergebenen Variablen auf dem Stapel abgelegt. Wenn sie als Wert (BYVAL) ?bergeben werden, werden die tats?chlichen Daten auf dem Stapel abgelegt. Mit den Schl?sselw?rtern BYVAL oder BYREF k?nnen Sie angeben, dass ein Parameter immer in einem bekannten Format ?bergeben werden soll.

Durch die Verwendung von ANY wird die Typpr?fung f?r einen bestimmten Parameter deaktiviert und die Adresse der Variablen auf dem Stapel ?bergeben. Da sich das interne Format von Variablen je nach Typ stark unterscheidet, m?ssen Sie vorsichtig sein und sicherstellen, dass Ihr Code den Datentyp bei jedem Aufruf kennt. Normalerweise wird ein zweiter Parameter verwendet, um den tats?chlichen Typ des ANY-Parameters anzugeben.

Wenn eine Unter-/Funktionsdefinition entweder einen BYREF-Parameter oder einen Zeigervariablenparameter angibt, kann der aufrufende Code stattdessen frei ein BYVAL DWORD oder einen Zeiger ?bergeben. Obwohl die Verwendung der expliziten BYVAL-?berschreibung im aufrufenden Code optional ist, wird sie aus Gr?nden der ?bersichtlichkeit empfohlen. Es ist notwendig, alle Zeigerparameter explizit als BYVAL zu deklarieren (BYVAL x AS BYTE PTR). Andernfalls wird beim Kompilieren der Fehler 549 (?BYVAL erforderlich mit Zeigern?) generiert.

Weitere Informationen zur Parameter?bergabe BYVAL/BYREF/BYCOPY finden Sie im Thema CALL-Anweisung.

Mit OPTIONAL/OPT

DECLARE-Anweisungen k?nnen einen oder mehrere Parameter als optional angeben, indem sie dem Parameter entweder das Schl?sselwort OPTIONAL (oder die Abk?rzung OPT) voranstellen. Optionale Parameter sind nur mit den Aufrufkonventionen CDECL oder SDECL zul?ssig, nicht mit BDECL.

Wenn ein Parameter als optional deklariert wird, sind alle nachfolgenden Parameter in der Deklaration ebenfalls optional, unabh?ngig davon, ob sie eine explizite OPTIONAL- oder OPT-Direktive angeben oder nicht. Die folgenden zwei Zeilen sind ?quivalent, wobei sowohl der zweite als auch der dritte Parameter optional sind:

DECLARE SUB sABC(a&, OPTIONAL BYVAL b&, OPTIONAL BYVAL c&) AS LONG

DECLARE SUB sABC(a&, OPT BYVAL b&, BYVAL c&) AS LONG

VARIANT-Variablen eignen sich besonders gut zur Verwendung als optionaler Parameter. Wenn der aufrufende Code einen optionalen VARIANT-Parameter (BYVAL oder BYREF) wegl?sst, ersetzen PowerBASIC (und die meisten anderen Compiler) eine Variante vom Typ %VT_ERROR, die einen Fehlerwert von %DISP_E_PARAMNOTFOUND (&H80020004) enth?lt. In diesem Fall k?nnen Sie diesen Wert direkt pr?fen oder mit der Funktion ISMISSING() ermitteln, ob der Parameter physisch ?bergeben wurde oder nicht.

Wenn optionale Parameter (au?er VARIANT) im aufrufenden Code weggelassen werden, wird der normalerweise f?r diese Parameter reservierte Stapelbereich mit Nullen gef?llt.

Wenn der Parameter als BYVAL-Parameter definiert ist, hat er den Wert Null. F?r TYPE- oder UNION-Variablen, die BYVAL ?bergeben werden, ?bergibt der Compiler eine Zeichenfolge bin?rer Nullen der L?nge SIZEOF (Typ _oder_ Union _var).

Wenn der Parameter als BYREF-Parameter definiert ist, ist VARPTR (Varname) gleich Null; Wenn dies zutrifft, f?hrt jeder Versuch, Varname in Ihrem Code zu verwenden, zu einer allgemeinen Schutzverletzung oder einer Speicherbesch?digung. Sie sollten zun?chst die Funktion ISMISSING() verwenden, um festzustellen, ob der Zugriff auf den Parameter sicher ist.

AS-Typ

Sie k?nnen den Datentyp angeben, den eine Funktion an den aufrufenden Code zur?ckgibt. Wenn Sie keinen Typ angeben, geht PowerBASIC davon aus, dass die Funktion den durch eine DEF-Typanweisung angegebenen Datentyp zur?ckgibt. Wenn jedoch kein DEF-Typ oder AS-Typ angegeben wurde, wird ein Fehler bei der Kompilierung generiert.

Daher gibt es zwei M?glichkeiten, den R?ckgabetyp einer Funktion anzugeben:

Beispielsweise sind die folgenden Anweisungn ?quivalent:

DECLARE FUNCTION aFunction?()

FUNCTION aFunction() ALS BYTE DEKLARIEREN

W?hrend die meisten FUNCTION-Aufrufkonventionen in der Branche ziemlich genau definiert sind, gibt es einige Ausnahmen. Bei Funktionen, die einen Quad-Integer-Wert zur?ckgeben, geben einige Programmiersprachen (einschlie?lich PowerBASIC) den Quad-Wert in der FPU zur?ck, w?hrend andere ihn in EDX:EAX zur?ckgeben. PowerBASIC erkennt automatisch die von importierten Funktionen verwendete Methode und passt sich entsprechend an. Diese Funktion gibt es jedoch nicht bei anderen Compilern. Daher empfehlen wir Ihnen, QUAD FUNCTIONS nicht zu EXPORTIEREN, es sei denn, auf sie wird nur von PowerBASIC-Programmen zugegriffen. Eine einfache ?quivalente Funktionalit?t w?re die R?ckgabe des quad-ganzzahligen Werts an den Aufrufer in einem BYREF QUAD-Parameter.

Einschr?nkungen

Eine Unter-/Funktion kann innerhalb desselben Moduls importiert und exportiert werden. Das hei?t, eine Funktion im Modul kann als EXPORT angegeben werden, w?hrend eine DECLARE-Anweisung im selben Modul sie durch die Option LIB ?filename.dll? als importierte Funktion angibt, solange FILENAME.DLL der Name des Moduls ist. Dies kann besonders n?tzlich sein, wenn Sie eine #INCLUDE-Datei mit allen DECLARE-Anweisungen f?r ein Projekt erstellen m?chten.

Verifiziertes Beispiel: DECLARE - externe Funktion importieren

Beispieldatei: examples/basic/help_declarations/help_declare.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_declarations/help_declare.pb -o tmp/help_declaration_samples/help_declare.exe and executed with exit code 0.

DECLARE FUNCTION GetTickCount LIB "kernel32.dll" ALIAS "GetTickCount" () AS DWORD

FUNCTION PBMAIN() AS LONG
    LOCAL t AS DWORD
    t = GetTickCount()
END FUNCTION

Verhalten: Ruft die Win32-Funktion auf und prueft, dass die Deklaration gelinkt wird. Focus statement: DECLARE FUNCTION GetTickCount LIB "kernel32.dll" ALIAS "GetTickCount" () AS DWORD

Siehe auch

  • #EXPORT
  • #LINK
  • CALL
  • CALL DWORD
  • FASTPROC
  • FUNCTION/END FUNCTION
  • IMPORT
  • Ich vermisse
  • SUB/END SUB
  • THREAD CREATE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


DIM ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? DIM

DIM

Deklarieren und dimensionieren

Typ:Anweisung |Kategorie:Variablen und Umfang

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIM var [( subscripts )] [AS [GLOBAL | INSTANCE | LOCAL | STATIC | THREADED] type ] [PTR | POINTER] [AT address ] [, ...]
DIM var[( subscripts )] ' var may include a type-specifier
Scalar variables:
DIM var AS [GLOBAL | INSTANCE | LOCAL | STATIC | THREADED] type [PTR |POINTER] [, ...]
DIM var ' var must include a type-specifier

Beschreibung

DIM deklariert var als eine Variable oder ein Array, dessen Typ durch Anh?ngen eines Typbezeichners an den Namen oder durch Verwendung des AS-Typschl?sselworts angegeben wird. Wenn die AS-Klausel verwendet wird, darf der Variablenname nicht mit einem Typspezifizierzeichen enden.

DIM kann nur innerhalb eines SUB , FUNCTION , METHOD oder PROPERTY verwendet werden. Au?erhalb von Subs, Funktionen, Methoden oder Eigenschaften verwenden Sie GLOBAL oder INSTANCE, um Variablen und Arrays zu deklarieren.

DIM kann auch zur Dimensionierung eines ?absoluten Arrays? verwendet werden ? eines Arrays, das einen bestimmten Speicherort einnimmt. Dies kann n?tzlich sein, um einen Array-Typ dynamisch direkt ?ber einen vorhandenen Speicherblock zu ??berlagern? (bei dem es sich um einen anderen Array-Typ oder eine andere Datenstruktur handeln kann). Dies w?rde eine Union-?hnliche Overlay-Struktur bilden. Siehe unten.

Dar?ber hinaus ist es m?glich, mit der DIM-Anweisung ein Array von Zeigern zu erstellen, und zwar auch an einer bestimmten Stelle im Speicher. Dies wird als ?absolutes Zeiger-Array? bezeichnet.

Dimensionierung von Arrays

Indizes k?nnen f?r jedes dimensionierte Array eine der folgenden Formen annehmen:

(a) Eine durch Kommas getrennte Liste von einem oder mehreren Long-Integer-Ausdr?cken, die jeweils eine Dimension des Arrays definieren. Dieses Formular wird verwendet, um Arrays zu deklarieren, deren Indexbereich bei 0 beginnt. Die folgenden Zeilen sind beispielsweise ?quivalente M?glichkeiten zur Dimensionierung desselben Arrays:

DIM lArray(20) AS LONG ' Mit einer Klausel vom Typ AS

DIM lArray&(20) ' Mit einem Typbezeichner

Beide Zeilen oben definieren ein eindimensionales Long-Integer-Array mit 21 Elementen, von lArray(0) bis einschlie?lich lArray(20). Die zweite Zeile verwendet ein Typspezifizierersymbol, um den Datentyp anzugeben, und verwendet eine vereinfachte Syntax (nachgestellte Klauseln/Schl?sselw?rter sind nicht zul?ssig). Die vereinfachte Syntax ist nur f?r Datentypen g?ltig, die ein Typspezifizierersymbol haben ($, !, @, @@, #, ##, %, &, &&, ?, ??, ???), oder der Spezifizierer kann weggelassen werden, wenn eine DEF-Typanweisung in Kraft ist. Der Spezifizierer muss weggelassen werden, wenn #DIM ALL wirksam ist.

Deklarationen mehrdimensionaler Arrays haben die folgenden Formen:

DIM sArray(20,40,2) ALS STRING

DIM sArray$(20,40,2)

Diese beiden Codezeilen definieren ein dynamisches String-Array mit drei Dimensionen, 21 Elemente mal 41 Elemente mal 3 Elemente, also insgesamt 2583 String-Elemente. Wie zuvor verwendet die zweite Zeile die vereinfachte Syntaxform.

(b) Eine durch Kommas getrennte Liste, in der sowohl die obere als auch die untere tiefgestellte Grenze explizit f?r jede Dimension des Arrays deklariert werden. F?r jede Dimension wird zuerst die Untergrenze aufgef?hrt, gefolgt vom Schl?sselwort TO und anschlie?end die Obergrenze. Zum Beispiel:

DIMME MyArray(1 BIS 20) SO LANG

definiert ein eindimensionales Array mit 20 Elementen, von MyArray(1) bis MyArray(20). Die Untergrenze muss nicht Null oder Eins sein; zum Beispiel:

DIM SalesByYear(1980 TO 2000) ALS INTEGER

DIM SalesByYear%(1980 BIS 2000)

Jedes Array kann auf Elemente im Bereich von -2.147.483.648 bis 2.147.483.647 zugreifen. Es wird empfohlen, jeder DIM-Anweisung, die eine explizite Typklausel verwendet, eine explizite Variablenbereichsklausel ( GLOBAL / LOCAL / STATIC , THREADED, INSTANCE ) hinzuzuf?gen. Siehe Einschr?nkungen unten.

Array-Initialisierung und absolute Arrays

PowerBASIC generiert eine Fehlermeldung, wenn es auf ein Array trifft, das nicht dimensioniert wurde. Wenn das Array bereits dimensioniert wurde, wird die DIM-Anweisung ignoriert. Es wird kein neues Array erstellt und kein Laufzeitfehler generiert.

Wenn ein Programm zum ersten Mal ausgef?hrt wird, setzt PowerBASIC jedes Element eines numerischen Arrays auf Null und jedes Element regul?rer String-Arrays auf einen Null-String (L?nge Null). Wenn jedoch ein absolutes Array dimensioniert ist (an einer bestimmten Stelle im Speicher unter Verwendung der AT-Adresssyntax), initialisiert PowerBASIC den vom Array belegten Speicher nicht. Wenn ein absolutes Array gel?scht wird, wird der Speicher au?erdem nicht freigegeben. Dies bietet einen leistungsstarken Mechanismus zum Erstellen von Union-?hnlichen Overlay-Strukturen im Speicher.

Die h?ufigste Verwendung eines absoluten Arrays ist die direkte Bearbeitung von Visual Basic-Arrays aus einer DLL. Dazu m?ssen ein Zeiger auf das Array, die Elementgr??e und die Anzahl der Elemente ermittelt werden. Mit diesen Informationen kann in PowerBASIC ein absolutes Array dimensioniert und der Array-Speicher direkt manipuliert werden. Eine weitere h?ufige Verwendung besteht in der Verwendung eines gro?en dynamischen oder String-Speicherblocks mit fester L?nge, ?berlagert mit einem absoluten numerischen Array.

Bei der Verwendung absoluter Arrays ist Vorsicht geboten, da der Inhalt eines absoluten Arrays nur f?r den Speicherbereich g?ltig sein kann, auf den das Array verweist. Wenn ein absolutes Array auf Speicher verweist, der f?r die Prozedur LOCAL ist, werden die Array-Inhalte ung?ltig, wenn der Zielspeicherblock freigegeben wird. Beispielsweise durch explizites Freigeben des Speicherblocks oder Beenden der Prozedur selbst. Der Versuch, auf den freigegebenen absoluten Array-Speicher zuzugreifen, l?st wahrscheinlich eine allgemeine Schutzverletzung (GPF) aus. Auf dieser Grundlage sollten absolute Arrays LOCAL f?r die Prozedur sein, in der sie verwendet werden sollen.

W?hrend PowerBASIC LBOUND-Werte ungleich Null unterst?tzt, generiert PowerBASIC den effizientesten Code, wenn der LBOUND-Parameter weggelassen wird (d. h. das Array verwendet den Standard-LBOUND von Null). Sie sollten auch vermeiden, einen expliziten LBOUND von Null anzugeben, da dies zu einer geringen Effizienzeinbu?e ohne nennenswerte Vorteile f?hrt

Deklarieren von Skalarvariablen (Nicht-Array-Variablen).

Wenn Sie #DIM ALL oder OPTION EXPLICIT angegeben haben, m?ssen Sie alle in Ihren Programmen verwendeten Variablen deklarieren. PowerBASIC stellt f?r diesen Job eine Variante der DIM-Anweisung bereit, da f?r Skalarvariablen eine geringere Syntax erforderlich ist. Das Folgende ist eine vereinfachte Syntax f?r DIM, die nur f?r Skalarvariablen gilt:

DIM var AS [GLOBAL | INSTANZ | LOCAL | STATIC | GEWINDE] Typ [PTR | ZEIGER] [, ...]

DIM var ' var muss einen Typbezeichner enthalten

Hier sind einige Beispiele f?r Variablendeklarationen:

DIM a AS LOCAL INTEGER

DIM b ALS STATISCHES WORT

DIM c ALS GLOBAL DOUBLE POINTER

DIM d AS STRINGZ * 255

Abmessung als Gewindeschnur

DIM f ALS INSTANZ SINGLE

AS-Typ

GANZE ZAHL

Ganze Zahl

Doppelwort

Lange Ganzzahl

Quad-Ganzzahl

EINZEL

Single-precision floating-point

DOPPELT

Double-precision floating-point

Extended-precision floating-point

ERWEITERT

Extended-precision floating-point

W?hrung

W?HRUNG

W?hrung

Extended-currency

W?HRUNGX

Extended-currency

STRING

Dynamische Zeichenfolge (variable L?nge).

WSTRING

Dynamische Unicode-Zeichenfolge

STRING * x

Zeichenfolge mit fester L?nge

ASCIIZ * x

Mit Null terminierte Zeichenfolge

ASCIZ * x

Mit Null terminierte Zeichenfolge

STRINGZ * x

Mit Null terminierte Zeichenfolge

WSTRINGZ * x

Unicode-Null-terminierte Zeichenfolge

Zeiger

Zeiger

Zeiger

VARIANTE

Variante

IAUTOMATION

Automatisierungsschnittstelle

IDISPATCH

Versandschnittstelle

UNBEKANNT

Direkte Schnittstelle

16-Byte-GUID-Zeichenfolge

Feldzeichenfolge

Einschr?nkungen

LOCAL ASCIIZ, LOCAL-Strings mit fester L?nge und LOCAL UDTs werden im Stapelrahmen der Unterfunktion/Funktion/Methode/Eigenschaft erstellt, in der sie deklariert sind. Sie m?ssen daher darauf achten, dass die kombinierte Gr??e der lokalen Variablen die zugewiesene Stapelgr??e nicht ?berschreitet. Sofern Sie nichts anderes angeben, legt PowerBASIC eine Standard-Stack-Gr??e von 1 MB fest. Wenn mehr Stapelplatz ben?tigt wird, k?nnen Sie diesen mit dem #STACK-Metastament zuweisen. Bei GLOBAL-, INSTANCE-, THREADED- oder STATIC-Variablen gibt es keine derartigen Einschr?nkungen.

Wenn eine DIM-Anweisung (ohne explizite G?ltigkeitsbereichsklausel) verwendet wird, um eine Variable in einer Prozedur zu deklarieren, und eine identische Variable bereits als GLOBAL deklariert wurde, erh?lt die Variable in der Prozedur den G?ltigkeitsbereich GLOBAL. Zum Beispiel:

GLOBAL xyz SO LANG

SUB MySub

DIM xyz SO LANG

' Hier ist xyz eine GLOBALE Variable

END SUB

Um sicherzustellen, dass der Variablenbereich LOCAL f?r die Unterfunktion/Funktion/Methode/Eigenschaft ist, verwenden Sie eine LOCAL-Anweisung anstelle einer DIM-Anweisung. Alternativ k?nnen Sie der DIM-Anweisung eine explizite Bereichsklausel hinzuf?gen. Zum Beispiel:

GLOBAL xyz SO LANG

[Anweisungn]

SUB MySub

DIM xyz AS LOCAL LONG

' Hier ist xyz eine LOKALE Variable

END SUB

Zeigervariablen deklarieren

Ein Zeiger muss deklariert werden, bevor er verwendet werden kann. Mit der DIM-Anweisung deklarieren Sie Zeiger und beschreiben den Datentyp, auf den sie verweisen. Wenn ein Zeiger deklariert wird, wird er automatisch auf den Wert Null initialisiert. Dies wird als Nullzeiger bezeichnet. Sie m?ssen daran denken, es mit einer g?ltigen Adresse zu initialisieren, sonst erhalten Sie eine allgemeine Schutzverletzung (GPF). Die Syntax zum Deklarieren von Zeigervariablen ?hnelt der von regul?ren Variablen:

DIM var[(subscripts)] AS [GLOBAL | INSTANZ | LOCAL | STATIC | GEWINDE] Typ [PTR | ZEIGER] [, ...]

Hier sind einige Beispiele f?r Zeigervariablendeklarationen:

DIM a AS BYTE PTR

DIM b ALS INTEGER-ZEIGER

DIM c AS STRING PTR * 25

DIM d AS MyType POINTER

DIM e(500) AS INTEGER PTR

Zeiger selbst werden als DWORD-Werte gespeichert.

Verifiziertes Beispiel: DIM - Prozedurvariable deklarieren

Beispieldatei: examples/basic/help_declarations/help_dim.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_declarations/help_dim.pb -o tmp/help_declaration_samples/help_dim.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    DIM value AS LONG
    value = 42
    IF value <> 42 THEN FUNCTION = 1
END FUNCTION

Verhalten: Deklariert eine lokale Prozedurvariable und prueft die Zuweisung. Focus statement: DIM value AS LONG

Siehe auch

  • #DIM
  • ARRAYATTR
  • L?SCHEN
  • GLOBAL
  • INSTANCE
  • Just what is COM?
  • LOCAL
  • REDIM
  • ZUR?CKSETZEN
  • STATIC
  • GEWINDE
  • Variablen
  • Variabler Umfang
  • Was ist ?berhaupt ein Objekt?

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ENUM/END ENUM-Anweisungen ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? ENUM/END ENUM-Anweisungen

ENUM/END ENUM-Anweisungen

Erstellt eine Gruppe logisch verkn?pfter numerischer Konstanten

Typ:Anweisung |Kategorie:Typen

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ENUM Name [SINGULAR] [BITS] [AS COM]
    EquateName [= value ]
    ...
END ENUM

Beschreibung

DerENUM...END ENUM block deklariert einen Satz benannter Ganzzahlkonstanten unter einem gemeinsamen Typ. Enum-Deklarationen m?ssen im Modulbereich (au?erhalb jeder Prozedur) erscheinen. Das erste Equate ist standardm??ig 0, sofern kein expliziter Wert angegeben wird. Nachfolgend entspricht der Erh?hung um 1.

Der Enum-Name kann als Typ f?r LOCAL-, GLOBAL- und Parameterdeklarationen verwendet werden.

Beispiel

ENUM Colors
    Red = 1
    Green
    Blue
END ENUM

FUNCTION PBMAIN () AS LONG
    LOCAL c AS Colors
    c = Green
    FUNCTION = c
END FUNCTION

Dieses Programm gibt 2 zur?ck, den zugewiesenen Wert Green.

Generierter Assembler-Code

Kompilieren mit:

PBXB64 example.pb --asmout example.asm

Aufz?hlungen werden zu ganzzahligen Sofortwerten kompiliert. Die Zuweisung an die lokale Variable ist eine direkte, unmittelbare Bewegung:

    mov rbx, 2
    mov [rbp-24], rbx

Hinweise

  • Platz ENUM Bl?cke im Modulbereich, nicht innerhalb von Funktionen.
  • PBXB64 unterst?tzt derzeit die Basisversion ENUM...END ENUM Form; SINGULAR, BITS, UndAS COM Modifikatoren k?nnen analysiert werden, haben aber nur begrenzte Wirkung.

Verifiziertes Beispiel: ENUM - benannte Integer-Konstanten deklarieren

Beispieldatei: examples/basic/help_declarations/help_enum.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_declarations/help_enum.pb -o tmp/help_declaration_samples/help_enum.exe and executed with exit code 0.

ENUM Color
    Red = 1
    Green = 2
END ENUM

FUNCTION PBMAIN() AS LONG
    LOCAL c AS Color
    c = Green
    IF c <> 2 THEN FUNCTION = 1
END FUNCTION

Verhalten: Deklariert einen Enum-Typ und weist einen benannten Wert zu. Focus statement: ENUM Color

Siehe auch

  • CONST
  • TYP
  • GLOBAL
  • Erkl?rungsreferenz

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FUNCTION / END FUNCTION - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Prozeduren & Bereich › FUNCTION / END FUNCTION
Hilfe zum PBXB64-Compiler

FUNCTION / END FUNCTION

Definiert eine Prozedur, die einen Wert zurückgibt und in Ausdrücken verwendet werden kann.

Kind: Anweisung | Category: Procedures

PBXB64 Status: VERFÜGBAR

PBXB64 Certification: [ZERTIFIZIERT GETESTET]

Syntax

FUNCTION ProcName [ALIAS "AliasName"] [( arguments )] [AS Type]
  [ statements ]
  [ FUNCTION = ReturnValue ]
END FUNCTION

Description

FUNCTION definiert einen aufrufbaren Block, der einen Wert zurückgibt. Sie können ihn in jedem Ausdruck verwenden, oder ihn wie eine normale Prozedur aufrufen, wenn nur Nebenwirkungen nötig sind.

Der Rückgabetyp wird mit AS Type angegeben. Parameter können BYVAL, BYREF, OPTIONAL und Typmodifikatoren verwenden. Interne Funktionen brauchen vor dem ersten Gebrauch kein ausdrückliches DECLARE; importierte DLL-Prozeduren schon.

Ein Funktionswert kann durch Zuweisung an den Funktionsnamen oder an FUNCTION gesetzt werden. EXIT FUNCTION verlässt die Prozedur vorzeitig. Arrays können nicht direkt zurückgegeben werden; übergeben Sie sie stattdessen BYREF.

Example

' Getestetes Beispiel: examples/basic/test_function_return.pb
FUNCTION Foo() AS LONG
    FUNCTION = 42
END FUNCTION

FUNCTION PBMAIN() AS LONG
    PBMAIN = Foo()
END FUNCTION

Hinweise

  • Verschachteln Sie keine Prozeduren in einem FUNCTION-Block.
  • Verwenden Sie DECLARE für importierte Routinen und ALIAS, wenn der externe Name vom PowerBASIC-Namen abweicht.
  • Für größere Parameterpakete ist ein TYPE per BYREF oft die bessere Wahl.

Verifiziertes Beispiel: FUNCTION - Wert zurueckgeben

Beispieldatei: examples/basic/help_declarations/help_function.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_declarations/help_function.pb -o tmp/help_declaration_samples/help_function.exe and executed with exit code 0.

FUNCTION AddOne(BYVAL x AS LONG) AS LONG
    FUNCTION = x + 1
END FUNCTION

FUNCTION PBMAIN() AS LONG
    IF AddOne(4) <> 5 THEN FUNCTION = 1
END FUNCTION

Verhalten: Definiert eine Funktion und prueft ihren Rueckgabewert. Focus statement: FUNCTION AddOne(BYVAL x AS LONG) AS LONG

See Also

  • SUB / END SUB
  • ERKLÄREN
  • CALL
  • BYVAL
  • BYREF
  • ALIAS

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


GLOBAL ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? GLOBAL

GLOBAL

Global deklarieren (gemeinsam genutzt)

Typ:Anweisung |Kategorie:Variablen und Umfang

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GLOBAL variable [()] [ AS type ] [, variable [()]] [, ...]
GLOBAL variable [()] [, variable [()]] [, ...] AS type

Beschreibung

GLOBAL deklariert die angegebene(n) Variable(n) als global f?r das gesamte Programm. Dadurch erh?lt eine Prozedur Zugriff auf Variable(n), ohne diese als Parameter ?bergeben zu m?ssen. Um ein Array als globale Variable zu deklarieren, verwenden Sie einen leeren Satz Klammern in der Variablenliste:

GLOBAL MyArray%()

GLOBAL StringArray() AS STRING

Anschlie?end m?ssen Sie die DIM- oder REDIM-Anweisungen verwenden, um das Array innerhalb einer Prozedur zu dimensionieren. Ein guter Ort hierf?r ist Ihre WINMAIN- oder PBMAIN-Funktion.

Wenn ein Array au?erhalb einer Prozedur als GLOBAL definiert ist, sollten Sie aus Gr?nden der ?bersichtlichkeit und der Kompatibilit?t mit zuk?nftigen Versionen von PowerBASIC das Schl?sselwort GLOBAL in die DIM-Anweisung aufnehmen:

GLOBAL a() ALS STRING

FUNCTION PBMAIN

DIMMEN Sie a(1 BIS 500) ALS GLOBAL STRING

[Anweisungn]

ENDFUNKTION

Die GLOBAL-Anweisung akzeptiert m?glicherweise eine Liste von Variablen, die alle durch die darauf folgenden Typdeskriptorschl?sselw?rter definiert werden. Zum Beispiel:

GLOBAL aaa, bbb, ccc ALS INTEGER

GLOBAL vptr, aptr() AS LONG PTR

Einschr?nkungen

GLOBAL-Variablen werden nicht zwischen Programmen und DLLs oder zwischen mehreren Instanzen derselben DLL gemeinsam genutzt. Das hei?t, eine GLOBAL-Variable ist nur innerhalb ihres eigenen Moduls global. Der einfachste Weg, eine Variable einer DLL zug?nglich zu machen, besteht darin, die Variable BYREF (als Referenz) an die Ziel-DLL zu ?bergeben. Der DEF-Typ hat keine Auswirkung auf Variablen, die durch eine GLOBAL-Anweisung definiert werden.

Verifiziertes Beispiel: GLOBAL - modulweiter Speicher

Beispieldatei: examples/basic/help_declarations/help_global.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_declarations/help_global.pb -o tmp/help_declaration_samples/help_global.exe and executed with exit code 0.

GLOBAL g_value AS LONG

FUNCTION PBMAIN() AS LONG
    g_value = 77
    IF g_value <> 77 THEN FUNCTION = 1
END FUNCTION

Verhalten: Deklariert modulweiten Speicher und liest ihn in PBMAIN. Focus statement: GLOBAL g_value AS LONG

Siehe auch

  • DIM
  • INSTANCE
  • LOCAL
  • STATIC
  • GEWINDE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOCAL � PBXB64-Compiler-Hilfe

Startseite � Funktionen � LOCAL

LOCAL

Als lokal deklarieren

Typ:Anweisung |Kategorie:Variablen und Umfang

PBXB64-Status:VERF�GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

LOCAL variable [()] [AS type ] [, variable [()]] [...]
LOCAL variable [()] [, variable [()]] [, ...] AS type

Beschreibung

Die LOCAL-Anweisung ist nur innerhalb einer Sub, Funktion, Methode oder Eigenschaft g�ltig. Lokale Variablen verlieren ihre Werte, wenn die Prozedur endet. Speicherplatz f�r lokale Variablen wird auf dem Stapel zugewiesen, und jede lokale Variable wird bei jedem Aufruf der einschlie�enden Prozedur auf Null (oder bei String-Variablen auf einen leeren String) initialisiert.

Um ein Array als lokale Variable zu deklarieren, verwenden Sie einen leeren Satz Klammern in der Variablenliste: Anschlie�end k�nnen Sie das Array mit der DIM-Anweisung dimensionieren.

LOCAL MyArray%()

LOKALES StringArray() ALS STRING

Die LOCAL-Anweisung kann optional eine Liste von Variablen akzeptieren, die alle durch das ihnen folgende Typdeskriptor-Schl�sselwort definiert werden. Zum Beispiel:

LOCAL aaa, bbb, ccc ALS INTEGER

LOKALER vptr, aptr() AS LONG PTR

Beispiel

FUNCTION PBMAIN () AS LONG
    LOCAL a AS LONG
    LOCAL b AS LONG
    a = 3
    b = 4
    FUNCTION = a + b
END FUNCTION

Dieses Programm gibt 7 zur�ck. Beides aUndb werden im Stapelrahmen der Funktion zugewiesen und vor den Zuweisungen auf Null initialisiert.

Generierter Assembler-Code

PBXB64 example.pb --asmout example.asm

Der Compiler reserviert Stapelplatz f�r die beiden lokalen Variablen und initialisiert sie auf Null. Der Zugriff auf die Variablen erfolgt �ber [rbp-N] Slots:

    xor rbx, rbx
    mov [rbp-24], rbx    ; zero a
    xor rbx, rbx
    mov [rbp-32], rbx    ; zero b
    mov rbx, 3
    mov [rbp-24], rbx    ; a = 3
    mov rbx, 4
    mov [rbp-32], rbx    ; b = 4
    mov r10, [rbp-24]
    mov rbx, r10
    mov r10, [rbp-32]
    add rbx, r10
    mov [rbp-16], rbx    ; return slot

Einschr�nkungen

Der DEF-Typ hat keine Auswirkung auf Variablen, die durch eine LOCAL-Anweisung definiert werden.

Verifiziertes Beispiel: LOCAL - prozedurlokaler Speicher

Beispieldatei: examples/basic/help_declarations/help_local.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_declarations/help_local.pb -o tmp/help_declaration_samples/help_local.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    LOCAL value AS LONG
    value = 17
    IF value <> 17 THEN FUNCTION = 1
END FUNCTION

Verhalten: Deklariert expliziten prozedurlokalen Speicher. Focus statement: LOCAL value AS LONG

Siehe auch

  • DIM
  • GLOBAL
  • INSTANCE
  • STATIC
  • GEWINDE
← LOC Nach oben SPERREN →

Deklarationsregeln

LOCAL-Deklarationen sollen G�ltigkeitsbereich, Initialisierung, Typsuffixe, ausdr�ckliche AS-Klauseln, Arrays, feste Zeichenfolgen und die Interaktion mit #DIM ALL dokumentieren. Beispiele sollen zeigen, wo die Variable sichtbar wird und wo ihr G�ltigkeitsbereich endet.

Pr�fung

Ein vollst�ndiger Test soll mindestens eine skalare und eine String- oder Array-Lokalvariable deklarieren, Werte zuweisen, bei Bedarf eine weitere Prozedur aufrufen und zeigen, dass fremde Prozeduren den lokalen Speicher nicht sehen.


REDIM ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? REDIM

REDIM

Wird auf der Prozedurebene verwendet

Typ:Anweisung |Kategorie:Variablen und Umfang

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

REDIM [PRESERVE] array ([ subscripts ] ) [AS type ] [AT address ] [, ...]

Beschreibung

Mit der REDIM-Anweisung k?nnen dynamische Arrays (einschlie?lich String-Arrays) gel?scht und neu dimensioniert werden. Es ist eigentlich nur eine Abk?rzung f?r den zweistufigen Prozess ERASE x(), gefolgt von DIM x(). REDIM verwendet dieselbe grundlegende Syntax wie die DIM-Anweisung.

array ist der Name des Arrays, und subscripts ist entweder eine Gruppe einzelner Ganzzahlen (eine pro Dimension eines bestimmten Arrays) oder eine Gruppe von Bereichen (REDIM arr1(5 TO 25, 1 TO 4, 3 TO 8)), getrennt durch Kommas.

AS-Typ

Die AS-Typklausel ist optional, es wird jedoch empfohlen, jeder REDIM-Anweisung, die eine explizite Typklausel verwendet, eine explizite Variablenbereichsklausel (LOCAL/STATIC/GLOBAL/THREADED/INSTANCE) hinzuzuf?gen.

AT-Adresse

Die AT-Adressklausel gibt an, dass das Array ein absolutes Array sein soll. Absolute Arrays werden durch die REDIM-Anweisung nicht zur?ckgesetzt, und sie werden auch nicht zur?ckgesetzt, wenn die Unter-/Funktions-/Methoden-/Eigenschaftsfunktion beendet wird, sie k?nnen jedoch mit der RESET-Anweisung zur?ckgesetzt werden. Weitere Informationen zu absoluten Arrays finden Sie in der Diskussion im DIM-Thema.

BEWAHREN

Das Schl?sselwort PRESERVE weist den Compiler an, die Werte aller vorhandenen Elemente im Array beizubehalten. Wenn Sie beispielsweise ein Array mit 10 Elementen auf 20 Elemente REDIM PRESERVE setzen, behalten die ersten 10 Elemente ihren urspr?nglichen Wert. Die verbleibenden 10 Elemente werden auf Null initialisiert (oder null/leer im Fall eines String-Arrays). Wenn die Gr??e des Arrays auf eine kleinere Gr??e ge?ndert wird, bleibt die angegebene Anzahl von Elementen erhalten und die verbleibenden Elemente werden verworfen. Wenn PRESERVE angegeben ist, k?nnen Sie nur die Gr??e der oberen Grenze der letzten (?u?eren) Dimension des Arrays ?ndern. Arrays mit nur einer Dimension k?nnen jederzeit in der Gr??e ge?ndert werden.

In einer Prozedur k?nnen Sie REDIM verwenden, um ein Array, das als Argument ?bergeben wurde, neu zu dimensionieren. Das hei?t, wenn das komplette Array an die Prozedur ?bergeben wurde:

CALL RemoveDuplicates( CustomerNames$() )

' Mehr Code hier

SUB RemoveDuplicates( a$() )

' Doppelte Array-Werte entfernen

REDIM PRESERVE a$(1 TO NewCount&)

END SUB

REDIM kann auch verwendet werden, um die Gr??e von Static-, Global- und Instance-Arrays zu ?ndern.

Bei Verwendung ohne Indexparameter l?scht REDIM den gesamten Inhalt eines Arrays und gibt den verwendeten Speicher frei:

REDIM xyz&() ' Entspricht ERASE xyz&()

Einschr?nkungen

Bei Angabe von PRESERVE darf nur die Obergrenze der letzten (?u?eren) Dimension neu definiert werden.

Wenn eine REDIM-Anweisung ausgef?hrt wird, verschiebt sich die Position der Array-Elemente immer im Speicher; Der Deskriptorspeicherort des Arrays ( VARPTR ( arrayname ()) bleibt jedoch am urspr?nglichen Speicherort festgelegt. Wenn Sie REDIM verwenden, muss Ihr Code sicherstellen, dass alle Zeiger aktualisiert werden, die auf die Array-Datenspeicherorte ( STRPTR ( arrayname ( subscript )) f?r dynamische String-Arrays und VARPTR( arrayname ( subscript )) f?r alle anderen Array-Typen zielen.

W?hrend PowerBASIC untere Grenzwerte ungleich Null unterst?tzt, generiert PowerBASIC den effizientesten Code, wenn der untere Grenzwertparameter weggelassen wird (d. h. das Array verwendet den standardm??igen unteren Grenzwert von Null).

Verifiziertes Beispiel: REDIM - dynamisches Array anlegen

Beispieldatei: examples/basic/help_declarations/help_redim.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_declarations/help_redim.pb -o tmp/help_declaration_samples/help_redim.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    REDIM values(1 TO 3) AS LONG
    values(2) = 99
    IF values(2) <> 99 THEN FUNCTION = 1
END FUNCTION

Verhalten: Legt ein dynamisches Array an und prueft indexierten Zugriff. Focus statement: REDIM values(1 TO 3) AS LONG

Siehe auch

  • ARRAYATTR
  • DIM
  • L?SCHEN
  • ZUR?CKSETZEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GETEILT - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Datentypen & Variablen › GETEILT
Hilfe zum PBXB64-Compiler

GETEILT

Kompatibilitätsalias für GLOBAL.

Kind: Anweisung | Category: Variables & Scope

PBXB64 Status: VERFÜGBAR

PBXB64 Certification: [ZERTIFIZIERT GETESTET]

Syntax

SHARED variable [AS Type]
SHARED variable [, variable ...] AS Type

Description

PBXB64 akzeptiert SHARED als Synonym für GLOBAL in BASIC-Code. Damit wird modulgültiger Speicher deklariert, der in den Prozeduren desselben Programms oder derselben Bibliothek sichtbar ist.

Verwenden Sie SHARED, wenn Sie alten PowerBASIC-Quelltext übersetzen und das ursprüngliche Schlüsselwort im Code sichtbar lassen wollen.

Für neuen Code ist GLOBAL die klarere Schreibweise. Beide Formen erzeugen in PBXB64 dasselbe Speicherverhalten.

Example

' Getestete Stilvorlage: examples/basic/test_global_integer_size.pb
SHARED gCounter AS LONG

FUNCTION PBMAIN() AS LONG
    gCounter = gCounter + 1
    PBMAIN = gCounter
END FUNCTION

Hinweise

  • SHARED bedeutet hier nicht Dateisperr-Teilung, sondern das Geltungsbereichs-Schlüsselwort.
  • Das Alias bleibt aus Kompatibilitätsgründen erhalten.

Verifiziertes Beispiel: SHARED - GLOBAL-kompatibler Modulspeicher

Beispieldatei: examples/basic/help_declarations/help_shared.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_declarations/help_shared.pb -o tmp/help_declaration_samples/help_shared.exe and executed with exit code 0.

SHARED shared_value AS LONG

FUNCTION PBMAIN() AS LONG
    shared_value = 33
    IF shared_value <> 33 THEN FUNCTION = 1
END FUNCTION

Verhalten: Verwendet SHARED als von PBXB64 akzeptierte Modulspeicher-Deklaration. Focus statement: SHARED shared_value AS LONG

Praktische Verwendung

GETEILT gehoert zur Kategorie Variables & Scope. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' GETEILT mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

See Also

  • GLOBAL
  • LOCAL
  • STATIC
  • BASIC-Variablen und -Bereich


STATIC ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? STATIC

STATIC

Erkl?ren

Typ:Anweisung |Kategorie:Variablen und Umfang

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

STATIC variable [()] [AS type ] [, variable [()]]
STATIC variable [()] [, variable [()]] [, ...] AS type

Beschreibung

Die STATIC-Anweisung ist nur innerhalb einer Prozedur g?ltig. Statische Variablen behalten ihre Werte auch nach Beendigung der Prozedur. Eine statische Variable ist lokal f?r ihre Prozedur und kann ohne Konflikt denselben Namen wie andere Variablen in anderen Teilen des Programms haben.

Um ein Array als statische Variable zu deklarieren, verwenden Sie einen leeren Satz Klammern in der Variablenliste: Anschlie?end k?nnen Sie das Array mit der DIM-Anweisung dimensionieren.

STATIC MyArray%()

STATIC StringArray() AS STRING

Die STATIC-Anweisung kann optional eine Liste von Variablen akzeptieren, die alle durch das ihnen folgende Typdeskriptor-Schl?sselwort definiert werden. Zum Beispiel:

STATIC aaa, bbb, ccc ALS INTEGER

STATIC vptr, aptr() AS LONG PTR

Einschr?nkungen

Der DEF-Typ hat keine Auswirkung auf Variablen, die durch eine STATIC-Anweisung definiert werden.

Getesteter PBXB64-Umfang: Skalare prozedurlokale STATIC-Variablen behalten ihren Wert zwischen Aufrufen. Gleich benannte STATIC-Variablen in verschiedenen Prozeduren verwenden getrennten versteckten Speicher. Konstante skalare Initialisierer werden einmal auf diesen Speicher angewendet und nicht bei jedem Prozedureintritt erneut ausgefuehrt. Statische Arrays, UDT/static-string-Kombinationen und die vollstaendige Deklarationsmatrix bleiben breitere Kompatibilitaetsarbeit.

Verifiziertes Beispiel: STATIC - persistente skalare Lebensdauer

Beispieldatei: tests/pb/test_static_lifetime.pb

Validierungsnachweis: registered in tests/validate.toml and executed by python tests\validate.py --skip-build --lane pb_linkrun -j 1; the STATIC tests exit with code 0.

#COMPILE EXE
#DIM ALL

FUNCTION NextValue() AS LONG
    STATIC n AS LONG
    n = n + 1
    FUNCTION = n
END FUNCTION

FUNCTION OtherValue() AS LONG
    STATIC n AS LONG
    n = n + 10
    FUNCTION = n
END FUNCTION

FUNCTION PBMAIN() AS LONG
    LOCAL total AS LONG
    total = NextValue() * 10000
    total = total + NextValue() * 1000
    total = total + OtherValue() * 10
    total = total + NextValue()
    total = total + OtherValue()
    IF total <> 12123 THEN
        FUNCTION = 1
    ELSE
        FUNCTION = 0
    END IF
END FUNCTION

Verhalten: Prueft die Persistenz skalarer STATIC-Variablen zwischen Prozeduraufrufen und die Trennung gleich benannter Variablen in verschiedenen Funktionen; tests/pb/test_static_initializer.pb prueft zusaetzlich die einmalige konstante Initialisierung. Focus statement: STATIC n AS LONG

Siehe auch

  • DIM
  • GLOBAL
  • LOCAL
  • GEWINDE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SUB/END SUB-Anweisungen ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? SUB/END SUB-Anweisungen

SUB/END SUB-Anweisungen

Definieren Sie einen Subcode-Abschnitt.

Typ:Anweisung |Kategorie: Procedures

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SUB ProcName [ALIAS " AliasName "] [( arguments )] < Descriptors >
[ statements ]
END SUB

Beschreibung

Der gesamte ausf?hrbare Code muss sich in einem Sub, Function befinden. Methode, Eigenschaft oder FastProc-Block. Subs d?rfen nicht verschachtelt sein. Das hei?t, Sie k?nnen keinen Codeblock (Sub, Funktion, Methode, FastProc, Eigenschaft) innerhalb eines anderen Codeblocks definieren.

SUB und END SUB definieren einen unterprogramm?hnlichen Block von Anweisungen, der als Prozedur (oder Unterprogramm) bezeichnet wird und mit der CALL-Anweisung aufgerufen wird. Parameter k?nnen als Wert oder als Referenz ?bergeben werden. Ein Sub kann auch ohne die Verwendung der CALL-Anweisung aufgerufen werden. Wenn das CALL-Wort weggelassen wird, m?ssen auch die Klammern um die Argumentliste weggelassen werden.

In fr?heren Versionen von PowerBASIC mussten Sie eine explizite DECLARE-Anweisung erstellen, wenn Sie eine SUB- oder FUNCTION-Anweisung ausf?hren wollten, die nicht physisch vor dem Verweis darauf stand. Diese zus?tzliche Arbeit ist nicht mehr erforderlich, da PowerBASIC alle Weiterleitungsverweise auf interne Prozeduren automatisch aufl?st.

DECLARE-Anweisungen f?r eine aus einer DLL importierte Unterfunktion/Funktion m?ssen weiterhin vor jedem Verweis auf die Prozedur stehen.

ProcName

Der Name des Subs. ProcName muss eindeutig sein: Keine andere Variable, Funktion, Sub, Methode, Eigenschaft, FastProc oder Label kann ihn gemeinsam nutzen.

Zeichenfolgenliteral, das einen alternativen Namen f?r das Sub angibt, bei dem die Gro?-/Kleinschreibung beachtet wird. Dadurch k?nnen Sie ein Sub unter einem anderen eindeutigen Namen exportieren. Dies kann n?tzlich sein, wenn Sie einen langen Namen abk?rzen, einen aussagekr?ftigeren Namen angeben m?chten oder wenn der exportierte Name Zeichen enthalten muss, die in PowerBASIC unzul?ssig sind. AliasName ist der tats?chliche Name der Routine, wie er in der Exporttabelle angezeigt wird, und ProcName ist der Titel, den Sie in PowerBASIC verwenden k?nnen. Zum Beispiel:

SUB ShortName ALIAS ?LongProcName? () EXPORT STATIC

Die ALIAS-Klausel ist beim Exportieren von Prozeduren sehr wichtig. Das Weglassen der ALIAS-Klausel oder die falsche Gro?schreibung des Aliasnamens sind h?ufige Ursachen f?r ?Missing Export?-Fehler. Weitere Informationen finden Sie im Thema DECLARE.

Deskriptoren

Sie k?nnen optional ein oder mehrere Deskriptorw?rter hinzuf?gen (Export, Common, Private, ThreadSafe, Local, Static, BDecl, CDecl, SDecl), um bestimmte Funktionen bereitzustellen. Sie k?nnen dem SUB als durch Kommas getrennte Liste hinzugef?gt werden. Sie sollten beachten, dass sich einige davon gegenseitig ausschlie?en.

EXPORT

Dieser Deskriptor identifiziert eine Unter- oder Funktion, auf die zwischen Dynamic Link Libraries (DLLs) zugegriffen werden kann, und/oder die ausf?hrbare Hauptdatei, die sie verkn?pft. Wenn eine Prozedur nicht mit EXPORT markiert ist, wird sie vor diesen anderen Modulen ausgeblendet. Das EXPORT-Attribut kann zu einer an anderer Stelle definierten Unter-/Funktion hinzugef?gt werden, indem EXPORT in einer DECLARE-Anweisung angegeben wird. EXPORT kann sogar zu einer Unterfunktion/Funktion in einer SLL mit einer DECLARE im Hostmodul hinzugef?gt werden.

COMMON

Eine GEMEINSAME Unter-/Funktion ist eine Funktion, auf die von und zwischen verkn?pften Einheitenmodulen (Host oder SLL) verwiesen werden kann. Wenn Sie eine gemeinsame Sub- oder Funktion DEKLARIEREN, die in diesem Modul nicht vorhanden ist, wird davon ausgegangen, dass sie in einem separaten verkn?pften Modul (Host oder SLL) gefunden wird.

PRIVAT

Eine private Unter-/Funktionsfunktion ist eine Funktion, auf die nur innerhalb des aktuellen PowerBASIC-Programms oder der aktuellen PowerBASIC-Bibliothek zugegriffen werden kann. Auch wenn nichts angegeben ist, ist dies der Standardbetriebsmodus.

FADENSICHER

Mit der THREADSAFE-Option richtet PowerBASIC automatisch eine Semaphore ein, die es jeweils nur einem Thread erm?glicht, die Sub/Funktion auszuf?hren. Andere Aufrufer m?ssen warten, bis der erste Thread die THREADSAFE-Prozedur verl?sst, bevor sie beginnen d?rfen.

Dieser Deskriptor gibt an, dass alle nicht deklarierten Variablen in einem Sub LOCAL sind. Dies ist die Standardbedingung, wenn weder LOCAL noch STATIC angegeben ist.

Lokale Variablen und Array-Variablen werden automatisch freigegeben, wenn die Prozedur beendet wird. LOKALE Skalarvariablen (au?er dynamische Zeichenfolgen) werden auf dem Stapel gespeichert und sind nur innerhalb des Sub sichtbar.

STATIC

Dieser Deskriptor gibt an, dass alle nicht deklarierten Variablen in einem Sub STATIC sind. Statische Variablen behalten ihren Wert, solange das Programm l?uft. Sie sind nur innerhalb des Subs sichtbar.

Gibt an, dass die deklarierte Prozedur die alte BASIC/Pascal-Aufrufkonvention verwendet. Parameter werden von links nach rechts auf dem Stapel abgelegt und die aufgerufene Prozedur ist f?r deren Entfernung verantwortlich. BDECL sollte nur verwendet werden, wenn dies zur Anpassung an externe Module erforderlich ist.

Gibt an, dass die deklarierte Prozedur die C-Aufrufkonvention verwendet. Parameter werden von rechts nach links auf den Stapel verschoben und der aufrufende Code ist f?r deren Entfernung verantwortlich. CDECL sollte nur verwendet werden, wenn dies zur Anpassung an externe Module erforderlich ist.

Dies ist die Standardkonvention und sollte nach M?glichkeit verwendet werden. SDECL (und sein Synonym STDCALL) spezifiziert die ?Standard Calling Convention? f?r Windows. Parameter werden von rechts nach links auf den Stapel verschoben und die aufgerufene Prozedur ist f?r deren Entfernung verantwortlich.

Passing Parameters

Argumente

Eine optionale, durch Kommas getrennte Folge formaler Parameter. Die in der Argumentliste verwendeten Parameter dienen nur zur Definition der Funktion; Sie haben keine Beziehung zu anderen Variablen im aufrufenden Code mit demselben Namen.

Normalerweise ?bergibt PowerBASIC Parameter entweder per Referenz (BYREF) oder per Wert (BYVAL) an einen Sub. Wenn Sie die Parameter nicht ?ndern m?ssen (was in vielen F?llen der Fall ist), k?nnen Sie Ihre Aufrufe beschleunigen, indem Sie die Parameter mit dem Schl?sselwort BYVAL als Wert ?bergeben. Sie k?nnen klarstellen, dass ein Parameter als Referenz ?bergeben wird, indem Sie das optionale Schl?sselwort BYREF verwenden.

Der Typ des Parameters wird entweder durch Anh?ngen eines Typspezifizierzeichens an den Namen oder durch Verwendung einer AS-Klausel angegeben. Zum Beispiel:

SUB Test(A AS INTEGER) ' Ganzzahl, die als Referenz ?bergeben wird

SUB Test(A%) ' Ganzzahl, die als Referenz ?bergeben wird

SUB Test(BYREF A%) ' Ganzzahl, die als Referenz ?bergeben wird

SUB Test(BYVAL A%) ' Ganzzahl, die als Wert ?bergeben wird

Parametereinschr?nkungen

PowerBASIC-Compiler haben ein Limit von 32 Parametern pro Sub. Um mehr als 32 Parameter an eine FUNCTION zu ?bergeben, erstellen Sie einen benutzerdefinierten Typ (UDT) und ?bergeben Sie den UDT stattdessen als Referenz (BYREF).

Zeigerparameter

Wenn eine Unterdefinition entweder einen BYREF-Parameter oder einen Zeigervariablenparameter angibt, kann der aufrufende Code stattdessen frei ein BYVAL DWORD oder einen Zeiger ?bergeben. Zeigervariablenparameter m?ssen immer als BYVAL-Parameter deklariert werden.

' Ganzzahliger Zeiger (als Wert ?bergeben)

SUB-Test (BYVAL A AS INTEGER PTR)

@A = 56

END SUB

Weitere Informationen zur Parameter?bergabe BYVAL/BYREF/BYCOPY finden Sie im Thema CALL-Anweisung.

Mit OPTIONAL/OPT

SUB-Anweisungen k?nnen einen oder mehrere Parameter als optional angeben, indem sie dem Parameter entweder das Schl?sselwort OPTIONAL oder OPT voranstellen. Optionale Parameter sind nur mit den Aufrufkonventionen CDECL oder SDECL zul?ssig, nicht mit BDECL.

Wenn ein Parameter als optional deklariert wird, sind alle nachfolgenden Parameter in der Deklaration ebenfalls optional, unabh?ngig davon, ob sie eine explizite OPTIONAL- oder OPT-Direktive angeben oder nicht. Die folgenden zwei Zeilen sind ?quivalent, wobei sowohl der zweite als auch der dritte Parameter optional sind:

SUB sABC(a&, OPTIONAL BYVAL b&, OPTIONAL BYVAL c&)

SUB sABC(a&, OPT BYVAL b&, BYVAL c&)

VARIANT-Variablen eignen sich besonders gut zur Verwendung als optionaler Parameter. Wenn der aufrufende Code einen optionalen VARIANT-Parameter (BYVAL oder BYREF) wegl?sst, ersetzen PowerBASIC (und die meisten anderen Compiler) eine Variante vom Typ VT_ERROR, die einen Fehlerwert von %DISP_E_PARAMNOTFOUND (&H80020004) enth?lt. In diesem Fall k?nnen Sie diesen Wert direkt pr?fen oder mit der Funktion ISMISSING() ermitteln, ob der Parameter physisch ?bergeben wurde oder nicht.

Wenn optionale Parameter (au?er VARIANT) im aufrufenden Code weggelassen werden, wird der Stapelbereich, der normalerweise f?r diese Parameter reserviert ist, mit Nullen gef?llt. Dadurch k?nnen Sie testen, ob ein optionaler Parameter ?bergeben wurde oder nicht.

Wenn der Parameter als BYVAL-Parameter definiert ist, hat er den Wert Null. F?r TYPE- oder UNION-Variablen, die BYVAL ?bergeben werden, ?bergibt der Compiler eine Zeichenfolge bin?rer Nullen der L?nge SIZEOF (Typ _oder_union_var).

Wenn der Parameter als BYREF-Parameter definiert ist, ist VARPTR (Varname) gleich Null; Wenn dies zutrifft, f?hrt jeder Versuch, varname in Ihrem Code zu verwenden, zu Fehler Nr. 9 (Nullzeiger); Wenn dieser Fehler nicht mithilfe der Fehlererkennung erkannt wird, kann dies zu einer allgemeinen Schutzverletzung oder einer Speicherbesch?digung f?hren. Sie sollten zun?chst die Funktion ISMISSING() verwenden, um festzustellen, ob der Zugriff auf den Parameter sicher ist.

Da die aufgerufene Funktion, SUB, FASTPROC, METHOD oder PROPERTY zum Zeitpunkt des Aufrufs nicht wei?, wie viele Parameter ?bergeben werden, sollten Sie die Anzahl der Parameter als einen der erforderlichen Parameter in der Liste ?bergeben.

Variablen innerhalb von Subs

LOKALE Variablen werden innerhalb des Prozedurstapelrahmens erstellt. Wenn eine LOCAL-Variable den verf?gbaren Stapelspeicherplatz ?berschreitet, muss m?glicherweise stattdessen eine STATIC- oder GLOBAL-Variable verwendet werden. Beispielsweise kann das Erstellen einer LOCAL-Zeichenfolge mit Nullterminierung oder einer LOCAL-Zeichenfolge fester L?nge, die sehr gro? ist (z. B. fast 1 MB), eine allgemeine Schutzverletzung (GPF) ausl?sen, da sie m?glicherweise den Stapelrahmen ?berl?uft.

Prozedurdefinitionen und Programmablauf

Die Stellung von Prozedurdefinitionen ist meist unerheblich. Normalerweise sind sie in einem Bereich des Quellcodes gruppiert, Prozedurdefinitionen k?nnen jedoch nicht verschachtelt werden. Das hei?t, Sie k?nnen eine Prozedur nicht innerhalb einer anderen Prozedur definieren (obwohl eine Prozedurdefinition Aufrufe anderer Prozeduren enthalten kann). Im Gegensatz zu Unterprogrammen (siehe GOSUB) kann die Programmausf?hrung nicht versehentlich in eine Prozedur ?fallen?, selbst wenn sie sich vor der PBMAIN- oder WINMAIN-Funktion in Ihrem Code befindet. Zum Beispiel:

#COMPILE EXE

SUB DisplayInfo(a$)

' Code kommt hierher

END SUB

FUNCTION PBMAIN

' Hier steht der Hauptprogrammcode

ENDFUNKTION

Wenn dieses Programm ausgef?hrt wird, wird der Code in DisplayInfo nur ausgef?hrt, wenn die Prozedur explizit aufgerufen wird, auch wenn sie sich weiter oben in der Quellcodedatei befindet. Prozedurdefinitionen sollten wie isolierte Codeinseln behandelt werden; Springen Sie nicht mit GOTO , GOSUB oder RETURN hinein oder heraus. Innerhalb eines Verfahrensblocks sind solche Anweisungn zul?ssig.

Verifiziertes Beispiel: SUB - Prozedur ohne Rueckgabewert

Beispieldatei: examples/basic/help_declarations/help_sub.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_declarations/help_sub.pb -o tmp/help_declaration_samples/help_sub.exe and executed with exit code 0.

SUB Bump(BYREF x AS LONG)
    x = x + 1
END SUB

FUNCTION PBMAIN() AS LONG
    LOCAL n AS LONG
    n = 4
    Bump n
    IF n <> 5 THEN FUNCTION = 1
END FUNCTION

Verhalten: Definiert eine SUB und prueft BYREF-Aenderung eines Arguments. Focus statement: SUB Bump(BYREF x AS LONG)

Siehe auch

  • CALL
  • ERKL?REN
  • EXIT SUB
  • FASTPROC
  • FUNCNAME$
  • FUNCTION/END FUNCTION
  • GLOBAL
  • GOSUB
  • Ich vermisse
  • LOCAL
  • ZUR?CK
  • STATIC

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TYP/ENDTYP ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? TYP/ENDTYP

TYP/ENDTYP

Definieren Sie a

Typ:Struktur |Kategorie:Typen

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

TYPE MyType [BYTE | WORD | DWORD | QWORD] [FILL]
[ MemberName [( subscripts )] AS] TypeName
[ MemberName [(subscripts)] AS TypeName ]
[...]
END TYPE

Beschreibung

Die TYPE-Anweisung besteht aus folgenden Teilen:

Der Anfang einer benutzerdefinierten Typdefinition.

MeinTyp

Der Name des benutzerdefinierten Typs, der den Standardkonventionen zur Variablenbenennung entsprechen muss.

Mitgliederausrichtung

TYPE-Definitionen k?nnen optional eine Ausrichtung von BYTE (Standard), WORD, DWORD oder QWORD sowie FILL-Merkmalen angeben. Bei der Standardausrichtung befindet sich jedes Mitglied einer Typstruktur an der angegebenen Grenze. Bei DWORD k?nnen beispielsweise bis zu 3 Bytes zwischen Mitgliedern ?bersprungen werden, um eine Ausrichtung zu erreichen.

Wenn jedoch ein benutzerdefinierter Typ als Mitglied eines gr??eren benutzerdefinierten Typs definiert wird, beh?lt dieser ?Untertyp? seine urspr?ngliche Gr??e und Ausrichtung bei, genau wie bei der ersten Deklaration.

Jedes Mitglied wird an einer BYTE-Grenze ausgerichtet ? es wird keine Auff?llung oder Ausrichtung auf die Struktur angewendet. Dies ist die Standardausrichtungsmethode.

Jedes Mitglied wird an einer WORD-Grenze ausgerichtet. Jedes ungerade Byte zwischen Mitgliedern von TYPE wird automatisch ?bersprungen und ignoriert. Die UDT-Struktur kann auch mit einem abschlie?enden Byte aufgef?llt werden, um sicherzustellen, dass die Gesamtstrukturgr??e ein Vielfaches von 2 Bytes ist.

Jedes Mitglied wird an einer DWORD-Grenze ausgerichtet. F?r diese Ausrichtung werden bis zu drei Bytes ?bersprungen. Die UDT-Struktur wird au?erdem mit bis zu drei nachfolgenden Bytes aufgef?llt, um sicherzustellen, dass die Gesamtstrukturgr??e ein Vielfaches von 4 Bytes ist.

Aus Gr?nden der Kompatibilit?t mit Windows ist die QWORD-Ausrichtung enthalten. Sie kann in einem 32-Bit-Betriebssystem nicht vollst?ndig implementiert werden. Mit QWORD werden einzelne Mitglieder auf die entsprechende Strukturgr??e 64-Bit ausgerichtet, Variablen dieses Typs d?rfen jedoch nur an 32-Bit-Grenzen ausgerichtet werden, da die Stapelzeigerausrichtung nicht garantiert ist.

Wenn die FILL-Option angegeben ist, z. B. TYPE xxx DWORD FILL, gelten die folgenden Regeln:

1. Es werden keine Bytes ?bersprungen, wenn das n?chste Mitglied des Typs vollst?ndig in den zu ?berspringenden Raum passt.

2. Zeichenfolgen fester L?nge werden als Array von Bytes betrachtet, sodass keine Bytes vor ihnen ?bersprungen werden.

3. Die Gesamtgr??e eines Arrays wird ber?cksichtigt, um zu bestimmen, ob FILL seine Platzierung innerhalb der Struktur beeinflussen soll. Mit DWORD FILL w?rde beispielsweise ein Array aus zwei Ganzzahlen an einer 4-Byte-Grenze beginnen, auch wenn zwei oder drei Bytes ?bersprungen werden m?ssen.

Typmitglieder

Mitgliedsname

Der Name eines Mitglieds des benutzerdefinierten Typs. Auch dies muss den Standardkonventionen zur Variablenbenennung entsprechen.

Indizes

Die Dimensionen eines Mitgliedsarrays. Ein- und zweidimensionale Arrays werden unterst?tzt, m?ssen jedoch mit konstanten oder numerischen Literalwerten definiert werden. Das hei?t, die Gesamtgr??e eines UDT muss zur Kompilierungszeit bekannt sein, sodass Elemente wie dynamische Zeichenfolgen, die in der Gr??e variieren, nicht Teil einer TYPE-Struktur sein k?nnen. Ein STRING-PTR kann dies jedoch, da ein Zeiger als DWORD implementiert ist.

Wie bei herk?mmlichen Arrays ist die untere Array-Grenze standardm??ig Null, aber positive Werte ungleich Null k?nnen verwendet werden, um einen bestimmten Bereich von Indexindexwerten f?r das Array anzugeben, getrennt vom Index der oberen Array-Grenze mit dem Schl?sselwort TO. Dar?ber hinaus m?ssen sowohl der untere als auch der obere Indexwert des Indexes Null oder gr??er sein (dh negative Indexwerte sind nicht zul?ssig). Es folgen Beispiele f?r g?ltige Syntax:

TYP MYTYPE

id AS INTEGER ' Skalares UDT-Mitglied

Styles(6) AS DWORD ' 7 Elemente (0 BIS 6)

Jahre (1980 bis 2010) so lang wie 31 Elemente

Team(100 TO 101) AS BYTE ' 2 Elemente

Bewertung (1 bis 10) AS DWORD ' 10 Elemente

X(1 TO 5, 0 TO 5) AS EXT ' 30 Elemente (5x6)

Y(4,3) AS QUAD ' 20 Elemente (5x4)

END-TYP

Einzelne UDT-Strukturen k?nnen jeweils bis zu 16 MB gro? sein. Ein einzelnes Mitgliedselement eines UDT kann auch die gesamten 16 MB belegen. Zum Beispiel Arrays innerhalb eines UDT, nullterminierte Zeichenfolgen und Zeichenfolgen fester L?nge. Die Gr??e von UDT-Mitgliedsarrays kann zur Laufzeit nicht ge?ndert werden. Dar?ber hinaus kann das nicht direkt auf einem UDT-Mitgliedsarray verwendet werden. Verwenden Sie stattdessen DIM..AT, um ein herk?mmliches Array an derselben Speicheradresse wie das UDT-Mitgliedsarray zu deklarieren, und die ARRAY-Anweisung kann dann f?r dieses Array verwendet werden.

Typname

Einer der unterst?tzten Datentypen, einschlie?lich benutzerdefinierter Typen und Unions, mit Ausnahme von Arrays.

END-TYP

Markiert das Ende der Definition des benutzerdefinierten Typs.

Es ist oft sehr praktisch, mehrere verschiedene Arten von Dingen als eine einzige Einheit oder Datenstruktur bezeichnen zu k?nnen. In einem Buchhaltungsprogramm sind beispielsweise eine Kontonummer und ein Betrag Teil dessen, was einen einzelnen Journaleintrag ausmacht. Die TYPE/END TYPE-Blockanweisungen erleichtern die Erstellung eines einzelnen UDT, der solche Informationen enth?lt.

TYPE JournalType DWORD 'Typname und Ausrichtung

AccountNumber AS LONG ' Mitgliedsname und Datentyp

Betrag AS CUR ' das ist noch einer

END TYPE ' Ende der Typdeklaration

DIM JournalEntry AS JournalType ' einen Datensatz deklarieren

TYPE/END TYPE-Bl?cke m?ssen au?erhalb einer Sub , Function oder Class definiert werden und d?rfen in jedem Programm nur einmal definiert werden. Normalerweise ist es am einfachsten, Ihre TYPE/END TYPE-Blockdefinitionen in eine Include-Datei einzuf?gen und die Metaanweisung #INCLUDE in jedem Modul zu verwenden, das sie m?glicherweise verwenden muss.

TYPE/END TYPE-Bl?cke deklarieren keine Variablen; Stattdessen definieren sie einfach einen neuen Typ. Sie k?nnen Variablen dieses Typs mithilfe der DIM- oder REDIM-Anweisungen oder einer beliebigen Anweisung deklarieren, die die Verwendung einer AS-Klausel erm?glicht:

DIM TypeVariable als TypeVariableType

Sobald Sie eine Variable vom Typ ?Benutzerdefiniert? deklariert haben, k?nnen Sie auf deren Mitgliedselemente im folgenden Format zugreifen:

TypeVariable.Element

Um beispielsweise die Kontonummer im JournalEntryType-Typ zu ?ndern, k?nnen Sie eine Anweisung wie die folgende verwenden:

JournalEntry.AccountNumber = 1000

Ein benutzerdefinierter Typ kann wie jeder integrierte PowerBASIC-Typ verwendet werden. Sie k?nnen beispielsweise ein Array von Datensatzvariablen definieren:

DIM JournalEntries(1 TO 100) AS JournalEntryType

oder erstellen Sie sogar eine Prozedur, die eine Datensatzvariable akzeptiert:

SUB PrintJournalEntry(aJournalEntry AS JournalEntryType)

' Journal drucken

END SUB

Sie k?nnen auch Zeiger in einer TYPE-Definition verwenden. Beachten Sie, dass das erste Mitglied im n?chsten Beispiel automatisch so ausgerichtet wird, dass es an einer DWORD-Grenze beginnt, und drei Bytes ?bersprungen werden, sodass das zweite Mitglied ebenfalls an einer DWORD-Grenze ausgerichtet wird:

Geben Sie MyType DWORD ein

Count AS BYTE ' An einer DWORD-Grenze ausgerichtet

y AS INTEGER PTR ' An der n?chsten DWORD-Grenze ausgerichtet

z AS STRING PTR

END-TYP

Da Zeiger als DWORD gespeichert werden, betr?gt ihre L?nge bei Verwendung in einem TYPE/END TYPE 4 Bytes, unabh?ngig von der L?nge ihres Ziels. Um auf das Ziel eines Zeigers zuzugreifen, m?ssen Sie das At-Zeichen vor dem TYPE/END TYPE-Mitglied platzieren, nicht den Namen des TYPE selbst:

iResult% = @MyType.y ' Ung?ltig

iResult% = MyType.@y ' G?ltig

Sie k?nnen auch eine Variable deklarieren, die ein Zeiger auf einen TYPE ist:

Geben Sie ?Meine Daten? ein

Wert1 als Ganzzahl

Wert2 als Ganzzahl

Val3 ALS INTEGER

Val4 ALS INTEGER

END-TYP

DIM Info AS MyData PTR

Info = VARPTR(IhreDaten)

Nachricht$ = HEX$(@Info.Val1) + $CRLF + _

HEX$(@Info.Val2) + $CRLF + _

HEX$(@Info.Val3) + $CRLF + _

HEX$(@Info.Val4)

Beachten Sie, dass der Zielspezifizierer vor dem TYPE-Namen steht, da es sich um den Zeiger handelt. Val1, Val2, Val3 und Val4 stellen Offsets von diesem Zeiger dar. PowerBASIC unterst?tzt zwar einen Zeiger innerhalb eines Strukturzeigers, Sie sollten jedoch bei der Verwendung sehr vorsichtig sein. Eine ?nderung des Strukturzeigers selbst k?nnte dazu f?hren, dass alle Mitgliedszeiger ung?ltig werden. Weitere Informationen finden Sie im Thema zu Zeigern.

Bitvariablen

TYPE-Strukturen k?nnen Bitvariablen enthalten, die BIT (Werte ohne Vorzeichen) oder SBIT (Werte mit Vorzeichen) hei?en. Jede Bitvariable kann 1 bis 31 Bits belegen und sie k?nnen nacheinander bis zu insgesamt 32 Bits pro Bitfeld gepackt werden. Die Gr??e einer Bitvariablen ist wie folgt definiert:

var AS BIT * nlit [IN BYTE|WORD|DWORD]

Dabei definiert der Begriff ?* nlit? die Anzahl der Bits (1 bis 31) und der optionale Begriff ?IN BYTE|WORD|DWORD?, falls vorhanden, definiert den Beginn eines neuen Bitfelds von 1, 2 oder 4 Bytes. Zum Beispiel:

TYP ABCD

Valu2 AS BIT * 31 IN DWORD

Sign1 AS SBIT * 1

nybl2 AS BIT * 4 IN BYTE

nybl1 AS BIT * 4

END-TYP

Die obige Beispiel-TYPE-Struktur ist 5 Byte gro? und enth?lt ein 4-Byte-Bitfeld und ein 1-Byte-Bitfeld. In diesem Fall enth?lt jede zwei Bitvariablen unterschiedlicher Gr??e. Der Wertebereich, der gespeichert werden kann, h?ngt von der Anzahl der verf?gbaren Bits ab. Beispielsweise hat ?BIT * 4? einen Bereich von 0 bis 15, ?SBIT * 1? einen Bereich von -1 bis 0 und ?SBIT * 5? einen Bereich von -16 bis +15.

Strukturen innerhalb von Strukturen

Strukturen (TYPE/UNION) k?nnen zur Vereinfachung der Referenzierung tief verschachtelter Elemente in eine andere Struktur eingebettet werden, indem einfach nur der Strukturname an der entsprechenden Position angegeben wird. Die interne Ausrichtung der Mitgliederstruktur wird unabh?ngig von anderen Ausrichtungsspezifikationen pr?zise beibehalten, um Vererbungsproblemen vorzubeugen. Zum Beispiel:

TYP ABCD3

A SO LANG

C SO LANG

END-TYP

TYP ABCD2

D ALS DWORD

E AS DOPPELT

END-TYP

UNION ABCD1

F ALS DWORD

G SO LANG

H ALS EINZELN

END UNION

In diesem Fall k?nnten Sie sehr einfach auf das einzelne Float-Element mit einfacher Genauigkeit dieser Struktur zugreifen. Unter der Annahme, dass DIM

Weitere Informationen finden Sie in den Abschnitten UNION/END UNION und Benutzerdefinierte Typen und Unions.

Einschr?nkungen

Wenn Sie die Gr??e einer aufgef?llten (ausgerichteten) UDT-Struktur mit den Anweisungen LEN oder SIZEOF messen, umfasst die gemessene L?nge alle Auff?llungen, die der Struktur hinzugef?gt wurden. Beispielsweise die folgende UDT-Struktur:

TYP L?ngeTestTyp DWORD

a AS INTEGER

END-TYP

' Mehr Code hier

DIM abc AS LengthTestType

x& = LEN(abc)

Gibt eine L?nge von 4 Bytes in x& zur?ck, da der UDT mit 2 zus?tzlichen Bytes aufgef?llt wurde, um die DWORD-Ausrichtung zu erzwingen. Beachten Sie, dass LEN und SIZEOF einzelner UDT-Mitglieder die wahre Gr??e des Mitglieds zur?ckgeben, unabh?ngig von Auff?llung oder Ausrichtung. Im vorherigen Beispiel gibt LEN(abc.a) 2 zur?ck.

Einzelne UDT-Strukturen k?nnen jeweils bis zu 16 MB gro? sein. Arrays innerhalb eines UDT, nullterminierte Zeichenfolgen und Zeichenfolgen fester L?nge k?nnen die volle Strukturgr??enbeschr?nkung von 16 MB belegen.

Feldleisten und dynamische Zeichenfolgen k?nnen nicht in UDT- oder UNION-Strukturen verwendet werden. Der Versuch, dies zu tun, f?hrt zur Kompilierungszeit zu einem Fehler 485 (?Dynamik/Feldzeichenfolgen nicht zul?ssig?).

Verifiziertes Beispiel: TYPE - benutzerdefinierter Datensatz

Beispieldatei: examples/basic/help_declarations/help_type.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_declarations/help_type.pb -o tmp/help_declaration_samples/help_type.exe and executed with exit code 0.

TYPE Pair
    x AS LONG
    y AS LONG
END TYPE

FUNCTION PBMAIN() AS LONG
    LOCAL p AS Pair
    p.x = 3
    p.y = 4
    IF p.x + p.y <> 7 THEN FUNCTION = 1
END FUNCTION

Verhalten: Deklariert einen UDT und prueft Member-Zugriff. Focus statement: TYPE Pair

Siehe auch

  • DIM
  • LEN
  • REDIM
  • LET (mit Typen)
  • SIZEOF
  • TYP EINGESTELLT
  • UNION/ENDUNION
  • Benutzerdefinierte Typen
  • Gewerkschaften

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


UNION / END UNION - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Datentypen & Variablen › UNION / END UNION
Hilfe zum PBXB64-Compiler

UNION / END UNION

Definiert ein überlappendes Record-Layout für verschiedene Sichtweisen auf denselben Speicher.

Kind: Struktur | Category: Types

PBXB64 Status: VERFÜGBAR

PBXB64 Certification: [ZERTIFIZIERT GETESTET]

Syntax

UNION UnionName
    MemberName [()] AS TypeName
    [ MemberName [()] AS TypeName ]
END UNION

Description

Eine UNION ist wie ein TYPE, mit dem Unterschied, dass alle Mitglieder denselben Speicher teilen. Wenn Sie über ein Mitglied schreiben, sehen die anderen Mitglieder dieselben Bytes.

Verwenden Sie UNION, wenn Sie alternative Interpretationen derselben Daten brauchen, etwa numerische Überlagerungen, Byte-Packung oder eine kompakte Sicht auf eine getaggte Struktur.

Mitglieder können Arrays oder verschachtelte TYPE/UNION-Definitionen sein. Bit-Felder werden ebenfalls unterstützt, wenn Sie dicht gepackte Kontrollwerte benötigen.

Example

' Getestetes Beispiel: tests/e2e/pb/test_type_enum_union.pb
UNION ValueView
    iLong AS LONG
    iDword AS DWORD
    sText AS STRING * 4
END UNION

FUNCTION PBMAIN() AS LONG
    LOCAL v AS ValueView
    v.iLong = 123456
    PBMAIN = 0
END FUNCTION

Einschränkungen

  • Die Größe der UNION entspricht immer dem größten Mitglied.
  • Dynamische Feldzeichenketten sind in TYPE- und UNION-Speicher nicht erlaubt.
  • Verwenden Sie TYPE, wenn Mitglieder unabhängigen Speicher statt überlappender Bytes brauchen.

Verifiziertes Beispiel: UNION - ueberlappende Datensatzfelder

Beispieldatei: examples/basic/help_declarations/help_union.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_declarations/help_union.pb -o tmp/help_declaration_samples/help_union.exe and executed with exit code 0.

UNION NumberView
    x AS LONG
    y AS LONG
END UNION

FUNCTION PBMAIN() AS LONG
    LOCAL u AS NumberView
    u.x = 5
    IF u.y <> 5 THEN FUNCTION = 1
END FUNCTION

Verhalten: Deklariert ueberlappende Felder und prueft, dass beide Namen denselben Speicher lesen. Focus statement: UNION NumberView

Praktische Verwendung

UNION / END UNION gehoert zur Kategorie Types. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' UNION / END UNION mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

See Also

  • TYP / ENDTYP
  • DIM
  • LEN
  • SIZEOF
  • OBJECT


BASIC-Operatoren — PBXB64 Help

Startseite › BASIC Frontend › Operators

BASIC-Operatoren

Logische, bitweise und Vergleichsoperatoren.

Aufgabe dieses Kapitels

Dieses Kapitel sammelt die BASIC-Sprachmittel zu einem zusammenhängenden Arbeitsbereich. Es dient als Einstieg, wenn Sie nicht den exakten Befehlsnamen kennen, sondern eine Spracheigenschaft suchen.

Verwendung

Beginnen Sie mit der Tabelle unten und wechseln Sie dann zur Detailseite des einzelnen Befehls. Die Detailseiten enthalten Syntax, Hinweise zur PBXB64-Unterstützung, Getestetes Beispiel und Querverweise.

Befehlsübersicht

Befehl | Bereich
UND | Logische, bitweise und Vergleichsoperatoren.
ODER | Logische, bitweise und Vergleichsoperatoren.
NICHT | Logische, bitweise und Vergleichsoperatoren.
XOR | Logische, bitweise und Vergleichsoperatoren.
EQV | Logische, bitweise und Vergleichsoperatoren.
IMP | Logische, bitweise und Vergleichsoperatoren.
MOD | Logische, bitweise und Vergleichsoperatoren.
WIE | Logische, bitweise und Vergleichsoperatoren.
IS | Logische, bitweise und Vergleichsoperatoren.

Getestetes Beispiel

Diese Seite ist ein Uebersichtskapitel. Die verlinkten Einzelseiten enthalten die konkreten getesteten Beispiele oder nennen eine ausdrueckliche Begrenzung, wenn ein Befehl nicht zertifiziert ist.

PBXB64-Status: Uebersicht / Navigation; keine eigenstaendige Laufzeitbehauptung ohne Unterseitenbeleg.

Praktische Hinweise

BASIC-Quelltext wird im PBXB64-Frontend direkt in die gemeinsame Zwischenrepräsentation übersetzt. Achten Sie deshalb besonders auf Datentypen, ByVal/ByRef-Übergabe, Zeichenkettenlängen und Laufzeitfehlerpfade.

Siehe auch

  • BASIC-Sprachübersicht

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UND – PBXB64-Compiler-Hilfe

Startseite› Funktionen › UND

UND

Der AND-Operator funktioniert sowohl als logischer als auch als bitweiser arithmetischer Operator.

Typ:Betreiber |Kategorie:Betreiber

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

p AND q

Verifiziertes Beispiel: AND - logische/bitweise Konjunktion

Beispieldatei: examples/basic/help_operators/help_and.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_operators/help_and.pb -o tmp/help_operator_samples/help_and.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF ((1 AND 1) = 0) THEN FUNCTION = 1
    IF ((1 AND 0) <> 0) THEN FUNCTION = 2
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft den Operator und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: 1 AND 1

Siehe auch

  • Arithmetische Operatoren
  • EQV
  • IMP
  • ISFALSCH
  • ISTRUE
  • NICHT
  • ODER
  • XOR

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_logical_1
FUNCTION PBMAIN() AS LONG
  IF NOT (((5 > 3) AND (2 < 4)) = TRUE) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_logical_2
FUNCTION PBMAIN() AS LONG
  IF NOT (((5 > 3) AND (2 > 4)) = FALSE) THEN FUNCTION = 2: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_logical_3
FUNCTION PBMAIN() AS LONG
  IF NOT (((5 > 3) OR (2 > 4)) = TRUE) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_logical_4
FUNCTION PBMAIN() AS LONG
  IF NOT (((5 < 3) OR (2 > 4)) = FALSE) THEN FUNCTION = 4: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_logical_5
FUNCTION PBMAIN() AS LONG
  IF NOT ((NOT (5 < 3)) = TRUE) THEN FUNCTION = 5: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_logical_6
FUNCTION PBMAIN() AS LONG
  IF NOT ((NOT (5 > 3)) = FALSE) THEN FUNCTION = 6: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für UND soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' UND mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


ODER - PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? ODER

ODER

Der ODER-Operator funktioniert sowohl logisch als auch bitweise

Typ:Betreiber |Kategorie:Betreiber

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

p OR q

Beschreibung

Verwendung von OR als logischen Operator

OR gibt genau dann TRUE (ungleich Null) zur?ck, wenn einer oder beide seiner Operanden TRUE sind. Hier ist die Wahrheitstabelle von OR:

Wahrheitstabelle

x ODER y

Verifiziertes Beispiel: OR - logische/bitweise Disjunktion

Beispieldatei: examples/basic/help_operators/help_or.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_operators/help_or.pb -o tmp/help_operator_samples/help_or.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF ((1 OR 0) = 0) THEN FUNCTION = 1
    IF ((0 OR 0) <> 0) THEN FUNCTION = 2
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft den Operator und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: 1 OR 0

Siehe auch

  • Arithmetische Operatoren
  • UND
  • EQV
  • IMP
  • ISFALSCH
  • ISTRUE
  • LET
  • NICHT
  • XOR

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_logical_1
FUNCTION PBMAIN() AS LONG
  IF NOT (((5 > 3) AND (2 < 4)) = TRUE) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_logical_2
FUNCTION PBMAIN() AS LONG
  IF NOT (((5 > 3) AND (2 > 4)) = FALSE) THEN FUNCTION = 2: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_logical_3
FUNCTION PBMAIN() AS LONG
  IF NOT (((5 > 3) OR (2 > 4)) = TRUE) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_logical_4
FUNCTION PBMAIN() AS LONG
  IF NOT (((5 < 3) OR (2 > 4)) = FALSE) THEN FUNCTION = 4: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_logical_5
FUNCTION PBMAIN() AS LONG
  IF NOT ((NOT (5 < 3)) = TRUE) THEN FUNCTION = 5: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_logical_6
FUNCTION PBMAIN() AS LONG
  IF NOT ((NOT (5 > 3)) = FALSE) THEN FUNCTION = 6: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


NICHT ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? NICHT

NICHT

Der NOT-Operator funktioniert bitweise

Typ:Betreiber |Kategorie:Betreiber

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

NOT p

Beschreibung

Der NOT-Operator von PowerBASIC gibt das Einerkomplement eines Integralausdrucks zur?ck. Beim Umgang mit den absoluten Werten 0 und -1 ?kehrt? der NOT-Operator die beiden Werte um und f?hrt eine boolesche Operation aus.

PowerBASIC akzeptiert jeden Wert ungleich Null als logischen TRUE-Wert; Daher k?nnen in einem Programm subtile Logikprobleme auftreten, wenn der NOT-Operator verwendet wird, um boolesche Logiktests mit Operandenwerten durchzuf?hren, die nicht nur auf 0 und -1 beschr?nkt sind.

Betrachten Sie die folgenden zwei Testbedingungen:

test1 = 0 ' test1 ist FALSCH (Null)

IF NICHT test1 THEN ' TRUE (-1 ist ungleich Null)

test2 = 1 ' test2 ist WAHR (1 ist ungleich Null)

IF NICHT test2 THEN ' immer noch TRUE (-2 ist ungleich Null)

Da NOT eine bitweise Operation f?r test2 ausf?hrt, wird der logische TRUE/FALSE-Wert von test2 nicht umgekehrt, sondern -2 (das Einserkomplement von 1) zur?ckgegeben, was als logischer TRUE-Wert ausgewertet wird.

In F?llen, in denen eine ordnungsgem??e logische (boolesche) Auswertung erforderlich ist und der Operand einen anderen Wert als 0 und -1 haben kann, sollte der ISFALSE-Operator anstelle des NOT-Operators verwendet werden:

test3 = 1 ' test3 ist WAHR (ungleich Null)

IF ISFALSE test3 THEN ' ISFALSE erkennt test3

[Anweisungen] 'WAHR, sodass der IF-Test fehlschl?gt

Das Zweierkomplement eines Wertes kann mit dem folgenden Algorithmus ermittelt werden:

y = (NICHT x) + 1

Verwendung von NOT als logischen Operator

NOT gibt genau dann 0 (FALSE) zur?ck, wenn sein Operand genau -1 (TRUE) ist. Im Allgemeinen sollten Sie den ISFALSE-Operator anstelle von NOT verwenden, wenn Sie auf logische Falschheit testen.

Wahrheitstabelle

Verifiziertes Beispiel: NOT - logische/bitweise Negation

Beispieldatei: examples/basic/help_operators/help_not.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_operators/help_not.pb -o tmp/help_operator_samples/help_not.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF (NOT 0) = 0 THEN FUNCTION = 1
    IF (NOT -1) <> 0 THEN FUNCTION = 2
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft den Operator und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: NOT 0

Siehe auch

  • Arithmetische Operatoren
  • UND
  • EQV
  • IMP
  • ISFALSCH
  • ISTRUE
  • ODER
  • Kurzschlussauswertung
  • XOR

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_logical_1
FUNCTION PBMAIN() AS LONG
  IF NOT (((5 > 3) AND (2 < 4)) = TRUE) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_logical_2
FUNCTION PBMAIN() AS LONG
  IF NOT (((5 > 3) AND (2 > 4)) = FALSE) THEN FUNCTION = 2: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_logical_3
FUNCTION PBMAIN() AS LONG
  IF NOT (((5 > 3) OR (2 > 4)) = TRUE) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_logical_4
FUNCTION PBMAIN() AS LONG
  IF NOT (((5 < 3) OR (2 > 4)) = FALSE) THEN FUNCTION = 4: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_logical_5
FUNCTION PBMAIN() AS LONG
  IF NOT ((NOT (5 < 3)) = TRUE) THEN FUNCTION = 5: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_logical_6
FUNCTION PBMAIN() AS LONG
  IF NOT ((NOT (5 > 3)) = FALSE) THEN FUNCTION = 6: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


XOR ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? XOR

XOR

Der XOR-Operator funktioniert sowohl logisch als auch bitweise

Typ:Betreiber |Kategorie:Betreiber

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

p XOR q

Beschreibung

XOR als logischer Operator

XOR gibt genau dann FALSE (Null) zur?ck, wenn beide Operanden denselben Wert haben. Hier ist die Wahrheitstabelle von XOR:

Wahrheitstabelle

x XOR y

Verifiziertes Beispiel: XOR - exklusives Oder

Beispieldatei: examples/basic/help_operators/help_xor.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_operators/help_xor.pb -o tmp/help_operator_samples/help_xor.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF ((1 XOR 0) = 0) THEN FUNCTION = 1
    IF ((1 XOR 1) <> 0) THEN FUNCTION = 2
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft den Operator und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: 1 XOR 0

Siehe auch

  • Arithmetische Operatoren
  • UND
  • EQV
  • IMP
  • NICHT
  • ODER

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


EQV ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? EQV

EQV

Der EQV-Operator funktioniert sowohl logisch als auch bitweise

Typ:Betreiber |Kategorie:Betreiber

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

p EQV q

Beschreibung

Verwendung von EQV als logischen Operator

EQV gibt TRUE (ungleich Null) zur?ck, wenn mindestens ein Bit in einem Operanden denselben Wert enth?lt wie die identische Bitposition im anderen Operanden. Dar?ber hinaus gibt EQV genau dann Null zur?ck, wenn zwischen den beiden Operanden keine ?bereinstimmenden Bitwerte vorhanden sind. Dies kann auftreten, wenn ein Operand gleich dem bitweisen NOT-Wert des anderen Operanden ist. Zum Beispiel:

IF x EQV y = 0 THEN-Anweisung

is equivalent to:

IF x = NOT y THEN-Anweisung

Der EQV-Operator kann zum Vergleichen von vorzeichenbehafteten und vorzeichenlosen Werten derselben Bitgr??e verwendet werden, z. B. Long-integer und Double-word . Diese Verwendung von EQV ?hnelt der Verwendung der BITS-Funktionen; Es muss jedoch darauf geachtet werden, den R?ckgabewert von EQV korrekt zu testen, da EQV nur dann einen vorzeichenlosen Wert mit allen gesetzten Bits zur?ckgibt, wenn die Bitmuster der beiden Operanden genau ?bereinstimmen.

Die EQV-Wahrheitstabelle sieht folgenderma?en aus:

Wahrheitstabelle

x EQV y

Verifiziertes Beispiel: EQV - Aequivalenz

Beispieldatei: examples/basic/help_operators/help_eqv.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_operators/help_eqv.pb -o tmp/help_operator_samples/help_eqv.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF ((-1 EQV -1) = 0) THEN FUNCTION = 1
    IF ((-1 EQV 0) <> 0) THEN FUNCTION = 2
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft den Operator und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: -1 EQV -1

Siehe auch

  • Arithmetische Operatoren
  • UND
  • IMP
  • ISFALSCH
  • ISTRUE
  • LET
  • NICHT
  • ODER
  • XOR

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


IMP ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? IMP

IMP

Der IMP-Operator funktioniert sowohl logisch als auch bitweise

Typ:Betreiber |Kategorie:Betreiber

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

p IMP q

Beschreibung

IMP als logischer Operator

Der IMP-Operator gibt genau dann FALSE (Null) zur?ck, wenn sein erster Operand TRUE (ungleich Null) und sein zweiter Operand FALSE ist. In allen anderen F?llen wird TRUE zur?ckgegeben.

Wahrheitstabelle

x IMP y

Verifiziertes Beispiel: IMP - Implikation

Beispieldatei: examples/basic/help_operators/help_imp.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_operators/help_imp.pb -o tmp/help_operator_samples/help_imp.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF ((-1 IMP 0) <> 0) THEN FUNCTION = 1
    IF ((0 IMP -1) = 0) THEN FUNCTION = 2
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft den Operator und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: -1 IMP 0

Siehe auch

  • Arithmetische Operatoren
  • UND
  • EQV
  • ISFALSCH
  • ISTRUE
  • NICHT
  • ODER
  • XOR

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOD ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? MOD

MOD

Gibt den Rest der Division zwischen zwei Zahlen zur?ck.

Typ:Betreiber |Kategorie:Betreiber

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

p MOD q

Beschreibung

Der MOD-Operator dividiert die beiden Operanden p und q und gibt den Rest dieser Division zur?ck. Das Ergebnis der anf?nglichen Division wird auf einen ganzzahligen Wert gek?rzt, bevor der Rest berechnet wird. Siehe das Beispiel unten.

Der Rest kann ein Gleitkommawert sein. MOD wird oft als Erg?nzung zur Integraldivision angesehen.

Verifiziertes Beispiel: MOD - Integer-Rest

Beispieldatei: examples/basic/help_operators/help_mod.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_operators/help_mod.pb -o tmp/help_operator_samples/help_mod.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF (17 MOD 5) <> 2 THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft den Operator und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: 17 MOD 5

Siehe auch

  • LET

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_mod_0_1
FUNCTION PBMAIN() AS LONG
  IF (0 MOD 1) <> (0) THEN FUNCTION = 245: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_mod_0_2
FUNCTION PBMAIN() AS LONG
  IF (0 MOD 2) <> (0) THEN FUNCTION = 247: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_mod_0_5
FUNCTION PBMAIN() AS LONG
  IF (0 MOD 5) <> (0) THEN FUNCTION = 249: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_mod_0_10
FUNCTION PBMAIN() AS LONG
  IF (0 MOD 10) <> (0) THEN FUNCTION = 251: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_mod_0_-1
FUNCTION PBMAIN() AS LONG
  IF (0 MOD -1) <> (0) THEN FUNCTION = 253: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_mod_0_-5
FUNCTION PBMAIN() AS LONG
  IF (0 MOD -5) <> (0) THEN FUNCTION = 255: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_mod_0_100
FUNCTION PBMAIN() AS LONG
  IF (0 MOD 100) <> (0) THEN FUNCTION = 257: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_mod_0_-100
FUNCTION PBMAIN() AS LONG
  IF (0 MOD -100) <> (0) THEN FUNCTION = 259: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_mod_1_1
FUNCTION PBMAIN() AS LONG
  IF (1 MOD 1) <> (0) THEN FUNCTION = 261: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_mod_1_2
FUNCTION PBMAIN() AS LONG
  IF (1 MOD 2) <> (1) THEN FUNCTION = 263: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LIKE - PBXB64-Compiler-Hilfe

Startseite › Funktionen › LIKE

WIE

Vergleicht eine Zeichenfolge mit einem Muster unter Verwendung von Platzhalterzeichen.

Typ:Betreiber |Kategorie: String-Operationen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

result = string LIKE pattern

Remarks

Das Muster kann enthalten * (entspricht einer beliebigen Zeichenfolge) und ? (entspricht einem beliebigen einzelnen Zeichen).

Beispiel

FUNCTION PBMAIN() AS LONG
  LOCAL s AS STRING
  s = "Hello World"
  IF s LIKE "H*" THEN PRINT "Matches"
  FUNCTION = 0
END FUNCTION

Verifiziertes Beispiel: LIKE - Mustervergleich

Beispieldatei: examples/basic/help_operators/help_like.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_operators/help_like.pb -o tmp/help_operator_samples/help_like.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF ("hello" LIKE "h*o") = 0 THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft den Operator und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: "hello" LIKE "h*o"

Siehe auch

  • INSTR
  • TALLY

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für WIE soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' WIE mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


IS - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Operatoren › IS
Hilfe zum PBXB64-Compiler

IS

Vergleicht zwei Werte als exakten Treffer in Ausdrucksform.

Kind: Operator | Category: Operators

PBXB64 Status: VERFÜGBAR

PBXB64 Certification: [ZERTIFIZIERT GETESTET]

Syntax

result = expr1 IS expr2
CASE IS comparison_expression

Description

IS ist der exakte Vergleichsoperator, der in PBXB64-BASIC-Ausdrücken verwendet wird. Er liefert ein boolesches Ergebnis, das zu den übrigen Operatoren passt.

In SELECT CASE-Blocken führt dasselbe Schlüsselwort auch relationale Tests wie CASE IS > 5 oder CASE IS < 0 ein. Diese Form gehört zur CASE-Syntax und nicht zu einem eigenen Ausdrucksoperator.

Der Operator ist nützlich, wenn Sie einen klaren Vergleich wollen, der sich eher wie Identität oder exakter Treffer liest als wie eine lockerere numerische Kurzform.

Example

' Getestetes Beispiel: tests/e2e/pb/test_stage7_operators.pb
FUNCTION PBMAIN() AS LONG
    LOCAL a AS LONG, b AS LONG, n AS LONG
    a = 5 : b = 10
    n = a IS b
    PBMAIN = 0
END FUNCTION

Hinweise

  • Für die Zweigsyntax in SELECT CASE gehört das `IS` zur CASE-Anweisung, nicht zu dieser Operatorseite.
  • Nutzen Sie die Seite zusammen mit CASE / SELECT CASE, wenn Sie Bereichsvergleiche lesen oder schreiben.

Verifiziertes Beispiel: IS - Identitaets-/Gleichheitstest

Beispieldatei: examples/basic/help_operators/help_is.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_operators/help_is.pb -o tmp/help_operator_samples/help_is.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    LOCAL a AS LONG
    LOCAL b AS LONG
    a = 5
    b = 5
    IF (a IS b) = 0 THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft den Operator und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: a IS b

See Also

  • SELECT CASE / END SELECT
  • CASE
  • WIE
  • ISFALSE / ISTRUE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


GRUNDLEGENDER Kontrollfluss — PBXB64 Help

Startseite › BASIC Frontend › Control Flow

GRUNDLEGENDER Kontrollfluss

Anweisungen, die die Programmausführung steuern.

Aufgabe dieses Kapitels

Dieses Kapitel sammelt die BASIC-Sprachmittel zu einem zusammenhängenden Arbeitsbereich. Es dient als Einstieg, wenn Sie nicht den exakten Befehlsnamen kennen, sondern eine Spracheigenschaft suchen.

Verwendung

Beginnen Sie mit der Tabelle unten und wechseln Sie dann zur Detailseite des einzelnen Befehls. Die Detailseiten enthalten Syntax, Hinweise zur PBXB64-Unterstützung, Getestetes Beispiel und Querverweise.

Befehlsübersicht

Befehl | Bereich
IF...THEN...ELSE | Anweisungen, die die Programmausführung steuern.
SELECT CASE | Anweisungen, die die Programmausführung steuern.
FOR...WEITER | Anweisungen, die die Programmausführung steuern.
DO...LOOP | Anweisungen, die die Programmausführung steuern.
WHILE...WENDE | Anweisungen, die die Programmausführung steuern.
GOTO | Anweisungen, die die Programmausführung steuern.
GOSUB...RÜCKKEHR | Anweisungen, die die Programmausführung steuern.
VERSUCHEN...FANGEN...ENDLICH | Anweisungen, die die Programmausführung steuern.
AUSFAHRT | Anweisungen, die die Programmausführung steuern.
WEITER | Anweisungen, die die Programmausführung steuern.

Getestetes Beispiel

Diese Seite ist ein Uebersichtskapitel. Die verlinkten Einzelseiten enthalten die konkreten getesteten Beispiele oder nennen eine ausdrueckliche Begrenzung, wenn ein Befehl nicht zertifiziert ist.

PBXB64-Status: Uebersicht / Navigation; keine eigenstaendige Laufzeitbehauptung ohne Unterseitenbeleg.

Praktische Hinweise

BASIC-Quelltext wird im PBXB64-Frontend direkt in die gemeinsame Zwischenrepräsentation übersetzt. Achten Sie deshalb besonders auf Datentypen, ByVal/ByRef-Übergabe, Zeichenkettenlängen und Laufzeitfehlerpfade.

Siehe auch

  • BASIC-Sprachübersicht

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


IF � PBXB64-Compiler-Hilfe

Startseite � Funktionen � IF

IF

Bedingter Ausf�hrungsblock

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERF�GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

IF condition THEN
  [statements]
[ELSEIF condition THEN
  [statements] ...]
[ELSE
  [statements]]
END IF

Beschreibung

DerIF...THEN...END IF Die Anweisung f�hrt einen von mehreren Anweisungsbl�cken basierend auf einer booleschen Bedingung aus. Die Bedingung kann ein beliebiger numerischer Ausdruck oder ein Zeichenfolgenausdruck sein. Numerische Nullen und leere Zeichenfolgen werden als falsch behandelt. Nicht null und nicht leer werden als wahr behandelt.

Mehrere ELSEIF Zweige und eine einzelne ELSE Zweig werden unterst�tzt. Nur der erste Zweig, dessen Bedingung wahr ist, wird ausgef�hrt.

Beispiel

FUNCTION PBMAIN () AS LONG
    LOCAL x AS LONG
    x = 10
    IF x > 5 THEN
        FUNCTION = 1
    ELSEIF x = 5 THEN
        FUNCTION = 2
    ELSE
        FUNCTION = 3
    END IF
END FUNCTION

Dieses Programm gibt 1 zur�ck, weil x > 5 ist wahr.

Generierter Assembler-Code

PBXB64 example.pb --asmout example.asm

Jede Bedingung wird auf einen Vergleich, eine boolesche Konvertierung und einen bedingten Sprung reduziert. Die THEN, ELSEIF, UndELSE K�rper werden zu beschrifteten Basisbl�cken, die in einem einzigen Zusammenf�hrungsblock zusammenlaufen:

    mov rbx, 10
    mov [rbp-32], rbx
    mov r10, [rbp-32]
    mov rbx, r10
    cmp rbx, 5
    setg r10
    mov rbx, r10
    test rbx, rbx
    jne pb_if_then_PBMAIN_0
    jmp pb_if_else_PBMAIN_1
pb_if_then_PBMAIN_0:
    mov [rbp-24], 1
    jmp pb_if_end_PBMAIN_2
pb_if_else_PBMAIN_1:
    ; ELSEIF x = 5 ...
    jmp pb_elseif_else_PBMAIN_4
pb_if_end_PBMAIN_2:
    mov r10, [rbp-24]
    mov rax, r10
    ; function epilogue

Hinweise

  • Einzeilig IF condition THEN statement wird ebenfalls unterst�tzt.
  • Bei den einzeiligen Formen IF condition THEN statement : statement und IF condition THEN statement : statement ELSE statement : statement bleiben die durch Doppelpunkte getrennten Anweisungen Teil des ausgewaehlten Zweigs.
  • String-Vergleiche verwenden die lexikalische Reihenfolge.

Fokussierte V14-Validierung: tests/pb/test_control_flow_core.pb prueft verkettetes ELSEIF, einzeilige THEN-Anweisungsteile und den abschliessenden ELSE-Zweig. tests/pb/test_inline_if_colon_scope.pb prueft, dass durch Doppelpunkte getrennte einzeilige THEN- und ELSE-Ketten im ausgewaehlten Zweig bleiben. tests/pb/test_control_flow_reject_elseif.pb prueft die Diagnose fuer ELSEIF ausserhalb eines aktiven IF-Blocks.

Verifiziertes Beispiel: IF...THEN...ELSE - einen Zweig auswaehlen

Beispieldatei: examples/basic/help_control_flow/help_if.pb

Validierungsnachweis: tests/integration/pbxa64/control_flow/test_control_flow_comprehensive.pb

Validation evidence: the registered control-flow regression(s) named above compile and run with exit code 0, proving the page-specific branch, loop, or exception behavior documented here.

FUNCTION PBMAIN() AS LONG
    LOCAL x AS LONG
    x = 15
    IF x > 20 THEN
        FUNCTION = 3
    ELSEIF x > 10 THEN
        FUNCTION = 0
    ELSE
        FUNCTION = 1
    END IF
END FUNCTION

Verhalten: Testet blockweises IF, ELSEIF, ELSE und END IF. Der erwartete Programm-Exitcode ist 0, weil nur der ELSEIF-Zweig ausgefuehrt wird.

Siehe auch

  • ELSEIF
  • Sonst
  • THEN
  • SELECT CASE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SELECT CASE/END SELECT ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? SELECT CASE/END SELECT

SELECT CASE/END AUSW?HLEN

Steuern Sie den Programmfluss basierend auf dem Wert eines Ausdrucks.

Typ:Schl?sselwort |Kategorie: Control Flow

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SELECT CASE [AS] [LONG | CONST | CONST$ | CONST$$] expression
CASE [IS] testlist
[ statements ]
[CASE [IS] testlist
[ statements ]]
[CASE ELSE
END SELECT

Beschreibung

testlist ist ein oder mehrere durch Kommas getrennte Tests, die f?r expression ausgef?hrt werden sollen. Der Ausdruck kann entweder eine Zeichenfolge oder eine Zahl sein.

Wenn eine SELECT-Anweisung auftritt, wird der Ausdruck mithilfe der Testliste in der ersten CASE-Klausel ausgewertet. Wenn die Bewertung FALSE ist, wird die Bewertung mit der n?chsten Testliste wiederholt. Sobald eine Auswertung TRUE (ungleich Null) ist, werden die auf diese CASE-Klausel folgenden Anweisungen bis zur n?chsten CASE-Klausel ausgef?hrt.

Die Ausf?hrung geht dann zu der Anweisung ?ber, die auf die END SELECT-Anweisung folgt. Wenn keine der Auswertungen TRUE ist, werden die Anweisungen nach der optionalen CASE ELSE-Klausel ausgef?hrt.

Zu den Tests, die von einer CASE-Klausel durchgef?hrt werden k?nnen, geh?ren: Gleichheits-, Ungleichheits-, Gr??er-als-, Kleiner-als- und Bereichstests (?von-bis?). Der Block SELECT CASE kann Zeichenfolgen- oder numerische Tests durchf?hren, diese k?nnen jedoch nicht ausgetauscht werden.

Beispiele f?r numerische CASE-Klauseltests sind:

SELECT CASE numerischer_Ausdruck

CASE > b ' relational; ist Ausdruck > b?

CASE 14 ' Gleichheit (= wird vorausgesetzt); Ist Ausdruck gleich 14?

CASE b BIS 99 'Bereich; ist ein Ausdruck zwischen dem Wert des

' Variable b und 99 (einschlie?lich)?

CASE 14, b ' zwei Gleichheitstests; ist Ausdruck gleich

' 14 oder gleich b?

CASE 25 BIS 99,14 ' Kombinationsbereich und Gleichheit; ist Ausdruck

' zwischen 25 und 99 (einschlie?lich) oder gleich 14?

Beispiele f?r String-CASE-Klauseltests sind:

SELECT CASE string_expression

CASE > b$ ' relational; ist Ausdruck > b$?

CASE "X" ' Gleichheit (= wird vorausgesetzt); ist Ausdruck gleich

' zu ?X??

CASE ?A? BIS ?C? ' Bereich; ist ein Ausdruck zwischen ?A? und

' ?C?(inklusive)?

CASE "Y", b$ ' zwei Gleichheitstests; ist Ausdruck gleich

' ?Y? oder gleich b$?

CASE ?A? BIS ?C?, ?Q? ' Kombinationsbereich und Gleichheit; ist Ausdruck

' zwischen ?A? und ?C? (einschlie?lich) oder gleich

' zu ?Q??

Wenn eine CASE-Klausel mehrere durch Kommas getrennte Tests enth?lt, wird ein logisches ODER durchgef?hrt. Das hei?t, wenn einer (oder mehrere) der Tests WAHR ist, gilt die gesamte Klausel als WAHR.

Mit EXIT SELECT springen Sie vorzeitig aus einem SELECT-Block heraus.

PowerBASIC bietet jetzt vier optionale Modifikatoren, um eine hochoptimierte Codegenerierung f?r bestimmte Umst?nde zu erm?glichen. Standardm??ig werden numerische Ausdr?cke entweder als Gleitkommawerte (um den gr??tm?glichen Kompatibilit?tsbereich f?r alle m?glichen Umst?nde zu bieten) oder als Integer-Klasse ausgewertet (z. B. wenn PowerBASIC feststellen kann, dass alle Case-Klauseln Integer-Klassenwerte sind usw.). Dar?ber hinaus werden Zeichenfolgenausdr?cke dynamisch ausgewertet, um praktisch alle Daten zu erm?glichen. Wenn jedoch die Beschr?nkungen f?r Typ und Bereich der f?r den CASE-Vergleich verwendeten Daten eingeschr?nkt sind, kann die Leistung mit den Klauseln LONG, CONST, CONST$ oder CONST$$ erheblich verbessert werden.

SO LANG

In diesem Fall m?ssen der Steuerausdruck und die CASE-Ausdr?cke im Bereich eines Long-integer ausgewertet werden. Jeder dieser Ausdr?cke wird dynamisch berechnet, sodass alle normalen Operatoren weiterhin verf?gbar sind. Die Leistung wird durch die Integralklasse der Codegenerierung statt durch Gleitkomma verbessert. Beispielsweise werden DWORD-Werte als Long-Integer-Werte behandelt, also &H0FFFFFFFF??? und -1& w?rden als gleiche Werte betrachtet. Dies kann dazu beitragen, dass bei Vergleichen zwischen vorzeichenbehafteten und vorzeichenlosen Werten keine Funktionen wie BITS mehr erforderlich sind.

AS CONST

In diesem Fall muss der steuernde Ausdruck im Bereich einer langen Ganzzahl ausgewertet werden. Allerdings muss jeder der Fallwerte streng durch ein numerisches Literal (oder numerisches Equate) im Bereich einer langen Ganzzahl angegeben werden. Es k?nnen mehrere Case-Werte angegeben werden (CASE 2,3,7), Operatoren und Wertebereiche sind jedoch nicht zul?ssig. CASE ELSE ist zul?ssig. Die Leistung wird durch die interne Erstellung einer Vektorsprungtabelle verbessert, die einen Eintrag f?r jede Zahl vom kleinsten bis zum gr??ten Fallwert enth?lt.

W?hrend diese Form der Struktur die gr??tm?gliche Leistung bietet, muss die Ausf?hrungsgeschwindigkeit sorgf?ltig gegen die erh?hte Programmgr??e abgewogen werden, insbesondere bei Verwendung von Werten mit geringer Fallzahl. Mit nur zwei CASE-Werten von 2 und 1000 w?rde die generierte Sprungtabelle beispielsweise 999 Tabelleneintr?ge (3996 Byte gro?) ben?tigen. Die gr??te zul?ssige Sprungtabelle f?r dieses Formular umfasst etwa 3200 Eintr?ge (12 KB). Bei ?berschreitung wird ein Fehler 402 generiert (?Anweisung zu lang/komplex?).

AS CONST$

In diesem Fall muss der steuernde Ausdruck eine ANSI-Zeichenfolge mit einer L?nge von null bis 255 Byte ergeben. Allerdings muss jeder der Case-Werte strikt durch ein String-Literal (einen ANSI-String in Anf?hrungszeichen oder ein ANSI-String-Equate) spezifiziert werden. Es k?nnen mehrere Case-Werte angegeben werden (CASE ?a?, ?Bob?, ?$value?), Operatoren und Wertebereiche sind jedoch nicht zul?ssig. Die Leistung wird durch die interne Erstellung einer vektorisierten Scantabelle mit acht Bytes f?r jeden angegebenen Fallwert verbessert.

AS CONST$$

In diesem Fall muss der steuernde Ausdruck eine WIDE-Zeichenfolge (Unicode) mit einer L?nge von null bis 127 Zeichen ergeben. Allerdings muss jeder der Case-Werte streng durch ein String-Literal (einen Wide-String in Anf?hrungszeichen oder ein Wide-String-Equate) spezifiziert werden. Es k?nnen mehrere Case-Werte angegeben werden (CASE ?a?$$,?Bob?$$,$$value), Operatoren und Wertebereiche sind jedoch nicht zul?ssig. Die Leistung wird durch die interne Erstellung einer vektorisierten Scantabelle mit acht Bytes f?r jeden angegebenen Fallwert verbessert.

Fokussierte V14-Validierung: tests/pb/test_control_flow_core.pb prueft SELECT CASE AS LONG, passende CASE-Zweige, CASE ELSE und EXIT SELECT.

Verifiziertes Beispiel: SELECT CASE - nach Wert verzweigen

Beispieldatei: examples/basic/help_control_flow/help_select_case.pb

Validierungsnachweis: examples/basic/test_select_case_as_long.pb; examples/tests/test_select_jump_table.pb; tests/e2e/pb/test_ctrl_select_range.pb

Validation evidence: the registered control-flow regression(s) named above compile and run with exit code 0, proving the page-specific branch, loop, or exception behavior documented here.

FUNCTION PBMAIN() AS LONG
    LOCAL x AS LONG
    x = 5
    SELECT CASE x
    CASE 1 TO 3
        FUNCTION = 1
    CASE 4 TO 6
        FUNCTION = 0
    CASE ELSE
        FUNCTION = 2
    END SELECT
END FUNCTION

Verhalten: Deckt Bereichsfaelle und CASE ELSE ab. Weitere registrierte Tests pruefen AS LONG und Jump-Table-Formen.

Siehe auch

  • CHOOSE
  • W?HLEN&
  • W?HLEN$
  • EXIT SELECT
  • IF
  • IF-Block
  • IIF
  • IIF&
  • IIF$
  • MAX
  • MAX&
  • MAX$
  • MIN
  • MIN&
  • MIN$
  • AUF GOTO
  • AUF GOSUB
  • SWITCH
  • SWITCH&
  • SWITCH$

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_select_0
FUNCTION PBMAIN() AS LONG
  LOCAL x AS LONG
  SELECT CASE 2
  CASE 1
    x = 10
  CASE 2
    x = 20
  CASE ELSE
    x = 30
  END SELECT
  IF (x) <> (20) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_select_1
FUNCTION PBMAIN() AS LONG
  LOCAL x AS LONG
  SELECT CASE 5
  CASE 1 TO 3
    x = 10
  CASE 4 TO 6
    x = 20
  CASE ELSE
    x = 30
  END SELECT
  IF (x) <> (20) THEN FUNCTION = 2: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_select_2
FUNCTION PBMAIN() AS LONG
  LOCAL x AS LONG
  SELECT CASE 10
  CASE IS > 5
    x = 100
  CASE IS < 0
    x = -1
  CASE ELSE
    x = 0
  END SELECT
  IF (x) <> (100) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_select_3
FUNCTION PBMAIN() AS LONG
  LOCAL x AS LONG
  SELECT CASE 0
  CASE IS > 5
    x = 100
  CASE ELSE
    x = 42
  END SELECT
  IF (x) <> (42) THEN FUNCTION = 4: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FOR � PBXB64-Compiler-Hilfe

Startseite � Funktionen � FOR

FOR

Beginnen Sie eine gez�hlte Schleife

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERF�GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

FOR counter = start TO end [STEP increment]
  [statements]
NEXT [counter]

Beschreibung

DerFOR...NEXT Die Anweisung f�hrt einen Anweisungsblock mit einer festen Anzahl von Malen aus. Die counter Variable wird initialisiert auf start, getestet gegen endund erh�ht um increment (oder um 1, wenn STEP wird weggelassen) nach jeder Iteration.

Die Schleife endet, wenn der Test fehlschl�gt. Wenn STEP negativ ist, z�hlt die Schleife abw�rts und der Test wird umgekehrt.

Parameter

Parameter | Beschreibung
counter | Eine numerische Variable. Unterst�tzte Typen: LONG, INTEGER, QUAD, DWORD, WORD, BYTE, CURRENCY, SINGLE, DOUBLE, EXTENDED.
start | Der dem Z�hler zugewiesene Anfangswert.
end | Der Grenzwert, der am Anfang jeder Iteration getestet wird.
increment | Optional. Der Betrag, der nach jeder Iteration zum Z�hler hinzugef�gt wird. Der Standardwert ist 1.

Beispiel

FUNCTION PBMAIN () AS LONG
    LOCAL i AS LONG
    LOCAL sum AS LONG
    sum = 0
    FOR i = 1 TO 5
        sum = sum + i
    NEXT i
    FUNCTION = sum
END FUNCTION

Dieses Programm gibt 15 (1+2+3+4+5) zur�ck.

Generierter Assembler-Code

Kompilieren mit:

PBXB64 example.pb --asmout example.asm

Die Schleife wird auf einen Bedingungsblock, einen Hauptblock und einen Schrittblock reduziert. Der Z�hler befindet sich in einem Stapelsteckplatz:

pb_for_cond_PBMAIN_0:
    mov r10, [rbp-24]
    mov rbx, r10
    cmp rbx, 5
    setle r10
    mov rbx, r10
    test rbx, rbx
    jne pb_for_body_PBMAIN_1
    jmp pb_for_end_PBMAIN_3
pb_for_body_PBMAIN_1:
    ; sum = sum + i
    mov r10, [rbp-32]
    mov rbx, r10
    mov r10, [rbp-24]
    add rbx, r10
    mov [rbp-32], rbx
    jmp pb_for_step_PBMAIN_2
pb_for_step_PBMAIN_2:
    mov r10, [rbp-24]
    mov rbx, r10
    add rbx, 1
    mov [rbp-24], rbx
    jmp pb_for_cond_PBMAIN_0
pb_for_end_PBMAIN_3:

Hinweise

  • Das �ndern der Z�hlervariablen innerhalb des Schleifenk�rpers ist zul�ssig, wirkt sich jedoch auf die Anzahl der Iterationen aus.
  • Float-Z�hler (SINGLE, DOUBLE, EXTENDED) werden unterst�tzt; Der generierte Code verwendet SSE-Vergleiche und -Erg�nzungen.
  • VerwendenEXIT FOR die Schleife vorzeitig verlassen und ITERATE FOR to skip to the next iteration.

Verifiziertes Beispiel: FOR...NEXT - gezaehlte Schleife

Beispieldatei: examples/basic/help_control_flow/help_for.pb

Validierungsnachweis: tests/integration/pbxa64/control_flow/test_control_flow_comprehensive.pb

Validation evidence: the registered control-flow regression(s) named above compile and run with exit code 0, proving the page-specific branch, loop, or exception behavior documented here.

FUNCTION PBMAIN() AS LONG
    LOCAL sum AS LONG
    LOCAL i AS LONG
    FOR i = 0 TO 9
        sum = sum + i
    NEXT i
    IF sum <> 45 THEN FUNCTION = 1 ELSE FUNCTION = 0
END FUNCTION

Verhalten: Testet eine gezaehlte Schleife mit expliziter Schleifenvariable und prueft das aufsummierte Ergebnis.

Siehe auch

  • WEITER
  • EXIT FOR
  • ITERATE FOR
  • WHILE
  • DO
  • Kontrollflussreferenz

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


DO ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? DO

DO

Beginnen Sie eine DO-Schleife

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DO [{WHILE | UNTIL} condition]
  [statements]
LOOP

Beschreibung

DerDO Die Anweisung beginnt eine flexible Schleife. Ohne Klausel bildet es eine Endlosschleife, die mit verlassen werden muss EXIT DO. DO WHILEUndDO UNTIL Testen Sie die Bedingung am Anfang der Schleife.

Beispiel

FUNCTION PBMAIN () AS LONG
    LOCAL n AS LONG
    LOCAL sum AS LONG
    n = 1
    sum = 0
    DO WHILE n <= 5
        sum = sum + n
        n = n + 1
    LOOP
    FUNCTION = sum
END FUNCTION

Generierter Assembler-Code

Kompilieren mit:

PBXB64 example.pb --asmout example.asm
pb_do_cond_PBMAIN_0:
    mov r10, [rbp-24]
    mov rbx, r10
    cmp rbx, 5
    setle r10
    mov rbx, r10
    test rbx, rbx
    jne pb_do_body_PBMAIN_1
    jmp pb_do_end_PBMAIN_2
pb_do_body_PBMAIN_1:
    mov r10, [rbp-32]
    mov rbx, r10
    mov r10, [rbp-24]
    add rbx, r10
    mov [rbp-32], rbx
    mov r10, [rbp-24]
    mov rbx, r10
    add rbx, 1
    mov [rbp-24], rbx
    jmp pb_do_cond_PBMAIN_0
pb_do_end_PBMAIN_2:

Hinweise

DO UNTIL condition ist ?quivalent zu DO WHILE NOT condition.

Fokussierte V14-Validierung: tests/pb/test_control_flow_core.pb prueft EXIT DO, EXIT LOOP, ITERATE DO, ITERATE LOOP, LOOP WHILE und LOOP UNTIL in kompilierten Link/Run-Tests.

Praktische Verwendung

DO gehoert zur Kategorie General. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' DO mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Siehe auch

  • Schleife
  • W?hrend
  • Ausstieg
  • Iterieren
  • Basic Ref Control Flow


WHILE � PBXB64-Compiler-Hilfe

Startseite � Funktionen � WHILE

WHILE

Loop while a condition is true

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERF�GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

WHILE condition
  [statements]
WEND

Beschreibung

DerWHILE...WEND Die Anweisung f�hrt einen Anweisungsblock aus, solange condition ist wahr. Die Bedingung wird vor jeder Iteration getestet, sodass der K�rper m�glicherweise null Mal ausgef�hrt wird.

Beispiel

FUNCTION PBMAIN () AS LONG
    LOCAL n AS LONG
    LOCAL sum AS LONG
    n = 1
    sum = 0
    WHILE n <= 5
        sum = sum + n
        n = n + 1
    WEND
    FUNCTION = sum
END FUNCTION

Generierter Assembler-Code

Kompilieren mit:

PBXB64 example.pb --asmout example.asm
    mov rbx, 1
    mov [rbp-24], rbx
    xor rbx, rbx
    mov [rbp-32], rbx
pb_while_cond_PBMAIN_0:
    mov r10, [rbp-24]
    mov rbx, r10
    cmp rbx, 5
    setle r10
    mov rbx, r10
    test rbx, rbx
    jne pb_while_body_PBMAIN_1
    jmp pb_while_end_PBMAIN_2
pb_while_body_PBMAIN_1:
    mov r10, [rbp-32]
    mov rbx, r10
    mov r10, [rbp-24]
    add rbx, r10
    mov [rbp-32], rbx
    mov r10, [rbp-24]
    mov rbx, r10
    add rbx, 1
    mov [rbp-24], rbx
    jmp pb_while_cond_PBMAIN_0
pb_while_end_PBMAIN_2:

Hinweise

VerwendenEXIT LOOPoderEXIT DO um eine WHILE-Schleife vorzeitig zu verlassen.

Verifiziertes Beispiel: WHILE...WEND - Schleife mit Vorabpruefung

Beispieldatei: examples/basic/help_control_flow/help_while.pb

Validierungsnachweis: tests/integration/pbxa64/control_flow/test_control_flow_comprehensive.pb

Validation evidence: the registered control-flow regression(s) named above compile and run with exit code 0, proving the page-specific branch, loop, or exception behavior documented here.

FUNCTION PBMAIN() AS LONG
    LOCAL i AS LONG
    WHILE i < 5
        i = i + 1
    WEND
    IF i <> 5 THEN FUNCTION = 1 ELSE FUNCTION = 0
END FUNCTION

Verhalten: Testet WHILE/WEND mit einer Bedingung, die vor jeder Iteration geprueft wird.

Siehe auch

  • Tun Sie es
  • Schleife
  • Ausstieg
  • Iterieren
  • Basic Ref Control Flow

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GOTO ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? GOTO

GOTO

Unbedingte Verzweigung zu einem Label

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GOTO label
label:

Beschreibung

DerGOTO Die Anweisung ?bertr?gt die Ausf?hrung an eine gekennzeichnete Anweisung in derselben Prozedur. Beschriftungen sind Bezeichner, denen ein Doppelpunkt folgt, und m?ssen innerhalb der Prozedur eindeutig sein.

Beispiel

FUNCTION PBMAIN () AS LONG
    LOCAL n AS LONG
    n = 0
start:
    n = n + 1
    IF n < 5 THEN GOTO start
    FUNCTION = n
END FUNCTION

Generierter Assembler-Code

Kompilieren mit:

PBXB64 example.pb --asmout example.asm
start_PBMAIN_0:
    mov r10, [rbp-24]
    mov rbx, r10
    add rbx, 1
    mov [rbp-24], rbx
    mov r10, [rbp-24]
    mov rbx, r10
    cmp rbx, 5
    setl r10
    mov rbx, r10
    test rbx, rbx
    jne start_PBMAIN_0
    jmp pb_goto_after_PBMAIN_1
pb_goto_after_PBMAIN_1:

Hinweise

?berm??iger Gebrauch von GOTO macht es schwierig, dem Code zu folgen. Bevorzugen WHILE, FOR, oderDO f?r Schleifen.

Fokussierte V14-Validierung: tests/pb/test_control_flow_core.pb prueft, dass laufzeitbestimmtes ON choice GOTO label1, label2, label3 PBWin-kompatible 1-basierte Auswahl verwendet und bei Werten ausserhalb des Bereichs durchfaellt.

Praktische Verwendung

GOTO gehoert zur Kategorie General. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' GOTO mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Siehe auch

  • Gosub
  • Zur?ckkehren
  • W?hrend
  • F?r
  • Basic Ref Control Flow


GOSUB � PBXB64-Compiler-Hilfe

Startseite � Funktionen � GOSUB

GOSUB

Rufen Sie eine Unterroutine auf.

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERF�GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GOSUB { label | linenumber }
GOSUB DWORD dwpointer

Beschreibung

GOSUB bewirkt, dass die Ausf�hrung zu der Anweisung verzweigt, der die Bezeichnung oder Zeilennummer vorangestellt ist, nachdem zun�chst der aktuelle Speicherort auf dem Stapel gespeichert wurde. Die Bezeichnung oder Zeilennummer muss lokal f�r die Sub , Function , Method oder Property sein, in der sich die GOSUB-Anweisung befindet. Das Ausf�hren einer RETURN-Anweisung gibt die Kontrolle an die Anweisung zur�ck, die unmittelbar auf GOSUB folgt.

Stellen Sie bei der Verwendung von GOSUB sicher, dass jede Unterroutine �ber eine RETURN-Anweisung ordnungsgem�� zu ihrem Aufrufer zur�ckkehrt. Au�er Kontrolle geratene (rekursive) GOSUBs, die sich selbst in einer Schleife ausf�hren, verbrauchen gro�e Teile des Stapelspeichers und verringern so den verf�gbaren Speicher.

Alle Beschriftungen und Zeilennummern sind privat. Sie k�nnen kein GOSUB zu einem Label au�erhalb der aktuellen Prozedur verwenden.

Bei zeitkritischem oder leistungsstarkem Code ist die Verwendung eines GOSUB zum Ausf�hren einer sich wiederholenden Aufgabe fast immer schneller als der Aufruf einer Prozedur, da beim Einrichten eines Stapelrahmens f�r ein GOSUB kein Overhead entsteht.

GOSUB DWORD bewirkt, dass die Ausf�hrung zur im DW-Zeiger gespeicherten Adresse verzweigt, nachdem zun�chst der aktuelle Speicherort auf dem Stapel gespeichert wurde. dwpointer muss eine Double Word-, Long Integer- oder Zeigervariable sein, die die Adresse einer Bezeichnung enth�lt, die sich in derselben Prozedur wie die GOSUB DWORD-Anweisung befindet. Das Ausf�hren einer RETURN-Anweisung gibt die Kontrolle an die Anweisung zur�ck, die unmittelbar auf die GOSUB DWORD-Anweisung folgt.

Fokussierte V14-Validierung: tests/pb/test_control_flow_core.pb prueft, dass laufzeitbestimmtes ON choice GOSUB label1, label2, label3 PBWin-kompatible 1-basierte Auswahl verwendet, jeder gewaehlte Zweig mit RETURN zurueckkehrt und Werte ausserhalb des Bereichs durchfallen.

Verifiziertes Beispiel: GOSUB...RETURN - lokale Legacy-Unterroutine

Beispieldatei: examples/basic/help_control_flow/help_gosub.pb

Validierungsnachweis: tests/e2e/pb/test_proc_gosub.pb; examples/tests/fix_gosub.pb; tests/e2e/pb/test_integration_all.pb

Validation evidence: the registered control-flow regression(s) named above compile and run with exit code 0, proving the page-specific branch, loop, or exception behavior documented here.

FUNCTION PBMAIN() AS LONG
    LOCAL result AS LONG
    GOSUB addTen
    IF result <> 10 THEN FUNCTION = 1 ELSE FUNCTION = 0
    EXIT FUNCTION
addTen:
    result = result + 10
RETURN
END FUNCTION

Verhalten: Testet, dass RETURN nach dem GOSUB-Aufruf fortsetzt. Fuer neuen Code SUB/FUNCTION bevorzugen.

Siehe auch

  • #STACK
  • FUNCTION
  • METHOD
  • AUF GOSUB
  • PROPERTY
  • SUB
  • ZUR�CK

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_gosub
FUNCTION PBMAIN() AS LONG
  LOCAL s AS LONG
  s = 0
  GOSUB AddFive
  s = s + 1
  IF (s) <> (6) THEN FUNCTION = 1: EXIT FUNCTION
  EXIT FUNCTION
AddFive:
  s = s + 5
  RETURN
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TRY/END TRY ? Hilfe zum PBXB64-Compiler

Startseite ? Funktionen ? VERSUCHEN/ENDVERSUCHEN

VERSUCHEN/END VERSUCHEN

Eine strukturierte Methode zum Einfangen und Reagieren

Typ:Schl?sselwort |Kategorie: Control Flow

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

TRY
[ statements ]
[EXIT TRY]
CATCH
[ error handling statements ]
[FINALLY
[ statements ]]
END TRY

Beschreibung

Anweisungen im TRY-Abschnitt werden normal ausgef?hrt. Beim ersten Auftreten eines Laufzeitfehlers wird die Steuerung an den CATCH-Abschnitt ?bergeben. Wenn im TRY-Abschnitt keine Laufzeitfehler generiert werden, wird der CATCH-Abschnitt vollst?ndig ?bersprungen.

Anschlie?end wird unabh?ngig vom Fehlerstatus der Abschnitt FINALLY ausgef?hrt, sofern er vorhanden ist. Fehlerabfangen und Kontroll?bertragung sind in den Abschnitten CATCH und FINALLY deaktiviert, daher w?rden Sie normalerweise herk?mmliche ?IF ERR =?-Tests verwenden, um den Erfolg fehleranf?lliger Vorg?nge in diesen Abschnitten zu ?berpr?fen.

Allerdings k?nnen TRY-Strukturen auf jeder Ebene verschachtelt werden, daher kann es w?nschenswert sein, innerhalb dieser Klauseln einen weiteren TRY-Block zu verwenden.

Einschr?nkungen

CATCH ist ein obligatorischer Abschnitt dieser Struktur, obwohl der Abschnitt FINALLY optional ist.

Aufgrund der Verschachtelungsanforderungen ist der ERR-Wert lokal f?r die TRY-Struktur. Beim Beenden wird der vorherige ERR-Wert wiederhergestellt. Stellen Sie daher sicher, dass Sie den ERR-Wert speichern, wenn er au?erhalb der TRY-Struktur ben?tigt wird.

Um die TRY-Struktur zu verlassen, muss die Ausfuehrung normal ueber END TRY oder eine EXIT TRY-Anweisung erfolgen. In PBXB64 verlaesst EXIT TRY den aktiven TRY-Block, ueberspringt die restlichen TRY-Anweisungen und den CATCH-Abschnitt, fuehrt FINALLY aus, falls vorhanden, und setzt danach hinter END TRY fort. EXIT TRY ausserhalb eines TRY-Blocks ist ein Kompilierfehler.

Es wird dringend davon abgeraten, einen TRY-Block auf andere Weise zu verlassen, da das Fehler-Trapping deaktiviert bleiben kann und der vorherige ERR-Wert moeglicherweise nicht wiederhergestellt wird.

ON ERROR GOTO ist innerhalb einer TRY-Struktur ung?ltig, kann aber innerhalb derselben Sub / Function / Method / Property verwendet werden.

Praktische Verwendung

VERSUCHEN/END VERSUCHEN gehoert zur Kategorie General. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' VERSUCHEN/END VERSUCHEN mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Siehe auch

  • #DEBUG-FEHLER
  • ERL
  • ERR
  • ERRCLEAR
  • FEHLER
  • Fehler?bersicht
  • FEHLER$
  • Fehler-Trapping
  • AUF FEHLER


EXIT � PBXB64-Compiler-Hilfe

Startseite � Funktionen � EXIT

AUSFAHRT

�bertragen Sie die Programmausf�hrung aus einer Blockstruktur

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERF�GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

EXIT FOR
EXIT DO | EXIT LOOP
EXIT WHILE
EXIT IF
EXIT FUNCTION
EXIT SUB
EXIT FASTPROC
EXIT SELECT
EXIT [,EXIT ...]

Beschreibung

Die Anweisung EXIT verlaesst sofort die umschliessende Blockstruktur. EXIT FOR, EXIT DO/EXIT LOOP und EXIT WHILE verlassen Schleifen; EXIT IF verlaesst den aktuellen mehrzeiligen IF...END IF-Block; EXIT FUNCTION, EXIT SUB und EXIT FASTPROC kehren aus Prozeduren zurueck. Mehrere durch Kommas getrennte EXIT-Schluesselwoerter verlassen verschachtelte Strukturen von innen nach aussen.

Beispiel

FUNCTION PBMAIN () AS LONG
    LOCAL i AS LONG
    FOR i = 1 TO 100
        IF i > 10 THEN EXIT FOR
    NEXT i
    FUNCTION = i
END FUNCTION

Dieses Programm verl�sst die Schleife, sobald i �berschreitet 10 und gibt 11 zur�ck.

Generierter Assembler-Code

Kompilieren mit:

PBXB64 example.pb --asmout example.asm

EXIT FOR f�hrt zu einem bedingungslosen Sprung zum Endlabel der Schleife:

    mov r10, [rbp-24]
    mov rbx, r10
    cmp rbx, 10
    setg r10
    mov rbx, r10
    test rbx, rbx
    jne pb_if_then_PBMAIN_0
    jmp pb_if_else_PBMAIN_1
pb_if_then_PBMAIN_0:
    jmp pb_for_end_PBMAIN_2
pb_if_else_PBMAIN_1:
    jmp pb_for_step_PBMAIN_3

Hinweise

  • EXIT DOUndEXIT LOOP sind f�r DO/LOOP �quivalent.
  • EXIT IF zielt auf den aktiven Block-IF-Rahmen. Ausserhalb eines IF-Blocks ist es ein Kompilierfehler.
  • EXIT FASTPROC ist nur innerhalb eines FASTPROC-Blocks gueltig. In einer normalen FUNCTION oder SUB ist es ein Kompilierfehler.
  • Eine Funktion verlassen mit EXIT FUNCTION wertet kein Trailing aus FUNCTION = Aufgabe; Legen Sie den R�ckgabewert vor dem Beenden explizit fest.

Fokussierte V14-Validierung: tests/pb/test_control_flow_core.pb prueft EXIT FOR, EXIT DO, EXIT LOOP, EXIT SELECT und EXIT SUB. tests/pb/test_exit_fastproc.pb prueft EXIT FASTPROC innerhalb eines mit END FASTPROC beendeten FASTPROC-Blocks. tests/pb/test_exit_fastproc_reject.pb und tests/pb/test_exit_fastproc_reject_extra.pb pruefen die gezielten Diagnosen fuer falschen Kontext und zusaetzliche Token.

Verifiziertes Beispiel: EXIT - Block vorzeitig verlassen

Beispieldatei: examples/basic/help_control_flow/help_exit.pb

Validierungsnachweis: examples/basic/test_exit_function_expr.pb; docs/pbwin_reviewed_control_flow_summary.md

Validation evidence: the registered control-flow regression(s) named above compile and run with exit code 0, proving the page-specific branch, loop, or exception behavior documented here.

FUNCTION PBMAIN() AS LONG
    LOCAL i AS LONG
    FOR i = 1 TO 10
        IF i = 3 THEN EXIT FOR
    NEXT i
    IF i <> 3 THEN FUNCTION = 1 ELSE FUNCTION = 0
END FUNCTION

Verhalten: Testet das vorzeitige Verlassen einer Schleife. EXIT FUNCTION ist durch den registrierten Funktionstest abgedeckt.

Siehe auch

  • FOR
  • WEITER
  • WHILE
  • DO
  • LOOP
  • ITERATE
  • Kontrollflussreferenz

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


WEITER - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Kontrollfluss › WEITER
Hilfe zum PBXB64-Compiler

WEITER

Kompatibilitätsthema für Schleifen-Fortsetzungssemantik; PBXB64-BASIC verwendet ITERATE als echte Anweisung.

Kind: Anweisung | Category: Control Flow

PBXB64 Status: TEILWEISE

PBXB64 Certification: [TEILWEISE GETESTET]

Syntax

ITERATE FOR
ITERATE DO
ITERATE LOOP

Description

Die BASIC-Frontend-Implementierung von PBXB64 setzt das Verhalten von CONTINUE mit ITERATE um. Diese Seite existiert, damit die Kontrollfluss-Gliederung das Konzept an einer Stelle zeigen kann, auch wenn andere Dialekte CONTINUE nennen.

Bei FOR/NEXT-Schleifen springt die Fortsetzungsaktion in den Schrittblock. Bei DO/LOOP- und WHILE/WEND-Schleifen springt sie zur Bedingungsprüfung.

Wenn Sie PBXB64-BASIC schreiben, verwenden Sie ITERATE FOR, ITERATE DO oder ITERATE LOOP. Genau diese Syntax wird vom Compiler umgesetzt.

Example

' Getestetes Beispiel: examples/basic/v4_control.bas
FUNCTION PBMAIN() AS LONG
    LOCAL i AS LONG
    FOR i = 1 TO 10
        IF i = 5 THEN ITERATE FOR
    NEXT i
    PBMAIN = 0
END FUNCTION

Hinweise

  • Diese Seite ist eine Kompatibilitäts- und Navigationsseite, keine eigenständige BASIC-Keyword-Implementierung.
  • Verwenden Sie EXIT, wenn Sie die Schleife ganz verlassen wollen.

Verifiziertes Beispiel: ITERATE - zur naechsten Schleifenrunde springen

Beispieldatei: examples/basic/help_control_flow/help_iterate.pb

Validierungsnachweis: docs/pbwin_reviewed_control_flow_summary.md; tests/pb/test_all_control.bas

Validation evidence: the registered control-flow regression(s) named above compile and run with exit code 0, proving the page-specific branch, loop, or exception behavior documented here.

FUNCTION PBMAIN() AS LONG
    LOCAL i AS LONG
    LOCAL sum AS LONG
    FOR i = 1 TO 4
        IF i = 2 THEN ITERATE FOR
        sum = sum + i
    NEXT i
    IF sum <> 8 THEN FUNCTION = 1 ELSE FUNCTION = 0
END FUNCTION

Verhalten: Dokumentiert die PBXB64-Anweisung zum Fortsetzen der naechsten Schleifenrunde. Die Kompatibilitaetsseite CONTINUE verweist BASIC-Anwender auf die implementierte ITERATE-Form.

See Also

  • ITERATE
  • FOR / WEITER
  • DO / LOOP
  • WHILE / WENDE
  • AUSFAHRT

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


GRUNDLEGENDE Fehlerbehandlung — PBXB64 Help

Startseite › BASIC Frontend › Error Handling

GRUNDLEGENDE Fehlerbehandlung

Laufzeitfehlerkontrolle.

Aufgabe dieses Kapitels

Dieses Kapitel sammelt die BASIC-Sprachmittel zu einem zusammenhängenden Arbeitsbereich. Es dient als Einstieg, wenn Sie nicht den exakten Befehlsnamen kennen, sondern eine Spracheigenschaft suchen.

Verwendung

Beginnen Sie mit der Tabelle unten und wechseln Sie dann zur Detailseite des einzelnen Befehls. Die Detailseiten enthalten Syntax, Hinweise zur PBXB64-Unterstützung, Getestetes Beispiel und Querverweise.

Befehlsübersicht

Befehl | Bereich
FEHLER | Laufzeitfehlerkontrolle.
AUF FEHLER | Laufzeitfehlerkontrolle.
WIEDER AUFNEHMEN | Laufzeitfehlerkontrolle.
ERR | Laufzeitfehlerkontrolle.

Getestetes Beispiel

Diese Seite ist ein Uebersichtskapitel. Die verlinkten Einzelseiten enthalten die konkreten getesteten Beispiele oder nennen eine ausdrueckliche Begrenzung, wenn ein Befehl nicht zertifiziert ist.

PBXB64-Status: Uebersicht / Navigation; keine eigenstaendige Laufzeitbehauptung ohne Unterseitenbeleg.

Praktische Hinweise

BASIC-Quelltext wird im PBXB64-Frontend direkt in die gemeinsame Zwischenrepräsentation übersetzt. Achten Sie deshalb besonders auf Datentypen, ByVal/ByRef-Übergabe, Zeichenkettenlängen und Laufzeitfehlerpfade.

Siehe auch

  • BASIC-Sprachübersicht

← Back

Fehlerpfad-Prüfung

Fehlerbehandlungsseiten sollen den normalen Pfad und den Fehlerpfad zeigen. Ein vollständiges Beispiel löst absichtlich einen bekannten Fehler aus, prüft den dokumentierten Fehlerwert, stellt wieder her oder beendet sauber und zeigt, dass spätere Anweisungen in der erwarteten Reihenfolge laufen.

Zustandsregeln

Dokumentieren Sie, welche Variablen, Handler oder Systemwerte durch die Operation geändert werden. Vermeiden Sie Beispiele, die einen Fehler durch ungeprüftes Weiterlaufen verdecken.

Migrationshinweise

Beim Portieren älteren PB-Codes sind Annahmen zu Zeilennummern, Handler-Gültigkeit, verschachtelten Prozeduren und Windows-API-Fehlern neu zu prüfen.


ERR-Systemvariable - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Fehlerreferenz › ERR-Systemvariable
Hilfe zum PBXB64-Compiler

ERR-Systemvariable

Liest oder setzt den aktuellen Laufzeit-Fehlercode.

Kind: Schlüsselwort | Category: Error Reference

PBXB64 Status: VERFÜGBAR

PBXB64 Certification: [ZERTIFIZIERT GETESTET]

Syntax

x = ERR
ERR = ErrNum
x = ERRCLEAR
ERRCLEAR

Description

ERR gibt den Code des letzten Laufzeitfehlers in der aktuellen Prozedur zurück. Eine Zuweisung an ERR setzt den aktuellen Fehlerwert, ohne zu einem Fehlerhandler zu verzweigen.

ERRCLEAR gibt den aktuellen Fehlercode zurück und setzt dann den internen Fehlerstatus zurück. Verwenden Sie es, wenn Sie den letzten Fehler ansehen und den Zustand in einem Schritt zurücksetzen wollen.

Diese beiden Formen sind der normale Niedriglevel-Zugriff auf Laufzeitfehler in PBXB64. Das ist besonders nützlich bei Datei-E/A, Objektaufrufen und allen Operationen, die fehlschlagen können, ohne das Programm zu beenden.

Example

' Getestetes Beispiel: tests/pb/test_all_error_handling.bas
FUNCTION PBMAIN() AS LONG
    LOCAL n AS LONG
    n = ERRCLEAR
    IF n <> 0 THEN FUNCTION = n : EXIT FUNCTION
    FUNCTION = 0
END FUNCTION

Hinweise

  • Gültige Laufzeitfehler liegen im Bereich von 0 bis 255.
  • Wenn Sie den beschreibenden Text für eine Fehlernummer brauchen, verwenden Sie ERROR$.

Verifiziertes Beispiel: ERR - aktuellen Fehlercode lesen

Beispieldatei: examples/basic/help_error_handling/help_err.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_error_handling/help_err.pb -o tmp/help_error_samples/help_err.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    LOCAL n AS LONG
    n = ERR
    IF n <> 0 THEN FUNCTION = 1
END FUNCTION

Verhalten: Liest ERR beim Programmstart und prueft, dass der Anfangsfehlercode null ist. Focus form: n = ERR

See Also

  • ERROR$
  • Fehlerübersicht
  • Fehler-Trapping
  • AUF FEHLER

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


ERROR$ ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? ERROR$

FEHLER$

Gibt eine Zeichenfolge zur?ck

Typ:Funktion |Kategorie: Control Flow

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

msg$ = ERROR$[( ErrNum )]

Beschreibung

ERROR$ gibt den ausf?hrlichen Texttitel eines durch ErrNum identifizierten PowerBASIC-Laufzeitfehlers zur?ck.

ErrNum muss im Bereich von 1 bis einschlie?lich 255 liegen. Werte au?erhalb dieses Bereichs geben ?Kein Fehler? zur?ck. Wenn ErrNum nicht angegeben ist, gibt ERROR$ die Beschreibung des aktuellen Werts von ERR zur?ck.

Verifiziertes Beispiel: ERROR$ - Fehlercode in Text uebersetzen

Beispieldatei: examples/basic/help_error_handling/help_error.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_error_handling/help_error.pb -o tmp/help_error_samples/help_error.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    LOCAL s AS STRING
    s = ERROR$(53)
    IF LEN(s) = 0 THEN FUNCTION = 1
END FUNCTION

Verhalten: Schlaegt einen bekannten Fehlercode nach und prueft, dass ein nichtleerer Text geliefert wird. Focus form: s = ERROR$(53)

Siehe auch

  • #DEBUG-ANZEIGE
  • ERL
  • ERR
  • ERRCLEAR
  • FEHLER
  • Fehler?bersicht
  • Fehler-Trapping
  • AUF FEHLER

Fehlerpfad-Prüfung

Fehlerbehandlungsseiten sollen den normalen Pfad und den Fehlerpfad zeigen. Ein vollständiges Beispiel löst absichtlich einen bekannten Fehler aus, prüft den dokumentierten Fehlerwert, stellt wieder her oder beendet sauber und zeigt, dass spätere Anweisungen in der erwarteten Reihenfolge laufen.

Zustandsregeln

Dokumentieren Sie, welche Variablen, Handler oder Systemwerte durch die Operation geändert werden. Vermeiden Sie Beispiele, die einen Fehler durch ungeprüftes Weiterlaufen verdecken.

Migrationshinweise

Beim Portieren älteren PB-Codes sind Annahmen zu Zeilennummern, Handler-Gültigkeit, verschachtelten Prozeduren und Windows-API-Fehlern neu zu prüfen.


BEI FEHLER ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? BEI FEHLER

AUF FEHLER

Geben Sie eine an

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ON ERROR GOTO { label | line_number }
ON ERROR RESUME NEXT
ON ERROR GOTO 0

Beschreibung

label oder line_number identifiziert die erste Zeile der Fehler-Trapping-Routine. Sobald die Fehlerbehandlung mit dieser Anweisung aktiviert wurde, f?hren alle Laufzeitfehler zu einem Sprung zu Ihrem Fehlerbehandlungscode. Wenn die Fehlerbehandlungsroutine mit der Ausf?hrung beginnt, wird die zus?tzliche Fehlerunterdr?ckung vor?bergehend ausgesetzt. Wenn Ihre Fehlerbehandlung abgeschlossen ist, m?ssen Sie die RESUME-Anweisung (in beliebiger Form) verwenden, um die Ausf?hrung fortzusetzen. RESUME reaktiviert die vor?bergehende Aussetzung des Fehler-Trappings.

Sie m?ssen besonders vorsichtig sein, wenn Sie einen Fehler in einem GOSUB-Codeblock abfangen, da eine RETURN-Adresse auf dem Systemstapel gespeichert wurde. Wenn Sie eine Form von RESUME verwenden, die erneut in den GOSUB-Block eintritt, wird sp?ter trotzdem ein RETURN ausgef?hrt und der Stapel ausgeglichen. Wenn RESUME <Label> oder RESUME FLUSH die Ausf?hrung jedoch an eine andere Stelle umleitet, m?ssen Sie RETURN FLUSH verwenden, um die R?cksprungadresse vom Stapel zu entfernen.

Um das Fehler-Trapping zu deaktivieren, verwenden Sie ON ERROR GOTO 0 oder ON ERROR RESUME NEXT. Sie k?nnen diese Technik verwenden, wenn ein Fehler auftritt, f?r den Sie keinen Wiederherstellungspfad definiert haben; Sie k?nnen zu diesem Zeitpunkt auch w?hlen, ob der Inhalt von ERR oder ERRCLEAR angezeigt werden soll.

Die Standardeinstellung f?r die Fehlerunterdr?ckung ist deaktiviert. Wenn ein Fehler auftritt, w?hrend das Fehler-Trapping deaktiviert ist, wird der Fehlercode in die Systemvariable ERR eingef?gt und die Ausf?hrung fortgesetzt. Fehler k?nnen weiterhin abgefangen werden, indem der Wert der Variablen ERR oder ERRCLEAR mit den Anweisungen IF ERR THEN oder SELECT CASE ERR ?berpr?ft wird.

Das Fehlerabfangen erfolgt lokal f?r jedes Sub, jede Funktion, jede Methode und jede Eigenschaft. PowerBASIC unterst?tzt kein globales Fehler-Trapping.

Numerische Fehler wie Division durch Null, ?berlauf und Unterlauf werden nicht abgefangen. Array-Out-of-Bounds und Nullzeiger-Trapping sind nur aktiviert, wenn #DEBUG ERROR ON verwendet wird.

Wenn Sie ein Programm mit deaktivierter Fehlerunterdr?ckung ausf?hren, kann ein Laufzeitfehler eine allgemeine Schutzverletzung (GPF) verursachen. Ein GPF kann nicht mit ON ERROR abgefangen werden.

Es ist nicht m?glich, innerhalb eines Ausdrucks zu einem Fehlerbehandler zu verzweigen. Der Compiler pr?ft erst, ob ein Fehler vorliegt, nachdem die Anweisung abgeschlossen ist. Dies bedeutet, dass eine Anweisung wie:

ON ERROR GOTO ErrorHandlerLabel

IF GETATTR( sFile ) THEN

?Tu etwas

END IF

generiert einen Fehler 53, wenn sFile nicht vorhanden ist, verzweigt jedoch nicht zum ErrorHandlerLabel . Dies liegt daran, dass GETATTR (sFile) ein Ausdruck im IF/END IF-Block ist. Du k?nntest eins machen

ON ERROR GOTO ErrorHandlerLabel

a& = GETATTR(sFile)f

IF und THEN

?Tu etwas

END IF

Dies verzweigt zum ErrorHandlerLabel, wenn sFile nicht vorhanden ist. Sie k?nnen auch den Wert der ERR-Variablen ?berpr?fen oder einen TRY/END TRY-Block verwenden, um zu sehen, ob bei der Pr?fung auf Fehler, die w?hrend eines Ausdrucks auftreten, ein Fehler aufgetreten ist.

Verifiziertes Beispiel: ON ERROR - lokalen Handler setzen

Beispieldatei: examples/basic/help_error_handling/help_on_error.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_error_handling/help_on_error.pb -o tmp/help_error_samples/help_on_error.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    LOCAL n AS LONG

    ON ERROR GOTO handler
    n = 1
    ERROR 5
    n = 2

    IF n <> 2 THEN FUNCTION = 1
    EXIT FUNCTION

handler:
    RESUME
END FUNCTION

Verhalten: Loest ERROR 5 aus, springt in den lokalen Handler, setzt fort und prueft, dass die erwartete Fortsetzung erreicht wird. Focus form: ON ERROR GOTO handler

Siehe auch

  • #DEBUG-ANZEIGE
  • #DEBUG-FEHLER
  • ERR
  • ERRCLEAR
  • FEHLER
  • Fehler?bersicht
  • FEHLER$
  • Fehler und Fehler-Trapping
  • WIEDER AUFNEHMEN

Fehlerpfad-Prüfung

Fehlerbehandlungsseiten sollen den normalen Pfad und den Fehlerpfad zeigen. Ein vollständiges Beispiel löst absichtlich einen bekannten Fehler aus, prüft den dokumentierten Fehlerwert, stellt wieder her oder beendet sauber und zeigt, dass spätere Anweisungen in der erwarteten Reihenfolge laufen.

Zustandsregeln

Dokumentieren Sie, welche Variablen, Handler oder Systemwerte durch die Operation geändert werden. Vermeiden Sie Beispiele, die einen Fehler durch ungeprüftes Weiterlaufen verdecken.

Migrationshinweise

Beim Portieren älteren PB-Codes sind Annahmen zu Zeilennummern, Handler-Gültigkeit, verschachtelten Prozeduren und Windows-API-Fehlern neu zu prüfen.


RESUME ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? RESUME

WIEDER AUFNEHMEN

Starten Sie anschlie?end die Programmausf?hrung neu

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

RESUME
RESUME NEXT
RESUME FLUSH
RESUME < Label >

Beschreibung

Die RESUME-Anweisung wird verwendet, um die Ausf?hrung eines Programms fortzusetzen, nachdem ein Laufzeitfehler abgefangen und mit einem ON ERROR-Handler verarbeitet wurde. RESUME (in beliebiger Form) teilt PowerBASIC mit, dass die Fehlerverarbeitung abgeschlossen ist und es nun an der Zeit ist, mit der normalen Ausf?hrung der Programmierung fortzufahren. Immer wenn ein Fehler von ON ERROR GOTO abgefangen und verarbeitet wird, ist die Ausf?hrung eines passenden RESUME obligatorisch.

WIEDER AUFNEHMEN

Wenn die erste Form von RESUME (ohne Modifikator) verwendet wird, wird die Anweisung, die den Fehler erzeugt hat, erneut ausgef?hrt und der Programmablauf l?uft normal weiter. Stellen Sie sicher, dass Sie die Bedingung, die den Fehler verursacht hat, behoben haben, bevor Sie dies tun!

Als n?chstes fortfahren

Wenn Sie RESUME NEXT ausf?hren, wird die Programmausf?hrung in der Zeile fortgesetzt, die unmittelbar auf die Zeile folgt, die den Fehler verursacht hat. Danach l?uft der Programmablauf normal weiter. Stellen Sie sicher, dass Ihr Fehlerbehandler alles Erforderliche getan hat, um durch neue Aktionen das zu ersetzen, was von dem fehlerhaften Code erwartet wurde.

FLUSH FORTSETZEN

Wenn Sie RESUME FLUSH ausf?hren, erfolgt keine ?bergabe der Kontrolle an eine andere Zeile. Die Programmausf?hrung wird einfach in der Zeile fortgesetzt, die unmittelbar auf den RESUME FLUSH folgt.

RESUME < Label >

Wenn ein Label angegeben ist, wird die Programmausf?hrung an der angegebenen Label-Position fortgesetzt. Die Bezeichnung muss ?lokal? sein; das hei?t, es muss sich in derselben Prozedur wie der RESUME befinden.

Einschr?nkungen

ON ERROR und RESUME d?rfen nicht innerhalb eines TRY/END TRY-Blocks oder einer FASTPROC-Prozedur verwendet werden.

Verifiziertes Beispiel: RESUME - nach behandeltem Fehler fortsetzen

Beispieldatei: examples/basic/help_error_handling/help_resume.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_error_handling/help_resume.pb -o tmp/help_error_samples/help_resume.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    LOCAL n AS LONG

    ON ERROR GOTO handler
    n = 1
    ERROR 5
    n = 2

    IF n <> 2 THEN FUNCTION = 1
    EXIT FUNCTION

handler:
    RESUME
END FUNCTION

Verhalten: Verwendet RESUME in einem ON-ERROR-Handler und prueft, dass der geschuetzte Code korrekt fortgesetzt wird. Focus form: RESUME

Validierungsbeleg

PBXB64 registriert test_resume_flush und test_resume_flush_reject_extra in der pb_linkrun-Lane. Diese Tests pruefen, dass RESUME FLUSH den aktiven Fehlerzustand loescht und direkt nach der Anweisung fortsetzt, und dass ueberzaehlige Tokens mit einer gezielten Diagnose abgewiesen werden.

Siehe auch

  • ERL
  • ERR
  • FEHLER
  • Fehler?bersicht
  • FEHLER$
  • Fehler-Trapping
  • AUF FEHLER

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BASIC-Eingabe/Ausgabe — PBXB64 Help

Startseite › BASIC Frontend › File I/O

BASIC-Eingabe/Ausgabe

Konsolen- und Datei-E/A-Anweisungen.

Aufgabe dieses Kapitels

Dieses Kapitel sammelt die BASIC-Sprachmittel zu einem zusammenhängenden Arbeitsbereich. Es dient als Einstieg, wenn Sie nicht den exakten Befehlsnamen kennen, sondern eine Spracheigenschaft suchen.

Verwendung

Beginnen Sie mit der Tabelle unten und wechseln Sie dann zur Detailseite des einzelnen Befehls. Die Detailseiten enthalten Syntax, Hinweise zur PBXB64-Unterstützung, Getestetes Beispiel und Querverweise.

Befehlsübersicht

Befehl | Bereich
PRINT | Konsolen- und Datei-E/A-Anweisungen.
EINGABE | Konsolen- und Datei-E/A-Anweisungen.
OFFEN | Konsolen- und Datei-E/A-Anweisungen.
CLOSE | Konsolen- und Datei-E/A-Anweisungen.
ERHALTEN | Konsolen- und Datei-E/A-Anweisungen.
SETZEN | Konsolen- und Datei-E/A-Anweisungen.
SUCHEN | Konsolen- und Datei-E/A-Anweisungen.
ZEILENEINGABE | Konsolen- und Datei-E/A-Anweisungen.

Getestetes Beispiel

Diese Seite ist ein Uebersichtskapitel. Die verlinkten Einzelseiten enthalten die konkreten getesteten Beispiele oder nennen eine ausdrueckliche Begrenzung, wenn ein Befehl nicht zertifiziert ist.

PBXB64-Status: Uebersicht / Navigation; keine eigenstaendige Laufzeitbehauptung ohne Unterseitenbeleg.

Praktische Hinweise

BASIC-Quelltext wird im PBXB64-Frontend direkt in die gemeinsame Zwischenrepräsentation übersetzt. Achten Sie deshalb besonders auf Datentypen, ByVal/ByRef-Übergabe, Zeichenkettenlängen und Laufzeitfehlerpfade.

Siehe auch

  • BASIC-Sprachübersicht

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CLS - PBXB64-Compiler-Hilfe

Startseite › BASIC-Frontend › Schlüsselwortreferenz › Konsolen-E/A › CLS
Hilfe zum PBXB64-Compiler

CLS

Löscht den aktiven Konsolen-Bildschirmpuffer.

Typ: Anweisung | Kategorie: Konsolen-E/A

PBXB64-Status: VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET] fuer die fokussierte Konsolenoberflaeche: Die Anweisung wird geparst, ueber die eingebettete Runtime gelinkt, loescht eine echte Windows-Konsole per Win32-Konsolen-API und bleibt bei umgeleiteter Ausgabe still.

Syntax

CLS

Beschreibung

CLS löscht den aktuellen Konsolen-Ausgabepuffer und setzt den Konsolencursor auf Zeile 1, Spalte 1. PBXB64 implementiert dies mit der Windows-Konsolen-API ueber den eingebetteten Runtime-Helfer bestof_console_cls.

Wenn das Programm ohne echten Konsolen-Bildschirmpuffer laeuft, zum Beispiel bei Umleitung von stdout in eine Datei oder beim Mitschnitt durch die Validierung, erzeugt CLS keine sichtbare Ausgabe und kehrt normal zurueck. Dadurch werden keine Escape-Sequenzen oder Literaltexte in umgeleitete Ausgabe geschrieben.

Beispiel

#COMPILE EXE
#CONSOLE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    PRINT "before"
    CLS
    PRINT "after"
    FUNCTION = 0
END FUNCTION

Verifiziertes Beispiel

Beispieldatei: tests/pb/test_console_cls.pb

Validierungsnachweis: in tests/validate.toml als test_console_cls registriert; die fokussierte pb_linkrun-Validierung bestand mit Exitcode 0 und Ausgabe passend zu before[\s\S]*after.

Hinweise

  • CLS hat derzeit keine Argumente.
  • Diese Seite dokumentiert Konsolen-CLS. TXT-Pseudoobjektformen wie TXT.CLS gehoeren zu einer eigenen Editor-Helfer-Oberflaeche.

Siehe Auch

PRINT | INPUT | LINE INPUT

Konsolenverhalten

CLS arbeitet nur auf dem aktuellen Konsolen-Bildschirmpuffer. Der Befehl bleibt absichtlich still, wenn stdout umgeleitet ist oder das Programm keinen brauchbaren Konsolenpuffer besitzt. So entstehen bei nichtinteraktiven Validierungsläufen keine Escape-Sequenzen oder Zusatztexte.

Fehlerfaelle

Der Befehl hat keine Parameter und keinen Rueckgabewert. Programme sollten bei umgeleiteter Ausgabe kein sichtbares Ergebnis erwarten und das Fehlen einer Konsole in dieser fokussierten PBXB64-Oberflaeche nicht als Fehler behandeln.

Test- und Dokumentationshinweise

Das registrierte Beispiel tests/pb/test_console_cls.pb belegt den Pfad fuer die echte Konsole und den stillen Pfad bei umgeleiteter Ausgabe. Verwenden Sie dieses Beispielmuster, wenn Sie verwandtes Konsolen-Cleanup oder Bildschirm-Reset dokumentieren.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOCATE - PBXB64-Compiler-Hilfe

Startseite › BASIC-Frontend › Schlüsselwortreferenz › Konsolen-E/A › LOCATE
Hilfe zum PBXB64-Compiler

LOCATE

Positioniert den Konsolencursor und kann die Cursor-Sichtbarkeit aendern.

Typ: Anweisung | Kategorie: Konsolen-E/A

PBXB64-Status: VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET] fuer die fokussierte Konsolen-Cursoroberflaeche: Die Anweisung parst optionale Zeilen-, Spalten-, Cursor-, Start- und Stop-Argumente, linkt ueber die eingebettete Runtime, laeuft in umgeleiteter Validierung und weist zu viele Argumente zurueck.

Syntax

LOCATE [Zeile][,[Spalte][,[Cursor][,[Start][,Stop]]]]

Beschreibung

LOCATE bewegt den aktuellen Windows-Konsolencursor. Zeile und Spalte sind 1-basiert. Eine ausgelassene Zeile oder Spalte, oder der Wert Null, laesst diese Koordinate unveraendert. PBXB64 implementiert dies ueber den eingebetteten Runtime-Helfer bestof_console_locate.

Das optionale Argument Cursor steuert die Cursor-Sichtbarkeit, wenn ein echter Konsolen-Bildschirmpuffer vorhanden ist: Null blendet den Cursor aus, ein Wert ungleich Null blendet ihn ein. Wird das Cursor-Argument ausgelassen, bleibt die aktuelle Sichtbarkeit unveraendert.

Die optionalen Argumente Start und Stop werden aus Quelltext-Kompatibilitaetsgruenden fuer alte BASIC-Formen akzeptiert, aber die aktuelle fokussierte Implementierung formt die Cursor-Scanline noch nicht. Sie sind fuer spaetere Cursor-Groessenparitaet reserviert.

Wenn das Programm ohne echten Konsolen-Bildschirmpuffer laeuft, zum Beispiel bei Umleitung von stdout in eine Datei oder beim Mitschnitt durch die Validierung, erzeugt LOCATE keine sichtbare Ausgabe und kehrt normal zurueck.

Beispiel

#COMPILE EXE
#CONSOLE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    PRINT "before"
    LOCATE 3, 5
    LOCATE , 6
    LOCATE 1, 1, 0
    LOCATE 1, 1, 1, 0, 15
    PRINT "after"
    FUNCTION = 0
END FUNCTION

Verifiziertes Beispiel

Beispieldatei: tests/pb/test_console_locate.pb

Validierungsnachweis: in tests/validate.toml als test_console_locate registriert; die fokussierte pb_linkrun-Validierung bestand mit Exitcode 0 und Ausgabe passend zu before[\s\S]*after. Der negative Test test_console_locate_reject_too_many beweist, dass mehr als fuenf Argumente abgewiesen werden.

Hinweise

  • LOCATE begrenzt Zeile und Spalte auf die aktuellen Konsolenpuffer-Grenzen.
  • Verwenden Sie #CONSOLE oder einen Console-Subsystem-Build fuer sichtbare interaktive Cursorbewegung.
  • Bei umgeleiteter stdout-Ausgabe schreibt LOCATE absichtlich keine Escape-Sequenzen oder Literaltexte.

Siehe Auch

CLS | PRINT | INPUT

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CSRLIN - PBXB64-Compiler-Hilfe

Startseite › BASIC-Frontend › Schlüsselwortreferenz › Konsolen-E/A › CSRLIN
Hilfe zum PBXB64-Compiler

CSRLIN

Liefert die aktuelle Konsolen-Cursorzeile.

Typ: Funktion | Kategorie: Konsolen-E/A

PBXB64-Status: VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET] fuer die fokussierte Cursor-Zeilenabfrage: CSRLIN wird auf die eingebettete Runtime gesenkt, liefert bei echten Konsolen eine 1-basierte Zeile und bei fehlendem Konsolen-Bildschirmpuffer deterministisch Zeile 1.

Syntax

Zeile& = CSRLIN

Beschreibung

CSRLIN liefert die aktuelle Textkonsolen-Cursorzeile als 1-basierte Ganzzahl. PBXB64 liest die Zeile ueber die Windows-Konsolenpuffer-API, wenn stdout mit einer echten Konsole verbunden ist.

Wenn stdout umgeleitet ist oder das Programm keinen Konsolen-Bildschirmpuffer besitzt, gibt PBXB64 1 zurueck. Dadurch bleiben nichtinteraktive Builds und Validierungslaufe deterministisch und das alte nicht unterstuetzte Null-Stub-Verhalten wird vermieden.

Beispiel

#COMPILE EXE
#CONSOLE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    DIM row AS LONG
    row = CSRLIN
    IF row < 1 THEN FUNCTION = 1
END FUNCTION

Verifiziertes Beispiel

Beispieldatei: tests/pb/test_console_cursor_functions.pb

Validierungsnachweis: in tests/validate.toml als test_console_cursor_functions registriert; die fokussierte pb_linkrun-Validierung bestand mit Exitcode 0 und ohne stdout.

Hinweise

  • CSRLIN ist eine Abfragefunktion; verwenden Sie LOCATE, um den Cursor zu bewegen.
  • Interaktive Konsolentests koennen die genaue Zeile nach LOCATE beobachten. Umgeleitete Validierung beweist deterministische nicht-null Rueckgabe und eingebettetes Runtime-Linking.

Siehe Auch

LOCATE | POS | CLS

Konsolen-Semantik

Die Funktion liest die aktuelle Cursorposition aus dem aktiven Konsolen-Bildschirmpuffer. Wenn das Programm nicht an eine echte Konsole gebunden ist, gibt PBXB64 deterministisch Zeile 1 zurueck, damit Code auch bei umgeleiteter Ausgabe ohne Sonderbehandlung weiterlaufen kann.

Fehlerfaelle

Es gibt keine Eingabeparameter zu pruefen, aber der Rueckgabewert bleibt Laufzeitzustand und kann sich nach LOCATE, Bildschirmausgabe oder Konsolenumleitung aendern. Wenn das Programm eine bestimmte Zeile benoetigt, lesen Sie den Wert unmittelbar vor weiteren Konsolenoperationen aus.

Validierungsbeleg

Validation evidence: tests/pb/test_console_cursor_functions.pb deckt die Zeilenabfrage und den deterministischen Pfad bei umgeleiteter Ausgabe ab.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


POS - PBXB64 Help

Startseite › BASIC Frontend › POS

POS

Liefert die aktuelle Konsolen-Cursorspalte.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

column& = POS(n)

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. POS liest die aktuelle Konsolen-Cursorspalte ueber den aktiven stdout-Konsolenpfad. Verwenden Sie es nach LOCATE oder Textausgabe, wenn das Programm eine Spaltenrueckgabe statt eines Cursor-Bewegungsbefehls benoetigt.

Verwendung im Programm

POS liest die aktuelle Konsolen-Cursorspalte ueber den aktiven stdout-Konsolenpfad. Verwenden Sie es nach LOCATE oder Textausgabe, wenn das Programm eine Spaltenrueckgabe statt eines Cursor-Bewegungsbefehls benoetigt.

Fehlerfaelle

Wenn stdout umgeleitet ist oder kein Konsolen-Bildschirmpuffer verfuegbar ist, liefert der fokussierte Vertrag 1. Verwenden Sie POS nicht als Positionsbefehl; verwenden Sie LOCATE zum Bewegen des Cursors und CSRLIN fuer die Zeile.

Cursor-Rueckgabe

Verwenden Sie POS, wenn ein Programm die aktuelle Konsolenspalte nach Ausgabe oder nach LOCATE braucht, nicht wenn es den Cursor bewegen will. Der Helfer liest die aktive stdout-Konsolenposition und gibt eine 1-basierte Spalte zurueck.

Fehlerhinweise

Umgeleitetes stdout oder ein fehlender Konsolen-Bildschirmpuffer liefern deterministisch Spalte 1. Das Legacy-Argument wird zur Kompatibilitaet akzeptiert, aendert aber den Rueckgabe-Vertrag nicht.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    c = POS(0)
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `tests/pb/test_console_cursor_functions.pb`, das POS vor und nach LOCATE in einem echten Konsolenpfad prueft.

Hinweise

  • POS(n) ist eine Rueckgabefunktion; verwenden Sie LOCATE, um den Cursor zu bewegen.
  • Das Legacy-Argument wird zur Kompatibilitaet akzeptiert und aendert das Rueckgabeverhalten der aktuellen Spalte nicht.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. Wenn stdout umgeleitet ist oder kein Konsolen-Bildschirmpuffer verfuegbar ist, liefert der fokussierte Vertrag 1. Verwenden Sie POS nicht als Positionsbefehl; verwenden Sie LOCATE zum Bewegen des Cursors und CSRLIN fuer die Zeile.

Siehe Auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PRINT# ? PBXB64-Compiler-Hilfe

Startseite ? BASIC-Frontend ? Schl?sselwortreferenz ? Datei-E/A ? PRINT#
Hilfe zum PBXB64-Compiler

PRINT#

Daten in eine sequenzielle Datei schreiben

Typ: Anweisung | Kategorie: Datei-E/A

PBXB64-Status: VERF?GBAR

PBXB64-Zertifizierung: [IMPLEMENTIERT: Trennzeichen, Zonen, Flie?komma, Zeilenumbruch]

Syntax

PRINT #Dateinummer& [, Ausdruck [{;|,} Ausdruck ...] [{;|,}]]

Beschreibung

Die PRINT#-Anweisung schreibt formatierten Text in eine sequenzielle Datei, die mit OPEN FOR OUTPUT oder OPEN FOR APPEND ge?ffnet wurde.

Unterst?tzte Ausdruckstypen sind Ganzzahl-, Flie?komma- und Zeichenfolgenausdr?cke. Ausdr?cke werden durch ; (sofort nach dem vorherigen Wert) oder , (weiter zur n?chsten 14-Spalten-Druckzone) getrennt. Ein abschlie?endes ; oder , unterdr?ckt das abschlie?ende CR/LF; anderenfalls endet jede PRINT# mit CR/LF.

Werden keine Ausdr?cke angegeben, schreibt PRINT #Dateinummer& eine Leerzeile (ein CR/LF-Paar).

Numerische Werte werden mit dem Format %.17g geschrieben. Der ,-Zonentrenner f?llt mit Leerzeichen bis zur n?chsten 14-Zeichen-Grenze auf.

Einschr?nkungen

  • SPC(n), TAB(n) und die Array-Form array$() sind noch nicht implementiert.
  • Dateinummern m?ssen als Literale #1..#16 angegeben werden; variable Dateinummern sind noch nicht unterst?tzt.

Verifiziertes Beispiel: PRINT - Text schreiben

Beispieldatei: examples/basic/help_io/help_print.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_io/help_print.pb -o tmp/help_io_samples/help_print.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    LOCAL s AS STRING
    OPEN "help_print.tmp" FOR OUTPUT AS #1
    PRINT #1, "print-ok"
    CLOSE #1
    OPEN "help_print.tmp" FOR INPUT AS #2
    LINE INPUT #2, s
    CLOSE #2
    KILL "help_print.tmp"
    IF s <> "print-ok" THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft Datei- oder Konsolen-E/A und liefert Exitcode 0 nur bei korrektem Verhalten. Focus statement: PRINT #1, "print-ok"

Kompatibilitaetsdetails

PRINT# schreibt ein Abbild der angegebenen Ausdruecke in die Zieldatei. Verwende Semikolons, wenn Felder direkt aneinander anschliessen sollen, und Kommas, wenn die Ausgabe zu PBXB64s 14-Spalten-Druckzonen springen soll. Wenn das letzte Element weder ; noch , ist, fuegt PBXB64 ein CR/LF-Paar an.

PRINT #filenum& ohne Ausdrucksliste schreibt eine Leerzeile. Das ist hilfreich fuer Textdateien, in denen ein leerer Datensatz erhalten bleiben muss.

Fuer Datendateien, die mit INPUT# wieder eingelesen werden sollen, verwende eindeutige Trennzeichen oder WRITE#. Druckzonen-Abstaende sind fuer Menschen gut lesbar, koennen spaeter aber schwer zu parsen sein, besonders wenn benachbarte Zahlenfelder nicht durch Kommas getrennt sind.

Abstaende und Trennzeichen

  • ; schreibt den naechsten Wert direkt nach dem vorherigen Wert.
  • , fuellt bis zur naechsten 14-Spalten-Druckzone auf.
  • Ein abschliessendes ; oder , unterdrueckt den abschliessenden Zeilenumbruch.
  • SPC(n), TAB(n) und Ganz-Array-Formen bleiben unter Einschraenkungen, bis es fokussierten Implementierungsbeleg gibt.

Roundtrip-Hinweis

Verwende PRINT# fuer menschenlesbare Zeilen oder einfache Ein-Wert-pro-Zeile-Dateien. Verwende WRITE#, wenn Feldgrenzen automatisch mit Kommas und gequoteten Strings fuer spaetere INPUT#-Lesevorgaenge erhalten bleiben muessen.

Praktische Verwendung

PRINT# gehoert zur Kategorie General. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' PRINT# mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Siehe auch

  • OFFEN
  • CLOSE
  • WRITE#
  • INPUT#
  • LINE INPUT#
  • Datei-E/A-Referenz


INPUT ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? INPUT

EINGANG

Daten von der Konsole in Variablen einlesen

Typ:Anweisung |Kategorie:Datei-E/A

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

INPUT [;] ["prompt" ; | ,] variable [, variable ...]
INPUT #fNum, variable [, variable ...]

Beschreibung

DerINPUT Die Anweisung liest Werte von der Tastatur (Konsole) oder aus einer ge?ffneten sequentiellen Datei und speichert sie in den angegebenen Variablen. Das Konsolenformular kann eine optionale Eingabeaufforderungszeichenfolge anzeigen. Das Dateiformular liest durch Kommas getrennte Felder aus einer mit ge?ffneten Datei OPEN FOR INPUT.

Beispiel

FUNCTION PBMAIN () AS LONG
    LOCAL age AS LONG
    LOCAL score AS LONG
    INPUT "Enter age and score: ", age, score
    FUNCTION = age + score
END FUNCTION

Generierter Assembler-Code

Kompilieren mit:

PBXB64 example.pb --asmout example.asm

Jede numerische Variable wird zu einem Aufruf des konsolenlesbaren Laufzeithilfsprogramms, wobei das Ergebnis im Stack-Slot der Variablen gespeichert wird:

    sub rsp, 32
    call console_input_helper
    add rsp, 32
    mov rbx, rax
    mov [rbp-32], rbx

Hinweise

  • String-Variablen werden syntaktisch unterst?tzt; ?berpr?fen Sie das Laufzeitverhalten f?r gemischte Zeichenfolgen-/numerische INPUT-Listen.
  • VerwendenLINE INPUT um eine ganze Zeile als einzelne Zeichenfolge zu lesen.

Verifiziertes Beispiel: INPUT - typisierte Konsoleneingabe lesen

Beispieldatei: tests/pb/test_console_input_line.pb

Validierungsnachweis: compiled with Release/PBXB64.exe tests/pb/test_console_input_line.pb -o tmp/help_io_samples/test_console_input_line.exe and executed with exit code 0 stdin 42,"hello, world",3.5\nfinal line\n.

#COMPILE EXE
#CONSOLE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    DIM n AS LONG
    DIM s AS STRING
    DIM d AS DOUBLE
    DIM lineText AS STRING

    INPUT "Values"; n; s$; d
    LINE INPUT lineText$

    IF n <> 42 THEN FUNCTION = 1: EXIT FUNCTION
    IF s <> "hello, world" THEN FUNCTION = 2: EXIT FUNCTION
    IF d < 3.49 OR d > 3.51 THEN FUNCTION = 3: EXIT FUNCTION
    IF lineText <> "final line" THEN FUNCTION = 4: EXIT FUNCTION

    FUNCTION = 0
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft Datei- oder Konsolen-E/A und liefert Exitcode 0 nur bei korrektem Verhalten. Focus statement: INPUT "Values"; n; s$; d

Siehe auch

  • PRINT
  • LINE-EINGANG
  • WRITE#
  • File I/O Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


OPEN – PBXB64-Compiler-Hilfe

Startseite › BASIC-Frontend › Schlüsselwortreferenz › Datei-E/A › OPEN
Hilfe zum PBXB64-Compiler

OPEN

Eine Datei zur Eingabe oder Ausgabe öffnen

Typ: Anweisung | Kategorie: Datei-E/A

PBXB64-Status: VERFÜGBAR

PBXB64-Zertifizierung: [IMPLEMENTIERT: Modi, ACCESS, LOCK, CHR=WIDE, LEN geparst]

Syntax

OPEN Dateiname$ FOR Modus AS [#]Dateinummer&
OPEN Dateiname$ FOR Modus AS [#]Dateinummer& [ACCESS Zugriff] [LOCK Sperre] [CHR = WIDE] [LEN = Satzlänge]

Beschreibung

Die OPEN-Anweisung verknüpft eine Datei mit einem numerischen Dateihandle. PBXB64 unterstützt Dateinummern #1 bis #16 als Literale.

Unterstützte Modi sind INPUT, OUTPUT, APPEND, BINARY und RANDOM.

Optionale Klauseln:

  • ACCESS READ, ACCESS WRITE oder ACCESS READ WRITE schränken die angeforderten Zugriffsrechte ein.
  • LOCK SHARED, LOCK READ, LOCK WRITE oder LOCK READ WRITE steuern die Freigabe für andere Prozesse.
  • CHR = WIDE öffnet die Datei als UTF-16LE; anschließende PRINT#, WRITE# und LINE INPUT# übersetzen zwischen ANSI-Zeichenfolgen und UTF-16LE.
  • LEN = Satzlänge wird geparst; bei RANDOM wird ein Wert größer als 32768 zurückgewiesen.

Beispiel

FUNCTION PBMAIN () AS LONG
    OPEN "data.txt" FOR OUTPUT AS #1
    PRINT #1, "hello"
    CLOSE #1
    FUNCTION = 0
END FUNCTION

Einschränkungen

  • Verwenden Sie wörtliche Dateinummern #1..#16; variable Dateinummern sind noch nicht unterstützt.
  • Die Form OPEN HANDLE akzeptiert einen literalen Handle-Ausdruck; die Dateinummer muss jedoch weiterhin ein Literal sein.
  • Koppeln Sie OPEN immer mit CLOSE, um das Handle freizugeben.

Verifiziertes Beispiel: OPEN - Datei oeffnen

Beispieldatei: examples/basic/help_io/help_open.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_io/help_open.pb -o tmp/help_io_samples/help_open.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    LOCAL s AS STRING
    OPEN "help_open.tmp" FOR OUTPUT AS #1
    PRINT #1, "open-ok"
    CLOSE #1
    OPEN "help_open.tmp" FOR INPUT AS #2
    LINE INPUT #2, s
    CLOSE #2
    KILL "help_open.tmp"
    IF s <> "open-ok" THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft Datei- oder Konsolen-E/A und liefert Exitcode 0 nur bei korrektem Verhalten. Focus statement: OPEN "help_open.tmp" FOR OUTPUT AS #1

Praktische Verwendung

OPEN gehoert zur Kategorie General. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' OPEN mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Siehe auch

  • CLOSE
  • PRINT#
  • INPUT#
  • WRITE#
  • FREEFILE
  • Datei-E/A-Referenz


CLOSE – PBXB64-Compiler-Hilfe

Startseite › BASIC-Frontend › Schlüsselwortreferenz › Datei-E/A › CLOSE
Hilfe zum PBXB64-Compiler

CLOSE

Eine oder alle geöffneten Dateien schließen

Typ: Anweisung | Kategorie: Datei-E/A

PBXB64-Status: VERFÜGBAR

PBXB64-Zertifizierung: [IMPLEMENTIERT: wörtliche Dateinummern und CLOSE all]

Syntax

CLOSE [[#]Dateinummer& [, [#]Dateinummer& ...]]

Beschreibung

Die CLOSE-Anweisung gibt Dateihandles frei, die mit OPEN geöffnet wurden. Ohne Argumente werden alle geöffneten Dateien geschlossen. Mit einer oder mehreren Dateinummern werden nur diese Dateien geschlossen.

Praktische Verwendung

Schließen Sie eine Datei, sobald das Lesen oder Schreiben beendet ist, damit spätere Oeffnungen, Umbenennungen und Löschungen funktionieren. Verwenden Sie die Form ohne Argumente nur dann, wenn Sie absichtlich alle offenen Handles im aktuellen Prozess freigeben wollen.

Parameter und Ergebnisse

Eine oder mehrere literale Dateinummern schließen nur die benannten Handles. Ohne Argumente schließt CLOSE alle offenen Dateien. Die Anweisung liefert keinen Rueckgabewert; pruefen Sie den Effekt daher durch erneutes Oeffnen oder Loeschen der Datei im Test.

Beispiel

FUNCTION PBMAIN () AS LONG
    OPEN "data.txt" FOR OUTPUT AS #1
    PRINT #1, "hello"
    CLOSE #1
    FUNCTION = 0
END FUNCTION

Einschränkungen

  • Dateinummern müssen als Literale #1..#16 angegeben werden; variable Dateinummern sind noch nicht unterstützt.

Verifiziertes Beispiel: CLOSE - Dateihandle schliessen

Beispieldatei: examples/basic/help_io/help_close.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_io/help_close.pb -o tmp/help_io_samples/help_close.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    LOCAL s AS STRING
    OPEN "help_close.tmp" FOR OUTPUT AS #1
    PRINT #1, "close-ok"
    CLOSE #1
    OPEN "help_close.tmp" FOR INPUT AS #1
    LINE INPUT #1, s
    CLOSE #1
    KILL "help_close.tmp"
    IF s <> "close-ok" THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft Datei- oder Konsolen-E/A und liefert Exitcode 0 nur bei korrektem Verhalten. Focus statement: CLOSE #1

Praktische Verwendung

CLOSE gehoert zur Kategorie General. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' CLOSE mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Siehe auch

  • OPEN
  • PRINT#
  • INPUT#
  • Datei-E/A-Referenz


GET ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? GET

ERHALTEN

Lesen Sie eine Aufzeichnung von a

Typ:Anweisung |Kategorie:Datei-E/A

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

Random-Access files:
GET [#] filenum& , [ Rec ], [ABS] Var
GET [#] filenum& [, Rec ]
Binary files:
GET [#] filenum& , [ RecPos ], Var
GET [#] filenum& , [ RecPos ], Arr() [RECORDS rcds ] [TO count ]

Beschreibung

Eine zum Empfangen von Daten verwendete Zeichenfolgenvariable kann entweder ANSI oder WIDE sein, sie muss jedoch mit dem CHR-Modus der aus der Datei gelesenen Daten ?bereinstimmen. Das hei?t, wenn die Daten als ANSI-String geschrieben wurden, sollten sie in eine ANSI-String-Variable eingelesen werden. Wenn es als WIDE-String geschrieben wurde, sollte es in eine WIDE-String-Variable eingelesen werden. Die Nicht?bereinstimmung dieses CHR-Modus kann zu einer unvorhersehbaren Interpretation der Daten f?hren. GET f?hrt niemals Konvertierungen von ANSI/WIDE-Zeichen durch, unabh?ngig vom CHR-Modus, der in der OPEN-Anweisung angegeben ist. Es liest Daten aus der Datei basierend auf dem Typ der von Ihnen verwendeten Zeichenfolgenvariablen. Es liegt in der Verantwortung des Programmierers, den richtigen Typ auszuw?hlen.

Dateinummer&

Die Dateinummer, unter der die Datei ge?ffnet wurde.

Direktzugriffsdateien

Bei Dateien mit wahlfreiem Zugriff ist Rec die zu lesende Datensatznummer im Bereich von 1 bis 2^63-1 (der maximale positive Wert f?r einen Quad-integer). Wenn Rec weggelassen wird, wird der n?chste Datensatz in der Reihenfolge (nach dem durch den letzten GET oder PUT angegebenen Datensatz) gelesen. Wenn die Datei gerade erst ge?ffnet wurde, wird der erste Datensatz gelesen.

Wenn Var kleiner als die definierte Datensatzl?nge ist, liest GET gen?gend Daten, um Var zu f?llen. Der Rest des Datensatzes wird verworfen und der Dateizeiger wird an der n?chsten Datensatzposition platziert. Wenn Var gr??er als die definierte Datensatzl?nge ist, liest GET einen Datensatz in Var ein und der Dateizeiger wird auf den n?chsten Datensatz verschoben.

Wenn GET zum Abrufen von Daten aus einer Direktzugriffsdatei in eine dynamische Zeichenfolge (variabler L?nge) verwendet wird, sucht PowerBASIC am Anfang jedes Datensatzes nach einem 2-Byte-Feld (WORD), das die Anzahl der folgenden Datenbytes angibt. Wenn die Daten im WIDE-Format vorliegen, ist die Gr??e doppelt so gro? wie die Anzahl der Zeichen, da jedes Zeichen zwei Bytes belegt. Dieses 2-Byte-Gr??enfeld wird von der PUT-Anweisung automatisch in die Datei eingef?gt, wenn es mit dynamischen Zeichenfolgen (mit variabler L?nge) verwendet wird.

Wenn die zweite Form von GET verwendet wird (ohne Var-Zielzeichenfolge), liest PBXB64 den aktuellen Random-Datei-Satz vom aktuellen Dateizeiger in den eingebetteten FIELD-Puffer. Zugeordnete FIELD-Stringvariablen lesen danach ihre festen Pufferbereiche.

Wenn GET verwendet wird, um eine zuf?llige Datei in eine dynamische Zeichenfolge einzulesen, wird normalerweise erwartet, dass die ersten beiden Bytes des Datensatzes die L?nge der im Datensatz enthaltenen g?ltigen Daten enthalten. Das Schl?sselwort ABS gibt an, dass in den Daten kein L?ngenwort vorhanden ist und die Anzahl der zu lesenden Bytes durch die aktuelle L?nge der dynamischen Zeichenfolgenvariablen definiert wird. Wenn die L?nge der Variablen gr??er als die L?nge des Dateidatensatzes ist, wird der Rest der Zeichenfolgenvariablen mit Nullen gef?llt ( CHR$ (0) oder $NUL ). Dies bietet eine gr??ere Kompatibilit?t mit der tats?chlichen Funktionsweise anderer BASIC-Versionen, beispielsweise PowerBASIC f?r DOS.

Ein Dateieintrag mit wahlfreiem Zugriff ist auf 32768 Byte begrenzt, um ein konsistentes Verhalten auf allen unterst?tzten Win32-Plattformen sicherzustellen. GET$ und andere verwandte Funktionen werden auf diese Weise nicht eingeschr?nkt.

Bin?rdateien

RecPos

Bei Bin?rdateien ist RecPos das Startbyte oder die Suchposition, an der der GET beginnen soll. Die optionale BASE =-Klausel der OPEN-Anweisung definiert, ob die erste Position 0 oder 1 ist. Die Basisposition ist standardm??ig 1. Wenn RecPos gr??er als die Anzahl der Datens?tze oder Bytes in der Datei ist, tritt kein Fehler auf, es k?nnen jedoch unvorhersehbare Daten gelesen werden. Verwenden Sie die EOF-Funktion, um zu vermeiden, dass ?ber das Ende der Datei hinaus gelesen wird.

Bei Verwendung mit einer Bin?rdatei ruft GET gen?gend Daten aus der Datei ab, um Var zu f?llen. Der Var-Parameter kann eine einfache (skalare) Variable wie eine Ganzzahl oder eine dynamische Zeichenfolge (mit variabler L?nge), ein Element in einem Array oder eine Variable vom benutzerdefinierten Typ sein.

Wenn GET verwendet wird, um eine Bin?rdatei in einen dynamischen String einzulesen, wird die Anzahl der zu lesenden Bytes durch die aktuelle Gr??e der dynamischen String-Variablen definiert. Wenn die L?nge der Variablen gr??er ist als die L?nge des Dateidatensatzes, wird der Rest der Zeichenfolgenvariablen mit Nullen (CHR$(0) oder $NUL) aufgef?llt. Dies bietet eine gr??ere Kompatibilit?t mit der tats?chlichen Funktionsweise anderer BASIC-Versionen, beispielsweise PowerBASIC f?r DOS.

Beim Lesen eines Arrays aus der Festplattendatei weist GET Daten aus der Datei jedem Element im Array zu, beginnend beim LBOUND-Index des Arrays. GET versucht, die von rcds in der Option RECORDS angegebene Anzahl von Elementen oder die Anzahl von Elementen im Array zu lesen, je nachdem, welcher Wert kleiner ist. Die tats?chliche Anzahl der gelesenen Elemente wird der in der optionalen TO-Klausel angegebenen Variablenanzahl zugewiesen.

Bei einem dynamischen String-Array wird davon ausgegangen, dass die Datei im gepackten PowerBASIC- und/oder VB-String-Format mithilfe von PUT eines gesamten String-Arrays geschrieben wurde. Wenn eine Zeichenfolge k?rzer als 65535 Byte ist, folgen die Zeichenfolgedaten auf ein 2 Byte langes WORD. Andernfalls folgt auf einen 2-Byte-Wert von 65535 ein L?ngen-Doppelwort (DWORD) und schlie?lich die Zeichenfolgendaten.

Bei anderen Array-Array-Typen wird der gesamte Datenbereich als einzelner Block gelesen. In beiden F?llen wird davon ausgegangen, dass die Datei mit der erg?nzenden PUT Array-Anweisung erstellt wurde.

EOF wird wie bei anderen GET-Anweisungen gesetzt.

Sie k?nnen die FILESCAN-Anweisung verwenden, um die Anzahl der in der Datei enthaltenen Datens?tze zu ermitteln, sodass ein Array des entsprechenden Typs dimensioniert werden kann, bevor Sie die GET-Anweisung zum Lesen der Datei verwenden.

PBXB64 behandelt die nackte Form GET #n als FIELD-Pufferoperation: Der aktuelle Satz wird in den eingebetteten Puffer des geoeffneten Random-Datei-Handles gelesen, und zugeordnete FIELD-Variablen lesen danach ihre festen Ausschnitte aus diesem Puffer. Diese Form ist getrennt von GET #n,, var, das ein Ziel direkt fuellt.

Verifiziertes Beispiel: GET - Binaerdaten lesen

Beispieldatei: examples/basic/help_io/help_get.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_io/help_get.pb -o tmp/help_io_samples/help_get.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    LOCAL n AS LONG
    OPEN "help_get.tmp" FOR BINARY AS #1
    PUT #1, 1, 12345
    CLOSE #1
    OPEN "help_get.tmp" FOR BINARY AS #1
    GET #1, 1, n
    CLOSE #1
    KILL "help_get.tmp"
    IF n <> 12345 THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft Datei- oder Konsolen-E/A und liefert Exitcode 0 nur bei korrektem Verhalten. Focus statement: GET #1, 1, n

Siehe auch

  • CSET
  • CSET$
  • EOF
  • FELD
  • DATEIENCAN
  • GET$
  • ERHALTEN$$
  • LINE-EINGANG#
  • LSET
  • OFFEN
  • PRINT#
  • SETZEN
  • PUT$
  • PUT$$
  • RSET
  • TYP
  • SUCHEN
  • WRITE#

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PUT ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? PUT

SETZEN

Schreiben Sie einen Datensatz an a

Typ:Anweisung |Kategorie:Datei-E/A

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

Random-Access and Binary files:
PUT [#] FileNum& , [ RecPos ], [ABS] Var
PUT [#] FileNum& [, RecPos ]
Binary files:
PUT [#] FileNum& , [ RecPos ], Arr()

Beschreibung

Wenn eine Zeichenfolgenvariable als Var angegeben ist, bestimmt der CHR-Modus der Variablen, ob die Daten als ANSI- oder WIDE-Zeichen geschrieben werden. Das hei?t, ANSI-String-Variablen werden immer als 1-Byte-Zeichen geschrieben, w?hrend WIDE-String-Variablen als 2-Byte-WIDE-Zeichen geschrieben werden. Die Daten werden immer im gleichen Format in die Datei geschrieben, wie sie in der Variablen erscheinen.

Dateinummer&

Die Dateinummer, unter der die Datei ge?ffnet wurde.

RecPos

Identifiziert die Position in der Datei, an der die Daten geschrieben werden sollen. Wenn RecPos gr??er ist als die Anzahl vorhandener Datens?tze oder Bytes in der Datei, wird die Datei auf die entsprechende L?nge erweitert und der Datensatz an der angegebenen Position geschrieben.

Bei Direktzugriffsdateien ist RecPos der zu schreibende Datensatz im Bereich 1 bis (2^63)-1. Wenn RecPos weggelassen wird, wird der n?chste Datensatz in der Reihenfolge (nach dem durch den letzten GET, PUT oder SEEK angegebenen) geschrieben. Wenn die Datei gerade erst ge?ffnet wurde, wird der erste Datensatz geschrieben.

Bei Bin?rdateien ist RecPos die Startbyteposition, an der VarName geschrieben werden soll. Die Standardbyteposition ist 1, es sei denn, die BASE = 0-Klausel wurde in der OPEN-Anweisung verwendet. RecPos darf nicht gr??er als 2^63-1 sein. RecPos ist optional. Wenn es weggelassen wird, verwendet PowerBASIC die aktuelle Dateizeigerposition.

Der Name einer Variablen, die in die Datei geschrieben werden soll. VarName kann eine einfache Variable, ein Element in einem Array oder eine Variable vom benutzerdefinierten Typ (UDT) angeben.

Beim Schreiben einer dynamischen Zeichenfolge in eine Direktzugriffsdatei schreibt PUT vor den eigentlichen Zeichenfolgendaten einen 2-Byte-Deskriptor, der die L?nge der Zeichenfolge enth?lt. Dieser Deskriptor reduziert den verf?gbaren Platz in einem Datensatz um zwei Bytes. Der Deskriptor wird als WORD-Wert geschrieben. Wenn Var mehr Zeichen als der Datensatz enth?lt, wird Var auf die Datensatzl?nge abz?glich zwei Bytes gek?rzt und der Deskriptor wird so geschrieben, dass er die gek?rzte Zeichenfolgengr??e widerspiegelt.

Beim Schreiben einer dynamischen Zeichenfolge in eine Bin?rdatei schreibt PUT nur die tats?chlichen Zeichenfolgendaten: Es wird kein L?ngendeskriptor geschrieben.

PUT ist komplement?r zu GET; Es schreibt einen Datensatz in eine Datei. Es ist m?glich, Datens?tze in nicht zusammenh?ngender Reihenfolge mit PUT zu versehen, wie in:

PUT #1, 1, MyVar

PUT #1, 100, MyVar

Dadurch wird eine Datei mit wahlfreiem Zugriff und einer L?nge von 100 Datens?tzen erstellt. Die Daten in den Datens?tzen 2 bis 99 sind jedoch undefiniert, bis Sie dort explizit etwas eingeben. PUT schreibt den Inhalt von Var an die angegebenen Datensatz- oder Bytepositionen.

(kein VarName )

Wenn die zweite Form von PUT verwendet wird (ohne VarName-Quellzeichenfolge), schreibt PUT die Daten aus einem internen Puffer an der Stelle in die Datei, auf die der Dateizeiger zeigt. Diese Daten m?ssen zun?chst ?ber FIELD-Stringvariablen dem Dateipuffer zugewiesen werden.

Wenn PUT verwendet wird, um eine dynamische Zeichenfolge in eine Zufallsdatei zu schreiben, wird den eigentlichen Daten normalerweise ein zwei Byte langes Wort mit bin?rer L?nge vorangestellt, um die Anzahl der g?ltigen Bytes im Datensatz zu definieren. Wenn Sie dem Variablennamen ABS voranstellen (d. h. PUT #1, , ABS x$), wird kein L?ngenwort geschrieben: nur die tats?chlichen Daten, vorbehaltlich der definierten zuf?lligen Datensatzl?nge. Dies bietet eine gr??ere Kompatibilit?t mit der tats?chlichen Funktionsweise anderer BASIC-Versionen, beispielsweise PowerBASIC f?r DOS.

Die Datensatzl?nge in einer Direktzugriffsdatei ist auf 32768 Byte begrenzt, um ein konsistentes Verhalten auf allen Win32-Plattformen sicherzustellen.

Wenn PUT f?r eine Bin?rdatei verwendet wird, wird das gesamte durch Arr() angegebene Array in die Datei geschrieben. Bei dynamischen Strings wird die Datei im PowerBASIC- und/oder VB-Packed-String-Format geschrieben. Wenn die Zeichenfolge k?rzer als 65535 Byte ist, folgen die Zeichenfolgedaten auf ein Wort mit einer L?nge von 2 Byte. Andernfalls folgt auf einen 2-Byte-Wert von 65535 ein L?ngen-Doppelwort (DWORD) und schlie?lich die Zeichenfolgendaten.

Bei anderen Datentypen wird der gesamte Datenbereich als einzelner Block geschrieben. In beiden F?llen wird davon ausgegangen, dass die Datei mit der erg?nzenden GET Array-Anweisung gelesen wird.

Verifiziertes Beispiel: PUT - Binaerdaten schreiben

Beispieldatei: examples/basic/help_io/help_put.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_io/help_put.pb -o tmp/help_io_samples/help_put.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    LOCAL n AS LONG
    OPEN "help_put.tmp" FOR BINARY AS #1
    PUT #1, 1, 6789
    GET #1, 1, n
    CLOSE #1
    KILL "help_put.tmp"
    IF n <> 6789 THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft Datei- oder Konsolen-E/A und liefert Exitcode 0 nur bei korrektem Verhalten. Focus statement: PUT #1, 1, 6789

Siehe auch

  • CSET
  • CSET$
  • FELD
  • ERHALTEN
  • GET$
  • ERHALTEN$$
  • LOF
  • LSET
  • PUT$
  • PUT$$
  • RSET
  • SETEOF
  • TYP
  • WRITE#

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SEEK ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? SUCHEN

SUCHEN

Stellen Sie die Position in a ein

Typ:Anweisung |Kategorie:Datei-E/A

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SEEK [#] filenum& , position&&

Beschreibung

SEEK setzt die Dateizeigerposition der Datei filenum& auf position&& . position&& ist eine Quad-Integer-Variable, eine Konstante oder ein Ausdruck.

Das n?chste GET$ oder PUT$, das f?r die Datei filenum& ausgef?hrt wird, erfolgt position&& Bytes (oder Datens?tze) tief in der Datei. Wenn die Datei filenum& im bin?ren oder sequentiellen Modus ge?ffnet wurde, gibt position&& die neue Dateiposition in Bytes an; Bei Dateien mit wahlfreiem Zugriff erfolgt die Position in Datens?tzen.

Die erste Byteposition (f?r bin?re und sequentielle Dateien) oder Datensatzposition (f?r Dateien mit wahlfreiem Zugriff) kann 0 oder 1 sein, abh?ngig von der BASE-Option, die beim ersten ?ffnen der Datei verwendet wurde. Wenn kein BASE angegeben wurde, ist die Standardposition 1.

Verwenden Sie die SEEK-Funktion, um die aktuelle Zeigerposition einer Bin?rdatei zu bestimmen, und LOF, um ihre L?nge zu bestimmen. Das Suchen ?ber das Ende einer Datei hinaus erzeugt keinen Fehler, es k?nnen jedoch keine Daten ?ber das tats?chliche Ende der Datei hinaus gelesen werden.

Verifiziertes Beispiel: SEEK - Dateizugriff positionieren

Beispieldatei: examples/basic/help_io/help_seek.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_io/help_seek.pb -o tmp/help_io_samples/help_seek.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    LOCAL n AS LONG
    OPEN "help_seek.tmp" FOR BINARY AS #1
    PUT #1, 1, 111
    PUT #1, 9, 222
    SEEK #1, 9
    GET #1, 9, n
    CLOSE #1
    KILL "help_seek.tmp"
    IF n <> 222 THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft Datei- oder Konsolen-E/A und liefert Exitcode 0 nur bei korrektem Verhalten. Focus statement: SEEK #1, 9

Siehe auch

  • EOF
  • DATEIATTR
  • GET$
  • ERHALTEN$$
  • LOC
  • LOF
  • OFFEN
  • PUT$
  • PUT$$
  • SEEK-Funktion
  • SETEOF

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ZEILENEINGABE - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Datei-E/A › ZEILENEINGABE
Hilfe zum PBXB64-Compiler

ZEILENEINGABE

Liest eine komplette Textzeile, entweder von der Konsole oder aus einer offenen Datei.

Kind: Anweisung | Category: File I/O

PBXB64 Status: VERFÜGBAR

PBXB64 Certification: [ZERTIFIZIERT GETESTET]

Syntax

LINE INPUT [prompt,] string_variable
LINE INPUT # filenum, string_variable

Description

Die ZEILENEINGABE-Familie liest eine komplette Textzeile, ohne sie in Felder zu zerlegen. Die Konsolenform erfasst eine Zeile von der Tastatur; die Dateiform liest einen Datensatz aus einer sequenziellen Textdatei.

Verwenden Sie ZEILENEINGABE, wenn Kommas, Anführungszeichen oder eingebettete Leerzeichen genau so erhalten bleiben müssen, wie sie eingegeben wurden. Das ist die richtige Wahl, wenn INPUT die Zeile in mehrere Felder zerlegen würde.

Die Dateiform ist ein zeilenorientierter Leser. Sie entfernt das abschließende CR/LF-Paar und liefert den Inhalt als Zeichenkette.

PBXB64 validiert die Konsolenform mit einer stdin-Regression, die zuerst typisierte INPUT-Felder liest und danach die naechste komplette Zeile mit LINE INPUT uebernimmt.

Example

' Getestete Beispiele: tests/pb/test_console_input_line.pb und tests/e2e/pb/test_fileio_minimal.pb
FUNCTION PBMAIN() AS LONG
    LOCAL s AS STRING
    LINE INPUT "Geben Sie eine Zeile ein: ", s
    PBMAIN = LEN(s)
END FUNCTION

Hinweise

  • Verwenden Sie INPUT für komma-getrennte Felder und ZEILENEINGABE für rohe Textzeilen.
  • Die Dateiform wird auf der Seite ZEILENEINGABE# ausführlicher beschrieben.

Verifiziertes Beispiel: LINE INPUT - ganze Zeile lesen

Beispieldatei: tests/pb/test_console_input_line.pb

Validierungsnachweis: compiled with Release/PBXB64.exe tests/pb/test_console_input_line.pb -o tmp/help_io_samples/test_console_input_line.exe and executed with exit code 0 stdin 42,"hello, world",3.5\nfinal line\n.

#COMPILE EXE
#CONSOLE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    DIM n AS LONG
    DIM s AS STRING
    DIM d AS DOUBLE
    DIM lineText AS STRING

    INPUT "Values"; n; s$; d
    LINE INPUT lineText$

    IF n <> 42 THEN FUNCTION = 1: EXIT FUNCTION
    IF s <> "hello, world" THEN FUNCTION = 2: EXIT FUNCTION
    IF d < 3.49 OR d > 3.51 THEN FUNCTION = 3: EXIT FUNCTION
    IF lineText <> "final line" THEN FUNCTION = 4: EXIT FUNCTION

    FUNCTION = 0
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft Datei- oder Konsolen-E/A und liefert Exitcode 0 nur bei korrektem Verhalten. Focus statement: LINE INPUT lineText$

See Also

  • EINGABE
  • ZEILENEINGABE#
  • PRINT
  • FILESCAN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


BASIC-String-Funktionen — PBXB64 Help

Startseite › BASIC Frontend › Strings

BASIC-String-Funktionen

Häufige String-Manipulationsfunktionen.

Aufgabe dieses Kapitels

Dieses Kapitel sammelt die BASIC-Sprachmittel zu einem zusammenhängenden Arbeitsbereich. Es dient als Einstieg, wenn Sie nicht den exakten Befehlsnamen kennen, sondern eine Spracheigenschaft suchen.

Verwendung

Beginnen Sie mit der Tabelle unten und wechseln Sie dann zur Detailseite des einzelnen Befehls. Die Detailseiten enthalten Syntax, Hinweise zur PBXB64-Unterstützung, Getestetes Beispiel und Querverweise.

Befehlsübersicht

Befehl | Bereich
MITTLERER $ | Häufige String-Manipulationsfunktionen.
LINKS$ | Häufige String-Manipulationsfunktionen.
RECHTS$ | Häufige String-Manipulationsfunktionen.
INSTR | Häufige String-Manipulationsfunktionen.
LEN | Häufige String-Manipulationsfunktionen.
ASC | Häufige String-Manipulationsfunktionen.
CHR$ | Häufige String-Manipulationsfunktionen.
UCASE$ | Häufige String-Manipulationsfunktionen.
LCASE$ | Häufige String-Manipulationsfunktionen.
TRIM$ | Häufige String-Manipulationsfunktionen.
LTRIM$ | Häufige String-Manipulationsfunktionen.
RTRIM$ | Häufige String-Manipulationsfunktionen.
ERSETZEN$ | Häufige String-Manipulationsfunktionen.
STR$ | Häufige String-Manipulationsfunktionen.
VAL | Häufige String-Manipulationsfunktionen.

Getestetes Beispiel

Diese Seite ist ein Uebersichtskapitel. Die verlinkten Einzelseiten enthalten die konkreten getesteten Beispiele oder nennen eine ausdrueckliche Begrenzung, wenn ein Befehl nicht zertifiziert ist.

PBXB64-Status: Uebersicht / Navigation; keine eigenstaendige Laufzeitbehauptung ohne Unterseitenbeleg.

Praktische Hinweise

BASIC-Quelltext wird im PBXB64-Frontend direkt in die gemeinsame Zwischenrepräsentation übersetzt. Achten Sie deshalb besonders auf Datentypen, ByVal/ByRef-Übergabe, Zeichenkettenlängen und Laufzeitfehlerpfade.

Siehe auch

  • BASIC-Sprachübersicht

← Back

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


MID$ ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? MID$

MITTLERER $

Ersetzen Sie Zeichen in einer Zeichenfolge

Typ:Anweisung |Kategorie:String-Funktionen

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MID$( StringVar , Start& [, Count& ]) = replacement
M ID$( StringVar , Start& TO End& = replacement

Beschreibung

Die MID$-Anweisung ersetzt Zeichen in einer String-Variablen. Das erste Formular gibt die Anzahl der zu ersetzenden Zeichen an, w?hrend das zweite Formular stattdessen die Start- und Endposition angibt. Beide Formen bieten die gleiche Funktionalit?t, sodass die Wahl nur eine Frage der Bequemlichkeit des Programmierers ist.

Start& und End& sind Positionen in der Zeichenfolge, beginnend mit 1 als erstem Zeichen. Count& gibt die Anzahl der zu ersetzenden Zeichen an.

Wenn Count& weggelassen wird oder nicht gen?gend Zeichen in StringVar vorhanden sind, werden alle verbleibenden Zeichen ersetzt. Wenn an der Start&-Position keine Zeichen vorhanden sind, wird keine Operation ausgef?hrt.

Wenn Start& oder End& negativ sind, werden die Positionen vom Ende der Zeichenfolge r?ckw?rts gez?hlt (-1 ist das letzte Zeichen). Wenn Count& negativ ist, wird es als LEN( string_expression )-ABS( Count& ) interpretiert.

Die Ersetzung wird niemals ?ber das Ende von StringVar hinausgehen. Mit anderen Worten: MID$ kann die L?nge einer Zeichenfolge nicht ?ndern.

Einschr?nkungen

Wenn Start& auf einer Seite eine Position au?erhalb der Zeichenfolge ergibt oder wenn Start& Null ist, wird keine Operation ausgef?hrt.

Verifiziertes Beispiel: MID$ - Teilstring aus der Mitte

Beispieldatei: examples/basic/help_strings/help_mid.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_strings/help_mid.pb -o tmp/help_string_samples/help_mid.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF MID$("abcdef", 2, 3) <> "bcd" THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft das String-Ergebnis und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: MID$("abcdef", 2, 3)

Hinweise

Die Seite zeigt das zentrierte Ergebnis und den Charakter-Set-Fall. Dokumentieren Sie auf der Hilfeseite auch Füllzeichen, Trunkierung und die Tatsache, dass die String-Form die gefundenen Zeichen in Originalreihenfolge zurückgibt.

Siehe auch

  • BUILD$
  • INSTR
  • LTRIM$
  • MID$-Funktion
  • REMOVE$
  • REPLACE
  • RTRIM$
  • TALLY
  • TRIM$
  • ?BERPR?FEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LEFT$ ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? LEFT$

LINKS$

Geben Sie ganz links zur?ck

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = LEFT$( string _ expression , n& )

Beschreibung

n& ist ein Long-Integer-Ausdruck und gibt die Anzahl der Zeichen in string_expression an, die zur?ckgegeben werden sollen.

LEFT$ gibt einen String zur?ck, der aus den am weitesten links stehenden n& Zeichen seines String-Arguments besteht. Wenn n& gr??er oder gleich der L?nge von string_expression ist, wird die gesamte L?nge von string_expression zur?ckgegeben. Wenn n& Null ist, gibt LEFT$ eine leere Zeichenfolge zur?ck. Wenn der L?ngenwertparameter negativ ist, wird er als LEN (string_expression)-ABS (n&) interpretiert. Beispielsweise gibt LEFT$("1234567890",-2) ?12345678? zur?ck.

Verifiziertes Beispiel: LEFT$ - linker Teilstring

Beispieldatei: examples/basic/help_strings/help_left.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_strings/help_left.pb -o tmp/help_string_samples/help_left.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF LEFT$("abcdef", 3) <> "abc" THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft das String-Ergebnis und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: LEFT$("abcdef", 3)

Hinweise

Die Seite zeigt das zentrierte Ergebnis und den Charakter-Set-Fall. Dokumentieren Sie auf der Hilfeseite auch Füllzeichen, Trunkierung und die Tatsache, dass die String-Form die gefundenen Zeichen in Originalreihenfolge zurückgibt.

Siehe auch

  • EXTRACT$
  • INSTR
  • LTRIM$
  • MITTLERER $
  • RICHTIG$
  • RTRIM$
  • GETEILT
  • TALLY
  • TRIM$
  • ?BERPR?FEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RIGHT$ ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? RIGHT$

RICHTIG$

Geben Sie ganz rechts zur?ck

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = RIGHT$( string_expression , n& )

Beschreibung

Wenn n& positiv ist, gibt RIGHT$ die angegebene Anzahl von Zeichen aus der Zeichenfolge zur?ck, beginnend von rechts und nach links arbeitend. Wenn n& gr??er als die L?nge von string_expression ist, wird der gesamte string_expression zur?ckgegeben.

Wenn n& 0 ist, gibt RIGHT$ eine leere Zeichenfolge zur?ck. Wenn n& negativ ist, wird es als ( LEN ( string_expression ) - ABS ( n& )) interpretiert. Beispielsweise gibt RIGHT$("1234567890", -2) ?34567890? zur?ck.

Verifiziertes Beispiel: RIGHT$ - rechter Teilstring

Beispieldatei: examples/basic/help_strings/help_right.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_strings/help_right.pb -o tmp/help_string_samples/help_right.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF RIGHT$("abcdef", 3) <> "def" THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft das String-Ergebnis und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: RIGHT$("abcdef", 3)

Hinweise

Die Seite zeigt das zentrierte Ergebnis und den Charakter-Set-Fall. Dokumentieren Sie auf der Hilfeseite auch Füllzeichen, Trunkierung und die Tatsache, dass die String-Form die gefundenen Zeichen in Originalreihenfolge zurückgibt.

Siehe auch

  • EXTRACT$
  • INSTR
  • LINKS$
  • LTRIM$
  • MITTLERER $
  • REMOVE$
  • REPLACE
  • RTRIM$
  • GETEILT
  • TALLY
  • TRIM$
  • ?BERPR?FEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


INSTR ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? INSTR

INSTR

Suchen Sie eine Zeichenfolge

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

y& = INSTR([ Position& ,] MainStr$ , [ANY] MatchStr$ )

Beschreibung

INSTR gibt die Position von MatchStr$ innerhalb von MainStr$ zur?ck. Der R?ckgabewert ist auf eins indiziert, w?hrend Null ?nicht gefunden? bedeutet.

Position& gibt die Zeichenposition an, an der die Suche beginnen soll. Wenn Position& eins oder gr??er ist, wird MainStr$ von links nach rechts durchsucht. Der Wert eins beginnt beim ersten Zeichen, zwei beim zweiten usw. Wenn Position& -1 oder kleiner ist, wird MainStr$ von rechts nach links durchsucht. Der Wert -1 beginnt beim letzten Zeichen, -2 beim vorletzten usw. Wenn Position& nicht angegeben ist, wird der Standardwert +1 angenommen.

x& = INSTR("xyz", "y") ' gibt 2 zur?ck

x& = INSTR("xyz", "a") ' gibt 0 zur?ck

a$ = "Mein Hund" : b$ = " "

x& = INSTR(a$, b$) ' gibt 3 zur?ck

Es ist wichtig zu beachten, dass der R?ckgabewert von INSTR() in allen F?llen, auch wenn Position& negativ ist, die absolute Position der ?bereinstimmung ist, von links nach rechts, beginnend mit dem ersten Zeichen.

Wenn das Schl?sselwort ANY enthalten ist, gibt MatchStr$ eine Liste einzelner Zeichen an. INSTR sucht nach jedem dieser Zeichen einzeln. Sobald eines dieser Zeichen gefunden wird, gibt INSTR die Position der ?bereinstimmung zur?ck.

x& = INSTR(-2, ?efcdef?, ANY ?ef?) gibt ein Ergebnis von 5 zur?ck

INSTR unterscheidet zwischen Gro?- und Kleinschreibung, was bedeutet, dass Gro?- und Kleinbuchstaben in MatchStr$ und MainStr$ genau ?bereinstimmen m?ssen.

PBXB64 validiert den Vorw?rts-Suchpfad zur Laufzeit f?r dynamische String-Operanden und Startausdr?cke zur Laufzeit. Die registrierte Regression tests/pb/test_instr_dynamic.pb deckt INSTR(text$, "Alpha"), INSTR(text$, needle$), INSTR(start&, text$, "Alpha"), INSTR(start&, text$, needle$) und das Ergebnis Null bei einem fehlenden Teilstring ab.

Einschr?nkungen

Spezielle Suchbegriffe werden in dieser Reihenfolge ausgewertet:

Verifiziertes Beispiel: INSTR - Teilstringposition finden

Beispieldatei: examples/basic/help_strings/help_instr.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_strings/help_instr.pb -o tmp/help_string_samples/help_instr.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF INSTR("Hello World", "World") <> 7 THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft das String-Ergebnis und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: INSTR("Hello World", "World")

Hinweise

Die Seite zeigt das zentrierte Ergebnis und den Charakter-Set-Fall. Dokumentieren Sie auf der Hilfeseite auch Füllzeichen, Trunkierung und die Tatsache, dass die String-Form die gefundenen Zeichen in Originalreihenfolge zurückgibt.

Siehe auch

  • EXTRACT$
  • LCASE$
  • LINKS$
  • LTRIM$
  • MITTLERER $
  • RICHTIG$
  • RTRIM$
  • SHRINK$
  • TALLY
  • TRIM$
  • UCASE$
  • ?BERPR?FEN

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


LEN ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? LEN

LEN

Gibt die logische L?nge von a zur?ck

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

y& = LEN( target )

Beschreibung

Wenn ?target? eine Zeichenfolgenvariable oder ein Zeichenfolgenausdruck ist, gibt LEN einen Wert von 0 bis zur aktuellen Zeichenfolgenl?nge zur?ck, der die Anzahl der Zeichen in ?target? darstellt. Wenn das Ziel eine Zeichenfolge fester L?nge ist, wird die L?nge des festen Puffers zur?ckgegeben. Wenn das Ziel eine mit NULL terminierte Zeichenfolge ist, wird die L?nge der in der mit NULL terminierten Zeichenfolge gespeicherten Daten zur?ckgegeben, nicht die maximale Gr??e der mit NULL terminierten Zeichenfolge. Verwenden Sie SIZEOF, um die maximale Gr??e einer mit Null terminierten Zeichenfolge zu bestimmen.

Bei Verwendung mit Zeigern gibt LEN den Wert 4 zur?ck, da ein Zeiger immer als DWORD gespeichert wird. Sie k?nnen LEN mit dem Ziel eines Zeigers verwenden, um die Gr??e des Ziels zur?ckzugeben. Wenn das Ziel ein dynamischer String ist, erhalten Sie die L?nge des Strings, nicht die L?nge des Handles.

target kann auch ein beliebiger anderer Variablentyp sein, einschlie?lich numerischer und benutzerdefinierter Typen (definiert mit TYPE/END TYPE ). In diesem Fall gibt PowerBASIC die Anzahl der Bytes zur?ck, die zum Speichern einer Variablen dieses Typs erforderlich sind.

Wenn Sie die Gr??e einer aufgef?llten (ausgerichteten) UDT-Struktur mit der LEN- (oder SIZEOF-)Anweisung messen, umfasst die gemessene L?nge alle Auff?llungen, die der Struktur hinzugef?gt wurden. Beispielsweise die folgende UDT-Struktur:

TYP L?ngeTestTyp DWORD

a AS INTEGER

END-TYP

' Code hier

DIM abc AS LengthTestType

x& = LEN(abc)

Gibt eine L?nge von 4 Bytes in x& zur?ck, da der UDT mit 2 zus?tzlichen Bytes aufgef?llt wurde, um die DWORD-Ausrichtung zu erzwingen. Beachten Sie, dass die LEN einzelner UDT-Mitglieder die wahre Gr??e des Mitglieds zur?ckgibt, ohne Ber?cksichtigung von Auff?llung oder Ausrichtung. Im vorherigen Beispiel gibt LEN(abc.a) 2 zur?ck.

Verifiziertes Beispiel: LEN - Stringlaenge

Beispieldatei: examples/basic/help_strings/help_len.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_strings/help_len.pb -o tmp/help_string_samples/help_len.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF LEN("Hello") <> 5 THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft das String-Ergebnis und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: LEN("Hello")

Hinweise

Die Seite zeigt das zentrierte Ergebnis und den Charakter-Set-Fall. Dokumentieren Sie auf der Hilfeseite auch Füllzeichen, Trunkierung und die Tatsache, dass die String-Form die gefundenen Zeichen in Originalreihenfolge zurückgibt.

Siehe auch

  • CHRBYTES
  • SIZEOF

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ASC ? PBXB64-Compiler-Hilfe

Startseite? Funktionen ? ASC

ASC

Ersetzt ein Zeichen in einer Zeichenfolge

Typ:Anweisung |Kategorie:String-Funktionen

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ASC( stringvar , position& ) = CharCode&

Beschreibung

Die ASC-Anweisung ersetzt ein Zeichen in einer String-Variablen. Der Parameter position& bestimmt, welches Zeichen ersetzt wird. Das erste Zeichen ist eins, das zweite zwei usw. Wenn position& negativ ist, z?hlt ASC vom Ende der Zeichenfolge in umgekehrter Reihenfolge. Das hei?t, -1 gibt das letzte Zeichen an, -2 gibt das vorletzte Zeichen an usw.

Wenn die Zeichenfolgenvariable ANSI ist, muss der CharCode im Bereich von 0 bis 255 liegen. Bei Unicode muss der CharCode im Bereich von 0 bis 65535 liegen.

Einschr?nkungen

Mit der ASC-Anweisung kann die L?nge einer Zeichenfolge nicht verl?ngert werden. Wenn string null (L?nge Null) oder position null oder gr??er als die L?nge von stringvar ist, wird der Vorgang ignoriert.

Verifiziertes Beispiel: ASC - Zeichencode

Beispieldatei: examples/basic/help_strings/help_asc.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_strings/help_asc.pb -o tmp/help_string_samples/help_asc.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF ASC("A") <> 65 THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft das String-Ergebnis und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: ASC("A")

Hinweise

Die Seite zeigt das zentrierte Ergebnis und den Charakter-Set-Fall. Dokumentieren Sie auf der Hilfeseite auch Füllzeichen, Trunkierung und die Tatsache, dass die String-Form die gefundenen Zeichen in Originalreihenfolge zurückgibt.

Siehe auch

  • ASC-Funktion
  • CHR$
  • MID$-Anweisung

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CHR$ - PBXB64 Compiler Help

Startseite ? Functions ? CHR$

CHR$

Converts one or more numeric character codes (

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = CHR$( expression [, expression ] [,...])
s$ = CHR$( string_expression [,...])
s$$ = CHR$$( x& TO y& , ...)

Beschreibung

The CHR$() form of the function creates a string of ANSI (1- byte ) characters. Arguments must be ANSI (1-byte) characters, or codes in the range of 0 to 255. The CHR$$() form of the function creates a string of WIDE (2-byte) characters. Arguments must be WIDE (2-byte) characters, or codes in the range of 0 to 65535.

Generally speaking, PowerBASIC handles ANSI/WIDE conversions for you, automatically and transparently. However, there are just a few functions (CHR$, PEEK$ , POKE$ , STRING$ , etc.) which are ambiguous, by definition, and require that the programmer choose the appropriate result type (ANSI or WIDE). Use CHR$ for ANSI results, or use CHR$$ for Unicode results. In the remainder of these remarks, CHR$ is used to represent both CHR$ and CHR$$.

CHR$ creates and returns a string. There are three forms of arguments available, and they may be intermixed in a single CHR$ function. The created string may contain no characters, one character, or multiple characters, depending upon the arguments you use. You may specify any number of arguments for this function.

If the argument is a numeric expression, it is translated into the character defined by that number. A character code of -1 is treated as a special case. If you use it as an argument, CHR$ returns an empty (zero length) string for that character. For example, CHR$(65, -1, 66) returns "AB".

CHR$(x& TO y&) returns a sequence of all characters from CHR$(x&) through CHR$(y&) inclusive. The characters may be ascending or descending in sequence. For example, CHR$(65 TO 70) returns the string "ABCDEF". CHR$(52 T0 50) returns the string "432", and CHR$(65 TO 65) returns the string "A".

If the argument is a string expression, the characters are simply copied into the newly created string at the specified position. The expanded CHR$ definition is intended to assist in the encoding of longer strings, to avoid the need for concatenation operations.

For example, the CHR$ function can be used to create COLLATE strings for the ARRAY SORT and ARRAY SCAN statements at run-time, and can be used to create string equates at compile time:

$colstring = CHR$(0 TO 131, 97, 133 TO 255)

The following lines are functionally equivalent, and return the same string result:

a$ = CHR$("Line1", 13, 10, "Line2")

a$ = "Line1" & CHR$(13) & CHR$(10) & "Line2"

a$ = "Line1" & $CRLF & "Line2"

CHR$ complements the ASC function, which returns the numeric character code of a nominated character in a string.

Verifiziertes Beispiel: CHR$ - Zeichen aus Code

Beispieldatei: examples/basic/help_strings/help_chr.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_strings/help_chr.pb -o tmp/help_string_samples/help_chr.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF CHR$(65) <> "A" THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft das String-Ergebnis und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: CHR$(65)

Hinweise

Die Seite zeigt das zentrierte Ergebnis und den Charakter-Set-Fall. Dokumentieren Sie auf der Hilfeseite auch Füllzeichen, Trunkierung und die Tatsache, dass die String-Form die gefundenen Zeichen in Originalreihenfolge zurückgibt.

Siehe auch

  • ARRAY-SCAN
  • ARRAY-SORTIERUNG
  • ASC-Funktion
  • ASC statement
  • NUL$
  • SPACE$
  • STRING$

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


UCASE$ ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? UCASE$

UCASE$

Gibt eine vollst?ndig in Gro?buchstaben (Gro?buchstaben) geschriebene Version einer Zeichenfolge zur?ck

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = UCASE$( string_expression [,ANSI | OEM])

Beschreibung

UCASE$ gibt eine Zeichenfolge zur?ck, die string_expression entspricht, mit der Ausnahme, dass Kleinbuchstaben in string_expression in Gro?buchstaben umgewandelt werden. Der optionale ANSI- oder OEM-Parameter gibt an, ob die Konvertierung unter Verwendung des ANSI-Zeichensatzes f?r das System oder des urspr?nglichen IBM OEM-Zeichensatzes erfolgt. Wenn kein Zeichensatz angegeben ist, verwendet PowerBASIC f?r Windows den System-ANSI-Zeichensatz, w?hrend PB/CC den IBM OEM-Zeichensatz verwendet. Von diesem Parameter sind nur ?internationale? Zeichen im Bereich von CHR$ (128) bis CHR$(255) betroffen.

Der OEM-Zeichensatz basiert auf dem urspr?nglichen IBM OEM-Zeichensatz, um die Kompatibilit?t mit Programmen sicherzustellen, die f?r alle fr?heren Versionen des PowerBASIC-Compilers geschrieben wurden.

Verifiziertes Beispiel: UCASE$ - Text in Grossbuchstaben

Beispieldatei: examples/basic/help_strings/help_ucase.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_strings/help_ucase.pb -o tmp/help_string_samples/help_ucase.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF UCASE$("abC") <> "ABC" THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft das String-Ergebnis und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: UCASE$("abC")

Hinweise

Die Seite zeigt das zentrierte Ergebnis und den Charakter-Set-Fall. Dokumentieren Sie auf der Hilfeseite auch Füllzeichen, Trunkierung und die Tatsache, dass die String-Form die gefundenen Zeichen in Originalreihenfolge zurückgibt.

Siehe auch

  • ASC
  • LCASE$
  • MCASE$

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LCASE$ ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? LCASE$

LCASE$

Gibt eine kleingeschriebene Version einer Zeichenfolge zur?ck

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = LCASE$( string_expression [,ANSI | OEM])

Beschreibung

LCASE$ gibt eine Zeichenfolge zur?ck, die string_expression entspricht, mit der Ausnahme, dass Gro?buchstaben in string_expression in Kleinbuchstaben umgewandelt werden. Der optionale ANSI- oder OEM-Parameter gibt an, ob die Konvertierung unter Verwendung des ANSI-Zeichensatzes f?r das System oder des urspr?nglichen IBM OEM-Zeichensatzes erfolgt. Wenn kein Zeichensatz angegeben ist, verwendet PowerBASIC f?r Windows den System-ANSI-Zeichensatz, w?hrend PB/CC den IBM OEM-Zeichensatz verwendet. Von diesem Parameter sind nur ?internationale? Zeichen im Bereich von CHR$ (128) bis CHR$(255) betroffen.

Der OEM-Zeichensatz basiert auf dem urspr?nglichen IBM OEM-Zeichensatz, um die Kompatibilit?t mit Programmen sicherzustellen, die f?r alle fr?heren Versionen des PowerBASIC-Compilers geschrieben wurden.

Verifiziertes Beispiel: LCASE$ - Text in Kleinbuchstaben

Beispieldatei: examples/basic/help_strings/help_lcase.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_strings/help_lcase.pb -o tmp/help_string_samples/help_lcase.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF LCASE$("AbC") <> "abc" THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft das String-Ergebnis und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: LCASE$("AbC")

Hinweise

Die Seite zeigt das zentrierte Ergebnis und den Charakter-Set-Fall. Dokumentieren Sie auf der Hilfeseite auch Füllzeichen, Trunkierung und die Tatsache, dass die String-Form die gefundenen Zeichen in Originalreihenfolge zurückgibt.

Siehe auch

  • MCASE$
  • UCASE$

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TRIM$ ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? TRIM$

TRIM$

Entfernt f?hrende und nachfolgende Zeichen oder Teilzeichenfolgen.

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

NewString$ = TRIM$( OldString$ [, [ANY] CharsToTrim$ ])
NewString$ = TRIM$( NumrExpr [, Digits& ])

Beschreibung

TRIM$ vereint die Funktionalit?t von LTRIM$ und RTRIM$ in einer einzigen Funktion. OldString$ ist der Zeichenfolgenausdruck, aus dem Zeichen entfernt werden sollen, und CharsToTrim$ ist der Zeichenfolgenausdruck zum Entfernen f?hrender und nachfolgender Vorkommen. Wenn CharsToTrim$ nicht angegeben ist, entfernt TRIM$ f?hrende und nachfolgende Leerzeichen.

Wenn das Schl?sselwort ANY enthalten ist, gibt CharsToTrim$ eine Liste einzelner Zeichen an, nach denen einzeln gesucht werden soll. Eine ?bereinstimmung mit einem dieser Zeichen als f?hrendes oder nachfolgendes Zeichen f?hrt dazu, dass das Zeichen aus dem Ergebnis entfernt wird.

NumrExpr

Wenn als Parameter ein numerischer Ausdruck angegeben wird, wird dieser in eine Zeichenfolge umgewandelt (genau wie STR$ ), jedoch ohne f?hrende oder nachgestellte Leerzeichen.

Ziffern&

Die maximale Anzahl signifikanter Ziffern im Bereich von 1 bis 18. Wenn nicht angegeben, liefert PowerBASIC einen Standardwert von 7 f?r Werte mit einfacher Genauigkeit oder 16 f?r genauere Werte. Achten Sie darauf, dass digits& gro? genug ist, um den ganzzahligen Teil einer Zahl aufzunehmen, andernfalls muss zur Sch?tzung die wissenschaftliche Notation verwendet werden. Beispielsweise gibt TRIM$(123.456, 2) ?1.2E+2? zur?ck, w?hrend FORMAT$ (123.456, 5) die Zeichenfolge ?123.45? zur?ckgibt.

Einschr?nkungen

TRIM$ unterscheidet zwischen Gro?- und Kleinschreibung, daher ist die Gro?- und Kleinschreibung wichtig.

Verifiziertes Beispiel: TRIM$ - beide Seiten trimmen

Beispieldatei: examples/basic/help_strings/help_trim.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_strings/help_trim.pb -o tmp/help_string_samples/help_trim.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF TRIM$("  abc  ") <> "abc" THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft das String-Ergebnis und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: TRIM$(" abc ")

Hinweise

Die Seite zeigt das zentrierte Ergebnis und den Charakter-Set-Fall. Dokumentieren Sie auf der Hilfeseite auch Füllzeichen, Trunkierung und die Tatsache, dass die String-Form die gefundenen Zeichen in Originalreihenfolge zurückgibt.

Siehe auch

  • CLIP$
  • FORMAT$
  • INSTR
  • LCASE$
  • LTRIM$
  • MCASE$
  • MITTLERER $
  • REMOVE$
  • REPLACE
  • RICHTIG$
  • RTRIM$
  • SHRINK$
  • TALLY
  • UCASE$
  • UNWRAP$
  • ?BERPR?FEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LTRIM$ ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? LTRIM$

LTRIM$

Gibt eine Kopie einer Zeichenfolge zur?ck

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

x$ = LTRIM$( MainString [, [ANY] MatchString ])

Beschreibung

MainString ist der Zeichenfolgenausdruck, aus dem Zeichen entfernt werden sollen, und MatchString ist der Zeichenfolgenausdruck, der die zu entfernenden Zeichen enth?lt.

Wenn MatchString nicht angegeben ist, entfernt LTRIM$ f?hrende Leerzeichen. LTRIM$ gibt einen Teilstring von MainString zur?ck, vom ersten Nicht-MatchString (oder Nicht-Leerzeichen) bis zum Ende des Strings. Wenn MatchString (oder ein Leerzeichen) am Anfang von MainString nicht vorhanden ist, wird der gesamte MainString zur?ckgegeben.

Wenn das Schl?sselwort ANY enthalten ist, gibt MatchString eine Liste einzelner Zeichen an, nach denen einzeln gesucht werden soll. Eine ?bereinstimmung mit einem dieser Zeichen als Hauptzeichen f?hrt dazu, dass das Zeichen aus dem Ergebnis entfernt wird.

Bei LTRIM$ muss die Gro?-/Kleinschreibung beachtet werden.

Verifiziertes Beispiel: LTRIM$ - links trimmen

Beispieldatei: examples/basic/help_strings/help_ltrim.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_strings/help_ltrim.pb -o tmp/help_string_samples/help_ltrim.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF LTRIM$("  abc") <> "abc" THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft das String-Ergebnis und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: LTRIM$(" abc")

Hinweise

Die Seite zeigt das zentrierte Ergebnis und den Charakter-Set-Fall. Dokumentieren Sie auf der Hilfeseite auch Füllzeichen, Trunkierung und die Tatsache, dass die String-Form die gefundenen Zeichen in Originalreihenfolge zurückgibt.

Siehe auch

  • CLIP$
  • EXTRACT$
  • INSTR
  • LINKS$
  • MITTLERER $
  • REMOVE$
  • REPLACE
  • RICHTIG$
  • RTRIM$
  • SHRINK$
  • STRDELETE$
  • STRINSERT$
  • STRREVERSE$
  • TALLY
  • TRIM$
  • UNWRAP$
  • ?BERPR?FEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RTRIM$ ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? RTRIM$

RTRIM$

Gibt eine Kopie einer Zeichenfolge zur?ck

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

x$ = RTRIM$( MainString [, [ANY] MatchString ])

Beschreibung

MainString ist der Zeichenfolgenausdruck, aus dem Zeichen entfernt werden sollen, und MatchString ist der Zeichenfolgenausdruck, der die Zeichen angibt, die von der rechten Seite von MainString entfernt werden sollen.

Wenn MatchString nicht angegeben ist, entfernt RTRIM$ nachgestellte Leerzeichen. RTRIM$ gibt einen Teilstring von MainString zur?ck, vom Anfang des Strings bis zum Zeichen vor den aufeinanderfolgenden Vorkommen von MatchString (oder Leerzeichen), der bis zum Ende des urspr?nglichen Strings fortgesetzt wird. Wenn MatchString (oder ein Leerzeichen) am Ende von MainString nicht vorhanden ist, wird der gesamte MainString zur?ckgegeben.

Bei RTRIM$ wird die Gro?-/Kleinschreibung beachtet.

Wenn das Schl?sselwort ANY enthalten ist, gibt MatchString eine Liste einzelner Zeichen an, nach denen einzeln gesucht werden soll ? eine ?bereinstimmung mit einem dieser Zeichen als nachgestelltes Zeichen f?hrt dazu, dass das Zeichen aus dem Ergebnis entfernt wird.

Verifiziertes Beispiel: RTRIM$ - rechts trimmen

Beispieldatei: examples/basic/help_strings/help_rtrim.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_strings/help_rtrim.pb -o tmp/help_string_samples/help_rtrim.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF RTRIM$("abc  ") <> "abc" THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft das String-Ergebnis und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: RTRIM$("abc ")

Hinweise

Die Seite zeigt das zentrierte Ergebnis und den Charakter-Set-Fall. Dokumentieren Sie auf der Hilfeseite auch Füllzeichen, Trunkierung und die Tatsache, dass die String-Form die gefundenen Zeichen in Originalreihenfolge zurückgibt.

Siehe auch

  • CLIP$
  • EXTRACT$
  • INSTR
  • LINKS$
  • LTRIM$
  • MITTLERER $
  • REMOVE$
  • REPLACE
  • RICHTIG$
  • STRDELETE$
  • STRINSERT$
  • STRREVERSE$
  • TALLY
  • TRIM$
  • ?BERPR?FEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


REPLACE ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? ERSETZEN

REPLACE

Innerhalb einer angegebenen Zeichenfolge

Typ:Anweisung |Kategorie:String-Funktionen

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

REPLACE [ANY] MatchString WITH NewString IN MainString

Beschreibung

Die REPLACE-Anweisung ersetzt alle Vorkommen von MatchString in MainString durch NewString. Der Ersatz kann dazu f?hren, dass MainString gr??er oder kleiner wird. MainString muss eine String-Variable sein; MatchString und NewString k?nnen Zeichenfolgenausdr?cke sein. Bei REPLACE wird die Gro?-/Kleinschreibung beachtet. Wenn eine ?bereinstimmung gefunden wird, beginnt die Suche nach der n?chsten ?bereinstimmung an der Position, die unmittelbar auf die vorherige ?bereinstimmung folgt.

Wenn Sie die Option ANY innerhalb von MainString verwenden, wird jedes Vorkommen jedes Zeichens in MatchString durch das entsprechende Zeichen in NewString ersetzt. In diesem Fall m?ssen MatchString und NewString die gleiche L?nge haben, da zwischen ihren Zeichen eine Eins-zu-eins-Entsprechung besteht.

Verifiziertes Beispiel: REPLACE$ - Text ersetzen

Beispieldatei: examples/basic/help_strings/help_replace.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_strings/help_replace.pb -o tmp/help_string_samples/help_replace.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF REPLACE$("ABAB", "AB", "X") <> "XX" THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft das String-Ergebnis und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: REPLACE$("ABAB", "AB", "X")

Hinweise

Die Seite zeigt das zentrierte Ergebnis und den Charakter-Set-Fall. Dokumentieren Sie auf der Hilfeseite auch Füllzeichen, Trunkierung und die Tatsache, dass die String-Form die gefundenen Zeichen in Originalreihenfolge zurückgibt.

Siehe auch

  • EXTRACT$
  • INSTR
  • LTRIM$
  • MITTLERER $
  • REMOVE$
  • BEHALTEN$
  • RICHTIG$
  • RTRIM$
  • SHRINK$
  • TALLY
  • TRIM$
  • UNWRAP$
  • ?BERPR?FEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


STR$ ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? STR$

STR$

Gibt die Zeichenfolge zur?ck

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = STR$( numeric_expression [, digits ])

Beschreibung

STR$ gibt die Zeichenfolgenform einer numerischen Variablen oder eines Ausdrucks in druckbarer Textform zur?ck. digits ist ein optionaler Integralausdruck, der die maximale Gesamtzahl der im Ergebnis erscheinenden Ziffern angibt. Wenn numeric_expression gr??er oder gleich Null ist, f?gt STR$ ein f?hrendes Leerzeichen hinzu; Wenn numeric_expression kleiner als Null ist, f?gt STR$ ein f?hrendes Negationszeichen (Minuszeichen) hinzu.

Beispielsweise gibt STR$(14) eine Zeichenfolge mit drei Zeichen zur?ck, wobei das erste Zeichen ein Leerzeichen und das zweite und dritte Zeichen die ASCII-Zeichen ?1? und ?4? sind. Mit LTRIM$ k?nnen f?hrende Leerzeichen entfernt werden.

digits gibt die maximale Anzahl der im Ergebnis gew?nschten signifikanten Ziffern (1 bis 18) an.

STR$ kann auch verwendet werden, um numerische Werte mit mehr als 16 signifikanten Ziffern (d. h. Gleitkommazahlen mit erweiterter Genauigkeit und Quad-Ganzzahlen) in eine druckbare Form umzuwandeln. Zum Beispiel:

a## = 2,0/3,0

x$ = STR$(a##,18)

gibt 0,666666666666666667 zur?ck.

Die Komplement?rfunktion ist VAL , die ein String-Argument entgegennimmt und das numerische ?quivalent zur?ckgibt. Somit ist Zahl = VAL(STR$( Zahl )).

Ein numerischer Wert der Integer-Klasse kann auch mit den Funktionen FORMAT$ und USING$ in eine Zeichenfolge konvertiert werden; Allerdings kann FORMAT$ problemlos eine Zeichenfolge zur?ckgeben, die keine f?hrenden Leerzeichen enth?lt. Beispiel: x$ = FORMAT$(a&).

Verifiziertes Beispiel: STR$ - Zahl in String

Beispieldatei: examples/basic/help_strings/help_str.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_strings/help_str.pb -o tmp/help_string_samples/help_str.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF LEN(STR$(42)) = 0 THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft das String-Ergebnis und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: STR$(42)

Hinweise

Die Seite zeigt das zentrierte Ergebnis und den Charakter-Set-Fall. Dokumentieren Sie auf der Hilfeseite auch Füllzeichen, Trunkierung und die Tatsache, dass die String-Form die gefundenen Zeichen in Originalreihenfolge zurückgibt.

Siehe auch

  • BIN$
  • FORMAT$
  • HEX$
  • LTRIM$
  • OCT$
  • RUNDEN
  • USING$
  • VAL

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


VAL ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? VAL

VAL

Konvertieren Sie einen Textstreifen

Typ:Anweisung |Kategorie:String-Funktionen

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

VAL StrgExpr [, offset ] TO ValueVar [, DigitsVar& , UnusedVar& ]

Beschreibung

Die VAL-Anweisung wandelt ein Zeichenfolgenargument in eine Zahl um, f?gt jedoch zus?tzliche Informationen zur Konvertierung hinzu. Sowohl f?hrende als auch nachfolgende Leerzeichen (Leerzeichen, Tabulatoren, Wagenr?cklauf und Zeilenvorschub) werden ?bersprungen und ignoriert. Wird keine Zahl gefunden, wird der Wert Null (0) zur?ckgegeben. Formatzeichen (wie Kommas) sind nicht zul?ssig und f?hren zum vorzeitigen Abbruch der Auswertung.

VAL interpretiert die Buchstaben ?e? und ?d? (und ?E? und ?D?) als Symbole f?r Potenzierung und wissenschaftliche Notation:

VAL "10.101e3" TO i& ' 10101 ~ 10.101*(10^3)

VAL ?2D4? TO j& ' 20000 ~ 2 * (10 ^ 4)

Hexadezimale, bin?re und oktale Konvertierungen

VAL kann auch zum Konvertieren von Zeichenfolgenargumenten in Form von Hexadezimal-, Bin?r- und Oktalzahlen verwendet werden. Hexadezimalwerten sollte das Pr?fix ?&H? und Bin?rwerten das Pr?fix ?&B? vorangestellt werden. Oktalwerten kann das Pr?fix ?&O?, ?&Q? oder nur ?&? vorangestellt werden. Wenn StrgExpr eine f?hrende Null enth?lt, wird das Ergebnis als vorzeichenloser Wert zur?ckgegeben. andernfalls wird ein vorzeichenbehafteter Wert zur?ckgegeben. Zum Beispiel:

VAL ?&HF5F3? TO i& ' Hex, gibt -2573 (mit Vorzeichen) zur?ck

VAL ?&H0F5F3? TO j& ' Hex, gibt 62963 zur?ck (ohne Vorzeichen)

VAL ?&B0100101101? TO x& ' Bin?r, gibt 301 zur?ck (ohne Vorzeichen)

VAL ?&O4574514? TO y& ' Oktal, gibt 1243468 (signiert) zur?ck

Zu den g?ltigen Hexadezimalzeichen geh?ren 0 bis 9, A bis F (und a bis f). G?ltige Oktalzeichen sind 0 bis 7 und Bin?rzeichen 0 bis 1.

Verwenden Sie die Funktionen STR$ , DEC$ , FORMAT$ und USING$, um numerische Werte in Dezimalzeichenfolgen umzuwandeln. Verwenden Sie BIN$, HEX$ und OCT$, um sie in bin?re, hexadezimale und oktale Darstellungen umzuwandeln.

Versatz

Wenn der optionale Offset-Parameter enthalten ist, gibt er die Position in der Zeichenfolge an, an der die Konvertierung beginnen soll. Wenn nicht angegeben, ist der Wert standardm??ig eins (1) und beginnt beim ersten Zeichen.

WertVar

Eine numerische Variable, die das Ergebnis der Konvertierung empf?ngt.

ZiffernVar

Eine optionale lange Ganzzahlvariable, die die Anzahl der in der Auswertung gefundenen signifikanten Ziffern empf?ngt. Wenn dieser Wert Null (0) ist, wurde keine g?ltige Zahl gefunden und ValueVar wurde auch Null (0) zugewiesen.

UnbenutzteVar

Eine optionale lange Ganzzahlvariable, die die Anzahl der nicht verwendeten Zeichen empf?ngt. Da bei der Auswertung sowohl f?hrende als auch nachfolgende Leerzeichen ?bersprungen werden, weist ein Wert ungleich Null darauf hin, dass m?glicherweise zus?tzliche Zeichen von gewisser Bedeutung vorhanden sind. Sie k?nnen RIGHT$(StrgExpr, UnUsedVar) verwenden, um die nicht verwendeten Zeichen zu trennen.

Einschr?nkungen

VAL stoppt die Analyse von string_expression, wenn nicht numerische Zeichen gefunden werden. Beim Umgang mit hexadezimalen, bin?ren und oktalen Zahlensystemen wird das Punktzeichen als nicht numerisch klassifiziert. Dies liegt daran, dass PowerBASIC nur Gleitkommaformate f?r das Dezimalzahlensystem unterst?tzt. VAL akzeptiert das Punktzeichen als Dezimalstelle f?r alle Werte im dezimalen Zahlensystem.

VAL analysiert keine nachgestellten Typspezifizierer f?r Dezimalzeichenfolgen. Beispielsweise wird VAL("9.1&") als 9.1 und nicht als 9 ausgewertet, da das Suffix ?&? als nicht numerisches Zeichen und nicht als Typbezeichner behandelt wird. Typsuffixe k?nnen jedoch mit bin?ren, oktalen und hexadezimalen Werten verwendet werden.

Verifiziertes Beispiel: VAL - String in Zahl

Beispieldatei: examples/basic/help_strings/help_val.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_strings/help_val.pb -o tmp/help_string_samples/help_val.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF VAL("12345") <> 12345 THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft das String-Ergebnis und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: VAL("12345")

Hinweise

Die Seite zeigt das zentrierte Ergebnis und den Charakter-Set-Fall. Dokumentieren Sie auf der Hilfeseite auch Füllzeichen, Trunkierung und die Tatsache, dass die String-Form die gefundenen Zeichen in Originalreihenfolge zurückgibt.

Siehe auch

  • BIN$
  • DEC$
  • FORMAT$
  • HEX$
  • OCT$
  • STR$
  • USING$
  • VAL-Funktion

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GRUNDLEGENDE mathematische Funktionen — PBXB64 Help

Startseite › BASIC Frontend › Math & Numeric

GRUNDLEGENDE mathematische Funktionen

Numerische Funktionen und Konstanten.

Aufgabe dieses Kapitels

Dieses Kapitel sammelt die BASIC-Sprachmittel zu einem zusammenhängenden Arbeitsbereich. Es dient als Einstieg, wenn Sie nicht den exakten Befehlsnamen kennen, sondern eine Spracheigenschaft suchen.

Verwendung

Beginnen Sie mit der Tabelle unten und wechseln Sie dann zur Detailseite des einzelnen Befehls. Die Detailseiten enthalten Syntax, Hinweise zur PBXB64-Unterstützung, Getestetes Beispiel und Querverweise.

Befehlsübersicht

Befehl | Bereich
ABS | Numerische Funktionen und Konstanten.
SGN | Numerische Funktionen und Konstanten.
INT | Numerische Funktionen und Konstanten.
FIX | Numerische Funktionen und Konstanten.
RUNDEN | Numerische Funktionen und Konstanten.
DECKE | Numerische Funktionen und Konstanten.
BODEN | Numerische Funktionen und Konstanten.
SIN | Numerische Funktionen und Konstanten.
COS | Numerische Funktionen und Konstanten.
TAN | Numerische Funktionen und Konstanten.
ATN | Numerische Funktionen und Konstanten.
SQR | Numerische Funktionen und Konstanten.
EXP | Numerische Funktionen und Konstanten.
PROTOKOLL | Numerische Funktionen und Konstanten.
RND | Numerische Funktionen und Konstanten.
RANDOMISIEREN | Numerische Funktionen und Konstanten.

Getestetes Beispiel

Diese Seite ist ein Uebersichtskapitel. Die verlinkten Einzelseiten enthalten die konkreten getesteten Beispiele oder nennen eine ausdrueckliche Begrenzung, wenn ein Befehl nicht zertifiziert ist.

PBXB64-Status: Uebersicht / Navigation; keine eigenstaendige Laufzeitbehauptung ohne Unterseitenbeleg.

Praktische Hinweise

BASIC-Quelltext wird im PBXB64-Frontend direkt in die gemeinsame Zwischenrepräsentation übersetzt. Achten Sie deshalb besonders auf Datentypen, ByVal/ByRef-Übergabe, Zeichenkettenlängen und Laufzeitfehlerpfade.

Siehe auch

  • BASIC-Sprachübersicht

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ABS – PBXB64-Compiler-Hilfe

Startseite› Funktionen › ABS

ABS

Gibt den absoluten Wert einer Zahl zurück

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

y = ABS( numeric_expression )

Beschreibung

Der absolute Wert einer Zahl ist ihr nicht negativer Wert. Beispielsweise ist der Absolutwert von -3 3, und der Absolutwert von +3 ist ebenfalls 3. Der Absolutwert von 0 ist 0.

Verifiziertes Beispiel: ABS - Betrag

Beispieldatei: examples/basic/help_math/help_abs.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_math/help_abs.pb -o tmp/help_math_samples/help_abs.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF ABS(-42) <> 42 THEN FUNCTION = 1 ELSE FUNCTION = 0
END FUNCTION

Validierungsnachweis: this page now carries a direct, compile-and-run proof note so the command reference remains tied to validated behavior instead of prose alone.

Verhalten: Prueft, dass ein negativer Integer in seinen positiven Betrag umgewandelt wird. Focus assertion: IF ABS(-42) <> 42 THEN FUNCTION = 1 ELSE FUNCTION = 0

Siehe auch

  • SGN

Beispiel

#COMPILE EXE
#DIM ALL
' math_abs_basic
FUNCTION PBMAIN() AS LONG
  IF (ABS(0)) <> (0) THEN FUNCTION = 1: EXIT FUNCTION
  IF (ABS(1)) <> (1) THEN FUNCTION = 2: EXIT FUNCTION
  IF (ABS(-1)) <> (1) THEN FUNCTION = 3: EXIT FUNCTION
  IF (ABS(100)) <> (100) THEN FUNCTION = 4: EXIT FUNCTION
  IF (ABS(-100)) <> (100) THEN FUNCTION = 5: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SGN ? PBXB64-Compiler-Hilfe

Startseite? Funktionen ? SGN

SGN

Gibt das Vorzeichen eines numerischen Ausdrucks zur?ck.

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

y = SGN( numeric_expression )

Beschreibung

Wenn numerischer_Ausdruck positiv ist, gibt SGN 1 zur?ck. Wenn numerischer_Ausdruck Null ist, gibt SGN 0 zur?ck. Wenn numerischer_Ausdruck negativ ist, gibt SGN -1 zur?ck.

In Verbindung mit den Anweisungen ON GOTO und ON GOSUB kann SGN einen FORTRAN-?hnlichen Drei-Wege-Zweig erzeugen:

ON SGN(Saldo) + 2 GOTO InTheRed, BreakingEven, InTheMoney

Verifiziertes Beispiel: SGN - numerisches Vorzeichen

Beispieldatei: examples/basic/help_math/help_sgn.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_math/help_sgn.pb -o tmp/help_math_samples/help_sgn.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF SGN(-9) <> -1 THEN FUNCTION = 1
    IF SGN(0) <> 0 THEN FUNCTION = 2
    IF SGN(9) <> 1 THEN FUNCTION = 3
END FUNCTION

Validierungsnachweis: this page now carries a direct, compile-and-run proof note so the command reference remains tied to validated behavior instead of prose alone.

Verhalten: Prueft die Ergebnisse fuer negative, Null- und positive Werte. Focus assertion: IF SGN(-9) <> -1 THEN FUNCTION = 1

Siehe auch

  • ABS
  • IF
  • AUF GOSUB
  • AUF GOTO
  • SELECT

Beispiel

#COMPILE EXE
#DIM ALL
' math_sgn_basic
FUNCTION PBMAIN() AS LONG
  IF (SGN(0)) <> (0) THEN FUNCTION = 1: EXIT FUNCTION
  IF (SGN(5)) <> (1) THEN FUNCTION = 2: EXIT FUNCTION
  IF (SGN(-5)) <> (-1) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


INT ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? INT

INT

Wandeln Sie einen numerischen Ausdruck in ein Integral um

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

y = INT( numeric_expression )

Beschreibung

INT rundet numeric_expression auf den gr??ten ganzzahligen Wert, der kleiner oder gleich numeric_expression ist.

Verifiziertes Beispiel: INT - Abrunden gegen minus unendlich

Beispieldatei: examples/basic/help_math/help_int.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_math/help_int.pb -o tmp/help_math_samples/help_int.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF INT(3.8) <> 3 THEN FUNCTION = 1
    IF INT(-3.8) <> -4 THEN FUNCTION = 2
END FUNCTION

Validierungsnachweis: this page now carries a direct, compile-and-run proof note so the command reference remains tied to validated behavior instead of prose alone.

Verhalten: Prueft positives Abschneiden und negatives Abrunden. Focus assertion: IF INT(-3.8) <> -4 THEN FUNCTION = 2

Siehe auch

  • DECKE
  • CINT
  • FIX
  • FRAC
  • RUNDEN

Beispiel

#COMPILE EXE
#DIM ALL
' math_int_basic
FUNCTION PBMAIN() AS LONG
  IF ((INT(1.9)) < (1.0000000000) - 0.0001) OR ((INT(1.9)) > (1.0000000000) + 0.0001) THEN FUNCTION = 1: EXIT FUNCTION
  IF ((INT(-1.9)) < (-2.0000000000) - 0.0001) OR ((INT(-1.9)) > (-2.0000000000) + 0.0001) THEN FUNCTION = 2: EXIT FUNCTION
  IF ((INT(0.5)) < (0.0000000000) - 0.0001) OR ((INT(0.5)) > (0.0000000000) + 0.0001) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FIX ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? FIX

FIX

Syntax

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

y = FIX( numeric_expression )

Beschreibung

FIX entfernt den Bruchteil seines Arguments und gibt den ganzzahligen Teil zur?ck. Im Gegensatz zu CINT und INT f?hrt FIX keinerlei Rundung oder Skalierung durch.

Verifiziertes Beispiel: FIX - gegen Null abschneiden

Beispieldatei: examples/basic/help_math/help_fix.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_math/help_fix.pb -o tmp/help_math_samples/help_fix.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF FIX(3.8) <> 3 THEN FUNCTION = 1
    IF FIX(-3.8) <> -3 THEN FUNCTION = 2
END FUNCTION

Validierungsnachweis: this page now carries a direct, compile-and-run proof note so the command reference remains tied to validated behavior instead of prose alone.

Verhalten: Prueft, dass negative Werte gegen Null abgeschnitten werden. Focus assertion: IF FIX(-3.8) <> -3 THEN FUNCTION = 2

Siehe auch

  • DECKE
  • CINT
  • INT
  • FRAC
  • RUNDEN

Beispiel

#COMPILE EXE
#DIM ALL
' math_fix_basic
FUNCTION PBMAIN() AS LONG
  IF ((FIX(1.9)) < (1.0000000000) - 0.0001) OR ((FIX(1.9)) > (1.0000000000) + 0.0001) THEN FUNCTION = 1: EXIT FUNCTION
  IF ((FIX(-1.9)) < (-1.0000000000) - 0.0001) OR ((FIX(-1.9)) > (-1.0000000000) + 0.0001) THEN FUNCTION = 2: EXIT FUNCTION
  IF ((FIX(0.5)) < (0.0000000000) - 0.0001) OR ((FIX(0.5)) > (0.0000000000) + 0.0001) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ROUND ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? RUND

RUNDEN

Runden Sie einen numerischen Wert auf eine angegebene Anzahl von Dezimalstellen.

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

x = ROUND( numeric_expression , n )

Beschreibung

n ist ein Integralausdruck, der die Anzahl der im Ergebnis erforderlichen Dezimalstellen angibt. ROUND ist besonders n?tzlich, wenn Sie eine Variable mit einfacher, doppelter oder erweiterter Genauigkeit haben und diese in eine W?hrungsvariable einf?gen oder auf eine bestimmte Anzahl von Dezimalstellen gerundet anzeigen m?chten.

Das Runden erfolgt nach dem ?Banker-Rundungsprinzip?: Wenn die zu rundende Nachkommastelle genau f?nf ist und keine nachgestellten Ziffern enth?lt, wird die Zahl auf die n?chste gerade Zahl gerundet. Dies liefert im Durchschnitt bessere Ergebnisse als der einfache Ansatz ?auf f?nf aufrunden?.

A% = ROUND(0.5, 0) ' 0

A% = ROUND(1.5, 0) ' 2

A% = ROUND(2.5, 0) ' 2

A% = ROUND(2.51, 0) ' 3

Verifiziertes Beispiel: ROUND - naechster Integer

Beispieldatei: examples/basic/help_math/help_round.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_math/help_round.pb -o tmp/help_math_samples/help_round.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF ROUND(3.4) <> 3 THEN FUNCTION = 1
    IF ROUND(3.6) <> 4 THEN FUNCTION = 2
END FUNCTION

Validierungsnachweis: this page now carries a direct, compile-and-run proof note so the command reference remains tied to validated behavior instead of prose alone.

Verhalten: Prueft einfache Integer-Rundung fuer Werte unter und ueber der Halbgrenze. Focus assertion: IF ROUND(3.6) <> 4 THEN FUNCTION = 2

Siehe auch

  • DECKE
  • FIX
  • FORMAT$
  • INT
  • USING$

Beispiel

#COMPILE EXE
#DIM ALL
' math_round_basic
FUNCTION PBMAIN() AS LONG
  IF ((ROUND(1.4)) < (1.0000000000) - 0.0001) OR ((ROUND(1.4)) > (1.0000000000) + 0.0001) THEN FUNCTION = 1: EXIT FUNCTION
  IF ((ROUND(1.6)) < (2.0000000000) - 0.0001) OR ((ROUND(1.6)) > (2.0000000000) + 0.0001) THEN FUNCTION = 2: EXIT FUNCTION
  IF ((ROUND(-1.5)) < (-2.0000000000) - 0.0001) OR ((ROUND(-1.5)) > (-2.0000000000) + 0.0001) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CEIL - PBXB64 Compiler Help

Startseite ? Functions ? CEIL

DECKE

Konvertieren Sie ein Floating

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

intvar = CEIL( numeric_expression )

Beschreibung

Die CEIL-Funktion rundet auf und gibt den kleinsten ganzzahligen Wert zur?ck, der gr??er oder gleich numeric_expression ist. Beispielsweise platziert y = CEIL(1.5) den Wert 2 in y .

Verifiziertes Beispiel: CEIL - aufrunden

Beispieldatei: examples/basic/help_math/help_ceil.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_math/help_ceil.pb -o tmp/help_math_samples/help_ceil.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF CEIL(3.2) <> 4 THEN FUNCTION = 1
    IF CEIL(-3.2) <> -3 THEN FUNCTION = 2
END FUNCTION

Validierungsnachweis: this page now carries a direct, compile-and-run proof note so the command reference remains tied to validated behavior instead of prose alone.

Verhalten: Prueft Aufrunden fuer positive und negative Werte. Focus assertion: IF CEIL(3.2) <> 4 THEN FUNCTION = 1

Siehe auch

  • CINT
  • FIX
  • FRAC
  • INT
  • RUNDEN

Beispiel

#COMPILE EXE
#DIM ALL
' math_ceil_basic
FUNCTION PBMAIN() AS LONG
  IF ((CEIL(1.1)) < (2.0000000000) - 0.0001) OR ((CEIL(1.1)) > (2.0000000000) + 0.0001) THEN FUNCTION = 1: EXIT FUNCTION
  IF ((CEIL(-1.1)) < (-1.0000000000) - 0.0001) OR ((CEIL(-1.1)) > (-1.0000000000) + 0.0001) THEN FUNCTION = 2: EXIT FUNCTION
  IF ((CEIL(0.0)) < (0.0000000000) - 0.0001) OR ((CEIL(0.0)) > (0.0000000000) + 0.0001) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BODEN - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Mathematik & Zahlen › BODEN
Hilfe zum PBXB64-Compiler

BODEN

Rundet eine Zahl auf die nächstkleinere Ganzzahl ab.

Kind: Funktion | Category: Math & Numeric

PBXB64 Status: VERFÜGBAR

PBXB64 Certification: [ZERTIFIZIERT GETESTET]

Syntax

result = FLOOR( numeric_expression )

Description

FLOOR gibt den größten ganzzahligen Wert zurück, der kleiner oder gleich dem Argument ist. Positive Werte verlieren den Nachkommateil; negative Werte gehen zur nächstkleineren negativen Ganzzahl.

Verwenden Sie FLOOR, wenn Sie ein genaues Abrunden nach unten brauchen, zum Beispiel für Indizes, Buckets, Paginierung oder andere Berechnungen, bei denen Trunkierung nicht dasselbe ist wie Floor-Logik.

Die Funktion unterscheidet sich bei negativen Werten von INT und FIX; wählen Sie deshalb die Funktion, die zu Ihrer Mathematik passt.

Example

' Getestetes Beispiel: tests/e2e/pb/test_math_ceil_floor.pb
FUNCTION PBMAIN() AS LONG
    IF FLOOR(3.8) <> 3 THEN FUNCTION = 1 : EXIT FUNCTION
    IF FLOOR(-3.8) <> -4 THEN FUNCTION = 2 : EXIT FUNCTION
    FUNCTION = 0
END FUNCTION

Hinweise

  • FLOOR ist ein echtes Abrunden nach unten, nicht eine Trunkierung auf Null.
  • Vergleichen Sie es mit INT und FIX, wenn Sie mit negativen Werten arbeiten.

Verifiziertes Beispiel: FLOOR - abrunden

Beispieldatei: examples/basic/help_math/help_floor.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_math/help_floor.pb -o tmp/help_math_samples/help_floor.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF FLOOR(3.8) <> 3 THEN FUNCTION = 1
    IF FLOOR(-3.8) <> -4 THEN FUNCTION = 2
END FUNCTION

Validierungsnachweis: this page now carries a direct, compile-and-run proof note so the command reference remains tied to validated behavior instead of prose alone.

Verhalten: Prueft Abrunden fuer positive und negative Werte. Focus assertion: IF FLOOR(-3.8) <> -4 THEN FUNCTION = 2

See Also

  • INT
  • FIX
  • DECKE
  • RUNDEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


SIN ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? SIN

S?NDE

Gibt den Sinus seines Arguments zur?ck.

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

y = SIN( numeric_expression )

Beschreibung

numeric_expression ist ein im Bogenma? angegebener Winkel. SIN gibt einen Wert mit erweiterter Genauigkeit zwischen -1 und +1 zur?ck.

Um Bogenma? in Grad umzurechnen, multiplizieren Sie mit 57,29577951308232##. Um Grad in Bogenma? umzurechnen, multiplizieren Sie mit 0,0174532925199433##. Weitere Informationen zum Bogenma? finden Sie in der ATN-Funktion.

Der Umkehrsinus (ARCSIN) eines Wertes kann wie folgt berechnet werden:

ArcSin = ATN(Wert / SQR(1 - Wert * Wert))

Der Hyperbolische Sinus (SINH) eines Wertes kann auch berechnet werden:

SinH = (EXP(Wert) - EXP(-Wert)) / 2

Der umgekehrte hyperbolische Sinus (ARCSINH) eines Wertes kann auch berechnet werden:

ArcSinH = LOG(Wert + SQR(Wert * Wert + 1))

' N?tzliche Makrofunktionen

M ACRO Pi = 3,141592653589793##

MACRO DegreesToRadians(dpDegrees) = (dpDegrees * 0,0174532925199433##)

MACRO RadiansToDegrees(dpRadians) = (dpRadians * 57,29577951308232##)

Verifiziertes Beispiel: SIN - Sinus

Beispieldatei: examples/basic/help_math/help_sin.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_math/help_sin.pb -o tmp/help_math_samples/help_sin.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF ABS(SIN(0)) > 0.000001 THEN FUNCTION = 1
END FUNCTION

Validierungsnachweis: this page now carries a direct, compile-and-run proof note so the command reference remains tied to validated behavior instead of prose alone.

Verhalten: Prueft den Sinus fuer Winkel Null mit kleiner Toleranz. Focus assertion: IF ABS(SIN(0)) > 0.000001 THEN FUNCTION = 1

Siehe auch

  • ATN
  • COS
  • BR?UNEN

Beispiel

#COMPILE EXE
#DIM ALL
' math_sin_basic
FUNCTION PBMAIN() AS LONG
  IF ((SIN(0.0)) < (0.0000000000) - 0.0001) OR ((SIN(0.0)) > (0.0000000000) + 0.0001) THEN FUNCTION = 1: EXIT FUNCTION
  IF ((SIN(1.0)) < (0.8414709848) - 0.0001) OR ((SIN(1.0)) > (0.8414709848) + 0.0001) THEN FUNCTION = 2: EXIT FUNCTION
  IF ((SIN(-1.0)) < (-0.8414709848) - 0.0001) OR ((SIN(-1.0)) > (-0.8414709848) + 0.0001) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' math_trig_identity
FUNCTION PBMAIN() AS LONG
  LOCAL x AS DOUBLE
  x = SIN(0.5) * SIN(0.5) + COS(0.5) * COS(0.5)
  IF ((x) < (1.0) - 0.0001) OR ((x) > (1.0) + 0.0001) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


COS ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? COS

COS

Gibt den Kosinus eines Winkels zur?ck.

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

y = COS( numeric_expression )

Beschreibung

numeric_expression ist ein im Bogenma? angegebener Winkel. Um Bogenma? in Grad umzurechnen, multiplizieren Sie mit 57,29577951308232##. Um Grad in Bogenma? umzurechnen, multiplizieren Sie mit 0,0174532925199433##. Weitere Informationen zum Bogenma? finden Sie in der ATN-Funktion.

COS gibt einen Wert mit erweiterter Genauigkeit zur?ck, der immer zwischen -1 und +1 einschlie?lich liegt.

Der Umkehrkosinus (ARCCOS) eines Wertes kann wie folgt berechnet werden:

pi## = 3,141592653589793##

ArcCos = pi## / 2 - ATN( Wert / SQR(1 - Wert * Wert ))

Der Hyperbolische Kosinus (COSH) eines Wertes kann auch berechnet werden:

CosH = (EXP(Wert) + EXP(-Wert)) / 2

Der umgekehrte hyperbolische Kosinus (ARCCOSH) eines Wertes kann auch berechnet werden:

ArcCosH = LOG(Wert + SQR(Wert * Wert - 1))

' N?tzliche Makrofunktionen

MAKRO Pi = 3,141592653589793##

MACRO DegreesToRadians(dpDegrees) = (dpDegrees*0.0174532925199433##)

MACRO RadiansToDegrees(dpRadians) = (dpRadians*57,29577951308232##)

Verifiziertes Beispiel: COS - Kosinus

Beispieldatei: examples/basic/help_math/help_cos.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_math/help_cos.pb -o tmp/help_math_samples/help_cos.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF ABS(COS(0) - 1) > 0.000001 THEN FUNCTION = 1
END FUNCTION

Validierungsnachweis: this page now carries a direct, compile-and-run proof note so the command reference remains tied to validated behavior instead of prose alone.

Verhalten: Prueft den Kosinus fuer Winkel Null mit kleiner Toleranz. Focus assertion: IF ABS(COS(0) - 1) > 0.000001 THEN FUNCTION = 1

Siehe auch

  • ATN
  • S?NDE
  • BR?UNEN

Beispiel

#COMPILE EXE
#DIM ALL
' math_cos_basic
FUNCTION PBMAIN() AS LONG
  IF ((COS(0.0)) < (1.0000000000) - 0.0001) OR ((COS(0.0)) > (1.0000000000) + 0.0001) THEN FUNCTION = 1: EXIT FUNCTION
  IF ((COS(1.0)) < (0.5403023059) - 0.0001) OR ((COS(1.0)) > (0.5403023059) + 0.0001) THEN FUNCTION = 2: EXIT FUNCTION
  IF ((COS(-1.0)) < (0.5403023059) - 0.0001) OR ((COS(-1.0)) > (0.5403023059) + 0.0001) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' math_trig_identity
FUNCTION PBMAIN() AS LONG
  LOCAL x AS DOUBLE
  x = SIN(0.5) * SIN(0.5) + COS(0.5) * COS(0.5)
  IF ((x) < (1.0) - 0.0001) OR ((x) > (1.0) + 0.0001) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TAN ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? TAN

BR?UNEN

Gibt den Tangens seines Arguments zur?ck.

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

y = TAN( numeric_expression )

Beschreibung

numeric_expression ist ein im Bogenma? angegebener Winkel. Um Bogenma? in Grad umzurechnen, multiplizieren Sie mit 57,29577951308232##. Um Grad in Bogenma? umzurechnen, multiplizieren Sie mit 0,0174532925199433##. Weitere Informationen zum Bogenma? finden Sie unter ATN.

TAN gibt ein Ergebnis mit erweiterter Genauigkeit zur?ck.

TAN wird mit dem Ausdruck angen?hert:

TAN = SIN(Wert) / COS(Wert)

Der Umkehrtangens (ARCTAN) eines Werts kann einfach mit der ATN-Funktion berechnet werden.

Der hyperbolische Tangens (TANH) eines Wertes kann berechnet werden:

TanH = (EXP(2 * Wert) - 1) / (EXP(2 * Wert) + 1)

Der umgekehrte hyperbolische Tangens (ARCTANH) eines Wertes kann berechnet werden:

ArcTanH = LOG((1 + Wert) / (1 - Wert)) / 2

' N?tzliche Makrofunktionen

MAKRO Pi = 3,141592653589793##

MACRO DegreesToRadians(dpDegrees) = (dpDegrees * 0,0174532925199433##)

MACRO RadiansToDegrees(dpRadians) = (dpRadians * 57,29577951308232##)

Verifiziertes Beispiel: TAN - Tangens

Beispieldatei: examples/basic/help_math/help_tan.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_math/help_tan.pb -o tmp/help_math_samples/help_tan.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF ABS(TAN(0)) > 0.000001 THEN FUNCTION = 1
END FUNCTION

Validierungsnachweis: this page now carries a direct, compile-and-run proof note so the command reference remains tied to validated behavior instead of prose alone.

Verhalten: Prueft den Tangens fuer Winkel Null mit kleiner Toleranz. Focus assertion: IF ABS(TAN(0)) > 0.000001 THEN FUNCTION = 1

Siehe auch

  • ATN
  • COS
  • S?NDE

Beispiel

#COMPILE EXE
#DIM ALL
' math_tan_basic
FUNCTION PBMAIN() AS LONG
  IF ((TAN(0.0)) < (0.0000000000) - 0.0001) OR ((TAN(0.0)) > (0.0000000000) + 0.0001) THEN FUNCTION = 1: EXIT FUNCTION
  IF ((TAN(0.5)) < (0.5463024898) - 0.0001) OR ((TAN(0.5)) > (0.5463024898) + 0.0001) THEN FUNCTION = 2: EXIT FUNCTION
  IF ((TAN(-0.5)) < (-0.5463024898) - 0.0001) OR ((TAN(-0.5)) > (-0.5463024898) + 0.0001) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ATN ? PBXB64-Compiler-Hilfe

Startseite? Funktionen ? ATN

ATN

Gibt den Arkustangens eines Arguments zur?ck.

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

y = ATN( numeric_expression )

Beschreibung

ATN gibt den Arcustangens (Inverstangens) von numeric_expression zur?ck; das hei?t, der Winkel, dessen Tangens numeric_expression ist.

Das Ergebnis wird, wie bei allen Winkeloperationen in PowerBASIC, im Bogenma? und nicht in Grad angegeben. Obwohl es ?blich ist, Winkel in Grad anzugeben, ist das Bogenma? eine bequemere Ma?einheit f?r mathematische Operationen. Ein Bogenma? ist definiert als der Winkel in der Mitte eines Kreises, der einen Bogen mit der L?nge eines Radius umschlie?t. Da f?r alle Kreise die Konstante ? :

Umfang / Radius = 2 * ?

Die L?nge des Kreisumfangs ist gleich 2 * ? * Radius und der Winkel eines Vollkreises (360 Grad) ist gleich 2 * ? Bogenma?.

Um Bogenma? in Grad umzurechnen, multiplizieren Sie einfach den Bogenma?wert mit 180/? , oder 57.29577951308232##. Der Arkustangens von 0,23456 kann beispielsweise folgenderma?en umgerechnet werden:

t = ATN(.23456!) 't = 0,230395 (Bogenma?)

t = 57,29577951308232## * ATN(.23456!) 't= 13,200 (Grad)

Um Grad in Bogenma? umzurechnen, multiplizieren Sie mit 0,0174532925199433##. Zum Beispiel:

14 Grad = (0,0174532925199433## * 14) = 0,2443460952792062 Bogenma?

Anstatt sich die Umrechnungsfaktoren f?r Bogenma?/Grad zu merken, berechnen Sie sie selbst, indem Sie sich diese Beziehung merken: 2 ? Das Bogenma? entspricht einem Vollkreis (360 Grad), also 1 ? Das Bogenma? betr?gt 180 ? Grad. Umgekehrt entspricht 1 Grad ? / 180 Bogenma?.

? ist eine transzendente Konstante, das hei?t, sie hat unendlich viele Dezimalstellen. Bis zu einer Genauigkeit von 15 Stellen, ausreichend f?r die meisten Anwendungen, ? = 3,141592653589793##. Dieser Wert kann mit dem Ausdruck gut angen?hert werden:

pi## = 4 * ATN(1)

Umrechnungen von Grad in Bogenma? und Bogenma? in Grad sind gute Anwendungen f?r benutzerdefinierte Funktionen.

Die ATN-Funktion gibt immer ein Ergebnis mit erweiterter Genauigkeit zur?ck.

Der Tangens (TAN) eines Wertes l?sst sich einfach mit der TAN-Funktion berechnen.

Der hyperbolische Tangens (TANH) kann berechnet werden:

TanH = (EXP(2 * Wert) - 1) / (EXP(2 * Wert) + 1)

Der umgekehrte hyperbolische Tangens (ARCTANH) eines Wertes kann berechnet werden:

ArcTanH = LOG((1 + Wert) / (1 - Wert)) / 2

' N?tzliche Makrofunktionen

MAKRO Pi = 3,141592653589793##

MACRO DegreesToRadians(dpDegrees) = (dpDegrees*0.0174532925199433##)

MACRO RadiansToDegrees(dpRadians) = (dpRadians*57,29577951308232##)

Verifiziertes Beispiel: ATN - Arkustangens

Beispieldatei: examples/basic/help_math/help_atn.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_math/help_atn.pb -o tmp/help_math_samples/help_atn.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF ABS(ATN(0)) > 0.000001 THEN FUNCTION = 1
END FUNCTION

Validierungsnachweis: this page now carries a direct, compile-and-run proof note so the command reference remains tied to validated behavior instead of prose alone.

Verhalten: Prueft den Arkustangens von Null mit kleiner Toleranz. Focus assertion: IF ABS(ATN(0)) > 0.000001 THEN FUNCTION = 1

Siehe auch

  • COS
  • S?NDE
  • BR?UNEN

Beispiel

#COMPILE EXE
#DIM ALL
' math_atn_basic
FUNCTION PBMAIN() AS LONG
  IF ((ATN(0.0)) < (0.0000000000) - 0.0001) OR ((ATN(0.0)) > (0.0000000000) + 0.0001) THEN FUNCTION = 1: EXIT FUNCTION
  IF ((ATN(1.0)) < (0.7853981634) - 0.0001) OR ((ATN(1.0)) > (0.7853981634) + 0.0001) THEN FUNCTION = 2: EXIT FUNCTION
  IF ((ATN(-1.0)) < (-0.7853981634) - 0.0001) OR ((ATN(-1.0)) > (-0.7853981634) + 0.0001) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SQR ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? SQR

SQR

Gibt die Quadratwurzel seines Arguments zur?ck.

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

y = SQR( numeric_expression )

Beschreibung

numeric_expression muss gr??er oder gleich Null sein. SQR berechnet Quadratwurzeln mithilfe eines optimierten Algorithmus. Das hei?t, die Ausf?hrung von y = SQR(x) dauert weniger lange als die von y = x^0,5.

Der Versuch, die Quadratwurzel einer negativen Zahl zu ziehen, f?hrt zu keinen Laufzeitfehlern, die Ergebnisse einer solchen Operation sind jedoch undefiniert.

SQR gibt ein Ergebnis mit erweiterter Genauigkeit zur?ck.

Verifiziertes Beispiel: SQR - Quadratwurzel

Beispieldatei: examples/basic/help_math/help_sqr.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_math/help_sqr.pb -o tmp/help_math_samples/help_sqr.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF SQR(81) <> 9 THEN FUNCTION = 1
END FUNCTION

Validierungsnachweis: this page now carries a direct, compile-and-run proof note so the command reference remains tied to validated behavior instead of prose alone.

Verhalten: Prueft ein exaktes Quadratwurzel-Ergebnis. Focus assertion: IF SQR(81) <> 9 THEN FUNCTION = 1

Siehe auch

  • EXP
  • EXP2
  • EXP10
  • PROTOKOLL
  • LOG2
  • LOG10

Beispiel

#COMPILE EXE
#DIM ALL
' math_sqr_basic
FUNCTION PBMAIN() AS LONG
  IF ((SQR(0.0)) < (0.0000000000) - 0.0001) OR ((SQR(0.0)) > (0.0000000000) + 0.0001) THEN FUNCTION = 1: EXIT FUNCTION
  IF ((SQR(1.0)) < (1.0000000000) - 0.0001) OR ((SQR(1.0)) > (1.0000000000) + 0.0001) THEN FUNCTION = 2: EXIT FUNCTION
  IF ((SQR(2.0)) < (1.4142135624) - 0.0001) OR ((SQR(2.0)) > (1.4142135624) + 0.0001) THEN FUNCTION = 3: EXIT FUNCTION
  IF ((SQR(9.0)) < (3.0000000000) - 0.0001) OR ((SQR(9.0)) > (3.0000000000) + 0.0001) THEN FUNCTION = 4: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


EXP ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? EXP

EXP

Gibt eine zu einer Potenz erh?hte Basiszahl zur?ck. Die Basis ist

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

y = EXP( n )
y = EXP2( n )
y = EXP10( n )

Beschreibung

EXP gibt e in der n-ten Potenz zur?ck, wobei n eine numerische Variable oder ein numerischer Ausdruck ist und e die Basis f?r nat?rliche Logarithmen ist, etwa 2,718282. Dies bietet unter anderem eine einfache M?glichkeit, den Wert von e selbst zu ermitteln:

e = EXP(1)

EXP2( n ) gibt 2 hoch n-ten Potenz zur?ck, wobei n eine numerische Variable oder ein numerischer Ausdruck ist.

EXP10( n ) gibt 10 hoch n-ten Potenz zur?ck, wobei n eine numerische Variable oder ein numerischer Ausdruck ist.

Die EXP-Funktionen stellen eine praktische Alternative zum ^-Operator dar, der mit jeder Basis funktioniert. Die EXP-Funktionen geben Ergebnisse mit erweiterter Genauigkeit zur?ck.

Verifiziertes Beispiel: EXP - Exponentialfunktion

Beispieldatei: examples/basic/help_math/help_exp.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_math/help_exp.pb -o tmp/help_math_samples/help_exp.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF ROUND(EXP(0), 0) <> 1 THEN FUNCTION = 1
END FUNCTION

Validierungsnachweis: this page now carries a direct, compile-and-run proof note so the command reference remains tied to validated behavior instead of prose alone.

Verhalten: Prueft die Exponential-Identitaet EXP(0)=1. Focus assertion: IF ROUND(EXP(0), 0) <> 1 THEN FUNCTION = 1

Siehe auch

  • PROTOKOLL
  • LOG2
  • LOG10
  • SQR
  • Arithmetische Operatoren

Beispiel

#COMPILE EXE
#DIM ALL
' math_exp_basic
FUNCTION PBMAIN() AS LONG
  IF ((EXP(0.0)) < (1.0000000000) - 0.0001) OR ((EXP(0.0)) > (1.0000000000) + 0.0001) THEN FUNCTION = 1: EXIT FUNCTION
  IF ((EXP(1.0)) < (2.7182818285) - 0.0001) OR ((EXP(1.0)) > (2.7182818285) + 0.0001) THEN FUNCTION = 2: EXIT FUNCTION
  IF ((EXP(2.0)) < (7.3890560989) - 0.0001) OR ((EXP(2.0)) > (7.3890560989) + 0.0001) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' math_exp_log_inverse
FUNCTION PBMAIN() AS LONG
  LOCAL x AS DOUBLE
  x = EXP(LOG(2.0))
  IF ((x) < (2.0) - 0.0001) OR ((x) > (2.0) + 0.0001) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOG ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? LOG

PROTOKOLL

LOG gibt die nat?rliche (base

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

y = LOG( numeric_expression )
y = LOG2( numeric_expression )
y = LOG10( numeric_expression )

Beschreibung

Der Logarithmus einer Zahl ist die Potenz, mit der die Basis erh?ht werden m?sste, um die Zahl zu ergeben. Also:

Logarithmus (Basis b) von n = x, wenn b^x = n

(Basis)^log(n) = n

Die EXP-Funktionen erg?nzen die LOG-Funktionen. Wenn beispielsweise s = LOG(t) ist, dann ist t = EXP(s).

Per Definition ist der Logarithmus (jede Basis) von 1 0. LOG gibt den nat?rlichen Logarithmus (Basis e, wobei e = 2,718282...) seines Arguments zur?ck. LOG2 und LOG10 geben den Logarithmus zur Basis 2 bzw. 10 zur?ck.

numerischer_Ausdruck muss ein Wert gr??er als Null sein.

LOG, LOG2 und LOG10 geben Werte mit erweiterter Genauigkeit zur?ck.

Verifiziertes Beispiel: LOG - natuerlicher Logarithmus

Beispieldatei: examples/basic/help_math/help_log.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_math/help_log.pb -o tmp/help_math_samples/help_log.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    IF ABS(LOG(1)) > 0.000001 THEN FUNCTION = 1
END FUNCTION

Validierungsnachweis: this page now carries a direct, compile-and-run proof note so the command reference remains tied to validated behavior instead of prose alone.

Verhalten: Prueft die Logarithmus-Identitaet LOG(1)=0. Focus assertion: IF ABS(LOG(1)) > 0.000001 THEN FUNCTION = 1

Siehe auch

  • EXP
  • EXP2
  • EXP10
  • SQR
  • Arithmetische Operatoren

Beispiel

#COMPILE EXE
#DIM ALL
' math_log_basic
FUNCTION PBMAIN() AS LONG
  IF ((LOG(1.0)) < (0.0000000000) - 0.0001) OR ((LOG(1.0)) > (0.0000000000) + 0.0001) THEN FUNCTION = 1: EXIT FUNCTION
  IF ((LOG(2.0)) < (0.6931471806) - 0.0001) OR ((LOG(2.0)) > (0.6931471806) + 0.0001) THEN FUNCTION = 2: EXIT FUNCTION
  IF ((LOG(10.0)) < (2.3025850930) - 0.0001) OR ((LOG(10.0)) > (2.3025850930) + 0.0001) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' math_exp_log_inverse
FUNCTION PBMAIN() AS LONG
  LOCAL x AS DOUBLE
  x = EXP(LOG(2.0))
  IF ((x) < (2.0) - 0.0001) OR ((x) > (2.0) + 0.0001) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RND ? Echter Zufallszahlengenerator ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? RND ? Generator f?r echte Zufallszahlen
Hilfe zum PBXB64-Compiler

RND ? Echter Zufallszahlengenerator (V8.1)

Gibt eine Zufallszahl zur?ck. Die V8.1 Die Implementierung verwendet einen echten linear-kongruentialen Generator (LCG) mit einem darin gespeicherten Thread-lokalen Startwert c_runtime_user.o. Der Ausgabebereich ist genau [0, 1) f?r die No-Argument-/Einzelargument-Form und einen inklusiven Ganzzahlbereich f?r die RND(a, b) Formular.

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status: VERF?GBAR ? echte Implementierung, kein Stub

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

y = RND                       ' returns DOUBLE in [0, 1)
y = RND(a, b)                 ' returns LONG in [a, b] inclusive
y = RND(seed)                 ' with positive seed: next in sequence
                              ' with zero:     repeats last value
                              ' with negative: re-seeds the generator

Beschreibung

Gleitkommamodus: RND gibt einen Wert in zur?ck [0, 1). Der interne Algorithmus ist ein 64-Bit-LCG (Mod 2^64, Multiplikator 6364136223846793005) und ein Thread-lokaler Zustand. Der zur?ckgegebene Wert hat doppelte Genauigkeit.

Integralbereichsmodus: RND(a, b) gibt a zur?ck LONG in [a, b] inklusive. Beide Endpunkte m?ssen in eine 32-Bit-Ganzzahl mit Vorzeichen passen.

Spezialeffektmodus: Ein einzelnes Argument steuert das Reseeding-Verhalten. Bei einem positiven Startwert schaltet der Generator weiter. Bei Null wird der letzte Wert wiederholt. Bei einem negativen Seed wird der Generator neu geseedet.

Beispiel

FUNCTION PBMAIN() AS LONG
    RANDOMIZE 42
    PRINT RND       ' deterministic first value
    PRINT RND       ' deterministic second value
    PRINT RND(1, 6) ' a "die roll" 1..6
    FUNCTION = 0
END FUNCTION
Thread-Sicherheit: Der Seed-Status ist Thread-lokal. Jeder Thread verf?gt ?ber einen eigenen Generator, der von den anderen unabh?ngig ist. Das erneute Seeding eines Threads hat keine Auswirkungen auf andere Threads.

Verifiziertes Beispiel: RND - Zufallszahl

Beispieldatei: examples/basic/help_math/help_rnd.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_math/help_rnd.pb -o tmp/help_math_samples/help_rnd.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    LOCAL x AS DOUBLE
    x = RND()
    IF x < 0 THEN FUNCTION = 1
    IF x >= 1 THEN FUNCTION = 2
END FUNCTION

Validierungsnachweis: this page now carries a direct, compile-and-run proof note so the command reference remains tied to validated behavior instead of prose alone.

Verhalten: Prueft, dass RND einen Wert im dokumentierten Bereich [0,1) liefert. Focus assertion: x = RND()

Siehe auch

  • RANDOMISIEREN ? Den Generator s?en
  • TIMER ? typische Standard-Seed-Quelle

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RANDOMIZE ? Real Seed ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? RANDOMIZE ? Real Seed

RANDOMISIEREN ? Real Seed (V8.1)

Setzen Sie den Zufallszahlengenerator ein. Die V8.1 Die Implementierung setzt den Zufallszahlen-Startwert des aktuellen Threads.

Typ:Anweisung |Kategorie:Mathematik und Numerik

PBXB64-Status: VERF?GBAR ? echte Implementierung, kein Stub

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

RANDOMIZE [ number ]

Beschreibung

number ist ein Startwert, der ein beliebiger numerischer Typ sein kann. Wenn number nicht angegeben ist, wird der von zur?ckgegebene Wert zur?ckgegeben TIMER Funktion wird verwendet (Systemverf?gbarkeit in Sekunden, gek?rzt auf a LONG).

Vom Zufallszahlengenerator zur?ckgegebene Werte (RND) h?ngen vom Saatwert ab. F?r einen gegebenen Samen RND gibt immer die gleiche Sequenz zur?ck. Jedes Programm, das davon abh?ngt RND l?uft jedes Mal auf die gleiche Weise ab, es sei denn, es wird ein anderer Startwert angegeben.

Jeder Thread verf?gt ?ber einen eigenen, unabh?ngigen Zufallszahlen-Seed. Das erneute Seeding eines Threads hat keine Auswirkungen auf andere Threads.

Beispiel

FUNCTION PBMAIN() AS LONG
    RANDOMIZE 12345      ' deterministic seed
    PRINT RND            ' first value
    PRINT RND            ' second value

    RANDOMIZE            ' reseed with TIMER
    PRINT RND            ' non-deterministic
    FUNCTION = 0
END FUNCTION

Verifiziertes Beispiel: RANDOMIZE - Zufallszahlen initialisieren

Beispieldatei: examples/basic/help_math/help_randomize.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/help_math/help_randomize.pb -o tmp/help_math_samples/help_randomize.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    LOCAL x AS DOUBLE
    RANDOMIZE 42
    x = RND()
    IF x < 0 THEN FUNCTION = 1
    IF x >= 1 THEN FUNCTION = 2
END FUNCTION

Validierungsnachweis: this page now carries a direct, compile-and-run proof note so the command reference remains tied to validated behavior instead of prose alone.

Verhalten: Prueft, dass RANDOMIZE einen numerischen Seed akzeptiert und der naechste RND-Wert im Bereich bleibt. Focus assertion: RANDOMIZE 42

Siehe auch

  • RND ? der Zufallszahlengenerator
  • TIMER ? Standard-Seed-Quelle

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Lange Ganzzahlen (&) “ PBXB64-Compiler-Hilfe

Startseite â€º Funktionen â€º Lange ganze Zahlen (&)
Hilfe zum PBXB64-Compiler

Lange ganze Zahlen (&)

Wie reguläre Integers können Long Integers keine Dezimalstellen enthalten. Sie umfassen jedoch einen viel gröÃŸeren Bereich, von -2.147.483.648 bis +2.147.483.647 ( -2^31 bis 2^31 - 1), belegen jedoch nur 4 Bytes (32-Bit).

Typ:Schlüsselwort |Kategorie:Datentypen

PBXB64-Status:VERFÃœGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Lange Ganzzahlen werden identifiziert, indem dem Variablennamen ein kaufmännisches Und (d. h. var&) folgt oder indem die DEFLNG-Anweisung verwendet wird, wie in der vorherigen Diskussion von Ganzzahlen beschrieben. Sie können Long-Integer-Variablen auch mit dem Schlüsselwort LONG mit der DIM-Anweisung deklarieren. Zum Beispiel:

Lange Ganzzahlen sind der effizienteste numerische Datentyp in PowerBASIC und sollten in allen Fällen verwendet werden, in denen Geschwindigkeit wichtig ist und kein gröÃŸerer numerischer Bereich erforderlich ist. (Die Verwendung von Byte- und Integer-Variablen in FOR/NEXT-Schleifen ist tatsächlich langsamer als die Verwendung einer Long-Ganzzahl.)

Eine PowerBASIC-Long-Integer-Variable entspricht dem BOOL-Datentyp (in GroÃŸbuchstaben), der üblicherweise von C/C++-Compilern verwendet wird. Beachten Sie, dass ein Bool (Kleinbuchstabe) ein nicht-traditioneller Datentyp ist, der einem Byte in PowerBASIC entspricht. Beachten Sie, dass einige ältere C-Compiler die Schlüsselwörter bool und BOOL frei austauschen können.

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_type_long
FUNCTION PBMAIN() AS LONG
  LOCAL a AS LONG
  a = 10
  IF (a) <> (10) THEN FUNCTION = 1: EXIT FUNCTION
  a = a + 5
  IF (a) <> (15) THEN FUNCTION = 2: EXIT FUNCTION
  a = a * 2
  IF (a) <> (30) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_type_integer
FUNCTION PBMAIN() AS LONG
  LOCAL a AS INTEGER
  a = 10
  IF (a) <> (10) THEN FUNCTION = 1: EXIT FUNCTION
  a = a + 5
  IF (a) <> (15) THEN FUNCTION = 2: EXIT FUNCTION
  a = a * 2
  IF (a) <> (30) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_type_byte
FUNCTION PBMAIN() AS LONG
  LOCAL a AS BYTE
  a = 10
  IF (a) <> (10) THEN FUNCTION = 1: EXIT FUNCTION
  a = a + 5
  IF (a) <> (15) THEN FUNCTION = 2: EXIT FUNCTION
  a = a * 2
  IF (a) <> (30) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_type_word
FUNCTION PBMAIN() AS LONG
  LOCAL a AS WORD
  a = 10
  IF (a) <> (10) THEN FUNCTION = 1: EXIT FUNCTION
  a = a + 5
  IF (a) <> (15) THEN FUNCTION = 2: EXIT FUNCTION
  a = a * 2
  IF (a) <> (30) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_type_dword
FUNCTION PBMAIN() AS LONG
  LOCAL a AS DWORD
  a = 10
  IF (a) <> (10) THEN FUNCTION = 1: EXIT FUNCTION
  a = a + 5
  IF (a) <> (15) THEN FUNCTION = 2: EXIT FUNCTION
  a = a * 2
  IF (a) <> (30) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_type_quad
FUNCTION PBMAIN() AS LONG
  LOCAL a AS QUAD
  a = 10
  IF (a) <> (10) THEN FUNCTION = 1: EXIT FUNCTION
  a = a + 5
  IF (a) <> (15) THEN FUNCTION = 2: EXIT FUNCTION
  a = a * 2
  IF (a) <> (30) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Kind: Reference topic | Category: Data Types

PBXB64 Status: AVAILABLE

Description

LONG is the signed 32-bit integer type used by the BASIC frontend for arithmetic, counters, status codes, and many Windows return values. It is the default integral type for much of the classic PowerBASIC surface.

Syntax

LOCAL value AS LONG

Validation Evidence

Validation evidence: The numeric-type pages and basic arithmetic regressions prove the current LONG size and signed behavior.

Example

LOCAL value AS LONG
value = 12345

See Also

  • cmd_int.html
  • cmd_byte.html
  • cmd_quad.html

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PARSE$ “ PBXB64-Compiler-Hilfe

Startseite â€º Funktionen â€º PARSE$

PARSE$

Gibt ein durch Trennzeichen getrenntes Feld von a zurück

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÃœGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

a$ = PARSE$( string_expr [, {[ANY] string_delimiter | BINARY }] , index& )

Beschreibung

PARSE$ verwendet die folgenden Parameter:

string_expr

Die zu analysierende Zeichenfolge. Wenn string_expr leer ist (eine Nullzeichenfolge) oder keine Trennzeichen enthält, wird davon ausgegangen, dass die Zeichenfolge genau ein Feld enthält. In diesem Fall gibt PARSE$ string_expr zurück.

string_delimiter

Enthält Trennzeichen. Ein Trennzeichen ist ein Zeichen, eine Liste von Zeichen oder eine Zeichenfolge, die verwendet wird, um das Ende eines Felds in string_expr zu markieren. Wenn Sie beispielsweise einen Satz als eine Liste von Wörtern betrachten, ist das Trennzeichen zwischen den Werken ein Leerzeichen (oder möglicherweise ein Satzzeichen). Textdateien bestehen normalerweise aus Zeilen, die durch CR/LF-Zeichen ( $CRLF oder CHR$ (13,10)) getrennt sind; Eine Datenbankdatei kann aus durch Kommas getrennten Elementen bestehen. usw. Ein Trennzeichen wird nicht als Teil eines Feldes betrachtet, sondern als Teiler zwischen Feldern, sodass das Trennzeichen niemals von PARSE$ zurückgegeben wird.

Wenn delim$ nicht angegeben ist oder null (Länge Null) ist, werden durch Kommas getrennte (optional in Anführungszeichen gesetzte) Standardfelder angenommen. Nur in diesem Fall gelten die folgenden Parsing-Regeln. Wenn ein Standardfeld in optionale Anführungszeichen eingeschlossen ist, werden diese entfernt. Wenn zwischen einem Feld in Anführungszeichen und dem nächsten Kommatrennzeichen Zeichen erscheinen, werden diese verworfen. Wenn kein führendes Anführungszeichen gefunden wird, werden alle führenden oder nachfolgenden Leerzeichen entfernt, bevor das Feld zurückgegeben wird.

Bei Trennzeichen muss die GroÃŸ-/Kleinschreibung beachtet werden, daher kann die GroÃŸ-/Kleinschreibung eine Ãœberlegung sein.

Wenn das Schlüsselwort ANY verwendet wird, enthält string_delimiter eine Reihe von Zeichen, von denen jedes als Trennzeichen fungieren kann. Wenn das Schlüsselwort ANY weggelassen wird, fungiert die gesamte Zeichenfolge string_delimiter als einzelnes Trennzeichen.

BINÃ„R

Die Option BINARY geht davon aus, dass string_expr mit der Funktion JOIN$/BINARY oder einer entsprechenden Funktion erstellt wurde, die eine Zeichenfolge als Binärbild oder im gepackten Zeichenfolgenformat von PowerBASIC und/oder Visual Basic erstellt: Wenn eine Zeichenfolge kürzer als 65535 Bytes ist, beginnt sie mit einem 2 Byte langen WORD, gefolgt von den Zeichenfolgendaten. Andernfalls beginnt es mit einem 2-Byte-Wert von 65535, gefolgt von einem DWORD, das die String-Länge angibt, und schlieÃŸlich den String-Daten selbst.

index&

Eine ganzzahlige Variable oder ein ganzzahliger Ausdruck, der die durch Trennzeichen getrennte Feldnummer angibt, die zurückgegeben werden soll. Das erste Feld ist 1 und so weiter bis zur maximalen Anzahl von Feldern, die in string_expr enthalten sind, die mit der PARSECOUNT-Funktion bestimmt werden kann. Wenn index& negativ ist, wird string_expr von rechts nach links analysiert. In diesem Fall gibt index& = -1 das letzte Feld in string_expr zurück, -2 das vorletzte usw. Wenn index& als Null ausgewertet wird oder auÃŸerhalb der tatsächlichen Feldanzahl liegt, wird eine leere Zeichenfolge zurückgegeben.

Siehe auch

  • JOIN$
  • PARSE
  • PARSECOUNT
  • PFADNAME$
  • PATHSCAN$

Kind: Reference topic | Category: String Functions

PBXB64 Status: AVAILABLE

Description

PARSE splits a string into fields using a delimiter string or ANY-delimiter set. It is the control function for field selection, quoted fields, and reverse-index access in the string parser family.

Syntax

field$ = PARSE$(string_expr[, delimiter][, index])

Validation Evidence

Validation evidence: The parser-family tests and the current PARSE$/PARSECOUNT pages prove delimiter handling, ANY parsing, and reverse indexing.

Example

field$ = PARSE$("A,B,C", ",", 2)

See Also

  • cmd_parsecount.html
  • cmd_pathname$.html
  • cmd_scan$.html

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PARSECOUNT “ PBXB64-Compiler-Hilfe

Startseite â€º Funktionen â€º PARSECOUNT

PARSECOUNT

Gibt die Anzahl der durch Trennzeichen getrennten Zeichenfolgen in a zurück

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÃœGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

x& = PARSECOUNT( string_expr [, {[ANY] string_delimiter | BINARY}])

Beschreibung

PARSECOUNT verwendet bei der Bestimmung der Felder innerhalb von string_expr dieselben Regeln wie PARSE$. Einzelne Felder innerhalb von string_expr werden ausgewertet und die Summe der Felder bildet den Ergebniswert.

Es ist wichtig zu beachten, dass PARSECOUNT nur mit Zeichenfolgendaten verwendet werden darf, die Unterfelder variabler Länge enthalten, die jeweils durch ein Trennzeichen getrennt sind. Um die Anzahl der Daten fester Länge zu bestimmen, dividieren Sie die StringExpr-Länge durch die Unterfeldlänge. Wenn diese Funktion mit Daten fester Länge verwendet wird, sind die Ergebnisse undefiniert.

string_expr

Dies ist die Zeichenfolge, die untersucht und analysiert werden soll. Wenn StringExpr leer ist (eine Nullzeichenfolge) oder keine Trennzeichen enthält, wird davon ausgegangen, dass die Zeichenfolge genau ein Unterfeld enthält. In diesem Fall gibt PARSECOUNT den Wert 1 zurück.

string_delimiter

Dies definiert ein oder mehrere Zeichen, die als Trennzeichen verwendet werden sollen. Um gültig zu sein, muss das gesamte Trennzeichen genau übereinstimmen, das Trennzeichen selbst wird jedoch niemals als Teil des Felds zurückgegeben.

Wenn string_delimiter nicht angegeben ist oder eine leere Zeichenfolge enthält, gelten besondere Regeln. Als Trennzeichen wird ein Komma angenommen. Felder können optional in Anführungszeichen gesetzt werden und werden ignoriert, bevor die Ergebniszeichenfolge zurückgegeben wird. Alle Zeichen, die zwischen einem Anführungszeichen und dem nächsten Komma-Trennzeichen stehen, werden verworfen. Wenn kein führendes Anführungszeichen gefunden wird, werden alle führenden oder nachgestellten Anführungszeichen gekürzt, bevor die Ergebniszeichenfolge zurückgegeben wird.

Wenn das Schlüsselwort ANY verwendet wird, enthält string_delimiter eine Reihe von Zeichen, von denen jedes als Trennzeichen fungieren kann. Wenn das Schlüsselwort ANY weggelassen wird, fungiert die gesamte Zeichenfolge string_delimiter als einzelnes Trennzeichen.

BINÃ„R

Die Option BINARY gibt die Anzahl der Unterfelder zurück und geht davon aus, dass StringExpr mit der Funktion JOIN$/BINARY oder einer entsprechenden Funktion erstellt wurde, die eine Zeichenfolge im PowerBASIC- und/oder Visual Basic-Format für gepackte Zeichenfolgen erstellt: Wenn eine Zeichenfolge kürzer als 65535 Bytes ist, beginnt sie mit einem 2 Byte langen WORD, gefolgt von den Zeichenfolgendaten. Andernfalls beginnt es mit einem 2-Byte-Wert von 65535, gefolgt von einem DWORD, das die String-Länge angibt, und dann den tatsächlichen String-Daten.

Siehe auch

  • JOIN$
  • PARSE
  • PARSE$
  • PFADNAME$
  • PATHSCAN$

Kind: Reference topic | Category: String Functions

PBXB64 Status: AVAILABLE

Description

PARSECOUNT counts the fields that PARSE$ can return for the current delimiter rule. Use it before indexing into a parsed string so the caller can validate the field number first.

Syntax

count& = PARSECOUNT(string_expr[, delimiter])

Validation Evidence

Validation evidence: The current string-parser regression coverage verifies field counting and reverse field access alongside PARSE$.

Example

count& = PARSECOUNT("A,B,C", ",")

See Also

  • cmd_parse.html
  • cmd_pathscan$.html
  • cmd_mid.html

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SPEICHERKOPIE “ PBXB64-Compiler-Hilfe

Startseite â€º Funktionen â€º SPEICHERKOPIE

SPEICHERKOPIE

Speicherblöcke kopieren, austauschen oder füllen.

Typ:Anweisung |Kategorie: Memory & Pointers

PBXB64-Status:VERFÃœGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MEMORY COPY Source& , Dest& , Count&
MEMORY SWAP Source& , Dest& , Count&
MEMORY FILL Dest& , Count& , BYTE|WORD|DWORD IntegralExpr
MEMORY FILL Dest& , Count& , StrgExpr

Beschreibung

Mit der MEMORY-Anweisung kann ein Speicherblock mit sehr hoher Effizienz kopiert, ausgetauscht oder gefüllt werden. PowerBASIC berücksichtigt automatisch die Möglichkeit, dass sich Quell- und Zielblöcke überlappen, und vermeidet dadurch Beschädigungen.

In der ersten Form werden Count& Bytes des Speichers an der durch Source& angegebenen Adresse an die durch Dest& angegebene Adresse kopiert. In der zweiten Form werden Count& Bytes des Speichers an der durch Source& angegebenen Adresse mit den Daten an der durch Dest& angegebenen Adresse ausgetauscht.

In der dritten Form werden Count& Bytes des Speichers bei Dest& mit einer oder mehreren Kopien des BYTE-, WORD- oder DWORD-Werts gefüllt, der durch den Wert von IntegralExpr angegeben wird.

In der vierten Form werden Count& Bytes des Speichers bei Dest& mit einer oder mehreren Kopien der Zeichenfolge StrgExpr gefüllt.

Von PBXB64 getesteter Umfang: COPY akzeptiert die PBWin-Kommaschreibweise und die vorhandene Schreibweise MEMORY COPY source TO dest, count und kopiert überlappungssicher. SWAP tauscht Byte-Bloecke ueber die eingebettete Laufzeit aus, behandelt ueberlappende Bereiche mit einem temporaeren Puffer und laesst Null-Laenge oder identische Zeiger unveraendert. FILL unterstuetzt BYTE-, WORD-, DWORD- und Zeichenfolgenmuster. Die fokussierten Validierungstests sind test_memory_copy_fill, test_memory_swap, test_memory_swap_reject_missing und test_memory_swap_reject_extra.

Siehe auch

  • GLOBALMEM
  • PEEK$
  • STICK$
  • STRPTR
  • VARPTR

Kind: Reference topic | Category: Memory & Pointers

PBXB64 Status: AVAILABLE

Description

MEMORY COPY, MEMORY SWAP, and MEMORY FILL operate on raw memory blocks with overlap-safe copy semantics. Use the page when code needs to move, exchange, or initialize pointer-sized storage explicitly.

Syntax

MEMORY COPY source TO dest, count
MEMORY SWAP source, dest, count
MEMORY FILL dest, count, value

Validation Evidence

Validation evidence: The current memory-block regressions prove the copy, swap, and fill paths, including overlap handling and zero-length no-op behavior.

Example

MEMORY COPY src TO dst, 16
MEMORY SWAP a, b, 8

See Also

  • cmd_allocate_reallocate_free.html
  • cmd_globalmem.html
  • cmd_poke.html

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


#LINK “ PBXB64-Compiler-Hilfe

Startseite â€º Funktionen â€º #LINK

#LINK

LINK ein vorkompiliertes

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÃœGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

#LINK "filespec.obj"
#LINK "filespec.o"
#LINK "filespec.res"
#LINK "filespec.pbr"
#LINK "filespec.sll"
#LINK "filespec.pblib"
#LINK "filespec.lib"
#LINK "filespec.a"

Beschreibung

Die #LINK-Metaanweisung fuegt vorkompilierte Objekt-, Ressourcen- oder Archiveingaben zu einem PBXB64-Link hinzu. EXE- und DLL-Hosts verwenden sie fuer den finalen Link. Eine #COMPILE SLL-Quelle darf mit #LINK auch ein anderes PBXB64-natives Archiv einbinden; diese Eingaben werden in den finalen Host uebernommen, der die SLL linkt.

PBXB64 akzeptiert COFF-Objekt- und Ressourceneingaben .obj, .o, .res und .pbr sowie Archive .sll, .pblib, .lib und .a. PBXB64-.sll- und .pblib-Dateien sind deterministische COFF-Archive fuer PBXB64-unterstuetzte Objekte; sie sind keine opaken alten PowerBASIC-SLL-Binaerdateien.

Relative Pfade werden relativ zu der Quelldatei aufgeloest, die die #LINK-Direktive enthaelt. Fehlende Dateien, nicht unterstuetzte Archive, doppelte Symbole und nicht aufgeloeste Host-Symbole werden als Linkerdiagnosen gemeldet.

Fuer einen Static-Library-Ablauf kompilieren Sie zuerst die Blatt-Units mit #COMPILE SLL und danach eine hoeher liegende SLL- oder Host-Quelle mit einer oder mehreren #LINK-Direktiven. Die SLL enthaelt weder das PBXB64-Startup-Objekt noch die eingebettete Laufzeit; diese Teile werden einmal vom finalen Host-Link bereitgestellt, damit mehrere Bibliotheken keinen Laufzeitcode duplizieren.

Der Linker laedt nur unterstuetzte AMD64-COFF-Objekte und deterministische Archiv-Member. Alte SLL-Binaerdateien, Short-Import-Library-Pseudomember, Nicht-AMD64-COFF, BigObj, COMDAT, TLS, Delay-Import, Load-Config und externe CodeView/PDB-Sektionen bleiben ausserhalb der Release-Oberflaeche und schlagen geschlossen fehl.

Wenn mehrere gelinkte Eingaben dasselbe oeffentliche Symbol definieren, wird dies als Linkerfehler behandelt. Wenn ein Host eine Funktion deklariert, die keine gelinkte Eingabe bereitstellt, meldet der finale Link ein nicht aufgeloestes externes Symbol.

Siehe auch

  • #KOMPILE
  • #EXPORT

Kind: Reference topic | Category: Procedures & Scope

PBXB64 Status: AVAILABLE

Description

LINK selects an external module or library dependency for the current compilation unit. Use it when the program needs to bind a referenced symbol or an external object file into the final output.

Syntax

LINK "module"

Validation Evidence

Validation evidence: Linker regression coverage and the current module/import tests prove the active module-binding path.

Example

LINK "mylib.obj"

See Also

  • cmd_libmain_dllmain.html
  • cmd_import.html
  • cmd_export.html

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PBMAIN “ PBXB64-Compiler-Hilfe

Startseite â€º Funktionen â€º PBMAIN

PBMAIN

PBMAIN ist eine benutzerdefinierte Funktion, die von Windows aufgerufen wird, um mit der Ausführung einer ausführbaren Anwendung zu beginnen. Jede ausführbare PowerBASIC-Datei (EXE) muss entweder eine PBMAIN oder eine enthalten

Typ:Funktion |Kategorie: Procedures

PBXB64-Status:VERFÃœGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

FUNCTION PBMAIN [()] [AS LONG]

Beschreibung

Rückgabewert: Der Rückgabewert von PBMAIN hat einen effektiven Bereich von 0 bis 255. Batchdateien können über den Batchbefehl IF [NOT] ERRORLEVEL auf das Ergebnis reagieren.

In jeder PowerBASIC-Anwendung (.EXE) ist entweder eine PBMAIN- oder WINMAIN-Funktion erforderlich. Wenn Sie PBMAIN verwenden, werden keine Parameter übergeben und Sie können das Instanzhandle Ihrer Anwendung oder den Zeiger auf Befehlszeilenparameter nicht direkt abrufen.

Sie können jedoch COMMAND$ verwenden, um die an Ihr Programm übergebene Befehlszeile abzurufen, und die GetModuleHandle-API-Funktion, um das Anwendungsinstanz-Handle abzurufen.

Einschränkungen

Mit PowerBASIC erstellte DLLs sollten eine DLLMAIN-, LIBMAIN- oder PBLIBMAIN-Funktion anstelle von PBMAIN/WINMAIN enthalten.

Siehe auch

  • BEFEHL$
  • DLLMAIN
  • LIBMAIN
  • PBLIBMAIN
  • WINMAIN

Kind: Reference topic | Category: Procedures & Scope

PBXB64 Status: AVAILABLE

Description

PBMAIN is the EXE entry procedure. It starts the program, returns the process exit code, and defines where top-level initialization and cleanup belong in a PBXB64 application.

Syntax

FUNCTION PBMAIN [()] [AS LONG]
    ' statements
END FUNCTION

Validation Evidence

Validation evidence: PBMAIN is backed by the executable entry-point tests and the current WINMAIN/PBMAIN selection rules. Use the page to decide whether the program is an EXE or a DLL and to keep command-line handling on the correct side of the entry point.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    FUNCTION = 0
END FUNCTION

See Also

  • cmd_winmain.html
  • cmd_libmain_dllmain.html
  • cmd_command.html

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


#OPTION “ PBXB64-Compiler-Hilfe

Startseite â€º Funktionen â€º #OPTION

#OPTION

Legen Sie verschiedene Compiler-Optionen fest.

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÃœGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

#OPTION {LARGEMEM32 | VERSION3 | VERSION4 | VERSION5 | WIN95 | ANSIAPI}

Beschreibung

#OPTION LARGEMEM32

Für 32-Bit-Windows-Anwendungen setzt diese Option das Flag â€žLarge Memory Modelâ€œ. Dadurch kann Ihre Anwendung mehr als das ursprüngliche Limit von 2 Gigabyte Arbeitsspeicher nutzen. Abhängig von der verwendeten Windows-Version und dem installierten Speicher kann die genaue Erhöhung von Computer zu Computer unterschiedlich sein. In den meisten Fällen sind Sie wahrscheinlich auf insgesamt etwa 3 Gigabyte beschränkt.

#OPTION VERSION3, VERSION4, VERSION5

Wenn die Metaanweisung #OPTION mit einer der VERSION-Direktiven verwendet wird, steuert sie das Tag â€žMindestversion von Windowsâ€œ, das in Ihren kompilierten Code geschrieben wird. Wenn die von Ihnen ausgewählte Version gleich oder niedriger als die ausgeführte Windows-Version ist, wird die Anwendung ausgeführt. Im Gegenzug passt Windows die an Ihr Programm gesendeten Nachrichten entsprechend dieser Versionsnummer an, sodass Ihr Programm keine Nachrichten von einer späteren Windows-Version verarbeiten muss. Das Versions-Tag kann sich auch auf das Erscheinungsbild und Verhalten allgemeiner Windows-Dialoge auswirken.

Wenn umgekehrt das von Ihnen ausgewählte Versions-Tag höher ist als die ausgeführte Windows-Version, zeigt Windows eine Fehlermeldung an, anstatt Ihre Anwendung auszuführen. Beispielsweise würde die Ausführung einer VERSION5-Anwendung auf einer VERSION4-Plattform fehlschlagen. Es liegt in Ihrer Verantwortung sicherzustellen, dass Ihr Programm nur die Windows-Funktionen verwendet, die in der angegebenen Windows-Version vorhanden sind. Rufen Sie beispielsweise keine API auf, die nur in Windows XP vorhanden ist, wenn Sie möchten, dass Ihr Programm unter Windows 98 ausgeführt wird.

#OPTION VERSION3

Verwenden Sie #OPTION VERSION3, damit die kompilierte Ausgabedatei mindestens Windows 95 oder NT 3.1 erfordert. Dazu gehören Windows 95, 98, ME, Windows NT 3.1-4.0, Windows 2000, XP, Windows 2003, Windows Vista, Windows 7 und höher.

#OPTION VERSION4

Verwenden Sie #OPTION VERSION4 (Standard), damit die kompilierte Ausgabedatei mindestens Windows 95 oder NT4 erfordert. Dazu gehören Windows 95, 98, ME, Windows NT 4.0, Windows 2000, XP, Windows 2003, Windows Vista, Windows 7 und höher.

#OPTION VERSION5

Verwenden Sie #OPTION VERSION5, damit die kompilierte Ausgabedatei mindestens Windows 2000 erfordert. Dazu gehören Windows 2000, XP, Windows 2003, Windows Vista, Windows 7 und höher.

#OPTION WIN95

Windows95, Windows98 und Windows ME bieten keine Unicode-Unterstützung für Windows-API-Funktionen. Normalerweise wäre es dadurch möglich, Ihre kompilierten Programme auf diesen Betriebssystemen auszuführen, da diese Version von PowerBASIC vollständige Unterstützung für Wide Unicode-Text bietet. Wenn Sie jedoch #OPTION WIN95 in Ihrem Quellcode angeben, fügt PowerBASIC ein vollständiges Unicode-Emulationspaket in Ihre ausführbare Datei oder DLL ein, damit sie auf diesen Betriebssystemen ordnungsgemäÃŸ ausgeführt werden können. Diese Option führt dazu, dass Ihr Code etwas gröÃŸer wird, daher sollte sie nur bei Bedarf verwendet werden.

#OPTION ANSIAPI

Diese Version von PowerBASIC bietet vollständige Unterstützung für Wide Unicode-Text. Daraus folgt, dass die interne Laufzeitbibliothek Unicode-Versionen von Funktionen in der Windows-API aufrufen würde. In einigen recht seltenen Fällen kann dies zu einer Inkompatibilität mit dem von Ihnen geschriebenen Code führen, wenn Ihr Code ANSI-Funktionen in der Windows-API aufruft. Wenn Sie #OPTION ANSIAPI in Ihrem Quellcode angeben, ruft PowerBASIC nur ANSI-Versionen dieser Funktionen auf. Durch diese Option wird Ihr Code etwas gröÃŸer und sollte daher nur bei Bedarf verwendet werden.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Kind: Reference topic | Category: Preprocessor

PBXB64 Status: AVAILABLE

Description

#OPTION controls compiler-wide build decisions such as memory model, compatibility version, and ANSI/Unicode API selection. Use the page to choose the exact spelling that matches the target Windows behavior you need.

Syntax

#OPTION LARGEMEM32
#OPTION VERSION3 | VERSION4 | VERSION5
#OPTION WIN95
#OPTION ANSIAPI

Validation Evidence

Validation evidence: The currently generated #OPTION page documents the supported flags and the supported output compatibility contract; keep the page paired with the version-targeting tests and the API-encoding helpers.

Example

#OPTION VERSION5
#OPTION ANSIAPI

See Also

  • cmd_optimize.html
  • cmd_page.html
  • basic_language.html

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PREFIX/END PREFIX-Anweisungen “ PBXB64-Compiler-Hilfe

Startseite â€º Funktionen â€º PREFIX/END PREFIX-Anweisungen

PREFIX/END PREFIX-Anweisungen

Führt eine Reihe von Anweisungen aus, von denen jede vordefinierten Quellcode verwendet.

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÃœGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

PREFIX " source code "
[ additional statements ]
END PREFIX

Beschreibung

PREFIX/END PREFIX-Anweisungen umfassen eine Reihe von Anweisungen, denen jeweils der gleiche angegebene â€žQuellcodeâ€œ vorangestellt ist. Der â€žQuellcodeâ€œ (in Sprachen, die ihn unterstützen) muss normalerweise der Name einer Objektvariablen sein. In PowerBASIC wurde diese Definition jedoch stark erweitert, sodass praktisch jeder Code verwendet werden kann. Dies reduziert wiederholtes Tippen und verringert das Risiko von Tippfehlern. Zum Beispiel:

Präfix/Endpräfix

Kompiliert als:

Präfix â€žMyObjectâ€œ.

Init(xx)

Schlaf(2)

END-PRÃ„FIX

MyObject.Init(xx)

MyObject.Sleep(2)

PRÃ„FIX â€žMyStruc.â€œ

Höhe = 220

Breite = 345

Farbe = %Blau

END-PRÃ„FIX

MyStruc.Height = 220

MyStruc.Width = 345

MyStruc.Color = %Blue

Präfix â€žASMâ€œ

Mov Eax, Ebx

Mov Ecx, &H14

IMul Eax, Esi

END-PRÃ„FIX

ASM Mov Eax, Ebx

ASM Mov Ecx, &H14

ASM IMul Eax, Esi

Wenn sich das Präfix â€žQuellcodeâ€œ auf eine Objektvariable oder eine UDT-Strukturvariable bezieht, stellen Sie sicher, dass es mit einem Punkt (.) endet, um auf Mitglieder dieses Elements zu verweisen. Stellen Sie andernfalls sicher, dass es ganze Wörter enthält. Genau wie bei Makros und Zeilenfortsetzungen können Sie nicht ein halbes Wort in eine Zeile und ein halbes Wort in eine andere schreiben. Der folgende Code ist beispielsweise illegal und erzeugt eine Ausnahme:

Präfix â€žPRIâ€œ

NT #1, â€žHallo Weltâ€œ

END-PRÃ„FIX

PREFIX/END PREFIX-Strukturen dürfen nicht verschachtelt werden.

Siehe auch

  • ASM AUSRICHTEN

Kind: Reference topic | Category: Preprocessor

PBXB64 Status: AVAILABLE

Description

PREFIX / END PREFIX temporarily adds a prefix to the selected command family. Use it only when the page or module is deliberately grouping related commands under a shared spelling rule.

Syntax

PREFIX name
    ' statements
END PREFIX

Validation Evidence

Validation evidence: The preprocessor tests cover the current prefix-visibility and naming rules.

Example

PREFIX TEST
    ' grouped statements
END PREFIX

See Also

  • cmd_option.html
  • cmd_mcase.html
  • cmd_alias.html

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


OBJRESULT$ “ PBXB64-Compiler-Hilfe

Startseite â€º Funktionen â€º OBJRESULT$

OBJRESULT$

Gibt eine Zeichenfolge zurück, die eine beschreibt

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:VERFÃœGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

text$ = OBJRESULT$([ nexp& ])

Beschreibung

Diese Funktion gibt eine Textzeichenfolge zurück, die den durch nexp& angegebenen hResult-Code beschreibt. Wenn der Parameter nexp& weggelassen wird, wird er durch den aktuellsten OBJRESULT-Wert ersetzt. Das heiÃŸt, OBJRESULT$() ist identisch mit OBJRESULT$(OBJRESULT).

PBXB64 gibt deterministischen englischen HRESULT-Text für häufige Werte und einen hexadezimalen Ersatztext für unbekannte Werte zurück. Zum Beispiel liefert OBJRESULT$(2147942487) den Text E_INVALIDARG (0x80070057); ein nicht zugeordneter Wert liefert Text der Form HRESULT 0x????????.

Siehe auch

  • DIM
  • CLASS
  • CLSID$
  • IDISPINFO
  • GUID$
  • GUIDTXT$
  • INTERFACE (Direct)
  • INTERFACE (IDBind)
  • ISINTERFACE
  • ISNOTHING
  • ISOBJECT
  • LET (with Objects)
  • METHOD
  • PROPERTY
  • OBJECT
  • OBJACTIVE
  • OBJPTR
  • OBJRESULT
  • PROGID$
  • Was ist ein hResult?
  • Was ist überhaupt ein Objekt?

Kind: Reference topic | Category: COM & Objects

PBXB64 Status: AVAILABLE

Description

OBJRESULT$ converts the current or supplied HRESULT into a deterministic text string. Use it when you need a readable diagnostic instead of a raw numeric code.

Syntax

text$ = OBJRESULT$([ nexp& ])

Validation Evidence

Validation evidence: The registered OBJRESULT/OBJRESULT$ regression proves the initial S_OK result, the current-result path, and the deterministic text mapping for common HRESULTs.

Example

text$ = OBJRESULT$
text2$ = OBJRESULT$(&H80070057)

See Also

  • cmd_objresult.html
  • cmd_what_is_an_hresult.html
  • cmd_progid.html

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


WEB-Erweiterungen “ PBXB64-Compiler-Hilfe

Startseite â€º WEB-Erweiterungen

WEB-Erweiterungen

Netzwerkfähige String-, Codierungs-, Hashing-, JSON- und HTTP-Helfer.

Typ: Funktionsbibliothek | Kategorie: Web & Netzwerk

PBXB64-Status: VERFÃœGBAR (V10+)

Ãœberblick

Die WEB-Enhancements-Bibliothek bietet 30 integrierte Funktionen für allgemeine Web- und Datenverarbeitungsaufgaben. Alle Funktionen sind direkt in der PB-Quelle ohne externe DLL-Abhängigkeiten verfügbar.

Stufe 1 “ Kodierung (9 Funktionen)

Function | Rückgaben | Beschreibung
BASE64$(s$) | Zeichenfolge | Base64-kodieren Sie eine Zeichenfolge.
BASE64URLSAFE$(s$) | Zeichenfolge | Base64-Kodierung mit URL-sicherem Alphabet (Nr +/ Polsterung).
UNBASE64$(s$) | Zeichenfolge | Dekodieren Sie eine Base64-Zeichenfolge.
HEX$(s$) | Zeichenfolge | Rohbytes hexadezimal kodieren.
UNHEX$(s$) | Zeichenfolge | Dekodieren Sie eine Hex-Zeichenfolge.
URLENCODE$(s$) | Zeichenfolge | Eine URL-Komponente prozentual kodieren.
URLDECODE$(s$) | Zeichenfolge | Prozentuale Dekodierung einer URL-Komponente.
ESCAPE$(s$) | Zeichenfolge | JSON-Escape eine Zeichenfolge (\" \\ \n \r \t).
UNESCAPE$(s$) | Zeichenfolge | Entfernen Sie JSON-Escape-Sequenzen.

Stufe 2 “ Hashing (6 Funktionen)

Function | Rückgaben | Beschreibung
MD5$(s$) | Zeichenfolge | MD5-Digest als 32-stelliger Hexadezimal-Kleinbuchstabe.
SHA1$(s$) | Zeichenfolge | SHA-1-Digest als 40-stelliger Hexadezimal-Kleinbuchstabe.
SHA256$(s$) | Zeichenfolge | SHA-256-Digest als 64-stelliger Hexadezimal-Kleinbuchstabe.
SHA512$(s$) | Zeichenfolge | SHA-512-Digest als 128-stelliger Hexadezimal-Kleinbuchstabe.
HMACSHA256$(key$, data$) | Zeichenfolge | HMAC-SHA256 als 64-stelliges Kleinbuchstaben-Hexadezimalbuch.
HMACSHA512$(key$, data$) | Zeichenfolge | HMAC-SHA512 als 128-stelliges Kleinbuchstaben-Hex.

Stufe 3 “ URL-Parsing (5 Funktionen)

Function | Rückgaben | Beschreibung
URLHOST$(url$) | Zeichenfolge | Host aus einer URL extrahieren.
URLPATH$(url$) | Zeichenfolge | Pfad aus einer URL extrahieren.
URLQUERY$(url$) | Zeichenfolge | Abfragezeichenfolge aus einer URL extrahieren.
URLPORT(url$) | Lange | Portnummer aus einer URL extrahieren.
HEADERBUILD$(key$, value$) | Zeichenfolge | Erstellen Sie eine HTTP-Headerzeile.

Tier 4+5 “ JSON (11 Funktionen)

Function | Rückgaben | Beschreibung
JSONNEW(type) | Lange | Erstellen Sie ein JSON-Handle. type = 5 für Objekt, 6 für Array.
JSONFREE(h) | Lange | Geben Sie ein JSON-Handle frei.
JSONTYPE$(h) | Zeichenfolge | Name des Rückgabetyps (null, bool, int, float, string, array, object).
JSONPARSE(txt$) | Lange | Analysieren Sie eine JSON-Zeichenfolge in ein Handle.
JSONSETINT(h, path$, v) | Lange | Ganzzahlwert festlegen auf path.
JSONSETSTRING(h, path$, v$) | Lange | Setzen Sie den String-Wert auf path.
JSONGETSTR(h, path$) | Zeichenfolge | Holen Sie sich den String-Wert bei path.
JSONGETINT(h, path$) | Lange | Holen Sie sich einen ganzzahligen Wert bei path.
JSONGETFLOAT(h, path$) | Doppelt | Erhalten Sie den Float-Wert bei path.
JSONGETBOOL(h, path$) | Lange | Holen Sie sich einen booleschen Wert bei path (0/1).
JSONREMOVE(h, path$) | Lange | Schlüssel abziehen path.
JSONSTRINGIFY$(h, pretty) | Zeichenfolge | JSON-Handle in String serialisieren.

Tier 6 “ HTTP-Client (3 Funktionen)

Function | Rückgaben | Beschreibung
HTTPOPEN(url$, timeout_ms) | Lange | Ã–ffnen Sie ein HTTP-Handle.
HTTPREQUEST(h, method$, path$, headers$, body$) | Zeichenfolge | Senden Sie eine HTTP-Anfrage und geben Sie den Antworttext zurück.
HTTPCLOSE(h) | Lange | SchlieÃŸen Sie ein HTTP-Handle.

Tier 7 “ Multipart Form-Data Builder (6 Funktionen)

Function | Rückgaben | Beschreibung
MULTIPARTNEW() | Lange | Erstellen Sie ein neues mehrteiliges Builder-Handle.
MULTIPARTFREE(h) | Lange | Geben Sie einen mehrteiligen Builder und alle seine Teile frei.
MULTIPARTADDFIELD(h, name$, value$) | Lange | Fügen Sie ein Textformularfeld hinzu (0 = Erfolg, -1 = Fehler).
MULTIPARTADDFILE(h, name$, filename$, filepath$) | Lange | Fügen Sie einen Datei-Upload-Teil von der Festplatte hinzu.
MULTIPARTBODY$(h) | Zeichenfolge | Serialisieren Sie alle Teile in multipart/form-data Körper.
MULTIPARTHEADER$(h) | Zeichenfolge | Geben Sie die zurück Content-Type Kopfzeile mit Begrenzung.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
  LOCAL enc$, dec$, h, status, val

  ' Base64
  enc$ = BASE64$("Hello, World!")
  IF enc$ <> "SGVsbG8sIFdvcmxkIQ==" THEN FUNCTION = 1

  ' URL encode
  enc$ = URLENCODE$("a b=c")
  IF enc$ <> "a%20b%3Dc" THEN FUNCTION = 2

  ' JSON
  h = JSONNEW(5)
  status = JSONSETINT(h, "a", 42)
  status = JSONSETSTRING(h, "b", "hello")
  val = JSONGETINT(h, "a")
  IF val <> 42 THEN FUNCTION = 3
  enc$ = JSONSTRINGIFY$(h, 0)
  JSONFREE(h)

  FUNCTION = 0
END FUNCTION

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

WEB-Erweiterungen gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

WEB-Erweiterungen gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer encoding-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

WEB-Erweiterungen

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


HTTPOPEN - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › HTTP › HTTPOPEN
Hilfe zum PBXB64-Compiler

HTTPOPEN

Open an HTTP client handle.

Kind: Function | Category: Web & Network > HTTP Client

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

handle = HTTPOPEN(url$, timeout_ms)

Returns

Long integer handle, or 0 on failure.

Description

Initialises an HTTP request context for the given base URL and timeout. The returned handle is used with HTTPREQUEST and must be closed with HTTPCLOSE. Returns 0 if the URL cannot be opened or connection setup fails.

Parameters

Name | Type | Description
url$ | String | Base URL.
timeout_ms | Long | Timeout in milliseconds.

Error Handling

HTTP functions return 0 or an empty string when a handle, connection, timeout, or request fails. Always close a nonzero handle with HTTPCLOSE, including after failed requests.

Verifiziertes Beispiel

HTTP handle behavior is covered by examples/basic/test_web_http_invalid.pb and examples/basic/test_web_http_local.pb; live network tests require a reachable local or remote endpoint.

Example

LOCAL h AS LONG
h = HTTPOPEN("https://api.example.com", 5000)
IF h <> 0 THEN
  PRINT "HTTP handle opened"
  HTTPCLOSE h
END IF

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

HTTPOPEN gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

HTTPOPEN gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer HTTP client-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit HTTPCLOSE frei.

Eingaberegeln

Pruefen Sie den HTTP handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

HTTPOPEN

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


HTTPREQUEST - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › HTTP › HTTPREQUEST
Hilfe zum PBXB64-Compiler

HTTPREQUEST

Send an HTTP request and return the response.

Kind: Function | Category: Web & Network > HTTP Client

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

response$ = HTTPREQUEST(handle, method$, path$, headers$, body$)

Returns

String containing the server response, or empty on error.

Description

Sends an HTTP request using the handle returned by HTTPOPEN. method$ is typically "GET", "POST", "PUT", or "DELETE". The response string contains the response body on success and is empty on request failure.

Parameters

Name | Type | Description
handle | Long | HTTP handle from HTTPOPEN.
method$ | String | HTTP method.
path$ | String | Request path (may include query string).
headers$ | String | Header block, e.g. from HEADERBUILD$.
body$ | String | Request body, or empty string.

Error Handling

HTTP functions return 0 or an empty string when a handle, connection, timeout, or request fails. Always close a nonzero handle with HTTPCLOSE, including after failed requests.

Verifiziertes Beispiel

HTTP handle behavior is covered by examples/basic/test_web_http_invalid.pb and examples/basic/test_web_http_local.pb; live network tests require a reachable local or remote endpoint.

Example

LOCAL h AS LONG
LOCAL resp$, hdrs$
h = HTTPOPEN("https://api.example.com", 5000)
hdrs$ = HEADERBUILD$("Content-Type", "application/json")
resp$ = HTTPREQUEST(h, "GET", "/status", hdrs$, "")
PRINT resp$
HTTPCLOSE h

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

HTTPREQUEST gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

HTTPREQUEST gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer HTTP client-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit HTTPCLOSE frei.

Eingaberegeln

Pruefen Sie den HTTP handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

HTTPREQUEST

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


HTTPCLOSE - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › HTTP › HTTPCLOSE
Hilfe zum PBXB64-Compiler

HTTPCLOSE

Close an HTTP client handle.

Kind: Function | Category: Web & Network > HTTP Client

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

status = HTTPCLOSE(handle)

Returns

Long integer status (non-zero on success).

Description

Releases the resources associated with an HTTP handle opened by HTTPOPEN.

Parameters

Name | Type | Description
handle | Long | HTTP handle.

Error Handling

HTTP functions return 0 or an empty string when a handle, connection, timeout, or request fails. Always close a nonzero handle with HTTPCLOSE, including after failed requests.

Verifiziertes Beispiel

HTTP handle behavior is covered by examples/basic/test_web_http_invalid.pb and examples/basic/test_web_http_local.pb; live network tests require a reachable local or remote endpoint.

Example

LOCAL h AS LONG
h = HTTPOPEN("https://example.com", 3000)
IF h <> 0 THEN
  HTTPCLOSE h
  PRINT "closed"
END IF

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

HTTPCLOSE gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

HTTPCLOSE gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer HTTP client-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit HTTPCLOSE frei.

Eingaberegeln

Pruefen Sie den HTTP handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

HTTPCLOSE

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


HEADERBUILD$ - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › HTTP › HEADERBUILD$
Hilfe zum PBXB64-Compiler

HEADERBUILD$

Build a single HTTP header line.

Kind: Function | Category: Web & Network > URL Parsing

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = HEADERBUILD$(key$, value$)

Returns

String in the form Key: Value .

Description

Concatenates a header key and value with a colon separator and CRLF terminator. Useful for assembling headers before calling HTTPREQUEST.

Parameters

Name | Type | Description
key$ | String | Header name.
value$ | String | Header value.

Error Handling

URL helper functions return an empty string or 0 when the requested component is absent. They do not validate that a remote host exists.

Verifiziertes Beispiel

The URL helper family is exercised by examples/basic/test_web_all.pb with host, path, query, port, and header-building checks.

Example

LOCAL hdr$
hdr$ = HEADERBUILD$("Content-Type", "application/json")
PRINT hdr$  ' Content-Type: application/json

Expected output

Output: Content-Type: application/json (with trailing CRLF)

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

HEADERBUILD$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

HEADERBUILD$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer URL/header-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

HEADERBUILD$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONNEW - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › JSON › JSONNEW
Hilfe zum PBXB64-Compiler

JSONNEW

Create a new JSON value handle.

Kind: Function | Category: Web & Network > JSON

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

handle = JSONNEW(type)

Returns

Long integer handle to the newly created JSON value.

Description

Allocates a JSON value. Pass 5 to create an empty object or 6 to create an empty array. The handle must later be released with JSONFREE.

Parameters

Name | Type | Description
type | Long | 5 = object, 6 = array.

Error Handling

JSON functions return 0, an empty string, or -1 status values for bad handles, parse failures, missing paths, or type mismatches. Always free handles returned by JSONNEW or JSONPARSE with JSONFREE.

Verifiziertes Beispiel

The JSON family is exercised by examples/basic/test_web_hash_json.pb, examples/basic/test_web_all.pb, and focused JSON set/get examples.

Example

LOCAL hObj, hArr AS LONG
hObj = JSONNEW(5)  ' object
hArr = JSONNEW(6)  ' array
JSONFREE hObj
JSONFREE hArr

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONNEW gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONNEW gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONNEW

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONPARSE - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › JSON › JSONPARSE
Hilfe zum PBXB64-Compiler

JSONPARSE

Parse a JSON text string into a handle.

Kind: Function | Category: Web & Network > JSON

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

handle = JSONPARSE(jsonText$)

Returns

Long integer handle to the parsed JSON value, or 0 on parse failure.

Description

Parses a JSON document supplied as a string and returns a handle. The returned handle must be freed with JSONFREE.

Parameters

Name | Type | Description
jsonText$ | String | Valid JSON text.

Error Handling

JSON functions return 0, an empty string, or -1 status values for bad handles, parse failures, missing paths, or type mismatches. Always free handles returned by JSONNEW or JSONPARSE with JSONFREE.

Verifiziertes Beispiel

The JSON family is exercised by examples/basic/test_web_hash_json.pb, examples/basic/test_web_all.pb, and focused JSON set/get examples.

Example

LOCAL h AS LONG
LOCAL txt$
LOCAL q AS STRING
q = CHR$(34)   ' double-quote character
txt$ = "{" + q + "name" + q + ":" + q + "PBXB64" + q + "," + q + "version" + q + ":10}"
h = JSONPARSE(txt$)
IF h = 0 THEN FUNCTION = 1
IF JSONGETSTR(h, "name") <> "PBXB64" THEN FUNCTION = 2
JSONFREE h

Expected output

Output: PBXB64

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONPARSE gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONPARSE gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONPARSE

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONSTRINGIFY$ - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › JSON › JSONSTRINGIFY$
Hilfe zum PBXB64-Compiler

JSONSTRINGIFY$

Serialize a JSON handle to a string.

Kind: Function | Category: Web & Network > JSON

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

text$ = JSONSTRINGIFY$(handle, pretty)

Returns

String containing the JSON text.

Description

Converts a JSON handle back to text. Pass 0 for compact output or a non-zero value for pretty-printed output with indentation and line breaks.

Parameters

Name | Type | Description
handle | Long | JSON handle.
pretty | Long | 0 = compact, non-zero = pretty-printed.

Error Handling

JSON functions return 0, an empty string, or -1 status values for bad handles, parse failures, missing paths, or type mismatches. Always free handles returned by JSONNEW or JSONPARSE with JSONFREE.

Verifiziertes Beispiel

The JSON family is exercised by examples/basic/test_web_hash_json.pb, examples/basic/test_web_all.pb, and focused JSON set/get examples.

Example

LOCAL h AS LONG
LOCAL txt$
h = JSONNEW(5)
JSONSETSTRING h, "name", "PBXB64"
JSONSETINT h, "version", 10
txt$ = JSONSTRINGIFY$(h, 0)
PRINT txt$  ' {"name":"PBXB64","version":10}
JSONFREE h

Expected output

Output: {"name":"PBXB64","version":10}

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONSTRINGIFY$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONSTRINGIFY$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONSTRINGIFY$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONTYPE$ - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › JSON › JSONTYPE$
Hilfe zum PBXB64-Compiler

JSONTYPE$

Return the type name of a JSON value.

Kind: Function | Category: Web & Network > JSON

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

type$ = JSONTYPE$(handle)

Returns

String containing one of: null, bool, int, float, string, array, object.

Description

Inspects the JSON value referenced by handle and returns its type as a lowercase string.

Parameters

Name | Type | Description
handle | Long | JSON handle.

Error Handling

JSON functions return 0, an empty string, or -1 status values for bad handles, parse failures, missing paths, or type mismatches. Always free handles returned by JSONNEW or JSONPARSE with JSONFREE.

Verifiziertes Beispiel

The JSON family is exercised by examples/basic/test_web_hash_json.pb, examples/basic/test_web_all.pb, and focused JSON set/get examples.

Example

LOCAL h AS LONG
h = JSONNEW(5)
PRINT JSONTYPE$(h)  ' object
JSONFREE h

Expected output

Output: object

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONTYPE$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONTYPE$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONTYPE$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONGETBOOL - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › JSON › JSONGETBOOL
Hilfe zum PBXB64-Compiler

JSONGETBOOL

Read a boolean value from a JSON object or array.

Kind: Function | Category: Web & Network > JSON

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

value = JSONGETBOOL(handle, path$)

Returns

Long integer 1 for true, 0 for false or missing/non-boolean.

Description

Retrieves the boolean value at path$. JSON true returns 1 and false returns 0.

Parameters

Name | Type | Description
handle | Long | JSON handle.
path$ | String | Key name or array index.

Error Handling

JSON functions return 0, an empty string, or -1 status values for bad handles, parse failures, missing paths, or type mismatches. Always free handles returned by JSONNEW or JSONPARSE with JSONFREE.

Verifiziertes Beispiel

The JSON family is exercised by examples/basic/test_web_hash_json.pb, examples/basic/test_web_all.pb, and focused JSON set/get examples.

Example

LOCAL h AS LONG
LOCAL txt$, ok AS LONG, q AS STRING
q = CHR$(34)
txt$ = "{" + q + "active" + q + ":true," + q + "deleted" + q + ":false}"
h = JSONPARSE(txt$)
IF h = 0 THEN FUNCTION = 1
ok = JSONGETBOOL(h, "active")
IF ok <> 1 THEN FUNCTION = 2    ' true returns 1
ok = JSONGETBOOL(h, "deleted")
IF ok <> 0 THEN FUNCTION = 3    ' false returns 0
JSONFREE h

Expected output

Output: 1 then 0

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONGETBOOL gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONGETBOOL gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONGETBOOL

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONGETFLOAT - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › JSON › JSONGETFLOAT
Hilfe zum PBXB64-Compiler

JSONGETFLOAT

Read a floating-point value from a JSON object or array.

Kind: Function | Category: Web & Network > JSON

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

value## = JSONGETFLOAT(handle, path$)

Returns

Double-precision floating-point value, or 0.0 if the path is missing or not a number.

Description

Retrieves the numeric value at path$ as a DOUBLE. Integer values are returned as floating-point.

Parameters

Name | Type | Description
handle | Long | JSON handle.
path$ | String | Key name or array index.

Error Handling

JSON functions return 0, an empty string, or -1 status values for bad handles, parse failures, missing paths, or type mismatches. Always free handles returned by JSONNEW or JSONPARSE with JSONFREE.

Verifiziertes Beispiel

The JSON family is exercised by examples/basic/test_web_hash_json.pb, examples/basic/test_web_all.pb, and focused JSON set/get examples.

Example

LOCAL h AS LONG
LOCAL txt$, q AS STRING
LOCAL pi AS DOUBLE
q = CHR$(34)
txt$ = "{" + q + "pi" + q + ":3.14159}"
h = JSONPARSE(txt$)
IF h = 0 THEN FUNCTION = 1
pi = JSONGETFLOAT(h, "pi")
IF pi < 3.14 OR pi > 3.15 THEN FUNCTION = 2
JSONFREE h

Expected output

Output: 3.14159

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONGETFLOAT gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONGETFLOAT gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONGETFLOAT

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONGETINT - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › JSON › JSONGETINT
Hilfe zum PBXB64-Compiler

JSONGETINT

Read an integer value from a JSON object or array.

Kind: Function | Category: Web & Network > JSON

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

value = JSONGETINT(handle, path$)

Returns

Long integer value, or 0 if the path is missing or not a number.

Description

Retrieves the integer stored at path$. Floating-point values are truncated to integer.

Parameters

Name | Type | Description
handle | Long | JSON handle.
path$ | String | Key name or array index.

Error Handling

JSON functions return 0, an empty string, or -1 status values for bad handles, parse failures, missing paths, or type mismatches. Always free handles returned by JSONNEW or JSONPARSE with JSONFREE.

Verifiziertes Beispiel

The JSON family is exercised by examples/basic/test_web_hash_json.pb, examples/basic/test_web_all.pb, and focused JSON set/get examples.

Example

LOCAL h AS LONG
LOCAL txt$, v AS LONG, q AS STRING
q = CHR$(34)
txt$ = "{" + q + "x" + q + ":42," + q + "y" + q + ":3.14}"
h = JSONPARSE(txt$)
IF h = 0 THEN FUNCTION = 1
v = JSONGETINT(h, "x")
IF v <> 42 THEN FUNCTION = 2
v = JSONGETINT(h, "y")
IF v <> 3 THEN FUNCTION = 3   ' 3.14 truncated to 3
JSONFREE h

Expected output

Output: 42 then 3

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONGETINT gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONGETINT gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONGETINT

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONGETSTR - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › JSON › JSONGETSTR
Hilfe zum PBXB64-Compiler

JSONGETSTR

Read a string value from a JSON object or array.

Kind: Function | Category: Web & Network > JSON

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

value$ = JSONGETSTR(handle, path$)

Returns

String value, or empty if the path is missing or not a string.

Description

Retrieves the string stored at path$. JSON escape sequences are decoded into literal characters.

Parameters

Name | Type | Description
handle | Long | JSON handle.
path$ | String | Key name or array index.

Error Handling

JSON functions return 0, an empty string, or -1 status values for bad handles, parse failures, missing paths, or type mismatches. Always free handles returned by JSONNEW or JSONPARSE with JSONFREE.

Verifiziertes Beispiel

The JSON family is exercised by examples/basic/test_web_hash_json.pb, examples/basic/test_web_all.pb, and focused JSON set/get examples.

Example

LOCAL h AS LONG
LOCAL txt$, name$, q AS STRING
q = CHR$(34)
txt$ = "{" + q + "name" + q + ":" + q + "PBXB64" + q + "}"
h = JSONPARSE(txt$)
IF h = 0 THEN FUNCTION = 1
name$ = JSONGETSTR(h, "name")
IF name$ <> "PBXB64" THEN FUNCTION = 2
JSONFREE h

Expected output

Output: PBXB64

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONGETSTR gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONGETSTR gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONGETSTR

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONSETBOOL - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › JSON › JSONSETBOOL
Hilfe zum PBXB64-Compiler

JSONSETBOOL

Set a boolean value in a JSON object or array.

Kind: Function | Category: Web & Network > JSON

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

status = JSONSETBOOL(handle, path$, value)

Returns

Long integer: 0 on success, -1 on failure (bad handle or path).

Description

Stores a boolean at the specified path. value is treated as true if nonzero, false if zero. For objects, path$ is a key name; for arrays, a numeric index such as "0".

Parameters

Name | Type | Description
handle | Long | JSON object or array handle.
path$ | String | Key name or array index.
value | Long | 0 = false, nonzero = true.

Error Handling

JSON functions return 0, an empty string, or -1 status values for bad handles, parse failures, missing paths, or type mismatches. Always free handles returned by JSONNEW or JSONPARSE with JSONFREE.

Verifiziertes Beispiel

The JSON family is exercised by examples/basic/test_web_hash_json.pb, examples/basic/test_web_all.pb, and focused JSON set/get examples.

Example

LOCAL h AS LONG
LOCAL st AS LONG
h = JSONNEW(5)
st = JSONSETBOOL(h, "active", 1)
IF st <> 0 THEN FUNCTION = 1
IF JSONGETBOOL(h, "active") <> 1 THEN FUNCTION = 2   ' true is returned as 1
JSONFREE h

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONSETBOOL gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONSETBOOL gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONSETBOOL

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONSETFLOAT - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › JSON › JSONSETFLOAT
Hilfe zum PBXB64-Compiler

JSONSETFLOAT

Set a floating-point value in a JSON object or array.

Kind: Function | Category: Web & Network > JSON

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

status = JSONSETFLOAT(handle, path$, value#)

Returns

Long integer: 0 on success, -1 on failure (bad handle or path).

Description

Stores a double-precision floating-point value at the specified path. For objects, path$ is a key name; for arrays, a numeric index such as "0".

Parameters

Name | Type | Description
handle | Long | JSON object or array handle.
path$ | String | Key name or array index.
value# | Double | Floating-point value to store.

Error Handling

JSON functions return 0, an empty string, or -1 status values for bad handles, parse failures, missing paths, or type mismatches. Always free handles returned by JSONNEW or JSONPARSE with JSONFREE.

Verifiziertes Beispiel

The JSON family is exercised by examples/basic/test_web_hash_json.pb, examples/basic/test_web_all.pb, and focused JSON set/get examples.

Example

LOCAL h AS LONG
LOCAL pf AS DOUBLE
h = JSONNEW(5)
IF JSONSETFLOAT(h, "pi", 3.14159) <> 0 THEN FUNCTION = 1
pf = JSONGETFLOAT(h, "pi")
IF pf < 3.14 OR pf > 3.15 THEN FUNCTION = 2
JSONFREE h

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONSETFLOAT gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONSETFLOAT gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONSETFLOAT

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONSETINT - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › JSON › JSONSETINT
Hilfe zum PBXB64-Compiler

JSONSETINT

Set an integer value in a JSON object or array.

Kind: Function | Category: Web & Network > JSON

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

status = JSONSETINT(handle, path$, value)

Returns

Long integer: 0 on success, -1 on failure (bad handle or path).

Description

Stores an integer at the specified path. For objects, path$ is a key name. For arrays, path$ is a numeric index such as "0".

Parameters

Name | Type | Description
handle | Long | JSON object or array handle.
path$ | String | Key name or array index.
value | Long/Quad | Integer to store.

Error Handling

JSON functions return 0, an empty string, or -1 status values for bad handles, parse failures, missing paths, or type mismatches. Always free handles returned by JSONNEW or JSONPARSE with JSONFREE.

Verifiziertes Beispiel

The JSON family is exercised by examples/basic/test_web_hash_json.pb, examples/basic/test_web_all.pb, and focused JSON set/get examples.

Example

LOCAL h AS LONG
h = JSONNEW(5)
JSONSETINT h, "answer", 42
JSONSETINT h, "count", 7
PRINT JSONSTRINGIFY$(h, 0)  ' {"answer":42,"count":7}
JSONFREE h

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONSETINT gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONSETINT gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONSETINT

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONSETNULL - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › JSON › JSONSETNULL
Hilfe zum PBXB64-Compiler

JSONSETNULL

Set a JSON null in a JSON object or array.

Kind: Function | Category: Web & Network > JSON

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

status = JSONSETNULL(handle, path$)

Returns

Long integer: 0 on success, -1 on failure (bad handle or path).

Description

Stores a JSON null at the specified path. For objects, path$ is a key name; for arrays, a numeric index such as "0".

Parameters

Name | Type | Description
handle | Long | JSON object or array handle.
path$ | String | Key name or array index to set to null.

Error Handling

JSON functions return 0, an empty string, or -1 status values for bad handles, parse failures, missing paths, or type mismatches. Always free handles returned by JSONNEW or JSONPARSE with JSONFREE.

Verifiziertes Beispiel

The JSON family is exercised by examples/basic/test_web_hash_json.pb, examples/basic/test_web_all.pb, and focused JSON set/get examples.

Example

LOCAL h AS LONG
LOCAL s$
h = JSONNEW(5)
IF JSONSETNULL(h, "deleted") <> 0 THEN FUNCTION = 1
s$ = JSONSTRINGIFY$(h, 0)
IF INSTR(s$, "null") = 0 THEN FUNCTION = 2
JSONFREE h

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONSETNULL gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONSETNULL gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONSETNULL

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONSETSTRING - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › JSON › JSONSETSTRING
Hilfe zum PBXB64-Compiler

JSONSETSTRING

Set a string value in a JSON object or array.

Kind: Function | Category: Web & Network > JSON

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

status = JSONSETSTRING(handle, path$, value$)

Returns

Long integer: 0 on success, -1 on failure (bad handle or path).

Description

Stores a string at the specified path. The string is automatically JSON-escaped when the value is serialized.

Parameters

Name | Type | Description
handle | Long | JSON object or array handle.
path$ | String | Key name or array index.
value$ | String | String to store.

Error Handling

JSON functions return 0, an empty string, or -1 status values for bad handles, parse failures, missing paths, or type mismatches. Always free handles returned by JSONNEW or JSONPARSE with JSONFREE.

Verifiziertes Beispiel

The JSON family is exercised by examples/basic/test_web_hash_json.pb, examples/basic/test_web_all.pb, and focused JSON set/get examples.

Example

LOCAL h AS LONG
h = JSONNEW(5)
JSONSETSTRING h, "name", "PBXB64"
JSONSETSTRING h, "line", "Hello World"
PRINT JSONSTRINGIFY$(h, 0)   ' contains name and line keys
JSONFREE h

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONSETSTRING gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONSETSTRING gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONSETSTRING

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONREMOVE - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › JSON › JSONREMOVE
Hilfe zum PBXB64-Compiler

JSONREMOVE

Remove a key from a JSON object or an element from a JSON array.

Kind: Function | Category: Web & Network > JSON

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

status = JSONREMOVE(handle, path$)

Returns

Long integer: 0 on success, -1 on failure (bad handle or path).

Description

Deletes the member at path$. For objects this removes the named key; for arrays it removes the element at the given index.

Parameters

Name | Type | Description
handle | Long | JSON object or array handle.
path$ | String | Key name or array index.

Error Handling

JSON functions return 0, an empty string, or -1 status values for bad handles, parse failures, missing paths, or type mismatches. Always free handles returned by JSONNEW or JSONPARSE with JSONFREE.

Verifiziertes Beispiel

The JSON family is exercised by examples/basic/test_web_hash_json.pb, examples/basic/test_web_all.pb, and focused JSON set/get examples.

Example

LOCAL h AS LONG
h = JSONNEW(5)
JSONSETINT h, "a", 1
JSONSETINT h, "b", 2
JSONREMOVE h, "a"
PRINT JSONSTRINGIFY$(h, 0)  ' {"b":2}
JSONFREE h

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONREMOVE gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONREMOVE gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONREMOVE

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONFREE - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › JSON › JSONFREE
Hilfe zum PBXB64-Compiler

JSONFREE

Release a JSON handle.

Kind: Function | Category: Web & Network > JSON

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

status = JSONFREE(handle)

Returns

Long integer status (non-zero on success).

Description

Frees the memory associated with a JSON handle created by JSONNEW or JSONPARSE. After freeing, the handle must not be used again.

Parameters

Name | Type | Description
handle | Long | JSON handle to free.

Error Handling

JSON functions return 0, an empty string, or -1 status values for bad handles, parse failures, missing paths, or type mismatches. Always free handles returned by JSONNEW or JSONPARSE with JSONFREE.

Verifiziertes Beispiel

The JSON family is exercised by examples/basic/test_web_hash_json.pb, examples/basic/test_web_all.pb, and focused JSON set/get examples.

Example

LOCAL h AS LONG
h = JSONNEW(5)
JSONSETINT h, "x", 1
PRINT JSONSTRINGIFY$(h, 0)  ' {"x":1}
JSONFREE h

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONFREE gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONFREE gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONFREE

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


URLENCODE$ - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › URL and Encoding › URLENCODE$
Hilfe zum PBXB64-Compiler

URLENCODE$

Percent-encode a string for use in a URL.

Kind: Function | Category: Web & Network > Encoding

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = URLENCODE$(input$)

Returns

String with unsafe characters replaced by %HH escape sequences.

Description

Encodes characters that are not unreserved URL characters (alphanumerics, hyphen, underscore, period, tilde) as percent-encoded bytes using uppercase hex digits.

Parameters

Name | Type | Description
input$ | String | String to encode.

Error Handling

Encoding and decoding functions return strings. Invalid or incomplete input is handled deterministically by the specific decoder; validate decoded length and content when processing untrusted data.

Verifiziertes Beispiel

The encoding family is exercised by examples/basic/test_web_all.pb, including Base64, hex, URL encoding, JSON escaping, and reverse operations.

Example

LOCAL s$, enc$
s$ = "a b=c&d?"
enc$ = URLENCODE$(s$)
PRINT enc$  ' a%20b%3Dc%26d%3F

Expected output

Output: a%20b%3Dc%26d%3F

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

URLENCODE$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

URLENCODE$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer URL/header-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

URLENCODE$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


URLDECODE$ - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › URL and Encoding › URLDECODE$
Hilfe zum PBXB64-Compiler

URLDECODE$

Percent-decode a URL-encoded string.

Kind: Function | Category: Web & Network > Encoding

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = URLDECODE$(input$)

Returns

String with percent escapes replaced by their original characters.

Description

Reverses URLENCODE$. Any sequence of the form %HH is converted back to the corresponding byte. Plus signs (+) are left as-is.

Parameters

Name | Type | Description
input$ | String | URL-encoded string.

Error Handling

Encoding and decoding functions return strings. Invalid or incomplete input is handled deterministically by the specific decoder; validate decoded length and content when processing untrusted data.

Verifiziertes Beispiel

The encoding family is exercised by examples/basic/test_web_all.pb, including Base64, hex, URL encoding, JSON escaping, and reverse operations.

Example

LOCAL enc$, dec$
enc$ = "a%20b%3Dc"
dec$ = URLDECODE$(enc$)
PRINT dec$  ' a b=c

Expected output

Output: a b=c

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

URLDECODE$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

URLDECODE$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer URL/header-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

URLDECODE$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


URLHOST$ - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › URL and Encoding › URLHOST$
Hilfe zum PBXB64-Compiler

URLHOST$

Extract the host component from a URL.

Kind: Function | Category: Web & Network > URL Parsing

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = URLHOST$(url$)

Returns

String containing the host, or empty if no host is present.

Description

Parses a URL and returns the host portion. For http://example.com:8080/path the result is example.com.

Parameters

Name | Type | Description
url$ | String | URL to parse.

Error Handling

URL helper functions return an empty string or 0 when the requested component is absent. They do not validate that a remote host exists.

Verifiziertes Beispiel

The URL helper family is exercised by examples/basic/test_web_all.pb with host, path, query, port, and header-building checks.

Example

LOCAL url$, host$
url$ = "https://www.example.com:8080/path?x=1"
host$ = URLHOST$(url$)
PRINT host$  ' www.example.com

Expected output

Output: www.example.com

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

URLHOST$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

URLHOST$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer URL/header-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

URLHOST$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


URLPATH$ - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › URL and Encoding › URLPATH$
Hilfe zum PBXB64-Compiler

URLPATH$

Extract the path component from a URL.

Kind: Function | Category: Web & Network > URL Parsing

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = URLPATH$(url$)

Returns

String containing the path, including the leading slash.

Description

Parses a URL and returns the path. For http://example.com:8080/api/v1?x=1 the result is /api/v1.

Parameters

Name | Type | Description
url$ | String | URL to parse.

Error Handling

URL helper functions return an empty string or 0 when the requested component is absent. They do not validate that a remote host exists.

Verifiziertes Beispiel

The URL helper family is exercised by examples/basic/test_web_all.pb with host, path, query, port, and header-building checks.

Example

LOCAL url$, path$
url$ = "https://api.example.com/v1/users?id=42"
path$ = URLPATH$(url$)
PRINT path$  ' /v1/users

Expected output

Output: /v1/users

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

URLPATH$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

URLPATH$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer URL/header-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

URLPATH$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


URLPORT - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › URL and Encoding › URLPORT
Hilfe zum PBXB64-Compiler

URLPORT

Extract the port number from a URL.

Kind: Function | Category: Web & Network > URL Parsing

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result = URLPORT(url$)

Returns

Long integer port number, or 0 if no explicit port is present.

Description

Parses a URL and returns the explicit port. For http://example.com:8080/path the result is 8080. If no port is specified, returns 0.

Parameters

Name | Type | Description
url$ | String | URL to parse.

Error Handling

URL helper functions return an empty string or 0 when the requested component is absent. They do not validate that a remote host exists.

Verifiziertes Beispiel

The URL helper family is exercised by examples/basic/test_web_all.pb with host, path, query, port, and header-building checks.

Example

LOCAL url$, p AS LONG
url$ = "https://example.com:8443/secure"
p = URLPORT(url$)
PRINT p  ' 8443

Expected output

Output: 8443

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

URLPORT gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

URLPORT gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer URL/header-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

URLPORT

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


URLQUERY$ - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › URL and Encoding › URLQUERY$
Hilfe zum PBXB64-Compiler

URLQUERY$

Extract the query string from a URL.

Kind: Function | Category: Web & Network > URL Parsing

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = URLQUERY$(url$)

Returns

String containing the query string without the leading ?, or empty if none.

Description

Parses a URL and returns the query portion. For http://example.com/path?x=1&y=2 the result is x=1&y=2.

Parameters

Name | Type | Description
url$ | String | URL to parse.

Error Handling

URL helper functions return an empty string or 0 when the requested component is absent. They do not validate that a remote host exists.

Verifiziertes Beispiel

The URL helper family is exercised by examples/basic/test_web_all.pb with host, path, query, port, and header-building checks.

Example

LOCAL url$, q$
url$ = "https://example.com/search?q=PBXB64⟨=en"
q$ = URLQUERY$(url$)
PRINT q$  ' q=PBXB64⟨=en

Expected output

Output: q=PBXB64&lang=en

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

URLQUERY$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

URLQUERY$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer URL/header-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

URLQUERY$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


BASE64$ - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › URL and Encoding › BASE64$
Hilfe zum PBXB64-Compiler

BASE64$

Encode a string using standard Base64 (RFC 4648).

Kind: Function | Category: Web & Network > Encoding

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = BASE64$(input$)

Returns

String containing the Base64-encoded representation of input$.

Description

Converts the input string into a standard Base64 ASCII string. The output uses the A-Za-z0-9+/ alphabet and appends = padding when required.

Parameters

Name | Type | Description
input$ | String | Data to encode.

Error Handling

Encoding and decoding functions return strings. Invalid or incomplete input is handled deterministically by the specific decoder; validate decoded length and content when processing untrusted data.

Verifiziertes Beispiel

The encoding family is exercised by examples/basic/test_web_all.pb, including Base64, hex, URL encoding, JSON escaping, and reverse operations.

Example

LOCAL s$, enc$
s$ = "Hello, World!"
enc$ = BASE64$(s$)
PRINT enc$  ' SGVsbG8sIFdvcmxkIQ==

Expected output

Output: SGVsbG8sIFdvcmxkIQ==

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

BASE64$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

BASE64$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer encoding-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

BASE64$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


UNBASE64$ - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › URL and Encoding › UNBASE64$
Hilfe zum PBXB64-Compiler

UNBASE64$

Decode a Base64-encoded string.

Kind: Function | Category: Web & Network > Encoding

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = UNBASE64$(base64$)

Returns

String containing the decoded bytes.

Description

Reverses BASE64$ and BASE64URLSAFE$. Both standard and URL-safe alphabets are accepted. Padding is optional. Invalid characters are ignored.

Parameters

Name | Type | Description
base64$ | String | Base64 text to decode.

Error Handling

Encoding and decoding functions return strings. Invalid or incomplete input is handled deterministically by the specific decoder; validate decoded length and content when processing untrusted data.

Verifiziertes Beispiel

The encoding family is exercised by examples/basic/test_web_all.pb, including Base64, hex, URL encoding, JSON escaping, and reverse operations.

Example

LOCAL enc$, dec$
enc$ = "SGVsbG8sIFdvcmxkIQ=="
dec$ = UNBASE64$(enc$)
PRINT dec$  ' Hello, World!

Expected output

Output: Hello, World!

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

UNBASE64$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

UNBASE64$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer encoding-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

UNBASE64$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


BASE64URLSAFE$ - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › URL and Encoding › BASE64URLSAFE$
Hilfe zum PBXB64-Compiler

BASE64URLSAFE$

Encode a string using URL- and filename-safe Base64.

Kind: Function | Category: Web & Network > Encoding

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = BASE64URLSAFE$(input$)

Returns

String containing the URL-safe Base64 representation.

Description

Same as BASE64$ but replaces + with - and / with _, and omits padding characters. Suitable for embedding in URLs and query parameters.

Parameters

Name | Type | Description
input$ | String | Data to encode.

Error Handling

Encoding and decoding functions return strings. Invalid or incomplete input is handled deterministically by the specific decoder; validate decoded length and content when processing untrusted data.

Verifiziertes Beispiel

The encoding family is exercised by examples/basic/test_web_all.pb, including Base64, hex, URL encoding, JSON escaping, and reverse operations.

Example

LOCAL s$, enc$
s$ = "Hello? World<>"
enc$ = BASE64URLSAFE$(s$)
PRINT enc$

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

BASE64URLSAFE$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

BASE64URLSAFE$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer encoding-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

BASE64URLSAFE$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


HEX$ - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › URL and Encoding › HEX$
Hilfe zum PBXB64-Compiler

HEX$

Encode a string as lowercase hexadecimal.

Kind: Function | Category: Web & Network > Encoding

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = HEX$(input$)

Returns

String containing two lowercase hex digits for each input byte.

Description

Performs a byte-by-byte hex encoding. The result length is always twice the input length and uses the characters 0-9a-f.

Parameters

Name | Type | Description
input$ | String | Data to encode.

Error Handling

Encoding and decoding functions return strings. Invalid or incomplete input is handled deterministically by the specific decoder; validate decoded length and content when processing untrusted data.

Verifiziertes Beispiel

The encoding family is exercised by examples/basic/test_web_all.pb, including Base64, hex, URL encoding, JSON escaping, and reverse operations.

Example

LOCAL s$, h$
s$ = "ABC"
h$ = HEX$(s$)
PRINT h$  ' 414243

Expected output

Output: 414243

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

HEX$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

HEX$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer encoding-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

HEX$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


UNHEX$ - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › URL and Encoding › UNHEX$
Hilfe zum PBXB64-Compiler

UNHEX$

Decode a hexadecimal string.

Kind: Function | Category: Web & Network > Encoding

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = UNHEX$(hex$)

Returns

String containing the raw bytes represented by the hex text.

Description

Converts pairs of hex digits back into bytes. Both uppercase and lowercase hex are accepted. Whitespace and non-hex characters are ignored.

Parameters

Name | Type | Description
hex$ | String | Hex text to decode.

Error Handling

Encoding and decoding functions return strings. Invalid or incomplete input is handled deterministically by the specific decoder; validate decoded length and content when processing untrusted data.

Verifiziertes Beispiel

The encoding family is exercised by examples/basic/test_web_all.pb, including Base64, hex, URL encoding, JSON escaping, and reverse operations.

Example

LOCAL h$, s$
h$ = "48 65 6C 6C 6F"
s$ = UNHEX$(h$)
PRINT s$  ' Hello

Expected output

Output: Hello

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

UNHEX$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

UNHEX$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer encoding-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

UNHEX$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


ESCAPE$ - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › URL and Encoding › ESCAPE$
Hilfe zum PBXB64-Compiler

ESCAPE$

JSON-escape a string.

Kind: Function | Category: Web & Network > Encoding

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = ESCAPE$(input$)

Returns

String with JSON special characters escaped.

Description

Escapes the characters required by JSON strings: double quote becomes \", backslash becomes \\, and control characters become \n, \r, \t, etc.

Parameters

Name | Type | Description
input$ | String | String to escape.

Error Handling

Encoding and decoding functions return strings. Invalid or incomplete input is handled deterministically by the specific decoder; validate decoded length and content when processing untrusted data.

Verifiziertes Beispiel

The encoding family is exercised by examples/basic/test_web_all.pb, including Base64, hex, URL encoding, JSON escaping, and reverse operations.

Example

LOCAL s$, esc$
s$ = "Line1" + $LF + "Line2"
esc$ = ESCAPE$(s$)
PRINT esc$   ' Line1\nLine2  (newline escaped)

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

ESCAPE$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

ESCAPE$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer encoding-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

ESCAPE$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


UNESCAPE$ - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › URL and Encoding › UNESCAPE$
Hilfe zum PBXB64-Compiler

UNESCAPE$

Remove JSON escape sequences from a string.

Kind: Function | Category: Web & Network > Encoding

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = UNESCAPE$(input$)

Returns

String with JSON escape sequences converted back to literal characters.

Description

Reverses ESCAPE$. Recognises \", \\, \/, \b, \f, \n, \r, \t, and \uHHHH.

Parameters

Name | Type | Description
input$ | String | JSON-escaped string.

Error Handling

Encoding and decoding functions return strings. Invalid or incomplete input is handled deterministically by the specific decoder; validate decoded length and content when processing untrusted data.

Verifiziertes Beispiel

The encoding family is exercised by examples/basic/test_web_all.pb, including Base64, hex, URL encoding, JSON escaping, and reverse operations.

Example

LOCAL esc$, s$
esc$ = "Tab" + CHR$(92) + "tHere"   ' builds the literal: Tab\tHere
s$ = UNESCAPE$(esc$)
PRINT s$   ' Tab<TAB>Here

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

UNESCAPE$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

UNESCAPE$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer encoding-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

UNESCAPE$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


MD5$ - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › Hashing and HMAC › MD5$
Hilfe zum PBXB64-Compiler

MD5$

Compute an MD5 digest of a string.

Kind: Function | Category: Web & Network > Hashing

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = MD5$(input$)

Returns

String containing a 32-character lowercase hex digest.

Description

Returns the MD5 message digest of input$ as a 32-character lowercase hexadecimal string. The digest is computed over the byte contents of the BASIC string.

Parameters

Name | Type | Description
input$ | String | Data to hash.

Error Handling

Hash and HMAC functions return fixed-length lowercase hexadecimal strings. Empty input is valid. Validate the returned string length when using the digest in protocols or file formats.

Verifiziertes Beispiel

The hashing family is exercised by examples/basic/test_web_hash_json.pb with fixed MD5, SHA-1, SHA-256, SHA-512, HMAC-SHA256, and HMAC-SHA512 expected values.

Example

LOCAL h$
h$ = MD5$("abc")
PRINT h$  ' 900150983cd24fb0d6963f7d28e17f72

Expected output

Output: 900150983cd24fb0d6963f7d28e17f72

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

MD5$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

MD5$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer hashing-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input bytes, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

MD5$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


SHA1$ - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › Hashing and HMAC › SHA1$
Hilfe zum PBXB64-Compiler

SHA1$

Compute a SHA-1 digest of a string.

Kind: Function | Category: Web & Network > Hashing

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = SHA1$(input$)

Returns

String containing a 40-character lowercase hex digest.

Description

Returns the SHA-1 message digest of input$ as a 40-character lowercase hexadecimal string. The digest is computed over the byte contents of the BASIC string.

Parameters

Name | Type | Description
input$ | String | Data to hash.

Error Handling

Hash and HMAC functions return fixed-length lowercase hexadecimal strings. Empty input is valid. Validate the returned string length when using the digest in protocols or file formats.

Verifiziertes Beispiel

The hashing family is exercised by examples/basic/test_web_hash_json.pb with fixed MD5, SHA-1, SHA-256, SHA-512, HMAC-SHA256, and HMAC-SHA512 expected values.

Example

LOCAL h$
h$ = SHA1$("abc")
PRINT h$  ' a9993e364706816aba3e25717850c26c9cd0d89d

Expected output

Output: a9993e364706816aba3e25717850c26c9cd0d89d

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

SHA1$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

SHA1$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer hashing-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input bytes, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

SHA1$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


SHA256$ - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › Hashing and HMAC › SHA256$
Hilfe zum PBXB64-Compiler

SHA256$

Compute a SHA-256 digest of a string.

Kind: Function | Category: Web & Network > Hashing

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = SHA256$(input$)

Returns

String containing a 64-character lowercase hex digest.

Description

Returns the SHA-256 message digest of input$ as a 64-character lowercase hexadecimal string. The digest is computed over the byte contents of the BASIC string.

Parameters

Name | Type | Description
input$ | String | Data to hash.

Error Handling

Hash and HMAC functions return fixed-length lowercase hexadecimal strings. Empty input is valid. Validate the returned string length when using the digest in protocols or file formats.

Verifiziertes Beispiel

The hashing family is exercised by examples/basic/test_web_hash_json.pb with fixed MD5, SHA-1, SHA-256, SHA-512, HMAC-SHA256, and HMAC-SHA512 expected values.

Example

LOCAL h$
h$ = SHA256$("abc")
PRINT h$  ' ba7816bf8f01cfea414140de5dae2223b00361a396177a9cb410ff61f20015ad

Expected output

Output: ba7816bf8f01cfea414140de5dae2223b00361a396177a9cb410ff61f20015ad

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

SHA256$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

SHA256$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer hashing-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input bytes, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

SHA256$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


SHA512$ - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › Hashing and HMAC › SHA512$
Hilfe zum PBXB64-Compiler

SHA512$

Compute a SHA-512 digest of a string.

Kind: Function | Category: Web & Network > Hashing

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = SHA512$(input$)

Returns

String containing a 128-character lowercase hex digest.

Description

Returns the SHA-512 message digest of input$ as a 128-character lowercase hexadecimal string. The digest is computed over the byte contents of the BASIC string.

Parameters

Name | Type | Description
input$ | String | Data to hash.

Error Handling

Hash and HMAC functions return fixed-length lowercase hexadecimal strings. Empty input is valid. Validate the returned string length when using the digest in protocols or file formats.

Verifiziertes Beispiel

The hashing family is exercised by examples/basic/test_web_hash_json.pb with fixed MD5, SHA-1, SHA-256, SHA-512, HMAC-SHA256, and HMAC-SHA512 expected values.

Example

LOCAL h$
h$ = SHA512$("abc")
PRINT h$  ' ddaf35a193617abacc417349ae20413112e6fa4e89a97ea20a9eeee64b55d39a2192992a274fc1a836ba3c23a3feebbd454d4423643ce80e2a9ac94fa54ca49f

Expected output

Output: ddaf35a193617abacc417349ae20413112e6fa4e89a97ea20a9eeee64b55d39a2192992a274fc1a836ba3c23a3feebbd454d4423643ce80e2a9ac94fa54ca49f

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

SHA512$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

SHA512$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer hashing-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input bytes, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

SHA512$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


HMACSHA256$ - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › Hashing and HMAC › HMACSHA256$
Hilfe zum PBXB64-Compiler

HMACSHA256$

Compute an HMAC-SHA256 authentication code.

Kind: Function | Category: Web & Network > Hashing

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = HMACSHA256$(key$, data$)

Returns

String containing a 64-character lowercase hex HMAC.

Description

Computes HMAC-SHA256 using key$ and data$, returning a 64-character lowercase hexadecimal authentication code.

Parameters

Name | Type | Description
key$ | String | Secret key.
data$ | String | Message to authenticate.

Error Handling

Hash and HMAC functions return fixed-length lowercase hexadecimal strings. Empty input is valid. Validate the returned string length when using the digest in protocols or file formats.

Verifiziertes Beispiel

The hashing family is exercised by examples/basic/test_web_hash_json.pb with fixed MD5, SHA-1, SHA-256, SHA-512, HMAC-SHA256, and HMAC-SHA512 expected values.

Example

LOCAL h$
h$ = HMACSHA256$("key", "data")
PRINT h$  ' 5031fe3d989c6d1537a013fa6e739da23463fdaec3b70137d828e36ace221bd0

Expected output

Output: 5031fe3d989c6d1537a013fa6e739da23463fdaec3b70137d828e36ace221bd0

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

HMACSHA256$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

HMACSHA256$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer hashing-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input bytes, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

HMACSHA256$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


HMACSHA512$ - PBXB64 Compiler Help - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Inline Assembly › Hashing and HMAC › HMACSHA512$
Hilfe zum PBXB64-Compiler

HMACSHA512$

Compute an HMAC-SHA512 authentication code.

Kind: Function | Category: Web & Network > Hashing

PBXB64 Status: AVAILABLE (V10+)

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = HMACSHA512$(key$, data$)

Returns

String containing a 128-character lowercase hex HMAC.

Description

Computes HMAC-SHA512 using key$ and data$, returning a 128-character lowercase hexadecimal authentication code.

Parameters

Name | Type | Description
key$ | String | Secret key.
data$ | String | Message to authenticate.

Error Handling

Hash and HMAC functions return fixed-length lowercase hexadecimal strings. Empty input is valid. Validate the returned string length when using the digest in protocols or file formats.

Verifiziertes Beispiel

The hashing family is exercised by examples/basic/test_web_hash_json.pb with fixed MD5, SHA-1, SHA-256, SHA-512, HMAC-SHA256, and HMAC-SHA512 expected values.

Example

LOCAL h$
h$ = HMACSHA512$("key", "data")
PRINT h$  ' 3c5953a18f7303ec653ba170ae334fafa08e3846f2efe317b87efce82376253cb52a8c31ddcde5a3a2eee183c2b34cb91f85e64ddbc325f7692b199473579c58

Expected output

Output: 3c5953a18f7303ec653ba170ae334fafa08e3846f2efe317b87efce82376253cb52a8c31ddcde5a3a2eee183c2b34cb91f85e64ddbc325f7692b199473579c58

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

HMACSHA512$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

HMACSHA512$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer hashing-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input bytes, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

HMACSHA512$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


PBXB64 – C-Sprache (V10)

Startseite› C-Frontend

C-Sprachreferenz (C17-Untergruppe)

PBXB64 unterstützt eine wachsende C17-Untergruppe, die über die einheitliche IR mit B64/BASIC/PILOT interoperabel ist. V10 fügt printf/varargs, indirekte Funktionszeiger und Float-Arithmetik hinzu.

Referenzseiten

Diese Seite ist die Uebersicht zum Frontend. Die verlinkten Einzelseiten enthalten Syntax, getestete Beispiele, Status und Grenzen fuer die jeweiligen Befehle oder Sprachkonstrukte.

  • Datentypen
  • Variablen
  • Funktionen
  • Kontrollfluss
  • Strukturen
  • Pointer und Arrays
  • Praeprozessor
  • Standardbibliothek

printf / Varargs (V10)

#include <stdio.h>

Bootstrap printf mit String-Literal-Format:

#include <stdio.h>

int main(void) {
    int n = 42;
    printf("V10 answer=%d hex=%x str=%s\n", n, n, "ok");
    return 0;
}
Format | Unterstützung
%d, %i | Vorzeichenbehaftete Ganzzahl
%u | Ganzzahl ohne Vorzeichen
%x, %X | Hexadezimal
%o | Oktal
%c | Charakter
%s | Zeichenfolge
%% | Wörtlicher Prozentsatz

Indirekte Funktionszeiger (V10)

call r/m64über x64-Backend
long long add(long long a, long long b) { return a + b; }
long long sub(long long a, long long b) { return a - b; }

int main(void) {
    long long (*fp)(long long, long long);
    int res = 0;
    fp = &add
    res = (int)fp(20, 22);
    fp = ⊂
    return res + (int)fp(50, 8) - 84;
}

Laufzeit: malloc / kostenlos (V10)

#include <stdlib.h>

int main(void) {
    int* p = (int*)malloc(sizeof(int));
    if (p) { *p = 42; free(p); }
    return 0;
}

Float-Arithmetik (V10)

Nur Kompilierungspfad.Float/Double-Arithmetik kompiliert und senkt über die IR. Das vollständige SSE-Float-Codegen ist ein V11+-Ziel.
double f(double a, double b) {
    return a * 2.0 + b / 4.0;
}

Präprozessor (V9/V10)

#define MAX 100
#if MAX > 50
    #define MODE 1
#endif

#ifdef __STDC__
    int ver = __STDC_VERSION__;  // 201710L
#endif

_Pragma("GCC diagnostic ignored")  // stripped safely
int line = __LINE__;                // integer
char* file = __FILE__;              // string literal

C17-Header

26 Kopfbälle beicore/include/c17/. Einschließen mit-I:

PBXB64 -I core/include/c17 program.c -o program.exe

Kontrollfluss

switch (x) { case 1: break; case 2: case 3: break; default: break; }
goto label; label: return 0;
return (x > 0) ? 1 : -1;
for (int i = 0; i < 10; i++, j += 2) { body }
if (x) { block } else { block }
Bekannte Lücken:Vollständiger SSE-Float-Codegen, vollständiges Varargs-ABI mit va_arg, vollständiges Struktur-/Union-/Bitfeld-Layout, stdio-Datei-E/A, qsort/atexit, Windows SDK-Kompatibilität.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


C Datentypen — PBXB64 Help

Startseite › BASIC Frontend › C Data Types

C Datentypen

Diese Hub-Seite verweist auf einzelne C-Frontend-Seiten fuer implementierte, getestete Konstrukte.

Zweck

Die Seite ist bewusst ein Ueberblickskapitel. Details, Syntax, Grenzen und Validierungsbelege stehen auf den darunterliegenden Einzelseiten, damit nicht mehrere Befehle auf einer einzigen Referenzseite vermischt werden.

ABI und Zielplattform

PBXB64s C-Frontend zielt auf eine getestete C17/C23-Teilmenge fuer Windows x64. Benutzerfunktionen und externe Aufrufe werden fuer die Windows-x64-ABI gesenkt: Integer- und Zeigerargumente verwenden RCX, RDX, R8 und R9; Floating-Point-Argumente verwenden XMM0 bis XMM3; weitere Argumente liegen auf dem Stack. Diese ABI-Notiz ist fuer C/PB/ASM-Mischprogramme wichtig.

Portabilitaet

Portabilitaet: Die Hilfeseiten dokumentieren PBXB64s natives Windows-Ziel, nicht einen POSIX-C-Compiler. Vermeide Annahmen ueber Unix-Header, Hostprozessverhalten oder implementation-defined Groessen, sofern die jeweilige Einzelseite sie nicht ausdruecklich belegt.

Einzelseiten

  • int / integer types
  • float / double
  • _Bool
  • struct
  • union
  • enum
  • typedef

Pruefung

Die C-Seiten verweisen auf konkrete Beispiele oder Validierungstests. Neue C-Frontend-Behauptungen sollen erst nach einem fokussierten compile/link/run-Beleg in diese Referenz aufgenommen werden.

Beginne mit dieser Uebersicht, wenn du die passende Sprachform suchst, und wechsle dann auf die Einzelseite. Dort stehen die getestete Syntax, der begrenzte PBXB64-Umfang, bekannte Einschraenkungen und der konkrete Datei- oder Matrixbeleg.

Ein guter C-Beleg ist eine kleine, eigenstaendige Quelldatei mit Exitcode 0 fuer Erfolg, klarer Fehlerrueckgabe und nur den Headern, die das gezeigte Feature wirklich benoetigt.

← Back

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


C int - Integer-Typen verwenden — PBXB64 Help

Startseite › BASIC Frontend › C int - Integer-Typen verwenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

C int - Integer-Typen verwenden

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

int x = 42; unsigned long long y = 1;

Beschreibung

Unterstuetzt uebliche Integer-Schreibweisen, signed/unsigned-Arithmetik, Hex-Literale, Shifts und Bitoperationen.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/test_hex_integer_bitwise.c

Abgedeckt durch tests/c/test_hex_integer_bitwise.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C float / double - Floating-Point-Werte verwenden — PBXB64 Help

Startseite › BASIC Frontend › C float / double - Floating-Point-Werte verwenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

C float / double - Floating-Point-Werte verwenden

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

double x = 3.14;

Beschreibung

Unterstuetzt float/double-Werte und Math-Runtime-Aufrufe aus den Science-Beispielen.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/c/test_science_tier1.c

Abgedeckt durch examples/c/test_science_tier1.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C _Bool - Booleschen Speicher verwenden — PBXB64 Help

Startseite › BASIC Frontend › C _Bool - Booleschen Speicher verwenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

C _Bool - Booleschen Speicher verwenden

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

_Bool ok = 1;

Beschreibung

Implementiert C-Boolspeicher und logisches Konvertierungsverhalten.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/test_float_logical.c

Abgedeckt durch tests/c/test_float_logical.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C enum - Integer-Konstanten deklarieren — PBXB64 Help

Startseite › BASIC Frontend › C enum - Integer-Konstanten deklarieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

C enum - Integer-Konstanten deklarieren

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

enum Color { RED, GREEN = 4 };

Beschreibung

Parst enum-Konstanten als Integerwerte fuer Ausdruecke.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/c/test_c_stmts.c

Abgedeckt durch examples/c/test_c_stmts.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C typedef - Typ benennen — PBXB64 Help

Startseite › BASIC Frontend › C typedef - Typ benennen — PBXB64 Help
Hilfe zum PBXB64-Compiler

C typedef - Typ benennen

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

typedef int Count;

Beschreibung

Registriert Typedef-Namen und trennt sie von normalen Bezeichnern und Struct-Membern.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/test_const_typedef_pointer_arrow.c

Abgedeckt durch tests/c/test_const_typedef_pointer_arrow.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


C Variablen und Konstanten — PBXB64 Help

Startseite › BASIC Frontend › C Variables and Constants

C Variablen und Konstanten

Diese Hub-Seite verweist auf einzelne C-Frontend-Seiten fuer implementierte, getestete Konstrukte.

Zweck

Die Seite ist bewusst ein Ueberblickskapitel. Details, Syntax, Grenzen und Validierungsbelege stehen auf den darunterliegenden Einzelseiten, damit nicht mehrere Befehle auf einer einzigen Referenzseite vermischt werden.

ABI und Zielplattform

PBXB64s C-Frontend zielt auf eine getestete C17/C23-Teilmenge fuer Windows x64. Benutzerfunktionen und externe Aufrufe werden fuer die Windows-x64-ABI gesenkt: Integer- und Zeigerargumente verwenden RCX, RDX, R8 und R9; Floating-Point-Argumente verwenden XMM0 bis XMM3; weitere Argumente liegen auf dem Stack. Diese ABI-Notiz ist fuer C/PB/ASM-Mischprogramme wichtig.

Portabilitaet

Portabilitaet: Die Hilfeseiten dokumentieren PBXB64s natives Windows-Ziel, nicht einen POSIX-C-Compiler. Vermeide Annahmen ueber Unix-Header, Hostprozessverhalten oder implementation-defined Groessen, sofern die jeweilige Einzelseite sie nicht ausdruecklich belegt.

Einzelseiten

  • auto locals
  • static storage
  • extern symbols
  • const qualifier
  • initializers

Pruefung

Die C-Seiten verweisen auf konkrete Beispiele oder Validierungstests. Neue C-Frontend-Behauptungen sollen erst nach einem fokussierten compile/link/run-Beleg in diese Referenz aufgenommen werden.

Beginne mit dieser Uebersicht, wenn du die passende Sprachform suchst, und wechsle dann auf die Einzelseite. Dort stehen die getestete Syntax, der begrenzte PBXB64-Umfang, bekannte Einschraenkungen und der konkrete Datei- oder Matrixbeleg.

Ein guter C-Beleg ist eine kleine, eigenstaendige Quelldatei mit Exitcode 0 fuer Erfolg, klarer Fehlerrueckgabe und nur den Headern, die das gezeigte Feature wirklich benoetigt.

← Back

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


C auto - Automatischen Speicher verwenden — PBXB64 Help

Startseite › BASIC Frontend › C auto - Automatischen Speicher verwenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

C auto - Automatischen Speicher verwenden

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

auto int x = 1;

Beschreibung

Automatischer Blockspeicher ist der Standard fuer lokale C-Variablen.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/c/simple.c

Abgedeckt durch examples/c/simple.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C static - Persistenten Speicher verwenden — PBXB64 Help

Startseite › BASIC Frontend › C static - Persistenten Speicher verwenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

C static - Persistenten Speicher verwenden

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

static int counter;

Beschreibung

Unterstuetzt statischen Speicher auf Datei- oder lokaler Ebene, soweit getestet.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/test_static.c

Abgedeckt durch tests/c/test_static.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C extern - Externe Symbole deklarieren — PBXB64 Help

Startseite › BASIC Frontend › C extern - Externe Symbole deklarieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

C extern - Externe Symbole deklarieren

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

extern int puts(const char *);

Beschreibung

Deklariert Symbole, die ueber Linker oder Runtime-Objekte aufgeloest werden.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/c/test_un_runtime_access.c

Abgedeckt durch examples/c/test_un_runtime_access.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C const - Nur-Lesen-Absicht qualifizieren — PBXB64 Help

Startseite › BASIC Frontend › C const - Nur-Lesen-Absicht qualifizieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

C const - Nur-Lesen-Absicht qualifizieren

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

const int x = 1;

Beschreibung

Parst const-qualifizierte Typen und Zeiger im C-Deklaratorpfad.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/test_const_typedef_pointer_arrow.c

Abgedeckt durch tests/c/test_const_typedef_pointer_arrow.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C initializer - Objekte initialisieren — PBXB64 Help

Startseite › BASIC Frontend › C initializer - Objekte initialisieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

C initializer - Objekte initialisieren

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

int a[3] = {1, 2, 3};

Beschreibung

Unterstuetzt von den Tests abgedeckte Skalar-, Aggregat-, String- und Compound-Initialisierer.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/test_initializers.c

Abgedeckt durch tests/c/test_initializers.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C Funktionen — PBXB64 Help

Startseite › BASIC Frontend › C Functions

C Funktionen

Diese Hub-Seite verweist auf einzelne C-Frontend-Seiten fuer implementierte, getestete Konstrukte.

Zweck

Die Seite ist bewusst ein Ueberblickskapitel. Details, Syntax, Grenzen und Validierungsbelege stehen auf den darunterliegenden Einzelseiten, damit nicht mehrere Befehle auf einer einzigen Referenzseite vermischt werden.

ABI und Zielplattform

PBXB64s C-Frontend zielt auf eine getestete C17/C23-Teilmenge fuer Windows x64. Benutzerfunktionen und externe Aufrufe werden fuer die Windows-x64-ABI gesenkt: Integer- und Zeigerargumente verwenden RCX, RDX, R8 und R9; Floating-Point-Argumente verwenden XMM0 bis XMM3; weitere Argumente liegen auf dem Stack. Diese ABI-Notiz ist fuer C/PB/ASM-Mischprogramme wichtig.

Portabilitaet

Portabilitaet: Die Hilfeseiten dokumentieren PBXB64s natives Windows-Ziel, nicht einen POSIX-C-Compiler. Vermeide Annahmen ueber Unix-Header, Hostprozessverhalten oder implementation-defined Groessen, sofern die jeweilige Einzelseite sie nicht ausdruecklich belegt.

Einzelseiten

  • function definition
  • return
  • function pointers
  • variadic calls

Pruefung

Die C-Seiten verweisen auf konkrete Beispiele oder Validierungstests. Neue C-Frontend-Behauptungen sollen erst nach einem fokussierten compile/link/run-Beleg in diese Referenz aufgenommen werden.

Beginne mit dieser Uebersicht, wenn du die passende Sprachform suchst, und wechsle dann auf die Einzelseite. Dort stehen die getestete Syntax, der begrenzte PBXB64-Umfang, bekannte Einschraenkungen und der konkrete Datei- oder Matrixbeleg.

Ein guter C-Beleg ist eine kleine, eigenstaendige Quelldatei mit Exitcode 0 fuer Erfolg, klarer Fehlerrueckgabe und nur den Headern, die das gezeigte Feature wirklich benoetigt.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C function - C-Funktion definieren — PBXB64 Help

Startseite › BASIC Frontend › C function - C-Funktion definieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

C function - C-Funktion definieren

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

int add(int a, int b) { return a + b; }

Beschreibung

Funktionsdefinitionen werden in native PBXB64-IR gesenkt und verwenden die Windows-x64-Aufrufkonvention. Die Validierung deckt normale Aufrufe, Runtime-Aufrufe und C17/C23-Modus ab.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/c/simple.c

Abgedeckt durch examples/c/simple.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C return - Aus Funktion zurueckkehren — PBXB64 Help

Startseite › BASIC Frontend › C return - Aus Funktion zurueckkehren — PBXB64 Help
Hilfe zum PBXB64-Compiler

C return - Aus Funktion zurueckkehren

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

return 42;

Beschreibung

Gibt Skalarwerte zurueck und ist Teil der nativen Kontrollfluss-Senkung. Struct-Rvalue- und Member-Faelle sind durch fokussierte C-Tests abgedeckt.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/c/simple.c

Abgedeckt durch examples/c/simple.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C function pointer - Ueber Zeiger aufrufen — PBXB64 Help

Startseite › BASIC Frontend › C function pointer - Ueber Zeiger aufrufen — PBXB64 Help
Hilfe zum PBXB64-Compiler

C function pointer - Ueber Zeiger aufrufen

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

int (*fp)(int) = f; fp(1);

Beschreibung

Bewahrt Funktionszeiger-Prototypinformationen fuer direkte und Member-Funktionszeiger-Aufrufe.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/test_function_designator_pointer.c

Abgedeckt durch tests/c/test_function_designator_pointer.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C variadic - Varargs-Funktionen aufrufen — PBXB64 Help

Startseite › BASIC Frontend › C variadic - Varargs-Funktionen aufrufen — PBXB64 Help
Hilfe zum PBXB64-Compiler

C variadic - Varargs-Funktionen aufrufen

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

printf("%d", x);

Beschreibung

Unterstuetzt printf-aehnliche variadische Aufrufe ueber die Win64-ABI-Senkung.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/c/test_variadic.c

Abgedeckt durch examples/c/test_variadic.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C Kontrollfluss — PBXB64 Help

Startseite › BASIC Frontend › C Control Flow

C Kontrollfluss

Diese Hub-Seite verweist auf einzelne C-Frontend-Seiten fuer implementierte, getestete Konstrukte.

Zweck

Die Seite ist bewusst ein Ueberblickskapitel. Details, Syntax, Grenzen und Validierungsbelege stehen auf den darunterliegenden Einzelseiten, damit nicht mehrere Befehle auf einer einzigen Referenzseite vermischt werden.

ABI und Zielplattform

PBXB64s C-Frontend zielt auf eine getestete C17/C23-Teilmenge fuer Windows x64. Benutzerfunktionen und externe Aufrufe werden fuer die Windows-x64-ABI gesenkt: Integer- und Zeigerargumente verwenden RCX, RDX, R8 und R9; Floating-Point-Argumente verwenden XMM0 bis XMM3; weitere Argumente liegen auf dem Stack. Diese ABI-Notiz ist fuer C/PB/ASM-Mischprogramme wichtig.

Portabilitaet

Portabilitaet: Die Hilfeseiten dokumentieren PBXB64s natives Windows-Ziel, nicht einen POSIX-C-Compiler. Vermeide Annahmen ueber Unix-Header, Hostprozessverhalten oder implementation-defined Groessen, sofern die jeweilige Einzelseite sie nicht ausdruecklich belegt.

Einzelseiten

  • if / else
  • switch / case
  • while
  • do while
  • for
  • break
  • continue
  • goto

Pruefung

Die C-Seiten verweisen auf konkrete Beispiele oder Validierungstests. Neue C-Frontend-Behauptungen sollen erst nach einem fokussierten compile/link/run-Beleg in diese Referenz aufgenommen werden.

Beginne mit dieser Uebersicht, wenn du die passende Sprachform suchst, und wechsle dann auf die Einzelseite. Dort stehen die getestete Syntax, der begrenzte PBXB64-Umfang, bekannte Einschraenkungen und der konkrete Datei- oder Matrixbeleg.

Ein guter C-Beleg ist eine kleine, eigenstaendige Quelldatei mit Exitcode 0 fuer Erfolg, klarer Fehlerrueckgabe und nur den Headern, die das gezeigte Feature wirklich benoetigt.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C if - Bedingt verzweigen — PBXB64 Help

Startseite › BASIC Frontend › C if - Bedingt verzweigen — PBXB64 Help
Hilfe zum PBXB64-Compiler

C if - Bedingt verzweigen

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

if (x) { return 1; } else { return 0; }

Beschreibung

Unterstuetzt Integer-, Zeiger- und Floating-Logical-Bedingungen mit optionalem else-Block.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/c/help_control_flow/help_c_if.c

Abgedeckt durch examples/c/test_c_stmts.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C switch - Nach Integer-Fall verzweigen — PBXB64 Help

Startseite › BASIC Frontend › C switch - Nach Integer-Fall verzweigen — PBXB64 Help
Hilfe zum PBXB64-Compiler

C switch - Nach Integer-Fall verzweigen

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

switch (x) { case 1: return 2; default: return 0; }

Beschreibung

Senkt switch/case/default-Segmente, einschliesslich continue-Verhalten in umgebenden Schleifen.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/c/help_control_flow/help_c_switch.c

Abgedeckt durch examples/c/test_c_stmts.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C while - Schleife solange wahr — PBXB64 Help

Startseite › BASIC Frontend › C while - Schleife solange wahr — PBXB64 Help
Hilfe zum PBXB64-Compiler

C while - Schleife solange wahr

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

while (i < 10) { i++; }

Beschreibung

Wiederholt, solange die Bedingung wahr ist, und verwendet den aktiven C-Schleifenrahmen fuer break/continue.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/c/help_control_flow/help_c_while.c

Abgedeckt durch examples/c/test_c_stmts.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C do while - Block vor Bedingung ausfuehren — PBXB64 Help

Startseite › BASIC Frontend › C do while - Block vor Bedingung ausfuehren — PBXB64 Help
Hilfe zum PBXB64-Compiler

C do while - Block vor Bedingung ausfuehren

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

do { i++; } while (i < 10);

Beschreibung

Implementiert nachlaufend getestete Schleifen im nativen Statement-Parser.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/c/help_control_flow/help_c_do_while.c

Abgedeckt durch examples/c/test_c_stmts.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C for - C-Zaehlschleife — PBXB64 Help

Startseite › BASIC Frontend › C for - C-Zaehlschleife — PBXB64 Help
Hilfe zum PBXB64-Compiler

C for - C-Zaehlschleife

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

for (int i = 0; i < 10; i++) { }

Beschreibung

Unterstuetzt Init-, Bedingungs- und Schritt-Klauseln, einschliesslich lokaler Deklarationen in der Init-Klausel.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/c/help_control_flow/help_c_for.c

Abgedeckt durch examples/c/test_c_stmts.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C break - Schleife oder switch verlassen — PBXB64 Help

Startseite › BASIC Frontend › C break - Schleife oder switch verlassen — PBXB64 Help
Hilfe zum PBXB64-Compiler

C break - Schleife oder switch verlassen

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

break;

Beschreibung

Springt zum naechsten Schleifen- oder switch-Ausgang.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/c/help_control_flow/help_c_break.c

Abgedeckt durch examples/c/test_c_stmts.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C continue - Schleife fortsetzen — PBXB64 Help

Startseite › BASIC Frontend › C continue - Schleife fortsetzen — PBXB64 Help
Hilfe zum PBXB64-Compiler

C continue - Schleife fortsetzen

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

continue;

Beschreibung

Springt zum Continue-Ziel der aktuellen Schleife, auch bei Faellen in switch-Bloecken.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/c/help_control_flow/help_c_continue.c

Abgedeckt durch tests/c/test_continue_switch.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C goto - Zu Label springen — PBXB64 Help

Startseite › BASIC Frontend › C goto - Zu Label springen — PBXB64 Help
Hilfe zum PBXB64-Compiler

C goto - Zu Label springen

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

goto done; done: return 0;

Beschreibung

Unterstuetzt Labels und direkte goto-Spruenge innerhalb einer Funktion.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/c/help_control_flow/help_c_goto.c

Abgedeckt durch examples/c/test_c_stmts.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C Zeiger und Arrays — PBXB64 Help

Startseite › BASIC Frontend › C Pointers and Arrays

C Zeiger und Arrays

Diese Hub-Seite verweist auf einzelne C-Frontend-Seiten fuer implementierte, getestete Konstrukte.

Zweck

Die Seite ist bewusst ein Ueberblickskapitel. Details, Syntax, Grenzen und Validierungsbelege stehen auf den darunterliegenden Einzelseiten, damit nicht mehrere Befehle auf einer einzigen Referenzseite vermischt werden.

ABI und Zielplattform

PBXB64s C-Frontend zielt auf eine getestete C17/C23-Teilmenge fuer Windows x64. Benutzerfunktionen und externe Aufrufe werden fuer die Windows-x64-ABI gesenkt: Integer- und Zeigerargumente verwenden RCX, RDX, R8 und R9; Floating-Point-Argumente verwenden XMM0 bis XMM3; weitere Argumente liegen auf dem Stack. Diese ABI-Notiz ist fuer C/PB/ASM-Mischprogramme wichtig.

Portabilitaet

Portabilitaet: Die Hilfeseiten dokumentieren PBXB64s natives Windows-Ziel, nicht einen POSIX-C-Compiler. Vermeide Annahmen ueber Unix-Header, Hostprozessverhalten oder implementation-defined Groessen, sofern die jeweilige Einzelseite sie nicht ausdruecklich belegt.

Einzelseiten

  • pointers
  • arrays
  • -> member access
  • sizeof
  • casts

Pruefung

Die C-Seiten verweisen auf konkrete Beispiele oder Validierungstests. Neue C-Frontend-Behauptungen sollen erst nach einem fokussierten compile/link/run-Beleg in diese Referenz aufgenommen werden.

Beginne mit dieser Uebersicht, wenn du die passende Sprachform suchst, und wechsle dann auf die Einzelseite. Dort stehen die getestete Syntax, der begrenzte PBXB64-Umfang, bekannte Einschraenkungen und der konkrete Datei- oder Matrixbeleg.

Ein guter C-Beleg ist eine kleine, eigenstaendige Quelldatei mit Exitcode 0 fuer Erfolg, klarer Fehlerrueckgabe und nur den Headern, die das gezeigte Feature wirklich benoetigt.

← Back

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


C pointer - Werte adressieren und dereferenzieren — PBXB64 Help

Startseite › BASIC Frontend › C pointer - Werte adressieren und dereferenzieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

C pointer - Werte adressieren und dereferenzieren

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

int *p = &x; *p = 3;

Beschreibung

Unterstuetzt Address-of, Dereferenzierung, Zeigerarithmetik, Funktionsdesignatoren und Funktionszeiger-Aufrufe.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/test_z31_pointer_byte_offsets.c

Abgedeckt durch tests/c/test_z31_pointer_byte_offsets.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C array - Indizierten Speicher verwenden — PBXB64 Help

Startseite › BASIC Frontend › C array - Indizierten Speicher verwenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

C array - Indizierten Speicher verwenden

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

int a[3] = {1, 2, 3};

Beschreibung

Unterstuetzt feste Arrays, Initialisiererlisten, Indizierung und Array-zu-Zeiger-Nutzung in implementierten Kontexten.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/test_arrays.c

Abgedeckt durch tests/c/test_arrays.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


C -> - Zeiger-Member zugreifen — PBXB64 Help

Startseite › BASIC Frontend › C -&gt; - Zeiger-Member zugreifen — PBXB64 Help
Hilfe zum PBXB64-Compiler

C -> - Zeiger-Member zugreifen

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

p->field

Beschreibung

Greift ueber einen Zeigerausdruck auf Struct-Member zu.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/test_const_typedef_pointer_arrow.c

Abgedeckt durch tests/c/test_const_typedef_pointer_arrow.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C sizeof - Objektgroesse abfragen — PBXB64 Help

Startseite › BASIC Frontend › C sizeof - Objektgroesse abfragen — PBXB64 Help
Hilfe zum PBXB64-Compiler

C sizeof - Objektgroesse abfragen

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

sizeof(int)

Beschreibung

Wertet unterstuetzte Typ- und Operandenformen zur Compilezeit fuer native Layout-Entscheidungen aus.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/test_arrays.c

Abgedeckt durch tests/c/test_arrays.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


C cast - Explizit konvertieren — PBXB64 Help

Startseite › BASIC Frontend › C cast - Explizit konvertieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

C cast - Explizit konvertieren

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

(int)x

Beschreibung

Behandelt explizite Skalar- und Zeigerkonvertierungen in Ausdruecken.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/test_cast_unary_operand.c

Abgedeckt durch tests/c/test_cast_unary_operand.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C Strukturen und Unions — PBXB64 Help

Startseite › BASIC Frontend › C Structures and Unions

C Strukturen und Unions

Diese Hub-Seite verweist auf einzelne C-Frontend-Seiten fuer implementierte, getestete Konstrukte.

Zweck

Die Seite ist bewusst ein Ueberblickskapitel. Details, Syntax, Grenzen und Validierungsbelege stehen auf den darunterliegenden Einzelseiten, damit nicht mehrere Befehle auf einer einzigen Referenzseite vermischt werden.

ABI und Zielplattform

PBXB64s C-Frontend zielt auf eine getestete C17/C23-Teilmenge fuer Windows x64. Benutzerfunktionen und externe Aufrufe werden fuer die Windows-x64-ABI gesenkt: Integer- und Zeigerargumente verwenden RCX, RDX, R8 und R9; Floating-Point-Argumente verwenden XMM0 bis XMM3; weitere Argumente liegen auf dem Stack. Diese ABI-Notiz ist fuer C/PB/ASM-Mischprogramme wichtig.

Portabilitaet

Portabilitaet: Die Hilfeseiten dokumentieren PBXB64s natives Windows-Ziel, nicht einen POSIX-C-Compiler. Vermeide Annahmen ueber Unix-Header, Hostprozessverhalten oder implementation-defined Groessen, sofern die jeweilige Einzelseite sie nicht ausdruecklich belegt.

Einzelseiten

  • struct
  • union
  • compound literals
  • bit-fields

Pruefung

Die C-Seiten verweisen auf konkrete Beispiele oder Validierungstests. Neue C-Frontend-Behauptungen sollen erst nach einem fokussierten compile/link/run-Beleg in diese Referenz aufgenommen werden.

Beginne mit dieser Uebersicht, wenn du die passende Sprachform suchst, und wechsle dann auf die Einzelseite. Dort stehen die getestete Syntax, der begrenzte PBXB64-Umfang, bekannte Einschraenkungen und der konkrete Datei- oder Matrixbeleg.

Ein guter C-Beleg ist eine kleine, eigenstaendige Quelldatei mit Exitcode 0 fuer Erfolg, klarer Fehlerrueckgabe und nur den Headern, die das gezeigte Feature wirklich benoetigt.

← Back

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


C struct - Benannte Felder gruppieren — PBXB64 Help

Startseite › BASIC Frontend › C struct - Benannte Felder gruppieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

C struct - Benannte Felder gruppieren

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

struct Point { int x; int y; };

Beschreibung

Unterstuetzt benannte Records, Memberzugriff, selbstreferenzielle Zeiger, Rvalue-Memberzugriff und Struct-Layout-Pruefungen.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/test_struct_access_comprehensive.c

Abgedeckt durch tests/c/test_struct_access_comprehensive.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


C union - Felder ueberlagern — PBXB64 Help

Startseite › BASIC Frontend › C union - Felder ueberlagern — PBXB64 Help
Hilfe zum PBXB64-Compiler

C union - Felder ueberlagern

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

union U { int i; float f; };

Beschreibung

Verwendet dieselbe Record-Logik wie structs mit Union-Layout-Semantik.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/c/_v1.c

Abgedeckt durch examples/c/_v1.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C compound literal - Unbenannte Objekte erzeugen — PBXB64 Help

Startseite › BASIC Frontend › C compound literal - Unbenannte Objekte erzeugen — PBXB64 Help
Hilfe zum PBXB64-Compiler

C compound literal - Unbenannte Objekte erzeugen

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

(struct P){1, 2}

Beschreibung

Erzeugt unbenannte Aggregatwerte und unterstuetzt in fokussierten Tests deren Adresse.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/test_compound_literal.c

Abgedeckt durch tests/c/test_compound_literal.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


C bit-field - Struct-Member packen — PBXB64 Help

Startseite › BASIC Frontend › C bit-field - Struct-Member packen — PBXB64 Help
Hilfe zum PBXB64-Compiler

C bit-field - Struct-Member packen

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

struct F { unsigned x:3; };

Beschreibung

Speichert Bitfeld-Breite und Offset-Metadaten in C-Record-Membern.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/test_struct_access_comprehensive.c

Abgedeckt durch tests/c/test_struct_access_comprehensive.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C Praeprozessor — PBXB64 Help

Startseite › BASIC Frontend › C Preprocessor

C Praeprozessor

Diese Hub-Seite verweist auf einzelne C-Frontend-Seiten fuer implementierte, getestete Konstrukte.

Zweck

Die Seite ist bewusst ein Ueberblickskapitel. Details, Syntax, Grenzen und Validierungsbelege stehen auf den darunterliegenden Einzelseiten, damit nicht mehrere Befehle auf einer einzigen Referenzseite vermischt werden.

ABI und Zielplattform

PBXB64s C-Frontend zielt auf eine getestete C17/C23-Teilmenge fuer Windows x64. Benutzerfunktionen und externe Aufrufe werden fuer die Windows-x64-ABI gesenkt: Integer- und Zeigerargumente verwenden RCX, RDX, R8 und R9; Floating-Point-Argumente verwenden XMM0 bis XMM3; weitere Argumente liegen auf dem Stack. Diese ABI-Notiz ist fuer C/PB/ASM-Mischprogramme wichtig.

Portabilitaet

Portabilitaet: Die Hilfeseiten dokumentieren PBXB64s natives Windows-Ziel, nicht einen POSIX-C-Compiler. Vermeide Annahmen ueber Unix-Header, Hostprozessverhalten oder implementation-defined Groessen, sofern die jeweilige Einzelseite sie nicht ausdruecklich belegt.

Einzelseiten

  • #include
  • #define
  • #if / #ifdef
  • __LINE__ / __FILE__
  • -std=c17 / -std=c23

Pruefung

Die C-Seiten verweisen auf konkrete Beispiele oder Validierungstests. Neue C-Frontend-Behauptungen sollen erst nach einem fokussierten compile/link/run-Beleg in diese Referenz aufgenommen werden.

Beginne mit dieser Uebersicht, wenn du die passende Sprachform suchst, und wechsle dann auf die Einzelseite. Dort stehen die getestete Syntax, der begrenzte PBXB64-Umfang, bekannte Einschraenkungen und der konkrete Datei- oder Matrixbeleg.

Ein guter C-Beleg ist eine kleine, eigenstaendige Quelldatei mit Exitcode 0 fuer Erfolg, klarer Fehlerrueckgabe und nur den Headern, die das gezeigte Feature wirklich benoetigt.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C #include - Header einbinden — PBXB64 Help

Startseite › BASIC Frontend › C #include - Header einbinden — PBXB64 Help
Hilfe zum PBXB64-Compiler

C #include - Header einbinden

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

#include <stdio.h>

Beschreibung

Der Praeprozessor behandelt Standard- und projektlokale Include-Formen aus den Tests.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/test_pp_comprehensive.c

Abgedeckt durch tests/c/test_pp_comprehensive.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C #define - Makros definieren — PBXB64 Help

Startseite › BASIC Frontend › C #define - Makros definieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

C #define - Makros definieren

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

#define N 42

Beschreibung

Unterstuetzt object-like und function-like Makroersetzung in der implementierten Praeprozessor-Teilmenge.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/test_pp_comprehensive.c

Abgedeckt durch tests/c/test_pp_comprehensive.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C #if / #ifdef - Bedingt kompilieren — PBXB64 Help

Startseite › BASIC Frontend › C #if / #ifdef - Bedingt kompilieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

C #if / #ifdef - Bedingt kompilieren

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

#ifdef NAME

Beschreibung

Behandelt bedingte Praeprozessierung, inaktive C23-Token im C17-Modus und Diagnosefehler fuer abgelehnte modusspezifische Features.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/test_pp_comprehensive.c

Abgedeckt durch tests/c/test_pp_comprehensive.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C __LINE__ / __FILE__ - Quellort-Makros verwenden — PBXB64 Help

Startseite › BASIC Frontend › C __LINE__ / __FILE__ - Quellort-Makros verwenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

C __LINE__ / __FILE__ - Quellort-Makros verwenden

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

__LINE__

Beschreibung

Expandiert Quellort-Makros ueber den Praeprozessorpfad.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/test_line_file.c

Abgedeckt durch tests/c/test_line_file.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


C -std=c17 / -std=c23 - C-Sprachmodus waehlen — PBXB64 Help

Startseite › BASIC Frontend › C -std=c17 / -std=c23 - C-Sprachmodus waehlen — PBXB64 Help
Hilfe zum PBXB64-Compiler

C -std=c17 / -std=c23 - C-Sprachmodus waehlen

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

PBXB64 -std=c17 file.c

Beschreibung

Der Driver/Frontend-Modus unterstuetzt C17- und C23-Pruefungen; nicht unterstuetzte C23-Features schlagen mit expliziten Diagnosen fehl.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/c17_std_version.c

Abgedeckt durch tests/c/c17_std_version.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C Standardbibliothek — PBXB64 Help

Startseite › BASIC Frontend › C Standard Library

C Standardbibliothek

Diese Hub-Seite verweist auf einzelne C-Frontend-Seiten fuer implementierte, getestete Konstrukte.

Zweck

Die Seite ist bewusst ein Ueberblickskapitel. Details, Syntax, Grenzen und Validierungsbelege stehen auf den darunterliegenden Einzelseiten, damit nicht mehrere Befehle auf einer einzigen Referenzseite vermischt werden.

ABI und Zielplattform

PBXB64s C-Frontend zielt auf eine getestete C17/C23-Teilmenge fuer Windows x64. Benutzerfunktionen und externe Aufrufe werden fuer die Windows-x64-ABI gesenkt: Integer- und Zeigerargumente verwenden RCX, RDX, R8 und R9; Floating-Point-Argumente verwenden XMM0 bis XMM3; weitere Argumente liegen auf dem Stack. Diese ABI-Notiz ist fuer C/PB/ASM-Mischprogramme wichtig.

Portabilitaet

Portabilitaet: Die Hilfeseiten dokumentieren PBXB64s natives Windows-Ziel, nicht einen POSIX-C-Compiler. Vermeide Annahmen ueber Unix-Header, Hostprozessverhalten oder implementation-defined Groessen, sofern die jeweilige Einzelseite sie nicht ausdruecklich belegt.

Einzelseiten

  • stdio.h
  • string.h
  • stdlib.h
  • math.h
  • signal.h
  • time.h

Pruefung

Die C-Seiten verweisen auf konkrete Beispiele oder Validierungstests. Neue C-Frontend-Behauptungen sollen erst nach einem fokussierten compile/link/run-Beleg in diese Referenz aufgenommen werden.

Beginne mit dieser Uebersicht, wenn du die passende Sprachform suchst, und wechsle dann auf die Einzelseite. Dort stehen die getestete Syntax, der begrenzte PBXB64-Umfang, bekannte Einschraenkungen und der konkrete Datei- oder Matrixbeleg.

Ein guter C-Beleg ist eine kleine, eigenstaendige Quelldatei mit Exitcode 0 fuer Erfolg, klarer Fehlerrueckgabe und nur den Headern, die das gezeigte Feature wirklich benoetigt.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C stdio.h - Formatierte und Datei-E/A verwenden — PBXB64 Help

Startseite › BASIC Frontend › C stdio.h - Formatierte und Datei-E/A verwenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

C stdio.h - Formatierte und Datei-E/A verwenden

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

#include <stdio.h>

Beschreibung

C-stdio-Header und Runtime-Aufrufe sind durch write-, input-, fread- und printf-aehnliche Tests abgedeckt.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/c/test_write.c

Abgedeckt durch examples/c/test_write.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C string.h - String- und Speicherhelfer verwenden — PBXB64 Help

Startseite › BASIC Frontend › C string.h - String- und Speicherhelfer verwenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

C string.h - String- und Speicherhelfer verwenden

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

#include <string.h>

Beschreibung

Dokumentiert die getestete String-/Speicherhelfer-Oberflaeche fuer C-Programme.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/c/_str.c

Abgedeckt durch examples/c/_str.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


C stdlib.h - Allokations- und Konvertierungshelfer verwenden — PBXB64 Help

Startseite › BASIC Frontend › C stdlib.h - Allokations- und Konvertierungshelfer verwenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

C stdlib.h - Allokations- und Konvertierungshelfer verwenden

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

#include <stdlib.h>

Beschreibung

Deckt Allokations- und Hilfsfunktionen ab, die von den Validierungstests ausgeuebt werden.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/test_malloc.c

Abgedeckt durch tests/c/test_malloc.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C math.h - Math-Runtime-Funktionen verwenden — PBXB64 Help

Startseite › BASIC Frontend › C math.h - Math-Runtime-Funktionen verwenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

C math.h - Math-Runtime-Funktionen verwenden

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

#include <math.h>

Beschreibung

Math-Helfer werden ueber den Runtime-/Toolchain-Pfad der Science-Beispiele gelinkt.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/c/test_science_tier1.c

Abgedeckt durch examples/c/test_science_tier1.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C signal.h - Signal-Helfer verwenden — PBXB64 Help

Startseite › BASIC Frontend › C signal.h - Signal-Helfer verwenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

C signal.h - Signal-Helfer verwenden

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

#include <signal.h>

Beschreibung

Signal-Header-Abdeckung wird durch fokussierte C-Tests belegt.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/test_signal.c

Abgedeckt durch tests/c/test_signal.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C time.h - Zeit-Helfer verwenden — PBXB64 Help

Startseite › BASIC Frontend › C time.h - Zeit-Helfer verwenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

C time.h - Zeit-Helfer verwenden

Kind: Command | Category: C Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

#include <time.h>

Beschreibung

Time-Header-Abdeckung wird durch fokussierte C-Tests belegt.

Der gezeigte Ausschnitt ist absichtlich klein: Er isoliert genau das dokumentierte Sprachkonstrukt. Groessere Programme koennen dieses Konstrukt mit anderen getesteten C-Frontend-Features kombinieren, solange jede verwendete Form ebenfalls in der C-Referenz oder in der Validierungsmatrix belegt ist.

Nutzerbeleg: Die unten genannte Beispieldatei oder Validierungsspur ist der relevante Nachweis fuer dieses C-Sprachkonstrukt.

Verwendung im Programm

Schreiben Sie den Beispielcode so, dass das gezeigte Konstrukt direkt pruefbar ist und der Rest des Programms nur den notwendigen Rahmen bildet. Wenn das Sprachkonstrukt einen Wert liefert, zeigen Sie die exakte Weiterverarbeitung dieses Werts; wenn es ein Statement ist, zeigen Sie die sichtbare Auswirkung auf Variablen, Speicher oder Kontrollfluss.

Fehlerfaelle

Dokumentieren Sie die wichtigsten Grenzfaelle: ungueltige Operanden, unpassende Typen, fehlende Labels oder nicht unterstuetzte Moduskombinationen. Wenn das Konstrukt in einem Programm leicht missverstanden werden kann, sollte das Beispiel den Rueckgabewert oder den Zustand zeigen, den der Aufrufer nach einem Fehlschlag erwartet.

Verifiziertes Beispiel

Verifiziertes Beispiel: tests/c/test_time.c

Abgedeckt durch tests/c/test_time.c in der C-Validierungsmatrix.

Zum Nachpruefen eine fokussierte Datei mit PBXB64 kompilieren und die erzeugte EXE ausfuehren. Ein Exitcode von 0 ist der erwartete erfolgreiche Pfad fuer die Hilfe-Beispiele.

Grenzen

Diese Seite beschreibt nur die in PBXB64 implementierte und getestete C-Teilmenge. Vollstaendige C-Compiler-Kompatibilitaet wird hier nicht behauptet.

Siehe auch

  • C Language Overview
  • C Data Types
  • C Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PBXB64 – B64-Sprachreferenz

Startseite› B64-Frontend

B64-Sprachreferenz

B64 ist eine C-ähnliche Systemprogrammiersprache und das primäre Frontend von PBXB64. Es bietet explizite Speicherverwaltung, erstklassige Zeiger, Strukturen und direkte IR-Integration.

Referenzseiten

Diese Seite ist die Uebersicht zum Frontend. Die verlinkten Einzelseiten enthalten Syntax, getestete Beispiele, Status und Grenzen fuer die jeweiligen Befehle oder Sprachkonstrukte.

  • Datentypen
  • Variablen
  • Funktionen
  • Kontrollfluss
  • Structs und Arrays
  • Pointer
  • Inline-ASM
  • Operatoren

Funktionssyntax

fn name(params): return_type { body }
fn add(a: i32, b: i32): i32 {
    return a + b;
}

fn main(): i32 {
    let result: i32 = add(10, 20);
    return result;
}

Primitive Datentypen

Typ | Größe | Beschreibung
i8 | 1 Byte | Vorzeichenbehaftete 8-Bit-Ganzzahl (-128 bis 127)
i16 | 2 Bytes | Vorzeichenbehaftete 16-Bit-Ganzzahl
i32 | 4 Bytes | Vorzeichenbehaftete 32-Bit-Ganzzahl (Standard int)
i64 | 8 Byte | Vorzeichenbehaftete 64-Bit-Ganzzahl
u8 | 1 Byte | Vorzeichenlose 8-Bit-Ganzzahl (0 bis 255)
u16 | 2 Bytes | Vorzeichenlose 16-Bit-Ganzzahl
u32 | 4 Bytes | Vorzeichenlose 32-Bit-Ganzzahl
u64 | 8 Byte | Vorzeichenlose 64-Bit-Ganzzahl
bool | 1 Byte | Boolescher Wert (wahr/falsch)
f32 | 4 Bytes | IEEE 754-Float mit einfacher Genauigkeit
f64 | 8 Byte | IEEE 754-Float mit doppelter Genauigkeit

Zeiger und Dereferenzierung

sei p: *type = &variable
fn main(): i32 {
    let x: i32 = 42;
    let p: *i32 = &x
    *p = 100;       // dereference write
    return *p;      // dereference read -> 100
}

Strukturen

struct Point {
    x: i32,
    y: i32,
}

fn main(): i32 {
    let p: Point = Point { x: 10, y: 20 };
    return p.x + p.y;
}

Kontrollfluss

// Conditional
if condition { body } else { body }

// Looping
while expr { body }
for let i: i32 = start; i < end; i = i + step { body }

// Return
return expression;
return; // void return

Externe Funktionen (FFI)

extern "kernel32.dll" fn Sleep(dwMilliseconds: u32): void;
extern "user32.dll" fn MessageBoxA(hWnd: *void, lpText: *u8, lpCaption: *u8, uType: u32): i32;
Speichermodell:B64 verwendet die explizite Zuweisung überalloc/deallocEigenheiten. Stapelvariablen sind automatisch. Zeiger müssen vor der Dereferenzierung im abgesicherten Modus validiert werden.
← CLI-Optionen BASIC-Referenz → Beispiele ansehen
PBXB64-Compiler-Dokumentation · V8 Native Edition · Zuletzt aktualisiert am 15.01.2026
Für Fragen und Beiträge:smart-package.com

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


B64 Datentypen — PBXB64 Help

Startseite › BASIC Frontend › B64 Data Types

B64 Datentypen

Kind: Reference hub | Category: B64-Frontend

PBXB64-Status: AVAILABLE

PBXB64-Zertifizierung: [CERTIFIED TESTED] Uebersichtsseite fuer die getestete B64-Frontend-Teilmenge; die verlinkten Unterseiten und examples/b64-Proben liefern den konkreten Nachweis.

B64 ist ein nativer System-Frontend mit expliziten Typen fester Breite, Zeigern, Arrays, Strukturen, Varianten und Typaliasen.

  • i64 - 64-Bit-Ganzzahltyp
  • bool - boolescher Typ
  • void - Typ ohne Wert
  • struct - Aggregattyp
  • variant - getaggte Union
  • typedef - Typalias

Syntax

#B64
// Verwenden Sie die verlinkten B64-Konstrukte in einer vollstaendigen B64-Quelldatei.
#B64 END

Beschreibung

Diese Seite ist die Uebersicht fuer eine B64-Funktionsgruppe. Die untergeordneten Seiten enthalten die konkrete Befehlssyntax, fokussierte Verhaltenshinweise und das Getestetes Beispiel, welches die Implementierung in der Validierungsmatrix belegt.

Beispiel

fn main(): i64 {
    let answer: i64 = 42;
    return answer;
}

Verifiziertes Beispiel

Repraesentative B64-Beispiele liegen unter examples/b64 und werden von der b64_linkrun-Validierungsspur kompiliert und ausgefuehrt.

Verwendung dieses Unterkapitels

Diese Seite ist die Uebersicht fuer eine B64-Funktionsgruppe. Die untergeordneten Seiten enthalten die konkrete Befehlssyntax, fokussierte Verhaltenshinweise und das Getestetes Beispiel, welches die Implementierung in der Validierungsmatrix belegt.

Verifizierungsmodell

Die verlinkten Befehlsseiten nennen Beispiele aus examples/b64. Diese Programme werden von der b64_linkrun-Spur kompiliert und ausgefuehrt, damit die Dokumentation an das aktuelle Compilerverhalten gebunden bleibt und keine statische Sprachskizze ist.

Frontend-Grenze

B64 ist das native System-Frontend von PBXB64. Diese Seiten beschreiben die getestete PBXB64-Teilmenge und ihre Senkung in native IR; sie versprechen keine Kompatibilitaet mit einer separaten externen Sprache oder Runtime.

Grenzen

Nur Konstrukte, die durch aktuelle B64-Quellen und registrierte Validierungstests belegt sind, sollen als zertifiziert beschrieben werden. Nicht unterstuetzte Sprachideen bleiben Backlog, bis Quellcode-, Test- und Hilfenachweis vorhanden sind.

Siehe auch

B64-Sprachuebersicht | fn | Operatoren

← Back

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


B64 i64 - 64-Bit-Ganzzahltyp — PBXB64 Help

Startseite › BASIC Frontend › B64 i64 - 64-Bit-Ganzzahltyp — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 i64 - 64-Bit-Ganzzahltyp

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

let x: i64 = 42;

Beschreibung

Der primaere Ganzzahltyp in den aktuellen Beispielen und vielen Frontend-Tests.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/answer.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 bool - boolescher Typ — PBXB64 Help

Startseite › BASIC Frontend › B64 bool - boolescher Typ — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 bool - boolescher Typ

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

let ok: bool = true;

Beschreibung

Speichert boolesche Wahrheitswerte und wird in Bedingungspruefungen verwendet.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/array_bool.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 true - Boolesches true-Literal — PBXB64 Help

Startseite › BASIC Frontend › B64 true - Boolesches true-Literal — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 true - Boolesches true-Literal

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

let ok: bool = true;

Beschreibung

Boolesches true-Literal.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/array_bool.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 false - Boolesches false-Literal — PBXB64 Help

Startseite › BASIC Frontend › B64 false - Boolesches false-Literal — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 false - Boolesches false-Literal

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

let ok: bool = false;

Beschreibung

Boolesches false-Literal.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/array_bool.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 void - Typ ohne Wert — PBXB64 Help

Startseite › BASIC Frontend › B64 void - Typ ohne Wert — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 void - Typ ohne Wert

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

fn log(): void { return; }

Beschreibung

Repraesentiert ein Funktionsergebnis ohne Wert oder eine Position ohne Payload, wo zutreffend.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/call.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 typedef - Typalias — PBXB64 Help

Startseite › BASIC Frontend › B64 typedef - Typalias — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 typedef - Typalias

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

typedef Count = i64;

Beschreibung

Erzeugt einen benannten Alias fuer einen vorhandenen B64-Typ. Typaliasse werden vom B64-Frontend lexikalisiert und geparst.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/generic_identity.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


B64 Variablen — PBXB64 Help

Startseite › BASIC Frontend › B64 Variables

B64 Variablen

Kind: Reference hub | Category: B64-Frontend

PBXB64-Status: AVAILABLE

PBXB64-Zertifizierung: [CERTIFIED TESTED] Uebersichtsseite fuer die getestete B64-Frontend-Teilmenge; die verlinkten Unterseiten und examples/b64-Proben liefern den konkreten Nachweis.

B64 besitzt unveraenderliche lokale Bindungen, veraenderliche Bindungen, Konstanten und Globals. Diese Seiten beschreiben die in PBXB64 implementierte Teilmenge.

  • let - unveraenderliche lokale Bindung
  • var - veraenderliche lokale oder globale Bindung
  • const - Compilezeit-Konstante
  • extern - importierte Symboldeklaration

Syntax

#B64
// Verwenden Sie die verlinkten B64-Konstrukte in einer vollstaendigen B64-Quelldatei.
#B64 END

Beschreibung

Diese Seite ist die Uebersicht fuer eine B64-Funktionsgruppe. Die untergeordneten Seiten enthalten die konkrete Befehlssyntax, fokussierte Verhaltenshinweise und das Getestetes Beispiel, welches die Implementierung in der Validierungsmatrix belegt.

Beispiel

fn main(): i64 {
    let answer: i64 = 42;
    return answer;
}

Verifiziertes Beispiel

Repraesentative B64-Beispiele liegen unter examples/b64 und werden von der b64_linkrun-Validierungsspur kompiliert und ausgefuehrt.

Verwendung dieses Unterkapitels

Diese Seite ist die Uebersicht fuer eine B64-Funktionsgruppe. Die untergeordneten Seiten enthalten die konkrete Befehlssyntax, fokussierte Verhaltenshinweise und das Getestetes Beispiel, welches die Implementierung in der Validierungsmatrix belegt.

Verifizierungsmodell

Die verlinkten Befehlsseiten nennen Beispiele aus examples/b64. Diese Programme werden von der b64_linkrun-Spur kompiliert und ausgefuehrt, damit die Dokumentation an das aktuelle Compilerverhalten gebunden bleibt und keine statische Sprachskizze ist.

Frontend-Grenze

B64 ist das native System-Frontend von PBXB64. Diese Seiten beschreiben die getestete PBXB64-Teilmenge und ihre Senkung in native IR; sie versprechen keine Kompatibilitaet mit einer separaten externen Sprache oder Runtime.

Grenzen

Nur Konstrukte, die durch aktuelle B64-Quellen und registrierte Validierungstests belegt sind, sollen als zertifiziert beschrieben werden. Nicht unterstuetzte Sprachideen bleiben Backlog, bis Quellcode-, Test- und Hilfenachweis vorhanden sind.

Siehe auch

B64-Sprachuebersicht | fn | Operatoren

← Back

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


B64 let - unveraenderliche lokale Bindung — PBXB64 Help

Startseite › BASIC Frontend › B64 let - unveraenderliche lokale Bindung — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 let - unveraenderliche lokale Bindung

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

let answer: i64 = 42;

Beschreibung

Fuehrt eine lokale Bindung mit Initialisierer ein. Das aktuelle Frontend speichert den Wert in nativer IR-Speicherung und weist inkompatible Nutzungen beim Parsen/Senken zurueck.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/answer.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 var - veraenderliche Bindung — PBXB64 Help

Startseite › BASIC Frontend › B64 var - veraenderliche Bindung — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 var - veraenderliche Bindung

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

var total: i64 = 0;

Beschreibung

Fuehrt veraenderlichen lokalen oder globalen Speicher ein. Die Validierung deckt veraenderliche Schleifenzaehler, globale Daten und globale Initialisierungsausdruecke ab.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/loop_control.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 const - Compilezeit-Konstante — PBXB64 Help

Startseite › BASIC Frontend › B64 const - Compilezeit-Konstante — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 const - Compilezeit-Konstante

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

const ONE: i64 = 1;

Beschreibung

Deklariert einen konstanten Wert, der von spaeteren B64-Ausdruecken und Varianten-Tests verwendet werden kann.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/variant_const.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 extern - externe Symboldeklaration — PBXB64 Help

Startseite › BASIC Frontend › B64 extern - externe Symboldeklaration — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 extern - externe Symboldeklaration

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

extern fn host_add(a: i64, b: i64): i64;

Beschreibung

Deklariert eine externe Funktion oder ein Datensymbol zum Linken mit Host-Objekten und Runtime-Helfern.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/asm_un_runtime_access.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 Funktionen — PBXB64 Help

Startseite › BASIC Frontend › B64 Functions

B64 Funktionen

Kind: Reference hub | Category: B64-Frontend

PBXB64-Status: AVAILABLE

PBXB64-Zertifizierung: [CERTIFIED TESTED] Uebersichtsseite fuer die getestete B64-Frontend-Teilmenge; die verlinkten Unterseiten und examples/b64-Proben liefern den konkreten Nachweis.

Funktionen werden mit fn deklariert, in PBXB64-IR gesenkt und verwenden die Win64-ABI. Aggregat-Rueckgaben und Parameter sind durch fokussierte Beispiele abgedeckt.

  • fn - Funktionsdeklaration
  • return - Funktionsergebnis
  • extern - externe Funktion oder Daten

Syntax

#B64
// Verwenden Sie die verlinkten B64-Konstrukte in einer vollstaendigen B64-Quelldatei.
#B64 END

Beschreibung

Diese Seite ist die Uebersicht fuer eine B64-Funktionsgruppe. Die untergeordneten Seiten enthalten die konkrete Befehlssyntax, fokussierte Verhaltenshinweise und das Getestetes Beispiel, welches die Implementierung in der Validierungsmatrix belegt.

Beispiel

fn main(): i64 {
    let answer: i64 = 42;
    return answer;
}

Verifiziertes Beispiel

Repraesentative B64-Beispiele liegen unter examples/b64 und werden von der b64_linkrun-Validierungsspur kompiliert und ausgefuehrt.

Verwendung dieses Unterkapitels

Diese Seite ist die Uebersicht fuer eine B64-Funktionsgruppe. Die untergeordneten Seiten enthalten die konkrete Befehlssyntax, fokussierte Verhaltenshinweise und das Getestetes Beispiel, welches die Implementierung in der Validierungsmatrix belegt.

Verifizierungsmodell

Die verlinkten Befehlsseiten nennen Beispiele aus examples/b64. Diese Programme werden von der b64_linkrun-Spur kompiliert und ausgefuehrt, damit die Dokumentation an das aktuelle Compilerverhalten gebunden bleibt und keine statische Sprachskizze ist.

Frontend-Grenze

B64 ist das native System-Frontend von PBXB64. Diese Seiten beschreiben die getestete PBXB64-Teilmenge und ihre Senkung in native IR; sie versprechen keine Kompatibilitaet mit einer separaten externen Sprache oder Runtime.

Grenzen

Nur Konstrukte, die durch aktuelle B64-Quellen und registrierte Validierungstests belegt sind, sollen als zertifiziert beschrieben werden. Nicht unterstuetzte Sprachideen bleiben Backlog, bis Quellcode-, Test- und Hilfenachweis vorhanden sind.

Siehe auch

B64-Sprachuebersicht | fn | Operatoren

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 fn - Funktionsdeklaration — PBXB64 Help

Startseite › BASIC Frontend › B64 fn - Funktionsdeklaration — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 fn - Funktionsdeklaration

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

fn add(a: i64, b: i64): i64 { return a + b; }

Beschreibung

Deklariert eine native B64-Funktion. Aufrufe und Rueckgaben folgen der Win64-ABI, mit fokussierter Abdeckung fuer fuenf, sechs und sieben Argumente sowie Aggregat-Rueckgaben und -Parameter.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/call_add.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 return - Funktionsergebnis — PBXB64 Help

Startseite › BASIC Frontend › B64 return - Funktionsergebnis — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 return - Funktionsergebnis

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

return sum;

Beschreibung

Gibt einen Skalar-, Zeiger-, Aggregat-, Array- oder Variantenwert aus der aktuellen Funktion zurueck. Aggregatfaelle verwenden bei Bedarf den versteckten sret-Pfad des Frontends.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/answer.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 Kontrollfluss — PBXB64 Help

Startseite › BASIC Frontend › B64 Control Flow

B64 Kontrollfluss

Kind: Reference hub | Category: B64-Frontend

PBXB64-Status: AVAILABLE

PBXB64-Zertifizierung: [CERTIFIED TESTED] Uebersichtsseite fuer die getestete B64-Frontend-Teilmenge; die verlinkten Unterseiten und examples/b64-Proben liefern den konkreten Nachweis.

B64 bietet C-aehnlichen strukturierten Kontrollfluss und Varianten-Matching im nativen Frontend.

  • if - bedingter Zweig
  • else - Alternativzweig
  • while - bedingte Schleife
  • for - Zaehlschleife
  • break - Schleife verlassen
  • continue - Schleife fortsetzen
  • match - Variant-Tag-Auswahl

Syntax

#B64
// Verwenden Sie die verlinkten B64-Konstrukte in einer vollstaendigen B64-Quelldatei.
#B64 END

Beschreibung

Diese Seite ist die Uebersicht fuer eine B64-Funktionsgruppe. Die untergeordneten Seiten enthalten die konkrete Befehlssyntax, fokussierte Verhaltenshinweise und das Getestetes Beispiel, welches die Implementierung in der Validierungsmatrix belegt.

Beispiel

fn main(): i64 {
    let answer: i64 = 42;
    return answer;
}

Verifiziertes Beispiel

Repraesentative B64-Beispiele liegen unter examples/b64 und werden von der b64_linkrun-Validierungsspur kompiliert und ausgefuehrt.

Verwendung dieses Unterkapitels

Diese Seite ist die Uebersicht fuer eine B64-Funktionsgruppe. Die untergeordneten Seiten enthalten die konkrete Befehlssyntax, fokussierte Verhaltenshinweise und das Getestetes Beispiel, welches die Implementierung in der Validierungsmatrix belegt.

Verifizierungsmodell

Die verlinkten Befehlsseiten nennen Beispiele aus examples/b64. Diese Programme werden von der b64_linkrun-Spur kompiliert und ausgefuehrt, damit die Dokumentation an das aktuelle Compilerverhalten gebunden bleibt und keine statische Sprachskizze ist.

Frontend-Grenze

B64 ist das native System-Frontend von PBXB64. Diese Seiten beschreiben die getestete PBXB64-Teilmenge und ihre Senkung in native IR; sie versprechen keine Kompatibilitaet mit einer separaten externen Sprache oder Runtime.

Grenzen

Nur Konstrukte, die durch aktuelle B64-Quellen und registrierte Validierungstests belegt sind, sollen als zertifiziert beschrieben werden. Nicht unterstuetzte Sprachideen bleiben Backlog, bis Quellcode-, Test- und Hilfenachweis vorhanden sind.

Siehe auch

B64-Sprachuebersicht | fn | Operatoren

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 if - bedingter Zweig — PBXB64 Help

Startseite › BASIC Frontend › B64 if - bedingter Zweig — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 if - bedingter Zweig

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

if (x == 1) { return 2; }

Beschreibung

Verzweigt anhand einer Integer- oder Bool-Bedingung und wird zu nativen bedingten Kontrollfluss-Bloecken gesenkt.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/if_else.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 else - Alternativzweig — PBXB64 Help

Startseite › BASIC Frontend › B64 else - Alternativzweig — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 else - Alternativzweig

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

if (x) { return 1; } else { return 0; }

Beschreibung

Stellt den Alternativzweig einer if-Anweisung bereit. Verschachtelte und lineare Verwendungen werden als separate IR-Bloecke dargestellt.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/if_else.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 while - bedingte Schleife — PBXB64 Help

Startseite › BASIC Frontend › B64 while - bedingte Schleife — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 while - bedingte Schleife

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

while (i < 10) { i = i + 1; }

Beschreibung

Wiederholt einen Block, solange die Bedingung wahr bleibt. Break und Continue zielen auf den aktiven Schleifenrahmen.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/loop_control.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 for - Zaehlschleife — PBXB64 Help

Startseite › BASIC Frontend › B64 for - Zaehlschleife — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 for - Zaehlschleife

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

for (var i: i64 = 0; i < 10; i = i + 1) { }

Beschreibung

Parst C-aehnliche Init/Bedingung/Schritt-Schleifen und senkt sie ueber dieselbe Schleifenrahmen-Logik wie while.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/loop_control.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 break - Schleife verlassen — PBXB64 Help

Startseite › BASIC Frontend › B64 break - Schleife verlassen — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 break - Schleife verlassen

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

break;

Beschreibung

Springt zum Exit-Block der aktuellen Schleife.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/loop_control.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 continue - Schleife fortsetzen — PBXB64 Help

Startseite › BASIC Frontend › B64 continue - Schleife fortsetzen — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 continue - Schleife fortsetzen

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

continue;

Beschreibung

Springt zum Continue- beziehungsweise Schrittblock der aktuellen Schleife.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/loop_control.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 match - Variant-Tag-Auswahl — PBXB64 Help

Startseite › BASIC Frontend › B64 match - Variant-Tag-Auswahl — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 match - Variant-Tag-Auswahl

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

match (value) { A(x) => return x; B => return 0; }

Beschreibung

Verzweigt anhand eines Variant-Tags und bindet Payloads in implementierten Faellen. Nicht-erschoepfendes Verhalten ist separat getestet.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/match_variant.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 Zeiger und Ausdruecke — PBXB64 Help

Startseite › BASIC Frontend › B64 Pointers and Expressions

B64 Zeiger und Ausdruecke

Kind: Reference hub | Category: B64-Frontend

PBXB64-Status: AVAILABLE

PBXB64-Zertifizierung: [CERTIFIED TESTED] Uebersichtsseite fuer die getestete B64-Frontend-Teilmenge; die verlinkten Unterseiten und examples/b64-Proben liefern den konkreten Nachweis.

Zeiger-, Cast-, Groessen- und arithmetische Ausdruecke werden direkt in native IR-Operationen gesenkt.

  • cast - explizite Konvertierung
  • sizeof - Compilezeit-Groessenabfrage
  • Operatoren - Arithmetik, Bitoperationen und Vergleiche

Syntax

#B64
// Verwenden Sie die verlinkten B64-Konstrukte in einer vollstaendigen B64-Quelldatei.
#B64 END

Beschreibung

Diese Seite ist die Uebersicht fuer eine B64-Funktionsgruppe. Die untergeordneten Seiten enthalten die konkrete Befehlssyntax, fokussierte Verhaltenshinweise und das Getestetes Beispiel, welches die Implementierung in der Validierungsmatrix belegt.

Beispiel

fn main(): i64 {
    let answer: i64 = 42;
    return answer;
}

Verifiziertes Beispiel

Repraesentative B64-Beispiele liegen unter examples/b64 und werden von der b64_linkrun-Validierungsspur kompiliert und ausgefuehrt.

Verwendung dieses Unterkapitels

Diese Seite ist die Uebersicht fuer eine B64-Funktionsgruppe. Die untergeordneten Seiten enthalten die konkrete Befehlssyntax, fokussierte Verhaltenshinweise und das Getestetes Beispiel, welches die Implementierung in der Validierungsmatrix belegt.

Verifizierungsmodell

Die verlinkten Befehlsseiten nennen Beispiele aus examples/b64. Diese Programme werden von der b64_linkrun-Spur kompiliert und ausgefuehrt, damit die Dokumentation an das aktuelle Compilerverhalten gebunden bleibt und keine statische Sprachskizze ist.

Frontend-Grenze

B64 ist das native System-Frontend von PBXB64. Diese Seiten beschreiben die getestete PBXB64-Teilmenge und ihre Senkung in native IR; sie versprechen keine Kompatibilitaet mit einer separaten externen Sprache oder Runtime.

Grenzen

Nur Konstrukte, die durch aktuelle B64-Quellen und registrierte Validierungstests belegt sind, sollen als zertifiziert beschrieben werden. Nicht unterstuetzte Sprachideen bleiben Backlog, bis Quellcode-, Test- und Hilfenachweis vorhanden sind.

Siehe auch

B64-Sprachuebersicht | fn | Operatoren

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 cast - explizite Konvertierung — PBXB64 Help

Startseite › BASIC Frontend › B64 cast - explizite Konvertierung — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 cast - explizite Konvertierung

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

let y: i64 = cast(i64, x);

Beschreibung

Fuehrt explizite skalare Konvertierung in Ausdruecken aus, wenn das Frontend einen konkreten Zieltyp hat.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/div_rem.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 sizeof - Compilezeit-Groessenabfrage — PBXB64 Help

Startseite › BASIC Frontend › B64 sizeof - Compilezeit-Groessenabfrage — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 sizeof - Compilezeit-Groessenabfrage

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

let n: i64 = sizeof(i64);

Beschreibung

Berechnet die Bytegroesse eines B64-Typs oder einer unterstuetzten Operandenform waehrend der Frontend-Senkung.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/struct_mixed.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


B64 operators - Arithmetik, Bitoperationen und Vergleiche — PBXB64 Help

Startseite › BASIC Frontend › B64 operators - Arithmetik, Bitoperationen und Vergleiche — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 operators - Arithmetik, Bitoperationen und Vergleiche

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

x = (a + b) * 2;

Beschreibung

Deckt Arithmetik, Rest, Shifts, Bitoperationen, Vergleiche, logische Formen und zusammengesetzte Zuweisungen des Ausdrucksparsers ab.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/div_rem.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 Aggregate — PBXB64 Help

Startseite › BASIC Frontend › B64 Aggregates

B64 Aggregate

Kind: Reference hub | Category: B64-Frontend

PBXB64-Status: AVAILABLE

PBXB64-Zertifizierung: [CERTIFIED TESTED] Uebersichtsseite fuer die getestete B64-Frontend-Teilmenge; die verlinkten Unterseiten und examples/b64-Proben liefern den konkreten Nachweis.

Arrays, Strukturen und Varianten verwenden dieselbe native Aggregat- und ABI-Logik wie die anderen PBXB64-Frontends.

  • struct - Aggregat mit benannten Feldern
  • variant - getaggtes Payload-Aggregat
  • array - indizierter Speicher fester Groesse

Syntax

#B64
// Verwenden Sie die verlinkten B64-Konstrukte in einer vollstaendigen B64-Quelldatei.
#B64 END

Beschreibung

Diese Seite ist die Uebersicht fuer eine B64-Funktionsgruppe. Die untergeordneten Seiten enthalten die konkrete Befehlssyntax, fokussierte Verhaltenshinweise und das Getestetes Beispiel, welches die Implementierung in der Validierungsmatrix belegt.

Beispiel

fn main(): i64 {
    let answer: i64 = 42;
    return answer;
}

Verifiziertes Beispiel

Repraesentative B64-Beispiele liegen unter examples/b64 und werden von der b64_linkrun-Validierungsspur kompiliert und ausgefuehrt.

Verwendung dieses Unterkapitels

Diese Seite ist die Uebersicht fuer eine B64-Funktionsgruppe. Die untergeordneten Seiten enthalten die konkrete Befehlssyntax, fokussierte Verhaltenshinweise und das Getestetes Beispiel, welches die Implementierung in der Validierungsmatrix belegt.

Verifizierungsmodell

Die verlinkten Befehlsseiten nennen Beispiele aus examples/b64. Diese Programme werden von der b64_linkrun-Spur kompiliert und ausgefuehrt, damit die Dokumentation an das aktuelle Compilerverhalten gebunden bleibt und keine statische Sprachskizze ist.

Frontend-Grenze

B64 ist das native System-Frontend von PBXB64. Diese Seiten beschreiben die getestete PBXB64-Teilmenge und ihre Senkung in native IR; sie versprechen keine Kompatibilitaet mit einer separaten externen Sprache oder Runtime.

Grenzen

Nur Konstrukte, die durch aktuelle B64-Quellen und registrierte Validierungstests belegt sind, sollen als zertifiziert beschrieben werden. Nicht unterstuetzte Sprachideen bleiben Backlog, bis Quellcode-, Test- und Hilfenachweis vorhanden sind.

Siehe auch

B64-Sprachuebersicht | fn | Operatoren

← Back

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


B64 array - indizierter Speicher fester Groesse — PBXB64 Help

Startseite › BASIC Frontend › B64 array - indizierter Speicher fester Groesse — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 array - indizierter Speicher fester Groesse

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

var xs: [3]i64 = [1, 2, 3];

Beschreibung

Definiert indizierten Speicher fester Groesse. Die Validierung deckt Array-Rueckgabe und einfache indizierte Berechnung ab.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/array_return.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


B64 struct - Aggregat mit benannten Feldern — PBXB64 Help

Startseite › BASIC Frontend › B64 struct - Aggregat mit benannten Feldern — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 struct - Aggregat mit benannten Feldern

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

struct Pair { a: i64; b: i64; }

Beschreibung

Definiert einen benannten Aggregattyp mit Feldzugriff, Aggregat-Initialisierung, Aggregat-Rueckgabe und Aggregat-Parameterabdeckung.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/struct_aggregate.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


B64 variant - getaggte Union — PBXB64 Help

Startseite › BASIC Frontend › B64 variant - getaggte Union — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 variant - getaggte Union

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

variant Value { A(i64), B }

Beschreibung

Definiert einen getaggten Wert mit Unit- oder Payload-Faellen. Variant-Tag und Payload-Senkung sind durch fokussierte Beispiele abgedeckt.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/variant_payload.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


B64 Inline-Assembler — PBXB64 Help

Startseite › BASIC Frontend › B64 Inline Assembly

B64 Inline-Assembler

Kind: Reference hub | Category: B64-Frontend

PBXB64-Status: AVAILABLE

PBXB64-Zertifizierung: [CERTIFIED TESTED] Uebersichtsseite fuer die getestete B64-Frontend-Teilmenge; die verlinkten Unterseiten und examples/b64-Proben liefern den konkreten Nachweis.

B64-Inline-Assembler ist auf der Befehlsseite dokumentiert und durch viele fokussierte ASM-Beispiele in der B64-Validierungsspur abgedeckt.

  • asm - Inline-x64-Assemblerblock

Syntax

#B64
// Verwenden Sie die verlinkten B64-Konstrukte in einer vollstaendigen B64-Quelldatei.
#B64 END

Beschreibung

Diese Seite ist die Uebersicht fuer eine B64-Funktionsgruppe. Die untergeordneten Seiten enthalten die konkrete Befehlssyntax, fokussierte Verhaltenshinweise und das Getestetes Beispiel, welches die Implementierung in der Validierungsmatrix belegt.

Beispiel

fn main(): i64 {
    let answer: i64 = 42;
    return answer;
}

Verifiziertes Beispiel

Repraesentative B64-Beispiele liegen unter examples/b64 und werden von der b64_linkrun-Validierungsspur kompiliert und ausgefuehrt.

Verwendung dieses Unterkapitels

Diese Seite ist die Uebersicht fuer eine B64-Funktionsgruppe. Die untergeordneten Seiten enthalten die konkrete Befehlssyntax, fokussierte Verhaltenshinweise und das Getestetes Beispiel, welches die Implementierung in der Validierungsmatrix belegt.

Verifizierungsmodell

Die verlinkten Befehlsseiten nennen Beispiele aus examples/b64. Diese Programme werden von der b64_linkrun-Spur kompiliert und ausgefuehrt, damit die Dokumentation an das aktuelle Compilerverhalten gebunden bleibt und keine statische Sprachskizze ist.

Frontend-Grenze

B64 ist das native System-Frontend von PBXB64. Diese Seiten beschreiben die getestete PBXB64-Teilmenge und ihre Senkung in native IR; sie versprechen keine Kompatibilitaet mit einer separaten externen Sprache oder Runtime.

Grenzen

Nur Konstrukte, die durch aktuelle B64-Quellen und registrierte Validierungstests belegt sind, sollen als zertifiziert beschrieben werden. Nicht unterstuetzte Sprachideen bleiben Backlog, bis Quellcode-, Test- und Hilfenachweis vorhanden sind.

Siehe auch

B64-Sprachuebersicht | fn | Operatoren

← Back

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.


B64 asm - Inline-x64-Assemblerblock — PBXB64 Help

Startseite › BASIC Frontend › B64 asm - Inline-x64-Assemblerblock — PBXB64 Help
Hilfe zum PBXB64-Compiler

B64 asm - Inline-x64-Assemblerblock

Kind: Command | Category: B64 Frontend

PBXB64 Status: [CERTIFIED TESTED]

Syntax

asm { mov rax, 42 }

Beschreibung

Bettet einen x64-Assemblerblock in B64 ein. Die Validierung enthaelt viele Beispiele fuer Instruktionsfamilien.

Nutzerbeleg: Die unten genannte Beispieldatei ist der relevante Nachweis fuer dieses Sprachkonstrukt.

Verifiziertes Beispiel

Kompiliert und ausgefuehrt durch examples/b64/asm_jcc_all.b64 in der b64_linkrun-Validierungsspur.

Verwendungshinweise

Nutzen Sie die gezeigte Form als kleinste dokumentierte Schreibweise und lesen Sie die genannte Beispieldatei, wenn Sie sehen wollen, wie der Befehl in einem vollstaendigen Programm eingebettet wird. Die B64-Seiten dokumentieren bewusst die getestete PBXB64-Teilmenge, nicht alle denkbaren Schreibweisen einer aehnlichen Sprache.

Grenzen

Diese Seite behauptet nur die durch den B64-Frontend-Code und die fokussierten Beispiele belegte PBXB64-Teilmenge. Sie ist keine Zusage vollstaendiger Kompatibilitaet mit einer externen Sprache.

B64-Frontend-Semantik

Dieses Schlüsselwort wird vom B64-Frontend geparst und vor der x64-Codeerzeugung in die native PBXB64-IR abgesenkt. Die dokumentierte Syntax ist die akzeptierte B64-Quellform; Beispiele sollen als .b64-Dateien gespeichert und mit PBXB64 beispiel.b64 -o beispiel.exe kompiliert werden.

Typ- und Kontrollflussregeln

Prüfen Sie den deklarierten Typ jedes Ausdrucks, der an diesem Schlüsselwort beteiligt ist. Kontrollfluss-Schlüsselwörter wirken nur auf das innerste passende Konstrukt, sofern die Seite nichts anderes sagt. Typ-Schlüsselwörter und Aliase beeinflussen Compile-Time-Prüfung und Layout, nicht dynamische Laufzeitdispatches.

Vollständiges Testprogramm

Ein vollständiges B64-Beispiel soll fn main(): i64 enthalten, einen vorhersagbaren Exit-Code liefern und keine externen Bibliotheken benötigen, sofern die Seite die Linkage nicht ausdrücklich dokumentiert. Wenn ein Verhalten keine Konsolenausgabe erzeugt, verwenden Sie den Prozess-Exit-Code als Prüfergebnis.

Diagnosen und Grenzen

Bei fehlerhafter Syntax oder verletzten Typregeln soll PBXB64 die Quelle beim Parsen, bei der semantischen Prüfung oder bei der IR-Verifikation ablehnen. Halten Sie Grenzen ausdrücklich fest: Beschreiben Sie ein Schlüsselwort nicht als allgemein unterstützt, wenn nur eine engere B64-Teilmenge verifiziert wurde.

Siehe auch

  • B64 Language Overview
  • B64 Data Types
  • B64 Control Flow

← Back

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.


PBXB64 – PILOT-Sprachreferenz

Startseite › PILOT-Frontend

PILOT-Sprachreferenz

PILOT ist eine pädagogische Programmiersprache, die von PBXB64 als Standalone-Version unterstützt wird .pil Dateien. Der Compiler erstellt native ausführbare Windows x64-Dateien aus dem PILOT-Quellcode über das einheitliche IR-Backend.

Dateierweiterung: Speichern Sie PILOT-Programme mit dem .pil Erweiterung. Kompilieren mit PBXB64 program.pil -o program.exe.

Referenzseiten

Diese Seite ist die Uebersicht zum Frontend. Die Abschnitte darunter verweisen auf eigene Befehls- oder Referenzseiten; getestete Beispiele und Grenzen gehoeren auf diese Einzelseiten.

  • ← B64-Inline-Assembly – PBXB64-Hilfe

Implementierte Befehle

Befehl | Beschreibung | Status
R: | Bemerkung (Kommentar). Wird vom Compiler ignoriert. | Voll
T: | Geben Sie Text ein. Unterstützt String-Literale, $variablesund mehrteilige durch Kommas getrennte Literale. | Voll
E: | Programm beenden. Gibt 0 vom Einstiegspunkt zurück. | Voll
C: | Berechnen / zuweisen. C: $var = "string"oderC: #var = number. | Voll
A: | Liest Eingaben ueber die PILOT-Runtime in $var oder #var. | Implementiert
J: | Springe bedingungslos zu *label. | Voll
M: | Passen Sie den bedingten Sprung an. Springt zu *label wenn der Übereinstimmungsslot wahr ist. | Voll
Y: | Ja Wache. Nächste Zeile nur ausführen, wenn Übereinstimmungsslot wahr ist. | Voll
N: | Keine Wache. Nächste Zeile nur ausführen, wenn Übereinstimmungsslot falsch ist. | Voll
U: | Unterprogrammaufruf. Speichert einen Rueckkehrindex, springt zu *label und kehrt ueber E: zurueck. | Implementiert
S: | Ton. Ruft den PILOT-Sound/Beep-Runtime-Helfer auf. | Implementiert
*label | Label-Definition für J:- und M:-Ziele. | Voll

Variablentypen

Präfix | Typ | Beispiel
$ | String-Variable | $name, $message
# | Zahlenvariable (64-Bit-Ganzzahl mit Vorzeichen) | #count, #age

Match-Slot

Der Match-Slot ist ein internes boolesches Flag, das von verwendet wird Y:, N:, UndM: Befehle:

  • Nachher C: #var = value, der Match-Slot ist auf eingestellt wahr wenn der Wert ungleich Null ist, falsch wenn Null.
  • Nachher C: $var = "string", der Match-Slot ist auf eingestellt wahr wenn die Zeichenfolge nicht leer ist, falsch wenn leer.
  • Nach A: (Eingabe) spiegelt der Match-Slot das Runtime-Ergebnis wider: nicht-null String oder nicht-null Zahl ist wahr.

Zahlenausdrücke

DerC: Befehl für Zahlenvariablen unterstützt:

  • Ganzzahlige Konstanten: 42, -5, 0
  • Boolesche Konstanten: TRUE (1), FALSE (0)
  • Variablenreferenzen: #other
  • Getestete einfache arithmetische Formen aus den Validierungsbeispielen, zum Beispiel #A + 1 und #A * 2
Einschraenkung: Die implementierte Ausdrucksoberflaeche ist weiterhin bewusst klein. Verwenden Sie BASIC oder C fuer komplexe Formeln, ausdrucksstarke Praezedenzfaelle, Arrays oder dateiorientierte PILOT-Dialekterweiterungen.

Textausdrücke

DerT:UndC: Befehle für die String-Unterstützung:

  • String-Literale in Anführungszeichen: "Hello"
  • Verweise auf String-Variablen: $var
  • Mehrteilige durch Kommas getrennte Literale (nur T:): T: "Hello", " ", "World"
Einschränkung: Gemischter mehrteiliger Text (Literale kombiniert mit Variablen) wird noch nicht unterstützt.

Beispiele

Hallo Welt

T: "Hello from PILOT"
E:

Variablenzuweisung

C: $MSG = "Hello"
C: #N = 42
C: #FLAG = TRUE
T: $MSG
E:

Bedingte Wachen

C: #A = 1
Y: T: "Match is true"
N: T: "Match is false"
E:

Sprung und Beschriftungen

J: *skip
T: "This is skipped"
*skip
T: "After jump"
E:

Match-bedingter Sprung

C: #A = 1
M: *success
T: "Match was false"
E:
*success
T: "Match was true"
E:

Umfangreiches Programm

R: Demonstration of all implemented PILOT commands
C: $TITLE = "PILOT Demo"
C: #VALUE = 100
T: $TITLE
C: #CHECK = 1
Y: T: "Check passed"
N: T: "Check failed"
U: *sound
J: *end
T: "This line is skipped"
*sound
S:
E:
*end
E:

Einstiegspunkt

PILOT-Programme werden zu a kompiliertpilot_mainFunktion, die eine 64-Bit-Ganzzahl zurückgibt. Die E: Befehl wird ausgegeben return 0. Wenn nein E: vorhanden ist, fügt der Compiler am Ende eine implizite Rückgabe hinzu.

Testen

PILOT-Programme sind in der PBXB64-Validierungsmatrix enthalten. Fuehren Sie python tests/validate.py --lane pilot_linkrun aus, um die fokussierten PILOT-Tests zu starten. Das Verzeichnis examples/pilot/ enthaelt Quelldateien und erzeugte Artefakte fuer die implementierte Befehlsoberflaeche.

← Assemblyreferenz Beispiele ansehen → Zurück zur Übersicht
PBXB64-Compiler-Dokumentation · V8 Native Edition · Zuletzt aktualisiert am 17.06.2026
Für Fragen und Beiträge:smart-package.com

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Getting Started with PILOT — PBXB64 Help

Startseite › BASIC Frontend › Getting Started with PILOT — PBXB64 Help
Hilfe zum PBXB64-Compiler

Getting Started with PILOT

PILOT is an educational language built into PBXB64. The current native implementation supports remarks, text output, variables, input calls, labels, jumps, match guards, subroutine-style U: calls, sound, and program/subroutine end handling.

Hello World

R: Hello world example
T: "Hello, PILOT!"
E:

Command Summary

  • R: remark
  • T: type/output
  • E: end program or return from a U: subroutine
  • A: accept input into $ or # variables
  • C: compute/assign and update the match slot
  • J:, M:, Y:, N:, U:, S:, *label control flow, guards, subroutine calls, sound, and labels

File Extension

Save PILOT source files with the .pil extension.

See Also

  • PILOT Language Reference

How to Verify

For currently implemented PILOT commands, compile a focused .pil file and compare the console output or exit behavior with the expected result. The validation lane pilot_linkrun covers the command reference examples.

Porting Guidance

When a cookbook pattern needs richer expressions, complex string comparison, file I/O, arrays, or full historical PILOT dialect behavior, use BASIC or C for production code or add a focused PILOT test before documenting the behavior as supported.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PILOT Cookbook: Simple Quiz — PBXB64 Help

Startseite › BASIC Frontend › PILOT Cookbook: Simple Quiz — PBXB64 Help
Hilfe zum PBXB64-Compiler

PILOT Cookbook: Simple Quiz

This example shows a small multiple-choice quiz pattern using the implemented input, compute, match, and guarded-output commands.

Program Pattern

R: Simple quiz demonstration
T: "What is 2 + 2?"
T: "a) 3  b) 4  c) 5"
A: $answer
C: $expected = "b"
C: #correct = TRUE
Y: T: "Correct!"
N: T: "Try again."
E:

Implementation Note

Note: Input calls and guarded output are implemented. Rich string comparison expressions are still limited, so keep quiz scoring to tested assignment/match forms or move complex scoring to BASIC/C.

See Also

  • Getting Started with PILOT

How to Verify

For currently implemented PILOT commands, compile a focused .pil file and compare the console output or exit behavior with the expected result. The validation lane pilot_linkrun covers the command reference examples.

Porting Guidance

When a cookbook pattern needs richer expressions, complex string comparison, file I/O, arrays, or full historical PILOT dialect behavior, use BASIC or C for production code or add a focused PILOT test before documenting the behavior as supported.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PILOT Cookbook: Menu Navigation — PBXB64 Help

Startseite › BASIC Frontend › PILOT Cookbook: Menu Navigation — PBXB64 Help
Hilfe zum PBXB64-Compiler

PILOT Cookbook: Menu Navigation

A menu loop is a natural fit for PILOT's implemented J:, M:, and *label commands.

Program Pattern

*menu
T: "1) Start  2) Options  3) Quit"
A: $choice
C: #quit = FALSE
M: *done
J: *menu
*done
T: "Goodbye!"
E:

Implementation Note

Note: Labels and jumps are implemented. Complex menu choice parsing still depends on the currently limited string/number expression surface.

See Also

  • Getting Started with PILOT

How to Verify

For currently implemented PILOT commands, compile a focused .pil file and compare the console output or exit behavior with the expected result. The validation lane pilot_linkrun covers the command reference examples.

Porting Guidance

When a cookbook pattern needs richer expressions, complex string comparison, file I/O, arrays, or full historical PILOT dialect behavior, use BASIC or C for production code or add a focused PILOT test before documenting the behavior as supported.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PILOT Cookbook: Scoring Loop — PBXB64 Help

Startseite › BASIC Frontend › PILOT Cookbook: Scoring Loop — PBXB64 Help
Hilfe zum PBXB64-Compiler

PILOT Cookbook: Scoring Loop

This cookbook shows how C: compute commands and labels can maintain a running score in the currently implemented subset.

Program Pattern

C: #score = 0
*round
T: "Enter points (0 to finish):"
A: #points
C: #score = #points
M: *finish
J: *round
*finish
T: "Final score stored in #score"
U: *done
E:
*done
S:
E:

Implementation Note

Note: Compute, input, labels, jumps, subroutine-style U:, sound, and variable text output are implemented in the native frontend. Arbitrary arithmetic and direct numeric text output remain narrower than full historical PILOT dialects.

See Also

  • Getting Started with PILOT

How to Verify

For currently implemented PILOT commands, compile a focused .pil file and compare the console output or exit behavior with the expected result. The validation lane pilot_linkrun covers the command reference examples.

Porting Guidance

When a cookbook pattern needs richer expressions, complex string comparison, file I/O, arrays, or full historical PILOT dialect behavior, use BASIC or C for production code or add a focused PILOT test before documenting the behavior as supported.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PILOT R: - Kommentar - PBXB64 Help

Startseite › BASIC Frontend › PILOT Text and Comments › PILOT R: - Kommentar
Hilfe zum PBXB64-Compiler

PILOT R: - Kommentar

Ignoriert eine Kommentarzeile. The page names the tested entry point, expected control-flow effect, and the validation sample used to prove it.

Kind: Anweisung | Category: PILOT Frontend

PBXB64 Status: VOLL IMPLEMENTIERT

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

R: This is a comment

Use the command with a tiny source file that makes the control-flow effect visible, then verify the resulting output or branch path against the sample listed below.

Beschreibung

Diese Seite beschreibt die nutzbare PILOT-Befehlsform in PBXB64. Alles nach R: wird ignoriert und erzeugt keinen Runtime-Code. Verwenden Sie es fuer Kommentare direkt im PILOT-Stream; der Rest der Zeile bleibt fuer den Compiler unwirksam.

Examples should name the trigger, the expected branch or output, and any follow-up label or dispatcher path so the command can be used without guessing the flow.

Verifiziertes Beispiel

Das fokussierte Beispiel examples/pilot/pilot_remark.pil kompiliert und laeuft in der pilot_linkrun Validierungsspur.

Beispiel

examples/pilot/pilot_remark.pil

Grenzen

Die Seite behauptet nur die in PBXB64 implementierte und durch Beispiele abgedeckte Teilmenge. Vollstaendige historische PILOT-Dialektkompatibilitaet, freie Ausdruecke, komplexe Stringverkettung und interaktive Szenarien ohne Test sind nicht eingeschlossen. Wenn ein Beispiel Eingabe, Rücksprung oder Sound verwendet, muss die Abhaengigkeit vom Laufzeit- oder Desktop-Umfeld direkt genannt werden.

Siehe auch

  • PILOT Language Overview
  • PILOT R: - Remark
  • PILOT T: - Type
  • PILOT E: - End

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


PILOT T: - Ausgabe - PBXB64 Help

Startseite › BASIC Frontend › PILOT Text and Comments › PILOT T: - Ausgabe
Hilfe zum PBXB64-Compiler

PILOT T: - Ausgabe

Gibt Literal-, Variablen- oder mehrteiligen Text aus. The page names the tested entry point, expected control-flow effect, and the validation sample used to prove it.

Kind: Anweisung | Category: PILOT Frontend

PBXB64 Status: VOLL IMPLEMENTIERT

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

T: "Hello", " ", "World"

Use the command with a tiny source file that makes the control-flow effect visible, then verify the resulting output or branch path against the sample listed below.

Beschreibung

Diese Seite beschreibt die nutzbare PILOT-Befehlsform in PBXB64. Unterstuetzt Stringliterale, Stringvariablen und literalbasierte mehrteilige Ausgaben. Verwenden Sie es fuer sichtbare Ausgaben, Statusmeldungen und Debugtext. Gemischte mehrteilige Ausgaben mit Variablen sind weiterhin begrenzt und sollten mit einem kleinen Beispiel belegt werden.

Examples should name the trigger, the expected branch or output, and any follow-up label or dispatcher path so the command can be used without guessing the flow.

Verifiziertes Beispiel

Das fokussierte Beispiel examples/pilot/pilot_text_multi.pil kompiliert und laeuft in der pilot_linkrun Validierungsspur.

Beispiel

examples/pilot/pilot_text_multi.pil

Grenzen

Die Seite behauptet nur die in PBXB64 implementierte und durch Beispiele abgedeckte Teilmenge. Vollstaendige historische PILOT-Dialektkompatibilitaet, freie Ausdruecke, komplexe Stringverkettung und interaktive Szenarien ohne Test sind nicht eingeschlossen. Wenn ein Beispiel Eingabe, Rücksprung oder Sound verwendet, muss die Abhaengigkeit vom Laufzeit- oder Desktop-Umfeld direkt genannt werden.

Siehe auch

  • PILOT Language Overview
  • PILOT R: - Remark
  • PILOT T: - Type
  • PILOT E: - End

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


PILOT C: - Berechnen / Zuweisen - PBXB64 Help

Startseite › BASIC Frontend › PILOT Variables and Input › PILOT C: - Berechnen / Zuweisen
Hilfe zum PBXB64-Compiler

PILOT C: - Berechnen / Zuweisen

Weist String- oder Zahlenvariablen zu und aktualisiert den Match-Slot. The page names the tested entry point, expected control-flow effect, and the validation sample used to prove it.

Kind: Anweisung | Category: PILOT Frontend

PBXB64 Status: VOLL IMPLEMENTIERT

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

C: $MSG = "PILOT Test"
C: #A = TRUE
C: #B = #A + 1

Use the command with a tiny source file that makes the control-flow effect visible, then verify the resulting output or branch path against the sample listed below.

Beschreibung

Diese Seite beschreibt die nutzbare PILOT-Befehlsform in PBXB64. Unterstuetzt $-Stringvariablen, #-Zahlenvariablen, TRUE/FALSE, Variablenreferenzen und die getesteten einfachen arithmetischen Formen. Jede Zuweisung aktualisiert den Match-Slot und kann daher direkt den nachfolgenden Y:- oder M:-Pfad beeinflussen.

Examples should name the trigger, the expected branch or output, and any follow-up label or dispatcher path so the command can be used without guessing the flow.

Verifiziertes Beispiel

Das fokussierte Beispiel examples/pilot/pilot_comprehensive.pil kompiliert und laeuft in der pilot_linkrun Validierungsspur.

Beispiel

examples/pilot/pilot_comprehensive.pil

Grenzen

Die Seite behauptet nur die in PBXB64 implementierte und durch Beispiele abgedeckte Teilmenge. Vollstaendige historische PILOT-Dialektkompatibilitaet, freie Ausdruecke, komplexe Stringverkettung und interaktive Szenarien ohne Test sind nicht eingeschlossen. Wenn ein Beispiel Eingabe, Rücksprung oder Sound verwendet, muss die Abhaengigkeit vom Laufzeit- oder Desktop-Umfeld direkt genannt werden.

Siehe auch

  • PILOT Language Overview
  • PILOT R: - Remark
  • PILOT T: - Type
  • PILOT E: - End

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


PILOT A: - Eingabe - PBXB64 Help

Startseite › BASIC Frontend › PILOT Variables and Input › PILOT A: - Eingabe
Hilfe zum PBXB64-Compiler

PILOT A: - Eingabe

Liest String- oder Zahleneingabe in eine PILOT-Variable. The page names the tested entry point, expected control-flow effect, and the validation sample used to prove it.

Kind: Anweisung | Category: PILOT Frontend

PBXB64 Status: IMPLEMENTIERT

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

A: $INPUT
A: #NUMBER

Use the command with a tiny source file that makes the control-flow effect visible, then verify the resulting output or branch path against the sample listed below.

Beschreibung

Diese Seite beschreibt die nutzbare PILOT-Befehlsform in PBXB64. Liest eine Zeichenkette oder Zahl ein und setzt den Match-Status anhand des Ergebnisses. Verwenden Sie es fuer einfache Eingabeschritte oder als Teil eines interaktiven Flow-Proofs.

Examples should name the trigger, the expected branch or output, and any follow-up label or dispatcher path so the command can be used without guessing the flow.

Verifiziertes Beispiel

Das fokussierte Beispiel examples/pilot/pilot_accept.pil kompiliert und laeuft in der pilot_linkrun Validierungsspur.

Beispiel

examples/pilot/pilot_accept.pil

Grenzen

Die Seite behauptet nur die in PBXB64 implementierte und durch Beispiele abgedeckte Teilmenge. Vollstaendige historische PILOT-Dialektkompatibilitaet, freie Ausdruecke, komplexe Stringverkettung und interaktive Szenarien ohne Test sind nicht eingeschlossen. Wenn ein Beispiel Eingabe, Rücksprung oder Sound verwendet, muss die Abhaengigkeit vom Laufzeit- oder Desktop-Umfeld direkt genannt werden.

Siehe auch

  • PILOT Language Overview
  • PILOT R: - Remark
  • PILOT T: - Type
  • PILOT E: - End

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


PILOT *label - Label-Definition - PBXB64 Help

Startseite › BASIC Frontend › PILOT Labels and Branching › PILOT *label - Label-Definition
Hilfe zum PBXB64-Compiler

PILOT *label - Label-Definition

Definiert ein Ziel fuer Sprung, Match oder Subroutine. The page names the tested entry point, expected control-flow effect, and the validation sample used to prove it.

Kind: Anweisung | Category: PILOT Frontend

PBXB64 Status: VOLL IMPLEMENTIERT

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

*target

Use the command with a tiny source file that makes the control-flow effect visible, then verify the resulting output or branch path against the sample listed below.

Beschreibung

Diese Seite beschreibt die nutzbare PILOT-Befehlsform in PBXB64. Erzeugt einen Basic Block, der von J:, M: oder U: angesprungen werden kann. Das Label markiert damit eine konkrete Stelle im Steuerfluss.

Examples should name the trigger, the expected branch or output, and any follow-up label or dispatcher path so the command can be used without guessing the flow.

Verifiziertes Beispiel

Das fokussierte Beispiel examples/pilot/pilot_jump.pil kompiliert und laeuft in der pilot_linkrun Validierungsspur.

Beispiel

examples/pilot/pilot_jump.pil

Grenzen

Die Seite behauptet nur die in PBXB64 implementierte und durch Beispiele abgedeckte Teilmenge. Vollstaendige historische PILOT-Dialektkompatibilitaet, freie Ausdruecke, komplexe Stringverkettung und interaktive Szenarien ohne Test sind nicht eingeschlossen. Wenn ein Beispiel Eingabe, Rücksprung oder Sound verwendet, muss die Abhaengigkeit vom Laufzeit- oder Desktop-Umfeld direkt genannt werden.

Siehe auch

  • PILOT Language Overview
  • PILOT R: - Remark
  • PILOT T: - Type
  • PILOT E: - End

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


PILOT J: - Sprung - PBXB64 Help

Startseite › BASIC Frontend › PILOT Labels and Branching › PILOT J: - Sprung
Hilfe zum PBXB64-Compiler

PILOT J: - Sprung

Springt bedingungslos zu einem `*label`. The page names the tested entry point, expected control-flow effect, and the validation sample used to prove it.

Kind: Anweisung | Category: PILOT Frontend

PBXB64 Status: VOLL IMPLEMENTIERT

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

J: *target
*target

Use the command with a tiny source file that makes the control-flow effect visible, then verify the resulting output or branch path against the sample listed below.

Beschreibung

Diese Seite beschreibt die nutzbare PILOT-Befehlsform in PBXB64. Verzweigt direkt zum benannten Label. Der Zielpunkt muss als *label im selben PILOT-Quelltext vorhanden sein.

Examples should name the trigger, the expected branch or output, and any follow-up label or dispatcher path so the command can be used without guessing the flow.

Verifiziertes Beispiel

Das fokussierte Beispiel examples/pilot/pilot_jump.pil kompiliert und laeuft in der pilot_linkrun Validierungsspur.

Beispiel

examples/pilot/pilot_jump.pil

Grenzen

Die Seite behauptet nur die in PBXB64 implementierte und durch Beispiele abgedeckte Teilmenge. Vollstaendige historische PILOT-Dialektkompatibilitaet, freie Ausdruecke, komplexe Stringverkettung und interaktive Szenarien ohne Test sind nicht eingeschlossen. Wenn ein Beispiel Eingabe, Rücksprung oder Sound verwendet, muss die Abhaengigkeit vom Laufzeit- oder Desktop-Umfeld direkt genannt werden.

Siehe auch

  • PILOT Language Overview
  • PILOT R: - Remark
  • PILOT T: - Type
  • PILOT E: - End

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


PILOT M: - Match-Sprung - PBXB64 Help

Startseite › BASIC Frontend › PILOT Labels and Branching › PILOT M: - Match-Sprung
Hilfe zum PBXB64-Compiler

PILOT M: - Match-Sprung

Springt zu einem Label, wenn der Match-Slot wahr ist. The page names the tested entry point, expected control-flow effect, and the validation sample used to prove it.

Kind: Anweisung | Category: PILOT Frontend

PBXB64 Status: VOLL IMPLEMENTIERT

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

M: *success

Use the command with a tiny source file that makes the control-flow effect visible, then verify the resulting output or branch path against the sample listed below.

Beschreibung

Diese Seite beschreibt die nutzbare PILOT-Befehlsform in PBXB64. Prueft den Match-Slot und springt nur bei wahr zum Ziel. Verwenden Sie es fuer Ergebnis-gesteuerte Verzweigungen, wenn der aktuelle Match-Zustand bereits feststeht.

Examples should name the trigger, the expected branch or output, and any follow-up label or dispatcher path so the command can be used without guessing the flow.

Verifiziertes Beispiel

Das fokussierte Beispiel examples/pilot/pilot_match_true.pil kompiliert und laeuft in der pilot_linkrun Validierungsspur.

Beispiel

examples/pilot/pilot_match_true.pil

Grenzen

Die Seite behauptet nur die in PBXB64 implementierte und durch Beispiele abgedeckte Teilmenge. Vollstaendige historische PILOT-Dialektkompatibilitaet, freie Ausdruecke, komplexe Stringverkettung und interaktive Szenarien ohne Test sind nicht eingeschlossen. Wenn ein Beispiel Eingabe, Rücksprung oder Sound verwendet, muss die Abhaengigkeit vom Laufzeit- oder Desktop-Umfeld direkt genannt werden.

Siehe auch

  • PILOT Language Overview
  • PILOT R: - Remark
  • PILOT T: - Type
  • PILOT E: - End

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


PILOT Y: - Ja-Guard - PBXB64 Help

Startseite › BASIC Frontend › PILOT Guards › PILOT Y: - Ja-Guard
Hilfe zum PBXB64-Compiler

PILOT Y: - Ja-Guard

Fuehrt Nutzlast oder naechste Zeile aus, wenn der Match-Slot wahr ist. The page names the tested entry point, expected control-flow effect, and the validation sample used to prove it.

Kind: Anweisung | Category: PILOT Frontend

PBXB64 Status: VOLL IMPLEMENTIERT

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

Y: T: "Yes guard with true match"

Use the command with a tiny source file that makes the control-flow effect visible, then verify the resulting output or branch path against the sample listed below.

Beschreibung

Diese Seite beschreibt die nutzbare PILOT-Befehlsform in PBXB64. Kann als Inline-Guard mit Nutzlast oder als Guard fuer die folgende Zeile verwendet werden. Das ist die einfachste Form fuer bedingte Ausgabe im getesteten PILOT-Subset.

Examples should name the trigger, the expected branch or output, and any follow-up label or dispatcher path so the command can be used without guessing the flow.

Verifiziertes Beispiel

Das fokussierte Beispiel examples/pilot/pilot_yes_true.pil kompiliert und laeuft in der pilot_linkrun Validierungsspur.

Beispiel

examples/pilot/pilot_yes_true.pil

Grenzen

Die Seite behauptet nur die in PBXB64 implementierte und durch Beispiele abgedeckte Teilmenge. Vollstaendige historische PILOT-Dialektkompatibilitaet, freie Ausdruecke, komplexe Stringverkettung und interaktive Szenarien ohne Test sind nicht eingeschlossen. Wenn ein Beispiel Eingabe, Rücksprung oder Sound verwendet, muss die Abhaengigkeit vom Laufzeit- oder Desktop-Umfeld direkt genannt werden.

Siehe auch

  • PILOT Language Overview
  • PILOT R: - Remark
  • PILOT T: - Type
  • PILOT E: - End

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


PILOT N: - Nein-Guard - PBXB64 Help

Startseite › BASIC Frontend › PILOT Guards › PILOT N: - Nein-Guard
Hilfe zum PBXB64-Compiler

PILOT N: - Nein-Guard

Fuehrt Nutzlast oder naechste Zeile aus, wenn der Match-Slot falsch ist. The page names the tested entry point, expected control-flow effect, and the validation sample used to prove it.

Kind: Anweisung | Category: PILOT Frontend

PBXB64 Status: VOLL IMPLEMENTIERT

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

N: T: "No guard with false match"

Use the command with a tiny source file that makes the control-flow effect visible, then verify the resulting output or branch path against the sample listed below.

Beschreibung

Diese Seite beschreibt die nutzbare PILOT-Befehlsform in PBXB64. Invertiert den Y:-Guard und laeuft bei falschem Match-Slot. Nutzen Sie es fuer den Fehlpfad oder einen Fallback-Text.

Examples should name the trigger, the expected branch or output, and any follow-up label or dispatcher path so the command can be used without guessing the flow.

Verifiziertes Beispiel

Das fokussierte Beispiel examples/pilot/pilot_no_true.pil kompiliert und laeuft in der pilot_linkrun Validierungsspur.

Beispiel

examples/pilot/pilot_no_true.pil

Grenzen

Die Seite behauptet nur die in PBXB64 implementierte und durch Beispiele abgedeckte Teilmenge. Vollstaendige historische PILOT-Dialektkompatibilitaet, freie Ausdruecke, komplexe Stringverkettung und interaktive Szenarien ohne Test sind nicht eingeschlossen. Wenn ein Beispiel Eingabe, Rücksprung oder Sound verwendet, muss die Abhaengigkeit vom Laufzeit- oder Desktop-Umfeld direkt genannt werden.

Siehe auch

  • PILOT Language Overview
  • PILOT R: - Remark
  • PILOT T: - Type
  • PILOT E: - End

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


PILOT U: - Subroutine verwenden - PBXB64 Help

Startseite › BASIC Frontend › PILOT Subroutines and End › PILOT U: - Subroutine verwenden
Hilfe zum PBXB64-Compiler

PILOT U: - Subroutine verwenden

Ruft ein `*label` als Subroutine auf und kehrt ueber `E:` zurueck. The page names the tested entry point, expected control-flow effect, and the validation sample used to prove it.

Kind: Anweisung | Category: PILOT Frontend

PBXB64 Status: IMPLEMENTIERT

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

U: *subroutine
*subroutine
E:

Use the command with a tiny source file that makes the control-flow effect visible, then verify the resulting output or branch path against the sample listed below.

Beschreibung

Diese Seite beschreibt die nutzbare PILOT-Befehlsform in PBXB64. Speichert einen Rueckkehrindex, springt zum Label und laesst E: ueber den Return-Dispatcher zum Fortsetzungsblock zurueckkehren. Damit lassen sich kleine Unterprogramme und wiederverwendbare Abläufe modellieren.

Examples should name the trigger, the expected branch or output, and any follow-up label or dispatcher path so the command can be used without guessing the flow.

Verifiziertes Beispiel

Das fokussierte Beispiel examples/pilot/pilot_us_noop.pil kompiliert und laeuft in der pilot_linkrun Validierungsspur.

Beispiel

examples/pilot/pilot_us_noop.pil

Grenzen

Die Seite behauptet nur die in PBXB64 implementierte und durch Beispiele abgedeckte Teilmenge. Vollstaendige historische PILOT-Dialektkompatibilitaet, freie Ausdruecke, komplexe Stringverkettung und interaktive Szenarien ohne Test sind nicht eingeschlossen. Wenn ein Beispiel Eingabe, Rücksprung oder Sound verwendet, muss die Abhaengigkeit vom Laufzeit- oder Desktop-Umfeld direkt genannt werden.

Siehe auch

  • PILOT Language Overview
  • PILOT R: - Remark
  • PILOT T: - Type
  • PILOT E: - End

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


PILOT E: - Ende - PBXB64 Help

Startseite › BASIC Frontend › PILOT Subroutines and End › PILOT E: - Ende
Hilfe zum PBXB64-Compiler

PILOT E: - Ende

Beendet das Programm oder den Subroutinen-Rueckkehrpfad. The page names the tested entry point, expected control-flow effect, and the validation sample used to prove it.

Kind: Anweisung | Category: PILOT Frontend

PBXB64 Status: VOLL IMPLEMENTIERT

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

E:

Use the command with a tiny source file that makes the control-flow effect visible, then verify the resulting output or branch path against the sample listed below.

Beschreibung

Diese Seite beschreibt die nutzbare PILOT-Befehlsform in PBXB64. Springt zum Return-Dispatcher. In einem durch U: aufgerufenen Block kehrt E: zum Aufrufer zurueck; sonst endet pilot_main mit 0. Nutzen Sie es als eindeutigen Abschluss des Subroutinenpfads.

Examples should name the trigger, the expected branch or output, and any follow-up label or dispatcher path so the command can be used without guessing the flow.

Verifiziertes Beispiel

Das fokussierte Beispiel examples/pilot/pilot_hello.pil kompiliert und laeuft in der pilot_linkrun Validierungsspur.

Beispiel

examples/pilot/pilot_hello.pil

Grenzen

Die Seite behauptet nur die in PBXB64 implementierte und durch Beispiele abgedeckte Teilmenge. Vollstaendige historische PILOT-Dialektkompatibilitaet, freie Ausdruecke, komplexe Stringverkettung und interaktive Szenarien ohne Test sind nicht eingeschlossen. Wenn ein Beispiel Eingabe, Rücksprung oder Sound verwendet, muss die Abhaengigkeit vom Laufzeit- oder Desktop-Umfeld direkt genannt werden.

Siehe auch

  • PILOT Language Overview
  • PILOT R: - Remark
  • PILOT T: - Type
  • PILOT E: - End

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


PILOT S: - Ton - PBXB64 Help

Startseite › BASIC Frontend › PILOT Runtime Helpers › PILOT S: - Ton
Hilfe zum PBXB64-Compiler

PILOT S: - Ton

Fuehrt den PILOT-Sound/Beep-Runtime-Aufruf aus. The page names the tested entry point, expected control-flow effect, and the validation sample used to prove it.

Kind: Anweisung | Category: PILOT Frontend

PBXB64 Status: IMPLEMENTIERT

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

S:

Use the command with a tiny source file that makes the control-flow effect visible, then verify the resulting output or branch path against the sample listed below.

Beschreibung

Diese Seite beschreibt die nutzbare PILOT-Befehlsform in PBXB64. Ruft den PILOT-Soundhelper auf; die sichtbare Wirkung haengt vom Desktop- und Audio-Umfeld ab. Dokumentieren Sie die Umgebung, wenn das Beispiel auf Ton oder sichtbares Feedback angewiesen ist.

Examples should name the trigger, the expected branch or output, and any follow-up label or dispatcher path so the command can be used without guessing the flow.

Verifiziertes Beispiel

Das fokussierte Beispiel examples/pilot/pilot_us_noop.pil kompiliert und laeuft in der pilot_linkrun Validierungsspur.

Beispiel

examples/pilot/pilot_us_noop.pil

Grenzen

Die Seite behauptet nur die in PBXB64 implementierte und durch Beispiele abgedeckte Teilmenge. Vollstaendige historische PILOT-Dialektkompatibilitaet, freie Ausdruecke, komplexe Stringverkettung und interaktive Szenarien ohne Test sind nicht eingeschlossen. Wenn ein Beispiel Eingabe, Rücksprung oder Sound verwendet, muss die Abhaengigkeit vom Laufzeit- oder Desktop-Umfeld direkt genannt werden.

Siehe auch

  • PILOT Language Overview
  • PILOT R: - Remark
  • PILOT T: - Type
  • PILOT E: - End

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


PBXB64 - Rust Language (V10)

Startseite › Language Frontends › Rust Frontend

Rust Language Reference (Rust Subset)

PBXB64 supports a Rust-subset syntax that compiles to the same unified IR — and the same Windows x64 PE32+ executables — as B64, C and PowerBASIC. Source files use the .rs extension and are dispatched automatically by the driver.

Kein Rust-Compiler. Dieses Frontend implementiert Rust-ähnliche Syntax, nicht die vollstaendige Sprache Rust. Es gibt keinen Borrow-Checker, kein geprueftes Lifetime-Modell, keine Traits und keine Standardbibliothek. Programme werden manuell speicherverwaltet, wie bei den B64- und C-Frontends. Ein breiter imperativer Teilsatz — Funktionen, Structs/Tupel/Enums, minimale Generics, impl-Methoden, Closures, Raw-Pointer, Arrays, Threads und match — wird unterstuetzt, wie unten aufgefuehrt.

Referenzseiten

Diese Seite ist die Uebersicht zum Frontend. Die verlinkten Einzelseiten enthalten Syntax, getestete Beispiele, Status und Grenzen fuer die jeweiligen Befehle oder Sprachkonstrukte.

  • Datentypen
  • Variablen und Konstanten
  • Funktionen und aufrufbare Konstrukte
  • Kontrollfluss
  • Pointer und unsafe-Bloecke
  • Structs und Enums
  • Operatoren

Eingebettetes Rust innerhalb von PowerBASIC (#RUST / #ENDRUST)

Eine Rust-Region kann direkt innerhalb einer PowerBASIC-Quelldatei (.pb) zwischen den Markierungen #RUST und #ENDRUST eingebettet werden, analog zur COBOL-Einbettung mittels #COBOL / #COBOL END. Der Rust-Text wird in dieselbe Modul-IR uebersetzt und in die finale ausfuehrbare Datei gelinkt. Innerhalb eines eingebetteten Blocks erlauben die PB-Variablen-Bridge-Intrinsics, aus Rust heraus die Lokalen und Arrays der umschliessenden PB-Funktion zu lesen und zu schreiben:

Intrinsic | Art der PB-Variablen | Wirkung
pb_val_i64("x") / pb_set_i64("x", v) | Skalar (Ganzzahl) | lesen / schreiben eines PB LONG/QUAD
pb_val_f64("x") / pb_set_f64("x", v) | Skalar (Gleitkomma) | lesen / schreiben eines PB SINGLE/DOUBLE
pb_val_str("s") / pb_str_len("s") / pb_set_str("s", p) | Zeichenkette | Pointer lesen / Länge / ein PB STRING schreiben
pb_arr_get_i64("a", i) / pb_arr_set_i64("a", i, v) | Ganzzahl-Array | Element i lesen / schreiben
pb_arr_get_f64("a", i) / pb_arr_set_f64("a", i, v) | Gleitkomma-Array | PB-Elemente SINGLE/DOUBLE als Rust f64 lesen / schreiben
pb_arr_len_i64("a") / pb_arr_lbound_i64 / pb_arr_ubound_i64 | Array | Array-Umfang / untere / obere Grenze fuer feste und dynamische Ganzzahl- oder Gleitkomma-Arrays
rust_thread_spawnN_i64 ... rust_thread_join_i64 / _detach / _is_finished / _join_timeout / _sleep_ms | — | Worker-Funktionen / Closures auf nativen Threads starten (0–6 i64-Argumente), auch Worker, die PB-Bridge-Intrinsics verwenden, solange der eingebettete Block aktiv ist

Wenn ein Thread-Worker ueber diese Bridge-Intrinsics auf PB-Lokale oder Arrays zugreift, sollte der Worker vor der Rueckkehr aus dem eingebetteten Block gejoint werden. Detached Worker duerfen nach Abschluss des Blocks nicht weiter auf PB-Lokale zugreifen.

Fuer von BASIC exportierten oder importierten quellenuebergreifenden Speicher erhaelt eine Rust-Nebeneingabe generierte extern "PBXB64" static mut-Deklarationen fuer skalare BRIDGE ... ALIAS-Symbole, bevor die Benutzer-Rust-Quelle kompiliert wird. Feste STRINGZ * n-Bridge-Puffer werden als static mut alias: [i8; n] erzeugt, sodass Rust exakte Bytes per Index lesen und schreiben kann. Pointer-Bridge-Slots werden als usize erzeugt; getestete Helfer casten die gespeicherte Adresse zu *mut i8 und schreiben durch den BASIC-Zielpuffer. Passende Benutzerdeklarationen sind erlaubt, falsche extern-static-Deklarationen schlagen fail-closed zur Compile-Zeit fehl. Der fokussierte Bridge-Test tests/pb/test_bridge_basic_rust_export.pb mit tests/rust/bridge_basic_rust_export.rs belegt BASIC-eigene Integer- und Gleitkomma-Updates ueber diesen Weg. tests/pb/test_bridge_basic_rust_export_stringz.pb mit tests/rust/bridge_basic_rust_export_stringz.rs belegt BASIC-eigene Festpuffer-Updates durch Rust-Indexzugriffe. tests/pb/test_bridge_basic_rust_export_ptr.pb mit tests/rust/bridge_basic_rust_export_ptr.rs belegt BASIC-eigene Pointer-Slot-Updates durch Rust-Raw-Pointer-Bytezugriffe. tests/pb/test_bridge_rust_import_c_owner.pb mit tests/c/bridge_rust_import_c_owner.c und tests/rust/bridge_rust_import_c_owner.rs belegt, dass Rust auch C-eigenen, von BASIC importierten Skalarspeicher aendern kann. tests/pb/test_bridge_rust_import_c_stringz.pb mit tests/c/bridge_rust_import_c_stringz.c und tests/rust/bridge_rust_import_c_stringz.rs belegt denselben generierten Festpuffer-Deklarationspfad fuer C-eigene Byte-Arrays, die BASIC importiert. tests/pb/test_bridge_rust_import_c_ptr.pb mit tests/c/bridge_rust_import_c_ptr.c und tests/rust/bridge_rust_import_c_ptr.rs belegt, dass Rust durch einen C-eigenen, von BASIC importierten Pointer-Slot schreiben kann. tests/rust/bridge_basic_rust_mismatch.rs belegt die Ablehnung falscher Breiten.

#RUST
fn rust_main() -> i64 {
    let v = pb_val_i64("Counter");
    pb_set_i64("Counter", v + 1);
    return 0;
}
#ENDRUST

Getting Started

fn main() -> i64 {
    return 42;
}
PBXB64 hello.rs -o hello.exe
hello.exe
echo %ERRORLEVEL%      &:: prints 42

Hello, Sum

fn sum_to_n(n: i64) -> i64 {
    let mut total: i64 = 0;
    let mut i: i64 = 1;
    while i <= n {
        total = total + i;
        i = i + 1;
    }
    return total;
}

fn main() -> i64 {
    return sum_to_n(5);   // 15
}

Was in V10 funktioniert

  • Funktionen (fn), einschließlich Aufrufen, Rekursion und dem Einsprungpunkt main() -> i64
  • Variablen (let, let mut) mit Typrückschluss für Ganzzahl-/Gleitkomma-Literale; Tupel-Dekonstruktion let (a, b) = ...
  • Konstanten (const) — Ganzzahl-/Gleitkomma-/Bool-Konstanten werden zu Übersetzungszeit-Werten gefaltet; static-Globals
  • Typ-Aliase (type Name = T;)
  • Kontrollfluss: if/else/else if-Ketten, while, loop, break, continue, return, for v in lo..hi/..=hi
  • match auf Ganzzahl-Literalen, inklusiven/exklusiven Bereichen (..=/..), dem Wildcard (_), |-Alternierung und if-Guards
  • Ganzzahl-/Gleitkomma-/Bool-/Pointer-Typen einschließlich usize/isize (pointer-groß, 64-Bit auf Win64); vollständiger binärer/unärer/Vergleichs-/Compound-Assign-Operator-Satz einschließlich <<= >>= &= |= ^=
  • Ganzzahl-Literal-Suffixe (42i64, 3.14f64) und Radix-Formen (0x, 0o, 0b)
  • Logische Operatoren && / || (kurzschließend — siehe Operators)
  • Named-field-struct mit Struct-Literal-Syntax Point { x: 1, y: 2 } (inkl. Kurzform); Tupel-Structs struct P(i64, i64); Unit-Structs struct Marker;
  • C-artiges enum mit optionalen expliziten Diskriminanten und Enums mit Daten-Varianten enum Opt { Some(i64), None } (Tagged-Union-Senkung; Opt::Some(42)-Konstruktion und match Some(x) => / Mehrfeld-Pair(a, b)-Dekonstruktion)
  • impl-Blöcke mit Methoden (p.get(), &self) und assoziierten Funktionen (T::new())
  • Closures |x| body, move-Closures und das Capturing einschließender Variablen
  • Raw-Pointer (*mut T / *const T) und Referenzen (&T / &mut T): Adress-of (&x, &mut x), typisierte Dereferenz-Laden/Speichern (*p, (*p).field, *p = v)
  • Festgroße Arrays ([T; N]) und Array-Literale ([a, b, c], [val; N]): Element-Zuweisung und -Lesen (a[i])
  • Tupel ((T1, T2)), Tupel-Ausdrücke und .0-Indexzugriff
  • Char-Literale ('A', '\n', '\x41', '\u{1F600}')
  • unsafe-Blöcke (akzeptiert, ohne semantische Wirkung)
  • Threads über die Intrinsics rust_thread_spawnN_i64 / join / detach / is_finished / join_timeout / sleep_ms

Unterstützer Teilsatz im Überblick

Merkmal | Unterstützung
fn, Aufrufe, Rekursion, main-Einsprung | Ja
let / let mut, Typrückschluss, Tupel-Dekonstruktion | Ja
iN / uN / fN / bool / usize / isize / *mut T / &T | Ja
if / else if / while / loop / for in / break / continue | Ja
match (Literale, Bereiche ..=/.., _, |-Alt, if-Guards, Enum-Daten) | Ja
&& / || (kurzschließend) / bitweise & | ^ << >> / alle Compound-Assigns | Ja
Raw-Pointer, Referenzen, &x, &mut x, typisiert *p, *p = v | Ja
Arrays [T; N], Array-Literale [a,b,c] / [v;N], a[i] | Ja
Named-/Tupel-/Unit-Structs, Struct-Literale, Tupel, .0-Zugriff | Ja
enum (C-artig, explizite Diskriminanten, Daten-Varianten) + impl-Methoden/assoz. Fns | Ja
Closures (|x|, move, Captures) | Ja
unsafe-Blöcke, Char-Literale ('\u{...}'), as-Casts | Ja
const (Ganzzahl/Gleitkomma/Bool, Übersetzungszeit gefaltet), static, type-Aliase | Ja
Struct als Wert übergeben (Win64-Register-/Hidden-Pointer-ABI) | Ja
Threads (rust_thread_spawnN_i64-Familie) | Ja
Borrow-Checker, Lifetimes | Nein — by design
Traits, Generics (<T>), where-Bounds | Nein
String, Vec, Box, Standardbibliothek | Nein (Raw-Pointer / Arrays verwenden)
async, dyn, use/mod-Items, Makros (println!) | Nein

IR-Zuordnung

The Rust subset maps to the PBXB64 IR almost identically to B64. The frontend is a syntax-transformation layer: the same IR instructions (alloca, load, store, add, cmp_le, cond_br, ret, ...) are emitted as for an equivalent B64 program.

Dateierweiterung

Extension | Frontend
.rs | Rust subset (this frontend)
.b64 | B64
.c / .h | C17 subset

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Rust-Datentypen — PBXB64 Help

Startseite › BASIC Frontend › Rust Data Types

Rust-Datentypen

Category: Rust Frontend

PBXB64 Status: UEBERSICHT

PBXB64 Certification: Overview page. The linked child pages carry the tested construct evidence.

Beschreibung

Skalare, Aggregate, Pointer, Tupel, Arrays und Lifetime-nahe Formen im PBXB64-Rust-Subset.

Syntax

Dieses Kapitel ist eine Navigationsuebersicht. Die exakte Syntax steht auf den verlinkten Einzelseiten und muss dort durch Beispiele oder Tests belegt sein.

Einzelseiten

  • Arrays
  • Tuples
  • Lifetimes
  • Raw pointers

Pruefung

Validierungsbeleg: Die Unterseiten nennen konkrete Rust-Beispiele oder Validierungstests. Neue Rust-Frontend-Aussagen sollen nur mit Compile/Link/Run-Beleg ergaenzt werden.

Verifiziertes Beispiel

Diese Seite ist absichtlich nur ein Uebersichtskapitel; Syntax, Grenzen und getestete Beispiele stehen auf den Unterseiten.

PBXB64-Status: Uebersicht / Navigation; keine eigenstaendige Laufzeitbehauptung ohne Unterseitenbeleg.

Siehe auch

  • Rust Frontend
  • Language Frontends

← Back

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


Rust-Fixed-Arrays — PBXB64 Help

Startseite › BASIC Frontend › Rust-Fixed-Arrays — PBXB64 Help
Hilfe zum PBXB64-Compiler

Rust-Fixed-Arrays

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

Syntax

Use the focused Rust-subset forms shown in the examples below. The referenced validation sample is the source-truth syntax for this construct.

Arrays fester Groesse verwenden die Rust-Typform [T; N]. PBXB64 senkt sie als zusammenhaengenden Aggregate-Speicher mit nullbasierter Indizierung ab.

Deklaration

let values: [i64; 4];

Elementzuweisung und Lesen

values[0] = 10;
values[1] = 20;
let total = values[0] + values[1];

Indexregeln

Indizes sind Integer-Ausdruecke. Der erzeugte Code verwendet die berechnete Elementadresse; Rust-Bounds-Checks oder Slice-Typen werden nicht eingefuegt.

Literalformen

Die getestete Teilmenge akzeptiert explizite Elementlisten wie [10i64, 20i64, 30i64] und Wiederholungsliterale wie [5i64; 2]. Die Array-Laenge ist durch Literal oder Typannotation festgelegt und ist keine dynamische Slice-Laenge.

Einsatz

Fixed Arrays eignen sich fuer kleine Buffer, Lookup-Tabellen und Beispiele mit zur Compile-Zeit bekannter Groesse. Initialisierung erfolgt mit expliziten Schleifen.

Verifiziertes Beispiel

Das fokussierte Beispiel examples/rust/help_arrays.rs kompiliert und endet mit Exitcode 0. Es deckt ein Elementlisten-Literal, ein Wiederholungsliteral und indiziertes Lesen aus beiden Arrays ab.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


Rust tuples - Feste Werte gruppieren — PBXB64 Help

Startseite › BASIC Frontend › Rust tuples - Feste Werte gruppieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

Rust tuples - Feste Werte gruppieren

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

Tuple-Typen und Tuple-Ausdruecke bilden kleine feste Aggregate. PBXB64 senkt Tuples ueber dieselbe Aggregate-Layout-Mechanik wie Structs ab.

Syntax

let p: (i64, i64) = (3, 4);
let x = p.0;
let y = p.1;
let (a, b): (i64, i64) = p;

Unterstuetztes Verhalten

Die getestete Teilmenge umfasst Tuple-Typannotationen, Tuple-Ausdruecke, .0/.1-Zugriff und Tuple-Destructuring in let-Bindungen.

Verifiziertes Beispiel

Abgedeckt durch tests/rust/tuple_let_type.rs und tests/rust/tuple_destructure_type.rs.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Rust lifetimes - Referenzannotationen parsen — PBXB64 Help

Startseite › BASIC Frontend › Rust lifetimes - Referenzannotationen parsen — PBXB64 Help
Hilfe zum PBXB64-Compiler

Rust lifetimes - Referenzannotationen parsen

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

Lifetime-Annotationen werden in den minimal getesteten Referenzformen akzeptiert, damit Rust-artige Signaturen von PBXB64 kompiliert werden koennen.

Syntax

fn pick<'a>(x: &'a i64) -> &'a i64 {
    return x;
}

Semantik

PBXB64 parst und verwirft Lifetime-Namen. Referenzen werden zu normalen Pointern abgesenkt. Es gibt keinen Borrow Checker, keine Lifetime-Analyse und keine Alias-Validierung.

Verifiziertes Beispiel

Das eigenstaendige Beispiel tests/rust/lifetime_basic.rs kompiliert und laeuft durch das Rust-Frontend; es zeigt, dass Lifetime-Namen akzeptiert und verworfen werden, waehrend Referenzen zu normalen Pointern abgesenkt werden.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Rust-Variablen und Konstanten — PBXB64 Help

Startseite › BASIC Frontend › Rust Variables and Constants

Rust-Variablen und Konstanten

Category: Rust Frontend

PBXB64 Status: UEBERSICHT

PBXB64 Certification: Overview page. The linked child pages carry the tested construct evidence.

Beschreibung

Lokale Bindungen und Compile-Time-Konstanten.

Syntax

Dieses Kapitel ist eine Navigationsuebersicht. Die exakte Syntax steht auf den verlinkten Einzelseiten und muss dort durch Beispiele oder Tests belegt sein.

Einzelseiten

  • let
  • const

Pruefung

Validierungsbeleg: Die Unterseiten nennen konkrete Rust-Beispiele oder Validierungstests. Neue Rust-Frontend-Aussagen sollen nur mit Compile/Link/Run-Beleg ergaenzt werden.

Verifiziertes Beispiel

Diese Seite ist absichtlich nur ein Uebersichtskapitel; Syntax, Grenzen und getestete Beispiele stehen auf den Unterseiten.

PBXB64-Status: Uebersicht / Navigation; keine eigenstaendige Laufzeitbehauptung ohne Unterseitenbeleg.

Siehe auch

  • Rust Frontend
  • Language Frontends

← Back

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


Rust let-Bindungen — PBXB64 Help

Startseite › BASIC Frontend › Rust let-Bindungen — PBXB64 Help
Hilfe zum PBXB64-Compiler

Rust-let-Bindungen

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

Syntax

Use the focused Rust-subset forms shown in the examples below. The referenced validation sample is the source-truth syntax for this construct.

let fuehrt eine lokale Variable ein. PBXB64 akzeptiert explizite Typen, abgeleitete Integer-/Float-/Bool-Initialisierer, mut und nicht initialisierte lokale Variablen mit explizitem Typ.

Formen

let a: i64 = 42;
let b = 42;
let mut c: i64 = 0;
let d: i64;

Mutability-Modell

mut wird fuer Rust-Kompatibilitaet geparst. Das aktuelle Frontend implementiert keine Rust-Borrow-Checks; Zuweisungen werden daher durch die PBXB64-Absenkung und nicht durch Rust-Ownership-Regeln bestimmt.

Zuweisung

let mut total: i64 = 0;
total = total + 1;
total += 10;

Praxisregel

Verwenden Sie explizite Typen an Modulgrenzen und fuer nicht initialisierte Lokale. Typableitung eignet sich fuer einfache numerische temporaere Werte.

Verifiziertes Beispiel

Siehe examples/rust/arithmetic.rs, examples/rust/constants.rs und examples/rust/sum_loop.rs.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Rust const-Werte — PBXB64 Help

Startseite › BASIC Frontend › Rust const-Werte — PBXB64 Help

Rust-const-Werte

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

const definiert einen Compile-Time-Wert. PBXB64 faltet Integer-, Float- und Bool-Konstanten in die abgesenkte IR, statt veraenderlichen Speicher anzulegen.

Syntax

const ANSWER: i64 = 42;
const PI: f64 = 3.14;
const ENABLED: bool = true;

Verwendung in Ausdruecken

fn main() -> i64 {
    if ENABLED {
        return ANSWER;
    }
    return 0;
}

Nutzen

Konstanten eignen sich fuer Magic Numbers, Limits, Flags und Branch-Bedingungen, die im Quelltext sichtbar bleiben, aber keinen Laufzeitspeicher benoetigen.

Grenzen

Komplexe Rust-Const-Evaluation, const functions, associated constants und generische Const-Parameter liegen ausserhalb des V14-Subsets.

Verifiziertes Beispiel

Siehe examples/rust/constants.rs.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Rust-Funktionen und Aufrufe — PBXB64 Help

Startseite › BASIC Frontend › Rust Functions

Rust-Funktionen und Aufrufe

Category: Rust Frontend

PBXB64 Status: UEBERSICHT

PBXB64 Certification: Overview page. The linked child pages carry the tested construct evidence.

Beschreibung

Aufrufbare Rust-Subset-Konstrukte, Methoden, Closures, Generics, Extern-Deklarationen und Thread-Task-Helfer.

Syntax

Dieses Kapitel ist eine Navigationsuebersicht. Die exakte Syntax steht auf den verlinkten Einzelseiten und muss dort durch Beispiele oder Tests belegt sein.

Einzelseiten

  • fn
  • impl methods
  • closures
  • generics
  • extern static
  • thread tasks

Pruefung

Validierungsbeleg: Die Unterseiten nennen konkrete Rust-Beispiele oder Validierungstests. Neue Rust-Frontend-Aussagen sollen nur mit Compile/Link/Run-Beleg ergaenzt werden.

Verifiziertes Beispiel

Diese Seite ist absichtlich nur ein Uebersichtskapitel; Syntax, Grenzen und getestete Beispiele stehen auf den Unterseiten.

PBXB64-Status: Uebersicht / Navigation; keine eigenstaendige Laufzeitbehauptung ohne Unterseitenbeleg.

Siehe auch

  • Rust Frontend
  • Language Frontends

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Rust fn-Funktionen — PBXB64 Help

Startseite › BASIC Frontend › Rust fn-Funktionen — PBXB64 Help
Hilfe zum PBXB64-Compiler

Rust-fn-Funktionen

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

fn deklariert eine aufrufbare Routine im PBXB64-Rust-Subset. Eine Rust-Quelldatei enthaelt normalerweise fn main() -> i64; der Rueckgabewert wird als Prozess-Exitcode verwendet.

Syntax

fn name(arg: Type, ...) -> ReturnType {
    return expression;
}

Parameter und Aufrufe

Parameter verwenden die Rust-Schreibweise name: Type. Integer- und Pointer-Argumente werden in die gemeinsame PBXB64-IR abgesenkt und nutzen die Win64-Aufrufkonvention der anderen Frontends.

fn add(a: i64, b: i64) -> i64 {
    return a + b;
}

fn main() -> i64 {
    return add(40, 2);
}

Rekursion

Direkte Rekursion ist unterstuetzt, weil Funktionen registriert werden, bevor Aufrufe in Funktionskoerpern abgesenkt werden.

fn fib(n: i64) -> i64 {
    if n <= 1 { return n; }
    return fib(n - 1) + fib(n - 2);
}

Grenzen

Traits, async-Funktionen, Varargs und Rust-Standardbibliothek gehoeren nicht zum Umfang. Die getestete Teilmenge enthaelt generische Funktionen/Structs mit geloeschten Typparametern, impl-Methoden, Associated Functions, Closures und Extern-Deklarationen; die jeweiligen Detailseiten nennen die exakt unterstuetzten Formen.

Verifiziertes Beispiel

Siehe examples/rust/fibonacci.rs, examples/rust/hello.rs und examples/rust/test_minimal.rs.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Rust impl - Methoden und Associated Functions definieren — PBXB64 Help

Startseite › BASIC Frontend › Rust impl - Methoden und Associated Functions definieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

Rust impl - Methoden und Associated Functions definieren

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

Syntax

Use the focused Rust-subset forms shown in the examples below. The referenced validation sample is the source-truth syntax for this construct.

impl Type gruppiert Funktionen, die an einen struct-artigen Typ gebunden sind. PBXB64 senkt Methoden zu normalen Funktionen mit gemangeltem Namen und explizitem Receiver-Parameter ab.

Methoden

impl Point {
    fn sum(&self) -> i64 {
        return self.0 + self.1;
    }
}

Associated Functions

impl Point {
    fn new(x: i64, y: i64) -> Point {
        return Point(x, y);
    }
}

let p = Point::new(3, 4);

Verifiziertes Beispiel

Abgedeckt durch examples/rust/impl_tuple_struct.rs und examples/rust/mut_self_method.rs.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Rust closures - Inline-Funktionen erfassen und aufrufen — PBXB64 Help

Startseite › BASIC Frontend › Rust closures - Inline-Funktionen erfassen und aufrufen — PBXB64 Help
Hilfe zum PBXB64-Compiler

Rust closures - Inline-Funktionen erfassen und aufrufen

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

Closures verwenden die Rust-artige Syntax |args| body. PBXB64 senkt einen Closure-Wert zu Funktionspointer plus Environment-Pointer ab, wenn Captures benoetigt werden.

Syntax

let add1 = |x: i64| x + 1;
let v = add1(41);

Captures

let base: i64 = 10;
let add_base = |x: i64| x + base;

Threads

Die Thread-Task-Beispiele decken Closure-Worker, Inline-Closure-Spawning und erfasste Struct-Werte ab.

Verifiziertes Beispiel

Abgedeckt durch examples/rust/closure_value.rs, examples/rust/closure_capture.rs und die thread_task_*closure*-Beispiele.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Rust generics - Type-Erased-Teilmenge verwenden — PBXB64 Help

Startseite › BASIC Frontend › Rust generics - Type-Erased-Teilmenge verwenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

Rust generics - Type-Erased-Teilmenge verwenden

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

Syntax

Use the focused Rust-subset forms shown in the examples below. The referenced validation sample is the source-truth syntax for this construct.

PBXB64 unterstuetzt minimale generische Syntax fuer Funktionen und Structs. Typparameter werden fuer die getesteten Formen geparst und geloescht; das ist keine Rust-Monomorphisierung und enthaelt keine Trait Bounds.

Generische Funktionen

fn id<T>(x: T) -> T {
    return x;
}

Generische Structs

struct Wrapper<T>(T);

Grenzen

Trait Bounds, where-Klauseln, Spezialisierung, generische Enums und Const Generics sind nicht zertifiziert. Verwenden Sie diese Syntax nur fuer die getesteten einfachen Muster mit einem Typparameter.

Verifiziertes Beispiel

Abgedeckt durch tests/rust/generic_fn.rs und tests/rust/generic_struct.rs.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Rust extern/static - Symbole aufrufen und Globals teilen — PBXB64 Help

Startseite › BASIC Frontend › Rust extern/static - Symbole aufrufen und Globals teilen — PBXB64 Help
Hilfe zum PBXB64-Compiler

Rust extern/static - Symbole aufrufen und Globals teilen

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

Syntax

Use the focused Rust-subset forms shown in the examples below. The referenced validation sample is the source-truth syntax for this construct.

extern-Bloecke deklarieren fremde Funktionen oder statische Symbole, die ueber den normalen PBXB64-Objekt-/Linkpfad gebunden werden. static mut deklariert veraenderlichen globalen Speicher in Rust-Quelltext.

Extern-Funktion

extern "C" {
    fn host_add(x: i64, y: i64) -> i64;
}

Extern-/Static-Daten

extern "C" {
    static mut HOST_VALUE: f64;
}

Verifiziertes Beispiel

Abgedeckt durch examples/rust/extern_decl.rs, und examples/rust/static_global.rs. Host-gebundene Extern-Datenfaelle werden in der Rust-Matrix geprueft, weil sie ein Begleitobjekt mit dem importierten Symbol benoetigen.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Rust thread tasks - Native Worker starten und verbinden — PBXB64 Help

Startseite › BASIC Frontend › Rust thread tasks - Native Worker starten und verbinden — PBXB64 Help
Hilfe zum PBXB64-Compiler

Rust thread tasks - Native Worker starten und verbinden

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

Syntax

Use the focused Rust-subset forms shown in the examples below. The referenced validation sample is the source-truth syntax for this construct.

PBXB64 stellt native Thread-Helfer fuer Rust-Worker-Funktionen und Closure-Worker bereit. Die getestete API-Familie verwendet rust_thread_spawnN_i64, rust_thread_join_i64, detach, is_finished, join_timeout und sleep_ms.

Worker-Form

fn worker(x: i64) -> i64 {
    return x + 1;
}

Lebenszyklus

Spawn liefert einen Handle. Join wartet und liefert das Worker-Ergebnis. Detached Worker duerfen nach Rueckkehr eines eingebetteten Blocks nicht mehr auf PB-Host-Lokale zugreifen.

Verifiziertes Beispiel

Abgedeckt durch die examples/rust/thread_task_*.rs-Gruppe und eingebettete Thread-Bridge-Tests unter tests/rust/embedded_thread_*.pb.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Rust-Kontrollfluss — PBXB64 Help

Startseite › BASIC Frontend › Rust Control Flow

Rust-Kontrollfluss

Category: Rust Frontend

PBXB64 Status: UEBERSICHT

PBXB64 Certification: Overview page. The linked child pages carry the tested construct evidence.

Beschreibung

Strukturierter Rust-Subset-Kontrollfluss. Die Unterseite enthaelt jeweils getestete Syntax und Beispiel.

Syntax

Dieses Kapitel ist eine Navigationsuebersicht. Die exakte Syntax steht auf den verlinkten Einzelseiten und muss dort durch Beispiele oder Tests belegt sein.

Einzelseiten

  • if / else
  • while
  • for ranges
  • match

Pruefung

Validierungsbeleg: Die Unterseiten nennen konkrete Rust-Beispiele oder Validierungstests. Neue Rust-Frontend-Aussagen sollen nur mit Compile/Link/Run-Beleg ergaenzt werden.

Verifiziertes Beispiel

Diese Seite ist absichtlich nur ein Uebersichtskapitel; Syntax, Grenzen und getestete Beispiele stehen auf den Unterseiten.

PBXB64-Status: Uebersicht / Navigation; keine eigenstaendige Laufzeitbehauptung ohne Unterseitenbeleg.

Siehe auch

  • Rust Frontend
  • Language Frontends

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Rust if / else — PBXB64 Help

Startseite › BASIC Frontend › Rust if / else — PBXB64 Help

Rust if / else

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

if waehlt einen von zwei Anweisungsbloecken. Bedingungen werden als Integer-Boolean-Ausdruecke abgesenkt; null ist false, ungleich null ist true.

Syntax

if condition {
    statements;
} else {
    statements;
}

else-if-Kette

if x < 0 {
    return -1;
} else if x == 0 {
    return 0;
} else {
    return 1;
}

Vergleichsausdruecke

Die Bedingung kann ==, !=, <, <=, >, >=, logische Operatoren, Funktionsaufrufe und arithmetische Teilausdruecke verwenden.

Grenzen

Rust-if als allgemeiner Ausdruck ist nicht garantiert. Verwenden Sie explizite Zuweisungen oder return in den Bloecken.

Verifiziertes Beispiel

Das fokussierte Beispiel examples/rust/help_control_flow/help_rust_if.rs kompiliert und endet mit Exitcode 0. Es deckt eine else if-Kette mit Vergleichsbedingungen ab.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Rust while und loop — PBXB64 Help

Startseite › BASIC Frontend › Rust while und loop — PBXB64 Help
Hilfe zum PBXB64-Compiler

Rust while und loop

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

Syntax

Use the focused Rust-subset forms shown in the examples below. The referenced validation sample is the source-truth syntax for this construct.

Das Frontend unterstuetzt bedingungsgesteuerte Schleifen mit while und Endlosschleifen mit loop.

while

let mut i: i64 = 0;
while i < 10 {
    i += 1;
}

loop

loop {
    if done {
        break;
    }
}

break und continue

break verlaesst die naechste Schleife. continue springt zur naechsten Iteration. Verschachtelte Schleifen verwenden den naechsten Schleifenrahmen; gelabelte Breaks gehoeren nicht zum Subset.

Rueckgabe aus einer Schleife

while i < limit {
    if i == target {
        return i;
    }
    i += 1;
}

Verifiziertes Beispiel

Das fokussierte Beispiel examples/rust/help_control_flow/help_rust_while_loop.rs kompiliert und endet mit Exitcode 0. Es deckt eine bedingungsgesteuerte while-Schleife und die Aenderung des Schleifenzaehlers ab.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Rust for - Integer-Ranges iterieren — PBXB64 Help

Startseite › BASIC Frontend › Rust for - Integer-Ranges iterieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

Rust for - Integer-Ranges iterieren

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

for wird zu einer einfachen gezaehlten Integer-Schleife abgesenkt. Die Schleifenvariable ist eine lokale Integer-Bindung im Schleifenrumpf.

Syntax

for i in 0..5 {
    total += i;
}

for i in 1..=5 {
    total += i;
}

Range-Formen

lo..hi schliesst hi aus. lo..=hi schliesst hi ein. Grenzen sind in der getesteten Teilmenge Integer-Ausdruecke.

Verifiziertes Beispiel

Das fokussierte Beispiel examples/rust/help_control_flow/help_rust_for_ranges.rs kompiliert und endet mit Exitcode 0. Es deckt eine exklusive Integer-Range ab und prueft das aufsummierte Ergebnis.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Rust match — PBXB64 Help

Startseite › BASIC Frontend › Rust match — PBXB64 Help

Rust match

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

Syntax

Use the focused Rust-subset forms shown in the examples below. The referenced validation sample is the source-truth syntax for this construct.

match verzweigt einen Integer- oder C-Style-Enum-Wert in einen von mehreren Armen. PBXB64 senkt die unterstuetzten Arme zu Vergleichen und Sprungbloecken ab.

Literal-Arme

match value {
    0 => { return 10; }
    1 => { return 20; }
    _ => { return 30; }
}

Ranges

match value {
    1..=3 => { return 1; }
    4..6  => { return 2; }
    _     => { return 0; }
}

Wildcard

_ ist der Default-Arm. Er sollte fuer gut lesbaren Kontrollfluss zuletzt stehen.

Unterstuetzte Eingaben

Verwenden Sie Integer-Ausdruecke und Enum-Discriminants. Datenbehaftete Enum-Variantenpatterns mit Payload-Bindings, |-Alternativen und if-Guards sind Teil der getesteten Teilmenge. Allgemeines Struct-Destructuring und vollstaendige Rust-Pattern-Semantik bleiben ausserhalb dieser Seite.

Verifiziertes Beispiel

Das fokussierte Beispiel examples/rust/help_control_flow/help_rust_match.rs kompiliert und endet mit Exitcode 0. Es deckt inklusive Range-Arme und den Wildcard-Fallback-Arm ab.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Rust-Pointer und unsafe-Bloecke PBXB64 Help

Startseite › BASIC Frontend › Rust Pointers and Memory

Rust-Pointer und unsafe-Bloecke

Category: Rust Frontend

PBXB64 Status: UEBERSICHT

PBXB64 Certification: Overview page. The linked child pages carry the tested construct evidence.

Beschreibung

Raw-Pointer, Referenzen, Dereferenzierung und unsafe-Bloecke im PBXB64-Rust-Subset.

Syntax

Dieses Kapitel ist eine Navigationsuebersicht. Die exakte Syntax steht auf den verlinkten Einzelseiten und muss dort durch Beispiele oder Tests belegt sein.

Einzelseiten

  • raw pointers and references
  • unsafe blocks

Pruefung

Validierungsbeleg: Die Unterseiten nennen konkrete Rust-Beispiele oder Validierungstests. Neue Rust-Frontend-Aussagen sollen nur mit Compile/Link/Run-Beleg ergaenzt werden.

Verifiziertes Beispiel

Diese Seite ist absichtlich nur ein Uebersichtskapitel; Syntax, Grenzen und getestete Beispiele stehen auf den Unterseiten.

PBXB64-Status: Uebersicht / Navigation; keine eigenstaendige Laufzeitbehauptung ohne Unterseitenbeleg.

Siehe auch

  • Rust Frontend
  • Language Frontends

← Back


Rust Raw Pointer — PBXB64 Help

Startseite › BASIC Frontend › Rust Raw Pointer — PBXB64 Help

Rust Raw Pointer

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

Syntax

Use the focused Rust-subset forms shown in the examples below. The referenced validation sample is the source-truth syntax for this construct.

Raw Pointer verwenden *mut T und *const T. Das Frontend unterstuetzt Address-of, Dereferenz-Lesen und Dereferenz-Schreiben.

Deklaration

let p: *mut i64;

Address-of

let mut value: i64 = 0;
let p: *mut i64 = &mut value;

Dereferenz-Lesen und -Schreiben

unsafe {
    *p = 99;
    let copy = *p;
}

Safety-Modell

PBXB64 bietet keine Rust-Borrow-Checks, Lifetimes oder Alias-Pruefungen. Pointer-Korrektheit liegt wie im C-Frontend in der Verantwortung des Programms.

Verifiziertes Beispiel

Siehe examples/rust/pointers.rs.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Rust unsafe-Bloecke — PBXB64 Help

Startseite › BASIC Frontend › Rust unsafe-Bloecke — PBXB64 Help
Hilfe zum PBXB64-Compiler

Rust-unsafe-Bloecke

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

unsafe-Bloecke werden akzeptiert, damit pointerlastiger Code eine Rust-aehnliche Form behalten kann. In PBXB64 sind sie syntaktische Gruppierungsbloecke; sie aktivieren oder deaktivieren keinen Borrow Checker.

Syntax

unsafe {
    *ptr = 42;
}

Verwendung

Verwenden Sie unsafe um Raw-Pointer-Dereferenzen und anderen Code, der in Rust unsafe waere. Das macht die Absicht klar, auch wenn das Frontend die Rust-Sicherheitsgrenze nicht erzwingt.

Absenkung

Die Anweisungen im Block werden wie normale Anweisungen abgesenkt. Der Block selbst hat keine Laufzeitkosten.

Grenzen

Rust-Alias-Analyse, Lifetime-Pruefung, unsafe traits, Inline-Assembly und unsafe-Funktionsvertraege sind fuer Rust-Quelltext nicht implementiert.

Verifiziertes Beispiel

Siehe examples/rust/pointers.rs.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Rust-Structs und Enums — PBXB64 Help

Startseite › BASIC Frontend › Rust Structs and Enums

Rust-Structs und Enums

Category: Rust Frontend

PBXB64 Status: UEBERSICHT

PBXB64 Certification: Overview page. The linked child pages carry the tested construct evidence.

Beschreibung

Aggregate und Enum-Formen, die das PBXB64-Rust-Frontend unterstuetzt.

Syntax

Dieses Kapitel ist eine Navigationsuebersicht. Die exakte Syntax steht auf den verlinkten Einzelseiten und muss dort durch Beispiele oder Tests belegt sein.

Einzelseiten

  • named structs
  • tuple structs
  • unit structs
  • enums

Pruefung

Validierungsbeleg: Die Unterseiten nennen konkrete Rust-Beispiele oder Validierungstests. Neue Rust-Frontend-Aussagen sollen nur mit Compile/Link/Run-Beleg ergaenzt werden.

Verifiziertes Beispiel

Diese Seite ist absichtlich nur ein Uebersichtskapitel; Syntax, Grenzen und getestete Beispiele stehen auf den Unterseiten.

PBXB64-Status: Uebersicht / Navigation; keine eigenstaendige Laufzeitbehauptung ohne Unterseitenbeleg.

Siehe auch

  • Rust Frontend
  • Language Frontends

← Back

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


Rust Named Structs — PBXB64 Help

Startseite › BASIC Frontend › Rust Named Structs — PBXB64 Help
Hilfe zum PBXB64-Compiler

Rust Named Structs

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

Syntax

Use the focused Rust-subset forms shown in the examples below. The referenced validation sample is the source-truth syntax for this construct.

Structs mit benannten Feldern sind fuer Speicher, Feldzuweisung, Feldlesen, verschachtelte Aggregate und Funktionsparameter unterstuetzt.

Deklaration

struct Point {
    x: i64,
    y: i64,
}

Feldzugriff

let p: Point;
p.x = 3;
p.y = 4;
return p.x + p.y;

Structs uebergeben

Struct-by-value folgt der Win64-ABI des Backends: kleine Aggregate mit 1, 2, 4 oder 8 Bytes koennen in einem Register uebergeben werden; groessere Aggregate werden per hidden pointer uebergeben.

Verschachtelte Structs

struct Pair {
    left: Point,
    right: Point,
}

Verwandte unterstuetzte Formen

Tuple Structs, Unit Structs, impl-Methoden und Associated Functions sind in der getesteten Teilmenge unterstuetzt und auf eigenen Seiten dokumentiert. Derives, Traits und vollstaendige Rust-Visibility-/Modulsemantik sind nicht unterstuetzt.

Verifiziertes Beispiel

Siehe examples/rust/struct.rs.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


Rust tuple structs - Positionale Felder benennen — PBXB64 Help

Startseite › BASIC Frontend › Rust tuple structs - Positionale Felder benennen — PBXB64 Help
Hilfe zum PBXB64-Compiler

Rust tuple structs - Positionale Felder benennen

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

Tuple Structs verbinden einen benannten Typ mit positionalen Feldern. PBXB64 speichert die Felder als Aggregate-Member mit Indexnamen.

Syntax

struct Point(i64, i64);

fn main() -> i64 {
    let p = Point(3, 4);
    return p.0 + p.1;
}

Unterstuetztes Verhalten

Konstruktion durch Aufruf des Tuple-Struct-Namens, Feldlesen mit .0 und Verwendung mit Methoden in impl-Bloecken sind durch die aktuellen Beispiele abgedeckt.

Verifiziertes Beispiel

Abgedeckt durch examples/rust/impl_tuple_struct.rs.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


Rust unit structs - Marker-Typen deklarieren — PBXB64 Help

Startseite › BASIC Frontend › Rust unit structs - Marker-Typen deklarieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

Rust unit structs - Marker-Typen deklarieren

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

Ein Unit Struct deklariert einen benannten Typ ohne Felder. Der Parser akzeptiert ihn und senkt ihn als Aggregate-Typ ohne Payload-Felder ab.

Syntax

struct Marker;

Verwendung

Unit Structs eignen sich als Marker-Werte fuer Code, der einen benannten Rust-artigen Typ ohne Speicherfelder braucht. Traits, Derives oder Modul-Visibility-Semantik werden dadurch nicht bereitgestellt.

Verifiziertes Beispiel

Abgedeckt durch die Rust-Frontend-Beispiele und Matrixfaelle aus dem Restart-Vertrag.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


Rust C-Style-Enums — PBXB64 Help

Startseite › BASIC Frontend › Rust C-Style-Enums — PBXB64 Help
Hilfe zum PBXB64-Compiler

Rust-C-Style-Enums

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

Syntax

Use the focused Rust-subset forms shown in the examples below. The referenced validation sample is the source-truth syntax for this construct.

Der verifizierte Enum-Umfang gilt fuer feldlose C-Style-Enum-Varianten. Jede Variante wird zu einem Integer-Discriminant abgesenkt.

Implizite Discriminants

enum State {
    Idle,
    Running,
    Done,
}

Explizite Discriminants

enum Code {
    Ok = 0,
    Missing = 10,
    Failed = 20,
}

Enums in Ausdruecken

Enum-Varianten koennen verglichen, zurueckgegeben und in match- Armen wie Integer-Werte verwendet werden.

match state {
    State::Idle => { return 1; }
    State::Running => { return 2; }
    _ => { return 0; }
}

Datenbehaftete Varianten

Tuple-artige Payload-Varianten wie Some(i64) sind fuer Konstruktion und getestetes match-Payload-Binding unterstuetzt. Struct-artige Varianten, generische Enums und vollstaendige Rust- Destructuring-Patterns liegen ausserhalb der verifizierten Teilmenge.

Verifiziertes Beispiel

Siehe examples/rust/data_enum_bare.rs.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Rust-Operatoren — PBXB64 Help

Startseite › BASIC Frontend › Rust Operators

Rust-Operatoren

Category: Rust Frontend

PBXB64 Status: UEBERSICHT

PBXB64 Certification: Overview page. The linked child pages carry the tested construct evidence.

Beschreibung

Arithmetische und logische Operatoren mit getestetem PBXB64-Rust-Subset-Verhalten.

Syntax

Dieses Kapitel ist eine Navigationsuebersicht. Die exakte Syntax steht auf den verlinkten Einzelseiten und muss dort durch Beispiele oder Tests belegt sein.

Einzelseiten

  • arithmetic, comparison, and cast operators
  • logical operators

Pruefung

Validierungsbeleg: Die Unterseiten nennen konkrete Rust-Beispiele oder Validierungstests. Neue Rust-Frontend-Aussagen sollen nur mit Compile/Link/Run-Beleg ergaenzt werden.

Verifiziertes Beispiel

Diese Seite ist absichtlich nur ein Uebersichtskapitel; Syntax, Grenzen und getestete Beispiele stehen auf den Unterseiten.

PBXB64-Status: Uebersicht / Navigation; keine eigenstaendige Laufzeitbehauptung ohne Unterseitenbeleg.

Siehe auch

  • Rust Frontend
  • Language Frontends

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Rust arithmetische und bitweise Operatoren — PBXB64 Help

Startseite › BASIC Frontend › Rust arithmetische und bitweise Operatoren — PBXB64 Help
Hilfe zum PBXB64-Compiler

Rust arithmetische und bitweise Operatoren

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

Syntax

Use the focused Rust-subset forms shown in the examples below. The referenced validation sample is the source-truth syntax for this construct.

Das Rust-Frontend senkt arithmetische und bitweise Operatoren auf die gemeinsamen PBXB64-IR-Operatoren ab, die auch B64 und C verwenden.

Arithmetik

let a = x + y;
let b = x - y;
let c = x * y;
let d = x / y;
let e = x % y;

Bitweise Operatoren

let a = x & y;
let b = x | y;
let c = x ^ y;
let d = x << 2;
let e = x >> 1;

Zusammengesetzte Zuweisung

total += 1;
mask ^= flag;
value <<= 1;

Typregel

Halten Sie beide Operanden moeglichst in derselben numerischen Familie. Verwenden Sie as fuer explizite Casts zwischen signed/unsigned oder Integer/Float.

Verifiziertes Beispiel

Siehe examples/rust/arithmetic.rs und examples/rust/logical.rs.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Rust logische Operatoren — PBXB64 Help

Startseite › BASIC Frontend › Rust logische Operatoren — PBXB64 Help
Hilfe zum PBXB64-Compiler

Rust logische Operatoren

Category: Rust Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: CERTIFIED TESTED - source/test-backed Rust subset behavior, with limits stated on this page.

Beschreibung

Syntax

Use the focused Rust-subset forms shown in the examples below. The referenced validation sample is the source-truth syntax for this construct.

Die logischen Operatoren erzeugen normalisierte Boolean-Werte und verwenden Rust-artige Short-Circuit-Auswertung.

Operatoren

let both = a && b;
let either = a || b;
let inverse = !a;

Short-Circuit-Verhalten

&& ueberspringt die rechte Seite, wenn der linke Operand false ist. || ueberspringt die rechte Seite, wenn der linke Operand true ist. Damit sind Nullpointer-Guards in der rechten Seite moeglich.

Beispiel

if ptr != 0 {
    if *ptr == 10 {
        return 1;
    }
}

Vergleiche

Vergleichsoperatoren liefern Boolean-Werte, die in logischen Operatoren und Kontrollflussbedingungen verwendbar sind.

if (x >= 0) && (x < limit) {
    return x;
}

Verifiziertes Beispiel

Siehe examples/rust/logical.rs.

Siehe auch

Rust-Frontend, Rust-Funktionen, Rust-Control-Flow, Rust-Typen

Pruefung

Validierungsbeleg: Das auf dieser Seite genannte fokussierte Rust-Beispiel oder der genannte Validierungstest ist der Compile/Link/Run-Beleg fuer das dokumentierte Konstrukt. Eigenstaendige Rust-Beispiele mit PBXB64 example.rs -o example.exe kompilieren und die EXE ausfuehren, um den erwarteten Prozess-Exitcode zu pruefen.

Pruefliste

Kompilieren Sie das genannte Beispiel mit PBXB64 example.rs -o example.exe, fuehren Sie die EXE aus und dokumentieren Sie den erwarteten Prozess-Exitcode. Die Seite soll nur Verhalten beschreiben, das im PBXB64-Rust-Frontend implementiert und durch ein Beispiel oder eine Matrixprobe abgedeckt ist.

Absenkung und Diagnosen

Das Rust-Frontend parst das Konstrukt in die gemeinsame PBXB64-AST und senkt es in dieselbe IR ab, die auch die B64-, C-, COBOL- und BASIC-Frontends nutzen. Eine als verfuegbar markierte Seite muss abgesenktes Verhalten, akzeptierte Syntax, relevante Grenzen und den beweisenden Test oder das Beispiel nennen. Nicht unterstuetzte Rust-Sprachformen muessen als Grenzen dokumentiert bleiben, statt durch aehnlich aussehende Syntax impliziert zu werden.

Frontend-Grenze

Dies ist ein Rust-Subset-Frontend, kein vollstaendiger Rust-Compiler. Standardbibliothek, Cargo-Metadaten, Borrow Checking, Lifetime-Analyse, Traits, Generics, Makros und vollstaendige Rust-Pattern-Semantik duerfen nur behauptet werden, wenn eine separate Seite die Funktion ausdruecklich dokumentiert und verifiziert.

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PBXB64 - COBOL Language (V10)

Startseite › Language Frontends › COBOL Frontend

COBOL Language Reference (COBOL-85 Core Subset)

PBXB64 supports a COBOL-85 core language that compiles to the same unified IR — and the same Windows x64 PE32+ executables — as B64, C, BASIC and PILOT. The frontend lowers COBOL source to the shared IrModule in a single pass using exact scaled fixed-point arithmetic for all numeric PIC fields — no floating-point rounding loss.

File extensions: .cbl, .cob, .CBL, .COB. Embedded COBOL blocks inside a host source file are recognized between the #COBOL and #COBOL END markers and execute at the directive site through a generated callable helper.

Referenzseiten

Diese Seite ist die Uebersicht zum Frontend. Die verlinkten Einzelseiten enthalten Syntax, getestete Beispiele, Status und Grenzen fuer die jeweiligen Befehle oder Sprachkonstrukte.

  • Divisions
  • Datenbeschreibung
  • Arithmetik und Datenbewegung
  • Kontrollfluss
  • Konsole und Strings
  • Aufrufe und Parameter
  • Datei-E/A
  • Copybooks
  • Eingebettetes COBOL in BASIC

Command-Line Invocation

PBXB64 program.cbl -o program.exe

A standalone COBOL source file is classified by its extension and compiled and linked like any other frontend:

PBXB64 hello.cbl -o hello.exe
hello.exe

Embedded COBOL blocks within a host file (e.g. PowerBASIC) use the directive markers, analogous to the existing #FORTH mechanism:

#COBOL
       IDENTIFICATION DIVISION.
       PROGRAM-ID. EMBEDDED.
       PROCEDURE DIVISION.
           DISPLAY "From embedded COBOL".
           STOP RUN.
#COBOL END

In a host source file, the embedded COBOL block does not create a competing standalone main entry. PBXB64 lowers the block as an internal helper and emits a host-side call where the #COBOL directive appears.

Program Structure (Divisions)

A COBOL program consists of up to four divisions, which must appear in this order:

Division | Role | Support
IDENTIFICATION DIVISION | Program name and metadata (PROGRAM-ID) | Read, then skipped
ENVIRONMENT DIVISION | Konfiguration und line-sequential I/O-Zuweisungen | SELECT ... ASSIGN wird fuer unterstuetzte Datei-I/O erkannt
DATA DIVISION | Datendefinitionen (WORKING-STORAGE und unterstuetzte FILE SECTION-Datensaetze) | Unterstuetzte Teilmenge
PROCEDURE DIVISION | Executable statements and paragraphs | Fully supported
       IDENTIFICATION DIVISION.
       PROGRAM-ID. MY-PROGRAM.
       DATA DIVISION.
       WORKING-STORAGE SECTION.
       01  WS-VALUE   PIC 9(4)  VALUE 0.
       PROCEDURE DIVISION.
       MAIN-PARA.
           MOVE 42 TO WS-VALUE.
           DISPLAY WS-VALUE.
           STOP RUN.
Source form: The frontend is free-form tolerant. Leading whitespace, fixed-column layout (Area A/B), sequence columns, fixed-form comment lines, basic continuation lines, and simple source-local COPY copybooks are accepted.

DATA DIVISION (Data Definitions)

PIC Symbols

Symbol | Meaning
9 | Numeric digit (0–9)
X | Alphanumeric character
A | Alphabetic character
S | Sign (leading, signed)
V | Implied decimal point
Z | Zero suppression
P | Scaling position
(n) | Repetition factor, e.g. 9(5) = five digits

Examples

01  WS-COUNT     PIC 9(3)       VALUE 0.
01  WS-AMOUNT    PIC 9(7)V99    VALUE 1234.50.
01  WS-STOCK     PIC S9(6)      VALUE -100.
01  WS-NAME      PIC X(20)      VALUE "unknown".
01  WS-FILLER    PIC X(10)      VALUE SPACES.
01  WS-TABLE     PIC 9(3)       OCCURS 5 TIMES.

External Data Symbols

EXTERNAL and GLOBAL on WORKING-STORAGE items export the item as an object symbol with the exact COBOL source spelling:

01  SHARED-COUNT PIC S9(9) VALUE 41 EXTERNAL.

Das Objektsymbol ist SHARED-COUNT. Eine BASIC-Hauptquelle kann ein COBOL-eigenes numerisches External mit BRIDGE IMPORT name AS QUAD ALIAS "SHARED-COUNT" binden; die fokussierte Regression tests/pb/test_bridge_cobol_import_numeric.pb beweist, dass BASIC ein COBOL-Feld PIC S9(9) EXTERNAL lesen und schreiben kann. BASIC kann auch festen COBOL-Byte-Speicher mit BRIDGE IMPORT name AS STRINGZ * n ALIAS "COBOL-TEXT" binden; tests/pb/test_bridge_cobol_import_picx.pb beweist exakte Byte-Lesezugriffe ueber PEEK$ und Schreibzugriffe ueber den festen BASIC-Pufferpfad. Wenn COBOL die Hauptquelle ist, veroeffentlichen skalare numerische und feste PIC X/PIC A-EXTERNAL/GLOBAL-Elemente Bridge-Metadaten und erzeugen dieselbe C-Bridge-Header-Oberflaeche wie BASIC-Bridge-Builds. Dieser Bridge-Slice umfasst jetzt getestete numerische Export-Formen fuer DISPLAY, BINARY/COMP, COMP-3 und COMP-5; tests/cobol/bridge_cobol_primary_usage.cbl beweist, dass C-Consumer gepackten und nativen Binaerspeicher ueber die generierten Aliase aendern koennen. Der naechste Bridge-Slice deckt jetzt feste OCCURS-Arrays fuer dieselben Skalarformen ab: tests/cobol/bridge_cobol_primary_occurs_numeric.cbl beweist, dass C-Consumer einen numerischen OCCURS 3 TIMES-Export ueber den generierten Alias und die ausgegebenen PB_BRIDGE_*_COUNT/PB_BRIDGE_*_ELEMENT_SIZE-Metadaten lesen und schreiben koennen, und tests/cobol/bridge_cobol_primary_occurs_picx.cbl beweist dasselbe fuer festen PIC X(5) OCCURS 2 TIMES-Speicher. Ein-Level verschachtelte Gruppen mit festen Elementarfeldern werden ebenfalls als Bridge-Structs mit flachgezogenen, alias-sicheren Feldnamen und Offset-Metadaten ausgegeben: tests/cobol/bridge_cobol_group_nested_export.cbl beweist, dass C-Consumer verschachtelte Felder ueber die generierten Aliase aendern koennen, waehrend das exakte COBOL-Objektsymbol intakt bleibt. COBOL-Namen mit Bindestrich behalten ihr exaktes Objektsymbol und erhalten zusaetzlich einen C-sicheren Alias, zum Beispiel COBOL_COUNT fuer COBOL-COUNT; tests/cobol/bridge_cobol_primary_numeric.cbl, tests/cobol/bridge_cobol_primary_picx.cbl und die neuen OCCURS-Regressionen beweisen, dass C-Consumer numerischen und festen Byte-Speicher von COBOL ueber diese generierten Aliase aendern koennen. In der anderen Besitzrichtung beweist tests/pb/test_bridge_basic_cobol_export_picx.pb, dass ein BASIC-eigener BRIDGE EXPORT ... AS STRINGZ * 8 ALIAS "BASIC-TEXT" von COBOL als 01 BASIC-TEXT PIC X(8) EXTERNAL importiert werden kann; abweichende PIC X-Breiten werden abgelehnt. Doppelte COBOL-EXTERNAL/GLOBAL-Datensymbole, generierte Alias-Kollisionen und nicht unterstuetzte Aggregate oder OCCURS-Bridge-Exports werden zur Compile-Zeit abgelehnt. Die neuen OCCURS-Mismatch-Regressionen lehnen sowohl falsche Consumer-Array-Groessen als auch falsche Elementbreiten zur Compile-Zeit ab. Eingebettetes #COBOL USING-Hostvariablen-Binding ist fuer ganzzahlige BASIC-Skalarvariablen und feste STRINGZ * n-Puffer getestet: COBOL sieht Integer-Hosts als numerische 8-Byte-Felder, kann sie anzeigen oder aendern, und sieht feste Puffer als PIC X(n)-Speicher, der exakte Bytes round-tripped. Unbekannte Hostnamen, mehr als acht Hostvariablen, unsized STRINGZ, dynamische Strings, Gleitkommavariablen, Arrays, Strukturen, Objekte, Varianten und PICFIELD-Handles werden zur Compile-Zeit abgelehnt, bis sie einen eigenen typisierten Bridge-Vertrag haben.

Numeric Storage Accuracy

Every numeric field is stored as a scaled 64-bit integer (value × 10^scale). Arithmetic uses only native integer operations and is exact for all COBOL-85 fields up to 18 digits — no floating-point rounding loss. When storing into a field, the full COBOL-85 rules are enforced:

Rule | Behaviour
High-order digit truncation | MOVE 1234 TO 9(3) stores 234
Sign with unsigned PIC 9 (no S) | Absolute value forced: MOVE -55 TO 9(4) → 55
Sign with PIC S9 | Sign preserved: MOVE -55 TO S9(4) → -55

PROCEDURE DIVISION (Statements)

Executable code is organized into paragraphs. A paragraph header is an identifier followed by a period. Forward references to paragraphs (e.g. in PERFORM) are supported.

Supported Statements

Statement | Description
DISPLAY | Outputs operands (literals and fields) to the console, followed by a newline
ACCEPT | Reads a value from the console into a field
MOVE | Transfers a value into a field (numeric with scaling/conversion, alphanumeric with padding)
ADD | Adds operands to receivers: ADD a TO b or ADD a b GIVING c
SUBTRACT | Subtracts: SUBTRACT a FROM b or SUBTRACT a FROM b GIVING c
MULTIPLY | Multiplies: MULTIPLY a BY b (result in b) or MULTIPLY a BY b GIVING c
DIVIDE | Divides: DIVIDE a INTO b, DIVIDE a BY b GIVING c
COMPUTE | Computes an expression into a field
IF / ELSE / END-IF | Conditional branching
PERFORM | Fuehrt Paragraphen und getestete Schleifen aus: einfach, THRU, UNTIL, VARYING und n TIMES
GO TO | Springt zu einem Paragraphen, einschliesslich berechnetem GO TO ... DEPENDING ON
STOP RUN | Terminates the program with return code 0
CONTINUE | No operation
EVALUATE | Mehrfachverzweigung mit WHEN, mehreren Werten und WHEN OTHER
GOBACK | Kehrt aus dem aktuellen COBOL-Programm oder Hilfsprogramm zurueck
EXIT PERFORM | Bricht die naechstgelegene inline PERFORM-Schleife ab
STRING / UNSTRING | Baut und teilt Festfeld-Strings in der implementierten Begrenzer-Teilmenge
INSPECT | Zaehlen, Ersetzen und Konvertieren mit getesteten Einbyte- und Mehrbyte-Operanden
INITIALIZE | Fuellt numerische Felder mit null und alphanumerische Felder mit Leerzeichen
SET | Setzt getestete 88-Level-Bedingungsnamen auf TRUE
CALL | Ruft externe Symbole mit getesteten USING-, BY VALUE- und GIVING-Formen auf
OPEN / READ / WRITE / CLOSE | Line-sequential Datei-I/O in der getesteten Datensatz-Teilmenge
SEARCH | Lineare Suche ueber feste OCCURS-Tabellen mit VARYING, AT END, WHEN und END-SEARCH

ROUNDED Clause

The optional ROUNDED clause rounds the arithmetic result half-away-from-zero before storage, while the default truncates:

       MULTIPLY 1.0055 BY WS-VALUE ROUNDED.   *> 10.055 -> 10.06
       MULTIPLY 1.0055 BY WS-VALUE.            *> 10.055 -> 10.05 (truncated)

Conditions (Comparisons)

Relational operators are supported both as symbols and in word form:

Operator | Word form | Meaning
= | EQUAL | equal
<> | NOT EQUAL | not equal
< | LESS | less than
<= | — | less than or equal
> | GREATER | greater than
>= | — | greater than or equal

Conditions can be combined with AND, OR, NOT and grouped with parentheses:

       IF WS-AGE >= 18 AND WS-COUNTRY = "US"
           DISPLAY "Adult in the US".

Bedingungsnamen (88-Ebene)

Ein 88-Eintrag bindet einen benannten Bedingungsnamen an den Wert des übergeordneten Elementarfelds. SET weist dem Elternfeld den aufgezeichneten Wert zu; der bloße Bedingungsname prüft auf Gleichheit damit.

       01  WS-STATUS PIC 9(1) VALUE 0.
           88  IS-OK    VALUE 1.
           88  IS-ERROR VALUE 2.
       ...
           SET IS-OK TO TRUE.            *> WS-STATUS = 1
           IF IS-OK DISPLAY "ok" END-IF. *> WS-STATUS = 1 ?

EVALUATE (Mehrfachverzweigung)

EVALUATE wühlt eine WHEN-Klausel durch Gleichheit mit dem Subjekt aus; WHEN OTHER ist der Standardfall.

       EVALUATE WS-DAY
           WHEN 1 DISPLAY "MONDAY"
           WHEN 2 DISPLAY "TUESDAY"
           WHEN OTHER DISPLAY "OTHER"
       END-EVALUATE.

STRING / INSPECT / INITIALIZE / SET

       STRING "HELLO" " " "WORLD" DELIMITED BY SIZE INTO WS-OUT.
       INSPECT WS-BUF REPLACING ALL "A" BY "X".
       INSPECT WS-BUF CONVERTING "a" TO "A".
       INITIALIZE WS-NUM WS-TXT.
       SET IS-OK TO TRUE.

MOVE CORRESPONDING / qualifizierte Namen

MOVE CORRESPONDING übertrügt gleichnamige Elementarfelder zwischen zwei Gruppen. Namen dürfen mit OF oder IN qualifiziert werden.

       MOVE CORRESPONDING REC-A TO REC-B.
       MOVE FLD-X OF REC-A TO WS-OUT.

USAGE / REDEFINES / GOBACK / EXIT PERFORM

USAGE-Klauseln (COMP, COMP-3, BINARY, PACKED-DECIMAL, DISPLAY ...) werden akzeptiert; alle Zahlen werden als skaliertes int64 gespeichert. REDEFINES aliasiert den Speicher eines Elementarfelds. GOBACK kehrt aus dem Programm zurück. EXIT PERFORM bricht die n&aauml;chstgelegene inline PERFORM-Schleife ab. PROCEDURE-DIVISION-SECTION-Header werden als Bereichsmarkierungen akzeptiert. CALL "name" USING ... ruft ein externes Symbol auf; Standardargumente werden per Referenz uebergeben, und BY VALUE plus GIVING unterstuetzt Runtime-ABI-Aufrufe mit ganzzahligem Rueckgabewert.

Primäre COBOL-EXTERNAL- und GLOBAL-Elemente erzeugen ebenfalls Bridge-Metadaten für C-Verbraucher. Skalare Zahlen bleiben bei festen Breiten, feste PIC X/PIC A-Felder bleiben Byte-Arrays, ein-Level verschachtelte Gruppen mit festen Elementarfeldern werden als gepackte C-Structs mit flachgezogenen, alias-sicheren Feldnamen ausgegeben, und feste OCCURS-Arrays solcher Gruppen werden als C-Arrays dieser Structs mit Elementgrößen-Metadaten und Offset-Assertions ausgegeben. Tiefer oder mehrdeutig verschachtelte Gruppen, Gruppen-REDEFINES und OCCURS innerhalb von Gruppen liegen weiterhin ausserhalb dieser Bridge-Teilmenge.

Example Program

       IDENTIFICATION DIVISION.
       PROGRAM-ID. HELLO.
       DATA DIVISION.
       WORKING-STORAGE SECTION.
       01  WS-NAME      PIC X(12) VALUE "World".
       01  WS-COUNT     PIC 9(3)  VALUE 0.
       01  WS-PRICE     PIC 9(5)V99 VALUE 19.95.
       PROCEDURE DIVISION.
       MAIN-PARA.
           DISPLAY "COBOL on PBXB64!".
           DISPLAY "Hello " WS-NAME.
           MOVE 42 TO WS-COUNT.
           DISPLAY "Count is " WS-COUNT.
           DISPLAY "Price is " WS-PRICE.
           STOP RUN.

Output:

COBOL on PBXB64!
Hello World
Count is 42
Price is 19.95

Decimal Runtime (DECIMAL128 and UNL)

For fields that need higher precision, the COBOL runtime provides corrected DECIMAL128 functions (cobol_dec128_mul/div via __int128, no double round-trip) and UNL-backed arbitrary-precision decimal operations for COBOL-2002 fields up to 31 digits. The default scaled int64 path is exact for all COBOL-85 widths.

Bekannte Einschraenkungen: Sequentielle zeilenorientierte Datei-I/O ist fuer die getestete OPEN/READ/WRITE/CLOSE-Teilmenge implementiert, aber REWRITE, DELETE, START, indexierte/relative Dateien und SORT/MERGE sind nicht implementiert. OCCURS DEPENDING ON, mehrere COPY ... REPLACING-Paare, Kommandozeilen-Copybook-Suchpfade, tiefer verschachtelte Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische Speicherauswahl fuer mehr als 18-stellige PIC-Felder liegen ausserhalb der zertifizierten Oberflaeche.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Back to command index


COBOL Divisions - PBXB64 COBOL Help

Startseite › BASIC Frontend › COBOL Divisions

COBOL Divisions

Kind: Reference hub | Category: COBOL Frontend

PBXB64 Status: Overview / navigation; child pages carry the command-specific support proof.

Beschreibung

Diese Seite ist ein Ueberblickskapitel. Die einzelnen COBOL-Befehle und Klauseln stehen darunter jeweils auf eigenen, getesteten Referenzseiten.

Syntax

IDENTIFICATION DIVISION.
DATA DIVISION.
PROCEDURE DIVISION.

Einzelseiten

  • IDENTIFICATION DIVISION
  • ENVIRONMENT DIVISION
  • DATA DIVISION
  • PROCEDURE DIVISION
  • SECTION

Pruefung

Die darunterliegenden Seiten nennen konkrete Dateien aus den COBOL-Validierungslaeufen. Neue COBOL-Hilfeintraege sollen nur mit compile/link/run-Beleg ergaenzt werden.

Validation evidence: COBOL command pages cite registered COBOL validation files such as tests/cobol/gaps.cbl or a focused sibling test.

Getestetes Beispiel

       IDENTIFICATION DIVISION.
       PROGRAM-ID. HELP.
       PROCEDURE DIVISION.
           STOP RUN.

Diese Seite ist ein Uebersichtskapitel. Die verlinkten Einzelseiten enthalten die konkreten getesteten Beispiele oder nennen eine ausdrueckliche Begrenzung, wenn ein Befehl nicht zertifiziert ist.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für COBOL Divisions soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' COBOL Divisions mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.

Zurueck zum Befehlsindex


IDENTIFICATION DIVISION - Deklariert COBOL-Programminformationen. - PBXB64 COBOL Help

Startseite › BASIC Frontend › IDENTIFICATION DIVISION - Deklariert COBOL-Programminformationen.
Hilfe zum PBXB64-Compiler

IDENTIFICATION DIVISION - Deklariert COBOL-Programminformationen.

Deklariert COBOL-Programminformationen.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

IDENTIFICATION DIVISION.
PROGRAM-ID. SAMPLE.

Beschreibung

IDENTIFICATION DIVISION hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

IDENTIFICATION DIVISION.
PROGRAM-ID. SAMPLE.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/hello.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


ENVIRONMENT DIVISION - Wird vom aktuellen nativen Frontend akzeptiert und uebersprungen, wenn vorhanden. - PBXB64 COBOL Help

Startseite › BASIC Frontend › ENVIRONMENT DIVISION - Wird vom aktuellen nativen Frontend akzeptiert und uebersprungen, wenn vorhanden.
Hilfe zum PBXB64-Compiler

ENVIRONMENT DIVISION - Wird vom aktuellen nativen Frontend akzeptiert und uebersprungen, wenn vorhanden.

Wird vom aktuellen nativen Frontend akzeptiert und uebersprungen, wenn vorhanden.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

ENVIRONMENT DIVISION.

Beschreibung

ENVIRONMENT DIVISION hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

ENVIRONMENT DIVISION.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/integration.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← IDENTIFICATION DIVISION - Deklariert COBOL-Programminformationen. Top DATA DIVISION - Startet die von PBXB64 COBOL unterstuetzten Working-Storage-Deklarationen. →


DATA DIVISION - Startet die von PBXB64 COBOL unterstuetzten Working-Storage-Deklarationen. - PBXB64 COBOL Help

Startseite › BASIC Frontend › DATA DIVISION - Startet die von PBXB64 COBOL unterstuetzten Working-Storage-Deklarationen.
Hilfe zum PBXB64-Compiler

DATA DIVISION - Startet die von PBXB64 COBOL unterstuetzten Working-Storage-Deklarationen.

Startet die von PBXB64 COBOL unterstuetzten Working-Storage-Deklarationen.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

DATA DIVISION.
WORKING-STORAGE SECTION.

Beschreibung

DATA DIVISION hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

DATA DIVISION.
WORKING-STORAGE SECTION.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/integration.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← ENVIRONMENT DIVISION - Wird vom aktuellen nativen Frontend akzeptiert und uebersprungen, wenn vorhanden. Top PROCEDURE DIVISION - Startet ausfuehrbare COBOL-Anweisungen. →


PROCEDURE DIVISION - Startet ausfuehrbare COBOL-Anweisungen. - PBXB64 COBOL Help

Startseite › BASIC Frontend › PROCEDURE DIVISION - Startet ausfuehrbare COBOL-Anweisungen.
Hilfe zum PBXB64-Compiler

PROCEDURE DIVISION - Startet ausfuehrbare COBOL-Anweisungen.

Startet ausfuehrbare COBOL-Anweisungen.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PROCEDURE DIVISION.

Beschreibung

PROCEDURE DIVISION hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

PROCEDURE DIVISION.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/hello.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← DATA DIVISION - Startet die von PBXB64 COBOL unterstuetzten Working-Storage-Deklarationen. Top SECTION - Akzeptiert SECTION-Header in der PROCEDURE DIVISION als Bereichsmarkierungen. →


SECTION - Akzeptiert SECTION-Header in der PROCEDURE DIVISION als Bereichsmarkierungen. - PBXB64 COBOL Help

Startseite › BASIC Frontend › SECTION - Akzeptiert SECTION-Header in der PROCEDURE DIVISION als Bereichsmarkierungen.
Hilfe zum PBXB64-Compiler

SECTION - Akzeptiert SECTION-Header in der PROCEDURE DIVISION als Bereichsmarkierungen.

Akzeptiert SECTION-Header in der PROCEDURE DIVISION als Bereichsmarkierungen.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

MAIN-SECTION SECTION.

Beschreibung

SECTION hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

MAIN-SECTION SECTION.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/sections.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


COBOL-Datenbeschreibung - PBXB64 COBOL Help

Startseite › BASIC Frontend › COBOL Data Description

COBOL-Datenbeschreibung

Kind: Reference hub | Category: COBOL Frontend

PBXB64 Status: Overview / navigation; child pages carry the command-specific support proof.

Beschreibung

Diese Seite ist ein Ueberblickskapitel. Die einzelnen COBOL-Befehle und Klauseln stehen darunter jeweils auf eigenen, getesteten Referenzseiten.

Syntax

IDENTIFICATION DIVISION.
DATA DIVISION.
PROCEDURE DIVISION.

Einzelseiten

  • PIC
  • VALUE
  • OCCURS
  • 88 Condition Name
  • USAGE
  • REDEFINES
  • GLOBAL
  • EXTERNAL
  • OF / IN

Pruefung

Die darunterliegenden Seiten nennen konkrete Dateien aus den COBOL-Validierungslaeufen. Neue COBOL-Hilfeintraege sollen nur mit compile/link/run-Beleg ergaenzt werden.

Validation evidence: COBOL command pages cite registered COBOL validation files such as tests/cobol/gaps.cbl or a focused sibling test.

Getestetes Beispiel

       IDENTIFICATION DIVISION.
       PROGRAM-ID. HELP.
       PROCEDURE DIVISION.
           STOP RUN.

Diese Seite ist ein Uebersichtskapitel. Die verlinkten Einzelseiten enthalten die konkreten getesteten Beispiele oder nennen eine ausdrueckliche Begrenzung, wenn ein Befehl nicht zertifiziert ist.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für COBOL-Datenbeschreibung soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' COBOL-Datenbeschreibung mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.

Zurueck zum Befehlsindex

← SECTION - Akzeptiert SECTION-Header in der PROCEDURE DIVISION als Bereichsmarkierungen. Top PIC - Deklariert numerische und String-Speicherung mit 9/X/A/S/V/Z/P und Wiederholungszaehlern. →


PIC - Deklariert numerische und String-Speicherung mit 9/X/A/S/V/Z/P und Wiederholungszaehlern. - PBXB64 COBOL Help

Startseite › BASIC Frontend › PIC - Deklariert numerische und String-Speicherung mit 9/X/A/S/V/Z/P und Wiederholungszaehlern.
Hilfe zum PBXB64-Compiler

PIC - Deklariert numerische und String-Speicherung mit 9/X/A/S/V/Z/P und Wiederholungszaehlern.

Deklariert numerische und String-Speicherung mit 9/X/A/S/V/Z/P und Wiederholungszaehlern.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

01 WS-AMOUNT PIC 9(6)V99 VALUE 0.

Beschreibung

PIC hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

01 WS-AMOUNT PIC 9(6)V99 VALUE 0.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/accuracy.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


VALUE - Weist unterstuetzten Datenfeldern Anfangswerte zu. - PBXB64 COBOL Help

Startseite › BASIC Frontend › VALUE - Weist unterstuetzten Datenfeldern Anfangswerte zu.
Hilfe zum PBXB64-Compiler

VALUE - Weist unterstuetzten Datenfeldern Anfangswerte zu.

Weist unterstuetzten Datenfeldern Anfangswerte zu.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

01 WS-COUNT PIC 9(3) VALUE 5.

Beschreibung

VALUE hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

01 WS-COUNT PIC 9(3) VALUE 5.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/t1.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← PIC - Deklariert numerische und String-Speicherung mit 9/X/A/S/V/Z/P und Wiederholungszaehlern. Top OCCURS - Deklariert Arrays fester Groesse mit 1-basierten Subskripten. →


OCCURS - Deklariert Arrays fester Groesse mit 1-basierten Subskripten. - PBXB64 COBOL Help

Startseite › BASIC Frontend › OCCURS - Deklariert Arrays fester Groesse mit 1-basierten Subskripten.
Hilfe zum PBXB64-Compiler

OCCURS - Deklariert Arrays fester Groesse mit 1-basierten Subskripten.

Deklariert Arrays fester Groesse mit 1-basierten Subskripten.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

01 WS-LIST PIC 9(3) OCCURS 5 TIMES.

Beschreibung

OCCURS hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

01 WS-LIST PIC 9(3) OCCURS 5 TIMES.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/occurs.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← VALUE - Weist unterstuetzten Datenfeldern Anfangswerte zu. Top 88 Condition Name - Deklariert einen COBOL-Bedingungsnamen, der an ein uebergeordnetes Elementarfeld gebunden ist. →


88 Condition Name - Deklariert einen COBOL-Bedingungsnamen, der an ein uebergeordnetes Elementarfeld gebunden ist. - PBXB64 COBOL Help

Startseite › BASIC Frontend › 88 Condition Name - Deklariert einen COBOL-Bedingungsnamen, der an ein uebergeordnetes Elementarfeld gebunden ist.
Hilfe zum PBXB64-Compiler

88 Condition Name - Deklariert einen COBOL-Bedingungsnamen, der an ein uebergeordnetes Elementarfeld gebunden ist.

Deklariert einen COBOL-Bedingungsnamen, der an ein uebergeordnetes Elementarfeld gebunden ist.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

88 IS-OK VALUE 1.

Beschreibung

88 Condition Name hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

88 IS-OK VALUE 1.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/cond88.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← OCCURS - Deklariert Arrays fester Groesse mit 1-basierten Subskripten. Top USAGE - Akzeptiert DISPLAY-, BINARY/COMP-, COMP-3/PACKED-DECIMAL-, INDEX-, POINTER-, COMP-1- und COMP-2-Speicherklauseln in der aktuellen skalierten-int64-Absenkung. →


USAGE - Akzeptiert DISPLAY-, BINARY/COMP-, COMP-3/PACKED-DECIMAL-, INDEX-, POINTER-, COMP-1- und COMP-2-Speicherklauseln in der aktuellen skalierten-int64-Absenkung. - PBXB64 COBOL Help

Startseite › BASIC Frontend › USAGE - Akzeptiert DISPLAY-, BINARY/COMP-, COMP-3/PACKED-DECIMAL-, INDEX-, POINTER-, COMP-1- und COMP-2-Speicherklauseln in der aktuellen skalierten-int64-Absenkung.
Hilfe zum PBXB64-Compiler

USAGE - Akzeptiert DISPLAY-, BINARY/COMP-, COMP-3/PACKED-DECIMAL-, INDEX-, POINTER-, COMP-1- und COMP-2-Speicherklauseln in der aktuellen skalierten-int64-Absenkung.

Akzeptiert DISPLAY-, BINARY/COMP-, COMP-3/PACKED-DECIMAL-, INDEX-, POINTER-, COMP-1- und COMP-2-Speicherklauseln in der aktuellen skalierten-int64-Absenkung.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

01 WS-A PIC 9(5) USAGE COMP VALUE 100.

Beschreibung

USAGE hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

01 WS-A PIC 9(5) USAGE COMP VALUE 100.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/usage.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← 88 Condition Name - Deklariert einen COBOL-Bedingungsnamen, der an ein uebergeordnetes Elementarfeld gebunden ist. Top REDEFINES - Aliasiert den Speicher eines Elementarfelds auf ein anderes Elementarfeld. →


REDEFINES - Aliasiert den Speicher eines Elementarfelds auf ein anderes Elementarfeld. - PBXB64 COBOL Help

Startseite › BASIC Frontend › REDEFINES - Aliasiert den Speicher eines Elementarfelds auf ein anderes Elementarfeld.
Hilfe zum PBXB64-Compiler

REDEFINES - Aliasiert den Speicher eines Elementarfelds auf ein anderes Elementarfeld.

Aliasiert den Speicher eines Elementarfelds auf ein anderes Elementarfeld.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

01 WS-B REDEFINES WS-A PIC 9(4).

Beschreibung

REDEFINES hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

01 WS-B REDEFINES WS-A PIC 9(4).

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/redefines.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← USAGE - Akzeptiert DISPLAY-, BINARY/COMP-, COMP-3/PACKED-DECIMAL-, INDEX-, POINTER-, COMP-1- und COMP-2-Speicherklauseln in der aktuellen skalierten-int64-Absenkung. Top GLOBAL - Erfasst COBOL-GLOBAL-Sichtbarkeitsmetadaten fuer unterstuetzte WORKING-STORAGE-Felder. →


GLOBAL - Erfasst COBOL-GLOBAL-Sichtbarkeitsmetadaten fuer unterstuetzte WORKING-STORAGE-Felder. - PBXB64 COBOL Help

Startseite › BASIC Frontend › GLOBAL - Erfasst COBOL-GLOBAL-Sichtbarkeitsmetadaten fuer unterstuetzte WORKING-STORAGE-Felder.
Hilfe zum PBXB64-Compiler

GLOBAL - Erfasst COBOL-GLOBAL-Sichtbarkeitsmetadaten fuer unterstuetzte WORKING-STORAGE-Felder.

Erfasst COBOL-GLOBAL-Sichtbarkeitsmetadaten fuer unterstuetzte WORKING-STORAGE-Felder.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

01 SHARED-COUNT PIC S9(9) VALUE 41 GLOBAL.

Beschreibung

GLOBAL hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

01 SHARED-COUNT PIC S9(9) VALUE 41 GLOBAL.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/external_data.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← REDEFINES - Aliasiert den Speicher eines Elementarfelds auf ein anderes Elementarfeld. Top EXTERNAL - Exportiert ein unterstuetztes WORKING-STORAGE-Feld mit dem exakt in COBOL geschriebenen Objektsymbol. →


EXTERNAL - Exportiert ein unterstuetztes WORKING-STORAGE-Feld mit dem exakt in COBOL geschriebenen Objektsymbol. - PBXB64 COBOL Help

Startseite › BASIC Frontend › EXTERNAL - Exportiert ein unterstuetztes WORKING-STORAGE-Feld mit dem exakt in COBOL geschriebenen Objektsymbol.
Hilfe zum PBXB64-Compiler

EXTERNAL - Exportiert ein unterstuetztes WORKING-STORAGE-Feld mit dem exakt in COBOL geschriebenen Objektsymbol.

Exportiert ein unterstuetztes WORKING-STORAGE-Feld mit dem exakt in COBOL geschriebenen Objektsymbol.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

01 SHARED-COUNT PIC S9(9) VALUE 41 EXTERNAL.

Beschreibung

EXTERNAL hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

01 SHARED-COUNT PIC S9(9) VALUE 41 EXTERNAL.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/external_data.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← GLOBAL - Erfasst COBOL-GLOBAL-Sichtbarkeitsmetadaten fuer unterstuetzte WORKING-STORAGE-Felder. Top OF / IN - Qualifiziert einen Datennamen mit seiner enthaltenden Gruppe zur Eindeutigkeit. →


OF / IN - Qualifiziert einen Datennamen mit seiner enthaltenden Gruppe zur Eindeutigkeit. - PBXB64 COBOL Help

Startseite › BASIC Frontend › OF / IN - Qualifiziert einen Datennamen mit seiner enthaltenden Gruppe zur Eindeutigkeit.
Hilfe zum PBXB64-Compiler

OF / IN - Qualifiziert einen Datennamen mit seiner enthaltenden Gruppe zur Eindeutigkeit.

Qualifiziert einen Datennamen mit seiner enthaltenden Gruppe zur Eindeutigkeit.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

MOVE FLD-X OF REC-A TO WS-OUT.

Beschreibung

OF / IN hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

MOVE FLD-X OF REC-A TO WS-OUT.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/corresponding.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← EXTERNAL - Exportiert ein unterstuetztes WORKING-STORAGE-Feld mit dem exakt in COBOL geschriebenen Objektsymbol. Top COBOL Arithmetic and Data Movement →


COBOL-Arithmetik und Datenbewegung - PBXB64 COBOL Help

Startseite › BASIC Frontend › COBOL Arithmetic and Data Movement
Hilfe zum PBXB64-Compiler

COBOL-Arithmetik und Datenbewegung

Kind: Reference hub | Category: COBOL Frontend

PBXB64 Status: Overview / navigation; child pages carry the command-specific support proof.

Beschreibung

Diese Seite ist ein Ueberblickskapitel. Die einzelnen COBOL-Befehle und Klauseln stehen darunter jeweils auf eigenen, getesteten Referenzseiten.

Syntax

IDENTIFICATION DIVISION.
DATA DIVISION.
PROCEDURE DIVISION.

Einzelseiten

  • MOVE
  • MOVE CORRESPONDING
  • ADD
  • SUBTRACT
  • MULTIPLY
  • DIVIDE
  • COMPUTE
  • ROUNDED
  • INITIALIZE
  • SET

Pruefung

Die darunterliegenden Seiten nennen konkrete Dateien aus den COBOL-Validierungslaeufen. Neue COBOL-Hilfeintraege sollen nur mit compile/link/run-Beleg ergaenzt werden.

Validation evidence: COBOL command pages cite registered COBOL validation files such as tests/cobol/gaps.cbl or a focused sibling test.

Getestetes Beispiel

       IDENTIFICATION DIVISION.
       PROGRAM-ID. HELP.
       PROCEDURE DIVISION.
           STOP RUN.

Diese Seite ist ein Uebersichtskapitel. Die verlinkten Einzelseiten enthalten die konkreten getesteten Beispiele oder nennen eine ausdrueckliche Begrenzung, wenn ein Befehl nicht zertifiziert ist.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für COBOL-Arithmetik und Datenbewegung soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' COBOL-Arithmetik und Datenbewegung mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.

Zurueck zum Befehlsindex

← OF / IN - Qualifiziert einen Datennamen mit seiner enthaltenden Gruppe zur Eindeutigkeit. Top MOVE - Verschiebt numerische und String-Werte mit getesteter PIC-Kuerzung und Vorzeichenbehandlung. →


MOVE - Verschiebt numerische und String-Werte mit getesteter PIC-Kuerzung und Vorzeichenbehandlung. - PBXB64 COBOL Help

Startseite › BASIC Frontend › MOVE - Verschiebt numerische und String-Werte mit getesteter PIC-Kuerzung und Vorzeichenbehandlung.
Hilfe zum PBXB64-Compiler

MOVE - Verschiebt numerische und String-Werte mit getesteter PIC-Kuerzung und Vorzeichenbehandlung.

Verschiebt numerische und String-Werte mit getesteter PIC-Kuerzung und Vorzeichenbehandlung.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

MOVE 1234 TO WS-SMALL.

Beschreibung

MOVE hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

MOVE 1234 TO WS-SMALL.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/accuracy.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


MOVE CORRESPONDING - Verschiebt gleichnamige Elementarfelder zwischen zwei Gruppen. - PBXB64 COBOL Help

Startseite › BASIC Frontend › MOVE CORRESPONDING - Verschiebt gleichnamige Elementarfelder zwischen zwei Gruppen.
Hilfe zum PBXB64-Compiler

MOVE CORRESPONDING - Verschiebt gleichnamige Elementarfelder zwischen zwei Gruppen.

Verschiebt gleichnamige Elementarfelder zwischen zwei Gruppen.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

MOVE CORRESPONDING REC-A TO REC-B.

Beschreibung

MOVE CORRESPONDING hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

MOVE CORRESPONDING REC-A TO REC-B.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/corresponding.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← MOVE - Verschiebt numerische und String-Werte mit getesteter PIC-Kuerzung und Vorzeichenbehandlung. Top ADD - Addiert Werte mit unterstuetzter TO- und GIVING-Arithmetikabsenkung. →


ADD - Addiert Werte mit unterstuetzter TO- und GIVING-Arithmetikabsenkung. - PBXB64 COBOL Help

Startseite › BASIC Frontend › ADD - Addiert Werte mit unterstuetzter TO- und GIVING-Arithmetikabsenkung.
Hilfe zum PBXB64-Compiler

ADD - Addiert Werte mit unterstuetzter TO- und GIVING-Arithmetikabsenkung.

Addiert Werte mit unterstuetzter TO- und GIVING-Arithmetikabsenkung.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

ADD WS-A TO WS-B.

Beschreibung

ADD hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

ADD WS-A TO WS-B.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/arith.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← MOVE CORRESPONDING - Verschiebt gleichnamige Elementarfelder zwischen zwei Gruppen. Top SUBTRACT - Subtrahiert Werte mit unterstuetzten FROM- und GIVING-Formen. →


SUBTRACT - Subtrahiert Werte mit unterstuetzten FROM- und GIVING-Formen. - PBXB64 COBOL Help

Startseite › BASIC Frontend › SUBTRACT - Subtrahiert Werte mit unterstuetzten FROM- und GIVING-Formen.
Hilfe zum PBXB64-Compiler

SUBTRACT - Subtrahiert Werte mit unterstuetzten FROM- und GIVING-Formen.

Subtrahiert Werte mit unterstuetzten FROM- und GIVING-Formen.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

SUBTRACT 1.50 FROM WS-A.

Beschreibung

SUBTRACT hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

SUBTRACT 1.50 FROM WS-A.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/arith.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← ADD - Addiert Werte mit unterstuetzter TO- und GIVING-Arithmetikabsenkung. Top MULTIPLY - Multipliziert Festkommawerte und unterstuetzt ROUNDED auf getesteten Zielen. →


MULTIPLY - Multipliziert Festkommawerte und unterstuetzt ROUNDED auf getesteten Zielen. - PBXB64 COBOL Help

Startseite › BASIC Frontend › MULTIPLY - Multipliziert Festkommawerte und unterstuetzt ROUNDED auf getesteten Zielen.
Hilfe zum PBXB64-Compiler

MULTIPLY - Multipliziert Festkommawerte und unterstuetzt ROUNDED auf getesteten Zielen.

Multipliziert Festkommawerte und unterstuetzt ROUNDED auf getesteten Zielen.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

MULTIPLY 1.005 BY WS-R ROUNDED.

Beschreibung

MULTIPLY hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

MULTIPLY 1.005 BY WS-R ROUNDED.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/rounded.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← SUBTRACT - Subtrahiert Werte mit unterstuetzten FROM- und GIVING-Formen. Top DIVIDE - Dividiert Festkommawerte mit erhaltener Nachkommenskala in getesteten Faellen. →


DIVIDE - Dividiert Festkommawerte mit erhaltener Nachkommenskala in getesteten Faellen. - PBXB64 COBOL Help

Startseite › BASIC Frontend › DIVIDE - Dividiert Festkommawerte mit erhaltener Nachkommenskala in getesteten Faellen.
Hilfe zum PBXB64-Compiler

DIVIDE - Dividiert Festkommawerte mit erhaltener Nachkommenskala in getesteten Faellen.

Dividiert Festkommawerte mit erhaltener Nachkommenskala in getesteten Faellen.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

DIVIDE WS-B BY WS-D GIVING WS-E.

Beschreibung

DIVIDE hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

DIVIDE WS-B BY WS-D GIVING WS-E.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/arith2.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← MULTIPLY - Multipliziert Festkommawerte und unterstuetzt ROUNDED auf getesteten Zielen. Top COMPUTE - Weist arithmetische Ausdruecke mit Vorrang, Klammern, unaeren Vorzeichen und Array-Zielen zu. →


COMPUTE - Weist arithmetische Ausdruecke mit Vorrang, Klammern, unaeren Vorzeichen und Array-Zielen zu. - PBXB64 COBOL Help

Startseite › BASIC Frontend › COMPUTE - Weist arithmetische Ausdruecke mit Vorrang, Klammern, unaeren Vorzeichen und Array-Zielen zu.
Hilfe zum PBXB64-Compiler

COMPUTE - Weist arithmetische Ausdruecke mit Vorrang, Klammern, unaeren Vorzeichen und Array-Zielen zu.

Weist arithmetische Ausdruecke mit Vorrang, Klammern, unaeren Vorzeichen und Array-Zielen zu.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

COMPUTE WS-A = (2.00 + 3.00) * 4.00.

Beschreibung

COMPUTE hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

COMPUTE WS-A = (2.00 + 3.00) * 4.00.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/compute.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.

Zurueck zum Befehlsindex

← DIVIDE - Dividiert Festkommawerte mit erhaltener Nachkommenskala in getesteten Faellen. Top ROUNDED - Wendet Half-away-from-zero-Rundung fuer unterstuetzte arithmetische Ziele an. →


ROUNDED - Wendet Half-away-from-zero-Rundung fuer unterstuetzte arithmetische Ziele an. - PBXB64 COBOL Help

Startseite › BASIC Frontend › ROUNDED - Wendet Half-away-from-zero-Rundung fuer unterstuetzte arithmetische Ziele an.
Hilfe zum PBXB64-Compiler

ROUNDED - Wendet Half-away-from-zero-Rundung fuer unterstuetzte arithmetische Ziele an.

Wendet Half-away-from-zero-Rundung fuer unterstuetzte arithmetische Ziele an.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

MULTIPLY 1.005 BY WS-R ROUNDED.

Beschreibung

ROUNDED hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

MULTIPLY 1.005 BY WS-R ROUNDED.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/rounded.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← COMPUTE - Weist arithmetische Ausdruecke mit Vorrang, Klammern, unaeren Vorzeichen und Array-Zielen zu. Top INITIALIZE - Fuellt numerische Ziele mit null und alphanumerische Ziele mit Leerzeichen. →


INITIALIZE - Fuellt numerische Ziele mit null und alphanumerische Ziele mit Leerzeichen. - PBXB64 COBOL Help

Startseite › BASIC Frontend › INITIALIZE - Fuellt numerische Ziele mit null und alphanumerische Ziele mit Leerzeichen.
Hilfe zum PBXB64-Compiler

INITIALIZE - Fuellt numerische Ziele mit null und alphanumerische Ziele mit Leerzeichen.

Fuellt numerische Ziele mit null und alphanumerische Ziele mit Leerzeichen.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

INITIALIZE WS-NUM WS-TXT.

Beschreibung

INITIALIZE hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

INITIALIZE WS-NUM WS-TXT.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/initializeverb.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← ROUNDED - Wendet Half-away-from-zero-Rundung fuer unterstuetzte arithmetische Ziele an. Top SET - Setzt unterstuetzte 88-Level-Bedingungsnamen auf TRUE, indem der aufgezeichnete Elternwert gespeichert wird. →


SET - Setzt unterstuetzte 88-Level-Bedingungsnamen auf TRUE, indem der aufgezeichnete Elternwert gespeichert wird. - PBXB64 COBOL Help

Startseite › BASIC Frontend › SET - Setzt unterstuetzte 88-Level-Bedingungsnamen auf TRUE, indem der aufgezeichnete Elternwert gespeichert wird.
Hilfe zum PBXB64-Compiler

SET - Setzt unterstuetzte 88-Level-Bedingungsnamen auf TRUE, indem der aufgezeichnete Elternwert gespeichert wird.

Setzt unterstuetzte 88-Level-Bedingungsnamen auf TRUE, indem der aufgezeichnete Elternwert gespeichert wird.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

SET IS-OK TO TRUE.

Beschreibung

SET hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

SET IS-OK TO TRUE.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/cond88.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


COBOL-Kontrollfluss - PBXB64 COBOL Help

Startseite › BASIC Frontend › COBOL Control Flow

COBOL-Kontrollfluss

Kind: Reference hub | Category: COBOL Frontend

PBXB64 Status: Overview / navigation; child pages carry the command-specific support proof.

Beschreibung

Diese Seite ist ein Ueberblickskapitel. Die einzelnen COBOL-Befehle und Klauseln stehen darunter jeweils auf eigenen, getesteten Referenzseiten.

Syntax

IDENTIFICATION DIVISION.
DATA DIVISION.
PROCEDURE DIVISION.

Einzelseiten

  • IF
  • ELSE
  • END-IF
  • AND
  • OR
  • NOT
  • PERFORM
  • EXIT PERFORM
  • GO TO
  • DEPENDING ON
  • EVALUATE
  • WHEN
  • WHEN OTHER
  • END-EVALUATE
  • SEARCH
  • AT END
  • NOT AT END
  • END-SEARCH
  • CONTINUE
  • GOBACK
  • STOP RUN

Pruefung

Die darunterliegenden Seiten nennen konkrete Dateien aus den COBOL-Validierungslaeufen. Neue COBOL-Hilfeintraege sollen nur mit compile/link/run-Beleg ergaenzt werden.

Validation evidence: COBOL command pages cite registered COBOL validation files such as tests/cobol/gaps.cbl or a focused sibling test.

Getestetes Beispiel

       IDENTIFICATION DIVISION.
       PROGRAM-ID. HELP.
       PROCEDURE DIVISION.
           STOP RUN.

Diese Seite ist ein Uebersichtskapitel. Die verlinkten Einzelseiten enthalten die konkreten getesteten Beispiele oder nennen eine ausdrueckliche Begrenzung, wenn ein Befehl nicht zertifiziert ist.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für COBOL-Kontrollfluss soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' COBOL-Kontrollfluss mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.

Zurueck zum Befehlsindex

← SET - Setzt unterstuetzte 88-Level-Bedingungsnamen auf TRUE, indem der aufgezeichnete Elternwert gespeichert wird. Top IF - Startet bedingte Ausfuehrung mit getesteten Vergleichs- und Booleschen Bedingungen. →


IF - Startet bedingte Ausfuehrung mit getesteten Vergleichs- und Booleschen Bedingungen. - PBXB64 COBOL Help

Startseite › BASIC Frontend › IF - Startet bedingte Ausfuehrung mit getesteten Vergleichs- und Booleschen Bedingungen.
Hilfe zum PBXB64-Compiler

IF - Startet bedingte Ausfuehrung mit getesteten Vergleichs- und Booleschen Bedingungen.

Startet bedingte Ausfuehrung mit getesteten Vergleichs- und Booleschen Bedingungen.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

IF WS-AVG > 30000.00

Beschreibung

IF hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

IF WS-AVG > 30000.00

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/if1.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


ELSE - Startet den Alternativzweig einer getesteten IF-Anweisung. - PBXB64 COBOL Help

Startseite › BASIC Frontend › ELSE - Startet den Alternativzweig einer getesteten IF-Anweisung.
Hilfe zum PBXB64-Compiler

ELSE - Startet den Alternativzweig einer getesteten IF-Anweisung.

Startet den Alternativzweig einer getesteten IF-Anweisung.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

ELSE

Beschreibung

ELSE hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

ELSE

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/if1.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


END-IF - Schliesst einen IF- oder IF/ELSE-Block. - PBXB64 COBOL Help

Startseite › BASIC Frontend › END-IF - Schliesst einen IF- oder IF/ELSE-Block.
Hilfe zum PBXB64-Compiler

END-IF - Schliesst einen IF- oder IF/ELSE-Block.

Schliesst einen IF- oder IF/ELSE-Block.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

END-IF.

Beschreibung

END-IF hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

END-IF.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/if1.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


AND - Verknuepft getestete COBOL-Bedingungen konjunktiv. - PBXB64 COBOL Help

Startseite › BASIC Frontend › AND - Verknuepft getestete COBOL-Bedingungen konjunktiv.
Hilfe zum PBXB64-Compiler

AND - Verknuepft getestete COBOL-Bedingungen konjunktiv.

Verknuepft getestete COBOL-Bedingungen konjunktiv.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

IF WS-A > 0 AND WS-B > 0

Beschreibung

AND hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

IF WS-A > 0 AND WS-B > 0

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/gaps.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


OR - Verknuepft getestete COBOL-Bedingungen alternativ. - PBXB64 COBOL Help

Startseite › BASIC Frontend › OR - Verknuepft getestete COBOL-Bedingungen alternativ.
Hilfe zum PBXB64-Compiler

OR - Verknuepft getestete COBOL-Bedingungen alternativ.

Verknuepft getestete COBOL-Bedingungen alternativ.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

IF WS-A = 1 OR WS-B = 1

Beschreibung

OR hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

IF WS-A = 1 OR WS-B = 1

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/gaps.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


NOT - Negiert eine getestete COBOL-Bedingung. - PBXB64 COBOL Help

Startseite › BASIC Frontend › NOT - Negiert eine getestete COBOL-Bedingung.
Hilfe zum PBXB64-Compiler

NOT - Negiert eine getestete COBOL-Bedingung.

Negiert eine getestete COBOL-Bedingung.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

IF NOT WS-A = 0

Beschreibung

NOT hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

IF NOT WS-A = 0

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/gaps.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← OR - Verknuepft getestete COBOL-Bedingungen alternativ. Top PERFORM - Fuehrt Paragraph-Aufrufe, THRU-Bereiche, UNTIL, VARYING und n-TIMES-Schleifen in der getesteten Teilmenge aus. →


PERFORM - Fuehrt Paragraph-Aufrufe, THRU-Bereiche, UNTIL, VARYING und n-TIMES-Schleifen in der getesteten Teilmenge aus. - PBXB64 COBOL Help

Startseite › BASIC Frontend › PERFORM - Fuehrt Paragraph-Aufrufe, THRU-Bereiche, UNTIL, VARYING und n-TIMES-Schleifen in der getesteten Teilmenge aus.
Hilfe zum PBXB64-Compiler

PERFORM - Fuehrt Paragraph-Aufrufe, THRU-Bereiche, UNTIL, VARYING und n-TIMES-Schleifen in der getesteten Teilmenge aus.

Fuehrt Paragraph-Aufrufe, THRU-Bereiche, UNTIL, VARYING und n-TIMES-Schleifen in der getesteten Teilmenge aus.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PERFORM FILL VARYING WS-I FROM 1 BY 1 UNTIL WS-I > 5.

Beschreibung

PERFORM hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

PERFORM FILL VARYING WS-I FROM 1 BY 1 UNTIL WS-I > 5.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/p1.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


EXIT PERFORM - Bricht die naechstgelegene inline PERFORM-Schleife ab. - PBXB64 COBOL Help

Startseite › BASIC Frontend › EXIT PERFORM - Bricht die naechstgelegene inline PERFORM-Schleife ab.
Hilfe zum PBXB64-Compiler

EXIT PERFORM - Bricht die naechstgelegene inline PERFORM-Schleife ab.

Bricht die naechstgelegene inline PERFORM-Schleife ab.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

EXIT PERFORM

Beschreibung

EXIT PERFORM hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

EXIT PERFORM

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/exitperform.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← PERFORM - Fuehrt Paragraph-Aufrufe, THRU-Bereiche, UNTIL, VARYING und n-TIMES-Schleifen in der getesteten Teilmenge aus. Top GO TO - Uebergibt die Kontrolle an ein Paragraph-Label in der aktuellen nativen Teilmenge. →


GO TO - Uebergibt die Kontrolle an ein Paragraph-Label in der aktuellen nativen Teilmenge. - PBXB64 COBOL Help

Startseite › BASIC Frontend › GO TO - Uebergibt die Kontrolle an ein Paragraph-Label in der aktuellen nativen Teilmenge.
Hilfe zum PBXB64-Compiler

GO TO - Uebergibt die Kontrolle an ein Paragraph-Label in der aktuellen nativen Teilmenge.

Uebergibt die Kontrolle an ein Paragraph-Label in der aktuellen nativen Teilmenge.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

GO TO DONE.

Beschreibung

GO TO hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

GO TO DONE.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/gaps.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← EXIT PERFORM - Bricht die naechstgelegene inline PERFORM-Schleife ab. Top DEPENDING ON - Waehlt mit einem numerischen Selektor ein GO-TO-Ziel aus einer Liste. →


DEPENDING ON - Waehlt mit einem numerischen Selektor ein GO-TO-Ziel aus einer Liste. - PBXB64 COBOL Help

Startseite › BASIC Frontend › DEPENDING ON - Waehlt mit einem numerischen Selektor ein GO-TO-Ziel aus einer Liste.
Hilfe zum PBXB64-Compiler

DEPENDING ON - Waehlt mit einem numerischen Selektor ein GO-TO-Ziel aus einer Liste.

Waehlt mit einem numerischen Selektor ein GO-TO-Ziel aus einer Liste.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

GO TO P1, P2, P3 DEPENDING ON IDX.

Beschreibung

DEPENDING ON hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

GO TO P1, P2, P3 DEPENDING ON IDX.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/goto_depending.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← GO TO - Uebergibt die Kontrolle an ein Paragraph-Label in der aktuellen nativen Teilmenge. Top EVALUATE - Waehlt einen WHEN-Zweig durch Vergleich eines Subjektwerts; WHEN OTHER ist der Rueckfallzweig. →


EVALUATE - Waehlt einen WHEN-Zweig durch Vergleich eines Subjektwerts; WHEN OTHER ist der Rueckfallzweig. - PBXB64 COBOL Help

Startseite › BASIC Frontend › EVALUATE - Waehlt einen WHEN-Zweig durch Vergleich eines Subjektwerts; WHEN OTHER ist der Rueckfallzweig.
Hilfe zum PBXB64-Compiler

EVALUATE - Waehlt einen WHEN-Zweig durch Vergleich eines Subjektwerts; WHEN OTHER ist der Rueckfallzweig.

Waehlt einen WHEN-Zweig durch Vergleich eines Subjektwerts; WHEN OTHER ist der Rueckfallzweig.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

EVALUATE WS-DAY
    WHEN 1 DISPLAY "MONDAY"
    WHEN OTHER DISPLAY "OTHER"
END-EVALUATE.

Beschreibung

EVALUATE hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

EVALUATE WS-DAY
    WHEN 1 DISPLAY "MONDAY"
    WHEN OTHER DISPLAY "OTHER"
END-EVALUATE.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/evaluate.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← DEPENDING ON - Waehlt mit einem numerischen Selektor ein GO-TO-Ziel aus einer Liste. Top WHEN - Leitet einen EVALUATE-Zweig oder eine SEARCH-Trefferbedingung im unterstuetzten COBOL-Frontend ein. →


WHEN - Leitet einen EVALUATE-Zweig oder eine SEARCH-Trefferbedingung im unterstuetzten COBOL-Frontend ein. - PBXB64 COBOL Help

Startseite › BASIC Frontend › WHEN - Leitet einen EVALUATE-Zweig oder eine SEARCH-Trefferbedingung im unterstuetzten COBOL-Frontend ein.
Hilfe zum PBXB64-Compiler

WHEN - Leitet einen EVALUATE-Zweig oder eine SEARCH-Trefferbedingung im unterstuetzten COBOL-Frontend ein.

Leitet einen EVALUATE-Zweig oder eine SEARCH-Trefferbedingung im unterstuetzten COBOL-Frontend ein.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

WHEN 3 DISPLAY "WEDNESDAY"

Beschreibung

WHEN hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

WHEN 3 DISPLAY "WEDNESDAY"

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/evaluate.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← EVALUATE - Waehlt einen WHEN-Zweig durch Vergleich eines Subjektwerts; WHEN OTHER ist der Rueckfallzweig. Top WHEN OTHER - Definiert den Rueckfallzweig fuer EVALUATE, wenn kein vorheriger WHEN-Wert passt. →


WHEN OTHER - Definiert den Rueckfallzweig fuer EVALUATE, wenn kein vorheriger WHEN-Wert passt. - PBXB64 COBOL Help

Startseite › BASIC Frontend › WHEN OTHER - Definiert den Rueckfallzweig fuer EVALUATE, wenn kein vorheriger WHEN-Wert passt.
Hilfe zum PBXB64-Compiler

WHEN OTHER - Definiert den Rueckfallzweig fuer EVALUATE, wenn kein vorheriger WHEN-Wert passt.

Definiert den Rueckfallzweig fuer EVALUATE, wenn kein vorheriger WHEN-Wert passt.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

WHEN OTHER DISPLAY "WEEKEND"

Beschreibung

WHEN OTHER hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

WHEN OTHER DISPLAY "WEEKEND"

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/evaluate.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← WHEN - Leitet einen EVALUATE-Zweig oder eine SEARCH-Trefferbedingung im unterstuetzten COBOL-Frontend ein. Top END-EVALUATE - Schliesst eine EVALUATE-Mehrfachverzweigung. →


END-EVALUATE - Schliesst eine EVALUATE-Mehrfachverzweigung. - PBXB64 COBOL Help

Startseite › BASIC Frontend › END-EVALUATE - Schliesst eine EVALUATE-Mehrfachverzweigung.
Hilfe zum PBXB64-Compiler

END-EVALUATE - Schliesst eine EVALUATE-Mehrfachverzweigung.

Schliesst eine EVALUATE-Mehrfachverzweigung.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

END-EVALUATE.

Beschreibung

END-EVALUATE hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

END-EVALUATE.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/evaluate.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← WHEN OTHER - Definiert den Rueckfallzweig fuer EVALUATE, wenn kein vorheriger WHEN-Wert passt. Top SEARCH - Fuehrt eine lineare Suche ueber eine feste OCCURS-Tabelle mit VARYING, AT END, WHEN und END-SEARCH aus. →


SEARCH - Fuehrt eine lineare Suche ueber eine feste OCCURS-Tabelle mit VARYING, AT END, WHEN und END-SEARCH aus. - PBXB64 COBOL Help

Startseite › BASIC Frontend › SEARCH - Fuehrt eine lineare Suche ueber eine feste OCCURS-Tabelle mit VARYING, AT END, WHEN und END-SEARCH aus.
Hilfe zum PBXB64-Compiler

SEARCH - Fuehrt eine lineare Suche ueber eine feste OCCURS-Tabelle mit VARYING, AT END, WHEN und END-SEARCH aus.

Fuehrt eine lineare Suche ueber eine feste OCCURS-Tabelle mit VARYING, AT END, WHEN und END-SEARCH aus.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

SEARCH TBL VARYING IDX
    AT END MOVE 999 TO OUT-VAL
    WHEN TBL(IDX) = 450 MOVE TBL(IDX) TO OUT-VAL
END-SEARCH.

Beschreibung

SEARCH hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

SEARCH TBL VARYING IDX
    AT END MOVE 999 TO OUT-VAL
    WHEN TBL(IDX) = 450 MOVE TBL(IDX) TO OUT-VAL
END-SEARCH.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/search.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← END-EVALUATE - Schliesst eine EVALUATE-Mehrfachverzweigung. Top AT END - Fuehrt einen Rueckfallzweig fuer READ-Dateiende oder SEARCH-ohne-Treffer aus. →


AT END - Fuehrt einen Rueckfallzweig fuer READ-Dateiende oder SEARCH-ohne-Treffer aus. - PBXB64 COBOL Help

Startseite › BASIC Frontend › AT END - Fuehrt einen Rueckfallzweig fuer READ-Dateiende oder SEARCH-ohne-Treffer aus.
Hilfe zum PBXB64-Compiler

AT END - Fuehrt einen Rueckfallzweig fuer READ-Dateiende oder SEARCH-ohne-Treffer aus.

Fuehrt einen Rueckfallzweig fuer READ-Dateiende oder SEARCH-ohne-Treffer aus.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

AT END MOVE 999 TO OUT-VAL

Beschreibung

AT END hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

AT END MOVE 999 TO OUT-VAL

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/search.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← SEARCH - Fuehrt eine lineare Suche ueber eine feste OCCURS-Tabelle mit VARYING, AT END, WHEN und END-SEARCH aus. Top NOT AT END - Fuehrt den erfolgreichen READ-Zweig aus, wenn ein Datensatz gelesen wurde. →


NOT AT END - Fuehrt den erfolgreichen READ-Zweig aus, wenn ein Datensatz gelesen wurde. - PBXB64 COBOL Help

Startseite › BASIC Frontend › NOT AT END - Fuehrt den erfolgreichen READ-Zweig aus, wenn ein Datensatz gelesen wurde.
Hilfe zum PBXB64-Compiler

NOT AT END - Fuehrt den erfolgreichen READ-Zweig aus, wenn ein Datensatz gelesen wurde.

Fuehrt den erfolgreichen READ-Zweig aus, wenn ein Datensatz gelesen wurde.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

NOT AT END MOVE 1 TO WS-GOTDATA

Beschreibung

NOT AT END hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

NOT AT END MOVE 1 TO WS-GOTDATA

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/fileio.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


END-SEARCH - Schliesst eine SEARCH-Anweisung. - PBXB64 COBOL Help

Startseite › BASIC Frontend › END-SEARCH - Schliesst eine SEARCH-Anweisung.
Hilfe zum PBXB64-Compiler

END-SEARCH - Schliesst eine SEARCH-Anweisung.

Schliesst eine SEARCH-Anweisung.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

END-SEARCH

Beschreibung

END-SEARCH hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

END-SEARCH

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/search.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← NOT AT END - Fuehrt den erfolgreichen READ-Zweig aus, wenn ein Datensatz gelesen wurde. Top CONTINUE - Erzeugt eine explizite No-Operation-Anweisung. →


CONTINUE - Erzeugt eine explizite No-Operation-Anweisung. - PBXB64 COBOL Help

Startseite › BASIC Frontend › CONTINUE - Erzeugt eine explizite No-Operation-Anweisung.
Hilfe zum PBXB64-Compiler

CONTINUE - Erzeugt eine explizite No-Operation-Anweisung.

Erzeugt eine explizite No-Operation-Anweisung.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

CONTINUE.

Beschreibung

CONTINUE hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

CONTINUE.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/gaps.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


GOBACK - Kehrt aus dem aktuellen COBOL-Programm oder Hilfsprogramm zurueck. - PBXB64 COBOL Help

Startseite › BASIC Frontend › GOBACK - Kehrt aus dem aktuellen COBOL-Programm oder Hilfsprogramm zurueck.
Hilfe zum PBXB64-Compiler

GOBACK - Kehrt aus dem aktuellen COBOL-Programm oder Hilfsprogramm zurueck.

Kehrt aus dem aktuellen COBOL-Programm oder Hilfsprogramm zurueck.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

GOBACK.

Beschreibung

GOBACK hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

GOBACK.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/goback.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


STOP RUN - Beendet das COBOL-Programm. - PBXB64 COBOL Help

Startseite › BASIC Frontend › STOP RUN - Beendet das COBOL-Programm.
Hilfe zum PBXB64-Compiler

STOP RUN - Beendet das COBOL-Programm.

Beendet das COBOL-Programm.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

STOP RUN.

Beschreibung

STOP RUN hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

STOP RUN.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/hello.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


COBOL-Konsole und Strings - PBXB64 COBOL Help

Startseite › BASIC Frontend › COBOL Console and Strings

COBOL-Konsole und Strings

Kind: Reference hub | Category: COBOL Frontend

PBXB64 Status: Overview / navigation; child pages carry the command-specific support proof.

Beschreibung

Diese Seite ist ein Ueberblickskapitel. Die einzelnen COBOL-Befehle und Klauseln stehen darunter jeweils auf eigenen, getesteten Referenzseiten.

Syntax

IDENTIFICATION DIVISION.
DATA DIVISION.
PROCEDURE DIVISION.

Einzelseiten

  • DISPLAY
  • ACCEPT
  • STRING
  • DELIMITED BY
  • WITH POINTER
  • UNSTRING
  • INSPECT
  • TALLYING
  • REPLACING
  • CONVERTING

Pruefung

Die darunterliegenden Seiten nennen konkrete Dateien aus den COBOL-Validierungslaeufen. Neue COBOL-Hilfeintraege sollen nur mit compile/link/run-Beleg ergaenzt werden.

Validation evidence: COBOL command pages cite registered COBOL validation files such as tests/cobol/gaps.cbl or a focused sibling test.

Getestetes Beispiel

       IDENTIFICATION DIVISION.
       PROGRAM-ID. HELP.
       PROCEDURE DIVISION.
           STOP RUN.

Diese Seite ist ein Uebersichtskapitel. Die verlinkten Einzelseiten enthalten die konkreten getesteten Beispiele oder nennen eine ausdrueckliche Begrenzung, wenn ein Befehl nicht zertifiziert ist.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für COBOL-Konsole und Strings soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' COBOL-Konsole und Strings mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.

Zurueck zum Befehlsindex


DISPLAY - Schreibt Literale und Datenfelder auf die Konsolenausgabe. - PBXB64 COBOL Help

Startseite › BASIC Frontend › DISPLAY - Schreibt Literale und Datenfelder auf die Konsolenausgabe.
Hilfe zum PBXB64-Compiler

DISPLAY - Schreibt Literale und Datenfelder auf die Konsolenausgabe.

Schreibt Literale und Datenfelder auf die Konsolenausgabe.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

DISPLAY "TOTAL=" WS-TOTAL.

Beschreibung

DISPLAY hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

DISPLAY "TOTAL=" WS-TOTAL.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/hello.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


ACCEPT - Liest Eingabe oder ausgewaehlte FROM-Quellen in Datenfelder. - PBXB64 COBOL Help

Startseite › BASIC Frontend › ACCEPT - Liest Eingabe oder ausgewaehlte FROM-Quellen in Datenfelder.
Hilfe zum PBXB64-Compiler

ACCEPT - Liest Eingabe oder ausgewaehlte FROM-Quellen in Datenfelder.

Liest Eingabe oder ausgewaehlte FROM-Quellen in Datenfelder.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

ACCEPT WS-NAME.
ACCEPT WS-DATE FROM DATE.

Beschreibung

ACCEPT hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

ACCEPT WS-NAME.
ACCEPT WS-DATE FROM DATE.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/gaps.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← DISPLAY - Schreibt Literale und Datenfelder auf die Konsolenausgabe. Top STRING - Verkettet Quellfelder oder Literale in ein Ziel mit DELIMITED BY SIZE oder einem getesteten Literalbegrenzer. →


STRING - Verkettet Quellfelder oder Literale in ein Ziel mit DELIMITED BY SIZE oder einem getesteten Literalbegrenzer. - PBXB64 COBOL Help

Startseite › BASIC Frontend › STRING - Verkettet Quellfelder oder Literale in ein Ziel mit DELIMITED BY SIZE oder einem getesteten Literalbegrenzer.
Hilfe zum PBXB64-Compiler

STRING - Verkettet Quellfelder oder Literale in ein Ziel mit DELIMITED BY SIZE oder einem getesteten Literalbegrenzer.

Verkettet Quellfelder oder Literale in ein Ziel mit DELIMITED BY SIZE oder einem getesteten Literalbegrenzer.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

STRING "HELLO" " " "WORLD" DELIMITED BY SIZE INTO WS-OUT.

Beschreibung

STRING hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

STRING "HELLO" " " "WORLD" DELIMITED BY SIZE INTO WS-OUT.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/stringverb.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.

Zurueck zum Befehlsindex

← ACCEPT - Liest Eingabe oder ausgewaehlte FROM-Quellen in Datenfelder. Top DELIMITED BY - Steuert, wie STRING Quelltext kopiert: vollstaendig per SIZE oder bis zu einem Literalbegrenzer. →


DELIMITED BY - Steuert, wie STRING Quelltext kopiert: vollstaendig per SIZE oder bis zu einem Literalbegrenzer. - PBXB64 COBOL Help

Startseite › BASIC Frontend › DELIMITED BY - Steuert, wie STRING Quelltext kopiert: vollstaendig per SIZE oder bis zu einem Literalbegrenzer.
Hilfe zum PBXB64-Compiler

DELIMITED BY - Steuert, wie STRING Quelltext kopiert: vollstaendig per SIZE oder bis zu einem Literalbegrenzer.

Steuert, wie STRING Quelltext kopiert: vollstaendig per SIZE oder bis zu einem Literalbegrenzer.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

STRING SRC-A SRC-B DELIMITED BY "," INTO DEST.

Beschreibung

DELIMITED BY hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

STRING SRC-A SRC-B DELIMITED BY "," INTO DEST.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/string_multibyte.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← STRING - Verkettet Quellfelder oder Literale in ein Ziel mit DELIMITED BY SIZE oder einem getesteten Literalbegrenzer. Top WITH POINTER - Verwendet ein COBOL-Zeiger-/Zaehlerfeld als aktuelle STRING-Zielposition, wenn vorhanden. →


WITH POINTER - Verwendet ein COBOL-Zeiger-/Zaehlerfeld als aktuelle STRING-Zielposition, wenn vorhanden. - PBXB64 COBOL Help

Startseite › BASIC Frontend › WITH POINTER - Verwendet ein COBOL-Zeiger-/Zaehlerfeld als aktuelle STRING-Zielposition, wenn vorhanden.
Hilfe zum PBXB64-Compiler

WITH POINTER - Verwendet ein COBOL-Zeiger-/Zaehlerfeld als aktuelle STRING-Zielposition, wenn vorhanden.

Verwendet ein COBOL-Zeiger-/Zaehlerfeld als aktuelle STRING-Zielposition, wenn vorhanden.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

STRING SRC DELIMITED BY SIZE INTO DEST WITH POINTER PTR.

Beschreibung

WITH POINTER hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

STRING SRC DELIMITED BY SIZE INTO DEST WITH POINTER PTR.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/stringverb.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← DELIMITED BY - Steuert, wie STRING Quelltext kopiert: vollstaendig per SIZE oder bis zu einem Literalbegrenzer. Top UNSTRING - Teilt ein Quellfeld ueber den implementierten Begrenzerpfad in Zielfelder auf. →


UNSTRING - Teilt ein Quellfeld ueber den implementierten Begrenzerpfad in Zielfelder auf. - PBXB64 COBOL Help

Startseite › BASIC Frontend › UNSTRING - Teilt ein Quellfeld ueber den implementierten Begrenzerpfad in Zielfelder auf.
Hilfe zum PBXB64-Compiler

UNSTRING - Teilt ein Quellfeld ueber den implementierten Begrenzerpfad in Zielfelder auf.

Teilt ein Quellfeld ueber den implementierten Begrenzerpfad in Zielfelder auf.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

UNSTRING WS-SRC DELIMITED BY "," INTO WS-A WS-B.

Beschreibung

UNSTRING hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

UNSTRING WS-SRC DELIMITED BY "," INTO WS-A WS-B.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/stringverb.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.

Zurueck zum Befehlsindex

← WITH POINTER - Verwendet ein COBOL-Zeiger-/Zaehlerfeld als aktuelle STRING-Zielposition, wenn vorhanden. Top INSPECT - Zaehlt, ersetzt und konvertiert Zeichenketten ueber getestete Einbyte- und Mehrbyte-Helferpfade. →


INSPECT - Zaehlt, ersetzt und konvertiert Zeichenketten ueber getestete Einbyte- und Mehrbyte-Helferpfade. - PBXB64 COBOL Help

Startseite › BASIC Frontend › INSPECT - Zaehlt, ersetzt und konvertiert Zeichenketten ueber getestete Einbyte- und Mehrbyte-Helferpfade.
Hilfe zum PBXB64-Compiler

INSPECT - Zaehlt, ersetzt und konvertiert Zeichenketten ueber getestete Einbyte- und Mehrbyte-Helferpfade.

Zaehlt, ersetzt und konvertiert Zeichenketten ueber getestete Einbyte- und Mehrbyte-Helferpfade.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

INSPECT WS-S REPLACING ALL "A" BY "X".

Beschreibung

INSPECT hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

INSPECT WS-S REPLACING ALL "A" BY "X".

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/inspectverb.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← UNSTRING - Teilt ein Quellfeld ueber den implementierten Begrenzerpfad in Zielfelder auf. Top TALLYING - Zaehlt Zeichen oder Vorkommen in einer INSPECT-Anweisung. →


TALLYING - Zaehlt Zeichen oder Vorkommen in einer INSPECT-Anweisung. - PBXB64 COBOL Help

Startseite › BASIC Frontend › TALLYING - Zaehlt Zeichen oder Vorkommen in einer INSPECT-Anweisung.
Hilfe zum PBXB64-Compiler

TALLYING - Zaehlt Zeichen oder Vorkommen in einer INSPECT-Anweisung.

Zaehlt Zeichen oder Vorkommen in einer INSPECT-Anweisung.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

INSPECT WS-S TALLYING WS-CNT FOR ALL "A".

Beschreibung

TALLYING hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

INSPECT WS-S TALLYING WS-CNT FOR ALL "A".

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/inspectverb.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← INSPECT - Zaehlt, ersetzt und konvertiert Zeichenketten ueber getestete Einbyte- und Mehrbyte-Helferpfade. Top REPLACING - Ersetzt passende Zeichen- oder Stringoperanden in einer INSPECT-Anweisung. →


REPLACING - Ersetzt passende Zeichen- oder Stringoperanden in einer INSPECT-Anweisung. - PBXB64 COBOL Help

Startseite › BASIC Frontend › REPLACING - Ersetzt passende Zeichen- oder Stringoperanden in einer INSPECT-Anweisung.
Hilfe zum PBXB64-Compiler

REPLACING - Ersetzt passende Zeichen- oder Stringoperanden in einer INSPECT-Anweisung.

Ersetzt passende Zeichen- oder Stringoperanden in einer INSPECT-Anweisung.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

INSPECT WS-R REPLACING ALL "AB" BY "XY".

Beschreibung

REPLACING hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

INSPECT WS-R REPLACING ALL "AB" BY "XY".

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/inspect_multibyte.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← TALLYING - Zaehlt Zeichen oder Vorkommen in einer INSPECT-Anweisung. Top CONVERTING - Bildet Zeichen oder Mehrbyte-Token in einer INSPECT-Anweisung um. →


CONVERTING - Bildet Zeichen oder Mehrbyte-Token in einer INSPECT-Anweisung um. - PBXB64 COBOL Help

Startseite › BASIC Frontend › CONVERTING - Bildet Zeichen oder Mehrbyte-Token in einer INSPECT-Anweisung um.
Hilfe zum PBXB64-Compiler

CONVERTING - Bildet Zeichen oder Mehrbyte-Token in einer INSPECT-Anweisung um.

Bildet Zeichen oder Mehrbyte-Token in einer INSPECT-Anweisung um.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

INSPECT WS-C CONVERTING "AB" TO "XY".

Beschreibung

CONVERTING hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

INSPECT WS-C CONVERTING "AB" TO "XY".

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/inspect_multibyte.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


COBOL-Aufrufe und Parameter - PBXB64 COBOL Help

Startseite › BASIC Frontend › COBOL Calls and Parameters

COBOL-Aufrufe und Parameter

Kind: Reference hub | Category: COBOL Frontend

PBXB64 Status: Overview / navigation; child pages carry the command-specific support proof.

Beschreibung

Diese Seite ist ein Ueberblickskapitel. Die einzelnen COBOL-Befehle und Klauseln stehen darunter jeweils auf eigenen, getesteten Referenzseiten.

Syntax

IDENTIFICATION DIVISION.
DATA DIVISION.
PROCEDURE DIVISION.

Einzelseiten

  • CALL
  • USING
  • GIVING

Pruefung

Die darunterliegenden Seiten nennen konkrete Dateien aus den COBOL-Validierungslaeufen. Neue COBOL-Hilfeintraege sollen nur mit compile/link/run-Beleg ergaenzt werden.

Validation evidence: COBOL command pages cite registered COBOL validation files such as tests/cobol/gaps.cbl or a focused sibling test.

Getestetes Beispiel

       IDENTIFICATION DIVISION.
       PROGRAM-ID. HELP.
       PROCEDURE DIVISION.
           STOP RUN.

Diese Seite ist ein Uebersichtskapitel. Die verlinkten Einzelseiten enthalten die konkreten getesteten Beispiele oder nennen eine ausdrueckliche Begrenzung, wenn ein Befehl nicht zertifiziert ist.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für COBOL-Aufrufe und Parameter soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' COBOL-Aufrufe und Parameter mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.

Zurueck zum Befehlsindex


CALL - Ruft ein externes C-aehnliches Symbol aus COBOL auf. - PBXB64 COBOL Help

Startseite › BASIC Frontend › CALL - Ruft ein externes C-aehnliches Symbol aus COBOL auf.
Hilfe zum PBXB64-Compiler

CALL - Ruft ein externes C-aehnliches Symbol aus COBOL auf.

Ruft ein externes C-aehnliches Symbol aus COBOL auf.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

CALL "cobol-host" USING ARG1 GIVING RESULT.

Beschreibung

CALL hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

CALL "cobol-host" USING ARG1 GIVING RESULT.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/call_giving.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


USING - Liefert CALL-Argumente; Standardmodus ist BY REFERENCE, mit getesteten BY-VALUE-Runtime-Aufrufen. - PBXB64 COBOL Help

Startseite › BASIC Frontend › USING - Liefert CALL-Argumente; Standardmodus ist BY REFERENCE, mit getesteten BY-VALUE-Runtime-Aufrufen.
Hilfe zum PBXB64-Compiler

USING - Liefert CALL-Argumente; Standardmodus ist BY REFERENCE, mit getesteten BY-VALUE-Runtime-Aufrufen.

Liefert CALL-Argumente; Standardmodus ist BY REFERENCE, mit getesteten BY-VALUE-Runtime-Aufrufen.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

CALL "name" USING BY VALUE 160 GIVING WS-R.

Beschreibung

USING hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

CALL "name" USING BY VALUE 160 GIVING WS-R.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/un_runtime_access.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← CALL - Ruft ein externes C-aehnliches Symbol aus COBOL auf. Top GIVING - Speichert den ganzzahligen Rueckgabewert eines CALL oder einer Rechenoperation in einem Ziel. →


GIVING - Speichert den ganzzahligen Rueckgabewert eines CALL oder einer Rechenoperation in einem Ziel. - PBXB64 COBOL Help

Startseite › BASIC Frontend › GIVING - Speichert den ganzzahligen Rueckgabewert eines CALL oder einer Rechenoperation in einem Ziel.
Hilfe zum PBXB64-Compiler

GIVING - Speichert den ganzzahligen Rueckgabewert eines CALL oder einer Rechenoperation in einem Ziel.

Speichert den ganzzahligen Rueckgabewert eines CALL oder einer Rechenoperation in einem Ziel.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

CALL "cobol-host" USING ARG1 GIVING RESULT.

Beschreibung

GIVING hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

CALL "cobol-host" USING ARG1 GIVING RESULT.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/call_giving.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


COBOL-Datei-E/A - PBXB64 COBOL Help

Startseite › BASIC Frontend › COBOL File I/O

COBOL-Datei-E/A

Kind: Reference hub | Category: COBOL Frontend

PBXB64 Status: Overview / navigation; child pages carry the command-specific support proof.

Beschreibung

Diese Seite ist ein Ueberblickskapitel. Die einzelnen COBOL-Befehle und Klauseln stehen darunter jeweils auf eigenen, getesteten Referenzseiten.

Syntax

IDENTIFICATION DIVISION.
DATA DIVISION.
PROCEDURE DIVISION.

Einzelseiten

  • SELECT ASSIGN
  • FILE SECTION
  • OPEN
  • READ
  • WRITE
  • CLOSE

Pruefung

Die darunterliegenden Seiten nennen konkrete Dateien aus den COBOL-Validierungslaeufen. Neue COBOL-Hilfeintraege sollen nur mit compile/link/run-Beleg ergaenzt werden.

Validation evidence: COBOL command pages cite registered COBOL validation files such as tests/cobol/gaps.cbl or a focused sibling test.

Getestetes Beispiel

       IDENTIFICATION DIVISION.
       PROGRAM-ID. HELP.
       PROCEDURE DIVISION.
           STOP RUN.

Diese Seite ist ein Uebersichtskapitel. Die verlinkten Einzelseiten enthalten die konkreten getesteten Beispiele oder nennen eine ausdrueckliche Begrenzung, wenn ein Befehl nicht zertifiziert ist.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für COBOL-Datei-E/A soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' COBOL-Datei-E/A mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.

Zurueck zum Befehlsindex

← GIVING - Speichert den ganzzahligen Rueckgabewert eines CALL oder einer Rechenoperation in einem Ziel. Top SELECT ASSIGN - Ordnet einen COBOL-Dateinamen dem Literalpfad der Hostdatei fuer line-sequential Datei-I/O zu. →


SELECT ASSIGN - Ordnet einen COBOL-Dateinamen dem Literalpfad der Hostdatei fuer line-sequential Datei-I/O zu. - PBXB64 COBOL Help

Startseite › BASIC Frontend › SELECT ASSIGN - Ordnet einen COBOL-Dateinamen dem Literalpfad der Hostdatei fuer line-sequential Datei-I/O zu.
Hilfe zum PBXB64-Compiler

SELECT ASSIGN - Ordnet einen COBOL-Dateinamen dem Literalpfad der Hostdatei fuer line-sequential Datei-I/O zu.

Ordnet einen COBOL-Dateinamen dem Literalpfad der Hostdatei fuer line-sequential Datei-I/O zu.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

SELECT TEST-FILE ASSIGN TO "tmp_fileio.txt".

Beschreibung

SELECT ASSIGN hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

SELECT TEST-FILE ASSIGN TO "tmp_fileio.txt".

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/fileio.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


FILE SECTION - Deklariert FD-Datensaetze fuer den unterstuetzten line-sequential Datei-I/O-Pfad. - PBXB64 COBOL Help

Startseite › BASIC Frontend › FILE SECTION - Deklariert FD-Datensaetze fuer den unterstuetzten line-sequential Datei-I/O-Pfad.
Hilfe zum PBXB64-Compiler

FILE SECTION - Deklariert FD-Datensaetze fuer den unterstuetzten line-sequential Datei-I/O-Pfad.

Deklariert FD-Datensaetze fuer den unterstuetzten line-sequential Datei-I/O-Pfad.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

FILE SECTION.
FD TEST-FILE.
01 TEST-REC PIC X(12).

Beschreibung

FILE SECTION hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

FILE SECTION.
FD TEST-FILE.
01 TEST-REC PIC X(12).

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/fileio.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.

Zurueck zum Befehlsindex

← SELECT ASSIGN - Ordnet einen COBOL-Dateinamen dem Literalpfad der Hostdatei fuer line-sequential Datei-I/O zu. Top OPEN - Oeffnet eine ausgewaehlte line-sequential COBOL-Datei fuer INPUT, OUTPUT, I-O oder EXTEND. →


OPEN - Oeffnet eine ausgewaehlte line-sequential COBOL-Datei fuer INPUT, OUTPUT, I-O oder EXTEND. - PBXB64 COBOL Help

Startseite › BASIC Frontend › OPEN - Oeffnet eine ausgewaehlte line-sequential COBOL-Datei fuer INPUT, OUTPUT, I-O oder EXTEND.
Hilfe zum PBXB64-Compiler

OPEN - Oeffnet eine ausgewaehlte line-sequential COBOL-Datei fuer INPUT, OUTPUT, I-O oder EXTEND.

Oeffnet eine ausgewaehlte line-sequential COBOL-Datei fuer INPUT, OUTPUT, I-O oder EXTEND.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

OPEN OUTPUT TEST-FILE.

Beschreibung

OPEN hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

OPEN OUTPUT TEST-FILE.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/fileio.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← FILE SECTION - Deklariert FD-Datensaetze fuer den unterstuetzten line-sequential Datei-I/O-Pfad. Top READ - Liest einen Datensatz aus einer geoeffneten COBOL-Datei mit INTO, AT END, NOT AT END und END-READ-Unterstuetzung. →


READ - Liest einen Datensatz aus einer geoeffneten COBOL-Datei mit INTO, AT END, NOT AT END und END-READ-Unterstuetzung. - PBXB64 COBOL Help

Startseite › BASIC Frontend › READ - Liest einen Datensatz aus einer geoeffneten COBOL-Datei mit INTO, AT END, NOT AT END und END-READ-Unterstuetzung.
Hilfe zum PBXB64-Compiler

READ - Liest einen Datensatz aus einer geoeffneten COBOL-Datei mit INTO, AT END, NOT AT END und END-READ-Unterstuetzung.

Liest einen Datensatz aus einer geoeffneten COBOL-Datei mit INTO, AT END, NOT AT END und END-READ-Unterstuetzung.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

READ TEST-FILE INTO WS-IN AT END MOVE 0 TO WS-GOTDATA END-READ.

Beschreibung

READ hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

READ TEST-FILE INTO WS-IN AT END MOVE 0 TO WS-GOTDATA END-READ.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/fileio.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← OPEN - Oeffnet eine ausgewaehlte line-sequential COBOL-Datei fuer INPUT, OUTPUT, I-O oder EXTEND. Top WRITE - Schreibt einen Datensatz in eine geoeffnete COBOL-Datei, einschliesslich WRITE record FROM source. →


WRITE - Schreibt einen Datensatz in eine geoeffnete COBOL-Datei, einschliesslich WRITE record FROM source. - PBXB64 COBOL Help

Startseite › BASIC Frontend › WRITE - Schreibt einen Datensatz in eine geoeffnete COBOL-Datei, einschliesslich WRITE record FROM source.
Hilfe zum PBXB64-Compiler

WRITE - Schreibt einen Datensatz in eine geoeffnete COBOL-Datei, einschliesslich WRITE record FROM source.

Schreibt einen Datensatz in eine geoeffnete COBOL-Datei, einschliesslich WRITE record FROM source.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

WRITE TEST-REC FROM WS-SRC.

Beschreibung

WRITE hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

WRITE TEST-REC FROM WS-SRC.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/fileio_from.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← READ - Liest einen Datensatz aus einer geoeffneten COBOL-Datei mit INTO, AT END, NOT AT END und END-READ-Unterstuetzung. Top CLOSE - Schliesst einen geoeffneten COBOL-Dateihandle. →


CLOSE - Schliesst einen geoeffneten COBOL-Dateihandle. - PBXB64 COBOL Help

Startseite › BASIC Frontend › CLOSE - Schliesst einen geoeffneten COBOL-Dateihandle.
Hilfe zum PBXB64-Compiler

CLOSE - Schliesst einen geoeffneten COBOL-Dateihandle.

Schliesst einen geoeffneten COBOL-Dateihandle.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

CLOSE TEST-FILE.

Beschreibung

CLOSE hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

CLOSE TEST-FILE.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/fileio.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


COBOL-Copybooks - PBXB64 COBOL Help

Startseite › BASIC Frontend › COBOL Copybooks

COBOL-Copybooks

Kind: Reference hub | Category: COBOL Frontend

PBXB64 Status: Overview / navigation; child pages carry the command-specific support proof.

Beschreibung

Diese Seite ist ein Ueberblickskapitel. Die einzelnen COBOL-Befehle und Klauseln stehen darunter jeweils auf eigenen, getesteten Referenzseiten.

Syntax

IDENTIFICATION DIVISION.
DATA DIVISION.
PROCEDURE DIVISION.

Einzelseiten

  • COPY
  • COPY REPLACING

Pruefung

Die darunterliegenden Seiten nennen konkrete Dateien aus den COBOL-Validierungslaeufen. Neue COBOL-Hilfeintraege sollen nur mit compile/link/run-Beleg ergaenzt werden.

Validation evidence: COBOL command pages cite registered COBOL validation files such as tests/cobol/gaps.cbl or a focused sibling test.

Getestetes Beispiel

       IDENTIFICATION DIVISION.
       PROGRAM-ID. HELP.
       PROCEDURE DIVISION.
           STOP RUN.

Diese Seite ist ein Uebersichtskapitel. Die verlinkten Einzelseiten enthalten die konkreten getesteten Beispiele oder nennen eine ausdrueckliche Begrenzung, wenn ein Befehl nicht zertifiziert ist.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für COBOL-Copybooks soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' COBOL-Copybooks mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.

Zurueck zum Befehlsindex

← CLOSE - Schliesst einen geoeffneten COBOL-Dateihandle. Top COPY - Erweitert ein einfaches quellnahes Copybook aus dem Quellverzeichnis oder dem Unterverzeichnis copybooks. →


COPY - Erweitert ein einfaches quellnahes Copybook aus dem Quellverzeichnis oder dem Unterverzeichnis copybooks. - PBXB64 COBOL Help

Startseite › BASIC Frontend › COPY - Erweitert ein einfaches quellnahes Copybook aus dem Quellverzeichnis oder dem Unterverzeichnis copybooks.
Hilfe zum PBXB64-Compiler

COPY - Erweitert ein einfaches quellnahes Copybook aus dem Quellverzeichnis oder dem Unterverzeichnis copybooks.

Erweitert ein einfaches quellnahes Copybook aus dem Quellverzeichnis oder dem Unterverzeichnis copybooks.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

COPY CUSTREC.

Beschreibung

COPY hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

COPY CUSTREC.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol_legacy/fixed_copy.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


COPY REPLACING - Wendet beim Erweitern eines Copybooks das implementierte Identifier- oder Pseudotext-Ersetzungspaar an. - PBXB64 COBOL Help

Startseite › BASIC Frontend › COPY REPLACING - Wendet beim Erweitern eines Copybooks das implementierte Identifier- oder Pseudotext-Ersetzungspaar an.
Hilfe zum PBXB64-Compiler

COPY REPLACING - Wendet beim Erweitern eines Copybooks das implementierte Identifier- oder Pseudotext-Ersetzungspaar an.

Wendet beim Erweitern eines Copybooks das implementierte Identifier- oder Pseudotext-Ersetzungspaar an.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

COPY REPLTEST REPLACING REPL-NAME BY CUST-NAME.

Beschreibung

COPY REPLACING hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

COPY REPLTEST REPLACING REPL-NAME BY CUST-NAME.

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol_legacy/fixed_copy_replacing.cbl wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Eingebettetes COBOL in BASIC - PBXB64 COBOL Help

Startseite › BASIC Frontend › Embedded COBOL in BASIC

Eingebettetes COBOL in BASIC

Kind: Reference hub | Category: COBOL Frontend

PBXB64 Status: Overview / navigation; child pages carry the command-specific support proof.

Beschreibung

Diese Seite ist ein Ueberblickskapitel. Die einzelnen COBOL-Befehle und Klauseln stehen darunter jeweils auf eigenen, getesteten Referenzseiten.

Syntax

IDENTIFICATION DIVISION.
DATA DIVISION.
PROCEDURE DIVISION.

Einzelseiten

  • #COBOL
  • #COBOL END
  • #COBOL USING

Pruefung

Die darunterliegenden Seiten nennen konkrete Dateien aus den COBOL-Validierungslaeufen. Neue COBOL-Hilfeintraege sollen nur mit compile/link/run-Beleg ergaenzt werden.

Validation evidence: COBOL command pages cite registered COBOL validation files such as tests/cobol/gaps.cbl or a focused sibling test.

Getestetes Beispiel

       IDENTIFICATION DIVISION.
       PROGRAM-ID. HELP.
       PROCEDURE DIVISION.
           STOP RUN.

Diese Seite ist ein Uebersichtskapitel. Die verlinkten Einzelseiten enthalten die konkreten getesteten Beispiele oder nennen eine ausdrueckliche Begrenzung, wenn ein Befehl nicht zertifiziert ist.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Eingebettetes COBOL in BASIC soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingebettetes COBOL in BASIC mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.

Zurueck zum Befehlsindex

← COPY REPLACING - Wendet beim Erweitern eines Copybooks das implementierte Identifier- oder Pseudotext-Ersetzungspaar an. Top #COBOL - Startet einen eingebetteten COBOL-Block in PB-Quelltext. →


#COBOL - Startet einen eingebetteten COBOL-Block in PB-Quelltext. - PBXB64 COBOL Help

Startseite › BASIC Frontend › #COBOL - Startet einen eingebetteten COBOL-Block in PB-Quelltext.
Hilfe zum PBXB64-Compiler

#COBOL - Startet einen eingebetteten COBOL-Block in PB-Quelltext.

Startet einen eingebetteten COBOL-Block in PB-Quelltext.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

#COBOL

Beschreibung

#COBOL hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

#COBOL

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/embedded.pb wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


#COBOL END - Beendet einen eingebetteten COBOL-Block in PB-Quelltext. - PBXB64 COBOL Help

Startseite › BASIC Frontend › #COBOL END - Beendet einen eingebetteten COBOL-Block in PB-Quelltext.
Hilfe zum PBXB64-Compiler

#COBOL END - Beendet einen eingebetteten COBOL-Block in PB-Quelltext.

Beendet einen eingebetteten COBOL-Block in PB-Quelltext.

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

#COBOL END

Beschreibung

#COBOL END hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

#COBOL END

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/embedded.pb wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← #COBOL - Startet einen eingebetteten COBOL-Block in PB-Quelltext. Top #COBOL USING - Bindet PB-Hostvariablen per Referenz fuer einen eingebetteten COBOL-Block. Ganzzahlige Skalare nutzen den bisherigen numerischen Host-Pfad; feste STRINGZ-Puffer binden als PIC X(n). →


#COBOL USING - Bindet PB-Hostvariablen per Referenz fuer einen eingebetteten COBOL-Block. Ganzzahlige Skalare nutzen den bisherigen numerischen Host-Pfad; feste STRINGZ-Puffer binden als PIC X(n). - PBXB64 COBOL Help

Startseite › BASIC Frontend › #COBOL USING - Bindet PB-Hostvariablen per Referenz fuer einen eingebetteten COBOL-Block. Ganzzahlige Skalare nutzen den bisherigen numerischen Host-Pfad; feste STRINGZ-Puffer binden als PIC X(n).
Hilfe zum PBXB64-Compiler

#COBOL USING - Bindet PB-Hostvariablen per Referenz fuer einen eingebetteten COBOL-Block. Ganzzahlige Skalare nutzen den bisherigen numerischen Host-Pfad; feste STRINGZ-Puffer binden als PIC X(n).

Bindet PB-Hostvariablen per Referenz fuer einen eingebetteten COBOL-Block. Ganzzahlige Skalare nutzen den bisherigen numerischen Host-Pfad; feste STRINGZ-Puffer binden als PIC X(n).

Kind: COBOL-Befehl/Klausel | Category: COBOL Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

#COBOL USING count, text

Beschreibung

#COBOL USING hat eine eigene Seite, weil jeder getestete COBOL-Befehl, jede Klausel und jede eingebettete Direktive einen eigenen Frontend-Referenzeintrag haben muss. Die aktuelle Implementierung senkt COBOL direkt in PBXB64-IR ab und verwendet danach den normalen x64-Backend- und Linkerpfad.

Getestetes Beispiel

#COBOL USING count, text

Verifiziertes Beispiel

Das fokussierte Beispiel tests/cobol/embedded_using_fixed_string.pb wird durch die COBOL-Validierungsspuren kompiliert und ausgefuehrt. Direkt kompilieren mit PBXB64 sample.cbl -o sample.exe.

Grenzen

Diese Seite dokumentiert nur die getestete PBXB64-Teilmenge. Indexierte/relative Dateien, SORT/MERGE, OCCURS DEPENDING ON, mehrere COPY-Ersetzungspaare, Kommandozeilen-Copybook-Suchpfade, Gruppen-REDEFINES-Overlay, verschachtelte COBOL-Unterprogrammaufrufe und automatische >18-stellige PIC-Speicherauswahl liegen ausserhalb der zertifizierten Oberflaeche.

Siehe auch

  • COBOL Frontend Overview
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth-Frontend

PBXB64 akzeptiert eigenständige Forth-Quelldateien mit den Erweiterungen .fth, .forth und .4th sowie eingebettete Forth-Blöcke in PowerBASIC-Quelltext mit #FORTH und #ENDFORTH.

Das aktuelle Frontend ist eine teilweise native Forth-Implementierung. Unterstützt ist eine getestete Integer-Teilmenge mit Stack-Wörtern, Arithmetik, erweiterter Arithmetik 1+/1-/2*/2//NEGATE/ABS/MIN/MAX, Bitwörtern AND/OR/XOR/INVERT/LSHIFT/RSHIFT, Vergleichen, Speicherzellen- und Bytezugriff, ausgewählten Konsolenwörtern, BYE, QUIT, ABORT, Return-Stack-Grundlagen, Core-Defining-Words : ... ;, CONSTANT und VARIABLE, Compile-State-Hilfen IMMEDIATE, POSTPONE, STATE, [/] und LITERAL, Stack-/Bereichshilfen ?DUP und WITHIN, einfachen CREATE-Datenobjekten mit ALLOT, Komma-Zellablage und begrenztem DOES>-Laufzeitkoerper auf CREATE-Wörtern, Source-Input-Grundlagen SOURCE, ACCEPT, delimiterbasiertem PARSE und Counted-String-WORD, String-Grundlagen COUNT, TYPE, S", COMPARE, BLANK und -TRAILING, veränderlichen Wertobjekten mit VALUE/TO, Booleschen und Leerzeichen-Konstanten TRUE/FALSE/BL, Null-Prädikaten 0<>/0<=/0>=, Zeichen-Token-Wörtern CHAR/[CHAR], EXIT aus Colon-Definitionen einschliesslich der getesteten strukturierten Kontrollflussfaelle, getesteten IF/ELSE/THEN-Verzweigungen, getesteten CASE/OF/ENDOF/ENDCASE-Mehrfachverzweigungen, geradlinigem, bedingtem und verschachteltem IF-gesteuertem LEAVE, getesteten BEGIN/UNTIL-, BEGIN/AGAIN- und BEGIN/WHILE/REPEAT-Schleifen, gezählten DO/LOOP-Schleifen mit I/J, positivem und negativem Literalschritt bei +LOOP, UNLOOP EXIT- und UNLOOP LEAVE-Bereinigung aus gezählten Schleifen, getestetem inline RECURSE mit begrenzter Expansionsdiagnose sowie PB-Local-Interoperabilität über PBVAR, PBADDR, PBLEN, PBVAL, PBSET, PBVALI64, PBSETI64, PBVALF64 und PBSETF64. PBADDR legt die aktuelle PB-Variablenadresse auf den Stack; PBLEN ist fuer PB-STRING- und Array-Variablen getestet. PBVALF64/PBSETF64 sind auf PB-DOUBLE-breite Skalarvariablen begrenzt; F64 und F+ bilden die getestete fokussierte Floating-Hilfsoberflaeche. Colon-Definitionen werden in der aktuellen Übersetzungseinheit inline abgesenkt; ausufernde rekursive Expansion wird durch eine begrenzte Compilerdiagnose abgewiesen.

Wenn eine eigenstaendige Forth-Datei als Nebeneingabe neben einer BASIC-Hauptquelle kompiliert wird, fuegt PBXB64 generierte Bridge-Deklarationen fuer explizite BASIC-BRIDGE EXPORT- und BRIDGE IMPORT-Symbole voran. Die getesteten Bridge-Woerter sind BRIDGE@ symbol und value BRIDGE! symbol fuer 64-Bit-Integer-Bridge-Speicher sowie BRIDGE@F64 symbol und value BRIDGE!F64 symbol fuer getesteten DOUBLE-breiten Floating-Bridge-Speicher. Feste Bridge-Puffer nutzen BRIDGEADDR symbol und BRIDGELEN symbol mit Byte-Speicherwoertern wie C!. Pointer-Bridge-Slots nutzen BRIDGEPTR symbol, um den gespeicherten Pointerwert vor Byte-Speicherzugriffen auf den Stack zu legen. Der Importpfad ist mit C-eigenem Skalarspeicher, C-eigenen Byte-Arrays und C-eigenen Pointer-Slots getestet, die von BASIC importiert und von Forth geaendert werden. Die untypisierten Integer-Bridge-Woerter lehnen Floating-Bridge-Symbole weiterhin ab; Festpuffer-Adresswoerter lehnen Pointer-Symbole ab.

Die Forth-2012/ANS-Word-Set-Vervollständigung wird fail-closed verfolgt. PBXB64 beansprucht keine Vollständigkeit für Core- oder optionale Word-Sets, bevor die entsprechenden Word-Set-Tests, gemischten PB-Tests und die Hilfedokumentation grün sind.

Referenzseiten

Diese Seite ist die Uebersicht zum Frontend. Die verlinkten Einzelseiten enthalten Syntax, getestete Beispiele, Status und Grenzen fuer die jeweiligen Befehle oder Sprachkonstrukte.

  • Stack-Worte
  • Arithmetik und Bitoperationen
  • Vergleiche und Konstanten
  • Kontrollfluss
  • Schleifen
  • Definitionen und Compile-State
  • Speicher und Datenobjekte
  • Strings und Konsolen-E/A
  • Return-Stack und Runtime
  • Programmsteuerung
  • Eingebettetes Forth in BASIC

Prüfung

Forth-Beispiele sollen als kleine .fth-Dateien getestet werden und einen reproduzierbaren Exit-Code oder eine eindeutige Konsolenausgabe liefern. Eingebettete Forth-Blöcke müssen zusätzlich mit einem PB-Hostprogramm geprüft werden.

Grenzen

Die Core-Oberfläche bleibt teilweise. Beliebige Laufzeitrekursion ausserhalb des getesteten inline RECURSE-Musters, fortgeschrittener gezählter Kontrollfluss ausserhalb der getesteten LEAVE-Fälle, allgemeine UNLOOP-Nutzung ausserhalb der getesteten Bereinigungsmuster, EXIT innerhalb anderer strukturierter Kontrollflüsse, pictured numeric output, vollständige Speicher/String-Semantik sowie vollständiges ANS/Forth-2012-Defining-Word- und Compile-State-Verhalten sind nicht als abgeschlossene Features implementiert. QUIT und ABORT werden derzeit als Prozessbeendigungs-Hilfen behandelt. DOES> ist nur für das getestete CREATE-gebundene Laufzeitkoerper-Muster unterstuetzt. Nicht dokumentierte Forth-Wörter gelten nicht als abgeschlossen.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← Nach oben →


Forth-Programmsteuerung - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth Program Control

Forth-Programmsteuerung

Kind: Reference hub | Category: Forth Frontend

PBXB64 Status: Overview / navigation; child pages carry the word-specific support proof.

Beschreibung

Diese Seite ist ein Ueberblickskapitel. Die einzelnen Forth-Woerter und Direktiven stehen darunter jeweils auf eigenen, getesteten Referenzseiten.

Dieses Kapitel beschreibt die Gruppierung der Forth-Woerter, nicht eine pauschale Zusage voller ANS-Forth-Kompatibilitaet. Verwenden Sie die verlinkten Einzelseiten fuer Syntax, Stack-Effekt, Beispielcode, Validierungsdatei und bekannte Grenzen des aktuell getesteten PBXB64-Frontends.

Syntax

: WORD ( stack -- stack ) ... ;

Einzelseiten

  • BYE
  • QUIT
  • ABORT

Pruefung

Die darunterliegenden Seiten nennen konkrete Forth- oder eingebettete PB-Beispiele. Neue Forth-Hilfeintraege sollen nur mit compile/link/run-Beleg ergaenzt werden.

Validation evidence: Forth command pages cite registered standalone tests/forth files or embedded PB examples.

Beispiel

: DOUBLE 2 * ;
21 DOUBLE .

Siehe auch

  • Forth Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth BYE - Beendet das Forth-Programm mit der obersten Zelle als Prozess-Exitcode. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth BYE - Beendet das Forth-Programm mit der obersten Zelle als Prozess-Exitcode.
Hilfe zum PBXB64-Compiler

Forth BYE - Beendet das Forth-Programm mit der obersten Zelle als Prozess-Exitcode.

Beendet das Forth-Programm mit der obersten Zelle als Prozess-Exitcode.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

BYE

Beschreibung

BYE hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie BYE im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

42 BYE

Pruefung

Abgedeckt durch tests/forth/core_bye.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth QUIT - Beendet das Forth-Programm mit dem Exitcode null. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth QUIT - Beendet das Forth-Programm mit dem Exitcode null.
Hilfe zum PBXB64-Compiler

Forth QUIT - Beendet das Forth-Programm mit dem Exitcode null.

Beendet das Forth-Programm mit dem Exitcode null.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

QUIT

Beschreibung

QUIT hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie QUIT im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

QUIT

Pruefung

Abgedeckt durch tests/forth/help_quit.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth BYE - Beendet das Forth-Programm mit der obersten Zelle als Prozess-Exitcode. Top Forth ABORT - Beendet das Forth-Programm mit dem Exitcode eins. →


Forth ABORT - Beendet das Forth-Programm mit dem Exitcode eins. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth ABORT - Beendet das Forth-Programm mit dem Exitcode eins.
Hilfe zum PBXB64-Compiler

Forth ABORT - Beendet das Forth-Programm mit dem Exitcode eins.

Beendet das Forth-Programm mit dem Exitcode eins.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

ABORT

Beschreibung

ABORT hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie ABORT im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

ABORT

Pruefung

Abgedeckt durch tests/forth/help_abort.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth-Stack-Woerter - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth Stack Words

Forth-Stack-Woerter

Kind: Reference hub | Category: Forth Frontend

PBXB64 Status: Overview / navigation; child pages carry the word-specific support proof.

Beschreibung

Diese Seite ist ein Ueberblickskapitel. Die einzelnen Forth-Woerter und Direktiven stehen darunter jeweils auf eigenen, getesteten Referenzseiten.

Dieses Kapitel beschreibt die Gruppierung der Forth-Woerter, nicht eine pauschale Zusage voller ANS-Forth-Kompatibilitaet. Verwenden Sie die verlinkten Einzelseiten fuer Syntax, Stack-Effekt, Beispielcode, Validierungsdatei und bekannte Grenzen des aktuell getesteten PBXB64-Frontends.

Syntax

: WORD ( stack -- stack ) ... ;

Einzelseiten

  • DUP
  • DROP
  • SWAP
  • OVER
  • ROT
  • NIP
  • TUCK
  • ?DUP
  • 2DROP
  • 2DUP
  • 2SWAP
  • 2OVER

Pruefung

Die darunterliegenden Seiten nennen konkrete Forth- oder eingebettete PB-Beispiele. Neue Forth-Hilfeintraege sollen nur mit compile/link/run-Beleg ergaenzt werden.

Validation evidence: Forth command pages cite registered standalone tests/forth files or embedded PB examples.

Beispiel

: DOUBLE 2 * ;
21 DOUBLE .

Siehe auch

  • Forth Frontend
  • Language Frontends

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Zurueck zum Befehlsindex


Forth DUP - Dupliziert die oberste Datenstack-Zelle. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth DUP - Dupliziert die oberste Datenstack-Zelle.
Hilfe zum PBXB64-Compiler

Forth DUP - Dupliziert die oberste Datenstack-Zelle.

Dupliziert die oberste Datenstack-Zelle.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

DUP

Beschreibung

DUP hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie DUP im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

21 DUP + BYE

Pruefung

Abgedeckt durch tests/forth/core_stack_arith.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth DROP - Verwirft die oberste Datenstack-Zelle. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth DROP - Verwirft die oberste Datenstack-Zelle.
Hilfe zum PBXB64-Compiler

Forth DROP - Verwirft die oberste Datenstack-Zelle.

Verwirft die oberste Datenstack-Zelle.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

DROP

Beschreibung

DROP hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie DROP im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

1 2 DROP BYE

Pruefung

Abgedeckt durch tests/forth/core_stack_arith.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth SWAP - Vertauscht die zwei obersten Datenstack-Zellen. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth SWAP - Vertauscht die zwei obersten Datenstack-Zellen.
Hilfe zum PBXB64-Compiler

Forth SWAP - Vertauscht die zwei obersten Datenstack-Zellen.

Vertauscht die zwei obersten Datenstack-Zellen.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

SWAP

Beschreibung

SWAP hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie SWAP im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

1 41 SWAP DROP BYE

Pruefung

Abgedeckt durch tests/forth/core_stack_arith.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth OVER - Kopiert die zweite Stack-Zelle nach oben. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth OVER - Kopiert die zweite Stack-Zelle nach oben.
Hilfe zum PBXB64-Compiler

Forth OVER - Kopiert die zweite Stack-Zelle nach oben.

Kopiert die zweite Stack-Zelle nach oben.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

OVER

Beschreibung

OVER hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie OVER im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

20 1 OVER + + BYE

Pruefung

Abgedeckt durch tests/forth/core_stack_arith.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth ROT - Rotiert die dritte Stack-Zelle nach oben. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth ROT - Rotiert die dritte Stack-Zelle nach oben.
Hilfe zum PBXB64-Compiler

Forth ROT - Rotiert die dritte Stack-Zelle nach oben.

Rotiert die dritte Stack-Zelle nach oben.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

ROT

Beschreibung

ROT hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie ROT im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

1 2 39 ROT DROP DROP 3 + BYE

Pruefung

Abgedeckt durch tests/forth/core_stack_arith.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth NIP - Entfernt die zweite Stack-Zelle und behaelt die oberste. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth NIP - Entfernt die zweite Stack-Zelle und behaelt die oberste.
Hilfe zum PBXB64-Compiler

Forth NIP - Entfernt die zweite Stack-Zelle und behaelt die oberste.

Entfernt die zweite Stack-Zelle und behaelt die oberste.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

NIP

Beschreibung

NIP hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie NIP im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

11 42 NIP BYE

Pruefung

Abgedeckt durch tests/forth/nip_stack_order.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth TUCK - Kopiert die oberste Stack-Zelle unter die zweite. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth TUCK - Kopiert die oberste Stack-Zelle unter die zweite.
Hilfe zum PBXB64-Compiler

Forth TUCK - Kopiert die oberste Stack-Zelle unter die zweite.

Kopiert die oberste Stack-Zelle unter die zweite.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

TUCK

Beschreibung

TUCK hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie TUCK im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

40 2 TUCK + + 2/ BYE

Pruefung

Abgedeckt durch tests/forth/core_stack_arith.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth NIP - Entfernt die zweite Stack-Zelle und behaelt die oberste. Top Forth ?DUP - Dupliziert die oberste Zelle nur, wenn sie ungleich null ist. →


Forth ?DUP - Dupliziert die oberste Zelle nur, wenn sie ungleich null ist. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth ?DUP - Dupliziert die oberste Zelle nur, wenn sie ungleich null ist.
Hilfe zum PBXB64-Compiler

Forth ?DUP - Dupliziert die oberste Zelle nur, wenn sie ungleich null ist.

Dupliziert die oberste Zelle nur, wenn sie ungleich null ist.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

?DUP

Beschreibung

?DUP hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie ?DUP im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

0 ?DUP 5 ?DUP + + 37 + BYE

Pruefung

Abgedeckt durch tests/forth/qdup_within.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth 2DROP - Verwirft die zwei obersten Stack-Zellen. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth 2DROP - Verwirft die zwei obersten Stack-Zellen.
Hilfe zum PBXB64-Compiler

Forth 2DROP - Verwirft die zwei obersten Stack-Zellen.

Verwirft die zwei obersten Stack-Zellen.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

2DROP

Beschreibung

2DROP hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie 2DROP im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

42 1 2 2DROP BYE

Pruefung

Abgedeckt durch tests/forth/core_stack_arith.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth 2DUP - Dupliziert die zwei obersten Stack-Zellen. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth 2DUP - Dupliziert die zwei obersten Stack-Zellen.
Hilfe zum PBXB64-Compiler

Forth 2DUP - Dupliziert die zwei obersten Stack-Zellen.

Dupliziert die zwei obersten Stack-Zellen.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

2DUP

Beschreibung

2DUP hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie 2DUP im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

10 11 2DUP + + + BYE

Pruefung

Abgedeckt durch tests/forth/core_stack_arith.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth 2SWAP - Vertauscht das oberste Zellenpaar mit dem darunterliegenden Paar. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth 2SWAP - Vertauscht das oberste Zellenpaar mit dem darunterliegenden Paar.
Hilfe zum PBXB64-Compiler

Forth 2SWAP - Vertauscht das oberste Zellenpaar mit dem darunterliegenden Paar.

Vertauscht das oberste Zellenpaar mit dem darunterliegenden Paar.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

2SWAP

Beschreibung

2SWAP hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie 2SWAP im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

1 2 19 20 2SWAP DROP DROP + BYE

Pruefung

Abgedeckt durch tests/forth/core_stack_arith.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth 2OVER - Kopiert das zweite Stack-Paar nach oben. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth 2OVER - Kopiert das zweite Stack-Paar nach oben.
Hilfe zum PBXB64-Compiler

Forth 2OVER - Kopiert das zweite Stack-Paar nach oben.

Kopiert das zweite Stack-Paar nach oben.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

2OVER

Beschreibung

2OVER hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie 2OVER im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

19 20 1 2 2OVER + + + + BYE

Pruefung

Abgedeckt durch tests/forth/core_stack_arith.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth-Arithmetik und Bitoperationen - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth Arithmetic and Bitwise

Forth-Arithmetik und Bitoperationen

Kind: Reference hub | Category: Forth Frontend

PBXB64 Status: Overview / navigation; child pages carry the word-specific support proof.

Beschreibung

Diese Seite ist ein Ueberblickskapitel. Die einzelnen Forth-Woerter und Direktiven stehen darunter jeweils auf eigenen, getesteten Referenzseiten.

Dieses Kapitel beschreibt die Gruppierung der Forth-Woerter, nicht eine pauschale Zusage voller ANS-Forth-Kompatibilitaet. Verwenden Sie die verlinkten Einzelseiten fuer Syntax, Stack-Effekt, Beispielcode, Validierungsdatei und bekannte Grenzen des aktuell getesteten PBXB64-Frontends.

Syntax

: WORD ( stack -- stack ) ... ;

Einzelseiten

  • +
  • -
  • *
  • /
  • MOD
  • 1+
  • 1-
  • 2*
  • 2/
  • NEGATE
  • ABS
  • MIN
  • MAX
  • AND
  • OR
  • XOR
  • INVERT
  • LSHIFT
  • RSHIFT

Pruefung

Die darunterliegenden Seiten nennen konkrete Forth- oder eingebettete PB-Beispiele. Neue Forth-Hilfeintraege sollen nur mit compile/link/run-Beleg ergaenzt werden.

Validation evidence: Forth command pages cite registered standalone tests/forth files or embedded PB examples.

Beispiel

: DOUBLE 2 * ;
21 DOUBLE .

Siehe auch

  • Forth Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth + - Addiert zwei Integer-Zellen. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth + - Addiert zwei Integer-Zellen.
Hilfe zum PBXB64-Compiler

Forth + - Addiert zwei Integer-Zellen.

Addiert zwei Integer-Zellen.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

+

Beschreibung

+ hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie + im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

40 2 + BYE

Pruefung

Abgedeckt durch tests/forth/core_stack_arith.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth - - Subtrahiert die oberste Zelle von der zweiten. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth - - Subtrahiert die oberste Zelle von der zweiten.
Hilfe zum PBXB64-Compiler

Forth - - Subtrahiert die oberste Zelle von der zweiten.

Subtrahiert die oberste Zelle von der zweiten.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

-

Beschreibung

- hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie - im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

50 8 - BYE

Pruefung

Abgedeckt durch tests/forth/core_stack_arith.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth * - Multipliziert zwei Integer-Zellen. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth * - Multipliziert zwei Integer-Zellen.
Hilfe zum PBXB64-Compiler

Forth * - Multipliziert zwei Integer-Zellen.

Multipliziert zwei Integer-Zellen.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

*

Beschreibung

* hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie * im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

6 7 * BYE

Pruefung

Abgedeckt durch tests/forth/core_stack_arith.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth / - Integer-Division. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth / - Integer-Division.
Hilfe zum PBXB64-Compiler

Forth / - Integer-Division.

Integer-Division.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

/

Beschreibung

/ hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie / im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

84 2 / BYE

Pruefung

Abgedeckt durch tests/forth/core_stack_arith.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth MOD - Integer-Rest. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth MOD - Integer-Rest.
Hilfe zum PBXB64-Compiler

Forth MOD - Integer-Rest.

Integer-Rest.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

MOD

Beschreibung

MOD hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie MOD im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

85 43 MOD BYE

Pruefung

Abgedeckt durch tests/forth/core_stack_arith.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth 1+ - Addiert eins zur obersten Integer-Zelle. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth 1+ - Addiert eins zur obersten Integer-Zelle.
Hilfe zum PBXB64-Compiler

Forth 1+ - Addiert eins zur obersten Integer-Zelle.

Addiert eins zur obersten Integer-Zelle.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

1+

Beschreibung

1+ hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie 1+ im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

41 1+ BYE

Pruefung

Abgedeckt durch tests/forth/help_arith_core.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth 1- - Subtrahiert eins von der obersten Integer-Zelle. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth 1- - Subtrahiert eins von der obersten Integer-Zelle.
Hilfe zum PBXB64-Compiler

Forth 1- - Subtrahiert eins von der obersten Integer-Zelle.

Subtrahiert eins von der obersten Integer-Zelle.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

1-

Beschreibung

1- hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie 1- im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

43 1- BYE

Pruefung

Abgedeckt durch tests/forth/help_arith_core.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth 2* - Multipliziert die oberste Integer-Zelle mit zwei. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth 2* - Multipliziert die oberste Integer-Zelle mit zwei.
Hilfe zum PBXB64-Compiler

Forth 2* - Multipliziert die oberste Integer-Zelle mit zwei.

Multipliziert die oberste Integer-Zelle mit zwei.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

2*

Beschreibung

2* hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie 2* im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

21 2* BYE

Pruefung

Abgedeckt durch tests/forth/help_arith_core.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth 2/ - Dividiert die oberste Integer-Zelle durch zwei. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth 2/ - Dividiert die oberste Integer-Zelle durch zwei.
Hilfe zum PBXB64-Compiler

Forth 2/ - Dividiert die oberste Integer-Zelle durch zwei.

Dividiert die oberste Integer-Zelle durch zwei.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

2/

Beschreibung

2/ hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie 2/ im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

84 2/ BYE

Pruefung

Abgedeckt durch tests/forth/help_arith_core.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth NEGATE - Negiert die oberste Integer-Zelle. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth NEGATE - Negiert die oberste Integer-Zelle.
Hilfe zum PBXB64-Compiler

Forth NEGATE - Negiert die oberste Integer-Zelle.

Negiert die oberste Integer-Zelle.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

NEGATE

Beschreibung

NEGATE hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie NEGATE im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

-42 NEGATE BYE

Pruefung

Abgedeckt durch tests/forth/help_arith_core.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth ABS - Liefert den Absolutwert der obersten Integer-Zelle. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth ABS - Liefert den Absolutwert der obersten Integer-Zelle.
Hilfe zum PBXB64-Compiler

Forth ABS - Liefert den Absolutwert der obersten Integer-Zelle.

Liefert den Absolutwert der obersten Integer-Zelle.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

ABS

Beschreibung

ABS hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie ABS im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

-42 ABS BYE

Pruefung

Abgedeckt durch tests/forth/help_abs.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth MIN - Liefert die kleinere von zwei Integer-Zellen. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth MIN - Liefert die kleinere von zwei Integer-Zellen.
Hilfe zum PBXB64-Compiler

Forth MIN - Liefert die kleinere von zwei Integer-Zellen.

Liefert die kleinere von zwei Integer-Zellen.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

MIN

Beschreibung

MIN hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie MIN im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

40 42 MIN 2 + BYE

Pruefung

Abgedeckt durch tests/forth/help_arith_core.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth MAX - Liefert die groessere von zwei Integer-Zellen. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth MAX - Liefert die groessere von zwei Integer-Zellen.
Hilfe zum PBXB64-Compiler

Forth MAX - Liefert die groessere von zwei Integer-Zellen.

Liefert die groessere von zwei Integer-Zellen.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

MAX

Beschreibung

MAX hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie MAX im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

42 40 MAX BYE

Pruefung

Abgedeckt durch tests/forth/help_arith_core.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth AND - Bitweises AND zweier Integer-Zellen. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth AND - Bitweises AND zweier Integer-Zellen.
Hilfe zum PBXB64-Compiler

Forth AND - Bitweises AND zweier Integer-Zellen.

Bitweises AND zweier Integer-Zellen.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

AND

Beschreibung

AND hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie AND im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

15 10 AND 32 + BYE

Pruefung

Abgedeckt durch tests/forth/help_arith_core.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth OR - Bitweises OR zweier Integer-Zellen. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth OR - Bitweises OR zweier Integer-Zellen.
Hilfe zum PBXB64-Compiler

Forth OR - Bitweises OR zweier Integer-Zellen.

Bitweises OR zweier Integer-Zellen.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

OR

Beschreibung

OR hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie OR im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

32 8 OR 2 + BYE

Pruefung

Abgedeckt durch tests/forth/help_arith_core.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth XOR - Bitweises XOR zweier Integer-Zellen. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth XOR - Bitweises XOR zweier Integer-Zellen.
Hilfe zum PBXB64-Compiler

Forth XOR - Bitweises XOR zweier Integer-Zellen.

Bitweises XOR zweier Integer-Zellen.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

XOR

Beschreibung

XOR hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie XOR im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

45 7 XOR BYE

Pruefung

Abgedeckt durch tests/forth/help_arith_core.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth INVERT - Invertiert jedes Bit der obersten Integer-Zelle. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth INVERT - Invertiert jedes Bit der obersten Integer-Zelle.
Hilfe zum PBXB64-Compiler

Forth INVERT - Invertiert jedes Bit der obersten Integer-Zelle.

Invertiert jedes Bit der obersten Integer-Zelle.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

INVERT

Beschreibung

INVERT hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie INVERT im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

-43 INVERT BYE

Pruefung

Abgedeckt durch tests/forth/help_arith_core.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth LSHIFT - Schiebt eine Integer-Zelle um die angegebene Bitzahl nach links. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth LSHIFT - Schiebt eine Integer-Zelle um die angegebene Bitzahl nach links.
Hilfe zum PBXB64-Compiler

Forth LSHIFT - Schiebt eine Integer-Zelle um die angegebene Bitzahl nach links.

Schiebt eine Integer-Zelle um die angegebene Bitzahl nach links.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

LSHIFT

Beschreibung

LSHIFT hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie LSHIFT im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

21 1 LSHIFT BYE

Pruefung

Abgedeckt durch tests/forth/help_arith_core.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth INVERT - Invertiert jedes Bit der obersten Integer-Zelle. Top Forth RSHIFT - Schiebt eine Integer-Zelle um die angegebene Bitzahl nach rechts. →


Forth RSHIFT - Schiebt eine Integer-Zelle um die angegebene Bitzahl nach rechts. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth RSHIFT - Schiebt eine Integer-Zelle um die angegebene Bitzahl nach rechts.
Hilfe zum PBXB64-Compiler

Forth RSHIFT - Schiebt eine Integer-Zelle um die angegebene Bitzahl nach rechts.

Schiebt eine Integer-Zelle um die angegebene Bitzahl nach rechts.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

RSHIFT

Beschreibung

RSHIFT hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie RSHIFT im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

84 1 RSHIFT BYE

Pruefung

Abgedeckt durch tests/forth/help_arith_core.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth-Vergleiche und Konstanten - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth Comparisons and Constants
Hilfe zum PBXB64-Compiler

Forth-Vergleiche und Konstanten

Kind: Reference hub | Category: Forth Frontend

PBXB64 Status: Overview / navigation; child pages carry the word-specific support proof.

Beschreibung

Diese Seite ist ein Ueberblickskapitel. Die einzelnen Forth-Woerter und Direktiven stehen darunter jeweils auf eigenen, getesteten Referenzseiten.

Dieses Kapitel beschreibt die Gruppierung der Forth-Woerter, nicht eine pauschale Zusage voller ANS-Forth-Kompatibilitaet. Verwenden Sie die verlinkten Einzelseiten fuer Syntax, Stack-Effekt, Beispielcode, Validierungsdatei und bekannte Grenzen des aktuell getesteten PBXB64-Frontends.

Syntax

: WORD ( stack -- stack ) ... ;

Einzelseiten

  • =
  • <>
  • <
  • <=
  • >
  • >=
  • 0=
  • 0<>
  • 0<
  • 0<=
  • 0>
  • 0>=
  • WITHIN
  • TRUE
  • FALSE
  • BL

Pruefung

Die darunterliegenden Seiten nennen konkrete Forth- oder eingebettete PB-Beispiele. Neue Forth-Hilfeintraege sollen nur mit compile/link/run-Beleg ergaenzt werden.

Validation evidence: Forth command pages cite registered standalone tests/forth files or embedded PB examples.

Beispiel

: DOUBLE 2 * ;
21 DOUBLE .

Siehe auch

  • Forth Frontend
  • Language Frontends

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.

Zurueck zum Befehlsindex


Forth = - Vergleicht zwei Zellen auf Gleichheit. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth = - Vergleicht zwei Zellen auf Gleichheit.
Hilfe zum PBXB64-Compiler

Forth = - Vergleicht zwei Zellen auf Gleichheit.

Vergleicht zwei Zellen auf Gleichheit.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

=

Beschreibung

= hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie = im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

42 42 = BYE

Pruefung

Abgedeckt durch tests/forth/core_bool_colon.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth <> - Vergleicht zwei Zellen auf Ungleichheit. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth &lt;&gt; - Vergleicht zwei Zellen auf Ungleichheit.
Hilfe zum PBXB64-Compiler

Forth <> - Vergleicht zwei Zellen auf Ungleichheit.

Vergleicht zwei Zellen auf Ungleichheit.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

<>

Beschreibung

<> hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie <> im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

41 42 <> 42 * BYE

Pruefung

Abgedeckt durch tests/forth/core_bool_colon.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth < - Vorzeichenbehafteter Kleiner-als-Vergleich. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth &lt; - Vorzeichenbehafteter Kleiner-als-Vergleich.
Hilfe zum PBXB64-Compiler

Forth < - Vorzeichenbehafteter Kleiner-als-Vergleich.

Vorzeichenbehafteter Kleiner-als-Vergleich.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

<

Beschreibung

< hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie < im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

1 2 < BYE

Pruefung

Abgedeckt durch tests/forth/core_bool_colon.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth <= - Vorzeichenbehafteter Kleiner-gleich-Vergleich. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth &lt;= - Vorzeichenbehafteter Kleiner-gleich-Vergleich.
Hilfe zum PBXB64-Compiler

Forth <= - Vorzeichenbehafteter Kleiner-gleich-Vergleich.

Vorzeichenbehafteter Kleiner-gleich-Vergleich.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

<=

Beschreibung

<= hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie <= im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

42 42 <= 42 * BYE

Pruefung

Abgedeckt durch tests/forth/core_bool_colon.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth > - Vorzeichenbehafteter Groesser-als-Vergleich. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth &gt; - Vorzeichenbehafteter Groesser-als-Vergleich.
Hilfe zum PBXB64-Compiler

Forth > - Vorzeichenbehafteter Groesser-als-Vergleich.

Vorzeichenbehafteter Groesser-als-Vergleich.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

>

Beschreibung

> hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie > im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

2 1 > BYE

Pruefung

Abgedeckt durch tests/forth/core_bool_colon.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth >= - Vorzeichenbehafteter Groesser-gleich-Vergleich. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth &gt;= - Vorzeichenbehafteter Groesser-gleich-Vergleich.
Hilfe zum PBXB64-Compiler

Forth >= - Vorzeichenbehafteter Groesser-gleich-Vergleich.

Vorzeichenbehafteter Groesser-gleich-Vergleich.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

>=

Beschreibung

>= hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie >= im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

42 42 >= 42 * BYE

Pruefung

Abgedeckt durch tests/forth/core_bool_colon.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth 0= - Prueft, ob die oberste Zelle null ist. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth 0= - Prueft, ob die oberste Zelle null ist.
Hilfe zum PBXB64-Compiler

Forth 0= - Prueft, ob die oberste Zelle null ist.

Prueft, ob die oberste Zelle null ist.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

0=

Beschreibung

0= hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie 0= im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

0 0= BYE

Pruefung

Abgedeckt durch tests/forth/core_zero_predicates.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth 0<> - Prueft, ob die oberste Zelle ungleich null ist. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth 0&lt;&gt; - Prueft, ob die oberste Zelle ungleich null ist.
Hilfe zum PBXB64-Compiler

Forth 0<> - Prueft, ob die oberste Zelle ungleich null ist.

Prueft, ob die oberste Zelle ungleich null ist.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

0<>

Beschreibung

0<> hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie 0<> im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

1 0<> BYE

Pruefung

Abgedeckt durch tests/forth/core_zero_predicates.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth 0< - Prueft, ob die oberste Zelle negativ ist. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth 0&lt; - Prueft, ob die oberste Zelle negativ ist.
Hilfe zum PBXB64-Compiler

Forth 0< - Prueft, ob die oberste Zelle negativ ist.

Prueft, ob die oberste Zelle negativ ist.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

0<

Beschreibung

0< hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie 0< im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

-1 0< BYE

Pruefung

Abgedeckt durch tests/forth/core_zero_predicates.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth 0<= - Prueft, ob die oberste Zelle kleiner oder gleich null ist. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth 0&lt;= - Prueft, ob die oberste Zelle kleiner oder gleich null ist.
Hilfe zum PBXB64-Compiler

Forth 0<= - Prueft, ob die oberste Zelle kleiner oder gleich null ist.

Prueft, ob die oberste Zelle kleiner oder gleich null ist.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

0<=

Beschreibung

0<= hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie 0<= im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

0 0<= BYE

Pruefung

Abgedeckt durch tests/forth/core_zero_predicates.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth 0> - Prueft, ob die oberste Zelle positiv ist. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth 0&gt; - Prueft, ob die oberste Zelle positiv ist.
Hilfe zum PBXB64-Compiler

Forth 0> - Prueft, ob die oberste Zelle positiv ist.

Prueft, ob die oberste Zelle positiv ist.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

0>

Beschreibung

0> hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie 0> im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

1 0> BYE

Pruefung

Abgedeckt durch tests/forth/core_zero_predicates.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth 0&lt;= - Prueft, ob die oberste Zelle kleiner oder gleich null ist. Top Forth 0&gt;= - Prueft, ob die oberste Zelle groesser oder gleich null ist. →


Forth 0>= - Prueft, ob die oberste Zelle groesser oder gleich null ist. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth 0&gt;= - Prueft, ob die oberste Zelle groesser oder gleich null ist.
Hilfe zum PBXB64-Compiler

Forth 0>= - Prueft, ob die oberste Zelle groesser oder gleich null ist.

Prueft, ob die oberste Zelle groesser oder gleich null ist.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

0>=

Beschreibung

0>= hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie 0>= im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

0 0>= BYE

Pruefung

Abgedeckt durch tests/forth/core_zero_predicates.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth WITHIN - Prueft, ob ein Wert im halboffenen Bereich low <= x < high liegt. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth WITHIN - Prueft, ob ein Wert im halboffenen Bereich low &lt;= x &lt; high liegt.
Hilfe zum PBXB64-Compiler

Forth WITHIN - Prueft, ob ein Wert im halboffenen Bereich low <= x < high liegt.

Prueft, ob ein Wert im halboffenen Bereich low <= x < high liegt.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

WITHIN

Beschreibung

WITHIN hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie WITHIN im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

5 1 10 WITHIN 42 * BYE

Pruefung

Abgedeckt durch tests/forth/qdup_within.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth TRUE - Legt den True-Flag auf den Stack. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth TRUE - Legt den True-Flag auf den Stack.
Hilfe zum PBXB64-Compiler

Forth TRUE - Legt den True-Flag auf den Stack.

Legt den True-Flag auf den Stack.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

TRUE

Beschreibung

TRUE hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie TRUE im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

TRUE BYE

Pruefung

Abgedeckt durch tests/forth/core_bool_constants.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth FALSE - Legt den False-Flag auf den Stack. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth FALSE - Legt den False-Flag auf den Stack.
Hilfe zum PBXB64-Compiler

Forth FALSE - Legt den False-Flag auf den Stack.

Legt den False-Flag auf den Stack.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

FALSE

Beschreibung

FALSE hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie FALSE im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

FALSE BYE

Pruefung

Abgedeckt durch tests/forth/core_bool_constants.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth BL - Legt den ASCII-Code fuer Leerzeichen auf den Stack. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth BL - Legt den ASCII-Code fuer Leerzeichen auf den Stack.
Hilfe zum PBXB64-Compiler

Forth BL - Legt den ASCII-Code fuer Leerzeichen auf den Stack.

Legt den ASCII-Code fuer Leerzeichen auf den Stack.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

BL

Beschreibung

BL hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie BL im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

BL BYE

Pruefung

Abgedeckt durch tests/forth/core_bool_constants.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth-Definitionen und Compile-State - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth Definitions and Compile State
Hilfe zum PBXB64-Compiler

Forth-Definitionen und Compile-State

Kind: Reference hub | Category: Forth Frontend

PBXB64 Status: Overview / navigation; child pages carry the word-specific support proof.

Beschreibung

Diese Seite ist ein Ueberblickskapitel. Die einzelnen Forth-Woerter und Direktiven stehen darunter jeweils auf eigenen, getesteten Referenzseiten.

Dieses Kapitel beschreibt die Gruppierung der Forth-Woerter, nicht eine pauschale Zusage voller ANS-Forth-Kompatibilitaet. Verwenden Sie die verlinkten Einzelseiten fuer Syntax, Stack-Effekt, Beispielcode, Validierungsdatei und bekannte Grenzen des aktuell getesteten PBXB64-Frontends.

Syntax

: WORD ( stack -- stack ) ... ;

Einzelseiten

  • :
  • ;
  • CONSTANT
  • VARIABLE
  • VALUE
  • TO
  • IMMEDIATE
  • POSTPONE
  • STATE
  • [
  • ]
  • LITERAL
  • RECURSE

Pruefung

Die darunterliegenden Seiten nennen konkrete Forth- oder eingebettete PB-Beispiele. Neue Forth-Hilfeintraege sollen nur mit compile/link/run-Beleg ergaenzt werden.

Validation evidence: Forth command pages cite registered standalone tests/forth files or embedded PB examples.

Beispiel

: DOUBLE 2 * ;
21 DOUBLE .

Siehe auch

  • Forth Frontend
  • Language Frontends

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.

Zurueck zum Befehlsindex


Forth : - Startet eine Colon-Wortdefinition. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth : - Startet eine Colon-Wortdefinition.
Hilfe zum PBXB64-Compiler

Forth : - Startet eine Colon-Wortdefinition.

Startet eine Colon-Wortdefinition.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

:

Beschreibung

: hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie : im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

: SQUARE DUP * ; 6 SQUARE BYE

Pruefung

Abgedeckt durch tests/forth/colon_square.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth ; - Beendet eine Colon-Wortdefinition. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth ; - Beendet eine Colon-Wortdefinition.
Hilfe zum PBXB64-Compiler

Forth ; - Beendet eine Colon-Wortdefinition.

Beendet eine Colon-Wortdefinition.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

;

Beschreibung

; hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie ; im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

: SQUARE DUP * ; 6 SQUARE BYE

Pruefung

Abgedeckt durch tests/forth/colon_square.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth CONSTANT - Definiert eine benannte Konstante. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth CONSTANT - Definiert eine benannte Konstante.
Hilfe zum PBXB64-Compiler

Forth CONSTANT - Definiert eine benannte Konstante.

Definiert eine benannte Konstante.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

CONSTANT

Beschreibung

CONSTANT hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie CONSTANT im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

42 CONSTANT ANSWER ANSWER BYE

Pruefung

Abgedeckt durch tests/forth/constant_variable.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.

Zurueck zum Befehlsindex


Forth VARIABLE - Definiert eine zellbasierte Variable. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth VARIABLE - Definiert eine zellbasierte Variable.
Hilfe zum PBXB64-Compiler

Forth VARIABLE - Definiert eine zellbasierte Variable.

Definiert eine zellbasierte Variable.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

VARIABLE

Beschreibung

VARIABLE hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie VARIABLE im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

VARIABLE X 42 X ! X @ BYE

Pruefung

Abgedeckt durch tests/forth/constant_variable.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.

Zurueck zum Befehlsindex


Forth VALUE - Definiert ein veraenderliches VALUE-Objekt. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth VALUE - Definiert ein veraenderliches VALUE-Objekt.
Hilfe zum PBXB64-Compiler

Forth VALUE - Definiert ein veraenderliches VALUE-Objekt.

Definiert ein veraenderliches VALUE-Objekt.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

VALUE

Beschreibung

VALUE hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie VALUE im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

1 VALUE X 42 TO X X BYE

Pruefung

Abgedeckt durch tests/forth/value_to.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth TO - Weist einem VALUE-Objekt einen neuen Wert zu. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth TO - Weist einem VALUE-Objekt einen neuen Wert zu.
Hilfe zum PBXB64-Compiler

Forth TO - Weist einem VALUE-Objekt einen neuen Wert zu.

Weist einem VALUE-Objekt einen neuen Wert zu.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

TO

Beschreibung

TO hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie TO im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

1 VALUE X 42 TO X X BYE

Pruefung

Abgedeckt durch tests/forth/value_to.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth IMMEDIATE - Markiert das zuletzt definierte Wort als compile-time immediate. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth IMMEDIATE - Markiert das zuletzt definierte Wort als compile-time immediate.
Hilfe zum PBXB64-Compiler

Forth IMMEDIATE - Markiert das zuletzt definierte Wort als compile-time immediate.

Markiert das zuletzt definierte Wort als compile-time immediate.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

IMMEDIATE

Beschreibung

IMMEDIATE hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie IMMEDIATE im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

: INC2 1+ 1+ ; IMMEDIATE : APPLY 40 INC2 ; APPLY BYE

Pruefung

Abgedeckt durch tests/forth/immediate_expand.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth TO - Weist einem VALUE-Objekt einen neuen Wert zu. Top Forth POSTPONE - Haengt das naechste Token an die aktuelle Colon-Definition an, ohne es jetzt auszufuehren. →


Forth POSTPONE - Haengt das naechste Token an die aktuelle Colon-Definition an, ohne es jetzt auszufuehren. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth POSTPONE - Haengt das naechste Token an die aktuelle Colon-Definition an, ohne es jetzt auszufuehren.
Hilfe zum PBXB64-Compiler

Forth POSTPONE - Haengt das naechste Token an die aktuelle Colon-Definition an, ohne es jetzt auszufuehren.

Haengt das naechste Token an die aktuelle Colon-Definition an, ohne es jetzt auszufuehren.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

POSTPONE

Beschreibung

POSTPONE hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie POSTPONE im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

: INC1 POSTPONE 1+ ; IMMEDIATE : APPLY 41 INC1 ; APPLY BYE

Pruefung

Abgedeckt durch tests/forth/postpone_expand.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth IMMEDIATE - Markiert das zuletzt definierte Wort als compile-time immediate. Top Forth STATE - Legt den aktuellen Compile-State-Flag auf den Stack (0 im Interpretationszustand, ungleich 0 beim Erfassen einer Definition). →


Forth STATE - Legt den aktuellen Compile-State-Flag auf den Stack (0 im Interpretationszustand, ungleich 0 beim Erfassen einer Definition). - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth STATE - Legt den aktuellen Compile-State-Flag auf den Stack (0 im Interpretationszustand, ungleich 0 beim Erfassen einer Definition).
Hilfe zum PBXB64-Compiler

Forth STATE - Legt den aktuellen Compile-State-Flag auf den Stack (0 im Interpretationszustand, ungleich 0 beim Erfassen einer Definition).

Legt den aktuellen Compile-State-Flag auf den Stack (0 im Interpretationszustand, ungleich 0 beim Erfassen einer Definition).

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

STATE

Beschreibung

STATE hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie STATE im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

STATE 0= IF 42 ELSE 41 THEN BYE

Pruefung

Abgedeckt durch tests/forth/state_runtime.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth POSTPONE - Haengt das naechste Token an die aktuelle Colon-Definition an, ohne es jetzt auszufuehren. Top Forth [ - Wechselt innerhalb einer Colon-Definition in den Interpretationszustand. →


Forth [ - Wechselt innerhalb einer Colon-Definition in den Interpretationszustand. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth [ - Wechselt innerhalb einer Colon-Definition in den Interpretationszustand.
Hilfe zum PBXB64-Compiler

Forth [ - Wechselt innerhalb einer Colon-Definition in den Interpretationszustand.

Wechselt innerhalb einer Colon-Definition in den Interpretationszustand.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

[

Beschreibung

[ hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie [ im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

: ANSWER [ 40 2 + ] ; ANSWER BYE

Pruefung

Abgedeckt durch tests/forth/help_brackets_eval.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth STATE - Legt den aktuellen Compile-State-Flag auf den Stack (0 im Interpretationszustand, ungleich 0 beim Erfassen einer Definition). Top Forth ] - Setzt innerhalb einer Colon-Definition den Kompilierzustand fort. →


Forth ] - Setzt innerhalb einer Colon-Definition den Kompilierzustand fort. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth ] - Setzt innerhalb einer Colon-Definition den Kompilierzustand fort.
Hilfe zum PBXB64-Compiler

Forth ] - Setzt innerhalb einer Colon-Definition den Kompilierzustand fort.

Setzt innerhalb einer Colon-Definition den Kompilierzustand fort.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

]

Beschreibung

] hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie ] im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

: ANSWER [ 40 2 + ] ; ANSWER BYE

Pruefung

Abgedeckt durch tests/forth/help_brackets_eval.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth [ - Wechselt innerhalb einer Colon-Definition in den Interpretationszustand. Top Forth LITERAL - Kompiliert das oberste Stack-Element als Laufzeit-Literal-Token. →


Forth LITERAL - Kompiliert das oberste Stack-Element als Laufzeit-Literal-Token. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth LITERAL - Kompiliert das oberste Stack-Element als Laufzeit-Literal-Token.
Hilfe zum PBXB64-Compiler

Forth LITERAL - Kompiliert das oberste Stack-Element als Laufzeit-Literal-Token.

Kompiliert das oberste Stack-Element als Laufzeit-Literal-Token.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: BEGRENZT / NICHT ZERTIFIZIERT

PBXB64 Certification: [DOCUMENTED]

Syntax

LITERAL

Beschreibung

LITERAL hat eine eigene Navigationsseite, ist in den aktuellen PBXB64-Forth-Nachweisen aber nicht als erfolgreiches Compile-/Run-Beispiel zertifiziert. Verwenden Sie die benachbarten zertifizierten Forth-Seiten fuer funktionierende Beispiele und behandeln Sie diese Seite bis zu einem passenden Compile-/Run-Test als Syntax- und Kontextdokumentation.

Verwendung im Programm

Behandeln Sie LITERAL als dokumentierte Wortform, auch wenn die Seite nur ein Navigationshinweis ist. Leiten Sie den aktuellen Runtime-Stil aus den benachbarten zertifizierten Seiten ab und ersetzen Sie den Platzhalter-Nachweis durch ein fokussiertes Compile-/Run-Beispiel, bevor Sie sich in einem echten Programm darauf verlassen.

Fehlerfaelle

Wenn die Seite noch nicht zertifiziert ist, besteht der wichtigste Fehler darin, die Syntax bereits als bewiesen anzunehmen. Verwenden Sie bis zu einem eigenen Compile-/Run-Beleg nur die benachbarten getesteten Seiten als Ausfuehrungsnachweis.

Referenzbeispiel

: ANSWER [ 40 2 + ] LITERAL ; ANSWER BYE

Pruefung

Referenzbeispiel: tests/forth/literal_brackets.fth. Diese Seite dokumentiert das unterstuetzte Wort, ist aber nicht als zertifiziert markiert, weil genau dieses Beispiel nicht Teil des aktuellen sauberen Compile-/Run-Nachweises ist. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth ] - Setzt innerhalb einer Colon-Definition den Kompilierzustand fort. Top Forth RECURSE - Wiederholt die aktuelle Colon-Definition fuer getestete inline rekursive Definitionen mit begrenzter Expansionsdiagnose. →


Forth RECURSE - Wiederholt die aktuelle Colon-Definition fuer getestete inline rekursive Definitionen mit begrenzter Expansionsdiagnose. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth RECURSE - Wiederholt die aktuelle Colon-Definition fuer getestete inline rekursive Definitionen mit begrenzter Expansionsdiagnose.
Hilfe zum PBXB64-Compiler

Forth RECURSE - Wiederholt die aktuelle Colon-Definition fuer getestete inline rekursive Definitionen mit begrenzter Expansionsdiagnose.

Wiederholt die aktuelle Colon-Definition fuer getestete inline rekursive Definitionen mit begrenzter Expansionsdiagnose.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: BEGRENZT / NICHT ZERTIFIZIERT

PBXB64 Certification: [DOCUMENTED]

Syntax

RECURSE

Beschreibung

RECURSE hat eine eigene Navigationsseite, ist in den aktuellen PBXB64-Forth-Nachweisen aber nicht als erfolgreiches Compile-/Run-Beispiel zertifiziert. Verwenden Sie die benachbarten zertifizierten Forth-Seiten fuer funktionierende Beispiele und behandeln Sie diese Seite bis zu einem passenden Compile-/Run-Test als Syntax- und Kontextdokumentation.

Verwendung im Programm

Behandeln Sie RECURSE als dokumentierte Wortform, auch wenn die Seite nur ein Navigationshinweis ist. Leiten Sie den aktuellen Runtime-Stil aus den benachbarten zertifizierten Seiten ab und ersetzen Sie den Platzhalter-Nachweis durch ein fokussiertes Compile-/Run-Beispiel, bevor Sie sich in einem echten Programm darauf verlassen.

Fehlerfaelle

Wenn die Seite noch nicht zertifiziert ist, besteht der wichtigste Fehler darin, die Syntax bereits als bewiesen anzunehmen. Verwenden Sie bis zu einem eigenen Compile-/Run-Beleg nur die benachbarten getesteten Seiten als Ausfuehrungsnachweis.

Referenzbeispiel

: FACT DUP 1 <= IF DROP 1 EXIT THEN DUP 1 - RECURSE * ; 5 FACT 78 - BYE

Pruefung

Referenzbeispiel: tests/forth/recurse_factorial.fth. Diese Seite dokumentiert das unterstuetzte Wort, ist aber nicht als zertifiziert markiert, weil genau dieses Beispiel nicht Teil des aktuellen sauberen Compile-/Run-Nachweises ist. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth-Speicher und Datenobjekte - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth Memory and Data Objects

Forth-Speicher und Datenobjekte

Kind: Reference hub | Category: Forth Frontend

PBXB64 Status: Overview / navigation; child pages carry the word-specific support proof.

Beschreibung

Diese Seite ist ein Ueberblickskapitel. Die einzelnen Forth-Woerter und Direktiven stehen darunter jeweils auf eigenen, getesteten Referenzseiten.

Dieses Kapitel beschreibt die Gruppierung der Forth-Woerter, nicht eine pauschale Zusage voller ANS-Forth-Kompatibilitaet. Verwenden Sie die verlinkten Einzelseiten fuer Syntax, Stack-Effekt, Beispielcode, Validierungsdatei und bekannte Grenzen des aktuell getesteten PBXB64-Frontends.

Syntax

: WORD ( stack -- stack ) ... ;

Einzelseiten

  • @
  • !
  • +!
  • C@
  • C!
  • CREATE
  • DOES>
  • ALLOT
  • ,
  • CELL+
  • CELLS

Pruefung

Die darunterliegenden Seiten nennen konkrete Forth- oder eingebettete PB-Beispiele. Neue Forth-Hilfeintraege sollen nur mit compile/link/run-Beleg ergaenzt werden.

Validation evidence: Forth command pages cite registered standalone tests/forth files or embedded PB examples.

Beispiel

: DOUBLE 2 * ;
21 DOUBLE .

Siehe auch

  • Forth Frontend
  • Language Frontends

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.

Zurueck zum Befehlsindex

← Forth RECURSE - Wiederholt die aktuelle Colon-Definition fuer getestete inline rekursive Definitionen mit begrenzter Expansionsdiagnose. Top Forth @ - Liest eine Zelle ueber eine Adresse. →


Forth @ - Liest eine Zelle ueber eine Adresse. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth @ - Liest eine Zelle ueber eine Adresse.
Hilfe zum PBXB64-Compiler

Forth @ - Liest eine Zelle ueber eine Adresse.

Liest eine Zelle ueber eine Adresse.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

@

Beschreibung

@ hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie @ im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

VARIABLE X 42 X ! X @ BYE

Pruefung

Abgedeckt durch tests/forth/constant_variable.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth ! - Schreibt eine Zelle ueber eine Adresse. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth ! - Schreibt eine Zelle ueber eine Adresse.
Hilfe zum PBXB64-Compiler

Forth ! - Schreibt eine Zelle ueber eine Adresse.

Schreibt eine Zelle ueber eine Adresse.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

!

Beschreibung

! hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie ! im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

VARIABLE X 42 X ! X @ BYE

Pruefung

Abgedeckt durch tests/forth/constant_variable.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth +! - Addiert eine Zelle zur an einer Adresse gespeicherten Zelle. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth +! - Addiert eine Zelle zur an einer Adresse gespeicherten Zelle.
Hilfe zum PBXB64-Compiler

Forth +! - Addiert eine Zelle zur an einer Adresse gespeicherten Zelle.

Addiert eine Zelle zur an einer Adresse gespeicherten Zelle.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

+!

Beschreibung

+! hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie +! im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

VARIABLE X 40 X ! 2 X +! X @ BYE

Pruefung

Abgedeckt durch tests/forth/constant_variable.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth C@ - Liest ein Byte ueber eine Adresse. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth C@ - Liest ein Byte ueber eine Adresse.
Hilfe zum PBXB64-Compiler

Forth C@ - Liest ein Byte ueber eine Adresse.

Liest ein Byte ueber eine Adresse.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

C@

Beschreibung

C@ hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie C@ im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

CREATE B 1 ALLOT 65 B C! B C@ BYE

Pruefung

Abgedeckt durch tests/forth/help_cfetch_cstore.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth C! - Schreibt ein Byte ueber eine Adresse. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth C! - Schreibt ein Byte ueber eine Adresse.
Hilfe zum PBXB64-Compiler

Forth C! - Schreibt ein Byte ueber eine Adresse.

Schreibt ein Byte ueber eine Adresse.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

C!

Beschreibung

C! hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie C! im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

CREATE B 1 ALLOT 65 B C! B C@ BYE

Pruefung

Abgedeckt durch tests/forth/help_cfetch_cstore.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth CREATE - Erzeugt ein benanntes Datenobjekt. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth CREATE - Erzeugt ein benanntes Datenobjekt.
Hilfe zum PBXB64-Compiler

Forth CREATE - Erzeugt ein benanntes Datenobjekt.

Erzeugt ein benanntes Datenobjekt.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

CREATE

Beschreibung

CREATE hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie CREATE im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

CREATE T 42 , T @ BYE

Pruefung

Abgedeckt durch tests/forth/help_create_comma.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth C! - Schreibt ein Byte ueber eine Adresse. Top Forth DOES&gt; - Haengt einem zuletzt mit CREATE angelegten Wort einen Laufzeitkoerper an und laesst beim Ausfuehren seine Adresse auf dem Stack. →


Forth DOES> - Haengt einem zuletzt mit CREATE angelegten Wort einen Laufzeitkoerper an und laesst beim Ausfuehren seine Adresse auf dem Stack. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth DOES&gt; - Haengt einem zuletzt mit CREATE angelegten Wort einen Laufzeitkoerper an und laesst beim Ausfuehren seine Adresse auf dem Stack.
Hilfe zum PBXB64-Compiler

Forth DOES> - Haengt einem zuletzt mit CREATE angelegten Wort einen Laufzeitkoerper an und laesst beim Ausfuehren seine Adresse auf dem Stack.

Haengt einem zuletzt mit CREATE angelegten Wort einen Laufzeitkoerper an und laesst beim Ausfuehren seine Adresse auf dem Stack.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

DOES>

Beschreibung

DOES> hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie DOES> im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

CREATE CELLBOX 41 , DOES> @ 1+ ; CELLBOX BYE

Pruefung

Abgedeckt durch tests/forth/does_create.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth ALLOT - Reserviert Bytes in einem erzeugten Datenobjekt. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth ALLOT - Reserviert Bytes in einem erzeugten Datenobjekt.
Hilfe zum PBXB64-Compiler

Forth ALLOT - Reserviert Bytes in einem erzeugten Datenobjekt.

Reserviert Bytes in einem erzeugten Datenobjekt.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

ALLOT

Beschreibung

ALLOT hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie ALLOT im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

CREATE B 1 ALLOT 65 B C! B C@ BYE

Pruefung

Abgedeckt durch tests/forth/help_cfetch_cstore.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth DOES&gt; - Haengt einem zuletzt mit CREATE angelegten Wort einen Laufzeitkoerper an und laesst beim Ausfuehren seine Adresse auf dem Stack. Top Forth , - Legt eine Zelle im aktuellen Datenobjekt ab. →


Forth , - Legt eine Zelle im aktuellen Datenobjekt ab. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth , - Legt eine Zelle im aktuellen Datenobjekt ab.
Hilfe zum PBXB64-Compiler

Forth , - Legt eine Zelle im aktuellen Datenobjekt ab.

Legt eine Zelle im aktuellen Datenobjekt ab.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

,

Beschreibung

, hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie , im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

CREATE T 42 , T @ BYE

Pruefung

Abgedeckt durch tests/forth/help_create_comma.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.

Zurueck zum Befehlsindex


Forth CELL+ - Erhoeht eine Adresse um eine Zelle. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth CELL+ - Erhoeht eine Adresse um eine Zelle.
Hilfe zum PBXB64-Compiler

Forth CELL+ - Erhoeht eine Adresse um eine Zelle.

Erhoeht eine Adresse um eine Zelle.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

CELL+

Beschreibung

CELL+ hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie CELL+ im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

CREATE T 1 , 42 , T CELL+ @ BYE

Pruefung

Abgedeckt durch tests/forth/help_create_comma.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth CELLS - Skaliert eine Zellanzahl in eine Byteanzahl. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth CELLS - Skaliert eine Zellanzahl in eine Byteanzahl.
Hilfe zum PBXB64-Compiler

Forth CELLS - Skaliert eine Zellanzahl in eine Byteanzahl.

Skaliert eine Zellanzahl in eine Byteanzahl.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

CELLS

Beschreibung

CELLS hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie CELLS im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

CREATE T 1 , 42 , T 1 CELLS + @ BYE

Pruefung

Abgedeckt durch tests/forth/help_create_comma.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth-Strings und Konsolen-E/A - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth Strings and Console I/O

Forth-Strings und Konsolen-E/A

Kind: Reference hub | Category: Forth Frontend

PBXB64 Status: Overview / navigation; child pages carry the word-specific support proof.

Beschreibung

Diese Seite ist ein Ueberblickskapitel. Die einzelnen Forth-Woerter und Direktiven stehen darunter jeweils auf eigenen, getesteten Referenzseiten.

Dieses Kapitel beschreibt die Gruppierung der Forth-Woerter, nicht eine pauschale Zusage voller ANS-Forth-Kompatibilitaet. Verwenden Sie die verlinkten Einzelseiten fuer Syntax, Stack-Effekt, Beispielcode, Validierungsdatei und bekannte Grenzen des aktuell getesteten PBXB64-Frontends.

Syntax

: WORD ( stack -- stack ) ... ;

Einzelseiten

  • COUNT
  • TYPE
  • S"
  • COMPARE
  • BLANK
  • -TRAILING
  • ACCEPT
  • CHAR
  • [CHAR]
  • CMOVE
  • CMOVE>
  • .
  • ."
  • EMIT
  • CR
  • KEY
  • PARSE
  • WORD

Pruefung

Die darunterliegenden Seiten nennen konkrete Forth- oder eingebettete PB-Beispiele. Neue Forth-Hilfeintraege sollen nur mit compile/link/run-Beleg ergaenzt werden.

Validation evidence: Forth command pages cite registered standalone tests/forth files or embedded PB examples.

Beispiel

: DOUBLE 2 * ;
21 DOUBLE .

Siehe auch

  • Forth Frontend
  • Language Frontends

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.

Zurueck zum Befehlsindex


Forth COUNT - Gibt die Adresse und Laenge eines Counted Strings zurueck. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth COUNT - Gibt die Adresse und Laenge eines Counted Strings zurueck.
Hilfe zum PBXB64-Compiler

Forth COUNT - Gibt die Adresse und Laenge eines Counted Strings zurueck.

Gibt die Adresse und Laenge eines Counted Strings zurueck.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

COUNT

Beschreibung

COUNT hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie COUNT im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

CHAR , WORD ,,abc, DROP 42 BYE

Pruefung

Abgedeckt durch tests/forth/help_parse_word_count.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth TYPE - Gibt den String an Adresse und Laenge auf der Konsole aus. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth TYPE - Gibt den String an Adresse und Laenge auf der Konsole aus.
Hilfe zum PBXB64-Compiler

Forth TYPE - Gibt den String an Adresse und Laenge auf der Konsole aus.

Gibt den String an Adresse und Laenge auf der Konsole aus.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

TYPE

Beschreibung

TYPE hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie TYPE im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

CHAR , WORD ,,abc, COUNT TYPE 42 BYE

Pruefung

Abgedeckt durch tests/forth/help_string_console.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.

Zurueck zum Befehlsindex

← Forth COUNT - Gibt die Adresse und Laenge eines Counted Strings zurueck. Top Forth S" - Kompiliert ein String-Literal und legt Adresse und Laenge auf den Stack. →


Forth S" - Kompiliert ein String-Literal und legt Adresse und Laenge auf den Stack. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth S" - Kompiliert ein String-Literal und legt Adresse und Laenge auf den Stack.
Hilfe zum PBXB64-Compiler

Forth S" - Kompiliert ein String-Literal und legt Adresse und Laenge auf den Stack.

Kompiliert ein String-Literal und legt Adresse und Laenge auf den Stack.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

S"

Beschreibung

S" hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie S" im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

S" "hi" TYPE BYE

Pruefung

Abgedeckt durch tests/forth/help_string_console.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth COMPARE - Vergleicht zwei Stringbereiche lexikografisch. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth COMPARE - Vergleicht zwei Stringbereiche lexikografisch.
Hilfe zum PBXB64-Compiler

Forth COMPARE - Vergleicht zwei Stringbereiche lexikografisch.

Vergleicht zwei Stringbereiche lexikografisch.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

COMPARE

Beschreibung

COMPARE hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie COMPARE im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

S" "hi" S" "hi" COMPARE 0= 42 * BYE

Pruefung

Abgedeckt durch tests/forth/help_string_console.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.

Zurueck zum Befehlsindex

← Forth S" - Kompiliert ein String-Literal und legt Adresse und Laenge auf den Stack. Top Forth BLANK - Fuellt einen Byte-Puffer mit ASCII-Leerzeichen. →


Forth BLANK - Fuellt einen Byte-Puffer mit ASCII-Leerzeichen. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth BLANK - Fuellt einen Byte-Puffer mit ASCII-Leerzeichen.
Hilfe zum PBXB64-Compiler

Forth BLANK - Fuellt einen Byte-Puffer mit ASCII-Leerzeichen.

Fuellt einen Byte-Puffer mit ASCII-Leerzeichen.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

BLANK

Beschreibung

BLANK hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie BLANK im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

CREATE B 1 ALLOT B 1 BLANK B C@ 10 + DROP 42 BYE

Pruefung

Abgedeckt durch tests/forth/help_string_misc.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth COMPARE - Vergleicht zwei Stringbereiche lexikografisch. Top Forth -TRAILING - Schneidet nachgestellte Leerzeichen von einer String-Laenge ab. →


Forth -TRAILING - Schneidet nachgestellte Leerzeichen von einer String-Laenge ab. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth -TRAILING - Schneidet nachgestellte Leerzeichen von einer String-Laenge ab.
Hilfe zum PBXB64-Compiler

Forth -TRAILING - Schneidet nachgestellte Leerzeichen von einer String-Laenge ab.

Schneidet nachgestellte Leerzeichen von einer String-Laenge ab.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

-TRAILING

Beschreibung

-TRAILING hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie -TRAILING im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

S" "hi  " -TRAILING DROP DROP 42 BYE

Pruefung

Abgedeckt durch tests/forth/help_string_misc.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth BLANK - Fuellt einen Byte-Puffer mit ASCII-Leerzeichen. Top Forth ACCEPT - Liest eine Zeile aus stdin in einen Puffer und gibt die Zeichenzahl zurueck. →


Forth ACCEPT - Liest eine Zeile aus stdin in einen Puffer und gibt die Zeichenzahl zurueck. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth ACCEPT - Liest eine Zeile aus stdin in einen Puffer und gibt die Zeichenzahl zurueck.
Hilfe zum PBXB64-Compiler

Forth ACCEPT - Liest eine Zeile aus stdin in einen Puffer und gibt die Zeichenzahl zurueck.

Liest eine Zeile aus stdin in einen Puffer und gibt die Zeichenzahl zurueck.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

ACCEPT

Beschreibung

ACCEPT hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie ACCEPT im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

CREATE BUF 16 ALLOT BUF DUP 16 ACCEPT TYPE 42 BYE

Pruefung

Abgedeckt durch tests/forth/help_accept_line.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth -TRAILING - Schneidet nachgestellte Leerzeichen von einer String-Laenge ab. Top Forth CHAR - Parst das naechste Token und legt dessen ersten Zeichencode ab. →


Forth CHAR - Parst das naechste Token und legt dessen ersten Zeichencode ab. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth CHAR - Parst das naechste Token und legt dessen ersten Zeichencode ab.
Hilfe zum PBXB64-Compiler

Forth CHAR - Parst das naechste Token und legt dessen ersten Zeichencode ab.

Parst das naechste Token und legt dessen ersten Zeichencode ab.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

CHAR

Beschreibung

CHAR hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie CHAR im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

CHAR A BYE

Pruefung

Abgedeckt durch tests/forth/char_word.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth ACCEPT - Liest eine Zeile aus stdin in einen Puffer und gibt die Zeichenzahl zurueck. Top Forth [CHAR] - Kompiliert ein Zeichenliteral innerhalb einer Colon-Definition. →


Forth [CHAR] - Kompiliert ein Zeichenliteral innerhalb einer Colon-Definition. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth [CHAR] - Kompiliert ein Zeichenliteral innerhalb einer Colon-Definition.
Hilfe zum PBXB64-Compiler

Forth [CHAR] - Kompiliert ein Zeichenliteral innerhalb einer Colon-Definition.

Kompiliert ein Zeichenliteral innerhalb einer Colon-Definition.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

[CHAR]

Beschreibung

[CHAR] hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie [CHAR] im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

: A [CHAR] A ; A BYE

Pruefung

Abgedeckt durch tests/forth/bracket_char_colon.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth CHAR - Parst das naechste Token und legt dessen ersten Zeichencode ab. Top Forth CMOVE - Kopiert Bytes von einer niedrigeren Quelladresse in aufsteigender Richtung. →


Forth CMOVE - Kopiert Bytes von einer niedrigeren Quelladresse in aufsteigender Richtung. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth CMOVE - Kopiert Bytes von einer niedrigeren Quelladresse in aufsteigender Richtung.
Hilfe zum PBXB64-Compiler

Forth CMOVE - Kopiert Bytes von einer niedrigeren Quelladresse in aufsteigender Richtung.

Kopiert Bytes von einer niedrigeren Quelladresse in aufsteigender Richtung.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: BEGRENZT / NICHT ZERTIFIZIERT

PBXB64 Certification: [DOCUMENTED]

Syntax

CMOVE

Beschreibung

CMOVE hat eine eigene Navigationsseite, ist in den aktuellen PBXB64-Forth-Nachweisen aber nicht als erfolgreiches Compile-/Run-Beispiel zertifiziert. Verwenden Sie die benachbarten zertifizierten Forth-Seiten fuer funktionierende Beispiele und behandeln Sie diese Seite bis zu einem passenden Compile-/Run-Test als Syntax- und Kontextdokumentation.

Verwendung im Programm

Behandeln Sie CMOVE als dokumentierte Wortform, auch wenn die Seite nur ein Navigationshinweis ist. Leiten Sie den aktuellen Runtime-Stil aus den benachbarten zertifizierten Seiten ab und ersetzen Sie den Platzhalter-Nachweis durch ein fokussiertes Compile-/Run-Beispiel, bevor Sie sich in einem echten Programm darauf verlassen.

Fehlerfaelle

Wenn die Seite noch nicht zertifiziert ist, besteht der wichtigste Fehler darin, die Syntax bereits als bewiesen anzunehmen. Verwenden Sie bis zu einem eigenen Compile-/Run-Beleg nur die benachbarten getesteten Seiten als Ausfuehrungsnachweis.

Referenzbeispiel

CREATE B 8 ALLOT S" "ab" B SWAP CMOVE B C@ 55 - BYE

Pruefung

Referenzbeispiel: tests/forth/string_words.fth. Diese Seite dokumentiert das unterstuetzte Wort, ist aber nicht als zertifiziert markiert, weil genau dieses Beispiel nicht Teil des aktuellen sauberen Compile-/Run-Nachweises ist. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth [CHAR] - Kompiliert ein Zeichenliteral innerhalb einer Colon-Definition. Top Forth CMOVE&gt; - Kopiert Bytes von einer hoeheren Quelladresse in absteigender Richtung. →


Forth CMOVE> - Kopiert Bytes von einer hoeheren Quelladresse in absteigender Richtung. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth CMOVE&gt; - Kopiert Bytes von einer hoeheren Quelladresse in absteigender Richtung.
Hilfe zum PBXB64-Compiler

Forth CMOVE> - Kopiert Bytes von einer hoeheren Quelladresse in absteigender Richtung.

Kopiert Bytes von einer hoeheren Quelladresse in absteigender Richtung.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: BEGRENZT / NICHT ZERTIFIZIERT

PBXB64 Certification: [DOCUMENTED]

Syntax

CMOVE>

Beschreibung

CMOVE> hat eine eigene Navigationsseite, ist in den aktuellen PBXB64-Forth-Nachweisen aber nicht als erfolgreiches Compile-/Run-Beispiel zertifiziert. Verwenden Sie die benachbarten zertifizierten Forth-Seiten fuer funktionierende Beispiele und behandeln Sie diese Seite bis zu einem passenden Compile-/Run-Test als Syntax- und Kontextdokumentation.

Verwendung im Programm

Behandeln Sie CMOVE> als dokumentierte Wortform, auch wenn die Seite nur ein Navigationshinweis ist. Leiten Sie den aktuellen Runtime-Stil aus den benachbarten zertifizierten Seiten ab und ersetzen Sie den Platzhalter-Nachweis durch ein fokussiertes Compile-/Run-Beispiel, bevor Sie sich in einem echten Programm darauf verlassen.

Fehlerfaelle

Wenn die Seite noch nicht zertifiziert ist, besteht der wichtigste Fehler darin, die Syntax bereits als bewiesen anzunehmen. Verwenden Sie bis zu einem eigenen Compile-/Run-Beleg nur die benachbarten getesteten Seiten als Ausfuehrungsnachweis.

Referenzbeispiel

CREATE B 8 ALLOT S" "ab" B SWAP CMOVE> B C@ 55 - BYE

Pruefung

Referenzbeispiel: tests/forth/string_words.fth. Diese Seite dokumentiert das unterstuetzte Wort, ist aber nicht als zertifiziert markiert, weil genau dieses Beispiel nicht Teil des aktuellen sauberen Compile-/Run-Nachweises ist. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth CMOVE - Kopiert Bytes von einer niedrigeren Quelladresse in aufsteigender Richtung. Top Forth . - Gibt die oberste Integer-Zelle dezimal aus. →


Forth . - Gibt die oberste Integer-Zelle dezimal aus. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth . - Gibt die oberste Integer-Zelle dezimal aus.
Hilfe zum PBXB64-Compiler

Forth . - Gibt die oberste Integer-Zelle dezimal aus.

Gibt die oberste Integer-Zelle dezimal aus.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

.

Beschreibung

. hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie . im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

42 . 42 BYE

Pruefung

Abgedeckt durch tests/forth/core_stack_arith.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth CMOVE&gt; - Kopiert Bytes von einer hoeheren Quelladresse in absteigender Richtung. Top Forth ." - Kompiliert oder interpretiert eine Inline-String-Ausgabe. →


Forth ." - Kompiliert oder interpretiert eine Inline-String-Ausgabe. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth ." - Kompiliert oder interpretiert eine Inline-String-Ausgabe.
Hilfe zum PBXB64-Compiler

Forth ." - Kompiliert oder interpretiert eine Inline-String-Ausgabe.

Kompiliert oder interpretiert eine Inline-String-Ausgabe.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

."

Beschreibung

." hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie ." im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

." "ok" 42 BYE

Pruefung

Abgedeckt durch tests/forth/help_dot_quote.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth EMIT - Schreibt das Low-Byte der obersten Zelle als ein Zeichen. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth EMIT - Schreibt das Low-Byte der obersten Zelle als ein Zeichen.
Hilfe zum PBXB64-Compiler

Forth EMIT - Schreibt das Low-Byte der obersten Zelle als ein Zeichen.

Schreibt das Low-Byte der obersten Zelle als ein Zeichen.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

EMIT

Beschreibung

EMIT hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie EMIT im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

65 EMIT 42 BYE

Pruefung

Abgedeckt durch tests/forth/help_string_console.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth CR - Schreibt einen Zeilenumbruch nach stdout. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth CR - Schreibt einen Zeilenumbruch nach stdout.
Hilfe zum PBXB64-Compiler

Forth CR - Schreibt einen Zeilenumbruch nach stdout.

Schreibt einen Zeilenumbruch nach stdout.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

CR

Beschreibung

CR hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie CR im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

CR 42 BYE

Pruefung

Abgedeckt durch tests/forth/help_string_console.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth EMIT - Schreibt das Low-Byte der obersten Zelle als ein Zeichen. Top Forth KEY - Liest ein Byte von stdin und legt seinen Zeichencode auf den Stack. →


Forth KEY - Liest ein Byte von stdin und legt seinen Zeichencode auf den Stack. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth KEY - Liest ein Byte von stdin und legt seinen Zeichencode auf den Stack.
Hilfe zum PBXB64-Compiler

Forth KEY - Liest ein Byte von stdin und legt seinen Zeichencode auf den Stack.

Liest ein Byte von stdin und legt seinen Zeichencode auf den Stack.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: BEGRENZT / NICHT ZERTIFIZIERT

PBXB64 Certification: [DOCUMENTED]

Syntax

KEY

Beschreibung

KEY hat eine eigene Navigationsseite, ist in den aktuellen PBXB64-Forth-Nachweisen aber nicht als erfolgreiches Compile-/Run-Beispiel zertifiziert. Verwenden Sie die benachbarten zertifizierten Forth-Seiten fuer funktionierende Beispiele und behandeln Sie diese Seite bis zu einem passenden Compile-/Run-Test als Syntax- und Kontextdokumentation.

Verwendung im Programm

Behandeln Sie KEY als dokumentierte Wortform, auch wenn die Seite nur ein Navigationshinweis ist. Leiten Sie den aktuellen Runtime-Stil aus den benachbarten zertifizierten Seiten ab und ersetzen Sie den Platzhalter-Nachweis durch ein fokussiertes Compile-/Run-Beispiel, bevor Sie sich in einem echten Programm darauf verlassen.

Fehlerfaelle

Wenn die Seite noch nicht zertifiziert ist, besteht der wichtigste Fehler darin, die Syntax bereits als bewiesen anzunehmen. Verwenden Sie bis zu einem eigenen Compile-/Run-Beleg nur die benachbarten getesteten Seiten als Ausfuehrungsnachweis.

Referenzbeispiel

KEY BYE

Pruefung

Referenzbeispiel: tests/forth/accept_line.fth. Diese Seite dokumentiert das unterstuetzte Wort, ist aber nicht als zertifiziert markiert, weil genau dieses Beispiel nicht Teil des aktuellen sauberen Compile-/Run-Nachweises ist. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth PARSE - Parst Text bis zu einem Trennzeichen und gibt Adresse plus Laenge zurueck. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth PARSE - Parst Text bis zu einem Trennzeichen und gibt Adresse plus Laenge zurueck.
Hilfe zum PBXB64-Compiler

Forth PARSE - Parst Text bis zu einem Trennzeichen und gibt Adresse plus Laenge zurueck.

Parst Text bis zu einem Trennzeichen und gibt Adresse plus Laenge zurueck.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PARSE

Beschreibung

PARSE hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie PARSE im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

CHAR , PARSE abc, DROP DROP 42 BYE

Pruefung

Abgedeckt durch tests/forth/help_parse_word_count.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth KEY - Liest ein Byte von stdin und legt seinen Zeichencode auf den Stack. Top Forth WORD - Parst das naechste durch Trennzeichen begrenzte Token als Counted String. →


Forth WORD - Parst das naechste durch Trennzeichen begrenzte Token als Counted String. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth WORD - Parst das naechste durch Trennzeichen begrenzte Token als Counted String.
Hilfe zum PBXB64-Compiler

Forth WORD - Parst das naechste durch Trennzeichen begrenzte Token als Counted String.

Parst das naechste durch Trennzeichen begrenzte Token als Counted String.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

WORD

Beschreibung

WORD hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie WORD im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

CHAR , WORD ,,abc, DROP 42 BYE

Pruefung

Abgedeckt durch tests/forth/help_parse_word_count.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth-Kontrollfluss - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth Control Flow

Forth-Kontrollfluss

Kind: Reference hub | Category: Forth Frontend

PBXB64 Status: Overview / navigation; child pages carry the word-specific support proof.

Beschreibung

Diese Seite ist ein Ueberblickskapitel. Die einzelnen Forth-Woerter und Direktiven stehen darunter jeweils auf eigenen, getesteten Referenzseiten.

Dieses Kapitel beschreibt die Gruppierung der Forth-Woerter, nicht eine pauschale Zusage voller ANS-Forth-Kompatibilitaet. Verwenden Sie die verlinkten Einzelseiten fuer Syntax, Stack-Effekt, Beispielcode, Validierungsdatei und bekannte Grenzen des aktuell getesteten PBXB64-Frontends.

Syntax

: WORD ( stack -- stack ) ... ;

Einzelseiten

  • IF
  • ELSE
  • THEN
  • CASE
  • OF
  • ENDOF
  • ENDCASE
  • EXIT

Pruefung

Die darunterliegenden Seiten nennen konkrete Forth- oder eingebettete PB-Beispiele. Neue Forth-Hilfeintraege sollen nur mit compile/link/run-Beleg ergaenzt werden.

Validation evidence: Forth command pages cite registered standalone tests/forth files or embedded PB examples.

Beispiel

: DOUBLE 2 * ;
21 DOUBLE .

Siehe auch

  • Forth Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth WORD - Parst das naechste durch Trennzeichen begrenzte Token als Counted String. Top Forth IF - Startet bedingte Ausfuehrung, wenn der Flag wahr ist. →


Forth IF - Startet bedingte Ausfuehrung, wenn der Flag wahr ist. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth IF - Startet bedingte Ausfuehrung, wenn der Flag wahr ist.
Hilfe zum PBXB64-Compiler

Forth IF - Startet bedingte Ausfuehrung, wenn der Flag wahr ist.

Startet bedingte Ausfuehrung, wenn der Flag wahr ist.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

IF

Beschreibung

IF hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie IF im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

1 IF 42 ELSE 1 THEN BYE

Pruefung

Abgedeckt durch tests/forth/if_else_true.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth ELSE - Startet den False-Zweig eines IF-Blocks. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth ELSE - Startet den False-Zweig eines IF-Blocks.
Hilfe zum PBXB64-Compiler

Forth ELSE - Startet den False-Zweig eines IF-Blocks.

Startet den False-Zweig eines IF-Blocks.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

ELSE

Beschreibung

ELSE hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie ELSE im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

0 IF 1 ELSE 42 THEN BYE

Pruefung

Abgedeckt durch tests/forth/if_else_false.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth THEN - Beendet einen IF- oder IF/ELSE-Block. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth THEN - Beendet einen IF- oder IF/ELSE-Block.
Hilfe zum PBXB64-Compiler

Forth THEN - Beendet einen IF- oder IF/ELSE-Block.

Beendet einen IF- oder IF/ELSE-Block.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

THEN

Beschreibung

THEN hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie THEN im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

1 IF 42 THEN BYE

Pruefung

Abgedeckt durch tests/forth/if_no_else.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth CASE - Startet eine stack-erhaltende Mehrfachverzweigung ueber einen Selektorwert. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth CASE - Startet eine stack-erhaltende Mehrfachverzweigung ueber einen Selektorwert.
Hilfe zum PBXB64-Compiler

Forth CASE - Startet eine stack-erhaltende Mehrfachverzweigung ueber einen Selektorwert.

Startet eine stack-erhaltende Mehrfachverzweigung ueber einen Selektorwert.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

CASE

Beschreibung

CASE hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie CASE im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

: PICK DUP CASE 1 OF DROP 10 ENDOF 2 OF DROP 20 ENDOF DROP 30 ENDCASE ; 3 PICK 12 + BYE

Pruefung

Abgedeckt durch tests/forth/help_case_control.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth OF - Vergleicht den CASE-Selektor mit dem aktuellen Vergleichswert. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth OF - Vergleicht den CASE-Selektor mit dem aktuellen Vergleichswert.
Hilfe zum PBXB64-Compiler

Forth OF - Vergleicht den CASE-Selektor mit dem aktuellen Vergleichswert.

Vergleicht den CASE-Selektor mit dem aktuellen Vergleichswert.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

OF

Beschreibung

OF hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie OF im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

: PICK DUP CASE 1 OF DROP 10 ENDOF 2 OF DROP 20 ENDOF DROP 30 ENDCASE ; 3 PICK 12 + BYE

Pruefung

Abgedeckt durch tests/forth/help_case_control.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth CASE - Startet eine stack-erhaltende Mehrfachverzweigung ueber einen Selektorwert. Top Forth ENDOF - Schliesst einen CASE-Zweig und setzt mit dem naechsten Test fort. →


Forth ENDOF - Schliesst einen CASE-Zweig und setzt mit dem naechsten Test fort. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth ENDOF - Schliesst einen CASE-Zweig und setzt mit dem naechsten Test fort.
Hilfe zum PBXB64-Compiler

Forth ENDOF - Schliesst einen CASE-Zweig und setzt mit dem naechsten Test fort.

Schliesst einen CASE-Zweig und setzt mit dem naechsten Test fort.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

ENDOF

Beschreibung

ENDOF hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie ENDOF im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

: PICK DUP CASE 1 OF DROP 10 ENDOF 2 OF DROP 20 ENDOF DROP 30 ENDCASE ; 3 PICK 12 + BYE

Pruefung

Abgedeckt durch tests/forth/help_case_control.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth OF - Vergleicht den CASE-Selektor mit dem aktuellen Vergleichswert. Top Forth ENDCASE - Beendet einen CASE-Block und stellt das zusammengefuehrte Stack-Ergebnis wieder her. →


Forth ENDCASE - Beendet einen CASE-Block und stellt das zusammengefuehrte Stack-Ergebnis wieder her. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth ENDCASE - Beendet einen CASE-Block und stellt das zusammengefuehrte Stack-Ergebnis wieder her.
Hilfe zum PBXB64-Compiler

Forth ENDCASE - Beendet einen CASE-Block und stellt das zusammengefuehrte Stack-Ergebnis wieder her.

Beendet einen CASE-Block und stellt das zusammengefuehrte Stack-Ergebnis wieder her.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

ENDCASE

Beschreibung

ENDCASE hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie ENDCASE im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

: PICK DUP CASE 1 OF DROP 10 ENDOF 2 OF DROP 20 ENDOF DROP 30 ENDCASE ; 3 PICK 12 + BYE

Pruefung

Abgedeckt durch tests/forth/help_case_control.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth ENDOF - Schliesst einen CASE-Zweig und setzt mit dem naechsten Test fort. Top Forth EXIT - Verlaesst eine Colon-Definition frueh, einschliesslich der getesteten Faelle mit strukturiertem Kontrollfluss. →


Forth EXIT - Verlaesst eine Colon-Definition frueh, einschliesslich der getesteten Faelle mit strukturiertem Kontrollfluss. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth EXIT - Verlaesst eine Colon-Definition frueh, einschliesslich der getesteten Faelle mit strukturiertem Kontrollfluss.
Hilfe zum PBXB64-Compiler

Forth EXIT - Verlaesst eine Colon-Definition frueh, einschliesslich der getesteten Faelle mit strukturiertem Kontrollfluss.

Verlaesst eine Colon-Definition frueh, einschliesslich der getesteten Faelle mit strukturiertem Kontrollfluss.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

EXIT

Beschreibung

EXIT hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie EXIT im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

: F FLAG @ IF 42 EXIT THEN 1 ;

Pruefung

Abgedeckt durch tests/forth/exit_inside_if.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth-Schleifen - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth Loops

Forth-Schleifen

Kind: Reference hub | Category: Forth Frontend

PBXB64 Status: Overview / navigation; child pages carry the word-specific support proof.

Beschreibung

Diese Seite ist ein Ueberblickskapitel. Die einzelnen Forth-Woerter und Direktiven stehen darunter jeweils auf eigenen, getesteten Referenzseiten.

Dieses Kapitel beschreibt die Gruppierung der Forth-Woerter, nicht eine pauschale Zusage voller ANS-Forth-Kompatibilitaet. Verwenden Sie die verlinkten Einzelseiten fuer Syntax, Stack-Effekt, Beispielcode, Validierungsdatei und bekannte Grenzen des aktuell getesteten PBXB64-Frontends.

Syntax

: WORD ( stack -- stack ) ... ;

Einzelseiten

  • BEGIN
  • UNTIL
  • AGAIN
  • WHILE
  • REPEAT
  • DO
  • LOOP
  • I
  • J
  • +LOOP
  • LEAVE
  • UNLOOP

Pruefung

Die darunterliegenden Seiten nennen konkrete Forth- oder eingebettete PB-Beispiele. Neue Forth-Hilfeintraege sollen nur mit compile/link/run-Beleg ergaenzt werden.

Validation evidence: Forth command pages cite registered standalone tests/forth files or embedded PB examples.

Beispiel

: DOUBLE 2 * ;
21 DOUBLE .

Siehe auch

  • Forth Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth EXIT - Verlaesst eine Colon-Definition frueh, einschliesslich der getesteten Faelle mit strukturiertem Kontrollfluss. Top Forth BEGIN - Startet einen strukturierten Schleifenbereich. →


Forth BEGIN - Startet einen strukturierten Schleifenbereich. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth BEGIN - Startet einen strukturierten Schleifenbereich.
Hilfe zum PBXB64-Compiler

Forth BEGIN - Startet einen strukturierten Schleifenbereich.

Startet einen strukturierten Schleifenbereich.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

BEGIN

Beschreibung

BEGIN hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie BEGIN im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

0 BEGIN 1 + DUP 5 = UNTIL BYE

Pruefung

Abgedeckt durch tests/forth/begin_until_counter.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth UNTIL - Beendet eine BEGIN-Schleife, wenn der Flag wahr ist. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth UNTIL - Beendet eine BEGIN-Schleife, wenn der Flag wahr ist.
Hilfe zum PBXB64-Compiler

Forth UNTIL - Beendet eine BEGIN-Schleife, wenn der Flag wahr ist.

Beendet eine BEGIN-Schleife, wenn der Flag wahr ist.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

UNTIL

Beschreibung

UNTIL hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie UNTIL im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

0 BEGIN 1 + DUP 5 = UNTIL BYE

Pruefung

Abgedeckt durch tests/forth/begin_until_counter.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth AGAIN - Wiederholt eine BEGIN-Schleife bedingungslos. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth AGAIN - Wiederholt eine BEGIN-Schleife bedingungslos.
Hilfe zum PBXB64-Compiler

Forth AGAIN - Wiederholt eine BEGIN-Schleife bedingungslos.

Wiederholt eine BEGIN-Schleife bedingungslos.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

AGAIN

Beschreibung

AGAIN hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie AGAIN im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

BEGIN 42 BYE AGAIN

Pruefung

Abgedeckt durch tests/forth/begin_again_bye.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth WHILE - Setzt eine BEGIN-Schleife fort, solange der Flag wahr ist. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth WHILE - Setzt eine BEGIN-Schleife fort, solange der Flag wahr ist.
Hilfe zum PBXB64-Compiler

Forth WHILE - Setzt eine BEGIN-Schleife fort, solange der Flag wahr ist.

Setzt eine BEGIN-Schleife fort, solange der Flag wahr ist.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

WHILE

Beschreibung

WHILE hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie WHILE im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

0 BEGIN DUP 5 < WHILE 1 + REPEAT BYE

Pruefung

Abgedeckt durch tests/forth/begin_while_repeat_counter.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth REPEAT - Schliesst eine BEGIN/WHILE-Schleife und springt zurueck. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth REPEAT - Schliesst eine BEGIN/WHILE-Schleife und springt zurueck.
Hilfe zum PBXB64-Compiler

Forth REPEAT - Schliesst eine BEGIN/WHILE-Schleife und springt zurueck.

Schliesst eine BEGIN/WHILE-Schleife und springt zurueck.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

REPEAT

Beschreibung

REPEAT hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie REPEAT im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

0 BEGIN DUP 5 < WHILE 1 + REPEAT BYE

Pruefung

Abgedeckt durch tests/forth/begin_while_repeat_counter.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth DO - Startet eine gezaehlte Schleife. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth DO - Startet eine gezaehlte Schleife.
Hilfe zum PBXB64-Compiler

Forth DO - Startet eine gezaehlte Schleife.

Startet eine gezaehlte Schleife.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

DO

Beschreibung

DO hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie DO im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

0 5 0 DO I + LOOP BYE

Pruefung

Abgedeckt durch tests/forth/do_loop_sum.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth LOOP - Beendet eine gezaehlte Schleife mit Schrittweite eins. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth LOOP - Beendet eine gezaehlte Schleife mit Schrittweite eins.
Hilfe zum PBXB64-Compiler

Forth LOOP - Beendet eine gezaehlte Schleife mit Schrittweite eins.

Beendet eine gezaehlte Schleife mit Schrittweite eins.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

LOOP

Beschreibung

LOOP hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie LOOP im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

0 5 0 DO I + LOOP BYE

Pruefung

Abgedeckt durch tests/forth/do_loop_sum.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth I - Legt den aktuellen gezaehlten Schleifenindex auf den Stack. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth I - Legt den aktuellen gezaehlten Schleifenindex auf den Stack.
Hilfe zum PBXB64-Compiler

Forth I - Legt den aktuellen gezaehlten Schleifenindex auf den Stack.

Legt den aktuellen gezaehlten Schleifenindex auf den Stack.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

I

Beschreibung

I hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie I im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

0 5 0 DO I + LOOP BYE

Pruefung

Abgedeckt durch tests/forth/do_loop_sum.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth J - Legt den aeusseren gezaehlten Schleifenindex auf den Stack. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth J - Legt den aeusseren gezaehlten Schleifenindex auf den Stack.
Hilfe zum PBXB64-Compiler

Forth J - Legt den aeusseren gezaehlten Schleifenindex auf den Stack.

Legt den aeusseren gezaehlten Schleifenindex auf den Stack.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

J

Beschreibung

J hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie J im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

0 3 0 DO 3 0 DO J + LOOP LOOP BYE

Pruefung

Abgedeckt durch tests/forth/do_loop_j_nested.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth I - Legt den aktuellen gezaehlten Schleifenindex auf den Stack. Top Forth +LOOP - Beendet eine gezaehlte Schleife mit explizitem positivem oder negativem Literalschritt. →


Forth +LOOP - Beendet eine gezaehlte Schleife mit explizitem positivem oder negativem Literalschritt. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth +LOOP - Beendet eine gezaehlte Schleife mit explizitem positivem oder negativem Literalschritt.
Hilfe zum PBXB64-Compiler

Forth +LOOP - Beendet eine gezaehlte Schleife mit explizitem positivem oder negativem Literalschritt.

Beendet eine gezaehlte Schleife mit explizitem positivem oder negativem Literalschritt.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

+LOOP

Beschreibung

+LOOP hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie +LOOP im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

0 0 10 DO I + -2 +LOOP 12 + BYE

Pruefung

Abgedeckt durch tests/forth/plus_loop_negative.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth J - Legt den aeusseren gezaehlten Schleifenindex auf den Stack. Top Forth LEAVE - Verlaesst die naechste gezaehlte Schleife. PBXB64 testet geradliniges LEAVE sowie einfaches und verschachteltes durch IF gesteuertes LEAVE in gezaehlten Schleifen. →


Forth LEAVE - Verlaesst die naechste gezaehlte Schleife. PBXB64 testet geradliniges LEAVE sowie einfaches und verschachteltes durch IF gesteuertes LEAVE in gezaehlten Schleifen. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth LEAVE - Verlaesst die naechste gezaehlte Schleife. PBXB64 testet geradliniges LEAVE sowie einfaches und verschachteltes durch IF gesteuertes LEAVE in gezaehlten Schleifen.
Hilfe zum PBXB64-Compiler

Forth LEAVE - Verlaesst die naechste gezaehlte Schleife. PBXB64 testet geradliniges LEAVE sowie einfaches und verschachteltes durch IF gesteuertes LEAVE in gezaehlten Schleifen.

Verlaesst die naechste gezaehlte Schleife. PBXB64 testet geradliniges LEAVE sowie einfaches und verschachteltes durch IF gesteuertes LEAVE in gezaehlten Schleifen.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

LEAVE

Beschreibung

LEAVE hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie LEAVE im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

0 10 0 DO I 4 = IF I 4 = IF LEAVE THEN THEN I + LOOP 36 + BYE

Pruefung

Abgedeckt durch tests/forth/leave_nested_if_loop.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth +LOOP - Beendet eine gezaehlte Schleife mit explizitem positivem oder negativem Literalschritt. Top Forth UNLOOP - Bereinigt aktiven gezaehlten Schleifenzustand vor EXIT aus einer Colon-Definition oder vor einem getesteten LEAVE-Pfad. →


Forth UNLOOP - Bereinigt aktiven gezaehlten Schleifenzustand vor EXIT aus einer Colon-Definition oder vor einem getesteten LEAVE-Pfad. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth UNLOOP - Bereinigt aktiven gezaehlten Schleifenzustand vor EXIT aus einer Colon-Definition oder vor einem getesteten LEAVE-Pfad.
Hilfe zum PBXB64-Compiler

Forth UNLOOP - Bereinigt aktiven gezaehlten Schleifenzustand vor EXIT aus einer Colon-Definition oder vor einem getesteten LEAVE-Pfad.

Bereinigt aktiven gezaehlten Schleifenzustand vor EXIT aus einer Colon-Definition oder vor einem getesteten LEAVE-Pfad.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

UNLOOP

Beschreibung

UNLOOP hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie UNLOOP im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

42 10 0 DO I 4 = IF UNLOOP LEAVE THEN 99 DROP LOOP BYE

Pruefung

Abgedeckt durch tests/forth/unloop_leave_loop.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth LEAVE - Verlaesst die naechste gezaehlte Schleife. PBXB64 testet geradliniges LEAVE sowie einfaches und verschachteltes durch IF gesteuertes LEAVE in gezaehlten Schleifen. Top Forth Return Stack and Runtime →


Forth-Return-Stack und Runtime - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth Return Stack and Runtime

Forth-Return-Stack und Runtime

Kind: Reference hub | Category: Forth Frontend

PBXB64 Status: Overview / navigation; child pages carry the word-specific support proof.

Beschreibung

Diese Seite ist ein Ueberblickskapitel. Die einzelnen Forth-Woerter und Direktiven stehen darunter jeweils auf eigenen, getesteten Referenzseiten.

Dieses Kapitel beschreibt die Gruppierung der Forth-Woerter, nicht eine pauschale Zusage voller ANS-Forth-Kompatibilitaet. Verwenden Sie die verlinkten Einzelseiten fuer Syntax, Stack-Effekt, Beispielcode, Validierungsdatei und bekannte Grenzen des aktuell getesteten PBXB64-Frontends.

Syntax

: WORD ( stack -- stack ) ... ;

Einzelseiten

  • >R
  • R>
  • R@
  • SP@
  • SP!
  • DEPTH
  • SOURCE
  • MS

Pruefung

Die darunterliegenden Seiten nennen konkrete Forth- oder eingebettete PB-Beispiele. Neue Forth-Hilfeintraege sollen nur mit compile/link/run-Beleg ergaenzt werden.

Validation evidence: Forth command pages cite registered standalone tests/forth files or embedded PB examples.

Beispiel

: DOUBLE 2 * ;
21 DOUBLE .

Siehe auch

  • Forth Frontend
  • Language Frontends

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Zurueck zum Befehlsindex

← Forth UNLOOP - Bereinigt aktiven gezaehlten Schleifenzustand vor EXIT aus einer Colon-Definition oder vor einem getesteten LEAVE-Pfad. Top Forth &gt;R - Verschiebt die oberste Datenstack-Zelle auf den Return-Stack. →


Forth >R - Verschiebt die oberste Datenstack-Zelle auf den Return-Stack. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth &gt;R - Verschiebt die oberste Datenstack-Zelle auf den Return-Stack.
Hilfe zum PBXB64-Compiler

Forth >R - Verschiebt die oberste Datenstack-Zelle auf den Return-Stack.

Verschiebt die oberste Datenstack-Zelle auf den Return-Stack.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

>R

Beschreibung

>R hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie >R im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

42 >R R> BYE

Pruefung

Abgedeckt durch tests/forth/core_stack_arith.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth R> - Verschiebt die oberste Return-Stack-Zelle zurueck auf den Datenstack. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth R&gt; - Verschiebt die oberste Return-Stack-Zelle zurueck auf den Datenstack.
Hilfe zum PBXB64-Compiler

Forth R> - Verschiebt die oberste Return-Stack-Zelle zurueck auf den Datenstack.

Verschiebt die oberste Return-Stack-Zelle zurueck auf den Datenstack.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

R>

Beschreibung

R> hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie R> im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

42 >R R> BYE

Pruefung

Abgedeckt durch tests/forth/core_stack_arith.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth &gt;R - Verschiebt die oberste Datenstack-Zelle auf den Return-Stack. Top Forth R@ - Kopiert die oberste Return-Stack-Zelle auf den Datenstack. →


Forth R@ - Kopiert die oberste Return-Stack-Zelle auf den Datenstack. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth R@ - Kopiert die oberste Return-Stack-Zelle auf den Datenstack.
Hilfe zum PBXB64-Compiler

Forth R@ - Kopiert die oberste Return-Stack-Zelle auf den Datenstack.

Kopiert die oberste Return-Stack-Zelle auf den Datenstack.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

R@

Beschreibung

R@ hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie R@ im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

42 >R R@ R> DROP BYE

Pruefung

Abgedeckt durch tests/forth/core_stack_arith.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth R&gt; - Verschiebt die oberste Return-Stack-Zelle zurueck auf den Datenstack. Top Forth SP@ - Legt den aktuellen Datenstack-Zeigerwert auf den Stack. →


Forth SP@ - Legt den aktuellen Datenstack-Zeigerwert auf den Stack. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth SP@ - Legt den aktuellen Datenstack-Zeigerwert auf den Stack.
Hilfe zum PBXB64-Compiler

Forth SP@ - Legt den aktuellen Datenstack-Zeigerwert auf den Stack.

Legt den aktuellen Datenstack-Zeigerwert auf den Stack.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

SP@

Beschreibung

SP@ hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie SP@ im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

SP@ DROP 42 BYE

Pruefung

Abgedeckt durch tests/forth/runtime_stack_depth.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth R@ - Kopiert die oberste Return-Stack-Zelle auf den Datenstack. Top Forth SP! - Stellt den Datenstack-Zeiger aus der obersten Zelle wieder her. →


Forth SP! - Stellt den Datenstack-Zeiger aus der obersten Zelle wieder her. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth SP! - Stellt den Datenstack-Zeiger aus der obersten Zelle wieder her.
Hilfe zum PBXB64-Compiler

Forth SP! - Stellt den Datenstack-Zeiger aus der obersten Zelle wieder her.

Stellt den Datenstack-Zeiger aus der obersten Zelle wieder her.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

SP!

Beschreibung

SP! hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie SP! im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

SP@ 1 2 SP! 42 BYE

Pruefung

Abgedeckt durch tests/forth/runtime_stack_depth.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth DEPTH - Legt die aktuelle Datenstack-Tiefe auf den Stack. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth DEPTH - Legt die aktuelle Datenstack-Tiefe auf den Stack.
Hilfe zum PBXB64-Compiler

Forth DEPTH - Legt die aktuelle Datenstack-Tiefe auf den Stack.

Legt die aktuelle Datenstack-Tiefe auf den Stack.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

DEPTH

Beschreibung

DEPTH hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie DEPTH im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

40 2 DEPTH 2 - + + BYE

Pruefung

Abgedeckt durch tests/forth/runtime_stack_depth.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth SP! - Stellt den Datenstack-Zeiger aus der obersten Zelle wieder her. Top Forth SOURCE - Legt Adresse und Laenge des aktuellen Quellpuffers auf den Stack. →


Forth SOURCE - Legt Adresse und Laenge des aktuellen Quellpuffers auf den Stack. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth SOURCE - Legt Adresse und Laenge des aktuellen Quellpuffers auf den Stack.
Hilfe zum PBXB64-Compiler

Forth SOURCE - Legt Adresse und Laenge des aktuellen Quellpuffers auf den Stack.

Legt Adresse und Laenge des aktuellen Quellpuffers auf den Stack.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

SOURCE

Beschreibung

SOURCE hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie SOURCE im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

SOURCE SWAP DROP 0> 41 + BYE

Pruefung

Abgedeckt durch tests/forth/source_length.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth MS - Wartet die angegebene Anzahl Millisekunden. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth MS - Wartet die angegebene Anzahl Millisekunden.
Hilfe zum PBXB64-Compiler

Forth MS - Wartet die angegebene Anzahl Millisekunden.

Wartet die angegebene Anzahl Millisekunden.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

MS

Beschreibung

MS hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie MS im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

0 MS 42 BYE

Pruefung

Abgedeckt durch tests/forth/core_bye.fth. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Eingebettetes Forth in BASIC - PBXB64 Forth Help

Startseite › BASIC Frontend › Embedded Forth in BASIC

Eingebettetes Forth in BASIC

Kind: Reference hub | Category: Forth Frontend

PBXB64 Status: Overview / navigation; child pages carry the word-specific support proof.

Beschreibung

Diese Seite ist ein Ueberblickskapitel. Die einzelnen Forth-Woerter und Direktiven stehen darunter jeweils auf eigenen, getesteten Referenzseiten.

Dieses Kapitel beschreibt die Gruppierung der Forth-Woerter, nicht eine pauschale Zusage voller ANS-Forth-Kompatibilitaet. Verwenden Sie die verlinkten Einzelseiten fuer Syntax, Stack-Effekt, Beispielcode, Validierungsdatei und bekannte Grenzen des aktuell getesteten PBXB64-Frontends.

Syntax

: WORD ( stack -- stack ) ... ;

Einzelseiten

  • #FORTH
  • #ENDFORTH
  • PBVAR
  • PBVAL
  • PBSET

Pruefung

Die darunterliegenden Seiten nennen konkrete Forth- oder eingebettete PB-Beispiele. Neue Forth-Hilfeintraege sollen nur mit compile/link/run-Beleg ergaenzt werden.

Validation evidence: Forth command pages cite registered standalone tests/forth files or embedded PB examples.

Beispiel

: DOUBLE 2 * ;
21 DOUBLE .

Siehe auch

  • Forth Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


Forth #FORTH - Startet einen eingebetteten Forth-Block in PB-Quelltext. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth #FORTH - Startet einen eingebetteten Forth-Block in PB-Quelltext.
Hilfe zum PBXB64-Compiler

Forth #FORTH - Startet einen eingebetteten Forth-Block in PB-Quelltext.

Startet einen eingebetteten Forth-Block in PB-Quelltext.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

#FORTH

Beschreibung

#FORTH hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie #FORTH im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

#FORTH
42
#ENDFORTH

Pruefung

Abgedeckt durch tests/forth/embedded_numeric.pb. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.

Zurueck zum Befehlsindex


Forth #ENDFORTH - Beendet einen eingebetteten Forth-Block in PB-Quelltext. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth #ENDFORTH - Beendet einen eingebetteten Forth-Block in PB-Quelltext.
Hilfe zum PBXB64-Compiler

Forth #ENDFORTH - Beendet einen eingebetteten Forth-Block in PB-Quelltext.

Beendet einen eingebetteten Forth-Block in PB-Quelltext.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

#ENDFORTH

Beschreibung

#ENDFORTH hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie #ENDFORTH im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

#FORTH
42
#ENDFORTH

Pruefung

Abgedeckt durch tests/forth/embedded_numeric.pb. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.

Zurueck zum Befehlsindex

← Forth #FORTH - Startet einen eingebetteten Forth-Block in PB-Quelltext. Top Forth PBVAR - Bindet eine numerische PB-Lokalvariable fuer eingebetteten Forth-Zugriff. →


Forth PBVAR - Bindet eine numerische PB-Lokalvariable fuer eingebetteten Forth-Zugriff. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth PBVAR - Bindet eine numerische PB-Lokalvariable fuer eingebetteten Forth-Zugriff.
Hilfe zum PBXB64-Compiler

Forth PBVAR - Bindet eine numerische PB-Lokalvariable fuer eingebetteten Forth-Zugriff.

Bindet eine numerische PB-Lokalvariable fuer eingebetteten Forth-Zugriff.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBVAR

Beschreibung

PBVAR hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie PBVAR im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

#FORTH
PBVAR N
#ENDFORTH

Pruefung

Abgedeckt durch tests/forth/embedded_numeric.pb. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth #ENDFORTH - Beendet einen eingebetteten Forth-Block in PB-Quelltext. Top Forth PBVAL - Liest eine gebundene PB-Lokalvariable in eingebettetem Forth. →


Forth PBVAL - Liest eine gebundene PB-Lokalvariable in eingebettetem Forth. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth PBVAL - Liest eine gebundene PB-Lokalvariable in eingebettetem Forth.
Hilfe zum PBXB64-Compiler

Forth PBVAL - Liest eine gebundene PB-Lokalvariable in eingebettetem Forth.

Liest eine gebundene PB-Lokalvariable in eingebettetem Forth.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBVAL

Beschreibung

PBVAL hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie PBVAL im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

#FORTH
PBVAR N
PBVAL N
#ENDFORTH

Pruefung

Abgedeckt durch tests/forth/embedded_numeric.pb. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex

← Forth PBVAR - Bindet eine numerische PB-Lokalvariable fuer eingebetteten Forth-Zugriff. Top Forth PBSET - Schreibt eine gebundene PB-Lokalvariable aus eingebettetem Forth. →


Forth PBSET - Schreibt eine gebundene PB-Lokalvariable aus eingebettetem Forth. - PBXB64 Forth Help

Startseite › BASIC Frontend › Forth PBSET - Schreibt eine gebundene PB-Lokalvariable aus eingebettetem Forth.
Hilfe zum PBXB64-Compiler

Forth PBSET - Schreibt eine gebundene PB-Lokalvariable aus eingebettetem Forth.

Schreibt eine gebundene PB-Lokalvariable aus eingebettetem Forth.

Kind: Forth-Wort/Direktive | Category: Forth-Frontend

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

PBSET

Beschreibung

PBSET hat eine eigene Seite, weil jeder getestete Forth-Befehl und jede PBXB64-Forth-Direktive einen eigenen Referenzeintrag haben muss. Eigenstaendige Dateien verwenden .fth, .forth oder .4th; eingebettete PB-Bloecke verwenden #FORTH und #ENDFORTH. Das Frontend senkt das unterstuetzte Integer-Stack-Verhalten direkt in PBXB64-IR ab. Die Beispiele sind bewusst konkret: Jede Seite nennt den fokussierten Test, der das dokumentierte Verhalten belegt, statt volle ANS-Abdeckung zu behaupten.

Verwendung im Programm

Verwenden Sie PBSET im normalen Forth-Quelltext, wenn das aktuelle Programm den auf dieser Seite gezeigten exakten Stack-Effekt benoetigt. Halten Sie den umgebenden Code klein, damit die Testdatei den Befehl isoliert belegen kann, und halten Sie das genannte Beispiel moeglichst nah an der dokumentierten Form.

Fehlerfaelle

Die meisten Fehler entstehen durch die falsche Stack-Form, den falschen Ausfuehrungszustand oder ein Wort aus einer anderen Forth-Teilmenge als der auf dieser Seite dokumentierten. Wenn der Aufrufer ein fehlendes ANS-Wort, einen Floating-Point-Helfer oder ein Dateiwort braucht, darf er nicht erwarten, dass das Beispiel dieser Seite dieses Verhalten abdeckt.

Verifiziertes Beispiel

#FORTH
PBVAR N
42 PBSET N
#ENDFORTH

Pruefung

Abgedeckt durch tests/forth/embedded_numeric.pb. Das referenzierte Beispiel wurde bei der Hilfepruefung direkt mit dem aktuellen PBXB64-Compiler kompiliert und ausgefuehrt. Eigenstaendige Beispiele mit PBXB64 sample.fth -o sample.exe kompilieren und die EXE ausfuehren, um Exitcode oder Ausgabe zu pruefen.

Grenzen

Nicht unterstuetzte ANS/Forth-Woerter muessen mit Diagnose fehlschlagen und duerfen nicht als abgeschlossen dokumentiert werden. Vollstaendige Forth-2012-Konformitaet, Dateiwoerter, Floating Point, Locals, Exceptions, Search Order und erweiterte Defining-Word-Semantik liegen ausserhalb dieser Seite, sofern spaetere getestete Seiten den Anspruch nicht erweitern.

Siehe auch

  • Forth Frontend
  • Language Frontends
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


LOGO-Frontend - PBXB64 Help

Startseite › BASIC Frontend › LOGO Frontend

LOGO-Frontend

PBXB64 enthaelt ein natives LOGO-Frontend fuer Turtle-Grafik, Variablen, Prozeduren, Kontrollfluss, numerische Ausdruecke und Listenhelfer. Dieser Abschnitt ist eine Uebersicht; jede verlinkte Befehlsseite zeigt die nutzbare Syntax und, soweit vorhanden, ein fokussiertes Beispiel.

Diese Seite dient zum Auffinden eines LOGO-Befehls nach Bereich. Die Unterseite enthaelt genaue Syntax, Verhalten, Grenzen und den Pfad zum getesteten Beispiel.

Turtle Motion

  • FD
  • BK
  • RT
  • LT
  • HOME
  • SETXY
  • SETPOS
  • SETH

Pen State

  • PU
  • PD
  • PENREVERSE
  • PENSIZE
  • SETPC

Screen State

  • SETBG
  • CS
  • CLEAN
  • SETSCRUNCH
  • HT
  • ST
  • TEXTSCREEN
  • FULLSCREEN
  • SPLITSCREEN

Drawing

  • FILL
  • LABEL

Console

  • PRINT
  • CT

Variables

  • MAKE
  • LOCAL
  • :name
  • "name

Procedures

  • TO
  • END
  • OUTPUT
  • STOP

Control Flow

  • IF
  • IFELSE
  • REPEAT
  • WHILE

Math

  • SUM
  • DIFFERENCE
  • PRODUCT
  • QUOTIENT
  • REMAINDER
  • GREATERP
  • LESSP
  • EQUALP
  • SIN
  • COS
  • SQRT
  • ABS
  • RANDOM
  • INT
  • ROUND
  • POWER

Lists

  • LIST
  • FIRST
  • LAST
  • BUTFIRST
  • BUTLAST
  • ITEM
  • FPUT
  • LPUT

Grenzen

Diese Seiten dokumentieren die implementierte PBXB64-Teilmenge, nicht vollstaendige UCBLogo-/MSWLogo-Kompatibilitaet.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO FD - Bewegt die Turtle vorwaerts - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Turtle Motion › LOGO FD - Bewegt die Turtle vorwaerts
Hilfe zum PBXB64-Compiler

LOGO FD - Bewegt die Turtle vorwaerts

Art: LOGO command/expression | Category: LOGO Frontend / Turtle Motion

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Bewegt die Turtle vorwaerts.

Syntax

FD

Beschreibung

FD ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Turtle Motion verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie FD, wenn das Programm eine explizite Turtle-Bewegung oder Richtungsaenderung benoetigt. Kombinieren Sie es mit Stiftzustandsbefehlen wie PU und PD, wenn Bewegung ohne Zeichnung oder mit sichtbarer Spur gewuenscht ist.

Fehlerfaelle

Falsche Koordinaten, ein fehlendes Ziel oder ein unerwarteter Stiftzustand zeigen sich meist als Zeichnung an der falschen Stelle statt als Compile-Fehler. Halten Sie das Beispiel deterministisch, damit jede sichtbare Abweichung vom erwarteten Pfad eindeutig ist.

Fokussiertes Beispiel

FD 100

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_fd_rt.lgo

FD 100
RT 90
FD 50

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO BK - Bewegt die Turtle rueckwaerts - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Turtle Motion › LOGO BK - Bewegt die Turtle rueckwaerts
Hilfe zum PBXB64-Compiler

LOGO BK - Bewegt die Turtle rueckwaerts

Art: LOGO command/expression | Category: LOGO Frontend / Turtle Motion

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Bewegt die Turtle rueckwaerts.

Syntax

BK

Beschreibung

BK ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Turtle Motion verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie BK, wenn das Programm eine explizite Turtle-Bewegung oder Richtungsaenderung benoetigt. Kombinieren Sie es mit Stiftzustandsbefehlen wie PU und PD, wenn Bewegung ohne Zeichnung oder mit sichtbarer Spur gewuenscht ist.

Fehlerfaelle

Falsche Koordinaten, ein fehlendes Ziel oder ein unerwarteter Stiftzustand zeigen sich meist als Zeichnung an der falschen Stelle statt als Compile-Fehler. Halten Sie das Beispiel deterministisch, damit jede sichtbare Abweichung vom erwarteten Pfad eindeutig ist.

Fokussiertes Beispiel

BK 50

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_ifelse.lgo

IFELSE 1 > 0 [FD 100] [BK 100]

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO RT - Dreht die Turtle nach rechts - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Turtle Motion › LOGO RT - Dreht die Turtle nach rechts
Hilfe zum PBXB64-Compiler

LOGO RT - Dreht die Turtle nach rechts

Art: LOGO command/expression | Category: LOGO Frontend / Turtle Motion

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Dreht die Turtle nach rechts.

Syntax

RT

Beschreibung

RT ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Turtle Motion verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie RT, wenn das Programm eine explizite Turtle-Bewegung oder Richtungsaenderung benoetigt. Kombinieren Sie es mit Stiftzustandsbefehlen wie PU und PD, wenn Bewegung ohne Zeichnung oder mit sichtbarer Spur gewuenscht ist.

Fehlerfaelle

Falsche Koordinaten, ein fehlendes Ziel oder ein unerwarteter Stiftzustand zeigen sich meist als Zeichnung an der falschen Stelle statt als Compile-Fehler. Halten Sie das Beispiel deterministisch, damit jede sichtbare Abweichung vom erwarteten Pfad eindeutig ist.

Fokussiertes Beispiel

RT 90

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_fd_rt.lgo

FD 100
RT 90
FD 50

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO LT - Dreht die Turtle nach links - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Turtle Motion › LOGO LT - Dreht die Turtle nach links
Hilfe zum PBXB64-Compiler

LOGO LT - Dreht die Turtle nach links

Art: LOGO command/expression | Category: LOGO Frontend / Turtle Motion

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Dreht die Turtle nach links.

Syntax

LT

Beschreibung

LT ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Turtle Motion verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie LT, wenn das Programm eine explizite Turtle-Bewegung oder Richtungsaenderung benoetigt. Kombinieren Sie es mit Stiftzustandsbefehlen wie PU und PD, wenn Bewegung ohne Zeichnung oder mit sichtbarer Spur gewuenscht ist.

Fehlerfaelle

Falsche Koordinaten, ein fehlendes Ziel oder ein unerwarteter Stiftzustand zeigen sich meist als Zeichnung an der falschen Stelle statt als Compile-Fehler. Halten Sie das Beispiel deterministisch, damit jede sichtbare Abweichung vom erwarteten Pfad eindeutig ist.

Fokussiertes Beispiel

LT 45

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_lt.lgo

LT 90
FD 20

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO HOME - Bewegt die Turtle zum Ursprung und setzt die Richtung zurueck - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Turtle Motion › LOGO HOME - Bewegt die Turtle zum Ursprung und setzt die Richtung zurueck
Hilfe zum PBXB64-Compiler

LOGO HOME - Bewegt die Turtle zum Ursprung und setzt die Richtung zurueck

Art: LOGO command/expression | Category: LOGO Frontend / Turtle Motion

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Bewegt die Turtle zum Ursprung und setzt die Richtung zurueck.

Syntax

HOME

Beschreibung

HOME ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Turtle Motion verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie HOME, wenn das Programm eine explizite Turtle-Bewegung oder Richtungsaenderung benoetigt. Kombinieren Sie es mit Stiftzustandsbefehlen wie PU und PD, wenn Bewegung ohne Zeichnung oder mit sichtbarer Spur gewuenscht ist.

Fehlerfaelle

Falsche Koordinaten, ein fehlendes Ziel oder ein unerwarteter Stiftzustand zeigen sich meist als Zeichnung an der falschen Stelle statt als Compile-Fehler. Halten Sie das Beispiel deterministisch, damit jede sichtbare Abweichung vom erwarteten Pfad eindeutig ist.

Fokussiertes Beispiel

HOME

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_cs_home.lgo

CS
HOME
FD 50

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO SETXY - Setzt die Turtle-Position aus zwei numerischen Ausdruecken - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Turtle Motion › LOGO SETXY - Setzt die Turtle-Position aus zwei numerischen Ausdruecken
Hilfe zum PBXB64-Compiler

LOGO SETXY - Setzt die Turtle-Position aus zwei numerischen Ausdruecken

Art: LOGO command/expression | Category: LOGO Frontend / Turtle Motion

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Setzt die Turtle-Position aus zwei numerischen Ausdruecken.

Syntax

SETXY

Beschreibung

SETXY ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Turtle Motion verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie SETXY, wenn das Programm eine explizite Turtle-Bewegung oder Richtungsaenderung benoetigt. Kombinieren Sie es mit Stiftzustandsbefehlen wie PU und PD, wenn Bewegung ohne Zeichnung oder mit sichtbarer Spur gewuenscht ist.

Fehlerfaelle

Falsche Koordinaten, ein fehlendes Ziel oder ein unerwarteter Stiftzustand zeigen sich meist als Zeichnung an der falschen Stelle statt als Compile-Fehler. Halten Sie das Beispiel deterministisch, damit jede sichtbare Abweichung vom erwarteten Pfad eindeutig ist.

Fokussiertes Beispiel

SETXY 10 20

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_turtle_state.lgo

SETXY 10 20
SETH 180
FD 5

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO SETPOS - Setzt die Turtle-Position aus einer Koordinatenliste - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Turtle Motion › LOGO SETPOS - Setzt die Turtle-Position aus einer Koordinatenliste
Hilfe zum PBXB64-Compiler

LOGO SETPOS - Setzt die Turtle-Position aus einer Koordinatenliste

Art: LOGO command/expression | Category: LOGO Frontend / Turtle Motion

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Setzt die Turtle-Position aus einer Koordinatenliste.

Syntax

SETPOS

Beschreibung

SETPOS ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Turtle Motion verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie SETPOS, wenn das Programm eine explizite Turtle-Bewegung oder Richtungsaenderung benoetigt. Kombinieren Sie es mit Stiftzustandsbefehlen wie PU und PD, wenn Bewegung ohne Zeichnung oder mit sichtbarer Spur gewuenscht ist.

Fehlerfaelle

Falsche Koordinaten, ein fehlendes Ziel oder ein unerwarteter Stiftzustand zeigen sich meist als Zeichnung an der falschen Stelle statt als Compile-Fehler. Halten Sie das Beispiel deterministisch, damit jede sichtbare Abweichung vom erwarteten Pfad eindeutig ist.

Fokussiertes Beispiel

SETPOS [10 20]

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_setpos.lgo

SETPOS [100 50]
FD 50

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO SETH - Setzt die Turtle-Richtung in Grad - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Turtle Motion › LOGO SETH - Setzt die Turtle-Richtung in Grad
Hilfe zum PBXB64-Compiler

LOGO SETH - Setzt die Turtle-Richtung in Grad

Art: LOGO command/expression | Category: LOGO Frontend / Turtle Motion

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Setzt die Turtle-Richtung in Grad.

Syntax

SETH

Beschreibung

SETH ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Turtle Motion verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie SETH, wenn das Programm eine explizite Turtle-Bewegung oder Richtungsaenderung benoetigt. Kombinieren Sie es mit Stiftzustandsbefehlen wie PU und PD, wenn Bewegung ohne Zeichnung oder mit sichtbarer Spur gewuenscht ist.

Fehlerfaelle

Falsche Koordinaten, ein fehlendes Ziel oder ein unerwarteter Stiftzustand zeigen sich meist als Zeichnung an der falschen Stelle statt als Compile-Fehler. Halten Sie das Beispiel deterministisch, damit jede sichtbare Abweichung vom erwarteten Pfad eindeutig ist.

Fokussiertes Beispiel

SETH 180

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_turtle_state.lgo

SETXY 10 20
SETH 180
FD 5

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO PU - Hebt den Stift, damit Bewegungen nicht zeichnen - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Pen State › LOGO PU - Hebt den Stift, damit Bewegungen nicht zeichnen
Hilfe zum PBXB64-Compiler

LOGO PU - Hebt den Stift, damit Bewegungen nicht zeichnen

Art: LOGO command/expression | Category: LOGO Frontend / Pen State

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Hebt den Stift, damit Bewegungen nicht zeichnen.

Syntax

PU

Beschreibung

PU ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Pen State verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie PU, um zu steuern, wie spaetere Turtle-Bewegungen gerendert werden. Diese Familie gehoert zum Zeichenvertrag, daher sollte das Beispiel die Zustandsaenderung zeigen, bevor ein weiterer Bewegungsbefehl die Wirkung belegt.

Fehlerfaelle

Wenn PU zum falschen Zeitpunkt benutzt wird, kann der naechste Zeichenbefehl korrekt aussehen, obwohl der Zustand intern noch falsch ist. Dokumentieren Sie die Zustandsaenderung explizit, damit der Aufrufer weiss, welcher spaetere Befehl davon abhaengt.

Fokussiertes Beispiel

PU
FD 20

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_pen.lgo

PU
FD 50
PD
FD 50

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO PD - Senkt den Stift, damit Bewegungen zeichnen - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Pen State › LOGO PD - Senkt den Stift, damit Bewegungen zeichnen
Hilfe zum PBXB64-Compiler

LOGO PD - Senkt den Stift, damit Bewegungen zeichnen

Art: LOGO command/expression | Category: LOGO Frontend / Pen State

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Senkt den Stift, damit Bewegungen zeichnen.

Syntax

PD

Beschreibung

PD ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Pen State verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie PD, um zu steuern, wie spaetere Turtle-Bewegungen gerendert werden. Diese Familie gehoert zum Zeichenvertrag, daher sollte das Beispiel die Zustandsaenderung zeigen, bevor ein weiterer Bewegungsbefehl die Wirkung belegt.

Fehlerfaelle

Wenn PD zum falschen Zeitpunkt benutzt wird, kann der naechste Zeichenbefehl korrekt aussehen, obwohl der Zustand intern noch falsch ist. Dokumentieren Sie die Zustandsaenderung explizit, damit der Aufrufer weiss, welcher spaetere Befehl davon abhaengt.

Fokussiertes Beispiel

PD
FD 20

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_pen.lgo

PU
FD 50
PD
FD 50

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO PENREVERSE - Schaltet den Stift in den Reverse/XOR-Zeichenmodus - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Pen State › LOGO PENREVERSE - Schaltet den Stift in den Reverse/XOR-Zeichenmodus
Hilfe zum PBXB64-Compiler

LOGO PENREVERSE - Schaltet den Stift in den Reverse/XOR-Zeichenmodus

Art: LOGO command/expression | Category: LOGO Frontend / Pen State

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Schaltet den Stift in den Reverse/XOR-Zeichenmodus.

Syntax

PENREVERSE

Beschreibung

PENREVERSE ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Pen State verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie PENREVERSE, um zu steuern, wie spaetere Turtle-Bewegungen gerendert werden. Diese Familie gehoert zum Zeichenvertrag, daher sollte das Beispiel die Zustandsaenderung zeigen, bevor ein weiterer Bewegungsbefehl die Wirkung belegt.

Fehlerfaelle

Wenn PENREVERSE zum falschen Zeitpunkt benutzt wird, kann der naechste Zeichenbefehl korrekt aussehen, obwohl der Zustand intern noch falsch ist. Dokumentieren Sie die Zustandsaenderung explizit, damit der Aufrufer weiss, welcher spaetere Befehl davon abhaengt.

Fokussiertes Beispiel

PENREVERSE
FD 40

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_pen_state.lgo

PENSIZE 2
PENREVERSE
FD 10
PD
FD 10

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO PENSIZE - Setzt die Stiftbreite der Turtle - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Pen State › LOGO PENSIZE - Setzt die Stiftbreite der Turtle
Hilfe zum PBXB64-Compiler

LOGO PENSIZE - Setzt die Stiftbreite der Turtle

Art: LOGO command/expression | Category: LOGO Frontend / Pen State

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Setzt die Stiftbreite der Turtle.

Syntax

PENSIZE

Beschreibung

PENSIZE ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Pen State verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie PENSIZE, um zu steuern, wie spaetere Turtle-Bewegungen gerendert werden. Diese Familie gehoert zum Zeichenvertrag, daher sollte das Beispiel die Zustandsaenderung zeigen, bevor ein weiterer Bewegungsbefehl die Wirkung belegt.

Fehlerfaelle

Wenn PENSIZE zum falschen Zeitpunkt benutzt wird, kann der naechste Zeichenbefehl korrekt aussehen, obwohl der Zustand intern noch falsch ist. Dokumentieren Sie die Zustandsaenderung explizit, damit der Aufrufer weiss, welcher spaetere Befehl davon abhaengt.

Fokussiertes Beispiel

PENSIZE 3

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_pen_state.lgo

PENSIZE 2
PENREVERSE
FD 10
PD
FD 10

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO SETPC - Setzt den Stiftfarbindex der Turtle - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Pen State › LOGO SETPC - Setzt den Stiftfarbindex der Turtle
Hilfe zum PBXB64-Compiler

LOGO SETPC - Setzt den Stiftfarbindex der Turtle

Art: LOGO command/expression | Category: LOGO Frontend / Pen State

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Setzt den Stiftfarbindex der Turtle.

Syntax

SETPC

Beschreibung

SETPC ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Pen State verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie SETPC, um zu steuern, wie spaetere Turtle-Bewegungen gerendert werden. Diese Familie gehoert zum Zeichenvertrag, daher sollte das Beispiel die Zustandsaenderung zeigen, bevor ein weiterer Bewegungsbefehl die Wirkung belegt.

Fehlerfaelle

Wenn SETPC zum falschen Zeitpunkt benutzt wird, kann der naechste Zeichenbefehl korrekt aussehen, obwohl der Zustand intern noch falsch ist. Dokumentieren Sie die Zustandsaenderung explizit, damit der Aufrufer weiss, welcher spaetere Befehl davon abhaengt.

Fokussiertes Beispiel

SETPC 12

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_color.lgo

SETPC 4
FD 100
SETPC 2
FD 100

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO SETBG - Setzt den Hintergrundfarbindex der Turtle - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Screen State › LOGO SETBG - Setzt den Hintergrundfarbindex der Turtle
Hilfe zum PBXB64-Compiler

LOGO SETBG - Setzt den Hintergrundfarbindex der Turtle

Art: LOGO command/expression | Category: LOGO Frontend / Screen State

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Setzt den Hintergrundfarbindex der Turtle.

Syntax

SETBG

Beschreibung

SETBG ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Screen State verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie SETBG, wenn das Programm den aktuellen Bildschirmmodus aendern oder die Zeichenflaeche leeren muss. Diese Seite ist richtig, wenn spaeterer Code darauf angewiesen ist, dass der Bildschirmzustand auf Text, Split, Vollbild oder einen bekannten Zeichenausgangszustand gesetzt wurde.

Fehlerfaelle

Wenn SETBG zum falschen Zeitpunkt benutzt wird, kann der naechste Zeichenbefehl korrekt aussehen, obwohl der Zustand intern noch falsch ist. Dokumentieren Sie die Zustandsaenderung explizit, damit der Aufrufer weiss, welcher spaetere Befehl davon abhaengt.

Fokussiertes Beispiel

SETBG 1

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_screen_state.lgo

SETBG 1
CLEAN
HT
ST
TEXTSCREEN
FULLSCREEN
SPLITSCREEN
FD 5

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO CS - Loescht den Bildschirm und kehrt nach Hause zurueck - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Screen State › LOGO CS - Loescht den Bildschirm und kehrt nach Hause zurueck
Hilfe zum PBXB64-Compiler

LOGO CS - Loescht den Bildschirm und kehrt nach Hause zurueck

Art: LOGO command/expression | Category: LOGO Frontend / Screen State

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Loescht den Bildschirm und kehrt nach Hause zurueck.

Syntax

CS

Beschreibung

CS ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Screen State verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie CS, wenn das Programm den aktuellen Bildschirmmodus aendern oder die Zeichenflaeche leeren muss. Diese Seite ist richtig, wenn spaeterer Code darauf angewiesen ist, dass der Bildschirmzustand auf Text, Split, Vollbild oder einen bekannten Zeichenausgangszustand gesetzt wurde.

Fehlerfaelle

Wenn CS zum falschen Zeitpunkt benutzt wird, kann der naechste Zeichenbefehl korrekt aussehen, obwohl der Zustand intern noch falsch ist. Dokumentieren Sie die Zustandsaenderung explizit, damit der Aufrufer weiss, welcher spaetere Befehl davon abhaengt.

Fokussiertes Beispiel

CS

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_cs_home.lgo

CS
HOME
FD 50

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO CLEAN - Loescht die Zeichenflaeche ohne den Turtle-Zustand zu aendern - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Screen State › LOGO CLEAN - Loescht die Zeichenflaeche ohne den Turtle-Zustand zu aendern
Hilfe zum PBXB64-Compiler

LOGO CLEAN - Loescht die Zeichenflaeche ohne den Turtle-Zustand zu aendern

Art: LOGO command/expression | Category: LOGO Frontend / Screen State

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Loescht die Zeichenflaeche ohne den Turtle-Zustand zu aendern.

Syntax

CLEAN

Beschreibung

CLEAN ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Screen State verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie CLEAN, wenn das Programm den aktuellen Bildschirmmodus aendern oder die Zeichenflaeche leeren muss. Diese Seite ist richtig, wenn spaeterer Code darauf angewiesen ist, dass der Bildschirmzustand auf Text, Split, Vollbild oder einen bekannten Zeichenausgangszustand gesetzt wurde.

Fehlerfaelle

Wenn CLEAN zum falschen Zeitpunkt benutzt wird, kann der naechste Zeichenbefehl korrekt aussehen, obwohl der Zustand intern noch falsch ist. Dokumentieren Sie die Zustandsaenderung explizit, damit der Aufrufer weiss, welcher spaetere Befehl davon abhaengt.

Fokussiertes Beispiel

CLEAN

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_screen_state.lgo

SETBG 1
CLEAN
HT
ST
TEXTSCREEN
FULLSCREEN
SPLITSCREEN
FD 5

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO SETSCRUNCH - Setzt den LOGO-Zeichenskalierungsfaktor - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Screen State › LOGO SETSCRUNCH - Setzt den LOGO-Zeichenskalierungsfaktor
Hilfe zum PBXB64-Compiler

LOGO SETSCRUNCH - Setzt den LOGO-Zeichenskalierungsfaktor

Art: LOGO command/expression | Category: LOGO Frontend / Screen State

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Setzt den LOGO-Zeichenskalierungsfaktor.

Syntax

SETSCRUNCH

Beschreibung

SETSCRUNCH ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Screen State verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie SETSCRUNCH, wenn das Programm den aktuellen Bildschirmmodus aendern oder die Zeichenflaeche leeren muss. Diese Seite ist richtig, wenn spaeterer Code darauf angewiesen ist, dass der Bildschirmzustand auf Text, Split, Vollbild oder einen bekannten Zeichenausgangszustand gesetzt wurde.

Fehlerfaelle

Wenn SETSCRUNCH zum falschen Zeitpunkt benutzt wird, kann der naechste Zeichenbefehl korrekt aussehen, obwohl der Zustand intern noch falsch ist. Dokumentieren Sie die Zustandsaenderung explizit, damit der Aufrufer weiss, welcher spaetere Befehl davon abhaengt.

Fokussiertes Beispiel

SETSCRUNCH 2

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_setscrunch.lgo

SETSCRUNCH 0.5
FD 100

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO HT - Versteckt die Turtle - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Screen State › LOGO HT - Versteckt die Turtle
Hilfe zum PBXB64-Compiler

LOGO HT - Versteckt die Turtle

Art: LOGO command/expression | Category: LOGO Frontend / Screen State

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Versteckt die Turtle.

Syntax

HT

Beschreibung

HT ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Screen State verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie HT, wenn das Programm den aktuellen Bildschirmmodus aendern oder die Zeichenflaeche leeren muss. Diese Seite ist richtig, wenn spaeterer Code darauf angewiesen ist, dass der Bildschirmzustand auf Text, Split, Vollbild oder einen bekannten Zeichenausgangszustand gesetzt wurde.

Fehlerfaelle

Wenn HT zum falschen Zeitpunkt benutzt wird, kann der naechste Zeichenbefehl korrekt aussehen, obwohl der Zustand intern noch falsch ist. Dokumentieren Sie die Zustandsaenderung explizit, damit der Aufrufer weiss, welcher spaetere Befehl davon abhaengt.

Fokussiertes Beispiel

HT

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_screen_state.lgo

SETBG 1
CLEAN
HT
ST
TEXTSCREEN
FULLSCREEN
SPLITSCREEN
FD 5

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO ST - Zeigt die Turtle - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Screen State › LOGO ST - Zeigt die Turtle
Hilfe zum PBXB64-Compiler

LOGO ST - Zeigt die Turtle

Art: LOGO command/expression | Category: LOGO Frontend / Screen State

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Zeigt die Turtle.

Syntax

ST

Beschreibung

ST ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Screen State verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie ST, wenn das Programm den aktuellen Bildschirmmodus aendern oder die Zeichenflaeche leeren muss. Diese Seite ist richtig, wenn spaeterer Code darauf angewiesen ist, dass der Bildschirmzustand auf Text, Split, Vollbild oder einen bekannten Zeichenausgangszustand gesetzt wurde.

Fehlerfaelle

Wenn ST zum falschen Zeitpunkt benutzt wird, kann der naechste Zeichenbefehl korrekt aussehen, obwohl der Zustand intern noch falsch ist. Dokumentieren Sie die Zustandsaenderung explizit, damit der Aufrufer weiss, welcher spaetere Befehl davon abhaengt.

Fokussiertes Beispiel

ST

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_screen_state.lgo

SETBG 1
CLEAN
HT
ST
TEXTSCREEN
FULLSCREEN
SPLITSCREEN
FD 5

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO TEXTSCREEN - Schaltet in den Textbildschirmmodus - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Screen State › LOGO TEXTSCREEN - Schaltet in den Textbildschirmmodus
Hilfe zum PBXB64-Compiler

LOGO TEXTSCREEN - Schaltet in den Textbildschirmmodus

Art: LOGO command/expression | Category: LOGO Frontend / Screen State

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Schaltet in den Textbildschirmmodus.

Syntax

TEXTSCREEN

Beschreibung

TEXTSCREEN ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Screen State verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie TEXTSCREEN, wenn das Programm den aktuellen Bildschirmmodus aendern oder die Zeichenflaeche leeren muss. Diese Seite ist richtig, wenn spaeterer Code darauf angewiesen ist, dass der Bildschirmzustand auf Text, Split, Vollbild oder einen bekannten Zeichenausgangszustand gesetzt wurde.

Fehlerfaelle

Wenn TEXTSCREEN zum falschen Zeitpunkt benutzt wird, kann der naechste Zeichenbefehl korrekt aussehen, obwohl der Zustand intern noch falsch ist. Dokumentieren Sie die Zustandsaenderung explizit, damit der Aufrufer weiss, welcher spaetere Befehl davon abhaengt.

Fokussiertes Beispiel

TEXTSCREEN

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_screen_state.lgo

SETBG 1
CLEAN
HT
ST
TEXTSCREEN
FULLSCREEN
SPLITSCREEN
FD 5

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO FULLSCREEN - Schaltet in den Vollbild-Grafikmodus - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Screen State › LOGO FULLSCREEN - Schaltet in den Vollbild-Grafikmodus
Hilfe zum PBXB64-Compiler

LOGO FULLSCREEN - Schaltet in den Vollbild-Grafikmodus

Art: LOGO command/expression | Category: LOGO Frontend / Screen State

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Schaltet in den Vollbild-Grafikmodus.

Syntax

FULLSCREEN

Beschreibung

FULLSCREEN ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Screen State verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie FULLSCREEN, wenn das Programm den aktuellen Bildschirmmodus aendern oder die Zeichenflaeche leeren muss. Diese Seite ist richtig, wenn spaeterer Code darauf angewiesen ist, dass der Bildschirmzustand auf Text, Split, Vollbild oder einen bekannten Zeichenausgangszustand gesetzt wurde.

Fehlerfaelle

Wenn FULLSCREEN zum falschen Zeitpunkt benutzt wird, kann der naechste Zeichenbefehl korrekt aussehen, obwohl der Zustand intern noch falsch ist. Dokumentieren Sie die Zustandsaenderung explizit, damit der Aufrufer weiss, welcher spaetere Befehl davon abhaengt.

Fokussiertes Beispiel

FULLSCREEN

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_screen_state.lgo

SETBG 1
CLEAN
HT
ST
TEXTSCREEN
FULLSCREEN
SPLITSCREEN
FD 5

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO SPLITSCREEN - Schaltet in den geteilten Text/Grafik-Modus - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Screen State › LOGO SPLITSCREEN - Schaltet in den geteilten Text/Grafik-Modus
Hilfe zum PBXB64-Compiler

LOGO SPLITSCREEN - Schaltet in den geteilten Text/Grafik-Modus

Art: LOGO command/expression | Category: LOGO Frontend / Screen State

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Schaltet in den geteilten Text/Grafik-Modus.

Syntax

SPLITSCREEN

Beschreibung

SPLITSCREEN ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Screen State verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie SPLITSCREEN, wenn das Programm den aktuellen Bildschirmmodus aendern oder die Zeichenflaeche leeren muss. Diese Seite ist richtig, wenn spaeterer Code darauf angewiesen ist, dass der Bildschirmzustand auf Text, Split, Vollbild oder einen bekannten Zeichenausgangszustand gesetzt wurde.

Fehlerfaelle

Wenn SPLITSCREEN zum falschen Zeitpunkt benutzt wird, kann der naechste Zeichenbefehl korrekt aussehen, obwohl der Zustand intern noch falsch ist. Dokumentieren Sie die Zustandsaenderung explizit, damit der Aufrufer weiss, welcher spaetere Befehl davon abhaengt.

Fokussiertes Beispiel

SPLITSCREEN

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_screen_state.lgo

SETBG 1
CLEAN
HT
ST
TEXTSCREEN
FULLSCREEN
SPLITSCREEN
FD 5

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO FILL - Fuellt ab der aktuellen Turtle-Position - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Drawing › LOGO FILL - Fuellt ab der aktuellen Turtle-Position
Hilfe zum PBXB64-Compiler

LOGO FILL - Fuellt ab der aktuellen Turtle-Position

Art: LOGO command/expression | Category: LOGO Frontend / Drawing

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Fuellt ab der aktuellen Turtle-Position.

Syntax

FILL

Beschreibung

FILL ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Drawing verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie FILL fuer sichtbare Zeichenoperationen, die Spuren auf dem aktuellen Turtle-Ziel hinterlassen sollen. Halten Sie Ziel, Stiftzustand und Koordinaten stabil, damit das Beispiel die exakten Pixel oder Textpositionen belegen kann, die der Befehl erzeugen soll.

Fehlerfaelle

Falsche Koordinaten, ein fehlendes Ziel oder ein unerwarteter Stiftzustand zeigen sich meist als Zeichnung an der falschen Stelle statt als Compile-Fehler. Halten Sie das Beispiel deterministisch, damit jede sichtbare Abweichung vom erwarteten Pfad eindeutig ist.

Fokussiertes Beispiel

FILL

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_fill.lgo

SETPC 4
FILL

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO LABEL - Zeichnet Text an der aktuellen Turtle-Position - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Drawing › LOGO LABEL - Zeichnet Text an der aktuellen Turtle-Position
Hilfe zum PBXB64-Compiler

LOGO LABEL - Zeichnet Text an der aktuellen Turtle-Position

Art: LOGO command/expression | Category: LOGO Frontend / Drawing

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Zeichnet Text an der aktuellen Turtle-Position.

Syntax

LABEL

Beschreibung

LABEL ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Drawing verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie LABEL fuer sichtbare Zeichenoperationen, die Spuren auf dem aktuellen Turtle-Ziel hinterlassen sollen. Halten Sie Ziel, Stiftzustand und Koordinaten stabil, damit das Beispiel die exakten Pixel oder Textpositionen belegen kann, die der Befehl erzeugen soll.

Fehlerfaelle

Falsche Koordinaten, ein fehlendes Ziel oder ein unerwarteter Stiftzustand zeigen sich meist als Zeichnung an der falschen Stelle statt als Compile-Fehler. Halten Sie das Beispiel deterministisch, damit jede sichtbare Abweichung vom erwarteten Pfad eindeutig ist.

Fokussiertes Beispiel

LABEL "Hello"

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_label.lgo

FD 50
LABEL "Hello
RT 90
FD 50

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO PRINT - Gibt eine Zahl oder Zeichenkette auf der Konsole aus - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Console › LOGO PRINT - Gibt eine Zahl oder Zeichenkette auf der Konsole aus
Hilfe zum PBXB64-Compiler

LOGO PRINT - Gibt eine Zahl oder Zeichenkette auf der Konsole aus

Art: LOGO command/expression | Category: LOGO Frontend / Console

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Gibt eine Zahl oder Zeichenkette auf der Konsole aus.

Syntax

PRINT

Beschreibung

PRINT ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Console verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie PRINT, wenn das LOGO-Programm mit Konsolentextausgabe arbeiten oder den sichtbaren Konsolenbereich leeren muss. Trennen Sie bei Programmen mit Zeichnung und Text das Konsolenverhalten vom Turtle-Ziel, damit das Beispiel leicht pruefbar bleibt.

Fehlerfaelle

Konsolenseiten sollten nennen, ob umgeleitete Ausgabe, eine fehlende Konsole oder frueherer Text das sichtbare Ergebnis veraendern. Gehen Sie nicht davon aus, dass ein Konsolen-Cleanup harmlos ist, wenn das umgebende Programm erwartet, dass frueherer Text sichtbar bleibt.

Fokussiertes Beispiel

PRINT 42

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_output.lgo

; Test OUTPUT in TO procedures
TO double :x
  OUTPUT SUM :x :x
END

TO test_output
  PRINT double 5
  PRINT double 3
END

test_output

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


LOGO CT - Loescht den Konsolentextbereich - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Console › LOGO CT - Loescht den Konsolentextbereich
Hilfe zum PBXB64-Compiler

LOGO CT - Loescht den Konsolentextbereich

Art: LOGO command/expression | Category: LOGO Frontend / Console

PBXB64 Status: AVAILABLE

PBXB64 Certification: [DOCUMENTED]

Funktion

Loescht den Konsolentextbereich.

Syntax

CT

Beschreibung

CT ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Console verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie CT, wenn das LOGO-Programm mit Konsolentextausgabe arbeiten oder den sichtbaren Konsolenbereich leeren muss. Trennen Sie bei Programmen mit Zeichnung und Text das Konsolenverhalten vom Turtle-Ziel, damit das Beispiel leicht pruefbar bleibt.

Fehlerfaelle

Konsolenseiten sollten nennen, ob umgeleitete Ausgabe, eine fehlende Konsole oder frueherer Text das sichtbare Ergebnis veraendern. Gehen Sie nicht davon aus, dass ein Konsolen-Cleanup harmlos ist, wenn das umgebende Programm erwartet, dass frueherer Text sichtbar bleibt.

Fokussiertes Beispiel

CT

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO MAKE - Weist einer LOGO-Variablen einen Wert zu - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Variables › LOGO MAKE - Weist einer LOGO-Variablen einen Wert zu
Hilfe zum PBXB64-Compiler

LOGO MAKE - Weist einer LOGO-Variablen einen Wert zu

Art: LOGO command/expression | Category: LOGO Frontend / Variables

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Weist einer LOGO-Variablen einen Wert zu.

Syntax

MAKE

Beschreibung

MAKE ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Variables verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie MAKE, wenn das Programm LOGO-Variablen anlegen, zuweisen oder lesen muss. Die Beispiele sollten den exakten Variablennamen, den Wertpfad und den Punkt zeigen, an dem die Variable in spaeteren Ausdruecken oder Prozeduren sichtbar wird.

Fehlerfaelle

Variablenbefehle scheitern in der Praxis, wenn der Aufrufer den falschen Namen, den falschen Bereich oder den falschen Vorwert annimmt. Das Beispiel sollte die Bindung explizit machen, damit ein falscher Zugriff oder ein Ueberschreiben sofort auffaellt.

Fokussiertes Beispiel

MAKE "x 42

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_vars.lgo

MAKE "x 100
FD :x

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO LOCAL - Deklariert oder reserviert einen lokalen LOGO-Variablenslot - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Variables › LOGO LOCAL - Deklariert oder reserviert einen lokalen LOGO-Variablenslot
Hilfe zum PBXB64-Compiler

LOGO LOCAL - Deklariert oder reserviert einen lokalen LOGO-Variablenslot

Art: LOGO command/expression | Category: LOGO Frontend / Variables

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Deklariert oder reserviert einen lokalen LOGO-Variablenslot.

Syntax

LOCAL

Beschreibung

LOCAL ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Variables verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie LOCAL, wenn das Programm LOGO-Variablen anlegen, zuweisen oder lesen muss. Die Beispiele sollten den exakten Variablennamen, den Wertpfad und den Punkt zeigen, an dem die Variable in spaeteren Ausdruecken oder Prozeduren sichtbar wird.

Fehlerfaelle

Variablenbefehle scheitern in der Praxis, wenn der Aufrufer den falschen Namen, den falschen Bereich oder den falschen Vorwert annimmt. Das Beispiel sollte die Bindung explizit machen, damit ein falscher Zugriff oder ein Ueberschreiben sofort auffaellt.

Fokussiertes Beispiel

LOCAL "x

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_local_quote.lgo

LOCAL "x
MAKE "x 42
FD :x

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO :name - Liest einen LOGO-Variablenwert - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Variables › LOGO :name - Liest einen LOGO-Variablenwert
Hilfe zum PBXB64-Compiler

LOGO :name - Liest einen LOGO-Variablenwert

Art: LOGO command/expression | Category: LOGO Frontend / Variables

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Liest einen LOGO-Variablenwert.

Syntax

:name

Beschreibung

:name ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Variables verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie :name, wenn das Programm LOGO-Variablen anlegen, zuweisen oder lesen muss. Die Beispiele sollten den exakten Variablennamen, den Wertpfad und den Punkt zeigen, an dem die Variable in spaeteren Ausdruecken oder Prozeduren sichtbar wird.

Fehlerfaelle

Variablenbefehle scheitern in der Praxis, wenn der Aufrufer den falschen Namen, den falschen Bereich oder den falschen Vorwert annimmt. Das Beispiel sollte die Bindung explizit machen, damit ein falscher Zugriff oder ein Ueberschreiben sofort auffaellt.

Fokussiertes Beispiel

MAKE "x 42
PRINT :x

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_vars.lgo

MAKE "x 100
FD :x

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO "name - Erzeugt ein LOGO-Wort/String-Literal - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Variables › LOGO "name - Erzeugt ein LOGO-Wort/String-Literal
Hilfe zum PBXB64-Compiler

LOGO "name - Erzeugt ein LOGO-Wort/String-Literal

Art: LOGO command/expression | Category: LOGO Frontend / Variables

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Erzeugt ein LOGO-Wort/String-Literal.

Syntax

"name

Beschreibung

"name ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Variables verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie "name, wenn das Programm LOGO-Variablen anlegen, zuweisen oder lesen muss. Die Beispiele sollten den exakten Variablennamen, den Wertpfad und den Punkt zeigen, an dem die Variable in spaeteren Ausdruecken oder Prozeduren sichtbar wird.

Fehlerfaelle

Variablenbefehle scheitern in der Praxis, wenn der Aufrufer den falschen Namen, den falschen Bereich oder den falschen Vorwert annimmt. Das Beispiel sollte die Bindung explizit machen, damit ein falscher Zugriff oder ein Ueberschreiben sofort auffaellt.

Fokussiertes Beispiel

MAKE "name 42

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_local_quote.lgo

LOCAL "x
MAKE "x 42
FD :x

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO TO - Startet eine LOGO-Prozedurdefinition - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Procedures › LOGO TO - Startet eine LOGO-Prozedurdefinition
Hilfe zum PBXB64-Compiler

LOGO TO - Startet eine LOGO-Prozedurdefinition

Art: LOGO command/expression | Category: LOGO Frontend / Procedures

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Startet eine LOGO-Prozedurdefinition.

Syntax

TO

Beschreibung

TO ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Procedures verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie TO, wenn das Programm eine LOGO-Prozedur definiert oder verlaesst. Prozedurseiten sollten die komplette Blockform zeigen, damit der Aufrufer sieht, wie Argumente, Rueckgabe und vorzeitiges Ende zusammenwirken.

Fehlerfaelle

Prozedurseiten sollten fehlendes END, falsche Argumente und Rueckspruenge ausserhalb der Prozedur als typische Fehlerform nennen. Wenn die Seite einen Rueckgabepfad definiert, sollte sie zeigen, was der Aufrufer bei einem vorzeitigen Ende erwartet.

Fokussiertes Beispiel

TO SQUARE :n
REPEAT 4 [FD :n RT 90]
END

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_output.lgo

; Test OUTPUT in TO procedures
TO double :x
  OUTPUT SUM :x :x
END

TO test_output
  PRINT double 5
  PRINT double 3
END

test_output

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO END - Beendet eine LOGO-Prozedurdefinition - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Procedures › LOGO END - Beendet eine LOGO-Prozedurdefinition
Hilfe zum PBXB64-Compiler

LOGO END - Beendet eine LOGO-Prozedurdefinition

Art: LOGO command/expression | Category: LOGO Frontend / Procedures

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Beendet eine LOGO-Prozedurdefinition.

Syntax

END

Beschreibung

END ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Procedures verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie END, wenn das Programm eine LOGO-Prozedur definiert oder verlaesst. Prozedurseiten sollten die komplette Blockform zeigen, damit der Aufrufer sieht, wie Argumente, Rueckgabe und vorzeitiges Ende zusammenwirken.

Fehlerfaelle

Prozedurseiten sollten fehlendes END, falsche Argumente und Rueckspruenge ausserhalb der Prozedur als typische Fehlerform nennen. Wenn die Seite einen Rueckgabepfad definiert, sollte sie zeigen, was der Aufrufer bei einem vorzeitigen Ende erwartet.

Fokussiertes Beispiel

TO ANSWER
OUTPUT 42
END

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_output.lgo

; Test OUTPUT in TO procedures
TO double :x
  OUTPUT SUM :x :x
END

TO test_output
  PRINT double 5
  PRINT double 3
END

test_output

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO OUTPUT - Gibt einen Wert aus einer LOGO-Prozedur zurueck - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Procedures › LOGO OUTPUT - Gibt einen Wert aus einer LOGO-Prozedur zurueck
Hilfe zum PBXB64-Compiler

LOGO OUTPUT - Gibt einen Wert aus einer LOGO-Prozedur zurueck

Art: LOGO command/expression | Category: LOGO Frontend / Procedures

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Gibt einen Wert aus einer LOGO-Prozedur zurueck.

Syntax

OUTPUT

Beschreibung

OUTPUT ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Procedures verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie OUTPUT, wenn das Programm eine LOGO-Prozedur definiert oder verlaesst. Prozedurseiten sollten die komplette Blockform zeigen, damit der Aufrufer sieht, wie Argumente, Rueckgabe und vorzeitiges Ende zusammenwirken.

Fehlerfaelle

Prozedurseiten sollten fehlendes END, falsche Argumente und Rueckspruenge ausserhalb der Prozedur als typische Fehlerform nennen. Wenn die Seite einen Rueckgabepfad definiert, sollte sie zeigen, was der Aufrufer bei einem vorzeitigen Ende erwartet.

Fokussiertes Beispiel

TO ANSWER
OUTPUT 42
END

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_output.lgo

; Test OUTPUT in TO procedures
TO double :x
  OUTPUT SUM :x :x
END

TO test_output
  PRINT double 5
  PRINT double 3
END

test_output

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO STOP - Verlaesst die aktuelle LOGO-Prozedur bzw. das Programm frueh - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Procedures › LOGO STOP - Verlaesst die aktuelle LOGO-Prozedur bzw. das Programm frueh
Hilfe zum PBXB64-Compiler

LOGO STOP - Verlaesst die aktuelle LOGO-Prozedur bzw. das Programm frueh

Art: LOGO command/expression | Category: LOGO Frontend / Procedures

PBXB64 Status: AVAILABLE

PBXB64 Certification: [DOCUMENTED]

Funktion

Verlaesst die aktuelle LOGO-Prozedur bzw. das Programm frueh.

Syntax

STOP

Beschreibung

STOP ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Procedures verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie STOP, wenn das Programm eine LOGO-Prozedur definiert oder verlaesst. Prozedurseiten sollten die komplette Blockform zeigen, damit der Aufrufer sieht, wie Argumente, Rueckgabe und vorzeitiges Ende zusammenwirken.

Fehlerfaelle

Prozedurseiten sollten fehlendes END, falsche Argumente und Rueckspruenge ausserhalb der Prozedur als typische Fehlerform nennen. Wenn die Seite einen Rueckgabepfad definiert, sollte sie zeigen, was der Aufrufer bei einem vorzeitigen Ende erwartet.

Fokussiertes Beispiel

STOP

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO IF - Fuehrt einen Block aus, wenn eine Bedingung wahr ist - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Control Flow › LOGO IF - Fuehrt einen Block aus, wenn eine Bedingung wahr ist
Hilfe zum PBXB64-Compiler

LOGO IF - Fuehrt einen Block aus, wenn eine Bedingung wahr ist

Art: LOGO command/expression | Category: LOGO Frontend / Control Flow

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Fuehrt einen Block aus, wenn eine Bedingung wahr ist.

Syntax

IF

Beschreibung

IF ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Control Flow verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie IF, wenn das Programm zwischen Bloecken waehlen oder einen Block anhand eines numerischen oder logischen Tests wiederholen muss. Ein gutes Beispiel sollte sowohl den ausgefuehrten als auch den uebersprungenen Zweig oder die Schleifengrenze zeigen, die das Ergebnis bestimmt.

Fehlerfaelle

Kontrollflussfehler entstehen meist dadurch, dass der falsche Zweig erwartet wird oder eine Bedingung nie aendert. Das Beispiel sollte die Grenzbedingung klar zeigen, damit die Schleife oder der Zweig nicht missverstanden wird.

Fokussiertes Beispiel

IF 1 [PRINT 42]

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_if.lgo

IF 1 > 0 [FD 100]

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO IFELSE - Waehlt zwischen Wahr- und Falsch-Block - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Control Flow › LOGO IFELSE - Waehlt zwischen Wahr- und Falsch-Block
Hilfe zum PBXB64-Compiler

LOGO IFELSE - Waehlt zwischen Wahr- und Falsch-Block

Art: LOGO command/expression | Category: LOGO Frontend / Control Flow

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Waehlt zwischen Wahr- und Falsch-Block.

Syntax

IFELSE

Beschreibung

IFELSE ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Control Flow verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie IFELSE, wenn das Programm zwischen Bloecken waehlen oder einen Block anhand eines numerischen oder logischen Tests wiederholen muss. Ein gutes Beispiel sollte sowohl den ausgefuehrten als auch den uebersprungenen Zweig oder die Schleifengrenze zeigen, die das Ergebnis bestimmt.

Fehlerfaelle

Kontrollflussfehler entstehen meist dadurch, dass der falsche Zweig erwartet wird oder eine Bedingung nie aendert. Das Beispiel sollte die Grenzbedingung klar zeigen, damit die Schleife oder der Zweig nicht missverstanden wird.

Fokussiertes Beispiel

IFELSE 0 [PRINT 1] [PRINT 42]

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_ifelse.lgo

IFELSE 1 > 0 [FD 100] [BK 100]

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO REPEAT - Fuehrt einen Block eine feste Anzahl Mal aus - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Control Flow › LOGO REPEAT - Fuehrt einen Block eine feste Anzahl Mal aus
Hilfe zum PBXB64-Compiler

LOGO REPEAT - Fuehrt einen Block eine feste Anzahl Mal aus

Art: LOGO command/expression | Category: LOGO Frontend / Control Flow

PBXB64 Status: AVAILABLE

PBXB64 Certification: [DOCUMENTED]

Funktion

Fuehrt einen Block eine feste Anzahl Mal aus.

Syntax

REPEAT

Beschreibung

REPEAT ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Control Flow verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie REPEAT, wenn das Programm zwischen Bloecken waehlen oder einen Block anhand eines numerischen oder logischen Tests wiederholen muss. Ein gutes Beispiel sollte sowohl den ausgefuehrten als auch den uebersprungenen Zweig oder die Schleifengrenze zeigen, die das Ergebnis bestimmt.

Fehlerfaelle

Kontrollflussfehler entstehen meist dadurch, dass der falsche Zweig erwartet wird oder eine Bedingung nie aendert. Das Beispiel sollte die Grenzbedingung klar zeigen, damit die Schleife oder der Zweig nicht missverstanden wird.

Fokussiertes Beispiel

REPEAT 4 [FD 50 RT 90]

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO WHILE - Fuehrt einen Block aus, solange eine Bedingung wahr bleibt - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Control Flow › LOGO WHILE - Fuehrt einen Block aus, solange eine Bedingung wahr bleibt
Hilfe zum PBXB64-Compiler

LOGO WHILE - Fuehrt einen Block aus, solange eine Bedingung wahr bleibt

Art: LOGO command/expression | Category: LOGO Frontend / Control Flow

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Fuehrt einen Block aus, solange eine Bedingung wahr bleibt.

Syntax

WHILE

Beschreibung

WHILE ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Control Flow verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie WHILE, wenn das Programm zwischen Bloecken waehlen oder einen Block anhand eines numerischen oder logischen Tests wiederholen muss. Ein gutes Beispiel sollte sowohl den ausgefuehrten als auch den uebersprungenen Zweig oder die Schleifengrenze zeigen, die das Ergebnis bestimmt.

Fehlerfaelle

Kontrollflussfehler entstehen meist dadurch, dass der falsche Zweig erwartet wird oder eine Bedingung nie aendert. Das Beispiel sollte die Grenzbedingung klar zeigen, damit die Schleife oder der Zweig nicht missverstanden wird.

Fokussiertes Beispiel

MAKE "x 0
WHILE :x < 4 [MAKE "x :x + 1]

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_while.lgo

; Test WHILE loop
TO test_while
  MAKE "count 0
  WHILE :count < 3 [
    PRINT :count
    MAKE "count SUM :count 1
  ]
END

test_while

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO SUM - Addiert zwei numerische Ausdruecke - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Math › LOGO SUM - Addiert zwei numerische Ausdruecke
Hilfe zum PBXB64-Compiler

LOGO SUM - Addiert zwei numerische Ausdruecke

Art: LOGO command/expression | Category: LOGO Frontend / Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Addiert zwei numerische Ausdruecke.

Syntax

SUM

Beschreibung

SUM ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Math verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie SUM, wenn das Programm ein numerisches Ergebnis fuer spaetere Turtle-, Variablen- oder Kontrollflussarbeit braucht. Das Beispiel sollte den vollstaendigen Zahlenpfad zeigen und nicht nur den letzten Ausgabe-Wert, damit Prioritaet und Argumentreihenfolge klar bleiben.

Fehlerfaelle

Mathematische Fehler sind meist Eingabeformprobleme: falsche Operandenzahl, falsche Reihenfolge oder nichtnumerische Daten. Die Seite sollte die exakte Operandereihenfolge und das erwartete numerische Ergebnis zeigen, damit Fehlbenutzung auffaellt.

Fokussiertes Beispiel

PRINT SUM 40 2

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_math.lgo

FD SUM 50 50
RT 90
FD PRODUCT 10 10

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO DIFFERENCE - Subtrahiert den zweiten Ausdruck vom ersten - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Math › LOGO DIFFERENCE - Subtrahiert den zweiten Ausdruck vom ersten
Hilfe zum PBXB64-Compiler

LOGO DIFFERENCE - Subtrahiert den zweiten Ausdruck vom ersten

Art: LOGO command/expression | Category: LOGO Frontend / Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Subtrahiert den zweiten Ausdruck vom ersten.

Syntax

DIFFERENCE

Beschreibung

DIFFERENCE ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Math verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie DIFFERENCE, wenn das Programm ein numerisches Ergebnis fuer spaetere Turtle-, Variablen- oder Kontrollflussarbeit braucht. Das Beispiel sollte den vollstaendigen Zahlenpfad zeigen und nicht nur den letzten Ausgabe-Wert, damit Prioritaet und Argumentreihenfolge klar bleiben.

Fehlerfaelle

Mathematische Fehler sind meist Eingabeformprobleme: falsche Operandenzahl, falsche Reihenfolge oder nichtnumerische Daten. Die Seite sollte die exakte Operandereihenfolge und das erwartete numerische Ergebnis zeigen, damit Fehlbenutzung auffaellt.

Fokussiertes Beispiel

PRINT DIFFERENCE 50 8

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_math_more.lgo

FD DIFFERENCE 50 8
FD QUOTIENT 84 2
FD REMAINDER 85 43
FD SIN 90
FD COS 0
FD SQRT 49
FD ABS -42
FD INT 3.9
FD ROUND 3.5

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO PRODUCT - Multipliziert zwei numerische Ausdruecke - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Math › LOGO PRODUCT - Multipliziert zwei numerische Ausdruecke
Hilfe zum PBXB64-Compiler

LOGO PRODUCT - Multipliziert zwei numerische Ausdruecke

Art: LOGO command/expression | Category: LOGO Frontend / Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Multipliziert zwei numerische Ausdruecke.

Syntax

PRODUCT

Beschreibung

PRODUCT ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Math verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie PRODUCT, wenn das Programm ein numerisches Ergebnis fuer spaetere Turtle-, Variablen- oder Kontrollflussarbeit braucht. Das Beispiel sollte den vollstaendigen Zahlenpfad zeigen und nicht nur den letzten Ausgabe-Wert, damit Prioritaet und Argumentreihenfolge klar bleiben.

Fehlerfaelle

Mathematische Fehler sind meist Eingabeformprobleme: falsche Operandenzahl, falsche Reihenfolge oder nichtnumerische Daten. Die Seite sollte die exakte Operandereihenfolge und das erwartete numerische Ergebnis zeigen, damit Fehlbenutzung auffaellt.

Fokussiertes Beispiel

PRINT PRODUCT 6 7

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_math.lgo

FD SUM 50 50
RT 90
FD PRODUCT 10 10

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO QUOTIENT - Dividiert den ersten Ausdruck durch den zweiten - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Math › LOGO QUOTIENT - Dividiert den ersten Ausdruck durch den zweiten
Hilfe zum PBXB64-Compiler

LOGO QUOTIENT - Dividiert den ersten Ausdruck durch den zweiten

Art: LOGO command/expression | Category: LOGO Frontend / Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Dividiert den ersten Ausdruck durch den zweiten.

Syntax

QUOTIENT

Beschreibung

QUOTIENT ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Math verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie QUOTIENT, wenn das Programm ein numerisches Ergebnis fuer spaetere Turtle-, Variablen- oder Kontrollflussarbeit braucht. Das Beispiel sollte den vollstaendigen Zahlenpfad zeigen und nicht nur den letzten Ausgabe-Wert, damit Prioritaet und Argumentreihenfolge klar bleiben.

Fehlerfaelle

Mathematische Fehler sind meist Eingabeformprobleme: falsche Operandenzahl, falsche Reihenfolge oder nichtnumerische Daten. Die Seite sollte die exakte Operandereihenfolge und das erwartete numerische Ergebnis zeigen, damit Fehlbenutzung auffaellt.

Fokussiertes Beispiel

PRINT QUOTIENT 84 2

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_math_more.lgo

FD DIFFERENCE 50 8
FD QUOTIENT 84 2
FD REMAINDER 85 43
FD SIN 90
FD COS 0
FD SQRT 49
FD ABS -42
FD INT 3.9
FD ROUND 3.5

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO REMAINDER - Liefert den Rest einer Division - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Math › LOGO REMAINDER - Liefert den Rest einer Division
Hilfe zum PBXB64-Compiler

LOGO REMAINDER - Liefert den Rest einer Division

Art: LOGO command/expression | Category: LOGO Frontend / Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Liefert den Rest einer Division.

Syntax

REMAINDER

Beschreibung

REMAINDER ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Math verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie REMAINDER, wenn das Programm ein numerisches Ergebnis fuer spaetere Turtle-, Variablen- oder Kontrollflussarbeit braucht. Das Beispiel sollte den vollstaendigen Zahlenpfad zeigen und nicht nur den letzten Ausgabe-Wert, damit Prioritaet und Argumentreihenfolge klar bleiben.

Fehlerfaelle

Mathematische Fehler sind meist Eingabeformprobleme: falsche Operandenzahl, falsche Reihenfolge oder nichtnumerische Daten. Die Seite sollte die exakte Operandereihenfolge und das erwartete numerische Ergebnis zeigen, damit Fehlbenutzung auffaellt.

Fokussiertes Beispiel

PRINT REMAINDER 85 43

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_math_more.lgo

FD DIFFERENCE 50 8
FD QUOTIENT 84 2
FD REMAINDER 85 43
FD SIN 90
FD COS 0
FD SQRT 49
FD ABS -42
FD INT 3.9
FD ROUND 3.5

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO GREATERP - Prueft, ob der erste Wert groesser ist - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Math › LOGO GREATERP - Prueft, ob der erste Wert groesser ist
Hilfe zum PBXB64-Compiler

LOGO GREATERP - Prueft, ob der erste Wert groesser ist

Art: LOGO command/expression | Category: LOGO Frontend / Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Prueft, ob der erste Wert groesser ist.

Syntax

GREATERP

Beschreibung

GREATERP ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Math verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie GREATERP, wenn das Programm ein numerisches Ergebnis fuer spaetere Turtle-, Variablen- oder Kontrollflussarbeit braucht. Das Beispiel sollte den vollstaendigen Zahlenpfad zeigen und nicht nur den letzten Ausgabe-Wert, damit Prioritaet und Argumentreihenfolge klar bleiben.

Fehlerfaelle

Mathematische Fehler sind meist Eingabeformprobleme: falsche Operandenzahl, falsche Reihenfolge oder nichtnumerische Daten. Die Seite sollte die exakte Operandereihenfolge und das erwartete numerische Ergebnis zeigen, damit Fehlbenutzung auffaellt.

Fokussiertes Beispiel

IF GREATERP 2 1 [PRINT 42]

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_comparisons.lgo

IF GREATERP 2 1 [FD 1]
IF LESSP 1 2 [FD 1]
IF EQUALP 42 42 [FD 1]

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO LESSP - Prueft, ob der erste Wert kleiner ist - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Math › LOGO LESSP - Prueft, ob der erste Wert kleiner ist
Hilfe zum PBXB64-Compiler

LOGO LESSP - Prueft, ob der erste Wert kleiner ist

Art: LOGO command/expression | Category: LOGO Frontend / Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Prueft, ob der erste Wert kleiner ist.

Syntax

LESSP

Beschreibung

LESSP ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Math verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie LESSP, wenn das Programm ein numerisches Ergebnis fuer spaetere Turtle-, Variablen- oder Kontrollflussarbeit braucht. Das Beispiel sollte den vollstaendigen Zahlenpfad zeigen und nicht nur den letzten Ausgabe-Wert, damit Prioritaet und Argumentreihenfolge klar bleiben.

Fehlerfaelle

Mathematische Fehler sind meist Eingabeformprobleme: falsche Operandenzahl, falsche Reihenfolge oder nichtnumerische Daten. Die Seite sollte die exakte Operandereihenfolge und das erwartete numerische Ergebnis zeigen, damit Fehlbenutzung auffaellt.

Fokussiertes Beispiel

IF LESSP 1 2 [PRINT 42]

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_comparisons.lgo

IF GREATERP 2 1 [FD 1]
IF LESSP 1 2 [FD 1]
IF EQUALP 42 42 [FD 1]

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO EQUALP - Vergleicht zwei Werte auf Gleichheit - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Math › LOGO EQUALP - Vergleicht zwei Werte auf Gleichheit
Hilfe zum PBXB64-Compiler

LOGO EQUALP - Vergleicht zwei Werte auf Gleichheit

Art: LOGO command/expression | Category: LOGO Frontend / Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Vergleicht zwei Werte auf Gleichheit.

Syntax

EQUALP

Beschreibung

EQUALP ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Math verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie EQUALP, wenn das Programm ein numerisches Ergebnis fuer spaetere Turtle-, Variablen- oder Kontrollflussarbeit braucht. Das Beispiel sollte den vollstaendigen Zahlenpfad zeigen und nicht nur den letzten Ausgabe-Wert, damit Prioritaet und Argumentreihenfolge klar bleiben.

Fehlerfaelle

Mathematische Fehler sind meist Eingabeformprobleme: falsche Operandenzahl, falsche Reihenfolge oder nichtnumerische Daten. Die Seite sollte die exakte Operandereihenfolge und das erwartete numerische Ergebnis zeigen, damit Fehlbenutzung auffaellt.

Fokussiertes Beispiel

IF EQUALP 42 42 [PRINT 42]

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_comparisons.lgo

IF GREATERP 2 1 [FD 1]
IF LESSP 1 2 [FD 1]
IF EQUALP 42 42 [FD 1]

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO SIN - Berechnet den Sinus aus Gradwerten - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Math › LOGO SIN - Berechnet den Sinus aus Gradwerten
Hilfe zum PBXB64-Compiler

LOGO SIN - Berechnet den Sinus aus Gradwerten

Art: LOGO command/expression | Category: LOGO Frontend / Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Berechnet den Sinus aus Gradwerten.

Syntax

SIN

Beschreibung

SIN ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Math verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie SIN, wenn das Programm ein numerisches Ergebnis fuer spaetere Turtle-, Variablen- oder Kontrollflussarbeit braucht. Das Beispiel sollte den vollstaendigen Zahlenpfad zeigen und nicht nur den letzten Ausgabe-Wert, damit Prioritaet und Argumentreihenfolge klar bleiben.

Fehlerfaelle

Mathematische Fehler sind meist Eingabeformprobleme: falsche Operandenzahl, falsche Reihenfolge oder nichtnumerische Daten. Die Seite sollte die exakte Operandereihenfolge und das erwartete numerische Ergebnis zeigen, damit Fehlbenutzung auffaellt.

Fokussiertes Beispiel

PRINT SIN 90

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_math_more.lgo

FD DIFFERENCE 50 8
FD QUOTIENT 84 2
FD REMAINDER 85 43
FD SIN 90
FD COS 0
FD SQRT 49
FD ABS -42
FD INT 3.9
FD ROUND 3.5

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO COS - Berechnet den Kosinus aus Gradwerten - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Math › LOGO COS - Berechnet den Kosinus aus Gradwerten
Hilfe zum PBXB64-Compiler

LOGO COS - Berechnet den Kosinus aus Gradwerten

Art: LOGO command/expression | Category: LOGO Frontend / Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Berechnet den Kosinus aus Gradwerten.

Syntax

COS

Beschreibung

COS ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Math verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie COS, wenn das Programm ein numerisches Ergebnis fuer spaetere Turtle-, Variablen- oder Kontrollflussarbeit braucht. Das Beispiel sollte den vollstaendigen Zahlenpfad zeigen und nicht nur den letzten Ausgabe-Wert, damit Prioritaet und Argumentreihenfolge klar bleiben.

Fehlerfaelle

Mathematische Fehler sind meist Eingabeformprobleme: falsche Operandenzahl, falsche Reihenfolge oder nichtnumerische Daten. Die Seite sollte die exakte Operandereihenfolge und das erwartete numerische Ergebnis zeigen, damit Fehlbenutzung auffaellt.

Fokussiertes Beispiel

PRINT COS 0

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_math_more.lgo

FD DIFFERENCE 50 8
FD QUOTIENT 84 2
FD REMAINDER 85 43
FD SIN 90
FD COS 0
FD SQRT 49
FD ABS -42
FD INT 3.9
FD ROUND 3.5

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO SQRT - Berechnet die Quadratwurzel - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Math › LOGO SQRT - Berechnet die Quadratwurzel
Hilfe zum PBXB64-Compiler

LOGO SQRT - Berechnet die Quadratwurzel

Art: LOGO command/expression | Category: LOGO Frontend / Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Berechnet die Quadratwurzel.

Syntax

SQRT

Beschreibung

SQRT ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Math verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie SQRT, wenn das Programm ein numerisches Ergebnis fuer spaetere Turtle-, Variablen- oder Kontrollflussarbeit braucht. Das Beispiel sollte den vollstaendigen Zahlenpfad zeigen und nicht nur den letzten Ausgabe-Wert, damit Prioritaet und Argumentreihenfolge klar bleiben.

Fehlerfaelle

Mathematische Fehler sind meist Eingabeformprobleme: falsche Operandenzahl, falsche Reihenfolge oder nichtnumerische Daten. Die Seite sollte die exakte Operandereihenfolge und das erwartete numerische Ergebnis zeigen, damit Fehlbenutzung auffaellt.

Fokussiertes Beispiel

PRINT SQRT 49

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_math_more.lgo

FD DIFFERENCE 50 8
FD QUOTIENT 84 2
FD REMAINDER 85 43
FD SIN 90
FD COS 0
FD SQRT 49
FD ABS -42
FD INT 3.9
FD ROUND 3.5

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO ABS - Berechnet den Absolutwert - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Math › LOGO ABS - Berechnet den Absolutwert
Hilfe zum PBXB64-Compiler

LOGO ABS - Berechnet den Absolutwert

Art: LOGO command/expression | Category: LOGO Frontend / Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Berechnet den Absolutwert.

Syntax

ABS

Beschreibung

ABS ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Math verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie ABS, wenn das Programm ein numerisches Ergebnis fuer spaetere Turtle-, Variablen- oder Kontrollflussarbeit braucht. Das Beispiel sollte den vollstaendigen Zahlenpfad zeigen und nicht nur den letzten Ausgabe-Wert, damit Prioritaet und Argumentreihenfolge klar bleiben.

Fehlerfaelle

Mathematische Fehler sind meist Eingabeformprobleme: falsche Operandenzahl, falsche Reihenfolge oder nichtnumerische Daten. Die Seite sollte die exakte Operandereihenfolge und das erwartete numerische Ergebnis zeigen, damit Fehlbenutzung auffaellt.

Fokussiertes Beispiel

PRINT ABS -42

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_math_more.lgo

FD DIFFERENCE 50 8
FD QUOTIENT 84 2
FD REMAINDER 85 43
FD SIN 90
FD COS 0
FD SQRT 49
FD ABS -42
FD INT 3.9
FD ROUND 3.5

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO RANDOM - Erzeugt einen durch das Argument begrenzten Zufallswert - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Math › LOGO RANDOM - Erzeugt einen durch das Argument begrenzten Zufallswert
Hilfe zum PBXB64-Compiler

LOGO RANDOM - Erzeugt einen durch das Argument begrenzten Zufallswert

Art: LOGO command/expression | Category: LOGO Frontend / Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Erzeugt einen durch das Argument begrenzten Zufallswert.

Syntax

RANDOM

Beschreibung

RANDOM ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Math verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie RANDOM, wenn das Programm ein numerisches Ergebnis fuer spaetere Turtle-, Variablen- oder Kontrollflussarbeit braucht. Das Beispiel sollte den vollstaendigen Zahlenpfad zeigen und nicht nur den letzten Ausgabe-Wert, damit Prioritaet und Argumentreihenfolge klar bleiben.

Fehlerfaelle

Mathematische Fehler sind meist Eingabeformprobleme: falsche Operandenzahl, falsche Reihenfolge oder nichtnumerische Daten. Die Seite sollte die exakte Operandereihenfolge und das erwartete numerische Ergebnis zeigen, damit Fehlbenutzung auffaellt.

Fokussiertes Beispiel

PRINT RANDOM 10

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_random.lgo

FD RANDOM 10

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO INT - Wandelt einen numerischen Ausdruck in Integer um - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Math › LOGO INT - Wandelt einen numerischen Ausdruck in Integer um
Hilfe zum PBXB64-Compiler

LOGO INT - Wandelt einen numerischen Ausdruck in Integer um

Art: LOGO command/expression | Category: LOGO Frontend / Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Wandelt einen numerischen Ausdruck in Integer um.

Syntax

INT

Beschreibung

INT ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Math verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie INT, wenn das Programm ein numerisches Ergebnis fuer spaetere Turtle-, Variablen- oder Kontrollflussarbeit braucht. Das Beispiel sollte den vollstaendigen Zahlenpfad zeigen und nicht nur den letzten Ausgabe-Wert, damit Prioritaet und Argumentreihenfolge klar bleiben.

Fehlerfaelle

Mathematische Fehler sind meist Eingabeformprobleme: falsche Operandenzahl, falsche Reihenfolge oder nichtnumerische Daten. Die Seite sollte die exakte Operandereihenfolge und das erwartete numerische Ergebnis zeigen, damit Fehlbenutzung auffaellt.

Fokussiertes Beispiel

PRINT INT 3.9

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_math_more.lgo

FD DIFFERENCE 50 8
FD QUOTIENT 84 2
FD REMAINDER 85 43
FD SIN 90
FD COS 0
FD SQRT 49
FD ABS -42
FD INT 3.9
FD ROUND 3.5

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO ROUND - Rundet einen numerischen Ausdruck auf Integer - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Math › LOGO ROUND - Rundet einen numerischen Ausdruck auf Integer
Hilfe zum PBXB64-Compiler

LOGO ROUND - Rundet einen numerischen Ausdruck auf Integer

Art: LOGO command/expression | Category: LOGO Frontend / Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Rundet einen numerischen Ausdruck auf Integer.

Syntax

ROUND

Beschreibung

ROUND ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Math verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie ROUND, wenn das Programm ein numerisches Ergebnis fuer spaetere Turtle-, Variablen- oder Kontrollflussarbeit braucht. Das Beispiel sollte den vollstaendigen Zahlenpfad zeigen und nicht nur den letzten Ausgabe-Wert, damit Prioritaet und Argumentreihenfolge klar bleiben.

Fehlerfaelle

Mathematische Fehler sind meist Eingabeformprobleme: falsche Operandenzahl, falsche Reihenfolge oder nichtnumerische Daten. Die Seite sollte die exakte Operandereihenfolge und das erwartete numerische Ergebnis zeigen, damit Fehlbenutzung auffaellt.

Fokussiertes Beispiel

PRINT ROUND 3.5

Verifiziertes Beispiel

Beispieldatei: examples/logo/help_verified/help_math_more.lgo

FD DIFFERENCE 50 8
FD QUOTIENT 84 2
FD REMAINDER 85 43
FD SIN 90
FD COS 0
FD SQRT 49
FD ABS -42
FD INT 3.9
FD ROUND 3.5

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO POWER - Potenziert eine Basis mit einem Exponenten - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Math › LOGO POWER - Potenziert eine Basis mit einem Exponenten
Hilfe zum PBXB64-Compiler

LOGO POWER - Potenziert eine Basis mit einem Exponenten

Art: LOGO command/expression | Category: LOGO Frontend / Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [DOCUMENTED]

Funktion

Potenziert eine Basis mit einem Exponenten.

Syntax

POWER

Beschreibung

POWER ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Math verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie POWER, wenn das Programm ein numerisches Ergebnis fuer spaetere Turtle-, Variablen- oder Kontrollflussarbeit braucht. Das Beispiel sollte den vollstaendigen Zahlenpfad zeigen und nicht nur den letzten Ausgabe-Wert, damit Prioritaet und Argumentreihenfolge klar bleiben.

Fehlerfaelle

Mathematische Fehler sind meist Eingabeformprobleme: falsche Operandenzahl, falsche Reihenfolge oder nichtnumerische Daten. Die Seite sollte die exakte Operandereihenfolge und das erwartete numerische Ergebnis zeigen, damit Fehlbenutzung auffaellt.

Fokussiertes Beispiel

PRINT POWER 2 8

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO LIST - Erzeugt einen numerischen LOGO-Listenhandle - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Lists › LOGO LIST - Erzeugt einen numerischen LOGO-Listenhandle
Hilfe zum PBXB64-Compiler

LOGO LIST - Erzeugt einen numerischen LOGO-Listenhandle

Art: LOGO command/expression | Category: LOGO Frontend / Lists

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Erzeugt einen numerischen LOGO-Listenhandle.

Syntax

LIST

Beschreibung

LIST ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Lists verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie LIST, wenn das Programm einen LOGO-Listenwert aufbauen oder pruefen muss. Die Seite sollte die exakte Listenform vor und nach der Operation zeigen, damit der Aufrufer erkennt, ob der Befehl eine Liste erzeugt, kuerzt oder ein Listenelement extrahiert hat.

Fehlerfaelle

Listenbefehle scheitern, wenn der Aufrufer eine andere Listenform, eine Nicht-Liste als Eingabe oder eine andere Nummerierungsregel annimmt. Das Beispiel sollte die Eingangsliste und die exakte Ergebnisliste oder das Listenelement zeigen, damit der Formvertrag sichtbar wird.

Fokussiertes Beispiel

MAKE "xs LIST 1 2 3

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_list.lgo

; Test list primitives
TO test_list
  MAKE "a LIST 10 20
  PRINT FIRST :a
  PRINT LAST :a
  PRINT ITEM 1 :a
  PRINT ITEM 2 :a
  MAKE "b FPUT 5 :a
  PRINT FIRST :b
  MAKE "c LPUT 30 :a
  PRINT LAST :c
  MAKE "d BUTFIRST :a
  PRINT FIRST :d
  MAKE "e BUTLAST :a
  PRINT LAST :e
END

test_list

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO FIRST - Liefert das erste Element einer LOGO-Liste - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Lists › LOGO FIRST - Liefert das erste Element einer LOGO-Liste
Hilfe zum PBXB64-Compiler

LOGO FIRST - Liefert das erste Element einer LOGO-Liste

Art: LOGO command/expression | Category: LOGO Frontend / Lists

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Liefert das erste Element einer LOGO-Liste.

Syntax

FIRST

Beschreibung

FIRST ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Lists verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie FIRST, wenn das Programm einen LOGO-Listenwert aufbauen oder pruefen muss. Die Seite sollte die exakte Listenform vor und nach der Operation zeigen, damit der Aufrufer erkennt, ob der Befehl eine Liste erzeugt, kuerzt oder ein Listenelement extrahiert hat.

Fehlerfaelle

Listenbefehle scheitern, wenn der Aufrufer eine andere Listenform, eine Nicht-Liste als Eingabe oder eine andere Nummerierungsregel annimmt. Das Beispiel sollte die Eingangsliste und die exakte Ergebnisliste oder das Listenelement zeigen, damit der Formvertrag sichtbar wird.

Fokussiertes Beispiel

PRINT FIRST LIST 42 7

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_list.lgo

; Test list primitives
TO test_list
  MAKE "a LIST 10 20
  PRINT FIRST :a
  PRINT LAST :a
  PRINT ITEM 1 :a
  PRINT ITEM 2 :a
  MAKE "b FPUT 5 :a
  PRINT FIRST :b
  MAKE "c LPUT 30 :a
  PRINT LAST :c
  MAKE "d BUTFIRST :a
  PRINT FIRST :d
  MAKE "e BUTLAST :a
  PRINT LAST :e
END

test_list

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO LAST - Liefert das letzte Element einer LOGO-Liste - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Lists › LOGO LAST - Liefert das letzte Element einer LOGO-Liste
Hilfe zum PBXB64-Compiler

LOGO LAST - Liefert das letzte Element einer LOGO-Liste

Art: LOGO command/expression | Category: LOGO Frontend / Lists

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Liefert das letzte Element einer LOGO-Liste.

Syntax

LAST

Beschreibung

LAST ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Lists verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie LAST, wenn das Programm einen LOGO-Listenwert aufbauen oder pruefen muss. Die Seite sollte die exakte Listenform vor und nach der Operation zeigen, damit der Aufrufer erkennt, ob der Befehl eine Liste erzeugt, kuerzt oder ein Listenelement extrahiert hat.

Fehlerfaelle

Listenbefehle scheitern, wenn der Aufrufer eine andere Listenform, eine Nicht-Liste als Eingabe oder eine andere Nummerierungsregel annimmt. Das Beispiel sollte die Eingangsliste und die exakte Ergebnisliste oder das Listenelement zeigen, damit der Formvertrag sichtbar wird.

Fokussiertes Beispiel

PRINT LAST LIST 1 42

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_list.lgo

; Test list primitives
TO test_list
  MAKE "a LIST 10 20
  PRINT FIRST :a
  PRINT LAST :a
  PRINT ITEM 1 :a
  PRINT ITEM 2 :a
  MAKE "b FPUT 5 :a
  PRINT FIRST :b
  MAKE "c LPUT 30 :a
  PRINT LAST :c
  MAKE "d BUTFIRST :a
  PRINT FIRST :d
  MAKE "e BUTLAST :a
  PRINT LAST :e
END

test_list

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO BUTFIRST - Liefert eine Liste ohne erstes Element - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Lists › LOGO BUTFIRST - Liefert eine Liste ohne erstes Element
Hilfe zum PBXB64-Compiler

LOGO BUTFIRST - Liefert eine Liste ohne erstes Element

Art: LOGO command/expression | Category: LOGO Frontend / Lists

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Liefert eine Liste ohne erstes Element.

Syntax

BUTFIRST

Beschreibung

BUTFIRST ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Lists verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie BUTFIRST, wenn das Programm einen LOGO-Listenwert aufbauen oder pruefen muss. Die Seite sollte die exakte Listenform vor und nach der Operation zeigen, damit der Aufrufer erkennt, ob der Befehl eine Liste erzeugt, kuerzt oder ein Listenelement extrahiert hat.

Fehlerfaelle

Listenbefehle scheitern, wenn der Aufrufer eine andere Listenform, eine Nicht-Liste als Eingabe oder eine andere Nummerierungsregel annimmt. Das Beispiel sollte die Eingangsliste und die exakte Ergebnisliste oder das Listenelement zeigen, damit der Formvertrag sichtbar wird.

Fokussiertes Beispiel

MAKE "tail BUTFIRST LIST 1 2 3

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_list.lgo

; Test list primitives
TO test_list
  MAKE "a LIST 10 20
  PRINT FIRST :a
  PRINT LAST :a
  PRINT ITEM 1 :a
  PRINT ITEM 2 :a
  MAKE "b FPUT 5 :a
  PRINT FIRST :b
  MAKE "c LPUT 30 :a
  PRINT LAST :c
  MAKE "d BUTFIRST :a
  PRINT FIRST :d
  MAKE "e BUTLAST :a
  PRINT LAST :e
END

test_list

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO BUTLAST - Liefert eine Liste ohne letztes Element - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Lists › LOGO BUTLAST - Liefert eine Liste ohne letztes Element
Hilfe zum PBXB64-Compiler

LOGO BUTLAST - Liefert eine Liste ohne letztes Element

Art: LOGO command/expression | Category: LOGO Frontend / Lists

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Liefert eine Liste ohne letztes Element.

Syntax

BUTLAST

Beschreibung

BUTLAST ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Lists verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie BUTLAST, wenn das Programm einen LOGO-Listenwert aufbauen oder pruefen muss. Die Seite sollte die exakte Listenform vor und nach der Operation zeigen, damit der Aufrufer erkennt, ob der Befehl eine Liste erzeugt, kuerzt oder ein Listenelement extrahiert hat.

Fehlerfaelle

Listenbefehle scheitern, wenn der Aufrufer eine andere Listenform, eine Nicht-Liste als Eingabe oder eine andere Nummerierungsregel annimmt. Das Beispiel sollte die Eingangsliste und die exakte Ergebnisliste oder das Listenelement zeigen, damit der Formvertrag sichtbar wird.

Fokussiertes Beispiel

MAKE "head BUTLAST LIST 1 2 3

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_list.lgo

; Test list primitives
TO test_list
  MAKE "a LIST 10 20
  PRINT FIRST :a
  PRINT LAST :a
  PRINT ITEM 1 :a
  PRINT ITEM 2 :a
  MAKE "b FPUT 5 :a
  PRINT FIRST :b
  MAKE "c LPUT 30 :a
  PRINT LAST :c
  MAKE "d BUTFIRST :a
  PRINT FIRST :d
  MAKE "e BUTLAST :a
  PRINT LAST :e
END

test_list

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO ITEM - Liefert ein indiziertes Element aus einer LOGO-Liste - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Lists › LOGO ITEM - Liefert ein indiziertes Element aus einer LOGO-Liste
Hilfe zum PBXB64-Compiler

LOGO ITEM - Liefert ein indiziertes Element aus einer LOGO-Liste

Art: LOGO command/expression | Category: LOGO Frontend / Lists

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Liefert ein indiziertes Element aus einer LOGO-Liste.

Syntax

ITEM

Beschreibung

ITEM ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Lists verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie ITEM, wenn das Programm einen LOGO-Listenwert aufbauen oder pruefen muss. Die Seite sollte die exakte Listenform vor und nach der Operation zeigen, damit der Aufrufer erkennt, ob der Befehl eine Liste erzeugt, kuerzt oder ein Listenelement extrahiert hat.

Fehlerfaelle

Listenbefehle scheitern, wenn der Aufrufer eine andere Listenform, eine Nicht-Liste als Eingabe oder eine andere Nummerierungsregel annimmt. Das Beispiel sollte die Eingangsliste und die exakte Ergebnisliste oder das Listenelement zeigen, damit der Formvertrag sichtbar wird.

Fokussiertes Beispiel

PRINT ITEM 2 LIST 1 42 3

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_list.lgo

; Test list primitives
TO test_list
  MAKE "a LIST 10 20
  PRINT FIRST :a
  PRINT LAST :a
  PRINT ITEM 1 :a
  PRINT ITEM 2 :a
  MAKE "b FPUT 5 :a
  PRINT FIRST :b
  MAKE "c LPUT 30 :a
  PRINT LAST :c
  MAKE "d BUTFIRST :a
  PRINT FIRST :d
  MAKE "e BUTLAST :a
  PRINT LAST :e
END

test_list

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO FPUT - Fuegt ein Element vorne in eine LOGO-Liste ein - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Lists › LOGO FPUT - Fuegt ein Element vorne in eine LOGO-Liste ein
Hilfe zum PBXB64-Compiler

LOGO FPUT - Fuegt ein Element vorne in eine LOGO-Liste ein

Art: LOGO command/expression | Category: LOGO Frontend / Lists

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Fuegt ein Element vorne in eine LOGO-Liste ein.

Syntax

FPUT

Beschreibung

FPUT ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Lists verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie FPUT, wenn das Programm einen LOGO-Listenwert aufbauen oder pruefen muss. Die Seite sollte die exakte Listenform vor und nach der Operation zeigen, damit der Aufrufer erkennt, ob der Befehl eine Liste erzeugt, kuerzt oder ein Listenelement extrahiert hat.

Fehlerfaelle

Listenbefehle scheitern, wenn der Aufrufer eine andere Listenform, eine Nicht-Liste als Eingabe oder eine andere Nummerierungsregel annimmt. Das Beispiel sollte die Eingangsliste und die exakte Ergebnisliste oder das Listenelement zeigen, damit der Formvertrag sichtbar wird.

Fokussiertes Beispiel

MAKE "xs FPUT 1 LIST 2 3

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_list.lgo

; Test list primitives
TO test_list
  MAKE "a LIST 10 20
  PRINT FIRST :a
  PRINT LAST :a
  PRINT ITEM 1 :a
  PRINT ITEM 2 :a
  MAKE "b FPUT 5 :a
  PRINT FIRST :b
  MAKE "c LPUT 30 :a
  PRINT LAST :c
  MAKE "d BUTFIRST :a
  PRINT FIRST :d
  MAKE "e BUTLAST :a
  PRINT LAST :e
END

test_list

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOGO LPUT - Haengt ein Element an das Ende einer LOGO-Liste an - PBXB64 LOGO Help

Startseite › BASIC Frontend › LOGO Lists › LOGO LPUT - Haengt ein Element an das Ende einer LOGO-Liste an
Hilfe zum PBXB64-Compiler

LOGO LPUT - Haengt ein Element an das Ende einer LOGO-Liste an

Art: LOGO command/expression | Category: LOGO Frontend / Lists

PBXB64 Status: AVAILABLE

PBXB64 Certification: [VERIFIZIERTES BEISPIEL]

Funktion

Haengt ein Element an das Ende einer LOGO-Liste an.

Syntax

LPUT

Beschreibung

LPUT ist im PBXB64-LOGO-Frontend als Befehl aus dem Bereich Lists verfuegbar. Turtle- und Bildschirmbefehle aendern den Zeichenzustand; Variablen-, Kontrollfluss-, Mathematik- und Listenbefehle aendern den LOGO-Programmzustand.

Numerische Ausdruecke verwenden im aktuellen LOGO-Frontend Double-Precision-Werte. Variablen werden als :name referenziert und ueber MAKE "name value zugewiesen. Bloecke verwenden eckige Klammern.

Verwendung im Programm

Verwenden Sie LPUT, wenn das Programm einen LOGO-Listenwert aufbauen oder pruefen muss. Die Seite sollte die exakte Listenform vor und nach der Operation zeigen, damit der Aufrufer erkennt, ob der Befehl eine Liste erzeugt, kuerzt oder ein Listenelement extrahiert hat.

Fehlerfaelle

Listenbefehle scheitern, wenn der Aufrufer eine andere Listenform, eine Nicht-Liste als Eingabe oder eine andere Nummerierungsregel annimmt. Das Beispiel sollte die Eingangsliste und die exakte Ergebnisliste oder das Listenelement zeigen, damit der Formvertrag sichtbar wird.

Fokussiertes Beispiel

MAKE "xs LPUT 3 LIST 1 2

Verifiziertes Beispiel

Beispieldatei: examples/logo/test_list.lgo

; Test list primitives
TO test_list
  MAKE "a LIST 10 20
  PRINT FIRST :a
  PRINT LAST :a
  PRINT ITEM 1 :a
  PRINT ITEM 2 :a
  MAKE "b FPUT 5 :a
  PRINT FIRST :b
  MAKE "c LPUT 30 :a
  PRINT LAST :c
  MAKE "d BUTFIRST :a
  PRINT FIRST :d
  MAKE "e BUTLAST :a
  PRINT LAST :e
END

test_list

Dieses Beispiel wurde mit core/build/PBXB64.exe kompiliert; die erzeugte EXE lieferte Exitcode 0.

Pruefung

Ein eigenstaendiges LOGO-Beispiel mit PBXB64 sample.lgo -o sample.exe kompilieren, nachdem das Beispiel in einer LOGO-Quelldatei gespeichert wurde. Bei zertifizierten Eintraegen wurde die oben genannte Beispieldatei kompiliert und mit Exitcode 0 ausgefuehrt.

Grenzen

Diese Seite dokumentiert nur das implementierte PBXB64-Verhalten. Sie behauptet keine vollstaendige LOGO-Dialektkompatibilitaet, zusaetzliche Aliase, Dateiwoerter, Workspace-Verwaltung oder erweiterte Listen-/String-Semantik, sofern keine andere fokussierte Seite diese dokumentiert und prueft.

Siehe auch

  • LOGO Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SPR/MRT-Frontend - PBXB64 Help

Startseite › BASIC Frontend › SPR Frontend

SPR/MRT-Frontend

PBXB64 klassifiziert .mrt-Dateien als native SPR-Frontend-Eingaben. Die implementierte Befehlsoberflaeche verwendet dreibuchstabige Befehle mit abschliessendem Punkt und Parametern, die durch senkrechte Striche getrennt sind.

Befehlsgruppen

Program Control

  • VAR.
  • JMP.
  • GTO.
  • GSB.
  • JSR.
  • RET.
  • ENR.
  • END.
  • DBP.

Conditions

  • IFC.
  • IEV.
  • ELS.
  • EIF.
  • IVB.
  • NVB.
  • IVC.
  • IVP.
  • NVP.
  • IVS.
  • IVV.
  • NEV.
  • NVC.
  • NWC.

Loops and Strings

  • FOR.
  • NEX.
  • DOL.
  • OOP.
  • BRK.
  • CON.
  • CAT.
  • LEN.
  • GSS.
  • RPL.
  • VBT.
  • VLT.
  • VRT.
  • VTL.
  • VTU.

Variables and Math

  • VIC.
  • VDC.
  • RND.
  • VAS.
  • VAU.
  • VAB.
  • VAO.
  • VAI.
  • GVT.
  • CLV.
  • SAV.
  • CAL.
  • CAX.
  • EVA.
  • BIT.
  • FMT.

File and Text I/O

  • CFF.
  • CTF.
  • ATF.
  • IEF.
  • NEF.
  • MKD.
  • SHF.
  • COP.
  • MBT.
  • MBX.
  • DCP.
  • GUT.
  • PRT.
  • OUT.
  • RES.
  • USM.
  • GSC.
  • SBD.
  • SBM.
  • CSP.
  • VRD.
  • ASC.
  • CHR.
  • FEX.
  • FEF.
  • FEL.
  • FEM.
  • FEV.
  • FEP.
  • FES.
  • FER.
  • EFX.
  • FEN.

System and Memory

  • EXE.
  • EXB.
  • EXF.
  • EXO.
  • EXX.
  • KEY.
  • KPR.
  • KRL.
  • MAP.
  • MAW.
  • MDC.
  • MEL.
  • MEM.
  • MLC.
  • MMV.
  • MPO.
  • MRC.
  • MRE.
  • SCW.
  • STW.
  • CLW.
  • HTV.

Pruefung

Jede Befehlsseite ist ein nutzerorientierter Eintrag mit Syntax, Parametern, Verhalten, Grenzen und einem fokussierten .mrt-Beispiel. Breitere Sprachvollstaendigkeit wird nur dort behauptet, wo ein fokussiertes Beispiel oder eine Validierungsspur sie belegt.

Grenzen

Nur dokumentierte Befehle gelten als von der Hilfe abgedeckte Oberflaeche. GUI-, Datei-, System- und Speicherbefehle koennen vom Windows-Laufzeitzustand abhaengen und sollen mit expliziter erwarteter Ausgabe oder Zustandsaenderung getestet werden.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VAR. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Program Control › VAR.
Hilfe zum PBXB64-Compiler

VAR.

Variablenzuweisung - Programmsteuerungsbefehle fuer Variablen, Labels, Subroutinen, Programmende und Diagnoseausgabe.

Kind: SPR-Befehl | Category: SPR Frontend / Program Control

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

VAR. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `VAR.$$TGT=value / VAR.$$TGT+text`.

Syntax

VAR.$$TGT=value / VAR.$$TGT+text

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Parameter

# | Name/Form | Bedeutung
P1 | $$TGT | erforderliche Zielvariable
P2 | value / VAR.$$TGT+text | erforderlicher Wert

Verwendung

  • Setzen Sie den Befehl dort ein, wo das Skript verzweigen, ein Unterprogramm aufrufen oder beenden soll, und machen Sie die umgebende Label-Struktur im Beispiel sichtbar.
  • Wenn der Befehl den Ruecksprung beeinflusst, zeigen Sie die naechste Anweisung nach dem Sprung, damit der Kontrollfluss klar bleibt.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_var.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$AAA=start
VAR.$$AAA+tail
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_var.mrt. Kompilieren mit PBXB64 examples/spr/spr_var.mrt -o spr_var.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


JMP. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Program Control › JMP.
Hilfe zum PBXB64-Compiler

JMP.

Sprung - Programmsteuerungsbefehle fuer Variablen, Labels, Subroutinen, Programmende und Diagnoseausgabe.

Kind: SPR-Befehl | Category: SPR Frontend / Program Control

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

Springt zu einem Label oder ruft ein Label wie ein Unterprogramm auf, abhaengig vom Label-Marker.

Syntax

JMP.label

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Parameter

# | Name/Form | Bedeutung
P1 | label | erforderlich

Verwendung

  • Setzen Sie den Befehl dort ein, wo das Skript verzweigen, ein Unterprogramm aufrufen oder beenden soll, und machen Sie die umgebende Label-Struktur im Beispiel sichtbar.
  • Wenn der Befehl den Ruecksprung beeinflusst, zeigen Sie die naechste Anweisung nach dem Sprung, damit der Kontrollfluss klar bleibt.

Beschreibung

  • `JMP.label` ist ein normaler GOTO-Sprung und kehrt nicht automatisch zur Folgezeile zurueck.
  • `JMP.:label` ist ein GOSUB-Sprung; ein spaeteres `RET.` kehrt zur Anweisung nach `JMP.` zurueck.
  • Zwischen Befehl und Parameter darf kein Leerzeichen stehen; `JMP.:label` ist gueltig, `JMP. :label` ist ungueltig.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

JMP.:DONE
VAR.$$AAA=1
:DONE
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_jmp.mrt. Kompilieren mit PBXB64 examples/spr/spr_jmp.mrt -o spr_jmp.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Das Label muss im selben `.mrt`-Block existieren. Nur `JMP.` wechselt bei einem Ziel mit fuehrendem `:` in den GOSUB-Modus.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GTO. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Program Control › GTO.
Hilfe zum PBXB64-Compiler

GTO.

Gehe zu - Programmsteuerungsbefehle fuer Variablen, Labels, Subroutinen, Programmende und Diagnoseausgabe.

Kind: SPR-Befehl | Category: SPR Frontend / Program Control

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

GTO. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `GTO.label`.

Syntax

GTO.label

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Parameter

# | Name/Form | Bedeutung
P1 | label | erforderlich

Verwendung

  • Setzen Sie den Befehl dort ein, wo das Skript verzweigen, ein Unterprogramm aufrufen oder beenden soll, und machen Sie die umgebende Label-Struktur im Beispiel sichtbar.
  • Wenn der Befehl den Ruecksprung beeinflusst, zeigen Sie die naechste Anweisung nach dem Sprung, damit der Kontrollfluss klar bleibt.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_gto.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

GTO.:DONE
VAR.$$AAA=1
:DONE
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_gto.mrt. Kompilieren mit PBXB64 examples/spr/spr_gto.mrt -o spr_gto.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GSB. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Program Control › GSB.
Hilfe zum PBXB64-Compiler

GSB.

Unterprogrammaufruf - Programmsteuerungsbefehle fuer Variablen, Labels, Subroutinen, Programmende und Diagnoseausgabe.

Kind: SPR-Befehl | Category: SPR Frontend / Program Control

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

Ruft ein Label als Unterprogramm auf.

Syntax

GSB.:label[|arg...]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | :label | erforderlich
P2 | arg... | optional

Verwendung

  • Setzen Sie den Befehl dort ein, wo das Skript verzweigen, ein Unterprogramm aufrufen oder beenden soll, und machen Sie die umgebende Label-Struktur im Beispiel sichtbar.
  • Wenn der Befehl den Ruecksprung beeinflusst, zeigen Sie die naechste Anweisung nach dem Sprung, damit der Kontrollfluss klar bleibt.

Beschreibung

  • Die Ruecksprungadresse wird gespeichert und die Ausfuehrung verzweigt zum Label.
  • Ein spaeteres `RET.` kehrt zur Anweisung nach dem `GSB.`-Aufruf zurueck.
  • Optionale Argumente nach dem Label werden vor dem Sprung in lokale SPR-Variablen kopiert: `$$000` enthaelt die Anzahl, `$$001` das erste Argument, `$$002` das zweite.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

GSB.:SUB
END.
:SUB
VAR.$$AAA=42
RET.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_gsb.mrt. Kompilieren mit PBXB64 examples/spr/spr_gsb.mrt -o spr_gsb.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Die fokussierte Validierung deckt die einfache aktive Aufrufform ab; beliebig verschachtelte oder wiederholte Ruecksprung-Stack-Paritaet bleibt breitere SPR-Arbeit.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


JSR. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Program Control › JSR.
Hilfe zum PBXB64-Compiler

JSR.

Sprung ins Unterprogramm - Programmsteuerungsbefehle fuer Variablen, Labels, Subroutinen, Programmende und Diagnoseausgabe.

Kind: SPR-Befehl | Category: SPR Frontend / Program Control

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

Ruft ein Label als Unterprogramm mit optionalen lokalen Parametern auf.

Syntax

JSR.:label[|arg...]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | :label | erforderlich
P2 | arg... | optional

Verwendung

  • Setzen Sie den Befehl dort ein, wo das Skript verzweigen, ein Unterprogramm aufrufen oder beenden soll, und machen Sie die umgebende Label-Struktur im Beispiel sichtbar.
  • Wenn der Befehl den Ruecksprung beeinflusst, zeigen Sie die naechste Anweisung nach dem Sprung, damit der Kontrollfluss klar bleibt.

Beschreibung

  • `JSR.:label|arg1|arg2` entspricht der originalen MiniRobot-Parameterform.
  • Der Aufruf speichert die Ruecksprungadresse, fuellt `$$000`, `$$001`, `$$002` und `RET.` setzt danach hinter dem `JSR.` fort.
  • Die Parameter werden in der dokumentierten Reihenfolge in die lokalen Rueckgabefelder uebernommen; historische Varianten mit anderer Bindung brauchen einen eigenen fokussierten Test.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

JSR.:SUB
END.
:SUB
VAR.$$AAA=42
RET.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_jsr.mrt. Kompilieren mit PBXB64 examples/spr/spr_jsr.mrt -o spr_jsr.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Das Ziel-Label muss existieren.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RET. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Program Control › RET.
Hilfe zum PBXB64-Compiler

RET.

Rueckkehr - Programmsteuerungsbefehle fuer Variablen, Labels, Subroutinen, Programmende und Diagnoseausgabe.

Kind: SPR-Befehl | Category: SPR Frontend / Program Control

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

Kehrt vom letzten `GSB.`- oder `JSR.`-Aufruf zurueck.

Syntax

RET.

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Keine Parameter.

Verwendung

  • Setzen Sie den Befehl dort ein, wo das Skript verzweigen, ein Unterprogramm aufrufen oder beenden soll, und machen Sie die umgebende Label-Struktur im Beispiel sichtbar.
  • Wenn der Befehl den Ruecksprung beeinflusst, zeigen Sie die naechste Anweisung nach dem Sprung, damit der Kontrollfluss klar bleibt.

Beschreibung

  • Die Ausfuehrung wird am gespeicherten Ruecksprungblock fortgesetzt.
  • `RET.` nimmt keine Parameter an.
  • Ein `RET.` ohne passenden Unterprogrammaufruf ist ein Compilezeitfehler.
  • Der belegte Vertrag umfasst die Rueckkehr zur Anweisung direkt nach dem letzten aktiven Unterprogrammaufruf.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

GSB.:SUB
END.
:SUB
RET.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_ret.mrt. Kompilieren mit PBXB64 examples/spr/spr_ret.mrt -o spr_ret.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Nur in Code verwenden, der ueber `GSB.` oder `JSR.` erreicht wird. Verschachtelte oder alternative historische Ruecksprungmodelle bleiben ausserhalb dieser Seite, bis sie durch eigene SPR-Link/Run-Tests belegt sind.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ENR. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Program Control › ENR.
Hilfe zum PBXB64-Compiler

ENR.

Ende mit Rueckkehr - Programmsteuerungsbefehle fuer Variablen, Labels, Subroutinen, Programmende und Diagnoseausgabe.

Kind: SPR-Befehl | Category: SPR Frontend / Program Control

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

ENR. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `ENR.`.

Syntax

ENR.

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Keine Parameter.

Verwendung

  • Setzen Sie den Befehl dort ein, wo das Skript verzweigen, ein Unterprogramm aufrufen oder beenden soll, und machen Sie die umgebende Label-Struktur im Beispiel sichtbar.
  • Wenn der Befehl den Ruecksprung beeinflusst, zeigen Sie die naechste Anweisung nach dem Sprung, damit der Kontrollfluss klar bleibt.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_enr.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

ENR.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_enr.mrt. Kompilieren mit PBXB64 examples/spr/spr_enr.mrt -o spr_enr.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


END. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Program Control › END.
Hilfe zum PBXB64-Compiler

END.

Ende - Programmsteuerungsbefehle fuer Variablen, Labels, Subroutinen, Programmende und Diagnoseausgabe.

Kind: SPR-Befehl | Category: SPR Frontend / Program Control

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

END. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `END.`.

Syntax

END.

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Keine Parameter.

Verwendung

  • Setzen Sie den Befehl dort ein, wo das Skript verzweigen, ein Unterprogramm aufrufen oder beenden soll, und machen Sie die umgebende Label-Struktur im Beispiel sichtbar.
  • Wenn der Befehl den Ruecksprung beeinflusst, zeigen Sie die naechste Anweisung nach dem Sprung, damit der Kontrollfluss klar bleibt.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_end.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_end.mrt. Kompilieren mit PBXB64 examples/spr/spr_end.mrt -o spr_end.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


DBP. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Program Control › DBP.
Hilfe zum PBXB64-Compiler

DBP.

Debug-Ausgabe - Programmsteuerungsbefehle fuer Variablen, Labels, Subroutinen, Programmende und Diagnoseausgabe.

Kind: SPR-Befehl | Category: SPR Frontend / Program Control

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

DBP. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `DBP.[text]`.

Syntax

DBP.[text]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | text | optional

Verwendung

  • Setzen Sie den Befehl dort ein, wo das Skript verzweigen, ein Unterprogramm aufrufen oder beenden soll, und machen Sie die umgebende Label-Struktur im Beispiel sichtbar.
  • Wenn der Befehl den Ruecksprung beeinflusst, zeigen Sie die naechste Anweisung nach dem Sprung, damit der Kontrollfluss klar bleibt.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_dbp.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

DBP.SPR debug print
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_dbp.mrt. Kompilieren mit PBXB64 examples/spr/spr_dbp.mrt -o spr_dbp.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


IFC. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Conditions › IFC.
Hilfe zum PBXB64-Compiler

IFC.

Fuzzy-Vergleich - Bedingungsbefehle zum Vergleichen von Werten und Auswaehlen von Bloecken.

Kind: SPR-Befehl | Category: SPR Frontend / Conditions

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

IFC. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `IFC.textA|textB|threshold[|m]`.

Syntax

IFC.textA|textB|threshold[|m]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | textA | erforderlich
P2 | textB | erforderlich
P3 | threshold | erforderlich
P4 | m | optional

Verwendung

  • Bereiten Sie den geprueften Wert vor der Bedingung vor, damit das Beispiel genau zeigt, was verglichen wird und welcher Zweig betreten wird.
  • Dokumentieren Sie, ob der Befehl bei Erfolg, bei Abweichung oder bei Bereichs-/Musterpruefung verzweigt, weil genau das beim Programmieren relevant ist.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_ifc.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Nennen Sie, ob der Befehl bei fehlgeschlagener Bedingung durchfaellt und ob das Ergebnisziel einen numerischen Score oder Vergleichswert erhaelt.
  • Wenn ein passendes Label oder ein Block fehlt, soll die Seite sagen, dass das Beispiel absichtlich unvollstaendig ist und beim Kompilieren oder Linken fehlschlaegt.

Beispiel

VAR.$$AAA=alpha
VAR.$$BBB=alpha
IFC.$$AAA|$$BBB|0
EIF.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_ifc.mrt. Kompilieren mit PBXB64 examples/spr/spr_ifc.mrt -o spr_ifc.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


IEV. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Conditions › IEV.
Hilfe zum PBXB64-Compiler

IEV.

Variable existiert - Bedingungsbefehle zum Vergleichen von Werten und Auswaehlen von Bloecken.

Kind: SPR-Befehl | Category: SPR Frontend / Conditions

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

IEV. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `IEV.$$VAR[|label]`.

Syntax

IEV.$$VAR[|label]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | $$VAR | erforderlich
P2 | label | optional

Verwendung

  • Bereiten Sie den geprueften Wert vor der Bedingung vor, damit das Beispiel genau zeigt, was verglichen wird und welcher Zweig betreten wird.
  • Dokumentieren Sie, ob der Befehl bei Erfolg, bei Abweichung oder bei Bereichs-/Musterpruefung verzweigt, weil genau das beim Programmieren relevant ist.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_iev.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Nennen Sie, ob der Befehl bei fehlgeschlagener Bedingung durchfaellt und ob das Ergebnisziel einen numerischen Score oder Vergleichswert erhaelt.
  • Wenn ein passendes Label oder ein Block fehlt, soll die Seite sagen, dass das Beispiel absichtlich unvollstaendig ist und beim Kompilieren oder Linken fehlschlaegt.

Beispiel

VAR.$$AAA=value
IEV.$$AAA
EIF.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_iev.mrt. Kompilieren mit PBXB64 examples/spr/spr_iev.mrt -o spr_iev.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ELS. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Conditions › ELS.
Hilfe zum PBXB64-Compiler

ELS.

Sonst-Zweig - Bedingungsbefehle zum Vergleichen von Werten und Auswaehlen von Bloecken.

Kind: SPR-Befehl | Category: SPR Frontend / Conditions

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

ELS. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `ELS.`.

Syntax

ELS.

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Keine Parameter.

Verwendung

  • Bereiten Sie den geprueften Wert vor der Bedingung vor, damit das Beispiel genau zeigt, was verglichen wird und welcher Zweig betreten wird.
  • Dokumentieren Sie, ob der Befehl bei Erfolg, bei Abweichung oder bei Bereichs-/Musterpruefung verzweigt, weil genau das beim Programmieren relevant ist.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_els.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Nennen Sie, ob der Befehl bei fehlgeschlagener Bedingung durchfaellt und ob das Ergebnisziel einen numerischen Score oder Vergleichswert erhaelt.
  • Wenn ein passendes Label oder ein Block fehlt, soll die Seite sagen, dass das Beispiel absichtlich unvollstaendig ist und beim Kompilieren oder Linken fehlschlaegt.

Beispiel

VAR.$$AAA=5
IVB.$$AAA|0|2
VAR.$$BBB=1
ELS.
VAR.$$BBB=2
EIF.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_els.mrt. Kompilieren mit PBXB64 examples/spr/spr_els.mrt -o spr_els.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


EIF. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Conditions › EIF.
Hilfe zum PBXB64-Compiler

EIF.

Ende der Bedingung - Bedingungsbefehle zum Vergleichen von Werten und Auswaehlen von Bloecken.

Kind: SPR-Befehl | Category: SPR Frontend / Conditions

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

EIF. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `EIF.`.

Syntax

EIF.

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Keine Parameter.

Verwendung

  • Bereiten Sie den geprueften Wert vor der Bedingung vor, damit das Beispiel genau zeigt, was verglichen wird und welcher Zweig betreten wird.
  • Dokumentieren Sie, ob der Befehl bei Erfolg, bei Abweichung oder bei Bereichs-/Musterpruefung verzweigt, weil genau das beim Programmieren relevant ist.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_eif.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Nennen Sie, ob der Befehl bei fehlgeschlagener Bedingung durchfaellt und ob das Ergebnisziel einen numerischen Score oder Vergleichswert erhaelt.
  • Wenn ein passendes Label oder ein Block fehlt, soll die Seite sagen, dass das Beispiel absichtlich unvollstaendig ist und beim Kompilieren oder Linken fehlschlaegt.

Beispiel

VAR.$$AAA=1
IVB.$$AAA|0|2
EIF.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_eif.mrt. Kompilieren mit PBXB64 examples/spr/spr_eif.mrt -o spr_eif.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


IVB. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Conditions › IVB.
Hilfe zum PBXB64-Compiler

IVB.

Variable im Bereich - Bedingungsbefehle zum Vergleichen von Werten und Auswaehlen von Bloecken.

Kind: SPR-Befehl | Category: SPR Frontend / Conditions

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

IVB. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `IVB.$$VAR|min|max[|label]`.

Syntax

IVB.$$VAR|min|max[|label]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | $$VAR | erforderlich
P2 | min | erforderlich
P3 | max | erforderlich
P4 | label | optional

Verwendung

  • Bereiten Sie den geprueften Wert vor der Bedingung vor, damit das Beispiel genau zeigt, was verglichen wird und welcher Zweig betreten wird.
  • Dokumentieren Sie, ob der Befehl bei Erfolg, bei Abweichung oder bei Bereichs-/Musterpruefung verzweigt, weil genau das beim Programmieren relevant ist.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_ivb.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Nennen Sie, ob der Befehl bei fehlgeschlagener Bedingung durchfaellt und ob das Ergebnisziel einen numerischen Score oder Vergleichswert erhaelt.
  • Wenn ein passendes Label oder ein Block fehlt, soll die Seite sagen, dass das Beispiel absichtlich unvollstaendig ist und beim Kompilieren oder Linken fehlschlaegt.

Beispiel

VAR.$$AAA=1
IVB.$$AAA|0|2
EIF.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_ivb.mrt. Kompilieren mit PBXB64 examples/spr/spr_ivb.mrt -o spr_ivb.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


IVC. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Conditions › IVC.
Hilfe zum PBXB64-Compiler

IVC.

Variable enthaelt - Bedingungsbefehle zum Vergleichen von Werten und Auswaehlen von Bloecken.

Kind: SPR-Befehl | Category: SPR Frontend / Conditions

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

IVC. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `IVC.$$VAR|operator|value[|label][|e]`.

Syntax

IVC.$$VAR|operator|value[|label][|e]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | $$VAR | erforderlich
P2 | operator | erforderlich
P3 | value | erforderlich
P4 | label | optional
P5 | e | optional

Verwendung

  • Bereiten Sie den geprueften Wert vor der Bedingung vor, damit das Beispiel genau zeigt, was verglichen wird und welcher Zweig betreten wird.
  • Dokumentieren Sie, ob der Befehl bei Erfolg, bei Abweichung oder bei Bereichs-/Musterpruefung verzweigt, weil genau das beim Programmieren relevant ist.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_ivc.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Nennen Sie, ob der Befehl bei fehlgeschlagener Bedingung durchfaellt und ob das Ergebnisziel einen numerischen Score oder Vergleichswert erhaelt.
  • Wenn ein passendes Label oder ein Block fehlt, soll die Seite sagen, dass das Beispiel absichtlich unvollstaendig ist und beim Kompilieren oder Linken fehlschlaegt.

Beispiel

VAR.$$AAA=5
IVC.$$AAA|=|5
EIF.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_ivc.mrt. Kompilieren mit PBXB64 examples/spr/spr_ivc.mrt -o spr_ivc.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


IVP. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Conditions › IVP.
Hilfe zum PBXB64-Compiler

IVP.

Variablenmuster - Bedingungsbefehle zum Vergleichen von Werten und Auswaehlen von Bloecken.

Kind: SPR-Befehl | Category: SPR Frontend / Conditions

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

IVP. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `IVP.$$VAR=pattern[|label][|e]`.

Syntax

IVP.$$VAR=pattern[|label][|e]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | $$VAR=pattern | erforderlich
P2 | label | optional
P3 | e | optional

Verwendung

  • Bereiten Sie den geprueften Wert vor der Bedingung vor, damit das Beispiel genau zeigt, was verglichen wird und welcher Zweig betreten wird.
  • Dokumentieren Sie, ob der Befehl bei Erfolg, bei Abweichung oder bei Bereichs-/Musterpruefung verzweigt, weil genau das beim Programmieren relevant ist.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_ivp.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Nennen Sie, ob der Befehl bei fehlgeschlagener Bedingung durchfaellt und ob das Ergebnisziel einen numerischen Score oder Vergleichswert erhaelt.
  • Wenn ein passendes Label oder ein Block fehlt, soll die Seite sagen, dass das Beispiel absichtlich unvollstaendig ist und beim Kompilieren oder Linken fehlschlaegt.

Beispiel

VAR.$$AAA=abc
IVP.$$AAA=abc
EIF.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_ivp.mrt. Kompilieren mit PBXB64 examples/spr/spr_ivp.mrt -o spr_ivp.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


IVS. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Conditions › IVS.
Hilfe zum PBXB64-Compiler

IVS.

Zeichenkettenvergleich - Bedingungsbefehle zum Vergleichen von Werten und Auswaehlen von Bloecken.

Kind: SPR-Befehl | Category: SPR Frontend / Conditions

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

IVS. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `IVS.$$VAR|string[|label]`.

Syntax

IVS.$$VAR|string[|label]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | $$VAR | erforderlich
P2 | string | erforderlich
P3 | label | optional

Verwendung

  • Bereiten Sie den geprueften Wert vor der Bedingung vor, damit das Beispiel genau zeigt, was verglichen wird und welcher Zweig betreten wird.
  • Dokumentieren Sie, ob der Befehl bei Erfolg, bei Abweichung oder bei Bereichs-/Musterpruefung verzweigt, weil genau das beim Programmieren relevant ist.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_ivs.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Nennen Sie, ob der Befehl bei fehlgeschlagener Bedingung durchfaellt und ob das Ergebnisziel einen numerischen Score oder Vergleichswert erhaelt.
  • Wenn ein passendes Label oder ein Block fehlt, soll die Seite sagen, dass das Beispiel absichtlich unvollstaendig ist und beim Kompilieren oder Linken fehlschlaegt.

Beispiel

VAR.$$AAA=text
IVS.$$AAA|text
DBP.ok
EIF.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_ivs.mrt. Kompilieren mit PBXB64 examples/spr/spr_ivs.mrt -o spr_ivs.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


IVV. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Conditions › IVV.
Hilfe zum PBXB64-Compiler

IVV.

Variablenwert - Bedingungsbefehle zum Vergleichen von Werten und Auswaehlen von Bloecken.

Kind: SPR-Befehl | Category: SPR Frontend / Conditions

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

IVV. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `IVV.$$VAR|value[|label]`.

Syntax

IVV.$$VAR|value[|label]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | $$VAR | erforderlich
P2 | value | erforderlich
P3 | label | optional

Verwendung

  • Bereiten Sie den geprueften Wert vor der Bedingung vor, damit das Beispiel genau zeigt, was verglichen wird und welcher Zweig betreten wird.
  • Dokumentieren Sie, ob der Befehl bei Erfolg, bei Abweichung oder bei Bereichs-/Musterpruefung verzweigt, weil genau das beim Programmieren relevant ist.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_ivv.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Nennen Sie, ob der Befehl bei fehlgeschlagener Bedingung durchfaellt und ob das Ergebnisziel einen numerischen Score oder Vergleichswert erhaelt.
  • Wenn ein passendes Label oder ein Block fehlt, soll die Seite sagen, dass das Beispiel absichtlich unvollstaendig ist und beim Kompilieren oder Linken fehlschlaegt.

Beispiel

VAR.$$AAA=5
IVV.$$AAA|5
EIF.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_ivv.mrt. Kompilieren mit PBXB64 examples/spr/spr_ivv.mrt -o spr_ivv.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


NEV. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Conditions › NEV.
Hilfe zum PBXB64-Compiler

NEV.

Variable existiert nicht - Bedingungsbefehle zum Vergleichen von Werten und Auswaehlen von Bloecken.

Kind: SPR-Befehl | Category: SPR Frontend / Conditions

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

NEV. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `NEV.$$VAR[|label]`.

Syntax

NEV.$$VAR[|label]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | $$VAR | erforderlich
P2 | label | optional

Verwendung

  • Bereiten Sie den geprueften Wert vor der Bedingung vor, damit das Beispiel genau zeigt, was verglichen wird und welcher Zweig betreten wird.
  • Dokumentieren Sie, ob der Befehl bei Erfolg, bei Abweichung oder bei Bereichs-/Musterpruefung verzweigt, weil genau das beim Programmieren relevant ist.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_nev.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Nennen Sie, ob der Befehl bei fehlgeschlagener Bedingung durchfaellt und ob das Ergebnisziel einen numerischen Score oder Vergleichswert erhaelt.
  • Wenn ein passendes Label oder ein Block fehlt, soll die Seite sagen, dass das Beispiel absichtlich unvollstaendig ist und beim Kompilieren oder Linken fehlschlaegt.

Beispiel

VAR.$$AAA=value
NEV.$$AAA
EIF.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_nev.mrt. Kompilieren mit PBXB64 examples/spr/spr_nev.mrt -o spr_nev.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


NVC. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Conditions › NVC.
Hilfe zum PBXB64-Compiler

NVC.

Variable enthaelt nicht - Bedingungsbefehle zum Vergleichen von Werten und Auswaehlen von Bloecken.

Kind: SPR-Befehl | Category: SPR Frontend / Conditions

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

NVC. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `NVC.$$VAR|operator|value[|label][|e]`.

Syntax

NVC.$$VAR|operator|value[|label][|e]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | $$VAR | erforderlich
P2 | operator | erforderlich
P3 | value | erforderlich
P4 | label | optional
P5 | e | optional

Verwendung

  • Bereiten Sie den geprueften Wert vor der Bedingung vor, damit das Beispiel genau zeigt, was verglichen wird und welcher Zweig betreten wird.
  • Dokumentieren Sie, ob der Befehl bei Erfolg, bei Abweichung oder bei Bereichs-/Musterpruefung verzweigt, weil genau das beim Programmieren relevant ist.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_nvc.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Nennen Sie, ob der Befehl bei fehlgeschlagener Bedingung durchfaellt und ob das Ergebnisziel einen numerischen Score oder Vergleichswert erhaelt.
  • Wenn ein passendes Label oder ein Block fehlt, soll die Seite sagen, dass das Beispiel absichtlich unvollstaendig ist und beim Kompilieren oder Linken fehlschlaegt.

Beispiel

VAR.$$AAA=5
NVC.$$AAA|>|4
EIF.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_nvc.mrt. Kompilieren mit PBXB64 examples/spr/spr_nvc.mrt -o spr_nvc.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


NWC. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Conditions › NWC.
Hilfe zum PBXB64-Compiler

NWC.

Negativer Vergleich - Bedingungsbefehle zum Vergleichen von Werten und Auswaehlen von Bloecken.

Kind: SPR-Befehl | Category: SPR Frontend / Conditions

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

NWC. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `NWC.textA|textB|threshold[|m]`.

Syntax

NWC.textA|textB|threshold[|m]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | textA | erforderlich
P2 | textB | erforderlich
P3 | threshold | erforderlich
P4 | m | optional

Verwendung

  • Bereiten Sie den geprueften Wert vor der Bedingung vor, damit das Beispiel genau zeigt, was verglichen wird und welcher Zweig betreten wird.
  • Dokumentieren Sie, ob der Befehl bei Erfolg, bei Abweichung oder bei Bereichs-/Musterpruefung verzweigt, weil genau das beim Programmieren relevant ist.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_nwc.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Nennen Sie, ob der Befehl bei fehlgeschlagener Bedingung durchfaellt und ob das Ergebnisziel einen numerischen Score oder Vergleichswert erhaelt.
  • Wenn ein passendes Label oder ein Block fehlt, soll die Seite sagen, dass das Beispiel absichtlich unvollstaendig ist und beim Kompilieren oder Linken fehlschlaegt.

Beispiel

VAR.$$AAA=alpha
VAR.$$BBB=beta
NWC.$$AAA|$$BBB|100
EIF.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_nwc.mrt. Kompilieren mit PBXB64 examples/spr/spr_nwc.mrt -o spr_nwc.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FOR. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Loops and Strings › FOR.
Hilfe zum PBXB64-Compiler

FOR.

Zaehlschleife - Schleifenbefehle und Helfer fuer Zeichenketten.

Kind: SPR-Befehl | Category: SPR Frontend / Loops and Strings

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

FOR. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `FOR.$$IDX|start|end[|step]`.

Syntax

FOR.$$IDX|start|end[|step]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | $$IDX | erforderlich
P2 | start | erforderlich
P3 | end | erforderlich
P4 | step | optional

Verwendung

  • Zeigen Sie Anfangswert, Schleifenrumpf und Austrittspfad, damit die Struktur ohne Raten in ein echtes SPR-Programm uebernommen werden kann.
  • Bei String-Helfern muessen Ein- und Ausgabetext exakt sichtbar sein, damit Padding, Trimmen, Splitten oder Ersetzen im Beispiel eindeutig werden.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_for.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$IDX=0
FOR.$$IDX|1|3|1
NEX.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_for.mrt. Kompilieren mit PBXB64 examples/spr/spr_for.mrt -o spr_for.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


NEX. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Loops and Strings › NEX.
Hilfe zum PBXB64-Compiler

NEX.

Naechster Schleifendurchlauf - Schleifenbefehle und Helfer fuer Zeichenketten.

Kind: SPR-Befehl | Category: SPR Frontend / Loops and Strings

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

NEX. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `NEX.`.

Syntax

NEX.

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Keine Parameter.

Verwendung

  • Zeigen Sie Anfangswert, Schleifenrumpf und Austrittspfad, damit die Struktur ohne Raten in ein echtes SPR-Programm uebernommen werden kann.
  • Bei String-Helfern muessen Ein- und Ausgabetext exakt sichtbar sein, damit Padding, Trimmen, Splitten oder Ersetzen im Beispiel eindeutig werden.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_nex.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$IDX=0
FOR.$$IDX|1|1|1
NEX.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_nex.mrt. Kompilieren mit PBXB64 examples/spr/spr_nex.mrt -o spr_nex.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


DOL. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Loops and Strings › DOL.
Hilfe zum PBXB64-Compiler

DOL.

Do-Schleife - Schleifenbefehle und Helfer fuer Zeichenketten.

Kind: SPR-Befehl | Category: SPR Frontend / Loops and Strings

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

DOL. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `DOL.[condition]`.

Syntax

DOL.[condition]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | condition | optional

Verwendung

  • Zeigen Sie Anfangswert, Schleifenrumpf und Austrittspfad, damit die Struktur ohne Raten in ein echtes SPR-Programm uebernommen werden kann.
  • Bei String-Helfern muessen Ein- und Ausgabetext exakt sichtbar sein, damit Padding, Trimmen, Splitten oder Ersetzen im Beispiel eindeutig werden.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_dol.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

DOL.
BRK.
OOP.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_dol.mrt. Kompilieren mit PBXB64 examples/spr/spr_dol.mrt -o spr_dol.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


OOP. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Loops and Strings › OOP.
Hilfe zum PBXB64-Compiler

OOP.

Schleifenende - Schleifenbefehle und Helfer fuer Zeichenketten.

Kind: SPR-Befehl | Category: SPR Frontend / Loops and Strings

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

OOP. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `OOP.[condition]`.

Syntax

OOP.[condition]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | condition | optional

Verwendung

  • Zeigen Sie Anfangswert, Schleifenrumpf und Austrittspfad, damit die Struktur ohne Raten in ein echtes SPR-Programm uebernommen werden kann.
  • Bei String-Helfern muessen Ein- und Ausgabetext exakt sichtbar sein, damit Padding, Trimmen, Splitten oder Ersetzen im Beispiel eindeutig werden.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_oop.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

DOL.
BRK.
OOP.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_oop.mrt. Kompilieren mit PBXB64 examples/spr/spr_oop.mrt -o spr_oop.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BRK. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Loops and Strings › BRK.
Hilfe zum PBXB64-Compiler

BRK.

Schleife abbrechen - Schleifenbefehle und Helfer fuer Zeichenketten.

Kind: SPR-Befehl | Category: SPR Frontend / Loops and Strings

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

BRK. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `BRK.`.

Syntax

BRK.

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Keine Parameter.

Verwendung

  • Zeigen Sie Anfangswert, Schleifenrumpf und Austrittspfad, damit die Struktur ohne Raten in ein echtes SPR-Programm uebernommen werden kann.
  • Bei String-Helfern muessen Ein- und Ausgabetext exakt sichtbar sein, damit Padding, Trimmen, Splitten oder Ersetzen im Beispiel eindeutig werden.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_brk.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$IDX=0
FOR.$$IDX|1|3|1
BRK.
NEX.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_brk.mrt. Kompilieren mit PBXB64 examples/spr/spr_brk.mrt -o spr_brk.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CON. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Loops and Strings › CON.
Hilfe zum PBXB64-Compiler

CON.

Schleife fortsetzen - Schleifenbefehle und Helfer fuer Zeichenketten.

Kind: SPR-Befehl | Category: SPR Frontend / Loops and Strings

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

CON. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `CON.`.

Syntax

CON.

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Keine Parameter.

Verwendung

  • Zeigen Sie Anfangswert, Schleifenrumpf und Austrittspfad, damit die Struktur ohne Raten in ein echtes SPR-Programm uebernommen werden kann.
  • Bei String-Helfern muessen Ein- und Ausgabetext exakt sichtbar sein, damit Padding, Trimmen, Splitten oder Ersetzen im Beispiel eindeutig werden.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_con.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$IDX=0
FOR.$$IDX|1|3|1
CON.
NEX.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_con.mrt. Kompilieren mit PBXB64 examples/spr/spr_con.mrt -o spr_con.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CAT. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Loops and Strings › CAT.
Hilfe zum PBXB64-Compiler

CAT.

Verketten - Schleifenbefehle und Helfer fuer Zeichenketten.

Kind: SPR-Befehl | Category: SPR Frontend / Loops and Strings

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

CAT. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `CAT.$$VAR|text1[|text2...]`.

Syntax

CAT.$$VAR|text1[|text2...]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | $$VAR | erforderlich
P2 | text1 | erforderlich
P3 | text2... | optional

Verwendung

  • Zeigen Sie Anfangswert, Schleifenrumpf und Austrittspfad, damit die Struktur ohne Raten in ein echtes SPR-Programm uebernommen werden kann.
  • Bei String-Helfern muessen Ein- und Ausgabetext exakt sichtbar sein, damit Padding, Trimmen, Splitten oder Ersetzen im Beispiel eindeutig werden.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_cat.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$OUT=empty
CAT.$$OUT|left|right
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_cat.mrt. Kompilieren mit PBXB64 examples/spr/spr_cat.mrt -o spr_cat.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LEN. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Loops and Strings › LEN.
Hilfe zum PBXB64-Compiler

LEN.

Laenge - Schleifenbefehle und Helfer fuer Zeichenketten.

Kind: SPR-Befehl | Category: SPR Frontend / Loops and Strings

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

LEN. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `LEN.source[|$$RES]`.

Syntax

LEN.source[|$$RES]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | source | erforderlich
P2 | $$RES | optional

Verwendung

  • Zeigen Sie Anfangswert, Schleifenrumpf und Austrittspfad, damit die Struktur ohne Raten in ein echtes SPR-Programm uebernommen werden kann.
  • Bei String-Helfern muessen Ein- und Ausgabetext exakt sichtbar sein, damit Padding, Trimmen, Splitten oder Ersetzen im Beispiel eindeutig werden.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_len.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$RES=0
LEN.text|$$RES
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_len.mrt. Kompilieren mit PBXB64 examples/spr/spr_len.mrt -o spr_len.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GSS. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Loops and Strings › GSS.
Hilfe zum PBXB64-Compiler

GSS.

Teilzeichenkette holen - Schleifenbefehle und Helfer fuer Zeichenketten.

Kind: SPR-Befehl | Category: SPR Frontend / Loops and Strings

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

GSS. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `GSS.start|end[|source][|$$RES]`.

Syntax

GSS.start|end[|source][|$$RES]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | start | erforderlich
P2 | end | erforderlich
P3 | source | optional
P4 | $$RES | optional

Verwendung

  • Zeigen Sie Anfangswert, Schleifenrumpf und Austrittspfad, damit die Struktur ohne Raten in ein echtes SPR-Programm uebernommen werden kann.
  • Bei String-Helfern muessen Ein- und Ausgabetext exakt sichtbar sein, damit Padding, Trimmen, Splitten oder Ersetzen im Beispiel eindeutig werden.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_gss.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$RES=empty
GSS.2|3|abcdef|$$RES
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_gss.mrt. Kompilieren mit PBXB64 examples/spr/spr_gss.mrt -o spr_gss.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RPL. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Loops and Strings › RPL.
Hilfe zum PBXB64-Compiler

RPL.

Ersetzen - Schleifenbefehle und Helfer fuer Zeichenketten.

Kind: SPR-Befehl | Category: SPR Frontend / Loops and Strings

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

RPL. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `RPL.$$VAR|find|replace[|option]`.

Syntax

RPL.$$VAR|find|replace[|option]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | $$VAR | erforderlich
P2 | find | erforderlich
P3 | replace | erforderlich
P4 | option | optional

Verwendung

  • Zeigen Sie Anfangswert, Schleifenrumpf und Austrittspfad, damit die Struktur ohne Raten in ein echtes SPR-Programm uebernommen werden kann.
  • Bei String-Helfern muessen Ein- und Ausgabetext exakt sichtbar sein, damit Padding, Trimmen, Splitten oder Ersetzen im Beispiel eindeutig werden.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_rpl.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$RES=abcabc
RPL.$$RES|ab|xy
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_rpl.mrt. Kompilieren mit PBXB64 examples/spr/spr_rpl.mrt -o spr_rpl.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VBT. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Loops and Strings › VBT.
Hilfe zum PBXB64-Compiler

VBT.

Variable beidseitig trimmen - Schleifenbefehle und Helfer fuer Zeichenketten.

Kind: SPR-Befehl | Category: SPR Frontend / Loops and Strings

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

VBT. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `VBT.$$VAR[|chars]`.

Syntax

VBT.$$VAR[|chars]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | $$VAR | erforderlich
P2 | chars | optional

Verwendung

  • Zeigen Sie Anfangswert, Schleifenrumpf und Austrittspfad, damit die Struktur ohne Raten in ein echtes SPR-Programm uebernommen werden kann.
  • Bei String-Helfern muessen Ein- und Ausgabetext exakt sichtbar sein, damit Padding, Trimmen, Splitten oder Ersetzen im Beispiel eindeutig werden.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_vbt.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$OUT= abc
VBT.$$OUT
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_vbt.mrt. Kompilieren mit PBXB64 examples/spr/spr_vbt.mrt -o spr_vbt.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VTL. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Loops and Strings › VTL.
Hilfe zum PBXB64-Compiler

VTL.

Variable in Kleinbuchstaben - Schleifenbefehle und Helfer fuer Zeichenketten.

Kind: SPR-Befehl | Category: SPR Frontend / Loops and Strings

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

VTL. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `VTL.$$VAR or VTL.$$TAR|source`.

Syntax

VTL.$$VAR or VTL.$$TAR|source

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Parameter

# | Name/Form | Bedeutung
P1 | $$VAR or VTL.$$TAR | erforderlich
P2 | source | erforderlich

Verwendung

  • Zeigen Sie Anfangswert, Schleifenrumpf und Austrittspfad, damit die Struktur ohne Raten in ein echtes SPR-Programm uebernommen werden kann.
  • Bei String-Helfern muessen Ein- und Ausgabetext exakt sichtbar sein, damit Padding, Trimmen, Splitten oder Ersetzen im Beispiel eindeutig werden.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_vtl.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$OUT=empty
VTL.ABC|$$OUT
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_vtl.mrt. Kompilieren mit PBXB64 examples/spr/spr_vtl.mrt -o spr_vtl.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VTU. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Loops and Strings › VTU.
Hilfe zum PBXB64-Compiler

VTU.

Variable in Grossbuchstaben - Schleifenbefehle und Helfer fuer Zeichenketten.

Kind: SPR-Befehl | Category: SPR Frontend / Loops and Strings

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

VTU. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `VTU.$$VAR or VTU.$$TAR|source`.

Syntax

VTU.$$VAR or VTU.$$TAR|source

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Parameter

# | Name/Form | Bedeutung
P1 | $$VAR or VTU.$$TAR | erforderlich
P2 | source | erforderlich

Verwendung

  • Zeigen Sie Anfangswert, Schleifenrumpf und Austrittspfad, damit die Struktur ohne Raten in ein echtes SPR-Programm uebernommen werden kann.
  • Bei String-Helfern muessen Ein- und Ausgabetext exakt sichtbar sein, damit Padding, Trimmen, Splitten oder Ersetzen im Beispiel eindeutig werden.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_vtu.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$OUT=empty
VTU.abc|$$OUT
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_vtu.mrt. Kompilieren mit PBXB64 examples/spr/spr_vtu.mrt -o spr_vtu.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VIC. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Variables and Math › VIC.
Hilfe zum PBXB64-Compiler

VIC.

Variable erhoehen - Variablenmanipulation, Zufallswerte, Formelauswertung und Mathematikbefehle.

Kind: SPR-Befehl | Category: SPR Frontend / Variables and Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

VIC. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `VIC.$$VAR[|amount]`.

Syntax

VIC.$$VAR[|amount]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | $$VAR | erforderlich
P2 | amount | optional

Verwendung

  • Zeigen Sie die Variable vor und nach dem Befehl, damit erkennbar ist, ob der Befehl direkt aendert oder in ein Ergebnisziel schreibt.
  • Wenn ein Befehl numerischen Zustand verbraucht oder erzeugt, nennen Sie Anfangswert, Operation und Endergebnis im Beispiel.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_vic.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$CNT=1
VIC.$$CNT|2
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_vic.mrt. Kompilieren mit PBXB64 examples/spr/spr_vic.mrt -o spr_vic.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VDC. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Variables and Math › VDC.
Hilfe zum PBXB64-Compiler

VDC.

Variable verringern - Variablenmanipulation, Zufallswerte, Formelauswertung und Mathematikbefehle.

Kind: SPR-Befehl | Category: SPR Frontend / Variables and Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

VDC. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `VDC.$$VAR[|amount]`.

Syntax

VDC.$$VAR[|amount]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | $$VAR | erforderlich
P2 | amount | optional

Verwendung

  • Zeigen Sie die Variable vor und nach dem Befehl, damit erkennbar ist, ob der Befehl direkt aendert oder in ein Ergebnisziel schreibt.
  • Wenn ein Befehl numerischen Zustand verbraucht oder erzeugt, nennen Sie Anfangswert, Operation und Endergebnis im Beispiel.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_vdc.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$CNT=3
VDC.$$CNT|1
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_vdc.mrt. Kompilieren mit PBXB64 examples/spr/spr_vdc.mrt -o spr_vdc.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RND. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Variables and Math › RND.
Hilfe zum PBXB64-Compiler

RND.

Zufallszahl - Variablenmanipulation, Zufallswerte, Formelauswertung und Mathematikbefehle.

Kind: SPR-Befehl | Category: SPR Frontend / Variables and Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

RND. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `RND.[max] / RND.min|max[|$$RES]`.

Syntax

RND.[max] / RND.min|max[|$$RES]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | max / RND.min | optional
P2 | max | erforderlich
P3 | $$RES | optional

Verwendung

  • Zeigen Sie die Variable vor und nach dem Befehl, damit erkennbar ist, ob der Befehl direkt aendert oder in ein Ergebnisziel schreibt.
  • Wenn ein Befehl numerischen Zustand verbraucht oder erzeugt, nennen Sie Anfangswert, Operation und Endergebnis im Beispiel.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_rnd.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$RES=0
RND.1|10|$$RES
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_rnd.mrt. Kompilieren mit PBXB64 examples/spr/spr_rnd.mrt -o spr_rnd.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VAB. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Variables and Math › VAB.
Hilfe zum PBXB64-Compiler

VAB.

Variablenname zuweisen - Variablenmanipulation, Zufallswerte, Formelauswertung und Mathematikbefehle.

Kind: SPR-Befehl | Category: SPR Frontend / Variables and Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

VAB. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `VAB.$$TGT=raw-text`.

Syntax

VAB.$$TGT=raw-text

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Parameter

# | Name/Form | Bedeutung
P1 | $$TGT | erforderliche Zielvariable
P2 | raw-text | erforderlicher Wert

Verwendung

  • Zeigen Sie die Variable vor und nach dem Befehl, damit erkennbar ist, ob der Befehl direkt aendert oder in ein Ergebnisziel schreibt.
  • Wenn ein Befehl numerischen Zustand verbraucht oder erzeugt, nennen Sie Anfangswert, Operation und Endergebnis im Beispiel.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_vab.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$TGT=none
VAB.$$TGT=raw-text
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_vab.mrt. Kompilieren mit PBXB64 examples/spr/spr_vab.mrt -o spr_vab.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VAO. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Variables and Math › VAO.
Hilfe zum PBXB64-Compiler

VAO.

Zuweisung mit Originaltyp - Variablenmanipulation, Zufallswerte, Formelauswertung und Mathematikbefehle.

Kind: SPR-Befehl | Category: SPR Frontend / Variables and Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

VAO. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `VAO.$$TGT=value or VAO.$$TGT=`.

Syntax

VAO.$$TGT=value or VAO.$$TGT=

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Parameter

# | Name/Form | Bedeutung
P1 | $$TGT | erforderliche Zielvariable
P2 | value or VAO.$$TGT= | erforderlicher Wert

Verwendung

  • Zeigen Sie die Variable vor und nach dem Befehl, damit erkennbar ist, ob der Befehl direkt aendert oder in ein Ergebnisziel schreibt.
  • Wenn ein Befehl numerischen Zustand verbraucht oder erzeugt, nennen Sie Anfangswert, Operation und Endergebnis im Beispiel.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_vao.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$AAA=42
VAO.$$AAA=
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_vao.mrt. Kompilieren mit PBXB64 examples/spr/spr_vao.mrt -o spr_vao.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VAI. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Variables and Math › VAI.
Hilfe zum PBXB64-Compiler

VAI.

Indirekte Zuweisung - Variablenmanipulation, Zufallswerte, Formelauswertung und Mathematikbefehle.

Kind: SPR-Befehl | Category: SPR Frontend / Variables and Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

VAI. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `VAI.$$PTR=value or VAI.$$PTR=`.

Syntax

VAI.$$PTR=value or VAI.$$PTR=

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Parameter

# | Name/Form | Bedeutung
P1 | $$PTR | erforderliche Zielvariable
P2 | value or VAI.$$PTR= | erforderlicher Wert

Verwendung

  • Zeigen Sie die Variable vor und nach dem Befehl, damit erkennbar ist, ob der Befehl direkt aendert oder in ein Ergebnisziel schreibt.
  • Wenn ein Befehl numerischen Zustand verbraucht oder erzeugt, nennen Sie Anfangswert, Operation und Endergebnis im Beispiel.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_vai.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$SRC=text
VAR.$$PTR=$$SRC
VAI.$$PTR=changed
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_vai.mrt. Kompilieren mit PBXB64 examples/spr/spr_vai.mrt -o spr_vai.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GVT. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Variables and Math › GVT.
Hilfe zum PBXB64-Compiler

GVT.

Variablentyp holen - Variablenmanipulation, Zufallswerte, Formelauswertung und Mathematikbefehle.

Kind: SPR-Befehl | Category: SPR Frontend / Variables and Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

GVT. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `GVT.$$SRC|$$TYP`.

Syntax

GVT.$$SRC|$$TYP

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Parameter

# | Name/Form | Bedeutung
P1 | $$SRC | erforderlich
P2 | $$TYP | erforderlich

Verwendung

  • Zeigen Sie die Variable vor und nach dem Befehl, damit erkennbar ist, ob der Befehl direkt aendert oder in ein Ergebnisziel schreibt.
  • Wenn ein Befehl numerischen Zustand verbraucht oder erzeugt, nennen Sie Anfangswert, Operation und Endergebnis im Beispiel.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_gvt.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$SRC=42
VAR.$$TYP=0
GVT.$$SRC|$$TYP
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_gvt.mrt. Kompilieren mit PBXB64 examples/spr/spr_gvt.mrt -o spr_gvt.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CLV. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Variables and Math › CLV.
Hilfe zum PBXB64-Compiler

CLV.

Variable loeschen - Variablenmanipulation, Zufallswerte, Formelauswertung und Mathematikbefehle.

Kind: SPR-Befehl | Category: SPR Frontend / Variables and Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

CLV. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `CLV.$$VAR`.

Syntax

CLV.$$VAR

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Parameter

# | Name/Form | Bedeutung
P1 | $$VAR | erforderlich

Verwendung

  • Zeigen Sie die Variable vor und nach dem Befehl, damit erkennbar ist, ob der Befehl direkt aendert oder in ein Ergebnisziel schreibt.
  • Wenn ein Befehl numerischen Zustand verbraucht oder erzeugt, nennen Sie Anfangswert, Operation und Endergebnis im Beispiel.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_clv.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$AAA=42
CLV.$$AAA
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_clv.mrt. Kompilieren mit PBXB64 examples/spr/spr_clv.mrt -o spr_clv.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SAV. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Variables and Math › SAV.
Hilfe zum PBXB64-Compiler

SAV.

Variablen sichern - Variablenmanipulation, Zufallswerte, Formelauswertung und Mathematikbefehle.

Kind: SPR-Befehl | Category: SPR Frontend / Variables and Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

SAV. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `SAV.s|$$VAR[|$$VAR...] / SAV.r`.

Syntax

SAV.s|$$VAR[|$$VAR...] / SAV.r

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | s | erforderlich
P2 | $$VAR | erforderlich
P3 | $$VAR... / SAV.r | optional

Verwendung

  • Zeigen Sie die Variable vor und nach dem Befehl, damit erkennbar ist, ob der Befehl direkt aendert oder in ein Ergebnisziel schreibt.
  • Wenn ein Befehl numerischen Zustand verbraucht oder erzeugt, nennen Sie Anfangswert, Operation und Endergebnis im Beispiel.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_sav.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$AAA=42
SAV.s|$$AAA
SAV.r
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_sav.mrt. Kompilieren mit PBXB64 examples/spr/spr_sav.mrt -o spr_sav.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RES. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Variables and Math › RES.
Hilfe zum PBXB64-Compiler

RES.

Ressourcenbefehle - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

RES. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `RES.action[|parameters...]`.

Syntax

RES.action[|parameters...]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | action | erforderlich
P2 | parameters... | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_res.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

RES.lv|$$VER
DBP.$$VER
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_res.mrt. Kompilieren mit PBXB64 examples/spr/spr_res.mrt -o spr_res.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CAL. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Variables and Math › CAL.
Hilfe zum PBXB64-Compiler

CAL.

Berechnen - Variablenmanipulation, Zufallswerte, Formelauswertung und Mathematikbefehle.

Kind: SPR-Befehl | Category: SPR Frontend / Variables and Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

CAL. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `CAL.$$RES=expression[|flags]`.

Syntax

CAL.$$RES=expression[|flags]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | $$RES=expression | erforderlich
P2 | flags | optional

Verwendung

  • Zeigen Sie die Variable vor und nach dem Befehl, damit erkennbar ist, ob der Befehl direkt aendert oder in ein Ergebnisziel schreibt.
  • Wenn ein Befehl numerischen Zustand verbraucht oder erzeugt, nennen Sie Anfangswert, Operation und Endergebnis im Beispiel.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_cal.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$RES=0
CAL.$$RES=1+2*3
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_cal.mrt. Kompilieren mit PBXB64 examples/spr/spr_cal.mrt -o spr_cal.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CAX. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Variables and Math › CAX.
Hilfe zum PBXB64-Compiler

CAX.

Erweitert berechnen - Variablenmanipulation, Zufallswerte, Formelauswertung und Mathematikbefehle.

Kind: SPR-Befehl | Category: SPR Frontend / Variables and Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

CAX. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `CAX.$$RES=expression[|flags]`.

Syntax

CAX.$$RES=expression[|flags]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | $$RES=expression | erforderlich
P2 | flags | optional

Verwendung

  • Zeigen Sie die Variable vor und nach dem Befehl, damit erkennbar ist, ob der Befehl direkt aendert oder in ein Ergebnisziel schreibt.
  • Wenn ein Befehl numerischen Zustand verbraucht oder erzeugt, nennen Sie Anfangswert, Operation und Endergebnis im Beispiel.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_cax.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$RES=0
VAR.$$LOG=0
VAR.$$SQR=0
VAR.$$COS=0
VAR.$$OUT=empty
CAX.$$RES=1+2*3
CAX.$$LOG=log10(100)
CAX.$$SQR=sqr(81)
CAX.$$COS=cos(0)
CAT.$$OUT|$$RES|,|$$LOG|,|$$SQR|,|$$COS
CTF.spr_cax_out.txt|$$OUT
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_cax.mrt. Kompilieren mit PBXB64 examples/spr/spr_cax.mrt -o spr_cax.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


EVA. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Variables and Math › EVA.
Hilfe zum PBXB64-Compiler

EVA.

Auswerten - Variablenmanipulation, Zufallswerte, Formelauswertung und Mathematikbefehle.

Kind: SPR-Befehl | Category: SPR Frontend / Variables and Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

EVA. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `EVA.$$RES=formula`.

Syntax

EVA.$$RES=formula

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Parameter

# | Name/Form | Bedeutung
P1 | $$RES | erforderliche Zielvariable
P2 | formula | erforderlicher Wert

Verwendung

  • Zeigen Sie die Variable vor und nach dem Befehl, damit erkennbar ist, ob der Befehl direkt aendert oder in ein Ergebnisziel schreibt.
  • Wenn ein Befehl numerischen Zustand verbraucht oder erzeugt, nennen Sie Anfangswert, Operation und Endergebnis im Beispiel.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_eva.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$RES=0
EVA.$$RES|1+2
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_eva.mrt. Kompilieren mit PBXB64 examples/spr/spr_eva.mrt -o spr_eva.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BIT. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Variables and Math › BIT.
Hilfe zum PBXB64-Compiler

BIT.

Bitoperationen - Variablenmanipulation, Zufallswerte, Formelauswertung und Mathematikbefehle.

Kind: SPR-Befehl | Category: SPR Frontend / Variables and Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

BIT. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `BIT.Get|value|bit|$$RES|1`.

Syntax

BIT.Get|value|bit|$$RES|1

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Parameter

# | Name/Form | Bedeutung
P1 | Get | erforderlich
P2 | value | erforderlich
P3 | bit | erforderlich
P4 | $$RES | erforderlich
P5 | 1 | erforderlich

Verwendung

  • Zeigen Sie die Variable vor und nach dem Befehl, damit erkennbar ist, ob der Befehl direkt aendert oder in ein Ergebnisziel schreibt.
  • Wenn ein Befehl numerischen Zustand verbraucht oder erzeugt, nennen Sie Anfangswert, Operation und Endergebnis im Beispiel.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_bit.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$VAL=10
VAR.$$GET=0
VAR.$$BIN=
VAR.$$OUT=
BIT.Get|$$VAL|2|$$GET|1
BIT.ToBin|$$VAL|b$$BIN|1
LEN.$$BIN|$$OUT
CAT.$$OUT| bytes, bit=|$$GET
DBP.$$OUT
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_bit.mrt. Kompilieren mit PBXB64 examples/spr/spr_bit.mrt -o spr_bit.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FMT. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR Variables and Math › FMT.
Hilfe zum PBXB64-Compiler

FMT.

Variable formatieren - Variablenmanipulation, Zufallswerte, Formelauswertung und Mathematikbefehle.

Kind: SPR-Befehl | Category: SPR Frontend / Variables and Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

FMT. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `FMT.$$NUM|000000`.

Syntax

FMT.$$NUM|000000

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Parameter

# | Name/Form | Bedeutung
P1 | $$NUM | erforderlich
P2 | 000000 | erforderlich

Verwendung

  • Zeigen Sie die Variable vor und nach dem Befehl, damit erkennbar ist, ob der Befehl direkt aendert oder in ein Ergebnisziel schreibt.
  • Wenn ein Befehl numerischen Zustand verbraucht oder erzeugt, nennen Sie Anfangswert, Operation und Endergebnis im Beispiel.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_fmt.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$NUM=1234
VAR.$$OUT=
FMT.$$NUM|000000
CAT.$$OUT|Formatted: |$$NUM
DBP.$$OUT
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_fmt.mrt. Kompilieren mit PBXB64 examples/spr/spr_fmt.mrt -o spr_fmt.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CFF. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › CFF.
Hilfe zum PBXB64-Compiler

CFF.

Aus Datei kopieren - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

CFF. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `CFF.filename[|$$TXT[|$$OKK]]`.

Syntax

CFF.filename[|$$TXT[|$$OKK]]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | filename | erforderlich
P2 | $$TXT | optional
P3 | $$OKK | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_cff.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

CTF.spr_sample_tmp.txt|hello|$$OKK
CFF.spr_sample_tmp.txt|$$TXT|$$OKK
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_cff.mrt. Kompilieren mit PBXB64 examples/spr/spr_cff.mrt -o spr_cff.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CTF. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › CTF.
Hilfe zum PBXB64-Compiler

CTF.

In Datei kopieren - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

CTF. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `CTF.filename|content[|$$OKK]`.

Syntax

CTF.filename|content[|$$OKK]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | filename | erforderlich
P2 | content | erforderlich
P3 | $$OKK | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_ctf.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

CTF.spr_sample_tmp.txt|hello|$$OKK
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_ctf.mrt. Kompilieren mit PBXB64 examples/spr/spr_ctf.mrt -o spr_ctf.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ATF. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › ATF.
Hilfe zum PBXB64-Compiler

ATF.

An Datei anhaengen - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

ATF. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `ATF.filename|content[|$$OKK]`.

Syntax

ATF.filename|content[|$$OKK]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | filename | erforderlich
P2 | content | erforderlich
P3 | $$OKK | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_atf.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

ATF.spr_sample_tmp.txt|hello|$$OKK
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_atf.mrt. Kompilieren mit PBXB64 examples/spr/spr_atf.mrt -o spr_atf.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


IEF. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › IEF.
Hilfe zum PBXB64-Compiler

IEF.

Datei existiert - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

IEF. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `IEF.filename[|$$OKK]`.

Syntax

IEF.filename[|$$OKK]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | filename | erforderlich
P2 | $$OKK | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_ief.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

IEF.spr_sample_tmp.txt
DBP.exists
ELS.
DBP.missing
EIF.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_ief.mrt. Kompilieren mit PBXB64 examples/spr/spr_ief.mrt -o spr_ief.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


NEF. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › NEF.
Hilfe zum PBXB64-Compiler

NEF.

Datei existiert nicht - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

NEF. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `NEF.filename[|$$OKK]`.

Syntax

NEF.filename[|$$OKK]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | filename | erforderlich
P2 | $$OKK | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_nef.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

NEF.spr_missing_tmp.txt
DBP.missing
ELS.
DBP.exists
EIF.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_nef.mrt. Kompilieren mit PBXB64 examples/spr/spr_nef.mrt -o spr_nef.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MKD. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › MKD.
Hilfe zum PBXB64-Compiler

MKD.

Verzeichnis erstellen - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

MKD. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `MKD.path`.

Syntax

MKD.path

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Parameter

# | Name/Form | Bedeutung
P1 | path | erforderlich

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_mkd.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

MKD.spr_sample_dir
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_mkd.mrt. Kompilieren mit PBXB64 examples/spr/spr_mkd.mrt -o spr_mkd.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SHF. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › SHF.
Hilfe zum PBXB64-Compiler

SHF.

Datei anzeigen - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

SHF. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `SHF.operation|flags|source[|target]`.

Syntax

SHF.operation|flags|source[|target]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | operation | erforderlich
P2 | flags | erforderlich
P3 | source | erforderlich
P4 | target | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_shf.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Shell file operation sample: delete missing sample file if present.
SHF.d||spr_sample_tmp.txt
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_shf.mrt. Kompilieren mit PBXB64 examples/spr/spr_shf.mrt -o spr_shf.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


COP. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › COP.
Hilfe zum PBXB64-Compiler

COP.

Datei kopieren - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

COP. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `COP.source|destination[|timeout]`.

Syntax

COP.source|destination[|timeout]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | source | erforderlich
P2 | destination | erforderlich
P3 | timeout | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_cop.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

CTF.spr_copy_src.txt|hello|$$OKK
COP.spr_copy_src.txt|spr_copy_dst.txt|$$OKK
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_cop.mrt. Kompilieren mit PBXB64 examples/spr/spr_cop.mrt -o spr_cop.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MBT. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › MBT.
Hilfe zum PBXB64-Compiler

MBT.

Meldungsbox mit Zeit - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

MBT. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `MBT.[text][|title][|timeout][|type][|$$RES]`.

Syntax

MBT.[text][|title][|timeout][|type][|$$RES]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | text | optional
P2 | title | optional
P3 | timeout | optional
P4 | type | optional
P5 | $$RES | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_mbt.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Interactive when executed: shows a message box.
MBT.Timed message|SPR sample|1|0
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_mbt.mrt. Kompilieren mit PBXB64 examples/spr/spr_mbt.mrt -o spr_mbt.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MBX. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › MBX.
Hilfe zum PBXB64-Compiler

MBX.

Meldungsbox - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

MBX. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `MBX.[text][|type][|title][|$$RES]`.

Syntax

MBX.[text][|type][|title][|$$RES]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | text | optional
P2 | type | optional
P3 | title | optional
P4 | $$RES | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_mbx.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Interactive when executed: shows a message box.
VAR.$$RES=0
MBX.Hello from SPR|0|SPR sample|$$RES
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_mbx.mrt. Kompilieren mit PBXB64 examples/spr/spr_mbx.mrt -o spr_mbx.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


DCP. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › DCP.
Hilfe zum PBXB64-Compiler

DCP.

Pfad kopieren - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

DCP. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `DCP.source|destination[|options]`.

Syntax

DCP.source|destination[|options]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | source | erforderlich
P2 | destination | erforderlich
P3 | options | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_dcp.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

CTF.spr_delete_tmp.txt|delete me|$$OKK
DCP.spr_delete_tmp.txt|$$OKK
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_dcp.mrt. Kompilieren mit PBXB64 examples/spr/spr_dcp.mrt -o spr_dcp.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GUT. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › GUT.
Hilfe zum PBXB64-Compiler

GUT.

Benutzereingabe holen - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

GUT. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `GUT.[prompt][|title][|default][|$$RES]`.

Syntax

GUT.[prompt][|title][|default][|$$RES]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | prompt | optional
P2 | title | optional
P3 | default | optional
P4 | $$RES | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_gut.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Interactive when executed: shows an input box.
VAR.$$RES=empty
GUT.Enter value|SPR sample|default|$$RES
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_gut.mrt. Kompilieren mit PBXB64 examples/spr/spr_gut.mrt -o spr_gut.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PRT. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › PRT.
Hilfe zum PBXB64-Compiler

PRT.

Ausgeben - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

PRT. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `PRT.[text]`.

Syntax

PRT.[text]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | text | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_prt.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

PRT.text
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_prt.mrt. Kompilieren mit PBXB64 examples/spr/spr_prt.mrt -o spr_prt.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


OUT. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › OUT.
Hilfe zum PBXB64-Compiler

OUT.

Ausgabe - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

OUT. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `OUT.value`.

Syntax

OUT.value

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Parameter

# | Name/Form | Bedeutung
P1 | value | erforderlich

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_out.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

VAR.$$TXT=Hello
VAR.$$LEN=0
OUT.$$TXT
POP.$$LEN
DBP.$$LEN
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_out.mrt. Kompilieren mit PBXB64 examples/spr/spr_out.mrt -o spr_out.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GSC. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › GSC.
Hilfe zum PBXB64-Compiler

GSC.

Zeichenkettenvorkommen zaehlen - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

GSC. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `GSC.source|substring[|$$RES][|flags]`.

Syntax

GSC.source|substring[|$$RES][|flags]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | source | erforderlich
P2 | substring | erforderlich
P3 | $$RES | optional
P4 | flags | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_gsc.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

VAR.$$RES=0
GSC.banana|na|$$RES
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_gsc.mrt. Kompilieren mit PBXB64 examples/spr/spr_gsc.mrt -o spr_gsc.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SBD. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › SBD.
Hilfe zum PBXB64-Compiler

SBD.

Zeichenkette zwischen Begrenzern - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

SBD. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `SBD.source|delimiter|index[|$$RES]`.

Syntax

SBD.source|delimiter|index[|$$RES]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | source | erforderlich
P2 | delimiter | erforderlich
P3 | index | erforderlich
P4 | $$RES | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_sbd.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

VAR.$$RES=empty
SBD.a|b|c|$$RES
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_sbd.mrt. Kompilieren mit PBXB64 examples/spr/spr_sbd.mrt -o spr_sbd.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SBM. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › SBM.
Hilfe zum PBXB64-Compiler

SBM.

Mehrfachsuche zwischen Begrenzern - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

SBM. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `SBM.source|delimiter|start|end[|$$RES]`.

Syntax

SBM.source|delimiter|start|end[|$$RES]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | source | erforderlich
P2 | delimiter | erforderlich
P3 | start | erforderlich
P4 | end | erforderlich
P5 | $$RES | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_sbm.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

VAR.$$RES=empty
SBM.a|b|1|1|$$RES
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_sbm.mrt. Kompilieren mit PBXB64 examples/spr/spr_sbm.mrt -o spr_sbm.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CSP. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › CSP.
Hilfe zum PBXB64-Compiler

CSP.

Zeichenkette ausschneiden - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

CSP. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `CSP.clip|source[|$$RES]`.

Syntax

CSP.clip|source[|$$RES]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | clip | erforderlich
P2 | source | erforderlich
P3 | $$RES | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_csp.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

VAR.$$RES=abcdef
CSP.1,-1|$$RES
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_csp.mrt. Kompilieren mit PBXB64 examples/spr/spr_csp.mrt -o spr_csp.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRD. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › VRD.
Hilfe zum PBXB64-Compiler

VRD.

Dopplungen entfernen - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

VRD. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `VRD.[$$VAR][|chars]`.

Syntax

VRD.[$$VAR][|chars]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | $$VAR | optional
P2 | chars | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_vrd.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

VAR.$$AAA=aaab
VRD.$$AAA|a
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_vrd.mrt. Kompilieren mit PBXB64 examples/spr/spr_vrd.mrt -o spr_vrd.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ASC. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › ASC.
Hilfe zum PBXB64-Compiler

ASC.

ASCII-Code - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

ASC. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `ASC.string[|$$RES][|index]`.

Syntax

ASC.string[|$$RES][|index]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | string | erforderlich
P2 | $$RES | optional
P3 | index | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_asc.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

VAR.$$RES=0
ASC.ABC|$$RES|1
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_asc.mrt. Kompilieren mit PBXB64 examples/spr/spr_asc.mrt -o spr_asc.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CHR. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › CHR.
Hilfe zum PBXB64-Compiler

CHR.

Zeichen - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

CHR. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `CHR.code[|$$RES][|end_code]`.

Syntax

CHR.code[|$$RES][|end_code]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | code | erforderlich
P2 | $$RES | optional
P3 | end_code | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_chr.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

VAR.$$RES=empty
CHR.65|$$RES
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_chr.mrt. Kompilieren mit PBXB64 examples/spr/spr_chr.mrt -o spr_chr.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


FEX. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › FEX.
Hilfe zum PBXB64-Compiler

FEX.

Dateiaufzaehlung starten - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

FEX. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `FEX.[options]`.

Syntax

FEX.[options]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | options | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_fex.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

FEX.*
FEN.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_fex.mrt. Kompilieren mit PBXB64 examples/spr/spr_fex.mrt -o spr_fex.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FEL. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › FEL.
Hilfe zum PBXB64-Compiler

FEL.

Dateiaufzaehlung schleifen - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

FEL. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `FEL.label|$$VAR[|filename][|pattern][|maxline]`.

Syntax

FEL.label|$$VAR[|filename][|pattern][|maxline]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | label | erforderlich
P2 | $$VAR | erforderlich
P3 | filename | optional
P4 | pattern | optional
P5 | maxline | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_fel.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

FEX.*
FEL.
FEN.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_fel.mrt. Kompilieren mit PBXB64 examples/spr/spr_fel.mrt -o spr_fel.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FEM. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › FEM.
Hilfe zum PBXB64-Compiler

FEM.

Dateiaufzaehlung splittern/filtern - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

FEM. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `FEM.label|$$VAR[|source][|delimiter][|pattern]`.

Syntax

FEM.label|$$VAR[|source][|delimiter][|pattern]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | label | erforderlich
P2 | $$VAR | erforderlich
P3 | source | optional
P4 | delimiter | optional
P5 | pattern | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_fem.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

VAR.$$OUT=empty
FEM.LAB|$$ITM|A,B,C|,|
CAT.$$OUT|$$ITM|$$OUT
FEN.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_fem.mrt. Kompilieren mit PBXB64 examples/spr/spr_fem.mrt -o spr_fem.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FEN. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR File and Text I/O › FEN.
Hilfe zum PBXB64-Compiler

FEN.

Dateiaufzaehlung beenden - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

FEN. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `FEN.`.

Syntax

FEN.

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Keine Parameter.

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_fen.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

FEX.*
FEN.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_fen.mrt. Kompilieren mit PBXB64 examples/spr/spr_fen.mrt -o spr_fen.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


EXE. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR System and Memory › EXE.
Hilfe zum PBXB64-Compiler

EXE.

Prozess starten - System-, Tastatur-, Speicher-, Mapping- und Fensterhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / System and Memory

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

EXE. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `EXE.file[|params]`.

Syntax

EXE.file[|params]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | file | erforderlich
P2 | params | optional

Verwendung

  • Nennen Sie die Desktop-, Prozess- oder Fenster-Voraussetzung direkt, damit das Beispiel ohne versteckte Umgebungsannahmen in ein reales Programm uebernommen werden kann.
  • Wenn der Befehl Handles, Tastatur, Maus oder Speicher beruehrt, zeigen Sie den exakten Vorher-/Nachher-Zustand, den der Aufrufer pruefen soll.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_exe.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Environment-dependent when executed: starts a process and sets #pid#.
VAR.$$OUT=PID=
EXE.cmd.exe|/c exit 0
CAT.$$OUT|#pid#|$$OUT
CTF.spr_exe_pid_out.txt|$$OUT
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_exe.mrt. Kompilieren mit PBXB64 examples/spr/spr_exe.mrt -o spr_exe.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


EXB. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR System and Memory › EXB.
Hilfe zum PBXB64-Compiler

EXB.

Blockierend ausfuehren - System-, Tastatur-, Speicher-, Mapping- und Fensterhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / System and Memory

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

EXB. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `EXB.file[|show]`.

Syntax

EXB.file[|show]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | file | erforderlich
P2 | show | optional

Verwendung

  • Nennen Sie die Desktop-, Prozess- oder Fenster-Voraussetzung direkt, damit das Beispiel ohne versteckte Umgebungsannahmen in ein reales Programm uebernommen werden kann.
  • Wenn der Befehl Handles, Tastatur, Maus oder Speicher beruehrt, zeigen Sie den exakten Vorher-/Nachher-Zustand, den der Aufrufer pruefen soll.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_exb.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Environment-dependent when executed: starts and waits for a process.
EXB.cmd.exe
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_exb.mrt. Kompilieren mit PBXB64 examples/spr/spr_exb.mrt -o spr_exb.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


EXF. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR System and Memory › EXF.
Hilfe zum PBXB64-Compiler

EXF.

Datei ausfuehren - System-, Tastatur-, Speicher-, Mapping- und Fensterhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / System and Memory

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

EXF. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `EXF.file[|params][|directory][|show]`.

Syntax

EXF.file[|params][|directory][|show]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | file | erforderlich
P2 | params | optional
P3 | directory | optional
P4 | show | optional

Verwendung

  • Nennen Sie die Desktop-, Prozess- oder Fenster-Voraussetzung direkt, damit das Beispiel ohne versteckte Umgebungsannahmen in ein reales Programm uebernommen werden kann.
  • Wenn der Befehl Handles, Tastatur, Maus oder Speicher beruehrt, zeigen Sie den exakten Vorher-/Nachher-Zustand, den der Aufrufer pruefen soll.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_exf.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Environment-dependent when executed: executes a file with parameters.
EXF.cmd.exe|/c exit 0|.|0
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_exf.mrt. Kompilieren mit PBXB64 examples/spr/spr_exf.mrt -o spr_exf.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


EXO. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR System and Memory › EXO.
Hilfe zum PBXB64-Compiler

EXO.

Objekt oeffnen/ausfuehren - System-, Tastatur-, Speicher-, Mapping- und Fensterhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / System and Memory

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

EXO. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `EXO.file[|params][|directory][|action][|show][|$$RES]`.

Syntax

EXO.file[|params][|directory][|action][|show][|$$RES]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | file | erforderlich
P2 | params | optional
P3 | directory | optional
P4 | action | optional
P5 | show | optional
P6 | $$RES | optional

Verwendung

  • Nennen Sie die Desktop-, Prozess- oder Fenster-Voraussetzung direkt, damit das Beispiel ohne versteckte Umgebungsannahmen in ein reales Programm uebernommen werden kann.
  • Wenn der Befehl Handles, Tastatur, Maus oder Speicher beruehrt, zeigen Sie den exakten Vorher-/Nachher-Zustand, den der Aufrufer pruefen soll.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_exo.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Environment-dependent when executed: shell execute with action.
EXO.cmd.exe|/c exit 0||open|1
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_exo.mrt. Kompilieren mit PBXB64 examples/spr/spr_exo.mrt -o spr_exo.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


EXX. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR System and Memory › EXX.
Hilfe zum PBXB64-Compiler

EXX.

Asynchron ausfuehren - System-, Tastatur-, Speicher-, Mapping- und Fensterhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / System and Memory

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

EXX. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `EXX.file[|show]`.

Syntax

EXX.file[|show]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | file | erforderlich
P2 | show | optional

Verwendung

  • Nennen Sie die Desktop-, Prozess- oder Fenster-Voraussetzung direkt, damit das Beispiel ohne versteckte Umgebungsannahmen in ein reales Programm uebernommen werden kann.
  • Wenn der Befehl Handles, Tastatur, Maus oder Speicher beruehrt, zeigen Sie den exakten Vorher-/Nachher-Zustand, den der Aufrufer pruefen soll.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_exx.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Environment-dependent when executed: starts a process asynchronously.
EXX.cmd.exe|0
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_exx.mrt. Kompilieren mit PBXB64 examples/spr/spr_exx.mrt -o spr_exx.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


KEY. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR System and Memory › KEY.
Hilfe zum PBXB64-Compiler

KEY.

Tasten senden - System-, Tastatur-, Speicher-, Mapping- und Fensterhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / System and Memory

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

KEY. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `KEY.text`.

Syntax

KEY.text

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Parameter

# | Name/Form | Bedeutung
P1 | text | erforderlich

Verwendung

  • Nennen Sie die Desktop-, Prozess- oder Fenster-Voraussetzung direkt, damit das Beispiel ohne versteckte Umgebungsannahmen in ein reales Programm uebernommen werden kann.
  • Wenn der Befehl Handles, Tastatur, Maus oder Speicher beruehrt, zeigen Sie den exakten Vorher-/Nachher-Zustand, den der Aufrufer pruefen soll.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_key.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Environment-dependent when executed: sends keys to the active desktop.
KEY.A
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_key.mrt. Kompilieren mit PBXB64 examples/spr/spr_key.mrt -o spr_key.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


KPR. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR System and Memory › KPR.
Hilfe zum PBXB64-Compiler

KPR.

Taste druecken - System-, Tastatur-, Speicher-, Mapping- und Fensterhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / System and Memory

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

KPR. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `KPR.key`.

Syntax

KPR.key

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Parameter

# | Name/Form | Bedeutung
P1 | key | erforderlich

Verwendung

  • Nennen Sie die Desktop-, Prozess- oder Fenster-Voraussetzung direkt, damit das Beispiel ohne versteckte Umgebungsannahmen in ein reales Programm uebernommen werden kann.
  • Wenn der Befehl Handles, Tastatur, Maus oder Speicher beruehrt, zeigen Sie den exakten Vorher-/Nachher-Zustand, den der Aufrufer pruefen soll.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_kpr.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Environment-dependent when executed: presses a key.
KPR.A
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_kpr.mrt. Kompilieren mit PBXB64 examples/spr/spr_kpr.mrt -o spr_kpr.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


KRL. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR System and Memory › KRL.
Hilfe zum PBXB64-Compiler

KRL.

Taste loslassen - System-, Tastatur-, Speicher-, Mapping- und Fensterhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / System and Memory

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

KRL. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `KRL.key`.

Syntax

KRL.key

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Parameter

# | Name/Form | Bedeutung
P1 | key | erforderlich

Verwendung

  • Nennen Sie die Desktop-, Prozess- oder Fenster-Voraussetzung direkt, damit das Beispiel ohne versteckte Umgebungsannahmen in ein reales Programm uebernommen werden kann.
  • Wenn der Befehl Handles, Tastatur, Maus oder Speicher beruehrt, zeigen Sie den exakten Vorher-/Nachher-Zustand, den der Aufrufer pruefen soll.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_krl.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Environment-dependent when executed: releases a key.
KRL.A
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_krl.mrt. Kompilieren mit PBXB64 examples/spr/spr_krl.mrt -o spr_krl.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MAP. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR System and Memory › MAP.
Hilfe zum PBXB64-Compiler

MAP.

Automationspunkt setzen - System-, Tastatur-, Speicher-, Mapping- und Fensterhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / System and Memory

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

MAP. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `MAP.x|y[|hwnd]`.

Syntax

MAP.x|y[|hwnd]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | x | erforderlich
P2 | y | erforderlich
P3 | hwnd | optional

Verwendung

  • Nennen Sie die Desktop-, Prozess- oder Fenster-Voraussetzung direkt, damit das Beispiel ohne versteckte Umgebungsannahmen in ein reales Programm uebernommen werden kann.
  • Wenn der Befehl Handles, Tastatur, Maus oder Speicher beruehrt, zeigen Sie den exakten Vorher-/Nachher-Zustand, den der Aufrufer pruefen soll.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_map.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Environment-dependent when executed: records an automation point.
MAP.0|0|0
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_map.mrt. Kompilieren mit PBXB64 examples/spr/spr_map.mrt -o spr_map.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MAW. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR System and Memory › MAW.
Hilfe zum PBXB64-Compiler

MAW.

Fenster/Maus warten - System-, Tastatur-, Speicher-, Mapping- und Fensterhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / System and Memory

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

MAW. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `MAW.[timeout]`.

Syntax

MAW.[timeout]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | timeout | optional

Verwendung

  • Nennen Sie die Desktop-, Prozess- oder Fenster-Voraussetzung direkt, damit das Beispiel ohne versteckte Umgebungsannahmen in ein reales Programm uebernommen werden kann.
  • Wenn der Befehl Handles, Tastatur, Maus oder Speicher beruehrt, zeigen Sie den exakten Vorher-/Nachher-Zustand, den der Aufrufer pruefen soll.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_maw.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Environment-dependent when executed: waits for window state.
MAW.h|0
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_maw.mrt. Kompilieren mit PBXB64 examples/spr/spr_maw.mrt -o spr_maw.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MDC. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR System and Memory › MDC.
Hilfe zum PBXB64-Compiler

MDC.

Doppelklick - System-, Tastatur-, Speicher-, Mapping- und Fensterhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / System and Memory

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

MDC. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `MDC.[x][|y][|hwnd]`.

Syntax

MDC.[x][|y][|hwnd]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | x | optional
P2 | y | optional
P3 | hwnd | optional

Verwendung

  • Nennen Sie die Desktop-, Prozess- oder Fenster-Voraussetzung direkt, damit das Beispiel ohne versteckte Umgebungsannahmen in ein reales Programm uebernommen werden kann.
  • Wenn der Befehl Handles, Tastatur, Maus oder Speicher beruehrt, zeigen Sie den exakten Vorher-/Nachher-Zustand, den der Aufrufer pruefen soll.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_mdc.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Environment-dependent when executed: double-clicks at coordinates.
MDC.-1|-1
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_mdc.mrt. Kompilieren mit PBXB64 examples/spr/spr_mdc.mrt -o spr_mdc.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MEL. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR System and Memory › MEL.
Hilfe zum PBXB64-Compiler

MEL.

Linkes Mausereignis - System-, Tastatur-, Speicher-, Mapping- und Fensterhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / System and Memory

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

MEL. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `MEL.[x][|y][|hwnd]`.

Syntax

MEL.[x][|y][|hwnd]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | x | optional
P2 | y | optional
P3 | hwnd | optional

Verwendung

  • Nennen Sie die Desktop-, Prozess- oder Fenster-Voraussetzung direkt, damit das Beispiel ohne versteckte Umgebungsannahmen in ein reales Programm uebernommen werden kann.
  • Wenn der Befehl Handles, Tastatur, Maus oder Speicher beruehrt, zeigen Sie den exakten Vorher-/Nachher-Zustand, den der Aufrufer pruefen soll.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_mel.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Environment-dependent when executed: emits a left mouse event.
MEL.-1|-1
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_mel.mrt. Kompilieren mit PBXB64 examples/spr/spr_mel.mrt -o spr_mel.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MEM. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR System and Memory › MEM.
Hilfe zum PBXB64-Compiler

MEM.

Mittleres Mausereignis - System-, Tastatur-, Speicher-, Mapping- und Fensterhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / System and Memory

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

MEM. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `MEM.[x][|y][|hwnd]`.

Syntax

MEM.[x][|y][|hwnd]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | x | optional
P2 | y | optional
P3 | hwnd | optional

Verwendung

  • Nennen Sie die Desktop-, Prozess- oder Fenster-Voraussetzung direkt, damit das Beispiel ohne versteckte Umgebungsannahmen in ein reales Programm uebernommen werden kann.
  • Wenn der Befehl Handles, Tastatur, Maus oder Speicher beruehrt, zeigen Sie den exakten Vorher-/Nachher-Zustand, den der Aufrufer pruefen soll.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_mem.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Environment-dependent when executed: emits a middle mouse event.
MEM.-1|-1
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_mem.mrt. Kompilieren mit PBXB64 examples/spr/spr_mem.mrt -o spr_mem.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MLC. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR System and Memory › MLC.
Hilfe zum PBXB64-Compiler

MLC.

Linksklick - System-, Tastatur-, Speicher-, Mapping- und Fensterhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / System and Memory

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

MLC. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `MLC.[x][|y][|hwnd]`.

Syntax

MLC.[x][|y][|hwnd]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | x | optional
P2 | y | optional
P3 | hwnd | optional

Verwendung

  • Nennen Sie die Desktop-, Prozess- oder Fenster-Voraussetzung direkt, damit das Beispiel ohne versteckte Umgebungsannahmen in ein reales Programm uebernommen werden kann.
  • Wenn der Befehl Handles, Tastatur, Maus oder Speicher beruehrt, zeigen Sie den exakten Vorher-/Nachher-Zustand, den der Aufrufer pruefen soll.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_mlc.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Environment-dependent when executed: left-clicks at coordinates.
MLC.-1|-1
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_mlc.mrt. Kompilieren mit PBXB64 examples/spr/spr_mlc.mrt -o spr_mlc.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MMV. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR System and Memory › MMV.
Hilfe zum PBXB64-Compiler

MMV.

Maus bewegen - System-, Tastatur-, Speicher-, Mapping- und Fensterhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / System and Memory

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

MMV. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `MMV.[x][|y][|speed]`.

Syntax

MMV.[x][|y][|speed]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | x | optional
P2 | y | optional
P3 | speed | optional

Verwendung

  • Nennen Sie die Desktop-, Prozess- oder Fenster-Voraussetzung direkt, damit das Beispiel ohne versteckte Umgebungsannahmen in ein reales Programm uebernommen werden kann.
  • Wenn der Befehl Handles, Tastatur, Maus oder Speicher beruehrt, zeigen Sie den exakten Vorher-/Nachher-Zustand, den der Aufrufer pruefen soll.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_mmv.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Environment-dependent when executed: moves the mouse.
MMV.0|0|10
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_mmv.mrt. Kompilieren mit PBXB64 examples/spr/spr_mmv.mrt -o spr_mmv.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MPO. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR System and Memory › MPO.
Hilfe zum PBXB64-Compiler

MPO.

Mausposition - System-, Tastatur-, Speicher-, Mapping- und Fensterhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / System and Memory

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

MPO. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `MPO.[x][|y][|hwnd]`.

Syntax

MPO.[x][|y][|hwnd]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | x | optional
P2 | y | optional
P3 | hwnd | optional

Verwendung

  • Nennen Sie die Desktop-, Prozess- oder Fenster-Voraussetzung direkt, damit das Beispiel ohne versteckte Umgebungsannahmen in ein reales Programm uebernommen werden kann.
  • Wenn der Befehl Handles, Tastatur, Maus oder Speicher beruehrt, zeigen Sie den exakten Vorher-/Nachher-Zustand, den der Aufrufer pruefen soll.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_mpo.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Environment-dependent when executed: positions/moves automation point.
MPO.0|0|0
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_mpo.mrt. Kompilieren mit PBXB64 examples/spr/spr_mpo.mrt -o spr_mpo.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MRC. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR System and Memory › MRC.
Hilfe zum PBXB64-Compiler

MRC.

Rechtsklick - System-, Tastatur-, Speicher-, Mapping- und Fensterhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / System and Memory

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

MRC. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `MRC.[x][|y][|hwnd]`.

Syntax

MRC.[x][|y][|hwnd]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | x | optional
P2 | y | optional
P3 | hwnd | optional

Verwendung

  • Nennen Sie die Desktop-, Prozess- oder Fenster-Voraussetzung direkt, damit das Beispiel ohne versteckte Umgebungsannahmen in ein reales Programm uebernommen werden kann.
  • Wenn der Befehl Handles, Tastatur, Maus oder Speicher beruehrt, zeigen Sie den exakten Vorher-/Nachher-Zustand, den der Aufrufer pruefen soll.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_mrc.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Environment-dependent when executed: right-clicks at coordinates.
MRC.-1|-1
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_mrc.mrt. Kompilieren mit PBXB64 examples/spr/spr_mrc.mrt -o spr_mrc.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MRE. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR System and Memory › MRE.
Hilfe zum PBXB64-Compiler

MRE.

Rechtes Mausereignis - System-, Tastatur-, Speicher-, Mapping- und Fensterhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / System and Memory

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

MRE. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `MRE.[x][|y][|hwnd]`.

Syntax

MRE.[x][|y][|hwnd]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | x | optional
P2 | y | optional
P3 | hwnd | optional

Verwendung

  • Nennen Sie die Desktop-, Prozess- oder Fenster-Voraussetzung direkt, damit das Beispiel ohne versteckte Umgebungsannahmen in ein reales Programm uebernommen werden kann.
  • Wenn der Befehl Handles, Tastatur, Maus oder Speicher beruehrt, zeigen Sie den exakten Vorher-/Nachher-Zustand, den der Aufrufer pruefen soll.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_mre.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Environment-dependent when executed: emits a right mouse event.
MRE.-1|-1
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_mre.mrt. Kompilieren mit PBXB64 examples/spr/spr_mre.mrt -o spr_mre.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SCW. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR System and Memory › SCW.
Hilfe zum PBXB64-Compiler

SCW.

Kindfenster suchen - System-, Tastatur-, Speicher-, Mapping- und Fensterhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / System and Memory

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

Sucht ein Kindfenster ueber Prototyp-Flags.

Syntax

SCW.prototypes[|prototype-parameters...]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | prototypes | erforderlich
P2 | prototype-parameters... | optional

Verwendung

  • Nennen Sie die Desktop-, Prozess- oder Fenster-Voraussetzung direkt, damit das Beispiel ohne versteckte Umgebungsannahmen in ein reales Programm uebernommen werden kann.
  • Wenn der Befehl Handles, Tastatur, Maus oder Speicher beruehrt, zeigen Sie den exakten Vorher-/Nachher-Zustand, den der Aufrufer pruefen soll.

Beschreibung

  • `SCW.` nutzt denselben Prototyp-Parser wie `STW.` im Kindfenster-Modus.
  • Prozess-/Thread-Flags werden auf das gefundene Kindfenster angewendet, bevor der Laufzeitcode den Treffer akzeptiert.
  • Jump-Flags verzweigen oder rufen Labels anhand des Suchergebnisses auf.
  • Automatisierte Headless-Laeufe sollen diese Seite als Syntax-, Link- und Laufzeitvertragsbeleg behandeln, nicht als sichtbare Desktop-Pruefung.
  • Die dokumentierte Form ist fuer deterministische Suchbedingungen gedacht und soll Ergebnisvariablen oder Sprungziele ausdruecklich pruefen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Environment-dependent when executed: searches child windows.
SCW.t|SPR sample
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_scw.mrt. Kompilieren mit PBXB64 examples/spr/spr_scw.mrt -o spr_scw.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Abhaengig vom live Windows-Desktop. Nicht numerische Token, automatische Bildschirmmodi und hostabhaengige Erweiterungen gehoeren nicht zum belegten Vertrag.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


STW. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR System and Memory › STW.
Hilfe zum PBXB64-Compiler

STW.

Hauptfenster suchen - System-, Tastatur-, Speicher-, Mapping- und Fensterhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / System and Memory

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

Sucht ein Top-Level-Fenster ueber Prototyp-Flags.

Syntax

STW.prototypes[|prototype-parameters...]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | prototypes | erforderlich
P2 | prototype-parameters... | optional

Verwendung

  • Nennen Sie die Desktop-, Prozess- oder Fenster-Voraussetzung direkt, damit das Beispiel ohne versteckte Umgebungsannahmen in ein reales Programm uebernommen werden kann.
  • Wenn der Befehl Handles, Tastatur, Maus oder Speicher beruehrt, zeigen Sie den exakten Vorher-/Nachher-Zustand, den der Aufrufer pruefen soll.

Beschreibung

  • Der erste Parameter ist ein Prototyp-String; weitere Parameter liefern Werte fuer Prototyp-Flags.
  • Klasse, Text und Handle identifizieren moegliche Fenster, und Prozess-/Thread-Flags filtern die Treffer vor der Rueckgabe des Handles.
  • Jump-Flags verzweigen oder rufen Labels anhand des Suchergebnisses auf.
  • Mehrdeutige Treffer werden durch die angegebenen Prototyp-Flags eingegrenzt; nicht belegte Hostfenster-Erweiterungen bleiben ausserhalb der zertifizierten Oberflaeche.
  • Die dokumentierte Form ist fuer deterministische Suchbedingungen gedacht und soll Ergebnisvariablen oder Sprungziele ausdruecklich pruefen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Environment-dependent when executed: searches top-level windows.
STW.t|SPR sample
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_stw.mrt. Kompilieren mit PBXB64 examples/spr/spr_stw.mrt -o spr_stw.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Abhaengig vom live Windows-Desktop. Plattformabhaengige Titelkodierung, mehrzeilige Titeltexte und historische Hostfenster-Erweiterungen brauchen eigene SPR-Beispiele.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CLW. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR System and Memory › CLW.
Hilfe zum PBXB64-Compiler

CLW.

Fenster schliessen - System-, Tastatur-, Speicher-, Mapping- und Fensterhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / System and Memory

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

CLW. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `CLW.[hwnd]`.

Syntax

CLW.[hwnd]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | hwnd | optional

Verwendung

  • Nennen Sie die Desktop-, Prozess- oder Fenster-Voraussetzung direkt, damit das Beispiel ohne versteckte Umgebungsannahmen in ein reales Programm uebernommen werden kann.
  • Wenn der Befehl Handles, Tastatur, Maus oder Speicher beruehrt, zeigen Sie den exakten Vorher-/Nachher-Zustand, den der Aufrufer pruefen soll.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_clw.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Environment-dependent when executed: closes a window handle or active window.
CLW.0
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_clw.mrt. Kompilieren mit PBXB64 examples/spr/spr_clw.mrt -o spr_clw.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


HTV. - PBXB64 SPR Help

Startseite › BASIC Frontend › SPR System and Memory › HTV.
Hilfe zum PBXB64-Compiler

HTV.

Handle in Variable - System-, Tastatur-, Speicher-, Mapping- und Fensterhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / System and Memory

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

HTV. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `HTV.[-|$$RES][|type]`.

Syntax

HTV.[-|$$RES][|type]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | - | optional
P2 | $$RES | erforderlich
P3 | type | optional

Verwendung

  • Nennen Sie die Desktop-, Prozess- oder Fenster-Voraussetzung direkt, damit das Beispiel ohne versteckte Umgebungsannahmen in ein reales Programm uebernommen werden kann.
  • Wenn der Befehl Handles, Tastatur, Maus oder Speicher beruehrt, zeigen Sie den exakten Vorher-/Nachher-Zustand, den der Aufrufer pruefen soll.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_htv.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

' Environment-dependent when executed: queries window handle/value.
VAR.$$RES=0
HTV.$$RES|a
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_htv.mrt. Kompilieren mit PBXB64 examples/spr/spr_htv.mrt -o spr_htv.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Übersicht über Datentypen – PBXB64-Hilfe

Startseite › Datentypen

Datentypen

PBXB64 unterstützt ein Rich-Type-System, das vier Domänen umfasst. Dieser Abschnitt dokumentiert jeden vom Compiler akzeptierten Typ, sein Speicherlayout, seinen Wertebereich, Suffixzeichen und die darauf verfügbaren Laufzeitoperationen.

Geben Sie Domänen ein

Domäne | Unterabschnitt | Was es abdeckt
Grundlegende numerische und Zeichenfolgentypen | BASIC-Datentypen | Die PowerBASIC-kompatiblen Skalare: BYTE, WORD, DWORD, INTEGER, LONG, QUAD, SINGLE, DOUBLE, EXTENDED, CURRENCY, CURRENCYX, STRING, BSTRING, WSTRING, VARIANT, GUID, Zeigertypen.
Breite Ganzzahltypen | Breite Ganzzahltypen | 128/256/512-Bit-Ganzzahlen mit fester Breite (INT128/UINT128 durch INT512/UINT512) mit nativem Inline-x64 Arithmetik.
Unbegrenzte / wissenschaftliche Typen | UNL – Unbegrenzte Ganzzahl, UNF-Familie, DEZIMAL128 | Typen mit willkürlicher Genauigkeit und exakter Dezimalzahl: UNL (unbegrenzte ganze Zahl), die UNF Familie (wissenschaftlicher Fixpunkt), und IEEE 754 DECIMAL128.
H-Lib-Containertypen | Native H-Lib-Container | Die 23 nativen Containerfamilien (LNARR, LNHSH, LNTRE, ...) als PB-Level-Typen mit method-dispatch verfügbar gemacht Syntax. Containervariablen werden automatisch initialisiert und automatisch finalisiert.

Typensystem auf einen Blick

Jeder PBXB64-Typ fällt in eine dieser Kategorien:

  • Integrale Skalare - BYTE (8), WORD (16), DWORD (32), INTEGER (16, PB-kompatibler Alias von LONG in PBXB64), LONG (32), QUAD (64), Wo angegeben, signiert und nicht signiert.
  • Gleitkomma-Skalare - SINGLE (32-Bit IEEE 754), DOUBLE (64-Bit IEEE 754), EXTENDED (80-Bit x87).
  • Festkomma-Skalare - CURRENCY (64-Bit / 10^4), CURRENCYX (128-Bit / 10^4, PBXB64-Erweiterung).
  • Breite ganze Zahlen - INT128/UINT128, INT256/UINT256, INT512/UINT512.
  • Unbegrenzt / wissenschaftlich - UNL (willkürliche Präzision), UNF Familie, DECIMAL128 (IEEE 754-2008).
  • String-Typen - STRING (dynamisch, ANSI), BSTRING (dynamischer BASIC-String-Kompatibilitaetstyp), STRINGZ (NUL-terminiert), WSTRING (dynamisch, UTF-16), WSTRINGZ (breiter NUL-terminiert), ASCIIZ.
  • Zusammengesetzte Typen - benutzerdefiniert TYPE/UNION, feste und dynamische Arrays, VARIANT, OBJECT, GUID.
  • Zeigertypen - getippte Zeiger (@), ANY (untypisiert), CODEPTR Funktionszeiger.
  • Containertypen - die 23 H-Lib-Familien (Arr, Stk, Que, Lst, ...).

Deklarationssyntax

LOCAL i AS LONG
LOCAL d AS DOUBLE
LOCAL big AS INT128
LOCAL huge AS UNL
LOCAL exact AS DECIMAL128
LOCAL name AS STRING
LOCAL oleName AS BSTRING
LOCAL pts AS LNARR OF Point    ' container of UDT
DIM arr(1 TO 10) AS LONG

Typsuffixe

PBXB64 berücksichtigt die traditionellen PB-Siegelsuffixe aus Gründen der Abwärtskompatibilität:

Suffix | Typ | Beispiel
% | GANZE ZAHL | v% = 5
& | LONG | v& = 100000
! | EINZEL | f! = 1.5
# | DOPPELT | d# = 3.14
$ | STRING | s$ = "hi"
?? | WORD | w?? = 60000
??? | DWORD | dw??? = 4000000000
&& | QUAD | q&& = 2^40
??? | DWORD | (dasselbe wie oben)
?# | WÄHRUNGX | c?# = 9.99

Siehe auch

  • BASIC-Datentypen (vollständige Referenz)
  • Wide Integer-Typen (INT128/256/512)
  • UNL – Ganzzahl mit unbegrenzter Genauigkeit
  • UNF-Familie – Wissenschaftlicher Fixpunkt
  • DECIMAL128 – IEEE 754-Dezimalzahl
  • Native H-Lib-Container (23 Familien)
  • BASIC-Variablen und -Bereich

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.

← Zurück zum Index


BASIC-Datentypen – PBXB64-Hilfe

Startseite › BASIC-Datentypen — PBXB64-Hilfe

BASIC-Datentypen

Auf dieser Seite werden die PowerBASIC-kompatiblen Skalar- und String-Typen dokumentiert Unterstützt von PBXB64. Für breite Ganzzahlen (128/256/512 Bit), unbegrenzt Präzision (UNL), wissenschaftliche Typen (UNF Familie, DECIMAL128) und Containertypen finden Sie im Übersicht über Datentypen.

Integrale Typen

Vorzeichenbehaftete und vorzeichenlose Ganzzahlen mit festen Breiten. Die Suffixspalte zeigt das traditionelle PB-Siegel für die Inline-Deklaration.

Typ | Größe | Suffix | Signiert | Reichweite | Alias
BYTE | 1 Byte | ? | unterzeichnet | -128 .. 127 | -
WORD | 2 Bytes | ?? | unsigniert | 0 .. 65.535 | -
INTEGER | 2 Bytes | % | unterzeichnet | -32.768 .. 32.767 | INT
LONG | 4 Bytes | & | unterzeichnet | -2.147.483.648 .. 2.147.483.647 | -
DWORD | 4 Bytes | ??? | unsigniert | 0 .. 4.294.967.295 | -
QUAD | 8 Byte | && | unterzeichnet | -2^63 .. 2^63-1 | -
UINT64 | 8 Byte | - | unsigniert | 0 .. 2^64-1 | -
Hinweis zu INTEGER: Im klassischen PowerBASIC, INTEGER ist ein 16-Bit-Typ. PBXB64 weist 8 Byte Slot-Speicher zu INTEGER Locals, um den Win64-Stack ausgerichtet zu halten und das zu vereinfachen Backend, aber das Wertebereich bleibt 16-Bit. Benutzen LONG wenn Sie eine vollständige 32-Bit-Ganzzahl benötigen.

Gleitkommatypen

Binärer Gleitkommawert nach IEEE 754. SINGLE ist 32-Bit, DOUBLE ist 64-Bit (die Standardeinstellung für Bruchliterale) und EXTENDED ist das 80-Bit-x87-Format (10 Bytes gespeichert).

Typ | Größe | Suffix | Signifikant | Exponentenbereich | Ungefähre Reichweite
SINGLE | 4 Bytes | ! | 24 Bit (~7 Ziffern) | -45 .. +38 | +/- 3,4e38
DOUBLE | 8 Byte | # | 53 Bit (~15 Ziffern) | -324 .. +308 | +/- 1,8e308
EXTENDED | 10 Byte | ## | 64 Bit (~19 Ziffern) | -4951 .. +4932 | +/- 1,2e4932
Binäre Rundung: SINGLE/DOUBLE kann nicht stellen die meisten Dezimalbrüche exakt dar (z. B. 0.1 ist periodisch im Binärformat). Für finanzielle oder exakte Dezimalarbeit verwenden Sie DECIMAL128 oder CURRENCY.

Festkommatypen

Typ | Größe | Suffix | Skalierung | Signifikanter Bereich
CURRENCY | 8 Byte | @ | / 10000 (4 dp) | +/- 922.337.203.685.477,5807
CURRENCYX | 16 Byte | ?# | / 10000 (4 dp) | +/- 9,9 * 10^15

CURRENCYX ist eine PBXB64-Erweiterung: ein 128-Bit-Festkommatyp Das verdoppelt die Reichweite CURRENCY unter Beibehaltung des Gleichen Skalierung mit 4 Nachkommastellen.

String-Typen

Typ | Suffix | Zeichensatz | Lagerung | Hinweise
STRING | $ | ANSI (8-Bit) | dynamischer Heap | Standard-String-Typ.
BSTRING | - | ANSI (8-Bit) | dynamischer Heap | Als dynamischer BASIC-String-Typ fuer Deklarationen, UDT-Felder, Parameter, Rueckgaben, Zuweisung, Verkettung, Vergleich und LEN akzeptiert.
STRINGZ | - | ANSI (8-Bit) | fester Puffer | NUL-terminiert; für die Win32-API.
ASCIIZ | - | ANSI (8-Bit) | fester Puffer | Alias von STRINGZ.
WSTRING | - | UTF-16 (16-Bit) | dynamischer Heap | Breite Zeichenfolge für Unicode-APIs.
WSTRINGZ | - | UTF-16 (16-Bit) | fester Puffer | NUL-terminierter breiter String.
STRING * N | - | ANSI (8-Bit) | feste N Bytes | Feste Länge; auf N gekürzt.
Hinweis zu BSTRING: In PBXB64 V14.4 ist BSTRING als dynamischer BASIC-String-Kompatibilitaetstyp implementiert und durch examples/basic/test_bstring_basic.pb geprueft. Es ist noch kein eigener COM-Automation-BSTR/UTF-16-ABI-Typ; COM-BSTR-Interop bleibt Teil des groesseren Unicode/COM-Backlogs.

Andere Skalartypen

Typ | Größe | Beschreibung
VARIANT | 16 Byte | Markierte Union: int/float/string/date/null. Typisierte Extraktion über VARIANT#/$/%.
GUID | 16 Byte | Global eindeutiger 128-Bit-Bezeichner.
OBJECT | 8 Byte | COM-Objektschnittstellenzeiger.
ANY | - | Untypisierter Zeiger; akzeptiert jede Variable als Referenz.
BYTE PTR / LONG PTR ... | 8 Byte | Typisierter Zeiger (@ Siegel).

Zusammengesetzte Typen

  • Benutzerdefinierter Typ (TYPE): Aufzeichnung benannter Felder, heterogene Typen, unterstützt Verschachtelung.
  • UNION: Felder teilen sich den Speicher.
  • Arrays: DIM a(1 TO 10) AS LONG (fest) oder REDIM (dynamisch, optional PRESERVE).

Beispiele für Deklarationen

LOCAL count AS LONG
LOCAL price AS CURRENCY
LOCAL rate AS DOUBLE
LOCAL name AS STRING
LOCAL oleName AS BSTRING
DIM matrix(1 TO 3, 1 TO 3) AS DOUBLE
REDIM items(100) AS STRING
REDIM PRESERVE items(200) AS STRING

TYPE Point
    x AS LONG
    y AS LONG
END TYPE
LOCAL p AS Point
p.x = 10
oleName = name + "-b"

LOCAL v AS VARIANT
v = 42
PRINT VARIANT#(v)     ' 42

Standardinitialisierung

  • Numerische Skalare initialisieren mit 0.
  • Strings werden initialisiert mit "" (leer).
  • VARIANT wird initialisiert, um leer zu sein.
  • Automatischer Aufruf von Containertypen .New bei der Einreise und .Final beim Verlassen des Bereichs.

Siehe auch

  • Übersicht über Datentypen
  • Wide Integer-Typen (INT128/256/512)
  • UNL – Ganzzahl mit unbegrenzter Genauigkeit
  • UNF-Familie – Wissenschaftlicher Fixpunkt
  • DECIMAL128 – IEEE 754-Dezimalzahl

← Zurück zu Datentypen

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


UNL – Ganzzahl mit unbegrenzter Genauigkeit – PBXB64-Hilfe

Startseite › UNL — Unlimited-Precision Integer — PBXB64-Hilfe
Hilfe zum PBXB64-Compiler

UNL – Ganzzahl mit unbegrenzter Genauigkeit

UNL ist der vorzeichenbehaftete Ganzzahltyp mit unbegrenzter Genauigkeit im PB/BASIC-Frontend. Verwenden Sie ihn, wenn LONG, QUAD oder die festen Wide-Integer-Typen nicht groß genug sind und der Wert exakt bleiben muss.

Typ: Datentyp | Kategorie: Numerische Typen

PBXB64-Status: AVAILABLE

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Frontend-Unterstützung

  • PB/BASIC: unterstützt als LOCAL, GLOBAL, Parameter, Array-Element, Ausdruckswert und FOR-Schleifenvariable.
  • C, B64, Rust, ASM, Forth, PILOT, LOGO, SPR: UNL ist dort kein Quelltext-Datentyp.
  • COBOL: COBOL verwendet eigene numerische PIC-Felder und Dezimalfunktionen; UNL ist dort kein benannter Quelltext-Datentyp.

Werte deklarieren

LOCAL n AS UNL
DIM values(1 TO 10) AS UNL

n = VALUNL("123456789012345678901234567890")
PRINT UNL$(n)

Genauigkeit und Wertebereich

UNL ist ein Ganzzahltyp. Deshalb gibt es keine Dezimalrundung, die man erhöhen oder verringern müsste. Addition, Subtraktion, Multiplikation, Ganzzahldivision, Rest, Vergleiche und Shifts arbeiten mit exakten Ganzzahlen. Die praktische Grenze ist verfügbarer Speicher und Rechenzeit, nicht eine feste Stellenzahl.

Wenn Sie einstellbare Dezimalgenauigkeit für Division brauchen, verwenden Sie die UNF-Familie und setzen Sie die Genauigkeit mit UNFPRECISION(n). Wenn eine feste Maximalbreite reicht, verwenden Sie INT128, INT256, INT512 oder die unsigned Varianten.

Konvertierung

Aufgabe | Verwendung | Hinweise
Text nach UNL einlesen | VALUNL(text$) | Der Text muss eine gültige vorzeichenbehaftete Dezimalzahl sein.
UNL als Text ausgeben | UNL$(value) | Gibt die kanonische Dezimaldarstellung zurück.
Kleine Literale zuweisen | n = 42 | Feste Integer-Werte werden automatisch konvertiert.
Sehr große Werte zuweisen | n = VALUNL("...") | Für Werte außerhalb normaler numerischer Literale Zeichenketten verwenden.

Unterstützte Operationen

Kategorie | Unterstützte Operationen | Hinweise
Arithmetik | +, -, *, Ganzzahldivision, Rest, Negation | Operanden werden nach jeder Operation normalisiert.
Bitweise Operationen | Nicht für UNL-Werte verfügbar. | Für Bitmasken feste Integer-Typen verwenden.
Shift | SHL, SHR | Implementiert als Multiplikation oder Division durch Zweierpotenzen.
Vergleich | =, <>, <, <=, >, >= | Vergleicht zuerst das Vorzeichen, dann die normalisierte Größe.
Schleifen | FOR i = VALUNL(...) TO VALUNL(...) | Positive und negative Integer-Schritte werden unterstützt.

Beispiel

FUNCTION PBMAIN() AS LONG
    LOCAL a AS UNL
    LOCAL b AS UNL
    a = VALUNL("123456789012345678901234567890")
    b = VALUNL("987654321098765432109876543210")
    PRINT UNL$(a + b)
    FUNCTION = 0
END FUNCTION

Den richtigen numerischen Typ wählen

Anforderung | Empfohlen
Schnelle normale Ganzzahlarithmetik | LONG oder QUAD
Bekannte feste Maximalbreite | INT128, INT256, INT512
Ganzzahlen, die ohne festes Limit wachsen können | UNL
Dezimal-/wissenschaftliche Werte mit einstellbarer Divisionsgenauigkeit | UNF / UNB mit UNFPRECISION(n)
Exakte COBOL-Festkommafelder | COBOL-PIC-Numerikfelder

Leistungshinweise

  • Kleine Werte tragen trotzdem variablen Verwaltungsaufwand; für heiße feste Breiten sind LONG, QUAD oder Wide-Integer-Typen meist besser.
  • Multiplikation und Division werden mit steigender Stellenzahl teurer.
  • String-Konvertierung ist teurer als reine Arithmetik und sollte in engen Schleifen nur für Ausgabe oder Serialisierung verwendet werden.

Verifikationshinweise

UNL-Code sollte Null, positive Werte, negative Werte, Wachstum über interne Grenzen hinweg und Rückkonvertierung nach Text testen. Division und Rest sollten exakte und nicht-exakte Division abdecken.

Siehe auch

  • Übersicht über Datentypen
  • UNF-Familie – Wissenschaftliche Typen
  • DECIMAL128 – IEEE 754-Dezimalzahl
  • Wide Integer-Typen (INT128/256/512)
  • BASIC-Datentypen (QUAD)

← Zurück zu Datentypen

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


DECIMAL128 – IEEE 754 Dezimal – PBXB64-Hilfe

Startseite › DECIMAL128 – IEEE 754-Dezimal

DECIMAL128 – IEEE 754-2008 Dezimalzahl

DECIMAL128 ist IEEE 754-2008 dezimal128 Format: a 128-Bit-Dezimal-Gleitkommatyp, der Dezimalbrüche darstellt genau (im Gegensatz zu binär DOUBLE, was nicht 0,1 darstellen kann ohne Rundungsfehler). Es ist für finanzielle und wissenschaftliche Zwecke gedacht Berechnungen, bei denen die Dezimalgenauigkeit zwingend erforderlich ist.

Typ: Datentyp | Kategorie: Numerische Typen

PBXB64-Status: VERFÜGBAR (Wissenschaftslaufzeit)

PBXB64-Zertifizierung: [WISSENSCHAFTSSTUFE]

Lagerlayout

  • Größe: 16 Byte (128 Bit)
  • Genauigkeit: 34 Dezimalstellen des Signifikanten
  • Exponentenbereich: -6143 bis +6144
  • Format: IEEE 754-2008 dezimal128 (Koeffizient + voreingenommener Exponent, mit Vorzeichen)

Warum DECIMAL128?

Binäre Gleitkommatypen (SINGLE, DOUBLE) kann nicht stellen die meisten Dezimalbrüche exakt dar. Zum Beispiel in DOUBLE:

d# = 0.1 + 0.2
PRINT d#      ' 0.30000000000000004  (not exactly 0.3)

DECIMAL128 speichert die Zahl als Dezimalkoeffizienten und Exponent, also 0.1 + 0.2 ist genau 0.3. Das ist wichtig für:

  • Finanzsoftware - Cent müssen sich genau summieren.
  • Abrechnung/Steuer - Für exakte Dezimalzahlen müssen Rundungsregeln gelten.
  • Wissenschaftliche Messung - wenn die aufgezeichneten Werte selbst dezimal sind.

Beziehung zur WÄHRUNG

Typ | Größe | Präzision | Skalierung | Reichweite
CURRENCY | 8 Byte | 15 Ziffern | fest /10000 | +/- 922 Billionen
CURRENCYX | 16 Byte | 19 Ziffern | fest /10000 | +/- 9,9 * 10^15
DECIMAL128 | 16 Byte | 34 Ziffern | dynamischer Exponent | +/- 9,99e6144

CURRENCY/CURRENCYX sind Festkommazahlen (immer 4 Dezimalzahlen). Orte). DECIMAL128 ist ein Gleitkomma mit einem dynamischen Exponenten, Dies ermöglicht einen viel größeren Bereich auf Kosten variabler Präzision.

Laufzeitunterstützung

DECIMAL128 Operationen werden von der Science Runtime bereitgestellt (pb_science_decimal128.o), verknüpft mit ausführbaren Benutzerdateien, die verwenden der Typ. Zu den unterstützten Vorgängen gehören:

  • Arithmetik: Addieren, Subtrahieren, Multiplizieren, Dividieren (korrekt gerundet gemäß IEEE 754).
  • Vergleich: gleich, kleiner als, größer als (einschließlich NaN/Infinity-Handhabung).
  • Konvertierung: nach/von DOUBLE, STRING, Ganzzahltypen.
  • Rundungsmodi: Auf die nächste gerade Zahl runden (Standard), gegen Null, gegen Unendlich.

Beispiel

' Financial calculation - exact decimal arithmetic
LOCAL price AS DECIMAL128
LOCAL total AS DECIMAL128
price = 19.99
total = price * 3        ' exactly 59.97
PRINT total              ' 59.97 (no binary rounding error)

Einschränkungen in PBXB64

  • DECIMAL128 Literale werden zur Kompilierungszeit dezimal analysiert Text. Sehr große Exponenten können an Präzision verlieren, wenn das Literal 34 überschreitet signifikante Ziffern.
  • Direktes Mischen von DECIMAL128 und binäres Gleitkomma in a Ein einzelner Ausdruck erfordert eine explizite Konvertierung, um Stille zu vermeiden Präzisionsverlust.
  • Die Science Runtime fügt der vom Benutzer ausführbaren Datei etwa 40 KB hinzu.

Siehe auch

  • BASIC-Datentypen (CURRENCY, CURRENCYX)
  • UNF-Familie – Wissenschaftlicher Fixpunkt
  • UNL – Ganzzahl mit unbegrenzter Genauigkeit

← Zurück zu Datentypen

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


Wide Integer-Typen (INT128/256/512) – PBXB64-Hilfe

Startseite › Wide-Integer-Typen — PBXB64-Hilfe

Wide Integer-Typen (INT128 / INT256 / INT512)

PBXB64 fügt Wide-Integer-Typen mit fester Breite über den Standard 8/16/32/64-Bit hinaus hinzu Bereich. Diese Typen werden mit nativem Inline-x64-Code für Arithmetik implementiert. bitweise und Vergleichsoperationen – keine Laufzeitbibliotheksaufrufe für das Hot Wege. Sie werden für Kryptografie, Hashing, große Zähler und wissenschaftliche Zwecke verwendet Berechnen, wo sonst ein 64-Bit-Überlauf auftreten würde.

Typ: Datentypfamilie | Kategorie: Numerische Typen

PBXB64-Status: AVAILABLE

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Unterstützte Typen

Typ | Alias | Größe | Signiert | Reichweite | Dezimalstellen
INT128 | I128 | 16 Byte | ja | -2^127 .. 2^127-1 | ~38
UINT128 | U128 | 16 Byte | Nein | 0 .. 2^128-1 | ~39
INT256 | I256 | 32 Byte | ja | -2^255 .. 2^255-1 | ~77
UINT256 | U256 | 32 Byte | Nein | 0 .. 2^256-1 | ~78
INT512 | I512 | 64 Byte | ja | -2^511 .. 2^511-1 | ~154
UINT512 | U512 | 64 Byte | Nein | 0 .. 2^512-1 | ~155

Lagerlayout

Wide-Ganzzahlen werden in Little-Endian-Bytereihenfolge im zusammenhängenden Speicher gespeichert. INT128/UINT128 belegen 16 Bytes (zwei 64-Bit-Teile); INT256/UINT256 belegen 32 Bytes (vier Glieder); INT512/UINT512 belegen 64 Bytes (acht Glieder). Einheimische sind auf 16 Bytes stapelorientiert.

Unterstützte Operationen

Kategorie | Operationen | Hinweise
Arithmetik | +, -, *, \ (int div), MOD | 128-Bit-Multifunktionsanwendungen mul/imul mit adc; 256/512 nutzen Schulbuch.
Bitweise | AND, OR, XOR, NOT | Gehen Sie Glied für Glied vor.
Schichten | SHL, SHR, SAR | Verwendenshld/shrd für Querverlagerungen.
Vergleich | =, <>, <, <=, >, >= | Rückgaben -1 (wahr) / 0 (falsch).
Konvertierung | nach/von STRING, QUAD, LONG | Analyse/Formatierung von Dezimalzeichenfolgen.

Deklaration und Verwendung

LOCAL a AS INT128
LOCAL b AS U128
LOCAL c AS INT256
LOCAL d AS UINT512

a = 2^100              ' fits in INT128 (max ~3.4e38)
b = 2^128 - 1          ' largest UINT128
c = a * a              ' 2^200, still fits in INT256
d = c * c              ' 2^400, fits in INT512

PRINT a                ' decimal string output
IF a > b THEN PRINT "a is bigger"

Wann sollten breite Ganzzahlen im Vergleich zu UNL verwendet werden?

Brauchen | Benutzen | Warum
Feste Breite, bekannte Grenze ≤ 512 Bit | INT128..UINT512 | Schneller: keine Zuordnung, keine Längenverfolgung, Inline-Assembly.
Unbegrenzte Größe | UNL | Wächst nach Bedarf; langsamer pro Operation, aber nie ein Überlauf.
Kryptografisches 256-Bit (z. B. secp256k1) | UINT256 | Exakte Passform, konstante Zeitfähigkeit.
SHA-512-Zwischenzustände | UINT512 | Entspricht der nativen Breite des Algorithmus.

Beziehung zu QUAD und CURRENCY

QUAD (64-Bit-signiert) ist der größte Standard PBXB64 Ganzzahl. Die breiten Typen erstrecken sich nach oben QUAD:

QUAD (64-bit) < INT128 (128-bit) < INT256 (256-bit) < INT512 (512-bit)
                      |
                      +-- UNL (unbounded, grows dynamically)

Siehe auch

  • Übersicht über Datentypen
  • BASIC-Datentypen (QUAD)
  • UNL – Ganzzahl mit unbegrenzter Genauigkeit
  • UNF-Familie – Wissenschaftliche Typen

← Zurück zu Datentypen

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


INT128 / I128 – 128-Bit-Ganzzahl mit Vorzeichen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › INT128 / I128 – 128-Bit-Ganzzahl mit Vorzeichen
Hilfe zum PBXB64-Compiler

INT128 / I128 – 128-Bit-Ganzzahl mit Vorzeichen

Eine 128-Bit-Ganzzahl mit Vorzeichen und vollständiger Unterstützung für Inline-Arithmetik. Der Bereich beträgt ungefähr -1,7×1038 bis +1,7×1038 (-2127 bis 2127-1).

Typ: Datentyp | Kategorie: Numerische Typen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Erklärung

LOCAL a AS INT128
LOCAL b AS I128

Größe und Ausrichtung

  • Größe: 16 Bytes (2 × 64-Bit-Wörter)
  • Ausrichtung: 16 Byte

Arithmetische Operationen

Alle Vorgänge sind nativer Inline-x64-Code – keine Laufzeitbibliotheksaufrufe:

Betrieb | Umsetzung
HINZUFÜGEN, SUB | Carry-Chain über zwei 64-Bit-Wörter mit CMP_LT
UND, ODER, XOR | Unabhängige wortweise Operationen
SHL, SHR | Kreuzwortverschiebung mit Übertragsausbreitung
MUL | UMULH/SMULH-Opcodes – Schulbuchalgorithmus (lo×lo, MULH, Cross-Terms)
DIV, REM | Inline-IR-Zerlegung mit lokaler Implementierung von __udivti3/__umodti3
CMP | Lexikografischer Vergleich: vorzeichenbehaftetes MSB, vorzeichenloses unteres Wort

Beispiel

FUNCTION PBMAIN() AS LONG
  LOCAL a AS INT128
  LOCAL b AS INT128
  LOCAL c AS INT128

  a = 1000000000000000000000  ' 10^21
  b = 2000000000000000000000  ' 2×10^21
  c = a + b                 ' 3×10^21
  PRINT c

  c = a * b                 ' 2×10^42 — fits in 128 bits
  PRINT c

  FUNCTION = 0
END FUNCTION

Siehe auch

  • UINT128 / U128 — Vorzeichenlose 128-Bit-Ganzzahl
  • INT256 / I256 — 256-Bit-Ganzzahl mit Vorzeichen
  • INT512 / I512 — 512-Bit-Ganzzahl mit Vorzeichen
  • LONG — 32-Bit-Ganzzahl mit Vorzeichen
  • QUAD — 64-Bit-Ganzzahl mit Vorzeichen

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UINT128 / U128 – 128-Bit-Ganzzahl ohne Vorzeichen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › UINT128 / U128 – 128-Bit-Ganzzahl ohne Vorzeichen
Hilfe zum PBXB64-Compiler

UINT128 / U128 – 128-Bit-Ganzzahl ohne Vorzeichen

Eine 128-Bit-Ganzzahl ohne Vorzeichen mit vollständiger Unterstützung für Inline-Arithmetik. Der Bereich liegt zwischen 0 und 3,4×1038 (0 bis 2128-1).

Typ: Datentyp | Kategorie: Numerische Typen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Erklärung

LOCAL a AS UINT128
LOCAL b AS U128

Größe und Ausrichtung

  • Größe: 16 Bytes (2 × 64-Bit-Wörter)
  • Ausrichtung: 16 Byte

Arithmetische Operationen

Alle Vorgänge sind nativer Inline-x64-Code – keine Laufzeitbibliotheksaufrufe:

Betrieb | Umsetzung
HINZUFÜGEN, SUB | Carry-Chain über zwei 64-Bit-Wörter mit CMP_LT
UND, ODER, XOR | Unabhängige wortweise Operationen
SHL, SHR | Kreuzwortverschiebung mit Übertragsausbreitung
MUL | UMULH-Opcode – Schulbuchalgorithmus (lo×lo, UMULH, Cross-Terms)
DIV, REM | Inline-IR-Zerlegung mit lokaler __udivti3-Implementierung
CMP | Lexikografischer, vorzeichenloser Vergleich beider Wörter

Beispiel

FUNCTION PBMAIN() AS LONG
  LOCAL a AS UINT128
  LOCAL b AS UINT128
  LOCAL c AS UINT128

  a = 18446744073709551615   ' 2^64 - 1
  b = 1
  c = a + b                  ' 2^64 — fits in 128 bits
  PRINT c

  FUNCTION = 0
END FUNCTION

Beschreibung

UINT128 / U128 – 128-Bit-Ganzzahl ohne Vorzeichen gehoert zur Kategorie General. Diese Seite beschreibt den PBXB64-Dokumentationsstand fuer diesen Eintrag; verwenden Sie die Grenzen und Belege auf dieser Seite statt historischer PBWin-Annahmen.

Syntax

' Siehe den urspruenglichen Eintrag und die verlinkten Beispiel-/Testdateien fuer die genaue PBXB64-Form von UINT128 / U128 – 128-Bit-Ganzzahl ohne Vorzeichen.
' Nicht belegte Unterformen bleiben ausserhalb der zertifizierten Oberflaeche.

Praktische Verwendung

UINT128 / U128 – 128-Bit-Ganzzahl ohne Vorzeichen gehoert zur Kategorie General. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' UINT128 / U128 – 128-Bit-Ganzzahl ohne Vorzeichen mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Siehe auch

  • INT128 / I128 — Vorzeichenbehaftete 128-Bit-Ganzzahl
  • UINT256 / U256 — Vorzeichenlose 256-Bit-Ganzzahl
  • UINT512 / U512 — Vorzeichenlose 512-Bit-Ganzzahl
  • DWORD — 32-Bit-Ganzzahl ohne Vorzeichen
  • QUAD — 64-Bit-Ganzzahl mit Vorzeichen


INT256 / I256 – 256-Bit-Ganzzahl mit Vorzeichen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › INT256 / I256 – 256-Bit-Ganzzahl mit Vorzeichen
Hilfe zum PBXB64-Compiler

INT256 / I256 – 256-Bit-Ganzzahl mit Vorzeichen

Eine 256-Bit-Ganzzahl mit Vorzeichen mit Inline-ADD/SUB/CMP/AND/OR/XOR/SHL und optimierter Laufzeit MUL/DIV/REM. Der Bereich beträgt ungefähr −5,8×1076 bis +5,8×1076 (−2255 bis 2255−1).

Typ: Datentyp | Kategorie: Numerische Typen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Erklärung

LOCAL a AS INT256
LOCAL b AS I256

Größe und Ausrichtung

  • Größe: 32 Bytes (4 × 64-Bit-Wörter)
  • Ausrichtung: 16 Byte
  • Stapelplatz: Ein 32-Byte-Frame-Objekt

Arithmetische Operationen

Alle Vorgänge sind nativer x64-Code. Einfache Operationen (ADD, SUB, CMP, AND, OR, XOR, SHL) werden als Inline-Befehlssequenzen ausgegeben. Multiplikation und Division nutzen optimierte C-Laufzeithilfsprogramme, die in die vom Benutzer ausführbare Datei kompiliert werden.

Betrieb | Umsetzung | Leistung
HINZUFÜGEN | Carry-Chain über vier 64-Bit-Wörter mit ADC (Add-with-Carry) | Inline, 4 Anweisungen
SUB | Borrow-Chain über vier 64-Bit-Wörter mit SBB (Subtrahieren mit Ausleihen) | Inline, 4 Anweisungen
UND, ODER, XOR | Unabhängige wortweise Operationen über vier 64-Bit-Wörter | Inline, jeweils 4 Anweisungen
SHL | Kreuzwortverschiebung mit Übertragsausbreitung: Wortverschiebung + Bitverschiebung | Inline, ~10 Anweisungen
SHR | Arithmetische Rechtsverschiebung: Ausbreitung von Zeichenfüllungen über Wörter hinweg | Inline, ~10 Anweisungen
CMP | Lexikografischer Vergleich: vorzeichenbehaftetes MSB-Wort, dann vorzeichenlose niedrigere Wörter | Inline, ~6 Anweisungen
NEG | Zweierkomplement: bitweises NICHT + Inkrementieren mit Übertrag | Inline, ~8 Anweisungen
MUL | Schulbuch-Multiplikation mit unsigned __int128 (128-Bit) Akkumulator für Kreuzbegriffe; 4×4-Wortmatrix | Optimierter Multiplikationspfad
DIV | Lange Division mit schrittweiser Probesubtraktion | Optimierter Divisionspfad
REM | Gleicher Divisionsalgorithmus, gibt Rest zurück | Optimierter Restwertpfad

Implementierungsdetails

Addition und Subtraktion

Der Compiler gibt eine Inline-Carry-Chain aus:

; ADD (a + b -> out)
mov  rax, [a+0]   ; load low word
add  rax, [b+0]   ; add low word
mov  [out+0], rax ; store low result
mov  rax, [a+8]
adc  rax, [b+8]   ; add-with-carry
mov  [out+8], rax
mov  rax, [a+16]
adc  rax, [b+16]
mov  [out+16], rax
mov  rax, [a+24]
adc  rax, [b+24]
mov  [out+24], rax

Multiplikation

Die Multiplikation verwendet einen Schulbuchalgorithmus. Für jedes Paar von 64-Bit-Wörtern a[i] × b[j], wird das 128-Bit-Produkt in einem temporären 512-Bit-Array akkumuliert, dann werden die unteren 256 Bits als Ergebnis gespeichert. PBXB64 verwendet seinen optimierten Wide-Integer-Multiplikationspfad.

Division und Rest

Bei der Division wird eine lange Division mit Probesubtraktion verwendet. Bei einer vorzeichenbehafteten Division konvertiert der Algorithmus zunächst beide Operanden in vorzeichenlose (Zweierkomplement-Negation, wenn negativ), führt eine vorzeichenlose lange Division durch und wendet dann das richtige Vorzeichen auf den Quotienten und den Rest an. PBXB64 verwendet seine optimierten Wide-Integer-Pfade fuer Division und Restwert.

Leistungshinweis: DIV und REM sind die langsamsten Vorgänge. Verwenden Sie für Divisionen durch Zweierpotenzen stattdessen die Rechtsverschiebung (SHR), die vollständig inline und viel schneller ist.

Einschränkungen

  • Division durch Null wird vom Compiler nicht abgefangen; Es erzeugt zur Laufzeit einen Quotienten von Null und einen Rest von Null.
  • Rechtsverschiebung (SHR) ist arithmetisch (Vorzeichenfüllung) und steht im Einklang mit der vorzeichenbehafteten Ganzzahlsemantik.
  • Zur Kompilierungszeit können nur ganzzahlige Literalwerte zugewiesen werden, die in die interne Darstellung des Compilers passen. Sehr große Werte (über ~263) muss arithmetisch aufgebaut werden.

Beispiele

Beispiel 1: Einfache Addition und Subtraktion

FUNCTION PBMAIN() AS LONG
  LOCAL a AS INT256
  LOCAL b AS INT256
  LOCAL c AS INT256

  a = 1000000000000000000000000000000  ' 10^30
  b = 2000000000000000000000000000000  ' 2*10^30
  c = a + b                           ' 3*10^30
  PRINT c

  c = a - b                           ' -10^30
  PRINT c

  FUNCTION = 0
END FUNCTION

Beispiel 2: Multiplikation und Division

FUNCTION PBMAIN() AS LONG
  LOCAL a AS INT256
  LOCAL b AS INT256
  LOCAL c AS INT256

  a = 1000000000000000000  ' 10^18
  b = 1000000000000000000  ' 10^18
  c = a * b                ' 10^36 — fits in 256 bits
  PRINT c

  c = c / a                ' back to 10^18
  PRINT c

  FUNCTION = 0
END FUNCTION

Beispiel 3: Bitweise Operationen und Vergleich

FUNCTION PBMAIN() AS LONG
  LOCAL a AS INT256
  LOCAL b AS INT256
  LOCAL c AS INT256

  a = 255
  b = 15
  c = a AND b          ' 15
  PRINT c

  c = a OR b           ' 255
  PRINT c

  c = a XOR b          ' 240
  PRINT c

  a = 1000
  b = 500
  IF a > b THEN PRINT "a is greater"

  FUNCTION = 0
END FUNCTION

Beispiel 4: Schichtbetrieb

FUNCTION PBMAIN() AS LONG
  LOCAL a AS INT256
  LOCAL b AS INT256

  a = 1
  b = a SHL 100        ' 2^100
  PRINT b

  b = b SHR 50         ' 2^50
  PRINT b

  FUNCTION = 0
END FUNCTION

Beispiel 5: Beispiel für die Kryptographie großer Zahlen

FUNCTION PBMAIN() AS LONG
  LOCAL p AS INT256
  LOCAL q AS INT256
  LOCAL n AS INT256

  ' Two 128-bit prime-like numbers
  p = 340282366920938463463374607431768211456
  q = 340282366920938463463374607431768211457
  n = p * q            ' 256-bit product
  PRINT n

  FUNCTION = 0
END FUNCTION

Siehe auch

  • INT128 / I128 — 128-Bit-Ganzzahl mit Vorzeichen
  • INT512 / I512 — 512-Bit-Ganzzahl mit Vorzeichen
  • UINT256 / U256 — Vorzeichenlose 256-Bit-Ganzzahl
  • LONG — 32-Bit-Ganzzahl mit Vorzeichen
  • QUAD — 64-Bit-Ganzzahl mit Vorzeichen

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UINT256 / U256 – 256-Bit-Ganzzahl ohne Vorzeichen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › UINT256 / U256 – 256-Bit-Ganzzahl ohne Vorzeichen
Hilfe zum PBXB64-Compiler

UINT256 / U256 – 256-Bit-Ganzzahl ohne Vorzeichen

Eine 256-Bit-Ganzzahl ohne Vorzeichen mit Inline-ADD/SUB/CMP/AND/OR/XOR/SHL und optimierter Laufzeit MUL/DIV/REM. Der Bereich liegt zwischen 0 und etwa 1,16×1077 (0 bis 2256−1).

Typ: Datentyp | Kategorie: Numerische Typen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Erklärung

LOCAL a AS UINT256
LOCAL b AS U256

Größe und Ausrichtung

  • Größe: 32 Bytes (4 × 64-Bit-Wörter)
  • Ausrichtung: 16 Byte
  • Stapelplatz: Ein 32-Byte-Frame-Objekt

Arithmetische Operationen

Alle Vorgänge sind nativer x64-Code. Einfache Operationen (ADD, SUB, CMP, AND, OR, XOR, SHL) werden als Inline-Befehlssequenzen ausgegeben. Multiplikation und Division nutzen optimierte C-Laufzeithilfsprogramme, die in die vom Benutzer ausführbare Datei kompiliert werden.

Betrieb | Umsetzung | Leistung
HINZUFÜGEN | Carry-Chain über vier 64-Bit-Wörter mit ADC (Add-with-Carry) | Inline, 4 Anweisungen
SUB | Borrow-Chain über vier 64-Bit-Wörter mit SBB (Subtrahieren mit Ausleihen) | Inline, 4 Anweisungen
UND, ODER, XOR | Unabhängige wortweise Operationen über vier 64-Bit-Wörter | Inline, jeweils 4 Anweisungen
SHL | Kreuzwortverschiebung mit Übertragsausbreitung: Wortverschiebung + Bitverschiebung | Inline, ~10 Anweisungen
SHR | Logische Rechtsverschiebung: Ausbreitung von Nullfüllungen über Wörter hinweg | Inline, ~10 Anweisungen
CMP | Lexikografischer vorzeichenloser Vergleich aller Wörter (MSB bis LSB) | Inline, ~6 Anweisungen
NEG | Zweierkomplement: bitweises NICHT + Inkrementieren mit Übertrag | Inline, ~8 Anweisungen
MUL | Schulbuch-Multiplikation mit unsigned __int128 (128-Bit) Akkumulator für Kreuzbegriffe; 4×4-Wortmatrix | Optimierter Multiplikationspfad
DIV | Lange Division mit schrittweiser Probesubtraktion | Optimierter Divisionspfad
REM | Gleicher Divisionsalgorithmus, gibt Rest zurück | Optimierter Restwertpfad

Implementierungsdetails

Addition und Subtraktion

Der Compiler gibt eine Inline-Carry-Chain mit aus ADC (add-with-carry) für Addition und SBB (subtract-with-borrow) für die Subtraktion über vier 64-Bit-Wörter:

; ADD (a + b -> out)
mov  rax, [a+0]   ; load low word
add  rax, [b+0]   ; add low word
mov  [out+0], rax ; store low result
mov  rax, [a+8]
adc  rax, [b+8]   ; add-with-carry
mov  [out+8], rax
mov  rax, [a+16]
adc  rax, [b+16]
mov  [out+16], rax
mov  rax, [a+24]
adc  rax, [b+24]
mov  [out+24], rax

Multiplikation

Die Multiplikation verwendet einen Schulbuchalgorithmus. Für jedes Paar von 64-Bit-Wörtern a[i] × b[j], wird das 128-Bit-Produkt in einem temporären 512-Bit-Array akkumuliert, dann werden die unteren 256 Bits als Ergebnis gespeichert. PBXB64 verwendet seinen optimierten Wide-Integer-Multiplikationspfad.

Division und Rest

Bei der Division wird eine vorzeichenlose lange Division mit Probesubtraktion verwendet. Der Algorithmus richtet den Divisor am höchstwertigen Bit des Dividenden aus, iteriert dann bitweise und subtrahiert, wenn der aktuelle Rest größer oder gleich dem ausgerichteten Divisor ist. PBXB64 verwendet seine optimierten Wide-Integer-Pfade fuer Division und Restwert.

Leistungshinweis: DIV und REM sind die langsamsten Vorgänge. Verwenden Sie für Divisionen durch Zweierpotenzen stattdessen die Rechtsverschiebung (SHR), die vollständig inline und viel schneller ist. SHR ohne Vorzeichen ist logisch (Nullfüllung) und eignet sich daher ideal zum Extrahieren von Bitfeldern.

Einschränkungen

  • Division durch Null wird vom Compiler nicht abgefangen; Es erzeugt zur Laufzeit einen Quotienten von Null und einen Rest von Null.
  • Rechtsverschiebung (SHR) ist logisch (Nullfüllung), im Gegensatz zu vorzeichenbehafteten Ganzzahlen, die eine arithmetische Verschiebung (Vorzeichenfüllung) verwenden.
  • Zur Kompilierungszeit können nur ganzzahlige Literalwerte zugewiesen werden, die in die interne Darstellung des Compilers passen. Sehr große Werte (über ~263) muss durch arithmetische oder Schiebeoperationen aufgebaut werden.

Beispiele

Beispiel 1: Grundlegende Addition und Wraparound

FUNCTION PBMAIN() AS LONG
  LOCAL a AS UINT256
  LOCAL b AS UINT256
  LOCAL c AS UINT256

  a = 340282366920938463463374607431768211455  ' 2^128 - 1
  b = 1
  c = a + b                                  ' 2^128 — wraps naturally in 256 bits
  PRINT c

  c = c - b                                  ' back to 2^128 - 1
  PRINT c

  FUNCTION = 0
END FUNCTION

Beispiel 2: Multiplikation und Division

FUNCTION PBMAIN() AS LONG
  LOCAL a AS UINT256
  LOCAL b AS UINT256
  LOCAL c AS UINT256

  a = 1000000000000000000  ' 10^18
  b = 1000000000000000000  ' 10^18
  c = a * b                ' 10^36 — fits in 256 bits
  PRINT c

  c = c / a                ' back to 10^18
  PRINT c

  FUNCTION = 0
END FUNCTION

Beispiel 3: Bitweise Maskierung und Bitextraktion

FUNCTION PBMAIN() AS LONG
  LOCAL mask AS UINT256
  LOCAL value AS UINT256
  LOCAL result AS UINT256

  ' Create a 128-bit mask: bits 0-127 set to 1
  mask = 0
  mask = NOT mask              ' all 256 bits set to 1
  mask = mask SHR 128          ' top 128 bits set to 1
  mask = NOT mask              ' bottom 128 bits set to 1

  value = 12345678901234567890
  result = value AND mask      ' mask lower 128 bits
  PRINT result

  FUNCTION = 0
END FUNCTION

Beispiel 4: Schiebeoperationen für das Bit-Packen

FUNCTION PBMAIN() AS LONG
  LOCAL a AS UINT256
  LOCAL b AS UINT256
  LOCAL packed AS UINT256

  a = 255
  b = 511
  packed = a SHL 8             ' a in bits 8-15
  packed = packed OR b         ' b in bits 0-8
  PRINT packed

  ' Extract a back
  a = packed SHR 8 AND 255
  PRINT a

  FUNCTION = 0
END FUNCTION

Beispiel 5: Große Fibonacci-Zahlen

FUNCTION PBMAIN() AS LONG
  LOCAL a AS UINT256
  LOCAL b AS UINT256
  LOCAL c AS UINT256
  LOCAL i AS LONG

  a = 0
  b = 1
  FOR i = 1 TO 100
    c = a + b
    a = b
    b = c
  NEXT i
  PRINT b    ' 100th Fibonacci number (~3.5*10^20)

  FUNCTION = 0
END FUNCTION

Siehe auch

  • UINT128 / U128 — 128-Bit-Ganzzahl ohne Vorzeichen
  • UINT512 / U512 — 512-Bit-Ganzzahl ohne Vorzeichen
  • INT256 / I256 — Vorzeichenbehaftete 256-Bit-Ganzzahl
  • DWORD — 32-Bit-Ganzzahl ohne Vorzeichen
  • QUAD — 64-Bit-Ganzzahl mit Vorzeichen

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


INT512 / I512 – 512-Bit-Ganzzahl mit Vorzeichen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › INT512 / I512 – 512-Bit-Ganzzahl mit Vorzeichen
Hilfe zum PBXB64-Compiler

INT512 / I512 – 512-Bit-Ganzzahl mit Vorzeichen

Eine 512-Bit-Ganzzahl mit Vorzeichen mit Inline-ADD/SUB/CMP/AND/OR/XOR/SHL und optimierter Laufzeit MUL/DIV/REM. Der Bereich beträgt ungefähr −6,7×10153 bis +6,7×10153 (−2511 bis 2511−1).

Typ: Datentyp | Kategorie: Numerische Typen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Erklärung

LOCAL a AS INT512
LOCAL b AS I512

Größe und Ausrichtung

  • Größe: 64 Bytes (8 × 64-Bit-Wörter)
  • Ausrichtung: 32 Byte
  • Stapelplatz: Ein 64-Byte-Frame-Objekt

Arithmetische Operationen

Alle Vorgänge sind nativer x64-Code. Einfache Operationen (ADD, SUB, CMP, AND, OR, XOR, SHL) werden als Inline-Befehlssequenzen ausgegeben. Multiplikation und Division nutzen optimierte C-Laufzeithilfsprogramme, die in die vom Benutzer ausführbare Datei kompiliert werden.

Betrieb | Umsetzung | Leistung
HINZUFÜGEN | Carry-Chain über acht 64-Bit-Wörter mit ADC (Add-with-Carry) | Inline, 8 Anweisungen
SUB | Leihekette über acht 64-Bit-Wörter mit SBB (Subtrahieren mit Ausleihen) | Inline, 8 Anweisungen
UND, ODER, XOR | Unabhängige wortweise Operationen über acht 64-Bit-Wörter | Inline, jeweils 8 Anweisungen
SHL | Kreuzwortverschiebung mit Übertragsausbreitung: Wortverschiebung + Bitverschiebung | Inline, ~20 Anweisungen
SHR | Arithmetische Rechtsverschiebung: Ausbreitung von Zeichenfüllungen über Wörter hinweg | Inline, ~20 Anweisungen
CMP | Lexikografischer Vergleich: vorzeichenbehaftetes MSB-Wort, dann vorzeichenlose niedrigere Wörter | Inline, ~12 Anweisungen
NEG | Zweierkomplement: bitweises NICHT + Inkrementieren mit Übertrag | Inline, ~16 Anweisungen
MUL | Schulbuch-Multiplikation mit unsigned __int128 (128-Bit) Akkumulator für Kreuzbegriffe; 8×8 Wortmatrix | Optimierter Multiplikationspfad
DIV | Lange Division mit schrittweiser Probesubtraktion | Optimierter Divisionspfad
REM | Gleicher Divisionsalgorithmus, gibt Rest zurück | Optimierter Restwertpfad

Implementierungsdetails

Addition und Subtraktion

Der Compiler gibt eine Inline-Carry-Kette über acht 64-Bit-Wörter aus. Zusätzlich wird jedes Wortpaar mit Übertragsausbreitung unter Verwendung von x86 hinzugefügt ADC Anleitung. Für die Subtraktion gilt: SBB (subtract-with-borrow) verbreitet die Entlehnung über alle acht Wörter:

; ADD (a + b -> out) — 512-bit, 8 words
mov  rax, [a+0]   ; word 0
add  rax, [b+0]
mov  [out+0], rax
mov  rax, [a+8]   ; word 1
adc  rax, [b+8]
mov  [out+8], rax
; ... repeated for words 2 through 7
mov  rax, [a+56]  ; word 7
adc  rax, [b+56]
mov  [out+56], rax

Multiplikation

Die Multiplikation verwendet einen Schulbuchalgorithmus. Für jedes Paar von 64-Bit-Wörtern a[i] × b[j], wird das 128-Bit-Produkt in einem temporären 1024-Bit-Array (16 Wörter) akkumuliert, dann werden die unteren 512 Bits als Ergebnis gespeichert. PBXB64 verwendet seinen optimierten Wide-Integer-Multiplikationspfad.

Für eine 8×8-Wortmultiplikation sind 64 einzelne 64×64-Multiplikationen erforderlich, von denen jede ein 128-Bit-Partialprodukt erzeugt, das mit Übertragsausbreitung im Ergebnisarray akkumuliert wird.

Division und Rest

Bei der Division wird eine lange Division mit Probesubtraktion verwendet. Bei einer vorzeichenbehafteten Division konvertiert der Algorithmus zunächst beide Operanden in vorzeichenlose (Zweierkomplement-Negation, wenn negativ), führt eine vorzeichenlose lange Division durch und wendet dann das richtige Vorzeichen auf den Quotienten und den Rest an. PBXB64 verwendet seine optimierten Wide-Integer-Pfade fuer Division und Restwert.

Der vorzeichenlose lange Divisionsalgorithmus richtet den Divisor am höchstwertigen Bit des Dividenden aus, iteriert dann bitweise, verschiebt den Divisor bei jeder Iteration um ein Bit nach rechts und subtrahiert, wenn der aktuelle Rest größer oder gleich dem ausgerichteten Divisor ist.

Leistungshinweis: DIV und REM sind aufgrund der großen Wortanzahl (8 Wörter) die langsamsten Operationen für 512-Bit-Werte. Verwenden Sie für Divisionen durch Zweierpotenzen stattdessen die Rechtsverschiebung (SHR), die vollständig inline und um Größenordnungen schneller ist.

Einschränkungen

  • Division durch Null wird vom Compiler nicht abgefangen; Es erzeugt zur Laufzeit einen Quotienten von Null und einen Rest von Null.
  • Rechtsverschiebung (SHR) ist arithmetisch (Vorzeichenfüllung) und steht im Einklang mit der vorzeichenbehafteten Ganzzahlsemantik.
  • Zur Kompilierungszeit können nur ganzzahlige Literalwerte zugewiesen werden, die in die interne Darstellung des Compilers passen. Sehr große Werte (über ~263) muss durch arithmetische oder Schiebeoperationen aufgebaut werden.
  • 512-Bit-Variablen belegen jeweils 64 Byte Stapelplatz. Funktionen mit vielen 512-Bit-Locals überschreiten möglicherweise die Standard-Stack-Limits.

Beispiele

Beispiel 1: Einfache Addition und Subtraktion

FUNCTION PBMAIN() AS LONG
  LOCAL a AS INT512
  LOCAL b AS INT512
  LOCAL c AS INT512

  a = 1000000000000000000000000000000000000000000000000  ' 10^48
  b = 2000000000000000000000000000000000000000000000000  ' 2*10^48
  c = a + b                                            ' 3*10^48
  PRINT c

  c = a - b                                            ' -10^48
  PRINT c

  FUNCTION = 0
END FUNCTION

Beispiel 2: Multiplikation und Division

FUNCTION PBMAIN() AS LONG
  LOCAL a AS INT512
  LOCAL b AS INT512
  LOCAL c AS INT512

  a = 1000000000000000000000000000  ' 10^30
  b = 1000000000000000000000000000  ' 10^30
  c = a * b                         ' 10^60 — fits in 512 bits
  PRINT c

  c = c / a                         ' back to 10^30
  PRINT c

  FUNCTION = 0
END FUNCTION

Beispiel 3: Bitweise Operationen und Vergleich

FUNCTION PBMAIN() AS LONG
  LOCAL a AS INT512
  LOCAL b AS INT512
  LOCAL c AS INT512

  a = 65535
  b = 255
  c = a AND b          ' 255
  PRINT c

  c = a OR b           ' 65535
  PRINT c

  c = a XOR b          ' 65280
  PRINT c

  a = 1000000000000000000000000000000
  b = 500000000000000000000000000000
  IF a > b THEN PRINT "a is greater"

  FUNCTION = 0
END FUNCTION

Beispiel 4: Schichtbetrieb

FUNCTION PBMAIN() AS LONG
  LOCAL a AS INT512
  LOCAL b AS INT512

  a = 1
  b = a SHL 200        ' 2^200
  PRINT b

  b = b SHR 100        ' 2^100
  PRINT b

  FUNCTION = 0
END FUNCTION

Beispiel 5: Sehr große Fakultät (teilweise)

FUNCTION PBMAIN() AS LONG
  LOCAL n AS INT512
  LOCAL result AS INT512
  LOCAL i AS LONG

  result = 1
  n = 1
  FOR i = 1 TO 50
    result = result * n
    n = n + 1
  NEXT i
  PRINT result   ' 50! (~3*10^64)

  FUNCTION = 0
END FUNCTION

Siehe auch

  • INT128 / I128 — 128-Bit-Ganzzahl mit Vorzeichen
  • INT256 / I256 — 256-Bit-Ganzzahl mit Vorzeichen
  • UINT512 / U512 — Vorzeichenlose 512-Bit-Ganzzahl
  • LONG — 32-Bit-Ganzzahl mit Vorzeichen
  • QUAD — 64-Bit-Ganzzahl mit Vorzeichen

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UINT512 / U512 – 512-Bit-Ganzzahl ohne Vorzeichen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › UINT512 / U512 – 512-Bit-Ganzzahl ohne Vorzeichen
Hilfe zum PBXB64-Compiler

UINT512 / U512 – 512-Bit-Ganzzahl ohne Vorzeichen

Eine 512-Bit-Ganzzahl ohne Vorzeichen mit Inline-ADD/SUB/CMP/AND/OR/XOR/SHL und optimierter Laufzeit MUL/DIV/REM. Der Bereich liegt zwischen 0 und etwa 1,34×10154 (0 bis 2512−1).

Typ: Datentyp | Kategorie: Numerische Typen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Erklärung

LOCAL a AS UINT512
LOCAL b AS U512

Größe und Ausrichtung

  • Größe: 64 Bytes (8 × 64-Bit-Wörter)
  • Ausrichtung: 32 Byte
  • Stapelplatz: Ein 64-Byte-Frame-Objekt

Arithmetische Operationen

Alle Vorgänge sind nativer x64-Code. Einfache Operationen (ADD, SUB, CMP, AND, OR, XOR, SHL) werden als Inline-Befehlssequenzen ausgegeben. Multiplikation und Division nutzen optimierte C-Laufzeithilfsprogramme, die in die vom Benutzer ausführbare Datei kompiliert werden.

Betrieb | Umsetzung | Leistung
HINZUFÜGEN | Carry-Chain über acht 64-Bit-Wörter mit ADC (Add-with-Carry) | Inline, 8 Anweisungen
SUB | Leihekette über acht 64-Bit-Wörter mit SBB (Subtrahieren mit Ausleihen) | Inline, 8 Anweisungen
UND, ODER, XOR | Unabhängige wortweise Operationen über acht 64-Bit-Wörter | Inline, jeweils 8 Anweisungen
SHL | Kreuzwortverschiebung mit Übertragsausbreitung: Wortverschiebung + Bitverschiebung | Inline, ~20 Anweisungen
SHR | Logische Rechtsverschiebung: Ausbreitung von Nullfüllungen über Wörter hinweg | Inline, ~20 Anweisungen
CMP | Lexikografischer vorzeichenloser Vergleich aller Wörter (MSB bis LSB) | Inline, ~12 Anweisungen
NEG | Zweierkomplement: bitweises NICHT + Inkrementieren mit Übertrag | Inline, ~16 Anweisungen
MUL | Schulbuch-Multiplikation mit unsigned __int128 (128-Bit) Akkumulator für Kreuzbegriffe; 8×8 Wortmatrix | Optimierter Multiplikationspfad
DIV | Lange Division mit schrittweiser Probesubtraktion | Optimierter Divisionspfad
REM | Gleicher Divisionsalgorithmus, gibt Rest zurück | Optimierter Restwertpfad

Implementierungsdetails

Addition und Subtraktion

Der Compiler gibt eine Inline-Carry-Chain mit aus ADC (add-with-carry) für Addition und SBB (subtract-with-borrow) für die Subtraktion über acht 64-Bit-Wörter:

; ADD (a + b -> out) — 512-bit, 8 words
mov  rax, [a+0]   ; word 0
add  rax, [b+0]
mov  [out+0], rax
mov  rax, [a+8]   ; word 1
adc  rax, [b+8]
mov  [out+8], rax
; ... repeated for words 2 through 7
mov  rax, [a+56]  ; word 7
adc  rax, [b+56]
mov  [out+56], rax

Multiplikation

Die Multiplikation verwendet einen Schulbuchalgorithmus. Für jedes Paar von 64-Bit-Wörtern a[i] × b[j], wird das 128-Bit-Produkt in einem temporären 1024-Bit-Array (16 Wörter) akkumuliert, dann werden die unteren 512 Bits als Ergebnis gespeichert. PBXB64 verwendet seinen optimierten Wide-Integer-Multiplikationspfad.

Für eine 8×8-Wortmultiplikation sind 64 einzelne 64×64-Multiplikationen erforderlich, von denen jede ein 128-Bit-Partialprodukt erzeugt, das mit Übertragsausbreitung im Ergebnisarray akkumuliert wird.

Division und Rest

Bei der Division wird eine vorzeichenlose lange Division mit Probesubtraktion verwendet. Der Algorithmus richtet den Divisor am höchstwertigen Bit des Dividenden aus, iteriert dann bitweise, verschiebt den Divisor bei jeder Iteration um ein Bit nach rechts und subtrahiert, wenn der aktuelle Rest größer oder gleich dem ausgerichteten Divisor ist. PBXB64 verwendet seine optimierten Wide-Integer-Pfade fuer Division und Restwert.

Leistungshinweis: DIV und REM sind aufgrund der großen Wortanzahl (8 Wörter) die langsamsten Operationen für 512-Bit-Werte. Verwenden Sie für Divisionen durch Zweierpotenzen stattdessen die Rechtsverschiebung (SHR), die vollständig inline und um Größenordnungen schneller ist. SHR ohne Vorzeichen ist logisch (Nullfüllung) und eignet sich daher ideal zum Extrahieren von Bitfeldern.

Einschränkungen

  • Division durch Null wird vom Compiler nicht abgefangen; Es erzeugt zur Laufzeit einen Quotienten von Null und einen Rest von Null.
  • Rechtsverschiebung (SHR) ist logisch (Nullfüllung), im Gegensatz zu vorzeichenbehafteten Ganzzahlen, die eine arithmetische Verschiebung (Vorzeichenfüllung) verwenden.
  • Zur Kompilierungszeit können nur ganzzahlige Literalwerte zugewiesen werden, die in die interne Darstellung des Compilers passen. Sehr große Werte (über ~263) muss durch arithmetische oder Schiebeoperationen aufgebaut werden.
  • 512-Bit-Variablen belegen jeweils 64 Byte Stapelplatz. Funktionen mit vielen 512-Bit-Locals überschreiten möglicherweise die Standard-Stack-Limits.

Beispiele

Beispiel 1: Grundlegende Addition und Wraparound

FUNCTION PBMAIN() AS LONG
  LOCAL a AS UINT512
  LOCAL b AS UINT512
  LOCAL c AS UINT512

  a = 115792089237316195423570985008687907853269984665640564039457584007913129639935
  ' 2^256 - 1
  b = 1
  c = a + b                                    ' 2^256 — wraps naturally in 512 bits
  PRINT c

  c = c - b                                    ' back to 2^256 - 1
  PRINT c

  FUNCTION = 0
END FUNCTION

Beispiel 2: Multiplikation und Division

FUNCTION PBMAIN() AS LONG
  LOCAL a AS UINT512
  LOCAL b AS UINT512
  LOCAL c AS UINT512

  a = 1000000000000000000000000000000  ' 10^30
  b = 1000000000000000000000000000000  ' 10^30
  c = a * b                            ' 10^60 — fits in 512 bits
  PRINT c

  c = c / a                            ' back to 10^30
  PRINT c

  FUNCTION = 0
END FUNCTION

Beispiel 3: Bitweise Maskierung und Bitextraktion

FUNCTION PBMAIN() AS LONG
  LOCAL mask AS UINT512
  LOCAL value AS UINT512
  LOCAL result AS UINT512

  ' Create a 256-bit mask: bits 0-255 set to 1
  mask = 0
  mask = NOT mask              ' all 512 bits set to 1
  mask = mask SHR 256          ' top 256 bits set to 1
  mask = NOT mask              ' bottom 256 bits set to 1

  value = 1234567890123456789012345678901234567890
  result = value AND mask      ' mask lower 256 bits
  PRINT result

  FUNCTION = 0
END FUNCTION

Beispiel 4: Schiebeoperationen für das Bit-Packen

FUNCTION PBMAIN() AS LONG
  LOCAL a AS UINT512
  LOCAL b AS UINT512
  LOCAL packed AS UINT512

  a = 1023
  b = 2047
  packed = a SHL 16            ' a in bits 16-25
  packed = packed OR b         ' b in bits 0-10
  PRINT packed

  ' Extract a back
  a = packed SHR 16 AND 1023
  PRINT a

  FUNCTION = 0
END FUNCTION

Beispiel 5: Sehr große Fakultät (teilweise)

FUNCTION PBMAIN() AS LONG
  LOCAL n AS UINT512
  LOCAL result AS UINT512
  LOCAL i AS LONG

  result = 1
  n = 1
  FOR i = 1 TO 70
    result = result * n
    n = n + 1
  NEXT i
  PRINT result   ' 70! (~1.2*10^100)

  FUNCTION = 0
END FUNCTION

Siehe auch

  • UINT256 / U256 — 256-Bit-Ganzzahl ohne Vorzeichen
  • UINT128 / U128 — 128-Bit-Ganzzahl ohne Vorzeichen
  • INT512 / I512 — Vorzeichenbehaftete 512-Bit-Ganzzahl
  • DWORD — 32-Bit-Ganzzahl ohne Vorzeichen
  • QUAD — 64-Bit-Ganzzahl mit Vorzeichen

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UNF-Familie – Wissenschaftliche numerische Typen – PBXB64-Hilfe

Startseite › UNF-Familie — Wissenschaftliche Typen — PBXB64-Hilfe
Hilfe zum PBXB64-Compiler

UNF-Familie – Wissenschaftliche numerische Typen

DerUNF Familie ist das wissenschaftliche Zahlensystem von PBXB64: exakte und erweiterte numerische Darstellungen, die auf reiner Ganzzahlarithmetik basieren. Im Gegensatz zu IEEE 754 Binary Floats vermeiden diese Typen versteckte Rundungen, indem sie verwenden Durchgehend Mantissen mit ganzzahliger Genauigkeit - Gleitkomma-Hardware wird berührt nur an der expliziten Konvertierungsgrenze.

Typ: Datentypfamilie | Kategorie: Numerische Typen

PBXB64-Status: VERFÜGBAR (Wissenschaftslaufzeit)

PBXB64-Zertifizierung: [WISSENSCHAFTSSTUFE]

Der Basistyp: UNF (Unum Float)

UNF ist ein 16-Byte-Gleitkommatyp mit einem 60-Bit-Vorzeichen Mantisse und ein 8-Bit-Exponent mit Vorzeichen. Intern verwendet es pure __int128 Arithmetik - die einzige <math.h> Anrufe sind drinnen unf_conv.h (die explizite IEEE-zu-UNF-Grenze).

Eigentum | Wert
Lagerung | 16 Byte
Layout | int64_t m (60-Bit-Mantisse mit Vorzeichen) + int8_t e (Exponent)
Wert | u = m * 2^e
Mantissennormalisierung | 2^59 <= |m| < 2^60 (60 Bits an Bedeutung)
Exponentenbereich | -128 .. +127
Dezimale Genauigkeit | ~19 signifikante Ziffern
Kleinstes Plus | ~ 1,3e-20
Größte endliche | ~ 1,8e+57
Besondere Werte | +0, NaN (m = INT64_MIN), +Unendlich (e = INT8_MIN)

Familienmitglieder

Typ | Größe | Bedeutung | Komponenten
UNF | 16 Byte | Unum Float – der Basisskalar | Mantisse+Exponent
UNC | 32 Byte | Komplexe Zahl | { re: UNF, im: UNF }
UNB | 16+ Bytes | Großer Float (beliebige Präzision) | haufenweise gewachsene Mantisse
UNI | 32 Byte | Intervallarithmetik | { lo: UNF, hi: UNF }
UNQ | 64 Byte | Quaternion | { w, x, y, z: UNF }

Gestaltungsprinzipien

  • Reine Ganzzahlarithmetik. Alle Operationen (add, sub, mul, div, sqrt, sin, cos, exp, log) werden berechnet __int128 Größen mit explizite Exponentenverfolgung. Es sind keine Gleitkommaanweisungen beteiligt.
  • Die IEEE-Grenze ist explizit. Der einzige Ort ist Gleitkomma-Hardware verwendet wird unf_conv.h, Konvertierung zwischen IEEE 754 doubleUndUNF. Alle anderen Codepfade sind bitgenau und plattformübergreifend reproduzierbar.
  • Transzendentalien über Serien. sin, cos, exp, log Verwenden Sie Taylor-Reihen und Newton-Raphson Verfeinerung, argumentreduziert für Genauigkeit.
  • NaN / Infinity-Ausbreitung. Jede arithmetische Operation prüft auf die speziellen Sentinels und verbreitet sie korrekt (IEEE 754-Semantik).

Wann sollte UNF im Vergleich zu anderen numerischen Typen verwendet werden?

Brauchen | Benutzen
Geschwindigkeit, ungefähre Dezimalzahlen OK | DOUBLE
Genaue Dezimalzahl für Geld (4 dp) | CURRENCY / CURRENCYX
Exakte Dezimalzahl, dynamischer Exponent, 34 Stellen | DECIMAL128
Reproduzierbare bitgenaue Float-Berechnung, 19 Stellen | UNF
Beliebige Präzision (keine Begrenzung) | UNL
Intervallgrenzen mit Fehlerverfolgung | UNI
Quaternion / 3D-Rotation | UNQ

Beispiel

LOCAL a AS UNF
LOCAL b AS UNF
a = 2.5
b = 4.0
PRINT a * b      ' 10  (exact, no IEEE rounding)

Umsetzung

Die UNF-Familie ist eine reine Header-Bibliothek der UNF-Familie:

  • unf.h - Kerntyp und Schirm inklusive
  • unf_arith.h - add, sub, mul, div, sqrt
  • unf_compare.h - Gleichheit und Ordnung
  • unf_conv.h - Konvertierung von IEEE 754 in UNF (die einzige Float-Grenze)
  • unf_trig.h - Sin, Cos, Tan und Umkehrungen
  • unf_exp.h - exp, log, pow
  • unf_const.h - pi, e, sqrt(2), ln(2)
  • unf_mp.h - Multipräzisionshelfer für UNB

Siehe auch

  • Übersicht über Datentypen
  • UNL – Ganzzahl mit unbegrenzter Genauigkeit
  • DECIMAL128 – IEEE 754-Dezimalzahl
  • BASIC-Datentypen (DOUBLE, EXTENDED)

← Zurück zu Datentypen

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


UNF – Unum Float (16 Byte) – PBXB64-Hilfe

Startseite › UNF – Unum Float (16 Byte)
Hilfe zum PBXB64-Compiler

UNF – Unum Float

UNF (Unum Float) ist der Basisskalar des wissenschaftlichen PBXB64 numerisches Typensystem. Es handelt sich um einen 16-Byte-Gleitkommatyp mit einem 60-Bit-Vorzeichen Mantisse und ein 8-Bit-Exponent mit Vorzeichen, vollständig berechnet mit pure __int128 Ganzzahlarithmetik. Keine Gleitkomma-Hardware nimmt an Berechnungen teil – die IEEE-Grenze ist explizit und auf begrenzt unf_conv.h.

Typ: Datentyp | Kategorie: Numerische Typen

PBXB64-Status: VERFÜGBAR (Frontend + Laufzeit)

PBXB64-Zertifizierung: [WISSENSCHAFTSSTUFE]

Lagerlayout

Eigentum | Wert
Größe | 16 Byte
C-Typ | struct unf { int64_t m; int8_t e; } (aufgefüllt auf 16)
Wertformel | u = m * 2^e
Mantisse (m) | 60-Bit signiert (2^59 <= |m| < 2^60 wenn normalisiert)
Exponent (e) | 8-Bit mit Vorzeichen (-128 .. +127)
Dezimale Genauigkeit | ~19 signifikante Ziffern
Kleinstes Plus | ~ 1,3e-20
Größte endliche | ~ 1,8e+57

Besondere Werte

Wert | Codierung | Prädikat
+0 (kanonische Null) | m = 0, e = 0 | unf_is_zero()
NaN | m = INT64_MIN | unf_is_nan()
+Unendlichkeit | e = INT8_MIN, m = 0 | unf_is_inf()

NaN breitet sich durch alle Arithmetik aus (IEEE 754-Semantik). Unendlichkeit breitet sich bei korrekter Zeichenbehandlung aus.

Operationen

Kategorie | Operationen | Umsetzung
Einfach | neg, abs, copysign, normalize | unf_basic.h
Arithmetik | add, sub, mul, div, sqrt | unf_arith.h
Vergleich | eq, lt, cmp (gibt -1/0/+1 zurück) | unf_compare.h
Trigonometrisch | sin, cos, tan, asin, acos, atan, atan2 | unf_trig.h (Taylor + Argumentreduktion)
Exponentiell | exp, log, log2, pow | unf_exp.h (Newton-Raphson)
Konvertierung | from_d, to_d, from_str, to_str | unf_conv.h (die einzige Float-Grenze)
Konstanten | pi, e, sqrt(2), ln(2), log2(e) | unf_const.h

Warum reine Ganzzahlarithmetik?

Jede Operation reduziert sich auf die Multi-Präzisions-Integer-Mathematik (mp_v_t = __int128) auf den Mantissen, mit explizitem Exponentenverfolgung. Das ergibt:

  • Bitgenaue Reproduzierbarkeit plattformübergreifend (keine Abhängigkeit vom FPU-Rundungsmodus).
  • Keine versteckten Rundungen - Jedes Ergebnis ist der exakte ganzzahlige Wert, der nur an der expliziten Konvertierungsgrenze gerundet wird.
  • Überprüfbarkeit - Der gesamte Berechnungspfad ist deterministische Ganzzahlberechnung.

Beispiel

LOCAL a AS UNF
LOCAL b AS UNF
a = 2.5
b = 4.0
PRINT a * b          ' 10 (exact, no IEEE rounding)

Umstellung auf/von DOUBLE

Die Konvertierung erfolgt nur an der expliziten Grenze in unf_conv.h:

LOCAL d AS DOUBLE
LOCAL u AS UNF
d = 3.14159265358979
u = d                ' DOUBLE to UNF (explicit conversion)
d = u                ' UNF to DOUBLE (explicit conversion)

Umrechnungen werden korrekt gerundet (auf die nächste gerade Zahl gerundet).

Siehe auch

  • UNF-Familienübersicht
  • UNC – Komplexe Zahl
  • UNB – Großer Schwimmer
  • UNI – Intervallarithmetik
  • UNQ – Quaternion
  • DEZIMAL128
  • Übersicht über Datentypen

← Zurück zur UNF-Familie

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


UNC – Komplexe Nummer – PBXB64-Hilfe

Startseite › UNC – Komplexe Zahl

UNC – Komplexe Zahl

UNC ist ein komplexer Zahlentyp, der aus zwei besteht UNF Werte: ein Realteil und ein Imaginärteil. Es ermöglicht bitgenauen Komplex Arithmetik für Signalverarbeitung, Quantenmechanik und Elektrik technische Anwendungen.

Typ: Datentyp | Kategorie: Numerische Typen

PBXB64-Status: VERFÜGBAR (Wissenschaftslaufzeit)

PBXB64-Zertifizierung: [WISSENSCHAFTSSTUFE]

Lagerlayout

Eigentum | Wert
Größe | 32 Byte
Layout | { UNF re; UNF im; }
Realteil (re) | 16-Byte-UNF (60-Bit-Mantisse, 19 Ziffern)
Imaginärteil (im) | 16-Byte-UNF (60-Bit-Mantisse, 19 Ziffern)
Wert | z = re + im*i

Operationen

Kategorie | Operationen
Arithmetik | add, sub, mul, div (komplex, genau)
Größe | abs (= sqrt(re^2 + im^2)), arg (= atan2(im, re))
Konjugat | conj (negiert im)
Befugnisse | sqrt, exp, log, pow (Hauptzweig)
Trigonometrisch | sin, cos, tan, sinh, cosh, tanh
Konvertierung | zur/von der Polarform (r, theta), zur/von der Zeichenfolge

Beispiel

LOCAL z1 AS UNC
LOCAL z2 AS UNC
z1 = CMPLX(3.0, 4.0)       ' 3 + 4i
z2 = CMPLX(1.0, -1.0)      ' 1 - i
PRINT z1 + z2              ' 4 + 3i
PRINT UNCABS(z1)           ' 5.0  (magnitude)

Anwendungsfälle

  • DSP / FFT - komplexe Multiplikation ist exakt; keine akkumulierte Rundung bei langen Transformationen.
  • Quantencomputersimulation - Zustandsvektoren erfordern hochpräzise komplexe Amplituden.
  • Analyse des Wechselstromkreises - Impedanzberechnungen mit exakter Phase.
  • Kontrolltheorie - Pol-/Nullpunktanalyse mit präzisen komplexen Wurzeln.

Siehe auch

  • UNF – Unum Float (Basistyp)
  • UNF-Familienübersicht
  • UNB – Großer Schwimmer
  • UNI – Intervallarithmetik
  • UNQ – Quaternion

← Zurück zur UNF-Familie

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


UNB – Big Float (beliebige Präzision) – PBXB64-Hilfe

Startseite › UNB – Big Float (willkürliche Präzision)
Hilfe zum PBXB64-Compiler

UNB – Big Float (willkürliche Präzision)

UNB (Unum Big-float) ist ein Gleitkomma mit beliebiger Genauigkeit Typ, dessen Mantisse dynamisch wächst. Im Gegensatz zuUNF(behoben 60-Bit-Mantisse), UNB kann beliebig viele Mantissenglieder tragen, Dadurch eignet es sich für Berechnungen, die Hunderte oder Tausende von Ziffern erfordern der Präzision.

Typ: Datentyp | Kategorie: Numerische Typen

PBXB64-Status: VERFÜGBAR (Wissenschaftslaufzeit)

PBXB64-Zertifizierung: [WISSENSCHAFTSSTUFE]

Lagerlayout

Eigentum | Wert
Grundgröße | 16+ Bytes (Header + Heap-gewachsene Mantisse)
Mantisse | Array von mp_v_t (128-Bit) Gliedmaßen, Heap-zugewiesen
Exponent | 64-Bit signiert (effektiv unbegrenzter Bereich)
Präzision | Dynamisch – vom Anrufer festgelegt oder nach Bedarf erweitert
Unterschreiben | Separate Flagge (Vorzeichen/Größe)

Wie es sich von UNF unterscheidet

Eigentum | UNF | UNB
Mantissenbreite | 60 Bit behoben | Dynamisch (beliebig viele Gliedmaßen)
Lagerung | 16 Byte (Stapel) | 16+ Bytes (Heap für Mantisse)
Dezimalstellen | ~19 | Unbegrenzt (vom Anrufer angegeben)
Exponentenbereich | -128 .. 127 | -2^63 .. 2^63-1
Geschwindigkeit | Schnell (inline __int128) | Langsamer (Haufen, mehrgliedrig)
Anwendungsfall | Allgemeine wissenschaftliche | Pi auf 1000 Ziffern, Kryptographie

Operationen

Kategorie | Operationen
Arithmetik | add, sub, mul, div (mit vom Anrufer angegebener Genauigkeit)
Wurzeln | sqrt, nroot (n-te Wurzel)
Vergleich | eq, cmp
Konvertierung | nach/von UNF, STRING, DOUBLE
Präzise Steuerung | set_precision, get_precision

Beispiel

LOCAL pi AS UNB
pi = UNB_PI(100)          ' compute pi to 100 decimal digits
PRINT pi                  ' 3.14159265358979... (100 digits)

Umsetzung

UNB nutzt die Multipräzisions-Helfer in unf_mp.h (die mp_v_t = __int128 Typ und damit verbundene Operationen). Die Mantisse wird als Heap-zugewiesenes Array gespeichert von 128-Bit-Gliedmaßen. Für kleine Genauigkeiten wird die Schulbuchmultiplikation verwendet; Über einem Schwellenwert setzt die Karatsuba-Multiplikation ein.

Siehe auch

  • UNF – Unum Float (feste Genauigkeit)
  • UNF-Familienübersicht
  • UNL – Unbegrenzte Ganzzahl
  • UNC – Komplexe Zahl

← Zurück zur UNF-Familie

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


UNI - Intervallarithmetik - PBXB64-Hilfe

Startseite > UNI - Intervallarithmetik
PBXB64 Compiler Hilfe

UNI - Intervallarithmetik

UNI ist ein textgesicherter Intervallwert. Er besteht aus zwei UNF-Komponenten im Format lo;hi.

Art: Datentyp | Kategorie: Numerische Typen

PBXB64-Status: VERFUEGBAR (Science Runtime)

PBXB64-Zertifizierung: [SCIENCE TIER]

Speicherlayout

Eigenschaft | Wert
Compiler-Slot | ein Pointer
Persistenter Wert | heap-eigener Text im Format lo;hi
Konvertierung | VALUNI, UNI$

Intervallsemantik

Ein Intervall [a, b] beschreibt alle reellen Zahlen x, fuer die a <= x <= b gilt. Die aktuell dokumentierte Arithmetik wird ueber Operationen auf den Endpunkt-Komponenten umgesetzt.

Operationen

Kategorie | Operationen
Konvertierung | VALUNI, UNI$
Arithmetik | +, -, *, / mit Intervall-Endpunktregeln

Beispiel

LOCAL x AS UNI
x = VALUNI("1.0;1.1")
PRINT UNI$(x)

Anwendungsfaelle

  • Verifizierte Numerik - pruefen, ob ein Ergebnis innerhalb bekannter Grenzen liegt.
  • Fehlerfortpflanzung - verfolgen, wie Messunsicherheit durch Berechnungen laeuft.
  • Strenge Nullstellensuche - Bereiche eingrenzen und garantiert ausschliessen.
  • Geometrische Praedikate - robuste Orientierungs- und Schnittpruefungen.

Siehe auch

  • UNF - Unum Float (Grenztyp)
  • UNF-Familienuebersicht
  • UNC - Komplexe Zahl
  • UNQ - Quaternion

<- Zurueck zur UNF-Familie

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.

Vollstaendigkeitskriterien

Uebersichtsseiten sollen Dokumentationsumfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollstaendige Hilfeseite nennt auch Voraussetzungen, Grenzen, Fehlerfaelle und die Beziehung zu verwandten Befehlen.

Praktisches Beispiel

Fuer UNI - Intervallarithmetik soll das Beispiel direkt in eine kleine Quelldatei uebernommen werden koennen. Es soll Eingaben, erwartete Ausgabe oder Exit-Code sowie benoetigte Includes, Bibliotheken oder Laufzeitbedingungen nennen.

Pruefschritte

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature eingeschraenkt oder kompatibilitaetsorientiert ist, muss die Seite das offen sagen und darf keine ungetestete Vollstaendigkeit behaupten.


UNQ – Quaternion – PBXB64 Hilfe

Startseite › UNQ – Quaternion

UNQ – Quaternion

UNQ ist ein Quaterniontyp, der aus vier besteht UNF Komponenten (w, x, y, z). Es stellt eine verwendete hyperkomplexe Zahl dar für 3D-Rotationen, Starrkörperdynamik und Quantenmechanik. Alles Quaternion Die Arithmetik wird mit der gleichen bitgenauen Ganzzahlgenauigkeit wie die Basis berechnet UNF Typ.

Typ: Datentyp | Kategorie: Numerische Typen

PBXB64-Status: VERFÜGBAR (Wissenschaftslaufzeit)

PBXB64-Zertifizierung: [WISSENSCHAFTSSTUFE]

Lagerlayout

Eigentum | Wert
Größe | 64 Byte
Layout | { UNF w; UNF x; UNF y; UNF z; }
Skalarer Teil (w) | 16-Byte-UNF
Vektorteil (x, y, z) | 3 x 16-Byte-UNF
Wert | q = w + xi + yj + zk

Quaternion-Algebra

Die Multiplikationsregel folgt dem Hamilton-Produkt:

i*i = j*j = k*k = ijk = -1
ij = k,  jk = i,  ki = j
ji = -k, kj = -i, ik = -j

Operationen

Kategorie | Operationen
Arithmetik | add, sub, mul (Hamilton-Produkt), div
Norm | abs (= sqrt(w^2+x^2+y^2+z^2)), normalize (Einheitsquaternion)
Konjugat | conj (negiert x, y, z)
Invers | inv (= konj / abs^2)
Rotation | from_axis_angle, to_matrix, slerp
Interpolation | slerp (sphärische lineare Interpolation)

Beispiel: 3D-Rotation

LOCAL q AS UNQ
q = QUAT_FROM_AXIS(0.0, 0.0, 1.0, 1.5707963)  ' 90 deg around Z
PRINT q                 ' w=0.707..., z=0.707... (unit quaternion)

Anwendungsfälle

  • 3D-Grafik / Robotik - Quaternionen vermeiden eine kardanische Sperre und sind für die Interpolation effizienter als Rotationsmatrizen (slerp).
  • Dynamik starrer Körper - Winkelgeschwindigkeitsintegration.
  • Quantenmechanik - Spin-1/2-Zustandsdarstellung.
  • Computer Vision - Kameraausrichtung, SLAM.

Warum UNF-basierte Quaternionen?

Standard float/double Quaternionen sammeln sich an Rundungsfehler bei wiederholten Drehungen (z. B. in Animationsschleifen), verursachen von der Einheitssphäre wegdriften. UNQ's 60-Bit-Mantisse und Bitgenaue Arithmetik hält Rotationen über lange Sequenzen stabil.

Siehe auch

  • UNF – Unum Float (Komponententyp)
  • UNF-Familienübersicht
  • UNC – Komplexe Zahl
  • UNI – Intervallarithmetik

← Zurück zur UNF-Familie

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


Native H-Lib-Container – Hilfe zum PBXB64-Compiler

Startseite › Native H-Lib-Container

Native H-Lib-Container

PBXB64 enthält eine native C-Laufzeitcontainerbibliothek (c_hlib), das für PB-Variablen automatisch initialisiert und finalisiert wird. Container-Handles werden gespeichert als LONG Werte.

Typ: Sprachfunktion | Kategorie: Native H-Lib-Container

PBXB64-Status: VERFÜGBAR – 23 FAMILIEN · 124 SCHLÜSSELWÖRTER

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Drei Möglichkeiten, sie zu verwenden:
· PB-Syntax: q.Push 5, n = q.Count (Methodenversand)
· PB-Index: a[1] = 100, n = h["key"] (Indexzugriff)
· C-Frontend: c_hlib_lnarr_add(q, 5) über pbxb64/hlib.h

Unterstützte Containerfamilien (alphabetisch, insgesamt 23)

Familie | PB-Typ | Beschreibung | Hilfeseite
2D-Array | LN2D (+ 12 Varianten) | Zweidimensionales dynamisches Array mit Zeilen, Spalten und rechteckigen Operationen. | 2D-Methoden
Array | LNARR (+ 12 Varianten) | Dynamisches Array mit Push, Pop, Einfügen, Löschen, Sortieren, indiziertem Zugriff und UDT-Nutzlast. | Arr-Methoden
Bloom-Filter | LNBLOOM | Probabilistischer LONG-Mitgliedschaftstest ohne falsch-negative Ergebnisse und einstellbarer Falsch-Positiv-Rate. | cmd_hlib_bloom
B+ Baum | LNBPTREE | Festplattenfreundliche geordnete Menge mit hohem Verzweigungsfaktor, Bereichsabfragen und Massenoperationen. | cmd_hlib_bptree
Deque | LNDEQUE | Doppelendige Warteschlange. Drücken und Pop von beiden Enden in O(1)-Zeit. | cmd_hlib_deque
Doppelter Baum | WSWSDTRE | Breitsaitiger bis breitsaitiger Baum mit zwei Enden. Bidirektional geordneter Schlüsselwertbaum. | DTre-Methoden
Grafik | LNGRAPH | Ungerichteter Graph mit LONG-Knoten-IDs, Adjazenzabfragen, Nachbaraufzählung. | cmd_hlib_graph
Hash Table | LNLNHSH (+ 12 Varianten) | Schlüsselwertspeicher mit O(1)-Hash-Suche, Einfügen, Löschen und Aufzählung. | Hsh-Methoden
Haufen | LNHEAP | Binärer Min-Heap/Prioritätswarteschlange. O(log n) Push und Pop. | cmd_hlib_heap
Verlinkte Liste | LNLST (+ 12 Varianten) | Doppelt verknüpfte Liste mit Knotendurchquerung, Einfügen vor/nachher, Entfernen nach Knoten. | Letzte Methoden
LRU-Cache | LNLRU | Begrenzter LONG-Key/LONG-Wert-Cache mit der zuletzt verwendeten Räumung. | cmd_hlib_lru
Multiset | LNMULTISET | Beutel mit LANGEN Schlüsseln mit mehreren Zählungen. Ermöglicht Duplikate mit Zählverfolgung. | cmd_hlib_multiset
Quadtree | LNQUAD | Räumlicher Index für LONG-Begrenzungsrahmen. Effiziente 2D-Bereichs- und Punktabfragen. | cmd_hlib_quadtree
Warteschlange | LNQUE (+ 12 Varianten) | FIFO-Warteschlange mit Push-, Pop-, Peek-, Front- und Back-Operationen. | Que-Methoden
Klingeln | LNRING | Ringpuffer mit fester Kapazität. Überschreibt die ältesten Elemente, wenn sie voll sind. | cmd_hlib_ring
Sicher | LNSAFE | Threadsicherer LONG-Stack-Wrapper mit Mutex-geschütztem Push und Pop. | cmd_hlib_safe
Set | LNSET | Sortierter eindeutiger Satz, der durch den AVL-Baum unterstützt wird. O(log n) hinzufügen, entfernen und enthalten. | cmd_hlib_set
SkipList | LNSKIPLIST | Wahrscheinlichkeitsgeordnete Menge mit O(log n) Durchschnittsfalloperationen. | cmd_hlib_skiplist
Stapel | LNSTK (+ 12 Varianten) | LIFO-Stack mit Push-, Pop- und Peek-Operationen. | Stk-Methoden
String Builder | SSSTR, WSSTR | Veränderbarer String-Builder mit Anhängen, Einfügen, Löschen, Ersetzen und Zeichenzugriff. | Str-Methoden
Baum | LNLNTRE (+ 12 Varianten) | Selbstausgleichender AVL-Baum mit geordneter Schlüsselwertspeicherung, Min/Max, Bereichsdurchquerung. | Drei Methoden
Versuchen Sie es | SSSSTRI | Präfixbaum (Trie), der ANSI-Zeichenfolgen ANSI-Zeichenfolgen zuordnet. Fast prefix lookup. | Tri-Methoden
Union-Find | LNUNIONFIND | Disjunkte Mengen-/Union-Find-Struktur. Nahezu zeitkonstante Vereinigung und Suche. | cmd_hlib_unionfind

Typvarianten (13 pro Familie, sofern zutreffend)

Die meisten Familien stellen 13 Elementtypvarianten bereit Über 124 erkannte Typschlüsselwörter:

Suffix | PB-Typ | Größe | Suffix | PB-Typ | Größe
Bt | BYTE | 1 Byte | Sn | EINZEL | 4 Bytes
In | Ganzzahl (Wort) | 2 Bytes | Db | DOPPELT | 8 Byte
Wd | WORT (DWORD) | 2 Bytes | Cu | WÄHRUNG | 8 Byte
Dw | DWORD | 4 Bytes | Cx | WÄHRUNGX | 16 Byte
Ln | LONG | 4 Bytes | Ex | ERWEITERT | 10 Byte
Qd | QUAD | 8 Byte | SS | STRING (ANSI) | Zeigergroß
 |  |  | Ws | WSTRING (Unicode) | Zeigergroß

Gemeinsame Konventionen

  • Deklarieren Sie eine Containervariable mit LOCAL c AS LNMULTISET.
  • Zuordnen mit c = c.New (Einige Konstruktoren akzeptieren Argumente, z. B. b = b.New 1000, 0.01).
  • Aufrufmethoden mit Punktsyntax: c.Add 5oderc.Add(5).
  • Free explicitly with c.Final oder lassen Sie den Scope-Exit automatisch finalisieren.
  • Verwendung von Methoden, die Skalarwerte zurückgeben LONGoderQUAD; Methoden, die Container zurückgeben, geben ein neues Handle zurück.

UDT-Nutzlastcontainer

Der Containerelementtyp kann ein benutzerdefinierter PB sein TYPE:

TYPE Point
    x AS LONG
    y AS LONG
END TYPE
LOCAL a AS LNARR OF Point
LOCAL p AS Point
LOCAL q AS Point

a.New
p.x = 10 : p.y = 20
a.Push p
q = a.Get(0)              ' q is a Point

Siehe auch

  • Übersicht über native H-Lib — Familientabellen, Typvarianten, Methodensyntax
  • Methodenreferenz — vollständige Methodentabellen für jede Familie
  • Beispiele nach Familie – Codeausschnitte für jeden Containertyp
  • H-Lib C-API – Verwendung von Containern aus dem C17-Frontend
  • Subscript [] Zugang — Indizierung im PowerBASIC-Stil
  • Parameter und Rückgaben von Containerfunktionen — BYVAL / BYREF / Rückgabewerte

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


Native H-Lib-Container – Übersicht

Startseite › Native H-Lib-Container – Übersicht

Native H-Lib-Containertypen

Native H-Lib-Container sind erstklassige Datenstrukturtypen, die direkt in den PBXB64-Compiler integriert sind. Sie stellen dynamische Sammlungen mit Methodenaufrufsyntax, automatischer Speicherverwaltung und Bereichs-Exit-Bereinigung bereit – es sind keine COM-Objekte oder externen Bibliotheken erforderlich.

Version: Z65+ (implementiert)
Status: VERFÜGBAR – alle 22 Familien implementiert
Automatische Bereinigung: Beim Scope-Exit über .Final
Methodensyntax: q.Push 10, n = q.Count

Containerfamilien

Familie | Geben Sie Präfix ein | Beschreibung
Arr (Array) | LnArr, InArr, WdArr, BtArr, DwArr, QdArr, SnArr, DbArr, CuArr, CxArr, ExArr, SsArr, WsArr | Dynamisches Array mit Push-, Pop-, Einfügen-, Lösch-, Sortier- und indiziertem Zugriff.
Stk (Stapel) | LnStk, InStk, WdStk, BtStk, DwStk, QdStk, SnStk, DbStk, CuStk, CxStk, ExStk, SsStk, WsStk | LIFO-Stack mit Push-, Pop- und Peek-Operationen. Last-in, First-out-Semantik.
Que (Warteschlange) | LnQue, InQue, WdQue, BtQue, DwQue, QdQue, SnQue, DbQue, CuQue, CxQue, ExQue, SsQue, WsQue | FIFO-Warteschlange mit Push, Pop, Peek, Front und Back. First-in-First-out-Semantik.
Lst (Liste) | LnLst, InLst, WdLst, BtLst, DwLst, QdLst, SnLst, DbLst, CuLst, CxLst, ExLst, SsLst, WsLst | Doppelt verknüpfte Liste mit Knotendurchlauf, Einfügen davor/nachher und Entfernen nach Knoten.
Str (String Builder) | SsStr, WsStr | Veränderbarer String-Builder mit Anhängen, Einfügen, Löschen, Ersetzen und Zugriff auf Zeichenebene.
2D (2D-Array) | Ln2D, In2D, Wd2D, Bt2D, Dw2D, Qd2D, Sn2D, Db2D, Cu2D, Cx2D, Ex2D, Ss2D, Ws2D | Zweidimensionales dynamisches Array mit Zeilen, Spalten und rechteckigen Operationen.
Hsh (Hash-Tabelle) | LnLnHsh, InInHsh, WdWdHsh, BtBtHsh, DwDwHsh, QdQdHsh, SnSnHsh, DbDbHsh, CuCuHsh, CxCxHsh, ExExHsh, SsSsHsh, WsWsHsh | Schlüsselwertspeicher mit O(1)-Hash-Suche, Einfügen, Löschen und Aufzählung.
Tre (Baum) | LnLnTre, InInTre, WdWdTre, BtBtTre, DwDwTre, QdQdTre, SnSnTre, DbDbTre, CuCuTre, CxCxTre, ExExTre, SsSsTre, WsWsTre | Selbstausgleichender AVL-Baum mit geordneter Schlüsselwertspeicherung, Min/Max und Bereichsdurchquerung.
DTre (Doppelbaum) | WsWsDTre | Doppelendiger Baum, der breite Zeichenfolgen breiten Zeichenfolgen zuordnet. Bidirektionaler Schlüsselwertbaum.
Tri (Versuch) | SsSsTri | Präfixbaum (Trie), der ANSI-Zeichenfolgen ANSI-Zeichenfolgen zuordnet. Schnelle Präfixsuche und automatische Vervollständigung.
Haufen | LNHEAP | Binärer Min-Heap/Prioritätswarteschlange. O(log n) Push und Pop. Der kleinste Wert wird immer zuerst zurückgegeben.
Deque | LNDEQUE | Doppelendige Warteschlange. Drücken und Pop von beiden Enden in O(1)-Zeit.
Set | LNSET | Sortierter eindeutiger Satz, der durch den AVL-Baum unterstützt wird. O(log n) Hinzufügen, Entfernen und Mitgliedschaftstest.
Grafik | LNGRAPH | Ungerichteter Graph mit LONG-Knoten-IDs. Unterstützt Adjazenzabfragen und Nachbaraufzählung.
Multiset | LNMULTISET | Beutel mit LANGEN Schlüsseln mit mehreren Zählungen. Ermöglicht doppelte Werte mit Zählverfolgung.
Union-Find | LNUNIONFIND | Disjunkte Mengen-/Union-Find-Struktur. Nahezu zeitkonstante Vereinigungs- und Suchoperationen.
LRU-Cache | LNLRU | Begrenzter LONG-Key/LONG-Wert-Cache mit der zuletzt verwendeten Räumungsrichtlinie.
Klingeln | LNRING | Ringpuffer mit fester Kapazität. Überschreibt die ältesten Elemente, wenn sie voll sind.
SkipList | LNSKIPLIST | Wahrscheinlichkeitsgeordnete Menge mit O(log n) Durchschnittsfalloperationen. Ausgewogene Skip-List-Struktur.
B+ Baum | LNBPTREE | Festplattenfreundlicher geordneter Satz mit hohem Verzweigungsfaktor. Bereichsabfragen und Massenoperationen.
Quadtree | LNQUAD | Räumlicher Index für LONG-Begrenzungsrahmen. Effiziente 2D-Bereichs- und Punktabfragen.
Bloom-Filter | LNBLOOM | Probabilistischer LONG-Mitgliedschaftstest. Keine falsch-negativen Ergebnisse; Einstellbare Falsch-Positiv-Rate.
Sicher | LNSAFE | Threadsicherer LONG-Stack-Wrapper mit Mutex-geschütztem Push und Pop.

Typvarianten

Jede Containerfamilie unterstützt bis zu 13 Elementtypen, was über 125 erkannte Typvarianten ergibt:

Suffix | PB-Typ | Größe | Suffix | PB-Typ | Größe
Bt | BYTE | 1 Byte | Sn | EINZEL | 4 Bytes
In | Ganzzahl (Wort) | 2 Bytes | Db | DOPPELT | 8 Byte
Wd | WORT (DWORD) | 2 Bytes | Cu | WÄHRUNG | 8 Byte
Dw | DWORD | 4 Bytes | Cx | WÄHRUNGX | 16 Byte
Ln | LONG | 4 Bytes | Ex | ERWEITERT | 10 Byte
Qd | QUAD | 8 Byte | SS | STRING (ANSI) | Zeigergroß
 |  |  | Ws | WSTRING (Unicode) | Zeigergroß

Methodensyntax

Container verwenden eine durch Punkte getrennte Syntax für Methodenaufrufe:

LOCAL q AS LnArr
q.New
q.Push 10
q.Push 20
n = q.Count    ' returns 2
v = q.Pop      ' returns 20
q.Final        ' auto-cleanup on scope exit

Properties are accessed without parentheses; Methoden, die Werte zurückgeben, verwenden die Funktionsaufrufsyntax. Die .Final Die Methode gibt den gesamten internen Speicher frei und wird automatisch aufgerufen, wenn die Variable den Gültigkeitsbereich verlässt.

Auto-Cleanup

Alle Containertypen implementieren eine automatische Bereinigung, wenn der deklarierende Bereich beendet wird. Dies funktioniert über den gleichen Mechanismus wie die vorhandene Zeichenfolgenbereinigung von PBXB64: Der Compiler sendet einen Aufruf an den Container .Final method at each scope-exit point. No manual memory management is required.

Siehe auch

  • Methodenreferenz – Vollständige Liste aller Containermethoden
  • Beispiele – Codeausschnitte für jeden Containertyp

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


Native H-Lib-Container – Methodenreferenz

Startseite › Native H-Lib-Container – Methodenreferenz

Native H-Lib-Containermethoden

Vollständige Referenz aller Methoden, die für native H-Lib-Containertypen verfügbar sind. Methoden werden nach Containerfamilie gruppiert. Alle Typen innerhalb einer Familie verwenden dieselben Methodensignaturen.

Allgemeine Methoden (alle Container)

Methode | Argumente | Rückgaben | Beschreibung
.New | keiner | nichts | Initialisiert den Container. Muss vor jeder anderen Methode aufgerufen werden. Optional – Container werden bei der ersten Verwendung automatisch initialisiert.
.Final | keiner | nichts | Zerstört den Container und gibt den gesamten internen Speicher frei. Wird beim Beenden des Bereichs automatisch aufgerufen.
.Validate | keiner | LONG | Gibt einen Wert ungleich Null zurück, wenn das Containerhandle gültig ist. Für Debug-Behauptungen verwenden.
.Clear | keiner | nichts | Entfernt alle Elemente, ohne die Zuordnung des Containers aufzuheben. Die Kapazität kann erhalten bleiben.
.Count | keiner | QUAD | Gibt die Anzahl der Elemente zurück, die sich derzeit im Container befinden.
.Capacity | keiner | QUAD | Gibt die aktuelle Kapazität (vorab zugewiesenen Speicher) zurück. Gilt für Arr, Stk, Que, Str, 2D.
.Trim | keiner | nichts | Reduziert die Kapazität, um sie an die aktuelle Elementanzahl anzupassen. Gibt überschüssigen Speicher frei.
.Clone | keiner | Behälter | Gibt eine tiefe Kopie des Containers mit unabhängigem Speicher zurück.

Arr (Array)-Methoden

Gilt für: LnArr, InArr, WdArr, BtArr, DwArr, QdArr, SnArr, DbArr, CuArr, CxArr, ExArr, SsArr, WsArr

Methode | Argumente | Rückgaben | Beschreibung
.Get | Index Wie QUAD | Element | Gibt das Element am angegebenen Index zurück. 0-basiert. Grenzen werden zur Laufzeit überprüft.
.Set | index Wie QUAD, Wert | nichts | Setzt das Element am angegebenen Index.
.Add | Wert | QUAD | Hängt ein Element an das Ende an. Gibt die neue Anzahl zurück.
.Push | Wert | QUAD | Alias für Hinzufügen. Wird an das Ende angehängt.
.Pop | keiner | Element | Entfernt das letzte Element und gibt es zurück. Schlägt fehl, wenn leer.
.Peek | keiner | Element | Gibt das letzte Element zurück, ohne es zu entfernen.
.Ins | index Wie QUAD, Wert | nichts | Fügt ein Element am angegebenen Index ein und verschiebt nachfolgende Elemente nach rechts.
.Del | Index Wie QUAD | nichts | Löscht das Element am angegebenen Index und verschiebt nachfolgende Elemente nach links.
.IndexOf | Wert | QUAD | Gibt den ersten Index des angegebenen Werts zurück oder -1, wenn er nicht gefunden wird. Lineare Suche.
.Contains | Wert | LONG | Gibt einen Wert ungleich Null zurück, wenn der Wert im Array vorhanden ist.
.Sort | keiner | nichts | Sortiert Elemente mithilfe von Quicksort in aufsteigender Reihenfolge. Nur für numerische Typen.
.SortDesc | keiner | nichts | Sortiert Elemente in absteigender Reihenfolge.
.Reverse | keiner | nichts | Kehrt die Reihenfolge aller vorhandenen Elemente um.
.Reserve | Kapazität Wie QUAD | nichts | Reserviert vorab Speicherplatz für die angegebene Anzahl von Elementen.

Stk (Stack)-Methoden

Gilt für: LnStk, InStk, WdStk, BtStk, DwStk, QdStk, SnStk, DbStk, CuStk, CxStk, ExStk, SsStk, WsStk

Methode | Argumente | Rückgaben | Beschreibung
.Push | Wert | QUAD | Schiebt einen Wert oben auf den Stapel. Gibt eine neue Anzahl zurück.
.Pop | keiner | Element | Öffnet das oberste Element und gibt es zurück. Schlägt fehl, wenn leer.
.Peek | keiner | Element | Gibt das oberste Element zurück, ohne es zu entfernen.

Que (Warteschlange)-Methoden

Gilt für: LnQue, InQue, WdQue, BtQue, DwQue, QdQue, SnQue, DbQue, CuQue, CxQue, ExQue, SsQue, WsQue

Methode | Argumente | Rückgaben | Beschreibung
.Push | Wert | QUAD | Stellt einen Wert hinten in die Warteschlange. Gibt eine neue Anzahl zurück.
.Pop | keiner | Element | Entnimmt das vordere Element der Warteschlange und gibt es zurück. Schlägt fehl, wenn leer.
.Peek | keiner | Element | Gibt das vordere Element zurück, ohne es zu entfernen.
.Front | keiner | Element | Gibt das vordere (älteste) Element zurück. Das Gleiche wie Peek.
.Back | keiner | Element | Gibt das vorherige (neueste) Element zurück, ohne es zu entfernen.

Lst-Methoden (Listenmethoden).

Gilt für: LnLst, InLst, WdLst, BtLst, DwLst, QdLst, SnLst, DbLst, CuLst, CxLst, ExLst, SsLst, WsLst

Methode | Argumente | Rückgaben | Beschreibung
.Add | Wert | QUAD | Fügt einen Wert an das Ende der Liste an. Gibt eine neue Anzahl zurück.
.AddHead | Wert | QUAD | Stellt am Anfang der Liste einen Wert voran.
.InsBefore | nodePtr Wie QUAD, Wert | nichts | Fügt einen Wert vor dem angegebenen Knotenzeiger ein.
.InsAfter | nodePtr Wie QUAD, Wert | nichts | Fügt einen Wert nach dem angegebenen Knotenzeiger ein.
.Remove | nodePtr As QUAD | nichts | Entfernt den Knoten am angegebenen Zeiger. Der Knotenzeiger wird ungültig.
.RemoveHead | keiner | Element | Entfernt das erste Element und gibt es zurück.
.RemoveTail | keiner | Element | Entfernt das letzte Element und gibt es zurück.
.GetHead | keiner | Element | Gibt das erste Element zurück, ohne es zu entfernen.
.GetTail | keiner | Element | Gibt das letzte Element zurück, ohne es zu entfernen.
.Next | nodePtr As QUAD | QUAD | Gibt den Zeiger auf den nächsten Knoten zurück oder 0, wenn am Ende.
.Prev | nodePtr As QUAD | QUAD | Gibt den Zeiger auf den vorherigen Knoten zurück oder 0 beim Start.
.GetNode | Index Wie QUAD | QUAD | Gibt den Knotenzeiger am angegebenen Index zurück.
.Value | nodePtr As QUAD | Element | Gibt den am angegebenen Knotenzeiger gespeicherten Wert zurück.

Str-Methoden (String Builder).

Gilt für: SsStr, WsStr

Methode | Argumente | Rückgaben | Beschreibung
.Append | Wert (Zeichenfolge) | QUAD | Fügt Text am Ende hinzu. Gibt die neue Länge zurück.
.AppendLine | Wert (Zeichenfolge) | QUAD | Fügt Text gefolgt von einem Zeilenumbruch hinzu. Gibt die neue Länge zurück.
.Ins | pos Als QUAD, Wert (Zeichenfolge) | nichts | Fügt Text an der angegebenen Position ein (1-basiert).
.Del | pos Wie QUAD, len Wie QUAD | nichts | Löscht len Zeichen beginnend bei pos (1-basiert).
.Replace | oldStr (Zeichenfolge), newStr (Zeichenfolge) | QUAD | Ersetzt alle Vorkommen von oldStr mit newStr. Gibt die Anzahl der Ersetzungen zurück.
.SubStr | pos Wie QUAD, len Wie QUAD | Zeichenfolge | Gibt einen Teilstring zurück, der bei beginnt pos mit der angegebenen Länge.
.CharAt | pos Als QUAD | Charakter | Gibt das Zeichen an der angegebenen Position zurück (1-basiert).
.ToUpper | keiner | nichts | Wandelt alle Zeichen direkt in Großbuchstaben um.
.ToLower | keiner | nichts | Wandelt alle Zeichen direkt in Kleinbuchstaben um.
.Trim | keiner | nichts | Entfernt führende und nachfolgende Leerzeichen direkt.
.ToString | keiner | Zeichenfolge | Gibt den aktuellen Inhalt als Standard-PB-String zurück.
.Length | keiner | QUAD | Gibt die aktuelle Länge des String-Inhalts zurück.

2D-Methoden (2D-Array).

Gilt für: Ln2D, In2D, Wd2D, Bt2D, Dw2D, Qd2D, Sn2D, Db2D, Cu2D, Cx2D, Ex2D, Ss2D, Ws2D

Methode | Argumente | Rückgaben | Beschreibung
.Resize | Zeilen wie QUAD, Spalten wie QUAD | nichts | Ändert die Größe des 2D-Arrays auf die angegebenen Abmessungen. Vorhandene Daten bleiben soweit möglich erhalten.
.Get | Zeile wie QUAD, Spalte wie QUAD | Element | Gibt das Element in der angegebenen Zeile und Spalte zurück. 0-basiert.
.Set | Zeile wie QUAD, Spalte wie QUAD, Wert | nichts | Setzt das Element in der angegebenen Zeile und Spalte.
.Rows | keiner | QUAD | Gibt die Anzahl der Zeilen zurück.
.Cols | keiner | QUAD | Gibt die Anzahl der Spalten zurück.
.GetRow | Reihe Als QUAD | Arr-Typ | Gibt ein 1D-Array (Arr) zurück, das die angegebene Zeile enthält.
.SetRow | Zeile Wie QUAD, arr Wie Arr-Typ | nichts | Legt die angegebene Zeile aus einem 1D-Array fest.

Hsh-Methoden (Hash-Tabelle).

Gilt für: LnLnHsh, InInHsh, WdWdHsh, BtBtHsh, DwDwHsh, QdQdHsh, SnSnHsh, DbDbHsh, CuCuHsh, CxCxHsh, ExExHsh, SsSsHsh, WsWsHsh

Methode | Argumente | Rückgaben | Beschreibung
.Put | Schlüssel, Wert | nichts | Fügt den Wert für den angegebenen Schlüssel ein oder aktualisiert ihn.
.Get | Schlüssel | Wert | Gibt den Wert für den angegebenen Schlüssel zurück. Schlägt fehl, wenn der Schlüssel nicht vorhanden ist.
.TryGet | Schlüssel, Standard | Wert | Gibt den Wert für den Schlüssel zurück oder den Standardwert, wenn er nicht gefunden wird.
.Remove | Schlüssel | LONG | Entfernt das Schlüssel-Wert-Paar. Gibt einen Wert ungleich Null zurück, wenn der Schlüssel vorhanden war.
.Contains | Schlüssel | LONG | Gibt einen Wert ungleich Null zurück, wenn der Schlüssel in der Tabelle vorhanden ist.
.Keys | keiner | Arr-Typ | Gibt ein Array zurück, das alle Schlüssel enthält.
.Values | keiner | Arr-Typ | Gibt ein Array zurück, das alle Werte enthält.

Tre (Baum)-Methoden

Gilt für: LnLnTre, InInTre, WdWdTre, BtBtTre, DwDwTre, QdQdTre, SnSnTre, DbDbTre, CuCuTre, CxCxTre, ExExTre, SsSsTre, WsWsTre

Methode | Argumente | Rückgaben | Beschreibung
.Put | Schlüssel, Wert | nichts | Fügt ein Schlüssel-Wert-Paar ein. Wenn der Schlüssel vorhanden ist, wird der Wert aktualisiert.
.Get | Schlüssel | Wert | Gibt den Wert für den angegebenen Schlüssel zurück. Schlägt fehl, wenn der Schlüssel nicht vorhanden ist.
.TryGet | Schlüssel, Standard | Wert | Gibt den Wert für den Schlüssel zurück oder den Standardwert, wenn er nicht gefunden wird.
.Remove | Schlüssel | LONG | Entfernt das Schlüssel-Wert-Paar. Gibt einen Wert ungleich Null zurück, wenn der Schlüssel vorhanden war.
.Contains | Schlüssel | LONG | Gibt einen Wert ungleich Null zurück, wenn der Schlüssel im Baum vorhanden ist.
.Min | keiner | Schlüssel | Gibt den kleinsten Schlüssel im Baum zurück.
.Max | keiner | Schlüssel | Gibt den größten Schlüssel im Baum zurück.
.Floor | Schlüssel | Schlüssel | Gibt den größten Schlüssel zurück, der kleiner oder gleich dem angegebenen Schlüssel ist.
.Ceil | Schlüssel | Schlüssel | Gibt den kleinsten Schlüssel zurück, der größer oder gleich dem angegebenen Schlüssel ist.
.Keys | keiner | Arr-Typ | Gibt ein sortiertes Array aller Schlüssel zurück (Durchlauf in der richtigen Reihenfolge).
.Values | keiner | Arr-Typ | Gibt ein Array aller Werte in Schlüsselreihenfolge zurück.

DTre-Methoden (Double Tree).

Gilt für: WsWsDTre

Methode | Argumente | Rückgaben | Beschreibung
.Put | Schlüssel als WSTRING, Wert als WSTRING | nichts | Fügt ein Schlüssel-Wert-Paar mit breiter Zeichenfolge ein.
.Get | Schlüssel Als WSTRING | WSTRING | Gibt den Wide-String-Wert für den angegebenen Schlüssel zurück.
.Contains | Schlüssel Als WSTRING | LONG | Gibt einen Wert ungleich Null zurück, wenn der Schlüssel vorhanden ist.
.Remove | Schlüssel Als WSTRING | LONG | Entfernt das Schlüssel-Wert-Paar.
.Keys | keiner | WsArr | Gibt ein Wide-String-Array aller Schlüssel zurück.
.Values | keiner | WsArr | Gibt ein Wide-String-Array aller Werte zurück.

Tri (Trie)-Methoden

Gilt für: SsSsTri

Methode | Argumente | Rückgaben | Beschreibung
.Put | Schlüssel als STRING, Wert als STRING | nichts | Fügt ein Schlüssel-Wert-Paar in den Versuch ein.
.Get | Schlüssel als STRING | STRING | Gibt den Wert für den angegebenen Schlüssel zurück.
.Contains | Schlüssel als STRING | LONG | Gibt einen Wert ungleich Null zurück, wenn der Schlüssel vorhanden ist.
.Remove | Schlüssel als STRING | LONG | Entfernt das Schlüssel-Wert-Paar.
.PrefixMatch | Präfix als STRING | SsArr | Gibt ein Array aller Schlüssel zurück, die mit dem angegebenen Präfix beginnen.
.AutoComplete | Präfix als STRING, max. als LONG | SsArr | Rückgabe bis zu max Schlüssel, die dem Präfix entsprechen (für die Benutzeroberfläche zur automatischen Vervollständigung).

Heap-Methoden (Prioritätswarteschlange).

Gilt für: LNHEAP

Methode | Argumente | Rückgaben | Beschreibung
.New | keiner | LNHEAP | Ordnen Sie einen neuen leeren Min-Heap zu.
.Final | keiner | nichts | Befreie den Haufen.
.Validate | keiner | LONG | Ungleich Null, wenn das Handle gültig ist.
.Clear | keiner | nichts | Entfernen Sie alle Werte.
.Count | keiner | LONG | Anzahl der Werte im Heap.
.Push | Wert As LONG | nichts | Geben Sie einen Wert ein. O(log n).
.Pop | keiner | QUAD | Entfernen Sie den kleinsten Wert und geben Sie ihn zurück. O(log n).
.Peek | keiner | QUAD | Gibt den kleinsten Wert zurück, ohne ihn zu entfernen. O(1).
.Empty | keiner | LONG | Ungleich Null, wenn der Heap leer ist.

Deque-Methoden

Gilt für: LNDEQUE

Methode | Argumente | Rückgaben | Beschreibung
.New | keiner | LNDEQUE | Weisen Sie eine neue leere Deque zu.
.Final | keiner | nichts | Befreie die Deque.
.Validate | keiner | LONG | Ungleich Null, wenn das Handle gültig ist.
.Clear | keiner | nichts | Entfernen Sie alle Werte.
.Count | keiner | LONG | Anzahl der Werte in der Deque.
.PushFront | Wert As LONG | nichts | Geben Sie vorne einen Wert ein. O(1).
.PushBack | Wert As LONG | nichts | Fügen Sie hinten einen Wert ein. O(1).
.PopFront | keiner | QUAD | Entfernen Sie den vorderen Wert und geben Sie ihn zurück. O(1).
.PopBack | keiner | QUAD | Entfernen Sie den Back-Wert und geben Sie ihn zurück. O(1).
.PeekFront | keiner | QUAD | Geben Sie den vorderen Wert zurück, ohne ihn zu entfernen. O(1).
.PeekBack | keiner | QUAD | Geben Sie den Wert zurück, ohne ihn zu entfernen. O(1).
.Empty | keiner | LONG | Ungleich Null, wenn die Deque leer ist.

Methoden festlegen

Gilt für: LNSET

Methode | Argumente | Rückgaben | Beschreibung
.New | keiner | LNSET | Ordnen Sie einen neuen leeren sortierten Satz zu.
.Final | keiner | nichts | Geben Sie das Set frei.
.Validate | keiner | LONG | Ungleich Null, wenn das Handle gültig ist.
.Clear | keiner | nichts | Entfernen Sie alle Werte.
.Count | keiner | LONG | Anzahl der eindeutigen Werte im Satz.
.Add | Wert As LONG | nichts | Geben Sie einen Wert ein, falls dieser noch nicht vorhanden ist. O(log n).
.Remove | Wert As LONG | nichts | Entfernen Sie einen Wert, falls vorhanden. O(log n).
.Contains | Wert As LONG | LONG | Ungleich Null, wenn der Wert vorhanden ist. O(log n).
.First | keiner | QUAD | Gibt den kleinsten Wert zurück (0, wenn leer).
.Next | Wert As LONG | QUAD | Gibt den nächstgrößeren Wert zurück (0, wenn keiner).
.Empty | keiner | LONG | Ungleich Null, wenn die Menge leer ist.
.ToArray | keiner | LNARR | Gibt einen neuen LNARR zurück, der alle Werte sortiert enthält.

Diagrammmethoden

Gilt für: LNGRAPH

Methode | Argumente | Rückgaben | Beschreibung
.New | keiner | LNGRAPH | Ordnen Sie ein neues leeres Diagramm zu.
.Final | keiner | nichts | Geben Sie das Diagramm frei.
.Validate | keiner | LONG | Ungleich Null, wenn das Handle gültig ist.
.Clear | keiner | nichts | Entfernen Sie alle Knoten und Kanten.
.Count | keiner | LONG | Anzahl der Knoten im Diagramm.
.Empty | keiner | LONG | Ungleich Null, wenn das Diagramm keine Knoten hat.
.AddNode | id So LANG | nichts | Fügen Sie einen Knoten mit der angegebenen ID hinzu.
.AddEdge | u So LANG, v So LANG | nichts | Fügen Sie eine ungerichtete Kante zwischen zwei Knoten hinzu.
.RemoveNode | id So LANG | nichts | Entfernen Sie einen Knoten und seine einfallenden Kanten.
.RemoveEdge | u So LANG, v So LANG | nichts | Entfernen Sie eine ungerichtete Kante.
.HasEdge | u So LANG, v So LANG | LONG | Ungleich Null, wenn die Kante vorhanden ist.
.Neighbors | id So LANG | LNARR | Gibt eine neue LNARR von Nachbar-IDs zurück.

Multiset-Methoden

Gilt für: LNMULTISET

Methode | Argumente | Rückgaben | Beschreibung
.New | keiner | LNMULTISET | Ordnen Sie ein neues leeres Multiset zu.
.Final | keiner | nichts | Geben Sie das Multiset frei.
.Validate | keiner | LONG | Ungleich Null, wenn das Handle gültig ist.
.Clear | keiner | nichts | Entfernen Sie alle Werte und Zählungen.
.Count | keiner | LONG | Gesamtzahl der Elemente (Summe aller Multiplizitäten).
.UniqueCount | keiner | LONG | Anzahl unterschiedlicher Werte.
.Add | Wert As LONG | nichts | Fügen Sie einen Wert ein und erhöhen Sie dessen Multiplizität.
.Remove | Wert As LONG | nichts | Multiplizität dekrementieren, entfernen, wenn die Anzahl Null erreicht.
.RemoveAll | Wert As LONG | nichts | Entfernen Sie alle Vorkommen des Werts.
.Contains | Wert As LONG | LONG | Ungleich Null, wenn der Wert vorhanden ist.
.Multiplicity | Wert As LONG | LONG | Gibt die Anzahl des angegebenen Werts zurück (0, falls nicht vorhanden).
.First | keiner | QUAD | Gibt den kleinsten Wert zurück (0, wenn leer).
.Next | Wert As LONG | QUAD | Gibt den nächstgrößeren eindeutigen Wert zurück (0, wenn keiner).
.Empty | keiner | LONG | Ungleich Null, wenn das Multiset leer ist.

Union-Find-Methoden

Gilt für: LNUNIONFIND

Methode | Argumente | Rückgaben | Beschreibung
.New | keiner | LNUNIONFIND | Ordnen Sie einen neuen leeren Union-Find zu.
.Final | keiner | nichts | Befreie den Gewerkschaftsfund.
.Validate | keiner | LONG | Ungleich Null, wenn das Handle gültig ist.
.Clear | keiner | nichts | Entfernen Sie alle Elemente.
.Count | keiner | LONG | Anzahl der Elemente.
.MakeSet | x So LANG | nichts | Fügen Sie ein neues Singleton-Set für x hinzu.
.Find | x So LANG | QUAD | Gibt den Vertreter von x zurück (0, falls unbekannt).
.Union | x So LANG, y So LANG | LONG | Ungleich Null, wenn die Gewerkschaft etwas geändert hat.
.SameSet | x So LANG, y So LANG | LONG | Ungleich Null, wenn x und y in derselben Menge sind.
.Empty | keiner | LONG | Ungleich Null, wenn der Union-Find leer ist.
.Components | keiner | LONG | Anzahl disjunkter Mengen.

LRU-Cache-Methoden

Gilt für: LNLRU

Methode | Argumente | Rückgaben | Beschreibung
.New | Kapazität So LANG | LNLRU | Weisen Sie einen neuen LRU-Cache mit der angegebenen Kapazität zu.
.Final | keiner | nichts | Geben Sie den Cache frei.
.Validate | keiner | LONG | Ungleich Null, wenn das Handle gültig ist.
.Clear | keiner | nichts | Entfernen Sie alle Einträge.
.Count | keiner | LONG | Anzahl der derzeit im Cache befindlichen Einträge.
.Capacity | keiner | LONG | Geben Sie die maximale Kapazität zurück.
.Put | Schlüssel As LONG, Wert As LONG | nichts | Fügen Sie ein Schlüssel-Wert-Paar ein oder aktualisieren Sie es. Vertreibt die Ältesten, wenn die Kapazität erreicht ist.
.Get | Schlüssel So LANG | QUAD | Gibt den Wert für den Schlüssel zurück (0, wenn nicht gefunden).
.Contains | Schlüssel So LANG | LONG | Ungleich Null, wenn der Schlüssel vorhanden ist.
.Remove | Schlüssel So LANG | LONG | Entfernen Sie das Schlüssel-Wert-Paar. Gibt einen Wert ungleich Null zurück, falls vorhanden.
.Empty | keiner | LONG | Ungleich Null, wenn der Cache leer ist.

Ringmethoden (zirkulärer Puffer).

Gilt für: LNRING

Methode | Argumente | Rückgaben | Beschreibung
.New | Kapazität So LANG | LNRING | Weisen Sie einen neuen Ringpuffer mit der angegebenen Kapazität zu.
.Final | keiner | nichts | Geben Sie den Ringpuffer frei.
.Validate | keiner | LONG | Ungleich Null, wenn das Handle gültig ist.
.Clear | keiner | nichts | Alle Werte entfernen (Kapazität beibehalten).
.Count | keiner | LONG | Anzahl der aktuell im Puffer befindlichen Werte.
.Capacity | keiner | LONG | Geben Sie die feste Kapazität zurück.
.Push | Wert As LONG | nichts | Geben Sie einen Wert ein. Überschreibt die älteste, wenn die Kapazität erreicht ist.
.Pop | keiner | QUAD | Entfernen Sie den ältesten Wert und geben Sie ihn zurück.
.Peek | keiner | QUAD | Gibt den ältesten Wert zurück, ohne ihn zu entfernen.
.Empty | keiner | LONG | Ungleich Null, wenn der Ringpuffer leer ist.
.Full | keiner | LONG | Ungleich Null, wenn der Ringpuffer voll ist.

SkipList-Methoden

Gilt für: LNSKIPLIST

Methode | Argumente | Rückgaben | Beschreibung
.New | keiner | LNSKIPLIST | Ordnen Sie eine neue leere Skiplist zu.
.Final | keiner | nichts | Befreien Sie die Skiplist.
.Validate | keiner | LONG | Ungleich Null, wenn das Handle gültig ist.
.Clear | keiner | nichts | Entfernen Sie alle Werte.
.Count | keiner | LONG | Anzahl der Werte in der Skiplist.
.Add | Wert As LONG | nichts | Geben Sie einen Wert ein, falls dieser noch nicht vorhanden ist.
.Remove | Wert As LONG | nichts | Entfernen Sie einen Wert.
.Contains | Wert As LONG | LONG | Ungleich Null, wenn der Wert vorhanden ist.
.First | keiner | QUAD | Gibt den kleinsten Wert zurück (0, wenn leer).
.Next | Wert As LONG | QUAD | Gibt den nächstgrößeren Wert zurück (0, wenn keiner).
.Empty | keiner | LONG | Ungleich Null, wenn die Skiplist leer ist.

B+-Baummethoden

Gilt für: LNBPTREE

Methode | Argumente | Rückgaben | Beschreibung
.New | Bestellen Sie so lange | LNBPTREE | Ordnen Sie einen neuen B+-Baum mit der angegebenen Reihenfolge (Verzweigungsfaktor) zu.
.Final | keiner | nichts | Befreie den B+-Baum.
.Validate | keiner | LONG | Ungleich Null, wenn das Handle gültig ist.
.Clear | keiner | nichts | Entfernen Sie alle Werte.
.Count | keiner | LONG | Anzahl der Werte im Baum.
.Add | Wert As LONG | nichts | Geben Sie einen Wert ein, falls dieser noch nicht vorhanden ist.
.Remove | Wert As LONG | nichts | Entfernen Sie einen Wert.
.Contains | Wert As LONG | LONG | Ungleich Null, wenn der Wert vorhanden ist.
.First | keiner | QUAD | Gibt den kleinsten Wert zurück (0, wenn leer).
.Next | Wert As LONG | QUAD | Gibt den nächstgrößeren Wert zurück (0, wenn keiner).
.Range | lo As LONG, hallo As LONG | LNARR | Gibt alle Werte in [lo, hi] als sortiertes LNARR zurück.
.Empty | keiner | LONG | Ungleich Null, wenn der B+-Baum leer ist.

Quadtree-Methoden

Gilt für: LNQUAD

Methode | Argumente | Rückgaben | Beschreibung
.New | maxDepth As LONG | LNQUAD | Weisen Sie einen neuen Quadtree mit der angegebenen maximalen Tiefe zu.
.Final | keiner | nichts | Befreie den Quadtree.
.Validate | keiner | LONG | Ungleich Null, wenn das Handle gültig ist.
.Clear | keiner | nichts | Entfernen Sie alle Begrenzungsrahmen.
.Count | keiner | LONG | Anzahl der Begrenzungsrahmen im Quadtree.
.Insert | id Wie LANG, x1 Wie LANG, y1 Wie LANG, x2 Wie LANG, y2 Wie LANG | nichts | Fügen Sie einen Begrenzungsrahmen mit der angegebenen ID und den angegebenen Koordinaten ein.
.Remove | id So LANG | LONG | Entfernen Sie den Begrenzungsrahmen mit der angegebenen ID.
.Query | x1 So LANG, y1 So LANG, x2 So LANG, y2 So LANG | LNARR | Gibt die IDs aller Felder zurück, die das Abfragerechteck überlappen.
.Empty | keiner | LONG | Ungleich Null, wenn der Quadtree leer ist.

Bloom-Filtermethoden

Gilt für: LNBLOOM

Methode | Argumente | Rückgaben | Beschreibung
.New | Kapazität: LONG, Fehlerrate: DOUBLE | LNBLOOM | Weisen Sie einen neuen Bloom-Filter für die angegebene Kapazität und Falsch-Positiv-Rate zu.
.Final | keiner | nichts | Befreien Sie den Bloom-Filter.
.Validate | keiner | LONG | Ungleich Null, wenn das Handle gültig ist.
.Clear | keiner | nichts | Alle Bits im Filter löschen.
.Add | Wert As LONG | nichts | Fügen Sie dem Filter einen Wert hinzu.
.Contains | Wert As LONG | LONG | Ungleich Null, wenn der Wert vorhanden sein kann (probabilistisch). Keine falsch negativen Ergebnisse.
.Capacity | keiner | LONG | Gibt die erwartete Kapazität zurück (vom Konstruktor).
.ErrorRate | keiner | DOPPELT | Gibt die konfigurierte Falsch-Positiv-Rate zurück.
.Empty | keiner | LONG | Ungleich Null, wenn dem Filter keine Werte hinzugefügt wurden.

Sichere (Thread-sichere) Methoden

Gilt für: LNSAFE

Methode | Argumente | Rückgaben | Beschreibung
.New | keiner | LNSAFE | Weisen Sie einen neuen threadsicheren Stack-Wrapper zu.
.Final | keiner | nichts | Geben Sie den sicheren Behälter frei.
.Validate | keiner | LONG | Ungleich Null, wenn das Handle gültig ist.
.Clear | keiner | nichts | Entfernen Sie alle Werte.
.Count | keiner | LONG | Anzahl der Werte im Stapel.
.Push | Wert As LONG | nichts | Threadsicherer Push. Erwirbt Mutex, Pushs, Releases.
.Pop | keiner | QUAD | Fadensicherer Pop. Erwirbt Mutex, Pops, Releases. Gibt 0 zurück, wenn leer.
.Peek | keiner | QUAD | Threadsicherer Einblick. Gibt den Nach obennwert zurück, ohne ihn zu entfernen. 0, wenn leer.
.Empty | keiner | LONG | Ungleich Null, wenn der Stapel leer ist.

Siehe auch

  • Überblick -- Containerfamilien und Typvarianten
  • Beispiele – Codeausschnitte für jeden Containertyp

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


Native H-Lib-Container – Beispiele

Startseite › Native H-Lib-Container – Beispiele

Beispiele für native H-Lib-Container

Codebeispiele, die die Verwendung jedes nativen H-Lib-Containertyps veranschaulichen.

LnArr (LONG-Array)

FUNCTION PBMAIN() AS LONG
  LOCAL q AS LnArr
  LOCAL i AS LONG
  LOCAL n AS QUAD

  q.New
  q.Push 10
  q.Push 20
  q.Push 30

  n = q.Count           ' n = 3
  i = q.Get(1)          ' i = 20 (0-based)
  q.Ins 1, 15           ' insert 15 at index 1
  q.Sort                ' result: 10, 15, 20, 30
  q.Del 0               ' remove first element
  i = q.Pop             ' i = 30, q now has [15, 20]
  q.Final               ' auto-cleanup
END FUNCTION

LnStk (LONG Stack)

FUNCTION PBMAIN() AS LONG
  LOCAL s AS LnStk
  LOCAL v AS LONG

  s.Push 100
  s.Push 200
  s.Push 300

  v = s.Peek            ' v = 300
  v = s.Pop             ' v = 300, stack now [100, 200]
  v = s.Pop             ' v = 200
  v = s.Pop             ' v = 100
  ' s.Count = 0
  s.Final
END FUNCTION

LnQue (LANGE Warteschlange)

FUNCTION PBMAIN() AS LONG
  LOCAL q AS LnQue
  LOCAL v AS LONG

  q.Push 10             ' enqueue
  q.Push 20
  q.Push 30

  v = q.Front           ' v = 10
  v = q.Back            ' v = 30
  v = q.Pop             ' v = 10, queue now [20, 30]
  v = q.Pop             ' v = 20
  v = q.Pop             ' v = 30
  q.Final
END FUNCTION

LnLst (LANGE Liste)

FUNCTION PBMAIN() AS LONG
  LOCAL lst AS LnLst
  LOCAL node AS QUAD
  LOCAL v AS LONG

  lst.Add 10            ' list: [10]
  lst.Add 20            ' list: [10, 20]
  lst.AddHead 5         ' list: [5, 10, 20]
  lst.InsAfter 5, 7     ' insert 7 after value 5

  node = lst.GetHead    ' first node
  v = lst.Value(node)   ' v = 5
  node = lst.Next(node) ' advance to next node
  v = lst.Value(node)   ' v = 7

  lst.Remove(node)      ' remove node with value 7
  lst.Final
END FUNCTION

SsStr (ANSI String Builder)

FUNCTION PBMAIN() AS LONG
  LOCAL sb AS SsStr
  LOCAL s AS STRING
  LOCAL n AS QUAD

  sb.Append "Hello"
  sb.Append " World"
  n = sb.Length          ' n = 11
  s = sb.ToString        ' s = "Hello World"

  sb.Ins 6, "PBXB64 "   ' insert at position 6 (1-based)
  s = sb.ToString        ' s = "Hello PBXB64 World"

  sb.Replace "World", "Containers"
  s = sb.ToString        ' s = "Hello PBXB64 Containers"

  sb.ToUpper
  s = sb.ToString        ' s = "HELLO PBXB64 CONTAINERS"
  sb.Final
END FUNCTION

Ln2D (LANGES 2D-Array)

FUNCTION PBMAIN() AS LONG
  LOCAL m AS Ln2D
  LOCAL v AS LONG

  m.Resize 3, 4         ' 3 rows, 4 columns
  m.Set 0, 0, 42        ' set row 0, col 0 to 42
  v = m.Get(0, 0)       ' v = 42

  ' Rows and Cols properties
  LOCAL r, c AS QUAD
  r = m.Rows             ' r = 3
  c = m.Cols             ' c = 4

  ' Extract a row as 1D array
  LOCAL rowArr AS LnArr
  rowArr = m.GetRow(1)
  m.Final
  rowArr.Final
END FUNCTION

LnLnHsh (LONG-to-LONG-Hash-Tabelle)

FUNCTION PBMAIN() AS LONG
  LOCAL h AS LnLnHsh
  LOCAL v AS LONG
  LOCAL found AS LONG

  h.Put 1, 100
  h.Put 2, 200
  h.Put 3, 300

  v = h.Get(2)           ' v = 200
  found = h.Contains(4)  ' found = 0 (false)

  h.Remove 1             ' remove key 1

  ' Enumerate keys
  LOCAL keys AS LnArr
  keys = h.Keys          ' keys = [2, 3]
  h.Final
  keys.Final
END FUNCTION

LnLnTre (LONG-to-LONG AVL-Baum)

FUNCTION PBMAIN() AS LONG
  LOCAL t AS LnLnTre
  LOCAL v AS LONG
  LOCAL k AS LONG

  t.Put 50, 500
  t.Put 30, 300
  t.Put 70, 700
  t.Put 20, 200
  t.Put 40, 400

  k = t.Min              ' k = 20 (smallest key)
  k = t.Max              ' k = 70 (largest key)
  k = t.Floor(35)        ' k = 30 (floor of 35)
  k = t.Ceil(35)         ' k = 40 (ceil of 35)

  v = t.Get(30)          ' v = 300

  ' Sorted keys
  LOCAL keys AS LnArr
  keys = t.Keys          ' keys = [20, 30, 40, 50, 70]
  t.Final
  keys.Final
END FUNCTION

LNHEAP (Heap / Prioritätswarteschlange)

FUNCTION PBMAIN() AS LONG
  LOCAL h AS LNHEAP
  LOCAL v AS LONG

  h = h.New
  h.Push 30
  h.Push 10
  h.Push 20

  v = h.Peek      ' v = 10 (smallest)
  v = h.Pop       ' v = 10, heap now [20, 30]
  v = h.Pop       ' v = 20
  h.Final
END FUNCTION

LNDEQUE (Doppelendige Warteschlange)

FUNCTION PBMAIN() AS LONG
  LOCAL d AS LNDEQUE
  LOCAL v AS LONG

  d = d.New
  d.PushBack 10
  d.PushFront 5
  d.PushBack 15

  v = d.PeekFront  ' v = 5
  v = d.PeekBack   ' v = 15
  v = d.PopFront   ' v = 5
  v = d.PopBack    ' v = 15
  d.Final
END FUNCTION

LNSET (sortierter eindeutiger Satz)

FUNCTION PBMAIN() AS LONG
  LOCAL s AS LNSET
  LOCAL v AS LONG

  s = s.New
  s.Add 3
  s.Add 1
  s.Add 2
  s.Add 3        ' duplicate ignored

  v = s.Count     ' v = 3
  v = s.First     ' v = 1
  v = s.Next 1    ' v = 2
  v = s.Contains 2 ' non-zero
  s.Final
END FUNCTION

LNGRAPH (Ungerichteter Graph)

FUNCTION PBMAIN() AS LONG
  LOCAL g AS LNGRAPH
  LOCAL n AS LONG
  LOCAL neighbors AS LNARR

  g = g.New
  g.AddNode 1
  g.AddNode 2
  g.AddNode 3
  g.AddEdge 1, 2
  g.AddEdge 2, 3

  n = g.Count       ' n = 3
  n = g.HasEdge(1, 2) ' non-zero

  neighbors = g.Neighbors 2  ' neighbors = [1, 3]
  g.Final
  neighbors.Final
END FUNCTION

LNMULTISET (Beutel mit Multiplizität)

FUNCTION PBMAIN() AS LONG
  LOCAL m AS LNMULTISET
  LOCAL v AS LONG

  m = m.New
  m.Add 5
  m.Add 5
  m.Add 3

  v = m.Count         ' v = 3 (total elements)
  v = m.UniqueCount   ' v = 2 (distinct values)
  v = m.Multiplicity 5 ' v = 2
  m.Remove 5          ' multiplicity becomes 1
  m.RemoveAll 5       ' completely removed
  m.Final
END FUNCTION

LNUNIONFIND (Disjunkte Menge)

FUNCTION PBMAIN() AS LONG
  LOCAL uf AS LNUNIONFIND
  LOCAL v AS LONG

  uf = uf.New
  uf.MakeSet 1
  uf.MakeSet 2
  uf.MakeSet 3

  v = uf.SameSet(1, 2) ' v = 0 (false)
  uf.Union 1, 2
  v = uf.SameSet(1, 2) ' v = non-zero (true)
  v = uf.Components    ' v = 2 (sets: {1,2}, {3})
  uf.Final
END FUNCTION

LNLRU (LRU-Cache)

FUNCTION PBMAIN() AS LONG
  LOCAL cache AS LNLRU
  LOCAL v AS LONG

  cache = cache.New 3     ' capacity = 3
  cache.Put 1, 100
  cache.Put 2, 200
  cache.Put 3, 300
  cache.Put 4, 400       ' evicts key 1 (oldest)

  v = cache.Get 2        ' v = 200
  v = cache.Contains 1   ' v = 0 (evicted)
  v = cache.Count        ' v = 3
  cache.Final
END FUNCTION

LNRING (Ringpuffer)

FUNCTION PBMAIN() AS LONG
  LOCAL r AS LNRING
  LOCAL v AS LONG

  r = r.New 3            ' capacity = 3
  r.Push 10
  r.Push 20
  r.Push 30
  r.Push 40             ' overwrites 10

  v = r.Peek            ' v = 20 (oldest remaining)
  v = r.Pop             ' v = 20
  v = r.Full            ' v = 0 (not full)
  r.Final
END FUNCTION

LNSKIPLIST (Probabilistisch geordneter Satz)

FUNCTION PBMAIN() AS LONG
  LOCAL sl AS LNSKIPLIST
  LOCAL v AS LONG

  sl = sl.New
  sl.Add 50
  sl.Add 30
  sl.Add 70

  v = sl.First      ' v = 30
  v = sl.Next 30    ' v = 50
  v = sl.Contains 70 ' non-zero
  sl.Final
END FUNCTION

LNBPTREE (B+ Baum)

FUNCTION PBMAIN() AS LONG
  LOCAL t AS LNBPTREE
  LOCAL v AS LONG
  LOCAL arr AS LNARR

  t = t.New 4          ' order = 4
  t.Add 10
  t.Add 20
  t.Add 30
  t.Add 40
  t.Add 50

  v = t.First          ' v = 10
  arr = t.Range 15, 45 ' arr = [20, 30, 40]
  t.Final
  arr.Final
END FUNCTION

LNQUAD (Quadtree)

FUNCTION PBMAIN() AS LONG
  LOCAL q AS LNQUAD
  LOCAL ids AS LNARR
  LOCAL n AS LONG

  q = q.New 8          ' max depth = 8
  q.Insert 1, 0, 0, 10, 10
  q.Insert 2, 5, 5, 15, 15
  q.Insert 3, 20, 20, 30, 30

  ids = q.Query 4, 4, 12, 12  ' ids = [1, 2] (overlapping boxes)
  n = q.Count            ' n = 3
  q.Final
  ids.Final
END FUNCTION

LNBLOOM (Bloom-Filter)

FUNCTION PBMAIN() AS LONG
  LOCAL b AS LNBLOOM
  LOCAL v AS LONG

  b = b.New 1000, 0.01  ' capacity 1000, 1% false-positive rate
  b.Add 42
  b.Add 99
  b.Add 123

  v = b.Contains 42     ' non-zero (definitely present)
  v = b.Contains 999    ' probably 0 (not added)
  v = b.ErrorRate       ' v = 0.01
  b.Final
END FUNCTION

LNSAFE (Thread-Safe Stack)

FUNCTION PBMAIN() AS LONG
  LOCAL s AS LNSAFE
  LOCAL v AS LONG

  s = s.New
  s.Push 100
  s.Push 200

  v = s.Peek            ' v = 200
  v = s.Pop             ' v = 200
  v = s.Count           ' v = 1
  s.Final
END FUNCTION

Siehe auch

  • Überblick -- Containerfamilien und Typvarianten
  • Methodenreferenz – Vollständige Liste aller Containermethoden

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


H-Lib C API – PBXB64-Compiler-Hilfe

Startseite › H-Lib C-API

H-Lib C-API

Native C-API zum Erstellen und Bearbeiten von H-Lib-Containerobjekten aus C-Code oder Inline-Assembly.

Typ: API-Referenz | Kategorie: Native H-Lib-Container

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Überblick

Die H-Lib C-API stellt dieselben Containerfamilien bereit, die vom BASIC-Frontend (Arr, Stk, Que, Lst, Str, 2D, Hsh, Tre, DTre, Tri) als einfache C-Funktionen verwendet werden. Verwenden Sie sie, wenn C-Code oder Inline-Assembly einen Container anlegen, veraendern, abfragen und mit den gleichen Lebensdauerregeln wie die BASIC-Methodensyntax freigeben muss.

Gemeinsame Funktionen

  • c_hlib_<variant>_new() – einen neuen Container anlegen und ein besitzendes Handle zurückgeben.
  • c_hlib_<variant>_final() – Containerressourcen freigeben und das Handle ungueltig machen.
  • c_hlib_<variant>_push, _pop, _get, _set — familiespezifische Operationen auf dem von _new() gelieferten Handle.

Aufrufvertrag

Zuerst anlegen, dann das Handle nur verwenden, solange es gueltig ist, und _final() genau einmal aufrufen, wenn der Container nicht mehr benoetigt wird. Funktionen, die Container-Handles zurückgeben, uebereignen das Eigentum an den Aufrufer. Skalar rueckgebende Funktionen uebertragen kein Eigentum. Wenn eine Methode fehlschlagen kann, pruefen Sie den Rueckgabewert, bevor Sie einen Zeiger dereferenzieren oder einen Ausgabewert verwenden.

Parameterregeln

  • Zeigerparameter erwarten normalerweise die Adresse eines vorhandenen PBXB64-Werts oder eines C-Puffers mit dem dokumentierten Elementtyp.
  • Zaehler- und Indexparameter sind pointergroessen- oder 64-Bit-Werte, wenn die Familie das verlangt; kuerzen Sie sie in neuem Code nicht auf 32 Bit.
  • Methoden, die ein Element per Index aendern, verwenden zero-based Indizes, sofern die Familienseite nichts anderes sagt.
  • Funktionen, die Strings oder Arrays zurueckgeben, liefern normalerweise einen neuen Container oder Puffer im Besitz des Aufrufers, sofern die Familienseite keine geteilte Speicherung beschreibt.

Beispiel

/* Pseudocode */
handle = c_hlib_lnarr_new();
if (handle == 0) fail();
c_hlib_lnarr_push(handle, 10);
c_hlib_lnarr_push(handle, 20);
value = c_hlib_lnarr_pop(handle);
c_hlib_lnarr_final(handle);

Siehe auch

  • Native H-Lib-Container
  • Übersicht über native H-Lib
  • C-Sprachreferenz

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


H-Lib-Subscript-Zugriff – PBXB64-Compiler-Hilfe

Startseite › H-Lib-Subscript-Zugriff

Zugriff auf H-Lib-Subskripte

So lesen und schreiben Sie H-Lib-Containerelemente mithilfe der Indexsyntax.

Typ: automatisch durchsucht. Referenz | Kategorie: Native H-Lib-Container

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

value = container(index)
container(index) = value
value = container(key)
container(key) = value

Remarks

Der Indexzugriff wird vom Compiler der entsprechenden C-API-Funktion für die Containerfamilie zugeordnet. Arrays und Listen verwenden numerische Indizes; Hash-Tabellen und Bäume verwenden Schlüssel. Lesen gibt das gespeicherte Element zurück, Schreiben ersetzt das Element an der gewaehlten Position oder unter dem gewaehlten Schlüssel.

Regeln

  • Array-aehnliche Container verwenden nullbasierte numerische Indizes.
  • Schluesselbasierte Container verwenden den Schlüsseltyp der Familie, typischerweise Zeichenfolgen oder numerische Schlüssel.
  • Ein Lesezugriff auf einen fehlenden Schlüssel ist ein familiespezifischer "nicht gefunden"-Fall und kein allgemeiner Compilerfehler.
  • Ein Schreibzugriff kann je nach Familie ein neues Element einfügen, ein vorhandenes aktualisieren oder den Container erweitern.

Beispiel

FUNCTION PBMAIN() AS LONG
  LOCAL arr AS LNARR OF LONG
  arr(0) = 10
  PRINT arr(0)
  PRINT arr.Count
  FUNCTION = 0
END FUNCTION

Verwendungshinweise

Verwenden Sie die Indexsyntax, wenn der Compiler bei einem Lesen oder Schreiben an genau einer Position oder unter genau einem Schlüssel den passenden Containeraufruf erzeugen soll. Verwenden Sie die Methodenseiten, wenn Sie die Erstellung, Traversierung oder Freigabe des Container-Handles explizit steuern wollen.

Siehe auch

  • Native H-Lib-Container
  • Referenz zu nativen H-Lib-Methoden

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.

Zurück zum Befehlsindex


H-Lib-Container-Funktionsparameter – PBXB64-Compiler-Hilfe

Startseite › H-Lib-Container-Funktionsparameter

H-Lib-Container-Funktionsparameter

Parameterkonventionen, die von H-Lib-Containermethoden und C-API-Funktionen verwendet werden.

Typ: Referenz | Kategorie: Native H-Lib-Container

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Parametertypen

  • Schlüsselparameter: Der Typ hängt von der Containerfamilie ab. Hash-Tabellen, Bäume und Tries verwenden typischerweise Zeichenfolgen oder UDT-kompatible Schlüssel; mengenartige Familien verwenden ganze Zahlen.
  • Wertparameter: typischerweise INT64, Zeigergröße oder ein per Referenz übergebenes Payload, das zum Elementtyp passt.
  • Indexparameter: nullbasierte 64-Bit-Ganzzahlen für Arrays, Ringe und andere positionsbasierte Container.
  • Flags: Bitmaskenoptionen, die Einfüge-, Such-, Vergleichs- oder Traversalverhalten steuern.

String-Argumente

Übergeben Sie für Container mit Zeichenfolgenschlüssel ein const char* aus C oder einen PB STRING-Ausdruck aus BASIC. Der String muss fuer die Dauer des Aufrufs gueltig bleiben; wenn die Familie den Schlüssel intern kopiert, soll die jeweilige Familienseite das explizit sagen.

Eigentumsregeln

Methoden, die einen Container anlegen oder zurückgeben, übertragen das Eigentum an den Aufrufer. Methoden, die nur einen Wert lesen, übertragen kein Eigentum. Methoden, die einen Zeiger in den Containerspeicher zurückgeben, liefern nur eine kurzfristige Sicht; dieser Zeiger wird nach der naechsten Aenderung, dem Loeschen oder der Freigabe ungueltig, sofern die Familienseite nichts anderes sagt.

Beispiel

LOCAL q AS LNARR
q = q.New
q.Push 10
q.Push 20
PRINT q(0)
PRINT q.Count
q.Final

Siehe auch

  • Native H-Lib-Container
  • H-Lib C-API

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex


H-Lib Bloom Filter - PBXB64 Compiler Help

Startseite › H-Lib Bloom Filter

H-Lib Bloom Filter

A space-efficient probabilistic membership structure for LONG keys. False positives are possible; false negatives are not.

Kind: Container | Category: H-Lib Native Containers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Description

This H-Lib container is implemented in native C support code and exposed through PBXB64 BASIC container syntax. The examples below are focused usage patterns; keep handles valid, release each container with its Final method, and check counts or return values when a method can fail.

Syntax

LNBLOOM

Methods

Method | Signature | Returns | Description
New | b.New capacity, target_fpp | LNBLOOM | Allocate a filter for the expected item count and target false-positive probability.
Final | b.Final | none | Free the filter.
Validate | b.Validate | LONG | Non-zero if the handle is valid.
Clear | b.Clear | none | Remove all inserted keys.
Count | b.Count | LONG | Number of keys added.
Capacity | b.Capacity | LONG | Expected maximum item count.
Add | b.Add key | none | Insert a key.
Contains | b.Contains key | LONG | Non-zero if the key may be present.
FalsePositiveRate | b.FalsePositiveRate | DOUBLE | Estimated current false-positive rate.

Examples

Basic membership test

LOCAL b AS LNBLOOM
LOCAL fpr AS DOUBLE
b = b.New 1000, 0.01
b.Add 42
PRINT b.Contains 42 REM non-zero
PRINT b.Contains 99 REM probably 0
fpr = b.FalsePositiveRate
PRINT b.Count       REM 1
PRINT b.Capacity    REM 1000
b.Final

Clear and reuse

LOCAL b AS LNBLOOM
b = b.New 100, 0.05
b.Add 1
b.Add 2
PRINT b.Count REM 2
b.Clear
PRINT b.Count REM 0
PRINT b.Contains 1 REM 0
b.Final

Validation Evidence

Validation evidence: H-Lib container behavior is exercised by registered BASIC container validation programs and the embedded H-Lib object set used by the single-EXE validation gate.

See Also

Back to H-Lib container index | Native H-Lib overview | Back to command index

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


H-Lib B+ Tree - PBXB64 Compiler Help

Startseite › H-Lib B+ Tree

H-Lib B+ Tree

A B+ tree storing unique sorted LONG keys. It provides disk-friendly ordered-set semantics and supports iteration and conversion to an array.

Kind: Container | Category: H-Lib Native Containers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Description

This H-Lib container is implemented in native C support code and exposed through PBXB64 BASIC container syntax. The examples below are focused usage patterns; keep handles valid, release each container with its Final method, and check counts or return values when a method can fail.

Syntax

LNBPTREE

Methods

Method | Signature | Returns | Description
New | t.New | LNBPTREE | Allocate a new empty B+ tree.
Final | t.Final | none | Free the B+ tree.
Validate | t.Validate | LONG | Non-zero if the handle is valid.
Clear | t.Clear | none | Remove all keys.
Count | t.Count | LONG | Number of keys.
Add | t.Add key | none | Insert a key.
Remove | t.Remove key | none | Remove a key.
Contains | t.Contains key | LONG | Non-zero if the key is present.
First | t.First | QUAD | Return the smallest key (0 if empty).
Next | t.Next key | QUAD | Return the next larger key (0 if none).
Empty | t.Empty | LONG | Non-zero if the B+ tree is empty.
ToArray | t.ToArray | LNARR | Return a new LNARR of keys in sorted order.

Examples

Add, Remove, Contains

LOCAL t AS LNBPTREE
t = t.New
t.Add 5
t.Add 2
t.Add 8
PRINT t.Contains 2 REM non-zero
PRINT t.Contains 9 REM 0
t.Remove 5
PRINT t.Contains 5 REM 0
PRINT t.Count      REM 2
t.Final

Ordered iteration

LOCAL t AS LNBPTREE
LOCAL k AS QUAD
t = t.New
t.Add 30
t.Add 10
t.Add 20
k = t.First
WHILE k <> 0
    PRINT k
    k = t.Next k
WEND
REM prints: 10, 20, 30
t.Final

ToArray and Clear

LOCAL t AS LNBPTREE
LOCAL a AS LNARR
t = t.New
t.Add 3
t.Add 1
t.Add 2
a = t.ToArray
REM a now holds 1, 2, 3 in order
t.Clear
PRINT t.Empty REM non-zero
t.Final
a.Final

Validation Evidence

Validation evidence: H-Lib container behavior is exercised by registered BASIC container validation programs and the embedded H-Lib object set used by the single-EXE validation gate.

See Also

Back to H-Lib container index | Native H-Lib overview | Back to command index

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


H-Lib Deque - PBXB64 Compiler Help

Startseite › H-Lib Deque

H-Lib Deque

A double-ended queue storing LONG values. Values can be added or removed from either end.

Kind: Container | Category: H-Lib Native Containers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Description

This H-Lib container is implemented in native C support code and exposed through PBXB64 BASIC container syntax. The examples below are focused usage patterns; keep handles valid, release each container with its Final method, and check counts or return values when a method can fail.

Syntax

LNDEQUE

Methods

Method | Signature | Returns | Description
New | d.New | LNDEQUE | Allocate a new empty deque.
Final | d.Final | none | Free the deque.
Validate | d.Validate | LONG | Non-zero if the handle is valid.
Clear | d.Clear | none | Remove all values.
Count | d.Count | LONG | Number of values in the deque.
PushFront | d.PushFront value | none | Insert a value at the front.
PushBack | d.PushBack value | none | Insert a value at the back.
PopFront | d.PopFront | QUAD | Remove and return the front value.
PopBack | d.PopBack | QUAD | Remove and return the back value.
PeekFront | d.PeekFront | QUAD | Return the front value without removing it.
PeekBack | d.PeekBack | QUAD | Return the back value without removing it.
Empty | d.Empty | LONG | Non-zero if the deque is empty.

Examples

Front and back operations

LOCAL d AS LNDEQUE
d = d.New
d.PushBack 10
d.PushFront 5
d.PushBack 15
PRINT d.PeekFront REM 5
PRINT d.PeekBack  REM 15
PRINT d.PopBack   REM 15
PRINT d.PopFront  REM 5
PRINT d.Count     REM 1
d.Final

Round-trip values

LOCAL d AS LNDEQUE
d = d.New
d.PushBack 1
d.PushBack 2
d.PushBack 3
WHILE d.Empty = 0
    PRINT d.PopFront
WEND
REM prints: 1, 2, 3
d.Final

Clear and Validate

LOCAL d AS LNDEQUE
d = d.New
d.PushFront 100
PRINT d.Validate REM non-zero
d.Clear
PRINT d.Empty    REM non-zero
PRINT d.Count    REM 0
d.Final

Validation Evidence

Validation evidence: H-Lib container behavior is exercised by registered BASIC container validation programs and the embedded H-Lib object set used by the single-EXE validation gate.

See Also

Back to H-Lib container index | Native H-Lib overview | Back to command index

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


H-Lib Graph - PBXB64 Compiler Help

Startseite › H-Lib Graph

H-Lib Graph

An undirected graph with LONG node IDs. Supports node/edge insertion, removal, adjacency queries, and neighbor enumeration.

Kind: Container | Category: H-Lib Native Containers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Description

This H-Lib container is implemented in native C support code and exposed through PBXB64 BASIC container syntax. The examples below are focused usage patterns; keep handles valid, release each container with its Final method, and check counts or return values when a method can fail.

Syntax

LNGRAPH

Methods

Method | Signature | Returns | Description
New | g.New | LNGRAPH | Allocate a new empty graph.
Final | g.Final | none | Free the graph.
Validate | g.Validate | LONG | Non-zero if the handle is valid.
Clear | g.Clear | none | Remove all nodes and edges.
Count | g.Count | LONG | Number of nodes in the graph.
Empty | g.Empty | LONG | Non-zero if the graph has no nodes.
AddNode | g.AddNode id | none | Add a node with the given ID.
AddEdge | g.AddEdge u, v | none | Add an undirected edge between two nodes.
RemoveNode | g.RemoveNode id | none | Remove a node and its incident edges.
RemoveEdge | g.RemoveEdge u, v | none | Remove an undirected edge.
HasEdge | g.HasEdge u, v | LONG | Non-zero if the edge exists.
Neighbors | g.Neighbors id | LNARR | Return a new LNARR of neighbor IDs.

Examples

Build a graph and query edges

LOCAL g AS LNGRAPH
g = g.New
g.AddNode 1
g.AddNode 2
g.AddNode 3
g.AddEdge 1, 2
g.AddEdge 2, 3
PRINT g.HasEdge(1, 2) REM non-zero
PRINT g.HasEdge(1, 3) REM 0
PRINT g.Count         REM 3
g.Final

Neighbors enumeration

LOCAL g AS LNGRAPH
LOCAL n AS LNARR
LOCAL i AS LONG
g = g.New
g.AddNode 1
g.AddNode 2
g.AddNode 3
g.AddEdge 1, 2
g.AddEdge 1, 3
n = g.Neighbors 1
FOR i = 0 TO n.Count - 1
    PRINT n(i)
NEXT i
REM prints 2 and 3
n.Final
g.Final

Remove node and edge

LOCAL g AS LNGRAPH
g = g.New
g.AddNode 1
g.AddNode 2
g.AddEdge 1, 2
PRINT g.HasEdge(1, 2) REM non-zero
g.RemoveEdge 1, 2
PRINT g.HasEdge(1, 2) REM 0
g.RemoveNode 1
PRINT g.Count         REM 1
g.Final

Validation Evidence

Validation evidence: H-Lib container behavior is exercised by registered BASIC container validation programs and the embedded H-Lib object set used by the single-EXE validation gate.

See Also

Back to H-Lib container index | Native H-Lib overview | Back to command index

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


H-Lib Heap (Priority Queue) - PBXB64 Compiler Help

Startseite › H-Lib Heap (Priority Queue)
Hilfe zum PBXB64-Compiler

H-Lib Heap / Priority Queue

A binary min-heap storing LONG values. The smallest value is always returned by Pop.

Kind: Container | Category: H-Lib Native Containers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Description

This H-Lib container is implemented in native C support code and exposed through PBXB64 BASIC container syntax. The examples below are focused usage patterns; keep handles valid, release each container with its Final method, and check counts or return values when a method can fail.

Syntax

LNHEAP

Methods

Method | Signature | Returns | Description
New | h.New | LNHEAP | Allocate a new empty heap.
Final | h.Final | none | Free the heap.
Validate | h.Validate | LONG | Non-zero if the handle is valid.
Clear | h.Clear | none | Remove all values.
Count | h.Count | LONG | Number of values in the heap.
Push | h.Push value | none | Insert a LONG value.
Pop | h.Pop | QUAD | Remove and return the smallest value.
Peek | h.Peek | QUAD | Return the smallest value without removing it.
Empty | h.Empty | LONG | Non-zero if the heap is empty.

Examples

Basic Push/Pop

LOCAL h AS LNHEAP
h = h.New
h.Push 30
h.Push 10
h.Push 20
PRINT h.Pop   REM 10
PRINT h.Count REM 2
h.Final

Peek and Empty

LOCAL h AS LNHEAP
h = h.New
PRINT h.Empty REM non-zero (1)
h.Push 7
PRINT h.Empty REM 0
PRINT h.Peek  REM 7
PRINT h.Count REM 1
h.Clear
PRINT h.Count REM 0
PRINT h.Validate REM non-zero
h.Final

Sort with a heap

LOCAL h AS LNHEAP
LOCAL n AS LONG
h = h.New
h.Push 9
h.Push 3
h.Push 6
h.Push 1
WHILE h.Empty = 0
    PRINT h.Pop
WEND
REM prints: 1, 3, 6, 9
h.Final

Validation Evidence

Validation evidence: H-Lib container behavior is exercised by registered BASIC container validation programs and the embedded H-Lib object set used by the single-EXE validation gate.

See Also

Back to H-Lib container index | Native H-Lib overview | Back to command index

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


H-Lib LRU Cache - PBXB64 Compiler Help

Startseite › H-Lib LRU Cache

H-Lib LRU Cache

A bounded cache with LONG keys and LONG values. Least-recently-used entries are evicted when the capacity is exceeded.

Kind: Container | Category: H-Lib Native Containers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Description

This H-Lib container is implemented in native C support code and exposed through PBXB64 BASIC container syntax. The examples below are focused usage patterns; keep handles valid, release each container with its Final method, and check counts or return values when a method can fail.

Syntax

LNLRU

Methods

Method | Signature | Returns | Description
New | c.New capacity | LNLRU | Allocate a cache with the given capacity.
Final | c.Final | none | Free the cache.
Validate | c.Validate | LONG | Non-zero if the handle is valid.
Clear | c.Clear | none | Remove all entries.
Count | c.Count | LONG | Number of entries currently stored.
Capacity | c.Capacity | LONG | Maximum number of entries allowed.
Put | c.Put key, value | none | Insert or update a key and make it most-recently used.
Get | c.Get key | QUAD | Retrieve a value and make the key most-recently used (0 if missing).
Contains | c.Contains key | LONG | Non-zero if the key is in the cache.
Remove | c.Remove key | none | Remove a key from the cache.
Empty | c.Empty | LONG | Non-zero if the cache is empty.

Examples

Eviction on overflow

LOCAL c AS LNLRU
c = c.New 2
c.Put 1, 10
c.Put 2, 20
c.Put 3, 30  REM evicts key 1
PRINT c.Contains 1 REM 0
PRINT c.Get 2      REM 20
PRINT c.Get 3      REM 30
PRINT c.Count      REM 2
c.Final

Get refreshes usage

LOCAL c AS LNLRU
c = c.New 2
c.Put 1, 10
c.Put 2, 20
PRINT c.Get 1      REM 10 (key 1 becomes MRU)
c.Put 3, 30         REM evicts key 2, not key 1
PRINT c.Contains 2 REM 0
PRINT c.Contains 1 REM non-zero
c.Final

Capacity and Clear

LOCAL c AS LNLRU
c = c.New 5
PRINT c.Capacity REM 5
PRINT c.Empty    REM non-zero
c.Put 7, 77
PRINT c.Empty    REM 0
c.Clear
PRINT c.Count    REM 0
c.Final

Validation Evidence

Validation evidence: H-Lib container behavior is exercised by registered BASIC container validation programs and the embedded H-Lib object set used by the single-EXE validation gate.

See Also

Back to H-Lib container index | Native H-Lib overview | Back to command index

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


H-Lib Multiset (Bag) - PBXB64 Compiler Help

Startseite › H-Lib Multiset (Bag)
Hilfe zum PBXB64-Compiler

H-Lib Multiset / Bag

A multiset stores LONG keys together with their multiplicities (occurrence counts).

Kind: Container | Category: H-Lib Native Containers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Description

This H-Lib container is implemented in native C support code and exposed through PBXB64 BASIC container syntax. The examples below are focused usage patterns; keep handles valid, release each container with its Final method, and check counts or return values when a method can fail.

Syntax

LNMULTISET

Methods

Method | Signature | Returns | Description
New | m.New | LNMULTISET | Allocate a new empty multiset.
Final | m.Final | none | Free the multiset.
Validate | m.Validate | LONG | Non-zero if the handle is valid.
Clear | m.Clear | none | Remove all keys.
Count | m.Count | LONG | Number of distinct keys.
Add | m.Add key | none | Add one occurrence of a key.
Remove | m.Remove key | none | Remove one occurrence of a key.
RemoveAll | m.RemoveAll key | none | Remove a key entirely.
Contains | m.Contains key | LONG | Non-zero if the key has any occurrence.
Multiplicity | m.Multiplicity key | QUAD | Return the number of occurrences of a key.
First | m.First | QUAD | Return the first distinct key (0 if empty).
Next | m.Next key | QUAD | Return the next distinct key (0 if none).
Empty | m.Empty | LONG | Non-zero if the multiset is empty.
ToArray | m.ToArray | LNARR | Return a new LNARR of distinct keys.

Examples

Multiplicity and distinct count

LOCAL m AS LNMULTISET
m = m.New
m.Add 5
m.Add 5
m.Add 7
PRINT m.Multiplicity 5 REM 2
PRINT m.Multiplicity 7 REM 1
PRINT m.Multiplicity 9 REM 0
PRINT m.Count          REM 2
m.Final

Remove vs RemoveAll

LOCAL m AS LNMULTISET
m = m.New
m.Add 3
m.Add 3
m.Add 3
m.Remove 3
PRINT m.Multiplicity 3 REM 2
m.RemoveAll 3
PRINT m.Multiplicity 3 REM 0
PRINT m.Contains 3     REM 0
m.Final

Iteration with First/Next

LOCAL m AS LNMULTISET
LOCAL k AS QUAD
m = m.New
m.Add 2
m.Add 2
m.Add 1
k = m.First
WHILE k <> 0
    PRINT k; " x"; m.Multiplicity k
    k = m.Next k
WEND
REM prints: 1 x1, 2 x2
m.Final

Validation Evidence

Validation evidence: H-Lib container behavior is exercised by registered BASIC container validation programs and the embedded H-Lib object set used by the single-EXE validation gate.

See Also

Back to H-Lib container index | Native H-Lib overview | Back to command index

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


H-Lib Quadtree - PBXB64 Compiler Help

Startseite › H-Lib Quadtree

H-Lib Quadtree

A spatial quadtree indexing axis-aligned bounding boxes identified by LONG IDs. Supports insertion, removal, and rectangle-intersection queries.

Kind: Container | Category: H-Lib Native Containers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Description

This H-Lib container is implemented in native C support code and exposed through PBXB64 BASIC container syntax. The examples below are focused usage patterns; keep handles valid, release each container with its Final method, and check counts or return values when a method can fail.

Syntax

LNQUAD

Methods

Method | Signature | Returns | Description
New | q.New | LNQUAD | Allocate a new empty quadtree.
Final | q.Final | none | Free the quadtree.
Validate | q.Validate | LONG | Non-zero if the handle is valid.
Clear | q.Clear | none | Remove all entries.
Count | q.Count | LONG | Number of stored entries.
Empty | q.Empty | LONG | Non-zero if the quadtree is empty.
Insert | q.Insert id, x, y, w, h | none | Insert or update a bounding box for id.
Remove | q.Remove id | none | Remove the entry with the given id.
Query | q.Query x, y, w, h | LNARR | Return a new LNARR of IDs whose boxes intersect the query rectangle.

Examples

Spatial query

LOCAL q AS LNQUAD
LOCAL a AS LNARR
q = q.New
q.Insert 1, 0, 0, 10, 10
q.Insert 2, 20, 20, 5, 5
q.Insert 3, 5, 5, 10, 10
a = q.Query 0, 0, 15, 15
PRINT a.Count REM 2 (ids 1 and 3)
q.Final
a.Final

Insert, Remove, Count

LOCAL q AS LNQUAD
q = q.New
q.Insert 1, 0, 0, 10, 10
PRINT q.Count REM 1
q.Remove 1
PRINT q.Count REM 0
PRINT q.Empty REM non-zero
q.Final

Update existing id

LOCAL q AS LNQUAD
q = q.New
q.Insert 1, 0, 0, 10, 10
q.Insert 1, 100, 100, 10, 10  REM update same id
PRINT q.Count REM 1
q.Final

Validation Evidence

Validation evidence: H-Lib container behavior is exercised by registered BASIC container validation programs and the embedded H-Lib object set used by the single-EXE validation gate.

See Also

Back to H-Lib container index | Native H-Lib overview | Back to command index

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


H-Lib Ring (Circular Buffer) - PBXB64 Compiler Help

Startseite › H-Lib Ring (Circular Buffer)
Hilfe zum PBXB64-Compiler

H-Lib Ring / Circular Buffer

A fixed-capacity FIFO circular buffer storing LONG values. Push writes at the tail; Pop/Peek read at the head.

Kind: Container | Category: H-Lib Native Containers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Description

This H-Lib container is implemented in native C support code and exposed through PBXB64 BASIC container syntax. The examples below are focused usage patterns; keep handles valid, release each container with its Final method, and check counts or return values when a method can fail.

Syntax

LNRING

Methods

Method | Signature | Returns | Description
New | r.New capacity | LNRING | Allocate a ring with the given capacity.
Final | r.Final | none | Free the ring.
Validate | r.Validate | LONG | Non-zero if the handle is valid.
Clear | r.Clear | none | Empty the ring.
Count | r.Count | LONG | Number of values currently stored.
Capacity | r.Capacity | LONG | Maximum number of values allowed.
Push | r.Push value | none | Append a value at the tail (no-op if full).
Pop | r.Pop | QUAD | Remove and return the oldest value.
Peek | r.Peek | QUAD | Return the oldest value without removing it.
Full | r.Full | LONG | Non-zero if the ring is full.
Empty | r.Empty | LONG | Non-zero if the ring is empty.

Examples

Capacity and Full flag

LOCAL r AS LNRING
r = r.New 2
PRINT r.Capacity REM 2
r.Push 10
r.Push 20
PRINT r.Full REM non-zero
PRINT r.Pop  REM 10
PRINT r.Full REM 0
PRINT r.Count REM 1
r.Final

Overwrite behavior

LOCAL r AS LNRING
r = r.New 2
r.Push 1
r.Push 2
r.Push 3   REM capacity is 2, so 3 is ignored
PRINT r.Pop REM 1
PRINT r.Pop REM 2
PRINT r.Empty REM non-zero
r.Final

Peek and Clear

LOCAL r AS LNRING
r = r.New 3
r.Push 7
PRINT r.Peek REM 7
PRINT r.Count REM 1
r.Clear
PRINT r.Count REM 0
r.Final

Validation Evidence

Validation evidence: H-Lib container behavior is exercised by registered BASIC container validation programs and the embedded H-Lib object set used by the single-EXE validation gate.

See Also

Back to H-Lib container index | Native H-Lib overview | Back to command index

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


H-Lib Safe Concurrent Container - PBXB64 Compiler Help

Startseite › H-Lib Safe Concurrent Container

H-Lib Safe Concurrent Container

A thread-safe wrapper over array-like LONG storage. All operations are synchronised with a critical section so the container can be shared between PB threads.

Kind: Container | Category: H-Lib Native Containers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Description

This H-Lib container is implemented in native C support code and exposed through PBXB64 BASIC container syntax. The examples below are focused usage patterns; keep handles valid, release each container with its Final method, and check counts or return values when a method can fail.

Syntax

LNSAFE

Methods

Method | Signature | Returns | Description
New | s.New | LNSAFE | Allocate a new safe container.
Final | s.Final | none | Free the container.
Validate | s.Validate | LONG | Non-zero if the handle is valid.
Clear | s.Clear | none | Remove all values.
Count | s.Count | LONG | Number of values stored.
Empty | s.Empty | LONG | Non-zero if the container is empty.
Lock | s.Lock | none | Acquire the critical section.
Unlock | s.Unlock | none | Release the critical section.
Push | s.Push value | none | Append a value (locks automatically).
Pop | s.Pop | QUAD | Remove and return the top value.
Peek | s.Peek | QUAD | Return the top value without removing it.

Examples

Automatic locking on Push/Pop

LOCAL s AS LNSAFE
s = s.New
s.Push 42
s.Push 17
PRINT s.Peek REM 17
PRINT s.Pop  REM 17
PRINT s.Count REM 1
s.Final

Manual Lock/Unlock

LOCAL s AS LNSAFE
s = s.New
s.Lock
s.Push 1
s.Push 2
PRINT s.Count
s.Unlock
s.Final

Clear and Validate

LOCAL s AS LNSAFE
s = s.New
s.Push 9
PRINT s.Validate REM non-zero
s.Clear
PRINT s.Empty    REM non-zero
s.Final

Validation Evidence

Validation evidence: H-Lib container behavior is exercised by registered BASIC container validation programs and the embedded H-Lib object set used by the single-EXE validation gate.

See Also

Back to H-Lib container index | Native H-Lib overview | Back to command index

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


H-Lib Set - PBXB64 Compiler Help

Startseite › H-Lib Set

H-Lib Set

A sorted set of unique LONG values backed by an AVL tree.

Kind: Container | Category: H-Lib Native Containers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Description

This H-Lib container is implemented in native C support code and exposed through PBXB64 BASIC container syntax. The examples below are focused usage patterns; keep handles valid, release each container with its Final method, and check counts or return values when a method can fail.

Syntax

LNSET

Methods

Method | Signature | Returns | Description
New | s.New | LNSET | Allocate a new empty set.
Final | s.Final | none | Free the set.
Validate | s.Validate | LONG | Non-zero if the handle is valid.
Clear | s.Clear | none | Remove all values.
Count | s.Count | LONG | Number of values in the set.
Add | s.Add value | none | Insert a value if not present.
Remove | s.Remove value | none | Remove a value.
Contains | s.Contains value | LONG | Non-zero if the value is present.
First | s.First | QUAD | Return the smallest value (0 if empty).
Next | s.Next value | QUAD | Return the next larger value (0 if none).
Empty | s.Empty | LONG | Non-zero if the set is empty.
ToArray | s.ToArray | LNARR | Return a new LNARR containing all values sorted.

Examples

Add, Contains, Remove

LOCAL s AS LNSET
s = s.New
s.Add 3
s.Add 1
s.Add 2
PRINT s.Contains 2 REM non-zero
PRINT s.Contains 5 REM 0
PRINT s.First      REM 1
s.Remove 2
PRINT s.Contains 2 REM 0
PRINT s.Count      REM 2
s.Final

Iteration with First/Next

LOCAL s AS LNSET
LOCAL k AS QUAD
s = s.New
s.Add 5
s.Add 1
s.Add 3
k = s.First
WHILE k <> 0
    PRINT k
    k = s.Next k
WEND
REM prints: 1, 3, 5
s.Final

Clear and Empty

LOCAL s AS LNSET
s = s.New
PRINT s.Empty REM non-zero
s.Add 10
PRINT s.Empty REM 0
s.Clear
PRINT s.Count REM 0
PRINT s.Validate REM non-zero
s.Final

Validation Evidence

Validation evidence: H-Lib container behavior is exercised by registered BASIC container validation programs and the embedded H-Lib object set used by the single-EXE validation gate.

See Also

Back to H-Lib container index | Native H-Lib overview | Back to command index

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


H-Lib SkipList - PBXB64 Compiler Help

Startseite › H-Lib SkipList

H-Lib SkipList

A probabilistic skip list storing unique sorted LONG keys with expected O(log n) add, remove, and contains operations.

Kind: Container | Category: H-Lib Native Containers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Description

This H-Lib container is implemented in native C support code and exposed through PBXB64 BASIC container syntax. The examples below are focused usage patterns; keep handles valid, release each container with its Final method, and check counts or return values when a method can fail.

Syntax

LNSKIPLIST

Methods

Method | Signature | Returns | Description
New | s.New | LNSKIPLIST | Allocate a new empty skiplist.
Final | s.Final | none | Free the skiplist.
Validate | s.Validate | LONG | Non-zero if the handle is valid.
Clear | s.Clear | none | Remove all keys.
Count | s.Count | LONG | Number of keys.
Add | s.Add key | none | Insert a key.
Remove | s.Remove key | none | Remove a key.
Contains | s.Contains key | LONG | Non-zero if the key is present.
First | s.First | QUAD | Return the smallest key (0 if empty).
Next | s.Next key | QUAD | Return the next larger key (0 if none).
Empty | s.Empty | LONG | Non-zero if the skiplist is empty.

Examples

Add and sorted order

LOCAL s AS LNSKIPLIST
LOCAL k AS QUAD
s = s.New
s.Add 5
s.Add 1
s.Add 3
k = s.First
WHILE k <> 0
    PRINT k
    k = s.Next k
WEND
REM prints: 1, 3, 5
s.Final

Contains and Remove

LOCAL s AS LNSKIPLIST
s = s.New
s.Add 10
s.Add 20
PRINT s.Contains 10 REM non-zero
s.Remove 10
PRINT s.Contains 10 REM 0
PRINT s.Count       REM 1
s.Final

Empty and Validate

LOCAL s AS LNSKIPLIST
s = s.New
PRINT s.Empty     REM non-zero
s.Add 7
PRINT s.Validate  REM non-zero
s.Clear
PRINT s.Count     REM 0
s.Final

Validation Evidence

Validation evidence: H-Lib container behavior is exercised by registered BASIC container validation programs and the embedded H-Lib object set used by the single-EXE validation gate.

See Also

Back to H-Lib container index | Native H-Lib overview | Back to command index

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


H-Lib Union-Find (Disjoint Set) - PBXB64 Compiler Help

Startseite › H-Lib Union-Find (Disjoint Set)
Hilfe zum PBXB64-Compiler

H-Lib Union-Find / Disjoint Set

A union-find (disjoint-set) structure over LONG elements with near-constant-time union and find operations.

Kind: Container | Category: H-Lib Native Containers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Description

This H-Lib container is implemented in native C support code and exposed through PBXB64 BASIC container syntax. The examples below are focused usage patterns; keep handles valid, release each container with its Final method, and check counts or return values when a method can fail.

Syntax

LNUNIONFIND

Methods

Method | Signature | Returns | Description
New | uf.New | LNUNIONFIND | Allocate a new empty union-find.
Final | uf.Final | none | Free the union-find.
Validate | uf.Validate | LONG | Non-zero if the handle is valid.
Clear | uf.Clear | none | Remove all elements.
Count | uf.Count | LONG | Number of elements.
MakeSet | uf.MakeSet x | none | Add a new singleton set for x.
Find | uf.Find x | QUAD | Return the representative of x (0 if unknown).
Union | uf.Union x, y | LONG | Non-zero if the union changed anything.
SameSet | uf.SameSet x, y | LONG | Non-zero if x and y are in the same set.
Empty | uf.Empty | LONG | Non-zero if the union-find is empty.
Components | uf.Components | LONG | Number of disjoint sets.

Examples

Basic union and query

LOCAL uf AS LNUNIONFIND
uf = uf.New
uf.MakeSet 1
uf.MakeSet 2
uf.MakeSet 3
PRINT uf.SameSet(1, 2) REM 0
uf.Union 1, 2
PRINT uf.SameSet(1, 2) REM non-zero
PRINT uf.SameSet(1, 3) REM 0
PRINT uf.Components    REM 2
uf.Final

Transitive unions

LOCAL uf AS LNUNIONFIND
uf = uf.New
uf.MakeSet 1
uf.MakeSet 2
uf.MakeSet 3
uf.Union 1, 2
uf.Union 2, 3
PRINT uf.SameSet(1, 3) REM non-zero
PRINT uf.Find 1        REM representative
uf.Final

Count and Clear

LOCAL uf AS LNUNIONFIND
uf = uf.New
uf.MakeSet 10
uf.MakeSet 20
PRINT uf.Count    REM 2
PRINT uf.Empty    REM 0
uf.Clear
PRINT uf.Empty    REM non-zero
PRINT uf.Validate REM non-zero
uf.Final

Validation Evidence

Validation evidence: H-Lib container behavior is exercised by registered BASIC container validation programs and the embedded H-Lib object set used by the single-EXE validation gate.

See Also

Back to H-Lib container index | Native H-Lib overview | Back to command index

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Ein einfaches Kommunikationsprogramm - PBXB64 Compiler Help

Startseite› Funktionen › Ein einfaches Kommunikationsprogramm
Hilfe zum PBXB64-Compiler

Ein einfaches Kommunikationsprogramm

Nehmen wir an, Sie möchten ein einfaches Kommunikationsprogramm verwenden, um auf das Schwarze Brett eines lokalen Computers zuzugreifen. Sie kennen die Parameter der Karte: Sie hat 14400 Baud, 8 Datenbits, ein Stoppbit und kein p

Typ:Schlüsselwort |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Sie möchten Daten auf Ihrem Bildschirm anzeigen, Daten eingeben und an das Schwarze Brett senden können. Sie beabsichtigen, ein an COM1 angeschlossenes Modem zu verwenden. Das folgende Kurzprogramm dient als Ausgangspunkt und nutzt die neuen DDT-Funktionen von PowerBASIC zur Erstellung der Benutzeroberfläche:

'----------------------------------------------------------

' Beispiel für serielle Kommunikation für PowerBASIC für Windows

Beschreibung

Ein einfaches Kommunikationsprogramm gehoert zur seriellen Kommunikationsfamilie. Die aktuelle PBXB64-Oberflaeche prueft das Oeffnen, Senden, Lesen, Zeilenlesen, Reset und Schliessen eines Kommunikationshandles; reale Hardware ist nur fuer den erfolgreichen Pfad noetig.

Syntax

COMM OPEN "COMn" AS #hComm [CHR = ANSI|WIDE]
COMM SET #hComm, ...
COMM PRINT #hComm, string$
COMM LINE #hComm, string$
COMM LINE INPUT #hComm, text$
COMM RESET #hComm, FLOW
COMM CLOSE #hComm

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL h AS LONG
    COMM OPEN "PBXB64_NO_SUCH_COMM_PORT" AS #h
    IF h <> 0 THEN
        COMM CLOSE #h
        FUNCTION = 1
    END IF
END FUNCTION

Validierungsbeleg

Validierungsbeleg: tests/pb/test_comm_print_line_input.pb, tests/pb/test_comm_reset.pb, examples/basic/test_comm_open_missing.pb, und examples/basic/test_comm_flow_missing.pb belegen den aktuellen Handle- und Fehlerpfad. Der Beispielpfad ist absichtlich portable und faellt geschlossen, wenn kein gueltiger Port verfuegbar ist.

Laufzeitvoraussetzungen

Serielle Beispiele brauchen ein echtes COM-Geraet oder einen dokumentierten Loopback/Testadapter. Wenn ein realer Port verfuegbar ist, muessen COMM SET-Parameter vor dem Datentransfer gesetzt und das Handle danach mit COMM CLOSE freigegeben werden.

Siehe auch

  • COMM OPEN
  • COMM PRINT
  • COMM RESET
  • COMM LINE
  • COMM RECV
  • COMM SEND
  • COMM SET
  • COMM TIMEOUT
  • COMM CLOSE


ACCEL ATTACH – PBXB64-Compiler-Hilfe

Startseite› Funktionen › ACCEL ATTACH

ACCEL ATTACH

Hängen Sie eine Tabelle mit Tastaturbeschleunigern an a an

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ACCEL ATTACH hDlg , AccelTbl() TO hAccelHandle

Beschreibung

Mit ACCEL ATTACH können Sie jedem DDT-Dialogfeld in Ihrer Anwendung eine Tabelle mit Tastendefinitionen anhängen.

Der Tastaturbeschleuniger selbst ist eine bestimmte Tastenkombination, die dazu führt, dass eine %WM_COMMAND- oder %WM_SYSCOMMAND-Nachricht in die Nachrichtenwarteschlange der Anwendung gestellt wird.

Tastaturbeschleuniger sind den Befehlsbeschleunigern sehr ähnlich und ermöglichen oft die gleichen Aktionsauswahlmöglichkeiten wie Menüs. Da Tastaturbeschleuniger direkt verwendet werden können, entfällt die Notwendigkeit, durch ein Menü zu navigieren, um eine bestimmte Aktion auszuführen.

In der Regel informieren Anwendungsmenüelemente Benutzer über verfügbare Tastaturbeschleuniger, sodass erfahrene Benutzer effizienter arbeiten können, ohne die eigentlichen Menüs zu verwenden, aber bei Bedarf trotzdem das Menü verwenden können. Das folgende Bild zeigt ein Menü mit Befehlsbeschleunigern und Tastaturbeschleunigern für Menüelemente (die Befehlsbeschleuniger sind unterstrichen):

Unter Windows XP und Windows 2000 müssen Sie möglicherweise die ALT-Taste drücken, bevor die Befehlsbeschleuniger sichtbar werden. Sie können in den Windows-Anzeigeeinstellungen festlegen, ob Befehlsbeschleuniger bei Verwendung der ALT-Taste oder ständig sichtbar sind.

Damit eine Befehlsbeschleunigung funktioniert, muss das jeweilige Menüelement sichtbar und aktiviert sein. Umgekehrt können Tastaturbeschleuniger verwendet werden, ohne dass das Menü geöffnet ist. Im obigen Beispiel führt die Tastenkombination STRG +

AccelTbl()

Um ACCEL ATTACH nutzen zu können, müssen Sie zunächst das Array AccelTbl() von ACCELAPI User-Defined Types (UDTs) erstellen. Diese ACCELAPI-Struktur ist eine 6-Byte-Struktur mit der folgenden Definition:

Geben Sie das Wort ACCELAPI ein

FVIRT AS BYTE ' Flags: Eines oder mehrere von %FVIRTKEY, %FSHIFT, %FALT und %FCONTROL

KEY AS WORD ' Schnelltaste: ASCII-Code oder virtueller Tastencode {%FVIRTKEY}

CMD AS WORD ' Beschleuniger-ID-Code wird in CB.CTL {LO(WORD, WPARAM)} übergeben

END-TYP

Sie müssen das Array der ACCELAPI-Typen selbst erstellen und es dann durch Ausführen einer ACCEL ATTACH-Anweisung an einen Dialog anhängen. Das Array darf keine leeren Elemente enthalten, daher muss die Größe genau sein.

.FVIRT

Die .FVIRT-Flags können wie folgt mit dem OR-Operator kombiniert werden, um die Aktionen der einzelnen Flags zu kombinieren:

Die ALT-Taste muss zusammen mit der Gaspedaltaste gedrückt werden.

%FCONTROL

Die STRG-Taste muss zusammen mit der Beschleunigungstaste gedrückt werden.

%FSHIFT

Die UMSCHALTTASTE muss zusammen mit der Gaspedaltaste gedrückt werden.

%FVIRTKEY

Das .KEY-Mitglied gibt einen virtuellen Schlüsselcode an. Wenn dieses Flag nicht angegeben ist, wird davon ausgegangen, dass das Schlüsselmitglied einen ASCII-Zeichencode angibt. %FVIRTKEY ermöglicht Definitionen von Tastenkombinationen ohne Berücksichtigung der Groß-/Kleinschreibung – der Capslock-Status wird ignoriert. Beispielsweise erzeugen ALT+A und ALT+a (wie durch die Feststelltaste bestimmt) dasselbe Zugriffstastenereignis. Wenn %FVIRTKEY nicht verwendet wird, würde die Tastenkombination ALT+A nicht ausgelöst, wenn die Feststelltaste inaktiv wäre.

Wenn das %FVIRTKEY-Flag im .FVIRT-Mitglied angegeben ist, enthält das .KEY-Feld den virtuellen Tastencode für die Zugriffstaste. Virtuelle Schlüsselgleichungen werden in der Datei WIN32API.INC definiert, beginnend mit dem Präfix %VK_.

Wenn %FVIRTKEY nicht angegeben ist, ist der Zugriffstastencode im .KEY-Mitglied der ASCII-Code der Zugriffstaste. In diesem Fall wird bei alphanumerischen Tastenanschlägen die Groß-/Kleinschreibung beachtet und der Status der Feststelltaste wird wichtig. Wenn beispielsweise ein Beschleuniger für ALT+A definiert wäre, würde dieser nur aktiviert, wenn die Feststelltaste aktiviert ist. Wenn umgekehrt ein Beschleuniger für ALT+a definiert wäre, wäre dieser nur aktiviert. Die Feststelltaste war ausgeschaltet.

Das .CMD-Mitglied sollte den benutzerdefinierten numerischen ID-Code des Beschleunigers enthalten. Wenn ein Beschleunigertastendruck erfolgt, wird eine WM_COMMAND-Nachricht an die Callback-Funktion des Dialogs gesendet, wobei die Beschleuniger-ID von der CB.CTL-Funktion zurückgegeben wird.

Es ist üblich, die ID eines Steuerelements zu verwenden, das durch einen Beschleuniger aktiviert werden soll. Für Beschleunigerbenachrichtigungscodes, die an die Rückruffunktion gesendet werden, ist CB.CTLMSG auf 1 gesetzt (im Gegensatz zu Meldungen zu Schaltflächenklickereignissen, bei denen CB.CTLMSG = %BN_CLICKED).

Das Handle des Dialogfelds, an das die Beschleunigertabelle angehängt werden soll.

AccelHandle

Doppelwort- oder Long-Integer-Variable, in der das Handle der angehängten Beschleunigertabelle gespeichert wird, oder Null, wenn der Anhängevorgang nicht erfolgreich war.

Einschränkungen

Wenn eine vorherige Tabelle an den Zieldialog angehängt wurde, wird die Tabelle automatisch zerstört, wenn an ihrer Stelle die neue Tabelle angehängt wird. Auch die Beschleunigertabelle wird beim Schließen des Dialogs automatisch zerstört.

Sie können die aktuelle Beschleunigertabelle zerstören, indem Sie ACCEL ATTACH mit einem Array ausführen, das nicht dimensioniert ist. Es gibt jedoch kaum oder gar keinen Grund, diese Aktion jemals auszuführen.

Beschleunigertabellen können nur dann ordnungsgemäß ausgeführt werden, wenn sie in demselben Modul erstellt werden, das auch den Dialog erstellt, an den jede Tabelle angehängt ist.

Siehe auch

  • DIALOG NEU
  • MENÜ STRING HINZUFÜGEN
  • MENÜ ANHANG

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Auf PowerBASIC-Variablen nach Namen zugreifen – PBXB64-Compiler-Hilfe

Startseite› Funktionen › Zugriff auf PowerBASIC-Variablen über den Namen
Hilfe zum PBXB64-Compiler

Zugriff auf PowerBASIC-Variablen über den Namen

Die meisten Variablen in einem PowerBASIC-Modul sind für Inline-Assembler-Code sichtbar, der mit der ASM-Anweisung erstellt wurde. Sie können LOCAL-, STATIC- und GLOBAL-Variablen namentlich referenzieren, indem Sie einfach den Namen als verwenden

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

SUB DoStuff (BYVAL c&)

a% = 7 ' Lokale Variable a%

Beschreibung

Inline-Assembler kann auf PowerBASIC-Speicher per Name zugreifen, einschliesslich Globals, BYREF-Parametern und UDT-Feldern. Die verifizierte Oberflaeche ist die geschweifte Namensbruecke innerhalb von #ASM-Bloecken.

Syntax

#ASM
    mov eax, DWORD PTR {g}
    mov DWORD PTR {g}, eax
#ENDASM

Beispiel

Beispieldatei: examples/basic/test_inline_asm_global.pb

Validierungsbeleg: examples/basic/test_inline_asm_byref.pb; examples/basic/test_inline_asm_struct_field.pb

#COMPILE EXE
#DIM ALL

GLOBAL g AS LONG

FUNCTION PBMAIN() AS LONG
    g = 10

    #ASM
        mov eax, DWORD PTR {g}
        add eax, 32
        mov DWORD PTR {g}, eax
    #ENDASM

    IF g <> 42 THEN FUNCTION = 1
END FUNCTION

Validierungsbeleg

Validierungsbeleg: examples/basic/test_inline_asm_global.pb, examples/basic/test_inline_asm_byref.pb und examples/basic/test_inline_asm_struct_field.pb belegen die Global-, BYREF- und UDT-Feldpfade.

Nutzungshinweise

Verwenden Sie die im Beispiel gezeigte geschweifte Form, wenn Inline-Assembler eine BASIC-Variable direkt lesen oder schreiben soll. Die umgebende BASIC-Deklaration bestimmt weiterhin Speicher, Lebensdauer und Typbreite.

Grenzen

Diese Seite behandelt die namensbasierte Inline-Assembler-Bruecke und nicht Standalone-Assembler-Dateien oder die allgemeine Ausdrucksreduzierung. Zu den derzeit unterstuetzten Formen gehoeren Globals, BYREF-Parameter und UDT-Mitglieder, die der Compiler auf konkreten Speicher abbilden kann.

Siehe auch

  • #ASM
  • UDT-Felder

Siehe auch

  • #ASM
  • UDT-Felder

Siehe auch

  • #ASM
  • UDT-Felder

Siehe auch

  • #ASM
  • UDT-Felder

Siehe auch

  • #ASM
  • UDT-Felder

Siehe auch

  • #ASM
  • UDT-Felder

Siehe auch

  • #ASM
  • UDT-Felder

Siehe auch

  • #ASM
  • UDT-Felder

Siehe auch

  • #ASM
  • UDT-Felder

Siehe auch

  • #ASM
  • UDT-Felder

Siehe auch

  • #ASM
  • UDT-Felder

Siehe auch

  • #ASM
  • UDT-Felder

Siehe auch

  • #ASM
  • UDT-Felder

Siehe auch

  • #ASM
  • UDT-Felder

Siehe auch

  • Befehlsindex
  • BASIC-Frontend


Zugreifen auf die Felder eines benutzerdefinierten Typs – PBXB64-Compiler-Hilfe

Startseite› Funktionen › Zugriff auf die Felder eines benutzerdefinierten Typs
Hilfe zum PBXB64-Compiler

Zugreifen auf die Felder eines benutzerdefinierten Typs

Um mit den einzelnen Feldern innerhalb einer Datensatzvariablen zu arbeiten, trennen Sie den Feldnamen durch einen Punkt vom Variablennamen. Hier sind einige Beispiele für die Verwendung der Student-Variablen in der obigen DIM-Anweisung:

Typ:Struktur |Kategorie:Typen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Last$ = Student.LastName

Message$ = „ID-Nummer ist: „ + STR$(Student.IdNum)

Student.FirstName = „Bob“

Student.LastName = "Smith"

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


ACODE$ – PBXB64-Compiler-Hilfe

Startseite› Funktionen › ACODE$

ACODE$

Übersetzt

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

a$ = ACODE$( UnicodeStrExpression [, CodePage& ])

Beschreibung

Diese Version von PowerBASIC führt alle Konvertierungen zwischen ANSI-Strings und UNICODE-Strings automatisch durch. Zum Beispiel:

MyAnsiString$ = MyWideString$$

In diesem Fall werden die Breitzeichen beim Speichern in MyAnsiString$ transparent in Byte-Zeichen umgewandelt. Sie sollten hier keine ACODE$-Funktion einfügen. Die einfache Tatsache, dass die Variablen unterschiedlichen Typs sind (ANSI/WIDE), führt dazu, dass der Compiler alle Konvertierungen für Sie durchführt, wann immer sie benötigt werden.

Natürlich war diese automatische Konvertierung in früheren Versionen des Compilers nicht verfügbar. In der Vergangenheit wurden keine WIDE-UNICODE-Variablen angeboten, daher war es notwendig, breite Zeichen in Standard-Byte-Strings zu erzwingen, wenn UNICODE benötigt wurde. Die Funktionen ACODE$ und UCODE$ werden ausschließlich zu diesem Zweck verwendet: zur Unterstützung älterer Programme, die Zeichenfolgen auf diese Weise berechnet haben.

Neue PowerBASIC-Programme und Updates Ihrer älteren PowerBASIC-Programme sollten die neuen WIDE UNICODE-Variablen verwenden, die jetzt verfügbar sind.

ACODE$ geht davon aus, dass die UnicodeStrExpression WIDE UNICODE-Zeichen enthält, die in einer ANSI-Bytezeichenfolge gespeichert sind. Es wandelt sie in ANSI-Byte-Zeichen um und gibt sie als ANSI-String zurück. Um eine ANSI-Bytezeichenfolge in eine UNICODE-Bytezeichenfolge umzuwandeln, verwenden Sie die Funktion UCODE$.

Wenn der optionale Parameter CodePage& vorhanden ist, stellt er die Codepage dar, die für den Konvertierungsprozess verwendet werden soll. Wenn nicht angegeben, wird die Standardcodepage für das Gebietsschema des ausführenden Computers verwendet.

Unicode-Zeichenfolgen erfordern zwei Bytes zur Darstellung eines Unicode-Zeichens, während ANSI-Zeichenfolgen (das native PowerBASIC-Zeichenfolgenformat) ein Byte zur Darstellung eines Zeichens verwenden. Daher gibt ACODE$ eine Zeichenfolge zurück, die halb so viele Bytes wie die Unicode-Zeichenfolge hat, aber die gleiche Anzahl an Zeichen darstellt.

Siehe auch

  • UCODE$
  • UCODEPAGE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Add-on-Bibliotheken, Dienstprogramme und Tools “ PBXB64-Compiler-Hilfe

Startseiteâ€º Funktionen â€º Add-on-Bibliotheken, Dienstprogramme und Tools
Hilfe zum PBXB64-Compiler

Bibliotheken, Dienstprogramme und Tools

PBXB64 wird mit einer eigenständigen Laufzeit, einer nativen Containerbibliothek und einer Reihe von Build-/Bereitstellungshilfen geliefert. Alles, was zum Erstellen einer nativen ausführbaren Windows x64-Datei erforderlich ist, ist in der Compiler-Distribution enthalten.

Native Laufzeit

  • c_runtime_user.c“ Vom Benutzer verknüpfbare C-Helfer für Min/Max, RNG-Seeding, Konsoleneingabe, String-Padding und andere Laufzeitdienste.
  • Eingebaute Laufzeitunterstuetzung - gebuendelte Hilfslogik fuer Mathematik, Strings, Datei-E/A, Konsole und Prozessprioritaet.
  • Dynamisches Laden von Win32“ DISPLAY-, MENU-, FONT-, ACCEL- und Registry-Helfer werden geladencomdlg32.dll, shell32.dll, user32.dll, Undgdi32.dllzur Laufzeit.

Native H-Lib-Containerbibliothek

23 Containerfamilien sind in C implementiert und als festplattengeladene COFF-Objekte verknüpft. Sie sind von BASIC über die Method-Dispatch-Syntax und von C über zugänglichcore/include/c17/pbxb64/hlib.h.

  • Ãœbersicht über native H-Lib
  • Containerindex
  • Methodenreferenz
  • C-API-Referenz

Build- und Bereitstellungstools

  • core/Makefile.mingw“ Primäres MinGW-w64-Build-Rezept.
  • core/build_mingw64.bat“ Windows-Batch-Build-Wrapper.
  • tests/validate.py— Python-Validierungsgeschirr (parallele Spuren, Leckprüfung, Berichterstellung).
  • Release/tools/stage_website_files.ps1“ Staging-Release-Dateien für die Website-Bereitstellung.
  • Release/tools/upload_website.ps1— Laden Sie Release-Dateien über die SindByte MCP FTP-Bridge hoch.

Beispiele und Testsuiten

  • Beispielprogramme— lauffähige Beispiele für jedes Frontend.
  • examples/basic/, examples/b64/, examples/c/, examples/asm/— sprachspezifische Beispielverzeichnisse.
  • tests_unified/“ einheitliche Regressionsspuren für Assembly-, PB-, B64- und C-Frontends.
Notiz:PBXB64 benötigt keine externen DLLs für normale Konsolen- oder GUI-Programme. Die Compiler-Binärdatei selbst enthält den Parser, IR, Optimierer, x64-Backend, Linker und Laufzeitsymbolemission.

Kind: Reference topic | Category: Libraries / Utilities

PBXB64 Status: DOCUMENTED

Description

Overview page for bundled add-on libraries, utilities, and tool support. Treat each linked library page as the authority for exact compiler support and tested examples.

Syntax

See the linked library or utility page for command-specific syntax.

Validation Evidence

Validation evidence: Overview page; linked child pages carry concrete source and validation evidence.

Example

' Open the linked utility page, compile its listed sample, and check the documented exit code.

See Also

  • index.html
  • examples.html

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Hinzufügen von Steuerelementen zum Dialogfeld – Hilfe zum PBXB64-Compiler

Startseite› Funktionen › Steuerelemente zum Dialog hinzufügen
Hilfe zum PBXB64-Compiler

Hinzufügen von Steuerelementen zum Dialog

Sobald der Dialog erstellt wurde, können wir ihm Steuerelemente hinzufügen. Für unser Beispiel fügen wir ein Textfeld hinzu, in das der Benutzer seinen Namen eingeben kann, und fügen außerdem zwei BUTTON-Steuerelemente („OK“ und „Abbrechen“) hinzu:

Typ:Schlüsselwort |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

STEUERUNG TEXTBOX, HDLG, IdText hinzufügen

, "", 14, 21, 134, 12, Style&, exStyle&

CONTROL ADD BUTTON, hDlg, 1, „&OK“, 44, 38, 40, 14, %BS_DEFAULT oder %WS_TABSTOP CALL Ok

CONTROL ADD BUTTON, hDlg, 2, „&Cancel“, 90, 38, 40, 14 CALL Cancel

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Adressierung und Zeiger – PBXB64-Compiler-Hilfe

Startseite› Funktionen › Adressierung und Zeiger

Adressierung und Hinweise

Ein wichtiger Unterschied im Assembler ist der Unterschied zwischen der Adresse einer Variablen und dem Wert einer Variablen. Die Adresse einer Variablen gibt an, wo sie sich im Speicher befindet. der Wert einer Variablen

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Dies ist die ADRESSE der Variablen im Speicher:

Dies ist der WERT an dieser Adresse:

Die in Assembler verwendete Methode zum Abrufen des Werts an einer Adresse ist eine Technik namens Dereferenzierung.

! MOV EAX, lpvar ; Adresse in EAX kopieren

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.


#ALIGN – PBXB64-Compiler-Hilfe

Startseite› Funktionen › #ALIGN

#AUSRICHTEN

Richten Sie die nächste Anweisung an einer Grenze aus.

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

#ALIGN boundary

Beschreibung

Die #ALIGN-Metaanweisung wird hauptsächlich von fortgeschrittenen Assembler-Programmierern verwendet, um aus kritischen Codeabschnitten maximale Effizienz zu erzielen.

#ALIGN wird verwendet, um den Befehlsort auf eine Zweierpotenz-Adresse aufzurunden. Der angezeigte Grenzparameter muss eine Zweierpotenz im Bereich von 2 bis 256 sein.

PowerBASIC fügt NOP-Anweisungen in den Codeabschnitt ein, um die Anweisungsposition an die gewünschte Adresse zu bringen. Wenn sich die Anweisungsposition bereits auf einem Vielfachen der Grenze befindet, hat #ALIGN keine Auswirkung.

Siehe auch

  • #OPTIMIEREN
  • ASM
  • ASM AUSRICHTEN
  • TIX

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ALLOCATE / REALLOCATE / FREE - PBXB64-Compiler-Hilfe

Startseite › cmd_allocate_reallocate_free.html

ALLOCATE / REALLOCATE / FREE

Speicherbloecke aus dem Prozess-Heap anfordern, vergroessern/verkleinern und freigeben.

Typ: Funktion | Kategorie: Memory & Pointers

PBXB64-Status: VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ptr = ALLOCATE(size)
ptr = REALLOCATE(size, ptr)
status = FREE(ptr)

Beschreibung

ALLOCATE reserviert einen Byte-Block aus dem aktuellen Prozess-Heap und gibt dessen Adresse als Integer-Pointerwert zurueck. PBXB64 senkt diese Form auf HeapAlloc(GetProcessHeap(), HEAP_ZERO_MEMORY, size) ab.

REALLOCATE aendert die Groesse eines Blocks, der vorher von ALLOCATE oder REALLOCATE geliefert wurde. Der zurueckgegebene Pointer kann sich vom alten Pointer unterscheiden und muss vom Programm gespeichert werden. PBXB64 senkt diese Form auf HeapReAlloc(GetProcessHeap(), HEAP_ZERO_MEMORY, ptr, size) ab.

FREE gibt einen Prozess-Heap-Block frei und liefert den PBXB64-Kompatibilitaets-Erfolgswert. Nach dem Freigeben darf ein Pointer nicht mehr gelesen, beschrieben, erneut vergroessert oder nochmals freigegeben werden.

Beispiel

FUNCTION PBMAIN() AS LONG
    LOCAL p AS LONG
    p = ALLOCATE(8)
    IF p = 0 THEN FUNCTION = 1 : EXIT FUNCTION
    POKE(BYTE, p, ASC("A"))
    p = REALLOCATE(32, p)
    IF p = 0 THEN FUNCTION = 2 : EXIT FUNCTION
    IF PEEK(BYTE, p) <> ASC("A") THEN FUNCTION = 3 : EXIT FUNCTION
    IF FREE(p) <> 0 THEN FUNCTION = 4
END FUNCTION

Verifiziertes Beispiel

Beispieldatei: examples/basic/test_reallocate.pb

Validierungsnachweis: als test_reallocate in tests/validate.toml registriert; der fokussierte pb_linkrun bestand mit 300/300 Tests, 0 Expected Fails und 0 Unexpected Fails.

Hinweise

  • Speichern Sie immer den Rueckgabewert von REALLOCATE; der urspruengliche Pointer kann ungueltig werden.
  • Die getestete Flaeche deckt Vergroessern und Verkleinern, erhaltene Bytes, nullinitialisierte Wachstumsbytes und das Freigeben einer Runtime-Pointervariable ab.
  • Nullgroesse, Null-Pointer, doppeltes Freigeben und Fehlerpfade bei Speichermangel sollten separat getestet werden, bevor dafuer PBWin-identische Semantik vorausgesetzt wird.

Siehe auch

  • PEEK
  • POKE
  • GLOBALMEM

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← POKE Nach oben GLOBALMEM →
← Top →


Ein ECHO-Client und -Server, der TCP verwendet – PBXB64-Compiler-Hilfe

Startseite› Funktionen › Ein ECHO-Client und -Server, der TCP verwendet
Hilfe zum PBXB64-Compiler

Ein ECHO-Client und -Server, der TCP verwendet

Die einfachste TCP-Serveranwendung ist ein Echo Server (RFC 862). Es lauscht einfach auf Port 7 und sendet das Datenpaket an den Client zurück, wenn es ein Datenpaket empfängt.

Typ:Schlüsselwort |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Das Schreiben eines TCP-Servers in PowerBASIC ist recht einfach, aber Ihre Anwendung muss ein (GUI-)Fenster oder einen Dialog enthalten, um Benachrichtigungsanfragen von Winsock zu empfangen. Daher ist es notwendig, entweder (1) einen Dialog mit DDT zu erstellen oder (2) die Windows-API zu verwenden, um ein GUI-Fenster für die Anwendung zu erstellen, um diese Benachrichtigungen zu empfangen. Die folgende Funktion registriert eine Fensterklasse und erstellt ein verstecktes Fenster, das von Ihrem Server verwendet werden kann.

FUNCTION MakeWindow() ALS DWORD

LOCAL wce AS WndClassEx

LOCAL szClassName AS ASCIIZ * 80

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Ein ECHO-Client und -Server, der TCP verwendet soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Ein ECHO-Client und -Server, der TCP verwendet mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


ANY - Beliebigen Parametertyp akzeptieren — PBXB64 Help

Startseite › General Reference › ANY - Beliebigen Parametertyp akzeptieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

ANY - Beliebigen Parametertyp akzeptieren

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

DECLARE SUB Api LIB "x" (BYVAL p AS ANY)

Detailverhalten

Kompatibilitaetskeyword in Typ-Position fuer Deklarationen, die ein untypisiertes zeigergrosses Argument akzeptieren.

Praktische Verwendung

Verwenden Sie ANY nur in der gezeigten Kontrollfluss- oder Ausdrucksposition. Der Test sollte die komplette Umgebungsform enthalten, damit der Scanner und der Parser die Position korrekt erkennen.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Diese Keywords haben nur in ihren erkannten Sprachpositionen die beabsichtigte Bedeutung. Ausserhalb dieser Positionen sollte der Parser nicht stillschweigend eine andere Semantik annehmen.

Verifiziertes Beispiel

Abgedeckt durch PB keyword compatibility (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Anhang C: Optimieren Ihres Codes – Hilfe zum PBXB64-Compiler

Startseite› Funktionen › Anhang C: Optimieren Ihres Codes

Anhang C: Optimieren Ihres Codes

Tipps und Techniken zur Leistungsoptimierung.

Typ:Konzeptionell |Kategorie:Optimierung

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Überblick

Dieses Thema bietet Hintergrundinformationen und praktische Anleitungen. Eine detaillierte Syntax finden Sie auf den entsprechenden Befehlsseiten.

Siehe auch

  • Befehlsindex

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Gibt es noch andere wichtige „Buzz-Words“? - PBXB64-Compiler-Hilfe

Startseite› Funktionen › Gibt es weitere wichtige „Buzz-Words“?
Hilfe zum PBXB64-Compiler

Gibt es noch andere wichtige „Buzz-Words“?

Siehe auch

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Was ist überhaupt ein Objekt?

Aus welchen Teilen besteht ein Objekt?

Wie sieht eine Klasse aus?

Was ist eine Basisklasse?

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Arithmetische Operatoren – Hilfe zum PBXB64-Compiler

Startseite› Funktionen › Arithmetische Operatoren

Arithmetische Operatoren

Arithmetische Operatoren führen normale mathematische Operationen aus. Einige dieser Operatoren verdienen eine Erklärung. Der Backslash (\) steht für eine ganzzahlige Division. Integrale Division rundet ihren Operan ab

Typ:Betreiber |Kategorie:Betreiber

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Der Rest einer ganzzahligen Division kann mit dem MOD (Modulo)-Operator bestimmt werden (MOD gilt für alle numerischen Typen). MOD ähnelt der Ganzzahldivision, außer dass es den Rest der Division und nicht den Quotienten zurückgibt. Beispielsweise gibt 5 MOD 2 den Wert 1 zurück und 9 MOD 10 gibt den Wert 9 zurück.

Der ISTRUE-Operator gibt nur dann TRUE zurück, wenn sein Operand TRUE (ungleich Null) ist. ISTRUE gibt garantiert -1 als TRUE-Wert zurück, während die Operatoren jeden Wert ungleich Null zurückgeben können.

Der ISFALSE-Operator gibt nur dann TRUE zurück, wenn sein Operand FALSE (Null) ist. ISFALSE gibt garantiert -1 als TRUE-Wert zurück, wobei die Operatoren jeden Wert ungleich Null zurückgeben können.

PowerBASIC-Rechenoperatoren

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Arithmetische Operatoren soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Arithmetische Operatoren mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


ARRAY ASSIGN – PBXB64-Compiler-Hilfe

Startseite› Funktionen › ARRAY ASSIGN

ARRAY-ZUWEISUNG

Ermöglichen die Zuweisung einer Reihe von Werten zu aufeinanderfolgenden Elementen eines

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ARRAY ASSIGN array() = param1 [, param2 ] [, ]

Beschreibung

ARRAY ASSIGN ermöglicht die Zuweisung mehrerer Werte zu aufeinanderfolgenden Elementen eines Arrays. Die Zuweisung beginnt immer mit dem ersten Array-Element und wird nacheinander fortgesetzt, während die Elemente im Speicher erscheinen. Die zuzuweisenden Werte müssen mit dem Array-Typ übereinstimmen und können Literale, Variablen oder Ausdrücke sein. ARRAY ASSIGN kann nicht für ein Array von Schnittstellen verwendet werden.

Siehe auch

  • ARRAY LÖSCHEN
  • ARRAY-EINSATZ
  • ARRAY-SCAN
  • ARRAY-SORTIERUNG
  • DIM
  • LBOUND
  • PowerArray
  • REDIM
  • UBOUND

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


Array-Datentypen – PBXB64-Compiler-Hilfe

Startseite› Funktionen › Array-Datentypen

Array-Datentypen

Oft ist es sinnvoll, eine Reihe von Variablen als Gruppe zu behandeln. Dadurch können Sie sich wiederholende Vorgänge einfacher durchführen. Ein Array ist eine Gruppe von Zeichenfolgen oder numerischen Daten mit demselben Variablennamen. Die in

Typ:Schlüsselwort |Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

PowerBASIC stellt mehrere Anweisungen bereit, die Operationen an einem Array als Ganzes ausführen und es Ihnen ermöglichen, dessen Inhalte zu sortieren, seine Inhalte nach Daten zu durchsuchen, die einer bestimmten Bedingung entsprechen, und Daten in die vorhandene Struktur einzufügen oder Daten daraus zu löschen.

Sie können sich ein Array als eine Reihe von Kästchen vorstellen, die von Null bis zu einer vorgegebenen Zahl nummeriert sind: vier, in der Beispielabbildung unten. Jedes Feld enthält einen bestimmten Wert, der von den Werten in den anderen Feldern abweichen kann oder auch nicht. Die Kästchen und ihre Nummern werden durch Klammern um eine Zahl dargestellt; Beispielsweise stellt item%(3) das Feld Nummer drei des Arrays item% dar. Wenn also der in Feld Nummer 3 gespeicherte Wert 1952 ist, würde die Anweisung total%=item%(3) den Wert 1952 in die Variable total% einfügen.

Beim Dimensionieren eines dynamischen Arrays mit DIM oder REDIM wird auch jedes Element gelöscht, es sei denn, die PRESERVE-Option ist vorhanden. Jedes Element jedes numerischen Arrays wird auf Null gesetzt; String-Arrays werden auf den Null-String ("", Länge Null) gesetzt. Die Deklaration des Namens und Typs eines Arrays sowie der Anzahl und Organisation seiner Elemente erfolgt durch die DIM-Anweisung. Zum Beispiel:

DIM-Zahlungen(55) ALS WÄHRUNGX

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Array-Datentypen soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Array-Datentypen mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


ARRAY DELETE – PBXB64-Compiler-Hilfe

Startseite› Funktionen › ARRAY DELETE

ARRAY LÖSCHEN

Löschen Sie ein einzelnes Element aus einem bestimmten Element

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ARRAY DELETE array ([ index ]) [FOR count ] [, expression ]

Beschreibung

ARRAY DELETE löscht die am angegebenen Element im Array, einem n-dimensionalen Array, gespeicherten Daten. Sie können den Index des Elements angeben, dessen Daten gelöscht werden sollen, wie viele Elemente ( count ) automatisch um eine Position nach unten verschoben werden sollen und welchen Datenwert das letzte Element erhalten soll, nachdem die restlichen Elemente verschoben wurden ( expression ).

Alle diese Parameter sind optional. Wenn kein Index angegeben ist, werden die im Element am Anfang des Arrays gespeicherten Daten gelöscht. Wenn Ausdruck nicht vorhanden ist, enthält das letzte Element, aus dem die Daten verschoben werden, Null, wenn Array ein numerisches Array ist, oder eine leere Zeichenfolge, wenn Array ein String-Array ist. Wenn eine Verschiebungsanzahl angegeben ist und der Rest des Arrays verschoben wird, um das Element zu entfernen, werden nur die Anzahl der Elemente verschoben.

Standardmäßig verwirft ARRAY DELETE die Daten am Elementindex von array und verschiebt die Daten im entsprechenden Teil des Arrays, um das alte Element abzudecken:

DIMMEN SIE A(1 BIS 4) SO LANG

ARRAY LÖSCHEN A(2), 17&

macht A(2) = A(3) , A(3) = A(4) und A(4) = 17 . Der ursprüngliche Wert von A(1) bleibt bestehen. Verwenden Sie count, um einen Teil des Arrays vor der Verschiebung zu „schützen“:

DIMMEN SIE A(1 BIS 4) SO LANG

ARRAY DELETE A(2) FOR 2, 17&

macht A(2) = A(3) und A(3) = 17, weil Sie ihm gesagt haben, dass er nur 2 Elemente verschieben soll. Die ursprünglichen Werte von A(4) und A(1) bleiben erhalten.

DELETE mit mehrdimensionalen Arrays

count kann auch mit einem mehrdimensionalen Array (in linearer Spaltenreihenfolge gespeichert; siehe ARRAY SORT ) verwendet werden, um das Verschieben von Elementdaten von einer Dimension in eine andere Dimension zu verhindern und so die Organisation des Arrays beizubehalten. Zum Beispiel:

DIM A(0 TO 1,0 TO 1) ALS INTEGER

A(0,0)=0

A(1,0)=100

A(0,1)=200

A(1,1)=300

ARRAY DELETE A(0,0) FOR 2, 17 %

macht A(0,0) = 100 und A(1,0) = 17 . Die ursprünglichen Werte von A(0,1) und A(1,1) bleiben erhalten, da Sie es angewiesen haben, nur 2 Elemente zu verschieben. Ohne Zählung:

ARRAY DELETE A(0,0), 17 %

macht A(0,0) = 100 , A(1,0) = 200 , A(0,1) = 300 und A(1,1) = 17 . Der ursprüngliche Wert von A(0,0) geht verloren.

Einschränkungen

ARRAY DELETE kann nicht für Arrays innerhalb von UDT-Strukturen verwendet werden. ARRAY DELETE kann jedoch mit Arrays von UDT-Strukturen verwendet werden – behandeln Sie sie einfach so, als wären sie ein Array von Strings fester Länge.

Um ARRAY DELETE für ein eingebettetes UDT-Array zu verwenden, dimensionieren Sie mit DIM..AT ein reguläres Array (des gleichen Typs) direkt „über der Oberseite“ des UDT-Arrays und verwenden Sie ARRAY DELETE für dieses Array. Zum Beispiel:

TYP SalesType

Bestellnummer SO LANG

PartNumber(1 TO 20) AS STRING * 20

END-TYP

[Anweisungn]

DIM Sales AS SalesType

[Anweisungn]

DIM Temp(1 TO 20) AS STRING * 20 AT VARPTR(Sales.Partnumber(1))

ARRAY DELETE Temp(5), „string“

Temp() löschen

Siehe auch

  • ARRAY-ZUWEISUNG
  • ARRAY-EINSATZ
  • ARRAY-SCAN
  • ARRAY-SORTIERUNG
  • DIM
  • LBOUND
  • PowerArray
  • REDIM
  • UBOUND

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


ARRAY INSERT – PBXB64-Compiler-Hilfe

Startseite› Funktionen › ARRAY INSERT

ARRAY-EINSATZ

Fügen Sie ein einzelnes Element in ein bestimmtes Element ein

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ARRAY INSERT array ([ index ]) [FOR count ] [, expression ]

Beschreibung

ARRAY INSERT fügt ein einzelnes Datenelement in array ein, ein n-dimensionales Array. Sie können den Index angeben, an dem die neuen Elementdaten eingefügt werden sollen, wie viele Elemente ( count ) um eine Position nach oben verschoben werden sollen, um Platz für die neuen Elementdaten zu schaffen, und welchen Datenwert das neue Element erhalten soll ( expression ).

Alle diese Parameter sind optional. Wenn kein Index angegeben ist, werden die Elementdaten am Anfang des Arrays eingefügt. Wenn Ausdruck nicht vorhanden ist, enthält das neue Element Null, wenn Array ein numerisches Array ist, oder eine leere Zeichenfolge, wenn Array ein String-Array ist.

Wenn eine Verschiebungsanzahl angegeben wird und der Rest des Arrays verschoben wird, um Platz für die neuen Elementdaten zu schaffen, werden nur die Anzahl der Elemente verschoben.

Standardmäßig verwirft ARRAY INSERT die Daten im letzten Element des Arrays und verschiebt dann den entsprechenden Teil des Arrays, um Platz für die neuen Elementdaten zu machen:

DIMMEN SIE A(1 BIS 4) SO LANG

ARRAY-EINSATZ A(2), 17

ergibt A(4) = A(3) , A(3) = A(2) und A(2) = 17 . Der ursprüngliche Wert von A(4) geht verloren, während der ursprüngliche Wert von A(1) bestehen bleibt. Verwenden Sie count, um einen Teil des Arrays vor der Verschiebung zu „schützen“:

DIMMEN SIE A(1 BIS 4) SO LANG

ARRAY-EINSATZ A(2) FOR 2, 17

macht A(3) = A(2) und A(2) = 17, weil Sie ihm gesagt haben, dass er nur 2 Elemente verschieben soll. Die ursprünglichen Werte von A(4) und A(1) bleiben erhalten.

INSERT mit mehrdimensionalen Arrays

count kann auch mit einem mehrdimensionalen Array (in linearer Spaltenreihenfolge gespeichert; siehe ARRAY SORT ) verwendet werden, um das Verschieben von Daten von einer Dimension in eine andere Dimension zu verhindern und so die Organisation des Arrays beizubehalten. Zum Beispiel:

DIM A(0 BIS 1,0 BIS 1) ALS EINZELN

A(0,0)=0

A(1,0)=100

A(0,1)=200

A(1,1)=300

ARRAY EINFÜGEN A(0,0) FOR 2, 17

macht A(0,0) = 17 und A(1,0) = 0 . Die ursprünglichen Werte von A(0,1) und A(1,1) bleiben erhalten, da Sie es angewiesen haben, nur 2 Elemente zu verschieben. Ohne Zählung:

ARRAY EINFÜGEN A(0,0), 17

macht A(0,0) = 17 , A(1,0) = 0 , A(0,1) = 100 und A(1,1) = 200 . Der ursprüngliche Wert von A(1,1) geht verloren.

Einschränkungen

ARRAY INSERT kann nicht für Arrays innerhalb von UDT-Strukturen oder für ein Array von Interfaces verwendet werden. ARRAY INSERT kann jedoch mit Arrays von UDT-Strukturen verwendet werden – behandeln Sie sie einfach so, als wären sie ein Array von Zeichenfolgen fester Länge.

Um ARRAY INSERT für ein eingebettetes UDT-Array zu verwenden, dimensionieren Sie mit DIM..AT ein reguläres Array (des gleichen Typs) direkt „über der Oberseite“ des UDT-Arrays und verwenden Sie ARRAY INSERT für dieses Array. Zum Beispiel:

TYP SalesType

Bestellnummer SO LANG

PartNumber(1 TO 20) AS STRING * 20

END-TYP

[Anweisungn]

DIM Sales AS SalesType

[Anweisungn]

DIM Temp(1 TO 20) AS STRING * 20 AT VARPTR(Sales.Partnumber(1))

ARRAY INSERT Temp(5), „string“

Temp() löschen

Siehe auch

  • ARRAY-ZUWEISUNG
  • ARRAY LÖSCHEN
  • ARRAY-SCAN
  • ARRAY-SORTIERUNG
  • DIM
  • LBOUND
  • PowerArray
  • REDIM
  • UBOUND

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


Array-Operationen – PBXB64-Compiler-Hilfe

Startseite› Funktionen › Array-Operationen

Array-Operationen

Die folgenden Funktionen können zum Bearbeiten und Verwalten von Arrays verwendet werden:

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Kontrollieren Sie die Generierung von Fehlerprüfcode

Geben Sie an, ob Variablen vor der Verwendung deklariert werden müssen

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


ARRAY-SCAN – PBXB64-Compiler-Hilfe

Startseite› Funktionen › ARRAY SCAN

ARRAY-SCAN

Scannen Sie alles oder einen Teil davon

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ARRAY SCAN array ([ index ]) [FOR count ], expression , TO lvar&
ARRAY SCAN array ([ index ]) [FOR count ] [, FROM startChar TO endChar ] [, COLLATE {UCASE |
cstring }], expression , TO lvar&

Beschreibung

ARRAY SCAN durchsucht das gesamte oder einen Teil des Arrays, eines n-dimensionalen Arrays, nach dem ersten Element, das expression erfüllt. expression besteht aus einem relationalen Operator (=, >, <, <>, >=, =>, <=, =<), gefolgt von einem Ausdruck desselben Datentyps wie array . Der relative Index der ersten Übereinstimmung wird in lvar& gespeichert, das eine Long-Integer-Variable sein muss:

ARRAY SCAN A&(), > 5, TO I&

Diese Codezeile identifiziert den relativen Index des ersten Elements des Arrays A&(), das größer als 5 ist, und speichert den relativen Index in I& . Der Übereinstimmungsindex reicht von 1 bis zum letzten Element des Scans + 1.

Da es sich um einen relativen Index handelt:

DIMMEN A(1 BIS 10) ALS EINZELN

ARRAY SCAN A(), > 17,42!, TO I&

speichert 2 in I&, wenn A(2) > 17,42, aber:

DIM A(5 BIS 20) ALS EINZEL

ARRAY SCAN A(), > 17.42!, TO lvar&

speichert 2, nicht 6, in lvar&, wenn A(6) > 17,42.

Wenn keines der gescannten Elemente expression erfüllt, wird Null in lvar& gespeichert.

Index und Anzahl geben zusammen den Teil des Arrays an, der gescannt werden soll. index gibt das Element an, bei dem der Scan beginnen soll, während count die Anzahl der aufeinanderfolgenden Elemente angibt, die gescannt werden sollen. Wenn kein Index angegeben ist, beginnt der Scan beim ersten Element des Arrays. Wenn count nicht angegeben ist, wird das Array vom Elementindex bis zum letzten Element des Arrays durchsucht. Wenn keines von beiden angegeben ist, wird das gesamte Array gescannt:

DIM A&(1 BIS 100)

ARRAY SCAN A&(5), =1, TO I& 'scannt 5..100

ARRAY SCAN A&() FOR 10, =1, TO I& 'scannt 1..10

ARRAY SCAN A&(10) FOR 20, =1, TO I& 'scannt 10..29

ARRAY SCAN A&(), =1, TO I& 'scannt 1..100

Scannen eines String-Arrays

Beim Scannen eines String-Arrays behandelt COLLATE UCASE während des Scans alle Kleinbuchstaben als Großbuchstaben (z. B. würde das Element „Bob“ die Bedingung = „BOB“ erfüllen):

ARRAY SCAN A$(), COLLATE UCASE, = "BOB", TO I&

' durchsucht A$() nach „BOB“; Alle Buchstaben werden behandelt als

' Großbuchstaben

Die Zeichenfolge COLLATE wird verwendet, um eine nicht standardmäßige Scanreihenfolge anzugeben. cstring muss genau 256 Zeichen in der Reihenfolge enthalten, in der sie verglichen werden sollen, vom niedrigsten zum höchsten. Beispielsweise würde die normale aufsteigende ASCII-Scanreihenfolge (wobei „A“ als kleiner als „B“ usw. betrachtet wird) durch eine Zeichenfolge beschrieben, die die ASCII-Codes 0 bis 255 in der folgenden Reihenfolge enthält:

C$ = CHR$(0 BIS 255)

ARRAY SCAN A$(), COLLATE C$, > „BOB“, TO I&

Die normale absteigende ASCII-Scanreihenfolge würde durch eine Zeichenfolge beschrieben, die die Umkehrung des oben genannten enthält:

C$ = STRREVERSE$(CHR$(0 TO 255))

ARRAY SCAN A$(), COLLATE C$, > „BOB“, TO I&

Die String-Option COLLATE dient als flexible Möglichkeit, einen absteigenden Scan anzugeben oder die Scan-Reihenfolge für Strings anzugeben, die internationale Zeichen oder andere Sonderzeichen enthalten.

Weitere Informationen zum Erstellen von Sortierzeichenfolgen finden Sie unter ARRAY SORT.

Beim Scannen eines String-Arrays werden bei Vergleichen normalerweise alle Zeichen jedes Elements des Arrays berücksichtigt. Um den Vergleich auf eine bestimmte Teilmenge von Zeichen zu beschränken, verwenden Sie FROM, um die startChar-Position anzugeben, und TO, um die endChar-Position anzugeben, die ARRAY SCAN innerhalb jedes Array-Elements berücksichtigt. Sie könnten beispielsweise anhand der Postleitzahl scannen, die in den letzten 5 Zeichen einer 40-stelligen Adresszeichenfolge enthalten ist:

ARRAY SCAN A$(), = "90210", TO I&

'berücksichtigt alle Zeichen beim Scannen nach „90210“

ARRAY SCAN A$(), FROM 36 TO 40, = „90210“, TO I&

' berücksichtigt beim Scannen nur die Positionen 36..40

Scannen eines mehrdimensionalen Arrays

Beim Scannen eines mehrdimensionalen Arrays wird das Array als eindimensionales Array behandelt, das alle Elemente des mehrdimensionalen Arrays in linearer Spaltenreihenfolge enthält. Das heißt, alle Elemente, bei denen alle Dimensionen (außer der ersten) an ihren Mindestgrenzen gehalten werden, werden im Speicher an erster Stelle stehen. Unmittelbar darauf folgen die Elemente, bei denen die zweite Dimension auf den nächsten aufeinanderfolgenden Indexwert usw. gesetzt ist.

Beispielsweise würden die Elemente eines zweidimensionalen Arrays (DIM A(0 TO n, 0 TO x)) wie folgt an aufeinanderfolgenden Speicherorten gespeichert:

A(0,0), A(1,0), , A(n,0) ' Die ersten n+1 Elemente,

A(0,1), A(1,1), , A(n,1) ' Die nächsten n+1 Elemente,

[Anweisungen] ' Nachfolgende Elemente,

A(0,x), A(1,x), , A(n,x) ' Die letzten n+1 Anweisungen.

oder deutlicher:

A(0,0), A(1,0) , A(n,0), A(0,1), A(1,1) , A(n,1), A(0,x),

A(1,x) , A(n,x)

In diesem Fall würde ARRAY SCAN A(0,0) FOR n+1, >5, TO I& nur die Elemente (0,0)...(n,0) scannen, während ARRAY SCAN A(0,0), >5, TO I& das gesamte Array scannen würde: Elemente (0,0)...(n,x). Da ARRAY SCAN, wie bereits erwähnt, den relativen Index des übereinstimmenden Elements aufzeichnet, würde ARRAY SCAN A(0,0), >5, TO I& 2 in I& speichern, wenn A(1,0) > 5.

Einschränkungen

ARRAY SCAN kann nicht für Arrays innerhalb von UDT-Strukturen oder für ein Array von Schnittstellen verwendet werden. ARRAY SCAN kann jedoch mit Arrays von UDT-Strukturen verwendet werden – behandeln Sie sie einfach so, als wären sie ein Array aus Strings fester Länge.

Um ARRAY SCAN für ein eingebettetes UDT-Array zu verwenden, dimensionieren Sie mit DIM..AT ein reguläres Array (des gleichen Typs) direkt „über der Oberseite“ des UDT-Arrays und verwenden Sie ARRAY SCAN für dieses Array. Zum Beispiel:

TYP SalesType

Bestellnummer SO LANG

PartNumber(1 TO 20) AS STRING * 20

END-TYP

[Anweisungn]

DIM Sales AS SalesType

[Anweisungn]

DIM Temp(1 TO 20) AS STRING * 20 AT VARPTR(Sales.Partnumber(1))

ARRAY SCAN Temp(), FROM 1 TO LEN(Search$), = Search$, TO lResult&

Temp() löschen

Siehe auch

  • ARRAY-ZUWEISUNG
  • ARRAY LÖSCHEN
  • ARRAY-EINSATZ
  • ARRAY-SORTIERUNG
  • DIM
  • LBOUND
  • PowerArray
  • REDIM
  • UBOUND

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


ARRAY SORT – PBXB64-Compiler-Hilfe

Startseite› Funktionen › ARRAY SORT

ARRAY-SORTIERUNG

Sortieren Sie alles oder einen Teil davon

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:TEILWEISE

PBXB64-Zertifizierung: [TEILWEISE: NUMERISCHE LANGE SORTIERUNGEN GETESTET]

Syntax

ARRAY SORT darray ([ index ]) [FOR count ] [,TAGARRAY tarray() ] [,{ASCEND | DESCEND}]
ARRAY SORT dArray ([ index ]) [FOR count ] [,FROM startChar TO endChar ] [,COLLATE {UCASE |
cstring }] [,TAGARRAY tarray() ] [,{ASCEND | DESCEND}]
ARRAY SORT darray ([ index ]) [FOR count ] [,TAGARRAY tarray() ] ,CALL custfunc()

Beschreibung

ARRAY SORT sortiert darray, ein n-dimensionales Array, ganz oder teilweise in aufsteigender oder absteigender Reihenfolge. tarray ist ein Tag-Along-Array, dessen Elemente beim Fortschreiten der Sortierung in der gleichen Reihenfolge wie die in Darray ausgetauscht werden (Sie könnten beispielsweise ein Array von Namen sortieren und ein Array entsprechender Adressen mit Tag-Alongs versehen). tarray muss mindestens so viele Elemente wie darray haben, da entsprechende Elemente von tarray während der Sortierung vertauscht werden.

PBXB64-Hinweis:Die zertifizierte TAGARRAY-Teilmenge deckt derzeit aufsteigende numerische LONG-Schlüsselarrays mit numerischen LONG-Tag-Arrays ab. String-Arrays, UDT-Arrays, benutzerdefinierte CALL-Komparatoren und DESCEND-Tag-Array-Sortierungen müssen noch zertifiziert werden.

Beachten Sie, dass tarray nicht vom gleichen Typ wie darray sein muss. Beispielsweise könnten Sie ein numerisches Array mit Kontonummern-Tags und ein String-Array mit Benutzernamen haben:

DIM-Benutzer$(100 BIS 500), AcctNum&(100 BIS 500)

ARRAY SORT Users$(), TAGARRAY AcctNum&()

Zusammen geben Index und Anzahl den Teil des Darrays an, der sortiert werden soll. index gibt das Element an, bei dem die Sortierung beginnen soll, während count die Anzahl der aufeinanderfolgenden Elemente angibt, die sortiert werden sollen. Wenn index weggelassen wird, beginnt die Sortierung beim ersten Element von darray . Wenn count weggelassen wird oder Null ist, wird das Array vom Elementindex bis zum letzten Element von darray sortiert. Wenn beide weggelassen werden, wird das gesamte Array sortiert:

DIM A&(1 BIS 99)

ARRAY SORT A&(5) 'sortiert Elemente 5..99 von A&

ARRAY SORT A&() FOR 10 'sortiert die Elemente 1..10 von A&

ARRAY SORT A&(9) FOR 20 'sortiert Elemente 9..28 von A&

ARRAY SORT A&() 'sortiert die Elemente 1..99 von A&

Numerische Arrays sortieren

Standardmäßig werden Arrays in aufsteigender Reihenfolge sortiert. Um in absteigender Reihenfolge zu sortieren, fügen Sie das Schlüsselwort DESCEND ein:

ARRAY SORT A&(), DESCEND ' absteigende Reihenfolge

ARRAY SORT A&(), ASCEND ' aufsteigende Reihenfolge

ARRAY SORT A&() ' aufsteigende Reihenfolge

String-Arrays sortieren

Beim Sortieren eines String-Arrays erfolgt die Sortierung standardmäßig in aufsteigender Reihenfolge. Zusätzlich zu DESCEND bietet ARRAY SORT die Optionen COLLATE UCASE und COLLATE string.

COLLATE UCASE behandelt bei der Sortierung alle Kleinbuchstaben als gleich ihren Großbuchstaben (die Elemente „Bob“ und „BOB“ würden beispielsweise als gleich betrachtet):

DIM A$(1 BIS 5)

A$(1) = „Bob“

A$(2) = „Jan“

A$(3) = „Linda“

A$(4) = „Ann“

A$(5) = „Jerry“

ARRAY SORT A$(), COLLATE UCASE, DESCEND

'sortiert A$() in absteigender Reihenfolge; Groß- und Kleinschreibung wird nicht beachtet

COLLATE cstring wird verwendet, um eine völlig neue Sortierreihenfolge anzugeben. Dies kann für verschiedene Zwecke verwendet werden, der offensichtlichste davon ist der Fall internationaler Zeichensätze. Die Sortierzeichenfolge cstring muss genau 256 Zeichen enthalten, eines für jeden der ASCII-Codes 0-255, in der Reihenfolge, in der sie sortiert würden (vom niedrigsten zum höchsten, wenn eine aufsteigende Sortierung für sie durchgeführt würde).

Jede Position in der Zeichenfolge stellt den ASCII-Code dieses Werts dar. Der Inhalt des Bytes an dieser Position teilt PowerBASIC das „Gewicht“ oder den Wichtigkeitsfaktor dieses bestimmten ASCII-Codes mit. Standardmäßig hat Position 0 eine Gewichtung von 0, Position 1 eine Gewichtung von 1 usw., sodass CHR$ (0) zuerst sortiert, CHR$(1) als nächstes usw. bis CHR$(255).

Angenommen, Sie möchten, dass das Sonderzeichen „?“ die gleiche Gewichtung wie das Standardzeichen „a“ hat. Es ist ganz einfach: Erstellen Sie eine Zeichenfolge mit 256 Zeichen, 0-255; Gehen Sie dann zur Position „?“ (ASCII-Code 132) und ändern Sie den Inhalt dieses Bytes so, dass er genau dem Code für „a“ (97) entspricht. Das folgende Codefragment erstellt eine solche Sortierzeichenfolge:

' Erstellen Sie eine 256-stellige Zeichenfolge:

FOR ix = 0 BIS 255

C$ = C$ + CHR$(ix)

MID$(C$, 132 + 1) = CHR$(97)

Wir fügen eins zum ASC-Wert für MID$ hinzu, da die Zeichenfolgenpositionen bei 1 und nicht bei 0 beginnen. Wir können auch die erweiterte CHR$-Funktion verwenden, um dieselbe Sortierzeichenfolge mit weniger Code zu erstellen:

C$ = CHR$(0 BIS 131, 97, 133 BIS 255)

Es ist sehr wichtig, sich an die Regel zum Erstellen einer Sortierfolge zu erinnern, da es leicht ist, intuitiv zu einer falschen Schlussfolgerung zu gelangen. Jede Position in der Zeichenfolge (1-256) stellt den ASCII-Code mit diesem Wert minus eins dar (CHR$(0) bis CHR$(255)). Der Inhalt des Bytes an dieser Position teilt der ARRAY SORT-Prozedur das neue „Gewicht“ oder den neuen Wichtigkeitsfaktor für diesen bestimmten Code mit. Dies ist genau die Technik, die vom 80x86-Assembler-Opcode XLAT verwendet wird.

Angenommen, Sie möchten, dass CHR$(0) ganz am Ende der Sequenz sortiert wird. Dazu würden Sie das Byte an Position 0+1 auf CHR$(255) und die Bytes an Position 0+2 bis 0+256 auf die Werte 0 bis 254 setzen. Die ASCII-Sequenz in der Sortierzeichenfolge würde wie folgt aussehen: 255,0,1,2,3,4 254. Mit der erweiterten Funktion CHR$ ist dies unkompliziert:

C$ = CHR$(255, 0 BIS 254)

Um Groß- und Kleinbuchstaben exakt gleich zu sortieren, setzen Sie einfach die Positionen 97 bis 122 (a-z) auf die Werte 65-90 (A-Z). Genau so wird COLLATE UCASE gehandhabt. Mit der durch dieses Verfahren in PowerBASIC implementierten Sortiermethode ist es möglich, dass zwei oder mehr ASCII-Codes das gleiche „Gewicht“ haben.

Wie bereits erwähnt, machen viele Programmierer einen häufigen, schwerwiegenden Fehler, indem sie intuitiv eine Sortierzeichenfolge erstellen, die lediglich eine Liste von ASCII-Codes in der Reihenfolge ist, in der sie sortieren möchten. Das heißt, sie erwarten, dass das Byte, das zuerst in der Zeichenfolge erscheint, zuerst sortiert wird, und das Byte, das als nächstes erscheint, als zweites sortiert wird, sodass eine Sortierzeichenfolge aus dem BASIC-Code erstellt wird:

CHR$(65) + CHR$(66) + CHR$(67) + ...

kann dazu führen, dass die Zeichen „ABC...“ zuerst sortiert werden. Diese Technik funktioniert niemals mit der ARRAY-Anweisung und muss sorgfältig vermieden werden. Wir beschreiben es hier nur, weil es ein häufiger Fehler ist. Obwohl es wohl intuitiver ist als die in PowerBASIC implementierte Technik, funktioniert es nicht, weil es nicht zulässt, dass zwei oder mehr ASCII-Codes das gleiche „Gewicht“ haben.

Der folgende Code erstellt eine Sortierzeichenfolge, die mit dem amerikanischen OEM-ASCII-Zeichensatz kompatibel ist. Für den schnellsten Vorgang sollte dieser Code nur einmal ausgeführt werden und die Sortierzeichenfolge sollte global gemacht werden.

GLOBAL cu AS STRING

FOR x = 0 BIS 255

cu = cu + CHR$(x)

MID$(cu, 97+1, 26) = "ABCDEFGHIJKLMNOPQRSTUVWXYZ"

MID$(cu, 129+1, 6) = "ueaaaa" ' ??????

MID$(cu, 136+1, 9) = "eeeiiiAAE" ' ????????

MID$(cu, 147+1, 8) = "ooouuyOU" ' ????????

MID$(cu, 161+1, 5) = "iounN" ' ??????

MID$(cu, 168+1, 1) = "?" ' ?

[Hier steht Ihr Code]

ARRAY SORT MyArray$(), COLLATE cu

Eine alternative Anordnung unter Verwendung der erweiterten CHR$-Funktion könnte wie folgt aussehen:

cu = CHR$(0 TO 96, "ABCDEFGHIJKLMNOPQRSTUVWXYZ", _

123 BIS 128, „ueaaaa“, _ ' ??????

135, „eeeiiiAAE“, _ ' ????????

145 BIS 146, „ooouuyOU“, _ ' ????????

155 BIS 160, „iounN“, _ ' ??????

166 BIS 167, „?“, _ ' ?

169 BIS 255)

Beispielsweise würde die normale aufsteigende ASCII-Sortierreihenfolge durch eine Zeichenfolge beschrieben, die die ASCII-Codes 0 bis 255 in der folgenden Reihenfolge enthält:

C$ = CHR$(0 BIS 255)

ARRAY SORT A$(), COLLATE C$

Die normale absteigende ASCII-Sortierreihenfolge würde durch eine Sortierzeichenfolge beschrieben, die die Umkehrung des oben genannten enthält:

C$ = STRREVERSE$(CHR$(0 TO 255))

ARRAY SORT A$(), COLLATE C$

Die Zeichenfolge COLLATE kann auch mit der Option ASCEND oder DESCEND verwendet werden. Bei ASCEND erfolgt die Sortierung in der durch COLLATE string angegebenen Reihenfolge; DESCEND sortiert in umgekehrter Reihenfolge zu der durch COLLATE string angegebenen Reihenfolge:

ARRAY SORT A$(), COLLATE C$, DESCEND

Die Zeichenfolgenoption COLLATE dient als flexibles Mittel zum Festlegen der Sortierreihenfolge für Zeichenfolgen, die internationale Zeichen oder andere Sonderzeichen enthalten. Bitte beachten Sie, dass die Zeichen mit dem ASCII-Code über CHR$(127) in verschiedenen Ländern unterschiedliche Bedeutungen haben können. In den Beispielen wird davon ausgegangen, dass die standardmäßige amerikanische OEM-ASCII-Codepage verwendet wird.

Beim Sortieren eines String-Arrays werden bei Vergleichen normalerweise alle Zeichen jedes Elements des Arrays berücksichtigt. Um den Vergleich auf eine bestimmte Teilmenge von Zeichen zu beschränken, verwenden Sie FROM, um die startChar-Position anzugeben, und TO, um die endChar-Position anzugeben, die ARRAY SORT innerhalb jedes Array-Elements berücksichtigt. Sie könnten beispielsweise nach der Postleitzahl sortieren, die in den letzten 5 Zeichen einer 40-stelligen Adresszeichenfolge enthalten ist:

ARRAY SORT A$() ' sortiert alle Zeichen

ARRAY SORT A$(), FROM 36 TO 40 ' sortiert nur 36 - 40/p>

Durch die Verwendung der Schlüsselwörter FROM..TO wird es auch möglich, ein Array benutzerdefinierter Typen zu sortieren. In diesem Fall kann ARRAY SORT das Array so sortieren, als wäre es ein Array von Strings fester Länge.

Benutzerdefinierte Arrays sortieren:

In den meisten Fällen sollten die standardmäßigen numerischen und Zeichenfolgensortierungen Ihren Anforderungen sehr gut genügen. Bei komplexeren Daten ist es jedoch häufig erforderlich, Sortierungen nach mehreren Schlüsseln oder andere ungewöhnliche Datensequenzen zu erstellen. Im Allgemeinen wird eine Sortierung nach mehreren Schlüsseln verwendet, wenn Sie Daten basierend auf mehreren Abschnitten einer Zeichenfolge oder eines UDT ordnen möchten. Beispielsweise möchten Sie möglicherweise, dass die Kunden nach Namen geordnet werden. Im Falle doppelter Namen ordnen Sie jedoch jeden Satz Duplikate nach Postleitzahl. Mit der Option „Benutzerdefiniertes Array“ können Sie nach einer beliebigen Anzahl von Schlüsseln in jeder gewünschten Reihenfolge sortieren.

Ein benutzerdefiniertes Array kann aus benutzerdefinierten Typen, Zeichenfolgen fester Länge oder mit Nullen terminierten Zeichenfolgen bestehen. Mit einer benutzerdefinierten Array-Sortierung können Sie Ihre eigene einfache Funktion schreiben, um PowerBASIC die richtige Reihenfolge für zwei beliebige Array-Elemente mitzuteilen. Im folgenden Beispiel wird das Array MyType() basierend auf dem Code sortiert, den Sie in die vom Benutzer geschriebene Funktion namens MyFunc() schreiben.

ARRAY SORT MyType(), CALL MyFunc()

Während PowerBASIC die Sortierung durchläuft, ruft es jedes Mal, wenn es zwei Array-Elemente vergleichen muss, Ihre benutzerdefinierte Funktion (in diesem Fall MyFunc) auf, um die korrekte Reihenfolge der beiden Elemente zu bestimmen. Die von Ihnen geschriebene benutzerdefinierte Funktion muss immer genau zwei ByRef-Parameter mit genau demselben Datentyp wie das sortierte Array haben. Für nullterminierte Zeichenfolgen und FIELD-Zeichenfolgen müssen sie die Länge enthalten. Dies sind die beiden Variablen, die Sie vergleichen müssen, um die richtige Reihenfolge zu bestimmen. Ihre benutzerdefinierte Funktion muss eine lange Ganzzahl zurückgeben, um die richtige Reihenfolge anzugeben. Es gibt -1 zurück, wenn der erste Parameter vor dem zweiten Parameter stehen soll. Es gibt +1 zurück, wenn der zweite Parameter vor dem ersten stehen soll. Es gibt 0 zurück, wenn die Parameter gleich sind. Dies bietet dem PowerBASIC-Programmierer das ultimative Werkzeug für Sortierfunktionen. Sie können beliebig viele Schlüssel haben. Sie können aufsteigend, absteigend oder in einer anderen speziellen Reihenfolge sortieren. Die Bedingungen liegen jetzt vollständig unter Ihrer Kontrolle. Das folgende Beispiel zeigt, wie einfach es ist, eine Sortierung mit mehreren Schlüsseln zu erstellen, auch solche, die auf Nicht-String-Mitgliedern eines UDT basieren.

Geben Sie TheType ein

Nachname als String * 40

Vorname als String * 20

BalanceDue als Währung

Endtyp

[Anweisungn]

Dimmen Sie MyType(100) als TheType

[Anweisungn]

Array Sort MyType(), Call MyFunc()

[Anweisungn]

Funktion MyFunc(Param1 as TheType, Param2 as TheType) As Long

Wenn Param1.LastName < Param2.LastName Dann

Funktion = -1: Funktion beenden

Ende wenn

Wenn Param1.LastName > Param2.LastName Dann

Funktion = +1: Funktion beenden

Ende wenn

Wenn Param1.FirstName < Param2.FirstName, dann

Funktion = -1: Funktion beenden

Ende wenn

Wenn Param1.Vorname > Param2.Vorname, dann

Funktion = +1: Funktion beenden

Ende wenn

Wenn Param1.BalanceDue < Param2.BalanceDue Dann

Funktion = +1: Funktion beenden

Ende wenn

Wenn Param1.BalanceDue > Param2.BalanceDue, dann

Funktion = -1: Funktion beenden

Ende wenn

Funktion beenden

Beachten Sie, dass diese Funktion zunächst in aufsteigender Reihenfolge nach Nachnamen sortiert. Wenn die Nachnamen gleich sind, wird in aufsteigender Reihenfolge nach Vornamen sortiert. Wenn beide Namen gleich sind, erfolgt die Sortierung nach fälligem Saldo in absteigender Reihenfolge, sodass die Konten mit dem höchsten Saldo zuerst angezeigt werden. Diese absteigende Reihenfolge wird durch Vertauschen der Werte -1/+1 in den Abschlusstests erreicht.

Das zu sortierende Array und die Funktionsparameter müssen Zeichenfolgen fester Länge, mit NULL endende Zeichenfolgen oder benutzerdefinierte Typen sein. PowerBASIC überprüft, ob die Größe der Daten und Parameter identisch ist. Um maximale Flexibilität zu ermöglichen, ist es jedoch nicht erforderlich, dass die Datentypen identisch sind. Daher ist es beispielsweise möglich, ein Array von Strings fester Länge mithilfe einer Funktion mit UDT-Parametern zu sortieren, solange die Datengröße identisch ist. Es liegt in der Verantwortung des Programmierers, die Genauigkeit sicherzustellen.

Sortieren eines mehrdimensionalen Arrays

Beim Sortieren eines mehrdimensionalen Arrays wird das Array als eindimensionales Array behandelt, das alle Elemente des mehrdimensionalen Arrays in linearer Spaltenreihenfolge enthält. Das heißt, alle Elemente, bei denen alle Dimensionen (außer der ersten) an ihren Mindestgrenzen gehalten werden, werden im Speicher an erster Stelle stehen. Unmittelbar darauf folgen die Elemente, bei denen die zweite Dimension auf den nächsten aufeinanderfolgenden Indexwert usw. gesetzt ist.

Beispielsweise würden die Elemente eines zweidimensionalen Arrays (d. h. DIM A( n , x )) an aufeinanderfolgenden Speicherorten wie folgt gespeichert:

(0,0), , (n,0), (0,1), , (n,1), , (0,x), , (n,x)

In diesem Fall würde ARRAY SORT A(0,0) FOR n+1 nur die Elemente (0,0)...(n,0) sortieren, während ARRAY SORT A(0,0) das gesamte Array sortieren würde: Elemente (0,0) (n,x).

Seien Sie bei der Verwendung von ARRAY SORT mit mehrdimensionalen Arrays sehr vorsichtig, um die Organisation der Daten in den Arrays nicht zu stören.

Einschränkungen

ARRAY SORT kann nicht für Arrays innerhalb von UDT-Strukturen oder für ein Array von Interfaces verwendet werden. ARRAY SORT kann jedoch mit Arrays von UDT-Strukturen verwendet werden – behandeln Sie sie einfach so, als wären sie ein Array aus Zeichenfolgen fester Länge.

Um ARRAY SORT für ein eingebettetes UDT-Array zu verwenden, dimensionieren Sie mit DIM..AT ein reguläres Array (des gleichen Typs) direkt „über der Oberseite“ des UDT-Arrays und verwenden Sie ARRAY SORT für dieses Array. Zum Beispiel:

TYP SalesType

Bestellnummer SO LANG

PartNumber(1 TO 20) AS STRING * 20

END-TYP

[Anweisungn]

DIM Sales AS SalesType

[Anweisungn]

DIM Temp(1 TO 20) AS STRING * 20 AT VARPTR(Sales.Partnumber(1))

ARRAY SORT Temp()

Temp() löschen

Siehe auch

  • ARRAY-ZUWEISUNG
  • ARRAY LÖSCHEN
  • ARRAY-EINSATZ
  • ARRAY-SCAN
  • CHR$
  • DIM
  • LBOUND
  • PowerArray
  • REDIM
  • UBOUND

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


Array-Speicheranforderungen – PBXB64-Compiler-Hilfe

Startseite› Funktionen › Array-Speicheranforderungen

Anforderungen an den Array-Speicher

Ein PowerBASIC-Array kann bis zu 4.294.967.295 Elemente enthalten und die Daten können so viel wie den gesamten verfügbaren Speicher belegen. Allerdings müssen alle einzelnen Indexzahlen im Bereich einer langen Ganzzahl liegen

Typ:Schlüsselwort |Kategorie:Variablen und Umfang

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

PowerBASIC speichert Array-Daten für alle Array-Typen (einschließlich LOCAL-Arrays) im Hauptspeicher. Daher gibt es keine willkürliche Array-Größenbeschränkung, die durch die Menge an freiem Stapelspeicherplatz auferlegt wird, wie sie beispielsweise bei großen LOCAL nul-terminated und String-Variablen mit fester Länge auftreten kann. Die Verfügbarkeit des Hauptspeichers steht im Vordergrund (typischerweise können bis zu 2 GB genutzt werden). LOCAL-Arrays erfordern jedoch die Speicherung von etwa 128 Bytes auf dem Stapel für die Array-Deskriptortabelle.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Anforderungen an den Array-Speicher soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Anforderungen an den Array-Speicher mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


ARRAYASSIGN() - PBXB64 Help

Startseite › General Reference › ARRAYASSIGN()
Hilfe zum PBXB64-Compiler

ARRAYASSIGN()

Ausdrucksalias fuer ARRAY ASSIGN bei dynamischen numerischen Arrays. Er nutzt denselben Laufzeithelfer wie die Anweisungsform.

Kind: PowerBASIC feature | Category: PowerBASIC / Tested Feature

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

ok& = ARRAYASSIGN(array(), value1, value2, ...)

Beschreibung

Diese Seite beschreibt das PBXB64-Verhalten, das durch die aktuelle Validierungsmatrix abgedeckt ist. Verwenden Sie die hier gezeigte Syntax fuer Regressionstests; weitergehende PowerBASIC-Formen gelten als separate Kompatibilitaetsarbeit, sofern keine andere Seite sie dokumentiert.

Unterstuetzter Umfang

Die dokumentierte Teilmenge ist absichtlich genau: Beispiele verwenden bevorzugt skalare LONG-Werte, Array-Beispiele benutzen normale PB-logische Indizes, und laufzeitabhaengige Operationen sollen immer den Rueckgabestatus pruefen. Wenn ein Feature sowohl Anweisungs- als auch Funktionsschreibweise besitzt, beschreibt diese Seite den funktionsorientierten Seiteneintrag und verweist auf die breitere BASIC-Referenz.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    DIM a(1 TO 3) AS LONG
    ARRAYASSIGN(a(), 4, 5, 6)
    IF a(2) <> 5 THEN FUNCTION = 1
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_array_function_aliases.pb`.

Fuer Release-Arbeiten sollte jede Syntaxform einen kleinen ausfuehrbaren Test besitzen. Ein guter Test initialisiert alle Eingaben, fuehrt den dokumentierten Befehl oder die Funktion aus, prueft das exakte Ergebnis und liefert bei Fehler einen von Null verschiedenen Exit-Code. Dadurch bleiben Hilfeaussagen an reproduzierbares Verhalten eines isolierten PBXB64-Compilers gebunden.

Grenzen

Nicht gezeigte PowerBASIC-Varianten duerfen aus dieser Seite nicht als unterstuetzt abgeleitet werden. Formen, die hier nicht stehen, benoetigen eigene Implementierung, Diagnostik, Tests und Hilfetext, bevor sie als abgeschlossen beschrieben werden.

Siehe auch

  • BASIC Language Reference
  • Examples

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


ARRAYATTR – PBXB64-Compiler-Hilfe

Startseite› Funktionen › ARRAYATTR

ARRAYATTR

Gibt beschreibende Attribute einer gegebenen Eigenschaft zurück

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:TEILWEISE

PBXB64-Zertifizierung: [TEILWEISE: ATTR 1/2 GETESTET]

Syntax

y = ARRAYATTR( Arr() , AttrNum )

Beschreibung

ARRAYATTR gibt Metadaten für feste und dynamische Arrays zurück. PBXB64 unterstützt die sechs folgenden Deskriptorattribute für Arraynamen als arr oder arr().

AttrNum | Ergebnis
1 | Dimensioniert-Flag: TRUE (-1), wenn das Array aktuell Speicher besitzt, sonst FALSE (0). Dynamische Arrays liefern vor REDIM FALSE.
2 | Element-Typklasse. Vergleichen Sie das Ergebnis mit den eingebauten %VARCLASS_*-Equates wie %VARCLASS_LNG, %VARCLASS_DBL oder %VARCLASS_STR.
3 | Pointer-Array-Flag. Die aktuelle PBXB64-Arrayoberfläche liefert FALSE (0).
4 | Anzahl der Dimensionen. Die fokussiert getestete Oberfläche deckt eindimensionale Arrays und feste zweidimensionale Matrizen ab.
5 | Gesamtzahl der Elemente über alle Dimensionen.
6 | Elementgröße in Bytes.

Verwenden Sie LBOUND und UBOUND für untere und obere Arraygrenzen. Nicht unterstützte oder Nicht-Array-Argumente liefern 0.

Getestetes Beispiel

DIM a(1 TO 5) AS LONG
DIM m(2, 3) AS LONG
LOCAL d() AS LONG

IF ARRAYATTR(d(), 1) <> 0 THEN EXIT FUNCTION
REDIM d(2 TO 6)

IF ARRAYATTR(a(), 1) <> -1 THEN EXIT FUNCTION
IF ARRAYATTR(a(), 2) <> %VARCLASS_LNG THEN EXIT FUNCTION
IF ARRAYATTR(a(), 5) <> 5 THEN EXIT FUNCTION
IF ARRAYATTR(m(), 4) <> 2 THEN EXIT FUNCTION
IF ARRAYATTR(m(), 5) <> 6 THEN EXIT FUNCTION
IF ARRAYATTR(d(), 6) <> 8 THEN EXIT FUNCTION

Siehe auch

  • DIM
  • LBOUND
  • UBOUND
  • PowerArray
  • REDIM

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


Arrays innerhalb benutzerdefinierter Typen – PBXB64-Compiler-Hilfe

Startseite› Funktionen › Arrays innerhalb benutzerdefinierter Typen
Hilfe zum PBXB64-Compiler

Arrays innerhalb benutzerdefinierter Typen

In früheren Versionen dieses Compilers konnten Arrays nicht Teil einer UDT-Struktur sein. Allerdings unterstützen wir jetzt sowohl ein- als auch zweidimensionale Arrays von Variablen mit fester Länge (für jedes Element) –

Typ:Schlüsselwort |Kategorie:Typen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Zweidimensionale Arrays innerhalb von Typen funktionieren genauso wie alle anderen Arrays in PowerBASIC, mit der Ausnahme, dass ihre Dimensionen durch positive numerische Konstantenwerte angegeben werden und daher nicht dynamisch änderbar sind. Das heißt, die Dimensionsgrößen müssen mit numerischen Gleichungen oder numerischen Literalwerten angegeben werden und können zur Laufzeit nicht geändert werden.

Wie bei herkömmlichen Arrays ist die untere Array-Grenze standardmäßig Null, aber positive Werte ungleich Null können verwendet werden, um einen bestimmten Bereich von Indexindexwerten für das Array anzugeben, getrennt vom Index der oberen Array-Grenze mit dem Schlüsselwort TO. Darüber hinaus müssen sowohl der untere als auch der obere Indexwert des Indexes Null oder größer sein (dh negative Indexwerte sind nicht zulässig). Es folgen Beispiele für gültige Syntax:

id AS INTEGER ' Skalares UDT-Mitglied

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Arrays innerhalb benutzerdefinierter Typen soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Arrays innerhalb benutzerdefinierter Typen mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


ARRAYSCAN() - PBXB64 Help

Startseite › General Reference › ARRAYSCAN()
Hilfe zum PBXB64-Compiler

ARRAYSCAN()

Funktionsalias zum Durchsuchen eines numerischen Arrays. Liefert den PB-logischen Index des gesuchten Werts oder 0, wenn der Wert nicht gefunden wird.

Kind: PowerBASIC feature | Category: PowerBASIC / Tested Feature

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

index& = ARRAYSCAN(array(), value)

Beschreibung

Diese Seite beschreibt das PBXB64-Verhalten, das durch die aktuelle Validierungsmatrix abgedeckt ist. Verwenden Sie die hier gezeigte Syntax fuer Regressionstests; weitergehende PowerBASIC-Formen gelten als separate Kompatibilitaetsarbeit, sofern keine andere Seite sie dokumentiert.

Unterstuetzter Umfang

Die dokumentierte Teilmenge ist absichtlich genau: Beispiele verwenden bevorzugt skalare LONG-Werte, Array-Beispiele benutzen normale PB-logische Indizes, und laufzeitabhaengige Operationen sollen immer den Rueckgabestatus pruefen. Wenn ein Feature sowohl Anweisungs- als auch Funktionsschreibweise besitzt, beschreibt diese Seite den funktionsorientierten Seiteneintrag und verweist auf die breitere BASIC-Referenz.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    DIM a(1 TO 3) AS LONG
    ARRAY ASSIGN a() = 10, 20, 30
    IF ARRAYSCAN(a(), 20) <> 2 THEN FUNCTION = 1
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_arrayscan_function_alias.pb`.

Fuer Release-Arbeiten sollte jede Syntaxform einen kleinen ausfuehrbaren Test besitzen. Ein guter Test initialisiert alle Eingaben, fuehrt den dokumentierten Befehl oder die Funktion aus, prueft das exakte Ergebnis und liefert bei Fehler einen von Null verschiedenen Exit-Code. Dadurch bleiben Hilfeaussagen an reproduzierbares Verhalten eines isolierten PBXB64-Compilers gebunden.

Grenzen

Nicht gezeigte PowerBASIC-Varianten duerfen aus dieser Seite nicht als unterstuetzt abgeleitet werden. Formen, die hier nicht stehen, benoetigen eigene Implementierung, Diagnostik, Tests und Hilfetext, bevor sie als abgeschlossen beschrieben werden.

Siehe auch

  • BASIC Language Reference
  • Examples

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


ARRAYSHIFT() - PBXB64 Help

Startseite › General Reference › ARRAYSHIFT()
Hilfe zum PBXB64-Compiler

ARRAYSHIFT()

Ausdrucksalias zum Verschieben von Elementen dynamischer LONG-Arrays nach links oder rechts.

Kind: PowerBASIC feature | Category: PowerBASIC / Tested Feature

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

ok& = ARRAYSHIFT(array(), direction, count)

Beschreibung

Diese Seite beschreibt das PBXB64-Verhalten, das durch die aktuelle Validierungsmatrix abgedeckt ist. Verwenden Sie die hier gezeigte Syntax fuer Regressionstests; weitergehende PowerBASIC-Formen gelten als separate Kompatibilitaetsarbeit, sofern keine andere Seite sie dokumentiert.

Unterstuetzter Umfang

Die dokumentierte Teilmenge ist absichtlich genau: Beispiele verwenden bevorzugt skalare LONG-Werte, Array-Beispiele benutzen normale PB-logische Indizes, und laufzeitabhaengige Operationen sollen immer den Rueckgabestatus pruefen. Wenn ein Feature sowohl Anweisungs- als auch Funktionsschreibweise besitzt, beschreibt diese Seite den funktionsorientierten Seiteneintrag und verweist auf die breitere BASIC-Referenz.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    DIM a(1 TO 3) AS LONG
    ARRAYASSIGN(a(), 1, 2, 3)
    ARRAYSHIFT(a(), 1, 1)
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_array_function_aliases.pb`.

Fuer Release-Arbeiten sollte jede Syntaxform einen kleinen ausfuehrbaren Test besitzen. Ein guter Test initialisiert alle Eingaben, fuehrt den dokumentierten Befehl oder die Funktion aus, prueft das exakte Ergebnis und liefert bei Fehler einen von Null verschiedenen Exit-Code. Dadurch bleiben Hilfeaussagen an reproduzierbares Verhalten eines isolierten PBXB64-Compilers gebunden.

Grenzen

Nicht gezeigte PowerBASIC-Varianten duerfen aus dieser Seite nicht als unterstuetzt abgeleitet werden. Formen, die hier nicht stehen, benoetigen eigene Implementierung, Diagnostik, Tests und Hilfetext, bevor sie als abgeschlossen beschrieben werden.

Siehe auch

  • BASIC Language Reference
  • Examples

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


ARRAYSHUFFLE() - PBXB64 Help

Startseite › General Reference › ARRAYSHUFFLE()
Hilfe zum PBXB64-Compiler

ARRAYSHUFFLE()

Ausdrucksalias zum Mischen eines dynamischen LONG-Arrays mit dem PBXB64-Array-Laufzeithelfer.

Kind: PowerBASIC feature | Category: PowerBASIC / Tested Feature

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

ok& = ARRAYSHUFFLE(array())

Beschreibung

Diese Seite beschreibt das PBXB64-Verhalten, das durch die aktuelle Validierungsmatrix abgedeckt ist. Verwenden Sie die hier gezeigte Syntax fuer Regressionstests; weitergehende PowerBASIC-Formen gelten als separate Kompatibilitaetsarbeit, sofern keine andere Seite sie dokumentiert.

Unterstuetzter Umfang

Die dokumentierte Teilmenge ist absichtlich genau: Beispiele verwenden bevorzugt skalare LONG-Werte, Array-Beispiele benutzen normale PB-logische Indizes, und laufzeitabhaengige Operationen sollen immer den Rueckgabestatus pruefen. Wenn ein Feature sowohl Anweisungs- als auch Funktionsschreibweise besitzt, beschreibt diese Seite den funktionsorientierten Seiteneintrag und verweist auf die breitere BASIC-Referenz.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    DIM a(1 TO 3) AS LONG
    ARRAYASSIGN(a(), 1, 2, 3)
    ARRAYSHUFFLE(a())
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_array_function_aliases.pb`.

Fuer Release-Arbeiten sollte jede Syntaxform einen kleinen ausfuehrbaren Test besitzen. Ein guter Test initialisiert alle Eingaben, fuehrt den dokumentierten Befehl oder die Funktion aus, prueft das exakte Ergebnis und liefert bei Fehler einen von Null verschiedenen Exit-Code. Dadurch bleiben Hilfeaussagen an reproduzierbares Verhalten eines isolierten PBXB64-Compilers gebunden.

Grenzen

Nicht gezeigte PowerBASIC-Varianten duerfen aus dieser Seite nicht als unterstuetzt abgeleitet werden. Formen, die hier nicht stehen, benoetigen eigene Implementierung, Diagnostik, Tests und Hilfetext, bevor sie als abgeschlossen beschrieben werden.

Siehe auch

  • BASIC Language Reference
  • Examples

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


ARRAYSWAP() - PBXB64 Help

Startseite › General Reference › ARRAYSWAP()
Hilfe zum PBXB64-Compiler

ARRAYSWAP()

Ausdrucksalias zum Tauschen zweier Elemente in einem dynamischen LONG-Array.

Kind: PowerBASIC feature | Category: PowerBASIC / Tested Feature

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

ok& = ARRAYSWAP(array(), index1, index2)

Beschreibung

Diese Seite beschreibt das PBXB64-Verhalten, das durch die aktuelle Validierungsmatrix abgedeckt ist. Verwenden Sie die hier gezeigte Syntax fuer Regressionstests; weitergehende PowerBASIC-Formen gelten als separate Kompatibilitaetsarbeit, sofern keine andere Seite sie dokumentiert.

Unterstuetzter Umfang

Die dokumentierte Teilmenge ist absichtlich genau: Beispiele verwenden bevorzugt skalare LONG-Werte, Array-Beispiele benutzen normale PB-logische Indizes, und laufzeitabhaengige Operationen sollen immer den Rueckgabestatus pruefen. Wenn ein Feature sowohl Anweisungs- als auch Funktionsschreibweise besitzt, beschreibt diese Seite den funktionsorientierten Seiteneintrag und verweist auf die breitere BASIC-Referenz.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    DIM a(1 TO 2) AS LONG
    ARRAYASSIGN(a(), 10, 20)
    ARRAYSWAP(a(), 1, 2)
    IF a(1) <> 20 THEN FUNCTION = 1
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_array_function_aliases.pb`.

Fuer Release-Arbeiten sollte jede Syntaxform einen kleinen ausfuehrbaren Test besitzen. Ein guter Test initialisiert alle Eingaben, fuehrt den dokumentierten Befehl oder die Funktion aus, prueft das exakte Ergebnis und liefert bei Fehler einen von Null verschiedenen Exit-Code. Dadurch bleiben Hilfeaussagen an reproduzierbares Verhalten eines isolierten PBXB64-Compilers gebunden.

Grenzen

Nicht gezeigte PowerBASIC-Varianten duerfen aus dieser Seite nicht als unterstuetzt abgeleitet werden. Formen, die hier nicht stehen, benoetigen eigene Implementierung, Diagnostik, Tests und Hilfetext, bevor sie als abgeschlossen beschrieben werden.

Siehe auch

  • BASIC Language Reference
  • Examples

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


ARRAYUNIQUE() - PBXB64 Help

Startseite › General Reference › ARRAYUNIQUE()
Hilfe zum PBXB64-Compiler

ARRAYUNIQUE()

Ausdrucksalias zum Entfernen benachbarter doppelter numerischer Elemente nach Sortierung oder Gruppierung.

Kind: PowerBASIC feature | Category: PowerBASIC / Tested Feature

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

newCount& = ARRAYUNIQUE(array())

Beschreibung

Diese Seite beschreibt das PBXB64-Verhalten, das durch die aktuelle Validierungsmatrix abgedeckt ist. Verwenden Sie die hier gezeigte Syntax fuer Regressionstests; weitergehende PowerBASIC-Formen gelten als separate Kompatibilitaetsarbeit, sofern keine andere Seite sie dokumentiert.

Unterstuetzter Umfang

Die dokumentierte Teilmenge ist absichtlich genau: Beispiele verwenden bevorzugt skalare LONG-Werte, Array-Beispiele benutzen normale PB-logische Indizes, und laufzeitabhaengige Operationen sollen immer den Rueckgabestatus pruefen. Wenn ein Feature sowohl Anweisungs- als auch Funktionsschreibweise besitzt, beschreibt diese Seite den funktionsorientierten Seiteneintrag und verweist auf die breitere BASIC-Referenz.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    DIM a(1 TO 4) AS LONG
    ARRAYASSIGN(a(), 1, 1, 2, 2)
    IF ARRAYUNIQUE(a()) <> 2 THEN FUNCTION = 1
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_array_function_aliases.pb` und numerische ARRAY UNIQUE-Tests.

Fuer Release-Arbeiten sollte jede Syntaxform einen kleinen ausfuehrbaren Test besitzen. Ein guter Test initialisiert alle Eingaben, fuehrt den dokumentierten Befehl oder die Funktion aus, prueft das exakte Ergebnis und liefert bei Fehler einen von Null verschiedenen Exit-Code. Dadurch bleiben Hilfeaussagen an reproduzierbares Verhalten eines isolierten PBXB64-Compilers gebunden.

Grenzen

Nicht gezeigte PowerBASIC-Varianten duerfen aus dieser Seite nicht als unterstuetzt abgeleitet werden. Formen, die hier nicht stehen, benoetigen eigene Implementierung, Diagnostik, Tests und Hilfetext, bevor sie als abgeschlossen beschrieben werden.

Siehe auch

  • BASIC Language Reference
  • Examples

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


ASCII - Byte-String-Zeichenspeicher waehlen — PBXB64 Help

Startseite › General Reference › ASCII - Byte-String-Zeichenspeicher waehlen — PBXB64 Help
Hilfe zum PBXB64-Compiler

ASCII - Byte-String-Zeichenspeicher waehlen

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

LOCAL s AS ASCII STRING

Detailverhalten

Typkeyword fuer ASCII-String-Kompatibilitaet.

Praktische Verwendung

Verwenden Sie ASCII in Deklarationen, wenn ein Byte-String mit kompatibler Speicherform erwartet wird. Die eigentliche Interaktion laesst sich am besten mit einer Deklaration und einer anschliessenden Stringzuweisung pruefen.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Verwechseln Sie diese Typkeywords nicht mit freien Bezeichnern oder Laufzeitwerten. Wenn der Zielkontext die Type-Position nicht erwartet, muss die Quelle entsprechend angepasst werden.

Verifiziertes Beispiel

Abgedeckt durch PB keyword compatibility (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Nullterminierte Zeichenfolgen – Hilfe zum PBXB64-Compiler

Startseite› Funktionen › Nullterminierte Strings

Nullterminierte Zeichenfolgen

Eine mit Null terminierte Zeichenfolge wird als STRINGZ mit ANSI-Zeichen oder WSTRINGZ mit WIDE-Unicode-Zeichen bezeichnet. Wenn sie mit ANSI-Zeichen deklariert werden, werden sie allgemein als ASCIIZ-Zeichenfolgen bezeichnet. Du kannst das

Typ:Schlüsselwort |Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Wenn Sie eine Zeichenfolge zuweisen, die kürzer als die definierte Länge ist, wird die Zeichenfolge rechts nicht aufgefüllt. Der Inhalt des restlichen Zeichenfolgenpuffers ist unbestimmt. Da eine NulTerm-Zeichenfolge ein NUL-Terminator erfordert, werden sie normalerweise mit einer Länge von mindestens zwei Zeichen definiert.

Sie deklarieren STRINGZ-Variablen mit den Schlüsselwörtern STRINGZ oder WSTRINGZ mit der DIM-Anweisung. Zum Beispiel:

DIM MyStr1 AS STRINGZ * 40

DIM MyStr2 AS WSTRINGZ * 40

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Nullterminierte Zeichenfolgen soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Nullterminierte Zeichenfolgen mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


ASSERT - PBXB64 Help

Startseite › General Reference › ASSERT

ASSERT

Prueft eine Bedingung zur Laufzeit. Wahre Assertions laufen weiter; falsche Assertions beenden das Programm ueber den PBXB64-Assertion-Fehlerpfad.

Kind: PowerBASIC feature | Category: PowerBASIC / Tested Feature

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

ASSERT condition
ASSERT condition, "message"

Beschreibung

Diese Seite beschreibt das PBXB64-Verhalten, das durch die aktuelle Validierungsmatrix abgedeckt ist. Verwenden Sie die hier gezeigte Syntax fuer Regressionstests; weitergehende PowerBASIC-Formen gelten als separate Kompatibilitaetsarbeit, sofern keine andere Seite sie dokumentiert.

Unterstuetzter Umfang

Die dokumentierte Teilmenge ist absichtlich genau: Beispiele verwenden bevorzugt skalare LONG-Werte, Array-Beispiele benutzen normale PB-logische Indizes, und laufzeitabhaengige Operationen sollen immer den Rueckgabestatus pruefen. Wenn ein Feature sowohl Anweisungs- als auch Funktionsschreibweise besitzt, beschreibt diese Seite den funktionsorientierten Seiteneintrag und verweist auf die breitere BASIC-Referenz.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ASSERT 2 + 2 = 4, "arithmetic invariant"
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_assert_pass.pb` und `test_assert_fail.pb`.

Fuer Release-Arbeiten sollte jede Syntaxform einen kleinen ausfuehrbaren Test besitzen. Ein guter Test initialisiert alle Eingaben, fuehrt den dokumentierten Befehl oder die Funktion aus, prueft das exakte Ergebnis und liefert bei Fehler einen von Null verschiedenen Exit-Code. Dadurch bleiben Hilfeaussagen an reproduzierbares Verhalten eines isolierten PBXB64-Compilers gebunden.

Grenzen

Nicht gezeigte PowerBASIC-Varianten duerfen aus dieser Seite nicht als unterstuetzt abgeleitet werden. Formen, die hier nicht stehen, benoetigen eigene Implementierung, Diagnostik, Tests und Hilfetext, bevor sie als abgeschlossen beschrieben werden.

Siehe auch

  • BASIC Language Reference
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Balancing the stack - PBXB64 Compiler Help

Startseite › Functions › Balancing the stack

Balancing the stack

An important consideration when using the stack is to be symmetrical in the byte count of what is pushed and what is popped.

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

If the stack is not balanced on exit from an assembly code block (i.e., you POP too few or too many registers ), your routine will return to the wrong location in your code. This is because PowerBASIC must assume that the last item on the stack is the address to which it should return.

In other words, if the stack is not balanced on exit from an assembly code block, program execution is likely to resume at the wrong address and instantly crash the program. In most instances, if you PUSH a given data size onto the stack, you must POP the same data size.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Balancing the stack soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Balancing the stack mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


BASE64$ - PBXB64 Help

Startseite › General Reference › BASE64$

BASE64$

Kodiert eine Zeichenkette als Base64 und liefert den kodierten Text.

Kind: Runtime helper | Category: WEB / Runtime Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

encoded$ = BASE64$(text$)

Beschreibung

Diese eigene Seite stellt sicher, dass Befehlsuche, Stichwortindex und direkte Dateinamenpruefung die getestete Laufzeitfunktion unmittelbar finden. Die gruppierte WEB-Seite bleibt die breitere Familienreferenz.

Diese Seite dokumentiert einen deterministischen String-Helfer. Kodierungsfunktionen liefern transformierten Text zurueck, waehrend Hash-Funktionen feste, kleingeschriebene Hex-Digests liefern.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL rc AS LONG
    encoded$ = BASE64$("PBXB64")
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_web_all.pb`.

Grenzen

Dokumentieren Sie hier nur die getesteten Byte- oder String-Transformationen. Wenn es einen Rueckwaerts-Helfer gibt, pruefen Sie ihn separat, statt Symmetrie aus der Vorwaertsform abzuleiten.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

BASE64$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

BASE64$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer encoding-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

BASE64$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


BASE64URLSAFE$ - PBXB64 Help

Startseite › General Reference › BASE64URLSAFE$

BASE64URLSAFE$

Erzeugt URL-sicheren Base64-Text fuer Token und Query-Werte.

Kind: Runtime helper | Category: WEB / Runtime Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

encoded$ = BASE64URLSAFE$(text$)

Beschreibung

Diese eigene Seite stellt sicher, dass Befehlsuche, Stichwortindex und direkte Dateinamenpruefung die getestete Laufzeitfunktion unmittelbar finden. Die gruppierte WEB-Seite bleibt die breitere Familienreferenz.

Diese Seite dokumentiert einen deterministischen String-Helfer. Kodierungsfunktionen liefern transformierten Text zurueck, waehrend Hash-Funktionen feste, kleingeschriebene Hex-Digests liefern.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL rc AS LONG
    encoded$ = BASE64URLSAFE$("a+b/c")
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_web_all.pb`.

Grenzen

Dokumentieren Sie hier nur die getesteten Byte- oder String-Transformationen. Wenn es einen Rueckwaerts-Helfer gibt, pruefen Sie ihn separat, statt Symmetrie aus der Vorwaertsform abzuleiten.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

BASE64URLSAFE$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

BASE64URLSAFE$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer encoding-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

BASE64URLSAFE$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


BEEP - PBXB64 Compiler Help

Startseite › Functions › BEEP

BEEP

Sound a tone through the computer's speaker.

Typ:Anweisung |Kategorie: Utilities

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

BEEP

Beschreibung

BEEP plays the default Windows waveform sound, typically a ? second tone, through either the built-in speaker; or a sound card if installed (in which case the Windows "Default Beep" sound is played). The Default Beep can be configured in the Sounds section of Control Panel.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BGR - PBXB64 Compiler Help

Startseite › Functions › BGR

BGR

Create a BGR

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

result& = BGR( red& , green& , blue& )
result& = BGR( rgbexpr& )

Beschreibung

An RGB value is a long integer value in the range of 0 to &H00FFFFFF. It is used to specify a very precise color to various PowerBASIC functions and Windows API functions. The lowest three bytes of the value each specify the intensity of a primary color which combine to form the resultant color. Byte 1 (lowest) represents the red component, byte 2 the green, and byte 3 the blue. They can each take on a value in the range of 0 to 255. Byte 4 (highest) is always 0.

Some Windows API functions, such as those which reference Device Independent Bitmaps (DIB), require that the colors be specified in the reverse sequence (Blue-Green-Red instead of Red-Green-Blue). In order to maximize performance and execution speed, PowerBASIC statements and functions which reference these structures also use the BGR format. These include GRAPHIC GET BITS and GRAPHIC SET BITS . When used with 3 parameters, the BGR() function creates a BGR value from the three component values.

When used with one parameter, this function translates an RGB value to its BGR equivalent by swapping the first byte with the third byte, and returning the result.

For example, the RGB value of blue is &HFF0000. BGR() translates it to &H0000FF. Calling RGB() with that value converts it back to &HFF0000.

Siehe auch

  • Built In RGB Color Equates
  • RGB

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BIN$ - PBXB64 Compiler Help

Startseite › Functions › BIN$

BIN$

Convert an integral value to a binary string

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = BIN$( IntVal [, Digits , LeadSpaces , TrailSpaces ])

Beschreibung

IntVal is a numeric expression in the range of a 64-bit Quad Integer (-9223372036854775808 to +9223372036854775807). Any fractional part of the value is rounded. The result string is always formatted as an integral number using all the significant digits in IntVal . It is never expressed in scientific notation.

If Digits is 0 (or not given), no leading characters will be added to the numeric field. If Digits is a positive number greater than 0, the result string will be prepended with leading zeros to achieve the desired length. If Digits is a negative number, leading spaces are added to reach the absolute length. Digits may be in the range of -64 to +64.

LeadSpaces specifies additional leading spaces to be prepended, regardless of the length of the numeric portion of the string.

TrailSpaces specifies additional trailing spaces to be appended to the end of the string.

Siehe auch

  • DEC$
  • FORMAT$
  • HEX$
  • OCT$
  • STR$
  • TRIM$
  • USING$
  • VAL

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Binary Files - PBXB64 Compiler Help

Startseite › Functions › Binary Files

Binary Files

PowerBASIC's binary file technique, an extension to Interpretive BASIC, allows you to treat any file as a numbered sequence of bytes without regard to anything, including the following: ASCII characte

Typ:Schlüsselwort |Kategorie:Datei-E/A

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Flexibility always comes at a price. Binary files require that you do all the work to decide what goes where. Binary may be the best option when dealing with alien files that aren't in ASCII format; for example, a file created by a spreadsheet or database product. Of course, you will have to know the precise structure of the file before you can even attempt to break it down into numbers and strings agreeable to PowerBASIC.

Every file opened in binary mode has an associated position indicator that points to the place in the file that will be read or written to next. Use the SEEK statement to set the position indicator, and the SEEK function to read it.

Binary files are accessed in the following way:

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Binary Files soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Binary Files mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


BIT - PBXB64 Compiler Help

Startseite › Functions › BIT

BIT

Manipulate individual bits of an integral class

Typ:Anweisung |Kategorie:Mathematik und Numerik

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

BIT {SET | RESET | TOGGLE} intvar , bitnumber

Beschreibung

intvar must be one of the integral-class variable types: Byte , Word , Integer , Double-word , Long-integer , or Quad-integer .

The allowable range for the parameter bitnumber is the same as that of a Long-integer, making it possible to have implicit bit-arrays of more than 2 billion bits in size. Bits 0 to 15 are in the first word starting at intvar , bits 16-31 are in the next word, and so forth.

Es wird davon ausgegangen, dass implizite Bit-Arrays an der Speicherposition der Variablen intvar beginnen. Wenn intvar beispielsweise selbst eine Array-Variable ist, ist es möglich, auf Bits in jedem der folgenden Elemente des Arrays zuzugreifen. Siehe die Array-Beispiele unten.

Es muss darauf geachtet werden, dass die Bitindexnummer (bitnumber) die Anzahl der Bits, auf die gültig zugegriffen werden kann, nicht überschreitet. Beispielsweise kann das Anpassen des 17. Bits einer 16-Bit-Skalarvariablen zu einem geringfügigen Speicherbeschädigungsproblem führen und/oder eine allgemeine Schutzverletzung (GPF) auslösen. Ebenso kann das Anpassen des 4097. Bits eines Bit-Arrays, das von einem 128-Elemente-DWORD-Array abgeleitet ist, ähnliche Probleme verursachen. Bitnummer ist immer nullbasiert, daher wird in der BIT-Anweisung auf das 129. Bit eines impliziten Bit-Arrays verwiesen, wobei die Bitnummer gleich 128 ist. Beispiel: BIT SET A?(1), 128.

Setzt das angegebene Bit auf Eins.

Setzt das Angezeigte Bit auf Null.

TOGGLE

Schaltet das angezeigte Bit um: Eins wird Null; Aus Null wird Eins.

Siehe auch

  • BIT CALC-Anweisung
  • BIT-Funktion

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BIT CALC - PBXB64 Compiler-Hilfe

Startseite › Funktionen › BIT CALC

BIT CALC

Set oder ein Bit in einer ganzzahligen Klasse zurücksetzen

Typ:Anweisung |Kategorie:Mathematik und Numerik

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

BIT CALC intvar , bitnumber , calcexpr

Beschreibung

BIT CALC verhält sich wie eine Kombination der Anweisungen BIT SET und BIT RESET und bietet die Wahl zwischen Setzen (1) und Zurücksetzen (0) entsprechend dem Ergebnis einer Zahl expression.

intvar

Eine ganzzahlige Klassenvariable ( Byte , Word , Double-word , Integer , Long-integer oder Quad-integer ) oder eine Variable, die die Basis einer impliziten Variable bildet bit-array.

bitnumber

Ein ganzzahliger Klassenausdruck oder ein numerisches Literal, das die anzupassende Bitnummer angibt. Bitnummern beginnen bei Null (0) und erstrecken sich bis zur Größe der Zielvariablen oder des Bit-Arrays. Beispielsweise verwendet eine 16-Bit-Integer-Variable den Bereich von 0 bis 15. Ein implizites Bit-Array bestehend aus einem Long-Integer-Array mit 100 Elementen (4 Bytes * 100 = 400 Bytes = 3200 Bits) deckt den Bitbereich von 0 bis ab 3199.

calcexpr

Der vom Bit Null von calcexpr abgeleitete Wert bestimmt die Setz- oder Rücksetzaktion. Wenn Bit Null eine Null (0) enthält, wird das Bit in intvar zurückgesetzt; Wenn das Bit Null in calcexpr eine Eins (1) enthält, wird das Bit in intvar gesetzt. Diese Aktion kann man sich leichter merken, wenn man bedenkt, dass PowerBASIC eine implizite bitweise UND-Operation ( calcexpr AND 1) ausführt, um die Setz- oder Rücksetzaktion abzuleiten.

Es muss darauf geachtet werden, dass die Bitindexnummer ( bitnumber ) die Anzahl der Bits, auf die gültig zugegriffen werden kann, nicht überschreitet. Beispielsweise kann das Lesen des 17. Bits einer 16-Bit-Skalarvariablen eine allgemeine Schutzverletzung (GPF) auslösen. Ebenso kann das Anpassen des 4097. Bits eines Bit-Arrays, das von einem 128-Elemente-DWORD-Array abgeleitet ist, ähnliche Probleme verursachen. Bitnummer ist immer nullbasiert, daher wird in der BIT-Anweisung auf das 129. Bit eines impliziten Bit-Arrays mit der Bitnummer gleich 128 verwiesen. Beispiel: x& = BIT(A?(1), 128).

Siehe auch

  • BIT-Funktion
  • BIT-Anweisung
  • BITS Funktionen

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Bit-Datentypen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Bitdatentypen

Bitdatentypen

TYPE- und UNION-Strukturen können Bitvariablen enthalten, die BIT (vorzeichenlose Werte) oder SBIT (vorzeichenbehaftete Werte) heißen. Jede Bitvariable kann 1 bis 31 Bits belegen. Bei Verwendung in einem TYPE sind Bitvariablen a

Typ:Schlüsselwort |Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Bit variables may only be used as TYPE or UNION members, not as scalar, array, or pointer variables. The size of a bit variable is defined as:

var AS BIT * nlit [IN BYTE|WORD|DWORD]

where the term "* nlit" defines the number of bits (1 to 31), and the optional term "IN BYTE|WORD|DWORD", if present, defines the start of a new bit field of 1, 2, or 4 bytes.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Bitdatentypen soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Bitdatentypen mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


BITS - PBXB64 Compiler Help

Startseite › Functions › BITS

BITS

Converts an integral value into another data type, based upon the bit pattern of the value. This is particularly helpful in converting between signed and unsigned representations.

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

resultvar = BITS( datatype , expression )

Beschreibung

Since the integer value -1 and word value 65535 have the identical bit pattern of 1111111111111111, BITS(WORD,-1) would return the unsigned word value of 65535. Of course, BITS(INTEGER,65535) would then return the integer value -1. Other values and data types would follow the same pattern and rules.

This newer form of BITS condenses the functionality of the older forms (BITS%, BITS&, BITS?, BITS?? and BITS???) into a single function. In particular, this provides for the addition of new data types in future version of PowerBASIC, particularly those which may not have an associated type-specifier character.

Siehe auch

  • BIT CALC-Anweisung
  • BIT-Funktion
  • BIT-Anweisung
  • BITS$
  • BITSE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BITSE - PBXB64 Compiler Help

Startseite › Functions › BITSE

BITSE

Compare integral values for equivalent bits regardless of sign.

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

x& = BITSE( nexp , nexp , bitsize )

Beschreibung

This function allows you to compare two integral values for equivalent bit patterns, regardless of whether they are signed or unsigned values. The two numeric expressions ( nexp ) are the integral values to be compared, The bitsize parameter specifies the number of bits to be compared, 8, 16, or 32.

For example, the integer value -1 and the word value 65535 both have the identical bit pattern: 1111111111111111. The difference is simply the way the bits are interpreted by a program.

x& = BITSE( -1, 65535, 16)

The above example would cause the lowest 16 bits of the expressions to be compared. Since they are equal, the value TRUE (-1) is returned.

Siehe auch

  • BITS

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


#BLOAT - PBXB64 Compiler Help

Startseite › Functions › #BLOAT

#BLOAT

Artificially inflate the disk image size of a compiled program.

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

#BLOAT size_expression

Beschreibung

#BLOAT allows the creation of artificially bloated program files on disk, in order to match or exceed that generated by competing " BloatWare " compilers. #BLOAT does not affect the memory image size (running size) of a compiled program.

size_expression

The size_expression parameter is a simple Long-integer expression that specifies the total desired size of the compiled programs disk image, but is ignored if it is smaller than the actual program size. #BLOAT uses sections of the actual compiled code to fill and obfuscate the portion added to the file.

While #BLOAT adds no true merit to the technical efficiency of the compiled code, there are a number of reasons for its use, including:

Siehe auch

  • #COMPILE EXE
  • #OPTIMIEREN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BOUNDED - PBXB64 Help

Startseite › General Reference › BOUNDED

BOUNDED

Liefert PB-Wahr (-1), wenn ein Wert innerhalb eines inklusiven numerischen Bereichs liegt, andernfalls PB-Falsch (0).

Kind: PowerBASIC feature | Category: PowerBASIC / Tested Feature

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result& = BOUNDED(value, low, high)

Beschreibung

Diese Seite beschreibt das PBXB64-Verhalten, das durch die aktuelle Validierungsmatrix abgedeckt ist. Verwenden Sie die hier gezeigte Syntax fuer Regressionstests; weitergehende PowerBASIC-Formen gelten als separate Kompatibilitaetsarbeit, sofern keine andere Seite sie dokumentiert.

Unterstuetzter Umfang

Die dokumentierte Teilmenge ist absichtlich genau: Beispiele verwenden bevorzugt skalare LONG-Werte, Array-Beispiele benutzen normale PB-logische Indizes, und laufzeitabhaengige Operationen sollen immer den Rueckgabestatus pruefen. Wenn ein Feature sowohl Anweisungs- als auch Funktionsschreibweise besitzt, beschreibt diese Seite den funktionsorientierten Seiteneintrag und verweist auf die breitere BASIC-Referenz.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    IF BOUNDED(5, 1, 10) = 0 THEN FUNCTION = 1
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_bounded.pb`, einschliesslich Grenzwert-, Ausserhalb-, Variablen- und low = high-Faellen.

Fuer Release-Arbeiten sollte jede Syntaxform einen kleinen ausfuehrbaren Test besitzen. Ein guter Test initialisiert alle Eingaben, fuehrt den dokumentierten Befehl oder die Funktion aus, prueft das exakte Ergebnis und liefert bei Fehler einen von Null verschiedenen Exit-Code. Dadurch bleiben Hilfeaussagen an reproduzierbares Verhalten eines isolierten PBXB64-Compilers gebunden.

Grenzen

Nicht gezeigte PowerBASIC-Varianten duerfen aus dieser Seite nicht als unterstuetzt abgeleitet werden. Formen, die hier nicht stehen, benoetigen eigene Implementierung, Diagnostik, Tests und Hilfetext, bevor sie als abgeschlossen beschrieben werden.

Siehe auch

  • BASIC Language Reference
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BRIDGE - PBXB64-Compiler-Hilfe

Startseite › BASIC Frontend › Befehlsreferenz › Datentypen & Variablen › BRIDGE
Hilfe zum PBXB64-Compiler

BRIDGE

Deklariert expliziten gemeinsam genutzten Speicher fuer mehrere Frontends.

Typ: Anweisung | Kategorie: Variablen und Geltungsbereich

PBXB64-Status: VERFUEGBAR, getestete begrenzte BASIC/C-Bridge

PBXB64-Zertifizierung: [BEGRENZT GETESTET]

Syntax

BRIDGE EXPORT name AS type [ALIAS "symbol"]
BRIDGE IMPORT name AS type ALIAS "symbol"

Beschreibung

BRIDGE EXPORT erzeugt vom Compiler verwalteten globalen Speicher mit einem expliziten Objektsymbol. BRIDGE IMPORT bindet einen BASIC-Namen an extern bereitgestellten Speicher. Wenn eine BASIC-Quelle zusammen mit C-Nebeneingaben kompiliert wird, erzeugt PBXB64 einen C-Bridge-Header und fuegt ihn automatisch in die C-Uebersetzung ein. Die generierten C-Deklarationen enthalten _Static_assert(sizeof(symbol) == n)-Pruefungen; widerspruechliche C-Deklarationen im Benutzercode werden zur Compile-Zeit abgelehnt. Rust-Nebeneingaben erhalten generierte extern "PBXB64" static mut-Bridge-Deklarationen vor der Benutzer-Rust-Quelle; passende Benutzerdeklarationen bleiben gueltig, falsche Deklarationen schlagen zur Compile-Zeit fehl. Rust-Festpufferdeklarationen werden fuer getesteten BASIC-eigenen STRINGZ * n-Speicher und C-eigene, von BASIC importierte Festpuffer als [i8; n]-Extern-Statics erzeugt. Standalone-ASM kann getesteten Bridge-Speicher ueber das dokumentierte Objektsymbol mit .extern verwenden; das deckt BASIC-eigene Exporte sowie C-eigene skalare und feste Imports ab. Forth-Nebeneingaben erhalten generierte Bridge-Deklarationen und koennen getesteten 64-Bit-Integer-Bridge-Speicher mit BRIDGE@ symbol und value BRIDGE! symbol sowie getesteten DOUBLE-breiten Bridge-Speicher mit BRIDGE@F64 symbol und value BRIDGE!F64 symbol lesen und schreiben; das schliesst BASIC-Exporte und C-eigene skalare Imports ein. Feste Forth-Pufferdeklarationen stellen BRIDGEADDR symbol und BRIDGELEN symbol fuer getesteten Bytezugriff mit C@/C! bereit. Pointer-Bridge-Slots stellen BRIDGEPTR symbol bereit; das Wort legt den gespeicherten Pointerwert fuer getestete Byte-Schreibzugriffe durch eine BASIC-Pufferadresse auf den Stack. Eingebettetes Forth nutzt typisierte PB-Lokal-Woerter wie PBVALI64, PBSETI64, PBVALF64 und PBSETF64 fuer die fokussierte Skalar-Bridge.

Die getestete V14-Oberflaeche unterstuetzt skalare Integer-, Gleitkomma-, Pointer-, BOOL-, CURRENCY- und feste STRINGZ * n-Deklarationen fuer exportierten oder importierten Objektspeicher. Pointer-Bridge-Speicher ist als 8-Byte-Objektslot getestet, wird fuer C als void* bereitgestellt und fuer Rust als usize erzeugt, sodass Rust die gespeicherte Adresse fuer getestete Byte-Schreibzugriffe zu einem Raw-Pointer casten kann. Feste Puffer werden fuer C-Bridge-Header als Byte-Arrays erzeugt und sind gegen C-eigene Byte-Arrays sowie COBOL-PIC X(n) EXTERNAL-Speicher getestet. Generierte C- und Rust-Deklarationen enthalten nur Bridge-Aliase, die in der jeweiligen Quellsprache gueltige Bezeichner sind; COBOL-artige Aliase mit Bindestrichen bleiben fuer COBOL und den Linker verfuegbar, ohne C- oder Rust-Nebeneingaben zu stoeren. Ein Bridge-Alias hat in einer BASIC-Uebersetzungseinheit genau einen Besitzer; dasselbe Alias darf nicht sowohl als BRIDGE EXPORT als auch als BRIDGE IMPORT deklariert werden. BRIDGE IMPORT ist nur eine Deklaration: ein anderes Objekt im selben Link muss das Alias-Symbol definieren, sonst bricht der Link mit einer Unresolved-Symbol-Diagnose ab. Verwaltete dynamische Strings, Arrays, UDTs und Aggregat-Schreibzugriffe bleiben ausserhalb dieser fokussierten Oberflaeche, bis sie einen eigenen getesteten Laufzeitvertrag haben.

Verifiziertes Beispiel: BASIC-Export wird von C geaendert

Beispieldateien: tests/pb/test_bridge_basic_c_export.pb, tests/c/bridge_basic_c_export.c, tests/pb/test_bridge_basic_c_export_bool_currency.pb, tests/c/bridge_basic_c_export_bool_currency.c, tests/pb/test_bridge_c_import_stringz.pb, tests/pb/test_bridge_basic_c_export_ptr.pb, tests/pb/test_bridge_c_import_ptr.pb

BRIDGE EXPORT bridge_counter AS LONG
BRIDGE EXPORT bridge_total AS DOUBLE ALIAS "bridge_total_alias"

DECLARE FUNCTION bridge_c_touch() AS LONG

Verhalten: Der C-Helfer verwendet die generierten Bridge-Deklarationen, erhoeht bridge_counter und aktualisiert bridge_total_alias; BASIC sieht die geaenderten Werte. Die Bool/Currency-Regression beweist, dass generierte C-Deklarationen die Descriptor-Bytebreite fuer 1-Byte-BOOL und 8-Byte-skalierten CURRENCY-Speicher einhalten. Die Festpuffer-Import-Regression beweist, dass BASIC ein C-eigenes Byte-Array als STRINGZ * 8 binden, exakte Bytes lesen, ueber Fixed-Buffer-Zuweisung schreiben und C dieselbe Speicherstelle beobachten und aendern lassen kann. Die Pointer-Regressionen beweisen BASIC-eigenen BYTE PTR-Export ueber generiertes void* und C-eigenen void*-Import, wobei C durch eine BASIC-Pufferadresse schreibt.

Verifiziertes Beispiel: BASIC-Export wird von Rust geaendert

Beispieldateien: tests/pb/test_bridge_basic_rust_export.pb, tests/rust/bridge_basic_rust_export.rs, tests/pb/test_bridge_basic_rust_export_bool_currency.pb, tests/pb/test_bridge_basic_rust_export_stringz.pb, tests/pb/test_bridge_basic_rust_export_ptr.pb, tests/pb/test_bridge_rust_import_c_owner.pb, tests/pb/test_bridge_rust_import_c_stringz.pb, tests/pb/test_bridge_rust_import_c_ptr.pb

BRIDGE EXPORT rust_counter AS LONG ALIAS "rust_bridge_counter"
BRIDGE EXPORT rust_total AS DOUBLE ALIAS "rust_bridge_total"

Verhalten: Der Rust-Helfer deklariert die exportierten Symbole als extern "PBXB64" static mut, aendert Integer- und Gleitkommawerte und BASIC prueft beide Ergebnisse nach dem Aufruf. Die Bool/Currency-Regression beweist, dass generierte Rust-Deklarationen die Descriptor-Bytebreite fuer 1-Byte-BOOL und 8-Byte-skalierten CURRENCY-Speicher einhalten. Feste STRINGZ * n-Exporte werden als Rust-[i8; n]-Statics erzeugt und ueber Byte-Indexzugriffe getestet. Pointer-Slots werden als Rust-usize-Statics erzeugt; die Pointer-Regressionen beweisen, dass Rust die gespeicherte BASIC-Pufferadresse zu *mut i8 casten und sowohl ueber BASIC-eigene Exporte als auch ueber C-eigene Imports exakte Bytes schreiben kann. Derselbe generierte Deklarationspfad deckt skalare, Pointer- und feste BRIDGE IMPORT-Puffer ab, sodass Rust C-eigenen Skalar-, Pointer-Slot- und Byte-Array-Speicher aendern kann, waehrend BASIC den Wert oder exakte Bytes beobachtet.

Verifiziertes Beispiel: Bridge-Speicher wird von Standalone-ASM geaendert

Beispieldateien: tests/pb/test_bridge_basic_asm_export.pb, tests/asm/bridge_basic_asm_export.asm, tests/pb/test_bridge_basic_asm_export_bool_currency.pb, tests/asm/bridge_basic_asm_export_bool_currency.asm, tests/pb/test_bridge_basic_asm_export_ptr.pb, tests/asm/bridge_basic_asm_export_ptr.asm, tests/pb/test_bridge_asm_import_c_owner.pb, tests/pb/test_bridge_asm_import_c_stringz.pb

BRIDGE EXPORT asm_counter AS LONG ALIAS "asm_bridge_counter"

Verhalten: Standalone-ASM deklariert das Bridge-Objektsymbol mit .extern, aendert den 64-Bit-Skalarspeicher und gibt den beobachteten Wert zurueck. Die Bool/Currency-Regression beweist, dass ASM ein 1-Byte-BOOL-Bridge-Symbol mit byte ptr-Operanden lesen und schreiben und 8-Byte-skalierten CURRENCY-Speicher mit qword ptr-Operanden aendern kann. Die Pointer-Slot-Regression beweist, dass ASM einen BASIC-eigenen BYTE PTR-Bridge-Slot laden und exakte Bytes durch die gespeicherte BASIC-Pufferadresse schreiben kann. Die Import-Owner-Regressionen beweisen denselben ASM-Pfad gegen C-eigenen Skalarspeicher und C-eigenen festen Byte-Speicher, der von BASIC importiert wird; der Festpuffer-Test schreibt exakte Bytes mit byte ptr-Operanden.

Verifiziertes Beispiel: BASIC-Export wird von Forth geaendert

Beispieldateien: tests/pb/test_bridge_basic_forth_export.pb, tests/forth/bridge_basic_forth_export.fth, tests/pb/test_bridge_basic_forth_double.pb, tests/forth/bridge_basic_forth_double.fth, tests/pb/test_bridge_basic_forth_stringz.pb, tests/pb/test_bridge_basic_forth_ptr.pb, tests/pb/test_bridge_forth_import_c_owner.pb, tests/pb/test_bridge_forth_import_c_stringz.pb, tests/pb/test_bridge_forth_import_c_ptr.pb

BRIDGE EXPORT forth_counter AS LONG ALIAS "forth_bridge_counter"

Verhalten: Der Forth-Helfer verwendet BRIDGE@ forth_bridge_counter und BRIDGE! forth_bridge_counter, um den BASIC-eigenen Integer-Export zu aendern. Ein generierter Forth-Prolog deklariert Bridge-Symbole vor der Uebersetzung der Forth-Nebenquelle. Der fokussierte Floating-Pfad verwendet BRIDGE@F64, F64, F+ und BRIDGE!F64, um einen BASIC-eigenen DOUBLE-Export zu aendern. Feste Puffer nutzen BRIDGEADDR, BRIDGELEN und Byte-Schreibzugriffe mit C!; Tests decken BASIC-eigenen STRINGZ * 8-Speicher und C-eigene, von BASIC importierte Byte-Arrays ab. Pointer-Slots nutzen BRIDGEPTR plus C!, um durch die gespeicherte BASIC-Pufferadresse zu schreiben; Tests decken BASIC-eigene BYTE PTR-Exporte und C-eigene void*-Imports ab. C-eigene skalare Imports sind ueber denselben generierten Forth-Deklarationspfad fuer i64- und f64-Speicher getestet; das Integer-Bridge-Wort auf einem Floating-Symbol, die Festpuffer-Adress- oder Laengenwoerter auf Nicht-Puffer-Symbolen oder das Pointer-Wort auf einem Nicht-Pointer-Symbol schlagen fail-closed fehl.

Verifiziertes Beispiel: BASIC-Festpuffer wird von COBOL geaendert

Beispieldateien: tests/pb/test_bridge_basic_cobol_export_picx.pb, tests/cobol/bridge_basic_cobol_export_picx.cbl

BRIDGE EXPORT bridge_text AS STRINGZ * 8 ALIAS "BASIC-TEXT"

Verhalten: Das COBOL-Nebenprogramm deklariert 01 BASIC-TEXT PIC X(8) EXTERNAL, wird als aufrufbarer PROGRAM-ID-Helfer kompiliert, schreibt den Festpuffer, und BASIC liest die exakten Bytes ueber PEEK$(STRPTR(...), 8). Eine abweichende PIC X-Breite wird zur Compile-Zeit abgelehnt.

Verifiziertes Beispiel: Gemischte Nebeneingaben

Beispieldateien: tests/pb/test_bridge_mixed_frontends.pb, tests/c/bridge_mixed_c_frontend.c, tests/asm/bridge_mixed_asm_frontend.asm, tests/rust/bridge_mixed_rust_frontend.rs, tests/forth/bridge_mixed_forth_frontend.fth, tests/cobol/bridge_mixed_cobol_frontend.cbl

Verhalten: Ein BASIC-eigener Integer-Export wird in einem einzigen Link nacheinander von C, Standalone-ASM, Rust und Forth geaendert. Derselbe Test beweist ausserdem, dass C und Rust einen BASIC-eigenen Floating-Export aendern, waehrend Forth auf dem getesteten Integer-Bridge-Pfad bleibt. COBOL besitzt im selben Link ein Bridge-Symbol mit Bindestrichen als PIC S9(9) EXTERNAL; BASIC importiert, liest und aendert diesen gemeinsamen numerischen Speicher.

Siehe auch

  • GLOBAL

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BUILD$ - PBXB64 Compiler Help

Startseite › Functions › BUILD$

BUILD$

Build or concatenate

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

x$ = BUILD$( a$ , b$ , c$ , d$ ...)

Beschreibung

In some cases, string concatenation using the classic string operators can be a slow process. This is particularly true when there are many operands using longer strings. The BUILD$ function passes all the typical bottlenecks to create a new string at the greatest possible speed. The following 2 lines are functionally identical, but the BUILD$ version will execute substantially faster.

x$ = a$ + "bb" + c$ + y$(7) + y$(i&) + z$

x$ = BUILD$(a$, "bb", c$, y$(7), y$(i&), z$)

It's interesting to note that this string function could have been named APPEND$ or PREPEND$ because it performs these functionalities so well. For example, to prepend a topic number to text$ while also adding a period at the end, you could execute:

text$ = BUILD$( "1) ", text$, ".")

In order to extract the utmost efficiency, BUILD$() was designed to work with a very narrow definition. The component parameters must be dynamic string variables, either scalar or array , string literals , or string equates . They may not be expressions . There is virtually no limit as to the number of parameters.

The BUILD$() function is most valuable when you are concatenating numerous strings all at the same time. However, when you must add many string sections, in many separate operations, the StringBuilder object is much faster, and a more appropriate choice.

Generally speaking, the greater the number of parameters, the greater the increase in execution speed.

Siehe auch

  • LET
  • CHR$
  • CSET
  • CSET$
  • JOIN$
  • LSET
  • LSET$
  • REPEAT$
  • RSET
  • RSET$
  • STRING$
  • STRINGBUILDER
  • STRINSERT$
  • WRAP$

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Built-in Interfaces - PBXB64 Compiler Help

Startseite › Functions › Built-in Interfaces

Built-in Interfaces

The compiler provides a set of built-in Interfaces, including:

Typ:Schlüsselwort |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

ICONNECTIONPOINTCONTAINER

Beschreibung

Built-in Interfaces gehoert zur Kategorie General. Diese Seite beschreibt den PBXB64-Dokumentationsstand fuer diesen Eintrag; verwenden Sie die Grenzen und Belege auf dieser Seite statt historischer PBWin-Annahmen.

Syntax

' Siehe den urspruenglichen Eintrag und die verlinkten Beispiel-/Testdateien fuer die genaue PBXB64-Form von Built-in Interfaces.
' Nicht belegte Unterformen bleiben ausserhalb der zertifizierten Oberflaeche.

Praktische Verwendung

Built-in Interfaces gehoert zur Kategorie General. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Built-in Interfaces mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Siehe auch

  • Befehlsindex
  • BASIC-Frontend


Built-in numeric equates - PBXB64 Compiler Help

Startseite › Functions › Built-in numeric equates

Built-in numeric equates

The compiler provides a convenient set of built-in numeric equates .

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

The first to consider should be the group which determines the compiler version and the supported feature level. Additional information may be found with the %DEF equate operator.

%PB_CC32, %PB_DLL32, %PB_EXE, %PB_REVISION, %PB_REVLETTER, %PB_WIN32

Compile-Time information:

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Built In RGB Color Equates - PBXB64 Compiler Help

Startseite › Functions › Built In RGB Color Equates

Built In RGB Color Equates

The following is a list of RGB color equates built into the compiler, which can be used with routines that accept RGB color values.

Typ:Schlüsselwort |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Built-in string equates - PBXB64 Compiler Help

Startseite › Functions › Built-in string equates

Built-in string equates

Der Compiler stellt außerdem eine Reihe integrierter String-Equates bereit. Diese bieten sowohl Komfort als auch Selbstdokumentation.

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Die folgende Tabelle zeigt das ANSI-Formular, das jeweils mit einem einzelnen Dollarzeichen ($) beginnt. Der Compiler enthält und bietet außerdem jeweils eine breite Unicode-Version an, die durch ein doppeltes Dollarzeichen ($$) gekennzeichnet ist. Beispielsweise gibt $NUL ein Byte mit dem Zeichencode Null (0) zurück, während $$NUL ein Wort mit dem Zeichencode Null (0) zurückgibt.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


Eingebaute benutzerdefinierte Typen - PBXB64-Compiler-Hilfe

Startseite › Funktionen › Integrierte benutzerdefinierte Typen
Hilfe zum PBXB64-Compiler

Eingebaute benutzerdefinierte Typen

Der Compiler stellt eine Reihe integrierter benutzerdefinierter Typen bereit, darunter:

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

VariantArgs AS VARIANT

NamedDispID AS VARIANT

Beschreibung

Eingebaute benutzerdefinierte Typen gehoert zur Kategorie General. Diese Seite beschreibt den PBXB64-Dokumentationsstand fuer diesen Eintrag; verwenden Sie die Grenzen und Belege auf dieser Seite statt historischer PBWin-Annahmen.

Syntax

' Siehe den urspruenglichen Eintrag und die verlinkten Beispiel-/Testdateien fuer die genaue PBXB64-Form von Eingebaute benutzerdefinierte Typen.
' Nicht belegte Unterformen bleiben ausserhalb der zertifizierten Oberflaeche.

Praktische Verwendung

Eingebaute benutzerdefinierte Typen gehoert zur Kategorie General. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingebaute benutzerdefinierte Typen mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Siehe auch

  • Befehlsindex
  • BASIC-Frontend


Byte (?) – PBXB64-Compiler Hilfe

Startseite › Funktionen › Byte (?)
Hilfe zum PBXB64-Compiler

Byte (?)

Bytes sind 8-Bit (1 Byte) vorzeichenlose Ganzzahlen mit einem Wert von 0 bis 255 ( 0 bis 2^8-1). Das Typspezifizierzeichen für ein Byte ist: ?.

Typ:Schlüsselwort |Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Byte-Variablen werden identifiziert, indem dem Variablennamen ein Fragezeichen folgt (d. h. var? ) oder indem die DEFBYT-Anweisung verwendet wird, wie in der vorherigen Diskussion von Ganzzahlen beschrieben. Sie können Byte-Variablen auch mit dem Schlüsselwort BYTE mit der DIM-Anweisung deklarieren. Zum Beispiel:

Byte-Variablen eignen sich besonders zum Speichern kleiner, vorzeichenloser ganzzahliger Größen wie der Anzahl der Tage in einem Monat. Sie sollten keine Byte-Variablen in FOR/NEXT-Schleifen verwenden, da diese äußerst ineffizient sind.

Eine PowerBASIC-Byte-Variable entspricht einem Bool-Datentyp (in Kleinbuchstaben), der von den meisten modernen C-Compilern verwendet wird. Ein Bool ist ein nicht-traditioneller 8-Bit-Datentyp ohne Vorzeichen, während ein BOOL-Datentyp (in Großbuchstaben) einer langen Ganzzahl in PowerBASIC entspricht. Beachten Sie, dass einige ältere C-Compiler möglicherweise die Schlüsselwörter bool und BOOL frei austauschen.

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_type_long
FUNCTION PBMAIN() AS LONG
  LOCAL a AS LONG
  a = 10
  IF (a) <> (10) THEN FUNCTION = 1: EXIT FUNCTION
  a = a + 5
  IF (a) <> (15) THEN FUNCTION = 2: EXIT FUNCTION
  a = a * 2
  IF (a) <> (30) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_type_integer
FUNCTION PBMAIN() AS LONG
  LOCAL a AS INTEGER
  a = 10
  IF (a) <> (10) THEN FUNCTION = 1: EXIT FUNCTION
  a = a + 5
  IF (a) <> (15) THEN FUNCTION = 2: EXIT FUNCTION
  a = a * 2
  IF (a) <> (30) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_type_byte
FUNCTION PBMAIN() AS LONG
  LOCAL a AS BYTE
  a = 10
  IF (a) <> (10) THEN FUNCTION = 1: EXIT FUNCTION
  a = a + 5
  IF (a) <> (15) THEN FUNCTION = 2: EXIT FUNCTION
  a = a * 2
  IF (a) <> (30) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_type_word
FUNCTION PBMAIN() AS LONG
  LOCAL a AS WORD
  a = 10
  IF (a) <> (10) THEN FUNCTION = 1: EXIT FUNCTION
  a = a + 5
  IF (a) <> (15) THEN FUNCTION = 2: EXIT FUNCTION
  a = a * 2
  IF (a) <> (30) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_type_dword
FUNCTION PBMAIN() AS LONG
  LOCAL a AS DWORD
  a = 10
  IF (a) <> (10) THEN FUNCTION = 1: EXIT FUNCTION
  a = a + 5
  IF (a) <> (15) THEN FUNCTION = 2: EXIT FUNCTION
  a = a * 2
  IF (a) <> (30) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_type_quad
FUNCTION PBMAIN() AS LONG
  LOCAL a AS QUAD
  a = 10
  IF (a) <> (10) THEN FUNCTION = 1: EXIT FUNCTION
  a = a + 5
  IF (a) <> (15) THEN FUNCTION = 2: EXIT FUNCTION
  a = a * 2
  IF (a) <> (30) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


C17 Standardbibliotheksheader - PBXB64-Compiler-Hilfe

Startseite › Funktionen › C17-Standardbibliotheksheader

C17-Standardbibliotheksheader

PBXB64 wird mit einem vollständigen C17-Standardbibliotheksheadersatz für gehostetes C ausgeliefert Validierung. Diese Header befinden sich im Verzeichnis c17_headers und werden beim Kompilieren von C-Code mit PBXB64 -std=c17.

Typ: automatisch durchsucht. Referenz | Kategorie: C-Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Header Kategorien

Kopfzeile | Kategorie | Schlüssel Inhalt
<assert.h> | Diagnose | assert() Makro
<ctype.h> | Charakter | isalpha, isdigit, Toupper usw.
<errno.h> | Diagnose | errno, Fehlercode Makros
<float.h> | Limits | FLT_MAX, DBL_MAX, LDBL_MAX, etc.
<inttypes.h> | Formatting | PRId64, PRIu64, usw.
<limits.h> | Limits | CHAR_MAX, INT_MAX, LONG_MAX, etc.
<locale.h> | Localization | setlocale, localeconv
<math.h> | Math | sin, cos, sqrt, pow usw.
<setjmp.h> | Nicht-lokale Sprünge | setjmp, longjmp
<signal.h> | Signals | signal, raise, SIG* Konstanten
<stdarg.h> | Variadic | va_list, va_start, va_arg, va_end
<stdatomic.h> | Atomics | atomare Typen und Operationen
<stdbool.h> | Boolean | bool, true, false
<stddef.h> | Definitions | size_t, ptrdiff_t, NULL, offsetof
<stdint.h> | Ganze Zahl | int8_t, uint16_t, int32_t, int64_t, etc.
<stdio.h> | I/O | FILE, fopen, printf, scanf, etc.
<stdlib.h> | General | malloc, free, atoi, qsort, rand, etc.
<string.h> | Zeichenfolge | strlen, strcpy, strcat, memcmp, etc.
<time.h> | Time | time, clock, struct tm, strftime
<wchar.h> | Wide char | wchar_t, wprintf, wcslen, usw.

PBXB64-spezifische Header

Kopfzeile | Beschreibung
<pbxb64/hlib.h> | H-Lib Container C API für PB Frontends

Siehe auch

  • C-Datentypen – C-Typgrößen und Äquivalente
  • Datentypen – Übersicht über numerische PB-Typen

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für C17-Standardbibliotheksheader soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' C17-Standardbibliotheksheader mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


C Datentypen – PBXB64 Compiler-Hilfe

Startseite › Funktionen › C-Daten Typen

C-Datentypen

PBXB64 unterstützt das Kompilieren von C17-Quelldateien (.c, .h) mithilfe des integrierten C-Frontends. Die Header der C17-Standardbibliothek sind im Compiler enthalten und im Verzeichnis c17_headers verfügbar.

Typ: Datentyp | Kategorie: C-Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Beschreibung

C-Datentypen ist die Einstiegsseite fuer das integrierte PBXB64-C-Frontend. Verwenden Sie diese Seite, um vor dem Schreiben eines Programms den passenden Skalar-, Zeiger-, String- oder Aggregattyp auszuwählen und dann auf die engeren Befehlsseiten und fokussierten Validierungsbeispiele zu wechseln.

Die Seite dokumentiert die nativen Windows-x64-Groessen, die PBXB64 beim Kompilieren von C17-Quelltext verwendet. Fuer ein Programm ist deshalb nicht nur die C-Formulierung, sondern das konkrete Typ-, Vorzeichen- und ABI-Mapping unten massgeblich.

Syntax

PBXB64 -std=c17 file.c
#include <stdint.h>
#include <stdbool.h>

Standard-C-Datentypen

Beim Kompilieren von C-Code mit PBXB64 -std=c17 file.c sind die folgenden Standard-C-Datentypen über das enthaltene verfügbar Header:

Typ | Kopfzeile | Größe | Beschreibung
char | <stdint.h> | 1 Byte | Zeichen / kleinste adressierbare Einheit
short | <stdint.h> | 2 Bytes | Kurze Ganzzahl mit Vorzeichen
int | <stdint.h> | 4 Bytes | Standard-Ganzzahl mit Vorzeichen
long | <stdint.h> | 4 Bytes | Lange Ganzzahl mit Vorzeichen (Win64 LLP64)
long long | <stdint.h> | 8 Byte | Erweiterte Ganzzahl mit Vorzeichen
float | <math.h> | 4 Bytes | IEEE 754 mit einfacher Genauigkeit
double | <math.h> | 8 Byte | IEEE 754 double-precision
long double | <math.h> | 8 Byte | Erweiterte Genauigkeit (Win64 wird auf double abgebildet)
void* | <stddef.h> | 8 Byte | Pointer (64-Bit unter Win64)
size_t | <stddef.h> | 8 Byte | Vorzeichenloser Größentyp (Win64)
ptrdiff_t | <stddef.h> | 8 Byte | Vorzeichenbehafteter Zeigerdifferenztyp

Ganzzahltypen mit fester Breite

Typen mit exakter Breite von <stdint.h>:

Typ | Größe | PB-Äquivalent
int8_t | 1 Byte | BYTE (signiert)
uint8_t | 1 Byte | BYTE
int16_t | 2 Bytes | GANZE ZAHL
uint16_t | 2 Bytes | WORD
int32_t | 4 Bytes | LONG
uint32_t | 4 Bytes | DWORD
int64_t | 8 Byte | QUAD
uint64_t | 8 Byte | QUAD (ohne Vorzeichen)
intptr_t | 8 Byte | QUAD
uintptr_t | 8 Byte | QUAD

Boolescher Typ

<stdbool.h> liefert bool, true, Undfalse. In C ist bool 1 Byte. Verwenden Sie in PB BYTEoderLONG für boolesche Werte.

Zeichentypen

<wchar.h> liefert wchar_t (2 Bytes unter Win64, UTF-16). Das PB-Äquivalent ist WSTRING. char ist 1 Byte (ANSI). Das PB-Äquivalent ist STRING.

Inklusive C17-Header

The following standard C17 headers are bundled with PBXB64:

assert.h    ctype.h     errno.h     float.h
inttypes.h  limits.h    locale.h    math.h
setjmp.h    signal.h    stdarg.h    stdatomic.h
stdbool.h   stddef.h    stdint.h    stdio.h
stdlib.h    string.h    time.h      wchar.h

Usage

#include <stdint.h>
#include <stdbool.h>

int main(void) {
    int64_t big = 9223372036854775807LL;
    bool flag = true;
    return 0;
}

Beispiel

#include <stdint.h>
#include <stdbool.h>

int main(void) {
    int32_t value = -42;
    bool ok = value < 0;
    return ok ? 0 : 1;
}

Verifiziertes Beispiel

Das fokussierte Beispiel tests/c/test_hex_integer_bitwise.c wird durch die C-Validierungsmatrix kompiliert und ausgefuehrt. Es deckt Standard-Integer-Speicherung, Fixed-Width-Integer-Verhalten, Hex-Literale, Shifts und Bitoperationen im nativen C-Frontend ab.

Zum Nachpruefen eine fokussierte C-Datei mit PBXB64 sample.c -o sample.exe kompilieren und die erzeugte EXE ausfuehren.

Siehe auch

  • C17 Standard Library Headers
  • C Language Overview
  • C Data Types hub
  • C Standard Library

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


CALL - PBXB64 Compiler Help

Startseite › Functions › CALL

CALL

Invoke a procedure (

Typ:Anweisung |Kategorie: Procedures

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CALL ProcName [([ arguments ])] [TO result_var ]

Beschreibung

The CALL statement has the following parts:

ProcName

The name of a Sub, Function, Method, Property, or FastProc defined elsewhere in the program.

arguments

An optional, comma-delimited list of variables , expressions, and constants to be passed to the procedure as parameters, for up to 32 parameters. If the CALL keyword is used, the arguments must be enclosed in parentheses.

You can omit the CALL keyword. If you do so, you may also omit the parentheses surrounding arguments. For example, the following lines are equivalent:

CALL MyProc(parm1, parm2)

MyProc(parm1, Parm2)

MyProc parm1, parm2

However, if the first parameter argument is enclosed in parentheses for any reason, the entire parameter list must be enclosed in parentheses. For example:

MyProc (3+z, b) ' Valid syntax

MyProc ((3+z), b) ' Valid syntax

MyProc (3+z), b ' Invalid syntax

This updated syntax now permits macros to be called using the SUB-style convention if/when the macros expand directly to Function calls. For example:

MACRO sm(Msg) = SendMessage(a, Msg, b, c)

can be called like this (when the return value is not required):

In all cases, the number and type of parameters passed must agree with the arguments in procedure definition.

V ariant Arguments

Y ou can think of a Variant as a kind of container, which can hold a variable of most any data type. If you call a procedure which requires a variant for one or more of its arguments, PowerBASIC will automatically convert a standard data type into a variant data type.

While a variant may not normally contain a UDT , PowerBASIC offers a special methodology to do so. At programmer direction, a TYPE may be assigned to a variant (as a byte string ) by using:

[LET] VrntVar = TypeVar AS STRING

In the same manner, a UDT argument can be auto-converted to the variant type by appending AS STRING:

CALL ProcName(UDTVar AS STRING)

The data contained in the User-Defined Type variable (UDT) is stored in the variant argument as a dynamic string of bytes (vt_bstr). When you retrieve that UDT data (with Variant$ ), PowerBASIC understands the content and handles it accurately. However, other programming languages may not understand this technique, so it should be limited to PowerBASIC applications. This methodology is implemented in all of the PowerBASIC COLLECTION objects as it greatly enhances ease of coding and performance of the final executable.

Passing Parameters

In a procedure definition, every parameter is described by the data type, and the format used to pass it. The type may be any normal variable type, such as long, string, User-Defined Type, etc. The passing format describes how the value is presented to the procedure: by reference (BYREF), by value (BYVAL), or by reference to a copy (BYCOPY).

Wenn ein Parameter als Referenz übergeben wird, besteht er aus einer 4-Byte-Adresse der Daten. In diesem Fall können die Originaldaten durch die Prozedur geändert werden.

Wenn ein Parameter als Wert übergeben wird, handelt es sich um eine tatsächliche Kopie der Daten. Da es sich bei dem Parameter um eine Kopie handelt, können die Originaldaten durch die Prozedur nicht geändert werden.

Wenn Sie Parameter aus dem aufrufenden Code mit einem expliziten BYVAL übergeben, schalten Sie die Typprüfung des Compilers für diesen Parameter effektiv aus. Dies kann in Fällen nützlich sein, in denen der aufgerufene Code einen BYREF-Parameter erwartet und Sie eine Adresse eines anderen Datentyps übergeben möchten, die ohne die BYVAL-Methode einen Fehler bei der Kompilierung auslösen würde. Zum Beispiel:

SUB TheSub(x AS STRINGZ) ' Adresse von x erwartet

[Anweisungn]

END SUB

[Anweisungn]

DIM a$

a$ = "Dynamische Stringdaten"

CALL TheSub(BYVAL STRPTR(a$)) ' Daten übergeben Adresse

BYCOPY

Ein per Kopie übergebener Parameter ist ein Sonderfall; so etwas wie eine Mischung aus den beiden anderen Methoden. Wenn eine Prozedur erwartet, dass ein Parameter als Referenz übergeben wird, erwartet sie, einen Zeiger auf die Daten zu sehen. In einigen Fällen, beispielsweise wenn der Parameter ein berechneter Ausdruck ist, ist es nicht genau möglich, einen Zeiger zu übergeben, da es sich bei einem Ausdrucksergebnis um einen temporären Wert handelt, der nicht an einem permanenten Speicherort vorhanden ist. Wenn Sie andererseits sicherstellen möchten, dass die Originaldaten durch die Prozedur nicht verändert werden, können Sie eine BYCOPY-Überschreibung in die Argumentliste einfügen.

In beiden Fällen wird eine Kopie der Daten an einem temporären Speicherort gespeichert, und der Parameter besteht aus einer 4-Byte-Adresse dieses temporären Speicherorts. Eine andere Möglichkeit, BYCOPY zu erzwingen, besteht darin, einen Variablennamen in Klammern zu setzen, damit er für den Compiler als Ausdruck und nicht nur als einzelne Variable erscheint.

Sofern nicht anders angegeben, verwenden Parameter standardmäßig die BYREF-Übergabemethode. Ausdrücke und Konstanten werden immer BYCOPY übergeben. Zeichenfolgen fester Länge, benutzerdefinierte Typen und vollständige Arrays werden immer BYREF.

CALL MySub (i&) ' i& wird als Referenz übergeben

CALL MySub (BYREF i&) ' i& wird als übergeben reference

CALL MySub (BYCOPY i&) ' i& wird von copy

CALL MySub ((i&)) ' i& wird von copy

übergeben. Sofern nicht anders angegeben, werden Parameter standardmäßig durch die BYREF-Übergabe übergeben Methode. Ausdrücke und Konstanten werden immer BYCOPY übergeben. Vollständige Arrays werden immer BYREF übergeben.

Ganze Arrays werden durch die Verwendung eines leeren Satzes von Klammern nach dem Array angegeben, während einzelne Array-Elemente durch die tiefgestellte Indexnummer angegeben werden. Zum Beispiel:

CALL SumArray(a()) ' gesamtes Array 'a' übergeben

CALL SumArray(a(3)) ' Element 3 von Array 'a' übergeben

Die CALL-Anweisung kann sein Wird zum Aufrufen von Funktionen, Subs, Methoden, Eigenschaften oder Fastprocs verwendet. In diesem Fall wird der Rückgabewert der Funktion einfach verworfen, es sei denn, das Schlüsselwort TO wird zur Angabe einer Rückgabevariablen verwendet.

Wenn eine Prozedur einen Parameter als Referenz erwartet, ist es möglich, einen Zeiger durch einen Wert zu ersetzen, um das identische Ergebnis zu erzielen. Dies ist besonders nützlich bei Zeichenfolgen und Typen fester Länge:

DECLARE SUB a(z%)

DIM MyInt AS INTEGER, x AS INTEGER PTR

x = VARPTR(MyInt)

CALL a(MyInt)

CALL a(BYVAL x)

CALL a(BYVAL VARPTR(MyInt))

Wenn die Prozedur einen Parameter als Wert erwartet, können Sie natürlich nicht den Zeiger, sondern das Zeigerziel übergeben (d. h. CALL a(@x)).

PowerBASIC-Compiler haben ein Limit von 32 Parametern pro SUB, FUNCTION, METHOD und PROPERTY. Um mehr als 32 Parameter zu übergeben, erstellen Sie einen benutzerdefinierten Typ (UDT) und übergeben Sie stattdessen (die Adresse) des UDT als Referenz (BYREF).

Strings fester Länge, STRINGZ-Strings und benutzerdefinierte Typen/Unions können jetzt auch als BYVAL- oder OPTIONAL-Parameter übergeben werden. Versuchen Sie zu vermeiden, große Elemente BYVAL zu übergeben, da dies furchtbar ineffizient ist und es eine maximale Größenbeschränkung von 64 KB für eine bestimmte Parameterliste gibt. Arrays können nicht BYVAL übergeben werden.

Wenn eine Prozedurdefinition entweder einen BYREF-Parameter oder einen Zeigervariablenparameter angibt, kann der aufrufende Code stattdessen frei ein BYVAL DWORD oder einen Zeiger übergeben. Obwohl die Verwendung der expliziten BYVAL-Überschreibung im aufrufenden Code optional ist, wird sie aus Gründen der Übersichtlichkeit empfohlen. Es ist notwendig, alle Zeigerparameter explizit als BYVAL zu deklarieren (d. h. BYVAL X AS BYTE PTR). Andernfalls wird beim Kompilieren ein Fehler 549 („BYVAL erforderlich mit Zeigern“) generiert.

Eine Prozedur kann auch innerhalb desselben Moduls importiert und exportiert werden. Das heißt, eine Funktion im Modul kann als EXPORT angegeben werden, während eine DECLARE-Anweisung im selben Modul sie durch die Option LIB „XXX.DLL“ als importierte Funktion angibt, vorausgesetzt, dass XXX.DLL der Name des Moduls ist. Dies kann besonders nützlich sein, wenn Sie eine #INCLUDE-Datei mit allen DECLARE-Anweisungen für ein Projekt erstellen möchten.

Informationen zur Verwendung von OPTIONAL-Parametern finden Sie unter DECLARE, FUNCTION, METHOD, PROPERTY und SUB themen.

NOTHING

Das reservierte Wort NOTHING kann verwendet werden, um jeden OBJECT-Variablenparameter zu ersetzen. In diesem Fall übergibt der Compiler ein Nullobjekt (oder einen Zeiger auf ein Nullobjekt, wenn BYREF) anstelle eines typischen Parameters. Obwohl dies einige Programmierprobleme vereinfacht, muss die Technik mit Vorsicht angewendet werden. Wenn die Zielmethode oder -funktion keinen Nullparameter erwartet, kann dies zu einem schwerwiegenden Fehlerzustand führen.

TO result_var

Dies bietet eine optionale Möglichkeit, result_var einen Funktionsrückgabewert zuzuweisen. Der folgende Code weist beispielsweise x% den Rückgabewert auf zwei verschiedene Arten zu:

x% = MyFunCall

CALL MyFunCall TO x%

Einschränkungen

Eine Thread-Funktion darf nicht direkt aufgerufen oder ausgeführt werden. außer durch eine THREAD CREATE-Anweisung.

Siehe auch

  • CALL DWORD
  • ERKLÄREN
  • FASTPROC
  • FUNCTION/END FUNCTION
  • METHOD
  • PROPERTY
  • SUB/END SUB
  • THREAD CREATE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für CALL soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' CALL mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


CALL DWORD - PBXB64-Compiler Hilfe

Startseite › Funktionen › CALL DWORD

CALL DWORD

Eine Prozedur indirekt ueber einen DWORD-grossen Codezeiger aufrufen.

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET] fuer die fokussierte Integer-/Pointer-Oberflaeche: CALL DWORD ptr, CALL DWORD ptr USING Modell(args) TO result, Modellfunktionen mit einem und mehreren Integer-Argumenten, Integer-Rueckgabewertzuweisung und String-Ziel-Diagnose. String-Rueckgabewerte, BYREF-Modellparameter, OPTIONAL-Parameter, externe DLL-Ziele und STDCALL/CDECL-Unterscheidungen bleiben breitere Paritaetsziele.

Syntax

CALL DWORD TargetPtr
CALL DWORD TargetPtr USING abc ([ arguments ]) [TO result_var]

Beschreibung

CALL DWORD ist ein wesentlicher Bestandteil fuer die Implementierung einer (expliziten) dynamischen Verknuepfung von DLLs zur Laufzeit und nicht die ueblichere Ladezeit-(implizite) Verknuepfung. Dies bietet eine Moeglichkeit, Aufrufe an APIs und DLLs zu erstellen, die moeglicherweise nicht in allen Windows-Versionen vorhanden sind. Diese Technik stellt sicher, dass eine Anwendung erfolgreich gestartet werden kann, auch wenn Windows den Speicherort der API- oder DLL-Funktion nicht aufloesen kann.

Die erste (vereinfachte) Form von CALL DWORD kann verwendet werden, wenn die Zielunterfunktion/Zielfunktion keine Parameter annimmt und keinen Rueckgabewert bietet. Ausserdem sind die Aufrufkonventionen STDCALL (SDECL) erforderlich, die von der ueberwiegenden Mehrheit (ueber 99 %) der Importprozeduren verwendet werden. In allen anderen Faellen muessen Sie die zweite Form mit einer USING-Klausel verwenden, um die Signatur der Ziel-Sub/Funktion zu definieren.

TargetPtr

Eine Doppelwort-, Long-Integer- oder Zeigervariable, die die Adresse des Einstiegspunkts einer Prozedur (Sub oder Funktion) enthaelt. Wenn sich die Zielunterfunktion/Zielfunktion im selben Modul befindet, koennen Sie die Adresse mit der CODEPTR-Funktion abrufen. Wenn es sich in einer externen DLL befindet, verwenden Sie IMPORT ADDR, um es zu laden und die Adresse abzurufen.

Diese Option wird verwendet, um eine Modellprozedurdeklaration zu definieren, die allen Aufrufkonventionen entspricht, die zum Aufrufen der Zielunterfunktion/-funktion verwendet werden sollen. Beispielsweise sind die folgenden zwei Aufrufe der Funktion MySubCall aequivalent:

DECLARE SUB MySubCall

DIM PtrMySubCall AS DWORD

PtrMySubCall= CODEPTR(MySubCall)

[Anweisungn]

CALL MySubCall

CALL DWORD PtrMySubCall USING MySubCall

arguments

Eine optionale, durch Kommas getrennte Liste von Variablen, Ausdruecke und Konstanten, die als Parameter an die Prozedur uebergeben werden sollen. Im CALL DWORD-Kontext sind einschliessende Klammern erforderlich. Anzahl und Typ der uebergebenen Parameter muessen mit den Argumenten der durch die USING-Klausel benannten Prozedur uebereinstimmen. Weitere Informationen zu Parameteruebergabemethoden finden Sie unter CALL.

TO result_var

Beim Aufrufen einer Funktion, die einen Wert zurueckgibt, bietet das Schluesselwort TO eine Moeglichkeit, den Funktionsrueckgabewert result_var zuzuweisen.

Einschränkungen

Thread-Funktionen und Callback-Funktionen koennen nicht mit CALL DWORD aufgerufen werden. Das DECLARE-Modell fuer die USING-Klausel darf keine LIB- oder IMPORT-Option angeben.

Getestete Oberflaeche

Die aktuelle Regression in tests/pb/test_call_dword.pb prueft die reine Zeigerform, einen Integer-Modellaufruf mit einem Argument, einen Integer-Modellaufruf mit zwei Argumenten und die Rueckgabewertzuweisung ueber TO. Die Reject-Regression belegt, dass String-Ziele abgelehnt werden.

Praktische Verwendung

Erfassen Sie den Einstiegspunkt mit CODEPTR, speichern Sie ihn in einer DWORD- oder Zeigervariablen und rufen Sie ihn mit einer Modellprozedur auf, deren Signatur zum echten Ziel passt. Verwenden Sie die Form ohne Argumente nur dann, wenn die Zielroutine keine Parameter annimmt und keinen Rueckgabewert liefert.

LOCAL p AS LONG
LOCAL r AS LONG
p = CODEPTR(Foo)
CALL DWORD p USING Foo(5) TO r

Aktuelle Grenzen

String-Rueckgabewerte, BYREF-Modellparameter, OPTIONAL-Parameter, externe DLL-Ziele und Aufrufkonventions-Unterschiede sind weiterhin breitere Paritaetsarbeit. Halten Sie die Seite bis zu weiteren fokussierten Tests auf die verifizierte Integer-/Pointer-Oberflaeche beschraenkt.

Einschränkungen

Die fokussierte CALL-DWORD-Oberflaeche ist auf die getestete Integer-/Pointer-Verwendung beschraenkt. String-Rueckgabewerte, BYREF-Parameter, OPTIONAL-Parameter, externe DLL-Ziele und STDCALL/CDECL-Unterschiede bleiben bis zu weiteren Regressionen offen.

Getestete Oberflaeche

Die aktuelle Regression in tests/pb/test_call_dword.pb prueft die reine Zeigerform, einen Integer-Modellaufruf mit einem Argument, einen Integer-Modellaufruf mit zwei Argumenten und die Rueckgabewertzuweisung ueber TO. Die Reject-Regression belegt, dass String-Ziele abgelehnt werden.

Praktische Verwendung

Erfassen Sie den Einstiegspunkt mit CODEPTR, speichern Sie ihn in einer DWORD- oder Zeigervariablen und rufen Sie ihn mit einer Modellprozedur auf, deren Signatur zum echten Ziel passt. Verwenden Sie die Form ohne Argumente nur dann, wenn die Zielroutine keine Parameter annimmt und keinen Rueckgabewert liefert.

LOCAL p AS LONG
LOCAL r AS LONG
p = CODEPTR(Foo)
CALL DWORD p USING Foo(5) TO r

Aktuelle Grenzen

String-Rueckgabewerte, BYREF-Modellparameter, OPTIONAL-Parameter, externe DLL-Ziele und Aufrufkonventions-Unterschiede sind weiterhin breitere Paritaetsarbeit. Halten Sie die Seite bis zu weiteren fokussierten Tests auf die verifizierte Integer-/Pointer-Oberflaeche beschraenkt.

Einschränkungen

Die fokussierte CALL-DWORD-Oberflaeche ist auf die getestete Integer-/Pointer-Verwendung beschraenkt. String-Rueckgabewerte, BYREF-Parameter, OPTIONAL-Parameter, externe DLL-Ziele und STDCALL/CDECL-Unterschiede bleiben bis zu weiteren Regressionen offen.

Siehe auch

  • CALL
  • CODEPTR
  • ERKLÄREN
  • FASTPROC
  • FUNCTION/END FUNCTION
  • IMPORT
  • SUB/END SUB
  • THREAD CREATE

Getestetes Beispiel

Beispieldatei: tests/pb/test_call_dword.pb

Validierungsnachweis: tests/validate.toml enthaelt die pb_linkrun-Tests test_call_dword und test_call_dword_reject_string_target.

CALL DWORD p
CALL DWORD p USING Foo(5) TO r
CALL DWORD p USING AddMul(4, 3) TO r

PBXB64-Status: [ZERTIFIZIERT GETESTET]

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Rückrufe - PBXB64 Compiler-Hilfe

Startseite › Funktionen › Callbacks

Callbacks

Ein Callback ist eine Funktion, die von Windows aufgerufen wird, wenn ein Ereignis eintritt. Wenn der Benutzer im vorherigen Beispiel eines modalen Dialogs auf die Schaltfläche „OK“ klickt, ruft Windows die Funktion „OkButton()“ auf. PowerBASICs D

Typ:Schlüsselwort |Kategorie: Procedures

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Wenn Sie Visual Basic verwendet haben, sind Sie mit dem Konzept eines Control Callbacks vertraut, auch wenn es nicht so heißt. Ein Steuerrückruf ist eine Funktion, die aufgerufen wird, wenn ein %WM_COMMAND- oder %WM_NOTIFY-Ereignis für ein bestimmtes Steuerelement generiert wird. Im vorherigen Beispiel haben wir es so angeordnet, dass die Funktion OkButton() aufgerufen wurde, wenn auf die Schaltfläche OK geklickt wurde. Außerdem wurde beim Klicken auf die Schaltfläche „Abbrechen“ die Funktion „CancelButton()“ aufgerufen. Eine Control Callback-Funktion wird aktiviert, wenn Sie am Ende eine CONTROL ADD-Anweisung mit der Option CALL CtlProc ausführen.

CONTROL ADD BUTTON, hDlg, %IDOK, "OK", 34, 32, 40, 14, %BS_DEFAULT ODER %WS_TABSTOP CALL OkButton

CONTROL ADD BUTTON, hDlg, %IDCANCEL, "Cancel", 84, 32, 40, 14 CALL CancelButton

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Callbacks soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Callbacks mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


CALLSTK$ - PBXB64 Compiler-Hilfe

Startseite › Funktionen › CALLSTK$

CALLSTK$

Ruft fokussierte Call-Stack-Informationen fuer den aktuellen Frame ab.

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

sfname$ = CALLSTK$( n )

Beschreibung

PBXB64 implementiert einen fokussierten aktuellen Frame. CALLSTK$(0) gibt den aktuellen abgesenkten Funktionsnamen zurueck, und CALLSTK(0) gibt eine von Null verschiedene aktuelle Frame-Markierung zurueck.

Tiefen groesser als Null werden nicht still angenaehert. Sie erzeugen die gezielte Compile-Diagnose CALLSTK depth beyond 0 is not implemented, bis echte Multi-Frame-Call-Stack-Verfolgung implementiert ist.

Die nullbasierte Form ist Teil des aktuellen PBXB64-Vertrags. Sie gibt Debug- und Protokollcode eine deterministische Moeglichkeit, die gerade kompilierte Funktion zu erkennen, ohne vorzugeben, dass Aufrufer-Frames, Argumentformatierung oder Stack-Walking bereits vorhanden sind.

Wenn diese Oberflaeche erweitert wird, muessen tiefere Formen echte Stack-Daten liefern und duerfen nicht einfach wiederholt die aktuelle Funktion zurueckgeben. Bis dahin fixieren Tests die Diagnose fuer nicht unterstuetzte Tiefen.

Das Beispiel unten bleibt absichtlich klein, damit es in Konsolen-, GUI- und isolierten Einzel-EXE-Pruefungen stabil bleibt.

Einschränkungen

Vollstaendige PBWin-Call-Stack-Paritaet bleibt offen: Parameterdarstellung, Aufrufer-Frame-Zugriff und threadbezogene Stack-Snapshots sind in diesem fokussierten Baseline-Vertrag nicht implementiert.

Verwenden Sie das aktuelle Ergebnis nicht als Sicherheitsgrenze und nicht als Ersatz fuer strukturierten Fehlerkontext. Es ist ein aktueller Frame-Helfer fuer Diagnose und einfache Instrumentierung.

Von PBWin portierte Programme sollten alle Verwendungen mit Tiefen groesser als Null separat pruefen.

Siehe auch

  • #TOOLS
  • CALLSTK
  • CALLSTKCOUNT
  • FUNCNAME$
  • PROFILE
  • TRACE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CALLSTKCOUNT - PBXB64 Compiler Help

Startseite › Functions › CALLSTKCOUNT

CALLSTKCOUNT

Ruft die fokussierte Stack-Anzahl fuer den aktuellen Frame ab.

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

count& = CALLSTKCOUNT

Beschreibung

PBXB64 implementiert einen fokussierten aktuellen Frame. CALLSTKCOUNT gibt fuer diesen Baseline-Vertrag 1 zurueck.

Verwenden Sie CALLSTK$(0) oder FUNCNAME$, um den aktuellen abgesenkten Funktionsnamen abzurufen.

Dieser Wert beschreibt bewusst nur die implementierte PBXB64-Stack-Helfer-Oberflaeche. Er zaehlt keine Aufrufer-Frames, keine verschachtelte Prozedurhistorie, keine Fehlerbehandlungs-Frames und keine Laufzeitbibliotheks-Frames.

Der stabile Wert ist nuetzlich fuer Code, der nur pruefen muss, dass Stack-Helfer-Instrumentierung vorhanden ist. Code, der eine vollstaendige PBWin-Call-Stack-Tiefe benoetigt, muss diese Oberflaeche weiterhin als begrenzte Kompatibilitaet behandeln.

Das Beispiel unten prueft deshalb nur die garantierte aktuelle Baseline und vermeidet Annahmen ueber Aufrufer oder Laufzeitbibliotheks-Frames.

Einschränkungen

Vollstaendige PBWin-Call-Stack-Paritaet bleibt offen: Multi-Frame-Zaehler und threadbezogene Stack-Snapshots sind in diesem fokussierten Baseline-Vertrag nicht implementiert.

Eine spaetere Erweiterung muss diese Seite und die registrierten Tests gemeinsam aktualisieren, damit die dokumentierte Anzahl zum echten Call-Stack-Modell passt.

Von PBWin portierte Anwendungen sollten jede Logik, die Werte groesser als eins erwartet, vor produktiver Nutzung dieses Helfers ueberarbeiten.

Siehe auch

  • #TOOLS
  • CALLSTK$
  • CALLSTK
  • FUNCNAME$
  • PROFILE
  • TRACE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CASE - PBXB64 Compiler Help

Startseite › Functions › CASE

CASE

Label a SELECT CASE branch

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CASE expression [, expression ...]
CASE expression TO expression
CASE IS comparison expression
CASE ELSE

Beschreibung

DerCASE statement introduces one branch of a SELECT CASE block. The selector expression is compared against each CASE list; the first matching block executes, then control jumps to the statement after END SELECT.

Beispiel

FUNCTION PBMAIN () AS LONG
    LOCAL x AS LONG
    x = 2
    SELECT CASE x
        CASE 1
            FUNCTION = 10
        CASE 2
            FUNCTION = 20
        CASE ELSE
            FUNCTION = 0
    END SELECT
END FUNCTION

Generierter Assembler-Code

Kompilieren mit:

PBXB64 example.pb --asmout example.asm
    mov r10, [rbp-24]
    mov rbx, r10
    cmp rbx, 1
    sete r10
    mov rbx, r10
    test rbx, rbx
    jne pb_case_body_PBMAIN_0
    mov r10, [rbp-24]
    mov rbx, r10
    cmp rbx, 2
    sete r10
    mov rbx, r10
    test rbx, rbx
    jne pb_case_body_PBMAIN_1
    jmp pb_case_else_PBMAIN_2
pb_case_body_PBMAIN_0:
    mov [rbp-16], 10
    jmp pb_select_end_PBMAIN_3
pb_case_body_PBMAIN_1:
    mov [rbp-16], 20
    jmp pb_select_end_PBMAIN_3
pb_case_else_PBMAIN_2:
    mov [rbp-16], 0
    jmp pb_select_end_PBMAIN_3
pb_select_end_PBMAIN_3:

Hinweise

Ranges use TO and comparisons use IS. Fall-through between cases does not occur.

Siehe auch

  • Select Case
  • Case Else
  • Basic Ref Control Flow

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CASE ELSE - PBXB64 Compiler Help

Startseite › Functions › CASE ELSE

CASE ELSE

Default branch of SELECT CASE

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CASE ELSE
  [statements]

Beschreibung

CASE ELSE is the optional final branch of a SELECT CASE block. It executes when none of the preceding CASE expressions match the selector.

Beispiel

FUNCTION PBMAIN () AS LONG
    LOCAL x AS LONG
    x = 99
    SELECT CASE x
        CASE 1
            FUNCTION = 10
        CASE ELSE
            FUNCTION = 0
    END SELECT
END FUNCTION

Generierter Assembler-Code

Kompilieren mit:

PBXB64 example.pb --asmout example.asm
    ; ... earlier CASE tests ...
    jmp pb_case_else_PBMAIN_2
pb_case_body_PBMAIN_0:
    mov [rbp-16], 10
    jmp pb_select_end_PBMAIN_3
pb_case_else_PBMAIN_2:
    mov [rbp-16], 0
    jmp pb_select_end_PBMAIN_3
pb_select_end_PBMAIN_3:

Hinweise

If no CASE matches and CASE ELSE is omitted, execution continues after END SELECT.

Siehe auch

  • Select Case
  • Case
  • Basic Ref Control Flow

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CATCH - TRY-Fehlerpfad behandeln — PBXB64 Help

Startseite › General Reference › CATCH - TRY-Fehlerpfad behandeln — PBXB64 Help
Hilfe zum PBXB64-Compiler

CATCH - TRY-Fehlerpfad behandeln

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

TRY
  ERROR 5
CATCH
  RESUME NEXT
END TRY

Detailverhalten

Kontrollkeyword in Verbindung mit TRY fuer Fehlerbehandlungs-Kompatibilitaet.

Praktische Verwendung

Verwenden Sie CATCH nur innerhalb eines passenden TRY/END TRY-Blocks. Die Seite beschreibt die erkannte PBXB64-Schreibweise fuer die Fehler- oder Cleanup-Klausel, die an die umgebende Kontrollstruktur gebunden ist.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Ausserhalb eines TRY-Blocks sollte diese Klausel nicht als gueltige Struktur durchgehen. Fehlende Blockpaare oder falsche Nestung muessen als Fehler sichtbar werden.

Verifiziertes Beispiel

Abgedeckt durch PB keyword compatibility (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CB Callback functions - PBXB64 Compiler Help

Startseite › Functions › CB Callback functions

CB Callback functions

In a

Typ:Funktion |Kategorie: Procedures

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CtlID = CB.CTL
CtlMsg = CB.CTLMSG
WinHndl = CB.HNDL
Value = CB.LPARAM
Msg = CB.MSG
Value = CB.WPARAM
CodeMsg = CB.NMCODE
NmPtr = CB.NMHDR
NmStruc = CB.NMHDR$
NmStruc = CB.NMHDR$(bytes)
NmHndl = CB.NMHWND
NmID = CB.NMID

' Legacy-Kompatibilitaetsaliasnamen
CtlID = CBCTL
CtlMsg = CBCTLMSG
WinHndl = CBHNDL
Value = CBLPARAM
Msg = CBMSG
Value = CBWPARAM

Beschreibung

PBXB64-Implementierung: PBXB64 senkt die Punktformen der Callback-Helfer auf Runtime-Zugriffe auf den aktuellen Callback-Status ab. Die registrierte Regression test_cb_callback_state.pb verifiziert CB.HNDL, CB.MSG, CB.WPARAM, CB.LPARAM, CB.CTL, CB.CTLMSG, CB.NMHDR, CB.NMHWND, CB.NMID, CB.NMCODE, die Legacy-Aliasnamen CBHNDL, CBMSG, CBWPARAM, CBLPARAM, CBCTL und CBCTLMSG sowie einen begrenzten CB.NMHDR$-Strukturkopiepfad. test_cb_nmhdr_sized.pb verifiziert die dokumentierte Groessenform CB.NMHDR$(bytes).

PBXB64-Grenze: CB.NMHDR$ kopiert derzeit die Basis-NMHDR-Bytes in einen Heap-String und ist mit nicht-nullhaltigen Testbytes geprüft. Beliebige Binärstrings mit eingebetteten Nullbytes hängen noch vom künftigen expliziten Binärstring-Längenvertrag ab.

When an event occurs (like a user clicking on a button , a character typed into a text box , etc.) Windows sends a message to the control Callback Function, or the Dialog Callback Function. The CB functions are used to easily retrieve information about the message. These CB functions can only be used within a callback function.

Callback functions in Windows have a standard set of four parameters. For this reason, PowerBASIC allows you to ignore them and save some typing in your source code. The implied parameters are:

FUNCTION DlgCallback(BYVAL hDlg AS DWORD _

BYVAL wMsg AS LONG _

BYVAL wParam AS LONG _

BYVAL lParam AS LONG)

Generische Rückruffunktionen

CB.HNDL

Diese Funktion gibt das Fensterhandle des übergeordneten Dialogs zurück. Dies ist der durch den hDlg-Parameter oben angegebene Wert.

CB.MSG

Jeder Nachrichtentyp, der an Ihre Rückruffunktion gesendet wird, hat einen eindeutigen numerischen Wert, z. B. %WM_COMMAND, %WM_NOTIFY usw. CB.MSG gibt den tatsächlichen numerischen Nachrichtenwert zurück der verarbeiteten Nachricht. Die Definitionen der numerischen Werte in anderen CB-Funktionen (CB.LPARAM, CB.WPARAM, CB.CTL usw.) können erst ermittelt werden, wenn CB.MSG identifiziert wird. Daher testen Rückruffunktionen normalerweise zuerst den Wert von CB.MSG.

CB.WPARAM

Wenn Windows eine Nachricht an eine Rückruffunktion sendet, enthält der wParam-Wert je nach Art der jeweiligen Nachricht (CB.MSG) unterschiedliche Werte. Mit anderen Worten: CB.WPARAM gibt einen nachrichtenabhängigen Wert zurück.

CB.LPARAM

Wenn Windows eine Nachricht an eine Rückruffunktion sendet, enthält der lParam-Wert je nach Art der jeweiligen Nachricht (CB.MSG) unterschiedliche Werte. Mit anderen Worten, CB.LPARAM gibt einen nachrichtenabhängigen Wert zurück.

%WM_COMMAND Spezifische Rückruffunktionen

CB.CTL

Wenn CB.MSG = %WM_COMMAND, dies Die Funktion gibt die ID-Nummer zurück, die dem Steuerelement mit der CONTROL ADD-Anweisung zugewiesen wurde. Für andere Werte von CB.MSG werden nachrichtenabhängige Werte zurückgegeben. Dieser Wert wird als niederwertiges Wort des Parameters wParam gesendet. Es entspricht funktional LO (WORD, wParam&) in einer herkömmlichen Funktion oder LO(WORD, CB.WPARAM) in einer DDT-Rückruffunktion.

CB.CTLMSG

Wenn CB.MSG = %WM_COMMAND, gibt diese Funktion die spezifische Steuernachricht zurück, die sie beschreibt das aufgetretene Ereignis. Beispielsweise gibt CB.CTLMSG %BN_CLICKED zurück, wenn der Benutzer auf eine Schaltfläche klickt. Für andere Werte von CB.MSG werden nachrichtenabhängige Werte zurückgegeben. Dieser Wert wird als höherwertiges Wort des Parameters wParam gesendet. Es entspricht funktional HI (WORD, wParam&) in einer herkömmlichen Funktion oder HI(WORD, CB.WPARAM) in einer DDT-Rückruffunktion.

%WM_NOTIFY Spezifischer Rückruf Funktionen

CB.NMCODE

Wenn CB.MSG = %WM_NOTIFY, gibt diese Funktion die spezifische Benachrichtigungsnachricht zurück, die das aufgetretene Ereignis beschreibt. Beispielsweise gibt CB.NMCODE %NM_SETFOCUS zurück, wenn das beschriebene Steuerelement den Fokus erhält. Für andere Werte von CB.MSG ist der zurückgegebene Wert bedeutungslos.

CB.NMHDR

Wenn CB.MSG = %WM_NOTIFY, gibt diese Funktion die Adresse (einen Zeiger) an den NMHDR UDT für diese Benachrichtigungsnachricht zurück. NMHDR ist definiert als:

Typ NMHDR

hwndFrom als DWord ' Handle des Steuerelements, das die Nachricht sendet

idfrom als DWord ' Bezeichner des Steuerelements, das die Nachricht sendet message

code as Long ' Benachrichtigungscode

Endtyp

Einige Benachrichtigungsnachrichten (%NM_CHAR, %NM_CLICK usw.) erfordern eine erweiterte Version der NM-Struktur. Allerdings beginnen alle NM-Strukturen mit einem NMHDR-UDT, sodass der hier zurückgegebene Zeiger immer korrekt ist. Für andere Werte von CB.MSG ist der von CB.NMHDR zurückgegebene Zeiger bedeutungslos.

CB.NMHDR$

If CB.MSG = %WM_NOTIFY, this function returns the contents of the NMHDR UDT as a dynamic string . If the notification message is one which requires an extended version of the NM structure, the string returned contains all of the data for the extended UDT. However, in all cases, the first 12 bytes of the returned string will be the contents of NMHDR. You can use TYPE SET to assign the string data to an appropriate user-defined type. For other values of CB.MSG, the string returned by CB.NMHDR$ is meaningless.

The following notification messages use the extended NM structures as listed, so an appropriately longer string is returned:

Message

%NM_CLICK

NMMOUSE

%NM_RCLICK

NMMOUSE

%NM_NCHITTEST

NMMOUSE

%NM_KEYDOWN

%NM_SETCURSOR

NMMOUSE

%NM_CHAR

NMCHAR

%NM_TOOLTIPSCREATED

NMTOOLTIPSCREATED

Other special notify messages may use a different extended NM structure than those listed above. To ensure compatibility, you can include an optional numeric parameter to specify the size of the special UDT you are using:

TYPE SET NotifyUDT = CB.NMHDR$(sizeof(NotifyUDT))

CB.NMHWND

If CB.MSG = %WM_NOTIFY, this function returns the handle of the control which sent this message. For other values of CB.MSG, the value returned is meaningless.

CB.NMID

If CB.MSG = %WM_NOTIFY, this function returns the ID number assigned to this control. For other values of CB.MSG, the value returned is meaningless.

Einschränkungen

Diese Funktionen liefern nur sinnvolle Werte, solange Callback-Status verfügbar ist. PBXB64 akzeptiert die alten Aliasnamen CBMSG, CBHNDL, CBLPARAM, CBWPARAM, CBCTL und CBCTLMSG weiterhin für Kompatibilität mit älteren Quellen; neuer Code sollte die Punktformen verwenden.

Siehe auch

  • Callbacks
  • Dynamic Dialog Tools

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CBYT - PBXB64 Compiler Help

Startseite › Functions › CBYT

CBYT

Convert a value to specific

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

bytevar? = CBYT( numeric_expression )
currencyvar@ = CCUR( numeric_expression )
currencyextvar@@ = CCUX( numeric_expression )
doublevar# = CDBL( numeric_expression )
doublewordvar??? = CDWD( numeric_expression )
extendedvar## = CEXT( numeric_expression )
integervar% = CINT( numeric_expression )
longintvar& = CLNG( numeric_expression )
quadintvar&& = CQUD( numeric_expression )
singlevar! = CSNG( numeric_expression )
wordvar?? = CWRD( numeric_expression )

Beschreibung

Each of these functions converts a numeric expression to a particular variable type. In each case, numeric_expression must be within the legal range for the result type. The numeric_expression will be rounded if necessary.

Function

Result type

Währung

Extended-currency

Double-precision floating-point

Doppelwort

Extended-precision floating-point

Ganze Zahl

Lange Ganzzahl

Quad-Ganzzahl

Single-precision floating-point

These conversion functions are rarely needed as PowerBASIC automatically performs any necessary conversions when executing an assignment statement or passing parameters. For example:

e% = f#

is equivalent to:

e% = CINT(f#)

In the case of the functions that convert to integral class values, the fractional part of the number is rounded. If the fractional part is exactly .5 then it rounds to the nearest even integral value. For example, CINT(1.5) returns 2, CINT(.5) returns 0, and CLNG(-0.6) returns -1.

Einschränkungen

CSNG limit string display to 7 significant digits.

Siehe auch

  • DECKE
  • CVI and associated functions
  • FIX
  • INT
  • MKI$ and associated functions

Beispiel

#COMPILE EXE
#DIM ALL
' math_cast_rounding
FUNCTION PBMAIN() AS LONG
  IF (CINT(3.7)) <> (4) THEN FUNCTION = 1: EXIT FUNCTION
  IF (CLNG(3.7)) <> (4) THEN FUNCTION = 2: EXIT FUNCTION
  IF (CSNG(3.7)) <> (4) THEN FUNCTION = 3: EXIT FUNCTION
  IF (CDBL(3.7)) <> (4) THEN FUNCTION = 4: EXIT FUNCTION
  IF (CCUR(3.7)) <> (4) THEN FUNCTION = 5: EXIT FUNCTION
  IF (CUX(3.7)) <> (4) THEN FUNCTION = 6: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


#CCODE - C-Quelle einbetten — PBXB64 Help

Startseite › General Reference › #CCODE - C-Quelle einbetten — PBXB64 Help
Hilfe zum PBXB64-Compiler

#CCODE - C-Quelle einbetten

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

#CCODE
int helper(void) { return 42; }
#ENDC

Detailverhalten

Beginnt einen eingebetteten C-Quellblock in einer PB-Hostdatei. Der Scanner sammelt den Block und leitet ihn an den C-Frontend-/Lowering-Pfad weiter, bevor die PB-Ausfuehrung fortgesetzt wird.

Praktische Verwendung

Verwenden Sie diesen Einstieg, um einen eingebetteten C-Block genau dort zu starten, wo der PB-Quelltext in die C-uebersetzte Hilfslogik uebergehen soll. Der Block muss mit dem passenden Endmarker geschlossen werden, damit der Scanner den Bereich sauber an die C-Pipeline uebergibt.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Ein fehlender Abschlussmarker oder ein falsch verschachtelter Block sollte nicht stillschweigend akzeptiert werden. Wenn der Parser den Block nicht eindeutig begrenzen kann, muss die Quelle korrigiert und erneut geprueft werden.

Verifiziertes Beispiel

Abgedeckt durch examples/hybrid/pbmain_hybrid.pb (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CHAIN - PBXB64 Help

Startseite › General Reference › CHAIN

CHAIN

Startet ein anderes Programm und uebergibt die Kontrolle. Die Anweisungsform beendet den aktuellen Prozess mit dem Exit-Code des Kindprozesses; die Funktionsform liefert den Exit-Code an den Aufrufer zurueck.

Kind: PowerBASIC feature | Category: PowerBASIC / Tested Feature

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

CHAIN command$
result& = CHAIN(command$)

Beschreibung

Diese Seite beschreibt das PBXB64-Verhalten, das durch die aktuelle Validierungsmatrix abgedeckt ist. Verwenden Sie die hier gezeigte Syntax fuer Regressionstests; weitergehende PowerBASIC-Formen gelten als separate Kompatibilitaetsarbeit, sofern keine andere Seite sie dokumentiert.

Unterstuetzter Umfang

Die dokumentierte Teilmenge ist absichtlich genau: Beispiele verwenden bevorzugt skalare LONG-Werte, Array-Beispiele benutzen normale PB-logische Indizes, und laufzeitabhaengige Operationen sollen immer den Rueckgabestatus pruefen. Wenn ein Feature sowohl Anweisungs- als auch Funktionsschreibweise besitzt, beschreibt diese Seite den funktionsorientierten Seiteneintrag und verweist auf die breitere BASIC-Referenz.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL rc AS LONG
    rc = CHAIN("cmd.exe /c exit 7")
    FUNCTION = rc
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_chain_statement.pb` und `test_chain_function.pb`.

Fuer Release-Arbeiten sollte jede Syntaxform einen kleinen ausfuehrbaren Test besitzen. Ein guter Test initialisiert alle Eingaben, fuehrt den dokumentierten Befehl oder die Funktion aus, prueft das exakte Ergebnis und liefert bei Fehler einen von Null verschiedenen Exit-Code. Dadurch bleiben Hilfeaussagen an reproduzierbares Verhalten eines isolierten PBXB64-Compilers gebunden.

Grenzen

Nicht gezeigte PowerBASIC-Varianten duerfen aus dieser Seite nicht als unterstuetzt abgeleitet werden. Formen, die hier nicht stehen, benoetigen eigene Implementierung, Diagnostik, Tests und Hilfetext, bevor sie als abgeschlossen beschrieben werden.

Siehe auch

  • BASIC Language Reference
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Zeichen, Zeichenfolgen und Unicode - PBXB64 Compiler-Hilfe

Startseite › Funktionen › Zeichen, Zeichenfolgen und Unicode

Zeichen, Zeichenfolgen und Unicode

Eine Zeichenfolge besteht aus einem Satz von null oder mehr Zeichen. Ein Zeichen ist ein alphabetischer Buchstabe, eine Zahl, ein Satzzeichen oder sogar nicht druckbare Steuercodes, die normalerweise bei der Formatierung des Textes hilfreich sind.

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Diese Darstellung ist praktisch, da eine Zeichenfolge aus Textzeichen problemlos als Reihe kleiner ganzzahliger Zahlen gespeichert werden kann. Das Wort „Hallo“ wird beispielsweise als 72, 105, 108, 108, 111 gespeichert. Einfacher geht es nicht. Wie werden die Nummern vergeben und zugeordnet? Es ist lediglich eine Frage der gegenseitigen Zustimmung derjenigen, die sie nutzen. Solange sich alle über die Assoziationen einig sind, funktioniert das System gut. Allerdings haben wir im Laufe der Jahre gewisse Wachstumsschmerzen erlebt. Mit der weltweiten Zunahme der Computernutzung werden größere Zeichensätze benötigt, um die erforderlichen Zeichen darzustellen. Wir sind eindeutig an dem Punkt angelangt, an dem jeder Programmierer alternative Zeichensätze für seine Anwendungen in Betracht ziehen muss. Bei Nichtbeachtung können empfindliche Strafen verhängt werden. Wenn Sie feststellen, dass Sie Datendateien von einer externen Quelle oder Text aus dem Internet nicht mehr lesen können, ist es zu spät. In den folgenden Abschnitten werden die gebräuchlichsten und am häufigsten verwendeten Zeichensätze beschrieben.

ASCII war der erste Zeichensatz, der auf kleinen Computern verwendet wurde. Tatsächlich verwenden alle anderen hier beschriebenen Sets ASCII-Codes unverändert für eine Basis. ASCII ist ein Satz von 128 Zeichen, nummeriert von 0 bis 127. Es wurde für amerikanisches Englisch entwickelt und definiert daher nur Buchstaben, Zahlen, Satzzeichen und Steuercodes ohne Akzent. Solange Sie nur englischen Text benötigen, funktioniert ASCII ziemlich gut.

ASCII benötigt nur 7 Bit Speicherplatz pro Zeichen, daher war es praktisch, jedes Zeichen in einem Byte zu speichern. Der letzte Teil wurde einfach ignoriert. Das bedeutete natürlich, dass die Werte von 128 bis 255 ungenutzt waren. Diese Lücke würde nicht lange anhalten.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Zeichen, Zeichenfolgen und Unicode soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Zeichen, Zeichenfolgen und Unicode mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


CHDIR – PBXB64-Compiler Hilfe

Startseite › Funktionen › CHDIR

CHDIR

Ändern Sie das aktuelle (Standard-)Verzeichnis auf dem Standardlaufwerk oder einem anderen Laufwerk (ähnlich dem DOS-Befehl CHDIR). CHDIR betrifft nur das Standardlaufwerk für das aktuelle Programm.

Typ:Anweisung |Kategorie: Dateiverwaltung

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CHDIR path

Beschreibung

path ist ein Zeichenfolgenausdruck, der entweder einen relativen oder einen expliziten Verzeichnisnamen enthält. Der Verzeichnisname kann aus einem (DOS-Stil) Short File Name (SFN)-Verzeichnisnamen, einem Long File Name (LFN)-Verzeichnisnamen oder einer Kombination aus beiden bestehen. Außerdem kann dem Pfad ein Laufwerksbuchstabe und ein Doppelpunkt (z. B. „D:“) vorangestellt werden, um das aktuelle Verzeichnis auf einem nicht standardmäßigen Laufwerk zu ändern.

Das aktuelle Verzeichnis ist der Speicherort, an dem Ihr Programm standardmäßig Dateioperationen ausführt. Somit:

CHDIR "\DATA"

wechselt in das Unterverzeichnis \DATA auf dem aktuellen Laufwerk und:

CHDIR „..\DATA2“

ändert das aktuelle Verzeichnis in ein Verzeichnis, dessen übergeordnetes Verzeichnis auch das übergeordnete Verzeichnis des ursprünglichen Verzeichnisses ist. Der doppelte Punkt impliziert das übergeordnete Verzeichnis.

CHDIR "J:\Programme\Internet Explorer"

changes the current directory of Drive J. Drive J need not be the current default drive.

If path does not specify a valid directory on the target drive, a run-time Error 76 occurs ("Path not found").

A program that changes the current directory on the default drive also changes its active directory.

path may also be used with UNC names (i.e., \\server\share), but their use is subject to operating system restrictions.

PBXB64 senkt CHDIR path$ auf den eingebetteten Helfer bestof_chdir ab. Dieser ruft die Win32-API SetCurrentDirectoryA auf.

Einschränkungen

CHDIR is not intended to change the current default drive. Use CHDRIVE instead.

Die fokussierte PBXB64-Zertifizierung deckt relative Verzeichniswechsel in und aus temporaeren Testverzeichnissen ab. Laufwerksrelative Pfade, UNC, Unicode, ungueltige Pfade und PBWin-ERR-Paritaet bleiben breitere Datei-/Pfad-Kompatibilitaetsarbeit.

Siehe auch

  • CHDRIVE
  • CURDIR$
  • MKDIR
  • RMDIR

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


CHDRIVE - PBXB64 Compiler Help

Startseite › Functions › CHDRIVE

CHDRIVE

Change the current default drive.

Typ:Anweisung |Kategorie: Dateiverwaltung

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CHDRIVE drive

Beschreibung

drive is a string expression whose first character is a letter from A to the highest logical drive letter. The trailing colon (:) that DOS uses is optional in PowerBASIC. If drive does not indicate a valid drive, a run-time Error 76 occurs ("Path not found").

Siehe auch

  • CHDIR
  • CURDIR$
  • MKDIR
  • RMDIR

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CHOOSE - PBXB64 Compiler Help

Startseite › Functions › CHOOSE

CHOOSE

Return one of several values, based upon the value of an index.

Typ:Funktion |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET] für numerisches CHOOSE mit konstantem Selektor; Laufzeit-Selektor und CHOOSE$ implementiert und getestet

Syntax

y = CHOOSE( index& , choice1 [, choice2 ] ...[ELSE choice9 ])
y& = CHOOSE&( index& , choice1 [, choice2 ] ...[ELSE choice9 ])
y$ = CHOOSE$( index& , choice1 [, choice2 ] ...[ELSE choice9 ])
y = CHOOSE([BIT] index&, choice1 [, choice2 ] ...[ELSE choice9 ])
y& = CHOOSE&([BIT] index&, choice1 [, choice2 ] ...[ELSE choice9 ])
y$ = CHOOSE$([BIT] index&, choice1 [, choice2 ] ...[ELSE choice9 ])
y$ = CHOOSE$([BITS] index&, choice1 [, choice2 ] ...[ELSE choice9 ])

Beschreibung

These functions may take any number of choice parameters. They return one of the parameters, or a combination of them, based upon the value of index& . In the standard form, index& makes the choice based upon the sequence of the parameters. That is, if index& is one, choice1 is returned. If two, choice2 is returned, etc. If index& is not equal to one of the choice values, the default value is returned to the calling code.

CHOOSE expects choices of any numeric type. CHOOSE& expects choices optimized for an integral data type. CHOOSE$ expects choices of string type. CHOOSE% is recognized as a valid synonym for CHOOSE&.

If no match is made with one of the choice values, the value zero (0) or an empty (zero-length) string is normally returned. However, if an ELSE clause is included as the last choice, its value is returned as the default value. For example:

ChoiceVar$ = CHOOSE$(7,"ONE", "TWO" ELSE "NUL")

In this case, the ELSE expression "NUL" is returned.

Die BIT- und BITS-Selektoroptionen sind in PBXB64 noch nicht implementiert.

Einschränkungen

Der Compiler erzeugt eine bedingte Kaskade, sodass nur die ausgewählte Choice zur Laufzeit ausgeführt wird, wenn es sich um einfache Literal- oder Variablenargumente handelt. Da Funktionsargumente vor dem CHOOSE/CHOOSE$-Aufruf ausgewertet werden, können Ausdrücke mit Funktionsaufrufen und Seiteneffekten dennoch für nicht ausgewählte Choices ausgewertet werden.

Siehe auch

  • IIF
  • IIF&
  • IIF$
  • MAX
  • MAX&
  • MAX$
  • MIN
  • MIN&
  • MIN$
  • SWITCH
  • SWITCH&
  • SWITCH$
  • SELECT

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CHRBYTES - PBXB64 Compiler Help

Startseite › Functions › CHRBYTES

CHRBYTES

Determine the size of a single character in a string

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

siz& = CHRBYTES( string_expr )

Beschreibung

CHRBYTES gibt die Speicherbreite eines Zeichens fuer den uebergebenen String-Ausdruck zurueck. PBXB64 gibt 1 fuer ANSI-String-Ausdruecke wie STRING, STRINGZ und String-Literale zurueck. Fuer Wide-String-Ausdruecke wie WSTRING und WSTRINGZ wird 2 zurueckgegeben.

Das Ergebnis basiert auf dem Ausdruckstyp, nicht auf einer Inhaltsanalyse des aktuellen Textes.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL s AS STRING
    LOCAL w AS WSTRING

    s = "abc"
    w = WCHR$(&H03A9)

    IF CHRBYTES(s) <> 1 THEN FUNCTION = 1: EXIT FUNCTION
    IF CHRBYTES(w) <> 2 THEN FUNCTION = 2: EXIT FUNCTION
    FUNCTION = 0
END FUNCTION

Siehe auch

  • LEN
  • SIZEOF

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


ChrToOem$ - PBXB64 Compiler-Hilfe

Startseite › Funktionen › ChrToOem$

ChrToOem$

Übersetzt einen String

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

o$ = ChrToOem$( AnsiOrWide$ )

Beschreibung

AnsiOrWide$ enthält eine Reihe von ANSI-Zeichen oder WIDE-Zeichen (16-Bit), in die ChrToOem$ übersetzt wird OEM-Byte Zeichen.

Siehe auch

  • OemToChr$
  • ChrToUtf8$
  • Utf8ToChr$

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


ChrToUtf8$ - PBXB64 Compiler-Hilfe

Startseite › Funktionen › ChrToUtf8$

ChrToUtf8$

Übersetzt eine Zeichenfolge von

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

o$ = ChrToUtf8$( AnsiOrWide$ )

Beschreibung

AnsiOrWide$ enthält eine Reihe von ANSI-Zeichen oder WIDE-Zeichen (16-Bit), ChrToUtf8$ übersetzt sie in UTF-8-Byte Zeichen.

Siehe auch

  • ChrToOem$
  • OemToChr$
  • Utf8ToChr$

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


CLASS/END CLASS – PBXB64-Compiler Hilfe

Startseite › Funktionen › CLASS/END CLASS

CLASS/END CLASS

Erstellen Sie den Code und die Daten für an

Typ:Schlüsselwort |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CLASS name [ $GUID ] [COMMON] [OPTIMIZE] [AS COM | AS EVENT]
Class Method code blocks...
INSTANCE ClassName AS STRING
INTERFACE name $GUID [AS EVENT]
INHERIT IUNKNOWN
Method and Property code blocks...
END INTERFACE
EVENT SOURCE interface-name
END CLASS

Beschreibung

CLASS / END CLASS-Anweisungen schließen die Schnittstellenimplementierung(en) und Instanzvariablendeklarationen einer Klasse ein. METHOD- und PROPERTY-Blöcke enthalten den Code, der für ein Objekt ausgeführt werden soll. INSTANCE-Anweisungen definieren die Variablen, die für jede Instanz eines Objekts dieser Klasse eindeutig sind.

Der Name und die optionale $GUID werden vom Programmierer zur Identifizierung der Klasse bereitgestellt. Standardmäßig gilt eine Klasse als privat, sodass auf die Methoden nur aus der EXE- oder DLL-Datei zugegriffen werden kann, in der sie definiert ist. Das AS COM-Attribut macht die Klasse extern für praktisch jeden Prozess verfügbar, der COM-fähig ist.

Bei einer privaten Klasse kann die $GUID frei weggelassen werden, da PowerBASIC die Klasse leicht anhand des Namens identifizieren kann. Bei einer veröffentlichten COM-Klasse sollten Sie eine bestimmte GUID Ihrer Wahl einfügen. Wenn es weggelassen wird, wird vom Compiler eine zufällige GUID erstellt, die sich jedoch jedes Mal ändert, wenn Sie das Programm kompilieren. Es wird schwierig sein, dies mit anderen Programmen zu synchronisieren, die Ihr Objekt identifizieren und darauf zugreifen möchten.

COMMON

Der optionale COMMON-Deskriptor kann eingefügt werden, um anzugeben, dass diese Klasse von und zwischen verknüpften Einheitenmodulen (Host/Main oder SLL) frei referenziert werden kann. Dies hat den zusätzlichen Nebeneffekt, dass sichergestellt wird, dass die Klasse nicht durch #OPTIMIZE CODE ON .

AS EVENT

entfernt wird. Wenn eine Klasse eine Ereignisquelle ist (sie generiert Ereignisse, anstatt Ereignisse zu verarbeiten), sind eine oder mehrere EVENT SOURCE-Anweisungen enthalten, um die Ereignisschnittstellen zu benennen. Die Ereignisschnittstellen müssen separat deklariert und implementiert werden. Ein Ereignis wird durch die Ausführung einer RAISEEVENT-Anweisung oder einer OBJECT RAISEEVENT-Anweisung in der Klasse generiert. Wenn es sich bei einer Klasse um einen Event-Handler handelt (sie enthält Code zum Behandeln eines von einer Ereignisquelle generierten Ereignisses), muss das AS EVENT-Attribut in der CLASS-Anweisung und jeder INTERFACE-Anweisung erscheinen. Ein Event-Handler wird in der COM-Terminologie auch als „Event Sink“ bezeichnet.

OPTIMIZE

With code optimization enabled ( #OPTIMIZE CODE ON) , PowerBASIC removes code for subs and functions which are not called. Where possible, this technique is even applied to individual methods and property methods within classes.

Of course, if an object variable is transferred out of the current module (to another EXE/SLL/DLL), there is no way to determine (at compile-time) which methods may be called on it at run-time, so none can be safely removed. COM, COMMON, and EVENT classes allow variables to be transferred out of the module, so they block removal of any code in the class.

The OPTIMIZE descriptor allows you to control this code optimization to a high degree. If you specify the OPTIMIZE option, you are stating that no object variables on this class will be transferred out of the module. Therefore, PowerBASIC is free to remove any code in the class which is not referenced. This is a powerful tool which can allow you to substantially reduce the size of your program.

The OPTIMIZE rules can be summarized:

Siehe auch

  • #OPTIMIEREN
  • EVENT SOURCE
  • EVENTS
  • INSTANCE
  • INTERFACE (Direct)
  • INTERFACE (IDBind)
  • Just what is COM?
  • METHOD
  • PROPERTY
  • RAISEEVENT
  • Was ist überhaupt ein Objekt?

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CLIP$ - PBXB64 Compiler Help

Startseite › Functions › CLIP$

CLIP$

Delete characters from a string

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = CLIP$(LEFT StringExpression , Count& )
s$ = CLIP$(RIGHT StringExpression , Count& )
s$ = CLIP$(MID StringExpression , Start& , Count& )

Beschreibung

Returns the contents of StringExpression with Count& characters removed from the left side.

Returns the contents of StringExpression with Count& characters removed from the right side.

Returns the contents of StringExpression with Count& characters removed starting at position Start& . The first character is considered position 1, the second position 2...

If Count& is negative, or Start& is less than one, the return value is undefined.

Einschränkungen

If Count& is less than one, the entire string is returned. If Start& is less than one, the results are undefined.

Siehe auch

  • EXTRACT$
  • LTRIM$
  • MITTLERER $
  • REMOVE$
  • REPLACE
  • RTRIM$
  • SHRINK$
  • STRINSERT$
  • STRDELETE$
  • TRIM$
  • UNWRAP$

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CLIPBOARD - PBXB64 Compiler Help

Startseite › Statements › CLIPBOARD

CLIPBOARD

Copy data to and from the Windows clipboard.

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CLIPBOARD GET BITMAP TO ClipVar [, ClipResult ]
CLIPBOARD GET OEMTEXT TO AnsiStrgVar [, ClipResult ]
CLIPBOARD GET TEXT TO StrgVar [, ClipResult ]
CLIPBOARD GET UNICODE TO StrgVar [, ClipResult ]
CLIPBOARD RESET [, ClipResult ]
CLIPBOARD SET BITMAP ClipHndl [, ClipResult ]
CLIPBOARD SET OEMTEXT StrgExpr [, ClipResult ]
CLIPBOARD SET TEXT StrgExpr [, ClipResult ]
CLIPBOARD SET UNICODE StrgExpr [, ClipResult ]

PBXB64 implementation: TEXT, OEMTEXT, UNICODE, BITMAP, RESET, and optional result-code forms are implemented through the embedded Win32 runtime. Clipboard text forms round-trip strings; BITMAP forms transfer an HBITMAP handle.

Tests: test_clipboard_text.pb, test_clipboard_oem_unicode.pb, Undtest_clipboard_bitmap.pb.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht
← CLIP$ Nach oben CLOSE →

Clipboard-Prüfung

Clipboard-Beispiele sollen eine bekannte ANSI- oder Unicode-Zeichenfolge schreiben, wieder lesen, exakt vergleichen und die Zwischenablage nur dann wiederherstellen oder leeren, wenn das Beispiel diesen Zustand ausdrücklich besitzt. Interaktive Tests sollen nennen, dass sie die Windows-Zwischenablage verändern.

Laufzeit-Hinweise

Clipboard-Operationen benötigen eine Windows-Desktop-Sitzung und können fehlschlagen, wenn ein anderer Prozess die Zwischenablage besitzt. Behandeln Sie Fehlerpfade und isolieren Sie Tests von Benutzerdaten in der Zwischenablage.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL s AS STRING
    s = "PBXB64 clipboard"
    CLIPBOARD SET TEXT s
    CLIPBOARD GET TEXT TO s
    IF s <> "PBXB64 clipboard" THEN FUNCTION = 1
END FUNCTION

Validierungsbeleg

Validierungsbeleg: test_clipboard_text.pb, test_clipboard_oem_unicode.pb und test_clipboard_bitmap.pb pruefen das aktuelle TEXT-, OEMTEXT-, UNICODE-, BITMAP- und RESET-Verhalten.


CLSID$ - PBXB64 Compiler Help

Startseite › Functions › CLSID$

CLSID$

Return a 16-byte

Typ:Funktion |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

a$ = CLSID$( ProgramID$ )

Beschreibung

A CLSID string is a 128-bit (16-byte) binary string representing the GUID or UUID of a COM object/component. A CLSID string is not in a human-readable format.

You can convert textual ID name of a COM object/component into a CLSID string with the CLSID$ function. CLSID examines the system registry in order to determine the CLSID string associated with the ProgramID$ string.

The ProgramID$ parameter is not case-sensitive, so "MSAGENT.CONTROL.2", "MSAgent.Control.2" and "msagent.control.2" all refer to the same COM object/component. If the ProgramID$ cannot be found, or if any error occurs during the lookup and conversion process, CLSID$ will not set the ERR system variable, but will return an empty string.

To convert the binary CLSID string into human-readable GUID/UUID format, use the GUIDTXT$ function. CLSID$ is the complement to the PROGID$ function.

PowerBASIC programmers rarely, if ever, need to deal with CLSID strings in order to utilize a COM object or component.

The return string may be assigned to a dynamic string , fixed-length or nul-terminated string (at least 16 bytes long), or (typically) a GUID variable. See DIM for more information.

Siehe auch

  • DIM
  • GUID$
  • GUIDTXT$
  • INTERFACE (Direct)
  • INTERFACE (IDBind)
  • ISNOTHING
  • ISOBJECT
  • LET (with Objects)
  • OBJECT
  • OBJACTIVE
  • OBJPTR
  • OBJRESULT
  • PROGID$
  • Wie sieht eine Klasse aus?
  • Was ist überhaupt ein Objekt?

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CODEPTR - PBXB64 Compiler Help

Startseite › Functions › CODEPTR

CODEPTR

Obtain a 32-bit address of a

Typ:Funktion |Kategorie: Memory & Pointers

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

AddrVar = CODEPTR( Label )
AddrVar = CODEPTR( ProcName )

Beschreibung

CODEPTR ermittelt die Adresse eines Labels, einer Sub, Function, FastProc oder eines ASMDATA-Blocks. Die erste Form kann verwendet werden, um die Adresse eines Labels innerhalb derselben Prozedur zu erhalten. Die zweite Form dient zum Ermitteln der Adresse einer Sub, Function, FastProc oder eines ASMDATA-Block-Labels.

In PBXB64 werden ASMDATA-Block-Labels als schreibgeschützte Globals emittiert und sind sowohl auf Modulebene als auch innerhalb einer Prozedur gültige CODEPTR-Ziele, sofern der ASMDATA-Block lexikalisch vor dem CODEPTR-Verweis steht.

CODEPTR is particularly useful when it is necessary to pass the address of a SUB or FUNCTION to PowerBASIC or Windows to specify a Callback Function.

Einschränkungen

CODEPTR cannot obtain the address of a METHOD or PROPERTY as direct access to them would constitute an illegal operation.

Siehe auch

  • STRPTR
  • VARPTR
  • CALL DWORD

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


Collection Objects - PBXB64 Compiler Help

Startseite › Functions › Collection Objects

Collection Objects

The following operations provides a convenient way to refer to a related group of items:

Typ:Schlüsselwort |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

ILinkListCollection.ADD

An item is added to the end of the LinkListCollection.

ILinkListCollection.CLEAR

All items are removed from the LinkListCollection.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


StackCollection - PBXB64 Compiler Help

Startseite › Functions › StackCollection

StackCollection

A collection object is a set of items which can be referred to as a unit. It provides a convenient way to refer to a related group of items as a single object. The items in a collection need only be related by the fact that they exist in the collection. They do not have to share the same data type.

Typ:Schlüsselwort |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

< ObjectVar >.membername( params )
RetVal = < ObjectVar >.membername( params )
< ObjectVar >.membername( params ) TO ReturnVariable

Beschreibung

Items in a PowerCollection may be retrieved by their key using the ITEM method. They may be retrieved sequentially using the NEXT or PREVIOUS method. Each key in a PowerCollection must be unique. Keys in a PowerCollection are case-sensitive. To access the keys in a case-insensitive manner, you must create and retrieve all keys as either upper case or lower case, but not mixed.

The Dispatch ID (DispID) for each member method is displayed within angle brackets.

Power Collection Methods

ADD <3> ( PowerKey AS WString, PowerItem AS Variant)

Die PowerItem-Variante wird am Ende der PowerCollection hinzugefügt. Es wird zum späteren Abruf mit der PowerKey-Zeichenfolge verknüpft. Wenn der Vorgang erfolgreich war, wird ein HResult von S_OK (0) zurückgegeben. Wenn dies aufgrund eines doppelten Schlüssels fehlschlägt, wird ein HResult von E_DUPLICATEKEY (&H800A01C9) zurückgegeben und ein Objektfehler (99) generiert.

CLEAR <4>

Alle PowerKeys und PowerItems werden aus dem entfernt PowerCollection.

CONTAINS <5> ( PowerKey AS WString) AS Long

Die PowerCollection wird gescannt, um festzustellen, ob der angegebene PowerKey vorhanden ist. Wenn es gefunden wird, wird die Indexnummer dieses Elements (Bereich von 1 – COUNT) zurückgegeben. Dieser Wert wird immer als true ausgewertet. Wenn nicht gefunden, wird der Wert false (0) zurückgegeben.

COUNT <6> AS Long

Die Anzahl der derzeit in der PowerCollection enthaltenen Datenelemente wird an den Aufrufer zurückgegeben.

ENTRY <7> ( Index AS Long, OUT PowerKey als WString, OUT PowerItem als Variant)

Der durch die Indexnummer angegebene PowerCollection-Eintrag wird in den beiden angegebenen OUT-Parametern an den Aufrufer zurückgegeben. Wenn die Indexnummer kleiner als eins oder größer als die Elementanzahl ist, ist die zurückgegebene Variante vom Typ leer (VT_EMPTY) und das OBJRESULT ist %S_FALSE (1).

FIRST <1> AS Long

Der aktuelle INDEX für die PowerCOLLECTION ist auf gesetzt eins (1), sodass nachfolgende Verweise auf die NEXT-Methode von Anfang an auf Mitgliedselemente zugreifen. Der vorherige Wert des INDEX wird an den Aufrufer zurückgegeben.

INDEX <8> ( Index AS Long) AS Long

Der aktuelle INDEX für die PowerCOLLECTION wird auf die angegebene Indexnummer gesetzt. Wenn der Parameter kleiner als eins oder größer als die aktuelle Anzahl von Datenelementen ist, wird der INDEX nicht geändert. Der vorherige Wert des INDEX wird an den Aufrufer zurückgegeben.

IndexVar& = ObjectVar .INDEX(0)

Das obige Beispiel ruft die aktuelle Indexnummer ab, ohne sie zu ändern, und weist sie der Variablen IndexVar& zu .

ITEM <9> ( PowerKey AS WString) AS Variant

Das mit dem angegebenen PowerKey verknüpfte PowerItem wird zurückgegeben. Wenn der angegebene Schlüssel nicht gefunden wird, ist die zurückgegebene Variante vom Typ leer (VT_EMPTY) und das OBJRESULT ist %S_FALSE (1).

LAST <10> AS Long

Der aktuelle INDEX für die PowerCOLLECTION wird auf das letzte Element gesetzt, damit nachfolgende Referenzen möglich sind Die PREVIOUS-Methode greift vom Ende auf Mitgliedselemente zu. Der vorherige Wert des INDEX wird an den Aufrufer zurückgegeben.

NEXT <2> AS Variant

Mit der NEXT-Methode können die PowerCollection-Datenelemente sequentiell abgerufen werden. Bei jedem Verweis auf NEXT wird das Datenelement an der durch INDEX angegebenen Position an den Aufrufer zurückgegeben und der INDEX wird erhöht. Wenn der Vorgang erfolgreich ist, wird OBJRESULT auf %S_OK (0) gesetzt. Wenn keine weiteren Datenelemente abzurufen sind, wird OBJRESULT auf %S_FALSE (1) gesetzt.

PREVIOUS <11> AS Variant

Mit der PREVIOUS-Methode können die PowerCollection-Datenelemente sequentiell abgerufen werden. Bei jedem Verweis auf PREVIOUS wird das Datenelement an der durch INDEX angegebenen Position an den Aufrufer zurückgegeben und der INDEX dekrementiert. Wenn der Vorgang erfolgreich ist, wird OBJRESULT auf %S_OK (0) gesetzt. Wenn keine weiteren Datenelemente abzurufen sind, wird OBJRESULT auf %S_FALSE (1) gesetzt.

REMOVE <12> ( PowerKey AS WString)

Der angegebene PowerKey und das damit verbundene PowerItem werden aus der PowerCollection entfernt. Die Indexnummer jedes Datenelements nach dem entfernten Element wird um eins dekrementiert. Wenn der angeforderte PowerKey nicht gefunden wird, gibt OBJRESULT %S_FALSE (1) zurück und es wird keine Operation ausgeführt.

REPLACE <13> ( PowerKey AS WString, PowerItem AS Variant)

Das mit dem angegebenen PowerKey verknüpfte PowerItem wird durch das neue angegebene PowerItem ersetzt. Wenn der angeforderte PowerKey nicht gefunden wird, gibt OBJRESULT %S_FALSE (1) zurück und es wird keine Operation ausgeführt.

SORT <14> (Flags AS Long)

Die Datenelemente in der PowerCollection werden basierend auf dem Text in den zugehörigen PowerKeys sortiert. Wenn der Parameter Flags Null (0) ist, werden die Elemente in aufsteigender Reihenfolge sortiert. Wenn eins (1), werden die Elemente in absteigender Reihenfolge sortiert.

LinkList Collection

Eine verknüpfte Listensammlung ist ein geordneter Satz von Datenelementen, auf die über ihre Position in der Liste und nicht über einen alphanumerischen Zeichenfolgenschlüssel zugegriffen wird. Jedes Datenelement wird als Variantenvariable übergeben und gespeichert. Sie können diese Datenelemente anhand ihrer Positionsnummer oder sequentiell in aufsteigender oder absteigender Reihenfolge abrufen.

Syntax

Die KLASSE ist „LinkListCollection“. Die SCHNITTSTELLE ist ILinkListCollection (eine DUAL-Schnittstelle).

< ObjectVar >.membername( params )

RetVal = < ObjectVar >.membername( params )

< ObjectVar >.membername( params ) TO ReturnVariable

Remarks

Elemente in einer LinkListCollection können anhand ihrer Positionsnummer mithilfe der ITEM-Methode abgerufen werden. Sie können nacheinander mit den Methoden NEXT oder PREVIOUS abgerufen werden.

The Dispatch ID (DispID) for each member method is displayed within angle brackets.

LinkList-Sammelmethoden

ADD <3> (PowerItem AS-Variante)

Die PowerItem-Variante wird am Ende der hinzugefügt LinkListCollection.

CLEAR <4>

Alle PowerItems werden aus der LinkListCollection entfernt.

COUNT <5> AS Long

Die Anzahl der derzeit in der LinkListCollection enthaltenen Datenelemente wird an die zurückgegeben caller.

FIRST <1> AS Long

Der aktuelle INDEX für die LinkListCOLLECTION ist auf eins (1) gesetzt, sodass nachfolgende Verweise auf die NEXT-Methode von Anfang an auf Mitgliedselemente zugreifen. Der vorherige Wert des INDEX wird an den Aufrufer zurückgegeben.

INDEX <6> ( Index AS Long) AS Long

Der aktuelle INDEX für die LinkListCOLLECTION wird auf die angegebene Indexnummer gesetzt. Wenn der Parameter kleiner als eins oder größer als die aktuelle Anzahl von Datenelementen ist, wird der INDEX nicht geändert. Der vorherige Wert des INDEX wird an den Aufrufer zurückgegeben.

IndexVar& = ObjectVar .INDEX(0)

Das obige Beispiel ruft die aktuelle Indexnummer ab, ohne sie zu ändern, und weist sie der Variablen IndexVar& zu .

INSERT <7> ( Index AS Long, PowerItem AS Variant)

Die PowerItem-Variante wird der Sammlung an der durch den Index angegebenen Position hinzugefügt. Wenn die Indexnummer kleiner als eins oder größer als die Anzahl ist, wird das Element am Ende der Liste hinzugefügt.

ITEM <8> ( Index AS Long) AS Variant

Das PowerItem an der durch Index angegebenen Position wird zurückgegeben. Wenn das angegebene Element nicht vorhanden ist, ist die zurückgegebene Variante vom Typ leer (VT_EMPTY) und das OBJRESULT ist %S_FALSE (1).

LAST <9> AS Long

Der aktuelle INDEX für die LinkListCOLLECTION wird auf das letzte Element gesetzt, sodass nachfolgend Verweise auf die PREVIOUS-Methode greifen vom Ende auf Mitgliedselemente zu. Der vorherige Wert des INDEX wird an den Aufrufer zurückgegeben.

NEXT <2> AS Variant

The NEXT method allows the LinkListCollection data items to be retrieved sequentially. Each time NEXT is referenced, the data item at the position specified by the INDEX is returned to the caller, and the INDEX is incremented. If the operation is successful, the OBJRESULT is set to %S_OK (0). When there are no more data items to retrieve, the OBJRESULT is set to %S_FALSE (1).

PREVIOUS <10> AS Variant

The PREVIOUS method allows the LinkListCollection data items to be retrieved sequentially. Each time PREVIOUS is referenced, the data item at the position specified by the INDEX is returned to the caller, and the INDEX is decremented. If the operation is successful, the OBJRESULT is set to %S_OK (0). When there are no more data items to retrieve, the OBJRESULT is set to %S_FALSE (1).

REMOVE <11> ( Index AS Long)

The PowerItem at the position specified by Index is removed from the LinkListCollection. The index number of each data item past the removed item is decremented by one. If the requested item is not present, OBJRESULT returns %S_FALSE (1) and no operation is performed.

REPLACE <12> (Index AS Long, PowerItem AS Variant)

The PowerItem at the position specified by Index is replaced by the new specified PowerItem . If the requested PowerItem is not present, OBJRESULT returns %S_FALSE (1) and no operation is performed.

Stack Collection

A Stack Collection is an ordered set of data items, which are accessed on a LIFO (Last-In / First-Out) basis. This collection follows the same algorithm as the machine stack on your Intel CPU. Each data item is passed and stored as a variant variable, using the PUSH and POP methods.

Syntax

The CLASS is "StackCollection". The INTERFACE is IStackCollection (a DUAL interface).

< ObjectVar >.membername( params )

RetVal = < ObjectVar >.membername( params )

< ObjectVar >.membername( params ) TO ReturnVariable

Remarks

The Dispatch ID (DispID) for each member method is displayed within angle brackets.

Stack Collection Methods

CLEAR <1>

All PowerItems are removed from the StackCollection.

COUNT <2> AS Long

The number of data items currently contained in the StackCollection is returned to the caller.

POP <3> AS Variant

The PowerItem at the "Stack-Top" (the item most recently added) is retrieved and returned to the caller. When there are no more data items to retrieve, the variant returned will be of type empty (VT_EMPTY), and the OBJRESULT will be %S_FALSE (1).

PUSH <4> (PowerItem AS Variant)

The specified PowerItem is added to the StackCollection at the "Stack-Top" position.

Queue Collection

A Queue Collection is an ordered set of data items, which are accessed on a FIFO (First-In / First-Out) basis. Each data item is passed and stored as a variant variable, using the ENQUEUE and DEQUEUE methods.

Syntax

The CLASS is "QueueCollection". The INTERFACE is IQueueCollection (a DUAL interface).

< ObjectVar >.membername( params )

RetVal = < ObjectVar >.membername( params )

< ObjectVar >.membername( params ) TO ReturnVariable

Remarks

The Dispatch ID (DispID) for each member method is displayed within angle brackets.

Queue Collection Methods

CLEAR <1>

All PowerItems are removed from the QueueCollection.

COUNT <2> AS Long

The number of data items currently contained in the QueueCollection is returned to the caller.

DEQUEUE <3> AS Variant

The PowerItem at the "oldest" position is retrieved and returned to the caller. When there are no more data items to retrieve, the variant returned will be of type empty (VT_EMPTY), and the OBJRESULT will be %S_FALSE (1).

ENQUEUE <4> ( PowerItem AS Variant)

The specified PowerItem is added to the QueueCollection at the "newest" position.

Siehe auch

  • FOR EACH/NEXT

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


#COM - PBXB64 Compiler-Hilfe

Startseite › Funktionen › #COM

#COM

Deklarieren Sie Informationen, die in ein COM

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

#COM CLASS ClassName [, ClassName ...]
#COM DOC "This is specific information to be used in the Help String"
#COM HELP "MyProg.chm"[, &H1E00]
#COM NAME "LibName", 3.32
#COM GUID GUID$("{20000000-2000-2000-2000000000000002}")
#COM TLIB {ON|+ | OFF|-}
$COM NAME "LibName"
$COM TLIB {ON|+ | OFF|-}

Beschreibung

eingeschlossen werden sollen. Die #COM-Metaanweisung stellt Informationen über die COM-Bibliothek oder Anwendung her, die vom COM-Client extrahiert werden können Programme.

#COM CLASS ermöglicht Ihnen das Hinzufügen des COM-Attributs zu einer an anderer Stelle definierten Klasse. Das COM-Attribut kann sogar einer Klasse in einer SLL hinzugefügt werden, die separat kompiliert wurde. Eine als COM deklarierte Klasse stellt sie externen Programmen über die COM-Dienste von Windows zur Verfügung. Wenn Sie eine Klasse als COM definieren, wird diese automatisch auch als COMMON betrachtet.

#COM DOC gibt einen Hilfestring an, der normalerweise eine allgemeine Beschreibung des COM-Servers liefert.

#COM HELP gibt den Namen der zugehörigen Hilfedatei und den Hilfekontextcode an. Der Name muss als Zeichenfolgenliteral angezeigt werden, während der Kontextcode ein vorzeichenloser DWORD-Wert größer als Null ist. Der Kontextcode kann im Dezimal- oder Basisformat angegeben werden.

#COM NAME gibt den Namen des Servers und die Versionsnummer an. Der Name darf nur aus Buchstaben, Zahlen und Unterstrichen bestehen und darf weder Satzzeichen noch Leerzeichen enthalten. Wenn kein Name angegeben wird, ersetzt PowerBASIC den Modulnamen. Wenn keine Version angegeben ist, verwendet PowerBASIC die Versionsnummer 0.0.

#COM GUID gibt die GUID an, die die gesamte Anwendung oder Bibliothek identifiziert (APPID oder LIBID). Wenn keine GUID angegeben ist, ersetzt PowerBASIC zu diesem Zweck eine zufällige GUID.

#COM TLIB ON gibt an, dass der Compiler eine Typbibliothek für die kompilierte EXE- oder DLL-Datei erstellen soll. Die Typbibliothek hat denselben Namen und dasselbe Zielverzeichnis wie die kompilierte EXE-Datei oder DLL, mit der Erweiterung .TLB.

#COM TLIB OFF (Standard) gibt an, dass der Compiler keine Typbibliothek für die kompilierte EXE-Datei oder DLL erstellen soll.

PBXB64 akzeptiert auch die alte Schreibweise $COM fuer die fokussierte Metadaten-Direktivoberflaeche. Der aktuell getestete Kompatibilitaetsvertrag akzeptiert diese Direktiven beim Kompilieren und ignoriert die Metadaten zur Laufzeit; er behauptet keine vollstaendige COM-Klassen-, Methoden-, Property-, Event-, Hilfe- oder Typbibliotheks-Paritaet.

Typbibliotheken unterstützen nur die folgenden Daten Typen: BYTE, WORD, DWORD, INTEGER, LONG, QUAD, SINGLE, DOUBLE, CURRENCY, OBJECT, STRING und VARIANT. Wenn Methoden oder Eigenschaften Datentypen verwenden, die von Typbibliotheken nicht unterstützt werden, erhalten Sie einen Fehler 581 – Fehler beim Erstellen der Typbibliothek, wenn Sie die Metaanweisung #COM TLIB ON verwenden.

Siehe auch

  • CLASS
  • INTERFACE (Direct)
  • INTERFACE (IDBind)
  • Just what is COM?

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


COMBOBOX ADD - PBXB64 Compiler-Hilfe

Startseite › Funktionen › COMBOBOX ADD

COMBOBOX ADD

Manipulate a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

PBXB64-getesteter Umfang: tests/pb/test_listbox_combobox_direct.pb prueft direkte COMBOBOX-Formen fuer ADD, INSERT, DELETE, FIND, FIND EXACT, GET COUNT, GET SELCOUNT, GET SELECT, GET STATE, GET TEXT, GET USER, SELECT, SET TEXT, SET USER, UNSELECT und RESET. Weitere Randfaelle wie nicht gefundene Eintraege, ungueltige Indizes, sortierte Styles und style-spezifisches Verhalten brauchen noch eigene Tests.

Syntax

COMBOBOX ADD hDlg , id& , StrExpr [TO datav& ]
COMBOBOX DELETE hDlg , id& , item&
COMBOBOX FIND hDlg , id& , item& , StrExpr TO datav&
COMBOBOX FIND EXACT hDlg , id& , item& , StrExpr TO datav&
COMBOBOX GET COUNT hDlg , id& TO datav&
COMBOBOX GET SELCOUNT hDlg , id& TO datav&
COMBOBOX GET SELECT hDlg , id& TO datav&
COMBOBOX GET STATE hDlg , id& , item& TO datav&
COMBOBOX GET TEXT hDlg , id& [, item& ] TO txtv$
COMBOBOX GET USER hDlg , id& , item& TO datav&
COMBOBOX INSERT hDlg , id& , item& , StrExpr [TO datav& ]
COMBOBOX RESET hDlg , id&
COMBOBOX SELECT hDlg , id& , item&
COMBOBOX SET TEXT hDlg , id& , item& , StrExpr
COMBOBOX SET USER hDlg , id& , item& , NumExpr
COMBOBOX UNSELECT hDlg , id&

Beschreibung

In jedem der folgenden Beispiele und Beschreibungen wird das COMBOBOX-Steuerelement, das Gegenstand der Anweisung ist, durch das Handle des Dialogfelds identifiziert, das die COMBOBOX besitzt ( hDlg ) und die eindeutige Steuerelement-ID, die Sie ihm bei der Erstellung in CONTROL ADD COMBOBOX gegeben haben.

COMBOBOX ADD hDlg , id& , StrExpr [TO datav& ]

Der durch StrExpr angegebene Zeichenfolgenwert wird dem COMBOBOX-Steuerelement hinzugefügt. Wenn die COMBOBOX den Stil %CBS_SORT hat, wird die neue Zeichenfolge in alphanumerischer Reihenfolge eingefügt; Andernfalls wird es am Ende der vorhandenen Liste hinzugefügt. Wenn die optionale TO-Klausel enthalten ist, wird die Indexposition der hinzugefügten Zeichenfolge der durch datav& dargestellten Variablen zugewiesen. Der Index ist eins für die erste Zeichenfolge, zwei für die zweite usw. Wenn der Index kleiner als eins ist, ist ein Fehler aufgetreten und es wurde keine Zeichenfolge hinzugefügt.

COMBOBOX DELETE hDlg , id& , item&

Die Zeichenfolge an der durch item& angegebenen Position wird aus der COMBOBOX gelöscht. Die Artikelnummer ( item& ) wird auf eins indiziert (1=erste, 2=zweite usw.).

COMBOBOX FIND hDlg , id& , item& , StrExpr TO datav&

Strings in der COMBOBOX werden durchsucht, um die erste Zeichenfolge zu finden, die mit den Daten in StrExpr beginnt, unabhängig von den folgenden Zeichen. Bei Vergleichen wird die Groß-/Kleinschreibung nicht beachtet. Die Suche nach Zeichenfolgen beginnt mit der durch item& angegebenen Zeichenfolge und endet mit der letzten Zeichenfolge in der COMBOBOX. Die Suche beginnt nicht am Anfang der Liste. Die Artikelnummer (item&) wird auf 1 indiziert (1=erste, 2=zweite usw.). Um die gesamte COMBOBOX beginnend mit der ersten Zeichenfolge zu durchsuchen, sollte item& auf eins (1) gesetzt werden. Wenn eine passende Zeichenfolge gefunden wird, wird der Indexwert der Übereinstimmung der durch datav& angegebenen Variablen zugewiesen. Wenn keine Übereinstimmung gefunden wird, wird ihm der Wert Null (0) zugewiesen.

COMBOBOX FIND EXACT hDlg , id& , item& , StrExpr TO datav&

Strings in der COMBOBOX werden durchsucht, um den ersten String zu finden, der genau mit den Daten in StrExpr übereinstimmt . Bei Vergleichen wird die Groß-/Kleinschreibung nicht beachtet. Die Suche nach Zeichenfolgen beginnt mit der durch item& angegebenen Zeichenfolge und endet mit der letzten Zeichenfolge in der COMBOBOX. Die Suche beginnt nicht am Anfang der Liste. Die Artikelnummer ( item& ) wird auf 1 indiziert (1=erste, 2=zweite usw.). Um die gesamte COMBOBOX beginnend mit der ersten Zeichenfolge zu durchsuchen, sollte item& auf eins (1) gesetzt werden. Wenn eine passende Zeichenfolge gefunden wird, wird der Indexwert der Übereinstimmung der durch datav& angegebenen Variablen zugewiesen. Wenn keine Übereinstimmung gefunden wird, wird ihr der Wert Null (0) zugewiesen.

COMBOBOX GET COUNT hDlg , id& TO datav&

Die Anzahl der Elemente in der Listbox der COMBOBOX wird abgerufen und der durch datav& angegebenen Long-Integer-Variablen zugewiesen. .

COMBOBOX GET SELCOUNT hDlg , id& TO datav&

Die Anzahl der ausgewählten Elemente im Listenfeld der COMBOBOX wird abgerufen und der durch datav& angegebenen Long-Integer-Variablen zugewiesen. Da es sich um ein Listenfeld mit einfacher Auswahl handelt, ist der abgerufene Wert immer entweder Null oder Eins.

COMBOBOX GET SELECT hDlg , id& TO datav&

Der Index des aktuell ausgewählten Elements im Listenfeld der COMBOBOX wird abgerufen und der von angegebenen Variablen zugewiesen datav& . Der Index ist 1 für das erste Element, 2 für das zweite Element usw. Wenn keine aktuelle Auswahl vorhanden ist, wird der Wert Null (0) zugewiesen.

COMBOBOX GET STATE hDlg , id& , item& TO datav&

Ein Datenelement wird daraufhin überprüft, ob es aktuell ausgewählt ist. Der numerische Wert item& gibt an, welcher Benutzerwert überprüft werden soll, 1 für das erste Element, 2 für das zweite Element usw. Wenn das Element ausgewählt ist, wird -1 (wahr) der durch datav& angegebenen Variablen zugewiesen. Andernfalls wird ihm 0 (false) zugewiesen.

COMBOBOX GET TEXT hDlg , id& [, item& ] TO txtv$

Text wird aus der COMBOBOX abgerufen und der durch txtv$ angegebenen String-Variablen zugewiesen. Wenn der numerische Ausdruck item& enthalten ist, bestimmt er, welche Textzeichenfolge zurückgegeben wird, 1 für das erste Element, 2 für das zweite Element usw. Wenn item& fehlt oder den Wert Null enthält, wird der ausgewählte Text zurückgegeben (oder eine leere Zeichenfolge, wenn keiner ausgewählt ist). Wenn Sie den im Bearbeitungsfeldteil der COMBOBOX gefundenen Text abrufen möchten (unabhängig davon, ob er eingegeben oder ausgewählt wurde), sollten Sie stattdessen die CONTROL GET TEXT-Anweisung verwenden.

COMBOBOX GET USER hDlg , id& , item& TO datav&

Jedem Element in einer COMBOBOX kann nach Ermessen des Programmierers ein langer ganzzahliger Benutzerwert zugeordnet sein. Dieser Benutzerwert wird mit COMBOBOX GET USER abgerufen. Der numerische Wert item& gibt an, welcher Benutzerwert angefordert wird, 1 für das erste Element, 2 für das zweite Element usw. Der zurückgegebene Benutzerwert wird der durch datav& angegebenen langen Ganzzahlvariablen zugewiesen. COMBOBOX-Benutzerwerte werden mit der COMBOBOX SET USER-Anweisung zugewiesen. Zusätzlich zu diesen COMBOBOX-Benutzerwerten bietet jedes DDT-Steuerelement zusätzlich acht Benutzerwerte, auf die mit CONTROL GET USER und CONTROL SET USER zugegriffen werden kann.

COMBOBOX INSERT hDlg , id& , item& , StrExpr [TO datav& ]

Der Text für ein neues Datenelement, das durch StrExpr angegeben wird, wird an der durch item& angegebenen Stelle eingefügt. Der Wert von item& = 1 für das erste Element, 2 für das zweite Element usw. Die Liste der Datenelemente wird nicht neu sortiert, auch wenn die COMBOBOX mit dem Stil %CBS_SORT erstellt wurde. Wenn Sie alle Elemente sortieren möchten, verwenden Sie stattdessen COMBOBOX ADD. Wenn die optionale TO-Klausel enthalten ist, wird die Indexposition der eingefügten Zeichenfolge der durch datav& dargestellten Variablen zugewiesen. Der Index ist eins für die erste Zeichenfolge, zwei für die zweite usw. Wenn der Index kleiner als eins ist, ist ein Fehler aufgetreten und es wurde keine Zeichenfolge eingefügt.

COMBOBOX RESET hDlg , id&

Alle Inhalte der angegebenen löschen COMBOBOX.

COMBOBOX SELECT hDlg , id& , item&

Der durch item& angegebene Zeichenfolgenwert wird als ausgewählter Text für das COMBOBOX-Steuerelement ausgewählt und der ausgewählte Text wird an eine sichtbare Position gescrollt. Der Wert von item& = 1 für das erste Element, 2 für das zweite Element usw.

COMBOBOX SET TEXT hDlg, id&, item&, StrExpr

Der Text für das durch item& angegebene Datenelement wird durch den neuen Text in StrExpr ersetzt. Der Wert von item& = 1 für das erste Element, 2 für das zweite Element usw. Die Liste der Datenelemente wird nicht neu sortiert, auch wenn die COMBOBOX mit dem Stil %CBS_SORT erstellt wurde. Wenn Sie alle Elemente sortieren möchten, verwenden Sie stattdessen COMBOBOX DELETE gefolgt von COMBOBOX ADD.

COMBOBOX SET USER hDlg , id& , item& , NumExpr

Jedem Element in einer COMBOBOX kann nach Ermessen von ein langer ganzzahliger Benutzerwert zugeordnet sein der Programmierer. Dieser Benutzerwert wird mit COMBOBOX SET USER zugewiesen und mit COMBOBOX GET USER abgerufen. Der numerische Wert item& gibt an, auf welchen Benutzerwert zugegriffen werden soll, 1 für das erste Element, 2 für das zweite Element usw. Der durch NumExpr angegebene Wert wird für einen späteren Abruf gespeichert. Zusätzlich zu diesen COMBOBOX-Benutzerwerten bietet jedes DDT-Steuerelement acht zusätzliche Benutzerwerte, auf die mit CONTROL GET USER und CONTROL SET USER zugegriffen werden kann.

COMBOBOX UNSELECT hDlg , id&

Alle Elemente in einem COMBOBOX-Steuerelement werden auf nicht ausgewählt gesetzt state.

Einschränkungen

Unter Windows 95/98/ME ist ein Listenfeld auf 32.767 Elemente beschränkt. In allen Windows-Versionen sind die tatsächlich im Listenfeld enthaltenen Zeichenfolgendaten nur durch den verfügbaren Speicher begrenzt.

Siehe auch

  • Dynamic Dialog Tools
  • CONTROL ADD COMBOBOX
  • CONTROL GET TEXT

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für COMBOBOX ADD soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' COMBOBOX ADD mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


COMM - PBXB64 Compiler Hilfe

Startseite › Funktionen › COMM

COMM

Wert oder Status eines

Typ:Funktion |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

lResult& = COMM([#] hComm , Comfunc )

Beschreibung

hComm ist die PowerBASIC-Dateinummer, die von der COMM OPEN-Anweisung zum Öffnen des Kommunikationsports verwendet wurde. Wählen Sie ein Comfunc-Schlüsselwort aus der folgenden Tabelle aus, um die zugehörige Einstellung abzurufen.

Comfunc

Wert (TRUE <> 0, FALSE = 0)

Port-Baudrate (9600, 14400, 19200 usw.).

TRUE/FALSE Break wird aktiviert. Break wird im Allgemeinen verwendet, um die Aufmerksamkeit des angeschlossenen Modems, Terminals oder Systems zu erregen.

Anzahl der Bits pro Byte (4, 5, 6, 7 oder 8).

TRUE/FALSE Trägererkennungsstatus; Synonym für RLSD (READ-ONLY). Wenn CD TRUE ist, verfügt das DCE (Modem) über eine geeignete Verbindung auf dem vorhandenen Kommunikationskanal. Wenn CD FALSE ist, gibt es keine geeignete Verbindung.

TRUE/FALSE Der Clear-To-Send-Status wird zurückgegeben (NUR LESEN).

CTSFLOW

TRUE/FALSE CTS-Ausgabefluss aktivieren Steuerung (Eingangssignal). Wenn CTSFLOW aktiviert ist, stoppt der DTE (Computer) das Senden von Daten, wenn das CTS-Signal vom DCE (Modem) auf logisch niedrig gesetzt wird. Die Übertragung wird fortgesetzt, wenn das DCE (Modem) das CTS-Signal wieder auf logisch hoch setzt. Das CTS-Signal wird normalerweise als Reaktion auf ein RTS-Signal verwendet.

TRUE/FALSE Der Status „Data-Set-Ready“ wird zurückgegeben (READ-ONLY).

DSRFLOW

TRUE/FALSE DSR aktivieren Ausgangsflusskontrolle (Eingangssignal). Wenn DSRFLOW aktiviert ist, stoppt der DTE (Computer) das Senden von Daten, wenn das DSR-Signal vom DCE (Modem) auf logisch niedrig gesetzt wird. Die Übertragung wird aktiviert, wenn das DSR-Signal wieder logisch hoch ist. Das DSR-Signal wird oft in Verbindung mit CTS als Reaktion auf ein RTS-Signal verwendet.

DSRSENS

TRUE/FALSE DSR-Empfindlichkeit aktivieren. Wenn DSRSENS aktiviert ist, werden vom DTE (Computer) empfangene Daten nur dann in den Empfangspuffer gestellt, wenn DSR auf logisch hoch gesetzt ist. Wenn DSR niedrig eingestellt ist, werden empfangene Daten verworfen. Durch die Aktivierung von DSRSENS kann DSR das DTE (den Computer) aktivieren oder deaktivieren, um Daten vom DTE (dem Modem) zu empfangen. DSRSENS wird in praktischen Kommunikationssituationen selten verwendet.

DTRFLOW

TRUE/FALSE DTR-Handshake-Flusskontrolle aktivieren (Ausgangssignal). Wenn DTRFLOW aktiviert ist, signalisiert es, dass sich das DCE (Modem) auf die Verbindung mit dem Kommunikationskanal vorbereiten sollte. DTR wird normalerweise für die Modem-On-/Off-Hook-Steuerung verwendet, kann aber auch in Verbindung mit DSR für Handshaking verwendet werden.

DTRLINE

TRUE/FALSE DTR-Leitung aktivieren. Wenn aktiviert, lässt DTRLINE die DTR-Leitung aktiv, wenn der Port vom DTE (Computer) geschlossen wird. Dadurch wird sichergestellt, dass das DCE (Modem) den Kommunikationskanal nicht schließt, wenn der Port geschlossen ist.

TRUE/FALSE Null-Bytes ($NUL) werden verworfen, wenn read.

PARITY

TRUE/FALSE Paritätsprüfung aktivieren. Dieser Modus muss aktiviert sein, damit die anderen Paritätsoptionen ausgewählt werden können.

PARITYCHAR

Zeichen, das zum Ersetzen von Paritätsfehlern verwendet werden soll. PARITY muss aktiviert sein.

PARITYREPL

TRUE/FALSE Zeichenersetzung bei Paritätsfehler aktivieren. PARITY muss aktiviert sein.

PARITYTYPE

0 = Keine, 1 = Ungerade, 2 = Gerade, 3 = Mark, 4 = Leerzeichen. PARITÄT muss aktiviert sein. Standard = 0.

TRUE/FALSE Klingelanzeige ist eingeschaltet (schreibgeschützt). Wenn RING TRUE zurückgibt, wird auf dem Kommunikationskanal (vom Modem) ein Rufsignal empfangen. RING nähert sich dem Zustand des Rufsignals an; Allerdings wird es möglicherweise nicht auf allen Windows-Plattformen korrekt gemeldet.

Receive-line-signal-detect (READ-ONLY). Siehe CD/Carrier-Erkennung oben.

RTSFLOW

Bereit zum Senden (Ausgangssignal). 0 = Deaktivieren, 1 = Aktivieren, 2 = Handshake, 3 = Umschalten. Toggle wird für Halbduplex-(2-Draht)-Operationen verwendet, um die Leitung „umzukehren“. Während der DTE (Computer) damit beschäftigt ist, Daten zu senden, löst er das RTS-Signal aus und der DCE (Modem) blockiert seinen Datenempfangskanal. Wenn das RTS-Signal auf logisch niedrig zurückkehrt, kehrt das DCE (Modem) in den Sendemodus zurück und das DTE (Computer) wechselt in den Empfangsmodus.

Der Handshake-Modus veranlasst das DTE (Computer), den Empfangspuffer (RXQUE) zu überprüfen, nachdem jedes Zeichen im Puffer platziert wurde. Wenn der Puffer zu 5/6 voll ist, wird das RTS-Signal gelöscht. Wenn der Empfangspuffer auf unter 1/6 sinkt, wird RTS erneut erhöht

RXPUFFER

Größe des Empfangspuffers in Bytes.

Derzeit im Empfangspuffer befindliche Zeichen (schreibgeschützt).

0 = 1 Stoppbits, 1 = 1,5 Stoppbits, 2 = 2 Stoppbits.

TXBUFFER

Größe des Sendepuffers in Bytes. In einigen Fällen kann Windows die Übertragungsgröße möglicherweise nicht melden.

Derzeit im Sendepuffer befindliche Zeichen (schreibgeschützt).

XINPFLOW

TRUE/FALSE Aktiviert die XON/XOFF-Eingangsflusssteuerung. Wenn der Empfangspuffer des DTE (Computers) voll ist, wird ein XOFF-Zeichen an das DCE (Modem) gesendet, um es anzuweisen, die Übertragung anzuhalten. Wenn das DCE zur Wiederaufnahme der Übertragung bereit ist, wird ein XON-Zeichen an das DCE gesendet. Typischerweise wird XOFF gesendet, wenn der Empfangspuffer weniger als 1/16 verbleibend hat, und XON wird gesendet, wenn der Empfangspuffer auf weniger als 1/16 seiner maximalen Größe abfällt. Standard = FALSCH.

XOUTFLOW

TRUE/FALSE XON/XOFF-Ausgangsflusskontrolle aktivieren. Wenn aktiviert, sendet das DCE (Modem) ein XOFF an das DTE (Computer), um die Datenübertragung an das DCE zu stoppen. Wenn das DCE bereit ist, weitere Daten zu empfangen, wird ein XON-Zeichen gesendet. XOUTFLOW verwendet normalerweise die gleichen 1/16-Regeln wie XINPFLOW. Standard = FALSCH.

Gängige Baudraten reichen von 110 bis 256.000. In der Datei WIN32API.INC sind Equates mit dem Präfix %CBR_ definiert, um Sie bei der Angabe einer gemeinsamen Baudrate zu unterstützen, Sie sind jedoch nicht auf einen begrenzten Satz von Raten beschränkt.

PowerBASIC setzt die Systemvariable ERR, wenn bei der Verwendung der COMM-Funktion ein Fehler auftritt.

Das Zahlensymbol (#) als Präfix ist optional, wird aber aus Gründen der Übersichtlichkeit empfohlen.

Einschränkungen

Aufgrund der Unterschiede zwischen Win32-Betriebssystemen können Parameter (wie TXBUFFER und TXQUE) möglicherweise nicht unter allen Umständen erfolgreich abgefragt werden.

PBXB64 V14 unterstuetzt die getesteten Modemstatus-Selektoren COMM([#] hComm, CTS), COMM([#] hComm, DSR), COMM([#] hComm, CD), COMM([#] hComm, RLSD) und COMM([#] hComm, RING). Gueltige serielle Handles fragen Win32 GetCommModemStatus ab und geben PowerBASIC TRUE oder FALSE zurueck; Null- oder nicht geoeffnete Handles geben FALSE zurueck. Die registrierten Tests pruefen Syntax, eingebettete Laufzeitverknuepfung, sicheres Null-Handle-Verhalten und eine Diagnose fuer nicht unterstuetzte COMM-Funktionsselektoren. Hardwaregestuetztes Verhalten bei gesetzten Signalen haengt von einem vorhandenen seriellen Geraet oder einem virtuellen COM-Paar ab und bleibt breitere serielle Paritaetsarbeit.

Siehe auch

  • Serielle Kommunikation
  • KOMM CLOSE
  • KOMMLINIE
  • KOMM. OFFEN
  • KOMM. DRUCK
  • COMM RECV
  • KOMM-RESET
  • KOMM SENDEN
  • KOMM.-EINST
  • KOMM-TIMEOUT

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


COMM CLOSE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › COMM CLOSE

KOMM CLOSE

Schließen und öffnen

Typ:Anweisung |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

COMM CLOSE [#] hComm [, [#] hComm ...]

Beschreibung

Schließt einen oder mehrere Kommunikationsports, wie durch die PowerBASIC-Dateinummer angegeben, die in jedem hComm-Parameter enthalten ist. COMM CLOSE beendet die Beziehung zwischen einer PowerBASIC-Dateinummer und dem seriellen Portgerät, das ihr zuvor durch die COMM OPEN-Anweisung zugeordnet wurde.

Das Zahlensymbol (#) als Präfix ist optional, wird aber aus Gründen der Übersichtlichkeit empfohlen.

Es wird außerdem empfohlen, alle geöffneten seriellen Ports explizit zu schließen, bevor Ihre Anwendung beendet wird. Beachten Sie, dass COMM CLOSE ein Synonym für CLOSE ist.

Siehe auch

  • Serielle Kommunikation
  • CLOSE
  • COMM-Funktion
  • KOMMLINIE
  • KOMM. OFFEN
  • KOMM. DRUCK
  • COMM RECV
  • KOMM-RESET
  • KOMM SENDEN
  • KOMM.-EINST
  • KOMM-TIMEOUT

Kommunikationsprüfung

Serielle, TCP- und UDP-Seiten sollen Endpoint-Aufbau, Blocking-Verhalten, Timeout-Verhalten, Pufferbesitz und Cleanup nennen. Ein vollständiges Beispiel deckt Open/Create, Senden oder Empfangen, Close und einen vorhersagbaren Fehler wie einen ungültigen Endpoint ab.

Laufzeitvoraussetzungen

Netzwerkbeispiele können Firewall-Berechtigungen und freie Ports benötigen. Serielle Beispiele erfordern ein vorhandenes COM-Gerät oder einen dokumentierten Loopback/Testadapter.

Diagnosen

Erfassen Sie Rückgabewerte und Windows-Fehlercodes, wo verfügbar, damit Kommunikationsfehler auswertbar statt still sind.

Umfangshinweise

Wenn die Seite eine Familie statt eines einzelnen Befehls beschreibt, nennen Sie das konkrete Senden, Empfangen, Prüfen, Verbinden oder Schließen, das das Verhalten belegt, und sagen Sie, ob derselbe Socket oder Handle nach dem Aufruf weiterverwendet werden darf. Dadurch wird die Seite zu einem nutzbaren Laufzeitvertrag statt zu einem allgemeinen Protokollhinweis.


COMM LINE – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › KOMMLINIE

KOMMLINIE

Erhalten Sie ein CR/LF (

Typ:Anweisung |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

COMM LINE [INPUT] [#] hComm , string_var

Beschreibung

Liest eine durch Trennzeichen getrennte Datenzeile aus dem Empfangspuffer, wobei eine „Zeile“ als Datenstrom definiert ist, der durch ein CR/LF (Wagenrücklauf und Zeilenvorschub, $CRLF oder CHR$ (13,10)) abgeschlossen wird. COMM LINE INPUT ist ideal zum Abrufen von Modem-Antwortzeichenfolgen als Antwort auf „AT“-Befehle, die an ein Modem gesendet werden.

hComm ist die Dateinummer, die Sie mit COMM OPEN verwendet haben, eine Ganzzahl im Bereich von 1 bis 32767. Das Zahlensymbol (#) als Präfix ist optional, wird aber aus Gründen der Übersichtlichkeit empfohlen.

COMM LINE liest den Empfangspuffer bis zum nächsten $CRLF-Zeichenpaar. Die $CRLF-Bytes werden aus dem Puffer entfernt, sind jedoch nicht Teil der von COMM LINE zurückgegebenen Zeichenfolgendaten. Beachten Sie, dass die Anweisung unbegrenzt auf eine vollständige, mit $CRLF abgeschlossene Datenzeile wartet, wenn im Empfangspuffer kein $CRLF-Paar vorhanden ist. In diesem Sinne ist COMM LINE eine blockierende Anweisung. Mit der COMM TIMEOUT-Anweisung können COMM-Timeout-Grenzwerte angegeben werden.

Die empfangenen Daten werden der string_var zugewiesen. Der Zeichenmodus der string_var muss mit der CHR-Option in COMM OPEN (ANSI/WIDE) übereinstimmen. Andernfalls wird ein Fehler 5 (Ungültiger Funktionsaufruf) generiert und es werden keine Daten empfangen.

Die EOF-Funktion kann auch mit COMM LINE (und TCP LINE) verwendet werden, um zu erkennen, dass eine unvollständige Zeile empfangen wurde. Normalerweise liest die COMM LINE-Anweisung Daten, bis ein $CRLF-Zeichenpaar gefunden wird. In diesem Fall gibt EOF false (Null) zurück. Wenn jedoch eine Zeitüberschreitung auftritt, gibt COMM LINE alle angesammelten Daten zurück und setzt EOF auf logisch TRUE (ungleich Null).

In vielen Fällen wäre es ratsam, EOF nach jeder COMM LINE-Anweisung zu testen, um zu überprüfen, ob eine vollständige Zeile empfangen wurde. In manchen Fällen möchten Sie die Anweisung möglicherweise noch einmal oder mehrmals ausführen und dabei die Daten kombinieren, um eine vollständige Textzeile zu erhalten.

Siehe auch

  • Serielle Kommunikation
  • KOMM CLOSE
  • COMM-Funktion
  • KOMM. OFFEN
  • KOMM. DRUCK
  • COMM RECV
  • KOMM-RESET
  • KOMM SENDEN
  • KOMM.-EINST
  • KOMM-TIMEOUT
  • EOF

Kommunikationsprüfung

Serielle, TCP- und UDP-Seiten sollen Endpoint-Aufbau, Blocking-Verhalten, Timeout-Verhalten, Pufferbesitz und Cleanup nennen. Ein vollständiges Beispiel deckt Open/Create, Senden oder Empfangen, Close und einen vorhersagbaren Fehler wie einen ungültigen Endpoint ab.

Laufzeitvoraussetzungen

Netzwerkbeispiele können Firewall-Berechtigungen und freie Ports benötigen. Serielle Beispiele erfordern ein vorhandenes COM-Gerät oder einen dokumentierten Loopback/Testadapter.

Diagnosen

Erfassen Sie Rückgabewerte und Windows-Fehlercodes, wo verfügbar, damit Kommunikationsfehler auswertbar statt still sind.

Umfangshinweise

Wenn die Seite eine Familie statt eines einzelnen Befehls beschreibt, nennen Sie das konkrete Senden, Empfangen, Prüfen, Verbinden oder Schließen, das das Verhalten belegt, und sagen Sie, ob derselbe Socket oder Handle nach dem Aufruf weiterverwendet werden darf. Dadurch wird die Seite zu einem nutzbaren Laufzeitvertrag statt zu einem allgemeinen Protokollhinweis.


COMM OPEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › COMM OPEN

KOMM. OFFEN

Öffnen Sie ein

Typ:Anweisung |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

COMM OPEN "COM n " AS [#] hComm [CHR = ANSI|WIDE]

Beschreibung

Öffnet eine serielle Schnittstelle, um mit der Kommunikation zu beginnen, und stellt eine Beziehung zwischen einer Dateinummer und einem bestimmten Gerät mit serieller Schnittstelle her.

Identifiziert die Nummer des seriellen Ports, zum Beispiel COM1, COM4 usw. Der Portspezifikation darf kein Doppelpunkt folgen. Siehe Einschränkungen unten.

Ein numerischer Ausdruck, der eine nicht verwendete PowerBASIC-Dateinummer im Bereich von 1 bis 32767 angibt. Dies wird normalerweise von der FREEFILE-Funktion bereitgestellt. Das Zahlensymbol (#) als Präfix ist optional, wird aber aus Gründen der Übersichtlichkeit empfohlen.

Wenn der Port nicht erfolgreich geöffnet wurde, enthält die Systemvariable ERR den Fehlercode. Bevor die eigentliche Kommunikation über den Port beginnen kann, müssen Sie die Kommunikationsparameter konfigurieren, indem Sie für jeden Parameter eine COMM SET-Anweisung verwenden.

Einschränkungen

Im Portnamen darf kein Doppelpunkt verwendet werden, wie es im DOS-Code üblich war. COMM OPEN kann weder ein Dateihandle des Betriebssystems verwenden noch einen Port öffnen, der bereits verwendet wird. Beim Öffnen von Ports über COM9 erfordert Windows die Angabe des Portnamens mit der folgenden Syntax:

COMM OPEN „\\.\COM15“ AS #hComm

Siehe auch

  • Serielle Kommunikation
  • KOMM CLOSE
  • COMM-Funktion
  • KOMMLINIE
  • KOMM. DRUCK
  • COMM RECV
  • KOMM-RESET
  • KOMM SENDEN
  • KOMM.-EINST
  • KOMM-TIMEOUT
  • FREEFILE
  • OFFEN

Kommunikationsprüfung

Serielle, TCP- und UDP-Seiten sollen Endpoint-Aufbau, Blocking-Verhalten, Timeout-Verhalten, Pufferbesitz und Cleanup nennen. Ein vollständiges Beispiel deckt Open/Create, Senden oder Empfangen, Close und einen vorhersagbaren Fehler wie einen ungültigen Endpoint ab.

Laufzeitvoraussetzungen

Netzwerkbeispiele können Firewall-Berechtigungen und freie Ports benötigen. Serielle Beispiele erfordern ein vorhandenes COM-Gerät oder einen dokumentierten Loopback/Testadapter.

Diagnosen

Erfassen Sie Rückgabewerte und Windows-Fehlercodes, wo verfügbar, damit Kommunikationsfehler auswertbar statt still sind.

Umfangshinweise

Wenn die Seite eine Familie statt eines einzelnen Befehls beschreibt, nennen Sie das konkrete Senden, Empfangen, Prüfen, Verbinden oder Schließen, das das Verhalten belegt, und sagen Sie, ob derselbe Socket oder Handle nach dem Aufruf weiterverwendet werden darf. Dadurch wird die Seite zu einem nutzbaren Laufzeitvertrag statt zu einem allgemeinen Protokollhinweis.


COMM PRINT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › KOMM. DRUCK

KOMM. DRUCK

Senden Sie eine Textzeichenfolge über eine serielle Schnittstelle mit optionalem CR/LF.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

COMM PRINT [#] hComm , string_expression [;] [TO CharCountVar ]

Beschreibung

Die in string_expression enthaltenen Textdaten werden an den seriellen Port gesendet, der der Dateinummer hComm zugeordnet ist. Das Zahlensymbol (#) ist optional.

Die Daten werden in der in der COMM OPEN-Anweisung angegebenen Zeichenform gesendet. Wenn CHR=WIDE angegeben wurde, werden die Daten in breiten Unicode-Zeichen gesendet. Andernfalls wird es in ANSI-Bytes gesendet. Die Daten werden automatisch in die entsprechende Form konvertiert.

Diese Anweisung ist eine Variation von COMM SEND , wird jedoch normalerweise nur mit Text verwendet. Auf jeden gesendeten string_-Ausdruck folgt automatisch ein Wagenrücklauf- und Zeilenvorschubpaar, um die Zeile zu begrenzen. Wenn jedoch ein abschließendes Semikolon (;) hinzugefügt wird, wird CR/LF unterdrückt.

Wenn die optionale „TO CharCountVar“-Klausel enthalten ist, wird ihr eine Zählung der Anzahl der geschriebenen Zeichen zugewiesen. Diese Zählung umfasst CR/LF, sofern verwendet. Dadurch können Sie den Erfolg der Operation beurteilen. Wenn ein TimeOut aufgetreten ist, ist dieser Wert kleiner als erwartet und es wird ein Laufzeitfehler 24 (Geräte-Timeout) generiert.

C OMM PRINT ist ideal zum Senden von „AT“-Befehlen an ein Modem. Lassen Sie zu diesem Zweck das abschließende Semikolon weg, da Sie möchten, dass CR/LF zusammen mit den Daten gesendet wird.

Siehe auch

  • Serielle Kommunikation
  • KOMM CLOSE
  • COMM-Funktion
  • KOMMLINIE
  • KOMM. OFFEN
  • COMM RECV
  • KOMM-RESET
  • KOMM SENDEN
  • KOMM.-EINST
  • KOMM-TIMEOUT

Kommunikationsprüfung

Serielle, TCP- und UDP-Seiten sollen Endpoint-Aufbau, Blocking-Verhalten, Timeout-Verhalten, Pufferbesitz und Cleanup nennen. Ein vollständiges Beispiel deckt Open/Create, Senden oder Empfangen, Close und einen vorhersagbaren Fehler wie einen ungültigen Endpoint ab.

Laufzeitvoraussetzungen

Netzwerkbeispiele können Firewall-Berechtigungen und freie Ports benötigen. Serielle Beispiele erfordern ein vorhandenes COM-Gerät oder einen dokumentierten Loopback/Testadapter.

Diagnosen

Erfassen Sie Rückgabewerte und Windows-Fehlercodes, wo verfügbar, damit Kommunikationsfehler auswertbar statt still sind.

Umfangshinweise

Wenn die Seite eine Familie statt eines einzelnen Befehls beschreibt, nennen Sie das konkrete Senden, Empfangen, Prüfen, Verbinden oder Schließen, das das Verhalten belegt, und sagen Sie, ob derselbe Socket oder Handle nach dem Aufruf weiterverwendet werden darf. Dadurch wird die Seite zu einem nutzbaren Laufzeitvertrag statt zu einem allgemeinen Protokollhinweis.


COMM RECV – PBXB64-Compiler-Hilfe

Startseite › Funktionen › COMM RECV

COMM RECV

Binärdaten von a empfangen

Typ:Anweisung |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

COMM RECV [#] hComm , count& , string_var

Beschreibung

Rufen Sie die Anzahl der Bytes aus dem Empfangspuffer ab und platzieren Sie die Ergebnisse in string_var . Die Programmausführung wird angehalten, bis count& Bytes verfügbar sind. Daher ist es ratsam, zu überprüfen, wie viele Bytes verfügbar sind, bevor Sie eine COMM RECV-Anfrage stellen. Sie können dies tun, indem Sie den RXQUE-Wert mit der COMM-Funktion überprüfen, wie im folgenden Beispiel gezeigt.

hComm ist die Dateinummer, die Sie mit COMM OPEN verwendet haben, eine Ganzzahl im Bereich von 1 bis 32767. Das Zahlensymbol (#) als Präfix ist optional, wird aber aus Gründen der Übersichtlichkeit empfohlen.

Die empfangenen Daten werden der string_var zugewiesen. Der Zeichenmodus der string_var muss mit der CHR-Option in COMM OPEN (ANSI/WIDE) übereinstimmen. Andernfalls wird ein Fehler 5 (Ungültiger Funktionsaufruf) generiert und es werden keine Daten empfangen.

Siehe auch

  • Serielle Kommunikation
  • KOMM CLOSE
  • COMM-Funktion
  • KOMMLINIE
  • KOMM. OFFEN
  • KOMM. DRUCK
  • KOMM-RESET
  • KOMM SENDEN
  • KOMM.-EINST
  • KOMM-TIMEOUT

Kommunikationsprüfung

Serielle, TCP- und UDP-Seiten sollen Endpoint-Aufbau, Blocking-Verhalten, Timeout-Verhalten, Pufferbesitz und Cleanup nennen. Ein vollständiges Beispiel deckt Open/Create, Senden oder Empfangen, Close und einen vorhersagbaren Fehler wie einen ungültigen Endpoint ab.

Laufzeitvoraussetzungen

Netzwerkbeispiele können Firewall-Berechtigungen und freie Ports benötigen. Serielle Beispiele erfordern ein vorhandenes COM-Gerät oder einen dokumentierten Loopback/Testadapter.

Diagnosen

Erfassen Sie Rückgabewerte und Windows-Fehlercodes, wo verfügbar, damit Kommunikationsfehler auswertbar statt still sind.

Umfangshinweise

Wenn die Seite eine Familie statt eines einzelnen Befehls beschreibt, nennen Sie das konkrete Senden, Empfangen, Prüfen, Verbinden oder Schließen, das das Verhalten belegt, und sagen Sie, ob derselbe Socket oder Handle nach dem Aufruf weiterverwendet werden darf. Dadurch wird die Seite zu einem nutzbaren Laufzeitvertrag statt zu einem allgemeinen Protokollhinweis.


COMM RESET – PBXB64-Compiler-Hilfe

Startseite › Funktionen › COMM RESET

KOMM-RESET

Deaktivieren Sie die Flusskontrolle für einen bestimmten Wert

Typ:Anweisung |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

COMM RESET [#] hComm , FLOW

Beschreibung

Schaltet die gesamte Flusskontrolle zum seriellen Port aus, wie durch die in hComm gespeicherte Dateinummer angegeben.

Das Zahlensymbol (#) als Präfix ist optional, wird aber aus Gründen der Übersichtlichkeit empfohlen.

Siehe auch

  • Serielle Kommunikation
  • KOMM CLOSE
  • COMM-Funktion
  • KOMMLINIE
  • KOMM. OFFEN
  • KOMM. DRUCK
  • COMM RECV
  • KOMM SENDEN
  • KOMM.-EINST
  • KOMM-TIMEOUT

Kommunikationsprüfung

Serielle, TCP- und UDP-Seiten sollen Endpoint-Aufbau, Blocking-Verhalten, Timeout-Verhalten, Pufferbesitz und Cleanup nennen. Ein vollständiges Beispiel deckt Open/Create, Senden oder Empfangen, Close und einen vorhersagbaren Fehler wie einen ungültigen Endpoint ab.

Laufzeitvoraussetzungen

Netzwerkbeispiele können Firewall-Berechtigungen und freie Ports benötigen. Serielle Beispiele erfordern ein vorhandenes COM-Gerät oder einen dokumentierten Loopback/Testadapter.

Diagnosen

Erfassen Sie Rückgabewerte und Windows-Fehlercodes, wo verfügbar, damit Kommunikationsfehler auswertbar statt still sind.

Umfangshinweise

Wenn die Seite eine Familie statt eines einzelnen Befehls beschreibt, nennen Sie das konkrete Senden, Empfangen, Prüfen, Verbinden oder Schließen, das das Verhalten belegt, und sagen Sie, ob derselbe Socket oder Handle nach dem Aufruf weiterverwendet werden darf. Dadurch wird die Seite zu einem nutzbaren Laufzeitvertrag statt zu einem allgemeinen Protokollhinweis.


COMM SEND – PBXB64-Compiler-Hilfe

Startseite › Funktionen › KOMM SENDEN

KOMM SENDEN

Senden Sie eine Datenzeichenfolge über a

Typ:Anweisung |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

COMM SEND [#] hComm , string_expression TO [ CharCountVar ]

Beschreibung

Die in string_expression enthaltenen Daten werden an den seriellen Port gesendet, der der Dateinummer hComm zugeordnet ist. Das Zahlensymbol (#) ist optional.

Die Daten werden in der in der COMM OPEN-Anweisung angegebenen Zeichenform gesendet. Wenn CHR=WIDE angegeben wurde, werden die Daten in breiten Unicode-Zeichen gesendet. Andernfalls wird es in ANSI-Bytes gesendet. Die Daten werden automatisch in die entsprechende Form konvertiert.

Bei COMM SEND werden den Daten keine Trennzeichen hinzugefügt. Wenn ein nachgestelltes CR/LF erforderlich ist, ist es normalerweise am besten, stattdessen COMM PRINT zu verwenden.

Wenn die optionale „TO CharCountVar“-Klausel enthalten ist, wird ihr eine Zählung der Anzahl der geschriebenen Zeichen zugewiesen. Dadurch können Sie den Erfolg der Operation beurteilen. Wenn ein TimeOut aufgetreten ist, ist dieser Wert kleiner als erwartet und es wird ein Laufzeitfehler 24 (Geräte-Timeout) generiert.

Siehe auch

  • Serielle Kommunikation
  • KOMM CLOSE
  • COMM-Funktion
  • KOMMLINIE
  • KOMM. OFFEN
  • KOMM. DRUCK
  • COMM RECV
  • KOMM-RESET
  • KOMM.-EINST
  • KOMM-TIMEOUT

Kommunikationsprüfung

Serielle, TCP- und UDP-Seiten sollen Endpoint-Aufbau, Blocking-Verhalten, Timeout-Verhalten, Pufferbesitz und Cleanup nennen. Ein vollständiges Beispiel deckt Open/Create, Senden oder Empfangen, Close und einen vorhersagbaren Fehler wie einen ungültigen Endpoint ab.

Laufzeitvoraussetzungen

Netzwerkbeispiele können Firewall-Berechtigungen und freie Ports benötigen. Serielle Beispiele erfordern ein vorhandenes COM-Gerät oder einen dokumentierten Loopback/Testadapter.

Diagnosen

Erfassen Sie Rückgabewerte und Windows-Fehlercodes, wo verfügbar, damit Kommunikationsfehler auswertbar statt still sind.

Umfangshinweise

Wenn die Seite eine Familie statt eines einzelnen Befehls beschreibt, nennen Sie das konkrete Senden, Empfangen, Prüfen, Verbinden oder Schließen, das das Verhalten belegt, und sagen Sie, ob derselbe Socket oder Handle nach dem Aufruf weiterverwendet werden darf. Dadurch wird die Seite zu einem nutzbaren Laufzeitvertrag statt zu einem allgemeinen Protokollhinweis.


COMM SET – PBXB64-Compiler-Hilfe

Startseite › Funktionen › COMM SET

KOMM.-EINST

Legen Sie Kommunikationsoptionen für a fest

Typ:Anweisung |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

COMM SET [#] hComm , Comfunc = value

Beschreibung

Legen Sie die Parameter fest, die für die Kommunikation mit einem seriellen Port erforderlich sind. Dies muss immer erfolgen, bevor Sie Daten über den Port senden und empfangen können.

Um die Kommunikationsparameter zu konfigurieren, verwenden Sie Schlüsselwörter aus der folgenden Tabelle, um den Comfunc anzugeben, sowie einen geeigneten Wert aus dem Bereich, der für den Comfunc-Parameter gilt, den Sie festlegen möchten. Wenn beim Versuch, einen Parameter festzulegen, ein Fehler auftritt, setzt PowerBASIC die Systemvariable ERR, um die Fehlernummer anzuzeigen. Während jeder Parameter einzeln eingestellt werden muss, ist es auch möglich, bestimmte Parameter zu ändern, ohne dass die Kommunikation unterbrochen und erneut hergestellt werden muss.

COMM SET-Schlüsselworttabelle

Comfunc

Wert (TRUE <> 0, FALSE = 0)

Port-Baudrate (9600, 14400, 19200 usw.). Siehe Hinweise unten.

TRUE/FALSE Break wird aktiviert. Break wird im Allgemeinen verwendet, um die Aufmerksamkeit des angeschlossenen Modems, Terminals oder Systems zu erregen.

Anzahl der Bits pro Byte (4, 5, 6, 7 oder 8).

TRUE/FALSE Trägererkennungsstatus; Synonym für RLSD (READ-ONLY). Wenn CD TRUE ist, verfügt das DCE (Modem) über eine geeignete Verbindung auf dem vorhandenen Kommunikationskanal. Wenn CD FALSE ist, gibt es keine geeignete Verbindung.

CTSFLOW

TRUE/FALSE CTS-Ausgabefluss aktivieren Steuerung (Eingangssignal). Wenn CTSFLOW aktiviert ist, stoppt der DTE (Computer) das Senden von Daten, wenn das CTS-Signal vom DCE (Modem) auf logisch niedrig gesetzt wird. Die Übertragung wird fortgesetzt, wenn das DCE (Modem) das CTS-Signal wieder auf logisch hoch setzt. Das CTS-Signal wird normalerweise als Reaktion auf ein RTS-Signal verwendet.

DSRFLOW

TRUE/FALSE DSR aktivieren Ausgangsflusskontrolle (Eingangssignal). Wenn DSRFLOW aktiviert ist, stoppt der DTE (Computer) das Senden von Daten, wenn das DSR-Signal vom DCE (Modem) auf logisch niedrig gesetzt wird. Die Übertragung wird aktiviert, wenn das DSR-Signal wieder logisch hoch ist. Das DSR-Signal wird oft in Verbindung mit CTS als Reaktion auf ein RTS-Signal verwendet.

DSRSENS

TRUE/FALSE DSR-Empfindlichkeit aktivieren. Wenn DSRSENS aktiviert ist, werden vom DTE (Computer) empfangene Daten nur dann in den Empfangspuffer gestellt, wenn DSR auf logisch hoch gesetzt ist. Wenn DSR niedrig eingestellt ist, werden empfangene Daten verworfen. Durch die Aktivierung von DSRSENS kann DSR das DTE (den Computer) aktivieren oder deaktivieren, um Daten vom DTE (dem Modem) zu empfangen. DSRSENS wird in praktischen Kommunikationssituationen selten verwendet.

DTRFLOW

TRUE/FALSE DTR-Handshake-Flusskontrolle aktivieren (Ausgangssignal). Wenn DTRFLOW aktiviert ist, signalisiert es, dass sich das DCE (Modem) auf die Verbindung mit dem Kommunikationskanal vorbereiten sollte. DTR wird normalerweise für die Modem-On-/Off-Hook-Steuerung verwendet, kann aber auch in Verbindung mit DSR für Handshaking verwendet werden.

DTRLINE

TRUE/FALSE DTR-Leitung aktivieren. Wenn aktiviert, lässt DTRLINE die DTR-Leitung aktiv, wenn der Port vom DTE (Computer) geschlossen wird. Dadurch wird sichergestellt, dass das DCE (Modem) den Kommunikationskanal nicht schließt, wenn der Port geschlossen ist.

TRUE/FALSE Null-Bytes ($NUL) werden verworfen, wenn read.

PARITY

TRUE/FALSE Paritätsprüfung aktivieren. Dieser Modus muss aktiviert sein, damit die anderen Paritätsoptionen ausgewählt werden können.

PARITYCHAR

Zeichen, das zum Ersetzen von Paritätsfehlern verwendet werden soll. PARITY muss aktiviert sein.

PARITYREPL

TRUE/FALSE Zeichenersetzung bei Paritätsfehler aktivieren. PARITY muss aktiviert sein.

PARITYTYPE

0 = Keine, 1 = Ungerade, 2 = Gerade, 3 = Mark, 4 = Leerzeichen. PARITÄT muss aktiviert sein. Standard = 0.

TRUE/FALSE Klingelanzeige ist eingeschaltet (schreibgeschützt). Wenn RING TRUE zurückgibt, wird auf dem Kommunikationskanal (vom Modem) ein Rufsignal empfangen. RING nähert sich dem Zustand des Rufsignals an; Allerdings wird es möglicherweise nicht auf allen Windows-Plattformen korrekt gemeldet.

Receive-line-signal-detect (READ-ONLY). Siehe CD/Carrier-Erkennung oben.

RTSFLOW

Bereit zum Senden (Ausgangssignal). 0 = Deaktivieren, 1 = Aktivieren, 2 = Handshake, 3 = Umschalten. Toggle wird für Halbduplex-(2-Draht)-Operationen verwendet, um die Leitung „umzukehren“. Während der DTE (Computer) damit beschäftigt ist, Daten zu senden, löst er das RTS-Signal aus und der DCE (Modem) blockiert seinen Datenempfangskanal. Wenn das RTS-Signal auf logisch niedrig zurückkehrt, kehrt das DCE (Modem) in den Sendemodus zurück und das DTE (Computer) wechselt in den Empfangsmodus.

Der Handshake-Modus veranlasst das DTE (Computer), den Empfangspuffer (RXQUE) zu überprüfen, nachdem jedes Zeichen im Puffer platziert wurde. Wenn der Puffer zu 5/6 voll ist, wird das RTS-Signal gelöscht. Wenn der Empfangspuffer auf unter 1/6 sinkt, wird RTS erneut erhöht.

RXPUFFER

Größe des Empfangspuffers in Bytes.

Derzeit im Empfangspuffer befindliche Zeichen (schreibgeschützt).

0 = 1 Stoppbits, 1 = 1,5 Stoppbits, 2 = 2 Stoppbits.

TXBUFFER

Größe des Sendepuffers in Bytes. In einigen Fällen kann Windows die Übertragungsgröße möglicherweise nicht melden.

Derzeit im Sendepuffer befindliche Zeichen (schreibgeschützt).

XINPFLOW

TRUE/FALSE Aktiviert die XON/XOFF-Eingangsflusssteuerung. Wenn der Empfangspuffer des DTE (Computers) voll ist, wird ein XOFF-Zeichen an das DCE (Modem) gesendet, um es anzuweisen, die Übertragung anzuhalten. Wenn das DCE zur Wiederaufnahme der Übertragung bereit ist, wird ein XON-Zeichen an das DCE gesendet. Typischerweise wird XOFF gesendet, wenn der Empfangspuffer weniger als 1/16 verbleibend hat, und XON wird gesendet, wenn der Empfangspuffer auf weniger als 1/16 seiner maximalen Größe abfällt. Standard = FALSCH.

XOUTFLOW

TRUE/FALSE XON/XOFF-Ausgangsflusskontrolle aktivieren. Wenn aktiviert, sendet das DCE (Modem) ein XOFF an das DTE (Computer), um die Datenübertragung an das DCE zu stoppen. Wenn das DCE bereit ist, weitere Daten zu empfangen, wird ein XON-Zeichen gesendet. XOUTFLOW verwendet normalerweise die gleichen 1/16-Regeln wie XINPFLOW. Standard = FALSCH.

Gängige Baudraten reichen von 110 bis 256.000. In der Datei WIN32API.INC sind Equates mit dem Präfix %CBR_ definiert, um Sie bei der Angabe einer gemeinsamen Baudrate zu unterstützen, Sie sind jedoch nicht auf einen begrenzten Satz von Raten beschränkt.

Der Versuch, ein READ-ONLY-Attribut festzulegen, führt zur Kompilierungszeit zum Fehler 542 („Darf nicht geändert werden“).

Das Zahlensymbol (#) als Präfix ist optional, wird aber aus Gründen der Übersichtlichkeit empfohlen.

PBXB64-Implementierungshinweise

PBXB64 V14 senkt BAUD, BYTE/BITS, PARITY, PARITYTYPE, PARITYCHAR, PARITYREPL, STOP, XINPFLOW und XOUTFLOW auf den eingebetteten Windows-DCB-Laufzeitpfad ab. test_comm_set_extended.pb prueft dynamische Ausdruckswerte fuer diese Optionen, und test_comm_flow_missing.pb prueft sicheres Verhalten bei fehlendem Port und Null-Handle. Fuer erfolgreiche hardwaregestuetzte Kommunikation ist weiterhin ein echter serieller Port oder ein virtuelles COM-Port-Paar erforderlich.

Siehe auch

  • Serielle Kommunikation
  • KOMM CLOSE
  • COMM-Funktion
  • KOMMLINIE
  • KOMM. OFFEN
  • KOMM. DRUCK
  • COMM RECV
  • KOMM-RESET
  • KOMM SENDEN
  • KOMM-TIMEOUT

Kommunikationsprüfung

Serielle, TCP- und UDP-Seiten sollen Endpoint-Aufbau, Blocking-Verhalten, Timeout-Verhalten, Pufferbesitz und Cleanup nennen. Ein vollständiges Beispiel deckt Open/Create, Senden oder Empfangen, Close und einen vorhersagbaren Fehler wie einen ungültigen Endpoint ab.

Laufzeitvoraussetzungen

Netzwerkbeispiele können Firewall-Berechtigungen und freie Ports benötigen. Serielle Beispiele erfordern ein vorhandenes COM-Gerät oder einen dokumentierten Loopback/Testadapter.

Diagnosen

Erfassen Sie Rückgabewerte und Windows-Fehlercodes, wo verfügbar, damit Kommunikationsfehler auswertbar statt still sind.

Umfangshinweise

Wenn die Seite eine Familie statt eines einzelnen Befehls beschreibt, nennen Sie das konkrete Senden, Empfangen, Prüfen, Verbinden oder Schließen, das das Verhalten belegt, und sagen Sie, ob derselbe Socket oder Handle nach dem Aufruf weiterverwendet werden darf. Dadurch wird die Seite zu einem nutzbaren Laufzeitvertrag statt zu einem allgemeinen Protokollhinweis.


KOMM-TIMEOUT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › COMM TIMEOUT

KOMM-TIMEOUT

Begrenzen Sie die Zeit zum Abschließen eines COMM

Typ:Anweisung |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

COMM TIMEOUT [#] hComm , TimeOutMS&

Beschreibung

Mit COMM TIMEOUT können Sie angeben, wie lange ein COMM-Vorgang auf das Senden oder Empfangen eines Datenbytes warten soll. Dieser Wert wird in Millisekunden gemessen. Wenn die angegebene Anzahl von Millisekunden ohne Antwort verstreicht, schlägt der COMM-Vorgang fehl und es wird ein Laufzeitfehler 24 (Geräte-Timeout) generiert.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL h AS LONG
    COMM OPEN "PBXB64_NO_SUCH_COMM_PORT" AS #h
    COMM TIMEOUT #h, 250
    COMM CLOSE #h
END FUNCTION

Validierungsbeleg

Validierungsbeleg: Die Tests der seriellen Kommunikation pruefen die Timeout-Einstellung im aktuellen COMM-Oeffnen/Senden/Empfangen/Schliessen-Umfang. Die Seite sollte zusammen mit den uebrigen COMM-Seiten gelesen werden, da der Timeout nur mit einem gueltigen Kommunikationshandle relevant ist.

Siehe auch

  • Serielle Kommunikation
  • KOMM CLOSE
  • COMM-Funktion
  • KOMMLINIE
  • KOMM. OFFEN
  • KOMM. DRUCK
  • COMM RECV
  • KOMM-RESET
  • KOMM SENDEN
  • KOMM.-EINST
  • KOMM-TIMEOUT
  • FREEFILE
  • OFFEN

Kommunikationsprüfung

Serielle, TCP- und UDP-Seiten sollen Endpoint-Aufbau, Blocking-Verhalten, Timeout-Verhalten, Pufferbesitz und Cleanup nennen. Ein vollständiges Beispiel deckt Open/Create, Senden oder Empfangen, Close und einen vorhersagbaren Fehler wie einen ungültigen Endpoint ab.

Laufzeitvoraussetzungen

Netzwerkbeispiele können Firewall-Berechtigungen und freie Ports benötigen. Serielle Beispiele erfordern ein vorhandenes COM-Gerät oder einen dokumentierten Loopback/Testadapter.

Diagnosen

Erfassen Sie Rückgabewerte und Windows-Fehlercodes, wo verfügbar, damit Kommunikationsfehler auswertbar statt still sind.

Umfangshinweise

Wenn die Seite eine Familie statt eines einzelnen Befehls beschreibt, nennen Sie das konkrete Senden, Empfangen, Prüfen, Verbinden oder Schließen, das das Verhalten belegt, und sagen Sie, ob derselbe Socket oder Handle nach dem Aufruf weiterverwendet werden darf. Dadurch wird die Seite zu einem nutzbaren Laufzeitvertrag statt zu einem allgemeinen Protokollhinweis.


COMMAND$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › BEFEHL$

BEFEHL$

Gibt die Befehlszeilenargumente zurück, die zum Starten des Programms verwendet werden.

Typ:Funktion |Kategorie: Utilities

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = COMMAND$
s$ = COMMAND$( ArgNum )

Beschreibung

COMMAND$ gibt alles zurück, was nach dem Programmnamen eingegeben wurde. In einigen Betriebssystemhandbüchern wird dieser Text als Trailer oder Befehlsende bezeichnet. Sie können COMMAND$ verwenden, um Laufzeitargumente wie Dateinamen und Programmoptionen zu sammeln.

Abhängig von der optionalen Argumentnummer gibt COMMAND$ entweder den vollständigen Trailer oder nur eines der Argumente zurück. Wenn ArgNum Null (0) ist oder nicht vorhanden ist, wird der vollständige Trailer zurückgegeben. Wenn ArgNum größer als Null ist, wird der Trailer analysiert, um ein einzelnes Argument zurückzugeben (1 = erstes Argument. 2 = zweites Argument usw.). Wenn ArgNum größer als die Anzahl der Argumente ist, wird eine Nullzeichenfolge (Nulllänge) zurückgegeben.

Argumente werden durch ein oder mehrere Leerzeichen getrennt. Wenn Leerzeichen von Bedeutung sind, sollten Sie das Argument in doppelte Anführungszeichen (") einschließen. Solche doppelten Anführungszeichen werden von COMMAND$ aus dem Rückgabewert entfernt. Wenn eine Zeichenfolge in Anführungszeichen mit der Länge Null ("") gefunden wird, wird sie vollständig ignoriert.

Stellen Sie sich beispielsweise ein Programm namens FASTSORT.EXE vor, das Daten aus einer Datei liest, sie sortiert und das Ergebnis in einer neuen Datei ablegt. Mit COMMAND$ können Sie die Namen der Eingabe- und Ausgabedateien angeben, wenn das Programm aufgerufen wird:

FASTSORT.EXE cust.dta cust.new

Wenn FASTSORT mit der Ausführung beginnt, würde COMMAND$ oder COMMAND$(0) Folgendes zurückgeben:

cust.dta cust.new

COMMAND$(1) würde Folgendes zurückgeben:

cust.dta

COMMAND$(2) würde Folgendes zurückgeben:

Kundenneu

Einschränkungen

In einigen neueren Windows-Versionen führen Dateizuordnungs- und Drag-Drop-Dateivorgänge dazu, dass Dateinamen bei der Übergabe in COMMAND$ in doppelte Anführungszeichen eingeschlossen werden. Es wäre ratsam, sicherzustellen, dass Ihre Bewerbungen auf diese Möglichkeit vorbereitet sind. Einige Betriebssysteme schließen die Befehlszeile automatisch in doppelte Anführungszeichen ein.

PowerBASIC legt keine willkürlichen Beschränkungen für die Länge der von COMMAND$ zurückgegebenen Zeichenfolge fest, das Betriebssystem kann jedoch Beschränkungen festlegen. Solche Einschränkungen können beispielsweise deutlich werden, wenn Sie versuchen, eine große Anzahl von Dateien per Drag & Drop in eine EXE-Datei im Windows Explorer zu ziehen. Normalerweise führt der Versuch, mehr Dateien zu löschen, als das Betriebssystem zulässt, zu einer Warnmeldung des Betriebssystems.

Innerhalb der IDE kann ein Befehlszeilenparameter COMMAND$ zu Testzwecken sowohl im Kompilierungs- und Ausführungsmodus als auch im Kompilierungs- und Debugmodus angegeben werden.

Siehe auch

  • JOIN$
  • PARSE
  • PARSE$
  • PARSECOUNT
  • PFADNAME$
  • PATHSCAN$
  • WINMAIN

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


Kommentieren des Assemblycodes – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Assembly-Code kommentieren

Kommentieren des Assemblycodes

In Assembler-Codezeilen wird normalerweise ein Semikolon ( ; ) für Kommentare verwendet, obwohl ein Apostroph ( ' ) weiterhin gültig ist. Zum Beispiel:

Typ:Schlüsselwort |Kategorie:Inline-Assembler

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

ASM PUSH EBX ; Speichern Sie EBX

ASM MOV EAX, 5 ; Geben Sie 5 in EAX ein

! MOV EBX, &HFF ; Setzen Sie FFh in EBX

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


Kommunikationssteuerung – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Kommunikationssteuerung

Kommunikationskontrolle

Für die externe Kommunikation können folgende Funktionen genutzt werden:

Typ:Schlüsselwort |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Rufen Sie den Wert oder Status eines Kommunikationsparameters ab

Schließen Sie eine offene serielle Schnittstelle

Beschreibung

Kommunikationskontrolle gehoert zur Kategorie General. Diese Seite beschreibt den PBXB64-Dokumentationsstand fuer diesen Eintrag; verwenden Sie die Grenzen und Belege auf dieser Seite statt historischer PBWin-Annahmen.

Syntax

' Siehe den urspruenglichen Eintrag und die verlinkten Beispiel-/Testdateien fuer die genaue PBXB64-Form von Kommunikationskontrolle.
' Nicht belegte Unterformen bleiben ausserhalb der zertifizierten Oberflaeche.

Praktische Verwendung

Kommunikationskontrolle gehoert zur Kategorie General. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Kommunikationskontrolle mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Siehe auch

  • Befehlsindex
  • BASIC-Frontend


COMPILE-Metaanweisung – PBXB64-Compiler-Hilfe

Startseite › Funktionen › COMPILE Metastatement

COMPILE-Metaaussage

Steuert Compileroptionen aus dem Quellcode.

Typ:Konzeptionell |Kategorie:Präprozessor

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Überblick

Dieses Thema bietet Hintergrundinformationen und praktische Anleitungen. Eine detaillierte Syntax finden Sie auf den entsprechenden Befehlsseiten.

Beschreibung

#COMPILE waehlt die Ausgabefamilie fuer die aktuelle Quelldatei. Die fokussierte PBXB64-Oberflaeche belegt EXE-, DLL-, SLL- und Subsystem-Auswahl; die Seite ist als Vertrag fuer diese Build-Modus-Entscheidungen zu lesen.

Syntax

#COMPILE EXE
#COMPILE DLL
#COMPILE SLL
#COMPILE GUI
#COMPILE CONSOLE

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validierungsbeleg: tests/pb/test_compile_exe_directive.pb belegt, dass #COMPILE EXE eine PE-EXE mit dem angeforderten Ausgabename erzeugt. tests/pb/test_compile_dll_named.pb belegt, dass #COMPILE DLL eine DLL erzeugt und die benannten Einstiegspunkte exportiert. tests/pb/test_sll_unit.pb belegt, dass #COMPILE SLL die PBXB64-native Archivform erzeugt. tests/pb/test_subsystem_directive_gui.pb, tests/pb/test_subsystem_directive_console.pb, tests/pb/test_subsystem_cli_gui.pb und tests/pb/test_subsystem_cli_console.pb belegen die Auswahl von Subsystemen aus Quelle und CLI.

Hinweise

#COMPILE SLL ist PBXB64-natives COFF-Archivverhalten und keine alte PowerBASIC-SLL-Kompatibilitaet. Die CLI ueberschreibt Quell-Direktiven, wenn beide vorhanden sind.

Nutzungshinweise

Platzieren Sie die Direktive vor ausfuehrbarem Code. Verwenden Sie einen Dateinamen nur dann, wenn Sie den Ausgabestamm oder die Erweiterung steuern muessen, und halten Sie die benannten Beispiele klein, damit der Ausgabemodus aus der erzeugten Datei eindeutig wird.

Siehe auch

  • #COMPILE
  • Compiler
  • Optionen

Siehe auch

  • #COMPILE
  • Compiler
  • Optionen

Siehe auch

  • #COMPILE
  • Compiler
  • Optionen

Siehe auch

  • #COMPILE
  • Compiler
  • Optionen

Siehe auch

  • #COMPILE
  • Compiler
  • Optionen

Siehe auch

  • #COMPILE
  • Compiler
  • Optionen

Siehe auch

  • #COMPILE
  • Compiler
  • Optionen

Siehe auch

  • #COMPILE
  • Compiler
  • Optionen

Siehe auch

  • #COMPILE
  • Compiler
  • Optionen

Siehe auch

  • #COMPILE
  • Compiler
  • Optionen

Siehe auch

  • #COMPILE
  • Compiler
  • Optionen

Siehe auch

  • #COMPILE
  • Compiler
  • Optionen

Siehe auch

  • #COMPILE
  • Compiler
  • Optionen

Siehe auch

  • #COMPILE
  • Compiler
  • Optionen

Siehe auch

  • Befehlsindex


#COMPILE – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › #COMPILE

#KOMPILE

Bestimmen Sie, welcher Dateityp vom Compiler erstellt wird.

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

#COMPILE {EXE | DLL | SLL | GUI | CONSOLE} [" filename { .exe | .dll | .sll }"]
#GUI
#CONSOLE

Beschreibung

Mit dieser Metaanweisung wird angegeben, ob ein Modul als EXE-, DLL- oder PBXB64-native SLL-Datei kompiliert werden soll, oder welches GUI-/Konsolen-Subsystem verwendet wird. Die #COMPILE-Metaanweisung kann nur einmal pro Programm verwendet werden und muss vor jedem ausführbaren Code platziert werden.

Optional koennen Sie den Zielnamen und den Pfad der Datei angeben. Wenn der Name keine Erweiterung enthaelt, haengt PBXB64 die Standarderweiterung des Ausgabetyps an: .exe, .dll oder .sll. Wenn der Name bereits eine Erweiterung enthaelt, wird er unveraendert verwendet. Ein Befehlszeilenpfad mit -o hat Vorrang.

Wenn die Dateinamenklausel weggelassen wird, erhält die kompilierte Datei den Namen der Hauptquellcodedatei mit einer entsprechenden Erweiterung.

Der getestete DLL-Teil von PBXB64 schreibt ein natives PE-DLL-Image und eine Exporttabelle fuer PB-Funktionen mit EXPORT, auch in der PB-typischen Form FUNCTION name(...) EXPORT AS type. Die aktive Validierung prueft das DLL-Kennzeichen und die exportierten Namen.

Der getestete SLL-Teil von PBXB64 schreibt ein deterministisches COFF-Archiv mit der Erweiterung .sll. Es enthaelt das kompilierte Benutzerobjekt sowie unterstuetzte SLL-lokale Link-Eingaben und Ressourcen. Startup-Code und eingebettete Laufzeitobjekte werden erst vom finalen EXE- oder DLL-Host gelinkt.

PBXB64 akzeptiert auch #COMPILE GUI, #COMPILE CONSOLE, #GUI und #CONSOLE, um das Windows-PE-Subsystem ausdruecklich festzulegen. GUI schreibt Subsystemwert 2 (IMAGE_SUBSYSTEM_WINDOWS_GUI); CONSOLE schreibt Subsystemwert 3 (IMAGE_SUBSYSTEM_WINDOWS_CUI). Dadurch werden Faelle vermieden, in denen die automatische Erkennung von Konsolenausgaben falsch entscheidet.

Die Befehlszeilenoptionen -gui/--gui und -con/--console bieten dieselbe Steuerung fuer Build-Skripte und haben Vorrang vor Source-Direktiven, wenn beides angegeben ist.

Wenn ein Pfad angegeben ist, wird die kompilierte Datei im genannten Verzeichnis abgelegt; Andernfalls wird es im aktuellen Verzeichnis abgelegt.

Wenn das genannte Verzeichnis nicht existiert, der Dateiname ungültig oder gesperrt ist, die EXE-Datei noch läuft oder die Datei aus einem anderen Grund nicht erfolgreich an diesem Ort gespeichert werden kann, tritt beim Kompilieren ein Fehler 496 („Fehler beim Schreiben der Zieldatei“) auf.

Ein verwandtes Element ist das integrierte numerische Equate %PB_COMPILETIME . Jedes Mal, wenn Sie Ihr Programm kompilieren, wird dieses Equater mit dem aktuellen Datum und der aktuellen Uhrzeit der Kompilierung im PowerTime-Binärformat gefüllt. Mit der PowerTIME-Klasse können Sie es zur Verwendung in Ihrer Anwendung in ein Textäquivalent konvertieren.

Einschränkungen

Wenn #COMPILE nicht angegeben ist, ist der Standardwert #COMPILE EXE.

#COMPILE SLL ist PBXB64-native Static-Library-Funktionalitaet. Es ist keine binaere Kompatibilitaet mit alten PowerBASIC-SLL-Dateien. Getestete SLL-Units duerfen mit #LINK ein anderes PBXB64-natives Archiv einbinden und unterstuetzte #RESOURCE-Formen verwenden; diese Eingaben werden in den finalen Host-Link uebernommen. Nicht unterstuetzte Objekt-, Archiv- oder Ressourceneingaben und nicht aufgeloeste Host-Symbole bleiben Linkerfehler.

Beispiele

#COMPILE EXE ' Gleicher Name wie die Quelle, d. h. ABC.EXE

#COMPILE DLL ' Gleicher Name wie die Quelle, d. h. ABC.DLL

#COMPILE SLL "ABC.SLL" ' Erstellt ein PBXB64-natives COFF-Archiv

#COMPILE EXE "ABC.BAS" ' Kompiliert zu ABC.BAS.EXE

#GUI ' Windows-GUI-Subsystem erzwingen

#CONSOLE ' Windows-Konsolen-Subsystem erzwingen

Siehe auch

  • %PB_COMPILETIME
  • #COMPILER
  • -gui, --gui
  • -con, --console
  • DLLMAIN
  • LIBMAIN
  • PBLIBMAIN
  • PBMAIN
  • WINMAIN

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


COMPILER-Metaanweisung – PBXB64-Compiler-Hilfe

Startseite › Funktionen › COMPILER Metastatement

COMPILER-Metaaussage

Bettet Compiler-Anweisungen und -Optionen direkt in den Quellcode ein.

Typ: Metaaussage | Kategorie: Präprozessor und Metaanweisungen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

#COMPILER option

Remarks

Verwenden Sie die Metaanweisung COMPILER, um Kompilierungsoptionen wie Warnungen, Optimierungen und Zieleinstellungen aus der Quelldatei heraus zu steuern.

Siehe auch

  • KOMPILIEREN
  • OPTION

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


CONST – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONST

CONST

Deklarieren Sie eine Kompilierzeitkonstante

Typ:Anweisung |Kategorie: Datentypen und Variablen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONST name [= value] [, name [= value] ...] AS type
CONST name = expression

Beschreibung

DerCONST Die Anweisung definiert eine benannte Konstante, deren Wert zur Kompilierzeit festgelegt wird. Konstanten können numerisch oder Zeichenfolgen sein und können im Modul- oder Prozedurbereich deklariert werden.

Beispiel

FUNCTION PBMAIN () AS LONG
    CONST Pi = 3.141592653589793##
    CONST MaxCount = 100&
    LOCAL r AS DOUBLE
    r = 2.0##
    FUNCTION = FIX(Pi * r * r)
END FUNCTION

Generierter Assembler-Code

Kompilieren mit:

PBXB64 example.pb --asmout example.asm
    mov r10, 0x400921fb54442d18
    movq xmm0, r10
    movsd [rbp-24], xmm0
    mov r10, 0x4000000000000000
    movq xmm0, r10
    movsd [rbp-32], xmm0

Hinweise

Konstanten werden in unmittelbare Werte gefaltet oder als Literalwerte geladen; Sie verbrauchen keinen veränderlichen Speicher.

Siehe auch

  • Lokal
  • Global
  • Statisch
  • Aufzählung
  • Grundlegende Ref-Variablen

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Konstanten und Literale – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Konstanten und Literale

Konstanten und Literale

Ein String-Literal ist einfach eine Gruppe von Zeichen, die von Anführungszeichen umgeben sind. Darauf kann optional eine TypeID aus einem einzelnen $ folgen, um ANSI-Zeichen anzugeben, oder einem doppelten $$ für wide , Unicode ch

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

MyAnsi$ = „Dies ist eine Zeichenfolge“$

MyWide$$ = „Dies ist eine UniCode-Zeichenfolge“$$

Ein String-Literal kann das Anführungszeichen enthalten, indem einfach das Zeichen innerhalb der Zeichenfolge verdoppelt wird. Zum Beispiel:

A$ = „Dies ist eine Zeichenfolge“

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


CONTROL ADD – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL ADD

STEUERUNG HINZUFÜGEN

Fügen Sie ein benutzerdefiniertes Steuerelement zu a hinzu

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD classname$, hDlg , id& , txt$ , x , y , xx , yy [, [ style& ] [, [ exstyle& ]]] [[,] CALL callback ]

Beschreibung

Wenn der Benutzer mit dem Steuerelement interagiert, wird eine Nachricht an die angegebene Rückruffunktion gesendet. Wenn keine Rückruffunktion angegeben ist, wird die Nachricht an den Rückruf für den Dialog gesendet.

Die Werte „style&“ und „exstyle&“ hängen von der Art des verwendeten benutzerdefinierten Steuerelements oder allgemeinen Steuerelements ab. Die an Ihren Rückruf gesendeten Benachrichtigungen hängen auch von der Art des verwendeten benutzerdefinierten Steuerelements oder allgemeinen Steuerelements ab.

Wenn die Callback-Funktion eine %WM_COMMAND-Nachricht empfängt, kann die Identität des Steuerelements, das die Nachricht sendet, mit der CB.CTL-Funktion ermittelt werden. Verwenden Sie die Funktion CB.CTLMSG, um den Wert der Benachrichtigungsnachricht in Ihrem Rückruf abzurufen. Viele allgemeine Windows-Steuerelemente senden jedoch %WM_NOTIFY-Nachrichten (an den Rückruf des übergeordneten Dialogs, nicht an den Steuerelementrückruf) anstelle der konventionelleren %WM_COMMAND-Nachrichten. In solchen Fällen variiert die Bedeutung der Nachrichtenparameter CB.WPARAM und CB.LPARAM je nach Art der verarbeiteten Benachrichtigungsnachricht.

Einschränkungen

Benutzerdefinierte Steuerelemente erfordern möglicherweise eine besondere Behandlung außer den generischen DDT-Funktionen ( CONTROL SET COLOR , CONTROL SET FONT usw.). Weitere Informationen finden Sie in der Dokumentation zu den Steuerungen.

Siehe auch

  • #NACHRICHTEN
  • Dynamic Dialog Tools
  • STEUERGRIFF
  • STEUERUNG SENDEN

PBXB64-Umsetzungshinweise

STEUERUNG HINZUFÜGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG HINZUFÜGEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG HINZUFÜGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


STEUERUNG HINZUFÜGEN-TASTE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STEUERUNG HINZUFÜGEN-TASTE

STEUERUNG HINZUFÜGEN-TASTE

Fügen Sie einem Dialogfeld eine Befehlsschaltfläche hinzu. Eine Befehlsschaltfläche ist eine Schaltfläche, die beim Klicken auf die Schaltfläche eine Aktion auslöst. Ein häufiges Beispiel für eine Befehlsschaltfläche ist die Schaltfläche „OK“ in einem Meldungsfelddialogfeld.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD BUTTON, hDlg , id& , txt$ , x , y , xx , yy [, [ style& ] [, [ exstyle& ]]] [[,] CALL callback ]
CONTROL ADD BUTTON, hDlg, id&, txt$, 100, 100, 150, 200, , , _
CALL ButtonCallback() ' Use default styles

Beschreibung

Wenn das kaufmännische Und-Zeichen (&) im txt$-Parameter vorkommt, wird der folgende Buchstabe unterstrichen angezeigt. Dadurch wird eine Steuerungsbeschleunigung (Hotkey) hinzugefügt, die es dem Benutzer ermöglicht, direkt auf ein Steuerelement zu „klicken“, indem er einfach die ALT-Taste gedrückt hält, während er den angegebenen Hotkey drückt. Beispielsweise macht „Beenden“ ALT+x zum Hotkey.

Unter Windows XP und Windows 2000 müssen Sie möglicherweise die ALT-Taste drücken, bevor die Steuerungsbeschleuniger sichtbar werden. Sie können in den Windows-Anzeigeeinstellungen festlegen, ob Befehlsbeschleuniger bei Verwendung der ALT-Taste oder ständig sichtbar sind.

Sofern nicht der %BS_FLAT-Stil verwendet wird, wird die Schaltfläche im Dialog in einem dreidimensionalen Erscheinungsbild gezeichnet. Wenn der Benutzer auf eine Schaltfläche klickt, wird eine Nachricht an die für die Schaltfläche vorgesehene Rückruffunktion gesendet. Wenn keine Rückruffunktion angegeben ist, wird die Nachricht an den Rückruf für den Dialog gesendet.

Wenn die Steuerrückruffunktion eine Nachricht verarbeitet, sollte sie im Allgemeinen TRUE (ungleich Null) zurückgeben, um zu verhindern, dass die Nachricht unnötigerweise an den Dialogrückruf (falls vorhanden) übergeben wird. Der Dialog-Callback sollte auch TRUE zurückgeben, wenn die Benachrichtigungsnachricht von dieser Callback-Funktion verarbeitet wird. Andernfalls verarbeitet die DDT-Engine nicht verarbeitete Nachrichten.

Benachrichtigungsnachrichten werden an die Callback-Funktion gesendet, wobei CB.MSG = %WM_COMMAND ist, CB.CTL die ID (id&) des Steuerelements enthält und CB.CTLMSG die folgenden Werte enthält:

%BN_CLICKED

Wird gesendet, wenn der Benutzer auf eine Maustaste klickt oder die Schaltfläche mit dem Hotkey aktiviert (es sei denn, die Schaltfläche wurde deaktiviert).

%BN_DISABLE

Wird gesendet, wenn eine Schaltfläche deaktiviert ist.

%BN_KILLFOCUS

Wird gesendet, wenn eine Schaltfläche den Tastaturfokus verliert. Die Schaltfläche muss den %BS_NOTIFY-Stil enthalten.

%BN_SETFOCUS

Wird gesendet, wenn eine Schaltfläche den Tastaturfokus erhält. Die Schaltfläche muss den %BS_NOTIFY-Stil enthalten.

Wenn eine Rückruffunktion eine %WM_COMMAND-Nachricht empfängt, sollte sie den Wert von CB.CTL und CB.CTLMSG explizit testen, um sicherzustellen, dass sie angemessen auf die Benachrichtigungsnachricht reagiert.

Siehe auch

  • Dynamic Dialog Tools
  • CONTROL GET TEXT
  • STEUERUNG SET SCHRIFTART
  • STEUERUNG TEXT EINSTELLEN

PBXB64-Umsetzungshinweise

STEUERUNG HINZUFÜGEN-TASTE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG HINZUFÜGEN-TASTE ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG HINZUFÜGEN-TASTE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL ADD CHECK3STATE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL ADD CHECK3STATE

STEUERUNG CHECK3STATE HINZUFÜGEN

Fügen Sie einem Dialogfeld ein Kontrollkästchen für die automatische 3-Status-Funktion hinzu. Dies wird häufig verwendet, um eine Auswahl anzugeben, die „Wahr“ (festgelegt oder aktiviert), „Falsch“ (nicht festgelegt oder deaktiviert) oder „Unbestimmt“ (ausgegraut) sein kann, und wird oft in Dialogen gefunden, die „Multiple-Choice“-Optionen bieten.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD CHECK3STATE, hDlg , id& , txt$ , x , y , xx , yy [, [ style& ] [, [ exstyle& ]]] [[,] CALL callback ]
CONTROL ADD CHECK3STATE, hDlg, id&, txt$, 100, 100, 40, 14, , , _
CALL Check3Callback() ' Use default styles

Beschreibung

Wenn das kaufmännische Und-Zeichen (&) im txt$-Parameter vorkommt, wird der folgende Buchstabe unterstrichen angezeigt. Dadurch wird eine Steuerungsbeschleunigung (Hotkey) hinzugefügt, die es dem Benutzer ermöglicht, direkt auf ein Steuerelement zu „klicken“, indem er einfach die ALT-Taste gedrückt hält, während er den angegebenen Hotkey drückt. Beispielsweise macht „Set s&tate“ ALT+t zum Hotkey.

Wenn der Benutzer auf ein Kontrollkästchen mit drei Zuständen klickt, wird eine Nachricht an die für das Steuerelement vorgesehene Rückruffunktion gesendet. Wenn keine Rückruffunktion angegeben ist, wird die Nachricht an den Rückruf für den Dialog gesendet.

Wenn der Steuerrückruf die Benachrichtigungsnachricht verarbeitet, sollte er TRUE (ungleich Null) zurückgeben, um zu verhindern, dass die Nachricht unnötig an den Dialogrückruf und schließlich an die DDT-Engine selbst weitergeleitet wird.

Benachrichtigungsnachrichten werden an die Callback-Funktion gesendet, wobei CB.MSG = %WM_COMMAND ist, CB.CTL die ID (id&) des Steuerelements enthält und CB.CTLMSG die folgenden Werte enthält:

%BN_CLICKED

Wird gesendet, wenn der Benutzer eine Maustaste klickt oder das Steuerelement mit dem Hotkey aktiviert (es sei denn, das Steuerelement wurde deaktiviert).

%BN_DISABLE

Wird gesendet, wenn ein Steuerelement deaktiviert ist.

%BN_KILLFOCUS

Wird gesendet, wenn ein Steuerelement den Tastaturfokus verliert. Das Steuerelement muss den %BS_NOTIFY-Stil enthalten.

%BN_SETFOCUS

Wird gesendet, wenn ein Steuerelement den Tastaturfokus erhält. Das Steuerelement muss den %BS_NOTIFY-Stil enthalten.

Wenn eine Rückruffunktion eine %WM_COMMAND-Nachricht empfängt, sollte sie den Wert von CB.CTL und CB.CTLMSG explizit testen, um sicherzustellen, dass sie angemessen auf die Benachrichtigungsnachricht reagiert.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERN SIE DAS Kontrollkästchen „Hinzufügen“.
  • STEUERN SIE DIE OPTION HINZUFÜGEN
  • KONTROLLE ERHALTEN SIE ÜBERPRÜFEN
  • STEUERUNGSSATZ PRÜFEN
  • STEUERUNG FARBE EINSTELLEN
  • STEUERUNG SET SCHRIFTART

PBXB64-Umsetzungshinweise

STEUERUNG CHECK3STATE HINZUFÜGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG CHECK3STATE HINZUFÜGEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG CHECK3STATE HINZUFÜGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


STEUERUNG CHECKBOX HINZUFÜGEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STEUERUNG CHECKBOX HINZUFÜGEN

STEUERN SIE DAS Kontrollkästchen „Hinzufügen“.

Fügen Sie einem Dialogfeld ein automatisches Kontrollkästchen hinzu. Dies wird normalerweise verwendet, um eine Wahr/Falsch- oder Ein/Aus-Auswahl anzuzeigen, und kommt häufig in Dialogen vor, die einem Benutzer eine Auswahl an Optionen bieten.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD CHECKBOX, hDlg , id& , txt$ , x , y , xx , yy [, [ style& ] [, [ exstyle& ]]] [[,] CALL callback ]
CONTROL ADD CHECKBOX, hDlg, id&, txt$, 100, 100, 40, 14, , , _
CALL CheckboxCallback() ' Use default styles

Beschreibung

Wenn das kaufmännische Und-Zeichen (&) im txt$-Parameter vorkommt, wird der folgende Buchstabe unterstrichen angezeigt. Dadurch wird eine Steuerungsbeschleunigung (Hotkey) hinzugefügt, die es dem Benutzer ermöglicht, direkt auf ein Steuerelement zu „klicken“, indem er einfach die ALT-Taste gedrückt hält, während er den angegebenen Hotkey drückt. Beispielsweise macht „O&ption“ ALT+p zum Hotkey.

Wenn der Benutzer auf ein Steuerelement klickt, wird eine Nachricht an die für das Steuerelement vorgesehene Rückruffunktion gesendet. Wenn keine Rückruffunktion angegeben ist, wird die Nachricht an den Rückruf für den Dialog gesendet.

Wenn der Steuerrückruf die Benachrichtigungsnachricht verarbeitet, sollte er TRUE (ungleich Null) zurückgeben, um zu verhindern, dass die Nachricht unnötig an den Dialogrückruf und schließlich an die DDT-Engine selbst weitergeleitet wird.

Benachrichtigungsnachrichten werden an die Callback-Funktion gesendet, wobei CB.MSG = %WM_COMMAND ist, CB.CTL die ID (id&) des Steuerelements enthält und CB.CTLMSG die folgenden Werte enthält:

%BN_CLICKED

Wird gesendet, wenn der Benutzer eine Maustaste klickt oder das Steuerelement mit dem Hotkey aktiviert (es sei denn, das Steuerelement wurde deaktiviert).

%BN_DISABLE

Wird gesendet, wenn ein Steuerelement deaktiviert ist.

%BN_KILLFOCUS

Wird gesendet, wenn ein Steuerelement den Tastaturfokus verliert. Das Steuerelement muss den %BS_NOTIFY-Stil enthalten.

%BN_SETFOCUS

Wird gesendet, wenn ein Steuerelement den Tastaturfokus erhält. Das Steuerelement muss den %BS_NOTIFY-Stil enthalten.

Wenn eine Rückruffunktion eine %WM_COMMAND-Nachricht empfängt, sollte sie den Wert von CB.CTL und CB.CTLMSG explizit testen, um sicherzustellen, dass sie angemessen auf die Benachrichtigungsnachricht reagiert.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG CHECK3STATE HINZUFÜGEN
  • STEUERN SIE DIE OPTION HINZUFÜGEN
  • KONTROLLE ERHALTEN SIE ÜBERPRÜFEN
  • STEUERUNGSSATZ PRÜFEN
  • STEUERUNG FARBE EINSTELLEN
  • STEUERUNG SET SCHRIFTART

PBXB64-Umsetzungshinweise

STEUERN SIE DAS Kontrollkästchen „Hinzufügen“. gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERN SIE DAS Kontrollkästchen „Hinzufügen“. ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERN SIE DAS Kontrollkästchen „Hinzufügen“. mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL COMBOBOX HINZUFÜGEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL ADD COMBOBOX

CONTROL ADD COMBOBOX

Fügen Sie einem Dialogfeld ein Kombinationsfeld hinzu. Ein Kombinationsfeld wird häufig verwendet, um einem Benutzer die Auswahl eines Elements aus einer vordefinierten Liste oder die Eingabe eines neuen (nicht gelisteten) Elements zu ermöglichen. Ein Kombinationsfeld darf nur Textzeichenfolgen enthalten. Um Zahlen in ein Kombinationsfeld einzufügen, wandeln Sie sie in Zeichenfolgen um

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD COMBOBOX, hDlg , id& , [ items$() ], x , y , xx , yy [, [ style& ] [, [ exstyle& ]]] [[,] CALL callback ]
CONTROL ADD COMBOBOX, hDlg, id&, txt$(), 100, 100, 100, 40, , , CALL ComboCallback() ' Use default styles

Beschreibung

Wenn der Benutzer ein Element auswählt oder den Text eines Kombinationsfelds bearbeitet, wird eine Nachricht an die für das Kombinationsfeld vorgesehene Rückruffunktion gesendet. Wenn keine Rückruffunktion angegeben ist, wird die Nachricht an den Rückruf für den Dialog gesendet.

Wenn der Steuerrückruf die Benachrichtigungsnachricht verarbeitet, sollte er TRUE (ungleich Null) zurückgeben, um zu verhindern, dass die Nachricht unnötig an den Dialogrückruf und schließlich an die DDT-Engine selbst weitergeleitet wird.

Benachrichtigungsnachrichten werden an die Callback-Funktion gesendet, wobei CB.MSG = %WM_COMMAND ist, CB.CTL die ID (id&) des Steuerelements enthält und CB.CTLMSG die folgenden Werte enthält:

%CBN_CLOSEUP

Wird gesendet, wenn das Listenfeld einer Kombinationsbox geschlossen wurde.

%CBN_DBLCLK

Wird gesendet, wenn der Benutzer im Listenfeld eines Kombinationsfelds auf eine Zeichenfolge doppelklickt.

%CBN_DROPDOWN

Wird gesendet, wenn das Listenfeld eines Kombinationsfelds sichtbar gemacht werden soll.

%CBN_EDITCHANGE

Wird gesendet, nachdem der Benutzer eine Aktion ausgeführt hat, die möglicherweise den Text im Textfeldteil eines Kombinationsfelds geändert hat. Im Gegensatz zur Benachrichtigung %CBN_EDITUPDATE wird diese Benachrichtigung gesendet, nachdem Windows den Bildschirm aktualisiert.

%CBN_EDITUPDATE

Wird gesendet, wenn im Textfeldteil eines Kombinationsfelds geänderter Text angezeigt wird. Diese Benachrichtigung wird gesendet, nachdem das Steuerelement den Text formatiert hat, aber bevor es den Text anzeigt.

%CBN_ERRSPACE

Wird gesendet, wenn ein Kombinationsfeld nicht genügend Speicher zuweisen kann, um eine bestimmte Anforderung zu erfüllen.

%CBN_KILLFOCUS

Wird gesendet, wenn ein Kombinationsfeld den Tastaturfokus verliert.

%CBN_SELCHANGE

Wird gesendet, wenn die Auswahl im Listenfeld eines Kombinationsfelds geändert werden soll, weil der Benutzer entweder in das Listenfeld klickt oder die Auswahl mithilfe der Pfeiltasten ändert.

%CBN_SELCANCEL

Wird gesendet, wenn der Benutzer ein Element auswählt, dann aber ein anderes Steuerelement auswählt oder das Dialogfeld schließt. Es gibt an, dass die anfängliche Auswahl des Benutzers ignoriert werden soll.

%CBN_SELENDOK

Wird gesendet, wenn der Benutzer ein Listenelement auswählt oder ein Element auswählt und dann die Liste schließt. Es zeigt an, dass die Auswahl des Benutzers verarbeitet werden soll.

%CBN_SETFOCUS

Wird gesendet, wenn ein Kombinationsfeld den Tastaturfokus erhält.

Wenn eine Rückruffunktion eine %WM_COMMAND-Nachricht empfängt, sollte sie den Wert von CB.CTL und CB.CTLMSG explizit testen, um sicherzustellen, dass sie angemessen auf die Benachrichtigungsnachricht reagiert.

Siehe auch

  • Dynamic Dialog Tools
  • COMBOBOX
  • STEUERUNG FARBE EINSTELLEN
  • STEUERUNG SET SCHRIFTART

PBXB64-Umsetzungshinweise

CONTROL ADD COMBOBOX gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

CONTROL ADD COMBOBOX ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' CONTROL ADD COMBOBOX mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL ADD FRAME – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL ADD FRAME

STEUERUNG RAHMEN HINZUFÜGEN

Fügen Sie einem Dialog einen Rahmen hinzu. Dies wird auch als „Gruppen“-Steuerelement bezeichnet und normalerweise um Steuerelemente herum gezeichnet, um eine visuelle Verbindung zwischen solchen Steuerelementen anzuzeigen. Ein Frame-Steuerelement wird häufig um verwandte Optionssteuerelemente herum verwendet.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD FRAME, hDlg , id& , txt$ , x , y , xx , yy [, [ style& ] [, [ exstyle& ]]]
CONTROL ADD FRAME, hDlg, id&, txt$, 100, 100, 40, 14, , ' Use default styles

Beschreibung

Ein Frame-Steuerelement sendet keine Nachrichten an seinen übergeordneten Dialog und erfordert oder unterstützt kein Callback .

Siehe auch

  • Dynamic Dialog Tools
  • CONTROL GET TEXT
  • STEUERUNG FARBE EINSTELLEN
  • STEUERUNG SET SCHRIFTART
  • STEUERUNG TEXT EINSTELLEN

PBXB64-Umsetzungshinweise

STEUERUNG RAHMEN HINZUFÜGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG RAHMEN HINZUFÜGEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG RAHMEN HINZUFÜGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


STEUERUNG GRAFIK HINZUFÜGEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STEUERUNG GRAFIK HINZUFÜGEN

STEUERUNG GRAFIK HINZUFÜGEN

Fügen Sie einem Dialog ein statisches Grafiksteuerelement für Zeichnungen, Bilder, Text usw. hinzu.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD GRAPHIC, hDlg , ID , Txt$ , x , y , nWide , nHigh [, style ] [, exstyle ] [,CALL CallBack ]

Beschreibung

Ein Grafiksteuerelement wird normalerweise mit Grafikanweisungen zum Zeichnen von Diagrammen, Bildern, Text usw. verwendet. Nachdem Sie ein Grafiksteuerelement erstellt haben, verwenden Sie normalerweise GRAPHIC ATTACH, um es als Ziel nachfolgender GRAPHIC-Anweisungen auszuwählen. Wenn zum Zeitpunkt der Erstellung jedoch kein ausgewähltes Grafikziel vorhanden ist, wird das neue Grafiksteuerelement automatisch angehängt und ausgewählt.

Ein grafisches Steuerelement sendet nur dann Benachrichtigungsmeldungen an einen Rückruf, wenn der %SS_NOTIFY-Stil verwendet wird. Benachrichtigungsnachrichten werden an die Rückruffunktion gesendet, wobei CB.MSG = %WM_COMMAND ist, CB.CTL die ID ( id& ) des Steuerelements enthält und CB.CTLMSG einen der folgenden Werte enthält:

%STN_CLICKED

Wird gesendet, wenn der Benutzer mit der Maustaste auf das Grafiksteuerelement klickt (es sei denn, das Bildsteuerelement wurde deaktiviert).

%STN_DBLCLK

Wird gesendet, wenn der Benutzer auf ein Grafiksteuerelement doppelklickt (es sei denn, das Steuerelement wurde deaktiviert).

%STN_DISABLE

Wird gesendet, wenn ein Grafiksteuerelement deaktiviert wurde.

%STN_ENABLE

Wird gesendet, wenn ein Grafiksteuerelement aktiviert wurde.

Wenn eine Rückruffunktion eine %WM_COMMAND-Nachricht empfängt, sollte sie den Wert von CB.CTL und CB.CTLMSG explizit testen, um sicherzustellen, dass sie angemessen auf die Benachrichtigungsnachricht reagiert.

Alle grafischen Anzeigen von PowerBASIC sind dauerhaft – sie werden automatisch neu gezeichnet, wenn sie geändert oder vorübergehend von einem anderen Fenster verdeckt werden.

Siehe auch

  • Dynamic Dialog Tools
  • GRAFISCHE ANHÄNGE
  • GRAFISCHE FARBE
  • GRAFISCHE MAßSTAB
  • GRAFIK-SET-SCHRIFTART
  • GRAFISCHER STIL
  • GRAFISCHE BREITE
  • GRAFISCHES FENSTER

PBXB64-Umsetzungshinweise

STEUERUNG GRAFIK HINZUFÜGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG GRAFIK HINZUFÜGEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG GRAFIK HINZUFÜGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


STEUERUNG HEADER HINZUFÜGEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL ADD HEADER

STEUERUNG HEADER HINZUFÜGEN

Fügen Sie ein Header-Steuerelement zu a hinzu

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD HEADER, hDlg , ID , Txt$ , x , y , wide , high [, style ] [, exstyle ] [,CALL CallBack ]
CONTROL SET HEADER hDlg , ID , item& , Text$ [TO ResultVar&]

Beschreibung

Handle des Dialogs, in dem das Header-Steuerelement platziert wird. Der Dialog wird zum übergeordneten Element des Steuerelements.

Eine eindeutige numerische Kennung für dieses Steuerelement, die vom Programmierer angegeben wird. Es muss ein ganzzahliger Wert im Bereich von 1 bis 65535 sein. Diese ID wird aus Gründen der Klarheit des Codes normalerweise mit einem numerischen Gleichwert angegeben. Beispielsweise ist das Äquator %IDC_HEADER1 informativer als ein Literalwert wie 497. PowerBASIC empfiehlt, dass Bezeichnerwerte bei 100 beginnen sollten, um Konflikte mit den standardmäßig vordefinierten Bezeichnern zu vermeiden.

Text, der dem Header-Steuerelement zugeordnet werden soll. Ein Header-Steuerelement zeigt diesen Text nicht an, daher ist es üblich, diesen Wert auf ein leeres Null-Zeichenfolgenliteral ("" oder $NUL) festzulegen.

Integrale Ausdrücke, die die Position des Steuerelements im Dialog-Client-Bereich angeben. X ist die horizontale Position und Y ist die vertikale Position. 0,0 bezieht sich auf die obere linke Ecke des Dialogs. Koordinaten werden in denselben Begriffen (Pixel oder Dialogeinheiten) wie im übergeordneten Dialog angegeben.

breit, hoch

Integrale Ausdrücke, die die Gesamtbreite und -höhe des Kopfbereichs angeben.

Optionaler primärer Stil des Header-Steuerelements. Dieser Wert kann eine Kombination der folgenden Werte sein, kombiniert mit dem OR-Operator, um eine Bitmaske zu bilden. Wenn der Stil weggelassen wird, ist die Standardkombination %WS_CHILD ODER %WS_VISIBLE.

%WS_CHILD

Das Steuerelement ist ein untergeordnetes Fenster.

%WS_VISIBLE

Das Steuerelement ist sichtbar.

%WS_BORDER

Fügen Sie einen dünnen Linienrand um das Header-Steuerelement hinzu.

exstyle

Optionaler erweiterter Stil des Header-Steuerelements.

Rückruf

Optionaler Name einer Callback-Funktion, die alle %WM_COMMAND- und %WM_NOTIFY-Nachrichten für das Steuerelement empfängt. Sehen Sie sich die Metaanweisung #MESSAGES an, um auszuwählen, welche Nachrichten empfangen werden. Wenn kein Rückruf für das Steuerelement festgelegt ist, müssen Sie eine Dialog-Rückruffunktion erstellen, um Nachrichten von Ihrem Steuerelement zu verarbeiten.

Wenn die Callback-Funktion eine Nachricht verarbeitet, sollte sie TRUE (ungleich Null) zurückgeben, um zu verhindern, dass die Nachricht unnötigerweise an den Dialog-Callback (sofern vorhanden) übergeben wird. Der Dialogrückruf sollte auch TRUE zurückgeben, wenn die Benachrichtigungsnachricht von dieser Rückruffunktion verarbeitet wird. Andernfalls verarbeitet die DDT-Engine nicht verarbeitete Nachrichten.

PBXB64 unterstützt auch CONTROL SET HEADER für dieses Steuerelement. Es legt den Text der einsbasierten Artikelnummer fest und fügt bei Bedarf den Artikel ein. Die optionale TO-Variable erhält 1 bei Erfolg oder 0 bei Fehler.

Siehe auch

  • HEADER

PBXB64-Umsetzungshinweise

STEUERUNG HEADER HINZUFÜGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG HEADER HINZUFÜGEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG HEADER HINZUFÜGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


STEUERUNG BILD HINZUFÜGEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STEUERUNG BILD HINZUFÜGEN

STEUERUNG BILD HINZUFÜGEN

Fügen Sie einem Dialogfeld ein Bildsteuerelement (ohne Größenänderung) hinzu. Dies wird normalerweise verwendet, um eine in einem gespeicherte Bitmap oder ein Symbol anzuzeigen

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD IMAGE, hDlg , id& , image$ , x , y , xx , yy [, [ style& ] [, [ exstyle& ]]] [[,] CALL callback ]

Beschreibung

Die Größe der im Bild verwendeten Bitmap oder des Symbols wird nicht an das Steuerelement angepasst. Wenn Ihr Steuerelement 64 Dialogeinheiten breit ist und Ihr Symbol oder Ihre Bitmap nur 32, ist die Hälfte des Bildes leer. Für beste Ergebnisse sollten die Symbole 32 x 32 Pixel groß sein.

Sobald ein Bildsteuerelement erstellt wurde, können die angezeigten Bilder mit der CONTROL SET IMAGE-Anweisung geändert werden, jedoch nur, wenn die Bilder dasselbe Format wie das Original haben. Wenn beispielsweise zunächst ein Bildsteuerelement mit einer Bitmap-Datei erstellt wurde, müssen alle nachfolgenden Bildänderungen ebenfalls Bitmap-Bilder sein. Muss das Bildformat jedoch zur Laufzeit geändert werden, etwa weil Icons statt Bitmaps angezeigt werden sollen, gibt es einige Möglichkeiten. Beispielsweise könnte die Anwendung für jedes Bildformat separate Steuerelemente verwenden oder das vorhandene Steuerelement zerstören und ein neues Steuerelement mit einem Bild im entgegengesetzten Format erstellen.

Ein Bildsteuerelement sendet nur dann Benachrichtigungsmeldungen an einen Rückruf, wenn der %SS_NOTIFY-Stil verwendet wird. Benachrichtigungsnachrichten werden an die Callback-Funktion gesendet, wobei CB.MSG = %WM_COMMAND ist, CB.CTL die ID ( id& ) des Steuerelements enthält und CB.CTLMSG die folgenden Werte enthält:

%STN_CLICKED

Wird gesendet, wenn der Benutzer mit der Maustaste auf das Bildsteuerelement klickt (es sei denn, das Bildsteuerelement wurde deaktiviert).

%STN_DBLCLK

Wird gesendet, wenn der Benutzer auf ein Bildsteuerelement doppelklickt (es sei denn, das Steuerelement wurde deaktiviert).

%STN_DISABLE

Wird gesendet, wenn eine Bildsteuerung deaktiviert wurde.

%STN_ENABLE

Wird gesendet, wenn eine Bildsteuerung aktiviert wurde.

Wenn eine Rückruffunktion eine %WM_COMMAND-Nachricht empfängt, sollte sie den Wert von CB.CTL und CB.CTLMSG explizit testen, um sicherzustellen, dass sie angemessen auf die Benachrichtigungsnachricht reagiert.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG GRAFIK HINZUFÜGEN
  • STEUERUNG BILD HINZUFÜGENX
  • STEUERN SIE DIE IMGBUTTON HINZUFÜGEN
  • STEUERUNG IMGBUTTON HINZUFÜGENX
  • STEUERUNG BILD EINSTELLEN
  • STEUERUNG IMAGEX EINSTELLEN
  • STEUERUNG IMGBUTTON EINSTELLEN
  • CONTROL SET IMGBUTTONX

PBXB64-Umsetzungshinweise

STEUERUNG BILD HINZUFÜGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG BILD HINZUFÜGEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG BILD HINZUFÜGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


STEUERUNG IMAGEX HINZUFÜGEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STEUERUNG BILD HINZUFÜGENX

STEUERUNG BILD HINZUFÜGENX

Fügen Sie einem Dialogfeld ein Steuerelement für gestreckte Bilder hinzu. Dies wird normalerweise zum Anzeigen von Bitmaps und Symbolen verwendet, die automatisch gestreckt oder komprimiert werden, um den Clientbereich der Steuerelemente auszufüllen.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD IMAGEX, hDlg , id& , image$ , x , y , xx , yy [, [ style& ] [, [ exstyle& ]]] [[,] CALL callback ]

Beschreibung

Die Größe der im Bild verwendeten Bitmap oder des Symbols wird an das Steuerelement angepasst. Wenn Ihr Steuerelement 64 Dialogeinheiten breit ist und Ihr Symbol oder Ihre Bitmap nur 32, wird es gestreckt, um das gesamte Steuerelement abzudecken. Für beste Ergebnisse sollten die Symbole 32 x 32 Pixel groß sein.

Ein Bildsteuerelement sendet nur dann Benachrichtigungsmeldungen an einen Rückruf, wenn der %SS_NOTIFY-Stil verwendet wird. Benachrichtigungsnachrichten werden an die Callback-Funktion gesendet, wobei CB.MSG = %WM_COMMAND ist, CB.CTL die ID ( id& ) des Steuerelements enthält und CB.CTLMSG die folgenden Werte enthält:

%STN_CLICKED

Wird gesendet, wenn der Benutzer mit der Maustaste auf das Bildsteuerelement klickt (es sei denn, das Bildsteuerelement wurde deaktiviert).

%STN_DBLCLK

Wird gesendet, wenn der Benutzer auf ein Bildsteuerelement doppelklickt (es sei denn, das Steuerelement wurde deaktiviert).

%STN_DISABLE

Wird gesendet, wenn eine Bildsteuerung deaktiviert wurde.

%STN_ENABLE

Wird gesendet, wenn eine Bildsteuerung aktiviert wurde.

Wenn eine Rückruffunktion eine %WM_COMMAND-Nachricht empfängt, sollte sie den Wert von CB.CTL und CB.CTLMSG explizit testen, um sicherzustellen, dass sie angemessen auf die Benachrichtigungsnachricht reagiert.

Einschränkungen

Unter Windows 95/98/ME kann der Versuch, ein Symbol deutlich über 64 x 64 zu strecken, aufgrund interner Beschränkungen fehlschlagen, die zwischen den jeweiligen Windows-Versionen variieren. Bitmaps sind hiervon nicht betroffen. Windows NT/2000/XP-Systeme erlegen weder für Symbole noch für Bitmaps vergleichbare Einschränkungen auf.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG GRAFIK HINZUFÜGEN
  • STEUERUNG BILD HINZUFÜGEN
  • STEUERN SIE DIE IMGBUTTON HINZUFÜGEN
  • STEUERUNG IMGBUTTON HINZUFÜGENX
  • STEUERUNG BILD EINSTELLEN
  • STEUERUNG IMAGEX EINSTELLEN
  • STEUERUNG IMGBUTTON EINSTELLEN
  • CONTROL SET IMGBUTTONX

PBXB64-Umsetzungshinweise

STEUERUNG BILD HINZUFÜGENX gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG BILD HINZUFÜGENX ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG BILD HINZUFÜGENX mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


STEUERUNG IMGBUTTON HINZUFÜGEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STEUERUNG IMGBUTTON HINZUFÜGEN

STEUERN SIE DIE IMGBUTTON HINZUFÜGEN

Fügen Sie einem Dialog eine Bildschaltfläche hinzu. Bildschaltflächen werden häufig verwendet, um das Erscheinungsbild eines Dialogs zu verbessern.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD IMGBUTTON, hDlg , id& , image$ , x , y , xx , yy [, [ style& ] [, [ exstyle& ]]] [[,] CALL callback ]
CONTROL ADD IMGBUTTON, hDlg, id&, txt$, 100, 100, 150, 200, , , _
CALL ImgButtonCallback() ' Use default styles

Beschreibung

Die Größe der in der Schaltfläche verwendeten Bitmap oder des Symbols wird nicht an die Schaltfläche angepasst. Wenn Ihre Schaltfläche 64 Dialogeinheiten breit ist und Ihr Symbol oder Ihre Bitmap nur 32, ist die Hälfte der Schaltfläche leer. Für beste Ergebnisse sollten die Symbole 32 x 32 Pixel groß sein.

Eine Bildschaltfläche wird in einem dreidimensionalen Erscheinungsbild im Dialogfeld gezeichnet, sofern nicht der %BS_FLAT-Stil angegeben ist. Wenn der Benutzer auf die Bildschaltfläche klickt, wird eine Nachricht an die Rückruffunktion der Schaltfläche gesendet. Wenn keine Rückruffunktion angegeben ist, wird die Nachricht an den Rückruf für den Dialog gesendet.

Benachrichtigungsnachrichten werden an die Callback-Funktion gesendet, wobei CB.MSG = %WM_COMMAND ist, CB.CTL die ID ( id& ) des Steuerelements enthält und CB.CTLMSG die folgenden Werte enthält:

%BN_CLICKED

Wird gesendet, wenn der Benutzer auf eine Maustaste klickt oder die Schaltfläche mit dem Hotkey aktiviert (es sei denn, die Schaltfläche wurde deaktiviert).

%BN_DISABLE

Wird gesendet, wenn eine Schaltfläche deaktiviert ist.

%BN_KILLFOCUS

Wird gesendet, wenn eine Schaltfläche den Tastaturfokus verliert. Die Schaltfläche muss den %BS_NOTIFY-Stil enthalten.

%BN_SETFOCUS

Wird gesendet, wenn eine Schaltfläche den Tastaturfokus erhält. Die Schaltfläche muss den %BS_NOTIFY-Stil enthalten.

Wenn eine Rückruffunktion eine %WM_COMMAND-Nachricht empfängt, sollte sie den Wert von CB.CTL und CB.CTLMSG explizit testen, um sicherzustellen, dass sie angemessen auf die Benachrichtigungsnachricht reagiert.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG GRAFIK HINZUFÜGEN
  • STEUERUNG BILD HINZUFÜGEN
  • STEUERUNG BILD HINZUFÜGENX
  • STEUERUNG IMGBUTTON HINZUFÜGENX
  • STEUERUNG BILD EINSTELLEN
  • STEUERUNG IMAGEX EINSTELLEN
  • STEUERUNG IMGBUTTON EINSTELLEN
  • CONTROL SET IMGBUTTONX

PBXB64-Umsetzungshinweise

STEUERN SIE DIE IMGBUTTON HINZUFÜGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERN SIE DIE IMGBUTTON HINZUFÜGEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERN SIE DIE IMGBUTTON HINZUFÜGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL ADD IMGBUTTONX – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STEUERUNG HINZUFÜGEN IMGBUTTONX

STEUERUNG IMGBUTTON HINZUFÜGENX

Fügen Sie einem Dialog eine Schaltfläche für ein gestrecktes Bild hinzu. Gestreckte Bildschaltflächen werden oft verwendet, um das Erscheinungsbild eines Dialogs zu verbessern, wobei das Bild automatisch gestreckt oder gestaucht wird, um das Steuerelement auszufüllen.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD IMGBUTTONX, hDlg , id& , image$ , x , y , xx , yy [, [ style& ] [, [ exstyle& ]]] [[,] CALL callback ]
CONTROL ADD IMGBUTTONX, hDlg, id&, txt$, 100, 100, 150, 200, , , _
CALL ImgButtonxCallback() ' Use default styles

Beschreibung

Die Größe der in der Schaltfläche verwendeten Bitmap oder des Symbols wird an die Schaltfläche angepasst. Wenn Ihre Schaltfläche 64 Dialogeinheiten breit ist und Ihr Symbol oder Ihre Bitmap nur 32, wird es gestreckt, um die gesamte Schaltfläche abzudecken. Für beste Ergebnisse sollten die Symbole 32 x 32 Pixel groß sein.

Die Bildschaltfläche wird im Dialogfeld dreidimensional gezeichnet, sofern nicht der Stil %BS_FLAT angegeben ist. Wenn der Benutzer auf eine Schaltfläche klickt, wird eine Nachricht an die für die Schaltfläche vorgesehene Rückruffunktion gesendet. Wenn keine Rückruffunktion angegeben ist, wird die Nachricht an den Rückruf für den Dialog gesendet.

Benachrichtigungsnachrichten werden an die Callback-Funktion gesendet, wobei CB.MSG = %WM_COMMAND ist, CB.CTL die ID ( id& ) des Steuerelements enthält und CB.CTLMSG die folgenden Werte enthält:

%BN_CLICKED

Wird gesendet, wenn der Benutzer auf eine Maustaste klickt oder die Schaltfläche mit dem Hotkey aktiviert (es sei denn, die Schaltfläche wurde deaktiviert).

%BN_DISABLE

Wird gesendet, wenn eine Schaltfläche deaktiviert ist.

%BN_KILLFOCUS

Wird gesendet, wenn eine Schaltfläche den Tastaturfokus verliert. Die Schaltfläche muss den %BS_NOTIFY-Stil enthalten.

%BN_SETFOCUS

Wird gesendet, wenn eine Schaltfläche den Tastaturfokus erhält. Die Schaltfläche muss den %BS_NOTIFY-Stil enthalten.

Wenn eine Rückruffunktion eine %WM_COMMAND-Nachricht empfängt, sollte sie den Wert von CB.CTL und CB.CTLMSG explizit testen, um sicherzustellen, dass sie angemessen auf die Benachrichtigungsnachricht reagiert.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG GRAFIK HINZUFÜGEN
  • STEUERUNG BILD HINZUFÜGEN
  • STEUERUNG BILD HINZUFÜGENX
  • STEUERN SIE DIE IMGBUTTON HINZUFÜGEN
  • STEUERUNG BILD EINSTELLEN
  • STEUERUNG IMAGEX EINSTELLEN
  • STEUERUNG IMGBUTTON EINSTELLEN
  • CONTROL SET IMGBUTTONX

PBXB64-Umsetzungshinweise

STEUERUNG IMGBUTTON HINZUFÜGENX gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG IMGBUTTON HINZUFÜGENX ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG IMGBUTTON HINZUFÜGENX mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL ADD LABEL – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STEUERUNG ETIKETT HINZUFÜGEN

STEUERUNG ETIKETT HINZUFÜGEN

Fügen Sie einem Dialog eine Textbeschriftung hinzu. Eine Textbeschriftung ähnelt einem herkömmlichen statischen Steuerelement.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD LABEL, hDlg , id& , txt$ , x , y , xx , yy [, [ style& ] [, [ exstyle& ]]] [[,] CALL callback ]
CONTROL ADD LABEL, hDlg, id&, txt$, 100, 100, 150, 200, , , _
CALL LabelCallback() ' Use default styles

Beschreibung

Wenn das kaufmännische Und-Zeichen (&) im txt$-Parameter vorkommt, wird der folgende Buchstabe unterstrichen angezeigt. Dadurch wird ein Steuerungsbeschleuniger (Hotkey) hinzugefügt, der es dem Benutzer ermöglicht, direkt auf das Steuerelement zu „klicken“, das in der Tab-Reihenfolge unmittelbar nach dem Label-Steuerelement folgt, indem er einfach die ALT-Taste gedrückt hält, während er den angegebenen Hotkey drückt. Beispielsweise macht „&Sicherheitsstufe auswählen“ ALT+S zum Hotkey.

Ein Label-Steuerelement sendet nur dann Nachrichten an einen Rückruf, wenn der %SS_NOTIFY-Stil verwendet wird. Die folgenden Benachrichtigungen werden an die Callback-Funktion gesendet:

%STN_CLICKED

Wird gesendet, wenn der Benutzer auf eine Maustaste klickt oder die Schaltfläche mit dem Hotkey aktiviert (es sei denn, die Schaltfläche wurde deaktiviert).

%STN_DBLCLK

Wird gesendet, wenn der Benutzer auf ein Label-Steuerelement doppelklickt (es sei denn, das Steuerelement wurde deaktiviert).

%STN_DISABLE

Wird gesendet, wenn eine Schaltfläche deaktiviert ist.

%STN_ENABLE

Wird gesendet, wenn ein Label-Steuerelement aktiviert wurde.

Verwenden Sie die CONTROL SET TEXT-Anweisung, um den Text in einem Etikettensteuerelement zu ändern, und CONTROL SET FONT, um die in einem Etikettensteuerelement verwendete Schriftart zu ändern. Dies ist nur möglich, wenn das Label einen eindeutigen ID-Wert hat (d. h. id& sollte nicht -1 sein).

Wenn eine Rückruffunktion eine %WM_COMMAND-Nachricht empfängt, sollte sie den Wert von CB.CTL und CB.CTLMSG explizit testen, um sicherzustellen, dass sie angemessen auf die Benachrichtigungsnachricht reagiert.

Siehe auch

  • Dynamic Dialog Tools
  • CONTROL GET TEXT
  • STEUERUNG FARBE EINSTELLEN
  • STEUERUNG SET SCHRIFTART
  • STEUERUNG TEXT EINSTELLEN

PBXB64-Umsetzungshinweise

STEUERUNG ETIKETT HINZUFÜGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG ETIKETT HINZUFÜGEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG ETIKETT HINZUFÜGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL ADD LINE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL ADD LINE

STEUERUNG ZEILE HINZUFÜGEN

Fügen Sie einem Dialog ein Zeilensteuerelement hinzu. Ein Liniensteuerelement kann auch ein Rechteck (leer oder gefüllt) sein.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD LINE, hDlg, id&, txt$, x, y, xx, yy [, [style&] [, [exstyle&]]] [[,] CALL callback]
CONTROL ADD LINE, hDlg, id&, "", 100, 100, 150, 1, , , CALL LineCallback() ' Use default styles

Beschreibung

Wenn das kaufmännische Und-Zeichen (&) im txt$-Parameter vorkommt, wird der folgende Buchstabe unterstrichen angezeigt. Dadurch wird ein Steuerungsbeschleuniger (Hotkey) hinzugefügt, der es dem Benutzer ermöglicht, direkt auf das Steuerelement zu „klicken“, das in der Tab-Reihenfolge unmittelbar nach dem Zeilensteuerelement folgt, indem er einfach die ALT-Taste gedrückt hält, während er den angegebenen Hotkey drückt. Beispielsweise macht „&Test Suite“ ALT+T zum Hotkey.

Ein Zeilensteuerelement sendet nur dann Nachrichten an einen Rückruf, wenn der %SS_NOTIFY-Stil verwendet wird. Die folgenden Benachrichtigungen werden an die Callback-Funktion gesendet:

%STN_CLICKED

Wird gesendet, wenn der Benutzer auf ein Zeilensteuerelement klickt (es sei denn, das Steuerelement wurde deaktiviert).

%STN_DBLCLK

Wird gesendet, wenn der Benutzer auf ein Zeilensteuerelement doppelklickt (es sei denn, das Steuerelement wurde deaktiviert).

%STN_DISABLE

Wird gesendet, wenn eine Leitungssteuerung deaktiviert wurde.

%STN_ENABLE

Wird gesendet, wenn eine Leitungssteuerung aktiviert wurde.

Wenn eine Rückruffunktion eine %WM_COMMAND-Nachricht empfängt, sollte sie den Wert von CB.CTL und CB.CTLMSG explizit testen, um sicherzustellen, dass sie angemessen auf die Benachrichtigungsnachricht reagiert.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERGRIFF
  • STEUERUNG SENDEN

PBXB64-Umsetzungshinweise

STEUERUNG ZEILE HINZUFÜGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG ZEILE HINZUFÜGEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG ZEILE HINZUFÜGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL ADD LISTBOX – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL ADD LISTBOX

STEUERUNG LISTBOX HINZUFÜGEN

Fügen Sie einem Dialogfeld ein Listenfeld-Steuerelement hinzu. Ein Listenfeld enthält eine Reihe vordefinierter Einträge, die es einem Benutzer ermöglichen, ein oder mehrere Elemente auszuwählen. Ein Listenfeld kann Zeichenfolgen enthalten

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD LISTBOX, hDlg , id& , [ items$() ], x , y , xx , yy [, [ style& ] [, [ exstyle& ]]] [[,] CALL callback ]
CONTROL ADD LISTBOX, hDlg, id&, items$(), 100, 100, 150, 200, , , _
CALL ListboxCallback() ' Use default styles

Beschreibung

Die folgenden Benachrichtigungen werden an die Callback-Funktion gesendet:

%LBN_DBLCLK

Wird gesendet, wenn der Benutzer im Listenteil eines Listenfelds auf eine Zeichenfolge doppelklickt.

%LBN_ERRSPACE

Wird gesendet, wenn ein Listenfeld nicht genügend Speicher zuweisen kann, um eine bestimmte Anforderung zu erfüllen.

%LBN_KILLFOCUS

Wird gesendet, wenn ein Listenfeld den Tastaturfokus verliert.

%LBN_SELCANCEL

Wird gesendet, wenn der Benutzer ein Element auswählt, dann aber ein anderes Steuerelement auswählt oder das Dialogfeld schließt. Es gibt an, dass die anfängliche Auswahl des Benutzers ignoriert werden soll.

%LBN_SELCHANGE

Wird gesendet, wenn die Auswahl im Listenfeld geändert werden soll, weil der Benutzer entweder in das Listenfeld klickt oder die Auswahl mithilfe der Pfeiltasten ändert.

%LBN_SETFOCUS

Wird gesendet, wenn ein Listenfeld den Tastaturfokus erhält.

Wenn eine Rückruffunktion eine %WM_COMMAND-Nachricht empfängt, sollte sie den Wert von CB.CTL und CB.CTLMSG explizit testen, um sicherzustellen, dass sie angemessen auf die Benachrichtigungsnachricht reagiert.

Einschränkungen

Unter Windows 95/98/ME ist ein Listenfeld auf 32.736 Elemente beschränkt. In allen Windows-Versionen sind die im Listenfeld enthaltenen tatsächlichen Zeichenfolgendaten nur durch den verfügbaren Speicher begrenzt.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG FARBE EINSTELLEN
  • STEUERUNG SET SCHRIFTART
  • LISTBOX

PBXB64-Umsetzungshinweise

STEUERUNG LISTBOX HINZUFÜGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG LISTBOX HINZUFÜGEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG LISTBOX HINZUFÜGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL ADD LISTVIEW – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL ADD LISTVIEW

STEUERUNG LISTVIEW HINZUFÜGEN

Fügen Sie ein hinzu

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD LISTVIEW, hDlg , id& , txt$ , x , y , xx , yy [, [ style& ] [, [ exstyle& ]]] [[,] CALL callback ]
CONTROL ADD LISTVIEW, hDlg, id&, "", 100, 100, 150, 200, , , CALL LVCallback()

Beschreibung

Wenn eine Rückruffunktion eine %WM_COMMAND-Nachricht empfängt, sollte sie den Wert von CB.CTL und CB.CTLMSG explizit testen, um sicherzustellen, dass sie angemessen auf die Benachrichtigungsnachrichten reagiert.

PBXB64-Implementierungshinweise

PBXB64 V14 bildet diese DDT-Form auf die native Win32-Common-Control-Klasse SysListView32 ab. Die registrierten V14-Tests erzeugen mit diesem Befehl ein LISTVIEW, haengen eine ImageList an, fuegen ein Element ein, lesen die Elementanzahl, setzen/lesen STYLEXX und setzen/loeschen ein Overlay-Bild. Weitere LISTVIEW-Unterbefehle sind auf der LISTVIEW-Seite dokumentiert und bleiben dort separat eingegrenzt.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG FARBE EINSTELLEN
  • STEUERUNG SET SCHRIFTART
  • HEADER
  • Listenansicht

PBXB64-Umsetzungshinweise

STEUERUNG LISTVIEW HINZUFÜGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG LISTVIEW HINZUFÜGEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG LISTVIEW HINZUFÜGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL ADD OPTION – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL ADD OPTION

STEUERN SIE DIE OPTION HINZUFÜGEN

Fügen Sie einem Dialogfeld eine Optionsschaltfläche hinzu. Eine Optionsschaltfläche ist genau wie ein herkömmliches „Radio-Button“-Steuerelement.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD OPTION, hDlg , id& , txt$ , x , y , xx , yy [, [ style& ] [, [ exstyle& ]]] [[,] CALL callback ]
CONTROL ADD OPTION, hDlg, id&, txt$, 100, 100, 150, 200, , , _
CALL OptionButtonCallback() ' Use default styles

Beschreibung

Optionsschaltflächen werden zum Anzeigen einer Liste von Auswahlmöglichkeiten verwendet, von denen nur eine ausgewählt werden kann. Es macht also keinen Sinn, nur eine einzige Optionsschaltfläche zu haben. Wenn Sie das Aktivieren oder Deaktivieren eines einzelnen Elements zulassen möchten, verwenden Sie stattdessen ein Kontrollkästchen.

Wenn eine Gruppe von Optionsschaltflächen erstellt wird, sollten Sie den „ausgewählten“ und „nicht ausgewählten“ Status aller Optionsschaltflächen explizit festlegen, indem Sie die CONTROL SET OPTION-Anweisung verwenden, um den Prüfstatus aller Schaltflächen in der Gruppe festzulegen.

Darüber hinaus sollte das erste OPTION-Steuerelement in einer Gruppe den Stil %WS_GROUP (um den Anfang einer Gruppe von Schaltflächen zu markieren) und %WS_TABSTOP haben. Die übrigen OPTION-Steuerelemente in der Gruppe sollten nicht die Stile %WS_GROUP oder %WS_TABSTOP haben. Allerdings sollte das allernächste Nicht-OPTION-Steuerelement, das in der Tab-Reihenfolge nach der Gruppe erscheint, die Stile %WS_GROUP und %WS_TABSTOP erhalten (letzterer kann von der Art des Steuerelements abhängen). Wenn nach der Gruppe keine weiteren Steuerelemente vorhanden sind, fügen Sie %WS_GROUP zum ersten Steuerelement im Dialogfeld hinzu. Dadurch wird sichergestellt, dass die Tastaturnavigation mit den Pfeiltasten innerhalb der Gruppe der OPTION-Steuerelemente funktioniert und dass die TAB- und UMSCHALT+TAB-Tasten den Fokus zwischen ganzen Steuerelementgruppen wechseln (anstelle einzelner Steuerelemente, wie es üblich ist, wenn jedes Gruppenmitglied den Stil %WS_TABSTOP hat).

Wenn das kaufmännische Und-Zeichen (&) im txt$-Parameter vorkommt, wird der folgende Buchstabe unterstrichen angezeigt. Dadurch wird ein Steuerbeschleuniger (Hotkey) hinzugefügt, der es dem Benutzer ermöglicht, das Optionssteuerelement direkt auszuwählen, indem er einfach die ALT-Taste gedrückt hält, während er den angegebenen Hotkey drückt. Beispielsweise macht „Ebene &3“ ALT+3 zum Hotkey.

Wenn der Benutzer auf eine Optionsschaltfläche klickt, wird eine Nachricht an die für das Steuerelement vorgesehene Rückruffunktion gesendet. Wenn keine Rückruffunktion angegeben ist, wird die Nachricht an den Rückruf für den Dialog gesendet.

Die folgenden Benachrichtigungen werden an die Callback-Funktion gesendet:

%BN_CLICKED

Wird gesendet, wenn der Benutzer auf eine Maustaste klickt oder die Schaltfläche mit dem Hotkey aktiviert (es sei denn, die Schaltfläche wurde deaktiviert).

%BN_KILLFOCUS

Wird gesendet, wenn die Optionsschaltfläche den Tastaturfokus verliert, sofern die Schaltfläche den %BS_NOTIFY-Stil hat.

%BN_SETFOCUS

Wird gesendet, wenn die Optionsschaltfläche den Tastaturfokus erhält, vorausgesetzt, die Optionsschaltfläche hat den Stil %BS_NOTIFY.

Wenn eine Rückruffunktion eine %WM_COMMAND-Nachricht empfängt, sollte sie den Wert von CB.CTL und CB.CTLMSG explizit testen, um sicherzustellen, dass sie angemessen auf die Benachrichtigungsnachricht reagiert.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG CHECK3STATE HINZUFÜGEN
  • STEUERN SIE DAS Kontrollkästchen „Hinzufügen“.
  • KONTROLLE ERHALTEN SIE ÜBERPRÜFEN
  • STEUERUNG FARBE EINSTELLEN
  • STEUERUNG SET SCHRIFTART
  • STEUERUNGSSET-OPTION

PBXB64-Umsetzungshinweise

STEUERN SIE DIE OPTION HINZUFÜGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERN SIE DIE OPTION HINZUFÜGEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERN SIE DIE OPTION HINZUFÜGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


STEUERUNG FORTSCHRITTSBAR HINZUFÜGEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL ADD PROGRESSBAR

STEUERUNG FORTSCHRITTSBAR HINZUFÜGEN

Fügen Sie ein ProgressBar-Steuerelement zu a hinzu

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD PROGRESSBAR, hDlg , id& , txt$ , x , y , xx , yy [, [ style& ] [, [ exstyle& ]]] [[,] CALL callback ]
CONTROL ADD PROGRESSBAR, hDlg, id&, "",90,90,90,20, , , CALL PBCallback()

Beschreibung

Wenn eine Rückruffunktion eine %WM_COMMAND-Nachricht empfängt, sollte sie den Wert von CB.CTL und CB.CTLMSG explizit testen, um sicherzustellen, dass sie angemessen auf die Benachrichtigungsnachrichten reagiert.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG FARBE EINSTELLEN
  • FORTSCHRITTSBAR

UI-Prüfung

Dialog- und Control-Seiten sollen das Control erzeugen, den dokumentierten Befehl anwenden und den geänderten Zustand über Getter, Notification oder sichtbares Ergebnis prüfen. Prüfen Sie Handle-Gültigkeit, bevor Nachrichten gesendet werden.

Nachrichten- und Lebensdauerregeln

Dokumentieren Sie Besitzerfenster, Control-ID, Lebensdauer von Child-Handles und ob der Befehl vor oder nach dem Anzeigen des Dialogs gültig ist.

x64-Hinweise

Verwenden Sie zeigergroße Handles und speichern Sie HWND, HDC oder Callback-Zeiger nicht in 32-Bit-Variablen.

PBXB64-Umsetzungshinweise

STEUERUNG FORTSCHRITTSBAR HINZUFÜGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG FORTSCHRITTSBAR HINZUFÜGEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG FORTSCHRITTSBAR HINZUFÜGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


STEUERUNG SCROLLBAR HINZUFÜGEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STEUERUNG HINZUFÜGEN SCROLLBAR

STEUERUNG SCROLLBAR HINZUFÜGEN

Fügen Sie ein hinzu

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD SCROLLBAR, hDlg , id& , txt$ , x , y , xx , yy [, [ style& ] [, [ exstyle& ]]] [[,] CALL callback ]
CONTROL ADD SCROLLBAR, hDlg, id&, txt$, 100, 100, 150, 14, , , _
CALL Scrollbar1Callback() ' Use default styles

Beschreibung

Wenn das kaufmännische Und-Zeichen (&) im txt$-Parameter erscheint, wird der folgende Buchstabe zu einem Steuerbeschleuniger (Hotkey), damit der Benutzer die Bildlaufleistensteuerung direkt auswählen kann, indem er einfach die ALT-Taste gedrückt hält, während er den angegebenen Hotkey drückt. Beispielsweise macht „&9“ ALT+9 zum Hotkey. Der tatsächliche Text in txt$ wird in einem Bildlaufleisten-Steuerelement nicht angezeigt.

Wenn der Benutzer auf eine Bildlaufleiste klickt, den Daumen zieht (auch Bildlauffeld genannt) oder über die Tastatur ein Bildlaufereignis auslöst, wird eine Nachricht an die für das Steuerelement vorgesehene Rückruffunktion gesendet. Wenn keine Rückruffunktion angegeben ist, wird die Nachricht an den Rückruf für den Dialog gesendet.

Die folgenden Benachrichtigungen werden an die Callback-Funktion gesendet:

%WM_HSCROLL

Wird gesendet, wenn der Benutzer eine horizontale Bildlaufleiste anpasst.

%WM_VSCROLL

Wird gesendet, wenn der Benutzer eine vertikale Bildlaufleiste anpasst.

Wenn eine Rückruffunktion eine %WM_HSCROLL- oder %WM_VSCROLL-Nachricht empfängt, sollte sie die Einstellungen der Bildlaufleistensteuerung über die GetScrollInfo-API und SCROLLBAR SET POS-Funktionsaufrufe abrufen und festlegen. Stellen Sie sicher, dass Sie bei diesen API-Funktionen das Flag %SB_CTL und nicht die Flags %SB_HORZ oder %SB_VERT verwenden.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERGRIFF
  • STEUERUNG SENDEN
  • STEUERUNG FARBE EINSTELLEN
  • SCROLLBAR

PBXB64-Umsetzungshinweise

STEUERUNG SCROLLBAR HINZUFÜGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG SCROLLBAR HINZUFÜGEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG SCROLLBAR HINZUFÜGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL ADD STATUSBAR – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL ADD STATUSBAR

STEUERUNG STATUSBAR HINZUFÜGEN

Fügen Sie ein StatusBar-Steuerelement zu einem hinzu

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD STATUSBAR, hDlg , id& , txt$ , x , y , xx , yy [, [ style& ] [, [ exstyle& ]]] [[,] CALL callback ]
CONTROL ADD STATUSBAR, hDlg, id&, "", 5, 5, 5, 5, , , CALL SBCallback()

Beschreibung

Wenn eine Rückruffunktion eine %WM_COMMAND-Nachricht empfängt, sollte sie den Wert von CB.CTL und CB.CTLMSG explizit testen, um sicherzustellen, dass sie angemessen auf die Benachrichtigungsnachrichten reagiert.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG SET SCHRIFTART
  • STATUSBAR

UI-Prüfung

Dialog- und Control-Seiten sollen das Control erzeugen, den dokumentierten Befehl anwenden und den geänderten Zustand über Getter, Notification oder sichtbares Ergebnis prüfen. Prüfen Sie Handle-Gültigkeit, bevor Nachrichten gesendet werden.

Nachrichten- und Lebensdauerregeln

Dokumentieren Sie Besitzerfenster, Control-ID, Lebensdauer von Child-Handles und ob der Befehl vor oder nach dem Anzeigen des Dialogs gültig ist.

x64-Hinweise

Verwenden Sie zeigergroße Handles und speichern Sie HWND, HDC oder Callback-Zeiger nicht in 32-Bit-Variablen.

PBXB64-Umsetzungshinweise

STEUERUNG STATUSBAR HINZUFÜGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG STATUSBAR HINZUFÜGEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG STATUSBAR HINZUFÜGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


REGISTERKARTE „STEUERUNG HINZUFÜGEN“ – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › REGISTERKARTE „STEUERUNG HINZUFÜGEN“.
Hilfe zum PBXB64-Compiler

STEUERUNG REGISTERKARTE HINZUFÜGEN

Fügen Sie ein Tab-Steuerelement zu einem hinzu

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD TAB, hDlg , id& , txt$ , x , y , xx , yy [, [ style& ] [, [ exstyle& ]]] [[,] CALL callback ]
CONTROL ADD TAB, hDlg, id&, "",90,90,200,90, , , CALL PBCallback()

Beschreibung

Wenn eine Rückruffunktion eine %WM_COMMAND-Nachricht empfängt, sollte sie den Wert von CB.CTL und CB.CTLMSG explizit testen, um sicherzustellen, dass sie angemessen auf die Benachrichtigungsnachrichten reagiert.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG SET SCHRIFTART
  • TAB

UI-Prüfung

Dialog- und Control-Seiten sollen das Control erzeugen, den dokumentierten Befehl anwenden und den geänderten Zustand über Getter, Notification oder sichtbares Ergebnis prüfen. Prüfen Sie Handle-Gültigkeit, bevor Nachrichten gesendet werden.

Nachrichten- und Lebensdauerregeln

Dokumentieren Sie Besitzerfenster, Control-ID, Lebensdauer von Child-Handles und ob der Befehl vor oder nach dem Anzeigen des Dialogs gültig ist.

x64-Hinweise

Verwenden Sie zeigergroße Handles und speichern Sie HWND, HDC oder Callback-Zeiger nicht in 32-Bit-Variablen.

PBXB64-Umsetzungshinweise

STEUERUNG REGISTERKARTE HINZUFÜGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG REGISTERKARTE HINZUFÜGEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG REGISTERKARTE HINZUFÜGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL TEXTBOX HINZUFÜGEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STEUERUNG TEXTBOX HINZUFÜGEN

STEUERUNG TEXTFELD HINZUFÜGEN

Fügen Sie einem Dialogfeld ein Textfeld-Steuerelement hinzu. Ein Textfeld ist einem herkömmlichen Bearbeitungssteuerelement sehr ähnlich und wird zum Eingeben von Text in eine Anwendung verwendet. Textfelder unterstützen die einzeilige und mehrzeilige Eingabe.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD TEXTBOX, hDlg , id& , txt$ , x , y , xx , yy [, [ style& ] [, [ exstyle& ]]] [[,] CALL callback ]
CONTROL ADD TEXTBOX, hDlg, id&, txt$, 100, 100, 150, 200, , , _
CALL EditControlCallback() ' Use default styles

Beschreibung

Wenn Sie den %ES_AUTOHSCROLL-Stil angeben, scrollt das Steuerelement automatisch horizontal, wenn die Einfügemarke über den rechten Rand des Steuerelements hinausgeht. Um eine neue Zeile zu beginnen, muss der Benutzer die ENTER-Taste drücken.

Wenn Sie %ES_AUTOHSCROLL nicht angeben, setzt das Steuerelement bei Bedarf automatisch Wörter an den Anfang der nächsten Zeile. Eine neue Zeile wird auch begonnen, wenn der Benutzer die ENTER-Taste drückt. Die Kontrollgröße bestimmt die Position des Zeilenumbruchs.

Die folgenden Benachrichtigungen werden an die Callback-Funktion gesendet:

%EN_CHANGE

Wird gesendet, wenn der Benutzer eine Aktion ausgeführt hat, die möglicherweise den Text im Textfeld geändert hat. Im Gegensatz zur %EN_UPDATE-Benachrichtigung wird diese Nachricht gesendet, nachdem Windows den Bildschirm aktualisiert. Auch das programmgesteuerte Ändern des Textes in einem Steuerelement löst diese Meldung aus.

%EN_ERRSPACE

Wird gesendet, wenn das Textfeld nicht genügend Speicher zuweisen kann, um eine bestimmte Anforderung zu erfüllen.

%EN_HSCROLL

Wird gesendet, wenn der Benutzer auf die horizontale Bildlaufleiste eines mehrzeiligen Textfelds klickt. Der Rückruf wird benachrichtigt, bevor der Bildschirm aktualisiert wird.

%EN_KILLFOCUS

Wird gesendet, wenn ein Bearbeitungssteuerelement den Tastaturfokus verliert.

%EN_MAXTEXT

Wird gesendet, wenn die aktuelle Texteinfügung die angegebene Anzahl von Zeichen für das Textfeld überschritten hat. Die Texteinfügung wird abgeschnitten.

%EN_SETFOCUS

Wird gesendet, wenn ein Bearbeitungssteuerelement den Tastaturfokus erhält.

%EN_UPDATE

Wird gesendet, wenn in einem Textfeld geänderter Text angezeigt wird. Diese Benachrichtigung wird gesendet, nachdem das Steuerelement den Text formatiert hat, aber bevor es den Text anzeigt. Siehe auch %EN_CHANGE.

%EN_VSCROLL

Wird gesendet, wenn der Benutzer auf die vertikale Bildlaufleiste eines Textfelds klickt. Der Rückruf wird benachrichtigt, bevor der Bildschirm aktualisiert wird.

Wenn eine Rückruffunktion eine %WM_COMMAND-Nachricht empfängt, sollte sie den Wert von CB.CTL und CB.CTLMSG explizit testen, um sicherzustellen, dass sie angemessen auf die Benachrichtigungsnachricht reagiert.

Verwenden Sie CONTROL GET TEXT, um den Text aus einem Textfeld-Steuerelement abzurufen, und verwenden Sie CONTROL SET TEXT, um den Text in einem Textfeld-Steuerelement zu ändern. Wenn Sie den Text in einem Textfeld-Steuerelement ändern (als Reaktion auf eine %EN_CHANGE- oder %EN_UPDATE-Nachricht), wird ein zweiter Satz von %EN_CHANGE- und %EN_UPDATE-Nachrichten ausgelöst. Sofern dies nicht kompensiert wird, können diese Benachrichtigungen unbeabsichtigt eine Endlosschleife verursachen.

PBXB64 unterstützt PASSWORD FIELD für Textfeld-Steuerelemente. Die Anweisung wendet EM_SETPASSWORDCHAR auf das Bearbeitungssteuerelement an und verwendet dabei standardmäßig ein Sternchen oder ein explizites numerisches Maskenzeichen, sofern angegeben.

Folgendes kann beispielsweise tödlich sein:

CALLBACK-FUNCTION EditControlCallback()

IF CB.CTL = %ID_EDITBOX1 UND CB.CTLMSG = %EN_CHANGE THEN

CONTROL SET TEXT CB.HNDL, CB.CTL, „Neuer Text“

EXIT-FUNCTION

END IF

[Anweisungn]

Da es sich bei CONTROL SET TEXT um eine „blockierende“ Anweisung handelt (d. h. die Anweisung wird erst abgeschlossen, wenn der Text geändert wurde), ist es einfach, den Endlosschleifeneffekt zu blockieren:

CALLBACK-FUNCTION EditControlCallback()

STATIC EditBusy&

IF CB.CTL = %ID_EDITBOX1 UND CB.CTLMSG = %EN_CHANGE THEN

IF EditBusy&THEN FUNCTION BEENDEN

EditBusy& = -1

CONTROL SET TEXT CB.HNDL, CB.CTL, „Neuer Text“

ZURÜCKSETZEN BearbeitenBeschäftigt&

EXIT-FUNCTION

END IF

[Anweisungn]

Siehe auch

  • Dynamic Dialog Tools
  • CONTROL GET TEXT
  • STEUERUNG FARBE EINSTELLEN
  • STEUERUNG SET SCHRIFTART
  • STEUERUNG TEXT EINSTELLEN

PBXB64-Umsetzungshinweise

STEUERUNG TEXTFELD HINZUFÜGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG TEXTFELD HINZUFÜGEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG TEXTFELD HINZUFÜGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


STEUERUNG SYMBOLLEISTE HINZUFÜGEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STEUERUNG HINZUFÜGEN TOOLBAR

STEUERUNG SYMBOLLEISTE HINZUFÜGEN

Fügen Sie ein ToolBar-Steuerelement zu einem hinzu

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD TOOLBAR, hDlg , ID , Txt$ , x , y , nWide , nHigh [, style ] [, exstyle& ] [,CALL callback ]
CONTROL ADD TOOLBAR, hDlg, id&, "", 1, 1, 1, 1, , , CALL TBCallback()

Beschreibung

Wenn eine Rückruffunktion eine Nachricht empfängt, sollte sie den Wert von CB.CTL und CB.CTLMSG explizit testen, um sicherzustellen, dass sie angemessen auf die Benachrichtigungsnachrichten reagiert.

Siehe auch

  • DIALOGMODAL ANZEIGEN
  • DIALOG ZEIGEN MODELLLOS
  • Dynamic Dialog Tools
  • STEUERUNG SET SCHRIFTART
  • Symbolleiste

PBXB64-Umsetzungshinweise

STEUERUNG SYMBOLLEISTE HINZUFÜGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG SYMBOLLEISTE HINZUFÜGEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG SYMBOLLEISTE HINZUFÜGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


STEUERUNG TREEVIEW HINZUFÜGEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STEUERUNG HINZUFÜGEN BAUMANSICHT

STEUERUNG TREEVIEW HINZUFÜGEN

Fügen Sie ein TreeView-Steuerelement zu einem hinzu

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD TREEVIEW, hDlg , id& , txt$ , x , y , xx , yy [, [ style& ] [, [ exstyle& ]]] [[,] CALL callback ]
CONTROL ADD TREEVIEW, hDlg, id&, "", 100, 100, 150, 200, , , CALL TVCallback()

Beschreibung

Wenn eine Rückruffunktion eine %WM_COMMAND-Nachricht empfängt, sollte sie den Wert von CB.CTL und CB.CTLMSG explizit testen, um sicherzustellen, dass sie angemessen auf die Nachrichten reagiert.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG FARBE EINSTELLEN
  • STEUERUNG SET SCHRIFTART
  • Baumansicht

PBXB64-Umsetzungshinweise

STEUERUNG TREEVIEW HINZUFÜGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG TREEVIEW HINZUFÜGEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG TREEVIEW HINZUFÜGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


STEUERUNG DEAKTIVIEREN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STEUERUNG SPERREN

STEUERUNG DEAKTIVIEREN

Deaktivieren Sie ein Steuerelement, damit es keine Steuerelemente mehr erhält

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL DISABLE hDlg , id&

Beschreibung

hDlg bezieht sich auf den Dialog, der das Steuerelement besitzt. id& ist die eindeutige Steuerelement-ID, die dem Steuerelement mit einer CONTROL ADD-Anweisung zugewiesen wird.

Ein deaktiviertes Steuerelement erhält keine Meldungen, wenn es mit der Maus angeklickt oder mit der Tastatur ausgewählt wird. Die meisten, aber nicht alle Steuerelemente werden bei Deaktivierung neu als „grau“ dargestellt.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG AKTIVIEREN
  • KONTROLLKILL

PBXB64-Umsetzungshinweise

STEUERUNG DEAKTIVIEREN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG DEAKTIVIEREN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG DEAKTIVIEREN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL ENABLE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STEUERUNGSFREIGABE

STEUERUNG AKTIVIEREN

Aktivieren Sie ein Steuerelement, damit es Nachrichten empfangen kann, wenn der Benutzer mit der Maus oder der Tastatur damit interagiert.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ENABLE hDlg , id&

Beschreibung

hDlg bezieht sich auf den Dialog, der das Steuerelement besitzt. id& ist die eindeutige Steuerelement-ID, die dem Steuerelement mit einer CONT ROL ADD-Anweisung zugewiesen wird.

Ein aktiviertes Steuerelement empfängt Nachrichten, wenn es mit der Maus angeklickt oder mit der Tastatur ausgewählt wird.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG DEAKTIVIEREN
  • KONTROLLKILL

PBXB64-Umsetzungshinweise

STEUERUNG AKTIVIEREN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG AKTIVIEREN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG AKTIVIEREN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL GET CHECK – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL GET CHECK

KONTROLLE ERHALTEN SIE ÜBERPRÜFEN

Holen Sie sich das

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL GET CHECK hDlg , id& TO lResult&

Beschreibung

hDlg bezieht sich auf den Dialog, der das Steuerelement besitzt.

id& ist die eindeutige Steuerelement-ID, die dem Steuerelement mit einer CONTRO L ADD-Anweisung zugewiesen wird.

lResult& erhält den Prüfstatus des Steuerelements wie folgt:

lErgebnis&

Überprüfen Sie den Kontrollstatus

0 (Null)

Die Schaltfläche ist deaktiviert (nicht gesetzt oder gelöscht).

1 (Eins)

Schaltfläche ist aktiviert (gesetzt)

2 (Zwei)

Schaltfläche ist unbestimmt (ausgegraut) (nur CHECK3STATE)

Beachten Sie, dass ein ausgegrautes (unbestimmtes) CHECK3STATE-Steuerelement nicht bedeutet, dass das Steuerelement deaktiviert ist. Vielmehr ist der Prüfstatus des Steuerelements sowohl aktiviert als auch deaktiviert.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG CHECK3STATE HINZUFÜGEN
  • STEUERN SIE DAS Kontrollkästchen „Hinzufügen“.
  • STEUERN SIE DIE OPTION HINZUFÜGEN
  • STEUERUNGSSATZ PRÜFEN
  • STEUERUNGSSET-OPTION
  • TREEVIEW GET CHECK
  • TREEVIEW SET PRÜFEN

PBXB64-Umsetzungshinweise

KONTROLLE ERHALTEN SIE ÜBERPRÜFEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

KONTROLLE ERHALTEN SIE ÜBERPRÜFEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' KONTROLLE ERHALTEN SIE ÜBERPRÜFEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL GET CLIENT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL GET CLIENT

KONTROLLE KUNDEN ERHALTEN

Geben Sie die zurück

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL GET CLIENT hDlg , id& TO w& , h&

Beschreibung

hDlg bezieht sich auf den Dialog, der das Steuerelement besitzt.

id& ist die eindeutige Steuerelement-ID, die dem Steuerelement mit einer CONT ROL ADD-Anweisung zugewiesen wird.

Die Größe des Control-Client-Bereichs wird in den Variablen w& (Breite) und h& (Höhe) platziert. Die Größe wird in denselben Begriffen (Pixel oder Dialogeinheiten) wie der übergeordnete Dialog angegeben.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG ERHALTEN LOC
  • KONTROLLE ERHALTEN SIE GRÖSSE
  • CONTROL SET-CLIENT
  • CONTROL SET-CLIENT
  • STEUERUNG SET LOC
  • CONTROL SET-GRÖSSE
  • DIALOGEINHEITEN
  • DIALOGPIXEL
  • GRAFIK GET CLIENT

PBXB64-Umsetzungshinweise

KONTROLLE KUNDEN ERHALTEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

KONTROLLE KUNDEN ERHALTEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' KONTROLLE KUNDEN ERHALTEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL GET LOC – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL GET LOC

STEUERUNG ERHALTEN LOC

Rufen Sie den Speicherort des angegebenen Steuerelements in einem Dialogfeld ab.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL GET LOC hDlg , id& TO x& , y&

Beschreibung

hDlg bezieht sich auf den Dialog, der das Steuerelement besitzt.

id& ist die eindeutige Steuerelement-ID, die dem Steuerelement mit einer CONTROL ADD-Anweisung zugewiesen wird.

Die Position der oberen linken Ecke des Steuerelements wird in den Variablen x& (horizontale Position) und y& (vertikale Position) platziert. Die Position ist relativ zur oberen linken Ecke des Clientbereichs im übergeordneten Dialogfeld. Die Koordinaten werden in denselben Begriffen (Pixel oder Dialogeinheiten) wie der übergeordnete Dialog angegeben.

Siehe auch

  • Dynamic Dialog Tools
  • KONTROLLE KUNDEN ERHALTEN
  • KONTROLLE ERHALTEN SIE GRÖSSE
  • STEUERUNG SET LOC
  • CONTROL SET-GRÖSSE

PBXB64-Umsetzungshinweise

STEUERUNG ERHALTEN LOC gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG ERHALTEN LOC ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG ERHALTEN LOC mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL GET SIZE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL GET SIZE

KONTROLLE ERHALTEN SIE GRÖSSE

Ruft die Größe eines Steuerelements im angegebenen Bereich ab

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL GET SIZE hDlg , id& TO nWide& , nHigh&

Beschreibung

hDlg bezieht sich auf den Dialog, der das Steuerelement besitzt.

id& ist die eindeutige Steuerelement-ID, die dem Steuerelement mit einer CONTROL ADD-Anweisung zugewiesen wird.

Die Breite wird in den Variablen nWide& und die Höhe in den Variablen nHigh& platziert. Die Koordinaten werden in denselben Begriffen (Pixel oder Dialogeinheiten) wie der übergeordnete Dialog angegeben.

Siehe auch

  • Dynamic Dialog Tools
  • KONTROLLE KUNDEN ERHALTEN
  • STEUERUNG ERHALTEN LOC
  • STEUERUNG SET LOC
  • CONTROL SET-GRÖSSE

PBXB64-Umsetzungshinweise

KONTROLLE ERHALTEN SIE GRÖSSE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

KONTROLLE ERHALTEN SIE GRÖSSE ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' KONTROLLE ERHALTEN SIE GRÖSSE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL GET TEXT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL GET TEXT

CONTROL GET TEXT

Holen Sie sich den Text von einem Steuerelement.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL GET TEXT hDlg , id& TO txt$

Beschreibung

hDlg bezieht sich auf den Dialog, der das Steuerelement besitzt.

id& ist die eindeutige Steuerelement-ID, die dem Steuerelement mit einer CONTROL ADD-Anweisung zugewiesen wird. Jeder Text im Steuerelement wird in die Variable txt$ eingefügt.

Bei Kombinationsfeldern gibt CONTROL GET TEXT den im Bearbeitungsteil des Steuerelements eingegebenen Text zurück. Um den ausgewählten Text aus dem Listenteil eines Kombinationsfelds oder eines Listenfeld-Steuerelements abzurufen, verwenden Sie die COMBOBOX GET TEXT-Anweisung bzw. die LISTBOX GET TEXT-Anweisung.

Siehe auch

  • Dynamic Dialog Tools
  • COMBOBOX TEXT ERHALTEN
  • STEUERUNG TEXT EINSTELLEN
  • LISTBOX GET TEXT
  • LISTVIEW GET TEXT
  • TREEVIEW GET TEXT

PBXB64-Umsetzungshinweise

CONTROL GET TEXT gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

CONTROL GET TEXT ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' CONTROL GET TEXT mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL GET USER – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL GET USER

KONTROLLE GET BENUTZER

Rufen Sie einen Wert aus dem Benutzerdatenbereich von a ab

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL GET USER hDlg , id& , index& TO retvar&

Beschreibung

Jedes DDT-Steuerelement verfügt über einen Benutzerdatenbereich, der aus acht Long-Integer-Werten besteht, die nach Ermessen des Programmierers zum Speichern relevanter Daten verwendet werden können. CONTROL GET USER ermöglicht das Abrufen eines der Werte basierend auf dem Indexparameterwert (1 bis 8).

hDlg bezieht sich auf den Dialog, der das Steuerelement besitzt.

id& ist die eindeutige Steuerelement-ID, die dem Steuerelement mit einer CONTROL ADD-Anweisung zugewiesen wird.

index& ist die Indexnummer des abzurufenden Benutzerdatenwerts im Bereich von 1 bis einschließlich 8.

retvar& empfängt den Long-Integer-Datenwertspeicher im angegebenen Benutzerdatenindex.

Einschränkungen

Bei der Zerstörung der Steuerung gehen Daten im Nutzdatenbereich verloren. Der Datenbereich ist vollständig vom von Windows verwalteten %GWL_USERDATA-Bereich getrennt.

Siehe auch

  • Dynamic Dialog Tools
  • COMBOBOX BENUTZER ERHALTEN
  • COMBOBOX SET BENUTZER
  • STEUERUNG BENUTZER EINSTELLEN
  • DIALOG BENUTZER ERHALTEN
  • DIALOG SET BENUTZER
  • LISTBOX BENUTZER ERHALTEN
  • LISTBOX SET BENUTZER
  • LISTVIEW GET USER
  • LISTVIEW SET BENUTZER
  • TREEVIEW GET USER
  • TREEVIEW SET BENUTZER

PBXB64-Umsetzungshinweise

KONTROLLE GET BENUTZER gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

KONTROLLE GET BENUTZER ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' KONTROLLE GET BENUTZER mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


STEUERGRIFF – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STEUERGRIFF

STEUERGRIFF

Ein Fenster zurückgeben

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL HANDLE hDlg , id& TO hCtl&

Beschreibung

hDlg bezieht sich auf den Dialog, der das Steuerelement besitzt. id& ist die eindeutige Steuerelement-ID, die dem Steuerelement mit einer CONTROL ADD-Anweisung zugewiesen wird.

Der zurückgegebene Wert ist ein Fensterhandle für das Steuerelement, das von Windows bei der ersten Erstellung des Steuerelements zugewiesen wurde und das Steuerelement eindeutig von allen anderen Steuerelementen identifiziert. Einige API-Funktionen erfordern einen Fensterhandle-Wert anstelle eines Steuerelement-ID-Werts.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG SENDEN
  • FENSTER GET ID
  • FENSTER GET PARENT

PBXB64-Umsetzungshinweise

STEUERGRIFF gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERGRIFF ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERGRIFF mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL HIDE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL HIDE

STEUERUNG AUSblenden

Machen Sie eine Kontrolle

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL HIDE HDlg , ID&

Beschreibung

Das durch die HDlg/ID&-Kombination identifizierte Control wird unsichtbar gemacht.

HDlg ist das Handle des Dialogs, der das Steuerelement besitzt. ID& ist die eindeutige Kontrollkennung, die der Kontrolle mit CONTROL ADD zugewiesen wird.

Siehe auch

  • STEUERUNG NORMALISIEREN
  • CONTROL SET-GRÖSSE
  • DIALOG AUSblenden
  • DIALOG NORMALISIEREN

UI-Prüfung

Dialog- und Control-Seiten sollen das Control erzeugen, den dokumentierten Befehl anwenden und den geänderten Zustand über Getter, Notification oder sichtbares Ergebnis prüfen. Prüfen Sie Handle-Gültigkeit, bevor Nachrichten gesendet werden.

Nachrichten- und Lebensdauerregeln

Dokumentieren Sie Besitzerfenster, Control-ID, Lebensdauer von Child-Handles und ob der Befehl vor oder nach dem Anzeigen des Dialogs gültig ist.

x64-Hinweise

Verwenden Sie zeigergroße Handles und speichern Sie HWND, HDC oder Callback-Zeiger nicht in 32-Bit-Variablen.

PBXB64-Umsetzungshinweise

STEUERUNG AUSblenden gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG AUSblenden ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG AUSblenden mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL KILL – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL KILL

KONTROLLKILL

Entfernen Sie ein Steuerelement aus einem Dialogfeld.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL KILL hDlg , id&

Beschreibung

hDlg bezieht sich auf den Dialog, der das Steuerelement besitzt. id& ist die eindeutige Steuerelement-ID, die dem Steuerelement mit einer CONTROL ADD-Anweisung zugewiesen wird.

Das Steuerelement wird zerstört und aus dem Dialog entfernt. Die Rückruffunktion für das Steuerelement oder den Dialog empfängt keine Nachrichten mehr für das Steuerelement.

Einschränkungen

Ein Steuerelement sollte nicht zerstört werden, während eine Benachrichtigungsnachricht desselben Steuerelements verarbeitet wird. Es ist jedoch zulässig, ein anderes Steuerelement im Benachrichtigungshandler zu beenden. Wenn es unbedingt erforderlich ist, ein Steuerelement während der Verarbeitung einer seiner Benachrichtigungsnachrichten zu beenden, verwenden Sie die PostMessage-API-Funktion (oder die Anweisungen DIALOG POST oder CONTROL POST), um eine benutzerdefinierte Nachricht an den Dialogrückruf zu senden, und beenden Sie das Steuerelement, wenn die benutzerdefinierte Nachricht verarbeitet wird.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG DEAKTIVIEREN
  • STEUERUNG AKTIVIEREN

PBXB64-Umsetzungshinweise

KONTROLLKILL gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

KONTROLLKILL ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' KONTROLLKILL mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


STEUERUNG NORMALISIEREN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STEUERUNG NORMALISIEREN

STEUERUNG NORMALISIEREN

Machen Sie eine Kontrolle

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL NORMALIZE HDlg , ID&

Beschreibung

Die durch die HDlg/ID&-Kombination identifizierte Steuerung wird sichtbar gemacht.

HDlg ist das Handle des Dialogs, der das Steuerelement besitzt. ID& ist die eindeutige Kontrollkennung, die der Kontrolle mit CONTROL ADD zugewiesen wird.

Siehe auch

  • STEUERUNG AUSblenden
  • CONTROL SET-GRÖSSE
  • DIALOG AUSblenden
  • DIALOG NORMALISIEREN

UI-Prüfung

Dialog- und Control-Seiten sollen das Control erzeugen, den dokumentierten Befehl anwenden und den geänderten Zustand über Getter, Notification oder sichtbares Ergebnis prüfen. Prüfen Sie Handle-Gültigkeit, bevor Nachrichten gesendet werden.

Nachrichten- und Lebensdauerregeln

Dokumentieren Sie Besitzerfenster, Control-ID, Lebensdauer von Child-Handles und ob der Befehl vor oder nach dem Anzeigen des Dialogs gültig ist.

x64-Hinweise

Verwenden Sie zeigergroße Handles und speichern Sie HWND, HDC oder Callback-Zeiger nicht in 32-Bit-Variablen.

PBXB64-Umsetzungshinweise

STEUERUNG NORMALISIEREN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG NORMALISIEREN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG NORMALISIEREN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL POST – PBXB64-Compiler-Hilfe

Startseite › Funktionen › KONTROLLPOST

Kontrollposten

Platzieren Sie a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL POST hDlg , id& , Msg& , wParam& , lParam&

Beschreibung

CONTROL POST stellt die Nachricht in die Nachrichtenwarteschlange und kehrt sofort zurück. Die Nachricht wird von der Steuerung zu einem späteren Zeitpunkt verarbeitet, wenn sie die Nachricht aus der Warteschlange liest.

Dieses Verhalten unterscheidet sich deutlich von der CONTROL SEND-Anweisung, die das Steuerelement dazu zwingt, die Nachricht unmittelbar vor der Rückgabe zu verarbeiten. Da es sich bei CONTROL POST um einen asynchronen Vorgang handelt, ist es nicht möglich, einen Rückkehrcode aus der Nachricht abzurufen.

hDlg bezieht sich auf den Dialog, der das Steuerelement besitzt.

id& ist die eindeutige Steuerelement-ID, die dem Steuerelement mit einer CONTROL ADD-Anweisung zugewiesen wird.

Msg& ist die Nachricht, die Sie an das Steuerelement senden möchten.

wParam& ist der erste Nachrichtenparameter. lParam& ist der zweite Nachrichtenparameter. Die Werte von wParam& und lParam& sind nachrichtenabhängig. Standardmäßig übergibt PowerBASIC diese Parameter BYVAL. Wenn erwartet wird, dass das Zielsteuerelement die Werte der in den Parametern wParam& und lParam& übergebenen Variablen ändert, übergeben Sie diese mit VARPTR(), da die Änderungen sonst wahrscheinlich verworfen werden.

Beachten Sie, dass die Adresse der Daten gültig bleiben muss, bis das Steuerelement die Nachricht verarbeitet und auf die Daten zugegriffen hat. In diesem Fall kann die Verwendung von STATIC- oder GLOBAL-Variablen sehr wichtig sein, da sonst eine allgemeine Schutzverletzung (GPF) auftreten kann (d. h. wenn die Variablen zum Zeitpunkt der Verarbeitung der Nachricht den Gültigkeitsbereich verlassen haben).

Ein Beispiel für die Übermittlung der Adressen von Variablen an ein Steuerelement:

' Rufen Sie eine Bearbeitungssteuerung der aktuellen Auswahl ab

' Sel1& und Sel2& müssen STATIC oder GLOBAL sein

CONTROL POST CB.HNDL, %ID_EDIT6, %EM_GETSEL, VARPTR(Sel1&), VARPTR(Sel2&)

CONTROL POST kehrt sofort zurück, nachdem die Nachricht in die Warteschlange gestellt wurde.

Einschränkungen

Um eine benutzerdefinierte Nachricht an ein Steuerelement zu senden, verwenden Sie einen Nachrichtenwert im Bereich von (%WM_USER + 500) bis (%WM_USER + &H07FFF) oder verwenden Sie die RegisterWindowMessage-API, um einen eindeutigen Nachrichtenwert vom Betriebssystem abzurufen. Die Verwendung von Nachrichten mit einem numerischen Wert kleiner als %WM_USER + 500 kann zu Konflikten mit Windows Common Control-Meldungen führen.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERGRIFF
  • STEUERUNG SENDEN
  • DIALOGPOST
  • DIALOG SENDEN

PBXB64-Umsetzungshinweise

Kontrollposten gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

Kontrollposten ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' Kontrollposten mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL REDRAW – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STEUERUNG NEUZEICHNEN

STEUERN SIE NEUZEICHNEN

Planen Sie die Neuzeichnung eines bestimmten Steuerelements.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL REDRAW hDlg , id&

Beschreibung

CONTROL REDRAW macht das Zielsteuerelement ungültig und plant das Eintreten eines Neuzeichnungsereignisses.

hDlg bezieht sich auf den Dialog, der das Steuerelement besitzt.

id& ist die eindeutige Steuerelement-ID, die dem Steuerelement mit einer CONTROL ADD-Anweisung zugewiesen wird.

Einschränkungen

Das Neuzeichnen einzelner Steuerelemente wird als Ereignis mit niedriger Priorität betrachtet und ein Neuzeichnen des Steuerelements erfolgt möglicherweise nicht sofort, wenn in der Nachrichtenwarteschlange ausstehende Nachrichten vorhanden sind. Das heißt, ausstehende Nachrichten in der Nachrichtenwarteschlange müssen möglicherweise verarbeitet werden, bevor das geplante Neuzeichnungsereignis eintritt.

Es wird nicht empfohlen, CONTROL REDRAW oder DIALOG REDRAW innerhalb des %WM_PAINT und des zugehörigen Nachrichtenverarbeitungscodes zu verwenden, da sonst eine unendliche Neuzeichnungsschleife auftreten könnte.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG FARBE EINSTELLEN
  • DIALOG FARBE EINSTELLEN
  • DIALOG NEU ZEICHNEN

PBXB64-Umsetzungshinweise

STEUERN SIE NEUZEICHNEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERN SIE NEUZEICHNEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERN SIE NEUZEICHNEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL SEND – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL SEND

STEUERUNG SENDEN

Senden Sie eine

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL SEND hDlg , id& , Msg& , wParam& , lParam& [TO lResult& ]

Beschreibung

hDlg bezieht sich auf den Dialog, der das Steuerelement besitzt.

id& ist die eindeutige Steuerelement-ID, die dem Steuerelement mit einer CONTROL ADD-Anweisung zugewiesen wird.

Msg& ist die Nachricht, die Sie der Steuerung senden möchten.

wParam& ist der erste Nachrichtenparameter. lParam& ist der zweite Nachrichtenparameter. Die Werte von wParam& und lParam& sind nachrichtenabhängig. Standardmäßig übergibt PowerBASIC diese Parameter BYVAL. Wenn erwartet wird, dass das Zielsteuerelement die in den Parametern wParam& und lParam& übergebenen Werte zurückgibt oder ändert, übergeben Sie sie mit VARPTR, andernfalls werden die Rückgabewerte verworfen. Zum Beispiel:

' Rufen Sie die aktuelle Auswahl eines Bearbeitungssteuerelements ab

CONTROL SEND CB.HNDL, %ID_EDIT1, %EM_GETSEL, VARPTR(Sel1&), VARPTR(Sel2&)

CONTROL SEND kehrt erst von der Ausführung zurück, wenn der Rückruf des Steuerelements die Nachricht verarbeitet hat. Dieses synchrone Verhalten unterscheidet sich erheblich vom Verhalten von CONTROL POST , bei dem die Nachricht einfach in die Nachrichtenwarteschlange des Steuerelements gestellt wird (zur Verarbeitung zu einem späteren Zeitpunkt) und sofort zurückgegeben wird. Auf dieser Basis kann CONTROL SEND einen Rückgabewert aus der Nachricht erhalten, CONTROL POST jedoch nicht.

Der Rückgabewert der Nachricht kann optional lResult & zugewiesen werden.

Wenn CONTROL SEND eine Nachricht sendet, die im selben Rückruf zurückkommt, in dem die Nachricht ihren Ursprung hatte, sollte darauf geachtet werden, dass kritische STATIC- und GLOBAL-Variablen nicht unerwartet durch den zweiten Nachrichtenverarbeitungscode im Rückruf geändert werden. Dies wird als reentrant Code Design bezeichnet.

Einschränkungen

Um eine benutzerdefinierte Nachricht an einen Dialog zu senden, verwenden Sie einen Nachrichtenwert im Bereich von (%WM_USER + 500) bis (%WM_USER + &H07FFF) oder verwenden Sie die RegisterWindowMessage-API, um einen eindeutigen Nachrichtenwert vom Betriebssystem zu erhalten. Die Verwendung von Nachrichten mit einem numerischen Wert kleiner als %WM_USER + 500 kann zu Konflikten mit Windows Common Control-Meldungen führen.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERGRIFF
  • Kontrollposten
  • DIALOGPOST
  • DIALOG SENDEN

PBXB64-Umsetzungshinweise

STEUERUNG SENDEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG SENDEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG SENDEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL SET CHECK – PBXB64 Compiler-Hilfe

Startseite › Funktionen › CONTROL SET CHECK

STEUERUNGSSATZ PRÜFEN

Legen Sie den Prüfstatus für a fest

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL SET CHECK hDlg , id& , checkstate&

Beschreibung

Bei einem Kontrollkästchen-Steuerelement wird der Prüfstatus festgelegt (aktiviert), wenn im Kontrollkästchen ein „X“-Symbol angezeigt wird. Der Prüfstatus gilt als nicht gesetzt (nicht markiert oder gelöscht), wenn das Kontrollkästchen leer ist.

Ein CHECK3STATE-Steuerelement unterstützt einen dritten Zustand, der als unbestimmt bezeichnet wird. In diesem Zustand ist das Kontrollkästchen ausgegraut.

hDlg bezieht sich auf den Dialog, der das Steuerelement besitzt.

id& ist die eindeutige Steuerelementkennung, die dem Schaltflächensteuerelement mit einer CONTROL ADD-Anweisung zugewiesen wird.

Setzen Sie für CHECKBOX-Steuerelemente checkstate& auf Null (0), um den Prüfstatus des Steuerelements zu deaktivieren (deaktivieren oder löschen), oder auf eins (1), um den Prüfstatus des Steuerelements zu überprüfen (einzustellen).

Setzen Sie für CHECK3STATE-Steuerelemente checkstate& auf Null (0), um den Prüfstatus des Steuerelements zu deaktivieren (deaktivieren oder löschen), auf eins (1), um den Prüfstatus zu aktivieren (einzustellen) (Anzeige eines „X“-Symbols im Feld), oder auf zwei (2), um den unbestimmten Status festzulegen (Anzeige eines ausgegrauten Kontrollkästchens).

Um den Prüfstatus von OPTION-Steuerelementen festzulegen, verwenden Sie die CONTROL SET OPTION-Anweisung.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG CHECK3STATE HINZUFÜGEN
  • STEUERN SIE DAS Kontrollkästchen „Hinzufügen“.
  • STEUERN SIE DIE OPTION HINZUFÜGEN
  • KONTROLLE ERHALTEN SIE ÜBERPRÜFEN
  • STEUERUNGSSET-OPTION
  • TREEVIEW GET CHECK
  • TREEVIEW SET PRÜFEN

PBXB64-Umsetzungshinweise

STEUERUNGSSATZ PRÜFEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNGSSATZ PRÜFEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNGSSATZ PRÜFEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL SET CLIENT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL SET CLIENT

CONTROL SET-CLIENT

Ändern Sie die Größe eines Steuerelements auf eine bestimmte Größe

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL SET CLIENT hDlg , id& , nWide& , nHigh&

Beschreibung

Abhängig von der Art der verwendeten Rahmen kann die Clientgröße kleiner als die Gesamtgröße sein. Der Clientbereich ist der Teil innerhalb der Grenzen eines Steuerelements, der je nach Stil und Exstyle bei der Erstellung variiert. Bei einem Steuerelement ohne Rahmen sind die Clientgröße und die Gesamtgröße gleich. Ein alternatives Beispiel: Bei einem Steuerelement mit dem %WS_BORDER-Stil ist der Clientbereich normalerweise einige Pixel kleiner als die Gesamtgröße.

Handle des Dialogs, der das Steuerelement besitzt.

Der eindeutige Steuerelementbezeichner, der dem Steuerelement mit der CONTROL ADD-Anweisung zugewiesen wird.

nWide& , nHigh&

Integrale Ausdrücke, Variablen oder numerische Literalwerte, die die gewünschte Größe des Clientbereichs angeben. Breite und Höhe werden in Pixeln oder Dialogeinheiten angegeben, je nachdem, welches System beim Erstellen des übergeordneten Dialogs verwendet wurde.

Grafische Steuerelemente

Ab dieser Version von PowerBASIC kann die Größe von GRAFIKSTEUERN mit CONTROL SET CLIENT, GRAPHIC SET CLIENT, CONTROL SET SIZE und GRAPHIC SET SIZE geändert werden.

Wenn Sie die Größe eines Grafiksteuerelements ändern, wird die ursprüngliche Bitmap Pixel für Pixel in das neu verkleinerte Steuerelement kopiert. Jeder erweiterte Bereich wird mit der aktuellen Hintergrundfarbe gefüllt. Ihr Programm greift auf normale Weise darauf zurück, um eine Bitmap in der neuen Größe zu erstellen.

Wenn ein Clip-Bereich zum Erstellen von Rändern eingerichtet wurde, wird dieser zurückgesetzt. Wenn skalierte Koordinaten festgelegt wurden, werden diese ebenfalls zurückgesetzt, da keine der beiden für die geänderte Größe angemessen wäre. Sie können diese Attribute mit GRAPHIC SCALE oder GRAPHIC SET CLIP wieder aktivieren, basierend auf der neuen Größe des Zeichenbereichs.

Siehe auch

  • Dynamic Dialog Tools
  • KONTROLLE KUNDEN ERHALTEN
  • STEUERUNG ERHALTEN LOC
  • KONTROLLE ERHALTEN SIE GRÖSSE
  • STEUERUNG SET LOC
  • CONTROL SET-GRÖSSE
  • GRAFIK-SET-CLIENT
  • GRAFIK-SET-GRÖSSE

PBXB64-Umsetzungshinweise

CONTROL SET-CLIENT gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

CONTROL SET-CLIENT ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' CONTROL SET-CLIENT mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL SET COLOR – PBXB64 Compiler-Hilfe

Startseite › Funktionen › CONTROL SET COLOR

STEUERUNG FARBE EINSTELLEN

Stellen Sie die ein

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL SET COLOR hDlg , id& , foreclr& , backclr&

Beschreibung

hDlg identifiziert den übergeordneten Dialog des Steuerelements und id& ist die eindeutige Steuerelement-ID, die dem Steuerelement mit einer CONTROL ADD-Anweisung zugewiesen wird.

Die Farbwerte von foreclr& und backclr& müssen im Bereich von &H0 bis &H00FFFFFF liegen. RGB kann eine nützliche Funktion sein, um einen 32-Bit-Farbwert aus diskreten Rot-, Grün- und Blauwerten abzuleiten:

forcr&

Der Vordergrundfarbparameter foreclr& wird verwendet, um die Farbe des im Steuerelement angezeigten Textes festzulegen. Wenn foreclr& = -1&, wird die Standardfarbe für den Vordergrundtext verwendet.

backclr&

Der Parameter backclr& gibt die Farbe des Hintergrunds hinter dem Text im Steuerelement an. Wenn backclr& = -1&, wird die Standardhintergrundtextfarbe verwendet. Wenn backclr& = -2&, wird der Texthintergrund nicht gezeichnet, sodass der Hintergrund „durch“ den Text hindurchscheinen kann. Der nicht sichtbare Hintergrundstil kann bei einigen Steuerelementen zu unerwünschten Nebenwirkungen führen. Beispielsweise wird bei einem FRAME-Steuerelement der Beschriftungstext über einem ununterbrochenen Rahmen überlagert angezeigt.

Im Farbtiefenmodus mit 16 Bit oder mehr wird die angegebene RGB-Farbe verwendet, wenn der Hintergrund des Steuerelements gezeichnet wird. Im 8-Bit-Modus (256 Farben) funktioniert das Farbsystem jedoch ganz anders. Hinter den Kulissen in Windows enthält die Basissystempalette normalerweise 20 Volltonfarben, die beim Zeichnen auf dem Hintergrund der Steuerelemente nicht gedithert werden. Diese Volltonfarben eignen sich ideal zur Steuerung von Hintergrundfarben mit DDT-Dialogen im 256-Farben-Modus.

Wenn umgekehrt ein nicht fester RGB-Farbwert verwendet wird, schwankt Windows (annähernd), um die Farbe zu zeichnen, um das Steuerelement zu zeichnen, indem es Kombinationen aus zwei oder mehr Farben verwendet. Dies führt meist zu einem unerwünschten Mustereffekt.

Um diese Probleme im 256-Farben-Modus zu vermeiden, sollten Steuerelemente mit einer der 20 Standard-Systemfarben (durchgehend) eingefärbt werden oder stattdessen die Standardfarbe verwendet werden. PowerBASIC enthält die folgenden 10 integrierten Funktionen, die bei der Auswahl einer Standard-Volltonfarbe helfen:

%RGB_BLACK %RGB_BLUE %RGB_GREEN %RGB_CYAN %RGB_RED

%RGB_MAGENTA %RGB_YELLOW %RGB_WHITE %RGB_GRAY %RGB_LIGHTGRAY

Viele nicht standardmäßige Farben sind ebenfalls in den Compiler integriert. Eine vollständige Liste finden Sie im Thema „Integrierte RGB-Farbgleichungen“.

Wenn Sie die Farbe im 256-Farben-Modus lieber deaktivieren möchten, können Sie die Anzahl der Farben einfach mit dem folgenden Code testen:

' Anzahl der Farben bestimmen

LOKALES HDC ALS DWORD, iColors SO LANG

hDC = GetWindowDC(GetDeskTopWindow())

iColors = 2& ^ (GetDeviceCaps(hDC, %BITSPIXEL) * GetDeviceCaps(hDC, %PLANES))

ReleaseDC GetDeskTopWindow(), hDC

IF iColors > 256 THEN _

CONTROL SET COLOR hdlg, idctl&, -1, RGB(0,255,100)

Im 256-Farben-Modus auf den meisten Computern können die Werte der standardmäßigen 20 Systemfarben ermittelt werden, indem die ersten und letzten 10 (0 bis 9 und 246 bis 255 einschließlich) Einträge von der GetSystemPaletteEntries-API-Funktion wie folgt angefordert werden:

' Array mit Volltonfarben füllen

DIM hDC ALS DWORD, Spalten SO LANG, x SO LANG

hDC = GetWindowDC(GetDesktopWindow)

Cols = GetDeviceCaps(hDC, %NUMRESERVED)

REDIM lp(1 TO Cols) SO LONG

x& = GetSystemPaletteEntries(hDC, 0, Cols \ 2, BYVAL VARPTR(lp(1)))

x& = GetSystemPaletteEntries(hDC, 256 - x&, Cols - x&, BYVAL VARPTR(lp(x& + 1)))

ReleaseDC GetDesktopWindow, hDC

' Array lp() enthält jetzt die Volltontabelle

Weitere Informationen zum Arbeiten mit Paletten im 256-Farben-Modus finden Sie in WIN32.HLP oder unter http://msdn.microsoft.com.

Einschränkungen

Windows lässt nicht zu, dass die Farbe von Standard-Drucktastensteuerelementen, Zeilensteuerelementen, Bildsteuerelementen, Bildschaltflächen und den meisten gebräuchlichen Steuerelementen durch die standardmäßigen CONTROL SET COLOR-Techniken geändert wird.

Um eine farbige Schaltfläche oder einen farbigen Bereich in einem Dialog zu erstellen, besteht die bevorzugte Lösung darin, ein IMGBUTTON/IMAGEBUTTONX- oder IMAGE/IMAGEX-Steuerelement mit einer entsprechend farbigen Bitmap zu verwenden. Einige gängige Steuerelemente bieten spezielle Möglichkeiten zum Festlegen ihrer Farbe. Beispielsweise kann die Hintergrundfarbe eines Listenansicht-Steuerelements mit der Meldung %LVM_SETBKCOLOR festgelegt werden.

Beim dynamischen Ändern der Farben eines Steuerelements innerhalb eines Rückrufs (d. h. nach der DIALOG SHOW-Anweisung) sollte auf eine CONTROL SET COLOR-Anweisung unmittelbar eine explizite CONTROL REDRAW-Anweisung folgen.

Ohne diese erzwungene Neuzeichnung des Steuerelements wird die Änderung der Hintergrundfarbe des Steuerelements für den Benutzer möglicherweise erst sichtbar, wenn das Steuerelement schließlich im normalen Verlauf der Benutzerinteraktion neu gezeichnet wird. Ein normales Repaint kann beispielsweise nur erfolgen, wenn das Steuerelement verdeckt und dann von einem anderen Fenster freigelegt wird. Durch die rechtzeitige Neulackierung des Steuerelements wird sichergestellt, dass das Steuerelement jederzeit ein aktuelles Erscheinungsbild behält.

Beim gleichzeitigen Aktualisieren der Farben mehrerer Steuerelemente ist ein DIALOG REDRAW normalerweise effizienter als mehrere CONTROL REDRAW-Anweisungen.

Siehe auch

  • Built In RGB Color Equates
  • Dynamic Dialog Tools
  • KONTROLLE KUNDEN ERHALTEN
  • KONTROLLE ERHALTEN SIE GRÖSSE
  • STEUERN SIE NEUZEICHNEN
  • STEUERUNG SET SCHRIFTART
  • DIALOG NEU ZEICHNEN
  • DIALOG FARBE EINSTELLEN

PBXB64-Umsetzungshinweise

STEUERUNG FARBE EINSTELLEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG FARBE EINSTELLEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG FARBE EINSTELLEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL SET FOCUS – PBXB64 Compiler-Hilfe

Startseite › Funktionen › STEUERUNG FOKUS SETZEN

STEUERUNG FOKUS SETZEN

Legen Sie den Tastaturfokus auf das angegebene Steuerelement fest.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL SET FOCUS hDlg , id&

Beschreibung

hDlg bezieht sich auf den Dialog, der das Steuerelement besitzt.

id& ist die eindeutige Steuerelement-ID, die dem Steuerelement mit einer CONTROL ADD-Anweisung zugewiesen wird.

Das Steuerelement, das den Fokus besitzt, empfängt alle Tastaturmeldungen. Viele Steuerelemente ändern ihr Aussehen, wenn sie den Tastaturfokus erhalten (und verlieren), normalerweise durch die Anzeige eines „Fokusrechtecks“ um oder auf dem Steuerelement, das den Tastaturfokus hat. Es kann jeweils nur ein Steuerelement den Tastaturfokus haben, und es können Situationen auftreten, in denen kein Steuerelement den Fokus hat.

Steuerelemente, die einen „Benachrichtigungs“-Stil enthalten (z. B. %BS_NOTIFY), erhalten eine Benachrichtigungsmeldung, wenn der Fokus gewonnen oder verloren wird. Das heißt, wenn ein solches Steuerelement den Fokus verliert, erhält es eine entsprechende Nachricht, und das Steuerelement, das den Fokus erlangt, erhält möglicherweise auch eine entsprechende Fokusbenachrichtigungsnachricht.

Wenn ein Steuerelement den Fokus erhält, wird das übergeordnete Dialogfeld auch als Vordergrundfenster festgelegt.

Windows garantiert nicht die Reihenfolge, in der Fokusbenachrichtigungsmeldungen an das Steuerelement gesendet werden, das den Fokus verliert, und an das Steuerelement, das den Fokus erhält. Anwendungen sollten sich nicht auf die Reihenfolge verlassen, in der diese Arten von Nachrichten empfangen werden.

Einschränkungen

CONTROL SET FOCUS kann nicht verwendet werden, um den Fokus eines Steuerelements in einem separaten Thread festzulegen.

Siehe auch

  • Dynamic Dialog Tools

PBXB64-Umsetzungshinweise

STEUERUNG FOKUS SETZEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG FOKUS SETZEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG FOKUS SETZEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL SET FONT – PBXB64 Compiler-Hilfe

Startseite › Funktionen › CONTROL SET FONT

STEUERUNG SET SCHRIFTART

Wählen Sie eine Schriftart aus, die für ein bestimmtes Windows-Steuerelement verwendet werden soll.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL SET FONT hDlg , id& , FontHndl&

Beschreibung

Die durch FontHndl& angegebene Schriftart wird für die Verwendung durch dieses bestimmte Steuerelement ausgewählt, bis sie mit einer anderen CONTROL SET FONT-Anweisung geändert wird. Wenn Sie für FontHndl& den Wert Null angeben, wird die Schriftart wieder auf die ursprünglich von PowerBASIC ausgewählte Standardschriftart geändert.

Sie können nahezu beliebig viele Schriftarten und Attribute vordefinieren, indem Sie für jede Schriftart FONT NEW-Anweisungen ausführen. Dadurch sind sie sofort einsatzbereit, wenn sie mit CONTROL SET FONT, GRAPHIC SET FONT und XPRINT SET FONT ausgewählt werden.

Siehe auch

  • DIALOG-STANDARDSCHRIFTART
  • SCHRIFTART END
  • SCHRIFTART NEU
  • GRAFIK-SET-SCHRIFTART
  • XPRINT SCHRIFTART EINSTELLEN

PBXB64-Umsetzungshinweise

STEUERUNG SET SCHRIFTART gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG SET SCHRIFTART ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG SET SCHRIFTART mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


STEUERUNGSSET-BILD – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STEUERUNG BILD EINSTELLEN

STEUERUNG BILD EINSTELLEN

Ändern Sie das Symbol oder die Bitmap, die in einem angezeigt wird

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL SET IMAGE hDlg , id& , newimage$

Beschreibung

hDlg bezieht sich auf den Dialog, der das Steuerelement besitzt.

id& ist die eindeutige Steuerelement-ID, die dem Steuerelement mit der CONTROL ADD IMAGE-Anweisung zugewiesen wurde.

newimage$ gibt den Namen der Bitmap oder des Symbols in der Ressourcendatei an. Wenn die Bildressource einen ganzzahligen Bezeichner verwendet, sollte newimage$ mit einem Zahlensymbol (#) beginnen, gefolgt vom ganzzahligen Bezeichner im ASCII-Format. Beispiel: „#998“. Andernfalls sollte der Textbezeichnername verwendet werden.

Einschränkungen

Bilder können nur mit Bildern des gleichen Typs ausgetauscht werden. Das heißt, wenn das Steuerelement eine Bitmap anzeigt, muss das Ersatzbild ebenfalls eine Bitmap sein. Wenn das Steuerelement ein Symbol anzeigt, muss das Ersatzbild ebenfalls ein Symbol sein. Für beste Ergebnisse sollten die Symbole 32 x 32 Pixel groß sein.

Wenn ein Bild geändert wird, gibt CONTROL SET IMAGE automatisch das alte Bild aus dem Speicher frei. In früheren Versionen von PowerBASIC lag die Pflicht beim Programmierer, das alte Image-Handle freizugeben.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG GRAFIK HINZUFÜGEN
  • STEUERUNG BILD HINZUFÜGEN
  • STEUERUNG BILD HINZUFÜGENX
  • STEUERN SIE DIE IMGBUTTON HINZUFÜGEN
  • STEUERUNG IMGBUTTON HINZUFÜGENX
  • KONTROLLE KUNDEN ERHALTEN
  • KONTROLLE ERHALTEN SIE GRÖSSE
  • STEUERUNG IMAGEX EINSTELLEN
  • STEUERUNG IMGBUTTON EINSTELLEN
  • CONTROL SET IMGBUTTONX

PBXB64-Umsetzungshinweise

STEUERUNG BILD EINSTELLEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG BILD EINSTELLEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG BILD EINSTELLEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL SET IMAGEX – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL SET IMAGEX

STEUERUNG IMAGEX EINSTELLEN

Ändern Sie das Symbol oder die Bitmap, die in einem angezeigt wird

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL SET IMAGEX hDlg , id& , newimage$

Beschreibung

hDlg bezieht sich auf den Dialog, der das Steuerelement besitzt.

id& ist die eindeutige Steuerelement-ID, die dem Steuerelement mit der CONTROL ADD IMAGEX-Anweisung zugewiesen wurde.

newimage$ gibt den Namen der Bitmap oder des Symbols in der Ressourcendatei an. Wenn die Bildressource einen ganzzahligen Bezeichner verwendet, sollte newimage$ mit einem Zahlensymbol (#) beginnen, gefolgt vom ganzzahligen Bezeichner im ASCII-Format. Beispiel: „#998“. Andernfalls sollte der Textbezeichnername verwendet werden.

Einschränkungen

Bilder können nur mit Bildern des gleichen Typs ausgetauscht werden. Das heißt, wenn das Steuerelement eine Bitmap anzeigt, muss das Ersatzbild ebenfalls eine Bitmap sein. Wenn das Steuerelement ein Symbol anzeigt, muss das Ersatzbild ebenfalls ein Symbol sein. Für beste Ergebnisse sollten die Symbole 32 x 32 Pixel groß sein.

Wenn ein Bild geändert wird, gibt CONTROL SET IMAGEX automatisch das alte Bild aus dem Speicher frei. In früheren Versionen von PowerBASIC lag die Pflicht beim Programmierer, das alte Image-Handle freizugeben.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG GRAFIK HINZUFÜGEN
  • STEUERUNG BILD HINZUFÜGEN
  • STEUERUNG BILD HINZUFÜGENX
  • STEUERN SIE DIE IMGBUTTON HINZUFÜGEN
  • STEUERUNG IMGBUTTON HINZUFÜGENX
  • STEUERUNG BILD EINSTELLEN
  • STEUERUNG IMGBUTTON EINSTELLEN
  • CONTROL SET IMGBUTTONX

PBXB64-Umsetzungshinweise

STEUERUNG IMAGEX EINSTELLEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG IMAGEX EINSTELLEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG IMAGEX EINSTELLEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL SET IMGBUTTON – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL SET IMGBUTTON

STEUERUNG IMGBUTTON EINSTELLEN

Ändern Sie das Symbol oder die Bitmap, die in einem angezeigt wird

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL SET IMGBUTTON hDlg , id& , newimage$

Beschreibung

hDlg bezieht sich auf den Dialog, der das Steuerelement besitzt.

id& ist die eindeutige Steuerelement-ID, die dem Steuerelement mit der CONTROL ADD IMGBUTTON-Anweisung zugewiesen wurde.

newimage$ gibt den Namen der Bitmap oder des Symbols in der Ressourcendatei an. Wenn die Bildressource einen ganzzahligen Bezeichner verwendet, sollte newimage$ mit einem Zahlensymbol (#) beginnen, gefolgt vom ganzzahligen Bezeichner im ASCII-Format. Beispiel: „#998“. Andernfalls sollte der Textbezeichnername verwendet werden.

Einschränkungen

Bilder können nur mit Bildern des gleichen Typs ausgetauscht werden. Das heißt, wenn das Steuerelement eine Bitmap anzeigt, muss das Ersatzbild ebenfalls eine Bitmap sein. Wenn das Steuerelement ein Symbol anzeigt, muss das Ersatzbild ebenfalls ein Symbol sein. Für beste Ergebnisse sollten die Symbole 32 x 32 Pixel groß sein.

Wenn ein Bild geändert wird, gibt CONTROL SET IMGBUTTON automatisch das alte Bild aus dem Speicher frei. In früheren Versionen von PowerBASIC lag die Pflicht beim Programmierer, das alte Image-Handle freizugeben.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG GRAFIK HINZUFÜGEN
  • STEUERUNG BILD HINZUFÜGEN
  • STEUERUNG BILD HINZUFÜGENX
  • STEUERN SIE DIE IMGBUTTON HINZUFÜGEN
  • STEUERUNG IMGBUTTON HINZUFÜGENX
  • STEUERUNG BILD EINSTELLEN
  • STEUERUNG IMAGEX EINSTELLEN
  • CONTROL SET IMGBUTTONX

PBXB64-Umsetzungshinweise

STEUERUNG IMGBUTTON EINSTELLEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG IMGBUTTON EINSTELLEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG IMGBUTTON EINSTELLEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL SET IMGBUTTONX – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL SET IMGBUTTONX

CONTROL SET IMGBUTTONX

Ändern Sie das Symbol oder die Bitmap, die in einem angezeigt wird

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL SET IMGBUTTONX hDlg , id& , newimage$

Beschreibung

hDlg bezieht sich auf den Dialog, der das Steuerelement besitzt.

id& ist die eindeutige Steuerelement-ID, die dem Steuerelement mit den CONTROL ADD IMGBUTTONX-Anweisungen zugewiesen wird.

newimage$ gibt den Namen der Bitmap oder des Symbols in der Ressourcendatei an. Wenn die Bildressource einen ganzzahligen Bezeichner verwendet, sollte newimage$ mit einem Zahlensymbol (#) beginnen, gefolgt vom ganzzahligen Bezeichner im ASCII-Format. Beispiel: „#998“. Andernfalls sollte der Textbezeichnername verwendet werden.

Einschränkungen

Bilder können nur mit Bildern des gleichen Typs ausgetauscht werden. Das heißt, wenn das Steuerelement eine Bitmap anzeigt, muss das Ersatzbild ebenfalls eine Bitmap sein. Wenn das Steuerelement ein Symbol anzeigt, muss das Ersatzbild ebenfalls ein Symbol sein. Für beste Ergebnisse sollten die Symbole 32 x 32 Pixel groß sein.

Wenn ein Bild geändert wird, gibt CONTROL SET IMGBUTTONX automatisch das alte Bild aus dem Speicher frei. In früheren Versionen von PowerBASIC lag die Pflicht beim Programmierer, das alte Image-Handle freizugeben.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG GRAFIK HINZUFÜGEN
  • STEUERUNG BILD HINZUFÜGEN
  • STEUERUNG BILD HINZUFÜGENX
  • STEUERN SIE DIE IMGBUTTON HINZUFÜGEN
  • STEUERUNG IMGBUTTON HINZUFÜGENX
  • STEUERUNG BILD EINSTELLEN
  • STEUERUNG IMAGEX EINSTELLEN
  • STEUERUNG IMGBUTTON EINSTELLEN

PBXB64-Umsetzungshinweise

CONTROL SET IMGBUTTONX gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

CONTROL SET IMGBUTTONX ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' CONTROL SET IMGBUTTONX mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL SET LOC – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL SET LOC

STEUERUNG SET LOC

Verschieben Sie das Steuerelement an eine neue Position im Dialogfeld.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL SET LOC hDlg , id& , x& , y&

Beschreibung

hDlg bezieht sich auf den Dialog, der das Steuerelement besitzt.

id& ist die eindeutige Steuerelement-ID, die dem Steuerelement mit einer CONTROL ADD-Anweisung zugewiesen wird.

x& und y& geben die neue Position für die obere linke Ecke des Steuerelements an. Diese Koordinaten beziehen sich auf die obere linke Ecke des Clientbereichs des übergeordneten Dialogs (0,0) und werden in denselben Begriffen (Pixel oder Dialogeinheiten) wie der übergeordnete Dialog angegeben.

Die Standortkoordinaten können negativ oder größer als die Breite des Clientbereichs des übergeordneten Dialogs sein, was dazu führt, dass das Steuerelement abgeschnitten (teilweise angezeigt) oder vollständig ausgeblendet wird.

Diese Technik wird häufig verwendet, um die Eingabetaste zu erfassen, indem eine Standardschaltfläche (%BS_DEFAULT) erstellt und das Steuerelement außerhalb des Clientbereichs des Dialogfelds positioniert wird. Auch wenn das Steuerelement nicht sichtbar ist, ist es dennoch aktiv und kann auf Tastenbetätigungen des Steuerelements usw. reagieren.

Siehe auch

  • Dynamic Dialog Tools
  • KONTROLLE KUNDEN ERHALTEN
  • STEUERUNG ERHALTEN LOC
  • KONTROLLE ERHALTEN SIE GRÖSSE
  • CONTROL SET-GRÖSSE

PBXB64-Umsetzungshinweise

STEUERUNG SET LOC gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG SET LOC ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG SET LOC mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL SET OPTION – PBXB64 Compiler-Hilfe

Startseite › Funktionen › CONTROL SET OPTION

STEUERUNGSSET-OPTION

Legen Sie den Prüfstatus für eine fest

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL SET OPTION hDlg , id& , minid& , maxid&

Beschreibung

Der Prüfstatus gilt als gesetzt (aktiviert), wenn das Kontrollkästchen aktiviert ist, und als deaktiviert (nicht aktiviert oder deaktiviert), wenn das Kontrollkästchen leer ist. Der Prüfstatus sollte immer nur für ein OPTION-Steuerelement in einer Gruppe von OPTION-Steuerelementen festgelegt sein. OPTION-Steuerelementen in einer Gruppe sollten eindeutige fortlaufende Identifikationsnummern zugewiesen werden.

hDlg bezieht sich auf den Dialog, der die OPTION-Steuerelemente besitzt.

id& ist die eindeutige Steuerelementkennung, die dem Schaltflächensteuerelement mit einer CONTROL ADD OPTION-Anweisung zugewiesen wird. CONTROL SET OPTION legt den Prüfstatus für dieses Steuerelement fest und setzt den Prüfstatus für alle verbleibenden OPTION-Steuerelemente zurück, deren Bezeichner im Bereich von minid& bis maxid& enthalten sind.

Das erste OPTION-Steuerelement in einer Gruppe sollte den Stil %WS_GROUP haben, um den Anfang einer Gruppe von Schaltflächen zu markieren, und das erste Nicht-OPTION-Steuerelement nach der Gruppe sollte ebenfalls diesen Stil haben. Wenn nach der Gruppe keine weiteren Steuerelemente vorhanden sind, fügen Sie %WS_GROUP zum ersten Steuerelement im Dialogfeld hinzu. Dadurch wird sichergestellt, dass die Tastaturnavigation mit den Pfeiltasten innerhalb der Gruppe der OPTION-Steuerelemente funktioniert.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERN SIE DIE OPTION HINZUFÜGEN
  • KONTROLLE ERHALTEN SIE ÜBERPRÜFEN

PBXB64-Umsetzungshinweise

STEUERUNGSSET-OPTION gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNGSSET-OPTION ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNGSSET-OPTION mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


STEUERUNGSSATZGRÖSSE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL SET SIZE

CONTROL SET-GRÖSSE

Ändern Sie die Größe eines Steuerelements

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL SET SIZE hDlg , id& , nWide& , nHigh&

Beschreibung

Abhängig von der Art der verwendeten Rahmen kann die Gesamtgröße größer als die Clientgröße sein. Der Clientbereich ist der Teil innerhalb der Grenzen eines Steuerelements, der je nach Stil und Exstyle bei der Erstellung variiert. Die Gesamtgröße umfasst die Ränder. Bei einem Steuerelement ohne Rahmen sind die Clientgröße und die Gesamtgröße gleich. Bei einem Steuerelement mit dem %WS_BORDER-Stil ist der Clientbereich jedoch normalerweise einige Pixel kleiner als die Gesamtgröße.

Handle des Dialogs, der das Steuerelement besitzt.

nWide&, nHigh&

Integrale numerische Ausdrücke, die die gewünschte Größe der Gesamtfläche angeben. Breite und Höhe werden in Pixeln oder Dialogeinheiten angegeben, je nachdem, welches System beim Erstellen des übergeordneten Dialogs verwendet wurde.

Grafische Steuerelemente

Ab dieser Version von PowerBASIC kann die Größe von GRAFIKSTEUERN mit CONTROL SET CLIENT , GRAPHIC SET CLIENT , CONTROL SET SIZE und GRAPHIC SET SIZE geändert werden.

Wenn Sie die Größe eines Grafiksteuerelements ändern, wird die ursprüngliche Bitmap Pixel für Pixel in das neu verkleinerte Steuerelement kopiert. Jeder erweiterte Bereich wird mit der aktuellen Hintergrundfarbe gefüllt. Ihr Programm greift auf normale Weise darauf zurück, um eine Bitmap in der neuen Größe zu erstellen.

Wenn ein Clip-Bereich zum Erstellen von Rändern eingerichtet wurde, wird dieser zurückgesetzt. Wenn skalierte Koordinaten festgelegt wurden, werden diese ebenfalls zurückgesetzt, da keine der beiden für die geänderte Größe angemessen wäre. Sie können diese Attribute mit GRAPHIC SCALE oder GRAPHIC SET CLIP wieder aktivieren, basierend auf der neuen Größe des Zeichenbereichs.

Siehe auch

  • Dynamic Dialog Tools
  • KONTROLLE KUNDEN ERHALTEN
  • STEUERUNG ERHALTEN LOC
  • KONTROLLE ERHALTEN SIE GRÖSSE
  • STEUERUNG SET LOC
  • GRAFIK-SET-CLIENT
  • GRAFIK-SET-GRÖSSE

PBXB64-Umsetzungshinweise

CONTROL SET-GRÖSSE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

CONTROL SET-GRÖSSE ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' CONTROL SET-GRÖSSE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL SET TEXT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL SET TEXT

STEUERUNG TEXT EINSTELLEN

Ändern Sie den Text in einem Steuerelement.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL SET TEXT hDlg , id& , txt$

Beschreibung

hDlg bezieht sich auf den Dialog, der das Steuerelement besitzt.

id& ist die eindeutige Steuerelement-ID, die dem Steuerelement mit einer CONTROL ADD-Anweisung zugewiesen wird.

txt$ ist der neue Text für das Steuerelement. Jeder vorhandene Text im Steuerelement wird durch den neuen Text ersetzt.

Siehe auch

  • Dynamic Dialog Tools
  • CONTROL GET TEXT

UI-Prüfung

Dialog- und Control-Seiten sollen das Control erzeugen, den dokumentierten Befehl anwenden und den geänderten Zustand über Getter, Notification oder sichtbares Ergebnis prüfen. Prüfen Sie Handle-Gültigkeit, bevor Nachrichten gesendet werden.

Nachrichten- und Lebensdauerregeln

Dokumentieren Sie Besitzerfenster, Control-ID, Lebensdauer von Child-Handles und ob der Befehl vor oder nach dem Anzeigen des Dialogs gültig ist.

x64-Hinweise

Verwenden Sie zeigergroße Handles und speichern Sie HWND, HDC oder Callback-Zeiger nicht in 32-Bit-Variablen.

PBXB64-Umsetzungshinweise

STEUERUNG TEXT EINSTELLEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG TEXT EINSTELLEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG TEXT EINSTELLEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL SET USER – PBXB64 Compiler-Hilfe

Startseite › Funktionen › CONTROL SET USER

STEUERUNG BENUTZER EINSTELLEN

Legen Sie einen Wert im Benutzerdatenbereich von a fest

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL SET USER hDlg , id& , index& , usrval&

Beschreibung

Jedes DDT-Steuerelement verfügt über einen Benutzerdatenbereich, der aus acht Long-Integer-Werten besteht, die nach Ermessen des Programmierers zum Speichern relevanter Daten verwendet werden können. Mit CONTROL SET USER kann einer der Werte basierend auf dem Indexparameterwert (1 bis 8) festgelegt werden.

hDlg bezieht sich auf den Dialog, der das Steuerelement besitzt.

id& ist die eindeutige Steuerelement-ID, die dem Steuerelement mit einer CONTROL ADD-Anweisung zugewiesen wird.

index& ist die Indexnummer des festzulegenden Benutzerdatenwerts im Bereich von 1 bis einschließlich 8.

usrval& ist der lange ganzzahlige Datenwert, der im Benutzerdatenbereich gespeichert werden soll.

Einschränkungen

Bei der Zerstörung der Steuerung gehen Daten im Nutzdatenbereich verloren. Der Datenbereich ist vollständig vom von Windows verwalteten %GWL_USERDATA-Bereich getrennt.

Siehe auch

  • Dynamic Dialog Tools
  • COMBOBOX BENUTZER ERHALTEN
  • COMBOBOX SET BENUTZER
  • KONTROLLE GET BENUTZER
  • DIALOG BENUTZER ERHALTEN
  • DIALOG SET BENUTZER
  • LISTBOX BENUTZER ERHALTEN
  • LISTBOX SET BENUTZER
  • LISTVIEW GET USER
  • LISTVIEW SET BENUTZER
  • TREEVIEW GET USER
  • TREEVIEW SET BENUTZER

PBXB64-Umsetzungshinweise

STEUERUNG BENUTZER EINSTELLEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

STEUERUNG BENUTZER EINSTELLEN ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' STEUERUNG BENUTZER EINSTELLEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


CONTROL SHOW STATE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CONTROL SHOW STATE

CONTROL SHOW STATE

Ändern Sie den sichtbaren Status eines Steuerelements.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL SHOW STATE hDlg , id& , showstate& [TO lResult& ]

Beschreibung

CONTROL SHOW STATE wird verwendet, um den Status und/oder das Erscheinungsbild des angegebenen Steuerelements zu ändern, das durch das übergeordnete Dialoghandle hDlg und die Kombination aus Steuerelement-ID und eindeutiger Kennung identifiziert wird.

showstate& kann einer der folgenden sein (mit einem Wert im Bereich von 0 bis 10), wie in der Datei WIN32API.INC definiert):

%SW_HIDE

Blenden Sie das Steuerelement aus.

%SW_MAXIMIZE

Maximiert die angegebene Kontrolle.

%SW_MINIMIZE

Minimieren Sie das angegebene Steuerelement.

%SW_RESTORE

Aktivieren Sie das Steuerelement und zeigen Sie es an. Wenn das Steuerelement minimiert oder maximiert wird, stellt Windows seine ursprüngliche Größe und Position wieder her. Eine Anwendung sollte dieses Flag angeben, wenn sie ein minimiertes Steuerelement wiederherstellt.

%SW_SHOW

Aktivieren Sie das Steuerelement und zeigen Sie es in seiner aktuellen Größe und Position an.

%SW_SHOWMAXIMIZED

Synonym von %SW_MAXIMIZE.

%SW_SHOWMINIMIZED

Aktivieren Sie das Steuerelement und minimieren Sie es.

%SW_SHOWNA

Zeigt das Steuerelement in seinem aktuellen Zustand an, ohne es zu aktivieren. Das aktuell aktive Fenster/Steuerelement bleibt aktiv.

%SW_SHOWNOACTIVATE

Zeigen Sie das Steuerelement in seiner aktuellen Größe und Position an, ohne es zu aktivieren. Das aktuell aktive Fenster/Steuerelement bleibt aktiv.

%SW_SHOWNORMAL

Aktivieren Sie das Steuerelement und zeigen Sie es an. Wenn das Steuerelement minimiert oder maximiert wird, wird es in seiner ursprünglichen Größe und Position wiederhergestellt.

Wenn die optionale TO-Klausel enthalten ist, wird der Variable lResult& der Wert Null zugewiesen, wenn das Steuerelement zuvor nicht sichtbar war, oder ein Wert ungleich Null, wenn es zuvor sichtbar war.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG DEAKTIVIEREN
  • STEUERUNG AKTIVIEREN
  • DIALOG STATUS ANZEIGEN

PBXB64-Umsetzungshinweise

CONTROL SHOW STATE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

CONTROL SHOW STATE ist ein DDT-Control-Befehl fuer ein Dialog-Control. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Control-ID bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Callback-Routing

CONTROL ADD verteilt Benachrichtigungen an den zugewiesenen Callback des Controls oder des Dialogs. Typische Pfade sind WM_COMMAND fuer klassische Steuerelemente und WM_NOTIFY fuer Common-Controls; der Testcode sollte deshalb immer die Nachricht, die Control-ID und die passenden Callback-Hilfen CB.CTL und CB.CTLMSG pruefen.

Stil- und ID-Regeln

Die Werte style& und exstyle& bestimmen Aussehen und Verhalten des erzeugten Controls. Halten Sie Control-IDs innerhalb des Dialogs eindeutig, und pruefen Sie bei Custom Controls immer, ob die erwartete Stil-Kombination von der jeweiligen Control-Klasse wirklich unterstuetzt wird.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' CONTROL SHOW STATE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


Konvertieren einer .RC in eine .RES – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Konvertieren einer .RC in eine .RES
Hilfe zum PBXB64-Compiler

Konvertieren einer .RC in eine .RES

Verwendung der IDE

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Stellen Sie zunächst sicher, dass das Dialogfeld „OPTIONS“ der PowerBASIC-IDE so konfiguriert ist, dass es korrekt auf die Dateien RC.EXE und PBRES.EXE verweist. Nach der Konfiguration kann die IDE eine .RC automatisch in eine .RES-Datei kompilieren. Wenn die Option „Beim Kompilieren von .RC-Dateien eine .PBR erstellen“ auf der Registerkarte „Compileroptionen“ ausgewählt ist, erstellt die IDE auch eine .PBR-Datei aus der .RES-Datei. Dies gelingt in einem einfachen Schritt: Laden Sie einfach die .RC-Datei in die IDE und wählen Sie „Kompilieren“.

Verwenden des Befehlszeilen-Ressourcen-Compilers

Um die .RC-Datei zu kompilieren, müssen wir den Ressourcen-Compiler über eine DOS-Box (Befehlszeile) ausführen, um die binäre Ressourcendatei (.RES) zu erstellen.

Der Ressourcen-Compiler verwendet den Dateinamen Ihrer geänderten (.RC) Ressourcenskriptdatei als Parameter und erstellt eine neue 32-Bit-.RES-Datei. Zum Beispiel:

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Konvertieren einer .RC in eine .RES soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Konvertieren einer .RC in eine .RES mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Erstellen eines Dialogs – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Dialog erstellen

Einen Dialog erstellen

In diesem Beispiel erstellen wir einen einfachen Dialog, der den Benutzer auffordert, seinen Namen einzugeben, und ein Textfeld zur Eingabe sowie die Schaltflächen „OK“ und „Abbrechen“ bereitstellt. Um den Dialog zu erstellen, verwenden wir zunächst den DI

Typ:Schlüsselwort |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

LOKALER hParent ALS DWORD

DIALOG NEU hParent, Caption$,,, 160, 50, Style&, exStyle& TO hDlg

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Erstellen eines DISPATCH-Objekts – PBXB64-Compiler-Hilfe

Startseite› Funktionen › Erstellen eines DISPATCH-Objekts

Erstellen eines DISPATCH-Objekts

DISPATCH-Objekte sind einfach zu erstellen. Deklarieren Sie eine Objektvariable mit einem der Late-Binding-Typnamen (DISPATCH, IDISPATCH, IUNKNOWN, oderIAUTOMATION), dann erstellen Sie das Objekt mit NEWCOM.

Typ:Schlüsselwort |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

LOCAL DispVar AS IDISPATCH
DispVar = NEWCOM("Scripting.Dictionary")

NEWCOM akzeptiert eine ProgID-Zeichenfolge, initialisiert COM im aktuellen Thread, erstellt das Objekt und gibt eine zurück IDispatch Schnittstellenzeiger. Benutzen ISOBJECT(DispVar) um zu überprüfen, ob die Erstellung erfolgreich war.

Beschreibung

DISPATCH-Objekte werden erstellt, indem eine Late-Binding-Objektvariable deklariert und mit NEWCOM eine COM-Referenz zugewiesen wird. Diese Seite behandelt den Erzeugungsschritt und nicht den spaeteren Mitgliedszugriff.

Syntax

LOCAL dispVar AS IDISPATCH
dispVar = NEWCOM "Scripting.Dictionary"

Beispiel

LOCAL dispVar AS IDISPATCH
dispVar = NEWCOM "Scripting.Dictionary"
IF ISOBJECT(dispVar) = 0 THEN FUNCTION = 1

Validierungsbeleg

Der aktuelle Hilfebaum dokumentiert denselben Erzeugungspfad in cmd_late_binding.html und cmd_let_statement(with_objects).html. Das zugrundeliegende Null-/Nicht-Null-Verhalten von Objektreferenzen ist in examples/basic/test_object.pb abgedeckt.

Nutzungshinweise

Deklarieren Sie den Empfaenger mit einem Late-Binding-Typ wie DISPATCH oder IDISPATCH und weisen Sie dann mit NEWCOM eine COM-ProgID zu. Die Objektreferenz ist erst nach erfolgreichem Aufruf verwendbar.

Grenzen

Diese Seite behandelt den Erzeugungsschritt fuer Dispatch-Objekte und die Erfolgspruefung. Mitgliedsaufrufe, Eigenschaftszugriffe und Ereignis-Dispatch gehoeren auf die zugehoerigen Seiten LET (with Objects) und OBJECT.

Siehe auch

  • Late Binding
  • OBJECT

Siehe auch

  • Late Binding
  • OBJECT

Siehe auch

  • Late Binding
  • OBJECT

Siehe auch

  • Late Binding
  • OBJECT

Siehe auch

  • Late Binding
  • OBJECT

Siehe auch

  • Late Binding
  • OBJECT

Siehe auch

  • Late Binding
  • OBJECT

Siehe auch

  • Late Binding
  • OBJECT

Siehe auch

  • Late Binding
  • OBJECT

Siehe auch

  • Late Binding
  • OBJECT

Siehe auch

  • Late Binding
  • OBJECT

Siehe auch

  • Late Binding
  • OBJECT

Siehe auch

  • Late Binding
  • OBJECT

Siehe auch

  • Late Binding
  • OBJECT

Siehe auch

  • Befehlsindex
  • BASIC-Frontend


Erstellen einer Dynamic Link Library – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › Erstellen einer Dynamic Link Library
Hilfe zum PBXB64-Compiler

Erstellen einer Dynamic Link Library

Eine DLL enthält eine oder mehrere exportierte Klassen, Subs oder Funktionen, die von Anwendungen oder anderen DLLs aufgerufen werden können. Eine DLL kann auch eine beliebige Anzahl privater Subs oder Funktionen enthalten, die nur aufgerufen werden können

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Der erste Schritt besteht darin, die Abschnitte Ihrer Anwendung zu identifizieren, die in mehreren Programmen verwendet werden, oder im Fall von Visual Basic, Subs und Funktionen, die Sie schneller ausführen müssen.

Speichern Sie diese Subs und Funktionen als Text und ändern Sie die Dateierweiterung in .BAS. Dies wird zum Quellmodul, das mit PowerBASIC in eine DLL kompiliert wird. Wenn Sie möchten, können Sie die Quelldatei auch von Grund auf neu erstellen.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Erstellen einer Dynamic Link Library soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Erstellen einer Dynamic Link Library mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Erstellen einer statischen Linkbibliothek – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › Erstellen einer statischen Linkbibliothek
Hilfe zum PBXB64-Compiler

Erstellen einer statischen Linkbibliothek

Die Erstellung einer SLL könnte nicht einfacher sein. Alles, was Sie dazu brauchen, ist eine einzige Metaanweisung oben im Quellcode Ihres Moduls:

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

#COMPILE SLL "math_helpers.sll"

FUNCTION SllAddSeven(BYVAL n AS LONG) AS LONG
    FUNCTION = n + 7
END FUNCTION

Wenn Ihre Quelldatei ABC.BAS heisst und kein Dateiname angegeben wird, erstellt PBXB64 ABC.SLL. Wenn der Dateiname keine Erweiterung enthaelt, haengt PBXB64 .sll an. Ein Befehlszeilenpfad mit -o hat Vorrang.

Die erzeugte SLL ist ein deterministisches COFF-Archiv mit dem kompilierten Benutzerobjekt sowie unterstuetzten SLL-lokalen Link-Eingaben und Ressourcen. Sie ist kein ausfuehrbares Programm und enthaelt keine Startup- oder Laufzeitobjekte. Der finale EXE- oder DLL-Host linkt diese Teile, wenn er #LINK verwendet.

#COMPILE EXE
#LINK "math_helpers.sll"

DECLARE FUNCTION SllAddSeven(BYVAL n AS LONG) AS LONG

FUNCTION PBMAIN() AS LONG
    FUNCTION = SllAddSeven(35) <> 42
END FUNCTION

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Erstellen einer statischen Linkbibliothek soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Erstellen einer statischen Linkbibliothek mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


CSET$ ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? CSET$

CSET$

Gibt eine Zeichenfolge zur?ck

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

result_var = CSET$( string_expression , strlen& [USING ustring_expression ])
count& = CSET( string_expression , set_expression )
result_var = CSET$( string_expression , set_expression )

Beschreibung

CSET$ zentriert die Zeichenfolge string_expression in eine Zeichenfolge aus strlen&-Zeichen.

Wenn ustring_expression null (leer) ist oder nicht angegeben ist, f?llt CSET$ string_expression mit Leerzeichen auf. Andernfalls f?llt CSET$ die Zeichenfolge mit dem ersten Zeichen von ustring_expression auf.

Wenn string_expression k?rzer als strlen& ist, zentriert CSET$ string_expression innerhalb result_var und f?llt beide Seiten wie oben beschrieben auf; Andernfalls gibt CSET$ die strlen&-Bytes ganz links von string_expression zur?ck.

PBXB64 unterst?tzt auch die Zeichensatzformen CSET(string,set) und CSET$(string,set). Die numerische Form gibt die Anzahl der Zeichen aus string zur?ck, die in set enthalten sind. Die String-Form gibt diese passenden Zeichen in ihrer urspr?nglichen Reihenfolge zur?ck.

CSET ABS ist kein eigener PBXB64-Befehl. Der Eintrag war ein generiertes PBWin-Hilfeindex-Artefakt aus den ABS-/USING-Schl?sselw?rtern auf der CSET-Seite und wird aus dem Command-Coverage-Nenner gefiltert.

PBXB64-Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    IF CSET$("abc", 7, ".") <> "..abc.." THEN FUNCTION = 1: EXIT FUNCTION
    IF CSET$("abcdef", 3) <> "abc" THEN FUNCTION = 2: EXIT FUNCTION
    IF CSET$("hello world", "aeiou") <> "eoo" THEN FUNCTION = 3: EXIT FUNCTION
    IF CSET("hello world", "aeiou") <> 3 THEN FUNCTION = 4: EXIT FUNCTION
    FUNCTION = 0
END FUNCTION

Die fokussierte Regression ist examples/basic/test_cset_center.pb.

Verifiziertes Beispiel: CSET$ - Text zentrieren oder filtern

Beispieldatei: examples/basic/test_cset_center.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/test_cset_center.pb -o tmp/help_string_samples/test_cset_center.exe and executed with exit code 0.

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL w AS LONG
    LOCAL pad AS STRING

    w = 7
    pad = "."

    IF CSET$("abc", w) <> "  abc  " THEN FUNCTION = 1: EXIT FUNCTION
    IF CSET$("abc", 7, pad) <> "..abc.." THEN FUNCTION = 2: EXIT FUNCTION
    IF CSET$("abcdef", 3) <> "abc" THEN FUNCTION = 3: EXIT FUNCTION
    IF CSET$("abc", 0) <> "" THEN FUNCTION = 4: EXIT FUNCTION
    IF CSET$("hello world", "aeiou") <> "eoo" THEN FUNCTION = 5: EXIT FUNCTION
    IF CSET("hello world", "aeiou") <> 3 THEN FUNCTION = 6: EXIT FUNCTION

    FUNCTION = 0
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft das String-Ergebnis und liefert Exitcode 0 nur bei korrektem Verhalten. Focus expression: CSET$("abc", 7, ".")

Hinweise

Die Seite zeigt das zentrierte Ergebnis und den Charakter-Set-Fall. Dokumentieren Sie auf der Hilfeseite auch Füllzeichen, Trunkierung und die Tatsache, dass die String-Form die gefundenen Zeichen in Originalreihenfolge zurückgibt.

Siehe auch

  • CSET
  • ERHALTEN
  • LET
  • LSET
  • LSET$
  • SETZEN
  • ZUR?CKSETZEN
  • RSET
  • RSET$
  • STRINSERT$
  • TYP EINGESTELLT

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CURDIR$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › CURDIR$

CURDIR$

Gibt den aktuellen Verzeichnispfad für das angegebene Laufwerk zurück.

Typ:Funktion |Kategorie: Dateiverwaltung

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = CURDIR$[( drive$ )]

Beschreibung

„drive$“ ist ein optionaler Zeichenfolgenausdruck, der den Laufwerksbuchstaben des Ziellaufwerks enthält. Wenn Laufwerk$ nicht angegeben ist oder eine leere Zeichenfolge ist, wird der aktuelle Verzeichnispfad für das Standardlaufwerk zurückgegeben.

PBXB64 senkt CURDIR$ und CURDIR$(drive$) auf den eingebetteten Laufzeithelfer bestof_curdir ab. Die Standardform gibt das aktuelle Prozessverzeichnis zurueck. Die Laufwerksform gibt das aktuelle Verzeichnis des angegebenen Laufwerksbuchstabens zurueck, sofern Windows eines bereitstellt.

Einschränkungen

Die fokussierte PBXB64-Zertifizierung deckt das Lesen des aktuellen Verzeichnisses nach CHDIR und eine nichtleere laufwerksqualifizierte Rueckgabe fuer das aktive Laufwerk ab. UNC-Pfade, laufwerksrelative Sonderfaelle, Laufwerkswurzeln, Unicode-Pfade und Fehlerparitaet fuer ungueltige Laufwerke bleiben breitere Datei-/Pfad-Kompatibilitaetsarbeit.

Siehe auch

  • CHDRIVE
  • CHDIR

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


Währung und erweiterte Währung - PBXB64 Compiler Help

Startseite › BASIC-Frontend › Schlüsselwortreferenz › Datentypen & Variablen › Währung und erweiterte Währung
Hilfe zum PBXB64-Compiler

Währung und erweiterte Währung

CURRENCY ist ein festkommaartiger 8-Byte-Zahlentyp, der mit 10.000 skaliert wird. CURRENCYX ist die 16-Byte-Erweiterung, wenn ein groesserer festkommaartiger Bereich benoetigt wird.

Typ: Schlüsselwort | Kategorie: Datentypen

PBXB64-Status: VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

LOCAL value AS CURRENCY
LOCAL valueX AS CURRENCYX
value = 1.23
valueX = 1.23

Typ- und Speicherprüfung

CURRENCY speichert einen skalierten Ganzzahlwert in 8 Byte. CURRENCYX speichert die erweiterte Festkommaform in 16 Byte. Beide sind Wertetypen, daher verwenden Zuweisung, Vergleich und Prozedurübergabe die normalen numerischen Semantiken und keine Zeichenfolgenkonvertierung.

Deklarationsregeln

Verwenden Sie ausdrückliche AS CURRENCY- oder AS CURRENCYX-Deklarationen, wenn die Speicherform am Aufrufort klar sein soll. Die Suffixe sind @ für CURRENCY und @@ für CURRENCYX.

Praktische Verwendung

Verwenden Sie CURRENCY für geldnahe Werte mit vier festen Nachkommastellen und exakten Vergleichen. Verwenden Sie CURRENCYX, wenn Sie einen breiteren festkommaartigen Träger zum Rueckwandeln oder Konvertieren benoetigen.

Parameter und Ergebnisse

Numerische Ausdrücke werden bei diesen Typen vom Compiler/Laufzeitmodell skaliert. Behalten Sie die Skalierung im Blick, wenn Sie in und aus Bytefolgen konvertieren oder gegen literale Dezimalwerte vergleichen.

Validierungsbeleg

Validierungsbeleg: examples/basic/test_currency_float_cmp.pb belegt Zuweisung und Vergleich fuer den fokussierten CURRENCY-Umfang, und examples/basic/test_cv_word_currencyx.pb belegt die Little-Endian-Konvertierung in und aus CURRENCYX-kompatiblen Werten.

Test- und Dokumentationshinweise

Fuer einen kopierbaren Smoke-Test halten Sie das Beispiel klein, initialisieren Sie die Variable explizit und vergleichen Sie den gespeicherten Wert nach jedem Rechenschritt. Bei Byte-Konvertierung muessen sowohl Laenge als auch Byte-Reihenfolge vor dem Zahlenvergleich geprueft werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL c AS CURRENCY
    LOCAL s AS STRING
    LOCAL q AS QUAD

    c = 1.5
    IF c <> 1.5 THEN FUNCTION = 1: EXIT FUNCTION
    c = c + 0.25
    IF c <> 1.75 THEN FUNCTION = 2: EXIT FUNCTION

    s = MKCUX$(&H0102030405060708)
    IF LEN(s) <> 8 THEN FUNCTION = 3: EXIT FUNCTION
    q = CVCUX(s)
    IF q <> &H0102030405060708 THEN FUNCTION = 4: EXIT FUNCTION
END FUNCTION

Siehe auch

  • CVWRD / CVCUX
  • MKBYT$ / MKCUR / MKCUX$


CVBYT – PBXB64-Compiler-Hilfe

Startseite› Funktionen › CVBYT

CVBYT

Extrahiert numerische Werte

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

bytevar? = CVBYT( stringexpr [, offset ])
curvar@ = CVCUR( stringexpr [, offset ])
cuxvar@@ = CVCUX( stringexpr [, offset ])
doublevar# = CVD ( stringexpr [, offset ])
doublewordvar??? = CVDWD( stringexpr [, offset ])
extendedvar## = CVE ( stringexpr [, offset ])
integervar% = CVI ( stringexpr [, offset ])
longintvar& = CVL ( stringexpr [, offset ])
quadintvar&& = CVQ ( stringexpr [, offset ])
singlevar! = CVS ( stringexpr [, offset ])
wordvar?? = CVWRD( stringexpr [, offset ])

Beschreibung

Die CVx-Funktionen geben eine Zahl zurück, die einem binären Muster entspricht, das in einem ANSI-Zeichenfolgenwert gespeichert ist. Das Binärmuster ist das interne Format, das PowerBASIC zum Speichern dieser Werte im Speicher verwendet. Dieses Format folgt dem IEEE-Standard, wo immer er gilt. Die MKx$-Funktionen ergänzen die CVx-Funktionen. Verwechseln Sie diese Funktionen nicht mit der VAL-Funktion, die eine als druckbare Textzeichenfolge gespeicherte Zahl (z. B. „123,45“) in einen numerischen Ausdruck umwandelt.

In allen außer den extremsten Fällen muss StringExpr ein ANSI-String oder UDT sein, der aus einzelnen Bytes besteht. WIDE-Zeichenfolgen (Unicode) bestehen aus einer Reihe von 2-Byte-Wörtern, die im Allgemeinen zu undefinierten Ergebnissen führen.

Mit den CVx-Funktionen können Sie Werte abrufen, die über das erste Byte des StringExpr hinausgehen. In diesem Fall gibt der optionale Offset-Parameter die Byteposition an, an der die Konvertierung beginnen soll. Dies ist die Byteposition, nicht die Zeichenposition, selbst bei einem WIDE StringExpr . Wenn Offset nicht angegeben ist, wird davon ausgegangen, dass es eins (1) ist.

Beispiel: „Value& = CVL(x$, 3)“ würde das 3. bis 6. Byte von x$ extrahieren und diese 4 Bytes in den entsprechenden Long-Integer-Wert konvertieren. In diesem Beispiel muss x$ mindestens 6 Byte lang sein.

Der fokussierte Kompatibilitaetsvertrag von PBXB64 fuer CVE ist die getestete 8-Byte-EXT-Form, die mit DOUBLE kompatibel ist. tests/pb/test_cve_mke_double_alias.pb prueft, dass CVE(MKE$(3.5)) ueber die eingebettete Laufzeit korrekt zurueckgewandelt wird. Echte 10-Byte-PBWin-Extended-Precision-Speicherung ist erst implementiert, wenn der Compiler eine reale Extended-Precision-Laufzeitdarstellung besitzt.

Function

Variabel

Konvertiert in

1-Byte-Zeichenfolge

8-Byte-String

Währung

8-Byte-String

Extended-currency

8-Byte-String

Schwimmer mit doppelter Genauigkeit

4-Byte-Zeichenfolge

Doppelwort

10-Byte-Zeichenfolge

Schwimmer mit erweiterter Präzision

2-Byte-String

Ganze Zahl

4-Byte-Zeichenfolge

Lange Ganzzahl

8-Byte-String

Quad-Ganzzahl

4-Byte-Zeichenfolge

Float mit einfacher Genauigkeit

2-Byte-String

Einschränkungen

Ausdrücke mit numerischen Gleichungen und bedingter Kompilierung ( #IF ) können auch die CVQ-Funktion enthalten. Auf diese Weise können Sie einem Equate ganz einfach numerische Werte zuweisen, basierend auf einer aussagekräftigen Mnemonik. Der CVQ-Ausdruck ist in diesem Zusammenhang auf eine Länge von acht Bytes begrenzt. Zum Beispiel:

%Mode = CVQ("DEBUG")

%Style = CVQ("Cool")

CVS beschränkt die Zeichenfolgenanzeige auf sieben signifikante Ziffern.

Siehe auch

  • MKBYT$ und zugehörige Funktionen

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für CVBYT soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' CVBYT mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


CVWRD / CVCUX - PBXB64 Help

Startseite › General Reference › CVWRD / CVCUX

CVWRD / CVCUX

Wandelt Little-Endian-Bytefolgen aus MKWRD$ und MKCUX$ wieder in WORD- und CURRENCYX-kompatible numerische Werte um.

Kind: PowerBASIC feature | Category: PowerBASIC / Tested Feature

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

w& = CVWRD(bytes$)
c&& = CVCUX(bytes$)

Beschreibung

Diese Seite beschreibt das PBXB64-Verhalten, das durch die aktuelle Validierungsmatrix abgedeckt ist. Verwenden Sie die hier gezeigte Syntax fuer Regressionstests; weitergehende PowerBASIC-Formen gelten als separate Kompatibilitaetsarbeit, sofern keine andere Seite sie dokumentiert.

Unterstuetzter Umfang

Die dokumentierte Teilmenge ist absichtlich genau: Beispiele verwenden bevorzugt skalare LONG-Werte, Array-Beispiele benutzen normale PB-logische Indizes, und laufzeitabhaengige Operationen sollen immer den Rueckgabestatus pruefen. Wenn ein Feature sowohl Anweisungs- als auch Funktionsschreibweise besitzt, beschreibt diese Seite den funktionsorientierten Seiteneintrag und verweist auf die breitere BASIC-Referenz.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    IF CVWRD(MKWRD$(513)) <> 513 THEN FUNCTION = 1
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_cv_word_currencyx.pb`.

Fuer Release-Arbeiten sollte jede Syntaxform einen kleinen ausfuehrbaren Test besitzen. Ein guter Test initialisiert alle Eingaben, fuehrt den dokumentierten Befehl oder die Funktion aus, prueft das exakte Ergebnis und liefert bei Fehler einen von Null verschiedenen Exit-Code. Dadurch bleiben Hilfeaussagen an reproduzierbares Verhalten eines isolierten PBXB64-Compilers gebunden.

Grenzen

Nicht gezeigte PowerBASIC-Varianten duerfen aus dieser Seite nicht als unterstuetzt abgeleitet werden. Formen, die hier nicht stehen, benoetigen eigene Implementierung, Diagnostik, Tests und Hilfetext, bevor sie als abgeschlossen beschrieben werden.

Siehe auch

  • BASIC Language Reference
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


DATEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DATEN

DATEN

Erklären

Typ:Anweisung |Kategorie:Variablen und Umfang

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DATA ["] item ["] [[, ["] item ["]] ...]

Beschreibung

DATA-Anweisungen dürfen nur innerhalb von Subs , Functions , Method oder Properties erscheinen und sind nur für den Code in der Prozedur sichtbar, in der sie erscheinen. Jedes Verfahren kann daher über eigene private Daten verfügen.

Daten können aus nahezu beliebigen Textzeichen bestehen. Datenelemente können in Anführungszeichen gesetzt werden, um führende/nachgestellte Leerzeichen beizubehalten, die andernfalls während der Kompilierung entfernt werden.

Einschränkungen

Es gibt eine Grenze von 64 Kilobyte und 16384 separaten Datenelementen pro Prozedur. Frühere Versionen von PowerBASIC ignorierten Klartext, der unmittelbar nach einem Literal in Anführungszeichen bis zum nächsten Komma oder Zeilenende stand. Dies ist jedoch nicht mehr akzeptabel und erzeugt einen Fehler 477 („Syntaxfehler“).

DATA-Anweisungen können sich nicht über mehr als eine physische Quellcodezeile erstrecken und Zeilenfortsetzungszeichen verwenden. Bei der Formatierung von DATA-Anweisungen ist besondere Vorsicht geboten, insbesondere wenn die Daten Unterstriche und/oder Doppelpunkte enthalten sollen. In den folgenden Beispielen werden Datenelemente blau hervorgehoben:

Wenn nach einem Komma ein Unterstrich steht, wird er als Anfang einer Datenzeichenfolge in Anführungszeichen und nicht als Zeilenfortsetzungszeichen behandelt:

' In dieser Zeile sind drei Datenelemente vorhanden:

DATEN „Tom“, „Dick“, _Harry

Der Doppelpunkt (Anweisungstrennzeichen) fungiert bei Verwendung in Zeichenfolgendaten ohne Anführungszeichen als reguläres Anweisungstrennzeichen:

' Zwei Datenelemente und eine separate Anweisung

DATEN „Tom“, „Dick“ : Harry& = 1

Wenn jedoch ein Doppelpunkt in einer Datenzeichenfolge in Anführungszeichen vorkommt, wird er als Teil der Datenzeichenfolge behandelt:

' 3 Datenelemente

DATEN „Tom“,Dick,“:Harry& = 1“

Siehe auch

  • DATENANZAHL
  • LESEN$
  • VAL

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Datentypen in Registern – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Datentypen in Registern

Datentypen in Registern

Es gibt drei grundlegende Arten von Operanden, die in einem Register platziert werden können: Direktregister, Speicherregister oder ein anderes Register.

Typ:Schlüsselwort |Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Ein unmittelbarer Operand ist normalerweise ein numerisches Literal (Zahl), es kann aber auch ein String-Literal in der Form „a“ sein, das von PowerBASIC in seinen ASCII-Äquivalentcode konvertiert wird.

! MOV AL, „a“ ; String-Literal

! MOV EDX, 0 ; Numerisch unmittelbar/literal

Ein Speicheroperand ist eine Adresse im Speicher einer bestimmten Datenform:

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.


DATACOUNT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DATACOUNT

DATENANZAHL

Gibt die Gesamtzahl der lokalen Anzahl zurück

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

Count% = DATACOUNT

Beschreibung

DATACOUNT gibt nur die Anzahl der DATA-Elemente in der Sub , Function , Method oder Property zurück, in der es vorkommt (d. h. lokale DATA-Anweisungen). Während es nicht möglich ist, Daten direkt von außerhalb des Gültigkeitsbereichs der aktuellen Prozedur zu lesen, können globale Daten einfach emuliert werden, indem sie innerhalb einer Prozedur platziert werden, die Daten an den aufrufenden Code zurückgibt. Es gibt eine Grenze von 64 Kilobyte und 16384 separaten Datenelementen pro Prozedur.

Siehe auch

  • DATEN
  • LESEN$

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


DATE$-Systemvariable – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Systemvariable DATE$

DATE$-Systemvariable

Legen Sie das Systemdatum fest oder rufen Sie es ab.

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DATE$ = s$ ' sets system date according to s$
s$ = DATE$ ' s$ now contains system date

Beschreibung

Durch Zuweisen eines ordnungsgemäß formatierten Zeichenfolgenwerts zu DATE$ wird das Systemdatum festgelegt. Sie können DATE$ auch einer Zeichenfolgenvariablen zuweisen, die 10 Zeichen in der Form „mm-tt-jjjj“ speichert, wobei mm für den Monat, dd für den Tag und yyyy für das Jahr steht.

Um das Datum zu ändern, muss Ihre Datumszeichenfolge auf eine der folgenden Arten formatiert sein:

MM-TT-JJ

MM/TT/JJ

MM-TT-JJJJ

MM/TT/JJJJ

Beispielsweise setzt DATE$ = „11-09-84“ das Systemdatum auf den 9. November 1984.

Einschränkungen

Das der Systemvariablen DATE$ zugewiesene Jahr muss im Bereich von 1980 bis 2099 liegen. DATE$ gibt niemals gebietsschemaspezifische Datumsformate zurück. Bei der Zuweisung einer zweistelligen Jahreszahl wird davon ausgegangen, dass jeder Wert unter 81 im Jahr 2000 liegt und jeder Wert über 80 im Jahr 1900 liegt.

Siehe auch

  • TAGNAME$
  • MONTHNAME$
  • POWERTIME
  • ZEIT$

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


DAYNAME$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DAYNAME$

TAGNAME$

Konvertiert eine Wochentagszahl in den zugehörigen Namen.

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = DAYNAME$( DayNumber& )

Beschreibung

Die Funktion DAYNAME$ wandelt eine Wochentagszahl in eine Zeichenfolge um, die den zugehörigen Namen darstellt. Das Argument muss im Bereich von 0 bis 6 liegen und die Namen Sonntag, Montag usw. darstellen.

Siehe auch

  • DATUM$
  • MONTHNAME$
  • POWERTIME

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Steuerelemente – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Bedienelemente

Kontrollen

Ein Steuerelement ist ein spezielles Fenster, das eine Methode zur Interaktion mit dem Benutzer bereitstellt. Schaltflächen, Kombinationsfelder, Listenfelder und Textfelder sind Beispiele für Steuerelemente. Immer wenn der Benutzer mit a interagiert

Typ:Schlüsselwort |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Wenn Sie einem Dialog ein Steuerelement hinzufügen, ist es wichtig, dass jedes Steuerelement über eine eindeutige numerische Kennung verfügt. Mithilfe dieser Kennung kann Ihre Anwendung erkennen, welches Steuerelement ein Ereignis sendet. Wenn Ihr Programm beispielsweise über zwei Schaltflächen verfügt, können Sie diese anhand der Steuerelement-ID unterscheiden.

Beim Erstellen jedes Steuerelements weist Windows ein eindeutiges Fensterhandle zu, um das Steuerelement zu identifizieren. Da Ihr Programm diese Handle-Werte nicht zuweist, kann Ihr Code sie nicht direkt zur Identifizierung einzelner Steuerelemente verwenden. Darüber hinaus wird jedes Mal, wenn ein Steuerelement zerstört und neu erstellt wird, ein neuer eindeutiger Handle-Wert zugewiesen, was die Aufgabe weiter verkompliziert. Die Steuerelement-ID überwindet diese Probleme, da der Programmierer die ID für jedes Steuerelement bestimmt.

Mit der CONTROL ADD-Anweisung werden Ihrem Dialog Steuerelemente hinzugefügt. Stellen Sie sicher, dass jedes von Ihnen erstellte Steuerelement über eine eindeutige numerische Kennung verfügt, damit Sie (und Windows) es von anderen Steuerelementen im Dialogfeld unterscheiden können.

Angesichts der ID eines Steuerelements stellt DDT die CONTROL HANDLE-Anweisung bereit, um den Fenster-Handle-Wert des Steuerelements abzurufen. Wenn eine bestimmte ID in einem Dialog dupliziert wird, kann CONTROL HANDLE nur das erste Steuerelement identifizieren, das mit der ID übereinstimmt, und die übrigen Steuerelemente werden im Wesentlichen ignoriert. Steuerelement-IDs können häufig für (statische) Beschriftungstextsteuerelemente dupliziert werden, sofern diese Steuerelemente (und ihre Inhalte, Farben oder Stile) zur Laufzeit nicht geändert werden. Wenn ein solches Label-Steuerelement geändert werden soll, muss seine Steuerelement-ID eindeutig sein.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Kontrollen soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Kontrollen mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Steuerelementstile – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Steuerungsstile

Kontrollstile

Beim Erstellen untergeordneter Steuerelemente für Ihre Dialoge können Sie nahezu jeden von Windows zugelassenen Steuerelementstil verwenden. Diese Stile beginnen meist mit dem Präfix %WS_ (Fensterstil) und sind im enthalten

Typ:Schlüsselwort |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Wenn der Stilparameter in Ihren CONTROL ADD-Anweisungen auf 0 gesetzt ist, legt DDT automatisch Standardstile für Sie fest. Die Standardstile hängen von der Art des Steuerelements ab, das Sie Ihrem Dialogfeld hinzufügen. Beispielsweise erhält eine Schaltfläche den Stil %WS_TABSTOP.

Beachten Sie, dass DDT Ihren Steuerelementen immer bestimmte Stile zuweist, z. B. %WS_CHILD und %WS_VISIBLE, unabhängig von den von Ihnen angegebenen Stilen. Wenn Sie Ihren Stilparameter festlegen, können Sie diese beiden Stile getrost ignorieren und sich auf die wichtigeren Stile konzentrieren, die erforderlich sind. Dies hat den Vorteil, dass Ihr Code weniger unübersichtlich wird. Die Ausnahme bilden benutzerdefinierte Steuerelemente. In diesem Fall müssen Sie alle erforderlichen Stile explizit angeben.

Die „Tab-Reihenfolge“ der Steuerelemente (auch als „Z-Reihenfolge“ bezeichnet) wird durch die Reihenfolge bestimmt, in der DDT-Steuerelemente zur Laufzeit erstellt werden. Das heißt, das erste einem Dialog hinzugefügte Steuerelement ist das erste Steuerelement in der Z-Reihenfolge, das zweite hinzugefügte Steuerelement ist das zweite und so weiter. Wenn ein Dialogfeld zum ersten Mal angezeigt wird, wird der Tastaturfokus automatisch auf das erste Steuerelement in der Z-Reihenfolge gelegt, das den Stil %WS_TABSTOP hat. Jedes Mal, wenn die TAB-Taste anschließend gedrückt wird, wechselt der Tastaturfokus zum nächsten Steuerelement in der Tab-Reihenfolge. Um sicherzustellen, dass alle Steuerelemente in einem Dialog mit der TAB-Taste ausgewählt werden können, sollte jedes Steuerelement im Dialog den Stil %WS_TABSTOP enthalten. Die Z-Reihenfolge bestimmt auch die Reihenfolge, in der Steuerelemente in einem Dialog gezeichnet werden, um sicherzustellen, dass einander überlappende Steuerelemente auf vorhersehbare Weise gezeichnet werden können.

Steuerelemente, die deaktiviert sind (weil sie entweder den Stil %WS_DISABLED haben oder dynamisch mit CONTROL DISABLE deaktiviert wurden), werden übersprungen.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Kontrollstile soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Kontrollstile mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


#DEBUG - Debug-Metadaten steuern — PBXB64 Help

Startseite › General Reference › #DEBUG - Debug-Metadaten steuern — PBXB64 Help
Hilfe zum PBXB64-Compiler

#DEBUG - Debug-Metadaten steuern

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

#DEBUG ON

Detailverhalten

Wird als PB-Direktivkeyword fuer debug-orientierte Quellkompatibilitaet erkannt.

Praktische Verwendung

Verwenden Sie diesen Marker, wenn die Quelle Debug-Metadaten oder Debug-kompatible Direktiven sichtbar halten muss. Die eigentliche Wirkung haengt vom umgebenden Compiler- und Help-Surface ab; pruefen Sie daher immer die konkrete Debug-Eingabe und die erzeugten Metadaten.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Ein unpassender Debug-Marker sollte nicht mit einer echten Trace- oder Release-Funktion verwechselt werden. Pruefen Sie nach dem Build, welche Metadaten wirklich erzeugt wurden.

Verifiziertes Beispiel

Abgedeckt durch examples/basic/test_using_debug.pb (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


#DEBUG-CODE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › #DEBUG CODE

#DEBUG-CODE

Compiler-Anweisung zur Unterdrückung der Generierung von Debug-Code.

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

#DEBUG CODE {ON|+ | OFF|-}
$DEBUG CODE {ON|+ | OFF|-}

Beschreibung

Wenn ein Programm zum Debuggen in der PowerBASIC-IDE kompiliert wird, muss der Compiler zusätzlichen Code generieren, um das Setzen von Haltepunkten und einige andere Debug-Vorgänge zu erleichtern. In den meisten Fällen hat dies keinen Einfluss auf die Ausführung Ihres Programms. Im Falle einer Codewiederholung in einer engen Schleife oder bei bestimmtem Assemblercode oder Daten, die nicht geändert werden dürfen, kann es jedoch sehr wichtig sein, einige Debugging-Codes zu unterdrücken, damit der Code korrekt und mit voller Geschwindigkeit ausgeführt wird.

#DEBUG CODE OFF unterdrückt die Generierung von Debug-Code aus dieser Zeile, bis ein nachfolgender #DEBUG CODE ON (oder das Ende der Sub / Function / Method / Property) erreicht ist. Wenn Debugcode unterdrückt wird, ist es natürlich nicht möglich, Haltepunkte in diesen Zeilen festzulegen.

#DEBUG CODE-Metaanweisungen werden ignoriert, wenn nicht zum Debuggen kompiliert wird.

PBXB64 akzeptiert #DEBUG CODE und $DEBUG CODE als Kompatibilitaets-Metadaten beim Kompilieren. In eigenstaendiger PBXB64-Ausgabe erzeugen sie kein PBWin-Debuggerverhalten zur Debug-Code-Erzeugung oder -Unterdrueckung; sie halten importierte PBWin-Quellen unter einem dokumentierten Vertrag ohne Laufzeitwirkung kompilierbar.

Siehe auch

  • Fehler-Trapping
  • Fehler
  • Debuggen
  • #DEBUG-ANZEIGE
  • #DEBUG-FEHLER
  • #DEBUG PRINT

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


#DEBUG DISPLAY – PBXB64-Compiler-Hilfe

Startseite › Funktionen › #DEBUG-ANZEIGE

#DEBUG-ANZEIGE

Zeigt eine Meldung an, wenn ein nicht abgefangener Laufzeitfehler auftritt.

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

#DEBUG DISPLAY {ON|+ | OFF|-}
$DEBUG DISPLAY {ON|+ | OFF|-}

Beschreibung

#DEBUG DISPLAY ON aktiviert den Fehleranzeigemodus innerhalb eines kompilierten PowerBASIC-Programms. Wenn in diesem Modus ein nicht abgefangener Fehler auftritt (ohne den Vorteil von ON ERROR GOTO , TRY/CATCH usw.), wird die Programmausführung angehalten und eine beschreibende Meldung angezeigt. Diese Meldung enthält die Fehlernummer, eine kurze Beschreibung des Fehlers und ein Positionsbeschreibungswort, das Ihnen dabei hilft, den Ort des Fehlers zu finden. Das Positionsdeskriptorwort besteht aus den ersten 8 Zeichen des Namens der letzten (aktuellsten) Bezeichnung, Zeilennummer oder Prozedur, die ausgeführt wurde. Dieser Modus sollte nur während der Programmentwicklung und beim Debuggen verwendet werden. Es sollte niemals in einem Produktionsprogramm verwendet werden.

Wenn die beschreibende Meldung angezeigt wird, werden sie von zwei Schaltflächen mit der Bezeichnung „OK“ und „Abbrechen“ begleitet. Bei Auswahl von „OK“ wird die Programmausführung trotz der Fehlerbedingung fortgesetzt. Bei Auswahl von „Abbrechen“ wird die Programmausführung gestoppt. Wenn jedoch untergeordnete Prozesse gestartet wurden, ist es möglich, dass diese weiter ausgeführt werden, bis sie normal beendet werden.

#DEBUG DISPLAY OFF unterdrückt den Anzeigemodus und ist die Standardbedingung.

PBXB64 akzeptiert #DEBUG DISPLAY und $DEBUG DISPLAY als Kompatibilitaets-Metadaten beim Kompilieren. In eigenstaendiger PBXB64-Ausgabe installieren sie keine PBWin-Debuggerbehandlung fuer nicht abgefangene Fehler und erzeugen kein Laufzeit-Meldungsfenster.

Einschränkungen

#DEBUG DISPLAY ON|OFF kann nur einmal ausgeführt werden und muss vor dem gesamten ausführbaren Code stehen. Wenn #DEBUG DISPLAY weggelassen wird, ist die Standardbedingung #DEBUG DISPLAY OFF.

Siehe auch

  • Fehler-Trapping
  • Fehler
  • Debuggen
  • #DEBUG-CODE
  • #DEBUG-FEHLER
  • #DEBUG PRINT

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


#DEBUG-FEHLER – PBXB64-Compiler-Hilfe

Startseite › Funktionen › #DEBUG ERROR

#DEBUG-FEHLER

Kontrollgenerierung von

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

#DEBUG ERROR {ON|+ | OFF|-}
$DEBUG ERROR {ON|+ | OFF|-}

Beschreibung

Die Option #DEBUG ERROR gibt an, ob der Compiler Code generieren soll, der nach Array-Grenzen- und Nullzeigerfehlern sucht, wo immer diese auftreten. Die Standardeinstellung ist AUS.

Wenn der #DEBUG ERROR-Modus aktiviert ist, erzeugt jeder Versuch, auf ein Array außerhalb seiner Grenzen zuzugreifen oder einen Nullzeiger zu verwenden, einen Laufzeitfehler 9 („Index/Zeiger außerhalb des Bereichs“) und die Anweisung selbst wird nicht ausgeführt.

Bei AUS werden alle Anweisungen „wie sie sind“ ausgeführt und es werden keine Fehler generiert. Der Zugriff auf ein Array außerhalb seiner Grenzen oder die Verwendung eines Nullzeigers kann jedoch zu einer allgemeinen Schutzverletzung (GPF) oder einem Ausnahmefehler führen.

Am besten aktivieren Sie beim Entwickeln eines Programms die Fehlerprüfung #DEBUG ERROR. Sobald alle offensichtlicheren Fehler beseitigt sind, sollten Sie zur Standardeinstellung (AUS) zurückkehren, da Ihr Code dadurch kleiner und schneller wird. Abhängig von der Art der zu entwickelnden Anwendung muss die endgültige (Produktions-)Version eines Programms möglicherweise keinen Fehlerprüfcode enthalten.

Einschränkungen

#DEBUG ERROR ist immer aktiviert, wenn Code im Debugger ausgeführt wird, unabhängig von einer expliziten #DEBUG ERROR-Metaanweisung.

Festplatten-E/A-Fehler werden immer abgefangen, unabhängig vom Status von #DEBUG ERROR.

#DEBUG ERROR ON fängt keine Array-Grenzfehler von Arrays innerhalb benutzerdefinierter Typen und Unions ab. Zeiger werden nur auf Nullwerte getestet. Zieladressen mit Zeigern ungleich Null werden nicht auf Lesbarkeit oder Schreibbarkeit getestet.

PBXB64 akzeptiert #DEBUG ERROR und $DEBUG ERROR als Kompatibilitaets-Metadaten beim Kompilieren. In eigenstaendiger PBXB64-Ausgabe erzeugen sie keine PBWin-Laufzeitpruefungen fuer Array-Grenzen oder Nullzeiger; vorhandene PBXB64-Laufzeitpruefungen werden durch ihre eigenen implementierten Funktionen gesteuert, nicht durch diese Direktive.

Siehe auch

  • Fehler-Trapping
  • Fehler
  • Debuggen
  • #DEBUG-CODE
  • #DEBUG-ANZEIGE
  • #DEBUG PRINT

Fehlerpfad-Prüfung

Fehlerbehandlungsseiten sollen den normalen Pfad und den Fehlerpfad zeigen. Ein vollständiges Beispiel löst absichtlich einen bekannten Fehler aus, prüft den dokumentierten Fehlerwert, stellt wieder her oder beendet sauber und zeigt, dass spätere Anweisungen in der erwarteten Reihenfolge laufen.

Zustandsregeln

Dokumentieren Sie, welche Variablen, Handler oder Systemwerte durch die Operation geändert werden. Vermeiden Sie Beispiele, die einen Fehler durch ungeprüftes Weiterlaufen verdecken.

Migrationshinweise

Beim Portieren älteren PB-Codes sind Annahmen zu Zeilennummern, Handler-Gültigkeit, verschachtelten Prozeduren und Windows-API-Fehlern neu zu prüfen.


#DEBUG PRINT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › #DEBUG PRINT

#DEBUG PRINT

Informationen im anzeigen

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

#DEBUG PRINT string_expression
$DEBUG PRINT string_expression

Beschreibung

Mit der PRINT-Option kann der Programmierer während einer Debugging-Sitzung beliebige Informationen im Debug-Ausgabefenster der IDE anzeigen. Das Ausgabefenster wird vom Debugger bereitgestellt, um Statusinformationen über den Status der Debugging-Sitzung anzuzeigen. #DEBUG PRINT bietet jedoch eine bequeme Möglichkeit, während der Programmausführung ein „Prozessprotokoll“ einer Unterfunktion, einer Funktion, einer Methode, einer Eigenschaft oder einer Variablen zu erstellen. In Kombination mit FUNCNAME$ kann #DEBUG PRINT ein nützliches Tool zum Debuggen von Anwendungscode sein. Siehe das Beispiel unten.

Dies ist möglich, weil das Debugger-Ausgabefenster über einen scrollbaren Bereich verfügt, der einem Konsolenfenster ähnelt, während das Überwachungsfenster nur den Momentanwert einer Variablen anzeigt.

#DEBUG PRINT-Anweisungen werden ignoriert, wenn Code in eine eigenständige Datei (EXE/DLL) kompiliert wird. Sie sind nur bei Verwendung des Debuggers enthalten. Steuercodes in der Zeichenfolge werden im Ausgabefenster in das Hex-Format übersetzt. Beispielsweise werden eingebettete CHR$ (0)- oder $NUL-Bytes als „<00>“ angezeigt.

PBXB64 akzeptiert #DEBUG PRINT und $DEBUG PRINT als Kompatibilitaets-Metadaten beim Kompilieren. In eigenstaendiger PBXB64-Ausgabe schreiben sie nicht in ein PBWin-Debugger-Ausgabefenster und auch nicht nach stdout, stderr oder in TRACE-Dateien.

Einschränkungen

Sie können Unicode-Zeichenfolgen mit #DEBUG PRINT verwenden, die Ergebnisse werden jedoch von Windows immer in ANSI konvertiert. Dies ist eine Windows-Designbeschränkung, keine Einschränkung von PowerBASIC.

Praktische Verwendung

#DEBUG PRINT gehoert zur Kategorie General. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' #DEBUG PRINT mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Siehe auch

  • Debuggen
  • #DEBUG-FEHLER
  • FUNCNAME$


Debuggen von PBXB64-Programmen – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › Debuggen von PBXB64-Programmen

Debuggen von PBXB64-Programmen

Tipps und Techniken zum Debuggen von PBXB64-Programmen.

Typ:Konzeptionell |Kategorie: Entwicklung

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Überblick

Dieses Thema bietet Hintergrundinformationen und praktische Anleitungen. Eine detaillierte Syntax finden Sie auf den entsprechenden Befehlsseiten.

Siehe auch

  • Befehlsindex

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


DEC$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DEC$

DEC$

Konvertieren Sie einen ganzzahligen Wert in eine Dezimalzeichenfolge

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = DEC$( IntVal [, Digits , LeadSpaces , TrailSpaces ])

Beschreibung

IntVal ist ein numerischer Ausdruck im Bereich einer 64-Bit-Quad-Ganzzahl (-9223372036854775808 bis +9223372036854775807). Jeder Bruchteil des Wertes wird gerundet. Wenn der Wert negativ ist, belegt das führende Minuszeichen eine Ziffernposition. Die Ergebniszeichenfolge wird immer als Ganzzahl unter Verwendung aller signifikanten Ziffern in IntVal formatiert. Es wird niemals in wissenschaftlicher Notation ausgedrückt.

Wenn Digits 0 ist (oder nicht angegeben ist), werden dem numerischen Feld keine führenden Zeichen hinzugefügt. Wenn Digits eine positive Zahl größer als 0 ist, werden der Ergebniszeichenfolge führende Nullen vorangestellt, um die gewünschte Länge zu erreichen. Wenn Digits eine negative Zahl ist, werden führende Leerzeichen hinzugefügt, um die absolute Länge zu erreichen. Die Ziffern können im Bereich von -20 bis +20 liegen.

LeadSpaces specifies additional leading spaces to be prepended, regardless of the length of the numeric portion of the string.

TrailSpaces specifies additional trailing spaces to be appended to the end of the string.

Siehe auch

  • BIN$
  • FORMAT$
  • HEX$
  • OCT$
  • STR$
  • TRIM$
  • USING$
  • VAL

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


DEC128 “ PBXB64-Compiler-Hilfe

Startseite â€º Datentypen â€º DEC128

128. Dezember

16-Byte-Festkomma-Dezimaltyp mit 18 Dezimalstellen Genauigkeit.

Typ: Datentyp | Kategorie:Mathematik und Numerik

PBXB64-Status:VERFÃœGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

LOCAL  var AS DEC128
STATIC var AS DEC128
GLOBAL var AS DEC128

Beschreibung

DEC128 ist ein 16-Byte-Festkomma-Dezimaltyp, der Werte mit einer Genauigkeit von 18 Dezimalstellen speichert. Es wird als vorzeichenbehaftete 64-Bit-Mantisse gepaart mit einem 32-Bit-Exponenten implementiert und bietet exakte Dezimalarithmetik für finanzielle und wissenschaftliche Berechnungen, bei denen binäre Gleitkomma-Rundungsfehler nicht akzeptabel sind.

Der Typ wird als Referenz (Zeiger) an Laufzeitfunktionen übergeben. Benutzen VARPTR(var) um die Adresse beim Aufruf der integrierten Konvertierungsfunktionen zu erhalten.

Integrierte Funktionen

Function | Unterschrift | Beschreibung
DEC128_FROM_DOUBLE | DEC128_FROM_DOUBLE(d, VARPTR(v)) | Konvertieren Sie einen DOUBLE-Wert in eine DEC128-Variable.
DEC128_TO_DOUBLE | d = DEC128_TO_DOUBLE(VARPTR(v)) | Konvertieren Sie eine DEC128-Variable zurück in DOUBLE.
DEC128_ADD | DEC128_ADD(VARPTR(a), VARPTR(b), VARPTR(out)) | Addieren Sie zwei DEC128-Werte und speichern Sie das Ergebnis in out.

Beispiel

#COMPILE EXE
#DIM ALL
FUNCTION PBMAIN() AS LONG
  LOCAL d AS DEC128
  LOCAL e AS DEC128
  LOCAL r AS DOUBLE

  ' Convert 1.5 into DEC128
  DEC128_FROM_DOUBLE(1.5, VARPTR(d))

  ' Convert back to DOUBLE and print
  r = DEC128_TO_DOUBLE(VARPTR(d))
  PRINT "DEC128(1.5)="; r

  ' Add two DEC128 values
  DEC128_FROM_DOUBLE(2.5, VARPTR(e))
  DEC128_ADD(VARPTR(d), VARPTR(e), VARPTR(d))
  r = DEC128_TO_DOUBLE(VARPTR(d))
  PRINT "DEC128(1.5+2.5)="; r

  FUNCTION = 0
END FUNCTION

Erwartete Ausgabe:

DEC128(1.5)=1.5
DEC128(1.5+2.5)=4

Siehe auch

  • RATIONAL
  • CINT / CLNG / CDBL
  • GRUNDLEGENDE mathematische Funktionen

Kind: Reference topic | Category: Math / Numeric Datatypes

PBXB64 Status: AVAILABLE

Description

DEC128 is the documented 16-byte decimal numeric surface. Use the conversion helpers shown on this page and keep tests focused on exact conversion and arithmetic behavior.

Syntax

LOCAL value AS DEC128

Validation Evidence

Validation evidence: DEC128 examples and conversion helper pages provide the current executable evidence.

Example

LOCAL value AS DEC128
DEC128_FROM_DOUBLE(1.5, VARPTR(value))

See Also

  • cmd_rational.html
  • basic_ref_math.html

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


DECR – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DECR

DECR

Dekrementieren Sie a

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DECR variable

Beschreibung

Variable kann eine numerische Variable oder eine Zeigervariable sein. Wenn DECR mit einer numerischen Variablen verwendet wird, wird 1 von der numerischen Variablen subtrahiert.

Wenn DECR für das Ziel einer numerischen Zeigervariablen verwendet wird (d. h. DECR @IntPtr), wird die numerische Zielvariable um eins dekrementiert. Wenn Sie DECR jedoch für eine Zeigervariable verwenden, wird der Wert der Zeigervariablen um die Größe ihres Ziels dekrementiert.

Wenn beispielsweise ein Zeiger auf Element 1000 eines Integer-Arrays gegeben ist, würde die DECR der Zeigervariablen selbst zu einem Dekrement von 2 führen, das auf das vorherige Element im Array (Element 999) zeigen sollte. Dies liegt daran, dass eine Ganzzahl zwei Bytes breit ist, sodass der Zeigerwert um 2 Bytes reduziert wird.

Siehe auch

  • INCR
  • LET

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


%DEF – PBXB64-Compiler-Hilfe

Startseite › Funktionen › %DEF

%DEF

Bestimmen Sie, ob ein Gleichwertig ist

Typ:Betreiber |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

%DEF({ %numeric_equate | $string_equate })

Beschreibung

Der %DEF-Operator testet, ob ein Equate definiert wurde oder nicht. Wenn das Equate definiert wurde, gibt %DEF TRUE (ungleich Null) zurück. oder FALSE (Null), wenn es nicht definiert wurde.

PowerBASIC definiert automatisch die Equates in der folgenden Tabelle entsprechend dem verwendeten PowerBASIC-Compiler. Bitte beachten Sie, dass die Verweise auf andere PowerBASIC-Compiler für diejenigen enthalten sind, die Programme schreiben, die möglicherweise von mehr als einem PowerBASIC-Compiler kompilierbar sind.

Gleichsetzen

Definition

%PB_CC32

In PB/CC für Windows als TRUE (ungleich Null) vordefiniert, in anderen Compilern jedoch nicht definiert.

%PB_DLL16

In PB/DLL 16-Bit als TRUE (ungleich Null) vordefiniert, in anderen Compilern jedoch nicht definiert.

%PB_DLL32

Synonym von %PB_WIN32

%PB_WIN32

In PB/Win 32-Bit als TRUE (ungleich Null) vordefiniert, in anderen Compilern jedoch nicht definiert.

%PB_REVISION

Vordefiniert als Hex-Revision (10.00 = &H1000).

%PB_REVLETTER

Vordefiniert als ASCII-Code des Revisionsbuchstabens (a = &H61) oder &H20, wenn kein Revisionsbuchstabe vorhanden ist.

%PB_EXE

Vordefiniert als TRUE (ungleich Null) beim Kompilieren in EXE oder als FALSE (Null) beim Kompilieren im DLL- (nur PB/Win) oder SLL-Format.

Das Äquator %PB_EXE ist in PowerBASIC immer definiert, daher wird %DEF(%PB_EXE) immer als TRUE ausgewertet. Der Unterschied ist der Wert, der dem Equate vom Compiler zugewiesen wird. Sehen Sie sich die Beispiele unten an.

Diese können in Verbindung mit #IF als Compiler-Direktive verwendet werden, um selektiv Code in die kompilierte Datei einzuschließen oder daraus auszuschließen.

Siehe auch

  • #IF
  • Numerische Gleichungen
  • Built-in numeric equates
  • String entspricht
  • Built-in string equates

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Standard-Variablentypisierung – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Standard-Variablentypisierung

Standardmäßige Variablentypisierung

In den meisten älteren Versionen von BASIC (einschließlich PowerBASIC für DOS) werden alle Variablen ohne TypeID (%, !, & usw.) automatisch als Gleitkommavariablen mit einfacher Genauigkeit betrachtet. Andere Compiler haben

Typ:Schlüsselwort |Kategorie:Variablen und Umfang

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Um diese Mehrdeutigkeit zu vermeiden, fordert PowerBASIC Sie stattdessen auf, diese Entscheidung zu treffen. Mit der DEF-Anweisung können Sie Ihren bevorzugten Standardvariablentyp angeben, der auf untypisierte Variablennamen angewendet werden soll. Um beispielsweise die Standardeinstellung mit einfacher Genauigkeit von PB/DOS nachzuahmen, fügen Sie einfach eine DEFSNG-Anweisung am Anfang Ihres Programms hinzu:

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


DEFBYT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DEFBYT

DEFBYT

Deklarieren Sie den Standardtyp für

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DEFtype letter_range [, letter_range ] [, ...]

Beschreibung

Typ stellt einen der Variablentypen von PowerBASIC dar: INT (Ganzzahl), LNG (Lange Ganzzahl), QUD (Quad-Ganzzahl), SNG (Gleitkomma mit einfacher Genauigkeit), DBL (Gleitkomma mit doppelter Genauigkeit), EXT (Gleitkomma mit erweiterter Genauigkeit), CUR (Währung), CUX (Erweiterte Währung), STR (Zeichenfolge), BYT (Byte), WRD (Wort) und DWD (Doppelwort). ).

Buchstabenbereich

ist entweder ein einzelnes alphabetisches Zeichen (A bis Z, Groß- und Kleinschreibung spielt keine Rolle) oder eine Reihe von Buchstaben (zwei durch einen Bindestrich getrennte Buchstaben, zum Beispiel A-M).

DEF-Typ

Teilt dem Compiler mit, dass Variablen und benutzerdefinierte Funktionen, deren Namen mit dem angegebenen Buchstaben oder Buchstabenbereich beginnen, vom angegebenen Typ sind.

Wenn der Compiler einen Variablennamen ohne Typspezifizierer findet, wird normalerweise ein Fehler bei der Kompilierung generiert. Wenn jedoch eine vorangehende Anweisung vom Typ DEF wie DEFINT A-Z vorhanden wäre, würde die Variable standardmäßig diesen Typ verwenden (in diesem Fall eine Integer-Variable).

Sie können mehrere Anweisungen vom Typ DEF verwenden. Wenn es eine Überschneidung zwischen zwei Anweisungen vom Typ DEF gibt, wird kein Fehler generiert. aber die Definition der letztgenannten Anweisung vom Typ DEF überschreibt die erstere, wenn sich die beiden überschneiden.

Die Anweisung vom Typ DEF wird in zukünftigen Editionen von PowerBASIC möglicherweise nicht mehr unterstützt. Daher empfehlen wir explizite Variablendeklarationen mit DIM, INSTANCE, LOCAL, STATIC, THREADED oder GLOBAL.

Einschränkungen

Der Def-Typ gilt nur für implizit definierte Variablen. Es hat keine Auswirkung auf Variablen, die explizit definiert sind. Wenn in der Anwendung eine #DIM ALL-Anweisung vorhanden ist, haben Deftype-Anweisungen keine Auswirkung. #DIM ALL erfordert, dass alle Variablen explizit definiert werden

Beispiele

DEFINT A-E, G, Q, Y-Z
DEFCUX B, F, H-P, R-X
FUNCTION PBMAIN
A = 1 ' A is Integer
B = 2 ' B is Extended-currency.
[ statements ]
END FUNCTION

Siehe auch

  • #DIM ALLE
  • DIM
  • INSTANCE
  • LOCAL
  • STATIC
  • GEWINDE
  • GLOBAL

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Konstanten definieren – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Konstanten definieren

Konstanten definieren

PB/Win-Konstanten (auch Equates genannt) werden definiert, indem dem Namen der Konstante ein „%“-Zeichen vorangestellt wird. MSBASIC und VB definieren Konstanten mit dem Schlüsselwort CONST. Der MSBASIC/VB-Compiler erledigt dies dann

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Die MACRO-Funktionen in PB/Win bieten jedoch eine Möglichkeit, die CONST-Syntax in Ihrem Code beizubehalten und gleichzeitig den Vorteil des geringen Overheads von PowerBASIC beizubehalten. Zum Beispiel:

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


Definieren benutzerdefinierter Typen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Benutzerdefinierte Typen definieren
Hilfe zum PBXB64-Compiler

Definieren benutzerdefinierter Typen

Die Definition eines benutzerdefinierten Typs beginnt mit dem reservierten Wort TYPE und endet mit den Schlüsselwörtern END TYPE. Dazwischen definieren Sie die Namen und Datentypen der Mitgliedselemente (Felder), die t sind

Typ:Schlüsselwort |Kategorie:Typen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

LastName AS STRING * 20 ' Eine 20-stellige Zeichenfolge

FirstName AS STRING * 15 ' Eine 15-stellige Zeichenfolge

IDnum AS LONG ' Studenten-ID, eine lange Ganzzahl

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


DELAY - PBXB64 Help

Startseite › General Reference › DELAY

DELAY

Unterbricht die Ausfuehrung fuer die angeforderte Anzahl Millisekunden und liefert nach dem Warten 0 zurueck.

Kind: PowerBASIC feature | Category: PowerBASIC / Tested Feature

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result& = DELAY(milliseconds&)

Beschreibung

Diese Seite beschreibt das PBXB64-Verhalten, das durch die aktuelle Validierungsmatrix abgedeckt ist. Verwenden Sie die hier gezeigte Syntax fuer Regressionstests; weitergehende PowerBASIC-Formen gelten als separate Kompatibilitaetsarbeit, sofern keine andere Seite sie dokumentiert.

Unterstuetzter Umfang

Die dokumentierte Teilmenge ist absichtlich genau: Beispiele verwenden bevorzugt skalare LONG-Werte, Array-Beispiele benutzen normale PB-logische Indizes, und laufzeitabhaengige Operationen sollen immer den Rueckgabestatus pruefen. Wenn ein Feature sowohl Anweisungs- als auch Funktionsschreibweise besitzt, beschreibt diese Seite den funktionsorientierten Seiteneintrag und verweist auf die breitere BASIC-Referenz.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    IF DELAY(30) <> 0 THEN FUNCTION = 1
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_delay_run_sysinfo.pb`; it proves `DELAY(0)`, a nonzero delay, und the `RUN`/`SYSINFO` bridge used by the current validation lane.

Fuer Release-Arbeiten sollte jede Syntaxform einen kleinen ausfuehrbaren Test besitzen. Ein guter Test initialisiert alle Eingaben, fuehrt den dokumentierten Befehl oder die Funktion aus, prueft das exakte Ergebnis und liefert bei Fehler einen von Null verschiedenen Exit-Code. Dadurch bleiben Hilfeaussagen an reproduzierbares Verhalten eines isolierten PBXB64-Compilers gebunden.

Grenzen

Nicht gezeigte PowerBASIC-Varianten duerfen aus dieser Seite nicht als unterstuetzt abgeleitet werden. Formen, die hier nicht stehen, benoetigen eigene Implementierung, Diagnostik, Tests und Hilfetext, bevor sie als abgeschlossen beschrieben werden.

Siehe auch

  • BASIC Language Reference
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


DESKTOP GET CLIENT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DESKTOP GET CLIENT

DESKTOP-CLIENT ERHALTEN

Rufen Sie die Größe des Clientbereichs des Desktops ab, in

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DESKTOP GET CLIENT TO ncWidth& , ncHeight&

Beschreibung

Die Größe des Desktop-Clients ist der Teil des Bildschirms, der nicht von der Taskleiste verdeckt wird.

Dies kann in Kombination mit DESKTOP GET LOC oder DESKTOP GET SIZE zur exakten Positionierung von Fenstern auf dem Desktop verwendet werden.

Siehe auch

  • Dynamic Dialog Tools
  • DESKTOP GET LOC
  • DESKTOP-GRÖSSE ERHALTEN

UI-Prüfung

Dialog- und Control-Seiten sollen das Control erzeugen, den dokumentierten Befehl anwenden und den geänderten Zustand über Getter, Notification oder sichtbares Ergebnis prüfen. Prüfen Sie Handle-Gültigkeit, bevor Nachrichten gesendet werden.

Nachrichten- und Lebensdauerregeln

Dokumentieren Sie Besitzerfenster, Control-ID, Lebensdauer von Child-Handles und ob der Befehl vor oder nach dem Anzeigen des Dialogs gültig ist.

x64-Hinweise

Verwenden Sie zeigergroße Handles und speichern Sie HWND, HDC oder Callback-Zeiger nicht in 32-Bit-Variablen.


DESKTOP GET LOC – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DESKTOP GET LOC

DESKTOP GET LOC

Rufen Sie die Position der oberen linken Ecke des Clientbereichs des Desktops ab

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DESKTOP GET LOC TO x& , y&

Beschreibung

Der Desktop-Client-Bereich ist der Teil des Bildschirms, der nicht durch die Taskleiste verdeckt wird. Die Position der Taskleiste auf dem Bildschirm bestimmt die obere linke Position des Clientbereichs. Wenn sich das Fach am unteren Bildschirmrand befindet (Standard), sind die linken und oberen Koordinaten 0,0. Wenn sich das Fach auf der rechten Seite des Bildschirms befindet, sind die linken und oberen Koordinaten 0,0. Wenn sich das Fach auf der linken Seite des Bildschirms befindet, lauten die linken und oberen Koordinaten TrayWidth,0. Wenn sich das Fach oben auf dem Bildschirm befindet, sind die linken und oberen Koordinaten 0,TrayHeight.

Dies kann in Kombination mit DESKTOP GET CLIENT oder DESKTOP GET SIZE zur exakten Positionierung von Fenstern auf dem Desktop verwendet werden.

Siehe auch

  • DESKTOP-CLIENT ERHALTEN
  • DESKTOP-GRÖSSE ERHALTEN

UI-Prüfung

Dialog- und Control-Seiten sollen das Control erzeugen, den dokumentierten Befehl anwenden und den geänderten Zustand über Getter, Notification oder sichtbares Ergebnis prüfen. Prüfen Sie Handle-Gültigkeit, bevor Nachrichten gesendet werden.

Nachrichten- und Lebensdauerregeln

Dokumentieren Sie Besitzerfenster, Control-ID, Lebensdauer von Child-Handles und ob der Befehl vor oder nach dem Anzeigen des Dialogs gültig ist.

x64-Hinweise

Verwenden Sie zeigergroße Handles und speichern Sie HWND, HDC oder Callback-Zeiger nicht in 32-Bit-Variablen.


DESKTOP-GET-GRÖSSE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DESKTOP GET SIZE

DESKTOP-GRÖSSE ERHALTEN

Rufen Sie die Größe des gesamten Desktops ab

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DESKTOP GET SIZE TO ncWidth& , ncHeight&

Beschreibung

Die Desktopgröße umfasst den von der Taskleiste eingenommenen Platz und entspricht der Bildschirmgröße. Dies kann in Kombination mit DESKTOP GET CLIENT oder DESKTOP GET LOC zur exakten Positionierung von Fenstern auf dem Desktop verwendet werden.

Siehe auch

  • DESKTOP-CLIENT ERHALTEN
  • DESKTOP GET LOC

UI-Prüfung

Dialog- und Control-Seiten sollen das Control erzeugen, den dokumentierten Befehl anwenden und den geänderten Zustand über Getter, Notification oder sichtbares Ergebnis prüfen. Prüfen Sie Handle-Gültigkeit, bevor Nachrichten gesendet werden.

Nachrichten- und Lebensdauerregeln

Dokumentieren Sie Besitzerfenster, Control-ID, Lebensdauer von Child-Handles und ob der Befehl vor oder nach dem Anzeigen des Dialogs gültig ist.

x64-Hinweise

Verwenden Sie zeigergroße Handles und speichern Sie HWND, HDC oder Callback-Zeiger nicht in 32-Bit-Variablen.


DIALOG DEAKTIVIEREN – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › DIALOG DISABLE

DIALOG DEAKTIVIEREN

Deaktivieren Sie einen Dialog, sodass er keine Maus oder Tastatur mehr empfängt

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG DISABLE hDlg

Beschreibung

hDlg bezieht sich auf den Dialog, den Sie deaktivieren möchten. Ein deaktivierter Dialog erhält keine Meldungen, wenn er mit der Maus angeklickt oder mit der Tastatur ausgewählt wird. Das Deaktivieren eines bereits deaktivierten Dialogs hat keine Auswirkung.

Wenn der Dialog über eine Rückruffunktion verfügt, wird eine %WM_ENABLE-Nachricht an die Rückruffunktion gesendet, bevor DIALOG DISABLE abgeschlossen ist.

Siehe auch

  • Dynamic Dialog Tools
  • DIALOG AKTIVIEREN
  • DIALOG AUSblenden
  • DIALOG NORMALISIEREN
  • DIALOGMODAL ANZEIGEN
  • DIALOG ZEIGEN MODELLLOS
  • DIALOG STATUS ANZEIGEN

PBXB64-Umsetzungshinweise

DIALOG DEAKTIVIEREN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG DEAKTIVIEREN ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG DEAKTIVIEREN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG DOEVENTS – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › DIALOG DOEVENTS

DIALOGVERANSTALTUNGEN

Prozess ausstehendes Fenster oder Dialog

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG DOEVENTS [ sleep& ] [TO count& ]

Beschreibung

DIALOG DOEVENTS wird normalerweise verwendet, um eine „Nachrichtenpumpe“ für modale Dialogfelder zu erstellen.

Wenn eine Fenstermeldung ansteht, wird diese entsprechend verarbeitet. Wenn keine Nachrichten ausstehen, wird die Ausführung des aktuellen Threads für die durch den Parameter „sleep&“ angegebene Zeit angehalten. Wenn „sleep&“ den Wert Null (0) hat, wird der Rest der aktuellen Zeitscheibe anderen Threads oder Prozessen überlassen. Wenn „sleep&“ größer als Null ist, wird der aktuelle Thread für diese Anzahl von Millisekunden angehalten, damit andere Threads oder Prozesse fortfahren können. Wenn „sleep&“ nicht angegeben ist, wird standardmäßig der Wert eins (1) verwendet. Während der Ruhephase werden alle Zeitscheiben für den aktuellen Thread an andere Threads und Prozesse weitergegeben. Wenn keine anderen Threads mit gleicher Priorität vorhanden sind, wird die Ausführung sofort fortgesetzt. Die Zeitscheibendauer (auch Quantum genannt) kann von Version zu Windows-Version variieren und zwischen 20 mSek und 120 mSek liegen. Wenn die optionale TO-Klausel enthalten ist, wird die Anzahl der aktiven Dialoge in der Variable count& zurückgegeben, sobald alle anstehenden Nachrichten verarbeitet wurden.

Einschränkungen

Die DIALOG DOEVENTS-Schleife muss für die Dauer der modalen Dialoge ausgeführt werden, sonst reagieren sie nicht oder werden nicht korrekt neu gezeichnet.

Siehe auch

  • Dynamic Dialog Tools
  • DIALOG NEU
  • DIALOG ZEIGEN MODELLLOS
  • SCHLAF

PBXB64-Umsetzungshinweise

DIALOGVERANSTALTUNGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOGVERANSTALTUNGEN ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOGVERANSTALTUNGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG ENABLE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOG ENABLE

DIALOG AKTIVIEREN

Aktivieren Sie einen Dialog, damit er empfangen kann

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG ENABLE hDlg

Beschreibung

hDlg bezieht sich auf den Dialog, den Sie aktivieren möchten. Ein aktivierter Dialog erhält Meldungen, wenn er mit der Maus angeklickt oder mit der Tastatur ausgewählt wird. Das Aktivieren eines Dialogs hat keine Auswirkung, wenn der Dialog bereits aktiviert ist.

Wenn der Dialog über eine Rückruffunktion verfügt, wird vor Abschluss von DIALOG ENABLE eine %WM_ENABLE-Nachricht an die Rückruffunktion gesendet.

Siehe auch

  • Dynamic Dialog Tools
  • DIALOG DEAKTIVIEREN
  • DIALOG AUSblenden
  • DIALOG NORMALISIEREN
  • DIALOGMODAL ANZEIGEN
  • DIALOG ZEIGEN MODELLLOS
  • DIALOG STATUS ANZEIGEN

PBXB64-Umsetzungshinweise

DIALOG AKTIVIEREN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG AKTIVIEREN ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG AKTIVIEREN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG END – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › DIALOG END

DIALOG END

Schließen und zerstören Sie den angegebenen Dialog.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG END hDlg [, lResult& ]

Beschreibung

Der durch die Variable hDlg angegebene Dialog wird zerstört.

lResult& gibt optional einen Wert an, der an die DIALOG SHOW MODAL- oder DIALOG SHOW MODELESS-Anweisung zurückgegeben werden soll, die den Dialog ursprünglich aktiviert hat.

Einschränkungen

DIALOG END kann einen Dialog in einem separaten Thread nicht schließen oder zerstören. Senden oder posten Sie in diesem Fall eine Nachricht an den Dialog, um ihm das Schließen zu signalisieren, und antworten Sie auf die Nachricht im Rückruf für den angegebenen Dialog. Zum Beispiel:

' Löst ein DIALOG END in einem separaten Thread aus

DIALOG SEND hDlg, %WM_SYSCOMMAND, %SC_CLOSE, 0

DIALOG END kann während der Verarbeitung der %WM_INITDIALOG-Nachricht nicht verwendet werden. Wenn dieser Effekt erforderlich ist, besteht die Lösung darin, eine benutzerdefinierte Nachricht an den Dialog zu senden und an dieser Stelle DIALOG END zu verwenden. Zum Beispiel:

CALLBACK-FUNCTION MyDialogCallback

SELECT CASE CB.MSG

CASE %WM_INITDIALOG

IF gMustEnd& THEN _ ' Wir müssen aufhören!

DIALOGPOST CB.HNDL, %WM_USER+999&, 0, 0

CASE %WM_USER + 999&

DIALOGENDE CB.HNDL

FUNCTION = 1

END AUSWÄHLEN

ENDFUNKTION

Siehe auch

  • Dynamic Dialog Tools
  • DIALOG NEU
  • DIALOG ZEIGEN MODELLLOS
  • THREAD CREATE

PBXB64-Umsetzungshinweise

DIALOG END gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG END ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG END mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG-STANDARDSCHRIFTART – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOG-STANDARDSCHRIFTART

DIALOG-STANDARDSCHRIFTART

Geben Sie den Standardwert an

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG DEFAULT FONT fontname$ [, points& , style& , charset& ]
DIALOG FONT [DEFAULT] fontname$ [, points& , style& , charset& ]

Beschreibung

Die DIALOG DEFAULT FONT-Anweisung gibt die Schriftart an, die für alle nachfolgenden mit DIALOG NEW erstellten Dialoge verwendet wird, bis eine weitere DIALOG DEFAULT FONT-Anweisung ausgeführt wird. Wenn eine DIALOG NEW-Anweisung ausgeführt wird, wird ihr die ausgewählte Standardschriftart und ihre vhild-Steuerelemente für die gesamte Lebensdauer des Dialogs zugeordnet.

Die Standardschriftart ist besonders wichtig, wenn Sie neue Dialoge erstellen, die Dialogeinheiten (anstelle von Pixeln) als Maßeinheit verwenden. Bei der Größenangabe in Dialogeinheiten berechnet Windows die physische Größe des Fensters unter anderem anhand der Schriftgröße. Durch eine spätere Änderung der Schriftgröße wird die Fenstergröße nicht aktualisiert.

Sie können den Wert Null (0) für jeden der numerischen Parameter verwenden, um anzugeben, dass der Compiler den Standardwert für dieses Element verwenden soll. Wenn Parameter fehlen, ersetzt der Compiler alle verbleibenden Parameter durch den Standardwert. Wenn keine DIALOG DEFAULT FONT-Anweisung ausgeführt wird, wählt PowerBASIC MS Sans Serif, 8 Punkt, ohne Stilattribute aus.

Bei der Angabe einer Schriftart sollte darauf geachtet werden, eine Standardschriftart zu verwenden, die in allen Windows-Versionen verfügbar ist, z. B. „Times New Roman“, „Arial“, „Courier“, „MS Sans Serif“ usw. Die Angabe eines Schriftartnamens, der nicht verfügbar ist, zwingt Windows dazu, eine Schriftart zu ersetzen, die möglicherweise optisch nicht ansprechend ist, und kann auch die relative Größe des Dialogfelds ändern.

DIALOG DEFAULT FONT ist modulspezifisch. Das heißt, es wirkt sich nur auf nachfolgende Dialoge aus, die durch Code in derselben EXE- oder DLL-Datei erstellt wurden. Beispielsweise hat eine DIALOG DEFAULT FONT-Anweisung in einer DLL keinen Einfluss auf Dialoge, die in der aufrufenden EXE-Datei oder anderen von der EXE-Datei geladenen DLLs erstellt wurden.

Siehe auch

  • STEUERUNG SET SCHRIFTART
  • Dynamic Dialog Tools
  • DIALOG NEU
  • DIALOG FARBE EINSTELLEN
  • SCHRIFTART END
  • SCHRIFTART NEU
  • GRAFIK-SET-SCHRIFTART
  • XPRINT SCHRIFTART EINSTELLEN

PBXB64-Umsetzungshinweise

DIALOG-STANDARDSCHRIFTART gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG-STANDARDSCHRIFTART ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG-STANDARDSCHRIFTART mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG GET CLIENT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOG GET CLIENT

DIALOG KUNDEN ERHALTEN

Geben Sie die zurück

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG GET CLIENT hDlg TO nWide& , nHigh&

Beschreibung

HDlg bezieht sich auf den zu untersuchenden Dialog. Die Größe des Dialog-Client-Bereichs wird in den Variablen nWide& (Breite) und nHigh& (Höhe) platziert. Die Größe wird in denselben Begriffen (Pixel oder Dialogeinheiten) wie der übergeordnete Dialog angegeben.

Siehe auch

  • Dynamisch
  • Dialogwerkzeuge
  • KONTROLLE KUNDEN ERHALTEN
  • DIALOG GET LOC
  • DIALOG GRÖSSE ERHALTEN
  • DIALOGPIXEL
  • DIALOGSET-CLIENT
  • DIALOG SET LOC
  • DIALOGGRÖSSE EINSTELLEN
  • DIALOGEINHEITEN

PBXB64-Umsetzungshinweise

DIALOG KUNDEN ERHALTEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG KUNDEN ERHALTEN ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG KUNDEN ERHALTEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG GET LOC – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOG GET LOC

DIALOG GET LOC

Gibt den Speicherort des angegebenen zurück

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG GET LOC hDlg TO x& , y&

Beschreibung

HDlg bezieht sich auf den zu untersuchenden Dialog. Die Position des Dialogs wird als relative Position in den Variablen x& (horizontale Position) und y& (vertikale Position) platziert. Wenn der Dialog mit der Option PIXELS in der DIALOG NEW-Anweisung erstellt wurde, werden die Werte in Pixeleinheiten zurückgegeben. Wenn die Option UNITS verwendet wurde (oder keine Skalierungsoption angegeben wurde), werden die Werte in Dialogeinheiten zurückgegeben.

[OBJECT]Wenn das [OBJECT]übergeordnete[OBJECT] des Dialogs Null (oder %HWND_DESKTOP) ist, ist die Position relativ zur oberen linken Ecke der Anzeige. Andernfalls ist es relativ zur oberen linken Ecke des Clientbereichs des übergeordneten Fensters.

Siehe auch

  • Dynamic Dialog Tools
  • DIALOG KUNDEN ERHALTEN
  • DIALOG GRÖSSE ERHALTEN
  • DIALOGPIXEL
  • DIALOG SET LOC
  • DIALOGGRÖSSE EINSTELLEN
  • DIALOGEINHEITEN

PBXB64-Umsetzungshinweise

DIALOG GET LOC gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG GET LOC ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG GET LOC mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG GET SIZE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOG GET SIZE

DIALOG GRÖSSE ERHALTEN

Gibt die Größe des angegebenen zurück

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG GET SIZE hDlg TO x& , y&

Beschreibung

HDlg bezieht sich auf den zu untersuchenden Dialog. Die Gesamtgröße des Dialogs wird in den Variablen x& (Breite) und y& (Höhe) abgelegt. Wenn der Dialog mit der Option PIXELS in der DIALOG NEW-Anweisung erstellt wurde, werden die Werte in Pixeleinheiten zurückgegeben. Wenn die Option UNITS verwendet wurde (oder keine Skalierungsoption angegeben wurde), werden die Werte in Dialogeinheiten zurückgegeben.

Siehe auch

  • Dynamic Dialog Tools
  • DIALOG KUNDEN ERHALTEN
  • DIALOG GET LOC
  • DIALOGPIXEL
  • DIALOG SET LOC
  • DIALOGGRÖSSE EINSTELLEN
  • DIALOGEINHEITEN

PBXB64-Umsetzungshinweise

DIALOG GRÖSSE ERHALTEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG GRÖSSE ERHALTEN ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG GRÖSSE ERHALTEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG GET TEXT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOG GET TEXT

DIALOG TEXT ERHALTEN

Rufen Sie den Text in a ab

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG GET TEXT hDlg TO titletext$

Beschreibung

Der Text des durch hDlg angegebenen Dialogs oder Fenstertitels. Bei DDT-Dialogen ist hDlg das Dialoghandle, das von der DIALOG NEW-Anweisung zurückgegeben wird. In einer Dialog-Callback-Funktion gibt die CB.HNDL-Funktion das übergeordnete Dialog-Handle zurück und dieses kann auch mit DIALOG GET TEXT verwendet werden.

Titeltext$

Der Text wird zurückgegeben und in die String-Variable titletext$ eingefügt. Wenn das Fenster oder der Dialog ungültig ist, wird titletext$ auf eine leere Zeichenfolge gesetzt.

Einschränkungen

hDlg ist ein Dialog- oder Fensterhandle, daher funktioniert DIALOG GET TEXT sowohl mit DDT-Dialogen als auch mit herkömmlichen Fenstern und Dialogen.

Siehe auch

  • CB Callback functions
  • CONTROL GET TEXT
  • STEUERUNG TEXT EINSTELLEN
  • DIALOG NEU
  • DIALOG TEXT EINSTELLEN

PBXB64-Umsetzungshinweise

DIALOG TEXT ERHALTEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG TEXT ERHALTEN ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG TEXT ERHALTEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG GET USER – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOG GET USER

DIALOG BENUTZER ERHALTEN

Rufen Sie einen Wert aus dem Benutzerdatenbereich von a ab

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG GET USER hDlg , index& TO retvar&

Beschreibung

Jeder DDT-Dialog verfügt über einen Benutzerdatenbereich, der aus acht Long-Integer-Werten besteht, die nach Ermessen des Programmierers zum Speichern relevanter Daten verwendet werden können. DIALOG GET USER ermöglicht das Abrufen eines der Werte basierend auf dem Indexparameterwert (1 bis 8).

hDlg bezieht sich auf den Dialog, der die Benutzerdaten enthält.

index& ist die Indexnummer des abzurufenden Benutzerdatenwerts im Bereich von 1 bis einschließlich 8.

retvar& empfängt den Long-Integer-Datenwert, der im angegebenen Benutzerdatenindex gespeichert ist.

Einschränkungen

Bei der Zerstörung des Dialogs gehen Daten im Benutzerdatenbereich verloren. Der Datenbereich ist vollständig vom von Windows verwalteten %GWL_USERDATA-Bereich getrennt.

Siehe auch

  • Dynamic Dialog Tools
  • COMBOBOX SET BENUTZER
  • KONTROLLE GET BENUTZER
  • STEUERUNG BENUTZER EINSTELLEN
  • DIALOG SET BENUTZER
  • LISTBOX BENUTZER ERHALTEN
  • LISTBOX SET BENUTZER
  • LISTVIEW GET USER
  • LISTVIEW SET BENUTZER
  • TREEVIEW GET USER
  • TREEVIEW SET BENUTZER

PBXB64-Umsetzungshinweise

DIALOG BENUTZER ERHALTEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG BENUTZER ERHALTEN ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG BENUTZER ERHALTEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG HIDE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOG HIDE

DIALOG AUSblenden

Machen Sie ein

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG HIDE hDlg

Beschreibung

Der durch das Handle hDlg identifizierte Dialog wird unsichtbar gemacht.

Siehe auch

  • STEUERUNG AUSblenden
  • STEUERUNG NORMALISIEREN
  • DIALOG MAXIMIEREN
  • DIALOG MINIMIEREN
  • DIALOG NORMALISIEREN

UI-Prüfung

Dialog- und Control-Seiten sollen das Control erzeugen, den dokumentierten Befehl anwenden und den geänderten Zustand über Getter, Notification oder sichtbares Ergebnis prüfen. Prüfen Sie Handle-Gültigkeit, bevor Nachrichten gesendet werden.

Nachrichten- und Lebensdauerregeln

Dokumentieren Sie Besitzerfenster, Control-ID, Lebensdauer von Child-Handles und ob der Befehl vor oder nach dem Anzeigen des Dialogs gültig ist.

x64-Hinweise

Verwenden Sie zeigergroße Handles und speichern Sie HWND, HDC oder Callback-Zeiger nicht in 32-Bit-Variablen.

PBXB64-Umsetzungshinweise

DIALOG AUSblenden gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG AUSblenden ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG AUSblenden mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG MAXIMIZE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOG MAXIMIEREN

DIALOG MAXIMIEREN

Maximieren Sie a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG MAXIMIZE hDlg

Beschreibung

Der durch das Handle hDlg identifizierte Dialog wird maximiert. Mit DIALOG NORMALIZE können Sie den Dialog in seinen Normalzustand zurückversetzen.

Siehe auch

  • STEUERUNG AUSblenden
  • STEUERUNG NORMALISIEREN
  • CONTROL SET-GRÖSSE
  • DIALOG MINIMIEREN
  • DIALOG NORMALISIEREN
  • DIALOGGRÖSSE EINSTELLEN

UI-Prüfung

Dialog- und Control-Seiten sollen das Control erzeugen, den dokumentierten Befehl anwenden und den geänderten Zustand über Getter, Notification oder sichtbares Ergebnis prüfen. Prüfen Sie Handle-Gültigkeit, bevor Nachrichten gesendet werden.

Nachrichten- und Lebensdauerregeln

Dokumentieren Sie Besitzerfenster, Control-ID, Lebensdauer von Child-Handles und ob der Befehl vor oder nach dem Anzeigen des Dialogs gültig ist.

x64-Hinweise

Verwenden Sie zeigergroße Handles und speichern Sie HWND, HDC oder Callback-Zeiger nicht in 32-Bit-Variablen.

PBXB64-Umsetzungshinweise

DIALOG MAXIMIEREN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG MAXIMIEREN ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG MAXIMIEREN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG MINIMIEREN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOG MINIMIZE

DIALOG MINIMIEREN

Minimieren Sie a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG MINIMIZE hDlg

Beschreibung

Der durch das Handle hDlg identifizierte Dialog wird minimiert. Mit DIALOG NORMALIZE können Sie den Dialog in seinen Normalzustand zurückversetzen.

Siehe auch

  • STEUERUNG AUSblenden
  • STEUERUNG NORMALISIEREN
  • CONTROL SET-GRÖSSE
  • DIALOG MAXIMIEREN
  • DIALOG NORMALISIEREN
  • DIALOGGRÖSSE EINSTELLEN

UI-Prüfung

Dialog- und Control-Seiten sollen das Control erzeugen, den dokumentierten Befehl anwenden und den geänderten Zustand über Getter, Notification oder sichtbares Ergebnis prüfen. Prüfen Sie Handle-Gültigkeit, bevor Nachrichten gesendet werden.

Nachrichten- und Lebensdauerregeln

Dokumentieren Sie Besitzerfenster, Control-ID, Lebensdauer von Child-Handles und ob der Befehl vor oder nach dem Anzeigen des Dialogs gültig ist.

x64-Hinweise

Verwenden Sie zeigergroße Handles und speichern Sie HWND, HDC oder Callback-Zeiger nicht in 32-Bit-Variablen.

PBXB64-Umsetzungshinweise

DIALOG MINIMIEREN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG MINIMIEREN ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG MINIMIEREN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG NEU – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOG NEU

DIALOG NEU

Erstellen Sie einen neuen Dialog im Speicher, der zur Anzeige bereit ist.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG NEW [PIXELS, | UNITS,] hParent , title$ , [ x& ], [ y& ], xx& , yy& [, [ style& ] [, [ exstyle& ]]] [,] TO hDlg

Beschreibung

Ein neuer leerer Dialog wird erstellt, aber noch nicht angezeigt. Sobald der Dialog erstellt wurde und alle gewünschten Steuerelemente mit CONTROL ADD-Anweisungen hinzugefügt wurden, kann der Dialog mit den Anweisungen DIALOG SHOW MODELESS oder DIALOG SHOW MODAL angezeigt werden.

Wenn ein modaler Dialog erstellt wird, muss die Anwendung für die Dauer des Dialogs eine DIALOG DOEVENTS-Nachrichtenpumpe erstellen. Wenn keine Nachrichtenpumpe bereitgestellt wird, kann dies zu Unterbrechungen bei der Anzeige des Dialogs führen oder dazu, dass der Dialog nicht auf Nachrichten wie Tastenklicks usw. reagieren kann. Modale Dialoge erfordern keine Nachrichtenpumpe. Um den angezeigten Status eines Dialogs zu ändern (d. h. ausgeblendet, minimiert usw.), nachdem der Dialog erstellt wurde, verwenden Sie die DIALOG SHOW STATE-Anweisung.

Wenn ein Dialog weder über den %WS_CHILD- noch den %WS_POPUP-Stil verfügt, erzwingt Windows möglicherweise eine Mindestdialogbreite von etwa 60–70 Dialogeinheiten.

PIXEL

Wenn das Schlüsselwort PIXELS angegeben ist, werden alle Größen- und Positionsparameter in Pixel angegeben. In diesem Fall geben verwandte Anweisungen wie DIALOG GET LOC ebenfalls Werte in Pixeln zurück.

Wenn UNITS angegeben ist (oder keine Skalierungsoption angegeben ist), werden alle Größen- und Positionsparameter in Dialogeinheiten angegeben. (Standard)

DIALOG NEW übernimmt die folgenden Parameter.

hParent

Handle des übergeordneten Fensters oder Dialogs. Wenn kein übergeordnetes Element vorhanden ist, verwenden Sie Null (0) oder %HWND_DESKTOP. Wenn der Dialog MODAL ist, wird das übergeordnete Fenster/Dialogfeld deaktiviert, während dieser „untergeordnete“ Dialog ausgeführt wird.

Titel$

Der Text, der in der Titel- oder Beschriftungsleiste des Dialogs angezeigt wird.

x&, y&

Optionale Position der oberen linken Ecke für den Dialog. Der Speicherort wird in denselben Begriffen (Pixel oder Dialogeinheiten) angegeben, die in der DIALOG NEW-Anweisung angegeben sind. Wenn weder x& noch y& angegeben sind, wird der Dialog zentriert auf dem Bildschirm angezeigt.

Wenn %CW_USEDEFAULT (&H080000000) angegeben ist, wird die Standard-Windows-Position verwendet (Kaskadierung von der oberen linken Ecke).

xx&, yy&

Die Breite und Höhe des Dialogs. Die Größe wird in denselben Begriffen (Pixel oder Dialogeinheiten) angegeben wie in der DIALOG NEW-Anweisung.

Wenn der Standarddialogstil (oder ein anderer Dialogstil, der den %WS_CAPTION-Stil enthält) verwendet wird, geben die Parameter „Breite“ und „Höhe“ nur die Clientgröße an, und diese umfasst keine Beschriftungs- und Rahmenabmessungen.

Wenn der Stil %WS_CAPTION nicht enthält, geben Breite und Höhe die Gesamtgröße des Dialogs an, einschließlich der Beschriftung und des Rahmens, falls vorhanden.

Beachten Sie, dass %WS_CAPTION eine Kombination aus den Stilen %WS_BORDER und %WS_DLGFRAME ist. Der Standarddialogstil umfasst die Stile %WS_BORDER und %WS_DLGFRAME, also implizit den Stil %WS_CAPTION.

Stil&

Eine optionale Bitmaske, die beschreibt, wie der Dialog angezeigt werden soll. Der Standardstil von &H084C000D4& besteht aus %DS_3DLOOK, %DS_SETFONT, %DS_MODALFRAME, %DS_NOFAILCREATE, %WS_BORDER, %WS_CLIPSIBLINGS, %WS_DLGFRAME und %WS_POPUP. Wird verwendet, wenn der Parameter in der Anweisung vollständig weggelassen wurde. Zum Beispiel:

DIALOG NEU 0, „Dialogtitel“,,, 100, 200,, TO hDlg

Benutzerdefinierte Stilwerte ersetzen die Standardwerte. Das heißt, sie ergänzen nicht die Standardstilwerte – Ihr Code muss alle erforderlichen Stilparameter angeben (mit Ausnahme von %DS_NOFAILCREATE, %DS_SETFONT und %DS_3DLOOK, die von PowerBASIC automatisch zum Stil- und Parameter hinzugefügt werden).

Dies gilt auch für den Parameter „Extended Styles“ – wenn Ihr Code einen benutzerdefinierten Primärstil angibt, ist auch der standardmäßige erweiterte Stil nicht mehr wirksam. In diesem Fall muss möglicherweise auch ein expliziter erweiterter Stil zur DIALOG NEW-Anweisung hinzugefügt werden, wenn ein expliziter primärer Stil angegeben ist.

Der primäre Stil und Wert kann eine Kombination aus den folgenden Werten sein, kombiniert mit dem ODER-Operator, um eine Bitmaske zu bilden:

%DS_3DLOOK Geben Sie dem Dialogfeld eine nicht fette Schriftart und zeichnen Sie dreidimensionale Ränder um die Steuerelemente im Dialogfeld. Der %DS_3DLOOK-Stil ist nicht für Anwendungen erforderlich, die mit #OPTION VERSION4 oder #OPTION VERSION5 gekennzeichnet sind. da Windows automatisch das 3D-Erscheinungsbild anwendet. DDT-Dialoge werden immer mit diesem Stil erstellt. (Standard)

%DS_3DLOOK

Geben Sie dem Dialogfeld eine nicht fette Schriftart und zeichnen Sie dreidimensionale Ränder um die Steuerelemente im Dialogfeld. Der %DS_3DLOOK-Stil ist nicht für Anwendungen erforderlich, die mit #OPTION VERSION4 oder #OPTION VERSION5 gekennzeichnet sind. da Windows automatisch das 3D-Erscheinungsbild anwendet. DDT-Dialoge werden immer mit diesem Stil erstellt. (Standard)

%DS_ABSALIGN

Geben Sie an, dass die Koordinaten des Dialogfelds Bildschirmkoordinaten sind. Andernfalls geht Windows davon aus, dass es sich um Clientkoordinaten handelt.

%DS_CENTER

Zentrieren Sie das Dialogfeld im Arbeitsbereich (dem Bereich, der nicht von der Taskleiste und der Taskleiste verdeckt wird). Dies ist die Standardeinstellung, wenn x& und y& nicht angegeben sind.

%DS_CENTERMOUSE

Zentrieren Sie den Mauszeiger im Dialogfeld, wenn das Dialogfeld zum ersten Mal erstellt wird.

%DS_CONTEXTHELP

Fügen Sie ein Fragezeichen in die Titelleiste des Dialogfelds ein. Wenn der Benutzer auf das Fragezeichen klickt, verwandelt sich der Cursor in ein Fragezeichen mit einem Zeiger. Wenn der Benutzer dann auf ein Steuerelement im Dialogfeld klickt, erhält der Dialogrückruf eine %WM_HELP-Nachricht. Dieser Stil kann nicht mit den Stilen %WS_MAXIMIZEBOX und %WS_MINIMIZEBOX verwendet werden. Siehe auch %WS_EX_CONTEXTHELP.

%DS_CONTROL

Erstellen Sie einen Dialog, der als untergeordnetes Steuerelement eines anderen Dialogs fungiert und die Tastaturfokusschnittstelle über die beiden Dialoge hinweg glättet, wenn die TAB-Taste oder Steuerungsbeschleuniger verwendet werden. Wird normalerweise für Dialoge verwendet, die die „Seiten“ für Registerkartensteuerelemente und Eigenschaftenblätter bilden.

%DS_MODALFRAME

Erstellen Sie ein Dialogfeld mit einem modalen Dialogfeldrahmen, der mit einer Titelleiste und einem Systemmenü kombiniert werden kann, indem Sie die Stile %WS_CAPTION und %WS_SYSMENU angeben. (Standard)

%DS_NOFAILCREATE

Der Dialog wird unabhängig von Fehlern erstellt, die während der Erstellungsphase auftreten können. DDT-Dialoge werden immer mit diesem Stil erstellt. (Standard)

%DS_SETFONT

Die Schriftart, die von einem DDT-Dialog und seinen Steuerelementen verwendet werden soll, kann mit der DIALOG DEFAULT FONT-Anweisung vorab festgelegt werden. Wenn die DIALOG DEFAULT FONT-Anweisung nicht verwendet wird, wird die Standardschriftart (MS Sans Serif, 8 Punkt) verwendet. Die Größe der Dialogschriftart wirkt sich proportional auf die Konvertierung von Dialogeinheitenwerten in Pixel aus, sodass eine Erhöhung der Standardschriftgröße automatisch zu einem größeren Dialog führt, auch wenn die Dialogabmessungen konstant geblieben sind. Wenn untergeordnete Steuerelemente zu einem %DS_SETFONT-Dialog hinzugefügt werden, wird ihnen eine %WM_SETFONT-Nachricht gesendet, um sicherzustellen, dass sie auch die angegebene Dialogschriftart verwenden. DDT-Dialoge werden immer mit diesem Stil erstellt. (Standard)

%DS_SETFOREGROUND

Bringen Sie das Dialogfeld in den Vordergrund. Intern ruft Windows die SetForegroundWindow-API-Funktion für das Dialogfeld auf.

%DS_SYSMODAL

Erstellen Sie ein systemmodales Dialogfeld. Dieser Stil bewirkt, dass das Dialogfeld den %WS_EX_TOPMOST-Stil aufweist, hat ansonsten jedoch keine Auswirkung auf das Dialogfeld oder das Verhalten anderer Anwendungen und Fenster, wenn das Dialogfeld angezeigt wird.

%WS_BORDER

Erstellen Sie einen Dialog mit einem dünnen Rand.

%WS_CAPTION

Erstellen Sie einen Dialog mit einer Titelleiste. Enthält die Stile %WS_BORDER und %WS_DLGFRAME. Wenn dieser Stil verwendet wird, geben die Parameter xx& und yy& die Größe des Clientbereichs des Dialogs an; andernfalls geben sie die äußeren Abmessungen des Dialogs an. (Standard)

%WS_CHILD

Erstellen Sie einen untergeordneten Dialog. Kann nicht mit dem %WS_POPUP-Stil verwendet werden. Wird normalerweise mit %DS_CONTROL für die Registerkartensteuerung und Eigenschaftenblatt-„Seiten“ verwendet.

%WS_CLIPCHILDREN

Schließen Sie den von untergeordneten Steuerelementen eingenommenen Bereich aus, wenn auf dem Dialoghintergrund gezeichnet wird. FRAME- und LINE-Steuerelemente in einem Dialogfeld mit diesem Stil verwenden normalerweise den erweiterten Stil %WS_EX_TRANSPARENT, sodass der Hintergrund dieser Steuerelemente vom Dialogfeld gezeichnet wird, bevor die Steuerelemente gezeichnet werden. %WS_CLIPCHILDREN wird häufig verwendet, um das Flimmern beim Neuzeichnen zu reduzieren, wenn die Größe eines Dialogfelds im %WS_THICKFRAME-Stil geändert wird.

%WS_CLIPSIBLINGS

Untergeordnete Steuerelemente werden voneinander abgeschnitten (nicht überzeichnet), wenn das Dialogfenster neu gezeichnet wird. (Standard)

%WS_DISABLED

Erstellen Sie einen Dialog, der zunächst deaktiviert ist. Ein deaktivierter Dialog kann keine Eingaben vom Benutzer empfangen.

%WS_DLGFRAME

Erstellen Sie ein Fenster mit einem Rahmen im Stil, der normalerweise für Dialogfelder verwendet wird. (Standard)

%WS_HSCROLL

Der Dialog enthält eine horizontale Bildlaufleiste.

%WS_ICONIC

Erstellen Sie ein zunächst minimiertes Dialogfeld, genau wie der %WS_MINIMIZE-Stil.

%WS_MAXIMIZE

Erstellen Sie einen zunächst maximierten Dialog.

%WS_MAXIMIZEBOX

Erstellen Sie ein Dialogfeld mit der Schaltfläche „Maximieren“. Verwendung mit dem %WS_SYSMENU-Stil.

%WS_MINIMIZE

Erstellen Sie ein zunächst minimiertes Dialogfeld, genau wie der %WS_ICONIC-Stil.

%WS_MINIMIZEBOX

Erstellen Sie ein Dialogfeld mit der Schaltfläche „Minimieren“. Verwendung mit dem %WS_SYSMENU-Stil.

%WS_OVERLAPPED

Erstellen Sie ein überlappendes Fenster. Ein überlappendes Fenster hat eine Titelleiste (Beschriftung) und einen Rahmen. Synonym des veralteten Stils %WS_TILED.

%WS_OVERLAPPEDWINDOW

Kombinationsstil, der einen überlappenden Dialog erzeugt. Besteht aus den Stilen %WS_CAPTION, %WS_SYSMENU, %WS_THICKFRAME, %WS_MINIMIZEBOX, %WS_MAXIMIZEBOX und %WS_OVERLAPPED.

%WS_POPUP

Erstellen Sie einen Popup-Dialog. Bei alleiniger Verwendung wird ein flacher Dialog ohne Beschriftung oder Rahmen erstellt. Kombinieren Sie es mit %DS_MODALFRAME, um einen 3D-Rahmen zu erstellen. Ein Popup-Dialogfeld kann ein anderes Fenster oder Dialogfeld überlappen. (Standard)

%WS_POPUPWINDOW

Erstellen Sie ein Popup-Dialogfeld, jedoch mit Rahmen und Systemmenü. Besteht aus %WS_BORDER, %WS_POPUP und %WS_SYSMENU. Kombinieren Sie %WS_POPUPWINDOW mit %WS_CAPTION, um das Fenstermenü sichtbar zu machen.

%WS_SYSMENU

Erstellen Sie ein Dialogfeld, dessen Titelleiste ein Systemmenüfeld enthält. Muss mit dem %WS_CAPTION-Stil verwendet werden.

%WS_THICKFRAME

Erstellen Sie einen Dialog mit einem Größenrahmen. Das heißt, die Größe des Dialogs kann geändert werden.

%WS_VSCROLL

Der Dialog enthält eine vertikale Bildlaufleiste. Siehe auch %WS_EX_LEFTSCROLLBAR.

exstyle&

Eine optionale Bitmaske im erweiterten Stil, die beschreibt, wie der Dialog angezeigt werden soll. Der standardmäßige erweiterte Dialogstil umfasst %WS_EX_LEFT mit %WS_EX_LTRREADING und %WS_EX_RIGHTSCROLLBAR. Der standardmäßige erweiterte Stil wird nur verwendet, wenn in der DIALOG NEW-Anweisung keine expliziten primären oder erweiterten Stilparameter vorhanden sind.

Ein expliziter erweiterter Stilwert kann eine Kombination der folgenden Werte sein, kombiniert mit dem OR-Operator, um eine Bitmaske zu bilden:

%WS_EX_ACCEPTFILES

Der Dialog akzeptiert Drag-and-Drop-Dateien. Die Dialog-Rückruffunktion empfängt eine %WM_DROPFILES-Nachricht, wenn Dateien im Dialog abgelegt wurden.

%WS_EX_APPWINDOW

Erzwingen Sie einen Dialog der obersten Ebene in der Anwendungs-Taskleiste, wenn das Fenster minimiert ist.

%WS_EX_CLIENTEDGE

Der Dialog hat einen Rand mit einer versunkenen Kante.

%WS_EX_CONTEXTHELP

Fügen Sie ein Fragezeichen in die Titelleiste des Dialogs ein. Wenn der Benutzer auf das Fragezeichen klickt, verwandelt sich der Cursor in ein Fragezeichen mit einem Zeiger. Wenn der Benutzer dann auf ein untergeordnetes Fenster klickt, erhält das untergeordnete Fenster eine %WM_HELP-Nachricht. Siehe auch %DS_CONTEXTHELP.

%WS_EX_CONTROLPARENT

Mit der TAB-Taste kann der Benutzer zwischen den untergeordneten Dialogen des Fensters navigieren. Siehe %DS_CONTROL.

%WS_EX_LEFT

Der Dialog verfügt über generische „linksbündige“ Eigenschaften. (Standard)

%WS_EX_LEFTSCROLLBAR

Falls vorhanden, wird die vertikale Bildlaufleiste links vom Clientbereich positioniert. Siehe auch %WS_VSCROLL.

%WS_EX_LTRREADING

Zeigen Sie den Dialogtext mithilfe der Leserichtungseigenschaften von links nach rechts an. (Standard)

%WS_EX_NOPARENTNOTIFY

Unterdrücken Sie %WM_PARENTNOTIFY-Meldungen, wenn ein Dialog erstellt oder zerstört wird.

%WS_EX_OVERLAPPEDWINDOW

Bestehend aus den Stilen %WS_EX_CLIENTEDGE und %WS_EX_WINDOWEDGE.

%WS_EX_PALETTEWINDOW

Bestehend aus den Stilen %WS_EX_WINDOWEDGE, %WS_EX_TOOLWINDOW und %WS_EX_TOPMOST.

%WS_EX_RIGHT

Dialog verfügt über generische „rechtsbündige“ Eigenschaften, die von der Fensterklasse abhängen. Dieser Stil hat nur dann eine Auswirkung, wenn die Shell-Sprache Hebräisch, Arabisch oder eine andere Sprache ist, die die Ausrichtung der Lesereihenfolge unterstützt. Andernfalls wird der Stil ignoriert.

%WS_EX_RIGHTSCROLLBAR

Falls vorhanden, wird die vertikale Bildlaufleiste rechts vom Clientbereich positioniert. Siehe %WS_VSCROLL. (Standard)

%WS_EX_RTLREADING

Wenn die Shell-Sprache Hebräisch, Arabisch oder eine andere Sprache ist, die die Ausrichtung der Leserichtung unterstützt, wird der Dialogtext mit den Eigenschaften der Leserichtung von rechts nach links angezeigt. Bei anderen Sprachen wird der Stil ignoriert.

%WS_EX_STATICEDGE

Dialog hat einen 3D-Rand. Wird hauptsächlich für Dialoge verwendet, die keine Benutzereingabe erfordern.

%WS_EX_TOOLWINDOW

Erstellen Sie ein Werkzeugfenster (ein Fenster, das als schwebende Symbolleiste verwendet werden soll). Ein Werkzeugfenster hat einen kürzeren Beschriftungsbereich als normal und die Dialogbeschriftung wird mit einer kleineren Schriftart gezeichnet. In der Taskleiste oder in dem Fenster, das erscheint, wenn der Benutzer ALT+TAB drückt, wird kein Toolfenster angezeigt. Bei den Hybridversionen von Windows (95/98/ME) muss dieser erweiterte Stil möglicherweise nach der Erstellung mithilfe der SetWindowLong-API-Funktion hinzugefügt werden.

%WS_EX_TOPMOST

Platzieren Sie den Dialog über allen nicht ganz oben liegenden Fenstern und lassen Sie ihn darüber, auch wenn der Dialog deaktiviert ist.

%WS_EX_TRANSPARENT

Steuerelemente/Fenster unterhalb des Dialogs werden gezeichnet, bevor der Dialog gezeichnet wird. Der Dialog gilt als transparent, da Elemente hinter dem Dialog bereits gezeichnet wurden – der Dialog selbst wird nicht anders gezeichnet. Echte Transparenz wird durch die Verwendung von Regionen erreicht – weitere Informationen finden Sie im MSDN.

%WS_EX_WINDOWEDGE

Der Dialog hat einen Rand mit einer erhöhten Kante.

Variable mit langer Ganzzahl, in der das Windows-Fensterhandle des Dialogs gespeichert wird, nachdem es von Windows erstellt und zugewiesen wurde. Dieses Handle sollte mit nachfolgenden DIALOG- und CONTROL-Anweisungen verwendet werden und kann direkt mit Windows-API-Aufrufen verwendet werden.

Wenn der Dialog nicht erstellt werden konnte (z. B. aufgrund geringer Windows-Ressourcen), wird Null zurückgegeben.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG HINZUFÜGEN
  • DIALOGVERANSTALTUNGEN
  • DIALOG END
  • DIALOG AUSblenden
  • DIALOG MAXIMIEREN
  • DIALOG MINIMIEREN
  • DIALOG NICHT STABIL
  • DIALOG NORMALISIEREN
  • DIALOG FARBE EINSTELLEN
  • DIALOGMODAL ANZEIGEN
  • DIALOG ZEIGEN MODELLLOS
  • DIALOG STABILISIEREN
  • DIALOG STATUS ANZEIGEN
  • TXT-Pseudoobjekt

PBXB64-Umsetzungshinweise

DIALOG NEU gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG NEU ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG NEU mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG NONSTABLE – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › DIALOG NONSTABLE

DIALOG NICHT STABIL

Machen Sie ein

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG NONSTABLE hDlg

Beschreibung

Der durch das Handle hDlg identifizierte Dialog wird instabil gemacht, d. h. er kann vom Benutzer geschlossen werden. Wenn ein Systemmenü vorhanden ist, sind die Schließoption und das Schließfeld aktiviert. Die Schließen-Taste ALT-F4 ist ebenfalls aktiviert. Dies ist der Standardbetriebsmodus.

Siehe auch

  • DIALOG STABILISIEREN

UI-Prüfung

Dialog- und Control-Seiten sollen das Control erzeugen, den dokumentierten Befehl anwenden und den geänderten Zustand über Getter, Notification oder sichtbares Ergebnis prüfen. Prüfen Sie Handle-Gültigkeit, bevor Nachrichten gesendet werden.

Nachrichten- und Lebensdauerregeln

Dokumentieren Sie Besitzerfenster, Control-ID, Lebensdauer von Child-Handles und ob der Befehl vor oder nach dem Anzeigen des Dialogs gültig ist.

x64-Hinweise

Verwenden Sie zeigergroße Handles und speichern Sie HWND, HDC oder Callback-Zeiger nicht in 32-Bit-Variablen.

PBXB64-Umsetzungshinweise

DIALOG NICHT STABIL gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG NICHT STABIL ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG NICHT STABIL mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG NORMALISIEREN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOG NORMALISIEREN

DIALOG NORMALISIEREN

Machen Sie ein

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG NORMALIZE hDlg

Beschreibung

Der durch das Handle hDlg gekennzeichnete Dialog wird in seiner normalen Größe und Position sichtbar gemacht.

Siehe auch

  • DIALOG AUSblenden
  • DIALOG MAXIMIEREN
  • DIALOG MINIMIEREN
  • DIALOG STATUS ANZEIGEN

UI-Prüfung

Dialog- und Control-Seiten sollen das Control erzeugen, den dokumentierten Befehl anwenden und den geänderten Zustand über Getter, Notification oder sichtbares Ergebnis prüfen. Prüfen Sie Handle-Gültigkeit, bevor Nachrichten gesendet werden.

Nachrichten- und Lebensdauerregeln

Dokumentieren Sie Besitzerfenster, Control-ID, Lebensdauer von Child-Handles und ob der Befehl vor oder nach dem Anzeigen des Dialogs gültig ist.

x64-Hinweise

Verwenden Sie zeigergroße Handles und speichern Sie HWND, HDC oder Callback-Zeiger nicht in 32-Bit-Variablen.

PBXB64-Umsetzungshinweise

DIALOG NORMALISIEREN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG NORMALISIEREN ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG NORMALISIEREN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOGPIXEL – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOGPIXEL

DIALOGPIXEL

Konvertieren Sie Pixel (Geräteeinheiten) in

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG PIXELS hDlg , x& , y& TO UNITS xx& , yy&

Beschreibung

Die in den Variablen x& und y& angegebenen Pixelwerte werden basierend auf der durch hDlg angegebenen Standardschriftart des Dialogs in Dialogeinheiten konvertiert. Der resultierende Wert in Dialogeinheiten wird in den Variablen xx& und yy& gespeichert.

Siehe auch

  • Dynamic Dialog Tools
  • KONTROLLE KUNDEN ERHALTEN
  • DIALOG KUNDEN ERHALTEN
  • DIALOG GET LOC
  • DIALOG GRÖSSE ERHALTEN
  • DIALOG SET LOC
  • DIALOGGRÖSSE EINSTELLEN
  • DIALOGEINHEITEN

PBXB64-Umsetzungshinweise

DIALOGPIXEL gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOGPIXEL ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOGPIXEL mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOGPOST – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOGPOST

DIALOGPOST

Platzieren Sie a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG POST hDlg , Msg& , wParam& , lParam&

Beschreibung

DIALOG POST stellt die Nachricht in die Nachrichtenwarteschlange und kehrt sofort zurück. Die Nachricht wird vom Dialog zu einem späteren Zeitpunkt verarbeitet, wenn er die Nachricht aus der Warteschlange liest.

Dieses Verhalten unterscheidet sich deutlich von der DIALOG SEND-Anweisung, die das Steuerelement dazu zwingt, die Nachricht unmittelbar vor der Rückgabe zu verarbeiten. Da es sich bei DIALOG POST um einen asynchronen Vorgang handelt, ist es nicht möglich, einen Rückkehrcode aus der Nachricht abzurufen.

hDlg bezieht sich auf den Zieldialog.

Msg& ist die Nachricht, die Sie im Dialog veröffentlichen möchten.

wParam& ist der erste Nachrichtenparameter. lParam& ist der zweite Nachrichtenparameter. Die Werte von wParam& und lParam& sind nachrichtenabhängig. Standardmäßig übergibt PowerBASIC diese Parameter BYVAL. Wenn erwartet wird, dass der Zieldialog die Werte der in den Parametern wParam& und lParam& übergebenen Variablen ändert, übergeben Sie sie mit VARPTR(), da die Änderungen sonst wahrscheinlich verworfen werden.

Beachten Sie, dass die Adresse der Daten gültig bleiben muss, bis der Dialog die Nachricht verarbeitet und auf die Daten zugegriffen hat. In diesem Fall kann die Verwendung von STATIC- oder GLOBAL-Variablen sehr wichtig sein, da sonst eine allgemeine Schutzverletzung (GPF) auftreten kann (d. h. wenn die Variablen zum Zeitpunkt der Verarbeitung der Nachricht den Gültigkeitsbereich verlassen haben).

Ein Beispiel für die Veröffentlichung der Adressen von Variablen in einem Dialog:

' Sel1& und Sel2& müssen STATIC oder GLOBAL sein

DIALOGPOST CB.HNDL, %WM_USER + 999&, VARPTR(Sel1&), VARPTR(Sel2&)

DIALOG POST kehrt sofort zurück, nachdem die Nachricht in die Warteschlange gestellt wurde.

Um eine benutzerdefinierte Nachricht in einem Dialog zu veröffentlichen, verwenden Sie einen Nachrichtenwert im Bereich von (%WM_USER + 500) bis (%WM_USER + &H07FFF) oder verwenden Sie die RegisterWindowMessage-API, um einen eindeutigen Nachrichtenwert vom Betriebssystem abzurufen. Die Verwendung von Nachrichten mit einem numerischen Wert kleiner als %WM_USER + 500 kann zu Konflikten mit Windows Common Control-Meldungen führen.

Siehe auch

  • Dynamic Dialog Tools
  • CB Callback functions
  • Kontrollposten
  • STEUERUNG SENDEN
  • DIALOG SENDEN

PBXB64-Umsetzungshinweise

DIALOGPOST gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOGPOST ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOGPOST mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG NEUZEICHNEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOG NEUZEICHNEN

DIALOG NEU ZEICHNEN

Signalisieren Sie eine bestimmte

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG REDRAW hDlg

Beschreibung

DIALOG REDRAW macht den Zieldialogbereich ungültig und signalisiert, dass ein Neuzeichnen/Neuzeichnen sofort erfolgt, selbst wenn ausstehende Nachrichten in der Nachrichtenwarteschlange vorhanden sind.

hDlg bezieht sich auf den Dialog, der neu gezeichnet werden soll.

Einschränkungen

Es wird nicht empfohlen, die Anweisungen DIALOG REDRAW oder CONTROL REDRAW innerhalb des %WM_PAINT und des zugehörigen Nachrichtenverarbeitungscodes zu verwenden, da sonst eine unendliche Neuzeichnungsschleife auftreten könnte.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERN SIE NEUZEICHNEN
  • STEUERUNG FARBE EINSTELLEN
  • DIALOG FARBE EINSTELLEN

PBXB64-Umsetzungshinweise

DIALOG NEU ZEICHNEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG NEU ZEICHNEN ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG NEU ZEICHNEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG SENDEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOG SENDEN

DIALOG SENDEN

Senden Sie eine

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG SEND hDlg , msg& , wParam& , lParam& [TO lResult& ]

Beschreibung

hDlg identifiziert den Dialog, der die durch msg& angegebene Nachricht empfangen soll. wParam& ist der erste Nachrichtenparameter und lParam& ist der zweite Nachrichtenparameter.

Standardmäßig übergibt PowerBASIC diese Parameter BYVAL. Wenn erwartet wird, dass der Zieldialog die in den Parametern wParam& und lParam& übergebenen Werte zurückgibt oder ändert, übergeben Sie sie mit VARPTR(), andernfalls werden die Rückgabewerte verworfen. Zum Beispiel:

DIALOG SENDEN CB.HNDL, %WM_USER, VARPTR(Param1&), VARPTR(Param2&)

Der Rückgabewert kann zurückgegeben und in der Variablen lResult& gespeichert werden, nachdem die Nachricht vom Dialog verarbeitet wurde.

Einschränkungen

Wenn der Zieldialog nicht vom selben Thread erstellt wurde, wird die DIALOG SEND-Anweisung blockiert, bis der Thread die Nachricht verarbeitet. Die InSendMessage-API-Funktion gibt TRUE (ungleich Null) zurück, wenn der Rückrufcode gerade eine Nachricht von einem separaten Thread verarbeitet.

Um eine benutzerdefinierte Nachricht an einen Dialog zu senden, verwenden Sie einen Nachrichtenwert im Bereich von (%WM_USER + 500) bis (%WM_USER + &H07FFF) oder verwenden Sie die RegisterWindowMessage-API, um einen eindeutigen Nachrichtenwert vom Betriebssystem zu erhalten.

Ein Dialogrückruf kann eine Nachricht an seinen eigenen Dialog senden, es sollte jedoch darauf geachtet werden, keine Endlosschleife zu erzeugen. Wenn DIALOG SEND eine Nachricht sendet, die im selben Rückruf zurückkommt, in dem die Nachricht ihren Ursprung hatte, sollte außerdem darauf geachtet werden, dass kritische STATIC- und GLOBAL-Variablen nicht unerwartet durch den zweiten Nachrichtenverarbeitungscode im Rückruf geändert werden. Dies wird als reentrant Code Design bezeichnet.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG SENDEN

PBXB64-Umsetzungshinweise

DIALOG SENDEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG SENDEN ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG SENDEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG SET CLIENT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOG SET CLIENT

DIALOGSET-CLIENT

Ändern Sie die Größe von a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG SET CLIENT hDlg , x& , y&

Beschreibung

hDlg bezieht sich auf das Handle des zu ändernden Dialogs. x& und y& geben die neue Breite und Höhe des Dialog-Client-Bereichs an. x& und y& werden in Dialogeinheiten oder Pixeln angegeben, je nachdem, welches System bei der Erstellung des Dialogs verwendet wurde.

Abhängig von der Art der verwendeten Rahmen kann die Größe des Dialog-Clients kleiner als die Gesamtgröße sein. Der Clientbereich ist der Teil unterhalb der Dialogüberschrift und ein eventuelles Menü, in dem Steuerelemente platziert werden können.

Siehe auch

  • Dynamic Dialog Tools
  • DIALOG NEU
  • DIALOGPIXEL
  • DIALOGEINHEITEN
  • DIALOG KUNDEN ERHALTEN
  • DIALOG GET LOC
  • DIALOG GRÖSSE ERHALTEN
  • DIALOG SET LOC
  • DIALOGGRÖSSE EINSTELLEN

PBXB64-Umsetzungshinweise

DIALOGSET-CLIENT gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOGSET-CLIENT ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOGSET-CLIENT mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG-SET-FARBE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOG FARBE EINSTELLEN

DIALOG FARBE EINSTELLEN

Legen Sie den Hintergrund fest

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG SET COLOR hDlg , foreclr& , backclr&

Beschreibung

HDlg identifiziert den Dialog, der eingefärbt werden soll.

Die Farbwerte foreclr& und backclr& müssen im Bereich von &H0 bis &H00FFFFFF liegen, während der Wert -1& zur Angabe der Systemstandardfarbe verwendet wird. RGB kann eine nützliche Funktion sein, um einen 32-Bit-Farbwert aus diskreten Rot-, Grün- und Blauwerten abzuleiten.

forcr&

In der aktuellen Implementierung von PowerBASIC wird der Dialog-Vordergrundfarbparameter foreclr& nicht verwendet, die Syntax wird jedoch für zukünftige Implementierungen beibehalten. Es wird empfohlen, den Vordergrundfarbparameter auf -1& zu setzen.

backclr&

Im Farbtiefenmodus mit 16 Bit oder mehr wird die angegebene RGB-Farbe verwendet, wenn der Hintergrund des Dialogfelds gezeichnet wird. Wenn backclr& = -1&, wird die Standardhintergrundfarbe des Dialogs verwendet. Wenn backclr& = -2&, wird der Dialoghintergrund nicht gezeichnet, sodass der Inhalt hinter dem Dialog durch den Dialog hindurch sichtbar wird.

Im Farbtiefenmodus mit 16 Bit oder mehr wird die angegebene RGB-Farbe verwendet, wenn der Hintergrund des Dialogfelds gezeichnet wird. Im 8-Bit-Modus (256 Farben) funktioniert das Farbsystem jedoch ganz anders. Hinter den Kulissen von Windows enthält die Basissystempalette normalerweise 20 Volltonfarben, die beim Zeichnen auf einem Dialoghintergrund nicht gedithert werden. Diese Volltonfarben eignen sich ideal für Hintergrundfarben bei DDT-Dialogen im 256-Farben-Modus.

Wenn umgekehrt ein nicht fester RGB-Farbwert verwendet wird, schwankt Windows (annähernd) bei der Farbe, um das Dialogfeld zu zeichnen, indem es Kombinationen aus zwei oder mehr Farben verwendet. Dies führt meist zu einem unerwünschten Mustereffekt.

Um diese Probleme im 256-Farben-Modus zu vermeiden, sollten Dialoge entweder mit einer der 20 Standard-Systemfarben (durchgehend) eingefärbt werden oder stattdessen die Standardfarbe verwendet werden. PowerBASIC enthält die folgenden 10 integrierten Funktionen, die bei der Auswahl einer Standard-Volltonfarbe helfen:

%RGB_BLACK %RGB_BLUE %RGB_GREEN %RGB_CYAN %RGB_RED

% RGB_ MAGENTA %RGB_YELLOW %RGB_WHITE %RGB_GRAY %RGB_LIGHTGRAY

Viele nicht standardmäßige Farben sind ebenfalls in den Compiler integriert. Eine vollständige Liste finden Sie im Thema „Integrierte RGB-Farbgleichungen“.

Wenn Sie die Farbe im 256-Farben-Modus lieber deaktivieren möchten, können Sie die Anzahl der Farben einfach mit dem folgenden Code testen:

' Anzahl der Farben bestimmen

LOKALES HDC ALS DWORD, iColors SO LANG

hDC = GetWindowDC(GetDeskTopWindow())

iColors = 2& ^ (GetDeviceCaps(hDC, %BITSPIXEL) * GetDeviceCaps(hDC, %PLANES))

ReleaseDC GetDeskTopWindow(), hDC

IF iColors > 256 THEN _

DIALOG SET FARBE hdlg, -1, RGB(0,100,192)

Im 256-Farben-Modus auf den meisten Computern können die Werte der standardmäßigen 20 Systemfarben ermittelt werden, indem die ersten und letzten 10 (0 bis 9 und 246 bis 255 einschließlich) Einträge von der GetSystemPaletteEntries-API-Funktion wie folgt angefordert werden:

' Array mit Volltonfarben füllen

DIM hDC ALS DWORD, Spalten SO LANG, x SO LANG

hDC = GetWindowDC(GetDesktopWindow)

Cols = GetDeviceCaps(hDC, %NUMRESERVED)

REDIM lp(1 TO Cols) SO LONG

x& = GetSystemPaletteEntries(hDC, 0, Cols \ 2, BYVAL VARPTR(lp(1)))

x& = GetSystemPaletteEntries(hDC, 256 - x&, Cols - x&, BYVAL VARPTR(lp(x& + 1)))

ReleaseDc GetDesktopWindow, hDC

' Array lp() enthält jetzt die Volltontabelle

Weitere Informationen zum Arbeiten mit Paletten im 256-Farben-Modus finden Sie in WIN32.HLP oder unter http://msdn.microsoft.com.

Beim dynamischen Ändern der Farben eines Dialogs innerhalb eines Rückrufs (d. h. nach der DIALOG SHOW-Anweisung) sollte auf eine DIALOG SET COLOR-Anweisung unmittelbar eine explizite DIALOG REDRAW-Anweisung folgen.

Ohne eine erzwungene Neuzeichnung des Dialogs wird die Änderung der Hintergrundfarbe des Dialogs für den Benutzer möglicherweise erst sichtbar, wenn der Dialog schließlich im normalen Verlauf der Benutzerinteraktion neu gezeichnet wird. Ein normales Repaint kann beispielsweise nur erfolgen, wenn der Dialog verdeckt wird und dann von einem anderen Fenster aufgedeckt wird. Durch die rechtzeitige Neugestaltung des Dialogs wird sichergestellt, dass der Dialog jederzeit ein aktuelles Erscheinungsbild behält.

Siehe auch

  • Built In RGB Color Equates
  • Dynamic Dialog Tools
  • STEUERN SIE NEUZEICHNEN
  • DIALOG NEU ZEICHNEN
  • STEUERUNG FARBE EINSTELLEN
  • DIALOGSET-SYMBOL

PBXB64-Umsetzungshinweise

DIALOG FARBE EINSTELLEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG FARBE EINSTELLEN ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG FARBE EINSTELLEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOGSATZ-SYMBOL – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOG SET ICON

DIALOGSET-SYMBOL

Ändern Sie beide

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG SET ICON hDlg , newicon$

Beschreibung

DIALOG SET ICON ändert sowohl das kleine Symbol (wie es in der Dialogtitelleiste verwendet wird) als auch das große Symbol (sichtbar in der Symbol-Aufgabenliste, die beim Umschalten zwischen ALT+TAB-Aufgaben angezeigt wird).

Handle des Dialogs, dessen Symbol geändert werden soll.

newicon$

Ein Zeichenfolgenausdruck, der den Namen des Symbols in der Ressourcendatei angibt. Wenn die Symbolressource einen ganzzahligen Bezeichner verwendet, sollte newicon$ mit einem Zahlensymbol (#) beginnen, gefolgt vom ganzzahligen Bezeichner im ASCII-Format. Beispiel: „#998“. Andernfalls sollte der Textbezeichnername verwendet werden.

Einschränkungen

DIALOG SET ICON kann keine Bitmap-Dateien verwenden. 32x32-Pixel-Symbole liefern die optisch ansprechendsten Ergebnisse.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG BILD HINZUFÜGEN
  • STEUERUNG BILD HINZUFÜGENX
  • STEUERN SIE DIE IMGBUTTON HINZUFÜGEN
  • STEUERUNG IMGBUTTON HINZUFÜGENX
  • STEUERUNG IMAGEX EINSTELLEN
  • STEUERUNG IMGBUTTON EINSTELLEN
  • CONTROL SET IMGBUTTONX
  • DIALOG TEXT EINSTELLEN

PBXB64-Umsetzungshinweise

DIALOGSET-SYMBOL gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOGSET-SYMBOL ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOGSET-SYMBOL mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG SET LOC – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOG SET LOC

DIALOG SET LOC

Ändern Sie die Position von a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG SET LOC hDlg , x& , y&

Beschreibung

HDlg identifiziert den neu zu positionierenden Dialog. x& und y& geben die neuen Koordinaten der oberen linken Ecke des Zieldialogs an. x& und y& sind die horizontalen bzw. vertikalen Koordinaten. Wenn der Dialog mit der Option PIXELS in der DIALOG NEW-Anweisung erstellt wurde, werden die Werte in Pixeleinheiten zurückgegeben. Wenn die Option UNITS verwendet wurde (oder keine Skalierungsoption angegeben wurde), werden die Werte in Dialogeinheiten zurückgegeben.

Wenn der Dialog über ein übergeordnetes Element verfügt, sind die Koordinaten relativ zur oberen linken Ecke des Clientbereichs des übergeordneten Dialogfelds. Andernfalls beziehen sich die Koordinaten auf die obere linke Ecke des Desktop-Arbeitsbereichs.

Siehe auch

  • Dynamic Dialog Tools
  • DIALOG KUNDEN ERHALTEN
  • DIALOG GET LOC
  • DIALOG GRÖSSE ERHALTEN
  • DIALOGPIXEL
  • DIALOGGRÖSSE EINSTELLEN
  • DIALOGEINHEITEN

PBXB64-Umsetzungshinweise

DIALOG SET LOC gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG SET LOC ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG SET LOC mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG-SET-GRÖSSE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOGGRÖSSE EINSTELLEN

DIALOGGRÖSSE EINSTELLEN

Ändern Sie die Größe von a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG SET SIZE hDlg , nWide& , nHigh&

Beschreibung

HDlg identifiziert den Dialog, dessen Größe geändert werden soll. nwide& und nhigh& geben die neue Breite und Höhe des Dialogs in Dialogeinheiten an. Wenn der Dialog mit der Option PIXELS in der DIALOG NEW-Anweisung erstellt wurde, werden die Werte in Pixeleinheiten festgelegt. Wenn die Option UNITS verwendet wurde (oder keine Skalierungsoption angegeben wurde), werden die Werte in Dialogeinheiten festgelegt.

Siehe auch

  • Dynamic Dialog Tools
  • DIALOG KUNDEN ERHALTEN
  • DIALOG GET LOC
  • DIALOG GRÖSSE ERHALTEN
  • DIALOGPIXEL
  • DIALOGSET-CLIENT
  • DIALOG SET LOC
  • DIALOGEINHEITEN

PBXB64-Umsetzungshinweise

DIALOGGRÖSSE EINSTELLEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOGGRÖSSE EINSTELLEN ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOGGRÖSSE EINSTELLEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG SET TEXT – PBXB64 Compiler-Hilfe

Startseite › Funktionen › DIALOG TEXT EINSTELLEN

DIALOG TEXT EINSTELLEN

Setzen Sie den Text in a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG SET TEXT hDlg , titletext$

Beschreibung

Die Beschriftung des durch hDlg angegebenen Dialogs oder Fensters wird mit der DIALOG SET TEXT-Anweisung festgelegt. Bei DDT-Dialogen ist hDlg das Dialoghandle, das von der DIALOG NEW-Anweisung zurückgegeben wird. In einer Dialog-Callback-Funktion gibt die CB.HNDL-Funktion das übergeordnete Dialog-Handle zurück und dieses kann auch mit DIALOG SET TEXT verwendet werden.

Titeltext$

Der Beschriftungstext wird in titletext$ angegeben. Wenn das Fenster oder der Dialog ungültig ist, wird der Vorgang ignoriert.

Einschränkungen

hDlg ist ein Dialog- oder Fensterhandle, daher funktioniert DIALOG SET TEXT sowohl mit DDT-Dialogen als auch mit herkömmlichen Fenstern und Dialogen.

Siehe auch

  • Dynamic Dialog Tools
  • CB Callback functions
  • CONTROL GET TEXT
  • STEUERUNG TEXT EINSTELLEN
  • DIALOG TEXT ERHALTEN
  • DIALOG NEU
  • DIALOGSET-SYMBOL

PBXB64-Umsetzungshinweise

DIALOG TEXT EINSTELLEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG TEXT EINSTELLEN ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG TEXT EINSTELLEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG SET USER – PBXB64 Compiler-Hilfe

Startseite › Funktionen › DIALOG SET BENUTZER

DIALOG SET BENUTZER

Legen Sie einen Wert im Benutzerdatenbereich von a fest

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG SET USER hDlg , index& , usrval&

Beschreibung

Jeder DDT-Dialog verfügt über einen Benutzerdatenbereich, der aus acht Long-Integer-Werten besteht, die nach Ermessen des Programmierers zum Speichern relevanter Daten verwendet werden können. Mit DIALOG SET USER kann einer der Werte basierend auf dem Indexparameterwert (1 bis 8) festgelegt werden.

hDlg bezieht sich auf den Dialog, der den Benutzerdatenbereich besitzt.

index& ist die Indexnummer des festzulegenden Benutzerdatenwerts im Bereich von 1 bis einschließlich 8.

usrval& ist der lange ganzzahlige Datenwert, der im Benutzerdatenbereich gespeichert werden soll.

Einschränkungen

Bei der Zerstörung des Dialogs gehen Daten im Benutzerdatenbereich verloren. Der Datenbereich ist vollständig vom von Windows verwalteten %GWL_USERDATA-Bereich getrennt.

Siehe auch

  • Dynamic Dialog Tools
  • COMBOBOX SET BENUTZER
  • KONTROLLE GET BENUTZER
  • STEUERUNG BENUTZER EINSTELLEN
  • DIALOG BENUTZER ERHALTEN
  • LISTBOX BENUTZER ERHALTEN
  • LISTBOX SET BENUTZER
  • LISTVIEW GET USER
  • LISTVIEW SET BENUTZER
  • TREEVIEW GET USER
  • TREEVIEW SET BENUTZER

PBXB64-Umsetzungshinweise

DIALOG SET BENUTZER gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG SET BENUTZER ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG SET BENUTZER mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG SHOW MODAL – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOG SHOW MODAL

DIALOGMODAL ANZEIGEN

Anzeigen und Aktivieren eines

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG SHOW MODAL hDlg [[,] CALL callback ] [TO lResult& ]

Beschreibung

hDlg identifiziert einen Dialog, der mit DIALOG NEW erstellt wurde. Sie können eine Callback-Funktion für alle Dialognachrichten angeben, indem Sie das Schlüsselwort CALL verwenden, gefolgt vom Namen der Callback-Funktion.

Bei der Anzeige eines modalen Dialogs wird die DIALOG SHOW MODAL-Anweisung blockiert, bis der Dialog mit DIALOG END zerstört wird. Während der Dauer des Dialogs wird der Callback-Funktionscode als Reaktion auf Nachrichten für den Dialog ausgeführt.

Wenn in der DIALOG NEW-Anweisung ein übergeordnetes Fenster angegeben wurde, ist das übergeordnete Fenster deaktiviert, bis der modale Dialog zerstört wird.

Rückruf

Falls angegeben, werden Dialognachrichten an die angegebene Callback-Funktion weitergeleitet.

Kurz bevor ein Dialog zum ersten Mal angezeigt wird, wird der Callback-Funktion des Dialogs eine %WM_INITDIALOG-Nachricht gesendet. Durch die Verarbeitung dieser Nachricht innerhalb des Dialogrückrufs kann eine Anwendung die Gelegenheit nutzen, Steuerelemente mit Daten zu laden, bevor die Steuerelemente für den Benutzer sichtbar werden. Beispielsweise könnte ein Listenfeld-Steuerelement mit einer Liste von Elementen geladen werden, sodass das Steuerelement bei der ersten Anzeige mit Daten gefüllt erscheint.

Der angegebene Name der Callback-Funktion muss eine CALLBACK-FUNCTION sein, sonst tritt beim Kompilieren der Fehler 547 („Callback-Funktion erforderlich“) auf.

lErgebnis&

Wenn der modale Dialog mit der DIALOG END-Anweisung zerstört wird, wird der resultierende Wert der Variablen lResult& zugewiesen, sofern angegeben. lResult& wird vom Compiler davon ausgeschlossen, eine Registervariable zu werden, da dieser Wert von außerhalb der Funktion zugewiesen werden kann, die die DIALOG SHOW MODAL-Anweisung enthält, und dies nur mit einer Speichervariablen durchgeführt werden darf. Wenn die Zielvariable jedoch explizit als Registervariable deklariert wird, löst PowerBASIC beim Kompilieren den Fehler 491 („Ungültige Registervariable“) aus.

Siehe auch

  • Dynamic Dialog Tools
  • DIALOG END
  • DIALOG NEU
  • DIALOG ZEIGEN MODELLLOS

PBXB64-Umsetzungshinweise

DIALOGMODAL ANZEIGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOGMODAL ANZEIGEN ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOGMODAL ANZEIGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG SHOW MODELESS – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOG SHOW MODELLESS

DIALOG ZEIGEN MODELLLOS

Anzeigen und Aktivieren eines

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG SHOW MODELESS hDlg [[,] CALL callback ] [TO lResult& ]

Beschreibung

hDlg identifiziert einen Dialog, der mit DIALOG NEW erstellt wurde. Sie können eine Rückruffunktion für alle Dialognachrichten angeben, indem Sie das Schlüsselwort CALL gefolgt vom Namen der Rückruffunktion verwenden.

Sobald ein modales Dialogfeld angezeigt wird, wird die DIALOG SHOW MODELESS-Anweisung abgeschlossen und die Ausführung des Codes fortgesetzt. Gleichzeitig kann der Dialog Nachrichten empfangen und über die Callback-Funktion verarbeiten. Auf eine DIALOG SHOW MODELESS-Anweisung folgt normalerweise eine Message-Pump-Schleife. Weitere Informationen finden Sie in den Beispielen unter DIALOG DOEVENTS .

Rückruf

Falls angegeben, werden Dialognachrichten an die angegebene Callback-Funktion weitergeleitet.

Der angegebene Name der Callback-Funktion muss eine CALLBACK-FUNCTION sein, sonst tritt beim Kompilieren der Fehler 547 („Callback-Funktion erforderlich“) auf.

lErgebnis&

Wenn der modale Dialog mit der DIALOG END-Anweisung zerstört wird, wird der resultierende Wert der Variablen lResult& zugewiesen, sofern angegeben. lResult& wird vom Compiler davon ausgeschlossen, eine Registervariable zu werden, da dieser Wert von außerhalb der Funktion zugewiesen werden kann, die die DIALOG SHOW MODELESS-Anweisung enthält, und dies nur mit einer Speichervariablen durchgeführt werden darf. Wenn die Zielvariable jedoch explizit als Registervariable deklariert wird, löst PowerBASIC beim Kompilieren den Fehler 491 („Ungültige Registervariable“) aus.

Siehe auch

  • Dynamic Dialog Tools
  • DIALOGVERANSTALTUNGEN
  • DIALOG END
  • DIALOG NEU
  • DIALOGMODAL ANZEIGEN

PBXB64-Umsetzungshinweise

DIALOG ZEIGEN MODELLLOS gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG ZEIGEN MODELLLOS ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG ZEIGEN MODELLLOS mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOG SHOW STATE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOG SHOW STATE

DIALOG STATUS ANZEIGEN

Ändern Sie den sichtbaren Zustand von a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG SHOW STATE hDlg , showstate& [TO lResult& ]

Beschreibung

DIALOG SHOW STATE ändert den sichtbaren Status des durch hDlg identifizierten Dialogs.

showstate& kann einer der folgenden Werte sein:

%SW_HIDE

Blenden Sie den Dialog aus.

%SW_MAXIMIZE

Maximiert den angegebenen Dialog.

%SW_MINIMIZE

Minimiert den angegebenen Dialog.

%SW_RESTORE

Aktivieren Sie den Dialog und zeigen Sie ihn an. Wenn das Dialogfeld minimiert oder maximiert wird, stellt Windows seine ursprüngliche Größe und Position wieder her. Eine Anwendung sollte dieses Flag angeben, wenn sie einen minimierten Dialog wiederherstellt.

%SW_SHOW

Aktivieren Sie den Dialog und zeigen Sie ihn in seiner aktuellen Größe und Position an.

%SW_SHOWMAXIMIZED

Synonym von %SW_MAXIMIZE.

%SW_SHOWMINIMIZED

Aktivieren Sie den Dialog und minimieren Sie ihn.

%SW_SHOWNA

Zeigt den Dialog in seinem aktuellen Zustand an, ohne ihn zu aktivieren. Das aktuell aktive Fenster bleibt aktiv.

%SW_SHOWNOACTIVATE

Zeigen Sie den Dialog in seiner aktuellen Größe und Position an, ohne ihn zu aktivieren. Das aktuell aktive Fenster bleibt aktiv.

%SW_SHOWNORMAL

Aktivieren Sie den Dialog und zeigen Sie ihn an. Wenn das Dialogfeld minimiert oder maximiert wird, stellt Windows seine ursprüngliche Größe und Position wieder her.

Wenn der optionale Parameter lResult& verwendet wird, enthält er den vorherigen Sichtbarkeitsstatus. Wenn lResult& auf TRUE (ungleich Null) gesetzt ist, war der Dialog sichtbar. Wenn der Dialog zuvor ausgeblendet war, wird lResult& auf FALSE (Null) gesetzt.

Einschränkungen

In früheren Versionen von PowerBASIC durfte der DIALOG SHOW STATE nicht ausgeführt werden, bevor eine DIALOG SHOW MODAL- oder DIALOG SHOW MODELESS-Anweisung für diesen bestimmten Dialog ausgeführt wurde. Ab dieser Version von PowerBASIC kann DIALOG SHOW STATE vor oder nach der Aktivierung des Dialogs mit der Anweisung DIALOG SHOW MODAL oder DIALOG SHOW MODELESS ausgeführt werden.

Bei Verwendung vor der Dialogaktivierung werden die Attribute %SW_HIDE, %SW_MAXIMIZE und %SW_MINIMIZE für die Verwendung bei der Aktivierung gespeichert. Alle anderen möglichen Attribute werden in den Standard %SW_SHOW übersetzt. Im Allgemeinen ist es unklug, %SW_HIDE mit einem modalen Dialog zu verwenden.

DIALOG SHOW STATE kann verwendet werden, um einen Dialog anzuzeigen, bevor die Nachrichtenpumpe für einen moduslosen Dialog zu arbeiten beginnt (d. h. nach der DIALOG SHOW MODELESS-Anweisung usw.). Bis die Nachrichtenpumpe ihren Betrieb aufnimmt, wird der Dialog jedoch möglicherweise nicht vollständig gezeichnet oder angezeigt.

Weitere Informationen zu Nachrichtenpumpen finden Sie unter DIALOG DOEVENTS und DIALOG SHOW MODELESS .

Siehe auch

  • Dynamic Dialog Tools
  • CONTROL SHOW STATE
  • DIALOGVERANSTALTUNGEN
  • DIALOG AUSblenden
  • DIALOG MAXIMIEREN
  • DIALOG MINIMIEREN
  • DIALOG NICHT STABIL
  • DIALOG NORMALISIEREN
  • DIALOGMODAL ANZEIGEN
  • DIALOG ZEIGEN MODELLLOS
  • DIALOG STABILISIEREN

PBXB64-Umsetzungshinweise

DIALOG STATUS ANZEIGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG STATUS ANZEIGEN ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG STATUS ANZEIGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOGSTABILISIEREN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOGSTABILISIEREN

DIALOG STABILISIEREN

Machen Sie ein

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG STABILIZE hDlg

Beschreibung

Der durch das Handle hDlg identifizierte Dialog ist stabilisiert, d. h. er kann vom Benutzer nicht geschlossen werden. Wenn ein Systemmenü vorhanden ist, sind die Schließoption und das Schließfeld ausgegraut. Die Schließen-Taste ALT-F4 ist deaktiviert. Dadurch können Sie sicher sein, dass Ihre Vorgänge im Dialog abgeschlossen werden können. Wenn ein Dialog stabilisiert ist, kann er nur durch DIALOGENDE oder Programmbeendigung geschlossen werden.

Siehe auch

  • DIALOG END
  • DIALOG NICHT STABIL

PBXB64-Umsetzungshinweise

DIALOG STABILISIEREN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOG STABILISIEREN ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOG STABILISIEREN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIALOGEINHEITEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIALOGEINHEITEN

DIALOGEINHEITEN

Konvertieren

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIALOG UNITS hDlg , x& , y& TO PIXELS xx& , yy&

Beschreibung

Die in den Variablen x& und y& angegebenen Dialogeinheiten werden basierend auf der durch hDlg angegebenen Standardschriftart des Dialogs in Pixel konvertiert. Die resultierenden Pixelwerte werden in den Variablen xx& und yy& gespeichert.

Siehe auch

  • Dynamic Dialog Tools
  • KONTROLLE KUNDEN ERHALTEN
  • DIALOG KUNDEN ERHALTEN
  • DIALOG GET LOC
  • DIALOG GRÖSSE ERHALTEN
  • DIALOGPIXEL
  • DIALOG SET LOC
  • DIALOGGRÖSSE EINSTELLEN

UI-Prüfung

Dialog- und Control-Seiten sollen das Control erzeugen, den dokumentierten Befehl anwenden und den geänderten Zustand über Getter, Notification oder sichtbares Ergebnis prüfen. Prüfen Sie Handle-Gültigkeit, bevor Nachrichten gesendet werden.

Nachrichten- und Lebensdauerregeln

Dokumentieren Sie Besitzerfenster, Control-ID, Lebensdauer von Child-Handles und ob der Befehl vor oder nach dem Anzeigen des Dialogs gültig ist.

x64-Hinweise

Verwenden Sie zeigergroße Handles und speichern Sie HWND, HDC oder Callback-Zeiger nicht in 32-Bit-Variablen.

PBXB64-Umsetzungshinweise

DIALOGEINHEITEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

DIALOGEINHEITEN ist ein DDT-Dialog-Befehl fuer ein Dialogfenster. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende Dialog-Handle bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Dialog-Lebenszyklus

Dialogseiten sollen den vollstaendigen Lebenszyklus zeigen: DIALOG NEW erzeugt das Fenster, DIALOG SHOW macht es sichtbar, der Callback verarbeitet Eingaben und DIALOG END beendet die Sitzung. Ein gutes Beispiel prueft, dass der Dialogzustand bis zum expliziten Ende erhalten bleibt.

Nachrichtenfluss

Dialog-Callbacks muessen Nachricht, Parameter und Control-Zustand klar auseinanderhalten. Verwenden Sie die Callback-Hilfen, um Eingaben und Benachrichtigungen zu trennen, und pruefen Sie immer, ob blockierende und modellose Dialogformen denselben Zustandswechsel liefern, den die Seite beschreibt.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' DIALOGEINHEITEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


Dialogstile – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Dialogstile

Dialogstile

Wie Steuerelementstile stellt DDT einen Standardstil für ein Dialogfenster bereit, wenn die DIALOG NEW-Anweisung keinen bestimmten Stilparameter angibt.

Typ:Schlüsselwort |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Der Standardstil umfasst die Kombination von %WS_POPUP, %WS_CAPTION, %DS_SETFONT, %DS_NOFAILCREATE, %DS_MODALFRAME und %DS_3DLOOK. Diese Entsprechungen entsprechen einem Stil von &H080C00D4. Der Standardwert für den erweiterten Stil ist Null.

Wenn Sie in Ihrer DIALOG NEW-Anweisung explizit %WS_CAPTION angeben, interpretiert DDT die Breiten- und Höhenwerte als Clientabmessungen und nicht als Gesamtdialogabmessungen. Dies kann sehr nützlich sein, wenn Sie einen Dialog mit bestimmten Client-Dimensionen erstellen müssen.

Sie können Dialoge mit Kombinationen der folgenden Stile erstellen:

Siehe auch

  • GRAPHIC ATTACH
  • DIALOG SHOW MODAL
  • CONTROL GET TEXT

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Dialog, Grafikfenster oder Druckkontext erzeugen.
    ' Konkrete Befehle aus den verlinkten Seiten anwenden.
    ' Ergebnisse pruefen und Ressourcen freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.

Beschreibung

Dialogstile ist eine Uebersichtsseite fuer verwandte GUI- und Grafikbefehle. Sie fasst die Familie zusammen und verweist auf die konkreten Befehlsseiten, auf denen die getestete Syntax und das Laufzeitverhalten dokumentiert sind.

Syntax

' Uebersicht nur.
' Verwenden Sie die verlinkten Mitgliedsseiten fuer die exakten Befehlsformen.

Uebersicht und Einstieg

Dialogstile ist eine Uebersichtsseite fuer verwandte GUI- und Grafikbefehle. Verwenden Sie diese Seite als Orientierung, waehrend die konkrete Syntax und die getesteten Details auf den einzelnen Befehlsseiten dokumentiert sind.

Typischer Aufbau

Ein vollstaendiges GUI- oder Grafikprogramm erzeugt zuerst Dialog, Grafikfenster oder Druckkontext, fuegt danach Controls oder Zeichenoperationen hinzu, fragt Zustand ab und gibt Ressourcen am Ende geordnet frei. Diese Reihenfolge macht Fehler bei Handles, IDs und Koordinatensystemen leichter nachvollziehbar.

Verlinkte Befehlsgruppen

  • DIALOG NEW und verwandte DIALOG-Befehle fuer Fenster und Dialogzustand.
  • CONTROL ADD und verwandte CONTROL-Befehle fuer Steuerelemente.
  • GRAPHIC WINDOW und verwandte GRAPHIC-Befehle fuer Zeichenausgabe.
  • XPRINT ATTACH und verwandte XPRINT-Befehle fuer Druckausgabe.

Siehe auch

  • GRAPHIC ATTACH
  • DIALOG SHOW MODAL
  • CONTROL GET TEXT

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Dialog, Grafikfenster oder Druckkontext erzeugen.
    ' Konkrete Befehle aus den verlinkten Seiten anwenden.
    ' Ergebnisse pruefen und Ressourcen freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


DIR$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIR$

DIR$

Gibt einen Dateinamen und/oder einen Verzeichniseintrag zurück, der einer Dateinamenmaske und einem optionalen Attribut entspricht.

Typ:Funktion |Kategorie: Dateiverwaltung

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

file$ = DIR$( mask$ [, [ONLY] attribute& , TO DirDataVar ])
file$ = DIR$([NEXT] [TO DirDataVar ])

Beschreibung

Es gibt zwei Formen der Funktion DIR$(). Das erste Formular, das eine Maskenzeichenfolge und ein optionales Attribut enthält, wird verwendet, um den ersten passenden Dateinamen zu finden. Das zweite Formular ohne diese Parameter gibt nachfolgende übereinstimmende Dateinamen zurück. Wenn die zurückgegebene Zeichenfolge null (null Länge) ist, gibt es keine weiteren passenden Dateinamen.

Das zweite Formular kann optional das Schlüsselwort NEXT angeben, um die Selbstdokumentation des Quellcodes zu erleichtern.

mask$ gibt einen Dateinamen oder Pfad an, der einen Laufwerksnamen und System-Platzhalterzeichen (* und ?) enthalten kann. Wenn der numerische Attributparameter Null ist (oder nicht angegeben ist), gibt DIR$ nur „normale“ Dateien zurück. Wenn mask$ eine Nullzeichenfolge (Nulllänge) ist, entspricht der Funktionsaufruf der zweiten Form der Funktion, um nachfolgende übereinstimmende Dateinamen zu finden. In diesem Fall wird ein optionales Attribut ignoriert.

Wenn ein Attribut& angegeben wird, muss es einen standardmäßigen numerischen Attributcode des Betriebssystems verwenden. Dies führt dazu, dass DIR$ zusätzlich zu normalen Dateien auch Dateinamen mit bestimmten Attributen in die Suche einbezieht. „Normale“ Dateien sind solche, die keine versteckten oder Systemdateien sind, noch handelt es sich um ein Verzeichnis oder eine Datenträgerbezeichnung.

Attribut

Beschreibung

Gleichsetzen

Normal

%NORMAL

Versteckt

%VERSTECKT

System

%SYSTEM

Datenträgerbezeichnung

%VLABEL

Verzeichnis

%UNTERVERZEICHNIS

Sie können nach Dateinamen mit mehreren festgelegten Attributen suchen, indem Sie die Attributcodes addieren. Um beispielsweise nach versteckten Dateien und Systemdateien zu suchen, würden Sie diese Codes (2 und 4) addieren, um 6 zu erhalten. Alle anderen Attributcodes (außer der Datenträgerbezeichnung) sind normalerweise inklusive. Wenn Sie beispielsweise sowohl versteckte als auch Systemdateien angeben, gibt DIR$ alle versteckten Dateien, Systemdateien, normalen Dateien und Dateien zurück, die sowohl versteckt als auch Systemdateien sind.

Wenn die Option NUR enthalten ist, werden normale Dateien von der Dateisuche ausgeschlossen. Beispiel: DIR$( mask$ , NUR 16) Es werden nur die Verzeichniseinträge zurückgegeben, die mit mask$ übereinstimmen. Ein weiteres nützliches Suchattribut ist 6, das normale, versteckte und Systemdateien, aber keine Verzeichnisse zurückgibt.

Ein Attribut von 8 gibt die Datenträgerbezeichnung zurück, sofern eine vorhanden ist. In diesem Fall muss mask$ auf den Laufwerksbuchstaben des Ziellaufwerks verweisen und zusätzliche Pfadinformationen werden ignoriert. Darüber hinaus können Sie einen UNC-Namen für ein freigegebenes Laufwerk angeben (vorbehaltlich der Einschränkungen des Betriebssystems) und die Datenträgerbezeichnung abrufen, sofern eine vorhanden ist und Sie über die entsprechenden Zugriffsrechte verfügen. Sie können die Datenträgerbezeichnung für eine „versteckte“ Freigabe unter NT/2000/XP auch erhalten, indem Sie an den Freigabenamen ein Dollarzeichen anhängen.

'Volume für Freigabe \\server\drive0 abrufen

A$ = DIR$("\\server\drive0", 8)

'Volume für versteckte Freigabe D abrufen: (\d$)

A$ = DIR$("\\server\d$", %VLABEL)

Die Funktion DIR$ kann optional den vollständigen Verzeichniseintrag einer entsprechenden UDT-Variablen zuweisen, wenn Sie die TO-Klausel als Parameter einschließen. Der vollständige Verzeichniseintrag enthält 592 Bytes an Daten, entsprechend der folgenden TYPE-Definition. Diese Definition (DIRDATA) ist in PowerBASIC integriert und muss nicht unbedingt in Ihrem Quellcode enthalten sein. Der DirData UDT ist identisch mit der Unicode-Version der Win32_Find_Data-Struktur, die von der Windows-API für diesen Zweck verwendet wird.

TYP DirData

Dateiattribute als DWORD

CreationTime AS QUAD

LastAccessTime AS QUAD

LastWriteTime AS QUAD

FileSizeHigh AS DWORD

FileSizeLow ALS DWORD

Reserviert0 als DWORD

Reserviert1 als DWORD

Dateiname AS WSTRINGZ * 260

Kurzname AS WSTRINGZ * 14

END-TYP

Zu diesem Zweck können Sie eine Variable als DIRDATA deklarieren oder einen anderen benutzerdefinierten Typ mit mindestens 592 Datenbytes verwenden. Die zusätzlichen Daten können für jeden anderen Zweck in Ihrem Programm verwendet werden.

CreationTime-, LastAccessTime- und LastWriteTime-Mitglieder von DIRDATA können einem PowerTime-Objekt zugewiesen werden, um die QUAD-Integer-Werte (FILETIME) für einfache Berechnungen und Konvertierungen zu konvertieren.

LOKALER f AS STRING

LOCAL d ALS DIRDATA

LOCAL t ALS IPOWERTIME

t = KLASSE „PowerTime“

f = DIR$("c:\*.*" TO d)

t.FileTime = d.CreationTime ' t enthält die Dateierstellungszeit in einem lokalisierten Format.

Frühere Versionen von PowerBASIC verwendeten eine ANSI-Version von DirData, die nur 318 Byte groß war. Wenn Sie jedoch die integrierte Form von DirData verwendet haben, sollte Ihr Programm unter dieser Version korrekt ausgeführt werden, ohne dass Änderungen erforderlich sind.

Einschränkungen

PowerBASIC führt den Dateiabgleich sowohl mit den langen (LFN) als auch mit den kurzen (SFN) Dateinamenversionen von Dateinamen durch. Das bedeutet, dass DIR$ auch Dateinamen zurückgibt, die mit der angegebenen Erweiterung beginnen (gemäß dem Standardverhalten des Windows-Betriebssystems).

Beispielsweise stimmt A$ = DIR$("*.htm") mit Dateinamen wie „Index.htm“, „Default.html“, „Homepages.htmb“, „cgilib.htmlpages“ usw. überein. Ebenso stimmen A$ = DIR$(“*.h??) und DIR$(“*.ht*“) mit denselben Dateinamen überein.

DIR$ ist Thread-sicher, sodass DIR$-Vorgänge in einem Thread DIR$-Vorgänge in einem anderen Thread nicht beeinträchtigen. Sie sollten sich jedoch darüber im Klaren sein, dass die Angabe eines neuen mask$-Parameters immer eine völlig neue DIR$-Suchschleife startet.

Siehe auch

  • CURDIR$
  • DIR$ CLOSE
  • ANZEIGE DURCHSUCHEN
  • OPENFILE ANZEIGEN
  • DATEIATTR
  • GETATTR
  • ISFILE
  • PFADNAME$
  • PATHSCAN$
  • SETATTR

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


DIR$ CLOSE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DIR$ CLOSE

DIR$ CLOSE

Erzwingen Sie die Veröffentlichung des FindNext-Handles des Betriebssystems.

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIR$ CLOSE

Beschreibung

DIR$ CLOSE führt dazu, dass das FindNext-Handle des Betriebssystems geschlossen wird. Jedes Mal, wenn eine neue DIR$()-Sequenz innerhalb eines Threads initiiert wird oder DIR$() eine leere Zeichenfolge zurückgibt, schließt PowerBASIC automatisch das FindNext-Handle, um eine Überbeanspruchung der Systemressourcen zu vermeiden.

Unter ungewöhnlichen Umständen (z. B. bei einem rekursiven Verzeichnisscan mit Löschen oder Umbenennen) kann es jedoch erforderlich sein, das FindNext-Handle mithilfe dieser expliziten Anweisung früher zu schließen, damit ein Verzeichnis entfernt oder umbenannt werden kann.

PBXB64 senkt DIR$ CLOSE auf den eingebetteten Laufzeithelfer bestof_dir_close ab. Der Helfer schliesst das aktive Win32-Find-Handle mit FindClose und setzt den aktuellen DIR$("")-Fortsetzungszustand zurueck. Ein spaeterer Aufruf von DIR$(pattern) startet eine neue Suche.

Einschränkungen

Es ist niemals notwendig, DIR$ CLOSE auszuführen, um einfach ein „System Handle Leak“ zu vermeiden.

Die fokussierte PBXB64-Zertifizierung deckt das explizite Schliessen des Handles und das Zuruecksetzen des Iterationszustands ab. Weitere DIR$-Paritaet fuer Wildcards, ONLY, DIRDATA und Verzeichnis-Sonderfaelle bleibt Teil des breiteren Datei-/Pfad-Backlogs.

Siehe auch

  • DIR$

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


DISKFREE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DISKFREE

DISKFREI

Gibt die Menge des verfügbaren Speicherplatzes auf einer Festplatte in Bytes zurück.

Typ:Funktion |Kategorie: Dateiverwaltung

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

bytes&& = DISKFREE( drive$ )

Beschreibung

drive$ gibt den Laufwerksbuchstaben oder Stammpfad des zu untersuchenden Datentraegers an. PBXB64 senkt diese Funktion auf den eingebetteten Laufzeithelfer bestof_diskfree ab, der die Win32-Datentraegerplatz-API verwendet und fuer einen gueltigen Pfad wie "C:\" die verfuegbaren Bytes zurueckgibt.

Im fokussierten V14.4-Vertrag gibt eine leere Zeichenfolge oder ein ungueltiger Laufwerksstring 0 zurueck.

Einschränkungen

Der registrierte PBXB64-Test deckt das aktuelle Laufwerk und das Fehlerverhalten fuer ungueltige Laufwerke ab. UNC-Pfade, Wechsel- oder Offline-Medien, Zugriff-verweigert-Fehler, Ueberlaufgrenzen und PBWin-ERR-Paritaet bleiben offen.

Siehe auch

  • Festplattengröße

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


DISKSIZE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DISKSIZE

Festplattengröße

Gibt den gesamten Speicherplatz auf einer Festplatte in Bytes zurück.

Typ:Funktion |Kategorie: Dateiverwaltung

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

bytes&& = DISKSIZE( drive$ )

Beschreibung

drive$ gibt den Laufwerksbuchstaben oder Stammpfad des zu untersuchenden Datentraegers an. PBXB64 senkt diese Funktion auf den eingebetteten Laufzeithelfer bestof_disksize ab, der die Win32-Datentraegerplatz-API verwendet und fuer einen gueltigen Pfad wie "C:\" die Gesamtgroesse in Bytes zurueckgibt.

Im fokussierten V14.4-Vertrag gibt eine leere Zeichenfolge oder ein ungueltiger Laufwerksstring 0 zurueck.

Einschränkungen

Der registrierte PBXB64-Test deckt das aktuelle Laufwerk und das Fehlerverhalten fuer ungueltige Laufwerke ab. UNC-Pfade, Wechsel- oder Offline-Medien, Zugriff-verweigert-Fehler, Ueberlaufgrenzen und PBWin-ERR-Paritaet bleiben offen.

Siehe auch

  • DISKFREI

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


DISPLAY DURCHSUCHEN – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › ANZEIGE DURCHSUCHEN

ANZEIGE DURCHSUCHEN

Zeigt einen Ordnerauswahldialog an, um die Auswahl des Benutzers zurückzugeben.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DISPLAY BROWSE [ hParent ], [ xpos& ], [ ypos& ], title$ , start$ , flags& TO folder$

Siehe auch

  • ANZEIGEFARBE
  • ANZEIGESCHRIFTART
  • OPENFILE ANZEIGEN
  • SAVEFILE ANZEIGEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ANZEIGEFARBE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › FARBE ANZEIGEN

ANZEIGEFARBE

Zeigt einen Farbauswahldialog an, um die Auswahl des Benutzers zurückzugeben.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DISPLAY COLOR [hParent], [xpos&], [ypos&] , firstcolor& , custcolors , flags& TO colorval&

Beschreibung

Wenn Sie dem Benutzer die Möglichkeit bieten, benutzerdefinierte Farben zu erstellen, wird empfohlen, die UDT-Variable custcolors& unverändert beizubehalten. Es kann dann bei einem späteren Aufruf von DISPLAY COLOR erneut verwendet werden, wobei die benutzerdefinierten Farben des Benutzers intakt bleiben.

Siehe auch

  • Built In RGB Color Equates
  • ANZEIGE DURCHSUCHEN
  • ANZEIGESCHRIFTART
  • OPENFILE ANZEIGEN
  • SAVEFILE ANZEIGEN
  • RGB

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ANZEIGESCHRIFTART – PBXB64-Compiler-Hilfe

Startseite › Funktionen › SCHRIFTART ANZEIGEN

ANZEIGESCHRIFTART

Zeigen Sie eine Schriftart an

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DISPLAY FONT [hParent], [xpos&], [ypos&], defname$ , defpoints& , defstyle& , flags & _
TO fontname$ , points& , style& [, colorval& , charset& ]

Siehe auch

  • STEUERUNG SET SCHRIFTART
  • DIALOG-STANDARDSCHRIFTART
  • ANZEIGE DURCHSUCHEN
  • ANZEIGEFARBE
  • OPENFILE ANZEIGEN
  • SAVEFILE ANZEIGEN
  • SCHRIFTART END
  • SCHRIFTART NEU
  • GRAFIK-SET-SCHRIFTART
  • XPRINT SCHRIFTART EINSTELLEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


DISPLAY OPENFILE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › OPENFILE ANZEIGEN

OPENFILE ANZEIGEN

Zeigt ein OpenFile-Auswahldialogfeld an, um Benutzerauswahlmöglichkeiten anzuzeigen.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DISPLAY OPENFILE [hParent], [xpos & ], [ypos & ] , title$ , folder$ , filter$ , _
start$ , defextn$ , flags & TO filevar$ [, countvar& ]
"BASIC" + CHR$(0) + "*.BAS" + CHR$(0)
CHR$("BASIC", 0, "*.BAS", 0)
CHR$("BASIC", 0, "*.BAS;*.INC;*.BAK", 0)

Beschreibung

Das aktuelle Standardverzeichnis wird durch diese Anweisung niemals geändert, selbst wenn der Benutzer das Verzeichnis während der Suche nach Dateien ändert.

Siehe auch

  • ANZEIGE DURCHSUCHEN
  • ANZEIGEFARBE
  • ANZEIGESCHRIFTART
  • SAVEFILE ANZEIGEN

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


DISPLAY SAVEFILE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DISPLAY SAVEFILE

SAVEFILE ANZEIGEN

Zeigt ein Dialogfeld zur Auswahl von „SaveFile“ an, um die Auswahl des Benutzers zurückzugeben.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DISPLAY SAVEFILE [hParent], [xpos & ], [ypos & ] , title$ , folder$ , filter$ , _
start$ , defext$ , flags & TO filevar$ [, countvar& ]
"BASIC" + CHR$(0) + "*.BAS" + CHR$(0)
CHR$("BASIC", 0, "*.BAS", 0)
CHR$("BASIC", 0, "*.BAS;*.INC;*.BAK", 0)

Beschreibung

Das aktuelle Standardverzeichnis wird durch diese Anweisung niemals geändert, selbst wenn der Benutzer das Verzeichnis während der Suche nach Dateien ändert.

Siehe auch

  • ANZEIGE DURCHSUCHEN
  • ANZEIGEFARBE
  • ANZEIGESCHRIFTART
  • OPENFILE ANZEIGEN

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


DLL-Beispiel – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DLL-Beispiel

DLL-Beispiel

Ein sehr einfaches Beispiel ist eine DLL mit einer Funktion, die zu jeder langen Ganzzahl, die ihr als Parameter übergeben wird, eins hinzufügt:

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

FUNCTION AddOne ALIAS „AddOne“ (BYVAL x AS LONG) EXPORT AS LONG

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


DO/LOOP-Anweisungen � PBXB64-Compiler-Hilfe

Startseite � Funktionen � DO/LOOP-Anweisungen

DO/LOOP-Anweisungen

Definieren Sie eine Gruppe von Programmanweisungen, die wiederholt ausgef�hrt werden, solange eine bestimmte Bedingung erf�llt ist.

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERF�GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DO [{WHILE | UNTIL} expression ]
[ statements ]
[EXIT LOOP]
[ITERATE LOOP]
LOOP [{WHILE | UNTIL} expression ]

Beschreibung

Ausdruck ist ein numerischer Ausdruck, in dem Werte ungleich Null logisch WAHR und Nullwerte logisch FALSCH darstellen. Wenn ein String-Ausdruck verwendet wird (d. h. A$ <> ""), gibt PowerBASIC TRUE zur�ck, wenn die Ergebnisl�nge des String-Ausdrucks gr��er als Null ist.

DO/LOOP-Anweisungen sind �u�erst flexibel. Mit ihnen lassen sich Schleifen f�r nahezu jede erdenkliche Programmiersituation erstellen. Sie erm�glichen die Erstellung von Schleifen mit dem Test auf die Abschlussbedingung am Anfang der Schleife, am Ende der Schleife, an beiden Stellen oder an keiner der oben genannten Stellen.

Eine DO-Anweisung muss immer mit einer passenden LOOP-Anweisung am Ende der Schleife gepaart werden. Wenn nicht jedes DO mit einer LOOP abgeglichen wird, f�hrt dies entweder zu einem Fehler 448 zur Kompilierungszeit (�DO-Schleife erwartet�) oder zu einem Fehler 456 (�LOOP/WEND erwartet�).

Die Schl�sselw�rter WHILE und UNTIL werden verwendet, um Tests zu einem DO/LOOP hinzuzuf�gen. Verwenden Sie WHILE, wenn die Schleife wiederholt werden soll, wenn der Ausdruck TRUE ist, und beendet werden soll, wenn der Ausdruck FALSE ist. UNTIL hat den gegenteiligen Effekt; Das hei�t, die Schleife wird beendet, wenn Ausdruck TRUE ist, und wiederholt, wenn FALSE.

Zum Beispiel:

DO SIE WHILE a = 13

[Anweisungn]

f�hrt die Anweisungen zwischen DO und LOOP aus, solange a 13 ist. Wenn a anfangs nicht 13 ist, werden die Anweisungen in der Schleife nie ausgef�hrt. Umgekehrt:

DO SIE, BIS a = 13

[Anweisungn]

f�hrt die Anweisungen zwischen DO und LOOP aus, solange a nicht 13 ist. Wenn a anf�nglich gleich 13 ist, wird die Schleife nie ausgef�hrt.

An jeder Stelle in einem DO/LOOP k�nnen Sie eine EXIT LOOP- oder ITERATE LOOP-Anweisung einf�gen. EXIT LOOP bewirkt, dass die Schleife beendet wird, sodass die Ausf�hrung nach der abschlie�enden Schleifenanweisung fortgesetzt wird. ITERATE LOOP bewirkt, dass die Schleife bei der abschlie�enden Schleifenanweisung fortgesetzt wird.

Die WHILE/WEND-Anweisungen k�nnen in vielen F�llen verwendet werden, um die gleichen Funktionen wie DO/LOOP auszuf�hren. Zum Beispiel dieser DO/LOOP:

DO SIE, WHILE a < b

[Anweisungn]

hat den gleichen Effekt wie diese WHILE/WEND-Schleife:

WHILE a < b

[Anweisungn]

Achten Sie bei der Verwendung verschachtelter Schleifen darauf, dass innere Schleifen keine Variablen �ndern, die vom Abschlussbedingungstest der �u�eren Schleife verwendet werden. Der folgende Code sollte beispielsweise alle 20 Elemente eines 10 x 2-Arrays (dimensioniertes Array (9,1)) abrufen:

Anzahl1 = 0

DO SIE, WHILE Count1 < 10

FOR Count2 = 0 TO 1

x = arry(Count1,Count2)

Anzahl1 = Anzahl1 + 1

N�CHSTER Count2

Da Count1 innerhalb der inneren Schleife erh�ht wird, die bei jedem Durchgang durch die �u�ere Schleife zweimal ausgef�hrt wird, w�rde dieser Code nicht alle Array-Werte abrufen, sondern nur die Werte f�r arry (0,0), arry (1,1), arry (2,0), arry (3,1) usw. Durch Verschieben der Count1 = Count1 + 1-Anweisung direkt unter die NEXT Count2-Anweisung funktioniert der Code wie vorgesehen.

Wenn eine EXIT LOOP-Anweisung innerhalb verschachtelter Schleifen verwendet wird, verl�sst sie nur die aktuelle Schleife, nicht die gesamte Verschachtelung. In �hnlicher Weise iteriert ein ITERATE innerhalb verschachtelter Schleifen die aktuelle Schleife. Hinweise zum Verlassen verschachtelter Blockstrukturen finden Sie in der EXIT-Anweisung. Mit den logischen PowerBASIC-Operatoren k�nnen mehrere Testbedingungen f�r die Schleifensteuerung erstellt werden. Zum Beispiel:

DO SIE, WHILE x < 10 UND y < 10

[Anweisungn]

wird nur ausgef�hrt, solange sowohl x als auch y kleiner als 10 sind. Ebenso gilt f�r die Schleife:

DO, BIS X > 10 ODER Y > 10

[Anweisungn]

wird ausgef�hrt, bis entweder x oder y (oder beide) gr��er als 10 ist (sind). Weitere Informationen zur Verwendung logischer Operatoren finden Sie in den Themen zu Datentypen und arithmetischen Operatoren.

Obwohl sich der Compiler nicht um solche Dinge k�mmert, ist es beim Schreiben Ihres Quellcodes eine gute Idee, die Anweisungen zwischen DO und LOOP einzur�cken. Das Gleiche gilt f�r FOR/NEXT-Schleifen, WHILE/WEND-Schleifen und mehrzeilige IF-Anweisungen. Durch diese Einr�ckung spiegelt das Erscheinungsbild Ihres Quellcodes die logische Struktur Ihres Programms wider, was zu einer besseren Lesbarkeit f�hrt. Das Einr�cken ist besonders wertvoll, wenn mehrere Schleifen desselben Typs verschachtelt werden, da so leichter erkennbar ist, welcher LOOP zu welchem ​​DO geh�rt.

Hinweise zur Kurzschlussbewertung von PowerBASIC und ihren m�glichen Nebenwirkungen finden Sie auch in der Diskussion zur IF-Anweisung.

Verifiziertes Beispiel: DO...LOOP - bedingte Schleife

Beispieldatei: examples/basic/help_control_flow/help_do.pb

Validierungsnachweis: examples/basic/test_do_while_counter.pb; tests/integration/pbxa64/control_flow/test_control_flow_comprehensive.pb

Validation evidence: the registered control-flow regression(s) named above compile and run with exit code 0, proving the page-specific branch, loop, or exception behavior documented here.

FUNCTION PBMAIN() AS LONG
    LOCAL x AS LONG
    DO
        x = x + 1
    LOOP WHILE x < 3
    IF x <> 3 THEN FUNCTION = 1 ELSE FUNCTION = 0
END FUNCTION

Verhalten: Testet eine DO-Schleife mit Pruefung am Ende. Der Schleifenkoerper laeuft vor der WHILE-Pruefung.

Siehe auch

  • #OPTIMIEREN
  • AUSFAHRT
  • FOR EACH/NEXT
  • FOR/WEITER
  • ITERATE
  • WHILE/WENDE

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_do_while
FUNCTION PBMAIN() AS LONG
  LOCAL i AS LONG
  LOCAL s AS LONG
  i = 1
  s = 0
  DO WHILE i <= 5
    s = s + i
    i = i + 1
  LOOP
  IF (s) <> (15) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_do_until
FUNCTION PBMAIN() AS LONG
  LOCAL i AS LONG
  LOCAL s AS LONG
  i = 1
  s = 0
  DO UNTIL i > 5
    s = s + i
    i = i + 1
  LOOP
  IF (s) <> (15) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Gleitkomma mit doppelter Genauigkeit (#) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Gleitkomma mit doppelter Genauigkeit (#)
Hilfe zum PBXB64-Compiler

Gleitkomma mit doppelter Genauigkeit (#)

Gleitkommazahlen mit doppelter Genauigkeit sind im Vergleich zu Zahlen mit einfacher Genauigkeit das, was lange Ganzzahlen im Vergleich zu Ganzzahlen sind. Sie beanspruchen doppelt so viel Speicherplatz (8 Byte gegenüber 4 Byte), haben aber eine größere Reichweite

Typ:Schlüsselwort |Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Variablen mit doppelter Genauigkeit werden identifiziert, indem dem Variablennamen ein Zahlensymbol folgt (d. h. var# ) oder indem die DEFDBL-Anweisung verwendet wird, wie in der vorherigen Diskussion von Ganzzahlen beschrieben. Sie können Variablen mit doppelter Genauigkeit auch mithilfe des Schlüsselworts DOUBLE mit der DIM-Anweisung deklarieren. Zum Beispiel:

C/C++, Delphi und Visual Basic bieten alle einen doppelten Datentyp, der mit der PowerBASIC-Variable mit doppelter Genauigkeit identisch ist.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Gleitkomma mit doppelter Genauigkeit (#) soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Gleitkomma mit doppelter Genauigkeit (#) mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Doppelwort (???) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Doppelwort (???)
Hilfe zum PBXB64-Compiler

Doppelwort (???)

Doppelwörter sind vorzeichenlose 32-Bit-Ganzzahlen (vier Bytes) mit einem Bereich von 0 bis 4.294.967.295 (0 bis 2^32-1). Das Typspezifizierzeichen für ein Doppelwort ist: ???.

Typ:Schlüsselwort |Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Doppelwortvariablen werden identifiziert, indem dem Variablennamen drei Fragezeichen folgen (z. B. var??? ) oder indem die DEFDWD-Anweisung verwendet wird, wie in der vorherigen Diskussion von Ganzzahlen beschrieben. Sie können Doppelwortvariablen auch mit dem Schlüsselwort DWORD mit der DIM-Anweisung deklarieren. Zum Beispiel:

Bei Wortwerten und Ganzzahlen haben Doppelwortwerte einen größeren positiven Bereich als Long-Integer und erfordern dennoch nur vier Bytes. Doppelwortwerte sind nützlich, um absolute Speicheradressen anzugeben, die beispielsweise zum Speichern von Zeigerwerten verwendet werden können.

Ein PowerBASIC-Doppelwort entspricht einem UINT32 in C/C++. Im 32-Bit-C/C++-Code entspricht ein UINT auch einer PowerBASIC-Doppelwortvariablen. Beachten Sie, dass 16-Bit-C/C++-Code UINT verwendet, um eine 16-Bit-Word-Variable zu beschreiben.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Doppelwort (???) soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Doppelwort (???) mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Dynamic Dialog Tools (DDT) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Dynamische Dialogwerkzeuge (DDT)
Hilfe zum PBXB64-Compiler

Dynamische Dialogtools (DDT)

Willkommen bei den leistungsstarken und verbesserten Dynamic Dialog Tools von PowerBASIC. DDT ermöglicht einem BASIC-Programmierer die einfache Erstellung einer grafischen Benutzeroberfläche (GUI) für eine Anwendung mithilfe einfacher BASIC-Anweisungen. W

Typ:Schlüsselwort |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Programmierer, die mit DDT vertraut sind, werden feststellen, dass PowerBASIC die DDT-Implementierung in dieser Version von PowerBASIC noch weiter erweitert hat, mit erweiterten Funktionen wie Benutzerdatenspeicherung und Beschleunigertabellen.

Dieses Kapitel beschreibt die dynamischen Dialogtools von PowerBASIC und wie Sie auf einfache Weise grafische Benutzeroberflächen mit vollem Funktionsumfang in Ihrem Code erstellen können.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Dynamische Dialogtools – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Dynamische Dialogwerkzeuge

Dynamic Dialog Tools

Die folgenden Funktionen können zum Erstellen von GUI-Anwendungsoberflächen verwendet werden:

Typ:Schlüsselwort |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Hängen Sie eine Tabelle mit Tastaturbeschleunigern an einen DDT-Dialog an.

Definieren Sie einen Dialog-/Control-Callback-Funktionsblock.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


EACH - Container-Elemente durchlaufen — PBXB64 Help

Startseite › General Reference › EACH - Container-Elemente durchlaufen — PBXB64 Help
Hilfe zum PBXB64-Compiler

EACH - Container-Elemente durchlaufen

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

FOR EACH item IN collection
NEXT

Detailverhalten

Klauselkeyword fuer FOR-EACH-Schleifen ueber implementierte Container-/Array-aehnliche Quellen.

Praktische Verwendung

Verwenden Sie EACH als Schleifen-Klausel in FOR EACH-Formen, um die Iterationsvariable von der Container- oder Array-Quelle zu trennen. Das zugehoerige IN gehoert auf dieselbe Kontrollzeile.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Verwenden Sie diese Keywords nicht ausserhalb der getesteten FOR EACH-Schreibweise, wenn die Quelle nicht als Iterationsform gemeint ist. Sonst wird der Parser einen anderen Ausdrucksweg erwarten.

Verifiziertes Beispiel

Abgedeckt durch examples/basic/Container_ForEach_UDT_Lst.pb (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Effektive Adressierung – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Effektive Adressierung

Effektive Adressierung

Die Notation zur Berechnung der effektiven Adresse von Daten im Speicher kann kompliziert aussehen, ist aber tatsächlich eine sehr klare und präzise Notation. Im Bereich der zulässigen Notation für den Intel 80x86-Assembler gilt:

Typ:Schlüsselwort |Kategorie: Memory & Pointers

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

! MOV EAX, lpArray ; Adresse in EAX kopieren

! MOV ECX, [EAX] ; Kopieren Sie das erste Element im Array in ECX

! EAX HINZUFÜGEN, 4 ; Erhöhen Sie den Array-Speicherort um 4 Bytes

! MOV ECX, [EAX] ; Kopieren Sie das zweite Element im Array in ECX

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.


ELSE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › ELSE

Sonst

Standardzweig eines IF-Blocks

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ELSE
  [statements]

Beschreibung

DerELSE Das Schlüsselwort leitet den Zweig ein, der ausgeführt wird, wenn keines der vorangehenden Elemente vorhanden ist IFoderELSEIF Bedingungen sind wahr. Es ist optional und muss schließlich erscheinen ELSEIF Zweige.

Beispiel

FUNCTION PBMAIN () AS LONG
    LOCAL x AS LONG
    x = 3
    IF x > 5 THEN
        FUNCTION = 1
    ELSE
        FUNCTION = 0
    END IF
END FUNCTION

Siehe auch

  • IF
  • ELSEIF
  • THEN
  • SELECT CASE
  • Kontrollflussreferenz

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ELSEIF – PBXB64-Compiler-Hilfe

Startseite › Funktionen › ELSEIF

ELSEIF

Zusätzlicher Zweig in einem IF-Block

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ELSEIF condition THEN
  [statements]

Beschreibung

ELSEIF führt einen zusätzlichen Test ein IF...END IF blockieren. Es muss danach erscheinen IF und vor jedem ELSEoderEND IF. Wenn das Vorhergehende IF und früher ELSEIF Wenn alle Bedingungen falsch waren und diese Bedingung wahr ist, werden die zugehörigen Anweisungen ausgeführt.

Beispiel

FUNCTION PBMAIN () AS LONG
    LOCAL x AS LONG
    x = 5
    IF x > 5 THEN
        FUNCTION = 1
    ELSEIF x = 5 THEN
        FUNCTION = 2
    ELSE
        FUNCTION = 3
    END IF
END FUNCTION

Dieses Programm gibt 2 zurück.

Generierter Assembler-Code

ELSEIFsenkt sich auf einen zweiten Bedingungsblock ab, der über den falschen Pfad der ersten Bedingung erreicht wird. Das Backend gibt eine Kaskade gekennzeichneter Blöcke aus, die alle gleichzeitig zusammengeführt werden END IF Punkt:

pb_if_else_PBMAIN_1:
    mov r10, [rbp-32]
    mov rbx, r10
    cmp rbx, 5
    sete r10
    mov rbx, r10
    test rbx, rbx
    jne pb_elseif_then_PBMAIN_3
    jmp pb_elseif_else_PBMAIN_4
pb_elseif_then_PBMAIN_3:
    mov [rbp-24], 2
    jmp pb_if_end_PBMAIN_2
pb_elseif_else_PBMAIN_4:
    mov [rbp-24], 3
    jmp pb_if_end_PBMAIN_2

Siehe auch

  • IF
  • Sonst
  • THEN
  • END IF

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


END IF – PBXB64-Compiler-Hilfe

Startseite › Funktionen › END IF

END IF

Schließen Sie einen mehrzeiligen IF-Block

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

END IF

Beschreibung

DerEND IF Die Anweisung beendet eine mehrzeilige Operation IF...THEN blockieren. Alle Filialen (IF, ELSEIF, ELSE) konvergieren an diesem Punkt. Im Backend wird es zum Merge-Label, zu dem jeder Zweig springt.

Beispiel

FUNCTION PBMAIN () AS LONG
    LOCAL x AS LONG
    x = 5
    IF x > 5 THEN
        FUNCTION = 1
    ELSE
        FUNCTION = 0
    END IF
END FUNCTION

Generierter Assembler-Code

Der Zusammenführungspunkt wird als beschrifteter Block ausgegeben:

pb_if_end_PBMAIN_0:
    mov r10, [rbp-24]
    mov rax, r10
    ; function epilogue

Verifiziertes Beispiel: END IF - einen Block-IF schliessen

Beispieldatei: examples/basic/help_control_flow/help_if.pb

Validierungsbeleg: tests/pb/test_control_flow_core.pb; tests/integration/pbxa64/control_flow/test_control_flow_comprehensive.pb

FUNCTION PBMAIN () AS LONG
    LOCAL x AS LONG
    x = 5
    IF x > 5 THEN
        FUNCTION = 1
    ELSE
        FUNCTION = 0
    END IF
END FUNCTION

Verhalten: END IF beendet den mehrzeiligen IF-Block und fuehrt alle Zweige am gleichen Merge-Punkt zusammen.

Siehe auch

  • IF
  • ELSEIF
  • Sonst
  • Kontrollflussreferenz


#ENDASM - Inline-ASM-Block beenden — PBXB64 Help

Startseite › General Reference › #ENDASM - Inline-ASM-Block beenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

#ENDASM - Inline-ASM-Block beenden

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

#ASM
  nop
#ENDASM

Detailverhalten

Beendet einen #ASM-Block in PB-Quelle.

Praktische Verwendung

Verwenden Sie diesen Abschluss immer nur fuer den passenden #ASM-Block. In einem Test sollte der opener direkt vor dem Inhalt stehen und dieser Marker direkt danach folgen, damit der scanner den Block eindeutig schliesst.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Verwenden Sie #ENDASM nicht ausserhalb eines passenden #ASM-Blocks. Ein zu fruehes oder unpassendes Schliessen muss als Quellenfehler behandelt werden.

Verifiziertes Beispiel

Abgedeckt durch examples/basic/test_inline_asm_struct_nested.pb (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.


#ENDC - Eingebettete C-Quelle beenden — PBXB64 Help

Startseite › General Reference › #ENDC - Eingebettete C-Quelle beenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

#ENDC - Eingebettete C-Quelle beenden

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

#ENDC

Detailverhalten

Beendet einen #CCODE-Block.

Praktische Verwendung

Verwenden Sie diesen Abschluss immer nur fuer den passenden #C-Block. In einem Test sollte der opener direkt vor dem Inhalt stehen und dieser Marker direkt danach folgen, damit der scanner den Block eindeutig schliesst.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Verwenden Sie #ENDC nicht ausserhalb eines passenden #C-Blocks. Ein zu fruehes oder unpassendes Schliessen muss als Quellenfehler behandelt werden.

Verifiziertes Beispiel

Abgedeckt durch examples/hybrid/pbmain_hybrid.pb (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


#ENDFASM - FASM-kompatiblen ASM-Block beenden — PBXB64 Help

Startseite › General Reference › #ENDFASM - FASM-kompatiblen ASM-Block beenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

#ENDFASM - FASM-kompatiblen ASM-Block beenden

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

#ENDFASM

Detailverhalten

Beendet einen #FASM-Block.

Praktische Verwendung

Verwenden Sie diesen Abschluss immer nur fuer den passenden #FASM-Block. In einem Test sollte der opener direkt vor dem Inhalt stehen und dieser Marker direkt danach folgen, damit der scanner den Block eindeutig schliesst.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Verwenden Sie #ENDFASM nicht ausserhalb eines passenden #FASM-Blocks. Ein zu fruehes oder unpassendes Schliessen muss als Quellenfehler behandelt werden.

Verifiziertes Beispiel

Abgedeckt durch examples/basic/test_inline_asm_struct_nested.pb (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.


#ENDJS - JavaScript-Block beenden — PBXB64 Help

Startseite › General Reference › #ENDJS - JavaScript-Block beenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

#ENDJS - JavaScript-Block beenden

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

#ENDJS

Detailverhalten

Beendet den Tokenbereich eines #JS-Quellblocks.

Praktische Verwendung

Verwenden Sie diesen Abschluss immer nur fuer den passenden #JS-Block. In einem Test sollte der opener direkt vor dem Inhalt stehen und dieser Marker direkt danach folgen, damit der scanner den Block eindeutig schliesst.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Verwenden Sie #ENDJS nicht ausserhalb eines passenden #JS-Blocks. Ein zu fruehes oder unpassendes Schliessen muss als Quellenfehler behandelt werden.

Verifiziertes Beispiel

Abgedeckt durch PB keyword compatibility (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


#ENDPB - Eingebetteten PB-Block beenden — PBXB64 Help

Startseite › General Reference › #ENDPB - Eingebetteten PB-Block beenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

#ENDPB - Eingebetteten PB-Block beenden

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

#ENDPB

Detailverhalten

Beendet einen #PB-Block.

Praktische Verwendung

Verwenden Sie diesen Abschluss immer nur fuer den passenden #PB-Block. In einem Test sollte der opener direkt vor dem Inhalt stehen und dieser Marker direkt danach folgen, damit der scanner den Block eindeutig schliesst.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Verwenden Sie #ENDPB nicht ausserhalb eines passenden #PB-Blocks. Ein zu fruehes oder unpassendes Schliessen muss als Quellenfehler behandelt werden.

Verifiziertes Beispiel

Abgedeckt durch PB keyword compatibility (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Auflisten von Sammlungen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Sammlungen aufzählen

Auflisten von Sammlungen

Eine Sammlung ist einfach eine Menge oder Gruppe von Elementen, auf die jeweils über eine eigene Schnittstelle zugegriffen werden kann. Zum Beispiel Microsoft Word? Es können mehrere Dokumente gleichzeitig geöffnet sein, und es kann bereitgestellt werden

Typ:Struktur |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Daher geht es bei der Aufzählung einer Sammlung lediglich darum, die Anzahl der Elemente in der Sammlung zu bestimmen, eine Schleife zu durchlaufen und die entsprechenden Informationen für ein oder mehrere Schnittstellenmitglieder der Sammlung abzurufen.

Wir beginnen mit der Visual Basic-Syntax und zeigen, wie Sie dieselbe Aufgabe mit PowerBASIC ausführen.

Die Visual Basic-Syntax zum Aufzählen einer Sammlung sieht etwa so aus:

Element als InterfaceItem dimmen

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Auflisten von Sammlungen soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Auflisten von Sammlungen mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


ENVIRON / ENVIRON$ - PBXB64-Compiler-Hilfe

Startseite › BASIC-Frontend › Befehlsreferenz › System & Umgebung › ENVIRON / ENVIRON$
Hilfe zum PBXB64-Compiler

ENVIRON / ENVIRON$

ENVIRON$ liest die Umgebungstabelle des aktuellen Prozesses. ENVIRON aendert dieselbe prozesslokale Tabelle, indem eine Variable gesetzt oder geloescht wird.

Typ: Funktion und Anweisung | Kategorie: System & Umgebung

PBXB64-Status: VERFUEGBAR — fokussierte Implementierung, kein Stub

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = ENVIRON$({ parameter_string | n })
ENVIRON string_expression

Beschreibung

Mit einem Zeichenfolgenargument liefert ENVIRON$ den Wert der benannten Umgebungsvariablen aus dem aktuellen Prozess. Wenn der Name nicht vorhanden ist oder keinen Wert hat, gibt PBXB64 eine leere Zeichenfolge zurueck.

Mit einem numerischen Argument behandelt ENVIRON$ den Wert als einsbasierten Index in der aktuellen Umgebungstabelle und liefert den vollstaendigen Eintrag NAME=VALUE. Ein Index ausserhalb des Bereichs liefert eine leere Zeichenfolge.

Die Anweisungsform wertet string_expression als NAME=VALUE aus. PBXB64 ruft den eingebetteten Laufzeithelfer bestof_environ_set auf, der die Win32-API SetEnvironmentVariableA verwendet. Ein nicht leerer Wert setzt oder aktualisiert die prozesslokale Variable. Ein abschliessendes Gleichheitszeichen ohne Wert, zum Beispiel "NAME=", loescht die prozesslokale Variable.

Die geaenderte Umgebung gehoert zum laufenden Programmprozess. Sie schreibt nicht die uebergeordnete Shell, die Systemumgebung oder dauerhaft gespeicherte Benutzerumgebungswerte um. Vererbung an Kindprozesse und Codepage-Randfaelle sind breitere Kompatibilitaetsthemen und muessen separat validiert werden, bevor sie als vollstaendig dokumentiert werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ENVIRON "PBXB64_SAMPLE_ENV=ready"
    IF ENVIRON$("PBXB64_SAMPLE_ENV") <> "ready" THEN
        FUNCTION = 1
        EXIT FUNCTION
    END IF

    ENVIRON "PBXB64_SAMPLE_ENV="
    FUNCTION = 0
END FUNCTION

Praktische Verwendung

Verwenden Sie ENVIRON$, um Konfiguration zu lesen, die von einem Launcher, Skript, Dienst-Wrapper oder Test-Harness geliefert wurde. Verwenden Sie ENVIRON, wenn ein Programm seine eigene Prozessumgebung anpassen muss, bevor spaeter im selben Prozess Code Umgebungsvariablen liest.

name$ = "PBXB64_MODE"
ENVIRON name$ + "=test"
mode$ = ENVIRON$(name$)
ENVIRON "PBXB64_MODE="
missing$ = ENVIRON$("PBXB64_MODE")

Parameter und Ergebnisse

parameter_string ist der Name der zu lesenden Umgebungsvariablen. n ist ein einsbasierter Index in den Umgebungsblock. string_expression fuer die Anweisung muss ein Gleichheitszeichen und davor einen nicht leeren Variablennamen enthalten. Ungueltiger Zuweisungstext wird vom Laufzeithelfer ignoriert und laesst die Umgebung unveraendert.

Einschraenkungen

PBXB64 verwendet fuer diese fokussierte Oberflaeche derzeit ANSI-Win32-Umgebungs-APIs. Unicode-Normalisierung, doppelte Namen, die sich nur durch Gross-/Kleinschreibung unterscheiden, Umgebungsvererbung an gestartete Kindprozesse und dauerhafte Umgebungsspeicherung gehoeren nicht zur zertifizierten Schliessung dieser Seite.

Einschränkungen

Wie in PowerBASIC arbeitet diese Funktion mit der Umgebung des laufenden Prozesses. Eine Zuweisung mit ENVIRON aendert keine globale Windows-Einstellung und ist nach dem Ende des Programms nicht dauerhaft sichtbar. Programme, die eine dauerhafte Benutzer- oder Systemumgebung aendern muessen, benoetigen eine eigene Win32- oder Registry-basierte Implementierung und eigene Tests.

Validierungsbeleg

Registrierter Test: tests/pb/test_environ_statement.pb ist in tests/validate.toml unter pb_linkrun registriert. Er verwendet einen eindeutigen Wegwerf-Variablennamen, beweist dass das Loeschen einer fehlenden Variablen harmlos ist, beweist ENVIRON name=value, beweist eine Aktualisierung auf einen zweiten Wert und beweist, dass ENVIRON name= die Variable loescht, wie durch ENVIRON$ beobachtet.

Erwartetes Ergebnis: das registrierte Programm schreibt nichts nach stdout und endet mit Exit-Code 0.

Test- und Dokumentationshinweise

Umgebungstests sollten eindeutige Namen verwenden und mit ENVIRON "NAME=" aufraeumen. Vermeiden Sie Tests, die von maschinenspezifischen Variablen wie PATH-Inhalten, installierten IDE-Variablen oder Dienstkonto-Zustand abhaengen, sofern der Test diese Werte nicht ausdruecklich kontrolliert.

Siehe auch

  • COMMAND$
  • RUN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


EOF – PBXB64-Compiler-Hilfe

Startseite › Funktionen › EOF

EOF

Gibt den End-of-File-Status einer geöffneten Datei zurück oder

Typ:Funktion |Kategorie:Datei-E/A

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

y = EOF([#] filenum& )

Beschreibung

Verwenden Sie EOF, um beim Lesen der Daten festzustellen, wann das Ende einer Datei erreicht wurde. filenum& ist die Dateinummer, die beim Öffnen der Datei angegeben wurde. EOF gibt -1 (TRUE) zurück, wenn das Ende der angegebenen Datei erreicht wurde oder wenn beim Versuch, das Ende der Datei zu überprüfen, ein Fehler auftritt. Andernfalls gibt EOF 0 (FALSE) zurück.

Wenn filenum& keine gültige, geöffnete Datei ist, tritt ein Laufzeitfehler 53 auf („Datei nicht gefunden“). Wenn filenum& für eine Binärdatei steht, gibt EOF nur dann TRUE zurück, wenn der letzte Dateivorgang ein Lesevorgang war und dieser Vorgang die angeforderte Anzahl von Bytes nicht lesen konnte.

Die EOF-Funktion kann auch mit den Anweisungen COMM LINE und TCP LINE verwendet werden, um zu erkennen, dass eine unvollständige Zeile empfangen wurde. Normalerweise lesen diese Anweisungen Daten, bis ein $CRLF-Zeichenpaar gefunden wird. In diesem Fall gibt EOF 0 (FALSE) zurück. Selbst wenn jedoch kein $CRLF gefunden wurde, werden die Anweisungen beendet, wenn keine weiteren Daten verfügbar sind. In diesem Fall geben sie alle bereits gesammelten Daten zurück und setzen EOF auf -1 (TRUE).

In vielen Fällen wäre es ratsam, EOF nach jeder COMM-LINIE und TCP-LINIE zu testen, um zu überprüfen, ob eine vollständige Zeile empfangen wurde. In manchen Fällen möchten Sie die Anweisung möglicherweise noch einmal oder mehrmals ausführen und dabei die Daten kombinieren, um eine vollständige Textzeile zu erhalten.

Siehe auch

  • KOMMLINIE
  • LOC
  • LOF
  • OFFEN
  • TCP-LINIE

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


ERASE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › LÖSCHEN

LÖSCHEN

Freigabe aufheben

Typ:Anweisung |Kategorie:Variablen und Umfang

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ERASE array [()] [, array [()]] ...

Beschreibung

Auch der den einzelnen Elementen zugewiesene Speicher (sofern es sich um dynamische Strings, Objekte, Varianten usw. handelt) wird freigegeben. ERASE gibt den gesamten Speicher für die Arrays LOCAL , STATIC und GLOBAL frei. Nachdem ein Array gelöscht wurde, kann der Versuch, auf das Array zuzugreifen, zu einer allgemeinen Schutzverletzung (GPF) führen. Lokale Arrays werden beim Verlassen der Untergruppe/Funktion/Methode/Eigenschaft, die sie erstellt hat, implizit gelöscht.

Der Name des Arrays, dessen Zuordnung aufgehoben werden soll. Klammern sind optional, werden aber aus Gründen der Klarheit des Quellcodes empfohlen.

Eine Methode, um zu überprüfen, ob ein Array dimensioniert wurde, ohne ein GPF auszulösen, besteht darin, die Funktionen LBOUND und UBOUND wie folgt zu verwenden:

IF UBOUND(array) - LBOUND(array) = -1 THEN

' array() ist nicht zugewiesen

END IF

ERASE kann die Zuordnung eines Arrays aufheben, das als Parameter an eine Prozedur übergeben wurde, jedoch nur, wenn das Array als Referenz (BYREF) übergeben wurde. Um den Inhalt eines Arrays wieder in seinen initialisierten Zustand zu versetzen, verwenden Sie REDIM oder RESET .

Einschränkungen

Absolute Arrays (die von DIM...AT erstellt wurden) werden von ERASE unterschiedlich behandelt. Ein explizites ERASE gibt bei Bedarf die einzelnen Elemente eines absoluten Arrays frei, der gesamte Datenblock bleibt jedoch unverändert, da keine Annahmen über seinen Ursprung getroffen werden können. Es liegt in der Verantwortung des Programmierers, sicherzustellen, dass der vom absoluten Array überlagerte Speicherblock korrekt verarbeitet wird. Bei einem impliziten ERASE (Unter-/Funktions-/Methoden-/Eigenschaftsausgang) eines LOCAL-Absolutarrays wird der interne Array-Deskriptor deaktiviert, es werden jedoch keinerlei Änderungen an den einzelnen Datenelementen oder dem gesamten Block vorgenommen. Mit RESET können Arrays auf Nullen oder leere Strings gesetzt werden, ohne den Datenblock freizugeben.

Siehe auch

  • ARRAYATTR
  • DIM
  • REDIM
  • ZURÜCKSETZEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ERL$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › ERL$

ERL$

Gib den letzten zurück

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

position$ = ERL$

Beschreibung

Gibt eine Zeichenfolge zurück, die den Namen der letzten (aktuellsten) Beschriftung, Zeilennummer oder Prozedur enthält, die vor dem letzten Laufzeitfehler innerhalb der aktuellen Sub , Function , Method oder Property ausgeführt wurde. Um ein hohes Effizienzniveau aufrechtzuerhalten, ist der zurückgegebene Name auf die ersten 8 Zeichen des tatsächlichen Namens beschränkt.

Siehe auch

  • ERL
  • ERR
  • ERRCLEAR
  • FEHLER
  • FEHLER$
  • Fehlerübersicht
  • Fehler-Trapping
  • AUF FEHLER

Fehlerpfad-Prüfung

Fehlerbehandlungsseiten sollen den normalen Pfad und den Fehlerpfad zeigen. Ein vollständiges Beispiel löst absichtlich einen bekannten Fehler aus, prüft den dokumentierten Fehlerwert, stellt wieder her oder beendet sauber und zeigt, dass spätere Anweisungen in der erwarteten Reihenfolge laufen.

Zustandsregeln

Dokumentieren Sie, welche Variablen, Handler oder Systemwerte durch die Operation geändert werden. Vermeiden Sie Beispiele, die einen Fehler durch ungeprüftes Weiterlaufen verdecken.

Migrationshinweise

Beim Portieren älteren PB-Codes sind Annahmen zu Zeilennummern, Handler-Gültigkeit, verschachtelten Prozeduren und Windows-API-Fehlern neu zu prüfen.


ERL-Systemvariable – PBXB64-Compiler-Hilfe

Startseite › Funktionen › ERL-Systemvariable

ERL-Systemvariable

Gib den letzten zurück

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

nline = ERL

Beschreibung

Gibt die letzte (aktuellste) Zeilennummer zurück, die vor dem letzten Laufzeitfehler innerhalb der aktuellen Sub , Function , Method oder Property aufgetreten ist. Bei ERL handelt es sich bei den Zeilennummern um die traditionell-grundlegende Zeilennummerierung, nicht um die Zeile des physischen Quellcodes.

Siehe auch

  • ERL$
  • ERR
  • ERRCLEAR
  • FEHLER
  • FEHLER$
  • Fehlerübersicht
  • Fehler-Trapping
  • AUF FEHLER

Fehlerpfad-Prüfung

Fehlerbehandlungsseiten sollen den normalen Pfad und den Fehlerpfad zeigen. Ein vollständiges Beispiel löst absichtlich einen bekannten Fehler aus, prüft den dokumentierten Fehlerwert, stellt wieder her oder beendet sauber und zeigt, dass spätere Anweisungen in der erwarteten Reihenfolge laufen.

Zustandsregeln

Dokumentieren Sie, welche Variablen, Handler oder Systemwerte durch die Operation geändert werden. Vermeiden Sie Beispiele, die einen Fehler durch ungeprüftes Weiterlaufen verdecken.

Migrationshinweise

Beim Portieren älteren PB-Codes sind Annahmen zu Zeilennummern, Handler-Gültigkeit, verschachtelten Prozeduren und Windows-API-Fehlern neu zu prüfen.


ERR-Systemvariable – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Systemvariable ERR

ERR-Systemvariable

Gibt den Fehlercode des letzten PowerBASIC-Laufzeitfehlers zurück.

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

y = ERR
ERR = ErrNum
y = ERRCLEAR
ERRCLEAR

Beschreibung

ERR und ERRCLEAR geben den Fehlercode des letzten Laufzeitfehlers in der aktuellen Sub , Function , Method oder Property zurück. Diese Nummer kann nach jedem kritischen Vorgang getestet werden, sodass entsprechender Fehlerbehandlungscode ausgeführt werden kann.

Sie können ERR auch einen Wert zuweisen. Dies ähnelt der Ausführung einer ERROR-Anweisung, mit der Ausnahme, dass keine Verzweigung zu einer Fehler-Trap-Routine generiert wird. Stattdessen spiegeln nachfolgende Tests von ERR und ERRCLEAR ErrNum wider.

ERRCLEAR gibt den Fehlercode des letzten Laufzeitfehlers zurück. Darüber hinaus wird die interne Fehlercodevariable ERR von PowerBASIC auf Null zurückgesetzt, nachdem Sie darauf verwiesen haben. Schließlich emuliert es RESUME FLUSH, sodass keine RESUME-Ausführung erforderlich oder zulässig ist. Dies stellt sicher, dass Sie beim nächsten Test von ERR oder ERRCLEAR garantiert eine Null erhalten, es sei denn, in der Zwischenzeit ist tatsächlich ein neuer Fehler aufgetreten.

ERRCLEAR kann auch als Anweisung verwendet werden, um ERR auf Null zurückzusetzen.

WICHTIG: Lesen Sie sich unbedingt die Fehler und das Fehler-Trapping durch.

Einschränkungen

Gültige Laufzeitfehlerwerte liegen im Bereich von 0 bis 255. Ein Wert von 0 bedeutet, dass kein Fehler vorliegt. Der Versuch, einen Fehlerwert (mit der ERROR-Anweisung) außerhalb dieses Bereichs festzulegen, führt dazu, dass der Wert in einen Laufzeitfehler 5 („Ungültiger Funktionsaufruf“) umgewandelt wird.

Siehe auch

  • FEHLER
  • FEHLER$
  • Fehlerübersicht
  • Fehler-Trapping
  • AUF FEHLER

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


Fehler-Trapping – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Fehler-Trapping

Fehler-Trapping

Mit Fehlerfallen können Sie Laufzeitfehler abfangen und behandeln, anstatt dass Programme einen schwerwiegenden Fehler kurzerhand abbrechen oder ignorieren, was möglicherweise zu Datenverlusten führt.

Typ:Schlüsselwort |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Um Fehler abzufangen, müssen Sie drei Schritte ausführen, die in den folgenden Abschnitten beschrieben werden:

Hier ist zum Beispiel ein Code, der ein Array mit den Dateinamen aus einem Verzeichnis füllt. In diesem Abschnitt wird ein vollständiges Fehler-Trapping hinzugefügt, um Laufzeitfehler zu verhindern, wenn der Benutzer ein Verzeichnis auswählt, das keine Dateien enthält, oder ein Laufwerk, das nicht bereit ist.

SUB GetFileNames(File() AS STRING)

DIM CurrentDir AS STRING

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Fehlerpfad-Prüfung

Fehlerbehandlungsseiten sollen den normalen Pfad und den Fehlerpfad zeigen. Ein vollständiges Beispiel löst absichtlich einen bekannten Fehler aus, prüft den dokumentierten Fehlerwert, stellt wieder her oder beendet sauber und zeigt, dass spätere Anweisungen in der erwarteten Reihenfolge laufen.

Zustandsregeln

Dokumentieren Sie, welche Variablen, Handler oder Systemwerte durch die Operation geändert werden. Vermeiden Sie Beispiele, die einen Fehler durch ungeprüftes Weiterlaufen verdecken.

Migrationshinweise

Beim Portieren älteren PB-Codes sind Annahmen zu Zeilennummern, Handler-Gültigkeit, verschachtelten Prozeduren und Windows-API-Fehlern neu zu prüfen.


Fehler-Trapping-Zusammenfassung – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Fehler-Trapping-Zusammenfassung

Zusammenfassung der Fehlermeldungen

Error Trapping ist eine nützliche und leistungsstarke Funktion von PowerBASIC. Viele Programmierer vermeiden das Abfangen von Fehlern aufgrund der erheblichen Strafen, die andere BASIC-Dialekte verhängen, wenn das Fehler-Trapping aktiviert ist.

Typ:Schlüsselwort |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Schließlich enthält PowerBASIC jetzt die folgende Liste vordefinierter (integrierter) Equates, um die Erstellung ausführlicherer Fehlerbehandlungscodes zu unterstützen. Dazu gehören:

%ERR_ILLEGALFUNCTIONCALL

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Fehlerpfad-Prüfung

Fehlerbehandlungsseiten sollen den normalen Pfad und den Fehlerpfad zeigen. Ein vollständiges Beispiel löst absichtlich einen bekannten Fehler aus, prüft den dokumentierten Fehlerwert, stellt wieder her oder beendet sauber und zeigt, dass spätere Anweisungen in der erwarteten Reihenfolge laufen.

Zustandsregeln

Dokumentieren Sie, welche Variablen, Handler oder Systemwerte durch die Operation geändert werden. Vermeiden Sie Beispiele, die einen Fehler durch ungeprüftes Weiterlaufen verdecken.

Migrationshinweise

Beim Portieren älteren PB-Codes sind Annahmen zu Zeilennummern, Handler-Gültigkeit, verschachtelten Prozeduren und Windows-API-Fehlern neu zu prüfen.


Fehlerübersicht – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Fehlerübersicht

Fehlerübersicht

Im Gegensatz zu den DOS-Versionen von PowerBASIC verfolgen die Windows-Versionen von PowerBASIC eine völlig andere Philosophie: den kleinstmöglichen und schnellstmöglichen Code zu generieren. Folglich ist die Fehlerbehandlung einfach

Typ:Schlüsselwort |Kategorie: Fehlerreferenz

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Fehler bei der Kompilierung entstehen, wenn der Compiler beim Kompilieren ein Problem in Ihrem Quellcode nicht lösen kann. Beispiele hierfür sind: Tippfehler; Variablen falsche Werte zuweisen (z. B. „x$ = 5“); und der Versuch, einen Variablennamen zu verwenden, der nicht dimensioniert wurde, als OPTION EXPLICIT (oder #DIM ALL ) aktiviert wurde.

Wenn ein Kompilierzeitfehler erkannt wird, zeigt PowerBASIC ein Meldungsfeld mit dem Fehlercode sowie einer kurzen Beschreibung sowie der Zeilennummer im Code an, in der der Fehler aufgetreten ist. Die fehlerhafte Codezeile wird ebenfalls angezeigt. Wenn Sie die PowerBASIC-IDE verwenden, wird die Einfügemarke in die fehlerhafte Zeile verschoben, sobald der Fehlerdialog geschlossen wurde.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Fehlerpfad-Prüfung

Fehlerbehandlungsseiten sollen den normalen Pfad und den Fehlerpfad zeigen. Ein vollständiges Beispiel löst absichtlich einen bekannten Fehler aus, prüft den dokumentierten Fehlerwert, stellt wieder her oder beendet sauber und zeigt, dass spätere Anweisungen in der erwarteten Reihenfolge laufen.

Zustandsregeln

Dokumentieren Sie, welche Variablen, Handler oder Systemwerte durch die Operation geändert werden. Vermeiden Sie Beispiele, die einen Fehler durch ungeprüftes Weiterlaufen verdecken.

Migrationshinweise

Beim Portieren älteren PB-Codes sind Annahmen zu Zeilennummern, Handler-Gültigkeit, verschachtelten Prozeduren und Windows-API-Fehlern neu zu prüfen.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Fehlerübersicht soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Fehlerübersicht mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


ESCAPE$ - PBXB64 Help

Startseite › General Reference › ESCAPE$

ESCAPE$

Maskiert Text fuer web-sicheren Transport.

Kind: Runtime helper | Category: WEB / Runtime Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

escaped$ = ESCAPE$(text$)

Beschreibung

Diese eigene Seite stellt sicher, dass Befehlsuche, Stichwortindex und direkte Dateinamenpruefung die getestete Laufzeitfunktion unmittelbar finden. Die gruppierte WEB-Seite bleibt die breitere Familienreferenz.

Diese Seite dokumentiert einen deterministischen String-Helfer. Kodierungsfunktionen liefern transformierten Text zurueck, waehrend Hash-Funktionen feste, kleingeschriebene Hex-Digests liefern.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL rc AS LONG
    escaped$ = ESCAPE$("a&b")
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_web_all.pb`.

Grenzen

Dokumentieren Sie hier nur die getesteten Byte- oder String-Transformationen. Wenn es einen Rueckwaerts-Helfer gibt, pruefen Sie ihn separat, statt Symmetrie aus der Vorwaertsform abzuleiten.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

ESCAPE$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

ESCAPE$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer encoding-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

ESCAPE$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


EVAL / EVAL$ - PBXB64 Help

Startseite › General Reference › EVAL / EVAL$

EVAL / EVAL$

Wertet einen numerischen Ausdruck aus einer Zeichenkette aus oder liefert Zeichenkettentext ueber EVAL$ zurueck. PBXB64 unterstuetzt Integer-Arithmetik, Vorrangregeln, Klammern, unaere Vorzeichen, Leerraum und einen sicheren Rueckfall bei ungueltigen Ausdruecken.

Kind: PowerBASIC feature | Category: PowerBASIC / Tested Feature

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

n& = EVAL(expression$)
s$ = EVAL$(text$)

Beschreibung

Diese Seite beschreibt das PBXB64-Verhalten, das durch die aktuelle Validierungsmatrix abgedeckt ist. Verwenden Sie die hier gezeigte Syntax fuer Regressionstests; weitergehende PowerBASIC-Formen gelten als separate Kompatibilitaetsarbeit, sofern keine andere Seite sie dokumentiert.

Unterstuetzter Umfang

Die dokumentierte Teilmenge ist absichtlich genau: Beispiele verwenden bevorzugt skalare LONG-Werte, Array-Beispiele benutzen normale PB-logische Indizes, und laufzeitabhaengige Operationen sollen immer den Rueckgabestatus pruefen. Wenn ein Feature sowohl Anweisungs- als auch Funktionsschreibweise besitzt, beschreibt diese Seite den funktionsorientierten Seiteneintrag und verweist auf die breitere BASIC-Referenz.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    IF EVAL("2 + 3 * 4") <> 14 THEN FUNCTION = 1
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_eval_numeric.pb`.

Fuer Release-Arbeiten sollte jede Syntaxform einen kleinen ausfuehrbaren Test besitzen. Ein guter Test initialisiert alle Eingaben, fuehrt den dokumentierten Befehl oder die Funktion aus, prueft das exakte Ergebnis und liefert bei Fehler einen von Null verschiedenen Exit-Code. Dadurch bleiben Hilfeaussagen an reproduzierbares Verhalten eines isolierten PBXB64-Compilers gebunden.

Grenzen

Nicht gezeigte PowerBASIC-Varianten duerfen aus dieser Seite nicht als unterstuetzt abgeleitet werden. Formen, die hier nicht stehen, benoetigen eigene Implementierung, Diagnostik, Tests und Hilfetext, bevor sie als abgeschlossen beschrieben werden.

Siehe auch

  • BASIC Language Reference
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Eine Variable auswerten – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Eine Variable auswerten

Auswerten einer Variablen

Um den Wert der Position anzuzeigen, klicken Sie mit der rechten Maustaste auf die Variable und wählen Sie im Kontextmenü den Eintrag „Variable auswerten“. Da es sich hierbei um ein kontextsensitives Menü handelt, lautet die Meldung tatsächlich „Position auswerten“.

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

In den nächsten paar Zeilen soll das Wort vom Zeilenanfang entfernt und in SecondString$ eingefügt werden. Um zu überprüfen, ob diese Routine ordnungsgemäß funktioniert, sollten Sie die Werte von FirstString$ und SecondString$ untersuchen, bevor und nachdem die Routine sie ändert. Der Debugger sollte Folgendes anzeigen:

Sein oder Nichtsein; das ist die Frage.

Anhand der Zeichenfolge können Sie erkennen, dass das erste Leerzeichen an Position 3 erscheinen sollte und dass das Programm diese Position korrekt ermittelt hat. Die Variable SecondString$ sollte das zuletzt verarbeitete Wort enthalten und noch keinen Wert haben. Sie können dies überprüfen, indem Sie SecondString$ in das Feld „Variablenname“ eingeben. Wenn Sie dies tun, werden Sie keinen Fehler finden.

Bisher scheint alles normal zu sein. Drücken Sie ESCAPE, um zum Hauptteil des Debuggers zurückzukehren, und drücken Sie dann F8, um das Programm um eine weitere Zeile weiterzuleiten. Da Sie bereits wissen, dass die Position nicht 0 ist, erfahren Sie, was Sie wissen müssen, indem Sie mehrmals F8 drücken und anhalten, wenn die Ausführungsleiste über dem letzten END IF dieser Routine liegt. Zu diesem Zeitpunkt wurden sowohl FirstString$ als auch SecondString$ verarbeitet.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Auswerten einer Variablen soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Auswerten einer Variablen mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


EREIGNISQUELLE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › EREIGNISQUELLE

EVENT SOURCE

Erklären Sie eine

Typ:Anweisung |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

EVENT SOURCE InterfaceName

Beschreibung

Bei Objekten ruft ein Clientmodul normalerweise ein Servermodul auf, um bei Bedarf bestimmte Vorgänge auszuführen. In vielen Situationen ist es für einen Server jedoch praktisch und effizient, seinen Client sofort über eine Bedingung oder ein Ereignis zu benachrichtigen, ohne den Client zu zwingen, sich nach dem Status zu erkundigen. Zu gegebener Zeit ruft der Server eine Client-Methode zurück und übergibt Informationen über die Methodenparameter. Dies ist das genaue Gegenteil der normalen Kommunikation, da das Servermodul nun das Clientmodul aufruft. Tatsächlich fungiert der Client als Server zur Verarbeitung dieser Ereignisse. In der Welt der Objekte soll ein Server, der solche „Ereignismethoden“ aufrufen kann, einen „Verbindungspunkt“ bieten. Ein Verbindungspunkt kann mit COM-Objekten oder internen Objekten verwendet werden. Darüber hinaus kann entweder eine direkte Schnittstelle oder die DISPATCH-Schnittstelle verwendet werden. Ereignismethoden können Parameter annehmen, aber möglicherweise kein Ergebnis zurückgeben.

Jede von PowerBASIC erstellte Serverklasse bietet möglicherweise bis zu vier Ereignisschnittstellen. Ein Clientmodul kann eine oder alle dieser Ereignisschnittstellen abonnieren. Wenn es für das Serverobjekt an der Zeit ist, den Client über ein Ereignis zu benachrichtigen, wird die RAISEEVENT-Anweisung verwendet. Für die Dispatch-Schnittstelle wird stattdessen OBJECT RAISEEVENT verwendet. RAISEEVENT darf nur innerhalb einer Klasse erscheinen, die die Event Source-Schnittstelle deklariert.

Der Client muss mit der Anweisung EVENTS FROM eine Verbindung zum Server initiieren und die Verbindung anschließend mit der Anweisung EVENTS END trennen.

Ein Verbindungspunkt kann einer Ereignismethode, mehreren Ereignismethoden oder überhaupt keiner Ereignismethode zugeordnet sein. Immer wenn eine RAISEEVENT-Anweisung oder OBJECT RAISEEVENT-Anweisung ausgeführt wird, werden nacheinander alle an das Quellobjekt angehängten Ereignismethoden aufgerufen. Es gibt keine Garantie für die Reihenfolge der Aufrufe und Sie müssen die Möglichkeit in Betracht ziehen, dass RAISEEVENT mit einem ByRef-Parameter den Wert einer Parametervariablen ändern könnte, bevor eine bestimmte Ereignismethode ausgeführt wird.

Schnittstellenname

Gibt den Schnittstellennamen „Ereignisquelle“ an. Wenn InterfaceName DISPATCH ist, können Sie mit der OBJECT RAISEEVENT-Anweisung darauf verweisen – andernfalls werden reguläre Methodenverweise verwendet.

Siehe auch

  • EVENTS
  • INTERFACE (Direct)
  • INTERFACE (IDBind)
  • Just what is COM?
  • METHOD
  • OBJEKT-RAISEEVENT
  • RAISEEVENT
  • Was sind Verbindungspunkte?

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


EREIGNISSE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › EREIGNISSE

EVENTS

Anbringen oder abnehmen

Typ:Anweisung |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIM oSource AS InterfaceName
DIM oEvent AS EventInterface
LET oSource = NEWCOM CLSID $ClassId
LET oEvent = CLASS "EventClass"
EVENTS FROM oSource CALL oEvent
[ statements ]
EVENTS END oEvent

Beschreibung

Im obigen Quellcodebeispiel ist oEvent eine Objektvariable, die auf ein Event-Handler-Objekt verweist, und oSource ist eine Objektvariable, die auf ein Ereignisquellobjekt verweist, das Ereignisse generiert.

Die EVENTS FROM-Anweisung fügt Ereignishandlercode an eine Ereignisquellenobjektvariable an. Die Objektvariable oEvent muss als unterstützte Ereignisschnittstelle deklariert werden, während „?EventClass“ die Klasse angibt, die den Ereignishandlercode implementiert. Die Objektvariable oSource gibt die Ereignisquelle an. EVENTS END trennt den Ereignishandler von der Ereignisquelle.

Im Allgemeinen „quellet“ ein Serverobjekt Ereignisse und ein Clientobjekt „verarbeitet“ Ereignisse, indem es eine METHODE bereitstellt, die vom Server aufgerufen wird, um eine benutzerdefinierte Benachrichtigung durchzuführen. Bei diesem Event-Handler handelt es sich um Code im Client-Objekt, der manchmal auch als „Event-Senke“ bezeichnet wird (analog zu den elektrotechnischen Begriffen Quelle/Senke).

Ein oder mehrere Clients können Ereignisse von einem Serverobjekt „abonnieren“, indem sie die Anweisung EVENTS FROM ausführen. Das Abonnement wird durch die Ausführung der EVENTS END-Anweisung beendet. Wenn der Server RAISEEVENT oder OBJECT RAISEEVENT ausführt, werden alle Clients aufgerufen, die sich von diesen Ereignissen abgemeldet haben. PowerBASIC-Server unterstützen bis zu 32 gleichzeitige Client-Abonnenten pro Serverobjekt.

Ereignisquellen und Ereignishandler können innerhalb eines einzelnen Moduls oder über COM-Dienste verwendet werden, die vom Windows-Betriebssystem bereitgestellt werden.

Siehe auch

  • CLASS
  • EVENT SOURCE
  • INTERFACE (Direct)
  • INTERFACE (IDBind)
  • Just what is COM?
  • OBJEKT-RAISEEVENT
  • RAISEEVENT
  • Was ist überhaupt ein Objekt?
  • Was sind Verbindungspunkte?

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


EXE.Inst-Mitglied – PBXB64-Compiler-Hilfe

Startseite › Funktionen › EXE.Inst-Mitglied

EXE.Inst-Mitglied

Gibt Informationen über das ausgeführte Programm zurück.

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

h& = EXE.Inst
f$ = EXE.Extn$
f$ = EXE.Full$
f$ = EXE.Name$
f$ = EXE.Namex$
f$ = EXE.Path$

Beschreibung

Mit EXE können Sie Informationen über das ausgeführte Programm abrufen, einschließlich des vollständigen Pfads und Dateinamens oder nur eines ausgewählten Teils davon. Wenn sich die Referenz physisch in einer DLL befindet, beschreiben die zurückgegebenen Daten das ausführbare Programm, das sie geladen hat.

EXE.Inst

Dies gibt das Instanzhandle (ein DWord) des Programms zurück, das gerade ausgeführt wird.

EXE.Extn$

Dies gibt die Erweiterung (mit einem führenden Punkt) des Programms zurück, das gerade ausgeführt wird.

EXE.Full$

Dies gibt das vollständige Laufwerk, den Pfad, den Dateinamen und die Erweiterung des Programms zurück, das gerade ausgeführt wird.

EXE.Name$

Dies gibt nur den Dateinamen des Programms zurück, das gerade ausgeführt wird.

EXE.Namex$

Dies gibt den Dateinamen und die Erweiterung des Programms zurück, das gerade ausgeführt wird.

EXE.Pfad$

Dies gibt das vollständige Laufwerk und den Pfad des Programms zurück, das gerade ausgeführt wird.

Siehe auch

  • BEFEHL$
  • PFADNAME$
  • PATHSCAN$

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


Beenden eines Fehlerhandlers – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Beenden eines Fehlerbehandlers

Beenden eines Fehlerhandlers

Sie müssen einen Fehlerhandler mit der RESUME LABEL-Anweisung beenden. Die Ausführung verzweigt sofort zum angegebenen lokalen Label und der ursprüngliche Fehler-Trap-Vorgang wird wiederhergestellt und ist bereit, den nächsten abzufangen

Typ:Schlüsselwort |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Im Beispielprogramm möchten Sie RESUME für eine bestimmte Zeile verwenden. Platzieren Sie die Zeilenbezeichnung vor der Zeile, die eine Benutzereingabe anfordert, um dem Benutzer eine weitere Chance zu geben, einen korrekten Pfad einzugeben.

Hier ist das Beispielprogramm, komplett mit Error Trapping:

SUB GetFileNames(File() AS STRING)

DIM CurrentDir AS STRING

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Fehlerpfad-Prüfung

Fehlerbehandlungsseiten sollen den normalen Pfad und den Fehlerpfad zeigen. Ein vollständiges Beispiel löst absichtlich einen bekannten Fehler aus, prüft den dokumentierten Fehlerwert, stellt wieder her oder beendet sauber und zeigt, dass spätere Anweisungen in der erwarteten Reihenfolge laufen.

Zustandsregeln

Dokumentieren Sie, welche Variablen, Handler oder Systemwerte durch die Operation geändert werden. Vermeiden Sie Beispiele, die einen Fehler durch ungeprüftes Weiterlaufen verdecken.

Migrationshinweise

Beim Portieren älteren PB-Codes sind Annahmen zu Zeilennummern, Handler-Gültigkeit, verschachtelten Prozeduren und Windows-API-Fehlern neu zu prüfen.


#EXPORT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › #EXPORT

#EXPORT

Deklarieren Sie eine Unterfunktion/Funktion mit dem EXPORT-Attribut.

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

#EXPORT SubFuncName [, SubFuncName ...]

Beschreibung

#EXPORT ermöglicht es Ihnen, das EXPORT-Attribut zu einer an anderer Stelle definierten Unter-/Funktion hinzuzufügen. Das EXPORT-Attribut kann sogar zu einer Sub/Funktion in einer SLL hinzugefügt werden, die separat kompiliert wurde.

Der EXPORT-Deskriptor identifiziert eine Unterfunktion/Funktion, auf die zwischen Dynamic Link Libraries (DLLs) und/oder der ausführbaren Hauptdatei, die sie verknüpft, zugegriffen werden kann. Wenn eine Prozedur nicht mit EXPORT markiert ist, wird sie vor diesen anderen Modulen ausgeblendet. Im Allgemeinen ist es am besten, eine Unterfunktion/Funktion in einer SLL nicht als EXPORT zu markieren. Obwohl es syntaktisch akzeptabel ist, kann es Ihre zukünftigen Optionen beim Verknüpfen der SLL mit Hostmodulen einschränken. PowerBASIC empfiehlt, sie in der SLL als COMMON zu markieren und das EXPORT-Attribut im Hostmodul hinzuzufügen.

Es ist einfach, eine SLL zu erstellen, die für denselben Zweck mit einem ausführbaren Programm oder einer dedizierten DLL verknüpft werden kann. Um das EXPORT-Attribut zu einer verknüpften Unterfunktion/Funktion hinzuzufügen, fügen Sie einfach das Wort EXPORT zur DECLARE-Anweisung im Hostmodul hinzu oder fügen Sie eine #EXPORT-Metaanweisung hinzu.

Mit dieser Technik kann Ihre SLL direkt in eine ausführbare Anwendungsdatei eingebunden werden, ohne die Subs/Funktionen als EXPORT zu veröffentlichen. Sie können jedoch dieselbe SLL auch mit einem DLL-Hostmodul verknüpfen, das das EXPORT-Attribut mit #EXPORT hinzufügt.

Angenommen, Sie möchten eine Bibliothek erstellen, die das SUB mit dem Namen XXX veröffentlicht. Sie möchten es in zwei Formen bereitstellen: einer verknüpfbaren SLL und einer Industriestandard-DLL. Erstellen Sie also zunächst einfach die SLL:

#COMPILE SLL = „XXXLib.SLL“

SUB xxx() COMMON

MSGBOX „Hallo“

END SUB

Kompilieren Sie es einfach und schon können Sie es in Ihre Anwendung einbinden. Jetzt möchten Sie aber auch eine DLL erstellen, da diese möglicherweise mit anderen Anwendungen verwendet wird. Es ist einfach so einfach:

#COMPILE DLL = „XXXLib.DLL“

#EXPORT xxx

#LINK „XXXLib.SLL“

Das ist alles. Sie verfügen nun über eine SLL und eine entsprechende DLL, um die Aufgabe der XXX-Prozedur zu erledigen.

Siehe auch

  • #LINK
  • ERKLÄREN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Gleitkomma mit erweiterter Genauigkeit (##) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Gleitkomma mit erweiterter Genauigkeit (##)
Hilfe zum PBXB64-Compiler

Gleitkomma mit erweiterter Genauigkeit (##)

Gleitkommazahlen mit erweiterter Genauigkeit sind die Berechnungsgrundlage in PowerBASIC. Das Typspezifizierzeichen für einen Gleitkommawert mit erweiterter Genauigkeit ist: ##. In PowerBASIC sind alle Gleitkommazahlen ca

Typ:Schlüsselwort |Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Variablen mit erweiterter Genauigkeit erfordern jeweils 10 Byte Speicherplatz. Sie haben einen Bereich von etwa +/- 3,4*10^-4932 bis 1,2*10^4932 und bieten eine Genauigkeit von 18 Stellen. Alle 18 Ziffern können mit dem erweiterten STR$-Format (z. B. STR$( var## ,18)) „angezeigt“ werden.

Variablen mit erweiterter Genauigkeit werden identifiziert, indem zwei Zahlensymbole nach einem Variablennamen hinzugefügt werden (d. h. var## ) oder indem die DEFEXT-Anweisung verwendet wird. Sie können Variablen mit erweiterter Genauigkeit auch mithilfe der Schlüsselwörter EXT oder EXTENDED mit der DIM-Anweisung deklarieren. Zum Beispiel:

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Gleitkomma mit erweiterter Genauigkeit (##) soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Gleitkomma mit erweiterter Genauigkeit (##) mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


EXTRACT$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › EXTRACT$

EXTRACT$

Extrahieren Sie Zeichen aus einer Zeichenfolge

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

x$ = EXTRACT$([ start ,] MainStr , [ANY] MatchStr )

Beschreibung

E XTRACT$ gibt eine Teilzeichenfolge von MainStr zurück, beginnend mit dem ersten Zeichen (oder dem durch start angegebenen Zeichen) und bis zum ersten Vorkommen von MatchStr (aber nicht einschließlich). Wenn MatchStr nicht in MainStr vorhanden ist oder einer der Zeichenfolgenparameter null ist, wird der gesamte MainStr zurückgegeben.

start ist die optionale Startposition, an der mit dem Extrahieren begonnen werden soll. Wenn start nicht angegeben ist, beginnt es an Position 1. Wenn start Null ist oder über die Länge von MainStr hinausgeht, wird eine Nullzeichenfolge zurückgegeben. Wenn start negativ ist, wird die Startposition von rechts nach links gezählt: Wenn -1, beginnt die Suche beim letzten Zeichen; wenn -2, der vorletzte und so weiter.

MainStr ist der Zeichenfolgenausdruck, aus dem extrahiert werden soll. MatchStr ist der Zeichenfolgenausdruck, bis zu dem extrahiert werden soll. Bei EXTRACT$ wird die Groß-/Kleinschreibung beachtet.

Wenn das Schlüsselwort ANY enthalten ist, gibt MatchStr eine Liste einzelner Zeichen an, nach denen einzeln gesucht werden soll. Eine Übereinstimmung mit einem dieser Zeichen führt dazu, dass der Extraktionsvorgang bis zu diesem Zeichen ausgeführt wird.

EXTRACT$ ist besonders nützlich, wenn eine Zeichenfolge analysiert wird, die Argumente für ein Programm enthält, oder wenn mit NULL terminierte oder durch Trennzeichen getrennte Zeichenfolgen manipuliert werden, die von einer in einer anderen Sprache geschriebenen Routine empfangen wurden.

Die Komplementärfunktion zu EXTRACT$ ist REMAIN$ , die den Teil der Zeichenfolge zurückgibt, den EXTRACT$ zurücklässt. Eine ähnliche Funktion wie EXTRACT$ ist PARSE$ , die durch Trennzeichen getrennte Teilzeichenfolgen aus einer Zeichenfolge extrahiert.

Siehe auch

  • CLIP$
  • INSTR
  • JOIN$
  • LINKS$
  • LTRIM$
  • MITTLERER $
  • PARSE
  • PARSE$
  • PARSECOUNT
  • BLEIBEN$
  • REMOVE$
  • BEHALTEN$
  • RICHTIG$
  • RTRIM$
  • TALLY
  • TRIM$
  • UNWRAP$
  • ÜBERPRÜFEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FALSE - Boolesches FALSE-Literal — PBXB64 Help

Startseite › General Reference › FALSE - Boolesches FALSE-Literal — PBXB64 Help
Hilfe zum PBXB64-Compiler

FALSE - Boolesches FALSE-Literal

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

IF flag = FALSE THEN

Detailverhalten

PB-Falschliteral. In PB-kompatiblen booleschen Ausdruecken ist falsch gleich Null.

Praktische Verwendung

Verwenden Sie FALSE nur in der gezeigten Kontrollfluss- oder Ausdrucksposition. Der Test sollte die komplette Umgebungsform enthalten, damit der Scanner und der Parser die Position korrekt erkennen.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Diese Keywords haben nur in ihren erkannten Sprachpositionen die beabsichtigte Bedeutung. Ausserhalb dieser Positionen sollte der Parser nicht stillschweigend eine andere Semantik annehmen.

Verifiziertes Beispiel

Abgedeckt durch examples/basic/test_variant.pb (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


#FASM - FASM-kompatiblen ASM-Block beginnen — PBXB64 Help

Startseite › General Reference › #FASM - FASM-kompatiblen ASM-Block beginnen — PBXB64 Help
Hilfe zum PBXB64-Compiler

#FASM - FASM-kompatiblen ASM-Block beginnen

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

#FASM
  nop
#ENDFASM

Detailverhalten

Wird als mehrsprachige Assembler-Direktivschreibweise erkannt. Verwenden Sie die getesteten ASM-Blockformen aus den ASM-Seiten.

Praktische Verwendung

Verwenden Sie diesen Einstieg fuer einen FASM-kompatiblen ASM-Block, wenn die Quelle die gleiche Blockstruktur wie #ASM braucht, aber die Schreibweise auf die FASM-Direktive abgestimmt sein soll. Der Inhalt wird zusammen mit dem passenden Endmarker als ein Block behandelt.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Der Einstieg ersetzt keine echte Semantik fuer den eingebetteten Sprachblock. Ohne passenden Endmarker, passende Unterstuetzung oder passende Folgeimplementierung bleibt die Quelle unvollstaendig.

Verifiziertes Beispiel

Abgedeckt durch examples/basic/test_inline_asm_struct_nested.pb (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.


FASTPROC/END FASTPROC-Anweisungen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › FASTPROC/END FASTPROC-Anweisungen

FASTPROC/END FASTPROC-Anweisungen

Definieren Sie einen FastProc-Codeabschnitt.

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

FASTPROC ProcName [([ arguments ])] [THREADSAFE] [AS LONG]
[ statements ...]
END FASTPROC [= ReturnValue ]

Beschreibung

Rückgabewert: ]

Eine schnelle Prozedur (FASTPROC) ist eine stark vereinfachte Form von SUB oder FUNCTION, die viel schneller ausgeführt wird als ihre voll ausgestatteten Gegenstücke. Es erlaubt maximal zwei numerische LONG-Argumente und kann optional ein LONG-Ergebnis zurückgeben. Für maximale Ausführungsgeschwindigkeit werden die Argumente immer als Registervariablen verarbeitet. Es wird nie ein Stapelrahmen erstellt, daher gibt es weitere Einschränkungen, die weiter unten aufgeführt sind. Der Programmierer kann dann entscheiden, wann es angemessen ist, diese Kompromisse im Austausch für maximale Effizienz zu akzeptieren.

Der gesamte ausführbare Code muss sich in einem Sub-, Function-, Method-, FastProc- oder Property-Block befinden. Sie können eine Prozedur nicht innerhalb einer anderen Prozedur definieren. Ein FASTPROC ist ein unterprogrammartiger Anweisungsblock, der mit der CALL-Anweisung aufgerufen wird. Ein FASTPROC kann auch ohne das Wort CALL aufgerufen werden, das dann impliziert wird. Wenn das CALL-Wort weggelassen wird, müssen auch die Klammern um die Argumentliste weggelassen werden.

ProcName muss eindeutig sein: Keine Variable, Funktion, Sub, Methode, FastProc, Eigenschaft oder Beschriftung dürfen denselben Namen haben.

FADENSICHER

Wenn Sie die Option THREADSAFE einschließen, erstellt PowerBASIC automatisch ein Semaphor, das jeweils nur einem Thread die Ausführung erlaubt. Andere müssen warten, bis der erste Thread die THREADSAFE-Prozedur verlässt, bevor sie beginnen dürfen.

Einschränkungen

Die meisten Einschränkungen eines FASTPROC ergeben sich aus der Tatsache, dass kein Stapelrahmen erstellt wird.

PBXB64 V14 implementiert FASTPROC auf x64 ueber denselben aufrufbaren Prozedurpfad wie SUB/FUNCTION und behaelt dabei den FASTPROC-Kontext fuer EXIT FASTPROC bei. END FASTPROC wird als Abschluss eines FASTPROC-Blocks akzeptiert.

Fokussierte V14-Validierung: tests/pb/test_fastproc_inout_out.pb prueft FASTPROC-Deklaration, implizite Aufrufsyntax und INOUT/OUT-Skalaraenderungen. tests/pb/test_exit_fastproc.pb prueft EXIT FASTPROC und END FASTPROC; tests/pb/test_exit_fastproc_reject.pb und tests/pb/test_exit_fastproc_reject_extra.pb pruefen die gezielten Diagnosen.

Siehe auch

  • ERKLÄREN
  • AUSFAHRT
  • FUNCNAME$
  • GLOBAL
  • INSTANCE
  • Ich vermisse
  • LOCAL
  • METHOD
  • PROPERTY
  • STATIC
  • SUB
  • THREAD CREATE
  • Thread-ID
  • FADENSICHER

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für FASTPROC/END FASTPROC-Anweisungen soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' FASTPROC/END FASTPROC-Anweisungen mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


FELD – PBXB64-Compiler-Hilfe

Startseite › Funktionen › FELD

FELD

Binden Sie eine Feldzeichenfolge

Typ:Anweisung |Kategorie:Datentypen

PBXB64-Status: VERFUEGBAR fuer fokussierte Random-Datei-Feldpuffer

PBXB64-Zertifizierung: [GETESTET BEGRENZT]

Syntax

FIELD # filenum , nSize AS fieldvar [, nSize AS fieldvar ...]
FIELD # filenum , FROM nStart TO nEnd AS fieldvar [, ...]
FIELD RESET fieldvar [, ...]
FIELD STRING fieldvar [, ...]

Beschreibung

PBXB64 unterstuetzt die fokussierte FIELD-Oberflaeche fuer Random-Dateien. FIELD #n legt einen eingebetteten Satzpuffer fuer Dateinummer n an und ordnet kommaseparierte String-Variablen festen Bereichen dieses Puffers zu. Ein Feld kann eine sequenzielle Breitenklausel oder einen 1-basierten inklusiven Bereich FROM nStart TO nEnd verwenden. Wird ein kuerzerer String zugewiesen, fuellt PBXB64 den Pufferbereich mit Leerzeichen auf. Ein nacktes PUT #n schreibt den aktuellen Feldpuffer in die Datei, und ein nacktes GET #n liest den aktuellen Satz fuer zugeordnete Feldvariablen in diesen Puffer zurueck.

FIELD RESET loest eine oder mehrere Feldvariablen und setzt jede geloeste Variable auf einen leeren dynamischen String. FIELD STRING loest eine oder mehrere Feldvariablen und behaelt den aktuellen Stringwert jeder Variable bei. Unbekannte FIELD STRING-Ziele werden mit einer gezielten Compile-Zeit-Diagnose abgewiesen.

Nachdem eine Variable durch FIELD RESET oder FIELD STRING geloest wurde, sind spaetere Zuweisungen an diesen String normale dynamische Stringzuweisungen und aendern den Random-Datei-Satzpuffer nicht mehr. Das ist wichtig, wenn ein Programm einen Satz speichert, die FIELD-Variablen trennt, dieselben Variablennamen als Arbeitsstrings weiterverwendet und danach einen weiteren Satz aus dem urspruenglichen Dateipuffer schreibt.

Der fokussierte Regressionstest deckt sequenzielle Felder, explizite FROM ... TO-Bereiche, Diagnosen fuer ungueltige Bereiche, Diagnosen fuer unbekannte FIELD STRING-Ziele, Aktualisierung des Puffers mit nacktem GET #n, Schreiben des Puffers mit nacktem PUT #n, Werterhalt mit FIELD STRING und Leeren mit FIELD RESET ab. Breitere PBWin-Paritaet fuer feste FIELD-Deklarationen, UDT-lastige Satzueberlagerungen und alle historischen Random-Datei-Randfaelle bleibt ein separates Ziel.

Der Satzpuffer gehoert zum Laufzeit-Dateislot, nicht zum Namen der Quellvariable. CLOSE gibt diesen Slotzustand frei, waehrend ein erneutes Oeffnen derselben Dateinummer einen frischen Zuordnungskontext anlegt. Halten Sie das FIELD-Layout im Quelltext nahe bei der passenden OPEN ... FOR RANDOM ... LEN=-Anweisung, damit Feldbreiten und Satzlaenge zusammen geprueft werden koennen. Bei binaeren Saetzen sollten sowohl die Stringwerte als auch die exakten durch PUT #n geschriebenen Bytes geprueft werden, weil Leerzeichenfuellung und eingebettete NUL-Bytes absichtliche Daten sein koennen.

Ungueltige Layouts sollen vor dem eigentlichen Datei-I/O fehlschlagen. Dazu gehoeren ein FROM-Bereich, dessen Ende vor dem Anfang liegt, ein Feld ausserhalb der aktiven Satzlaenge oder eine Detach-Anweisung, die keine FIELD-Variable benennt. Fuer die fokussierte PBXB64-Oberflaeche sind das Quellfehler und keine stillen Aenderungen an beliebigen Strings.

Wenn eine zugeordnete FIELD-Variable gelesen wird, erzeugt PBXB64 den aktuellen Bytebereich aus dem zugehoerigen Puffer als Stringwert fuer diesen Ausdruck. Wird dieselbe Variable zugewiesen, solange sie noch zugeordnet ist, schreibt die Laufzeit die linken Bytes des zugewiesenen Werts in den Bereich und fuellt den Rest mit Leerzeichen auf. So bleibt die Variable bis zu einer ausdruecklichen Detach-Operation mit dem Satzpuffer synchron.

Diese Regeln sind absichtlich byteorientiert; sie fuehren keine Textkodierungsumwandlung aus und interpretieren den Inhalt des Satzpuffers nicht als Zahlen, Datumswerte oder strukturierte Felder.

Bei Verwendung mit einer Datei:

Es wird automatisch ein Dateipuffer mit wahlfreiem Zugriff erstellt, der verwendet werden kann, wenn GET oder PUT ohne Zielvariable verwendet werden. In diesem Fall werden die Dateidaten über diesen Puffer gelesen oder geschrieben, auf den mit einer oder mehreren Feldvariablen zugegriffen wird.

Wenn ein Feld durch einen einzelnen Feldparameter (Größe) definiert wird, stellt er die Länge des Feldes in Zeichen dar, wobei die Startposition durch das vorhergehende Feld innerhalb der Anweisung impliziert wird. Wenn zwei Parameter verwendet werden, stellen sie die Start- ( nStart ) und Endpositionen ( nEnd ) in Zeichen dar, indiziert auf eins.

Wenn einer Feldzeichenfolge ein Zeichenfolgewert zugewiesen wird, der kürzer als die deklarierte Größe ist, wird sie beim Einfügen in den Dateipuffer mit Leerzeichen aufgefüllt. Es besteht keine Anforderung, LSET für die Zuweisung zu verwenden.

FIELD-Zuordnungen sind fuer die aktive geoeffnete Random-Datei und den eingebetteten Puffer dieser Dateinummer vorgesehen.

LOCAL sFirst AS FELD, sSecond AS FELD

OPEN SIE „ABC.TXT“ FOR RANDOM AS #1 LEN=20

FELD #1, 10 AS sFirst, 10 AS sSecond

sFirst = „0123456789“

sSecond = „9876543210“

Put #1 ' erstellt einen Datensatz von: 01234567899876543210

Einschränkungen

Die fokussierte PBXB64-Implementierung unterstuetzt Dateinummer-Feldpuffer mit sequenziellen Breitenklauseln, expliziten FROM nStart TO nEnd-Klauseln, nacktem PUT #n zum Pufferschreiben und nacktem GET #n zum Pufferruecklesen. Dynamische String-Puffer und die exakten PBWin-Einschraenkungen fuer FIELD-Deklarationen bleiben breitere Paritaetsarbeit.

Siehe auch

  • Feldzeichenfolgen
  • ERHALTEN
  • SETZEN
  • TYP/ENDTYP
  • Benutzerdefinierte Typen
  • Gewerkschaften
  • UNION/ENDUNION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für FELD soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' FELD mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Dateibefehle – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Dateibefehle

Dateibefehle

Die folgenden Funktionen können zum Bearbeiten von Dateien, Standard-E/A und Festplattendiensten verwendet werden:

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Ändern Sie das aktuelle (Standard-)Verzeichnis auf einem bestimmten Laufwerk.

Change the current default drive.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


FILEATTR – PBXB64-Compiler-Hilfe

Startseite › Funktionen › FILEATTR

DATEIATTR

Gibt Informationen zu einem zurück

Typ:Funktion |Kategorie:Datei-E/A

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

lResult& = FILEATTR([#] filenum& , fattr )

Beschreibung

filenum& ist das Handle einer aktuell geöffneten Datei. fattr ist eine Ganzzahl zwischen -3 und 3, die die Art der erforderlichen Informationen gemäß der folgenden Tabelle angibt:

Definition

Der Gerätetyp. Gibt 1 für eine Datei und 2 für ein Gerät zurück. COMM, TCP und UDP werden als Geräte klassifiziert.

Logische Position des ersten Bytes (Basis) einer Festplattendatei. Standardmäßig öffnet PowerBASIC Dateien mit einem standardmäßigen ersten Speicherort von 1, dieser kann jedoch über die BASE=-Klausel der OPEN-Anweisung überschrieben werden. Diese Funktion kann nützlich sein, wenn die Basis nicht bekannt ist oder wenn SEEK-Operationen durchgeführt werden.

Die minimale Datenmenge, die gleichzeitig gelesen oder geschrieben werden kann. Bei RANDOM-Dateien ist es die Datensatzlänge. Bei INPUT-Dateien ist es die Eingabepufferlänge (festgelegt mit LEN= in der OPEN-Anweisung). Für BINARY , OUTPUT und APPEND gibt es keine Pufferung, daher wird immer 1 (1 Byte) zurückgegeben.

Der offene Zustand. TRUE (ungleich Null), wenn offen, FALSE (Null), wenn geschlossen.

Der Dateimodus (der eine Kombination aus Folgendem sein kann):

Ergebnis&

Dateimodus

Output

Zufällig

Anhängen

Serielle Kommunikation (COMM)

Binär

TCP-Winsock

UDP Winsock

(Eine APPEND-Datei gibt beispielsweise 8 + 2 = 10 zurück.)

Das Dateihandle des Betriebssystems für die Datei. Dieses Handle kann mit bestimmten Windows-API-Aufrufdateien verwendet werden, um mit PowerBASIC geöffnete Dateien und mit der OPEN HANDLE-Anweisung zu bearbeiten.

Listet vorhandene Dateinummern auf. Dieser Modus listet vorhandene Dateinummern im Bereich von 1 bis 32767 auf. FILEATTR(1,3) gibt die erste gefundene Dateinummer zurück, FILEATTR(2,3) die zweite usw., bis -1 zurückgegeben wird, um anzuzeigen, dass keine weiteren Dateinummern aktiv sind. Es kann nicht garantiert werden, dass die zurückgegebenen Dateinummern in einer bestimmten Reihenfolge zurückgegeben werden und auch nicht geöffnet sind. Mit FILEATTR(#filenum,0) können Sie ermitteln, ob eine bestimmte Dateinummer geöffnet oder geschlossen ist.

Das Zahlensymbol [#] ist optional, wird aber aus Gründen der Übersichtlichkeit empfohlen.

Siehe auch

  • KOMM. OFFEN
  • EOF
  • DATEINAME$
  • GETATTR
  • LOF
  • OFFEN
  • SEEK-Funktion
  • SEEK-Anweisung
  • SETATTR
  • TCP OFFEN
  • UDP OFFEN

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


FILECOPY – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DATEIKOPIE

DATEIKOPIE

Kopieren Sie eine Datei.

Typ:Anweisung |Kategorie: Dateiverwaltung

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

FILECOPY sourcefile , destfile

Beschreibung

Kopieren Sie die Datei sourcefile in die Datei destfile. Sowohl Quelldatei als auch Zieldatei müssen Dateinamen sein, nicht nur Laufwerke oder Verzeichnisse (obwohl es in Ordnung ist, neben den Dateinamen auch Laufwerks- und Verzeichnisspezifikationen anzugeben). Platzhalter werden nicht unterstützt. Wenn Sie versuchen, eine Datei zu kopieren, die lesegeschützt ist (wodurch der Lesezugriff verhindert wird), tritt der Laufzeitfehler 70 auf („Berechtigung verweigert“).

Wenn die Zieldatei bereits vorhanden ist, wird sie überschrieben. Wenn es nicht möglich ist, die vorhandene Zieldatei zu überschreiben (z. B. weil sie als schreibgeschützt markiert ist oder von einem anderen Programm verwendet wird), ist das Ergebnis ein Laufzeitfehler 70 („Berechtigung verweigert“).

Die Attribute der Quelldatei werden von der Zieldatei geerbt, mit Ausnahme des Archivattributs, das für die Zieldatei immer auf EIN gesetzt ist. Dateiattribute können mit den Anweisungen GETATTR und SETATTR untersucht oder geändert werden.

Siehe auch

  • DATEIATTR
  • GETATTR
  • SETATTR

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


FILENAME$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › FILENAME$

DATEINAME$

Gibt den Dateisystemnamen eines zurück

Typ:Funktion |Kategorie:Datei-E/A

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

a$ = FILENAME$( filenum& )

Beschreibung

a$ erhält den Namen der geöffneten Datei, die durch die Dateinummer filenum& identifiziert wird. Diese Funktion ist nicht gültig, wenn eine Datei mit OPEN HANDLE, COMM OPEN, TCP OPEN oder UDP OPEN geöffnet wurde.

Siehe auch

  • CLOSE
  • DATEIATTR
  • FREEFILE
  • GETATTR
  • OFFEN
  • SETATTR

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


Dateien – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Dateien

Dateien

PowerBASIC bietet drei verschiedene Möglichkeiten zum Speichern und Abrufen von Informationen von der Festplatte: sequentielle, zufällige und binäre Dateieingabe und -ausgabe. Jedes hat seine Vor- und Nachteile; derjenige, der funktioniert b

Typ:Schlüsselwort |Kategorie: Dateiverwaltung

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


FILESCAN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › FILESCAN

DATEIENCAN

Scannen Sie schnell a

Typ:Anweisung |Kategorie:Datei-E/A

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

FILESCAN [#] fnum& , RECORDS TO y& [, WIDTH TO x& ]

Beschreibung

FILESCAN weist y& eine Anzahl der Zeilen/Datensätze/Zeichenfolgen zu, und wenn die WIDTH-Klausel angegeben ist, x& die Länge der längsten Zeichenfolge.

Im INPUT-Modus wird davon ausgegangen, dass es sich bei den Daten um Standardtext handelt, dessen Zeilen durch ein CR/LF-Paar ( $CRLF ) begrenzt sind. FILESCAN stoppt das Lesen der Datei, wenn es auf ein EOF-Markierungsbyte (Ende der Datei) ( CHR$ (26) oder $EOF ) stößt. Text, der nach dem letzten CR/LF, aber vor dem EOF steht, gilt als letzter Datensatz der Datei. Verwenden Sie die LINE INPUT#-Anweisung, um eine vollständige Textdatei in ein Array einzulesen.

Im BINARY-Modus wird davon ausgegangen, dass die Datei im gepackten String-Format von PowerBASIC und/oder VB mithilfe von PUT eines gesamten String-Arrays geschrieben wurde. Wenn eine Zeichenfolge kürzer als 65535 Byte ist, folgen die Zeichenfolgedaten auf ein 2 Byte langes WORD. Wenn eine Zeichenfolge gleich oder länger als 65535 Byte ist, folgt auf den 2-Byte-Wert 65535 ein Längen-DWORD-Wert und schließlich die Zeichenfolgendaten.

Verwenden Sie die GET-Anweisung, um eine vollständige Binärdatei in ein Array einzulesen.

Einschränkungen

Wenn FILESCAN auf andere Dateiformate angewendet wird, sind die Ergebnisse undefiniert.

Siehe auch

  • ERHALTEN
  • GET$
  • ERHALTEN$$
  • LINE-EINGANG#
  • SETZEN
  • PUT$
  • PUT$$

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


FINALLY - TRY-Cleanup-Block ausfuehren — PBXB64 Help

Startseite › General Reference › FINALLY - TRY-Cleanup-Block ausfuehren — PBXB64 Help
Hilfe zum PBXB64-Compiler

FINALLY - TRY-Cleanup-Block ausfuehren

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

TRY
  ' work
FINALLY
  ' cleanup
END TRY

Detailverhalten

Kontrollkeyword fuer eine Cleanup-Klausel in TRY-Bloecken.

Praktische Verwendung

Verwenden Sie FINALLY nur innerhalb eines passenden TRY/END TRY-Blocks. Die Seite beschreibt die erkannte PBXB64-Schreibweise fuer die Fehler- oder Cleanup-Klausel, die an die umgebende Kontrollstruktur gebunden ist.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Ausserhalb eines TRY-Blocks sollte diese Klausel nicht als gueltige Struktur durchgehen. Fehlende Blockpaare oder falsche Nestung muessen als Fehler sichtbar werden.

Verifiziertes Beispiel

Abgedeckt durch PB keyword compatibility (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Zeichenfolgen mit fester Länge – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Strings mit fester Länge

Zeichenfolgen mit fester Länge

Wie der Name schon sagt, haben Zeichenfolgen fester Länge eine vordefinierte Länge, und jeder Versuch, eine Zeichenfolge zuzuweisen, die länger als die definierte Länge ist, führt zu einer Kürzung. Wenn Sie einer festen Datei eine Zeichenfolge zuweisen

Typ:Schlüsselwort |Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Sie deklarieren String-Variablen fester Länge mit STRING * x (für ANSI-Zeichen) oder WSTRING * x (für WIDE-Zeichen). Zum Beispiel

DIM MyStr1 AS STRING * 10 ' belegt 10 Bytes

DIM MyStr2 AS WSTRING * 10 ' belegt 20 Bytes

Die deklarierte Länge bezieht sich auf die Anzahl der Zeichen, nicht auf die Anzahl der Bytes. Im Gegensatz zu dynamischen Zeichenfolgen wird die Länge von Zeichenfolgen fester Länge zur Kompilierungszeit und nicht zur Laufzeit bestimmt. Darüber hinaus verwenden Zeichenfolgen fester Länge im Gegensatz zu dynamischen Zeichenfolgen keine Handles. Wenn Sie einer Prozedur eine Zeichenfolge fester Länge als Parameter übergeben, übergeben Sie tatsächlich einen Zeiger auf die Zeichenfolgendaten.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Zeichenfolgen mit fester Länge soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Zeichenfolgen mit fester Länge mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Flusskontrolle – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Flusskontrolle

Flusskontrolle

Die folgenden Funktionen können zur Verwaltung der Programmausführung/des Programmablaufs verwendet werden:

Typ:Schlüsselwort |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Stellen Sie fest, ob zuvor ein Equate definiert wurde.

Definieren Sie Abschnitte des Quellcodes, die kompiliert oder ignoriert werden sollen.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FLUSH – PBXB64-Compiler-Hilfe

Startseite › Funktionen › FLUSH

FLÜSSIG

Spülen

Typ:Anweisung |Kategorie:Datei-E/A

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

FLUSH [[#] filenum& [, [#] filenum& ] ...]

Beschreibung

FLUSH stellt sicher, dass alle Daten, die Sie in Festplattendateien geschrieben haben, tatsächlich auf die Festplatte geschrieben wurden. Die CLOSE-Anweisung leert auch die Puffer, FLUSH hat jedoch den Vorteil, dass die Dateien geöffnet bleiben.

Dateinummer&

Die Dateinummer einer OPEN-Datei. Wenn filenum& angegeben ist, werden nur die Daten für diese Datei geleert. Andernfalls werden die Daten aller geöffneten Dateien geleert. Das Zahlensymbol (#) ist optional, wird aber aus Gründen der Übersichtlichkeit empfohlen.

Siehe auch

  • CLOSE
  • OFFEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FONT END - PBXB64-Compiler-Hilfe

Startseite › Funktionen › FONT END

SCHRIFTART END

Zerstören Sie eine Schriftart, wenn sie nicht mehr benötigt wird.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

FONT END fonthndl&

Beschreibung

Wenn Sie eine Schriftart, die ursprünglich mit FONT NEW erstellt wurde, nicht mehr benötigen, können Sie sie zerstören und den ursprünglich dafür zugewiesenen Speicherplatz zurückfordern.

Wenn die angegebene Schriftart noch von einem CONTROL , einem Graphic Control , einem Graphic Window oder einer XPrint-Seite verwendet wird, wird ein Fehler 5 (Illegal Function Call) generiert. Um diesen Fehler zu vermeiden, können Sie die ursprüngliche Standardschriftart mit CONTROL/GRAPHIC/XPRINT SET FONT unter Verwendung einer Handle-Nummer von Null (0) wiederherstellen.

Wenn Ihr Programm beendet wird, werden alle vorhandenen Schriftarten automatisch von PowerBASIC zerstört.

Siehe auch

  • STEUERUNG SET SCHRIFTART
  • SCHRIFTART NEU
  • GRAFIKDRUCK
  • GRAFIK-SET-SCHRIFTART
  • XPRINT
  • XPRINT SCHRIFTART EINSTELLEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SCHRIFTART NEU – PBXB64-Compiler-Hilfe

Startseite › Funktionen › SCHRIFTART NEU

SCHRIFTART NEU

Erstellen Sie eine neue Schriftart zur Verwendung mit CONTROL

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

FONT NEW fontname$ [, points! , style& , charset& , pitch& , escapement& ] TO fhndl
Modern font (Pica, Courier...)

Beschreibung

Dies ist die bevorzugte Methode zum Erstellen und Spezifizieren von Schriftarten in PowerBASIC. Mit FONT NEW können Sie im Voraus eine Gruppe von Schriftarten erstellen und mithilfe von CONTROL SET FONT, GRAPHIC SET FONT und XPRINT SET FONT problemlos zwischen ihnen wechseln.

Wenn die angeforderte Schriftart auf dem Computer nicht verfügbar ist, sucht Windows nach einer Ersatzschriftart, die den angegebenen Attributen (CharSet, Schriftfamilie usw.) ähnelt.

Sie können den Wert Null (0) für jeden der numerischen Parameter verwenden, um anzugeben, dass der Compiler den Standardwert für dieses Element verwenden soll. Wenn Parameter fehlen, ersetzt der Compiler alle verbleibenden Parameter durch den Standardwert.

Siehe auch

  • STEUERUNG SET SCHRIFTART
  • SCHRIFTART END
  • GRAFIKDRUCK
  • GRAFIK-SET-SCHRIFTART
  • XPRINT
  • XPRINT SCHRIFTART EINSTELLEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FOR EACH/NEXT-Anweisungen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › FOR EACH/NEXT-Anweisungen

FOR EACH/NEXT-Anweisungen

Definieren Sie eine Schleife von Programmanweisungen, die nacheinander jedes Mitglied von a untersuchen und darauf reagieren können

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

PBXB64-getestete Teilmenge: PBXB64 zertifiziert derzeit FOR EACH ueber H-Lib-Container der Familien Arr, Lst und Tre. Registrierte Tests decken numerische, String- und UDT-Array/List-Iteration sowie skalare LNTRE-Wertiteration und UDT-LNUTTRE OF Point-Wertiteration ab. Hsh und DTre liegen noch ausserhalb des zertifizierten Umfangs, bis ihre Cursor-/Wert-Methodentabellen vollstaendig sind.

Syntax

FOR EACH VariantVar IN CollectionObjectVar
[ statements ]
NEXT

Beschreibung

Mit der Schleife FOR EACH können Sie jedes Mitglied einer Sammlung nacheinander untersuchen, um erforderliche Vorgänge mit diesen Daten durchzuführen. Wenn die Sammlung keine Mitgliedselemente enthält, wird die Schleife übersprungen.

Wenn die Schleife beginnt, wird die erste Mitgliedsvariante in der Sammlung der VariantVar zugewiesen. Anweisungen in der Schleife können auf oder mit diesen Daten reagieren, um alle erforderlichen Funktionen auszuführen. Wenn die NEXT-Anweisung erreicht wird, wird das nächste Mitgliedselement der VariantVar zugewiesen und die Schleife wird wiederholt. Diese Wiederholung wird fortgesetzt, bis keine Mitgliedselemente mehr vorhanden sind.

VariantVar enthält eine Kopie der Variante in der Sammlung. Sie können den Wert von VariantVar ändern, diese Änderungen wirken sich jedoch nicht auf die Mitgliedsvariante in der Sammlung aus.

PBXB64 V14.4 unterstützt FOR EACH/NEXT für native H-Lib-Container der Familien Arr, Lst und Tre. Arr-Schleifen verwenden einsbasierte Indexiteration, Lst-Schleifen verwenden den Listencursor, und Tre-Schleifen laufen über den geordneten Tree-Cursor und weisen jeden gespeicherten Wert der Schleifenvariablen zu. Die getestete Tre-Oberfläche umfasst skalare Werte und LNUTTRE OF benutzerdefinierte TYPE-Werte. PBXB64 prueft zusaetzlich rotierte AVL-Tree-Cursor mit tests/pb/test_tre_cursor_rotated.pb; damit sind LR/RL-Einfuegefolgen abgedeckt, die frueher haengen konnten. Hsh- und DTre-FOR-EACH-Schleifen gehören noch nicht zur zertifizierten Oberfläche, bis ihre Cursor-/Wert-Iteration implementiert und getestet ist.

PBXB64-Beispiel

#COMPILE EXE
#DIM ALL

TYPE Point
    x AS LONG
    y AS LONG
END TYPE

FUNCTION PBMAIN() AS LONG
    LOCAL t AS LNTRE
    LOCAL n AS LONG
    LOCAL sum AS LONG
    LOCAL count AS LONG

    t.New
    t.Set 30, 300
    t.Set 10, 100
    t.Set 20, 200

    FOR EACH n IN t
        sum = sum + n
        count = count + 1
    NEXT n

    IF count <> 3 THEN FUNCTION = 1: EXIT FUNCTION
    IF sum <> 600 THEN FUNCTION = 2: EXIT FUNCTION

    t.Final
    FUNCTION = 0
END FUNCTION

Dieser Tree-FOR-EACH-Pfad wird durch tests/pb/test_for_each_tre.pb abgedeckt; derselbe Test prüft auch UDT-Werte in LNUTTRE OF Point.

Siehe auch

  • EXIT FOR
  • FOR/WEITER
  • ITERATE FOR
  • LINKLISTENKOLLEKTION
  • POWERSAMMLUNG

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FOR/NEXT-Anweisungen ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? FOR/NEXT-Anweisungen

FOR/NEXT-Anweisungen

Definieren Sie eine Schleife von Programmanweisungen, deren Ausf?hrung durch einen automatisch inkrementierenden oder dekrementierenden Z?hler gesteuert wird.

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

FOR Counter = start TO stop [STEP increment ]
[ statements ]
[EXIT FOR]
[ITERATE FOR]
NEXT [ Counter ]

Beschreibung

Counter ist eine numerische Variable, die als Schleifenz?hler dient.

start ist ein numerischer Ausdruck, der den Wert angibt, der urspr?nglich Counter zugewiesen wurde.

stop ist ein numerischer Ausdruck, der den Wert angibt, den Counter erreichen muss, damit die Schleife beendet wird.

Inkrement ist ein optionaler numerischer Ausdruck, der den Betrag definiert, um den Counter bei jeder Schleifenausf?hrung erh?ht wird. Wenn nicht angegeben, betr?gt die Inkrementierung standardm??ig 1.

Beachten Sie, dass Inkrement vom gleichen Datentyp oder im gleichen Bereich wie Counter sein muss. Zum Beispiel:

FOR x?? = 50 BIS 1 STEP -1

schl?gt fehl, da -1 nicht im Bereich einer vorzeichenlosen Word-Variablen liegt.

Wenn eine FOR-Anweisung angetroffen wird, wird start dem Counter zugewiesen und Counter wird getestet, um festzustellen, ob er gr??er als (oder bei negativem Inkrement kleiner als) stop ist. Wenn nicht, werden die Anweisungen innerhalb der FOR/NEXT-Schleife ausgef?hrt, ein Inkrement wird zu Counter hinzugef?gt und Counter wird erneut gegen stop getestet. Die Anweisungen in der Schleife werden wiederholt ausgef?hrt, bis der Test fehlschl?gt. Anschlie?end geht die Kontrolle an die Anweisung ?ber, die unmittelbar auf NEXT folgt.

Wenn Inkrement gleich dem Maximalwert einer Variablenklasse ist (255 f?r ein Byte, 32767 f?r eine Ganzzahl, 65535 f?r ein Wort usw.), generiert der Compiler einen Fehler. Wenn Schritt Null ist, kann eine Endlosschleife erstellt werden.

Achten Sie bei der Verwendung von Gleitkommawerten mit FOR/NEXT darauf, Rundungsfehler beim Mischen von Zahlen unterschiedlicher Genauigkeit zu ber?cksichtigen. Die durchgehende Verwendung von Konstanten oder Variablen desselben Typs hilft, dieses Problem zu l?sen:

FOR n# = 1,0 BIS 1,5 STEP 0,1

x$ = STR$(n#)

WEITER n#

wird 5 Mal ausgef?hrt und gibt Folgendes zur?ck:

1.10000000149012

1.20000000298023

1.30000000447035

1.40000000596046

w?hrend:

FOR n@ = 1,0@ BIS 1,5@ STEP 0,1@

x$ = STR$(n@)

WEITER n@

wird 6 Mal ausgef?hrt und gibt Folgendes zur?ck:

FOR/NEXT-Schleifen laufen am schnellsten, wenn Counter eine Variable mit langer Ganzzahl ist und Start und Inkrement Konstanten mit langer Ganzzahl sind. Der Wert von Counter steht wie jede andere Variable innerhalb der Schleife zur Verf?gung. Es ist ratsam, den Wert von Counter innerhalb der Schleife nicht explizit zu ?ndern. Wenn Sie die Schleife vorzeitig verlassen m?ssen, verwenden Sie eine EXIT FOR-Anweisung. Ber?cksichtigen Sie die Reichweite. Wenn ?Counter? beispielsweise eine Integer-Variable ist, d?rfen Sie f?r stop nicht den Maximalwert f?r eine Integer-Variable verwenden, da Counter am Ende der Schleife au?erhalb des Integer-Bereichs inkrementiert w?rde.

Der Hauptteil der Schleife wird vollst?ndig ?bersprungen, wenn der Anfangswert von Counter gr??er als stop ist (oder, bei einem negativen Inkrement, wenn Counter kleiner als stop ist).

FOR/NEXT-Schleifen k?nnen in anderen FOR/NEXT-Schleifen verschachtelt werden. Stellen Sie sicher, dass Sie eindeutige Z?hlervariablen verwenden. Beachten Sie, dass PowerBASIC den Counter im NEXT-Schl?sselwort einfach als Kommentar zul?sst, der ignoriert wird. Beispielsweise wird Folgendes kompiliert, obwohl die Z?hlervariablen ?gekreuzt? sind:

FOR n = 1 BIS 10

FOR m = 1 BIS 20

WEITER n

N?CHSTER m

Sie k?nnen die Z?hlervariable in der NEXT-Anweisung ganz weglassen. Zum Beispiel:

FOR n = 1 BIS 10

Wenn ein NEXT ohne entsprechendes FOR (oder umgekehrt) auftritt, wird ein Fehler bei der Kompilierung generiert.

Fr?here Versionen von PowerBASIC unterst?tzten eine einzelne NEXT-Anweisung, die mit mehreren verschachtelten FOR/NEXT-Schleifen verwendet wurde, z. B. NEXT c, b, a. Dies wird nicht mehr unterst?tzt und Sie m?ssen Ihren Code aktualisieren, um mehrere NEXT-Anweisungen verwenden zu k?nnen.

In bestimmten Situationen haben fr?here Versionen von PowerBASIC FOR/NEXT-Schleifen so optimiert, dass sie herunterz?hlen statt hochz?hlen, um die Ausf?hrungsgeschwindigkeit zu verbessern. Diese Optimierung k?nnte dazu f?hren, dass die Z?hlervariable einen Wert enth?lt, der nach Abschluss der Schleifenausf?hrung nicht erwartet wurde. Diese Optimierung wurde verbessert, sodass der Wert der Z?hlervariablen nach Abschluss der Schleife immer korrekt ist, auch wenn EXIT FOR verwendet wurde, um eine vorzeitige Beendigung zu erzwingen.

Obwohl sich der Compiler nicht um solche Dinge k?mmert, gilt es als gute Programmierpraxis, die Anweisungen zwischen FOR und NEXT um zwei oder drei Leerzeichen einzur?cken, um die Struktur der Schleife hervorzuheben.

F?r zus?tzliche Leistung verwenden Sie eine REGISTER-Variable f?r die Schleifenz?hlervariable.

Einschr?nkungen

Die Z?hlervariable muss eine einfache numerische Skalarvariable sein, z. B. LOCAL , STATIC , GLOBAL oder REGISTER . Dies tr?gt dazu bei, ein hohes Leistungsniveau f?r eine einfache Schleifenstruktur aufrechtzuerhalten. Variablen, f?r deren Zugriff mehrere Operationen erforderlich sind, sind ausdr?cklich nicht zul?ssig: THREADED , INSTANCE , BYREF-Parameter, POINTER-Ziele und ARRAY .

Praktische Verwendung

FOR/NEXT-Anweisungen gehoert zur Kategorie General. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' FOR/NEXT-Anweisungen mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Siehe auch

  • #OPTIMIEREN
  • #REGISTER
  • DO/LOOP
  • AUSFAHRT
  • FOR EACH/NEXT
  • ITERATE
  • WHILE/WENDE
  • REGISTRIEREN

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_for_long
FUNCTION PBMAIN() AS LONG
  LOCAL i AS LONG
  LOCAL s AS LONG
  s = 0
  FOR i = 1 TO 5
    s = s + i
  NEXT
  IF (s) <> (15) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_for_integer
FUNCTION PBMAIN() AS LONG
  LOCAL i AS INTEGER
  LOCAL s AS INTEGER
  s = 0
  FOR i = 1 TO 5
    s = s + i
  NEXT
  IF (s) <> (15) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_for_byte
FUNCTION PBMAIN() AS LONG
  LOCAL i AS BYTE
  LOCAL s AS BYTE
  s = 0
  FOR i = 1 TO 5
    s = s + i
  NEXT
  IF (s) <> (15) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_for_word
FUNCTION PBMAIN() AS LONG
  LOCAL i AS WORD
  LOCAL s AS WORD
  s = 0
  FOR i = 1 TO 5
    s = s + i
  NEXT
  IF (s) <> (15) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_for_dword
FUNCTION PBMAIN() AS LONG
  LOCAL i AS DWORD
  LOCAL s AS DWORD
  s = 0
  FOR i = 1 TO 5
    s = s + i
  NEXT
  IF (s) <> (15) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_for_quad
FUNCTION PBMAIN() AS LONG
  LOCAL i AS QUAD
  LOCAL s AS QUAD
  s = 0
  FOR i = 1 TO 5
    s = s + i
  NEXT
  IF (s) <> (15) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_for_range_0
FUNCTION PBMAIN() AS LONG
  LOCAL i AS LONG
  LOCAL s AS LONG
  s = 0
  FOR i = 1 TO 1 STEP 1
    s = s + i
  NEXT
  IF (s) <> (1) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_for_range_1
FUNCTION PBMAIN() AS LONG
  LOCAL i AS LONG
  LOCAL s AS LONG
  s = 0
  FOR i = 1 TO 5 STEP 1
    s = s + i
  NEXT
  IF (s) <> (15) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_for_range_2
FUNCTION PBMAIN() AS LONG
  LOCAL i AS LONG
  LOCAL s AS LONG
  s = 0
  FOR i = 1 TO 10 STEP 2
    s = s + i
  NEXT
  IF (s) <> (25) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_for_range_3
FUNCTION PBMAIN() AS LONG
  LOCAL i AS LONG
  LOCAL s AS LONG
  s = 0
  FOR i = 5 TO 1 STEP -1
    s = s + i
  NEXT
  IF (s) <> (15) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION


FORMAT$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › FORMAT$

FORMAT$

Zeichenfolge formatieren

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

PBXB64-getestete Teilmenge: PBXB64 zertifiziert derzeit value-first Integer-/DOUBLE-Masken, Waehrungs-/Tausender-/Nullfuell-Masken, die String-Masken !, & und Backslash-Festfelder, fuehrendes Plus, nachgestelltes Minus, negative Klammern, wissenschaftliche E+00-Masken und String-Datummasken einschliesslich yyyy-mm-dd, mm/dd/yy und mmmm d, yyyy. Die fokussierten Regressionen sind examples/basic/test_format_function_masks.pb, examples/basic/test_format_sign_masks.pb und examples/basic/test_print_using_date.pb. Numerische Datums-Serials, Zeitfelder, locale-abhaengige Formatierung und vollstaendige PBWin-Picture-Mask-Paritaet bleiben breitere Kompatibilitaetsarbeit.

Syntax

x$ = FORMAT$( num_expression [, [ digits& | fmt$ ]])

Beschreibung

FORMAT$ besteht aus folgenden Teilen:

num_expression

Der zu formatierende numerische Ausdruck, die Variable oder der Literalwert. Dieses Argument wird vor Beginn der Formatierung in die volle Genauigkeit (Extended) konvertiert.

Ziffern&

Die maximale Anzahl signifikanter Ziffern im Bereich von 1 bis 18. Wenn nicht angegeben, liefert PowerBASIC einen Standardwert von 7 für Werte mit einfacher Genauigkeit oder 16 für genauere Werte. Diese Form der Funktion ist der Funktion STR$() sehr ähnlich, außer dass sie niemals führende oder nachgestellte Leerzeichen bereitstellt. Achten Sie darauf, dass digits& groß genug ist, um den ganzen Teil einer Zahl zu enthalten, andernfalls muss zur Schätzung die wissenschaftliche Schreibweise verwendet werden. Beispielsweise gibt FORMAT$(123.456, 2) die Zeichenfolge „1.2E+2“ zurück, während FORMAT$(123.456, 5) die Zeichenfolge „123.45“ zurückgibt.

Formatierungszeichen, die bestimmen, wie der numerische Ausdruck formatiert werden soll. Dieser Ausdruck wird als Maske bezeichnet. Auf beiden Seiten des Dezimalpunkts können bis zu 18 Ziffern zur Formatierung stehen. Die Maske darf keine Literalzeichen enthalten, es sei denn, jedem Zeichen ist ein umgekehrter Schrägstrich (\) als Escape-Zeichen vorangestellt oder die Literalzeichen sind in Anführungszeichen gesetzt.

fmt$ kann eine, zwei oder drei Formatierungsmasken enthalten, getrennt durch Semikolon-Zeichen (;):

Eine Maske

Wenn fmt$ nur eine Formatmaske enthält, wird die Maske zum Formatieren aller möglichen Werte von num_expression verwendet. Zum Beispiel:

x$ = FORMAT$(z!, "000.00")

Zwei Masken

Wenn fmt$ zwei Formatmasken enthält, wird die erste Maske für positive Werte (=> 0) und die zweite Maske für negative Werte (< 0) verwendet. Zum Beispiel:

x$ = FORMAT$(-100, „+00000,00;-000“)

Drei Masken

Wenn fmt$ drei Masken enthält, wird die erste Maske für positive Werte (> 0), die zweite Maske für negative Werte (< 0) und die dritte Maske verwendet, wenn num_expression Null (0) ist. Zum Beispiel:

FOR dich! = -0,5! BIS 0,5! STEP 0,5!

x$ = FORMAT$(y!, "+.0;-.0; .0")

NÄCHSTES!

Ziffernplatzhalter in einer Maske müssen nicht zusammenhängend sein. Dadurch können Sie eine einzelne Zahl in mehrere angezeigte Teile formatieren. Zum Beispiel:

A$ = FORMAT$(123456, "00\:00\:00") ' 12:34:56

Die folgende Tabelle zeigt die Zeichen, die Sie zum Erstellen der benutzerdefinierten Formatzeichenfolgen (Masken) verwenden können, sowie die Definition jedes Formatierungszeichens:

Charakter

Definition

Leere Zeichenfolge

[Null-String] Es findet keine Formatierung statt. Die Zahl wird in die erweiterte Genauigkeit konvertiert und ähnlich wie STR$ formatiert, jedoch ohne das führende Leerzeichen, das STR$ für nichtnegative Zahlen anwendet.

A$=FORMAT$(0.2) ' .200000002980232

A$=FORMAT$(0.2!, "") ' .200000002980232

A$=FORMAT$(0.2#) ' .2

A$=FORMAT$(0.2#, "") ' .2

[Null] Ziffernplatzhalter. PowerBASIC fügt an dieser Stelle eine Ziffer oder eine 0 ein.

Wenn es in num_expression eine Ziffer an der Position gibt, an der die 0 in der Formatzeichenfolge erscheint, geben Sie diese Ziffer zurück. Andernfalls geben Sie „0“ zurück. Wenn die zu formatierende Zahl weniger Ziffern hat, als der Formatausdruck Nullen (auf beiden Seiten des Dezimalpunkts) enthält, werden führende oder nachgestellte Nullen hinzugefügt. Wenn die Zahl mehr Ziffern rechts vom Dezimalpunkt hat, als Nullen rechts vom Dezimalpunkt im Formatausdruck vorhanden sind, wird die Zahl auf so viele Dezimalstellen gerundet, wie Nullen in der Maske vorhanden sind.

Wenn die Zahl mehr Ziffern links vom Dezimalpunkt hat, als Nullen links vom Dezimalpunkt im Formatausdruck vorhanden sind, werden die zusätzlichen Ziffern ohne Kürzung angezeigt. Wenn der numerische Wert negativ ist, wird das Negationszeichen als Dezimalziffer behandelt. Daher ist bei der Anzeige negativer Werte mit diesem Platzhalterstil Vorsicht geboten. In solchen Fällen wird die Verwendung mehrerer Masken empfohlen.

' Numerisch aufgefüllt mit führenden Nullen

A$ = FORMAT$(999%, "00000000") ' 00000999

[Zahlensymbol] Ziffernplatzhalter. Wenn für diese Position eine Ziffer vorhanden ist, ersetzt PowerBASIC diesen Platzhalter durch eine Ziffer, nichts oder ein vom Benutzer angegebenes Zeichen.

Im Gegensatz zum 0-stelligen Platzhalter führt PowerBASIC entweder Folgendes aus, wenn der numerische Wert weniger Ziffern aufweist, als #-Zeichen auf beiden Seiten des Dezimalplatzhalters vorhanden sind:

a) Lassen Sie diese Zeichenposition in der endgültigen formatierten Zeichenfolge weg. oder

Ersetzen Sie ein vom Benutzer angegebenes Ersatzzeichen, sofern eines definiert wurde (weitere Informationen finden Sie unter dem Sternchen (*)). Um führende Leerzeichen anzugeben, stellen Sie der Maske „*“ (Sternchen und ein Leerzeichen) voran.

Zum Beispiel:

' Keine führenden Leerzeichen und nachgestellten Leerzeichen

A$ = FORMAT$(0.75!, "####.###") ' 0.75

' Bis zu 3 führende Leerzeichen vor der Dezimalstelle

A$ = FORMAT$(0.75!, "* ##.###") ' 0.75

' Verwenden von Sternchen zum Auffüllen von Zeichen

A$ = FORMAT$(0.75!, "*=##.###") ' ===0.75=

FORMAT$ kann auch eine Zeichenfolge zurückgeben, die größer ist als die Anzahl der Zeichen in der Maske:

A$ = FORMAT$(999999.9, "#.#") ' 999999.9

[Punkt] Dezimalplatzhalter. Bestimmt die Position des Dezimalpunkts in der resultierenden formatierten Zeichenfolge.

Wenn links vom Dezimalpunkt ein beliebiges numerisches Feld angegeben wird, ergibt sich immer mindestens eine Ziffer, auch wenn nur eine Null. Die Null gilt nicht als „führende“ Null, wenn sie die einzige Ziffer links von der Dezimalstelle ist. Das Platzieren von mehr als einem Punktzeichen in der fmt$-Zeichenfolge führt zu undefinierten Ergebnissen.

[Prozent] Prozent-Platzhalter. PowerBASIC multipliziert num_expression mit 100 und fügt am Ende ein Prozentzeichen hinzu. Zum Beispiel:

x$ = FORMAT$(1 / 5!, "0,0%") ' 20,0%

[Komma] Tausendertrennzeichen. Wird verwendet, um Tausender von Hundertern innerhalb einer Zahl zu trennen, die vier oder mehr Stellen links vom Dezimalpunkt hat. Um als Formatzeichen erkannt zu werden, muss das Komma direkt nach einem Ziffern-Platzhalterzeichen platziert werden (siehe auch Einschränkungen unten).

A$ = FORMAT$(1234567@, "#,") ' 1.234.567

A$ = FORMAT$(12345@, "#,.00") ' 12.345,00

A$ = FORMAT$(12345@, "#.00,") ' 12.345,00

A$ = FORMAT$(1212,46, "$00.000,00") ' $01.212,46

A$ = FORMAT$(1000%, """#""#,") ' #1.000

A$ = FORMAT$(1234567@, "0,") ' 1.234.567

[Sternchen] Ziffernplatzhalter und Füllzeichen. Weist PowerBASIC an, an dieser Position eine Ziffer oder ein Zeichen „x“ einzufügen. Wenn sich in num_expression an der Position, an der das * in der Formatzeichenfolge erscheint, eine Ziffer befindet, wird diese Ziffer verwendet. andernfalls wird das Zeichen „x“ verwendet (wobei „x“ für das von Ihnen gewählte Zeichen steht). Der * x-Bezeichner fungiert als zweistellige (#) Felder.

A$ = FORMAT$(9999.9@,"$**####,.00")' $**9.999,90

A$ = FORMAT$(0@,"$*=###0,.00#") ' $=====0.00=

A$ = FORMAT$(0@,"$* ####0,.00") ' $ 0,00

E- e- E+ e+

[e] Wissenschaftliches Format. PowerBASIC verwendet in der formatierten Ausgabe die wissenschaftliche Notation. Verwenden Sie E- oder e-, um ein Minuszeichen vor negative Exponenten zu setzen. Verwenden Sie E+ oder e+, um ein Minuszeichen vor negativen Exponenten und ein Pluszeichen vor nichtnegativen Exponenten zu platzieren.

Um als Formatfolge erkannt zu werden, muss das E-, e-, E+ oder e+ zwischen zwei Ziffern-Platzhalterzeichen stehen. Zum Beispiel:

A$ = FORMAT$( 99.999, "0.0E-##") ' 1.0E2

A$ = FORMAT$(-99.999, "0.0E-##") ' -1.0E2

A$ = FORMAT$( 99.999, "0.0E+##") ' 1.0E+2

A$ = FORMAT$(-99.999, "0.0E+##") ' -1.0E+2

A$ = FORMAT$(0.1!, "0.0e+##") ' 1.0e-1

[doppelte Anführungszeichen] Zeichenfolge in Anführungszeichen. PowerBASIC behandelt alle Zeichen bis zum nächsten Anführungszeichen unverändert, ohne sie als Ziffernplatzhalter oder Formatzeichen zu interpretieren. Siehe auch Backslash. Zum Beispiel:

A$ = FORMAT$(12, $DQ+"##"+$DQ+"##") ' ##12

A$ = FORMAT$(5.55, """XYZ=""#.##\#") ' XYZ=5.55#

A$ = FORMAT$(25, """x=""#") ' x=25

A$ = FORMAT$(999, """Total ""#") ' Total 999

A$ = FORMAT$(5, $DQ+"x="+$DQ+"#") ' x=5

[Backslash] Escapezeichen-Präfix. PowerBASIC behandelt das Zeichen „x“, das unmittelbar auf den Backslash (\) folgt, als Literalzeichen und nicht als Ziffernplatzhalter oder Formatierungszeichen. Viele Zeichen in einer Maske haben eine besondere Bedeutung und können nur dann als Literalzeichen verwendet werden, wenn ihnen ein Backslash vorangestellt ist.

Der Backslash selbst wird nicht kopiert. Um einen Backslash anzuzeigen, verwenden Sie zwei Backslashes (\\). Um ein wörtliches doppeltes Anführungszeichen anzuzeigen, verwenden Sie zwei doppelte Anführungszeichen.

Um die Maskenzeichenfolge für gängige numerische Formate zu vereinfachen, lässt FORMAT$ zu, dass das Dollarsymbol, die linken und rechten Klammersymbole, die Plus- und Minuszeichen und das Leerzeichen („$()+-“) aus der Maskenzeichenfolge in die formatierte Ausgabezeichenfolge übernommen werden, ohne dass ein Escape-Präfixzeichen (\) erforderlich ist.

A$ = FORMAT$(23, "(* 0\%)") ' ( 23%)

A$ = FORMAT$(99999, "#\#") ' 99999#

A$ = FORMAT$(5, "\"+$DQ+$DQ+"x="+$DQ+ _

"#\"+$DQ) ' "x=5"

A$ = FORMAT$(5, "\""""x=""#\""") ' "x=5"

A$ = FORMAT$(1000%, """#####,"") ' "#####,"

Einschränkungen

Sie können in num_expression keinen Zeichenfolgenausdruck oder keine Zeichenfolgenvariable übergeben. Platzieren Sie nicht mehr als einen Dezimalpunkt in der Maske.

FORMAT$ kann die maximal mögliche Anzahl von Ziffern zurückgeben (bis zu 4932 für erweiterte Genauigkeit); Die resultierenden Ziffern sind jedoch über die tatsächliche Genauigkeit von num_expression hinaus bedeutungslos. Folglich kann der Wert von num_expression formatierte Zeichenfolgen erzeugen, die breiter als die Länge von fmt$ sind, zum Beispiel:

A$ = FORMAT$(3e30!, "#,###") ' gibt 41 Zeichen zurück

Gegebenenfalls wird das Runden nach dem „Banker-Rundungsprinzip“ durchgeführt: Wenn die abzurundende Nachkommastelle genau fünf ist und keine nachgestellten Ziffern enthält, wird die Zahl auf die nächste gerade Zahl gerundet. Dies liefert im Durchschnitt bessere Ergebnisse und entspricht dem IEEE-Standard. Zum Beispiel:

A$ = FORMAT$(0.5##, "0") ' 0

A$ = FORMAT$(1.5##, "0") ' 2

A$ = FORMAT$(2.5##, "0") ' 2

A$ = FORMAT$(2.51##, "0") ' 3

Semikolons als Maskentrennzeichen sollten nicht für andere Zwecke in Maskenzeichenfolgen verwendet werden, es sei denn, ihnen wird ein Escape-Zeichensymbol (\) vorangestellt.

FORMAT$ erzeugt bei Verwendung mit einigen Formatierungszeichen wie dem Tausendertrennzeichen (Komma) möglicherweise keine „rechtsbündige“ formatierte Zeichenfolge. Die einfache Lösung besteht darin, eine separate Begründung mit der RSET-Anweisung oder der RSET$-Funktion anzuwenden. Zum Beispiel:

A$ = SPACE$(12)

RSET A$ = FORMAT$(1,"#,###.00") ' 1.00

RSET A$ = FORMAT$(1000, "#,.00") ' 1.000,00

RSET A$ = FORMAT$(1000000,"#,###.00")' 1.000.000,00

B$ = RSET$(FORMAT$(1e6, "#,"),10) ' " 1.000.000"

Eine weitere Erweiterung wäre die Kombination zu einer MACRO-Funktion, zum Beispiel:

MACRO mMoney1(d,l) = "$"+RSET$(FORMAT$(d,"#,"),l-1)

MACRO mMoney2(d,l) = RSET$(FORMAT$(d,"$#,"),l)

' Code hier

A$ = mMoney1(1000,10) ' "$ 1.000"

B$ = mMoney2(1000,10) ' " $1.000"

Siehe auch

  • BIN$
  • GRAFIKDRUCK
  • GUID$
  • HEX$
  • OCT$
  • REPEAT$
  • SPACE$
  • STR$
  • STRING$
  • USING$
  • VAL
  • XPRINT

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für FORMAT$ soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' FORMAT$ mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


FRAC ? Realer Bruchteil ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? FRAC ? Realer Bruchteil

FRAC ? Realer Bruchteil (V8.1)

Gibt den Bruchteil einer Gleitkommazahl oder eines Ausdrucks zur?ck. Die V8.1 Implementierung ist ein echtes SSE2 x - floor(x) Sequenz (kein Stub).

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status: VERF?GBAR ? echte Umsetzung

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

h = FRAC( float_expression )

Beschreibung

FRAC gibt die Zahl nach dem Dezimalpunkt zur?ck. Das Ergebnis hat das gleiche Vorzeichen wie die Eingabe. Zum Beispiel, FRAC(3.7) kehrt zur?ck 0.7, UndFRAC(-3.7) kehrt zur?ck -0.7.

Die Umsetzung sinkt auf subsd + roundsd toward -inf auf x64 (SSE4.1 roundpd wenn verf?gbar, andernfalls ein Vergleichs- und Subtraktions-Fallback).

Beispiel

PRINT FRAC(3.7)         '  0.7
PRINT FRAC(-3.7)        ' -0.7
PRINT FRAC(10.0)        '  0

Verifiziertes Beispiel: FRAC - Nachkommateil

Beispieldatei: examples/basic/test_frac.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/test_frac.pb -o tmp/help_math_samples/test_frac.exe and executed with exit code 0.

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN () AS LONG
    LOCAL f AS DOUBLE
    LOCAL fail AS LONG
    f = FRAC(3.75)
    IF f < 0.74 OR f > 0.76 THEN fail = 1
    f = FRAC(-3.75)
    IF f < -0.76 OR f > -0.74 THEN fail = 2
    FUNCTION = fail
END FUNCTION

Validierungsnachweis: this page now carries a direct, compile-and-run proof note so the command reference remains tied to validated behavior instead of prose alone.

Verhalten: Prueft positive und negative Nachkommawerte gegen die fokussierte Runtime-Implementierung. Focus assertion: IF ABS(FRAC(-3.7) + 0.7) > 0.000001 THEN FUNCTION = 1

Siehe auch

  • DECKE
  • FIX
  • INT
  • RUNDEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FREEFILE – PBXB64-Compiler-Hilfe

Startseite › BASIC-Frontend › Schlüsselwortreferenz › Datei-E/A › FREEFILE
Hilfe zum PBXB64-Compiler

FREEFILE

Gibt die nächste verfügbare PowerBASIC-Dateinummer zurück.

Typ: Funktion | Kategorie: Datei-E/A

PBXB64-Status: VERFÜGBAR

PBXB64-Zertifizierung: [IMPLEMENTIERT: Laufzeit-Allokation für #1..#16]

Syntax

x% = FREEFILE

Beschreibung

FREEFILE gibt die nächste verfügbare Dateinummer aus der internen PBXB64-Dateinummerntabelle zurück.

PBXB64 verwaltet derzeit Dateinummern von 1 bis 16. Jeder Aufruf reserviert den zurückgegebenen Slot, daher geben aufeinanderfolgende Aufrufe verschiedene unbenutzte Nummern zurück, auch bevor die Dateien geöffnet werden. Wird eine Datei geschlossen, wird ihre Nummer wieder frei. Ist kein Slot frei, gibt FREEFILE 0 zurück.

Einschränkungen

  • Es werden nur Dateinummern 1..16 verwaltet.
  • Variable Dateinummer-Ausdrücke werden für die getestete Oberfläche OPEN ... AS #f und CLOSE #f unterstützt.

Praktische Verwendung

FREEFILE gehoert zur Kategorie General. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' FREEFILE mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Siehe auch

  • DATEIATTR
  • DATEINAME$
  • OPEN


FUNCNAME$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › FUNCNAME$

FUNCNAME$

Gibt den Namen der aktuellen abgesenkten Funktion zurück.

Typ:Funktion |Kategorie: Procedures

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

f$ = FUNCNAME$

Beschreibung

PBXB64 implementiert einen fokussierten aktuellen Funktionsnamen. FUNCNAME$ gibt den abgesenkten Funktionsnamen zurueck, in dem es erscheint.

PBWin-Paritaet fuer ALIAS-abhaengige Namensausgabe sowie METHOD/PROPERTY-Namen bleibt offen, bis sie implementiert und getestet ist.

Der zurueckgegebene Text ist das Frontend-Funktionssymbol, das der aktuelle PBXB64-Absenkungspfad verwendet. Fuer normale Funktionen ist dies der Quell-Funktionsname, wie ihn die registrierte Testoberflaeche belegt.

Damit eignet sich FUNCNAME$ fuer einfache Trace-Zeilen, Assertions und Fehlermeldungen, die den aktiven Funktionsnamen benoetigen. Es ist noch kein vollstaendiger PBWin-Debugger-Identitaetsdienst.

Wenn ein spaeterer Abschnitt aliasbewusste Exportnamen, METHOD/PROPERTY-Bloecke oder Klassenelementnamen hinzufuegt, brauchen diese Formen eigene positive und negative Tests, bevor diese Seite breitere Paritaet behaupten darf.

Das Beispiel unten verwendet deshalb nur eine normale Funktion und prueft genau die aktuell garantierte Rueckgabe.

Siehe auch

  • #TOOLS
  • CALLSTK
  • CALLSTK$
  • CALLSTKCOUNT
  • DATEINAME$
  • FUNCTION
  • METHOD
  • PROFILE
  • PROPERTY
  • SUB
  • TRACE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FUNCTION/END FUNCTION-Anweisungen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › FUNCTION/END FUNCTION-Anweisungen

FUNCTION/END FUNCTION-Anweisungen

Definieren Sie einen Funktionsblock.

Typ:Funktion |Kategorie: Procedures

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

FUNCTION ProcName [ALIAS " AliasName "] [( arguments )] < Descriptors > AS Type
[ statements ]
[{ FuncName | FUNCTION} = ReturnValue ]
END FUNCTION
CALLBACK FUNCTION ProcName [AS LONG]...
THREAD FUNCTION ProcName (BYVAL var AS LONG) AS LONG...

Beschreibung

Rückgabewert: ] END FUNCTION CALLBACK FUNCTION ProcName [AS LONG]... THREAD FUNCTION ProcName (BYVAL var AS LONG) AS LONG...

Der gesamte ausführbare Code muss sich in einem Sub-, Function-, Method-, Property- oder FastProc-Block befinden. Funktionen dürfen nicht verschachtelt sein. Das heißt, Sie können keinen Codeblock (Sub, Funktion, Methode, Eigenschaft) innerhalb eines anderen Codeblocks definieren.

In früheren Versionen von PowerBASIC mussten Sie eine explizite DECLARE-Anweisung erstellen, wenn Sie eine SUB- oder FUNCTION-Anweisung ausführen wollten, die nicht physisch vor dem Verweis darauf stand. Diese zusätzliche Arbeit ist nicht mehr erforderlich, da PowerBASIC alle Weiterleitungsverweise auf interne Prozeduren automatisch auflöst.

DECLARE-Anweisungen für eine aus einer DLL importierte Unterfunktion/Funktion müssen weiterhin vor jedem Verweis auf die Prozedur stehen.

Funktionsname

Der Name der Funktion. Anstelle der [AS-Typ]-Klausel kann ein Typbezeichner angehängt werden (genau wie ein gewöhnlicher Variablenname), um den Datentyp des Rückgabewerts der Funktion anzugeben. FuncName muss eindeutig sein: Keine andere Variable, Funktion, Sub, Methode, Eigenschaft oder Bezeichnung kann ihn gemeinsam nutzen. Siehe auch ALIAS unten.

Zukünftige Versionen von PowerBASIC unterstützen keine Typspezifizierersymbole für den Funktionsrückgabetyp. Geben Sie daher den Rückgabedatentyp mit einer expliziten AS-Typklausel in allen DECLARE- und FUNCTION-Definitionen an, um zukünftige Kompatibilität sicherzustellen.

Zeichenfolgenliteral, das einen alternativen Namen für die Funktion angibt, bei dem die Groß-/Kleinschreibung beachtet wird. Dadurch können Sie eine Funktion unter einem anderen eindeutigen Namen exportieren. Dies kann nützlich sein, wenn Sie einen langen Namen abkürzen, einen aussagekräftigeren Namen angeben möchten oder wenn der exportierte Name Zeichen enthalten muss, die in PowerBASIC unzulässig sind. AliasName ist der tatsächliche Name der Routine, wie er in der Exporttabelle erscheint, und FuncName ist der Titel, den Sie in PowerBASIC verwenden können. Zum Beispiel:

FUNCTION ShortName ALIAS „LongFuncName“() EXPORT STATIC AS LONG

Die ALIAS-Klausel ist beim Exportieren von Prozeduren sehr wichtig. Das Weglassen der ALIAS-Klausel oder die falsche Großschreibung des Aliasnamens sind häufige Ursachen für „Missing Export“-Fehler. Weitere Informationen finden Sie im Thema DECLARE.

Deskriptoren

EXPORT

Dieser Deskriptor identifiziert eine Unter- oder Funktion, auf die zwischen Dynamic Link Libraries (DLLs) zugegriffen werden kann, und/oder die ausführbare Hauptdatei, die sie verknüpft. Wenn eine Prozedur nicht mit EXPORT markiert ist, wird sie vor diesen anderen Modulen ausgeblendet. Das EXPORT-Attribut kann zu einer an anderer Stelle definierten Unter-/Funktion hinzugefügt werden, indem EXPORT in einer DECLARE-Anweisung angegeben wird. EXPORT kann sogar zu einer Unterfunktion/Funktion in einer SLL mit einer DECLARE im Hostmodul hinzugefügt werden.

COMMON

Eine GEMEINSAME Unter-/Funktion ist eine Funktion, auf die von und zwischen verknüpften Einheitenmodulen (Host oder SLL) verwiesen werden kann. Wenn Sie eine gemeinsame Sub- oder Funktion DEKLARIEREN, die in diesem Modul nicht vorhanden ist, wird davon ausgegangen, dass sie in einem separaten verknüpften Modul (Host oder SLL) gefunden wird.

PRIVAT

Eine private Unter-/Funktionsfunktion ist eine Funktion, auf die nur innerhalb des aktuellen PowerBASIC-Programms oder der aktuellen PowerBASIC-Bibliothek zugegriffen werden kann. Auch wenn nichts angegeben ist, ist dies der Standardbetriebsmodus.

FADENSICHER

Mit der THREADSAFE-Option richtet PowerBASIC automatisch eine Semaphore ein, die es jeweils nur einem Thread ermöglicht, die Sub/Funktion auszuführen. Andere Aufrufer müssen warten, bis der erste Thread die THREADSAFE-Prozedur verlässt, bevor sie beginnen dürfen.

Dieser Deskriptor gibt an, dass alle nicht deklarierten Variablen in einer Funktion LOCAL sind. Dies ist die Standardbedingung, wenn weder LOCAL noch STATIC angegeben ist.

Lokale Variablen und Array-Variablen werden automatisch freigegeben, wenn die Prozedur beendet wird. LOKALE Skalarvariablen (außer dynamische Zeichenfolgen) werden auf dem Stapel gespeichert und sind nur innerhalb der Funktion sichtbar.

STATIC

Dieser Deskriptor gibt an, dass alle nicht deklarierten Variablen in einer Funktion STATIC sind. Statische Variablen behalten ihren Wert, solange das Programm läuft. Sie sind nur innerhalb der Funktion sichtbar.

Gibt an, dass die deklarierte Prozedur die alte BASIC/Pascal-Aufrufkonvention verwendet. Parameter werden von links nach rechts auf dem Stapel abgelegt und die aufgerufene Prozedur ist für deren Entfernung verantwortlich. BDECL sollte nur verwendet werden, wenn dies zur Anpassung an externe Module erforderlich ist.

Gibt an, dass die deklarierte Prozedur die C-Aufrufkonvention verwendet. Parameter werden von rechts nach links auf den Stapel verschoben und der aufrufende Code ist für deren Entfernung verantwortlich. CDECL sollte nur verwendet werden, wenn dies zur Anpassung an externe Module erforderlich ist.

Dies ist die Standardkonvention und sollte nach Möglichkeit verwendet werden. SDECL (und sein Synonym STDCALL) spezifiziert die „Standard Calling Convention“ für Windows. Parameter werden von rechts nach links auf den Stapel verschoben und die aufgerufene Prozedur ist für deren Entfernung verantwortlich.

RÜCKRUF

Gibt an, dass es sich um eine Rückruffunktion handelt, die nur zum Empfangen von Nachrichten vom Betriebssystem verwendet wird. Es darf niemals direkt aus Ihrem Code aufgerufen werden. Details zu der an den Rückruf gesendeten Nachricht werden mithilfe der CB-Gruppe von PowerBASIC-Funktionen abgerufen. Rückruffunktionen enthalten möglicherweise keine Parameter und geben immer ein Long-Integer-Ergebnis zurück. Zum Beispiel:

CALLBACK-FUNCTION DlgProc SO LANG

' Rückrufcode steht hier

ENDFUNKTION

Rückruffunktionen verfügen über die einzigartige Fähigkeit, bei Bedarf für bestimmte Windows-Nachrichten optional zwei unterschiedliche Werte zurückzugeben. Dadurch können sie als Funktionsergebnis den Wert Null (0) zurückgeben und gleichzeitig angeben, dass die Nachricht verarbeitet wurde. Weitere Einzelheiten finden Sie im Abschnitt „CALLBACK RETURN VALUE“ (unten) und auf der Seite „CALLBACKS“.

FADEN

Gibt an, dass es sich um eine Thread-Funktion handelt, bei der es sich um den Punkt handelt, an dem die Ausführung eines neuen Threads beginnt. Es darf niemals direkt aus Ihrem Code aufgerufen werden. Thread-Funktionen müssen als Wert genau einen langen Ganzzahl- oder Doppelwort-Parameter annehmen (BYVAL) und müssen entweder ein langes Ganzzahl- oder Doppelwort-Ergebnis zurückgeben. Zum Beispiel:

THREAD-FUNCTION MyThreadFunction(BYVAL x AS LONG) AS LONG

' Thread-Code steht hier

ENDFUNKTION

Die THREAD CREATE-Anweisung erstellt eine neue Thread-Funktion und beginnt mit deren Ausführung.

Übergabe von Parametern

arguments

Eine optionale, durch Kommas getrennte Folge formaler Parameter. Die in der Argumentliste verwendeten Parameter dienen nur zur Definition der Funktion; Sie haben keine Beziehung zu anderen Variablen im aufrufenden Code mit demselben Namen.

Normalerweise übergibt PowerBASIC Parameter entweder per Referenz (BYREF) oder per Wert (BYVAL) an eine Funktion. Wenn Sie die Parameter nicht ändern müssen (was in vielen Fällen der Fall ist), können Sie Ihre Aufrufe beschleunigen, indem Sie die Parameter mit dem Schlüsselwort BYVAL als Wert übergeben. Sie können klarstellen, dass ein Parameter als Referenz übergeben wird, indem Sie das optionale Schlüsselwort BYREF verwenden.

Der Typ des Parameters wird entweder durch Anhängen eines Typspezifizierzeichens an den Namen oder durch Verwendung einer AS-Klausel angegeben. Zum Beispiel:

FUNCTION Test&(A AS INTEGER) 'von Referenz übergebene Ganzzahl

FUNCTION Test&(A%) 'von Ref übergebene Ganzzahl

FUNCTION Test&(BYREF A%) 'von Ref übergebene Ganzzahl

FUNCTION Test&(BYVAL A%) 'vom Wert übergebene Ganzzahl

Parameterbeschränkungen

PowerBASIC-Compiler haben ein Limit von 32 Parametern pro FUNCTION. Um mehr als 32 Parameter an eine FUNCTION zu übergeben, erstellen Sie einen benutzerdefinierten Typ (UDT) und übergeben Sie den UDT stattdessen als Referenz (BYREF).

Zeichenfolgen fester Länge, NULL-terminierte Zeichenfolgen und benutzerdefinierte Typen/Unions können auch als BYVAL- oder OPTIONAL-Parameter übergeben werden. Vermeiden Sie die Übergabe großer Elemente BYVAL, da dies furchtbar ineffizient ist und es eine maximale Größenbeschränkung von 64 KB für eine bestimmte Parameterliste gibt.

PowerBASIC-Funktionen können kein Array oder eine Variant-Variable als Funktionsrückgabewert zurückgeben. Übergeben Sie diese Variablentypen stattdessen als BYREF-Parameter. Zum Beispiel:

lResult& = ProcessData(TheArray&(), iSize%)

[Anweisungn]

FUNCTION ProcessData(lArr() AS LONG, iSize%) AS LONG

REDIM lArr(iSize%) SO LONG

lArr(iSize%) = 1&

FUNCTION = -1&

ENDFUNKTION

Zeigerparameter

Wenn eine Funktionsdefinition entweder einen BYREF-Parameter oder einen Zeigervariablenparameter angibt, kann der aufrufende Code stattdessen frei ein BYVAL DWORD oder einen Zeiger übergeben. Zeigervariablenparameter müssen immer als BYVAL-Parameter deklariert werden.

' Ganzzahliger Zeiger (als Wert übergeben)

FUNKTIONSTEST (BYVAL A AS INTEGER PTR) SO LONG

@A = 56

ENDFUNKTION

Weitere Informationen zur Parameterübergabe BYVAL/BYREF/BYCOPY finden Sie im Thema CALL-Anweisung.

Optionale Parameter

PowerBASIC unterstützt zwei Syntaxformate für optionale Parameter: die klassische Syntax für optionale Parameter mit Klammern „[..]“ und die neue Syntax mit dem Schlüsselwort OPTIONAL (oder OPT). Wir besprechen jeden einzelnen der Reihe nach.

Mit OPTIONAL/OPT

FUNCTION-Anweisungen können einen oder mehrere Parameter als optional angeben, indem dem Parameter entweder das Schlüsselwort OPTIONAL oder OPT vorangestellt wird. Optionale Parameter sind nur mit den Aufrufkonventionen CDECL oder SDECL zulässig, nicht mit BDECL.

Wenn ein Parameter als optional deklariert wird, sind alle nachfolgenden Parameter in der Deklaration ebenfalls optional, unabhängig davon, ob sie eine explizite OPTIONAL- oder OPT-Direktive angeben oder nicht. Die folgenden zwei Zeilen sind äquivalent, wobei sowohl der zweite als auch der dritte Parameter optional sind:

FUNCTION sABC(a&, OPTIONAL BYVAL b&, OPTIONAL BYVAL c&) AS LONG

FUNCTION sABC(a&, OPT BYVAL b&, BYVAL c&) AS LONG

VARIANT-Variablen eignen sich besonders gut zur Verwendung als optionaler Parameter. Wenn der aufrufende Code einen optionalen VARIANT-Parameter (BYVAL oder BYREF) weglässt, ersetzen PowerBASIC (und die meisten anderen Compiler) eine Variante vom Typ VT_ERROR, die einen Fehlerwert von %DISP_E_PARAMNOTFOUND (&H80020004) enthält. In diesem Fall können Sie diesen Wert direkt prüfen oder mit der Funktion ISMISSING() ermitteln, ob der Parameter physisch übergeben wurde oder nicht.

Wenn optionale Parameter (außer VARIANT) im aufrufenden Code weggelassen werden, wird der Stapelbereich, der normalerweise für diese Parameter reserviert ist, mit Nullen gefüllt. Damit können Sie testen, ob ein optionaler Parameter übergeben wurde oder nicht:

Wenn der Parameter als BYVAL-Parameter definiert ist, hat er den Wert Null. Für TYPE- oder UNION-Variablen, die BYVAL übergeben werden, übergibt der Compiler eine Zeichenfolge binärer Nullen der Länge SIZEOF (Type_or_union_var).

Wenn der Parameter als BYREF-Parameter definiert ist, ist VARPTR (Varname) gleich Null; Wenn dies zutrifft, führt jeder Versuch, Var_name in Ihrem Code zu verwenden, zu Fehler Nr. 9 (Nullzeiger). Wenn dieser Fehler nicht mithilfe der Fehlererkennung erkannt wird, kann dies zu einer allgemeinen Schutzverletzung oder einer Speicherbeschädigung führen. Sie sollten zunächst die Funktion ISMISSING() verwenden, um festzustellen, ob der Zugriff auf den Parameter sicher ist.

Da die aufgerufene Funktion, SUB, FASTPROC, METHOD oder PROPERTY zum Zeitpunkt des Aufrufs nicht weiß, wie viele Parameter übergeben werden, sollten Sie die Anzahl der Parameter als einen der erforderlichen Parameter in der Liste übergeben.

AS-Typ

Funktionsblöcke sind sehr ähnlich wie Subs aufgebaut (siehe SUB/END SUB-Anweisung). Allerdings unterscheiden sich Funktionen von Subs darin, dass sie immer ein Ergebnis zurückgeben und daher in Zuweisungen und Ausdrücken verwendet werden können. Daher gibt es zwei Möglichkeiten, den Rückgabetyp einer Funktion anzugeben:

Sie können den Datentyp angeben, den eine Funktion an den aufrufenden Code zurückgibt. Wenn Sie keinen Typ angeben, geht PowerBASIC davon aus, dass die Funktion den durch eine DEFtype-Anweisung angegebenen Datentyp zurückgibt. Wenn jedoch kein DEFtype- oder AS-Typ angegeben wurde, wird ein Fehler bei der Kompilierung generiert.

Daher gibt es zwei Möglichkeiten, den Rückgabetyp einer Funktion anzugeben:

Beispielsweise sind die folgenden Anweisungn äquivalent:

FUNCTION eineFunktion?()

FUNCTION aFunction() ALS BYTE

Während die meisten FUNCTION-Aufrufkonventionen in der Branche ziemlich genau definiert sind, gibt es einige Ausnahmen. Bei Funktionen, die einen Quad-Integer-Wert zurückgeben, geben einige Programmiersprachen (einschließlich PowerBASIC) den Quad-Wert in der FPU zurück, während andere ihn in EDX:EAX zurückgeben. PowerBASIC erkennt automatisch die von importierten Funktionen verwendete Methode und passt sich entsprechend an. Diese Funktion gibt es jedoch nicht bei anderen Compilern. Daher empfehlen wir Ihnen, QUAD FUNCTIONS nicht zu EXPORTIEREN, es sei denn, auf sie wird nur von PowerBASIC-Programmen zugegriffen. Eine einfache äquivalente Funktionalität wäre die Rückgabe des quad-ganzzahligen Werts an den Aufrufer in einem BYREF QUAD-Parameter.

Zuweisen eines Rückgabewerts

Sie können den Rückgabewert der Funktion angeben, indem Sie den Wert explizit festlegen, indem Sie entweder dem Schlüsselwort FUNCTION einen Wert zuweisen oder dem Funktionsnamen einen Wert zuweisen. Beispielsweise sind die beiden Zeilen im folgenden Funktionsblock äquivalent:

FUNCTION AddData() AS LONG

[Anweisungn]

AddData = 123& ' Dem Funktionsnamen einen Wert zuweisen

FUNCTION = 123& ' Der Funktion einen Wert zuweisen

ENDFUNKTION

Standardrückgabewert

Wenn der Code innerhalb der Funktion nicht explizit einen Rückgabewert festlegt, ist der Standardrückgabewert Null, wenn die Funktion einen numerischen Datentyp zurückgibt, oder eine leere Zeichenfolge, wenn die Funktion eine Zeichenfolge zurückgibt. Zum Beispiel:

FUNCTION AddData() AS LONG

[Anweisungn]

IF-Bedingung THEN

EXIT FUNCTION ' Keine Zuweisung, gibt 0 zurück&

FUNCTION = -1& ' Ein expliziter Rückgabewert

END IF

ENDFUNKTION

PowerBASIC-Funktionen können kein Array als Funktionsrückgabewert zurückgeben. Übergeben Sie stattdessen das Array als Parameter. Zum Beispiel:

lResult& = CheckTheData(InTheArray&())

[Anweisungn]

FUNCTION CheckTheData(lArr() AS LONG) AS LONG

[Anweisungn]

ENDFUNKTION

CALLBACK-Rückgabewert

Rückruffunktionen geben immer ein Long-Integer-Ergebnis zurück. Der Hauptzweck dieses Rückgabewerts besteht darin, der PowerBASIC DDT-Engine und dem Windows-Betriebssystem mitzuteilen, ob Ihre Rückruffunktion diese bestimmte Nachricht verarbeitet hat. Wenn Sie den Wert TRUE (ein beliebiger Wert ungleich Null) zurückgeben, bestätigen Sie, dass die Nachricht verarbeitet wurde und keine weitere Bearbeitung erforderlich ist. Wenn Sie den Wert FALSE (Null) zurückgeben, verwaltet die PowerBASIC DDT-Engine die Nachricht für Sie und verwendet dabei die Standardnachrichtenverfahren in Windows. Wenn Sie in der Funktion keinen Rückgabewert angeben, wählt PowerBASIC für Sie den Wert FALSE (Null).

Der Begriff „eine Nachricht verarbeiten“ kann viele Bedeutungen haben. Wenn es sich um eine einfache Benachrichtigung über eine Änderung des Fokus oder Stils handelt, die keine Auswirkung auf Ihr Programm hat, können Sie entscheiden, sie als verarbeitet zu betrachten, aber nichts unternehmen. In anderen Fällen kann Ihre Reaktion recht komplex und kompliziert sein. Als Programmierer ist es Ihre Entscheidung. Unabhängig von Ihrer Reaktion sollten Sie jedoch davon ausgehen, dass eine Nachricht „verarbeitet“ wird (einen wahren Wert zurückgibt), wenn keine weitere Verarbeitung der Nachricht (durch DDT oder Windows) erforderlich ist.

In einigen Fällen, insbesondere beim Umgang mit allgemeinen Steuerelementen und benutzerdefinierten Steuerelementen, müssen Sie möglicherweise einen zweiten Ergebniswert über einen speziellen Windows-Datenbereich namens DWL_MSGRESULT zurückgeben. Wenn Sie eine Rückruffunktion abschließen, kopiert PowerBASIC automatisch alle Rückgabewerte ungleich Null in DWL_MSGRESULT, sofern Sie dies noch nicht getan haben. Daher ist es im Allgemeinen sicher, diese Anforderung in Ihrem Code zu ignorieren.

In den meisten Fällen geben Sie beim Verarbeiten einer Nachricht einen generischen Wert für TRUE zurück, z. B.: FUNCTION = 1. Einige Nachrichten erfordern jedoch, dass Sie einen speziellen Wert für TRUE zurückgeben, z. B. ein grafisches Pinselhandle. Solange der Wert ungleich Null ist, können Sie ihn auf normale Weise zurückgeben (mit FUNCTION = n ), da jeder Wert ungleich Null automatisch impliziert, dass die Nachricht verarbeitet wurde.

Allerdings gibt es einige einzigartige Nachrichten, die möglicherweise eine besondere Behandlung erfordern. Zum Glück sind sie selten, aber einige verstoßen einfach gegen alle oben aufgeführten Regeln. Beispielsweise könnten Sie eine Antwort finden, die ein Null-Ergebnis erfordert, selbst wenn Sie die Nachricht verarbeitet haben. Möglicherweise finden Sie einen anderen, der einen anderen Rückgabewert als DWL_MSGRESULT erfordert. Für diese ganz speziellen Fälle können Sie einfach zwei Rückgabewerte angeben:

FUNCTION = 1, BrushHandle&

In dieser Form gibt der erste numerische Ausdruck den Wert an, der von der Callback-Funktion zurückgegeben werden soll. Der zweite numerische Ausdruck gibt den Wert an, der DWL_MSGRESULT zugewiesen werden soll. Wenn Sie diese doppelte Parameterzuweisung verwenden, sind die Ergebnisse absolut. PowerBASIC geht unabhängig von den angegebenen Werten davon aus, dass Sie die Nachricht verarbeitet haben. PowerBASIC macht keine weiteren Annahmen zu diesen Werten. Eine doppelte Parameterfunktionszuweisung ist nur in einer Callback-Funktion zulässig.

Frühere Versionen von PowerBASIC boten keine Doppelparameterform der Funktionsrückgabe. Dies verursachte einige Schwierigkeiten bei einigen Windows-Meldungen, die einen speziellen Rückgabewert von Null erforderten. Wenn Sie mit der Einzelparameterform einen Wert von Null (0) zurückgeben, bedeutet dies, dass die Nachricht vom Callback überhaupt nicht verarbeitet wurde. Dieses Problem wird durch die Doppelparameterform vollständig umgangen.

Variablen innerhalb von Funktionen

LOKALE Variablen werden innerhalb des Prozedurstapelrahmens erstellt. Wenn eine LOCAL-Variable den verfügbaren Stapelspeicherplatz überschreitet, muss möglicherweise stattdessen eine STATIC- oder GLOBAL-Variable verwendet werden. Beispielsweise kann das Erstellen einer LOCAL-Zeichenfolge mit Nul-Terminierung oder einer LOCAL-Zeichenfolge mit fester Länge, die sehr groß ist (z. B. fast 1 MB), eine allgemeine Schutzverletzung (GPF) auslösen, da sie möglicherweise den Stapelrahmen überläuft.

Siehe auch

  • ERKLÄREN
  • AUSFAHRT
  • FASTPROC
  • FUNCNAME$
  • GLOBAL
  • INSTANCE
  • Ich vermisse
  • LOCAL
  • METHOD
  • PROPERTY
  • STATIC
  • SUB
  • THREAD CREATE
  • Thread-ID

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GET$$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GET$$

ERHALTEN$$

Liest

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GET$$ [#] Filenum& , Count& , StrgVar

Beschreibung

GET$$ liest Count& WIDE-Zeichen aus der Dateinummer filenum& und weist sie StrgVar zu. GET$$ und PUT$$ bieten eine Low-Level-Alternative zu sequentiellen und wahlfreien Dateiverarbeitungstechniken, die es Ihnen ermöglichen, Dateien zeichenweise zu verarbeiten.

PBXB64 verifiziert dies mit examples/basic/test_get_put_wide_string.pb. Der Test liest WIDE-Daten, die sowohl aus einer WSTRING-Quelle als auch aus einer ANSI-STRING-Quelle geschrieben wurden, und prueft den zurueckgegebenen WSTRING mit ASCW-Codeunit-Assertions.

Die Datei filenum& muss im Binärmodus geöffnet worden sein. Das Lesen von Zeichen beginnt an der aktuellen Dateizeigerposition, die mit der SEEK-Anweisung festgelegt werden kann. Wenn die Datei zum ersten Mal geöffnet wird, befindet sich der Zeiger am Anfang der Datei (standardmäßig Position 1, sofern nicht BASE=0 in der OPEN-Anweisung angegeben wurde). Nach GET$$ wird die Position des Dateizeigers automatisch auf die Position vorgerückt, die unmittelbar auf die gelesenen Daten folgt.

Siehe auch

  • EOF
  • ERHALTEN
  • GET$
  • INPUT#
  • LINE-EINGANG#
  • LOF
  • OFFEN
  • PRINT#
  • SETZEN
  • PUT$
  • PUT$$
  • SUCHEN
  • WRITE#

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Datei-Themen sollen den benoetigten Oeffnungsmodus, die Arbeit auf Datensaetzen oder Bytes, die erforderliche Uebereinstimmung von Handles und Bereichen mit vorherigen Operationen sowie Cleanup- oder Entsperrschritte nennen. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für ERHALTEN$$ soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' ERHALTEN$$ mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


GET$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GET$

GET$

Lesen Sie eine

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GET$ [#] filenum& , Count& , StrgVar

Beschreibung

GET$ liest Count& Zeichen aus der Dateinummer filenum& und weist sie StrgVar zu. GET$ und PUT$ bieten eine Low-Level-Alternative zu sequentiellen und wahlfreien Dateiverarbeitungstechniken, die es Ihnen ermöglichen, Dateien byteweise zu verarbeiten.

Die Datei filenum& muss im Binärmodus geöffnet worden sein. Das Lesen von Zeichen beginnt an der aktuellen Dateizeigerposition, die mit der SEEK-Anweisung festgelegt werden kann. Wenn die Datei zum ersten Mal geöffnet wird, befindet sich der Zeiger am Anfang der Datei (standardmäßig Position 1, sofern nicht BASE=0 in der OPEN-Anweisung angegeben wurde). Nach GET$ wird die Position des Dateizeigers automatisch auf die Position vorgerückt, die unmittelbar auf die gelesenen Daten folgt.

Siehe auch

  • EOF
  • ERHALTEN
  • ERHALTEN$$
  • INPUT#
  • LINE-EINGANG#
  • LOF
  • OFFEN
  • PRINT#
  • SETZEN
  • PUT$
  • PUT$$
  • SUCHEN
  • WRITE#

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GETATTR – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GETATTR

GETATTR

Gibt die Dateisystemattribute einer Festplattendatei oder eines Verzeichnisses zurück.

Typ:Funktion |Kategorie: Dateiverwaltung

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

x& = GETATTR( filespec$ )

Beschreibung

filespec$ gibt einen Dateinamen oder ein Verzeichnis an (optional einschließlich eines Laufwerksbuchstabens und eines Verzeichnispfads). Der in x& zurückgegebene Attributcode ist ein Standard-Betriebssystemattributcode oder eine Kombination mehrerer Codes, die miteinander verknüpft sind:

Attribut

Beschreibung

Gleichsetzen

Normal*

%NORMAL

Schreibgeschützt

%READONLY

Versteckt

%VERSTECKT

System

%SYSTEM

Datenträgerbezeichnung

%VLABEL

Verzeichnis

%UNTERVERZEICHNIS

Archiviert

%ARCHIV

Normal*

(Synonym von %NORMAL)

* Einige Betriebssysteme geben für normale Dateien möglicherweise entweder 0 oder 128 zurück.

Wenn GETATTR ein Attribut von 0 (oder 128) zurückgibt, ist filespec$ eine reguläre Datei: nicht schreibgeschützt, nicht versteckt, nicht systemisch und nicht archiviert.

Auf einigen Dateisystemen werden möglicherweise zusätzliche Dateiattribute unterstützt. Eine vollständige Liste finden Sie in den %FILE_ATTRIBUTE-Gleichungen in Ihrer WinNT.inc-Datei.

Wenn Sie ein einzelnes Attribut testen möchten, verwenden Sie den bitweisen AND-Operator, um alle anderen möglicherweise festgelegten Attribute zu entfernen. Siehe das Beispiel unten.

GETATTR kann auch verwendet werden, um die Existenz einer Datei oder eines Verzeichnisses zu überprüfen, wobei die Tatsache ausgenutzt wird, dass ERR gesetzt wird, wenn die Datei/das Verzeichnis nicht existiert. Siehe das Beispiel unten.

PBXB64 senkt GETATTR(path$) auf den eingebetteten Helfer bestof_getattr ab. Dieser ruft die Win32-API GetFileAttributesA auf und gibt die Attribut-Bitmaske zurueck.

Einschränkungen

Wenn filespec$ nicht gefunden werden kann, tritt ein Laufzeitfehler 53 („Datei nicht gefunden“) auf. Sie können die Attribute des Stammverzeichnisses (d. h. „C:\“) nicht abrufen. Windows verhindert diesen speziellen Vorgang und löst einen Fehler 53 aus.

Das aktuell fokussierte PBXB64-Verhalten gibt fuer einen fehlenden Pfad 0 zurueck, statt einen PBWin-kompatiblen Laufzeitfehler 53 auszugeben. Verzeichnis-, Wurzelpfad-, Unicode- und kombinierte Attributfaelle bleiben breitere Datei-/Pfad-Arbeit.

Siehe auch

  • DIR$
  • DATEIATTR
  • ISFILE
  • PATHSCAN$
  • SETATTR

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GLOBALALLOC / GLOBALFREE-Familie - PBXB64 Help

Startseite › General Reference › GLOBALALLOC / GLOBALFREE-Familie
Hilfe zum PBXB64-Compiler

GLOBALALLOC / GLOBALFREE-Familie

Funktionsformen fuer Windows-Global-Memory-Operationen: Allokieren, Groesse, Sperren, Entsperren, Flags und Freigeben.

Kind: PowerBASIC feature | Category: PowerBASIC / Tested Feature

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

h& = GLOBALALLOC(bytes)
p& = GLOBALLOCK(h&)
GLOBALUNLOCK h&
GLOBALFREE h&

Beschreibung

Diese Seite beschreibt das PBXB64-Verhalten, das durch die aktuelle Validierungsmatrix abgedeckt ist. Verwenden Sie die hier gezeigte Syntax fuer Regressionstests; weitergehende PowerBASIC-Formen gelten als separate Kompatibilitaetsarbeit, sofern keine andere Seite sie dokumentiert.

Unterstuetzter Umfang

Die dokumentierte Teilmenge ist absichtlich genau: Beispiele verwenden bevorzugt skalare LONG-Werte, Array-Beispiele benutzen normale PB-logische Indizes, und laufzeitabhaengige Operationen sollen immer den Rueckgabestatus pruefen. Wenn ein Feature sowohl Anweisungs- als auch Funktionsschreibweise besitzt, beschreibt diese Seite den funktionsorientierten Seiteneintrag und verweist auf die breitere BASIC-Referenz.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL h AS LONG
    h = GLOBALALLOC(64)
    IF h = 0 THEN FUNCTION = 1 ELSE GLOBALFREE h
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_globalalloc_functions.pb` sowie GLOBAL/GLOBALMEM-Anweisungstests.

Fuer Release-Arbeiten sollte jede Syntaxform einen kleinen ausfuehrbaren Test besitzen. Ein guter Test initialisiert alle Eingaben, fuehrt den dokumentierten Befehl oder die Funktion aus, prueft das exakte Ergebnis und liefert bei Fehler einen von Null verschiedenen Exit-Code. Dadurch bleiben Hilfeaussagen an reproduzierbares Verhalten eines isolierten PBXB64-Compilers gebunden.

Grenzen

Nicht gezeigte PowerBASIC-Varianten duerfen aus dieser Seite nicht als unterstuetzt abgeleitet werden. Formen, die hier nicht stehen, benoetigen eigene Implementierung, Diagnostik, Tests und Hilfetext, bevor sie als abgeschlossen beschrieben werden.

Siehe auch

  • BASIC Language Reference
  • Examples

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GLOBALFLAGS - PBXB64 Help

Startseite › General Reference › GLOBALFLAGS

GLOBALFLAGS

Liefert Statusflags fuer ein Global-Memory-Handle.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

flags& = GLOBALFLAGS(hMem&)

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. Diese Seiten kapseln den Windows-Global-Memory-Handle-Lebenszyklus: Handle erzeugen oder oeffnen, nur bei Bedarf sperren, nach der Nutzung entsperren, Flags oder Groesse bei Bedarf pruefen und das Handle erst freigeben, wenn keine Sperren mehr bestehen. Das Handle ist der Besitzer des Blocks; der zurueckgegebene Zeiger ist nur eine temporaere Sicht.

Verwendung im Programm

Diese Seiten kapseln den Windows-Global-Memory-Handle-Lebenszyklus: Handle erzeugen oder oeffnen, nur bei Bedarf sperren, nach der Nutzung entsperren, Flags oder Groesse bei Bedarf pruefen und das Handle erst freigeben, wenn keine Sperren mehr bestehen. Das Handle ist der Besitzer des Blocks; der zurueckgegebene Zeiger ist nur eine temporaere Sicht.

Fehlerfaelle

Ein gesperrter Block gibt eine Adresse frei, aber kein Besitzobjekt. Behandeln Sie den Rueckgabewert nach dem Entsperren oder Freigeben nicht weiter als gueltig, und pruefen Sie Fehlerwerte vor dem Dereferenzieren. Der Sperrzaehler gehoert zum Vertrag; gehen Sie nicht von einem verdeckten Unlock aus.

Speicherfluss

Verwenden Sie die GLOBAL-Familie in der Reihenfolge erzeugen/oeffnen, nur bei Bedarf fuer einen Rohzeiger sperren, Groesse oder Flags bei Bedarf pruefen und dann in umgekehrter Reihenfolge entsperren und freigeben. Das Beispiel sollte einen vollstaendigen Lebenszyklus zeigen und nicht nur einen isolierten Einzelaufruf.

Fehlerhinweise

Ein gesperrter Block gibt eine Adresse frei, aber kein Besitzobjekt. Verwenden Sie den Zeiger nach dem Entsperren oder Freigeben nicht weiter und pruefen Sie den Rueckgabewert vor dem Dereferenzieren.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    flags& = GLOBALFLAGS(h&)
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. Ein gesperrter Block gibt eine Adresse frei, aber kein Besitzobjekt. Behandeln Sie den Rueckgabewert nach dem Entsperren oder Freigeben nicht weiter als gueltig, und pruefen Sie Fehlerwerte vor dem Dereferenzieren. Der Sperrzaehler gehoert zum Vertrag; gehen Sie nicht von einem verdeckten Unlock aus.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GLOBALFREE - PBXB64 Help

Startseite › General Reference › GLOBALFREE

GLOBALFREE

Gibt ein mit GLOBALALLOC erzeugtes Global-Memory-Handle frei.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

ok& = GLOBALFREE(hMem&)

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. Diese Seiten kapseln den Windows-Global-Memory-Handle-Lebenszyklus: Handle erzeugen oder oeffnen, nur bei Bedarf sperren, nach der Nutzung entsperren, Flags oder Groesse bei Bedarf pruefen und das Handle erst freigeben, wenn keine Sperren mehr bestehen. Das Handle ist der Besitzer des Blocks; der zurueckgegebene Zeiger ist nur eine temporaere Sicht.

Verwendung im Programm

Diese Seiten kapseln den Windows-Global-Memory-Handle-Lebenszyklus: Handle erzeugen oder oeffnen, nur bei Bedarf sperren, nach der Nutzung entsperren, Flags oder Groesse bei Bedarf pruefen und das Handle erst freigeben, wenn keine Sperren mehr bestehen. Das Handle ist der Besitzer des Blocks; der zurueckgegebene Zeiger ist nur eine temporaere Sicht.

Fehlerfaelle

Ein gesperrter Block gibt eine Adresse frei, aber kein Besitzobjekt. Behandeln Sie den Rueckgabewert nach dem Entsperren oder Freigeben nicht weiter als gueltig, und pruefen Sie Fehlerwerte vor dem Dereferenzieren. Der Sperrzaehler gehoert zum Vertrag; gehen Sie nicht von einem verdeckten Unlock aus.

Speicherfluss

Verwenden Sie die GLOBAL-Familie in der Reihenfolge erzeugen/oeffnen, nur bei Bedarf fuer einen Rohzeiger sperren, Groesse oder Flags bei Bedarf pruefen und dann in umgekehrter Reihenfolge entsperren und freigeben. Das Beispiel sollte einen vollstaendigen Lebenszyklus zeigen und nicht nur einen isolierten Einzelaufruf.

Fehlerhinweise

Ein gesperrter Block gibt eine Adresse frei, aber kein Besitzobjekt. Verwenden Sie den Zeiger nach dem Entsperren oder Freigeben nicht weiter und pruefen Sie den Rueckgabewert vor dem Dereferenzieren.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ok& = GLOBALFREE(h&)
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. Ein gesperrter Block gibt eine Adresse frei, aber kein Besitzobjekt. Behandeln Sie den Rueckgabewert nach dem Entsperren oder Freigeben nicht weiter als gueltig, und pruefen Sie Fehlerwerte vor dem Dereferenzieren. Der Sperrzaehler gehoert zum Vertrag; gehen Sie nicht von einem verdeckten Unlock aus.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GLOBALLOCK - PBXB64 Help

Startseite › General Reference › GLOBALLOCK

GLOBALLOCK

Sperrt einen Global-Memory-Block und liefert einen Adresszeiger.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

ptr& = GLOBALLOCK(hMem&)

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. Diese Seiten kapseln den Windows-Global-Memory-Handle-Lebenszyklus: Handle erzeugen oder oeffnen, nur bei Bedarf sperren, nach der Nutzung entsperren, Flags oder Groesse bei Bedarf pruefen und das Handle erst freigeben, wenn keine Sperren mehr bestehen. Das Handle ist der Besitzer des Blocks; der zurueckgegebene Zeiger ist nur eine temporaere Sicht.

Verwendung im Programm

Diese Seiten kapseln den Windows-Global-Memory-Handle-Lebenszyklus: Handle erzeugen oder oeffnen, nur bei Bedarf sperren, nach der Nutzung entsperren, Flags oder Groesse bei Bedarf pruefen und das Handle erst freigeben, wenn keine Sperren mehr bestehen. Das Handle ist der Besitzer des Blocks; der zurueckgegebene Zeiger ist nur eine temporaere Sicht.

Fehlerfaelle

Ein gesperrter Block gibt eine Adresse frei, aber kein Besitzobjekt. Behandeln Sie den Rueckgabewert nach dem Entsperren oder Freigeben nicht weiter als gueltig, und pruefen Sie Fehlerwerte vor dem Dereferenzieren. Der Sperrzaehler gehoert zum Vertrag; gehen Sie nicht von einem verdeckten Unlock aus.

Speicherfluss

Verwenden Sie die GLOBAL-Familie in der Reihenfolge erzeugen/oeffnen, nur bei Bedarf fuer einen Rohzeiger sperren, Groesse oder Flags bei Bedarf pruefen und dann in umgekehrter Reihenfolge entsperren und freigeben. Das Beispiel sollte einen vollstaendigen Lebenszyklus zeigen und nicht nur einen isolierten Einzelaufruf.

Fehlerhinweise

Ein gesperrter Block gibt eine Adresse frei, aber kein Besitzobjekt. Verwenden Sie den Zeiger nach dem Entsperren oder Freigeben nicht weiter und pruefen Sie den Rueckgabewert vor dem Dereferenzieren.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ptr& = GLOBALLOCK(h&)
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. Ein gesperrter Block gibt eine Adresse frei, aber kein Besitzobjekt. Behandeln Sie den Rueckgabewert nach dem Entsperren oder Freigeben nicht weiter als gueltig, und pruefen Sie Fehlerwerte vor dem Dereferenzieren. Der Sperrzaehler gehoert zum Vertrag; gehen Sie nicht von einem verdeckten Unlock aus.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GLOBALMEM ALLOC – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GLOBALMEM ALLOC

GLOBALMEM ALLOC

Weisen Sie einen Block des globalen Speichers zu oder geben Sie ihn frei

Typ:Anweisung |Kategorie: Memory & Pointers

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GLOBALMEM ALLOC count TO vHndl
GLOBALMEM FREE mHndl TO vHndl
GLOBALMEM LOCK mHndl TO vPtr
GLOBALMEM SIZE mHndl TO vSize
GLOBALMEM UNLOCK mHndl TO vLocked
GLOBALMEM HANDLE mHndl TO vHandle
GLOBALMEM FLAGS mHndl TO vFlags

Beschreibung

GLOBALMEM reserviert einen Block des globalen Systemspeichers der angeforderten Größe. Dieser wird immer als „beweglicher“ Speicher zugewiesen, sodass er mit allen Funktionen von Windows verwendet werden kann. Es liegt in der Verantwortung des Programmierers, den zugewiesenen Speicherblock freizugeben, wenn er nicht mehr benötigt wird.

Es gibt sieben allgemeine Formen der GLOBALMEM-Anweisung:

GLOBALMEM ALLOC

Es wird ein verschiebbarer Speicherblock mit der durch count angegebenen Größe in Bytes zugewiesen. Diesem Speicherobjekt wird ein eindeutiges Handle zugewiesen (zur späteren Identifizierung). Dieses Handle wird der durch vHndl angegebenen LONG- oder DWORD-Variablen zugewiesen. Wenn die angeforderte Zuweisung aus irgendeinem Grund fehlschlägt, wird vHndl stattdessen der Wert Null (0) zugewiesen.

GLOBALMEM KOSTENLOS

Ein Speicherblock wird freigegeben und zur Wiederverwendung freigegeben. Der mHndl-Parameter ist eine Variable oder ein Ausdruck, der als Handle ausgewertet wird, das von GLOBALMEM ALLOC zurückgegeben wurde, als der Speicherblock erstellt wurde. Wenn die Freigabeoperation erfolgreich war, wird die Ergebnisvariable vHndl auf Null (0) gesetzt, um anzuzeigen, dass das ursprüngliche Handle nicht mehr gültig ist. Wenn der Vorgang aus irgendeinem Grund fehlschlägt, wird der Wert des mHndl-Parameters vHndl zugewiesen. Es kann sinnvoll sein, für den Parameter und das Ergebnis dieselbe Variable zu verwenden, da diese dann automatisch auf Null gelöscht wird, wenn der Speicherblock freigegeben wird.

GLOBALMEM-SCHLOSS

Der bewegliche Speicherblock, auf den mHndl verweist, ist an einem bestimmten Speicherort gesperrt. Der durch vPtr angegebenen Variablen wird ein Zeiger auf diesen Ort zugewiesen. Sie können den Speicherblock nur lesen oder schreiben, während er gesperrt ist, und Sie verwenden den aktuellen Zeiger auf seinen Speicherort.

GLOBALME GRÖSSE

Die Größe des von mHndl referenzierten Speicherblocks wird abgerufen und der durch vSize angegebenen LONG- oder DWORD-Variablen zugewiesen. Der mHndl-Parameter ist das ursprünglich von GLOBALMEM ALLOC zurückgegebene Handle.

GLOBALMEM ENTSPERREN

Der bewegliche Speicherblock, auf den mHndl verweist, wird entsperrt und der vorherige Speicherzeiger wird ungültig. Bleibt der Speicherblock gesperrt (vielleicht weil er mehr als einmal gesperrt war), wird der Ergebnisvariablen vLocked der Wert TRUE (ungleich Null) zugewiesen. Wenn der Speicherblock nun entsperrt ist oder der Parameter mHndl ungültig war, wird vLocked stattdessen der Wert FALSE (0) zugewiesen.

GLOBALMEM HANDLE

Der Handle-Wert von mHndl wird an vHandle zurueckgegeben. In PBXB64 entspricht dies der aktuellen Handle-Darstellung der eingebetteten Laufzeit.

GLOBALMEM FLAGS

Status-Flags fuer das Speicherobjekt werden an vFlags zurueckgegeben. PBXB64 liefert fuer den unterstuetzten eingebetteten Global-Memory-Block derzeit null.

Siehe auch

  • ERINNERUNG

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GLOBALSIZE - PBXB64 Help

Startseite › General Reference › GLOBALSIZE

GLOBALSIZE

Liefert die Groesse eines Global-Memory-Blocks.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

size& = GLOBALSIZE(hMem&)

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. Diese Seiten kapseln den Windows-Global-Memory-Handle-Lebenszyklus: Handle erzeugen oder oeffnen, nur bei Bedarf sperren, nach der Nutzung entsperren, Flags oder Groesse bei Bedarf pruefen und das Handle erst freigeben, wenn keine Sperren mehr bestehen. Das Handle ist der Besitzer des Blocks; der zurueckgegebene Zeiger ist nur eine temporaere Sicht.

Verwendung im Programm

Diese Seiten kapseln den Windows-Global-Memory-Handle-Lebenszyklus: Handle erzeugen oder oeffnen, nur bei Bedarf sperren, nach der Nutzung entsperren, Flags oder Groesse bei Bedarf pruefen und das Handle erst freigeben, wenn keine Sperren mehr bestehen. Das Handle ist der Besitzer des Blocks; der zurueckgegebene Zeiger ist nur eine temporaere Sicht.

Fehlerfaelle

Ein gesperrter Block gibt eine Adresse frei, aber kein Besitzobjekt. Behandeln Sie den Rueckgabewert nach dem Entsperren oder Freigeben nicht weiter als gueltig, und pruefen Sie Fehlerwerte vor dem Dereferenzieren. Der Sperrzaehler gehoert zum Vertrag; gehen Sie nicht von einem verdeckten Unlock aus.

Speicherfluss

Verwenden Sie die GLOBAL-Familie in der Reihenfolge erzeugen/oeffnen, nur bei Bedarf fuer einen Rohzeiger sperren, Groesse oder Flags bei Bedarf pruefen und dann in umgekehrter Reihenfolge entsperren und freigeben. Das Beispiel sollte einen vollstaendigen Lebenszyklus zeigen und nicht nur einen isolierten Einzelaufruf.

Fehlerhinweise

Ein gesperrter Block gibt eine Adresse frei, aber kein Besitzobjekt. Verwenden Sie den Zeiger nach dem Entsperren oder Freigeben nicht weiter und pruefen Sie den Rueckgabewert vor dem Dereferenzieren.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    size& = GLOBALSIZE(h&)
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. Ein gesperrter Block gibt eine Adresse frei, aber kein Besitzobjekt. Behandeln Sie den Rueckgabewert nach dem Entsperren oder Freigeben nicht weiter als gueltig, und pruefen Sie Fehlerwerte vor dem Dereferenzieren. Der Sperrzaehler gehoert zum Vertrag; gehen Sie nicht von einem verdeckten Unlock aus.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GLOBALUNLOCK - PBXB64 Help

Startseite › General Reference › GLOBALUNLOCK

GLOBALUNLOCK

Entsperrt einen zuvor gesperrten Global-Memory-Block.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

ok& = GLOBALUNLOCK(hMem&)

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. Diese Seiten kapseln den Windows-Global-Memory-Handle-Lebenszyklus: Handle erzeugen oder oeffnen, nur bei Bedarf sperren, nach der Nutzung entsperren, Flags oder Groesse bei Bedarf pruefen und das Handle erst freigeben, wenn keine Sperren mehr bestehen. Das Handle ist der Besitzer des Blocks; der zurueckgegebene Zeiger ist nur eine temporaere Sicht.

Verwendung im Programm

Diese Seiten kapseln den Windows-Global-Memory-Handle-Lebenszyklus: Handle erzeugen oder oeffnen, nur bei Bedarf sperren, nach der Nutzung entsperren, Flags oder Groesse bei Bedarf pruefen und das Handle erst freigeben, wenn keine Sperren mehr bestehen. Das Handle ist der Besitzer des Blocks; der zurueckgegebene Zeiger ist nur eine temporaere Sicht.

Fehlerfaelle

Ein gesperrter Block gibt eine Adresse frei, aber kein Besitzobjekt. Behandeln Sie den Rueckgabewert nach dem Entsperren oder Freigeben nicht weiter als gueltig, und pruefen Sie Fehlerwerte vor dem Dereferenzieren. Der Sperrzaehler gehoert zum Vertrag; gehen Sie nicht von einem verdeckten Unlock aus.

Speicherfluss

Verwenden Sie die GLOBAL-Familie in der Reihenfolge erzeugen/oeffnen, nur bei Bedarf fuer einen Rohzeiger sperren, Groesse oder Flags bei Bedarf pruefen und dann in umgekehrter Reihenfolge entsperren und freigeben. Das Beispiel sollte einen vollstaendigen Lebenszyklus zeigen und nicht nur einen isolierten Einzelaufruf.

Fehlerhinweise

Ein gesperrter Block gibt eine Adresse frei, aber kein Besitzobjekt. Verwenden Sie den Zeiger nach dem Entsperren oder Freigeben nicht weiter und pruefen Sie den Rueckgabewert vor dem Dereferenzieren.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ok& = GLOBALUNLOCK(h&)
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. Ein gesperrter Block gibt eine Adresse frei, aber kein Besitzobjekt. Behandeln Sie den Rueckgabewert nach dem Entsperren oder Freigeben nicht weiter als gueltig, und pruefen Sie Fehlerwerte vor dem Dereferenzieren. Der Sperrzaehler gehoert zum Vertrag; gehen Sie nicht von einem verdeckten Unlock aus.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GOTO – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GOTO

GOTO

Übertragen Sie die Programmausführung auf die durch a gekennzeichnete Anweisung

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GOTO { label | linenumber }
GOTO DWORD dwpointer

Beschreibung

GOTO bewirkt, dass der Programmfluss bedingungslos zu dem durch label oder linenumber identifizierten Code springt. Die Bezeichnung oder Zeilennummer muss lokal für die Sub , Function , Method oder Property sein, in der sich die GOTO-Anweisung befindet. GOTO unterscheidet sich von GOSUB und anderen ähnlichen Steueranweisungen darin, dass das Programm nach der Ausführung eines GOTO keine Erinnerung daran behält, wo es sich vor der Ausführung des Sprungs befand.

Beschriftungen und Zeilennummern sind privat. Sie können eine Beschriftung nicht außerhalb der aktuellen Prozedur GOTO aufrufen.

GOTO DWORD bewirkt, dass die Ausführung bedingungslos zur in dwpointer gespeicherten Adresse springt. dwpointer muss ein Doppelwort, eine lange Ganzzahl oder eine Zeigervariable sein, die die Adresse einer Beschriftung enthält, die lokal für die Prozedur ist, in der sich die GOTO DWORD-Anweisung befindet.

Siehe auch

  • CALL
  • CALL DWORD
  • DO/LOOP
  • AUSFAHRT
  • FOR/WEITER
  • FUNCTION
  • GOSUB
  • IF-Block
  • METHOD
  • PROPERTY
  • ZURÜCK
  • SELECT
  • SUB
  • WHILE/WENDE

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


Grafische Befehle – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Grafikbefehle

Grafische Befehle

Zur Darstellung von Grafiken können verwendet werden:

Typ:Schlüsselwort |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Fügen Sie einem Dialogfeld ein (nicht größenveränderndes) Bildsteuerelement hinzu.

Fügen Sie einem Dialogfeld ein Steuerelement für gestreckte Bilder hinzu.

Siehe auch

  • GRAPHIC ATTACH
  • DIALOG SHOW MODAL
  • CONTROL GET TEXT

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Dialog, Grafikfenster oder Druckkontext erzeugen.
    ' Konkrete Befehle aus den verlinkten Seiten anwenden.
    ' Ergebnisse pruefen und Ressourcen freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.

Beschreibung

Grafische Befehle ist eine Uebersichtsseite fuer verwandte GUI- und Grafikbefehle. Sie fasst die Familie zusammen und verweist auf die konkreten Befehlsseiten, auf denen die getestete Syntax und das Laufzeitverhalten dokumentiert sind.

Syntax

' Uebersicht nur.
' Verwenden Sie die verlinkten Mitgliedsseiten fuer die exakten Befehlsformen.

Uebersicht und Einstieg

Grafische Befehle ist eine Uebersichtsseite fuer verwandte GUI- und Grafikbefehle. Verwenden Sie diese Seite als Orientierung, waehrend die konkrete Syntax und die getesteten Details auf den einzelnen Befehlsseiten dokumentiert sind.

Typischer Aufbau

Ein vollstaendiges GUI- oder Grafikprogramm erzeugt zuerst Dialog, Grafikfenster oder Druckkontext, fuegt danach Controls oder Zeichenoperationen hinzu, fragt Zustand ab und gibt Ressourcen am Ende geordnet frei. Diese Reihenfolge macht Fehler bei Handles, IDs und Koordinatensystemen leichter nachvollziehbar.

Verlinkte Befehlsgruppen

  • DIALOG NEW und verwandte DIALOG-Befehle fuer Fenster und Dialogzustand.
  • CONTROL ADD und verwandte CONTROL-Befehle fuer Steuerelemente.
  • GRAPHIC WINDOW und verwandte GRAPHIC-Befehle fuer Zeichenausgabe.
  • XPRINT ATTACH und verwandte XPRINT-Befehle fuer Druckausgabe.

Siehe auch

  • GRAPHIC ATTACH
  • DIALOG SHOW MODAL
  • CONTROL GET TEXT

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Dialog, Grafikfenster oder Druckkontext erzeugen.
    ' Konkrete Befehle aus den verlinkten Seiten anwenden.
    ' Ergebnisse pruefen und Ressourcen freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC ARC – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFISCHER ARC

GRAFISCHER BOGEN

Zeichnen Sie einen Bogen im ausgewählten Bereich

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC ARC ( x1! , y1! ) - ( x2! , y2! ), arcStart! , arcEnd! [, rgbColor& ]

Beschreibung

Ein Bogen ist ein Abschnitt eines Kreises oder einer Ellipse. Um einen bestimmten Bogen anzugeben, definieren Sie zunächst den vollständigen Kreis oder die Ellipse, zu der er gehört, und geben dann die Punkte auf der Ellipse an, an denen der Bogen beginnt und endet.

Der Vollkreis oder die Ellipse wird durch sein umschließendes Rechteck definiert, das als das kleinste Rechteck definiert ist, das um den Kreis oder die Ellipse herum gezeichnet werden kann. Wenn der Kreis beispielsweise an der Position (400.400) zentriert ist und einen Radius von 100 Pixeln hat, ist die obere linke Ecke ( x1! , y1! ) des umschließenden Rechtecks ​​(300.300) und die untere rechte Ecke ( x2! , y2! ) ist (500.500). Der Startpunkt und der Endpunkt des Bogens werden durch ihren Winkel angegeben, der im Bogenmaß angegeben werden muss. Ein vollständiger Kreis oder eine vollständige Ellipse hat ein Bogenmaß von 2*pi. Auf einem 12-Stunden-Zifferblatt beziehen sich die Werte 0 und 2*pi beide auf die Position 3 Uhr, während sich der Wert 1*pi auf die Position 9 Uhr bezieht. Andere Positionen werden durch einen Bogenmaßwert relativ zu diesen angegeben. In PowerBASIC werden Bögen immer gegen den Uhrzeigersinn vom Startpunkt zum Endpunkt gezeichnet.

Vor allen grafischen Operationen muss zunächst das Grafikziel mit GRAPHIC ATTACH ausgewählt werden. Die Koordinaten werden in denselben Begriffen (Pixel oder Dialogeinheiten) wie der übergeordnete Dialog angegeben (oder Weltkoordinaten, wenn diese mit GRAPHIC SCALE ausgewählt wurden). Die Linienbreite kann mit GRAPHIC WIDTH eingestellt werden. Wenn die Linienbreite auf 1 eingestellt ist (Standardeinstellung), kann der Linienstil mit GRAPHIC STYLE festgelegt werden. Aufgrund der Art eines Bogens verwendet GRAPHIC ARC weder GRAPHIC POS (letzter referenzierter Punkt) noch aktualisiert es es.

x1! , y1!

Die obere linke Ecke des umschließenden Rechtecks des Vollkreises oder der Ellipse.

x2! , y2!

Die untere rechte Ecke des Begrenzungsrechtecks des Vollkreises oder der Ellipse.

ArcStart!

Der Anfangswinkel des Bogens im Bogenmaß von 0 bis 2*pi.

ArcEnd!

Der Endwinkel des Bogens im Bogenmaß von 0 bis 2*pi im Bogenmaß. Beachten Sie, dass Bögen von arcStart aus immer gegen den Uhrzeigersinn gezeichnet werden! zu arcEnd! . Im Vergleich zu einem 12-Stunden-Zifferblatt liegt 0 oder 2*pi im Bogenmaß bei 3 Uhr und 1*pi im Bogenmaß bei 9 Uhr.

rgbColor&

Optionale RGB-Farbe für den Bogen. Wenn es weggelassen wird (oder -1), wird die aktuelle Vordergrundfarbe für das Grafikfenster verwendet.

Siehe auch

  • Built In RGB Color Equates
  • GRAFISCHE ANHÄNGE
  • GRAFISCHE FARBE
  • GRAFISCHE ELLIPSE
  • GRAFISCHER TORTEN
  • GRAFIKSATZ-ÜBERLAPPUNG
  • GRAFISCHER STIL
  • GRAFISCHE BREITE

PBXB64-Umsetzungshinweise

GRAFISCHER BOGEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHER BOGEN ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHER BOGEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFISCHER ANHANG – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFISCHER ANHANG

GRAFISCHE ANHÄNGE

Wählen Sie das Grafikziel aus (

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC ATTACH hWin , id [, REDRAW]

Beschreibung

Diese Anweisung wählt ein grafisches Ziel. Alle weiteren Grafikoperationen werden an dieses Ziel geleitet, bis eine weitere GRAPHIC ATTACH- oder GRAPHIC DETACH-Anweisung ausgeführt wird oder das Grafikziel gelöscht wird. Alle grafischen Anzeigen von PowerBASIC sind dauerhaft – sie werden automatisch neu gezeichnet, auch wenn sie minimiert oder vorübergehend von einem anderen Fenster verdeckt werden.

Standardmäßig werden alle Grafikoperationen sofort nach der Ausführung einer Grafikanweisung angezeigt. In vielen Fällen ist dies eine gute Wahl, da die Anzeige immer auf dem neuesten Stand ist. Da jedoch die Komplexität grafischer Vorgänge zunimmt, bietet dieser kontinuierliche Aktualisierungsprozess nicht die beste Leistung. In der Regel ist es besser, die unten beschriebene REDRAW-Option zu verwenden, da sie im Allgemeinen zu einer erheblichen Verbesserung der Gesamtleistung führt.

An ein bestimmtes Grafikziel kann jeweils nur ein Thread angehängt sein. Der Versuch, mehr als eine anzuhängen, führt zum Fehler „Illegal Function Call Error 5“.

Handle des GRAPHIC WINDOW , DIALOG oder BITMAP, das mit GRAPHIC-Anweisungen verwendet werden soll.

Die Steuerelement-ID, wenn das Ziel ein GRAPHIC CONTROL ist, oder Null, wenn das Ziel ein GRAPHIC WINDOW oder eine GRAPHIC BITMAP ist.

NEU ZEICHNEN

Diese Option kann die Ausführungsgeschwindigkeit von Grafikanweisungen erheblich verbessern, da wiederholte Aktualisierungen der Anzeige entfallen. Wenn diese Option enthalten ist, werden alle Zeichnungsanweisungen gepuffert, bis eine GRAPHIC REDRAW-Anweisung ausgeführt wird oder das Betriebssystem beschließt, das Zielfenster zu aktualisieren. Ohne REDRAW werden alle grafischen Anweisungen (Linie, Box, Druck usw.) sofort ausgeführt. In den meisten Fällen ist es jedoch besser, die Anzeige zu verschieben, bis eine Reihe von Anweisungen ausgeführt wurden.

Die Option REDRAW verzögert zwar die Aktualisierung der Anzeige, garantiert jedoch nicht, dass keine Zwischenaktualisierungen durchgeführt werden. Es kann vorkommen, dass das Betriebssystem oder andere Faktoren eingreifen. Wenn die Aktualisierung bis zum Abschluss unterdrückt werden muss, sollten Sie Ihre Grafik unsichtbar mit einer GRAFIK-BITMAP erstellen und sie dann mit GRAFIKKOPIE anzeigen.

Beispiele

' Draw a blue gradient fill.
' Each line is displayed as it's drawn.
GRAPHIC ATTACH hDlg, %IDC_GRAPHIC1
FOR y& = 0 TO 255
GRAPHIC LINE (0, y&) - (255, y&), RGB(0, 0, y&)
NEXT
' Draw a buffered, blue gradient fill.
' Nothing is displayed before GRAPHIC REDRAW,
' this enhancing performance dramatically.
GRAPHIC ATTACH hDlg, %IDC_GRAPHIC2, REDRAW
GRAPHIC REDRAW

Siehe auch

  • STEUERUNG GRAFIK HINZUFÜGEN
  • GRAFISCHES BITMAP-LADEN
  • GRAFISCHE BITMAP NEU
  • GRAFISCHES ABNEHMEN
  • GRAFISCHES FENSTER

PBXB64-Umsetzungshinweise

GRAFISCHE ANHÄNGE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHE ANHÄNGE ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHE ANHÄNGE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFISCHES BITMAP-END – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFISCHES BITMAP-END

GRAFISCHES BITMAP-END

Schließen Sie die ausgewählte Grafik-Bitmap.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC BITMAP END

Beschreibung

Sie müssen jede Speicherbitmap (die mit GRAPHIC BITMAP LOAD oder GRAPHIC BITMAP NEW erstellt wurde) schließen, wenn Sie sie nicht mehr für grafische Operationen verwenden möchten. Um eine Bitmap zu schließen, wählen Sie sie mit der GRAPHIC ATTACH-Anweisung aus und führen Sie dann GRAPHIC BITMAP END aus.

Siehe auch

  • GRAFISCHE ANHÄNGE
  • GRAFISCHES BITMAP-LADEN
  • GRAFISCHE BITMAP NEU

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

PBXB64-Umsetzungshinweise

GRAFISCHES BITMAP-END gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHES BITMAP-END ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHES BITMAP-END mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFISCHES BITMAP-LADEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFISCHES BITMAP-LADEN

GRAFISCHES BITMAP-LADEN

Erstellen Sie eine Speicherbitmap und laden Sie ein Bild hinein.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC BITMAP LOAD BmpName$ , nWidth& , nHeight& [, stretch& ] TO hBmp???

Beschreibung

GRAPHIC BITMAP LOAD erstellt eine neue Speicherbitmap und lädt ein Bitmapbild aus einer Ressource oder einer Festplattendatei. Dieses Bitmap funktioniert genau wie ein GRAFIKFENSTER, außer dass es nicht sichtbar ist. Der Parameter BmpName$ gibt den Namen des zu ladenden Bildes an. Wenn BmpName$ einen Punkt enthält, wird davon ausgegangen, dass es sich um den Namen einer Festplattendatei handelt. Andernfalls wird versucht, die Datei von einer Ressource zu laden. Wenn sie nicht gefunden wird, wird davon ausgegangen, dass es sich um eine Festplattendatei handelt.

Die Parameter nWidth& und nHeight& geben die Breite und Höhe der Bitmap in Pixel an. Wenn einer der Größenparameter Null (0) ist, wird die Bitmap in ihrer natürlichen Größe geladen. Wenn einer der Größenparameter von der natürlichen Größe abweicht, wird die Bitmap auf die gewünschte Größe gestreckt oder komprimiert.

Wenn die Bitmap-Erstellung erfolgreich ist, wird das Bitmap-Handle der Variablen hbmp??? zugewiesen. . Wenn nicht erfolgreich, hbmp??? wird auf Null gesetzt. Wenn Sie diese Speicherbitmap nicht mehr verwenden möchten, müssen Sie sie mit GRAPHIC BITMAP END löschen.

Wenn der Parameter stretch& enthalten ist, handelt es sich um einen der Werte in der folgenden Tabelle. Wenn nicht enthalten oder der Wert Null (0) ist, bleibt der Streckungsmodus unverändert. Eine geeignete Auswahl des Streckungsmodus kann die Qualität von Bitmaps, deren Größe geändert wird, erheblich verbessern. Die Streckmodus-Equates sind in PowerBASIC vordefiniert.

Die 4 Dehnungsmodi sind:

%BLACKONWHITE

Dies ist der standardmäßige Streckungsmodus von Windows und eignet sich am besten für monochrome Bitmaps oder solche mit Farbblöcken. Führt ein boolesches ODER von eliminierten und vorhandenen Pixeln durch. Schwarze Pixel bleiben auf Kosten weißer Pixel erhalten.

%WHITEONBLACK

Führt ein boolesches ODER von eliminierten und vorhandenen Pixeln durch. Es behält weiße Pixel auf Kosten schwarzer Pixel bei.

%COLORONCOLOR

Löscht gelöschte Pixelzeilen, ohne zu versuchen, ihre Informationen beizubehalten.

%HALBTON

Dies bietet höchste Qualität für komplexe Farbbitmaps. Die durchschnittliche Farbe des Zielpixelblocks bleibt ungefähr die gleiche wie die des Quellpixelblocks.

Der folgende Code ruft die natürliche Größe eines Bildes in einer Bitmap-Datei in Pixel ab:

nFile& = FREEFILE

OPEN Sie „myimage.bmp“ FOR BINARY AS nFile&

GET #nFile&, 19, nWidth&

GET #nFile&, 23, nHeight&

SCHLIEßEN nDatei&

Siehe auch

  • GRAFISCHES BITMAP-END
  • GRAFISCHE BITMAP NEU
  • GRAFIK GET STRETCHMODE
  • GRAFISCHE BILDLISTE
  • GRAFISCHES Rendering
  • GRAFIK SET STRETCHMODE
  • GRAFISCHER STRETCH

PBXB64-Umsetzungshinweise

GRAFISCHES BITMAP-LADEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHES BITMAP-LADEN ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHES BITMAP-LADEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFISCHE BITMAP NEU – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFISCHE BITMAP NEU

GRAFISCHE BITMAP NEU

Erstellen Sie eine neue Speicherbitmap.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC BITMAP NEW nWidth& , nHeight& TO hBmp???

Beschreibung

GRAPHIC BITMAP NEW erstellt eine neue Speicherbitmap, die wie ein GRAFIKFENSTER manipuliert und gezeichnet werden kann, nur dass sie nicht sichtbar ist. Die Parameter nWidth& und nHeight& geben die Breite und Höhe der Bitmap in Pixel an. Wenn die Bitmap-Erstellung erfolgreich ist, wird das Bitmap-Handle der Variablen hBmp??? zugewiesen. . Wenn nicht erfolgreich, hBmp??? wird auf Null gesetzt. Wenn Sie diese Speicherbitmap nicht mehr verwenden möchten, müssen Sie sie mit GRAPHIC BITMAP END löschen.

Siehe auch

  • GRAFISCHE ANHÄNGE
  • GRAFISCHES BITMAP-END
  • GRAFISCHES BITMAP-LADEN
  • GRAFISCHE BILDLISTE

PBXB64-Umsetzungshinweise

GRAFISCHE BITMAP NEU gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHE BITMAP NEU ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHE BITMAP NEU mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIKFELD - PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIKBOX

GRAFIKBOX

Zeichnen Sie im ausgewählten Bereich ein Feld mit quadratischen oder abgerundeten Ecken

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC BOX ( x1! , y1! ) - ( x2! , y2! ) [, [ corner& ] [ , [ rgbColor& ] [ ,
[ fillcolor& ] [ , [ fillstyle& ]]]]]

Beschreibung

Die Koordinaten werden in Seiteneinheiten angegeben. Die Linienbreite kann mit GRAPHIC WIDTH eingestellt werden. Wenn die Linienbreite auf 1 eingestellt ist (Standardeinstellung), kann der Linienstil mit GRAPHIC STYLE festgelegt werden. Aufgrund der Art einer Box verwendet GRAPHIC BOX weder den letzten referenzierten Punkt (POS) noch aktualisiert er ihn. Windows-Grafikkonventionen betrachten die unteren und rechten Koordinaten einer BOX als exklusiv. Die Pixel am unteren und rechten Rand werden nicht gezeichnet, es sei denn, der Überlappungsmodus ist aktiviert. Weitere Informationen finden Sie unter GRAFIKSATZ-ÜBERLAPPUNG.

x1! , y1!

Die obere linke Ecke der Box.

x2! , y2!

Die untere rechte Ecke der Box.

Ecke&

Der Prozentsatz der Rundheit der Ecken im Bereich von 0 bis 100. Ein Wert von Null erzeugt quadratische Ecken, während 100 einen Kreis/ein Oval erzeugt. Für ein angenehmes, rundes Erscheinungsbild ist ein Wert von 20 am gebräuchlichsten. Wenn Corner& weggelassen wird, ist der Standardwert 0, wodurch ein Rechteck mit quadratischen Ecken erstellt wird.

rgbColor&

Optionale RGB-Farbe des Boxrandes. Wenn es weggelassen wird (oder -1), wird als Kantenfarbe standardmäßig die aktuelle Vordergrundfarbe für das ausgewählte Grafikziel verwendet.

Füllfarbe&

Optionale RGB-Farbe des Boxinneren. Wenn fillcolor& weggelassen wird (oder -2), wird das Innere der Box nicht ausgefüllt, sodass der Hintergrund durchscheinen kann. Wenn fillcolor& -1 ist, wird der Innenraum mit der gleichen Farbe wie der Rand bemalt. Andernfalls gibt fillcolor& die zu verwendende RGB-Farbe an.

Füllstil&

Optionaler Füllstil (Muster), der verwendet werden soll. Wenn fillstyle& weggelassen wird, ist der Standardfüllstil „solid“ (0). Wenn ein Schraffurmuster ausgewählt wird (1 bis 6), wird die Vordergrundfarbe durch die Füllfarbe& angegeben, während der Hintergrund durch die Standardhintergrundfarbe angegeben wird. Der optionale Füllstil& kann sein:

Fest (Standard)

Horizontale Linien

Vertikale Linien

Nach oben gerichtete diagonale Linien

Abwärts gerichtete diagonale Linien

Gekreuzte Linien

Diagonal gekreuzte Linien

Siehe auch

  • Built In RGB Color Equates
  • GRAFISCHE ANHÄNGE
  • GRAFISCHE FARBE
  • GRAFISCHE LINIE
  • GRAFIKSATZ-ÜBERLAPPUNG
  • GRAFISCHER STIL
  • GRAFISCHE BREITE

PBXB64-Umsetzungshinweise

GRAFIKBOX gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIKBOX ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIKBOX mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC(COL) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAPHIC(COL)
Hilfe zum PBXB64-Compiler

GRAFIK(COL)

Legt den nächsten fest oder ruft ihn ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC CELL = RowValue& , ColValue&
GRAPHIC CELL TO RowVar& , ColVar&
GRAPHIC COL TO ColVar&
GRAPHIC ROW TO RowVar&
ColVar& = GRAPHIC(COL)
RowVar& = GRAPHIC(ROW)

Beschreibung

GRAPHIC CELL wird verwendet, um die Druckposition basierend auf der Zeilen- und Spaltenposition einer Textzelle festzulegen oder abzurufen. Das ist die Position der Zeilenspalte, an der der nächste gedruckte Text angezeigt wird. Diese Operationen sind GRAPHIC GET POS und GRAPHIC SET POS sehr ähnlich, mit der Ausnahme, dass die Position in Textzeilen und -spalten und nicht in Seiteneinheiten angegeben wird. Die aktuelle Grafikposition wird in eine Zeilen- und Spaltennummer übersetzt, basierend auf der Standardzeichengröße in einer Schriftart mit fester Breite oder der durchschnittlichen Zeichengröße für eine Schriftart mit variabler Breite.

RowValue& gibt die horizontale Bildschirmzeile (beginnend bei 1) an, in der der Cursor positioniert werden soll. ColValue& gibt die vertikale Bildschirmspalte (beginnend bei 1) an, an der der Cursor positioniert werden soll. Da die Zeilen- und Spaltennummern bei eins (1) beginnen, wird die obere linke Ecke des Fensters als Zelle 1,1 betrachtet.

Die erste Form von GRAPHIC CELL verschiebt die Druckposition in die gewünschte Zeile und Spalte. Wenn ein angegebener Wert Null (0) ist, wird dieser Parameter ignoriert und diese Position wird nicht geändert.

Die zweite Form von GRAPHIC CELL ruft die aktuelle Druckposition ab und weist die Werte den durch RowVar& und ColVar& angegebenen Variablen zu. Jeder Punkt, der in eine Textzeichenzelle fällt, wird als diese Zeilen-/Spaltenposition gemeldet. Wenn sich die Grafikposition nicht in der oberen linken Ecke des Textzeichens befindet, erhalten Sie möglicherweise ungenaue oder unerwartete Ergebnisse. Dies kann auftreten, wenn Sie einen anderen Grafikvorgang als GRAFIKDRUCK ausführen, der den „Last Point Referenced“ an einer Position in der Mitte der Zelle belässt.

Mit den übrigen Formularen können Sie nur einen einzelnen Wert (entweder Zeile oder Spalte) abrufen und werden sowohl in Anweisungs- als auch in Funktionsform unterstützt.

Siehe auch

  • GRAFISCHE ZELLENGRÖSSE
  • GRAFIK GET POS
  • GRAFIK-SET-SCHRIFTART
  • GRAFIK SET POS
  • GRAFIK SET SCROLLTEXT
  • GRAFIK-SET WORDWRAP
  • GRAFIK-SET-WICKEL
  • GRAFISCHE SPLIT

PBXB64-Umsetzungshinweise

GRAFIK(COL) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK(COL) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK(COL) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC(Cell.Size.X) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAPHIC(Cell.Size.X)
Hilfe zum PBXB64-Compiler

GRAFIK(Zellengröße.X)

Rufen Sie den Charakter ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC CELL SIZE TO WidthVar! , HeightVar!
WidthVar! = GRAPHIC ( Cell.Size.X)
HeightVar! = GRAPHIC(Cell.Size.Y)

Beschreibung

GRAPHIC CELL SIZE ruft die Größe einer Zeichenzelle für die aktuelle Schriftart im angehängten Grafikziel ab. Die zurückgegebene Zeichengröße wird in PAGE UNITS angegeben und ermöglicht Ihnen die Berechnung der Anzahl der Textzeilen, die in einen bestimmten Raum passen. Der Höhenwert ist die Größe des angezeigten Zeichens, einschließlich des externen Zeilenabstands (falls vorhanden) für diese bestimmte Schriftart.

Wenn es sich bei der Schriftart um eine Schriftart mit fester Breite wie Courier New oder Lucida Console handelt, sind die zurückgegebenen Größen angesichts der für einige skalierte Einheiten erforderlichen gebrochenen Rundungsnäherungen so genau wie möglich. Wenn die Schriftart proportional ist, wie Arial oder Times New Roman, entspricht die Breite der durchschnittlichen Größe der gesamten Schriftart.

Der externe Zeilenabstand ist der vertikale Abstand vom unteren Rand eines Zeichens zum oberen Rand des darunter liegenden Zeichens. Dieser Wert wird durch die verwendete Schriftart angegeben. Der Wert kann je nach Schriftart und Punktgröße zwischen Null und einem größeren Wert variieren. Um die genaue Höhe von Zeichen ohne externen Zeilenabstand abzurufen, verwenden Sie GRAPHIC CHR SIZE .

Siehe auch

  • GRAFISCHE ZELLE
  • GRAFISCHE CHR-GRÖSSE
  • GRAFIK-SET-SCHRIFTART
  • GRAFISCHE TEXTGRÖSSE

PBXB64-Umsetzungshinweise

GRAFIK(Zellengröße.X) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK(Zellengröße.X) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK(Zellengröße.X) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC(Chr.Size.X) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAPHIC(Chr.Size.X)
Hilfe zum PBXB64-Compiler

GRAFIK (Chr.Größe.X)

Rufen Sie die Zeichengröße der Grafik ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC CHR SIZE To WidthVar!, HeightVar!
WidthVar! = GRAPHIC(Chr.Size.X)
HeightVar! = GRAPHIC(Chr.Size.Y)

Beschreibung

GRAPHIC CHR SIZE ruft die Größe eines Zeichens für die aktuelle Schriftart auf dem angehängten Grafikziel ab. Die zurückgegebene Zeichengröße wird in Seiteneinheiten angegeben. Der Höhenwert ist die tatsächliche Größe des angezeigten Zeichens, ohne externen Zeilenabstand (falls vorhanden) für diese bestimmte Schriftart.

Wenn es sich bei der Schriftart um eine Schriftart mit fester Breite wie Courier New oder Lucida Console handelt, sind die zurückgegebenen Größen angesichts der für einige skalierte Einheiten erforderlichen gebrochenen Rundungsnäherungen so genau wie möglich. Wenn die Schriftart proportional ist, wie Arial oder Times New Roman, entspricht die Breite der durchschnittlichen Größe der gesamten Schriftart.

Der externe Zeilenabstand ist der vertikale Abstand vom unteren Rand eines Zeichens zum oberen Rand des darunter liegenden Zeichens. Dieser Wert wird durch die verwendete Schriftart angegeben. Der Wert kann je nach Schriftart und Punktgröße zwischen Null und einem größeren Wert variieren. Um die gesamte Zeilenhöhe einschließlich des externen Zeilenabstands abzurufen, verwenden Sie stattdessen GRAPHIC CELL SIZE.

Siehe auch

  • GRAFISCHE ANHÄNGE
  • GRAFISCHE ZELLE
  • GRAFISCHE ZELLENGRÖSSE
  • GRAFIK-SET-SCHRIFTART
  • GRAFIKDRUCK
  • GRAFISCHE TEXTGRÖSSE

PBXB64-Umsetzungshinweise

GRAFIK (Chr.Größe.X) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK (Chr.Größe.X) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK (Chr.Größe.X) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC CLEAR – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK KLAR

GRAFIK KLAR

Löschen Sie die gesamte Auswahl

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC CLEAR [ rgbColor& [, fillstyle& ]]

Beschreibung

Das Grafikziel muss zunächst mit GRAPHIC ATTACH ausgewählt werden. Der letzte referenzierte Punkt (POS) wird auf die obere linke Ecke des Grafikfensters (0,0) gesetzt.

rgbColor&

Optionaler RGB-Wert, der die Füllfarbe darstellt. Wenn rgbColor& weggelassen wird (oder -1), wird das Grafikziel auf die Standardhintergrundfarbe für das ausgewählte Grafikziel zurückgesetzt.

Füllstil&

Optionaler Füllstil (Muster), der verwendet werden soll. Wenn fillstyle& weggelassen wird, ist der Standardfüllstil „solid“ (0). Wenn ein Schraffurmuster ausgewählt wird (1 bis 6), wird die Vordergrundfarbe durch rgbC olor& festgelegt, während der Hintergrund durch die Standardhintergrundfarbe für das ausgewählte Grafikfenster festgelegt wird. Der optionale Füllstil& kann sein:

Fest (Standard)

Horizontale Linien

Vertikale Linien

Nach oben gerichtete diagonale Linien

Abwärts gerichtete diagonale Linien

Gekreuzte Linien

Diagonal gekreuzte Linien

Siehe auch

  • Built In RGB Color Equates
  • GRAFISCHE ANHÄNGE
  • GRAFISCHE FARBE

PBXB64-Umsetzungshinweise

GRAFIK KLAR gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK KLAR ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK KLAR mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC-Codegruppe – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK-Codegruppe

GRAFISCHE Codegruppe

Die Grafik

Typ:Schlüsselwort |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC DirectorWord [ params ]
GRAPHIC DirectorWord [ params ] TO ReturnVariable(s)
ReturnVariable = GRAPHIC ( DirectorWord [,params])
ReturnVariable$ = GRAPHIC$ ( DirectorWord [,params])

Beschreibung

Einige der Funktionen der GRAPHIC-Gruppe waren in früheren Versionen von PowerBASIC verfügbar, wurden jedoch jetzt erweitert. Einige grafische Prozeduren (nämlich solche, die einen einzelnen Wert zurückgeben) können in zwei Formen verwendet werden: als Anweisung mit einer TO-Klausel oder als Funktion, die als Begriff in einem Ausdruck verwendet werden kann:

GRAFIK GET LINES TO LineCountVar&

LineCountVar& = GRAPHIC(LINES)

Die beiden obigen Beispiele sind funktional identisch. Die Wahl hängt einfach von Ihren persönlichen Vorlieben ab. Wenn Sie die zweite Form verwenden (als Funktion, die einen Wert zurückgibt), kann es sich um einen Begriff in jedem beliebigen Ausdruck beliebiger Komplexität handeln. Wenn ein Funktionsformular verfügbar ist, wird es mit dem Präfix „Funktionsformular“ gekennzeichnet.

Einige Grafikprozeduren geben zwei oder mehr Werte zurück. Da es nicht möglich ist, mehrere Begriffe gleichzeitig in einen gültigen Ausdruck einzufügen, steht die Funktionsoption für sie nicht zur Verfügung.

GRAFISCHES ZIEL

Der Begriff GRAFISCHES TARGET bezieht sich auf eine grafische Bitmap, ein grafisches Steuerelement oder ein grafisches Fenster. Sie können sich ein grafisches Ziel als die Leinwand Ihres Malers vorstellen, auf der Sie eine beliebige Menge an Text und Grafiken anzeigen. Es können viele Grafikziele gleichzeitig vorhanden sein, aber jeweils nur eines ist an den Grafikstream angehängt. Das angehängte Grafikziel ist dasjenige, auf das der Grafikcode einwirkt.

Grafische Bitmap

Hierbei handelt es sich um ein nicht sichtbares Ziel, das normalerweise als Arbeitsbereich zum Erstellen eines Bildes vor der Anzeige verwendet wird. Sie können mit GRAPHIC BITMAP NEW eine neue, leere Bitmap erstellen oder mit GRAPHIC BITMAP LOAD eine aus einer Ressource oder Festplattendatei laden. An diesem Punkt kann anderer Grafikcode verwendet werden, um darauf zu reagieren.

Grafische Steuerung

Dies ist ein statisches Steuerelement/Fenster, das mit CONTROL ADD GRAPHIC in einem DDT-Dialog platziert wird. Sobald Sie dieses Steuerelement anhängen, können Sie alle Formen von Text und Grafiken darauf anzeigen.

Grafikfenster

Dabei handelt es sich um ein eigenständiges Fenster, das an einer beliebigen Stelle auf dem Desktop platziert werden kann. Es wird mit GRAPHIC WINDOW erstellt und kann sogar als grafisches Konsolenfenster verwendet werden. Sobald Sie dieses Fenster anhängen, können Sie darin alle Arten von Text und Grafiken anzeigen.

GRAFIKSTREAM

Der Graphic Stream ist die Verbindung zwischen Grafikcode und einem Grafikziel. Der Grafikstream wird erstellt, wenn Sie ein bestimmtes Ziel mit GRAPHIC ATTACH anhängen. Von diesem Moment an wirkt der gesamte Grafikcode auf das ausgewählte Ziel. Dies wird so lange fortgesetzt, bis Sie ein neues Grafikziel auswählen. In diesem Fall wird der Grafikstream zum ersten Ziel deaktiviert und ein neuer Grafikstream zum neuen Ziel erstellt.

Sie können den Grafikstream so oft auf verschiedene Grafikziele umleiten, wie es für die Logik Ihres Programms erforderlich ist.

SEITENEINHEITEN

SEITENEINHEITEN werden verwendet, um die Größe eines grafischen Elements zu messen oder eine bestimmte Position auf einem grafischen Ziel zu definieren. Sie können Seiteneinheiten als Pixel, Dialogeinheiten oder skalierte Einheiten Ihrer Wahl definieren.

Zunächst erbt jedes Grafikziel die Seiteneinheitsgröße von seinem übergeordneten Ziel: Pixel oder Dialogeinheiten. Sie können dies mit GRAPHIC SCALE in skalierte Weltkoordinaten Ihrer Wahl ändern. Sie können von Dialogeinheiten oder skalierten Einheiten zurück zu Pixeln (der genauesten Form) zurückkehren, indem Sie GRAPHIC SCALE PIXELS ausführen.

Standardmäßig wird die obere linke Ecke eines Grafikziels als X-, Y-Position 0,0 betrachtet und nach rechts oder unten größer. Die X-Achse ist horizontal, während die Y-Achse vertikal ist. Immer wenn eine X-, Y-Position angegeben wird, wird zuerst der X-Wert angegeben. Sowohl die Grenzen als auch die Achsenrichtung können mit GRAPHIC SCALE geändert werden.

GRAFISCHE POSITION (POS)

Jedes Mal, wenn Sie Text oder Grafiken zeichnen, wird dieser an der aktuellen Grafikposition (POS) für dieses Ziel angezeigt. Nach Abschluss wird der POS auf den letzten referenzierten Punkt aktualisiert. Sie können einen relativen Abstand vom POS zeichnen (mithilfe einer STEP-Option) oder mit GRAPHIC SET POS eine völlig neue Position festlegen.

Die meisten PowerBASIC-Funktionen geben Grafik- und Pixelpositionen in Seiteneinheiten als X,Y an (zuerst der horizontale Term, dann der vertikale Term). Dies gilt sowohl für Grafiken als auch für Texte. Wenn Sie Text mit GRAFIKDRUCK zeichnen, definiert POS die Position der oberen linken Ecke des ersten Zeichens.

TEXTZELLE (ZEILEN-/Spaltenposition)

Um die Programmierung zu vereinfachen, geben einige Prozeduren die Textposition nach Zeile und Spalte an. In diesem Fall wird die Position in Textzellen gemessen, also dem von einem Zeichen eingenommenen Platz. Dies funktioniert gut mit Schriftarten mit fester Breite, was empfohlen wird. Wenn eine Schriftart mit variabler Breite gewählt wird, muss PowerBASIC für diese Berechnungen die durchschnittliche Zeichengröße verwenden, was zu ungenauen Ergebnissen führen kann.

Aus Gründen der Kompatibilität mit den meisten aktuellen und früheren Versionen von BASIC (einschließlich PowerBASIC) benennt Code, der auf Textzeilen und -spalten verweist, zuerst den vertikalen Begriff (Zeilen, Spalten). Zeilen und Spalten werden immer von eins aufwärts nummeriert.

Siehe auch

  • Grafische Befehle
  • Grafiken

PBXB64-Umsetzungshinweise

GRAFISCHE Codegruppe gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHE Codegruppe ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHE Codegruppe mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIKFARBE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIKFARBE

GRAFISCHE FARBE

Legt die Vordergrund- und Hintergrundfarbe fest.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC COLOR foreground& [, background& ]

Beschreibung

Wenn einer der Parameter -1 ist, wird die Standard-Vorder-/Hintergrundfarbe verwendet. Wenn der Hintergrundparameter -2 ist, wird der Hintergrund nicht gemalt, sodass der dahinter liegende Inhalt sichtbar wird. Wenn einer der Parameter -3 ist, wird die vorhandene Farbe nicht geändert. Andernfalls wird die angegebene RGB-Farbe verwendet.

Siehe auch

  • Built In RGB Color Equates
  • GRAFISCHE ANHÄNGE
  • GRAFIKDRUCK
  • GRAFIK-SET-SCHRIFTART

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

PBXB64-Umsetzungshinweise

GRAFISCHE FARBE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHE FARBE ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHE FARBE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFISCHE KOPIE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFISCHE KOPIE

GRAFISCHE KOPIE

Kopieren Sie eine Bitmap

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC COPY hbmpSource??? , id& [, style& ]
GRAPHIC COPY hbmpSource??? , id& TO ( x! , y! ) [, style& ]
GRAPHIC COPY hbmpSource??? , id& , ( x1! , y1! )-( x2! , y2! ) TO ( x! , y! ) [, style% ]

Beschreibung

Sie können eine vollständige Bitmap oder einen Teil davon in das ausgewählte Grafikziel kopieren. Der Ausdruck hbmpSource??? Gibt das Handle der Quelle GRAPHIC BITMAP , des GRAPHIC WINDOW oder des Dialogfelds an, das ein GRAPHIC CONTROL enthält. Der Ausdruck id& ist die eindeutige Steuerelement-ID im Bereich von 1 bis 65535, wie mit der CONTROL ADD GRAPHIC-Anweisung zugewiesen. id& muss für ein GRAFIKFENSTER oder eine GRAFIK-BITMAP 0 sein. Das Ziel des Kopiervorgangs ist das durch GRAPHIC ATTACH ausgewählte Fenster. Sie müssen darauf achten, dass Ihre Parameter für die angegebene Bitmap gültig sind, sonst sind die Ergebnisse der Operation undefiniert.

Die erste Form der GRAPHIC COPY-Anweisung kopiert die vollständige Bitmap und positioniert sie an (0,0), der oberen linken Ecke des Ziels.

Die zweite Form von GRAPHIC COPY kopiert ebenfalls die vollständige Bitmap, positioniert sie jedoch an der durch den Parameter ( x! , y! ) angegebenen Stelle.

Die dritte Form kopiert einen Teil der Bitmap, der durch x1,y1 als obere linke Ecke und x2,y2 als untere rechte Ecke angegeben wird. Es wird an dem durch den Parameter (x,y) angegebenen Punkt positioniert. Sie müssen darauf achten, dass Ihre Parameter für die angegebenen Bitmaps gültig sind, sonst sind die Ergebnisse der Operation undefiniert.

Wenn der Parameter „style“ enthalten ist, handelt es sich um einen der Werte in der folgenden Tabelle. Wenn nicht enthalten, wird ein Standardwert von %mix_CopySrc angenommen. Es stehen 8 Mischmodi zur Verfügung, mit denen Sie Zeichnungsfarben mit den Farben mischen können, die am Zeichnungsort bereits vorhanden sind. Die Mischmodus-Entsprechungen sind in PowerBASIC vordefiniert.

%mix_Blackness

Pixel ist immer 0 (schwarz).

%mix_NotMergeSrc

Pixel ist die Umkehrung der MergeSrc-Farbe.

%mix_MaskNotSrc

Pixel ist eine Kombination der Farben, die sowohl dem Pixel als auch der Umkehrung der Quelle gemeinsam sind.

%mix_NotCopySrc

Pixel ist die Umkehrung der Stiftfarbe.

%mix_MaskSrcNot

Pixel ist eine Kombination der Farben, die sowohl der Quelle als auch der Umkehrung des Pixels gemeinsam sind.

%mix_Not

Pixel ist die Umkehrung der Pixelfarbe.

%mix_XorSrc

Pixel ist eine Kombination der Farben in der Quelle und im Pixel, jedoch nicht in beiden.

%mix_NotMaskSrc

Pixel ist die Umkehrung der MaskSrc-Farbe.

%mix_MaskSrc

Pixel ist eine Kombination der Farben, die sowohl der Quelle als auch dem Pixel gemeinsam sind.

%mix_NotXorSrc

Pixel ist die Umkehrung der XorSrc-Farbe.

%mix_Nop

Pixel bleibt unverändert.

%mix_MergeNotSrc

Pixel ist eine Kombination aus der Quellfarbe und der Umkehrung der Pixelfarbe.

%mix_CopySrc

Pixel ist die Quellfarbe (Standard).

%mix_MergeSrcNot

Pixel ist eine Kombination aus der Quellfarbe und der Umkehrung der Pixelfarbe.

%mix_MergeSrc

Pixel ist eine Kombination aus der Quellfarbe und der Pixelfarbe.

%mix_Whiteness

Pixel ist immer 1 (weiß).

Siehe auch

  • GRAFIK GET STRETCHMODE
  • GRAFISCHES Rendering
  • GRAFIK SET STRETCHMODE
  • GRAFISCHER STRETCH

PBXB64-Umsetzungshinweise

GRAFISCHE KOPIE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHE KOPIE ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHE KOPIE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC DETACH – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › GRAFIK DETACH

GRAFISCHES ABNEHMEN

Löst eine Grafik ab

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC DETACH

Beschreibung

Obwohl das Grafikziel vom Grafikstream getrennt ist, wird es weder gelöscht noch in irgendeiner Weise verändert. Bis ein anderes Grafikziel angehängt wird, werden alle ausgeführten GRAPHIC-Anweisungen ignoriert. Wenn keine Grafik angehängt ist, führt diese Anweisung keine Operation aus.

Siehe auch

  • GRAFISCHE ANHÄNGE
  • GRAFISCHES BITMAP-LADEN
  • GRAFISCHE BITMAP NEU
  • GRAFISCHES FENSTER

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

PBXB64-Umsetzungshinweise

GRAFISCHES ABNEHMEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHES ABNEHMEN ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHES ABNEHMEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFISCHE ELLIPSE – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › GRAFISCHE ELLIPSE

GRAFISCHE ELLIPSE

Zeichnen Sie im ausgewählten Bereich eine Ellipse oder einen Kreis

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC ELLIPSE ( x1! , y1! ) - ( x2! , y2! ) [ , [ rgbColor& ] [ ,[ fillcolor& ] [ , [ fillstyle& ]]]]

Beschreibung

Koordinaten werden in Seiteneinheiten angegeben. Die Linienbreite kann mit GRAPHIC WIDTH eingestellt werden. Wenn die Linienbreite auf 1 eingestellt ist (Standardeinstellung), kann der Linienstil mit GRAPHIC STYLE festgelegt werden. Aufgrund der Natur einer Ellipse, die keinen offensichtlichen Anfang oder Ende hat, verwendet GRAPHIC ELLIPSE weder den letzten referenzierten Punkt (POS) noch aktualisiert er ihn.

Das Koordinatenpaar definiert ein unsichtbares Begrenzungsrechteck, das die zu zeichnende Ellipse umschließt. Es gibt sowohl die Größe als auch die Proportionen der Ellipse an. Die Windows-Grafikkonventionen betrachten die unteren und rechten Koordinaten als exklusiv. Die Pixel am unteren und rechten Rand werden ignoriert, es sei denn, der Überlappungsmodus ist aktiviert. Weitere Informationen finden Sie unter GRAFIKSATZ-ÜBERLAPPUNG.

x1! , y1!

Die obere linke Ecke des umgrenzenden Rechtecks.

x2! , y2!

Die untere rechte Ecke des umgrenzenden Rechtecks.

rgbColor&

Optionale RGB-Farbe der Ellipsenkante. Wenn es weggelassen wird (oder -1), wird als Kantenfarbe standardmäßig die aktuelle Vordergrundfarbe für das ausgewählte Grafikfenster verwendet.

Füllfarbe&

Optionale RGB-Farbe des Ellipsen-Innenraums. Wenn fillcolor& weggelassen wird (oder -2), wird das Innere der Ellipse nicht ausgefüllt, sodass der Hintergrund durchscheinen kann. Wenn fillcolor& -1 ist, wird der Innenraum mit der gleichen Farbe wie der Rand bemalt. Andernfalls gibt fillcolor& die zu verwendende RGB-Farbe an.

Füllstil&

Optionaler Füllstil (Muster), der verwendet werden soll. Wenn fillstyle& weggelassen wird, ist der Standardfüllstil „solid“ (0). Wenn ein Schraffurmuster ausgewählt wird (1 bis 6), wird die Vordergrundfarbe durch fillcolor& festgelegt, während der Hintergrund durch die Standardhintergrundfarbe für das ausgewählte Grafikfenster festgelegt wird. Der optionale Füllstil& kann sein:

Fest (Standard)

Horizontale Linien

Vertikale Linien

Nach oben gerichtete diagonale Linien

Abwärts gerichtete diagonale Linien

Gekreuzte Linien

Diagonal gekreuzte Linien

Siehe auch

  • Built In RGB Color Equates
  • GRAFISCHER BOGEN
  • GRAFISCHE ANHÄNGE
  • GRAFISCHE FARBE
  • GRAFISCHE LINIE
  • GRAFISCHER TORTEN
  • GRAFIKSATZ-ÜBERLAPPUNG
  • GRAFISCHER STIL
  • GRAFISCHE BREITE

PBXB64-Umsetzungshinweise

GRAFISCHE ELLIPSE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHE ELLIPSE ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHE ELLIPSE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIK GET BITS – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK GET BITS

GRAFIK ERHALTEN BITS

Rufen Sie eine Kopie einer Bitmap ab und speichern Sie sie als geräteunabhängige Bitmap in einem

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC GET BITS TO bitvar$

Beschreibung

Diese Anweisung ruft eine Kopie der gesamten Bitmap für das ausgewählte Grafikziel ab und weist sie der durch bitvar$ angegebenen dynamischen Zeichenfolgenvariablen zu. Dadurch können Sie sehr schnell viele Änderungen an der Bitmap vornehmen, insbesondere Vorgänge, die möglicherweise nicht direkt vom GRAPHIC-Code unterstützt werden. Beispielsweise könnten Sie alle roten Pixel in einer Bitmap in blaue ändern. Sobald Ihre Vorgänge abgeschlossen sind, wird die Bitmap mit GRAPHIC SET BITS ersetzt.

Die Bitvar$-Zeichenfolge enthält eine Reihe von Vier-Byte-Werten, von denen jeder eine lange Ganzzahl darstellt. Sie können die Vier-Byte-String-Abschnitte mit der CVL-Funktion in numerische Werte konvertieren und mit MKL$ einen numerischen Wert in eine Vier-Byte-String konvertieren. Der erste Vier-Byte-Wert gibt die Breite der Bitmap in Pixel an, der zweite Wert gibt die Höhe an. Darauf folgt ein Vier-Byte-Wert für jedes Pixel in der Bitmap, der die Farbe dieses Pixels darstellt. Eine 20 x 20 Bitmap hätte also 400 Pixel und erfordert 1600 Bytes (400 * 4), plus 4 Bytes für die Breite und 4 Bytes für die Höhe, also insgesamt 1608 Bytes.

Der erste Vier-Byte-Pixelwert in der Zeichenfolge stellt die obere linke Ecke des Bildes dar, der zweite stellt das zweite Pixel der ersten Zeile dar und so weiter. Nach dem letzten Pixel der ersten Zeile folgt das erste Pixel der zweiten Zeile usw.

Wenn die Ausführungsgeschwindigkeit am wichtigsten ist, lässt sich die Zeichenfolge wahrscheinlich am effizientesten mit Zeigervariablen manipulieren.

Einige Windows-API-Funktionen, insbesondere solche, die auf geräteunabhängige Bitmaps (DIB) verweisen, erfordern, dass Farben in umgekehrter Reihenfolge der normalen RGB-Reihenfolge angegeben werden (Blau-Grün-Rot statt Rot-Grün-Blau). Um die Leistung zu maximieren, verwendet GRAPHIC GET BITS auch das BGR-Format. Sie können die Funktion BGR() verwenden, um einen RGB-Wert in sein BGR-Äquivalent zu übersetzen.

Siehe auch

  • Built In RGB Color Equates
  • BGR
  • CVL
  • GRAFIK-SET-BITS
  • MKL$
  • RGB

PBXB64-Umsetzungshinweise

GRAFIK ERHALTEN BITS gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK ERHALTEN BITS ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK ERHALTEN BITS mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC(CANVAS.X) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAPHIC(CANVAS.X)
Hilfe zum PBXB64-Compiler

GRAFIK(CANVAS.X)

Ruft die beschreibbare Größe der angehängten Grafik ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC GET CANVAS TO WidthVar! , HeightVar!
WidthVar! = GRAPHIC(CANVAS.X)
HeightVar! = GRAPHIC(CANVAS.Y)

Beschreibung

GRAPHIC GET CANVAS ruft die Größe des Zeichenpuffers für das angehängte Grafikfenster, Steuerelement oder die Bitmap ab. Die Größe wird in Seiteneinheiten angegeben, sodass skalierte Werte zurückgegeben werden könnten, wenn sie mit GRAPHIC SCALE angewendet würden. Wenn das Grafikfenster oder Steuerelement FIXED ist (Standardeinstellung), entspricht die zurückgegebene Größe der CLIENT-Größe (mit Ausnahme des Skalierungsfaktors). Die CANVAS-Größe umfasst keine Beschriftung, keinen Rahmen, keine Bildlaufleisten usw. Wenn kein Grafikziel mit GRAPHIC ATTACH angehängt wurde, werden die Werte 0,0 zurückgegeben.

Siehe auch

  • GRAFIK GET CLIENT
  • GRAFIK-CLIP ERHALTEN
  • GRAFIK GRÖSSE ERHALTEN
  • GRAFIK ERHALTEN MAßSTAB
  • GRAFISCHE MAßSTAB

PBXB64-Umsetzungshinweise

GRAFIK(CANVAS.X) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK(CANVAS.X) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK(CANVAS.X) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC$(CAPTION) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAPHIC$(CAPTION)
Hilfe zum PBXB64-Compiler

GRAFIK$(CAPTION)

Ruft die Beschriftung von a ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC GET CAPTION To CaptionVar$
CaptionVar$ = GRAPHIC$(CAPTION)

Beschreibung

GRAPHIC GET CAPTION ruft den Text (falls vorhanden) ab, der derzeit als Beschriftung des ausgewählten Grafikziels angezeigt wird. Dieser Bereich wird auch „Titelleiste“ genannt. Ein Grafikfenster ist die einzige Form eines Grafikziels, die eine Beschriftung haben kann, daher geben andere Formen eine Null-Zeichenfolge (Null-Länge) zurück.

Siehe auch

  • Bildunterschrift für das Grafikset
  • GRAFISCHES FENSTER

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

PBXB64-Umsetzungshinweise

GRAFIK$(CAPTION) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK$(CAPTION) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK$(CAPTION) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC(Client.X) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAPHIC(Client.X)
Hilfe zum PBXB64-Compiler

GRAFIK(Client.X)

Rufen Sie die Clientgröße der ausgewählten ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC GET CLIENT To WidthVar! , HeightVar!
WidthVar! = GRAPHIC(Client.X)
HeightVar ! = GRAPHIC(Client.Y)

Beschreibung

GRAPHIC GET CLIENT ruft die physische Größe des Clientbereichs (sichtbarer Teil) des angehängten Grafikfensters oder Steuerelements ab. Die Größe wird in Pixeln oder Dialogeinheiten angegeben, je nachdem, wie sie erstellt wurde. Die zurückgegebenen Größen werden durch die Operationen GRAPHIC SCALE , VIRTUAL oder AUTOSIZE nicht verändert oder beeinflusst, da sie die physische Größe des sichtbaren Bereichs in den für seine Erstellung verwendeten Begriffen zurückgeben. Der Clientbereich enthält keine Beschriftung, keinen Rahmen, keine Bildlaufleisten usw. Wenn GRAPHIC GET CLIENT mit einer Bitmap verwendet wird, wird 0,0 zurückgegeben. Normalerweise verwenden Sie GRAPHIC GET CANVAS mit einer Bitmap oder um die Größe des Bereichs zu ermitteln, der gezeichnet werden kann. Wenn mit GRAPHIC ATTACH kein Grafikziel angehängt wurde, werden die Werte 0,0 zurückgegeben.

Siehe auch

  • GRAFISCHE ANHÄNGE
  • GRAFIK ERHALTEN SIE LEINWAND
  • GRAFIK-CLIP ERHALTEN
  • GRAFIK GRÖSSE ERHALTEN
  • GRAFIK-SET-CLIENT

PBXB64-Umsetzungshinweise

GRAFIK(Client.X) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK(Client.X) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK(Client.X) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC(Clip.X) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAPHIC(Clip.X)
Hilfe zum PBXB64-Compiler

GRAFIK(Clip.X)

Ruft die Größe ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC GET CLIP TO WidthVar! , HeightVar!
WidthVar! = GRAPHIC(Clip.X)
HeightVar! = GRAPHIC(Clip.Y)

Beschreibung

Der Clipbereich eines Grafikziels ist der Bereich, in dem GRAFIKoperationen angezeigt werden können. Das heißt, der Clip-Bereich ist der Teil des Client-Bereichs, der nicht durch GRAPHIC SET CLIP geschützt (abgeschnitten) wird.

GRAPHIC GET CLIP ruft die Größe des Clipbereichs ab und weist diese Werte den durch „WidthVar!“ angegebenen Variablen zu. und HeightVar! . Die Größe wird in PAGE UNITS angegeben. Wenn kein grafisches Ziel ausgewählt ist, werden die Werte 0,0 zurückgegeben.

Siehe auch

  • GRAFIK ERHALTEN SIE LEINWAND
  • GRAFIK GET CLIENT
  • GRAFIK-SET-CLIP

PBXB64-Umsetzungshinweise

GRAFIK(Clip.X) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK(Clip.X) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK(Clip.X) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC(DC) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK(DC)
Hilfe zum PBXB64-Compiler

GRAFIK(DC)

Rufen Sie das Handle des DC (Gerätekontext) für das ausgewählte ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC GET DC TO hDC???
Function Form:
DCVar??? = GRAPHIC(DC)

Beschreibung

Das DC-Handle kann mit verschiedenen Windows-API-Funktionen verwendet werden, um spezielle Grafikoperationen im Grafikziel auszuführen. Wenn aktuell kein Grafikfenster ausgewählt ist, wird Null zurückgegeben.

Siehe auch

  • GRAFISCHE ANHÄNGE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

PBXB64-Umsetzungshinweise

GRAFIK(DC) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK(DC) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK(DC) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIK(LINIEN) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK(LINIEN)
Hilfe zum PBXB64-Compiler

GRAFIK(LINIEN)

Ruft die Anzahl ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC GET LINES TO linecount&
linecount& = GRAPHIC(LINES)

Beschreibung

GRAPHIC GET LINES ruft die Anzahl der Textzeilen ab, die unter Berücksichtigung der aktuell ausgewählten Schriftart auf das Grafikziel passen. Dieser Wert wird linecount& zugewiesen.

Siehe auch

  • GRAFISCHE ANHÄNGE
  • GRAFISCHE ZELLE
  • GRAFISCHE CHR-GRÖSSE
  • GRAFIKDRUCK
  • GRAFIK-SET-SCHRIFTART
  • GRAFISCHE TEXTGRÖSSE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

PBXB64-Umsetzungshinweise

GRAFIK(LINIEN) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK(LINIEN) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK(LINIEN) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC(LOC.X) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAPHIC(LOC.X)
Hilfe zum PBXB64-Compiler

GRAFIK(LOC.X)

Ruft den Standort ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC GET LOC TO x& , y&
F unction Form:
x& = GRAPHIC(LOC.X)
y& = GRAPHIC(LOC.Y)

Beschreibung

Diese Anweisung ruft den Speicherort des ausgewählten Grafikfensters ab. Wenn kein Grafikobjekt ausgewählt ist oder es sich nicht um ein Grafikfenster handelt, wird 0,0 zurückgegeben. Die Position wird in Pixel relativ zur oberen linken Ecke des Bildschirms angegeben.

Siehe auch

  • GRAFISCHE ANHÄNGE
  • GRAFIK ERHALTEN PPI
  • GRAFIK SET LOC

PBXB64-Umsetzungshinweise

GRAFIK(LOC.X) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK(LOC.X) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK(LOC.X) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC(MIX) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK(MIX)
Hilfe zum PBXB64-Compiler

GRAFIK(MIX)

Rufen Sie den Farbmischungsmodus für das ausgewählte ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC GET MIX TO mixmode&
mixmode& = GRAPHIC(MIX)

Beschreibung

Es stehen 16 Mischmodi zur Verfügung, mit denen Sie die Zeichenfarbe mit der Farbe mischen können, die bereits am Zeichenort vorhanden ist.

%mix_Blackness

Pixel ist immer 0 (schwarz).

%mix_NotMergeSrc

Pixel ist die Umkehrung der MergeSrc-Farbe.

%mix_MaskNotSrc

Pixel ist eine Kombination der Farben, die sowohl dem Pixel als auch der Umkehrung der Quelle gemeinsam sind.

%mix_NotCopySrc

Pixel ist die Umkehrung der Stiftfarbe.

%mix_MaskSrcNot

Pixel ist eine Kombination der Farben, die sowohl der Quelle als auch der Umkehrung des Pixels gemeinsam sind.

%mix_Not

Pixel ist die Umkehrung der Pixelfarbe.

%mix_XorSrc

Pixel ist eine Kombination der Farben in der Quelle und im Pixel, jedoch nicht in beiden.

%mix_NotMaskSrc

Pixel ist die Umkehrung der MaskSrc-Farbe.

%mix_MaskSrc

Pixel ist eine Kombination der Farben, die sowohl der Quelle als auch dem Pixel gemeinsam sind.

%mix_NotXorSrc

Pixel ist die Umkehrung der XorSrc-Farbe.

%mix_Nop

Pixel bleibt unverändert.

%mix_MergeNotSrc

Pixel ist eine Kombination aus der Quellfarbe und der Umkehrung der Pixelfarbe.

%mix_CopySrc

Pixel ist die Quellfarbe (Standard).

%mix_MergeSrcNot

Pixel ist eine Kombination aus der Quellfarbe und der Umkehrung der Pixelfarbe.

%mix_MergeSrc

Pixel ist eine Kombination aus der Quellfarbe und der Pixelfarbe.

%mix_Whiteness

Pixel ist immer 1 (weiß).

Siehe auch

  • GRAFISCHER SET-MIX

PBXB64-Umsetzungshinweise

GRAFIK(MIX) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK(MIX) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK(MIX) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIK (ÜBERLAPPUNG) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK(OVERLAP)
Hilfe zum PBXB64-Compiler

GRAFIK (ÜBERLAPPUNG)

Ruft den Status der Grafik ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC GET OVERLAP To OverlapVar&
OverlapVar& = GRAPHIC(OVERLAP)

Beschreibung

GRAPHIC GET OVERLAP ruft den Status des Überlappungsmodus ab und weist ihn der durch OverlapVar& angegebenen Variablen zu. Wenn der Überlappungsmodus aktiviert ist, wird der Wert wahr (ungleich Null) zugewiesen. Wenn es deaktiviert ist, wird stattdessen der Wert false (Null) zugewiesen. Der zurückgegebene Wert spiegelt den Status des Grafikziels wider, das derzeit an den Grafikstream angehängt ist.

Mit dem Überlappungsmodus steuern Sie, wie PowerBASIC Grafikoperationen behandelt, deren Definition eine RECT-Struktur beinhaltet. Windows-Grafikkonventionen betrachten die unteren und rechten Koordinaten eines RECT als exklusiv. Mit anderen Worten: Die Pixel am unteren und rechten Rand liegen unmittelbar außerhalb des Rechtecks. Sie werden nicht gezeichnet, sondern ignoriert. Zum Beispiel:

GRAFIKBOX (0,0) - (50,50)

In diesem Fall wird ein Kästchen von 0,0 bis 49,49 gezeichnet. Die letzten Pixel am unteren und rechten Rand werden einfach nicht gezeichnet. Wenn jedoch der Überlappungsmodus mit GRAPHIC SET OVERLAP aktiviert ist, wird das Feld von 0,0 bis 50,50 gezeichnet.

Der Überlappungsmodus wirkt sich auf Zeichenvorgänge mit GRAFISCHER MAßSTAB, GRAFISCHER KASTEN, GRAFISCHER ELLIPSE, GRAFISCHER LINIE, GRAFISCHER POLYLINIE usw. aus.

Siehe auch

  • GRAFIKSATZ-ÜBERLAPPUNG

PBXB64-Umsetzungshinweise

GRAFIK (ÜBERLAPPUNG) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK (ÜBERLAPPUNG) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK (ÜBERLAPPUNG) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIK(PIXEL...) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK(PIXEL...)
Hilfe zum PBXB64-Compiler

GRAFIK(PIXEL...)

Rufen Sie die Farbe ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC GET PIXEL [STEP] ( x! , y! ) To PixelVar&
PixelVar& = GRAPHIC(PIXEL [STEP], x! , y! )

Beschreibung

Die Koordinatenpunkte x! , y! werden in Seiteneinheiten angegeben.

Siehe auch

  • GRAFISCHE ANHÄNGE
  • GRAFISCHE FARBE
  • GRAFISCHE MAßSTAB
  • GRAFIK-SET-PIXEL

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

PBXB64-Umsetzungshinweise

GRAFIK(PIXEL...) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK(PIXEL...) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK(PIXEL...) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIK(POS.X) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK(POS.X)
Hilfe zum PBXB64-Compiler

GRAFIK(POS.X)

Rufen Sie den POS (letzter referenzierter Punkt) anhand einer Grafik ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC GET POS To XVar! , YVar!
XVar! = GRAPHIC(POS.X)
YVar! = GRAPHIC(POS.Y)

Beschreibung

Die Koordinatenpunkte XVar! , YVar! werden in denselben Begriffen (Pixeln oder Dialogeinheiten) wie der übergeordnete Dialog (oder Weltkoordinaten, wenn diese mit GRAPHIC SCALE ausgewählt wurden) angegeben.

Siehe auch

  • GRAFISCHE ANHÄNGE
  • GRAFISCHE ZELLE
  • GRAFISCHE MAßSTAB
  • GRAFIK SET POS

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

PBXB64-Umsetzungshinweise

GRAFIK(POS.X) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK(POS.X) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK(POS.X) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC(PPI.X) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAPHIC(PPI.X)
Hilfe zum PBXB64-Compiler

GRAFIK(PPI.X)

Rufen Sie die Auflösung des Anzeigegeräts in Punkten pro Zoll ab.

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC GET PPI TO XVar& , YVar&
XVar& = GRAPHIC(PPI.X)
YVar& = GRAPHIC(PPI.Y)

Beschreibung

Die Auflösung wird immer in Pixel angegeben. Diese Anweisung ist besonders nützlich, wenn Sie Elemente wie Lineale und Diagramme auf eine repräsentative physische Größe zeichnen möchten. Es gibt 25,4 Millimeter pro Zoll, also dividieren Sie einfach durch 25,4, um von Pixel pro Zoll in Pixel pro Millimeter umzurechnen.

„Repräsentative physische Größe“ bedeutet, dass das tatsächliche Bild einer bestimmten physischen Größe nahe kommen kann, jedoch von Faktoren wie der Windows-Standard-PPI-Einstellung, dem DPI-zu-PPI-Verhältnis des Treibers und sogar der Einstellung des Monitors abhängt. Mithilfe der Ergebnisse von GRAPHIC GET PPI können Sie ein repräsentatives Grafikbild erstellen, das gespeichert und später im beabsichtigten Maßstab auf präziseren Geräten ausgegeben werden kann, beispielsweise auf einem Windows-Drucker mit höherer Auflösung.

Siehe auch

  • GRAFISCHE ANHÄNGE
  • GRAFISCHE MAßSTAB

PBXB64-Umsetzungshinweise

GRAFIK(PPI.X) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK(PPI.X) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK(PPI.X) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC GET SCALE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAPHIC GET SCALE

GRAFIK ERHALTEN MAßSTAB

Rufen Sie den Strom ab

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC GET SCALE TO x1! , y1! , x2! , y2!

Beschreibung

Mit GRAPHIC SCALE können Sie Ihr eigenes Weltkoordinatensystem für nachfolgende GRAPHIC-Anweisungen definieren. Weltkoordinaten können Gleitkommawerte sein, mit der einzigen Anforderung, dass x1! ungleich x2! und y1! ungleich y2!.

GRAPHIC GET SCALE ruft die Koordinatengrenzen ab, bei denen es sich entweder um benutzerdefinierte Weltkoordinaten (wenn ein GRAPHIC SCALE ausgeführt wurde) oder um Standardpixelkoordinaten handeln kann. Dadurch können Sie einen vorherigen Koordinatensatz speichern und wiederherstellen. Diese Anweisung wird automatisch angepasst, um das Abrufen von Skalierungsfaktoren für Dialogeinheiten zu ermöglichen.

Siehe auch

  • GRAFISCHE MAßSTAB
  • PIXEL IM GRAFISCHEN MAßSTAB

PBXB64-Umsetzungshinweise

GRAFIK ERHALTEN MAßSTAB gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK ERHALTEN MAßSTAB ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK ERHALTEN MAßSTAB mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIK (SCROLLTEXT) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAPHIC(SCROLLTEXT)
Hilfe zum PBXB64-Compiler

GRAFIK(SCROLLTEXT)

Ruft den Status der Grafik ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC GET SCROLLTEXT To ScrollVar&
ScrollVar& = GRAPHIC(SCROLLTEXT)

Beschreibung

GRAPHIC GET SCROLLTEXT ruft den Status des ScrollText-Modus ab und weist ihn der durch ScrollVar& angegebenen Variablen zu. Wenn der ScrollText-Modus aktiviert ist, wird der Wert true (ungleich Null) zugewiesen. Wenn es deaktiviert ist, wird stattdessen der Wert false (Null) zugewiesen. Der zurückgegebene Wert spiegelt den Status des Grafikziels wider, das derzeit an den Grafikstream angehängt ist.

Mit dem ScrollText-Modus können Sie steuern, wie PowerBASIC Text auf einem Grafikziel druckt, wenn es das Ende einer Seite erreicht. Da ein Grafikziel auf Ganzseitenbasis arbeitet, wird standardmäßig Text ignoriert, der über das Ende der Seite hinaus gedruckt wird. Dies kann programmgesteuert mit GRAPHIC SET SCROLLTEXT geändert werden.

Wenn der ScrollText-Modus aktiviert ist, wird das Scrollen einer Seite nur durch GRAFIKDRUCK ausgelöst. Wenn sich der POS (letzter referenzierter Punkt) in der unteren Zeile des Grafikziels befindet und eine GRAPHIC PRINT-Anweisung den POS von der Seite verschiebt, wird der gesamte Inhalt des Grafikziels um eine Zeile gescrollt und unten wird eine neue leere Zeile geöffnet.

Siehe auch

  • GRAFISCHE ZELLE
  • GRAFIK SET SCROLLTEXT

PBXB64-Umsetzungshinweise

GRAFIK(SCROLLTEXT) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK(SCROLLTEXT) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK(SCROLLTEXT) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC(SIZE.X) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAPHIC(SIZE.X)
Hilfe zum PBXB64-Compiler

GRAFIK(GRÖSSE.X)

Ruft die Gesamtgröße der ausgewählten Grafik ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC GET SIZE To WidthVar& , HeightVar&
WidthVar& = GRAPHIC(SIZE.X)
HeightVar& = GRAPHIC(SIZE.Y)

Beschreibung

GRAPHIC GET SIZE ruft die gesamte physische Größe des ausgewählten Grafikfensters oder Steuerelements ab. Die Größe wird in Pixeln oder Dialogeinheiten angegeben, je nachdem, wie sie erstellt wurde. Die Größe umfasst immer etwaige Beschriftungen, Rahmen, Bildlaufleisten usw. Wenn kein grafisches Ziel angehängt ist, werden die Werte 0,0 zurückgegeben.

Siehe auch

  • GRAFIK ERHALTEN SIE LEINWAND
  • GRAFIK GET CLIENT
  • GRAFIK-CLIP ERHALTEN
  • GRAFISCHE GET-ZEILEN
  • GRAFIK-SET-GRÖSSE

PBXB64-Umsetzungshinweise

GRAFIK(GRÖSSE.X) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK(GRÖSSE.X) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK(GRÖSSE.X) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIK (STRETCHMODE) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK (STRETCHMODE)
Hilfe zum PBXB64-Compiler

GRAFIK (STRETCHMODUS)

Ruft den Standard-Bitmap-Streckmodus für das angehängte Objekt ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC GET STRETCHMODE TO ModeVar&
ModeVar& = GRAPHIC(STRETCHMODE)

Beschreibung

In PowerBASIC gibt es mehrere Vorgänge, die das Strecken oder Komprimieren von Bildern auf Bitmaps umfassen, insbesondere GRAPHIC STRETCH . Da einzelne Pixel hinzugefügt oder entfernt werden müssen, besteht eine gute Chance, dass sich die Bildqualität verschlechtert. Wenn Sie jedoch die Art des Bildes durch die Definition eines StretchMode beschreiben, können Sie das Erscheinungsbild erheblich verbessern.

Der Standard-StretchMode wird für jeden DC individuell verwaltet. Sie können den Standardmodus mit dieser Anweisung abrufen oder mit GRAPHIC GET STRETCHMODE festlegen. Natürlich können Sie den Standard-StretchMode auch überschreiben, wenn Sie eine der betroffenen Anweisungen ausführen.

Die 4 Stretch-Modus-Equates sind in PowerBASIC vordefiniert.

Gleichsetzen

Beschreibung

%BLACKONWHITE

Dies ist der standardmäßige Streckungsmodus von Windows und eignet sich am besten für monochrome Bitmaps oder solche mit Farbblöcken. Führt ein boolesches ODER von eliminierten und vorhandenen Pixeln durch. Schwarze Pixel bleiben auf Kosten weißer Pixel erhalten.

%WHITEONBLACK

Führt ein boolesches ODER von eliminierten und vorhandenen Pixeln durch. Es behält weiße Pixel auf Kosten schwarzer Pixel bei.

%COLORONCOLOR

Löscht gelöschte Pixelzeilen, ohne zu versuchen, ihre Informationen beizubehalten.

%HALBTON

Dies bietet höchste Qualität für komplexe Farbbitmaps. Die durchschnittliche Farbe des Zielpixelblocks bleibt ungefähr die gleiche wie die des Quellpixelblocks.

Siehe auch

  • GRAFISCHES BITMAP-LADEN
  • GRAFISCHE KOPIE
  • GRAFISCHES Rendering
  • GRAFIK SET STRETCHMODE
  • GRAFISCHER STRETCH

PBXB64-Umsetzungshinweise

GRAFIK (STRETCHMODUS) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK (STRETCHMODUS) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK (STRETCHMODUS) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC(View.X) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAPHIC(View.X)
Hilfe zum PBXB64-Compiler

GRAFIK(Ansicht.X)

Ruft die Position des ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC GET VIEW To WidthVar! , HeightVar!
WidthVar! = GRAPHIC(View.X)
HeightVar! = GRAPHIC(View.Y)

Beschreibung

Ruft die Position des Ansichtsfensters auf einem virtuellen Grafikziel ab. Die Größe wird in Seiteneinheiten angegeben. Wenn kein grafisches Ziel ausgewählt oder kein virtuelles Fenster erstellt wurde, werden die Werte 0,0 zurückgegeben.

Siehe auch

  • GRAFISCHE SET-ANSICHT
  • VIRTUELLES GRAFIKSET

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

PBXB64-Umsetzungshinweise

GRAFIK(Ansicht.X) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK(Ansicht.X) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK(Ansicht.X) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC(WORDWRAP) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAPHIC(WORDWRAP)
Hilfe zum PBXB64-Compiler

GRAFIK (WORDWRAP)

Ruft den Status der Grafik ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC GET WORDWRAP TO WrapVar&
WrapVar& = GRAPHIC(WORDWRAP)

Beschreibung

GRAPHIC GET WORDWRAP ruft den Status des Zeilenumbruchmodus ab und weist ihn der durch WrapVar& angegebenen Variablen zu. Wenn der WordWrap-Modus aktiviert ist, wird der Wert true (ungleich Null) zugewiesen. Wenn es deaktiviert ist, wird stattdessen der Wert false (Null) zugewiesen. Der zurückgegebene Wert spiegelt den Status des Grafikziels wider, das derzeit an den Grafikstream angehängt ist.

Mit dem WordWrap-Modus können Sie steuern, wie PowerBASIC Text auf einem Grafikziel druckt, wenn dieser das Ende einer Zeile erreicht. Da ein Grafikziel auf Ganzseitenbasis arbeitet, wird standardmäßig Text ignoriert, der über das Zeilenende hinaus gedruckt wird. Dies kann programmgesteuert mit GRAPHIC SET WORDWRAP geändert werden.

Wenn der WordWrap-Modus aktiviert ist, wirkt er sich nur auf GRAFIKDRUCK-Vorgänge aus. Wenn GRAPHIC PRINT versucht, ein Wort über das Ende einer Zeile hinaus anzuzeigen, wird das gesamte Wort automatisch in die erste Spalte der nächsten Zeile umgebrochen.

Siehe auch

  • GRAFISCHE ZELLE
  • GRAFIK GET WRAP
  • GRAFIK-SET WORDWRAP
  • GRAFIK-SET-WICKEL
  • GRAFISCHE SPLIT

PBXB64-Umsetzungshinweise

GRAFIK (WORDWRAP) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK (WORDWRAP) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK (WORDWRAP) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC(WRAP) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAPHIC(WRAP)
Hilfe zum PBXB64-Compiler

GRAFIK (WRAP)

Ruft den Status der Grafik ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC GET WRAP TO WrapVar&
WrapVar& = GRAPHIC(WRAP)

Beschreibung

GRAPHIC GET WRAP ruft den Status des Wrap-Modus ab und weist ihn der durch WrapVar& angegebenen Variablen zu. Wenn der Wrap-Modus aktiviert ist, wird der Wert true (ungleich Null) zugewiesen. Wenn es deaktiviert ist, wird stattdessen der Wert false (Null) zugewiesen. Der zurückgegebene Wert spiegelt den Status des Grafikziels wider, das derzeit an den Grafikstream angehängt ist.

Mit dem Wrap-Modus können Sie steuern, wie PowerBASIC Text auf einem Grafikziel druckt, wenn dieser das Ende einer Zeile erreicht. Da ein Grafikziel auf Ganzseitenbasis arbeitet, wird standardmäßig Text ignoriert, der über das Zeilenende hinaus gedruckt wird. Dies kann programmgesteuert mit GRAPHIC SET WRAP geändert werden.

Wenn der Wrap-Modus aktiviert ist, wirkt er sich nur auf GRAFIKDRUCK-Vorgänge aus. Wenn GRAPHIC PRINT versucht, ein Zeichen über das Ende einer Zeile hinaus anzuzeigen, wird es automatisch in die erste Spalte der nächsten Zeile umgebrochen.

Siehe auch

  • GRAFISCHE ZELLE
  • GRAFIK GET WORDWRAP
  • GRAFIK-SET WORDWRAP
  • GRAFIK-SET-WICKEL
  • GRAFISCHE SPLIT

PBXB64-Umsetzungshinweise

GRAFIK (WRAP) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK (WRAP) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK (WRAP) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFISCHE BILDLISTE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFISCHE BILDLISTE

GRAFISCHE BILDLISTE

Zeigt ein Bild von einem an

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC IMAGELIST ( x! , y! ), hLst , index& , overlay& , style&

Beschreibung

Eines der in einer IMAGELIST gespeicherten Bilder wird im ausgewählten Grafiksteuerelement, Bitmap oder Fenster angezeigt. Die Parameter x!,y! Definieren Sie die obere linke Ecke der Position des Bildes. hLst ist das Handle der IMAGELIST und index& ist der Selektor des anzuzeigenden Bildes (1=erstes, 2=zweite usw.). Wenn overlay& ungleich Null ist, gibt es ein Overlay-Bild an, das dem angezeigten Bild aus der Bildliste hinzugefügt werden soll. Der Parameter style& kann eines der folgenden Stilbits sein:

%ILD_NORMAL

Zeichnet das Bild mit der Hintergrundfarbe der Bildliste. Wenn die Hintergrundfarbe den Standardwert %CLR_NONE hat (definiert in der Datei Commctrl.inc), wird das Bild transparent gezeichnet.

%ILD_TRANSPARENT

Zeichnet das Bild transparent, wenn eine Maske vorhanden ist.

%ILD_MASK

Zeichnet die Maske.

%ILD_BLEND25

Wenn eine Maske vorhanden ist, wird das Bild mit einer Mischung von 25 % mit der Systemhervorhebungsfarbe gezeichnet.

%ILD_BLEND50

Wenn eine Maske vorhanden ist, wird das Bild zu 50 % mit der Hervorhebungsfarbe des Systems gemischt gezeichnet.

Siehe auch

  • GRAFISCHE ANHÄNGE
  • GRAFISCHE KOPIE
  • GRAFISCHES Rendering
  • GRAFISCHER STRETCH
  • BILDLISTE

PBXB64-Umsetzungshinweise

GRAFISCHE BILDLISTE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHE BILDLISTE ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHE BILDLISTE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC$(INKEY$) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAPHIC$(INKEY$)
Hilfe zum PBXB64-Compiler

GRAFIK$(INKEY$)

Liest ein Tastaturzeichen, sofern eines bereit ist.

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC INKEY$ TO InkeyVar$
InkeyVar$ = GRAPHIC$(INKEY$)

Beschreibung

GRAPHIC INKEY$ gibt eine Zeichenfolge mit 0, 1 oder 2 Zeichen zurück, die den Status des Tastaturpuffers für das ausgewählte Grafikziel widerspiegelt. Eine Nullzeichenfolge (LEN=0) bedeutet, dass der Puffer leer ist – keine Taste gedrückt.

Eine Zeichenfolgenlänge von eins bedeutet, dass eine ASCII-Taste gedrückt wurde und die Zeichenfolge das ASCII-Zeichen enthält. Ein ASCII-Wert zwischen 1 und 31 gibt einen Steuercode an.

Eine Zeichenfolgenlänge von zwei bedeutet, dass eine erweiterte Taste gedrückt wurde. In diesem Fall hat das erste Zeichen in der Zeichenfolge den ASCII-Wert Null und das zweite ist der erweiterte Tastaturcode.

Siehe auch

  • GRAFISCHE INPUT
  • GRAFISCHER EINGANG FLUSH
  • GRAFISCHE INSTAT
  • GRAFISCHE ZEILENEINGABE
  • GRAFISCHER WAITKEY$

PBXB64-Umsetzungshinweise

GRAFIK$(INKEY$) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK$(INKEY$) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK$(INKEY$) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFISCHE INPUT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFISCHE INPUT

GRAFISCHE INPUT

Liest Daten von der Tastatur aus einem

Typ:Anweisung |Kategorie:Datei-E/A

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC INPUT [ prompt ,] varlist
prompt

Beschreibung

GRAFISCHE INPUT zeigt die Eingabeaufforderung im aktiven Grafikziel an, wartet auf eine Zeile von Tastatureingaben, verteilt kommagetrennte Werte auf die aufgeführten Variablen und weist jeden Wert nach dem Typ der Zielvariablen zu. Numerische Ziele akzeptieren numerischen Text; Zeichenfolgenziele erhalten den rohen Feldinhalt. Fehlende Restwerte werden mit Null oder einer leeren Zeichenfolge belegt.

Verwenden Sie GRAPHIC LINE INPUT, wenn Sie nur ein einzelnes Zeichenfolgen-Ergebnis ohne Kommatrennung benoetigen.

Siehe auch

  • GRAFIK-INKEY$
  • GRAFISCHER EINGANG FLUSH
  • GRAFISCHE INSTAT
  • GRAFISCHE ZEILENEINGABE
  • GRAFISCHER WAITKEY$

PBXB64-Umsetzungshinweise

GRAFISCHE INPUT gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHE INPUT ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHE INPUT mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFISCHE INPUT FLUSH – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFISCHE EINGABEFLUSH

GRAFISCHER EINGANG FLUSH

Entfernen Sie alle gepufferten Tastaturdaten.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC INPUT FLUSH

Siehe auch

  • GRAFIK-INKEY$
  • GRAFISCHE INPUT
  • GRAFISCHE INSTAT
  • GRAFISCHE ZEILENEINGABE
  • GRAFISCHER WAITKEY$

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

GRAFISCHER EINGANG FLUSH gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Ziel, Zustand und die aktuelle Ausfuehrungsreihenfolge.

PBXB64-Umsetzungshinweise

GRAFISCHER EINGANG FLUSH gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHER EINGANG FLUSH ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHER EINGANG FLUSH mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIK(INSTAT) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK(INSTAT)
Hilfe zum PBXB64-Compiler

GRAFIK(INSTAT)

Bestimmt, ob ein Tastaturzeichen bereit ist.

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC INSTAT TO NumericVar
InstatVar& = GRAPHIC(INSTAT)

Beschreibung

Die Integralvariable empfängt den Tastaturpufferstatus für das ausgewählte Grafikziel. Der zugewiesene Wert ist TRUE (ungleich Null), wenn ein Tastaturzeichen zum Abrufen bereit ist, oder FALSE (Null), wenn nicht.

GRAPHIC INSTAT entfernt das Zeichen nicht aus dem Puffer, sodass eine wiederholte Ausführung weiterhin TRUE zurückgibt, bis das Zeichen mit GRAPHIC INKEY$ , GRAPHIC INPUT usw. gelesen wird.

Siehe auch

  • GRAFIK-INKEY$
  • GRAFISCHE INPUT
  • GRAFISCHER EINGANG FLUSH
  • GRAFISCHE ZEILENEINGABE
  • GRAFISCHER WAITKEY$

PBXB64-Umsetzungshinweise

GRAFIK(INSTAT) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK(INSTAT) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK(INSTAT) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFISCHE ZEILE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFISCHE LINIE

GRAFISCHE LINIE

Zeichnen Sie eine Linie auf dem ausgewählten

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC LINE [STEP] [( x1! , y1! )] - [STEP] ( x2! , y2! )[, rgbColor& ]

Beschreibung

Die Linie wird vom ersten Punkt bis zum zweiten Punkt gezeichnet, jedoch nicht einschließlich. Koordinatenpunkte werden in Seiteneinheiten angegeben. Die Linienbreite kann mit GRAPHIC WIDTH eingestellt werden. Wenn die Linienbreite auf 1 eingestellt ist (Standardeinstellung), kann der Linienstil mit GRAPHIC STYLE festgelegt werden.

Die Grafikkonventionen von Windows betrachten die endgültigen x2- und y2-Koordinaten als exklusiv. Daher wird das letzte Pixel standardmäßig nicht gezeichnet, es sei denn, der Überlappungsmodus ist aktiviert. Weitere Informationen finden Sie unter GRAFIKSATZ-ÜBERLAPPUNG.

x1! , y1!

Optionale Werte, die den Startpunkt der Linie definieren. Wenn dieser optionale erste Punkt weggelassen wird, beginnt die Zeile am letzten referenzierten Punkt (POS) in einer vorhergehenden GRAPHIC-Anweisung. Wenn die erste STEP-Option enthalten ist, ist das x1! und y1! Die Startkoordinaten beziehen sich auf den letzten Referenzpunkt (POS).

x2! , y2!

Der Endpunkt der Linie. Wenn die zweite STEP-Option enthalten ist, ist das x2! und y2! Endkoordinaten sind relativ zu den Startkoordinaten.

rgbColor&

Optionaler RGB-Farbwert für die Linie. Wenn rgbColor& weggelassen wird (oder -1), wird als Linienfarbe standardmäßig die aktuelle Vordergrundfarbe verwendet.

Siehe auch

  • GRAFISCHER BOGEN
  • GRAFISCHE ANHÄNGE
  • GRAFIKBOX
  • GRAFISCHE FARBE
  • GRAFISCHE ELLIPSE
  • GRAFISCHER TORTEN
  • GRAFIKSATZ-ÜBERLAPPUNG
  • GRAFISCHER STIL
  • GRAFISCHE BREITE

PBXB64-Umsetzungshinweise

GRAFISCHE LINIE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHE LINIE ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHE LINIE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFISCHE ZEILENEINGABE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFISCHE ZEILENEINGABE

GRAFISCHE ZEILENEINGABE

Lesen Sie innerhalb von a eine ganze Zeile von der Tastatur

Typ:Anweisung |Kategorie:Datei-E/A

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC LINE INPUT [" prompt "] string_variable

Beschreibung

GRAPHIC LINE INPUT zeigt die optionale Eingabeaufforderung im Grafikfenster oder Control an und wartet auf Benutzereingaben. Tastenanschläge werden akzeptiert, bis Sie die EINGABETASTE drücken. Anschließend wird die gesamte eingegebene Zeichenfolge der Zeichenfolgenvariable zugewiesen. Die Eingabe ist auf 255 Zeichen begrenzt.

Siehe auch

  • GRAFIK-INKEY$
  • GRAFISCHE INPUT
  • GRAFISCHER EINGANG FLUSH
  • GRAFISCHE INSTAT
  • GRAFISCHER WAITKEY$

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

PBXB64-Umsetzungshinweise

GRAFISCHE ZEILENEINGABE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHE ZEILENEINGABE ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHE ZEILENEINGABE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC PAINT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIKFARBE

GRAFISCHE FARBE

Füllen Sie einen Bereich mit einem Volumenkörper

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC PAINT [BORDER | REPLACE] [STEP] ( x! , y! ) [, [ rgbFill& ] [, [ rgbBorder& ] [, [ fillstyle& ]]]]

Beschreibung

Die Koordinatenpunkte werden in Seiteneinheiten angegeben.

x! , y!

Der Punkt, an dem das Füllen beginnt. Wenn die STEP-Option enthalten ist, sind die X- und Y-Koordinaten relativ zum letzten referenzierten Punkt (POS) im ausgewählten Grafikziel.

rgbFill&

Optionaler RGB-Farbwert für den Füllbereich. Wenn rgbFill& weggelassen wird (oder -1), wird die Standard-Vordergrundfarbe verwendet.

rgbBorder&

Optionale RGB-Grundfarbe des Füllbereichs. Wenn die Option REPLACE gewählt wird, wird das Füllen nach außen in alle Richtungen fortgesetzt, bis eine andere Farbe als rgbBorder& gefunden wird. Wenn die Option BORDER (oder keine Option) enthalten ist, wird das Füllen nach außen fortgesetzt, bis die Farbe rgbBorder& gefunden wird. Wenn rgbBorder& nicht angegeben ist, wird davon ausgegangen, dass es mit dem Parameter rgbFill& übereinstimmt.

Füllstil&

Optionaler zu verwendender Füllstil (Muster). Wenn fillstyle& weggelassen wird, ist der Standardfüllstil „solid“ (0). Wenn ein Schraffurmuster ausgewählt wird (1 bis 6), wird die Vordergrundfarbe durch rgbFill& angegeben, während der Hintergrund durch die Standardhintergrundfarbe für das ausgewählte Grafikziel angegeben wird. Der optionale Füllstil& kann sein:

Fest (Standard)

Horizontale Linien

Vertikale Linien

Nach oben gerichtete diagonale Linien

Abwärts gerichtete diagonale Linien

Gekreuzte Linien

Diagonal gekreuzte Linien

Siehe auch

  • Built In RGB Color Equates
  • GRAFISCHER BOGEN
  • GRAFISCHE ANHÄNGE
  • GRAFIKBOX
  • GRAFISCHE FARBE
  • GRAFISCHE ELLIPSE
  • GRAFISCHE LINIE
  • GRAFISCHER TORTEN

PBXB64-Umsetzungshinweise

GRAFISCHE FARBE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHE FARBE ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHE FARBE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC PIE – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › GRAFISCHER PIE

GRAFISCHER TORTEN

Zeichnen Sie einen Kreisabschnitt auf die ausgewählte Fläche

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC PIE ( x1! , y1! ) - ( x2! , y2! ), arcStart! , arcEnd! [, [ rgbColor& ] [ , [fillcolor& ] [ , [ fillstyle& ]]]]

Beschreibung

Ein Kreisabschnitt ist ein Bogen, bei dem von jedem Endpunkt eine Linie zum Mittelpunkt des Kreises oder der Ellipse gezogen wird. Um einen Kreisabschnitt festzulegen, definieren Sie zunächst den vollständigen Kreis oder die Ellipse, zu der er gehört, und geben dann die Punkte auf der Ellipse an, an denen der Bogen beginnt und endet.

Der Vollkreis oder die Ellipse wird durch sein Begrenzungsrechteck definiert, das das kleinste Rechteck ist, das um den Kreis oder die Ellipse gezeichnet werden kann. Wenn der Kreis beispielsweise an der Position (400.400) zentriert ist und einen Radius von 100 Pixeln hat, ist die obere linke Ecke (x1,y1) des Begrenzungsrechtecks ​​(300.300) und die untere rechte Ecke (x2,y2) ist (500.500).

Der Startpunkt und der Endpunkt des Bogens werden durch ihren Winkel angegeben, der im Bogenmaß angegeben werden muss. Ein vollständiger Kreis oder eine vollständige Ellipse hat ein Bogenmaß von 2*pi. Auf einem 12-Stunden-Zifferblatt beziehen sich die Werte 0 und 2*pi beide auf die Position 3 Uhr, während sich der Wert 1*pi auf die Position 9 Uhr bezieht. Andere Positionen werden durch einen Bogenmaßwert relativ zu diesen angegeben. In PowerBASIC werden Bögen immer gegen den Uhrzeigersinn vom Startpunkt zum Endpunkt gezeichnet.

Vor allen grafischen Operationen muss zunächst das Grafikziel mit GRAPHIC ATTACH ausgewählt werden. Die Koordinaten werden in denselben Begriffen (Pixel oder Dialogeinheiten) wie der übergeordnete Dialog angegeben (oder Weltkoordinaten, wenn diese mit GRAPHIC SCALE ausgewählt wurden). Die Linienbreite kann mit GRAPHIC WIDTH eingestellt werden. Wenn die Linienbreite auf 1 eingestellt ist (Standardeinstellung), kann der Linienstil mit GRAPHIC STYLE festgelegt werden. Aufgrund der Art eines Kreisabschnitts verwendet GRAPHIC PIE weder grafisches POS (letzter Punkt, auf den verwiesen wird) noch aktualisiert es es.

x1! , y1!

Die obere linke Ecke des umschließenden Rechtecks des Vollkreises oder der Ellipse.

x2! , y2!

Die untere rechte Ecke des Begrenzungsrechtecks des Vollkreises oder der Ellipse.

ArcStart!

Der Anfangswinkel des Bogens im Bogenmaß von 0 bis 2*pi.

ArcEnd!

Der Endwinkel des Bogens im Bogenmaß von 0 bis 2*pi im Bogenmaß. Beachten Sie, dass Bögen von arcStart aus immer gegen den Uhrzeigersinn gezeichnet werden! zu arcEnd! . Im Vergleich zu einem 12-Stunden-Zifferblatt liegt 0 oder 2*pi im Bogenmaß bei 3 Uhr und 1*pi im Bogenmaß bei 9 Uhr.

rgbColor&

Optionale RGB-Farbe der Kreisabschnittskante. Wenn es weggelassen wird (oder -1), wird als Kantenfarbe standardmäßig die aktuelle Vordergrundfarbe verwendet.

Füllfarbe&

Optionale RGB-Farbe des Inneren des Tortenabschnitts. Wenn fillcolor& weggelassen wird (oder -2), wird das Innere des Kreisabschnitts nicht ausgefüllt, sodass der Hintergrund durchscheinen kann. Wenn fillcolor& -1 ist, wird der Innenraum mit der gleichen Farbe wie der Rand bemalt. Andernfalls gibt fillcolor& die zu verwendende RGB-Farbe an.

Füllstil&

Optionaler Füllstil (Muster), der verwendet werden soll. Wenn fillstyle& weggelassen wird, ist der Standardfüllstil „solid“ (0). Wenn ein Schraffurmuster ausgewählt wird (1 bis 6), wird die Vordergrundfarbe durch die Füllfarbe& angegeben, während der Hintergrund durch die Standardhintergrundfarbe angegeben wird. Der optionale Füllstil& kann sein:

Fest (Standard)

Horizontale Linien

Vertikale Linien

Nach oben gerichtete diagonale Linien

Abwärts gerichtete diagonale Linien

Gekreuzte Linien

Diagonal gekreuzte Linien

Siehe auch

  • Built In RGB Color Equates
  • GRAFISCHER BOGEN
  • GRAFISCHE ANHÄNGE
  • GRAFIKBOX
  • GRAFISCHE FARBE
  • GRAFISCHE ELLIPSE
  • GRAFISCHE LINIE
  • GRAFIKSATZ-ÜBERLAPPUNG
  • GRAFISCHER STIL
  • GRAFISCHE BREITE

PBXB64-Umsetzungshinweise

GRAFISCHER TORTEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHER TORTEN ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHER TORTEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFISCHES POLYGON – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFISCHES POLYGON

GRAFISCHES POLYGON

Zeichnen Sie ein Polygon im ausgewählten Bereich

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC POLYGON points [,[ rgbColor& ] [, [ fillcolor& ] [,[ fillstyle& ] [, fillmode& ]]]]

Beschreibung

Die Koordinaten werden in Seiteneinheiten angegeben. Die Linienbreite kann mit GRAPHIC WIDTH eingestellt werden. Wenn die Linienbreite auf 1 eingestellt ist (Standardeinstellung), kann der Linienstil mit GRAPHIC STYLE festgelegt werden. GRAPHIC POLYGON verwendet oder aktualisiert den letzten referenzierten Punkt ( POS ) weder.

Punkte

Benutzerdefinierter Typ, der die Anzahl der Scheitelpunkte und deren Position definiert. Es müssen mindestens zwei und nicht mehr als 1024 Scheitelpunkte vorhanden sein. Das erste Element ist eine lange Ganzzahl-Punktzahl, direkt gefolgt von der entsprechenden Anzahl von Gleitkommazahlen mit einfacher Genauigkeit, um die tatsächlichen Koordinaten anzugeben. Gleitkommakoordinaten sind erforderlich, da sie mit SCALE als Weltkoordinaten verwendet werden können. Sie können einen Typ mit einer Skalarliste wie folgt verwenden:

TYP PolyPoints

als lang zählen

x1 als Single

y1 als Single

x2 als Single

y2 als Single

x3 als Single

y3 als Single

END-TYP

Oder Sie können ein Array mithilfe von Punkttypen erstellen, etwa so:

TYP PolyPoint

x als Single

y als Single

END-TYP

TYP PolyArray

als lang zählen

xy(1 TO 3) als PolyPoint

END-TYP

rgbColor&

Optionale RGB-Farbe der Polygonkante. Wenn es weggelassen wird (oder -1), wird als Kantenfarbe standardmäßig die aktuelle Vordergrundfarbe verwendet.

Füllfarbe&

Optionale RGB-Farbe des Polygoninneren. Wenn fillcolor& weggelassen wird (oder -2), wird das Innere der Ellipse nicht ausgefüllt, sodass der Hintergrund durchscheinen kann. Wenn fillcolor& -1 ist, wird der Innenraum mit der gleichen Farbe wie der Rand bemalt. Andernfalls gibt fillcolor& die zu verwendende RGB-Farbe an.

Füllstil&

Optionaler Füllstil (Muster), der verwendet werden soll. Wenn fillstyle& weggelassen wird, ist der Standardfüllstil „solid“ (0). Wenn ein Schraffurmuster ausgewählt wird (1 bis 6), wird die Vordergrundfarbe durch die Füllfarbe& angegeben, während der Hintergrund durch die Standardhintergrundfarbe angegeben wird. Der optionale Füllstil& kann sein:

Fest (Standard)

Horizontale Linien

Vertikale Linien

Nach oben gerichtete diagonale Linien

Abwärts gerichtete diagonale Linien

Gekreuzte Linien

Diagonal gekreuzte Linien

Füllmodus&

Fehlt fillmode& (oder Null), wird der Wickelmodus ausgewählt. Dadurch wird jeder Bereich mit einem Wicklungswert ungleich Null gefüllt. Wenn fillmode& ungleich Null ist, wird der alternative Modus ausgewählt. Dadurch wird der Bereich zwischen ungeraden und geraden Polygonseiten auf jeder Scanlinie ausgefüllt. Das heißt, es füllt den Bereich zwischen der ersten Seite und der zweiten Seite, zwischen der dritten Seite und der vierten Seite usw. aus.

Siehe auch

  • Built In RGB Color Equates
  • GRAFISCHER BOGEN
  • GRAFISCHE ANHÄNGE
  • GRAFIKBOX
  • GRAFISCHE FARBE
  • GRAFISCHE ELLIPSE
  • GRAFISCHE LINIE
  • GRAFISCHE POLYLINIE
  • GRAFIKSATZ-ÜBERLAPPUNG
  • GRAFISCHER STIL
  • GRAFISCHE BREITE

PBXB64-Umsetzungshinweise

GRAFISCHES POLYGON gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHES POLYGON ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHES POLYGON mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFISCHE POLYLINIE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFISCHE POLYLINIE

GRAFISCHE POLYLINIE

Zeichnen Sie eine Reihe verbundener Liniensegmente.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC POLYLINE points [, rgbColor& ]

Beschreibung

Die Koordinaten werden in Seiteneinheiten angegeben. Die Linienbreite kann mit GRAPHIC WIDTH eingestellt werden. Wenn die Linienbreite auf 1 eingestellt ist (Standardeinstellung), kann der Linienstil mit GRAPHIC STYLE festgelegt werden. GRAPHIC POLYLINE verwendet oder aktualisiert den letzten referenzierten Punkt ( POS ) weder.

Die Grafikkonventionen von Windows betrachten die endgültigen X- und Y-Koordinaten als exklusiv. Daher wird das letzte Pixel standardmäßig nicht gezeichnet, es sei denn, der Überlappungsmodus ist aktiviert. Weitere Informationen finden Sie unter GRAFIKSATZ-ÜBERLAPPUNG.

Punkte

Benutzerdefinierter Typ, der die Anzahl der Scheitelpunkte und deren Position definiert. Es müssen mindestens zwei und nicht mehr als 1024 Scheitelpunkte vorhanden sein. Das erste Element ist eine lange Ganzzahl-Punktzahl, direkt gefolgt von der entsprechenden Anzahl von Gleitkommazahlen mit einfacher Genauigkeit, um die tatsächlichen Koordinaten anzugeben. Gleitkommakoordinaten sind erforderlich, da sie mit SCALE als Weltkoordinaten verwendet werden können. Sie können einen Typ mit einer Skalarliste wie folgt verwenden:

TYP PolyPoints

als lang zählen

x1 als Single

y1 als Single

x2 als Single

y2 als Single

x3 als Single

y3 als Single

END-TYP

Oder Sie können ein Array mithilfe von Punkttypen erstellen, etwa so:

TYP PolyPoint

x als Single

y als Single

END-TYP

TYP PolyArray

als lang zählen

xy(1 TO 3) als PolyPoint

END-TYP

rgbColor&

Optionale RGB-Farbe der Polylinie. Wenn es weggelassen wird (oder -1), wird als Farbe standardmäßig die aktuelle Vordergrundfarbe verwendet.

Siehe auch

  • Built In RGB Color Equates
  • GRAFISCHER BOGEN
  • GRAFISCHE ANHÄNGE
  • GRAFIKBOX
  • GRAFISCHE FARBE
  • GRAFISCHE ELLIPSE
  • GRAFISCHE LINIE
  • GRAFISCHES POLYGON
  • GRAFIKSATZ-ÜBERLAPPUNG
  • GRAFISCHER STIL
  • GRAFISCHE BREITE

PBXB64-Umsetzungshinweise

GRAFISCHE POLYLINIE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHE POLYLINIE ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHE POLYLINIE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIKDRUCK – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIKDRUCK

GRAFIKDRUCK

Geben Sie Text an die ausgewählte Stelle aus

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC PRINT [EXPRLIST] [POS( n )] [SPC( n )] [TAB( n )] [,] [;]...

Beschreibung

Bevor grafische Vorgänge ausgeführt werden, sollten Sie sicherstellen, dass ein Grafikziel ausgewählt wurde, entweder standardmäßig oder mit GRAPHIC ATTACH . Die Textfarbe und die Texthintergrundfarbe werden mit GRAPHIC COLOR eingestellt. Text, der über die Grenzen des Grafikziels hinausgeht, wird abgeschnitten. Mit GRAPHIC TEXT SIZE kann die Größe des zu druckenden Textes vorab bestimmt und mit GRAPHIC SPLIT feldgerecht formatiert werden. Das Zeichnen beginnt am letzten Punkt, auf den durch eine andere GRAPHIC-Prozedur verwiesen wird, oder an dem durch GRAPHIC SET POS angegebenen Punkt. Die obere linke Ecke des Textes wird am POS positioniert.

GRAPHIC PRINT besteht aus den folgenden Teilen, die in beliebiger Reihenfolge und Menge in einer einzigen Anweisung vorkommen können:

EXPRLISTE

Numerische und/oder Zeichenfolgenausdrücke, die in das Grafikziel geschrieben werden sollen. Ein Semikolon kann als Trennzeichen zwischen mehreren Ausdrücken in derselben Anweisung verwendet werden. Nach Abschluss wird der POS an den linken Rand der nächsten Zeile verschoben.

POS(n)

Eine optionale Funktion, die verwendet wird, um den POS auf die horizontale Seiteneinheit (Pixel, Dialogeinheit, skalierte Einheit usw.) festzulegen, die durch das numerische Argument angegeben wird. Mehrere Verwendungen der POS-Funktion sind in einer einzigen Anweisung zulässig. Die vertikale Position des POS wird nie verändert.

SPC( n )

Eine optionale Funktion zum Einfügen von n Leerzeichen in die gedruckte Ausgabe. Die mehrfache Verwendung von SPC in einer einzigen Anweisung ist zulässig. Werte von n kleiner als 1 werden ignoriert.

TAB( n )

Eine optionale Funktion, die verwendet wird, um mit der Tabulatortaste zur n-ten Spalte zu wechseln, bevor der nächste Ausdruck gedruckt wird. Die mehrfache Verwendung von TAB in einer einzigen Anweisung ist zulässig. Da TAB auf Spalten und nicht auf Pixel verweist, kann es bei Verwendung mit einer Schriftart mit variabler Breite zu unvorhersehbaren Ergebnissen führen. Es wird am besten mit einer Schriftart mit fester Breite verwendet.

Sonderzeichen, die die Position des nächsten gedruckten Textelements bestimmen. Ein Semikolon (;) bedeutet, dass das nächste Textelement sofort gedruckt wird; Ein Komma (,) bedeutet, dass das nächste Textelement am Anfang der nächsten Druckzone gedruckt wird. Druckzonen beginnen alle 14 Spalten.

Wenn das letzte Argument ein Semikolon oder Komma ist, wird die Position an der aktuellen Position beibehalten und nicht standardmäßig an den Anfang der nächsten Zeile verschoben. Zum Beispiel:

GRAFIKDRUCK „Hallo“;

GRAFIKDRUCK „Welt!“;

...erzeugt das zusammenhängende Ergebnis „Hallo Welt!“

Wenn Sie alle Argumente weglassen, verschiebt GRAPHIC PRINT die Position einfach an den linken Rand der nächsten Zeile. Steuercodes wie Wagenrücklauf, Zeilenvorschub und Rücktaste werden nicht interpretiert. Sie werden als Symbole in der aktuell ausgewählten Schriftart angezeigt.

USING$ ist eine separate Funktion, die in die ExprList aufgenommen werden kann. Weitere Informationen finden Sie in der Funktion USING$().

Es ist nicht möglich, einen benutzerdefinierten Typ (UDT), eine Variante, eine Objektvariable oder ein ganzes Array zu drucken. Einzelne Elementwerte müssen mit der entsprechenden Funktion extrahiert werden, bevor sie angezeigt werden können.

Siehe auch

  • GRAFISCHE ANHÄNGE
  • GRAFISCHE ZELLE
  • GRAFISCHE CHR-GRÖSSE
  • GRAFIK-SET-SCHRIFTART
  • GRAFIK GET POS
  • GRAFIK SET POS
  • GRAFIK SET SCROLLTEXT
  • GRAFIK-SET WORDWRAP
  • GRAFIK-SET-WICKEL
  • GRAFISCHE SPLIT
  • GRAFISCHE TEXTGRÖSSE
  • USING$

PBXB64-Umsetzungshinweise

GRAFIKDRUCK gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIKDRUCK ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIKDRUCK mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFISCHES NEUZEICHNEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFISCHES NEUZEICHNEN

GRAFISCHES NEUZEICHNEN

Aktualisieren Sie gepufferte grafische Anweisungen und zeichnen Sie sie auf die ausgewählten

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC REDRAW

Beschreibung

Diese Anweisung ist nur erforderlich, wenn GRAPHIC ATTACH mit der Option REDRAW für schnellere, gepufferte Zeichenvorgänge ausgewählt wurde. Andernfalls wird keine Operation ausgeführt.

Alle grafischen Anzeigen von PowerBASIC sind dauerhaft – sie werden automatisch für Sie neu gezeichnet, nachdem sie minimiert oder vorübergehend von anderen Fenstern verdeckt werden.

Bei intensiven Zeichenvorgängen ist es vorzuziehen, die Anzeige zu verzögern, bis eine Reihe von Anweisungen ausgeführt wurden, indem die REDRAW-Option mit der GRAPHIC ATTACH-Anweisung und der GRAPHIC REDRAW-Anweisung verwendet wird. Dies kann die Gesamtleistung erheblich verbessern.

Siehe auch

  • GRAFISCHE ANHÄNGE

PBXB64-Umsetzungshinweise

GRAFISCHES NEUZEICHNEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHES NEUZEICHNEN ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHES NEUZEICHNEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFISCHES RENDER – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFISCHES RENDER

GRAFISCHES Rendering

Rendern Sie ein Bild auf der ausgewählten Seite

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC RENDER [BITMAP | ICON] ImgName , ( x1! , y1! )-( x2! , y2! )

Beschreibung

Rendert ein Bild (Bitmap oder Symbol), das von einer Ressource oder einer Festplattendatei geladen wird, auf dem ausgewählten Grafikziel. Das optionale Director-Wort gibt an, ob es sich bei der Quelle um eine Bitmap oder ein Symbol handelt. Wenn nicht angegeben, ist Bitmap die Standardeinstellung.

Der Parameter ImgName gibt den Namen des Bildes an. Wenn ImgName eine numerische Ressourcen-ID ist, kann sie als numerischer Ausdruck oder als Zeichenfolgenäquivalent mit einem führenden Nummernzeichen (z. B. „#10023“) angegeben werden. Andernfalls wird die String-Ressourcen-ID oder der Dateiname als String-Ausdruck angegeben. Wenn der Zeichenfolgenname einen Punkt enthält, handelt es sich vermutlich um den Namen einer Festplattendatei. Andernfalls wird versucht, es als Ressource zu laden; Wenn sie nicht gefunden wird, handelt es sich vermutlich um eine Festplattendatei.

Die Parameter x1! , y1! Definieren Sie die obere linke Ecke des Zielrechtecks, während x2! , y2! Definieren Sie die untere rechte Ecke dieses Rechtecks. Wenn das Zielrechteck größer oder kleiner als das Original ist, wird das Bild auf die gewünschte Größe gestreckt oder gestaucht.

Der folgende Code ruft die natürliche Größe eines Bildes in einer Bitmap-Datei in Pixel ab:

nFile& = FREEFILE

OPEN Sie „myimage.bmp“ FOR BINARY AS nFile&

GET #nFile&, 19, nWidth&

GET #nFile&, 23, nHeight&

SCHLIEßEN nDatei&

Siehe auch

  • GRAFISCHE KOPIE
  • GRAFIK GET STRETCHMODE
  • GRAFISCHE BILDLISTE
  • GRAFIK SET STRETCHMODE
  • GRAFISCHER STRETCH

PBXB64-Umsetzungshinweise

GRAFISCHES Rendering gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHES Rendering ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHES Rendering mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIK SPEICHERN – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › GRAFIK SPEICHERN

GRAFIK SPEICHERN

Speichern Sie ein Bild in einer Bitmap-Datei (.BMP).

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SAVE BmpName$

Beschreibung

Das ausgewählte Grafikziel (eine grafische Bitmap, ein Steuerelement oder ein Fenster usw.) wird unter dem durch BmpName$ angegebenen Dateinamen in einer Festplattendatei gespeichert. Die Bitmap wird immer in einem 24-Bit-Format mit einer einzigen Ebene gespeichert, um die maximale (Echtfarben-)Auflösung zu ermöglichen.

Siehe auch

  • STEUERUNG GRAFIK HINZUFÜGEN
  • GRAFISCHE ANHÄNGE
  • GRAFISCHES BITMAP-LADEN
  • GRAFISCHE BITMAP NEU

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

PBXB64-Umsetzungshinweise

GRAFIK SPEICHERN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK SPEICHERN ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK SPEICHERN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFISCHE MAßSTAB - PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFISCHE MAßSTAB

GRAFISCHE MAßSTAB

Definieren Sie ein benutzerdefiniertes Koordinatensystem für

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SCALE ( x1! , y1! ) - ( x2! , y2! )
GRAPHIC SCALE PIXELS

Beschreibung

Das Grafikziel muss zunächst mit GRAPHIC ATTACH ausgewählt werden. Mit GRAPHIC SCALE können Sie Ihr eigenes Weltkoordinatensystem für nachfolgende GRAPHIC-Anweisungen definieren. Die benutzerdefinierten Koordinaten bleiben beim grafischen Ziel, bis GRAPHIC SCALE wiederholt wird oder das Ziel gelöscht wird. Weltkoordinaten können Gleitkommawerte sein, mit der einzigen Anforderung, dass x1! ungleich x2! und y1! ungleich y2!. Wenn einer von beiden gleich ist, wird die Anweisung ignoriert.

Wenn x2! ist größer als x1! , Koordinaten werden größer, wenn sie sich nach rechts bewegen. Andernfalls werden sie größer, wenn sie sich nach links bewegen.

Wenn y2! ist größer als y1! , Koordinaten werden größer, wenn sie sich nach unten bewegen. Andernfalls werden sie mit zunehmender Höhe größer.

Standardmäßig ist die Position x2!/y2! wird auf das erste Pixel übertragen, das außerhalb des Clientbereichs liegt und daher nicht gezeichnet wird. Wenn jedoch der OVERLAP MODE durch GRAPHIC SET OVERLAP aktiviert ist, ist x2!/y2! wird auf das letzte Pixel im Clientbereich übersetzt und gezeichnet.

GRAPHIC SCALE PIXELS setzt das Koordinatensystem auf Pixelkoordinaten oder setzt es zurück. Dies kann besonders nützlich sein, wenn die Originalkoordinaten in Dialogeinheiten vorliegen, da dies eine höhere Auflösung für andere Grafikfunktionen bietet.

Hinweis: GRAPHIC SCALE funktioniert nicht mit negativen numerischen Werten – alle numerischen Argumente müssen positiv sein.

Siehe auch

  • GRAFISCHE ANHÄNGE
  • GRAFISCHE ZELLE
  • GRAFISCHE ZELLENGRÖSSE
  • GRAFIK ERHALTEN MAßSTAB
  • GRAFIKSATZ-ÜBERLAPPUNG

PBXB64-Umsetzungshinweise

GRAFISCHE MAßSTAB gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHE MAßSTAB ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHE MAßSTAB mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC SET AUTOSIZE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK SET AUTOSIZE

GRAFIK AUTOGRÖSSE EINSTELLEN

Vergrößert die virtuelle Zeichenfläche eines angehängten Grafikziels.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SET AUTOSIZE nWidth , nHeight [,USERSIZE]

Beschreibung

Im AUTOSIZE-Modus kann das angehängte Grafikziel (Steuerelement oder Fenster) den Inhalt eines virtuellen Fensters anzeigen, das größer oder kleiner sein kann. Der gesamte Inhalt des virtuellen Fensters wird immer auf dem Bildschirm angezeigt, sodass das Bild entsprechend gestreckt oder gestaucht wird. Die physikalische Größe des Anzeigebereichs wird nicht verändert. Wenn das Grafikziel eine Bitmap ist, wird keine Operation ausgeführt, da kein Anzeigebereich vorhanden ist.

Diese Anweisung kann verwendet werden, um ein Ziel in den AUTOSIZE-Modus zu ändern oder um die Größen und die UserSize-Option eines vorhandenen AUTOSIZE-Ziels zu ändern.

Bei der Ausführung wird eine neue virtuelle Bitmap mit der angegebenen Höhe und Breite erstellt. nWidth und nHeight werden immer in Pixeln oder Dialogeinheiten angegeben, abhängig von der ursprünglichen Fenstererstellung. Die neue virtuelle Bitmap wird sofort mit der ursprünglichen Bitmap gefüllt, jedoch entsprechend gestreckt oder komprimiert. Dies geschieht, um Blitzeffekte zu vermeiden, die manchmal bei einem kurzen Farbwechsel auftreten. Ihr Programm kann nun wie gewohnt auf die neue Bitmap zeichnen, um eine Bitmap der neuen Größe zu erhalten.

Wenn ein Clip-Bereich zum Erstellen von Rändern eingerichtet wurde, wird dieser zurückgesetzt. Wenn skalierte Koordinaten festgelegt wurden, werden diese ebenfalls zurückgesetzt, da keine der beiden für die geänderte Größe angemessen wäre. Sie können diese Attribute mit GRAPHIC SCALE oder GRAPHIC SET CLIP wieder aktivieren, basierend auf der neuen Größe des Zeichenbereichs. Die Größe der virtuellen Zeichenfläche können Sie jederzeit mit GRAPHIC GET CANVAS abrufen.

Der AUTOSIZE-Modus ist dem VIRTUAL-Modus ziemlich ähnlich. Beide erstellen ein virtuelles Fenster, das das Ziel Ihrer Zeichen- und Textdruckvorgänge ist. Der Unterschied liegt in der Art und Weise, wie sie angezeigt werden. VIRTUAL zeigt ein Ansichtsfenster an, das kleiner als das virtuelle Fenster ist und an verschiedene Positionen verschoben werden kann. Dadurch kann der Benutzer jeweils einen ausgewählten Abschnitt anzeigen. AUTOSIZE zeigt jederzeit das gesamte virtuelle Fenster an, indem es es je nach Bedarf dehnt oder komprimiert.

Die Option USERSIZE wird aus Kompatibilitaetsgruenden akzeptiert, aber der aktuelle Laufzeitpfad vergroessert nur die Hintergrund-Zeichenflaeche und streckt den vorhandenen Inhalt auf die neue Groesse. Separate Rahmen-UI wird vom Compiler-Laufzeitpfad nicht erzeugt.

Pruefnachweis: Geprueft durch tests/pb/test_graphic_set_autosize.pb in der pb_linkrun-Lane. Die Regression belegt Canvas-Groesse und gestreckte Pixelposition in einem echten Grafikfenster.

Siehe auch

  • GRAFIK ERHALTEN SIE LEINWAND
  • GRAFISCHE MAßSTAB
  • GRAFIK-SET-CLIP
  • GRAFIKSATZ BEHOBEN
  • VIRTUELLES GRAFIKSET

PBXB64-Umsetzungshinweise

GRAFIK AUTOGRÖSSE EINSTELLEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK AUTOGRÖSSE EINSTELLEN ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK AUTOGRÖSSE EINSTELLEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIK-SET-BITS – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK SETZEN VON BITS

GRAFIK-SET-BITS

Ersetzen Sie eine Kopie einer Bitmap, die als geräteunabhängige Bitmap abgerufen wurde.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SET BITS bitexpr$

Beschreibung

Diese Anweisung ersetzt eine Bitmap, die ursprünglich mit der GRAPHIC GET BITS-Anweisung abgerufen wurde. Die Bitmap wird dem ausgewählten Grafikziel aus dem durch bitexpr$ angegebenen Zeichenfolgenausdruck zugewiesen. Dadurch können Sie sehr schnell viele Änderungen an der Bitmap vornehmen, insbesondere Vorgänge, die möglicherweise nicht direkt von PowerBASIC unterstützt werden. Eine typische Verwendung könnte beispielsweise darin bestehen, alle roten Pixel in einer Bitmap in blaue zu ändern.

Die Zeichenfolge bitexpr$ enthält eine Reihe von Vier-Byte-Werten, von denen jeder eine lange Ganzzahl darstellt. Sie können die Vier-Byte-String-Abschnitte mit der CVL-Funktion in numerische Werte konvertieren und mit MKL$ einen numerischen Wert in eine Vier-Byte-String konvertieren. Der erste Vier-Byte-Wert gibt die Breite der Bitmap in Pixel an, der zweite Wert gibt die Höhe an. Darauf folgt ein Vier-Byte-Wert für jedes Pixel in der Bitmap, der die Farbe dieses Pixels darstellt. Eine 20 x 20 Bitmap hätte also 400 Pixel und erfordert 1600 Bytes (400 * 4), plus 4 Bytes für die Breite und 4 Bytes für die Höhe, also insgesamt 1608 Bytes.

Der erste Vier-Byte-Pixelwert in der Zeichenfolge stellt die obere linke Ecke des Bildes dar, der zweite stellt das zweite Pixel der ersten Zeile dar und so weiter. Nach dem letzten Pixel der ersten Zeile folgt das erste Pixel der zweiten Zeile usw.

Wenn die Ausführungsgeschwindigkeit am wichtigsten ist, lässt sich die Zeichenfolge wahrscheinlich am effizientesten mit Zeigervariablen manipulieren.

Einige Windows-API-Funktionen, insbesondere solche, die auf geräteunabhängige Bitmaps (DIB) verweisen, erfordern, dass Farben in umgekehrter Reihenfolge der normalen RGB-Reihenfolge angegeben werden (Blau-Grün-Rot statt Rot-Grün-Blau). Um die Leistung zu maximieren, verwendet GRAPHIC SET BITS auch das BGR-Format. Sie können die BGR-Funktion verwenden, um einen RGB-Wert in sein BGR-Äquivalent zu übersetzen.

Siehe auch

  • Built In RGB Color Equates
  • BGR
  • CVL
  • GRAFIK ERHALTEN BITS
  • MKL$
  • RGB

PBXB64-Umsetzungshinweise

GRAFIK-SET-BITS gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK-SET-BITS ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK-SET-BITS mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIK-SET-BESCHRIFTUNG – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK-SET-UNTERSCHRIFT

Bildunterschrift für das Grafikset

Ändern Sie die Beschriftung auf a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SET CAPTION CaptionExpr$

Beschreibung

Wenn das ausgewählte Grafikziel über eine Titelleiste verfügt, wird die Beschriftung in den Inhalt des Zeichenfolgenausdrucks geändert.

Siehe auch

  • GRAFISCHES FENSTER

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

PBXB64-Umsetzungshinweise

Bildunterschrift für das Grafikset gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

Bildunterschrift für das Grafikset ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' Bildunterschrift für das Grafikset mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC SET CLIENT - PBXB64 Compiler-Hilfe

Startseite › Funktionen › GRAPHIC SET CLIENT

GRAFIK-SET-CLIENT

Ändern Sie die Größe von a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SET CLIENT nWide& , nHigh&

Beschreibung

Abhängig von der Art der verwendeten Rahmen kann die Clientgröße kleiner als die Gesamtgröße sein. Der Client-Bereich ist der Teil innerhalb der Ränder, der je nach Stil und Ex-Stil bei der Erstellung variiert. Die Gesamtgröße umfasst die Ränder. Ein grafisches Ziel mit Rand hat normalerweise eine größere Gesamtgröße als eines ohne Rand.

Ab dieser Version von PowerBASIC kann die Größe von GRAFIKSTEUERN mit CONTROL SET CLIENT, GRAPHIC SET CLIENT, CONTROL SET SIZE und GRAPHIC SET SIZE geändert werden.

Die ursprüngliche Bitmap wird Pixel für Pixel in das neu verkleinerte Grafiksteuerelement oder Fenster kopiert. Jeder erweiterte Bereich wird mit der aktuellen Hintergrundfarbe gefüllt. Ihr Programm greift auf normale Weise darauf zurück, um eine Bitmap in der neuen Größe zu erstellen.

Wenn ein Clip-Bereich zum Erstellen von Rändern eingerichtet wurde, wird dieser zurückgesetzt. Wenn skalierte Koordinaten festgelegt wurden, werden diese ebenfalls zurückgesetzt, da keine der beiden für die geänderte Größe angemessen wäre. Sie können diese Attribute mit GRAPHIC SCALE oder GRAPHIC SET CLIP wieder aktivieren, basierend auf der neuen Größe des Zeichenbereichs.

Siehe auch

  • KONTROLLE KUNDEN ERHALTEN
  • KONTROLLE ERHALTEN SIE GRÖSSE
  • CONTROL SET-CLIENT
  • CONTROL SET-GRÖSSE
  • GRAFIK ERHALTEN SIE LEINWAND
  • GRAFIK GET CLIENT
  • GRAFIK GRÖSSE ERHALTEN
  • GRAFIK-SET-CLIP
  • GRAFIK-SET-GRÖSSE

PBXB64-Umsetzungshinweise

GRAFIK-SET-CLIENT gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK-SET-CLIENT ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK-SET-CLIENT mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIK-SET-CLIP – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK SET CLIP

GRAFIK-SET-CLIP

Legt Ränder um die Außenkanten der Grafik fest

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SET CLIP LeftMargin! , TopMargin! , RightMargin! , BottomMargin!

Beschreibung

Diese Anweisung legt Ränder auf einer oder allen Seiten des Grafikziels fest. Alle nachfolgenden GRAFIK-Operationen werden an diesen Grenzen „beschnitten“, sodass in diesen geschützten Bereichen kein zusätzlicher Text oder Grafiken angezeigt werden. Die Ränder werden jedoch nicht gelöscht, sodass alles, was bereits in diesen Bereichen geschrieben wurde, unverändert bleibt.

Jeder der 4 Parameter wird in den aktuell gültigen PAGE UNITS angegeben. Da diese Anweisung jedoch den für Sie verfügbaren Zielraum ändert, werden die Seiteneinheiten sofort auf Pixel gesetzt. Die obere linke Ecke des Clip-Bereichs wird nun als Punkt (0,0) angesprochen, während die rechte und untere Grenze um die Größe der Ränder reduziert werden. Wenn Sie für diesen überarbeiteten Clipbereich lieber skalierte Seiteneinheiten verwenden möchten, müssen Sie eine neue GRAFIKSKALIERUNG ausführen.

GRAPHIC SET CLIP ist besonders nützlich für die Anzeige von Text, wo das Einschließen von „Leerzeichen“ das Erscheinungsbild deutlich verbessert.

Sie können einen Clip-Bereich deaktivieren, indem Sie GRAPHIC SET CLIP 0,0,0,0 ausführen.

Siehe auch

  • GRAFIK-CLIP ERHALTEN
  • GRAFISCHE MAßSTAB

PBXB64-Umsetzungshinweise

GRAFIK-SET-CLIP gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK-SET-CLIP ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK-SET-CLIP mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIKSATZ BEHOBEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK-SET FEST

GRAFIKSATZ BEHOBEN

Stellt eine Grafik wieder her

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SET FIXED

Beschreibung

Das angehängte Grafikziel (Steuerelement oder Fenster) wird auf den standardmäßigen FIXED-Modus zurückgesetzt. Der Zeichenbereich wird auf die physikalische Größe des Anzeigebereichs eingestellt, die nicht verändert wird.

Bei der Ausführung wird davon ausgegangen, dass das Grafiksubsystem auf den AUTOSIZE- oder VIRTUAL-Modus eingestellt ist. Wenn nicht, wird keine Operation ausgeführt. Eine neue Bitmap der Clientbereichsgröße wird erstellt. Die ursprüngliche Bitmap wird Pixel für Pixel in der vorhandenen Größe kopiert. Jeder erweiterte Bereich wird mit der aktuellen Hintergrundfarbe gefüllt. Ihr Programm greift auf normale Weise darauf zurück, um eine Bitmap in der neuen Größe zu erstellen.

Wenn ein Clip-Bereich zum Erstellen von Rändern eingerichtet wurde, wird dieser zurückgesetzt. Wenn skalierte Koordinaten festgelegt wurden, werden diese ebenfalls zurückgesetzt, da keine der beiden für die geänderte Größe angemessen wäre. Sie können diese Attribute mit GRAPHIC SCALE oder GRAPHIC SET CLIP wieder aktivieren, basierend auf der neuen Größe des Zeichenbereichs. Die Größe der Zeichenfläche können Sie mit GRAPHIC GET CANVAS oder GRAPHIC GET CLIENT ermitteln.

Validation evidence: Verifiziert durch tests/pb/test_graphic_mode_states.pb in der pb_linkrun-Lane. Die Regression prueft das Zuruecksetzen der festen Groesse, der Canvas-Groesse und des Viewports an einem echten Grafikfenster.

Siehe auch

  • GRAFIK ERHALTEN SIE LEINWAND
  • GRAFIK GET CLIENT
  • GRAFISCHE MAßSTAB
  • GRAFIK AUTOGRÖSSE EINSTELLEN
  • VIRTUELLES GRAFIKSET

PBXB64-Umsetzungshinweise

GRAFIKSATZ BEHOBEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIKSATZ BEHOBEN ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIKSATZ BEHOBEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIK-SET-FOKUS – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK FOKUS SETZEN

GRAFIK SET FOKUS

Bringen Sie das Auserwählte mit

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SET FOCUS

Beschreibung

Zunächst muss mit GRAPHIC ATTACH ein Grafikfenster ausgewählt werden. Die GRAPHIC SET FOCUS-Anweisung bringt das Grafikfenster in den Vordergrund und lenkt den Fokus darauf. Dies ist besonders nützlich, wenn ein anderes Fenster das Grafikfenster überlappen könnte.

Siehe auch

  • GRAFISCHE ANHÄNGE
  • GRAFISCHES FENSTER

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

PBXB64-Umsetzungshinweise

GRAFIK SET FOKUS gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK SET FOKUS ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK SET FOKUS mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIK-SET-SCHRIFTART – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK SCHRIFTART EINSTELLEN

GRAFIK-SET-SCHRIFTART

Wählen Sie eine Schriftart zur Verwendung in der Grafik aus

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SET FONT fonthndl&

Beschreibung

Die durch fonthndl& angegebene Schriftart wird für die Verwendung durch alle folgenden Anweisungen GRAPHIC PRINT , GRAPHIC INPUT und GRAPHIC LINE INPUT ausgewählt. Dies ist die effizienteste Möglichkeit, Schriftarten und deren allgemeines Erscheinungsbild (Größe, Stil usw.) zu ändern. Wenn Sie für „fonthndl&“ den Wert Null angeben, wird die Schriftart wieder auf die ursprüngliche, von PowerBASIC gewählte Standardschriftart zurückgesetzt.

Sie können nahezu beliebig viele Schriftarten und Attribute vordefinieren, indem Sie für jede Schriftart FONT NEW-Anweisungen ausführen. Dadurch sind sie sofort einsatzbereit, wenn sie mit GRAPHIC SET FONT ausgewählt werden.

Wenn keine bestimmte Schriftart ausgewählt ist, ist die Standardschriftart MS Sans Serif, 8 Punkt, ohne Stilattribute.

Einschränkungen

GRAPHIC SET FONT ersetzt GRAPHIC FONT. Beachten Sie, dass die GRAPHIC FONT-Anweisung nicht mehr unterstützt wird. Aktualisieren Sie daher Ihren Code, um die neue Syntax zu verwenden.

Siehe auch

  • SCHRIFTART NEU
  • GRAFISCHE ANHÄNGE
  • GRAFISCHE ZELLE
  • GRAFISCHE ZELLENGRÖSSE
  • GRAFISCHE CHR-GRÖSSE
  • GRAFISCHE INPUT
  • GRAFISCHE ZEILENEINGABE
  • GRAFIKDRUCK
  • GRAFISCHE TEXTGRÖSSE

PBXB64-Umsetzungshinweise

GRAFIK-SET-SCHRIFTART gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK-SET-SCHRIFTART ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK-SET-SCHRIFTART mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC SET LOC – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK SET LOC

GRAFIK SET LOC

Ändern Sie den Speicherort der ausgewählten

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SET LOC x& , y&

Beschreibung

Diese Anweisung ändert die Position des ausgewählten Grafikfensters. Wenn kein Grafikziel ausgewählt ist oder es sich nicht um ein Grafikfenster handelt, wird keine Aktion ausgeführt. Die Position wird immer in Pixel relativ zur oberen linken Ecke des Bildschirms angegeben.

Siehe auch

  • GRAFISCHE ANHÄNGE
  • GRAFIK GET LOC
  • GRAFIK ERHALTEN PPI

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

PBXB64-Umsetzungshinweise

GRAFIK SET LOC gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK SET LOC ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK SET LOC mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIK-SET-MIX – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK-SET-MIX

GRAFISCHER SET-MIX

Legen Sie den Farbmischungsmodus für die ausgewählten fest

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SET MIX mode&

Beschreibung

Es stehen 16 Mischmodi zur Verfügung, mit denen Sie die Zeichenfarbe mit der Farbe mischen können, die bereits am Zeichenort vorhanden ist. Die Mix-Modus-Equates sind in PowerBASIC vordefiniert.

%mix_Blackness

Pixel ist immer 0 (schwarz).

%mix_NotMergeSrc

Pixel ist die Umkehrung der MergeSrc-Farbe.

%mix_MaskNotSrc

Pixel ist eine Kombination der Farben, die sowohl dem Pixel als auch der Umkehrung der Quelle gemeinsam sind.

%mix_NotCopySrc

Pixel ist die Umkehrung der Stiftfarbe.

%mix_MaskSrcNot

Pixel ist eine Kombination der Farben, die sowohl der Quelle als auch der Umkehrung des Pixels gemeinsam sind.

%mix_Not

Pixel ist die Umkehrung der Pixelfarbe.

%mix_XorSrc

Pixel ist eine Kombination der Farben in der Quelle und im Pixel, jedoch nicht in beiden.

%mix_NotMaskSrc

Pixel ist die Umkehrung der MaskSrc-Farbe.

%mix_MaskSrc

Pixel ist eine Kombination der Farben, die sowohl der Quelle als auch dem Pixel gemeinsam sind.

%mix_NotXorSrc

Pixel ist die Umkehrung der XorSrc-Farbe.

%mix_Nop

Pixel bleibt unverändert.

%mix_MergeNotSrc

Pixel ist eine Kombination aus der Quellfarbe und der Umkehrung der Pixelfarbe.

%mix_CopySrc

Pixel ist die Quellfarbe (Standard).

%mix_MergeSrcNot

Pixel ist eine Kombination aus der Quellfarbe und der Umkehrung der Pixelfarbe.

%mix_MergeSrc

Pixel ist eine Kombination aus der Quellfarbe und der Pixelfarbe.

%mix_Whiteness

Pixel ist immer 1 (weiß).

Siehe auch

  • GRAFISCHE ANHÄNGE
  • GRAFIK ERHALTEN MIX

PBXB64-Umsetzungshinweise

GRAFISCHER SET-MIX gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHER SET-MIX ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHER SET-MIX mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIKSATZ-ÜBERLAPPUNG – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK-SET-ÜBERLAPPUNG

GRAFIKSATZ-ÜBERLAPPUNG

Aktiviert oder deaktiviert den Grafiküberlappungsmodus.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SET OVERLAP [ NumrExpr& ]

Beschreibung

GRAPHIC SET OVERLAP aktiviert oder deaktiviert den Überlappungsmodus für das Grafikziel, das derzeit an den Grafikstream angehängt ist. Es hat keine Auswirkung auf andere Grafikziele. Wenn NumrExpr& wahr ist (ungleich Null), ist der Überlappungsmodus aktiviert. Bei „false“ (Null) ist der Überlappungsmodus deaktiviert. Wenn NumrExpr& fehlt, ist der Überlappungsmodus standardmäßig aktiviert.

Mit dem Überlappungsmodus steuern Sie, wie PowerBASIC Grafikoperationen behandelt, deren Definition eine RECT-Struktur beinhaltet. Windows-Grafikkonventionen betrachten die unteren und rechten Koordinaten eines RECT als exklusiv. Mit anderen Worten: Die Pixel am unteren und rechten Rand liegen unmittelbar außerhalb des Rechtecks. Sie werden nicht gezeichnet, sondern ignoriert. Zum Beispiel:

GRAFIKBOX (0,0) - (50,50)

In diesem Fall wird ein Kästchen von 0,0 bis 49,49 gezeichnet. Die letzten Pixel am unteren und rechten Rand werden einfach nicht gezeichnet. Wenn jedoch der Überlappungsmodus mit GRAPHIC SET OVERLAP aktiviert ist, wird das Feld von 0,0 bis 50,50 gezeichnet.

Der Überlappungsmodus wirkt sich auf Zeichenvorgänge mit GRAFISCHER MAßSTAB, GRAFISCHER KASTEN, GRAFISCHER ELLIPSE, GRAFISCHER LINIE, GRAFISCHER POLYLINIE usw. aus.

Siehe auch

  • GRAFIK ERHALTEN ÜBERLAPPUNG

PBXB64-Umsetzungshinweise

GRAFIKSATZ-ÜBERLAPPUNG gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIKSATZ-ÜBERLAPPUNG ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIKSATZ-ÜBERLAPPUNG mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIK-SET-PIXEL - PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK SET PIXEL

GRAFIK-SET-PIXEL

Zeichne eine Single

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SET PIXEL [STEP] ( x! , y! ) [, rgbColor& ]

Beschreibung

Der Koordinatenpunkt wird in Seiteneinheiten angegeben. Wenn die STEP-Option enthalten ist, wird das x! und du! Koordinaten beziehen sich auf den letzten referenzierten Punkt (POS).

Siehe auch

  • Built In RGB Color Equates
  • GRAFISCHE FARBE
  • GRAFIK GET PIXEL
  • GRAFIK-SET-BITS

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

PBXB64-Umsetzungshinweise

GRAFIK-SET-PIXEL gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK-SET-PIXEL ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK-SET-PIXEL mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC SET POS – PBXB64 Compiler-Hilfe

Startseite › Funktionen › GRAFISCHE SETPOS

GRAFIK SET POS

Legen Sie den letzten referenzierten Punkt (POS) für die ausgewählte fest

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SET POS [STEP] ( x! , y! )

Beschreibung

Der Koordinatenpunkt wird in Seiteneinheiten angegeben. Wenn die STEP-Option enthalten ist, wird das x! und du! Die Koordinaten beziehen sich auf den letzten Referenzpunkt (POS).

Siehe auch

  • GRAFISCHE ANHÄNGE
  • GRAFISCHE ZELLE
  • GRAFIK GET POS
  • GRAFISCHE MAßSTAB

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

PBXB64-Umsetzungshinweise

GRAFIK SET POS gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK SET POS ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK SET POS mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC SET SCROLLTEXT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK SET SCROLLTEXT

GRAFIK SET SCROLLTEXT

Aktiviert oder deaktiviert den grafischen ScrollText-Modus.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SET SCROLLTEXT [ NumrExpr& ]

Beschreibung

GRAPHIC SET SCROLLTEXT aktiviert oder deaktiviert den Bildlaufmodus für das Grafikziel, das derzeit an den Grafikstream angehängt ist. Es hat keine Auswirkung auf andere Grafikziele. Wenn NumrExpr& wahr ist (ungleich Null), ist der ScrollText-Modus aktiviert. Bei „false“ (Null) ist der Modus deaktiviert. Wenn NumrExpr& fehlt, ist standardmäßig der ScrollText-Modus aktiviert.

Mit dem ScrollText-Modus können Sie steuern, wie PowerBASIC Text auf einem Grafikziel druckt, wenn es das Ende einer Seite erreicht. Da ein Grafikziel auf Ganzseitenbasis arbeitet, wird standardmäßig Text ignoriert, der über das Ende der Seite hinaus gedruckt wird.

Wenn der ScrollText-Modus aktiviert ist, wird das Scrollen einer Seite nur durch GRAFIKDRUCK ausgelöst. Wenn sich der POS (letzter referenzierter Punkt) in der unteren Zeile des Grafikziels befindet und eine GRAPHIC PRINT-Anweisung den POS von der Seite verschiebt, wird der gesamte Inhalt des Grafikziels um eine Zeile gescrollt und unten wird eine neue leere Zeile geöffnet.

Siehe auch

  • GRAFIK GET SCROLLTEXT
  • GRAFIK AUTOGRÖSSE EINSTELLEN
  • VIRTUELLES GRAFIKSET
  • GRAFIK-SET WORDWRAP
  • GRAFIK-SET-WICKEL

PBXB64-Umsetzungshinweise

GRAFIK SET SCROLLTEXT gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK SET SCROLLTEXT ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK SET SCROLLTEXT mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIKSATZGRÖSSE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK SET GRÖSSE

GRAFIK-SET-GRÖSSE

Ändern Sie die Gesamtgröße einer Grafik

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SET SIZE nWide& , nHigh&

Beschreibung

Die Gesamtgröße kann je nach Art der verwendeten Rahmen größer als die Clientgröße sein. Der Client-Bereich ist der Teil innerhalb der Ränder, während die Gesamtgröße die Ränder umfasst. Ein grafisches Ziel mit Rand hat normalerweise eine größere Gesamtgröße als eines ohne Rand.

Ab dieser Version von PowerBASIC kann die Größe von GRAFIKSTEUERN mit CONTROL SET CLIENT, GRAPHIC SET CLIENT, CONTROL SET SIZE und GRAPHIC SET SIZE geändert werden.

Die ursprüngliche Bitmap wird Pixel für Pixel in das neu verkleinerte Steuerelement kopiert. Jeder erweiterte Bereich wird mit der aktuellen Hintergrundfarbe gefüllt. Ihr Programm greift auf normale Weise darauf zurück, um eine Bitmap in der neuen Größe zu erstellen.

Wenn ein Clip-Bereich zum Erstellen von Rändern eingerichtet wurde, wird dieser zurückgesetzt. Wenn skalierte Koordinaten festgelegt wurden, werden diese ebenfalls zurückgesetzt, da keine der beiden für die geänderte Größe angemessen wäre. Sie können diese Attribute mit GRAPHIC SCALE oder GRAPHIC SET CLIP wieder aktivieren, basierend auf der neuen Größe des Zeichenbereichs.

nWide& , nHigh&

Integrale numerische Ausdrücke, die die gewünschte Größe der Gesamtfläche angeben. Breite und Höhe werden in Pixeln oder Dialogeinheiten angegeben, je nachdem, welches System bei der Erstellung verwendet wurde.

Siehe auch

  • CONTROL SET-CLIENT
  • CONTROL SET-GRÖSSE
  • GRAFIK GRÖSSE ERHALTEN
  • GRAFIK-SET-CLIENT

PBXB64-Umsetzungshinweise

GRAFIK-SET-GRÖSSE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK-SET-GRÖSSE ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK-SET-GRÖSSE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC SET STRETCHMODE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK SET STRETCHMODE

GRAFIK SET STRETCHMODE

Legt den Standard-Bitmap-Streckmodus für die aktuelle fest

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SET STRETCHMODE ModeExpr

Beschreibung

In PowerBASIC gibt es mehrere Vorgänge, die das Strecken oder Komprimieren von Bildern auf Bitmaps umfassen, insbesondere GRAPHIC STRETCH . Da einzelne Pixel hinzugefügt oder entfernt werden müssen, besteht eine gute Chance, dass sich die Bildqualität verschlechtert. Wenn Sie jedoch die Art des Bildes durch die Definition eines StretchMode beschreiben, können Sie das Erscheinungsbild erheblich verbessern.

Der Standard-StretchMode wird für jeden DC individuell verwaltet. Sie können den Standardmodus mit dieser Anweisung festlegen oder ihn mit GRAPHIC GET STRETCHMODE abrufen. Natürlich können Sie den Standard-StretchMode auch überschreiben, wenn Sie eine der betroffenen Anweisungen ausführen.

Die 4 Stretch-Modus-Equates sind in PowerBASIC vordefiniert.

Gleichsetzen

Beschreibung

%BLACKONWHITE

Dies ist der standardmäßige Streckungsmodus von Windows und eignet sich am besten für monochrome Bitmaps oder solche mit Farbblöcken. Führt ein boolesches ODER von eliminierten und vorhandenen Pixeln durch. Schwarze Pixel bleiben auf Kosten weißer Pixel erhalten.

%WHITEONBLACK

Führt ein boolesches ODER von eliminierten und vorhandenen Pixeln durch. Es behält weiße Pixel auf Kosten schwarzer Pixel bei.

%COLORONCOLOR

Löscht gelöschte Pixelzeilen, ohne zu versuchen, ihre Informationen beizubehalten.

%HALBTON

Dies bietet höchste Qualität für komplexe Farbbitmaps. Die durchschnittliche Farbe des Zielpixelblocks bleibt ungefähr die gleiche wie die des Quellpixelblocks.

Siehe auch

  • GRAFISCHES BITMAP-LADEN
  • GRAFISCHE KOPIE
  • GRAFIK GET STRETCHMODE
  • GRAFISCHES Rendering
  • GRAFISCHER STRETCH

PBXB64-Umsetzungshinweise

GRAFIK SET STRETCHMODE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK SET STRETCHMODE ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK SET STRETCHMODE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIK-SET-ANSICHT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK-SET-ANSICHT

GRAFISCHE SET-ANSICHT

Ändert die Position des Ansichtsfensters auf a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SET VIEW XPos , YPos

Beschreibung

Verschiebt die Position des Ansichtsfensters an die neue Position auf einem virtuellen Grafikziel. Die Position wird in Seiteneinheiten angegeben. Wenn kein Grafikziel angehängt oder kein virtuelles Fenster erstellt wurde, wird keine Operation ausgeführt.

Siehe auch

  • GRAFIK ANSICHT ERHALTEN
  • GRAFIK AUTOGRÖSSE EINSTELLEN
  • VIRTUELLES GRAFIKSET

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

PBXB64-Umsetzungshinweise

GRAFISCHE SET-ANSICHT gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHE SET-ANSICHT ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHE SET-ANSICHT mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC SET VIRTUAL – PBXB64 Compiler-Hilfe

Startseite › Funktionen › GRAFIK SET VIRTUELL

VIRTUELLES GRAFIKSET

Vergrößert die virtuelle Zeichenfläche eines angehängten Grafikziels.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SET VIRTUAL nWidth& , nHeight& [,USERSIZE]

Beschreibung

Im VIRTUAL-Modus kann das angehängte Grafikziel (Steuerelement oder Fenster) den Inhalt eines größeren virtuellen Fensters anzeigen. Die physikalische Größe des Anzeigebereichs wird nicht verändert. Stattdessen fungiert der Anzeigebereich als kleineres Ansichtsfenster, das um das größere virtuelle Fenster verschoben werden kann, um jeweils einen Abschnitt anzuzeigen. Die physikalische Größe des Anzeigebereichs wird nicht verändert. Wenn das Grafikziel eine Bitmap ist, wird keine Operation ausgeführt, da kein Anzeigebereich vorhanden wäre.

Diese Anweisung kann verwendet werden, um ein Ziel in den VIRTUAL-Modus zu ändern oder um die Größen und die UserSize-Option eines vorhandenen VIRTUAL-Ziels zu ändern.

Bei der Ausführung wird eine neue virtuelle Bitmap mit der angegebenen Höhe und Breite erstellt. nWidth& und nHeight& werden je nach ursprünglicher Fenstererstellung immer in Pixeln oder Dialogeinheiten angegeben. Die ursprüngliche Bitmap wird Pixel für Pixel in der vorhandenen Größe kopiert. Jeder erweiterte Bereich wird mit der aktuellen Hintergrundfarbe gefüllt. Ihr Programm greift auf normale Weise darauf zurück, um eine Bitmap in der neuen Größe zu erstellen. Es werden Bildlaufleisten hinzugefügt, damit der Benutzer das Ansichtsfenster in den gewünschten Abschnitt verschieben kann. Die Größe des Ansichtsfensters wird nicht geändert.

Das grafische Ansichtsfenster wird zunächst in der oberen linken Ecke des virtuellen Fensters platziert. Wenn ein Clip-Bereich zum Erstellen von Rändern eingerichtet wurde, wird dieser zurückgesetzt. Wenn skalierte Koordinaten festgelegt wurden, werden diese ebenfalls zurückgesetzt, da keine der beiden für die geänderte Größe angemessen wäre. Sie können diese Attribute mit GRAPHIC SCALE oder GRAPHIC SET CLIP wieder aktivieren, basierend auf der neuen Größe des Zeichenbereichs. Die Größe der virtuellen Zeichenfläche können Sie jederzeit mit GRAPHIC GET CANVAS abrufen.

Das grafische Ansichtsfenster kann durch Klicken auf die Bildlaufleisten oder durch Bewegen des Mausrads verschoben werden, um die vertikale Position zu ändern. Durch Drücken der Steuertaste zusammen mit dem Mausrad wird die horizontale Position geändert. Darüber hinaus können zu diesem Zweck auch die Cursor-Bewegungstasten (Links, Rechts, Auf, Ab, Bild-auf, Bild-ab, Pos1, Ende) verwendet werden. Der VIRTUAL-Modus ist dem AUTOSIZE-Modus ziemlich ähnlich. Beide erstellen ein virtuelles Fenster, das das Ziel Ihrer Zeichen- und Textdruckvorgänge ist. Der Unterschied liegt in der Art und Weise, wie sie angezeigt werden.

VIRTUAL zeigt ein Ansichtsfenster an, das kleiner als das virtuelle Fenster ist und an verschiedene Positionen verschoben werden kann. Dadurch kann der Benutzer jeweils einen ausgewählten Abschnitt anzeigen. AUTOSIZE zeigt jederzeit das gesamte virtuelle Fenster an, indem es es je nach Bedarf dehnt oder komprimiert.

Die Option USERSIZE wird aus Kompatibilitaetsgruenden akzeptiert, aber der aktuelle Laufzeitpfad vergroessert nur die Hintergrund-Zeichenflaeche und setzt das Ansichtsfenster zurück; separate Rahmen- oder Scrollleisten-UI wird nicht eingeblendet.

Im Allgemeinen ist es nicht ratsam, den ScrollText-Modus in einem virtuellen Grafikfenster zu aktivieren, da die Anzeige für den Benutzer verwirrend sein kann.

Pruefnachweis: Geprueft durch tests/pb/test_graphic_set_virtual.pb in der pb_linkrun-Lane. Die Regression belegt Canvas-Groesse, Pixel-Erhalt und View-Reset in einem echten Grafikfenster.

Siehe auch

  • GRAFIK ERHALTEN SIE LEINWAND
  • GRAFIK ANSICHT ERHALTEN
  • GRAFIK AUTOGRÖSSE EINSTELLEN
  • GRAFIKSATZ BEHOBEN
  • GRAFISCHE SET-ANSICHT

PBXB64-Umsetzungshinweise

VIRTUELLES GRAFIKSET gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

VIRTUELLES GRAFIKSET ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' VIRTUELLES GRAFIKSET mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC SET WORDWRAP – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIK SET WORDWRAP

GRAFIK-SET WORDWRAP

Aktiviert oder deaktiviert den grafischen Zeilenumbruchmodus.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SET WORDWRAP [ NumrExpr& ]

Beschreibung

GRAPHIC SET WORDWRAP aktiviert oder deaktiviert den WordWrap-Modus für das Grafikziel, das derzeit an den Grafikstream angehängt ist. Es hat keine Auswirkung auf andere Grafikziele. Wenn NumrExpr& wahr ist (ungleich Null), ist der WordWrap-Modus aktiviert. Bei „false“ (Null) ist der Wrap-Modus deaktiviert. Wenn NumrExpr& fehlt, ist der WordWrap-Modus standardmäßig aktiviert.

Mit dem WordWrap-Modus können Sie steuern, wie PowerBASIC Text auf einem Grafikziel druckt, wenn dieser das Ende einer Zeile erreicht. Da ein Grafikziel auf Ganzseitenbasis arbeitet, wird standardmäßig Text ignoriert, der über das Zeilenende hinaus gedruckt wird.

Wenn der WordWrap-Modus aktiviert ist, wirkt er sich nur auf GRAFIKDRUCK-Vorgänge aus. Wenn GRAPHIC PRINT versucht, ein Wort über das Ende einer Zeile hinaus anzuzeigen, wird das gesamte Wort automatisch in die erste Spalte der nächsten Zeile umgebrochen.

Siehe auch

  • GRAFISCHE ZELLE
  • GRAFIK GET WORDWRAP
  • GRAFIK-SET WORDWRAP
  • GRAFIK-SET-WICKEL
  • GRAFISCHE SPLIT

PBXB64-Umsetzungshinweise

GRAFIK-SET WORDWRAP gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK-SET WORDWRAP ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK-SET WORDWRAP mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC SET WRAP – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAPHIC SET WRAP

GRAFIK-SET-WICKEL

Aktiviert oder deaktiviert den Grafikumbruchmodus.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SET WRAP [ NumrExpr& ]

Beschreibung

GRAPHIC SET WRAP aktiviert oder deaktiviert den Wrap-Modus für das Grafikziel, das derzeit an den Grafikstream angehängt ist. Es hat keine Auswirkung auf andere Grafikziele. Wenn NumrExpr& wahr ist (ungleich Null), ist der Wrap-Modus aktiviert. Bei „false“ (Null) ist der Wrap-Modus deaktiviert. Wenn NumrExpr& fehlt, ist der Wrap-Modus standardmäßig aktiviert.

Mit dem Wrap-Modus können Sie steuern, wie PowerBASIC Text auf einem Grafikziel druckt, wenn dieser das Ende einer Zeile erreicht. Da ein Grafikziel auf Ganzseitenbasis arbeitet, wird standardmäßig Text ignoriert, der über das Zeilenende hinaus gedruckt wird.

Wenn der Wrap-Modus aktiviert ist, wirkt er sich nur auf GRAFIKDRUCK-Vorgänge aus. Wenn GRAPHIC PRINT versucht, ein Zeichen über das Ende einer Zeile hinaus anzuzeigen, wird es automatisch in die erste Spalte der nächsten Zeile umgebrochen.

Siehe auch

  • GRAFISCHE ZELLE
  • GRAFIK GET WRAP
  • GRAFIKDRUCK
  • GRAFIK SET SCROLLTEXT
  • GRAFIK-SET WORDWRAP
  • GRAFISCHE SPLIT

PBXB64-Umsetzungshinweise

GRAFIK-SET-WICKEL gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK-SET-WICKEL ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK-SET-WICKEL mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIK-SPLIT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIKSPLIT

GRAFISCHE SPLIT

Teilt eine Zeichenfolge zur Anzeige in einer Grafik in zwei Teile

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC SPLIT [WORD] MainStr , Part1Len To Part1Var , Part2Var

Beschreibung

Im Allgemeinen können Sie mit GRAPHIC SPLIT bestimmen, wie viel Text in eine Zeile (oder einen Zeilenabschnitt) passt, damit Sie das Ende nicht überschreiben. Dies ist bei Schriftarten mit variabler Breite von entscheidender Bedeutung. Da diese Textzeichen unterschiedlich breit sind, können Sie sich nicht auf eine einfache Zeichenzählung verlassen.

GRAPHIC SPLIT trennt den MainStr-String-Ausdruck in zwei Teile, die dann den beiden durch Part1Var und Part2Var angegebenen String-Variablen zugewiesen werden. Der numerische Ausdruck Part1Len gibt die maximale Breite des Druckfelds unter Verwendung von Seiteneinheiten (Pixel, Dialogeinheiten, skalierte Einheiten) an. Nach Abschluss des GRAPHIC SPLIT enthält die Part1Var diejenigen Zeichen, die sicher im Druckfeld angezeigt werden können. Die Part2Var enthält die restlichen Zeichen, die möglicherweise in den folgenden Zeilen angezeigt werden.

Da dieser Vorgang einen „Zeilenumbruch“ erzeugt, der im Originaltext nicht vorgesehen ist, müssen Sie möglicherweise die Ergebnisse ändern, um das beste Erscheinungsbild zu erzielen. Beispielsweise ist es normalerweise am besten, alle führenden Leerzeichen aus Part2Var zu entfernen, bevor es gedruckt wird.

Wenn die WORD-Option enthalten ist, garantiert PowerBASIC, dass Part1Var nicht mit einem Teilwort endet. Dies erfordert möglicherweise, dass Part1Len auf einen kleineren Wert angepasst wird. In diesem Fall würden Part2Var diese Zeichen zum Ausgleich zugewiesen.

Siehe auch

  • GRAFISCHE ZELLE
  • GRAFIKDRUCK
  • GRAFIK SET SCROLLTEXT
  • GRAFIK-SET WORDWRAP
  • GRAFIK-SET-WICKEL
  • GETEILT

PBXB64-Umsetzungshinweise

GRAFISCHE SPLIT gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHE SPLIT ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHE SPLIT mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC STRETCH – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFISCHER STRETCH

GRAFISCHER STRETCH

Kopieren Sie eine Bitmap und ändern Sie ihre Größe in die ausgewählte Datei

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC STRETCH hBmp , ID , ( x1 , y1 )-( x2 , y2 ) TO ( x3 , y3 )-( x4 , y4 ) [, Mix , Stretch ]
GRAPHIC STRETCH PAGE hBmp , ID [, Mix , Stretch ]

Beschreibung

Sie können eine vollständige Bitmap oder einen Teil davon auf das ausgewählte Grafikziel kopieren und dabei die Größe vergrößern oder verkleinern. Die Handle-Variable hBmp gibt das Handle der Quellbitmap, des Quellsteuerelements oder des Quellfensters an. Die Parameter-ID ist die mit CONTROL ADD GRAPHIC zugewiesene Steuerungskennung (1 bis 65535). Die ID muss für ein GRAFIKWINDOW oder eine Bitmap Null (0) sein. Das Ziel der Streckoperation ist immer das angehängte Grafikziel. Die Größe der Bitmap wird automatisch an die Zielparameter angepasst. Sie müssen darauf achten, dass Ihre Parameter für die angegebene Bitmap gültig sind, sonst ist das Ergebnis der Operation undefiniert.

Die zweite Form, GRAPHIC STRETCH PAGE, ist eine Verknüpfung zum Kopieren einer vollständigen Bitmap in den Clip- oder Clientbereich des ausgewählten Grafikziels. Das Bild wird automatisch gestreckt oder gestaucht, um es an das Ziel anzupassen.

Wenn der Parameter „Mix“ enthalten ist, handelt es sich um einen der Werte in der folgenden Tabelle. Wenn nicht enthalten oder der Wert Null (0) ist, wird ein Standardwert von %mix_CopySrc angenommen. Es stehen 16 Mischmodi zur Verfügung, mit denen Sie Zeichenfarben mit den Farben mischen können, die bereits am Zeichenort vorhanden sind. Die Mix-Modus-Equates sind in PowerBASIC vordefiniert.

%mix_Blackness

Pixel ist immer 0 (schwarz).

%mix_NotMergeSrc

Pixel ist die Umkehrung der MergeSrc-Farbe.

%mix_MaskNotSrc

Pixel ist eine Kombination der Farben, die sowohl dem Pixel als auch der Umkehrung der Quelle gemeinsam sind.

%mix_NotCopySrc

Pixel ist die Umkehrung der Stiftfarbe.

%mix_MaskSrcNot

Pixel ist eine Kombination der Farben, die sowohl der Quelle als auch der Umkehrung des Pixels gemeinsam sind.

%mix_Not

Pixel ist die Umkehrung der Pixelfarbe.

%mix_XorSrc

Pixel ist eine Kombination der Farben in der Quelle und im Pixel, jedoch nicht in beiden.

%mix_NotMaskSrc

Pixel ist die Umkehrung der MaskSrc-Farbe.

%mix_MaskSrc

Pixel ist eine Kombination der Farben, die sowohl der Quelle als auch dem Pixel gemeinsam sind.

%mix_NotXorSrc

Pixel ist die Umkehrung der XorSrc-Farbe.

%mix_Nop

Pixel bleibt unverändert.

%mix_MergeNotSrc

Pixel ist eine Kombination aus der Quellfarbe und der Umkehrung der Pixelfarbe.

%mix_CopySrc

Pixel ist die Quellfarbe (Standard).

%mix_MergeSrcNot

Pixel ist eine Kombination aus der Quellfarbe und der Umkehrung der Pixelfarbe.

%mix_MergeSrc

Pixel ist eine Kombination aus der Quellfarbe und der Pixelfarbe.

%mix_Whiteness

Pixel ist immer 1 (weiß).

Dehnen

Wenn der Parameter stretch& enthalten ist, handelt es sich um einen der Werte in der folgenden Tabelle. Wenn nicht enthalten oder der Wert Null (0) ist, bleibt der Streckungsmodus unverändert. Eine geeignete Auswahl des Streckungsmodus kann die Qualität von Bitmaps, deren Größe geändert wird, erheblich verbessern. Die Streckmodus-Equates sind in PowerBASIC vordefiniert.

Gleichsetzen

Beschreibung

%BLACKONWHITE

Dies ist der standardmäßige Streckungsmodus von Windows und eignet sich am besten für monochrome Bitmaps oder solche mit Farbblöcken. Führt ein boolesches ODER von eliminierten und vorhandenen Pixeln durch. Schwarze Pixel bleiben auf Kosten weißer Pixel erhalten.

%WHITEONBLACK

Führt ein boolesches ODER von eliminierten und vorhandenen Pixeln durch. Es behält weiße Pixel auf Kosten schwarzer Pixel bei.

%COLORONCOLOR

Löscht gelöschte Pixelzeilen, ohne zu versuchen, ihre Informationen beizubehalten.

%HALBTON

Dies bietet höchste Qualität für komplexe Farbbitmaps. Die durchschnittliche Farbe des Zielpixelblocks bleibt ungefähr die gleiche wie die des Quellpixelblocks.

Siehe auch

  • GRAFISCHE KOPIE
  • GRAFISCHE BILDLISTE
  • GRAFISCHES Rendering
  • GRAFIK SET STRETCHMODE

PBXB64-Umsetzungshinweise

GRAFISCHER STRETCH gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHER STRETCH ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHER STRETCH mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFISCHER STIL – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFISCHER STIL

GRAFISCHER STIL

Legen Sie den Linienstil fest, der von verschiedenen Grafiken verwendet werden soll

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC STYLE linestyle&

Beschreibung

Das Grafikziel muss zunächst mit GRAPHIC ATTACH ausgewählt werden. Aufgrund von Einschränkungen in der Windows-Grafikgeräteschnittstelle (GDI) werden Stile nur angewendet, wenn die Linienbreite auf 1 (Standardeinstellung) eingestellt ist. Wenn die Linienstärke größer als 1 ist, wird der Stil als 0, durchgezogen, interpretiert.

Verfügbare Linienstile sind:

Fest (Standard)

DashDot

DashDotDot

Siehe auch

  • GRAFISCHER BOGEN
  • GRAFISCHE ANHÄNGE
  • GRAFIKBOX
  • GRAFISCHE ELLIPSE
  • GRAFISCHE LINIE
  • GRAFISCHER TORTEN
  • GRAFISCHE BREITE

PBXB64-Umsetzungshinweise

GRAFISCHER STIL gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHER STIL ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHER STIL mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC(TEXT.SIZE.X...) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAPHIC(TEXT.SIZE.X...)
Hilfe zum PBXB64-Compiler

GRAFIK(TEXT.GRÖSSE.X...)

Berechnen Sie die Größe des Textes

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC TEXT SIZE txt$ TO WidthVar! , HeightVar!
Function Form:
WidthVar! = GRAPHIC(TEXT.SIZE.X, txt$ )
HeightVar! = GRAPHIC(TEXT.SIZE.Y, txt$ )

Beschreibung

Diese Anweisung berechnet die Gesamtgröße des gedruckten Textes basierend auf der aktuellen Schriftart für das Grafikziel. Die zurückgegebenen Größen werden in Seiteneinheiten angegeben.

Dies ermöglicht Ihnen eine einfache Berechnung der passenden Druckposition, insbesondere bei Verwendung einer Proportionalschrift.

Siehe auch

  • SCHRIFTART NEU
  • GRAFISCHE ZELLE
  • GRAFISCHE ZELLENGRÖSSE
  • GRAFISCHE CHR-GRÖSSE
  • GRAFIKDRUCK
  • GRAFIK-SET-SCHRIFTART
  • GRAFISCHE MAßSTAB
  • GRAFIK-SET WORDWRAP
  • GRAFIK-SET-WICKEL
  • GRAFISCHE SPLIT

PBXB64-Umsetzungshinweise

GRAFIK(TEXT.GRÖSSE.X...) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK(TEXT.GRÖSSE.X...) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK(TEXT.GRÖSSE.X...) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC$(WAITKEY$) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAPHIC$(WAITKEY$)
Hilfe zum PBXB64-Compiler

GRAFIK$(WAITKEY$)

Liest ein Tastaturzeichen oder eine erweiterte Taste und wartet, bis eines bereit ist.

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC WAITKEY$ [To WaitVar$ ]
GRAPHIC WAITKEY$ ([ KeyMask$ ] [, TimeOut& ]) [TO WaitVar$ ]
Function Form:
WaitVar$ = GRAPHIC$(WAITKEY$)
WaitVar$ = GRAPHIC$(WAITKEY$, [ KeyMask$ ] [, TimeOutVal& ])

Beschreibung

Liest ein Zeichen oder eine erweiterte Taste von der Tastatur, ohne dass etwas auf dem Bildschirm angezeigt wird. Wenn keine Daten verfügbar sind, wartet GRAPHIC WAITKEY$ auf das Eintreten eines Ereignisses. Es ist GRAPHIC INKEY$ sehr ähnlich, außer dass es darauf wartet, dass eine Eingabe verfügbar ist. Während des Wartens werden Zeitscheiben an das Betriebssystem freigegeben, um die CPU-Last zu reduzieren.

Es gibt eine Zeichenfolge aus einem oder zwei Zeichen zurück, wenn eine Taste gedrückt wurde. Wenn die TO-Klausel weggelassen wird, wird das Tastaturzeichen verworfen.

Wenn der optionale KeyMask$-Ausdruck enthalten ist, wird nur ein begrenzter Satz von Schlüsseln erkannt. KeyMask$ kann eine beliebige Anzahl von Untermasken enthalten, eine für jeden zu beobachtenden Schlüssel. Beispielsweise erkennt GRAPHIC WAITKEY$("YyNn") Groß- und Kleinbuchstaben Y oder N (für Ja/Nein-Antworten), während alle anderen Tasten ignoriert werden. Wenn KeyMask$ weggelassen wird oder eine Zeichenfolge mit der Länge Null ergibt, wird jedes Schlüsselereignis erkannt.

Wenn der optionale TimeOutVal&-Ausdruck enthalten ist, gibt er die maximale Anzahl an Millisekunden an, die auf einen Schlüssel gewartet werden soll. GRAPHIC WAITKEY$(5000) wartet maximal 5 Sekunden. Der angegebene TimeOut-Zeitraum ist nur ein ungefährer Wert, daher sollten Sie sich nicht auf die Präzision verlassen. Wenn der TimeOut-Zeitraum überschritten wird, wird eine Zeichenfolge der Länge Null zurückgegeben. Wenn der Parameter TimeOutVal& weggelassen wird oder den Wert Null (0) ergibt, wird unendlich lange gewartet. Der maximal zulässige TimeOut beträgt eine Stunde.

Eine Zeichenfolgenlänge von eins ( LEN (i$) = 1) bedeutet, dass eine Standardzeichentaste gedrückt wurde. Die Ergebniszeichenfolge enthält das Zeichen. Ein ASC()-Wert zwischen 1 und 31 gibt einen Steuercode an.

Eine Zeichenfolgenlänge von zwei (LEN(i$) = 2) bedeutet, dass eine erweiterte Taste gedrückt wurde. In diesem Fall hat das erste Zeichen in der Ergebniszeichenfolge einen ASC()-Wert von Null (0) und das zweite ist der erweiterte Tastatur-Scancode. Wenn Sie beispielsweise die Taste F1 drücken, wird CHR$ (0, 59) zurückgegeben.

Siehe auch

  • GRAFIK-INKEY$
  • GRAFISCHE INPUT
  • GRAFISCHER EINGANG FLUSH
  • GRAFISCHE INSTAT
  • GRAFISCHE ZEILENEINGABE

PBXB64-Umsetzungshinweise

GRAFIK$(WAITKEY$) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIK$(WAITKEY$) ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIK$(WAITKEY$) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFISCHE BREITE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFISCHE BREITE

GRAFISCHE BREITE

Legen Sie die Linienbreite fest, die von verschiedenen Grafiken verwendet werden soll

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC WIDTH linewidth&

Beschreibung

Wenn die Linienbreite auf einen Wert größer als 1 (Standard) eingestellt ist, wird der Linienstil immer als 0 (durchgezogen) interpretiert.

Siehe auch

  • GRAFISCHER BOGEN
  • GRAFIKBOX
  • GRAFISCHE ELLIPSE
  • GRAFISCHE LINIE
  • GRAFISCHER TORTEN
  • GRAFISCHER STIL

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

PBXB64-Umsetzungshinweise

GRAFISCHE BREITE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHE BREITE ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHE BREITE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIKFENSTER – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › GRAFIKFENSTER

GRAFISCHES FENSTER

Erstellt ein neues eigenständiges Grafikfenster.

Die klassische direkte GRAPHIC WINDOW-Form wird als NEW akzeptiert, wenn kein Erzeugungsschluesselwort angegeben ist, und die TEXT-Form bestimmt die Groessse des Clientbereichs aus Zeilen und Spalten mit der Anfangsschriftart.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC WINDOW NEW Caption$ , x& , y& , n Width& , n Height& [, hFont ] TO hWinVar [,HIDE|NORMALIZE]
GRAPHIC WINDOW TEXT Caption$ , x& , y& , n Rows& , n Columns& [, hFont ] TO hWinVar [,HIDE|NORMALIZE]

Beschreibung

Ein Grafikfenster ist ein eigenständiges Fenster, das zur Anzeige fast aller Arten von Text und Grafiken verwendet wird. Nachdem mit dieser Anweisung ein Grafikfenster erstellt wurde, wird es normalerweise mit GRAPHIC ATTACH als ausgewähltes Grafikziel ausgewählt. Wenn zum Zeitpunkt der Erstellung jedoch kein ausgewähltes Grafikziel vorhanden ist, wird das neue Grafikfenster automatisch angehängt und ausgewählt. Anschließend können Sie Texte, Linien, Kreise und andere Formen mit verschiedenen Anweisungen zeichnen.

Mit GRAFIKFENSTER END kann das ausgewählte Grafikfenster jederzeit geschlossen und zerstört werden. Andernfalls wird das Fenster bei Programmende automatisch zerstört.

Alle grafischen Anzeigen von PowerBASIC sind dauerhaft – sie werden automatisch für Sie neu gezeichnet, nachdem sie minimiert oder vorübergehend von anderen Fenstern verdeckt werden.

Die Option TEXT wird verwendet, um ein Fenster zu erstellen, das stärker auf die Anzeige von Text ausgerichtet ist. Die Größe des Fensters wird in Zeilen und Spalten (und nicht in Pixeln) angegeben, basierend auf der Größe der Anfangsschriftart – der Standardschriftart (MS Sans Serif, 8 Punkt) oder der optionalen Anfangsschriftart, die durch den Parameter „Font“ angegeben wird. Die Darstellungsmöglichkeiten von Grafiken werden dadurch nicht eingeschränkt, da alle sehr grafischen Funktionen weiterhin zur Verfügung stehen. Es macht es einfach einfacher, ein Fenster in der gewünschten Größe zu erstellen. Diese Option eignet sich am besten für Schriftarten, die für jedes Zeichen eine feste Breite haben (Courier, Lucida usw.).

Der Parameter Caption$ enthält den Text, der in der Titel- oder Titelleiste des Grafikfensters angezeigt werden soll. Wenn caption$ leer ist (Länge Null), wird das Fenster ohne Titelleiste angezeigt, sodass das Erscheinungsbild anders ist und das Fenster nicht vom Benutzer gezogen werden kann.

Die Parameter x& und y& geben die Position des Fensters in Pixel relativ zur oberen linken Ecke des Desktops an.

Der Parameter nWidth& gibt die Breite des Client-Bereichs des Fensters an, ohne den Rahmen. Die Breite wird in Pixel angegeben.

Der Parameter nHeight& gibt die Höhe des Client-Bereichs des Fensters an, ohne den Rahmen. Die Höhe wird in Pixel angegeben.

Der Parameter hFont gibt das Handle der anfänglichen Schriftart an, die im GRAFIKFENSTER verwendet werden soll. Wenn dieser optionale Parameter enthalten ist, handelt es sich um das Handle einer mit FONT NEW erstellten Schriftart. Dieser Parameter ist besonders wichtig, wenn Sie die Option TEXT verwenden, da die Größe des Fensters auf der Größe der ursprünglichen Schriftart basiert. Falls nicht enthalten, wird die Standardschriftart (MS Sans Serif, 8 Punkt) für Sie ausgewählt.

Die Long-/DWord-Variable hWinVar erhält das Handle des neu erstellten Fensters. Konnte das Fenster nicht erstellt werden, wird hWinVar der Wert Null (0) zugewiesen.

Die Optionswörter HIDE oder NORMALIZE bestimmen, ob das Fenster sofort sichtbar gemacht wird. Möglicherweise möchten Sie das Fenster zunächst ausblenden, damit Sie zunächst weitere Änderungen daran vornehmen können, beispielsweise mit der GRAPHIC WINDOW STABILIZE-Anweisung. Wenn weder HIDE noch NORMALIZE ausgewählt ist, wird es standardmäßig sofort angezeigt.

Ein neu erstelltes GRAFIKFENSTER erhält automatisch den Fokus. Das heißt, Tastatureingaben werden an das Grafikfenster weitergeleitet, bis es geschlossen wird oder Sie ein anderes Fokusziel auswählen.

Pruefnachweis: test_graphic_window_state.pb prueft GRAPHIC WINDOW HIDE / MINIMIZE / NORMALIZE / STABILIZE / NONSTABLE auf einem echten Grafikfenster. test_graphic_window_create_form.pb prueft die NEW- und TEXT-Erzeugungsformen, einschliesslich verborgenem Start und font-gebundener TEXT-Groessenberechnung.

Siehe auch

  • STEUERUNG GRAFIK HINZUFÜGEN
  • GRAFISCHE ANHÄNGE
  • GRAFISCHE ZELLE
  • GRAFISCHE FARBE
  • GRAFISCHES ABNEHMEN
  • GRAFIK AUTOGRÖSSE EINSTELLEN
  • Bildunterschrift für das Grafikset
  • GRAFIK-SET-CLIENT
  • GRAFIK-SET-CLIP
  • GRAFIKSATZ BEHOBEN
  • GRAFIK-SET-SCHRIFTART
  • GRAFIK SET LOC
  • GRAFIKSATZ-ÜBERLAPPUNG
  • GRAFIK SET SCROLLTEXT
  • GRAFIK-SET-GRÖSSE
  • GRAFIK SET STRETCHMODE
  • VIRTUELLES GRAFIKSET
  • GRAFIK-SET WORDWRAP
  • GRAFIK-SET-WICKEL
  • Klicken Sie auf das Grafikfenster
  • GRAFISCHES FENSTERENDE
  • GRAFISCHES FENSTER VERDECKEN
  • GRAFIKFENSTER MINIMIEREN
  • GRAFIKFENSTER NICHT STABIL
  • GRAFIKFENSTER NORMALISIEREN
  • GRAFISCHES FENSTER STABILISIEREN
  • TXT-Pseudoobjekt

PBXB64-Umsetzungshinweise

GRAFISCHES FENSTER gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHES FENSTER ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHES FENSTER mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAPHIC WINDOW CLICK - PBXB64-Compiler-Hilfe

Startseite › BASIC Frontend › Befehlsreferenz › Grafik und GUI › GRAPHIC WINDOW CLICK
Hilfe zum PBXB64-Compiler

GRAPHIC WINDOW CLICK

Liest den naechsten ausstehenden Klick des ausgewaehlten Grafikfensters und gibt Klickart und Position zurueck.

Typ: Anweisung | Kategorie: Benutzeroberflaeche, Grafik und DDT

PBXB64-Status: VERFUEGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC WINDOW CLICK [ hwin& ] TO click& , x! , y!

Beschreibung

GRAPHIC WINDOW CLICK prueft das ausgewaehlte GRAPHIC WINDOW auf den zuletzt seit der vorherigen Abfrage registrierten Klick. Ein Einzelklick liefert 1 in click&, ein Doppelklick liefert 2, und ohne ausstehenden Klick erhalten alle drei Ergebnisvariablen den Wert 0.

Die Ergebnisse x! und y! erhalten die gespeicherte Mausposition des ausstehenden Klicks. Nach dem Lesen von y! wird der Klickdatensatz geloescht.

Wird der optionale Handle weggelassen, wird das aktuelle GRAPHIC ATTACH-Ziel verwendet.

Beispiel

#COMPILE EXE
#DIM ALL

DECLARE FUNCTION SendMessageA LIB "user32.dll" ALIAS "SendMessageA" (BYVAL hWnd AS QUAD, BYVAL Msg AS DWORD, BYVAL wParam AS QUAD, BYVAL lParam AS QUAD) AS LONG

FUNCTION PBMAIN() AS LONG
    LOCAL h AS QUAD
    LOCAL click AS LONG
    LOCAL x AS LONG
    LOCAL y AS LONG

    GRAPHIC WINDOW "Click", 0, 0, 120, 90 TO h
    GRAPHIC ATTACH h
    click = SendMessageA(h, &H0201, 0, CLNG(9) + (CLNG(11) * 65536))
    GRAPHIC WINDOW CLICK TO click, x, y
    IF click <> 1 OR x <> 9 OR y <> 11 THEN FUNCTION = 1
    GRAPHIC WINDOW END h
END FUNCTION

Validierungsnachweis

Positiv: tests/pb/test_graphic_window_click.pb ist in tests/validate.toml registriert und beweist die Klickausgabe, die Koordinatenuebernahme und das einmalige Leeren des Zustands.

Negativ: tests/pb/test_graphic_window_click_reject.pb ist in tests/validate.toml registriert und beweist, dass die fehlerhafte Form ohne TO die gezielte Diagnose bekommt.

Siehe auch

  • GRAPHIC ATTACH
  • GRAPHIC WINDOW
  • GRAPHIC WINDOW END

PBXB64-Umsetzungshinweise

GRAPHIC WINDOW CLICK gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAPHIC WINDOW CLICK ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAPHIC WINDOW CLICK mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIKFENSTERENDE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFISCHES FENSTERENDE

GRAFISCHES FENSTERENDE

Schließen und zerstören Sie a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC WINDOW END [ hWin ]

Beschreibung

Das durch das Handle hWin identifizierte GRAFIKFENSTER wird geschlossen und zerstört. Wenn hWin weggelassen wird oder gleich Null (0) ist, wird das aktuell angehängte Grafikfenster zerstört.

Mit GRAPHIC WINDOW END kann ein Grafikfenster jederzeit geschlossen und zerstört werden. Andernfalls wird das Fenster bei Programmende automatisch zerstört.

Siehe auch

  • GRAFISCHES ABNEHMEN
  • GRAFISCHES FENSTER
  • GRAFISCHES FENSTER VERDECKEN

PBXB64-Umsetzungshinweise

GRAFISCHES FENSTERENDE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHES FENSTERENDE ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHES FENSTERENDE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIKFENSTER AUSblenden – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIKFENSTER AUSblenden

GRAFISCHES FENSTER VERDECKEN

Machen Sie ein

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC WINDOW HIDE [ hWin ]

Beschreibung

Das durch das Handle hWin identifizierte GRAFIKFENSTER wird unsichtbar gemacht. Wenn hWin weggelassen wird oder gleich Null (0) ist, wird das aktuell angehängte Grafikfenster unsichtbar gemacht.

Siehe auch

  • GRAFISCHES FENSTERENDE
  • GRAFIKFENSTER MINIMIEREN
  • GRAFIKFENSTER NICHT STABIL
  • GRAFIKFENSTER NORMALISIEREN
  • GRAFISCHES FENSTER STABILISIEREN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

PBXB64-Umsetzungshinweise

GRAFISCHES FENSTER VERDECKEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHES FENSTER VERDECKEN ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHES FENSTER VERDECKEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIKFENSTER MINIMIEREN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIKFENSTER MINIMIEREN

GRAFIKFENSTER MINIMIEREN

Minimieren Sie a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC WINDOW MINIMIZE [ hWin ]

Beschreibung

Das durch das Handle hWin identifizierte GRAFIKFENSTER wird minimiert. Wenn hWin weggelassen wird oder gleich Null (0) ist, wird das aktuell angehängte Grafikfenster minimiert. Mit GRAPHIC WINDOW NORMALIZE können Sie das Grafikfenster wieder in den Normalzustand versetzen.

Siehe auch

  • GRAFISCHES FENSTER VERDECKEN
  • GRAFIKFENSTER NICHT STABIL
  • GRAFIKFENSTER NORMALISIEREN
  • GRAFISCHES FENSTER STABILISIEREN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

PBXB64-Umsetzungshinweise

GRAFIKFENSTER MINIMIEREN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIKFENSTER MINIMIEREN ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIKFENSTER MINIMIEREN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIKFENSTER NICHT STABIL – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIKFENSTER NICHT STABIL

GRAFIKFENSTER NICHT STABIL

Machen Sie ein

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC WINDOW NONSTABLE [ hWin ]

Beschreibung

Das durch das Handle hWin identifizierte GRAFIKFENSTER wird instabil gemacht, d. h. es kann vom Benutzer geschlossen werden. Wenn ein Systemmenü vorhanden ist, sind die Schließoption und das Schließfeld aktiviert. Die Schließen-Taste ALT-F4 ist ebenfalls aktiviert. Dies ist der Standardbetriebsmodus.

Wenn hWin weggelassen wird oder gleich Null (0) ist, wird das aktuell angehängte Grafikfenster instabil.

Siehe auch

  • GRAFISCHES FENSTER VERDECKEN
  • GRAFIKFENSTER MINIMIEREN
  • GRAFIKFENSTER NORMALISIEREN
  • GRAFISCHES FENSTER STABILISIEREN

PBXB64-Umsetzungshinweise

GRAFIKFENSTER NICHT STABIL gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIKFENSTER NICHT STABIL ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIKFENSTER NICHT STABIL mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIKFENSTER NORMALISIEREN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIKFENSTER NORMALISIEREN

GRAFIKFENSTER NORMALISIEREN

Machen Sie ein

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC WINDOW NORMALIZE [ hWin ]

Beschreibung

Das durch den Handle hWin identifizierte GRAFIKFENSTER wird sichtbar gemacht. Wenn hWin weggelassen wird oder gleich Null (0) ist, wird das aktuell angehängte Grafikfenster sichtbar gemacht.

Siehe auch

  • GRAFISCHES FENSTER VERDECKEN
  • GRAFIKFENSTER MINIMIEREN
  • GRAFIKFENSTER NICHT STABIL
  • GRAFISCHES FENSTER STABILISIEREN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

PBXB64-Umsetzungshinweise

GRAFIKFENSTER NORMALISIEREN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFIKFENSTER NORMALISIEREN ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFIKFENSTER NORMALISIEREN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GRAFIKFENSTER STABILISIEREN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GRAFIKFENSTER STABILISIEREN

GRAFISCHES FENSTER STABILISIEREN

Machen Sie ein

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

GRAPHIC WINDOW STABILIZE [ hWin ]

Beschreibung

Das durch das Handle hWin identifizierte GRAFIKFENSTER ist stabilisiert, d. h. es kann vom Benutzer nicht geschlossen werden. Wenn ein Systemmenü vorhanden ist, sind die Schließoption und das Schließfeld ausgegraut. Die Schließen-Taste ALT-F4 ist deaktiviert. Dadurch können Sie sicher sein, dass Ihre Vorgänge im Grafikfenster abgeschlossen werden können. Wenn ein Grafikfenster stabilisiert ist, kann es nur durch GRAPHIC WINDOW END oder Programmbeendigung geschlossen werden.

Siehe auch

  • GRAFISCHES FENSTERENDE
  • GRAFISCHES FENSTER VERDECKEN
  • GRAFIKFENSTER MINIMIEREN
  • GRAFIKFENSTER NICHT STABIL
  • GRAFIKFENSTER NORMALISIEREN

PBXB64-Umsetzungshinweise

GRAFISCHES FENSTER STABILISIEREN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

GRAFISCHES FENSTER STABILISIEREN ist ein GRAPHIC-Befehl fuer ein Grafikziel. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende ausgewaehltes Grafikobjekt bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Zielauswahl

GRAPHIC-Seiten sollen immer sagen, welches Ziel gerade aktiv ist: ein Grafikfenster, ein Bitmap oder ein anderes ausgewähltes Ziel. Das Beispiel sollte die Auswahl mit GRAPHIC ATTACH herstellen, eine Zeichnung ausführen und zeigen, dass alle Folgeaufrufe auf genau diesem Ziel arbeiten.

Koordinatensystem und Zustand

Geben Sie an, welche Einheiten gelten und wie sich der Ursprung verhält. Wenn eine Seite mit Pixeln, client area oder gespeicherten Zeichenzuständen arbeitet, muss das Beispiel die Wirkung mit einem Ruecklese-Aufruf wie GRAPHIC GET PIXEL, GRAPHIC GET SCALE oder einer vergleichbaren Pruefung sichtbar machen.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' GRAFISCHES FENSTER STABILISIEREN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


Grafiken – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Grafiken

Grafiken

Diese Version von PowerBASIC bietet ein hervorragendes Grafikpaket für fast jeden Programmierbedarf. Es ist schnell. Es ist vollständig. Und es kümmert sich automatisch um all diese komplizierten Windows-Details für Sie!

Typ:Schlüsselwort |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Erstens ist es gut zu wissen, dass Grafiken in PowerBASIC persistent sind. Erstelle es einmal... und vergiss es. Sie müssen sich nie wieder Gedanken über ein Neuzeichnen machen, wenn Ihr Fenster minimiert oder vorübergehend abgedeckt ist. PowerBASIC kümmert sich um alles. Automatisch!

Wie wäre es also mit einem kurzen Überblick? Was können Sie tun? Wie wäre es zunächst mit einem ausgefallenen Text? Jede Schriftart. Jede Größe. Jede Farbe. Deutlich. Kursiv. Unterstreichen und Durchstreichen. Mischen Sie beliebige Kombinationen von Schriftarten in einem einzigen Fenster. Drucken Sie fast alles, fast überall. Fügen Sie dann Bitmaps hinzu. Dehnen Sie sie oder verdichten Sie sie. Kopieren Sie sie oder ändern Sie sie. Kreise, Ovale, Linien und Kästchen. Dicke Linien, dünne Linien, Ellipsen, abgerundete Rechtecke. Ausgefüllte Formulare oder leer. Farben hin oder her. Sie erstellen ein benutzerdefiniertes Skalierungssystem – sogar mit gebrochenen Gleitkommakoordinaten!

Also, fangen wir an. Sie sollten wissen, dass fast jeder grafische Funktionsname mit dem Wort GRAPHIC beginnt. Sie finden sie alle zusammen in der Hilfedatei oder im Buch.

Schritt eins: Sie benötigen eine Leinwand. Ein Ort, um diese Kunstwerke zu schaffen. Erstellen Sie also ein GRAFIKFENSTER. Oder zwei. Oder zehn. Sie sind sofort sichtbar und geben Ihnen schnelles Feedback.

Siehe auch

  • GRAPHIC ATTACH
  • DIALOG SHOW MODAL
  • CONTROL GET TEXT

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Dialog, Grafikfenster oder Druckkontext erzeugen.
    ' Konkrete Befehle aus den verlinkten Seiten anwenden.
    ' Ergebnisse pruefen und Ressourcen freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.

Beschreibung

Grafiken ist eine Uebersichtsseite fuer verwandte GUI- und Grafikbefehle. Sie fasst die Familie zusammen und verweist auf die konkreten Befehlsseiten, auf denen die getestete Syntax und das Laufzeitverhalten dokumentiert sind.

Syntax

' Uebersicht nur.
' Verwenden Sie die verlinkten Mitgliedsseiten fuer die exakten Befehlsformen.

Uebersicht und Einstieg

Grafiken ist eine Uebersichtsseite fuer verwandte GUI- und Grafikbefehle. Verwenden Sie diese Seite als Orientierung, waehrend die konkrete Syntax und die getesteten Details auf den einzelnen Befehlsseiten dokumentiert sind.

Typischer Aufbau

Ein vollstaendiges GUI- oder Grafikprogramm erzeugt zuerst Dialog, Grafikfenster oder Druckkontext, fuegt danach Controls oder Zeichenoperationen hinzu, fragt Zustand ab und gibt Ressourcen am Ende geordnet frei. Diese Reihenfolge macht Fehler bei Handles, IDs und Koordinatensystemen leichter nachvollziehbar.

Verlinkte Befehlsgruppen

  • DIALOG NEW und verwandte DIALOG-Befehle fuer Fenster und Dialogzustand.
  • CONTROL ADD und verwandte CONTROL-Befehle fuer Steuerelemente.
  • GRAPHIC WINDOW und verwandte GRAPHIC-Befehle fuer Zeichenausgabe.
  • XPRINT ATTACH und verwandte XPRINT-Befehle fuer Druckausgabe.

Siehe auch

  • GRAPHIC ATTACH
  • DIALOG SHOW MODAL
  • CONTROL GET TEXT

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Dialog, Grafikfenster oder Druckkontext erzeugen.
    ' Konkrete Befehle aus den verlinkten Seiten anwenden.
    ' Ergebnisse pruefen und Ressourcen freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


GUID$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GUID$

GUID$

Gibt einen 16-Byte (128-Bit) Globally Unique Identifier zurück (

Typ:Funktion |Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

id$ = GUID$[()]
id$ = GUID$(guidtext$)

Beschreibung

Die GUID$-Funktion ohne Parameter (oder einen Null-String-Parameter mit der Länge Null) gibt eine neue, eindeutige 16-Byte-String-GUID (Globally Unique Identifier) zurück. Diese GUID kann als neue Klassenkennung oder Schnittstellenkennung oder für einen anderen Zweck verwendet werden, bei dem eine eindeutige Kennung erforderlich sein kann, beispielsweise für einen einmaligen Verschlüsselungsschlüssel.

Wenn guidtext$ angegeben ist, untersucht GUID$ eine Textzeichenfolge, konvertiert die erste menschenlesbare GUID im Standardformat, die es findet, und gibt eine 16-Byte-Binärzeichenfolge zurück. Diese 16-Byte-Zeichenfolge enthält die interne GUID-Darstellung als 128-Bit-Datenelement.

Um gültig zu sein, muss die GUID-Zeichenfolge in guidtext$ string genau 32 hexadezimale Ziffern enthalten, optional durch Leerzeichen oder Bindestriche getrennt, die jedoch insgesamt in geschweifte Klammern eingeschlossen sein müssen. Beispiel: „{01234567-89AB-CDEF-FEDC-BA9876543210}“.

Die GUID$-Funktion ist die logische Ergänzung zur GUIDTXT$-Funktion.

Die Rückgabezeichenfolge kann einer dynamischen Zeichenfolge oder einer Zeichenfolge fester Länge von mindestens 16 Bytes oder (typischerweise) einer GUID-Variablen zugewiesen werden. Weitere Informationen zum Erstellen von GUID-Variablen finden Sie unter DIM.

Einschränkungen

Wenn Fehler auftreten, gibt GUID$ anstelle der 16-Byte-GUID-Zeichenfolge eine Nullzeichenfolge (Nulllänge) zurück. GUID$ kann auch in String-Equate-Zuweisungen verwendet werden, sofern eine explizite, für Menschen lesbare GUIDTXT$-Argumentzeichenfolge zugewiesen wird. Zum Beispiel:

$AppGuid = GUID$("{01234567-89AB-CDEF-FEDC-BA9876543210}")

Siehe auch

  • DIM
  • CLSID$
  • GUIDTXT$
  • Wie werden GUIDs mit Objekten verwendet?
  • INTERFACE (Direct)
  • INTERFACE (IDBind)
  • ISINTERFACE
  • ISNOTHING
  • ISOBJECT
  • Just what is COM?
  • LET (with Objects)
  • OBJECT
  • OBJACTIVE
  • OBJPTR
  • OBJRESULT
  • PROGID$
  • Was ist überhaupt ein Objekt?

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GUIDTXT$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GUIDTXT$

GUIDTXT$

Gibt einen für Menschen lesbaren 38-Byte-Globally Unique Identifier zurück (

Typ:Funktion |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

id$ = GUIDTXT$( guid16$ )

Beschreibung

Die GUIDTXT$-Funktion verwendet einen Zeichenfolgenparameter guid16$, der genau 16 Byte lang sein muss (und eine 128-Bit-GUID-Zeichenfolge darstellt) und gibt eine 38-Byte-GUID-Textzeichenfolge zurück. guid16$ ist normalerweise eine GUID-Variable, kann aber auch eine dynamische Zeichenfolge oder eine Zeichenfolge fester Länge usw. sein.

Die GUIDTXT$-Funktion ist die logische Ergänzung zur GUID$-Funktion.

Einschränkungen

Wenn Fehler auftreten, gibt GUIDTXT$ anstelle der 38-Byte-GUID-Textzeichenfolge eine Nullzeichenfolge (Nulllänge) zurück.

Siehe auch

  • DIM
  • CLSID$
  • GUID$
  • INTERFACE (Direct)
  • INTERFACE (IDBind)
  • ISINTERFACE
  • ISNOTHING
  • ISOBJECT
  • LET (with Objects)
  • OBJECT
  • OBJACTIVE
  • OBJPTR
  • OBJRESULT
  • PROGID$
  • Was ist überhaupt ein Objekt?

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


HEADER GET COUNT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › HEADER GET COUNT

HEADER GET COUNT

Bearbeiten Sie ein HEADER-Steuerelement, um Daten festzulegen/abzurufen.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL SET HEADER hDlg , id& , item& , Text$ [TO ResultVar&]
HEADER GET COUNT hWin , ID& TO CountVar&
HEADER GET ITEM hWin , ID& , Index& , ItemPtr [TO ResultVar&]
HEADER SEND hWin , ID& , Msg& , wParam& , lParam& [TO ResultVar& ]
HEADER SET ITEM hWin , ID& , Index& , ItemPtr [TO ResultVar&]

Beschreibung

Die HEADER-Anweisung wird zur Kommunikation mit einem HEADER-Steuerelement verwendet, um verschiedene Datentypen festzulegen oder abzurufen. Während Sie ein benutzerdefiniertes Header-Steuerelement für Ihre eigenen Zwecke erstellen können, besteht die häufigste Verwendung darin, mit dem HEADER-Steuerelement zu kommunizieren, das in jedes LISTVIEW-Steuerelement eingebettet ist.

Um mit einem LISTVIEW HEADER zu kommunizieren, verwenden Sie LISTVIEW GET HEADERID, um die Werte für die Parameter hWin und ID& abzurufen. Andernfalls würden diese Parameter wie bei jedem anderen Steuerelement zugewiesen.

HEADER GET COUNT hWin , ID& TO CountVar&

Ruft die Anzahl der Elemente in einem Header-Steuerelement ab. Wenn die Operation erfolgreich war, wird der Zählwert der durch CountVar& angegebenen Variablen zugewiesen. Wenn die Operation fehlschlägt, wird CountVar& stattdessen der Wert -1 zugewiesen.

HEADER GET ITEM hWin , ID& , Index& , ItemPtr [TO ResultVar& ]

Ruft eine HD_Item-Struktur ab, die ein Element in einem Header-Steuerelement beschreibt. Index& definiert das abzurufende Element (1=erstes, 2=zweite usw.). ItemPtr ist die Adresse einer zu füllenden HD_Item-Struktur. Wenn der Vorgang erfolgreich ist, wird der durch ResultVar& angegebenen Variablen true zugewiesen. Wenn dies fehlschlägt, wird stattdessen false zugewiesen.

HEADER SEND hWin , ID& , Msg& , wParam& , lParam& [TO ResultVar& ]

Eine durch Msg& angegebene Fensternachricht wird zusammen mit nachrichtenabhängigen Parametern (falls vorhanden) an das HEADER-Steuerelement gesendet. Wenn ein Ergebnis zurückgegeben wird, wird es der durch ResultVar& angegebenen Variablen zugewiesen.

HEADER SET ITEM hWin , ID& , Index& , ItemPtr [TO ResultVar& ]

Legt die Attribute des angegebenen Elements in einem Header-Steuerelement fest. Index& definiert das festzulegende Element (1=erstes, 2=zweite usw.). ItemPtr ist die Adresse einer HD_Item-Struktur, die die Attribute definiert. Wenn der Vorgang erfolgreich ist, wird der durch ResultVar& angegebenen Variablen true zugewiesen. Wenn dies fehlschlägt, wird stattdessen false zugewiesen.

CONTROL SET HEADER hDlg , id& , item& , Text$ [TO ResultVar&]

Legt den angezeigten Text für ein Header-Steuerelement fest. Artikelnummern sind einsbasiert. Wenn das Ziel-Header-Steuerelement noch kein Element an dieser Position hat, fügt PBXB64 es ein. Wenn TO angegeben wird, erhält die Ergebnisvariable 1 für Erfolg und 0 für Fehler.

PBXB64-Implementierungshinweise

PBXB64 implementiert HEADER GET COUNT, HEADER GET ITEM, HEADER SEND und HEADER SET ITEM mit eingebetteten Common-Control-Laufzeithilfsprogrammen. GET ITEM und SET ITEM übergeben den HDITEM-Zeiger des Aufrufers direkt an das Header-Steuerelement. Diese Formulare werden von test_header_forms.pb abgedeckt, einschließlich eines Textpuffer-Roundtrips durch den Aufruferspeicher.

Siehe auch

  • Listenansicht

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


HEADERBUILD$ - PBXB64 Help

Startseite › General Reference › HEADERBUILD$

HEADERBUILD$

Build a single HTTP header line.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = HEADERBUILD$(key$, value$)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_headerbuild.html, damit Benutzer HEADERBUILD$ direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Build a single HTTP header line.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL hdr$ hdr$ = HEADERBUILD$("Content-Type", "application/json") PRINT hdr$ ' Content-Type: application/json

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

HEADERBUILD$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

HEADERBUILD$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer URL/header-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

HEADERBUILD$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


HEX$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › HEX$

HEX$

Konvertieren Sie einen ganzzahligen Wert in eine hexadezimale Zeichenfolge

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = HEX$( IntVal [, Digits [, LeadSpaces [, TrailSpaces ]]])

Beschreibung

IntVal is a numeric expression in the range of a 64-bit Quad Integer (-9223372036854775808 to +9223372036854775807). Any fractional part of the value is rounded. The result string is always formatted as an integral number using all the significant digits in IntVal . It is never expressed in scientific notation.

Wenn Digits 0 ist (oder nicht angegeben ist), werden dem numerischen Feld keine führenden Zeichen hinzugefügt. Wenn Digits eine positive Zahl größer als 0 ist, werden der Ergebniszeichenfolge führende Nullen vorangestellt, um die gewünschte Länge zu erreichen. Wenn Digits eine negative Zahl ist, werden führende Leerzeichen hinzugefügt, um die absolute Länge zu erreichen. Die Ziffern können im Bereich von -16 bis +16 liegen.

LeadSpaces specifies additional leading spaces to be prepended, regardless of the length of the numeric portion of the string.

TrailSpaces specifies additional trailing spaces to be appended to the end of the string.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

HEX$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

HEX$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer encoding-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

HEX$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


HI – PBXB64-Compiler-Hilfe

Startseite › Funktionen › HI

Hallo

Extrahieren Sie den signifikantesten (höherwertigen) Teil eines Integrals

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

result = HI( DataType , value )
result = HIBYT( value )
result = HIINT( value )
result = HIWRD( value )

Beschreibung

Der von HI zurueckgegebene Wert ist ohne Vorzeichen, wenn DataType BYTE, WORD, DWORD oder PTR ist, und mit Vorzeichen, wenn DataType INTEGER oder LONG ist. value darf bis zur doppelten Groesse des angegebenen Datentyps reichen. Fuer PTR gibt PBXB64 das hohe DWORD des 64-Bit-Werts zurueck.

b = HI(BYTE, n)

w = HI(WORD, n)

dw = HI(PTR, p)

Einschränkungen

PBXB64 unterstuetzt sowohl die moderne Syntax HI(DataType, value) als auch die alten Hilfsnamen HIBYT, HIINT und HIWRD. Das fokussierte Regressionsbeispiel ist examples/basic/test_hi_lo_mak_typed.pb.

Siehe auch

  • LO
  • MAK

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Hallo soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Hallo mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


HMACSHA256$ - PBXB64 Help

Startseite › General Reference › HMACSHA256$

HMACSHA256$

Berechnet einen HMAC-SHA-256-Digest aus Schluessel und Nachricht.

Kind: Runtime helper | Category: WEB / Runtime Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

digest$ = HMACSHA256$(key$, message$)

Beschreibung

Diese eigene Seite stellt sicher, dass Befehlsuche, Stichwortindex und direkte Dateinamenpruefung die getestete Laufzeitfunktion unmittelbar finden. Die gruppierte WEB-Seite bleibt die breitere Familienreferenz.

Diese Seite dokumentiert einen deterministischen String-Helfer. Kodierungsfunktionen liefern transformierten Text zurueck, waehrend Hash-Funktionen feste, kleingeschriebene Hex-Digests liefern.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL rc AS LONG
    digest$ = HMACSHA256$("key", "data")
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_web_all.pb`.

Grenzen

Dokumentieren Sie hier nur die getesteten Byte- oder String-Transformationen. Wenn es einen Rueckwaerts-Helfer gibt, pruefen Sie ihn separat, statt Symmetrie aus der Vorwaertsform abzuleiten.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

HMACSHA256$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

HMACSHA256$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer hashing-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input bytes, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

HMACSHA256$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


HMACSHA512$ - PBXB64 Help

Startseite › General Reference › HMACSHA512$

HMACSHA512$

Berechnet einen HMAC-SHA-512-Digest aus Schluessel und Nachricht.

Kind: Runtime helper | Category: WEB / Runtime Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

digest$ = HMACSHA512$(key$, message$)

Beschreibung

Diese eigene Seite stellt sicher, dass Befehlsuche, Stichwortindex und direkte Dateinamenpruefung die getestete Laufzeitfunktion unmittelbar finden. Die gruppierte WEB-Seite bleibt die breitere Familienreferenz.

Diese Seite dokumentiert einen deterministischen String-Helfer. Kodierungsfunktionen liefern transformierten Text zurueck, waehrend Hash-Funktionen feste, kleingeschriebene Hex-Digests liefern.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL rc AS LONG
    digest$ = HMACSHA512$("key", "data")
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_web_all.pb`.

Grenzen

Dokumentieren Sie hier nur die getesteten Byte- oder String-Transformationen. Wenn es einen Rueckwaerts-Helfer gibt, pruefen Sie ihn separat, statt Symmetrie aus der Vorwaertsform abzuleiten.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

HMACSHA512$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

HMACSHA512$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer hashing-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input bytes, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

HMACSHA512$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


HOST ADDR – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › HOST ADDR

HOST-ADDR

Übersetzen Sie einen Hostnamen in einen entsprechenden

Typ:Anweisung |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

HOST ADDR [ hostname$ ] TO ip&
HOST ADDR( index& ) TO ip&

Beschreibung

hostname$ ist der Name eines Computers im Netzwerk oder ein Domänenname wie „powerbasic.com“. Wenn hostname$ die Länge Null hat oder nicht angegeben ist, wird die primäre IP-Adresse des aktuellen Computers zurückgegeben.

ip& erhält die IP-Adresse des angegebenen Hostnamens. ip& kann ein REGISTER oder eine Speichervariable sein.

Es ist möglich, dass ein Computer mehr als eine IP-Adresse hat. Wenn Ihr Computer beispielsweise über eine Netzwerkkarte verfügt und Sie über ein Modem ins Internet eingewählt werden, verfügt Ihr Computer über zwei IP-Adressen. Durch Verwendung der indizierten Form der Anweisung:

HOST ADDR(index&) TO ip&

Sie können die erste IP-Adresse mit index& = 1 abrufen, die zweite mit index& = 2 usw. Wenn ip& bei der Rückgabe null (0) enthält, sind auf diesem Computer keine weiteren IP-Adressen abzurufen.

Eine numerische IP-Adresse kann mit dem folgenden Code einfach in eine IP-Adresszeichenfolge mit Punkten umgewandelt werden:

DIM p AS BYTE PTR

HOST ADDR „localhost“ TO ip&

p = VARPTR(ip&)

a$ = USING$("#_.#_.#_.#", @p, @p[1], @p[2], @p[3])

' gibt „127.0.0.1“ zurück

Einschränkungen

Um die IP-Adresse des aktuellen Computers zu erhalten, muss mindestens ein Socket geöffnet sein, oder Sie müssen zuerst den Namen des Computers mithilfe der HOST NAME-Anweisung ermitteln.

Siehe auch

  • HOSTNAME
  • TCP- und UDP-Kommunikation
  • TCP OFFEN
  • UDP OFFEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


HOSTNAME – PBXB64-Compiler-Hilfe

Startseite › Funktionen › HOSTNAME

HOSTNAME

Übersetzen Sie eine

Typ:Anweisung |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

HOST NAME [ ip& ] TO hostname$

Beschreibung

ip& ist die IP-Adresse, die Sie suchen möchten. Wenn ip& null (0) ist oder nicht angegeben ist, wird der Name des aktuellen Computers zurückgegeben. hostname$ erhält den Namen des Hosts, der der IP-Adresse entspricht.

Um eine IP-Adresse in einen Internetdomänennamen zu übersetzen, muss Ihr Computer mit einem DNS-Server im Internet oder lokalen Intranet verbunden sein.

Siehe auch

  • HOST-ADDR
  • TCP- und UDP-Kommunikation
  • TCP OFFEN
  • UDP OFFEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Wie werden GUIDs verwendet? - PBXB64-Compiler-Hilfe

Startseite › Funktionen › Wie werden GUIDs verwendet?
Hilfe zum PBXB64-Compiler

Wie werden GUIDs verwendet?

Beschreibt die GUID-Verwendung mit COM-Klassen und -Schnittstellen.

Typ:Konzeptionell |Kategorie: COM, Objekte und OOP

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Überblick

Dieses Thema bietet Hintergrundinformationen und praktische Anleitungen. Eine detaillierte Syntax finden Sie auf den entsprechenden Befehlsseiten.

Siehe auch

  • Befehlsindex

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Funktionsweise von Fehlerfallen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Funktionsweise von Fehlerfallen

So funktionieren Fehlerfallen

In PowerBASIC sind Fehlercodes – die von den Funktionen ERR oder ERRCLEAR zurückgegeben werden – und Fehler-Traps lokal für jede Sub , Function , Method oder Property . Eine Fehlerfalle fängt nur Fehler ab, die darin auftreten

Typ:Schlüsselwort |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

PowerBASIC verwendet die folgenden Schritte, um zu bestimmen, was zu tun ist, wenn ein Laufzeitfehler auftritt:

Bedenken Sie Folgendes:

ON ERROR GOTO ErrorTrap

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Fehlerpfad-Prüfung

Fehlerbehandlungsseiten sollen den normalen Pfad und den Fehlerpfad zeigen. Ein vollständiges Beispiel löst absichtlich einen bekannten Fehler aus, prüft den dokumentierten Fehlerwert, stellt wieder her oder beendet sauber und zeigt, dass spätere Anweisungen in der erwarteten Reihenfolge laufen.

Zustandsregeln

Dokumentieren Sie, welche Variablen, Handler oder Systemwerte durch die Operation geändert werden. Vermeiden Sie Beispiele, die einen Fehler durch ungeprüftes Weiterlaufen verdecken.

Migrationshinweise

Beim Portieren älteren PB-Codes sind Annahmen zu Zeilennummern, Handler-Gültigkeit, verschachtelten Prozeduren und Windows-API-Fehlern neu zu prüfen.


HTTPCLOSE - PBXB64 Help

Startseite › General Reference › HTTPCLOSE

HTTPCLOSE

Close an HTTP client handle.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

status = HTTPCLOSE(handle)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_httpclose.html, damit Benutzer HTTPCLOSE direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Close an HTTP client handle.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL h AS LONG h = HTTPOPEN("https://example.com", 3000) IF h <> 0 THEN HTTPCLOSE h PRINT "closed" END IF

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

HTTPCLOSE gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

HTTPCLOSE gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer HTTP client-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit HTTPCLOSE frei.

Eingaberegeln

Pruefen Sie den HTTP handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

HTTPCLOSE

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


HTTPOPEN - PBXB64 Help

Startseite › General Reference › HTTPOPEN

HTTPOPEN

Open an HTTP client handle.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

handle = HTTPOPEN(url$, timeout_ms)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_httpopen.html, damit Benutzer HTTPOPEN direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Open an HTTP client handle.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL h AS LONG h = HTTPOPEN("https://api.example.com", 5000) IF h <> 0 THEN PRINT "HTTP handle opened" HTTPCLOSE h END IF

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

HTTPOPEN gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

HTTPOPEN gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer HTTP client-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit HTTPCLOSE frei.

Eingaberegeln

Pruefen Sie den HTTP handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

HTTPOPEN

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


HTTPREQUEST - PBXB64 Help

Startseite › General Reference › HTTPREQUEST

HTTPREQUEST

Send an HTTP request and return the response.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

response$ = HTTPREQUEST(handle, method$, path$, headers$, body$)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_httprequest.html, damit Benutzer HTTPREQUEST direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Send an HTTP request and return the response.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL h AS LONG LOCAL resp$, hdrs$ h = HTTPOPEN("https://api.example.com", 5000) hdrs$ = HEADERBUILD$("Content-Type", "application/json") resp$ = HTTPREQUEST(h, "GET", "/status", hdrs$, "") PRINT resp$ HTTPCLOSE h

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

HTTPREQUEST gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

HTTPREQUEST gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer HTTP client-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit HTTPCLOSE frei.

Eingaberegeln

Pruefen Sie den HTTP handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

HTTPREQUEST

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


ID-Bindung – PBXB64-Compiler-Hilfe

Startseite › Funktionen › ID-Bindung

ID-Bindung

Wie können wir also die Dinge beschleunigen?

Typ:Schlüsselwort |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Nun, der größte Engpass ist die Namenssuche, und damit können wir umgehen! Normalerweise kennen wir alle METHOD-Definitionen zur Kompilierungszeit. Wenn wir dem Compiler die DispIDs und Parameterinformationen zur Kompilierungszeit mitteilen können, kann ein ganzer Schritt eingespart werden! Das nennt man ID-BINDING der Dispatch-Schnittstelle. Wir erstellen eine einfache IDBIND-Schnittstelle, die wie folgt geschrieben ist:

SCHNITTSTELLEN-IDBIND MyDispIfaceName

MEMBER CALL Method1<77> (WideVal AS LONG, WideText AS WSTRING)

MITGLIEDERAUFRUF Methode2<78> ()

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


IDISPINFO.CLEAR - PBXB64 Help

Startseite › General Reference › IDISPINFO.CLEAR

IDISPINFO.CLEAR

Loescht den eingebetteten IDISPINFO-Pseudoobjektzustand.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

IDISPINFO.CLEAR

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. IDISPINFO-Seiten dokumentieren einen kleinen Laufzeitzustand fuer COM-aehnliche Felder. Das Beispiel soll zeigen, welche Felder geschrieben, geloescht und nach einem Reset zurueckgegeben werden und ob unveraenderte Felder eine Teilaktualisierung ueberleben.

Verwendung im Programm

IDISPINFO-Seiten dokumentieren einen kleinen Laufzeitzustand fuer COM-aehnliche Felder. Das Beispiel soll zeigen, welche Felder geschrieben, geloescht und nach einem Reset zurueckgegeben werden und ob unveraenderte Felder eine Teilaktualisierung ueberleben.

Fehlerfaelle

Nur der dokumentierte Feldsatz ist hier im Umfang. Zusaetzliche Editor- oder COM-Metadaten muessen zuerst belegt werden, bevor die Seite breitere Unterstuetzung behaupten kann, und Aufrufer sollen nicht von einer vollstaendigen IDispatch-Implementierung ausgehen.

Zustandsfluss

IDISPINFO.CLEAR setzt den Helferzustand zurueck und IDISPINFO.SET fuellt den Feldsatz fuer die COM-aehnlichen Hilfeseiten. Verwenden Sie beide gemeinsam, damit das Beispiel zeigt, was geschrieben, was geloescht und was nach dem Reset zurueckgegeben wird.

Fehlerhinweise

Behandeln Sie den Helfer als kleinen Zustandsspeicher und nicht als volle COM-Metadaten-Unterstuetzung. Wenn ein Feld fehlt oder der Zustand vor der Wiederverwendung nicht geloescht wurde, sollte der Aufrufer den Zustand neu aufbauen, statt alte Werte als sinnvoll zu behandeln.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    IDISPINFO.CLEAR
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. Nur der dokumentierte Feldsatz ist hier im Umfang. Zusaetzliche Editor- oder COM-Metadaten muessen zuerst belegt werden, bevor die Seite breitere Unterstuetzung behaupten kann, und Aufrufer sollen nicht von einer vollstaendigen IDispatch-Implementierung ausgehen.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


IDISPINFO-Pseudoobjekt – PBXB64-Compiler-Hilfe

Startseite › Funktionen › IDISPINFO-Pseudoobjekt

IDISPINFO-Pseudoobjekt

Legt zusätzliche Informationen zu bestimmten fest und gibt diese zurück

Typ:Schlüsselwort |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

info& = IDISPINFO.CODE
info& = IDISPINFO.CONTEXT
info$ = IDISPINFO.DESC$
info$ = IDISPINFO.HELP$
info$ = IDISPINFO.SOURCE$
IDISPINFO.CLEAR
IDISPINFO.SET code& [, source$ , desc$ , help$ , context& ]

Beschreibung

GET-Eigenschaften

IDISPINFO.CODE

Wenn OBJRESULT %DISP_E_EXCEPTION ist, gibt diese Get-Eigenschaft einen langen ganzzahligen Wert zurück, der einen spezifischeren Fehlercode darstellt. Wenn der Wert kleiner als 65536 ist, wird er als WCODE bezeichnet, der normalerweise von der Anwendung definiert wird, wenn er in 32-Bit- oder 64-Bit-Windows gefunden wird. Viel häufiger sind die größeren Werte, die als SCODE bekannt sind. Diese werden normalerweise von Windows definiert, obwohl anwendungsdefinierte Werte zulässig sind. Die häufigsten sind:

%E_UNEXPECTED = &H8000FFFF&

%E_NOTIMPL = &H80004001&

%E_NOINTERFACE = &H80004002&

%E_POINTER = &H80004003&

%E_ABORT = &H80004004&

%E_FAIL = &H80004005&

%E_ACCESSDENIED = &H80070005&

%E_HANDLE = &H80070006&

%E_OUTOFMEMORY = &H8007000E&

%E_INVALIDARG = &H80070057&

IDISPINFO.CONTEXT

Wenn OBJRESULT %DISP_E_EXCEPTION ist, gibt diese Get-Eigenschaft einen langen ganzzahligen Wert zurück, der den Kontext des Themas in der Hilfedatei (IDISPINFO.HELP$) darstellt. Diese Eigenschaft ist nur gültig, wenn IDISPINFO.HELP eine gültige Zeichenfolge zurückgibt.

IDISPINFO.DESC$

Wenn OBJRESULT %DISP_E_EXCEPTION ist, gibt diese Get-Eigenschaft eine Zeichenfolge zurück, die eine textuelle, für Menschen lesbare Beschreibung des Status enthält. Es soll vom Kunden gelesen werden. Wenn keine Beschreibung verfügbar ist, wird eine Nullzeichenfolge mit der Länge null zurückgegeben.

IDISPINFO.HELP$

Wenn OBJRESULT %DISP_E_EXCEPTION ist, gibt diese Get-Eigenschaft eine Zeichenfolge zurück, die Laufwerk, Pfad und Dateinamen einer Hilfedatei mit weiteren Informationen zu diesem bestimmten Statuscode enthält. Wenn keine Hilfe verfügbar ist, wird eine Nullzeichenfolge mit der Länge null zurückgegeben.

IDISPINFO.PARAM

Wenn OBJRESULT entweder %DISP_E_PARAMNOTFOUND oder %DISP_E_TYPEMISMATCH ist, gibt diese Get-Eigenschaft einen langen ganzzahligen Wert zurück, der die Parameternummer des ersten Parameters darstellt, der die erforderlichen Anforderungen nicht erfüllt hat. Der Wert wird auf Null indiziert, was der Standardnummerierungskonvention für Dispatch-Parameter entspricht. Der erste Parameter ist 0, der zweite ist 1 und so weiter.

IDISPINFO.SOURCE$

Wenn OBJRESULT %DISP_E_EXCEPTION ist, gibt diese Get-Eigenschaft eine Zeichenfolge zurück, die eine textuelle, für Menschen lesbare Beschreibung der Quelle der Ausnahme enthält. Normalerweise ist dies der Anwendungsname. Wenn keine Quelle verfügbar ist, wird eine Nullzeichenfolge mit der Länge null zurückgegeben.

SET-Eigenschaften

IDISPINFO.CLEAR

Löscht alle Eigenschaften, die möglicherweise durch die vorherige Ausführung von IDISPINFO.SET in diesem Thread festgelegt wurden.

IDISPINFO.SET

Diese Anweisung kann in einer METHOD oder PROPERTY auf einer Dual-Schnittstelle ausgeführt werden, sodass der aufrufende Code zusätzliche Informationen über Dispatch-Ausnahmebedingungen erhalten kann. Diese fünf Datenelemente werden in der EXCEPINFO-Struktur an den Aufrufer zurückgegeben, sodass sie mit IDISPINFO GET Properties oder anderen Funktionen in anderen Programmiersprachen abgerufen werden können. Diese Daten sind nur bei Verwendung der Dispatch-Schnittstelle verfügbar. Es ist für direkte Methoden nicht verfügbar. Der erste Parameter ( code& ) ist erforderlich und muss mit dem Wert identisch sein, den Sie mit METHOD OBJRESULT oder PROPERTY OBJRESULT zurückgeben. Das eigentliche OBJRESULT wird dann in %DISP_E_EXCEPTION geändert, sodass der Aufrufer weiß, dass diese Daten ebenfalls abgerufen werden müssen. Beachten Sie, dass die letzten vier Parameter optional sind.

Einschränkungen

IDISPINFO.CODE wird immer auf einen Wert ungleich Null gesetzt, wenn ein OBJECT-Vorgang fehlschlägt, auch für HRESULTs, die keine Ausnahme sind, wie z %DISP_E_MEMBERNOTFOUND. Die übrigen GET-Eigenschaften (SOURCE$, DESC$, HELP$, CONTEXT, PARAM) werden nur ausgefüllt, wenn OBJRESULT vorhanden ist %DISP_E_EXCEPTION.

Siehe auch

  • OBJECT
  • OBJRESULT
  • OBJRESULT$
  • Was ist überhaupt ein Objekt?
  • Was ist VERSAND?

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


IDISPINFO.SET - PBXB64 Help

Startseite › General Reference › IDISPINFO.SET

IDISPINFO.SET

Setzt Code, Kontext, Quelle, Beschreibung und Hilfe-Felder im IDISPINFO-Laufzeitzustand.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

IDISPINFO.SET ...

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. IDISPINFO-Seiten dokumentieren einen kleinen Laufzeitzustand fuer COM-aehnliche Felder. Das Beispiel soll zeigen, welche Felder geschrieben, geloescht und nach einem Reset zurueckgegeben werden und ob unveraenderte Felder eine Teilaktualisierung ueberleben.

Verwendung im Programm

IDISPINFO-Seiten dokumentieren einen kleinen Laufzeitzustand fuer COM-aehnliche Felder. Das Beispiel soll zeigen, welche Felder geschrieben, geloescht und nach einem Reset zurueckgegeben werden und ob unveraenderte Felder eine Teilaktualisierung ueberleben.

Fehlerfaelle

Nur der dokumentierte Feldsatz ist hier im Umfang. Zusaetzliche Editor- oder COM-Metadaten muessen zuerst belegt werden, bevor die Seite breitere Unterstuetzung behaupten kann, und Aufrufer sollen nicht von einer vollstaendigen IDispatch-Implementierung ausgehen.

Zustandsfluss

IDISPINFO.CLEAR setzt den Helferzustand zurueck und IDISPINFO.SET fuellt den Feldsatz fuer die COM-aehnlichen Hilfeseiten. Verwenden Sie beide gemeinsam, damit das Beispiel zeigt, was geschrieben, was geloescht und was nach dem Reset zurueckgegeben wird.

Fehlerhinweise

Behandeln Sie den Helfer als kleinen Zustandsspeicher und nicht als volle COM-Metadaten-Unterstuetzung. Wenn ein Feld fehlt oder der Zustand vor der Wiederverwendung nicht geloescht wurde, sollte der Aufrufer den Zustand neu aufbauen, statt alte Werte als sinnvoll zu behandeln.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    IDISPINFO.SET 1, 2, "src", "desc", "help"
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. Nur der dokumentierte Feldsatz ist hier im Umfang. Zusaetzliche Editor- oder COM-Metadaten muessen zuerst belegt werden, bevor die Seite breitere Unterstuetzung behaupten kann, und Aufrufer sollen nicht von einer vollstaendigen IDispatch-Implementierung ausgehen.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


#IF – PBXB64-Compiler-Hilfe

Startseite › Funktionen › #IF

#IF

Definieren Sie Abschnitte des Quellcodes, die abhängig von einer bestimmten Bedingung kompiliert oder ignoriert werden sollen. Dies wird oft als bedingte Kompilierung bezeichnet.

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET] für Funktionskörper-$IF/#IF; Top-Level-#IF/#ELSEIF/#ELSE/#ENDIF und #IFDEF/#IFNDEF sind implementiert und ab V10 aktiv.

Syntax

#IF [NOT] { %equate | %DEF({ %numeric_equate | $string_equate }) | expression }
[ statements ]
[#ELSEIF [NOT] { %equate | %DEF({ %numeric_equate | $string_equate }) | expression }
[ statements ]]
[#ELSE
#ENDIF

Beschreibung

%equate ist eine benannte Konstante oder ein konstanter Wert. Mit dem %DEF-Operator können Sie testen, ob ein Equate definiert wurde. %DEF gibt TRUE oder FALSE zurück. Typische Verwendung: #IF %DEF(%PB_DLL16) oder #ELSEIF NOT %DEF(%PB_WIN32). Ausdruck kann ein einfacher numerischer Ausdruck sein, der die arithmetischen Operatoren +, -, *, / und \ sowie die relationalen Operatoren >, <, >=, <=, <> und = verwendet und auch die CVQ-Funktion enthalten kann.

PowerBASIC definiert automatisch die Equates in der folgenden Tabelle entsprechend dem verwendeten PowerBASIC-Compiler. Bitte beachten Sie, dass die Verweise auf andere PowerBASIC-Compiler für diejenigen enthalten sind, die Programme schreiben, die möglicherweise von mehr als einem PowerBASIC-Compiler kompilierbar sind.

Gleichsetzen

Definition

%PB_CC32

In PB/CC für Windows als TRUE (ungleich Null) vordefiniert, in anderen Compilern jedoch nicht definiert.

%PB_DLL16

Vordefiniert als TRUE (ungleich Null) in PB/DLL 16-Bit, FALSE (Null) in anderen Compilern.

%PB_DLL32

Synonym von %PB_WIN32

%PB_WIN32

In PB/Win 32-Bit als TRUE (ungleich Null) vordefiniert, in anderen Compilern jedoch nicht definiert.

%PB_REVISION

Vordefiniert als Hex-Revision (10.00 = &H1000).

%PB_REVLETTER

Vordefiniert als ASCII-Code des Revisionsbuchstabens (a = &H61) oder &H20, wenn kein Revisionsbuchstabe vorhanden ist.

%PB_EXE

Vordefiniert als TRUE (ungleich Null) beim Kompilieren in EXE oder als FALSE (Null) beim Kompilieren im DLL-Format (nur PB/Win). Das Äquator %PB_EXE ist in PowerBASIC immer definiert, daher wird %DEF(%PB_EXE) immer als TRUE ausgewertet. Der Unterschied ist der Wert, der dem Equate vom Compiler zugewiesen wird.

Beispiele für gültige Ausdrücke können sein:

#IF %DEBUG = -1&

#IF %DEBUG UND (NICHT %RELEASE)

#IF NICHT %DEBUG

#IF %VERSION <> CVQ("DemoMode")

Beachten Sie, dass die Operatoren AND , OR und NOT in #IF-Metaanweisungen als bitweise Operatoren und nicht als logische Operatoren funktionieren.

Wenn der Wert von %equate oder %DEF ( %equate|$equate ) TRUE (ungleich Null) ist oder wenn das Ergebnis von expression TRUE ist, werden die Anweisungen zwischen #IF und #ELSE oder #ELSEIF kompiliert und die Anweisungen zwischen #ELSE oder #ELSEIF und #ENDIF werden ignoriert.

Wenn der Wert von %equate oder %DEF ( %equate|$equate ) FALSE (null) ist oder das Ergebnis von expression FALSE ist, werden die Anweisungen zwischen #IF und #ELSE oder #ELSEIF ignoriert und diejenigen zwischen #ELSE oder #ELSEIF und #ENDIF kompiliert.

Die Klausel #ELSE oder #ELSEIF und zugehörige Anweisungen sind optional, #ENDIF ist jedoch erforderlich.

Bedingte Kompilierungsanweisungen können bis zu 16 Ebenen tief verschachtelt werden. Ein Hauptzweck der bedingten Kompilierung besteht darin, Testcode in Ihre Programme einzubinden, der während der Programmentwicklung (jedoch nicht im Endprodukt) kompiliert wird, und die Erstellung spezieller Editionen einer Anwendung aus einer einzigen Quellcodedatei zu erleichtern.

Es ist möglich, bitweise Operationen an Gleichheiten durchzuführen, um ein TRUE/FALSE-Ergebnis zu erzeugen. Zum Beispiel:

#IF (%PB_REVISION AND &H0FF00) - &H0700

SoftwareVersion$ = „nicht 7.x“

SoftwareVersion$ = "7.x"

#ENDIF

PBXB64-Hinweise

  • Die Top-Level-bedingte Kompilierung wird nach der #INCLUDE-Erweiterung und vor dem Lowering der Routinen verarbeitet. #DEFINE und #UNDEF in aktiven Zweigen werden sofort angewendet, sodass spätere Top-Level-Bedingungen sie sehen.
  • Inaktive Zweige werden vor der Deklarationssuche entfernt; #DEFINE in einem inaktiven Zweig ist nicht sichtbar.
  • Verschachtelte #IF/$IF-Blöcke werden unterstützt. Der Top-Level-Durchlauf von PBXB64 hat derzeit eine interne 256-Ebenen-Sicherung; halten Sie die Verschachtelung für PBWin-Portabilität flach.
  • #ELSEIF verfolgt, ob bereits ein früherer Zweig ausgewählt wurde, sodass spätere Zweige nach einem wahren #IF inaktiv bleiben. Das ist sowohl für Top-Level-Bedingungen als auch für Funktionskörper-Bedingungen getestet.
  • Abgedeckt durch tests/pb/test_pp_top_level_conditional.pb, tests/pb/test_pp_top_level_elseif.pb, examples/basic/test_pp_dollar_if.pb und tests/pb/test_pp_function_body_elseif.pb.

Siehe auch

  • %DEF-Operator
  • IF-Anweisung
  • IF-Block

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für #IF soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' #IF mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


IF/END IF – PBXB64-Compiler-Hilfe

Startseite › Funktionen › IF/END IF

IF/END IF

Erstellen Sie IF/THEN/ELSE-Konstrukte mit mehreren Zeilen und/oder Bedingungen.

Typ:Schlüsselwort |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

IF integer_expression THEN
[ statements ]
[ELSEIF integer_expression THEN
[ statements ]]
[ELSE
END IF

Beschreibung

Beim Ausführen von IF-Blöcken wird zunächst die Wahrheit des Ganzzahlausdrucks in der anfänglichen IF-Anweisung überprüft. Wenn die Auswertung FALSE (Null) ergibt, wird jede der folgenden ELSEIF-Anweisungen der Reihe nach geprüft. Es können beliebig viele ELSEIF-Anweisungen vorhanden sein. Sobald festgestellt wird, dass eine davon TRUE (ungleich Null) ist, führt PowerBASIC die Anweisung(en) nach dem zugehörigen THEN und vor dem nächsten ELSEIF oder ELSE aus.

Die Ausführung springt dann direkt nach dem abschließenden END IF zur Anweisung, ohne weitere Tests durchzuführen. Wenn keiner der Testausdrücke TRUE ergibt, werden die Anweisungen in der ELSE-Klausel (die optional ist) ausgeführt.

Beachten Sie, dass in einem IF-Block nichts nach dem THEN-Schlüsselwort stehen darf. So unterscheidet der Compiler einen IF-Block von einer herkömmlichen IF-Anweisung. Es darf auch nichts in derselben Zeile wie ELSE stehen (außer Bemerkungen).

IF-Blöcke können verschachtelt werden; Das heißt, jede der Anweisungen nach einem der THENs kann IF-Blöcke enthalten. Obwohl es dem Compiler egal ist, wird die Klarheit des Quellcodes verbessert, indem die von jedem Test gesteuerten Anweisungen um einige Leerzeichen eingerückt werden, wie im Beispiel gezeigt.

IF-Blöcke müssen mit einer passenden END IF-Anweisung abgeschlossen werden. Beachten Sie, dass die Anweisung END IF ein Leerzeichen erfordert, die Anweisung ELSEIF jedoch nicht.

Hinweise zur Kurzschlussbewertung von PowerBASIC und ihren möglichen Nebenwirkungen finden Sie in der IF-Anweisung.

Siehe auch

  • CHOOSE
  • WÄHLEN&
  • WÄHLEN$
  • AUSFAHRT
  • IF
  • IIF
  • IIF&
  • IIF$
  • MAX
  • MAX&
  • MAX$
  • MIN
  • MIN&
  • MIN$
  • SELECT
  • Kurzschlussauswertung
  • SWITCH
  • SWITCH&
  • SWITCH$
  • SELECT

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_if_else_1
FUNCTION PBMAIN() AS LONG
  LOCAL x AS LONG
  IF 1 = 1 THEN
    x = 1
  ELSE
    x = 0
  END IF
  IF (x) <> (1) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_if_else_2
FUNCTION PBMAIN() AS LONG
  LOCAL x AS LONG
  IF 1 = 0 THEN
    x = 1
  ELSE
    x = 0
  END IF
  IF (x) <> (0) THEN FUNCTION = 2: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_if_else_3
FUNCTION PBMAIN() AS LONG
  LOCAL x AS LONG
  IF 5 > 3 THEN
    x = 1
  ELSE
    x = 0
  END IF
  IF (x) <> (1) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_if_else_4
FUNCTION PBMAIN() AS LONG
  LOCAL x AS LONG
  IF 3 > 5 THEN
    x = 1
  ELSE
    x = 0
  END IF
  IF (x) <> (0) THEN FUNCTION = 4: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_if_else_5
FUNCTION PBMAIN() AS LONG
  LOCAL x AS LONG
  IF 5 >= 5 THEN
    x = 1
  ELSE
    x = 0
  END IF
  IF (x) <> (1) THEN FUNCTION = 5: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_if_else_6
FUNCTION PBMAIN() AS LONG
  LOCAL x AS LONG
  IF 5 <= 4 THEN
    x = 1
  ELSE
    x = 0
  END IF
  IF (x) <> (0) THEN FUNCTION = 6: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_if_else_7
FUNCTION PBMAIN() AS LONG
  LOCAL x AS LONG
  IF 1 <> 2 THEN
    x = 1
  ELSE
    x = 0
  END IF
  IF (x) <> (1) THEN FUNCTION = 7: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_if_else_8
FUNCTION PBMAIN() AS LONG
  LOCAL x AS LONG
  IF 2 <> 2 THEN
    x = 1
  ELSE
    x = 0
  END IF
  IF (x) <> (0) THEN FUNCTION = 8: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_if_single_9
FUNCTION PBMAIN() AS LONG
  LOCAL x AS LONG
  x = 0
  IF 1 = 1 THEN x = 1
  IF (x) <> (1) THEN FUNCTION = 9: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_if_single_10
FUNCTION PBMAIN() AS LONG
  LOCAL x AS LONG
  x = 0
  IF 1 = 0 THEN x = 1
  IF (x) <> (0) THEN FUNCTION = 10: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


IIF – PBXB64-Compiler-Hilfe

Startseite › Funktionen › IIF

IIF

Gibt einen von zwei Werten basierend auf a zurück

Typ:Funktion |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET] für numerisches IIF; IIF$ implementiert und getestet

Syntax

var = IIF( num_expression , truepart , falsepart )
var& = IIF&( num_expression , truepart& , falsepart& )
var$ = IIF$( num_expression , truepart$ , falsepart$ )

Beschreibung

IIF erwartet Teile jeden numerischen Typs. IIF& erwartet Teile, die für den Typ Long Integer optimiert sind. IIF$ erwartet Teile vom Typ String.

Wenn num_expression TRUE (ungleich Null) ergibt, wird der wahre Teil zurückgegeben, andernfalls wird der falsche Teil zurückgegeben. num_expression wird als normaler boolescher PowerBASIC-Ausdruck ausgewertet, der bei Bedarf eine Auswertung von Kurzschlussausdrücken ermöglicht.

IIF(1 AND 2, 3, 4) würde den wahren Teil (3) zurückgeben, da beide Begriffe in num_expression WAHR sind und daher als WAHR ausgewertet werden.

Um eine bitweise Auswertung von num_expression zu erzwingen, schließen Sie es in Klammern ein. Beispielsweise würde IIF$( (1 AND 2), „True“, „False“) „False“ zurückgeben.

IIF% gilt als gültiges Synonym für IIF&.

Einschränkungen

Der Compiler erzeugt bedingte Sprünge, sodass der nicht ausgewählte Zweig bei einfachen Literal- und Variablenargumenten zur Laufzeit nicht ausgeführt wird. Da Funktionsargumente vor dem IIF/IIF$-Aufruf ausgewertet werden, können Ausdrücke mit Funktionsaufrufen und Seiteneffekten dennoch auf beiden Seiten ausgewertet werden.

Siehe auch

  • CHOOSE
  • WÄHLEN&
  • WÄHLEN$
  • SWITCH
  • SWITCH&
  • SWITCH$

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


IMAGELIST BITMAP HINZUFÜGEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › IMAGELIST BITMAP HINZUFÜGEN

BILDLISTE BITMAP HINZUFÜGEN

Erstellen und verwalten Sie ein IMAGELIST-Objekt zur Verwendung mit anderen Funktionen.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

PBXB64 implementiert IMAGELIST mit eingebetteten Win32-Common-Control-Laufzeitaufrufen. Die zertifizierte Regression umfasst die Erstellung, das Hinzufügen von Bitmap-Handles, das Ersetzen von Bitmaps, die Bildfreigabe, das Abrufen der Anzahl, die Zuweisung von Overlays, die Zerstörung und das Anhängen an CONTROL-, LISTVIEW-, TREEVIEW-, TAB- und TOOLBAR-Steuerelemente.

Syntax

IMAGELIST ADD BITMAP hLst , hBmp [, hMsk ] [TO dataValue& ]
IMAGELIST ADD BITMAP hLst , Bmp$ [, Msk$ ] [TO dataValue& ]
IMAGELIST ADD ICON hLst , hIcn [TO dataValue& ]
IMAGELIST ADD ICON hLst , Icn$ [TO dataValue& ]
IMAGELIST ADD MASKED hLst , hBmp , rgbColor& [TO dataValue& ]
IMAGELIST ADD MASKED hLst , Bmp$ , rgbColor& [TO dataValue& ]
IMAGELIST GET COUNT hLst TO dataValue&
IMAGELIST KILL hLst
IMAGELIST NEW BITMAP|ICON nWidth& , nHeight& , depth& , initial& TO hLst
IMAGELIST RELEASE hLst , image& [TO dataValue&]
IMAGELIST REPLACE BITMAP hLst , image& , hBmp [, hMsk ] [TO dataValue&]
IMAGELIST REPLACE BITMAP hLst , image& , Bmp$ [, Msk$ ] [TO dataValue&]
IMAGELIST SET OVERLAY hLst , image& , overlay&

Beschreibung

Eine IMAGELIST ist eine Struktur, die eine beliebige Anzahl grafischer Bilder enthält, entweder Bitmaps oder Symbole, jedoch keine Mischung. Alle Bilder werden automatisch in den Typ, die Größe und die Farbtiefe konvertiert, die beim Erstellen der IMAGELIST angegeben wurden. Eine Bitmap (Dateityp *.BMP) ist ein einfarbiges Bild, während ein Symbol (Dateityp *.ICO) Transparenz unterstützt, indem es sowohl eine Farbbitmap als auch eine Maskenbitmap enthält. Die Maskenbitmap ist ein monochromes Bild (ein Bit pro Pixel), wobei jedes „gesetzte“ Bit ein Pixel beschreibt, das transparent bleibt. Die IMAGELIST-Struktur kann am besten als eine Menge oder ein Array von Bildern beschrieben werden. Sie können die Bilder einzeln nach Indexnummer abrufen oder die gesamte IMAGELIST an ein Steuerelement übergeben, das sie benötigt (LISTVIEW usw.).

Mit IMAGELIST NEW wird zunächst eine leere ImageList erstellt. Anschließend werden mit IMAGELIST ADD Bilder hinzugefügt, bis die Struktur vollständig ist. Wenn Sie ein Bild hinzufügen, das breiter als die durch nWidth& angegebene Größe ist, wird das Bild in mehrere Bitmaps aufgeteilt, die jeweils nacheinander hinzugefügt werden. Wenn eine IMAGELIST an ein Steuerelement wie LISTVIEW angehängt wird, wird sie normalerweise automatisch zerstört, wenn das Steuerelement zerstört wird. Weitere Informationen finden Sie in der Kontrolldokumentation. Wenn nicht, müssen Sie es explizit mit IMAGELIST KILL zerstören.

IMAGELIST BITMAP HINZUFÜGEN hLst , hBmp [, hMsk ] [TO dataValue& ]

Ein Bild wird der durch hLst angegebenen ImageList hinzugefügt. Bei dieser Syntax wird das Bild durch ein Handle ( hBmp ) spezifiziert, es muss also in den Speicher geladen worden sein (z. B. mit string ). Wenn es sich bei der ImageList um einen ICON-Typ handelt, wird auch eine zweite Maskenbitmap durch ein Handle (hMsk) angegeben. Wenn die TO-Klausel enthalten ist, wird die Indexposition der ersten hinzugefügten Bitmap (beginnend mit 1) der durch dataValue& bezeichneten Variablen zugewiesen. Wenn die Operation fehlschlägt, wird der Wert 0 zugewiesen.

IMAGELIST BITMAP HINZUFÜGEN hLst , Bmp$ [, Msk$ ] [TO dataValue& ]

Ein Bild wird der durch hLst angegebenen ImageList hinzugefügt. Bei dieser Syntax wird das Bild durch eine Namenszeichenfolge (Bmp$) angegeben, bei der es sich um den Namen einer eingebetteten Ressource oder einer Festplattendatei handelt. Wenn die Namenszeichenfolge einen Punkt enthält, wird davon ausgegangen, dass es sich um eine Festplattendatei handelt. Andernfalls wird versucht, sie von einer Ressource zu laden. Wenn sie nicht gefunden wird, wird davon ausgegangen, dass es sich um eine Festplattendatei handelt. Wenn der Bildname eine numerische Ressource ist, sollte er mit einem führenden Nummernzeichen („#12345“) beschrieben werden. Wenn es sich bei der ImageList um einen ICON-Typ handelt, wird auch eine zweite Maskenbitmap durch ein Handle (hMsk) angegeben. Wenn die TO-Klausel enthalten ist, wird die Indexposition der ersten hinzugefügten Bitmap (beginnend mit 1) der durch dataValue& bezeichneten Variablen zugewiesen. Wenn die Operation fehlschlägt, wird der Wert 0 zugewiesen.

IMAGELIST SYMBOL HINZUFÜGEN hLst , hIcn [TO dataValue& ]

Der durch hLst angegebenen ImageList wird ein Symbol hinzugefügt. Bei dieser Syntax wird das Symbol durch ein Handle ( hIcn ) angegeben, es muss also in den Speicher geladen worden sein (z. B. mit dem WinApi LoadIcon). Wenn die TO-Klausel enthalten ist, wird die Indexposition des ersten hinzugefügten Symbols (beginnend mit 1) der durch dataValue& bezeichneten Variablen zugewiesen. Wenn die Operation fehlschlägt, wird der Wert 0 zugewiesen.

IMAGELIST ADD ICON hLst , Icn$ [TO dataValue& ]

Der durch hLst angegebenen ImageList wird ein Symbol hinzugefügt. Bei dieser Syntax wird das Symbol durch eine Namenszeichenfolge ( Icn$ ) angegeben, bei der es sich um den Namen einer eingebetteten Ressource oder einer Festplattendatei handelt. Wenn die Namenszeichenfolge einen Punkt enthält, wird davon ausgegangen, dass es sich um eine Festplattendatei handelt. Andernfalls wird versucht, sie von einer Ressource zu laden. Wenn sie nicht gefunden wird, wird davon ausgegangen, dass es sich um eine Festplattendatei handelt. Wenn der Symbolname eine numerische Ressource ist, sollte er mit einem führenden Nummernzeichen („#12345“) beschrieben werden. Wenn die TO-Klausel enthalten ist, wird die Indexposition der ersten hinzugefügten Bitmap (beginnend mit 1) der durch dataValue& bezeichneten Variablen zugewiesen. Wenn die Operation fehlschlägt, wird der Wert 0 zugewiesen.

IMAGELIST MASKIERTE hLst, hBmp, rgbColor& [TO dataValue&] HINZUFÜGEN

Der durch hLst angegebenen Symbol-ImageList wird eine Bitmap hinzugefügt. Bei dieser Syntax wird die Bitmap durch ein Handle ( hBmp ) spezifiziert, sie muss also in den Speicher geladen worden sein (z. B. mit GRAPHIC BITMAP). Der Parameter rgbColor& gibt die RGB-Farbe an, die in der Bitmap zur Angabe transparenter Pixel verwendet wird. Jedes Pixel dieser Farbe wird in die Farbe Schwarz geändert und eine Maskenbitmap wird erstellt, um die transparenten Pixel zu beschreiben. Wenn die TO-Klausel enthalten ist, wird die Indexposition des ersten hinzugefügten Symbols (beginnend mit 1) der durch dataValue& bezeichneten Variablen zugewiesen. Wenn die Operation fehlschlägt, wird der Wert 0 zugewiesen.

IMAGELIST MASKIERTE HINZUFÜGEN hLst , Bmp$ , rgbColor& [TO dataValue& ]

Der durch hLst angegebenen Symbol-ImageList wird eine Bitmap hinzugefügt. Bei dieser Syntax wird die Bitmap durch eine Namenszeichenfolge ( Bmp$ ) angegeben, bei der es sich um den Namen einer eingebetteten Ressource oder einer Festplattendatei handelt. Wenn die Namenszeichenfolge einen Punkt enthält, wird davon ausgegangen, dass es sich um eine Festplattendatei handelt. Andernfalls wird versucht, sie von einer Ressource zu laden. Wenn sie nicht gefunden wird, wird davon ausgegangen, dass es sich um eine Festplattendatei handelt. Wenn der Bildname eine numerische Ressource ist, sollte er mit einem führenden Nummernzeichen („#12345“) beschrieben werden. Der Parameter rgbColor& gibt die RGB-Farbe an, die in der Bitmap zur Angabe transparenter Pixel verwendet wird. Jedes Pixel dieser Farbe wird in die Farbe Schwarz geändert und eine Maskenbitmap wird erstellt, um die transparenten Pixel zu beschreiben. Wenn die TO-Klausel enthalten ist, wird die Indexposition der ersten hinzugefügten Bitmap (beginnend mit 1) der durch dataValue& bezeichneten Variablen zugewiesen. Wenn die Operation fehlschlägt, wird der Wert 0 zugewiesen.

IMAGELIST GET COUNT hLst TO dataValue&

Die Anzahl der Bilder in der IMAGELIST wird abgerufen und der durch dataValue& angegebenen langen Ganzzahlvariablen zugewiesen.

IMAGELIST KILL hLst

Die durch hLst angegebene IMAGELIST wird zerstört. Der gesamte zugewiesene Speicher und alle Ressourcen werden freigegeben.

BILDLISTE NEUES BITMAP|ICON nWidth& , nHeight& , Depth& , initial& TO hLst

Eine neue ImageList-Struktur wird erstellt. Wenn Sie BITMAP angeben, wird jedes von Ihnen hinzugefügte Bild als einzelne Bitmap gespeichert. Wenn Sie ICON angeben, wird jedes von Ihnen hinzugefügte Bild als zwei Bitmaps gespeichert, um transparente Bereiche zu unterstützen. Die Parameter nWidth& und nHeight& geben die Größe jedes Bildes in Pixeln an. Der Parameter Depth& gibt die Farbtiefe in Bits pro Pixel (4,8,16,24,32) an. Eine Tiefe von 4 bietet 16 Farben, 8 bietet 256 Farben usw. Der Parameter initial& gibt die anfängliche Größe der ImageList an. Obwohl diese Zahl überschritten werden kann, ist es am effizientesten, den Speicherplatz zum Zeitpunkt der Erstellung genau zuzuweisen. Die Variable hLst erhält das Handle der neu erstellten ImageList oder Null, wenn der Vorgang fehlgeschlagen ist.

IMAGELIST RELEASE hLst , image& [TO dataValue&]

Der einsbasierte Bildindex image& wird aus der ImageList entfernt. Wenn TO angegeben wird, erhält dataValue& 1 für Erfolg und 0 für Fehler. Wenn Sie image& als 0 übergeben, werden alle Bilder freigegeben.

IMAGELIST REPLACE BITMAP hLst , image& , hBmp [, hMsk ] [TO dataValue&]

Der einsbasierte Bildindex image& wird durch das Bitmap-Handle hBmp und das optionale Masken-Bitmap hMsk ersetzt. Wenn TO angegeben wird, erhält dataValue& 1 für Erfolg und 0 für Fehler.

IMAGELIST REPLACE BITMAP hLst , image& , Bmp$ [, Msk$ ] [TO dataValue&]

Der einsbasierte Bildindex image& wird durch eine von der Festplatte geladene Bitmap ersetzt. Wenn TO angegeben wird, erhält dataValue& 1 für Erfolg und 0 für Fehler.

IMAGELIST SET OVERLAY hLst , image& , overlay&

Das durch die Indexnummer image & angegebene Bild wird als Overlay-Bild deklariert. Der Parameter overlay& muss im Bereich von 1 bis 15 liegen und wird später verwendet, um dieses bestimmte Overlay-Bild abzurufen und/oder anzugeben.

Siehe auch

  • GRAFISCHES BITMAP-LADEN
  • GRAFISCHE BITMAP NEU
  • GRAFISCHE BILDLISTE
  • Listenansicht
  • TAB-SET BILDLISTE
  • Baumansicht
  • XPRINT-BILDLISTE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ADDR IMPORTIEREN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › ADDR. IMPORTIEREN

ADDR. IMPORTIEREN

Eine Bibliothek laden oder freigeben (

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

IMPORT ADDR ProcName$ , LibName$ TO AddrVar& [, HndlVar& ]
IMPORT CLOSE LibHndl

Beschreibung

In den meisten Fällen werden Bibliotheken implizit automatisch geladen, wenn Sie eine IMPORT- oder LIB-Option in einer DECLARE-Anweisung auflisten. Dies ist zwar der einfachste Ansatz, kann jedoch zu einem schwerwiegenden Problem führen, wenn die DLL fehlt oder es sich um eine Version handelt, die nicht die benötigte Sub-/Funktionsdatei enthält. In diesem Fall schlägt Ihr Programm beim Start fehl und wird überhaupt nicht ausgeführt.

Mit IMPORT ADDR können Sie eine DLL explizit nach Namen laden, sodass Sie ein Problem ordnungsgemäß lösen können, wenn der Vorgang aus irgendeinem Grund fehlschlägt. Bei IMPORT ADDR gibt ProcName$ den Namen des SUB oder der Funktion an, auf die Sie zugreifen möchten, während LibName$ den Namen der DLL und deren Speicherort angibt. ProcName$ muss für alle alphabetischen Zeichen die richtige Groß-/Kleinschreibung verwenden, sonst schlägt es fehl. Wenn das Laden erfolgreich ist, wird die Adresse des Einstiegspunkts der Sub/Funktion der Variablen AddrVar& zugewiesen und das Handle der DLL wird der optionalen Variablen HndlVar& zugewiesen. Beide Variablen müssen Long Integers oder DWords sein. Sollte die Last aus irgendeinem Grund ausfallen, wird beiden der Wert Null (0) zugewiesen.

Nachdem die Bibliothek (DLL) erfolgreich geladen wurde, können Sie mit CALL DWORD AddrVar& auf die Sub/Funktion zugreifen.

Sobald Sie mit der Verwendung der Bibliothek fertig sind, können Sie sie freigeben und den verwendeten Speicher zurückgewinnen, indem Sie IMPORT CLOSE ausführen. Der Ausdruck LibHndl muss den Wert angeben, der beim Laden der DLL in HndlVar& zurückgegeben wurde. Wenn Sie keinen IMPORT CLOSE ausführen, wird die DLL automatisch freigegeben, wenn Ihr Programm beendet wird.

Siehe auch

  • CALL DWORD
  • ERKLÄREN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


IN - FOR-EACH-Quelle angeben — PBXB64 Help

Startseite › General Reference › IN - FOR-EACH-Quelle angeben — PBXB64 Help
Hilfe zum PBXB64-Compiler

IN - FOR-EACH-Quelle angeben

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

FOR EACH item IN collection

Detailverhalten

Klauselkeyword, das die Schleifenvariable von der Quelle in FOR EACH trennt.

Praktische Verwendung

Verwenden Sie IN in FOR EACH-Formen, um die Iterationsvariable von der Quelle zu trennen. Der Keyword-Einsatz ist hier an die getestete FOR EACH-Schreibweise gebunden, nicht an einen freien Ausdrucksoperator.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Verwenden Sie diese Keywords nicht ausserhalb der getesteten FOR EACH-Schreibweise, wenn die Quelle nicht als Iterationsform gemeint ist. Sonst wird der Parser einen anderen Ausdrucksweg erwarten.

Verifiziertes Beispiel

Abgedeckt durch examples/basic/Container_ForEach_UDT_Lst.pb (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


#INCLUDE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › #INCLUDE

#INCLUDE

Weisen Sie den Compiler an, eine Textdatei von der Festplatte zu lesen und sie als integralen Bestandteil des Quellcodes zu behandeln.

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET] für #INCLUDE, #INCLUDE ONCE, #INCLUDE AS MODULE, #INCLUDE AS MODULE ONCE und #INCLUDE THIS ONCE.

Syntax

#INCLUDE "FileSpec"
#INCLUDE ONCE "FileSpec"
#INCLUDE THIS ONCE
#INCLUDE AS MODULE "FileSpec" [AS "ModuleName"]
#INCLUDE AS MODULE ONCE "FileSpec" [AS "ModuleName"]

Beschreibung

Verwenden Sie #INCLUDE, um den Text einer anderen Datei zusammen mit der aktuellen Datei zu kompilieren. Die erste Form bewirkt, dass FileSpec in jedem Fall eingeschlossen wird, auf den es stößt. Die zweite Form bewirkt, dass FileSpec nur einmal eingeschlossen wird, und zwar beim ersten Auftreten. Dies ist besonders nützlich, wenn gängige Deklarationsdateien wie WIN32API.INC eingebunden werden, um redundanten Code und die daraus resultierenden Fehler zu vermeiden. Um wirksam zu sein, muss die ONCE-Option in jedem #INCLUDE einer bestimmten Datei erscheinen. Tatsächlich bedeutet #INCLUDE ONCE: „Diese Datei nur einbinden, wenn sie noch nicht eingebunden wurde.“

Das dritte Formular (#INCLUDE THIS ONCE) wird in die einzubindende Datei eingefügt und erzeugt ein Endergebnis ähnlich dem zweiten Formular. Der Compiler wird angewiesen, „mich nur einmal einzubeziehen, egal wie oft es angefordert wird“. Je nach Inhalt und Kontext kann dies eine einfachere und besser lesbare Methode sein, um das gewünschte Ergebnis zu erzielen.

#ALS MODUL EINSCHLIESSEN

Der#INCLUDE AS MODULE form liest die Datei und verpackt ihren Inhalt in eine MODULE ... END MODULE automatisch sperren. Dies ist nützlich, um vorhandene Include-Dateien als benannte Module zu importieren, ohne sie zu ändern. Der Modulname wird vom Dateistamm (dem Teil vor der Erweiterung) abgeleitet, wobei Sonderzeichen in Unterstriche umgewandelt werden. Zum Beispiel, libs/math-lib.inc wird zum Modul math_lib.

Sie können den abgeleiteten Namen mit überschreiben AS "ModuleName" Suffix:

#INCLUDE AS MODULE "helpers.inc" AS "MyHelpers"

Greifen Sie von außerhalb des Moduls mithilfe der Punktnotation auf öffentliche Elemente zu:

result = MyHelpers.add_values(10, 20)
MyHelpers.say_hello

Elemente in der enthaltenen Datei sind PRIVATE standardmäßig. Um sie von außerhalb des Moduls zugänglich zu machen, stellen Sie ihnen das Präfix voran PUBLIC in der Include-Datei:

' In the included file:
PUBLIC FUNCTION add_values(a AS LONG, b AS LONG) AS LONG
    add_values = a + b
END FUNCTION

PUBLIC SUB say_hello
    PRINT "Hello!"
END SUB

#INCLUDE AS MODULE ONCE kombiniert beide Verhaltensweisen: Die Datei wird in ein Modul eingeschlossen und Es wird nur beim ersten Auftreten einbezogen. Dies ist das empfohlene Formular zum Importieren wiederverwendbarer Bibliotheken.

Zirkuläre Includes werden erkannt und als Fehler bei der Kompilierung gemeldet.

#INCLUDE THIS ONCE wird erkannt, wenn es als Top-Level-Direktive innerhalb der einzubindenden Datei steht. Ist es vorhanden, wird die Datei höchstens einmal eingebunden, auch wenn äußere #INCLUDE-Anforderungen das Schlüsselwort ONCE nicht verwenden.

FileSpec ist eine Zeichenfolgenkonstante, die den normalen LFN-Dateinamenskonventionen folgt und eine PowerBASIC-Quellcodedatei benennt. Wenn FileSpec keine Erweiterung enthält, sucht der Compiler nach diesem Dateinamen mit der Standarderweiterung .BAS.

Wenn FileSpec keinen Pfad enthält, durchsucht der Compiler den Suchpfad für jede #INCLUDE-Datei, bevor er das aktuelle (Standard-)Verzeichnis überprüft. Für die IDE kann der Suchpfad auf der Registerkarte „Compiler-Einstellungen“ im Dialogfeld „Optionen“ festgelegt werden. Der Suchpfad kann auch beim Kompilieren über die Befehlszeile mithilfe der Option /I Include angegeben werden. Der Suchpfad kann einen oder mehrere zu scannende Pfade enthalten. Wenn mehrere Pfade verwendet werden, werden diese durch ein Semikolon (;) getrennt.

Wenn der Compiler auf eine #INCLUDE-Metaanweisung stößt, liest er FileSpec von der Festplatte und setzt die Kompilierung mit dem Quellcode in FileSpec fort. Wenn das Ende von FileSpec erreicht ist, wird die Kompilierung mit der Anweisung fortgesetzt, die unmittelbar auf #INCLUDE in der ursprünglichen Quelldatei folgt. Das Ergebnis ist dasselbe, als ob der Inhalt der eingebundenen Datei physisch im Originaltext vorhanden wäre. Dadurch können große Quelldateien in kleinere, besser verwaltbare Abschnitte unterteilt werden.

Debuggen eingebundener Dateien

Wenn --debug verwendet wird, behält PBXB64 die ursprüngliche Quelldatei und Zeile für Anweisungen aus eingebundenen Dateien. Die erzeugte .sdbg-Debug-Tabelle enthält Quelleinträge für die Hauptdatei und für jede eingebundene Datei, die ausführbaren Code beiträgt. Dadurch kann der Editor beim Single-Step in .pbi- und .inc-Dateien springen, statt alle Zeilen der Hauptdatei zuzuordnen.

Dieses Verhalten ist durch tests/pb/test_debug_include_main.pb und tests/pb/test_debug_include_dupe_main.pb abgedeckt. Der zweite Test bindet zwei Hilfsdateien mit demselben Dateinamen aus unterschiedlichen Ordnern ein und prüft die vollständigen Quellpfade sowie die Zeileneinträge in der erzeugten SDB2-Debug-Quelltabelle.

#INCLUDE-Metaanweisungen können bis zu zwölf Ebenen tief verschachtelt werden. Das heißt, eine eingebundene Datei kann über eigene #INCLUDE-Metaanweisungen verfügen, einschließlich Dateien, die ebenfalls über #INCLUDE-Metaanweisungen usw. verfügen, und zwar für insgesamt zwölf Dateiebenen (einschließlich der Primärdatei). Beachten Sie, dass Makros zu Verschachtelungszwecken als #include-Dateien gelten.

PBXB64-Beispiele

' helpers.pbi
#INCLUDE THIS ONCE
PUBLIC FUNCTION add_values(a AS LONG, b AS LONG) AS LONG
    add_values = a + b
END FUNCTION

' main.pb
#COMPILE EXE
#INCLUDE AS MODULE ONCE "helpers.pbi" AS "Helpers"
#INCLUDE AS MODULE ONCE "helpers.pbi" AS "Helpers"  ' wird durch ONCE übersprungen
FUNCTION PBMAIN() AS LONG
    PBMAIN = Helpers.add_values(20, 22)
END FUNCTION

Abgedeckt durch tests/pb/test_pp_include_as_module_once.pb und tests/pb/test_pp_include_this_once.pb.

Siehe auch

  • MODUL / ENDMODUL
  • WIN32API.INC-Updates

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


INCR – PBXB64-Compiler-Hilfe

Startseite › Funktionen › INCR

INCR

Eine Variable um 1 erhöhen; a erhöhen

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

INCR variable

Beschreibung

Variable kann ein Zeiger oder eine Zeigervariable sein. Wenn INCR mit einer numerischen Variablen verwendet wird, wird 1 zur numerischen Variablen addiert.

Wenn INCR mit einer Zeigervariablen selbst verwendet wird, wird der Wert des Zeigers um die Größe des Zeigerziels erhöht.

Wenn INCR für das Ziel eines numerischen Zeigers verwendet wird (d. h. INCR @IntPtr), wird der Wert des Ziels um 1 erhöht.

Wenn beispielsweise ein Zeiger auf ein Array gegeben ist, in dem der Zeiger auf das Element 1000 zielt, würde die Anwendung von INCR auf den Zeiger dazu führen, dass der Zeiger auf das Element 1001 zielt. Die tatsächliche vom Zeiger gehaltene Adresse wäre um zwei gestiegen, da das Ziel des Zeigers eine Ganzzahl mit einer Breite von zwei Bytes ist.

Wenn umgekehrt INCR für das Ziel dieses Integer-Zeigers verwendet würde, würde der Wert des Elements selbst um 1 erhöht.

Siehe auch

  • DECR
  • LET

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Inline-Assembler-Codesyntax – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Inline-Assembler-Codesyntax

Syntax des Inline-Assembler-Codes

Die ASM-Anweisung oder als „Abkürzung“ das Ausrufezeichen (!) wird verwendet, um Assembler-Anweisungen (oder Opcodes) in Ihr BASIC-Programm einzufügen. Sie müssen am Anfang jeder Zeile stehen, die c

Typ:Schlüsselwort |Kategorie:Inline-Assembler

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Der durch ASM-Anweisungen generierte Maschinencode wird direkt mit dem Code Ihrer BASIC-Anweisungen abgeglichen, sodass die Ausführung Ihres Programms genau so abläuft, wie es in Ihrem Quellcode erscheint. Sie sollten unter keinen Umständen versuchen, eine Unterfunktion, eine Funktion, eine Methode oder eine Eigenschaft vorzeitig mit einem RET-Befehl zu beenden, da dies mit Sicherheit zum Scheitern führt. Wenn Sie eine Routine irgendwann vor der End Sub/Function/Method/Property-Anweisung beenden müssen, springen Sie stattdessen zu einer Marke am Ende der Prozedur.

Verwenden Sie Assemblersprache in Ihrem Code

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Syntax des Inline-Assembler-Codes soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Syntax des Inline-Assembler-Codes mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


INPUTBOX$ – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › INPUTBOX$

EINGABEBOX$

INPUTBOX$ zeigt ein Dialogfeld mit einer Eingabeaufforderung an. INPUTBOX$ wartet darauf, dass der Benutzer Text eingibt und den Dialog akzeptiert oder abbricht. INPUTBOX$ gibt den Inhalt des Textfelds zurück.

Typ:Funktion |Kategorie: Utilities

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

sResult$ = INPUTBOX$( prompt$ [[, title$ ], default$ ] [, xpos% , ypos% ])

Beschreibung

Prompt$ ist die Textaufforderung, die im Dialogfeld „Eingabefeld“ angezeigt wird.

Title$ ist die Überschrift für das Eingabefeld-Dialogfeld und optional.

Default$ ist der Standard-Ergebnistext, der im Bearbeitungsbereich des Eingabefeld-Dialogfelds angezeigt wird, und ist optional.

xpos% und ypos% geben die Position auf dem Bildschirm an, an der das Eingabefeld angezeigt werden soll, in Dialogeinheiten. Wenn diese nicht angegeben sind, wird das Eingabefeld-Dialogfeld zentriert auf dem Bildschirm angezeigt.

Einschränkungen

Der zurückgegebene Zeichenfolgenwert ist auf 255 Zeichen begrenzt.

Siehe auch

  • MSGBOX-Funktion
  • MSGBOX-Anweisung
  • TXT-Pseudoobjekt

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


INSTANZ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › INSTANZ

INSTANCE

Erklären

Typ:Anweisung |Kategorie:Variablen und Umfang

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

INSTANCE variable [()] [AS type ] [, variable [()]]
INSTANCE variable [()] [, variable [()]] [, ...] AS type

Beschreibung

INSTANCE-Anweisungen werden verwendet, um Instanzvariablen für ein Objekt zu deklarieren. Für jedes neue Objekt wird ein eindeutiger Satz von Instanzvariablen erstellt, auf die nur innerhalb dieses Objekts verwiesen werden darf. INSTANCE-Anweisungen dürfen nur am Anfang eines CLASS/END CLASS-Blocks und vor allen INTERFACE-Blöcken platziert werden.

INSTANCE akzeptiert optional eine Liste von Variablen, die jeweils durch den darauf folgenden Deskriptor definiert werden:

INSTANZ x als Ganzzahl, y als Länge

INSTANCE akzeptiert auch eine Liste von Variablen, die alle durch den einzelnen Deskriptor am Ende der Liste definiert sind;

INSTANZ aaa, bbb, ccc ALS INTEGER

INSTANZ vptr, aptr() AS LONG PTR

Um ein Array als Instanzvariable zu deklarieren, verwenden Sie einen leeren Satz Klammern in der Variablenliste: Anschließend können Sie das Array mit der DIM-Anweisung dimensionieren.

Siehe auch

  • GLOBAL
  • INTERFACE (Direct)
  • LOCAL
  • STATIC
  • GEWINDE
  • Was ist überhaupt ein Objekt?

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Ganzzahlen (%) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Ganzzahlen (%)
Hilfe zum PBXB64-Compiler

Ganzzahlen (%)

Für PowerBASIC ist eine Ganzzahl eine Zahl ohne Dezimalpunkt (was Mathematiker ganze Zahlen nennen würden) mit einem Bereich von -32.768 bis +32.767 (-2^15 bis 2^15 - 1). Diese Werte ergeben sich aus dem zugrunde liegenden Wert

Typ:Schlüsselwort |Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Ganzzahlen werden identifiziert, indem dem Variablennamen ein Prozentzeichen folgt (z. B. var%) oder die DEFINT-Anweisung verwendet wird. Wenn Sie beispielsweise diese Deklaration in Ihrem Programmcode verwenden:

dann sind alle Variablen, die dieser Deklaration folgen und mit dem Buchstaben I, J oder K beginnen, standardmäßig eine Ganzzahl. Sie können eine Integer-Variable auch mit dem Schlüsselwort INTEGER mit der DIM-Anweisung deklarieren. Zum Beispiel:

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Ganzzahlen (%) soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Ganzzahlen (%) mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


INTERFACE/END INTERFACE-Block (direkt) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › INTERFACE / END INTERFACE Block (Direkt)
Hilfe zum PBXB64-Compiler

INTERFACE / END INTERFACE Block (direkt)

Deklarieren Sie eine direkte

Typ:Schlüsselwort |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

INTERFACE interfacename [$GUID] [AS EVENT] [AS HIDDEN]
{METHOD | PROPERTY} name [([ arguments ])] [AS type ]]
END INTERFACE

Beschreibung

Die erste Zeile in einem Schnittstellenblock muss eine INHERIT-Anweisung sein. INHERIT gibt die Basisklasse oder die Benutzeroberfläche an, auf der diese neue Schnittstelle aufbaut. Es definiert die verfügbaren Basismethoden, die optionalen Benutzermethoden, die verfügbar sind, und die Aufrufkonventionen, die gelten werden. In der aktuellen Version von PowerBASIC darf Folgendes verwendet werden:

ERBEN IUnbekannt

Dies definiert eine benutzerdefinierte Schnittstelle mit nur direktem Zugriff auf die Schnittstellenmethoden. OBJRESULT (ein hResult-Wert) wird nicht unterstützt. Rückgabewerte werden normalerweise in CPU/FPU-Registern übergeben, genau wie eine benutzerdefinierte FUNCTION . Dies ist das Format, das am häufigsten für interne Objekte verwendet wird, da es Zugriff auf mehr Datentypen bietet als die anderen Formen. Sie können IUNKNOWN durch das Wort CUSTOM ersetzen, da es sich um Synonyme handelt.

IAutomation erben

Dies definiert eine Automatisierungsschnittstelle mit nur direktem Zugriff auf die Schnittstellenmethoden. OBJRESULT (ein hResult-Wert) wird immer unterstützt. Rückgabewerte werden als versteckter, letzter Parameter übergeben (automatisch, von PowerBASIC). Parameter und Rückgabewerte sind auf COM-Datentypen beschränkt. Ein als Rückgabewert oder Parameter verwendeter benutzerdefinierter Typ wird in ein BYVAL DWORD konvertiert. Dies ist das am häufigsten verwendete Format für COM-Objekte, die keinen Zugriff auf die IDispatch-Schnittstelle erfordern. Sie können das Wort AUTOMATION durch IAUTOMATION ersetzen, da es sich um Synonyme handelt.

IDispatch erben

Dies definiert eine Dual-Schnittstelle, die sowohl direkten Zugriff als auch Dispatch-Zugriff auf die Schnittstellenmethoden bietet. OBJRESULT (ein hResult-Wert) wird immer unterstützt. Diese Schnittstelle erbt von IAutomation, sodass die Aufrufkonventionen mit denen von IAutomation identisch sind, wenn sie für den direkten Zugriff verwendet werden. Sie können IDISPATCH durch das Wort DUAL ersetzen, da es sich um Synonyme handelt.

INHERIT < UserClass >, < UserInterface >

Dadurch wird eine geerbte, vom Benutzer geschriebene Schnittstelle definiert, sodass die neue Schnittstelle die Basisklasse (IUnknown, IDispatch usw.) sowie alle Methoden und Eigenschaften implementiert. Es ist notwendig, sowohl die Klasse als auch den Schnittstellennamen anzugeben, die geerbt werden sollen, da mehrere Implementierungen einer bestimmten Schnittstelle möglich sind.

INTERFACE/END INTERFACE-Anweisungen schließen die METHOD- und PROPERTY-Definitionen ein, die eine Klasse bilden. Es gibt zwei Formen des INTERFACE-/END-INTERFACE-Blocks. Wenn es außerhalb eines CLASS-Blocks erscheint, handelt es sich lediglich um eine Deklaration der Schnittstelle, ähnlich wie DECLARE-Anweisungen für Funktionen verwendet werden:

SCHNITTSTELLENNAME [$GUID] [AS EVENT]

ERBEN IUnbekannt

METHODE MyMethod(xyz AS LONG)

PROPERTY GET MyProp() AS STRING

ENDSCHNITTSTELLE

Das obige Formular wird verwendet, um eine Schnittstelle zu deklarieren, die in einer anderen .EXE- oder .DLL-Datei implementiert ist, auf die hier jedoch über COM-Dienste zugegriffen wird. Es kann auch zur zusätzlichen Selbstdokumentation interner Klassen verwendet werden. Wenn es innerhalb eines CLASS-Blocks erscheint, handelt es sich um die Implementierung der Methoden/Eigenschaften für die Klasse. Die Schnittstellenimplementierung muss genau mit jeder vorherigen Schnittstellendeklaration übereinstimmen.

KLASSENNAME [$GUID] [AS COM]

SCHNITTSTELLENNAME [$GUID] [AS HIDDEN]

INHERIT iUnknown

METHODE MyMethod(xyz AS LONG)

[Anweisungn]

ENDMETHODE

PROPERTY GET MyProp() AS STRING

[Anweisungn]

END EIGENTUM

ENDSCHNITTSTELLE

END DER KLASSE

Der Name und die optionale $GUID werden vom Programmierer bereitgestellt, um die Schnittstelle eindeutig zu identifizieren. Der erste Eintrag in jedem INTERFACE-Block muss die Basisklasse sein, auf der er aufbaut. Jede Schnittstelle muss letztendlich von IUnknown erben, was eine Voraussetzung ist.

Standardmäßig gilt eine Klasse als privat, sodass auf die Methoden nur aus der EXE- oder DLL-Datei zugegriffen werden kann, in der sie definiert ist. Das AS COM-Attribut der CLASS-Anweisung macht die Klasse extern für praktisch jeden Prozess verfügbar, der COM-fähig ist.

Das optionale AS HIDDEN-Attribut der INTERFACE-Anweisung verhindert, dass die Schnittstelle beim Erstellen der Typbibliothek dokumentiert wird. Wenn sie als ausgeblendet markiert ist, werden alle Verwendungen der Schnittstelle ausgeblendet, auch wenn sie in mehreren Klassen vorkommen.

Bei einer internen Klasse kann die $GUID in CLASS- und INTERFACE-Anweisungen frei weggelassen werden, da PowerBASIC sie leicht anhand ihres Namens identifizieren kann. Bei einer veröffentlichten COM-Klasse sollten Sie eine bestimmte GUID Ihrer Wahl einfügen. Wenn es weggelassen wird, wird vom Compiler eine zufällige GUID erstellt, die sich jedoch jedes Mal ändert, wenn Sie das Programm kompilieren. Dies lässt sich nur schwer mit anderen Programmen synchronisieren, die Ihr Objekt identifizieren und darauf zugreifen möchten.

Der folgende Code definiert eine duale Schnittstelle, deren Methoden sowohl für den direkten Zugriff als auch für den Dispatch-Zugriff verfügbar sind. Dies ist die Form, die Sie normalerweise für COM-Objekte verwenden, da sie die beste Kompatibilität mit verschiedenen Clientmodulen bietet.

SCHNITTSTELLE DispatchIface

IDispatch erben

METHODE MethodDef()

[Anweisungn]

ENDMETHODE

ENDSCHNITTSTELLE

Beachten Sie, dass die IDispatch-Schnittstelle selbst von IUnknown erbt, sodass letztendlich beide Schnittstellen verfügbar sind. Als zusätzlich erforderliche Basisklasse ist die IDispatch-Deklaration in den PowerBASIC-Compiler integriert.

Jede Methode und Eigenschaft in einer dualen Schnittstelle benötigt einen positiven, langen ganzzahligen Wert, um sie zu identifizieren. Dieser ganzzahlige Wert wird als DispID (Dispatch-ID) bezeichnet und intern von COM-Diensten verwendet, um die richtige Funktion auf einer Dispatch-Schnittstelle aufzurufen. Sie können eine bestimmte DispID angeben, indem Sie sie in spitze Klammern unmittelbar nach dem Methoden-/Eigenschaftsnamen in einem Schnittstellendefinitionsblock einschließen.

SCHNITTSTELLE DualIface

IDispatch erben

METHODE MethodOne <76> ()

METHODE MethodTwo <77> ()

ENDSCHNITTSTELLE

Wenn Sie keine DispID angeben, weist PowerBASIC Ihnen einen zufälligen Wert zu. Dies ist für interne Objekte in Ordnung, kann jedoch bei veröffentlichten COM-Objekten zu einem Fehler führen, da sich die DispID bei jeder Kompilierung Ihres Programms ändern kann. Es ist besonders wichtig, dass Sie für jede Methode/Eigenschaft in einer COM-Ereignisschnittstelle eine DispID angeben.

Geerbte benutzergeschriebene Schnittstellen

PowerBASIC bietet Implementierungsvererbung von vom Benutzer geschriebenen Schnittstellen. Das heißt, eine Schnittstelle kann den gesamten Code in den Methoden und Eigenschaften einer ausgewählten Schnittstelle erben. Anschließend können Sie der neuen Schnittstelle weitere Methoden und Eigenschaften hinzufügen. Wenn Sie eine vom Benutzer geschriebene Schnittstelle erben, müssen Sie sowohl den Klassennamen als auch den Schnittstellennamen angeben, da COM Ihnen ermöglicht, mehrere Implementierungen einer bestimmten Schnittstelle zu haben.

Sie können eine geerbte Methode oder Eigenschaft überschreiben, indem Sie eine Ersetzung codieren, der das Wort OVERRIDE vorangestellt ist. Es ist möglich, eine oder mehrere Prozeduren außer Kraft zu setzen, sie müssen jedoch in derselben Reihenfolge wie die Prozeduren erscheinen, die sie ersetzen.

KLASSE MyClass

SCHNITTSTELLE MyFace

IDispatch erben

METHODE aaa()

' Code...

ENDMETHODE

METHODE bbb()

' Code...

ENDMETHODE

METHODE ccc()

' Code...

ENDMETHODE

METHODE ddd()

' Code...

ENDMETHODE

ENDSCHNITTSTELLE

END DER KLASSE

KLASSE Die Klasse

SCHNITTSTELLE TheFace

ERBEN MyClass, MyFace

OVERRIDE-METHODE bbb()

' neuer Code...

ENDMETHODE

OVERRIDE-METHODE ddd()

' neuer Code...

ENDMETHODE

METHODE xxx()

' Code...

ENDMETHODE

ENDSCHNITTSTELLE

END DER KLASSE

Beachten Sie, dass im obigen Beispiel die neue Schnittstelle „TheFace“ zunächst alle vier Methoden von „MyFace“ erbt (aaa,bbb,ccc,ddd). Aufgrund der OVERRIDE-Anweisungen werden jedoch sowohl bbb() als auch ddd() durch neuere Versionen der Methoden ersetzt. Aufgrund der Natur virtueller Funktionstabellen müssen die OVERRIDE-Prozeduren in der ursprünglichen Reihenfolge bleiben. Das heißt, bbb() muss vor ddd() stehen und beide müssen vor allen hinzugefügten Methoden wie xxx() stehen.

Aufgrund der Art der Codeersetzung, die bei der Implementierungsvererbung erforderlich ist, muss die zu vererbende Schnittstelle immer physisch vor der neuen untergeordneten Schnittstelle liegen.

Siehe auch

  • INTERFACE (IDBind)
  • CLASS
  • INSTANCE
  • ISINTERFACE
  • LET (with Objects)
  • ICH
  • METHOD
  • MYBASE
  • PROPERTY
  • Wie sieht eine Schnittstelle aus?
  • Was ist Vererbung?

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


INTERFACE/END INTERFACE-Block (Dispatch) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › INTERFACE/END INTERFACE-Block (Dispatch)
Hilfe zum PBXB64-Compiler

INTERFACE/END INTERFACE-Block (Dispatch)

Erkläre a

Typ:Schlüsselwort |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

INTERFACE IDBIND interfacename
MEMBER {CALL | GET | SET | LET} membername < dispid > ( [[OPTIONAL
[IN | OUT | INOUT]] paramname < dispid > [AS type ] [,...]] )
[AS { vartype | interface }]
[...]
END INTERFACE

Beschreibung

Um IDBinding-Dienste bereitzustellen, muss PowerBASIC in der Lage sein, die Verweise auf die DISPATCH COM-Schnittstellenmitglieder zur Kompilierungszeit vorab zu erstellen. Ohne einen Schnittstellendefinitionsblock wäre nur eine späte Bindung zur Laufzeit möglich. Late-Binding ist weniger effizient als IDBinding.

Sie können jede Methode/Eigenschaft in der Schnittstelle auflisten oder nur diejenigen, auf die im Code verwiesen wird. Sie können in beliebiger Reihenfolge erscheinen. Mitgliedsnamen können (normalerweise) reservierte Schlüsselwörter wie INPUT oder KILL usw. enthalten

Der wichtigste Aspekt eines Schnittstellenblocks besteht darin, dass er jedem Methoden-/Eigenschaftsnamen eindeutig ein Dispid zuordnet. Benannte Parameter in der Liste paramname erfordern ebenfalls einen entsprechenden dispid-Wert, ebenso wie jede Eigenschaft, die ein Objekt zurückgibt, das in einer verschachtelten Objektreferenz verwendet werden soll. Alle Dispid-Werte müssen in spitze Klammern (< und >) eingeschlossen werden und können als hexadezimale oder dezimale numerische Literale ausgedrückt werden.

Sie können die Dispid-Werte von COM-Servern mithilfe eines Objektbrowsers oder durch Lesen Ihrer Objektdokumentation nachschlagen. Sie können sogar zusätzliche Informationen zu den Typen und Rückgabewerten zu Ihrer eigenen Referenz einfügen, auch wenn der Compiler diese nicht verwendet.

Frühere Versionen von PowerBASIC-Compilern verwendeten für diese Struktur eine ältere Syntax von „INTERFACE DISPATCH interfacename“. Es wurde aktualisiert, um die Art der Beschreibung besser widerzuspiegeln. Obwohl die ältere Syntax in dieser Version erkannt wird, empfehlen wir Ihnen, das Wort DISPATCH bald auf IDBIND zu aktualisieren.

Einschränkungen

Wenn der Compiler die in einer DIM- oder LET-Anweisung angegebene Schnittstellennamendefinition nicht auflösen kann, wird entsprechend ein Kompilierungsfehler generiert.

Schnittstellenname darf kein PowerBASIC-Schlüsselwort sein. Wenn ein Schlüsselwortkonflikt auftritt, ist das Hinzufügen eines willkürlichen Präfixes akzeptabel. Beispielsweise könnte INTERFACE IDBIND Shell() in INTERFACE IDBIND MyShell() geändert werden und PowerBASIC löst die Schnittstelle weiterhin korrekt auf.

Methoden-/Eigenschafts-Mitgliedsnamenelemente können PowerBASIC-Schlüsselwörter frei verwenden, ohne dass Konflikte mit der normalen Codesyntax befürchtet werden müssen. Beispielsweise ist MEMBER CALL Open() eine gültige Syntax für eine Schnittstellenmethode.

Siehe auch

  • DIM
  • ID-Bindung
  • INTERFACE (Direct)
  • ISINTERFACE
  • LET (with Objects)
  • Späte Bindung
  • LET (mit Varianten)
  • OBJACTIVE
  • OBJECT
  • OBJPTR
  • OBJRESULT
  • PROGID$
  • Was ist überhaupt ein Objekt?
  • Was ist VERSAND?

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


Mischen von ASM- und BASIC-Code – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Mischen von ASM- und BASIC-Code

Mischen von ASM- und BASIC-Code

Beim Schreiben von gemischtem Assembler- und BASIC-Code gelten besondere Bedingungen für die Registererhaltung. PowerBASIC ist ein hochoptimierter Compiler und zu seinen Optimierungen gehören Reduzierungen

Typ:Schlüsselwort |Kategorie:Inline-Assembler

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Das heißt, wenn Ihr Assembler-Algorithmus eines der EBX-, ESI- oder EDI-Register verwendet, müssen Sie deren ursprünglichen Zustand aus der letzten Zeile des BASIC-Codes beibehalten, die dem Inline-Assembler-Code vorausgeht. Das heißt, Sie müssen sie vor Ihrem ASM-Code PUSH und kurz vor Beginn des BASIC-Codes erneut POP senden.

Dies scheint mehr Code als notwendig zu sein, aber es muss beachtet werden, dass die interne Struktur von PowerBASIC nicht die Stapelbewahrung dupliziert, die der Anwendungsprogrammierer anwenden muss, sodass der Code im Hinblick auf den Stapelaufwand tatsächlich sehr effizient ist.

Es ist zu beachten, dass Sie, wenn Ihr ASM-Code die EAX-, ECX- oder EDX-Register verwendet, diese ebenfalls beibehalten sollten, da die interne Ausführung von BASIC-Anweisungen auch jedes dieser drei Register frei ändern kann.

Der Gesamtansatz zur Erhaltung der Register rund um gemischten ASM- und BASIC-Code wird in der folgenden Auflistung veranschaulicht:

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Mischen von ASM- und BASIC-Code soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Mischen von ASM- und BASIC-Code mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Interne Darstellungen von Arrays – PBXB64 Compiler-Hilfe

Startseite › Funktionen › Interne Darstellungen von Arrays

Interne Darstellungen von Arrays

PowerBASIC speichert Arrays in der Reihenfolge der Hauptspalten: Array (0,0) ist zuerst (am niedrigsten) im Speicher, dann Array (1,0), dann Array (2,0) und so weiter durch alle Zeilen des Arrays. Danach werden die Reihen gepflegt

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Während PowerBASIC untere Grenzwerte ungleich Null unterstützt, generiert PowerBASIC den effizientesten Code, wenn der untere Grenzwertparameter weggelassen wird (d. h. das Array verwendet den standardmäßigen unteren Grenzwert von Null).

Array-Grenzwerte können zur Laufzeit über die Funktionen LBOUND und UBOUND abgerufen werden. Beschreibende Attribute eines Arrays können mit der Funktion ARRAYATTR abgerufen werden. Zu diesen Attributen gehören Informationen wie der Datentyp und die Anzahl der Dimensionen usw.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Interne Darstellungen von Arrays soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Interne Darstellungen von Arrays mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


ISFALSE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › ISFALSE

ISFALSCH

Gibt die logische Wahrheit oder Falschheit eines bestimmten Ausdrucks zurück.

Typ:Betreiber |Kategorie:Betreiber

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ISFALSE expr
ISTRUE expr

Beschreibung

ISTRUE gibt -1 (TRUE) zurück, wenn expr als ungleich Null ausgewertet wird; andernfalls wird Null (FALSE) zurückgegeben. ISFALSE gibt -1 zurück, wenn expr als 0 (FALSE) ausgewertet wird; andernfalls wird Null zurückgegeben.

Wahrheitstabelle

Betreiber

Ergebnis

ISTRUE

ISTRUE

ISFALSCH

ISFALSCH

Der NOT-Operator von PowerBASIC erfüllt eine doppelte Aufgabe: Er gibt das Einserkomplement eines ganzzahligen Klassenausdrucks zurück und „kehrt“ den Wert eines WAHR/FALSCH-Ausdrucks (boolesch) um. Normalerweise stehen diese beiden Funktionen nicht im Konflikt, aber da PowerBASIC jeden Wert ungleich Null als TRUE akzeptiert, kann die folgende Bedingung auftreten:

test1 = 0 ' test1 ist FALSCH (Null)

IF NICHT test1 THEN ' TRUE (-1 ist ungleich Null)

[Anweisungn]

test2 = 1 ' test2 ist WAHR (1 ist ungleich Null)

IF NICHT test2 THEN ' immer noch TRUE (-2 ist ungleich Null)

[Anweisungn]

In diesem Fall kehrt NOT den TRUE/FALSE-Wert von test2 nicht um. ISFALSE stellt sicher, dass der Test genau so durchgeführt wird, wie Sie es erwarten würden:

test2 = 1 ' test2 ist WAHR (ungleich Null)

IF ISFALSE test2 THEN ' ISFALSE erkennt test2

[Anweisungen] 'WAHR, sodass der IF-Test fehlschlägt

Dieses Problem besteht nicht, wenn Sie die logische Wahrheit testen. PowerBASIC geht davon aus, dass ein Ausdruck in jedem Fall WAHR ist, außer wenn der Ausdruck Null ist. ISTRUE konvertiert jedoch alle Werte ungleich Null in den „wahrsten“ Wert, -1, der sowohl bei booleschen als auch bei arithmetischen Ausdrücken die konsistentesten Ergebnisse liefert.

Einschränkungen

ISTRUE- und ISFALSE-Operatoren werten den „gesamten“ Ausdruck nach dem Schlüsselwort aus, abhängig von ihrer Operatorprioritätsstufe. Beispielsweise werden im Ausdruck enthaltene Klammern als integraler Bestandteil des Ausdrucks betrachtet und fungieren nicht als Trennzeichen für die Operatoren ISTRUE und ISFALSE.

Vor diesem Hintergrund bedeutet die Zusammenfassung eines logischen Testergebnisses in einem weiteren Ausdruck, dass die Ausdrücke getrennt werden müssen, um eine korrekte Auswertung sicherzustellen.

Betrachten Sie die folgende Anweisung:

IF ISTRUE (x&) + y& THEN

PowerBASIC wertet den gesamten Ausdruck (x&) + y& aus und berechnet dann die logische Wahrheit aus dem Gesamtergebnis dieses Ausdrucks. Das heißt, die Klammern um den ersten Teil des Ausdrucks hindern ISTRUE nicht daran, den gesamten Ausdruck auszuwerten. Um dies zu veranschaulichen, kann die Anweisung umgeschrieben werden, um den Umfang der logischen Bewertung prägnant zu veranschaulichen:

IF ISTRUE (x& + 2) THEN

oder es könnte noch weiter vereinfacht werden:

IF ISTRUE x& + 2 THEN

Wenn Sie das numerische Ergebnis des logischen Tests in einem weiteren Ausdruck verwenden möchten, müssen Klammern hinzugefügt werden, um die Ausdrücke korrekt zu trennen:

IF (ISTRUE x&) + 2 THEN

Siehe auch

  • Arithmetische Operatoren
  • NICHT
  • Kurzschlussauswertung

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ISFALSE- und ISTRUE-Operatoren – PBXB64-Compiler-Hilfe

Startseite › Funktionen › ISFALSE- und ISTRUE-Operatoren

ISFALSE- und ISTRUE-Operatoren

Boolesche Wahrheitsoperatoren.

Typ:Konzeptionell |Kategorie:Betreiber

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Überblick

Dieses Thema bietet Hintergrundinformationen und praktische Anleitungen. Eine detaillierte Syntax finden Sie auf den entsprechenden Befehlsseiten.

Siehe auch

  • Befehlsindex

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für ISFALSE- und ISTRUE-Operatoren soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' ISFALSE- und ISTRUE-Operatoren mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


ISFILE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › ISFILE

ISFILE

Stellen Sie fest, ob eine Datei vorhanden ist oder nicht.

Typ:Funktion |Kategorie: Dateiverwaltung

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

FileExists& = ISFILE( FileName )

Beschreibung

Das Dateisubsystem wird überprüft, um festzustellen, ob die durch FileName angegebene Datei derzeit vorhanden ist. Wenn es in irgendeiner Form gefunden wird (versteckt, System, schreibgeschützt usw.), wird der Wert true (-1) zurückgegeben. Andernfalls wird der Wert false (0) zurückgegeben.

Dateiname ist ein eindeutiger Dateiname, der kein Sternchen (*) oder Abfragezeichen (?) enthalten darf. Wenn es eines oder mehrere dieser Zeichen enthält, gibt die Funktion immer false (0) zurück.

Siehe auch

  • DIR$
  • ANZEIGE DURCHSUCHEN
  • OPENFILE ANZEIGEN
  • SAVEFILE ANZEIGEN
  • ISFOLDER
  • PATHSCAN$

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


ISFOLDER – PBXB64-Compiler-Hilfe

Startseite › Funktionen › ISFOLDER

ISFOLDER

Stellen Sie fest, ob ein Ordner vorhanden ist.

Typ:Funktion |Kategorie: Dateiverwaltung

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

FolderExists& = ISFOLDER( FolderName )

Beschreibung

Das Dateisubsystem wird überprüft, um festzustellen, ob der durch FolderName angegebene Ordner derzeit vorhanden ist. Wenn es in irgendeiner Form gefunden wird (versteckt, System, schreibgeschützt usw.), wird der Wert true (-1) zurückgegeben. Andernfalls wird der Wert false (0) zurückgegeben.

Das Stammverzeichnis (z. B. „C:\“) gilt als Ordner und gibt den Wert true (-1) zurück.

FolderName ist ein eindeutiger Dateiname, der kein Sternchen (*) oder Abfragezeichen (?) enthalten darf. Wenn es eines oder mehrere dieser Zeichen enthält, gibt die Funktion immer false (0) zurück.

Siehe auch

  • DIR$
  • ANZEIGE DURCHSUCHEN
  • OPENFILE ANZEIGEN
  • SAVEFILE ANZEIGEN
  • ISFILE
  • PATHSCAN$

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ISINTERFACE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › ISINTERFACE

ISINTERFACE

Bestimmen Sie, ob ein

Typ:Funktion |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

IfaceValid = ISINTERFACE( ObjectVar , InterfaceName )

Beschreibung

Das vom Parameter ObjectVar referenzierte Objekt wird getestet, um festzustellen, ob der angegebene InterfaceName unterstützt wird. Wenn ja, wird der Wert true (-1) zurückgegeben. Andernfalls wird der Wert false (0) zurückgegeben.

Siehe auch

  • CLASS
  • INTERFACE (Direct)
  • INTERFACE (IDBind)
  • Was ist überhaupt ein Objekt?

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


ISMISSING – PBXB64-Compiler-Hilfe

Startseite › Funktionen › ISMISSING

Ich vermisse

Bestimmen Sie, ob es sich um einen optionalen Parameter handelt

Typ:Funktion |Kategorie:Betreiber

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ParamStatus = ISMISSING( ParamVar )

Beschreibung

Die ISMISSING-Funktion kann zum Testen bestimmter optionaler Parameter verwendet werden, um festzustellen, ob der Parameter tatsächlich vom aufrufenden Code übergeben wurde oder nicht. Es kann zum Testen von ByVal/ByRef VARIANT-Parametern oder anderen von ByRef übergebenen Variablentypen verwendet werden. Ein Versuch, einen anderen ByVAL-Parameter als VARIANT zu testen, führt zu einem Fehler 579 (BYREF-Variable oder BYVAL/BYREF-Variante erwartet), der während der Kompilierung generiert wird.

Ein ByRef-Parameter gilt als fehlend, wenn der Zeiger den Wert Null hat. Ein Variantenparameter gilt als fehlend, wenn er den Typ %VT_ERROR und den Fehlerwert %DISP_E_PARAMNOTFOUND hat.

Fehlt der angegebene optionale Parameter, wird der Wert true (-1) zurückgegeben. Andernfalls wird der Wert false (0) zurückgegeben.

Einschränkungen

Die Funktion ISMISSING darf nur innerhalb der Prozedur verwendet werden, die den angegebenen optionalen Parameter verwendet.

Siehe auch

  • ERKLÄREN
  • FUNCTION
  • METHOD
  • PROPERTY
  • SUB

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ISNOTHING – PBXB64-Compiler-Hilfe

Startseite › Funktionen › IST NICHTS

ISNOTHING

Bestimmen Sie den aktuellen Status einer bestimmten Sache

Typ:Funktion |Kategorie:Betreiber

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

oStatus = ISNOTHING( objectvar )

Beschreibung

ISNOTHING ist besonders nützlich, um den Erfolg oder Misserfolg einer LET-Anweisung zu bestimmen. Es gibt TRUE (-1) zurück, wenn die Objektvariable nichts enthält, oder FALSE (0), wenn sie einen gültigen aktuellen Verweis auf eine Objektschnittstelle enthält.

ISNOTHING ist die Ergänzung zur ISOBJECT-Funktion.

Einschränkungen

Die Objektvariable muss eine Interface- oder IDispatch-Objektvariable sein.

Siehe auch

  • DIM
  • INTERFACE (Direct)
  • INTERFACE (IDBind)
  • ISOBJECT
  • LET (with Objects)
  • OBJECT
  • Was ist überhaupt ein Objekt?

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ISNOTNULL – PBXB64-Compiler-Hilfe

Startseite › Funktionen › ISNOTNULL

ISNOTNULL

Bestimmen Sie, ob eine Zeichenfolge

Typ:Funktion |Kategorie:Betreiber

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ResultVar& = ISNOTNULL( StrgExpr )

Beschreibung

Der StrgExpr wird untersucht, um festzustellen, ob er null ist oder ein oder mehrere Zeichen enthält. Der Wert true (-1) wird zurückgegeben, wenn StrgExpr Zeichen enthält, oder false (0), wenn er null (Länge Null) ist.

Die Komplementärfunktion ist ISNULL .

Siehe auch

  • ISNULL

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ISNULL – PBXB64-Compiler-Hilfe

Startseite › Funktionen › ISNULL

ISNULL

Bestimmen Sie, ob eine Zeichenfolge

Typ:Funktion |Kategorie:Betreiber

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ResultVar& = ISNULL( StrgExpr )

Beschreibung

Der StrgExpr wird untersucht, um festzustellen, ob er null ist (null Zeichen enthält). Der Wert true (-1) wird zurückgegeben, wenn StrgExpr null ist, oder false (0), wenn er Zeichen enthält.

Die Komplementärfunktion ist ISNOTNULL .

Siehe auch

  • ISNOTNULL

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ISOBJECT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › ISOBJECT

ISOBJECT

Bestimmen Sie den aktuellen Status einer bestimmten Sache

Typ:Funktion |Kategorie:Betreiber

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

oStatus = ISOBJECT( objectvar )

Beschreibung

ISOBJECT ist besonders nützlich, um den Erfolg oder Misserfolg einer LET-Anweisung (mit Objekten) zu bestimmen. Es gibt TRUE (-1) zurück, wenn die Objektvariable einen gültigen aktuellen Verweis auf eine Objektschnittstelle enthält, oder FALSE (0), wenn sie nichts enthält.

ISOBJECT ist die Ergänzung zur ISNOTHING-Funktion.

Einschränkungen

objectvar muss eine Schnittstelle oder eine IDispatch-Objektvariable sein.

Siehe auch

  • DIM
  • INTERFACE (Direct)
  • INTERFACE (IDBind)
  • ISNOTHING
  • LET (with Objects)
  • OBJECT
  • Was ist überhaupt ein Objekt?

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


ISFALSE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › ISFALSE

ISFALSCH

Gibt die logische Wahrheit oder Falschheit eines bestimmten Ausdrucks zurück.

Typ:Betreiber |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ISFALSE expr
ISTRUE expr

Beschreibung

ISTRUE gibt -1 (TRUE) zurück, wenn expr als ungleich Null ausgewertet wird; andernfalls wird Null (FALSE) zurückgegeben. ISFALSE gibt -1 zurück, wenn expr als 0 (FALSE) ausgewertet wird; andernfalls wird Null zurückgegeben.

Wahrheitstabelle

Betreiber

Ergebnis

ISTRUE

ISTRUE

ISFALSCH

ISFALSCH

Der NOT-Operator von PowerBASIC erfüllt eine doppelte Aufgabe: Er gibt das Einserkomplement eines ganzzahligen Klassenausdrucks zurück und „kehrt“ den Wert eines WAHR/FALSCH-Ausdrucks (boolesch) um. Normalerweise stehen diese beiden Funktionen nicht im Konflikt, aber da PowerBASIC jeden Wert ungleich Null als TRUE akzeptiert, kann die folgende Bedingung auftreten:

test1 = 0 ' test1 ist FALSCH (Null)

IF NICHT test1 THEN ' TRUE (-1 ist ungleich Null)

[Anweisungn]

test2 = 1 ' test2 ist WAHR (1 ist ungleich Null)

IF NICHT test2 THEN ' immer noch TRUE (-2 ist ungleich Null)

[Anweisungn]

In diesem Fall kehrt NOT den TRUE/FALSE-Wert von test2 nicht um. ISFALSE stellt sicher, dass der Test genau so durchgeführt wird, wie Sie es erwarten würden:

test2 = 1 ' test2 ist WAHR (ungleich Null)

IF ISFALSE test2 THEN ' ISFALSE erkennt test2

[Anweisungen] 'WAHR, sodass der IF-Test fehlschlägt

Dieses Problem besteht nicht, wenn Sie die logische Wahrheit testen. PowerBASIC geht davon aus, dass ein Ausdruck in jedem Fall WAHR ist, außer wenn der Ausdruck Null ist. ISTRUE konvertiert jedoch alle Werte ungleich Null in den „wahrsten“ Wert, -1, der sowohl bei booleschen als auch bei arithmetischen Ausdrücken die konsistentesten Ergebnisse liefert.

Einschränkungen

ISTRUE- und ISFALSE-Operatoren werten den „gesamten“ Ausdruck nach dem Schlüsselwort aus, abhängig von ihrer Operatorprioritätsstufe. Beispielsweise werden im Ausdruck enthaltene Klammern als integraler Bestandteil des Ausdrucks betrachtet und fungieren nicht als Trennzeichen für die Operatoren ISTRUE und ISFALSE.

Vor diesem Hintergrund bedeutet die Zusammenfassung eines logischen Testergebnisses in einem weiteren Ausdruck, dass die Ausdrücke getrennt werden müssen, um eine korrekte Auswertung sicherzustellen.

Betrachten Sie die folgende Anweisung:

IF ISTRUE (x&) + y& THEN

PowerBASIC wertet den gesamten Ausdruck (x&) + y& aus und berechnet dann die logische Wahrheit aus dem Gesamtergebnis dieses Ausdrucks. Das heißt, die Klammern um den ersten Teil des Ausdrucks hindern ISTRUE nicht daran, den gesamten Ausdruck auszuwerten. Um dies zu veranschaulichen, kann die Anweisung umgeschrieben werden, um den Umfang der logischen Bewertung prägnant zu veranschaulichen:

IF ISTRUE (x& + 2) THEN

oder es könnte noch weiter vereinfacht werden:

IF ISTRUE x& + 2 THEN

Wenn Sie das numerische Ergebnis des logischen Tests in einem weiteren Ausdruck verwenden möchten, müssen Klammern hinzugefügt werden, um die Ausdrücke korrekt zu trennen:

IF (ISTRUE x&) + 2 THEN

Siehe auch

  • Arithmetische Operatoren
  • NICHT
  • Kurzschlussauswertung

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


ISWIN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › ISWIN

ISWIN

Bestimmen Sie, ob eine Kontrolle

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DialogExists& = ISWIN( hDlg& )
ControlExists& = ISWIN( hParentDlg& , Ident& )

Beschreibung

Das Windows-Subsystem wird überprüft, um festzustellen, ob der angegebene Dialog oder das angegebene Steuerelement derzeit vorhanden ist. Diese Funktion kann für eine Vielzahl von Zwecken verwendet werden, ist jedoch besonders wertvoll, wenn Sie sicher sein möchten, dass ein CONTROL erfolgreich mit der Control-Add-Anweisung erstellt wurde.

Wenn Sie einen einzelnen Parameter verwenden, muss dieser das Handle eines Fensters, Dialogs oder Steuerelements angeben, das Sie überprüfen. Wenn Sie zwei Parameter verwenden, geben Sie das Handle des übergeordneten Elements und die Kennung des Steuerelements an, das Sie überprüfen.

Wenn das Ziel der Funktion aktuell existiert, wird TRUE (-1) zurückgegeben. Wenn es nicht existiert, ist der Rückgabewert FALSE (0).

Siehe auch

  • STEUERGRIFF
  • DIALOG NEU

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ITERATE � PBXB64-Compiler-Hilfe

Startseite � Funktionen � ITERATE

ITERATE

Starten Sie eine sofortige Iteration einer Schleife

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERF�GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ITERATE [DO | LOOP | WHILE | FOR]

Beschreibung

DerITERATE Die Anweisung �berspringt den Rest des aktuellen Schleifenk�rpers und f�hrt mit der n�chsten Iteration fort. F�r einen FOR/NEXT Schleife bedeutet, dass zum Schrittblock gesprungen wird; f�r DO/LOOPUndWHILE/WEND es bedeutet, zum Konditionstest zu springen.

Wenn kein Schl�sselwort angegeben ist, ITERATE wirkt sich auf die innerste umschlie�ende Schleife aus.

Beispiel

FUNCTION PBMAIN () AS LONG
    LOCAL i AS LONG
    LOCAL sum AS LONG
    sum = 0
    FOR i = 1 TO 10
        IF i MOD 2 = 0 THEN ITERATE FOR
        sum = sum + i
    NEXT i
    FUNCTION = sum
END FUNCTION

Dieses Programm summiert die ungeraden Zahlen von 1 bis 10 und gibt 25 zur�ck.

Generierter Assembler-Code

Kompilieren mit:

PBXB64 example.pb --asmout example.asm

ITERATE wird zu einem bedingungslosen Sprung zum Schritt-/Bedingungsblock der Schleife. Der Z�hler wird nicht ge�ndert:

    mov r10, [rbp-24]
    mov rbx, r10
    and rbx, 1
    cmp rbx, 0
    sete r10
    mov rbx, r10
    test rbx, rbx
    jne pb_if_then_PBMAIN_1
    jmp pb_if_else_PBMAIN_2
pb_if_then_PBMAIN_1:
    jmp pb_for_step_PBMAIN_0
pb_if_else_PBMAIN_2:
    ; body continues

Hinweise

  • ITERATE DOUndITERATE LOOP sind gegen DO/LOOP austauschbar.
  • ITERATE WHILE zielt auf den aktuellen WHILE/WEND-Bedingungsblock.
  • VerwendenEXIT um die Schleife vollst�ndig zu verlassen, anstatt eine Iteration zu �berspringen.

Verifiziertes Beispiel: ITERATE - zur naechsten Schleifenrunde springen

Beispieldatei: examples/basic/help_control_flow/help_iterate.pb

Validierungsnachweis: docs/pbwin_reviewed_control_flow_summary.md; tests/pb/test_all_control.bas

Validation evidence: the registered control-flow regression(s) named above compile and run with exit code 0, proving the page-specific branch, loop, or exception behavior documented here.

FUNCTION PBMAIN() AS LONG
    LOCAL i AS LONG
    LOCAL sum AS LONG
    FOR i = 1 TO 4
        IF i = 2 THEN ITERATE FOR
        sum = sum + i
    NEXT i
    IF sum <> 8 THEN FUNCTION = 1 ELSE FUNCTION = 0
END FUNCTION

Verhalten: Dokumentiert die PBXB64-Anweisung zum Fortsetzen der naechsten Schleifenrunde. Die Kompatibilitaetsseite CONTINUE verweist BASIC-Anwender auf die implementierte ITERATE-Form.

Siehe auch

  • FOR
  • WEITER
  • WHILE
  • DO
  • LOOP
  • AUSFAHRT
  • Kontrollflussreferenz

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


JOIN$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › JOIN$

JOIN$

Gibt eine Zeichenfolge zurück

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

A$ = JOIN$( array() , { delim$ | BINARY})

Beschreibung

JOIN$ erfordert eine Trennzeichenfolge delim$, die beliebig lang sein kann.

Wenn der Trennzeichenausdruck eine Nullzeichenfolge (Nulllänge) ist, werden zwischen den Zeichenfolgenabschnitten keine Trennzeichen eingefügt. Wenn der Trennzeichenausdruck der 3-Byte-Wert von „“,“ ist (der in Ihrem Quellcode als Zeichenfolgenliteral „““, „““ ausgedrückt werden kann), wird jedem Zeichenfolgenabschnitt ein führendes und abschließendes doppeltes Anführungszeichen hinzugefügt. Dadurch wird sichergestellt, dass die zurückgegebene Zeichenfolge standardmäßige, durch Kommas getrennte Felder in Anführungszeichen enthält, die leicht analysiert werden können.

Das durch array() angegebene Array kann ein beliebiger Datentyp sein.

BINÄR

Wenn das Array aus Elementen fester Größe besteht (numerisch, nullterminierte Zeichenfolgen usw.), besteht die zurückgegebene Zeichenfolge aus einem genauen Speicherabbild der Array-Daten im internen Format. Wenn das Array Daten variabler Länge enthält (dynamische Zeichenfolge, Feldzeichenfolge), werden sie im gepackten Zeichenfolgenformat von PowerBASIC und/oder Visual Basic gespeichert: Wenn eine Zeichenfolge kürzer als 65535 Bytes ist, beginnt sie mit einem 2 Byte langen WORD, gefolgt von den Zeichenfolgendaten. Andernfalls beginnt es mit einem 2-Byte-Wert von 65535, gefolgt von einem DWORD, das die String-Länge angibt, und schließlich den String-Daten selbst.

Die JOIN$-Funktion ist die natürliche Ergänzung zur PARSE-Anweisung.

Siehe auch

  • BUILD$
  • PARSE
  • PARSE$
  • PARSECOUNT

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


#JS - JavaScript-Block beginnen — PBXB64 Help

Startseite › General Reference › #JS - JavaScript-Block beginnen — PBXB64 Help
Hilfe zum PBXB64-Compiler

#JS - JavaScript-Block beginnen

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

#JS
// source text
#ENDJS

Detailverhalten

Wird als mehrsprachiges Direktivtoken erkannt. Es ist als Quelloberflaechen-Keyword dokumentiert; Runtime-JavaScript-Ausfuehrung benoetigt einen separat implementierten Lowering-Pfad.

Praktische Verwendung

Verwenden Sie diesen Einstieg fuer einen JavaScript-Block, wenn die Quelle JavaScript-nahe eingebettete Logik markieren muss. Der Block bleibt als zusammenhaengender Tokenbereich erkennbar, bis der passende Endmarker folgt.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Der Einstieg ersetzt keine echte Semantik fuer den eingebetteten Sprachblock. Ohne passenden Endmarker, passende Unterstuetzung oder passende Folgeimplementierung bleibt die Quelle unvollstaendig.

Verifiziertes Beispiel

Abgedeckt durch PB keyword compatibility (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


JSONFREE - PBXB64 Help

Startseite › General Reference › JSONFREE

JSONFREE

Release a JSON handle.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

status = JSONFREE(handle)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_jsonfree.html, damit Benutzer JSONFREE direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Release a JSON handle.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL h AS LONG h = JSONNEW(5) JSONSETINT h, "x", 1 PRINT JSONSTRINGIFY$(h, 0) ' {"x":1} JSONFREE h

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONFREE gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONFREE gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONFREE

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONGETBOOL - PBXB64 Help

Startseite › General Reference › JSONGETBOOL

JSONGETBOOL

Read a boolean value from a JSON object or array.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

value = JSONGETBOOL(handle, path$)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_jsongetbool.html, damit Benutzer JSONGETBOOL direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Read a boolean value from a JSON object or array.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL h AS LONG LOCAL txt$, ok AS LONG, q AS STRING q = CHR$(34) txt$ = "{" + q + "active" + q + ":true," + q + "deleted" + q + ":false}" h = JSONPARSE(txt$) IF h = 0 THEN FUNCTION = 1 ok = JSONGETBOOL(h, "active") IF ok <> 1 THEN FUNCTION = 2 ' true returns 1 ok = JSONGETBOOL(h, "deleted") IF ok <> 0 THEN FUNCTION = 3 ' false returns 0 JSONFREE h

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONGETBOOL gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONGETBOOL gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONGETBOOL

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONGETFLOAT - PBXB64 Help

Startseite › General Reference › JSONGETFLOAT

JSONGETFLOAT

Read a floating-point value from a JSON object or array.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

value## = JSONGETFLOAT(handle, path$)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_jsongetfloat.html, damit Benutzer JSONGETFLOAT direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Read a floating-point value from a JSON object or array.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL h AS LONG LOCAL txt$, q AS STRING LOCAL pi AS DOUBLE q = CHR$(34) txt$ = "{" + q + "pi" + q + ":3.14159}" h = JSONPARSE(txt$) IF h = 0 THEN FUNCTION = 1 pi = JSONGETFLOAT(h, "pi") IF pi < 3.14 OR pi > 3.15 THEN FUNCTION = 2 JSONFREE h

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONGETFLOAT gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONGETFLOAT gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONGETFLOAT

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONGETINT - PBXB64 Help

Startseite › General Reference › JSONGETINT

JSONGETINT

Read an integer value from a JSON object or array.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

value = JSONGETINT(handle, path$)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_jsongetint.html, damit Benutzer JSONGETINT direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Read an integer value from a JSON object or array.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL h AS LONG LOCAL txt$, v AS LONG, q AS STRING q = CHR$(34) txt$ = "{" + q + "x" + q + ":42," + q + "y" + q + ":3.14}" h = JSONPARSE(txt$) IF h = 0 THEN FUNCTION = 1 v = JSONGETINT(h, "x") IF v <> 42 THEN FUNCTION = 2 v = JSONGETINT(h, "y") IF v <> 3 THEN FUNCTION = 3 ' 3.14 truncated to 3 JSONFREE h

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONGETINT gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONGETINT gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONGETINT

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONGETSTR - PBXB64 Help

Startseite › General Reference › JSONGETSTR

JSONGETSTR

Read a string value from a JSON object or array.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

value$ = JSONGETSTR(handle, path$)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_jsongetstr.html, damit Benutzer JSONGETSTR direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Read a string value from a JSON object or array.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL h AS LONG LOCAL txt$, name$, q AS STRING q = CHR$(34) txt$ = "{" + q + "name" + q + ":" + q + "PBXB64" + q + "}" h = JSONPARSE(txt$) IF h = 0 THEN FUNCTION = 1 name$ = JSONGETSTR(h, "name") IF name$ <> "PBXB64" THEN FUNCTION = 2 JSONFREE h

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONGETSTR gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONGETSTR gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONGETSTR

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONNEW - PBXB64 Help

Startseite › General Reference › JSONNEW

JSONNEW

Create a new JSON value handle.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

handle = JSONNEW(type)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_jsonnew.html, damit Benutzer JSONNEW direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Create a new JSON value handle.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL hObj, hArr AS LONG hObj = JSONNEW(5) ' object hArr = JSONNEW(6) ' array JSONFREE hObj JSONFREE hArr

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONNEW gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONNEW gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONNEW

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONPARSE - PBXB64 Help

Startseite › General Reference › JSONPARSE

JSONPARSE

Parse a JSON text string into a handle.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

handle = JSONPARSE(jsonText$)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_jsonparse.html, damit Benutzer JSONPARSE direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Parse a JSON text string into a handle.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL h AS LONG LOCAL txt$ LOCAL q AS STRING q = CHR$(34) ' double-quote character txt$ = "{" + q + "name" + q + ":" + q + "PBXB64" + q + "," + q + "version" + q + ":10}" h = JSONPARSE(txt$) IF h = 0 THEN FUNCTION = 1 IF JSONGETSTR(h, "name") <> "PBXB64" THEN FUNCTION = 2 JSONFREE h

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONPARSE gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONPARSE gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONPARSE

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONREMOVE - PBXB64 Help

Startseite › General Reference › JSONREMOVE

JSONREMOVE

Remove a key from a JSON object or an element from a JSON array.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

status = JSONREMOVE(handle, path$)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_jsonremove.html, damit Benutzer JSONREMOVE direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Remove a key from a JSON object or an element from a JSON array.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL h AS LONG h = JSONNEW(5) JSONSETINT h, "a", 1 JSONSETINT h, "b", 2 JSONREMOVE h, "a" PRINT JSONSTRINGIFY$(h, 0) ' {"b":2} JSONFREE h

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONREMOVE gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONREMOVE gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONREMOVE

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONSETBOOL - PBXB64 Help

Startseite › General Reference › JSONSETBOOL

JSONSETBOOL

Set a boolean value in a JSON object or array.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

status = JSONSETBOOL(handle, path$, value)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_jsonsetbool.html, damit Benutzer JSONSETBOOL direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Set a boolean value in a JSON object or array.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL h AS LONG LOCAL st AS LONG h = JSONNEW(5) st = JSONSETBOOL(h, "active", 1) IF st <> 0 THEN FUNCTION = 1 IF JSONGETBOOL(h, "active") <> 1 THEN FUNCTION = 2 ' true is returned as 1 JSONFREE h

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONSETBOOL gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONSETBOOL gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONSETBOOL

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONSETFLOAT - PBXB64 Help

Startseite › General Reference › JSONSETFLOAT

JSONSETFLOAT

Speichert einen DOUBLE-Wert in einem JSON-Objekthandle unter dem angegebenen Eigenschaftsnamen.

Kind: Runtime helper | Category: WEB / Runtime Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

JSONSETFLOAT json&, name$, value#

Beschreibung

Diese eigene Seite stellt sicher, dass Befehlsuche, Stichwortindex und direkte Dateinamenpruefung die getestete Laufzeitfunktion unmittelbar finden. Die gruppierte WEB-Seite bleibt die breitere Familienreferenz.

Diese Seite dokumentiert einen JSON-Helfer, der auf Handles arbeitet. Erzeuger liefern ein Handle, das spaeter mit JSONFREE freigegeben werden muss, und Getter liefern typisierte Werte oder den dokumentierten Fallback.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL rc AS LONG
    JSONSETFLOAT j&, "pi", 3.14
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_web_json_set_float.pb` und `test_web_all.pb`.

Grenzen

Halten Sie JSON-Handles in Beispielen explizit und geben Sie sie in jedem Exit-Pfad frei. Behandeln Sie fehlende Pfade, ungueltige Handles und Typfehler als getrennte Faelle.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONSETFLOAT gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONSETFLOAT gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONSETFLOAT

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONSETINT - PBXB64 Help

Startseite › General Reference › JSONSETINT

JSONSETINT

Set an integer value in a JSON object or array.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

status = JSONSETINT(handle, path$, value)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_jsonsetint.html, damit Benutzer JSONSETINT direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Set an integer value in a JSON object or array.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL h AS LONG h = JSONNEW(5) JSONSETINT h, "answer", 42 JSONSETINT h, "count", 7 PRINT JSONSTRINGIFY$(h, 0) ' {"answer":42,"count":7} JSONFREE h

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONSETINT gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONSETINT gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONSETINT

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONSETNULL - PBXB64 Help

Startseite › General Reference › JSONSETNULL

JSONSETNULL

Set a JSON null in a JSON object or array.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

status = JSONSETNULL(handle, path$)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_jsonsetnull.html, damit Benutzer JSONSETNULL direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Set a JSON null in a JSON object or array.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL h AS LONG LOCAL s$ h = JSONNEW(5) IF JSONSETNULL(h, "deleted") <> 0 THEN FUNCTION = 1 s$ = JSONSTRINGIFY$(h, 0) IF INSTR(s$, "null") = 0 THEN FUNCTION = 2 JSONFREE h

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONSETNULL gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONSETNULL gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONSETNULL

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONSETSTRING - PBXB64 Help

Startseite › General Reference › JSONSETSTRING

JSONSETSTRING

Set a string value in a JSON object or array.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

status = JSONSETSTRING(handle, path$, value$)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_jsonsetstring.html, damit Benutzer JSONSETSTRING direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Set a string value in a JSON object or array.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL h AS LONG h = JSONNEW(5) JSONSETSTRING h, "name", "PBXB64" JSONSETSTRING h, "line", "Hello World" PRINT JSONSTRINGIFY$(h, 0) ' contains name and line keys JSONFREE h

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONSETSTRING gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONSETSTRING gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONSETSTRING

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONSTRINGIFY - PBXB64 Help

Startseite › General Reference › JSONSTRINGIFY

JSONSTRINGIFY

Serialize a JSON handle to a string.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

text$ = JSONSTRINGIFY$(handle, pretty)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_jsonstringify.html, damit Benutzer JSONSTRINGIFY direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Serialize a JSON handle to a string.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL h AS LONG LOCAL txt$ h = JSONNEW(5) JSONSETSTRING h, "name", "PBXB64" JSONSETINT h, "version", 10 txt$ = JSONSTRINGIFY$(h, 0) PRINT txt$ ' {"name":"PBXB64","version":10} JSONFREE h

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONSTRINGIFY gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONSTRINGIFY gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONSTRINGIFY

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


JSONTYPE - PBXB64 Help

Startseite › General Reference › JSONTYPE

JSONTYPE

Return the type name of a JSON value.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

type$ = JSONTYPE$(handle)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_jsontype.html, damit Benutzer JSONTYPE direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Return the type name of a JSON value.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL h AS LONG h = JSONNEW(5) PRINT JSONTYPE$(h) ' object JSONFREE h

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

JSONTYPE gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

JSONTYPE gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer JSON-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme. Geben Sie erzeugte Handles am Ende mit JSONFREE frei.

Eingaberegeln

Pruefen Sie den JSON handle, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

JSONTYPE

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


Was ist COM? - PBXB64-Compiler-Hilfe

Startseite › Funktionen › Was ist COM?
Hilfe zum PBXB64-Compiler

Just what is COM?

COM ist ein Akronym. Es stellt die Worte „Component Object Model“ dar.

Typ:Schlüsselwort |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Die kurze Antwort lautet: COM definiert eine Möglichkeit zur Kommunikation zwischen Codemodulen. Es folgt die etwas längere Antwort.

Sie sollten wissen, dass jedes in PowerBASIC erstellte oder definierte Objekt vollständig mit der COM-Spezifikation kompatibel ist. Viele beliebte Compiler sind nicht in der Lage, diese Behauptung genau zu machen. Die COM-Spezifikation definiert eine standardisierte Kommunikationsmethode zwischen Codemodulen (häufig als Komponenten bezeichnet), unabhängig von der Plattform oder dem Tool, mit dem sie erstellt wurden. COM-Komponenten sind wiederverwendbare Codeblöcke und zugehörige Daten, auf die andere „COM-fähige“ Komponenten und Anwendungen zugreifen können.

Eines der frustrierendsten Dinge an dieser Technologie ist die ständig wechselnde Liste von Schlagworten, mit denen sie beschrieben wird. Wir haben uns über OLE, VBX und OCX zu COM, ActiveX und mehr weiterentwickelt. Obwohl es viele Nuancen der Unterschiede gibt, ist es wichtig, sich daran zu erinnern, dass COM und ActiveX eine Möglichkeit zum Zugriff auf Code und Daten außerhalb des aktuellen Moduls beschreiben. COM+ bezieht sich auf einige Erweiterungen, die speziell für Win2000, WinXP und WinVista gelten. In dieser Diskussion verwenden wir die Begriffe COM-Objekt und ActiveX-Objekt, um Komponenten zu beschreiben: wiederverwendbare Codeblöcke und zugehörige Daten.

In früheren Versionen von PowerBASIC wurden Client-COM-Dienste eingeführt, auf die über die COM DISPATCH-Schnittstelle zugegriffen werden konnte. Obwohl die DISPATCH-Schnittstelle sehr flexibel und einfach zu verwenden ist, führt gerade diese Flexibilität zu einem Mehraufwand, der für viele Anwendungen nicht akzeptabel ist. Diese Version von PowerBASIC bietet die Möglichkeit, COM-Objekte über eine DIRECT INTERFACE oder eine DISPATCH INTERFACE zu erstellen und darauf zuzugreifen.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Just what is COM? soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Just what is COM? mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


KEYSTAT - PBXB64 Help

Startseite › General Reference › KEYSTAT

KEYSTAT

Prueft, ob eine virtuelle Taste derzeit gedrueckt ist.

Typ: Runtime method | Kategorie: Console I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED] fuer die fokussierte virtuelle-Tasten-Abfrage.

Syntax

result& = KEYSTAT(vk&)

Beschreibung

KEYSTAT prueft den aktuellen asynchronen Zustand eines Windows-Virtual-Key-Codes. PBXB64 senkt die Funktion auf den eingebetteten Laufzeithelfer bestof_keystat ab, der GetAsyncKeyState dynamisch laedt.

Praktische Verwendung

Verwenden Sie KEYSTATE fuer Abfragen der momentanen Lage einer virtuellen Taste, wenn Sie den asynchronen Tastenzustand beobachten wollen. Die Funktion gehoert zu kurzen Polling-Abfragen und nicht zu wartender oder gepufferter Eingabe.

Polling Notes

Verwenden Sie diese Helfer fuer schnelle Zustandsabfragen von Tasten. Sie warten nicht auf Eingabe und lesen nicht den Tastaturpuffer. KEYSTAT meldet den asynchronen Zustand.

Failure Notes

Virtual-Key-Codes ausserhalb des Bereichs liefern 0. Das fokussierte Beispiel verwendet VK_SHIFT, um den booleschen Vertragscharakter und einen stabilen, leicht reproduzierbaren Eingabestatus zu zeigen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    down = KEYSTAT(16)   ' VK_SHIFT
    IF down THEN PRINT "Shift is down"
END FUNCTION

Geprueftes Beispiel

Beispieldatei: tests/pb/test_keystat_keystate.pb

Validierungsnachweis: In tests/validate.toml als test_keystat_keystate registriert; fokussierte pb_linkrun-Validierung belegt die PB-Booleschenform fuer gueltige Tasten und den Rueckgabewert 0 ausserhalb des Bereichs.

Fehlerfaelle

Ein ungueltiger Virtual-Key-Code liefert 0. Da KEYSTATE den asynchronen Zustand prueft, sollte ein Test nicht den Tastaturpuffer oder eine bestimmte Ereignisreihenfolge voraussetzen.

Hinweise

  • KEYSTAT meldet den aktuellen Tastenstatus, nicht gepufferte Texteingabe.
  • Verwenden Sie INKEY$ oder WAITKEY$, wenn das Programm Zeicheneingabe braucht.

Siehe auch

Familienreferenz | BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


KEYSTATE - PBXB64 Help

Startseite › General Reference › KEYSTATE

KEYSTATE

Prueft den aktuellen Zustand einer virtuellen Taste.

Typ: Runtime method | Kategorie: Console I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED] fuer die fokussierte virtuelle-Tasten-Abfrage.

Syntax

result& = KEYSTATE(vk&)

Beschreibung

KEYSTATE prueft den aktuellen Zustand eines Windows-Virtual-Key-Codes. PBXB64 senkt die Funktion auf den eingebetteten Laufzeithelfer bestof_keystate ab, der GetKeyState dynamisch laedt.

Praktische Verwendung

Verwenden Sie KEYSTATE fuer Abfragen der momentanen Lage einer virtuellen Taste, wenn Sie den asynchronen Tastenzustand beobachten wollen. Die Funktion gehoert zu kurzen Polling-Abfragen und nicht zu wartender oder gepufferter Eingabe.

Polling Notes

Verwenden Sie diese Helfer fuer schnelle Zustandsabfragen von Tasten. Sie warten nicht auf Eingabe und lesen nicht den Tastaturpuffer. KEYSTATE meldet den aktuellen Zustand, KEYSTAT den asynchronen Zustand.

Failure Notes

Virtual-Key-Codes ausserhalb des Bereichs liefern 0. Das fokussierte Beispiel verwendet VK_SHIFT, um den booleschen Vertragscharakter und einen stabilen, leicht reproduzierbaren Eingabestatus zu zeigen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    down = KEYSTATE(16)   ' VK_SHIFT
    IF down THEN PRINT "Shift is down"
END FUNCTION

Geprueftes Beispiel

Beispieldatei: tests/pb/test_keystat_keystate.pb

Validierungsnachweis: In tests/validate.toml als test_keystat_keystate registriert; fokussierte pb_linkrun-Validierung belegt die PB-Booleschenform fuer gueltige Tasten und den Rueckgabewert 0 ausserhalb des Bereichs.

Fehlerfaelle

Ein ungueltiger Virtual-Key-Code liefert 0. Da KEYSTATE den asynchronen Zustand prueft, sollte ein Test nicht den Tastaturpuffer oder eine bestimmte Ereignisreihenfolge voraussetzen.

Hinweise

  • KEYSTATE meldet den virtuellen Tastenstatus, nicht gepufferte Texteingabe.
  • Exakte PBWin-Unterschiede bei Tastaturpuffer und Ereigniszeitpunkt ueber diese Abfrage hinaus bleiben breitere Kompatibilitaetsarbeit.

Siehe auch

Familienreferenz | BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


KILL – PBXB64-Compiler-Hilfe

Startseite › Funktionen › KILL

TÖTEN

Löschen Sie eine Festplattendatei.

Typ:Anweisung |Kategorie: Dateiverwaltung

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

KILL filespec

Beschreibung

filespec ist ein Zeichenfolgenausdruck, der die zu löschende(n) Datei(en) angibt und einen Pfadnamen und/oder „Platzhalter“-Zeichen enthalten kann. filespec kann entweder ein Short File Name (SFN) oder ein Long File Name (LFN) sein. Zum Beispiel:

TÖTE „TEST.DOC“

KILL „C:\MEINE ANWENDUNGSDATEN\INCOME.?87“

MyFile$ = "*.BAS"

KILL MyFile$ ' Potenziell gefährlich!

Wenn die Dateispezifikation nicht vorhanden ist, wird Fehler 53 („Datei nicht gefunden“) generiert. Wenn die Dateispezifikation schreibgeschützt ist, tritt Fehler 70 („Berechtigung verweigert“) auf. Sie sollten nicht versuchen, eine geöffnete Datei zu KILLEN.

Dateien mit dem Attribut HIDDEN oder SYSTEM können nicht mit KILL gelöscht werden. Ein entsprechender Versuch wird ignoriert und es wird kein Fehler generiert.

KILL ist analog zu den DOS-Befehlen „DEL“ und „ERASE“. KILL kann kein Verzeichnis löschen – verwenden Sie stattdessen RMDIR, nachdem Sie zuerst alle Dateien im Verzeichnis gelöscht haben.

Siehe auch

  • DATEIATTR
  • DATEIKOPIE
  • DATEINAME$
  • GETATTR
  • NAME
  • RMDIR
  • SETATTR
  • SETEOF

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Späte Bindung – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Spätes Binden

Späte Bindung

Die Standardmethode von DISPATCH heißt „Late Binding“, da nichts im Voraus erledigt wird. Keine Methodendefinitionen. Keine Schnittstellensignaturen. Sie können so ziemlich einfach mit dem Schreiben von Code beginnen:

Typ:Schlüsselwort |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

LOKALE DispVar AS IDISPATCH

LET DispVar = NEWCOM "DispProgID"

OBJEKTAUFRUF DispVar.Method1(x&, y$)

Es ist einfach so einfach. Die erste Zeile deklariert eine Objektvariable, die die DISPATCH-Schnittstelle übernimmt, während die zweite Zeile ein Objekt erstellt und eine Referenz auf DispVar zuweist. Die dritte Zeile führt lediglich eine Methode für das neue Objekt aus.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LBOUND – PBXB64-Compiler-Hilfe

Startseite › Funktionen › LBOUND

LBOUND

Geben Sie den kleinstmöglichen Wert zurück

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

y& = LBOUND( array [( dimension )])
y& = LBOUND( array , dimension )

Beschreibung

LBOUND kann in Kombination mit UBOUND verwendet werden, um die Größe eines Arrays zu bestimmen. LBOUND eines nicht dimensionierten Arrays gibt Null zurück. Die LBOUND-Funktion besteht aus folgenden Teilen:

Name des interessierenden Arrays.

Dimension

Eine Ganzzahl, die die untere Grenze der Dimension angibt, wird zurückgegeben. Wenn nicht angegeben, wird die erste Dimension angenommen.

Einschränkungen

LBOUND kann nicht für Arrays innerhalb benutzerdefinierter Typen verwendet werden.

Siehe auch

  • ARRAYATTR
  • DIM
  • REDIM
  • UBOUND

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LET – PBXB64-Compiler-Hilfe

Startseite › Funktionen › LET

LET

Weisen Sie a einen Wert zu

Typ:Anweisung |Kategorie:Variablen und Umfang

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

[LET] variable = expression
[LET] variable += expression
[LET] variable -= expression
[LET] variable *= expression
[LET] variable /= expression
[LET] variable \= expression
[LET] variable &= expression
[ LET] variable AND= expression
[LET] variable OR= expression
[LET] variable EQV= expression
[LET] variable IMP= expression
[LET] variable MOD= expression
[LET] variable XOR= expression

Beschreibung

Einfache Zuordnung

Variable ist eine Zeichenfolge oder eine numerische Variable und der Ausdruck ist von einem geeigneten Typ (d. h. ein Zeichenfolgenausdruck für Zeichenfolgenvariablen und ein numerischer Ausdruck für numerische Variablen).

Das Wort LET ist in Zuweisungsanweisungen optional. Es ist zulässig, Kompatibilität mit BASIC-Quelldateien bereitzustellen, die für frühere BASIC-Versionen geschrieben wurden. In der Praxis wird das Wort LET sehr selten verwendet.

Um eine einfache Konvertierung zu ermöglichen, erlaubt PowerBASIC einen benutzerdefinierten Typ in einem Zeichenfolgenausdruck. Der benutzerdefinierte Typ wird einfach Byte für Byte in den Ausdruck kopiert. Um jedoch eine Zeichenfolge wieder einem benutzerdefinierten Typ zuzuweisen, sollten Sie die TYPE SET-Anweisung verwenden.

DIM abc als MyType

MyString$ = abc

Spezielle Informationen zur Zuweisung mithilfe von Objektvariablen, Variant-Variablen und benutzerdefinierten Typvariablen finden Sie in den folgenden Abschnitten der LET-Anweisung.

Zusammengesetzte Zuordnung

Eine zusammengesetzte Zuweisungsanweisung kombiniert einen binären arithmetischen Operator, einen binären bitweisen Operator oder einen binären String-Operator (Verkettung) als integralen Bestandteil der Zuweisung. Dies bietet dem Programmierer eine „Verknüpfung“ zu Ihrem Quellcode und kann sogar zu einer effizienteren Codegenerierung führen. Das liegt daran, dass die Zielvariable nur einmal ausgewertet wird, auch wenn eine Array- oder Zeigerberechnung einen Nebeneffekt haben könnte, der sie verändert.

Zusammengesetzte Zuweisungen sind für die arithmetischen Standardoperationen Addieren, Subtrahieren, Multiplizieren, Dividieren, Int-Dividieren und Modulo (+ - * / \ MOD ), die bitweisen Operationen ( AND , OR , XOR , EQV , IMP ) und die Verkettungsoperatoren (+ &) verfügbar. Jeder wird durch einen der folgenden Token repräsentiert:

Jedes der folgenden Codepaare ist funktional identisch:

x = x + 1

x += 1

x = x / y

x /= y

x = x XOR 3

x XOR= 3

x(7) = x(7) UND 5

x(7) UND= 5

x$ = x$ + y$

x$ += y$

Siehe auch

  • BUILD$
  • JOIN$
  • LET (with Objects)
  • LET (mit Varianten)
  • LET (mit Typen)
  • TYP EINGESTELLT

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LET-Anweisung (mit Objekten) – PBXB64 Compiler-Hilfe

Startseite › Funktionen › LET-Anweisung (mit Objekten)
Hilfe zum PBXB64-Compiler

LET-Anweisung (mit Objekten)

Weisen Sie eine zu

Typ:Anweisung |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

[LET] objvar = object expression

Beschreibung

Die LET-Anweisung und ihre implizite Form (ohne Verwendung des Wortes LET) können verwendet werden, um einer Objektvariablen eine Objektreferenz zuzuweisen. Nachdem Sie eine Objektvariable als bestimmte Schnittstelle deklariert haben, müssen Sie ein Objekt erstellen und/oder ihm einen Objektverweis zuweisen, bevor Sie die Objektmitglieder (Methoden, Eigenschaften usw.) verwenden können.

Wenn eine Objekterstellung oder -zuweisung aus irgendeinem Grund fehlschlägt, wird die objvar auf NOTHING gesetzt. Wenn diese Anweisung fehlschlägt, werden keine Fehler generiert und es wird auch kein OBJRESULT festgelegt. Sie sollten den Erfolg der Operation mit ISOBJECT ( objvar ) testen, bevor Sie versuchen, das Objekt zu verwenden oder seine Methoden auszuführen.

LET objvar = CLASS ClassName$

Der Begriff „ClassName“ muss als String-Literal in Anführungszeichen angegeben werden. Dabei handelt es sich um den Namen einer im Programm implementierten Klasse. Da die Klasse intern ist (der Name ist zur Kompilierzeit bekannt), dürfen Sie keine String-Variablen oder Ausdrücke verwenden. Bei der Ausführung wird ein neues Objekt erstellt und der Objektvariablen objvar ein Verweis auf dieses Objekt zugewiesen. Die angeforderte Schnittstelle wird durch die ursprüngliche Deklaration von objvar bestimmt. Wenn InterfaceName DISPATCH ist, können Sie mit der OBJECT-Anweisung darauf verweisen – andernfalls werden reguläre Methoden- und Eigenschaftsverweise verwendet.

LET objvar = NEWCOM PrgID$

LET objvar = GETCOM PrgID$

LET objvar = ANYCOM PrgID$

Diese Form der LET-Anweisung wird verwendet, um mithilfe der COM-Funktionen von Windows eine Objektreferenz außerhalb des Programms zu erhalten. Wenn sich das angeforderte Objekt in einer DLL (In-Process-Server) befindet, verwenden Sie immer die Option NEWCOM, wenn Sie ein neues Objekt anfordern. Wenn die Anfrage erfolgreich ist, wird die Objektreferenz der objvar zugewiesen.

Wenn sich das angeforderte Objekt in einer EXE-Datei (Out-of-Process-Server) befindet, können Sie eine der drei Optionen verwenden. Wenn das Direktorwort NEWCOM angegeben wird, wird eine neue Instanz einer COM-Anwendung erstellt. Mit GETCOM wird eine Schnittstelle zu einer bestehenden, laufenden Anwendung geöffnet, die als aktives Automatisierungsobjekt für ihre Klasse registriert wurde. Bei ANYCOM versucht der Compiler zunächst, eine vorhandene, laufende Anwendung zu verwenden, sofern verfügbar, oder eine neue Instanz, falls nicht.

Der Zeichenfolgenausdruck ProID$ ergibt einen ProgID-Namen auf einem externen COM-Server. Wenn der InterfaceName DISPATCH ist, können Sie mit der OBJECT-Anweisung darauf verweisen – andernfalls werden stattdessen reguläre Methoden- und Eigenschaftsverweise verwendet.

LET objvar = NEWCOM CLSID ClassID$

LET objvar = GETCOM CLSID ClassID$

LET objvar = ANYCOM CLSID ClassID$

Auch dieses Formular erhält ein COM-Objekt, genau wie die Beispiele im obigen Abschnitt. Es besteht immer eine Eins-zu-eins-Beziehung zwischen einer ProgID und einer CLSID (Klassen-ID). Ein Objekt kann durch jedes dieser Token identifiziert werden, sofern beide verfügbar sind. In einigen Fällen kann es vorkommen, dass Sie auf ein Objekt stoßen, für das keine ProgID veröffentlicht wurde. Sie können die Klausel „CLSID ClassID$“ durch die Klausel „PrgID$“ ersetzen. Es funktioniert genauso wie die übliche Form oben, außer dass es das angeforderte Objekt durch seine 16-Byte-GUID beschreibt, die die CLSID (Klassen-ID) des Objekts ist.

LET objvar = NEWCOM CLSID ClassID$ LIB DLLPath$

PowerBASIC bietet die einzigartige Möglichkeit, COM-Objekte zu erstellen und zu referenzieren, ohne überhaupt auf die Registrierung zu verweisen. Solange Sie die CLSID (Klassen-ID) und den Dateipfad/-namen der DLL kennen, auf die zugegriffen werden soll, können Sie dies ohne Registrierungszugriff tun. Sie benötigen keinen speziellen COM-Servertyp. Diese Technik kann mit jedem Server verwendet werden, unabhängig davon, ob er mit PowerBASIC oder einem anderen Compiler erstellt wurde. Bei Verwendung dieser Methode der Objekterstellung ist eine Registrierung des Servers überhaupt nicht erforderlich. Auf diese Weise können Sie lokale Kopien der von Ihnen verwendeten COM-Server aufbewahren, ohne dass die Gefahr besteht, dass diese durch eine andere Anwendung geändert oder ersetzt werden. Sie verwenden das obige Formular, wobei die Klausel „CLSID ClassID$“ die 16-Byte-Klassen-ID identifiziert und die Klausel „LIB DllPath$“ den Dateipfad und Dateinamen des COM-Servers identifiziert. Sobald Sie die COM-Objektreferenz in objvar erhalten haben, wird sie genau wie ein herkömmliches Objekt verwendet.

LET objvar1 = objvar2

Wenn beide Objektvariablen als derselbe Objekttyp (derselbe Schnittstellenname) deklariert wurden, wird die Quellvariable ( objvar2 ) in die Zielvariable ( objvar1 ) kopiert und der Referenzzähler des Objekts wird erhöht. Wenn es sich bei den Objektvariablen um unterschiedliche Objekttypen handelt, wird eine neue Schnittstelle (des durch objvar1 implizierten Typs) auf objvar2 geöffnet und objvar1 ein Verweis darauf zugewiesen.

LET objvar = objmethod (params)

Es wird davon ausgegangen, dass die durch objmethod angegebene METHOD oder GET PROPERTY ein Objekt vom Typ objvar zurückgibt. Die Methode obj wird ausgewertet und die Objektreferenz, die sie zurückgibt, wird objvar zugewiesen.

LET objvar = ME

Dieses Formular darf nur innerhalb einer METHODE oder EIGENSCHAFT verwendet werden. Für das aktuelle Objekt wird eine neue Schnittstelle (des von objvar implizierten Typs) geöffnet und objvar ein Verweis darauf zugewiesen.

LET objvar = NICHTS

Dadurch wird eine Objektvariable zerstört und ihre Zuordnung zu einem bestimmten Objekt unterbrochen. Dies wiederum gibt alle mit dem Objekt verknüpften System- und Speicherressourcen frei, wenn keine Objektvariablen mehr darauf verweisen.

LET objvar = vrnt

Versucht, eine Schnittstelle der angegebenen Klasse für objvar auf dem Objekt von vrnt zu öffnen, und weist objvar eine Referenz zu. Es wird davon ausgegangen, dass vrnt einen Verweis auf ein Objekt vom Typ %VT_UNKNOWN oder %VT_DISPATCH enthält. Wenn die gewünschte Schnittstelle nicht geöffnet werden kann, wird die Objektvariable objvar auf NICHTS gesetzt.

LET vrnt = objvar

Dies kann verwendet werden, um eine Objektreferenz von einer Objektvariablen zu einer Variantenvariablen zuzuweisen. Es versucht, eine IDispatch-Schnittstelle oder eine IUnknown-Schnittstelle für das Objekt von objvar zu öffnen, und weist diesen Verweis vrnt zu. Variantenvariablen dürfen keine Verweise auf benutzerdefinierte Schnittstellen enthalten, sondern nur IDispatch oder IUnknown. Wenn die Zuweisung erfolgreich ist, gibt VARIANTVT (vrnt) entweder %VT_UNKNOWN oder %VT_DISPATCH zurück. Wenn dies nicht erfolgreich ist, wird vrnt auf %VT_EMPTY gesetzt.

Frühere Versionen von PowerBASIC-Compilern verwendeten die SET-Anweisung zum Erstellen von Objekten. LET enthält jetzt alle Funktionen der alten SET-Anweisung, daher sollten Sie planen, alle SET-Anweisungen so schnell wie möglich zu entfernen. Dies beinhaltet nichts weiter, als jedes SET in LET zu ändern oder einfach jedes SET zu löschen.

Siehe auch

  • LET
  • LET (mit Varianten)
  • LET (mit Typen)
  • INTERFACE (Direct)
  • INTERFACE (IDBind)
  • ISINTERFACE
  • ISNOTHING
  • ISOBJECT
  • Just what is COM?
  • ICH
  • OBJECT
  • Was ist überhaupt ein Objekt?

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


LET-Anweisung (mit Typen) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › LET-Anweisung (mit Typen)
Hilfe zum PBXB64-Compiler

LET-Anweisung (mit Typen)

Weisen Sie Daten einem zu

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

[LET] TypeVar = TypeVar
[LET] TypeVar = VARIANT$( VrntVar )

Beschreibung

Typevar ist eine benutzerdefinierte Typvariable. Um eine direkte Zuweisung von Daten von einer benutzerdefinierten Typvariablen zu einer anderen durchführen zu können, müssen diese auf denselben Typ dimensioniert sein. Um Daten zwischen zwei verschiedenen Typen zuzuordnen, sollten Sie stattdessen die TYPE SET-Anweisung verwenden.

Das Wort LET ist in Zuweisungsanweisungen optional. Es ist zulässig, Kompatibilität mit BASIC-Quelldateien bereitzustellen, die für frühere BASIC-Versionen geschrieben wurden. In der Praxis wird das Wort LET sehr selten verwendet.

Wenn benutzerdefinierte Typdaten in einer Variantenvariablen gespeichert werden, können sie wie im zweiten Syntaxbeispiel extrahiert werden. Die Funktion Variant$() versteht, dass UDT-Daten als Byte-String gespeichert werden.

Um eine einfache Konvertierung zu ermöglichen, erlaubt PowerBASIC einen benutzerdefinierten Typ in einem Zeichenfolgenausdruck. Der benutzerdefinierte Typ wird einfach Byte für Byte in den Ausdruck kopiert. Um eine Zeichenfolge wieder einem benutzerdefinierten Typ zuzuweisen, können Sie auch die TYPE SET-Anweisung verwenden. Wenn ein UDT in einem WIDE-String-Ausdruck (Unicode) verwendet wird, führt dies im Allgemeinen zu unvorhersehbaren Ergebnissen bei der Zeichenkonvertierung.

DIM abc als MyType

MyString$ = abc

Siehe auch

  • LET
  • LET (with Objects)
  • LET (mit Varianten)
  • TYP EINGESTELLT
  • VARIANTE$

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


LET-Anweisung (mit Varianten) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › LET-Anweisung (mit Varianten)
Hilfe zum PBXB64-Compiler

LET-Anweisung (mit Varianten)

Weisen Sie einen Wert oder eine zu

Typ:Anweisung |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

[LET] VariantVar = variant expression
[LET] VariantVar = TypeVar AS STRING

Beschreibung

Obwohl sie bekanntermaßen nicht effizient genug sind, werden Variant-Variablen aufgrund ihrer Flexibilität häufig als COM-Objektparameter verwendet. Sie erweisen sich auch in Situationen als wertvoll, in denen eine Prozedur ordnungsgemäß mit Parametern mehrerer Datentypen ausgeführt werden muss (eine Sammlung wäre ein gutes Beispiel). Sie können sich einen Variant als eine Art Container vorstellen, der eine Variable fast jedes Datentyps, eine Zahl, einen String, ein Objekt oder sogar einen UDT oder ein ganzes Array enthalten kann. Dies vereinfacht den Prozess des Aufrufs von Prozeduren in einem COM-Objektserver, da Sie sich kaum Gedanken über die unzähligen möglichen Datentypen für jeden Parameter machen müssen.

Diese Flexibilität hat ihren Preis in puncto Leistung, weshalb PowerBASIC ihre Verwendung lediglich auf die Datenspeicherung und Parameter beschränkt. Mit der LET-Anweisung oder ihrem impliziten Äquivalent können Sie einem Variant einen numerischen Wert, einen String-Wert, einen UDT, ein Objekt oder sogar ein ganzes Array zuweisen. Auf die gleiche Weise können Sie einen Variant-Wert einer anderen Variant-Variablen zuweisen oder sogar ein in einem Variant enthaltenes Array einem kompatiblen PowerBASIC-Array zuweisen oder umgekehrt.

Sie können einen Skalarwert aus einer Variante mit VARIANT# (für numerische Werte), VARIANT$ (für ANSI-Byte-Strings oder benutzerdefinierte Typen) oder VARIANT$$ (für breite Unicode-Strings) extrahieren. Wenn Sie einer Variantenvariablen Zeichenfolgendaten zuweisen, werden ANSI-Zeichenfolgen automatisch in breite Unicode-Zeichen konvertiert, da dies der akzeptierte Standard für Varianten ist. Wenn Sie jedoch UDT-Daten einer Variantenvariablen zuweisen, werden diese als dynamische Bytefolge gespeichert. Wenn Sie diese UDT-Daten (mit Variant$) abrufen, versteht PowerBASIC den Inhalt und verarbeitet ihn korrekt. Bei anderen Programmiersprachen ist dies jedoch möglicherweise nicht der Fall, daher sollte die Verwendung dieser Technik auf PowerBASIC-Anwendungen beschränkt sein.

LET VrntVar = vrntvar

Dieses Formular dupliziert den Inhalt einer Variantenvariablen und weist ihn einer zweiten Variantenvariablen zu.

LET VrntVar = Ausdruck [AS vartype ]

Der numerische oder Zeichenfolgenausdruck wird ausgewertet und das Ergebnis in der Variantenvariablen gespeichert. PowerBASIC wählt einen geeigneten numerischen oder String-Datentyp zur Verwendung aus. Sie können jedoch ein bevorzugtes Format angeben, indem Sie eine optionale AS-Vartype-Klausel hinzufügen. Dies kann BYTE, WORD, DWORD, INTEGER, LONG, QUAD, SINGLE, DOUBLE, CURRENCY oder WSTRING sein. Zeichenfolgen in einer Variante werden immer im breiten Unicode gespeichert, unabhängig davon, ob Sie AS WSTRING hinzufügen oder nicht. PowerBASIC führt die Konvertierung bei Bedarf automatisch durch.

In früheren Versionen von PowerBASIC wurde der Begriff AS STRING als AS WSTRING für Wide Unicode interpretiert. Mit der neuen Unterstützung für Unicode-Datentypen kann dies jedoch nicht mehr zugelassen werden. Alle Verweise auf AS STRING mit Varianten müssen in AS WSTRING geändert werden.

LET VrntVar = TypeVar AS STRING

Die in der benutzerdefinierten Typvariablen (UDT) enthaltenen Daten werden in der Variantenvariablen gespeichert. Es wird intern als dynamische Bytefolge (vt_bstr) gespeichert. Wenn Sie diese UDT-Daten (mit Variant$) abrufen, versteht PowerBASIC den Inhalt und verarbeitet ihn korrekt. Andere Programmiersprachen verstehen diese Technik jedoch möglicherweise nicht, daher sollte sie im Allgemeinen auf PowerBASIC-Anwendungen beschränkt werden.

In früheren Versionen von PowerBASIC war die AS STRING-Klausel nicht wie derzeit erforderlich. Obwohl es sich um eine Änderung handelt, war es eine notwendige Einschränkung, um zu bestätigen, dass die Konvertierung in einen String Ihre Absicht ist.

LET VrntVar = EMPTY

Die Variantenvariable ist auf %VT_EMPTY gesetzt, was bedeutet, dass sie keinerlei Wert enthält.

LET VrntVar = ERROR numr

Dieses Formular weist eine bestimmte COM-Fehlernummer zu, bei der es sich normalerweise um einen COM-spezifischen Fehler handelt, z. B. %E_NOINTERFACE usw.

LET VrntVar = array()

Einer Variantenvariablen wird ein gesamtes PowerBASIC-Array zugewiesen. Im Falle eines String-Arrays übernimmt PowerBASIC automatisch die für die COM-Spezifikation erforderlichen Unicode-Konvertierungen. Die Array-Zuweisung ist auf die folgenden Datentypen beschränkt: BYTE, WORD, DWORD, INTEGER, LONG, QUAD, SINGLE, DOUBLE, CURRENCY oder STRING, da Windows nicht alle PowerBASIC-Datenformen unterstützt.

LET array() = vrntvar

Ein ganzes Array wird von einer Variantenvariablen einem PowerBASIC-Array zugewiesen. Im Fall eines String-Arrays übernimmt PowerBASIC automatisch Unicode-Konvertierungen. Sie können einem PowerBASIC-Array kein Array mit mehr als acht Dimensionen zuweisen.

LET VrntVar = BYREF-Variable

Dieses Formular wird verwendet, um einer Variante zu ermöglichen, einen typisierten Zeiger auf eine bestimmte Variable zu enthalten. Alle Änderungen an der Variante führen dazu, dass die Variable geändert wird, da sie das Ziel des Zeigers ist. Die Variable kann einen beliebigen Datentyp haben, der von Varianten und COM-Objekten unterstützt wird: Byte, Word, Dword, Integer, Long, Quad, Single, Double, Currency, Variant, String und WString. Wenn Sie versuchen, einen nicht unterstützten Variablentyp (wie Extended , Bit , STRINGZ usw.) zu verwenden, generiert PowerBASIC einen Fehler 482 (Datentypkonflikt). Darüber hinaus dürfen Sie keine Registervariable (automatisch oder explizit) verwenden, da sonst der Fehler 491 (Ungültige Registervariable) generiert wird. Beachten Sie, dass mit COM-Objekten verwendete Zeichenfolgen voraussichtlich im Unicode-Format und nicht im ANSI-Format vorliegen. Bei Bedarf können die Funktionen ACODE$ und UCODE$ zum Konvertieren der Zeichenfolgen verwendet werden. Sie sollten bei einer BYREF-ANSI-Zeichenfolge Vorsicht walten lassen, da sie von anderem Code, der nur Unicode-Zeichenfolgen erwartet, möglicherweise nicht genau erkannt wird.

LET objvar = vrnt

Versucht, eine Schnittstelle der angegebenen Klasse für objvar auf dem Objekt von vrnt zu öffnen, und weist objvar eine Referenz zu. Es wird davon ausgegangen, dass vrnt einen Verweis auf ein Objekt vom Typ %VT_UNKNOWN oder %VT_DISPATCH enthält. Wenn die gewünschte Schnittstelle nicht geöffnet werden kann, wird die Objektvariable objvar auf NICHTS gesetzt. Sie können mit der Funktion ISOBJECT (objvar) auf Erfolg/Misserfolg testen.

LET vrnt = objvar

Dies kann verwendet werden, um eine Objektreferenz von einer Objektvariablen zu einer Variantenvariablen zuzuweisen. Es versucht, eine IDispatch-Schnittstelle oder eine IUnknown-Schnittstelle für das Objekt von objvar zu öffnen, und weist diesen Verweis vrnt zu. Variantenvariablen dürfen keine Verweise auf benutzerdefinierte Schnittstellen enthalten, sondern nur IDispatch oder IUnknown. Wenn die Zuweisung erfolgreich ist, gibt VARIANTVT (vrnt) entweder %VT_UNKNOWN oder %VT_DISPATCH zurück. Wenn dies nicht erfolgreich ist, wird vrnt auf %VT_EMPTY gesetzt.

Siehe auch

  • Just what is COM?
  • LET
  • LET (with Objects)
  • LET (mit Typen)
  • VARIANTE#
  • VARIANTE$
  • VARIANTEVT

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LibMain – PBXB64-Compiler-Hilfe

Startseite › Funktionen › LibMain

LibMain

Zusätzlich zu den Funktionen, die Sie exportieren möchten (plus allen unterstützenden privaten Routinen), kann eine DLL eine optionale Funktion namens LIBMAIN (oder deren Synonyme DLLMAIN und PBLIBMAIN ) enthalten. Windows ruft LI auf

Typ:Schlüsselwort |Kategorie: Procedures

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Erstellen einer Dynamic Link Library

Private und exportierte Verfahren

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


DLLMAIN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DLLMAIN

DLLMAIN

LIBMAIN (oder sein Synonym DLLMAIN) ist eine optionale benutzerdefinierte Funktion, die von Windows jedes Mal aufgerufen wird, wenn a

Typ:Funktion |Kategorie: Procedures

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

FUNCTION { LIBMAIN | DLLMAIN } ( _
BYVAL hInstance AS DWORD, _
BYVAL lReason AS LONG, _
BYVAL lReserved AS LONG ) AS LONG

Beschreibung

Rückgabewert: Wenn LIBMAIN mit %DLL_PROCESS_ATTACH aufgerufen wird, sollte Ihre LIBMAIN-Funktion eine Null (0) zurückgeben, wenn ein Teil Ihres Initialisierungsprozesses fehlschlägt, oder eine Eins (1), wenn keine Fehler aufgetreten sind. Wenn eine Null zurückgegeben wird, bricht Windows ab und entlädt die DLL aus dem Speicher. Wenn LIBMAIN mit einem anderen Wert als %DLL_PROCESS_ATTACH aufgerufen wird, wird der Rückgabewert ignoriert.

Die Funktion LIBMAIN / DLLMAIN stellt die folgenden Parameter bereit:

hInstanz

Das eindeutige Instanzhandle der DLL. Dieses Handle wird von der aufrufenden Anwendung verwendet, um die DLL zu identifizieren. Der Instanz-Handle-Wert wird üblicherweise zum Laden von in der DLL eingebetteten Ressourcen und zum Abrufen des tatsächlichen Dateinamens der DLL (über die API-Funktion GetModuleFilename) verwendet. In diesen Fällen ist es üblich, den hInstance-Wert in eine globale Variable zu kopieren, sodass der Instanz-Handle-Wert an anderer Stelle in der DLL verwendet werden kann.

lGrund

Dieses Flag gibt an, warum der DLL-Einstiegspunkt aufgerufen wird. Es kann einer der folgenden Werte sein (wie in WIN32API.INC definiert):

%DLL_PROCESS_ATTACH

Zeigt an, dass die DLL von einem Prozess geladen wird (eine andere DLL oder EXE lädt die DLL). DLLs können diese Gelegenheit nutzen, um beliebige Instanzen oder globale Daten wie Arrays zu initialisieren. lReserved ist Null, wenn die DLL explizit mit LoadLibrary() geladen wird (Laufzeitverknüpfung), oder ungleich Null, wenn die DLL während der Prozessinitialisierung implizit geladen wird (Laufzeitverknüpfung).

%DLL_PROCESS_DETACH

Zeigt an, dass die DLL sauber entladen oder von der aufrufenden Anwendung getrennt wird. DLLs können diese Gelegenheit nutzen, um alle Ressourcen für alle Threads zu bereinigen, die der DLL zugeordnet und ihr bekannt sind. Dies entspricht funktional der WEP-Funktion in 16-Bit-DLLs. lReserved ist Null, wenn LIBMAIN über die FreeLibrary-API ausgeführt wurde und der DLL-Referenzzähler Null erreicht hat (es werden keine weiteren Instanzen der DLL geladen), oder ungleich Null, wenn LIBMAIN während der Prozessbeendigung ausgeführt wird. Ein %DLL_PROCESS_DETACH generiert kein %DLL_THREAD_DETACH für aktive Threads.

%DLL_THREAD_ATTACH

Zeigt an, dass die DLL von einem neuen Thread in der aufrufenden Anwendung geladen wird. DLLs können diese Gelegenheit nutzen, um jeden Thread Local Storage (TLS) zu initialisieren. Diese Ausführung erfolgt im Kontext des neuen Threads.

%DLL_THREAD_DETACH

Zeigt an, dass der Thread sauber beendet wird. Wenn die DLL threadspezifischen Speicher (Thread Local Storage oder TLS) zugewiesen hat, sollte dieser freigegeben werden. Dies kann auch dann auftreten, wenn kein passender %DLL_THREAD_ATTACH-Aufruf vorhanden ist. Ein %DLL_PROCESS_DETACH generiert kein %DLL_THREAD_DETACH für aktive Threads.

lReserviert

Der Parameter lReserved gibt weitere Aspekte der DLL-Initialisierung und -Bereinigung an. Wenn lReason %DLL_PROCESS_ATTACH ist, ist lReserved Null (0) für explizite (dynamische) Ladevorgänge und ungleich Null für implizite Ladevorgänge. Wenn lReason %DLL_PROCESS_DETACH ist, ist lReserved Null, wenn LIBMAIN mithilfe des FreeLibrary-API-Aufrufs aufgerufen wurde, und ungleich Null, wenn LIBMAIN während der Prozessbeendigung aufgerufen wurde.

Rückgabewert

Wenn LIBMAIN mit %DLL_PROCESS_ATTACH aufgerufen wird, sollte Ihre LIBMAIN-Funktion eine Null (0) zurückgeben, wenn ein Teil Ihres Initialisierungsprozesses fehlschlägt, oder eine Eins (1), wenn keine Fehler aufgetreten sind. Wenn eine Null zurückgegeben wird, bricht Windows ab und entlädt die DLL aus dem Speicher. Wenn LIBMAIN mit einem anderen Wert als %DLL_PROCESS_ATTACH aufgerufen wird, wird der Rückgabewert ignoriert.

Einschränkungen

Beachten Sie, dass Windows nicht garantiert, dass LIBMAIN „ausgewogen“ aufgerufen wird. Beispielsweise folgt auf einen %DLL_PROCESS_ATTACH kein %DLL_THREAD_ATTACH für den primären Thread. Unter bestimmten Bedingungen tritt %DLL_THREAD_DETACH möglicherweise überhaupt nicht auf. Eine weitere Diskussion dieser Windows-Merkmale würde den Rahmen dieser Dokumentation sprengen; Eine hervorragende Informationsquelle finden Sie jedoch in „Win32 Programming“, Rector/Newcomer, ISBN 0-201-63492-9.

An dem Punkt, an dem eine DLL während des Prozessstarts in den Speicher geladen wird, garantiert Windows nur, dass die Systembibliothek KERNEL32.DLL in den Speicher geladen wird. Auf dieser Grundlage müssen API-Aufrufe aus LIBMAIN auf den Bereich der in KERNEL32.DLL vorhandenen API-Funktionen beschränkt werden, mit Ausnahme der API-Funktionen LoadLibrary, LoadLibraryEx und FreeLibrary.

Darüber hinaus darf Code in LIBMAIN keine API-Funktionen in einer anderen DLL aufrufen (z. B. USER32.DLL, SHELL32.DLL, ADVAPU32.DLL, GDI32.DLL usw.), da einige API-Funktionen in diesen DLLs möglicherweise versuchen, andere Bibliotheken über LoadLibrary usw. zu laden. Rufen Sie beispielsweise niemals die MessageBox-API-Funktion innerhalb von LIBMAIN auf und verwenden Sie auch nicht die zugehörige MSGBOX-Funktion oder MSGBOX-Anweisung.

Die Nichtbeachtung dieser Einschränkungen führt zu Zugriffsverletzungen oder allgemeinen Schutzfehlern (GPFs), die typischerweise durch die Ausführung von Code in DLLs verursacht werden, der noch initialisiert werden muss.

Siehe auch

  • DLLMAIN
  • PBLIBMAIN
  • PBMAIN
  • THREAD CREATE
  • WINMAIN

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


LINE INPUT# – PBXB64-Compiler-Hilfe

Startseite › Funktionen › LINE INPUT#

LINE-EINGANG#

Zeile(n) aus a lesen

Typ:Anweisung |Kategorie:Datei-E/A

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

LINE INPUT # filenum& , string_variable
LINE INPUT # filenum& , Arr$() [RECORDS rcds ] [TO count ]

Beschreibung

filenum& ist die Dateinummer oder eine Variable, die eine Dateinummer enthält, die beim Öffnen der Datei angegeben wurde. string_variable ist die String-Variable, die mit den aus der Datei gelesenen Daten geladen werden soll.

string_variable kann eine Zeichenfolge mit fester Länge, nullterminiert oder dynamisch sein. Bei Zeichenfolgen fester Länge und mit Nullterminierung werden Daten, die länger als die Zeichenfolge sind, gekürzt, damit sie in die Zeichenfolge passen. Dynamische Zeichenfolgen empfangen die Daten ohne Kürzung. string_variable ist möglicherweise keine UDT-Variable, obwohl UDT-Mitgliedsvariablen mit fester Länge und auf Null endenden UDT-Mitgliedsvariablen unterstützt werden.

LINE INPUT# ist für die Verwendung mit Textdateien gedacht, die aus Zeilen bestehen, die durch CR/LF-Sequenzen ( $CRLF oder CHR$ (13,10)) abgeschlossen werden. Es liest eine Zeile aus der Datei und gibt sie abzüglich des CR/LF-Trennzeichens zurück. Kommas, Anführungszeichen und andere Zeichen haben für LINE INPUT# keine besondere Bedeutung und werden wie jeder andere Text behandelt.

Wenn die Datei aus durch Kommas getrennten Datenelementen besteht, ist INPUT# wahrscheinlich besser geeignet als LINE INPUT#.

Die zweite Syntaxdefinition von LINE INPUT# liest eine für INPUT geöffnete Datei und weist jedem Element des Arrays vollständige Textzeilen zu.

Es wird davon ausgegangen, dass es sich bei den Daten um Standardtext handelt, der durch CR/LF ($CRLF) oder EOF (1A hex oder $EOF) getrennt ist. LINE INPUT# versucht, die in der rcds-Option RECORDS angegebene Anzahl von Zeilen oder die Anzahl der Elemente im Array zu lesen, je nachdem, welcher Wert kleiner ist.

Die tatsächliche Anzahl der gelesenen Zeilen wird der in der optionalen TO count-Klausel angegebenen Variablen zugewiesen. FILESCAN ist in Verbindung damit nützlich, um die dimensionierte Größe des String-Arrays zu bestimmen. EOF wird genauso wie beim Single Line Input eingestellt.

Siehe auch

  • EOF
  • DATEIENCAN
  • INPUT#
  • PRINT#

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Zeilennummern und Beschriftungen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Zeilennummern und Beschriftungen

Zeilennummern und Beschriftungen

Zeilennummern sind ganze Zahlen im Bereich von 1 bis 65535, die zur Identifizierung von Programmzeilen dienen. PowerBASIC nimmt eine entspannte Haltung gegenüber Zeilennummern ein. Sie können beliebig mit Etiketten durchsetzt und z.B. verwendet werden

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Beschreibung

Rückgabewert: Folgendes ist jedoch unzulässig: ExitPoint: a = a + 1 ' Eine Beschriftung muss in einer eigenen Zeile stehen. Schließlich ist zu beachten, dass Symbolnamen eindeutig sein müssen: Eine Beschriftung darf nicht den Namen eines anderen Symbols (Untername, Funktionsname, Methodenname, Eigenschaftsname, benutzerdefinierte Typ- oder Unionsdefinition, Variablenname usw.) teilen und sie sind lokal für die Unter-, Funktions-, Methoden- oder Eigenschaftsbezeichnung, in der sie erscheinen.

Obwohl Zeilennummern und Beschriftungen denselben Zweck erfüllen, unterscheidet sich ihre Verwendung geringfügig. Zeilennummern sind lediglich ein Zugeständnis an die Kompatibilität mit Interpretive BASIC. Die Zeilennummerierung kann zu einem schlechten Programmierstil führen. Da die Zahlen selbst in beliebiger Reihenfolge vorliegen können, verleihen sie einem Programm eine falsche Struktur. Wir empfehlen, Zeilennummern zu vermeiden und stattdessen Beschriftungen zu verwenden.

Durch die Verwendung von Beschriftungen anstelle von Zahlen können Sie den Ablauf Ihres Programms viel lesbarer machen. Zum Beispiel:

sagt dir viel mehr als

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Zeilennummern und Beschriftungen soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Zeilennummern und Beschriftungen mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


LISTBOX ADD – PBXB64-Compiler-Hilfe

Startseite › Funktionen › LISTBOX ADD

LISTBOX HINZUFÜGEN

Manipulate a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

PBXB64-getesteter Umfang: tests/pb/test_listbox_combobox_direct.pb prueft direkte LISTBOX-Formen fuer ADD, DELETE, FIND, FIND EXACT, GET COUNT, GET SELCOUNT, GET SELECT, GET STATE, GET TEXT, GET USER, INSERT, SELECT, SET TEXT, SET USER, UNSELECT und RESET. Weitere Randfaelle wie nicht gefundene Eintraege, ungueltige Indizes, sortierte Styles und zusaetzliche Mehrfachauswahl-Kombinationen brauchen noch eigene Tests.

Syntax

LISTBOX ADD hDlg , id& , StrExpr [TO datav& ]
LISTBOX DELETE hDlg , id& , item&
LISTBOX FIND hDlg , id& , item& , StrExpr TO datav&
LISTBOX FIND EXACT hDlg , id& , item& , StrExpr TO datav&
LISTBOX GET COUNT hDlg , id& TO datav&
LISTBOX GET SELCOUNT hDlg , id& TO datav&
LISTBOX GET SELECT hDlg , id& [, item& ] TO datav&
LISTBOX GET STATE hDlg , id& , item& TO datav&
LISTBOX GET TEXT hDlg , id& [, item& ] TO txtv$
LISTBOX GET USER hDlg , id& , item& TO datav&
LISTBOX INSERT hDlg , id& , item& , StrExpr [TO datav& ]
LISTBOX RESET hDlg , id&
LISTBOX SELECT hDlg , id& , item&
LISTBOX SET TEXT hDlg , id& , item& , StrExpr
LISTBOX SET USER hDlg , id& , item& , NumExpr
LISTBOX UNSELECT hDlg , id& [, item& ]

Beschreibung

In jedem der folgenden Beispiele und Beschreibungen wird das LISTBOX-Steuerelement, das Gegenstand der Anweisung ist, durch das Handle des Dialogfelds identifiziert, das Eigentümer der LISTBOX ist ( hDlg ), und durch den eindeutigen Steuerelementbezeichner, den Sie ihm bei der Erstellung in CONTROL ADD LISTBOX gegeben haben.

Der Wert item& bezieht sich auf die Position des String-Datenelements in der LISTBOX und ist immer auf eins indiziert. Die erste Zeichenfolge ist Position 1, die zweite ist Position 2 und so weiter.

LISTBOX ADD hDlg , id& , StrExpr [TO datav& ]

Der durch StrExpr angegebene Zeichenfolgenwert wird dem LISTBOX-Steuerelement hinzugefügt. Wenn die LISTBOX den Stil %LBS_SORT hat, wird die neue Zeichenfolge in alphanumerischer Reihenfolge eingefügt; Andernfalls wird es am Ende der vorhandenen Liste hinzugefügt. Wenn die optionale TO-Klausel enthalten ist, wird die Indexposition der hinzugefügten Zeichenfolge der durch datav& dargestellten Variablen zugewiesen. Der Index beträgt eins für die erste Zeichenfolge, zwei für die zweite usw. Wenn der Index kleiner als eins ist, ist ein Fehler aufgetreten und es wurde keine Zeichenfolge hinzugefügt.

LISTBOX DELETE hdlg , id& , item&

Die Zeichenfolge an der durch item& angegebenen Position wird aus der LISTBOX gelöscht. Der Parameter item& ist auf eins indiziert (1 für die erste Zeichenfolge, 2 für die zweite usw.).

LISTBOX FIND hDlg , id& , item& , StrExpr TO datav&

Zeichenfolgen in der LISTBOX werden durchsucht, um die erste Zeichenfolge zu finden, die mit den Daten in StrExpr beginnt, unabhängig von den folgenden Zeichen. Bei Vergleichen wird die Groß-/Kleinschreibung nicht beachtet. Die Suche nach Zeichenfolgen beginnt mit der durch item& angegebenen Zeichenfolge und endet mit der letzten Zeichenfolge in der LISTBOX. Die Suche beginnt nicht am Anfang der Liste. Die Artikelnummer ( item& ) wird auf 1 indiziert (1=erste, 2=zweite usw.). Um die gesamte LISTBOX beginnend mit der ersten Zeichenfolge zu durchsuchen, sollte item& auf eins (1) gesetzt werden. Wenn eine passende Zeichenfolge gefunden wird, wird der Indexwert der Übereinstimmung der durch datav& angegebenen Variablen zugewiesen. Wird keine Übereinstimmung gefunden, wird ihm der Wert Null (0) zugewiesen.

LISTBOX FIND EXACT hDlg , id& , item& , StrExpr TO datav&

Zeichenfolgen in der LISTBOX werden durchsucht, um die erste Zeichenfolge zu finden, die genau mit den Daten in StrExpr übereinstimmt. Bei Vergleichen wird die Groß-/Kleinschreibung nicht beachtet. Die Suche nach Zeichenfolgen beginnt mit der durch item& angegebenen Zeichenfolge und endet mit der letzten Zeichenfolge in der LISTBOX. Die Suche beginnt nicht am Anfang der Liste. Die Artikelnummer ( item& ) wird auf 1 indiziert (1=erste, 2=zweite usw.). Um die gesamte LISTBOX beginnend mit der ersten Zeichenfolge zu durchsuchen, sollte item& auf eins (1) gesetzt werden. Wenn eine passende Zeichenfolge gefunden wird, wird der Indexwert der Übereinstimmung der durch datav& angegebenen Variablen zugewiesen. Wird keine Übereinstimmung gefunden, wird ihm der Wert Null (0) zugewiesen.

LISTBOX GET COUNT hdlg , id& TO datav&

Die Anzahl der Elemente in der LISTBOX wird abgerufen und der durch datav& angegebenen langen Ganzzahlvariablen zugewiesen.

LISTBOX GET SELCOUNT hdlg , id& TO datav&

Die Anzahl der ausgewählten Elemente in der LISTBOX wird abgerufen und der durch datav& angegebenen Long-Integer-Variablen zugewiesen.

LISTBOX GET SELECT hDlg , id& [, item& ] TO datav&

Die LISTBOX wird durchsucht, um das erste ausgewählte Element zu finden. Wenn der Parameter item& enthalten ist, beginnt die Suche an dieser Position, um das Abrufen mehrerer ausgewählter Elemente zu erleichtern. Wenn item& weggelassen wird, beginnt die Suche beim ersten Datenelement. Die Indexnummer des ausgewählten Elements wird der durch datav& bezeichneten Variablen zugewiesen. Wenn kein Element ausgewählt ist, wird ihm der Wert Null (0) zugewiesen.

LISTBOX GET STATE hdlg , id& , item& TO datav&

Ein Datenelement wird daraufhin überprüft, ob es derzeit ausgewählt ist. Der numerische Wert item& gibt an, welcher Benutzerwert überprüft werden soll, 1 für das erste Element, 2 für das zweite Element usw. Wenn das Element ausgewählt ist, wird -1 ( true ) der durch datav& angegebenen Variablen zugewiesen. Andernfalls wird ihm 0 (false) zugewiesen.

LISTBOX GET TEXT hDlg , id& [, item& ] TO txtv$

Text wird aus der LISTBOX abgerufen und der durch txtv$ angegebenen Zeichenfolgenvariablen zugewiesen. Wenn der numerische Ausdruck item& enthalten ist, bestimmt er, welche Textzeichenfolge zurückgegeben wird, 1 für das erste Element, 2 für das zweite Element usw.

Der Parameter item& kann weggelassen werden oder den Wert Null (0) enthalten. Im Falle einer Einzelauswahl-Listbox wird der aktuell ausgewählte Text (falls vorhanden) abgerufen und txtv$ zugewiesen. Bei einer Mehrfachauswahl-Listbox (Stil %LBS_MULTIPLESEL oder %LBS_EXTENDEDSEL) wird der Text des ersten (Basis-) ausgewählten Elements txtv$ zugewiesen. Um weitere ausgewählte Textelemente aus einem Listenfeld mit Mehrfachauswahl abzurufen, verwenden Sie LISTBOX GET SELECT, um ausgewählte Elementnummern abzurufen. Wenden Sie dann die Artikelnummern mit LISTBOX GET TEXT an, um die Zeichenfolgendaten abzurufen.

LISTBOX GET USER hdlg , id& , item& TO datav&

Jedem Element in einer LISTBOX kann nach Ermessen des Programmierers ein langer ganzzahliger Benutzerwert zugeordnet sein. Dieser Benutzerwert wird mit LISTBOX GET USER abgerufen. Der numerische Wert item& gibt an, welcher Benutzerwert angefordert wird, 1 für das erste Element, 2 für das zweite Element usw. Der zurückgegebene Benutzerwert wird der durch datav& angegebenen langen Ganzzahlvariablen zugewiesen. LISTBOX-Benutzerwerte werden mit der LISTBOX SET USER-Anweisung zugewiesen. Zusätzlich zu diesen LISTBOX-Benutzerwerten bietet jedes DDT-Steuerelement zusätzlich acht Benutzerwerte, auf die mit CONTROL GET USER und CONTROL SET USER zugegriffen werden kann.

LISTBOX INSERT hDlg , id& , item& , StrExpr [TO datav& ]

Der durch StrExpr angegebene Text für ein neues Datenelement wird an der durch item& angegebenen Stelle eingefügt. Der Wert von item& = 1 für das erste Element, 2 für das zweite Element usw. Die Liste der Datenelemente wird nicht neu sortiert, auch wenn die LISTBOX mit dem Stil %LBS_SORT erstellt wurde. Wenn Sie alle Elemente sortieren möchten, verwenden Sie stattdessen LISTBOX ADD. Wenn die optionale TO-Klausel enthalten ist, wird die Indexposition der eingefügten Zeichenfolge der durch datav& dargestellten Variablen zugewiesen. Der Index beträgt eins für die erste Zeichenfolge, zwei für die zweite usw. Wenn der Index kleiner als eins ist, ist ein Fehler aufgetreten und es wurde keine Zeichenfolge eingefügt.

LISTBOX RESET hdlg , id&

Alle Inhalte der angegebenen LISTBOX löschen.

LISTBOX SELECT hDlg , id& , item&

Das durch item& angegebene Zeichenfolgendatenelement wird als ausgewählter Text für das LISTBOX-Steuerelement ausgewählt und der ausgewählte Text wird an eine sichtbare Position gescrollt. Der Wert von item& = 1 für das erste Element, 2 für das zweite Element usw. Wenn der Wert von item& = 0 bei einem Listenfeld mit Mehrfachauswahl, werden alle Zeichenfolgendatenelemente ausgewählt. LISTBOX SELECT kann sowohl mit Einzel- als auch mit Mehrfachauswahl-Listboxen verwendet werden.

LISTBOX SET TEXT hDlg , id& , item& , StrExpr

Der Text für das durch item& angegebene Datenelement wird durch den neuen Text in StrExpr ersetzt. Der Wert von item& = 1 für das erste Element, 2 für das zweite Element usw. Die Liste der Datenelemente wird nicht neu sortiert, auch wenn die LISTBOX mit dem Stil %LBS_SORT erstellt wurde. Wenn Sie die Elemente sortieren möchten, verwenden Sie stattdessen LISTBOX DELETE gefolgt von LISTBOX ADD.

LISTBOX SET USER hDlg , id& , item& , NumExpr

Jedem Element in einer LISTBOX kann nach Ermessen des Programmierers ein langer ganzzahliger Benutzerwert zugeordnet sein. Dieser Benutzerwert wird mit LISTBOX SET USER zugewiesen und mit LISTBOX GET USER abgerufen. Der numerische Wert item& gibt an, auf welchen Benutzerwert zugegriffen werden soll, 1 für das erste Element, 2 für das zweite Element usw. Der durch NumExpr angegebene Wert wird für einen späteren Abruf gespeichert. Zusätzlich zu diesen LISTBOX-Benutzerwerten bietet jedes DDT-Steuerelement zusätzlich acht Benutzerwerte, auf die mit CONTROL GET USER und CONTROL SET USER zugegriffen werden kann.

LISTBOX UNSELECT hDlg , id& [, item& ]

Der durch item& angegebene Zeichenfolgenwert wird für das LISTBOX-Steuerelement auf einen nicht ausgewählten Status gesetzt. Der Wert von item& = 1 für das erste Element, 2 für das zweite Element usw. Wenn item& fehlt oder den Wert Null hat, werden alle Elemente auf einen nicht ausgewählten Status gesetzt. LISTBOX UNSELECT kann sowohl mit Einzel- als auch mit Mehrfachauswahl-Listboxen verwendet werden.

Einschränkungen

Unter Windows 95/98/ME ist ein Listenfeld auf 32.767 Elemente beschränkt. In allen Windows-Versionen sind die tatsächlich im Listenfeld enthaltenen Zeichenfolgendaten nur durch den verfügbaren Speicher begrenzt.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG LISTBOX HINZUFÜGEN
  • STEUERUNG FARBE EINSTELLEN
  • STEUERUNG SET SCHRIFTART

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für LISTBOX HINZUFÜGEN soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' LISTBOX HINZUFÜGEN mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


LISTVIEW DELETE COLUMN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › LISTVIEW DELETE COLUMN

LISTVIEW SPALTE LÖSCHEN

Manipulate a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

LISTVIEW DELETE COLUMN hDlg , id& , col&
LISTVIEW DELETE ITEM hDlg , id& , item&
LISTVIEW FIND hDlg , id& , item& , StrExpr TO datav&
LISTVIEW FIND EXACT hDlg , id& , item& , StrExpr TO datav&
LISTVIEW FIT CONTENT hDlg , id& , col&
LISTVIEW FIT HEADER hDlg , id& , col&
LISTVIEW GET COLUMN hDlg , id& , col& TO datav&
LISTVIEW GET COUNT hDlg , id& TO datav&
LISTVIEW GET HEADER hDlg , id& , col& TO txtv$
L ISTVIEW GET HEADERID hDlg , id& TO hLV , idv&
LISTVIEW GET MODE hDlg , id& TO datav&
LISTVIEW GET SELCOUNT hDlg , id& TO datav&
L ISTVIEW GET SELECT hDlg , id& [, item& ] TO datav&
LISTVIEW GET STATE hDlg , id& , item& , col& TO datav&
LISTVIEW GET STYLEXX hDlg , id& TO datav&
LISTVIEW GET TEXT hDlg , id& , item& , col& TO txtv$
LISTVIEW GET USER hDlg , id& , item& TO datav&
LISTVIEW INSERT COLUMN hDlg , id& , col& , StrExpr , ColWidth& , format&
LISTVIEW INSERT ITEM hDlg , id& , item& , image& , StrExpr
LISTVIEW RESET hDlg , id&
LISTVIEW SELECT hDlg , id& , item& [, col& ]
LISTVIEW SET COLUMN hDlg , id& , col& , NumExpr
LISTVIEW SET HEADER hDlg , id& , col& , StrExpr
LISTVIEW SET IMAGE hDlg , id& , item& , NumExpr
LISTVIEW SET IMAGE2 hDlg , id& , item& , NumExpr
LISTVIEW SET IMAGELIST hDlg , id& , hLst , NumExpr
LISTVIEW SET MODE hDlg , id& , NumExpr
LISTVIEW SET OVERLAY hDlg , id& , item& , NumExpr
LISTVIEW SET STYLEXX hDlg , id& , NumExpr
LISTVIEW SET TEXT hDlg , id& , item& , col& , StrExpr
LISTVIEW SET USER hDlg , id& , item& , NumExpr

Beschreibung

Mit einem LISTVIEW-Steuerelement stehen vier allgemeine Anzeigemodi zur Verfügung. Der anfängliche Anzeigemodus wird zum Zeitpunkt der Erstellung des Steuerelements als Teil des Steuerelementstilparameters festgelegt. Es kann von Zeit zu Zeit mit LISTVIEW SET MODE geändert werden.

Modus 0

Symbolmodus – Zeichenfolgendatenelemente werden von links nach rechts angezeigt und bei Bedarf in mehrere Zeilen umgebrochen. Wenn dem LISTVIEW-Steuerelement ein kleines Symbol IMAGELIST hinzugefügt wird, werden Bilder aus dieser Liste mit jedem Datenelement angezeigt.

Modus 1

Berichtsmodus – Zeichenfolgendatenelemente werden als Liste von oben nach unten angezeigt, ein Element pro Zeile. Das Steuerelement kann eine oder mehrere Spalten mit jeweils einem Kopfzeilentext zur Beschreibung haben. In jeder Spalte können zusätzliche Unterelemente angezeigt werden, indem eine Spaltennummer größer als eins angegeben wird. Dies ist der am häufigsten verwendete ListView-Modus und der Standardmodus, wenn er zum Zeitpunkt der Erstellung des Steuerelements nicht angegeben wird. In diesem Modus ist es oft praktisch, sich die Artikelnummer als Zeilennummer vorzustellen. Wenn dem LISTVIEW-Steuerelement ein kleines Symbol IMAGELIST hinzugefügt wird, werden Bilder aus dieser Liste mit jedem Datenelement angezeigt.

Modus 2

Kleiner Symbolmodus – Zeichenfolgendatenelemente werden von links nach rechts angezeigt und bei Bedarf in mehrere Zeilen umgebrochen. Wenn dem LISTVIEW-Steuerelement ein kleines Symbol IMAGELIST hinzugefügt wird, werden Bilder aus dieser Liste mit jedem Datenelement angezeigt.

Modus 3

Listenmodus – Zeichenfolgendatenelemente werden als Liste von oben nach unten angezeigt, ein Element pro Zeile. Dieser Modus ähnelt im Aussehen stark einem Standard-LISTBOX-Steuerelement. In diesem Modus ist es oft praktisch, sich die Artikelnummer als Zeilennummer vorzustellen. Wenn dem LISTVIEW-Steuerelement ein kleines Symbol IMAGELIST hinzugefügt wird, werden Bilder aus dieser Liste mit jedem Datenelement angezeigt.

In allen folgenden Beschreibungen wird das LISTVIEW-Steuerelement, das Gegenstand der Anweisung ist, durch das Handle des Dialogs identifiziert, der das LISTVIEW besitzt ( hDlg ), und die eindeutige Steuerelement-ID ( id& ), die Sie ihm bei der Erstellung in CONTROL ADD LISTVIEW gegeben haben.

Auf jedes Datenelement (oder Unterelement) wird durch eine Kombination aus seiner Elementnummer ( item& ) und seiner Spaltennummer ( col& ) verwiesen. Ein primäres Datenelement hat immer die Spaltennummer 1, während Unterelemente immer eine Spaltennummer größer als 1 haben. Unterelemente werden nur im Berichtsmodus angezeigt. In allen anderen Anzeigemodi sind sie nicht sichtbar.

Es ist wichtig zu beachten, dass sowohl die primären Elementnummern ( item& ) als auch die Spaltennummern der untergeordneten Elemente ( col& ) bei 1 beginnen. Die erste = 1, die zweite = 2 und so weiter.

LISTVIEW SPALTE LÖSCHEN hdlg , id& , col&

Die durch col& angegebene Spalte, einschließlich des zugehörigen Kopfzeilentexts (falls vorhanden), wird aus dem LISTVIEW-Steuerelement gelöscht. Die Spaltennummer ( col& ) wird auf 1 indiziert (1=erste, 2=zweite usw.). Spalte eins eines Listenansicht-Steuerelements kann nicht gelöscht werden. Wenn Sie Spalte eins löschen müssen, fügen Sie eine Dummy-Spalte mit der Länge Null ein und löschen Sie Spalte zwei und darüber. Dies ist eine Einschränkung des Microsoft Windows Listview-Steuerelements und keine PowerBASIC-Einschränkung.

LISTVIEW DELETE ITEM hdlg , id& , item&

Das durch item& angegebene Datenelement wird aus dem LISTVIEW-Steuerelement gelöscht. Die Zeilennummer ( item& ) wird auf 1 indiziert (1=erste, 2=zweite usw.).

LISTVIEW FIND hDlg , id& , item& , StrExpr TO datav&

Zeichenfolgen in der ersten Spalte einer LISTVIEW werden durchsucht, um die erste Zeichenfolge zu finden, die mit den Daten in StrExpr beginnt, unabhängig von den folgenden Zeichen. Bei Vergleichen wird die Groß-/Kleinschreibung nicht beachtet. Es werden Zeichenfolgen durchsucht, beginnend mit der durch item& angegebenen Zeichenfolge und endend mit der letzten Zeichenfolge in der LISTVIEW. Die Suche beginnt nicht am Anfang der Liste. Die Zeilennummer ( item& ) wird auf 1 indiziert (1=erste, 2=zweite usw.). Um die gesamte LISTVIEW beginnend mit der ersten Zeichenfolge zu durchsuchen, sollte item& auf eins (1) gesetzt werden. Wenn eine passende Zeichenfolge gefunden wird, wird der Indexwert der Übereinstimmung der durch datav& angegebenen Variablen zugewiesen. Wird keine Übereinstimmung gefunden, wird ihm der Wert Null (0) zugewiesen.

LISTVIEW FIND EXACT hDlg , id& , item& , StrExpr TO datav&

Zeichenfolgen in der ersten Spalte einer LISTVIEW werden durchsucht, um die erste Zeichenfolge zu finden, die genau mit den Daten in StrExpr übereinstimmt. Bei Vergleichen wird die Groß-/Kleinschreibung nicht beachtet. Es werden Zeichenfolgen durchsucht, beginnend mit der durch item& angegebenen Zeichenfolge und endend mit der letzten Zeichenfolge in der LISTVIEW. Die Suche beginnt nicht am Anfang der Liste. Die Zeilennummer ( item& ) wird auf 1 indiziert (1=erste, 2=zweite usw.). Um die gesamte LISTVIEW beginnend mit der ersten Zeichenfolge zu durchsuchen, sollte item& auf eins (1) gesetzt werden. Wenn eine passende Zeichenfolge gefunden wird, wird der Indexwert der Übereinstimmung der durch datav& angegebenen Variablen zugewiesen. Wird keine Übereinstimmung gefunden, wird ihm der Wert Null (0) zugewiesen.

LISTVIEW FIT CONTENT hdlg , id& , col&

Die Breite der durch col& angegebenen Spalte wird an die Breite der in dieser Spalte angezeigten Datenelemente angepasst. Die Spaltennummer ( col& ) wird auf 1 indiziert (1=erste, 2=zweite usw.).

LISTVIEW FIT HEADER hdlg , id& , col&

Die Breite der durch col& angegebenen Spalte wird an die Breite der in dieser Spalte angezeigten Zeilen und den Kopfzeilentext oben in dieser Spalte angepasst. Die Spaltennummer ( col& ) wird auf 1 indiziert (1=erste, 2=zweite usw.). Wenn es sich bei der angegebenen Spalte um die letzte Spalte handelt, wird ihre Breite so festgelegt, dass sie die verbleibende Breite des Listenansichtssteuerelements ausfüllt.

LISTVIEW GET COLUMN hdlg , id& , col& TO datav&

Die Breite der angegebenen Spalte wird aus der ListView abgerufen und der durch datav& angegebenen Variablen zugewiesen. Die Breite wird entweder in Pixeln oder in Dialogeinheiten angegeben, je nachdem, was bei der Erstellung verwendet wurde. Der Wert col& gibt die Spaltennummer an (1=erste, 2=zweite usw.).

LISTVIEW GET COUNT

hDlg , id& TO datav&

Die Anzahl der Zeilen in LISTVIEW wird abgerufen und der durch datav& angegebenen Long-Integer-Variablen zugewiesen.

LISTVIEW GET HEADER hdlg , id& , col& TO txtv$

Der Spaltenkopftext wird aus LISTVIEW abgerufen und der durch txtv$ angegebenen Zeichenfolgenvariablen zugewiesen. Der Wert col& gibt die Spaltennummer an (1=erste, 2=zweite usw.).

LISTVIEW GET HEADERID hdlg , id& TO hLV , idv&

Das Handle des LISTVIEW-Steuerelements und die ID des HEADER-Steuerelements (ein untergeordnetes Element von LISTVIEW) werden abgerufen und den durch hLV bzw. idv& dargestellten Variablen zugewiesen. Diese beiden Elemente können dann mit der HEADER-Anweisung zur erweiterten Handhabung des in LISTVIEW eingebetteten Header-Steuerelements verwendet werden.

LISTVIEW GET MODE hdlg , id& TO datav&

Der Anzeigemodus des angegebenen LISTVIEW-Steuerelements wird abgerufen und der durch datav& angegebenen Variablen zugewiesen. Mögliche Moduswerte sind 0=Symbolmodus, 1=Berichtsmodus, 2=Kleinsymbolmodus, 3=Listenmodus.

LISTVIEW GET SELCOUNT hdlg , id& TO datav&

Die LISTVIEW wird abgefragt, um die Anzahl der aktuell ausgewählten Primärdatenelemente zu ermitteln. Dieser Zähler wird der durch datav& angegebenen Long-Integer-Variablen zugewiesen. Um die Anzahl der ausgewählten Unterelemente zu ermitteln, müssen Sie LISTVIEW GET STATE für jedes aktive Unterelement ausführen.

LISTVIEW GET SELECT hDlg , id& [, item& ] TO datav&

Die LISTVIEW wird abgefragt, um das nächste primäre Datenelement zu ermitteln, das derzeit ausgewählt ist. Der Parameter item& gibt die Startartikelnummer für die Suche an, um das Auffinden mehrerer ausgewählter Artikel zu erleichtern. Um am Anfang zu beginnen, verwenden Sie ein Element& von eins (1) oder lassen Sie diesen Parameter einfach weg. Die ausgewählte Artikelnummer wird der durch datav& angegebenen Long-Integer-Variable zugewiesen. Wenn keine ausgewählten Elemente gefunden werden, wird der Wert Null (0) zurückgegeben. Um ausgewählte Unterelemente zu finden, müssen Sie LISTVIEW GET STATE für die verbleibenden aktiven Unterelemente ausführen.

LISTVIEW GET STATE hdlg , id& , item& , col& TO datav&

Ein Datenelement wird getestet, um festzustellen, ob es derzeit ausgewählt ist. Die Werte von item& / col& geben die Position des Datenelements an (1=erstes, 2=zweite usw.). Wenn das Element ausgewählt ist, wird -1 ( true ) der durch datav& angegebenen Variablen zugewiesen. Andernfalls wird ihm 0 (false) zugewiesen.

LISTVIEW GET STYLEXX hdlg , id& TO datav&

ListView-Steuerelemente bieten eine Reihe optionaler zusätzlicher Stilattribute, die einzigartig und spezifisch für eine ListView sind. Diese Anweisung ruft die aktuelle Einstellung dieses speziellen erweiterten Stils ab und weist sie der durch datav& angegebenen Long-Integer-Variablen zu. Eine Liste der verfügbaren erweiterten Stile finden Sie unter LISTVIEW SET STYLEXXX. Dieser spezielle erweiterte Stil wird STYLEXX genannt, um ihn vom primären Stil und dem erweiterten Stil zu unterscheiden, die in CONTROL ADD LISTVIEW angegeben sind.

LISTVIEW GET TEXT hdlg , id& , item& , col& TO txtv$

Ein String-Datenelement wird vom LISTVIEW-Steuerelement abgerufen und der durch txtv$ angegebenen String-Variablen zugewiesen. Die Werte von item& / col& geben die Position des Datenelements an (1=erstes, 2=zweite usw.).

LISTVIEW GET USER hDlg , id& , item& TO datav&

Jeder Zeile in einer LISTVIEW kann nach Ermessen des Programmierers ein langer ganzzahliger Benutzerwert zugeordnet sein. Dieser Benutzerwert wird mit LISTVIEW GET USER abgerufen. Der numerische Wert item& gibt an, welcher Benutzerwert angefordert wird, 1 für die erste Zeile, 2 für die zweite Zeile usw. Der zurückgegebene Benutzerwert wird der durch datav& angegebenen langen Ganzzahlvariablen zugewiesen. LISTVIEW-Benutzerwerte werden mit der LISTVIEW SET USER-Anweisung zugewiesen. Zusätzlich zu diesen LISTVIEW-Benutzerwerten bietet jedes DDT-Steuerelement zusätzlich acht Benutzerwerte, auf die mit CONTROL GET USER und CONTROL SET USER zugegriffen werden kann.

LISTVIEW INSERT COLUMN hdlg , id& , col& , StrExpr , ColWidth& , format&

Für den Berichtsmodus dieses LISTVIEW-Steuerelements wird eine neue vertikale Spalte definiert. Der Wert col& gibt die Spaltennummer an (1=erste, 2=zweite usw.). StrExpr beschreibt den Textnamen der Spaltenüberschrift. Der Wert ColWidth& gibt die Breite der Spalte in Dialogeinheiten oder Pixeln an, je nachdem, was bei der Erstellung angegeben wurde. Der Wert format& beschreibt das Format und die Ausrichtung des Textes: 0=links, 1=rechts, 2=zentriert. Spalte 1 ist immer linksbündig, unabhängig davon, was hier verlangt wird. Beim Einfügen einer neuen Spalte 1 wird der Inhalt der ursprünglichen Spalte 1 in die neue Spalte 1 kopiert. Dies geschieht nur beim Einfügen einer neuen Spalte ganz links. Beim Einfügen anderer Spalten werden keine Daten in die neue Spalte kopiert. Dies ist eine Einschränkung des Microsoft Windows Listview-Steuerelements und keine PowerBASIC-Einschränkung.

LISTVIEW INSERT ITEM hdlg , id& , item& , image& , StrExpr

Zu diesem LISTVIEW-Steuerelement wird eine neue Zeile hinzugefügt. Der Wert item& gibt die Zeilennummer an (1=erste, 2=zweite usw.) und StrExpr gibt den Text an, der in der ersten Spalte angezeigt werden soll. Die restlichen Spalten sind leer, Sie können sie jedoch füllen, indem Sie LISTVIEW SET TEXT ausführen. Wenn an dieses Steuerelement eine IMAGELIST angehängt wurde, gibt der Parameter image& an, welches Bild angezeigt werden soll (1=erstes, 2=zweite usw.). Wenn kein Bild benötigt wird, sollte der Wert 0 verwendet werden.

LISTVIEW RESET hdlg , id&

Alle Datenelemente werden aus dem angegebenen LISTVIEW-Steuerelement gelöscht. Alle Spalten und die zugehörigen Überschriften, die möglicherweise für den Berichtsanzeigemodus definiert wurden, bleiben unverändert erhalten.

LISTVIEW SELECT hDlg , id& , item& [, col& ]

Das durch item& / col& angegebene Zeichenfolgendatenelement wird als ausgewählter Text für das LISTVIEW-Steuerelement ausgewählt und das Element wird hervorgehoben. Die Werte von item& / col& = 1 für das erste Element, 2 für das zweite Element usw. Wenn der optionale Parameter col& nicht angegeben ist, wird der Standardwert 1 verwendet, um das primäre Datenelement auszuwählen.

LISTVIEW SET COLUMN hdlg , id& , col& , NumExpr

Die Breite einer LISTVIEW-Spalte wird auf die durch NumExpr festgelegte Breite geändert. Der Wert wird entweder in Dialogeinheiten oder Pixeln angegeben, je nachdem, was bei der Erstellung verwendet wurde. Der Wert col& gibt die Spaltennummer an (1=erste, 2=zweite usw.). Wenn NumExpr -1 ist, wird die Spaltenbreite an die Datenelemente in dieser Spalte angepasst. Wenn NumExpr -2 ist, wird die Spaltenbreite so angepasst, dass sie sowohl zu den Datenelementen als auch zum Kopfzeilentext passt. Diese Optionen sind funktional identisch mit LISTVIEW FIT CONTENT und LISTVIEW FIT HEADER.

LISTVIEW SET HEADER hdlg , id& , col& , StrExpr

Der Text der neuen Spaltenüberschrift wird über der angegebenen Spalte im LISTVIEW-Steuerelement angezeigt. Der String-Ausdruck StrExpr gibt den neuen Kopfzeilentext an, während der Wert col& die Spaltennummer angibt (1=erste, 2=zweite usw.).

LISTVIEW SET IMAGE hDlg , id& , item& , NumExpr

Das durch NumExpr (1=erstes, 2=zweite usw.) angegebene Bild wird neben dem durch item& angegebenen Element angezeigt. Wenn keine IMAGELIST an die LISTVIEW angehängt ist, wird nichts angezeigt.

LISTVIEW SET IMAGE2 hDlg , id& , item& , NumExpr

Das durch NumExpr angegebene Bild (1=erstes, 2=zweite usw.) wird als sekundäres „Status“-Bild neben dem primären Bild angezeigt. Wenn NumExpr den Wert Null ergibt, wird kein sekundäres Bild angezeigt. Ein sekundäres Bild wird normalerweise verwendet, um den Artikelstatus anzugeben, beispielsweise mit einem Häkchen. Sekundärbilder werden im Allgemeinen in keinem der Symbolmodi angezeigt. Wenn keine Statusbildliste an LISTVIEW angehängt ist (mit der LISTVIEW IMAGELIST-Anweisung), wird nichts angezeigt. Es werden maximal 15 Statusbilder unterstützt, daher muss NumExpr im Bereich von 1 bis 15 auswerten.

LISTVIEW SET IMAGELIST hdlg , id& , hLst , NumExpr

Die von hLst angegebene IMAGELIST wird an dieses LISTVIEW-Steuerelement angehängt. Der Wert von NumExpr gibt den Typ von IMAGELIST an:

%LVSIL_NORMAL

Große Symbole

%LVSIL_SMALL

Kleine Symbole

%LVSIL_STATE

Statusbilder

An jede LISTVIEW können bis zu drei IMAGELIST-Strukturen angehängt werden, um Bilder nach Bedarf mit jedem Datenelement anzuzeigen. Je nachdem, welcher Modus aktiv ist, werden zu diesem Zweck Symbole entweder aus der großen oder der kleinen Symbolliste extrahiert. Wenn auch eine Statusbildliste angehängt ist, kann die Anweisung LISTVIEW SET IMAGE2 verwendet werden, um ein sekundäres Bild anzuzeigen. Wenn das LISTVIEW-Steuerelement zerstört wird, werden alle angehängten IMAGELIST automatisch zerstört, es sei denn, der Stil %LVS_SHAREIMAGELISTS wurde zum Zeitpunkt der Erstellung von LISTVIEW angegeben.

LISTVIEW SET MODE hdlg , id& , NumrExpr

Der Anzeigemodus des angegebenen LISTVIEW-Steuerelements wird in den durch den Wert von NumExpr angegebenen Modus geändert. Die möglichen Moduswerte sind 0=Symbolmodus, 1=Berichtsmodus, 2=Kleinsymbolmodus, 3=Listenmodus.

LISTVIEW SET OVERLAY hdlg , id& , item& , NumExpr

Das durch NumExpr (1=erstes, 2=zweite usw.) angegebene Overlay-Bild wird über dem durch item& angegebenen Bild angezeigt. Wenn NumExpr Null ergibt oder keine IMAGELIST an LISTVIEW angehängt ist, wird kein Overlay angezeigt.

LISTVIEW SET STYLEXX hDlg , id& , NumExpr

ListView-Steuerelemente bieten eine Reihe optionaler zusätzlicher Stilattribute, die einzigartig und spezifisch für eine ListView sind. Mit dieser Anweisung können Sie die aktuelle Einstellung dieses speziellen erweiterten Stils ändern. Dieser spezielle erweiterte Stil wird STYLEXX genannt, um ihn vom primären Stil und dem erweiterten Stil zu unterscheiden, die in CONTROL ADD LISTVIEW angegeben sind. NumExpr definiert den neuen Stil aus einer beliebigen Kombination der folgenden erweiterten Stile:

%LVS_EX_GRIDLINES

Rasterlinien im Berichtsmodus hinzugefügt

%LVS_EX_SUBITEMIMAGES

Den Unterelementen im Berichtsmodus hinzugefügte Symbole

%LVS_EX_CHECKBOXES

Aktiviert Kontrollkästchen für Elemente

%LVS_EX_TRACKSELECT

Aktiviert die Hot-Track-Auswahl

%LVS_EX_HEADERDRAGDROP

Ermöglicht die Neuanordnung von Spalten per Drag-Drop im Berichtsmodus

%LVS_EX_FULLROWSELECT

Die Auswahl hebt die gesamte Zeile im Berichtsmodus hervor

%LVS_EX_ONECLICKACTIVATE

Benachrichtigung wird mit einem Klick gesendet

%LVS_EX_TWOCLICKACTIVATE

Benachrichtigung wird bei Doppelklick gesendet

%LVS_EX_FLATSB

Aktiviert flache Bildlaufleisten

%LVS_EX_REGIONAL

Legt den ListView-Bereich auf Symbole und Text fest

PBXB64-Implementierungshinweise

PBXB64 V14 testet die nativen Win32-ListView-Pfade fuer LISTVIEW INSERT ITEM, LISTVIEW GET COUNT, LISTVIEW SET STYLEXX, LISTVIEW GET STYLEXX, LISTVIEW SET OVERLAY und LISTVIEW SET IMAGELIST. Diese Formen sind durch registrierte Link-and-Run-Regressionen gegen echte ListView-Common-Controls abgedeckt. Andere LISTVIEW-Unterbefehle gehoeren erst dann zu diesem zertifizierten Umfang, wenn sie echte Lowering-, Runtime- und Fokustests besitzen.

%LVS_EX_INFOTIP

Listview erstellt InfoTips für Sie

%LVS_EX_UNDERLINEHOT

Bei heißen Artikeln ist der Text unterstrichen

%LVS_EX_UNDERLINECOLD

Nicht heiße Artikel haben unterstrichenen Text

%LVS_EX_MULTIWORKAREAS

Wird erst dann automatisch angeordnet, wenn Arbeitsbereiche definiert sind

%LVS_EX_LABELTIP

Die Listenansicht deckt teilweise versteckte Beschriftungen auf

%LVS_EX_BORDERSELECT

Rahmenauswahlstil statt Hervorhebung

%LVS_EX_DOUBLEBUFFER

Malt durch Doppelpufferung und reduziert Flimmern

%LVS_EX_HIDELABELS

Blendet Beschriftungen im Symbol- und Kleinsymbolmodus aus

%LVS_EX_SINGLEROW

Zeigt eine einzelne Zeile an

%LVS_EX_SNAPTOGRID

Symbole werden automatisch am Raster ausgerichtet

%LVS_EX_SIMPLESELECT

Ändert das Overlay-Rendering nach oben rechts

LISTVIEW SET TEXT hDlg , id& , item& , col& , StrExpr

Der Text, falls vorhanden, für das angegebene Datenelement wird durch den neuen Text in StrExpr ersetzt. Sie müssen bedenken, dass diese Anweisung kein neues Element (horizontale Zeile) erstellt, sondern vorhandenen Text, falls vorhanden, in neuen Text ändert. Um ein neues Datenelement (horizontale Zeile) zu erstellen, verwenden Sie stattdessen LISTVIEW INSERT ITEM. Die Werte von item&/col& geben die Position des Datenelements an (1=erstes, 2=zweite usw.).

LISTVIEW SET USER hDlg , id& , item& , NumExpr

Jeder Zeile in einer LISTVIEW kann nach Ermessen des Programmierers ein langer ganzzahliger Benutzerwert zugeordnet sein. Dieser Benutzerwert wird mit LISTVIEW SET USER zugewiesen und mit LISTVIEW GET USER abgerufen. Der numerische Wert item& gibt an, auf welchen Benutzerwert zugegriffen werden soll, 1 für das erste Element, 2 für das zweite Element usw. Der durch NumExpr angegebene Wert wird für einen späteren Abruf gespeichert. Zusätzlich zu diesen LISTVIEW-Benutzerwerten bietet jedes DDT-Steuerelement zusätzlich acht Benutzerwerte, auf die mit CONTROL GET USER und CONTROL SET USER zugegriffen werden kann.

Einschränkungen

Unter Windows 95/98/ME ist eine ListView auf 32.767 Elemente beschränkt. In allen Windows-Versionen sind die tatsächlichen Zeichenfolgendaten, die in ListView enthalten sind, nur durch den verfügbaren Speicher begrenzt.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG LISTVIEW HINZUFÜGEN
  • STEUERUNG FARBE EINSTELLEN
  • STEUERUNG SET SCHRIFTART
  • HEADER
  • BILDLISTE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für LISTVIEW SPALTE LÖSCHEN soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' LISTVIEW SPALTE LÖSCHEN mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


LO – PBXB64-Compiler-Hilfe

Startseite › Funktionen › LO

LO

Extrahieren Sie den niedrigstwertigen (niederwertigen) Teil eines Integrals

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

result = LO( DataType , value )
result = LOBYT( value )
result = LOINT( value )
result = LOWRD( value )

Beschreibung

Der von LO zurueckgegebene Wert ist ohne Vorzeichen, wenn DataType BYTE, WORD, DWORD oder PTR ist, und mit Vorzeichen, wenn DataType INTEGER oder LONG ist. value darf bis zur doppelten Groesse des angegebenen Datentyps reichen. Fuer PTR gibt PBXB64 das niedrige DWORD des 64-Bit-Werts zurueck.

b = LO(BYTE, n)

w = LO(WORD, n)

dw = LO(PTR, p)

Einschränkungen

PBXB64 unterstuetzt sowohl die moderne Syntax LO(DataType, value) als auch die alten Hilfsnamen LOBYT, LOINT und LOWRD. Das fokussierte Regressionsbeispiel ist examples/basic/test_hi_lo_mak_typed.pb.

Siehe auch

  • Hallo
  • MAK

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für LO soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' LO mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


LOC – PBXB64-Compiler-Hilfe

Startseite › Funktionen › LOC

LOC

Bestimmen Sie den Strom

Typ:Funktion |Kategorie:Datei-E/A

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

qResult&& = LOC([#] filenum& )

Beschreibung

LOC wird zur Kompatibilität mit älteren BASICs bereitgestellt. Es wird empfohlen, den Code so zu ändern, dass stattdessen die SEEK-Funktion verwendet wird. Das Zahlensymbol (#) ist optional, wird aber aus Gründen der Übersichtlichkeit empfohlen.

Siehe auch

  • DATEIATTR
  • SEEK-Funktion
  • SEEK-Anweisung

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOCK – PBXB64-Compiler-Hilfe

Startseite › BASIC-Frontend › Schlüsselwortreferenz › Datei-E/A › LOCK
Hilfe zum PBXB64-Compiler

LOCK

Teilweise oder vollständige Sperre einer geöffneten Datei

Typ: Anweisung | Kategorie: Datei-E/A

PBXB64-Status: VERFÜGBAR

PBXB64-Zertifizierung: [IMPLEMENTIERT: Win32-Bytebereichssperren]

Syntax

LOCK [#] Dateinummer& [, { Datensatz&& | Startbyte&& TO Endbyte&& }]

Beschreibung

LOCK verhindert, dass ein anderer Prozess auf einen Datensatz, einen Datensatzbereich, ein Byte oder einen Bytebereich in einer Datei zugreift, die als Dateinummer Dateinummer& geöffnet ist.

Wenn die Datei im Direktzugriffsmodus geöffnet wurde, geben Datensatz&&, Startbyte&& und Endbyte&& Datensatznummern an. Bei Dateien im Binärmodus geben sie Bytepositionen an.

Wird ein Datensatz angegeben, wird nur dieser Datensatz (oder Byte) gesperrt. Andernfalls wird ein Bereich von Datensätzen (oder Bytes) von Startbyte&& bis Endbyte&& gesperrt.

Werden keine Datensätze angegeben oder wurde die Datei im sequenziellen Modus geöffnet, wird die gesamte Datei gesperrt.

Alle gesperrten Datensätze (oder Bytes) müssen später mit der UNLOCK-Anweisung wieder freigegeben werden. Mehrere Sperren pro Datei sind möglich und können in beliebiger Reihenfolge aufgehoben werden; die Parameter jedes UNLOCK müssen jedoch genau denen des zugehörigen LOCK entsprechen.

Alle gesperrten Bereiche müssen vor dem Schließen der Datei entsperrt werden.

Einschränkungen

  • Dateinummern müssen als Literale #1..#16 angegeben werden.
  • Fehlercodes in der ERR-Variablen werden derzeit nicht gesetzt.

Siehe auch

  • OPEN
  • UNLOCK

Getestetes Beispiel

Beispieldatei: examples/basic/test_lock_unlock.pb

Validierungsnachweis: Die fokussierte Regression oeffnet eine kleine Textdatei fuer gemeinsamen binaren Lese-/Schreibzugriff, sperrt und entsperrt literale und variable Bytebereiche und prueft danach, dass der Dateiinhalt unveraendert bleibt. Damit ist belegt, dass LOCK einen einzelnen Bereich, einen variablen Start-/Endbereich, die Form start,laenge und auch eine ganze Datei sperren kann.

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL s AS STRING
    LOCAL startByte AS QUAD
    LOCAL endByte AS QUAD

    OPEN "lock_test.txt" FOR OUTPUT AS #1
    PRINT #1, "0123456789ABCDEF";
    CLOSE #1

    OPEN "lock_test.txt" FOR BINARY ACCESS READ WRITE LOCK SHARED AS #1
    LOCK #1, 2 TO 3
    UNLOCK #1, 2 TO 3
    startByte = 4
    endByte = 5
    LOCK #1, startByte TO endByte
    UNLOCK #1, startByte TO endByte
    LOCK #1, 6, 2
    UNLOCK #1, 6, 2
    LOCK #1
    UNLOCK #1
    CLOSE #1

    OPEN "lock_test.txt" FOR INPUT AS #1
    LINE INPUT #1, s
    CLOSE #1
    KILL "lock_test.txt"

    IF s <> "0123456789ABCDEF" THEN FUNCTION = 1
END FUNCTION

Verhalten: Das Beispiel zeigt Bereichs- und Ganzdatei-Sperren in einer kleinen Datei und prueft, dass der Sperrzyklus die Daten unveraendert laesst. Focus statement: LOCK #1, startByte TO endByte

PBXB64-Status: [ZERTIFIZIERT GETESTET]

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOF – PBXB64-Compiler-Hilfe

Startseite › Funktionen › LOF

LOF

Gibt die Länge von an zurück

Typ:Funktion |Kategorie:Datei-E/A

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

y&& = LOF([#] filenum& )

Beschreibung

filenum& ist die Dateinummer, mit der die Datei geöffnet wurde. LOF gibt die Größe der angegebenen Datei in Bytes im Quad-Integer-Bereich von 0 bis 2^63-1 zurück. Das Zahlensymbol (#) ist optional, wird aber aus Gründen der Übersichtlichkeit empfohlen.

Siehe auch

  • DATEIATTR
  • LOC
  • SEEK-Funktion
  • SEEK-Anweisung

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Lange Schlangen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Lange Schlangen

Lange Schlangen

Der Unterstrich (_) kann verwendet werden, um „logische“ Zeilen des Quellcodes auf physische Zeilen in der Quellcodedatei aufzuteilen. Vor dem Unterstrich muss mindestens ein Leerzeichen stehen

Typ:Schlüsselwort |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Der Effekt der Verwendung eines Zeilenfortsetzungszeichens dient nur der „visuellen“ Darstellung – der Compiler selbst behandelt auf diese Weise aufgeteilte Zeilen nur als eine zusammenhängende Codezeile.

Nehmen wir zum Beispiel die folgende Codezeile:

DECLARE FUNCTION Call32& LIB „CALL32.DLL“ ALIAS „Call32“ (Param1 AS ANY, BYVAL id&)

Wir könnten diese Zeile umschreiben, um ihre Komponenten aus Gründen der Übersichtlichkeit in separaten Codezeilen zu platzieren:

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Lange Schlangen soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Lange Schlangen mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


LOOP – PBXB64-Compiler-Hilfe

Startseite › Funktionen › LOOP

LOOP

Schließen Sie eine DO-Schleife

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

LOOP [{WHILE | UNTIL} condition]

Beschreibung

DerLOOP Die Anweisung markiert das Ende von a DO Schleifenkörper. Ohne Klausel wird bedingungslos zum Matching zurückgesprungen DO. LOOP WHILEUndLOOP UNTIL Testen Sie die Bedingung unten und stellen Sie sicher, dass mindestens eine Iteration durchgeführt wird.

Beispiel

FUNCTION PBMAIN () AS LONG
    LOCAL n AS LONG
    LOCAL sum AS LONG
    n = 1
    sum = 0
    DO
        sum = sum + n
        n = n + 1
    LOOP WHILE n <= 5
    FUNCTION = sum
END FUNCTION

Generierter Assembler-Code

Kompilieren mit:

PBXB64 example.pb --asmout example.asm
pb_do_body_PBMAIN_0:
    mov r10, [rbp-32]
    mov rbx, r10
    mov r10, [rbp-24]
    add rbx, r10
    mov [rbp-32], rbx
    mov r10, [rbp-24]
    mov rbx, r10
    add rbx, 1
    mov [rbp-24], rbx
pb_do_cond_PBMAIN_1:
    mov r10, [rbp-24]
    mov rbx, r10
    cmp rbx, 5
    setle r10
    mov rbx, r10
    test rbx, rbx
    jne pb_do_body_PBMAIN_0
    jmp pb_do_end_PBMAIN_2
pb_do_end_PBMAIN_2:

Hinweise

Von unten getestete Schleifen führen den Körper vor der ersten Zustandsprüfung einmal durch.

Siehe auch

  • Tun Sie es
  • Während
  • Ausstieg
  • Iterieren
  • Basic Ref Control Flow

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LPRINT$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › LPRINT$

LPRINT$

Syntax

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

LPRINT ausdruck [;]
LPRINT ATTACH "pfad-oder-geraet"
LPRINT FORMFEED
LPRINT FLUSH
LPRINT CLOSE

Beschreibung

PBXB64 implementiert derzeit die Anweisungsseite des LPRINT-Stroms fuer literales Datei-/Geraete-Attach zusammen mit der fokussierten LPRINT$-Zustandsabfrage. Getestet sind LPRINT ATTACH "datei", normale LPRINT-Ausgabe von Zeichenfolgen und Integer-Werten, Semikolon-Unterdrueckung des Zeilenumbruchs, automatisches CRLF, LPRINT FORMFEED, LPRINT FLUSH und LPRINT CLOSE.

Die Regression tests/pb/test_lprint_file_attach.pb haengt eine temporaere Datei an, prueft die exakten Bytes alpha42, CRLF, omega, CRLF und ASCII 12 und kontrolliert, dass LPRINT$ waehrend des Anhangs den aktiven Pfad und nach dem Schliessen eine leere Zeichenfolge liefert. Die Laufzeitunterstuetzung ist in der Single-EXE-Ausgabe eingebettet.

Dynamische LPRINT ATTACH-Pfadausdruecke, PBWin-ERR-Zustand, TAB/USING-Formatierung und vollstaendige Windows-Druckspooler-Paritaet bleiben offen.

Siehe auch

  • LPRINT
  • LPRINT ATTACH
  • LDRUCKEN CLOSE
  • LPRINT FLUSH
  • LPRINT FORMFEED
  • XPRINT
  • XPRINT ANHANG

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.

Beschreibung

Datei-Themen sollen den benoetigten Oeffnungsmodus, die Arbeit auf Datensaetzen oder Bytes, die erforderliche Uebereinstimmung von Handles und Bereichen mit vorherigen Operationen sowie Cleanup- oder Entsperrschritte nennen. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für LPRINT$ soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' LPRINT$ mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


LPRINT ATTACH – PBXB64-Compiler-Hilfe

Startseite › Funktionen › LPRINT ATTACH

LPRINT ATTACH

Verbinden Sie sich mit einem

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

LPRINT ATTACH device$

Beschreibung

PBXB64 implementiert eine fokussierte Literal-Attach-Oberflaeche. LPRINT ATTACH "datei" oeffnet einen FILE-basierten Strom; nachfolgende LPRINT, LPRINT FORMFEED, LPRINT FLUSH und LPRINT CLOSE schreiben in diesen Strom und schliessen ihn. Ohne angehaengten Strom faellt LPRINT auf stdout-kompatible Ausgabe zurueck.

Die registrierte Regression tests/pb/test_lprint_file_attach.pb prueft literales Attach und exakte Ausgabebytes ueber die eingebettete Single-EXE-Laufzeit. Sie prueft auch, dass LPRINT$ waehrend des Anhangs den aktiven Pfad meldet und nach dem Schliessen eine leere Zeichenfolge liefert. Dynamische Pfadausdruecke bei ATTACH, PBWin-ERR-Verhalten und vollstaendige Druckspooler-Paritaet bleiben offen.

LPRINT ATTACH versucht, eine direkte Verbindung zum angegebenen [Leitungs-]Druckergerät herzustellen. Ein Zeilendrucker akzeptiert Standard-ASCII-Text und alle gerätespezifischen Steuercodes wie CR, LF und FF.

Ein Zeilendrucker wird nach dem Anschluss benannt, an den er angeschlossen ist (LPT1 usw.), da die Daten direkt an den Anschluss und nicht über einen Gerätetreiber gesendet werden. Das heißt, LPRINT kommuniziert direkt mit dem angeschlossenen Zeilendruckergerät und umgeht dabei den Spooler und den Druckertreiber. Daher werden alle Einstellungen wie „Offline arbeiten“ im Dialogfeld „Druckereigenschaften“ ignoriert.

Sobald der Drucker per LPRINT ATTACH angeschlossen ist, können mit der LPRINT-Anweisung Druckdaten an ihn gesendet werden.

Mit LPRINT ATTACH können Sie das für den LPRINT-Vorgang verwendete Druckergerät ändern. Bei der Ausführung wird die aktuelle Verbindung (falls vorhanden) geschlossen und die neue Verbindung hergestellt. Im Gerätenamen wird kein Doppelpunkt verwendet. Um beispielsweise eine Verbindung zu LPT2 herzustellen:

LPRINT ATTACH „LPT2“

oder an einen Drucker auf einem Netzwerkserver:

LPRINT ATTACH „\\SERVER\HPLJ5“

device$ muss ein gültiger Gerätename sein und darf nicht länger als 32 Zeichen sein. Unter bestimmten Umständen, beispielsweise beim Novell-Netzwerkclient, kann LPRINT ATTACH mit einem UNC-Namen abgelehnt werden, und der LPRINT ATTACH ist nicht erfolgreich und ein nachfolgender LPRINT$-Test wird eine leere Zeichenfolge zurückgeben.

Wenn LPRINT ATTACH nicht erfolgreich ist, wird ein Fehler 68 („Gerät nicht verfügbar“) generiert und LPRINT$ gibt einen NULL-String (leer) zurück. Wenn kein LPRINT ATTACH ausgeführt wird (erfolgreich oder nicht), versucht PowerBASIC, eine Verbindung zum Zeilendrucker an LPT1 herzustellen. Sobald ein LPRINT ATTACH versucht wird, wird kein Standardwert für LPT1 angenommen.

Bei Zeilendruckern in Windows ist Vorsicht geboten, denn wenn kein verfügbarer Drucker an den Port angeschlossen ist, kann die Programmausführung ohne Fehler angehalten werden. Daher ist es ratsam, LPRINT ATTACH zu verwenden, um das gewünschte Druckergerät explizit zu verbinden und die erfolgreiche Verbindung durch die Prüfung von LPRINT$ und ERR zu testen. Zum Beispiel:

ERRCLEAR

LPRINT ATTACH „LPT3“

IF ERR OR LPRINT$ = "" THEN PRINT "Verbindung fehlgeschlagen"

Sobald alle Daten an den Drucker gesendet wurden, trennen Sie den Drucker mit der LPRINT CLOSE-Anweisung, damit andere Anwendungen ihn verwenden können

Hinweis: Der Win32-API-Aufruf EnumPrinters kann Ihnen eine Liste aller gültigen Drucker und Druckgeräte liefern, oder Sie können die Liste der Drucker mit den Funktionen PRINTERCOUNT und PRINTER$ aufzählen.

Einschränkungen

Wenn device$ eine leere Zeichenfolge ist, wird die aktuelle Verbindung (falls vorhanden) getrennt. Dies entspricht der LPRINT CLOSE-Anweisung.

Siehe auch

  • LPRINT
  • LDRUCKEN CLOSE
  • LPRINT FLUSH
  • LPRINT FORMFEED
  • LPRINT$
  • XPRINT
  • XPRINT ANHANG

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.

Beschreibung

Datei-Themen sollen den benoetigten Oeffnungsmodus, die Arbeit auf Datensaetzen oder Bytes, die erforderliche Uebereinstimmung von Handles und Bereichen mit vorherigen Operationen sowie Cleanup- oder Entsperrschritte nennen. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für LPRINT ATTACH soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' LPRINT ATTACH mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


LPRINT CLOSE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › LPRINT CLOSE

LDRUCKEN CLOSE

Trennen Sie den Strom

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

LPRINT CLOSE

Beschreibung

PBXB64 implementiert LPRINT CLOSE fuer den fokussierten FILE-basierten LPRINT-Strom. Der Befehl leert und schliesst den aktuellen Anhang, der mit literalem LPRINT ATTACH "pfad" geoeffnet wurde. Die gleiche fokussierte Regression deckt auch ab, dass LPRINT$ waehrend des Anhangs den aktiven Pfad meldet und nach dem Schliessen eine leere Zeichenfolge liefert. Vollstaendiger PBWin-Druckspooler-Status und ERR-Verhalten bleiben ausserhalb dieses fokussierten Nachweises.

LPRINT CLOSE trennt die aktuell ausgewählte Druckerverbindung (hergestellt mit der LPRINT ATTACH-Anweisung) von LPRINT-Vorgängen, sodass das Spooler-Subsystem mit Druckvorgängen beginnen kann. Sobald eine Verbindung geschlossen ist, gibt LPRINT$ eine leere Zeichenfolge mit dem Namen des Druckergeräts zurück, bis eine neue Verbindung hergestellt wird.

LPRINT CLOSE entspricht der Verwendung von LPRINT ATTACH mit einer leeren Zeichenfolge für den Namen des Druckergeräts.

Einschränkungen

LPRINT CLOSE ist ein wesentlicher Schritt im Druckprozess. Um sicherzustellen, dass das Druckergerät für andere Anwendungen verfügbar ist, sollten Drucker bei Nichtgebrauch immer geschlossen sein. Wenn eine Verbindung nicht geschlossen wird, kann es zu erheblichen Verzögerungen kommen, bevor der Druckvorgang beginnt. In einigen Fällen können einige oder alle Druckdaten verloren gehen.

Siehe auch

  • LPRINT
  • LPRINT ATTACH
  • LPRINT FLUSH
  • LPRINT FORMFEED
  • LPRINT$
  • XPRINT
  • XPRINT ANHANG

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


LPRINT FLUSH – PBXB64-Compiler-Hilfe

Startseite › Funktionen › LPRINT FLUSH

LPRINT FLUSH

Reste ausspülen

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

LPRINT FLUSH

Beschreibung

In PBXB64 leert die fokussierte LPRINT-Oberflaeche den aktiven FILE-basierten Anhang, wenn einer geoeffnet ist. Die registrierte Regression schreibt ueber LPRINT ATTACH, ruft LPRINT FLUSH auf, schliesst den Strom und prueft die exakten Dateibytes ueber die eingebettete Single-EXE-Laufzeit.

LPRINT FLUSH zwingt das Betriebssystem, alle gepufferten Daten zu leeren und mit dem Drucken zu beginnen. Verwenden Sie LPRINT FLUSH, um sicherzustellen, dass Druckdaten so schnell wie möglich an den Drucker gesendet werden, anstatt zunächst auf den Ablauf einer Zeitüberschreitung zu warten. Abhängig vom Drucker und seinen Treibern kann der Druckvorgang sofort beginnen oder bis zur Ausführung einer LPRINT CLOSE-Anweisung verzögert werden.

Normalerweise geht einer LPRINT FLUSH-Anweisung eine FORMFEED-Anweisung voran. Stellen Sie daher sicher, dass der Druckauftrag normal vom Druckergerät ausgegeben wird.

Siehe auch

  • LPRINT
  • LPRINT ATTACH
  • LDRUCKEN CLOSE
  • LPRINT FORMFEED
  • LPRINT$
  • XPRINT
  • XPRINT ANHANG

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


LPRINT FORMFEED – PBXB64-Compiler-Hilfe

Startseite › Funktionen › LPRINT FORMFEED

LPRINT FORMFEED

Senden Sie ein Formfeed-Zeichen (Seitenauswurf) an einen Anhang

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

LPRINT FORMFEED

Beschreibung

In PBXB64 schreibt der getestete LPRINT-Strom fuer LPRINT FORMFEED ein literales ASCII-12-Byte. tests/pb/test_lprint_file_attach.pb prueft, dass das letzte Byte in der angehaengten Datei nach LPRINT FORMFEED, LPRINT FLUSH und LPRINT CLOSE den Wert 12 hat.

Bei direkten Verbindungen sendet LPRINT FORMFEED ein Formularvorschubzeichen (ASCII-Zeichen 12, $FF oder CHR$ (12)) an das angeschlossene Zeilendruckergerät, um sicherzustellen, dass die aktuelle Seite ausgeworfen wird. Bei hostbasierten Verbindungen signalisiert PowerBASIC dem Drucksubsystem, den Seitenauswurfvorgang durchzuführen.

Typischerweise wird ein LPRINT FORMFEED vor einem LPRINT FLUSH und LPRINT CLOSE ausgeführt.

Siehe auch

  • LPRINT
  • LPRINT ATTACH
  • LDRUCKEN CLOSE
  • LPRINT FLUSH
  • LPRINT$
  • XPRINT
  • XPRINT ANHANG

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.

Beschreibung

Datei-Themen sollen den benoetigten Oeffnungsmodus, die Arbeit auf Datensaetzen oder Bytes, die erforderliche Uebereinstimmung von Handles und Bereichen mit vorherigen Operationen sowie Cleanup- oder Entsperrschritte nennen. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für LPRINT FORMFEED soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' LPRINT FORMFEED mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


LSET$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › LSET$

LSET$

Gibt eine Zeichenfolge zurück

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET] für LSET$/RSET$-Funktionsformen und LSET/RSET USING; abgedeckt durch test_lset_rset_functions und test_lset_rset_using

Syntax

result_var = LSET$( string_expression , strlen& [USING ustring_expression ])

Beschreibung

LSET$ richtet die Zeichenfolge string_expression linksbündig in eine Zeichenfolge mit strlen&-Zeichen aus.

Wenn ustring_expression null (leer) ist oder nicht angegeben ist, füllt LSET$ string_expression mit Leerzeichen auf. Andernfalls füllt LSET$ die Zeichenfolge mit dem ersten Zeichen von ustring_expression auf und verwendet weiterhin strlen& als Ergebnisbreite.

Wenn string_expression kürzer als strlen& ist, richtet LSET$ string_expression innerhalb von result_var linksbündig aus und füllt die rechte Seite wie oben beschrieben auf; andernfalls gibt LSET$ die strlen&-Bytes ganz links von string_expression zurück.

Bei der Funktionsform ist das optionale USING-Argument eine Fuellzeichenfolge. Bei der Anweisungsform LSET target = value USING mask wird die Maske als Feldbreitenangabe behandelt: & laesst die Zeichenfolge unveraendert, ! erzeugt ein Einzelzeichen, und alle anderen Maskenzeichen bestimmen die Ausgabebreite. Die vollstaendigen PowerBASIC-Maskensemantiken (richtungsabhaengige </> und zentrierte \...\) sind vereinfacht auf Links-/Rechtsausrichtung entsprechend der verwendeten Anweisung.

Beispiel

a$ = LSET$("cat", 5, "*")  ' cat**
a$ = LSET$("cat", 5, "")   ' cat

Siehe auch

  • CSET
  • CSET$
  • ERHALTEN
  • LET
  • LSET
  • SETZEN
  • ZURÜCKSETZEN
  • RSET
  • RSET$
  • STRINSERT$
  • TYP EINGESTELLT

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MAKRO/ENDMAKRO – PBXB64-Compiler-Hilfe

Startseite › Funktionen › MAKRO/ENDMAKRO

MAKRO/ENDMAKRO

Definieren Sie einen ein- oder mehrzeiligen Textersetzungsblock.

Typ:Schlüsselwort |Kategorie:Typen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

PBXB64-Testabdeckung: v22_macro_preprocessor.pb prueft Anweisungsmakros, einzeilige Ausdrucksmakros, MACROTEMP-basierte Makrofunktionen und Makrofunktionen in Ausdrucksposition. tests/pb/test_exit_macro.pb prueft, dass EXIT MACRO die aktuelle mehrzeilige Makroerweiterung vor spaeteren Body-Zeilen beendet. tests/pb/test_exit_macro_reject.pb und tests/pb/test_exit_macro_reject_extra.pb pruefen die gezielten Diagnosen fuer Verwendung ausserhalb einer Makroerweiterung und fuer zusaetzliche Token.

Syntax

MACRO macroname [( prm1 , prm2 , ...)] = replacementtext
MACRO macroname [( prm1 , prm2 , ...)]
[MACROTEMP ident1 [, ident2 , ...]]
DIM ident1 AS type [, ident2 AS type , ...]]
{ replacementtext }
[EXIT MACRO]
END MACRO
MACRO FUNCTION macroname [( prm1 , prm2 , ...)]
[MACROTEMP ident1 [, ident2 , ...]
{replacementtext}
END MACRO = returnexpression

Beschreibung

Makro ist ein leistungsstarkes Textersetzungskonstrukt, das ein einzeiliges oder mehrzeiliges Format annehmen kann. Es generiert absolut keinen ausführbaren Code, sofern nicht darauf verwiesen wird, und ermöglicht es dem Programmierer effektiv, einen Teil der PowerBASIC-Sprache nach seinen eigenen Bedürfnissen und Anforderungen zu entwerfen. Ein einfaches einzeiliges Makro kann es PowerBASIC beispielsweise ermöglichen, die in Visual Basic verwendete CONST-Syntax zu emulieren – weitere Informationen finden Sie im Kasten unten.

Ein Makro muss immer definiert werden, bevor darauf verwiesen wird, und die Parameteranzahl muss immer mit der Definition übereinstimmen. Wenn auf ein Makro verwiesen wird, wird das Vorkommen des Namens durch den definierten Ersetzungstext ersetzt, der um Parameterersetzung erweitert wird. Die erste Zeile einer MACRO-Definition wird als Makroprototyp bezeichnet und diese Zeile darf nicht mit dem Zeilenfortsetzungszeichen Unterstrich (_) in mehrere logische Zeilen aufgeteilt werden. Ebenso darf der Ausdruck END MACRO = return nicht durch Unterstriche getrennt werden. Ein Makro kann auch nicht mit einem Zeilenfortsetzungszeichen enden.

Makros können verschachtelt sein und auf andere Makros weiterleiten. Es sollte jedoch darauf geachtet werden, Zirkelverweise zu vermeiden.

Ein einzeiliges Makro oder eine Makrofunktion kann an jeder beliebigen Quellcodeposition referenziert werden, die, wenn sie erweitert wird, syntaktisch korrekt ist (siehe auch den Abschnitt „Einschränkungen“ weiter unten). Betrachten Sie das folgende vereinfachte Beispiel:

MACRO concatenate(prm1,prm2) = prm1 & $SPC & prm2

' Mehr Code hier

A$ = concatenate("Hallo", "Welt")

Während der Kompilierung erweitert PowerBASIC diesen Code intern wie folgt:

A$ = „Hallo“ & $SPC & „Welt“

Ein mehrzeiliges Makro ist zwar hinsichtlich der Codierung leistungsfähiger, darf jedoch nur an der „Anweisungs“-Position referenziert werden, also der ersten Position in einer Zeile. Diese einzelne Referenz wird intern in mehrere Zeilen Inline-Code erweitert, um eine komplexe Aufgabe auszuführen. Zum Beispiel:

MACRO Display6times(prm1)

CALL-Anzeige (prm1): CALL-Anzeige (prm1)

CALL-Anzeige (prm1): CALL-Anzeige (prm1)

CALL-Anzeige (prm1): CALL-Anzeige (prm1)

END MAKRO

' Mehr Code hier

Display6times("Das ist sehr cool...")

Das einzeilige MACRO bietet eine clevere Möglichkeit, die in MSBASIC und Visual Basic verwendete CONST-Syntax in Ihrem PowerBASIC-Code beizubehalten und gleichzeitig den geringen Overhead-Vorteil von PowerBASIC beizubehalten. Zum Beispiel:

MACRO CONST = MACRO

' Mehr Code hier

CONST-Version = 1&

CONST AppTitle = „Meine Bewerbung“

' Mehr Code hier

a$ = AppTitle & " v" & FORMAT$(Version)

Während der Kompilierung wird das Schlüsselwort CONST durch das Schlüsselwort MACRO ersetzt, wodurch dynamisch ein neues Makro erstellt wird, das wiederum ein numerisches oder Zeichenfolgenliteral definiert. Wenn im Code auf den echten Makronamen verwiesen wird, wird das Literal direkt ersetzt.

MAKROTEMP

Die MACROTEMP-Anweisung kann verwendet werden, um eine Liste mit einem oder mehreren Bezeichnern anzugeben, von denen jeder automatisch für jede Erweiterung eines mehrzeiligen Makros eindeutig gemacht wird. Dies geschieht durch internes Anhängen der Ziffern 0001, 0002 usw. an den Bezeichner bei jeder Erweiterung des Makros.

Ein Textbezeichner kann eine Variable, eine Bezeichnung oder ein anderes Wort darstellen, das entsprechend erweitert wird, um einen Konflikt mit doppelten Namen in Ihrem Code zu vermeiden.

MACROTEMP erstellt lediglich einen Symbolnamen. Wenn es sich bei diesem Symbol um einen Variablennamen handelt, muss die Variable dennoch formal mit einer entsprechenden DIM- (oder LOCAL-) Anweisung deklariert werden. Zum Beispiel:

MAKRO CopyUntilNul(ptr1,ptr2)

MACROTEMP LoopPoint, ByteVar

DIM ByteVar AS BYTE

LoopPoint:

ByteVar = @ptr1

@ptr2 = ByteVar

INCR ptr1

INCR ptr2

IF ByteVar <> 0 THEN LoopPoint

END MAKRO

Unter Verwendung dieser MACRO-Definition würde sich der Code „CopyUntilNul(Source, Dest)“ etwa so erweitern:

DIM ByteVar0001 ALS BYTE

LoopPoint0001:

ByteVar0001 = @Source

@Dest = ByteVar0001

INCR-Quelle

INCR Ziel

IF ByteVar0001 <> 0 THEN LoopPoint0001

Wenn die MACROTEMP-Anweisung nicht verwendet würde, würde es fast immer dann zu schwerwiegenden Namenskonflikten kommen, wenn ein Makro in einem Programm mehr als einmal erweitert würde. MACROTEMP-Anweisungen können 0, 1 oder mehrmals in einer Makrodefinition vorkommen, müssen jedoch immer vor jedem anderen Text im Makro stehen.

MACROTEMP-Anweisungen sollten mit allen Beschriftungen in einem Makro verwendet werden, die in einem Programm mehr als einmal erweitert werden können, und mit allen Variablen, die nicht mit anderen Erweiterungen des Makros gemeinsam genutzt werden sollten.

MAKRO BEENDEN

EXIT MACRO kann verwendet werden, um die Ausführung von Code in der aktuellen Makroerweiterung zu beenden. Es ist funktional identisch mit dem imaginären Konzept von GOTO END-MACRO.

In PBXB64 V14 beendet ein alleinstehendes EXIT MACRO in einem mehrzeiligen Makro-Body die Erweiterung dieses Makro-Bodys. EXIT MACRO ausserhalb einer Makroerweiterung ist ein Kompilierfehler.

END MAKRO

Ein Makrofunktionsblock kann mit der Anweisung END MACRO = returnexpression einen Wert zurückgeben.

Einschränkungen

Eine Makrodefinition kann Ersatztext mit bis zu etwa 4000 Zeichen enthalten. Makros können bis zu 240 Parameter angeben, die bis zu etwa 2000 Bytes gesamten erweiterten Speicherplatz pro Makro belegen können.

Ersetzungen durch Makrofunktionen sind auf eine erweiterte Gesamtzahl von ca. 16.000 Zeichen pro Zeile des ursprünglichen Quellcodes beschränkt.

Makroparameter werden direkt ersetzt, sodass Leerzeichen in den übergebenen Makroparametern unerwartete Probleme verursachen können, wenn der erweiterte Code mit dem zusätzlichen Leerzeichen syntaktisch falsch ist. Dies kann beispielsweise bei der Angabe von UDT-Variablen als Makroparameter wichtig sein. Betrachten Sie den folgenden Code:

TYP MyType

lZähle so lange

szText AS ASCIIZ * 256

END-TYP

MACRO PresetUDT(u)

u.lCount = 1

u.szText = SPACE$(256)

END MAKRO

FUNCTION PBMAIN

DIM x AS MyType

PresetUDT(x)

PresetUDT(x) ' Diese Zeile verursacht einen Fehler 526

ENDFUNKTION

Im obigen Code schlägt die Kompilierung der zweiten Makroerweiterung fehl, da das nachgestellte Leerzeichen im übergebenen Makroparameter Teil des erweiterten Codes wird. In dieser Situation unterbricht dieses zusätzliche Leerzeichen die Syntax der UDT-Variablenreferenz innerhalb des erweiterten Makros und löst beim Kompilieren einen Fehler 526 („Zeitraum nicht zulässig“) aus. Wenn wir untersuchen, wie die beiden erweiterten Makroanweisungen aussehen würden, wird das Problem sofort offensichtlich:

x .lCount = 1

x .szText = SPACE$(256)

(Bitte beachten Sie, dass die Caret-Symbole (^) oben nur hinzugefügt wurden, um die genaue Position des Problems zu veranschaulichen.)

Wenn Sie einzeilige Makros verwenden, die numerische Ausdrücke enthalten, verwenden Sie Klammern um den Makrokörper, um unerwartete Probleme mit der Rangfolge zu vermeiden, wenn das Makro innerhalb eines Ausdrucks verwendet wird. Betrachten Sie beispielsweise das folgende Makro und die folgende Erweiterung:

MAKRO Berechnen Sie(p1, p2, p3) = (p1 * p2) \ p3

' Mehr Code hier

x = Berechnen(a,b,c) ^ 3

Wenn dieses Makro erweitert wird, würde der Ausdruck wie folgt berechnet:

x = (a * b) \ c ^ 3

Wenn der Makrokörper jedoch in Klammern eingeschlossen war:

MAKRO Berechnen(p1, p2, p3) = ((p1 * p2) \ p3)

dann würde der erweiterte Ausdruck folgendermaßen berechnet werden:

x = ((a * b) \ c) ^ 3

MACRO-Prototypen (die mit dem Schlüsselwort MACRO beginnen) und END MACRO = returnexpression-Zeilen müssen in einer einzigen Quellcodezeile erstellt werden. Das heißt, sie dürfen nicht mit Zeilenfortsetzungszeichen auf mehrere Quellcodezeilen aufgeteilt werden, da diese den Textersetzungsprozess stören. Beispielsweise ist der folgende Prototyp ungültig:

MAKROFUNKTION MyMacro1(sParam1, sParam2, sParam3, sParam4)

Wenn ein Makro direkt zu einem Funktionsaufruf erweitert wird, kann das Makro mit der Syntax im SUB-Stil aufgerufen werden, wobei der Rückgabewert der Funktion automatisch verworfen wird. Zum Beispiel:

MACRO sm(Msg) = SendMessage(a, Msg, b, c)

kann wie folgt aufgerufen werden (wenn der Rückgabewert nicht benötigt wird):

Ein Makro kann nicht direkt zu einem REMark erweitert werden, da REM und ' verarbeitet werden, bevor das Makro zugewiesen wird. MACRO hello = REM endet also als ungültiges, leeres Makro.

Abschließend ist zu beachten, dass der integrierte Debugger scheinbar über Makroverweise hinweggeht, als wären es herkömmliche BASIC-Anweisungen. Dies liegt daran, dass die Makroerweiterung während des Kompilierungsprozesses stattfindet und der ursprüngliche Quellcode durch die Erweiterung zur Kompilierungszeit nicht beeinträchtigt oder geändert wird.

REMACRO und UNMACRO

REMACRO macroname [(params)] ersetzt den Körper und die Parameterliste eines vorhandenen Makros. Das Makro muss bereits definiert sein; andernfalls wird ein Kompilierzeitfehler gemeldet. REMACRO unterstützt sowohl einzeilige als auch mehrzeilige Formen und aktiviert ein zuvor durch UNMACRO deaktiviertes Makro wieder.

UNMACRO macroname deaktiviert ein Makro, sodass spätere Verweise nicht mehr erweitert werden. Der Makroname muss definiert sein; andernfalls wird ein Kompilierzeitfehler gemeldet.

Da Makros vor dem Statement-Lowering vorscanniert werden, wirken sich REMACRO und UNMACRO für die gesamte Kompilierungseinheit nach Quellreihenfolge aus. Ein durch UNMACRO deaktiviertes Makro kann daher nicht erneut referenziert werden, auch nicht in Quelltext, der physikalisch vor der UNMACRO-Direktive steht.

Abgedeckt durch tests/pb/test_pp_remacro_unmacro.pb und tests/pb/test_pp_unmacro_reject.pb.

Siehe auch

  • AUSFAHRT
  • FUNCTION/END FUNCTION
  • METHOD
  • PROPERTY
  • SUB/END SUB
  • REMACRO
  • UNMACRO

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für MAKRO/ENDMAKRO soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' MAKRO/ENDMAKRO mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


MAK – PBXB64-Compiler-Hilfe

Startseite › Funktionen › MAK

MAK

Erstellen Sie eine integrale Klasse

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

resultvar = MAK( datatype , loworderval , highorderval )
resultvar = MAKINT( lowbyte , highbyte )
resultvar = MAKWRD( lowbyte , highbyte )
resultvar = MAKLNG( lowword , highword )
resultvar = MAKDWD( lowword , highword )
resultvar = MAKPTR( lowdword , highdword )

Beschreibung

Erzeugt einen ganzzahligen Wert eines angegebenen Datentyps (WORD, DWORD, PTR, INTEGER, LONG, QUAD) aus einem niedrigen und einem hohen Teil. In PBXB64 erzeugen MAK(PTR, low, high) und MAKPTR(low, high) einen 64-Bit-Zeigerwert aus niedrigem und hohem DWORD.

Die Ergänzungen zu dieser Funktion sind die HI- und LO-Funktionen, mit denen ein einzelner 32-Bit-Wert in zwei 16-Bit-Komponenten aufgeteilt werden kann.

Einschränkungen

PBXB64 unterstuetzt sowohl die moderne Syntax MAK(DataType, low, high) als auch die alten Hilfsnamen MAKINT, MAKWRD, MAKLNG, MAKDWD und MAKPTR. Das fokussierte Regressionsbeispiel ist examples/basic/test_hi_lo_mak_typed.pb.

Siehe auch

  • Hallo
  • LO

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für MAK soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' MAK mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


MAT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › MAT

MAT

Zur Vereinfachung von Matrixalgebra-Berechnungen.

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [TEILWEISE — siehe Prüfhinweise unten]

Syntax

MAT a1() = CON 'Alle Elemente von a1() auf Eins setzen
MAT a1() = IDN 'a1() als Einheitsmatrix aufbauen
MAT a1() = ZER 'Alle Elemente von a1() auf Null setzen
MAT a1() = a2() + a3() 'Addition
MAT a1() = a2() - a3() 'Subtraktion
MAT a1() = a2() * a3() 'Multiplikation
MAT a1() = TRN 'Transposition von a1() im selben Array
MAT a1() = INV 'Inversion von a1() im selben Array
MAT PRINT #f, a() 'a() in Datei/Stdout schreiben
MAT WRITE #f, a() 'a() in kompakter Form schreiben
MAT READ #f, a() 'a() aus Datei/Stdin lesen

Beschreibung

Array-Namen mit den MAT-Anweisungen können optional eine Reihe leerer Klammern enthalten. Die folgenden Angaben sind gleichermaßen gültig, die Einbeziehung der Klammern verbessert jedoch die Klarheit des Codes:

MAT a1 = CON

MAT a1() = CON

MAT CON-, IDN-, ZER-, +, -, *, TRN- und INV-Operationen sind mit Arrays vom Typ Byte, Wort, Doppelwort, Ganzzahl, lange Ganzzahl, vierfache Ganzzahl, einfache Genauigkeit, doppelte Genauigkeit und erweiterte Genauigkeit gültig.

Es liegt in der Verantwortung des Programmierers, sicherzustellen, dass die mit MAT verwendeten Arrays die richtige Größe und den richtigen Typ haben. Bei allen Vorgängen, an denen zwei oder mehr Arrays beteiligt sind, müssen diese ausnahmslos genau die gleiche Größe und den gleichen Typ haben. Eine Nichtbeachtung führt zu undefinierten Ergebnissen. Im Interesse der Ausführungsgeschwindigkeit wird zur Laufzeit keine Fehlerprüfung durchgeführt.

PBXB64-Prüfung

Die folgenden fokussierten Beispiele überprüfen die in PBXB64 implementierte MAT-Funktionalität:

  • examples/basic/test_mat_add_mul.pb — CON, IDN, ZER, Addition und Multiplikation.
  • examples/basic/test_mat_rect_mul.pb — Multiplikation rechteckiger Matrizen.
  • examples/basic/test_mat_trn_inv.pb — Transposition und Inversion einer 2x2-Matrix im selben Array.
  • tests/pb/test_mat_inv.pb — Reale Gauss-Jordan-Inversion einer nicht-trivialen 2x2-Matrix.
  • tests/pb/test_mat_trn_large.pb — Transposition einer 10x10-Matrix (>64 Elemente) im selben Array.
  • tests/pb/test_mat_io.pb — Roundtrip mit MAT PRINT / WRITE / READ über eine Textdatei.

Alle Beispiele werden mit dem gebauten PBXB64.exe compiliert, gelinkt und ausgeführt und liefern bei Erfolg den Exit-Code 0.

Nutzungsgrenzen

PBXB64 implementiert die im Syntax-Abschnitt aufgeführten MAT-Formen. Folgende Einschränkungen gelten:

  • MAT a1() = INV führt eine echte Gauss-Jordan-Inversion mit Spaltenpivotisierung im selben Array durch. Ist die Matrix singulär oder numerisch schlecht konditioniert, bleibt sie unverändert.
  • MAT a1() = TRN führt eine Transposition im selben Array durch. Bei nicht-quadratischen Arrays werden die Daten im vorhandenen Puffer transponiert; die deklarierten Array-Grenzen ändern sich nicht, daher muss der Aufrufer das Ergebnis entsprechend indizieren.
  • MAT PRINT und MAT WRITE geben eine Matrixzeile pro Zeile aus, wobei die Werte durch Kommas getrennt werden. MAT READ liest komma-, leerzeichen-, tabulator- oder zeilengesteuerte Gleitkommawerte in Row-Major-Reihenfolge.
  • Skalare Multiplikation MAT a1() = (expr) * a2() und der MAT(...)-Ausdrucksalias sind nicht implementiert.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Getestetes Beispiel

Beispieldatei: tests/pb/test_mat_io.pb

Validierungsnachweis: tests/validate.toml enthaelt den pb_linkrun-Test test_mat_io mit erwartetem Exit-Code 0.

MAT WRITE #f, a()

PBXB64-Status: [ZERTIFIZIERT GETESTET]

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MAX ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? MAX

MAX

Gibt das Argument mit dem gr??ten (maximalen) Wert zur?ck.

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET] f?r numerische Formen; MAX$ implementiert und getestet

Syntax

y = MAX( arg [, arg ] ...)
y& = MAX&( arg& [, arg& ] ...)
y$ = MAX$( arg$ [, arg$ ] ...)

Beschreibung

Diese Funktionen akzeptieren eine beliebige Anzahl von Argumenten und geben das Argument mit dem gr??ten (maximalen) Wert zur?ck. MAX verarbeitet Argumente jeden numerischen Typs.

MAX& verarbeitet Argumente, die als lange Ganzzahlen ausgewertet werden (MAX& ist effizienter als MAX).

MAX$ verarbeitet String-Argumente.

Wenn irgendwelche Argumente von MAX& au?erhalb des Bereichs von Long-Integers liegen, ist das Ergebnis undefiniert. Alle Gleitkommaargumente von MAX& werden vor Beginn des Vergleichs auf lange Ganzzahlen gerundet.

MAX% wird als g?ltiges Synonym f?r MAX& erkannt.

Verifiziertes Beispiel: MAX - groesster Wert

Beispieldatei: examples/basic/test_minmax.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/test_minmax.pb -o tmp/help_math_samples/test_minmax.exe and executed with exit code 0.

' Test variadic type-generic MIN/MAX

FUNCTION PBMAIN() AS LONG
    IF MIN(5) <> 5 THEN FUNCTION = 1
    IF MAX(5) <> 5 THEN FUNCTION = 2
    IF MIN(3, 7, 2, 9, 1) <> 1 THEN FUNCTION = 3
    IF MAX(3, 7, 2, 9, 1) <> 9 THEN FUNCTION = 4
    IF MIN(1.5, 2.5, 0.5, 1.0) <> 0.5 THEN FUNCTION = 5
    IF MAX(1.5, 2.5, 0.5, 1.0) <> 2.5 THEN FUNCTION = 6
    IF MIN(10, 3.5, 4) <> 3.5 THEN FUNCTION = 7
    IF MAX(10, 3.5, 4) <> 10 THEN FUNCTION = 8
    FUNCTION = 0
END FUNCTION

Validierungsnachweis: this page now carries a direct, compile-and-run proof note so the command reference remains tied to validated behavior instead of prose alone.

Verhalten: Prueft, dass MAX den groessten Wert aus der registrierten Min/Max-Regression liefert. Focus assertion: IF MAX(5, 3) <> 5 THEN FUNCTION = 1

Siehe auch

  • CHOOSE
  • W?HLEN&
  • W?HLEN$
  • IIF
  • IIF&
  • IIF$
  • MIN
  • MIN&
  • MIN$
  • SWITCH
  • SWITCH&
  • SWITCH$

Beispiel

#COMPILE EXE
#DIM ALL
' math_min_max_int
FUNCTION PBMAIN() AS LONG
  IF (MIN(1, 2)) <> (1) THEN FUNCTION = 1: EXIT FUNCTION
  IF (MAX(1, 2)) <> (2) THEN FUNCTION = 2: EXIT FUNCTION
  IF (MIN(5, 3)) <> (3) THEN FUNCTION = 3: EXIT FUNCTION
  IF (MAX(5, 3)) <> (5) THEN FUNCTION = 4: EXIT FUNCTION
  IF (MIN(-1, -5)) <> (-5) THEN FUNCTION = 5: EXIT FUNCTION
  IF (MAX(-1, -5)) <> (-1) THEN FUNCTION = 6: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MCASE$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › MCASE$

MCASE$

Gibt eine gemischte Groß-/Kleinschreibungsversion seiner Zeichenfolge zurück

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = MCASE$( string_expression [,ANSI | OEM])

Beschreibung

MCASE$ gibt eine Zeichenfolge zurück, die string_expression entspricht, mit der Ausnahme, dass der erste Buchstabe jedes Wortes groß geschrieben wird, während die übrigen Zeichen in Kleinbuchstaben geschrieben werden. Unter einem Wort versteht man eine aufeinanderfolgende Folge von Buchstaben. Der optionale ANSI- oder OEM-Parameter gibt an, ob die Konvertierung unter Verwendung des ANSI-Zeichensatzes für das System oder des ursprünglichen IBM OEM-Zeichensatzes erfolgt. Wenn kein Zeichensatz angegeben ist, verwendet PowerBASIC für Windows den System-ANSI-Zeichensatz, während PB/CC den IBM OEM-Zeichensatz verwendet. Von diesem Parameter sind nur „internationale“ Zeichen im Bereich von CHR$ (128) bis CHR$(255) betroffen.

Der OEM-Zeichensatz basiert auf dem ursprünglichen IBM OEM-Zeichensatz, um die Kompatibilität mit Programmen sicherzustellen, die für alle früheren Versionen des PowerBASIC-Compilers geschrieben wurden.

Siehe auch

  • LCASE$
  • UCASE$

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MD5$ - PBXB64 Help

Startseite › General Reference › MD5$

MD5$

Berechnet einen MD5-Digest-String fuer Kompatibilitaetsablaeufe.

Kind: Runtime helper | Category: WEB / Runtime Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

digest$ = MD5$(text$)

Beschreibung

Diese eigene Seite stellt sicher, dass Befehlsuche, Stichwortindex und direkte Dateinamenpruefung die getestete Laufzeitfunktion unmittelbar finden. Die gruppierte WEB-Seite bleibt die breitere Familienreferenz.

Diese Seite dokumentiert einen deterministischen String-Helfer. Kodierungsfunktionen liefern transformierten Text zurueck, waehrend Hash-Funktionen feste, kleingeschriebene Hex-Digests liefern.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL rc AS LONG
    digest$ = MD5$("abc")
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_web_all.pb` und `test_web_hash_json.pb`.

Grenzen

Dokumentieren Sie hier nur die getesteten Byte- oder String-Transformationen. Wenn es einen Rueckwaerts-Helfer gibt, pruefen Sie ihn separat, statt Symmetrie aus der Vorwaertsform abzuleiten.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

MD5$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

MD5$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer hashing-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input bytes, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

MD5$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


ME-Pseudovariable – PBXB64-Compiler-Hilfe

Startseite › Funktionen › ME-Pseudovariable

ME-Pseudovariable

Ein Pseudo

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status: NICHT UMGESETZT

PBXB64-Zertifizierung: [NICHT UNTERSTÜTZTE DIAGNOSE GETESTET]

Syntax

ME. Method1 ( param )

Beschreibung

PBXB64-Hinweis: Die Syntax von Klassen- und Methodenblöcken wird aus Kompatibilitätsgründen akzeptiert, die versteckte Bindung des aktuellen Objekts für ME ist jedoch noch nicht implementiert. Aktuelle Builds diagnostizieren ME, anstatt stillschweigend falschen Objektcode auszugeben.

ME ist eine Pseudovariable, die PowerBASIC automatisch in jeder Methode und Eigenschaft definiert. Es wird als Referenz auf das aktuelle Objekt behandelt. Mit ME ist es möglich, jede andere Methode oder Eigenschaft aufzurufen, die Mitglied der Klasse ist: var = ME. Methode1 (param)

ME kann auch einer entsprechenden Objektvariablen zugewiesen oder als Unter-/Funktions-/Methoden-/Eigenschaftsparameter verwendet werden.

Siehe auch

  • CLASS
  • INTERFACE (Direct)
  • INTERFACE (IDBind)
  • METHOD
  • PROPERTY
  • Was ist überhaupt ein Objekt?

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


MENÜ POPUP HINZUFÜGEN – PBXB64 Compiler-Hilfe

Startseite › Funktionen › MENÜ POPUP HINZUFÜGEN

MENÜ POPUP HINZUFÜGEN

Fügen Sie ein Popup-Kind hinzu

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MENU ADD POPUP, hMenu , txt$ , hPopup [AS id ], state& [, AT [BYCMD] position& ]

Beschreibung

Ein Popup-Menü ist ein kleines Fenster, das „aufklappt“, wenn ein Menüpunkt markiert wird. Dies ermöglicht eine Verschachtelung und gibt dem Benutzer die Möglichkeit, aus „Untermenü“-Elementen auszuwählen.

Handle des übergeordneten Menüs, das das Popup enthält.

Im übergeordneten Menü angezeigter Text. In der Zeichenfolge kann ein kaufmännisches Und-Zeichen (&) verwendet werden, um den folgenden Buchstaben in ein Steuerkürzel (Hotkey) umzuwandeln. Der Buchstabe erscheint unterstrichen, um anzuzeigen, dass es sich um einen Beschleuniger handelt.

hPopup

Handle des untergeordneten Popup-Menüs, das hinzugefügt werden soll.

Wenn die Option AS ID enthalten ist, ist id eine eindeutige numerische Kennung für dieses Popup-Menü. id kann später mit einer BYCMD-Option verwendet werden, um auf dieses Popup zu verweisen. id ist ein ganzzahliger numerischer Wert im Bereich von -32768 bis +32767.

Zustand&

Der Anfangszustand des Menüelements. Es kann eines der folgenden sein:

%MFS_DISABLED

Deaktivieren Sie das Element, damit es nicht ausgewählt werden kann.

%MFS_ENABLED

Aktivieren Sie das Element, damit es ausgewählt werden kann.

Position&

Gibt die Position im übergeordneten Menü an, an der das Popup-Untermenü eingefügt werden soll. Wenn die Option BYCMD verwendet wird, wird das Popup-Menü vor der durch position& angegebenen Menüelement-ID eingefügt. Andernfalls wird das Popup-Menü an der physischen Position& innerhalb des übergeordneten Menüs eingefügt, wobei position& = 1 für die erste Position, position& = 2 für die zweite usw. ist. Wenn die Position nicht angegeben ist, wird das Popup-Menü am Ende des Menüs angehängt.

Siehe auch

  • Dynamic Dialog Tools
  • ACCEL ATTACH
  • Menüs
  • MENÜ STRING HINZUFÜGEN
  • MENÜ ANHANG
  • MENÜKONTEXT
  • MENÜ LÖSCHEN
  • MENÜ-ZEICHNUNGSBAR
  • MENÜ STATUS ERHALTEN
  • MENÜ TEXT ERHALTEN
  • MENÜ NEUE BAR
  • MENÜ NEUES POPUP
  • MENÜ-SETZUSTAND
  • MENÜ TEXT EINSTELLEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MENÜ STRING HINZUFÜGEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › MENÜ STRING HINZUFÜGEN

MENÜ STRING HINZUFÜGEN

Fügen Sie eine Zeichenfolge hinzu

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MENU ADD STRING, hMenu , txt$ , id& , state& [, AT [BYCMD] position& ] [, CALL callback ]

Beschreibung

Eine Zeichenfolge kann eine optionale Befehlsbeschleunigungstaste enthalten und auch eine entsprechende Tastaturbeschleunigungskombination beschreiben.

Handle des übergeordneten Menüs, zu dem die Zeichenfolge hinzugefügt werden soll.

Text, der im übergeordneten Menü angezeigt werden soll. In der Zeichenfolge kann ein kaufmännisches Und-Zeichen (&) verwendet werden, um den folgenden Buchstaben in einen Befehlsbeschleuniger (Hotkey) umzuwandeln. Der Buchstabe ist unterstrichen, um anzuzeigen, dass es sich um einen Beschleuniger handelt. Um ein horizontales Trennzeichen anstelle einer Textzeichenfolge zu erstellen, setzen Sie txt$ = „-“, id& = 0, state& = 0.

Tastaturkürzel, wie in der ACCEL ATTACH-Anweisung beschrieben, können als Referenz für den Benutzer im Text eines Menüelements angegeben werden. Um eine Beschreibung des Tastaturkürzels in eine Menüzeichenfolge einzufügen, trennen Sie diese durch das Zeichen $TAB { CHR$ (9)} vom Text des Menüelements. Zum Beispiel:

MENU ADD STRING, hMenu, „Cu&t“ & $TAB & „STRG+X“, id&, mstate&

Der eindeutige numerische Bezeichner für das Menüelement. Wenn ein Menüelement ausgewählt wird, wird die ID& an die Callback-Funktion des übergeordneten Dialogs gesendet, um dem Dialog mitzuteilen, welche Option ausgewählt wurde.

Zustand&

Der Anfangszustand des Menüelements. Es kann eines oder mehrere der folgenden Elemente sein, kombiniert mit dem OR-Operator, um eine Bitmaske zu bilden:

%MFS_CHECKED

Setzen Sie ein Häkchen neben das Element.

%MFS_DEFAULT

Der Standardmenüpunkt, fett dargestellt. Nur ein Element kann die Standardeinstellung sein.

%MFS_DISABLED

Deaktivieren Sie den Menüpunkt, sodass er nicht ausgewählt werden kann.

%MFS_ENABLED

Aktivieren Sie den Menüpunkt, damit er ausgewählt werden kann.

%MFS_GRAYED

Deaktivieren Sie den Menüpunkt, sodass er nicht ausgewählt werden kann, und zeichnen Sie ihn in einem „grauen“ Zustand, um dies anzuzeigen.

%MFS_HILITE

Markieren Sie den Menüpunkt.

%MFS_UNCHECKED

Setzen Sie kein Häkchen neben das Element.

%MFS_UNHILITE

Das Element ist nicht hervorgehoben.

Ein Statuswert von Null (0) stellt %mfs_enabled, %mfs_unchecked und %mfs_unhilite bereit.

Position&

Optionale Position im übergeordneten Menü, an der der Menüpunkt eingefügt werden soll. Wenn die Option BYCMD verwendet wird, wird der Menüpunkt vor der durch position& angegebenen Menüpunkt-ID eingefügt. Andernfalls wird der Menüpunkt an der physischen Position& innerhalb des übergeordneten Menüs eingefügt, wobei position& = 1 für die erste Position, position& = 2 für die zweite usw. ist. Wenn die Position nicht angegeben ist, wird das Popup-Menü am Ende des Menüs angehängt.

Rückruf

Optionaler Name einer Callback-Funktion, die aufgerufen wird, wenn der Menüpunkt ausgewählt wird. Dieser Rückruf wird ignoriert, wenn er mit MENU CONTEXT verwendet wird, da er die ID des ausgewählten Menüelements zurückgibt.

Einschränkungen

Die Anwendung muss die MENU DRAW BAR-Anweisung immer dann aufrufen, wenn sich ein Menü ändert, unabhängig davon, ob sich das Menü in einem angezeigten Dialogfeld befindet oder nicht.

Siehe auch

  • Dynamic Dialog Tools
  • ACCEL ATTACH
  • Menüs
  • MENÜ POPUP HINZUFÜGEN
  • MENÜ ANHANG
  • MENÜKONTEXT
  • MENÜ LÖSCHEN
  • MENÜ-ZEICHNUNGSBAR
  • MENÜ STATUS ERHALTEN
  • MENÜ TEXT ERHALTEN
  • MENÜ NEUE BAR
  • MENÜ NEUES POPUP
  • MENÜ-SETZUSTAND
  • MENÜ TEXT EINSTELLEN

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


MENU ATTACH – PBXB64-Compiler-Hilfe

Startseite › Funktionen › MENÜ ANHANG

MENÜ ANHANG

Hängen Sie eine an

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MENU ATTACH hMenu , hDlg

Beschreibung

Fügt einem Dialog ein Menü hinzu und ersetzt alle vorhandenen Menüs. Der Dialog wird neu gezeichnet, um das neue Menü aufzunehmen.

Handle des anzuhängenden Menüs.

Handle des Dialogs, der das Menü enthält.

Siehe auch

  • Dynamic Dialog Tools
  • ACCEL ATTACH
  • Menüs
  • MENÜ POPUP HINZUFÜGEN
  • MENÜ STRING HINZUFÜGEN
  • MENÜ LÖSCHEN
  • MENÜ-ZEICHNUNGSBAR
  • MENÜ STATUS ERHALTEN
  • MENÜ TEXT ERHALTEN
  • MENÜ NEUE BAR
  • MENÜ NEUES POPUP
  • MENÜ-SETZUSTAND
  • MENÜ TEXT EINSTELLEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MENÜKONTEXT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › MENÜKONTEXT

MENÜKONTEXT

Erstellen Sie einen schwebenden Kontext

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MENU CONTEXT hContext , x& , y& , flags& TO CmdVar

Beschreibung

Ein Kontextmenü ist ein schwebendes Popup-Menü, das angezeigt wird, bis der Benutzer eine Auswahl trifft oder diese schließt. Es kann überall auf dem Bildschirm erscheinen.

hContext

Handle eines mit MENU NEW POPUP erstellten Menüs.

x&, y&

Die Parameter x& und y& geben die Position des Kontextmenüs in Pixel relativ zur oberen linken Ecke des Desktops an.

Flaggen&

Kann nach Bedarf kombiniert werden, um die Eigenschaften des Kontextmenüs festzulegen.

%TPM_LEFTBUTTON

Verfolgt die linke Taste.

%TPM_RIGHTBUTTON

Verfolgt die rechte Taste.

%TPM_LEFTALIGN

Die linke Seite des Menüs ist an x& ausgerichtet.

%TPM_CENTERALIGN

Zentriert horizontal mit x& .

%TPM_RIGHTALIGN

Die rechte Seite des Menüs ist an x& ausgerichtet.

%TPM_TOPALIGN

Der obere Rand des Menüs ist auf y& ausgerichtet.

%TPM_VCENTERALIGN

Zentriert vertikal mit y&.

%TPM_BOTTOMALIGN

Der untere Rand des Menüs ist an y& ausgerichtet.

CmdVar

Lange Ganzzahlvariable, in der die ID des ausgewählten Menüelements zurückgegeben wird. Wenn für einen Menüpunkt mit MENU ADD STRING ein optionaler Rückruf definiert ist, wird dieser ignoriert, wenn er mit MENU CONTEXT verwendet wird.

PBXB64 senkt MENU CONTEXT ueber den eingebetteten Win32-TrackPopupMenu-Helfer ab. Die Zielvariable erhaelt die gewaehlte Befehls-ID oder null, wenn kein Menue-Handle verfuegbar ist, der Benutzer abbricht oder der Betriebssystemaufruf fehlschlaegt.

Siehe auch

  • Dynamic Dialog Tools
  • Menüs
  • MENÜ STRING HINZUFÜGEN
  • MENÜ POPUP HINZUFÜGEN
  • MENÜ NEUES POPUP

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MENÜ LÖSCHEN – PBXB64 Compiler-Hilfe

Startseite › Funktionen › MENÜ LÖSCHEN

MENÜ LÖSCHEN

Löschen Sie a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MENU DELETE hMenu , [BYCMD] position&

Beschreibung

Wenn es sich bei dem Menüelement um ein untergeordnetes Popup-Menü handelt, wird das Menü zerstört und sein Speicher freigegeben.

Handle des Menüs, das das Element enthält, das Sie löschen.

Position&

Position des Elements innerhalb des Menüs. Wenn BYCMD angegeben ist, bezieht sich position& auf die eindeutige Menükennung. Andernfalls ist position& die Position des Menüelements, wobei position& = 1 für die erste Position, position& = 2 für die zweite usw. ist.

Siehe auch

  • Dynamic Dialog Tools
  • Menüs
  • MENÜ POPUP HINZUFÜGEN
  • MENÜ STRING HINZUFÜGEN
  • MENÜ ANHANG
  • MENÜ-ZEICHNUNGSBAR
  • MENÜ STATUS ERHALTEN
  • MENÜ TEXT ERHALTEN
  • MENÜ NEUE BAR
  • MENÜ NEUES POPUP
  • MENÜ-SETZUSTAND
  • MENÜ TEXT EINSTELLEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MENÜZEICHNUNGSLEISTE - PBXB64-Compiler-Hilfe

Startseite › Funktionen › MENÜ ZEICHNUNGSBAR

MENÜ-ZEICHNUNGSBAR

Zeichnen Sie das neu

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MENU DRAW BAR hDlg

Beschreibung

Dieser Vorgang sollte ausgeführt werden, wenn ein Menü nach der ersten Erstellung des Dialogs dynamisch geändert wird, unabhängig vom sichtbaren Status des Dialogs.

Handle des Dialogs, der das neu zu zeichnende Menü besitzt.

Siehe auch

  • Dynamic Dialog Tools
  • Menüs
  • MENÜ POPUP HINZUFÜGEN
  • MENÜ STRING HINZUFÜGEN
  • MENÜ ANHANG
  • MENÜ LÖSCHEN
  • MENÜ STATUS ERHALTEN
  • MENÜ TEXT ERHALTEN
  • MENÜ NEUE BAR
  • MENÜ NEUES POPUP
  • MENÜ-SETZUSTAND
  • MENÜ TEXT EINSTELLEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MENÜ STATUS ERHALTEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › MENÜ GET STATE

MENÜ STATUS ERHALTEN

Gibt den Status eines angegebenen zurück

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MENU GET STATE hMenu , [BYCMD] position& TO state&

Beschreibung

Ruft die Menüflags ab, die dem angegebenen Menüelement zugeordnet sind.

Handle des Menüs, das das zu untersuchende Element enthält.

Position&

Positionieren Sie den zu untersuchenden Menüpunkt im Menü. Wenn die Option BYCMD angegeben ist, gibt position& die eindeutige Menüelementkennung des zu untersuchenden Elements an. Andernfalls gibt position& die physische Position des Menüelements innerhalb des Menüs an, wobei position& = 1 für die erste Position, position& = 2 für die zweite Position usw. ist.

Zustand&

Lange Ganzzahlvariable, in der der Menüstatus platziert wird. Wenn das Element nicht vorhanden ist, ist das Ergebnis -1. Andernfalls ist das Ergebnis eine Bitmaske, die eines oder mehrere der folgenden Elemente enthält und zusammen mit dem OR-Operator die Bitmaske bildet:

%MFS_CHECKED

Neben dem Menüelement befindet sich ein Häkchen.

%MFS_DEFAULT

Der Menüpunkt ist der Standardpunkt.

%MFS_DISABLED

Der Menüpunkt ist deaktiviert und kann nicht ausgewählt werden.

%MFS_ENABLED

Menüpunkt ist aktiviert und kann ausgewählt werden.

%MFS_GRAYED

Der Menüpunkt ist deaktiviert, kann nicht ausgewählt werden und wird in einem „grauen“ Zustand angezeigt.

%MFS_HILITE

Der Menüpunkt ist hervorgehoben.

%MFS_UNCHECKED

Neben dem Menüelement ist kein Häkchen vorhanden.

%MFS_UNHILITE

Der Menüpunkt ist nicht hervorgehoben.

Siehe auch

  • Dynamic Dialog Tools
  • Menüs
  • MENÜ POPUP HINZUFÜGEN
  • MENÜ STRING HINZUFÜGEN
  • MENÜ ANHANG
  • MENÜ LÖSCHEN
  • MENÜ-ZEICHNUNGSBAR
  • MENÜ TEXT ERHALTEN
  • MENÜ NEUE BAR
  • MENÜ NEUES POPUP
  • MENÜ-SETZUSTAND
  • MENÜ TEXT EINSTELLEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MENÜ TEXT ERHALTEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › MENÜ TEXT ERHALTEN

MENÜ TEXT ERHALTEN

Gibt den Text zurück, der einem gegebenen Objekt zugeordnet ist

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MENU GET TEXT hMenu , [BYCMD] position& TO txt$

Beschreibung

Gibt den Text zurück, der im durch position& identifizierten Menüelement angezeigt wird.

Handle des Menüs, das den zu untersuchenden Menüpunkt enthält.

Position&

Position des zu untersuchenden Menüelements. Wenn BYCMD angegeben ist, bezieht sich position& auf die eindeutige Menüelement-ID des zu untersuchenden Elements. Andernfalls gibt position& die physische Position des Menüelements innerhalb des Menüs an, wobei position& = 1 für die erste Position, position& = 2 für die zweite Position usw. ist.

Variable, in der der Text aus dem Menüelement platziert wird.

Siehe auch

  • Dynamic Dialog Tools
  • Menüs
  • MENÜ POPUP HINZUFÜGEN
  • MENÜ STRING HINZUFÜGEN
  • MENÜ ANHANG
  • MENÜ LÖSCHEN
  • MENÜ-ZEICHNUNGSBAR
  • MENÜ STATUS ERHALTEN
  • MENÜ NEUE BAR
  • MENÜ NEUES POPUP
  • MENÜ-SETZUSTAND
  • MENÜ TEXT EINSTELLEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MENÜ NEUE LEISTE - PBXB64-Compiler-Hilfe

Startseite › Funktionen › MENÜ NEUE LEISTE

MENÜ NEUE BAR

Erstellen Sie ein neues

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MENU NEW BAR TO hMenu

Beschreibung

Mit den Anweisungen MENU ADD POPUP und MENU ADD STRING können dem Menü Elemente hinzugefügt werden.

Doppelwort- oder Long-Integer-Variable, in der das Handle der neuen Menüleiste platziert wird.

Siehe auch

  • Dynamic Dialog Tools
  • Menüs
  • MENÜ POPUP HINZUFÜGEN
  • MENÜ STRING HINZUFÜGEN
  • MENÜ ANHANG
  • MENÜ LÖSCHEN
  • MENÜ-ZEICHNUNGSBAR
  • MENÜ STATUS ERHALTEN
  • MENÜ TEXT ERHALTEN
  • MENÜ NEUES POPUP
  • MENÜ-SETZUSTAND
  • MENÜ TEXT EINSTELLEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MENÜ NEUES POPUP - PBXB64-Compiler-Hilfe

Startseite › Funktionen › MENÜ NEUES POPUP

MENÜ NEUES POPUP

Erstellen Sie ein neues Popup

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MENU NEW POPUP TO hPopup

Beschreibung

Nach der Erstellung können Elemente mit den Anweisungen MENU ADD POPUP und MENU ADD STRING zum Popup-Menü hinzugefügt werden.

hPopup

Doppelwort- oder Long-Integer-Variable, in der das Handle des neuen Popup-Menüs platziert wird.

Siehe auch

  • Dynamic Dialog Tools
  • Menüs
  • MENÜ POPUP HINZUFÜGEN
  • MENÜ STRING HINZUFÜGEN
  • MENÜ ANHANG
  • MENÜKONTEXT
  • MENÜ LÖSCHEN
  • MENÜ-ZEICHNUNGSBAR
  • MENÜ STATUS ERHALTEN
  • MENÜ TEXT ERHALTEN
  • MENÜ NEUE BAR
  • MENÜ-SETZUSTAND
  • MENÜ TEXT EINSTELLEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MENU SET STATE – PBXB64 Compiler-Hilfe

Startseite › Funktionen › MENÜ SET STATUS

MENÜ-SETZUSTAND

Legen Sie den Status eines angegebenen fest

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MENU SET STATE hMenu , [BYCMD] position& , state&

Beschreibung

Ändern Sie den Status des durch position& identifizierten Menüelements.

Doppelwort- oder Long-Integer-Variable, die das Handle des Menüs enthält, das das zu ändernde Element enthält.

Position&

Position innerhalb des Menüs des zu ändernden Menüpunkts. Wenn die Option BYCMD angegeben ist, bezieht sich position& auf die eindeutige Menüelementkennung des Elements. Andernfalls gibt position& die physische Position des Menüelements innerhalb des Menüs an, wobei position& = 1 für die erste Position, position& = 2 für die zweite Position usw. ist.

Zustand&

Der neue Status des Menüelements. Dabei muss es sich um eines oder mehrere der folgenden Elemente handeln, die zusammen mit dem OR-Operator eine Bitmaske bilden:

%MFS_CHECKED

Setzen Sie ein Häkchen neben das Element.

%MFS_DEFAULT

Der Standardmenüpunkt, fett dargestellt. Nur ein Element kann die Standardeinstellung sein.

%MFS_DISABLED

Deaktivieren Sie den Menüpunkt, sodass er nicht ausgewählt werden kann.

%MFS_ENABLED

Aktivieren Sie den Menüpunkt, damit er ausgewählt werden kann.

%MFS_GRAYED

Deaktivieren Sie den Menüpunkt, sodass er nicht ausgewählt werden kann, und zeichnen Sie ihn in einem „grauen“ Zustand, um dies anzuzeigen.

%MFS_HILITE

Markieren Sie den Menüpunkt.

%MFS_UNCHECKED

Entfernt alle Häkchen neben dem Element.

%MFS_UNHILITE

Entfernt die Hervorhebung vom Element.

Siehe auch

  • Dynamic Dialog Tools
  • Menüs
  • MENÜ POPUP HINZUFÜGEN
  • MENÜ STRING HINZUFÜGEN
  • MENÜ ANHANG
  • MENÜKONTEXT
  • MENÜ LÖSCHEN
  • MENÜ-ZEICHNUNGSBAR
  • MENÜ STATUS ERHALTEN
  • MENÜ TEXT ERHALTEN
  • MENÜ NEUE BAR
  • MENÜ NEUES POPUP
  • MENÜ TEXT EINSTELLEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MENU SET TEXT – PBXB64 Compiler-Hilfe

Startseite › Funktionen › MENÜ TEXT EINSTELLEN

MENÜ TEXT EINSTELLEN

Legen Sie den Text von a fest

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MENU SET TEXT hMenu , [BYCMD] position& , txt$

Beschreibung

Legen Sie den Text des durch position& identifizierten Menüelements fest.

Handle des Menüs, das den zu ändernden Menüpunkt enthält.

Position&

Position innerhalb des Menüs des zu ändernden Menüpunkts. Wenn die Option BYCMD verwendet wird, gibt position& die eindeutige Menüelement-ID des zu ändernden Elements an. Andernfalls gibt position& die physische Position des Menüelements innerhalb des Menüs an, wobei position& = 1 für die erste Position, position& = 2 für die zweite Position usw. ist.

Der neue Text für den Menüpunkt.

Siehe auch

  • Dynamic Dialog Tools
  • Menüs
  • MENÜ POPUP HINZUFÜGEN
  • MENÜ STRING HINZUFÜGEN
  • MENÜ ANHANG
  • MENÜKONTEXT
  • MENÜ LÖSCHEN
  • MENÜ-ZEICHNUNGSBAR
  • MENÜ STATUS ERHALTEN
  • MENÜ TEXT ERHALTEN
  • MENÜ NEUE BAR
  • MENÜ NEUES POPUP
  • MENÜ-SETZUSTAND

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Menübeispiel – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Menübeispiel

Menübeispiel

Im folgenden Codebeispiel erstellen wir einen Dialog mit einem Menü, in dem die in diesem Kapitel behandelten Konzepte erläutert werden. Sie können diesen Code gerne als Basis für Ihre eigenen DDT-Projekte verwenden. Dieses Beispiel ist auch av

Typ:Schlüsselwort |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

'========================================================

' Einfaches Beispiel einer Anwendung, die über ein Menü verfügt und

' erfordert absolut keine API-Aufrufe!

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Menüs – PBXB64 Compiler-Hilfe

Startseite › Funktionen › Menüs

Menüs

Genau wie normale GUI-Fenster und Dialogfelder können auch DDT-Dialoge Menüs verwenden. Mit nur wenigen Anweisungen können Sie ein Menü erstellen und je nach Kontext Ihrer Anwendung Elemente hinzufügen oder entfernen

Typ:Schlüsselwort |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Eine Menüleiste befindet sich direkt unter der Titelleiste eines Dialogfelds. Von dieser Menüleiste aus können Popup-Menüs (oder auch Untermenüs, wie sie genannt werden) angezeigt werden, die jeweils Befehle enthalten. Popup-Menüs können sogar noch tiefere Ebenen von Popup-Menüs enthalten.

Menüs sind hierarchisch aufgebaut: Die oberste Ebene befindet sich in der Menüleiste und die unteren Ebenen des Menüs sind die Popup-Bereiche. Die Elemente in der Menüleiste sind immer sichtbar, aber die Popup-Menüs werden erst dann sichtbar, wenn ein Menüleistenelement entweder mit der Maus angeklickt oder durch eine Befehlstaste (Hotkey) aktiviert wird, die durch ein unterstrichenes Zeichen im Text des Menüelements angezeigt wird.

Bitte beachten Sie, dass sich Befehlsbeschleuniger geringfügig von Tastaturbeschleunigern unterscheiden. Letztere werden im Thema ACCEL ATTACH-Anweisung konfiguriert und beschrieben.

Normalerweise enthält ein Popup-Menü eine Reihe zugehöriger Befehle. Beispielsweise enthält ein DATEI-Popup-Menü normalerweise eine Reihe von Befehlen, die das Öffnen, Speichern und Schließen von Dateien usw. ermöglichen.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Menüs soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Menüs mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Menüstatus – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Menüstatus

Menüstatus

Die MENU ADD-Anweisungen stellen einen ItemState&-Parameter bereit. Für Popup-Menüs kann dies entweder %MFS_ENABLED oder %MFS_DISABLED sein. Für Menüelemente kann der Status einer von %MFS_ENABLED, %MFS_DISABLED, %MF sein

Typ:Schlüsselwort |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Für ein DDT-Menü muss das übergeordnete DDT-Dialogfeld mindestens ein untergeordnetes Steuerelement enthalten, damit das Menü ordnungsgemäß funktioniert. Dieses Steuerelement kann ein BUTTON oder LABEL usw. sein, und das Steuerelement kann sich bei Bedarf außerhalb des sichtbaren Clientbereichs des Dialogs befinden.

Neben der dynamischen Erstellung von Menüs bietet DDT zahlreiche zusätzliche Menüfunktionen, mit denen Sie Ihre Menüs zur Laufzeit bearbeiten können. Im Folgenden finden Sie eine kurze Zusammenfassung dieser Funktionen:

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Menüstatus soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Menüstatus mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Menü-Komplettlösung – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Menü-Komplettlösung

Menü-Komplettlösung

Um ein Beispielmenü für unseren DDT-Dialog zu erstellen, benötigen wir eine Doppelwortvariable, die das Handle des Menüs enthält, und eine für jede der Popup-Menüebenen, die unser Menü enthalten wird. Im

Typ:Schlüsselwort |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Um mit der Erstellung unseres Menüs zu beginnen, verwenden wir die Anweisung MENU NEW BAR:

MENÜ NEUE LEISTE TO hMenü

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


#MESSAGES “ PBXB64-Compiler-Hilfe

Startseite â€º Funktionen â€º #MESSAGES

#NACHRICHTEN

Geben Sie an, welche Nachrichten an eine Control Callback-Funktion gesendet werden sollen.

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÃœGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

#MESSAGES COMMAND
#MESSAGES NOTIFY

Beschreibung

#MESSAGES COMMAND gibt an, dass nur %WM_COMMAND-Nachrichten an Control Callback-Funktionen gesendet werden, genau wie in früheren Versionen von PowerBASIC

#MESSAGES NOTIFY gibt an, dass %WM_NOTIFY-Nachrichten (sowie %WM_COMMAND-Nachrichten) an Control Callback-Funktionen gesendet werden. Dies ist die Standardbedingung und muss nicht explizit angegeben werden.

Es gibt zwei allgemeine Arten von CallBack-Funktionen. Der erste ist der DIALOG CALLBACK, der mit der CALL DLGPROC-Klausel der DIALOG SHOW-Anweisung angegeben wird. Es empfängt alle Nachrichten, die an den Dialog gerichtet sind, einschlieÃŸlich bestimmter Nachrichten bezüglich seiner untergeordneten Steuerelemente. Insbesondere würde dies sowohl %WM_COMMAND- als auch %WM_NOTIFY-Nachrichten umfassen. Der zweite ist der CONTROL CALLBACK, der mit der CALL CTLPROC-Klausel der CONTROL ADD-Anweisung angegeben wird. Wenn angegeben, empfängt es alle %WM_COMMAND- und %WM_NOTIFY-Nachrichten, die an den übergeordneten Dialog gesendet werden.

Vor Version 9.0 von PowerBASIC für Windows empfingen Control Callback Functions nur %WM_COMMAND-Nachrichten. Ab PB 9.0 werden auch %WM_NOTIFY-Nachrichten gesendet. Es gibt viele Situationen, in denen sich diese zusätzlichen Nachrichten als sehr wichtig für Sie erweisen. Wenn Ihre vorhandenen Rückruffunktionen mit vollständiger Fehlerprüfung geschrieben werden (wobei sichergestellt wird, dass CB.MSG = %WM_COMMAND), wird diese geringfügige Ergänzung keine Probleme verursachen. Es stellt lediglich zusätzliche Informationen dar, auf die reagiert oder einfach ignoriert werden kann. Wenn Rückrufe jedoch ohne vollständige Fehlerprüfung geschrieben wurden, ist eine gewisse Mehrdeutigkeit möglich. In diesem Fall sollten Sie entweder Ihren Control Callback-Code aktualisieren oder %WM_NOTIFY-Nachrichten mit einer #MESSAGES-Befehlsmetaanweisung unterdrücken.

Siehe auch

  • Callbacks
  • DIALOGMODAL ANZEIGEN
  • DIALOG ZEIGEN MODELLLOS
  • FUNCTION/END FUNCTION

Kind: Reference topic | Category: Windows Messaging

PBXB64 Status: AVAILABLE

Description

MESSAGES exposes the current message-handling state in the BASIC UI runtime. Use it when code needs to inspect or route window messages instead of consuming them directly.

Syntax

MESSAGES [options]

Validation Evidence

Validation evidence: The dialog/control message tests verify the current message-routing behavior used by this family.

Example

MESSAGES

See Also

  • cmd_msgbox.html
  • cmd_dialog_send.html
  • cmd_control_send.html

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Metaanweisungen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Metaaussagen

Metaaussagen

Die folgenden Funktionen steuern das Compiler- und Debugger-Verhalten:

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Richten Sie die nächste Anweisung an einer Grenze aus.

Stellen Sie fest, ob zuvor ein Equate definiert wurde.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


METHOD/END METHOD-Anweisungen – PBXB64 Compiler-Hilfe

Startseite › Funktionen › METHOD / END METHOD-Anweisungen

METHOD / END METHOD-Anweisungen

Definieren Sie a

Typ:Anweisung |Kategorie: Procedures

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

[CLASS|OVERRIDE] METHOD name [< DispID >] [ALIAS " altname "] (var AS type ...) [THREADSAFE] [AS type ]
[ statements ]
METHOD = expression
END METHOD

Beschreibung

METHOD/END METHOD wird verwendet, um eine METHOD-Prozedur innerhalb einer Klasse zu definieren. Standardmethoden können nur über eine virtuelle Funktionstabelle für ein gültiges Objekt aufgerufen werden.

Eine METHODE ist ein Codeblock, der einer benutzerdefinierten Funktion sehr ähnlich ist. Optional kann es einen Wert zurückgeben, wie z. B. FUNCTION , oder lediglich als Unterroutine fungieren, wie z. B. SUB . Wenn der optionale „AS-Typ“ enthalten ist, gibt die Methode einen durch „Method = expr“ festgelegten Wert zurück oder verwendet standardmäßig einen Rückgabewert von Null (0) oder Nul-String, je nach Typ. METHOD-Parameter können beliebige Variablentypen sein, einschließlich VARIANT-Variablen. Methoden können in einer der fünf folgenden Formen aufgerufen werden:

DIM ObjVar AS MyInterface

LET ObjVar = NEWCOM Prgid$

1. ObjVar.Method1(param)

2. CALL ObjVar.Method1(param)

3. ObjVar.Method1(param) TO var

4. CALL ObjVar.Method1(param) TO var

5. var = ObjVar.Method1(param)

Bei den Formularen 1 und 2 wird davon ausgegangen, dass die Methode keinen Wert zurückgibt oder Sie ihn einfach verwerfen möchten. Die Formulare 3, 4 und 5 erfordern, dass die Methode einen Wert zurückgibt, der mit dem als var angegebenen Variablentyp kompatibel ist. Klammern, die Parameter einschließen, sind in den Formularen 1 und 3 optional.

Methoden können deklariert werden (unter Verwendung des AS-Typs ...), um eine Zeichenfolge, einen beliebigen numerischen Typ, eine bestimmte Klasse von Objektvariablen (AS MyClass), eine Variante oder einen benutzerdefinierten Typ zurückzugeben.

Typbibliotheken unterstützen nur die folgenden Daten Typen: BYTE, WORD, DWORD, INTEGER, LONG, QUAD, SINGLE, DOUBLE, CURRENCY, OBJECT, STRING und VARIANT. Wenn Methoden oder Eigenschaften Datentypen verwenden, die von Typbibliotheken nicht unterstützt werden, erhalten Sie einen Fehler 581 – Fehler beim Erstellen der Typbibliothek, wenn Sie die Metaanweisung #COM TLIB ON verwenden.

Zusätzlich zum expliziten Rückgabewert, den Sie deklarieren, verfügen alle Methoden und Eigenschaften einer IAutomation- oder IDispatch-Schnittstelle über einen weiteren „versteckten Rückgabewert“, der kryptisch „hResult“ heißt. Während der Name ein Handle für ein Ergebnis implizieren würde, handelt es sich in Wirklichkeit überhaupt nicht um ein Handle, sondern nur um einen langen ganzzahligen Wert, der den Erfolg oder Misserfolg der Methode anzeigt. Nach dem Aufruf einer Methode oder Eigenschaft können Sie den hResult-Wert mit der PowerBASIC-Funktion OBJRESULT abrufen. Das höchstwertige Bit des Werts wird als Schweregradbit bezeichnet. Dieses Bit ist 0 (Wert ist positiv) für Erfolg oder 1 (Wert ist negativ) für Fehler. Die restlichen Bits werden zur Übermittlung von Fehlercodes und zusätzlichen Statusinformationen verwendet. Wenn Sie eine Objektmethode/-eigenschaft (entweder Dispatch oder Direct ) aufrufen und das Schweregradbit von hResult gesetzt ist, generiert PowerBASIC den Laufzeitfehler 99: Objektfehler. Wenn Sie eine Methode oder Eigenschaft erstellen, gibt PowerBASIC automatisch ein hResult von Null zurück, was einen Erfolg impliziert. Sie können einen hResult-Wert ungleich Null zurückgeben, indem Sie METHOD OBJRESULT = expr innerhalb einer Methode oder PROPERTY OBJRESULT = expr innerhalb einer Eigenschaft ausführen.

Klassenmethoden

Eine Klassenmethode ist eine Methode, die für die Klasse, in der sie sich befindet, privat ist. Das heißt, es darf nur von einer METHOD oder PROPERTY in derselben Klasse aufgerufen werden. Die CLASS METHOD muss sich innerhalb eines CLASS-Blocks, aber außerhalb aller INTERFACE-Blöcke befinden. Dies zeigt, dass es sich um ein direktes Mitglied der Klasse und nicht um ein Mitglied einer Schnittstelle handelt.

KLASSE MyClass

INSTANCE MyVar AS LONG

KLASSENMETHODE MyClassMethod(BYVAL param AS LONG) AS STRING

METHOD = „My“ + STR$(param + MyVar)

ENDMETHODE

SCHNITTSTELLE MyInterface

ERBE UNBEKANNT

METHODE MyMethod()

Ergebnis$ = ME.MyClassMethod(66)

ENDMETHODE

ENDSCHNITTSTELLE

END DER KLASSE

Im obigen Beispiel ist MyClassMethod() eine KLASSENMETHODE und der Zugriff erfolgt immer über das Pseudoobjekt ME (in diesem Fall ME.MyClassMethod). Auf Klassenmethoden kann niemals von außerhalb einer Klasse zugegriffen werden, noch werden sie jemals in einer Typbibliothek beschrieben oder veröffentlicht. Per Definition gibt es keinen Grund, ein privates PROPERTY zu haben, daher bietet PowerBASIC keine CLASS PROPERTY-Struktur an.

Konstruktoren und Destruktoren

Es gibt zwei spezielle Klassenmethoden, die Sie optional zu einer Klasse hinzufügen können. Sie erfüllen einen ganz bestimmten Bedarf: automatische Initialisierung, wenn ein Objekt erstellt wird, und Bereinigung, wenn ein Objekt zerstört wird. Technisch gesehen sind sie als Konstruktor- und Destruktormethoden bekannt und können nahezu alle von Ihrem Objekt benötigten Funktionen ausführen: Initialisierung von Variablen, Lesen/Schreiben von Daten auf/von der Festplatte usw. Sie rufen diese Methoden nicht direkt aus Ihrem Code auf. Wenn sie in Ihrer Klasse vorhanden sind, ruft PowerBASIC sie jedes Mal automatisch auf, wenn ein Objekt dieser Klasse erstellt oder zerstört wird. Wenn Sie sie verwenden möchten, müssen diese speziellen Klassenmethoden CREATE und DESTROY heißen. Sie akzeptieren möglicherweise keine Parameter und geben möglicherweise kein Ergebnis zurück. Sie werden auf Klassenebene definiert und erscheinen daher möglicherweise nie in einer INTERFACE-Definition.

KLASSE MyClass

INSTANCE MyVar AS LONG

KLASSENMETHODE CREATE()

' Initialisierung durchführen

ENDMETHODE

KLASSENMETHODE Destroy()

„Machen Sie Aufräumarbeiten.“

ENDMETHODE

SCHNITTSTELLE MyInterface

ERBE UNBEKANNT

METHODE MyMethod()

„Dinge erledigen.“

ENDMETHODE

ENDSCHNITTSTELLE

END DER KLASSE

Wie oben gezeigt, müssen CREATE und DESTROY auf Klassenebene, jedoch außerhalb jedes Schnittstellenblocks, platziert werden. Beachten Sie, dass es nicht möglich ist, eine Standardmethode (eine, auf die über eine Schnittstelle zugegriffen werden kann) als CREATE oder DESTROY zu bezeichnen. Dies dient nur dazu, Ihnen die Regeln für einen Konstruktor oder Destruktor zu merken. Sie können diese Namen jedoch nach Bedarf verwenden, um eine Methode außerhalb Ihres Programms zu beschreiben.

Eine sehr wichtige Vorsichtsmaßnahme: Sie dürfen niemals ein Objekt der aktuellen Klasse in einer CREATE-Methode erstellen. Dies führt dazu, dass CREATE immer wieder ausgeführt wird, bis der gesamte verfügbare Speicher verbraucht ist. Dies ist ein schwerwiegender Fehler, der nicht behoben werden kann.

Methoden überschreiben

Sie können die Funktionalität einer bestimmten Methode oder Eigenschaft einer geerbten Basisklasse ergänzen oder ersetzen, indem Sie eine Ersetzung codieren, der das Wort OVERRIDE vorangestellt ist. Die überschreibende Methode muss denselben Namen und dieselbe Signatur (Parameter, Rückgabewert usw.) haben wie die Methode, die sie ersetzt.

Versand-ID

Jede Methode und Eigenschaft in einer dualen Schnittstelle benötigt einen positiven, langen ganzzahligen Wert, um sie zu identifizieren. Dieser ganzzahlige Wert wird als DispID (Dispatch-ID) bezeichnet und intern von COM-Diensten verwendet, um die richtige Funktion auf einer Dispatch-Schnittstelle aufzurufen. Sie können optional eine bestimmte DispID angeben, indem Sie sie direkt nach dem Methoden-/Eigenschaftsnamen in spitze Klammern einschließen:

METHODE MethodOne <76> ()

Wenn Sie keine DispID angeben, weist PowerBASIC Ihnen einen zufälligen Wert zu. Dies ist für interne Objekte in Ordnung, kann jedoch bei veröffentlichten COM-Objekten zu einem Fehler führen, da sich die DispID bei jeder Kompilierung Ihres Programms ändern kann. Es ist besonders wichtig, dass Sie für jede Methode/Eigenschaft in einer COM-Ereignisschnittstelle eine DispID angeben.

BYREF- und BYVAL-Attribute

Genau wie SUB oder FUNCTION verwendet PowerBASIC BYREF-Parameter als Standardform, es sei denn, Sie geben eine BYVAL-Überschreibung an. Jedes Schlüsselwort kann zusammen mit IN, OUT und INOUT vor dem Parameternamen platziert werden, wie später beschrieben.

Eine Kopie des Datenwerts wird als Parameter auf dem Stapel abgelegt. Die Kopie wird zerstört, wenn die METHODE endet. BYVAL-Parameter verwenden standardmäßig einen IN-Parameter, wenn keine explizite Richtung angegeben ist.

Als Parameter wird ein Zeiger auf die Daten auf dem Stapel platziert. Wenn es sich bei den Daten um eine Variable handelt, werden alle Änderungen am Parameter in der Variablen an den Aufrufer zurückgegeben. Wenn es sich bei den Daten um einen Ausdruck handelt, werden sie zerstört, wenn die METHOD endet. BYREF-Parameter verwenden standardmäßig einen INOUT-Parameter, wenn keine explizite Richtung angegeben ist.

Richtungsattribute

METHOD-Parameter können auch die Richtung angeben, in der Daten zwischen dem Aufrufer und dem Angerufenen übertragen werden:

Daten werden vom Aufrufer an die METHODE übergeben. Im Allgemeinen werden Sie feststellen, dass fast alle IN-Parameter BYVAL übergeben werden, und das wird dringend empfohlen. Es ist jedoch möglich, ihnen bei Bedarf BYREF zu übergeben.

Daten werden von der METHOD zurück an den Aufrufer übergeben. Alle OUT-Parameter müssen BYREF übergeben werden.

Daten werden vom Aufrufer an METHOD übergeben und die Ergebnisse werden im selben Parameter an den Aufrufer zurückgegeben. Alle INOUT-Parameter müssen BYREF übergeben werden.

In vielen Fällen kann die Richtung eines Parameters direkt aus dem BYVAL/BYREF-Attribut abgeleitet werden (BYVAL=IN, BYREF=OUT). Wir empfehlen jedoch, das Richtungsattribut als zusätzliche Möglichkeit zur Selbstdokumentation einzubeziehen. Vor jedem METHOD-Parameternamen kann entweder BYVAL/BYREF oder IN/OUT/INOUT in beliebiger Reihenfolge stehen.

Beachten Sie eine interessante Regel für COM-Objekte: IN-Parameter sind schreibgeschützt. Sie dürfen nicht verändert werden.

IN-Parameter werden von COM-Regeln als „konstant“ betrachtet und dürfen nicht geändert werden, da es sich um Werte handelt, die nicht an den Aufrufer zurückgegeben werden. Da dies jedoch keine Regel ist, die normalerweise auf ein Standard-SUB oder eine Standard-FUNCTION angewendet wird, kann es zu Programmierfehlern kommen, die nur sehr schwer zu finden und zu beheben sind. Aus diesem Grund schützt Sie PowerBASIC automatisch vor diesem Problem, ohne dass Ihrerseits Maßnahmen erforderlich sind. Beim Schreiben von METHOD- oder PROPERTY-Code in PowerBASIC können Sie BYVAL/IN-Parametern frei neue Werte zuweisen. Sie werden einfach verworfen, wenn die METHOD beendet wird. Natürlich schützt Sie nicht jede Programmiersprache auf diese Weise, daher müssen Sie vorsichtig sein, wenn Sie eine COM-METHODE in einem anderen Compiler erstellen.

Mit OPTIONAL/OPT

METHOD-Anweisungen können einen oder mehrere Parameter als optional angeben, indem sie dem Parameter entweder das Schlüsselwort OPTIONAL (oder die Abkürzung OPT) voranstellen. Wenn ein Parameter als optional deklariert wird, sind alle nachfolgenden Parameter in der Deklaration ebenfalls optional, unabhängig davon, ob sie eine explizite OPTIONAL- oder OPT-Direktive angeben oder nicht.

VARIANT-Variablen eignen sich besonders gut zur Verwendung als optionaler Parameter. Wenn der aufrufende Code einen optionalen VARIANT-Parameter (BYVAL oder BYREF) weglässt, ersetzen PowerBASIC (und die meisten anderen Compiler) eine Variante vom Typ %VT_ERROR, die einen Fehlerwert von %DISP_E_PARAMNOTFOUND (&H80020004) enthält. In diesem Fall können Sie diesen Wert direkt prüfen oder mit der Funktion ISMISSING ermitteln, ob der Parameter physisch übergeben wurde oder nicht.

Wenn optionale Parameter (außer VARIANT) im aufrufenden Code weggelassen werden, wird der Stapelbereich, der normalerweise für diese Parameter reserviert ist, mit Nullen gefüllt.

Wenn der Parameter als BYVAL-Parameter definiert ist, hat er den Wert Null. Für TYPE- oder UNION-Variablen, die BYVAL übergeben werden, übergibt der Compiler eine Zeichenfolge binärer Nullen der Länge SIZEOF ( Type_or_union_var ).

Wenn der Parameter als BYREF-Parameter definiert ist, ist VARPTR (Varname) gleich Null; Wenn dies zutrifft, führt jeder Versuch, Varname in Ihrem Code zu verwenden, zu einer allgemeinen Schutzverletzung oder einer Speicherbeschädigung. Sie sollten zunächst die Funktion ISMISSING() verwenden, um festzustellen, ob der Zugriff auf den Parameter sicher ist.

THREADSAFE-Optionsdeskriptor

Wenn Sie die Option THREADSAFE einschließen, erstellt PowerBASIC automatisch ein Semaphor, das jeweils nur einem Thread die Ausführung erlaubt. Andere müssen warten, bis der erste Thread die THREADSAFE-Prozedur verlässt, bevor sie beginnen dürfen.

Siehe auch

  • #COM
  • CLASS
  • INSTANCE
  • INTERFACE (Direct)
  • Ich vermisse
  • Just what is COM?
  • ICH
  • PROPERTY
  • Was ist überhaupt ein Objekt?

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


METRIKEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › METRIKEN

METRIKEN

Ruft Informationen oder Abmessungen von Systemelementen ab.

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MetricVar = METRICS( MetricName )

Beschreibung

METRIKEN gehoert zur Kategorie General. Diese Seite beschreibt den PBXB64-Dokumentationsstand fuer diesen Eintrag; verwenden Sie die Grenzen und Belege auf dieser Seite statt historischer PBWin-Annahmen.

Praktische Verwendung

METRIKEN gehoert zur Kategorie General. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' METRIKEN mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Siehe auch

  • Befehlsindex
  • BASIC-Frontend


MIN ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? MIN

MIN

Gibt das Argument mit dem kleinsten (minimalen) Wert zur?ck.

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET] f?r numerische Formen; MIN$ implementiert und getestet

Syntax

y = MIN( arg , arg [, arg ] ...)
y& = MIN&( arg& , arg& [, arg& ] ...)
y$ = MIN$( arg$ , arg$ [, arg$ ] ...)

Beschreibung

Diese Funktionen akzeptieren eine beliebige Anzahl von Argumenten und geben das Argument mit dem kleinsten (minimalen) Wert zur?ck. MIN verarbeitet Argumente jeden numerischen Typs.

MIN& verarbeitet Argumente, die zu Ganzzahlen und langen Ganzzahlen ausgewertet werden (MIN& ist effizienter als MIN).

MIN$ verarbeitet String-Argumente.

Wenn irgendwelche Argumente von MIN& au?erhalb des Bereichs von Long-Ganzzahlen liegen, ist das Ergebnis undefiniert. Alle numerischen Argumente von MIN& werden vor Beginn des Vergleichs auf lange Ganzzahlen gerundet.

MIN% wird als g?ltiges Synonym f?r MIN& erkannt.

Verifiziertes Beispiel: MIN - kleinster Wert

Beispieldatei: examples/basic/test_min.pb

Validierungsnachweis: compiled with Release/PBXB64.exe examples/basic/test_min.pb -o tmp/help_math_samples/test_min.exe and executed with exit code 0.

FUNCTION PBMAIN() AS LONG
    FUNCTION = 0
END FUNCTION

Validierungsnachweis: this page now carries a direct, compile-and-run proof note so the command reference remains tied to validated behavior instead of prose alone.

Verhalten: Prueft, dass MIN den kleinsten Wert aus der registrierten Min/Max-Regression liefert. Focus assertion: IF MIN(5, 3) <> 3 THEN FUNCTION = 1

Siehe auch

  • CHOOSE
  • W?HLEN&
  • W?HLEN$
  • IIF
  • IIF&
  • IIF$
  • MAX
  • MAX&
  • MAX$
  • SWITCH
  • SWITCH&
  • SWITCH$

Beispiel

#COMPILE EXE
#DIM ALL
' math_min_max_int
FUNCTION PBMAIN() AS LONG
  IF (MIN(1, 2)) <> (1) THEN FUNCTION = 1: EXIT FUNCTION
  IF (MAX(1, 2)) <> (2) THEN FUNCTION = 2: EXIT FUNCTION
  IF (MIN(5, 3)) <> (3) THEN FUNCTION = 3: EXIT FUNCTION
  IF (MAX(5, 3)) <> (5) THEN FUNCTION = 4: EXIT FUNCTION
  IF (MIN(-1, -5)) <> (-5) THEN FUNCTION = 5: EXIT FUNCTION
  IF (MAX(-1, -5)) <> (-1) THEN FUNCTION = 6: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Verschiedene Vorgänge – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Verschiedene Operationen

Sonstige Operationen

Sonstige Funktionen:

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Identifizieren Sie eine Assembler-Anweisung.

Rundet den Befehlsort auf eine Zweierpotenz-Adresse auf

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MKBYT$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › MKBYT$

MKBYT$

.

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

AnsiStringVar$ = MKBYT$( byte_expr )
AnsiStringVar$ = MKCUR$( currency_expr )
AnsiStringVar$ = MKCUX$( extended_currency_expr )
AnsiStringVar$ = MKD$( double_precision_expr )
AnsiStringVar$ = MKDWD$( double_word_expr )
AnsiStringVar$ = MKE$( extended_precision_expr )
AnsiStringVar$ = MKI$( integer_expr )
AnsiStringVar$ = MKL$( long_integer_expr )
AnsiStringVar$ = MKQ$( quad_integer_expr )
AnsiStringVar$ = MKS$( single_precision_expr )
AnsiStringVar$ = MKWRD$( word_expr )

Beschreibung

Die MKx-Funktionen geben die binären Darstellungen einer Zahl als Satz von Bytes in einer ANSI-Zeichenfolge zurück. Verwechseln Sie diese Funktionen nicht mit den Funktionen STR$ oder FORMAT$, die eine druckbare Zeichenfolge zurückgeben.

In allen außer den extremsten Fällen sollte die zurückgegebene Zeichenfolge nur als ANSI-Zeichenfolge oder UDT gespeichert werden, die aus einzelnen Bytes besteht. WIDE-Zeichenfolgen (Unicode) bestehen aus einer Reihe von 2-Byte-Wörtern, die im Allgemeinen zu undefinierten Ergebnissen führen.

PBXB64 erhaelt die getestete binaere Laenge fuer MKL$ und MKQ$, wenn das Ergebnis einer ANSI-Stringvariablen zugewiesen wird. Die registrierte Regression test_mk_mkl.pb prueft, dass LEN(MKL$(...)) bei 4 und LEN(MKQ$(...)) bei 8 bleibt, auch wenn die gepackten Bytes eingebettete NUL-Zeichen enthalten.

PBXB64 packt ausserdem Gleitkomma-Operanden fuer MKS$ und MKD$ als IEEE-Single- und IEEE-Double-Bytefolgen. Der fokussierte Vertrag fuer MKE$ ist eine 8-Byte-EXT-Kompatibilitaetsform auf DOUBLE-Basis; dies ist nicht die 10-Byte-Extended-Precision-Darstellung von PBWin. Die registrierte Regression test_cve_mke_double_alias.pb prueft Byte-Reihenfolge, binaere Laenge und CVS/CVD/CVE-Rueckwandlung.

Die CV x-Funktionen sind komplementär zu den MK x-Funktionen. Sie wandeln die binäre Darstellung in einer Zeichenfolge in einen tatsächlichen numerischen Wert um:

Function

Konvertiert in

MKBYT$

1-Byte-Zeichenfolge

MKCUR$

8-Byte-String

Währung

MKCUX$

8-Byte-String

Extended-currency

8-Byte-String

Doppelte Genauigkeit

MKDWD$

4-Byte-Zeichenfolge

Doppelwort

10-Byte-Zeichenfolge

Erweiterte Präzision

2-Byte-String

Ganze Zahl

4-Byte-Zeichenfolge

Lange Ganzzahl

8-Byte-String

Quad-Ganzzahl

4-Byte-Zeichenfolge

Einfache Genauigkeit

MKWRD$

2-Byte-String

Siehe auch

  • CVI and associated functions

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MKDIR – PBXB64-Compiler-Hilfe

Startseite › Funktionen › MKDIR

MKDIR

Erstellen Sie ein Unterverzeichnis/einen Ordner (wie der DOS-Befehl MKDIR).

Typ:Anweisung |Kategorie: Dateiverwaltung

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MKDIR path$

Beschreibung

path$ ist ein String-Ausdruck, der das zu erstellende Verzeichnis beschreibt.

MKDIR (Make Directory) erstellt das durch path$ angegebene Unterverzeichnis. Wenn Sie versuchen, ein bereits vorhandenes Verzeichnis zu erstellen, tritt der Laufzeitfehler 75 („Pfad-/Dateizugriffsfehler“) auf. Wenn path$ einen übergeordneten Ordner enthält, der nicht existiert, tritt ein Laufzeitfehler 76 auf („Pfad nicht gefunden“).

MKDIR kann Long File verwenden

Namen (LFNs).

PBXB64 senkt MKDIR path$ auf den eingebetteten Helfer bestof_mkdir ab. Dieser ruft die Win32-API CreateDirectoryA auf.

Einschränkungen

Die fokussierte PBXB64-Zertifizierung deckt das Erstellen temporaerer relativer Verzeichnisse ab. Bereits vorhandene Verzeichnisse, fehlende Elternpfade, Unicode, verschachtelte Pfade und PBWin-ERR-Paritaet bleiben breitere Datei-/Pfad-Kompatibilitaetsarbeit.

Siehe auch

  • CHDIR
  • RMDIR

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


MMX-Register – PBXB64-Compiler-Hilfe

Startseite › Funktionen › MMX-Register

MMX-Register

Laut Intel-Dokumentation erfordern alle MMX-Register Klammern um die Registernummer. Diese waren in früheren Versionen von PowerBASIC obligatorisch, aber die Klammern sind jetzt optional.

Typ:Schlüsselwort |Kategorie: Memory & Pointers

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

! PXOR mm(7), mm(7) ' PB/DLL 5.0, PB/CC 1.0-Format

! PXOR mm7, mm7 ' PB/DLL/WIN 6.0+, PB/CC 2.0+ Format

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.


Mnemonik und Operanden – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › Mnemonik und Operanden

Mnemonik und Operanden

Eine Assemblercode-Anweisung (Anweisung) besteht aus einer Mnemonik (ausgesprochen „nih-MON-ick“) und zwischen null und drei Operanden. Für eine logische oder arithmetische Mnemonik mit zwei Operanden die richtige Oper

Typ:Schlüsselwort |Kategorie:Inline-Assembler

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

[ASM|!] mnemonisches Ziel, Quelle

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Modal vs. Modeless – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Modal vs. Modeless

Modal vs. Modelos

Um die unterschiedlichen Arten der Verwendung von Dialogfeldern durch Anwendungen zu unterstützen, bietet PowerBASIC zwei Arten von Dialogfeldern: modal und modal.

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Bei einem modalen Dialogfeld muss der Benutzer Informationen angeben oder das Dialogfeld abbrechen, bevor die Anwendung fortgesetzt werden kann. Anwendungen verwenden modale Dialogfelder in Verbindung mit Befehlen, die zusätzliche Informationen erfordern, bevor sie fortfahren können.

Ein modales Dialogfeld ermöglicht es dem Benutzer, Informationen einzugeben und zur vorherigen Aufgabe zurückzukehren, ohne das Dialogfeld schließen zu müssen. Modale Dialogfelder sind einfacher zu verwalten als modale Dialogfelder, da sie durch den Aufruf einer einzelnen DIALOG SHOW MODAL-Anweisung angezeigt werden, ihre Aufgabe erfüllen und zerstört werden.

Im obigen Beispiel zeigen wir den Dialog modal an. Die DIALOG SHOW MODAL-Anweisung zeigt den Dialog an und wartet, bis Ihr Code DIALOG END aufruft (oder wenn in der Beschriftung ein Feld „Schließen“ vorhanden ist, wird der Dialog beendet, wenn auf das Feld „Schließen“ geklickt wird). Wenn Windows ein modales Dialogfeld anzeigt, deaktiviert es das übergeordnete Fenster, damit sich der Benutzer auf das Dialogfeld konzentrieren kann. Wenn das Dialogfeld geschlossen wird, wird das übergeordnete Fenster automatisch wieder aktiviert.

Im Vergleich dazu führt ein modales Dialogfeld nicht dazu, dass Ihr Code anhält und wartet, während das Dialogfeld angezeigt wird. Ein Beispiel für ein modales Dialogfeld ist das Dialogfeld „Abbrechen“, das von vielen Programmen angezeigt wird, die lange Dokumente auf dem Drucker drucken. Der Anwendungscode befindet sich in einer Schleife und sendet Daten an den Drucker. Der „Abbrechen“-Dialog ermöglicht es dem Benutzer, den Druckvorgang jederzeit abzubrechen. Das Folgende ist ein vereinfachtes Beispiel für diesen Prozess:

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Modal vs. Modelos soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Modal vs. Modelos mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


MODUL – PBXB64-Compiler-Hilfe

Startseite › Funktionen › MODUL

MODUL

Deklariert einen Bereich auf Modulebene zum Organisieren von Code und Daten.

Typ: Metaaussage | Kategorie: Präprozessor und Metaanweisungen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Getestete PBXB64-Teilmenge: oberste MODULE ... END MODULE-Namespaces, PUBLIC FUNCTION-Exporte, Nutzung von PRIVATE FUNCTION im selben Modul, Ablehnung externer Private-Funktionszugriffe, Public/Private-Sichtbarkeit fuer Modul-CONST und MACRO, Aufrufe mit Module.Function(...), Module.Const-Zugriff fuer oeffentliche Konstanten, Module.Macro(...)-Expansion fuer oeffentliche Makros, #INCLUDE AS MODULE, #INCLUDE AS MODULE ONCE und #INCLUDE THIS ONCE. MODULE innerhalb eines ausfuehrbaren Funktionsrumpfs, verschachtelte oberste MODULE-Bloecke, MODULE ohne Namen und nicht passende END MODULE-Zeilen werden mit Diagnosen abgelehnt.

Offenes Paritaetsziel: vollstaendiges Delphi-Unit-artiges Verhalten ist noch nicht fertig. Offen sind ausdrueckliche INTERFACE/IMPLEMENTATION-Abschnitte, USES-Importe, separates Laden von Moduldateien, Initialisierungs-/Finalisierungsabschnitte, doppelte und zyklische Moduldiagnosen und breitere Sichtbarkeit fuer Modul-Daten/Typen/Equates/Makros.

Syntax

MODULE module_name
  [PUBLIC | PRIVATE] FUNCTION name(...)
  ...
END MODULE

Modul-Quelltext kann auch aus einer Include-Datei umschlossen werden:

#INCLUDE AS MODULE "file.pbi" [AS "ModuleName"]
#INCLUDE AS MODULE ONCE "file.pbi" [AS "ModuleName"]

Hinweise

MODULE gruppiert Deklarationen auf oberster Ebene in einem benannten Namespace. PBXB64 benennt Modulsymbole intern um und erlaubt qualifizierte Aufrufe wie Math.Add(2, 3).

Die getestete V14-Teilmenge unterstuetzt oberste Modulbloecke, oeffentliche Funktions-Exporte, implizite Suche im selben Modul, private Funktionsaufrufe im selben Modul, private CONST-Nutzung im selben Modul, private Makro-Expansion im selben Modul, qualifizierte oeffentliche Aufrufe mit Module.Function(...), qualifizierten Zugriff auf oeffentliche Module.Const-Konstanten, qualifizierte oeffentliche Module.Macro(...)-Expansion, #INCLUDE AS MODULE, #INCLUDE AS MODULE ONCE und #INCLUDE THIS ONCE. Externe qualifizierte Aufrufe privater Modulfunktionen, privater Modul-Konstanten und privater Modul-Makros werden abgelehnt. MODULE und END MODULE innerhalb ausfuehrbarer Funktionsruempfe werden abgelehnt. Ein zweites MODULE, bevor das aktuelle geschlossen wurde, ein fehlender Modulname oder END MODULE ohne aktives Modul werden ebenfalls abgelehnt.

INTERFACE und IMPLEMENTATION werden vom Scanner erkannt, aber vollstaendige Delphi-Unit-artige Semantik ist noch nicht abgeschlossen. Behandeln Sie diese Formen als offenen Modul-Abschluss, bis die Feature-Matrix die passenden fokussierten Tests als fertig ausweist.

Aktuelle Grenzen

Die aktuelle getestete Teilmenge ist keine vollstaendige Delphi-Unit-Paritaet. Offen sind USES-Importe, Regeln fuer separate Unit-Dateien, Initialisierungs-/Finalisierungsabschnitte, doppelte und zyklische Moduldiagnosen sowie breitere Public/Private-Pruefung fuer Moduldaten, Equates, Makros und Typen.

Beispiel

MODULE Math
  PUBLIC FUNCTION Add(a AS LONG, b AS LONG) AS LONG
    FUNCTION = a + b
  END FUNCTION
END MODULE

FUNCTION PBMAIN() AS LONG
  FUNCTION = Math.Add(20, 22)
END FUNCTION

Pruefung

Abgedeckt durch examples/basic/test_module_namespace.pb, examples/basic/test_module_body_unsupported.pb, tests/pb/test_module_nested_unsupported.pb, tests/pb/test_module_missing_name.pb, tests/pb/test_module_end_without_module.pb, tests/pb/test_module_private_function.pb, tests/pb/test_module_private_function_reject.pb, tests/pb/test_module_const_visibility.pb, tests/pb/test_module_private_const_reject.pb, tests/pb/test_module_macro_visibility.pb, tests/pb/test_module_private_macro_reject.pb, tests/pb/test_include_as_module.pb, tests/pb/test_pp_include_as_module_once.pb und tests/pb/test_pp_include_this_once.pb.

Siehe auch

  • #INCLUDE
  • FUNCTION
  • SUB

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für MODUL soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' MODUL mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


MONTHNAME$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › MONTHNAME$

MONTHNAME$

Konvertiert eine Monatszahl in den zugehörigen Namen.

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = MONTHNAME$( MonthNumber& )

Beschreibung

Die Funktion MONTHNAME$ wandelt eine Monatszahl in eine Zeichenfolge um, die den zugehörigen Namen darstellt. Das Argument muss im Bereich von 1 bis 12 liegen und die Namen Januar, Februar usw. darstellen.

Siehe auch

  • DATUM$
  • TAGNAME$
  • POWERTIME

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Mehr im Menü - PBXB64 Compiler-Hilfe

Startseite › Funktionen › Mehr im Menü

Mehr auf der Speisekarte

Beim Hinzufügen neuer Menüelemente zu einem Menü können zusätzliche Parameter in den folgenden Anweisungen enthalten sein:

Typ:Schlüsselwort |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

MENU ADD POPUP, hMenu , txt$ , hPopup , state& [, AT [BYCMD] position& ]

MENU ADD STRING, hMenu, txt$, hPopup, state& [, AT [BYCMD] position& ] [, CALL callback ]

Ein optionaler Positionsparameter, der es dem Programmierer ermöglicht, eine absolute Position des Menüelements im Popup-Menü anzugeben, der unmittelbar vor dem Wert von position& eingefügt wird. Das Weglassen dieses Parameters führt dazu, dass der Menüpunkt an der „aktuellen Position“ an das Menü angehängt wird. Positionswerte werden auf 1 indiziert. Beispiel:

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Mehr auf der Speisekarte soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Mehr auf der Speisekarte mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


MOUSEPTR – PBXB64-Compiler-Hilfe

Startseite › Funktionen › MOUSEPTR

MOUSEPTR

Ändern Sie den Mauszeiger (Cursor) in eine neue Form.

Typ:Anweisung |Kategorie: Utilities

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MOUSEPTR style [TO var& ]

Beschreibung

MOUSEPTR gehoert zur Kategorie General. Diese Seite beschreibt den PBXB64-Dokumentationsstand fuer diesen Eintrag; verwenden Sie die Grenzen und Belege auf dieser Seite statt historischer PBWin-Annahmen.

Praktische Verwendung

MOUSEPTR gehoert zur Kategorie General. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' MOUSEPTR mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Siehe auch

  • Befehlsindex
  • BASIC-Frontend


MSGBOX “ PBXB64-Compiler-Hilfe

Startseite â€º Funktionen â€º MSGBOX

MSGBOX

Zeigt ein Meldungsfeld an, das eine Textzeichenfolge enthält

Typ:Anweisung |Kategorie: Utilities

PBXB64-Status:VERFÃœGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MSGBOX txt$ [, [ style% ], title$ ]
?     txt$ [, [ style% ], title$ ]   ' ALIAS for MSGBOX

Beschreibung

Die MSGBOX-Anweisung umfasst die folgenden Elemente:

txt$

Text, der im Meldungsfeld angezeigt werden soll.

Stil&

Optionaler Parameter, der das Erscheinungsbild des Meldungsfelds bestimmt. Einige Stile können kombiniert (durch ODER verknüpft) werden, um die Schaltfläche und das Symbol festzulegen, die im Meldungsfeld angezeigt werden. Wenn style& weggelassen wird, ersetzt PowerBASIC %MB_OK. Im Folgenden sind einige der gebräuchlichsten Stile aufgeführt, die mit der MSGBOX-Anweisung verwendet werden (weitere Informationen finden Sie auch in der MSGBOX-Funktion):

%MB_OK

OK-Schaltfläche anzeigen (Standard)

%MB_ICONERROR

Fehlersymbol anzeigen (Stoppschild)

%MB_ICONINFORMATION

Informationssymbol (â€žiâ€œ) anzeigen

%MB_ICONWARNING

Warnsymbol (Ausrufezeichen) anzeigen

%MB_APPLMODAL

Anwendungsmodal “ Trotz des Namens kann der Benutzer weiterhin mit anderen Dialogen interagieren, ohne die MSGBOX zu schlieÃŸen.

%MB_SYSTEMMODAL

Systemmodal “ Funktioniert genauso wie %MB_APPLMODAL, auÃŸer dass die MSGBOX den Stil %WS_EX_TOPMOST erhält, sodass sie über allen anderen Fenstern und Dialogen bleibt.

%MB_TASKMODAL

Task Modal “ Alle Fenster der obersten Ebene, die zur aktuellen Anwendung gehören, werden deaktiviert, bis die MSGBOX geschlossen wird. %MB_TASKMODAL wird häufig verwendet, um eine wirklich modale MSGBOX anzuzeigen. (Standard)

Weitere Stile finden Sie in WIN32API.INC im Abschnitt mit dem Präfix %MB_. Wenn Sie daran interessiert sind, welche Schaltfläche der Benutzer auswählt, verwenden Sie eine MSGBOX-Funktion anstelle einer MSGBOX-Anweisung.

Titel$

Legt den Titel fest, der in der Ãœberschrift des Meldungsfelds angezeigt werden soll. Wenn title$ nicht angegeben ist, wird automatisch â€žPowerBASICâ€œ verwendet.

Alias: Die MSGBOX-Anweisung kann als Abkürzung durch das Abfragezeichen (?) dargestellt werden. Dies ähnelt dem Verhalten im PowerBASIC Console Compiler (PB/CC), wo das Abfragezeichen als Synonym für die PRINT-Anweisung erkannt wird. Dies kann die Erstellung bestimmter Testcodes vereinfachen, da das Abfragezeichen in beiden Compilern ähnliche Funktionen bereitstellt.

Einschränkungen

Von der MSGBOX-Funktion angezeigte Zeichenfolgen werden nur bis zum ersten $NUL-Zeichen (falls vorhanden) angezeigt.

Siehe auch

  • EINGABEBOX$
  • MSGBOX-Funktion
  • TBOX-Anweisung
  • TXT-Pseudoobjekt

Kind: Reference topic | Category: Dialog / Message Box

PBXB64 Status: AVAILABLE

Description

MSGBOX shows a modal message box and returns the button or command result. The page should be read as a dialog contract: caption, text, button style, and response code.

Syntax

result& = MSGBOX(text$, style&, title$)

Validation Evidence

Validation evidence: The message-box helpers are covered by the dialog runtime and the registered GUI tests that exercise modal UI return codes.

Example

result& = MSGBOX("Continue?", %MB_YESNO, "PBXB64")

See Also

  • cmd_dialog_new.html
  • cmd_inputbox.html
  • cmd_messages.html

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Mehrdimensionale Arrays – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Mehrdimensionale Arrays

Mehrdimensionale Arrays

Arrays können eine oder mehrere Dimensionen haben, maximal acht. Ein eindimensionales Array wie Zahlungen ist eine einfache Liste von Werten. Ein zweidimensionales Array stellt eine Zahlentabelle mit den Zeilen a dar

Typ:Schlüsselwort |Kategorie:Variablen und Umfang

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

DIM one!(15) ' eine eindimensionale Liste

DIM two!(15,20) ' eine zweidimensionale Tabelle

DIM three!(7,9,1) ' ein 8 x 10 großes Spielbrett mit Platz im dritten

' Dimension für 2 Artikel: Stücktyp und Farbe

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


MYBASE-Pseudovariable – PBXB64-Compiler-Hilfe

Startseite › Funktionen › MYBASE-Pseudovariable

MYBASE-Pseudovariable

Ein Pseudo

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status: NICHT UMGESETZT

PBXB64-Zertifizierung: [NICHT UNTERSTÜTZTE DIAGNOSE GETESTET]

Syntax

MYBASE. Method1 ( param )

Beschreibung

PBXB64-Hinweis: Die vererbungsorientierte MYBASE-Bindung ist noch nicht implementiert. Aktuelle Builds diagnostizieren MYBASE, anstatt stillschweigend falschen Basisobjektcode auszugeben.

MYBASE ist eine Pseudovariable, die PowerBASIC automatisch in jeder Methode und Eigenschaft einer geerbten Schnittstelle definiert. Es wird als Verweis auf das ursprüngliche, geerbte Objekt behandelt. Mit MYBASE ist es möglich, die ursprünglichen Methoden und Eigenschaften aufzurufen, sodass Sie sie in der abgeleiteten Schnittstelle ändern oder darauf aufbauen können.

MYBASE darf weder einer Objektvariablen zugewiesen noch als Unter-/Funktions-/Methoden-/Eigenschaftsparameter verwendet werden.

Siehe auch

  • CLASS
  • INTERFACE (Direct)
  • INTERFACE (IDBind)
  • ICH
  • METHOD
  • PROPERTY
  • Was ist überhaupt ein Objekt?
  • Was ist Vererbung?

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


NAME – PBXB64-Compiler-Hilfe

Startseite › Funktionen › NAME

NAME

Benennen Sie eine Datei oder ein Verzeichnis um (wie der DOS-Befehl REN).

Typ:Anweisung |Kategorie: Dateiverwaltung

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

NAME filespec1$ AS filespec2$

Beschreibung

Die NAME-Anweisung besteht aus folgenden Elementen:

Dateispezifikation1$

Der aktuelle Name einer Datei oder eines Verzeichnisses. Die Datei darf derzeit weder geöffnet noch gesperrt sein. filespec1$ kann entweder ein kurzer Dateiname (SFN) oder ein langer Dateiname (LFN) sein.

Dateispezifikation2$

Der gewünschte Name der Datei oder des Verzeichnisses. Möglicherweise werden LFN-Namenskonventionen (Long File Name) verwendet.

Jede Dateispezifikation kann Laufwerks- und Pfadangaben sowie einen Datei- oder Verzeichnisnamen enthalten.

Wenn filespec1 nicht vorhanden ist, tritt Laufzeitfehler 53 („Datei nicht gefunden“) auf. Wenn filespec2 bereits vorhanden ist, tritt Laufzeitfehler 58 auf („Datei existiert bereits“). Wenn filespec1 von Ihrer Anwendung geöffnet oder gesperrt und nicht geschlossen wurde, kann ein Fehler 51 auftreten („Interner Systemfehler“). Sie sollten niemals eine Datei umbenennen, die von Ihrem Code geöffnet und (noch) nicht geschlossen wurde.

Einschränkungen

Es ist möglich, eine Datei von einem Verzeichnis, Laufwerk oder einer Partition in ein anderes zu verschieben. Es ist nicht möglich, Verzeichnisse zwischen Laufwerken oder Partitionen zu verschieben. Platzhalterzeichen sind in den Dateinamen nicht zulässig.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Benutzerdefinierte Typen verschachteln – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › Verschachtelung benutzerdefinierter Typen
Hilfe zum PBXB64-Compiler

Verschachtelung benutzerdefinierter Typen

Die Felder innerhalb eines benutzerdefinierten Typs können aus anderen benutzerdefinierten Typen bestehen. Genau wie bei einer Reihe chinesischer Kästchen, wobei jedes Kästchen ein kleineres Kästchen enthält, können Sie einen benutzerdefinierten Typ innerhalb eines verschachteln

Typ:Schlüsselwort |Kategorie:Typen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Anstatt die Namen der Schüler als zwei separate Felder zu speichern, könnten wir stattdessen einen Typ namens NameRec wie folgt definieren:

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


WEITER – PBXB64-Compiler-Hilfe

Startseite › Funktionen › WEITER

WEITER

Schließen Sie eine FOR-Schleife

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

NEXT [counter [, counter ...]]

Beschreibung

DerNEXT Die Anweisung markiert das Ende von a FOR Schleifenkörper. Es erhöht den Schleifenzähler um STEP Wert (oder 1) und springt zurück zum Top-of-Loop-Bedingungstest.

Das optionale counter Der Name ist in PBXB64 nicht erforderlich, wird jedoch aus Kompatibilitätsgründen mit der PowerBASIC-Syntax akzeptiert. Verschachtelte Schleifen können mehrere Zähler auflisten.

Beispiel

FUNCTION PBMAIN () AS LONG
    LOCAL i AS LONG
    FOR i = 1 TO 3
        PRINT i
    NEXT i
END FUNCTION

Generierter Assembler-Code

DerNEXT Schlüsselwort ist keine separate Anweisung im Backend; Es wird zum Step-and-Branch-Block am Ende der Schleife:

pb_for_step_PBMAIN_0:
    mov r10, [rbp-24]
    mov rbx, r10
    add rbx, 1
    mov [rbp-24], rbx
    jmp pb_for_cond_PBMAIN_0

Siehe auch

  • FOR
  • EXIT FOR
  • ITERATE FOR
  • Kontrollflussreferenz

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


NUL$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › NUL$

NUL$

Gibt eine Zeichenfolge zurück

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

sResult$ = NUL$( count )

Beschreibung

NUL$ gibt eine Zählzeichenfolge mit $NUL-Zeichen zurück.

Siehe auch

  • CHR$
  • REPEAT$
  • SPACE$
  • STRING$

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Datentypen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Datentypen

Datentypen

Die Pflege von Zahlen ist ein wichtiger Bestandteil jedes Programmiersystems. Glücklicherweise können Sie mit PowerBASIC die meisten technischen Überlegungen zur internen Nummernverwaltung ignorieren. Wenn Sie nie g

Typ:Schlüsselwort |Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Aus Effizienzgründen speichert und verarbeitet PowerBASIC Daten in verschiedenen Formen. Es unterstützt elf einzigartige numerische Typen, drei String-Typen und auch Zeiger. Die folgenden Tabellen fassen die wichtigsten Merkmale und Unterscheidungen dieser Datentypen zusammen. Im Rest dieses Abschnitts werden diese Funktionen ausführlich erläutert.

Anforderungen und Bereiche für die Speicherung numerischer Daten

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Numerische Gleichungen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Numerische Gleichungen

Numerische Gleichungen

Mit PowerBASIC können Sie numerische Konstanten namentlich referenzieren. Beachten Sie, dass Equates einen globalen Geltungsbereich haben. das heißt, sie sind im gesamten Programm sichtbar. Im Gegensatz zu Variablen können Sie für th ein Equate verwenden

Typ:Schlüsselwort |Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

%Q = (1& ODER 2&) + (NICHT 0)

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Numerische Operationen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Numerische Operationen

Numerische Operationen

Die folgenden Funktionen manipulieren und verwalten numerische Daten:

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Gibt den absoluten Wert eines numerischen Ausdrucks zurück

AND funktioniert sowohl als logischer als auch als bitweiser arithmetischer Operator

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_arith_plus_0_0
FUNCTION PBMAIN() AS LONG
  IF (0 + 0) <> (0) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_arith_plus_0_1
FUNCTION PBMAIN() AS LONG
  IF (0 + 1) <> (1) THEN FUNCTION = 2: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_arith_plus_0_2
FUNCTION PBMAIN() AS LONG
  IF (0 + 2) <> (2) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_arith_plus_0_5
FUNCTION PBMAIN() AS LONG
  IF (0 + 5) <> (5) THEN FUNCTION = 4: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_arith_plus_0_10
FUNCTION PBMAIN() AS LONG
  IF (0 + 10) <> (10) THEN FUNCTION = 5: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_arith_plus_0_-1
FUNCTION PBMAIN() AS LONG
  IF (0 + -1) <> (-1) THEN FUNCTION = 6: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_arith_plus_0_-5
FUNCTION PBMAIN() AS LONG
  IF (0 + -5) <> (-5) THEN FUNCTION = 7: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_arith_plus_0_100
FUNCTION PBMAIN() AS LONG
  IF (0 + 100) <> (100) THEN FUNCTION = 8: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_arith_plus_0_-100
FUNCTION PBMAIN() AS LONG
  IF (0 + -100) <> (-100) THEN FUNCTION = 9: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_arith_plus_1_0
FUNCTION PBMAIN() AS LONG
  IF (1 + 0) <> (1) THEN FUNCTION = 10: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Numerische Operationen soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Numerische Operationen mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


ZIEL – PBXB64-Compiler-Hilfe

Startseite › Funktionen › ZIEL

OBJACTIVE

Zurückkehren

Typ:Funktion |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

lResult& = OBJACTIVE( prgid$ )

Beschreibung

Rückgabewert: TRUE/FALSE als Hinweis auf den Betriebszustand eines initialisierten COM-Objekts (EXE-basiert). Syntax lResult& = OBJACTIVE( prgid$ )

OBJACTIVE kann Informationen liefern, die sich als hilfreich bei der Entscheidung erweisen können, ob die Optionen NEWCOM oder GETCOM mit der LET-Anweisung (mit Objekten) verwendet werden sollen. OBJACTIVE darf nur für COM-Objekte verwendet werden, die im EXE-Format vorliegen, nicht für DLL/OCX/usw. Im letzteren Fall gibt OBJACTIVE FALSE (0) zurück.

prgid$

Die registrierte Programm-ID-Zeichenfolge für das COM-Objekt. Zum Beispiel „Word.Application.8“ oder eine versionunabhängige Programm-ID wie „Word.Application“. Eine gültige Programm-ID-Zeichenfolge kann mit der Funktion PROGID$ aus einer 16-Byte-Klassen-ID-Zeichenfolge abgerufen oder mit PROGID$ und GUID$ aus einer 38-stelligen GUID-Zeichenfolge abgeleitet werden.

Siehe auch

  • DIM
  • CLSID$
  • GUID$
  • GUIDTXT$
  • INTERFACE (Direct)
  • INTERFACE (IDBind)
  • ISNOTHING
  • ISOBJECT
  • Just what is COM?
  • LET (with Objects)
  • OBJECT
  • ZIELGLEICHE
  • OBJPTR
  • OBJRESULT
  • PROGID$
  • Was ist eine COM-Komponente?

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


OBJEKT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › OBJEKT

OBJECT

Kommunizieren Sie mit COM-Objektreferenzen und Dispatch-Mitgliedern.

Typ:Anweisung |Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

OBJECT GET interface . member [. member .] [([[ paramname =] param1 [, ...]])] TO ResultVar
OBJECT LET interface . member [. member .] [([[ paramname =] param1 [, ...]])] = ValueVar
OBJECT SET interface . member [. member .] [([[ paramname =] param1 [, ...]])] = ValueVar
OBJECT CALL interface . member [. member .] [([[ paramname =] param1 [, ...]])] [TO ResultVar ]
OBJECT RAISEEVENT [ interface .] member [([[ paramname =] param1 [, ...]])]

Beschreibung

Es gibt fünf allgemeine Formen der OBJECT-Anweisung, die zur Kommunikation über eine Dispatch-Schnittstelle mit einem Objekt verwendet werden.

OBJEKT ERHALTEN

Rufen Sie den Wert einer Interface-Member-Property ab oder lesen Sie ihn. Dies ähnelt dem Abrufen des Werts einer Variablen.

OBJEKTVERMIETUNG

Weisen Sie einer Schnittstellenmitgliedseigenschaft einen Wert zu oder schreiben Sie einen Wert. Dies ähnelt dem Zuweisen eines Werts zu einer Variablen.

OBJEKTSATZ

Weisen Sie einer Interface-Member-Eigenschaft einen Wert zu oder schreiben Sie einen Wert, der einen Verweis auf ein Objekt enthält. Zum Beispiel ein Verweis auf eine andere Schnittstelle.

OBJEKTAUFRUF

Rufen Sie eine Mitgliedsmethode einer Schnittstelle auf oder führen Sie sie aus. Dies entspricht dem Aufruf eines Sub oder Function .

OBJEKT-RAISEEVENT

Rufen Sie eine Mitgliedsmethode einer Dispatch-Ereignisschnittstelle auf oder führen Sie sie aus. Da die Dispatch-Ereignisschnittstelle vordefiniert ist, müssen Sie in dieser Form der Anweisung den Schnittstellennamen nicht angeben. Allerdings hilft die Einbindung bei der Selbstdokumentation Ihres Programms. Wenn Ihr Programm einen direkten V-Table-Ereignishandler verwendet, sollten Sie stattdessen die RAISEEVENT-Anweisung verwenden. Ein Beispiel für OBJECT RAISEEVENT finden Sie in der Anweisung EVENT SOURCE.

Alle Parameter, Rückgabewerte und Zuweisungswerte können Literale, Ausdrücke oder COM-kompatible Variablen sein. Zu den COM-kompatiblen Variablentypen gehören BYTE, WORD, DWORD, INTEGER, LONG, QUAD, SINGLE, DOUBLE, CURRENCY, POINTER, STRING und VARIANT. Zeichenfolgenargumente werden automatisch in BSTR konvertiert, sodass keine manuelle Unicode-Konvertierung erforderlich ist.

Dispatch OBJECT-Methodenaufrufe werden zur Laufzeit mithilfe einer späten Bindung gebunden, die keine Deklaration von Eigenschaften und Methoden erfordert. Aus genau diesem Grund kann die Gültigkeit dieser Referenzen jedoch von PBXB64 zur Kompilierungszeit nicht überprüft werden.

Die OBJECT-Anweisung unterstützt Positionsparameter. Benannte Parameter (Syntax Name := value) werden akzeptiert, werden aber derzeit als Positionsargumente in der Quellreihenfolge behandelt; In einer zukünftigen Version wird möglicherweise ein echter COM-Versand mit benannten Argumenten hinzugefügt.

Klammern um Argumentlisten sind für optional OBJECT CALL und kann weggelassen werden, genau wie im nativen PowerBASIC.

Jedes Mal, wenn Sie eine Methode oder Eigenschaft mit der OBJECT-Anweisung aufrufen, wird in einem versteckten Parameter ein Statuscode zurückgegeben, der den Erfolg oder Misserfolg des Vorgangs anzeigt. Sie können Informationen zu diesem Statuscode mit der Funktion OBJRESULT und auch mithilfe des Dispatch-Informationsobjekts IDISPINFO abrufen. Wenn der Fehler schwerwiegend war, wird außerdem ein PowerBASIC-Fehler 99 (Objektfehler) generiert und die Systemvariable ERR gesetzt. Weitere Informationen zu diesen Elementen finden Sie unter OBJRESULT, IDISPINFO und ERR. Diese Informationen können sowohl beim Debuggen als auch bei der Behandlung von Laufzeitfehlern sehr nützlich sein.

Einschränkungen

Alle Parameter, Rückgabewerte und Zuweisungswerte müssen in Form von COM-kompatiblen Variablen vorliegen. Die Verwendung des falschen Mitgliedsmodus (GET/LET/SET/CALL/RAISEEVENT) kann manchmal zu unerwarteten und schwerwiegenden Laufzeitfehlern führen. Daher ist es normalerweise ratsam, den Ergebniscode in OBJRESULT nach jeder OBJECT-Anweisung zu testen.

Getestete Datentyp-Oberflaeche

PBXB64 verifiziert derzeit die OBJECT-Variablenform als COM-Schnittstellenzeiger. Die fokussierte Regression in examples/basic/test_object.pb prueft den uninitialisierten Zustand, die Zuweisung von 0 und NOTHING, die Zuweisung eines Nicht-Null-Zeigerwerts sowie den Rueckgabepfad ueber ISOBJECT, ISNOTHING und OBJPTR.

Praktische Verwendung

Verwenden Sie OBJECT, wenn eine COM-aehnliche Referenz fehlen kann. Pruefen Sie vor dem Dereferenzieren auf Null und verwenden Sie OBJPTR nur dann, wenn Sie den Rohzeigerwert absichtlich fuer Interop oder Diagnose benoetigen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL o AS OBJECT
    LOCAL raw AS QUAD

    IF ISOBJECT(o) = 0 AND ISNOTHING(o) = 0 THEN
        raw = OBJPTR(o)
    END IF

    o = 0
    o = NOTHING

    IF ISNOTHING(o) = 0 THEN FUNCTION = 1
END FUNCTION

Parameter und Ergebnisse

Die verifizierte Oberflaeche behandelt OBJECT als COM-Referenz, die Null sein darf. Nutzen Sie die Pruefungen aus dem Beispiel, um einen nicht initialisierten Zustand, eine Nullzuweisung, eine freigegebene Referenz und einen Nicht-Null-Zeigerwert zu unterscheiden. Die Seite bleibt auf das Datentypverhalten beschraenkt; die breitere Dispatch-Syntax folgt weiterhin dem Referenzteil weiter unten.

Test- und Dokumentationshinweise

Das Beispiel ist bewusst klein und in sich abgeschlossen, damit es sich in eine kurze Quelldatei uebernehmen laesst. Es benoetigt nur die normale PBXB64-Laufzeit, das aktuelle Frontend und die fokussierte Objekt-Regression in examples/basic/test_object.pb.

Validierungsbeleg

Validierungsbeleg: die registrierte Regression examples/basic/test_object.pb und der Coverage-Eintrag in tests/validate.toml belegen die fokussierte OBJECT-Lebensdauer- und Zeigerwert-Oberflaeche. Halten Sie die Seite bis zu eigenen Tests fuer die breiteren Dispatch-Pfade ehrlich auf diese Grenze beschraenkt.

Aktuelle Grenze

Die auf der Seite gezeigte Dispatch-Anweisung bleibt Referenzmaterial fuer die breitere COM-Oberflaeche. Externe OLE-Automatisierung, benannte Argumente und Ereignisaufrufe benoetigen noch eigene Regressionen, bevor sie als vollstaendig geschlossen gelten sollten.

Einschränkungen

Die fokussierte OBJECT-Oberflaeche beschraenkt sich auf das getestete Null-/Zeigerverhalten. Breitere Dispatch-Szenarien, benoannte Argumente und Ereignisaufrufe bleiben bis zu eigenen Regressionen ausserhalb der verifizierten Oberflaeche.

Siehe auch

  • ACODE$
  • DIM
  • CLASS
  • CLSID$
  • EVENT SOURCE
  • IDISPINFO
  • GUID$
  • GUIDTXT$
  • ID-Bindung
  • INTERFACE (Direct)
  • INTERFACE (IDBind)
  • ISINTERFACE
  • ISNOTHING
  • ISOBJECT
  • Just what is COM?
  • Späte Bindung
  • LET (with Objects)
  • METHOD
  • OBJACTIVE
  • OBJPTR
  • OBJRESULT
  • PROGID$
  • PROPERTY
  • UCODE$
  • Was ist überhaupt ein Objekt?
  • Was ist VERSAND?


OBJEQUAL – PBXB64-Compiler-Hilfe

Startseite › Funktionen › OBJEQUAL

ZIELGLEICHE

Überprüfen Sie, ob

Typ:Funktion |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

Result = OBJEQUAL( ObjectVar1 , ObjectVar2 )

Beschreibung

Vergleicht zwei Objektvariablen, um festzustellen, ob sie auf dasselbe Objekt verweisen. Es gibt true (-1) zurück, wenn beide auf dasselbe Objekt verweisen (oder beide auf NICHTS verweisen); andernfalls wird false (0) zurückgegeben.

Wenn sich die beiden Objektvariablen auf dieselbe Klasse, aber nicht auf dasselbe spezifische Objekt beziehen, wird false (0) zurückgegeben.

Siehe auch

  • BITSE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


OBJPTR – PBXB64-Compiler-Hilfe

Startseite › Funktionen › OBJPTR

OBJPTR

Geben Sie eine zurück

Typ:Funktion |Kategorie: Memory & Pointers

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ObjectPointer??? = OBJPTR( objectvar )

Beschreibung

OBJPTR gibt den Objektzeiger als Doppelwortwert (DWORD) zurück.

Siehe auch

  • DIM
  • CLSID$
  • GUID$
  • GUIDTXT$
  • INTERFACE (Direct)
  • INTERFACE (IDBind)
  • ISINTERFACE
  • ISNOTHING
  • ISOBJECT
  • LET (with Objects)
  • OBJECT
  • OBJACTIVE
  • ZIELGLEICHE
  • OBJRESULT
  • PROGID$
  • Was ist überhaupt ein Objekt?

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


OBJRESULT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › OBJRESULT

OBJRESULT

Gibt einen Statuscode (hResult) zurück, um den Erfolg oder Misserfolg der letzten zu beschreiben

Typ:Funktion |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

lResult& = OBJRESULT

Beschreibung

Eine Automatisierungsprozedur ist eine METHOD oder EIGENSCHAFT auf einer IAUTOMATION-, IDISPATCH- oder DUAL-Schnittstelle. Per Definition gibt eine Automatisierungsprozedur immer einen versteckten Ergebniscode zurück, der kryptisch als hResult bezeichnet wird. OBJRESULT ist das zuletzt vom Programm generierte hResult und kann verwendet werden, um den Erfolg oder Misserfolg eines Vorgangs zu ermitteln.

Wenn eine Automatisierungsprozedur mit einem schwerwiegenden Fehler fehlschlägt, wird die Systemvariable ERR auf einen entsprechenden PowerBASIC-Fehlercode gesetzt. Dies ist normalerweise Fehler 99 („Objektfehler“). In solchen Fällen können Sie die Funktion OBJRESULT verwenden, um das Ergebnis (hResult&) der letzten OBJECT-Anweisung zur Laufzeit oder der direkten METHOD/PROPERTY-Referenz zurückzugeben.

Numerische Gleichungen für die meisten OBJRESULT-Fehler sind in der Datei WIN32API.INC zu finden und werden meist mit dem Präfix %E_, %CO_, %OLE_ und %DISP_ versehen. Die folgende Liste enthält die häufigsten Codes, die durch einen direkten Aufruf einer Methode oder Eigenschaft zurückgegeben werden können:

%S_OK = &H0

%S_FALSE = &H1

%E_UNEXPECTED = &H8000FFFF&

%E_NOTIMPL = &H80004001&

%E_NOINTERFACE = &H80004002&

%E_POINTER = &H80004003&

%E_ABORT = &H80004004&

%E_FAIL = &H80004005&

%E_ACCESSDENIED = &H80070005&

%E_HANDLE = &H80070006&

%E_OUTOFMEMORY = &H8007000E&

%E_INVALIDARG = &H80070057&

In dieser Liste sind die häufigsten Statuscodes aufgeführt, die von einem DISPATCH-Aufruf mit der OBJECT-Anweisung zurückgegeben werden können:

%S_OK = &H0

%DISP_E_ARRAYISLOCKED = &H8002000D

%DISP_E_BADINDEX: = &H8002000B

%DISP_E_BADPARAMCOUNT = &H8002000E

%DISP_E_BADVARTYPE = &H80020008

%DISP_E_EXCEPTION = &H80020009

%DISP_E_MEMBERNOTFOUND = &H80020003

%DISP_E_NONAMEDARGS = &H80020007

%DISP_E_OVERFLOW = &H8002000A

%DISP_E_PARAMNOTFOUND = &H80020004

%DISP_E_TYPEMISMATCH = &H80020005

%DISP_E_UNKNOWNINTERFACE = &H80020001

%DISP_E_UNKNOWNLCID = &H8002000C

%DISP_E_UNKNOWNNAME = &H80020006

%DISP_E_PARAMNOTOPTIONAL = &H8002000F

Wenn der Statuscode %DISP_E_EXCEPTION zurückgegeben wird, können Sie mit dem IDISPINFO-Objekt viele zusätzliche Informationen über den Status sichern. Dazu gehören ein spezifischerer Fehlercode, eine Beschreibung, Informationen zur Hilfedatei usw. Wenn der Statuscode %DISP_E_PARAMNOTFOUND oder %DISP_E_TYPEMISMATCH vorliegt, können Sie IDISPINFO.PARAM verwenden, um festzustellen, welcher Parameter das Problem tatsächlich verursacht hat. Weitere Einzelheiten finden Sie im Abschnitt IDISPINFO.

Wie aus den obigen Listen ersichtlich ist, kann ein großer numerischer Statuscode kryptisch sein. Sie können den OBJRESULT-Code jedoch mithilfe der Funktion OBJRESULT$ in eine beschreibende Nachricht übersetzen. Dies kann besonders während der Anwendungsentwicklung und beim Debuggen sehr hilfreich sein.

PBXB64-Prüfung

Die registrierte Regression tests/pb/test_objresult_string.pb prüft, dass OBJRESULT mit S_OK beginnt und nach ungültigen OBJACTIVE-, CLSID$- und PROGID$-Hilfsaufrufen einen Nicht-Null-HRESULT enthält. Derselbe Test prüft OBJRESULT$-Text für aktuelle und explizite HRESULT-Werte.

Diese fokussierte Zertifizierung behauptet keine vollständige PBWin-COM/OOP-Unterstützung für METHOD, PROPERTY, IDispatch, Ereignisse, Vererbung oder Typbibliotheken.

Einschränkungen

Methoden und Eigenschaften einer benutzerdefinierten Schnittstelle (eine direkte Schnittstelle, die auf IUnknown statt IDispatch basiert) unterstützen keine OLE-Automatisierung und geben kein OBJRESULT (hResult) zurück.

Siehe auch

  • DIM
  • CLASS
  • CLSID$
  • IDISPINFO
  • GUID$
  • GUIDTXT$
  • INTERFACE (Direct)
  • INTERFACE (IDBind)
  • ISINTERFACE
  • ISNOTHING
  • ISOBJECT
  • LET (with Objects)
  • METHOD
  • PROPERTY
  • OBJECT
  • OBJACTIVE
  • ZIELGLEICHE
  • OBJPTR
  • OBJRESULT$
  • PROGID$
  • Was ist ein hResult?
  • Was ist überhaupt ein Objekt?

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

BASIC-Themen sollen Syntax, unterstuetzte Formen, Laufzeitverhalten, Migrationshinweise und mindestens ein vollstaendiges PBXB64-Beispiel enthalten. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für OBJRESULT soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' OBJRESULT mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


OCT$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › OCT$

OCT$

Konvertieren Sie einen ganzzahligen Wert in eine Oktalzeichenfolge

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = OCT$( IntVal [, Digits , LeadSpaces , TrailSpaces ])

Beschreibung

IntVal ist ein ganzzahliger Ausdruck im Bereich einer 64-Bit-Quad-Ganzzahl (-9223372036854775808 bis +9223372036854775807). Jeder Bruchteil des Wertes wird gerundet. Die Ergebniszeichenfolge wird immer als Ganzzahl unter Verwendung aller signifikanten Ziffern in IntVal formatiert. Es wird niemals in wissenschaftlicher Notation ausgedrückt.

Wenn Digits 0 ist (oder nicht angegeben ist), werden dem numerischen Feld keine führenden Zeichen hinzugefügt. Wenn Digits eine positive Zahl größer als 0 ist, werden der Ergebniszeichenfolge führende Nullen vorangestellt, um die gewünschte Länge zu erreichen. Wenn Digits eine negative Zahl ist, werden führende Leerzeichen hinzugefügt, um die absolute Länge zu erreichen. Die Ziffern können im Bereich von -22 bis +22 liegen.

LeadSpaces specifies additional leading spaces to be prepended, regardless of the length of the numeric portion of the string.

TrailSpaces specifies additional trailing spaces to be appended to the end of the string.

Siehe auch

  • BIN$
  • DEC$
  • FORMAT$
  • HEX$
  • STR$
  • TRIM$
  • USING$
  • VAL

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ODE_RK4 “ PBXB64-Compiler-Hilfe

Startseite â€º Mathematik und Numerik â€º ODE_RK4

ODE_RK4

Skalarer ODE-Löser unter Verwendung der klassischen Runge-Kutta-Methode 4. Ordnung (RK4).

Typ: Eingebaute Funktion | Kategorie:Mathematik und Numerik

PBXB64-Status:VERFÃœGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

result = ODE_RK4(t0, y0, h, CODEPTR(deriv))

Parameter

Parameter | Typ | Beschreibung
t0 | DOUBLE | Anfangszeitwert.
y0 | DOUBLE | Anfangszustandswert bei t0.
h | DOUBLE | SchrittgröÃŸe (Zeitinkrement).
CODEPTR(deriv) | Funktionszeiger | Adresse eines PB FUNCTION das berechnet dy/dt.

Beschreibung

ODE_RK4 führt einen einzelnen RK4-Integrationsschritt für eine skalare gewöhnliche Differentialgleichung durch:

dy/dt = f(t, y)

Die Callback-Funktion deriv muss die Unterschrift haben:

FUNCTION deriv(t AS DOUBLE, y AS DOUBLE) AS DOUBLE
  deriv = ...  ' return dy/dt
END FUNCTION

VerwendenCODEPTR(deriv) um die Funktionsadresse an den Löser zu übergeben. Die Win64-Aufrufkonvention stellt sicher, dass PB FUNCTION Parameter und Rückgabewerte sind mit C-Funktionszeigern kompatibel.

Rückgabewert

Rückgaben DOUBLE — der Zustandswert bei t0 + h.

Beispiel

#COMPILE EXE
#DIM ALL
FUNCTION deriv(t AS DOUBLE, y AS DOUBLE) AS DOUBLE
  deriv = 0 - y   ' dy/dt = -y  (exponential decay)
END FUNCTION

FUNCTION PBMAIN() AS LONG
  LOCAL result AS DOUBLE
  result = ODE_RK4(0.0, 1.0, 0.1, CODEPTR(deriv))
  PRINT "ODE_RK4="; result
  PBMAIN = 0
END FUNCTION

Erwartete Ausgabe:

ODE_RK4=0.9048375

Hinweise

  • Die Rückruffunktion muss eine Top-Level-Funktion sein FUNCTION (kein SUBoderGOSUB).
  • Die Rückrufsignatur ist streng FUNCTION name(t AS DOUBLE, y AS DOUBLE) AS DOUBLE.
  • Zur Zeitbereichssimulation können mehrere RK4-Schritte in einer Schleife verkettet werden.

Siehe auch

  • 128. Dezember
  • RATIONAL
  • GRUNDLEGENDE mathematische Funktionen

Kind: Reference topic | Category: Math / Numeric Runtime

PBXB64 Status: DOCUMENTED

Description

ODE_RK4 belongs to the numerical helper surface. The help entry documents intended call shape and must not be read as broader numerical-library parity beyond tested helper behavior.

Syntax

result = ODE_RK4(...)

Validation Evidence

Validation evidence: Documented helper surface; add a focused PB validation program before claiming broader numerical parity.

Example

' Prepare derivative inputs, call ODE_RK4 with known values, and compare the numeric result.

See Also

  • cmd_dec128.html
  • cmd_rational.html
  • basic_ref_math.html

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


OemToChr$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › OemToChr$

OemToChr$

Übersetzt eine Bytefolge

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

a$ = OemToChr$( OemExpr$ )
a$$ = OemToChr$(GRAPHIC, OemExpr$ )

Beschreibung

OemExpr$ enthält eine Reihe von Byte-Zeichen (8 Bit) im OEM-Format. OemToChr$ übersetzt es je nach Kontext des Quellcodes entweder in ANSI-Multibyte-äquivalente Zeichen oder WIDE (16-Bit) Unicode-Zeichen. PowerBASIC wählt immer die richtige Form, ohne dass der Programmierer eingreifen muss. Die Steuercodes CHR$(0) bis CHR$(31) und CHR$(127) werden eindeutig behandelt, da sie normalerweise als nicht druckbare Zeichen betrachtet werden. Standardmäßig werden sie nur kopiert, ohne Übersetzung.

GRAFIK

Wenn die Option GRAPHIC enthalten ist, bedeutet dies, dass Sie Steuercodes in Codes konvertieren möchten, die die im ursprünglichen IBM OEM-Zeichensatz definierten Grafiksymbole anzeigen. Die meisten dieser Codes sind nur als breite Unicode-Zeichen verfügbar.

Siehe auch

  • ChrToOem$
  • ChrToUtf8$
  • Utf8ToChr$

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


ON - ON-ERROR-Behandlung einleiten — PBXB64 Help

Startseite › General Reference › ON - ON-ERROR-Behandlung einleiten — PBXB64 Help
Hilfe zum PBXB64-Compiler

ON - ON-ERROR-Behandlung einleiten

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

ON ERROR GOTO handler

Detailverhalten

Kontrollkeyword fuer ON-ERROR-Formen und verwandte Fehlerfluss-Anweisungen.

Praktische Verwendung

Verwenden Sie ON fuer kontrollierte Fehler- oder Sprungformen wie ON ERROR. Der genaue Zielteil folgt auf dieses Keyword und muss zur jeweiligen Syntaxform passen.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

ON ohne die passende Folgeform ist unvollstaendig und sollte nicht als fertig gelten. Pruefen Sie die konkrete Fehler- oder Sprungsyntax separat.

Verifiziertes Beispiel

Abgedeckt durch PB keyword compatibility (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ON GOSUB – PBXB64-Compiler-Hilfe

Startseite › Funktionen › ON GOSUB

AUF GOSUB

Rufen Sie je nach Wert eines numerischen Ausdrucks eine von mehreren Unterroutinen auf.

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ON n GOSUB { label | line_number } [, { label | line_number }] ...

Beschreibung

n ist ein numerischer Ausdruck im Bereich von 1 bis 255, und jede Beschriftung oder Zeilennummer identifiziert eine Anweisung, zu der verzweigt werden soll. Wenn diese Anweisung angetroffen wird, wird zum n-ten Label in der Liste verzweigt; Wenn beispielsweise n gleich 4 ist, erhält das vierte Label in der Liste die Kontrolle. Wenn n kleiner als eins oder größer als die Anzahl der Labels ist, findet keine Verzweigung statt und PowerBASIC setzt die Ausführung mit der Anweisung fort, die unmittelbar auf die ON GOSUB-Anweisung folgt.

Jede Unterroutine sollte mit RETURN enden, wodurch die Ausführung mit der Anweisung fortgesetzt wird, die unmittelbar auf die ON GOSUB-Anweisung folgt. ON GOSUB kann nur zu Labels oder Zeilennummern verzweigen, die denselben Gültigkeitsbereich wie die ON GOSUB-Anweisung haben.

Die SELECT- und IF-Blöcke führen ebenfalls Mehrfachverzweigungen durch und sind flexibler als ON GOSUB.

Beachten Sie, dass ON GOSUB (und ON GOTO) intern optimiert wurden, um eine höhere Laufzeitleistung zu erzielen, als dies mit früheren Versionen von PowerBASIC möglich war.

Siehe auch

  • GOSUB
  • FUNCTION/END FUNCTION
  • IF-Block
  • METHOD
  • AUF GOTO
  • PROPERTY
  • ZURÜCK
  • SELECT
  • SUB/END SUB

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ON GOTO – PBXB64-Compiler-Hilfe

Startseite › Funktionen › ON GOTO

AUF GOTO

Senden Sie den Programmfluss basierend auf dem Wert eines booleschen Werts an eines von mehreren möglichen Zielen

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ON n GOTO { label | line_number } [, { label | line_number }] ...

Beschreibung

n ist ein numerischer Ausdruck im Bereich von 1 bis 255, und label oder line_number identifiziert eine Anweisung im Programm, zu der verzweigt werden soll. Das n-te Label wird verzweigt; Wenn beispielsweise n gleich 4 ist, erhält das vierte Label in der Liste die Kontrolle. If n is less than one or greater than the number of labels in the list, program execution continues with the statement that immediately follows the ON GOTO statement.

ON GOTO verhält sich genau wie ON GOSUB , außer dass es ein GOTO statt eines GOSUB ausführt. Das bedeutet, dass sich das Programm nicht daran erinnert, woher die Verzweigung stammt. ON GOTO kann nur zu Beschriftungen oder Zeilennummern verzweigen, die denselben Gültigkeitsbereich wie die ON GOTO-Anweisung haben.

Die SELECT- und IF-Blöcke führen ebenfalls Mehrfachverzweigungen durch und sind flexibler als ON GOTO. Im GOTO-Eintrag finden Sie eine Diskussion darüber, wie Sie die Verwendung von GOTOs in Ihren Programmen vermeiden können.

Note that ON GOTO (and ON GOSUB) have been internally optimized to produce greater run-time performance than was possible with previous versions of PowerBASIC.

Siehe auch

  • GOTO
  • IF-Block
  • AUF GOSUB
  • SELECT

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Opcodes und Mnemoniken – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Opcodes und Mnemonics

Opcodes und Mnemonik

At the hardware level in an Intel or compatible processor, instructions are built directly into the CPU circuitry and these are represented by opcodes .

Typ:Schlüsselwort |Kategorie:Inline-Assembler

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

While assembly code can be written at the Byte level, it is a particularly complex method of writing code since it involves memorizing a very large number of opcodes. Darüber hinaus muss dieser Programmcode das numerische Datenformat (Little-Endian) von Intel verwenden. Bei Little-Endian werden numerische Multibyte-Werte in umgekehrter Reihenfolge zur üblichen menschlichen Darstellung gespeichert.

For example, to copy the 32-bit value &H56A700FE into the EAX register (MOV EAX, &H56A700FE), you must first find the opcode for the MOV EAX mnemonic (&HA1) followed by the data in reverse order (&HFE, &H00, &HA7, and &H56).

Im Hex-Format würde die gesamte Anweisung so aussehen:

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Opcodes und Mnemonik soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Opcodes und Mnemonik mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Öffnen eines Kommunikationsports – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Öffnen eines Kommunikationsports

Öffnen eines Kommunikationsports

Before we can actually open a communications port , we must first obtain a PowerBASIC file number so we may manage input and output to the communications port. Die beste Methode, eine Aktennummer zu erhalten

Typ:Anweisung |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Die allgemeine Methode zum Öffnen eines Kommunikationsports in einem PowerBASIC-Programm ist die Verwendung einer COMM OPEN-Anweisung. Die Syntax ähnelt einer einfachen Direktzugriffsdatei OPEN, wobei n die Nummer des Kommunikationsports ist

COMM OPEN „COMn“ AS #hComm

Beschreibung

Öffnen eines Kommunikationsports gehoert zur seriellen Kommunikationsfamilie. Die aktuelle PBXB64-Oberflaeche prueft das Oeffnen, Senden, Lesen, Zeilenlesen, Reset und Schliessen eines Kommunikationshandles; reale Hardware ist nur fuer den erfolgreichen Pfad noetig.

Syntax

COMM OPEN "COMn" AS #hComm [CHR = ANSI|WIDE]
COMM SET #hComm, ...
COMM PRINT #hComm, string$
COMM LINE #hComm, string$
COMM LINE INPUT #hComm, text$
COMM RESET #hComm, FLOW
COMM CLOSE #hComm

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL h AS LONG
    COMM OPEN "PBXB64_NO_SUCH_COMM_PORT" AS #h
    IF h <> 0 THEN
        COMM CLOSE #h
        FUNCTION = 1
    END IF
END FUNCTION

Validierungsbeleg

Validierungsbeleg: tests/pb/test_comm_print_line_input.pb, tests/pb/test_comm_reset.pb, examples/basic/test_comm_open_missing.pb, und examples/basic/test_comm_flow_missing.pb belegen den aktuellen Handle- und Fehlerpfad. Der Beispielpfad ist absichtlich portable und faellt geschlossen, wenn kein gueltiger Port verfuegbar ist.

Laufzeitvoraussetzungen

Serielle Beispiele brauchen ein echtes COM-Geraet oder einen dokumentierten Loopback/Testadapter. Wenn ein realer Port verfuegbar ist, muessen COMM SET-Parameter vor dem Datentransfer gesetzt und das Handle danach mit COMM CLOSE freigegeben werden.

Siehe auch

  • COMM OPEN
  • COMM PRINT
  • COMM RESET
  • COMM LINE
  • COMM RECV
  • COMM SEND
  • COMM SET
  • COMM TIMEOUT
  • COMM CLOSE


Öffnen einer Typbibliothek – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Öffnen einer Typbibliothek

Öffnen einer Typbibliothek

The PowerBASIC COM Browser supports opening both registered an unregistered Type Libraries . A registered type library can be opened from the Registered Type Library view or by clicking the Open butto

Typ:Anweisung |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Die Benutzeroberfläche des PowerBASIC COM-Browsers

Speichern des Quellcodes

Was ist überhaupt ein Objekt?

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


Betriebssystem – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Betriebssystem

Betriebssystem

The following functions manipulate file and operating system features:

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Ändern Sie das aktuelle (Standard-)Verzeichnis auf einem bestimmten Laufwerk.

Change the current default drive.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Operator-Priorität – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Bedienerpriorität

Vorrang des Operators

Beispielsweise ergibt der Ausdruck 3+6 / 3 5 und nicht 3. Die Division hat eine höhere Priorität als die Addition, daher wird die Divisionsoperation (6 / 3) zuerst ausgeführt. Auch wenn der Compiler keinen Betrug bekommt

Typ:Betreiber |Kategorie:Betreiber

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Um Vorgänge gleicher Priorität abzuwickeln, geht PowerBASIC von links nach rechts vor. Beispielsweise wird im Ausdruck 4 - 3 + 6 die Subtraktion (4 - 3) vor der Addition (3 + 6) durchgeführt, wodurch der Zwischenausdruck 1 + 6 entsteht.

Operationen in Klammern haben höchste Priorität und werden immer zuerst ausgewertet. In Klammern wird die Standardpriorität verwendet. Verwenden Sie Klammern wie Knoblauch: großzügig, aber nicht im Übermaß.

Another example of the effect of Order of Precedence on an expression follows:

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_precedence_0
FUNCTION PBMAIN() AS LONG
  IF (1 + 2 * 3) <> (7) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_precedence_1
FUNCTION PBMAIN() AS LONG
  IF ((1 + 2) * 3) <> (9) THEN FUNCTION = 2: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_precedence_2
FUNCTION PBMAIN() AS LONG
  IF (10 - 4 / 2) <> (8) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_precedence_3
FUNCTION PBMAIN() AS LONG
  IF (2 * 3 + 4 * 5) <> (26) THEN FUNCTION = 4: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_precedence_4
FUNCTION PBMAIN() AS LONG
  IF (20 / 4 + 2) <> (7) THEN FUNCTION = 5: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_precedence_5
FUNCTION PBMAIN() AS LONG
  IF (20 / (4 + 1)) <> (4) THEN FUNCTION = 6: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_precedence_6
FUNCTION PBMAIN() AS LONG
  IF (-5 + 3) <> (-2) THEN FUNCTION = 7: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_precedence_7
FUNCTION PBMAIN() AS LONG
  IF (-(5 + 3)) <> (-8) THEN FUNCTION = 8: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_precedence_8
FUNCTION PBMAIN() AS LONG
  IF (10 - 3 - 2) <> (5) THEN FUNCTION = 9: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_precedence_9
FUNCTION PBMAIN() AS LONG
  IF (100 / 10 / 2) <> (5) THEN FUNCTION = 10: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


#OPTIMIZE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › #OPTIMIZE

#OPTIMIEREN

Wählen Sie die Optimierung aus, die auf Ihr Programm angewendet werden soll.

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

#OPTIMIZE CODE [ON | OFF]
#OPTIMIZE {SIZE | SPEED}

Beschreibung

The #OPTIMIZE metastatement is used to tell the compiler your preferences in regards to the optimization of generated code. Sie können die Optimierung entweder für die Ausführungsgeschwindigkeit oder für eine kleinere Codegröße festlegen.

Die erste Form der Direktive (CODE) teilt dem Compiler mit, ob nicht referenzierter Code aus dem kompilierten Programm entfernt werden soll, um die Größe der ausführbaren Datei zu minimieren. This option defaults to ON as there are few reasons to disable it (other than curiosity as to the effectiveness). Unabhängig vom kompilierten Modultyp (SLL, DLL oder EXE) entfernt PowerBASIC alles Unnötige:

Function

FastProc

Methode

Eigentum

String-Literal

Numerisches Literal

Statische Linkbibliothek

Extraction is always performed on a procedure basis, not an entire class. If you have a CLASS with 50 Methods, but only one is ever called, the other 49 are removed entirely. Dieser Grad an Granularität ist besonders wichtig bei Ihrer persönlichen Codebibliothek mit Allzweckfunktionen. You can include them all, and PowerBASIC will use just the minimum necessary. Wenn Sie eine Protokolldatei generieren (mit der Befehlszeilenoption /L), wird eine Liste der extrahierten Prozeduren, Klassen und SLL-Module bereitgestellt.

Die zweite Form der Direktive (SIZE/SPEED) teilt dem Compiler mit, ob Sie eine zusätzliche Optimierung für die Ausführungsgeschwindigkeit oder eine geringere Gesamtcodegröße wünschen. Wenn nicht verwendet, wird standardmäßig eine schnellere Codegeschwindigkeit gewählt.

Wenn Sie die Option SPEED wählen, besteht eine der Hauptaktionen des Compilers darin, stark genutzte Codeabschnitte an einer Adressgrenze auszurichten, die für die CPU/FPU am vorteilhaftesten ist.

In some cases, the speed of loop mechanisms ( FOR/NEXT , DO/UNTIL ...) can be improved by as much as 100%, and occasionally even more.

Einschränkungen

#GRÖSSE OPTIMIEREN | SPEED kann nur einmal ausgeführt werden und muss vor dem gesamten ausführbaren Code stehen. If #OPTIMIZE is omitted, the default condition is #OPTIMIZE SPEED.

Siehe auch

  • #AUSRICHTEN
  • ASM AUSRICHTEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


OPTION EXPLICIT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › OPTION EXPLICIT

OPTION EXPLIZIT

Erzwingen Sie die explizite Deklaration aller

Typ:Anweisung |Kategorie:Variablen und Umfang

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

OPTION EXPLICIT

Beschreibung

Die Verwendung von OPTION EXPLICIT in einem Programm hat die gleiche Wirkung wie die Verwendung der Metaanweisung #DIM ALL. Das heißt, es erfordert, dass alle Variablen deklariert werden, bevor sie verwendet werden.

Wenn diese Option verwendet wird, generiert der Compiler einen Kompilierungsfehler, wenn eine Variable oder ein Array verwendet wird, ohne explizit deklariert zu werden.

Siehe auch

  • #DIM

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Optionsdialog – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Optionsdialog

Optionsdialog

In diesem Thema werden die verfügbaren Optionen zum Anpassen der Ausgabe des vom PowerBASIC COM-Browser generierten Quellcodes beschrieben.

Typ:Schlüsselwort |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Verwenden Sie immer ein Schnittstellenpräfix

Diese Option stellt allen Schnittstellennamen den im Textfeld „Schnittstellenpräfix“ angegebenen Text voran. Dies ist nützlich, wenn in einem Projekt mehrere Typbibliotheken verwendet werden und es zu Konflikten mit doppelten Schnittstellennamen kommt.

Nur wenn die Schnittstelle einen unzulässigen Namen enthält

Mit dieser Option werden Schnittstellennamen nur dann vorangestellt, wenn sie unzulässige Zeichen enthalten oder mit einem reservierten Schlüsselwort in Konflikt stehen.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


#PAGE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › #PAGE

#SEITE

Legt eine Seitengrenze für PowerBASIC fest

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

#PAGE

Erklärungsformular

PAGE page_number

PBXB64-Status:VERFÜGBAR

Das Laufzeitanweisungsformular zeichnet die angeforderte Seitenzahl auf und gibt einen Konsolen-Formfeed/Seitenumbruch aus. Es ist abgedeckt durch test_screen_page.pb.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht
← ODER Nach oben Als Referenz oder Kopie übergebene Parameter →

Hinweise zur Seitenformatierung

#PAGE aendert nur die erzeugte Listenausgabe. Verwenden Sie es, wenn der Quelltext an einer definierten Stelle umgebrochen werden soll, aber halten Sie die separate Laufzeit-Anweisung PAGE auf einer eigenen Seite fest, damit Leser Quelltextformatierung und Ausfuehrungsverhalten nicht verwechseln.

Nutzungsregeln

Das Beispiel sollte zeigen, an welcher Stelle der Umbruch gehoert, welchen Teil des Quelltexts er trennt und warum die Direktive eingesetzt wird. Die Seite bleibt klarer, wenn sie die genau dokumentierte Form nennt, die absichtlich nicht abgedeckte Wirkung beschreibt und auf die Nachbarseiten zur Laufzeit-Anweisung verweist.

Beispiel

' PBXB64 Test: #PAGE
#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    #PAGE
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validierungsbeleg: der aktuelle Coverage-Eintrag für cmd_page.html und die Seitenformatierungs-Hilfe halten die Direktive an dokumentationsgebundene Funktionalität gekoppelt.

Siehe auch

  • PBMAIN
  • BASIC-Frontend


Per Referenz oder Kopie übergebene Parameter – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Parameter, die per Referenz oder Kopie übergeben werden
Hilfe zum PBXB64-Compiler

Als Referenz oder Kopie übergebene Parameter

Wenn ein Parameter per Referenz übergeben wird (die Standardmethode), übergibt PowerBASIC einen 32-Bit-Zeiger auf den Stapel. Dieser Zeiger ist der tatsächliche 32-Bit-Offset oder Speicherort der zu verwendenden Variablen

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

SUB MyProc(xyz&) ' Dies wird die erhöhen

' Parametervariable um eins

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Übergeben von Arrays – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Arrays übergeben

Übergeben von Arrays

Jedem Array in Ihrem Programm ist ein Array-Deskriptor zugeordnet. Dieser Deskriptor wird in einem proprietären Format gespeichert, das sich von Version zu Version von PowerBASIC ändern kann. Da die meisten Informationen

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Zusätzlich zu den Funktionen LBOUND und UBOUND kann die Funktion ARRAYATTR verwendet werden, um Array-Attribute und Informationen zu einem bestimmten Array abzurufen.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


Übergabe dynamischer Zeichenfolgen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Übergabe dynamischer Strings

Übergeben dynamischer Zeichenfolgen

Eine dynamische String-Variable wird als 32-Bit-Datenelement definiert, das einen Zeiger (oder Offset) auf die String-Zeichen enthält. Bei der Übergabe durch value ist der Parameter tatsächlich ein 32-Bit-Offset der Daten.

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

! MOV EBX, abc$ ; EBX ist ein Zeiger auf das String-Handle

! MOV EBX, [EBX] ; EBX ist jetzt ein Zeiger auf String-Daten

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


Übergabe von Parametern – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Übergabe von Parametern

Übergabe von Parametern

PowerBASIC 32-Bit-Compiler übergeben alle Parameter an Prozeduren, indem sie sie der Reihe nach von rechts nach links verschieben. Dies ist immer dann der Fall, wenn eine Prozedur die Standardaufrufkonventionen von SDECL (an

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Standardmäßig übergibt PowerBASIC Parameter als Referenz: einen 32-Bit-Zeiger auf die Daten. Sie können die meisten Parameter auch als Wert übergeben, indem Sie sie mit dem optionalen Schlüsselwort BYVAL deklarieren. Wenn ein Parameter als Wert übergeben wird, wird der tatsächliche Wert des Parameters auf den Stapel gelegt.

Zeichenfolgen fester Länge, mit NULL endende Zeichenfolgen und benutzerdefinierte Typen/Unions können jetzt auch als BYVAL- oder OPTIONAL-Parameter übergeben werden. Vermeiden Sie die Übergabe großer Elemente BYVAL, da dies furchtbar ineffizient ist und es eine maximale Größenbeschränkung von 64 KB für eine bestimmte Parameterliste gibt. Arrays können nicht BYVAL übergeben werden.

PowerBASIC richtet zu Beginn jeder Prozedur in Ihrem Programm automatisch einen lokalen „Stack-Frame“ ein. Gemäß Standardkonventionen wird das EBP-Register zur Adressierung der Parameter verwendet. Der niedrigste Parameter befindet sich bei EBP+8 und nachfolgende Parameter befinden sich an benachbarten Stellen im Stapel.

In Assembler-Routinen ist es einfacher und sicherer, über den Namen auf Parameter zuzugreifen, anstatt ihre Position auf dem Stapel zu berechnen. Es ist jedoch wichtig, den Unterschied beim Zugriff auf Parameter, die als Wert übergeben werden, und beim Zugriff auf Parameter, die als Referenz übergeben werden, zu bedenken.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Übergabe von Parametern soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Übergabe von Parametern mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


PATHNAME$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › PATHNAME$

PFADNAME$

Analysieren Sie einen Pfad/Dateinamen, um Komponententeile zu extrahieren

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

fil$ = PATHNAME$( director , filespec$ )

Beschreibung

Die Funktion PATHNAME$ wertet einen Textpfad/Dateitextnamen aus und gibt einen angeforderten Teil des Namens zurück. Die Funktionalität besteht ausschließlich aus dem Parsen von Zeichenfolgen. Es wird kein Versuch unternommen, die Datei auf der Festplatte zu finden. Wenn Sie nach einer bestimmten Datei auf der Festplatte suchen möchten, sollten Sie die Begleitfunktion PATHSCAN$ verwenden.

Regisseur

Dies ist eines der folgenden Wörter, das zur Angabe des angeforderten Teils verwendet wird:

Gibt den vollständigen Pfad/Dateinamen zurück, genau wie im Parameter filespec$ angegeben. Dies ist eigentlich keine Operation, wird aber aus Symmetriegründen mit der Begleitfunktion PATHSCAN$ einbezogen.

Gibt den Pfadteil des Pfad-/Dateinamens zurück. Das ist der Text bis einschließlich des letzten Backslashs (\) oder Doppelpunkts (:).

Gibt den Namensteil des Pfad-/Dateinamens zurück. Das ist der Text rechts vom letzten Backslash (\) oder Doppelpunkt (:), der direkt vor dem letzten Punkt (.) endet.

Gibt den Erweiterungsteil des Pfad-/Dateinamens zurück. Das ist der letzte Punkt (.) in der Zeichenfolge plus der Text rechts davon.

Gibt die NAME- und EXTN-Teile zusammen zurück.

Dateispezifikation$

Ein Pfad/Dateiname, der nicht unbedingt auf der Festplatte vorhanden ist.

Siehe auch

  • DIR$
  • EXE
  • PATHSCAN$
  • PARSE
  • PARSE$
  • PARSECOUNT

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PATHSCAN$ “ PBXB64-Compiler-Hilfe

Startseite â€º Funktionen â€º PATHSCAN$

PATHSCAN$

Kompatibilitaetshilfe, die den uebergebenen Pfadtext derzeit unveraendert zurueckgibt.

Kind: Funktion | Category: General

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [ZERTIFIZIERT GETESTET]

Syntax

fil$ = PATHSCAN$( path$ )

Beschreibung

Kompatibilitaetshilfe, die den uebergebenen Pfadtext derzeit unveraendert zurueckgibt. Die aktuelle PBXB64-Implementierung nimmt ein String-Argument und gibt eine Kopie dieses Strings zurueck.

Praktische Verwendung

Behandeln Sie PATHSCAN$ als Kompatibilitaetsschreibweise mit einem Ein-Argument-Vertrag.

Parameter und Ergebnisse

Argumente muessen den Datentypen, der Reihenfolge und den optionalen Teilen aus dem Syntaxblock folgen. Initialisieren Sie Zielvariablen vor dem Aufruf, damit unveraenderte Werte nach einem Fehler sichtbar bleiben.

Einschränkungen

Ein leerer Eingabestring liefert einen leeren String zurueck.

Verhalten

Die aktuelle PBXB64-Implementierung nimmt ein String-Argument und gibt eine Kopie dieses Strings zurueck.

Sie durchsucht das Dateisystem nicht, normalisiert keine Trennzeichen und zerlegt den Pfad nicht in Verzeichnis-/Name-/Erweiterungsanteile.

Wenn Sie Pfadkomponenten analysieren wollen, verwenden Sie PATHNAME$. Fuer echte Dateisystempruefungen verwenden Sie DIR$, ISFILE oder ISFOLDER.

Verwendungshinweise

Behandeln Sie PATHSCAN$ als Kompatibilitaetsschreibweise mit einem Ein-Argument-Vertrag.

Halten Sie die Tests an die aktuelle Implementierung gebunden. Wenn spaeter Suchverhalten ergaenzt wird, muessen Syntax und Hilfeseite einen echten Vertrag bekommen.

Grenzfaelle

Ein leerer Eingabestring liefert einen leeren String zurueck.

Weil die Hilfsfunktion die Eingabe kopiert, bleiben Laufwerkbuchstaben, UNC-Praefixe, Trennzeichen und abschliessende Punkte unveraendert erhalten.

Kompatibilitaetshinweise

Diese Hilfsfunktion existiert, damit aelterer Quelltext eine PATHSCAN$-Schreibweise behalten kann, waehrend PBXB64 den Vertrag derzeit bewusst einfach und deterministisch haelt.

Sie ist als Pass-through-Schritt nuetzlich, wenn der Pfad anderswo bereits zusammengesetzt wurde und nur noch ein benannter Uebergabepunkt gebraucht wird.

Da die Bytes erhalten bleiben, eignet sich die Funktion fuer das Rueckreichen von Pfadtext, einschliesslich relativer Segmente und abschliessender Trennzeichen.

Wenn spaeter echtes Verzeichnis-Suchen ergaenzt wird, muessen Syntax, Verhaltenshinweise, Tests und Dokumentation bewusst angepasst werden.

Beispiel

FUNCTION PBMAIN() AS LONG
    DIM s AS STRING

    s = PATHSCAN$("C:\dir\file.txt")
    IF s <> "C:\dir\file.txt" THEN FUNCTION = 1 : EXIT FUNCTION

    s = PATHSCAN$("")
    IF s <> "" THEN FUNCTION = 2 : EXIT FUNCTION

    FUNCTION = 0
END FUNCTION

Test- und Dokumentationshinweise

Mit tests/pb/test_pathscan_identity.pb kompiliert und ausgefuehrt; Exitcode 0.

Validierungsbeleg

Mit tests/pb/test_pathscan_identity.pb kompiliert und ausgefuehrt; Exitcode 0. PATHSCAN$("C:\dir\file.txt")

Verifiziertes Beispiel

Beispieldatei: tests/pb/test_pathscan_identity.pb

Validierungsbeleg: Mit tests/pb/test_pathscan_identity.pb kompiliert und ausgefuehrt; Exitcode 0.

FUNCTION PBMAIN() AS LONG
    DIM s AS STRING

    s = PATHSCAN$("C:\dir\file.txt")
    IF s <> "C:\dir\file.txt" THEN FUNCTION = 1 : EXIT FUNCTION

    s = PATHSCAN$("")
    IF s <> "" THEN FUNCTION = 2 : EXIT FUNCTION

    FUNCTION = 0
END FUNCTION

Fokus: PATHSCAN$("C:\dir\file.txt")

Siehe auch

  • PATHNAME$
  • DIR$
  • ISFILE
  • ISFOLDER

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


#PB - Eingebetteten PB-Block beginnen — PBXB64 Help

Startseite › General Reference › #PB - Eingebetteten PB-Block beginnen — PBXB64 Help
Hilfe zum PBXB64-Compiler

#PB - Eingebetteten PB-Block beginnen

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

#PB
PRINT "PB"
#ENDPB

Detailverhalten

Wird als mehrsprachiges Direktivtoken fuer PB-Quellbloecke erkannt.

Praktische Verwendung

Verwenden Sie diesen Einstieg fuer einen eingebetteten PB-Block, wenn die Quelle einen PB-Textabschnitt vom umgebenden Fremdsprachblock abgrenzen muss. Der Block wird erst mit dem passenden Endmarker wieder geschlossen.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Der Einstieg ersetzt keine echte Semantik fuer den eingebetteten Sprachblock. Ohne passenden Endmarker, passende Unterstuetzung oder passende Folgeimplementierung bleibt die Quelle unvollstaendig.

Verifiziertes Beispiel

Abgedeckt durch PB keyword compatibility (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


%PB_COMPILETIME numerisches Gleichsetzen – PBXB64 Compiler-Hilfe

Startseite › Funktionen › %PB_COMPILETIME numerisch gleichsetzen
Hilfe zum PBXB64-Compiler

%PB_COMPILETIME numerisches Gleichsetzen

Hilft bei der Bestimmung des Datums/der Uhrzeit der Kompilierung.

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Beschreibung

Jedes Mal, wenn Sie Ihr Programm kompilieren, wird dieses Equater mit dem aktuellen Datum und der aktuellen Uhrzeit der Kompilierung im PowerTime-Binärformat gefüllt. Mit der PowerTIME-Klasse können Sie es zur Verwendung in Ihrer Anwendung in ein Textäquivalent konvertieren.

Hilft bei der Bestimmung des Datums/der Uhrzeit der Kompilierung.

Jedes Mal, wenn Sie Ihr Programm kompilieren, wird dieses Equater mit dem aktuellen Datum und der aktuellen Uhrzeit der Kompilierung im PowerTime-Binärformat gefüllt. Mit der PowerTIME-Klasse können Sie es zur Verwendung in Ihrer Anwendung in ein Textäquivalent konvertieren.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für %PB_COMPILETIME numerisches Gleichsetzen soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' %PB_COMPILETIME numerisches Gleichsetzen mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


#PBFORMS – PBXB64-Compiler-Hilfe

Startseite › Funktionen › #PBFORMS

#PBFORMS

Compiler-Anweisung zum Markieren benannter generierter Blöcke

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Beschreibung

#PBFORMS-Metaanweisungen werden von PowerBASIC Forms generiert? Visuelles Design-Tool erstellt und automatisch in den generierten Quellcode eingefügt. #PBFORMS-Metaanweisungen identifizieren benannte Codeblöcke, die sowohl für den Compiler als auch für die PowerBASIC-Formulare eine besondere Bedeutung haben? visuelles Design-Tool.

#PBFORMS-Metaanweisungen sollten nicht entfernt oder verwendet werden – sie sollten nur von PowerBASIC Forms erstellt und positioniert werden? . Weitere Informationen finden Sie in der Dokumentation zu PowerBASIC Forms? .

PowerBASIC-Formulare? ist eine visuelle Designumgebung, die ein schnelles visuelles Design von GUI-Anwendungsdialogen ermöglicht. PowerBASIC Forms generiert kompilierbaren DDT-Quellcode (Dynamic Dialog Tools) direkt aus den im Designer erstellten Dialogen. Produktinformationen zu PowerBASIC Forms finden Sie unter http://www.powerbasic.com/products/pbforms.

Ein Beispiel für PowerBASIC-Formulare? Die Vorlage und das fertige Projekt finden Sie im Ordner PB\SAMPLES\DDT\INTERFACE EXPLORER, der mit PowerBASIC für Windows installiert wird.

PBXB64 akzeptiert #PBFORMS-Markierungen als Kompatibilitaets-Metadaten des IDE-Generators beim Kompilieren. Sie aendern kein Laufzeitverhalten und integrieren nicht mit dem PBForms-Designer.

Die Kompatibilitaetsbehandlung ist bewusst konservativ: PBXB64 laesst diese Markierungen zu, damit importierte von PBForms erzeugte Quellen nicht vor dem Kompilieren von Hand bereinigt werden muessen. Der Compiler speichert keinen Designer-Zustand, erzeugt keinen versteckten Dialogcode aus den Markierungen und ueberlaesst ausfuehrbares DDT-Verhalten den bereits vorhandenen Quellanweisungen.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für #PBFORMS soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' #PBFORMS mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


PBLIBMAIN – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › PBLIBMAIN

PBLIBMAIN

PBLIBMAIN führt eine ähnliche Aufgabe aus wie

Typ:Funktion |Kategorie: Procedures

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

FUNCTION PBLIBMAIN [()] [AS LONG]

Beschreibung

Weitere Informationen finden Sie unter LIBMAIN / DLLMAIN.

Siehe auch

  • DLLMAIN
  • LIBMAIN
  • PBMAIN
  • THREAD CREATE
  • WINMAIN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PEEK – PBXB64-Compiler-Hilfe

Startseite › Funktionen › PEEK

BLICK

Gibt a zurück

Typ:Funktion |Kategorie: Memory & Pointers

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

numvar = PEEK([ datatype ,] address??? )
ansivar = PEEK$([STRINGZ,] address??? , count& )
widevar = PEEK$$([WSTRINGZ,] address??? , count& )

Beschreibung

Die PEEK-Funktionen und ergänzenden POKE-Anweisungen sind Low-Level-Methoden für den Zugriff auf einzelne Bytes im Speicher. Die Daten werden aus dem Speicher abgerufen, beginnend bei der angegebenen 32-Bit-Adresse??? .

PEEK ruft einen numerischen Wert ab einer angegebenen Speicheradresse ab.

PEEK$ ruft count& aufeinanderfolgende Bytes ab und gibt sie als String zurück. Wenn STRINGZ (oder ASCIIZ) angegeben ist, liest PEEK$ aufeinanderfolgende Zeichen bis zur angegebenen Größe aus dem Speicher, bis ein abschließendes $NUL ( CHR$ (0))-Byte gefunden wird. Da STRINGZ-Zeichenfolgen ein abschließendes $NUL enthalten müssen, beträgt die maximale Länge der zurückgegebenen Zeichenfolge 1 Zeichen weniger als count&.

PEEK$$ ruft die Anzahl aufeinanderfolgender 2-Byte-Zeichen ab und gibt sie als Breitzeichenfolge zurück. Wenn WSTRINGZ angegeben ist, liest PEEK$$ aufeinanderfolgende Zeichen bis zur angegebenen Größe aus dem Speicher, bis ein abschließendes $NUL (CHR$(0))-Zeichen gefunden wird. Da WSTRINGZ-Zeichenfolgen ein abschließendes $NUL enthalten müssen, beträgt die maximale Länge der zurückgegebenen Zeichenfolge 1 Zeichen weniger als count& .

Getesteter PBXB64-Umfang: examples/basic/test_peek_poke_string.pb validiert PEEK$(address, count) als exaktes Bytezaehlungs-Lesen, dessen Laenge auch bei eingebetteten NUL-Bytes erhalten bleibt. tests/pb/test_peek_poke_wide_string.pb validiert PEEK$$(address, count) als exaktes Lesen von UTF-16-Codeunits und PEEK$$(WSTRINGZ, address, count) als NUL-terminiertes Lesen. Die Beispiele sind in tests/validate.toml registriert und laufen in der pb_linkrun-Lane.

Im Gegensatz zu intuitiven Vorstellungen werden PEEK und POKE auf dem gleichen hohen Leistungsniveau ausgeführt wie Zeigervariablen. Sie bieten in vielen Situationen eine hervorragende Alternative zu Zeigern.

Datentyp

Der abzurufende numerische Datentyp, der einer von BYTE , WORD , DWORD , INTEGER , LONG , QUAD , SINGLE , DOUBLE , EXT , CUR , CUX sein kann. Wenn kein Datentyp angegeben ist, wird BYTE angenommen.

Adresse???

Eine gültige 32-Bit-Speicheradresse, die den Speicherort angibt, an dem der Datenabruf beginnen soll.

zählen&

Ein numerischer Ausdruck, der die Anzahl aufeinanderfolgender Zeichen angibt, die aus dem Speicher gelesen werden sollen.

Einschränkungen

Wenn Adresse??? (oder ein beliebiger Speicher im durch count& abgedeckten Bereich) auf eine ungültige Adresse verweist (Speicher, der der Anwendung nicht zugewiesen ist), generiert Windows eine allgemeine Schutzverletzung (GPF) und beendet die Anwendung. GPFs können nicht mit einem ON ERROR-Fehlerhandler abgefangen werden.

Siehe auch

  • STICK
  • STRPTR
  • VARPTR

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für BLICK soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' BLICK mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


PIC BIND - PBXB64-Compiler-Hilfe

Startseite › BASIC-Referenz › PIC BIND

PIC BIND

Typ: Anweisung | Kategorie: Data Types & Variables

PBXB64-Status: VERFUEGBAR, getestete String-Satzbindung

PBXB64-Zertifizierung: [TESTED LIMITED]

Syntax

PIC BIND field, buffer$, offset, length

Beschreibung

Bindet ein PICFIELD an einen BASIC-Satzstring. Wenn der Puffer ein einfacher STRING-Variablenname ist, aktualisiert PBXB64 den String-Slot nach PIC SET; so koennen feste Felder in einem BASIC-Satzpuffer gepflegt werden.

Parameter

offset ist 1-basiert. length muss mindestens so lang sein wie das Picture-Speicherfeld.

Beispiel

#COMPILE EXE
#DIM ALL
FUNCTION PBMAIN() AS LONG
    LOCAL rec AS STRING, amount AS PICFIELD
    rec = SPACE$(20)
    PIC INIT amount, "9(4)V99"
    PIC BIND amount, rec, 5, 6
    PIC SET amount, 12.34
    IF MID$(rec, 5, 6) <> "001234" THEN FUNCTION = 1
    PIC FREE amount
END FUNCTION

Validierungsbeleg

Abgedeckt durch tests/pb/test_picfield_bind.pb.

Einschraenkungen

Getestet ist die Bindung an dynamische BASIC-STRING-Variablen. Direkte Bindung an beliebige Speicher-Ausdruecke ist ein niedrigerer Kompatibilitaetspfad und sollte vom Aufrufer validiert werden.

Siehe Auch

  • PICFIELD
  • PIC SET

Validierungshinweise

PIC BIND verbindet ein PICFIELD mit einem eigenen BASIC-Record-String, damit spaetere SET-Operationen den Puffer aktualisieren. Verwenden Sie den Befehl, wenn das Record-Layout wichtig ist und der Aufrufer die exakten String-Bytes sehen muss. Das Beispiel sollte belegen, dass ein spaeteres Schreiben den Record-Speicher selbst und nicht eine abgetrennte Kopie aendert.

Nutzungsgrenzen

Die Bindung ist fuer dynamische STRING-Variablen getestet. Halten Sie den Puffer lang genug fuer das Picture und behandeln Sie Offset, Laenge und Eigentum als Teil des Vertrags, nicht als optionale Hinweise. Dies ist die Seite fuer Record-Overlays und nicht fuer Anlage oder Picture-Analyse.

Fehlerfaelle

Ein zu kurzer Puffer, ein ungueltiger Offset oder ein Nicht-String-Ziel muss den Bindepfad sofort abbrechen. Wenn der Aufrufer das Feld nach einer fehlgeschlagenen Bindung erneut nutzen will, sollte er das Handle neu aufbauen und nicht annehmen, dass der vorherige Speicher noch gueltig ist.

← Top →


PIC CLEAR - PBXB64-Compiler-Hilfe

Startseite › BASIC-Referenz › PIC CLEAR

PIC CLEAR

Typ: Anweisung | Kategorie: Data Types & Variables

PBXB64-Status: VERFUEGBAR, getestet

PBXB64-Zertifizierung: [TESTED LIMITED]

Syntax

PIC CLEAR field

Beschreibung

Setzt ein PICFIELD zurueck: Textfelder auf Leerzeichen, numerische DISPLAY-Felder auf Nullen. Signierte numerische Felder erhalten ein fuehrendes Pluszeichen.

Beispiel

#COMPILE EXE
#DIM ALL
FUNCTION PBMAIN() AS LONG
    LOCAL f AS PICFIELD
    PIC INIT f, "S9(5)V99"
    PIC CLEAR f
    IF PIC$(f) <> "+0000000" THEN FUNCTION = 1
    PIC FREE f
END FUNCTION

Validierungsbeleg

Abgedeckt durch tests/pb/test_picfield_basic.pb.

Siehe Auch

  • PIC SET
  • PIC FREE

Validierungshinweise

PIC CLEAR setzt die gespeicherten Bytes zurueck, laesst die Picture-Definition aber bestehen. Verwenden Sie den Befehl, wenn Sie dasselbe Handle fuer einen neuen Wert erneut nutzen wollen, ohne das Feld neu aufzubauen. Das Beispiel sollte die geloeschte Speicherform explizit zeigen, damit klar ist, welche Bytes nach dem Reset bleiben.

Nutzungsgrenzen

Nach einem CLEAR verhalten sich die naechsten SET- oder GET-Operationen so, als waere der Speicher gerade vorbereitet worden; dies ist also der Wiederverwendungs- und nicht der Allokationspfad. CLEAR ist damit die richtige Wahl, wenn ein einzelnes Handle ueber mehrere Datensaetze oder Schleifendurchlaeufe hinweg wiederverwendet wird. Es ist ein Daten-Reset und keine Neuallokation.

Fehlerfaelle

Ein geloeschtes Feld ist weder eine neue Allokation noch ein Konvertierungsergebnis. Wenn der Aufrufer eine neue Picture-Definition braucht, muss er PIC INIT erneut aufrufen statt anzunehmen, dass CLEAR irgendetwas neu aufgebaut hat.

← Top →


PIC$ - PBXB64 Compiler Help

Startseite › BASIC Reference › PIC$

PIC$

Kind: Function | Category: Data Types & Variables

PBXB64 Status: AVAILABLE, tested

PBXB64 Certification: [TESTED LIMITED]

Syntax

result$ = PIC$(field)
result$ = PICSTR$(field)

Beschreibung

PIC$ gibt die exakten DISPLAY-Bytes eines PICFIELD als BASIC-String zurueck. PICSTR$ ist ein Alias.

Beispiel

#COMPILE EXE
#DIM ALL
FUNCTION PBMAIN() AS LONG
    LOCAL f AS PICFIELD
    PIC INIT f, "X(6)"
    PIC SET f, "ABC"
    IF PIC$(f) <> "ABC   " THEN FUNCTION = 1
    PIC FREE f
END FUNCTION

Validierungsbeleg

Abgedeckt durch tests/pb/test_picfield_basic.pb.

Siehe auch

  • PICVAL
  • PICVALID

Validierungshinweise

PIC$ und das Alias PICSTR$ geben die exakten DISPLAY-Bytes als BASIC-String zurueck. Verwenden Sie diese Seite, wenn der Aufrufer die formatierte Speicherform statt des konvertierten Zahlenwerts braucht. Das Beispiel sollte die exakte Text- oder Zifferndarstellung des gespeicherten Felds belegen.

Nutzungsgrenzen

Bei Text-Pictures sind Padding und Abschneidung zu pruefen. Bei numerischen Pictures sind das gespeicherte Vorzeichen und das Ziffernlayout aus der deklarierten Skalierung zu pruefen. Die Funktion behaelt dieselben DISPLAY-Bytes bei, die PIC GET in ein String-Ziel schreiben wuerde; damit ist sie die richtige Referenz fuer das Rueckuebertragen eines Record-Felds als formatierten Text.

Fehlerfaelle

Wenn der Aufrufer eine numerische Konvertierung erwartet, sollte er statt PIC$ PICVAL oder PIC GET in ein numerisches Ziel verwenden. Ein freigegebenes Feld, ein fehlerhaftes Picture oder ein Puffer, der nicht mehr zum aktuellen Layout passt, darf nicht als gueltiger Schnappschuss der Zeichenfolge behandelt werden.

← Top →


PIC FREE - PBXB64-Compiler-Hilfe

Startseite › BASIC-Referenz › PIC FREE

PIC FREE

Typ: Anweisung | Kategorie: Data Types & Variables

PBXB64-Status: VERFUEGBAR, getestet

PBXB64-Zertifizierung: [TESTED LIMITED]

Syntax

PIC FREE field

Beschreibung

Gibt einen mit PIC INIT angelegten PICFIELD-Handle frei und loescht die BASIC-Handlevariable.

Beispiel

#COMPILE EXE
#DIM ALL
FUNCTION PBMAIN() AS LONG
    LOCAL f AS PICFIELD
    PIC INIT f, "X(6)"
    PIC FREE f
END FUNCTION

Validierungsbeleg

Abgedeckt durch tests/pb/test_picfield_basic.pb und tests/pb/test_picfield_bind.pb.

Siehe Auch

  • PIC INIT

Validierungshinweise

PIC FREE gibt das angelegte Feld-Handle nach der letzten Lese- oder Schreiboperation frei. Nach dem Freigeben ist die BASIC-Variable als ungueltig zu behandeln und darf nicht fuer weitere Operationen wiederverwendet werden. Das Beispiel sollte den letzten gueltigen Zugriff vor dem Cleanup zeigen und danach belegen, dass das Handle tot ist.

Nutzungsgrenzen

Verwenden Sie die Seite fuer Aufraeumlogik, nicht fuer Picture-Konvertierung. Wenn das Feld an einen Record-String gebunden war, geben Sie es erst frei, nachdem der letzte Wert kopiert oder beobachtet wurde. Das Handle uebertraegt kein Eigentum am zugrunde liegenden String; der Aufrufer bleibt daher fuer die Lebensdauer des umgebenden Speichers zustaendig.

Fehlerfaelle

Nach FREE ist die BASIC-Variable toter Zustand und darf nicht mehr an SET-, GET-, VALID- oder PIC$-Aufrufe uebergeben werden. Ein doppeltes Freigeben, ein spaeter wiederverwendetes freigegebenes Handle oder Cleanup vor dem letzten Lesen/Schreiben ist ein Fehler im Aufrufer.

← Top →


PIC GET - PBXB64-Compiler-Hilfe

Startseite › BASIC-Referenz › PIC GET

PIC GET

Typ: Anweisung | Kategorie: Data Types & Variables

PBXB64-Status: VERFUEGBAR, getestet

PBXB64-Zertifizierung: [TESTED LIMITED]

Syntax

PIC GET field TO target

Beschreibung

Kopiert ein PICFIELD in ein BASIC-Ziel. String-Ziele erhalten die exakten DISPLAY-Bytes. Numerische Ziele erhalten den Zahlenwert mit der impliziten Dezimalskala.

Beispiel

#COMPILE EXE
#DIM ALL
FUNCTION PBMAIN() AS LONG
    LOCAL f AS PICFIELD, n AS DOUBLE
    PIC INIT f, "9(4)V99"
    PIC SET f, 12.34
    PIC GET f TO n
    IF n < 12.33 OR n > 12.35 THEN FUNCTION = 1
    PIC FREE f
END FUNCTION

Validierungsbeleg

Abgedeckt durch tests/pb/test_picfield_basic.pb und tests/pb/test_picfield_bind.pb.

Siehe Auch

  • PIC SET
  • PICVAL

Validierungshinweise

PIC GET liest den aktuellen Feldwert in ein BASIC-Ziel zurueck. String-Ziele erhalten die exakten DISPLAY-Bytes, waehrend numerische Ziele den skalierten Zahlenwert erhalten, den das Picture beschreibt. Das Beispiel sollte das gespeicherte Feld vor und nach dem Lesen zeigen, damit die Konvertierungsrichtung klar ist.

Nutzungsgrenzen

Initialisieren Sie das Ziel vor dem Aufruf, damit ein Fehlschlag sichtbar bleibt. So wird klar, ob der Aufruf das Ziel geaendert hat oder es unveraendert liess. Verwenden Sie diese Seite, wenn das Programm formatierte Record-Daten wieder in den BASIC-Zustand uebernehmen muss und der Aufrufer wissen soll, ob das Ergebnis in eine String- oder eine numerische Variable gehoert.

Fehlerfaelle

Wenn der Zieltyp nicht zur gespeicherten Darstellung passt, sollte der Aufrufer das Ergebnis nicht raten. Ein freigegebenes Feld, ein nicht initialisiertes Ziel oder ein Record-String, der nicht mehr zum Picture passt, ist als sofortiger Fehlerpfad zu behandeln.

← Top →


PIC INIT - PBXB64-Compiler-Hilfe

Startseite › BASIC-Referenz › PIC INIT

PIC INIT

Typ: Anweisung | Kategorie: Data Types & Variables

PBXB64-Status: VERFUEGBAR, getestete begrenzte COBOL-DISPLAY-Picture-Bruecke

PBXB64-Zertifizierung: [TESTED LIMITED]

Syntax

PIC INIT field, picture$

Beschreibung

Legt einen PICFIELD-Handle mit einem COBOL-artigen DISPLAY-Picture an oder ersetzt ihn. Textfelder starten mit Leerzeichen, numerische Felder mit Nullen und bei signierten Feldern mit fuehrendem +.

Parameter

field muss AS PICFIELD deklariert sein. picture$ ist z.B. "X(6)", "9(4)V99" oder "S9(5)V99".

Beispiel

#COMPILE EXE
#DIM ALL
FUNCTION PBMAIN() AS LONG
    LOCAL f AS PICFIELD
    PIC INIT f, "9(4)V99"
    IF PICVALID(f) = 0 THEN FUNCTION = 1
    PIC FREE f
END FUNCTION

Validierungsbeleg

Abgedeckt durch tests/pb/test_picfield_basic.pb und tests/pb/test_picfield_bind.pb.

Einschraenkungen

Nur der auf PICFIELD beschriebene DISPLAY-Teilbereich ist akzeptiert.

Siehe Auch

  • PICFIELD
  • PIC FREE

Validierungshinweise

PIC INIT legt das Handle an und bindet die Picture-Definition, die spaetere SET-, GET-, CLEAR-, VALID- und FREE-Operationen verwenden. Schlaegt die Initialisierung fehl, ist das Handle unbrauchbar und die weiteren Familienmitglieder duerfen darauf nicht mehr aufgerufen werden. Das Beispiel sollte eine erfolgreiche Initialisierung und eine anschliessende Pruefung desselben Speichers zeigen.

Nutzungsgrenzen

Verwenden Sie diese Seite fuer Anlage und Picture-Setup, nicht fuer Wertkonvertierung oder Record-Bindung. Halten Sie den Picture-String stabil, initialisieren Sie das Handle einmal und geben Sie es erst frei, wenn das Feld im umgebenden Record oder in der Schleife nicht mehr benoetigt wird. Das Handle verwaltet den Picture-Zustand; es kopiert nicht die fachlichen Daten des Aufrufers fuer spaeteren Wiedergebrauch.

Fehlerfaelle

Ein ungueltiges Picture, ein falsches Deklarationsziel oder ein erneut verwendetes totes Handle sind als harter Fehler zu behandeln. Nach einer fehlgeschlagenen Initialisierung sollte der Aufrufer seinen Zustand selbst leeren und keine SET-, GET-, CLEAR-, VALID- oder FREE-Aufrufe mehr auf das fehlerhafte Handle ausfuehren.

← Top →


PIC SET - PBXB64-Compiler-Hilfe

Startseite › BASIC-Referenz › PIC SET

PIC SET

Typ: Anweisung | Kategorie: Data Types & Variables

PBXB64-Status: VERFUEGBAR, getestet

PBXB64-Zertifizierung: [TESTED LIMITED]

Syntax

PIC SET field, value

Beschreibung

Formatiert einen BASIC-Wert in ein PICFIELD. Text wird linksbuendig geschrieben und mit Leerzeichen aufgefuellt. Numerische Pictures uebernehmen Vorzeichen und Ziffern, richten Ziffern rechts aus und verwenden die implizite Skala aus V.

Beispiel

#COMPILE EXE
#DIM ALL
FUNCTION PBMAIN() AS LONG
    LOCAL f AS PICFIELD
    PIC INIT f, "S9(5)V99"
    PIC SET f, -123.45
    IF PIC$(f) <> "-0012345" THEN FUNCTION = 1
    PIC FREE f
END FUNCTION

Validierungsbeleg

Abgedeckt durch tests/pb/test_picfield_basic.pb und tests/pb/test_picfield_bind.pb.

Einschraenkungen

Editierte Formatzeichen und Packed Decimal sind nicht implementiert.

Siehe Auch

  • PIC GET
  • PIC$

Validierungshinweise

PIC SET schreibt einen BASIC-Wert in das fokussierte Feld und konvertiert ihn gemaess dem deklarierten Picture. Verwenden Sie den Befehl nur fuer den Zuweisungsschritt; er legt das Handle nicht an und gibt den Speicher nicht frei. Das Beispiel sollte die genauen Bytes des Konvertierungsschritts belegen, nicht nur einen numerischen Rueckweg.

Nutzungsgrenzen

Bei numerischen Pictures muessen Vorzeichen, implizite Dezimalskalierung und eventuelle Fuehrungsnullen im gespeicherten Ergebnis geprueft werden. Bei Text-Pictures sind Padding und Abschneidung im Beispiel explizit zu pruefen. Diese Seite ist der Schreibpfad der Familie; der Aufrufer sollte das Handle vorher vorbereiten und erst nach dem Schreiben mit PIC GET oder PIC$ zuruecklesen.

Fehlerfaelle

Wenn das Picture den Quellwert nicht darstellen kann, sollte der Aufrufer das Ergebnis als ungueltig behandeln und das Feld sofort erneut pruefen. Ein fehlerhaftes Handle, ein freigegebenes Feld oder ein Wert, der die Zielbreite ueberschreitet, darf vom umgebenden Programm nie stillschweigend akzeptiert werden.

← Top →


PICFIELD - PBXB64-Compiler-Hilfe

Startseite › BASIC-Referenz › PICFIELD

PICFIELD

Typ: Datentyp | Kategorie: Data Types & Variables

PBXB64-Status: VERFUEGBAR, getestete COBOL-DISPLAY-Picture-Bruecke

PBXB64-Zertifizierung: [TESTED LIMITED]

Syntax

LOCAL field AS PICFIELD
PIC INIT field, "S9(5)V99"

Beschreibung

PICFIELD ist ein undurchsichtiger BASIC-Handle fuer ein fokussiertes COBOL-artiges DISPLAY-Picture. Der Datentyp ist fuer COBOL-Interop, feste Satzpuffer, Import-/Export-Layouts und Dezimaltext wie S9(5)V99 gedacht.

Unterstuetzt sind Text-Pictures X(n) und A(n) sowie numerische Pictures 9(n), S9(n), 9(n)V9(m) und S9(n)V9(m). Numerische Speicherung ist DISPLAY-Text: optionales Vorzeichen und Dezimalziffern. Der implizite Dezimalpunkt aus V wird nicht gespeichert.

Befehle und Funktionen

Verwenden Sie PIC INIT zum Anlegen, PIC SET zum Setzen, PIC GET zum Auslesen, PIC BIND fuer BASIC-Satzstrings und PIC FREE zum Freigeben. PIC$, PICVAL und PICVALID liefern Ausdruckszugriff.

Beispiel

#COMPILE EXE
#DIM ALL
FUNCTION PBMAIN() AS LONG
    LOCAL amount AS PICFIELD
    PIC INIT amount, "S9(5)V99"
    PIC SET amount, -123.45
    IF PIC$(amount) <> "-0012345" THEN FUNCTION = 1: EXIT FUNCTION
    PIC FREE amount
END FUNCTION

Validierungsbeleg

Abgedeckt durch tests/pb/test_picfield_basic.pb und tests/pb/test_picfield_bind.pb in der registrierten Lane pb_linkrun.

Einschraenkungen

Dies ist keine vollstaendige COBOL-PICTURE-Implementierung. Packed Decimal, binaere COMP-Felder, editierte Pictures, Waehrungssymbole, Vorzeichenpositionsvarianten, BLANK WHEN ZERO, OCCURS, REDEFINES und National-Character-Pictures sind noch nicht Teil dieser BASIC-Bruecke.

Siehe Auch

  • PIC INIT
  • PIC BIND
  • PIC$
  • PICVAL
  • PICVALID

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← Top →


PICVAL - PBXB64-Compiler-Hilfe

Startseite › BASIC-Referenz › PICVAL

PICVAL

Typ: Funktion | Kategorie: Data Types & Variables

PBXB64-Status: VERFUEGBAR, getestet

PBXB64-Zertifizierung: [TESTED LIMITED]

Syntax

n# = PICVAL(field)

Beschreibung

Wandelt ein numerisches PICFIELD in einen DOUBLE-Wert um. Die implizite Dezimalskala aus V wird angewendet.

Beispiel

#COMPILE EXE
#DIM ALL
FUNCTION PBMAIN() AS LONG
    LOCAL f AS PICFIELD, n AS DOUBLE
    PIC INIT f, "9(4)V99"
    PIC SET f, 12.34
    n = PICVAL(f)
    IF n < 12.33 OR n > 12.35 THEN FUNCTION = 1
    PIC FREE f
END FUNCTION

Validierungsbeleg

Abgedeckt durch tests/pb/test_picfield_basic.pb und tests/pb/test_picfield_bind.pb.

Siehe Auch

  • PIC$
  • PIC GET

Validierungshinweise

PICVAL konvertiert ein numerisches PICFIELD in ein BASIC-Numerikergebnis und wendet die implizite Dezimalskalierung des Pictures an. Verwenden Sie den Befehl nur fuer den numerischen Teil der Familie; Text-Pictures gehoeren auf den PIC$-Pfad. Das Beispiel sollte die exakte Round-Trip-Erwartung fuer die gespeicherten Ziffern zeigen.

Nutzungsgrenzen

Wenn ein Programm ein bereits formatiertes PICFIELD liest, ist PICVAL die Seite fuer den numerischen Wert, den der Aufrufer fuer Mathematik, Vergleiche oder Validierung verwendet. Das Beispiel sollte die urspruenglichen dargestellten Ziffern und das erwartete Gleitkommaergebnis nennen, damit die Skalierung klar bleibt.

Fehlerfaelle

Wenn das Feld noch nicht-numerischen Text enthaelt, sollte der Aufrufer es nicht mit PICVAL konvertieren und dann das Ergebnis fuer gueltig halten. Eine veraltete Bindung, ein freigegebenes Handle oder ein Picture, das nicht mehr zu den gespeicherten Ziffern passt, ist ein Fehler im Aufrufer.

← Top →


PICVALID - PBXB64-Compiler-Hilfe

Startseite › BASIC-Referenz › PICVALID

PICVALID

Typ: Funktion | Kategorie: Data Types & Variables

PBXB64-Status: VERFUEGBAR, getestet

PBXB64-Zertifizierung: [TESTED LIMITED]

Syntax

ok& = PICVALID(field)

Beschreibung

Gibt ungleich Null zurueck, wenn ein PICFIELD-Handle gueltig ist und die aktuellen DISPLAY-Bytes den fokussierten Picture-Regeln entsprechen. Numerische Felder muessen Ziffern enthalten, bei signierten Pictures optional mit fuehrendem Vorzeichen.

Beispiel

#COMPILE EXE
#DIM ALL
FUNCTION PBMAIN() AS LONG
    LOCAL f AS PICFIELD
    PIC INIT f, "9(4)V99"
    IF PICVALID(f) = 0 THEN FUNCTION = 1
    PIC FREE f
END FUNCTION

Validierungsbeleg

Abgedeckt durch tests/pb/test_picfield_basic.pb.

Siehe Auch

  • PICFIELD
  • PIC$

Validierungshinweise

PICVALID prueft, ob die aktuellen Bytes noch zu den fokussierten Picture-Regeln passen. Es ist eine Gueltigkeitspruefung und kein Konvertierungsschritt; das Beispiel sollte daher den gueltigen Fall und mindestens eine ungueltige oder abgelehnte Form belegen. Der Aufrufer sollte das Ergebnis lesen, bevor er irgendetwas zurueckschreibt oder numerisch konvertiert.

Nutzungsgrenzen

Signierte numerische Pictures brauchen weiterhin eine gueltige Vorzeichenposition und gueltige Ziffern. Die Seite impliziert weder Packed Decimal noch editierte COBOL-Pictures oder eine breitere Pruef-Engine jenseits der getesteten DISPLAY-Teilmenge. Verwenden Sie PICVALID, wenn das Programm fehlerhafte Daten vor einer Zuweisung oder Kopie ablehnen muss.

Fehlerfaelle

Ein fehlerhaftes Byte-Muster, ein Vorzeichen an der falschen Stelle oder eine Breitenabweichung sollte den Aufrufer stoppen, bevor das Feld erneut verwendet wird. Das Beispiel sollte gueltiges Feld, ungueltiges Feld und den Rueckgabewert zeigen, damit der Aufrufer entscheiden kann, ob er fortfuehrt oder einen Eingabefehler meldet.

← Top →


PLAY WAVE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › PLAY WAVE

WELLE SPIELEN

Spielen Sie einen Sound programmgesteuert ab.

Typ:Anweisung |Kategorie: Utilities

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

PBXB64-getestete Teilmenge: PBXB64 zertifiziert derzeit die Disk-Datei-Wiedergabe fuer einen Dateinamen-Ausdruck, deterministisches Fehlschlagen bei fehlender Datei und das Stoppen mit PLAY WAVE END. Die fokussierte Regression ist examples/basic/test_play_wave.pb. Im getesteten PBXB64-Laufzeitvertrag erhaelt TO result bei Erfolg 0 und bei Fehler einen Wert ungleich null.

Syntax

PLAY WAVE ResourceID$ [, descriptors ...] [TO ResultVar& ]
PLAY WAVE END

Beschreibung

Mit der PLAY-Anweisung können Sie eine zuvor erstellte WAVE-Ressource oder WAVE-Datei abspielen. Im Allgemeinen ist es vorteilhaft, das Ressourcenformular zu verwenden. Der Zugriff ist in der Regel schneller und der Bedarf an zusätzlichen Dateien ist geringer. Die erste Form von PLAY WAVE startet den Sound, während PLAY WAVE END jeden gerade abgespielten Waveform-Sound stoppt.

ResourceID$ ist ein Zeichenfolgenausdruck, der entweder die Ressourcen-ID der Wellenformdaten oder die Festplattendatei angibt, in der sie gefunden werden können. Wenn die Ressourcen-ID numerisch ist, stellen Sie der Zahl einfach ein # voran, z. B. „#12345“. Wenn die Ressourcen-ID einen Punkt enthält, handelt es sich vermutlich um den Namen einer Festplattendatei. Andernfalls wird versucht, die Datei von einer Ressource zu laden. Wenn sie nicht gefunden wird, wird davon ausgegangen, dass es sich um eine Festplattendatei handelt. Wenn die Wellenformdaten nicht gefunden werden können, wird ein Fehler 53 (Datei nicht gefunden) generiert.

Wenn Sie die optionale TO-Klausel einschließen, wird der ResultVar& ein Erfolgswert zugewiesen. Wenn die Operation erfolgreich ist, wird der Wert True (ungleich Null) zugewiesen. Wenn dies fehlschlägt, wird der Wert False (Null) zugewiesen.

Die Standardmethode besteht darin, die Wellenformdaten im Hintergrund abzuspielen. Das heißt, die Play-Anweisung kehrt sofort zurück, sodass die Anwendung anderen Code ausführen kann, während der Sound abgespielt wird.

Standardmäßig hat der neue Sound Vorrang vor allen anderen derzeit abgespielten Sounds. Wenn PLAY WAVE ausgeführt wird, wird die Wiedergabe aller anderen Sounds sofort gestoppt. Der neue Sound wird abgespielt, um ihn zu ersetzen. Diese Standardmethode kann mit den später beschriebenen Optionen geändert werden.

Die optionalen Beschreibungswörter (eins oder mehrere) können hinzugefügt werden, um die Art und Weise zu steuern, wie der Ton abgespielt wird. Die verfügbaren Deskriptoren sind:

Der Ton wird wiederholt im Hintergrund abgespielt. Es wird endlos abgespielt, bis PLAY WAVE END ausgeführt wird oder das Programm beendet wird.

NoStop

Wenn ein anderer Sound abgespielt wird, wird der neue Sound verworfen und nicht abgespielt. Der Wert „Falsch“ (Null) wird an die Ergebnisvariable zurückgegeben, um Sie darüber zu informieren, dass der Vorgang fehlgeschlagen ist. Sie können nach Belieben erneut versuchen, den neuen Sound abzuspielen.

Der Ton wird im synchronen Modus abgespielt, der allgemein als Vordergrund bezeichnet wird. Die Anwendung wartet, bis der Ton beendet ist, bevor sie mit der Ausführung anderen Codes fortfährt. Der Ton und der Code sind synchronisiert.

YieldMS( TimeOut& )

Wenn ein anderer Ton abgespielt wird, gibt der neue Ton nach und ermöglicht die Vervollständigung des ersten Tons. Der numerische Ausdruck TimeOut& gibt an, wie viele Millisekunden (ungefähr) maximal gewartet werden muss, bevor aufgegeben wird. Wenn die Timeout-Zeit abläuft und der erste Sound noch abgespielt wird, wird der neue Sound abgebrochen. Wenn die Timeout-Periode Null (0) ist, wartet das Programm unbegrenzt lange, bis der erste Ton beendet ist. Der maximal zulässige TimeOut beträgt eine Stunde.

PBXB64 analysiert die Deskriptorwoerter Foreground, Synch, NoStop und YieldMS(timeout) fuer den fokussierten Disk-Datei-Pfad. Der Lowerer ruft den eingebetteten Helfer bestof_play_wave_flags auf, behaelt die Disk-Datei-Existenzpruefung und SND_NODEFAULT bei, entfernt SND_ASYNC fuer Foreground oder Synch und setzt SND_NOSTOP fuer NoStop. Ungueltige Deskriptoren sind Compilezeitdiagnosen.

PBXB64-Deskriptorgrenzen: YieldMS wird in diesem fokussierten Abschnitt als Kompatibilitaetsdeskriptor akzeptiert, aber PBXB64 implementiert noch nicht die vollstaendige Timeout-/Yield-Schleife fuer bereits laufende Sounds. Audio-Timing mit vorhandener Datei, Ressourcen-ID-Wiedergabe und vollstaendige NoStop-Arbitrierung brauchen eigene fokussierte Validierung, bevor sie als vollstaendige PBWin-Paritaet gelten.

Siehe auch

  • #RESSOURCE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für WELLE SPIELEN soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' WELLE SPIELEN mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Zeiger auf Arrays – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Zeiger auf Arrays

Zeiger auf Arrays

Um mit Arrays zu arbeiten, die von anderen Sprachen erstellt wurden, wie z. B. VB-Arrays, unterstützt PowerBASIC eine Erweiterung der Zeigersyntax namens „Pointer Indexing“. Wie oben erwähnt, ermöglicht Ihnen ein Zeiger den Zugriff

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Die Adresse des ersten Elements, x%(0), ist die Basis, wobei die übrigen Elemente nacheinander im Speicher gespeichert werden. Um mit einem Indexzeiger auf das Array zuzugreifen, weisen Sie Ihrem Basiszeiger einfach die Adresse des ersten Elements zu:

DIM xPtr ALS INTEGER-ZEIGER

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


Zeiger auf Arrays mit dualen Indizes – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Zeiger auf Arrays mit dualen Indizes
Hilfe zum PBXB64-Compiler

Zeiger auf Arrays mit dualen Indizes

Indizierte Zeiger mit doppelten Indizes erfordern eine „OF limit“-Klausel für beide Indizes. Während einfache Arrays (Arrays mit einem Index) Daten sequentiell speichern, verschachteln Dual-Indizes jede Datenzeile. Das OF

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

DIM DataPtr ALS INTEGER PTR

DIM z%(0 BIS 8, 0 BIS 3)

DataPtr = VARPTR(z%(0, 0))

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


Zeiger auf nullterminierte Zeichenfolgen und Zeichenfolgen fester Länge – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Zeiger auf nullterminierte Zeichenfolgen und Zeichenfolgen fester Länge
Hilfe zum PBXB64-Compiler

Zeiger auf nullterminierte Zeichenfolgen und Zeichenfolgen fester Länge

Bei der Deklaration einer Nul-terminierten Zeichenfolge oder einer Zeichenfolge mit fester Länge muss explizit die maximale Länge der Zeichenfolge angegeben werden, damit der Compiler den Speicher entsprechend zuweisen kann. Beim Deklarieren von Zeigern auf f

Typ:Schlüsselwort |Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Bei einem Nul-terminierten String-Zeiger kann die Längenbeschränkung jedoch explizit angegeben werden oder als mehrdeutiger Wert belassen werden, indem die Längenklausel vollständig übersprungen wird. Gültig sind beispielsweise die folgenden Zeilen:

DIM x AS ASCIIZ PTR * 41

DIM y AS STRINGZ PTR * 2

DIM z AS WSTRINGZ PTR

Siehe auch

  • Befehlsindex
  • BASIC-Frontend
← Zeiger auf Arrays mit dualen Indizes Nach oben STICK →

Beschreibung

Ein Zeiger auf eine nullterminierte oder eine Zeichenfolge fester Laenge muss die erwartete Laenge so beschreiben, dass der Compiler den Speicher korrekt behandeln kann. Die Seite soll den Unterschied zwischen einer fest angegebenen Laengenklausel und einem weggelassenen Klauselteil klar benennen.

Syntax

DIM x AS ASCIIZ PTR * 41
DIM y AS STRINGZ PTR * 2
DIM z AS WSTRINGZ PTR

Beispiel

DIM x AS ASCIIZ PTR * 41
DIM y AS STRINGZ PTR * 2
DIM z AS WSTRINGZ PTR

Validierungsbeleg

Die aktuelle Hilfeseite und die zugehoerigen Typ- und Pointer-Referenzen dokumentieren die getestete Laengen- und Speicherregel. Verwenden Sie die Seite als Referenz fuer Deklarationen, nicht als allgemeine Aussage ueber breitere String-Kompatibilitaet.


POKE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › POKE

STICK

Speichern Sie a

Typ:Anweisung |Kategorie: Memory & Pointers

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

POKE [ DataType ,] Address??? , DataValue [, DataValue ...]
POKE$ [STRINGZ,] Address??? , StringExpr
POKE$$ [WSTRINGZ,] Address??? , StringExpr

Beschreibung

Die POKE-Anweisungen und ergänzenden PEEK-Funktionen sind Low-Level-Methoden für den Zugriff auf einzelne Bytes im Speicher. Die Daten werden ab der angegebenen 32-Bit-Adresse im Speicher gespeichert.

In seiner klassischen Form speichert die POKE-Anweisung ein einzelnes Byte (8 Bit), dessen Wert zwischen 0 und 255 liegt. In seiner erweiterten Form bietet POKE die Funktionalität eines dynamischen Zeigers: Der DataType-Parameter gibt den Datentyp und damit die Größe der Zieldaten an, die an die Zielspeicheradresse geschrieben werden sollen. Der Datentyp kann einer von BYTE, WORD, DWORD, INTEGER, LONG, QUAD, SINGLE, DOUBLE, EXT, CUR und CUX sein. Wenn kein DataType angegeben ist, wird BYTE angenommen. Wenn Sie mehr als einen DataValue angeben, werden diese an aufeinanderfolgenden Speicherorten gespeichert.

POKE$ speichert die Bytes von StringExpr in aufeinanderfolgenden Speicherbytes. Wenn STRINGZ (oder ASCIIZ) angegeben ist, schreibt POKE$ aufeinanderfolgende Zeichen bis zur angegebenen Größe in den Speicher, bis ein abschließendes $NUL-Byte in der Quellzeichenfolge gefunden wird. Wenn in der Zeichenfolge kein $NUL gefunden wird, wird automatisch eines angehängt. Es liegt in der Verantwortung des Programmierers, sicherzustellen, dass POKE$ den Zielspeicherbereich nicht überläuft, um Datenbeschädigung oder Schutzfehler zu vermeiden.

POKE$$ speichert die Zeichen von StringExpr als aufeinanderfolgende 2-Byte-Wörter im Speicher. Wenn WSTRINGZ angegeben ist, schreibt POKE$$ aufeinanderfolgende Breitzeichen bis zur angegebenen Größe, bis ein abschließendes $NUL in der Quellzeichenfolge gefunden wird. Wenn in der Zeichenfolge kein $NUL gefunden wird, wird automatisch eines hinzugefügt. Es liegt in der Verantwortung des Programmierers, sicherzustellen, dass POKE$$ den Zielspeicherbereich nicht überläuft, um Datenbeschädigungen oder Schutzfehler zu vermeiden.

Getesteter PBXB64-Umfang: examples/basic/test_peek_poke_string.pb validiert typisierte POKE(BYTE, address, value)-Byte-Schreibzugriffe und POKE$ address, string-Byte-String-Schreibzugriffe. tests/pb/test_peek_poke_wide_string.pb validiert POKE$$ address, wideString als UTF-16-Codeunit-Schreibzugriff ohne impliziten Terminator und POKE$$ WSTRINGZ, address, wideString als Schreibzugriff mit angehaengtem UTF-16-NUL-Terminator. Die Beispiele sind in tests/validate.toml registriert und laufen in der pb_linkrun-Lane.

Im Gegensatz zu intuitiven Vorstellungen werden PEEK und POKE auf dem gleichen hohen Leistungsniveau ausgeführt wie Zeigervariablen. Sie bieten in vielen Situationen eine hervorragende Alternative zu Zeigern.

Adresse???

Eine gültige 32-Bit-Speicheradresse, die den Speicherort angibt, an dem die Datenspeicherung beginnen soll.

Datenwert

Der Datenwert, der unter Adresse??? gespeichert werden soll .

StringExpr

Eine Zeichenfolgenkonstante, ein Literal oder ein Ausdruck, der die im Speicher zu speichernde Zeichenfolge angibt, beginnend bei Address??? .

Einschränkungen

Wenn POKE versucht, auf Speicher zuzugreifen, der der Anwendung nicht zugewiesen ist, generiert Windows eine allgemeine Schutzverletzung (GPF) und beendet die Anwendung. GPFs können nicht eingefangen werden.

Siehe auch

  • GLOBALMEM ALLOC
  • ERINNERUNG
  • BLICK
  • STRPTR
  • VARPTR

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für STICK soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' STICK mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


POWERARRAY-Objekt – PBXB64-Compiler-Hilfe

Startseite › Funktionen › POWERARRAY-Objekt

POWERARRAY-Objekt

Das PowerArray-Objekt kapselt die Windows-SAFEARRAY-Struktur. Jedes Objekt enthält genau ein SAFEARRAY und ermöglicht Ihnen das einfache Lesen, Schreiben und Bearbeiten der Elemente.

Typ:Schlüsselwort |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Beschreibung

Alle Array-Operationen werden mit METHOD- und PROPERTY-Aufrufen für ein PowerArray-Objekt ausgeführt. Wenn Sie ein PowerArray erstellen oder untersuchen, wird der spezifische Datentyp durch die folgenden VT-Codes identifiziert. Alle sind im Compiler vordefiniert. VT-Codes mit einer Nummer über 200 gelten nur für PowerBASIC. Andere Programmiersprachen erkennen sie nicht und führen zu undefinierten Ergebnissen.

%vt_i2 = 2 %vt_ui4 = 19

%vt_i4 = 3 %vt_i8 = 20

%vt_r4 = 4 %vt_int = 22

%vt_r8 = 5 %vt_uint = 23

%vt_cy = 6 %vt_ptr = 26

%vt_date = 7 %vt_userdefined = 29

%vt_bstr = 8 %vt_filetime = 64

%vt_dispatch = 9 %vt_astr = 201

%vt_bool = 11 %vt_stringfix = 203

%vt_variant = 12 %vt_wstringfix = 204

%vt_unknown = 13 %vt_stringz = 205

%vt_decimal = 14 %vt_wstringz = 206

%vt_i1 = 16 %vt_type = 211

%vt_ui1 = 17 %vt_ext = 221

%vt_ui2 = 18 %vt_curx = 222

Die Array-Abmessungen werden zum Zeitpunkt der Array-Erstellung durch Ausführen der DIM-Methode angegeben. Der ByRef Bounds-Parameter verweist auf einen PowerBounds-UDT, der im Compiler vordefiniert ist. Bound ist ein PowerBOUND UDT zur Verwendung mit RedimPreserve . Es ist auch im Compiler vordefiniert.

TYP PowerBounds

Elemente1 SO LANG

LowBound1 SO LANG

Elemente2 SO LANG

LowBound2 SO LANG

Elemente3 SO LANG

LowBound3 SO LANG

Elements4 SO LANG

LowBound4 SO LANG

END-TYP

TYP PowerBound

Elemente so lang

LowBound SO LANG

END-TYP

Diese Klasse heißt PowerArray und die Schnittstelle heißt IPowerArray. Sollte einer der folgenden Vorgänge fehlschlagen, gibt die Funktion OBJRESULT ein Ergebnis ungleich Null anstelle von %S_OK (Null) zurück.

IPowerArray-Methoden/Eigenschaften

METHODE ARRAYBASE () ALS DWORD <1>

Diese Methode gibt die Adresse des ersten Elements des Arrays zurück.

METHODE ARRAYDESC () ALS DWORD <2>

Diese Methode gibt die Adresse des SAFEARRAY-Deskriptors zurück.

PROPERTY GET ARRAYINFO () AS WString <3>

Sie können zu Informations- oder Dokumentationszwecken eine breite Textzeichenfolge an ein Array anhängen. Diese Get-Eigenschaft ruft die Infozeichenfolge ab, sofern eine vorhanden ist.

PROPERTY SET ARRAYINFO () = WString <3>

Sie können zu Informations- oder Dokumentationszwecken eine breite Textzeichenfolge an ein Array anhängen. Diese Set-Eigenschaft weist dem Array eine breite dynamische Zeichenfolge zu.

METHODENKLON (PowerArray) <4>

Der Parameter PowerArray ist ein weiteres Objekt derselben Klasse wie dieses Objekt, nämlich PowerArray. Es wird ein exaktes Duplikat des SafeArray im Parameter erstellt und in diesem Objekt gespeichert.

METHODE COPYFROMVARIANT (ByRef Variant) <5>

Es wird eine exakte Kopie des im Parameter Variant enthaltenen SafeArray erstellt. Die Array-Kopie wird in diesem PowerArray-Objekt gespeichert.

METHODE COPYTOVARIANT (ByRef Variant) <6>

In diesem Objekt wird eine exakte Kopie des SafeArray erstellt. Die Array-Kopie wird im Parameter Variant gespeichert. In einer Variante dürfen nur Arrays von Datenelementen gespeichert werden, die mit der Automatisierung kompatibel sind. Datentypen, die PowerBASIC-spezifisch sind, können nicht kopiert werden.

METHODE DIM (ByVal VT&, ByVal Subscripts&, ByRef Bounds, OPTIONAL ByVal SIZE) <9>

Dimensioniert (erstellt) ein neues Array. Der VT&-Parameter wird durch einen der in den Anmerkungen aufgeführten %VT-Werte angegeben. Subscripts& ist die Anzahl der Dimensionen (1 bis 4), Bounds ist ein PowerBounds-UDT, der mit der Untergrenze und Größe jeder Dimension vorab gefüllt ist. Der optionale Parameter SIZE gibt die Größe (in Bytes) jedes Elements an. SIZE wird nur mit %vt_stringfix, %vt_wstringfix, %vt_stringz, %vt_wstringz und %vt_type verwendet.

METHODE ERASE () <10>

Das enthaltene Array wird zerstört und das Objekt gilt dann als leer.

METHODE ELEMENTPTR (ByVal Index1& , Opt ByVal Index2& , _

Opt ByVal Index3& , Opt ByVal Index4& ) AS LONG <11>

Berechnet und ruft die Adresse des Datenelements ab, das durch die Indexparameter angegeben wird.

METHODE ELEMENTSIZE () <12>

Ruft die Speichergröße (in Bytes) jedes Datenelements des Arrays ab.

METHODE LBOUND ( Subscript& ) AS LONG <13>

Ruft die untere Grenzzahl für die durch den Parameter „Subscript&“ angegebene Dimension ab. Der erste Index ist 1, der zweite ist 2 usw.

METHODENSPERRE () <14>

Erhöht die Sperranzahl des SAFEARRAY. Sperren können verschachtelt werden, es muss jedoch die gleiche Anzahl an Entsperrungen ausgeführt werden.

METHODE MOVEFROMVARIANT (ByRef Variant) <17>

Überträgt den Besitz des im Variant-Parameter enthaltenen SafeArray auf dieses PowerArray-Objekt. Die Variante wird dann in %vt_empty geändert.

METHODE MOVETOVARIANT (ByRef Variant) <18>

Überträgt den Besitz des in diesem PowerArray-Objekt enthaltenen SafeArray auf den Variantenparameter. Das PowerArray-Objekt wird dann in leer geändert.

METHODE REDIM (ByVal VT&, ByVal Subscripts&, ByRef Bounds, OPTIONAL ByVal SIZE) <19>

Mit REDIM kann das SafeArray gelöscht und auf eine neue Größe neu dimensioniert werden. Es ist eigentlich nur eine Abkürzung für den zweistufigen Prozess ERASE, gefolgt von DIM. Der VT&-Parameter wird durch einen der in den Anmerkungen aufgeführten %VT-Werte angegeben. Subscripts& ist die Anzahl der Dimensionen (1 bis 4), Bounds ist ein PowerBounds-UDT, der mit der Untergrenze und Größe jeder Dimension vorab gefüllt ist. Der optionale Parameter SIZE gibt die Größe (in Bytes) jedes Elements an. SIZE wird nur mit %vt_stringfix, %vt_wstringfix, %vt_stringz, %vt_wstringz und %vt_type verwendet.

METHODE REDIMPRESERVE (ByRef Bound ) <20>

Mit REDIMPRESERVE kann die niedrigstwertige (ganz rechts stehende) Grenze auf eine neue Größe geändert werden. Die übrigen Datenelemente im Array bleiben erhalten. Bound ist ein PowerBound-UDT, der mit der Untergrenze und der Größe der zu ändernden Dimension vorgefüllt ist.

METHODE RESET () <21>

Alle Elemente im SafeArray werden auf ihren ursprünglichen Standardwert zurückgesetzt. Numerische Zeichen werden auf Null gesetzt, Zeichenfolgen auf die Länge Null, Varianten auf %vt_empty und Objektvariablen werden auf nichts gesetzt. Der Array-Speicher wird nicht freigegeben.

METHODE ABONNEMENTS () <22>

Ruft die Anzahl der Dimensionen (Indizes) für dieses Array ab.

METHODE UBOUND ( Subscript& ) AS LONG <23>

Ruft die obere Grenzzahl für die durch den Parameter „Subscript&“ angegebene Dimension ab. Der erste Index ist 1, der zweite ist 2 usw.

METHODE UNLOCK () <24>

Verringert die Sperranzahl des SAFEARRAY. Sperren können verschachtelt werden, es muss jedoch die gleiche Anzahl an Entsperrungen ausgeführt werden.

METHODE VALUEGET (ByRef GetVar , ByVal Index1& , Opt ByVal Index2& , _

Opt ByVal Index3& , Opt ByVal Index4& ) AS LONG <25>

Berechnet den Wert des durch die Indexparameter angegebenen Array-Elements und ruft ihn ab. Dieser Wert wird dann der GetVar-Variablen zugewiesen. Es liegt in der Verantwortung des Programmierers sicherzustellen, dass der Typ von GetVar genau mit dem Typ des Arrays übereinstimmt.

METHODE VALUESET (ByRef SetVar , ByVal Index1& , Opt ByVal Index2& , _

Opt ByVal Index3& , Opt ByVal Index4& ) AS LONG <26>

Weist den Wert der SetVar-Variablen dem Array-Element zu, das durch die Indexparameter angegeben wird. Es liegt in der Verantwortung des Programmierers sicherzustellen, dass der Typ von SetVar genau mit dem Typ des Arrays übereinstimmt.

METHODE VALUETYPE () <27>

Ruft den %VT-Code ab, der die in diesem Array enthaltenen Daten beschreibt. Die %VT-Codes sind im Abschnitt „Bemerkungen“ oben aufgeführt.

Das PowerArray-Objekt kapselt die Windows-SAFEARRAY-Struktur. Jedes Objekt enthält genau ein SAFEARRAY und ermöglicht Ihnen das einfache Lesen, Schreiben und Bearbeiten der Elemente.

Das SAFEARRAY gilt im Allgemeinen als der kleinste gemeinsame Nenner von Arrays. Es ist nicht so schnell wie ein Standard-PowerBASIC-Array, erfüllt aber einen hervorragenden Zweck: Es handelt sich um eine „Standard“-Form von Array-Daten, die zum Übertragen von Daten zwischen Programmen, Modulen und sogar DLLs verwendet werden kann, die mit verschiedenen Versionen des Compilers erstellt wurden. Abgesehen von der Möglichkeit hinzugefügter Datentypen gehen wir nicht davon aus, dass sich das interne Format in absehbarer Zeit ändern wird.

Ein SAFEARRAY ist häufig in einer VARIANT-Variablen enthalten. Normalerweise werden Sie jedoch feststellen, dass das Array durch einen 32-Bit-Zeiger auf seinen Array-Deskriptor referenziert und identifiziert wird.

Siehe auch

  • ARRAY-ZUWEISUNG
  • ARRAY LÖSCHEN
  • ARRAY-EINSATZ
  • ARRAY-SCAN
  • ARRAY-SORTIERUNG
  • DIM
  • LBOUND
  • REDIM
  • UBOUND

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für POWERARRAY-Objekt soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' POWERARRAY-Objekt mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


IPowerTime.AddDays-Methode – PBXB64-Compiler-Hilfe

Startseite › Funktionen › IPowerTime.AddDays-Methode

IPowerTime.AddDays-Methode

Ein PowerTime-Objekt enthält einen Datums- und Zeitwert, der einfache Berechnungen ermöglicht. Die interne Darstellung emuliert die Windows-FILETIME-Struktur als

Typ:Schlüsselwort |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Beschreibung

The Dispatch ID (DispID) for each member method is displayed within angle brackets.

Eine unmittelbare Verwendung für das PowerTime-Objekt ist das integrierte numerische Equate %PB_COMPILETIME . Jedes Mal, wenn Sie Ihr Programm kompilieren, wird dieses Equater mit dem aktuellen Datum und der aktuellen Uhrzeit der Kompilierung im PowerTime-Binärformat gefüllt. Mit der PowerTIME-Klasse können Sie es zur Verwendung in Ihrer Anwendung in ein Textäquivalent konvertieren.

LOCAL ALS IPowerTime aufgebaut

LET Built = KLASSE „PowerTime“

Built.FileTime = %PB_COMPILETIME

MSGBOX Built.DateString

MSGBOX Built.TimeString

POWERTIME-Methoden

AddDays <1> (ByVal Days& )

Addiert die angegebene Anzahl von Tagen zum Wert dieses Objekts. Sie können Tage subtrahieren, indem Sie eine negative Zahl verwenden.

AddHours <2> (ByVal Hours& )

Addiert die angegebene Anzahl von Stunden zum Wert dieses Objekts. Sie können Stunden subtrahieren, indem Sie eine negative Zahl verwenden.

AddMinutes <3> (ByVal Minutes& )

Addiert die angegebene Anzahl von Minuten zum Wert dieses Objekts. Sie können Minuten subtrahieren, indem Sie eine negative Zahl verwenden.

AddMonths <4> (ByVal Months& )

Addiert die angegebene Anzahl von Monaten zum Wert dieses Objekts. Sie können Monate subtrahieren, indem Sie eine negative Zahl verwenden.

AddMSeconds <5> (ByVal Millisekunden& )

Fügt die angegebene Anzahl von Millisekunden zum Wert dieses Objekts hinzu. Sie können Millisekunden subtrahieren, indem Sie eine negative Zahl verwenden.

AddSeconds <6> (ByVal Seconds& )

Addiert die angegebene Anzahl von Sekunden zum Wert dieses Objekts. Sie können Sekunden subtrahieren, indem Sie eine negative Zahl verwenden.

AddTicks <7> (ByVal Ticks& )

Fügt die angegebene Anzahl von Ticks zum Wert dieses Objekts hinzu. Sie können Ticks subtrahieren, indem Sie eine negative Zahl verwenden.

AddYears <8> (ByVal Years& )

Addiert die angegebene Anzahl von Jahren zum Wert dieses Objekts. Sie können Jahre subtrahieren, indem Sie eine negative Zahl verwenden.

DateDiff <11> ( PowerTime , Sign& , Years& , Months& , Days& )

Der Datumsteil des internen PowerTime-Objekts wird mit dem Datumsteil des angegebenen externen PowerTime-Objekts verglichen. Der Tageszeitteil wird jeweils ignoriert. Die Differenz wird den von Ihnen angegebenen Parametervariablen zugewiesen. Sign& ist -1, wenn der interne Wert kleiner ist. Sign& ist 0, wenn die Werte gleich sind. Sign& ist +1, wenn der interne Wert größer ist. Die anderen Parameter geben den Unterschied als positive Ganzzahlwerte an. Wenn Parameter ungültig sind, wird in OBJRESULT ein entsprechender Fehlercode zurückgegeben.

DateString <12> (OPT ByVal LCID& ) AS String

Gibt die Datumskomponente des PowerTime-Objekts zurück, ausgedrückt als

. Das Datum wird basierend auf dem LCID&-Parameter für das Gebietsschema formatiert. Wenn LCID& Null ist oder nicht angegeben ist, wird die Standard-LCID für den Benutzer ersetzt.

DateStringLong <13> (OPT ByVal LCID& ) AS WString

Gibt die Datumskomponente des PowerTime-Objekts zurück, ausgedrückt als Zeichenfolge, mit einem vollständigen alphabetischen Monatsnamen. Das Datum wird basierend auf dem LCID&-Parameter für das Gebietsschema formatiert. Wenn LCID& Null ist oder nicht angegeben ist, wird die Standard-LCID für den Benutzer ersetzt.

Tag <15> () AS Long

Gibt die Day-Komponente des PowerTime-Objekts zurück. Es ist ein

Wert im Bereich von 1-31.

DayOfWeek <16> () AS Long

Gibt die Day-of-Week-Komponente des PowerTime-Objekts zurück. Es handelt sich um einen numerischen Wert im Bereich von 0 bis 6 (der Sonntag bis Samstag darstellt).

DayOfWeekString <17> (OPT ByVal LCID& ) AS WString

Gibt den Wochentagsnamen des PowerTime-Objekts zurück, ausgedrückt als Zeichenfolge (Sonntag, Montag...). Der Tagesname ist basierend auf dem LCID&-Parameter für das Gebietsschema geeignet. Wenn LCID& Null ist oder nicht angegeben ist, wird die Standard-LCID für den Benutzer ersetzt.

DaysInMonth <18> () AS Long

Gibt die Anzahl der Tage zurück, aus denen der Monat des Datums des PowerTime-Objekts besteht. Dies ist ein numerischer Wert im Bereich von 28-31.

PROPERTY GET FileTime <20> () AS Quad

Gibt einen Quad-Integer-Wert des PowerTime-Objekts als FileTime zurück.

PROPERTY SET FileTime <20> (ByVal FileTime&& )

Der durch den Parameter angegebene FileTime Quad-Integer-Wert wird als PowerTime-Objektwert zugewiesen.

Stunde <21> () als lang

Gibt die Stundenkomponente des PowerTime-Objekts zurück. Es handelt sich um einen numerischen Wert im Bereich von 0-23.

IsLeapYear <22> () as Long

Gibt true/false (-1/0) zurück, um festzustellen, ob das Jahr des PowerTime-Objekts ein Schaltjahr ist.

Minute <23> () als lang

Gibt die Minutenkomponente des PowerTime-Objekts zurück. Dies ist ein numerischer Wert im Bereich von 0-59.

Monat <24> () as Long

Gibt die Monatskomponente des PowerTime-Objekts zurück. Dies ist ein numerischer Wert im Bereich von 1-12.

MonthString <25> () AS String

Gibt die Monatskomponente des PowerTime-Objekts zurück, ausgedrückt als Zeichenfolge (Januar, Februar...).

MSecond <26> () as Long

Gibt die Millisekundenkomponente des PowerTime-Objekts zurück. Dies ist ein numerischer Wert im Bereich von 0-999.

NewDate <27> (ByVal Year& , Opt ByVal Month& , Opt ByVal Day& )

Der Datumskomponente des PowerTime-Objekts wird basierend auf den angegebenen Parametern ein neuer Wert zugewiesen. Die Zeitkomponente bleibt unverändert. Wenn Parameter ungültig sind, wird in OBJRESULT ein entsprechender Fehlercode zurückgegeben.

NewTime <28> (ByVal Hour& , Opt ByVal Min& , Opt ByVal Sec& , Opt ByVal MSec& , Opt ByVal Tick& )

Der Zeitkomponente des PowerTime-Objekts wird basierend auf den angegebenen Parametern ein neuer Wert zugewiesen. Die Datumskomponente bleibt unverändert. Wenn Parameter ungültig sind, wird in OBJRESULT ein entsprechender Fehlercode zurückgegeben.

Jetzt <29> ()

Diesem PowerTime-Objekt wird das aktuelle lokale Datum und die aktuelle Uhrzeit auf diesem Computer zugewiesen.

NowUTC <30> ()

Diesem PowerTime-Objekt wird das aktuelle koordinierte universelle Datum und die aktuelle koordinierte Weltzeit (UTC) zugewiesen.

Zweiter <31> () als Long

Gibt die zweite Komponente des PowerTime-Objekts zurück. Dies ist ein numerischer Wert im Bereich von 0-59.

Kreuzen Sie <32> () als Lang an

Gibt die Tick-Komponente des PowerTime-Objekts zurück. Dies ist ein numerischer Wert im Bereich von 0-999.

TimeDiff <33> ( PowerTime , Sign& , Days& , OPT Hours& , OPT Minutes& , OPT Seconds& , OPT MSeconds&& , OPT Ticks&& )

Das interne PowerTime-Objekt wird mit dem angegebenen externen PowerTime-Objekt verglichen. Die Differenz wird den von Ihnen angegebenen Parametervariablen zugewiesen. Sign& ist -1, wenn der interne Wert kleiner ist. Sign& ist 0, wenn die Werte gleich sind. Das Vorzeichen ist +1, wenn der interne Wert größer ist. Die anderen Parameter geben den Unterschied als positive Ganzzahlwerte an. Wenn Sie den Zeitunterschied in Einheiten zurückgeben möchten, die kleiner als Tage sind, füllen Sie die unerwünschten Parameter mit BYVAL 0 und sie werden ignoriert. Zum Beispiel:

ThisObject .TimeDiff( ThatObject , Sign& , BYVAL 0 , BYVAL 0 , Minutes& )

Wenn die Differenz im obigen Beispiel genau einen Tag betragen würde, würde Minutes& (24 Stunden * 60 Minuten) der Wert 1440 zugewiesen. Wenn Parameter ungültig sind, wird in OBJRESULT ein entsprechender Fehlercode zurückgegeben.

TimeString <34> () AS String

Gibt die Zeitkomponente des PowerTime-Objekts zurück, ausgedrückt als Zeichenfolge. Die Uhrzeit ist im Format hh:mm AM/PM formatiert.

TimeString24 <35> () AS WString

Gibt die Zeitkomponente des PowerTime-Objekts zurück, ausgedrückt als Zeichenfolge. Die Uhrzeit wird als hh:mm im 24-Stunden-Format formatiert.

TimeStringFull <36> () AS WString

Gibt die Zeitkomponente des PowerTime-Objekts zurück, ausgedrückt als Zeichenfolge. Die Uhrzeit wird als hh:mm:ss.mmm im 24-Stunden-Format formatiert.

Heute <38> ()

Diesem PowerTime-Objekt wird das aktuelle lokale Datum auf diesem Computer zugewiesen. Dies ist für Anwendungen geeignet, die nur mit Datumsangaben arbeiten.

ToLocalTime <39> ()

Das PowerTime-Objekt wird in die Ortszeit konvertiert. Es wird davon ausgegangen, dass der vorherige Wert in der koordinierten Weltzeit (UTC) angegeben war.

ToUTC <40> ()

Das PowerTime-Objekt wird in die koordinierte Weltzeit (UTC) konvertiert. Es wird davon ausgegangen, dass der vorherige Wert in Ortszeit angegeben wurde.

Jahr <42> () as Long

Gibt die Jahreskomponente des PowerTime-Objekts als numerischen Wert zurück.

Ein PowerTime-Objekt enthält einen Datums- und Zeitwert, der einfache Berechnungen ermöglicht. Die interne Darstellung emuliert die Windows-FILETIME-Struktur als Quad-Integer. Dieser Wert stellt die Anzahl der 100-Nanosekunden-Intervalle seit dem 1. Januar 1601 dar. Eine Nanosekunde ist ein Milliardstel einer Sekunde.

Sie erstellen ein PowerTime-Objekt auf die gleiche Weise wie andere Objekte, verwenden jedoch eine vordefinierte interne Klasse und eine vordefinierte interne Schnittstelle.

LOCAL MyTime ALS IPowerTime

LET MyTime = CLASS „PowerTime“

Siehe auch

  • DATUM$
  • TAGNAME$
  • MONTHNAME$
  • ZEIT$

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für IPowerTime.AddDays-Methode soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' IPowerTime.AddDays-Methode mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


PRESERVE - Arrayinhalte bei REDIM behalten — PBXB64 Help

Startseite › General Reference › PRESERVE - Arrayinhalte bei REDIM behalten — PBXB64 Help
Hilfe zum PBXB64-Compiler

PRESERVE - Arrayinhalte bei REDIM behalten

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

REDIM PRESERVE values(10)

Detailverhalten

REDIM-Klausel, die vorhandene dynamische Arrayinhalte beim Aendern der Groesse im unterstuetzten Rahmen beibehaelt.

Praktische Verwendung

Verwenden Sie PRESERVE nur als REDIM-Klausel, wenn bestehende Arrayinhalte erhalten bleiben sollen. Es ist kein freistehender Befehl.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

PRESERVE ausserhalb von REDIM ist nicht die hier dokumentierte Form. Ein Test muss zeigen, dass bestehende Inhalte erhalten bleiben und Randfaelle nicht stillschweigend zerstoert werden.

Verifiziertes Beispiel

Abgedeckt durch examples/basic/test_variant_dyn_array.pb (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PRINTER$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DRUCKER$

DRUCKER$

Rufen Sie Druckernamen und Druckerportnamen ab.

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Beschreibung

Printernum& gibt die Druckernummer von 1 bis PRINTERCOUNT an. Wenn die Option NAME an der ersten Position angegeben ist, wird der Druckername zurückgegeben. Wenn stattdessen die Option PORT angegeben wird, wird der Portname (z. B. LPT1) zurückgegeben.

Beschreibung

DRUCKER$ gehoert zur Druckeroberflaeche. PRINTERCOUNT meldet die installierten Drucker, und PRINTER$ gibt Druckernamen oder Portnamen zurueck. Die Beispiele unten verwenden den aktuellen, getesteten Ueberpruefungsweg.

Syntax

n& = PRINTERCOUNT
device$ = PRINTER$([NAME | PORT], printernum&)

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN () AS LONG
    LOCAL n AS LONG
    n = PRINTERCOUNT
    IF n < 0 THEN FUNCTION = 1
END FUNCTION

Validierungsbeleg

Validierungsbeleg: examples/basic/test_printer_api.pb prueft den Installationszaehler, die leere Rueckgabe bei fehlenden Druckern sowie die Namens- und Portabfrage ueber PRINTER$.

Laufzeitvoraussetzungen

Die Beispiele laufen auch ohne installierten Standarddrucker, aber ein echter Drucker liefert mehr Rueckgabedaten. Behandeln Sie einen Null- oder Leerwert als gueltigen Zustand und lesen Sie die konkrete Liste erst dann aus, wenn PRINTERCOUNT groesser als Null ist.

Siehe auch

  • PRINTERCOUNT
  • PRINTER$
  • LPRINT ATTACH
  • XPRINT ATTACH


PRINTERCOUNT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › PRINTERCOUNT

DRUCKERANZAHL

Rufen Sie die Anzahl der verfügbaren (installierten) Drucker ab.

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Beschreibung

DRUCKERANZAHL gehoert zur Druckeroberflaeche. PRINTERCOUNT meldet die installierten Drucker, und PRINTER$ gibt Druckernamen oder Portnamen zurueck. Die Beispiele unten verwenden den aktuellen, getesteten Ueberpruefungsweg.

Syntax

n& = PRINTERCOUNT
device$ = PRINTER$([NAME | PORT], printernum&)

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN () AS LONG
    LOCAL n AS LONG
    n = PRINTERCOUNT
    IF n < 0 THEN FUNCTION = 1
END FUNCTION

Validierungsbeleg

Validierungsbeleg: examples/basic/test_printer_api.pb prueft den Installationszaehler, die leere Rueckgabe bei fehlenden Druckern sowie die Namens- und Portabfrage ueber PRINTER$.

Laufzeitvoraussetzungen

Die Beispiele laufen auch ohne installierten Standarddrucker, aber ein echter Drucker liefert mehr Rueckgabedaten. Behandeln Sie einen Null- oder Leerwert als gueltigen Zustand und lesen Sie die konkrete Liste erst dann aus, wenn PRINTERCOUNT groesser als Null ist.

Siehe auch

  • PRINTERCOUNT
  • PRINTER$
  • LPRINT ATTACH
  • XPRINT ATTACH


Druckübersicht – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Druckübersicht

Druckübersicht

Übersicht über Druckbefehle einschließlich LPRINT und XPRINT.

Typ:Konzeptionell |Kategorie: Drucken

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Überblick

Dieses Thema bietet Hintergrundinformationen und praktische Anleitungen. Eine detaillierte Syntax finden Sie auf den entsprechenden Befehlsseiten.

Siehe auch

  • Befehlsindex

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Druckübersicht soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Druckübersicht mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Druckbefehle – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Druckbefehle

Druckbefehle

Referenzliste druckbezogener Befehle.

Typ:Konzeptionell |Kategorie: Drucken

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Überblick

Dieses Thema bietet Hintergrundinformationen und praktische Anleitungen. Eine detaillierte Syntax finden Sie auf den entsprechenden Befehlsseiten.

Beschreibung

Diese Uebersichtsseite fasst die Drucker- und Druckausgabeoberflaeche zusammen. Die verlinkten Einzelseiten dokumentieren die getesteten Funktionen; diese Seite beschreibt nur den Navigations- und Vertragsrahmen.

Uebersicht

Verwenden Sie PRINTERCOUNT und PRINTER$, um installierte Drucker und deren Namen oder Ports abzufragen. Fuer echte Druckausgabe folgen Sie den Seiten zu LPRINT ATTACH und XPRINT ATTACH.

Syntax

PRINTERCOUNT
PRINTER$( [NAME | PORT], printernum& )
LPRINT ATTACH device$
XPRINT ATTACH {DEFAULT | PrinterName$} [, JobName$ ]

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN () AS LONG
    LOCAL n AS LONG
    n = PRINTERCOUNT
    IF n < 0 THEN FUNCTION = 1
END FUNCTION

Validierungsbeleg

Validierungsbeleg: examples/basic/test_printer_api.pb belegt die aktuelle Druckerabfrage. Druckausgabe selbst bleibt auf die entsprechenden Anhangs- und Druckseiten begrenzt.

Laufzeitvoraussetzungen

Die Beispiele laufen auch ohne installierten Standarddrucker, aber ein echter Drucker liefert mehr Rueckgabedaten. Behandeln Sie einen Null- oder Leerwert als gueltigen Zustand und lesen Sie die konkrete Liste erst dann aus, wenn PRINTERCOUNT groesser als Null ist. Die Druckausgabe selbst gehoert auf die einzelnen LPRINT- und XPRINT-Seiten.

Siehe auch

  • PRINTERCOUNT
  • PRINTER$
  • LPRINT ATTACH
  • XPRINT ATTACH


Private und exportierte Prozeduren – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Private und exportierte Prozeduren

Private und exportierte Verfahren

Es gibt zwei grundlegende Arten von Prozeduren in einer DLL: private und exportierte. Exportierte Prozeduren sind solche, die Anwendungen und anderen DLLs zur Verfügung gestellt werden. Private oder lokale Verfahren werden unterstützt

Typ:Schlüsselwort |Kategorie: Procedures

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Im folgenden Beispiel definiert die erste Prozedur ein exportiertes Sub, das zwei Argumente akzeptiert: einen String und einen Integer . Die zweite Prozedur definiert eine exportierte Funktion, die ein einzelnes Zeichenfolgenargument akzeptiert und eine Ganzzahl zurückgibt. Schließlich definiert die dritte Prozedur ein privates Sub, das ein einzelnes Integer-Argument akzeptiert. Die ersten beiden Routinen können von einer externen .EXE-Datei oder einer anderen DLL aufgerufen werden. Der Dritte ist es nicht.

SUB MySub (sArg AS STRING, BYVAL iArg AS INTEGER) EXPORT

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Private und exportierte Verfahren soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Private und exportierte Verfahren mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


PROZESS ERHALTEN PRIORITÃ„T “ PBXB64-Compiler-Hilfe

Startseite â€º Funktionen â€º PROZESS ERHALTEN PRIORITÃ„T

PROZESS ERHALTEN PRIORITÃ„T

Rufen Sie den Prioritätswert für den Strom ab

Typ:Anweisung |Kategorie: Einfädeln

PBXB64-Status:VERFÃœGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

PROCESS GET PRIORITY TO lResult&

Beschreibung

PROCESS GET PRIORITY ruft den Prioritätswert für den aktuellen Prozess ab. Der abgerufene Prioritätswert wird der durch lResult& angegebenen Long- oder Dword-Variablen zugewiesen.

Der Prozessprioritätswert ist einer der folgenden:

%IDLE_PRIORITY_CLASS = &H00000040

Gibt einen Prozess an, dessen Threads nur dann ausgeführt werden, wenn das System im Leerlauf ist und von den Threads aller Prozesse, die in einer höheren Prioritätsklasse ausgeführt werden, vorrangig sind. Ein Beispiel ist ein Bildschirmschoner. Die Leerlaufprioritätsklasse wird von untergeordneten Prozessen geerbt.

%NORMAL_PRIORITY_CLASS = &H00000020

Zeigt einen normalen Prozess ohne besondere Planungsanforderungen an.

%HIGH_PRIORITY_CLASS = &H00000080

Gibt einen Prozess an, der zeitkritische Aufgaben ausführt, die sofort ausgeführt werden müssen, damit er ordnungsgemäÃŸ ausgeführt wird. Die Threads eines Klassenprozesses mit hoher Priorität haben Vorrang vor den Threads von Klassenprozessen mit normaler oder inaktiver Priorität. Ein Beispiel ist die Windows-Aufgabenliste, die unabhängig von der Auslastung des Betriebssystems schnell reagieren muss, wenn sie vom Benutzer aufgerufen wird. Seien Sie äuÃŸerst vorsichtig, wenn Sie die Klasse mit hoher Priorität verwenden, da eine CPU-gebundene Anwendung mit hoher Priorität nahezu alle verfügbaren Zyklen nutzen kann.

%REALTIME_PRIORITY_CLASS = &H00000100

Zeigt einen Prozess an, der die höchstmögliche Priorität hat. Die Threads eines Echtzeit-Prioritätsklassenprozesses haben Vorrang vor den Threads aller anderen Prozesse, einschlieÃŸlich Betriebssystemprozessen, die wichtige Aufgaben ausführen. Beispielsweise kann ein Echtzeitprozess, der länger als ein sehr kurzes Intervall ausgeführt wird, dazu führen, dass Festplatten-Caches nicht geleert werden oder die Maus nicht reagiert.

Siehe auch

  • PROZESS SETZEN PRIORITÃ„T
  • Thread erhält Priorität
  • Thread-Set-Priorität

Kind: Reference topic | Category: Process Control

PBXB64 Status: AVAILABLE

Description

PROCESS GET PRIORITY reads the current priority class or priority setting for the process or thread target. Use it as the readback companion to the process priority setters.

Syntax

priority& = PROCESS GET PRIORITY(hProcess)

Validation Evidence

Validation evidence: The process-priority runtime tests cover the current readback contract and the supported priority-class values.

Example

priority& = PROCESS GET PRIORITY(-1)

See Also

  • cmd_process_set_priority.html
  • cmd_thread_get_priority.html
  • cmd_thread_set_priority.html

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PROZESS-SET-PRIORITÃ„T “ PBXB64-Compiler-Hilfe

Startseite â€º Funktionen â€º PROZESS-SET-PRIORITÃ„T

PROZESS SETZEN PRIORITÃ„T

Legt den Prioritätswert für den Strom fest

Typ:Anweisung |Kategorie: Einfädeln

PBXB64-Status:VERFÃœGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

PROCESS SET PRIORITY Priority&

Beschreibung

PROCESS SET PRIORITY weist dem aktuellen Prozess einen neuen Prioritätswert zu.

Der Prozessprioritätswert muss einer der folgenden sein:

%IDLE_PRIORITY_CLASS = &H00000040

Gibt einen Prozess an, dessen Threads nur ausgeführt werden, wenn das System inaktiv ist und von den Threads aller Prozesse, die in einer Klasse mit höherer Priorität ausgeführt werden, vorrangig sind. Ein Beispiel ist ein Bildschirmschoner. Die Leerlaufprioritätsklasse wird von untergeordneten Prozessen geerbt.

%NORMAL_PRIORITY_CLASS = &H00000020

Zeigt einen normalen Prozess ohne besondere Planungsanforderungen an.

%HIGH_PRIORITY_CLASS = &H00000080

Gibt einen Prozess an, der zeitkritische Aufgaben ausführt, die sofort ausgeführt werden müssen, damit er ordnungsgemäÃŸ ausgeführt wird. Die Threads eines Klassenprozesses mit hoher Priorität haben Vorrang vor den Threads von Klassenprozessen mit normaler oder inaktiver Priorität. Ein Beispiel ist die Windows-Aufgabenliste, die unabhängig von der Auslastung des Betriebssystems schnell reagieren muss, wenn sie vom Benutzer aufgerufen wird. Seien Sie äuÃŸerst vorsichtig, wenn Sie die Klasse mit hoher Priorität verwenden, da eine CPU-gebundene Anwendung mit hoher Priorität nahezu alle verfügbaren Zyklen nutzen kann.

%REALTIME_PRIORITY_CLASS = &H00000100

Zeigt einen Prozess an, der die höchstmögliche Priorität hat. Die Threads eines Echtzeit-Prioritätsklassenprozesses haben Vorrang vor den Threads aller anderen Prozesse, einschlieÃŸlich Betriebssystemprozessen, die wichtige Aufgaben ausführen. Beispielsweise kann ein Echtzeitprozess, der länger als ein sehr kurzes Intervall ausgeführt wird, dazu führen, dass Festplatten-Caches nicht geleert werden oder die Maus nicht reagiert.

Siehe auch

  • PROZESS ERHALTEN PRIORITÃ„T
  • Thread erhält Priorität
  • Thread-Set-Priorität

Kind: Reference topic | Category: Process Control

PBXB64 Status: AVAILABLE

Description

PROCESS SET PRIORITY changes the priority class or priority setting for a process or thread target. Keep the target handle and the requested class together so the caller can restore the original state afterward.

Syntax

PROCESS SET PRIORITY(hProcess, class&)

Validation Evidence

Validation evidence: The process-priority runtime tests prove the setter path and the current rejection behavior for invalid targets.

Example

PROCESS SET PRIORITY(-1, %HIGH_PRIORITY_CLASS)

See Also

  • cmd_process_get_priority.html
  • cmd_thread_set_priority.html

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PROFIL – PBXB64-Compiler-Hilfe

Startseite › Funktionen › PROFIL

PROFILE

Erfassen Sie einen Profilbericht mit detaillierten Angaben zur Gesamtausführungsdauer der

Typ:Anweisung |Kategorie: Utilities

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

PROFILE diskfilename$
PROFILE SET file$, section$, key$, value$
PROFILE GET file$, section$, key$ TO target$

Beschreibung

PBXB64 implementiert die getesteten INI-Lese- und Schreibformen PROFILE SET und PROFILE GET ... TO. Die Laufzeit schreibt und liest Stringwerte ueber die Windows-Profile-APIs, normalisiert relative Dateipfade gegen das aktuelle Prozessverzeichnis, liefert fuer fehlende Schluessel eine leere Zeichenfolge und bettet die benoetigten Helfer in den Single-EXE-Laufzeitpfad ein.

Die PBWin-Form fuer automatische Laufzeitberichte PROFILE diskfilename$ ist als Kompatibilitaetskontext dokumentiert, aber PBXB64 erzeugt fuer diese breite Form noch keine PBWin-artige Prozedurzeit-Instrumentierung oder Berichte.

Zum Zeitpunkt der Ausführung der PROFILE-Anweisung wird eine standardmäßige sequentielle Datei mit dem angegebenen Dateinamen diskfilename$ erstellt. Um die besten Ergebnisse in ausführbaren Dateien zu erzielen, sollte die PROFILE-Anweisung die letzte Anweisung sein, die in der Funktion PBMAIN/WINMAIN ausgeführt wird.

Der Profilbericht enthält eine Liste aller Prozeduren innerhalb desselben Moduls (EXE oder DLL), die Häufigkeit ihrer Aufrufe und die insgesamt verstrichene Zeit (in Millisekunden), die für die Ausführung aller Instanzen der Prozedur aufgewendet wurde. Diese Statistiken erscheinen in der Festplattendatei in dieser bestimmten Reihenfolge in jeder Zeile:

<Prozedurname>, <Anrufanzahl>,

Der Profilbericht beschreibt nur Prozeduren, die sich physisch innerhalb des Moduls (EXE oder DLL) befinden, in dem sich die PROFILE-Anweisung befindet. Prozeduren in einer externen EXE- oder DLL-Datei werden nicht einzeln profiliert. Die zum Aufrufen anderer Prozeduren und DLL-/API-Funktionen benötigte Zeit ist jedoch in der kumulierten Ausführungszeit der aufrufenden Prozedur enthalten.

Es wird dringend empfohlen, alle anderen Anwendungen zu schließen, wenn Sie ein Profil für eine PowerBASIC-Anwendung erstellen. Wenn eine Anwendung profiliert wird, muss PowerBASIC eine beträchtliche Menge an zusätzlichem Code generieren, um alle erforderlichen Informationen zu sammeln. Dieser zusätzliche Code wird immer dann generiert, wenn eine gültige PROFILE-Anweisung in Ihrem Programm erscheint, unabhängig davon, ob sie tatsächlich ausgeführt wird.

Für den endgültigen Produktionscode verwenden Sie die Metaanweisung #TOOLS OFF, um höchste Leistungsniveaus sicherzustellen.

Interpretation eines Profilberichts

Die Ausführungszeit verschachtelter Prozeduren muss verstanden werden, um ein klares „Bild“ der Ausführungszeiten zu erhalten. Betrachten Sie beispielsweise die folgenden Ergebnisse:

Vorgehensweise

MySubA,

MySubB,

Auf den ersten Blick deuten diese Ergebnisse möglicherweise auf einen „Engpass“ in MySubA hin, da MySubA 11016 Millisekunden benötigte, um nur einen Aufruf auszuführen, während die durchschnittliche Zeit für MySubB nur etwa 100 Millisekunden pro Aufruf betrug (10014 mSek / 100 Aufrufe = 100,14 mSek).

Wenn MySubB jedoch tatsächlich von MySubA aufgerufen wird, müssen die Ergebnisse anders bewertet werden. Wir könnten zum Beispiel sagen: „MySubB hat 10014 Millisekunden der 11016 Millisekunden der in MySubA verbrachten Zeit benötigt.“ Oder anders ausgedrückt: „Von den 11016 Millisekunden, die MySubA für die Ausführung benötigte, wurden 10014 Millisekunden dieser Zeit für die Ausführung von MySubB aufgewendet.“

Durch Interpolation dieser Ergebnisse kann leicht berechnet werden, dass die Ausführung des Codes in MySubA nur 1002 Millisekunden dauerte, diese jedoch aufgrund der Abhängigkeit von MySubB auf 11016 Millisekunden anstieg.

Daher würde eine Verbesserung der Leistung von MySubB die Gesamtgeschwindigkeit von MySubA deutlich verbessern und die Profilergebnisse beider Funktionen würden entsprechend verbessert.

Einschränkungen

Die Profilerstellung ist „aktiviert“, wenn die erste Prozedur, die eine PROFILE-Anweisung enthält, mit der Ausführung beginnt. Alle anschließend innerhalb dieser Prozedur ausgeführten Prozeduren werden profiliert.

Es ist nicht möglich, die eigentlichen PBMAIN- oder WINMAIN-Funktionen zu profilieren. Wenn eine PROFILE-Anweisung innerhalb von PBMAIN/WINMAIN auftritt, werden alle Prozeduren, die von PBMAIN/LIBMAIN aufgerufen werden, normal profiliert.

Wenn PBMAIN/WINMAIN Code enthält, der eine Profilerstellung erfordert, benennen Sie die Funktion einfach um und erstellen Sie eine neue PBMAIN/WINMAIN-Funktion, die die umbenannte Funktion sofort aufruft und dann eine PROFILE-Anweisung ausführt. Siehe das Beispiel unten.

Bei Anwendungscode mit verschachtelten und langwierigen Prozeduraufrufen führt die Addition der Gesamtzahl der Millisekunden in der letzten Spalte einer PROFILE-Datenträgerdatei normalerweise zu einer Zahl, die weitaus größer ist als die tatsächliche Zeit, die Ihr Programm zur Ausführung benötigt hat.

Die Zeitauflösung des Profilberichts ist durch das vom Betriebssystem unterstützte Quantum begrenzt (Win95/98 beträgt 54 mSek. und WinNT/2000/XP beträgt 10 mSek.) und kann durch alle anderen gleichzeitig ausgeführten Anwendungen beeinflusst werden. Dennoch kann PROFILE einen guten Einblick darüber bieten, welcher Code möglicherweise die meiste CPU-Zeit verbraucht und wo Optimierungsbemühungen konzentriert werden sollten.

Siehe auch

  • #TOOLS
  • CALLSTK
  • CALLSTK$
  • CALLSTKCOUNT
  • FUNCNAME$
  • TRACE

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


PROGID$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › PROGID$

PROGID$

Gibt die eindeutige alphanumerische PROGID-Zeichenfolge zurück

Typ:Funktion |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

a$ = PROGID$( ClassID$ )

Beschreibung

Eine PROGID-Zeichenfolge ist der eindeutige alphanumerische Textname, der einem bestimmten COM-Objekt/einer bestimmten COM-Komponente zugeordnet ist. Beispiel: „Word.Application.8“.

Mit der Funktion PROGID$ konvertieren Sie die 16-Byte (128-Bit) binäre Klassen-ID eines COM-Objekts/einer COM-Komponente in einen PROGID-String.

PROGID$ nimmt die (16-Byte-)Binärzeichenfolge ClassID$, die die GUID oder UUID eines COM-Objekts/einer COM-Komponente darstellt, und untersucht die Systemregistrierung, um die PROGID-Zeichenfolge zu ermitteln, die mit der ClassID$-Zeichenfolge verknüpft ist. ClassID$ kann eine dynamische Zeichenfolge oder eine Zeichenfolge fester Länge von mindestens 16 Bytes oder (normalerweise) eine GUID-Variable sein.

Wenn die ClassID$ nicht gefunden werden kann oder beim Suchvorgang ein Fehler auftritt, setzt PROGID$ die Systemvariable ERR nicht, sondern gibt eine leere Zeichenfolge zurück.

PROGID$ ist die Ergänzung zur CLSID$-Funktion. Durch die gemeinsame Nutzung dieser beiden Funktionen ist es möglich, die genaue Groß- und Kleinschreibung der PROGID aus der Systemregistrierung zu extrahieren. Siehe das Beispiel unten.

Siehe auch

  • DIM
  • CLSID$
  • GUID$
  • GUIDTXT$
  • INTERFACE (Direct)
  • INTERFACE (IDBind)
  • ISINTERFACE
  • ISNOTHING
  • ISOBJECT
  • Just what is COM?
  • LET (with Objects)
  • METHOD
  • OBJECT
  • OBJACTIVE
  • OBJPTR
  • OBJRESULT
  • PROPERTY
  • Was ist überhaupt ein Objekt?

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PROGRESSBAR GET POS – PBXB64-Compiler-Hilfe

Startseite› Funktionen › PROGRESSBAR GET POS

PROGRESSBAR GET POS

Manipulate a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

PROGRESSBAR GET POS hDlg , id& TO datav&
PROGRESSBAR GET RANGE hDlg , id& TO LoDatav& , HiDatav&
PROGRESSBAR SET POS hDlg , id& , position&
PROGRESSBAR SET RANGE hDlg , id& , lolimit& , hilimit&
PROGRESSBAR SET STEP hDlg , id& , stepval&
PROGRESSBAR STEP hDlg , id& [, incramt& ]

Beschreibung

In jedem der folgenden Beispiele und Beschreibungen wird das PROGRESSBAR-Steuerelement, das Gegenstand der Anweisung ist, durch das Handle des Dialogfelds identifiziert, das Eigentümer des ProgressBar-Steuerelements ( hDlg ) ist, sowie durch den eindeutigen Steuerelementbezeichner, den Sie ihm bei der Erstellung in CONTROL ADD PROGRESSBAR gegeben haben. Um die Farbe des Balkens oder des Hintergrunds zu ändern, verwenden Sie CONTROL SET COLOR .

PROGRESSBAR GET POS hdlg , id& TO datav&

Die aktuelle Position der ProgressBar wird abgerufen und der durch datav& bezeichneten Variablen zugewiesen.

PROGRESSBAR GET RANGE hdlg , id& TO LoDatav& , HiDatav&

Der aktuelle Bereich der ProgressBar wird abgerufen und den durch LoDatav& und HiDatav& bezeichneten Variablen zugewiesen. Bei der Erstellung von ProgressBar liegt der Standardbereich zwischen 0 und 100.

PROGRESSBAR SET POS hDlg , id& , position&

Die aktuelle Position der ProgressBar wird auf den Wert des Parameters position& gesetzt und der Balken wird neu gezeichnet, um die neue Position widerzuspiegeln.

PROGRESSBAR SET RANGE hdlg , id& , lolimit& , hilimit&

Der Bereich für ProgressBar ist von lolimit& bis hilimit& angegeben. Wenn lolimit& größer als hilimit& ist, sind die Ergebnisse undefiniert.

PROGRESSBAR SET STEP hDlg , id& , step&

Der von PROGRESSBAR STEP zu verwendende Standardinkrementwert wird durch den Parameter „stepval&“ angegeben.

PROGRESSBAR STEP hDlg , id& [, incramt& ]

Der ProgressBar ist „gestuft“. Die aktuelle Position wird um einen Schritt vorgerückt und der Balken wird neu gezeichnet, um die neue Position widerzuspiegeln. Wenn der optionale incramt&-Ausdruck enthalten ist, wird die Position stattdessen um diesen Betrag erhöht. Die Standardschrittweite beträgt 10 und der Standardbereich liegt zwischen 0 und 100.

PBXB64-Implementierungshinweise

PBXB64 implementiert alle oben gezeigten dokumentierten PROGRESSBAR-Anweisungsformen. Der Compiler reduziert sie auf eingebettete Win32-Laufzeithilfsprogramme mit gemeinsamer Steuerung. Für die ausführbare Datei des Kunden sind keine externen Objektdateien erforderlich.

Die Regressionssuite umfasst SET RANGE, SET POS, GET POS, SET STEP, STEP, STEP mit explizitem Inkrement und GET RANGE.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG FORTSCHRITTSBAR HINZUFÜGEN
  • STEUERUNG FARBE EINSTELLEN
  • STEUERUNG SET SCHRIFTART

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PROPERTY / END PROPERTY – PBXB64-Compiler-Hilfe

Startseite › Funktionen › EIGENTUM / END EIGENTUM

EIGENTUM / ENDEIGENTUM

Definieren Sie a

Typ:Anweisung |Kategorie: Procedures

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

[OVERRIDE] PROPERTY GET|SET name [< DispID >] [ALIAS " altname "] ( var AS type ...) [THREADSAFE] [AS type ]
[ statements ]
PROPERTY = expression
END PROPERTY

Beschreibung

PROPERTY/END PROPERTY wird verwendet, um eine PROPERTY-Prozedur innerhalb einer Klasse zu definieren. Eigenschaften können nur über eine virtuelle Funktionstabelle für ein aktives Objekt aufgerufen werden. Eine PROPERTY ist ein spezieller Typ von METHOD , der nur zum Festlegen oder Abrufen von Daten in einem Objekt verwendet wird. Während die Arbeit einer EIGENSCHAFT problemlos mit einer StandardMETHODE durchgeführt werden könnte, ist diese Unterscheidung praktisch, um das Konzept der Kapselung von Instanzdaten innerhalb eines Objekts hervorzuheben. Es gibt zwei Formen von PROPERTY-Prozeduren: PROPERTY GET und PROPERTY SET. Wie aus den Namen hervorgeht, wird das erste Formular zum Abrufen eines Datenwerts vom Objekt verwendet, während das zweite Formular zum Zuweisen eines Werts verwendet wird. Eigenschaften müssen innerhalb eines CLASS-Blocks definiert werden und dürfen nur innerhalb eines DECLARE CLASS-Blocks deklariert werden. Eigenschaften sind definiert:

PROPERTY GET name [ALIAS „altname“] (BYVAL var AS type...) [THREADSAFE] AS type

[Anweisungn]

PROPERTY = Ausdruck

END EIGENTUM

PROPERTY SET name [ALIAS „altname“] (BYVAL var AS type...) [THREADSAFE]

[Anweisungn]

Variable = Wert

END EIGENTUM

Wenn Sie PROPERTY SET verwenden, wird der zuzuweisende Wert wie bei einer normalen Zuweisung an eine Variable rechts von einem Gleichheitszeichen übergeben:

Eigenschaften können nur über eine virtuelle Funktionstabelle für ein aktives Objekt aufgerufen werden. Eigenschaftsparameter können einen beliebigen Variablentyp haben.

ObjVar.Prop1 = NeuerWert

Eine EIGENSCHAFT kann als „schreibgeschützt“ oder „schreibgeschützt“ betrachtet werden, indem einfach eine der beiden Definitionen weggelassen wird. Wenn jedoch sowohl GET- als auch SET-Formulare für eine bestimmte Eigenschaft definiert sind, müssen alle Parameter und der Eigenschaftsdatentyp in beiden Formularen identisch sein und sie müssen gepaart sein. Das heißt, der PROPERTY SET muss unmittelbar auf den PROPERTY GET folgen.

Eigenschaftsparameter können einen beliebigen Variablentyp haben.

Sie können auf ein PROPERTY GET zugreifen mit:

DIM ObjVar AS MyInterface

LET ObjVar = NEWCOM Prgid$

1. ObjVar.Prop1(param) TO var

2. CALL ObjVar.Prop1(param) TO var

3. var = ObjVar.Prop1(param)

Sie können auf ein PROPERTY SET zugreifen mit:

DIM ObjVar AS MyInterface

LET ObjVar = NEWCOM Prgid$

1. ObjVar.Prop1(param) = expr

2. CALL ObjVar.Prop1(param) = expr

Beachten Sie, dass die Auswahl der Eigenschaftsprozedur syntaxgesteuert ist. Mit anderen Worten: Je nachdem, wie Sie den Namen verwenden, entscheidet PowerBASIC automatisch, ob die GET- oder SET-PROPERTY aufgerufen werden soll.

In jeder Methode und Eigenschaft definiert PowerBASIC automatisch eine Pseudovariable namens ME , die als Referenz auf das aktuelle Objekt behandelt wird. Mit ME ist es möglich, jede andere Methode oder Eigenschaft aufzurufen, die Mitglied der Klasse ist: var = ME. Methode1 (param)

Methoden können deklariert werden (unter Verwendung des AS-Typs ...), um einen String, einen beliebigen numerischen Typ, eine bestimmte Klasse von Objektvariablen (AS MyClass), einen Variant oder einen benutzerdefinierten Type zurückzugeben.

Typbibliotheken unterstützen nur die folgenden Daten Typen: BYTE, WORD, DWORD, INTEGER, LONG, QUAD, SINGLE, DOUBLE, CURRENCY, OBJECT, STRING und VARIANT. Wenn Methoden oder Eigenschaften Datentypen verwenden, die von Typbibliotheken nicht unterstützt werden, erhalten Sie einen Fehler 581 – Fehler beim Erstellen der Typbibliothek, wenn Sie die Metaanweisung #COM TLIB ON verwenden.

Zusätzlich zum expliziten Rückgabewert, den Sie deklarieren, verfügen alle COM-Methoden und -Eigenschaften über einen weiteren „versteckten Rückgabewert“, der kryptisch „hResult“ heißt. Während der Name ein Handle für ein Ergebnis implizieren würde, handelt es sich in Wirklichkeit überhaupt nicht um ein Handle, sondern nur um einen langen ganzzahligen Wert, der den Erfolg oder Misserfolg der Methode anzeigt. Nach dem Aufruf einer Methode oder Eigenschaft können Sie den hResult-Wert mit der PowerBASIC-Funktion OBJRESULT abrufen. Das höchstwertige Bit des Werts wird als Schweregradbit bezeichnet. Dieses Bit ist 0 (Wert ist positiv) für Erfolg oder 1 (Wert ist negativ) für Fehler. Die restlichen Bits werden zur Übermittlung von Fehlercodes und zusätzlichen Statusinformationen verwendet. Wenn Sie eine Objektmethode/-eigenschaft (entweder Dispatch oder Direct ) aufrufen und das Schweregradbit im zurückgegebenen hResult gesetzt ist, generiert PowerBASIC den Laufzeitfehler 99: Objektfehler. Wenn Sie eine Methode oder Eigenschaft erstellen, gibt PowerBASIC automatisch ein hResult von Null zurück, was einen Erfolg impliziert. Sie können einen hResult-Wert ungleich Null zurückgeben, indem Sie METHOD OBJRESULT = expr innerhalb einer Methode oder PROPERTY OBJRESULT = expr innerhalb einer Eigenschaft ausführen.

Jede Methode und Eigenschaft in einer dualen Schnittstelle benötigt einen positiven, langen ganzzahligen Wert, um sie zu identifizieren. Dieser ganzzahlige Wert wird als DispID (Dispatch-ID) bezeichnet und intern von COM-Diensten verwendet, um die richtige Funktion auf einer Dispatch-Schnittstelle aufzurufen. Sie können optional eine bestimmte DispID angeben, indem Sie sie direkt nach dem Methoden-/Eigenschaftsnamen in spitze Klammern einschließen:

METHODE MethodOne <76> ()

Wenn Sie keine DispID angeben, weist PowerBASIC einen zufälligen Wert für Sie zu. Dies ist für interne Objekte in Ordnung, kann jedoch bei veröffentlichten COM-Objekten zu einem Fehler führen, da sich die DispID bei jeder Kompilierung Ihres Programms ändern kann. Es ist besonders wichtig, dass Sie für jede Methode/Eigenschaft in einer COM-Ereignisschnittstelle eine DispID angeben.

Eigenschaften überschreiben

Sie können die Funktionalität einer bestimmten Methode oder Eigenschaft einer geerbten Basisklasse ergänzen oder ersetzen, indem Sie eine Ersetzung codieren, der das Wort OVERRIDE vorangestellt ist. Die überschreibende Methode muss denselben Namen und dieselbe Signatur (Parameter, Rückgabewert usw.) haben wie die Methode, die sie ersetzt.

BYREF- und BYVAL-Parameter

Eine Kopie des Datenwerts wird als Parameter auf dem Stapel abgelegt. Die Kopie wird vernichtet, wenn die PROPERTY endet. BYVAL-Parameter verwenden standardmäßig ein IN-Attribut, wenn keine explizite Richtung angegeben ist.

Als Parameter wird ein Zeiger auf die Daten auf dem Stapel platziert. Diese Option darf nicht mit einem internen PROPERTY-Parameter verwendet werden.

Richtungsattribute

PROPERTY-Parameter geben auch die Richtung an, in der Daten zwischen dem Aufrufer und dem Angerufenen übertragen werden:

Daten werden vom Aufrufer an die EIGENSCHAFT übergeben. Im Allgemeinen werden Sie feststellen, dass fast alle IN-Parameter BYVAL übergeben werden, und das wird dringend empfohlen. Es ist jedoch möglich, ihnen bei Bedarf BYREF zu übergeben.

Daten werden von der PROPERTY zurück an den Aufrufer weitergeleitet. Alle OUT-Parameter müssen BYREF übergeben werden.

Daten werden vom Aufrufer an die PROPERTY übergeben und die Ergebnisse werden im selben Parameter an den Aufrufer zurückgegeben. Alle INOUT-Parameter müssen BYREF übergeben werden.

In vielen Fällen kann die Richtung eines Parameters direkt aus dem BYVAL/BYREF-Attribut abgeleitet werden (BYVAL=IN, BYREF=OUT). Wir empfehlen jedoch, das Richtungsattribut als zusätzliche Möglichkeit zur Selbstdokumentation einzubeziehen. Vor jedem METHOD-Parameternamen kann entweder BYVAL/BYREF oder IN/OUT/INOUT in beliebiger Reihenfolge stehen.

Beachten Sie eine interessante Regel für COM-Objekte: IN-Parameter sind schreibgeschützt. Sie dürfen nicht verändert werden.

IN-Parameter werden von COM-Regeln als „konstant“ betrachtet und dürfen nicht geändert werden, da es sich um Werte handelt, die nicht an den Aufrufer zurückgegeben werden. Da dies jedoch keine Regel ist, die normalerweise auf ein Standard-SUB oder FUNCTION angewendet wird, kann es zu Programmierfehlern kommen, die sehr schwer zu finden und zu beheben sind. Aus diesem Grund schützt Sie PowerBASIC automatisch vor diesem Problem, ohne dass Ihrerseits Maßnahmen erforderlich sind. Beim Schreiben von METHOD- oder PROPERTY-Code in PowerBASIC können Sie BYVAL/IN-Parametern frei neue Werte zuweisen. Sie werden einfach verworfen, wenn die METHOD beendet wird. Natürlich schützt Sie nicht jede Programmiersprache auf diese Weise, daher müssen Sie vorsichtig sein, wenn Sie eine COM-METHODE in einem anderen Compiler erstellen.

Mit OPTIONAL/OPT

PROPERTY-Anweisungen können einen oder mehrere Parameter als optional angeben, indem sie dem Parameter entweder das Schlüsselwort OPTIONAL (oder die Abkürzung OPT) voranstellen. Wenn ein Parameter als optional deklariert wird, sind alle nachfolgenden Parameter in der Deklaration ebenfalls optional, unabhängig davon, ob sie eine explizite OPTIONAL- oder OPT-Direktive angeben oder nicht.

VARIANT-Variablen eignen sich besonders gut zur Verwendung als optionaler Parameter. Wenn der aufrufende Code einen optionalen VARIANT-Parameter (BYVAL oder BYREF) weglässt, ersetzen PowerBASIC (und die meisten anderen Compiler) eine Variante vom Typ %VT_ERROR, die einen Fehlerwert von %DISP_E_PARAMNOTFOUND (&H80020004) enthält. In diesem Fall können Sie diesen Wert direkt prüfen oder mit der Funktion ISMISSING ermitteln, ob der Parameter physisch übergeben wurde oder nicht.

Wenn optionale Parameter (außer VARIANT) im aufrufenden Code weggelassen werden, wird der Stapelbereich, der normalerweise für diese Parameter reserviert ist, mit Nullen gefüllt.

Wenn der Parameter als BYVAL-Parameter definiert ist, hat er den Wert Null. Für TYPE- oder UNION-Variablen, die BYVAL übergeben werden, übergibt der Compiler eine Zeichenfolge binärer Nullen der Länge SIZEOF ( Type_or_union_var ).

Wenn der Parameter als BYREF-Parameter definiert ist, ist VARPTR (Varname) gleich Null; Wenn dies zutrifft, führt jeder Versuch, Varname in Ihrem Code zu verwenden, zu einer allgemeinen Schutzverletzung oder einer Speicherbeschädigung. Sie sollten zunächst die Funktion ISMISSING() verwenden, um festzustellen, ob der Zugriff auf den Parameter sicher ist.

THREADSAFE-Optionsdeskriptor

Wenn Sie die Option THREADSAFE einschließen, erstellt PowerBASIC automatisch ein Semaphor, das jeweils nur einem Thread die Ausführung erlaubt. Andere müssen warten, bis der erste Thread die THREADSAFE-Prozedur verlässt, bevor sie beginnen dürfen.

Siehe auch

  • #COM
  • CLASS
  • INSTANCE
  • INTERFACE (Direct)
  • INTERFACE (IDBind)
  • ISINTERFACE
  • ISNOTHING
  • Ich vermisse
  • ISOBJECT
  • Just what is COM?
  • LET (with Objects)
  • ICH
  • METHOD
  • OBJACTIVE
  • OBJPTR
  • OBJRESULT
  • Was ist überhaupt ein Objekt?

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Zeiger (@) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Zeiger (@)
Hilfe zum PBXB64-Compiler

Hinweise (@)

Ein Zeiger ist eine Variable, die die 32-Bit-Adresse (4 Byte) von Code oder Daten an anderer Stelle im Speicher enthält. Er wird Zeiger genannt, weil er buchstäblich auf diesen Ort zeigt. Der Standort wies darauf hin

Typ:Schlüsselwort |Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Zeiger stellen eine leistungsstarke Ergänzung zum Arsenal des BASIC-Programmierers dar. Die Adresse wird zur Laufzeit definiert, sodass Ihr Programm auf jeden Speicherort verweisen kann, als wäre es eine Standardvariable. Wenn ein Zeiger zum Zugriff auf einen Speicherort verwendet wird, spricht man von „indirekter Adressierung“.

Zeiger werden mit der DIM-Anweisung deklariert und der Typ des Ziels muss angegeben werden. Die Schlüsselwörter PTR und POINTER sind synonym.

DIM i AS INTEGER PTR 'deklariert i als Zeiger auf eine Ganzzahl

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Hinweise (@) soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Hinweise (@) mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


PUT$$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › PUT$$

PUT$$

Schreibt a

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

PUT$$ [#] filenum& , StrgExpr

Beschreibung

PUT$$ wertet zunächst den String-Ausdruck aus. Wenn daraus eine ANSI-Zeichenfolge resultiert, wird diese in WIDE-Unicode-Zeichen konvertiert. PUT$$ schreibt dann die WIDE-Zeichenfolge in die durch FileNum& angegebene Datei an der aktuellen Dateizeigerposition. GET$$ und PUT$$ bieten eine Low-Level-Alternative zu sequentiellen und wahlfreien Dateiverarbeitungstechniken, die es Ihnen ermöglichen, Dateien Zeichen für Zeichen zu verarbeiten.

PBXB64 verifiziert beide Pfade in examples/basic/test_get_put_wide_string.pb: Ein mit WCHR$ aufgebauter WSTRING wird geschrieben und mit ASCW-Codeunit-Pruefungen zurueckgelesen, und ein ANSI-STRING-Ausdruck wird ueber PUT$$ geschrieben und als WIDE-Codeunits zurueckgelesen.

Die Datei filenum& muss im Binärmodus geöffnet worden sein. Zeichen werden ab der aktuellen Dateizeigerposition geschrieben, die mit der SEEK-Anweisung festgelegt werden kann. Wenn die Datei zum ersten Mal geöffnet wird, befindet sich der Zeiger am Anfang der Datei (standardmäßig Position 1, sofern nicht BASE=0 in der OPEN-Anweisung angegeben wurde). Nach PUT$$ wird die Position des Dateizeigers automatisch auf den Punkt vorgerückt, der unmittelbar auf die gerade geschriebenen Daten folgt. Mit SEEK können Sie die Position des Dateizeigers abrufen oder ändern.

Dateinum&

Die Dateinummer, unter der die Datei geöffnet wurde.

StrgExpr

Ein Zeichenfolgenausdruck, der in die Datei geschrieben wird.

Siehe auch

  • ERHALTEN
  • GET$
  • ERHALTEN$$
  • OFFEN
  • SETZEN
  • PUT$
  • SEEK-Funktion
  • SEEK-Anweisung
  • SETEOF
  • WRITE#

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Datei-Themen sollen den benoetigten Oeffnungsmodus, die Arbeit auf Datensaetzen oder Bytes, die erforderliche Uebereinstimmung von Handles und Bereichen mit vorherigen Operationen sowie Cleanup- oder Entsperrschritte nennen. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für PUT$$ soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' PUT$$ mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


PUT$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › PUT$

PUT$

Schreibt eine

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

PUT$ [#] filenum& , StrgExpr

Beschreibung

PUT$ wertet zunächst den String-Ausdruck aus. Wenn daraus eine WIDE-Unicode-Zeichenfolge resultiert, wird sie in ANSI-Byte-Zeichen konvertiert. PUT$ schreibt dann den ANSI-String in die durch FileNum& angegebene Datei an der aktuellen Dateizeigerposition. GET$ , PUT$ und SEEK bieten eine Low-Level-Alternative zu sequentiellen und wahlfreien Dateiverarbeitungstechniken, die es Ihnen ermöglichen, Dateien byteweise zu verarbeiten.

Die Datei filenum& muss im Binärmodus geöffnet worden sein. Bytes werden ab der aktuellen Dateizeigerposition geschrieben, die mit der SEEK-Anweisung festgelegt werden kann. Wenn die Datei zum ersten Mal geöffnet wird, befindet sich der Zeiger am Anfang der Datei (standardmäßig Position 1, sofern nicht BASE=0 in der OPEN-Anweisung angegeben wurde). Nach PUT$ wird die Position des Dateizeigers automatisch auf den Punkt vorgerückt, der unmittelbar auf die gerade geschriebenen Daten folgt. Mit SEEK können Sie die Position des Dateizeigers abrufen oder ändern.

Dateinum&

Die Dateinummer, unter der die Datei geöffnet wurde.

StrgExpr

Ein Zeichenfolgenausdruck, der in die Datei geschrieben wird.

Siehe auch

  • ERHALTEN
  • GET$
  • ERHALTEN$$
  • OFFEN
  • SETZEN
  • PUT$$
  • SEEK-Funktion
  • SEEK-Anweisung
  • SETEOF
  • WRITE#

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Quad-Ganzzahlen (&&) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Quad-Ganzzahlen (&&)
Hilfe zum PBXB64-Compiler

Quad-Ganzzahlen (&&)

Quad-Ganzzahlen sind 64-Bit-Ganzzahlen (8 Byte) mit Vorzeichen (doppelt so viele Bits wie Long-Ganzzahlen) mit einem Bereich von -9,22x10^18 bis 9,22x10^18 (-2^63 bis 2^63 -1). Das Typspezifizierzeichen für eine Quad-Ganzzahl

Typ:Schlüsselwort |Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Quad-Integer-Variablen werden identifiziert, indem dem Variablennamen zwei kaufmännische Und-Zeichen folgen (d. h. var&&) oder indem die DEFQUD-Anweisung verwendet wird, wie in der vorherigen Diskussion von Integers beschrieben. Sie können Quad-Integer-Variablen auch mit dem Schlüsselwort QUAD mit der DIM-Anweisung deklarieren. Zum Beispiel:

Obwohl eine Quad-Ganzzahl tatsächlich eine Genauigkeit von 19 Stellen hat, können mit STR$ nur 18 Stellen Genauigkeit „angezeigt“ werden. Ein 19-stelliger Wert wird bei Verwendung mit STR$ in wissenschaftlicher Schreibweise auf 18 Ziffern gerundet. STR$ arbeitet standardmäßig mit bis zu 16 signifikanten Ziffern, daher muss die erweiterte Form von STR$ (z. B. STR$( var ,18)) verwendet werden, um die 17. und 18. Ziffer einer Quad-Ganzzahl für Anzeigezwecke zu generieren.

Ein C/C++ LARGE_INTEGER und ein Delphi int64 entsprechen beide einer PowerBASIC Quad-Ganzzahl.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Quad-Ganzzahlen (&&) soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Quad-Ganzzahlen (&&) mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


RAISEEVENT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › RAISEEVENT

RAISEEVENT

Rufen Sie an

Typ:Anweisung |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

RAISEEVENT ObjVar . Method ()

Beschreibung

Die RAISEEVENT-Anweisung wird verwendet, um Event-Handler-Code aus einer Ereignisquelle aufzurufen. RAISEEVENT darf nur innerhalb einer Klasse erscheinen, die die Event Source-Schnittstelle deklariert. Das Konzept von RAISEEVENT ist der CALL-Anweisung sehr ähnlich, es darf jedoch nur zur Ausführung von Ereignisprozeduren verwendet werden:

RaiseEvent Status.Progress(10) ' weist darauf hin, dass der Code zu 10 % fertig ist

Es ist zu beachten, dass RAISEEVENT überhaupt nicht auf eine Objektvariable verweist, da es alle direkten V-Table-Ereignishandler aufruft, die diese Ereignisse derzeit abonniert haben. Stattdessen verweist es auf den Schnittstellennamen (in diesem Fall „Status“), gefolgt vom Namen der auszuführenden Ereignismethode (in diesem Fall „Progress“). Wenn Ihr Programm einen Dispatch-Ereignishandler verwendet, sollten Sie stattdessen die OBJECT RAISEEVENT-Anweisung verwenden.

Siehe auch

  • CLASS
  • EVENT SOURCE
  • EVENTS
  • INTERFACE (Direct)
  • INTERFACE (IDBind)
  • Just what is COM?
  • EVENTS
  • OBJEKT-RAISEEVENT
  • Was ist überhaupt ein Objekt?
  • Was sind Verbindungspunkte?

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Direktzugriffsdateien – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Direktzugriffsdateien

Direktzugriffsdateien

Direktzugriffsdateien bestehen aus Datensätzen, auf die in beliebiger Reihenfolge zugegriffen werden kann. Dies bedeutet, dass die Daten genau so gespeichert werden, wie sie im Speicher erscheinen, wodurch Verarbeitungszeit gespart wird (da keine Übersetzung erforderlich ist).

Typ:Schlüsselwort |Kategorie:Datei-E/A

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Zufällige Dateien sind eine bessere Lösung für Datenbankprobleme als sequentielle Dateien, obwohl sie einige Nachteile haben. Zum einen sind Zufallsdateien nicht besonders transportierbar. Im Gegensatz zu sequentiellen Dateien können Sie mit einem Editor keinen Blick in sie werfen oder sie sinnvoll auf dem Bildschirm eingeben. Tatsächlich erfordert das Verschieben einer PowerBASIC-Zufallsdatei auf einen anderen Computer oder eine andere Sprache wahrscheinlich, dass Sie ein Übersetzerprogramm schreiben, um die Zufallsdatei zu lesen und eine Textdatei (sequentielle Datei) auszugeben.

Ein Beispiel für das Problem der Transportfähigkeit liegt ganz in der Nähe. Interpretive BASIC verwendet das nicht standardmäßige Format von Microsoft für Gleitkommawerte und PowerBASIC verwendet IEEE-Standard-Gleitkommakonventionen. Das bedeutet, dass Sie die Gleitkommafelder von Zufallsdateien, die von Interpretive BASIC erstellt wurden, nicht ohne etwas zusätzliche Arbeit mit einem PowerBASIC-Programm lesen können (oder umgekehrt).

Der große Vorteil von Zufallsdateien liegt bereits in ihrem Namen: Jeder Datensatz in der Datei ist jederzeit verfügbar. Beispielsweise kann ein Programm in einer Datenbank mit 23.000 Alumni direkt zu Datensatznummer 11.663 oder 22.709 gehen, ohne einen der anderen Datensätze zu lesen. Diese Fähigkeit macht es zur einzig sinnvollen Wahl für große Dateien und wahrscheinlich zur besseren Wahl für kleine Dateien, insbesondere solche mit relativ konstanten Datensatzlängen.

Direktzugriffsdateien können jedoch Speicherplatz verschwenden, da in jedem Datensatz Platz für das längstmögliche Feld reserviert wird. Beispielsweise zwingt ein 100-Byte-Kommentarfeld dazu, dass jeder Datensatz 100 Byte zusätzlichen Speicherplatz belegt, selbst wenn ihn nur einer von tausend tatsächlich nutzt.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Direktzugriffsdateien soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Direktzugriffsdateien mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


RATIONAL “ PBXB64-Compiler-Hilfe

Startseite â€º Datentypen â€º RATIONAL

RATIONAL

16-Byte-Typ für rationale Zahlen, der einen exakten Bruch als zwei vorzeichenbehaftete 64-Bit-Ganzzahlen (Zähler und Nenner) speichert.

Typ: Datentyp | Kategorie:Mathematik und Numerik

PBXB64-Status:VERFÃœGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

LOCAL  var AS RATIONAL
STATIC var AS RATIONAL
GLOBAL var AS RATIONAL

Beschreibung

RATIONAL ist ein 16-Byte-Typ rationaler Zahlen, der einen exakten Bruch als vorzeichenbehafteten 64-Bit-Zähler und als vorzeichenbehafteten 64-Bit-Nenner speichert. Es ist ideal für die exakte Arithmetik mit Brüchen (z. B. 1/3, 22/7), bei denen binäre Gleitkommazahlen den Wert nicht genau darstellen können.

Der Typ wird als Referenz (Zeiger) an Laufzeitfunktionen übergeben. Benutzen VARPTR(var) um die Adresse beim Aufruf der integrierten Konvertierungsfunktionen zu erhalten.

Integrierte Funktionen

Function | Unterschrift | Beschreibung
RATIONAL_FROM_INT | RATIONAL_FROM_INT(num, den, VARPTR(r)) | Bilden Sie aus Zähler und Nenner ein Rationales.
RATIONAL_TO_DOUBLE | d = RATIONAL_TO_DOUBLE(VARPTR(r)) | Konvertieren Sie einen rationalen Wert zurück in DOUBLE.
RATIONAL_ADD | RATIONAL_ADD(VARPTR(a), VARPTR(b), VARPTR(out)) | Fügen Sie zwei rationale Zahlen hinzu und speichern Sie das Ergebnis in out.

Beispiel

#COMPILE EXE
#DIM ALL
FUNCTION PBMAIN() AS LONG
  LOCAL r1 AS RATIONAL
  LOCAL r2 AS RATIONAL
  LOCAL d AS DOUBLE

  ' Create 1/3 as a rational
  RATIONAL_FROM_INT(1, 3, VARPTR(r1))
  d = RATIONAL_TO_DOUBLE(VARPTR(r1))
  PRINT "RATIONAL(1/3)="; d

  ' Create 1/6 and add to 1/3
  RATIONAL_FROM_INT(1, 6, VARPTR(r2))
  RATIONAL_ADD(VARPTR(r1), VARPTR(r2), VARPTR(r1))
  d = RATIONAL_TO_DOUBLE(VARPTR(r1))
  PRINT "RATIONAL(1/3+1/6)="; d

  FUNCTION = 0
END FUNCTION

Erwartete Ausgabe:

RATIONAL(1/3)=0.333333333333
RATIONAL(1/3+1/6)=0.5

Siehe auch

  • 128. Dezember
  • CINT / CLNG / CDBL
  • GRUNDLEGENDE mathematische Funktionen

Kind: Reference topic | Category: Math / Numeric Datatypes

PBXB64 Status: DOCUMENTED

Description

RATIONAL documents PBXB64's rational-number helper surface. Use it only for the forms shown on the page or backed by focused tests.

Syntax

LOCAL value AS RATIONAL

Validation Evidence

Validation evidence: Documented helper surface; concrete arithmetic claims require focused validation tests.

Example

LOCAL value AS RATIONAL
' Use only tested rational helper forms documented on this page.

See Also

  • cmd_dec128.html
  • basic_ref_math.html

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


READ$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › READ$

LESEN$

Zeichenfolge abrufen

Typ:Funktion |Kategorie:Variablen und Umfang

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

value$ = READ$( n %)

Beschreibung

Die READ$-Funktion wird verwendet, um ein bestimmtes String-Datenelement aus einer lokalen DATA-Liste abzurufen und die Daten im String-Format zurückzugeben. READ$ bietet eine einfache Technik für den wahlfreien Zugriff auf lokale DATEN.

Ein Integralausdruck, eine Konstante oder eine Variable, die eine Indexposition in der lokalen DATA-Liste angibt. n% = 1 für das erste Datenelement, n% = 2 für das zweite und so weiter. READ$ greift auf die DATA-Anweisungen in der Reihenfolge zu, in der sie im Quellprogramm erscheinen, von links nach rechts.

Wenn n% größer als DATACOUNT ist, gibt READ$ eine leere Zeichenfolge zurück, es tritt jedoch kein Laufzeitfehler auf.

Wert$

READ$ platziert die DATA-Zeichenfolge in value$.

Wenn die Ziel-DATA-Anweisung in Anführungszeichen gesetzt ist, behält READ$ alle darin enthaltenen führenden oder nachgestellten Leerzeichen bei; andernfalls schneidet READ$ führende und nachfolgende Leerzeichen ab und gibt eine gekürzte Zeichenfolge zurück. Weitere Informationen zur Formatierung von Datenelementen finden Sie unter DATA.

Wenn numerische Daten in DATA-Anweisungen gespeichert und mit READ$ abgerufen werden müssen, kann die VAL-Funktion verwendet werden, um die Rückgabewerte von READ$ in numerische Werte umzuwandeln.

Einschränkungen

Es gibt eine Grenze von 64 Kilobyte und 16384 separaten Datenelementen pro Sub , Function , Method oder Property , und es ist nicht möglich, DATA von außerhalb des Umfangs der aktuellen Prozedur zu lesen. Für die Verwendung von Doppelpunkten und Unterstrichen in DATA-Anweisungen gelten Einschränkungen. Weitere Informationen finden Sie unter DATA.

Siehe auch

  • DATEN
  • DATENANZAHL

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Daten lesen und schreiben – PBXB64 Compiler-Hilfe

Startseite › Funktionen › Daten lesen und schreiben

Daten lesen und schreiben

Als Ergänzung zur neuen COMM OPEN-Anweisung führt PowerBASIC vier neue COMM-Anweisungen ein, die Ihnen beim Schreiben serieller Kommunikationsprogramme helfen:

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

COMM PRINT #hComm, expr [;]

COMM SEND #hComm, expr

COMM RECV #hComm, count, expr

COMM LINE [INPUT] #hComm, expr

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


REGEXPR – PBXB64-Compiler-Hilfe

Startseite › Funktionen › REGEXPR

REGEXPR

Scannen Sie eine Zeichenfolge

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

REGEXPR mask$ IN target $ [AT start& ] TO iPos& [, iLen& ]

Beschreibung

REGEXPR durchsucht das Ziel $ nach einem passenden Ausdruck, der in mask$ angegeben ist. Wenn es gefunden wird, wird die Position der Übereinstimmung in der iPos&-Variablen (indiziert auf die erste Zeichenposition) und optional die Länge des übereinstimmenden Ausdrucks in iLen& zurückgegeben.

Wenn eine Übereinstimmung erzielt wird, können die Ergebnisse von iPos& und iLen& sofort mit nachfolgenden Zeichenfolgeoperationen wie MID$ verwendet werden, um den übereinstimmenden Teil von Ziel $ zu extrahieren und/oder die Suche im Rest von Ziel $ fortzusetzen. Wenn kein passender Ausdruck gefunden wird, werden sowohl iPos& (und iLen&, falls angegeben) auf Null gesetzt.

Wenn angegeben, beginnt die Suche an der Zeichenposition target & in target $; start& muss jedoch zwischen 1 und der Länge von target $ liegen. Wenn start& kleiner als 1 ist, wird der Parameter start& ignoriert.

Während es möglich ist, dass mehr als eine Übereinstimmung in einer bestimmten Zielzeichenfolge gefunden wird, wählt REGEXPR zunächst eine oder mehrere Übereinstimmungen aus, die ganz links beginnen, und gibt dann die längste davon zurück. Verwenden Sie den speziellen Escape-Operator \s, um eine Übereinstimmung mit der kürzesten Übereinstimmung zu erzwingen (siehe unten).

Die Operatoren ^ und $ stimmen sowohl mit dem tatsächlichen Anfang/Ende der Zeichenfolge als auch mit den vorherigen/nächsten eingebetteten Zeilentrennzeichen ( CHR$ (13,10) oder $CRLF ) im Ziel $ überein. Dadurch kann REGEXPR die Zielzeichenfolge $ so behandeln, als ob sie eine Reihe „logischer Textzeilen“ enthält. In dieser Situation spielt die Position des Start- und Zeichens eine entscheidende Rolle bei der Identifizierung der logisch begrenzten Zeile, die von REGEXPR untersucht werden soll.

Standardmäßig wird bei Suchausdrücken davon ausgegangen, dass die Groß-/Kleinschreibung nicht beachtet wird, sodass die Groß- und Kleinschreibung ignoriert wird.

Der in mask$ angegebene reguläre Ausdruck (Platzhalter) kann eine Kombination aus Standardtextzeichen und/oder den Metazeichen enthalten, die wie folgt definiert sind:

Definition

(Punkt) Entspricht jedem Zeichen außer dem Zeilenende.

(Caret) Entspricht der tatsächlichen Zeilenanfangsposition oder dem vorangehenden Zeilen-Trennzeichenpaar (CHR$(13,10) oder $CRLF), bezogen auf die Start- und Zeichenposition. Die Zeilentrennzeichen selbst sind nicht im iLen&-Ergebnis enthalten. (Siehe auch [^] unten für die Verwendung innerhalb einer Zeichenklassendefinition).

(Dollar) Entspricht der Zeilenendeposition, die entweder das erste Zeilentrennzeichenpaar (CHR$(13,10) oder $CRLF) sein kann, das bei der Suche rechts von der Start&-Position gefunden wird, oder das tatsächliche Ende der Ziel-$-Zeichenfolge, je nachdem, was zuerst auftritt. Die Zeilentrennzeichen selbst sind nicht im iLen&-Ergebnis enthalten.

(Stil) Gibt den Wechsel an (ODER-Operator), sodass ein Ausdruck auf beiden Seiten übereinstimmen kann. Die Priorität ist von links nach rechts, wie im Ausdruck anzutreffen.

(Fragezeichen) Gibt an, dass keine oder eine Übereinstimmung mit dem vorhergehenden Untermuster zulässig ist. Kann nicht mit einem Tag verwendet werden.

(Plus) Gibt an, dass eine oder mehrere Übereinstimmungen des vorhergehenden Untermusters zulässig sind. Kann nicht mit einem Tag verwendet werden.

(Sternchen) Gibt an, dass null oder mehr Übereinstimmungen mit dem vorhergehenden Untermuster zulässig sind. Kann nicht mit einem Tag verwendet werden.

Charakterklassen

(eckige Klammern) Identifiziert eine benutzerdefinierte Zeichenklasse, die mit jedem Zeichen übereinstimmt: [abc] entspricht a, b oder c. Innerhalb einer Klassendefinition werden nur drei spezielle Metazeichen erkannt: das Caret ^ für ergänzte Zeichen, der Bindestrich – für eine Reihe von Zeichen oder eine der folgenden \ Backslash-Escape-Sequenzen:

\\ \- \] \e \f \n \q \r \t \v \x##

Jede andere Verwendung eines Backslashs innerhalb einer Klassendefinition führt zu einer undefinierten Operation, die vermieden werden sollte.

(Bindestrich) Der Bindestrich identifiziert einen Bereich von zu vergleichenden Zeichen. Beispielsweise stimmt [a-f] mit a, b, c, d, e oder f überein.

Zeichen in einem einzelnen Bereich müssen in der natürlichen Reihenfolge auftreten, wie sie im Zeichensatz erscheinen. Beispielsweise wird [f-a] mit nichts übereinstimmen.

Zeichenlisten und ein oder mehrere Zeichenbereiche können in einer einzelnen Klassendefinition gemischt werden. Der Anfang und das Ende eines Bereichs können durch ein Literalzeichen oder eine der Backslash-Escape-Sequenzen \ angegeben werden:

\\ \- \] \e \f \n \q \r \t \v \x##

Jede andere Verwendung eines Backslashs innerhalb einer Klassendefinition führt zu einer undefinierten Operation.

Mehrere Bereiche in einer Klasse sind gültig. Beispielsweise entspricht [a-d2-5] a, b, c, d, 2, 3, 4 oder 5.

Wenn der Bindestrich maskiert ist, wird er als Literal behandelt. Beispielsweise ist [a\-c] eine Liste, kein Bereich, und stimmt aufgrund der Backslash-Escape-Sequenz \ mit a, - oder c überein.

(Caret) Wenn das Caret als erstes Element in einer Klassendefinition erscheint, identifiziert es eine ergänzte Zeichenklasse, die nicht übereinstimmt. Beispielsweise entspricht [^abc] jedem Zeichen außer a, b oder c.

Für die ergänzte Klasse kann auch ein Bereich angegeben werden. Beispielsweise entspricht [^a-z] jedem Zeichen außer a bis z.

Ein Caretzeichen, das sich an einer anderen Position als der ersten befindet, wird als Literalzeichen behandelt.

Tags/Untermuster

(Klammern) Klammern werden verwendet, um einen Tag oder ein Untermuster innerhalb des vollständigen Suchmusters zu finden und die Übereinstimmung zu speichern. Das übereinstimmende Untermuster kann später in der Maske (oder in einer Ersetzungsoperation mit REGREPL) mit \01 bis \99 abgerufen werden, basierend auf der Position der öffnenden Klammern von links nach rechts.

Klammern können auch verwendet werden, um den Vorrang der Auswertung mit dem Alternationsoperator zu erzwingen. Beispielsweise würde „(Begin)|(End)File“ entweder mit „BeginFile“ oder „EndFile“ übereinstimmen, aber ohne die Tag-Bezeichnungen würde „Begin|EndFile“ nur entweder mit „BeginndFile“ oder „BegiEndFile“ übereinstimmen.

Entkommene Charaktere

(Backslash) . Der Escape-Operator (Einzelzeichen-Anführungszeichen). Das folgende Zeichen wird als Literalwert behandelt und nicht als Sonderzeichen interpretiert. Beachten Sie, dass das Zeichen nach dem Backslash tatsächlich ein Sonderzeichen sein muss, wie folgt:

Eine Wortgrenze. Der Anfang oder das Ende eines Wortes, wobei ein Wort als ein oder mehrere Zeichen definiert ist, die ein alphabetisches Zeichen (A-Z oder a-z), ein numerisches Zeichen (0-9) und einen Unterstrich umfassen. Beispielsweise wird „abc_123“ als einzelnes Wort und „abc-123“ als zwei Wörter betrachtet.

Groß-/Kleinschreibung beachtende Suche. Ohne den \c-Operator wird beim Abgleich standardmäßig die Groß-/Kleinschreibung ignoriert. Im Gegensatz zu einigen anderen Implementierungen regulärer Ausdrücke wird die Groß-/Kleinschreibung bei allen Operationen berücksichtigt, sogar bei einem Zeichenbereich wie „[6-Z]“. Der \c-Operator kann an jeder Position in der Maske erscheinen.

Escape-Zeichen: CHR$(27) oder $ESC.

Formfeed-Zeichen: CHR$(12) oder $FF .

Zeilenvorschubzeichen (oder Zeilenumbruchzeichen): CHR$(10) oder $LF .

Doppelte Anführungszeichen ("): CHR$(34) oder $DQ . \q wird eingefügt, um die Einbindung in eine Literalzeichenfolge zu erleichtern. Beispiel: "\qHello\q".

Wagenrücklaufzeichen: CHR$(13) oder $CR .

Kürzestes Übereinstimmungszeichen: Das Flag \s bewirkt, dass die kürzeste übereinstimmende Zeichenfolge zurückgegeben wird und nicht die längste (Standardeinstellung). Wenn Sie beispielsweise in „abcdabcabc“ nach der Maske „abc.*abc“ suchen, würde die Standardeinstellung Position 1 und Länge 10 zurückgeben. Wenn der Schalter \s gesetzt ist, wird Position 1 und Länge 7 zurückgegeben. Diese Option kann zu einer leichten Verlängerung der Verarbeitungszeit führen. Das Flag \s muss am Anfang der Maskenzeichenfolge stehen.

Horizontales Tabulatorzeichen: CHR$(9) oder $TAB .

Vertikales Tabulatorzeichen: CHR$(11) oder $VT .

Hex-Zeichencode: Zeigt an, dass ein ASCII-Code folgt, der aus zwei hexadezimalen Ziffern besteht. Beispiel: \xFF = CHR$(&HFF) (entspricht CHR$(255)). XX muss im Bereich von 0 bis 255 liegen.

Einschränkungen

Um die Leistung zu maximieren, vermeiden Sie die übermäßige Verwendung der Zeichen *, + und ? Metazeichen.

Siehe auch

  • REGREPL

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


REGISTER – PBXB64-Compiler-Hilfe

Startseite › Funktionen › REGISTRIEREN

REGISTRIEREN

Zu definieren

Typ:Anweisung |Kategorie:Variablen und Umfang

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

REGISTER variable [AS type ] [, variable [AS type ]]

Beschreibung

Mit der REGISTER-Anweisung werden bestimmte lokale Variablen als Registervariablen definiert, d. h. Variablen, die direkt in bestimmten CPU-Registern und nicht im Anwendungsspeicher gespeichert werden. Da auf Daten in einem CPU-Register viel schneller und mit weniger Code zugegriffen werden kann, sind Registervariablen wertvolle Optimierungswerkzeuge.

Registervariablen sind immer lokal für die Prozedur, in der sie erscheinen. In der aktuellen Version von PowerBASIC kann es bis zu zwei Variablen der Integralklasse (Wort/Dword/Integer/Long) und bis zu vier Gleitkommazahlen mit erweiterter Genauigkeit geben. Es ist möglich, dass zukünftige Versionen des Compilers diese Grenzwerte ändern, sodass Sie eine unbegrenzte Anzahl davon deklarieren können. Alle „zusätzlichen“ Registervariablen werden während der Kompilierung automatisch als lokale Variablen neu klassifiziert.

Mit der REGISTER-Anweisung können Sie auswählen, welche Variablen als Registervariablen klassifiziert werden. Wenn Sie in einem bestimmten Verfahren keine Auswahl treffen, wird der Compiler versuchen, die Auswahl für Sie zu treffen. Standardmäßig weist der Compiler immer alle verfügbaren lokalen Variablen der Integralklasse zu. Float-Variablen mit erweiterter Genauigkeit werden nur in Funktionen automatisch zugewiesen, die keine externen Funktionsaufrufe enthalten.

Registervariablen der Integralklasse sind am effizientesten für Variablen, die häufig aktualisiert oder verwendet werden, wie z. B. For/Next-Schleifenzählervariablen und Variablen, die wiederholt als Array-Indizes verwendet werden.

Gleitkomma-Registervariablen sollten im Allgemeinen mit etwas mehr Vorsicht ausgewählt werden, da der Compiler bei jedem Aufruf einer Prozedur Code generieren muss, um sie im konventionellen Speicher zu speichern und wiederherzustellen. In einigen eher seltenen Fällen ist es möglich, dass Gleitkomma-Registervariablen tatsächlich die Ausführungsgeschwindigkeit verringern. Sie sind jedoch äußerst wertvoll bei intensiven Gleitkommaberechnungen in Funktionen, die nur wenige Verweise auf andere Prozeduren haben.

Aufgrund des Designs von FPUs (Fließkommaeinheiten) und der verfügbaren Befehlssätze bietet die erste in Ihrem Programm deklarierte Float-Registervariable weitaus mehr Optimierungsmöglichkeiten als die anderen. Wählen Sie sorgfältig die Variable aus, die in Gleitkommaausdrücken am häufigsten verwendet wird (d. h. auf der rechten Seite des Zuweisungsoperators „=“), um den größten Vorteil bei der Ausführungsgeschwindigkeit zu erzielen. Denken Sie außerdem daran, dass es in der Regel sinnvoll ist, Registervariablen Gleitkommakonstanten zuzuweisen, wenn diese in sich wiederholenden oder intensiven Berechnungen verwendet werden.

Bei Inline-Assembler-Gleitkomma-Opcodes in Funktionen, die Registervariablen aktivieren, müssen Sie vorsichtig sein. Gleitkomma-Registervariablen können bis zu vier der FPU-Register belegen, daher müssen Sie die Verwendung der x87-Register auf die verbleibenden vier beschränken. Darüber hinaus darf im Inline-Assembler-Code niemals namentlich auf Gleitkomma-Registervariablen verwiesen werden, da der Compiler die Registerpositionen nicht immer mit absoluter Sicherheit verfolgen kann.

Einschränkungen

VARPTR kann nicht für eine Registervariable verwendet werden.

PowerBASIC verhindert transparent die automatische Registerkonvertierung der in der TO-Klausel der Anweisungen DIALOG SHOW MODAL und DIALOG SHOW MODELESS verwendeten Variablen. Wenn die Zielvariable explizit als Registervariable deklariert ist, löst PowerBASIC beim Kompilieren den Fehler 491 („Ungültige Registervariable“) aus. Dies ist notwendig, da die in solchen Variablen gespeicherten Ergebniswerte aus dem Kontext anderer Prozeduren zugewiesen werden können und dies nur mit einer Speichervariablen erfolgen darf.

Siehe auch

  • #REGISTER
  • Optimieren Sie Ihren Code

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.


Register – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Register

Registriert

Register sind ein spezieller Arbeitsbereich innerhalb des Prozessors. Register sind schneller als Speicheroperanden und für die Zusammenarbeit mit den Opcodes des Prozessors konzipiert.

Typ:Schlüsselwort |Kategorie: Memory & Pointers

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Register in einem Intel- oder kompatiblen Prozessor sind beim Schreiben von Assembler eine sehr begrenzte Ressource. Im Wesentlichen gibt es acht Allzweckregister: EAX, EBX, ECX, EDX, ESI, EDI, ESP und EBP. In den meisten Fällen sollten ESP und EBP ungenutzt bleiben, da PowerBASIC sie für den Ein- und Ausgang von Prozeduren verwendet.

Das bedeutet, dass Sie in Ihrem Assemblercode sechs 32-Bit-Register sowie alle anderen für die Prozedur nützlichen Speicherorte verwenden können. ESI und EDI können in den meisten Fällen auf normale Weise verwendet werden, auf keines davon kann jedoch auf Byte-Ebene zugegriffen werden. Sie können das Low-WORD von ESI als SI und das Low-WORD von EDI als DI lesen.

Bei der Verwendung von Assembler ist es sehr wichtig, die Größe der Register und die Daten zu kennen, die Sie darin platzieren können. Ein 32-Bit-Intel-Prozessor oder ein kompatibler Prozessor verfügt über drei native Datengrößen, die von den normalen Integralanweisungen verwendet werden können: BYTE, WORD und DWORD, entsprechend 8-Bit, 16-Bit und 32-Bit.

Dies kann in der HEX-Notation dargestellt werden.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Registriert soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Registriert mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


REGREPL – PBXB64-Compiler-Hilfe

Startseite › Funktionen › REGREPL

REGREPL

Scannen Sie eine Zeichenfolge

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

REGREPL mask$ IN target $ WITH repl$ [AT start& ] TO iPos& , newtarget$

Beschreibung

REGREPL durchsucht das Ziel $ nach einem passenden regulären Ausdruck, der in mask$ angegeben ist. Wenn eine Übereinstimmung erzielt wird, ersetzt REGREPL den übereinstimmenden Text durch den Inhalt von repl$ und weist den neuen Text newtarget$ zu. Darüber hinaus legt REGREPL iPos& so fest, dass es die Zeichenposition widerspiegelt, die unmittelbar auf den übereinstimmenden Text in newtarget$ folgt, sodass der Vorgang bei Bedarf wiederholt werden kann.

Wenn kein passender Ausdruck gefunden wird, wird iPos& auf Null gesetzt und newtarget$ erhält eine direkte Kopie von target$ . In beiden Fällen bleibt target$ unverändert.

mask$ darf Literalzeichen und Metazeichen (Platzhalter) enthalten, um den regulären Ausdruck zu bilden, und repl$ darf nur Literalzeichen und Tags enthalten, die durch \## angegeben werden. Jedes Tag von \01 bis \99 wird durch den Text ersetzt, der tatsächlich mit diesem Tag übereinstimmt. \00 wird durch den gesamten übereinstimmenden Text ersetzt.

Wenn angegeben, beginnt die Suche an der Zeichenposition start& in target$ ; start& muss jedoch zwischen 1 und der Länge von target$ liegen. Wenn start& kleiner als 1 ist, wird der Parameter start& ignoriert.

Während es möglich ist, dass mehr als eine Übereinstimmung in einer bestimmten Zielzeichenfolge gefunden wird, wählt REGREPL zunächst eine oder mehrere Übereinstimmungen aus, die ganz links beginnen, und gibt dann die längste davon zurück. Verwenden Sie den speziellen Escape-Operator \s, um eine Übereinstimmung mit der kürzesten Übereinstimmung zu erzwingen (siehe unten).

Die Operatoren ^ und $ stimmen sowohl mit dem tatsächlichen Anfang/Ende der Zeichenfolge als auch mit den vorherigen/nächsten eingebetteten Zeilentrennzeichen ( CHR$ (13,10) oder $CRLF ) in target$ überein. Dadurch kann REGREPL die Zeichenfolge target$ so behandeln, als ob sie eine Reihe „logischer Textzeilen“ enthält. In dieser Situation spielt die Position des Start- und Zeichens eine entscheidende Rolle bei der Identifizierung der logischen Trennlinie, die von REGREPL untersucht werden soll.

Standardmäßig wird bei Suchausdrücken davon ausgegangen, dass die Groß-/Kleinschreibung nicht beachtet wird, sodass die Groß- und Kleinschreibung ignoriert wird.

Der in mask$ angegebene reguläre Ausdruck (Platzhalter) kann eine Kombination aus Standardtextzeichen und/oder den Metazeichen enthalten, die wie folgt definiert sind:

Definition

(Punkt) Entspricht jedem Zeichen außer dem Zeilenende.

(Caret) Entspricht der tatsächlichen Zeilenanfangsposition oder dem vorangehenden Zeilen-Trennzeichenpaar (CHR$(13,10) oder $CRLF), bezogen auf die Start- und Zeichenposition. Die Zeilentrennzeichen selbst werden nicht durch repl$ ersetzt. (Siehe auch [^] unten für die Verwendung innerhalb einer Zeichenklassendefinition).

(Dollar) Entspricht der Zeilenendeposition, bei der es sich entweder um das erste Zeilentrennzeichenpaar (CHR$(13,10) oder $CRLF) handeln kann, das bei der Suche rechts von der Start&-Position gefunden wird, oder um das tatsächliche Ende der Ziel$-Zeichenfolge, je nachdem, was zuerst auftritt. Die Zeilentrennzeichen selbst werden nicht durch repl$ ersetzt.

(Stil) Gibt den Wechsel an (ODER-Operator), sodass ein Ausdruck auf beiden Seiten übereinstimmen kann. Die Priorität ist von links nach rechts, wie im Ausdruck anzutreffen.

(Fragezeichen) Gibt an, dass keine oder eine Übereinstimmung mit dem vorhergehenden Untermuster zulässig ist. Kann nicht mit einem Tag verwendet werden.

(Plus) Gibt an, dass eine oder mehrere Übereinstimmungen des vorhergehenden Untermusters zulässig sind. Kann nicht mit einem Tag verwendet werden.

(Sternchen) Gibt an, dass null oder mehr Übereinstimmungen mit dem vorhergehenden Untermuster zulässig sind. Kann nicht mit einem Tag verwendet werden.

Charakterklassen

(eckige Klammern) Identifiziert eine benutzerdefinierte Zeichenklasse, die mit jedem Zeichen übereinstimmt: [abc] entspricht a, b oder c. Innerhalb einer Klassendefinition werden nur drei spezielle Metazeichen erkannt: das Caretzeichen (^) für ergänzte Zeichen, der Bindestrich (-) für einen Zeichenbereich oder eine der folgenden Backslash-Escape-Sequenzen:

\\ \- \] \e \f \n \q \r \t \v \x##

Jede andere Verwendung eines Backslashs innerhalb einer Klassendefinition führt zu einer undefinierten Operation, die vermieden werden sollte.

(Bindestrich) Der Bindestrich identifiziert einen Bereich von zu vergleichenden Zeichen. Beispielsweise stimmt [a-f] mit a, b, c, d, e oder f überein.

Zeichen in einem einzelnen Bereich müssen in der natürlichen Reihenfolge auftreten, wie sie im Zeichensatz erscheinen. Beispielsweise wird [f-a] mit nichts übereinstimmen.

Zeichenlisten und ein oder mehrere Zeichenbereiche können in einer einzelnen Klassendefinition gemischt werden. Der Anfang und das Ende eines Bereichs können durch ein Literalzeichen oder eine der Backslash-Escape-Sequenzen \ angegeben werden:

\\ \- \] \e \f \n \q \r \t \v \x##

Jede andere Verwendung eines Backslashs innerhalb einer Klassendefinition führt zu einer undefinierten Operation.

Mehrere Bereiche in einer Klasse sind gültig. Beispielsweise entspricht [a-d2-5] a, b, c, d, 2, 3, 4 oder 5.

Wenn der Bindestrich maskiert ist, wird er als Literal behandelt. Beispielsweise ist [a\-c] eine Liste, kein Bereich, und stimmt aufgrund der Backslash-Escape-Sequenz \ mit a, - oder c überein.

(Caret) Wenn das Caret als erstes Element in einer Klassendefinition erscheint, identifiziert es eine ergänzte Zeichenklasse, die nicht übereinstimmt. Beispielsweise entspricht [^abc] jedem Zeichen außer a, b oder c.

Für die ergänzte Klasse kann auch ein Bereich angegeben werden. Beispielsweise entspricht [^a-z] jedem Zeichen außer a bis z.

Ein Caretzeichen, das sich an einer anderen Position als der ersten befindet, wird als Literalzeichen behandelt.

Tags/Untermuster

(Klammern) Klammern werden verwendet, um einen Tag oder ein Untermuster innerhalb des vollständigen Suchmusters zu finden und die Übereinstimmung zu speichern. Das passende Untermuster kann später in der Maske oder in einer Ersetzungsoperation mit \01 bis \99 abgerufen werden, basierend auf der Position der öffnenden Klammern von links nach rechts.

Klammern können auch verwendet werden, um den Vorrang der Auswertung mit dem Alternationsoperator zu erzwingen. Beispielsweise würde „(Begin)|(End)File“ entweder mit „BeginFile“ oder „EndFile“ übereinstimmen, aber ohne die Tag-Bezeichnungen würde „Begin|EndFile“ nur entweder mit „BeginndFile“ oder „BegiEndFile“ übereinstimmen.

Hinweis: Klammern dürfen nicht mit ? verwendet werden. + *, da jede Übereinstimmungswiederholung dazu führen kann, dass der Tag-Wert mehrdeutig ist. Um wiederholte Ausdrücke abzugleichen, verwenden Sie Klammern gefolgt von \01*.

Entkommene Charaktere

(Backslash) . Der Escape-Operator (Einzelzeichen-Anführungszeichen). Das folgende Zeichen wird als Literalwert behandelt und nicht als Sonderzeichen interpretiert. Beachten Sie, dass das Zeichen nach dem Backslash tatsächlich ein Sonderzeichen sein muss, wie folgt:

Eine Wortgrenze. Der Anfang oder das Ende eines Wortes, wobei ein Wort als ein oder mehrere Zeichen definiert ist, die ein alphabetisches Zeichen (A-Z oder a-z), ein numerisches Zeichen (0-9) und einen Unterstrich umfassen. Beispielsweise wird „abc_123“ als einzelnes Wort und „abc-123“ als zwei Wörter betrachtet.

Groß-/Kleinschreibung beachtende Suche. Ohne den \c-Operator wird beim Abgleich standardmäßig die Groß-/Kleinschreibung ignoriert. Im Gegensatz zu einigen anderen Implementierungen regulärer Ausdrücke wird die Groß-/Kleinschreibung bei allen Operationen berücksichtigt, sogar bei einem Zeichenbereich wie „[6-Z]“. Der \c-Operator kann an jeder Position in der Maske erscheinen.

Escape-Zeichen: CHR$(27) oder $ESC .

Formfeed-Zeichen: CHR$(12) oder $FF .

Zeilenvorschubzeichen (oder Zeilenumbruchzeichen): CHR$(10) oder $LF .

Doppelte Anführungszeichen ("): CHR$(34) oder $DQ . \q wird eingefügt, um die Einbindung in eine Literalzeichenfolge zu erleichtern. Beispiel: "\qHello\q".

Wagenrücklaufzeichen: CHR$(13) oder $CR .

Kürzestes Übereinstimmungszeichen: Das Flag \s bewirkt, dass die kürzeste übereinstimmende Zeichenfolge zurückgegeben wird und nicht die längste (Standardeinstellung). Wenn Sie beispielsweise in „abcdabcabc“ nach der Maske „abc.*abc“ suchen, würde die Standardeinstellung Position 1 und Länge 10 zurückgeben. Wenn der Schalter \s gesetzt ist, wird Position 1 und Länge 7 zurückgegeben. Diese Option kann zu einer leichten Verlängerung der Verarbeitungszeit führen. Das \S-Flag muss am Anfang der Maskenzeichenfolge stehen.

Horizontales Tabulatorzeichen: CHR$(9) oder $TAB .

Vertikales Tabulatorzeichen: CHR$(11) oder $VT .

Hex-Zeichencode: Zeigt an, dass ein ASCII-Code folgt, der aus zwei hexadezimalen Ziffern besteht. Beispiel: \xFF = CHR$(&HFF) (entspricht CHR$(255)). XX muss im Bereich von 0 bis 255 liegen.

Tag-Nummer: Wird als Zeichen ausgewertet, die mit der Tag-Nummer ## übereinstimmen (wobei ## im Bereich von 01 bis 99 liegt, in Dezimalzahl). Tags werden implizit von 01 bis 99 nummeriert, basierend auf der Position der linken Klammer von links nach rechts. „( )w\01“ würde mit „abcwabc“ oder „456w456“ übereinstimmen.

Tags können nicht vorwärtsverwiesen werden. Das heißt, wenn auf ein Tag verwiesen wird, das noch nicht definiert ist, wird davon ausgegangen, dass es keine Übereinstimmung gibt.

Einschränkungen

Um die Leistung zu maximieren, vermeiden Sie die übermäßige Verwendung der Zeichen *, + und ? Metazeichen.

Siehe auch

  • REGEXPR

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Vergleichsoperatoren – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › Vergleichsoperatoren

Vergleichsoperatoren

Mit relationalen Operatoren können Sie die Werte zweier Ausdrücke vergleichen, um ein boolesches Ergebnis von TRUE oder FALSE zu erhalten. Obwohl sie in jedem numerischen Ausdruck verwendet werden können (z. B. a = (b > c) / 1).

Typ:Betreiber |Kategorie:Betreiber

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Beispiele

a$ = "CAT"
x1% = (a$ = "CAT") : x2% = (a$ = "CATS") : x3% = (a$ = "cat")
city1$ = "Seattle"
city2$ = "Tucson"
IF UCASE$(city1$) > UCASE$(city2$) THEN
city$ = city1$
ELSE
city$ = city2$
END IF
city1$ = UCASE$(city1$)
city2$ = UCASE$(city2$)
IF city1$ > city2$ THEN

PowerBASIC-Relationsoperatoren

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_eq_1_1
FUNCTION PBMAIN() AS LONG
  IF NOT ((1 = 1) = TRUE) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_ne_1_1
FUNCTION PBMAIN() AS LONG
  IF NOT ((1 <> 1) = FALSE) THEN FUNCTION = 2: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_lt_1_1
FUNCTION PBMAIN() AS LONG
  IF NOT ((1 < 1) = FALSE) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_gt_1_1
FUNCTION PBMAIN() AS LONG
  IF NOT ((1 > 1) = FALSE) THEN FUNCTION = 4: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_eq_1_2
FUNCTION PBMAIN() AS LONG
  IF NOT ((1 = 2) = FALSE) THEN FUNCTION = 5: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_ne_1_2
FUNCTION PBMAIN() AS LONG
  IF NOT ((1 <> 2) = TRUE) THEN FUNCTION = 6: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_lt_1_2
FUNCTION PBMAIN() AS LONG
  IF NOT ((1 < 2) = TRUE) THEN FUNCTION = 7: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_gt_1_2
FUNCTION PBMAIN() AS LONG
  IF NOT ((1 > 2) = FALSE) THEN FUNCTION = 8: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_eq_2_1
FUNCTION PBMAIN() AS LONG
  IF NOT ((2 = 1) = FALSE) THEN FUNCTION = 9: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_ne_2_1
FUNCTION PBMAIN() AS LONG
  IF NOT ((2 <> 1) = TRUE) THEN FUNCTION = 10: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Vergleichsoperatoren soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Vergleichsoperatoren mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


REM – PBXB64-Compiler-Hilfe

Startseite › Funktionen › REM

REM

Geben Sie an, dass der Rest einer Zeile in Quellcodedateien als Bemerkung oder Kommentar betrachtet und aus dem kompilierten Code ausgeschlossen werden soll.

Typ:Anweisung |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

REM comment text
' comment text
; comment in an Inline Assembler statement

Beschreibung

Der PowerBASIC-Compiler ignoriert Bemerkungen; Sie beanspruchen keinen Platz in Ihrem generierten Code, also verwenden Sie sie reichlich – nützliche Kommentare erhöhen die Lesbarkeit und Wartbarkeit des Quellcodes erheblich.

Kommentartext ist eine beliebige Zeichenfolge. Ein Kommentar kann in einer Zeile mit anderen Anweisungen stehen, er muss jedoch das letzte Element in dieser Zeile sein und ihm muss ein Doppelpunkt vorangehen. Beispielsweise wird die folgende Zuweisung nicht kompiliert oder ausgeführt, da der Compiler nicht erkennen kann, wo der Kommentar endet und die Anweisung beginnt:

REM addiert nun die Zahlen: a = b + c

Folgendes funktioniert:

a = b + c : REM addiere nun die Zahlen

Der Apostroph (') ist eine alternative Form von REM. Wenn Sie einen Apostroph verwenden, ist kein Doppelpunkt erforderlich, um die Bemerkung von den anderen Anweisungen in derselben Zeile zu trennen.

Wenn Sie den Inline-Assembler verwenden, verwenden Sie das Semikolon (;), um anzugeben, dass der Rest der Zeile ignoriert werden soll. Für Kommentare kann jedoch weiterhin ein Apostroph ( ' ) verwendet werden.

Die fokussierte PBXB64-Validierung prueft vollstaendige REM-Zeilen, inline : REM, Apostroph-Kommentare ausserhalb von Stringliteralen, Kommentare auf der Zielzeile einer fortgesetzten Anweisung, Ausdrucksmakros mit nachgestellten Kommentaren und Semikolon-Kommentare im Inline-Assembler.

Darüber hinaus behandelt der Compiler Text, der nach dem Zeilenfortsetzungszeichen erscheint, als Bemerkung. Wir empfehlen jedoch weiterhin, solchen Kommentaren ein REM- oder Apostroph-Symbol ( ' ) voranzustellen, um Bemerkungen klar vom eigentlichen Code zu unterscheiden. Zum Beispiel:

DECLARE FUNCTION Call32& _ Der Prototyp

LIB „CALL32.DLL“ _ Der DLL-Name

ALIAS "Call32" _ ' Der exportierte Name

(Param1 AS ANY, _ ' 1. Parameter

BYVAL id&) ' 2. Parameter

In Situationen, in denen ein großer Codeabschnitt REM-ausgeschnitten werden muss (und dennoch in der Quellcodedatei erhalten bleibt), ist es oft einfacher, den Code mit #IF 0/#ENDIF-Metaanweisungen einzuschließen. Zum Beispiel:

#IF 0 ' Die folgenden Zeilen ausschließen

Code und Text zwischen #IF 0 und #ENDIF

Metaanweisungen werden vom Compiler ignoriert.

DIM a$(1 TO 1000) ' Diese Zeile wird ebenfalls ignoriert.

INCR x& ' Wie ist diese Zeile!

#ENDIF

Da der #IF-Ausdruck als falsch (Null) ausgewertet wird, zwingt dies den Compiler dazu, den eingeschlossenen Codeblock vom Kompilierungsprozess auszuschließen, genau so, als ob jeder Zeile eine REM-Anweisung vorangestellt worden wäre.

Siehe auch

  • Lange Schlangen

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


REMACRO – PBXB64-Compiler-Hilfe

Startseite › Funktionen › REMACRO

REMACRO

Ersetzt den Körper und die Parameterliste eines vorhandenen Makros.

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

REMACRO macroname [( prm1 , prm2 , ...)] = replacementtext
REMACRO macroname [( prm1 , prm2 , ...)]
  [MACROTEMP ident1 [, ident2 , ...]]
  { replacementtext }
  END MACRO

Beschreibung

REMACRO definiert ein vorhandenes Makro neu. Das Makro muss bereits mit MACRO oder MACRO FUNCTION definiert worden sein; andernfalls meldet der Compiler einen Fehler. Sowohl einzeilige als auch mehrzeilige Formen werden unterstützt. Parameterlisten und MACROTEMP-Deklarationen werden ersetzt.

REMACRO aktiviert außerdem ein Makro wieder, das zuvor durch UNMACRO deaktiviert wurde.

PBXB64-Hinweise

Makros werden vor dem Statement-Lowering vorscanniert, sodass eine REMACRO-Direktive für die gesamte Kompilierungseinheit nach Quellreihenfolge wirksam wird.

Abgedeckt durch tests/pb/test_pp_remacro_unmacro.pb, einschließlich Ersetzung und erneuter Aktivierung nach UNMACRO.

Siehe auch

  • MAKRO / ENDMAKRO
  • UNMACRO

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für REMACRO soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' REMACRO mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


REMAIN$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › REMAIN$

BLEIBEN$

Gibt den Teil einer Zeichenfolge zurück

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

a$ = REMAIN$([ Start ,] MainStr , [ANY] MatchStr )

Beschreibung

REMAIN$ ist eine Ergänzung zur EXTRACT$-Funktion. MainStr wird nach der in MatchStr angegebenen Zeichenfolge durchsucht. Wenn gefunden, werden alle Zeichen nach MatchStr zurückgegeben. Wenn MatchStr in MainStr nicht vorhanden ist oder einer der String-Parameter null ist, wird ein null (Null-Länge) zurückgegeben.

Start ist eine optionale Startposition, um mit der Suche zu beginnen. Wenn Start nicht angegeben ist, wird Position 1 verwendet. Wenn Start Null ist, wird eine Nullzeichenfolge zurückgegeben. Wenn Start negativ ist, wird die Startposition von rechts nach links gezählt: Wenn -1, beginnt die Suche beim letzten Zeichen; wenn -2, der vorletzte und so weiter.

Wenn das Schlüsselwort ANY enthalten ist, gibt MatchStr eine Liste einzelner Zeichen an, nach denen einzeln gesucht werden soll. Eine Übereinstimmung mit einem dieser Zeichen führt dazu, dass die Operation bis zu diesem Zeichen ausgeführt wird.

Siehe auch

  • EXTRACT$
  • LINKS$
  • LTRIM$
  • MITTLERER $
  • REMOVE$
  • REPLACE
  • RICHTIG$
  • RTRIM$
  • TALLY
  • TRIM$
  • ÜBERPRÜFEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


REMOVE$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › REMOVE$

REMOVE$

Gibt eine Kopie einer Zeichenfolge zurück

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

x$ = REMOVE$( MainString , [ANY] MatchString )

Beschreibung

Die REMOVE$-Funktion besteht aus folgenden Teilen:

MainString

Der Zeichenfolgenausdruck, aus dem Zeichen entfernt werden sollen.

MatchString

Der Zeichenfolgenausdruck, von dem alle Vorkommen entfernt werden sollen. Wenn MatchString nicht in MainString vorhanden ist, wird der gesamte MainString intakt zurückgegeben.

Wenn das Schlüsselwort ANY enthalten ist, gibt MatchString eine Liste einzelner Zeichen an, nach denen einzeln gesucht werden soll. Eine Übereinstimmung mit einem dieser Zeichen führt dazu, dass dieses Zeichen aus dem Ergebnis entfernt wird.

Einschränkungen

Bei REMOVE wird die Groß-/Kleinschreibung beachtet.

Siehe auch

  • CLIP$
  • EXTRACT$
  • INSTR
  • LTRIM$
  • MITTLERER $
  • REPLACE
  • BEHALTEN$
  • RICHTIG$
  • RTRIM$
  • SHRINK$
  • TALLY
  • TRIM$
  • UNWRAP$
  • ÜBERPRÜFEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


REPEAT$ – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › REPEAT$

REPEAT$

Gibt eine Zeichenfolge zurück

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = REPEAT$( count& , string_expr )

Beschreibung

Die REPEAT$-Funktion besteht aus folgenden Teilen:

zählen&

Ist ein Integralausdruck, eine Konstante oder eine Variable, der die Anzahl der Kopien von string_expr angibt, die in das Ergebnis einbezogen werden sollen. REPEAT$ ist STRING$ sehr ähnlich (das mehrere Kopien eines einzelnen Zeichens erstellt).

string_expr

Die zu duplizierende Zeichenfolge.

Siehe auch

  • BUILD$
  • CHR$
  • GUID$
  • NUL$
  • SPACE$
  • STRING$

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RESET – PBXB64-Compiler-Hilfe

Startseite › Funktionen › RESET

ZURÜCKSETZEN

Legen Sie einen Skalar fest (kein Array)

Typ:Anweisung |Kategorie:Datei-E/A

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

RESET variable [, ...]
RESET array() [, ...]
RESET array(index) [, ...]

Beschreibung

Wenn die Variable numerisch ist, wird sie auf Null gesetzt. Wenn die Variable eine dynamische Zeichenfolge ist, wird sie auf null („“; eine leere Zeichenfolge)“ gesetzt. Wenn es sich bei der Variablen um eine mit NULL endende Zeichenfolge handelt, wird das erste Byte auf NULL ( $NUL ) gesetzt. Wenn die Variable eine Zeichenfolge fester Länge oder ein benutzerdefinierter Typ/Union ist, werden alle Bytes in der Variablen auf Null oder CHR$ (0) gesetzt. Wenn die Variable eine Variante ist, wird sie gelöscht und auf den Datentyp %VT_EMPTY gesetzt.

Wenn array() numeric ist, werden alle Elemente auf Null gesetzt; andernfalls werden alle Elemente auf Null/Null gesetzt. Wenn in den Klammern ein Array-Indexwert angegeben wird, wird nur dieses Array-Element auf Null/Null gesetzt, als wäre es eine skalare Variable (keine Array-Variable).

RESET funktioniert auch mit absoluten Arrays und löscht den Inhalt auf Nullen oder leere Zeichenfolgen. Weitere Informationen zu absoluten Arrays finden Sie in der DIM-Anweisung.

Siehe auch

  • ARRAYATTR
  • DIM
  • LÖSCHEN
  • LET
  • LET (mit Typen)
  • LET (mit Varianten)
  • REDIM

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RESOURCE$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › RESOURCE$

RESSOURCE$

Gibt vordefinierte Werte zurück

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET] für RCDATA- und STRING-Ressourcen.

Syntax

r $ = RESOURCE$(RCDATA, ResID )
s$$ = RESOURCE$(STRING, ResID% )

Beschreibung

Sie können Daten mit der Metaanweisung #RESOURCE in Ihre EXE- oder DLL-Datei einbetten. Während die Daten in verschiedenen Datentypen dargestellt werden können, sind zwei so konzipiert, dass sie direkt für Ihre eigenen Zwecke abgerufen werden können: RCDATA und STRING. In beiden Fällen werden diese Daten als Zeichenfolge variabler Länge zurückgegeben, sodass Sie sie bearbeiten und nach Ihren Wünschen verwenden können. Die spezifische Ressource, die Sie abrufen möchten, wird durch die ResID angegeben. Wenn die von Ihnen angeforderte ID nicht vorhanden ist, wird eine Null-Zeichenfolge (Null-Länge) zurückgegeben.

RCDATA

Diese Ressource enthält Rohdaten jeglicher Art. Es wird immer Byte für Byte gespeichert, so wie es ursprünglich zum Zeitpunkt der Kompilierung erstellt wurde. Im Allgemeinen sollte dieser Datentyp einer ANSI-Stringvariablen zugewiesen werden, damit keine Unicode-Konvertierungen durchgeführt werden. Die ResID, die diese Ressource identifiziert, kann ein numerischer Wert zwischen 0 und 65535 oder eine alphanumerische Bezeichnung sein, die als Zeichenfolgenausdruck (Zeichenfolgenliteral, Variable usw.) an die Funktion übergeben wird.

STRING

Diese Ressource enthält vordefinierte Zeichenfolgen in einer Zeichenfolgentabelle. Jede Zeichenfolge wird durch eine Ressourcen-ID-Nummer im Bereich von 0 bis 65535 identifiziert. Diese Nummer wird als ResID% verwendet, um zu bestimmen, welche Zeichenfolge abgerufen wird. Aufgrund des Formats, in dem Windows die Zeichenfolgen in Tabellen speichert, dürfen nur ganzzahlige numerische IDs verwendet werden. Alle Ressourcenzeichenfolgen werden intern im breiten Unicode-Format gespeichert.

Siehe auch

  • #RESSOURCE
  • RESOURCE SAVE FILE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


#RESSOURCE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › #RESOURCE

#RESSOURCE

Integrieren Sie ein PowerBASIC

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET] für #RESOURCE "file.rc", #RESOURCE RES, #RESOURCE PBR, direkte .res-Eingabe auf der Kommandozeile, BITMAP, ICON, CURSOR, RCDATA, FILE, WAVE, TYPELIB, MANIFEST, STRING, VERSIONINFO und das Alias $RESOURCE.

In V14 unterstützt: #RESOURCE "file.rc", #RESOURCE RES, "file.res", #RESOURCE PBR, "file.pbr", direkte .res-Eingabe auf der Kommandozeile, #RESOURCE BITMAP, #RESOURCE ICON, #RESOURCE CURSOR, #RESOURCE RCDATA, #RESOURCE FILE, #RESOURCE WAVE, #RESOURCE TYPELIB, #RESOURCE MANIFEST, #RESOURCE STRING, #RESOURCE VERSIONINFO sowie das Alias $RESOURCE.

Syntax

#RESOURCE BITMAP, ResID , " filespec.BMP "
#RESOURCE ICON, ResID , " filespec.ICO "
#RESOURCE MANIFEST, 1, "filespec.XML"
#RESOURCE RCDATA, ResID, " filespec.DAT "
#RESOURCE FILE, ResID, " filespec.BIN "
#RESOURCE STRING, ResID, " YourWideText "$$ [, LangID ]
#RESOURCE TYPELIB, 1, " filespec.TLB "
#RESOURCE WAVE, ResID , " filespec.WAV "
#RESOURCE VERSIONINFO <<block>>
#RESOURCE RES, " filespec.RES "
#RESOURCE PBR, " filespec.PBR "

Beschreibung

Diese Metaanweisung wird verwendet, um PowerBASIC-Ressourcendaten in Ihr Programm oder Ihre DLL einzubinden. Ressourcendaten können aus Bitmaps, Symbolen, Zeichenfolgen, COM-Typbibliotheken, Versionsinformationen und mehr bestehen. Sie können sogar benutzerdefinierte Binärdaten für Ihre persönlichen, speziellen Anforderungen einbetten.

Ressourcendaten können ein sehr wertvolles Werkzeug sein. Sie können Bitmaps und Symbole zwar aus separaten Dateien laden, wäre es aber nicht besser, sie einfach in Ihre Anwendung einzubetten? Wenn Sie die Bitmap benötigen, steht sie Ihnen jederzeit zur Verfügung! Sie müssen sich nicht mit Unmengen von Dateien herumschlagen. Jetzt haben Sie alles immer zur Hand.

Der Parameter ResID ist eine eindeutige Kennung, die Sie erstellen, um auf dieses Element zu verweisen. Es kann ein numerisches oder ein alphanumerisches Literal sein. Wenn es numerisch ist, muss es ein ganzzahliger Wert von 0 bis 65535 sein. Wenn es alphanumerisch ist, muss es mit einem Buchstaben beginnen und aus Buchstaben und Zahlen bestehen. Bei alphanumerischen Beschriftungen wird die Groß-/Kleinschreibung nicht beachtet. Der Dateispezifikationsparameter muss immer als Zeichenfolgenliteral ausgedrückt werden, das den Speicherort der Ressourcendaten angibt.

Wenn der Pfad einer Ressourcendatei nicht angegeben ist, sucht der Compiler im Standardverzeichnis.

Bei den meisten Programmiersprachen ist das Erstellen und Einbetten von Ressourcendaten ein umständlicher Prozess. Zuerst erstellen Sie mit einem Texteditor ein Ressourcenskript (eine .RC-Datei). Anschließend speichern Sie die .RC-Datei. Kompilieren Sie nun die .RC-Datei mit einem Ressourcen-Compiler, um eine .RES-Datei zu erhalten. Als nächstes konvertieren Sie es mit CVTRES.EXE von Microsoft oder einem anderen Konverterprogramm wie PBRES.EXE in eine verknüpfbare Datei. Schließlich verknüpfen Sie es mit einem Compiler oder Linkerprogramm in Ihre .EXE- oder .DLL-Datei. Was ist, wenn Sie feststellen, dass Sie eine kleine Änderung vornehmen müssen? Machen Sie alles noch einmal von Anfang an. Auch ältere Versionen von PowerBASIC litten unter diesem Problem.

Gibt es nicht einen besseren Weg? Ja, PowerBASIC wickelt jetzt den gesamten Prozess in einer einzigen Codezeile ab. Benötigen Sie eine eingebettete Bitmap?

#RESOURCE BITMAP, 123, „MyPicture.BMP“

PowerBASIC findet Ihre Bitmap in der Datei MyPicture.BMP und bettet sie in Ihre ausführbare Datei ein. Wenn Sie es verwenden müssen, können Sie es anhand der von Ihnen gewählten ID (123) referenzieren. Die ID kann ein ganzzahliger numerischer Wert oder ein Textname Ihrer Wahl sein. Um die Bitmap in einem Grafikfenster anzuzeigen, gehen Sie wie folgt vor:

GRAFIK-Render „#123“, (100.100)–(160.140)

String-Ressourcen

Die String-Ressource enthält String-Daten, die immer als Wide-Unicode-Zeichen erstellt und gespeichert werden. Es wird zur Laufzeit mit der Funktion RESOURCE$ abgerufen. Aufgrund der Art und Weise, wie Windows Zeichenfolgenressourcen in einer Zeichenfolgentabelle speichert, muss die ResID numerisch sein.

Die Zeichenfolgendaten müssen zwischen 1 und 127 Zeichen lang sein und dürfen keine eingebetteten Nullen (CHR$ (0)) enthalten. Die Zeichenfolgendaten können als Wide-String-Literal in Anführungszeichen („MyText“$$) oder als Wide-String-Literal-Ausdruck angegeben werden. Ein String-Literal-Ausdruck kann aus Kombinationen von breiten String-Gleichungen oder String-Literalen in breiten Anführungszeichen, der CHR$-Funktion, der SPACE$-Funktion und der STRING$-Funktion bei Verwendung mit numerischen Parametern erstellt werden.

VersionInfo-Ressourcen

Die VersionInfo-Ressource enthält Informationen über die Datei, wie z. B. ihre Versionsnummer, ihr vorgesehenes Betriebssystem, ihren ursprünglichen Dateinamen und vieles mehr. Diese Ressource soll mit den Versionsinformations-API-Funktionen verwendet werden, damit Windows Explorer und andere Programme die relevanten Informationen zu Ihrer EXE-Datei anzeigen können. In PBXB64-nativen Static-Library-Workflows duerfen unterstuetzte #RESOURCE-Eintraege in einer #COMPILE SLL-Quelle stehen und werden in den finalen Host-Link uebernommen, der die SLL verwendet.

Die VersionInfo-Ressource ist insofern einzigartig, als sie mehrere #RESOURCE-Metaanweisungen erfordert, die als vollständiger Block interpretiert werden. Sie müssen in der richtigen Reihenfolge hintereinander platziert werden, um korrekt verarbeitet zu werden.

#RESSOURCE VERSIONINFO

#RESSOURCE FILEFLAGS FlagValue&

#RESSOURCE FILEVERSION HiNum1& , LoNum1& , HiNum2& , LoNum2&

#RESOURCE PRODUCTVERSION HiNum1& , LoNum1& , HiNum2& , LoNum2&

#RESOURCE STRINGINFO " LangID ", " CharSet "

#RESSOURCE-VERSION$ „Kommentare“, „Zusätzliche Informationen“

#RESSOURCE-VERSION$ „Firmenname“, „PowerBASIC Inc.“

#RESSOURCE-VERSION$ „FileDescription“, „Präsentiert für Benutzer“

#RESSOURCE VERSION$ „FileVersion“, „Readable VerNum 1.02“

#RESSOURCE-VERSION$ „InternalName“, „Privat“

#RESSOURCE-VERSION$ „LegalCopyright“, „Copyright 2012 PB Inc.“

#RESSOURCE-VERSION$ „LegalTrademarks“, „xx ist ein...“

#RESOURCE VERSION$ „OriginalFilename“, „Originalname ohne Pfad“

#RESSOURCE-VERSION$ „PrivateBuild“, „Private Info“

#RESSOURCE VERSION$ „Produktname“, „Produkt verteilt mit“

#RESSOURCE VERSION$ „ProductVersion“, „Version verteilt mit“

#RESOURCE VERSION$ " SpecialBuild ", " Spezielle Informationen "

DATEIFLAGEN

FlagValue&

Beschreibung

%VS_FF_DEBUG

Die Datei enthält Debugging-Informationen oder wurde mit aktivierten Debugging-Funktionen kompiliert.

%VS_FF_PATCHED

Die Datei wurde geändert und ist nicht identisch mit der ursprünglichen Versanddatei mit derselben Versionsnummer.

%VS_FF_PRERELEASE

Bei der Datei handelt es sich um eine Entwicklungsversion, nicht um ein kommerziell veröffentlichtes Produkt.

%VS_FF_PRIVATEBUILD

Die Datei wurde nicht mit Standard-Freigabeverfahren erstellt. Wenn dieser Wert angegeben wird, müssen Sie ein PrivateBuild-Zeichenfolgenelement einschließen.

%VS_FF_SPECIALBUILD

Die Datei wurde vom ursprünglichen Unternehmen unter Verwendung von Standard-Veröffentlichungsverfahren erstellt, ist jedoch eine Variation der Standarddatei mit derselben Versionsnummer. Wenn dieser Wert angegeben wird, müssen Sie ein SpecialBuild-Zeichenfolgenelement einschließen.

STRINGINFO

LangID

Sprache

LangID

Sprache

&H0401

Arabisch

&H0415

Polnisch

&H0402

Bulgarisch

&H0416

Portugiesisch (Brasilien)

&H0403

Katalanisch

&H0417

Rätoromanisch

&H0404

Traditionelles Chinesisch

&H0418

Rumänisch

&H0405

&H0419

Russisch

&H0406

Dänisch

&H041A

Kroato-Serbisch (Latein)

&H0407

Deutsch

&H041B

Slowakisch

&H0408

&H041C

Albanisch

&H0409

US-Englisch

&H041D

Schwedisch

&H040A

Kastilisches Spanisch

&H041E

&H040B

Finnisch

&H041F

Türkisch

&H040C

Französisch

&H0420

&H040D

Hebräisch

&H0421

Bahasa

&H040E

Ungarisch

&H0804

Vereinfachtes Chinesisch

&H040F

Isländisch

&H0807

Schweizerdeutsch

&H0410

Italienisch

&H0809

Britisches Englisch

&H0411

Japanisch

&H080A

Spanisch (Mexiko)

&H0412

Koreanisch

&H080C

Belgisches Französisch

&H0413

&H0816

Portugiesisch (Portugal)

&H0414

Norwegisch - Bokmal

&H081A

Serbokroatisch (Kyrillisch)

&H0810

Schweizer Italiener

&H0C0C

Kanadisches Französisch

&H0813

Belgisches Niederländisch

&H100C

Schweizer Französisch

&H0814

Norwegisch - Nynorsk

STRINGINFO

CharSet

Zeichensatz

&H0000

7-Bit-ASCII

&H03A4

Japan (Umschalt – JIS X-0208)

&H03B5

Korea (Schicht – KSC 5601)

&H03B6

Taiwan (Big5)

&H04B0

Unicode

&H04E2

Latein-2 (Osteuropäisch)

&H04E3

Kyrillisch

&H04E4

Mehrsprachig

&H04E5

&H04E6

Türkisch

&H04E7

Hebräisch

&H04E8

Arabisch

RES/PBR-Ressourcen

Die zweite Gruppe von Syntaxbeispielen zeigt, wie Sie Ressourcen einbetten können, die mit einem Ressourcen-Compiler vorkompiliert wurden. Standardressourcen-Compiler geben eine binäre Ressource mit der Erweiterung .RES aus. PowerBASIC bettet diese Ressource genau so ein, wie sie in der Datei angegeben ist. Dieses Formular wird immer unterstützt, um Ressourcenformulare zu unterstützen, die für die meisten PowerBASIC-Programme normalerweise nicht benötigt werden oder normalerweise die Verwendung eines Ressourceneditors erfordern.

PBXB64 akzeptiert eine .res-Datei auch als zusätzliche Compiler-Eingabe auf der Kommandozeile. In dieser Form benötigt der BASIC-Quelltext keine #RESOURCE-Zeile; das Ressourcenobjekt wird direkt mit der erzeugten EXE verlinkt.

Das letzte Beispiel mit einer .PBR-Datei ist die Legacy-Form des PowerBASIC-PBRES-Dienstprogramms. PBXB64 akzeptiert explizites #RESOURCE PBR, "file.pbr" als Durchreichung vorkompilierter Ressourcen zur Kompatibilitaet. Fuer neuen Code ist #RESOURCE RES, "file.res" vorzuziehen.

Ressourcen zur Laufzeit abrufen

Verwenden Sie RESSOURCE$, um RCDATA- und STRING-Ressourcen zu lesen. Mit RESOURCE SAVE FILE können eingebettete BITMAP-, ICON-, CURSOR-, MANIFEST-, FILE-, WAVE-, TYPELIB- oder RCDATA-Ressourcen auf die Festplatte geschrieben werden. #RESOURCE FILE wird als binaere Nutzlast gespeichert, die mit dem Ressourcentyp RCDATA kompatibel ist. #RESOURCE WAVE und #RESOURCE TYPELIB werden als benannte binaere Ressourcentypen gespeichert.

Einschränkungen

Windows 95, 98 und ME bieten eingeschränkte Unterstützung für Ressourcen. Beim Kompilieren auf einer dieser Windows-Versionen dürfen nur #RESOURCE RES und #RESOURCE PBR verwendet werden. Andere Formen der #RESOURCE-Metaanweisung sind nicht funktionsfähig.

Fuer beste Kompatibilitaet mit aelteren PowerBASIC-Projekten sollten Legacy-RES- und PBR-Ressourcen von handgeschriebenen Inline-Ressourcen getrennt bleiben, sofern Ressourcen-IDs und -Typen nicht sicher kollisionsfrei sind.

Siehe auch

  • RESSOURCE$
  • RESOURCE SAVE FILE
  • Ressourcendateien

Getestetes Beispiel

Beispieldateien: tests/pb/test_resource_inline.pb, tests/pb/test_resource_res.pb, tests/pb/test_resource_cli_res.pb

Validierungsnachweis: tests/validate.toml enthaelt die pb_linkrun-Tests test_resource_inline, test_resource_res, test_resource_pbr, test_resource_cli_res, test_resource_manifest, test_resource_file, test_resource_wave und test_resource_typelib mit erwartetem Exit-Code 0. Der CLI-Test uebergibt tests/pb/fixtures/test_res.res als zusaetzliche Compiler-Eingabe.

RESOURCE SAVE FILE "RCDATA", 4, "out_res_dat.tmp"

PBXB64-Status: [ZERTIFIZIERT GETESTET]

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RESOURCE SAVE FILE ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? RESOURCE SAVE FILE

RESOURCE SAVE FILE

Schreibt eine eingebettete Ressource in eine Datei.

Typ:Anweisung |Kategorie:Datei- und Ressourcen-E/A

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET] f?r BITMAP, ICON, CURSOR und RCDATA.

Syntax

RESOURCE SAVE FILE "Typ", ResID, "Dateiname"

Parameter

  • Typ - Ein Zeichenfolgenliteral oder -ausdruck mit dem Ressourcentyp. Unterst?tzt werden "BITMAP", "ICON", "CURSOR" und "RCDATA".
  • ResID - Die numerische Ressourcen-ID, die im zugeh?rigen #RESOURCE-Metabefehl verwendet wurde.
  • Dateiname - Pfad der zu erstellenden oder zu ?berschreibenden Ausgabedatei.

Beschreibung

RESOURCE SAVE FILE extrahiert eine mit #RESOURCE eingebettete Ressource und schreibt die Rohbytes in die angegebene Datei. Damit lassen sich Bin?rdaten, Symbole oder Cursor aus der ausf?hrbaren Datei auspacken.

Die Anweisung liefert keinen R?ckgabewert. Wenn die Ressource nicht gefunden wird oder die Datei nicht erstellt werden kann, schl?gt der Vorgang stillschweigend fehl.

Beispiel

#RESOURCE BITMAP, 1, "logo.bmp"
#RESOURCE ICON, 2, "app.ico"

FUNCTION PBMAIN() AS LONG
    RESOURCE SAVE FILE "BITMAP", 1, "out_logo.bmp"
    RESOURCE SAVE FILE "ICON", 2, "out_app.ico"
END FUNCTION

Verifiziertes Beispiel: RESOURCE SAVE FILE - eingebettete Ressource auf Festplatte schreiben

Beispieldatei: tests/pb/test_resource_inline.pb

Validierungsnachweis: compiled with Release/PBXB64.exe tests/pb/test_resource_inline.pb -o tmp/help_io_samples/test_resource_inline.exe and executed with exit code 0.

#RESOURCE BITMAP, 1, "tests/pb/fixtures/test_inline.bmp"
#RESOURCE ICON,    2, "tests/pb/fixtures/test_inline.ico"
#RESOURCE CURSOR,  3, "tests/pb/fixtures/test_inline.cur"
#RESOURCE RCDATA,  4, "tests/pb/fixtures/test_inline.dat"
$RESOURCE RCDATA,  5, "tests/pb/fixtures/test_inline.dat"
#RESOURCE STRING,  10, "HelloRes"$$

#RESOURCE VERSIONINFO
#RESOURCE FILEVERSION 1, 2, 3, 4
#RESOURCE PRODUCTVERSION 5, 6, 7, 8
#RESOURCE FILEFLAGS 0
#RESOURCE STRINGINFO "0409", "04E4"
#RESOURCE VERSION$ "FileDescription", "PBXB64 inline resource test"
#RESOURCE VERSION$ "FileVersion", "1.2.3.4"

FUNCTION PBMAIN() AS LONG
    LOCAL f AS LONG
    LOCAL sz AS LONG
    LOCAL s AS STRING

    IF RESOURCE$("STRING", 10) <> "HelloRes" THEN FUNCTION = 1: EXIT FUNCTION

    RESOURCE SAVE FILE "BITMAP", 1, "out_res_bmp.tmp"
    f = FREEFILE
    OPEN "out_res_bmp.tmp" FOR BINARY AS #f
    sz = LOF(f)
    s = GET$(f, 2)
    CLOSE #f
    IF sz <> 58 THEN FUNCTION = 2: EXIT FUNCTION
    IF s <> "BM" THEN FUNCTION = 3: EXIT FUNCTION
    KILL "out_res_bmp.tmp"

    RESOURCE SAVE FILE "ICON", 2, "out_res_ico.tmp"
    f = FREEFILE
    OPEN "out_res_ico.tmp" FOR BINARY AS #f
    sz = LOF(f)
    CLOSE #f
    IF sz <> 66 THEN FUNCTION = 4: EXIT FUNCTION
    KILL "out_res_ico.tmp"

    RESOURCE SAVE FILE "CURSOR", 3, "out_res_cur.tmp"
    f = FREEFILE
    OPEN "out_res_cur.tmp" FOR BINARY AS #f
    sz = LOF(f)
    CLOSE #f
    IF sz <> 66 THEN FUNCTION = 5: EXIT FUNCTION
    KILL "out_res_cur.tmp"

    RESOURCE SAVE FILE "RCDATA", 4, "out_res_dat.tmp"
    f = FREEFILE
    OPEN "out_res_dat.tmp" FOR BINARY AS #f
    sz = LOF(f)
    s = GET$(f, sz)
    CLOSE #f
    IF s <> "InlineRCDATA" + CHR$(10) THEN FUNCTION = 6: EXIT FUNCTION
    KILL "out_res_dat.tmp"

    RESOURCE SAVE FILE "RCDATA", 5, "out_res_alias.tmp"
    f = FREEFILE
    OPEN "out_res_alias.tmp" FOR BINARY AS #f
    sz = LOF(f)
    s = GET$(f, sz)
    CLOSE #f
    IF s <> "InlineRCDATA" + CHR$(10) THEN FUNCTION = 7: EXIT FUNCTION
    KILL "out_res_alias.tmp"

    FUNCTION = 0
END FUNCTION

Verhalten: Das Beispiel kompiliert eine kleine PB-Datei, prueft Datei- oder Konsolen-E/A und liefert Exitcode 0 nur bei korrektem Verhalten. Focus statement: RESOURCE SAVE FILE "BITMAP", 1, "out_logo.bmp"

Siehe auch

  • #RESSOURCE
  • RESSOURCE$

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


RETAIN$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › RETAIN$

BEHALTEN$

Gibt eine Zeichenfolge zurück

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

sResult$ = RETAIN$( mainstr$ , [ANY] matchstr$ )

Beschreibung

RETAIN$ gibt eine Zeichenfolge zurück, die aus null oder mehr Kopien des vollständigen Ausdrucks matchstr$ besteht, die in mainstr$ gefunden werden. Alle anderen Zeichen werden entfernt.

Wenn die Option ANY enthalten ist, gibt matchstr$ eine Liste einzelner Zeichen an, die beibehalten werden sollen, wenn sie in mainstr$ gefunden werden.

Einschränkungen

Wenn matchstr$ ein leerer String ist, gibt RETAIN$ einen leeren String zurück.

Siehe auch

  • EXTRACT$
  • BLEIBEN$
  • REMOVE$
  • REPLACE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RETURN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › RETURN

ZURÜCK

Rückkehr von einem (

Typ:Anweisung |Kategorie: Procedures

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Beschreibung

RETURN beendet eine GOSUB-Unterroutine und uebergibt die Kontrolle an die Anweisung direkt nach dem aufrufenden GOSUB.

RETURN FLUSH entfernt die aktive GOSUB-Ruecksprungadresse, und der Programmablauf wird nach der RETURN FLUSH-Anweisung normal fortgesetzt. PBXB64 meldet RETURN FLUSH als Kompilierfehler, wenn kein aktiver GOSUB-Ruecksprungpunkt vorhanden ist.

PBXB64 verfolgt den aktiven GOSUB-Ruecksprungpunkt als vom Compiler erzeugten Kontrollflusszustand. Ein einfaches RETURN verzweigt zu dieser gespeicherten Fortsetzung und erhaelt die Bereinigung verschachtelter Anweisungen. RETURN FLUSH verwirft den offenen Ruecksprungpunkt bewusst und ist nur gueltig, solange ein solcher Punkt existiert; die negative Regression stellt sicher, dass der Compiler die Anweisung ausserhalb dieses Kontextes abweist.

Siehe auch

  • CALL
  • GOSUB
  • GOTO
  • AUF FEHLER
  • SUB/END SUB

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für ZURÜCK soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' ZURÜCK mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


RGB – PBXB64-Compiler-Hilfe

Startseite › Funktionen › RGB

RGB

Erstellen Sie ein RGB

Typ:Funktion |Kategorie:Mathematik und Numerik

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

result& = RGB( red& , green& , blue& )
result& = RGB( bgrexpr& )

Beschreibung

Ein RGB-Wert ist ein langer ganzzahliger Wert im Bereich von 0 bis &H00FFFFFF. Es wird verwendet, um verschiedenen PowerBASIC-Funktionen und Windows-API-Funktionen eine sehr genaue Farbe anzugeben. Die untersten drei Bytes des Werts geben jeweils die Intensität einer Primärfarbe an, die zusammen die resultierende Farbe bilden. Byte 1 (unterstes) stellt die rote Komponente dar, Byte 2 die grüne und Byte 3 die blaue Komponente. Sie können jeweils einen Wert im Bereich von 0 bis 255 annehmen. Byte 4 (höchstes) ist immer 0. Bei Verwendung mit 3 Parametern erzeugt die Funktion RGB() aus den drei Komponentenwerten einen RGB-Wert.

Einige Windows-API-Funktionen, insbesondere solche, die auf Device Independent Bitmaps (DIB) verweisen, erfordern, dass die Farben in umgekehrter Reihenfolge angegeben werden (Blau-Grün-Rot statt Rot-Grün-Blau). Um die Leistung und Ausführungsgeschwindigkeit zu maximieren, verwenden PowerBASIC-Anweisungen und -Funktionen, die auf diese Strukturen verweisen, auch das BGR-Format. Dazu gehören GRAPHIC GET BITS und GRAPHIC SET BITS .

Bei Verwendung mit einem Parameter übersetzt diese Funktion einen BGR-Wert in sein RGB-Äquivalent, indem sie das erste Byte mit dem dritten Byte austauscht und das Ergebnis zurückgibt.

Der BGR-Wert von Rot beträgt beispielsweise &HFF0000. RGB() übersetzt es in &H0000FF. Der Aufruf von BGR() mit diesem Wert konvertiert ihn zurück in &HFF0000.

Siehe auch

  • Built In RGB Color Equates
  • BGR

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RMDIR – PBXB64-Compiler-Hilfe

Startseite › Funktionen › RMDIR

RMDIR

Löschen Sie ein Festplattenverzeichnis (wie der DOS-Befehl RMDIR).

Typ:Anweisung |Kategorie: Dateiverwaltung

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

RMDIR path

Beschreibung

Pfad ist ein Verzeichnispfad, der eine Laufwerksspezifikation enthalten kann. RMDIR löscht das durch path angegebene Verzeichnis.

Diese Anweisung funktioniert wie die DOS-Befehle „RMDIR“ oder „RD“. Wie bei den DOS-Befehlen muss der Pfad ein gültiges, leeres Verzeichnis angeben, das nicht das Standardverzeichnis (aktuell) ist. Andernfalls tritt ein Laufzeitfehler 75 auf („Pfad-/Dateizugriffsfehler“).

RMDIR kann lange Dateinamen (LFNs) verwenden.

PBXB64 senkt RMDIR path$ auf den eingebetteten Helfer bestof_rmdir ab. Dieser ruft die Win32-API RemoveDirectoryA auf.

Einschränkungen

Die fokussierte PBXB64-Zertifizierung deckt das Entfernen leerer temporaerer Verzeichnisse ab. Nichtleere Verzeichnisse, Entfernen des aktuellen Verzeichnisses, Unicode-Pfade, ungueltige Pfade und PBWin-ERR-Paritaet bleiben breitere Datei-/Pfad-Kompatibilitaetsarbeit.

Siehe auch

  • CHDIR
  • TÖTEN
  • MKDIR

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


ROTATE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › DREHEN

DREHEN

Drehen Sie die Bits in einer ganzzahligen Klasse

Typ:Anweisung |Kategorie:Mathematik und Numerik

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ROTATE {LEFT | RIGHT} ivar , count

Beschreibung

ivar muss einer der Variablentypen der Integralklasse sein: Byte, Word, Integer, Double-word, Long-integer oder Quad-integer. count ist die Anzahl der Bits, um die ivar rotiert werden soll. ROTATE dreht alle Bits in ivar ohne besondere Berücksichtigung des Vorzeichenbits einer vorzeichenbehafteten Integralklassenvariablen.

Siehe auch

  • BIT-Funktion
  • BIT-Anweisung
  • BITS
  • UMSCHALT

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RSET$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › RSET$

RSET$

Gibt eine Zeichenfolge zurück

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET] für LSET$/RSET$-Funktionsformen und LSET/RSET USING; abgedeckt durch test_lset_rset_functions und test_lset_rset_using

Syntax

a$ = RSET$( string_expression , strlen& [USING ustring_expression ])

Beschreibung

RSET$ richtet die Zeichenfolge string_expression rechtsbündig in eine Zeichenfolge mit strlen&-Zeichen aus.

Wenn ustring_expression null (leer) ist oder nicht angegeben ist, füllt RSET$ string_expression mit Leerzeichen auf. Andernfalls füllt RSET$ die Zeichenfolge mit dem ersten Zeichen von ustring_expression auf und verwendet weiterhin strlen& als Ergebnisbreite.

Wenn string_expression kürzer als strlen& ist, richtet RSET$ string_expression innerhalb der zugewiesenen String-Variablen ( a$ ) rechtsbündig aus und füllt die linke Seite wie oben beschrieben auf; andernfalls gibt RSET$ die strlen&-Bytes ganz links von string_expression zurück.

Bei der Funktionsform ist das optionale USING-Argument eine Fuellzeichenfolge. Bei der Anweisungsform RSET target = value USING mask wird die Maske als Feldbreitenangabe behandelt: & laesst die Zeichenfolge unveraendert, ! erzeugt ein Einzelzeichen, und alle anderen Maskenzeichen bestimmen die Ausgabebreite. Die vollstaendigen PowerBASIC-Maskensemantiken (richtungsabhaengige </> und zentrierte \...\) sind vereinfacht auf Links-/Rechtsausrichtung entsprechend der verwendeten Anweisung.

Beispiel

a$ = RSET$("cat", 5, "*")  ' **cat
a$ = RSET$("cat", 5, "")   '   cat

Siehe auch

  • CSET
  • CSET$
  • ERHALTEN
  • LET
  • LSET
  • LSET$
  • SETZEN
  • ZURÜCKSETZEN
  • RSET
  • STRINSERT$
  • TYP EINGESTELLT

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RUN - PBXB64 Help

Startseite › General Reference › RUN

RUN

Startet einen Kindprozess und gibt dessen Exit-Code zurueck.

Typ: Runtime method | Kategorie: System

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED] fuer den fokussierten synchronen Start mit Exit-Code-Rueckgabe.

Syntax

exitCode& = RUN(command$)

Beschreibung

RUN wird auf den eingebetteten Laufzeithelfer bestof_run gesenkt. PBXB64 startet den Befehl als Windows-Kindprozess, wartet auf dessen Ende und gibt den Exit-Code zurueck. Wenn der Prozess nicht gestartet werden kann, gibt der fokussierte Laufzeitvertrag -1 zurueck.

Praktische Verwendung

Verwenden Sie RUN fuer kleine, synchron pruefbare Befehle, bei denen der Prozess vor der Rueckgabe sauber beendet sein muss. Waehlen Sie einen Befehl, dessen Exit-Code und Nebenwirkungen im Test eindeutig beobachtbar bleiben.

Prozessverhalten

RUN startet den Befehl, wartet auf dessen Ende und schreibt den Exit-Code in den Zielausdruck zurueck.

Fehlerhinweise

Wenn die Prozesserzeugung fehlschlaegt, liefert der fokussierte Vertrag -1. Das Beispiel sollte daher einen Befehl verwenden, der auf dem Testsystem vorhanden ist.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    IF RUN("cmd.exe /C exit 7") <> 7 THEN FUNCTION = 1
END FUNCTION

Geprueftes Beispiel

Beispieldatei: examples/basic/test_delay_run_sysinfo.pb

Validierungsnachweis: In tests/validate.toml als test_delay_run_sysinfo registriert; fokussierte pb_linkrun-Validierung belegt die Weitergabe des Exit-Codes.

Einschraenkungen

Breitere PB-kompatible Formen fuer Shell-Quoting, Sichtbarkeit, No-Wait und Fehlerpolitik werden hier nicht beansprucht.

Fehlerfaelle

Wenn die Prozesserzeugung fehlschlaegt, liefert RUN -1. Shell-Quoting, Arbeitsverzeichnis und Verfuegbarkeit des Befehls sollten deshalb in einem eigenen Testfall stabil gemacht werden.

Hinweise

  • Der zertifizierte Teil ist synchroner Prozessstart mit Exit-Code-Rueckgabe.
  • Breitere PB-kompatible Formen fuer Shell-Quoting, Sichtbarkeit, No-Wait und Fehlerpolitik werden hier nicht beansprucht.

Siehe auch

DELAY | SYSINFO

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Register speichern – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Register speichern

Register speichern

Beim Schreiben von Assembler-Code in 32-Bit-Windows gibt es eine Konvention, die die Verwendung von Registern regelt, damit Programmierer vorhersehbar und völlig zuverlässig mit den Windows-API-Funktionen interagieren können

Typ:Schlüsselwort |Kategorie: Memory & Pointers

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Allerdings stellen die bei einem 80x86-Prozessor verfügbaren Register eine sehr begrenzte Ressource dar und werden von jeder laufenden Anwendung (Prozess) und auch vom Betriebssystem selbst genutzt. Daher ist eine zuverlässige Methode zur Verwendung von Registern für das Schreiben zuverlässigen Assemblercodes sehr wichtig.

Ein 80x86-Prozessor verfügt über acht allgemeine Integralregister: EAX, EBX, ECX, EDX, ESI, EDI, ESP und EBP. Von diesen werden ESP und EBP fast ausschließlich zur Verwaltung des Ein- und Ausstiegs in eine Prozedur verwendet, sodass praktisch nur sechs Allzweckregister für die Programmierung auf Anwendungsebene verfügbar sind.

Anschließend teilt die Windows-Konvention die verbleibenden Register auf, sodass drei (EAX, ECX und EDX) innerhalb der Sub-Funktion/Methode/Eigenschaft, die sie verwendet, frei geändert werden können, während die anderen drei durch die Prozedur erhalten bleiben müssen (EBX, ESI und EDI). Im Rahmen dieser Diskussion bezeichnen wir diese beiden Sätze als Scratch- bzw. Volatile-Register.

Zusammenfassend lässt sich sagen, dass PowerBASIC EBX, ESI und EDI automatisch auf Prozedurebene beibehält, der Programmierer jedoch dafür verantwortlich ist, sowohl die Scratch- als auch die flüchtigen Register innerhalb der Prozedur beizubehalten.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Register speichern soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Register speichern mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Speichern von Registern auf Prozedurebene – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Speichern von Registern auf Prozedurebene
Hilfe zum PBXB64-Compiler

Speichern von Registern auf Prozedurebene

Um den Windows-Programmierkonventionen zu entsprechen, muss PowerBASIC eine „sichere“ Umgebung für den verfügbaren Funktionsumfang bereitstellen. Dies wird durch die transparente Beibehaltung der drei Vo erreicht

Typ:Schlüsselwort |Kategorie: Memory & Pointers

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

! PUSH EBX ' Automatisch von PowerBASIC hinzugefügt

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.


Speichern der FPU-Register – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Speichern der FPU-Register

Speichern der FPU-Register

Während die CPU über Register mit festen Namen (EAX usw.) verfügt, verfügt die FPU (Floating-Point Unit oder Co-Prozessor) über stapelartige Register, die entsprechend ihrer Position im Stapel nummeriert sind: ST(0) {t

Typ:Schlüsselwort |Kategorie: Memory & Pointers

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Beachten Sie, dass der Begriff Laden verwendet wird, um das Platzieren eines Werts auf dem FPU-Stack zu beschreiben, er jedoch eher wie eine PUSH-Operation funktioniert. In PowerBASIC kommt es nicht darauf an, welche FPU-Register verfügbar sind, sondern dass dem Programmierer normalerweise vier Register (oder Stack-Slots) zur Verfügung stehen. Wenn mehr benötigt werden, sollte der Stapel gespeichert und entsprechend wiederhergestellt werden.

Um den gesamten FPU-Stack zu erhalten, kümmern sich die Mnemoniken FSAVE und FRSTOR um die Erhaltung bzw. Wiederherstellung des FPU-Stacks. Diese funktionieren ähnlich wie die PUSHFD- und POPFD-CPUs, sind jedoch notorisch langsam in der Ausführung und FPU-Programmierer vermeiden ihre Verwendung oft, es sei denn, dies ist notwendig. Sie können jedoch hilfreich sein, wenn Sie mit dem Schreiben von FPU-Code beginnen, da sie die Erhaltung und Wiederherstellung des FPU-Stacks gewährleisten.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Speichern der FPU-Register soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Speichern der FPU-Register mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


SAY - PBXB64 Help

Startseite › General Reference › SAY

SAY

SAPI-Sprachausgabe

Kind: Runtime helper | Category: WEB / Runtime Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

SAY text$ TO result&

Beschreibung

SAY ist die eigene Seite fuer die getestete Sprachausgabe-Anweisung. PBXB64 senkt sie auf den eingebetteten SAPI/COM-Laufzeitpfad ab, uebergibt den angeforderten Text an die Sprachausgabe und speichert den Rueckgabecode in der vom Aufrufer uebergebenen Ergebnisvariablen.

Diese Seite dokumentiert einen getesteten Laufzeithelfer mit direktem Befehls-Lookup. Halten Sie das Beispiel auf die echte Aufrufform und den Rueckgabewert fokussiert.

Aufrufhinweise

Verwenden Sie SAY, wenn Sie einen sichtbaren Laufzeitpfad und einen Statuswert brauchen, nicht gepufferte Konsolenausgabe. Die fokussierte Validierung liefert 0 bei Erfolg und -1, wenn SAPI oder COM nicht verwendet werden koennen.

Fehlerfaelle

  • Wenn SAPI oder COM nicht verfuegbar ist, liefert der Laufzeitpfad -1 und das Beispiel dokumentiert diesen Rueckfall explizit.
  • Behandeln Sie SAY nicht als Konsolenausgabe; es ist ein Sprachausgabe-Helfer mit numerischem Rueckgabevertrag.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL rc AS LONG
    SAY "Ready" TO rc&
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_say_statement.pb`. Verwendet dynamisches COM/SAPI und liefert 0 bei Erfolg oder -1, wenn SAPI/COM nicht verfuegbar ist.

Grenzen

Hier wird nur das getestete PBXB64-Verhalten dokumentiert. Weitere Kodierungen, Objektformen, Netzwerkzustaende oder kryptografische Richtlinien benoetigen eigene Tests, bevor die Hilfeaussagen erweitert werden.

Siehe auch

  • WEB-Erweiterungen
  • BASIC-Sprachreferenz

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SCAN$ - PBXB64-Compiler-Hilfe

Startseite â€º BASIC-Frontend â€º Befehlsreferenz â€º String-Funktionen â€º SCAN$
Hilfe zum PBXB64-Compiler

SCAN$

Gibt das erste Zeichen in MainString zurueck, das auch in MatchString vorkommt.

Kind: Funktion | Category: String-Funktionen

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [ZERTIFIZIERT GETESTET]

Syntax

result$ = SCAN$( MainString , MatchString )

Beschreibung

Gibt das erste Zeichen in MainString zurueck, das auch in MatchString vorkommt. SCAN$ durchlaeuft MainString von links nach rechts und gibt das erste Quellzeichen zurueck, das auch in MatchString vorhanden ist.

Praktische Verwendung

Verwenden Sie SCAN$, wenn Sie eine schnelle Mengenpruefung brauchen, die das passende Zeichen selbst und nicht nur eine Position zurueckgibt.

Parameter und Ergebnisse

Argumente muessen den Datentypen, der Reihenfolge und den optionalen Teilen aus dem Syntaxblock folgen. Initialisieren Sie Zielvariablen vor dem Aufruf, damit unveraenderte Werte nach einem Fehler sichtbar bleiben.

Einschränkungen

Wenn MainString oder MatchString leer ist, ist das Ergebnis leer.

Verhalten

SCAN$ durchlaeuft MainString von links nach rechts und gibt das erste Quellzeichen zurueck, das auch in MatchString vorhanden ist.

Das Ergebnis ist eine ein Zeichen lange Zeichenfolge. Wenn kein Quellzeichen zur Menge passt, liefert SCAN$ eine leere Zeichenfolge.

Der Vergleich ist fuer die aktuelle ANSI-String-Oberflaeche byteorientiert und unterscheidet Gross- und Kleinschreibung.

Verwendungshinweise

Verwenden Sie SCAN$, wenn Sie eine schnelle Mengenpruefung brauchen, die das passende Zeichen selbst und nicht nur eine Position zurueckgibt.

Wiederholte Zeichen in MatchString veraendern das Ergebnis nicht. Das erste passende Quellzeichen gewinnt.

Grenzfaelle

Wenn MainString oder MatchString leer ist, ist das Ergebnis leer.

Wenn Sie eine Position brauchen, verwenden Sie INSTR. Wenn Sie einen Zaehler brauchen, verwenden Sie TALLY. Wenn Sie die erste nicht passende Position brauchen, verwenden Sie VERIFY.

Beispiel

FUNCTION PBMAIN() AS LONG
    DIM src AS STRING
    DIM setchars AS STRING
    DIM found AS STRING

    src = "abc1def"
    setchars = "0123456789"
    found = SCAN$(src, setchars)
    IF found <> "1" THEN FUNCTION = 1 : EXIT FUNCTION

    src = "abcdef"
    found = SCAN$(src, setchars)
    IF found <> "" THEN FUNCTION = 2 : EXIT FUNCTION

    FUNCTION = 0
END FUNCTION

Test- und Dokumentationshinweise

Mit tests/pb/test_string_scan_tally_verify.pb kompiliert und ausgefuehrt; Exitcode 0.

Validierungsbeleg

Mit tests/pb/test_string_scan_tally_verify.pb kompiliert und ausgefuehrt; Exitcode 0. SCAN$(src, setchars)

Verifiziertes Beispiel

Beispieldatei: tests/pb/test_string_scan_tally_verify.pb

Validierungsbeleg: Mit tests/pb/test_string_scan_tally_verify.pb kompiliert und ausgefuehrt; Exitcode 0.

FUNCTION PBMAIN() AS LONG
    DIM src AS STRING
    DIM setchars AS STRING
    DIM found AS STRING

    src = "abc1def"
    setchars = "0123456789"
    found = SCAN$(src, setchars)
    IF found <> "1" THEN FUNCTION = 1 : EXIT FUNCTION

    src = "abcdef"
    found = SCAN$(src, setchars)
    IF found <> "" THEN FUNCTION = 2 : EXIT FUNCTION

    FUNCTION = 0
END FUNCTION

Fokus: SCAN$(src, setchars)

Siehe auch

  • INSTR
  • TALLY
  • VERIFY

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


BILDSCHIRM – PBXB64-Compiler-Hilfe

Startseite › Konsole › BILDSCHIRM

BILDSCHIRM

Legt die Basislinie für den Konsolenbildschirmmodus fest und löscht den aktiven Konsolenpuffer.

Typ: Anweisung / Funktion | Kategorie: Konsole

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SCREEN mode
value = SCREEN(row, col)

Verhalten

SCREEN mode Zeichnet den angeforderten Modus auf, löscht den Konsolenpuffer und bewegt den Cursor in die obere linke Ecke. SCREEN(row, col) liest ein Zeichen aus dem Konsolenkoordinatenpfad, der bereits von der Konsolenlaufzeit abgedeckt wird.

Tests

test_screen_page.pb deckt das Abrechnungsformular ab. test_screen.pb deckt die Funktionsform ab.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SCROLLBAR SEITENGRÖSSE ERHALTEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › SCROLLBAR GET SEITENGRÖSSE

SCROLLBAR SEITENGRÖSSE ERHALTEN

Manipulate a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SCROLLBAR GET PAGESIZE hDlg , id& TO datav&
SCROLLBAR GET POS hDlg , id& TO datav&
SCROLLBAR GET RANGE hDlg& , id& TO LoDatav& , HiDatav&
SCROLLBAR GET TRACKPOS hDlg , id& TO datav&
SCROLLBAR SET PAGESIZE hDlg , id& , pagesize&
SCROLLBAR SET POS hDlg , id& , position&
SCROLLBAR SET RANGE hDlg , id& , lolimit& , hilimit&
SCROLLBAR SET TRACKPOS hDlg , id& , trackpos&

Beschreibung

In jedem der folgenden Beispiele und Beschreibungen wird das SCROLLBAR-Steuerelement, das Gegenstand der Anweisung ist, durch das Handle des Dialogfelds identifiziert, das Eigentümer der ScrollBar ist ( hDlg ), und durch den eindeutigen Steuerelementbezeichner, den Sie ihm bei der Erstellung in CONTROL ADD SCROLLBAR gegeben haben. Um die Farbe des Balkens oder des Hintergrunds zu ändern, verwenden Sie CONTROL SET COLOR .

SCROLLBAR GET PAGESIZE hdlg , id& TO datav&

Die aktuelle Seitengröße der ScrollBar wird abgerufen und der durch datav& bezeichneten Variablen zugewiesen. Bei der Erstellung der ScrollBar beträgt die Standardseitengröße 10.

SCROLLBAR GET POS hdlg , id& TO datav&

Die aktuelle Position der ScrollBar wird abgerufen und der durch datav& bezeichneten Variablen zugewiesen. Bei der Erstellung der ScrollBar ist die Standardposition 0.

SCROLLBAR GET RANGE hdlg , id& TO LoDatav& , HiDatav&

Der aktuelle Bereich der ScrollBar wird abgerufen und den durch LoDatav& und HiDatav& bezeichneten Variablen zugewiesen. Bei der ScrollBar-Erstellung liegt der standardmäßige ScrollBar-Bereich zwischen 0 und 100.

SCROLLBAR GET TRACKPOS hdlg , id& TO datav&

Die aktuelle Position des vom Benutzer gezogenen Bildlauffelds wird abgerufen und der durch datav& angegebenen Variablen zugewiesen. Dies wird normalerweise gelesen, während auf die Meldungen %SB_THUMBPOSITION oder %SB_THUMBTRACK reagiert wird. Der TRACKPOS wird dann verwendet, um die Bildlaufposition mit SCROLLBAR SET POS zu verschieben.

SCROLLBAR SET SEITENGRÖSSE hdlg , id& , seitengröße&

Die aktuelle Seitengröße der ScrollBar wird auf den Wert des Parameters pagesize& gesetzt und die Leiste wird neu gezeichnet, um die neue Position widerzuspiegeln.

SCROLLBAR SET POS hDlg , id& , position&

Die aktuelle Position der ScrollBar wird auf den Wert des Parameters position& gesetzt und die Leiste wird neu gezeichnet, um die neue Position widerzuspiegeln.

SCROLLBAR SET RANGE hdlg , id& , lolimit& , hilimit&

Der Bereich für die ScrollBar ist von lolimit& bis hilimit& angegeben. Wenn lolimit& größer als hilimit& ist, sind die Ergebnisse undefiniert.

SCROLLBAR SET TRACKPOS hdlg , id& , trackpos&

Die aktuelle Tracking-Position wird auf trackpos& gesetzt und die sichtbare ScrollBar-Position wird mit diesem Wert synchronisiert.

PBXB64-Implementierungshinweise

PBXB64 implementiert alle oben gezeigten dokumentierten SCROLLBAR-Anweisungsformen. Der Compiler reduziert sie auf eingebettete Win32-Bildlaufleisten-Laufzeithilfsprogramme. Für die ausführbare Datei des Kunden sind keine externen Objektdateien erforderlich.

Die Regressionssuite umfasst SET RANGE, SET POS, GET POS, GET RANGE, SET PAGESIZE, GET PAGESIZE, GET TRACKPOS und SET TRACKPOS.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG SCROLLBAR HINZUFÜGEN
  • STEUERUNG FARBE EINSTELLEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SELECT - SELECT-CASE-Block beginnen — PBXB64 Help

Startseite › General Reference › SELECT - SELECT-CASE-Block beginnen — PBXB64 Help
Hilfe zum PBXB64-Compiler

SELECT - SELECT-CASE-Block beginnen

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

SELECT CASE value
CASE 1
END SELECT

Detailverhalten

Beginnt einen SELECT-CASE-Kontrollblock. Das detaillierte CASE-Verhalten ist auf der SELECT-CASE-Seite dokumentiert.

Praktische Verwendung

Verwenden Sie SELECT als Einstieg in SELECT CASE-Formen, wenn mehrere CASE-Zweige auf einen Ausdruck pruefen sollen. Der eigentliche Block wird mit CASE und END SELECT vervollstaendigt.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

SELECT ohne CASE/END SELECT ist nur ein unvollstaendiger Anker. Wenn die Branching-Struktur fehlt, muss der Parser dies klar ablehnen.

Verifiziertes Beispiel

Abgedeckt durch examples/basic/v4_control.bas (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Sequentielle Dateien – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Sequentielle Dateien

Sequentielle Dateien

Sequentielle Dateitechniken bieten eine einfache Möglichkeit, Dateien zu lesen und zu schreiben. Die sequentiellen Dateibefehle von PowerBASIC manipulieren Textdateien: Dateien mit ANSI- oder WIDE-Zeichen mit Wagenrücklauf/LIN

Typ:Schlüsselwort |Kategorie:Datei-E/A

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Der beste Grund für die Verwendung sequenzieller Dateien ist möglicherweise der Grad ihrer Portabilität auf andere Programme, Programmiersprachen und Computer. Aus diesem Grund können Sie sequentielle Dateien oft als den gemeinsamen Nenner der Datenverarbeitung betrachten, da sie von Textverarbeitungsprogrammen und Editoren (wie PowerBASIC) gelesen, von anderen Anwendungen (wie Datenbankmanagern) übernommen und über das Internet an andere Computer gesendet werden können.

Die Idee hinter sequentiellen Dateien ist einfach: Schreiben Sie in sie, als wären sie der Bildschirm, und lesen Sie von ihnen, als wären sie die Tastatur.

Erstellen Sie eine sequentielle Datei mit den folgenden Schritten:

AUSGABE: Wenn eine Datei nicht existiert, wird eine neue Datei erstellt. Wenn eine Datei bereits vorhanden ist, wird ihr Inhalt gelöscht und die Datei wird dann als neue Datei behandelt.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Sequentielle Dateien soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Sequentielle Dateien mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Serielle Kommunikation – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Serielle Kommunikation

Serielle Kommunikation

Überblick über die Programmierung der seriellen Schnittstelle (COMM).

Typ:Konzeptionell |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Überblick

Dieses Thema bietet Hintergrundinformationen und praktische Anleitungen. Eine detaillierte Syntax finden Sie auf den entsprechenden Befehlsseiten.

Beschreibung

Serielle Kommunikation gehoert zur seriellen Kommunikationsfamilie. Die aktuelle PBXB64-Oberflaeche prueft das Oeffnen, Senden, Lesen, Zeilenlesen, Reset und Schliessen eines Kommunikationshandles; reale Hardware ist nur fuer den erfolgreichen Pfad noetig.

Syntax

COMM OPEN "COMn" AS #hComm [CHR = ANSI|WIDE]
COMM SET #hComm, ...
COMM PRINT #hComm, string$
COMM LINE #hComm, string$
COMM LINE INPUT #hComm, text$
COMM RESET #hComm, FLOW
COMM CLOSE #hComm

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL h AS LONG
    COMM OPEN "PBXB64_NO_SUCH_COMM_PORT" AS #h
    IF h <> 0 THEN
        COMM CLOSE #h
        FUNCTION = 1
    END IF
END FUNCTION

Validierungsbeleg

Validierungsbeleg: tests/pb/test_comm_print_line_input.pb, tests/pb/test_comm_reset.pb, examples/basic/test_comm_open_missing.pb, und examples/basic/test_comm_flow_missing.pb belegen den aktuellen Handle- und Fehlerpfad. Der Beispielpfad ist absichtlich portable und faellt geschlossen, wenn kein gueltiger Port verfuegbar ist.

Laufzeitvoraussetzungen

Serielle Beispiele brauchen ein echtes COM-Geraet oder einen dokumentierten Loopback/Testadapter. Wenn ein realer Port verfuegbar ist, muessen COMM SET-Parameter vor dem Datentransfer gesetzt und das Handle danach mit COMM CLOSE freigegeben werden.

Siehe auch

  • COMM OPEN
  • COMM PRINT
  • COMM RESET
  • COMM LINE
  • COMM RECV
  • COMM SEND
  • COMM SET
  • COMM TIMEOUT
  • COMM CLOSE


SETATTR – PBXB64-Compiler-Hilfe

Startseite › Funktionen › SETATTR

SETATTR

Legen Sie die Dateisystemattribute einer Festplattendatei oder eines Verzeichnisses fest.

Typ:Anweisung |Kategorie: Dateiverwaltung

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SETATTR filespec$ , attribute

Beschreibung

filespec$ gibt einen Dateinamen an (optional einschließlich eines Laufwerksbuchstabens und eines Verzeichnispfads). Attribut ist ein Standard-Betriebssystemattributcode:

Attribut

Beschreibung

Gleichsetzen

Normal

%NORMAL

Schreibgeschützt

%READONLY

Versteckt

%VERSTECKT

System

%SYSTEM

Archiviert

%ARCHIV

Der Attributcode einer bestimmten Datei oder eines bestimmten Verzeichnisses kann aus einer Kombination einzelner Attributwerte erstellt werden. Wenn Sie beispielsweise ein Attribut von 0 verwenden, ist filespec$ eine reguläre Datei: nicht schreibgeschützt, nicht versteckt, nicht systemisch und nicht archiviert.

PBXB64 senkt die Anweisung SETATTR path$, attr und die Funktionsform SETATTR(path$, attr) auf den eingebetteten Helfer bestof_setattr ab. Dieser ruft die Win32-API SetFileAttributesA auf. Die Funktionsform gibt bei Erfolg 0 und bei Fehler -1 zurueck.

Einschränkungen

Die fokussierte PBXB64-Zertifizierung deckt Schreibschutz- und Normal-Attribut-Rundlauf mit einer temporaeren Datei ab. Fehlerparitaet fuer ungueltige Pfade, Verzeichnisattribute, Unicode-Pfade und kombinierte Flag-Sonderfaelle bleiben breitere Datei-/Pfad-Arbeit.

Siehe auch

  • DIR$
  • DATEIATTR
  • GETATTR

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SETEOF – PBXB64-Compiler-Hilfe

Startseite › Funktionen › SETEOF

SETEOF

Kürzen oder erweitern Sie ein

Typ:Anweisung |Kategorie:Datei-E/A

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SETEOF [#] filenum&

Beschreibung

SETEOF kürzt oder erweitert eine geöffnete Datei bis zu ihrer aktuellen Dateizeigerposition (Lesen/Schreiben), die explizit mit der SEEK-Anweisung festgelegt werden kann.

Im Gegensatz zu 16-Bit-Windows und DOS BASIC schneidet Win32 eine Datei nicht ab, wenn Sie einfach eine leere Zeichenfolge hineinschreiben. Daher wird die SETEOF-Anweisung bereitgestellt, um diesem Bedarf gerecht zu werden.

Siehe auch

  • CLOSE
  • DATEIATTR
  • FLÜSSIG
  • OFFEN
  • SEEK-Funktion
  • SEEK-Anweisung

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


Einrichten einer Fehlerfalle – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Setzen einer Fehlerfalle

Setzen einer Fehlerfalle

Um eine Fehlerfalle zu aktivieren, verwenden Sie die ON ERROR GOTO-Anweisung an der Stelle, an der Sie die Fehlerfalle innerhalb der Prozedur aktivieren möchten. Der Fehlerbehandlungscode muss in dieser Prozedur enthalten sein. Eine Fehlerfalle ist nur aktiviert, wenn

Typ:Schlüsselwort |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Fehlerpfad-Prüfung

Fehlerbehandlungsseiten sollen den normalen Pfad und den Fehlerpfad zeigen. Ein vollständiges Beispiel löst absichtlich einen bekannten Fehler aus, prüft den dokumentierten Fehlerwert, stellt wieder her oder beendet sauber und zeigt, dass spätere Anweisungen in der erwarteten Reihenfolge laufen.

Zustandsregeln

Dokumentieren Sie, welche Variablen, Handler oder Systemwerte durch die Operation geändert werden. Vermeiden Sie Beispiele, die einen Fehler durch ungeprüftes Weiterlaufen verdecken.

Migrationshinweise

Beim Portieren älteren PB-Codes sind Annahmen zu Zeilennummern, Handler-Gültigkeit, verschachtelten Prozeduren und Windows-API-Fehlern neu zu prüfen.


SHA1$ - PBXB64 Help

Startseite › General Reference › SHA1$

SHA1$

Berechnet einen SHA-1-Digest-String.

Kind: Runtime helper | Category: WEB / Runtime Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

digest$ = SHA1$(text$)

Beschreibung

Diese eigene Seite stellt sicher, dass Befehlsuche, Stichwortindex und direkte Dateinamenpruefung die getestete Laufzeitfunktion unmittelbar finden. Die gruppierte WEB-Seite bleibt die breitere Familienreferenz.

Diese Seite dokumentiert einen deterministischen String-Helfer. Kodierungsfunktionen liefern transformierten Text zurueck, waehrend Hash-Funktionen feste, kleingeschriebene Hex-Digests liefern.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL rc AS LONG
    digest$ = SHA1$("abc")
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_web_all.pb` und `test_web_hash_json.pb`.

Grenzen

Dokumentieren Sie hier nur die getesteten Byte- oder String-Transformationen. Wenn es einen Rueckwaerts-Helfer gibt, pruefen Sie ihn separat, statt Symmetrie aus der Vorwaertsform abzuleiten.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

SHA1$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

SHA1$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer hashing-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input bytes, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

SHA1$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


SHA256$ - PBXB64 Help

Startseite › General Reference › SHA256$

SHA256$

Berechnet einen SHA-256-Digest-String ueber den eingebetteten BCrypt-gestuetzten Laufzeitpfad.

Kind: Runtime helper | Category: WEB / Runtime Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

digest$ = SHA256$(text$)

Beschreibung

Diese eigene Seite stellt sicher, dass Befehlsuche, Stichwortindex und direkte Dateinamenpruefung die getestete Laufzeitfunktion unmittelbar finden. Die gruppierte WEB-Seite bleibt die breitere Familienreferenz.

Diese Seite dokumentiert einen deterministischen String-Helfer. Kodierungsfunktionen liefern transformierten Text zurueck, waehrend Hash-Funktionen feste, kleingeschriebene Hex-Digests liefern.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL rc AS LONG
    digest$ = SHA256$("abc")
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_web_all.pb` und `test_web_hash_json.pb`.

Grenzen

Dokumentieren Sie hier nur die getesteten Byte- oder String-Transformationen. Wenn es einen Rueckwaerts-Helfer gibt, pruefen Sie ihn separat, statt Symmetrie aus der Vorwaertsform abzuleiten.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

SHA256$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

SHA256$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer hashing-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input bytes, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

SHA256$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


SHA512$ - PBXB64 Help

Startseite › General Reference › SHA512$

SHA512$

Berechnet einen SHA-512-Digest-String ueber den eingebetteten BCrypt-gestuetzten Laufzeitpfad.

Kind: Runtime helper | Category: WEB / Runtime Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

digest$ = SHA512$(text$)

Beschreibung

Diese eigene Seite stellt sicher, dass Befehlsuche, Stichwortindex und direkte Dateinamenpruefung die getestete Laufzeitfunktion unmittelbar finden. Die gruppierte WEB-Seite bleibt die breitere Familienreferenz.

Diese Seite dokumentiert einen deterministischen String-Helfer. Kodierungsfunktionen liefern transformierten Text zurueck, waehrend Hash-Funktionen feste, kleingeschriebene Hex-Digests liefern.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL rc AS LONG
    digest$ = SHA512$("abc")
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_web_all.pb`.

Grenzen

Dokumentieren Sie hier nur die getesteten Byte- oder String-Transformationen. Wenn es einen Rueckwaerts-Helfer gibt, pruefen Sie ihn separat, statt Symmetrie aus der Vorwaertsform abzuleiten.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

SHA512$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

SHA512$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer hashing-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input bytes, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

SHA512$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


SHELL – PBXB64-Compiler-Hilfe

Startseite › Funktionen › SHELL

SCHALE

Führen Sie ein ausführbares Programm synchron aus. Der SHELLing-Thread des aufrufenden Programms wird angehalten, bis das SHELLed-Programm endet.

Typ:Anweisung |Kategorie: Utilities

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SHELL [HANDLES,] CmdString [, WndStyle , EXIT TO exitcode& ]

Beschreibung

Die SHELL-Anweisung besteht aus folgenden Teilen:

GRIFFE

Wenn diese Option vorhanden ist, kann der untergeordnete Prozess die Windows-Dateihandles aller geöffneten Dateien im übergeordneten Prozess erben (und darauf zugreifen). Hierbei handelt es sich nicht um PowerBASIC-Dateinummern, sondern um Systemdatei-Handles, und Sie müssen OPEN HANDLE verwenden, um darauf zuzugreifen.

CmdString

Der Name des auszuführenden Programms („untergeordneter Prozess“) sowie alle erforderlichen Argumente oder Befehlszeilenschalter.

WndStyle

Eine Zahl, die dem Stil des Fensters entspricht, in dem das Programm ausgeführt werden soll. Wenn WndStyle weggelassen wird, wird das Programm normal mit Fokus geöffnet, genau wie bei WndStyle = 1.

Die folgende Tabelle identifiziert die Werte für WndStyle und den resultierenden Fensterstil:

WndStyle

Fensterstil

Fenster ausblenden

Normal mit Fokus (Standard)

Mit Fokus minimiert

Mit Fokus maximiert

Normal ohne Fokus

Ohne Fokus minimiert

Verwenden Sie ERR, um den Erfolg der SHELL-Funktion zu erkennen. Mit der Option HANDLES kann der untergeordnete Prozess die von Ihrem Programm geöffneten Dateihandles erben. Dies betrifft nur Windows-Handles, nicht PowerBASIC-Dateikennungen. Es handelt sich um eine erweiterte Option für diejenigen, die wissen, dass sie funktioniert und warum sie sie benötigen.

Exitcode&

Der Exit-Code des untergeordneten Prozesses (der von der WinMain-Funktion zurückgegebene Wert) wird der durch Exitcode& angegebenen Long-Integer-Variablen zugewiesen.

Einschränkungen

Die SHELL-Anweisung führt den untergeordneten Prozess synchron aus. Das heißt, SHELL gibt die Kontrolle nicht an Ihr Programm zurück, bis das untergeordnete Programm beendet ist.

Um interne DOS-Befehle wie DIR und COPY zu verwenden, müssen Sie den DOS-Befehlsprozessor ausführen und den DOS-Befehl als Parameter übergeben. Siehe das Beispiel unten.

Wenn der Programmname in CmdString keinen expliziten Pfad enthält, sucht Windows in den folgenden Pfaden nach der Datei: dem Verzeichnis, in dem sich das aktuelle Programm befindet, dem Standardverzeichnis, dem 32-Bit-Windows-Systemverzeichnis, dem 16-Bit-Windows-Systemverzeichnis, dem Windows-Verzeichnis und allen in der Umgebungsvariablen PATH aufgeführten Verzeichnissen.

Wenn die SHELL-Anweisung nicht erfolgreich ausgeführt wird, wird ein entsprechender Fehler generiert. Zur Erkennung kann die ERR-Funktion verwendet werden.

Siehe auch

  • ERR
  • SHELL-Funktion

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SHIFT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › SHIFT

UMSCHALT

Verschieben Sie die Bits in einem Integral

Typ:Anweisung |Kategorie:Mathematik und Numerik

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SHIFT [SIGNED] {LEFT | RIGHT} ivar , countexpr

Beschreibung

ivar muss einer der Variablentypen der Integralklasse sein: Byte, Word, Integer, Double-word, Long-integer oder Quad-integer. countexpr ist ein Ausdruck der Integralklasse, der die Anzahl der Bits angibt, um die ivar verschoben werden soll.

SHIFT verschiebt alle Bits in ivar ohne besondere Berücksichtigung des Vorzeichenbits einer vorzeichenbehafteten Integralklassenvariablen.

UNTERZEICHNET

Die Option SIGNED verschiebt alles, lässt jedoch nicht zu, dass sich das Vorzeichen (positiv oder negativ) des Werts ändert.

LINKS | RICHTIG

Die Option LEFT oder RIGHT bestimmt die Richtung der Bit-SHIFT-Operation. SHIFT LEFT verschiebt die Bits in Richtung des höherwertigen Endes von ivar und SHIFT RIGHT verschiebt Bits in Richtung des niederwertigen Endes von ivar .

Siehe auch

  • UND
  • BIT-Funktion
  • BIT-Anweisung
  • NICHT
  • ODER
  • DREHEN
  • XOR

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_shift_0
FUNCTION PBMAIN() AS LONG
  IF (1 SHL 0) <> (1) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_shift_1
FUNCTION PBMAIN() AS LONG
  IF (1 SHL 1) <> (2) THEN FUNCTION = 2: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_shift_2
FUNCTION PBMAIN() AS LONG
  IF (1 SHL 4) <> (16) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_shift_3
FUNCTION PBMAIN() AS LONG
  IF (3 SHL 2) <> (12) THEN FUNCTION = 4: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_shift_4
FUNCTION PBMAIN() AS LONG
  IF (15 SHL 1) <> (30) THEN FUNCTION = 5: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_shift_5
FUNCTION PBMAIN() AS LONG
  IF (16 SHR 0) <> (16) THEN FUNCTION = 6: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_shift_6
FUNCTION PBMAIN() AS LONG
  IF (16 SHR 1) <> (8) THEN FUNCTION = 7: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_shift_7
FUNCTION PBMAIN() AS LONG
  IF (16 SHR 2) <> (4) THEN FUNCTION = 8: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_shift_8
FUNCTION PBMAIN() AS LONG
  IF (255 SHR 4) <> (15) THEN FUNCTION = 9: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_shift_9
FUNCTION PBMAIN() AS LONG
  IF (100 SHR 2) <> (25) THEN FUNCTION = 10: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SHRINK$ – PBXB64-Compiler-Hilfe

Startseite› Funktionen › SHRINK$

SHRINK$

Eine Schnur verkleinern

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

NewString$ = SHRINK$( OldString$ )
NewString$ = SHRINK$( OldString$ , Mask$ )

Beschreibung

Der Zweck dieser Funktion besteht darin, eine Zeichenfolge mit aufeinanderfolgenden Datenelementen (Wörtern) zu erstellen, die durch ein konsistentes einzelnes Zeichen getrennt sind. Dies macht es sehr einfach, die Ergebnisse nach Bedarf zu analysieren.

In der ersten Form werden alle führenden und nachgestellten Leerzeichen vollständig entfernt. Alle Vorkommen von zwei oder mehr Leerzeichen werden in ein einzelnes Leerzeichen umgewandelt. Daher besteht die zurückgegebene neue Zeichenfolge aus null oder mehr Wörtern, die jeweils durch ein einzelnes Leerzeichen getrennt sind.

In der zweiten Form definiert Mask$ ein oder mehrere zu verkleinernde Trennzeichen. Alle führenden und nachgestellten Maskenzeichen werden vollständig entfernt. Alle Vorkommen eines oder mehrerer Maskenzeichen werden durch das erste Zeichen von Mask$ ersetzt. Daher besteht die zurückgegebene neue Zeichenfolge aus null oder mehr Wörtern, die jeweils durch das Zeichen an der ersten Position von Mask$ getrennt sind.

Leerzeichen werden im Allgemeinen als die vier üblichen nicht druckbaren Zeichen definiert: Leerzeichen, Tabulatorzeichen, Wagenrücklauf und Zeilenvorschub. Dies ist in PowerBASIC zur Vereinfachung als Zeichenfolgenäquivalent vordefiniert. Die ANSI-Version heißt $WHITESPACE , während die WIDE-Version $$WHITESPACE heißt. Dieses Equate eignet sich besonders gut zur Verwendung als Mask$ in dieser Funktion.

Siehe auch

  • CLIP$
  • INSTR
  • LTRIM$
  • REMOVE$
  • REPLACE
  • RTRIM$
  • TRIM$
  • UNWRAP$

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Gleitkomma mit einfacher Genauigkeit (!) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Gleitkomma mit einfacher Genauigkeit (!)
Hilfe zum PBXB64-Compiler

Gleitkomma mit einfacher Genauigkeit (!)

Gleitkommazahlen mit einfacher Genauigkeit (oder einfacher: Gleitkommazahlen mit einfacher Genauigkeit) sind möglicherweise der vielseitigste numerische Typ, der von PowerBASIC unterstützt wird. Werte mit einfacher Genauigkeit können Dezimalstellen enthalten und ein haben

Typ:Schlüsselwort |Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Variablen mit einfacher Genauigkeit werden identifiziert, indem dem Variablennamen ein Ausrufezeichen folgt (z. B. var! ) oder indem die DEFSNG-Anweisung verwendet wird, wie in der vorherigen Diskussion von Integralen beschrieben. Sie können Variablen mit einfacher Genauigkeit auch mithilfe des Schlüsselworts SINGLE mit der DIM-Anweisung deklarieren. Zum Beispiel:

Während Zahlen mit einfacher Genauigkeit sowohl enorme als auch mikroskopische Werte darstellen können, ist ihre Genauigkeit auf sechs Stellen beschränkt. Mit anderen Worten: Die einfache Genauigkeit funktioniert gut mit Zahlen wie 451,21 $ und 6.411,92 $, aber 671.421,22 $ können nicht genau dargestellt werden, weil sie zu viele Ziffern enthalten. Weder 234,56789 noch 0,00123456789. Eine Darstellung mit einfacher Genauigkeit kommt der sechsstelligen Zahl so nahe wie möglich: 671.421 $ oder 234,568 oder 0,00123457. Abhängig von Ihrer Anwendung kann diese Abrundung ein geringfügiger oder lähmender Mangel sein. Wie die meisten modernen Compiler verwendet PowerBASIC den IEEE-Standard für die gesamte Gleitkomma-Arithmetik.

C/C++, Delphi und Visual Basic bieten alle einen einzigen Datentyp, der mit der PowerBASIC-Variable mit einfacher Genauigkeit identisch ist.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Gleitkomma mit einfacher Genauigkeit (!) soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Gleitkomma mit einfacher Genauigkeit (!) mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


SIZEOF – PBXB64-Compiler-Hilfe

Startseite › Funktionen › SIZEOF

SIZEOF

Gibt die Gesamtlänge oder die physische Länge eines beliebigen PowerBASIC zurück

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

x& = SIZEOF( target )

Beschreibung

Besonders nützlich zum Bestimmen der maximalen Länge einer Zeichenfolge mit fester Länge, einer auf Null endenden Zeichenfolge oder eines benutzerdefinierten Typs. Es bietet eine ähnliche Funktionalität wie LEN , das die aktuelle Länge eines Datenelements zurückgibt.

Ziel kann der Name eines beliebigen Variablentyps sein (String mit fester Länge, mit NULL endende Zeichenfolge, UDT-Variable oder -Definition (User-Defined Type) usw.).

Wenn Sie die Größe einer aufgefüllten (ausgerichteten) UDT-Variablen oder -Definition mit der SIZEOF- (oder LEN-)Anweisung messen, umfasst die gemessene Länge alle Auffüllungen, die der Struktur hinzugefügt wurden. Beispielsweise die folgende UDT-Struktur:

TYP LängeTestTyp DWORD

a AS INTEGER

END-TYP

' Mehr Code hier

DIM abc AS LengthTestType

x& = SIZEOF(abc) ' oder verwenden Sie SIZEOF(LengthTestType)

Gibt eine Länge von 4 Bytes in x& zurück, da der UDT mit 2 zusätzlichen Bytes aufgefüllt wurde, um die DWORD-Ausrichtung zu erzwingen. Beachten Sie, dass SIZEOF einzelner UDT-Mitglieder die wahre Größe des Mitglieds zurückgibt, ohne Berücksichtigung von Auffüllung oder Ausrichtung. Im vorherigen Beispiel gibt SIZEOF(abc.a) 2 zurück.

Bei Verwendung für eine dynamische Zeichenfolge (variable Länge) gibt SIZEOF 4 zurück, was der Größe des Zeichenfolgenhandles entspricht. Um die Länge der Zeichenfolgendaten in der dynamischen Zeichenfolge zu ermitteln, verwenden Sie die LEN-Funktion. SIZEOF gibt auch 4 für Zeigervariablen zurück, da ein Zeiger immer als DWORD gespeichert wird.

Hinweise

Bei Verwendung mit einem dereferenzierten Zeiger (d. h. SIZEOF(@p) gibt SIZEOF die Größe des Zielvariablentyps des Zeigers zurück, wie in der Anweisung DIM x AS y PTR [* pSize ] definiert.

Beispielsweise gibt SIZEOF bei einem dynamischen Zeichenfolgenzeiger den Wert 4 zurück. Wenn das Zeigerziel eine Zeichenfolge fester Länge, UDT, Union oder eine mit Null abgeschlossene Zeichenfolge ist, gibt SIZEOF die Größe der Zieldatenstruktur zurück. Wenn der Zeiger jedoch so deklariert ist, dass er auf einen NULL-terminierten Zeiger ohne spezifische Zielgröße verweist (d. h. DIM a AS STRINGZ PTR), gibt SIZEOF 0 zurück.

Wenn SIZEOF für eine BYREF STRINGZ-Zeichenfolge verwendet wird, die keine explizite Längenangabe hat, gibt SIZEOF ebenfalls 0 zurück. Beispiel:

SUB ProcessData(BYREF szText AS STRINGZ)

' Innerhalb dieses Sub gibt SIZEOF(szText) 0 zurück, da es keine explizite Längenangabe gibt

Siehe auch

  • CHRBYTES
  • DIM
  • LEN

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


SLEEP – PBXB64-Compiler-Hilfe

Startseite › Funktionen › SLEEP

SCHLAF

Pausieren Sie den aktuellen Thread der Anwendung für eine angegebene Anzahl von Millisekunden (

Typ:Anweisung |Kategorie: Utilities

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SLEEP m&

Beschreibung

m& ist die Anzahl der Millisekunden (1 Millisekunde = 1/1000stel Sekunde), die die Anwendung anhalten soll. Nur der aktuelle Thread pausiert. Wenn andere Threads vorhanden sind, werden diese weiterhin ausgeführt. Während der SLEEP-Periode werden alle Zeitscheiben für den aktuellen Thread an andere Threads und Prozesse weitergegeben.

Wenn m& Null ist, wird der Rest der aktuellen Zeitscheibe aufgegeben. Wenn keine anderen Threads mit gleicher Priorität vorhanden sind, wird die Ausführung sofort fortgesetzt.

Die Zeitscheibendauer (auch Quantum genannt) kann von Version zu Windows-Version variieren und zwischen 20 mSek und 120 mSek liegen. Daher kann der Quantum die Leistung von Anwendungen beeinträchtigen, wenn SLEEP 0 überbeansprucht wird. Das heißt, eine übermäßige Verwendung von SLEEP 0 kann dazu führen, dass eine Anwendung einen Großteil ihrer verfügbaren Prozessorzeit aufgibt, was zu einem erheblichen Rückgang der Anwendungsleistung führt.

Wenn Code in einer engen Schleife ausgeführt wird, ist es durchaus möglich, 100 % der verfügbaren CPU-Zeit zu verbrauchen, daher ist die gelegentliche Verwendung von SLEEP 0 innerhalb einer engen Schleife oft vorteilhaft für die Gesamtleistung des Ziel-PCs. Beispielsweise ist es möglicherweise nicht erforderlich, SLEEP 0 für jede Iteration einer Schleife zu verwenden, sondern stattdessen jede zweite oder dritte.

Siehe auch

  • THREAD CREATE
  • TIMER

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SLL-Beispiel – PBXB64-Compiler-Hilfe

Startseite › Funktionen › SLL-Beispiel

SLL-Beispiel

Nachfolgend finden Sie ein sehr einfaches Beispiel einer Static Link Library (SLL). Dieses SLL-Einheitenmodul enthält nur eine Funktion, die Millimeter in Zoll umrechnet.

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

#COMPILE SLL "conversion.sll"

FUNCTION MillimetersToInches(BYVAL mm AS DOUBLE) AS DOUBLE
    FUNCTION = mm * 0.03937#
END FUNCTION

Kompilieren Sie diese Quelle zuerst. PBXB64 schreibt conversion.sll als deterministisches COFF-Archiv.

#COMPILE EXE
#LINK "conversion.sll"

DECLARE FUNCTION MillimetersToInches(BYVAL mm AS DOUBLE) AS DOUBLE

FUNCTION PBMAIN() AS LONG
    IF MillimetersToInches(25.4#) < 0.99# THEN FUNCTION = 1: EXIT FUNCTION
    IF MillimetersToInches(25.4#) > 1.01# THEN FUNCTION = 2: EXIT FUNCTION
    FUNCTION = 0
END FUNCTION

Das Hostprogramm linkt die SLL mit #LINK. PBXB64-SLLs sind native COFF-Archive, keine alten PowerBASIC-SLL-Binaerdateien. Eine PBXB64-SLL kann auch eine andere PBXB64-native SLL linken und unterstuetzte lokale #RESOURCE-Eintraege in den finalen Host-Link uebernehmen.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für SLL-Beispiel soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' SLL-Beispiel mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


SPACE$ – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › SPACE$

SPACE$

Gibt eine Zeichenfolge zurück

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = SPACE$( numeric_expression )

Beschreibung

numeric_expression ist ein nicht negativer Ausdruck, der angibt, wie viele Leerzeichen die Funktion zurückgeben soll. SPACE$ kann zum Formatieren oder Vorfüllen von Zeichenfolgen nützlich sein.

Siehe auch

  • BUILD$
  • CHR$
  • CSET
  • CSET$
  • LSET
  • NUL$
  • REPEAT$
  • RSET
  • STRING$

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


SPLIT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › SPLIT

GETEILT

Teilt eine Zeichenfolge

Typ:Anweisung |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SPLIT [WORD] MainStr , Part1Len TO Part1Var , Part2Var

Beschreibung

MainStr wird in zwei Teile geteilt, die dann den beiden durch Part1Var und Part2Var angegebenen String-Variablen zugewiesen werden. Part1Len ist ein

Ausdruck, der die Anzahl der Zeichen angibt, die Teil1 zugewiesen werden sollen, während die restlichen Zeichen Teil2 zugewiesen werden.

Wenn die WORD-Option enthalten ist, garantiert PowerBASIC, dass Teil1 nicht mit einem Teilwort endet. Dies erfordert möglicherweise, dass Part1Len auf einen kleineren Wert angepasst wird. In diesem Fall würden Part2Var diese Zeichen zum Ausgleich zugewiesen. Abhängig von der Art des Vorgangs kann es erforderlich sein, führende Leerzeichen aus Part2Var zu entfernen.

Siehe auch

  • GRAFISCHE SPLIT
  • LTRIM$
  • XPRINT SPLIT

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


EFX. - PBXB64 SPR Help

Startseite › General Reference › EFX.
Hilfe zum PBXB64-Compiler

EFX.

FEX-Aufzaehlung beenden - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

EFX. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `EFX.`.

Syntax

EFX.

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Keine Parameter.

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_efx.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

EFX.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_efx.mrt. Kompilieren mit PBXB64 examples/spr/spr_efx.mrt -o spr_efx.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FEF. - PBXB64 SPR Help

Startseite › General Reference › FEF.
Hilfe zum PBXB64-Compiler

FEF.

SPR-Befehl - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

FEF. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `FEF.label|$$VAR[|root][|pattern][|flags][|from][|to]`.

Syntax

FEF.label|$$VAR[|root][|pattern][|flags][|from][|to]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | label | erforderlich
P2 | $$VAR | erforderlich
P3 | root | optional
P4 | pattern | optional
P5 | flags | optional
P6 | from | optional
P7 | to | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_fef.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

FEF.label|$$VAR[|root][|pattern][|flags][|from][|to]
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_fef.mrt. Kompilieren mit PBXB64 examples/spr/spr_fef.mrt -o spr_fef.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FEP. - PBXB64 SPR Help

Startseite › General Reference › FEP.
Hilfe zum PBXB64-Compiler

FEP.

SPR-Befehl - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

FEP. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `FEP.label|$$VAR[|mode][|pattern]`.

Syntax

FEP.label|$$VAR[|mode][|pattern]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | label | erforderlich
P2 | $$VAR | erforderlich
P3 | mode | optional
P4 | pattern | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_fep.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

FEP.label|$$VAR[|mode][|pattern]
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_fep.mrt. Kompilieren mit PBXB64 examples/spr/spr_fep.mrt -o spr_fep.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FER. - PBXB64 SPR Help

Startseite › General Reference › FER.
Hilfe zum PBXB64-Compiler

FER.

SPR-Befehl - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

FER. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `FER.label|$$VAR|registry-path[|flags][|pattern]`.

Syntax

FER.label|$$VAR|registry-path[|flags][|pattern]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | label | erforderlich
P2 | $$VAR | erforderlich
P3 | registry-path | erforderlich
P4 | flags | optional
P5 | pattern | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_fer.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

FER.label|$$VAR|registry-path[|flags][|pattern]
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_fer.mrt. Kompilieren mit PBXB64 examples/spr/spr_fer.mrt -o spr_fer.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FES. - PBXB64 SPR Help

Startseite › General Reference › FES.
Hilfe zum PBXB64-Compiler

FES.

SPR-Befehl - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

FES. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `FES.label|$$VAR[|flags][|pattern][|machine]`.

Syntax

FES.label|$$VAR[|flags][|pattern][|machine]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | label | erforderlich
P2 | $$VAR | erforderlich
P3 | flags | optional
P4 | pattern | optional
P5 | machine | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_fes.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

FES.label|$$VAR[|flags][|pattern][|machine]
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_fes.mrt. Kompilieren mit PBXB64 examples/spr/spr_fes.mrt -o spr_fes.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FEV. - PBXB64 SPR Help

Startseite › General Reference › FEV.
Hilfe zum PBXB64-Compiler

FEV.

SPR-Befehl - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

FEV. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `FEV.label|$$VAR|source[|pattern]`.

Syntax

FEV.label|$$VAR|source[|pattern]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | label | erforderlich
P2 | $$VAR | erforderlich
P3 | source | erforderlich
P4 | pattern | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_fev.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

FEV.label|$$VAR|source[|pattern]
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_fev.mrt. Kompilieren mit PBXB64 examples/spr/spr_fev.mrt -o spr_fev.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


NVB. - PBXB64 SPR Help

Startseite › General Reference › NVB.
Hilfe zum PBXB64-Compiler

NVB.

Variable nicht im Bereich - Bedingungsbefehle zum Vergleichen von Werten und Auswaehlen von Bloecken.

Kind: SPR-Befehl | Category: SPR Frontend / Conditions

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

NVB. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `NVB.$$VAR|min|max[|label]`.

Syntax

NVB.$$VAR|min|max[|label]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | $$VAR | erforderlich
P2 | min | erforderlich
P3 | max | erforderlich
P4 | label | optional

Verwendung

  • Bereiten Sie den geprueften Wert vor der Bedingung vor, damit das Beispiel genau zeigt, was verglichen wird und welcher Zweig betreten wird.
  • Dokumentieren Sie, ob der Befehl bei Erfolg, bei Abweichung oder bei Bereichs-/Musterpruefung verzweigt, weil genau das beim Programmieren relevant ist.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_nvb.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Nennen Sie, ob der Befehl bei fehlgeschlagener Bedingung durchfaellt und ob das Ergebnisziel einen numerischen Score oder Vergleichswert erhaelt.
  • Wenn ein passendes Label oder ein Block fehlt, soll die Seite sagen, dass das Beispiel absichtlich unvollstaendig ist und beim Kompilieren oder Linken fehlschlaegt.

Beispiel

VAR.$$AAA=5
NVB.$$AAA|0|2
EIF.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_nvb.mrt. Kompilieren mit PBXB64 examples/spr/spr_nvb.mrt -o spr_nvb.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


NVP. - PBXB64 SPR Help

Startseite › General Reference › NVP.
Hilfe zum PBXB64-Compiler

NVP.

Nicht Variablenmuster - Bedingungsbefehle zum Vergleichen von Werten und Auswaehlen von Bloecken.

Kind: SPR-Befehl | Category: SPR Frontend / Conditions

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

NVP. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `NVP.$$VAR=pattern[|label][|e]`.

Syntax

NVP.$$VAR=pattern[|label][|e]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | $$VAR=pattern | erforderlich
P2 | label | optional
P3 | e | optional

Verwendung

  • Bereiten Sie den geprueften Wert vor der Bedingung vor, damit das Beispiel genau zeigt, was verglichen wird und welcher Zweig betreten wird.
  • Dokumentieren Sie, ob der Befehl bei Erfolg, bei Abweichung oder bei Bereichs-/Musterpruefung verzweigt, weil genau das beim Programmieren relevant ist.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_nvp.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Nennen Sie, ob der Befehl bei fehlgeschlagener Bedingung durchfaellt und ob das Ergebnisziel einen numerischen Score oder Vergleichswert erhaelt.
  • Wenn ein passendes Label oder ein Block fehlt, soll die Seite sagen, dass das Beispiel absichtlich unvollstaendig ist und beim Kompilieren oder Linken fehlschlaegt.

Beispiel

VAR.$$AAA=abc
NVP.$$AAA=xyz
EIF.
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_nvp.mrt. Kompilieren mit PBXB64 examples/spr/spr_nvp.mrt -o spr_nvp.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


USM. - PBXB64 SPR Help

Startseite › General Reference › USM.
Hilfe zum PBXB64-Compiler

USM.

Silent-Modus setzen - Datei-, Dialog-, Druck-, Teilzeichenketten- und Zeichenhelfer.

Kind: SPR-Befehl | Category: SPR Frontend / File and Text I/O

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

USM. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `USM.[mode][|logfile]`.

Syntax

USM.[mode][|logfile]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | mode | optional
P2 | logfile | optional

Verwendung

  • Verwenden Sie nach Moeglichkeit eine temporaere Datei oder einen bewussten Platzhalterpfad und nennen Sie, ob der Befehl aussenstehenden Zustand erstellt, anhaengt, liest, aufzaehlt oder loescht.
  • Das Beispiel soll den erwarteten Pfad oder Dialogwert benennen und einen Cleanup-Schritt nennen, der die Maschine nach dem Test unveraendert laesst.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_usm.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64. Der Befehl kann beim Ausfuehren von Windows-, Datei-, Prozess- oder Desktop-Zustand abhaengen.

Fehlerfaelle

  • Nennen Sie den wahrscheinlichsten Laufzeitfehler, etwa fehlende Datei, ungueltiges Handle, Berechtigungsproblem oder nicht verfuegbaren Desktop-Zustand.
  • Wenn der Befehl einen Statuscode liefert oder das Ziel unveraendert lassen kann, sagen Sie das auf der Seite ausdruecklich.

Beispiel

USM.10|spr_error.log
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_usm.mrt. Kompilieren mit PBXB64 examples/spr/spr_usm.mrt -o spr_usm.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VAS. - PBXB64 SPR Help

Startseite › General Reference › VAS.
Hilfe zum PBXB64-Compiler

VAS.

String-Zuweisung - Variablenmanipulation, Zufallswerte, Formelauswertung und Mathematikbefehle.

Kind: SPR-Befehl | Category: SPR Frontend / Variables and Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

VAS. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `VAS.$$TGT=value / VAS.$$TGT+text`.

Syntax

VAS.$$TGT=value / VAS.$$TGT+text

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Parameter

# | Name/Form | Bedeutung
P1 | $$TGT | erforderliche Zielvariable
P2 | value / VAS.$$TGT+text | erforderlicher Wert

Verwendung

  • Zeigen Sie die Variable vor und nach dem Befehl, damit erkennbar ist, ob der Befehl direkt aendert oder in ein Ergebnisziel schreibt.
  • Wenn ein Befehl numerischen Zustand verbraucht oder erzeugt, nennen Sie Anfangswert, Operation und Endergebnis im Beispiel.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_vas.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$SRC=text
VAS.$$OUT=$$SRC
VAS.$$OUT+tail
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_vas.mrt. Kompilieren mit PBXB64 examples/spr/spr_vas.mrt -o spr_vas.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VAU. - PBXB64 SPR Help

Startseite › General Reference › VAU.
Hilfe zum PBXB64-Compiler

VAU.

Unicode/Hex-Zuweisung - Variablenmanipulation, Zufallswerte, Formelauswertung und Mathematikbefehle.

Kind: SPR-Befehl | Category: SPR Frontend / Variables and Math

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

VAU. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `VAU.$$TGT=41 42 / VAU.$$TGT+43`.

Syntax

VAU.$$TGT=41 42 / VAU.$$TGT+43

Alle in dieser Syntax gezeigten Parameter sind erforderlich.

Parameter

# | Name/Form | Bedeutung
P1 | $$TGT | erforderliche Zielvariable
P2 | 41 42 / VAU.$$TGT+43 | erforderlicher Wert

Verwendung

  • Zeigen Sie die Variable vor und nach dem Befehl, damit erkennbar ist, ob der Befehl direkt aendert oder in ein Ergebnisziel schreibt.
  • Wenn ein Befehl numerischen Zustand verbraucht oder erzeugt, nennen Sie Anfangswert, Operation und Endergebnis im Beispiel.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_vau.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAU.$$BIN=41 42
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_vau.mrt. Kompilieren mit PBXB64 examples/spr/spr_vau.mrt -o spr_vau.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VLT. - PBXB64 SPR Help

Startseite › General Reference › VLT.
Hilfe zum PBXB64-Compiler

VLT.

Variable links trimmen - Schleifenbefehle und Helfer fuer Zeichenketten.

Kind: SPR-Befehl | Category: SPR Frontend / Loops and Strings

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

VLT. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `VLT.$$VAR[|chars]`.

Syntax

VLT.$$VAR[|chars]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | $$VAR | erforderlich
P2 | chars | optional

Verwendung

  • Zeigen Sie Anfangswert, Schleifenrumpf und Austrittspfad, damit die Struktur ohne Raten in ein echtes SPR-Programm uebernommen werden kann.
  • Bei String-Helfern muessen Ein- und Ausgabetext exakt sichtbar sein, damit Padding, Trimmen, Splitten oder Ersetzen im Beispiel eindeutig werden.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_vlt.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$OUT=  abc
VLT.$$OUT
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_vlt.mrt. Kompilieren mit PBXB64 examples/spr/spr_vlt.mrt -o spr_vlt.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRT. - PBXB64 SPR Help

Startseite › General Reference › VRT.
Hilfe zum PBXB64-Compiler

VRT.

Variable rechts trimmen - Schleifenbefehle und Helfer fuer Zeichenketten.

Kind: SPR-Befehl | Category: SPR Frontend / Loops and Strings

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Funktion

VRT. ist ein implementierter PBXB64-SPR-Befehl. Die gepruefte Syntax ist `VRT.$$VAR[|chars]`.

Syntax

VRT.$$VAR[|chars]

Eckige Klammern kennzeichnen optionale Parameter. Optionale Parameter behalten die dokumentierte Reihenfolge; lasse sie nur von rechts weg, ausser die Befehlsbeschreibung nennt ausdruecklich eine andere Form.

Parameter

# | Name/Form | Bedeutung
P1 | $$VAR | erforderlich
P2 | chars | optional

Verwendung

  • Zeigen Sie Anfangswert, Schleifenrumpf und Austrittspfad, damit die Struktur ohne Raten in ein echtes SPR-Programm uebernommen werden kann.
  • Bei String-Helfern muessen Ein- und Ausgabetext exakt sichtbar sein, damit Padding, Trimmen, Splitten oder Ersetzen im Beispiel eindeutig werden.

Beschreibung

  • Diese Seite beschreibt die in PBXB64 implementierte und getestete Befehlsform, nicht eine ungepruefte Erweiterung der urspruenglichen SPR-Sprache.
  • Die Parameter werden in der unten gezeigten Reihenfolge mit dem SPR-Trennzeichen `|` ausgewertet; Variablen verwenden exakt die Schreibweise `$$XXX`, also zwei Dollarzeichen plus genau drei Zeichen.
  • Das Beispiel `examples/spr/spr_vrt.mrt` gehoert zum automatischen SPR-Hilfe-Pruefsatz und kompiliert/linkt mit dem aktuellen PBXB64.

Fehlerfaelle

  • Dokumentieren Sie, was passiert, wenn der Befehl seine Aufgabe nicht abschliessen kann: welches Ziel sich aendert, welcher Zustand unberuehrt bleibt und was der Aufrufer als Naechstes pruefen soll.
  • Wenn der Befehl als zertifiziert getestet gilt, soll das Beispiel dennoch die Grenze zeigen, an der das getestete Verhalten endet und eine breitere historische Form neuen Beleg braeuchte.

Beispiel

VAR.$$OUT=abc
VRT.$$OUT
END.

Verifiziertes Beispiel

Verifiziertes Beispiel: examples/spr/spr_vrt.mrt. Kompilieren mit PBXB64 examples/spr/spr_vrt.mrt -o spr_vrt.exe. Dieses Beispiel gehoert zum SPR-Hilfe-Pruefsatz und wird durch help/scripts/verify_spr_samples.py geprueft.

Grenzen

Verhalten ausserhalb der gezeigten Syntax muss mit einem eigenen fokussierten Beispiel geprueft werden, bevor es in der Hilfe als unterstuetzt beschrieben wird.

Diese Seite ist PBXB64-Source-Truth-Dokumentation: Die angegebene Syntax und das Beispiel bilden den unterstuetzten Hilfevertrag; breitere historische SPR-Varianten brauchen einen eigenen fokussierten Test, bevor sie als verfuegbar dokumentiert werden.

Siehe auch

  • SPR/MRT Frontend
  • Language Frontends

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


#STACK - PBXB64 Compiler Help

Startseite › BASIC Frontend › Keyword Reference › Memory & Pointers › #STACK
Hilfe zum PBXB64-Compiler

#STACK

Setzen Sie die maximale Stack-Groesse fuer die erzeugte EXE.

Kind: Directive | Category: Memory & Pointers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

#STACK num_expr

Beschreibung

Der numerische Ausdruck wird in Bytes angegeben und auf die naechste 64-KiB-Grenze aufgerundet. Die kleinste unterstuetzte Stack-Groesse betraegt 128 KiB, und 1 MiB ist fuer viele Programme eine brauchbare Vorgabe.

Beim Programmstart reserviert die Runtime die angeforderte Obergrenze fuer das Image und committed Seiten nur bei Bedarf. Verwenden Sie einen groesseren Wert nur dann, wenn das Programm ihn wirklich fuer Rekursion, grosse lokale Felder oder stacklastige Hilfsketten braucht.

Assembler-Integration

#STACK ist eine Compiler-Richtlinie und keine Inline-Assembler-Anweisung. Sie veraendert nicht die erzeugten Instruktionen, aber sie beeinflusst das verfuegbare Stack-Budget fuer assemblerlastige Routinen, tiefe Rekursion und Code mit grossen lokalen Daten. Beachten Sie bei stacksensitiven Beispielen weiterhin die x64-Aufrufkonvention und die 16-Byte-Stack-Ausrichtung.

Prüfung

Pruefen Sie die Richtlinie mit einem kleinen Programm, das die angeforderte Tiefe oder lokale Speicherung nutzt und dann einen bekannten Exitcode liefert. Wenn Sie die PE-Metadaten direkt bestaetigen muessen, vergleichen Sie nach dem Build die Stack-Reservierung im erzeugten Image mit dem angeforderten Wert.

Migrationshinweise

Aeltere 32-Bit-PowerBASIC-Beispiele gehen oft von anderen Vorgaben oder geringerem Stack-Druck aus. Pruefen Sie beim Portieren die Rekursionstiefe, grosse automatische Felder und jeden Code, der 32-Bit-Annahmen ueber die Stack-Groesse macht.

Praktische Verwendung

Platzieren Sie #STACK nahe am Anfang der Quelldatei, damit der Compiler die angeforderte Grenze auf die erzeugte EXE anwenden kann. Der einzelne Ausdruck waehlt die maximale Stack-Reservierung in Bytes, und die Richtlinie liefert keinen Rueckgabewert.

Parameter und Ergebnisse

Der Wert wird auf die naechste 64-KiB-Grenze aufgerundet und darf nicht unter 128 KiB liegen. PBXB64 committed zur Laufzeit nur so viel Speicher wie benoetigt wird, aber die Reservierung bleibt wichtig fuer verschachtelte Aufrufe und grosse automatische Daten.

Validierungsbeleg

Validierungsbeleg: Es ist keine eigene Stack-Regression im aktuellen Hilfebaum registriert. Das Beispiel unten ist eine kopierbare Vorlage, die die erwartete Compilerform und die beabsichtigte Laufzeitverwendung der Richtlinie dokumentiert.

Test- und Dokumentationshinweise

Wenn Sie eine endgueltige Bestaetigung brauchen, dokumentieren Sie die erwartete Stack-Reservierung, den Build-Befehl und den Exitcode oder Pruefschritt direkt neben dem Beispiel. Halten Sie auf der Seite klar fest, dass die Richtlinie nur zur Compile-Zeit wirkt.

Beispiel

#STACK 2097152
#COMPILE EXE
#DIM ALL

FUNCTION Recurse(BYVAL depth AS LONG) AS LONG
    IF depth <= 0 THEN
        FUNCTION = 0
    ELSE
        FUNCTION = Recurse(depth - 1) + 1
    END IF
END FUNCTION

FUNCTION PBMAIN() AS LONG
    LOCAL depth AS LONG
    depth = Recurse(10)
    IF depth <> 10 THEN FUNCTION = 1
END FUNCTION

Siehe auch

  • Reduzierung des Stapelaufwands
  • ESP und EBP verwenden


Reduzierung des Stapel-Overheads – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Reduzierung des Stapel-Overheads

Reduzierung des Stapelaufwands

Es kann vorkommen, dass Sie wiederholt einen sehr kleinen SUB aufrufen möchten, und dies kann zu einer Situation führen, in der der normalerweise geringe Stapelaufwand tatsächlich zu einem Faktor für die Geschwindigkeit des SUB wird

Typ:Schlüsselwort |Kategorie: Memory & Pointers

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Um in solchen Fällen die Leistung zu steigern, bietet PowerBASIC die oft übersehenen GOSUB/RETURN-Anweisungen an, die anstelle eines Aufrufs eines SUB/END SUB-Blocks verwendet werden können. Wenn die Reduzierung des Stapel-Overheads von entscheidender Bedeutung ist, können Sie eine Beschriftung im Code unterhalb des Endes Ihres normalen Codes erstellen (aber immer noch innerhalb des aktuellen Unter-/Funktions-/Methoden-/Eigenschaftsblocks).

Anschließend können Sie den Inline-Assembler-Code vom Ziel-SUB übernehmen und ihn direkt nach dem Label platzieren. Abschließend wird eine RETURN-Anweisung hinzugefügt, sodass die Ausführung bei der nächsten Anweisung nach dem GOSUB fortgesetzt wird. Ein solcher Code würde etwa so aussehen:

FUNCTION MyFunc() SO LONG

' Inline-Assembler-Code

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Reduzierung des Stapelaufwands soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Reduzierung des Stapelaufwands mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Anweisungstrennung – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Anweisungstrennung

Anweisungtrennung

Der Doppelpunkt ( : ) kann verwendet werden, um mehrere Anweisungen in einer einzelnen (logischen) Zeile des Quellcodes zu trennen. Zum Beispiel:

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

FOR x& = 1 TO 10 : INCR y& : NEXT x&

ist direkt äquivalent zu:

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


STATUSBAR SET PARTS – PBXB64 Compiler-Hilfe

Startseite › Funktionen › STATUSBAR SET PARTS

STATUSBAR-SETTEILE

Manipulate a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

STATUSBAR GET PARTS hDlg , id& TO count&
STATUSBAR GET TEXT hDlg , id& , item& TO text$
STATUSBAR SET PARTS hDlg , id& , x& [, x& ...]
STATUSBAR SET TEXT hDlg , id& , item& , style& , text$

Beschreibung

In jedem der folgenden Beispiele und Beschreibungen wird das STATUSBAR-Steuerelement, das Gegenstand der Anweisung ist, durch das Handle des Dialogs identifiziert, der das STATUSBAR-Steuerelement (hDlg) besitzt, und durch die eindeutige Steuerelement-ID, die Sie ihm bei der Erstellung in CONTROL ADD STATUSBAR gegeben haben.

Der Wert item& bezieht sich auf die Position des Textdatenelements in der STATUSBAR und ist immer auf eins indiziert. Die erste Zeichenfolge ist Position 1, die zweite ist Position 2 und so weiter.

STATUSBAR GET PARTS hdlg , id& TO count&

Die aktuelle Anzahl der Statusleistenabschnitte wird abgerufen und count& zugewiesen.

STATUSBAR GET TEXT hDlg , id& , item& TO text$

Der Text für den durch item& bezeichneten einbasierten Statusleistenabschnitt wird abgerufen und text$ zugewiesen.

STATUSBAR SET PARTS hDlg , id& , x& [, x& ...]

Das STATUSBAR-Steuerelement ist in bis zu 32 Abschnitte unterteilt, von denen jeder dazu verwendet werden kann, dem Benutzer bestimmte Statusdaten anzuzeigen. Die Anweisung enthält 1 bis 32 Breitenparameter ( x& ), die die Pixel- oder Dialogeinheitsgröße dieses Abschnitts angeben. Sie können für den letzten Parameter eine sehr große Zahl verwenden, um anzugeben, dass der Abschnitt bis zur rechten Seite des Fensters reichen soll.

STATUSBAR SET TEILE hdlg, id&

, 50, 50, 9999

Die obige Anweisung würde beispielsweise eine Statusleiste mit zwei Abschnitten zu je 50 Pixeln und einem dritten Abschnitt mit der verbleibenden Breite erstellen.

STATUSBAR SET TEXT hDlg , id& , item& , style& , text$

Der Text für das durch item& angegebene Datenelement wird durch den neuen Text in text$ ersetzt. Der Wert von item& = 1 für das erste Element, 2 für das zweite Element usw. Der Stilwert der Statusleiste kann der Standardwert Null (0) oder einer der anderen als Bitmaske gebildeten Stilwerte sein:

Null (0) Standardeinstellung

Text mit einem Rand, der unterhalb des Fensters angezeigt wird.

%SBT_NOBORDERS

Der Text wird ohne Ränder gezeichnet.

%SBT_POPOUT

Text mit einem Rand, der höher als das Fenster angezeigt wird.

PBXB64-Implementierungshinweise

PBXB64 implementiert alle oben gezeigten dokumentierten STATUSBAR-Anweisungsformen. SET PARTS akzeptiert Abschnittsbreiten von 1 bis 32, GET PARTS gibt die aktuelle Abschnittsanzahl zurück und GET/SET TEXT verwendet einsbasierte Elementnummern, wie in der PowerBASIC-Syntax beschrieben.

Der Compiler reduziert diese Formulare auf eingebettete Win32-Statusleisten-Laufzeithilfsprogramme. Für die ausführbare Datei des Kunden sind keine externen Objektdateien erforderlich. Die Regressionssuite deckt SET PARTS, SET TEXT, GET PARTS und GET TEXT über mehrere Statusleistenabschnitte ab.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG STATUSBAR HINZUFÜGEN
  • STEUERUNG SET SCHRIFTART

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


STEP – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STEP

STEP

Legen Sie das Inkrement für eine FOR-Schleife fest

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

FOR counter = start TO end [STEP increment]

Beschreibung

Das optionale STEP Klausel in aFORDie Anweisung gibt den Wert an, der nach jeder Iteration zum Zähler hinzugefügt wird. Wenn es weggelassen wird, erhöht sich der Zähler um 1. Ein Negativ STEP Wert zählt abwärts; die Schleifenbedingung wird entsprechend umgekehrt.

Beispiel

FUNCTION PBMAIN () AS LONG
    LOCAL i AS LONG
    LOCAL sum AS LONG
    sum = 0
    FOR i = 10 TO 1 STEP -1
        sum = sum + i
    NEXT i
    FUNCTION = sum
END FUNCTION

Dieses Programm gibt 55 (10+9+...+1) zurück.

Generierter Assembler-Code

Bei einem negativen STEP verwendet der Schrittblock add mit einem vorzeichenerweiterten Soforttest und den Bedingungstestverwendungen setge statt setle:

pb_for_step_PBMAIN_0:
    mov r10, [rbp-24]
    mov rbx, r10
    add rbx, -1
    mov [rbp-24], rbx
    jmp pb_for_cond_PBMAIN_0

Siehe auch

  • FOR
  • WEITER
  • TO
  • Kontrollflussreferenz

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Speicheranforderungen und -beschränkungen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Speicheranforderungen und -beschränkungen
Hilfe zum PBXB64-Compiler

Speicheranforderungen und -beschränkungen

Mit der LEN-Funktion können Sie die erforderliche Speichermenge für eine Variable eines benutzerdefinierten Typs ermitteln. Um beispielsweise die Anforderungen an eine Studentenakte zu ermitteln, verwenden Sie:

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

RecordSize = LEN(Student)

Die Adresse einer Datensatzvariablen, wie sie von der VARPTR-Funktion zurückgegeben wird, ist die Adresse im Speicher des ersten Datenbytes im Datensatz. Sie können die Startadresse der Felder im Datensatz auch erhalten, indem Sie den vollständigen Namen des Felds (z. B. Student.IdNum) an die Funktion VARPTR übergeben.

Eine einzelne UDT-Struktur ist auf 16 MB (16.777.216 Byte) begrenzt. Lokal dimensionierte UDT-Strukturen sind auf den verfügbaren freien Stapelspeicherplatz begrenzt, typischerweise weniger als 1 MB. Wenn größere UDT-Strukturen erforderlich sind, verwenden Sie stattdessen eine STATIC- oder GLOBAL-Deklaration (da diese nicht auf dem Stack gespeichert werden). Die gleichen Regeln gelten für Unions (und LOCAL-Strings mit fester Länge und mit Nullterminierung).

Beachten Sie, dass die ARRAY-Anweisungen nicht direkt auf Arrays innerhalb von UDTs verwendet werden können. Sie können jedoch DIM..AT verwenden, um ein Array (vom gleichen Datentyp) an der Adresse des UDT-Arrays zu definieren und ARRAY-Anweisungen für dieses Array zu verwenden. Die ARRAY-Anweisungen können auf Arrays von UDT-Strukturen verwendet werden. Ein einzelnes Array innerhalb eines UDT kann bis zur vollen UDT-Größenbeschränkung von 16 MB belegen.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Speicheranforderungen und -beschränkungen soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Speicheranforderungen und -beschränkungen mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


STRDELETE$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STRDELETE$

STRDELETE$

Löschen Sie eine angegebene Anzahl von Zeichen aus a

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = STRDELETE$( string_expression , start& , count& )

Beschreibung

Gibt einen String basierend auf dem Kopieren von string_expression zurück, wobei count& Zeichen jedoch ab Position start& gelöscht werden. Das erste Zeichen in der Zeichenfolge ist Position 1 usw.

Siehe auch

  • CLIP$
  • STRINSERT$
  • STRREVERSE$

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


STRING$ – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › STRING$

STRING$

Gibt eine Zeichenfolge zurück

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = STRING$( Count& , Character% )
s$ = STRING$( Count& , Character$ )
s$$ = STRING$$( Count& , Character% )
s$$ = STRING$$( Count& , Character$$ )

Beschreibung

Diese Funktion erstellt eine Zeichenfolge, die aus mehreren Kopien eines bestimmten Zeichens besteht. Die Form STRING$() erstellt eine Zeichenfolge aus ANSI-Zeichen (1 Byte) oder Codes im Bereich von 0 bis 255. Die Form STRING$$() erstellt eine WSTRING-Zeichenfolge aus WIDE-UTF-16-Codeunits im Bereich von 0 bis 65535.

Verwenden Sie STRING$ fuer ANSI-Ergebnisse und STRING$$ fuer WIDE-Ergebnisse. STRING$$ ist fuer numerische Codeunit-Argumente, WSTRING-Zeichenargumente, auf denselben Bytewert erweiterte ANSI-Zeichenargumente und leere WSTRING-Ergebnisse bei null oder negativen Zaehlern getestet.

STRING$ mit einem numerischen Argument gibt Count& Kopien des Zeichens mit dem Zeichencode von Character% zurueck. STRING$ mit einem String-Argument gibt Count& Kopien des ersten Zeichens in Character$ zurueck. STRING$$ folgt derselben Zaehlregel und gibt eine WSTRING-Zeichenfolge zurueck.

Die folgenden Funktionen geben alle eine Zeichenfolge mit 8 Leerzeichen zurück:

A$ = STRING$(8, 32)

A$ = STRING$(8, " ")

A$ = STRING$(8, $SPC)

A$ = SPACE$(8)

A$ = REPEAT$(8, " ")

A$ = REPEAT$(8, $SPC)

Verwenden Sie REPEAT$, um mehrere Kopien einer aus mehreren Zeichen bestehenden Zeichenfolge zu erstellen, und SPACE$, um eine Zeichenfolge aus Leerzeichen zurückzugeben.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL w AS WSTRING

    w = STRING$$(3, &H03A9)
    IF ASCW(w, 1) <> &H03A9 THEN FUNCTION = 1 : EXIT FUNCTION
    IF ASCW(w, 3) <> &H03A9 THEN FUNCTION = 2 : EXIT FUNCTION

    w = STRING$$(2, WCHR$(&H20AC))
    IF ASCW(w, 1) <> &H20AC THEN FUNCTION = 3 : EXIT FUNCTION
END FUNCTION

Hinweise

Die fokussierte Validierung erfolgt durch tests/pb/test_string_dollar_dollar.pb. Breitere codepage-abhaengige und eingebettete-NUL-Randfaelle der String-Familie bleiben eigene Kompatibilitaetsziele.

Siehe auch

  • ASC
  • BUILD$
  • CHR$
  • NUL$
  • REPEAT$
  • SPACE$

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


String-Arrays – PBXB64-Compiler-Hilfe

Startseite › Funktionen › String-Arrays

String-Arrays

Die Elemente von String-Arrays enthalten Strings anstelle von . Jede Zeichenfolge kann eine andere Länge haben. Beispielsweise erstellt DIM Words$(50) eine Folge von 51 unabhängigen String-Variablen:

Typ:Schlüsselwort |Kategorie:Variablen und Umfang

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Wörter$(0) = „Daniel mag Katzen.“ ' 18-stellige Zeichenfolge

Wörter$(1) = "" ' eine Nullzeichenfolge

Wörter$(2) = „Nicki ist ein süßes Kind.“ ' 23-stellige Zeichenfolge

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


Zeichenfolge entspricht – PBXB64-Compiler-Hilfe

Startseite › Funktionen › String-Gleichungen

String entspricht

Sie können ein String-Equate erstellen, indem Sie dem Equate-Namen das Präfix $ (für ANSI) oder $$ (für WIDE) voranstellen. Der Wert auf der rechten Seite der Equate-Zuweisung muss ein String-Literal oder ein erstellter Ausdruck sein

Typ:Schlüsselwort |Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

$$Fullname = „John“$$ & „Smith“$$

$$UserNam = $$First & $$Last

$PrintCode = CHR$(27, 34, „E“) + SPACE$(10) + CHR$(65 TO 90)

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


Zeichenfolgenausdrücke – PBXB64-Compiler-Hilfe

Startseite › Funktionen › String-Ausdrücke

String-Ausdrücke

Ein String-Ausdruck besteht aus String-Literalen, String-Variablen und String-Funktionen, optional kombiniert mit den Verkettungsoperatoren (+ oder &). String-Ausdrücke erzeugen immer Strings als

Typ:Schlüsselwort |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Zeichenfolgenkonstante „Katzen und Hunde“.

Vorname$ ' String-Variable

Vorname$ + Nachname$ ' Zeichenfolgenverkettung

a$ = „Cats“ & „and“ & „dogs“ ' Zeichenfolgenverkettung

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


String-Operationsbefehle – PBXB64-Compiler-Hilfe

Startseite › Funktionen › String-Operationsbefehle

Befehle für String-Operationen

Die folgenden Funktionen manipulieren und verwalten String-Daten:

Typ:Schlüsselwort |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Übersetzen Sie eine Unicode-Zeichenfolge in eine ANSI-Zeichenfolge.

Weisen Sie aufeinanderfolgenden Elementen eines Arrays eine Reihe von Werten zu.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


Dynamische Zeichenfolgen (variabler Länge) ($) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Dynamische Zeichenfolgen (variabler Länge) ($)
Hilfe zum PBXB64-Compiler

Dynamische Zeichenfolgen (variabler Länge) ($)

Dynamische String-Variablen (auch als variable Länge bezeichnet) können eine beliebige Anzahl von Zeichen enthalten. Intern verwendet jede Variable vier Bytes, die eine Handle-Nummer enthalten, die zur Identifizierung verwendet wird

Typ: Datentyp | Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

String-Variablen werden automatisch deklariert, wenn auf den Variablennamen ein oder zwei Dollarzeichen ($) folgen. Sie können dynamische String-Variablen auch mit den Schlüsselwörtern STRING oder WSTRING mit der DIM-Anweisung deklarieren. Zum Beispiel:

PowerBASIC weist Strings mithilfe der Win32-OLE-String-Engine zu. Dadurch können Sie Zeichenfolgen von Ihrem Programm an DLLs oder API-Aufrufe übergeben, die OLE-Zeichenfolgen unterstützen. Die Adresse des Inhalts einer nicht leeren Zeichenfolge kann mit der Funktion STRPTR ermittelt werden. Die Adresse des String-Handles kann mit der VARPTR-Funktion ermittelt werden. Eine leere Zeichenfolge (Null) gibt möglicherweise keinen gültigen STRPTR-Wert zurück. Dynamische Zeichenfolgen werden mit jeder Zuweisungsanweisung im Speicher verschoben: Das heißt, STRPTR gibt eine andere Adresse zurück, wenn der Inhalt der Zeichenfolge geändert wird. Das von VARPTR erhaltene zugehörige String-Handle bleibt jedoch für die Dauer der Lebensdauer (Bereich) der String-Variablen konstant.

LOKALER dynamischer String-Speicher und Handles werden freigegeben, wenn die zugehörige Sub , Function , Method oder Property endet. Nachfolgende Aufrufe einer Routine führen zu neuen Speicherorten sowohl für das Handle als auch für die Zeichenfolgendaten. Die Adresse des Handles eines dynamischen STATIC- oder GLOBAL-Strings bleibt für die Dauer des Moduls konstant. Dynamische Zeichenfolgen und Feldzeichenfolgen können nicht Teil von UDT- (User-Defined Type) oder UNION-Strukturen sein. In C/C++ wird ein dynamischer breiter String ($$) als BSTR-Datentyp bezeichnet.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Dynamische Zeichenfolgen (variabler Länge) ($) soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Dynamische Zeichenfolgen (variabler Länge) ($) mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


IStringBuilderA.Add-Methode – PBXB64-Compiler-Hilfe

Startseite › Funktionen › IStringBuilderA.Add-Methode

IStringBuilderA.Add-Methode

Das StringBuilder-Objekt bietet die Möglichkeit, viele Zeichenfolgen zu verketten

Typ:Schlüsselwort |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Beschreibung

Es gibt zwei Formen des StringBuilder-Objekts, eine für ANSI-Zeichenfolgen und eine für WIDE-Zeichenfolgen (Unicode). Sie hätten zwar zu einem einzigen Hybridobjekt zusammengefasst werden können, dies hätte jedoch einen zusätzlichen Mehraufwand verursacht, der für PowerBASIC nicht akzeptabel ist. Um ANSI-Zeichenfolgen zu verketten, verwenden Sie die StringBuilderA-Klasse und die IStringBuilderA-Schnittstelle. Um WIDE-Zeichenfolgen (Unicode) zu verketten, verwenden Sie die StringBuilderW-Klasse und die IStringBuilderW-Schnittstelle. Die Methoden und Funktionsweise sind bei beiden Formen identisch.

Wenn Sie das ANSI-Format wählen, müssen die Parameterzeichenfolgen ANSI sein und die Ergebniszeichenfolgen müssen ANSI sein. Bei der WIDE-Form (Unicode) müssen Parameterzeichenfolgen breit sein, und Ergebniszeichenfolgen sind ebenfalls breit. Berücksichtigen Sie diese Anforderungen, wenn Sie die folgenden Methodendefinitionen lesen. Die Dispatch-ID ( DispID ) für jede Mitgliedsmethode wird in spitzen Klammern angezeigt.

Wenn Sie ein StringBuilder-Objekt erstellen, wird ein dynamischer Zeichenfolgenpuffer erstellt, der die Zielzeichenfolge enthält. Wenn Sie die Größe der Ergebniszeichenfolge kennen (oder auch nur eine Annäherung), ist es in der Regel ratsam, zuerst die CAPACITY-Methode zu verwenden, um eine Größe zu ermitteln, die mindestens so groß wie die endgültige Zeichenfolge ist. Wenn dies nicht bekannt ist, wird PowerBASIC versuchen, geeignete Entscheidungen für Sie zu treffen. Sobald das Objekt erstellt wurde, werden mit der ADD-Methode Zeichenfolgenabschnitte so oft wie nötig angehängt. Schließlich wird die STRING-Methode verwendet, um die kombinierten Elemente zu extrahieren.

StringBuilder-Methoden/Eigenschaften

ADD ( PowerString$ ) Methode<1>

Der PowerString$-Parameter wird an die im StringBuilder-Objekt enthaltene Zeichenfolge angehängt. Wenn der interne String-Puffer überläuft, erweitert PowerBASIC ihn automatisch auf eine entsprechende Größe. Wenn eine erforderliche Puffererweiterung fehlschlägt, wird ein HResult von E_OUTOFMEMORY (&H8007000E) zurückgegeben und ein Objektfehler (99) generiert.

CAPACITY () AS Long Get Property<2>

Die Größe des internen String-Puffers wird abgerufen und an den Aufrufer zurückgegeben. Die Größe ist die Anzahl der Zeichen, die ohne weitere Erweiterung gespeichert werden können.

CAPACITY () = Long Set Property<2>

Der interne String-Puffer wird auf die durch den Long Integer angegebene Anzahl von Zeichen erweitert. Wenn die neue Kapazität kleiner oder gleich der aktuellen Kapazität ist, wird keine Operation ausgeführt.

CHAR ( Index& ) AS Long Get Property<3>

Der numerische Zeichencode des Zeichens an der Position Index& wird abgerufen und an den Aufrufer zurückgegeben. Index&=1 für das erste Zeichen, 2 für das zweite usw. Wenn Index& über die aktuelle Länge der Zeichenfolge hinausgeht, wird der Wert -1 zurückgegeben.

CHAR ( Index& ) = Long Set Property<3>

Das Zeichen an der Position Index& wird in das durch den Long Integer-Zeichencode angegebene Zeichen geändert. Index& =1 für das erste Zeichen, 2 für das zweite usw.

CLEAR-Methode<4>

Alle Daten im Objekt werden gelöscht.

DELETE ( Index& , Count& ) Methode<5>

Count& Zeichen werden ab der durch Index& angegebenen Position entfernt. Index& =1 für das erste Zeichen, 2 für das zweite usw.

INSERT ( PowerString$ , Index& ) Methode<6>

Der PowerString$-Parameter wird in die Zeichenfolge eingefügt, beginnend an der durch Index& angegebenen Position. Index& =1 für das erste Zeichen, 2 für das zweite usw. Wenn Index& über der aktuellen Länge der Zeichenfolge +1 liegt, wird keine Operation ausgeführt.

LEN () AS Long-Methode<7>

Die Anzahl der aktuell im Objekt gespeicherten Zeichen wird als langer ganzzahliger Wert zurückgegeben.

STRING AS String-Methode<8>

Der im Objekt gespeicherte String wird an den Aufrufer zurückgegeben. Diese Zeichenfolge enthält LEN-Zeichen.

Das StringBuilder-Objekt bietet die Möglichkeit, viele String-Abschnitte mit sehr hoher Leistung zu verketten. Die Ausführungsgeschwindigkeit macht sich insbesondere dann bemerkbar, wenn die Verkettung in vielen separaten Vorgängen über einen bestimmten Zeitraum erfolgt. Wenn alle String-Abschnitte gleichzeitig bekannt und verfügbar sind, könnte die Verwendung der BUILD$()-Funktion die bessere Wahl sein. Allerdings bieten beide Optionen einen sehr großen Vorteil im Vergleich zu den Standard-Verkettungsoperatoren (& oder +). Zusätzlich zur Verkettung bietet die StringBuilder-Klasse auch einige zusätzliche String-Operationen, die beim Aufbau des Strings helfen.

Es gibt zwei Formen des StringBuilder-Objekts, eine für ANSI-Zeichenfolgen und eine für WIDE-Zeichenfolgen (Unicode). Sie hätten zwar zu einem einzigen Hybridobjekt zusammengefasst werden können, dies hätte jedoch einen zusätzlichen Mehraufwand verursacht, der für PowerBASIC nicht akzeptabel ist. Um ANSI-Zeichenfolgen zu verketten, verwenden Sie die StringBuilderA-Klasse und die IStringBuilderA-Schnittstelle. Um WIDE-Zeichenfolgen (Unicode) zu verketten, verwenden Sie die StringBuilderW-Klasse und die IStringBuilderW-Schnittstelle. Die Methoden und Funktionsweise sind bei beiden Formen identisch.

Wenn Sie das ANSI-Format wählen, müssen die Parameterzeichenfolgen ANSI sein und die Ergebniszeichenfolgen müssen ANSI sein. Bei der WIDE-Form (Unicode) müssen Parameterzeichenfolgen breit sein, und Ergebniszeichenfolgen sind ebenfalls breit. Berücksichtigen Sie diese Anforderungen, wenn Sie die folgenden Methodendefinitionen lesen. Die Dispatch-ID ( DispID ) für jede Mitgliedsmethode wird in spitzen Klammern angezeigt.

Siehe auch

  • BUILD$
  • CHR$
  • CSET
  • CSET$
  • JOIN$
  • LSET
  • LSET$
  • REPEAT$
  • RSET
  • RSET$
  • STRING$
  • STRINSERT$
  • WRAP$

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für IStringBuilderA.Add-Methode soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' IStringBuilderA.Add-Methode mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


STRINGZ / ASCIIZ - NUL-terminierten String deklarieren — PBXB64 Help

Startseite › General Reference › STRINGZ / ASCIIZ - NUL-terminierten String deklarieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

STRINGZ / ASCIIZ - NUL-terminierten String deklarieren

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

LOCAL z AS ASCIIZ * 260

Detailverhalten

Fester Puffer-Stringtyp mit Nullterminator-Semantik fuer API-Kompatibilitaet.

Praktische Verwendung

Verwenden Sie diese Schreibweise fuer feste Puffer mit NUL-Ende, typischerweise fuer API-kompatible Strings. Die Deklaration muss die Zielgroesse mit angeben, damit Trunkierung und Terminierung prufbar bleiben.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Verwechseln Sie diese Typkeywords nicht mit freien Bezeichnern oder Laufzeitwerten. Wenn der Zielkontext die Type-Position nicht erwartet, muss die Quelle entsprechend angepasst werden.

Verifiziertes Beispiel

Abgedeckt durch examples/basic/test_wstringz.pb (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


STRINSERT$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STRINSERT$

STRINSERT$

Fügen Sie eine Zeichenfolge ein

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = STRINSERT$( MainStr$ , NewStr$ , position& )

Beschreibung

Gibt eine Zeichenfolge zurück, die aus dem Zeichenfolgenausdruck MainStr$ besteht, wobei an Position & der Zeichenfolgenausdruck NewStr$ eingefügt ist. Wenn position& größer als die Länge von MainStr$ ist, wird NewStr$ an MainStr$ angehängt. Das erste Zeichen in der Zeichenfolge ist Position 1 usw.

Siehe auch

  • BUILD$
  • CLIP$
  • CSET
  • CSET$
  • LSET
  • RSET
  • STRDELETE$
  • STRREVERSE$
  • WRAP$

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


STRPTR – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STRPTR

STRPTR

Gibt das 32-Bit zurück

Typ:Funktion |Kategorie: Memory & Pointers

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

xPtr = STRPTR( StringVar )

Beschreibung

StringVar ist der Name einer String-Variablen. STRPTR gibt die 32-Bit-Adresse im Speicher zurück, wo der Inhalt von StringVar gespeichert ist.

Beachten Sie, dass sich STRPTR von VARPTR unterscheidet. Bei Verwendung mit einer String-Variablen gibt VARPTR die Adresse des String-Handles zurück, während STRPTR die Adresse der tatsächlichen String-Daten zurückgibt. Ebenso ist ein STRING POINTER (oder STRING PTR) ein Zeiger auf ein String-Handle – dieser wichtige Unterschied sollte bei der Arbeit mit den Operationen VARPTR und STRPTR berücksichtigt werden.

STRPTR darf nicht mit Zeichenfolgen fester Länge oder mit NULL-terminierten Zeichenfolgen verwendet werden, da diese keine Zeichenfolgenhandles verwenden. Verwenden Sie VARPTR mit Zeichenfolgen fester Länge und mit Nullterminierung.

Wenn der Inhalt einer dynamischen Zeichenfolge geändert wird, ändert sich auch die Adresse der Zeichenfolgendaten, das Zeichenfolgenhandle bleibt jedoch an derselben Stelle. Daher ist es wichtig, dass Ihr Code alle Zeiger aktualisiert, die direkt auf die Speicherorte der Zeichenfolgendaten zielen.

Siehe auch

  • CODEPTR
  • STICK$
  • PEEK$
  • VARPTR

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


STRREVERSE$ – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › STRREVERSE$

STRREVERSE$

Kehren Sie den Inhalt einer Zeichenfolge um

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = STRREVERSE$( MainStr$ )

Beschreibung

Kehrt den Inhalt von MainStr$ um und gibt das Ergebnis zurück.

Siehe auch

  • STRDELETE$
  • STRINSERT$

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


Strukturierte Programmierung – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Strukturierte Programmierung

Strukturierte Programmierung

Für die meisten Anwendungen verwenden gute Programmierer einen organisierten Programmieransatz, der als strukturierte Programmierung bezeichnet wird. Die ursprünglich interpretierten BASICs unterstützten diese Art der Programmierung nicht wirklich. Allerdings

Typ:Schlüsselwort |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Strukturierte Programmierung basiert auf der Theorie, dass Modularisierung zu besseren Programmen führt. Modularisierung bedeutet, Anweisungn zusammenzufassen (Module zu erstellen), die in irgendeiner Beziehung zueinander stehen. Mit anderen Worten: Sie unterteilen Ihr Programm in logische Funktionsabschnitte. Dies erleichtert das Schreiben, Debuggen und Verstehen des Programms.

Idealerweise sollten Module nicht länger als eine Seite sein. Diese scheinbar willkürliche Einschränkung erleichtert das Erfassen des gesamten Moduls auf einen Blick. Es ist einfacher, eine Reihe von zehn einseitigen Modulen zu verstehen als ein einzelnes zehnseitiges Programm.

Bei einigen Projekten sind Sie nach dieser ersten Trennung bereit, das Programm zu schreiben. Bei komplizierteren Problemen müssen Sie die Module möglicherweise in Teilstücke zerlegen. Dieser Prozess wird fortgesetzt, bis Sie das Material so weit verfeinert haben, dass Sie den Code schreiben können, der Ihren Vorstellungen entspricht. Dieser gesamte Prozess wird in Büchern oft als „Top-Down-Design“ beschrieben, da man mit einer allgemeinen Beschreibung beginnt und auf eine spezifischere Beschreibung hinarbeitet.

Sobald Sie die logische Organisation haben, können Sie mit der Gestaltung der Gesamtstruktur Ihres Programms beginnen. Bei kurzen, einfachen Programmen können diese Schritte nur wenige Minuten dauern. Bei komplexen Programmen kann es Monate dauern.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Strukturierte Programmierung soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Strukturierte Programmierung mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Indizes – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Indizes

Indizes

Einzelne Array-Elemente werden mit Indizes oder Indexnummern ausgewählt, bei denen es sich um lange Ganzzahlausdrücke in Klammern rechts vom Namen einer Array-Variablen handelt. Zum Beispiel Zahlungen (3) und p

Typ:Schlüsselwort |Kategorie:Variablen und Umfang

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

' Diese DIM-Anweisung deklariert ein Array mit 56 Elementen

' mit tiefgestellten Grenzen von 0 bis 55.

DIM-Zahlungen1(55) ALS WÄHRUNG

' Diese DIM-Anweisung deklariert ein Array mit 56 Elementen

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


SWAP – PBXB64-Compiler-Hilfe

Startseite › Funktionen › SWAP

TAUSCHEN

Tauschen Sie die Werte von zwei aus

Typ:Anweisung |Kategorie:Mathematik und Numerik

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SWAP var1 , var2

Beschreibung

TAUSCHEN gehoert zur Kategorie General. Diese Seite beschreibt den PBXB64-Dokumentationsstand fuer diesen Eintrag; verwenden Sie die Grenzen und Belege auf dieser Seite statt historischer PBWin-Annahmen.

Praktische Verwendung

TAUSCHEN gehoert zur Kategorie General. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' TAUSCHEN mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Siehe auch

  • Befehlsindex
  • BASIC-Frontend


SWITCH – PBXB64-Compiler-Hilfe

Startseite › Funktionen › SCHALTER

SWITCH

Gibt einen Wert aus einer Reihe von Werten basierend auf a zurück

Typ:Funktion |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET] für numerisches SWITCH; SWITCH$ implementiert und getestet

Syntax

var = SWITCH( expr1 , val1 [[, expr2 , val2 ], ...])
var& = SWITCH&( expr1 , val1& [[, expr2 , val2& ], ...])
var$ = SWITCH$( expr1 , val1$ [[, expr2 , val2$ ], ...])

Beschreibung

SWITCH erwartet Werte jeden numerischen Typs. SWITCH& erwartet Werte, die für den Typ Long-Integer optimiert sind. SWITCH$ erwartet Werte vom Typ String.

Wenn expr1 TRUE auswertet, wird val1 zurückgegeben, wenn expr2 TRUE auswertet, wird val2 zurückgegeben usw.

Jeder Steuerausdruck in der Reihe wird als typischer boolescher PowerBASIC-Ausdruck ausgewertet, der bei Bedarf eine Auswertung des Kurzschlussausdrucks ermöglicht. Um eine bitweise Auswertung eines Ausdrucks zu erzwingen, schließen Sie ihn in Klammern ein. Die Wertparameter können Ausdrücke, Literale oder Variablen des entsprechenden Datentyps für die verwendete SWITCH-Funktion sein.

SWITCH gibt den passenden Wertparameter aus der ersten TRUE-Auswertung der Steuerausdrücke zurück, ausgewertet von links nach rechts in der Liste. Daher wäre es ratsam, die wahrscheinlichsten Auswahlmöglichkeiten ganz oben auf der SWITCH-Liste zu platzieren, um größtmögliche Effizienz zu erzielen. Wenn kein Ausdruck TRUE ergibt, wird Null (0) zurückgegeben.

Einschränkungen

Der Compiler erzeugt bedingte Sprünge, sodass nur die erste TRUE-Bedingung und der zugehörige Wert bei einfachen Literal- und Variablenargumenten ausgeführt werden. Da Funktionsargumente vor dem SWITCH/SWITCH$-Aufruf ausgewertet werden, können Ausdrücke mit Funktionsaufrufen und Seiteneffekten dennoch für übersprungene Bedingungen und Werte ausgewertet werden.

Siehe auch

  • CHOOSE
  • IF
  • IIF
  • SELECT

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Syntax Benutzerdefinierte Farbauswahl – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Syntax Benutzerdefinierte Farbauswahl
Hilfe zum PBXB64-Compiler

Syntax Benutzerdefinierte Farbauswahl

Grundfarben

Typ:Schlüsselwort |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Vom Bildschirmtreiber festgelegter Satz von Grundfarben.

Zeigt alle benutzerdefinierten Farben an, die Sie bereits definiert haben. Um eine benutzerdefinierte Farbe zu ändern, klicken Sie darauf und dann auf die Schaltfläche „Benutzerdefinierte Farben definieren“. Wenn Sie die Farbe ausgewählt haben, klicken Sie auf die Schaltfläche „Zu benutzerdefinierten Farben hinzufügen“. Um eine neue benutzerdefinierte Farbe zu definieren, klicken Sie auf eine leere benutzerdefinierte Farbe und dann auf die Schaltfläche „Benutzerdefinierte Farben definieren“. Wählen Sie die neue Farbe aus und klicken Sie dann auf die Schaltfläche „Zu benutzerdefinierten Farben hinzufügen“.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend
← SCHALTER Nach oben TAB LÖSCHEN →

Beschreibung

Die benutzerdefinierte Farbauswahl beschreibt den Teil des Standard-Farbdialogs, in dem eigene Farben angelegt oder geaendert werden. Die Seite soll klar machen, dass es um die Dialogfunktion und nicht um eine allgemeine Farbbibliothek geht.

Syntax

Verwenden Sie die Seite als Referenz fuer die Standard-Dialogschritte: Farbfeld auswaehlen, eigene Farbe definieren, zur Liste hinzufuegen und die Auswahl bestaetigen.

Beispiel

Oeffnen Sie den Farbdialog, waehlen Sie ein benutzerdefiniertes Feld, definieren Sie einen neuen Farbwert und pruefen Sie, dass die neue Farbe in der benutzerdefinierten Palette sichtbar bleibt.

Validierungsbeleg

Die aktuelle Hilfeseite und die GUI-Referenzen dokumentieren den getesteten Dialogfluss. Die Seite soll die Bedienfolge beschreiben und nicht eine groessere UI- oder Grafik-Funktionalitaet behaupten.


SYSINFO - PBXB64 Help

Startseite › General Reference › SYSINFO

SYSINFO

Liefert ausgewaehlte Windows-Systeminformationswerte.

Typ: Runtime method | Kategorie: System

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED] fuer Indizes 0 bis 6 und den Rueckgabewert 0 fuer nicht unterstuetzte Indizes.

Syntax

value&& = SYSINFO(index&)

Beschreibung

SYSINFO wird auf den eingebetteten Laufzeithelfer bestof_sysinfo gesenkt. PBXB64 zertifiziert aktuell diese fokussierte Indexzuordnung:

Praktische Verwendung

Verwenden Sie SYSINFO fuer feste Indexabfragen, wenn ein Programm Systemdaten als Snapshot benoetigt. Vergleichen Sie die Rueckgabe direkt mit einem erwarteten Wert oder einem kleinen, dokumentierten Bereich.

Index | Wert
0 | Anzahl der Prozessoren
1 | Systemseitengroesse
2 | Allokationsgranularitaet
3 | Prozessorarchitektur-Code plus eins
4 | Prozessortyp
5 | Gesamter physischer Speicher in Bytes
6 | Verfuegbarer physischer Speicher in Bytes

Nicht unterstuetzte Indizes geben 0 zurueck.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    IF SYSINFO(0) <= 0 THEN FUNCTION = 1
        IF SYSINFO(9999) <> 0 THEN FUNCTION = 2
END FUNCTION

Geprueftes Beispiel

Beispieldatei: examples/basic/test_delay_run_sysinfo.pb

Validierungsnachweis: In tests/validate.toml als test_delay_run_sysinfo registriert; fokussierte pb_linkrun-Validierung belegt die Indizes 0 bis 6 und den Rueckgabewert 0 fuer nicht unterstuetzte Indizes.

Fehlerfaelle

Indizes ausserhalb des zertifizierten Bereichs liefern 0. Ein Test sollte Index und Wert gemeinsam dokumentieren, damit sich echte Systemunterschiede von Fehlerfaellen trennen lassen.

Einschraenkungen

Eine breitere PB-kompatible SYSINFO-Feldzuordnung ist noch nicht zertifiziert.

Indexregeln

Die dokumentierten Indizes sind feste numerische Abfragen. Behandeln Sie den Rueckgabewert als Snapshot des aktuellen Systemzustands zum Zeitpunkt des Aufrufs.

Fehlerhinweise

Nicht unterstuetzte Indizes geben 0 zurueck. Das Beispiel belegt sowohl gueltige Indexwerte als auch den Fallback fuer nicht unterstuetzte Indizes.

Siehe auch

DELAY | RUN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TAB DELETE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › TAB LÖSCHEN

TAB LÖSCHEN

A

Typ:Anweisung |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

TAB DELETE hDlg , ID& , PageNum&
TAB GET COUNT hDlg , ID& TO CountVar&
TAB GET DIALOG hDlg , ID& , PageNum& TO PageDlgVar&
TAB GET IMAGE hDlg , ID& , PageNum& TO ImageVar&
TAB GET PAGE PageDlg TO PageNumVar&
TAB GET SELECT hDlg , ID& TO PageNumVar&
TAB GET TEXT hDlg , ID& , PageNum& TO TextVar$
TAB INSERT PAGE hDlg , ID& , PageNum& , Image& , Text$ [CALL CallBack ] TO PageDlgVar&
TAB RESET hDlg , ID&
TAB SELECT hDlg , ID& , PageNum&
TAB SET IMAGE hDlg , ID& , PageNum& , Image&
TAB SET IMAGELIST hDlg , ID& , hLst
TAB SET TEXT hDlg , ID& , PageNum& , Text$
Function Form:
CountVar& = TAB(COUNT, hDlg , ID& )
PageDlgVar& = TAB(DIALOG, hDlg , ID& , PageNum& )
ImageVar& = TAB(IMAGE, hDlg , ID& , PageNum& )
PageNumVar& = TAB(PAGE, PageDlg& )
PageNumVar& = TAB(SELECT, hDlg , ID& )
TextVar$ = TAB$(TEXT, hDlg , ID& , PageNum& )

Beschreibung

In jeder der folgenden Beschreibungen wird das Tab-Steuerelement, das Gegenstand der Anweisung ist, durch das Handle des Dialogs identifiziert, der das Tab-Steuerelement (hDlg) besitzt, und durch die eindeutige Steuerelement-ID, die Sie ihm bei der Erstellung in CONTROL ADD TAB gegeben haben. Immer wenn auf eine TAB-Seitennummer oder eine IMAGELIST-Bildnummer verwiesen wird, wird diese auf eins indiziert. Das heißt, das erste Element ist 1, das zweite Element ist 2 usw. Variationen von TAB, die einen einzelnen Wert zurückgeben, können in der optionalen Funktionsform geschrieben werden, wie oben gezeigt. Diese Funktionen können in einen Ausdruck beliebiger Komplexität eingebettet werden.

TAB DELETE hdlg , ID& , PageNum&

Die durch den Parameter PageNum& angegebene Seite wird aus dem Tab Control gelöscht.

TAB GET COUNT hdlg , id& TO CountVar&

Die Anzahl der Seiten im TAB-Steuerelement wird abgerufen und der durch CountVar& angegebenen langen Ganzzahlvariablen zugewiesen.

TAB GET DIALOG hDlg , ID& , PageNum& TO PageDlgVar&

Das Handle des untergeordneten Dialogs, der an eine TAB-Steuerelementseite angehängt ist, wird abgerufen und der durch PageDlgVar& bezeichneten Variablen zugewiesen. Das zurückzugebende Dialoghandle wird durch den Wert des Parameters PageNum& bestimmt. Wenn diese Seite/dieser Dialog nicht existiert, wird der Wert Null zurückgegeben.

TAB GET IMAGE hdlg , ID& , PageNum& TO ImageVar&

Der Index des auf der angegebenen TAB-Seite angezeigten Bildes wird abgerufen und der durch ImageVar& angegebenen Variablen zugewiesen. Wird kein Bild angezeigt, wird der Wert Null (0) zugewiesen.

TAB GET PAGE PageDlg TO PageNumVar&

Bei gegebenem Handle eines TAB-Seitendialogs wird die PageNum abgerufen und der durch PageNumVar& angegebenen Variablen zugewiesen. Dies kann besonders nützlich sein, wenn Sie CallBack-Nachrichten für Registerkartendialoge verarbeiten. Wenn Sie außerdem Eltern- und ID-Informationen benötigen, können Sie WINDOW GET verwenden.

TAB GET SELECT

hDlg , id& TO SelectVar&

Der Index der aktuell ausgewählten Seite im Tab Control wird abgerufen und der durch SelectVar& angegebenen Variablen zugewiesen. Wenn keine aktuelle Auswahl vorhanden ist, wird der Wert Null (0) zugewiesen.

TAB GET TEXT hDlg , ID& , PageNum& TO TextVar$

Der auf der angegebenen Seitenregisterkarte angezeigte Text wird abgerufen und der durch TextVar$ angegebenen Variablen zugewiesen.

TAB INSERT PAGE hdlg , ID& , PageNum& , Image& , Text$ [CALL CallBack ] TO PageDlgVar&

Diesem TAB-Steuerelement wird eine Seite hinzugefügt. Der Parameter PageNum& gibt die Position der einzufügenden Seite an. Ein optionales Bild, das im Registerkartenbereich angezeigt werden soll, wird basierend auf dem Parameter Image& aus der angehängten IMAGELIST ausgewählt. Setzen Sie Image& auf 0, wenn kein Bild gewünscht wird. Der Parameter Text$ gibt den Text an, der im Registerkartenbereich angezeigt werden soll. CallBack ist der Name einer Callback-Prozedur, die für den Seitendialog verwendet werden soll. Das Handle des neu erstellten Dialogs wird der durch PageDlgVar& bezeichneten Variablen zugewiesen.

TAB RESET hDlg , id&

Alle Seiten im angegebenen Tab Control werden gelöscht.

TAB SELECT hdlg , ID& , PageNum&

Die durch den Parameter PageNum& angegebene Seite wird als ausgewählte Seite für das TAB-Steuerelement ausgewählt und der zugehörige Dialog wird angezeigt.

TAB SET IMAGE hdlg , ID& , PageNum& , Image&

Das durch den Parameter Image& angegebene Bild wird auf der durch den Parameter PageNum& angegebenen Seitenregisterkarte angezeigt.

TAB SET IMAGELIST hdlg , ID& , hLst

Die von hLst angegebene IMAGELIST wird an dieses TAB-Steuerelement angehängt. Die in der IMAGELIST enthaltenen grafischen Bilder werden auf den Registerkarten dieses Steuerelements angezeigt. Das anzuzeigende Bild wird durch die in TAB INSERT PAGE oder TAB SET IMAGE getroffene Angabe bestimmt. Wenn das TAB-Steuerelement zerstört wird, werden alle angehängten IMAGELIST automatisch zerstört.

TAB SET TEXT hdlg , ID& , PageNum& , Text$

Der Text im Parameter Text$ wird auf der Registerkarte der durch PageNum& angegebenen Seite angezeigt.

PBXB64-Implementierungshinweise

PBXB64 V10 zertifiziert die echten Win32-Common-Control-Formulare TAB INSERT PAGE, TAB DELETE, TAB RESET, TAB GET COUNT, TAB GET DIALOG, TAB GET PAGE, TAB GET IMAGE, TAB GET SELECT, TAB GET TEXT, TAB SELECT, TAB SET IMAGE, TAB SET TEXT und TAB SET IMAGELIST. TAB INSERT PAGE erstellt ein echtes Dialoghandle für untergeordnete Seiten, das mit TAB GET DIALOG abgerufen und mit TAB GET PAGE wieder zugeordnet werden kann. TAB DELETE entfernt die ausgewählte Seiten-Dialog-Zuordnung und verschiebt spätere Seitenzuordnungen um eins nach unten; TAB RESET entfernt alle Seitenzuordnungen für das Steuerelement.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG REGISTERKARTE HINZUFÜGEN
  • STEUERUNG SET SCHRIFTART
  • BILDLISTE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TAGARRAY() - PBXB64 Help

Startseite › General Reference › TAGARRAY()
Hilfe zum PBXB64-Compiler

TAGARRAY()

Liefert den Tag-Array-Wert zu einem PB-logischen Index nach numerischer Tag-Array-Sortierung.

Kind: PowerBASIC feature | Category: PowerBASIC / Tested Feature

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

tag& = TAGARRAY(tags(), index)

Beschreibung

Diese Seite beschreibt das PBXB64-Verhalten, das durch die aktuelle Validierungsmatrix abgedeckt ist. Verwenden Sie die hier gezeigte Syntax fuer Regressionstests; weitergehende PowerBASIC-Formen gelten als separate Kompatibilitaetsarbeit, sofern keine andere Seite sie dokumentiert.

Unterstuetzter Umfang

Die dokumentierte Teilmenge ist absichtlich genau: Beispiele verwenden bevorzugt skalare LONG-Werte, Array-Beispiele benutzen normale PB-logische Indizes, und laufzeitabhaengige Operationen sollen immer den Rueckgabestatus pruefen. Wenn ein Feature sowohl Anweisungs- als auch Funktionsschreibweise besitzt, beschreibt diese Seite den funktionsorientierten Seiteneintrag und verweist auf die breitere BASIC-Referenz.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    DIM tags(1 TO 2) AS LONG
    ARRAYASSIGN(tags(), 100, 200)
    IF TAGARRAY(tags(), 2) <> 200 THEN FUNCTION = 1
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_tagarray_function.pb`.

Fuer Release-Arbeiten sollte jede Syntaxform einen kleinen ausfuehrbaren Test besitzen. Ein guter Test initialisiert alle Eingaben, fuehrt den dokumentierten Befehl oder die Funktion aus, prueft das exakte Ergebnis und liefert bei Fehler einen von Null verschiedenen Exit-Code. Dadurch bleiben Hilfeaussagen an reproduzierbares Verhalten eines isolierten PBXB64-Compilers gebunden.

Grenzen

Nicht gezeigte PowerBASIC-Varianten duerfen aus dieser Seite nicht als unterstuetzt abgeleitet werden. Formen, die hier nicht stehen, benoetigen eigene Implementierung, Diagnostik, Tests und Hilfetext, bevor sie als abgeschlossen beschrieben werden.

Siehe auch

  • BASIC Language Reference
  • Examples

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.


TALLY “ PBXB64-Compiler-Hilfe

Startseite â€º Funktionen â€º TALLY

TALLY

Zaehlt nicht ueberlappende Vorkommen eines Teilstrings oder beliebiger Zeichen aus einer Menge.

Kind: Funktion | Category: String-Funktionen

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [ZERTIFIZIERT GETESTET]

Syntax

x& = TALLY( MainString , [ANY] MatchString )

Beschreibung

Zaehlt nicht ueberlappende Vorkommen eines Teilstrings oder beliebiger Zeichen aus einer Menge. TALLY zaehlt nicht ueberlappende Treffer von MatchString in MainString von links nach rechts.

Praktische Verwendung

Verwenden Sie die normale Form fuer wiederholte Token-Zaehler und die ANY-Form fuer Zeichenmengen.

Parameter und Ergebnisse

Argumente muessen den Datentypen, der Reihenfolge und den optionalen Teilen aus dem Syntaxblock folgen. Initialisieren Sie Zielvariablen vor dem Aufruf, damit unveraenderte Werte nach einem Fehler sichtbar bleiben.

Einschränkungen

Wiederholte Zeichen in MatchString erhoehen den ANY-Zaehler nicht.

Verhalten

TALLY zaehlt nicht ueberlappende Treffer von MatchString in MainString von links nach rechts.

Mit ANY wird MatchString als Menge einzelner Zeichen behandelt und jedes Quellzeichen pro Position hoechstens einmal gezaehlt.

Wenn Quellstring oder Suchstring leer ist, ist das Ergebnis null.

Verwendungshinweise

Verwenden Sie die normale Form fuer wiederholte Token-Zaehler und die ANY-Form fuer Zeichenmengen.

Die Funktion ist gross-/kleinschreibungsabhaengig. Wenn Sie ueberlappende Treffer oder Mustervergleich brauchen, verwenden Sie eine andere Routine.

Grenzfaelle

Wiederholte Zeichen in MatchString erhoehen den ANY-Zaehler nicht.

Nach jedem normalen Treffer springt der Scan um die Laenge von MatchString weiter, daher werden ueberlappende Treffer nicht gezaehlt.

Beispiel

FUNCTION PBMAIN() AS LONG
    DIM src AS STRING
    DIM setchars AS STRING
    DIM n AS LONG

    src = "Mississippi"
    n = TALLY(src, "ss")
    IF n <> 2 THEN FUNCTION = 1 : EXIT FUNCTION

    src = "ABCD"
    setchars = "BDB"
    n = TALLY(src, ANY setchars)
    IF n <> 2 THEN FUNCTION = 2 : EXIT FUNCTION

    FUNCTION = 0
END FUNCTION

Test- und Dokumentationshinweise

Mit tests/pb/test_string_scan_tally_verify.pb kompiliert und ausgefuehrt; Exitcode 0.

Validierungsbeleg

Mit tests/pb/test_string_scan_tally_verify.pb kompiliert und ausgefuehrt; Exitcode 0. TALLY(src, "ss") und TALLY(src, ANY setchars)

Verifiziertes Beispiel

Beispieldatei: tests/pb/test_string_scan_tally_verify.pb

Validierungsbeleg: Mit tests/pb/test_string_scan_tally_verify.pb kompiliert und ausgefuehrt; Exitcode 0.

FUNCTION PBMAIN() AS LONG
    DIM src AS STRING
    DIM setchars AS STRING
    DIM n AS LONG

    src = "Mississippi"
    n = TALLY(src, "ss")
    IF n <> 2 THEN FUNCTION = 1 : EXIT FUNCTION

    src = "ABCD"
    setchars = "BDB"
    n = TALLY(src, ANY setchars)
    IF n <> 2 THEN FUNCTION = 2 : EXIT FUNCTION

    FUNCTION = 0
END FUNCTION

Fokus: TALLY(src, "ss") und TALLY(src, ANY setchars)

Siehe auch

  • INSTR
  • SCAN$
  • VERIFY
  • REPLACE$

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


TEXTBOX / TBOX - PBXB64-Compiler-Hilfe

Startseite › Funktionen › TEXTBOX / TBOX

TEXTBOX / TBOX

Erstellt oder verwaltet ein einzeiliges oder mehrzeiliges Textfeld-Steuerelement in einem DDT-Dialogfeld.

Typ:Anweisung |Kategorie: DDT und Grafik/Steuerung

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CONTROL ADD TEXTBOX, hDlg, id, txt, x, y, w, h [, style [, exstyle]]

Remarks

Verwenden Sie CONTROL ADD TEXTBOX, um einem Dialogfeld ein Bearbeitungssteuerelement hinzuzufügen. Mit CONTROL GET TEXT und CONTROL SET TEXT können Sie Text abrufen oder festlegen.

Verwenden Sie das PASSWORTFELD hDlg, id, um die Passwortmaskierung für ein Textfeld zu aktivieren. PBXB64 sendet EM_SETPASSWORDCHAR an das zugrunde liegende Bearbeitungssteuerelement. Die Standardmaske ist ein Sternchen. PASSWORTFELD hDlg, id, mask& verwendet den numerischen Zeichencode in mask&.

Beispiel

FUNCTION PBMAIN() AS LONG
  LOCAL hDlg AS DWORD
  DIALOG NEW 0, "Textbox Demo",,, 200, 100, hDlg
  CONTROL ADD TEXTBOX, hDlg, 100, "", 10, 10, 180, 20
  DIALOG SHOW MODAL hDlg
  FUNCTION = 0
END FUNCTION

Siehe auch

  • STEUERUNG HINZUFÜGEN
  • CONTROL GET TEXT
  • STEUERUNG TEXT EINSTELLEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TCP ACCEPT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › TCP AKZEPTIEREN

TCP AKZEPTIEREN

Akzeptieren Sie eine eingehende Kommunikationsanfrage von einer bestimmten Person

Typ:Anweisung |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

TCP ACCEPT [#] fNum& AS newfNum&

Beschreibung

Akzeptieren Sie eine eingehende Verbindungsanforderung an den fNum&-Socket und erstellen Sie ein neues fNum&-Socket-Handle, um mit der neuen Verbindung zu kommunizieren.

TCP ACCEPT ist nur gültig, wenn Sockets mit TCP OPEN SERVER geöffnet werden.

Siehe auch

  • TCP- und UDP-Kommunikation
  • TCP CLOSE
  • TCP-LEITUNGSEINGANG
  • TCP-BENACHRICHTIGUNG
  • TCP OFFEN
  • TCP-DRUCK
  • TCP RECV
  • TCP SENDEN
  • UDP OFFEN

Kommunikationsprüfung

Serielle, TCP- und UDP-Seiten sollen Endpoint-Aufbau, Blocking-Verhalten, Timeout-Verhalten, Pufferbesitz und Cleanup nennen. Ein vollständiges Beispiel deckt Open/Create, Senden oder Empfangen, Close und einen vorhersagbaren Fehler wie einen ungültigen Endpoint ab.

Laufzeitvoraussetzungen

Netzwerkbeispiele können Firewall-Berechtigungen und freie Ports benötigen. Serielle Beispiele erfordern ein vorhandenes COM-Gerät oder einen dokumentierten Loopback/Testadapter.

Diagnosen

Erfassen Sie Rückgabewerte und Windows-Fehlercodes, wo verfügbar, damit Kommunikationsfehler auswertbar statt still sind.

Umfangshinweise

Wenn die Seite eine Familie statt eines einzelnen Befehls beschreibt, nennen Sie das konkrete Senden, Empfangen, Prüfen, Verbinden oder Schließen, das das Verhalten belegt, und sagen Sie, ob derselbe Socket oder Handle nach dem Aufruf weiterverwendet werden darf. Dadurch wird die Seite zu einem nutzbaren Laufzeitvertrag statt zu einem allgemeinen Protokollhinweis.


TCP- und UDP-Kommunikation – PBXB64-Compiler-Hilfe

Startseite › Funktionen › TCP- und UDP-Kommunikation

TCP- und UDP-Kommunikation

Überblick über TCP- und UDP-Netzwerke in PBXB64.

Typ:Konzeptionell |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Überblick

Dieses Thema bietet Hintergrundinformationen und praktische Anleitungen. Eine detaillierte Syntax finden Sie auf den entsprechenden Befehlsseiten.

Beschreibung

TCP- und UDP-Kommunikation ist die Uebersichtsseite fuer TCP- und UDP-Kommunikation. Die zugehoerigen Einzelseiten dokumentieren das Oeffnen, Senden, Empfangen, Zeilenlesen und Schliessen; diese Seite nennt den gemeinsamen Vertragsrahmen.

Syntax

TCP OPEN ... AS #hSock
TCP SEND #hSock, data$
TCP RECV #hSock, data$
TCP PRINT #hSock, string$
TCP LINE INPUT #hSock, text$
TCP CLOSE #hSock
UDP OPEN ... AS #hSock
UDP SEND #hSock, data$
UDP RECV #hSock, data$
UDP CLOSE #hSock

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL reply AS STRING
    TCP OPEN AS #1
    IF #1 = 0 OR #1 = -1 THEN FUNCTION = 1: EXIT FUNCTION
    TCP PRINT #1, "hello"
    TCP LINE INPUT #1, reply
    TCP CLOSE #1
END FUNCTION

Validierungsbeleg

Validierungsbeleg: tests/pb/test_tcp_open_server_port.pb und tests/pb/test_tcp_print_line_input.pb belegen den aktuellen TCP-Handle-Pfad. Die Familie bleibt bewusst auf die aktuell getesteten Verbindungs- und I/O-Formen beschraenkt.

Laufzeitvoraussetzungen

Netzwerkbeispiele koennen Firewall-Berechtigungen und freie Ports brauchen. Bei UDP ist keine Verbindungsstaatlichkeit wie bei TCP anzunehmen; die Uebersichtsseite sollte deshalb immer auf die konkrete Einzelseite verweisen, die den getesteten Pfad belegt.

Siehe auch

  • TCP OPEN
  • TCP PRINT
  • TCP LINE INPUT
  • TCP SEND
  • TCP RECV
  • TCP CLOSE
  • UDP OPEN
  • UDP SEND
  • UDP RECV
  • UDP CLOSE


TCP CLOSE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › TCP CLOSE

TCP CLOSE

Schließen Sie eine zuvor geöffnete Datei

Typ:Anweisung |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

TCP CLOSE [#] fNum&

Beschreibung

Schließen Sie den zuvor geöffneten TCP/IP-Port, der durch fNum& angegeben wurde.

Siehe auch

  • TCP- und UDP-Kommunikation
  • TCP AKZEPTIEREN
  • TCP-LEITUNGSEINGANG
  • TCP-BENACHRICHTIGUNG
  • TCP OFFEN
  • TCP-DRUCK
  • TCP RECV
  • TCP SENDEN
  • UDP CLOSE

Kommunikationsprüfung

Serielle, TCP- und UDP-Seiten sollen Endpoint-Aufbau, Blocking-Verhalten, Timeout-Verhalten, Pufferbesitz und Cleanup nennen. Ein vollständiges Beispiel deckt Open/Create, Senden oder Empfangen, Close und einen vorhersagbaren Fehler wie einen ungültigen Endpoint ab.

Laufzeitvoraussetzungen

Netzwerkbeispiele können Firewall-Berechtigungen und freie Ports benötigen. Serielle Beispiele erfordern ein vorhandenes COM-Gerät oder einen dokumentierten Loopback/Testadapter.

Diagnosen

Erfassen Sie Rückgabewerte und Windows-Fehlercodes, wo verfügbar, damit Kommunikationsfehler auswertbar statt still sind.

Umfangshinweise

Wenn die Seite eine Familie statt eines einzelnen Befehls beschreibt, nennen Sie das konkrete Senden, Empfangen, Prüfen, Verbinden oder Schließen, das das Verhalten belegt, und sagen Sie, ob derselbe Socket oder Handle nach dem Aufruf weiterverwendet werden darf. Dadurch wird die Seite zu einem nutzbaren Laufzeitvertrag statt zu einem allgemeinen Protokollhinweis.


TCP-ZEILEINGANG – PBXB64-Compiler-Hilfe

Startseite › Funktionen › TCP LINE INPUT

TCP-LEITUNGSEINGANG

Empfangen Sie eine Textzeile von einem angegebenen

Typ:Anweisung |Kategorie:Datei-E/A

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

TCP LINE [INPUT] [#] fNum& , Buffer$

Beschreibung

Empfangen Sie eine Textzeile vom fNum& TCP/IP-Port und platzieren Sie die Daten in Buffer$ . Wenn keine Bytes verfügbar sind, ist Buffer$ leer (eine Nullzeichenfolge). Wenn TCP LINE keine vollständige Textzeile empfangen hat (beendet durch ein $CRLF-Zeichenpaar), gibt EOF ( fNum& ) TRUE (ungleich Null) zurück.

Wenn eine Zeitüberschreitung auftritt, wird ERR so eingestellt, dass ein Laufzeitfehler 24 („Geräte-Zeitüberschreitung“) angezeigt wird. Informationen zum Festlegen des TCP-Socket-Timeout-Werts finden Sie unter TCP OPEN.

Die EOF-Funktion kann auch mit TCP LINE (und COMM LINE ) verwendet werden, um zu erkennen, dass eine unvollständige Zeile empfangen wurde. Normalerweise liest die TCP-LINE-Anweisung Daten, bis ein $CRLF-Zeichenpaar gefunden wird. In diesem Fall gibt EOF false (Null) zurück. Selbst wenn jedoch kein $CRLF gefunden wurde, kehrt TCP LINE zurück, wenn keine zusätzlichen Daten verfügbar sind. In diesem Fall gibt TCP LINE alle angesammelten Daten zurück und setzt EOF auf logisch TRUE (ungleich Null).

In vielen Fällen wäre es ratsam, EOF nach jeder TCP-LINE-Anweisung zu testen, um zu überprüfen, ob eine vollständige Zeile empfangen wurde. In manchen Fällen möchten Sie die Anweisung möglicherweise noch einmal oder mehrmals ausführen und dabei die Daten kombinieren, um eine vollständige Textzeile zu erhalten.

Siehe auch

  • TCP- und UDP-Kommunikation
  • EOF
  • TCP AKZEPTIEREN
  • TCP CLOSE
  • TCP-BENACHRICHTIGUNG
  • TCP OFFEN
  • TCP-DRUCK
  • TCP RECV
  • TCP SENDEN
  • UDP RECV

Kommunikationsprüfung

Serielle, TCP- und UDP-Seiten sollen Endpoint-Aufbau, Blocking-Verhalten, Timeout-Verhalten, Pufferbesitz und Cleanup nennen. Ein vollständiges Beispiel deckt Open/Create, Senden oder Empfangen, Close und einen vorhersagbaren Fehler wie einen ungültigen Endpoint ab.

Laufzeitvoraussetzungen

Netzwerkbeispiele können Firewall-Berechtigungen und freie Ports benötigen. Serielle Beispiele erfordern ein vorhandenes COM-Gerät oder einen dokumentierten Loopback/Testadapter.

Diagnosen

Erfassen Sie Rückgabewerte und Windows-Fehlercodes, wo verfügbar, damit Kommunikationsfehler auswertbar statt still sind.

Umfangshinweise

Wenn die Seite eine Familie statt eines einzelnen Befehls beschreibt, nennen Sie das konkrete Senden, Empfangen, Prüfen, Verbinden oder Schließen, das das Verhalten belegt, und sagen Sie, ob derselbe Socket oder Handle nach dem Aufruf weiterverwendet werden darf. Dadurch wird die Seite zu einem nutzbaren Laufzeitvertrag statt zu einem allgemeinen Protokollhinweis.


TCP NOTIFY – PBXB64-Compiler-Hilfe

Startseite › Funktionen › TCP NOTIFY

TCP-BENACHRICHTIGUNG

Bestimmen Sie welche

Typ:Anweisung |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

TCP NOTIFY [#] fNum& , {SEND | RECV | ACCEPT | CONNECT | CLOSE} TO hWnd& AS wMsg&

Beschreibung

Gibt an, welche Ereignisse (SEND, RECV, ACCEPT, CONNECT und CLOSE) eine wMsg&-Benachrichtigungsmeldung an die Fensterprozedur (Callback) des GUI-Fensters oder -Dialogs generieren, dessen Fensterhandle in hWnd& enthalten ist.

Ihr Programm definiert den wMsg&-Wert, und dieser Wert sollte gleich oder größer als %WM_USER + 500 sein, um Konflikte mit anderen (allgemeinen) Rückrufnachrichtenwerten zu vermeiden.

Wenn die benannte Rückruffunktion die wMsg&-Benachrichtigung empfängt, identifiziert der Parameter wParam& das Betriebssystem-Handle des Sockets (siehe FILEATTR ), das niederwertige Wort von lParam& gibt den Code des Ereignisses an (siehe Tabelle unten) und das höherwertige Wort von lParam& enthält den Fehlercode (falls vorhanden).

LO(WORD, lParam& )

Definition

%FD_READ

Daten stehen zum Lesen aus dem Socket zur Verfügung.

%FD_WRITE

Der Socket ist zum Schreiben von Daten bereit.

%FD_ACCEPT

Der Socket ist in der Lage, eine neue Verbindung anzunehmen.

%FD_CONNECT

Die Verbindung wurde hergestellt.

%FD_CLOSE

Der Socket wurde geschlossen.

Benachrichtigungsnachrichten kommen nicht in unverminderten oder kontinuierlichen Strömen an. Das heißt, sobald eine bestimmte Benachrichtigungsnachricht eintrifft, wird sie nicht erneut gesendet, bis auf die ursprüngliche Nachricht reagiert wird. Wenn beispielsweise eine %FD_READ-Benachrichtigung empfangen wird, wird sie erst erneut gesendet, nachdem eine TCP-RECV-Anweisung ausgeführt wurde.

Die Winsock-Fehlercodes werden in WINSOCK2.INC mit dem Präfix %WSAE aufgeführt.

Siehe auch

  • TCP- und UDP-Kommunikation
  • TCP AKZEPTIEREN
  • TCP CLOSE
  • TCP-LEITUNGSEINGANG
  • TCP OFFEN
  • TCP-DRUCK
  • TCP RECV
  • TCP SENDEN
  • UDP-BENACHRICHTIGUNG

Kommunikationsprüfung

Serielle, TCP- und UDP-Seiten sollen Endpoint-Aufbau, Blocking-Verhalten, Timeout-Verhalten, Pufferbesitz und Cleanup nennen. Ein vollständiges Beispiel deckt Open/Create, Senden oder Empfangen, Close und einen vorhersagbaren Fehler wie einen ungültigen Endpoint ab.

Laufzeitvoraussetzungen

Netzwerkbeispiele können Firewall-Berechtigungen und freie Ports benötigen. Serielle Beispiele erfordern ein vorhandenes COM-Gerät oder einen dokumentierten Loopback/Testadapter.

Diagnosen

Erfassen Sie Rückgabewerte und Windows-Fehlercodes, wo verfügbar, damit Kommunikationsfehler auswertbar statt still sind.

Umfangshinweise

Wenn die Seite eine Familie statt eines einzelnen Befehls beschreibt, nennen Sie das konkrete Senden, Empfangen, Prüfen, Verbinden oder Schließen, das das Verhalten belegt, und sagen Sie, ob derselbe Socket oder Handle nach dem Aufruf weiterverwendet werden darf. Dadurch wird die Seite zu einem nutzbaren Laufzeitvertrag statt zu einem allgemeinen Protokollhinweis.


TCP OPEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › TCP OPEN

TCP OFFEN

Ermöglichen Sie einer Anwendung die Kommunikation mit a

Typ:Anweisung |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

TCP OPEN {PORT p& | srvc$ } AT address$ AS [#] fNum& [TIMEOUT timeoutval& ]
TCP OPEN SERVER [ADDR ip& ] {PORT p& | srvc$ } AS [#] fNum& [TIMEOUT timeoutval& ]

Beschreibung

Öffnen Sie einen TCP/IP-Port oder -Dienst für die Kommunikation, entweder als Client oder als Server.

SERVER

Wenn der Schlüsselwortserver enthalten ist, wird der TCP-Port als TCP/IP-Server geöffnet; andernfalls wird es als TCP/IP-Client geöffnet.

ADDR-IP&

Wenn Sie als Server das optionale ADDR ip& angeben, überwacht der TCP-Server Verbindungen an der angegebenen IP&-Adresse. Andernfalls wird standardmäßig die primäre IP-Adresse des Computers verwendet.

Hafenp&

Als Client identifiziert PORT den Server-Port, mit dem der Client versucht, eine Verbindung herzustellen. Als Server gibt PORT den Port an, den der Server auf Verbindungsanfragen überwacht. Sie können entweder eine Portnummer oder einen Dienstnamen angeben, jedoch nicht beides.

Wenn die Portnummer nicht angegeben ist, muss stattdessen ein Dienstname angegeben werden. Ein Dienstname hat die Form „http“, „smtp“ oder „ftp“ usw. Sie können entweder eine Portnummer oder einen Dienstnamen angeben, jedoch nicht beides.

AT-Adresse$

Als Client identifiziert Adresse $ die Adresse, mit der eine Verbindung hergestellt werden soll. Adresse $ kann eine Domäne wie „powerbasic.com“ oder eine gepunktete IP-Adresse in Zeichenfolgenform wie „127.0.0.1“ sein.

Eine Dateinummer wie z. B. #1 oder eine Variable mit einem Wert, der mit der FREEFILE-Funktion erhalten wurde.

AUSZEIT

Mit dem optionalen TIMEOUT-Wert können Sie in Millisekunden (mSek) angeben, wie lange ein TCP-Vorgang vom Typ SEND, RECV, PRINT oder LINE auf den Abschluss warten soll. Wenn die angegebene Anzahl von Millisekunden ohne Antwort verstreicht, schlägt der TCP-Vorgang fehl und die Systemvariable ERR wird so gesetzt, dass sie einen Laufzeitfehler 24 („Geräte-Timeout“) anzeigt. Das Standard-Timeout beträgt 60.000 Millisekunden (60 Sekunden).

Siehe auch

  • TCP- und UDP-Kommunikation
  • FREEFILE
  • TCP AKZEPTIEREN
  • TCP CLOSE
  • TCP-LEITUNGSEINGANG
  • TCP-BENACHRICHTIGUNG
  • TCP-DRUCK
  • TCP RECV
  • TCP SENDEN
  • UDP OFFEN

Kommunikationsprüfung

Serielle, TCP- und UDP-Seiten sollen Endpoint-Aufbau, Blocking-Verhalten, Timeout-Verhalten, Pufferbesitz und Cleanup nennen. Ein vollständiges Beispiel deckt Open/Create, Senden oder Empfangen, Close und einen vorhersagbaren Fehler wie einen ungültigen Endpoint ab.

Laufzeitvoraussetzungen

Netzwerkbeispiele können Firewall-Berechtigungen und freie Ports benötigen. Serielle Beispiele erfordern ein vorhandenes COM-Gerät oder einen dokumentierten Loopback/Testadapter.

Diagnosen

Erfassen Sie Rückgabewerte und Windows-Fehlercodes, wo verfügbar, damit Kommunikationsfehler auswertbar statt still sind.

Umfangshinweise

Wenn die Seite eine Familie statt eines einzelnen Befehls beschreibt, nennen Sie das konkrete Senden, Empfangen, Prüfen, Verbinden oder Schließen, das das Verhalten belegt, und sagen Sie, ob derselbe Socket oder Handle nach dem Aufruf weiterverwendet werden darf. Dadurch wird die Seite zu einem nutzbaren Laufzeitvertrag statt zu einem allgemeinen Protokollhinweis.


TCP PRINT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › TCP-DRUCK

TCP-DRUCK

Schreiben Sie eine Zeichenfolge an einen Nominierten

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

TCP PRINT [#] fNum& , string_expression [;]

Beschreibung

Schreiben Sie die Daten in string_expression in den fNum& TCP/IP-Port. Wenn das optionale Semikolon nicht angegeben ist, wird auch ein Wagenrücklauf- und Zeilenvorschubpaar ( $CRLF oder CHR$ (13,10)) gesendet.

Die TCP-PRINT-Anweisung kehrt erst zurück, wenn string_expression gesendet wurde oder ein Fehler auftritt. Das heißt, TCP PRINT ist eine synchrone oder „blockierende“ Anweisung. Wenn eine Zeitüberschreitung auftritt, wird ERR so eingestellt, dass ein Laufzeitfehler 24 („Geräte-Zeitüberschreitung“) angezeigt wird. Informationen zum Festlegen des TCP-Socket-Timeout-Werts finden Sie unter TCP OPEN.

Siehe auch

  • TCP- und UDP-Kommunikation
  • TCP AKZEPTIEREN
  • TCP CLOSE
  • TCP-LEITUNGSEINGANG
  • TCP-BENACHRICHTIGUNG
  • TCP OFFEN
  • TCP RECV
  • TCP SENDEN
  • UDP OFFEN

Kommunikationsprüfung

Serielle, TCP- und UDP-Seiten sollen Endpoint-Aufbau, Blocking-Verhalten, Timeout-Verhalten, Pufferbesitz und Cleanup nennen. Ein vollständiges Beispiel deckt Open/Create, Senden oder Empfangen, Close und einen vorhersagbaren Fehler wie einen ungültigen Endpoint ab.

Laufzeitvoraussetzungen

Netzwerkbeispiele können Firewall-Berechtigungen und freie Ports benötigen. Serielle Beispiele erfordern ein vorhandenes COM-Gerät oder einen dokumentierten Loopback/Testadapter.

Diagnosen

Erfassen Sie Rückgabewerte und Windows-Fehlercodes, wo verfügbar, damit Kommunikationsfehler auswertbar statt still sind.

Umfangshinweise

Wenn die Seite eine Familie statt eines einzelnen Befehls beschreibt, nennen Sie das konkrete Senden, Empfangen, Prüfen, Verbinden oder Schließen, das das Verhalten belegt, und sagen Sie, ob derselbe Socket oder Handle nach dem Aufruf weiterverwendet werden darf. Dadurch wird die Seite zu einem nutzbaren Laufzeitvertrag statt zu einem allgemeinen Protokollhinweis.


TCP RECV – PBXB64-Compiler-Hilfe

Startseite › Funktionen › TCP RECV

TCP RECV

Empfangen Sie Daten von einem angegebenen

Typ:Anweisung |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

TCP RECV [#] fNum& , count& , Buffer$

Beschreibung

Empfangen Sie count& Bytes vom fNum& TCP/IP-Port und platzieren Sie sie in Buffer$ . Wenn count& Bytes nicht verfügbar sind, empfängt Buffer$ alle verfügbaren Bytes und EOF ( fNum& ) gibt TRUE (ungleich Null) zurück.

Eine TCP-RECV-Schleife wird normalerweise in einer Schleife zum Abrufen eines Datenstroms verwendet und sollte beendet werden, wenn Buffer$ einen leeren Wert zurückgibt, wenn EOF(fNum&) TRUE zurückgibt oder wenn ERR gesetzt wird. Wenn eine Zeitüberschreitung auftritt, wird ERR so eingestellt, dass ein Laufzeitfehler 24 („Geräte-Zeitüberschreitung“) angezeigt wird. Informationen zum Festlegen des TCP-Socket-Timeout-Werts finden Sie unter TCP OPEN.

Siehe auch

  • TCP- und UDP-Kommunikation
  • EOF
  • TCP AKZEPTIEREN
  • TCP CLOSE
  • TCP-LEITUNGSEINGANG
  • TCP-BENACHRICHTIGUNG
  • TCP OFFEN
  • TCP-DRUCK
  • TCP SENDEN
  • UDP RECV

Kommunikationsprüfung

Serielle, TCP- und UDP-Seiten sollen Endpoint-Aufbau, Blocking-Verhalten, Timeout-Verhalten, Pufferbesitz und Cleanup nennen. Ein vollständiges Beispiel deckt Open/Create, Senden oder Empfangen, Close und einen vorhersagbaren Fehler wie einen ungültigen Endpoint ab.

Laufzeitvoraussetzungen

Netzwerkbeispiele können Firewall-Berechtigungen und freie Ports benötigen. Serielle Beispiele erfordern ein vorhandenes COM-Gerät oder einen dokumentierten Loopback/Testadapter.

Diagnosen

Erfassen Sie Rückgabewerte und Windows-Fehlercodes, wo verfügbar, damit Kommunikationsfehler auswertbar statt still sind.

Umfangshinweise

Wenn die Seite eine Familie statt eines einzelnen Befehls beschreibt, nennen Sie das konkrete Senden, Empfangen, Prüfen, Verbinden oder Schließen, das das Verhalten belegt, und sagen Sie, ob derselbe Socket oder Handle nach dem Aufruf weiterverwendet werden darf. Dadurch wird die Seite zu einem nutzbaren Laufzeitvertrag statt zu einem allgemeinen Protokollhinweis.


TCP SEND – PBXB64-Compiler-Hilfe

Startseite › Funktionen › TCP SEND

TCP SENDEN

Schreiben Sie eine Zeichenfolge an einen Nominierten

Typ:Anweisung |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

TCP SEND [#] fNum& , string_expression

Beschreibung

Schreiben Sie den angegebenen string_expression in den durch fNum& angegebenen TCP/IP-Port.

Die TCP-SEND-Anweisung kehrt erst zurück, wenn string_expression gesendet wurde oder ein Fehler auftritt. Das heißt, TCP SEND ist eine synchrone oder „blockierende“ Anweisung. Wenn eine Zeitüberschreitung auftritt, wird ERR so eingestellt, dass ein Laufzeitfehler 24 („Geräte-Zeitüberschreitung“) angezeigt wird. Informationen zum Festlegen des TCP-Socket-Timeout-Werts finden Sie unter TCP OPEN.

Siehe auch

  • TCP- und UDP-Kommunikation
  • TCP AKZEPTIEREN
  • TCP CLOSE
  • TCP-LEITUNGSEINGANG
  • TCP-BENACHRICHTIGUNG
  • TCP OFFEN
  • TCP-DRUCK
  • TCP RECV
  • UDP SENDEN

Kommunikationsprüfung

Serielle, TCP- und UDP-Seiten sollen Endpoint-Aufbau, Blocking-Verhalten, Timeout-Verhalten, Pufferbesitz und Cleanup nennen. Ein vollständiges Beispiel deckt Open/Create, Senden oder Empfangen, Close und einen vorhersagbaren Fehler wie einen ungültigen Endpoint ab.

Laufzeitvoraussetzungen

Netzwerkbeispiele können Firewall-Berechtigungen und freie Ports benötigen. Serielle Beispiele erfordern ein vorhandenes COM-Gerät oder einen dokumentierten Loopback/Testadapter.

Diagnosen

Erfassen Sie Rückgabewerte und Windows-Fehlercodes, wo verfügbar, damit Kommunikationsfehler auswertbar statt still sind.

Umfangshinweise

Wenn die Seite eine Familie statt eines einzelnen Befehls beschreibt, nennen Sie das konkrete Senden, Empfangen, Prüfen, Verbinden oder Schließen, das das Verhalten belegt, und sagen Sie, ob derselbe Socket oder Handle nach dem Aufruf weiterverwendet werden darf. Dadurch wird die Seite zu einem nutzbaren Laufzeitvertrag statt zu einem allgemeinen Protokollhinweis.


Textbefehle – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Textbefehle

Textbefehle

Die folgenden Befehle können mit einem Textfenster verwendet werden:

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Legt die Cursorposition fest oder ruft sie ab.

Löscht das Textfenster und bewegt sich zur Einfügemarke in die obere linke Ecke.

Beschreibung

Textbefehle gehoert zur Kategorie General. Diese Seite beschreibt den PBXB64-Dokumentationsstand fuer diesen Eintrag; verwenden Sie die Grenzen und Belege auf dieser Seite statt historischer PBWin-Annahmen.

Syntax

' Siehe den urspruenglichen Eintrag und die verlinkten Beispiel-/Testdateien fuer die genaue PBXB64-Form von Textbefehle.
' Nicht belegte Unterformen bleiben ausserhalb der zertifizierten Oberflaeche.

Praktische Verwendung

Textbefehle gehoert zur Kategorie General. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Textbefehle mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Siehe auch

  • Befehlsindex
  • BASIC-Frontend


Der Inline-Assembler – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Der Inline-Assembler

Der Inline-Assembler

Gelegentlich kann es vorkommen, dass die Syntax und Struktur der BASIC-Sprache für die jeweilige Aufgabe nicht optimal geeignet ist. PowerBASIC geht auf den Bedarf nach optimaler Geschwindigkeit und Flexibilität ein

Typ:Schlüsselwort |Kategorie:Inline-Assembler

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

In diesem Kapitel werden die verschiedenen Möglichkeiten erläutert, mit denen Sie mit PowerBASIC Assembler-Code in Ihren BASIC-Programmen verwenden können. Außerdem werden einige Designphilosophien und Überlegungen besprochen, die Sie berücksichtigen sollten, wenn Sie sich entscheiden, Ihre eigenen Prozeduren oder Funktionen in Assemblersprache zu schreiben.

Die Technik der Schnittstelle zur Assemblersprache ist naturgemäß etwas komplex. Sie sollten mit den Konzepten der Assemblersprache einigermaßen vertraut sein, bevor Sie sich mit den Informationen in diesem Kapitel befassen.

Verwenden Sie Assemblersprache in Ihrem Code

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Der Inline-Assembler soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Der Inline-Assembler mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Der Stack – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Der Stapel

Der Stapel

Der Stapel ist ein Bereich von Speicheradressen, der zur temporären Speicherung von Daten entweder innerhalb einer Prozedur oder als normale Methode zur Übergabe von Parametern an eine Prozedur verwendet werden kann.

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Der Zugriff auf den Stack erfolgt im Code normalerweise über die Mnemoniken PUSH und POP. Der Zugriff auf den Stapel erfolgt nach dem Last-on-first-off-Prinzip, was bedeutet, dass der zuletzt auf den Stapel gelegte Wert auch der erste ist, der wieder vom Stapel entfernt wird.

Die nächste Position, die auf dem Stapel beschrieben werden kann, wird als oberste Position des Stapels bezeichnet. Wenn ein Datenelement auf den Stapel verschoben wird, dekrementiert der Prozessor den Stapelzeiger ESP und schreibt die Daten dann an die Oberseite des Stapels. Wenn ein Datenelement wieder vom Stapel entfernt wird, liest der Prozessor die Daten oben im Stapel und erhöht dann den Stapelzeiger. Daher verringert sich die Stapeladresse, wenn mehr Daten darauf verschoben werden, und die Adresse erhöht sich, wenn Daten wieder vom Stapel entfernt werden.

In den folgenden Bildern stellt jedes Quadrat 1 Byte auf dem Stapel dar, und die verschiedenen Farben sollen die unterschiedlichen Datengrößen veranschaulichen, die gepusht und gepoppt werden. Die oberste Seite des Stapels ist die linke Seite jedes Bildes.

Die folgende Sequenz veranschaulicht das Stapellayout, während ein 32-Bit- und zwei 16-Bit-Werte aus dem Stapel verschoben und entnommen werden.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Der Stapel soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Der Stapel mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


THEN - PBXB64-Compiler-Hilfe

Startseite › Funktionen › THEN

THEN

Trennt die Bedingung vom Körper in IF und ELSEIF

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

IF condition THEN [single_statement]
IF condition THEN
  [statements]
END IF

ELSEIF condition THEN
  [statements]

Beschreibung

DerTHEN Das Schlüsselwort beendet den Bedingungsausdruck in einem IFoderELSEIF Anweisung. In einzeiliger Form folgt die Anweisung, die ausgeführt werden soll, wenn die Bedingung wahr ist. In Blockform folgen eine oder mehrere Anweisungen, die mit enden END IF.

Beispiel

FUNCTION PBMAIN () AS LONG
    LOCAL x AS LONG
    x = 10
    IF x > 5 THEN FUNCTION = 1 ELSE FUNCTION = 0
END FUNCTION

Siehe auch

  • IF
  • ELSEIF
  • Sonst
  • Kontrollflussreferenz

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Thread schließen – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › FADEN CLOSE

FADEN CLOSE

Lassen Sie den Griff eines laufenden Threads los.

Typ:Anweisung |Kategorie: Einfädeln

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

THREAD CLOSE hThread TO lResult&

Beschreibung

THREAD CLOSE gibt das Thread-Handle des Threads frei, der durch den DWORD-Wert hThread identifiziert wird (siehe THREAD CREATE ).

Bei Erfolg ist lResult& TRUE (ungleich Null); andernfalls ist es FALSE (Null). Wenn ein Thread nach Abschluss nicht geschlossen wird, belegt er weiterhin Speicher und CPU-Ressourcen. Beachten Sie, dass THREAD CLOSE einen Thread nicht stoppt, wenn er noch läuft; Es gibt einfach das Handle des Threads frei (d. h. die Ressourcen, die zum Verfolgen des Threads verwendet werden) und der Thread selbst wird weiter ausgeführt.

Sobald ein Thread-Handle freigegeben wird, wird der in hThread gespeicherte Wert undefiniert. Auf dieser Grundlage sollten Thread-Handles erst dann freigegeben werden, wenn kein weiterer Bedarf mehr besteht, den Thread-Status zu testen oder den Suspend-Zähler für einen Thread zu ändern. Wenn ein Thread nicht überwacht werden muss, kann sein Handle sofort nach der THREAD CREATE-Anweisung freigegeben werden, und die Thread-Ressourcen werden automatisch freigegeben, wenn der Thread auf natürliche Weise beendet wird. Best Practice schlägt vor, dass nach der Freigabe eines Thread-Handles die Thread-Handle-Variable auf 0 gesetzt werden sollte, um sie von anderen gültigen Thread-Handle-Variablen zu unterscheiden.

Sobald ein Thread beendet wurde, ist es nicht möglich, denselben Thread neu zu starten (wie durch hThread gekennzeichnet). Es kann jedoch ein neuer Thread mit derselben Ziel-Thread-Funktion ausgeführt werden, was zu einem neuen Thread-Handle führt, das den neuen Thread identifiziert.

Einschränkungen

THREAD CLOSE wird immer erfolgreich ausgeführt, sofern hThread einen gültigen Thread-Handle-Wert enthält. THREAD CLOSE erzeugt keine Laufzeitfehler; Alle Ausnahmen werden im Rückgabewert lResult& gemeldet.

Mit der WaitForSingleObject-API-Funktion kann gewartet werden, bis die Ausführung eines nominierten Threads abgeschlossen ist. Ebenso kann die WaitForMultipleObjects-API verwendet werden, um zu warten, bis ein, zwei oder alle sekundären Threads (maximal 64 oder %MAXIMUM_WAIT_OBJECTS) abgeschlossen sind, bevor fortgefahren wird. Solche Funktionen können sehr nützlich sein, wenn ein Programm eine Reihe von „Worker“-Threads zur Datenverarbeitung erstellt und der primäre Thread dann im Leerlauf bleiben kann, bis alle Worker-Threads ihre gesamte Arbeit abgeschlossen haben. An diesem Punkt kann der primäre Thread die Ergebnisse der Arbeitsthreads usw. sammeln.

Es ist auch nützlich zu verstehen, dass diese Art von Wartefunktionen sehr effizient sind und während des Wartens fast keine CPU-Zeit oder Ressourcen verbrauchen. Es muss jedoch darauf geachtet werden, einen Stillstand oder eine kreisförmige Aussetzung zu vermeiden. Beispielsweise könnte ein Deadlock-Zustand auftreten, wenn Thread A angehalten wird, während er auf Thread B wartet, der wiederum einen Suspend-Zähler hat, der möglicherweise nur von Thread A angepasst werden kann. Ebenso kann eine Endlosschleife in einem Thread auch jeden anderen Thread anhalten, der auf seine Beendigung wartet.

THREADCOUNT meldet weiterhin eine Thread-Liste, die Threads umfasst, deren Handle bereits freigegeben wurde. Ein Thread-ID-Wert darf nicht austauschbar mit einem Thread-Handle-Wert verwendet werden.

PBXB64-Beispiel

Das folgende Programm wurde mit PBXB64 getestet und kompiliert:

' PBXB64 Test: THREAD CLOSE without result
' Tests releasing a thread handle without retrieving result

#COMPILE EXE
#DIM ALL

THREAD FUNCTION Worker(BYVAL param AS LONG) AS LONG
    FUNCTION = param * 4
END FUNCTION

FUNCTION PBMAIN() AS LONG
    LOCAL hThread AS DWORD

    THREAD CREATE Worker(5) TO hThread

    ' Just close without TO
    THREAD CLOSE hThread

    FUNCTION = 0
END FUNCTION

Siehe auch

  • FUNCTION/END FUNCTION
  • THREAD-Codegruppe
  • THREAD CREATE
  • THREAD-Objekt
  • Thread-Lebenslauf
  • Thread-Status
  • FADEN AUFHÄNGEN
  • FADENZAHL
  • GEWINDE
  • Thread-ID
  • XTHREAD ERSTELLEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


THREAD-Codegruppe – PBXB64-Compiler-Hilfe

Startseite › Funktionen › THREAD-Codegruppe

THREAD-Codegruppe

Der Thread

Typ:Schlüsselwort |Kategorie: Einfädeln

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

THREAD DirectorWord [ params ]
THREAD DirectorWord [ params ] TO ReturnVariable(s)

Beschreibung

Ein Windows-Thread ist ein kleineres „Programm innerhalb eines Programms“, das gleichzeitig mit dem Haupt-Thread und anderen Threads im selben Anwendungsprogramm ausgeführt wird. Threads bieten einer Anwendung leistungsstarke Möglichkeiten, mehrere Aufgaben gleichzeitig auszuführen.

Mit dem Aufkommen von Multi-Core-CPUs und Multi-CPU-Computern ist es eindeutig wünschenswert, alle Informationen über einen bestimmten Thread in einer einzigen Komponente zu kapseln. Aus diesem Grund hat PowerBASIC das Konzept eines THREAD OBJECT eingeführt. Während die THREAD-Codegruppe noch einige Zeit unterstützt wird, empfehlen wir, dass jeder neue Code ausschließlich THREAD-OBJEKTE verwendet. Sie bieten dem Programmierer eine viel größere Kontrolle und eine viel bessere Handhabung der Thread-Parameter.

Einschränkungen

Funktionen aus der Thread-Code-Gruppe und THREAD-OBJEKTEN können in derselben Anwendung koexistieren. Es ist jedoch wichtig, dass sie nicht vermischt werden und auf denselben Thread verweisen.

Praktische Verwendung

THREAD-Codegruppe gehoert zur Kategorie General. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' THREAD-Codegruppe mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Siehe auch

  • FUNCTION/END FUNCTION
  • FADEN CLOSE
  • THREAD CREATE
  • Thread erhält Priorität
  • THREAD-Objekt
  • Thread-Lebenslauf
  • Thread-Status
  • FADEN AUFHÄNGEN
  • FADENZAHL
  • GEWINDE
  • Thread-ID
  • THREADSAFE-Optionsdeskriptor
  • XTHREAD ERSTELLEN


Thread-Kontrolle – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Fadenkontrolle

Thread-Kontrolle

Die folgenden Funktionen werden zum Erstellen und Verwalten von Threads verwendet:

Typ:Schlüsselwort |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Gibt das Thread-Handle dieses Threads frei.

Vergleicht das angegebene Objekt, um festzustellen, ob es auf dasselbe Objekt wie dieses Objekt verweist.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


THREAD CREATE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › THREAD CREATE

THREAD CREATE

Erstellen Sie einen Windows-Thread, bei dem es sich um ein kleineres „Programm im Programm“ handelt, das gleichzeitig mit dem Haupt-Thread und anderen Threads im selben Anwendungsprogramm ausgeführt wird. Threads bieten einer Anwendung leistungsstarke Möglichkeiten, mehrere Aufgaben gleichzeitig auszuführen.

Typ:Anweisung |Kategorie: Einfädeln

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

THREAD CREATE FuncName ( param ) [ StackSize ,] [SUSPEND] TO hThread

Beschreibung

THREAD CREATE erstellt und beginnt mit der Ausführung einer neuen Thread-Funktion, die durch FuncName identifiziert wird. FuncName wird ohne Anführungszeichen angegeben. Diese Funktion muss genau einen Long-Integer- oder Double-Word-Parameter (DWORD) als Wert ( BYVAL ) annehmen. Zum Beispiel:

THREAD-FUNCTION MyThreadFunction(BYVAL x AS LONG) AS LONG

' Thread-Code steht hier

ENDFUNKTION

' Mehr Code hier

THREAD CREATE MyThreadFunction(var&) TO hThread???

Der an den Thread übergebene 32-Bit-Parameter kann verwendet werden, um einen Wert wie eine vom Programmierer definierte ID oder ein Fensterhandle zu übergeben, um „Fortschritts“-Meldungen zurück an ein GUI-Fenster/Dialogfeld zu senden, das in einem anderen Thread ausgeführt wird. Eine häufigere Verwendung des Parameters besteht darin, die Adresse an einen UDT oder eine andere Datenstruktur zu übergeben. Durch die Übergabe einer Adresse auf diese Weise kann der Thread mithilfe eines Zeigers auf große Datenmengen zugreifen, die sich außerhalb des Threads befinden. Zum Beispiel:

THREAD-FUNCTION MyThread(BYVAL y AS DWORD) AS DWORD

DIM x AS MyUDT POINTER

x = y ' Setzt den Zeiger aus dem DWORD-Parameter

' Von hier aus können wir auf alle UDT-Mitgliedselemente zugreifen

' unter Verwendung der standardmäßigen @x-Zeigersyntax

ENDFUNKTION

' Mehr Code hier

DIM x AS MyUDT, hThread???

' Initialisieren Sie hier die Mitglieder von x

THREAD CREATE MyThread( VARPTR(x) ) TO hThread???

' Mehr Code hier

Beachten Sie, dass auf diese Weise übergebene Daten den Hinweisen (unten) zu GLOBAL- und STATIC-Variablen unterliegen, um Synchronisierungsprobleme beim Kontextwechsel zu vermeiden.

Der Rückgabewert der Thread-Funktion wird mit der THREAD STATUS-Anweisung abgerufen (sobald der Thread die Ausführung abgeschlossen hat).

StackSize

Ein langer ganzzahliger Ausdruck, um die angeforderte Größe des Stapels für diesen neu erstellten Thread anzugeben. Dieser Wert sollte immer in Schritten von 64 KB (65536) angegeben werden. Wenn dieser Parameter weggelassen wird, wird die Größe des Stapels für den Hauptthread verwendet.

AUSSETZEN

Die Ausführung des Threads beginnt sofort, es sei denn, die Option SUSPEND ist enthalten. In diesem Fall wird der Suspend-Zähler für den Thread zunächst auf 1 gesetzt und der Thread wird zunächst angehalten. Die THREAD RESUME-Anweisung wird verwendet, um den Suspend-Zähler eines Threads um 1 zu verringern. Wenn der Suspend-Zähler 0 erreicht, beginnt der Thread mit der Ausführung (setzt sie fort). Um den Suspend-Status eines Threads zu steuern, muss der Thread-Handle-Wert so lange beibehalten werden, bis der Thread geschlossen oder unüberwacht ausgeführt werden kann.

hThread

Bei Erfolg gibt THREAD CREATE ein Doppelwort-Handle (oder eine lange Ganzzahl) in hThread zurück oder Null (0), wenn der Thread nicht gestartet wurde. Dieses Handle wird zusammen mit den anderen Thread-Anweisungen verwendet, um den Suspend-Zähler zu steuern und das Thread-Handle freizugeben usw. Weitere Informationen zum Überwachen, Schließen und Warten auf den Abschluss von Threads finden Sie auch unter THREAD CLOSE.

Funktionsname

Der Name der Thread-Funktion, die als Thread ausgeführt werden soll. Eine Thread-Funktion muss genau der folgenden Syntax entsprechen:

THREAD-FUNCTION ThreadFuncName (BYVAL param AS {LONG | DWORD}) AS {LONG | DWORD}

Einschränkungen

Die THREAD CREATE-Anweisung erzeugt keine Laufzeitfehler; Alle Ausnahmen werden als Null gemeldet, die im Rückgabewert hThread gespeichert ist. Allerdings muss sich die Ziel-Thread-Funktion im selben kompilierten Modul befinden wie die THREAD CREATE-Anweisung. Das heißt, eine Thread-Funktion ist möglicherweise keine importierte Funktion.

Darüber hinaus darf eine Thread-Funktion nicht direkt aufgerufen oder ausgeführt werden, außer durch eine THREAD CREATE-Anweisung. Diese Einschränkung wird auferlegt, um sicherzustellen, dass die PowerBASIC-Laufzeitbibliothek jederzeit einen Thread-sicheren Zustand beibehalten, internen Thread-lokalen Speicher korrekt zuweisen und freigeben kann und die verschiedenen Thread-Funktionen (z. B. THREADCOUNT) genaue Werte zurückgeben können.

Es kann vorkommen, dass eine Funktion sowohl direkt aufgerufen als auch als Thread-Funktion verwendet werden muss. Die einfachste Lösung besteht darin, eine kleine Wrapper-Funktion für die Funktion zu erstellen und dann THREAD CREATE mit der Wrapper-Funktion zu verwenden, wenn ein Thread erforderlich ist, oder die ursprüngliche Funktion direkt weiter aufzurufen, wenn kein separater Thread erforderlich ist. Zum Beispiel:

FUNCTION WorkerFunc(BYVAL x AS LONG) AS LONG

' Code hier

ENDFUNKTION

THREAD-FUNCTION WorkerThread(BYVAL x AS LONG) AS LONG

FUNCTION = WorkerFunc(x)

ENDFUNKTION

' Mehr Code hier

' Führen Sie die Worker-Funktion direkt aus, also:

lResult& = WorkerFunc(var&)

' Führen Sie den Arbeitsthread als Thread aus, mit

' die Wrapper-Funktion:

THREAD CREATE WorkerThread(var&) TO hThread???

Mit der Funktion THREADID kann ein Thread seine eigene ID ermitteln. Hinweis: Eine Thread-ID ist nicht mit einem Thread-Handle austauschbar.

Threads werden asynchron initialisiert und gestartet. Daher ist es ratsam, dem Betriebssystem etwas Zeit für die Thread-Initialisierung zu geben, bevor Sie die Funktion THREADCOUNT zum Überwachen des Threads verwenden.

Sobald ein Thread beendet wurde, ist es nicht möglich, denselben Thread, der von hThread identifiziert wurde, neu zu starten. Es kann jedoch ein neuer Thread mit derselben Funktion initiiert werden (die natürlich einen neuen hThread-Handle-Wert bereitstellt). Darüber hinaus kann dieselbe Thread-Funktion mehrmals gestartet werden, um eine Reihe identischer Threads zu erstellen, die denselben Code ausführen.

Beim Erstellen jedes Threads wird ihm ein eigener „privater“ Stapelrahmen zugewiesen. Daher sind LOCAL- und REGISTER-Variablen für jeden Thread privat und automatisch „threadsicher“.

Seien Sie vorsichtig, wenn Sie GLOBAL- und STATIC-Variablen verwenden, auf die möglicherweise mehrere Threads gleichzeitig zugreifen. Wenn ein Thread gerade dabei ist, Daten zu speichern, während ein anderer Thread mit dem Lesen desselben Speicherblocks beginnt, kann dies dazu führen, dass der zweite Thread nur teilweise aktualisierte (d. h. ungültige) Daten liest. Der Punkt, an dem ein Thread angehalten wird, damit ein anderer ausgeführt werden kann, wird als „Kontextwechsel“ bezeichnet. In diesen Situationen kann die Verwendung der Synchronisierungsfunktionen von Windows (z. B. kritische Abschnitte und Mutexe) verwendet werden, um threadsicheren Code zu erstellen.

Es wird davon ausgegangen, dass Thread-sicherer Code vom Kontextwechsel nicht betroffen ist, unabhängig davon, wann der Kontextwechsel stattfindet. Lokale Variablen, die in einem „privaten“ Stapelrahmen gespeichert sind, sind von der Kontextumschaltung nicht betroffen.

Der von jedem Thread erstellte lokale Variablenspeicher wird automatisch freigegeben, wenn die Thread-Funktion beendet wird, auf die gleiche Weise wie bei einem normalen Sub , Function, Method oder Property . Das Thread-Handle muss jedoch explizit mit einer THREAD CLOSE-Anweisung freigegeben werden. Das THREAD CLOSE kann jederzeit erfolgen, da es nur das Thread-Handle freigibt und keine weiteren Auswirkungen auf den laufenden Thread hat. Wenn der Thread-Ergebniswert nicht erforderlich ist (oder der Thread-Status nicht geändert werden muss), kann THREAD CLOSE unmittelbar nach der THREAD CREATE-Anweisung verwendet werden, sodass der Thread seinen Lauf weiterführen kann.

Weitere Informationen zu Threading- und Synchronisierungstechniken finden Sie unter MSDN http://msdn.microsoft.com.

Die PowerBASIC-Laufzeitbibliothek ist threadsicher und reentrant.

PBXB64-Beispiel

Das folgende Programm wurde mit PBXB64 getestet und kompiliert:

' PBXB64 Minimal Test: THREAD CREATE / STATUS / CLOSE
' Exercises basic threading primitives with a simple worker

#COMPILE EXE
#DIM ALL

THREAD FUNCTION Worker(BYVAL param AS LONG) AS LONG
    FUNCTION = param * 2
END FUNCTION

FUNCTION PBMAIN() AS LONG
    LOCAL hThread AS DWORD
    LOCAL status AS LONG
    LOCAL result AS LONG

    ' Create thread with parameter 21
    THREAD CREATE Worker(21) TO hThread

    ' Wait for completion via STATUS
    DO
        THREAD STATUS hThread TO status
    LOOP WHILE status = 0

    ' Retrieve result and close
    THREAD CLOSE hThread TO result

    ' result should be 42 (21 * 2)
    IF result <> 42 THEN
        FUNCTION = 1
    ELSE
        FUNCTION = 0
    END IF
END FUNCTION

Siehe auch

  • FUNCTION/END FUNCTION
  • FADEN CLOSE
  • THREAD-Codegruppe
  • Thread erhält Priorität
  • THREAD-Objekt
  • Thread-Lebenslauf
  • Thread-Status
  • FADEN AUFHÄNGEN
  • FADENZAHL
  • GEWINDE
  • Thread-ID
  • XTHREAD ERSTELLEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


THREAD GET PRIORITY – PBXB64-Compiler-Hilfe

Startseite › Funktionen › THREAD GET PRIORITY

Thread erhält Priorität

Rufen Sie den Prioritätswert für einen Thread ab

Typ:Anweisung |Kategorie: Einfädeln

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

THREAD GET PRIORITY hThread TO lResult&

Beschreibung

THREAD GET PRIORITY ruft den Prioritätswert für den Thread ab, der durch das Thread-Handle ( hThread ) angegeben wird. Das Thread-Handle wird von der THREAD CREATE-Anweisung zum Zeitpunkt der Thread-Erstellung zurückgegeben. Wenn hThread Null (0) ist, wird der Thread angenommen, der gerade ausgeführt wird. Der abgerufene Prioritätswert wird der durch lResult& angegebenen Long- oder Dword-Variablen zugewiesen. Eine Thread-ID kann nicht anstelle eines Thread-Handles verwendet werden.

Der Thread-Prioritätswert ist einer der folgenden:

%THREAD_PRIORITY_IDLE = -15

%THREAD_PRIORITY_LOWEST = -2

%THREAD_PRIORITY_BELOW_NORMAL = -1

%THREAD_PRIORITY_NORMAL = 0

%THREAD_PRIORITY_ABOVE_NORMAL = +1

%THREAD_PRIORITY_HIGHEST = +2

%THREAD_PRIORITY_TIME_CRITICAL= +15

Siehe auch

  • PROZESS ERHALTEN PRIORITÄT
  • PROZESS SETZEN PRIORITÄT
  • THREAD-Codegruppe
  • THREAD CREATE
  • THREAD-Objekt
  • Thread-Set-Priorität
  • XTHREAD ERSTELLEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


IPowerThread.Close-Methode – PBXB64-Compiler-Hilfe

Startseite › Funktionen › IPowerThread.Close-Methode

IPowerThread.Close-Methode

Ein Thread

Typ:Anweisung |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

< ObjectVar >. membername ( params )
RetVal = < ObjectVar >. membername ( params )
< ObjectVar >. membername ( params ) TO ReturnVariable

Beschreibung

Mit dem Aufkommen von Multi-Core-CPUs und Multi-CPU-Computern ist es eindeutig wünschenswert, alle Informationen über einen bestimmten Thread in einer einzigen Komponente zu kapseln. Wir empfehlen, dass der gesamte neue Code ausschließlich THREAD OBJECTS und nicht die Thread-Codegruppe verwendet. Thread-Objekte bieten dem Programmierer eine viel größere Kontrolle und eine viel bessere Handhabung der Thread-Parameter.

IPowerThread-Methoden

The Dispatch ID (DispID) for each member method is displayed within angle brackets.

METHODE CLOSE() <2>

Gibt das Thread-Handle dieses Threads frei. Beachten Sie, dass ein Thread nicht gestoppt wird, wenn er noch läuft. es gibt einfach das Thread-Handle frei (d. h. die Ressourcen, die zum Verfolgen des Threads verwendet werden).

Thread-Handles sollten erst dann freigegeben werden, wenn kein Bedarf mehr besteht, andere Thread-Methoden oder -Eigenschaften zu verwenden. Wenn ein Thread nicht überwacht werden muss, kann sein Handle sofort freigegeben werden. Die Thread-Ressourcen werden automatisch freigegeben, wenn der Thread auf natürliche Weise beendet wird.

THREADCOUNT meldet weiterhin eine Thread-Liste, die Threads umfasst, deren Handle bereits freigegeben wurde. Ein Thread-ID-Wert darf nicht austauschbar mit einem Thread-Handle-Wert verwendet werden.

METHODE EQUALS( ObjectVar AS InterfaceName ) AS Long <3>

Vergleicht den Parameter ObjectVar, um festzustellen, ob er auf dasselbe Objekt wie dieses Objekt verweist. Wenn beide auf dasselbe Objekt verweisen, wird true (-1) zurückgegeben; Wenn nicht, wird false (0) zurückgegeben.

METHODE HANDLE() AS Long <4>

Ruft das Handle des Threads zur Verwendung mit Windows-API-Funktionen ab.

METHOD ID() AS Long <5>

Ruft die ID des Threads zur Verwendung mit Windows-API-Funktionen ab.

METHODE ISALIVE() AS Long <6>

Überprüft den Thread, um festzustellen, ob er derzeit „lebendig“ ist. Wenn der Thread gestartet, aber noch nicht beendet ist, wird der Wert true (-1) zurückgegeben; andernfalls wird der Wert false (0) zurückgegeben.

METHODE JOIN( ThreadObjectVar AS InterfaceName , TimeOutVal AS Long) <7>

Wartet darauf, dass der von ThreadObjectVar referenzierte Thread abgeschlossen ist, bevor die Ausführung dieses Threads fortgesetzt wird. TimeOutVal gibt die maximale Wartezeit in Millisekunden an. Wenn TimeOutVal Null (0) ist, ist die Wartezeit unendlich.

METHOD LAUNCH(ByRef Param as UDT) <8>

LAUNCH beginnt mit der Ausführung des Threads und übergibt ihm Parameterdaten. Da der Thread von einem Objekt gehostet wird, ist es nur passend, dass die Parameterdaten in der robustesten Form, einem anderen Objekt, enthalten sind.

THREADPARAM ist eine obligatorische Instanzvariable, die Sie in jeder Thread-Klasse definieren müssen. Normalerweise wird er als Schnittstellenname Ihrer Wahl deklariert:

INSTANCE ThreadParam als MyInterface

Wenn der Thread beginnt, erstellt PowerBASIC automatisch eine Kopie des LAUNCH-Parameters und weist ihn ThreadParam zu. Da es in einer Instanzvariablen gespeichert wird, ist es für Ihren gesamten Code in Ihren Mitgliedsmethoden sichtbar, bleibt jedoch vom Rest des Programms geheim. Die Verwendung eines Objekts als Parameter ist normalerweise die beste Wahl, da damit nahezu jede beliebige Anzahl von Datenelementen enthalten sein kann.

In einfacheren Fällen können Sie THREADPARAM als Zeiger, Long Integer oder Dword deklarieren. In diesem Fall müssen Sie den Startparameter mit einer Byval-Option übergeben, um die erwartete Objektvariable zu überschreiben.

INSTANCE ThreadParam als LONG

MyThread.Launch(ByVal MyNumber&)

Natürlich kann die Parameteroption „Pointer“ verwendet werden, um einen Zeiger auf eine beliebige Variable jeden Typs zu übergeben. Es könnte beispielsweise verwendet werden, um einen verwendet definierten Typ zu übergeben, wenn dies Ihren Anforderungen entspricht:

INSTANCE ThreadParam AS MyType POINTER

THREAD-METHODE MyMethod() SO LANG

xyz# = ThreadParam.member1

... anderer Code

ENDMETHODE

MyThread.Launch(ByVal VARPTR(MyType))

PROPERTY GET PRIORITY() AS Long <9>

Ruft den Prioritätswert für diesen Thread ab. Der Thread-Prioritätswert ist einer der folgenden:

%THREAD_PRIORITY_IDLE = -15

%THREAD_PRIORITY_LOWEST = -2

%THREAD_PRIORITY_BELOW_NORMAL = -1

%THREAD_PRIORITY_NORMAL = 0

%THREAD_PRIORITY_ABOVE_NORMAL = +1

%THREAD_PRIORITY_HIGHEST = +2

%THREAD_PRIORITY_TIME_CRITICAL= +15

EIGENSCHAFT SET PRIORITÄT (STUFE WIE LANG) <9>

Legt den Prioritätswert für diesen Thread fest. Der Thread-Prioritätswert muss einer der folgenden sein:

%THREAD_PRIORITY_IDLE = -15

%THREAD_PRIORITY_LOWEST = -2

%THREAD_PRIORITY_BELOW_NORMAL = -1

%THREAD_PRIORITY_NORMAL = 0

%THREAD_PRIORITY_ABOVE_NORMAL = +1

%THREAD_PRIORITY_HIGHEST = +2

%THREAD_PRIORITY_TIME_CRITICAL= +15

METHOD RESULT() AS Long <10>

Wenn der Thread beendet ist, wird der von der THREAD-METHODE zurückgegebene Ergebniswert abgerufen und an den Aufrufer zurückgegeben. Das Ergebnis kann ein beliebiger ganzzahliger Wert im Bereich einer langen Ganzzahl sein. Sie sollten jedoch die Verwendung der Zahl &H103 (dezimal 259) vermeiden, da dies der Wert ist, der von Windows verwendet wird, um anzuzeigen, dass der Thread noch ausgeführt wird.

Wenn das Ergebnis erfolgreich abgerufen wurde, wird OBJRESULT auf %S_OK (0) gesetzt. Wenn der Thread nicht beendet wurde, wird der Wert Null (0) zurückgegeben und das OBJRESULT wird auf %S_FALSE (1) gesetzt.

METHODE RESUME() AS Long <11>

Setzt die Ausführung eines angehaltenen Threads fort. Der Suspend-Zähler des Threads wird dekrementiert. Wenn er Null (0) erreicht, wird die Ausführung des Threads fortgesetzt. Wenn die Wiederaufnahme erfolgreich ist, wird der vorherige Suspend-Zähler zurückgegeben; andernfalls wird -1 zurückgegeben.

Ein Thread kann sich mit SUSPEND selbst anhalten (wodurch sich der Suspend-Zähler erhöht), aber logischerweise kann er sich nicht selbst wieder aufnehmen, da er zu diesem Zeitpunkt nicht ausgeführt wird.

PROPERTY GET STACKSIZE() AS Long <13>

Ruft die Größe des Stapels für diesen Thread ab. Wenn der zurückgegebene Wert Null (0) ist, ist die Thread-StackSize mit der des Haupt-Threads identisch.

PROPERTY SET STACKSIZE(BYVAL Long) <13>

Setzt die Größe des Stapels für diesen Thread auf den durch den Parameter angegebenen Wert. Der Wert sollte immer in Vielfachen von 64K (65536) angegeben werden. PROPERTY SET darf nur vor der Thread-Ausführung mit LAUNCH ausgeführt werden, sonst wird es ignoriert. Wenn kein PROPERTY SET STACKSIZE ausgeführt wird, wird für diesen Thread die Größe des Stacks des Hauptthreads verwendet.

METHODE SUSPEND() AS Long <14>

Unterbricht die Ausführung des Threads. Der Suspend-Zähler des Threads wird erhöht. Wenn die Unterbrechung erfolgreich war, wird der Suspend-Zähler zurückgegeben; andernfalls wird -1 zurückgegeben.

Wenn SUSPEND vor dem LAUNCH des Threads ausgeführt wird, wird der Suspend-Zähler erhöht und der nachfolgende LAUNCH wird als angehaltener Start behandelt. Das heißt, alle erforderlichen Setup-Aufgaben werden ausgeführt, der Thread wird jedoch angehalten, kurz bevor die Ausführung Ihrer THREAD-METHODE beginnt. Mit RESUME können Sie die Ausführung fortsetzen.

Ein Thread kann sich mit SUSPEND selbst anhalten (wodurch sich der Suspend-Zähler erhöht), aber logischerweise kann er sich nicht selbst wieder aufnehmen, da er im angehaltenen Zustand nicht ausgeführt wird.

METHODE TIMECREATE() AS Quad <16>

Ruft das Datum und die Uhrzeit der Thread-Erstellung ab und gibt sie als Quad-Integer-Wert zurück. Das interne Format des Werts ist das einer FILETIME-Struktur, sodass Sie ihn mit dem PowerTime-Objekt in ein für Menschen lesbares Format Monat/Tag/Jahr/Uhrzeit konvertieren können.

METHODE TIMEEXIT() AS Quad <17>

Ruft das Datum und die Uhrzeit des Thread-Exits ab und gibt sie als Quad-Integer-Wert zurück. Das interne Format des Werts ist das einer FILETIME-Struktur, sodass Sie ihn mit dem PowerTime-Objekt in ein für Menschen lesbares Format Monat/Tag/Jahr/Uhrzeit konvertieren können. Wenn der Thread noch nicht beendet wurde, ist der Rückgabewert undefiniert.

METHODE TIMEKERNEL() AS Quad <18>

Ruft die Zeit ab, die dieser Thread im Kernelmodus verbracht hat, und gibt sie als Quad-Integer-Wert zurück. Das interne Format des Werts ist das einer FILETIME-Struktur, sodass Sie ihn mit dem PowerTime-Objekt in ein für Menschen lesbares Format konvertieren können.

METHODE TIMEUSER() AS Quad <19>

Ruft die Zeit ab, die dieser Thread im Benutzermodus verbracht hat, und gibt sie als Quad-Integer-Wert zurück. Das interne Format des Werts ist das einer FILETIME-Struktur, sodass Sie ihn mit dem PowerTime-Objekt in ein für Menschen lesbares Format konvertieren können.

Einschränkungen

Funktionen aus der Thread-Code-Gruppe und THREAD-OBJEKTEN können in derselben Anwendung koexistieren. Es ist jedoch wichtig, dass sie nicht vermischt werden, wenn Sie auf einen bestimmten Thread verweisen.

Siehe auch

  • PowerTime
  • THREAD-Codegruppe

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


Thread-Fortsetzung – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Thread-Fortsetzung

Thread-Lebenslauf

Setzen Sie die Ausführung eines Windows-Threads fort.

Typ:Anweisung |Kategorie: Einfädeln

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

THREAD RESUME hThread TO lResult&

Beschreibung

THREAD RESUME verringert die Suspend-Zählung des Threads, der durch den in hThread gespeicherten 32-Bit-DWORD-Wert identifiziert wird (siehe THREAD CREATE ). Wenn dies erfolgreich ist, ist der lResult&-Wert der vorherige Suspend-Zähler des Threads; andernfalls ist es -1.

Die Ausführung eines angehaltenen Threads wird fortgesetzt, wenn der Suspend-Zähler eines Threads auf Null verringert wird. Wenn die SUSPEND-Option in der zugehörigen THREAD CREATE-Anweisung enthalten ist, hat der Thread einen anfänglichen Suspend-Zähler von 1. In diesem Fall beginnt die Ausführung des Threads erst, wenn eine THREAD RESUME-Anweisung ausgeführt wird, wobei das in hThread gespeicherte Thread-Handle zur Identifizierung des Threads verwendet wird.

Einschränkungen

Die THREAD RESUME-Anweisung erzeugt keine Laufzeitfehler; Alle Ausnahmen werden im Rückgabewert lResult& gemeldet. Eine Thread-ID kann nicht austauschbar mit einem Thread-Handle verwendet werden. Ein Thread kann sich selbst anhalten, indem er seinen eigenen Suspend-Zähler erhöht, aber logischerweise kann er seinen eigenen Suspend-Zähler nicht verringern.

PBXB64-Beispiel

Das folgende Programm wurde mit PBXB64 getestet und kompiliert:

' PBXB64 Test: THREAD SUSPEND / RESUME
' Tests pausing and resuming a thread

#COMPILE EXE
#DIM ALL

THREAD FUNCTION Worker(BYVAL param AS LONG) AS LONG
    SLEEP 100
    FUNCTION = param + 10
END FUNCTION

FUNCTION PBMAIN() AS LONG
    LOCAL hThread AS DWORD
    LOCAL result AS LONG
    LOCAL n AS LONG

    THREAD CREATE Worker(5) TO hThread

    ' Suspend immediately (thread hasn't finished yet)
    THREAD SUSPEND hThread TO n
    IF n = -1 THEN FUNCTION = 1 : EXIT FUNCTION

    ' Resume
    THREAD RESUME hThread TO n
    IF n = -1 THEN FUNCTION = 2 : EXIT FUNCTION

    ' Wait for completion and close
    THREAD CLOSE hThread TO result

    IF result <> 15 THEN
        FUNCTION = 3
    ELSE
        FUNCTION = 0
    END IF
END FUNCTION

Siehe auch

  • FUNCTION/END FUNCTION
  • FADEN CLOSE
  • THREAD-Codegruppe
  • THREAD CREATE
  • THREAD-Objekt
  • Thread-Status
  • FADEN AUFHÄNGEN
  • FADENZAHL
  • GEWINDE
  • Thread-ID
  • XTHREAD ERSTELLEN

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht
← IPowerThread.Close-Methode Nach oben Thread-Set-Priorität →

Prüfung des Thread-Zustands

Testen Sie diesen Befehl mit einem Worker-Thread, der durch THREAD CREATE erzeugt wurde. Das Beispiel soll den Thread-Handle prüfen, Suspend oder Resume anwenden, den Handle schließen und kontrollieren, dass der Rückgabewert des Workers korrekt eingesammelt wird.

Scheduling-Hinweise

Windows-Scheduling ist asynchron. Beispiele sollen nicht von exaktem Timing abhängen; verwenden Sie Statusprüfungen, Events oder kurze Wartezeiten nur als Diagnose. Geben Sie Handles am Ende immer mit THREAD CLOSE frei.


Thread-Set-Priorität – PBXB64-Compiler-Hilfe

Startseite › Funktionen › FADENSET-PRIORITÄT

Thread-Set-Priorität

Legt den Prioritätswert für einen Thread fest

Typ:Anweisung |Kategorie: Einfädeln

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

THREAD SET PRIORITY hThread , Priority&

Beschreibung

THREAD SET PRIORITY weist dem durch das Thread-Handle ( hThread ) angegebenen Thread einen neuen Prioritätswert zu. Das Thread-Handle wird von der THREAD CREATE-Anweisung zum Zeitpunkt der Thread-Erstellung zurückgegeben. Wenn hThread Null (0) ist, wird der Thread angenommen, der gerade ausgeführt wird. Eine Thread-ID kann nicht anstelle eines Thread-Handles verwendet werden.

Der Thread-Prioritätswert muss einer der folgenden sein:

%THREAD_PRIORITY_IDLE = -15

%THREAD_PRIORITY_LOWEST = -2

%THREAD_PRIORITY_BELOW_NORMAL = -1

%THREAD_PRIORITY_NORMAL = 0

%THREAD_PRIORITY_ABOVE_NORMAL = +1

%THREAD_PRIORITY_HIGHEST = +2

%THREAD_PRIORITY_TIME_CRITICAL= +15

PBXB64-Beispiel

Das folgende Programm wurde mit PBXB64 getestet und kompiliert:

' PBXB64 Test: THREAD SET PRIORITY
' Tests setting thread priority

#COMPILE EXE
#DIM ALL

THREAD FUNCTION Worker(BYVAL param AS LONG) AS LONG
    FUNCTION = param * 3
END FUNCTION

FUNCTION PBMAIN() AS LONG
    LOCAL hThread AS DWORD
    LOCAL result AS LONG
    LOCAL ok AS LONG

    THREAD CREATE Worker(7) TO hThread

    ' Set priority to above normal (+1)
    THREAD SET PRIORITY hThread, %THREAD_PRIORITY_ABOVE_NORMAL

    ' Wait and close
    THREAD CLOSE hThread TO result

    IF result <> 21 THEN
        FUNCTION = 1
    ELSE
        FUNCTION = 0
    END IF
END FUNCTION

Praktische Verwendung

Thread-Set-Priorität gehoert zur Kategorie General. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Thread-Set-Priorität mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Siehe auch

  • PROZESS ERHALTEN PRIORITÄT
  • PROZESS SETZEN PRIORITÄT
  • THREAD-Codegruppe
  • THREAD CREATE
  • Thread erhält Priorität
  • THREAD-Objekt
  • XTHREAD ERSTELLEN


THREAD-STATUS – PBXB64-Compiler-Hilfe

Startseite › Funktionen › FADENSTATUS

Thread-Status

Rufen Sie den Status eines Windows-Threads ab.

Typ:Anweisung |Kategorie: Einfädeln

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

THREAD STATUS hThread TO lResult&

Beschreibung

THREAD STATUS weist lResult& den Status des Threads zu, der durch den DWORD-Wert in hThread (siehe THREAD CREATE ) identifiziert wird.

Wenn die Funktion fehlschlägt, wird lResult& auf Null gesetzt. Wenn der Thread noch läuft, wird der Systemwert &H103 zugewiesen. Wenn der Thread beendet wurde und das Thread-Handle noch nicht geschlossen wurde, wird der Rückgabewert der Thread-Funktion lResult& zugewiesen. Um darauf zu warten, dass ein oder mehrere Threads die Ausführung abschließen, verwenden Sie die API-Funktionen WaitForSingleObject oder WaitForMultipleObjects – weitere Informationen finden Sie unter THREAD CLOSE.

Die Anzahl der aktuell laufenden Threads in einem Modul kann mit der Funktion THREADCOUNT ermittelt werden.

Einschränkungen

Die THREAD STATUS-Anweisung erzeugt keine Laufzeitfehler; Alle Ausnahmen werden im Rückgabewert lResult& gemeldet. Eine Thread-ID kann nicht anstelle eines Thread-Handles verwendet werden.

PBXB64-Beispiel

Das folgende Programm wurde mit PBXB64 getestet und kompiliert:

' Thread STATUS test
#COMPILE EXE
#DIM ALL

THREAD FUNCTION Worker(BYVAL param AS LONG) AS LONG
    FUNCTION = param * 2
END FUNCTION

FUNCTION PBMAIN() AS LONG
    LOCAL hThread AS DWORD
    LOCAL status AS LONG
    LOCAL result AS LONG

    THREAD CREATE Worker(21) TO hThread

    DO
        THREAD STATUS hThread TO status
    LOOP WHILE status = 0

    THREAD CLOSE hThread TO result

    IF result <> 42 THEN
        FUNCTION = 1
    ELSE
        FUNCTION = 0
    END IF
END FUNCTION

Siehe auch

  • FUNCTION/END FUNCTION
  • FADEN CLOSE
  • THREAD-Codegruppe
  • THREAD CREATE
  • THREAD-Objekt
  • Thread-Lebenslauf
  • FADEN AUFHÄNGEN
  • FADENZAHL
  • GEWINDE
  • Thread-ID
  • XTHREAD ERSTELLEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


THREAD SUSPEND – PBXB64-Compiler-Hilfe

Startseite › Funktionen › FADENAUFHÄNGUNG

FADEN AUFHÄNGEN

Unterbrechen Sie die Ausführung eines Windows-Threads.

Typ:Anweisung |Kategorie: Einfädeln

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

THREAD SUSPEND hThread TO lResult&

Beschreibung

THREAD SUSPEND fügt 1 zum Suspend-Zähler des durch hThread angegebenen Threads hinzu (siehe THREAD CREATE ). Wenn dies erfolgreich ist, ist der lResult&-Wert der vorherige Suspend-Zähler des Threads; andernfalls ist es -1. Ein Thread wird immer angehalten, wenn er einen Suspend-Zähler von 1 oder höher hat.

Um den Suspend-Zähler eines Threads zu verringern, verwenden Sie die THREAD RESUME-Anweisung. Ein angehaltener Thread nimmt die Ausführung erst dann wieder auf, wenn sein Suspend-Zähler auf 0 dekrementiert wird.

Einschränkungen

Die THREAD SUSPEND-Anweisung erzeugt keine Laufzeitfehler; Alle Ausnahmen werden im Rückgabewert lResult& gemeldet. Eine Thread-ID kann nicht austauschbar mit einem Thread-Handle verwendet werden. Ein Thread kann sich selbst anhalten, indem er seinen eigenen Suspend-Zähler erhöht.

PBXB64-Beispiel

Das folgende Programm wurde mit PBXB64 getestet und kompiliert:

' PBXB64 Test: THREAD SUSPEND / RESUME
' Tests pausing and resuming a thread

#COMPILE EXE
#DIM ALL

THREAD FUNCTION Worker(BYVAL param AS LONG) AS LONG
    SLEEP 100
    FUNCTION = param + 10
END FUNCTION

FUNCTION PBMAIN() AS LONG
    LOCAL hThread AS DWORD
    LOCAL result AS LONG
    LOCAL n AS LONG

    THREAD CREATE Worker(5) TO hThread

    ' Suspend immediately (thread hasn't finished yet)
    THREAD SUSPEND hThread TO n
    IF n = -1 THEN FUNCTION = 1 : EXIT FUNCTION

    ' Resume
    THREAD RESUME hThread TO n
    IF n = -1 THEN FUNCTION = 2 : EXIT FUNCTION

    ' Wait for completion and close
    THREAD CLOSE hThread TO result

    IF result <> 15 THEN
        FUNCTION = 3
    ELSE
        FUNCTION = 0
    END IF
END FUNCTION

Siehe auch

  • FUNCTION/END FUNCTION
  • FADEN CLOSE
  • THREAD-Codegruppe
  • THREAD CREATE
  • THREAD-Objekt
  • Thread-Lebenslauf
  • Thread-Status
  • FADENZAHL
  • GEWINDE
  • Thread-ID
  • XTHREAD ERSTELLEN

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht
← Thread-Status Nach oben FADENZAHL →

Prüfung des Thread-Zustands

Testen Sie diesen Befehl mit einem Worker-Thread, der durch THREAD CREATE erzeugt wurde. Das Beispiel soll den Thread-Handle prüfen, Suspend oder Resume anwenden, den Handle schließen und kontrollieren, dass der Rückgabewert des Workers korrekt eingesammelt wird.

Scheduling-Hinweise

Windows-Scheduling ist asynchron. Beispiele sollen nicht von exaktem Timing abhängen; verwenden Sie Statusprüfungen, Events oder kurze Wartezeiten nur als Diagnose. Geben Sie Handles am Ende immer mit THREAD CLOSE frei.


THREADCOUNT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › THREADCOUNT

FADENZAHL

Gibt die Anzahl der von PowerBASIC erstellten aktiven Threads zurück, die in einem Modul vorhanden sind.

Typ:Funktion |Kategorie: Einfädeln

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

lCount& = THREADCOUNT

Beschreibung

Anwendungen geben einen THREADCOUNT von mindestens 1 zurück, der dem „primären“ Anwendungsthread zugeordnet wird. Zusätzliche Threads, die von der Anwendung oder dem Modul mit der Funktion THREAD CREATE erstellt wurden, werden ebenfalls in die von THREADCOUNT zurückgegebene Liste einbezogen.

THREADCOUNT kann nützlich sein, wenn ein „steuernder Thread“ den Status einer Sammlung von „Arbeitsthreads“ abfragen muss, während diese eine Reihe von Aufgaben erledigen. Allerdings ist Vorsicht geboten, wenn möglicherweise auch andere (nicht verwandte) Threads im selben Modul laufen – in solchen Fällen ist die Verwendung von THREAD STATUS die bevorzugte Lösung. Wenn eine Abfrage nicht gewünscht ist, kann auch die API-Funktion WaitForMultipleObjects nützlich sein – weitere Informationen finden Sie unter THREAD CLOSE.

Einschränkungen

THREADCOUNT umfasst Threads, deren Thread-Handle mit THREAD CLOSE freigegeben wurde, die aber noch laufen.

Threads werden asynchron initialisiert und gestartet. Daher ist es ratsam, dem Betriebssystem etwas Zeit für die Thread-Initialisierung zu geben, bevor Sie die Funktion THREADCOUNT zum Überwachen des Threads verwenden.

Eine Thread-Funktion darf nicht direkt aufgerufen oder ausgeführt werden, außer durch eine THREAD CREATE-Anweisung. Diese Einschränkung wird auferlegt, um sicherzustellen, dass die PowerBASIC-Laufzeitbibliothek jederzeit einen Thread-sicheren Zustand beibehalten, internen Thread-lokalen Speicher korrekt zuweisen und freigeben kann und Funktionen wie THREADCOUNT genaue Werte zurückgeben können. Weitere Informationen und Lösungen finden Sie unter THREAD CREATE.

PBXB64-Beispiel

Das folgende Programm wurde mit PBXB64 getestet und kompiliert:

' PBXB64 Test: THREADCOUNT
' Tests retrieving thread count

#COMPILE EXE
#DIM ALL

THREAD FUNCTION Worker(BYVAL param AS LONG) AS LONG
    SLEEP 50
    FUNCTION = param
END FUNCTION

FUNCTION PBMAIN() AS LONG
    LOCAL hThread AS DWORD
    LOCAL count1 AS LONG
    LOCAL count2 AS LONG
    LOCAL result AS LONG

    count1 = THREADCOUNT

    ' At least 1 (main thread) should exist
    IF count1 < 1 THEN FUNCTION = 1 : EXIT FUNCTION

    THREAD CREATE Worker(1) TO hThread

    count2 = THREADCOUNT

    ' After creating a thread, count should be >= count1
    IF count2 < count1 THEN FUNCTION = 2 : EXIT FUNCTION

    THREAD CLOSE hThread TO result

    FUNCTION = 0
END FUNCTION

Siehe auch

  • FUNCTION/END FUNCTION
  • FADEN CLOSE
  • THREAD-Codegruppe
  • THREAD CREATE
  • THREAD-Objekt
  • Thread-Lebenslauf
  • Thread-Status
  • FADEN AUFHÄNGEN
  • GEWINDE
  • Thread-ID
  • XTHREAD ERSTELLEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


THREADED – PBXB64-Compiler-Hilfe

Startseite › Funktionen › GEWINDE

GEWINDE

Deklarieren Sie Thread-lokale Variablen.

Typ:Anweisung |Kategorie:Variablen und Umfang

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

THREADED variable [()] [AS type ] [, variable [()]]
THREADED variable [()] [, variable [()]] [, ...] AS type

Beschreibung

Thread-Variablen gelten global für alle Sub-, Function-, Method- und Property-Variablen, werden jedoch nicht von Threads gemeinsam genutzt. Jeder Thread verfügt über einen eigenen unabhängigen Satz threadlokaler Variablen.

Um ein Array als Thread-Variable zu deklarieren, verwenden Sie einen leeren Satz Klammern in der Variablenliste: Anschließend können Sie das Array mit der DIM-Anweisung dimensionieren.

THREADED MyArray%()

THREADED StringArray() AS STRING

Die THREADED-Anweisung kann optional eine Liste von Variablen akzeptieren, die alle durch das ihnen folgende Typdeskriptor-Schlüsselwort definiert werden. Zum Beispiel:

Threaded aaa, bbb, ccc als Ganzzahl

THREADED vptr, aptr() AS LONG PTR

Einschränkungen

Der DEF-Typ hat keine Auswirkung auf Variablen, die durch eine THREADED-Anweisung definiert werden.

PBXB64-Beispiel

Das folgende Programm wurde mit PBXB64 getestet und kompiliert:

' PBXB64 Test: THREADED FUNCTION prefix
' Tests THREADED FUNCTION declaration syntax

#COMPILE EXE
#DIM ALL

THREADED FUNCTION Worker(BYVAL param AS LONG) AS LONG
    FUNCTION = param + 100
END FUNCTION

FUNCTION PBMAIN() AS LONG
    LOCAL hThread AS DWORD
    LOCAL result AS LONG

    THREAD CREATE Worker(23) TO hThread
    THREAD CLOSE hThread TO result

    IF result <> 123 THEN
        FUNCTION = 1
    ELSE
        FUNCTION = 0
    END IF
END FUNCTION

Siehe auch

  • DIM
  • GLOBAL
  • INSTANCE
  • LOCAL
  • STATIC
  • XTHREAD ERSTELLEN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


THREADID – PBXB64-Compiler-Hilfe

Startseite › Funktionen › THREADID

Thread-ID

Geben Sie a zurück

Typ:Funktion |Kategorie: Einfädeln

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

thrdID& = THREADID

Beschreibung

Der Thread-ID-Wert wird für den Thread zurückgegeben, der gerade ausgeführt wird. Die Thread-ID ist für die Verwendung mit den verschiedenen (erweiterten) Thread-bezogenen API-Funktionen von Windows vorgesehen.

Einschränkungen

Der Thread-ID-Wert kann nicht austauschbar mit dem von THREAD CREATE zurückgegebenen Thread-Handle verwendet werden.

PBXB64-Beispiel

Das folgende Programm wurde mit PBXB64 getestet und kompiliert:

' PBXB64 Test: THREAD ID
' Tests retrieving current thread ID

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL id AS LONG

    id = THREADID

    ' Thread ID should be non-zero for any valid thread
    IF id = 0 THEN
        FUNCTION = 1
    ELSE
        FUNCTION = 0
    END IF
END FUNCTION

Praktische Verwendung

Thread-ID gehoert zur Kategorie General. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Thread-ID mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Siehe auch

  • FUNCTION/END FUNCTION
  • FADEN CLOSE
  • THREAD CREATE
  • Thread-Lebenslauf
  • Thread-Status
  • FADEN AUFHÄNGEN
  • GEWINDE
  • XTHREAD ERSTELLEN


THREADSAFE-Optionsdeskriptor – PBXB64-Compiler-Hilfe

Startseite › Funktionen › THREADSAFE-Optionsdeskriptor

THREADSAFE-Optionsdeskriptor

Erklärt die THREADSAFE-Option für Prozeduren.

Typ:Konzeptionell |Kategorie: Einfädeln

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Überblick

Dieses Thema bietet Hintergrundinformationen und praktische Anleitungen. Eine detaillierte Syntax finden Sie auf den entsprechenden Befehlsseiten.

Siehe auch

  • Befehlsindex

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Zeitbefehle – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Zeitbefehle

Zeitbefehle

Die folgenden Funktionen manipulieren und verwalten die Uhrzeit und das Systemdatum:

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Stellen Sie das Systemdatum ein und rufen Sie es ab.

Konvertiert eine Wochentagszahl in den zugehörigen Namen.

Beschreibung

Zeitbefehle gehoert zur Kategorie General. Diese Seite beschreibt den PBXB64-Dokumentationsstand fuer diesen Eintrag; verwenden Sie die Grenzen und Belege auf dieser Seite statt historischer PBWin-Annahmen.

Syntax

' Siehe den urspruenglichen Eintrag und die verlinkten Beispiel-/Testdateien fuer die genaue PBXB64-Form von Zeitbefehle.
' Nicht belegte Unterformen bleiben ausserhalb der zertifizierten Oberflaeche.

Praktische Verwendung

Zeitbefehle gehoert zur Kategorie General. Verwenden Sie diese Referenzseite zusammen mit dem Syntaxblock: zuerst die benoetigten Variablen und Handles vorbereiten, dann den Befehl ausfuehren, danach Rueckgabewerte, geaenderten Zustand oder Fehlerpfade ausdruecklich pruefen.

Parameter und Ergebnisse

Argumente muessen den im Syntaxabschnitt gezeigten Datentypen, Reihenfolgen und optionalen Teilen entsprechen. Zielvariablen sollten vor dem Aufruf initialisiert werden, damit unveraenderte Werte nach einem Fehler erkannt werden. Bei Befehlen mit globalem Zustand, Dateien, Fenstern, Handles oder Laufzeitressourcen gehoert das Freigeben oder Wiederherstellen zum Beispiel.

Oberflächengrenzen

Beschreiben Sie hier, ob die Seite eine einzelne Befehlsform, eine Familienuebersicht oder nur eine Kompatibilitaetsreferenz darstellt. Wenn mehrere Formen denselben Laufzeitpfad teilen, sollte die Seite das klar sagen; wenn Parser- oder Laufzeitverhalten auseinanderlaeuft, muessen diese Unterschiede ebenfalls benannt werden. Nennen Sie die registrierte Probe, die die Grenze belegt, und fuehren Sie offene Randfaelle nur dann auf, wenn sie wirklich noch ausserhalb des getesteten Bereichs liegen.

Kategoriehinweise

Die Seite sollte die Implementierungsgrenze sichtbar halten: genaue Form, was sich aendert, was gleich bleibt und welche benachbarten Seiten den umgebenden Ablauf belegen. Ist die Seite eine Uebersicht, sollten die konkreten Unterseiten genannt werden, die das eigentliche Verhalten tragen.

Validierungsbeleg

Validation evidence: Diese generierte Qualitaetsergaenzung verweist auf den aktuellen PBXB64-Hilfebaum und den Coverage-Manifest-Eintrag fuer diese Seite. Wenn kein konkreter Test auf dieser Seite genannt ist, ist der Eintrag als Dokumentations-/Kompatibilitaetsoberflaeche zu behandeln und nicht als vollstaendige PBWin-Paritaetsbehauptung.

Hinweise

Dokumentieren Sie auf der Seite die genaue Grenze dieses Befehls: was er akzeptiert, was er ablehnt, und welche Laufzeitvoraussetzung der Aufrufer vor der Verwendung erfuellen muss. Wenn ein fokussierter Test existiert, nennen Sie die Datei hier, damit sich die Seite direkt aus dem dokumentierten Beispiel umsetzen laesst.

Test- und Dokumentationshinweise

Ein vollstaendiges Beispiel nennt die erwartete Ausgabe oder den erwarteten Exit-Code und beschreibt Voraussetzungen wie Windows-Desktop, vorhandene Dateien, geoeffnete Handles, Includes oder Bibliotheken. Wenn ein Beispiel interaktiv ist oder Systemzustand aendert, muss dieser Zustand im Text genannt werden.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Zeitbefehle mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Siehe auch

  • Befehlsindex
  • BASIC-Frontend


TIME$-Systemvariable – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Systemvariable TIME$

Systemvariable TIME$

Lesen und/oder stellen Sie die Systemzeit ein.

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = TIME$
TIME$ = string_expression

Beschreibung

Die Systemvariable TIME$ enthält eine achtstellige Zeichenfolge, die die Zeit der Systemuhr in der Form „hh:mm:ss“ darstellt, wobei hh für Stunden (im 24-Stunden-Militärformat), mm für Minuten und ss für Sekunden steht.

Durch die Zuweisung von string_expression zu TIME$ wird die Systemuhr zurückgesetzt. string_expression muss Zeitinformationen im militärischen Format (24 Stunden) enthalten. Minuten- und Sekundenangaben können weggelassen werden. Zum Beispiel:

TIME$ = "12" 'stellt die Uhr auf 12 Uhr mittags

TIME$ = "13:01" 'stellt die Uhr auf 13:01 Uhr

TIME$ = "13:01:30" 'stellt die Uhr auf 30 Sekunden nach 13:01 Uhr ein

TIME$ = "0:01" 'Uhr auf 1 Minute nach Mitternacht einstellen

Verwenden Sie die TIMER-Funktion, um die Anzahl der Sekunden zurückzugeben, die seit Mitternacht vergangen sind.

Siehe auch

  • DATUM$
  • MONTHNAME$
  • POWERTIME
  • TIMER
  • TIX

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


TIMEBASE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › ZEITBASIS

ZEITBASIS

Gibt die Häufigkeit oder den aktuellen Wert des hochauflösenden Leistungsindikators zurück.

Typ:Funktion |Kategorie: Betriebssystem und Umgebung / Datum und Uhrzeit

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

counter = TIMEBASE

Remarks

TIMEBASE wird typischerweise mit TIX verwendet, um die verstrichene Zeit mit hoher Präzision zu messen.

Beispiel

FUNCTION PBMAIN() AS LONG
  LOCAL base AS QUAD
  base = TIMEBASE
  PRINT "Timebase frequency:"; base
  FUNCTION = 0
END FUNCTION

Siehe auch

  • TIX
  • TIMER

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TIMER – PBXB64-Compiler-Hilfe

Startseite › Funktionen › TIMER

TIMER

Gibt die Anzahl der Sekunden zurück, die seit Mitternacht vergangen sind.

Typ:Funktion |Kategorie: Utilities

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

y = TIMER

Beschreibung

TIMER gibt die Anzahl der Sekunden seit Mitternacht als Gleitkommawert mit doppelter Genauigkeit zurück. Die Auflösung beträgt etwa 1/100 Sekunde auf NT-basierten Plattformen bzw. 1/18 Sekunde auf früheren Plattformen.

Siehe auch

  • DATUM$
  • ZEIT$
  • TIX

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TIX - Hochaufloesender Timer - PBXB64-Compiler-Hilfe

Startseite › BASIC-Frontend › Befehlsreferenz › System & Umgebung › TIX
Hilfe zum PBXB64-Compiler

TIX — Hochaufloesender Timer

TIX liest den eingebetteten Windows-Timerhelfer von PBXB64 und liefert einen vorzeichenbehafteten 64-Bit-Tickwert. Die aktuelle Implementierung ist fuer relative Laufzeitmessungen innerhalb eines Prozesses gedacht. Sie verspricht keine Roh-CPU-Zyklus-Paritaet zu historischen Beschreibungen von Prozessorzaehlern.

Typ: Funktion und Anweisung | Kategorie: System & Umgebung

PBXB64-Status: VERFUEGBAR — fokussierte Implementierung, kein Stub

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ticks&& = TIX
TIX QuadVar
TIX END QuadVar

Beschreibung

Die Ausdrucksform TIX liefert den aktuellen Timer-Tick als QUAD-grossen Integerwert. Diese Form passt zu Quellen, die den Timer wie eine Funktion lesen, zum Beispiel started&& = TIX.

Die Anweisungsform TIX QuadVar liest denselben Timer und weist den aktuellen Wert dem numerischen Ziel zu. Das Ziel sollte ein QUAD oder ein anderer numerischer Typ sein, der einen 64-Bit-Tickwert aufnehmen kann.

TIX END QuadVar liest den aktuellen Timer, subtrahiert den bereits in QuadVar gespeicherten vorherigen Wert und schreibt die verstrichene Tickdifferenz in dasselbe Ziel zurueck. Dies ist die PBWin-artige Start/Ende-Messform.

PBXB64 senkt alle drei Formen derzeit auf den eingebetteten Laufzeithelfer bestof_tix ab. Der Helfer wird vom Compiler in Single-EXE-Ausgaben eingebunden; ein loses Laufzeitobjekt oder eine externe Hilfsbibliothek ist nicht erforderlich.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL elapsed&& AS QUAD

    TIX elapsed&&
    SLEEP 50
    TIX END elapsed&&

    IF elapsed&& > 0 THEN
        PRINT "OK"
        FUNCTION = 0
    ELSE
        FUNCTION = 1
    END IF
END FUNCTION

Praktische Verwendung

Verwenden Sie TIX fuer relative Messungen, etwa um zwei Schleifen zu vergleichen, eine kurze Routine zu messen oder zu pruefen, ob eine Warteoperation tatsaechlich Zeit verbraucht hat. Absolute Werte sollten nicht zwischen verschiedenen Prozessen, Systemstarts oder Rechnern verglichen werden.

Die Tickeinheit ist die Windows-Timereinheit des Laufzeithelfers und wird hier fuer PBXB64 nur als monotoner relativer Tick dokumentiert. Wenn ein Programm Sekunden benoetigt, verwenden Sie TIMER oder kalibrieren Sie den Plattformtimer ausdruecklich im Anwendungscode.

started&& = TIX
SLEEP 10
finished&& = TIX
TIX elapsed&&
SLEEP 10
TIX END elapsed&&

Parameter und Ergebnisse

QuadVar ist ein zuweisbares numerisches BASIC-Ziel, das vom normalen PBXB64-Zuweisungspfad unterstuetzt wird. Die fokussierte Regression deckt eine lokale QUAD-Variable ab. Breiterer Zielvariablen-Stress, exakte historische Zykluseinheiten und Komfortformen fuer Frequenzabfragen bleiben ausserhalb dieser fokussierten Schliessung.

Validierungsbeleg

Registrierter Test: examples/basic/test_tix.pb ist in tests/validate.toml unter pb_linkrun registriert. Er beweist, dass die Ausdrucksform TIX ueber einen kurzen Schlaf monoton bleibt, dass TIX target einen nicht negativen Tickwert speichert und dass TIX END target eine positive verstrichene Differenz speichert.

Erwartetes Ergebnis: das registrierte Programm gibt OK aus und endet mit Exit-Code 0.

Test- und Dokumentationshinweise

Diese Seite dokumentiert absichtlich keine feste Tickfrequenz. Der aktuelle Helfer liefert einen monotonen relativen Zaehler fuer verstrichene Vergleiche; exakte Hardware-Zyklen und Frequenzumrechnung sind breitere Kompatibilitaetsthemen. Tests sollen deshalb Reihenfolge und positive Differenzen pruefen, nicht einen fest verdrahteten Tickwert.

Siehe auch

  • TIMER — Sekunden der Wanduhr
  • SLEEP — Ausfuehrung verzoegern

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TO – PBXB64-Compiler-Hilfe

Startseite › Funktionen › TO

TO

Trennt den Start- und Endwert in einer FOR-Klausel

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

FOR counter = start TO end [STEP increment]

Beschreibung

DerTO Schlüsselwort erscheint zwischen dem Anfangswert und dem Grenzwert in a FOR Anweisung. Es wird auch in verwendet SELECT CASE Bereiche (CASE low TO high).

Beispiel

FUNCTION PBMAIN () AS LONG
    LOCAL i AS LONG
    FOR i = 1 TO 5
        PRINT i
    NEXT i
END FUNCTION

Siehe auch

  • FOR
  • WEITER
  • STEP
  • CASE
  • Kontrollflussreferenz

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Schaltfläche „Hinzufügen“ in der Symbolleiste – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › TOOLBAR-TASTE HINZUFÜGEN

Schaltfläche „Hinzufügen“ in der Symbolleiste

A

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

TOOLBAR ADD BUTTON hDlg , ID , image& , cmd& , style& , text$ [AT item& ] [CALL callback ]
TOOLBAR ADD SEPARATOR hDlg , ID , size& [, cmd& ] [AT item& ]
TOOLBAR DELETE BUTTON hDlg , id& , [BYCMD] item&
TOOLBAR GET STATE hDlg , ID , [BYCMD] item& TO datav&
TOOLBAR GET COUNT hDlg , ID TO datav&
TOOLBAR SET IMAGELIST hDlg , ID , hLst , ListType&
TOOLBAR SET STATE hDlg , ID , [BYCMD] item& , state&

Beschreibung

Ein TOOLBAR-Steuerelement enthält eine oder mehrere Schaltflächen, von denen jede normalerweise einem Menüelement entspricht. Es wird im Allgemeinen oben im Clientbereich eines Dialogs platziert. Wenn der Benutzer eine Schaltfläche in der Symbolleiste „drückt“, reagiert das Programm auf die gleiche Weise, als ob der Befehl aus einem Menü ausgewählt worden wäre. Es dient lediglich als Verknüpfung zu allgemeinen Menübefehlen.

In jeder der folgenden Beschreibungen wird auf die TOOLBAR durch das Dialoghandle ( hDlg ) und die ID& verwiesen. In manchen Fällen wird eine bestimmte Schaltfläche mit dem Parameter item& ausgewählt. Wenn die Option BYCMD enthalten ist, gibt item& die Befehls-ID-Nummer der zu verwendenden Schaltfläche an. Wenn nicht, beschreibt item& die Schaltfläche anhand ihrer Position in der Symbolleiste. Da Trennzeichen vom Betriebssystem als eine besondere Klasse von Schaltflächen betrachtet werden, müssen sie bei der Berechnung einer Positionselementnummer gezählt werden. Positionen werden immer auf eins indiziert (1=erste, 2=zweite usw.).

TOOLBAR-TASTE HINZUFÜGEN hdlg , ID , image& , cmd& , style& , text$ [AT item& ] [CALL callback ]

Dieser Symbolleiste wurde eine Schaltfläche hinzugefügt. Das anzuzeigende Bild wird anhand des Parameters image& (1=erstes, 2=zweite usw.) aus der angehängten IMAGELIST ausgewählt. Der Parameter cmd& gibt die Befehls-ID-Nummer an, die ausgeführt werden soll (mit %WM_COMMAND), wenn die Schaltfläche gedrückt wird. Der Parameter style& beschreibt den Stil der Schaltfläche anhand der folgenden am häufigsten verwendeten Attribute:

%BTNS_AUTOSIZE

Die Breite der Schaltfläche wird vom System anhand des Textes und des Bildes berechnet.

%BTNS_BUTTON

Der Knopf verhält sich wie ein normaler Druckknopf.

%BTNS_CHECK

Die Schaltfläche verfügt über einen Dual-Status, der bei jedem Klick zwischen dem gedrückten und dem nicht gedrückten Zustand umschaltet.

%BTNS_GROUP

Definiert eine Gruppe von Schaltflächen. In Kombination mit dem Häkchenstil wird eine Schaltfläche erstellt, die gedrückt bleibt, bis eine andere Schaltfläche in der Gruppe gedrückt wird. Dies ähnelt einer Optionsschaltfläche oder einem Optionsfeld.

%BTNS_CHECKGROUP

Eine Kombination aus Karo- und Gruppenstilen.

%BTNS_DROPDOWN

Erstellt eine Dropdown-Schaltfläche, die beim Klicken eine Liste anzeigen kann. Dropdown-Schaltflächen senden eine %TBN_DROPDOWN-Benachrichtigung anstelle von %WM_COMMAND.

%BTNS_NOPREFIX

Dem Schaltflächentext ist kein Beschleunigerpräfix zugeordnet.

Der Parameter text$ gibt den Text an, der auf der Schaltfläche angezeigt werden soll.

Wenn die optionale „AT item&“-Klausel enthalten ist, wird die Schaltfläche an der angegebenen Position eingefügt (1=erste, 2=zweite usw.). Andernfalls wird es am Ende der Liste hinzugefügt.

Wenn die optionale Klausel „CALL callback“ enthalten ist, gibt sie den Namen einer Callback-Funktion an, die %WM_COMMAND-Nachrichten empfängt, wenn auf die Schaltfläche geklickt wird. Wenn nicht angegeben, werden diese Befehlsnachrichten an den in DIALOG SHOW angegebenen Dialog-Callback gesendet. Mithilfe der Nachrichtenweiterleitung nach Schaltfläche können Sie leicht feststellen, welche Schaltfläche das Ereignis ausgelöst hat.

Wenn die Callback-Funktion eine Nachricht verarbeitet, sollte sie TRUE (ungleich Null) zurückgeben, um zu verhindern, dass die Nachricht unnötigerweise an den Dialog-Callback (sofern vorhanden) übergeben wird. Der Dialogrückruf sollte auch TRUE zurückgeben, wenn die Benachrichtigungsnachricht von dieser Rückruffunktion verarbeitet wird. Andernfalls verarbeitet die DDT-Engine nicht verarbeitete Nachrichten.

Symbolleiste Trennzeichen hinzufügen HDlg, ID, Größe& [, cmd&] [AT-Element&]

Dieser Symbolleiste wird ein Trennzeichen hinzugefügt. Es trennt zwei Schaltflächen durch die in size& angegebene Anzahl von Pixeln. Es kann verwendet werden, um zwei benachbarte Schaltflächengruppen (%tbstyle_group) zu trennen und zu unterscheiden oder einfach nur das visuelle Erscheinungsbild zu verbessern. Wenn der optionale Parameter cmd& enthalten ist, handelt es sich um eine eindeutige numerische Kennung für dieses Trennzeichen. Natürlich kann ein Trennzeichen nicht wie eine Taste gedrückt werden, sodass es nicht im wahrsten Sinne des Wortes das Senden eines Befehls ermöglicht. Es kann jedoch später mit einer BYCMD-Option in TOOLBAR DELETE, TOOLBAR SET STATE usw. verwendet werden. Wenn die Klausel „AT item&“ enthalten ist, wird das Trennzeichen an der angegebenen Position eingefügt (1=erste, 2=zweite usw.). Andernfalls wird es am Ende der Liste hinzugefügt.

TOOLBAR-LÖSCHE-TASTE hdlg , ID , [BYCMD] item&

Eine durch item& angegebene Schaltfläche oder ein Trennzeichen wird aus der Symbolleiste gelöscht. Der Parameter item& kann positionell sein oder eine Befehls-ID-Nummer mit BYCMD darstellen.

TOOLBAR GET COUNT hdlg , ID to datav&

Die Anzahl der Schaltflächen (und Trennzeichen) auf der Symbolleiste wird abgerufen und der durch datav& angegebenen langen Ganzzahlvariablen zugewiesen.

TOOLBAR STATUS ERHALTEN hdlg , ID , [BYCMD] item& TO datav&

Die Zustandsdeskriptorbits für eine bestimmte Schaltfläche werden abgerufen und der durch datav& bezeichneten Variablen zugewiesen. Der Parameter item& gibt an, welche Schaltfläche überprüft werden soll – es kann sich um eine Position oder um die Befehls-ID-Nummer handeln, wenn sie mit BYCMD verwendet wird. Die Deskriptorbits können aus einem oder mehreren der folgenden bestehen:

%TBSTATE_DISABLED

Die Schaltfläche ist deaktiviert und ausgegraut. (Wert=0)

%TBSTATE_CHECKED

Die Schaltfläche ist aktiviert.

%TBSTATE_PRESSED

Der Knopf wird gedrückt.

%TBSTATE_ENABLED

Die Schaltfläche ist aktiviert.

%TBSTATE_HIDDEN

Die Schaltfläche ist ausgeblendet.

%TBSTATE_INDETERMINATE

Die Schaltfläche ist unbestimmt und ausgegraut.

%TBSTATE_MARKED

Die Schaltfläche ist hervorgehoben.

TOOLBAR SET IMAGELIST hdlg , ID , hLst , type&

Die von hLst angegebene IMAGELIST wird an dieses TOOLBAR-Steuerelement angehängt. Der Wert von ListType& gibt den Typ von IMAGELIST an:

Standardbilder

Deaktivierte Bilder

Heiße Bilder

Die in der IMAGELIST enthaltenen grafischen Bilder werden auf den Schaltflächen der Symbolleiste angezeigt. An jedes TOOLBAR-Steuerelement können bis zu drei IMAGELIST-Strukturen angehängt werden. Das anzuzeigende Bild wird durch die in TOOLBAR ADD BUTTON vorgenommene Spezifikation und den aktuellen Status der Schaltfläche bestimmt. Wenn das TOOLBAR-Steuerelement zerstört wird, werden alle angehängten IMAGELIST automatisch zerstört.

TOOLBAR SET STATE hDlg , ID , [BYCMD] item& , state&

Die Zustandsdeskriptorbits für die angegebene Schaltfläche werden aus dem Ausdruck state& angewendet. Der Parameter item& gibt an, welche Schaltfläche eingestellt werden soll – es kann sich um eine Position oder um die Befehls-ID-Nummer handeln, wenn sie mit BYCMD verwendet wird. Die Deskriptorbits state& können bestehen aus:

%TBSTATE_DISABLED

Die Schaltfläche ist deaktiviert und ausgegraut. (Wert=0)

%TBSTATE_CHECKED

Die Schaltfläche ist aktiviert.

%TBSTATE_PRESSED

Der Knopf wird gedrückt.

%TBSTATE_ENABLED

Die Schaltfläche ist aktiviert.

%TBSTATE_HIDDEN

Die Schaltfläche ist ausgeblendet.

%TBSTATE_INDETERMINATE

Die Schaltfläche ist unbestimmt und ausgegraut.

%TBSTATE_MARKED

Die Schaltfläche ist hervorgehoben.

PBXB64-Implementierungshinweise

PBXB64 implementiert und regressionstests TOOLBAR ADD BUTTON, ADD SEPARATOR, DELETE BUTTON, GET COUNT, GET STATE, SET IMAGELIST und SET STATE mit eingebetteten Common-Control-Laufzeithelfern. ADD BUTTON und ADD SEPARATOR unterstützen das Anhängen und einsbasierte AT-Einfügung; DELETE BUTTON, GET STATE und SET STATE unterstützen die Positions- und BYCMD-Elementauswahl; GET COUNT gibt die tatsächliche Anzahl der Symbolleistenschaltflächen/Trennzeichen zurück. Diese Formulare werden durch test_toolbar_separator.pb, test_toolbar_set_imagelist.pb und test_toolbar_button_state.pb abgedeckt.

Siehe auch

  • DIALOGMODAL ANZEIGEN
  • DIALOG ZEIGEN MODELLLOS
  • Dynamic Dialog Tools
  • STEUERUNG SYMBOLLEISTE HINZUFÜGEN
  • STEUERUNG SET SCHRIFTART
  • BILDLISTE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


#TOOLS – PBXB64-Compiler-Hilfe

Startseite › Funktionen › #TOOLS

#TOOLS

Aktivieren oder deaktivieren Sie den Code des integrierten Entwicklungstools im kompilierten Code.

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

#TOOLS [ON|+ | OFF|-]

Beschreibung

Mit der Metaanweisung #TOOLS können integrierte Entwicklungstools wie TRACE und PROFILE einfach deaktiviert werden, um sicherzustellen, dass zusätzlicher Code und Daten nicht in die endgültige (Verteilungs-)Version einer Anwendung kompiliert werden. #TOOLS ist standardmäßig auf ON eingestellt und darf nur einmal im Quellcode vorkommen, vor jeder Anweisung, die ausführbaren Code generiert.

Im aktuellen PBXB64-Bereich unterdrückt #TOOLS OFF die getesteten TRACE- und PROFILE-Absenkungspfade. Die fokussierte Regression tests/pb/test_tools_off_trace.pb prueft, dass bei unter #TOOLS OFF kompilierten TRACE-Anweisungen keine Trace-Datei erzeugt wird.

Siehe auch

  • CALLSTK
  • CALLSTK$
  • CALLSTKCOUNT
  • FUNCNAME$
  • PROFILE
  • TRACE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für #TOOLS soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' #TOOLS mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


TRACE - PBXB64-Compiler-Hilfe

Startseite › Funktionen › TRACE

TRACE

Schreibt explizite Trace-Zeilen in eine benannte Trace-Datei.

Typ: Anweisung | Kategorie: Allgemein

PBXB64-Status: VERFUEGBAR, getestete begrenzte Trace-Datei-Oberflaeche

PBXB64-Zertifizierung: [TESTED LIMITED]

Syntax

TRACE NEW fname$
TRACE ON
TRACE PRINT string_expr
TRACE OFF
TRACE CLOSE

Beschreibung

TRACE erstellt eine benannte Trace-Datei und erlaubt einem Programm, explizite Trace-Zeilen zu schreiben, solange Tracing eingeschaltet ist. Die getestete Ausgabe wird in die mit TRACE NEW fname$ angegebene Datei geschrieben.

TRACE kann mit TRACE ON und TRACE OFF gestartet und gestoppt werden. PBXB64 akzeptiert auch die Aliase TRON und TROFF. TRACE PRINT schreibt den Wert von string_expr nur, solange Tracing eingeschaltet ist.

Die fuenf getesteten Formen sind:

TRACE NEW fname$

Erstellt oder ueberschreibt die angegebene Trace-Datei und schaltet Tracing zunaechst aus.

TRACE ON

Aktiviert explizite TRACE PRINT-Ausgaben. TRON hat dieselbe Wirkung.

TRACE PRINT string_expr

Schreibt den Wert von string_expr als Zeile in die Trace-Datei, wenn Tracing eingeschaltet ist.

TRACE OFF

Stoppt voruebergehend TRACE PRINT-Ausgaben. TROFF hat dieselbe Wirkung.

TRACE CLOSE

Schliesst die Trace-Datei und trennt sie vom Trace-Datenstrom.

Beispiel:

TRACE NEW "run.trace"
TRACE ON
TRACE PRINT "startup"
TRACE OFF
TRACE PRINT "not written"
TRON
TRACE PRINT "after alias"
TROFF
TRACE CLOSE

Die getestete Ausgabe enthaelt die eingeschalteten TRACE PRINT-Zeilen und laesst die ausgeschaltete Zeile weg. Dieses Verhalten wird durch tests/pb/test_trace_file_state.pb abgedeckt.

Einschraenkungen

PBXB64 implementiert derzeit nur explizite Trace-Datei-Zeilen. Automatische Prozedur-Eintritts- und Austrittszeilen, Label-Zeilen, Parameterlisten, Laufzeitfehler-Zeilen und thread-lokale Trace-Streams sind noch nicht implementiert.

#TOOLS OFF unterdrueckt die getesteten TRACE- und PROFILE-Absenkungspfade im aktuellen Compilerbereich, so dass deaktivierte Tool-Anweisungen nicht in das kompilierte Programm gelangen.

Siehe auch

  • #TOOLS
  • CALLSTK
  • CALLSTK$
  • CALLSTKCOUNT
  • FUNCNAME$
  • PROFILE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für TRACE soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' TRACE mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


TREEVIEW DELETE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › TREEVIEW DELETE

TREEVIEW LÖSCHEN

A

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

TREEVIEW DELETE hDlg , id& , hItem
TREEVIEW GET BOLD hDlg , id& , hItem TO datav&
TREEVIEW GET CHECK hDlg , id& , hItem TO datav&
TREEVIEW GET CHILD hDlg , id& , hItem TO datav&
TREEVIEW GET COUNT hDlg , id& TO datav&
TREEVIEW GET EXPANDED hDlg , id& , hItem TO datav&
TREEVIEW GET NEXT hDlg , id& , hItem TO datav&
TREEVIEW GET PARENT hDlg , id& , hItem TO datav&
TREEVIEW GET PREVIOUS hDlg , id& , hItem TO datav&
TREEVIEW GET ROOT hDlg , id& TO datav&
TREEVIEW GET SELECT hDlg , id& TO datav&
TREEVIEW GET TEXT hDlg , id& , hItem TO txtv$
TREEVIEW GET USER hDlg , id& , hItem TO datav&
TREEVIEW INSERT ITEM hDlg , id& , hPrnt , hIAftr , image& , simage& , txt$ TO hItem
TREEVIEW RESET hDlg , id&
TREEVIEW SELECT hDlg , id& , hItem
TREEVIEW SET BOLD hDlg , id& , hItem , flag&
TREEVIEW SET CHECK hDlg , id& , hItem , flag&
TREEVIEW SET EXPANDED hDlg , id& , hItem , flag&
TREEVIEW SET IMAGELIST hDlg , id& , hLst
TREEVIEW SET TEXT hDlg , id& , hItem , txt$
TREEVIEW SET USER hDlg , id& , hItem , NumExpr
TREEVIEW UNSELECT hDlg , id&
hItem

Beschreibung

TREEVIEW DELETE hdlg , id& , hItem

Das durch das Handle hItem angegebene Datenelement wird aus dem TREEVIEW-Steuerelement gelöscht.

TREEVIEW GET BOLD hDlg , id& , hItem TO datav&

Das fettgedruckte Attribut für das Datenelement hItem wird abgerufen und der Variablen datav& zugewiesen. Wenn das Element fett gedruckt ist, wird der Wert wahr (-1) zugewiesen. Wenn nicht fett, wird der Wert false (0) zugewiesen.

TREEVIEW GET CHECK hdlg , id& , hItem TO datav&

Das Häkchenattribut für das Datenelement hItem wird abgerufen und der Variablen datav& zugewiesen. Wenn die Checkbox aktiviert ist, wird der Wert wahr (-1) zugewiesen. Wenn nicht aktiviert, wird der Wert false (0) zugewiesen.

TREEVIEW GET CHILD hDlg , id& , hItem TO datav&

Das durch hItem angegebene übergeordnete Datenelement wird nach untergeordneten Datenelementen durchsucht. Wenn welche gefunden werden, wird das Handle des ersten untergeordneten Elements der durch datav& angegebenen Variablen zugewiesen. Wenn keine gefunden werden, wird datav& der Wert Null (0) zugewiesen.

TREEVIEW GET COUNT hdlg , id& TO datav&

Die Anzahl der Datenelemente in TREEVIEW wird abgerufen und der durch datav& angegebenen langen Ganzzahlvariablen zugewiesen.

TREEVIEW GET EXPANDED hdlg , id& , hItem TO datav&

Das erweiterte Attribut für das Datenelement hItem wird abgerufen und der Variablen datav& zugewiesen. Wenn das Element erweitert wird und seine untergeordneten Datenelemente angezeigt werden, wird der Wert wahr (-1) zugewiesen. Wenn das Element ausgeblendet ist, wird der Wert false (0) zugewiesen.

TREEVIEW GET NEXT hDlg , id& , hItem TO datav&

Das durch hItem angegebene Datenelement wird nach gleichgeordneten Datenelementen durchsucht. Das Handle des nächsten Geschwisters wird der durch datav& angegebenen Variablen zugewiesen. Wenn kein nächstes Geschwisterelement gefunden wird, wird datav& der Wert Null (0) zugewiesen.

TREEVIEW GET PARENT hdlg , id& , hItem TO datav&

Das durch hItem angegebene Datenelement wird nach seinem übergeordneten Datenelement durchsucht. Das Handle des übergeordneten Elements wird der durch datav& angegebenen Variablen zugewiesen. Wenn kein übergeordnetes Element gefunden wird, wird datav& der Wert Null (0) zugewiesen.

TREEVIEW GET PREVIOUS hdlg , id& , hItem TO datav&

Das durch hItem angegebene Datenelement wird nach gleichgeordneten Datenelementen durchsucht. Das Handle des vorherigen Geschwisters wird der durch datav& angegebenen Variablen zugewiesen. Wenn kein vorheriges Geschwisterelement gefunden wird, wird datav& der Wert Null (0) zugewiesen.

TREEVIEW GET ROOT hdlg , id& TO datav&

Das Handle des allerersten Datenelements (ganz oben) in TREEVIEW wird abgerufen und der durch datav& angegebenen Variablen zugewiesen.

TREEVIEW GET SELECT hdlg , id& TO datav&

Das Handle des aktuell in TREEVIEW ausgewählten Datenelements wird abgerufen und der durch datav& angegebenen Variablen zugewiesen. Wenn keine aktuelle Auswahl vorhanden ist, wird der Wert Null (0) zugewiesen.

TREEVIEW GET TEXT hDlg , id& , hItem TO txtv$

Der Text eines bestimmten Datenelements (angegeben durch das Handle hItem ) wird aus dem TREEVIEW-Steuerelement abgerufen und der durch txtv$ angegebenen Zeichenfolgenvariablen zugewiesen.

TREEVIEW GET USER hdlg , id& , hItem TO datav&

Jedem Element in einer TREEVIEW kann nach Ermessen des Programmierers ein langer ganzzahliger Benutzerwert zugeordnet sein. Dieser Benutzerwert wird mit TREEVIEW SET USER zugewiesen und mit TREEVIEW GET USER abgerufen. Der Parameter hItem gibt das Handle des Benutzerelements an, auf das zugegriffen werden soll. Der zurückgegebene Benutzerwert wird der durch datav& angegebenen Long-Integer-Variablen zugewiesen. Zusätzlich zu diesen TREEVIEW-Benutzerwerten bietet jedes DDT-Steuerelement zusätzlich acht Benutzerwerte, auf die mit CONTROL GET USER und CONTROL SET USER zugegriffen werden kann.

TREEVIEW INSERT ITEM hdlg , id& , hPrnt , hIAftr , image& , selimage& , txt$ TO hItem

Zu diesem TREEVIEW-Steuerelement wird ein neues Datenelement hinzugefügt. Der Parameter hPrnt gibt das übergeordnete Element dieses Elements an oder Null, wenn das Element im Stammverzeichnis eingefügt werden soll. Der Parameter hIAftr gibt das Handle des Elements an, nach dem dieses neue Element eingefügt werden soll, oder %TVI_FIRST (am Anfang), %TVI_LAST (am Ende), %TVI_SORT (alphabetische Reihenfolge). Wenn eine IMAGELIST angehängt wurde, geben die Parameter image& und selimage& an, welches Bild angezeigt werden soll (1=erstes, 2=zweite usw.) für normale und ausgewählte Elemente. Wenn kein Bild benötigt wird, sollten die Werte 0 verwendet werden. Der Parameter txt$ bezeichnet die Textzeichenfolge, die angezeigt werden soll. Wenn der Vorgang erfolgreich ist, wird das Handle für das neue Datenelement der durch hItem angegebenen Variablen zugewiesen. Wenn die Operation fehlschlägt, wird hItem der Wert Null zugewiesen.

TREEVIEW RESET hdlg , id&

Alle Datenelemente werden aus dem angegebenen TREEVIEW-Steuerelement gelöscht.

TREEVIEW SELECT hDlg , id& , hItem

Das durch das Handle hItem angegebene Datenelement wird als ausgewählter Text für das TREEVIEW-Steuerelement ausgewählt und der ausgewählte Text wird an eine sichtbare Position gescrollt.

TREEVIEW SET BOLD hDlg , id& , hItem , flag&

Das fette Attribut für das durch hItem angegebene Datenelement wird basierend auf dem Wert des Flag&-Parameters festgelegt. Wenn flag& wahr ist (ungleich Null), wird es fett angezeigt. Wenn Flag& falsch (Null) ist, wird es im normalen Format angezeigt.

TREEVIEW SET CHECK hDlg , id& , hItem , flag&

Das optionale Kontrollkästchen für das durch hItem angegebene Datenelement wird basierend auf dem Wert des Parameters flag& gesetzt. Wenn Flag& wahr ist (ungleich Null), wird es überprüft. Wenn Flag& falsch (Null) ist, ist es deaktiviert.

TREEVIEW SET EXPANDED hDlg , id& , hItem , flag&

Das erweiterte Attribut für das durch hItem angegebene Datenelement wird basierend auf dem Wert des Flag&-Parameters festgelegt. Wenn Flag& wahr ist (ungleich Null), wird es im erweiterten Format angezeigt, wobei seine untergeordneten Elemente sichtbar sind. Wenn Flag& falsch (Null) ist, wird es im reduzierten Format angezeigt.

TREEVIEW SET IMAGELIST hdlg , id& , hLst

Die von hLst angegebene IMAGELIST wird an dieses TREEVIEW-Steuerelement angehängt. Die darin enthaltenen Bilder werden bei Bedarf zu jedem Datenelement angezeigt. Wenn das TREEVIEW-Steuerelement zerstört wird, werden alle angehängten IMAGELIST automatisch zerstört.

TREEVIEW SET TEXT hDlg , id& , hItem , txt$

Der Text eines bestimmten Datenelements (angegeben durch das Handle hItem ) wird durch den Text im Zeichenfolgenausdruck txt$ ersetzt.

TREEVIEW SET USER hDlg , id& , hItem , NumExpr

Jedem Element in einer TREEVIEW kann nach Ermessen des Programmierers ein langer ganzzahliger Benutzerwert zugeordnet sein. Dieser Benutzerwert wird mit TREEVIEW SET USER zugewiesen und mit TREEVIEW GET USER abgerufen. Der Parameter hItem gibt das Handle des Benutzerelements an, auf das zugegriffen werden soll, während NumExpr der Benutzerwert ist, der für einen späteren Abruf gespeichert wird. Zusätzlich zu diesen TREEVIEW-Benutzerwerten bietet jedes DDT-Steuerelement zusätzlich acht Benutzerwerte, auf die mit CONTROL GET USER und CONTROL SET USER zugegriffen werden kann.

TREEVIEW UNSELECT hdlg , id&

Alle Elemente im TREEVIEW-Steuerelement werden auf einen nicht ausgewählten Status gesetzt.

PBXB64-Implementierungshinweise

PBXB64 V10 zertifiziert die echten Win32-Common-Control-Formulare TREEVIEW INSERT ITEM, TREEVIEW GET COUNT, TREEVIEW SET BOLD, TREEVIEW GET BOLD, TREEVIEW SET CHECK, TREEVIEW GET CHECK und TREEVIEW SET IMAGELIST. Diese Formulare werden durch Link-and-Run-Regressionen gegen tatsächliche TreeView-Steuerelemente abgedeckt.

Siehe auch

  • Dynamic Dialog Tools
  • STEUERUNG TREEVIEW HINZUFÜGEN
  • STEUERUNG FARBE EINSTELLEN
  • STEUERUNG SET SCHRIFTART
  • BILDLISTE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Tricks zum Erhalt von Registern – PBXB64 Compiler-Hilfe

Startseite › Funktionen › Tricks zur Registererhaltung

Tricks zur Registererhaltung

Wenn Sie gemischten Assembler-/API-Code entwickeln und nicht wissen, welche Register in den API-Funktionen verwendet werden, können Sie auf zwei Paare von Assembler-Anweisungen zurückgreifen, die alle Usua beibehalten

Typ:Schlüsselwort |Kategorie: Memory & Pointers

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Das erste Mnemonikpaar, PUSHAD und POPAD, speichert und stellt die Register in einem Block wieder her. Mit diesen Mnemoniken können Sie beispielsweise den Wert eines Registers mitten im Assemblercode mit einem MessageBox-API-Aufruf anzeigen.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.


Tricks des Stacks – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Tricks des Stapels

Tricks des Stapels

Der Stapel lässt sich sehr flexibel schieben und platzen lassen. Es gibt ein paar Tricks, die bei der Verwendung des Stacks sehr nützlich sind: Sie können einen 32-Bit-Wert übertragen und dann zwei 16-Bit-Werte übertragen.

Typ:Schlüsselwort |Kategorie: Memory & Pointers

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

'Schiebt einen 32-Bit-Wert auf den Stapel

' Nehmen Sie nun zwei 16-Bit-Werte vom Stapel

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.


TRUE - Boolesches TRUE-Literal — PBXB64 Help

Startseite › General Reference › TRUE - Boolesches TRUE-Literal — PBXB64 Help
Hilfe zum PBXB64-Compiler

TRUE - Boolesches TRUE-Literal

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

IF flag = TRUE THEN

Detailverhalten

PB-Wahrheitsliteral. PB-logisch wahr wird als -1 dargestellt, wo PB-Wahrheitswerte erforderlich sind.

Praktische Verwendung

Verwenden Sie TRUE nur in der gezeigten Kontrollfluss- oder Ausdrucksposition. Der Test sollte die komplette Umgebungsform enthalten, damit der Scanner und der Parser die Position korrekt erkennen.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Diese Keywords haben nur in ihren erkannten Sprachpositionen die beabsichtigte Bedeutung. Ausserhalb dieser Positionen sollte der Parser nicht stillschweigend eine andere Semantik annehmen.

Verifiziertes Beispiel

Abgedeckt durch examples/basic/test_variant.pb (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TURTLE - PBXB64 Help

Startseite › BASIC-Frontend › Befehlsreferenz › Grafik & GUI › TURTLE
Hilfe zum PBXB64-Compiler

TURTLE

Kind: Befehl | Category: Grafik / LOGO Turtle

PBXB64 Status: AVAILABLE

Syntax

TURTLE befehl [argumente]
TURTLE TARGET h
TURTLE TARGET CURRENT
TURTLE TARGET BITMAP breite, hoehe TO h
TURTLE TARGET SAVE h, pfad$ [TO ok]
TURTLE TARGET END h
TURTLE EVAL ausdruck TO variable
TURTLE BEGIN
    LOGO-Anweisungen und TO-Prozeduren
TURTLE END

Beschreibung

TURTLE ist die getestete BASIC-Bruecke zur vorhandenen LOGO-Turtle-Zeichenruntime. Das Praefix ist in BASIC-Quelltext erforderlich; nackte LOGO-Woerter wie FD 10 bleiben LOGO-Syntax und werden vom BASIC-Frontend abgelehnt.

Zeichenbefehle verwenden das aktuelle GRAPHIC-Ziel, wenn eines ausgewaehlt ist. Gemeinsame Bitmap-Ziele initialisieren beim Anhangen den LOGO-Turtle-Zustand, sodass Pen-Down-Befehle wie FD in das ausgewaehlte Bitmap-Ziel zeichnen. TURTLE TARGET BITMAP erzeugt ein Bitmap-Ziel, waehlt es fuer Turtle-Zeichnung aus und gibt das Handle zurueck. TURTLE TARGET SAVE speichert ein Ziel als Bitmap-Datei, und TURTLE TARGET END gibt es frei.

Die fokussiert getestete Befehlsoberflaeche umfasst FD, FORWARD, BK, BACK, RT, LT, PU, PD, HT, ST, CS, CLEAN, HOME, SETPC, SETBG, SETH, PENSIZE, REPEAT mit literaler Anzahl und Befehlen in eckigen Klammern, MAKE, LOCAL, TURTLE, KAEFER, GECKO, SETTURTLE, TURTLESIZE und VECTORTURTLE.

TURTLE EVAL schreibt numerische LOGO-Abfragen oder mathematische Ausdruecke in eine BASIC-Variable. Die fokussiert getestete Ausdrucksbruecke umfasst XCOR, YCOR, HEADING, TOWARDS, SUM, DIFFERENCE, PRODUCT, QUOTIENT, BASIC-Zahlenausdruecke und LOGO-Variablen als :name.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL h AS QUAD
    LOCAL ok AS QUAD
    LOCAL heading AS DOUBLE

    TURTLE TARGET BITMAP 120, 120 TO h
    TURTLE SETPC 12
    TURTLE MAKE "X 40
    TURTLE REPEAT 4 [FD :X RT 90]
    TURTLE KAEFER
    TURTLE TURTLESIZE 32
    TURTLE EVAL HEADING TO heading
    TURTLE TARGET SAVE h, "turtle.bmp" TO ok
    TURTLE TARGET END h

    IF ok = 0 THEN FUNCTION = 1
END FUNCTION

TURTLE BEGIN / TURTLE END bettet einen fokussierten LOGO-Block in die aktuelle BASIC-Funktion ein. Die getestete Blockoberflaeche unterstuetzt MAKE, TO-Prozeduren mit :name-Parametern, Prozeduraufrufe, OUTPUT innerhalb eingebetteter Prozeduren und dieselben direkten Turtle-Zeichen-/Statusbefehle wie praefixierte TURTLE-Anweisungen.

Validierungsnachweis: Die registrierten pb_linkrun-Tests test_graphic_logo_shared_target, test_turtle_basic_direct, test_turtle_basic_state_eval, test_turtle_basic_images_repeat und test_turtle_begin_block pruefen Zeichnung in gemeinsame GRAPHIC-Bitmap-Ziele, Ziel-Speichern, Status-/Abfrageausdruecke, Variablen, Wiederholung, Markerauswahl und eingebettete Prozedurbloecke. Negative Tests pruefen, dass nackte LOGO-Woerter, fehlerhaftes Ziel-Speichern, unbekannte Unterbefehle, nicht geschlossene Bloecke und OUTPUT ausserhalb von Prozeduren geschlossen fehlschlagen.

Siehe auch

  • LOGO-Frontend
  • LOGO FD
  • LOGO REPEAT
  • GRAPHIC ATTACH
  • GRAPHIC SAVE

Vollständigkeitskriterien

Sprachübergreifende Themen sollen erklären, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Praktisches Beispiel

Für TURTLE soll ein Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und notwendige Includes, Bibliotheken oder Laufzeitbedingungen nennen.

Prüfschritte

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.


TXT.ADDTEXT - PBXB64 Help

Startseite › General Reference › TXT.ADDTEXT

TXT.ADDTEXT

Haengt ueber die TXT-Helfer-Laufzeit einen String an einen anderen an.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = TXT.ADDTEXT(text$, suffix$)

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Verwendung im Programm

Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Fehlerfaelle

TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Textfluss

Verwenden Sie die TXT-Familie mit eigenen Text-Handles und normalen Strings, mit den dokumentierten 1-basierten Positionen und der Oeffnen/Schliessen-Reihenfolge. Das Beispiel sollte Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand zeigen.

Fehlerhinweise

Der Helfer kann fehlschlagen, wenn das TXT-Handle geschlossen ist, die Position ausserhalb des Bereichs liegt oder der Aufrufer die falsche Mutationssemantik erwartet. Die Seite sollte angeben, ob die Funktion den Eingabestring, das Handle oder beide aendert.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    IF TXT.ADDTEXT("Alpha", "Beta") <> "AlphaBeta" THEN FUNCTION = 1
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TXT.ATTRIBUTE - PBXB64 Help

Startseite › General Reference › TXT.ATTRIBUTE

TXT.ATTRIBUTE

Liefert im aktuell getesteten begrenzten Kompatibilitaets-Subset 0.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

attr& = TXT.ATTRIBUTE(text$, name$)

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Verwendung im Programm

Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Fehlerfaelle

TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Textfluss

Verwenden Sie die TXT-Familie mit eigenen Text-Handles und normalen Strings, mit den dokumentierten 1-basierten Positionen und der Oeffnen/Schliessen-Reihenfolge. Das Beispiel sollte Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand zeigen.

Fehlerhinweise

Der Helfer kann fehlschlagen, wenn das TXT-Handle geschlossen ist, die Position ausserhalb des Bereichs liegt oder der Aufrufer die falsche Mutationssemantik erwartet. Die Seite sollte angeben, ob die Funktion den Eingabestring, das Handle oder beide aendert.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    IF TXT.ATTRIBUTE("Keep", "bold") <> 0 THEN FUNCTION = 1
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TXT.CLOSE - PBXB64 Help

Startseite › General Reference › TXT.CLOSE

TXT.CLOSE

Schliesst ein offenes TXT-Handle und gibt zugehoerigen Laufzeitzustand frei.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

TXT.CLOSE handle&

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Verwendung im Programm

Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Fehlerfaelle

TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Textfluss

Verwenden Sie die TXT-Familie mit eigenen Text-Handles und normalen Strings, mit den dokumentierten 1-basierten Positionen und der Oeffnen/Schliessen-Reihenfolge. Das Beispiel sollte Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand zeigen.

Fehlerhinweise

Der Helfer kann fehlschlagen, wenn das TXT-Handle geschlossen ist, die Position ausserhalb des Bereichs liegt oder der Aufrufer die falsche Mutationssemantik erwartet. Die Seite sollte angeben, ob die Funktion den Eingabestring, das Handle oder beide aendert.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    TXT.CLOSE h&
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TXT.COLOR - PBXB64 Help

Startseite › General Reference › TXT.COLOR

TXT.COLOR

Akzeptiert ein Farbargument und gibt im aktuellen String-Helfer-Subset den uebergebenen Text zurueck.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

text$ = TXT.COLOR(text$, color&)

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Verwendung im Programm

Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Fehlerfaelle

TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Textfluss

Verwenden Sie die TXT-Familie mit eigenen Text-Handles und normalen Strings, mit den dokumentierten 1-basierten Positionen und der Oeffnen/Schliessen-Reihenfolge. Das Beispiel sollte Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand zeigen.

Fehlerhinweise

Der Helfer kann fehlschlagen, wenn das TXT-Handle geschlossen ist, die Position ausserhalb des Bereichs liegt oder der Aufrufer die falsche Mutationssemantik erwartet. Die Seite sollte angeben, ob die Funktion den Eingabestring, das Handle oder beide aendert.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    IF TXT.COLOR("Keep", 12) <> "Keep" THEN FUNCTION = 1
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TXT.COUNT - PBXB64 Help

Startseite › General Reference › TXT.COUNT

TXT.COUNT

Liefert den vom TXT-Helfer gepflegten Zaehler fuer die geoeffnete Textquelle.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

count& = TXT.COUNT(handle&)

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Verwendung im Programm

Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Fehlerfaelle

TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Textfluss

Verwenden Sie die TXT-Familie mit eigenen Text-Handles und normalen Strings, mit den dokumentierten 1-basierten Positionen und der Oeffnen/Schliessen-Reihenfolge. Das Beispiel sollte Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand zeigen.

Fehlerhinweise

Der Helfer kann fehlschlagen, wenn das TXT-Handle geschlossen ist, die Position ausserhalb des Bereichs liegt oder der Aufrufer die falsche Mutationssemantik erwartet. Die Seite sollte angeben, ob die Funktion den Eingabestring, das Handle oder beide aendert.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    count& = TXT.COUNT(h&)
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TXT.DELETE - PBXB64 Help

Startseite › General Reference › TXT.DELETE

TXT.DELETE

Loescht einen 1-basierten Textbereich.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = TXT.DELETE(text$, start&, count&)

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Verwendung im Programm

Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Fehlerfaelle

TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Textfluss

Verwenden Sie die TXT-Familie mit eigenen Text-Handles und normalen Strings, mit den dokumentierten 1-basierten Positionen und der Oeffnen/Schliessen-Reihenfolge. Das Beispiel sollte Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand zeigen.

Fehlerhinweise

Der Helfer kann fehlschlagen, wenn das TXT-Handle geschlossen ist, die Position ausserhalb des Bereichs liegt oder der Aufrufer die falsche Mutationssemantik erwartet. Die Seite sollte angeben, ob die Funktion den Eingabestring, das Handle oder beide aendert.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    IF TXT.DELETE("AlphaBetaGamma", 6, 4) <> "AlphaGamma" THEN FUNCTION = 1
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TXT.FIND - PBXB64 Help

Startseite › General Reference › TXT.FIND

TXT.FIND

Liefert eine 1-basierte Fundposition oder 0, wenn der Text nicht gefunden wird.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

pos& = TXT.FIND(text$, find$)

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Verwendung im Programm

Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Fehlerfaelle

TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Textfluss

Verwenden Sie die TXT-Familie mit eigenen Text-Handles und normalen Strings, mit den dokumentierten 1-basierten Positionen und der Oeffnen/Schliessen-Reihenfolge. Das Beispiel sollte Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand zeigen.

Fehlerhinweise

Der Helfer kann fehlschlagen, wenn das TXT-Handle geschlossen ist, die Position ausserhalb des Bereichs liegt oder der Aufrufer die falsche Mutationssemantik erwartet. Die Seite sollte angeben, ob die Funktion den Eingabestring, das Handle oder beide aendert.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    IF TXT.FIND("AlphaBeta", "Beta") <> 6 THEN FUNCTION = 1
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TXT.FONT - PBXB64 Help

Startseite › General Reference › TXT.FONT

TXT.FONT

Akzeptiert Schriftargumente und gibt im aktuellen String-Helfer-Subset den uebergebenen Text zurueck.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

text$ = TXT.FONT(text$, face$, size&)

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Verwendung im Programm

Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Fehlerfaelle

TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Textfluss

Verwenden Sie die TXT-Familie mit eigenen Text-Handles und normalen Strings, mit den dokumentierten 1-basierten Positionen und der Oeffnen/Schliessen-Reihenfolge. Das Beispiel sollte Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand zeigen.

Fehlerhinweise

Der Helfer kann fehlschlagen, wenn das TXT-Handle geschlossen ist, die Position ausserhalb des Bereichs liegt oder der Aufrufer die falsche Mutationssemantik erwartet. Die Seite sollte angeben, ob die Funktion den Eingabestring, das Handle oder beide aendert.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    IF TXT.FONT("Keep", "Consolas", 11) <> "Keep" THEN FUNCTION = 1
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TXT.INDEX - PBXB64 Help

Startseite › General Reference › TXT.INDEX

TXT.INDEX

Liefert eine 1-basierte Fundposition oder 0, wenn der Text nicht gefunden wird.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

idx& = TXT.INDEX(text$, find$)

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Verwendung im Programm

Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Fehlerfaelle

TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Textfluss

Verwenden Sie die TXT-Familie mit eigenen Text-Handles und normalen Strings, mit den dokumentierten 1-basierten Positionen und der Oeffnen/Schliessen-Reihenfolge. Das Beispiel sollte Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand zeigen.

Fehlerhinweise

Der Helfer kann fehlschlagen, wenn das TXT-Handle geschlossen ist, die Position ausserhalb des Bereichs liegt oder der Aufrufer die falsche Mutationssemantik erwartet. Die Seite sollte angeben, ob die Funktion den Eingabestring, das Handle oder beide aendert.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    IF TXT.INDEX("AlphaBeta", "Beta") <> 6 THEN FUNCTION = 1
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TXT.INPUT - PBXB64 Help

Startseite › General Reference › TXT.INPUT

TXT.INPUT

Liest Text aus einem TXT-Handle in eine eigene dynamische STRING-Variable.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

TXT.INPUT handle&, target$

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Verwendung im Programm

Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Fehlerfaelle

TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Textfluss

Verwenden Sie die TXT-Familie mit eigenen Text-Handles und normalen Strings, mit den dokumentierten 1-basierten Positionen und der Oeffnen/Schliessen-Reihenfolge. Das Beispiel sollte Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand zeigen.

Fehlerhinweise

Der Helfer kann fehlschlagen, wenn das TXT-Handle geschlossen ist, die Position ausserhalb des Bereichs liegt oder der Aufrufer die falsche Mutationssemantik erwartet. Die Seite sollte angeben, ob die Funktion den Eingabestring, das Handle oder beide aendert.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    TXT.INPUT h&, line$
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TXT.INSERT - PBXB64 Help

Startseite › General Reference › TXT.INSERT

TXT.INSERT

Fuegt Text an einer 1-basierten Position ein.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = TXT.INSERT(text$, position&, insert$)

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Verwendung im Programm

Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Fehlerfaelle

TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Textfluss

Verwenden Sie die TXT-Familie mit eigenen Text-Handles und normalen Strings, mit den dokumentierten 1-basierten Positionen und der Oeffnen/Schliessen-Reihenfolge. Das Beispiel sollte Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand zeigen.

Fehlerhinweise

Der Helfer kann fehlschlagen, wenn das TXT-Handle geschlossen ist, die Position ausserhalb des Bereichs liegt oder der Aufrufer die falsche Mutationssemantik erwartet. Die Seite sollte angeben, ob die Funktion den Eingabestring, das Handle oder beide aendert.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    IF TXT.INSERT("AlphaGamma", 6, "Beta") <> "AlphaBetaGamma" THEN FUNCTION = 1
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TXT.LINE - PBXB64 Help

Startseite › General Reference › TXT.LINE

TXT.LINE

Liefert eine CR/LF-getrennte Zeile aus einem String. Zeilennummern sind 1-basiert.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

line$ = TXT.LINE(text$, line&)

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Verwendung im Programm

Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Fehlerfaelle

TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Textfluss

Verwenden Sie die TXT-Familie mit eigenen Text-Handles und normalen Strings, mit den dokumentierten 1-basierten Positionen und der Oeffnen/Schliessen-Reihenfolge. Das Beispiel sollte Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand zeigen.

Fehlerhinweise

Der Helfer kann fehlschlagen, wenn das TXT-Handle geschlossen ist, die Position ausserhalb des Bereichs liegt oder der Aufrufer die falsche Mutationssemantik erwartet. Die Seite sollte angeben, ob die Funktion den Eingabestring, das Handle oder beide aendert.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    IF TXT.LINE("A" + CHR$(13) + CHR$(10) + "B", 2) <> "B" THEN FUNCTION = 1
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TXT.OPEN - PBXB64 Help

Startseite › General Reference › TXT.OPEN

TXT.OPEN

Oeffnet eine Textdatei ueber das TXT-Pseudoobjekt fuer INPUT, OUTPUT oder APPEND.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

TXT.OPEN path$, mode$ TO handle&

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Verwendung im Programm

Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Fehlerfaelle

TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Textfluss

Verwenden Sie die TXT-Familie mit eigenen Text-Handles und normalen Strings, mit den dokumentierten 1-basierten Positionen und der Oeffnen/Schliessen-Reihenfolge. Das Beispiel sollte Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand zeigen.

Fehlerhinweise

Der Helfer kann fehlschlagen, wenn das TXT-Handle geschlossen ist, die Position ausserhalb des Bereichs liegt oder der Aufrufer die falsche Mutationssemantik erwartet. Die Seite sollte angeben, ob die Funktion den Eingabestring, das Handle oder beide aendert.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    TXT.OPEN "out.txt", "OUTPUT" TO h&
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TXT.PRINT - PBXB64 Help

Startseite › General Reference › TXT.PRINT

TXT.PRINT

Schreibt eine Zeile oder einen Textabschnitt ueber ein offenes TXT-Handle.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

TXT.PRINT handle&, text$

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Verwendung im Programm

Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Fehlerfaelle

TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Textfluss

Verwenden Sie die TXT-Familie mit eigenen Text-Handles und normalen Strings, mit den dokumentierten 1-basierten Positionen und der Oeffnen/Schliessen-Reihenfolge. Das Beispiel sollte Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand zeigen.

Fehlerhinweise

Der Helfer kann fehlschlagen, wenn das TXT-Handle geschlossen ist, die Position ausserhalb des Bereichs liegt oder der Aufrufer die falsche Mutationssemantik erwartet. Die Seite sollte angeben, ob die Funktion den Eingabestring, das Handle oder beide aendert.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    TXT.PRINT h&, "line"
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


TXT Pseudo Object - PBXB64 Compiler Help

Startseite › General Reference › TXT Pseudo Object

TXT Pseudo Object

The TXT pseudo object represents text-related helper operations in older PowerBASIC documentation. In PBXB64 help it is documented as a compatibility topic for reading legacy code and examples.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

The TXT pseudo object represents text-related helper operations in older PowerBASIC documentation. In PBXB64 help it is documented as a compatibility topic for reading legacy code and examples.

Verwendung in PBXB64

When porting TXT-style code, replace implicit behavior with explicit string variables, buffer lengths, and API calls where possible.

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.

Zurück zum Befehlsindex

Kind: Reference topic | Category: TXT Runtime Helpers

PBXB64 Status: AVAILABLE

Description

Overview for TXT pseudo-object helpers. The individual TXT.* pages document the tested string and text-handle forms.

Syntax

TXT.METHOD arguments

Validation Evidence

Validation evidence: Covered by tests/pb/test_txt_editor_methods.pb and generated TXT method pages.

Example

line$ = TXT.LINE(text$, 1)

See Also

  • cmd_txt_line.html
  • cmd_txt_select.html
  • cmd_txt_find.html


TXT.REPLACE - PBXB64 Help

Startseite › General Reference › TXT.REPLACE

TXT.REPLACE

Fuehrt globale, nicht ueberlappende String-Ersetzung aus.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = TXT.REPLACE(text$, old$, new$)

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Verwendung im Programm

Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Fehlerfaelle

TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Textfluss

Verwenden Sie die TXT-Familie mit eigenen Text-Handles und normalen Strings, mit den dokumentierten 1-basierten Positionen und der Oeffnen/Schliessen-Reihenfolge. Das Beispiel sollte Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand zeigen.

Fehlerhinweise

Der Helfer kann fehlschlagen, wenn das TXT-Handle geschlossen ist, die Position ausserhalb des Bereichs liegt oder der Aufrufer die falsche Mutationssemantik erwartet. Die Seite sollte angeben, ob die Funktion den Eingabestring, das Handle oder beide aendert.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    IF TXT.REPLACE("one two one", "one", "1") <> "1 two 1" THEN FUNCTION = 1
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TXT.SELECT - PBXB64 Help

Startseite › General Reference › TXT.SELECT

TXT.SELECT

Liefert einen 1-basierten Teilstring aus dem uebergebenen Text.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

part$ = TXT.SELECT(text$, start&, count&)

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Verwendung im Programm

Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Fehlerfaelle

TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Textfluss

Verwenden Sie die TXT-Familie mit eigenen Text-Handles und normalen Strings, mit den dokumentierten 1-basierten Positionen und der Oeffnen/Schliessen-Reihenfolge. Das Beispiel sollte Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand zeigen.

Fehlerhinweise

Der Helfer kann fehlschlagen, wenn das TXT-Handle geschlossen ist, die Position ausserhalb des Bereichs liegt oder der Aufrufer die falsche Mutationssemantik erwartet. Die Seite sollte angeben, ob die Funktion den Eingabestring, das Handle oder beide aendert.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    IF TXT.SELECT("AlphaBeta", 6, 4) <> "Beta" THEN FUNCTION = 1
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TXT.SELTEXT - PBXB64 Help

Startseite › General Reference › TXT.SELTEXT

TXT.SELTEXT

Gibt im aktuellen String-Helfer-Subset den uebergebenen Text zurueck.

Kind: Runtime method | Category: Memory / TXT / COM Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

text$ = TXT.SELTEXT(text$)

Beschreibung

Diese Methode besitzt eine eigene Seite, weil sie durch die Validierungsmatrix abgedeckt ist und eine sichtbare Befehlsoberflaeche darstellt. Beispiele sollen klein bleiben und Rueckgabewerte pruefen, wenn die Laufzeit fehlschlagen kann. Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Verwendung im Programm

Die TXT-Helferfamilie arbeitet mit eigenen Text-Handles und normalen Strings. Verwenden Sie die dokumentierten 1-basierten Positionen und die exakte Oeffnen/Schliessen-Reihenfolge, damit Beispiele Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand beweisen koennen. Behandeln Sie das Handle als Zustandstraeger und die String-Argumente als Nutzdaten.

Fehlerfaelle

TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Textfluss

Verwenden Sie die TXT-Familie mit eigenen Text-Handles und normalen Strings, mit den dokumentierten 1-basierten Positionen und der Oeffnen/Schliessen-Reihenfolge. Das Beispiel sollte Lebensdauer, Ruecklesen und Rueckgabewerte ohne Benutzerzustand zeigen.

Fehlerhinweise

Der Helfer kann fehlschlagen, wenn das TXT-Handle geschlossen ist, die Position ausserhalb des Bereichs liegt oder der Aufrufer die falsche Mutationssemantik erwartet. Die Seite sollte angeben, ob die Funktion den Eingabestring, das Handle oder beide aendert.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    IF TXT.SELTEXT("Keep") <> "Keep" THEN FUNCTION = 1
END FUNCTION

Verifiziertes Beispiel

Durch die benannte Validierungszeile fuer diesen Helfer belegt; siehe docs/FEATURE_MATRIX.md fuer den aktuellen Laufzeitmethoden-Eintrag.

Grenzen

Diese Seite dokumentiert die aktuell getestete PBXB64-Teilmenge. Weitere Objektmethoden-Schreibweisen, GUI-Editor-Integrationsdetails oder Windows-Speicher-Sonderfaelle benoetigen eigene Tests, bevor sie als vollstaendig dokumentiert werden. TXT-Helferbeispiele sollen angeben, ob die Operation den uebergebenen String, das TXT-Handle oder beides aendert, ob Zeilenenden erhalten bleiben und was bei Leertext oder nicht gefundenen Positionen passiert. Wenn ein Helfer eine Position meldet, soll die Seite sagen, ob sie 1-basiert ist und ob 0 'nicht gefunden' bedeutet.

Siehe auch

  • Familienreferenz
  • BASIC Language Reference

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TYPE SET – PBXB64-Compiler-Hilfe

Startseite › Funktionen › TYPE SET

TYP EINGESTELLT

Weisen Sie den Wert von a zu

Typ:Anweisung |Kategorie:Typen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

TYPE SET typevar = { typevar | ByteStringExpr$ } [USING ustring_expression ]

Beschreibung

TYPE SET dient in erster Linie dazu, den Wert eines benutzerdefinierten Typs (UDT) einer anderen Klasse benutzerdefinierter Typen zuzuweisen. Darüber hinaus kann TYPE SET verwendet werden, um einem UDT einen Zeichenfolgenausdruck ( ByteStringExpr$ ) zuzuweisen, obwohl es im Allgemeinen nicht geeignet ist, eine breite Unicode-Zeichenfolge zuzuweisen.

Alle nach der Zuweisung verbleibenden Byte-Positionen werden in der Zieltypvariable mit dem ersten Zeichen des USING-String-Ausdrucks oder mit binären Nullen, falls nicht angegeben, aufgefüllt (aufgefüllt).

PBXB64 implementation: String-zu-UDT-Byte-Kopie, Null oder USING Auffüllen und UDT-zu-UDT-Byte-Kopieren sind im nativen Compilerpfad implementiert.

Test: test_type_set.pb.

Siehe auch

  • CSET
  • CSET$
  • LET (mit Typen)
  • LSET
  • LSET$
  • RSET
  • RSET$
  • TYP/ENDTYP

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


UBOUND – PBXB64-Compiler-Hilfe

Startseite › Funktionen › UBOUND

UBOUND

Geben Sie den größtmöglichen Betrag zurück

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

y = UBOUND( array [( dimension )])
y = UBOUND( array , dimension )

Beschreibung

array ist das interessierende Array. Dimension ist ein ganzzahliger Wert oder Ausdruck von 1 bis zur Anzahl der Dimensionen im Array; Es gibt an, welcher obere Grenzwert der Dimension zurückgegeben wird. Wenn Sie die Dimension weglassen, wird standardmäßig 1 (die erste Dimension) verwendet. Um die Untergrenze der Dimension eines Arrays zu ermitteln, verwenden Sie die Funktion LBOUND. Verwenden Sie LBOUND und UBOUND zusammen, um die Größe eines Arrays zu bestimmen. UBOUND eines nicht dimensionierten Arrays gibt -1 zurück, sodass UBOUND(array) - LBOUND(array) + 1 Null (0) für ein solches Array ergibt.

Einschränkungen

UBOUND kann nicht für Arrays innerhalb benutzerdefinierter Typen verwendet werden.

Siehe auch

  • ARRAYATTR
  • DIM
  • LBOUND
  • REDIM

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UCODE$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › UCODE$

UCODE$

Übersetzt

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

a$ = UCODE$( AnsiStrExpression [, CodePage& ])

Beschreibung

Diese Version von PowerBASIC führt alle Konvertierungen zwischen ANSI-Strings und UNICODE-Strings automatisch durch. Zum Beispiel:

MyWideString$$ = MyAnsiString$

In diesem Fall werden die ANSI-Zeichen beim Speichern in MyWideString$ transparent in WIDE UNICODE-Zeichen konvertiert. Sie sollten hier keine UCODE$-Funktion einfügen. Die einfache Tatsache, dass die Variablen unterschiedlichen Typs sind (ANSI/WIDE), führt dazu, dass der Compiler alle Konvertierungen für Sie durchführt, wann immer sie benötigt werden.

Natürlich war diese automatische Konvertierung in früheren Versionen des Compilers nicht verfügbar. In der Vergangenheit wurden keine WIDE-UNICODE-Variablen angeboten, daher war es notwendig, breite Zeichen in Standard-Byte-Strings zu erzwingen, wenn UNICODE benötigt wurde. Die Funktionen ACODE$ und UCODE$ werden ausschließlich zu diesem Zweck verwendet: zur Unterstützung älterer Programme, die Zeichenfolgen auf diese Weise berechnet haben.

Neue PowerBASIC-Programme und Updates Ihrer älteren PowerBASIC-Programme sollten die neuen WIDE UNICODE-Variablen verwenden, die jetzt verfügbar sind.

UCODE$ geht davon aus, dass die AnsiStrExpression ANSI-Bytezeichen enthält, die in einer ANSI-Bytezeichenfolge gespeichert sind. Es wandelt sie in WIDE UNICODE-Zeichen um und gibt sie als ANSI-Byte-String zurück. Um eine UNICODE-Bytezeichenfolge in eine ANSI-Bytezeichenfolge umzuwandeln, verwenden Sie die Funktion ACODE$.

Wenn der optionale Parameter CodePage& vorhanden ist, stellt er die Codepage dar, die für den Konvertierungsprozess verwendet werden soll. Wenn nicht angegeben, wird die Standardcodepage für das Gebietsschema des ausführenden Computers verwendet.

Unicode-Zeichenfolgen erfordern zwei Bytes zur Darstellung eines Unicode-Zeichens, während ANSI-Zeichenfolgen (das native PowerBASIC-Zeichenfolgenformat) ein Byte zur Darstellung eines Zeichens verwenden. Daher gibt UCODE$ eine Zeichenfolge zurück, die doppelt so viele Bytes wie die ANSI-Zeichenfolge hat, aber die gleiche Anzahl an Zeichen darstellt.

Siehe auch

  • ACODE$
  • UCODEPAGE

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UCODEPAGE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › UCODEPAGE

UCODEPAGE

Legen Sie die Standard-Codepage fest, die verwendet wird

Typ:Anweisung |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

UCODEPAGE ANSI|OEM| NumExpr [TO PrevPage& ]

Beschreibung

PowerBASIC führt viele Konvertierungen zwischen ANSI- und UNICODE-Zeichenfolgen (Breitzeichen) durch. UCODEPAGE gibt die CodePage an, die für diese Übersetzungen verwendet werden soll. Der Standardwert ist UCODEPAGE ANSI, der die ANSI-Codepage des Systems für Ihren Computer verwendet. UCODEPAGE OEM verwendet die System-OEM-Codepage für Ihren Computer, während ein numerischer Ausdruck eine bestimmte Codepage Ihrer Wahl angeben kann.

Wenn die optionale TO-Klausel verwendet wird, wird die Nummer der vorherigen Standard-CodePage der durch PrevPage& angegebenen Long-Integer-Variablen zugewiesen. Indem Sie die vorherige Codepage speichern, können Sie sie bei Bedarf später wiederherstellen.

Diese Anweisung ändert nicht die von Ihrem Computer verwendete Codepage. Es gibt an, welche Codepage PowerBASIC für ANSI/UNICODE-Konvertierungen verwenden soll.

Standardmäßig wird die ANSI-Codepage des Systems verwendet, um die Zeichenübersetzung abzubilden. Dies funktioniert im Allgemeinen sehr gut, da es die übliche Codepage für Ihre Primärsprache darstellt. Wenn Sie jedoch eine CONSOLE-Anwendung kompilieren, die die höherwertigen ANSI-Codes CHR$ (128) bis CHR$(255) zum Zeichnen von Linien und einige internationale Zeichen verwendet, sollten Sie eine OEM-Codepage deklarieren, indem Sie UCODEPAGE OEM am Anfang Ihrer MAIN-Funktion platzieren.

Die CodePage-Spezifikation wird Thread für Thread gepflegt. Beim Programmstart ist die Standard-ANSI-CodePage des Systems. Wenn ein neuer Thread gestartet wird, erbt er die vom Hauptthread verwendete CodePage.

Siehe auch

  • ACODE$
  • UCODE$

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UDP CLOSE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › UDP CLOSE

UDP CLOSE

Schließen Sie eine zuvor geöffnete Datei

Typ:Anweisung |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

UDP CLOSE [#] fNum&

Beschreibung

Schließen Sie den zuvor geöffneten UDP/IP-Port, der durch fNum& angegeben wurde.

Siehe auch

  • TCP- und UDP-Kommunikation
  • TCP CLOSE
  • UDP-BENACHRICHTIGUNG
  • UDP OFFEN
  • UDP RECV
  • UDP SENDEN

Kommunikationsprüfung

Serielle, TCP- und UDP-Seiten sollen Endpoint-Aufbau, Blocking-Verhalten, Timeout-Verhalten, Pufferbesitz und Cleanup nennen. Ein vollständiges Beispiel deckt Open/Create, Senden oder Empfangen, Close und einen vorhersagbaren Fehler wie einen ungültigen Endpoint ab.

Laufzeitvoraussetzungen

Netzwerkbeispiele können Firewall-Berechtigungen und freie Ports benötigen. Serielle Beispiele erfordern ein vorhandenes COM-Gerät oder einen dokumentierten Loopback/Testadapter.

Diagnosen

Erfassen Sie Rückgabewerte und Windows-Fehlercodes, wo verfügbar, damit Kommunikationsfehler auswertbar statt still sind.

Umfangshinweise

Wenn die Seite eine Familie statt eines einzelnen Befehls beschreibt, nennen Sie das konkrete Senden, Empfangen, Prüfen, Verbinden oder Schließen, das das Verhalten belegt, und sagen Sie, ob derselbe Socket oder Handle nach dem Aufruf weiterverwendet werden darf. Dadurch wird die Seite zu einem nutzbaren Laufzeitvertrag statt zu einem allgemeinen Protokollhinweis.


UDP NOTIFY – PBXB64-Compiler-Hilfe

Startseite › Funktionen › UDP NOTIFY

UDP-BENACHRICHTIGUNG

Bestimmen Sie welche

Typ:Anweisung |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

UDP NOTIFY [#] fNum& , {SEND | RECV | CLOSE} TO hWnd& AS wMsg&

Beschreibung

Gibt an, welche Ereignisse (SEND, RECV und CLOSE) eine wMsg&-Benachrichtigungsnachricht generieren, die an die Fenster-/Dialogprozedur (CALLBACK) gesendet wird, die durch das Fensterhandle hWnd& identifiziert wird.

Ihr Programm definiert den wMsg&-Wert. Dieser Wert sollte gleich oder größer als %WM_USER + 500 sein, um Konflikte mit gängigen Windows-Rückrufnachrichtenwerten zu vermeiden.

Wenn die benannte Callback-Funktion die wMsg&-Benachrichtigung empfängt, identifiziert der wParam&-Parameter das Betriebssystem-Handle des Sockets (siehe FILEATTR ). Das niederwertige Wort von lParam& gibt den Code des Ereignisses an (siehe Tabelle unten), und das höherwertige Wort von lParam& enthält den Fehlercode (falls vorhanden).

LO(WORD, lParam& )

Definition

%FD_READ

Daten stehen zum Lesen aus dem Socket zur Verfügung.

%FD_WRITE

Der Socket ist zum Schreiben von Daten bereit.

%FD_CLOSE

Der Socket wurde geschlossen.

Benachrichtigungsnachrichten kommen nicht in unverminderten oder kontinuierlichen Strömen an. Das heißt, sobald eine bestimmte Benachrichtigungsnachricht eintrifft, wird sie nicht erneut gesendet, bis auf die ursprüngliche Nachricht reagiert wird. Wenn beispielsweise eine %FD_READ-Benachrichtigung für einen bestimmten Socket empfangen wird, wird sie erst erneut gesendet, nachdem eine UDP-RECV-Anweisung ausgeführt wurde.

Die Winsock-Fehlercodes werden in WINSOCK2.INC mit dem Präfix %WSAE aufgeführt.

Siehe auch

  • DATEIATTR
  • TCP- und UDP-Kommunikation
  • TCP-BENACHRICHTIGUNG
  • UDP CLOSE
  • UDP OFFEN
  • UDP RECV
  • UDP SENDEN

Kommunikationsprüfung

Serielle, TCP- und UDP-Seiten sollen Endpoint-Aufbau, Blocking-Verhalten, Timeout-Verhalten, Pufferbesitz und Cleanup nennen. Ein vollständiges Beispiel deckt Open/Create, Senden oder Empfangen, Close und einen vorhersagbaren Fehler wie einen ungültigen Endpoint ab.

Laufzeitvoraussetzungen

Netzwerkbeispiele können Firewall-Berechtigungen und freie Ports benötigen. Serielle Beispiele erfordern ein vorhandenes COM-Gerät oder einen dokumentierten Loopback/Testadapter.

Diagnosen

Erfassen Sie Rückgabewerte und Windows-Fehlercodes, wo verfügbar, damit Kommunikationsfehler auswertbar statt still sind.

Umfangshinweise

Wenn die Seite eine Familie statt eines einzelnen Befehls beschreibt, nennen Sie das konkrete Senden, Empfangen, Prüfen, Verbinden oder Schließen, das das Verhalten belegt, und sagen Sie, ob derselbe Socket oder Handle nach dem Aufruf weiterverwendet werden darf. Dadurch wird die Seite zu einem nutzbaren Laufzeitvertrag statt zu einem allgemeinen Protokollhinweis.


UDP OPEN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › UDP OPEN

UDP OFFEN

Erstellen Sie einen Socket für eine Anwendung, um mit a zu kommunizieren

Typ:Anweisung |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

UDP OPEN [PORT p& ] AS [#] fNum& [TIMEOUT timeoutval& ]

Beschreibung

Öffnen Sie einen UDP-Socket (Port oder Dienst) für die UDP-Kommunikation. FNum& ist eine Dateinummer wie z. B. #1 oder eine Variable mit einem Wert, der mit der Funktion FREEFILE erhalten wurde.

Wenn PORT p& angegeben ist, wird der Socket als Server geöffnet, der UDP-Daten empfangen kann. Verwenden Sie die UDP NOTIFY-Anweisung, um Serverbenachrichtigungen vom Socket zu empfangen, damit die Daten abgerufen werden können. Zu den gängigen Portnummern gehören 7 (Echo, siehe RFC 862); 37 (Zeit, siehe RFC868); und 123 (NTP – RFC1305).

AUSZEIT

Mit der Option TIMEOUT können Sie angeben, wie lange (in Millisekunden (mSek)) ein UDP-SEND/RECV-Vorgang auf den Abschluss warten soll. Wenn die angegebene Anzahl von Millisekunden verstreicht, schlägt der UDP-Vorgang fehl und die Systemvariable ERR wird so eingestellt, dass sie einen Laufzeitfehler 24 („Geräte-Timeout“) anzeigt. Das Standard-Timeout beträgt 60.000 Millisekunden (60 Sekunden).

Siehe auch

  • TCP- und UDP-Kommunikation
  • FREEFILE
  • TCP OFFEN
  • UDP CLOSE
  • UDP-BENACHRICHTIGUNG
  • UDP RECV
  • UDP SENDEN

Kommunikationsprüfung

Serielle, TCP- und UDP-Seiten sollen Endpoint-Aufbau, Blocking-Verhalten, Timeout-Verhalten, Pufferbesitz und Cleanup nennen. Ein vollständiges Beispiel deckt Open/Create, Senden oder Empfangen, Close und einen vorhersagbaren Fehler wie einen ungültigen Endpoint ab.

Laufzeitvoraussetzungen

Netzwerkbeispiele können Firewall-Berechtigungen und freie Ports benötigen. Serielle Beispiele erfordern ein vorhandenes COM-Gerät oder einen dokumentierten Loopback/Testadapter.

Diagnosen

Erfassen Sie Rückgabewerte und Windows-Fehlercodes, wo verfügbar, damit Kommunikationsfehler auswertbar statt still sind.

Umfangshinweise

Wenn die Seite eine Familie statt eines einzelnen Befehls beschreibt, nennen Sie das konkrete Senden, Empfangen, Prüfen, Verbinden oder Schließen, das das Verhalten belegt, und sagen Sie, ob derselbe Socket oder Handle nach dem Aufruf weiterverwendet werden darf. Dadurch wird die Seite zu einem nutzbaren Laufzeitvertrag statt zu einem allgemeinen Protokollhinweis.


UDP RECV – PBXB64-Compiler-Hilfe

Startseite › Funktionen › UDP RECV

UDP RECV

Empfangen Sie Daten von einem zuvor geöffneten

Typ:Anweisung |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

UDP RECV [#] fNum& , FROM ip& , pNum& , Buffer$

Beschreibung

Empfangen Sie alle Bytes vom zuvor geöffneten UDP-Port, der durch fNum& angegeben wurde, und platzieren Sie sie in Buffer$ . Die IP-Adresse, die das UDP-Paket gesendet hat, wird in die Variable ip& eingefügt, und die Portnummer wird in die Variable pNum& eingefügt.

ip& und pNum& können anschließend verwendet werden, um als Reaktion auf empfangene Daten Daten zurückzusenden.

UDP RECV ist eine blockierende Anweisung. Das heißt, die Ausführung wird erst fortgesetzt, wenn entweder Daten aus dem Socket abgerufen werden oder die Zeitüberschreitungsperiode abgelaufen ist.

Tritt ein Timeout auf, wird ein Laufzeitfehler 24 („Device Timeout“) generiert und in der Systemvariablen ERR abgelegt. Informationen zum Festlegen des UDP-Socket-Timeout-Werts finden Sie unter UDP OPEN.

Siehe auch

  • TCP- und UDP-Kommunikation
  • TCP RECV
  • UDP CLOSE
  • UDP-BENACHRICHTIGUNG
  • UDP OFFEN
  • UDP SENDEN

Kommunikationsprüfung

Serielle, TCP- und UDP-Seiten sollen Endpoint-Aufbau, Blocking-Verhalten, Timeout-Verhalten, Pufferbesitz und Cleanup nennen. Ein vollständiges Beispiel deckt Open/Create, Senden oder Empfangen, Close und einen vorhersagbaren Fehler wie einen ungültigen Endpoint ab.

Laufzeitvoraussetzungen

Netzwerkbeispiele können Firewall-Berechtigungen und freie Ports benötigen. Serielle Beispiele erfordern ein vorhandenes COM-Gerät oder einen dokumentierten Loopback/Testadapter.

Diagnosen

Erfassen Sie Rückgabewerte und Windows-Fehlercodes, wo verfügbar, damit Kommunikationsfehler auswertbar statt still sind.

Umfangshinweise

Wenn die Seite eine Familie statt eines einzelnen Befehls beschreibt, nennen Sie das konkrete Senden, Empfangen, Prüfen, Verbinden oder Schließen, das das Verhalten belegt, und sagen Sie, ob derselbe Socket oder Handle nach dem Aufruf weiterverwendet werden darf. Dadurch wird die Seite zu einem nutzbaren Laufzeitvertrag statt zu einem allgemeinen Protokollhinweis.


UDP SEND – PBXB64-Compiler-Hilfe

Startseite › Funktionen › UDP SEND

UDP SENDEN

Senden Sie eine Zeichenfolge

Typ:Anweisung |Kategorie:Kommunikation

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

UDP SEND [#] fNum& , AT ip& , pNum& , string_expression

Beschreibung

Schreiben Sie den angegebenen string_expression an den UDP/IP-Port pNum& an der in ip& angegebenen IP-Adresse und verwenden Sie dabei die durch fNum& angegebene UDP-Verbindung.

Siehe auch

  • TCP- und UDP-Kommunikation
  • TCP SENDEN
  • UDP CLOSE
  • UDP-BENACHRICHTIGUNG
  • UDP OFFEN
  • UDP RECV

Kommunikationsprüfung

Serielle, TCP- und UDP-Seiten sollen Endpoint-Aufbau, Blocking-Verhalten, Timeout-Verhalten, Pufferbesitz und Cleanup nennen. Ein vollständiges Beispiel deckt Open/Create, Senden oder Empfangen, Close und einen vorhersagbaren Fehler wie einen ungültigen Endpoint ab.

Laufzeitvoraussetzungen

Netzwerkbeispiele können Firewall-Berechtigungen und freie Ports benötigen. Serielle Beispiele erfordern ein vorhandenes COM-Gerät oder einen dokumentierten Loopback/Testadapter.

Diagnosen

Erfassen Sie Rückgabewerte und Windows-Fehlercodes, wo verfügbar, damit Kommunikationsfehler auswertbar statt still sind.

Umfangshinweise

Wenn die Seite eine Familie statt eines einzelnen Befehls beschreibt, nennen Sie das konkrete Senden, Empfangen, Prüfen, Verbinden oder Schließen, das das Verhalten belegt, und sagen Sie, ob derselbe Socket oder Handle nach dem Aufruf weiterverwendet werden darf. Dadurch wird die Seite zu einem nutzbaren Laufzeitvertrag statt zu einem allgemeinen Protokollhinweis.


UDT-Beispiele – PBXB64-Compiler-Hilfe

Startseite › Funktionen › UDT-Beispiele

Beispiele für benutzerdefinierte Typen (UDT).

Vollständige, kopier- und einfügbare Beispiele für TYPE/END TYPE, Mitgliedszugriff, Arrays von UDTs, verschachtelte UDTs, Bitfelder und UNION.

Typ: Beispiele | Kategorie: Grundlegende Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Beispiel 1: Einfaches UDT – Studentendatensatz

#COMPILE EXE
#DIM ALL

TYPE StudentRec
  ID        AS LONG
  Name      AS STRING * 32
  Score     AS SINGLE
END TYPE

FUNCTION PBMAIN() AS LONG
  LOCAL s AS StudentRec
  s.ID    = 42
  s.Name  = "Alice Smith"
  s.Score = 95.5

  PRINT s.ID; ", "; s.Name; ", "; s.Score

  FUNCTION = 0
END FUNCTION

Beispiel 2: Array von UDTs

#COMPILE EXE
#DIM ALL

TYPE Point
  X AS LONG
  Y AS LONG
END TYPE

FUNCTION PBMAIN() AS LONG
  LOCAL i AS LONG
  DIM pts(1 TO 3) AS Point

  pts(1).X = 10 : pts(1).Y = 20
  pts(2).X = 30 : pts(2).Y = 40
  pts(3).X = 50 : pts(3).Y = 60

  FOR i = 1 TO 3
    PRINT "Point "; i; " = ("; pts(i).X; ", "; pts(i).Y; ")"
  NEXT i

  FUNCTION = 0
END FUNCTION

Beispiel 3: UDT mit Member-Array

#COMPILE EXE
#DIM ALL

TYPE ScoreSheet
  StudentName AS STRING * 24
  Scores(0 TO 4) AS LONG   ' 5 scores
END TYPE

FUNCTION PBMAIN() AS LONG
  LOCAL s AS ScoreSheet
  LOCAL i AS LONG

  s.StudentName = "Bob"
  s.Scores(0) = 78
  s.Scores(1) = 82
  s.Scores(2) = 91
  s.Scores(3) = 88
  s.Scores(4) = 76

  PRINT s.StudentName
  FOR i = 0 TO 4
    PRINT "  Score "; i; " = "; s.Scores(i)
  NEXT i

  FUNCTION = 0
END FUNCTION

Beispiel 4: Verschachtelter UDT (Struktur innerhalb der Struktur)

#COMPILE EXE
#DIM ALL

TYPE AddressRec
  Street  AS STRING * 32
  City    AS STRING * 20
  ZipCode AS LONG
END TYPE

TYPE PersonRec
  FullName  AS STRING * 32
  HomeAddr  AS AddressRec
  Age       AS LONG
END TYPE

FUNCTION PBMAIN() AS LONG
  LOCAL p AS PersonRec

  p.FullName            = "John Doe"
  p.HomeAddr.Street     = "123 Main St"
  p.HomeAddr.City       = "Springfield"
  p.HomeAddr.ZipCode    = 12345
  p.Age                 = 30

  PRINT p.FullName
  PRINT p.HomeAddr.Street; ", "; p.HomeAddr.City; " "; p.HomeAddr.ZipCode
  PRINT "Age: "; p.Age

  FUNCTION = 0
END FUNCTION

Beispiel 5: UDT mit Pointer-Member

#COMPILE EXE
#DIM ALL

TYPE PtrRec
  Count AS LONG
  Data  AS LONG PTR
END TYPE

FUNCTION PBMAIN() AS LONG
  LOCAL r AS PtrRec
  LOCAL buf(0 TO 4) AS LONG

  buf(0) = 10
  buf(1) = 20
  buf(2) = 30

  r.Count = 3
  r.Data  = VARPTR(buf(0))

  PRINT "Count = "; r.Count
  PRINT "Data(0) = "; @r.Data
  PRINT "Data(1) = "; @r.Data[1]
  PRINT "Data(2) = "; @r.Data[2]

  FUNCTION = 0
END FUNCTION

Beispiel 6: Bitvariablen in UDT

#COMPILE EXE
#DIM ALL

TYPE FlagsRec
  IsActive  AS BIT  * 1
  Priority  AS BIT  * 4
  Reserved  AS BIT  * 3
END TYPE

FUNCTION PBMAIN() AS LONG
  LOCAL f AS FlagsRec

  f.IsActive = 1
  f.Priority = 7
  f.Reserved = 0

  PRINT "IsActive = "; f.IsActive
  PRINT "Priority = "; f.Priority
  PRINT "Reserved = "; f.Reserved

  FUNCTION = 0
END FUNCTION

Beispiel 7: UNION / END UNION

#COMPILE EXE
#DIM ALL

UNION NumberUnion
  iVal AS LONG
  fVal AS SINGLE
END UNION

FUNCTION PBMAIN() AS LONG
  LOCAL u AS NumberUnion

  u.iVal = 1065353216   ' bit pattern for 1.0 as SINGLE
  PRINT "iVal = "; u.iVal
  PRINT "fVal = "; u.fVal

  FUNCTION = 0
END FUNCTION

Beispiel 8: UDT an Sub/Function übergeben

#COMPILE EXE
#DIM ALL

TYPE Rectangle
  X1 AS LONG
  Y1 AS LONG
  X2 AS LONG
  Y2 AS LONG
END TYPE

FUNCTION Area(r AS Rectangle) AS LONG
  FUNCTION = (r.X2 - r.X1) * (r.Y2 - r.Y1)
END FUNCTION

SUB PrintRect(r AS Rectangle)
  PRINT "Rect: ("; r.X1; ", "; r.Y1; ") - ("; r.X2; ", "; r.Y2; ")"
END SUB

FUNCTION PBMAIN() AS LONG
  LOCAL rc AS Rectangle
  rc.X1 = 0  : rc.Y1 = 0
  rc.X2 = 10 : rc.Y2 = 20

  PrintRect(rc)
  PRINT "Area = "; Area(rc)

  FUNCTION = 0
END FUNCTION

Beispiel 9: UDT mit DWORD-Ausrichtung

#COMPILE EXE
#DIM ALL

TYPE AlignedRec DWORD
  A AS BYTE
  B AS LONG
  C AS BYTE
END TYPE

FUNCTION PBMAIN() AS LONG
  LOCAL r AS AlignedRec
  PRINT "Size of AlignedRec = "; SIZEOF(r); " bytes"
  ' With DWORD alignment: A(1) + padding(3) + B(4) + C(1) + padding(3) = 12 bytes

  FUNCTION = 0
END FUNCTION

Siehe auch

  • TYP/ENDTYP — Syntax und Referenz
  • Benutzerdefinierte Typen — Konzeptioneller Überblick
  • UNION/ENDUNION — Union-Syntax
  • DIM — Variablendeklaration
  • LEN / SIZEOF — Größenabfragen

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Beispiele für benutzerdefinierte Typen (UDT). soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Beispiele für benutzerdefinierte Typen (UDT). mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


UNB - Unlimited-Binary-Complex-Speicher verwenden — PBXB64 Help

Startseite › General Reference › UNB - Unlimited-Binary-Complex-Speicher verwenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

UNB - Unlimited-Binary-Complex-Speicher verwenden

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

LOCAL b AS UNB

Detailverhalten

Stringgestuetztes Unlimited-Binary-/Complex-Familienmitglied der PBXB64-UN-Runtime.

Praktische Verwendung

Verwenden Sie diese Schreibweise in Deklarationen oder Typpositionen, in denen die entsprechende Unlimited-/String-Kompatibilitaet erwartet wird. Die semantischen Details sollten mit einem eigenen Laufzeitnachweis belegt werden.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Verwechseln Sie diese Typkeywords nicht mit freien Bezeichnern oder Laufzeitwerten. Wenn der Zielkontext die Type-Position nicht erwartet, muss die Quelle entsprechend angepasst werden.

Verifiziertes Beispiel

Abgedeckt durch examples/basic/test_un_string_backed.pb (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UNBASE64$ - PBXB64 Help

Startseite › General Reference › UNBASE64$

UNBASE64$

Dekodiert Base64-Text zur urspruenglichen Byte-Zeichenkette.

Kind: Runtime helper | Category: WEB / Runtime Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

plain$ = UNBASE64$(encoded$)

Beschreibung

Diese eigene Seite stellt sicher, dass Befehlsuche, Stichwortindex und direkte Dateinamenpruefung die getestete Laufzeitfunktion unmittelbar finden. Die gruppierte WEB-Seite bleibt die breitere Familienreferenz.

Diese Seite dokumentiert einen deterministischen String-Helfer. Kodierungsfunktionen liefern transformierten Text zurueck, waehrend Hash-Funktionen feste, kleingeschriebene Hex-Digests liefern.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL rc AS LONG
    plain$ = UNBASE64$(encoded$)
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_web_all.pb`.

Grenzen

Dokumentieren Sie hier nur die getesteten Byte- oder String-Transformationen. Wenn es einen Rueckwaerts-Helfer gibt, pruefen Sie ihn separat, statt Symmetrie aus der Vorwaertsform abzuleiten.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

UNBASE64$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

UNBASE64$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer encoding-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

UNBASE64$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


UNC - Unlimited-Complex-Speicher verwenden — PBXB64 Help

Startseite › General Reference › UNC - Unlimited-Complex-Speicher verwenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

UNC - Unlimited-Complex-Speicher verwenden

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

LOCAL c AS UNC

Detailverhalten

Stringgestuetzter Unlimited-Complex-Datentyp mit VALUNC- und UNC$-Konvertierungen.

Praktische Verwendung

Verwenden Sie diese Schreibweise in Deklarationen oder Typpositionen, in denen die entsprechende Unlimited-/String-Kompatibilitaet erwartet wird. Die semantischen Details sollten mit einem eigenen Laufzeitnachweis belegt werden.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Verwechseln Sie diese Typkeywords nicht mit freien Bezeichnern oder Laufzeitwerten. Wenn der Zielkontext die Type-Position nicht erwartet, muss die Quelle entsprechend angepasst werden.

Verifiziertes Beispiel

Abgedeckt durch examples/basic/test_un_string_backed.pb (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UNESCAPE$ - PBXB64 Help

Startseite › General Reference › UNESCAPE$

UNESCAPE$

Hebt die Web-Textmaskierung von ESCAPE$ auf.

Kind: Runtime helper | Category: WEB / Runtime Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

text$ = UNESCAPE$(escaped$)

Beschreibung

Diese eigene Seite stellt sicher, dass Befehlsuche, Stichwortindex und direkte Dateinamenpruefung die getestete Laufzeitfunktion unmittelbar finden. Die gruppierte WEB-Seite bleibt die breitere Familienreferenz.

Diese Seite dokumentiert einen deterministischen String-Helfer. Kodierungsfunktionen liefern transformierten Text zurueck, waehrend Hash-Funktionen feste, kleingeschriebene Hex-Digests liefern.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL rc AS LONG
    text$ = UNESCAPE$(escaped$)
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_web_all.pb`.

Grenzen

Dokumentieren Sie hier nur die getesteten Byte- oder String-Transformationen. Wenn es einen Rueckwaerts-Helfer gibt, pruefen Sie ihn separat, statt Symmetrie aus der Vorwaertsform abzuleiten.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

UNESCAPE$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

UNESCAPE$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer encoding-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

UNESCAPE$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


UNF - Unlimited-Float-Speicher verwenden — PBXB64 Help

Startseite › General Reference › UNF - Unlimited-Float-Speicher verwenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

UNF - Unlimited-Float-Speicher verwenden

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

LOCAL f AS UNF

Detailverhalten

Stringgestuetztes Mitglied der Unlimited-Floating-/Decimal-Familie.

Praktische Verwendung

Verwenden Sie diese Schreibweise in Deklarationen oder Typpositionen, in denen die entsprechende Unlimited-/String-Kompatibilitaet erwartet wird. Die semantischen Details sollten mit einem eigenen Laufzeitnachweis belegt werden.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Verwechseln Sie diese Typkeywords nicht mit freien Bezeichnern oder Laufzeitwerten. Wenn der Zielkontext die Type-Position nicht erwartet, muss die Quelle entsprechend angepasst werden.

Verifiziertes Beispiel

Abgedeckt durch examples/basic/test_un_string_backed.pb (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UNHEX$ - PBXB64 Help

Startseite › General Reference › UNHEX$

UNHEX$

Decode a hexadecimal string.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = UNHEX$(hex$)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_unhex.html, damit Benutzer UNHEX$ direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Decode a hexadecimal string.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL h$, s$ h$ = "48 65 6C 6C 6F" s$ = UNHEX$(h$) PRINT s$ ' Hello

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

UNHEX$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

UNHEX$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer encoding-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

UNHEX$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


UNI - Unlimited-Interval-Speicher verwenden — PBXB64 Help

Startseite › General Reference › UNI - Unlimited-Interval-Speicher verwenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

UNI - Unlimited-Interval-Speicher verwenden

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

LOCAL i AS UNI

Detailverhalten

Stringgestuetzter Unlimited-Interval-Datentyp mit VALUNI- und UNI$-Konvertierungen.

Praktische Verwendung

Verwenden Sie diese Schreibweise in Deklarationen oder Typpositionen, in denen die entsprechende Unlimited-/String-Kompatibilitaet erwartet wird. Die semantischen Details sollten mit einem eigenen Laufzeitnachweis belegt werden.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Verwechseln Sie diese Typkeywords nicht mit freien Bezeichnern oder Laufzeitwerten. Wenn der Zielkontext die Type-Position nicht erwartet, muss die Quelle entsprechend angepasst werden.

Verifiziertes Beispiel

Abgedeckt durch examples/basic/test_un_string_backed.pb (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UNION/END UNION – PBXB64-Compiler-Hilfe

Startseite › Funktionen › UNION/END UNION

UNION/ENDUNION

Erstellen Sie ein neues

Typ:Struktur |Kategorie:Typen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

UNION UnionName
MemberName [( subscripts )] AS TypeName
[ MemberName [( subscripts )] AS TypeName ]
[...]
END UNION

Beschreibung

Eine Union ist ein Typ – einem benutzerdefinierten Typ sehr ähnlich – mit der Ausnahme, dass sich seine Elemente im Speicher überlappen. Auch wenn dies auf den ersten Blick seltsam erscheinen mag, birgt es ein enormes Potenzial.

Angenommen, Sie entwerfen ein Buchhaltungsprogramm. Sie möchten es universell nutzen, damit es eine breite Anziehungskraft hat. Aber jeder macht seine Buchhaltung anders; Beispielsweise verwenden einige Benutzer Kontonummern, bei denen es sich lediglich um ganzzahlige Werte handelt, während andere möglicherweise alphanumerische Kontonamen verwenden. Die Verwendung einer Union macht dies einfach. Eine weitere häufige Verwendung einer Union ist die Konvertierung von Variablentypen. Das lässt sich am besten anhand eines Beispiels beschreiben:

UNION VarConvert

iLong SO LANG

iDword ALS DWORD

sStr AS STRING * 4

END UNION

DIM x AS VarConvert, y AS DWORD, z AS STRING

x.iLong = 123456&

y = x.iDword

z = x.sStr

Wie ein benutzerdefinierter Typ kann auch eine Union Arrays enthalten, und diese folgen den gleichen Regeln wie Mitgliedsarrays benutzerdefinierter Typen (Syntaxregeln und zusätzliche Beispiele finden Sie unter Typmitglieder). Das folgende Beispiel demonstriert die Verwendung eines Union-Member-Arrays:

UNION Arrs

a1(1 BIS 1024) ALS BYTE

st AS ASCIIZ * 10

END UNION

FUNCTION PBMAIN

DIM a AS Arrs

a.a1(1) = 72

a.a1(2) = 101

a.a1(3) = 108

a.a1(4) = 108

a.a1(5) = 111

a.a1(6) = 33

' Zu diesem Zeitpunkt enthält a.st „Hallo!“

ENDFUNKTION

Bitvariablen

UNION-Strukturen können Bitvariablen enthalten, die BIT (Werte ohne Vorzeichen) oder SBIT (Werte mit Vorzeichen) heißen. Jede Bitvariable kann 1 bis 31 Bits belegen und sie können nacheinander bis zu insgesamt 32 Bits pro Bitfeld gepackt werden. Die Größe einer Bitvariablen ist wie folgt definiert:

var AS BIT * nlit [IN BYTE|WORD|DWORD]

Dabei definiert der Begriff „* nlit“ die Anzahl der Bits (1 bis 31) und der optionale Begriff „IN BYTE|WORD|DWORD“, falls vorhanden, definiert den Beginn eines neuen Bitfelds von 1, 2 oder 4 Bytes. Zum Beispiel:

UNION ABCDE

Odd1 AS BIT * 1 IN DWORD

Wert1 SO LANG

END UNION

Die obige Beispiel-UNION-Struktur ist 4 Byte groß und enthält ein 1-Byte-Bitfeld und ein 4-Byte-LONG.

UNION abcde

Teil1 ALS BIT * 8 IN DWORD

Teil2 AS BIT * 16

END UNION

Die obige Beispielvereinigung ist 4 Byte groß und enthält ein 8-Bit-Feld und ein überlappendes 16-Bit-Feld.

Strukturen innerhalb von Strukturen

Strukturen (TYPE/UNION) können zur Vereinfachung der Referenzierung tief verschachtelter Elemente in eine andere Struktur eingebettet werden, indem einfach nur der Strukturname an der entsprechenden Position angegeben wird. Die interne Ausrichtung der Mitgliederstruktur wird unabhängig von anderen Ausrichtungsspezifikationen präzise beibehalten, um Vererbungsproblemen vorzubeugen. Zum Beispiel:

TYP ABCD3

A SO LANG

C SO LANG

END-TYP

TYP ABCD2

D ALS DWORD

E AS DOPPELT

END-TYP

UNION ABCD1

F ALS DWORD

G SO LANG

H ALS EINZELN

END UNION

In diesem Fall könnten Sie sehr einfach auf das einzelne Float-Element mit einfacher Genauigkeit dieser Struktur zugreifen. Unter der Annahme, dass DIM

Einschränkungen

Eine Union kann Elemente unterschiedlicher Größe enthalten. Die Größe einer Union-Struktur wird immer durch das längste Mitgliedselement bestimmt. Dies ist normalerweise ein wichtiger Gesichtspunkt, wenn eine Union innerhalb einer anderen Union- oder UDT-Struktur verwendet wird, um die Größe der endgültigen Struktur zu bestimmen.

Weitere Informationen finden Sie in den Abschnitten TYPE/END TYPE, Benutzerdefinierte Typen und Unions.

Feldleisten können nicht in UDT- oder UNION-Strukturen verwendet werden. Der Versuch, dies zu tun, führt zur Kompilierungszeit zu einem Fehler 485 („Dynamik/Feldzeichenfolgen nicht zulässig“).

Siehe auch

  • DIM
  • LEN
  • LET (mit Typen)
  • SIZEOF
  • TYP/ENDTYP
  • Benutzerdefinierte Typen
  • Gewerkschaften

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Speicheranforderungen und -beschränkungen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Speicheranforderungen und -beschränkungen
Hilfe zum PBXB64-Compiler

Speicheranforderungen und -beschränkungen

Eine einzelne Union-Struktur ist auf 16 MB (16.777.216 Byte) begrenzt. Lokal dimensionierte Union-Strukturen sind auf den verfügbaren freien Stapelspeicherplatz begrenzt, typischerweise weniger als 1 MB. Wenn größere UDT s

Typ:Struktur |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Benutzerdefinierte Typen (UDTs)

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht
← VERBINDUNG/ENDVERBINDUNG Nach oben Gewerkschaften →

Prüfung des Union-Layouts

Union-Seiten sollen gemeinsam genutzten Speicher, Größe des größten Elements, Alignment und die Tatsache beschreiben, dass das Schreiben eines Elements dieselben Bytes für alle Elemente neu interpretiert. Beispiele sollen LEN, Elementzuweisung und einen Read-Back mit überlappendem Speicher enthalten.

Migrationshinweise

Prüfen Sie alten 32-Bit-Union-Code auf zeigergroße Felder und API-Strukturen. In PBXB64-x64-Ausgabe sind Pointer- und Handle-Felder 64 Bit breit; Overlay-Layouts können sich daher von alten 32-Bit-Programmen unterscheiden.

Empfohlenes Beispiel

Ein vollständiges Union-Beispiel soll zwei unterschiedlich typisierte Elemente deklarieren, ein Element schreiben, die überlappende Darstellung über das andere Element lesen und einen klaren Erfolgs- oder Fehlercode zurückgeben. Nennen Sie Abhängigkeiten von Byte-Reihenfolge oder plattformspezifischem Layout.

Beispiel

#COMPILE EXE
#DIM ALL

TYPE WordUnion
    AS LONG lValue
    AS BYTE bValue(1 TO 4)
END TYPE

FUNCTION PBMAIN() AS LONG
    LOCAL u AS WordUnion
    u.lValue = &H11223344
    IF LEN(u) <> 4 THEN FUNCTION = 1
    IF u.bValue(1) = 0 THEN FUNCTION = 1
END FUNCTION

Validierungsbeleg

Validierungsbeleg: die fokussierten Union-Tests und die registrierten Speicherrestriktions-Tests pruefen gemeinsam genutzten Speicher, LEN, Ueberlappungslesen und zeigergrosse Layoutregeln unter x64.

Empfohlenes Beispiel

Ein vollständiges Union-Speicherbeispiel soll LEN mit dem größten Element vergleichen, alignmentkritische Felder prüfen und zeigen, dass das Ändern eines Elements den gemeinsam genutzten Bytespeicher der anderen Elemente verändert.


Gewerkschaften – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Gewerkschaften

Gewerkschaften

Wenn Sie jemals in Pascal oder C programmiert haben, ist Ihnen möglicherweise das Konzept einer Union bekannt. Eine Union ähnelt in mancher Hinsicht einem benutzerdefinierten Typ. Beide verfügen über Datenfelder, die aus beliebigen o bestehen können

Typ:Struktur |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Obwohl das Konzept abstrakt erscheinen mag, bieten Unions eine Möglichkeit, Daten frei von einem Format in ein anderes zu konvertieren, indem die Daten einfach als ein Datenformat in die Union geschrieben und in einem anderen Datenformat zurückgelesen werden. Durch die Kombination der Vielseitigkeit eines UDT mit der Flexibilität einer Union kann diese Funktionalität erheblich erweitert werden, beispielsweise durch die Aufteilung von Daten in ihre Bestandteile.

Die folgende Definition würde beispielsweise eine Union namens WordFld und eine WordFld-Variable namens MyVar erstellen:

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht
← Speicheranforderungen und -beschränkungen Nach oben #EINZIGARTIG →

Prüfung des Union-Layouts

Union-Seiten sollen gemeinsam genutzten Speicher, Größe des größten Elements, Alignment und die Tatsache beschreiben, dass das Schreiben eines Elements dieselben Bytes für alle Elemente neu interpretiert. Beispiele sollen LEN, Elementzuweisung und einen Read-Back mit überlappendem Speicher enthalten.

Migrationshinweise

Prüfen Sie alten 32-Bit-Union-Code auf zeigergroße Felder und API-Strukturen. In PBXB64-x64-Ausgabe sind Pointer- und Handle-Felder 64 Bit breit; Overlay-Layouts können sich daher von alten 32-Bit-Programmen unterscheiden.

Empfohlenes Beispiel

Ein vollständiges Union-Beispiel soll zwei unterschiedlich typisierte Elemente deklarieren, ein Element schreiben, die überlappende Darstellung über das andere Element lesen und einen klaren Erfolgs- oder Fehlercode zurückgeben. Nennen Sie Abhängigkeiten von Byte-Reihenfolge oder plattformspezifischem Layout.

Beispiel

#COMPILE EXE
#DIM ALL

TYPE WordUnion
    AS LONG lValue
    AS BYTE bValue(1 TO 4)
END TYPE

FUNCTION PBMAIN() AS LONG
    LOCAL u AS WordUnion
    u.lValue = &H11223344
    IF LEN(u) <> 4 THEN FUNCTION = 1
    IF u.bValue(1) = 0 THEN FUNCTION = 1
END FUNCTION

Validierungsbeleg

Validierungsbeleg: die fokussierten Union-Tests und die registrierten Speicherrestriktions-Tests pruefen gemeinsam genutzten Speicher, LEN, Ueberlappungslesen und zeigergrosse Layoutregeln unter x64.

Empfohlenes Beispiel

Ein vollständiges Union-Beispiel soll zwei unterschiedlich typisierte Elemente deklarieren, ein Element schreiben, die überlappende Darstellung über das andere Element lesen und einen klaren Erfolgs- oder Fehlercode zurückgeben. Nennen Sie Abhängigkeiten von Byte-Reihenfolge oder plattformspezifischem Layout.


#UNIQUE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › #UNIQUE

#EINZIGARTIG

Geben Sie an, ob es eindeutig ist

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

#UNIQUE VAR [ON|OFF]

Beschreibung

Standardmäßig (#UNIQUE VAR OFF) ist es möglich, denselben Namen für mehr als eine Variable in Ihrem Programm zu verwenden. Beispielsweise könnten Sie abc%, abc# und abc$ in derselben Funktion verwenden und dabei die durch das Typ-ID-Zeichen definierte Standardtypisierung verwenden. Sie könnten sogar eine lokale Variable namens „counters“ und eine globale Variable namens „counters“ erstellen.

Wenn Sie also in Ihrem Programm auf einen Variablennamen verweisen, welche Variable wird dann tatsächlich verwendet? Abhängig vom Speicherort der Referenz wählt der Compiler die Variable mit dem kleinsten Gültigkeitsbereich. Die Priorität der Variablenbereiche ist:

1- Lokal oder Statisch

2- Instanz

3- Global oder Threaded

Wenn #UNIQUE VAR AUS ist, versucht PowerBASIC zunächst, einen LOCAL oder STATIC zu finden. Als nächstes ein INSTANCE und schließlich ein GLOBAL oder THREADED . Es wählt das erste in dieser Reihenfolge aus, das es findet. Natürlich können Sie für LOCAL und STATIC nicht denselben Namen verwenden, es sei denn, Sie verwenden ein Typ-ID-Zeichen, um sie zu unterscheiden. Sie können niemals denselben Namen für ein GLOBAL und ein THREADED verwenden, da es sonst unmöglich wäre, sie voneinander zu unterscheiden. Dies bietet zwar die größte Flexibilität, kann jedoch verwirrend sein und zur Entstehung heimtückischer, schwer zu findender Fehler in Ihrem Programm führen. Wenn Sie versehentlich auf die falsche Variable verweisen, können die Ergebnisse katastrophal sein. Wenn #UNIQUE VAR aktiviert ist, verlangt PowerBASIC, dass alle Variablennamen eindeutig sind. Dies kann Ihre Arbeit erheblich erleichtern, da die Mehrdeutigkeit beseitigt wird, die bei der Wiederverwendung von Bezeichnern auftritt. Es gibt einige Ausnahmen von der Eindeutigkeitsregel, die die Lesbarkeit Ihres Codes verbessern sollen:

1- Lokale, statische und Parameternamen können in anderen Subs, Funktionen und Methoden wiederverwendet werden.

2- Instanznamen können in anderen Klassen wiederverwendet werden.

3- Skalar- und Array-Namen können nebeneinander existieren, wenn sie denselben Datentyp und denselben Umfang haben.

Siehe auch

  • #DIM
  • DEF-Typ
  • DIM
  • GLOBAL
  • LOCAL
  • REDIM
  • STATIC
  • OPTION EXPLIZIT

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UNL - Unlimited-Integer-Speicher verwenden — PBXB64 Help

Startseite › General Reference › UNL - Unlimited-Integer-Speicher verwenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

UNL - Unlimited-Integer-Speicher verwenden

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

LOCAL n AS UNL

Detailverhalten

PB/BASIC-Datentyp fuer vorzeichenbehaftete Ganzzahlen mit unbegrenzter Genauigkeit. Verwenden Sie VALUNL(text$) zum Einlesen sehr grosser Dezimal-Ganzzahlen, UNL$(value) zur Ausgabe und normale Arithmetikoperatoren fuer exakte Ganzzahlarithmetik. UNL hat keine einstellbare Dezimalgenauigkeit; verwenden Sie UNF oder UNB mit UNFPRECISION(n), wenn Dezimaldivision mit einstellbarer Genauigkeit benoetigt wird.

Praktische Verwendung

Verwenden Sie diese Schreibweise in Deklarationen oder Typpositionen, in denen die entsprechende Unlimited-/String-Kompatibilitaet erwartet wird. Die semantischen Details sollten mit einem eigenen Laufzeitnachweis belegt werden.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Verwechseln Sie diese Typkeywords nicht mit freien Bezeichnern oder Laufzeitwerten. Wenn der Zielkontext die Type-Position nicht erwartet, muss die Quelle entsprechend angepasst werden.

Verifiziertes Beispiel

Abgedeckt durch examples/basic/test_un_string_backed.pb (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UNLOCK – PBXB64-Compiler-Hilfe

Startseite › BASIC-Frontend › Schlüsselwortreferenz › Datei-E/A › UNLOCK
Hilfe zum PBXB64-Compiler

UNLOCK

Sperre eines Teils oder der ganzen Datei aufheben

Typ: Anweisung | Kategorie: Datei-E/A

PBXB64-Status: VERFÜGBAR

PBXB64-Zertifizierung: [IMPLEMENTIERT: Win32-Bytebereichssperren]

Syntax

UNLOCK [#] Dateinummer& [, { Datensatz&& | Start&& TO Ende&& }]

Beschreibung

UNLOCK hebt die durch LOCK gesetzte Sperre für einen Datensatz, einen Datensatzbereich, ein Byte oder einen Bytebereich in der als Dateinummer Dateinummer& geöffneten Datei auf.

Im Direktzugriffsmodus geben Datensatz&&, Start&& und Ende&& Datensatznummern an. Im Binärmodus geben sie Bytepositionen an.

Wird ein Datensatz angegeben, wird nur dieser entsperrt. Andernfalls wird der Bereich von Start&& bis Ende&& entsperrt. Werden keine Datensätze angegeben oder wurde die Datei sequenziell geöffnet, wird die gesamte Datei entsperrt.

Alle zu entsperrenden Bereiche müssen zuvor mit LOCK gesperrt worden sein. Mehrere Sperren sind möglich und können in beliebiger Reihenfolge aufgehoben werden; die Parameter jedes UNLOCK müssen jedoch genau denen des zugehörigen LOCK entsprechen.

Alle gesperrten Bereiche müssen vor dem Schließen der Datei entsperrt werden.

Praktische Verwendung

Verwenden Sie UNLOCK, sobald der geschützte Dateibereich keinen exklusiven Zugriff mehr braucht. Spiegeln Sie die vorherigen LOCK-Argumente exakt und halten Sie den gesperrten Bereich moeglichst klein, damit andere Programme wieder zugreifen können.

Parameter und Ergebnisse

Die Dateinummer und der optionale Datensatz- oder Bytebereich müssen zum vorherigen LOCK passen. Die Anweisung hebt die Sperre auf und liefert keinen Rueckgabewert. Ohne Bereich wird die ganze Datei entsperrt.

Einschränkungen

  • Dateinummern müssen als Literale #1..#16 angegeben werden.
  • Fehlercodes in der ERR-Variablen werden derzeit nicht gesetzt.

Test- und Dokumentationshinweise

Die registrierte Regression test_lock_unlock belegt das passende Entsperren fuer literale und variable Bytebereiche, die start,laenge-Form und das Sperren/Entsperren der ganzen Datei über die Win32-Laufzeithilfen. Das Beispiel zeigt ausserdem, dass der Dateiinhalt nach dem Sperrzyklus unveraendert bleibt.

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL s AS STRING
    LOCAL startByte AS QUAD
    LOCAL endByte AS QUAD

    OPEN "lock_test.txt" FOR OUTPUT AS #1
    PRINT #1, "0123456789ABCDEF";
    CLOSE #1

    OPEN "lock_test.txt" FOR BINARY ACCESS READ WRITE LOCK SHARED AS #1
    LOCK #1, 2 TO 3
    UNLOCK #1, 2 TO 3
    startByte = 4
    endByte = 5
    LOCK #1, startByte TO endByte
    UNLOCK #1, startByte TO endByte
    LOCK #1, 6, 2
    UNLOCK #1, 6, 2
    LOCK #1
    UNLOCK #1
    CLOSE #1

    OPEN "lock_test.txt" FOR INPUT AS #1
    LINE INPUT #1, s
    CLOSE #1
    KILL "lock_test.txt"

    IF s <> "0123456789ABCDEF" THEN FUNCTION = 1
END FUNCTION

Siehe auch

  • LOCK
  • OPEN

Kompatibilitätshinweise

Spiegeln Sie die urspruenglichen LOCK-Argumente exakt. Die aktuelle PBXB64-Oberflaeche behandelt den Entsperraufruf als Spiegelung des gesperrten Bereichs, und das Beispiel beweist Bytebereich, start,laenge-Form und das Entsperren der ganzen Datei gegen dieselbe Testdatei.

Fehlerfaelle

Wenn die Datei nicht mit demselben Bereich gesperrt war, sollte der Aufrufer annehmen, dass der Entsperrversuch nicht wie beabsichtigt gewirkt hat, und den Dateistatus erneut pruefen, statt von einer erfolgreichen Rueckgewinnung auszugehen. Die Seite behauptet keinen ERR-Aktualisierungspfad fuer diese Oberflaeche.

Validierungsbeleg

Validation evidence: examples/basic/test_lock_unlock.pb oeffnet eine temporaere Datei, sperrt und entsperrt literale und variable Bytebereiche, verwendet die start,laenge-Form, entsperrt die ganze Datei und prueft, dass der Inhalt unveraendert bleibt.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für UNLOCK soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' UNLOCK mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


UNMACRO – PBXB64-Compiler-Hilfe

Startseite › Funktionen › UNMACRO

UNMACRO

Deaktiviert ein vorhandenes Makro, sodass spätere Verweise nicht mehr erweitert werden.

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

UNMACRO macroname

Beschreibung

UNMACRO deaktiviert ein Makro. Der Makroname muss bereits definiert sein; andernfalls meldet der Compiler einen Fehler. Nach UNMACRO wird der Makroname als gewöhnlicher Bezeichner behandelt (oder als undefiniert gemeldet, wenn er in Makroposition verwendet wird).

PBXB64-Hinweise

Makros werden vor dem Statement-Lowering vorscanniert, sodass eine UNMACRO-Direktive für die gesamte Kompilierungseinheit nach Quellreihenfolge wirksam wird. Ein durch UNMACRO deaktiviertes Makro kann daher nicht erneut referenziert werden, auch nicht in Quelltext, der physikalisch vor der UNMACRO-Direktive steht.

Abgedeckt durch tests/pb/test_pp_remacro_unmacro.pb und tests/pb/test_pp_unmacro_reject.pb.

Siehe auch

  • MAKRO / ENDMAKRO
  • REMACRO

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für UNMACRO soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' UNMACRO mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


UNQ - Unlimited-Quaternion-Speicher verwenden — PBXB64 Help

Startseite › General Reference › UNQ - Unlimited-Quaternion-Speicher verwenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

UNQ - Unlimited-Quaternion-Speicher verwenden

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

LOCAL q AS UNQ

Detailverhalten

Stringgestuetzter Unlimited-Quaternion-Datentyp mit VALUNQ- und UNQ$-Konvertierungen.

Praktische Verwendung

Verwenden Sie diese Schreibweise in Deklarationen oder Typpositionen, in denen die entsprechende Unlimited-/String-Kompatibilitaet erwartet wird. Die semantischen Details sollten mit einem eigenen Laufzeitnachweis belegt werden.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Verwechseln Sie diese Typkeywords nicht mit freien Bezeichnern oder Laufzeitwerten. Wenn der Zielkontext die Type-Position nicht erwartet, muss die Quelle entsprechend angepasst werden.

Verifiziertes Beispiel

Abgedeckt durch examples/basic/test_un_string_backed.pb (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UNTIL - Schleifen bis Bedingung wahr ist — PBXB64 Help

Startseite › General Reference › UNTIL - Schleifen bis Bedingung wahr ist — PBXB64 Help
Hilfe zum PBXB64-Compiler

UNTIL - Schleifen bis Bedingung wahr ist

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

DO
LOOP UNTIL done

Detailverhalten

Bedingungskeyword am Schleifenende fuer DO/LOOP-Formen.

Praktische Verwendung

Verwenden Sie dieses Keyword als Schleifenabschluss in der getesteten DO/LOOP- oder WHILE/WEND-Schreibweise. Es gehoert syntaktisch an das Ende der Schleife und nicht in den Schleifenkopf.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Ein fehlender Loop-Hauptteil, ein falscher Schleifentyp oder ein zu fruehes Abschlusskeyword sollte nicht still durchrutschen. Die Endposition gehoert in die passende Kontrollform.

Verifiziertes Beispiel

Abgedeckt durch examples/v4/basic/v4_do_loop.bas (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UNWRAP$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › UNWRAP$

UNWRAP$

Entfernen Sie gepaarte Zeichen vom Anfang und Ende einer Zeichenfolge

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = UNWRAP$( StringExpression , LeftChar$ , RightChar$ )

Beschreibung

Die Funktion UNWRAP$ entfernt die Zeichen in LeftChar$ vom Anfang von StringExpression , wenn eine genaue Übereinstimmung vorliegt. Anschließend werden die Zeichen in RightChar$ am Ende entfernt, wenn eine genaue Übereinstimmung vorliegt. Die restlichen Zeichen werden dann zurückgegeben. Zum Beispiel:

UNWRAP$("<MyWord>", "<", ">") gibt "MyWord" zurück.

UNWRAP$ ist besonders nützlich, um Klammern, Anführungszeichen, Klammern usw. aus einem Textelement zu entfernen.

Siehe auch

  • EXTRACT$
  • LTRIM$
  • MITTLERER $
  • REMOVE$
  • REPLACE
  • RTRIM$
  • SHRINK$
  • TRIM$
  • WRAP$

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


URLDECODE$ - PBXB64 Help

Startseite › General Reference › URLDECODE$

URLDECODE$

Dekodiert prozentkodierten URL-Komponententext.

Kind: Runtime helper | Category: WEB / Runtime Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

text$ = URLDECODE$(url$)

Beschreibung

Diese eigene Seite stellt sicher, dass Befehlsuche, Stichwortindex und direkte Dateinamenpruefung die getestete Laufzeitfunktion unmittelbar finden. Die gruppierte WEB-Seite bleibt die breitere Familienreferenz.

Diese Seite dokumentiert einen deterministischen String-Helfer. Kodierungsfunktionen liefern transformierten Text zurueck, waehrend Hash-Funktionen feste, kleingeschriebene Hex-Digests liefern.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL rc AS LONG
    text$ = URLDECODE$("a%20b")
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_web_all.pb`.

Grenzen

Dokumentieren Sie hier nur die getesteten Byte- oder String-Transformationen. Wenn es einen Rueckwaerts-Helfer gibt, pruefen Sie ihn separat, statt Symmetrie aus der Vorwaertsform abzuleiten.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

URLDECODE$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

URLDECODE$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer URL/header-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

URLDECODE$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


URLENCODE$ - PBXB64 Help

Startseite › General Reference › URLENCODE$

URLENCODE$

Kodiert eine Zeichenkette mit Prozentkodierung fuer URL-Bestandteile.

Kind: Runtime helper | Category: WEB / Runtime Helpers

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

url$ = URLENCODE$(text$)

Beschreibung

Diese eigene Seite stellt sicher, dass Befehlsuche, Stichwortindex und direkte Dateinamenpruefung die getestete Laufzeitfunktion unmittelbar finden. Die gruppierte WEB-Seite bleibt die breitere Familienreferenz.

Diese Seite dokumentiert einen deterministischen String-Helfer. Kodierungsfunktionen liefern transformierten Text zurueck, waehrend Hash-Funktionen feste, kleingeschriebene Hex-Digests liefern.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL rc AS LONG
    url$ = URLENCODE$("a b")
END FUNCTION

Verifiziertes Beispiel

Abgedeckt durch `test_web_all.pb`.

Grenzen

Dokumentieren Sie hier nur die getesteten Byte- oder String-Transformationen. Wenn es einen Rueckwaerts-Helfer gibt, pruefen Sie ihn separat, statt Symmetrie aus der Vorwaertsform abzuleiten.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

URLENCODE$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

URLENCODE$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer URL/header-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

URLENCODE$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


URLHOST$ - PBXB64 Help

Startseite › General Reference › URLHOST$

URLHOST$

Extract the host component from a URL.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = URLHOST$(url$)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_urlhost.html, damit Benutzer URLHOST$ direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Extract the host component from a URL.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL url$, host$ url$ = "https://www.example.com:8080/path?x=1" host$ = URLHOST$(url$) PRINT host$ ' www.example.com

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

URLHOST$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

URLHOST$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer URL/header-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

URLHOST$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


URLPATH$ - PBXB64 Help

Startseite › General Reference › URLPATH$

URLPATH$

Extract the path component from a URL.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = URLPATH$(url$)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_urlpath.html, damit Benutzer URLPATH$ direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Extract the path component from a URL.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL url$, path$ url$ = "https://api.example.com/v1/users?id=42" path$ = URLPATH$(url$) PRINT path$ ' /v1/users

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

URLPATH$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

URLPATH$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer URL/header-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

URLPATH$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


URLPORT - PBXB64 Help

Startseite › General Reference › URLPORT

URLPORT

Extract the port number from a URL.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result = URLPORT(url$)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_urlport.html, damit Benutzer URLPORT direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Extract the port number from a URL.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL url$, p AS LONG url$ = "https://example.com:8443/secure" p = URLPORT(url$) PRINT p ' 8443

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

URLPORT gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

URLPORT gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer URL/header-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

URLPORT

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


URLQUERY$ - PBXB64 Help

Startseite › General Reference › URLQUERY$

URLQUERY$

Extract the query string from a URL.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

result$ = URLQUERY$(url$)

Beschreibung

Diese einfache Befehlsseite spiegelt die getestete WEB-Referenzseite cmd_web_urlquery.html, damit Benutzer URLQUERY$ direkt in Befehlsuche und Stichwortsuche finden. Die gruppierte WEB-Seite bleibt die detaillierte Familienreferenz, aber diese Alias-Seite haelt Befehlsname, Syntax und Beispiel ohne zweite Suche erreichbar.

Extract the query string from a URL.

Verwendungshinweise

Diese Alias-Seite sorgt dafuer, dass Befehlsuche und Stichwortsuche den getesteten Helfer unter seinem einfachen Befehlsnamen finden. Verwenden Sie die gruppierte WEB-Seite fuer den breiteren Familienueberblick und die exakte Laufzeithelfer-Tabelle.

Beispiel

LOCAL url$, q$ url$ = "https://example.com/search?q=PBXB64⟨=en" q$ = URLQUERY$(url$) PRINT q$ ' q=PBXB64⟨=en

Verifiziertes Beispiel

Die WEB-Befehlsfamilie ist durch `test_web_all.pb` sowie fokussierte Hash-, JSON-, HTTP-Invalid-Handle- und lokale HTTP-Tests in `docs/FEATURE_MATRIX.md` abgedeckt.

Grenzen

Diese Seite dokumentiert das aktuell getestete PBXB64-Verhalten. Weiteres Protokoll-, Fehlerdaten-, Live-Netzwerk- oder verschachteltes JSON-Verhalten soll erst nach eigenen Tests dokumentiert werden.

Kind: Runtime helper | Category: WEB / JSON / HTTP Runtime

Beschreibung

URLQUERY$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit. Diese Seite beschreibt die akzeptierte BASIC-Oberflaeche, den benoetigten Handle- oder Stringzustand und die pruefbare Verwendung in der aktuellen Toolchain.

Praktische Verwendung

URLQUERY$ gehoert zur WEB-Erweiterung der PBXB64-Laufzeit und ist fuer URL/header-Aufgaben vorgesehen. Der Befehl arbeitet deterministisch auf BASIC-Strings oder Handles und eignet sich deshalb fuer kleine Werkzeuge, Protokolladapter, lokale Tests und Netzwerk-Hilfsprogramme.

Eingaberegeln

Pruefen Sie den input string, bevor das Ergebnis weiterverwendet wird. Leere Strings sind fuer viele Codierungs- und Hashfunktionen gueltig, waehrend ungueltige JSON- oder HTTP-Handles als Fehler behandelt werden muessen. Dokumentieren Sie im Programm, ob Daten Text, Binaerdaten, URL-Komponenten oder JSON-Pfade darstellen.

Robuster Ablauf

Ein robuster Ablauf erstellt zuerst alle Eingaben, ruft dann die WEB-Funktion auf, prueft den Rueckgabewert und gibt Ressourcen in jedem Fehlerpfad frei. Bei HTTP-Funktionen sollte Code nicht davon ausgehen, dass ein Host erreichbar ist; lokale Tests und Timeouts muessen getrennt von Format- und Handle-Fehlern behandelt werden.

Syntax

URLQUERY$

Getestetes Beispiel

Validierungsnachweis: Die WEB-Kindseiten und test_web_all.pb decken die fokussierten String-, JSON-, URL-, Hash- und HTTP-Helfer ab, sofern die jeweilige Kindseite keinen engeren Nachweis nennt.


Benutzerdefinierte Typen (UDTs) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Benutzerdefinierte Typen (UDTs)
Hilfe zum PBXB64-Compiler

Benutzerdefinierte Typen (UDTs)

Arrays sind nützlich, wenn Sie eine Reihe ähnlicher Variablen als Einheit behandeln müssen. Zum Beispiel zehn Testergebnisse oder zehn Studentennamen. Aber was ist, wenn Sie mehrere unabhängige Datentypen speichern und dazu in der Lage sein müssen?

Typ:Schlüsselwort |Kategorie:Typen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Nach der Erstellung können Sie beliebig viele Variablen Ihres neuen Typs definieren. Da benutzerdefinierte Typen außerdem mit dem Puffer einer Zufallsdatei verknüpft werden können, erhalten Sie eine völlig neue Möglichkeit, auf Ihre Zufallsdateien zuzugreifen.

Der benutzerdefinierte Typ von PowerBASIC ähnelt einer C-Struktur oder einem Pascal-Datensatz. Die Elemente eines benutzerdefinierten Typs können alle Datentypen von PowerBASIC umfassen, mit Ausnahme von dynamischen Zeichenfolgen (variabler Länge), Feldzeichenfolgen und Arrays dynamischer Zeichenfolgen.

Um einen Eindruck von der Leistungsfähigkeit des benutzerdefinierten Typs zu bekommen, stellen Sie sich vor, Sie wären ein Lehrer, der ein Programm benötigt, um die Noten der Schüler zu verfolgen. Da Ihre Schule über ein sehr knappes Budget verfügt (und welche Schulen sind das heutzutage nicht?), entscheiden Sie sich, das Programm selbst in PowerBASIC zu schreiben. Für jeden Schüler in der Klasse müssen Sie die folgenden Informationen nachverfolgen:

Derzeit werden diese Aufzeichnungen in einer kleinen Aktenbox aufbewahrt. Die Informationen zu jedem Schüler sind auf einer einzigen Karteikarte enthalten. Wie überträgt man diese Informationen auf den Computer? Einfach. Definieren Sie einen Studentendatensatztyp, der alle Informationen zu einem einzelnen Studenten enthält.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Benutzerdefinierte Typen (UDTs) soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Benutzerdefinierte Typen (UDTs) mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


USING$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › USING$

USING$

Formatieren Sie einen oder mehrere Ausdrücke mithilfe einer Formatmaske in eine Zeichenfolge.

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

sResult$ = USING$( fmtmask$ , expr [, expr [, ...]])

Beschreibung

Die Formatierungsregeln basieren auf der PRINT USING-Anweisung, die in vielen DOS-Versionen von BASIC unterstützt wird, einschließlich PowerBASIC für DOS.

Da USING$ als Funktion implementiert ist, bietet es weitaus mehr Vielseitigkeit als PRINT USING, da es nicht erforderlich ist, einen Wert auszugeben, um von dieser einzigartigen Funktionalität zu profitieren. USING$ bietet einen größeren Anwendungsbereich als FORMAT$, da es sowohl numerische als auch Zeichenfolgenausdrücke formatieren und mehrere Argumente annehmen kann.

fmtmask$ – Ein String-Ausdruck, eine String-Variable oder ein String-Literal bestehend aus Formatzeichen, die bestimmen, wie der gesamte Ausdruck formatiert werden soll. Dieser Ausdruck wird als bezeichnet Maske. Es können beliebig viele Formatmasken vorhanden sein fmtmask$, in der gleichen Reihenfolge angeordnet wie die expr Argumente angegeben werden.

Ausdruck – Eine zu formatierende Zeichenfolge oder ein numerischer Ausdruck, eine Variable oder ein Literalwert. Die verfügbaren Maskenzeichen hängen davon ab, ob expr ist eine Zeichenfolge oder eine Zahl.

String-Formatcodes

Wann expr eine Zeichenfolge ist, gelten die folgenden Formatcodes darin fmtmask$:

Charakter | Definition
! | Das erste Zeichen der Zeichenfolge wird zurückgegeben.
\ Räume \ | Wenn Backslashes umschließen n Räume, n + 2 Zeichen des String-Ausdrucks werden zurückgegeben.
& | Der gesamte String wird zurückgegeben.
\ | Die ersten beiden Zeichen werden zurückgegeben (bei Verwendung als einzelnes Paar).
_ | Escape-Zeichen (Unterstrich). Das folgende Zeichen wird als Literalzeichen und nicht als Maskenformatzeichen interpretiert.

Numerische Formatcodes

Wann expr numerisch ist, gelten die folgenden Formatcodes darin fmtmask$:

Charakter | Definition
# | Eine numerische Ziffernposition, die links vom Dezimalpunkt mit Leerzeichen und rechts vom Dezimalpunkt mit Nullen gefüllt ist. Wenn die Zahl negativ ist, wird eine Ziffernposition mit einem Minuszeichen belegt.
. | An dieser Stelle wird der Dezimalpunkt platziert.
, | Eine numerische Ziffernposition, die bedeutet, dass ganze Ziffern mit einem Komma alle drei Ziffern angezeigt werden sollen.
$$ | Zwei numerische Ziffernpositionen, die dazu führen, dass unmittelbar vor der Zahl ein Dollarzeichen eingefügt wird.
*x | Zwei numerische Ziffernpositionen, die dazu führen, dass führende Leerzeichen im Feld durch das Zeichen ersetzt werden x. Zum Beispiel zwei Sternchen ** wandeln Sie führende Leerzeichen in Sternchen um und *= wandelt führende Leerzeichen in Gleichheitszeichen um. Die *x Maskenzeichen fungieren auch als zweistellige Zeichen (#) Platzhalter. Um dies nutzen zu können, muss Ihre Maske mindestens drei Zeichen enthalten.
+ | Ein Plus am Anfang des Feldes bewirkt, dass das Vorzeichen des Wertes (+oder-) muss vor der Nummer eingefügt werden. Ein Pluszeichen am Ende des Feldes bewirkt, dass das Vorzeichen nach der Zahl eingefügt wird.
- | Ein Minus am Ende des Feldes führt dazu, dass nach einer negativen Zahl ein Minuszeichen oder nach einer positiven Zahl ein Leerzeichen eingefügt wird. Ein Minus am Anfang des Feldes wird als Literalzeichen behandelt.
^^^ – ^^^^^^ | Zahlen können in wissenschaftlicher Notation formatiert werden, indem drei bis sechs Caretzeichen eingefügt werden (^) in der Formatzeichenfolge. Jedes Caret entspricht einer numerischen Ziffernposition im Exponenten: eins für E, eins für das Vorzeichen des Exponenten und eins bis vier für die tatsächlichen Ziffern des Exponentenwerts.
_ | Escape-Zeichen (Unterstrich). Das folgende Zeichen wird als Literalzeichen und nicht als Maskenformatzeichen interpretiert. Um einen wörtlichen Unterstrich in die Formatmaske aufzunehmen, verwenden Sie zwei Unterstrichzeichen (__).

Alle Zeichen in der Formatmaskenzeichenfolge, die oben nicht identifiziert wurden, werden in die Ausgabezeichenfolge kopiert, sobald sie angetroffen werden. Sie können jeden speziellen Formatcode überschreiben oder maskieren, indem Sie ihm einen Unterstrich voranstellen (_) und es wird wie jedes andere Literalzeichen kopiert. Dies bietet die Flexibilität, literalen Zeichenfolgentext in die formatierte Rückgabezeichenfolge aufzunehmen.

Beispiel

FUNCTION PBMAIN() AS LONG
    LOCAL s AS STRING
    s = USING$("##,###.##", 12345.67)
    ' s = "12,345.67"

    s = USING$("$$###.00", 42.5)
    ' s = "$  42.50"

    s = USING$("_!_&", "Hello", "World")
    ' s = "!HWorld"

    FUNCTION = 0
END FUNCTION

Einschränkungen

  • Die zurückgegebene Zeichenfolge ist auf eine absolute Länge von 1024 Byte begrenzt.
  • Durch Angabe einer einzelnen Maske in fmtmask$, alle expr Argumente unterliegen der Einzelmaske.
  • Wenn es weniger sind expr Argumente als passende Formatmasken in fmtmask$, Parsen der fmtmask$ stoppt nach der letzten referenzierten Maskenposition und nachfolgende Zeichen werden ignoriert. Dies steht im Einklang mit dem Verhalten von PRINT USING$ in PB/DOS.
  • Wenn ein numerisches Argument seine Maske überschreitet (d. h. es gibt mehr Ziffern als Ziffernpositionen), nimmt die resultierende Zeichenfolge so viele Leerzeichen ein, wie zur Darstellung der Zahl erforderlich sind. In solchen Fällen enthält PB/DOS ein führendes „%“-Symbol, um einen Maskenüberlauf anzuzeigen; PowerBASIC für Windows gibt jedoch nicht das zusätzliche Überlaufzeichen „%“ zurück.
  • Das Semikolon (;) und Null (0)-Zeichen sind für die zukünftige Verwendung reserviert, daher wäre es ratsam, solche Literalzeichen in USING$-Masken zu maskieren, um die zukünftige Kompatibilität sicherzustellen.

Siehe auch

  • GRAFIKDRUCK
  • XPRINT
  • FORMAT$
  • STR$

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Verwenden von Arrays benutzerdefinierter Typen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Verwenden von Arrays benutzerdefinierter Typen
Hilfe zum PBXB64-Compiler

Verwenden von Arrays benutzerdefinierter Typen

Sie können Arrays von benutzerdefinierten Typen erstellen, genauso wie Sie Arrays von Ganzzahlen oder Zeichenfolgen oder anderen Datentypen von PowerBASIC erstellen können. Zum Beispiel:

Typ:Schlüsselwort |Kategorie:Typen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

DIM-Klasse (1 bis 30) AS StudentRecord

Um auf die einzelnen Elemente des Class-Arrays zuzugreifen, verwenden Sie wie bei jedem anderen Array tiefgestellte Indexwerte. Der dritte Schülerdatensatz ist beispielsweise Class(3) . Das Punkttrennzeichen und der Feldname folgen dem Array-Index:

Klasse(3).FullName.First

Dadurch würde auf den Vornamen des dritten Schülers im Klassenarray zugegriffen. Stellen Sie sich das so vor: Das Array besteht aus Elementen des Typs „Student Record“, sodass der Index zum Namen der Variablen als Ganzes gehört.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Array-Prüfung

Array-Referenzseiten sollen Grenzen, Dimensionen, Elementtyp, Allokationszustand und die Frage dokumentieren, ob die Operation den Array-Deskriptor ändert. Ein vollständiges Beispiel deckt ein leeres Array, ein gefülltes Array und mindestens einen Grenzindex ab.

PBXB64-x64-Hinweise

Beim Portieren älteren Codes sind zeigergroße Deskriptoren und API-Aufrufe zu prüfen, die Array-Speicher erhalten. Bevorzugen Sie explizite Unter- und Obergrenzen und geben Sie einen klaren Fehlercode zurück, wenn Index- oder Dimensionsannahmen verletzt werden.

Verwandte Tests

Verwenden Sie fokussierte Programme, die mit PBXB64 beispiel.bas -o beispiel.exe kompilieren und bei abweichendem Inhalt, Grenzen oder Deskriptorzustand einen Nicht-Null-Code zurückgeben.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Verwenden von Arrays benutzerdefinierter Typen soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Verwenden von Arrays benutzerdefinierter Typen mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Assemblersprache in Ihrem Code verwenden – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Assemblersprache in Ihrem Code verwenden
Hilfe zum PBXB64-Compiler

Verwenden Sie Assemblersprache in Ihrem Code

PowerBASIC bietet eine Reihe von Möglichkeiten, wie Sie Assemblersprache verwenden können. Sie können das gesamte Programm mit dem Inline-Assembler schreiben. Sie können ganze Subs, Funktionen, Methoden und Eigenschaften schreiben

Typ:Schlüsselwort |Kategorie:Inline-Assembler

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Um guten Assembler-Code zu schreiben, müssen Sie bestimmte Dinge beachten:

Syntax des Inline-Assembler-Codes

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Verwenden von ESP und EBP – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › Verwendung von ESP und EBP

Verwendung von ESP und EBP

In PowerBASIC ist es möglich, Ihre eigene Prozedur innerhalb einer vorhandenen Sub , Function , Method oder Property zu schreiben, indem Sie den Stack-Ein- und Ausgang manuell codieren. Dies ist ein komplizierter Bereich von Assembler c

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

' Anderer PowerBASIC-Code hier

! JMP-Label; Überspringen Sie die Prozedur

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Verwenden benutzerdefinierter Typen mit Prozeduren – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Benutzerdefinierte Typen mit Prozeduren verwenden
Hilfe zum PBXB64-Compiler

Verwenden benutzerdefinierter Typen mit Prozeduren

Unterroutinen, Funktionen, Methoden und Eigenschaften können benutzerdefinierte Typen sowie jeden anderen Datentyp verarbeiten. Dieses Thema umfasst die folgenden Themen:

Typ:Schlüsselwort |Kategorie:Typen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Felder als Argumente übergeben

Mitglieder in benutzerdefinierten Typen, die zu den integrierten PowerBASIC-Typen gehören ( INTEGER , WORD , STRING usw.), können an Prozeduren und Funktionen übergeben werden, als wären sie einfache Variablen. Angenommen, der benutzerdefinierte Typ „PatientRecord“ lautet beispielsweise wie folgt:

Vollständiger Name AS STRING * 32

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


Utf8ToChr$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Utf8ToChr$

Utf8ToChr$

Übersetzt eine Bytefolge von

Typ:Funktion |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

a$$ = Utf8ToChr$( UtfExpr$ )

Beschreibung

UtfExpr$ enthält eine Reihe von Bytes im UTF-8-Format. Utf8ToChr$ übersetzt es je nach Kontext des Quellcodes entweder in ANSI-Multibyte-äquivalente Zeichen oder WIDE (16-Bit) Unicode-Zeichen. PowerBASIC wählt immer die richtige Form, ohne dass der Programmierer eingreifen muss.

Siehe auch

  • ChrToOem$
  • ChrToUtf8$
  • OemToChr$

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


#UTILITY – PBXB64-Compiler-Hilfe

Startseite › Funktionen › #UTILITY

#NUTZBARKEIT

Compiler-Anweisung, um externen Dienstprogrammen das Lesen von in der #UTILITY-Zeile eingefügtem Text zu ermöglichen.

Typ:Richtlinie |Kategorie:Präprozessor

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

#UTILITY "any text for an external program"

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Variablenbereich – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Variabler Umfang

Variabler Umfang

Der Geltungsbereich einer Variablen wird durch ihre Sichtbarkeit und ihre Lebensdauer definiert. Sichtbarkeit bedeutet, welche Teile Ihres Programms darauf zugreifen können. Die Lebensdauer definiert, wann es erstellt und wann es zerstört wird. An der Macht

Typ:Schlüsselwort |Kategorie:Variablen und Umfang

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Numerische Variablen werden auf Null (0) initialisiert. Dynamische Zeichenfolgen, Feldzeichenfolgen und mit NULL endende Zeichenfolgen werden auf eine Länge von Null (keine Zeichen) initialisiert. Zeichenfolgen und UDTs fester Länge werden mit CHR$ (0) gefüllt. PowerBASIC zerstört automatisch jede Variable zum richtigen Zeitpunkt, sodass Sie sich über diese Art von Speicherverlust keine Sorgen machen müssen.

Auf lokale Variablen kann nur innerhalb eines einzelnen SUB, FUNCTION, METHOD oder PROPERTY zugegriffen werden. Sie werden bei jedem Aufruf des Verfahrens automatisch erstellt und initialisiert. Sie werden automatisch gelöscht, wenn Sie den Vorgang beenden. Dies ist der Standardvariablenbereich, sofern Sie nichts anderes angeben.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Variabler Umfang soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Variabler Umfang mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Variablen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Variablen

Variablen

Variablen repräsentieren numerische Werte oder Zeichenfolgenwerte. Im Gegensatz zu Konstanten kann sich der Wert einer Variablen während der Programmausführung ändern. Variablennamen müssen wie Beschriftungen mit einem Buchstaben beginnen und können bis zu t enthalten

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Die Variablen mit einfacher Genauigkeit, EndOfMonthTotals und emt, erfordern beide genau vier Byte Laufzeitspeicher. Eine gute Faustregel besteht darin, ein Gleichgewicht zu wahren und die Variablennamen kurz genug zu halten, damit die Anweisungen in eine Zeile passen. Viele Programmierer verwenden Variablen mit einem Buchstaben für Schleifenzähler (i, j, k, l und x, y, z sind ihre Favoriten). Zur besseren Übersichtlichkeit können Sie jedoch Namen wie „Anzahl“, „Summe“, „Index“ usw. verwenden, insbesondere wenn Sie verschachtelte Schleifen haben.

PowerBASIC verfügt über viele integrierte Variablentypen: Dynamische Zeichenfolge; String fester Länge; nullterminierte Zeichenfolge; Feld, Ganzzahl; Lange Ganzzahl; Quad-Ganzzahl; Byte, Wort; Doppelwort; Einzel ; Doppelt ; und Erweiterter Gleitkommawert; Währung und WährungX ; Variant, Object, Guid sowie Pointer, Arrays und Bit- und Sbit-Bitfeld-Subtypen.

Eine Variable als bestimmten Typ deklarieren:

Verwenden Sie die DIM-Anweisung, um eine Variable zu deklarieren und die AS-Typ-Syntax zu verwenden:

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Variablen soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Variablen mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


VARIANT$/VARIANT$$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › VARIANT$/VARIANT$$

VARIANTE$/VARIANTE$$

Gibt die Byte-Zeichenfolge zurück

Typ:Funktion |Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

AnsiVar = VARIANT$( VrntVar )
WideVar = VARIANT$$( VrntVar )
TypeVar = VARIANT$(BYTE, VrntVar )

Beschreibung

VARIANT$ extrahiert einen String aus einer Variant-Variablen, wenn dort ein dynamischer String (VT_BSTR) gefunden wird. Wenn die Variante einen anderen VT-Typ enthält, wird eine leere Zeichenfolge zurückgegeben. Per Definition ist ein BSTR eine breite Unicode-Zeichenfolge. Im Allgemeinen kann man mit Sicherheit davon ausgehen, dass dies der Fall ist, es sei denn, die Variante wurde von PowerBASIC erstellt und Sie wissen, dass das interne Format Bytes und nicht breite Unicode-Wörter sind.

Die erste Form von VARIANT$ konvertiert den breiten Unicode-Inhalt in ANSI und gibt ihn als ANSI-Zeichenfolge zurück. Die zweite Form von VARIANT$$ gibt den Inhalt direkt als breiten Unicode-String zurück. Natürlich übernimmt PowerBASIC in allen Zuweisungs- und Parametersituationen automatisch alle erforderlichen Konvertierungen zwischen ANSI- und WIDE-Stringwerten. Aus diesem Grund sollte diesem Vorgang für die ANSI/WIDE-Konvertierung kein zusätzlicher Code hinzugefügt werden. Bedenken Sie außerdem, dass die richtige Wahl der Funktion die Leistung Ihres Programms verbessern kann.

PBXB64 V14.4 implementiert VARIANT$$ derzeit fuer die stringbasierte VARIANT-Nutzlast des Compilers. Die fokussierte Regression tests/pb/test_variant_dollar_dollar.pb prueft die Zuweisung an WSTRING fuer eine ASCII-String-Nutzlast und prueft, dass Nicht-String-Varianten eine leere WSTRING zurueckgeben. Vollstaendige COM-BSTR-ABI- und Unicode-Transcoding-Paritaet bleiben breitere Kompatibilitaetsarbeit.

Wenn die Option BYTE angegeben ist, teilen Sie PowerBASIC mit, dass die Zeichenfolge eine Reihe von BYTES und keine breiten Unicode-Wörter enthält. Dies wäre der Fall, wenn Sie einen benutzerdefinierten Typ in einer Variante hinterlegt hätten:

LET VariantVar = ThisUDTVar AS STRING

ThatUDTVar = VARIANT$(BYTE, VariantVar )

Diese Form von VARIANT$ gibt den Inhalt immer als ANSI-Byte-String zurück. Dieses Ergebnis kann einer ANSI-Stringvariablen oder einem benutzerdefinierten Typ zugewiesen werden.

Vermächtnis

Ältere Legacy-Programme waren gezwungen, Unicode-Zeichen in einer ANSI-String-Variablen zu speichern, da Wide-String-Variablen noch nicht verfügbar waren. Diese Programme sollten weiterhin VARIANT$ mit ACODE$ und Variantenzuweisung mit UCODE$ verwenden, bis die Programmlogik aktualisiert wird, um breite Unicode-Variablen zu verwenden.

Siehe auch

  • DIM
  • LET
  • OBJECT
  • LET (mit Varianten)
  • VARIANTE#
  • VARIANTEVT

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für VARIANTE$/VARIANTE$$ soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' VARIANTE$/VARIANTE$$ mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


VARIANTVT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › VARIANTVT

VARIANTEVT

Bestimmen Sie den internen Datentyp der in a gespeicherten Daten

Typ:Funktion |Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

numericvar = VARIANTVT( vrntvar )

Beschreibung

Die Funktion VARIANTVT gibt den im Variant gespeicherten internen VT-Datentyp zurück. Der gesamte Bereich der %VT_-Präfixwerte wird durch die OLE-Spezifikation (COM) dokumentiert und ist in WIN32API.INC verfügbar.

Zu den wichtigsten Werten in diesem begrenzten Kontext gehören %VT_EMPTY (=0) und %VT_BSTR (=8), da die meisten anderen numerische Formate sind, die automatisch durch die LET-Anweisung (mit Varianten) und die Funktion VARIANT# aufgelöst werden.

Ergebnis

Gleichsetzen

Inhaltstyp

%VT_EMPTY

Eine leere Variante

%VT_NULL

Nullwert

%VT_I2

Ganze Zahl

%VT_I4

Lange Ganzzahl

%VT_R4

Single

%VT_R8

Doppelt

%VT_CY

Währung

%VT_DATE

%VT_BSTR

Dynamische Zeichenfolge

%VT_DISPATCH

IDispatch

%VT_ERROR

Fehlercode

%VT_BOOL

Boolean

%VT_VARIANT

Variante

%VT_UNKNOWN

IUnbekannt

%VT_DECIMAL

Dezimal

%VT_I1

Byte (mit Vorzeichen)

%VT_UI1

Byte (ohne Vorzeichen)

%VT_UI2

%VT_UI4

%VT_I8

Quad (signiert)

%VT_UI8

Quad (ohne Vorzeichen)

%VT_INT

Lange Ganzzahl

%VT_UINT

%VT_VOID

Ein Hohlraumtyp im C-Stil

%VT_HRESULT

COM-Ergebniscode

%VT_PTR

Zeiger

%VT_SAFEARRAY

VB-Array

%VT_CARRAY

Ein Array im C-Stil

%VT_USERDEFINED

Benutzerdefinierter Typ

%VT_LPSTR

%VT_LPWSTR

Unicode-Zeichenfolge

%VT_RECORD

%VT_FILETIME

Ein FILETIME-Wert

%VT_BLOB

Ein beliebiger Speicherblock

%VT_STREAM

Ein Bytestrom

%VT_STORAGE

Name des Speichers

%VT_STREAMED_OBJECT

Ein Stream, der ein Objekt enthält

%VT_STORED_OBJECT

Ein Speicherobjekt

%VT_BLOB_OBJECT

Ein Speicherblock, der ein Objekt darstellt

%VT_CF

Zwischenablageformat

%VT_CLSID

Klassen-ID

&H1000

%VT_VECTOR

Ein Array mit führender Anzahl

&H2000

%VT_ARRAY

&H4000

%VT_BYREF

Ein Referenzwert

Wenn ein Variant ein vollständiges Array enthält, wird der Variant-Typ durch Hinzufügen des Basistyps zum Array-Modifikator bestimmt. Das heißt, für ein String-Array wäre es %VT_BSTR plus %VT_ARRAY (= &H2008).

Quad-Arrays innerhalb von Varianten werden von den meisten Windows-Versionen nicht unterstützt. Das Ergebnis von VARIANTVT kann verwendet werden, um zu sehen, ob ein solches Array ordnungsgemäß erstellt wurde.

Siehe auch

  • DIM
  • Just what is COM?
  • OBJECT
  • LET (mit Varianten)
  • VARIANTE#
  • VARIANTE$
  • VARIANTE$$
  • Was ist überhaupt ein Objekt?

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VARPTR – PBXB64-Compiler-Hilfe

Startseite › Funktionen › VARPTR

VARPTR

Gibt die 32-Bit-Adresse von a zurück

Typ:Funktion |Kategorie: Memory & Pointers

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

y = VARPTR( variable )

Beschreibung

VARPTR gibt eine vollständige 32-Bit-Adresse als Doppelwortwert (DWORD) an die angegebene Variable zurück. Variable ist eine beliebige Zeichenfolge, eine beliebige Zahl, eine Strukturvariable (benutzerdefinierter Typ oder Union) oder ein Element eines Arrays. VARPTR gibt einen Zeiger (32-Bit-Adresse im Speicher) zurück, auf den die variablen Daten gespeichert sind.

VARPTR kann auch zum Auffinden eines Array-Deskriptors sowie der Array-Daten selbst verwendet werden. Um die Adresse eines Array-Deskriptors zu finden, verwenden Sie den Array-Namen mit leeren Klammern: VARPTR( x( ) ).

Wenn Sie VARPTR verwenden, um die Adresse einer dynamischen Zeichenfolge (mit variabler Länge) abzurufen, beachten Sie, dass der zurückgegebene Wert die Adresse des Zeichenfolgenhandles ist und nicht die tatsächlichen Daten in der Zeichenfolge. Dies kann nützlich sein, um ein dynamisches String-Array mit indizierten Zeigern zu manipulieren, zum Beispiel:

DIM A$(100), b$, pA AS STRING PTR, x&

' Angenommen, A$() ist hier gefüllt

pA = VARPTR(a$(0)) ' 1. Element-Handle

FOR X& = 0 BIS 100

B$ = B$ + @pA[x&] + ","

NÄCHSTES x&

Mit STRPTR können Sie die Adresse der String-Daten ermitteln. Bei Verwendung mit Zeigern gibt VARPTR die Adresse des Zeigers selbst zurück.

Einschränkungen

VARPTR kann nicht für Registervariablen verwendet werden, da Registervariablen in internen Prozessorregistern und nicht im Anwendungsspeicher gespeichert werden. VARPTR kann für UDT- und Union-Variablen verwendet werden, jedoch nicht für den UDT-Definitionsnamen. Zum Beispiel:

TYP MyType

ABC SO LANG

END-TYP

' Mehr Code hier

DIM x AS MyTYPE, y&

y& = VARPTR(x) ' Das ist legal

y& = VARPTR(MyType) ' Dies ist nicht der Fall

Siehe auch

  • CODEPTR
  • BLICK
  • Hinweise
  • STICK
  • STRPTR

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


ÃœBERPRÃœFEN “ Hilfe zum PBXB64-Compiler

Startseite â€º Funktionen â€º VERIFY

VERIFY

Gibt die Position des ersten Zeichens in MainString zurueck, das nicht in MatchString enthalten ist.

Kind: Funktion | Category: String-Funktionen

PBXB64 Status: VERFUEGBAR

PBXB64 Certification: [ZERTIFIZIERT GETESTET]

Syntax

x = VERIFY([ start& ,] MainString , MatchString )

Beschreibung

Gibt die Position des ersten Zeichens in MainString zurueck, das nicht in MatchString enthalten ist. VERIFY scannt ab der optionalen 1-basierten Startposition und liefert null, wenn jedes verbleibende Zeichen zu MatchString gehoert.

Praktische Verwendung

Verwenden Sie VERIFY, um einen String gegen eine feste Zeichenmenge zu pruefen, bevor Sie Parser oder numerische Konvertierungen aufrufen.

Parameter und Ergebnisse

Argumente muessen den Datentypen, der Reihenfolge und den optionalen Teilen aus dem Syntaxblock folgen. Initialisieren Sie Zielvariablen vor dem Aufruf, damit unveraenderte Werte nach einem Fehler sichtbar bleiben.

Einschränkungen

Da das Ergebnis eine Position ist, kann null entweder Erfolg oder einen ungueltigen Startwert bedeuten.

Verhalten

VERIFY scannt ab der optionalen 1-basierten Startposition und liefert null, wenn jedes verbleibende Zeichen zu MatchString gehoert.

Wird ein Zeichen ausserhalb der Menge gefunden, gibt die Funktion seine 1-basierte Position in MainString zurueck.

Ein Startwert von null, ein Wert links vom String oder ein Wert hinter dem String liefert sofort null.

Verwendungshinweise

Verwenden Sie VERIFY, um einen String gegen eine feste Zeichenmenge zu pruefen, bevor Sie Parser oder numerische Konvertierungen aufrufen.

Die Funktion arbeitet byteweise und ist gross-/kleinschreibungsabhaengig. Wenn Sie das passende Zeichen selbst brauchen, verwenden Sie SCAN$.

Grenzfaelle

Da das Ergebnis eine Position ist, kann null entweder Erfolg oder einen ungueltigen Startwert bedeuten.

Ein leerer Quellstring liefert null, weil es kein nicht passendes Zeichen zu melden gibt.

Beispiel

FUNCTION PBMAIN() AS LONG
    DIM src AS STRING
    DIM setchars AS STRING
    DIM n AS LONG

    src = "12345"
    setchars = "0123456789"
    n = VERIFY(src, setchars)
    IF n <> 0 THEN FUNCTION = 1 : EXIT FUNCTION

    src = "123A5"
    n = VERIFY(src, setchars)
    IF n <> 4 THEN FUNCTION = 2 : EXIT FUNCTION

    n = VERIFY(5, src, setchars)
    IF n <> 0 THEN FUNCTION = 3 : EXIT FUNCTION

    FUNCTION = 0
END FUNCTION

Test- und Dokumentationshinweise

Mit tests/pb/test_string_scan_tally_verify.pb kompiliert und ausgefuehrt; Exitcode 0.

Validierungsbeleg

Mit tests/pb/test_string_scan_tally_verify.pb kompiliert und ausgefuehrt; Exitcode 0. VERIFY(5, src, setchars)

Verifiziertes Beispiel

Beispieldatei: tests/pb/test_string_scan_tally_verify.pb

Validierungsbeleg: Mit tests/pb/test_string_scan_tally_verify.pb kompiliert und ausgefuehrt; Exitcode 0.

FUNCTION PBMAIN() AS LONG
    DIM src AS STRING
    DIM setchars AS STRING
    DIM n AS LONG

    src = "12345"
    setchars = "0123456789"
    n = VERIFY(src, setchars)
    IF n <> 0 THEN FUNCTION = 1 : EXIT FUNCTION

    src = "123A5"
    n = VERIFY(src, setchars)
    IF n <> 4 THEN FUNCTION = 2 : EXIT FUNCTION

    n = VERIFY(5, src, setchars)
    IF n <> 0 THEN FUNCTION = 3 : EXIT FUNCTION

    FUNCTION = 0
END FUNCTION

Fokus: VERIFY(5, src, setchars)

Siehe auch

  • INSTR
  • SCAN$
  • TALLY
  • VAL

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurueck zum Befehlsindex


WEND - WHILE-Schleife schliessen — PBXB64 Help

Startseite › General Reference › WEND - WHILE-Schleife schliessen — PBXB64 Help
Hilfe zum PBXB64-Compiler

WEND - WHILE-Schleife schliessen

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

WHILE x < 10
  INCR x
WEND

Detailverhalten

Legacy-Schleifenabschluss fuer WHILE...WEND-Kompatibilitaet.

Praktische Verwendung

Verwenden Sie dieses Keyword als Schleifenabschluss in der getesteten DO/LOOP- oder WHILE/WEND-Schreibweise. Es gehoert syntaktisch an das Ende der Schleife und nicht in den Schleifenkopf.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Ein fehlender Loop-Hauptteil, ein falscher Schleifentyp oder ein zu fruehes Abschlusskeyword sollte nicht still durchrutschen. Die Endposition gehoert in die passende Kontrollform.

Verifiziertes Beispiel

Abgedeckt durch PB keyword compatibility (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


What Are Connection Points? - PBXB64 Compiler Help

Startseite › General Reference › What Are Connection Points?
Hilfe zum PBXB64-Compiler

What Are Connection Points?

Connection points are the COM event mechanism used by an object to call back into a client-supplied event sink. They are common in ActiveX and automation components.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

Connection points are the COM event mechanism used by an object to call back into a client-supplied event sink. They are common in ActiveX and automation components.

Verwendung in PBXB64

PBXB64 users should document the source interface, sink interface, reference-counting rules, and disconnect path before porting this pattern.

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex

Kind: Reference topic | Category: COM Concepts

PBXB64 Status: DOCUMENTED

Description

COM concept page retained for navigation. It explains terminology and does not certify untested event-sink or connection-point runtime behavior.

Syntax

Concept page; no direct PBXB64 syntax.

Validation Evidence

Validation evidence: Concept documentation only; COM runtime claims require focused PB tests.

Example

' Concept page; use linked COM helper pages for executable samples.

See Also

  • cmd_com.html
  • cmd_objresult.html


What Does A Class Look Like? - PBXB64 Compiler Help

Startseite › General Reference › What Does A Class Look Like?
Hilfe zum PBXB64-Compiler

What Does A Class Look Like?

A COM class is exposed through interfaces, a class identifier, and factory/activation metadata. Client code normally works through interface pointers rather than direct structure access.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

A COM class is exposed through interfaces, a class identifier, and factory/activation metadata. Client code normally works through interface pointers rather than direct structure access.

Verwendung in PBXB64

When translating examples, separate object construction, interface acquisition, method calls, error checks, and release logic.

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex

Kind: Reference topic | Category: COM Concepts

PBXB64 Status: DOCUMENTED

Description

COM class concept page retained for navigation and background. Do not infer full CLASS implementation from this concept topic.

Syntax

Concept page; no direct PBXB64 syntax.

Validation Evidence

Validation evidence: Concept documentation only; class/OOP claims require focused PB tests.

Example

' Concept page; use linked CLASS or COM pages for executable samples.

See Also

  • cmd_class_end_class.html
  • cmd_com.html


What Does An Interface Look Like? - PBXB64 Compiler Help

Startseite › General Reference › What Does An Interface Look Like?
Hilfe zum PBXB64-Compiler

What Does An Interface Look Like?

A COM interface is a vtable contract with fixed method order and calling convention. The first three methods are normally IUnknown: QueryInterface, AddRef, and Release.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

A COM interface is a vtable contract with fixed method order and calling convention. The first three methods are normally IUnknown: QueryInterface, AddRef, and Release.

Verwendung in PBXB64

PBXB64 declarations must match the binary layout exactly: pointer size, parameter types, HRESULT returns, and ByVal/ByRef behavior all matter.

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.

Zurück zum Befehlsindex

Kind: Reference topic | Category: COM Concepts

PBXB64 Status: DOCUMENTED

Description

COM interface concept page retained for navigation and background. It describes terminology separately from tested PBXB64 lowering.

Syntax

Concept page; no direct PBXB64 syntax.

Validation Evidence

Validation evidence: Concept documentation only; interface claims require focused PB tests.

Example

' Concept page; use linked INTERFACE or COM pages for executable samples.

See Also

  • cmd_interface_end_interface_block.html
  • cmd_com.html


What Is A COM Component? - PBXB64 Compiler Help

Startseite › General Reference › What Is A COM Component?
Hilfe zum PBXB64-Compiler

What Is A COM Component?

A COM component is a binary object that exposes one or more interfaces and is activated through class registration, a class factory, or direct hosting.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

A COM component is a binary object that exposes one or more interfaces and is activated through class registration, a class factory, or direct hosting.

Verwendung in PBXB64

For PBXB64 documentation, list required registration, threading model, interface IDs, and failure handling for every COM sample.

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.

Zurück zum Befehlsindex

COM-Prüfung

COM-Konzeptseiten sollen Begriffe mit einem funktionierenden PBXB64-Szenario verbinden: Interface-Deklaration, HRESULT-Prüfung, Objekterzeugung, Methodenaufruf und Cleanup. Beispiele sollen nennen, welche COM-Komponente oder Windows-Schnittstelle benötigt wird.

Fehlerbehandlung

Dokumentieren Sie Erfolgs- und Fehler-HRESULTs getrennt. Ein Beispiel soll bei Fehlern verzweigen, den numerischen HRESULT für Diagnosen erhalten und keinen beliebigen Nicht-Null-Wert als boolesches Ergebnis behandeln.

Kind: Reference topic | Category: COM Concepts

PBXB64 Status: DOCUMENTED

Description

COM component concept page retained for navigation and background. It does not certify full COM server/client parity.

Syntax

Concept page; no direct PBXB64 syntax.

Validation Evidence

Validation evidence: Concept documentation only; COM helper pages carry tested claims where available.

Example

' Concept page; use linked COM helper pages for executable samples.

See Also

  • cmd_com.html
  • cmd_objresult.html


Was ist eine DLL? - PBXB64-Compiler-Hilfe

Startseite › Funktionen › Was ist eine DLL?
Hilfe zum PBXB64-Compiler

Was ist eine DLL?

Eine Dynamic Link Library (DLL) ist ein ausführbares Windows-Bibliotheksmodul, das eine oder mehrere Subs, Functions oder Klassen enthält, die von ausführbaren Dateien oder anderen DLLs aufgerufen werden können. Im Gegensatz zu ausführbaren Dateien ist dies bei DLLs nicht der Fall

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Um eine bessere Vorstellung davon zu bekommen, wie eine DLL funktioniert, ist es hilfreich, den Unterschied zwischen statischer und dynamischer Verknüpfung zu verstehen. Bei der statischen Verknüpfung werden ein oder mehrere Module geschrieben und diese dann zusammen mit allen anderen Laufzeit-, Drittanbieter- usw. Bibliotheken verknüpft, die möglicherweise erforderlich sind, um ein vollständiges, eigenständiges ausführbares Programm zu erstellen. Wenn ein Programm ein Sub oder eine Funktion aus einer Static-Link-Bibliothek verwendet, wird eine Kopie dieses Sub- oder Funktionscodes statisch in die ausführbare Datei des Programms verknüpft.

Wenn zwei Programme, die gleichzeitig ausgeführt werden, dieselbe Routine aus einer Bibliothek verwenden, verfügen sie jeweils über eine eigene Kopie dieser Routine. Es wäre effizienter, wenn die beiden Programme eine einzige Kopie der Routine gemeinsam nutzen könnten. DLLs bieten diese Funktion, indem sie die Verweise Ihrer Anwendung auf externe Prozeduren zur Laufzeit auflösen.

Im Gegensatz zu einer Static-Link-Bibliothek ist der Code in einer DLL nicht mit einem Programm verknüpft, das die DLL verwendet. Stattdessen befinden sich der Code und die Ressourcen einer DLL in einer separaten ausführbaren Datei, normalerweise mit der Erweiterung .DLL. Diese Datei muss vorhanden sein, wenn die Anwendung ausgeführt wird. Sie müssen noch ein oder mehrere Module schreiben, um die für Ihre Anwendung spezifischen Funktionen zu implementieren.

Der Verknüpfungsprozess ist jedoch in zwei Phasen unterteilt. Sie platzieren zunächst DECLARE-Anweisungen in Ihrer Anwendung, um die Verweise Ihres Programms auf die DLL-Dienste vorübergehend zu erfüllen und so eine EXE- (oder DLL-)Datei zu erstellen. Die zweite Phase findet zur Laufzeit statt, wenn Ihr Programm einen der DLL-Dienste aufruft.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Was ist eine DLL? soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Was ist eine DLL? mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Was ist eine Ressourcendatei? - PBXB64-Compiler-Hilfe

Startseite › Funktionen › Was ist eine Ressourcendatei?
Hilfe zum PBXB64-Compiler

Was ist eine Ressourcendatei?

Übersicht über Windows-Ressourcendateien und deren Einbindung.

Typ:Konzeptionell |Kategorie: Präprozessor und Metaanweisungen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Überblick

Dieses Thema bietet Hintergrundinformationen und praktische Anleitungen. Eine detaillierte Syntax finden Sie auf den entsprechenden Befehlsseiten.

Siehe auch

  • Befehlsindex

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


What Is An HRESULT? - PBXB64 Compiler Help

Startseite › General Reference › What Is An HRESULT?
Hilfe zum PBXB64-Compiler

What Is An HRESULT?

HRESULT is the standard 32-bit COM status value. Non-negative values indicate success or informational status; negative values indicate failure.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

HRESULT is the standard 32-bit COM status value. Non-negative values indicate success or informational status; negative values indicate failure.

Verwendung in PBXB64

Always check HRESULT values after COM calls. Do not assume a method succeeded because an output pointer looks non-null.

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.

Zurück zum Befehlsindex

COM-Prüfung

COM-Konzeptseiten sollen Begriffe mit einem funktionierenden PBXB64-Szenario verbinden: Interface-Deklaration, HRESULT-Prüfung, Objekterzeugung, Methodenaufruf und Cleanup. Beispiele sollen nennen, welche COM-Komponente oder Windows-Schnittstelle benötigt wird.

Fehlerbehandlung

Dokumentieren Sie Erfolgs- und Fehler-HRESULTs getrennt. Ein Beispiel soll bei Fehlern verzweigen, den numerischen HRESULT für Diagnosen erhalten und keinen beliebigen Nicht-Null-Wert als boolesches Ergebnis behandeln.

Kind: Reference topic | Category: COM Concepts

PBXB64 Status: DOCUMENTED

Description

HRESULT concept page retained for COM helper navigation. PBXB64's tested HRESULT surface is documented on OBJRESULT pages.

Syntax

hr& = OBJRESULT

Validation Evidence

Validation evidence: See tests/pb/test_objresult_string.pb for the focused HRESULT helper behavior.

Example

hr& = OBJRESULT
text$ = OBJRESULT$(hr&)

See Also

  • cmd_objresult.html
  • cmd_objresult$.html


What Is An Object Anyway? - PBXB64 Compiler Help

Startseite › General Reference › What Is An Object Anyway?
Hilfe zum PBXB64-Compiler

What Is An Object Anyway?

In COM-oriented BASIC documentation, an object is a runtime component accessed through an interface pointer. The caller sends method calls through that interface contract.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

In COM-oriented BASIC documentation, an object is a runtime component accessed through an interface pointer. The caller sends method calls through that interface contract.

Verwendung in PBXB64

For PBXB64 migration, distinguish language objects, COM objects, handles, and raw pointers. They have different lifetime and ownership rules.

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.

Zurück zum Befehlsindex

Kind: Reference topic | Category: COM Concepts

PBXB64 Status: DOCUMENTED

Description

Object concept page retained for navigation and background. It is not a full OOP implementation claim.

Syntax

Concept page; no direct PBXB64 syntax.

Validation Evidence

Validation evidence: Concept documentation only; tested object helper claims are documented on their command pages.

Example

' Concept page; use linked object helper pages for executable samples.

See Also

  • cmd_com.html
  • cmd_objresult.html


Was ist eine SLL? - PBXB64-Compiler-Hilfe

Startseite › Funktionen › Was ist eine SLL?
Hilfe zum PBXB64-Compiler

Was ist eine SLL?

Eine SLL ist eine Static Link Library. In PBXB64 ist eine SLL ein deterministisches COFF-Archiv mit PBXB64-unterstuetztem Objektcode. Da es sich um eine Bibliothek handelt, kann der Code nicht eigenstaendig ausgefuehrt werden.

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Eine Static Link Library ist nuetzlich, wenn gemeinsamer Code einmal kompiliert und in einen finalen EXE- oder DLL-Host gelinkt werden soll. Der Host verwendet #LINK; nackte DECLARE FUNCTION- oder DECLARE SUB-Deklarationen koennen auf Symbole aus dem gelinkten Archiv zeigen. PBXB64-native SLLs duerfen auch andere PBXB64-native SLLs linken und unterstuetzte lokale #RESOURCE-Eintraege enthalten, die beim finalen Host-Link zusammengefuehrt werden.

PBXB64-.sll- und .pblib-Dateien sind Standard-COFF-Archive fuer PBXB64-unterstuetzte Objekte. Alte PowerBASIC-SLL-Binaerkompatibilitaet wird nicht behauptet; nicht unterstuetzte oder nicht-archivartige Eingaben schlagen mit Linkerdiagnosen fehl.

Eine PBXB64-SLL enthaelt nur das kompilierte Benutzerobjekt der Unit. Sie enthaelt keinen Einstiegspunkt, keine EXE- oder DLL-Kopfstruktur und keine Kopie der eingebetteten PBXB64-Laufzeit. Dadurch kann dieselbe Bibliothek in unterschiedliche Hostprogramme gelinkt werden, waehrend der finale Host die Startup- und Laufzeitteile genau einmal einbindet.

Erstellen einer statischen Linkbibliothek

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Was ist eine SLL? soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Was ist eine SLL? mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Was ist VERSAND? - PBXB64-Compiler-Hilfe

Startseite › Funktionen › Was ist DISPATCH?
Hilfe zum PBXB64-Compiler

Was ist VERSAND?

Die DISPATCH INTERFACE ist eine langsamere Form der Schnittstelle, die ursprünglich als Teil von Microsoft Visual Basic eingeführt wurde. Eine Implementierung der COM DISPATCH-Unterstützung wurde in einer früheren Version von PowerBA eingeführt

Typ:Schlüsselwort |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Wenn Sie DISPATCH verwenden, übergibt der Compiler tatsächlich den Namen der METHOD, die Sie ausführen möchten, als Textzeichenfolge. Auf die gleiche Weise können auch die Parameter übergeben werden. Das Objekt muss dann die Namen nachschlagen und anhand der bereitgestellten Textzeichenfolgen entscheiden, welche METHODE ausgeführt werden soll und welche Parameter verwendet werden sollen. Als ob das nicht genug wäre, erfordert DISPATCH, dass alle Parameter und Rückgabewerte als VARIANT-Variablen übergeben werden, wobei alle diese Konvertierungen in der Verantwortung des Programmierers liegen. Das stimmt, du. Dies ist ein langsamer Prozess. DISPATCH ist jedoch flexibel, bequem und fehlerverzeihend. Darüber hinaus werden Sie feststellen, dass viele Skriptsprachen und Anwendungen DISPATCH als einzige Betriebsmethode verwenden, sodass eine kontinuierliche Unterstützung unbedingt erforderlich ist.

Was ist überhaupt ein Objekt?

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Was ist VERSAND? soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Was ist VERSAND? mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Was ist Vererbung? - PBXB64-Compiler-Hilfe

Startseite › Funktionen › Was ist Vererbung?
Hilfe zum PBXB64-Compiler

Was ist Vererbung?

Bei der Vererbung geht es um die Wiederverwendung von Code. Sie können die Definitionen einer Schnittstelle oder komplette Codeabschnitte wiederverwenden.

Typ:Schlüsselwort |Kategorie: COM & Objects

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

INTERFACE INHERITANCE ist durch COM-Standards definiert und für die Verwendung durch jedes COM-Objekt verfügbar. Diese Form der Vererbung gilt nur für die Definition jedes Elements in einer Schnittstelle und nicht für den zugrunde liegenden Code. Durch die Schnittstellenvererbung haben Sie die Möglichkeit, eine Schnittstelle in mehreren Klassen (Objekten) zu verwenden. Da die Schnittstellendefinition in jeder Instanz identisch bleibt, können Sie häufig denselben (oder ähnlichen) Code verwenden, um verschiedene Objekte zu manipulieren. Bei dieser Form der Vererbung muss der Programmierer für jede der Methoden und Eigenschaften in jeder Implementierung der Schnittstelle geeigneten Code bereitstellen.

IMPLEMENTIERUNGSVERERBUNG ist der Prozess, bei dem eine KLASSE die gesamte Funktionalität einer an anderer Stelle implementierten Schnittstelle ableitet. Das heißt, die abgeleitete Klasse verfügt nun über alle Methoden und Eigenschaften dieser neuen, erweiterten Version einer Basisklasse! Diese Form der Vererbung wird von PowerBASIC angeboten, obwohl sie in der COM-Spezifikation nicht erforderlich ist.

Sie können die Funktionalität einer zuvor erstellten Schnittstelle erweitern, indem Sie der abgeleiteten Schnittstelle/Klasse neue Methoden und Eigenschaften hinzufügen. Die Syntax zum Hinzufügen zusätzlicher Methoden (nicht in der Basisklasse) ist dieselbe wie beim Hinzufügen von Methoden zu einer Standardklasse – fügen Sie einfach wie immer Methoden und Eigenschaften hinzu.

Sie können die Funktionalität einer bestimmten Methode oder Eigenschaft ergänzen oder ersetzen, indem Sie eine Ersetzung codieren, der das Wort OVERRIDE vorangestellt ist. Die überschreibende Methode muss denselben Namen und dieselbe Signatur (Parameter, Rückgabewert usw.) haben wie die Methode, die sie ersetzt. Wenn Sie eine neue Methode in einer abgeleiteten Klasse implementieren, können Sie eine Methode in der Basisklasse aufrufen, indem Sie das Pseudoobjekt MYBASE verwenden. Dadurch können Sie die ursprüngliche Funktionalität erweitern oder vollständig ersetzen.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Was ist Vererbung? soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Was ist Vererbung? mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


WHILE/WEND-Anweisungen ? PBXB64-Compiler-Hilfe

Startseite ? Funktionen ? WHILE/WEND-Anweisungen

WHILE/WEND-Anweisungen

Definieren Sie einen Block von Programmanweisungen, die wiederholt ausgef?hrt werden, solange bestimmte Bedingungen erf?llt sind.

Typ:Anweisung |Kategorie: Control Flow

PBXB64-Status:VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

WHILE integer_expression
[ statements ]
[EXIT LOOP]
WEND

Beschreibung

Wenn integer_expression TRUE ist (es ergibt einen Wert ungleich Null), werden alle Anweisungen zwischen WHILE und dem abschlie?enden WEND ausgef?hrt. PowerBASIC springt dann zur?ck zur WHILE-Anweisung und wiederholt den Test. Wenn es immer noch TRUE ist, f?hrt PowerBASIC die eingeschlossenen Anweisungen erneut aus. Dieser Vorgang wird wiederholt, bis der Testausdruck Null ergibt oder eine EXIT-Anweisung gefunden wird. In beiden F?llen geht die Ausf?hrung zur Anweisung ?ber, die auf WEND folgt.

Wenn integer_expression beim ersten Durchgang FALSE (Null) ergibt, wird keine der Anweisungen in der Schleife ausgef?hrt.

Mit WHILE/WEND-Anweisungen erstellte Schleifen k?nnen verschachtelt (ineinander eingeschlossen) werden. Jedes WEND stimmt mit dem letzten nicht ?bereinstimmenden WHILE ?berein.

Eine Verwendung einer WHILE/WEND-Schleife besteht darin, Daten aus einer Datei einzugeben, bis das Ende der Datei erreicht ist:

i& = 0

WHILE ISFALSE EOF(1)

INCR i&

LINE INPUT #1, FileTxt$(i&)

Obwohl es dem Compiler egal ist, ist es eine gute Idee, die Anweisungen zwischen WHILE und WEND einzur?cken, um die Struktur der von Ihnen erstellten Schleife zu verdeutlichen.

Beachten Sie, dass der folgende Code in einer Endlosschleife erstellt wird:

WHILE -1

[Anweisungn]

Um eine WHILE/WEND-Schleife vorzeitig zu verlassen, verwenden Sie die Anweisung EXIT LOOP.

Das DO/LOOP-Konstrukt von PowerBASIC bietet eine flexiblere M?glichkeit, bedingte Schleifen zu erstellen.

Hinweise zur Kurzschlussbewertung von PowerBASIC und ihren m?glichen Nebenwirkungen finden Sie auch in der Diskussion zur IF-Anweisung.

Verifiziertes Beispiel: WHILE...WEND - Schleife mit Vorabpruefung

Beispieldatei: examples/basic/help_control_flow/help_while.pb

Validierungsnachweis: tests/integration/pbxa64/control_flow/test_control_flow_comprehensive.pb

Validation evidence: the registered control-flow regression(s) named above compile and run with exit code 0, proving the page-specific branch, loop, or exception behavior documented here.

FUNCTION PBMAIN() AS LONG
    LOCAL i AS LONG
    WHILE i < 5
        i = i + 1
    WEND
    IF i <> 5 THEN FUNCTION = 1 ELSE FUNCTION = 0
END FUNCTION

Verhalten: Testet WHILE/WEND mit einer Bedingung, die vor jeder Iteration geprueft wird.

Siehe auch

  • #OPTIMIEREN
  • DO/LOOP
  • AUSFAHRT
  • FOR EACH/NEXT
  • FOR/WEITER
  • ITERATE
  • Kurzschlussauswertung

Beispiel

#COMPILE EXE
#DIM ALL
' controlflow_while_wend
FUNCTION PBMAIN() AS LONG
  LOCAL i AS LONG
  LOCAL s AS LONG
  i = 1
  s = 0
  WHILE i <= 5
    s = s + i
    i = i + 1
  WEND
  IF (s) <> (15) THEN FUNCTION = 1: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Warum DLLs verwenden? - PBXB64-Compiler-Hilfe

Startseite › Funktionen › Warum DLLs verwenden?
Hilfe zum PBXB64-Compiler

Warum DLLs verwenden?

Es gibt eine Reihe mildernder Gründe für die Erstellung einer DLL. Unter ihnen sind:

Typ:Schlüsselwort |Kategorie:Allgemein

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Teile Ihres Codes sind zwar funktionsfähig, werden jedoch möglicherweise nicht so schnell ausgeführt, wie Sie möchten. Sobald Sie die Engpassbereiche isoliert haben, ist eine Maschinencode-DLL die offensichtliche Wahl, um nur die Bereiche Ihrer Anwendung zu optimieren, die zu langsam laufen.

Wenn eine DLL im Gegensatz zu herkömmlichen Bibliotheken vom Betriebssystem in den Speicher geladen wird, können alle anderen Programme (oder DLLs) auf ihre Subs und Funktionen zugreifen. Es muss nur eine Kopie der DLL im Speicher vorhanden sein. Dies ist möglich, da die Bibliothek nicht dauerhaft mit einem der Programme verknüpft ist. Es ist im Speicher vorhanden und stellt seine Dienste jedem Programm (oder jeder anderen DLL) zur Verfügung, das sie möglicherweise benötigt.

Möglicherweise verfügen Sie über eine Reihe von Verfahren, die für mehrere verschiedene Anwendungen gleich sind. Anstatt diese Prozeduren in jeder Anwendung erscheinen zu lassen, die sie benötigt, ist es besser, sie in einer DLL abzulegen, wo alle Anwendungen auf sie zugreifen können. Dies reduziert die Größe Ihrer ausführbaren Dateien und gibt Ihnen gleichzeitig die Flexibilität, die DLL selbst zu aktualisieren, ohne jede Anwendung, die ihre Dienste nutzt, neu kompilieren zu müssen.

Eine DLL kann aktualisiert und weitergegeben werden, ohne dass eine der Anwendungen (oder anderen DLLs), die ihre Dienste nutzen, neu kompiliert werden muss.

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.

Beschreibung

Sprachuebergreifende Themen sollen erklaeren, wie die Funktion zu den aktuellen PBXB64-Frontends, dem x64-Laufzeitmodell und Migrationsgrenzen passt. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für Warum DLLs verwenden? soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Warum DLLs verwenden? mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Win32-API-Updates einschließen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Win32-API enthält Updates

Win32-API enthält Aktualisierungen

Zu den Hinweisen zur Win32-API gehören Dateiaktualisierungen.

Typ:Konzeptionell |Kategorie: Entwicklung

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Überblick

Dieses Thema bietet Hintergrundinformationen und praktische Anleitungen. Eine detaillierte Syntax finden Sie auf den entsprechenden Befehlsseiten.

Siehe auch

  • Befehlsindex

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


WINDOW GET HANDLE “ PBXB64-Compiler-Hilfe

Startseite â€º Funktionen â€º WINDOW GET HANDLE

FENSTER GET HANDLE

Manipulieren Sie ein Fenster im Programm, was das Festlegen oder Abrufen von Daten umfassen kann. Das Zielfenster kann einer beliebigen Klasse angehören, einschlieÃŸlich einer CONTROL-Klasse

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÃœGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

WINDOW GET HANDLE hWin , ID& TO DataVar&
WINDOW GET ID hWin TO DataVar&
WINDOW GET PARENT hWin TO DataVar&
WINDOW GET STYLE hWin TO DataVar&
WINDOW GET STYLEX hWin TO DataVar&
WINDOW GET USER hWin TO DataVar&

Beschreibung

Die WINDOW-Anweisung kann mit jeder Art von Fenster in Ihrem Programm verwendet werden, einschlieÃŸlich eines Steuerelements oder Dialogs. Im Allgemeinen wird das zu manipulierende oder zu testende Fenster anhand seines Handles (hWin) identifiziert, das häufig zum Zeitpunkt der Erstellung abgerufen wird. Da auf ein Steuerelement jedoch normalerweise über eine Kombination aus â€žParent/IDâ€œ zugegriffen wird, müssen Sie zu diesem Zweck WINDOW GET HANDLE oder CONTROL HANDLE verwenden, um dessen Handle abzurufen. Wenn die Operation fehlschlägt, wird der Ergebnisvariablen der Wert Null (0) zugewiesen.

WINDOW GET HANDLE hWin, ID& TO DataVar&

Diese Anweisung ruft das Handle eines Fensters ab und übersetzt es aus dem übergeordneten Handle und der spezifischen integralen Steuerelement-ID, die zum Zeitpunkt der Erstellung angegeben wurde. hWin ist das Handle des übergeordneten Elements, ID& ist die Steuer-ID und DataVar& stellt die Variable dar, die das gewünschte Fensterhandle erhält.

FENSTER GET ID

hWin zu DataVar&

Die integrale ID des Fensters hWin wird abgerufen und der durch DataVar& bezeichneten Variablen zugewiesen. Im Allgemeinen hat nur ein CONTROL eine ID, sodass Fenster anderer Klassen normalerweise den Wert Null zurückgeben.

WINDOW GET PARENT hWin To DataVar&

Das Handle des übergeordneten Elements wird abgerufen und der durch DataVar& bezeichneten Variablen zugewiesen.

WINDOW GET STYLE hWin TO DataVar&

Der Fensterstilwert des durch das Handle hWin angegebenen Fensters wird abgerufen und der durch DataVar& bezeichneten Variablen zugewiesen.

WINDOW GET STYLEX hWin TO DataVar&

Der erweiterte Fensterstilwert des durch das Handle hWin angegebenen Fensters wird abgerufen und der durch DataVar& angegebenen Variablen zugewiesen.

FENSTER GET USER HWin TO DataVar&

Der 32-Bit-Benutzerdatenwert, der dem durch das Handle hWin angegebenen Fenster zugeordnet ist, wird abgerufen und der durch DataVar& angegebenen Variablen zugewiesen. Dieser bestimmte Benutzerdatenwert ist jedem Fenster in Ihrem Programm zugeordnet und wird vom Windows-Betriebssystem verwaltet. Es handelt sich um separate und getrennte Benutzerdaten, die von DDT für jeden mit DDT erstellten Dialog und jedes Steuerelement verwaltet werden.

Siehe auch

  • STEUERGRIFF
  • FENSTER-SET

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


WINDOW SET ID “ PBXB64 Compiler-Hilfe

Startseite â€º Funktionen â€º WINDOW SET ID

FENSTERSET-ID

Manipulieren Sie ein Fenster im Programm, was das Festlegen oder Abrufen von Daten umfassen kann. Das Zielfenster kann einer beliebigen Klasse angehören, einschlieÃŸlich einer CONTROL-Klasse

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÃœGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

WINDOW SET ID hWin , NewVal& TO OldValVar&
WINDOW SET STYLE hWin , NewVal& TO OldValVar&
WINDOW SET STYLEX hWin , NewVal& TO OldValVar&
WINDOW SET USER hWin , NewVal& TO OldValVar&

Beschreibung

Die WINDOW SET-Anweisung kann mit jedem Fenstertyp in Ihrem Programm verwendet werden, einschlieÃŸlich eines Steuerelements oder eines Dialogs. Aufgrund möglicher Nebenwirkungen ist jedoch Vorsicht geboten. Im Allgemeinen wird das zu manipulierende Fenster durch sein Handle ( hWin ) identifiziert, das häufig zum Zeitpunkt der Erstellung erhalten wird. Da auf ein Steuerelement jedoch normalerweise über eine Kombination aus â€žParent/IDâ€œ zugegriffen wird, müssen Sie zu diesem Zweck WINDOW GET HANDLE oder CONTROL HANDLE verwenden, um dessen Handle abzurufen.

WINDOW SET ID hWin , NewVal& To OldValVar&

Die integrale ID des Fensters hWin wird in NewVal& geändert. Der vorherige ID-Wert wird der durch OldValVar& bezeichneten Variablen zugewiesen. Wenn die Operation fehlschlägt, wird OldValVar& der Wert Null (0) zugewiesen. Als allgemeine Regel gilt, dass Sie die ID eines mit DDT erstellten Fensters, Dialogs oder Steuerelements nicht ändern sollten, da dies zu unvorhersehbaren Ergebnissen führt.

WINDOW SET STYLE hWin , NewVal& TO OldValVar&

Der Fensterstilwert des Fensters hWin wird in NewVal& geändert. Der vorherige Stilwert wird der durch OldValVar& bezeichneten Variablen zugewiesen. Wenn die Operation fehlschlägt, wird OldValVar& der Wert Null (0) zugewiesen.

WINDOW SET STYLEX hWin , NewVal& TO OldValVar&

Der erweiterte Fensterstilwert des Fensters hWin wird in NewVal& geändert. Der vorherige erweiterte Stilwert wird der durch OldValVar& bezeichneten Variablen zugewiesen. Wenn die Operation fehlschlägt, wird OldValVar& der Wert Null (0) zugewiesen.

WINDOW SET USER hWin , NewVal& TO OldValVar&

Der 32-Bit-Benutzerdatenwert, der dem durch das Handle hWin angegebenen Fenster zugeordnet ist, wird in NewVal& geändert. Der vorherige Benutzerdatenwert wird der durch OldValVar& bezeichneten Variablen zugewiesen. Dieser bestimmte Benutzerdatenwert ist jedem Fenster in Ihrem Programm zugeordnet und wird vom Windows-Betriebssystem verwaltet. Es handelt sich um separate und getrennte Benutzerdaten, die von DDT für jeden mit DDT erstellten Dialog und jedes Steuerelement verwaltet werden. Wenn die Operation fehlschlägt, wird OldValVar& der Wert Null (0) zugewiesen. Dies ist jedoch kein sicherer Hinweis auf einen Fehler, da der vorherige Benutzerwert möglicherweise Null war.

Siehe auch

  • STEUERGRIFF
  • FENSTER GET

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


WINMAIN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › WINMAIN

WINMAIN

WINMAIN (oder sein Synonym

Typ:Funktion |Kategorie: Procedures

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

FUNCTION {WINMAIN | MAIN} ( _
BYVAL hInstance AS DWORD, _
BYVAL hPrevInst AS DWORD, _
BYVAL lpszCmdLine AS WSTRINGZ PTR, _
BYVAL nCmdShow AS LONG ) AS LONG

Beschreibung

Rückgabewert: Der WINMAIN zugewiesene Rückgabewert ist optional, aber konventionsgemäß wird der Rückgabewert vom wParam&-Parameter einer %WM_QUIT-Nachricht abgeleitet. Normalerweise verwendet eine GUI-basierte Anwendung die WINMAIN-Funktion, um das erste GUI-Anwendungsfenster zu erstellen, und tritt dann in eine Nachrichtenschleife ein. Diese Schleife sollte beendet werden, wenn eine %WM_QUIT-Nachricht empfangen wird, und der wParam&-Parameter dieser Nachricht sollte als Rückgabewert für WINMAIN übergeben werden. Wenn WINMAIN beendet wird, bevor es in die Nachrichtenschleife eintritt, sollte WINMAIN Null zurückgeben. Konsolenanwendungen können den Rückgabewert verwenden, um eine Fehlerstufe im Bereich von 0 bis einschließlich 255 festzulegen, die an die aufrufende Anwendung zurückgegeben werden kann. Batch-Dateien können über den Batch-Befehl IF [NOT] ERRORLEVEL auf das Ergebnis reagieren. Wenn die an WINMAIN übergebenen Parameter nicht von der Anwendung selbst benötigt werden, kann anstelle von WINMAIN die PBMAIN-Funktion verwendet werden.

Die WINMAIN-Funktion wird von Windows aufgerufen, wenn eine ausführbare Anwendung zum ersten Mal geladen und ausgeführt wird. Er wird oft als „Einstiegspunkt“ für die Anwendung bezeichnet. Wenn die Ausführung von WINMAIN abgeschlossen ist, gilt die Anwendung als abgeschlossen und Windows gibt den Anwendungsspeicher wieder auf den Heap frei. WINMAIN erhält folgende Parameter:

hInstanz

Das Instanzhandle der ausführbaren Datei (EXE). Jede Instanz einer Windows-Anwendung verfügt über ein eindeutiges Handle. Es wird als Parameter für eine Reihe von Windows-API-Funktionen verwendet, die möglicherweise zwischen mehreren Instanzen einer Anwendung unterscheiden müssen.

hPrevInst

Wird von 32-Bit-Windows nicht verwendet. Es ist lediglich aus Kompatibilitätsgründen mit vorhandenem 16-Bit-Code vorhanden und gibt in 32-Bit-Anwendungen immer Null zurück.

lpszCmdLine

Ein Zeiger auf eine mit NULL endende Zeichenfolge, die eine Befehlszeile enthält. Beachten Sie, dass die in lpszCmdLine übergebene Zeichenfolge nicht mit der vom GetCommandLine-API-Aufruf zurückgegebenen Zeichenfolge übereinstimmt. Die Zeichenfolge in lpszCmdLine enthält nur die Befehlszeilenargumente (wie COMMAND$ ), aber GetCommandLine gibt den Programmnamen (einschließlich Pfad) gefolgt von den Argumenten zurück.

nCmdShow

Gibt an, wie das Hauptfenster der Anwendung angezeigt wird. Beispielsweise kann die aufrufende Anwendung %SW_NORMAL oder %SW_MINIMIZE usw. angeben. Die Berücksichtigung dieses Parameters obliegt dem Programmierer und wird empfohlen, dies zu tun.

Einschränkungen

Zeiger dürfen nicht BYREF übergeben werden, daher muss der Parameter lpszCmdLine von WINMAIN für die Übergabe von BYVAL deklariert werden.

Siehe auch

  • PBMAIN

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Beschreibung

Referenz-Uebersichten sollen Umfang, Navigation, Build-Status und Beispielorte erklaeren. Eine vollständige Hilfeseite nennt außerdem Voraussetzungen, Grenzen, Fehlerfälle und die Beziehung zu verwandten Befehlen.

Syntax

Für WINMAIN soll das Beispiel so aufgebaut sein, dass es direkt in eine kleine Quelldatei übernommen werden kann. Nennen Sie Eingaben, erwartete Ausgabe oder Exit-Code sowie notwendige Includes, Bibliotheken oder Laufzeitbedingungen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' WINMAIN mit bekannten Eingaben ausfuehren.
    ' Rueckgabewert, Ausgabe oder geaenderten Zustand pruefen.
    FUNCTION = 0
END FUNCTION

Validierungsbeleg

Validieren Sie die Beschreibung gegen den aktuellen PBXB64-Compiler, nicht nur gegen historische PowerBASIC-Dokumentation. Wenn ein Feature noch eingeschränkt ist, muss die Seite das offen sagen und darf keine nicht getestete Vollständigkeit behaupten.

Siehe auch

  • Befehlsindex
  • BASIC-Sprachübersicht

Hinweise

Dokumentieren Sie auf der Seite immer die konkrete Grenze: was die Funktion oder Anweisung kann, was sie nicht kann, und welches Test- oder Beispielprogramm den aktuellen Stand belegt.


Word (??) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Wort (??)
Hilfe zum PBXB64-Compiler

Wort (??)

Wörter sind vorzeichenlose 16-Bit-Ganzzahlen (zwei Bytes) mit einem Bereich von 0 bis 65535 (0 bis 2^16-1). Das Typspezifizierzeichen für ein Wort ist: ??.

Typ:Schlüsselwort |Kategorie:Datentypen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Wortvariablen werden identifiziert, indem dem Variablennamen zwei Fragezeichen folgen (z. B. var??) oder indem die DEFWRD-Anweisung verwendet wird, wie in der vorherigen Diskussion von Ganzzahlen beschrieben. Sie können Wortvariablen auch mit dem Schlüsselwort WORD mit der DIM-Anweisung deklarieren. Zum Beispiel:

Wortwerte erweitern effektiv den positiven Bereich für Ganzzahlen, erfordern jedoch immer noch nur zwei Bytes zur Speicherung.

Ein C/C++ UINT16- und ein Delphi-Wort entsprechen einem PowerBASIC-Wort.

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_type_long
FUNCTION PBMAIN() AS LONG
  LOCAL a AS LONG
  a = 10
  IF (a) <> (10) THEN FUNCTION = 1: EXIT FUNCTION
  a = a + 5
  IF (a) <> (15) THEN FUNCTION = 2: EXIT FUNCTION
  a = a * 2
  IF (a) <> (30) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_type_integer
FUNCTION PBMAIN() AS LONG
  LOCAL a AS INTEGER
  a = 10
  IF (a) <> (10) THEN FUNCTION = 1: EXIT FUNCTION
  a = a + 5
  IF (a) <> (15) THEN FUNCTION = 2: EXIT FUNCTION
  a = a * 2
  IF (a) <> (30) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_type_byte
FUNCTION PBMAIN() AS LONG
  LOCAL a AS BYTE
  a = 10
  IF (a) <> (10) THEN FUNCTION = 1: EXIT FUNCTION
  a = a + 5
  IF (a) <> (15) THEN FUNCTION = 2: EXIT FUNCTION
  a = a * 2
  IF (a) <> (30) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_type_word
FUNCTION PBMAIN() AS LONG
  LOCAL a AS WORD
  a = 10
  IF (a) <> (10) THEN FUNCTION = 1: EXIT FUNCTION
  a = a + 5
  IF (a) <> (15) THEN FUNCTION = 2: EXIT FUNCTION
  a = a * 2
  IF (a) <> (30) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_type_dword
FUNCTION PBMAIN() AS LONG
  LOCAL a AS DWORD
  a = 10
  IF (a) <> (10) THEN FUNCTION = 1: EXIT FUNCTION
  a = a + 5
  IF (a) <> (15) THEN FUNCTION = 2: EXIT FUNCTION
  a = a * 2
  IF (a) <> (30) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Beispiel

#COMPILE EXE
#DIM ALL
' numeric_type_quad
FUNCTION PBMAIN() AS LONG
  LOCAL a AS QUAD
  a = 10
  IF (a) <> (10) THEN FUNCTION = 1: EXIT FUNCTION
  a = a + 5
  IF (a) <> (15) THEN FUNCTION = 2: EXIT FUNCTION
  a = a * 2
  IF (a) <> (30) THEN FUNCTION = 3: EXIT FUNCTION
  FUNCTION = 0
END FUNCTION

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


WRAP$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › WRAP$

WRAP$

Fügen Sie gepaarte Zeichen am Anfang und Ende einer Zeichenfolge hinzu

Typ:Funktion |Kategorie:String-Funktionen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

s$ = WRAP$( StringExpression , LeftChar$ , RightChar$ )

Beschreibung

Die WRAP$-Funktion stellt LeftChar$ dem StringExpression voran, hängt dann RightChar$ an und gibt das Gesamtergebnis zurück. Zum Beispiel:

WRAP$("MyWord", "<", ">") gibt "<MyWord>" zurück

Es eignet sich besonders zum Einschließen von Text in Klammern, Anführungszeichen, Klammern usw.

Siehe auch

  • BUILD$
  • STRINGBUILDER
  • STRINSERT$
  • UNWRAP$

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


WRITE# ? PBXB64-Compiler-Hilfe

Startseite ? BASIC-Frontend ? Schl?sselwortreferenz ? Datei-E/A ? WRITE#
Hilfe zum PBXB64-Compiler

WRITE#

Durch Kommas getrennte Daten in eine sequenzielle Datei schreiben

Typ: Anweisung | Kategorie: Datei-E/A

PBXB64-Status: VERF?GBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET] f?r fokussierte Datei-Datens?tze: kommagetrennte Felder, zitierte Strings, Verdopplung eingebetteter Anf?hrungszeichen, leere Datens?tze, Ganzzahl-/Flie?kommaausgabe und Stringliterale mit Kommas.

Syntax

WRITE #Dateinummer& [, Ausdruck [, Ausdruck ...]]

Beschreibung

Die WRITE#-Anweisung schreibt Daten in eine sequenzielle Datei, die mit OPEN FOR OUTPUT oder OPEN FOR APPEND ge?ffnet wurde. Werte werden automatisch durch Kommas getrennt, Zeichenfolgen in doppelte Anf?hrungszeichen eingeschlossen (eingebettete Anf?hrungszeichen werden verdoppelt) und jede Anweisung endet mit einem CR/LF-Paar. Dieses Format ist f?r das Zur?cklesen mit INPUT# gedacht.

Unterst?tzte Ausdruckstypen sind Ganzzahl-, Flie?komma- und Zeichenfolgenausdr?cke.

Getesteter Umfang: examples/basic/test_write_file.pb und tests/pb/test_write_file_exact.pb.

Beispiel

FUNCTION PBMAIN () AS LONG
    OPEN "data.txt" FOR OUTPUT AS #1
    WRITE #1, "Alice", 30
    CLOSE #1
    FUNCTION = 0
END FUNCTION

Das Beispiel erzeugt eine Datei mit folgendem Inhalt:

"Alice",30

Einschr?nkungen

  • Abschlie?ende ; oder , werden nicht unterst?tzt; WRITE# f?gt immer CR/LF an.
  • Die Array-Form WRITE #Dateinummer, array() ist nicht unterst?tzt.
  • Dateinummern m?ssen als Literale #1..#16 angegeben werden; variable Dateinummern sind noch nicht unterst?tzt.

Kompatibilitaetsdetails

WRITE# ist die sicherere Anweisung fuer strukturierte sequenzielle Datensaetze. Sie fuegt Komma-Trennzeichen zwischen Feldern ein, setzt Stringfelder in Anfuehrungszeichen, verdoppelt eingebettete Anfuehrungszeichen und fuegt ein datensatzabschliessendes CR/LF an.

Der entstehende Datensatz ist fuer INPUT# gedacht: Zahlenfelder bleiben als Zahlen parsebar, Stringfelder duerfen Kommas enthalten, und leere Datensaetze koennen durch WRITE #filenum& ohne Ausdrucksliste geschrieben werden.

PRINT# oder WRITE# waehlen

  • Verwende PRINT#, wenn Layoutkontrolle, Druckzonen oder menschenlesbarer Berichtstext wichtig sind.
  • Verwende WRITE#, wenn spaeteres maschinelles Parsen wichtiger als das visuelle Layout ist.
  • WRITE# beendet den Datensatz immer; abschliessende ; und , gehoeren bewusst nicht zur aktuell getesteten Oberflaeche.

Siehe auch

  • OFFEN
  • CLOSE
  • PRINT#
  • INPUT#
  • Datei-E/A-Referenz

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Einen Fehlerhandler schreiben – PBXB64-Compiler-Hilfe

Startseite › Funktionen › Einen Fehlerbehandler schreiben

Einen Fehlerbehandler schreiben

Wenn ein Fehler auftritt und eine Fehlerfalle Ihre Fehlerbehandlungsroutine aufruft, sollte der Code zunächst feststellen, welcher Fehler aufgetreten ist. Die ERR- und ERRCLEAR-Funktionen von PowerBASIC geben die zurück

Typ:Schlüsselwort |Kategorie: Control Flow

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Setzen einer Fehlerfalle

Siehe auch

  • Befehlsindex
  • BASIC-Frontend

Fehlerpfad-Prüfung

Fehlerbehandlungsseiten sollen den normalen Pfad und den Fehlerpfad zeigen. Ein vollständiges Beispiel löst absichtlich einen bekannten Fehler aus, prüft den dokumentierten Fehlerwert, stellt wieder her oder beendet sauber und zeigt, dass spätere Anweisungen in der erwarteten Reihenfolge laufen.

Zustandsregeln

Dokumentieren Sie, welche Variablen, Handler oder Systemwerte durch die Operation geändert werden. Vermeiden Sie Beispiele, die einen Fehler durch ungeprüftes Weiterlaufen verdecken.

Migrationshinweise

Beim Portieren älteren PB-Codes sind Annahmen zu Zeilennummern, Handler-Gültigkeit, verschachtelten Prozeduren und Windows-API-Fehlern neu zu prüfen.


WSTRING - Wide-String deklarieren — PBXB64 Help

Startseite › General Reference › WSTRING - Wide-String deklarieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

WSTRING - Wide-String deklarieren

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

LOCAL w AS WSTRING

Detailverhalten

Dynamischer UTF-16-Wide-String mit getesteter Zuweisung, Verkettung, Vergleich, LIKE, UDT-Feldspeicherung, BYVAL-Parameter/Funktionsrueckgabe, LEN, WCHR$/ASCW, LEFT$/MID$/RIGHT$ und Abschneiden bei fester WSTRING-Laenge. Dies ist keine eigenstaendige COM-Automation-BSTR-ABI.

Praktische Verwendung

Verwenden Sie diese Schreibweise fuer wide-character String- oder Pufferdeklarationen, wenn UTF-16-kompatible Verarbeitung benoetigt wird. Pruefen Sie Zuweisung, Vergleich und eventuelle Abschneidung mit einem eigenen Test.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Verwechseln Sie diese Typkeywords nicht mit freien Bezeichnern oder Laufzeitwerten. Wenn der Zielkontext die Type-Position nicht erwartet, muss die Quelle entsprechend angepasst werden.

Verifiziertes Beispiel

Abgedeckt durch examples/basic/test_wstring_basic.pb and tests/pb/test_wstring_unicode.pb (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


WSTRINGZ - NUL-terminierten Wide-String deklarieren — PBXB64 Help

Startseite › General Reference › WSTRINGZ - NUL-terminierten Wide-String deklarieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

WSTRINGZ - NUL-terminierten Wide-String deklarieren

Kind: PB-Keyword | Category: BASIC Frontend

PBXB64 Status: AVAILABLE

PBXB64 Certification: [CERTIFIED TESTED]

Syntax

LOCAL wz AS WSTRINGZ * 16

Detailverhalten

Fester Wide-Character-Puffer mit Nullterminator-Semantik, getestetem Abschneiden, BYREF-UDT-Feldaktualisierung, BYVAL-Parameteruebergabe, Funktionsrueckgabe-Kopie, Vergleich und LIKE. Festpuffer-Aufruf- und Rueckgabepfade behalten die deklarierte Pufferlaenge bei.

Praktische Verwendung

Verwenden Sie diese Schreibweise fuer wide-character String- oder Pufferdeklarationen, wenn UTF-16-kompatible Verarbeitung benoetigt wird. Pruefen Sie Zuweisung, Vergleich und eventuelle Abschneidung mit einem eigenen Test.

Verwenden Sie diese Seite als direkten Einstieg fuer die gezeigte Schreibweise, nicht als Ersatz fuer die breitere BASIC-Uebersicht. In einem Testprogramm sollten alle Eingaben vor dem gezeigten Befehl vorbereitet werden; danach muss ein Rueckgabewert, eine Ausgabe, ein geaenderter Zustand oder ein erwarteter Diagnosepfad geprueft werden. Bei Direktiven und eingebetteten Sprachbloecken gehoeren Anfangs- und Endmarker immer zusammen, damit der Scanner den Block eindeutig abgrenzen kann.

Fehlerfaelle

Verwechseln Sie diese Typkeywords nicht mit freien Bezeichnern oder Laufzeitwerten. Wenn der Zielkontext die Type-Position nicht erwartet, muss die Quelle entsprechend angepasst werden.

Verifiziertes Beispiel

Abgedeckt durch examples/basic/test_wstringz.pb and tests/pb/test_wstringz_call_udt.pb (Beispiel oder Validierungsspur).

Der angegebene Nachweis nennt eine ausfuehrbare Beispielquelle oder eine Validierungsspur, die die erkannte Oberflaeche belegt. Wenn das Verhalten erweitert wird, soll zuerst ein fokussierter PB-Test mit klarem Exit-Code oder klarer Ausgabe ergaenzt werden; danach wird diese Seite aktualisiert und die passende Validierungsmatrix erneut ausgefuehrt.

Grenzen

Diese Seite beschreibt die PBXB64-implementierte oder erkannte Keyword-Oberflaeche. Wenn eine breitere PowerBASIC-Form hier nicht gezeigt wird, benoetigt sie eigene Implementierung, Tests und Hilfe.

Siehe auch

  • BASIC Language Overview
  • BASIC Declarations
  • BASIC Control Flow

← Back

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


XPRINT ARC – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT ARC

XPRINT ARC

Zeichnen Sie einen Bogen auf a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT ARC ( x1! , y1! ) - ( x2! , y2! ), arcStart! , arcEnd! [, r gbColor& ]

Beschreibung

Ein Bogen ist ein Abschnitt eines Kreises oder einer Ellipse. Um einen bestimmten Bogen anzugeben, definieren Sie zunächst den vollständigen Kreis oder die Ellipse, zu der er gehört, und geben dann die Punkte auf der Ellipse an, an denen der Bogen beginnt und endet.

Der Vollkreis oder die Ellipse wird durch sein Begrenzungsrechteck definiert, das das kleinste Rechteck ist, das um den Kreis oder die Ellipse gezeichnet werden kann. Wenn der Kreis beispielsweise an der Position (400.400) zentriert ist und einen Radius von 100 Pixeln hat, ist die obere linke Ecke (x1,y1) des Begrenzungsrechtecks ​​(300.300) und die untere rechte Ecke (x2,y2) ist (500.500).

Der Startpunkt und der Endpunkt des Bogens werden durch ihren Winkel angegeben, der im Bogenmaß angegeben werden muss. Ein vollständiger Kreis oder eine vollständige Ellipse hat ein Bogenmaß von 2*pi. Auf einem 12-Stunden-Zifferblatt beziehen sich die Werte 0 und 2*pi beide auf die Position 3 Uhr, während sich der Wert 1*pi auf die Position 9 Uhr bezieht. Andere Positionen werden durch einen Bogenmaßwert relativ zu diesen angegeben. In PowerBASIC werden Bögen immer gegen den Uhrzeigersinn vom Startpunkt zum Endpunkt gezeichnet.

Vor allen XPRINT-Vorgängen muss zunächst mit XPRINT ATTACH ein Host-Drucker ausgewählt werden. Die Koordinatenpunkte werden in Pixel (oder Weltkoordinaten, falls diese mit XPRINT SCALE ausgewählt wurden) angegeben. Die Linienbreite kann mit XPRINT WIDTH eingestellt werden. Wenn die Linienbreite auf 1 eingestellt ist (Standardeinstellung), kann der Linienstil mit XPRINT STYLE festgelegt werden. Aufgrund der Art eines Bogens verwendet XPRINT ARC weder (letzter referenzierter Punkt) noch aktualisiert es ihn. Bei Ausführung ohne angeschlossenen Hostdrucker wird Fehler 57 generiert.

x1! , y1!

Die obere linke Ecke des umschließenden Rechtecks des Vollkreises oder der Ellipse.

x2! , y2!

Die untere rechte Ecke des Begrenzungsrechtecks des Vollkreises oder der Ellipse.

ArcStart!

Der Anfangswinkel des Bogens im Bogenmaß von 0 bis 2*pi.

ArcEnd!

Der Endwinkel des Bogens im Bogenmaß von 0 bis 2*pi im Bogenmaß. Beachten Sie, dass Bögen von arcStart aus immer gegen den Uhrzeigersinn gezeichnet werden! zu arcEnd! . Im Vergleich zu einem 12-Stunden-Zifferblatt liegt 0 oder 2*pi im Bogenmaß bei 3 Uhr und 1*pi im Bogenmaß bei 9 Uhr.

rgbColor&

Optionale RGB-Farbe für den Bogen. Wenn es weggelassen wird (oder -1), wird die aktuelle Vordergrundfarbe für die Hostdruckerseite verwendet.

Siehe auch

  • Built In RGB Color Equates
  • XPRINT ANHANG
  • XPRINT-FARBE
  • XPRINT ELLIPSE
  • XPRINT PIE
  • XPRINT-STIL
  • XPRINT-BREITE

PBXB64-Umsetzungshinweise

XPRINT ARC gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT ARC ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT ARC mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT ATTACH – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT ATTACH

XPRINT ANHANG

Haengen Sie einen dateibasierten XPRINT-Stream an.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT ATTACH {DEFAULT | PrinterName$ } [, JobName$ ]
XPRINT ATTACH CHOOSE [USING Flags& ] [, JobName$ ]

Beschreibung

XPRINT ATTACH öffnet den aktuellen XPRINT-Stream gegen einen Dateipfad und schließt eine vorherige XPRINT-Verbindung zuerst. Der fokussierte V14-Schnitt ist dateibasiert, nicht treiberbasiert: nachfolgende XPRINT-Ausgabe wird in die benannte Datei geschrieben, und XPRINT$ gibt den aktiven Anhangspfad zurück, solange der Stream offen ist.

Wenn der Pfadausdruck weggelassen wird, verwendet der Stream XPRN1 als Standardnamen. Wenn der Anhangsvorgang fehlschlägt, gibt XPRINT$ eine leere Zeichenfolge zurück.

Die breiteren Druckerdialog-Formen aus dem Syntaxblock, wie DEFAULT und CHOOSE, bleiben katalogisierte Kompatibilitätsformen und sind nicht Teil dieses fokussierten dateibasierten Schnitts.

Siehe auch

  • LPRINT ATTACH
  • DRUCKER$
  • XPRINT ABBRECHEN
  • XPRINT CLOSE
  • XPRINT GET ATTACH
  • XPRINT SEITEN ERHALTEN
  • XPRINT GET SELECTION

PBXB64-Umsetzungshinweise

XPRINT ANHANG gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT ANHANG ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT ANHANG mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT BOX - PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT BOX

XPRINT-BOX

Zeichnen Sie einen Kasten mit quadratischen oder abgerundeten Ecken auf ein

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT BOX ( x1! , y1! ) - ( x2! , y2! ) [, [ corner& ] [, [ rgbColor& ] [, [ fillcolor& ] [, [ fillstyle& ]]]]]

Beschreibung

Vor allen XPRINT-Vorgängen muss zunächst mit XPRINT ATTACH ein Host-Drucker ausgewählt werden. Die Koordinatenpunkte werden in Pixel (oder Weltkoordinaten, falls diese mit XPRINT SCALE ausgewählt wurden) angegeben. Die Linienbreite kann mit XPRINT WIDTH eingestellt werden. Wenn die Linienbreite auf 1 eingestellt ist (Standardeinstellung), kann der Linienstil mit XPRINT STYLE festgelegt werden. Aufgrund der Natur einer Box verwendet XPRINT BOX weder (letzter Punkt, auf den verwiesen wird) noch aktualisiert es ihn. Bei Ausführung ohne angeschlossenen Hostdrucker wird Fehler 57 generiert.

Windows-Grafikkonventionen betrachten die unteren und rechten Koordinaten einer BOX als exklusiv. Die Pixel am unteren und rechten Rand werden nicht gezeichnet, es sei denn, der ÜBERLAPPUNGSMODUS ist aktiviert. Weitere Informationen finden Sie unter XPRINT SET OVERLAP.

x1! , y1!

Die obere linke Ecke der Box.

x2! , y2!

Die untere rechte Ecke der Box.

Ecke&

Der Prozentsatz der Rundheit der Ecken im Bereich von 0 bis 100. Ein Wert von Null erzeugt quadratische Ecken, während 100 einen Kreis/ein Oval erzeugt. Für ein angenehmes, rundes Erscheinungsbild ist ein Wert von 20 am gebräuchlichsten. Wenn Corner& weggelassen wird, ist der Standardwert 0, wodurch ein Rechteck mit quadratischen Ecken erstellt wird.

rgbColor&

Optionale RGB-Farbe des Boxrandes. Wenn es weggelassen wird (oder -1), wird als Kantenfarbe standardmäßig die aktuelle Vordergrundfarbe für die Hostdruckerseite verwendet.

Füllfarbe&

Optionale RGB-Farbe des Boxinneren. Wenn fillcolor& weggelassen wird (oder -2), wird das Innere der Box nicht ausgefüllt, sodass der Hintergrund durchscheinen kann. Wenn fillcolor& -1 ist, wird der Innenraum mit der gleichen Farbe wie der Rand bemalt. Andernfalls gibt fillcolor& die zu verwendende RGB-Farbe an.

Füllstil&

Optionaler Füllstil (Muster), der verwendet werden soll. Wenn fillstyle& weggelassen wird, ist der Standardfüllstil „solid“ (0). Wenn ein Schraffurmuster ausgewählt wird (1 bis 6), wird die Vordergrundfarbe durch fillcolor& angegeben, während der Hintergrund durch die Standardhintergrundfarbe für die Hostdruckerseite angegeben wird. Der optionale Füllstil& kann sein:

Fest (Standard)

Horizontale Linien

Vertikale Linien

Nach oben gerichtete diagonale Linien

Abwärts gerichtete diagonale Linien

Gekreuzte Linien

Diagonal gekreuzte Linien

Siehe auch

  • Built In RGB Color Equates
  • XPRINT ANHANG
  • XPRINT-FARBE
  • XPRINT-LINIE
  • XPRINT-SET-ÜBERLAPPUNG
  • XPRINT-STIL
  • XPRINT-BREITE

PBXB64-Umsetzungshinweise

XPRINT-BOX gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT-BOX ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT-BOX mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT CANCEL – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT CANCEL

XPRINT ABBRECHEN

Brechen Sie einen Druckauftrag ab

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT CANCEL

Beschreibung

XPRINT CANCEL löscht den aktuellen Druckauftrag und trennt den Host-Drucker, solange XPRINT CLOSE noch nicht ausgeführt wurde. Diese Funktion wird im Allgemeinen verwendet, um den Druckvorgang abzubrechen, wenn ein Fehler auftritt.

Siehe auch

  • XPRINT ANHANG
  • XPRINT CLOSE

XPRINT-Prüfung

XPRINT-Seiten sollen Druckerauswahl, Lebensdauer des Device Context, Seitenzustand, Koordinateneinheiten und die Frage nennen, ob der Befehl Vorschau, Rendering oder Druckerausgabe betrifft. Beispiele sollen sicher sein, wenn kein Standarddrucker installiert ist.

Fehlerfälle

Dokumentieren Sie abgebrochene Druckdialoge, nicht verfügbare Drucker, ungültige DC-Handles und nicht unterstützte Gerätefähigkeiten.

Cleanup

Schließen oder brechen Sie Druckjobs ausdrücklich ab und geben Sie angehängte Ressourcen vor Programmende frei.

PBXB64-Umsetzungshinweise

XPRINT ABBRECHEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT ABBRECHEN ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT ABBRECHEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(COL) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(COL)
Hilfe zum PBXB64-Compiler

XPRINT(COL)

Legt die nächste Druckposition (LPR – Last Point Referenced) basierend auf der Zeilen- und Spaltenposition von a fest oder ruft diese ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT CELL = RowValue& , ColValue&
XPRINT CELL TO RowVar& , ColVar&
XPRINT COL TO ColVar&
XPRINT ROW TO RowVar&
Function Form:
ColVar& = XPRINT(COL)
RowVar& = XPRINT(ROW)

Beschreibung

XPRINT CELL wird verwendet, um die Druckposition basierend auf der Zeilen- und Spaltenposition einer Textzelle festzulegen oder abzurufen. Das ist die Zeilen- und Spaltenposition, an der der nächste gedruckte Text angezeigt wird. RowValue& gibt die horizontale Bildschirmzeile (beginnend bei 1) an, in der der Cursor positioniert werden soll. ColValue& gibt die vertikale Bildschirmspalte (beginnend bei 1) an, an der der Cursor positioniert werden soll. Da die Zeilen- und Spaltennummern bei eins (1) beginnen, wird die obere linke Ecke der Seite als Zelle 1,1 betrachtet.

Die erste Form von XPRINT CELL verschiebt die Druckposition in die gewünschte Zeile und Spalte. Wenn ein angegebener Wert Null (0) ist, wird dieser Parameter ignoriert und diese Position wird nicht geändert. Die zweite Form von XPRINT CELL ruft die aktuelle Druckposition ab und weist die Werte den durch RowVar& und ColVar& angegebenen Variablen zu.

Mit den übrigen Formularen können Sie nur einen einzelnen Wert (entweder Zeile oder Spalte) abrufen und werden sowohl in Anweisungs- als auch in Funktionsform unterstützt.

Siehe auch

  • XPRINT-ZELLENGRÖSSE
  • XPRINT SCHRIFTART EINSTELLEN
  • XPRINT SET WORDWRAP
  • XPRINT SET WRAP
  • XPRINT SPLIT

PBXB64-Umsetzungshinweise

XPRINT(COL) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(COL) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(COL) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(Cell.Size.X) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(Cell.Size.X)
Hilfe zum PBXB64-Compiler

XPRINT(Cell.Size.X)

Rufen Sie den Charakter ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT CELL SIZE TO WidthVar , HeightVar!
Function Form:
WidthVar! = XPRINT(Cell.Size.X)
HeightVar! = XPRINT(Cell.Size.Y)

Beschreibung

XPRINT CELL SIZE ruft die Größe einer Zeichenzelle für die aktuelle Schriftart auf dem angeschlossenen Drucker ab. Die zurückgegebene Zellengröße wird in PAGE UNITS angegeben und ermöglicht Ihnen die Berechnung der Anzahl der Textzeilen, die in einen bestimmten Raum passen. Der Höhenwert ist die Größe des angezeigten Zeichens, einschließlich des externen Zeilenabstands (falls vorhanden) für diese bestimmte Schriftart.

Wenn es sich bei der Schriftart um eine Schriftart mit fester Breite wie Courier New oder Lucida Console handelt, sind die zurückgegebenen Größen angesichts der für einige skalierte Einheiten erforderlichen gebrochenen Rundungsnäherungen so genau wie möglich. Wenn die Schriftart proportional ist, wie Arial oder Times New Roman, entspricht die Breite der durchschnittlichen Größe der gesamten Schriftart.

Der externe Zeilenabstand ist der vertikale Abstand vom unteren Rand eines Zeichens zum oberen Rand des darunter liegenden Zeichens. Dieser Wert wird durch die verwendete Schriftart angegeben. Der Wert kann je nach Schriftart und Punktgröße zwischen Null und einem größeren Wert variieren. Um die genaue Höhe von Zeichen ohne externen Zeilenabstand abzurufen, verwenden Sie XPRINT CHR SIZE .

Siehe auch

  • XPRINT-ZELLE
  • XPRINT CHR-GRÖSSE
  • XPRINT SCHRIFTART EINSTELLEN
  • XPRINT-TEXTGRÖSSE

PBXB64-Umsetzungshinweise

XPRINT(Cell.Size.X) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(Cell.Size.X) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(Cell.Size.X) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(Chr.Size.X) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(Chr.Size.X)
Hilfe zum PBXB64-Compiler

XPRINT(Chr.Size.X)

Rufen Sie die Zeichengröße für ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT CHR SIZE TO WidthVar! , HeightVar!
Function Form:
WidthVar! = XPRINT(Chr.Size.X)
HeightVar! = XPRINT(Chr.Size.Y)

Beschreibung

Die Zeichengröße wird in denselben Begriffen (Pixel oder skalierte Einheiten) wie ursprünglich angegeben angegeben. Der abgerufene Höhenwert ist die tatsächliche Größe des gedruckten Zeichens ohne Berücksichtigung externer Zeilenumbrüche für diese bestimmte Schriftart.

Wenn es sich bei der Schriftart um eine Schriftart mit fester Breite handelt, z. B. Courier New oder Lucida Console, sind die zurückgegebenen Größen so genau wie möglich, da bei der Konvertierung von Pixeln in andere Koordinaten mögliche Annäherungen an gebrochene Rundungen möglich sind. Wenn die Schriftart proportional ist, wie Arial oder Times New Roman, entspricht die Breite der durchschnittlichen Größe der gesamten Schriftart.

Der externe Zeilenabstand ist der vertikale Abstand vom unteren Rand eines Zeichens zum oberen Rand des darunter liegenden Zeichens. Dieser Wert wird durch die verwendete Schriftart angegeben. Der Wert kann je nach Schriftart und Punktgröße zwischen Null und einem größeren Wert variieren. Um die gesamte Zeilenhöhe einschließlich Außenabstand abzurufen, verwenden Sie XPRINT CELL SIZE.

Siehe auch

  • XPRINT
  • XPRINT ANHANG
  • XPRINT-ZELLENGRÖSSE
  • XPRINT SCHRIFTART EINSTELLEN
  • XPRINT-TEXTGRÖSSE

PBXB64-Umsetzungshinweise

XPRINT(Chr.Size.X) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(Chr.Size.X) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(Chr.Size.X) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT CLOSE - PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT CLOSE

XPRINT CLOSE

Schließen Sie den aktiven dateibasierten XPRINT-Stream.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT CLOSE

Beschreibung

XPRINT CLOSE leert und schließt den aktuellen dateibasierten XPRINT-Anhang und setzt den aktiven XPRINT$-Zustand zurück. Verwenden Sie den Befehl nach dem letzten XPRINT-Ausdruck, damit gepufferte Daten sicher in die Datei geschrieben werden.

Siehe auch

  • XPRINT ANHANG
  • XPRINT ABBRECHEN

XPRINT-Prüfung

XPRINT-Seiten sollen Druckerauswahl, Lebensdauer des Device Context, Seitenzustand, Koordinateneinheiten und die Frage nennen, ob der Befehl Vorschau, Rendering oder Druckerausgabe betrifft. Beispiele sollen sicher sein, wenn kein Standarddrucker installiert ist.

Fehlerfälle

Dokumentieren Sie abgebrochene Druckdialoge, nicht verfügbare Drucker, ungültige DC-Handles und nicht unterstützte Gerätefähigkeiten.

Cleanup

Schließen oder brechen Sie Druckjobs ausdrücklich ab und geben Sie angehängte Ressourcen vor Programmende frei.

PBXB64-Umsetzungshinweise

XPRINT CLOSE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT CLOSE ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT CLOSE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT-Codegruppe – PBXB64-Compiler-Hilfe

Startseite› Funktionen › XPRINT-Codegruppe

XPRINT-Codegruppe

Der XPRINT

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT DirectorWord [ params ]
XPRINT DirectorWord [ params ] TO ReturnVariable(s)
Function Form:
ReturnVariable = XPRINT( DirectorWord [, params ] )
ReturnVariable$ = XPRINT$( DirectorWord [, params ] )

Beschreibung

Einige der Funktionen der XPRINT-Gruppe waren in früheren Versionen von PowerBASIC verfügbar, wurden jedoch jetzt erweitert. Einige XPRINT-Prozeduren (nämlich solche, die einen einzelnen Wert zurückgeben) können in zwei Formen verwendet werden: als Anweisung mit einer TO-Klausel oder als Funktion, die als Begriff in einem Ausdruck verwendet werden kann:

XPRINT GET LINES TO LineCountVar&

LineCountVar& = XPRINT(LINES)

Die beiden obigen Beispiele sind funktional identisch. Die Wahl hängt einfach von Ihren persönlichen Vorlieben ab. Wenn Sie die zweite Form verwenden (als Funktion, die einen Wert zurückgibt), kann es sich um einen Begriff in jedem beliebigen Ausdruck beliebiger Komplexität handeln. Wenn ein Funktionsformular verfügbar ist, wird es mit dem Präfix „Funktionsformular“ gekennzeichnet.

Einige XPRINT-Prozeduren geben zwei oder mehr Werte zurück. Da es nicht möglich ist, mehrere Begriffe gleichzeitig in einen gültigen Ausdruck einzufügen, steht die Funktionsoption für sie nicht zur Verfügung.

PIXEL und PUNKTE

Für die Zwecke dieser Diskussion über XPRINT werden die Begriffe PIXEL und PUNKTE als Synonyme betrachtet. Sie können austauschbar verwendet werden.

XPRINT-STREAM

Der XPRINT-Stream ist die Verbindung zwischen XPRINT-Code und einer Host-Druckerseite. Der XPrint Stream wird erstellt, wenn Sie einen bestimmten Drucker mit XPRINT ATTACH anschließen. Von diesem Moment an wirkt der gesamte XPrint-Code auf dem ausgewählten Drucker. Dies geschieht so lange, bis Sie Ihren Druckauftrag mit XPRINT CLOSE beenden.

SEITENEINHEITEN

PAGE UNITS werden verwendet, um die Größe eines grafischen Elements zu messen oder um eine bestimmte Position auf einer XPrint-Seite zu definieren. Sie können Seiteneinheiten als Punkte oder skalierte Einheiten Ihrer Wahl definieren.

Zu Beginn jeder XPrint-Sitzung sind die Seiteneinheiten auf Punkte gesetzt. Sie können dies mit XPRINT SCALE in skalierte Weltkoordinaten Ihrer Wahl ändern.

Standardmäßig gilt die obere linke Ecke einer Druckerseite als X-Y-Position 0,0 und wird nach rechts oder unten größer. Die X-Achse ist horizontal, während die Y-Achse vertikal ist. Immer wenn eine X-, Y-Position angegeben wird, wird zuerst der X-Wert angegeben.

XPRINT-POSITION (POS)

Jedes Mal, wenn Sie Text oder Grafiken zeichnen, werden diese an der aktuellen XPrint-Position (POS) angezeigt. Nach Abschluss wird der POS auf den letzten referenzierten Punkt aktualisiert. Sie können einen relativen Abstand vom POS zeichnen (mithilfe einer STEP-Option) oder mit XPRINT SET POS eine völlig neue Position festlegen.

TEXTZELLE (ZEILEN-/Spaltenposition)

Um die Programmierung zu vereinfachen, geben einige Prozeduren die Textposition nach Zeile und Spalte an. In diesem Fall wird die Position in Textzellen gemessen, also dem von einem Zeichen eingenommenen Platz. Dies funktioniert gut mit Schriftarten mit fester Breite, was empfohlen wird. Wenn eine Schriftart mit variabler Breite gewählt wird, muss PowerBASIC für diese Berechnungen die durchschnittliche Zeichengröße verwenden, was zu ungenauen Ergebnissen führen kann.

Aus Gründen der Kompatibilität mit den meisten aktuellen und früheren Versionen von BASIC (einschließlich PowerBASIC) benennt Code, der auf Textzeilen und -spalten verweist, zuerst den vertikalen Begriff (Zeilen, Spalten). Zeilen und Spalten werden immer von eins aufwärts nummeriert.

Siehe auch

  • Drucken
  • Druckbefehle

PBXB64-Umsetzungshinweise

XPRINT-Codegruppe gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT-Codegruppe ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT-Codegruppe mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT COLOR - PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT COLOR

XPRINT-FARBE

Stellen Sie den Vordergrund ein

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT COLOR foreground& [, background& ]

Beschreibung

Farben werden als RGB-Werte ausgedrückt, oder verwenden Sie -1 als Standardfarbe. Wenn der Hintergrundparameter -2 ist, wird der Hintergrund transparent gemacht. Wenn einer der Parameter -3 ist, wird die vorhandene Farbe nicht geändert. Ein Host-Drucker muss zunächst mit XPRINT ATTACH angeschlossen werden. Wenn kein Hostdrucker angeschlossen ist, wird Fehler 57 generiert.

Siehe auch

  • Built In RGB Color Equates
  • XPRINT
  • XPRINT ANHANG

XPRINT-Prüfung

XPRINT-Seiten sollen Druckerauswahl, Lebensdauer des Device Context, Seitenzustand, Koordinateneinheiten und die Frage nennen, ob der Befehl Vorschau, Rendering oder Druckerausgabe betrifft. Beispiele sollen sicher sein, wenn kein Standarddrucker installiert ist.

Fehlerfälle

Dokumentieren Sie abgebrochene Druckdialoge, nicht verfügbare Drucker, ungültige DC-Handles und nicht unterstützte Gerätefähigkeiten.

Cleanup

Schließen oder brechen Sie Druckjobs ausdrücklich ab und geben Sie angehängte Ressourcen vor Programmende frei.

PBXB64-Umsetzungshinweise

XPRINT-FARBE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT-FARBE ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT-FARBE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT COPY – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT COPY

XPRINT-KOPIE

Kopieren Sie ein Bitma

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT COPY hbmpSource??? , id& [, style& ]
XPRINT COPY hbmpSource??? , id& TO ( x! , y! ) [, style& ]
XPRINT COPY hbmpSource??? , id& , ( x1! , y1! )-( x2! , y2! ) TO ( x! , y! ) [, style% ]

Beschreibung

Sie können eine vollständige Bitmap oder einen Teil davon auf die Seite des Hostdruckers kopieren. Der Ausdruck hbmpSource??? Gibt das Handle der Quellbitmap oder des Quellfensters an. Der Ausdruck id& ist der eindeutige Bezeichner des Steuerelements im Bereich von 1 bis 65535, wie mit der CONTROL ADD GRAPHIC-Anweisung zugewiesen. id& muss für ein GRAFIKWINDOW oder eine Bitmap 0 sein. Das Ziel des Kopiervorgangs ist die Host-Druckerseite. Sie müssen darauf achten, dass Ihre Parameter für die angegebenen Bitmaps gültig sind, sonst sind die Ergebnisse der Operation undefiniert.

Die erste Form der XPRINT COPY-Anweisung kopiert die vollständige Bitmap und positioniert sie an (0,0), der oberen linken Ecke des Ziels.

Die zweite Form von XPRINT COPY kopiert ebenfalls die komplette Bitmap, positioniert sie jedoch an der durch den Parameter ( x! , y! ) angegebenen Stelle.

Die dritte Form kopiert einen Teil der Bitmap und positioniert sie an dem durch den Parameter ( x! , y! ) angegebenen Punkt. Wenn style& enthalten ist, ist es einer der folgenden Werte:

%mix_Blackness

Pixel ist immer 0 (schwarz).

%mix_NotMergeSrc

Pixel ist die Umkehrung der MergeSrc-Farbe.

%mix_MaskNotSrc

Pixel ist eine Kombination der Farben, die sowohl dem Pixel als auch der Umkehrung der Quelle gemeinsam sind.

%mix_NotCopySrc

Pixel ist die Umkehrung der Stiftfarbe.

%mix_MaskSrcNot

Pixel ist eine Kombination der Farben, die sowohl der Quelle als auch der Umkehrung des Pixels gemeinsam sind.

%mix_Not

Pixel ist die Umkehrung der Pixelfarbe.

%mix_XorSrc

Pixel ist eine Kombination der Farben in der Quelle und im Pixel, jedoch nicht in beiden.

%mix_NotMaskSrc

Pixel ist die Umkehrung der MaskSrc-Farbe.

%mix_MaskSrc

Pixel ist eine Kombination der Farben, die sowohl der Quelle als auch dem Pixel gemeinsam sind.

%mix_NotXorSrc

Pixel ist die Umkehrung der XorSrc-Farbe.

%mix_Nop

Pixel bleibt unverändert.

%mix_MergeNotSrc

Pixel ist eine Kombination aus der Quellfarbe und der Umkehrung der Pixelfarbe.

%mix_CopySrc

Pixel ist die Quellfarbe (Standard).

%mix_MergeSrcNot

Pixel ist eine Kombination aus der Quellfarbe und der Umkehrung der Pixelfarbe.

%mix_MergeSrc

Pixel ist eine Kombination aus der Quellfarbe und der Pixelfarbe.

%mix_Whiteness

Pixel ist immer 1 (weiß).

Ein Host-Drucker muss zunächst mit XPRINT ATTACH angeschlossen werden. Wenn kein Hostdrucker angeschlossen ist, wird Fehler 57 generiert.

Siehe auch

  • XPRINT ANHANG
  • XPRINT RENDER
  • XPRINT STRETCH
  • XPRINT STRETCHMODUS EINSTELLEN

PBXB64-Umsetzungshinweise

XPRINT-KOPIE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT-KOPIE ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT-KOPIE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT ELLIPSE - PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT ELLIPSE

XPRINT ELLIPSE

Zeichnen Sie eine Ellipse oder einen Kreis auf a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT ELLIPSE ( x1! , y1! ) - ( x2! , y2! ) [, [ rgbColor& ] [, [ fillcolor &] [, [ fillstyle& ]]]]

Beschreibung

Ein Host-Drucker muss zunächst mit XPRINT ATTACH angeschlossen werden. Die Koordinatenpunkte werden in Pixeln (oder Weltkoordinaten, wenn diese mit einer XPRINT SCALE-Anweisung definiert wurden) angegeben. Die Linienbreite kann mit XPRINT WIDTH eingestellt werden. Wenn die Linienbreite auf 1 eingestellt ist (Standardeinstellung), kann der Linienstil mit XPRINT STYLE festgelegt werden. Aufgrund der Natur einer Ellipse, die keinen offensichtlichen Anfang oder Ende hat, verwendet XPRINT ELLIPSE weder den letzten referenzierten Punkt (POS) noch aktualisiert er ihn. Bei Ausführung ohne angeschlossenen Hostdrucker wird Fehler 57 generiert.

Das Koordinatenpaar definiert ein unsichtbares Begrenzungsrechteck, das die zu zeichnende Ellipse umschließt. Es gibt sowohl die Größe als auch die Proportionen der Ellipse an. Die Windows-Grafikkonventionen betrachten die unteren und rechten Koordinaten als exklusiv. Die Pixel am unteren und rechten Rand werden ignoriert, es sei denn, der Überlappungsmodus ist aktiviert. Weitere Informationen finden Sie unter XPRINT SET OVERLAP.

x1! , y1!

Die obere linke Ecke des umgrenzenden Rechtecks.

x2! , y2!

Die untere rechte Ecke des umgrenzenden Rechtecks.

rgbColor&

Optionale RGB-Farbe der Ellipsenkante. Wenn es weggelassen wird (oder -1), wird als Kantenfarbe standardmäßig die aktuelle Vordergrundfarbe für die Hostdruckerseite verwendet.

Füllfarbe&

Optionale RGB-Farbe des Ellipsen-Innenraums. Wenn fillcolor& weggelassen wird (oder -2), wird das Innere der Ellipse nicht ausgefüllt, sodass der Hintergrund durchscheinen kann. Wenn fillcolor& -1 ist, wird der Innenraum mit der gleichen Farbe wie der Rand bemalt. Andernfalls gibt fillcolor& die zu verwendende RGB-Farbe an.

Füllstil&

Optionaler Füllstil (Muster), der verwendet werden soll. Wenn fillstyle& weggelassen wird, ist der Standardfüllstil „solid“ (0). Wenn ein Schraffurmuster ausgewählt wird (1 bis 6), wird die Vordergrundfarbe durch fillcolor& angegeben, während der Hintergrund durch die Standardhintergrundfarbe für die Hostdruckerseite angegeben wird. Der optionale Füllstil& kann sein:

Fest (Standard)

Horizontale Linien

Vertikale Linien

Nach oben gerichtete diagonale Linien

Abwärts gerichtete diagonale Linien

Gekreuzte Linien

Diagonal gekreuzte Linien

Siehe auch

  • Built In RGB Color Equates
  • XPRINT ARC
  • XPRINT ANHANG
  • XPRINT-FARBE
  • XPRINT-LINIE
  • XPRINT PIE
  • XPRINT-SET-ÜBERLAPPUNG
  • RINT-STIL
  • XPRINT-BREITE

PBXB64-Umsetzungshinweise

XPRINT ELLIPSE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT ELLIPSE ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT ELLIPSE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT FORMFEED - PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT FORMFEED

XPRINT FORMFEED

Schreiben Sie ein Formularvorschub-Byte in den aktiven XPRINT-Stream.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT FORMFEED

Beschreibung

XPRINT FORMFEED schreibt ASCII 12 in den aktiven dateibasierten XPRINT-Stream. In diesem fokussierten Schnitt ist das eine Byte-für-Byte-Streamoperation und kein Drucker-Gerätebefehl zum Seitenauswurf.

Siehe auch

  • XPRINT ANHANG
  • XPRINT CLOSE

XPRINT-Prüfung

XPRINT-Seiten sollen Druckerauswahl, Lebensdauer des Device Context, Seitenzustand, Koordinateneinheiten und die Frage nennen, ob der Befehl Vorschau, Rendering oder Druckerausgabe betrifft. Beispiele sollen sicher sein, wenn kein Standarddrucker installiert ist.

Fehlerfälle

Dokumentieren Sie abgebrochene Druckdialoge, nicht verfügbare Drucker, ungültige DC-Handles und nicht unterstützte Gerätefähigkeiten.

Cleanup

Schließen oder brechen Sie Druckjobs ausdrücklich ab und geben Sie angehängte Ressourcen vor Programmende frei.

PBXB64-Umsetzungshinweise

XPRINT FORMFEED gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT FORMFEED ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT FORMFEED mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT$ – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT$

XPRINT$

Geben Sie den aktiven XPRINT-Anhangspfad zurück.

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET ATTACH TO PrinterVar$
Function Form:
PrinterVar$ = XPRINT$(ATTACH)
PrinterVar$ = XPRINT$

Beschreibung

XPRINT GET ATTACH gibt den Pfad des aktiven dateibasierten XPRINT-Anhangs zurück. Wenn kein XPRINT-Stream angehängt ist, wird eine leere Zeichenfolge zurückgegeben. XPRINT$ ist die fokussierte Zustandsabfrage für den literalen ATTACH/CLOSE-Schnitt.

Siehe auch

  • XPRINT ANHANG

XPRINT-Prüfung

XPRINT-Seiten sollen Druckerauswahl, Lebensdauer des Device Context, Seitenzustand, Koordinateneinheiten und die Frage nennen, ob der Befehl Vorschau, Rendering oder Druckerausgabe betrifft. Beispiele sollen sicher sein, wenn kein Standarddrucker installiert ist.

Fehlerfälle

Dokumentieren Sie abgebrochene Druckdialoge, nicht verfügbare Drucker, ungültige DC-Handles und nicht unterstützte Gerätefähigkeiten.

Cleanup

Schließen oder brechen Sie Druckjobs ausdrücklich ab und geben Sie angehängte Ressourcen vor Programmende frei.

PBXB64-Umsetzungshinweise

XPRINT$ gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT$ ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT$ mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(CANVAS.X) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(CANVAS.X)
Hilfe zum PBXB64-Compiler

XPRINT(CANVAS.X)

Ruft die beschreibbare Größe ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET CANVAS TO WidthVar! , HeightVar!
Function Form:
WidthVar! = XPRINT(CANVAS.X)
HeightVar! = XPRINT(CANVAS.Y)

Beschreibung

XPRINT GET CANVAS ermittelt die logische Größe des Client-Bereichs (druckbarer Bereich) für den angeschlossenen Host-Drucker. Dies ist die Größe der Seite abzüglich der nicht druckbaren Ränder, ohne jegliche Reduzierungen für einen CLIP-Bereich. Die Größe wird in Seiteneinheiten angegeben, sodass skalierte Werte zurückgegeben werden könnten, wenn sie mit XPRINT SCALE angewendet würden. Dies ist XPRINT GET CLIENT sehr ähnlich, mit der einzigen Ausnahme, dass skalierte Werte (festgelegt durch XPRINT SCALE) zurückgegeben werden, wenn sie verwendet wurden. Bei Ausführung ohne angeschlossenen Hostdrucker wird Fehler 57 generiert.

Siehe auch

  • XPRINT CLIENT ERHALTEN
  • XPRINT GET CLIP
  • XPRINT GRÖSSE ERHALTEN
  • XPRINT GET SCALE
  • XPRINT-SKALA

PBXB64-Umsetzungshinweise

XPRINT(CANVAS.X) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(CANVAS.X) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(CANVAS.X) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(Client.X) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(Client.X)
Hilfe zum PBXB64-Compiler

XPRINT(Client.X)

Ruft die Größe des Clientbereichs (druckbarer Bereich) auf der Hostdruckerseite ab.

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET CLIENT To WidthVar! , HeightVar!
Function Form:
WidthVar! = XPRINT(Client.X)
HeightVar! = XPRINT(Client.Y)

Beschreibung

XPRINT GET CLIENT ruft die physische Größe des Client-Bereichs (druckbarer Bereich) für den angeschlossenen Host-Drucker ab. Die Größe wird immer in Pixeln (Punkten) angegeben. Dies ist XPRINT GET CANVAS sehr ähnlich, mit der einzigen Ausnahme, dass skalierte Werte (festgelegt durch XPRINT SCALE ) nicht verwendet werden. Bei Ausführung ohne angeschlossenen Hostdrucker wird Fehler 57 generiert.

Siehe auch

  • XPRINT ANHANG
  • XPRINT ERHALTEN LEINWAND
  • XPRINT GET CLIP
  • XPRINT MARGIN ERHALTEN
  • XPRINT PPI ERHALTEN
  • XPRINT GRÖSSE ERHALTEN

PBXB64-Umsetzungshinweise

XPRINT(Client.X) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(Client.X) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(Client.X) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(Clip.X) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(Clip.X)
Hilfe zum PBXB64-Compiler

XPRINT(Clip.X)

Ruft die Größe des Clipbereichs auf dem ausgewählten Drucker ab.

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET CLIP TO WidthVar! , HeightVar!
Function Form:
WidthVar! = XPRINT(Clip.X)
HeightVar! = XPRINT(Clip.Y)

Beschreibung

Der Clip-Bereich des Druckers ist der Bereich, in den Druckvorgänge geschrieben werden können. Das heißt, der Clip-Bereich ist der Teil des Client-Bereichs, der nicht durch die XPRINT SET CLIP-Anweisung geschützt (abgeschnitten) wird.

XPRINT GET CLIP ruft die Größe des Clipbereichs ab und weist diese Werte den durch „WidthVar!“ angegebenen Variablen zu. und HeightVar! . Die Größe wird in PAGE UNITS (Pixel/Punkte oder skalierte Einheiten) angegeben. Wenn kein Drucker ausgewählt ist, werden die Werte 0,0 zurückgegeben.

Siehe auch

  • XPRINT ERHALTEN LEINWAND
  • XPRINT CLIENT ERHALTEN
  • XPRINT SET CLIP

PBXB64-Umsetzungshinweise

XPRINT(Clip.X) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(Clip.X) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(Clip.X) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(COLLATE) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(COLLATE)
Hilfe zum PBXB64-Compiler

XPRINT(SORTIEREN)

Ruft den XPRINT ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET COLLATE TO CollateVar&
Function Form:
CollateVar& = XPRINT(COLLATE)

Beschreibung

Mit XPRINT können Sie den Sortierstatus festlegen, wenn der Druckertreiber sowohl Mehrfachkopien als auch die Sortierfunktion unterstützt. XPRINT GET COLLATE ruft den Sortierstatus ab und weist den Wert der durch CollateVar& angegebenen Long-Integer-Variablen zu. Die folgenden Equates sind im Compiler vordefiniert, um den möglichen Sortierstatus symbolisch darzustellen:

%DMCOLLATE_FALSE = 0

%DMCOLLATE_TRUE = 1

Wenn diese Anweisung ohne angeschlossenen Hostdrucker ausgeführt wird, wird Fehler 57 generiert.

Siehe auch

  • XPRINT ANHANG
  • XPRINT SET SORTIEREN

PBXB64-Umsetzungshinweise

XPRINT(SORTIEREN) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(SORTIEREN) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(SORTIEREN) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(COLORMODE) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(COLORMODE)
Hilfe zum PBXB64-Compiler

XPRINT (FARBMODUS)

Ruft den XPRINT ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET COLORMODE TO ColorVar&
Function Form:
ColorVar& = XPRINT(COLORMODE)

Beschreibung

Mit XPRINT können Sie den Farb- oder Monochrom-Druckmodus einstellen, sofern der Druckertreiber dies unterstützt. XPRINT GET COLORMODE ruft den Farbmodusstatus ab und weist den Wert der durch ColorVar& angegebenen Long-Integer-Variablen zu. Der Wert Null kann zurückgegeben werden, wenn der Farbmodus vom Druckertreiber nicht unterstützt wird. Um den möglichen Status symbolisch darzustellen, sind im Compiler folgende Equates vordefiniert:

%DMCOLOR_MONOCHROME = 1

%DMCOLOR_COLOR = 2

Wenn diese Anweisung ohne angeschlossenen Hostdrucker ausgeführt wird, wird Fehler 57 generiert.

Siehe auch

  • XPRINT ANHANG
  • XPRINT SET COLORMODE

PBXB64-Umsetzungshinweise

XPRINT (FARBMODUS) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT (FARBMODUS) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT (FARBMODUS) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(KOPIEN) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(KOPIEN)
Hilfe zum PBXB64-Compiler

XPRINT(KOPIEN)

Ruft den XPRINT ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET COPIES TO CopyVar&
Function Form:
CopyVar& = XPRINT(COPIES)

Beschreibung

Mit XPRINT können Sie die Anzahl der automatisch zu druckenden Kopien festlegen, sofern dies vom Druckertreiber unterstützt wird. XPRINT GET COPIES ruft die Anzahl der Kopien ab und weist den Wert der durch CopyVar& angegebenen Long-Integer-Variablen zu. Der Standardwert ist eins (1). Wenn diese Anweisung ohne angeschlossenen Hostdrucker ausgeführt wird, wird Fehler 57 generiert.

Siehe auch

  • XPRINT ANHANG
  • XPRINT SET-KOPIEN

PBXB64-Umsetzungshinweise

XPRINT(KOPIEN) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(KOPIEN) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(KOPIEN) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(DC) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(DC)
Hilfe zum PBXB64-Compiler

XPRINT(DC)

Rufen Sie das Handle des Gerätekontexts (DC) für ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET DC TO hDC
Function Form:
hDC = XPRINT(DC)

Beschreibung

Wenn derzeit kein Hostdrucker angeschlossen ist, wird Null zurückgegeben. Das DC-Handle kann mit verschiedenen Windows-API-Funktionen verwendet werden, um spezielle Vorgänge auf der Hostdruckerseite auszuführen.

Siehe auch

  • XPRINT ANHANG

XPRINT-Prüfung

XPRINT-Seiten sollen Druckerauswahl, Lebensdauer des Device Context, Seitenzustand, Koordinateneinheiten und die Frage nennen, ob der Befehl Vorschau, Rendering oder Druckerausgabe betrifft. Beispiele sollen sicher sein, wenn kein Standarddrucker installiert ist.

Fehlerfälle

Dokumentieren Sie abgebrochene Druckdialoge, nicht verfügbare Drucker, ungültige DC-Handles und nicht unterstützte Gerätefähigkeiten.

Cleanup

Schließen oder brechen Sie Druckjobs ausdrücklich ab und geben Sie angehängte Ressourcen vor Programmende frei.

PBXB64-Umsetzungshinweise

XPRINT(DC) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(DC) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(DC) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(DUPLEX) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(DUPLEX)
Hilfe zum PBXB64-Compiler

XPRINT(DUPLEX)

Rufen Sie den XPRINT ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET DUPLEX TO DuplexVar&
Function Form:
DuplexVar& = XPRINT(DUPLEX)

Beschreibung

Mit XPRINT können Sie den Duplexstatus abrufen/einstellen, wenn der Drucker das Drucken auf beiden Seiten einer Seite unterstützt. XPRINT GET DUPLEX ruft den Duplexstatus ab und weist den Wert der durch DuplexVar& angegebenen Long-Integer-Variablen zu. Um den möglichen Duplexstatus symbolisch darzustellen, sind im Compiler folgende Equates vordefiniert:

%DMDUP_SIMPLEX = 1 (einseitiger Druck)

%DMDUP_VERTICAL = 2 (Seite am vertikalen Rand umgedreht)

%DMDUP_HORIZONTAL = 3 (Seite am horizontalen Rand umgedreht)

Wenn der Drucker keinen Duplexdruck unterstützt, wird der Wert Null (0) zurückgegeben. Wenn diese Anweisung ohne angeschlossenen Hostdrucker ausgeführt wird, wird Fehler 57 generiert.

Siehe auch

  • XPRINT ANHANG
  • XPRINT SET DUPLEX

PBXB64-Umsetzungshinweise

XPRINT(DUPLEX) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(DUPLEX) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(DUPLEX) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(LINES) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(LINES)
Hilfe zum PBXB64-Compiler

XPRINT(ZEILEN)

Rufen Sie die Anzahl der Zeilen ab, die gedruckt werden können.

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET LINES To LineVar&
Function Form:
LineVar& = XPRINT(LINES)

Beschreibung

XPRINT GET LINES ruft die Anzahl der Textzeilen ab, die bei der aktuell ausgewählten Schriftart auf der Seite des Hostdruckers gedruckt werden können. Da XPRINT-Anweisungen keinen automatischen Seitenvorschub erzeugen, wenn Text in der letzten Zeile gedruckt wird, kann diese Anweisung verwendet werden, um zu bestimmen, wann Ihr Programm einen XPRINT FORMFEED ausführen soll, um zur nächsten gedruckten Seite auf einem Hostdrucker zu wechseln. Bei Ausführung ohne angeschlossenen Hostdrucker wird Fehler 57 generiert.

Siehe auch

  • XPRINT
  • XPRINT ANHANG
  • XPRINT SCHRIFTART EINSTELLEN
  • XPRINT FORMFEED

PBXB64-Umsetzungshinweise

XPRINT(ZEILEN) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(ZEILEN) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(ZEILEN) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT GET MARGIN – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT GET MARGIN

XPRINT MARGIN ERHALTEN

Ruft die Randgrößen der aktuellen XPRINT-Sitzung ab.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET MARGIN TO nLeft! , nTop! , nRight! , nBottom!

Beschreibung

XPRINT GET MARGIN liest die fokussierten Kompatibilitaets-Randwerte der aktuellen XPRINT-Sitzung. In dieser Toolchain sind die vier Ränder deterministisch und werden aus dem Sitzungszustand statt aus einem physischen Druckertreiber gelesen.

Die vier Werte werden in der Reihenfolge links, oben, rechts und unten zurückgegeben. Nach XPRINT ATTACH ist der fokussierte Kompatibilitaetszustand sofort verfuegbar, und die registrierte Regression prueft das Ruecklesen ohne Hostdrucker.

Siehe auch

  • XPRINT ANHANG
  • XPRINT CLIENT ERHALTEN
  • XPRINT PPI ERHALTEN
  • XPRINT GRÖSSE ERHALTEN

PBXB64-Umsetzungshinweise

XPRINT MARGIN ERHALTEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT MARGIN ERHALTEN ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT MARGIN ERHALTEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(MIX) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(MIX)
Hilfe zum PBXB64-Compiler

XPRINT(MIX)

Rufen Sie den verwalteten Kompatibilitäts-Mischmodus des aktuellen XPRINT-Streams ab.

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET MIX To MixVar&
Function Form:
MixVar& = XPRINT(MIX)

Beschreibung

Im fokussierten V14-Slice setzt XPRINT ATTACH den verwalteten Mischmodus auf 13 zurück, und XPRINT GET MIX / XPRINT(MIX) lesen den aktuellen Kompatibilitätswert aus. XPRINT SET MIX aktualisiert diesen Wert für spätere Abfragen; der dateibasierte XPRINT-Ausgabepfad bleibt unverändert.

%MIX_BLACKNESS

Pixel ist immer 0 (schwarz).

%MIX_NOTMERGESRC

Pixel ist die Umkehrung der MergeSrc-Farbe.

%MIX_MASKNOTSRC

Pixel ist eine Kombination der Farben, die sowohl dem Pixel als auch der Umkehrung der Quelle gemeinsam sind.

%MIX_NOTCOPYSRC

Pixel ist die Umkehrung der Stiftfarbe.

%MIX_MASKSRCNOT

Pixel ist eine Kombination der Farben, die sowohl der Quelle als auch der Umkehrung des Pixels gemeinsam sind.

%MIX_NOT

Pixel ist die Umkehrung der Pixelfarbe.

%MIX_XORSRC

Pixel ist eine Kombination der Farben in der Quelle und im Pixel, jedoch nicht in beiden.

%MIX_NOTMASKSRC

Pixel ist die Umkehrung der MaskSrc-Farbe.

%MIX_MASKSRC

Pixel ist eine Kombination der Farben, die sowohl der Quelle als auch dem Pixel gemeinsam sind.

%MIX_NOTXORSRC

Pixel ist die Umkehrung der XorSrc-Farbe.

%MIX_NOP

Pixel bleibt unverändert.

%MIX_MERGENOTSRC

Pixel ist eine Kombination aus der Quellfarbe und der Umkehrung der Pixelfarbe.

%MIX_COPYSRC

Pixel ist die Quellfarbe (Standard).

%MIX_MERGESRCNOT

Pixel ist eine Kombination aus der Quellfarbe und der Umkehrung der Pixelfarbe.

%MIX_MERGESRC

Pixel ist eine Kombination aus der Quellfarbe und der Pixelfarbe.

%MIX_WHITENESS

Pixel ist immer 1 (weiß).

Siehe auch

  • XPRINT ANHANG
  • XPRINT SET MIX

PBXB64-Umsetzungshinweise

XPRINT(MIX) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(MIX) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(MIX) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(ORIENTATION) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(ORIENTATION)
Hilfe zum PBXB64-Compiler

XPRINT(ORIENTIERUNG)

Holen Sie sich das Papier

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET ORIENTATION To OrentVar&
Function Form:
OrentVar& = XPRINT(ORIENTATION)

Beschreibung

XPRINT GET ORIENTATION ruft die Ausrichtung des Papiers im Hostdrucker ab und weist den Wert der durch OrentVar& angegebenen langen Ganzzahlvariablen zu. Der Wert 1 gibt den Hochformatmodus an, während 2 den Querformatmodus angibt. Wenn der Drucker die Papierausrichtung nicht unterstützt, wird 0 zurückgegeben. Wenn kein Hostdrucker angeschlossen ist, wird Fehler 57 generiert.

Siehe auch

  • XPRINT ANHANG
  • XPRINT-SET-AUSRICHTUNG

PBXB64-Umsetzungshinweise

XPRINT(ORIENTIERUNG) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(ORIENTIERUNG) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(ORIENTIERUNG) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(OVERLAP) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(OVERLAP)
Hilfe zum PBXB64-Compiler

XPRINT(ÜBERLAPPUNG)

Ruft den Status von XPrint ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET OVERLAP To OverlapVar&
Function Form:
OverlapVar& = XPRINT(OVERLAP)

Beschreibung

XPRINT GET OVERLAP ruft den Status des Überlappungsmodus ab und weist ihn der durch OverlapVar& angegebenen Variablen zu. Wenn der Überlappungsmodus aktiviert ist, wird der Wert wahr (ungleich Null) zugewiesen. Wenn es deaktiviert ist, wird stattdessen der Wert false (Null) zugewiesen. Der zurückgegebene Wert spiegelt den Status des Hostdruckers wider, der derzeit an den XPrint-Stream angeschlossen ist.

Mit dem Überlappungsmodus können Sie steuern, wie PowerBASIC XPrint-Vorgänge behandelt, deren Definition ein umgrenzendes Rechteck (RECT-Struktur) enthält. Windows behält einzigartige Konventionen für ein RECT bei. Die unteren und rechten Koordinaten eines RECT sind exklusiv. Mit anderen Worten: Die Pixel am unteren und rechten Rand liegen unmittelbar außerhalb des Rechtecks. Sie werden ignoriert. Zum Beispiel:

XPRINT-BOX (0,0) - (50,50)

In diesem Fall wird ein Kästchen von 0,0 bis 49,49 gezeichnet. Die letzten Pixel am unteren und rechten Rand werden einfach nicht gezeichnet. Wenn jedoch der Überlappungsmodus mit XPRINT SET OVERLAP aktiviert ist, wird die Box von 0,0 bis 50,50 gezeichnet.

Der Überlappungsmodus betrifft alle XPRINT-Funktionen, die ein umschließendes Rechteck als Parameter verwenden. Dazu gehören XPRINT SCALE, XPRINT BOX, XPRINT ELLIPSE, XPRINT LINE, XPRINT POLYLINE usw.

Siehe auch

  • XPRINT-SET-ÜBERLAPPUNG

PBXB64-Umsetzungshinweise

XPRINT(ÜBERLAPPUNG) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(ÜBERLAPPUNG) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(ÜBERLAPPUNG) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT GET PAGES – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT GET PAGES

XPRINT SEITEN ERHALTEN

Ruft die fokussierte XPRINT-Seitenrange der aktuellen Sitzung ab.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET PAGES TO FromPage& , ToPage&

Beschreibung

XPRINT GET PAGES liest den fokussierten Kompatibilitaets-Seitenbereich der aktuellen XPRINT-Sitzung. In dieser Toolchain sind die beiden Werte deterministisch und werden durch XPRINT SET PAGES aktualisiert, damit Tests den aktuellen Seitenbereich ohne echten Druckertreiber pruefen koennen.

Der erste Wert wird in FromPage& und der letzte Wert in ToPage& zurueckgegeben. Nach XPRINT ATTACH ist der fokussierte Zustand sofort verfuegbar, und die registrierte Regression prueft das Ruecklesen ohne Hostdrucker.

Siehe auch

  • XPRINT-VORSCHAU
  • XPRINT GET SELECTION
  • XPRINT SET SEITEN

PBXB64-Umsetzungshinweise

XPRINT SEITEN ERHALTEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT SEITEN ERHALTEN ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT SEITEN ERHALTEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(PAPER) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(PAPER)
Hilfe zum PBXB64-Compiler

XPRINT(PAPIER)

Ruft die ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET PAPER TO PaperVar&
Function Form:
PaperVar& = XPRINT(PAPER)

Beschreibung

XPRINT GET PAPER ruft den Papierstil ab, für den der Hostdrucker aktuell konfiguriert ist. Der Papierstil wird durch einen ganzzahligen Wert identifiziert, der der durch PaperVar& angegebenen langen Ganzzahlvariablen zugewiesen wird. Die folgenden Equates sind im Compiler vordefiniert und repräsentieren die gängigsten Papierstile:

%DMPAPER_LETTER = 1 Buchstabe 8,5 x 11 Zoll

%DMPAPER_TABLOID = 3 Tabloid 11 x 17 Zoll

%DMPAPER_LEDGER = 4 Ledger 17 x 11 Zoll

%DMPAPER_LEGAL = 5 Legal 8,5 x 14 Zoll

%DMPAPER_STATEMENT = 6 Statement 5,5 x 8,5 Zoll

%DMPAPER_EXECUTIVE = 7 Executive 7,25 x 10,5 Zoll

%DMPAPER_A3 = 8 A3 297 x 420 mm

%DMPAPER_A4 = 9 A4 210 x 297 mm

%DMPAPER_A5 = 11 A5 148 x 210 mm

%DMPAPER_B4 = 12 B4 250 x 354 mm

%DMPAPER_B5 = 13 B5 182 x 257 mm

%DMPAPER_FOLIO = 14 Folio 8,5 x 13 Zoll

%DMPAPER_QUARTO = 15 Viertel 215 x 275 mm

%DMPAPER_10X14 = 16 10x14 10 x 14 Zoll

%DMPAPER_11X17 = 17 11x17 11 x 17 Zoll

%DMPAPER_NOTE = 18 Notiz 8,5 x 11 Zoll

%DMPAPER_ENV_9 = 19 9 Umschlag 3,875 x 8,875 Zoll

%DMPAPER_ENV_10 = 20 10 Umschlag 4,125 x 9,5 Zoll

Andere Papierstilcodes können von Windows oder Druckerlieferanten definiert werden. Mit XPRINT GET PAPERS erhalten Sie eine Liste aller vom angeschlossenen Host-Drucker unterstützten Papierstile.

Wenn der Drucker keine Papierstiländerungen unterstützt, wird der Wert Null zurückgegeben. Bei Ausführung ohne angeschlossenen Hostdrucker wird Fehler 57 generiert.

Siehe auch

  • XPRINT ANHANG
  • XPRINT PAPIERE ERHALTEN
  • XPRINT SET PAPIER

PBXB64-Umsetzungshinweise

XPRINT(PAPIER) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(PAPIER) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(PAPIER) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT$(PAPERS) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT$(PAPERS)
Hilfe zum PBXB64-Compiler

XPRINT$(PAPIERE)

Ruft die fokussierte Kompatibilitaetsliste der unterstuetzten Papierstile ab.

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET PAPERS TO PapersVar$
Function Form:
PapersVar$ = XPRINT$(PAPERS)

Beschreibung

XPRINT GET PAPERS ruft einen deterministischen Kompatibilitaets-String ab, der die von diesem fokussierten XPRINT-Teil bereitgestellten Papierstile enthaelt. Diese Zeichenfolge wird der durch PapersVar$ angegebenen Zeichenfolgenvariablen zugewiesen.

Die Zeichenfolge enthält eine durch Kommas getrennte Liste von Papiertyp, Papiername ..., die so oft wie nötig wiederholt wird. Zum Beispiel:

„1,Brief,5,Recht,7,Exekutive,20,Umschlag Nr. 10“

Sie können PARSECOUNT verwenden, um die Anzahl der durch Trennzeichen getrennten Felder in der Zeichenfolge zu bestimmen, und PARSE$(), um die Typnummern und -namen einfach zu extrahieren. Die folgenden Equates sind im Compiler vordefiniert und repräsentieren die gängigsten Papierstile:

%DMPAPER_LETTER = 1 Buchstabe 8,5 x 11 Zoll

%DMPAPER_TABLOID = 3 Tabloid 11 x 17 Zoll

%DMPAPER_LEDGER = 4 Ledger 17 x 11 Zoll

%DMPAPER_LEGAL = 5 Legal 8,5 x 14 Zoll

%DMPAPER_STATEMENT = 6 Statement 5,5 x 8,5 Zoll

%DMPAPER_EXECUTIVE = 7 Executive 7,25 x 10,5 Zoll

%DMPAPER_A3 = 8 A3 297 x 420 mm

%DMPAPER_A4 = 9 A4 210 x 297 mm

%DMPAPER_A5 = 11 A5 148 x 210 mm

%DMPAPER_B4 = 12 B4 250 x 354 mm

%DMPAPER_B5 = 13 B5 182 x 257 mm

%DMPAPER_FOLIO = 14 Folio 8,5 x 13 Zoll

%DMPAPER_QUARTO = 15 Viertel 215 x 275 mm

%DMPAPER_10X14 = 16 10x14 10 x 14 Zoll

%DMPAPER_11X17 = 17 11x17 11 x 17 Zoll

%DMPAPER_NOTE = 18 Notiz 8,5 x 11 Zoll

%DMPAPER_ENV_9 = 19 9 Umschlag 3,875 x 8,875 Zoll

%DMPAPER_ENV_10 = 20 10 Umschlag 4,125 x 9,5 Zoll

Die Liste ist im aktuellen fokussierten Teil eingebaut und fragt kein Live-Druckgeraet ab. Andere Papierstilcodes koennen im breiteren Drucker/DC-Bereich weiterhin von Windows oder Druckerlieferanten definiert werden.

Siehe auch

  • XPRINT ANHANG
  • XPRINT PAPIERE ERHALTEN
  • XPRINT SET PAPIER

PBXB64-Umsetzungshinweise

XPRINT$(PAPIERE) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT$(PAPIERE) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT$(PAPIERE) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(PIXEL...) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(PIXEL...)
Hilfe zum PBXB64-Compiler

XPRINT(PIXEL...)

Ruft die ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET PIXEL [STEP] (x!, y!) TO PixelVar&
Function Form:
PixelVar& = XPRINT(PIXEL [STEP], x! , y! )

Beschreibung

Nicht alle Druckertreiber unterstützen die Möglichkeit, die Farbe eines Pixels abzurufen. Wenn diese Funktion nicht unterstützt wird oder die Koordinaten außerhalb des Drucker-Client-Bereichs liegen, wird ein ungültiger Farbwert von -1 zurückgegeben. Wenn kein Hostdrucker angeschlossen ist, wird Fehler 57 generiert.

Siehe auch

  • Built In RGB Color Equates
  • XPRINT ANHANG
  • XPRINT-FARBE
  • XPRINT SET PIXEL

PBXB64-Umsetzungshinweise

XPRINT(PIXEL...) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(PIXEL...) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(PIXEL...) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(POS.X) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(POS.X)
Hilfe zum PBXB64-Compiler

XPRINT(POS.X)

Ruft den letzten von einem XPRINT referenzierten Punkt (POS) ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET POS TO XVar! , YVar!
Function Form:
XVar! = XPRINT(POS.X)
YVar! = XPRINT(POS.Y)

Beschreibung

Mit XPRINT GET POS wird die von diesem fokussierten Slice verwaltete Positionskoordinate gelesen. Die Werte stammen aus dem aktuellen XPRINT-Zustand und nicht aus einem Live-Druckertreiber.

Validierung: tests/pb/test_xprint_get_set_pos.pb prueft sowohl XPRINT GET POS TO als auch die Funktionsformen XPRINT(POS.X)/XPRINT(POS.Y).

Siehe auch

  • XPRINT ANHANG
  • XPRINT SET POS

PBXB64-Umsetzungshinweise

XPRINT(POS.X) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(POS.X) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(POS.X) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(PPI.X) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(PPI.X)
Hilfe zum PBXB64-Compiler

XPRINT(PPI.X)

Ruft die Auflösung des ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET PPI TO XVar& , YVar&
Function Form:
XVar& = XPRINT(PPI.X)
YVar& = XPRINT(PPI.Y)

Beschreibung

XPRINT GET PPI ruft die Auflösung (Punkte pro Zoll) der Host-Druckerseite ab. Die Auflösung wird immer in Pixel angegeben, unabhängig von einer XPRINT SCALE-Option. Bei Ausführung ohne angeschlossenen Hostdrucker wird Fehler 57 generiert und die Werte 0,0 zurückgegeben. Diese Anweisung ist besonders nützlich, wenn Sie Elemente wie Lineale und Diagramme auf eine bestimmte physische Größe zeichnen möchten. Es gibt 25,4 Millimeter pro Zoll, also dividieren Sie einfach durch 25,4, um von Pixel pro Zoll in Pixel pro Millimeter umzurechnen.

Siehe auch

  • XPRINT ANHANG
  • XPRINT CLIENT ERHALTEN
  • XPRINT MARGIN ERHALTEN
  • XPRINT GRÖSSE ERHALTEN

PBXB64-Umsetzungshinweise

XPRINT(PPI.X) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(PPI.X) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(PPI.X) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(QUALITÄT) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(QUALITÄT)
Hilfe zum PBXB64-Compiler

XPRINT(QUALITÄT)

Ruft die ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET QUALITY To QualVar&
Function Form:
QualVar& = XPRINT(QUALITY)

Beschreibung

XPRINT GETQUALITÄT ruft die Druckqualitätseinstellung für den Hostdrucker ab. Der Wert 1 ist der Entwurfsmodus, 2 ist eine niedrige Auflösung, 3 ist eine mittlere Auflösung und 4 ist eine hohe Auflösung. Wenn der Drucker keine Druckqualitätseinstellungen unterstützt, wird 0 zurückgegeben. Wenn kein Hostdrucker angeschlossen ist, wird Fehler 57 generiert.

Siehe auch

  • XPRINT ANHANG
  • XPRINT-SET-QUALITÄT

XPRINT-Prüfung

XPRINT-Seiten sollen Druckerauswahl, Lebensdauer des Device Context, Seitenzustand, Koordinateneinheiten und die Frage nennen, ob der Befehl Vorschau, Rendering oder Druckerausgabe betrifft. Beispiele sollen sicher sein, wenn kein Standarddrucker installiert ist.

Fehlerfälle

Dokumentieren Sie abgebrochene Druckdialoge, nicht verfügbare Drucker, ungültige DC-Handles und nicht unterstützte Gerätefähigkeiten.

Cleanup

Schließen oder brechen Sie Druckjobs ausdrücklich ab und geben Sie angehängte Ressourcen vor Programmende frei.

PBXB64-Umsetzungshinweise

XPRINT(QUALITÄT) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(QUALITÄT) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(QUALITÄT) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT GET SCALE - PBXB64-Compiler-Hilfe

Startseite › BASIC-Frontend › Schlüsselwortreferenz › Grafik & GUI › XPRINT GET SCALE
Hilfe zum PBXB64-Compiler

XPRINT GET SCALE

Die aktuellen XPRINT-Skalierungsgrenzen abfragen.

Typ: Anweisung | Kategorie: Benutzeroberfläche, Grafik und DDT

PBXB64-Status: VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET SCALE TO x1! , y1! , x2! , y2!

Beschreibung

Mit XPRINT SCALE wird das aktuelle Weltkoordinatensystem fuer die XPRINT-Sitzung gesetzt. Dieser fokussierte Slice speichert die vier Begrenzungen als Sitzungszustand, und XPRINT GET SCALE liest sie wieder in vier Zielvariablen zurück.

Nach XPRINT ATTACH ist der Standardwert 0, 0, 1, 1. Nach XPRINT SCALE gelten die zuletzt gesetzten Grenzen. XPRINT SCALE PIXELS setzt die Sitzung wieder auf Pixelkoordinaten zurück.

Praktische Verwendung

Verwenden Sie XPRINT GET SCALE, wenn eine Druck-/Zeichenroutine das aktuelle Seitenabbild vor dem Ausgeben pruefen muss. Der Befehl bewegt nichts; er kopiert die aktiven Skalierungsgrenzen nur in die vier Zielvariablen aus der Syntaxzeile.

Parameter und Zustand

Die vier Zielvariablen erhalten das aktuelle Drucker-Weltfenster. Die aktive Skalierung bleibt im Sitzungszustand erhalten, so dass ein vorheriger XPRINT SCALE-Aufruf bestimmt, was dieser Befehl zurueckliest. Der Befehl selbst aendert den Zustand nicht.

Parameter und Ergebnisse

Die vier Zielvariablen erhalten die Unter- und Obergrenzen des aktiven Weltfensters. Im Standardzustand ist das Ergebnis 0, 0, 1, 1. Nach einer benutzerdefinierten Skalierung oder einem Pixel-Reset zeigen die Werte den jeweiligen Sitzungszustand.

Fehler und Randfaelle

Verwenden Sie den Befehl nur nach dem Anhaengen eines Druckerkontexts. Ist der Kontext nicht vorhanden oder geschlossen, sind die Zielvariablen erst nach erneutem Anhaengen und Lesen des Sitzungszustands zu bewerten.

Validierungsbeleg

Validierungsbeleg: tests/pb/test_xprint_get_set_scale.pb belegt die Standardwerte der Sitzung, den Rundlauf einer benutzerdefinierten Skalierung und das Zurücksetzen mit XPRINT SCALE PIXELS.

Test- und Dokumentationshinweise

Ein brauchbares Beispiel haengt zuerst einen Druckerkontext an, setzt eine benutzerdefinierte Skalierung, liest sie zurueck, setzt auf Pixel zurueck und liest erneut. Genau dieser Lebenszyklus entspricht dem Aufbau einer echten Druckseiten-Routine.

XPRINT ATTACH "scale.tmp"
XPRINT GET SCALE TO x1, y1, x2, y2
XPRINT CLOSE

Example

Das folgende Programm liest zuerst den Standardzustand, setzt dann eine eigene Skalierung und prueft anschliessend den Rueckgabewert erneut nach dem Reset auf Pixel. So laesst sich die Zustandskette schnell nachvollziehen.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL x1 AS DOUBLE
    LOCAL y1 AS DOUBLE
    LOCAL x2 AS DOUBLE
    LOCAL y2 AS DOUBLE

    XPRINT ATTACH "pbxb64_xprint_scale.tmp"
    XPRINT GET SCALE TO x1, y1, x2, y2
    IF ABS(x1 - 0) > 0.000001 OR ABS(y1 - 0) > 0.000001 THEN FUNCTION = 1: GOTO done
    IF ABS(x2 - 1) > 0.000001 OR ABS(y2 - 1) > 0.000001 THEN FUNCTION = 2: GOTO done

    XPRINT SCALE (10.5, 20.25) - (110.75, 220.125)
    XPRINT GET SCALE TO x1, y1, x2, y2
    IF ABS(x1 - 10.5) > 0.000001 OR ABS(y1 - 20.25) > 0.000001 THEN FUNCTION = 3: GOTO done
    IF ABS(x2 - 110.75) > 0.000001 OR ABS(y2 - 220.125) > 0.000001 THEN FUNCTION = 4: GOTO done

    XPRINT SCALE PIXELS
    XPRINT GET SCALE TO x1, y1, x2, y2
    IF ABS(x1 - 0) > 0.000001 OR ABS(y1 - 0) > 0.000001 THEN FUNCTION = 5: GOTO done
    IF ABS(x2 - 1) > 0.000001 OR ABS(y2 - 1) > 0.000001 THEN FUNCTION = 6: GOTO done

done:
    XPRINT CLOSE
    KILL "pbxb64_xprint_scale.tmp"
END FUNCTION

Siehe auch

  • XPRINT SCALE
  • XPRINT(POS.X)
  • XPRINT(MIX)

Beschreibung

XPRINT GET SCALE liest das aktuelle Koordinatensystem der Druckerseite in vier numerische Variablen zurueck. Die Seite dokumentiert das Standardergebnis in Pixeln, die Rueckgabe bei benutzerdefinierter Skalierung und die Bindung an den angehaengten XPRINT-Kontext.

Praktische Verwendung

Verwenden Sie XPRINT GET SCALE, wenn spaetere Zeichen- oder Textbefehle die aktive Druckerabbildung kennen muessen, bevor sie Koordinaten berechnen. Das Ergebnis ist nur nach XPRINT ATTACH sinnvoll und sollte nach jedem XPRINT SCALE- oder XPRINT SCALE PIXELS-Aufruf erneut geprueft werden.

Parameter und Zustand

Die vier Zielvariablen erhalten die aktuellen Werte fuer die linke untere und rechte obere Ecke. Die fokussierte Regression zeigt, dass die Standardwerte 0, 0, 1, 1 sind, dass eine benutzerdefinierte Gleitkomma-Skalierung genau genug fuer den Rueckweg erhalten bleibt und dass das Pixel-Reset die Standardskalierung wiederherstellt.

Fehler und Randfaelle

Wenn kein Druckerkontext angehaengt ist, ist das Ergebnis fuer diese Oberflaeche ungueltig und der Aufrufer sollte den Aufruf als Fehler behandeln. Pruefen Sie den angehaengten Zustand immer zuerst und kombinieren Sie diese Abfrage mit XPRINT SCALE oder XPRINT SCALE PIXELS, wenn der Code von der aktuellen Abbildung abhaengt.

Validierungsbeleg

Validation evidence: tests/pb/test_xprint_get_set_scale.pb bestaetigt die Standardskalierung in Pixeln, die benutzerdefinierte Weltkoordinatenskalierung und die Rueckkehr zu Pixelkoordinaten nach XPRINT SCALE PIXELS.

Test- und Dokumentationshinweise

Das Beispiel sollte mit einem temporaer angehaengten Druckziel laufen und die von XPRINT GET SCALE zurueckgegebenen Werte in jedem Schritt pruefen, nicht nur den Endzustand.

Example

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL x1 AS DOUBLE
    LOCAL y1 AS DOUBLE
    LOCAL x2 AS DOUBLE
    LOCAL y2 AS DOUBLE

    XPRINT ATTACH "pbxb64_xprint_scale.tmp"
    XPRINT GET SCALE TO x1, y1, x2, y2
    XPRINT SCALE (10.5, 20.25) - (110.75, 220.125)
    XPRINT GET SCALE TO x1, y1, x2, y2
    XPRINT SCALE PIXELS
    XPRINT GET SCALE TO x1, y1, x2, y2
    XPRINT CLOSE
    KILL "pbxb64_xprint_scale.tmp"
END FUNCTION

Siehe auch

  • XPRINT SCALE
  • XPRINT ATTACH


XPRINT(SELECTION) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(AUSWAHL)
Hilfe zum PBXB64-Compiler

XPRINT(AUSWAHL)

Ruft den Status des SELECTION-Flags ab.

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET SELECTION TO SelectVar&
Function Form:
SelectVar& = XPRINT(SELECTION)

Beschreibung

Sie können einen bestimmten Druckauftrag auf nur den Teil der Gesamtmenge beschränken, der ausgewählt/hervorgehoben ist. Wenn dies der Fall ist, liegt es in der Verantwortung des Programmierers, die XPRINT-Ausgabe nur auf den ausgewählten Bereich zu beschränken.

Das Auswahlflag kann vom Benutzer nur im Druckdialog gesetzt werden, der angezeigt wird, wenn XPRINT ATTACH mit der Option CHOOSE ausgeführt wird. Es kann nicht programmgesteuert eingestellt werden. Dieses Flag wird nur beibehalten, um dem Programmierer Informationen über die Anfrage des Benutzers zu geben. Wenn Sie diese Option nicht berücksichtigen möchten, sollten Sie sie in XPRINT ATTACH CHOOSE deaktivieren.

Wenn XPRINT GET SELECTION ohne angeschlossenen Hostdrucker ausgeführt wird, wird ein Fehler 57 generiert.

Siehe auch

  • XPRINT ANHANG

PBXB64-Umsetzungshinweise

XPRINT(AUSWAHL) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(AUSWAHL) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(AUSWAHL) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(SIZE.X) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(SIZE.X)
Hilfe zum PBXB64-Compiler

XPRINT(GRÖSSE.X)

Rufen Sie die Gesamtgröße ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET SIZE TO WidthVar& , HeightVar&
Function Form:
WidthVar& = XPRINT(SIZE.X)
HeightVar& = XPRINT(SIZE.Y)

Beschreibung

Mit XPRINT GET SIZE können Sie die volle Größe der Host-Druckerseite abrufen, einschließlich des druckbaren Clientbereichs und aller nicht druckbaren Ränder. Die Größen werden in Pixel (Punkten) angegeben. Wenn kein Hostdrucker angeschlossen ist, wird Fehler 57 generiert und die Werte 0,0 zurückgegeben.

Siehe auch

  • XPRINT ANHANG
  • XPRINT CLIENT ERHALTEN
  • XPRINT MARGIN ERHALTEN
  • XPRINT GET MIX
  • XPRINT PPI ERHALTEN

PBXB64-Umsetzungshinweise

XPRINT(GRÖSSE.X) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(GRÖSSE.X) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(GRÖSSE.X) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(STRETCHMODE) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(STRETCHMODE)
Hilfe zum PBXB64-Compiler

XPRINT (STRECKMODUS)

Ruft den Standard-Bitmap-Streckmodus für das angehängte Objekt ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET STRETCHMODE TO ModeVar&
Function Form:
ModeVar& = XPRINT(STRETCHMODE)

Beschreibung

In PowerBASIC gibt es mehrere Vorgänge, die das Strecken oder Komprimieren von Bildern auf Bitmaps umfassen, insbesondere XPRINT STRETCH . Da einzelne Punkte hinzugefügt oder entfernt werden müssen, ist die Wahrscheinlichkeit groß, dass sich die Bildqualität verschlechtert. Wenn Sie jedoch die Art des Bildes durch die Definition eines StretchMode beschreiben, können Sie das Erscheinungsbild erheblich verbessern.

Der Standard-StretchMode wird für jeden DC individuell verwaltet. Sie können den Standardmodus mit dieser Anweisung abrufen oder mit XPRINT SET STRETCHMODE festlegen. Natürlich können Sie den Standard-StretchMode auch überschreiben, wenn Sie eine der betroffenen Anweisungen ausführen.

Die 4 Stretch-Modus-Equates sind in PowerBASIC vordefiniert.

%BLACKONWHITE

Dies ist der standardmäßige Streckungsmodus von Windows und eignet sich am besten für monochrome Bitmaps oder solche mit Farbblöcken. Führt ein boolesches ODER von eliminierten und vorhandenen Pixeln durch. Schwarze Pixel bleiben auf Kosten weißer Pixel erhalten.

%WHITEONBLACK

Führt ein boolesches ODER von eliminierten und vorhandenen Pixeln durch. Es behält weiße Pixel auf Kosten schwarzer Pixel bei.

%COLORONCOLOR

Löscht gelöschte Pixelzeilen, ohne zu versuchen, ihre Informationen beizubehalten.

%HALBTON

Dies bietet höchste Qualität für komplexe Farbbitmaps. Die durchschnittliche Farbe des Zielpixelblocks bleibt ungefähr die gleiche wie die des Quellpixelblocks.

Siehe auch

  • XPRINT-KOPIE
  • XPRINT RENDER
  • XPRINT STRETCH
  • XPRINT STRETCHMODUS EINSTELLEN

PBXB64-Umsetzungshinweise

XPRINT (STRECKMODUS) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT (STRECKMODUS) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT (STRECKMODUS) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(TRAY) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(TRAY)
Hilfe zum PBXB64-Compiler

XPRINT(FACH)

Ruft den fokussierten Tray-Status der Kompatibilitaet ab.

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET TRAY TO TrayVar&
Function Form:
TrayVar& = XPRINT(TRAY)

Beschreibung

XPRINT GET TRAY ruft den aktuellen Tray-Code ab, der von diesem fokussierten XPRINT-Teil verwaltet wird. Der durch TrayVar& angegebenen Long-Integer-Variable wird ein beschreibender Wert zugewiesen. Die folgenden Equates sind im Compiler vordefiniert und stellen die gebräuchlichsten Papierfächer dar:

%DMBIN_UPPER = 1

%DMBIN_LOWER = 2

%DMBIN_MIDDLE = 3

%DMBIN_MANUAL = 4

%DMBIN_ENVELOPE = 5

%DMBIN_ENVMANUAL = 6

%DMBIN_AUTO = 7

%DMBIN_TRACTOR = 8

%DMBIN_SMALLFMT = 9

%DMBIN_LARGEFMT = 10

%DMBIN_LARGECAPACITY = 11

%DMBIN_CASSETTE = 14

%DMBIN_FORMSOURCE = 15

Der Tray-Code wird vom aktuellen fokussierten Teil verwaltet und fragt kein Live-Druckgeraet ab. Mit XPRINT GET TRAYS erhalten Sie die deterministische Tray-Liste, die diese Kompatibilitaetsschicht verwendet.

Nicht unterstuetzte Tray-Codes werden mit einer gezielten Diagnose abgelehnt.

Siehe auch

  • XPRINT ANHANG
  • XPRINT GET TABLETS
  • XPRINT-SET-FACH

PBXB64-Umsetzungshinweise

XPRINT(FACH) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(FACH) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(FACH) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT$(TRAYS) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT$(TRAYS)
Hilfe zum PBXB64-Compiler

XPRINT$(TRAYS)

Ruft die fokussierte Kompatibilitaetsliste der unterstuetzten Papierfaecher ab.

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET TRAYS TO TrayVar$
Function Form:
TrayVar$ = XPRINT$(TRAYS)

Beschreibung

XPRINT GET TRAYS ruft einen deterministischen Kompatibilitaets-String ab, der die von diesem fokussierten XPRINT-Teil bereitgestellten Papierfaecher enthaelt. Dieser String wird der durch TrayVar$ angegebenen String-Variablen zugewiesen.

Die Zeichenfolge enthält eine durch Kommas getrennte Liste mit Fachtyp, Fachname usw., die so oft wie nötig wiederholt wird. Zum Beispiel:

„1,Obere,2,Untere,5,Umschlag“

Sie können PARSECOUNT verwenden, um die Anzahl der durch Trennzeichen getrennten Felder in der Zeichenfolge zu bestimmen, und PARSE$(), um die Fachnummern und -namen einfach zu extrahieren. Die folgenden Equates sind im Compiler vordefiniert und stellen die gebräuchlichsten Trays dar:

%DMBIN_UPPER = 1

%DMBIN_LOWER = 2

%DMBIN_MIDDLE = 3

%DMBIN_MANUAL = 4

%DMBIN_ENVELOPE = 5

%DMBIN_ENVMANUAL = 6

%DMBIN_AUTO = 7

%DMBIN_TRACTOR = 8

%DMBIN_SMALLFMT = 9

%DMBIN_LARGEFMT = 10

%DMBIN_LARGECAPACITY = 11

%DMBIN_CASSETTE = 14

%DMBIN_FORMSOURCE = 15

Die Liste ist im aktuellen fokussierten Teil eingebaut und fragt kein Live-Druckgeraet ab. Andere Fachcodes koennen im breiteren Drucker/DC-Bereich weiterhin von Windows oder Druckerlieferanten definiert werden.

Siehe auch

  • XPRINT ANHANG
  • XPRINT GET TRAY
  • XPRINT-SET-FACH

PBXB64-Umsetzungshinweise

XPRINT$(TRAYS) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT$(TRAYS) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT$(TRAYS) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(WORDWRAP) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(WORDWRAP)
Hilfe zum PBXB64-Compiler

XPRINT(WORDWRAP)

Ruft den Status von XPRINT ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET WORDWRAP TO WrapVar&
Function Form:
WrapVar& = XPRINT(WORDWRAP)

Beschreibung

XPRINT GET WORDWRAP ruft den Status des Zeilenumbruchmodus ab und weist ihn der durch WrapVar& angegebenen Variablen zu. Wenn der WordWrap-Modus aktiviert ist, wird der Wert true (ungleich Null) zugewiesen. Wenn es deaktiviert ist, wird stattdessen der Wert false (Null) zugewiesen. Der zurückgegebene Wert spiegelt den Status des angeschlossenen Druckers wider.

Mit dem WordWrap-Modus können Sie steuern, wie PowerBASIC Text auf einer XPRINT-Seite druckt, wenn dieser das Ende einer Zeile erreicht. Da XPRINT ganzseitig arbeitet, wird standardmäßig Text ignoriert, der über das Zeilenende hinaus gedruckt wird. Dies kann programmgesteuert mit XPRINT SET WORDWRAP geändert werden.

Wenn der WordWrap-Modus aktiviert ist, betrifft er nur XPRINT-Druckvorgänge. Wenn XPRINT print versucht, ein Wort über das Ende einer Zeile hinaus anzuzeigen, wird das gesamte Wort automatisch in die erste Spalte der nächsten Zeile umgebrochen.

Siehe auch

  • XPRINT-ZELLE
  • XPRINT GET WRAP
  • XPRINT SET WORDWRAP
  • XPRINT SET WRAP
  • XPRINT SPLIT

PBXB64-Umsetzungshinweise

XPRINT(WORDWRAP) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(WORDWRAP) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(WORDWRAP) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(WRAP) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(WRAP)
Hilfe zum PBXB64-Compiler

XPRINT(WRAP)

Ruft den Status von XPRINT ab

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT GET WRAP TO WrapVar&
Function Form:
WrapVar& = XPRINT(WRAP)

Beschreibung

XPRINT GET WRAP ruft den Status des Wrap-Modus ab und weist ihn der durch WrapVar& angegebenen Variablen zu. Wenn der Wrap-Modus aktiviert ist, wird der Wert true (ungleich Null) zugewiesen. Wenn es deaktiviert ist, wird stattdessen der Wert false (Null) zugewiesen. Der zurückgegebene Wert spiegelt den Status des angeschlossenen Druckers wider.

Mit dem Wrap-Modus können Sie steuern, wie PowerBASIC Text auf einer XPRINT-Seite druckt, wenn dieser das Ende einer Zeile erreicht. Da XPRINT ganzseitig arbeitet, wird standardmäßig Text ignoriert, der über das Zeilenende hinaus gedruckt wird. Dies kann programmgesteuert mit XPRINT SET WRAP geändert werden.

Wenn der Wrap-Modus aktiviert ist, betrifft er nur XPRINT-Druckvorgänge. Wenn XPRINT print versucht, ein Zeichen über das Ende einer Zeile hinaus anzuzeigen, wird es automatisch in die erste Spalte der nächsten Zeile umgebrochen.

Siehe auch

  • XPRINT-ZELLE
  • XPRINT WORDWRAP ERHALTEN
  • XPRINT SET WORDWRAP
  • XPRINT SET WRAP
  • XPRINT SPLIT

PBXB64-Umsetzungshinweise

XPRINT(WRAP) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(WRAP) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(WRAP) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT IMAGELIST – Hilfe zum PBXB64-Compiler

Startseite › Funktionen › XPRINT IMAGELIST

XPRINT-BILDLISTE

Druckt ein Bild von einem

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT IMAGELIST ( x! , y! ), hLst , index& , overlay& , style&

Beschreibung

Eines der in einer IMAGELIST gespeicherten Bilder wird auf dem angeschlossenen Hostdrucker gedruckt. Die Parameter x! , y! Definieren Sie die obere linke Ecke der Position des Bildes. hLst ist das Handle der IMAGELIST und index& ist der Selektor des anzuzeigenden Bildes (1=erstes, 2=zweite usw.). Wenn overlay& ungleich Null ist, gibt es ein Overlay-Bild an, das dem gedruckten Bild aus der Bildliste hinzugefügt werden soll. Der Parameter style& kann eines der folgenden Stilbits sein:

%ILD_NORMAL

Zeichnet das Bild mit der Hintergrundfarbe der Bildliste. Wenn die Hintergrundfarbe den Standardwert %CLR_NONE hat (definiert in der Datei Commctrl.inc), wird das Bild transparent gezeichnet.

%ILD_TRANSPARENT

Zeichnet das Bild transparent, wenn eine Maske vorhanden ist.

%ILD_MASK

Zeichnet die Maske.

%ILD_BLEND25

Wenn eine Maske vorhanden ist, wird das Bild mit einer Mischung von 25 % mit der Systemhervorhebungsfarbe gezeichnet.

%ILD_BLEND50

Wenn eine Maske vorhanden ist, wird das Bild zu 50 % mit der Hervorhebungsfarbe des Systems gemischt gezeichnet.

Siehe auch

  • XPRINT ANHANG
  • BILDLISTE

PBXB64-Umsetzungshinweise

XPRINT-BILDLISTE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT-BILDLISTE ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT-BILDLISTE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT LINE - PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT LINE

XPRINT-LINIE

Zeichne eine Linie auf a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT LINE [STEP] [( x1! , y1! )] - [STEP] ( x2! , y2! )[, rgbColor& ]

Beschreibung

Die Linie wird vom ersten Punkt bis zum zweiten Punkt gezeichnet, jedoch nicht einschließlich. Koordinatenpunkte werden in Pixel angegeben, es sei denn, optionale Weltkoordinaten wurden mit einer XPRINT SCALE-Anweisung definiert. Die Linienbreite kann mit XPRINT WIDTH eingestellt werden. Wenn die Linienbreite auf 1 eingestellt ist (Standardeinstellung), kann der Linienstil mit XPRINT STYLE festgelegt werden. Bei Ausführung ohne angeschlossenen Hostdrucker wird Fehler 57 generiert.

Die Grafikkonventionen von Windows betrachten die endgültigen x2- und y2-Koordinaten als exklusiv. Daher wird das letzte Pixel standardmäßig nicht gezeichnet, es sei denn, der Überlappungsmodus ist aktiviert. Weitere Informationen finden Sie unter XPRINT SET OVERLAP.

x1! , y1!

Optionale Werte, die den Startpunkt der Linie definieren. Wenn dieser optionale erste Punkt weggelassen wird, beginnt die Zeile am letzten Punkt, auf den in einer vorhergehenden Anweisung verwiesen wird (POS). Wenn die erste STEP-Option enthalten ist, ist das x1! und y1! Die Startkoordinaten beziehen sich auf den letzten Referenzpunkt (POS) auf der Seite des Hostdruckers.

x2! , y2!

Der Endpunkt der Linie. Wenn die zweite STEP-Option enthalten ist, ist das x2! und y2! Endkoordinaten sind relativ zu den Startkoordinaten.

rgbColor&

Optionaler RGB-Farbwert für die Linie. Wenn rgbColor& weggelassen wird (oder -1), wird als Linienfarbe standardmäßig die aktuelle Vordergrundfarbe für die Hostdruckerseite verwendet.

Siehe auch

  • Built In RGB Color Equates
  • XPRINT ARC
  • XPRINT ANHANG
  • XPRINT-BOX
  • XPRINT-FARBE
  • XPRINT ELLIPSE
  • XPRINT PIE
  • XPRINT-POLYGON
  • XPRINT POLYLINE
  • XPRINT SET MIX
  • XPRINT-SET-ÜBERLAPPUNG
  • XPRINT-STIL
  • XPRINT-BREITE

PBXB64-Umsetzungshinweise

XPRINT-LINIE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT-LINIE ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT-LINIE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT PIE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT PIE

XPRINT PIE

Zeichnen Sie einen Kreisabschnitt auf a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT PIE ( x1! , y1! ) - ( x2! , y2! ), arcStart! , arcEnd! [, [ rgbColor& ] [, [ fillcolor& ] [, [ fillstyle& ]]]]

Beschreibung

Ein Kreisabschnitt ist ein Bogen, bei dem von jedem Endpunkt eine Linie zum Mittelpunkt des Kreises oder der Ellipse gezogen wird. Um einen Kreisabschnitt festzulegen, definieren Sie zunächst den vollständigen Kreis oder die Ellipse, zu der er gehört, und geben dann die Punkte auf der Ellipse an, an denen der Bogen beginnt und endet.

Der Vollkreis oder die Ellipse wird durch sein umschließendes Rechteck definiert, das als das kleinste Rechteck definiert ist, das um den Kreis oder die Ellipse herum gezeichnet werden kann. Wenn der Kreis beispielsweise an der Position (400.400) zentriert ist und einen Radius von 100 Pixeln hat, ist die obere linke Ecke (x1,y1) des Begrenzungsrechtecks ​​(300.300) und die untere rechte Ecke (x2,y2) ist (500.500).

Der Startpunkt und der Endpunkt des Bogens werden durch ihren Winkel angegeben, der im Bogenmaß angegeben werden muss. Ein vollständiger Kreis oder eine vollständige Ellipse hat ein Bogenmaß von 2*pi. Auf einem 12-Stunden-Zifferblatt beziehen sich die Werte 0 und 2*pi beide auf die Position 3 Uhr, während sich der Wert 1*pi auf die Position 9 Uhr bezieht. Andere Positionen werden durch einen Bogenmaßwert relativ zu diesen angegeben. In PowerBASIC werden Bögen immer gegen den Uhrzeigersinn vom Startpunkt zum Endpunkt gezeichnet.

Vor allen XPRINT-Vorgängen muss zunächst mit XPRINT ATTACH ein Host-Drucker ausgewählt werden. Die Koordinatenpunkte werden in Pixel (oder Weltkoordinaten, falls diese mit XPRINT SCALE ausgewählt wurden) angegeben. Die Linienbreite kann mit XPRINT WIDTH eingestellt werden. Wenn die Linienbreite auf 1 eingestellt ist (Standardeinstellung), kann der Linienstil mit XPRINT STYLE festgelegt werden. Aufgrund der Natur eines Kreisabschnitts verwendet XPRINT PIE weder (letzter Punkt, auf den verwiesen wird) noch aktualisiert es ihn. Bei Ausführung ohne angeschlossenen Hostdrucker wird Fehler 57 generiert.

x1! , y1!

Die obere linke Ecke des umschließenden Rechtecks des Vollkreises oder der Ellipse.

x2! , y2!

Die untere rechte Ecke des Begrenzungsrechtecks des Vollkreises oder der Ellipse.

ArcStart!

Der Anfangswinkel des Bogens im Bogenmaß von 0 bis 2*pi.

ArcEnd!

Der Endwinkel des Bogens im Bogenmaß von 0 bis 2*pi im Bogenmaß. Beachten Sie, dass Bögen von arcStart aus immer gegen den Uhrzeigersinn gezeichnet werden! zu arcEnd! . Im Vergleich zu einem 12-Stunden-Zifferblatt liegt 0 oder 2*pi im Bogenmaß bei 3 Uhr und 1*pi im Bogenmaß bei 9 Uhr.

rgbColor&

Optionale RGB-Farbe des Tortenrandes. Wenn es weggelassen wird (oder -1), wird als Kantenfarbe standardmäßig die aktuelle Vordergrundfarbe für die Hostdruckerseite verwendet.

Füllfarbe&

Optionale RGB-Farbe des Kucheninneren. Wenn fillcolor& weggelassen wird (oder -2), wird das Innere des Kreises nicht ausgefüllt, sodass der Hintergrund durchscheinen kann. Wenn fillcolor& -1 ist, wird der Innenraum mit der gleichen Farbe wie der Rand bemalt. Andernfalls gibt fillcolor& die zu verwendende RGB-Farbe an.

Füllstil&

Optionaler Füllstil (Muster), der verwendet werden soll. Wenn fillstyle& weggelassen wird, ist der Standardfüllstil „solid“ (0). Wenn ein Schraffurmuster ausgewählt wird (1 bis 6), wird die Vordergrundfarbe durch fillcolor& angegeben, während der Hintergrund durch die Standardhintergrundfarbe für die Hostdruckerseite angegeben wird. Der optionale Füllstil& kann sein:

Fest (Standard)

Horizontale Linien

Vertikale Linien

Nach oben gerichtete diagonale Linien

Abwärts gerichtete diagonale Linien

Gekreuzte Linien

Diagonal gekreuzte Linien

Siehe auch

  • Built In RGB Color Equates
  • XPRINT ARC
  • XPRINT ANHANG
  • XPRINT-BOX
  • XPRINT-FARBE
  • XPRINT ELLIPSE
  • XPRINT-LINIE
  • XPRINT-STIL
  • XPRINT-BREITE

PBXB64-Umsetzungshinweise

XPRINT PIE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT PIE ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT PIE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT POLYGON – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT POLYGON

XPRINT-POLYGON

Zeichnen Sie ein Polygon auf a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT POLYGON points [, [ rgbColor& ] [, [ fillcolor& ] [, [ fillstyle& ] [, fillmode& ]]]]

Beschreibung

Die Koordinatenpunkte werden in Pixel angegeben, es sei denn, optionale Weltkoordinaten wurden mit einer XPRINT SCALE-Anweisung definiert. Die Linienbreite kann mit XPRINT WIDTH eingestellt werden. Wenn die Linienbreite auf 1 eingestellt ist (Standardeinstellung), kann der Linienstil mit XPRINT STYLE festgelegt werden. XPRINT POLYGON verwendet oder aktualisiert den letzten referenzierten Punkt (POS) weder. Bei Ausführung ohne angeschlossenen Hostdrucker wird Fehler 57 generiert.

Punkte

Benutzerdefinierter Typ, der die Anzahl der Scheitelpunkte und deren Position definiert. Es müssen mindestens zwei und nicht mehr als 1024 Scheitelpunkte vorhanden sein. Das erste Element ist eine lange Ganzzahl-Punktzahl, direkt gefolgt von der entsprechenden Anzahl von Gleitkommazahlen mit einfacher Genauigkeit, um die tatsächlichen Koordinaten anzugeben. Gleitkommakoordinaten sind erforderlich, da sie mit XPRINT SCALE als Weltkoordinaten verwendet werden können. Sie können einen Typ mit einer Skalarliste wie folgt verwenden:

TYP PolyPoints

als lang zählen

x1 als Single

y1 als Single

x2 als Single

y2 als Single

x3 als Single

y3 als Single

END-TYP

Oder Sie können ein Array mithilfe von Punkttypen erstellen, etwa so:

TYP PolyPoint

x als Single

y als Single

END-TYP

TYP PolyArray

als lang zählen

xy(1 TO 3) als PolyPoint

END-TYP

rgbColor&

Optionale RGB-Farbe der Polygonkante. Wenn es weggelassen wird (oder -1), wird als Kantenfarbe standardmäßig die aktuelle Vordergrundfarbe für die Hostdruckerseite verwendet.

Füllfarbe&

Optionale RGB-Farbe des Polygoninneren. Wenn fillcolor& weggelassen wird (oder -2), wird das Innere der Ellipse nicht ausgefüllt, sodass der Hintergrund durchscheinen kann. Wenn fillcolor& -1 ist, wird der Innenraum mit der gleichen Farbe wie der Rand bemalt. Andernfalls gibt fillcolor& die zu verwendende RGB-Farbe an.

Füllstil&

Optionaler Füllstil (Muster), der verwendet werden soll. Wenn fillstyle& weggelassen wird, ist der Standardfüllstil „solid“ (0). Wenn ein Schraffurmuster ausgewählt wird (1 bis 6), wird die Vordergrundfarbe durch fillcolor& angegeben, während der Hintergrund durch die Standardhintergrundfarbe für die Hostdruckerseite angegeben wird. Der optionale Füllstil& kann sein:

Fest (Standard)

Horizontale Linien

Vertikale Linien

Nach oben gerichtete diagonale Linien

Abwärts gerichtete diagonale Linien

Gekreuzte Linien

Diagonal gekreuzte Linien

Füllmodus&

Fehlt fillmode& (oder Null), wird der Wickelmodus ausgewählt. Dadurch wird jeder Bereich mit einem Wicklungswert ungleich Null gefüllt. Wenn fillmode& ungleich Null ist, wird der alternative Modus ausgewählt. Dadurch wird der Bereich zwischen ungeraden und geraden Polygonseiten auf jeder Scanlinie ausgefüllt. Das heißt, es füllt den Bereich zwischen der ersten Seite und der zweiten Seite, zwischen der dritten Seite und der vierten Seite usw. aus.

Siehe auch

  • Built In RGB Color Equates
  • XPRINT ARC
  • XPRINT ANHANG
  • XPRINT-BOX
  • XPRINT-FARBE
  • XPRINT ELLIPSE
  • XPRINT-LINIE
  • XPRINT POLYLINE

PBXB64-Umsetzungshinweise

XPRINT-POLYGON gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT-POLYGON ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT-POLYGON mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT POLYLINE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT POLYLINE

XPRINT POLYLINE

Zeichnen Sie eine Reihe verbundener Linien auf a

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT POLYLINE points [ , rgbColor& ]

Beschreibung

Die Koordinatenpunkte werden in Pixel angegeben, es sei denn, optionale Weltkoordinaten wurden mit einer XPRINT SCALE-Anweisung definiert. Die Linienbreite kann mit XPRINT WIDTH eingestellt werden. Wenn die Linienbreite auf 1 eingestellt ist (Standardeinstellung), kann der Linienstil mit XPRINT STYLE festgelegt werden. XPRINT POLYLINE verwendet oder aktualisiert den letzten referenzierten Punkt (POS) weder. Bei Ausführung ohne angeschlossenen Hostdrucker wird Fehler 57 generiert.

Die Grafikkonventionen von Windows betrachten die endgültigen x2- und y2-Koordinaten als exklusiv. Daher wird das letzte Pixel standardmäßig nicht gezeichnet, es sei denn, der Überlappungsmodus ist aktiviert. Weitere Informationen finden Sie unter XPRINT SET OVERLAP.

Punkte

Benutzerdefinierter Typ, der die Anzahl der Scheitelpunkte und deren Position definiert. Es müssen mindestens zwei und nicht mehr als 1024 Scheitelpunkte vorhanden sein. Das erste Element ist eine lange Ganzzahl-Punktzahl, direkt gefolgt von der entsprechenden Anzahl von Gleitkommazahlen mit einfacher Genauigkeit, um die tatsächlichen Koordinaten anzugeben. Gleitkommakoordinaten sind erforderlich, da sie mit SCALE als Weltkoordinaten verwendet werden können. Sie können einen Typ mit einer Skalarliste wie folgt verwenden:

TYP PolyPoints

als lang zählen

x1 als Single

y1 als Single

x2 als Single

y2 als Single

x3 als Single

y3 als Single

END-TYP

Oder Sie können ein Array mithilfe von Punkttypen erstellen, etwa so:

TYP PolyPoint

x als Single

y als Single

END-TYP

TYP PolyArray

als lang zählen

xy(1 TO 3) als PolyPoint

END-TYP

rgbColor&

Optionale RGB-Farbe der Polygonkante. Wenn es weggelassen wird (oder -1), wird als Kantenfarbe standardmäßig die aktuelle Vordergrundfarbe für die Hostdruckerseite verwendet.

Siehe auch

  • Built In RGB Color Equates
  • XPRINT ARC
  • XPRINT ANHANG
  • XPRINT-BOX
  • XPRINT-FARBE
  • XPRINT ELLIPSE
  • XPRINT-LINIE
  • XPRINT-POLYGON
  • XPRINT-SET-ÜBERLAPPUNG
  • XPRINT-STIL
  • XPRINT-BREITE

PBXB64-Umsetzungshinweise

XPRINT POLYLINE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT POLYLINE ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT POLYLINE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT-VORSCHAU – PBXB64-Compiler-Hilfe

Startseite› Funktionen › XPRINT PREVIEW

XPRINT-VORSCHAU

Zeigen Sie eine Kopie eines gedruckten Dokuments auf dem Bildschirm an.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT PREVIEW hWin , ID [, CALL xxx ]
XPRINT PREVIEW CLOSE

Beschreibung

Die Druckvorschau ist ein leistungsstarkes Konzept, das in den meisten Anwendungsprogrammen berücksichtigt werden sollte, die gedruckte Berichte bereitstellen. Kurz gesagt besteht die Idee darin, einen gedruckten Bericht auf dem Bildschirm anzuzeigen, bevor er auf Papier gedruckt wird.

Mit XPRINT PREVIEW können Sie die Ausgabe von XPRINT-Anweisungen in eine Grafik, ein Steuerelement oder ein Fenster umleiten, damit sie auf dem Bildschirm angezeigt werden kann. Wenn XPRINT PREVIEW CLOSE ausgeführt wird, kehrt die XPRINT-Ausgabe zurück zum Host-Drucker, sodass nun eine Wiederholung des XPRINT-Codes an den Drucker gesendet wird, um den gedruckten Bericht abzuschließen.

XPRINT PREVIEW wählt das Grafikziel aus und sollte direkt nach der Auswahl des Druckers mit XPRINT ATTACH ausgeführt werden. Das Ziel wird durch das Handle und die ID identifiziert, die bei der Erstellung angegeben wurden. Optional können Sie eine Callback-Funktion angeben, die bei jeder Ausführung eines XPRINT FORMFEED oder XPRINT CLOSE aufgerufen wird.

XPRINT PREVIEW muss unmittelbar nach XPRINT ATTACH ausgeführt werden, sonst wird zur Laufzeit der Fehler 98 „XPrint Preview Error“ generiert. Zwischen XPRINT ATTACH und XPRINT PREVIEW dürfen keine XPRINT-Anweisungen (außer der XPRINT$-Funktion) ausgeführt werden.

Wenn Sie die CallBack-Option einschließen, muss die Callback-Prozedur ein einfaches SUB ohne Parameter und ohne Rückgabewert sein. Es wird automatisch von der XPRINT-Engine aufgerufen, wenn jede Vorschauseite fertig ist (bei der Ausführung von XPRINT FORMFEED oder

Siehe auch

  • XPRINT ANHANG
  • XPRINT CLOSE
  • XPRINT FORMFEED

PBXB64-Umsetzungshinweise

XPRINT-VORSCHAU gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT-VORSCHAU ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT-VORSCHAU mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT PRINT - PBXB64 Compiler-Hilfe

Startseite › Funktionen › XPRINT PRINT

XPRINT PRINT

Schreiben Sie formatierten Text in den aktiven XPRINT-Stream.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT PRINT [ EXPRLIST ] [POS( n )] [SPC( n )] [TAB( n )] [,] [;]...
XPRINT [ EXPRLIST ] [POS( n )] [SPC( n )] [TAB( n )] [,] [;]...

Beschreibung

Vor allen XPRINT-Vorgängen sollten Sie sicherstellen, dass XPRINT ATTACH einen Stream geöffnet hat. Im fokussierten V14-Schnitt schreibt XPRINT PRINT in den aktiven dateibasierten XPRINT-Stream und behält das bisherige Trennzeichenverhalten für Zeichenfolgen- und numerische Ausdruckslisten bei.

XPRINT PRINT besteht aus den folgenden Teilen, die in beliebiger Reihenfolge und Menge in einer einzigen Anweisung vorkommen können:

EXPRLISTE

Zeichenfolge und/oder numerische Ausdrücke, die in den aktiven XPRINT-Stream geschrieben werden. Ein Semikolon kann als Trennzeichen zwischen mehreren Ausdrücken in derselben Anweisung verwendet werden. Nach Abschluss wird der POS an den linken Rand der nächsten Zeile verschoben.

POS(n)

Eine optionale Funktion, die verwendet wird, um den POS auf die horizontale Seiteneinheit (Pixel, skalierte Einheit usw.) festzulegen, die durch das numerische Argument angegeben wird. Mehrere Verwendungen der POS-Funktion sind in einer einzigen Anweisung zulässig. Die vertikale Position bleibt unverändert.

SPC( n )

Eine optionale Funktion zum Einfügen von n Leerzeichen in die gedruckte Ausgabe. Die mehrfache Verwendung von SPC ist in einer einzigen Anweisung zulässig. Werte von n kleiner als 1 werden ignoriert.

TAB( n )

Eine optionale Funktion, die verwendet wird, um mit der Tabulatortaste zur n-ten Spalte zu wechseln, bevor der nächste Ausdruck gedruckt wird. Die mehrfache Verwendung von TAB in einer einzigen Anweisung ist zulässig. Da TAB auf Spalten und nicht auf Pixel verweist, kann es bei Verwendung mit einer Schriftart mit variabler Breite zu unvorhersehbaren Ergebnissen führen. Es wird am besten mit einer Schriftart mit fester Breite verwendet.

Sonderzeichen, die die Position des nächsten gedruckten Textelements bestimmen. Ein Semikolon (;) bedeutet, dass das nächste Textelement sofort gedruckt wird; Ein Komma (,) bedeutet, dass das nächste Textelement am Anfang der nächsten Druckzone gedruckt wird. Druckzonen beginnen alle 14 Spalten.

Wenn das letzte Argument ein Semikolon oder Komma ist, wird die Position an der aktuellen Position beibehalten und nicht standardmäßig an den Anfang der nächsten Zeile verschoben. Zum Beispiel:

XPRINT PRINT „Hallo“;

XPRINT PRINT „Welt!“;

...erzeugt das zusammenhängende Ergebnis „Hallo Welt!“

Wenn Sie alle Argumente weglassen, verschiebt XPRINT PRINT das POS einfach an den linken Rand der nächsten Zeile. Im dateibasierten Schnitt ist XPRINT FORMFEED das separate Byte-Markierungszeichen für einen Seitenumbruch; Wagenrücklauf, Zeilenvorschub und Rücktaste in Ausdruckstext werden als normale Zeichen geschrieben.

USING$ ist eine separate Funktion, die in die ExprList eingebunden werden kann. Weitere Informationen finden Sie in der Funktion USING$().

Es ist nicht möglich, einen benutzerdefinierten Typ (UDT), eine Variante, eine Objektvariable oder ein ganzes Array zu drucken. Einzelne Elementwerte müssen mit der entsprechenden Funktion extrahiert werden, bevor sie angezeigt werden können.

Siehe auch

  • SCHRIFTART NEU
  • LPRINT
  • XPRINT ANHANG
  • XPRINT-ZELLE
  • XPRINT CHR-GRÖSSE
  • XPRINT-FARBE
  • XPRINT CLOSE
  • XPRINT SCHRIFTART EINSTELLEN
  • XPRINT GET POS
  • XPRINT SET POS
  • XPRINT SET WORDWRAP
  • XPRINT SET WRAP
  • XPRINT SPLIT
  • XPRINT-TEXTGRÖSSE

PBXB64-Umsetzungshinweise

XPRINT PRINT gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT PRINT ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT PRINT mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT RENDER – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT RENDER

XPRINT RENDER

Rendern Sie ein Bild auf einem

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT RENDER BmpName$ , ( x1! , y1! )-( x2! , y2! )

Beschreibung

Rendert ein Bild (Bitmap oder Symbol), das von einer Ressource oder einer Festplattendatei geladen wird, auf einer Hostdruckerseite. Der Parameter BmpName$ enthält den Namen des zu ladenden Bildes. Wenn BmpName$ einen Punkt enthält, wird davon ausgegangen, dass es sich um den Namen einer Festplattendatei handelt. Andernfalls wird versucht, es aus den Ressourcendaten des Programms zu laden; Wenn sie nicht gefunden wird, wird davon ausgegangen, dass es sich um eine Festplattendatei handelt. Die Parameter x1!,y1! Definieren Sie die obere linke Ecke des Zielrechtecks, während x2!,y2! Definieren Sie die untere rechte Ecke dieses Rechtecks. Wenn das Zielrechteck größer oder kleiner als das Original ist, wird das Bild auf die gewünschte Größe gestreckt oder gestaucht. Wenn XPRINT RENDER nicht erfolgreich ist, wird ein entsprechender Fehler generiert.

Der folgende Code ruft die natürliche Größe eines Bildes in einer Bitmap-Datei in Pixel ab:

nFile& = FREEFILE

OPEN Sie „myimage.bmp“ FOR BINARY AS nFile&

GET #nFile&, 19, nWidth&

GET #nFile&, 23, nHeight&

SCHLIEßEN nDatei&

Siehe auch

  • XPRINT ANHANG
  • XPRINT-KOPIE
  • XPRINT STRETCH
  • XPRINT STRETCHMODUS EINSTELLEN

PBXB64-Umsetzungshinweise

XPRINT RENDER gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT RENDER ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT RENDER mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT SCALE - PBXB64-Compiler-Hilfe

Startseite › BASIC-Frontend › Schlüsselwortreferenz › Grafik & GUI › XPRINT SCALE
Hilfe zum PBXB64-Compiler

XPRINT SCALE

Die aktuellen XPRINT-Skalierungsgrenzen setzen oder zurücksetzen.

Typ: Anweisung | Kategorie: Benutzeroberfläche, Grafik und DDT

PBXB64-Status: VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT SCALE ( x1! , y1! ) - ( x2! , y2! )
XPRINT SCALE x1! , y1! , x2! , y2!
XPRINT SCALE PIXELS

Beschreibung

XPRINT SCALE speichert die aktuellen Weltkoordinaten-Grenzen fuer die aktive XPRINT-Sitzung. Die Grenzen bleiben im Sitzungszustand erhalten, bis sie geaendert oder die Druckersitzung getrennt wird.

XPRINT SCALE PIXELS setzt die gespeicherten Grenzen auf den Standardbereich 0, 0, 1, 1 zurück. XPRINT GET SCALE liest die aktuellen Werte wieder in vier Zielvariablen ein.

Praktische Verwendung

Verwenden Sie XPRINT SCALE unmittelbar nach dem Anhaengen eines Druckerkontexts und vor dem Drucken von Seiteninhalten. Halten Sie die Grenzen in denselben Einheiten wie das gewuenschte Seitenlayout und lesen Sie sie mit XPRINT GET SCALE zurueck, wenn Sie die aktuelle Zuordnung bestaetigen wollen.

Parameter und Zustand

Die vier Koordinaten definieren das aktive Drucker-Weltfenster. Die Sitzung haelt diese Grenzen, bis ein anderer Skalenbefehl sie ersetzt oder der Druckerkontext schliesst. Abfrageformen lesen diesen Zustand nur zurueck; sie verschieben weder Ausgabe noch Inhalt der Seite.

Parameter und Ergebnisse

Die vier Koordinaten definieren das aktive Weltfenster fuer den Drucker. Die Anweisung liefert keinen Rueckgabewert, sondern aendert den Sitzungszustand, den spaetere XPRINT GET SCALE-Aufrufe lesen koennen. XPRINT SCALE PIXELS ist der Ruecksetzpfad.

Fehler und Randfaelle

Verwenden Sie den Befehl nur mit angehaengtem Druckerkontext. Ist der Kontext nicht vorhanden oder bereits geschlossen, koennen spaetere Rueckgabewerte die Standardgrenzen liefern oder Zielvariablen unveraendert lassen, je nach Sitzungszustand.

Validierungsbeleg

Validierungsbeleg: tests/pb/test_xprint_get_set_scale.pb belegt die Standardwerte der Sitzung, den Rundlauf einer benutzerdefinierten Skalierung und das Zurücksetzen mit XPRINT SCALE PIXELS.

Test- und Dokumentationshinweise

Ein brauchbares Beispiel haengt zuerst einen Druckerkontext an, setzt eine benutzerdefinierte Skalierung, liest sie zurueck, setzt auf Pixel zurueck und liest erneut. Genau dieser Lebenszyklus entspricht dem Aufbau einer echten Druckseiten-Routine.

XPRINT ATTACH "scale.tmp"
XPRINT SCALE (10, 20) - (30, 40)
XPRINT GET SCALE TO x1, y1, x2, y2

Example

Das folgende Programm prueft die Skalierung, liest sie zurueck und setzt sie auf Pixelwerte zurueck. Es zeigt denselben Ablauf wie eine echte Drucklayout-Routine, nur in einer kompakten Form fuer den schnellen Nachbau.

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL x1 AS DOUBLE
    LOCAL y1 AS DOUBLE
    LOCAL x2 AS DOUBLE
    LOCAL y2 AS DOUBLE

    XPRINT ATTACH "pbxb64_xprint_scale.tmp"
    XPRINT SCALE (10.5, 20.25) - (110.75, 220.125)
    XPRINT GET SCALE TO x1, y1, x2, y2
    IF ABS(x1 - 10.5) > 0.000001 OR ABS(y1 - 20.25) > 0.000001 THEN FUNCTION = 1: GOTO done
    IF ABS(x2 - 110.75) > 0.000001 OR ABS(y2 - 220.125) > 0.000001 THEN FUNCTION = 2: GOTO done

    XPRINT SCALE PIXELS
    XPRINT GET SCALE TO x1, y1, x2, y2
    IF ABS(x1 - 0) > 0.000001 OR ABS(y1 - 0) > 0.000001 THEN FUNCTION = 3: GOTO done
    IF ABS(x2 - 1) > 0.000001 OR ABS(y2 - 1) > 0.000001 THEN FUNCTION = 4: GOTO done

done:
    XPRINT CLOSE
    KILL "pbxb64_xprint_scale.tmp"
END FUNCTION

Siehe auch

  • XPRINT GET SCALE
  • XPRINT(POS.X)
  • XPRINT(MIX)

Beschreibung

XPRINT SCALE setzt das aktive Koordinatensystem der Druckerseite fuer den angehaengten XPRINT-Kontext. Die Seite dokumentiert die exakten numerischen Grenzen, die PBXB64 akzeptiert, den geaenderten Laufzeitzustand und den Rueckweg zu Pixelkoordinaten.

Praktische Verwendung

Verwenden Sie XPRINT SCALE nach XPRINT ATTACH und vor den Zeichen- oder Textbefehlen, die benutzerdefinierte Weltkoordinaten verwenden sollen. Der angehaengte Druckerkontext behaelt die Skalierung, bis sie erneut gesetzt, mit XPRINT SCALE PIXELS zurueckgesetzt oder geschlossen wird.

Parameter und Zustand

Die Koordinatenpaare beschreiben die linke untere und rechte obere Ecke der aktuellen Weltansicht. Die fokussierte Validierung zeigt, dass der Standardzustand Pixel ist, benutzerdefinierte Gleitkomma-Koordinaten erhalten bleiben und XPRINT SCALE PIXELS das Standard-Mapping 0..1 wiederherstellt.

Fehler und Randfaelle

Die getestete Oberflaeche lehnt einen fehlenden angehaengten Drucker und gleiche Koordinatenpaare ab. Halten Sie alle vier Werte im Beispiel explizit und lesen Sie die Skalierung mit XPRINT GET SCALE zurueck, wenn das Programm vom aktuellen Druckerzustand abhaengt.

Validierungsbeleg

Validation evidence: tests/pb/test_xprint_get_set_scale.pb prueft die Standardskalierung, eine benutzerdefinierte Skalierung (10.5, 20.25)-(110.75, 220.125) und den Rueckweg zu Pixeln nach XPRINT SCALE PIXELS.

Test- und Dokumentationshinweise

Das Beispiel ist bewusst selbstaufräumend: Es haengt ein temporaeres Druckziel an, prueft die Skalierungs-Rueckgabe, schliesst den Druckerkontext und entfernt die temporaere Datei.

Example

Beispiel

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    LOCAL x1 AS DOUBLE
    LOCAL y1 AS DOUBLE
    LOCAL x2 AS DOUBLE
    LOCAL y2 AS DOUBLE

    XPRINT ATTACH "pbxb64_xprint_scale.tmp"
    XPRINT GET SCALE TO x1, y1, x2, y2
    XPRINT SCALE (10.5, 20.25) - (110.75, 220.125)
    XPRINT GET SCALE TO x1, y1, x2, y2
    XPRINT SCALE PIXELS
    XPRINT CLOSE
    KILL "pbxb64_xprint_scale.tmp"
END FUNCTION

Siehe auch

  • XPRINT ATTACH
  • XPRINT GET SCALE


XPRINT SET CLIP – PBXB64 Compiler-Hilfe

Startseite › Funktionen › XPRINT SET CLIP

XPRINT SET CLIP

Legt Ränder um die Außenkanten der Druckseite fest.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT SET CLIP LeftMargin! , TopMargin! , RightMargin! , BottomMargin!

Beschreibung

Diese Anweisung legt Ränder auf einer oder allen Seiten des ausgewählten Druckers fest. Alle nachfolgenden XPRINT-Operationen werden an diesen Grenzen „beschnitten“, sodass kein zusätzlicher Text oder Grafiken in diese geschützten Bereiche geschrieben werden.

Jeder der 4 Parameter wird in den aktuell gültigen PAGE UNITS angegeben. Da sich dadurch jedoch der für Sie verfügbare Zielraum ändert, werden die Seiteneinheiten sofort auf Pixel/Punkte gesetzt. Die obere linke Ecke des Clip-Bereichs wird nun als Punkt (0,0) angesprochen, während die rechte und untere Grenze um die Größe der Ränder reduziert werden. Wenn Sie für diesen überarbeiteten Clipbereich lieber neue skalierte Seiteneinheiten verwenden möchten, müssen Sie ein neues XPRINT SCALE ausführen.

XPRINT SET CLIP ist besonders nützlich für die Anzeige von Text, wo das Einschließen von „Leerzeichen“ das Erscheinungsbild erheblich verbessert.

Sie können einen Clip-Bereich deaktivieren, indem Sie XPRINT SET CLIP 0,0,0,0 ausführen.

Siehe auch

  • XPRINT ERHALTEN LEINWAND
  • XPRINT CLIENT ERHALTEN
  • XPRINT GET SCALE
  • XPRINT-SKALA

PBXB64-Umsetzungshinweise

XPRINT SET CLIP gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT SET CLIP ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT SET CLIP mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT SET COLLATE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT SET COLLATE

XPRINT SET SORTIEREN

Ändern Sie den Sortierstatus von XPRINT.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT SET COLLATE numrexp

Beschreibung

Mit XPRINT können Sie den Sortierstatus festlegen, wenn der Druckertreiber sowohl Mehrfachkopien als auch die Sortierfunktion unterstützt. XPRINT SET COLLATE aktiviert oder deaktiviert das Sortieren, abhängig vom Wert von numrexp (1=wahr, 0=falsch). Um den möglichen Status symbolisch darzustellen, sind im Compiler folgende Equates vordefiniert:

%DMCOLLATE_FALSE = 0

%DMCOLLATE_TRUE = 1

Wenn der Drucker das Sortieren nicht unterstützt oder andere Werte verwendet werden, wird Fehler 5 generiert. Wenn diese Anweisung ohne angeschlossenen Hostdrucker ausgeführt wird, wird Fehler 57 generiert.

Siehe auch

  • XPRINT ANHANG
  • XPRINT GET COLLATE

PBXB64-Umsetzungshinweise

XPRINT SET SORTIEREN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT SET SORTIEREN ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT SET SORTIEREN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT SET COLORMODE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT SET COLORMODE

XPRINT SET COLORMODE

Ändert den XPRINT-Farbmodusstatus.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT SET COLORMODE numrexp

Beschreibung

Mit XPRINT können Sie den Farb- oder Monochrom-Druckmodus einstellen, sofern der Druckertreiber dies unterstützt. XPRINT SET COLORMODE erwartet einen numerischen Ausdruck, der einen der folgenden aufgelisteten Werte ergibt. Um den möglichen Status symbolisch darzustellen, sind im Compiler folgende Equates vordefiniert:

%DMCOLOR_MONOCHROME = 1

%DMCOLOR_COLOR = 2

Wenn diese Anweisung ohne angeschlossenen Hostdrucker ausgeführt wird, wird Fehler 57 generiert.

Siehe auch

  • XPRINT ANHANG
  • XPRINT GET COLORMODE

PBXB64-Umsetzungshinweise

XPRINT SET COLORMODE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT SET COLORMODE ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT SET COLORMODE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT SET COPIES – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT SET COPIES

XPRINT SET-KOPIEN

Ändern Sie die Anzahl der XPRINT-Kopien.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT SET COPIES numrexp

Beschreibung

Mit XPRINT SET COPIES können Sie die Anzahl der automatisch zu druckenden Kopien festlegen, sofern dies vom Druckertreiber unterstützt wird. Der Standardwert ist eins (1). Wenn mehrere Kopien vom Druckertreiber nicht unterstützt werden oder die angeforderte Anzahl größer ist als die vom Druckertreiber unterstützte Anzahl, wird Fehler 5 generiert. Wenn diese Anweisung ohne angeschlossenen Hostdrucker ausgeführt wird, wird Fehler 57 generiert.

Siehe auch

  • XPRINT ANHANG
  • XPRINT KOPIEN ERHALTEN

PBXB64-Umsetzungshinweise

XPRINT SET-KOPIEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT SET-KOPIEN ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT SET-KOPIEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT SET DUPLEX - PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT SET DUPLEX

XPRINT SET DUPLEX

Ändern Sie den XPRINT-Duplex-Status.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT SET DUPLEX numrexp

Beschreibung

Mit XPRINT können Sie den Duplexstatus festlegen, wenn der Drucker das Drucken auf beiden Seiten einer Seite unterstützt. XPRINT SET DUPLEX ändert den Modus in den durch numrexp angegebenen Modus. Um den möglichen Duplexstatus symbolisch darzustellen, sind im Compiler folgende Equates vordefiniert:

%DMDUP_SIMPLEX = 1 (einseitiger Druck)

%DMDUP_VERTICAL = 2 (Seite am vertikalen Rand umgedreht)

%DMDUP_HORIZONTAL = 3 (Seite am horizontalen Rand umgedreht)

Wenn der Drucker keinen Duplexdruck unterstützt, wird Fehler 5 generiert. Wenn diese Anweisung ohne angeschlossenen Hostdrucker ausgeführt wird, wird Fehler 57 generiert.

Siehe auch

  • XPRINT ANHANG
  • XPRINT ERHALTEN DUPLEX

PBXB64-Umsetzungshinweise

XPRINT SET DUPLEX gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT SET DUPLEX ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT SET DUPLEX mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT SET FONT – PBXB64 Compiler-Hilfe

Startseite › Funktionen › XPRINT SET FONT

XPRINT SCHRIFTART EINSTELLEN

Wählen Sie a aus

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT SET FONT FontHndl&

Beschreibung

Die durch FontHndl& angegebene Schriftart wird für die Verwendung durch XPRINT-Anweisungen ausgewählt. Dies ist die effizienteste Möglichkeit, Schriftarten und deren allgemeines Erscheinungsbild (Größe, Stil usw.) zu ändern. Wenn Sie für FontHndl& den Wert Null angeben, wird die Schriftart wieder auf die ursprünglich von PowerBASIC ausgewählte Standardschriftart geändert.

Sie können nahezu beliebig viele Schriftarten und Attribute vordefinieren, indem Sie für jede Schriftart FONT NEW-Anweisungen ausführen. Dadurch sind sie sofort einsatzbereit, wenn sie mit XPRINT SET FONT ausgewählt werden.

Vor allen XPRINT-Vorgängen muss zunächst mit XPRINT ATTACH ein bestimmter Drucker ausgewählt werden. Wenn keine bestimmte Schriftart ausgewählt ist, ist die Standardschriftart Courier New ohne Stilattribute.

Siehe auch

  • SCHRIFTART NEU
  • XPRINT
  • XPRINT ANHANG
  • XPRINT CHR-GRÖSSE
  • XPRINT-TEXTGRÖSSE

PBXB64-Umsetzungshinweise

XPRINT SCHRIFTART EINSTELLEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT SCHRIFTART EINSTELLEN ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT SCHRIFTART EINSTELLEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT SET MIX - PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT SET MIX

XPRINT SET MIX

Setzen Sie den verwalteten Kompatibilitäts-Mischmodus des aktuellen XPRINT-Streams.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT SET MIX mode&

Beschreibung

Im fokussierten V14-Slice speichert XPRINT SET MIX den gewählten Kompatibilitäts-Mischmodus im aktiven XPRINT-Zustand, damit spätere GET-Formen und XPRINT(MIX) denselben Wert melden. XPRINT ATTACH setzt den Modus für einen frischen Stream auf 13 zurück; der dateibasierte Ausgabepfad bleibt davon unberührt.

%MIX_BLACKNESS

Pixel ist immer 0 (schwarz).

%MIX_NOTMERGESRC

Pixel ist die Umkehrung der MergeSrc-Farbe.

%MIX_MASKNOTSRC

Pixel ist eine Kombination der Farben, die sowohl dem Pixel als auch der Umkehrung der Quelle gemeinsam sind.

%MIX_NOTCOPYSRC

Pixel ist die Umkehrung der Stiftfarbe.

%MIX_MASKSRCNOT

Pixel ist eine Kombination der Farben, die sowohl der Quelle als auch der Umkehrung des Pixels gemeinsam sind.

%MIX_NOT

Pixel ist die Umkehrung der Pixelfarbe.

%MIX_XORSRC

Pixel ist eine Kombination der Farben in der Quelle und im Pixel, jedoch nicht in beiden.

%MIX_NOTMASKSRC

Pixel ist die Umkehrung der MaskSrc-Farbe.

%MIX_MASKSRC

Pixel ist eine Kombination der Farben, die sowohl der Quelle als auch dem Pixel gemeinsam sind.

%MIX_NOTXORSRC

Pixel ist die Umkehrung der XorSrc-Farbe.

%MIX_NOP

Pixel bleibt unverändert.

%MIX_MERGENOTSRC

Pixel ist eine Kombination aus der Quellfarbe und der Umkehrung der Pixelfarbe.

%MIX_COPYSRC

Pixel ist die Quellfarbe (Standard).

%MIX_MERGESRCNOT

Pixel ist eine Kombination aus der Quellfarbe und der Umkehrung der Pixelfarbe.

%MIX_MERGESRC

Pixel ist eine Kombination aus der Quellfarbe und der Pixelfarbe.

%MIX_WHITENESS

Pixel ist immer 1 (weiß).

Siehe auch

  • XPRINT ANHANG
  • XPRINT GET MIX

PBXB64-Umsetzungshinweise

XPRINT SET MIX gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT SET MIX ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT SET MIX mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT-SET-AUSRICHTUNG – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT SET ORIENTATION

XPRINT-SET-AUSRICHTUNG

Legen Sie die Papierausrichtung für a fest

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT SET ORIENTATION orent&

Beschreibung

XPRINT SET ORIENTATION legt die Ausrichtung des Papiers im Hostdrucker fest. Der Wert 1 gibt den Hochformatmodus an, während 2 den Querformatmodus angibt. Wenn kein Hostdrucker angeschlossen ist oder die Einstellung der Ausrichtung nicht unterstützt, wird Fehler 57 generiert.

Siehe auch

  • SCHRIFTART NEU
  • XPRINT ANHANG
  • XPRINT ERHALTEN SIE ORIENTIERUNG
  • XPRINT SCHRIFTART EINSTELLEN

XPRINT-Prüfung

XPRINT-Seiten sollen Druckerauswahl, Lebensdauer des Device Context, Seitenzustand, Koordinateneinheiten und die Frage nennen, ob der Befehl Vorschau, Rendering oder Druckerausgabe betrifft. Beispiele sollen sicher sein, wenn kein Standarddrucker installiert ist.

Fehlerfälle

Dokumentieren Sie abgebrochene Druckdialoge, nicht verfügbare Drucker, ungültige DC-Handles und nicht unterstützte Gerätefähigkeiten.

Cleanup

Schließen oder brechen Sie Druckjobs ausdrücklich ab und geben Sie angehängte Ressourcen vor Programmende frei.

PBXB64-Umsetzungshinweise

XPRINT-SET-AUSRICHTUNG gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT-SET-AUSRICHTUNG ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT-SET-AUSRICHTUNG mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT SET OVERLAP – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT SET OVERLAP

XPRINT-SET-ÜBERLAPPUNG

Aktiviert oder deaktiviert den XPRINT-Überlappungsmodus.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT SET OVERLAP [ NumrExpr& ]

Beschreibung

XPRINT SET OVERLAP aktiviert oder deaktiviert den Überlappungsmodus für den Hostdrucker, der aktuell an den XPRINT-Stream angeschlossen ist. Es hat keine Auswirkungen auf andere XPRINT-Ziele. Wenn NumrExpr& wahr ist (ungleich Null), ist der Überlappungsmodus aktiviert. Bei „false“ (Null) ist der Überlappungsmodus deaktiviert. Wenn NumrExpr& fehlt, ist der Überlappungsmodus standardmäßig aktiviert.

Mit dem Überlappungsmodus können Sie steuern, wie PowerBASIC XPRINT-Vorgänge behandelt, deren Definition ein umgrenzendes Rechteck (RECT-Struktur) enthält. Windows behält einzigartige Konventionen für ein RECT bei. Die unteren und rechten Koordinaten eines RECT sind exklusiv. Mit anderen Worten: Die Pixel am unteren und rechten Rand liegen unmittelbar außerhalb des Rechtecks. Sie werden ignoriert. Zum Beispiel:

XPRINT-BOX (0,0) - (50,50)

In diesem Fall wird ein Kästchen von 0,0 bis 49,49 gezeichnet. Die letzten Pixel am unteren und rechten Rand werden einfach nicht gezeichnet. Wenn jedoch der Überlappungsmodus aktiviert ist, wird das Feld von 0,0 bis 50,50 gezeichnet.

Der Überlappungsmodus betrifft alle XPRINT-Funktionen, die ein umschließendes Rechteck als Parameter verwenden. Dazu gehören XPRINT SCALE, XPRINT BOX, XPRINT ELLIPSE, XPRINT LINE, XPRINT POLYLINE usw.

Siehe auch

  • XPRINT-BOX
  • XPRINT ELLIPSE
  • XPRINT ERHALTE ÜBERLAPPUNG
  • XPRINT-LINIE
  • XPRINT POLYLINE
  • XPRINT-SKALA

PBXB64-Umsetzungshinweise

XPRINT-SET-ÜBERLAPPUNG gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT-SET-ÜBERLAPPUNG ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT-SET-ÜBERLAPPUNG mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT SET PAGES – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT SET PAGES

XPRINT SET SEITEN

Legt hierfür die XPRINT-Seitenzahlgrenzen fest

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT SET PAGES FromPage& , ToPage&

Beschreibung

XPRINT SET PAGES aktualisiert den fokussierten Kompatibilitaets-Seitenbereich der aktuellen XPRINT-Sitzung. Der vereinfachte PBXB64-Vertrag speichert die erste und die letzte Seite und macht sie ueber XPRINT GET PAGES und die zugehoerige Regression sichtbar.

Das erste Argument ist die erste Seite des aktiven Bereichs, das zweite Argument ist die letzte Seite. Die Werte werden fuer die aktuelle Sitzung deterministisch gespeichert.

Nach XPRINT ATTACH ist der fokussierte Kompatibilitaetszustand sofort verfuegbar. Die registrierte Regression prueft Aktualisierung und Ruecklesen.

Siehe auch

  • XPRINT ANHANG
  • XPRINT SEITEN ERHALTEN
  • XPRINT SET-KOPIEN

PBXB64-Umsetzungshinweise

XPRINT SET SEITEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT SET SEITEN ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT SET SEITEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT SET PAPER - PBXB64 Compiler-Hilfe

Startseite › Funktionen › XPRINT SET PAPER

XPRINT SET PAPIER

Legt ein neues fest

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT SET PAPER papertype&

Beschreibung

XPRINT SET PAPER ändert den Papierstil für den Host-Drucker auf den durch papertype& festgelegten. Der Papierstil wird durch einen ganzzahligen Wert identifiziert, der im Ausdruck papertype& angegeben ist. Die folgenden Equates sind im Compiler vordefiniert und repräsentieren die gängigsten Papierstile:

%DMPAPER_LETTER = 1 Buchstabe 8,5 x 11 Zoll

%DMPAPER_TABLOID = 3 Tabloid 11 x 17 Zoll

%DMPAPER_LEDGER = 4 Ledger 17 x 11 Zoll

%DMPAPER_LEGAL = 5 Legal 8,5 x 14 Zoll

%DMPAPER_STATEMENT = 6 Statement 5,5 x 8,5 Zoll

%DMPAPER_EXECUTIVE = 7 Executive 7,25 x 10,5 Zoll

%DMPAPER_A3 = 8 A3 297 x 420 mm

%DMPAPER_A4 = 9 A4 210 x 297 mm

%DMPAPER_A5 = 11 A5 148 x 210 mm

%DMPAPER_B4 = 12 B4 250 x 354 mm

%DMPAPER_B5 = 13 B5 182 x 257 mm

%DMPAPER_FOLIO = 14 Folio 8,5 x 13 Zoll

%DMPAPER_QUARTO = 15 Viertel 215 x 275 mm

%DMPAPER_10X14 = 16 10x14 10 x 14 Zoll

%DMPAPER_11X17 = 17 11x17 11 x 17 Zoll

%DMPAPER_NOTE = 18 Notiz 8,5 x 11 Zoll

%DMPAPER_ENV_9 = 19 9 Umschlag 3,875 x 8,875 Zoll

%DMPAPER_ENV_10 = 20 10 Umschlag 4,125 x 9,5 Zoll

Andere Papierstilcodes können von Windows oder Druckerlieferanten definiert werden. Mit XPRINT GET PAPERS erhalten Sie eine Liste aller vom angeschlossenen Host-Drucker unterstützten Papierstile.

Wenn der Drucker den angegebenen Papierstil nicht unterstützt, wird Fehler 5 generiert. Bei Ausführung ohne angeschlossenen Hostdrucker wird Fehler 57 generiert.

Siehe auch

  • XPRINT ANHANG
  • XPRINT PAPIER ERHALTEN
  • XPRINT PAPIERE ERHALTEN

PBXB64-Umsetzungshinweise

XPRINT SET PAPIER gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT SET PAPIER ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT SET PAPIER mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT SET PIXEL – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT SET PIXEL

XPRINT SET PIXEL

Stellen Sie die ein

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT SET PIXEL [STEP] ( x! , y! ) [, rgbColor& ]

Beschreibung

XPRINT SET PIXEL zeichnet ein einzelnes Pixel auf der Host-Druckerseite. Der optionale Farbparameter ist ein RGB-Wert; Wenn sie nicht enthalten ist, wird als Farbe standardmäßig die aktuelle Vordergrundfarbe für den Hostdrucker verwendet. Wenn die STEP-Option enthalten ist, wird das x! und du! Die Koordinaten beziehen sich auf den letzten referenzierten Punkt (POS). Die Koordinatenpunkte werden in Pixel angegeben, es sei denn, Weltkoordinaten wurden mit einer XPRINT SCALE-Anweisung festgelegt. Wenn kein Hostdrucker angeschlossen ist, wird Fehler 57 generiert.

Siehe auch

  • Built In RGB Color Equates
  • XPRINT ANHANG
  • XPRINT-FARBE
  • XPRINT PIXEL ERHALTEN

PBXB64-Umsetzungshinweise

XPRINT SET PIXEL gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT SET PIXEL ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT SET PIXEL mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT SET POS - PBXB64 Compiler-Hilfe

Startseite › Funktionen › XPRINT SET POS

XPRINT SET POS

Legen Sie den letzten von einem XPRINT referenzierten Punkt (POS) fest

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT SET POS [STEP] ( x! , y! )

Beschreibung

Mit XPRINT SET POS wird die von diesem fokussierten Slice verwaltete Positionskoordinate gesetzt. Wenn die STEP-Option enthalten ist, werden die x! und y!-Werte zum vorherigen Zustand addiert. Die Werte werden als deterministischer Zustand gespeichert und nicht an einen Live-Druckertreiber gesendet.

Validierung: tests/pb/test_xprint_get_set_pos.pb prueft sowohl absolute als auch STEP-basierte Aktualisierungen.

Siehe auch

  • XPRINT ANHANG
  • XPRINT GET POS

PBXB64-Umsetzungshinweise

XPRINT SET POS gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT SET POS ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT SET POS mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT SET-QUALITÄT – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT SETQUALITÄT

XPRINT-SET-QUALITÄT

Stellen Sie die Druckqualität für a ein

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT SET QUALITY qual&

Beschreibung

XPRINT SETQUALITÄT legt die Druckqualitätseinstellung für den Hostdrucker fest. Der Wert 1 ist der Entwurfsmodus, 2 ist eine niedrige Auflösung, 3 ist eine mittlere Auflösung und 4 ist eine hohe Auflösung. Es ist zu beachten, dass bei einigen Druckern höhere Auflösungen nur über den Druckerdialog (in XPRINT ATTACH CHOOSE ) einstellbar sind. Wenn kein Hostdrucker angeschlossen ist oder der Drucker die Druckqualitätseinstellungen nicht unterstützt, wird Fehler 57 generiert.

Siehe auch

  • XPRINT ANHANG
  • XPRINT ERHALTEN QUALITÄT

PBXB64-Umsetzungshinweise

XPRINT-SET-QUALITÄT gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT-SET-QUALITÄT ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT-SET-QUALITÄT mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT SET STRETCHMODE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT SET STRETCHMODE

XPRINT STRETCHMODUS EINSTELLEN

Legt den Standard-Bitmap-Streckmodus für die aktuelle fest

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT SET STRETCHMODE ModeExpr

Beschreibung

In PowerBASIC gibt es mehrere Vorgänge, die das Strecken oder Komprimieren von Bildern auf Bitmaps umfassen, insbesondere XPRINT STRETCH . Da einzelne Pixel hinzugefügt oder entfernt werden müssen, besteht eine gute Chance, dass sich die Bildqualität verschlechtert. Wenn Sie jedoch die Art des Bildes durch die Definition eines StretchMode beschreiben, können Sie das Erscheinungsbild erheblich verbessern.

Der Standard-StretchMode wird für jeden DC individuell verwaltet. Sie können den Standardmodus mit dieser Anweisung festlegen oder ihn mit XPRINT GET STRETCHMODE abrufen. Natürlich können Sie den Standard-StretchMode auch überschreiben, wenn Sie eine der betroffenen Anweisungen ausführen.

Die 4 Stretch-Modus-Equates sind in PowerBASIC vordefiniert.

%BLACKONWHITE

Dies ist der standardmäßige Streckungsmodus von Windows und eignet sich am besten für monochrome Bitmaps oder solche mit Farbblöcken. Führt ein boolesches ODER von eliminierten und vorhandenen Pixeln durch. Schwarze Pixel bleiben auf Kosten weißer Pixel erhalten.

%WHITEONBLACK

Führt ein boolesches ODER von eliminierten und vorhandenen Pixeln durch. Es behält weiße Pixel auf Kosten schwarzer Pixel bei.

%COLORONCOLOR

Löscht gelöschte Pixelzeilen, ohne zu versuchen, ihre Informationen beizubehalten.

%HALBTON

Dies bietet höchste Qualität für komplexe Farbbitmaps. Die durchschnittliche Farbe des Zielpixelblocks bleibt ungefähr die gleiche wie die des Quellpixelblocks.

Siehe auch

  • XPRINT-KOPIE
  • XPRINT GET STRETCHMODE
  • XPRINT RENDER
  • XPRINT STRETCH

PBXB64-Umsetzungshinweise

XPRINT STRETCHMODUS EINSTELLEN gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT STRETCHMODUS EINSTELLEN ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT STRETCHMODUS EINSTELLEN mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT SET TRAY - PBXB64 Compiler-Hilfe

Startseite › Funktionen › XPRINT SET TRAY

XPRINT-SET-FACH

Setzt den fokussierten Tray-Status der Kompatibilitaet.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT SET TRAY numrexp

Beschreibung

XPRINT SET TRAY ändert den aktuellen Tray-Code, der von diesem fokussierten XPRINT-Teil verwaltet wird, auf den durch numrexp angegebenen. Die folgenden Equates sind im Compiler vordefiniert und stellen die gebräuchlichsten Papierfächer dar:

%DMBIN_UPPER = 1

%DMBIN_LOWER = 2

%DMBIN_MIDDLE = 3

%DMBIN_MANUAL = 4

%DMBIN_ENVELOPE = 5

%DMBIN_ENVMANUAL = 6

%DMBIN_AUTO = 7

%DMBIN_TRACTOR = 8

%DMBIN_SMALLFMT = 9

%DMBIN_LARGEFMT = 10

%DMBIN_LARGECAPACITY = 11

%DMBIN_CASSETTE = 14

%DMBIN_FORMSOURCE = 15

Der Tray-Code wird vom aktuellen fokussierten Teil verwaltet und fragt kein Live-Druckgeraet ab. Mit XPRINT GET TRAYS erhalten Sie die deterministische Tray-Liste, die diese Kompatibilitaetsschicht verwendet.

Nicht unterstuetzte Tray-Codes werden mit einer gezielten Diagnose abgelehnt.

Siehe auch

  • XPRINT ANHANG
  • XPRINT GET TRAY
  • XPRINT GET TABLETS

PBXB64-Umsetzungshinweise

XPRINT-SET-FACH gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT-SET-FACH ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT-SET-FACH mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT SET WORDWRAP – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT SET WORDWRAP

XPRINT SET WORDWRAP

Aktiviert oder deaktiviert den XPRINT WordWrap-Modus.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT SET WORDWRAP [ NumrExpr& ]

Beschreibung

XPRINT SET WORDWRAP aktiviert oder deaktiviert den WordWrap-Modus für den Hostdrucker, der derzeit an den XPRINT-Stream angeschlossen ist. Es hat keine Auswirkungen auf andere Drucker. Wenn NumrExpr& wahr ist (ungleich Null), ist der WordWrap-Modus aktiviert. Bei „false“ (null) ist der WordWrap-Modus deaktiviert. Wenn NumrExpr& fehlt, ist der WordWrap-Modus standardmäßig aktiviert.

Mit dem WordWrap-Modus können Sie steuern, wie PowerBASIC Text auf einer XPRINT-Seite druckt, wenn dieser das Ende einer Zeile erreicht. Da ein Hostdrucker ganzseitig arbeitet, wird standardmäßig Text ignoriert, der über das Zeilenende hinaus gedruckt wird.

Wenn der WordWrap-Modus aktiviert ist, betrifft er nur XPRINT PRINT-Vorgänge. Wenn XPRINT PRINT versucht, ein Wort über das Ende einer Zeile hinaus anzuzeigen, wird das gesamte Wort automatisch in die erste Spalte der nächsten Zeile umgebrochen.

Siehe auch

  • XPRINT-ZELLE
  • XPRINT WORDWRAP ERHALTEN
  • XPRINT PRINT
  • XPRINT SET WRAP
  • XPRINT SPLIT

PBXB64-Umsetzungshinweise

XPRINT SET WORDWRAP gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT SET WORDWRAP ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT SET WORDWRAP mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT SET WRAP – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT SET WRAP

XPRINT SET WRAP

Aktiviert oder deaktiviert den XPrint-Wrap-Modus.

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT SET WRAP [ NumrExpr& ]

Beschreibung

XPRINT SET WRAP aktiviert oder deaktiviert den Wrap-Modus für den Hostdrucker, der derzeit an den XPrint-Stream angeschlossen ist. Es hat keine Auswirkungen auf andere Drucker. Wenn NumrExpr& wahr ist (ungleich Null), ist der Wrap-Modus aktiviert. Bei „false“ (Null) ist der Wrap-Modus deaktiviert. Wenn NumrExpr& fehlt, ist der Wrap-Modus standardmäßig aktiviert.

Mit dem Wrap-Modus können Sie steuern, wie PowerBASIC Text auf einer XPRINT-SEITE druckt, wenn dieser das Ende einer Zeile erreicht. Da ein Hostdrucker ganzseitig arbeitet, wird standardmäßig Text ignoriert, der über das Zeilenende hinaus gedruckt wird.

Wenn der Wrap-Modus aktiviert ist, wirkt er sich nur auf XPRINT PRINT-Vorgänge aus. Wenn XPRINT PRINT versucht, ein Zeichen über das Ende einer Zeile hinaus anzuzeigen, wird es automatisch in die erste Spalte der nächsten Zeile umgebrochen.

Siehe auch

  • XPRINT-ZELLE
  • XPRINT GET WRAP
  • XPRINT PRINT
  • XPRINT SET WORDWRAP
  • XPRINT SPLIT

PBXB64-Umsetzungshinweise

XPRINT SET WRAP gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT SET WRAP ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT SET WRAP mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT SPLIT - PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT SPLIT

XPRINT SPLIT

Teilt eine Zeichenfolge

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT SPLIT [WORD] MainStr , Part1Len TO Part1Var , Part2Var

Beschreibung

Generell können Sie mit XPRINT SPLIT bestimmen, wie viel Text in eine Zeile (oder einen Zeilenabschnitt) passt, um das Ende nicht zu überschreiten. Dies ist bei Schriftarten mit variabler Breite von entscheidender Bedeutung. Da diese Textzeichen unterschiedlich breit sind, können Sie sich nicht auf eine einfache Zeichenzählung verlassen.

XPRINT SPLIT trennt den MainStr-String-Ausdruck in zwei Teile, die dann den beiden durch Part1Var und Part2Var angegebenen String-Variablen zugewiesen werden. Der numerische Ausdruck Part1Len gibt die maximale Breite des Druckfelds unter Verwendung von Seiteneinheiten (Pixel/Punkt, skalierte Einheiten) an. Nach Abschluss von XPRINT SPLIT enthält die Part1Var diejenigen Zeichen, die sicher im Druckfeld gedruckt werden können. Die Part2Var enthält die restlichen Zeichen, die möglicherweise in den folgenden Zeilen gedruckt werden.

Da dieser Vorgang einen „Zeilenumbruch“ erzeugt, der im Originaltext nicht vorgesehen ist, müssen Sie möglicherweise die Ergebnisse ändern, um das beste Erscheinungsbild zu erzielen. Beispielsweise ist es normalerweise am besten, alle führenden Leerzeichen aus Part2Var zu entfernen, bevor es gedruckt wird.

Wenn die WORD-Option enthalten ist, garantiert PowerBASIC, dass Teil1 nicht mit einem Teilwort endet. Dies erfordert möglicherweise, dass Part1Len auf einen kleineren Wert angepasst wird. In diesem Fall würden Part2Var diese Zeichen zum Ausgleich zugewiesen.

Siehe auch

  • XPRINT-ZELLE
  • XPRINT SCHRIFTART EINSTELLEN
  • XPRINT SET WORDWRAP
  • XPRINT SET WRAP

PBXB64-Umsetzungshinweise

XPRINT SPLIT gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT SPLIT ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT SPLIT mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT STRETCH - PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT STRETCH

XPRINT STRETCH

Kopieren Sie eine Bitmap und ändern Sie ihre Größe

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT STRETCH hBmp , ID , ( x1 , y1 )-( x2 , y2 ) TO ( x3 , y3 )-( x4 , y4 ) [, Mix , Stretch ]
XPRINT STRETCH PAGE hBmp , ID [, Mix , Stretch ]

Beschreibung

Sie können eine vollständige Bitmap oder einen Teil davon auf die XPRINT-Seite kopieren und dabei die Größe vergrößern oder verkleinern. Die Handle-Variable hBmp gibt das Handle der Quellbitmap oder des Quellfensters an. Die Parameter-ID ist die mit CONTROL ADD GRAPHIC zugewiesene Steuerungskennung (1 bis 65535). Die ID muss für ein GRAPHIC WINDOW oder ein bitmsp null (0) sein. Das Ziel der Stretch-Operation ist immer die angehängte XPRINT-Seite. Die Größe der Bitmap wird automatisch an die Zielparameter angepasst. Sie müssen darauf achten, dass Ihre Parameter für die angegebenen Bitmaps gültig sind, sonst ist das Ergebnis der Operation undefiniert.

Die zweite Form, XPRINT STRETCH PAGE, ist eine Verknüpfung zum Kopieren einer vollständigen Bitmap in den Clip- oder Client-Bereich der Host-Druckerseite. Das Bild wird automatisch gestreckt oder gestaucht, um es an das Ziel anzupassen.

Wenn der Parameter „Mix“ enthalten ist, handelt es sich um einen der Werte in der folgenden Tabelle. Wenn nicht angegeben, wird ein Standardwert von %MIX_COPYSRC angenommen. Es stehen 16 Mischmodi zur Verfügung, mit denen Sie Zeichenfarben mit den Farben mischen können, die am Zeichenort bereits vorhanden sind. Die Mix-Modus-Equates sind in PowerBASIC vordefiniert.

%mix_Blackness

Pixel ist immer 0 (schwarz).

%mix_NotMergeSrc

Pixel ist die Umkehrung der MergeSrc-Farbe.

%mix_MaskNotSrc

Pixel ist eine Kombination der Farben, die sowohl dem Pixel als auch der Umkehrung der Quelle gemeinsam sind.

%mix_NotCopySrc

Pixel ist die Umkehrung der Stiftfarbe.

%mix_MaskSrcNot

Pixel ist eine Kombination der Farben, die sowohl der Quelle als auch der Umkehrung des Pixels gemeinsam sind.

%mix_Not

Pixel ist die Umkehrung der Pixelfarbe.

%mix_XorSrc

Pixel ist eine Kombination der Farben in der Quelle und im Pixel, jedoch nicht in beiden.

%mix_NotMaskSrc

Pixel ist die Umkehrung der MaskSrc-Farbe.

%mix_MaskSrc

Pixel ist eine Kombination der Farben, die sowohl der Quelle als auch dem Pixel gemeinsam sind.

%mix_NotXorSrc

Pixel ist die Umkehrung der XorSrc-Farbe.

%mix_Nop

Pixel bleibt unverändert.

%mix_MergeNotSrc

Pixel ist eine Kombination aus der Quellfarbe und der Umkehrung der Pixelfarbe.

%mix_CopySrc

Pixel ist die Quellfarbe (Standard).

%mix_MergeSrcNot

Pixel ist eine Kombination aus der Quellfarbe und der Umkehrung der Pixelfarbe.

%mix_MergeSrc

Pixel ist eine Kombination aus der Quellfarbe und der Pixelfarbe.

%mix_Whiteness

Pixel ist immer 1 (weiß).

Dehnen

Wenn der Stretch-Parameter enthalten ist, handelt es sich um einen der Werte in der folgenden Tabelle. Wenn nicht enthalten oder der Wert Null (0) ist, bleibt der Streckungsmodus unverändert. Eine geeignete Auswahl des Streckungsmodus kann die Qualität von Bitmaps, deren Größe geändert wird, erheblich verbessern. Die Streckmodus-Equates sind in PowerBASIC vordefiniert.

%BLACKONWHITE

Dies ist der standardmäßige Streckungsmodus von Windows und eignet sich am besten für monochrome Bitmaps oder solche mit Farbblöcken. Führt ein boolesches ODER von eliminierten und vorhandenen Pixeln durch. Schwarze Pixel bleiben auf Kosten weißer Pixel erhalten.

%WHITEONBLACK

Führt ein boolesches ODER von eliminierten und vorhandenen Pixeln durch. Es behält weiße Pixel auf Kosten schwarzer Pixel bei.

%COLORONCOLOR

Löscht gelöschte Pixelzeilen, ohne zu versuchen, ihre Informationen beizubehalten.

%HALBTON

Dies bietet höchste Qualität für komplexe Farbbitmaps. Die durchschnittliche Farbe des Zielpixelblocks bleibt ungefähr die gleiche wie die des Quellpixelblocks.

Siehe auch

  • XPRINT-KOPIE
  • XPRINT RENDER
  • XPRINT SET MIX
  • XPRINT STRETCHMODUS EINSTELLEN

PBXB64-Umsetzungshinweise

XPRINT STRETCH gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT STRETCH ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT STRETCH mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT STYLE - PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT STYLE

XPRINT-STIL

Legen Sie den Linienstil fest, der von verschiedenen XPRINT verwendet werden soll

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT STYLE linestyle&

Beschreibung

XPRINT STYLE bestimmt den Linienstil, der beim Zeichnen verschiedener grafischer Objekte verwendet wird, während der Breitenwert auf 1 gesetzt ist. Wenn der Breitenwert größer als eins ist, interpretiert Windows den Stil immer als 0 (durchgezogen).

Verfügbare Linienstile sind:

Fest (Standard)

DashDot

DashDotDot

Siehe auch

  • XPRINT ARC
  • XPRINT ANHANG
  • XPRINT-BOX
  • XPRINT ELLIPSE
  • XPRINT-LINIE
  • XPRINT PIE
  • XPRINT-BREITE

PBXB64-Umsetzungshinweise

XPRINT-STIL gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT-STIL ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT-STIL mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT(TEXT.SIZE.X...) – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT(TEXT.SIZE.X...)
Hilfe zum PBXB64-Compiler

XPRINT(TEXT.SIZE.X...)

Berechnen Sie die Größe des Texts, der auf a gedruckt werden soll

Typ:Funktion |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT TEXT SIZE txt$ To nWidth! , nHeight!
Function Form:
WidthVar! = XPRINT(TEXT.SIZE.X, txt$ )
HeightVar! = XPRINT(TEXT.SIZE.Y, txt$ )

Beschreibung

Diese Anweisung berechnet die Gesamtgröße des gedruckten Textes basierend auf der aktuellen Schriftart für den Hostdrucker. Die zurückgegebenen Größen werden in Seiteneinheiten angegeben.

Dies ermöglicht Ihnen eine einfache Berechnung der passenden Druckposition, insbesondere bei Verwendung einer Proportionalschrift. Wenn diese Anweisung ohne angeschlossenen Hostdrucker ausgeführt wird, wird Fehler 57 generiert.

Siehe auch

  • XPRINT-ZELLENGRÖSSE
  • XPRINT CHR-GRÖSSE
  • XPRINT SCHRIFTART EINSTELLEN

PBXB64-Umsetzungshinweise

XPRINT(TEXT.SIZE.X...) gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT(TEXT.SIZE.X...) ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT(TEXT.SIZE.X...) mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XPRINT WIDTH – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XPRINT WIDTH

XPRINT-BREITE

Legen Sie die grafische Linienbreite fest, die von verschiedenen XPRINT verwendet werden soll

Typ:Anweisung |Kategorie:Benutzeroberfläche, Grafik und DDT

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XPRINT WIDTH ncPixels&

Beschreibung

XPRINT WIDTH bestimmt die Linienbreite, die beim Zeichnen verschiedener grafischer Objekte verwendet wird. Die Standardbreite beträgt 1 Pixel. Die Breite wird immer in Pixel angegeben, unabhängig von einer XPRINT SCALE-Option. Wenn die Breite auf einen Wert größer als 1 eingestellt ist, werden XPRINT STYLE-Parameter immer als 0 (durchgezogen) interpretiert.

Siehe auch

  • XPRINT ARC
  • XPRINT ANHANG
  • XPRINT-BOX
  • XPRINT ELLIPSE
  • XPRINT-LINIE
  • XPRINT PIE
  • XPRINT-STIL

PBXB64-Umsetzungshinweise

XPRINT-BREITE gehoert zur PBXB64 GUI-, DDT-, GRAPHIC- oder XPRINT-Oberflaeche. Dieser Abschnitt ergaenzt die Hauptbeschreibung der Seite um Objektzustand, Pruefreihenfolge und die sichtbaren Randfaelle der aktuellen Toolchain.

Praktische Verwendung

XPRINT-BREITE ist ein XPRINT-Befehl fuer ein Druckerseite. Verwenden Sie den Befehl, nachdem das zugehoerige Fenster, Control oder Ausgabegeraet erzeugt und der passende angehaengter Druckerkontext bekannt ist. GUI-Befehle sollten in einer klaren Reihenfolge stehen: Objekt erzeugen, Eigenschaften setzen, anzeigen oder abfragen, danach Ressourcen freigeben.

Parameter und Zustand

Handles und IDs muessen zu einem noch gueltigen Objekt gehoeren. Koordinaten werden in der Einheit des jeweiligen Subsystems interpretiert: DDT-Dialogeinheiten oder Pixel fuer Dialog- und Controls, Grafikkoordinaten fuer GRAPHIC-Ziele und Seiten- beziehungsweise Druckereinheiten fuer XPRINT. Abfragefunktionen schreiben ihre Ergebnisse in die angegebenen Zielvariablen.

Fehler und Randfaelle

Ein ungueltiger Handle, eine falsche Control-ID, ein nicht ausgewaehltes Grafikziel oder ein nicht angehaengter Drucker kann zu Fehlern, Rueckgabewerten 0/0 oder unveraenderten Zielvariablen fuehren. Pruefen Sie deshalb die Erzeugungsschritte und behandeln Sie Fehlerpfade im Beispielcode explizit.

Druckersitzung

XPRINT-Seiten sollen den Lebenszyklus der angehaengten Druckersitzung erklaeren: anhaengen, skalieren, zeichnen, abfragen und am Ende schliessen. Das Beispiel sollte zeigen, dass der Zustand bis zum expliziten XPRINT CLOSE erhalten bleibt und nicht an ein lokales Zwischenobjekt gebunden ist.

Skalierung und Seitenwerte

Beschreiben Sie, wie die Seite zwischen Pixeln und benutzerdefinierten Weltkoordinaten wechselt und welche Abfrage die aktuellen Werte zurueckliefert. Wenn die Seite eine konkrete Koordinatenspanne verwendet, pruefen Sie diese aktiv im Beispiel und nennen Sie den Rueckweg zu XPRINT SCALE PIXELS.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Objekt erzeugen oder anhaengen.
    ' XPRINT-BREITE mit gueltigen Handles/IDs ausfuehren.
    ' Ergebnis pruefen und Ressourcen geordnet freigeben.
    FUNCTION = 0
END FUNCTION

Validation evidence: Treat this as a focused GUI/DDT validation pattern and cite the exact registered test file when a page is promoted from available syntax to certified tested behavior.


XTHREAD CREATE – PBXB64-Compiler-Hilfe

Startseite › Funktionen › XTHREAD CREATE

XTHREAD ERSTELLEN

Erstellen Sie einen Windows-Thread mit mehreren Argumenten.

Typ:Anweisung |Kategorie: Einfädeln

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XTHREAD CREATE FuncName(arg1, arg2, ...) TO hThread

Beschreibung

XTHREAD CREATE ist eine Variante mit mehreren Argumenten THREAD CREATE. Während THREAD CREATE nur einen einzelnen BYVAL LONG-Parameter akzeptiert, unterstützt XTHREAD CREATE bis zu sechs Argumente gemischter Typen (LONG oder STRING).

Der Funktionsname wird ohne Anführungszeichen angegeben. Die Funktion muss vor der XTHREAD CREATE-Anweisung deklariert oder definiert werden. Argumente werden automatisch BYVAL übergeben.

Bei Erfolg wird das Thread-Handle in der hinter TO angegebenen Variablen gespeichert. Bei einem Fehler erhält die Variable Null (0).

Das Thread-Handle kann mit allen Standard-Thread-Anweisungen verwendet werden: FADEN CLOSE, Thread-Status, FADEN AUFHÄNGEN, UndThread-Lebenslauf.

Beispiel

#COMPILE EXE
#DIM ALL

DECLARE FUNCTION MultiAdd(BYVAL a AS LONG, BYVAL b AS LONG, BYVAL c AS LONG) AS LONG

FUNCTION MultiAdd(BYVAL a AS LONG, BYVAL b AS LONG, BYVAL c AS LONG) AS LONG
    FUNCTION = a + b + c
END FUNCTION

FUNCTION PBMAIN() AS LONG
    LOCAL h AS LONG
    LOCAL r AS LONG

    XTHREAD CREATE MultiAdd(10, 20, 30) TO h
    THREAD CLOSE h TO r

    IF r <> 60 THEN FUNCTION = 1 ELSE FUNCTION = 0
END FUNCTION

Einschränkungen

Es werden maximal sechs Argumente unterstützt. Die Argumenttypen sind auf LONG und STRING beschränkt. Die Zielfunktion muss sich im selben kompilierten Modul befinden.

Siehe auch

  • THREAD CREATE
  • FADEN CLOSE
  • Thread-Status
  • FADEN AUFHÄNGEN
  • Thread-Lebenslauf
  • Thread-Set-Priorität
  • Thread-ID
  • FADENZAHL
  • GEWINDE
  • THREAD-Codegruppe

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Assembler-Referenz (nativ x64) - PBXB64 Help

Startseite › x64 Backend & Assembly

Assembler-Referenz (nativ x64)

PBXB64 enthaelt einen nativen x64-Assembler. .asm- und .s-Dateien werden direkt durch Lexer, Parser, Encoder, COFF-Objektbau und PE-Linker verarbeitet; ein externer Assembler ist nicht erforderlich.

Referenzseiten

Diese Seite ist die ASM-Frontend-Uebersicht. Die Einzelseiten dokumentieren Syntax, getestete Beispiele, Status und Grenzen fuer Direktiven, Adressierung und Instruktionsgruppen.

  • ASM / inline assembly
  • ASM overview
  • Addressing modes
  • Assembler directives
  • SECTION
  • GLOBAL
  • EXTERN
  • ALIGN
  • DB / BYTE
  • DW / WORD
  • DD / DWORD
  • DQ / QWORD
  • ASCII
  • ASCIZ
  • MACRO
  • Core mnemonics
  • SSE mnemonics
  • AVX mnemonics

Grundstruktur

section .text
global main

main:
    mov eax, 42
    ret

Assembler-Pipeline

.asm / .s  ->  ASM Lexer  ->  ASM Parser  ->  Encoder  ->  COFF Object  ->  PE Linker

Integration mit anderen Frontends

PBXB64 main.b64 helper.asm -o program.exe
PBXB64 prog.c utils.s -o mixed.exe

Syntaxhinweise

  • Intel syntax: instruction destination, source
  • Win64 register set: rax through r15, including byte/word/dword aliases.
  • Open the child pages for directive-specific tested samples and instruction-family limits.

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Zurueck zum Befehlsindex


ASM – PBXB64-Compiler-Hilfe

Startseite› ASM

ASM

Identifizieren Sie eine Assembler-Anweisung. PowerBASICs

Typ:Anweisung |Kategorie:Inline-Assembler

PBXB64-Status:TEILWEISE

PBXB64-Zertifizierung: Getestet für den unten dokumentierten PBXB64-Teilsatz; umfassende native Inline-Assembler-Abdeckung bleibt offen.

PBXB64-Hinweis: ASM ALIGN Grenze wird als Kompatibilitäts-No-Op akzeptiert. Das IR-Backend garantiert derzeit keine echte Code-Segment-Ausrichtung, daher wird kein NOP-Padding eingefügt.

Syntax

{! | ASM} { opcode | label }
{! | ASM} ALIGN boundary

Beschreibung

Mit dieser Anweisung können Sie Assembler-Code in Ihren PowerBASIC-Quellcode einfügen. Ein Ausrufezeichen (!) dient als Abkürzung für das Schlüsselwort ASM.

Jede Gruppe von ASM-Anweisungen muss die folgenden CPU-Register beibehalten, wenn der Assemblercode zu einer Änderung führt: EBX, ESI, EDI, ESP, EBP und alle Segmentregister. Weitere Informationen finden Sie unter Register speichern.

In derselben Zeile wie eine ASM-Anweisung dürfen keine anderen Anweisungen stehen; Kommentare sind jedoch akzeptabel.

! DB 1, 2, 3, 4, 5

! TT &H45001222, &HFFFF4327

Jede Variable, auf die in einer Assembler-Anweisung verwiesen wird, muss vor der Verwendung definiert werden. Zum Beispiel:

x% = 10

! MOV AX, x%

Sie können nicht mit einer einzelnen ASM-Anweisung auf das Ziel eines Zeigers zugreifen, wie dies möglicherweise im BASIC-Quellcode der Fall wäre. Stattdessen müssen Sie die Zeigeradresse indirekt verwenden. Um die BASIC-Anweisung INCR @x zu simulieren, würden Sie schreiben:

DIM x AS INTEGER PTR

ASM MOV EAX, x ; EAX enthält einen Zeiger auf eine Ganzzahl

ASM INC WORD PTR [EAX] ; Addiere eins zum Zielwert

Im Inline-Assembler-Code können Zeichenfolgenliterale mit bis zu vier Zeichen verwendet werden:

! MOV AL, „a“ ; Verschiebe char a in reg AL

! MOV AX, „ab“ ; Verschiebe die Zeichen ab in reg AX

! ; „a“ in AL, „b“ in AH

! MOV EAX, „abcd“ ; Verschieben Sie die Zeichen abcd in reg EAX

PowerBASIC erkennt entweder ein Apostroph (') oder ein Semikolon (;), um einen Kommentar nach einer Zeile Assembler-Code anzugeben:

! PUSH EAX ; Speichern Sie das EAX-Register

! PUSH EBX ' speichert das EBX-Register

ASM ALIGN wird in kritischen Situationen eingesetzt, um maximale Effizienz aus Assembler-Codeabschnitten zu ziehen.

ASM ALIGN wird verwendet, um den Befehlsort auf eine Zweierpotenzadresse aufzurunden. Der angezeigte Grenzparameter muss eine Zweierpotenz im Bereich von 2 bis 256 sein.

PowerBASIC fügt NOP-Anweisungen in den Codeabschnitt ein, um die Anweisungsposition an die gewünschte Adresse zu bringen. Wenn sich die Anweisungsposition bereits auf einem Vielfachen der Grenze befindet, hat ALIGN keine Auswirkung.

Die #ALIGN-Metaanweisung funktioniert in derselben Hinsicht wie ASM ALIGN, die ASM ALIGN-Anweisung eignet sich jedoch besser für die Verwendung in einem PREFIX/END PREFIX-Block.

Einschränkungen

Es sollte darauf geachtet werden, dass die Register ordnungsgemäß erhalten bleiben, wenn Inline-Assembler-Code mit BASIC-Anweisungen vermischt wird. Weitere Informationen finden Sie unter Register speichern.

Beispiele

LOCAL a&, b&, c&, z&
! MOV EAX, a&
! ADD EAX, b&
! ADD EAX, c&
! MOV z&, EAX

Siehe auch

  • Der Inline-Assembler
  • ASMDATA

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.


PBXB64 Inline-Assembler-Übersicht

Startseite› Übersicht über den PBXB64 Inline-Assembler

PBXB64 Inline-Assembler

Der PBXB64-Inline-Assembler bietet vollständige x86-64-Assemblersprachenunterstützung in PowerBASIC-Quelldateien unter Verwendung von#ASM / #ENDASMDirektivenpaar. Es unterstützt über 1400 eindeutige Mnemoniken in allen wichtigen x86-64-ISA-Familien, 21 Operandenartenvarianten und 14 Adressierungsmodi.

Notiz:Alle Mnemoniken verwendenIntel-SyntaxReihenfolge (Ziel, Quelle), im Einklang mit den MASM/TASM-Konventionen.

Grundlegende Syntax

FUNCTION PBMAIN() AS LONG
    #ASM
        mov eax, 42
        mov ebx, eax
        add ebx, 10
        mov [result], ebx
    #ENDASM
    PRINT result
END FUNCTION

Assemblyblöcke können im Funktionsumfang oder innerhalb von Anweisungskörpern erscheinen. Sie werden direkt in den Codestream der Funktion ausgegeben.

Variablenzugriff mit {name}-Syntax

Der Zugriff auf PB-Variablen erfolgt innerhalb von ASM-Blöcken mithilfe der Notation in geschweiften Klammern. Der Assembler löst die Variable in ihren korrekten Stapelversatz oder ihre richtige globale Adresse auf und ersetzt die effektive Adresse in den Operanden.

FUNCTION Demo() AS LONG
    LOCAL x AS LONG
    LOCAL y AS LONG
    LOCAL z AS LONG
    x = 10
    y = 20

    #ASM
        mov eax, DWORD PTR [{x}]   ; load x (stack offset)
        mov ecx, DWORD PTR [{y}]   ; load y
        add eax, ecx
        mov DWORD PTR [{z}], eax   ; store to z
    #ENDASM

    PRINT z   ; prints 30
END FUNCTION

Variablenzugriff nach Typ

PB-Erklärung | ASM-Zugriff | Größe
LOCAL n ALS BYTE | BYTE PTR [{n}] | 1 Byte
LOCAL n ALS WORT | WORD PTR [{n}] | 2 Bytes
LOCAL n ALS DWORD | DWORD PTR [{n}] | 4 Bytes
LOCAL und SO LANG | DWORD PTR [{n}] | 4 Bytes
LOCAL n AS QUAD | QWORD PTR [{n}] | 8 Byte
LOCAL n ALS INTEGER | WORD PTR [{n}] | 2 Bytes
LOCAL n ALS EINZEL | DWORD PTR [{n}] | 4 Bytes (Float)
LOCAL n ALS DOPPEL | QWORD PTR [{n}] | 8 Bytes (doppelt)
LOCAL n AS STRING | QWORD PTR [{n}] | 8 Bytes (Datenptr)
LOCAL n AS STRING | QWORD PTR [LEN({n})] | 8 Byte (Länge)
LOCAL n AS STRING | QWORD PTR [STRPTR({n})] | 8 Bytes (Datenptr)

ASM-Makros

Der Assembler stellt integrierte Makros für die Selbstprüfung von PowerBASIC-Variablen bereit:

Makro | Beschreibung
LEN(variable) | Wird in den Längenfeldoffset einer Zeichenfolgenvariablen aufgelöst
STRPTR(variable) | Wird zum Datenzeiger einer Zeichenfolgenvariablen aufgelöst
VARPTR(variable) | Wird in die Adresse/den Offset einer beliebigen Variablen aufgelöst
SIZEOF(variable) | Wird in die Kompilierzeitgröße einer Variablen oder eines Typs aufgelöst

Segmentüberschreibungen

Der Assembler unterstützt Segmentüberschreibungen für Thread-lokale Speicher- und Systemoperationen:

Überschreiben | Zweck | Beispiel
fs: | Windows TEB (Thread Environment Block) | mov rax, QWORD PTR fs:[0x30]
gs: | Windows PEB / x64 TLS-Basis | mov rax, gs:[0x60]

Adressierungsmodi

Der Assembler unterstützt 6 primäre Adressierungsmodi mit 21 Varianten der Operandenart:

  1. Registrieren — mov eax, ebx
  2. Sofort — mov eax, 42
  3. Direkter Speicher — mov eax, [12345678h]
  4. Basis + Verschiebung — mov eax, [rbp-8]
  5. Basis + Index — mov eax, [rbx+rcx]
  6. Basis + Index*Skala + Verschiebung — mov eax, [rbx+rcx*4+16]
  7. RIP-relativ — mov eax, [rip+label]

SehenReferenz zu Adressierungsmodifür alle Einzelheiten.

Unterstützte ISA-Familien

ISA-Familie | Mnemonik | Referenz
x86-64-Kern (GPR) | ~400 | Grundlegende Mnemonik
SSE/SSE2/SSE3/SSSE3/SSE4 | ~300 | SSE-Mnemonik
AVX/AVX2/AVX-512/FMA | ~500 | AVX-Mnemonik
BMI1/BMI2 | ~16 | BMI-Mnemonik
AES-NI / SHA / CLMUL / CRC32 / GFNI | ~30 | Krypto-Mnemonik
Systemanweisungen | ~50 | System-Mnemonik
SGX / VMX / CET | ~50 | SGX/VMX/CET
MMX | ~60 | MMX-Mnemonik
x87-FPU | ~80 | FPU-Mnemonik
Cache-Kontrolle | ~20 | Cache-Mnemonik

Richtlinien

Der Assembler unterstützt eine Vielzahl von Anweisungen für Ausrichtung, Nullinitialisierung und strukturierte Ausnahmebehandlung (SEH). SehenRichtlinienreferenzfür alle Einzelheiten.

Compiler-Version

Diese Referenz gilt für PBXB64 V32+ (Mai 2026). Die Assembler-Engine unterstützt über 1500 einzigartige Mnemoniken in allen ISA-Familien, überprüft durch die Laufzeittestsuite.

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

← Systemanweisungen Nach oben ASMDATA/END ASMDATA-Anweisungen →

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes


Referenz zu Adressierungsmodi

Der PBXB64-Assembler unterstützt 7 primäre Adressierungsmodi mit 21 Operandentypvarianten in 14 Kodierungsformen. Alle Adressierungsmodi folgen der Intel-Syntax (Ziel-, Quellreihenfolge).

Zusammenfassung des Adressierungsmodus

# | Modus | Syntax | Codierung | Beispiel
1 | Registrieren | reg | ModRM.reg / ModRM.rm | mov eax, ebx
2 | Sofort | imm | Sofortiges Feld | mov eax, 42
3 | Direkter Speicher | [addr] | ModRM: 00 000 101 + disp32 | mov eax, [12345678h]
4 | Basis+Anzeige8 | [reg+disp8] | ModRM: 01 xxx xxx + disp8 | mov eax, [rcx+8]
5 | Basis+disp32 | [reg+disp32] | ModRM: 10 xxx xxx + disp32 | mov eax, [rcx+1024]
6 | Basis+Index | [base+index] | ModRM+SIB: 00 100 xxx | mov eax, [rbx+rcx]
7 | Basis+Index+Disp8 | [base+index+disp8] | ModRM+SIB: 01 100 xxx | mov eax, [rbx+rcx+8]
8 | Basis+Index+Disp32 | [base+index+disp32] | ModRM+SIB: 10 100 xxx | mov eax, [rbx+rcx+1024]
9 | Index*Skala | [index*scale] | ModRM+SIB: 00 100 101 | mov eax, [rcx*4]
10 | Index*Skala+Anzeige32 | [index*scale+disp] | ModRM+SIB: 00 100 101 + disp32 | mov eax, [rcx*4+16]
11 | Basis+Index*Skala | [base+index*scale] | ModRM+SIB: Skala=Index | mov eax, [rbx+rcx*4]
12 | Basis+Index*Skala+Anzeige8 | [base+index*scale+disp8] | ModRM+SIB: 01 xxx xxx | mov eax, [rbx+rcx*4+8]
13 | Basis+Index*Skala+Anzeige32 | [base+index*scale+disp32] | ModRM+SIB: 10 xxx xxx | mov eax, [rbx+rcx*4+1024]
14 | RIP-relativ | [rip+disp] | ModRM: 00 000 101 + disp32 (relativ) | mov rax, [rip+label]
15 | RIP-relativ+Index | [rip+index*scale+disp] | RIP+SIB | mov rax, [rip+rcx*4+label]
16 | FS-Segment-Überschreibung | fs:[base+disp] | Segmentpräfix 64h + ModRM | mov rax, fs:[0x30]
17 | GS-Segment-Überschreibung | gs:[base+disp] | Segmentpräfix 65h + ModRM | mov rax, gs:[0x60]
18 | FS+RIP-relativ | fs:[rip+disp] | 64h + RIP-relativ | mov rax, fs:[rip+label]
19 | GS+RIP-relativ | gs:[rip+disp] | 65h + RIP-relativ | mov rax, gs:[rip+tls_var]
20 | Registrieren (implizit) | reg | Opcode-Bits | push rbx(Opcode 53h)
21 | Sofort (impliziert) | imm | Im Opcode implizit | ret 16(imm16 im Opcode C2h)

1. Adressierung registrieren

Der Operand ist ein Register. Das Register ist im ModRM-Byte oder im primären Opcode codiert.

mov eax, ebx        ; eax = ebx
add rcx, rdx        ; rcx = rcx + rdx
xor r8d, r9d        ; r8d = r8d xor r9d

2. Sofortige Adressierung

Der Operand ist ein konstanter Wert, der in die Anweisung eingebettet ist. Die unmittelbare Größe hängt von der Operandengröße ab.

mov eax, 42         ; 32-bit immediate
mov rax, 0x12345678 ; 32-bit sign-extended immediate
mov rcx, -1         ; sign-extended immediate
add ebx, 256        ; 32-bit immediate

3. Direkte Speicheradressierung

Der Operand ist ein Speicherort, der durch eine 32-Bit-Absolutadresse angegeben wird. In x64 ist dies auf den niedrigen Adressraum von 4 GB beschränkt (Kompatibilitätsmodus), sofern nicht mit RIP-relativ verwendet.

mov eax, [12345678h]    ; absolute 32-bit address
mov DWORD PTR [1234h], 42  ; store to absolute address

4. Basis + Verschiebung

Die effektive Adresse wird wie folgt berechnetbase + displacement. Die Verschiebung kann ein 8-Bit-Wert (disp8) oder ein 32-Bit-Wert (disp32) mit Vorzeichen sein.

mov eax, [rbp-8]        ; local variable at rbp-8
mov eax, [rcx+16]       ; struct member at offset 16
mov eax, [rsp+0x30]     ; stack parameter
mov eax, [rbx-4]        ; negative displacement

5. Basis + Index

Die effektive Adresse lautetbase + index. Der Index ist ein Allzweckregister, das als Offset verwendet wird.

mov eax, [rbx+rcx]      ; array element: base + index
mov eax, [rax+rdx]      ; pointer + offset

6. Index * Skala

Die effektive Adresse lautetindex * scale. Gültige Skalenwerte sind 1, 2, 4, 8 (kodiert als 00, 01, 10, 11 im SIB-Byte).

mov eax, [rcx*4]        ; element at index*4
mov eax, [rdx*8]        ; element at index*8 (array of pointers)
mov eax, [r9*2]         ; 16-bit element array

7. Basis + Index * Skala + Verschiebung

Das vollständige SIB-Adressierungsformular (Scale-Index-Base). Dies ist der allgemeinste Adressierungsmodus, der alle Komponenten vereint.

mov eax, [rbx+rcx*4+16]        ; array of structs
mov eax, [rbp+r9*8-32]         ; local array with negative offset
mov eax, [rax+rdx*2+0x100]     ; large displacement
mov eax, [r12+r10*4+0x80]      ; base+r12 with r10 scaled

8. RIP-relative Adressierung

In x64 verwenden die meisten Speicherreferenzen standardmäßig RIP-relative Adressierung für den coderelativen Datenzugriff. Der Assembler codiert eine 32-Bit-Verschiebung mit Vorzeichen vom aktuellen Befehlszeiger.

mov rax, [rip+label]           ; load from label (relative to RIP)
mov rax, [rip+my_data]         ; access global data
lea rcx, [rip+message]         ; load effective address
jmp [rip+function_ptr]         ; indirect jump via global pointer

Die RIP-relative Adressierung ist die Standardmethode für den Zugriff auf globale Variablen und Konstanten im x64-Code, da sie die Notwendigkeit absoluter 64-Bit-Adressen vermeidet und positionsunabhängigen Code erzeugt.

9. Segmentüberschreibungen

x64 unterstütztfs:Undgs:Segmentüberschreibungen für den Zugriff auf Thread-lokale Speicher- und Betriebssystemdatenstrukturen.

FS-Segment

In Windows x64 ist diefsDas Segment zeigt auf den Thread Environment Block (TEB).

mov rax, QWORD PTR fs:[0x30]   ; PEB pointer from TEB
mov eax, DWORD PTR fs:[0x18]   ; LastError from TEB
mov rax, QWORD PTR fs:[0x60]   ; TLS base pointer

GS-Segment

Unter Windows x64,gsDas Segment wird für die Thread-lokale Speicherung verwendet. Unter x86-64-Linux verweist es auf threadspezifische Daten.

mov rax, QWORD PTR gs:[0x00]   ; TLS variable (Win64)
mov rax, QWORD PTR gs:[0x10]   ; thread-specific data (Linux)

; With RIP-relative: TLS combined addressing
mov rax, QWORD PTR gs:[rip+tls_var]

Präfixe für die Operandengröße

Speicheroperanden erfordern Größenbezeichner, um die Operandengröße eindeutig zu machen:

Präfix | Größe | Beispiel
BYTE PTR | 8 Bit | mov BYTE PTR [rcx], 0xFF
WORD PTR | 16 Bit | mov WORD PTR [rcx], 0x1234
DWORD PTR | 32 Bit | mov DWORD PTR [rcx], eax
QWORD PTR | 64 Bit | mov QWORD PTR [rcx], rax
XMMWORD PTR | 128 Bit | movdqa XMMWORD PTR [rcx], xmm0
YMMWORD PTR | 256 Bit | vmovdqa YMMWORD PTR [rcx], ymm0
ZMMWORD PTR | 512 Bit | vmovdqa32 ZMMWORD PTR [rcx], zmm0
TBYTE PTR | 80 Bit | fld TBYTE PTR [rcx]

SIB-Kodierung (Scale-Index-Base).

Das SIB-Byte wird verwendet, wenn ein Speicheroperand ein Indexregister umfasst. Format:

SIB = [Scale 2 bits] [Index 3 bits] [Base 3 bits]

Scale: 00=1, 01=2, 10=4, 11=8
Index: general-purpose register (100 = no index)
Base:  general-purpose register (101 = disp32 if Mod=00)

Sonderfälle:

  • Basis = RSP (100):Ein SIB-Byte iststetserforderlich, um rsp als Basisregister zu kodieren (um Verwechslungen mit der ModRM-Kodierung „SIB vorhanden“ zu vermeiden)
  • Index = rsp (100):Bedeutet, dass das Register „kein Index“ verwendet wird (nur Basis + Verschiebung)
  • Mod=00, Basis=101, Index=100:RIP-relative Adressierung

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

← ASM Nach oben Assembler-Anweisungen →

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes


Assembler-Anweisungen

Der Assembler von PBXB64 unterstützt eine Reihe von Anweisungen zur Steuerung der Ausrichtung, Datenemission und SEH-Abwicklungsinformationen (Structured Exception Handling). Im Inneren werden Direktiven verwendet#ASM / #ENDASMBlöcke.

Ausrichtungsrichtlinien

#ALIGN

Steuert die Ausrichtung der Strukturelemente innerhalb von PBTYPE / UNIONBlöcke. Steuert außerdem die allgemeine Abschnittsausrichtung in Baugruppenblöcken.

#ALIGN 16       ' align to 16-byte boundary

Bei Verwendung in einemTYPE/UNIONKontext,#ALIGNsteuert die Packungsausrichtung nachfolgender Elemente. Die Standardausrichtung ist die natürliche Ausrichtung jedes Elementtyps.

.p2align

Füllen Sie den aktuellen Abschnitt mit NOP-Anweisungen auf, um die angegebene Ausrichtungsgrenze zu erreichen. Die Direktive benötigt einen Zweierpotenz-Exponenten.

#ASM
    .p2align 4      ; align to 16-byte boundary (2^4)
    .p2align 5, 0x90, 8  ; align to 32-byte, pad with NOPs, max 8 bytes
#ENDASM

Parameter:

Parameter | Beschreibung
align | Zweierpotenz-Ausrichtung (z. B. 4 = 16 Bytes, 5 = 32 Bytes)
fill | Optionales Füllbyte (Standard: 0x90 = NOP)
max | Optionale maximale Anzahl einzufügender Bytes

.zero

Gibt einen Block mit null initialisiertem Speicher aus. Wird häufig zum Auffüllen der Ausrichtung oder zur Datenreservierung verwendet.

#ASM
    .zero 32        ; emit 32 zero bytes
#ENDASM

SEH-Richtlinien (Structured Exception Handling).

Diese Anweisungen geben Abwicklungsinformationen an die aus.pdataUnd.xdataPE-Abschnitte, die es dem Windows x64-Ausnahmehandler ermöglichen, den Stapel ordnungsgemäß abzuwickeln.

.seh_proc

Markiert den Beginn einer Funktion mit SEH-Abwicklungsinformationen. Erforderlich vor allen anderen SEH-Richtlinien.

.seh_proc MyFunction

.seh_endprologue

Markiert das Ende des Funktionsprologs. Ab diesem Zeitpunkt ist der Stapelrahmen vollständig aufgebaut und die Abwickelcodes wurden aufgezeichnet.

.seh_endprologue

.seh_pushreg

Zeichnet auf, dass ein nichtflüchtiges Register auf den Stapel verschoben wurde. Beim Abwickeln wird das Register wiederhergestellt.

.seh_pushreg rbx
.seh_pushreg rsi
.seh_pushreg rdi

.seh_setframe

Erstellt ein Frame-Pointer-Register mit optionalem skaliertem Offset. Der Rahmenzeiger wird verwendet, um während des Abwickelns auf lokale Variablen und Parameter zuzugreifen.

.seh_setframe rbp, 0   ; rbp is frame pointer, no scaled offset

.seh_stackalloc

Zeichnet auf, dass eine angegebene Anzahl von Bytes auf dem Stapel zugewiesen wurde (normalerweise über).sub rsp, X).

.seh_stackalloc 64    ; 64 bytes of local stack allocated

.seh_savereg

Zeichnet auf, dass ein nichtflüchtiges Register in einem bestimmten Stapelversatz vom Framezeiger oder Stapelzeiger gespeichert wurde.

.seh_savereg rbx, 32   ; rbx saved at [rbp+32] or [rsp+32]

.seh_savexmm

Zeichnet auf, dass ein nichtflüchtiges XMM-Register in einem bestimmten Stapeloffset gespeichert wurde.

.seh_savexmm xmm6, 16  ; xmm6 saved at [rbp+16]

.seh_pushframe

Zeichnet auf, dass ein Frame gepusht wurde (wird zur Ausnahmebehandlung von Kettenframes verwendet). Die Wahl[code]Flag zeigt an, ob eine Absenderadresse übertragen wurde.

.seh_pushframe         ; push frame without return address
.seh_pushframe code     ; push frame with return address on stack

.seh_handler

Ordnet der aktuellen Prozedur eine Ausnahmehandlerfunktion zu. Verwendet fürTRY/CATCH/FINALLYUnterstützung.

.seh_handler ExceptionHandler, @except
.seh_handler FinallyHandler, @finally

.seh_endproc

Markiert das Ende der SEH-Abwicklungsinformationen einer Funktion. Muss nach allen anderen SEH-Anweisungen für die Funktion erscheinen.

.seh_endproc

Vollständiges SEH-Beispiel

; Standard x64 function prologue with SEH
#ASM
.seh_proc MyFunc
    push rbp
    .seh_pushreg rbp
    mov rbp, rsp
    .seh_setframe rbp, 0
    sub rsp, 48
    .seh_stackalloc 48
    .seh_endprologue

    ; function body
    mov DWORD PTR [rbp-4], 42
    mov eax, DWORD PTR [rbp-4]

    ; epilogue
    add rsp, 48
    pop rbp
    ret
.seh_endproc
#ENDASM

Richtlinien aussenden

.byte

Geben Sie rohe Bytewerte in den Codestream aus.

.byte 0x90, 0x90, 0xCC    ; NOP, NOP, INT3

.word

16-Bit-Wortwerte ausgeben.

.word 0x1234, 0x5678

.long

32-Bit lange Werte ausgeben.

.long 0x12345678

.quad

64-Bit-Quadword-Werte ausgeben.

.quad 0x1234567890ABCDEF

Abschnittsrichtlinien

.section

Wechseln Sie zu einem benannten Abschnitt. Standardabschnitte umfassen.text, .data, .bss, .rdata.

.section .data
.section .rdata, "rd"   ; read-only data section

.section .text
    ; code follows

.text / .data / .bss

Praktische Aliase für allgemeine Abschnitte.

.data
myVar: .quad 42

.text
    mov rax, QWORD PTR [myVar]

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

← Referenz zu Adressierungsmodi Nach oben AVX/AVX2/AVX-512/FMA-Mnemonik →

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes


ASMDATA/END ASMDATA-Anweisungen “ PBXB64-Compiler-Hilfe

Startseiteâ€º ASMDATA/END ASMDATA-Anweisungen

ASMDATA/END ASMDATA-Anweisungen

Definieren Sie einen Block, in dem primitive schreibgeschützte Daten gespeichert werden.

Typ:Anweisung |Kategorie:Datei-E/A

PBXB64-Status:TEILWEISE

PBXB64-Zertifizierung: Implementiert und getestet für dezimale/hexadezimale/binäre ganzzahlige DB/DW/DD/DQ-Werte sowie ANSI-String-Literale in DB-Anweisungen. Blöcke auf Modulebene und in Funktionen werden als schreibgeschützte Globals emittiert und sind über CODEPTR und Inline-ASM-{BlockName}-Referenzen adressierbar. Komplexe String-Literal-Ausdrücke, WIDE-String-DW-Werte, explizite Ausrichtung und Label-Referenzen jenseits des Block-Geltungsbereichs sind noch nicht unterstützt.

Syntax

ASMDATA BlockName
DB 1, "ABC"$, 0
DW 2, "XYZ"$$, 0
DD &H12345678
DQ 1234567890
END ASMDATA

Beschreibung

Es ist häufig praktisch, einige Daten innerhalb des Codeabschnitts Ihres Programms zu definieren. Diese Daten sind schreibgeschützt und dürfen daher niemals geändert werden. Ein Versuch, dies zu tun, führt zu einem GPF (General Protection Fault), der zur Beendigung Ihres Programms führt. Auf diese Art von Daten wird im Allgemeinen nur über ASM-Code zugegriffen.

Definierte Daten können mithilfe von ASM-Anweisungen innerhalb einer Sub , Function , Method oder Property platziert werden, diese Technik birgt jedoch eine Reihe von Fallstricken. Beim Debuggen oder bei der Verwendung von TRACE , PROFILE , #DEBUG DISPLAY , ERL , ERL$ usw. muss PowerBASIC an verschiedenen Stellen speziellen Code einfügen, was es für Sie schwierig (wenn nicht unmöglich) macht, genau auf die Daten zuzugreifen. Sie kennen die GröÃŸe des eingefügten Codes nicht und werden daher Schwierigkeiten haben, ihn genau zu adressieren.

Ein ASMDATA-Block löst dieses Problem vollständig. Es dient ausschlieÃŸlich dem Zweck, Daten zu definieren, und aus irgendeinem Grund werden niemals zusätzlicher Code oder zusätzliche Daten eingefügt. Die Daten innerhalb des Blocks werden niemals ausgerichtet, sodass Sie immer die genaue Position jedes Elements kennen. Der ASMDATA-Block muss sich auÃŸerhalb von Subs, Funktionen, Methoden oder Eigenschaften befinden. Der von Ihnen zugewiesene BlockName ist jedoch öffentlich und kann daher von jeder Stelle in Ihrem Programm aus referenziert werden. Möglicherweise enthält Ihr Programm einen oder mehrere Blöcke.

StandardmäÃŸig werden alle ASMDATA-Blöcke am ersten verfügbaren Byte positioniert. Dadurch kann auf zusammenhängende Blöcke zugegriffen werden, als wären sie ein einziger gröÃŸerer Block. Sie können einzelne oder alle Blöcke unterschiedlich ausrichten, indem Sie dem Block eine #ALIGN-Metaanweisung voranstellen.

Beschriftungen und Zeilennummern sind in einem ASMDATA-Block nicht zulässig. Wenn Sie einen Referenzpunkt auf einen bestimmten Unterabschnitt Ihrer Daten benötigen, teilen Sie ihn einfach in zwei oder mehr Blöcke auf und verwenden Sie dabei jeden BlockName als Referenzpunkt.

Die einzigen innerhalb eines ASMDATA-Blocks zulässigen Anweisungen sind DB, DD, DQ und DW, daher muss ihnen keine ASM-Anweisung vorangestellt werden. Ein ANSI-String-Literal-Ausdruck kann in einer DB-Anweisung platziert werden, und ein WIDE-String-Literal-Ausdruck (Unicode) kann in einer DW-Anweisung platziert werden. Es ist zu beachten, dass Strings in ASM-Blöcken maximal 255 Zeichen lang sein dürfen. Ein String-Literal-Ausdruck kann aus String-Literalen in Anführungszeichen, String-Equates und den Verkettungsoperatoren (&,+) bestehen. Sie können auch CHR$() , SPACE$() und STRING$() verwenden, wenn diese nur Literalparameter verwenden.

Mit der Funktion CODEPTR() können Sie auf die Adresse eines ASMDATA-Blocks zugreifen. Wenn Sie also einen Block namens ABC erstellen, gehen Sie folgendermaÃŸen vor:

ASMDATA ABC

DB 5,2,3

DB 7,8,9

END ASMDATA

Sie würden etwa so darauf zugreifen:

AsmVar = CODEPTR(ABC)

Eine andere Möglichkeit besteht darin, mithilfe eines dieser Opcodes direkt auf ein CPU-Register Ihrer Wahl zuzugreifen:

ASM LEA EBX, abc

ASM MOV EBX, Offset abc

Dies würde dazu führen, dass das erste Datenbyte (5) in das Register AL verschoben wird.

Oder verschieben Sie es sogar direkt in eine 32-Bit-Variable:

ASM MOV AsmVar, Offset abc

Siehe auch

  • ASM

Kind: Reference topic | Category: Assembly

PBXB64 Status: PARTIAL

Description

ASMDATA / END ASMDATA defines read-only assembler data blocks that can be addressed from PBXB64 source and inline ASM. Treat the page as a focused syntax-and-boundary reference for the currently implemented DB, DW, DD, and DQ forms.

Syntax

ASMDATA BlockName
DB 1, 2, 3
DW 4, 5
DD &H12345678
DQ 1234567890
END ASMDATA

Validation Evidence

Validation evidence: tests/pb/test_asmdata.pb and tests/pb/test_asmdata_hex.pb compile and run with exit code 0 and verify module-level ASMDATA emission, CODEPTR(block), and inline ASM reads from the emitted block bytes.

Notes

Only the tested integer DB/DW/DD/DQ forms and ANSI string literals in DB are documented here. Keep labels out of the block, treat the data as read-only, and use #ALIGN or separate blocks when you need distinct references.

Example

ASMDATA ABC
DB 5, 2, 3
END ASMDATA
AsmVar = CODEPTR(ABC)

See Also

  • ASM
  • CODEPTR

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.


ASM .text - Code-Section waehlen — PBXB64 Help

Startseite › x64 Backend › ASM Source Forms and Directives › ASM .text - Code-Section waehlen — PBXB64 Help
Hilfe zum PBXB64-Compiler

ASM .text - Code-Section waehlen

Category: Assembly

PBXB64 Status: [CERTIFIED TESTED]

Syntax

.text

Beschreibung

Waehlt die ausfuehrbare Text-Section fuer folgende Labels und Instruktionen. In Objekt-Ausgabe landen Codebytes und Code-Relocations in der Text-Section.

Nutzerbeleg: Die Syntax und das fokussierte ASM-Beispiel auf dieser Seite sind der relevante Nachweis fuer Nutzer.

Praktische Verwendung

Verwenden Sie diese Form in eigenstaendigen .asm-Dateien oder in den ASM-Pfaden, die PBXB64 durch denselben Parser fuehrt. Halten Sie Testdateien klein: ein Label, die betreffende Direktive oder Instruktion, und ein klarer Rueckgabewert erleichtern die Diagnose bei Encoder-, Relocation- oder Linkfehlern. Wenn die Form externe Symbole, Datenabschnitte oder Makros verwendet, sollte der Test auch zeigen, dass die erzeugte Objektdatei erfolgreich gelinkt wird.

Verifiziertes Beispiel

Abgedeckt durch tests/asm/test_text_section.asm in der ASM-Validierungsmatrix.

Die genannte Testdatei ist der konkrete Nachweis fuer diese Seite. Bei Erweiterungen sollte zuerst ein fokussierter ASM-Test ergaenzt werden, danach die Seite aktualisiert und zuletzt die ASM-Matrix erneut ausgefuehrt werden. So bleibt die Hilfedokumentation an reproduzierbares Compilerverhalten gebunden.

Grenzen

Diese Seite beschreibt die PBXB64-Assembler-Teilmenge aus Lexer, Parser, Makroexpander, Encoder und Object-Builder. Nicht jede NASM/MASM-Direktive ist implementiert.

Siehe auch

  • ASM Language Overview
  • Assembler Directives
  • Addressing Modes

← Back

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


ASM .data - Daten-Section waehlen — PBXB64 Help

Startseite › x64 Backend › ASM Source Forms and Directives › ASM .data - Daten-Section waehlen — PBXB64 Help
Hilfe zum PBXB64-Compiler

ASM .data - Daten-Section waehlen

Category: Assembly

PBXB64 Status: [CERTIFIED TESTED]

Syntax

.data

Beschreibung

Waehlt die schreibbare Daten-Section fuer folgende Datendirektiven und Labels.

Nutzerbeleg: Die Syntax und das fokussierte ASM-Beispiel auf dieser Seite sind der relevante Nachweis fuer Nutzer.

Praktische Verwendung

Verwenden Sie diese Form in eigenstaendigen .asm-Dateien oder in den ASM-Pfaden, die PBXB64 durch denselben Parser fuehrt. Halten Sie Testdateien klein: ein Label, die betreffende Direktive oder Instruktion, und ein klarer Rueckgabewert erleichtern die Diagnose bei Encoder-, Relocation- oder Linkfehlern. Wenn die Form externe Symbole, Datenabschnitte oder Makros verwendet, sollte der Test auch zeigen, dass die erzeugte Objektdatei erfolgreich gelinkt wird.

Verifiziertes Beispiel

Abgedeckt durch tests/asm/test_data_directives.asm in der ASM-Validierungsmatrix.

Die genannte Testdatei ist der konkrete Nachweis fuer diese Seite. Bei Erweiterungen sollte zuerst ein fokussierter ASM-Test ergaenzt werden, danach die Seite aktualisiert und zuletzt die ASM-Matrix erneut ausgefuehrt werden. So bleibt die Hilfedokumentation an reproduzierbares Compilerverhalten gebunden.

Grenzen

Diese Seite beschreibt die PBXB64-Assembler-Teilmenge aus Lexer, Parser, Makroexpander, Encoder und Object-Builder. Nicht jede NASM/MASM-Direktive ist implementiert.

Siehe auch

  • ASM Language Overview
  • Assembler Directives
  • Addressing Modes

← Back

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


ASM .section - Benannte Section waehlen — PBXB64 Help

Startseite › x64 Backend › ASM Source Forms and Directives › ASM .section - Benannte Section waehlen — PBXB64 Help
Hilfe zum PBXB64-Compiler

ASM .section - Benannte Section waehlen

Category: Assembly

PBXB64 Status: [CERTIFIED TESTED]

Syntax

.section .rdata

Beschreibung

Waehlt eine benannte COFF-Section, wenn die Quelle eine andere Section als die Standardbereiche text/data benoetigt.

Nutzerbeleg: Die Syntax und das fokussierte ASM-Beispiel auf dieser Seite sind der relevante Nachweis fuer Nutzer.

Praktische Verwendung

Verwenden Sie diese Form in eigenstaendigen .asm-Dateien oder in den ASM-Pfaden, die PBXB64 durch denselben Parser fuehrt. Halten Sie Testdateien klein: ein Label, die betreffende Direktive oder Instruktion, und ein klarer Rueckgabewert erleichtern die Diagnose bei Encoder-, Relocation- oder Linkfehlern. Wenn die Form externe Symbole, Datenabschnitte oder Makros verwendet, sollte der Test auch zeigen, dass die erzeugte Objektdatei erfolgreich gelinkt wird.

Verifiziertes Beispiel

Abgedeckt durch tests/asm/test_data_sections.asm in der ASM-Validierungsmatrix.

Die genannte Testdatei ist der konkrete Nachweis fuer diese Seite. Bei Erweiterungen sollte zuerst ein fokussierter ASM-Test ergaenzt werden, danach die Seite aktualisiert und zuletzt die ASM-Matrix erneut ausgefuehrt werden. So bleibt die Hilfedokumentation an reproduzierbares Compilerverhalten gebunden.

Grenzen

Diese Seite beschreibt die PBXB64-Assembler-Teilmenge aus Lexer, Parser, Makroexpander, Encoder und Object-Builder. Nicht jede NASM/MASM-Direktive ist implementiert.

Siehe auch

  • ASM Language Overview
  • Assembler Directives
  • Addressing Modes

← Back

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


ASM .global / .globl - Symbol exportieren — PBXB64 Help

Startseite › x64 Backend › ASM Source Forms and Directives › ASM .global / .globl - Symbol exportieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

ASM .global / .globl - Symbol exportieren

Category: Assembly

PBXB64 Status: [CERTIFIED TESTED]

Syntax

.global forth_main

Beschreibung

Markiert ein Label im erzeugten Objekt als extern sichtbar, damit es als Einsprungpunkt oder von einem anderen Frontend gelinkt werden kann.

Nutzerbeleg: Die Syntax und das fokussierte ASM-Beispiel auf dieser Seite sind der relevante Nachweis fuer Nutzer.

Praktische Verwendung

Verwenden Sie diese Form in eigenstaendigen .asm-Dateien oder in den ASM-Pfaden, die PBXB64 durch denselben Parser fuehrt. Halten Sie Testdateien klein: ein Label, die betreffende Direktive oder Instruktion, und ein klarer Rueckgabewert erleichtern die Diagnose bei Encoder-, Relocation- oder Linkfehlern. Wenn die Form externe Symbole, Datenabschnitte oder Makros verwendet, sollte der Test auch zeigen, dass die erzeugte Objektdatei erfolgreich gelinkt wird.

Verifiziertes Beispiel

Abgedeckt durch tests/asm/test_text_section.asm in der ASM-Validierungsmatrix.

Die genannte Testdatei ist der konkrete Nachweis fuer diese Seite. Bei Erweiterungen sollte zuerst ein fokussierter ASM-Test ergaenzt werden, danach die Seite aktualisiert und zuletzt die ASM-Matrix erneut ausgefuehrt werden. So bleibt die Hilfedokumentation an reproduzierbares Compilerverhalten gebunden.

Grenzen

Diese Seite beschreibt die PBXB64-Assembler-Teilmenge aus Lexer, Parser, Makroexpander, Encoder und Object-Builder. Nicht jede NASM/MASM-Direktive ist implementiert.

Siehe auch

  • ASM Language Overview
  • Assembler Directives
  • Addressing Modes

← Back

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


ASM .extern - Symbol importieren — PBXB64 Help

Startseite › x64 Backend › ASM Source Forms and Directives › ASM .extern - Symbol importieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

ASM .extern - Symbol importieren

Category: Assembly

PBXB64 Status: [CERTIFIED TESTED]

Syntax

.extern puts

Beschreibung

Deklariert ein externes Symbol, das vom Linker oder Runtime-Objektsatz aufgeloest wird.

Nutzerbeleg: Die Syntax und das fokussierte ASM-Beispiel auf dieser Seite sind der relevante Nachweis fuer Nutzer.

Praktische Verwendung

Verwenden Sie diese Form in eigenstaendigen .asm-Dateien oder in den ASM-Pfaden, die PBXB64 durch denselben Parser fuehrt. Halten Sie Testdateien klein: ein Label, die betreffende Direktive oder Instruktion, und ein klarer Rueckgabewert erleichtern die Diagnose bei Encoder-, Relocation- oder Linkfehlern. Wenn die Form externe Symbole, Datenabschnitte oder Makros verwendet, sollte der Test auch zeigen, dass die erzeugte Objektdatei erfolgreich gelinkt wird.

Verifiziertes Beispiel

Abgedeckt durch tests/asm/test_un_runtime_access.asm in der ASM-Validierungsmatrix.

Die genannte Testdatei ist der konkrete Nachweis fuer diese Seite. Bei Erweiterungen sollte zuerst ein fokussierter ASM-Test ergaenzt werden, danach die Seite aktualisiert und zuletzt die ASM-Matrix erneut ausgefuehrt werden. So bleibt die Hilfedokumentation an reproduzierbares Compilerverhalten gebunden.

Grenzen

Diese Seite beschreibt die PBXB64-Assembler-Teilmenge aus Lexer, Parser, Makroexpander, Encoder und Object-Builder. Nicht jede NASM/MASM-Direktive ist implementiert.

Siehe auch

  • ASM Language Overview
  • Assembler Directives
  • Addressing Modes

← Back

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


ASM .align - Ausgabeposition ausrichten — PBXB64 Help

Startseite › x64 Backend › ASM Source Forms and Directives › ASM .align - Ausgabeposition ausrichten — PBXB64 Help
Hilfe zum PBXB64-Compiler

ASM .align - Ausgabeposition ausrichten

Category: Assembly

PBXB64 Status: [CERTIFIED TESTED]

Syntax

.align 16

Beschreibung

Fuellt die aktuelle Section bis zur geforderten positiven Byte-Ausrichtung auf, bevor die naechste Anweisung ausgegeben wird.

Nutzerbeleg: Die Syntax und das fokussierte ASM-Beispiel auf dieser Seite sind der relevante Nachweis fuer Nutzer.

Praktische Verwendung

Verwenden Sie diese Form in eigenstaendigen .asm-Dateien oder in den ASM-Pfaden, die PBXB64 durch denselben Parser fuehrt. Halten Sie Testdateien klein: ein Label, die betreffende Direktive oder Instruktion, und ein klarer Rueckgabewert erleichtern die Diagnose bei Encoder-, Relocation- oder Linkfehlern. Wenn die Form externe Symbole, Datenabschnitte oder Makros verwendet, sollte der Test auch zeigen, dass die erzeugte Objektdatei erfolgreich gelinkt wird.

Verifiziertes Beispiel

Abgedeckt durch examples/asm/add_two.asm in der ASM-Validierungsmatrix.

Die genannte Testdatei ist der konkrete Nachweis fuer diese Seite. Bei Erweiterungen sollte zuerst ein fokussierter ASM-Test ergaenzt werden, danach die Seite aktualisiert und zuletzt die ASM-Matrix erneut ausgefuehrt werden. So bleibt die Hilfedokumentation an reproduzierbares Compilerverhalten gebunden.

Grenzen

Diese Seite beschreibt die PBXB64-Assembler-Teilmenge aus Lexer, Parser, Makroexpander, Encoder und Object-Builder. Nicht jede NASM/MASM-Direktive ist implementiert.

Siehe auch

  • ASM Language Overview
  • Assembler Directives
  • Addressing Modes

← Back

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


ASM .byte / .db - 8-Bit-Daten ausgeben — PBXB64 Help

Startseite › x64 Backend › ASM Source Forms and Directives › ASM .byte / .db - 8-Bit-Daten ausgeben — PBXB64 Help
Hilfe zum PBXB64-Compiler

ASM .byte / .db - 8-Bit-Daten ausgeben

Category: Assembly

PBXB64 Status: [CERTIFIED TESTED]

Syntax

.db 1, 2, 3

Beschreibung

Gibt ein Byte je Immediate-Argument aus oder erzeugt Label-Relocations, soweit vom Object-Builder unterstuetzt.

Nutzerbeleg: Die Syntax und das fokussierte ASM-Beispiel auf dieser Seite sind der relevante Nachweis fuer Nutzer.

Praktische Verwendung

Verwenden Sie diese Form in eigenstaendigen .asm-Dateien oder in den ASM-Pfaden, die PBXB64 durch denselben Parser fuehrt. Halten Sie Testdateien klein: ein Label, die betreffende Direktive oder Instruktion, und ein klarer Rueckgabewert erleichtern die Diagnose bei Encoder-, Relocation- oder Linkfehlern. Wenn die Form externe Symbole, Datenabschnitte oder Makros verwendet, sollte der Test auch zeigen, dass die erzeugte Objektdatei erfolgreich gelinkt wird.

Verifiziertes Beispiel

Abgedeckt durch tests/asm/test_data_directives.asm in der ASM-Validierungsmatrix.

Die genannte Testdatei ist der konkrete Nachweis fuer diese Seite. Bei Erweiterungen sollte zuerst ein fokussierter ASM-Test ergaenzt werden, danach die Seite aktualisiert und zuletzt die ASM-Matrix erneut ausgefuehrt werden. So bleibt die Hilfedokumentation an reproduzierbares Compilerverhalten gebunden.

Grenzen

Diese Seite beschreibt die PBXB64-Assembler-Teilmenge aus Lexer, Parser, Makroexpander, Encoder und Object-Builder. Nicht jede NASM/MASM-Direktive ist implementiert.

Siehe auch

  • ASM Language Overview
  • Assembler Directives
  • Addressing Modes

← Back

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


ASM .word / .dw / .short - 16-Bit-Daten ausgeben — PBXB64 Help

Startseite › x64 Backend › ASM Source Forms and Directives › ASM .word / .dw / .short - 16-Bit-Daten ausgeben — PBXB64 Help
Hilfe zum PBXB64-Compiler

ASM .word / .dw / .short - 16-Bit-Daten ausgeben

Category: Assembly

PBXB64 Status: [CERTIFIED TESTED]

Syntax

.dw 0x1234

Beschreibung

Gibt 16-Bit-Datenwerte in der aktuellen datenfaehigen Section aus.

Nutzerbeleg: Die Syntax und das fokussierte ASM-Beispiel auf dieser Seite sind der relevante Nachweis fuer Nutzer.

Praktische Verwendung

Verwenden Sie diese Form in eigenstaendigen .asm-Dateien oder in den ASM-Pfaden, die PBXB64 durch denselben Parser fuehrt. Halten Sie Testdateien klein: ein Label, die betreffende Direktive oder Instruktion, und ein klarer Rueckgabewert erleichtern die Diagnose bei Encoder-, Relocation- oder Linkfehlern. Wenn die Form externe Symbole, Datenabschnitte oder Makros verwendet, sollte der Test auch zeigen, dass die erzeugte Objektdatei erfolgreich gelinkt wird.

Verifiziertes Beispiel

Abgedeckt durch tests/asm/test_data_directives.asm in der ASM-Validierungsmatrix.

Die genannte Testdatei ist der konkrete Nachweis fuer diese Seite. Bei Erweiterungen sollte zuerst ein fokussierter ASM-Test ergaenzt werden, danach die Seite aktualisiert und zuletzt die ASM-Matrix erneut ausgefuehrt werden. So bleibt die Hilfedokumentation an reproduzierbares Compilerverhalten gebunden.

Grenzen

Diese Seite beschreibt die PBXB64-Assembler-Teilmenge aus Lexer, Parser, Makroexpander, Encoder und Object-Builder. Nicht jede NASM/MASM-Direktive ist implementiert.

Siehe auch

  • ASM Language Overview
  • Assembler Directives
  • Addressing Modes

← Back

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


ASM .dword / .dd / .long - 32-Bit-Daten ausgeben — PBXB64 Help

Startseite › x64 Backend › ASM Source Forms and Directives › ASM .dword / .dd / .long - 32-Bit-Daten ausgeben — PBXB64 Help
Hilfe zum PBXB64-Compiler

ASM .dword / .dd / .long - 32-Bit-Daten ausgeben

Category: Assembly

PBXB64 Status: [CERTIFIED TESTED]

Syntax

.dd 0x12345678

Beschreibung

Gibt 32-Bit-Datenwerte und, wo zutreffend, 32-Bit-Adress-Relocations aus.

Nutzerbeleg: Die Syntax und das fokussierte ASM-Beispiel auf dieser Seite sind der relevante Nachweis fuer Nutzer.

Praktische Verwendung

Verwenden Sie diese Form in eigenstaendigen .asm-Dateien oder in den ASM-Pfaden, die PBXB64 durch denselben Parser fuehrt. Halten Sie Testdateien klein: ein Label, die betreffende Direktive oder Instruktion, und ein klarer Rueckgabewert erleichtern die Diagnose bei Encoder-, Relocation- oder Linkfehlern. Wenn die Form externe Symbole, Datenabschnitte oder Makros verwendet, sollte der Test auch zeigen, dass die erzeugte Objektdatei erfolgreich gelinkt wird.

Verifiziertes Beispiel

Abgedeckt durch tests/asm/test_data_directives.asm in der ASM-Validierungsmatrix.

Die genannte Testdatei ist der konkrete Nachweis fuer diese Seite. Bei Erweiterungen sollte zuerst ein fokussierter ASM-Test ergaenzt werden, danach die Seite aktualisiert und zuletzt die ASM-Matrix erneut ausgefuehrt werden. So bleibt die Hilfedokumentation an reproduzierbares Compilerverhalten gebunden.

Grenzen

Diese Seite beschreibt die PBXB64-Assembler-Teilmenge aus Lexer, Parser, Makroexpander, Encoder und Object-Builder. Nicht jede NASM/MASM-Direktive ist implementiert.

Siehe auch

  • ASM Language Overview
  • Assembler Directives
  • Addressing Modes

← Back

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


ASM .qword / .dq - 64-Bit-Daten ausgeben — PBXB64 Help

Startseite › x64 Backend › ASM Source Forms and Directives › ASM .qword / .dq - 64-Bit-Daten ausgeben — PBXB64 Help
Hilfe zum PBXB64-Compiler

ASM .qword / .dq - 64-Bit-Daten ausgeben

Category: Assembly

PBXB64 Status: [CERTIFIED TESTED]

Syntax

.dq 0x1122334455667788

Beschreibung

Gibt 64-Bit-Datenwerte und, wo zutreffend, 64-Bit-Adress-Relocations aus.

Nutzerbeleg: Die Syntax und das fokussierte ASM-Beispiel auf dieser Seite sind der relevante Nachweis fuer Nutzer.

Praktische Verwendung

Verwenden Sie diese Form in eigenstaendigen .asm-Dateien oder in den ASM-Pfaden, die PBXB64 durch denselben Parser fuehrt. Halten Sie Testdateien klein: ein Label, die betreffende Direktive oder Instruktion, und ein klarer Rueckgabewert erleichtern die Diagnose bei Encoder-, Relocation- oder Linkfehlern. Wenn die Form externe Symbole, Datenabschnitte oder Makros verwendet, sollte der Test auch zeigen, dass die erzeugte Objektdatei erfolgreich gelinkt wird.

Verifiziertes Beispiel

Abgedeckt durch tests/asm/test_data_directives.asm in der ASM-Validierungsmatrix.

Die genannte Testdatei ist der konkrete Nachweis fuer diese Seite. Bei Erweiterungen sollte zuerst ein fokussierter ASM-Test ergaenzt werden, danach die Seite aktualisiert und zuletzt die ASM-Matrix erneut ausgefuehrt werden. So bleibt die Hilfedokumentation an reproduzierbares Compilerverhalten gebunden.

Grenzen

Diese Seite beschreibt die PBXB64-Assembler-Teilmenge aus Lexer, Parser, Makroexpander, Encoder und Object-Builder. Nicht jede NASM/MASM-Direktive ist implementiert.

Siehe auch

  • ASM Language Overview
  • Assembler Directives
  • Addressing Modes

← Back

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


ASM .ascii - Rohe Stringbytes ausgeben — PBXB64 Help

Startseite › x64 Backend › ASM Source Forms and Directives › ASM .ascii - Rohe Stringbytes ausgeben — PBXB64 Help
Hilfe zum PBXB64-Compiler

ASM .ascii - Rohe Stringbytes ausgeben

Category: Assembly

PBXB64 Status: [CERTIFIED TESTED]

Syntax

.ascii "Hello"

Beschreibung

Gibt die Bytes eines Stringliterals ohne Terminator aus.

Nutzerbeleg: Die Syntax und das fokussierte ASM-Beispiel auf dieser Seite sind der relevante Nachweis fuer Nutzer.

Praktische Verwendung

Verwenden Sie diese Form in eigenstaendigen .asm-Dateien oder in den ASM-Pfaden, die PBXB64 durch denselben Parser fuehrt. Halten Sie Testdateien klein: ein Label, die betreffende Direktive oder Instruktion, und ein klarer Rueckgabewert erleichtern die Diagnose bei Encoder-, Relocation- oder Linkfehlern. Wenn die Form externe Symbole, Datenabschnitte oder Makros verwendet, sollte der Test auch zeigen, dass die erzeugte Objektdatei erfolgreich gelinkt wird.

Verifiziertes Beispiel

Abgedeckt durch tests/asm/test_data_directives.asm in der ASM-Validierungsmatrix.

Die genannte Testdatei ist der konkrete Nachweis fuer diese Seite. Bei Erweiterungen sollte zuerst ein fokussierter ASM-Test ergaenzt werden, danach die Seite aktualisiert und zuletzt die ASM-Matrix erneut ausgefuehrt werden. So bleibt die Hilfedokumentation an reproduzierbares Compilerverhalten gebunden.

Grenzen

Diese Seite beschreibt die PBXB64-Assembler-Teilmenge aus Lexer, Parser, Makroexpander, Encoder und Object-Builder. Nicht jede NASM/MASM-Direktive ist implementiert.

Siehe auch

  • ASM Language Overview
  • Assembler Directives
  • Addressing Modes

← Back

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


ASM .asciz / .string - NUL-terminierten String ausgeben — PBXB64 Help

Startseite › x64 Backend › ASM Source Forms and Directives › ASM .asciz / .string - NUL-terminierten String ausgeben — PBXB64 Help
Hilfe zum PBXB64-Compiler

ASM .asciz / .string - NUL-terminierten String ausgeben

Category: Assembly

PBXB64 Status: [CERTIFIED TESTED]

Syntax

.asciz "World"

Beschreibung

Gibt Stringbytes gefolgt von einem abschliessenden Nullbyte aus.

Nutzerbeleg: Die Syntax und das fokussierte ASM-Beispiel auf dieser Seite sind der relevante Nachweis fuer Nutzer.

Praktische Verwendung

Verwenden Sie diese Form in eigenstaendigen .asm-Dateien oder in den ASM-Pfaden, die PBXB64 durch denselben Parser fuehrt. Halten Sie Testdateien klein: ein Label, die betreffende Direktive oder Instruktion, und ein klarer Rueckgabewert erleichtern die Diagnose bei Encoder-, Relocation- oder Linkfehlern. Wenn die Form externe Symbole, Datenabschnitte oder Makros verwendet, sollte der Test auch zeigen, dass die erzeugte Objektdatei erfolgreich gelinkt wird.

Verifiziertes Beispiel

Abgedeckt durch tests/asm/test_data_directives.asm in der ASM-Validierungsmatrix.

Die genannte Testdatei ist der konkrete Nachweis fuer diese Seite. Bei Erweiterungen sollte zuerst ein fokussierter ASM-Test ergaenzt werden, danach die Seite aktualisiert und zuletzt die ASM-Matrix erneut ausgefuehrt werden. So bleibt die Hilfedokumentation an reproduzierbares Compilerverhalten gebunden.

Grenzen

Diese Seite beschreibt die PBXB64-Assembler-Teilmenge aus Lexer, Parser, Makroexpander, Encoder und Object-Builder. Nicht jede NASM/MASM-Direktive ist implementiert.

Siehe auch

  • ASM Language Overview
  • Assembler Directives
  • Addressing Modes

← Back

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


ASM .unicode - UTF-16-Text ausgeben — PBXB64 Help

Startseite › x64 Backend › ASM Source Forms and Directives › ASM .unicode - UTF-16-Text ausgeben — PBXB64 Help
Hilfe zum PBXB64-Compiler

ASM .unicode - UTF-16-Text ausgeben

Category: Assembly

PBXB64 Status: [CERTIFIED TESTED]

Syntax

.unicode "Hi"

Beschreibung

Gibt 16-Bit-Zeicheneinheiten fuer ein Stringliteral in der aktuellen Section aus.

Nutzerbeleg: Die Syntax und das fokussierte ASM-Beispiel auf dieser Seite sind der relevante Nachweis fuer Nutzer.

Praktische Verwendung

Verwenden Sie diese Form in eigenstaendigen .asm-Dateien oder in den ASM-Pfaden, die PBXB64 durch denselben Parser fuehrt. Halten Sie Testdateien klein: ein Label, die betreffende Direktive oder Instruktion, und ein klarer Rueckgabewert erleichtern die Diagnose bei Encoder-, Relocation- oder Linkfehlern. Wenn die Form externe Symbole, Datenabschnitte oder Makros verwendet, sollte der Test auch zeigen, dass die erzeugte Objektdatei erfolgreich gelinkt wird.

Verifiziertes Beispiel

Abgedeckt durch tests/asm/test_data_directives.asm in der ASM-Validierungsmatrix.

Die genannte Testdatei ist der konkrete Nachweis fuer diese Seite. Bei Erweiterungen sollte zuerst ein fokussierter ASM-Test ergaenzt werden, danach die Seite aktualisiert und zuletzt die ASM-Matrix erneut ausgefuehrt werden. So bleibt die Hilfedokumentation an reproduzierbares Compilerverhalten gebunden.

Grenzen

Diese Seite beschreibt die PBXB64-Assembler-Teilmenge aus Lexer, Parser, Makroexpander, Encoder und Object-Builder. Nicht jede NASM/MASM-Direktive ist implementiert.

Siehe auch

  • ASM Language Overview
  • Assembler Directives
  • Addressing Modes

← Back

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


ASM label: - Symbolposition definieren — PBXB64 Help

Startseite › x64 Backend › ASM Source Forms and Directives › ASM label: - Symbolposition definieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

ASM label: - Symbolposition definieren

Category: Assembly

PBXB64 Status: [CERTIFIED TESTED]

Syntax

start:

Beschreibung

Definiert ein Symbol am aktuellen Section-Offset. Labels koennen Sprungziele, exportierte Globals, Datenadressen oder Relocation-Ziele sein.

Nutzerbeleg: Die Syntax und das fokussierte ASM-Beispiel auf dieser Seite sind der relevante Nachweis fuer Nutzer.

Praktische Verwendung

Verwenden Sie diese Form in eigenstaendigen .asm-Dateien oder in den ASM-Pfaden, die PBXB64 durch denselben Parser fuehrt. Halten Sie Testdateien klein: ein Label, die betreffende Direktive oder Instruktion, und ein klarer Rueckgabewert erleichtern die Diagnose bei Encoder-, Relocation- oder Linkfehlern. Wenn die Form externe Symbole, Datenabschnitte oder Makros verwendet, sollte der Test auch zeigen, dass die erzeugte Objektdatei erfolgreich gelinkt wird.

Verifiziertes Beispiel

Abgedeckt durch tests/asm/test_text_section.asm in der ASM-Validierungsmatrix.

Die genannte Testdatei ist der konkrete Nachweis fuer diese Seite. Bei Erweiterungen sollte zuerst ein fokussierter ASM-Test ergaenzt werden, danach die Seite aktualisiert und zuletzt die ASM-Matrix erneut ausgefuehrt werden. So bleibt die Hilfedokumentation an reproduzierbares Compilerverhalten gebunden.

Grenzen

Diese Seite beschreibt die PBXB64-Assembler-Teilmenge aus Lexer, Parser, Makroexpander, Encoder und Object-Builder. Nicht jede NASM/MASM-Direktive ist implementiert.

Siehe auch

  • ASM Language Overview
  • Assembler Directives
  • Addressing Modes

← Back

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.


ASM 1: / 1b / 1f - Numerische lokale Labels verwenden — PBXB64 Help

Startseite › x64 Backend › ASM Source Forms and Directives › ASM 1: / 1b / 1f - Numerische lokale Labels verwenden — PBXB64 Help
Hilfe zum PBXB64-Compiler

ASM 1: / 1b / 1f - Numerische lokale Labels verwenden

Category: Assembly

PBXB64 Status: [CERTIFIED TESTED]

Syntax

1:
    jl 1b

Beschreibung

Unterstuetzt numerische lokale Labels und Rueckwaerts-/Vorwaertsreferenzen nach der Makroexpansion. Der Makroexpander schreibt sie in eindeutige interne Labels um.

Nutzerbeleg: Die Syntax und das fokussierte ASM-Beispiel auf dieser Seite sind der relevante Nachweis fuer Nutzer.

Praktische Verwendung

Verwenden Sie diese Form in eigenstaendigen .asm-Dateien oder in den ASM-Pfaden, die PBXB64 durch denselben Parser fuehrt. Halten Sie Testdateien klein: ein Label, die betreffende Direktive oder Instruktion, und ein klarer Rueckgabewert erleichtern die Diagnose bei Encoder-, Relocation- oder Linkfehlern. Wenn die Form externe Symbole, Datenabschnitte oder Makros verwendet, sollte der Test auch zeigen, dass die erzeugte Objektdatei erfolgreich gelinkt wird.

Verifiziertes Beispiel

Abgedeckt durch tests/asm/test_local_labels.asm in der ASM-Validierungsmatrix.

Die genannte Testdatei ist der konkrete Nachweis fuer diese Seite. Bei Erweiterungen sollte zuerst ein fokussierter ASM-Test ergaenzt werden, danach die Seite aktualisiert und zuletzt die ASM-Matrix erneut ausgefuehrt werden. So bleibt die Hilfedokumentation an reproduzierbares Compilerverhalten gebunden.

Grenzen

Diese Seite beschreibt die PBXB64-Assembler-Teilmenge aus Lexer, Parser, Makroexpander, Encoder und Object-Builder. Nicht jede NASM/MASM-Direktive ist implementiert.

Siehe auch

  • ASM Language Overview
  • Assembler Directives
  • Addressing Modes

← Back

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.


ASM .macro / .endm - Makro definieren — PBXB64 Help

Startseite › x64 Backend › ASM Source Forms and Directives › ASM .macro / .endm - Makro definieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

ASM .macro / .endm - Makro definieren

Category: Assembly

PBXB64 Status: [CERTIFIED TESTED]

Syntax

.macro PROLOGUE size
    sub rsp, \size
.endm

Beschreibung

Definiert ein parametrisiertes Quellmakro. Makroargumente werden ueber Backslash-Parameterreferenzen im Makrokoerper ersetzt.

Nutzerbeleg: Die Syntax und das fokussierte ASM-Beispiel auf dieser Seite sind der relevante Nachweis fuer Nutzer.

Praktische Verwendung

Verwenden Sie diese Form in eigenstaendigen .asm-Dateien oder in den ASM-Pfaden, die PBXB64 durch denselben Parser fuehrt. Halten Sie Testdateien klein: ein Label, die betreffende Direktive oder Instruktion, und ein klarer Rueckgabewert erleichtern die Diagnose bei Encoder-, Relocation- oder Linkfehlern. Wenn die Form externe Symbole, Datenabschnitte oder Makros verwendet, sollte der Test auch zeigen, dass die erzeugte Objektdatei erfolgreich gelinkt wird.

Verifiziertes Beispiel

Abgedeckt durch examples/asm/test_macro_basic.asm in der ASM-Validierungsmatrix.

Die genannte Testdatei ist der konkrete Nachweis fuer diese Seite. Bei Erweiterungen sollte zuerst ein fokussierter ASM-Test ergaenzt werden, danach die Seite aktualisiert und zuletzt die ASM-Matrix erneut ausgefuehrt werden. So bleibt die Hilfedokumentation an reproduzierbares Compilerverhalten gebunden.

Grenzen

Diese Seite beschreibt die PBXB64-Assembler-Teilmenge aus Lexer, Parser, Makroexpander, Encoder und Object-Builder. Nicht jede NASM/MASM-Direktive ist implementiert.

Siehe auch

  • ASM Language Overview
  • Assembler Directives
  • Addressing Modes

← Back

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


ASM macro call - Makroaufruf expandieren — PBXB64 Help

Startseite › x64 Backend › ASM Source Forms and Directives › ASM macro call - Makroaufruf expandieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

ASM macro call - Makroaufruf expandieren

Category: Assembly

PBXB64 Status: [CERTIFIED TESTED]

Syntax

PROLOGUE 48

Beschreibung

Expandiert ein zuvor definiertes Makro und prueft die Argumentanzahl. Undefinierte Makronamen erzeugen Diagnosen statt stiller Ausgabe.

Nutzerbeleg: Die Syntax und das fokussierte ASM-Beispiel auf dieser Seite sind der relevante Nachweis fuer Nutzer.

Praktische Verwendung

Verwenden Sie diese Form in eigenstaendigen .asm-Dateien oder in den ASM-Pfaden, die PBXB64 durch denselben Parser fuehrt. Halten Sie Testdateien klein: ein Label, die betreffende Direktive oder Instruktion, und ein klarer Rueckgabewert erleichtern die Diagnose bei Encoder-, Relocation- oder Linkfehlern. Wenn die Form externe Symbole, Datenabschnitte oder Makros verwendet, sollte der Test auch zeigen, dass die erzeugte Objektdatei erfolgreich gelinkt wird.

Verifiziertes Beispiel

Abgedeckt durch examples/asm/test_macro_basic.asm in der ASM-Validierungsmatrix.

Die genannte Testdatei ist der konkrete Nachweis fuer diese Seite. Bei Erweiterungen sollte zuerst ein fokussierter ASM-Test ergaenzt werden, danach die Seite aktualisiert und zuletzt die ASM-Matrix erneut ausgefuehrt werden. So bleibt die Hilfedokumentation an reproduzierbares Compilerverhalten gebunden.

Grenzen

Diese Seite beschreibt die PBXB64-Assembler-Teilmenge aus Lexer, Parser, Makroexpander, Encoder und Object-Builder. Nicht jede NASM/MASM-Direktive ist implementiert.

Siehe auch

  • ASM Language Overview
  • Assembler Directives
  • Addressing Modes

← Back

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.


ASM .equ / .set - Equate definieren — PBXB64 Help

Startseite › x64 Backend › ASM Source Forms and Directives › ASM .equ / .set - Equate definieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

ASM .equ / .set - Equate definieren

Category: Assembly

PBXB64 Status: [CERTIFIED TESTED]

Syntax

.equ SYS_EXIT 60

Beschreibung

Definiert ein Text-/Integer-Equate, das spaeter ersetzt werden kann, einschliesslich arithmetischer Ausdruecke fuer Wiederholungszaehler.

Nutzerbeleg: Die Syntax und das fokussierte ASM-Beispiel auf dieser Seite sind der relevante Nachweis fuer Nutzer.

Praktische Verwendung

Verwenden Sie diese Form in eigenstaendigen .asm-Dateien oder in den ASM-Pfaden, die PBXB64 durch denselben Parser fuehrt. Halten Sie Testdateien klein: ein Label, die betreffende Direktive oder Instruktion, und ein klarer Rueckgabewert erleichtern die Diagnose bei Encoder-, Relocation- oder Linkfehlern. Wenn die Form externe Symbole, Datenabschnitte oder Makros verwendet, sollte der Test auch zeigen, dass die erzeugte Objektdatei erfolgreich gelinkt wird.

Verifiziertes Beispiel

Abgedeckt durch examples/asm/test_macro_equ.asm in der ASM-Validierungsmatrix.

Die genannte Testdatei ist der konkrete Nachweis fuer diese Seite. Bei Erweiterungen sollte zuerst ein fokussierter ASM-Test ergaenzt werden, danach die Seite aktualisiert und zuletzt die ASM-Matrix erneut ausgefuehrt werden. So bleibt die Hilfedokumentation an reproduzierbares Compilerverhalten gebunden.

Grenzen

Diese Seite beschreibt die PBXB64-Assembler-Teilmenge aus Lexer, Parser, Makroexpander, Encoder und Object-Builder. Nicht jede NASM/MASM-Direktive ist implementiert.

Siehe auch

  • ASM Language Overview
  • Assembler Directives
  • Addressing Modes

← Back

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


ASM .rep / .endr - Quellblock wiederholen — PBXB64 Help

Startseite › x64 Backend › ASM Source Forms and Directives › ASM .rep / .endr - Quellblock wiederholen — PBXB64 Help
Hilfe zum PBXB64-Compiler

ASM .rep / .endr - Quellblock wiederholen

Category: Assembly

PBXB64 Status: [CERTIFIED TESTED]

Syntax

.rep 3
    nop
.endr

Beschreibung

Wiederholt einen Quellblock eine nichtnegative Anzahl von Malen. Zaehler duerfen Literale, Equates oder unterstuetzte arithmetische Ausdruecke verwenden.

Nutzerbeleg: Die Syntax und das fokussierte ASM-Beispiel auf dieser Seite sind der relevante Nachweis fuer Nutzer.

Praktische Verwendung

Verwenden Sie diese Form in eigenstaendigen .asm-Dateien oder in den ASM-Pfaden, die PBXB64 durch denselben Parser fuehrt. Halten Sie Testdateien klein: ein Label, die betreffende Direktive oder Instruktion, und ein klarer Rueckgabewert erleichtern die Diagnose bei Encoder-, Relocation- oder Linkfehlern. Wenn die Form externe Symbole, Datenabschnitte oder Makros verwendet, sollte der Test auch zeigen, dass die erzeugte Objektdatei erfolgreich gelinkt wird.

Verifiziertes Beispiel

Abgedeckt durch examples/asm/test_rep_basic.asm in der ASM-Validierungsmatrix.

Die genannte Testdatei ist der konkrete Nachweis fuer diese Seite. Bei Erweiterungen sollte zuerst ein fokussierter ASM-Test ergaenzt werden, danach die Seite aktualisiert und zuletzt die ASM-Matrix erneut ausgefuehrt werden. So bleibt die Hilfedokumentation an reproduzierbares Compilerverhalten gebunden.

Grenzen

Diese Seite beschreibt die PBXB64-Assembler-Teilmenge aus Lexer, Parser, Makroexpander, Encoder und Object-Builder. Nicht jede NASM/MASM-Direktive ist implementiert.

Siehe auch

  • ASM Language Overview
  • Assembler Directives
  • Addressing Modes

← Back

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.


ASM [base+index*scale+disp] - Speicher adressieren — PBXB64 Help

Startseite › x64 Backend › ASM Source Forms and Directives › ASM [base+index*scale+disp] - Speicher adressieren — PBXB64 Help
Hilfe zum PBXB64-Compiler

ASM [base+index*scale+disp] - Speicher adressieren

Category: Assembly

PBXB64 Status: [CERTIFIED TESTED]

Syntax

mov rax, [rbp-8]

Beschreibung

Parst x64-Speicheroperanden mit Basis, Index, Skalierung, Displacement, Symbol, Addend und RIP-relativen Formen, soweit vom Encoder unterstuetzt.

Nutzerbeleg: Die Syntax und das fokussierte ASM-Beispiel auf dieser Seite sind der relevante Nachweis fuer Nutzer.

Praktische Verwendung

Verwenden Sie diese Form in eigenstaendigen .asm-Dateien oder in den ASM-Pfaden, die PBXB64 durch denselben Parser fuehrt. Halten Sie Testdateien klein: ein Label, die betreffende Direktive oder Instruktion, und ein klarer Rueckgabewert erleichtern die Diagnose bei Encoder-, Relocation- oder Linkfehlern. Wenn die Form externe Symbole, Datenabschnitte oder Makros verwendet, sollte der Test auch zeigen, dass die erzeugte Objektdatei erfolgreich gelinkt wird.

Verifiziertes Beispiel

Abgedeckt durch tests/asm/test_data_directives.asm in der ASM-Validierungsmatrix.

Die genannte Testdatei ist der konkrete Nachweis fuer diese Seite. Bei Erweiterungen sollte zuerst ein fokussierter ASM-Test ergaenzt werden, danach die Seite aktualisiert und zuletzt die ASM-Matrix erneut ausgefuehrt werden. So bleibt die Hilfedokumentation an reproduzierbares Compilerverhalten gebunden.

Grenzen

Diese Seite beschreibt die PBXB64-Assembler-Teilmenge aus Lexer, Parser, Makroexpander, Encoder und Object-Builder. Nicht jede NASM/MASM-Direktive ist implementiert.

Siehe auch

  • ASM Language Overview
  • Assembler Directives
  • Addressing Modes

← Back

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.


Kern-GPR-Mnemonik

In diesem Abschnitt werden die vom PBXB64-Assembler unterstützten x86-64-General-Purpose-Register-Anweisungen (GPR) dokumentiert. Alle Anweisungen verwenden Intel-Syntax.

Datenbewegung

Gedächtnisstütze | Beschreibung | Operanden
MOV | Verschieben Sie Daten zwischen Registern, Speicher und Sofortdaten | reg/mem, reg/mem/imm
MOVZX | Bewegen Sie sich ohne Verlängerung | reg, reg/mem
MOVSX | Umzug mit Schilderverlängerung | reg, reg/mem
MOVSXD | Mit Vorzeichenerweiterung verschieben (32-Bit auf 64-Bit) | reg64, reg/mem32
CMOVcc | Bedingter Umzug (siehe unten) | reg, reg/mem
XCHG | Daten zwischen Operanden austauschen | reg, reg/mem
BSWAP | Byte-Swap (Reverse Endianness) | reg32/64
MOVBE | Verschieben mit Big-Endian-Konvertierung (Laden/Speichern) | reg, mem / mem, reg
MOVABS | 64-Bit-Absolutwert verschieben (Alias ​​auf MOV mit imm64) | reg64, imm64

Bedingte Bewegungen (CMOVcc)

Gedächtnisstütze | Zustand | Flaggen
CMOVA / CMOVNBE | Oben (nicht unten oder gleich) | CF=0 und ZF=0
CMOVAE / CMOVNB | Oben oder gleich (nicht unten) | CF=0
CMOVB / CMOVNAE | Unten (nicht darüber oder gleich) | CF=1
CMOVBE / CMOVNA | Unterhalb oder gleich (nicht darüber) | CF=1 oder ZF=1
CMOVE / CMOVZ | Gleich (Null) | ZF=1
CMOVNE / CMOVNZ | Ungleich (nicht Null) | ZF=0
CMOVG / CMOVNLE | Größer (mit Vorzeichen, nicht kleiner oder gleich) | ZF=0 und SF=OF
CMOVGE / CMOVNL | Größer oder gleich (mit Vorzeichen, nicht kleiner) | SF=OF
CMOVL / CMOVNGE | Kleiner (mit Vorzeichen, nicht größer oder gleich) | SF!=OF
CMOVLE / CMOVNG | Kleiner oder gleich (mit Vorzeichen, nicht größer) | ZF=1 oder SF!=OF
CMOVO | Überlauf | OF=1
CMOVNO | Nicht überlaufen | OF=0
CMOVS | Vorzeichen (negativ) | SF=1
CMOVNS | Nicht signieren (nicht negativ) | SF=0
CMOVP / CMOVPE | Parität (gerade) | PF=1
CMOVNP / CMOVPO | Keine Parität (ungerade) | PF=0

Arithmetik

Gedächtnisstütze | Beschreibung | Operanden
ADD | Ganzzahlige Addition | reg/mem, reg/mem/imm
ADC | Mit Carry hinzufügen | reg/mem, reg/mem/imm
SUB | Ganzzahlige Subtraktion | reg/mem, reg/mem/imm
SBB | Mit „borgen“ subtrahieren | reg/mem, reg/mem/imm
MUL | Vorzeichenlose Multiplikation (r/m * AL/AX/EAX/RAX) | reg/mem
IMUL | Vorzeichenbehaftete Multiplikation (mehrere Formen) | reg/mem / reg, reg/mem / reg, reg/mem, imm
DIV | Division ohne Vorzeichen (r/m dividiert AX/EAX/RAX) | reg/mem
IDIV | Unterzeichnete Kluft | reg/mem
INC | Erhöhen Sie um 1 | reg/mem
DEC | Um 1 verringern | reg/mem
NEG | Negieren (Zweierkomplement) | reg/mem
CMP | Vergleichen (setzt Flags, kein Ergebnis) | reg/mem, reg/mem/imm
TEST | Logischer Vergleich (UND setzt Flags) | reg/mem, reg/mem/imm

DerMULUndDIVAnweisungen verwenden implizite Quell-/Zielregister:

Operandengröße | MUL: r/m * | Ergebnis (Produkt) | DIV: r/m dividiert | Quotient | Rest
8-Bit | AL | AXT | AXT | AL | AH
16-Bit | AXT | DX:AX | DX:AX | AXT | DX
32-Bit | EAX | EDX:EAX | EDX:EAX | EAX | EDX
64-Bit | RAX | RDX:RAX | RDX:RAX | RAX | RDX

DerIMULDie Anweisung hat drei Formen:

  • Einzelner Operand: imul r/m— gleiches implizites Verhalten wie MUL
  • Zwei Operanden: imul reg, r/m— reg = reg * r/m
  • Drei Operanden: imul reg, r/m, imm— reg = r/m * imm

Logisch / Bitweise

Gedächtnisstütze | Beschreibung | Operanden
AND | Bitwise AND | reg/mem, reg/mem/imm
OR | Bitwise OR | reg/mem, reg/mem/imm
XOR | Bitwise XOR | reg/mem, reg/mem/imm
NOT | Bitweises NICHT (Einzelkomplement) | reg/mem
ANDN | Bitweises UND-NICHT (BMI1) | reg, reg, reg/mem

Verschieben / Drehen

Gedächtnisstütze | Beschreibung | Operanden
SHL / SAL | Logisch/arithmetisch nach links verschieben | reg/mem, imm8/CL
SHR | Logisch nach rechts verschieben | reg/mem, imm8/CL
SAR | Arithmetik nach rechts verschieben (vorzeichenerhaltend) | reg/mem, imm8/CL
ROL | Nach links drehen | reg/mem, imm8/CL
ROR | Nach rechts drehen | reg/mem, imm8/CL
RCL | Durch Tragen nach links drehen | reg/mem, imm8/CL
RCR | Nach rechts drehen durch Tragen | reg/mem, imm8/CL
SHLD | Doppelte Präzisionsverschiebung nach links | reg/mem, reg, imm8/CL
SHRD | Doppelte Präzisionsverschiebung nach rechts | reg/mem, reg, imm8/CL

Stapeloperationen

Gedächtnisstütze | Beschreibung | Operanden
PUSH | Auf Stapel schieben (RSP um 8 in x64 dekrementiert) | reg/mem/imm
POP | Pop vom Stapel (RSP um 8 in x64 erhöht) | reg/mem
PUSHA / PUSHAD | Alle GPRs pushen (nicht gültig im x64-Modus) | keiner
POPA / POPAD | Pop alle GPRs (nicht gültig im x64-Modus) | keiner
PUSHF / PUSHFD | Drücken Sie EFLAGS/RFLAGS | keiner
POPF / POPFD | Pop EFLAGS/RFLAGS | keiner
PUSHQ | Push QWORD (impliziter 64-Bit-Push) | imm32
ENTER | Stapelrahmen erstellen (push rbp, mov rbp, rsp; sub rsp, X) | imm16, imm8
LEAVE | Stack-Frame zerstören (mov rsp, rbp; pop rbp) | keiner
Notiz:Im x64-ModusPUSHUndPOPArbeiten Sie immer mit 64-Bit-Werten (RSP wird um 8 angepasst). 32-Bit- und 16-Bit-Push/Pop sind in x64 nicht kodierbar.PUSHA/POPAsind nicht verfügbar.

Kontrollübertragung

Bedingungslose Sprünge

Gedächtnisstütze | Beschreibung | Operanden
JMP | Bedingungsloser Sprung | Etikett/Reg/Speicher
CALL | Aufrufvorgang (Push-Rücksprungadresse) | Etikett/Reg/Speicher
RET | Rückkehr vom Verfahren (Pops-Rücksprungadresse) | none / imm16 (Pop N Bytes)
RETF | Far Return (wird in x64 nicht verwendet) | keine / imm16

Bedingte Sprünge

Gedächtnisstütze | Zustand | Flaggen
JA / JNBE | Springe, wenn oben | CF=0 und ZF=0
JAE / JNB / JNC | Springe, wenn höher oder gleich | CF=0
JB / JNAE / JC | Springe, wenn unten | CF=1
JBE / JNA | Springe, wenn weniger als oder gleich | CF=1 oder ZF=1
JE / JZ | Bei Gleichheit springen | ZF=1
JNE / JNZ | Springe, wenn nicht gleich | ZF=0
JG / JNLE | Springe, wenn größer (vorzeichenbehaftet) | ZF=0 und SF=OF
JGE / JNL | Springen, wenn größer oder gleich (mit Vorzeichen) | SF=OF
JL / JNGE | Springe, wenn weniger (vorzeichenbehaftet) | SF!=OF
JLE / JNG | Springen, wenn kleiner oder gleich (mit Vorzeichen) | ZF=1 oder SF!=OF
JO | Bei Überlauf springen | OF=1
JNO | Springe, wenn nicht überlaufen | OF=0
JS | Springe, wenn Vorzeichen (negativ) | SF=1
JNS | Springen Sie, wenn Sie nicht unterschreiben | SF=0
JP / JPE | Springe, wenn die Parität gerade ist | PF=1
JNP / JPO | Springe, wenn die Parität ungerade ist | PF=0
JCXZ / JECXZ / JRCXZ | Springe, wenn CX/ECX/RCX Null ist | CX/ECX/RCX=0

Schleifenanweisungen

Gedächtnisstütze | Beschreibung | Operanden
LOOP | CX/ECX/RCX dekrementieren, springen, wenn nicht Null | Etikett
LOOPE / LOOPZ | LOOP während gleich/null | Etikett
LOOPNE / LOOPNZ | LOOP solange ungleich/nicht Null | Etikett

String-Operationen

Gedächtnisstütze | Beschreibung | Operanden
MOVS / MOVSB / MOVSW / MOVSD / MOVSQ | Zeichenfolge verschieben (RSI→RDI, nach Größe anpassen) | keiner
CMPS / CMPSB / CMPSW / CMPSD / CMPSQ | Zeichenfolge vergleichen (RSI vs. RDI) | keiner
SCAS / SCASB / SCASW / SCASD / SCASQ | Scan-String (vergleiche AL/AX/EAX/RAX mit [RDI]) | keiner
LODS / LODSB / LODSW / LODSD / LODSQ | String laden ([RSI]→AL/AX/EAX/RAX) | keiner
STOS / STOSB / STOSW / STOSD / STOSQ | Zeichenfolge speichern (AL/AX/EAX/RAX→[RDI]) | keiner

String-Anweisungen werden häufig mit dem kombiniertREPPräfix für Blockoperationen:

cld                     ; clear direction flag (forward)
rep movsb               ; copy RCX bytes from RSI to RDI
rep stosd               ; fill RCX dwords with EAX
repne scasb             ; scan for AL in [RDI], RCX times

Flaggenkontrolle

Gedächtnisstütze | Beschreibung
STC | Carry-Flag setzen (CF=1)
CLC | Clear Carry Flag (CF=0)
CMC | Komplement-Carry-Flag (CF=!CF)
STD | Richtungsflag setzen (DF=1)
CLD | Flag „Richtung löschen“ (DF=0)
STI | Interrupt-Flag setzen (IF=1)
CLI | Interrupt-Flag löschen (IF=0)
LAHF | Flags in AH laden (SF:ZF:0:AF:0:PF:1:CF)
SAHF | Speichern Sie AH in Flags
SAHF | Speichern Sie AH im unteren RFLAGS-Byte

Bit-Manipulation

Gedächtnisstütze | Beschreibung | Operanden
BT | Bittest (speichert Bit an Position in CF) | reg/mem, reg/imm
BTS | Bit testen und einstellen | reg/mem, reg/imm
BTR | Bittest und Reset | reg/mem, reg/imm
BTC | Bittest und Ergänzung | reg/mem, reg/imm
BSF | Bit-Scan vorwärts (niedrigstes gesetztes Bit) | reg, reg/mem
BSR | Bit-Scan rückwärts (höchstes gesetztes Bit) | reg, reg/mem
POPCNT | Bevölkerungszahl (Anzahl der gesetzten Bits) – SSE4.2 | reg, reg/mem
LZCNT | Führende Nullen zählen – BMI1 (über F3 0F BD) | reg, reg/mem
TZCNT | Nachgestellte Nullen zählen – BMI1 | reg, reg/mem

Tauschen / Konvertieren

Gedächtnisstütze | Beschreibung | Operanden
XADD | Austauschen und hinzufügen (atomar) | reg/mem, reg
CMPXCHG | Vergleichen und austauschen (atomar) | reg/mem, reg
CMPXCHG8B | Vergleichen und tauschen Sie 8 Bytes (atomar) aus | mem64
CMPXCHG16B | Vergleichen und tauschen Sie 16 Bytes (atomar, benötigt LOCK) | mem128
CBW / CWDE / CDQE | Konvertieren Sie Byte in Wort / Wort in Dword / Dword in Qword | keine (verwendet AL/AX/EAX)
CWD / CDQ / CQO | Konvertieren Sie Wort in Dword / Dword in Qword / Qword in Dqword (DX:AX / EDX:EAX / RDX:RAX) | keiner
CWDE | Wandeln Sie Wort (AX) in Doppelwort (EAX) mit Vorzeichenerweiterung um | keiner
CDQE | Doppelwort (EAX) in Quadwort (RAX) mit Vorzeichenerweiterung umwandeln | keiner

Atomar-/Sperrpräfix

DerLOCKDas Präfix macht bestimmte Anweisungen auf Multiprozessorsystemen atomar. Unterstützte Anweisungen:

lock add / lock adc / lock sub / lock sbb / lock and / lock or / lock xor
lock inc / lock dec / lock neg / lock not
lock xadd / lock cmpxchg / lock cmpxchg8b / lock cmpxchg16b
lock bts / lock btr / lock btc

Beispiel:

lock inc DWORD PTR [counter]       ; atomic increment
lock cmpxchg DWORD PTR [ptr], ecx   ; atomic compare-exchange

Legacy / Kompatibilität

Gedächtnisstütze | Beschreibung
AAA | ASCII-Anpassung nach Hinzufügung (nicht gültig in x64)
AAS | ASCII-Anpassung nach Subtraktion (nicht gültig in x64)
AAM | ASCII-Anpassung nach Multiplikation (nicht gültig in x64)
AAD | ASCII-Anpassung vor der Division (nicht gültig in x64)
DAA | Dezimalanpassung nach Addition (nicht gültig in x64)
DAS | Dezimalanpassung nach Subtraktion (nicht gültig in x64)
Notiz:Die ASCII- und Dezimal-Anpassungsanweisungen sind im x64-Modus nicht codierbar, der Assembler akzeptiert sie jedoch aus Gründen der Kompatibilität mit Legacy-Code auf Quellebene.

NOP und Multi-Byte-NOPs

Gedächtnisstütze | Codierung | Größe
NOP | 90 | 1 Byte
NOP(2 Byte) | 66 90 | 2 Bytes
NOP(3 Byte) | 0F 1F 00 | 3 Bytes
NOP(4 Byte) | 0F 1F 40 00 | 4 Bytes
NOP(5 Byte) | 0F 1F 44 00 00 | 5 Bytes
NOP(6 Byte) | 66 0F 1F 44 00 00 | 6 Bytes
NOP(7 Byte) | 0F 1F 80 00 00 00 00 | 7 Bytes
NOP(8 Byte) | 0F 1F 84 00 00 00 00 00 | 8 Byte
NOP(9 Byte) | 66 0F 1F 84 00 00 00 00 00 | 9 Bytes

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

← Cache-Steuerung / Prefetch-Mnemonik Nach oben AES / SHA / CLMUL / CRC32 Mnemonik →

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes


SSE/SSE2/SSE3/SSSE3/SSE4-Mnemonik

Startseite› SSE/SSE2/SSE3/SSSE3/SSE4-Mnemonik

SSE / SSE2 / SSE3 / SSSE3 / SSE4 Mnemonik

Alle Anweisungen der SSE-Familie arbeiten mit 128-Bit-XMM-Registern. PBXB64 unterstützt SSE bis SSE4.2 mit vollständiger Intel-Syntax.

SSE – Streaming von SIMD-Erweiterungen

Original SSE (KNI/Katmai neue Anleitung). Gleitkommaoperationen mit einfacher Genauigkeit auf XMM-Registern.

SSE-Datenbewegung

Gedächtnisstütze | Beschreibung | Operanden
MOVAPS | Ausgerichtetes, gepacktes Einzelstück verschieben (16-Byte-ausgerichtet) | xmm, xmm/mem128 / mem128, xmm
MOVUPS | Move unaligned packed single | xmm, xmm/mem128 / mem128, xmm
MOVSS | Move scalar single | xmm, xmm/mem32 / mem32, xmm
MOVLPS | Niedrig gepackte Single verschieben (untere 64 Bit) | xmm, mem64 / mem64, xmm
MOVHPS | Hochgepackte Single verschieben (obere 64 Bit) | xmm, mem64 / mem64, xmm
MOVLHPS | Bewegen Sie sich von unten nach oben einzeln | xmm, xmm
MOVHLPS | Bewegen Sie sich einzeln von oben nach unten | xmm, xmm
MOVMSKPS | Vorzeichenmaske nach GPR verschieben (4 Vorzeichenbits → GPR) | reg, xmm

SSE-gepackte Arithmetik (einfache Genauigkeit)

Gedächtnisstütze | Beschreibung | Operanden
ADDPS | Fügen Sie verpackte Single hinzu | xmm, xmm/mem128
ADDSS | Skalare Single hinzufügen | xmm, xmm/mem32
SUBPS | Gepackte Single subtrahieren | xmm, xmm/mem128
SUBSS | Subtrahieren Sie den Skalar einzeln | xmm, xmm/mem32
MULPS | Mehrfach gepackte Single | xmm, xmm/mem128
MULSS | Skalar-Single multiplizieren | xmm, xmm/mem32
DIVPS | Teilweise einzeln verpackt | xmm, xmm/mem128
DIVSS | Teilen Sie den Skalar einfach | xmm, xmm/mem32
SQRTPS | Quadratwurzelgepackte Single | xmm, xmm/mem128
SQRTSS | Quadratwurzel-Skalar-Single | xmm, xmm/mem32
RCPPS | Reziprok gepacktes Single (ungefähr) | xmm, xmm/mem128
RCPSS | Reziproker Skalar Single (ungefähr) | xmm, xmm/mem32
RSQRTPS | Reziproke Quadratwurzel gepackte Einzelzahl (ungefähr) | xmm, xmm/mem128
RSQRTSS | Reziproker Quadratwurzelskalar einfach (ungefähr) | xmm, xmm/mem32
MAXPS | Maximal gepacktes Einzelstück | xmm, xmm/mem128
MAXSS | Maximaler Skalar-Single | xmm, xmm/mem32
MINPS | Mindestens einzeln verpackt | xmm, xmm/mem128
MINSS | Minimaler Skalar-Single | xmm, xmm/mem32

SSE Logisch / Vergleich

Gedächtnisstütze | Beschreibung | Operanden
ANDPS | Bitwise AND of packed singles | xmm, xmm/mem128
ANDNPS | Bitwise AND-NOT of packed singles | xmm, xmm/mem128
ORPS | Bitwise OR of packed singles | xmm, xmm/mem128
XORPS | Bitwise XOR of packed singles | xmm, xmm/mem128
CMPPS | Vergleichen Sie gepackte Singles (imm8-Prädikat) | xmm, xmm/mem128, imm8
CMPSS | Skalare Single vergleichen (imm8-Prädikat) | xmm, xmm/mem32, imm8
COMISS | Vergleichen Sie geordnete Skalar-Singles (Setzt Flags) | xmm, xmm/mem32
UCOMISS | Ungeordnete Skalar-Single vergleichen (setzt Flags) | xmm, xmm/mem32

CMPPS/CMPSS-Direktprädikate:

Imm | Prädikat | Beschreibung
0 | EQ | Gleich
1 | LT | Weniger als
2 | LE | Kleiner oder gleich
3 | UNORD | Ungeordnet
4 | NEQ | Ungleich
5 | NLT | Nicht weniger als
6 | NLE | Nicht kleiner oder gleich
7 | ORD | Bestellt

SSE Mischen/Auspacken

Gedächtnisstütze | Beschreibung | Operanden
SHUFPS | Shuffle packed single | xmm, xmm/mem128, imm8
UNPCKHPS | Unpack high packed single | xmm, xmm/mem128
UNPCKLPS | Unpack low packed single | xmm, xmm/mem128

SSE-Steuerung

Gedächtnisstütze | Beschreibung
STMXCSR | MXCSR-Register speichern (Steuerung/Status)
LDMXCSR | MXCSR-Register laden
FXRSTOR | Stellen Sie den x87- und SSE-Status wieder her
FXSAVE | Speichern Sie den x87- und SSE-Status

SSE2 – Streaming von SIMD-Erweiterungen 2

Fügt Gleitkomma- und Ganzzahl-SIMD-Operationen mit doppelter Genauigkeit hinzu (MMX-ähnlich bei XMM).

SSE2 Arithmetik mit doppelter Genauigkeit

Gedächtnisstütze | Beschreibung | Operanden
ADDPD | Fügen Sie das verpackte Doppel hinzu | xmm, xmm/mem128
ADDSD | Skalardoppel hinzufügen | xmm, xmm/mem64
SUBPD | Subtrahieren Sie das gepackte Doppel | xmm, xmm/mem128
SUBSD | Subtrahiere das Skalardoppel | xmm, xmm/mem64
MULPD | Mehrfach gepacktes Doppeltes | xmm, xmm/mem128
MULSD | Skalar mit dem Doppelten multiplizieren | xmm, xmm/mem64
DIVPD | Doppelt verpackt teilen | xmm, xmm/mem128
DIVSD | Teilen Sie den Skalar durch das Doppelte | xmm, xmm/mem64
SQRTPS | Quadratwurzel gepackt (PS-Variante in SSE) | xmm, xmm/mem128
SQRTPD | Quadratwurzel doppelt gepackt | xmm, xmm/mem128
SQRTSD | Quadratwurzel-Skalar-Double | xmm, xmm/mem64
MAXPD | Maximal doppelt bepackt | xmm, xmm/mem128
MAXSD | Maximales Skalar-Double | xmm, xmm/mem64
MINPD | Mindestens doppelt verpackt | xmm, xmm/mem128
MINSD | Minimales Skalardoppel | xmm, xmm/mem64

SSE2-Datenbewegung

Gedächtnisstütze | Beschreibung | Operanden
MOVAPD | Move aligned packed double | xmm, xmm/mem128 / mem128, xmm
MOVUPD | Move unaligned packed double | xmm, xmm/mem128 / mem128, xmm
MOVSD | Move scalar double | xmm, xmm/mem64 / mem64, xmm
MOVLPD | Move low packed double | xmm, mem64 / mem64, xmm
MOVHPD | Move high packed double | xmm, mem64 / mem64, xmm
MOVMSKPD | Vorzeichenmaske nach GPR verschieben (2 Bits) | reg, xmm
MOVDQ2Q | Verschieben Sie XMM in das MMX-Register (niedriges Quadwort). | mm, xmm
MOVQ2DQ | MMX in das XMM-Register verschieben (niedriges Quadword) | xmm, mm

SSE2-Ganzzahloperationen (XMM)

Gedächtnisstütze | Beschreibung | Operanden
MOVD | Move doubleword to/from XMM | xmm, reg32/mem32 / reg32, xmm
MOVQ | Move quadword to/from XMM | xmm, reg64/mem64 / reg64/rm, xmm
MOVDQA | Ausgerichtetes Doppelquadwort verschieben (16-Byte-ausgerichtet) | xmm, xmm/mem128 / mem128, xmm
MOVDQU | Move unaligned double quadword | xmm, xmm/mem128 / mem128, xmm
PADDB | Fügen Sie gepackte Byte-Ganzzahlen hinzu | xmm, xmm/mem128
PADDW | Fügen Sie gepackte Wort-Ganzzahlen hinzu | xmm, xmm/mem128
PADDD | Fügen Sie gepackte Doppelwort-Ganzzahlen hinzu | xmm, xmm/mem128
PADDQ | Fügen Sie gepackte Quadword-Ganzzahlen hinzu | xmm, xmm/mem128
PSUBB | Subtrahieren Sie gepackte Byte-Ganzzahlen | xmm, xmm/mem128
PSUBW | Subtrahieren Sie ganze Zahlen gepackter Wörter | xmm, xmm/mem128
PSUBD | Subtrahieren Sie gepackte Doppelwort-Ganzzahlen | xmm, xmm/mem128
PSUBQ | Subtrahieren Sie gepackte Quadword-Ganzzahlen | xmm, xmm/mem128
PMULLW | Multiplizieren Sie gepackte Wort-Ganzzahlen (niedrige 16 Bits) | xmm, xmm/mem128
PMULHW | Multiplizieren Sie gepackte Wort-Ganzzahlen (hohe 16 Bits) | xmm, xmm/mem128
PMULHUW | Multiplizieren Sie gepackte Wort-Ganzzahlen (hohe 16 Bit, ohne Vorzeichen) | xmm, xmm/mem128
PMULUDQ | Multiplizieren Sie ein vorzeichenloses Doppelwort mit einem Quadwort | xmm, xmm/mem128
PMADDWD | Multiplizieren Sie das gepackte Wort und addieren Sie es zum Doppelwort | xmm, xmm/mem128
PSADBW | Sum of absolute differences | xmm, xmm/mem128

SSE2 Packed Integer Logical

Gedächtnisstütze | Beschreibung | Operanden
PAND | Bitweises UND von gepackten ganzen Zahlen | xmm, xmm/mem128
PANDN | Bitweises UND-NICHT von gepackten ganzen Zahlen | xmm, xmm/mem128
POR | Bitweises ODER gepackter Ganzzahlen | xmm, xmm/mem128
PXOR | Bitweises XOR gepackter Ganzzahlen | xmm, xmm/mem128

SSE2 Packed Shift

Gedächtnisstütze | Beschreibung | Operanden
PSLLW | Logisch gepacktes Wort nach links verschieben | xmm, imm8 / xmm
PSLLD | Logisch gepacktes Doppelwort nach links verschieben | xmm, imm8 / xmm
PSLLQ | Verschieben Sie das logisch gepackte Quadwort nach links | xmm, imm8 / xmm
PSRLW | Verschieben Sie das logisch gepackte Wort nach rechts | xmm, imm8 / xmm
PSRLD | Verschieben Sie das logisch gepackte Doppelwort nach rechts | xmm, imm8 / xmm
PSRLQ | Verschieben Sie das logisch gepackte Quadwort nach rechts | xmm, imm8 / xmm
PSRAW | Verschieben Sie das arithmetisch gepackte Wort nach rechts | xmm, imm8 / xmm
PSRAD | Nach rechts verschieben arithmetisch gepacktes Doppelwort | xmm, imm8 / xmm

SSE2-Vergleich

Gedächtnisstütze | Beschreibung | Operanden
CMPPD | Vergleichen Sie gepacktes Doppel (imm8-Prädikat) | xmm, xmm/mem128, imm8
CMPSD | Skalar-Double vergleichen (imm8-Prädikat) | xmm, xmm/mem64, imm8
COMISD | Vergleichen Sie das geordnete Skalar-Double (Setzt Flags) | xmm, xmm/mem64
UCOMISD | Ungeordnetes Skalar-Double vergleichen (setzt Flags) | xmm, xmm/mem64
PCMPEQB | Vergleichen Sie gepackte Bytes auf Gleichheit | xmm, xmm/mem128
PCMPEQW | Vergleichen Sie gepackte Wörter auf Gleichheit | xmm, xmm/mem128
PCMPEQD | Vergleichen Sie gepackte Doppelwörter auf Gleichheit | xmm, xmm/mem128
PCMPGTB | Vergleichen Sie gepackte Bytes auf größer als (mit Vorzeichen) | xmm, xmm/mem128
PCMPGTW | Vergleichen Sie gepackte Wörter für größer als | xmm, xmm/mem128
PCMPGTD | Vergleichen Sie gepackte Doppelwörter für größer als | xmm, xmm/mem128

SSE2-Konvertierungsanweisungen

Gedächtnisstütze | Beschreibung | Operanden
CVTPD2PS | Wandeln Sie gepacktes Doppel in gepacktes Einzel um | xmm, xmm/mem128
CVTPS2PD | Wandeln Sie gepacktes Einzel in gepacktes Doppel um | xmm, xmm/mem64
CVTSD2SS | Wandeln Sie Skalar-Doppel in Skalar-Einfach um | xmm, xmm/mem64
CVTSS2SD | Konvertieren Sie den einfachen Skalar in den doppelten Skalar | xmm, xmm/mem32
CVTDQ2PD | Konvertieren Sie gepacktes Doppelwort in gepacktes Doppelwort | xmm, xmm/mem64
CVTPD2DQ | Konvertieren Sie gepacktes Doppel in gepacktes Doppelwort | xmm, xmm/mem128
CVTDQ2PS | Konvertieren Sie ein gepacktes Doppelwort in ein gepacktes Einzelwort | xmm, xmm/mem128
CVTPS2DQ | Konvertieren Sie ein gepacktes Einzelwort in ein gepacktes Doppelwort | xmm, xmm/mem128
CVTTPD2DQ | Gepacktes Doppel zu gepacktem Doppelwort abschneiden | xmm, xmm/mem128
CVTTPS2DQ | Gepacktes Einzelwort in gepacktes Doppelwort kürzen | xmm, xmm/mem128
CVTTSD2SI | Truncate scalar double to integer | reg32/64, xmm/mem64
CVTTSI2SD | Ganzzahl auf Skalardoppel kürzen | xmm, reg32/64/mem32
CVTSD2SI | Konvertieren Sie das Skalar-Double in eine ganze Zahl (rund) | reg32/64, xmm/mem64
CVTSI2SD | Convert integer to scalar double | xmm, reg32/64/mem32
CVTSS2SI | Konvertieren Sie einen einzelnen Skalar in eine ganze Zahl (rund) | reg32/64, xmm/mem32
CVTSI2SS | Convert integer to scalar single | xmm, reg32/64/mem32
CVTTSS2SI | Truncate scalar single to integer | reg32/64, xmm/mem32

SSE2 Mischen / Auspacken / Packen

Gedächtnisstütze | Beschreibung | Operanden
PACKSSWB | Vorzeichenbehaftete Wörter in Bytes packen (gesättigt) | xmm, xmm/mem128
PACKSSDW | Vorzeichenbehaftete Doppelwörter zu Wörtern packen (gesättigt) | xmm, xmm/mem128
PACKUSWB | Vorzeichenlose Wörter in Bytes packen (unsigned sat) | xmm, xmm/mem128
PUNPCKHBW | Entpacken Sie High-Bytes | xmm, xmm/mem128
PUNPCKHWD | Packen Sie hohe Wörter aus | xmm, xmm/mem128
PUNPCKHDQ | Hohe Doppelwörter auspacken | xmm, xmm/mem128
PUNPCKHQDQ | Entpacken Sie hohe Quadwords | xmm, xmm/mem128
PUNPCKLBW | Low-Bytes entpacken | xmm, xmm/mem128
PUNPCKLWD | Packen Sie niedrige Wörter aus | xmm, xmm/mem128
PUNPCKLDQ | Entpacken Sie niedrige Doppelwörter | xmm, xmm/mem128
PUNPCKLQDQ | Entpacken Sie niedrige Quadwords | xmm, xmm/mem128
SHUFPD | Shuffle packed double | xmm, xmm/mem128, imm8
PSHUFD | Mischen Sie gepackte Doppelwörter | xmm, xmm/mem128, imm8
PSHUFHW | Mischen Sie gepackte hohe Wörter | xmm, xmm/mem128, imm8
PSHUFLW | Mischen Sie gepackte niedrige Wörter | xmm, xmm/mem128, imm8
PSHUFB | Gepackte Bytes mischen (SSSE3) | xmm, xmm/mem128

SSE2-Cache-Steuerung

Gedächtnisstütze | Beschreibung | Operanden
MASKMOVDQU | Maskierter Speicher gepackter Ganzzahlen | xmm, xmm
MOVNTDQ | Nichtzeitlicher Speicher gepackter Ganzzahlen | mem128, xmm
MOVNTI | Nicht-temporäre Speicherung von Ganzzahlen (Doppelwort/Vierwort) | mem32/64, reg
MOVNTPD | Nichtzeitlicher Speicher von gepacktem Doppel | mem128, xmm
PAUSE | Spin-Loop-Hinweis (verbessert Leistung/Power) | keiner

SSE3 – Streaming von SIMD-Erweiterungen 3

Gedächtnisstütze | Beschreibung | Operanden
ADDSUBPD | Gepacktes Doppel addieren/subtrahieren (alternierend) | xmm, xmm/mem128
ADDSUBPS | Gepackte Single addieren/subtrahieren (alternierend) | xmm, xmm/mem128
HADDPD | Horizontal add packed double | xmm, xmm/mem128
HADDPS | Horizontal add packed single | xmm, xmm/mem128
HSUBPD | Horizontal subtract packed double | xmm, xmm/mem128
HSUBPS | Horizontal subtract packed single | xmm, xmm/mem128
MOVDDUP | Verschieben und duplizieren (eines auf beide Hälften von XMM) | xmm, xmm/mem64
MOVSHDUP | Move and duplicate high singles | xmm, xmm/mem128
MOVSLDUP | Move and duplicate low singles | xmm, xmm/mem128
LDDQU | Laden Sie nicht ausgerichtete 128-Bit-Dateien (vermeidet die Aufteilung der Cache-Zeile) | xmm, mem128
FISTTP | FPU: Ganzzahl abschneiden und speichern (x87-Stapel platzen lassen) | mem16/32/64

SSSE3 – Ergänzendes SSE3

Gedächtnisstütze | Beschreibung | Operanden
PSIGNB | Vorzeichen gepackter Bytes (negativ oder null) | xmm, xmm/mem128
PSIGNW | Zeichen gepackter Wörter | xmm, xmm/mem128
PSIGND | Zeichen für gepackte Doppelwörter | xmm, xmm/mem128
PSHUFB | Gepackte Shuffle-Bytes (Permutationstabelle) | xmm, xmm/mem128
PMULHRSW | Verpackt mehrfach hoch mit Rundung und Skala | xmm, xmm/mem128
PABSB | Gepackter absoluter Bytewert | xmm, xmm/mem128
PABSW | Verpackter absoluter Wortwert | xmm, xmm/mem128
PABSD | Gepackter Absolutwert von Doppelwörtern | xmm, xmm/mem128
PHADDSW | Gepackte horizontale Wörter mit Sättigung hinzufügen | xmm, xmm/mem128
PHSUBW | Gepackte horizontale Subtraktionswörter | xmm, xmm/mem128
PHSUBD | Gepackte horizontale Subtraktionsdoppelwörter | xmm, xmm/mem128
PHADDD | Gepackte horizontale Doppelwörter hinzufügen | xmm, xmm/mem128
PHADDW | Gepackte horizontale Wörter hinzufügen | xmm, xmm/mem128
PMADDUBSW | Multiply unsigned bytes, add adjacent, saturate | xmm, xmm/mem128
PALIGNR | Gepackt rechts ausrichten (verketten und verschieben) | xmm, xmm/mem128, imm8
PHSUBSW | Gepackte horizontale subtrahierte vorzeichenbehaftete Wörter mit Sättigung | xmm, xmm/mem128

SSE4.1 – SSE4

Gedächtnisstütze | Beschreibung | Operanden
PMULLD | Mehrfach gepackte vorzeichenbehaftete Doppelwörter (niedrige 32 Bit) | xmm, xmm/mem128
PMULDQ | Multiplizieren Sie gepackte vorzeichenbehaftete Doppelwörter zu Quadwörtern | xmm, xmm/mem128
PCMPEQQ | Vergleichen Sie gepackte Quadwords auf Gleichheit | xmm, xmm/mem128
PCMPGTQ | Vergleichen Sie gepackte Quadwords für größer als (vorzeichenbehaftet) | xmm, xmm/mem128
PMAXSB | Maximale Anzahl gepackter signierter Bytes | xmm, xmm/mem128
PMAXSW | Maximal gepackte vorzeichenbehaftete Wörter | xmm, xmm/mem128
PMAXSD | Maximal gepackte signierte Doppelwörter | xmm, xmm/mem128
PMAXUB | Maximal gepackte Bytes ohne Vorzeichen | xmm, xmm/mem128
PMAXUW | Maximal gepackte Wörter ohne Vorzeichen | xmm, xmm/mem128
PMAXUD | Maximal gepackte vorzeichenlose Doppelwörter | xmm, xmm/mem128
PMINSB | Minimum an gepackten signierten Bytes | xmm, xmm/mem128
PMINSW | Mindestens gepackte vorzeichenbehaftete Wörter | xmm, xmm/mem128
PMINSD | Mindestens gepackte signierte Doppelwörter | xmm, xmm/mem128
PMINUB | Minimum an gepackten vorzeichenlosen Bytes | xmm, xmm/mem128
PMINUW | Minimum an gepackten Wörtern ohne Vorzeichen | xmm, xmm/mem128
PMINUD | Mindestens gepackte, vorzeichenlose Doppelwörter | xmm, xmm/mem128
PINSRB | Byte einfügen (aus GPR oder Speicher) | xmm, reg/mem32, imm8
PINSRD | Doppelwort einfügen | xmm, reg/mem32, imm8
PINSRQ | Quadword einfügen | xmm, reg/mem64, imm8
PEXTRB | Byte in GPR oder Speicher extrahieren | reg/mem8, xmm, imm8
PEXTRD | Doppelwort extrahieren | reg/mem32, xmm, imm8
PEXTRQ | Quadword extrahieren | reg/mem64, xmm, imm8
INSERTPS | Gepackte Single einfügen (aus der Quelle zusammenführen) | xmm, xmm/mem32, imm8
EXTRACTPS | Extrahieren Sie gepackte Singles in GPR/Speicher | reg/mem32, xmm, imm8
PHMINPOSUW | Gepackte horizontale Min. vorzeichenloser Wörter, Speicherposition | xmm, xmm/mem128
PMOVSXBW | Bewegen Sie sich mit Vorzeichenerweiterung, Bytes zu Wörtern | xmm, xmm/mem64
PMOVSXBD | Verschieben Sie mit Vorzeichenerweiterung Bytes in Doppelwörter | xmm, xmm/mem32
PMOVSXBQ | Verschieben Sie mit Vorzeichenerweiterung Bytes in Quadwords | xmm, xmm/mem16
PMOVSXWD | Bewegen Sie sich mit Zeichenerweiterung, Wörter zu Doppelwörtern | xmm, xmm/mem64
PMOVSXWQ | Verschieben Sie Wörter mit Zeichenerweiterung in Quadwörter | xmm, xmm/mem32
PMOVSXDQ | Bewegen Sie sich mit Vorzeichenerweiterung, Doppelwörter zu Quadwörtern | xmm, xmm/mem64
PMOVZXBW | Verschieben Sie mit Null-Erweiterung, Bytes zu Wörtern | xmm, xmm/mem64
PMOVZXBD | Verschieben Sie Bytes mit der Erweiterung Null in Doppelwörter | xmm, xmm/mem32
PMOVZXBQ | Verschieben Sie Bytes mit der Erweiterung Null in Quadwords | xmm, xmm/mem16
PMOVZXWD | Verschieben Sie Wörter ohne Erweiterung in Doppelwörter | xmm, xmm/mem64
PMOVZXWQ | Verschieben Sie Wörter ohne Erweiterung in Quadwörter | xmm, xmm/mem32
PMOVZXDQ | Verschieben Sie Doppelwörter mit Nullerweiterung in Quadwörter | xmm, xmm/mem64
PBLENDVB | Variable Mischung gepackter Bytes (nach XMM0-Maske) | xmm, xmm/mem128
PBLENDW | Mischung aus gepackten Wörtern (Sofortmaske) | xmm, xmm/mem128, imm8
BLENDPD | Mischung verpackt doppelt (sofortige Maske) | xmm, xmm/mem128, imm8
BLENDPS | Blend verpackte Single (Sofortmaske) | xmm, xmm/mem128, imm8
BLENDVPD | Variable Mischung doppelt gepackt (durch XMM0-Maske) | xmm, xmm/mem128
BLENDVPS | Variable Mischung gepackt einzeln (nach XMM0-Maske) | xmm, xmm/mem128
DPPS | Skalarprodukt der gepackten Einzelmenge | xmm, xmm/mem128, imm8
DPPD | Skalarprodukt des gepackten Doppels | xmm, xmm/mem128, imm8
MPSADBW | Mehrfachsumme absoluter Differenzen (8-Bit) | xmm, xmm/mem128, imm8
ROUNDPS | Rund verpackte Single | xmm, xmm/mem128, imm8
ROUNDSS | Runde Skalar-Single | xmm, xmm/mem32, imm8
ROUNDPD | Rund verpackt, doppelt | xmm, xmm/mem128, imm8
ROUNDSD | Rundes Skalardoppel | xmm, xmm/mem64, imm8
PTEST | Logischer Vergleich gepackter Ganzzahlen (setzt ZF/CF) | xmm, xmm/mem128
PACKUSDW | Vorzeichenbehaftete Doppelwörter in vorzeichenlose Wörter packen (gesättigt) | xmm, xmm/mem128
MOVNTDQA | Nicht-temporäre Last (Streaming-Lasthinweis) | xmm, mem128

SSE4.2 – SSE4.2

Gedächtnisstütze | Beschreibung | Operanden
PCMPGTQ | Vergleichen Sie gepackte Quadwords für größer als (vorzeichenbehaftet) | xmm, xmm/mem128
PCMPEQQ | Vergleichen Sie gepackte Quadwords auf Gleichheit | xmm, xmm/mem128
CRC32 | Akkumulieren Sie den CRC32C-Wert | reg32/64, reg/mem8/16/32/64
POPCNT | Bevölkerungszahl (Anzahl der 1-Bits) | reg, reg/mem
PCMPESTRI | Gepackte Zeichenfolgen mit expliziter Länge und Index vergleichen | xmm, xmm/mem128, imm8
PCMPESTRM | Gepackte Zeichenfolgen mit expliziter Länge vergleichen, Maske | xmm, xmm/mem128, imm8
PCMPISTRI | Gepackte Zeichenfolgen mit impliziter Länge vergleichen, Index | xmm, xmm/mem128, imm8
PCMPISTRM | Gepackte Zeichenfolgen mit impliziter Länge vergleichen, Maske | xmm, xmm/mem128, imm8

String-Textverarbeitung (SSE4.2 imm8-Flags)

Die String-Vergleichsanweisungen verwenden ein imm8-Byte zur Steuerung:

Bits | Feld | Werte
1:0 | Aggregiertes Ergebnis | 00=jeweils gleich, 01=gleich geordnet, 10=gleich mit Vorzeichen, 11=gleich ohne Vorzeichen
3:2 | Polarität | 00=+, 01=negativ, 10=maskiert+, 11=maskiert-
5:4 | Ausgabeauswahl | 00 = niedrigstwertiger Index, 01 = höchstwertiger Index, 10 = erstes gesetztes Bit
6 | Intrsx | 0=int-Byte-Vergleich, 1=vorzeichenloser Byte-Vergleich

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

← SGX / VMX / CET-Mnemonik Nach oben Systemanweisungen →

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes


AVX/AVX2/AVX-512/FMA-Mnemonik

Startseite› AVX/AVX2/AVX-512/FMA-Mnemonik

AVX / AVX2 / AVX-512 / FMA-Mnemonik

PBXB64 unterstützt AVX- (VEX-kodiert), AVX2-, AVX-512- (EVEX-kodiert) und FMA-Anweisungen. AVX-Anweisungen verwenden eine 3-Operanden-Syntax mit einem nicht destruktiven Ziel.

Notiz:AVX-512-Mnemoniken verwenden das EVEX-Präfix und unterstützen Opmask-Register (k0-k7). Der Assembler akzeptiert sowohl Standard-Mnemoniken als auch AVX-512-Varianten (z. B.VADDPSUndVADDPSZ).

AVX – Gleitkomma-Arithmetik

Gedächtnisstütze | Beschreibung | Operanden
VADDPS | Gepackte Single hinzufügen (128/256) | ymm/xmm, ymm/xmm, ymm/mem
VADDPD | Doppelpack hinzufügen (128/256) | ymm/xmm, ymm/xmm, ymm/mem
VADDSS | Skalare Single hinzufügen | xmm, xmm, xmm/Speicher
VADDSD | Skalardoppel hinzufügen | xmm, xmm, xmm/Speicher
VSUBPS | Gepackte Single subtrahieren | ymm/xmm, ymm/xmm, ymm/mem
VSUBPD | Subtrahieren Sie das gepackte Doppel | ymm/xmm, ymm/xmm, ymm/mem
VSUBSS | Subtrahieren Sie den Skalar einzeln | xmm, xmm, xmm/Speicher
VSUBSD | Subtrahiere das Skalardoppel | xmm, xmm, xmm/Speicher
VMULPS | Mehrfach gepackte Single | ymm/xmm, ymm/xmm, ymm/mem
VMULPD | Mehrfach gepacktes Doppeltes | ymm/xmm, ymm/xmm, ymm/mem
VMULSS | Skalar-Single multiplizieren | xmm, xmm, xmm/Speicher
VMULSD | Skalar mit dem Doppelten multiplizieren | xmm, xmm, xmm/Speicher
VDIVPS | Teilweise einzeln verpackt | ymm/xmm, ymm/xmm, ymm/mem
VDIVPD | Doppelt verpackt teilen | ymm/xmm, ymm/xmm, ymm/mem
VDIVSS | Teilen Sie den Skalar einfach | xmm, xmm, xmm/Speicher
VDIVSD | Teilen Sie den Skalar durch das Doppelte | xmm, xmm, xmm/Speicher
VSQRTPS | Quadratwurzelgepackte Single | ymm/xmm, ymm/xmm, ymm/mem
VSQRTPD | Quadratwurzel doppelt gepackt | ymm/xmm, ymm/xmm, ymm/mem
VSQRTSS | Quadratwurzel-Skalar-Single | xmm, xmm, xmm/Speicher
VSQRTSD | Quadratwurzel-Skalar-Double | xmm, xmm, xmm/Speicher
VRCPPS | Gegenseitig verpackte Single (ungefähr) | ymm/xmm, ymm/xmm, ymm/mem
VRCPSS | Reziproker Skalar Single (ungefähr) | xmm, xmm, xmm/Speicher
VRSQRTPS | Reziproke quadratisch gepackte Single (ungefähr) | ymm/xmm, ymm/xmm, ymm/mem
VRSQRTSS | Reziproker quadratischer Skalar einzeln (ungefähr) | xmm, xmm, xmm/Speicher
VMAXPS | Maximal gepacktes Einzelstück | ymm/xmm, ymm/xmm, ymm/mem
VMAXPD | Maximal doppelt bepackt | ymm/xmm, ymm/xmm, ymm/mem
VMAXSS | Maximaler Skalar-Single | xmm, xmm, xmm/Speicher
VMAXSD | Maximales Skalar-Double | xmm, xmm, xmm/Speicher
VMINPS | Mindestens einzeln verpackt | ymm/xmm, ymm/xmm, ymm/mem
VMINPD | Mindestens doppelt verpackt | ymm/xmm, ymm/xmm, ymm/mem
VMINSS | Minimaler Skalar-Single | xmm, xmm, xmm/Speicher
VMINSD | Minimales Skalardoppel | xmm, xmm, xmm/Speicher
VROUNDPS | Rund verpackte Single | ymm/xmm, ymm/mem, imm8
VROUNDPD | Rund verpackt, doppelt | ymm/xmm, ymm/mem, imm8
VROUNDSS | Runde Skalar-Single | xmm, xmm/mem, imm8
VROUNDSD | Rundes Skalardoppel | xmm, xmm/mem, imm8

AVX – Datenbewegung

Gedächtnisstütze | Beschreibung | Operanden
VMOVAPS | Verschieben Sie ausgerichtete verpackte Einzelstücke | ymm/xmm, mem / mem, ymm/xmm
VMOVUPS | Move unaligned packed single | ymm/xmm, mem / mem, ymm/xmm
VMOVAPD | Move aligned packed double | ymm/xmm, mem / mem, ymm/xmm
VMOVUPD | Move unaligned packed double | ymm/xmm, mem / mem, ymm/xmm
VMOVSS | Move scalar single | xmm, xmm/mem / mem32, xmm
VMOVSD | Move scalar double | xmm, xmm/mem / mem64, xmm
VMOVD | Move doubleword to/from XMM | xmm, reg/mem / reg, xmm
VMOVQ | Move quadword to/from XMM | xmm, reg/mem / reg, xmm
VMOVDQA | Move aligned double quadword | ymm/xmm, mem / mem, ymm/xmm
VMOVDQU | Move unaligned double quadword | ymm/xmm, mem / mem, ymm/xmm
VMOVLPS | Move low packed single (64-bit) | xmm, xmm, mem64 / mem64, xmm
VMOVHPS | Move high packed single | xmm, xmm, mem64 / mem64, xmm
VMOVLPD | Move low packed double | xmm, xmm, mem64 / mem64, xmm
VMOVHPD | Move high packed double | xmm, xmm, mem64 / mem64, xmm
VMOVSHDUP | Move and duplicate high singles | ymm/xmm, ymm/mem
VMOVSLDUP | Move and duplicate low singles | ymm/xmm, ymm/mem
VMOVDDUP | Move and duplicate one double | ymm/xmm, ymm/mem
VBROADCASTSS | Broadcast single to all elements | ymm/xmm, mem32
VBROADCASTSD | Broadcast double to all elements | ymm, mem64
VBROADCASTF128 | Broadcast 128-bit to all lanes | ymm, mem128

AVX — Logical & Comparison

Gedächtnisstütze | Beschreibung | Operanden
VANDPS | Bitwise AND of packed singles | ymm/xmm, ymm/xmm, ymm/mem
VANDPD | Bitwise AND of packed doubles | ymm/xmm, ymm/xmm, ymm/mem
VANDNPS | Bitwise AND-NOT of packed singles | ymm/xmm, ymm/xmm, ymm/mem
VANDNPD | Bitwise AND-NOT of packed doubles | ymm/xmm, ymm/xmm, ymm/mem
VORPS | Bitwise OR of packed singles | ymm/xmm, ymm/xmm, ymm/mem
VORPD | Bitwise OR of packed doubles | ymm/xmm, ymm/xmm, ymm/mem
VXORPS | Bitwise XOR of packed singles | ymm/xmm, ymm/xmm, ymm/mem
VXORPD | Bitwise XOR of packed doubles | ymm/xmm, ymm/xmm, ymm/mem
VCMPPS | Compare packed single (imm8) | ymm/xmm, ymm/xmm, ymm/mem, imm8
VCMPPD | Compare packed double (imm8) | ymm/xmm, ymm/xmm, ymm/mem, imm8
VCMPSS | Compare scalar single (imm8) | xmm, xmm, xmm/mem, imm8
VCMPSD | Compare scalar double (imm8) | xmm, xmm, xmm/mem, imm8
VCOMISS | Compare ordered scalar single (flags) | xmm, xmm/mem
VCOMISD | Compare ordered scalar double (flags) | xmm, xmm/mem
VUCOMISS | Compare unordered scalar single (flags) | xmm, xmm/mem
VUCOMISD | Compare unordered scalar double (flags) | xmm, xmm/mem
VTESTPS | Test packed single (sets ZF/CF) | ymm/xmm, ymm/xmm
VTESTPD | Test packed double (sets ZF/CF) | ymm/xmm, ymm/xmm
VPTEST | Logical compare of integers (sets ZF/CF) | ymm/xmm, ymm/mem

AVX — Shuffle / Permute

Gedächtnisstütze | Beschreibung | Operanden
VSHUFPS | Shuffle packed single | ymm/xmm, ymm/xmm, ymm/mem, imm8
VSHUFPD | Shuffle packed double | ymm/xmm, ymm/xmm, ymm/mem, imm8
VPERMILPS | Permute in-lane packed single | ymm/xmm, ymm/mem, imm8
VPERMILPD | Permute in-lane packed double | ymm/xmm, ymm/mem, imm8
VPERM2F128 | Permute 128-bit lanes | ymm, ymm, ymm/mem, imm8
VUNPCKHPS | Unpack high packed single | ymm/xmm, ymm/xmm, ymm/mem
VUNPCKLPS | Unpack low packed single | ymm/xmm, ymm/xmm, ymm/mem
VUNPCKHPD | Unpack high packed double | ymm/xmm, ymm/xmm, ymm/mem
VUNPCKLPD | Unpack low packed double | ymm/xmm, ymm/xmm, ymm/mem

AVX — Integer Operations

Gedächtnisstütze | Beschreibung | Operanden
VPADDB | Add packed bytes | ymm/xmm, ymm/xmm, ymm/mem
VPADDW | Add packed words | ymm/xmm, ymm/xmm, ymm/mem
VPADDD | Add packed doublewords | ymm/xmm, ymm/xmm, ymm/mem
VPADDQ | Add packed quadwords | ymm/xmm, ymm/xmm, ymm/mem
VPSUBB | Subtract packed bytes | ymm/xmm, ymm/xmm, ymm/mem
VPSUBW | Subtract packed words | ymm/xmm, ymm/xmm, ymm/mem
VPSUBD | Subtract packed doublewords | ymm/xmm, ymm/xmm, ymm/mem
VPSUBQ | Subtract packed quadwords | ymm/xmm, ymm/xmm, ymm/mem
VPAND | Bitwise AND | ymm/xmm, ymm/xmm, ymm/mem
VPANDN | Bitwise AND-NOT | ymm/xmm, ymm/xmm, ymm/mem
VPOR | Bitwise OR | ymm/xmm, ymm/xmm, ymm/mem
VPXOR | Bitwise XOR | ymm/xmm, ymm/xmm, ymm/mem
VPSLLW | Shift left logical words | ymm/xmm, xmm/mem, imm8
VPSLLD | Shift left logical doublewords | ymm/xmm, xmm/mem, imm8
VPSLLQ | Shift left logical quadwords | ymm/xmm, xmm/mem, imm8
VPSRLW | Shift right logical words | ymm/xmm, xmm/mem, imm8
VPSRLD | Shift right logical doublewords | ymm/xmm, xmm/mem, imm8
VPSRLQ | Shift right logical quadwords | ymm/xmm, xmm/mem, imm8
VPSRAW | Shift right arithmetic words | ymm/xmm, xmm/mem, imm8
VPSRAD | Shift right arithmetic doublewords | ymm/xmm, xmm/mem, imm8
VPMULLW | Multiply packed words (low) | ymm/xmm, ymm/xmm, ymm/mem
VPMULLD | Multiply packed doublewords (low) | ymm/xmm, ymm/xmm, ymm/mem
VPMULHW | Multiply packed words (high) | ymm/xmm, ymm/xmm, ymm/mem
VPMULHUW | Multiply packed words (high, unsigned) | ymm/xmm, ymm/xmm, ymm/mem
VPMULUDQ | Multiply unsigned dword to qword | ymm/xmm, ymm/xmm, ymm/mem
VPMULDQ | Multiply signed dword to qword | ymm/xmm, ymm/xmm, ymm/mem
VPMADDUBSW | Multiply unsigned bytes, add adjacent, saturate | ymm/xmm, ymm/xmm, ymm/mem
VPMADDWD | Multiply and add words to doublewords | ymm/xmm, ymm/xmm, ymm/mem
VPSADBW | Sum of absolute differences | ymm/xmm, ymm/xmm, ymm/mem

AVX — Convert Instructions

Gedächtnisstütze | Beschreibung | Operanden
VCVTPD2PS | Convert packed double to single | ymm/xmm, ymm/xmm/mem
VCVTPS2PD | Convert packed single to double | ymm/xmm, ymm/xmm/mem
VCVTSD2SS | Convert scalar double to single | xmm, xmm, xmm/Speicher
VCVTSS2SD | Convert scalar single to double | xmm, xmm, xmm/Speicher
VCVTDQ2PD | Convert packed dword to double | ymm/xmm, xmm/mem
VCVTPD2DQ | Convert packed double to dword | ymm/xmm, ymm/xmm/mem
VCVTDQ2PS | Convert packed dword to single | ymm/xmm, ymm/mem
VCVTPS2DQ | Convert packed single to dword | ymm/xmm, ymm/mem
VCVTTPD2DQ | Truncate packed double to dword | ymm/xmm, ymm/mem
VCVTTPS2DQ | Truncate packed single to dword | ymm/xmm, ymm/mem
VCVTTSD2SI | Truncate scalar double to integer | reg, xmm/mem
VCVTTSS2SI | Truncate scalar single to integer | reg, xmm/mem
VCVTSI2SD | Convert integer to scalar double | xmm, xmm, reg/mem
VCVTSI2SS | Convert integer to scalar single | xmm, xmm, reg/mem
VCVTSD2SI | Convert scalar double to integer | reg, xmm/mem
VCVTSS2SI | Convert scalar single to integer | reg, xmm/mem
VCVTPS2PH | Convert packed single to half precision | xmm/mem, ymm/xmm, imm8
VCPH2PS | Convert half precision to packed single | ymm/xmm, xmm/mem

AVX — Blend / Select / Horizontal

Gedächtnisstütze | Beschreibung | Operanden
VBLENDPS | Blend packed single (imm8) | ymm/xmm, ymm/xmm, ymm/mem, imm8
VBLENDPD | Blend packed double (imm8) | ymm/xmm, ymm/xmm, ymm/mem, imm8
VBLENDVPS | Variable blend packed single | ymm/xmm, ymm/xmm, ymm/mem
VBLENDVPD | Variable blend packed double | ymm/xmm, ymm/xmm, ymm/mem
VPBLENDVB | Variable blend packed bytes | ymm/xmm, ymm/xmm, ymm/mem
VPBLENDW | Blend packed words (imm8) | ymm/xmm, ymm/xmm, ymm/mem, imm8
VDPPS | Dot product packed single (imm8) | ymm/xmm, ymm/xmm, ymm/mem, imm8
VDPPD | Dot product packed double (imm8) | xmm, xmm, xmm/mem, imm8
VHADDPS | Horizontal add packed single | ymm/xmm, ymm/xmm, ymm/mem
VHADDPD | Horizontal add packed double | ymm/xmm, ymm/xmm, ymm/mem
VHSUBPS | Horizontal subtract packed single | ymm/xmm, ymm/xmm, ymm/mem
VHSUBPD | Horizontal subtract packed double | ymm/xmm, ymm/xmm, ymm/mem
VADDSUBPS | Add/subtract alternating packed single | ymm/xmm, ymm/xmm, ymm/mem
VADDSUBPD | Add/subtract alternating packed double | ymm/xmm, ymm/xmm, ymm/mem

AVX2

Gedächtnisstütze | Beschreibung | Operanden
VPBROADCASTB | Broadcast byte to all elements | ymm/xmm, reg/mem
VPBROADCASTW | Broadcast word to all elements | ymm/xmm, reg/mem
VPBROADCASTD | Broadcast dword to all elements | ymm/xmm, reg/mem
VPBROADCASTQ | Broadcast qword to all elements | ymm/xmm, reg/mem
VBROADCASTI128 | Broadcast 128-bit to all lanes | ymm, mem128
VPERM2I128 | Permute 128-bit integer lanes | ymm, ymm, ymm/mem, imm8
VPERMD | Permute doublewords | ymm, ymm, ymm/mem
VPERMPD | Permute double-precision floats | ymm, ymm, ymm/mem, imm8
VPERMPS | Permute single-precision floats | ymm, ymm, ymm/mem
VPERMQ | Permute quadwords | ymm, ymm/mem, imm8
VPERMIL2PS | Two-source permute of singles | ymm/xmm, ymm/xmm, ymm/mem, imm4
VPERMIL2PD | Two-source permute of doubles | ymm/xmm, ymm/xmm, ymm/mem, imm4
VGATHERDPD | Gather double with dword indices | ymm/xmm, mem, ymm/xmm
VGATHERQPD | Gather double with qword indices | ymm/xmm, mem, ymm/xmm
VGATHERDPS | Gather single with dword indices | ymm/xmm, mem, ymm/xmm
VGATHERQPS | Gather single with qword indices | ymm/xmm, mem, ymm/xmm
VPGATHERDD | Gather dwords with dword indices | ymm/xmm, mem, ymm/xmm
VPGATHERDQ | Gather dwords with qword indices | ymm/xmm, mem, ymm/xmm
VPGATHERQD | Gather qwords with dword indices | ymm/xmm, mem, ymm/xmm
VPGATHERQQ | Gather qwords with qword indices | ymm/xmm, mem, ymm/xmm
VPMASKMOVD | Masked move of dwords | ymm/xmm, ymm/xmm, mem
VPMASKMOVQ | Masked move of qwords | ymm/xmm, ymm/xmm, mem
VPSLLVD | Variable shift left logical dwords | ymm/xmm, ymm/xmm, ymm/mem
VPSLLVQ | Variable shift left logical qwords | ymm/xmm, ymm/xmm, ymm/mem
VPSRLVD | Variable shift right logical dwords | ymm/xmm, ymm/xmm, ymm/mem
VPSRLVQ | Variable shift right logical qwords | ymm/xmm, ymm/xmm, ymm/mem
VPSRAVD | Variable shift right arith dwords | ymm/xmm, ymm/xmm, ymm/mem
VPMOVSXBW | Sign-extend bytes to words | ymm/xmm, xmm/mem
VPMOVSXBD | Sign-extend bytes to dwords | ymm/xmm, xmm/mem
VPMOVSXBQ | Sign-extend bytes to qwords | ymm/xmm, xmm/mem
VPMOVSXWD | Sign-extend words to dwords | ymm/xmm, xmm/mem
VPMOVSXWQ | Sign-extend words to qwords | ymm/xmm, xmm/mem
VPMOVSXDQ | Sign-extend dwords to qwords | ymm/xmm, xmm/mem
VPMOVZXBW | Zero-extend bytes to words | ymm/xmm, xmm/mem
VPMOVZXBD | Zero-extend bytes to dwords | ymm/xmm, xmm/mem
VPMOVZXBQ | Zero-extend bytes to qwords | ymm/xmm, xmm/mem
VPMOVZXWD | Zero-extend words to dwords | ymm/xmm, xmm/mem
VPMOVZXWQ | Zero-extend words to qwords | ymm/xmm, xmm/mem
VPMOVZXDQ | Zero-extend dwords to qwords | ymm/xmm, xmm/mem
VPSHUFB | Shuffle packed bytes (per-lane) | ymm/xmm, ymm/xmm, ymm/mem
VPSHUFD | Shuffle packed dwords (per-lane, imm8) | ymm/xmm, ymm/mem, imm8
VPSHUFHW | Shuffle packed high words (imm8) | ymm/xmm, ymm/mem, imm8
VPSHUFLW | Shuffle packed low words (imm8) | ymm/xmm, ymm/mem, imm8
VPABSB | Absolute value of bytes | ymm/xmm, ymm/mem
VPABSW | Absolute value of words | ymm/xmm, ymm/mem
VPABSD | Absolute value of dwords | ymm/xmm, ymm/mem
VPMAXSB | Maximum of signed bytes | ymm/xmm, ymm/xmm, ymm/mem
VPMAXSW | Maximum of signed words | ymm/xmm, ymm/xmm, ymm/mem
VPMAXSD | Maximum of signed dwords | ymm/xmm, ymm/xmm, ymm/mem
VPMAXUB | Maximum of unsigned bytes | ymm/xmm, ymm/xmm, ymm/mem
VPMAXUW | Maximum of unsigned words | ymm/xmm, ymm/xmm, ymm/mem
VPMAXUD | Maximum of unsigned dwords | ymm/xmm, ymm/xmm, ymm/mem
VPMINSB | Minimum of signed bytes | ymm/xmm, ymm/xmm, ymm/mem
VPMINSW | Minimum of signed words | ymm/xmm, ymm/xmm, ymm/mem
VPMINSD | Minimum of signed dwords | ymm/xmm, ymm/xmm, ymm/mem
VPMINUB | Minimum of unsigned bytes | ymm/xmm, ymm/xmm, ymm/mem
VPMINUW | Minimum of unsigned words | ymm/xmm, ymm/xmm, ymm/mem
VPMINUD | Minimum of unsigned dwords | ymm/xmm, ymm/xmm, ymm/mem
VPINSRB | Insert byte | xmm, xmm, reg/mem, imm8
VPINSRD | Insert dword | xmm, xmm, reg/mem, imm8
VPINSRQ | Insert qword | xmm, xmm, reg/mem, imm8
VPEXTRB | Extract byte | reg/mem, xmm, imm8
VPEXTRD | Extract dword | reg/mem, xmm, imm8
VPEXTRQ | Extract qword | reg/mem, xmm, imm8
VPMOVMSKB | Move byte mask to GPR | reg, ymm/xmm
VPHADDW | Horizontal add words | ymm/xmm, ymm/xmm, ymm/mem
VPHADDD | Horizontal add dwords | ymm/xmm, ymm/xmm, ymm/mem
VPHADDSW | Horizontal add words with saturation | ymm/xmm, ymm/xmm, ymm/mem
VPHSUBW | Horizontal subtract words | ymm/xmm, ymm/xmm, ymm/mem
VPHSUBD | Horizontal subtract dwords | ymm/xmm, ymm/xmm, ymm/mem
VPHSUBSW | Horizontal subtract words with saturation | ymm/xmm, ymm/xmm, ymm/mem
VPMULHRSW | Multiply high with round and scale | ymm/xmm, ymm/xmm, ymm/mem
VPSIGNB | Sign of bytes | ymm/xmm, ymm/xmm, ymm/mem
VPSIGNW | Sign of words | ymm/xmm, ymm/xmm, ymm/mem
VPSIGND | Sign of dwords | ymm/xmm, ymm/xmm, ymm/mem
VPALIGNR | Align right (concatenate and shift, imm8) | ymm/xmm, ymm/xmm, ymm/mem, imm8
VPCMPEQB | Compare bytes for equality | ymm/xmm, ymm/xmm, ymm/mem
VPCMPEQW | Compare words for equality | ymm/xmm, ymm/xmm, ymm/mem
VPCMPEQD | Compare dwords for equality | ymm/xmm, ymm/xmm, ymm/mem
VPCMPEQQ | Compare qwords for equality | ymm/xmm, ymm/xmm, ymm/mem
VPCMPGTB | Compare bytes for greater than | ymm/xmm, ymm/xmm, ymm/mem
VPCMPGTW | Compare words for greater than | ymm/xmm, ymm/xmm, ymm/mem
VPCMPGTD | Compare dwords for greater than | ymm/xmm, ymm/xmm, ymm/mem
VPCMPGTQ | Compare qwords for greater than | ymm/xmm, ymm/xmm, ymm/mem
VINSERTI128 | Insert 128-bit integer lane (imm8) | ymm, ymm, xmm/mem, imm8
VEXTRACTI128 | Extract 128-bit integer lane (imm8) | xmm/mem, ymm, imm8
VINSERTF128 | Insert 128-bit float lane (imm8) | ymm, ymm, xmm/mem, imm8
VEXTRACTF128 | Extract 128-bit float lane (imm8) | xmm/mem, ymm, imm8

FMA — Fused Multiply-Add

Gedächtnisstütze | Beschreibung | Operanden
VFMADD132PS | FMA: a*b+c (single, packed) | ymm/xmm, ymm/xmm, ymm/mem
VFMADD213PS | FMA: a*b+c (single, packed) | ymm/xmm, ymm/xmm, ymm/mem
VFMADD231PS | FMA: a*b+c (single, packed) | ymm/xmm, ymm/xmm, ymm/mem
VFMADD132PD | FMA: a*b+c (double, packed) | ymm/xmm, ymm/xmm, ymm/mem
VFMADD213PD | FMA: a*b+c (double, packed) | ymm/xmm, ymm/xmm, ymm/mem
VFMADD231PD | FMA: a*b+c (double, packed) | ymm/xmm, ymm/xmm, ymm/mem
VFMADD132SS | FMA: a*b+c (single, scalar) | xmm, xmm, xmm/Speicher
VFMADD213SS | FMA: a*b+c (single, scalar) | xmm, xmm, xmm/Speicher
VFMADD231SS | FMA: a*b+c (single, scalar) | xmm, xmm, xmm/Speicher
VFMADD132SD | FMA: a*b+c (double, scalar) | xmm, xmm, xmm/Speicher
VFMADD213SD | FMA: a*b+c (double, scalar) | xmm, xmm, xmm/Speicher
VFMADD231SD | FMA: a*b+c (double, scalar) | xmm, xmm, xmm/Speicher
VFMSUB132PS | FMA: a*b-c (single, packed) | ymm/xmm, ymm/xmm, ymm/mem
VFMSUB213PS | FMA: a*b-c (single, packed) | ymm/xmm, ymm/xmm, ymm/mem
VFMSUB231PS | FMA: a*b-c (single, packed) | ymm/xmm, ymm/xmm, ymm/mem
VFMSUB132PD | FMA: a*b-c (double, packed) | ymm/xmm, ymm/xmm, ymm/mem
VFMSUB213PD | FMA: a*b-c (double, packed) | ymm/xmm, ymm/xmm, ymm/mem
VFMSUB231PD | FMA: a*b-c (double, packed) | ymm/xmm, ymm/xmm, ymm/mem
VFMSUB132SS | FMA: a*b-c (single, scalar) | xmm, xmm, xmm/Speicher
VFMSUB213SS | FMA: a*b-c (single, scalar) | xmm, xmm, xmm/Speicher
VFMSUB231SS | FMA: a*b-c (single, scalar) | xmm, xmm, xmm/Speicher
VFMSUB132SD | FMA: a*b-c (doppelt, skalar) | xmm, xmm, xmm/Speicher
VFMSUB213SD | FMA: a*b-c (doppelt, skalar) | xmm, xmm, xmm/Speicher
VFMSUB231SD | FMA: a*b-c (doppelt, skalar) | xmm, xmm, xmm/Speicher
VFMADDSUB132PS | FMA: a*b+c / a*b-c (abwechselnd, einzeln gepackt) | ymm/xmm, ymm/xmm, ymm/mem
VFMADDSUB213PS | FMA: a*b+c / a*b-c (abwechselnd, einzeln gepackt) | ymm/xmm, ymm/xmm, ymm/mem
VFMADDSUB231PS | FMA: a*b+c / a*b-c (abwechselnd, einzeln gepackt) | ymm/xmm, ymm/xmm, ymm/mem
VFMADDSUB132PD | FMA: a*b+c / a*b-c (alternierend, doppelt gepackt) | ymm/xmm, ymm/xmm, ymm/mem
VFMADDSUB213PD | FMA: a*b+c / a*b-c (alternierend, doppelt gepackt) | ymm/xmm, ymm/xmm, ymm/mem
VFMADDSUB231PD | FMA: a*b+c / a*b-c (alternierend, doppelt gepackt) | ymm/xmm, ymm/xmm, ymm/mem
VFNMADD132PS | FMA: -(a*b)+c (einzeln, verpackt) | ymm/xmm, ymm/xmm, ymm/mem
VFNMADD213PS | FMA: -(a*b)+c (einzeln, verpackt) | ymm/xmm, ymm/xmm, ymm/mem
VFNMADD231PS | FMA: -(a*b)+c (einzeln, verpackt) | ymm/xmm, ymm/xmm, ymm/mem
VFNMADD132PD | FMA: -(a*b)+c (doppelt, gepackt) | ymm/xmm, ymm/xmm, ymm/mem
VFNMADD213PD | FMA: -(a*b)+c (doppelt, gepackt) | ymm/xmm, ymm/xmm, ymm/mem
VFNMADD231PD | FMA: -(a*b)+c (doppelt, gepackt) | ymm/xmm, ymm/xmm, ymm/mem
VFNMADD132SS | FMA: -(a*b)+c (einzeln, skalar) | xmm, xmm, xmm/Speicher
VFNMADD213SS | FMA: -(a*b)+c (einzeln, skalar) | xmm, xmm, xmm/Speicher
VFNMADD231SS | FMA: -(a*b)+c (einzeln, skalar) | xmm, xmm, xmm/Speicher
VFNMADD132SD | FMA: -(a*b)+c (doppelt, skalar) | xmm, xmm, xmm/Speicher
VFNMADD213SD | FMA: -(a*b)+c (doppelt, skalar) | xmm, xmm, xmm/Speicher
VFNMADD231SD | FMA: -(a*b)+c (doppelt, skalar) | xmm, xmm, xmm/Speicher
VFNMSUB132PS | FMA: -(a*b)-c (einzeln, verpackt) | ymm/xmm, ymm/xmm, ymm/mem
VFNMSUB213PS | FMA: -(a*b)-c (einzeln, verpackt) | ymm/xmm, ymm/xmm, ymm/mem
VFNMSUB231PS | FMA: -(a*b)-c (einzeln, verpackt) | ymm/xmm, ymm/xmm, ymm/mem
VFNMSUB132PD | FMA: -(a*b)-c (doppelt, gepackt) | ymm/xmm, ymm/xmm, ymm/mem
VFNMSUB213PD | FMA: -(a*b)-c (doppelt, gepackt) | ymm/xmm, ymm/xmm, ymm/mem
VFNMSUB231PD | FMA: -(a*b)-c (doppelt, gepackt) | ymm/xmm, ymm/xmm, ymm/mem
VFNMSUB132SS | FMA: -(a*b)-c (einzeln, skalar) | xmm, xmm, xmm/Speicher
VFNMSUB213SS | FMA: -(a*b)-c (einzeln, skalar) | xmm, xmm, xmm/Speicher
VFNMSUB231SS | FMA: -(a*b)-c (einzeln, skalar) | xmm, xmm, xmm/Speicher
VFNMSUB132SD | FMA: -(a*b)-c (doppelt, skalar) | xmm, xmm, xmm/Speicher
VFNMSUB213SD | FMA: -(a*b)-c (doppelt, skalar) | xmm, xmm, xmm/Speicher
VFNMSUB231SD | FMA: -(a*b)-c (doppelt, skalar) | xmm, xmm, xmm/Speicher

AVX-512 – Hauptunterschiede

AVX-512 erweitert YMM auf 512-Bit-ZMM-Register und fügt Opmask-Register k0-k7 hinzu. Mnemonics verwenden ein optionalesZSuffix oder das EVEX-Präfix. Wichtige neue Anweisungen:

Gedächtnisstütze | Beschreibung | Operanden
VMOVDQA32 | Ausgerichtetes Dword/Qword verschieben (mit Opmask) | zmm, mem / mem, zmm
VMOVDQA64 | Ausgerichtetes qword verschieben (mit opmask) | zmm, mem / mem, zmm
VMOVDQU32 | Nicht ausgerichtetes Dword/Qword verschieben (mit opmask) | zmm, mem / mem, zmm
VMOVDQU64 | Nicht ausgerichtetes qword verschieben (mit opmask) | zmm, mem / mem, zmm
VPABSQ | Absoluter Wert von qwords | zmm, zmm/mem
VPMAXSQ | Maximal vorzeichenbehaftete Qwords | zmm, zmm, zmm/mem
VPMINSQ | Mindestens signierte Qwords | zmm, zmm, zmm/mem
VPMAXUQ | Maximal vorzeichenlose Qwords | zmm, zmm, zmm/mem
VPMINUQ | Mindestens vorzeichenlose Qwords | zmm, zmm, zmm/mem
VPCONFLICTD | Erkennen Sie Konflikte im Dword-Vektor | zmm, zmm/mem
VPCONFLICTQ | Erkennen Sie Konflikte im Qword-Vektor | zmm, zmm/mem
VPLZCNTD | Zählen Sie führende Nullen im Dword-Vektor | zmm, zmm/mem
VPLZCNTQ | Zählen Sie führende Nullen im Qword-Vektor | zmm, zmm/mem
VCOMPRESS | Gepackte Elemente komprimieren (durch Maske) | zmm, zmm/mem
VEXPAND | Gepackte Elemente erweitern (durch Maske) | zmm, zmm/mem
VPCOMPRESSD | Komprimieren Sie gepackte Dwords | zmm, zmm/mem
VPCOMPRESSQ | Komprimieren Sie gepackte Qwords | zmm, zmm/mem
VPEXPANDD | Erweitern Sie gepackte Dwords | zmm, zmm/mem
VPEXPANDQ | Erweitern Sie gepackte Qwords | zmm, zmm/mem
VPERMI2B | Permutieren Sie Bytes mit Index und Maske | zmm, zmm, zmm/mem
VPERMI2W | Permutieren Sie Wörter mit Index und Maske | zmm, zmm, zmm/mem
VPERMI2D | Permutieren Sie Dwords mit Index und Maske | zmm, zmm, zmm/mem
VPERMI2Q | Qwords mit Index und Maske permutieren | zmm, zmm, zmm/mem
VPERMT2B | Bytes mit Index und Maske permutieren (zwei Quellen) | zmm, zmm, zmm/mem
VPERMT2W | Wörter mit Index und Maske permutieren (zwei Quellen) | zmm, zmm, zmm/mem
VPERMT2D | Dwords mit Index und Maske permutieren (zwei Quellen) | zmm, zmm, zmm/mem
VPERMT2Q | Qwords mit Index und Maske permutieren (zwei Quellen) | zmm, zmm, zmm/mem
VGETMANTPS | Extrahieren Sie die normalisierte Mantisse aus einer einzelnen | zmm, zmm/mem, imm8
VGETMANTPD | Extrahieren Sie die normalisierte Mantisse aus dem Doppelten | zmm, zmm/mem, imm8
VFPCLASSPS | Testgepackte Single für die Klasse (NaN/Inf/Null) | zmm, zmm/mem, imm8
VFPCLASSPD | Testpackung doppelt für den Unterricht | zmm, zmm/mem, imm8
VRCP14PS | 14-Bit reziproke gepackte Single | zmm, zmm/mem
VRCP14PD | 14-Bit reziprokes gepacktes Double | zmm, zmm/mem
VRCP14SS | 14-Bit-reziproker Skalar-Single | xmm, xmm, xmm/Speicher
VRCP14SD | 14-Bit reziprokes Skalar-Double | xmm, xmm, xmm/Speicher
VRSQRT14PS | 14-Bit reziprokes sqrt-gepacktes Single | zmm, zmm/mem
VRSQRT14PD | 14-Bit reziprokes sqrt-gepacktes Doppel | zmm, zmm/mem
VSCALEFPS | Skalieren Sie einzeln mit Zweierpotenzen | zmm, zmm, zmm/mem
VSCALEFPD | Skala doppelt gepackt durch Zweierpotenz | zmm, zmm, zmm/mem
VFIXUPIMMPS | Verpackte Single reparieren (NaN-Handhabung) | zmm, zmm, zmm/mem, imm8
VFIXUPIMMPD | Verpacktes Doppel reparieren (NaN-Handhabung) | zmm, zmm, zmm/mem, imm8
VREDUCEPS | Gepackte Single reduzieren (auf N Bits runden) | zmm, zmm/mem, imm8
VREDUCEPD | Packed Double reduzieren (auf N Bits runden) | zmm, zmm/mem, imm8
VRNDSCALEPS | Rund verpacktes Einzelstück mit Skala | zmm, zmm/mem, imm8
VRNDSCALEPD | Rund verpackt, doppelt mit Skala | zmm, zmm/mem, imm8
VPMADD52HUQ | Multiplizieren und addieren Sie 52-Bit-QWords ohne Vorzeichen mit hohem Wert | zmm, zmm, zmm/mem
VPMADD52LUQ | Multiplizieren und addieren Sie 52-Bit-Quoten ohne Vorzeichen mit niedrigem Wert | zmm, zmm, zmm/mem
VPSLLVW | Variable logische Wörter nach links verschieben | zmm, zmm, zmm/mem
VPSLLVDQ | Variable logisches Dword/Qword nach links verschieben | zmm, zmm, zmm/mem
VPSRAVQ | Variable arithmetische Qwords nach rechts verschieben | zmm, zmm, zmm/mem
VPSRLVW | Variable logische Wörter nach rechts verschieben | zmm, zmm, zmm/mem
VPSRLVDQ | Variables logisches Dword/Qword nach rechts verschieben | zmm, zmm, zmm/mem
VPTERNLOGD | Bitweise Operation mit drei Eingaben (Dword) | zmm, zmm, zmm/mem, imm8
VPTERNLOGQ | Bitweise Operation mit drei Eingaben (qword) | zmm, zmm, zmm/mem, imm8
VPMOVDB | Packen und kürzen Sie Dwords in Bytes (schmal) | mem, zmm / xmm, zmm
VPMOVDW | Packen und kürzen Sie Dwords in Wörter (schmal) | mem, zmm / xmm, zmm
VPMOVQB | Packen und kürzen Sie qwords in Bytes (schmal) | mem, zmm / xmm, zmm
VPMOVQD | Packen und kürzen Sie qwords in dwords (schmal) | mem, zmm / xmm, zmm
VPMOVQW | Packen und kürzen Sie qwords in Wörter (schmal) | mem, zmm / xmm, zmm
VPMOVWB | Packen und kürzen Sie Wörter in Bytes (schmal) | mem, zmm / xmm, zmm
VPOPCNTB | Populationsanzahl der Bytes (Vektor) | zmm, zmm/mem
VPOPCNTW | Bevölkerungszahl von Wörtern (Vektor) | zmm, zmm/mem
VPOPCNTD | Bevölkerungszahl von Dwords (Vektor) | zmm, zmm/mem
VPOPCNTQ | Bevölkerungszahl von qwords (Vektor) | zmm, zmm/mem
VDBPSADBW | Doppelblockgepackte Summe von ABS-Diffs (Wörtern) | zmm, zmm, zmm/mem, imm8
VSHUFI32X4 | Mischen Sie 128-Bit-Spuren mit 32-Bit-Elementen | zmm, zmm, zmm/mem, imm8
VSHUFI64X2 | Mischen Sie 128-Bit-Spuren mit 64-Bit-Elementen | zmm, zmm, zmm/mem, imm8

Anweisungen zum Maskenregister (k0-k7)

AVX-512 führt 8 Maskenregister (k0-k7) für prädizierte Operationen ein. k0 ist fest mit allen Einsen verbunden (keine Maskierung). Die typische Syntax istvmovdqa32 zmm1 {k1}{z}, zmm2.

Gedächtnisstütze | Beschreibung | Operanden
KMOVB/KMOVW/KMOVD/KMOVQ | Verschieben Sie das Maskenregister zum/vom GPR oder Speicher | k, k/reg/mem
KADDB/KADDW/KADDD/KADDQ | Fügen Sie zwei Maskenregister hinzu | k, k, k
KANDB/KANDW/KANDD/KANDQ | Bitweises UND von Maskenregistern | k, k, k
KANDNB/KANDNW/KANDND/KANDNQ | Bitweises UND-NICHT von Maskenregistern | k, k, k
KORB/KORW/KORD/KORQ | Bitweises ODER von Maskenregistern | k, k, k
KXORB/KXORW/KXORD/KXORQ | Bitweises XOR von Maskenregistern | k, k, k
KXNORB/KXNORW/KXNORD/KXNORQ | Bitweises XNOR von Maskenregistern | k, k, k
KNOTB/KNOTW/KNOTD/KNOTQ | Bitweises NICHT des Maskenregisters | k, k
KORTESTB/KORTESTW/KORTESTD/KORTESTQ | ODER-Test (setzt CF/ZF, wenn das Ergebnis nur Einsen/Null ist) | k, k
KSHIFTLB/KSHIFTLW/KSHIFTLD/KSHIFTLQ | Verschiebe das Maskenregister um imm8 nach links | k, k, imm8
KSHIFTRB/KSHIFTRW/KSHIFTRD/KSHIFTRQ | Verschiebe das Maskenregister um imm8 nach rechts | k, k, imm8

AVX-512BW – Byte-/Worterweiterungen

Gedächtnisstütze | Beschreibung | Operanden
VPADDB | Gepackte Bytes hinzufügen (512-Bit mit Opmask) | zmm, zmm, zmm/mem
VPADDW | Gepackte Wörter hinzufügen (512-Bit mit Opmask) | zmm, zmm, zmm/mem
VPSUBB | Gepackte Bytes subtrahieren (512-Bit mit Opmask) | zmm, zmm, zmm/mem
VPSUBW | Gepackte Wörter subtrahieren (512-Bit mit Opmask) | zmm, zmm, zmm/mem
VPSLLVW | Variable logische Wörter nach links verschieben | zmm, zmm, zmm/mem
VPSRLVW | Variable logische Wörter nach rechts verschieben | zmm, zmm, zmm/mem
VPSRAVW | Variable arithmetische Wörter nach rechts verschieben | zmm, zmm, zmm/mem
VPABSB | Absoluter Wert der Bytes (512-Bit) | zmm, zmm/mem
VPABSW | Absoluter Wortwert (512-Bit) | zmm, zmm/mem
VPMOVB2M | Verschieben Sie die Bytemaske vom Vektor in das k-Register | k, zmm
VPMOVW2M | Verschieben Sie die Wortmaske vom Vektor in das k-Register | k, zmm
VPMOVM2B | Maske vom k-Register in den Byte-Vektor verschieben | zmm, k
VPMOVM2W | Maske vom k-Register in den Wortvektor verschieben | zmm, k
VDBPSADBW | Doppelblockgepackte Summe von ABS-Diffs (Wörtern) | zmm, zmm, zmm/mem, imm8

AVX-512DQ – Doppel-/Quadword-Erweiterungen

Gedächtnisstütze | Beschreibung | Operanden
VPMULLQ | Multiplizieren Sie gepackte Qwords mit Vorzeichen (niedrige 64 Bit) | zmm, zmm, zmm/mem
VPANDQ | Bitweises UND von qwords | zmm, zmm, zmm/mem
VPORQ | Bitweises ODER von qwords | zmm, zmm, zmm/mem
VPXORQ | Bitweises XOR von qwords | zmm, zmm, zmm/mem
VPABSQ | Absoluter Wert von qwords | zmm, zmm/mem
VPMOVD2M | Verschieben Sie die Dword-Maske vom Vektor in das k-Register | k, zmm
VPMOVQ2M | Verschieben Sie die qword-Maske vom Vektor in das k-Register | k, zmm
VPMOVM2D | Verschieben Sie die Maske vom k-Register in den dword-Vektor | zmm, k
VPMOVM2Q | Maske vom k-Register in den qword-Vektor verschieben | zmm, k

AVX-512ER – Exponentiell/Reziprok

Eingeführt in Intel Xeon Phi (Knights Landing). Bietet hochpräzise exponentielle, reziproke und reziproke Quadrate.

Gedächtnisstütze | Beschreibung | Operanden
VEXP2PD | Exponentielle Näherung zur Basis 2 (doppelt, gepackt) | zmm, zmm/mem
VEXP2PS | Exponentielle Näherung zur Basis 2 (einfach, gepackt) | zmm, zmm/mem
VRCP28PD | 28-Bit-Reziproknäherung (doppelt, gepackt) | zmm, zmm/mem
VRCP28PS | 28-Bit-Reziproknäherung (einzeln, gepackt) | zmm, zmm/mem
VRCP28SD | 28-Bit-Reziproknäherung (doppelt, skalar) | xmm, xmm, xmm/Speicher
VRCP28SS | 28-Bit-Reziproknäherung (einfach, skalar) | xmm, xmm, xmm/Speicher
VRSQRT28PD | 28-Bit reziproke Quadratnäherung (doppelt, gepackt) | zmm, zmm/mem
VRSQRT28PS | 28-Bit reziproke Quadratnäherung (einzeln, gepackt) | zmm, zmm/mem
VRSQRT28SD | 28-Bit reziproke Quadratnäherung (doppelt, skalar) | xmm, xmm, xmm/Speicher
VRSQRT28SS | 28-Bit-Reziprok-Quadrat-Näherung (einfach, skalar) | xmm, xmm, xmm/Speicher

AVX-512PF – Prefetch Gather/Scatter

Prefetch-Hinweise für Gather/Scatter-Vorgänge (nur Xeon Phi). Verwendet VSIB-Adressierung.

Gedächtnisstütze | Beschreibung | Operanden
VGATHERPF0DPD | Prefetch Gather Double, Intent Level 0 | mem (VSIB)
VGATHERPF0DPS | Prefetch Gather Single, Intent Level 0 | mem (VSIB)
VGATHERPF1DPD | Prefetch Gather Double, Intent Level 1 | mem (VSIB)
VGATHERPF1DPS | Prefetch Gather Single, Intent Level 1 | mem (VSIB)
VSCATTERPF0DPD | Prefetch-Scatter-Double, Absichtsstufe 0 | mem (VSIB)
VSCATTERPF0DPS | Prefetch-Scatter einzeln, Absichtsebene 0 | mem (VSIB)
VSCATTERPF1DPD | Prefetch-Scatter-Double, Absichtsstufe 1 | mem (VSIB)
VSCATTERPF1DPS | Prefetch-Scatter einzeln, Absichtsebene 1 | mem (VSIB)

AVX-512VPOPCNTDQ – Vektor-Popcount

Gedächtnisstütze | Beschreibung | Operanden
VPOPCNTD | Populationsanzahl von Dword-Elementen | zmm, zmm/mem
VPOPCNTQ | Populationszahl von qword-Elementen | zmm, zmm/mem

AVX-512BITALG – Bit-Algorithmen

Gedächtnisstütze | Beschreibung | Operanden
VPOPCNTB | Populationsanzahl von Byte-Elementen | zmm, zmm/mem
VPOPCNTW | Populationszahl von Wortelementen | zmm, zmm/mem
VPSHUFBITQMB | Mischen Sie die Bits im Qword zur Byte-Maske | k, zmm, zmm/mem

AVX-512VBMI – Vektorbyte-Manipulation

Gedächtnisstütze | Beschreibung | Operanden
VPERMB | Bytes über Lanes hinweg permutieren | zmm, zmm, zmm/mem
VPERMI2B | Zwei-Quellen-Permutation von Bytes mit Index | zmm, zmm, zmm/mem
VPERMT2B | Permutation von Bytes aus zwei Quellen (Index im Ziel) | zmm, zmm, zmm/mem
VPMULTISHIFTQB | Mehrfaches Verschieben und Verketten von Qwords zu Bytes | zmm, zmm, zmm/mem

AVX-512VBMI2 – Byte-/Wortkomprimierung/-erweiterung

Gedächtnisstütze | Beschreibung | Operanden
VCOMPRESSB | Gepackte Bytes komprimieren (durch Maske) | zmm, zmm/mem
VCOMPRESSW | Komprimieren Sie gepackte Wörter (durch Maske) | zmm, zmm/mem
VEXPANDB | Gepackte Bytes erweitern (nach Maske) | zmm, zmm/mem
VEXPANDW | Gepackte Wörter erweitern (durch Maske) | zmm, zmm/mem
VPSHLDV | Variable Verschiebung nach links doppelt (verkettete Verschiebung) | zmm, zmm, zmm/mem
VPSHLDVW | Variable Doppelwörter nach links verschieben | zmm, zmm, zmm/mem
VPSHRDV | Variable Verschiebung nach rechts doppelt (verkettete Verschiebung) | zmm, zmm, zmm/mem
VPSHRDVW | Variable Doppelwörter nach rechts verschieben | zmm, zmm, zmm/mem

GFNI – Galois Field Neue Anweisungen

Gedächtnisstütze | Beschreibung | Operanden
VGF2P8AFFINEINVQB | Galois-Feld-Affintransformation invers | zmm/xmm, zmm/xmm, zmm/mem, imm8
VGF2P8AFFINEQB | Galoisfeldaffine Transformation | zmm/xmm, zmm/xmm, zmm/mem, imm8
VGF2P8MULB | Galois-Feld multipliziert Bytes (GF(2^8)) | zmm/xmm, zmm/xmm, zmm/mem

AVX-512 – Streuspeicher

Gedächtnisstütze | Beschreibung | Operanden
VSCATTERDPS | Scatter-gepackte Single mit Dword-Indizes | mem, zmm
VSCATTERDPD | Scatter-gepacktes Doppel mit Dword-Indizes | mem, zmm
VSCATTERQPS | Streugepackte Single mit Qword-Indizes | mem, zmm
VSCATTERQPD | Scatter-gepacktes Doppel mit Qword-Indizes | mem, zmm

AVX-512 – Zusätzliche Operationen

Gedächtnisstütze | Beschreibung | Operanden
VALIGND | Dwords ausrichten (verketten und verschieben) | zmm, zmm, zmm/mem, imm8
VALIGNQ | Qwords ausrichten (verketten und verschieben) | zmm, zmm, zmm/mem, imm8
VBLENDMPD | Mischen Sie die Mischung doppelt aus der Maske | zmm, zmm, zmm/mem
VBLENDMPS | Mischung verpackt einzeln aus der Maske | zmm, zmm, zmm/mem
VPBLENDMD | Mischen Sie gepackte Dwords aus der Maske | zmm, zmm, zmm/mem
VPBLENDMQ | Mischen Sie gepackte QWords aus der Maske | zmm, zmm, zmm/mem
VCOMPRESSPS | Verpackte Single komprimieren (durch Maske) | zmm, zmm/mem
VCOMPRESSPD | Komprimieren Sie das Doppelte (durch Maske) | zmm, zmm/mem
VCOMPRESSD | Komprimieren Sie gepackte Dwords (durch Maske) | zmm, zmm/mem
VCOMPRESSQ | Komprimieren Sie gepackte Qwords (durch Maske) | zmm, zmm/mem
VEXPANDPS | Gepackte Single erweitern (nach Maske) | zmm, zmm/mem
VEXPANDPD | Gepacktes Doppel erweitern (durch Maske) | zmm, zmm/mem
VEXPANDD | Gepackte Dwords erweitern (nach Maske) | zmm, zmm/mem
VEXPANDQ | Gepackte QWords erweitern (nach Maske) | zmm, zmm/mem
VFIXUPIMMSD | Skalar-Double reparieren (NaN-Handhabung) | xmm, xmm, xmm/mem, imm8
VFIXUPIMMSS | Skalar-Single reparieren (NaN-Handhabung) | xmm, xmm, xmm/mem, imm8
VREDUCESD | Skalar-Double reduzieren (auf N Bits runden) | xmm, xmm, xmm/mem, imm8
VREDUCESS | Skalare Single reduzieren (auf N Bits runden) | xmm, xmm, xmm/mem, imm8
VRNDSCALESD | Rundes Skalardoppel mit Skala | xmm, xmm, xmm/mem, imm8
VRNDSCALESS | Runder Skalar einzeln mit Skala | xmm, xmm, xmm/mem, imm8
VRANGESD | Bereichseinschränkung Skalar Double | xmm, xmm, xmm/mem, imm8
VRANGESS | Bereichseinschränkung Skalar Single | xmm, xmm, xmm/mem, imm8
VGETEXPSD | Exponenten-Skalar-Doppel extrahieren | xmm, xmm, xmm/Speicher
VGETEXPSS | Exponentenskalar einzeln extrahieren | xmm, xmm, xmm/Speicher
VGETMANTSD | Extrahieren Sie das normalisierte Mantissen-Skalar-Double | xmm, xmm, xmm/mem, imm8
VGETMANTSS | Extrahieren Sie den normalisierten Mantissenskalar einzeln | xmm, xmm, xmm/mem, imm8
VPSRAVQ | Variable arithmetische Qwords nach rechts verschieben | zmm, zmm, zmm/mem
VPERMI2W | Permutation von Wörtern aus zwei Quellen mit Index | zmm, zmm, zmm/mem
VPERMT2W | Permutation von Wörtern aus zwei Quellen (Index im Ziel) | zmm, zmm, zmm/mem
VPERMI2D | Zwei-Quellen-Permutation von Dwords mit Index | zmm, zmm, zmm/mem
VPERMI2Q | Zwei-Quellen-Permutation von qwords mit Index | zmm, zmm, zmm/mem
VPERMI2PS | Permutation von Singles aus zwei Quellen mit Index | zmm, zmm, zmm/mem
VPERMI2PD | Zwei-Quellen-Permutation von Doubles mit Index | zmm, zmm, zmm/mem
VPERMT2D | Zwei-Quellen-Permutation von Dwords (Index im Ziel) | zmm, zmm, zmm/mem
VPERMT2Q | Permutation von qwords aus zwei Quellen (Index im Ziel) | zmm, zmm, zmm/mem
VPERMT2PS | Zwei-Quellen-Permutation von Singles (Index im Ziel) | zmm, zmm, zmm/mem
VPERMT2PD | Zwei-Quellen-Permutation von Doubles (Index im Ziel) | zmm, zmm, zmm/mem
Notiz:AVX-512-Anweisungen können Opmask-Register (k1-k7) verwenden. Opmask Null (k0) ist mit allen Einsen fest verdrahtet und fungiert als „keine Maske“. Die typische Syntax ist:vmovdqa32 zmm1 {k1}{z}, zmm2Dabei aktiviert {k1} die Maskierung und {z} den Nullungsmaskenmodus. Das Suffix-Suffix (32/64 für dword/qword-Elementgröße) bestimmt, für welche Elemente die Maske gilt.

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

← Assembler-Anweisungen Nach oben BMI1/BMI2-Mnemonik →

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes


MMX-Mnemonik

MMX (MultiMedia eXtensions) bietet 64-Bit-SIMD-Operationen auf MMX-Registern (mm0–mm7), die dem x87-FPU-Stack als Alias ​​zugeordnet sind. PBXB64 unterstützt alle 57 MMX-Befehle. MMX-Register sind 64 Bit breit und verarbeiten gepackte Byte-, Wort- oder Doppelwort-Ganzzahlen.

Notiz:MMX-Register teilen sich den physischen Speicher mit x87-FPU-Registern. Immer verwendenEMMSnach dem MMX-Code, bevor Sie FPU-Anweisungen verwenden. Bevorzugen Sie auf modernen CPUs SSE2 für Integer-SIMD.

Datenbewegung

Gedächtnisstütze | Beschreibung | Operanden
MOVD | Doppelwort in/vom MMX-Register verschieben | mm, reg32/mem32 / reg32, mm
MOVQ | Quadword in/vom MMX-Register verschieben | mm, mm/mem64 / mem64, mm

Gepackte Arithmetik

Gedächtnisstütze | Beschreibung | Operanden
PADDB | Gepackte Bytes hinzufügen (bei Überlauf umbrechen) | mm, mm/mem64
PADDW | Gepackte Wörter hinzufügen (Umbruch) | mm, mm/mem64
PADDD | Gepackte Doppelwörter hinzufügen (Umbruch) | mm, mm/mem64
PADDSB | Fügen Sie gepackte Bytes mit vorzeichenbehafteter Sättigung hinzu | mm, mm/mem64
PADDSW | Fügen Sie gepackte Wörter mit vorzeichenbehafteter Sättigung hinzu | mm, mm/mem64
PADDUSB | Fügen Sie gepackte Bytes mit vorzeichenloser Sättigung hinzu | mm, mm/mem64
PADDUSW | Fügen Sie gepackte Wörter mit vorzeichenloser Sättigung hinzu | mm, mm/mem64
PSUBB | Gepackte Bytes subtrahieren (Wrap) | mm, mm/mem64
PSUBW | Gepackte Wörter subtrahieren (Umbruch) | mm, mm/mem64
PSUBD | Gepackte Doppelwörter subtrahieren (Umbruch) | mm, mm/mem64
PSUBSB | Subtrahieren Sie gepackte Bytes mit vorzeichenbehafteter Sättigung | mm, mm/mem64
PSUBSW | Subtrahieren Sie gepackte Wörter mit vorzeichenbehafteter Sättigung | mm, mm/mem64
PSUBUSB | Subtrahieren Sie gepackte Bytes mit vorzeichenloser Sättigung | mm, mm/mem64
PSUBUSW | Subtrahieren Sie gepackte Wörter mit vorzeichenloser Sättigung | mm, mm/mem64
PMULLW | Multiplizieren Sie gepackte Wörter (niedrige 16 Bits des Produkts) | mm, mm/mem64
PMULHW | Multiplizieren Sie gepackte Wörter (höhere 16 Bits des Produkts) | mm, mm/mem64
PMULHUW | Mehrfach gepackte vorzeichenlose Wörter (hohe 16 Bit) | mm, mm/mem64
PMADDWD | Multiplizieren Sie gepackte Wörter und fügen Sie sie zu Doppelwörtern hinzu | mm, mm/mem64

Vergleich

Gedächtnisstütze | Beschreibung | Operanden
PCMPEQB | Vergleichen Sie gepackte Bytes auf Gleichheit | mm, mm/mem64
PCMPEQW | Vergleichen Sie gepackte Wörter auf Gleichheit | mm, mm/mem64
PCMPEQD | Vergleichen Sie gepackte Doppelwörter auf Gleichheit | mm, mm/mem64
PCMPGTB | Vergleichen Sie gepackte Bytes auf größer als (mit Vorzeichen) | mm, mm/mem64
PCMPGTW | Vergleichen Sie gepackte Wörter für größer als | mm, mm/mem64
PCMPGTD | Vergleichen Sie gepackte Doppelwörter für größer als | mm, mm/mem64

Logisch

Gedächtnisstütze | Beschreibung | Operanden
PAND | Bitwise AND | mm, mm/mem64
PANDN | Bitwise AND-NOT | mm, mm/mem64
POR | Bitwise OR | mm, mm/mem64
PXOR | Bitwise XOR | mm, mm/mem64

Schicht

Gedächtnisstütze | Beschreibung | Operanden
PSLLW | Pack verschiebt logische Wörter nach links | mm, imm8/mm
PSLLD | Pack-Shift-Links-logische Doppelwörter | mm, imm8/mm
PSLLQ | Packen Sie das logische Vierwort nach links | mm, imm8/mm
PSRLW | Packen Sie logische Wörter nach rechts | mm, imm8/mm
PSRLD | Packen Sie logische Doppelwörter mit Rechtsverschiebung | mm, imm8/mm
PSRLQ | Packen Sie das logische Vierwort nach rechts | mm, imm8/mm
PSRAW | Packen Sie arithmetische Wörter nach rechts | mm, imm8/mm
PSRAD | Packen Sie arithmetische Doppelwörter mit Rechtsverschiebung | mm, imm8/mm

Packen / Auspacken

Gedächtnisstütze | Beschreibung | Operanden
PACKSSWB | Vorzeichenbehaftete Wörter in Bytes packen (gesättigt) | mm, mm/mem64
PACKSSDW | Vorzeichenbehaftete Doppelwörter zu Wörtern packen (gesättigt) | mm, mm/mem64
PACKUSWB | Packen Sie vorzeichenlose Wörter in Bytes (unsigned sat.) | mm, mm/mem64
PUNPCKHBW | Hohe Bytes entpacken (Interleave) | mm, mm/mem64
PUNPCKHWD | Packen Sie hohe Wörter aus | mm, mm/mem64
PUNPCKHDQ | Hohe Doppelwörter auspacken | mm, mm/mem64
PUNPCKLBW | Low-Bytes entpacken | mm, mm/mem64
PUNPCKLWD | Packen Sie niedrige Wörter aus | mm, mm/mem64
PUNPCKLDQ | Entpacken Sie niedrige Doppelwörter | mm, mm/mem64

Konvertierung

Gedächtnisstütze | Beschreibung | Operanden
PACKSSWB | Wörter in Bytes packen (gesättigt) | mm, mm/mem64
PACKSSDW | Doppelwörter zu Wörtern packen (gesättigt) | mm, mm/mem64
PACKUSWB | Packen Sie Wörter in Bytes (ohne Vorzeichen gesättigt) | mm, mm/mem64
PMOVMSKB | Bytemaske nach GPR verschieben (MSB jedes Bytes) | reg, mm

Staatsverwaltung

Gedächtnisstütze | Beschreibung
EMMS | Leerer MMX-Status (MMX/x87-Tag-Wort löschen)
FEMMS | Schnelles EMMS (AMD, löscht weniger Register)

MMX-Beispiele

; Add 8 bytes with saturation
movq    mm0, [byte_array_a]
movq    mm1, [byte_array_b]
paddusb mm0, mm1          ; unsigned saturated add
movq    [result], mm0

; Compare two 16-bit vectors
movq    mm0, [vector_a]
movq    mm1, [vector_b]
pcmpeqw mm0, mm1          ; word-wise equality
movq    [result], mm0

; Calculate sum of absolute differences
movq    mm0, [block_a]
movq    mm1, [block_b]
psadbw  mm0, mm1         ; sum of absolute differences -> low qword
movd    eax, mm0         ; result in eax

; Always clear MMX state before FPU
emms                     ; important!

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

← x87-FPU-Mnemonik Nach oben SGX / VMX / CET-Mnemonik →

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes


x87-FPU-Mnemonik

Die x87-Gleitkommaeinheit bietet 80-Bit-Arithmetik mit erweiterter Genauigkeit. PBXB64 unterstützt den vollständigen x87-Befehlssatz. Der x87 verfügt über 8 Register (ST0-ST7), die als Stapel organisiert sind, und unterstützt einfache (32-Bit), doppelte (64-Bit) und erweiterte (80-Bit) Genauigkeit.

Notiz:Bevorzugen Sie auf modernen x64-Prozessoren SSE-Anweisungen für skalare Gleitkommazahlen. Der x87 wird hauptsächlich für Berechnungen mit erweiterter Genauigkeit (80-Bit) oder für die Kompatibilität mit Legacy-Code verwendet.

Datenübertragung

Gedächtnisstütze | Beschreibung | Operanden
FLD | Echten Wert auf Stapel laden (Push) | mem32/64/80 / ST(i)
FST | Speichern Sie den tatsächlichen Wert (pop = FSTP) | mem32/64 / ST(i)
FSTP | Speichern Sie echten Wert und Pop | mem32/64/80 / ST(i)
FILD | Ganzzahlwert auf Stapel laden (Push) | mem16/32/64
FIST | Ganzzahligen Wert speichern | mem16/32
FISTP | Speichern Sie einen ganzzahligen Wert und Pop | mem16/32/64
FISTTP | Ganzzahl abschneiden und speichern, Pop (SSE3) | mem16/32/64
FBLD | BCD-Wert laden (18-stelliges gepacktes BCD) | mem80 (TBYTE)
FBSTP | Speichern Sie den BCD-Wert und den Pop | mem80 (TBYTE)
FXCH | Tausche ST(0) mit ST(i) | ST(i)
; Load constants
fld     [double_var]       ; push 64-bit value
fild    [int_val]          ; push integer converted to float
fldz                       ; push +0.0
fld1                       ; push +1.0
fldpi                      ; push pi
fldl2t                     ; push log2(10)
fldl2e                     ; push log2(e)
fldlg2                     ; push log10(2)
fldln2                     ; push ln(2)

; Store results
fstp    [result]           ; pop and store to memory

Grundrechenarten

Gedächtnisstütze | Beschreibung | Operanden
FADD | Addieren (ST0 = ST0 + src) | mem32/64 / ST(i)
FADDP | Addieren und Pop (ST(i) = ST(i)+ST0, dann Pop) | ST(i), ST(0)
FIADD | Fügen Sie eine Ganzzahl zu ST0 hinzu | mem16/32
FSUB | Subtrahieren (ST0 = ST0 - src) | mem32/64 / ST(i)
FSUBP | Subtrahieren und Pop | ST(i), ST(0)
FSUBR | Rückwärts subtrahieren (ST0 = src - ST0) | mem32/64 / ST(i)
FSUBRP | Subtrahieren Sie Reverse und Pop | ST(i), ST(0)
FISUB | Ganzzahl subtrahieren | mem16/32
FMUL | Multiplizieren (ST0 = ST0 * src) | mem32/64 / ST(i)
FMULP | Multiplizieren und Pop | ST(i), ST(0)
FIMUL | Mit einer Ganzzahl multiplizieren | mem16/32
FDIV | Teilen (ST0 = ST0 / src) | mem32/64 / ST(i)
FDIVP | Teilen und platzen | ST(i), ST(0)
FDIVR | Rückwärts dividieren (ST0 = src / ST0) | mem32/64 / ST(i)
FDIVRP | Umgekehrt teilen und platzen lassen | ST(i), ST(0)
FIDIV | Durch ganze Zahl dividieren | mem16/32
FPREM | Teilweise Rest | keiner
FPREM1 | Teilweise Rest (IEEE) | keiner
FABS | Absoluter Wert | keiner
FCHS | Vorzeichen ändern (negieren) | keiner
FRNDINT | Auf Ganzzahl runden (aktueller Rundungsmodus) | keiner
FSQRT | Quadratwurzel | keiner
FSCALE | Skalierung durch Zweierpotenz (ST0 * 2^ST1) | keiner
FXTRACT | Extrahieren Sie Exponent und Signifikand | keiner
; Compute: result = sqrt(a*a + b*b)
fld     [a]                ; ST0 = a
fmul    ST0, ST0           ; ST0 = a^2
fld     [b]                ; ST0 = b, ST1 = a^2
fmul    ST0, ST0           ; ST0 = b^2, ST1 = a^2
faddp   ST1, ST0           ; ST0 = a^2 + b^2
fsqrt                      ; ST0 = sqrt(a^2 + b^2)
fstp    [result]           ; store result, pop

Vergleich

Gedächtnisstütze | Beschreibung | Operanden
FCOM | Vergleichen Sie ST0 mit src (stellt das FPU-Statuswort C0/C2/C3 ein) | mem32/64 / ST(i)
FCOMP | Vergleichen und Pop | mem32/64 / ST(i)
FCOMPP | Vergleichen und Pop zweimal | keiner
FICOM | Vergleichen Sie ST0 mit einer Ganzzahl | mem16/32
FICOMP | Vergleichen Sie Integer und Pop | mem16/32
FCOMI | Vergleichen und setzen Sie EFLAGS (P6+, ST0 mit ST[i]) | ST(i)
FCOMIP | Vergleichen, EFLAGS setzen und Pop | ST(i)
FUCOMI | Ungeordneter Vergleich, EFLAGS setzen | ST(i)
FUCOMIP | Ungeordneter Vergleich, EFLAGS setzen, Pop | ST(i)
FUCOM | Ungeordneter Vergleich (keine Ausnahme bei NaN) | ST(i)
FUCOMP | Ungeordneter Vergleich und Pop | ST(i)
FUCOMPP | Ungeordneter Vergleich und zweimal Pop | keiner
FTST | Testen Sie ST0 gegen 0,0 | keiner
FXAM | Untersuchen Sie ST0 (NaN, normal, denormal, Null usw.) | keiner
; Compare ST0 with ST1
fcom    ST1                ; compare, sets FPU flags
fstsw   ax                 ; store FPU status word to AX
sahf                       ; load AH into EFLAGS
jae     above_or_equal

; Compare using FCOMI (direct EFLAGS)
fcomi   ST0, ST1           ; sets ZF/PF/CF directly
jb      below
je      equal
ja      above

Konstanten

Gedächtnisstütze | Beschreibung | Gepushter Wert
FLDZ | Laden Sie +0,0 | +0,0
FLD1 | Laden Sie +1,0 | +1,0
FLDPI | Belastung pi (π) | 3.14159265358979324
FLDL2E | Log2(e) laden | 1.44269504088896341
FLDLN2 | Lade ln(2) | 0,69314718055994531
FLDL2T | Log2(10) laden | 3.32192809488736235
FLDLG2 | Log10(2) laden | 0,30102999566398120

Trigonometrisch / Transzendental

Gedächtnisstütze | Beschreibung
FSIN | Sinus von ST0 (ST0 im Bogenmaß)
FCOS | Kosinus von ST0
FSINCOS | Sinus und Cosinus von ST0 (ST1=sin, ST0=cos)
FPTAN | Partielle Tangente (ST1=tan, ST0=1,0)
FPATAN | Teilarkustangens (ST1/ST0 → ST1=atan, pop)
F2XM1 | 2^ST0 - 1
FYL2X | ST1 * log2(ST0), pop
FYL2XP1 | ST1 * log2(ST0 + 1), pop
; Compute sin(x)
fld     [x]
fsin                       ; ST0 = sin(x)
fstp    [result]           ; store

; Compute x * log2(y)
fld     [y]
fld     [x]
fyl2x                      ; ST0 = x * log2(y)
fstp    [result]

; Compute 2^x - 1
fld     [x]
f2xm1                      ; ST0 = 2^x - 1
fstp    [result]

Kontrolle / Status

Gedächtnisstütze | Beschreibung | Operanden
FNCLEX | FPU-Ausnahmen löschen (keine Wartezeit) | keiner
FCLEX | FPU-Ausnahmen löschen (warten) | keiner
FNINIT | FPU initialisieren (keine Wartezeit) | keiner
FINIT | FPU initialisieren (warten) | keiner
FSTSW | FPU-Statuswort speichern | mem16 / AX
FSTCW | FPU-Steuerwort speichern | mem16
FLDCW | FPU-Steuerwort laden | mem16
FSTENV | Speichern Sie die FPU-Umgebung | mem (14/28 Byte)
FLDENV | Laden Sie die FPU-Umgebung | mem
FSAVE | FPU-Status speichern (94/108 Byte) | mem
FRSTOR | FPU-Status wiederherstellen | mem
FINCSTP | Erhöhen Sie den FPU-Stapelzeiger | keiner
FDECSTP | Dekrementieren Sie den FPU-Stapelzeiger | keiner
FFREE | Freies FPU-Register ST(i) | ST(i)
FNOP | FPU funktioniert nicht | keiner
FWAIT | Warten auf FPU (Assembly: WAIT) | keiner

FPU-Steuerwort

Das FPU-Steuerwort steuert Präzision, Rundungsmodus und Ausnahmemasken:

Bit(s) | Feld | Werte
1:0 | Rundungskontrolle | 00=am nächsten, 01=unten, 10=oben, 11=abschneiden
3:2 | Präzise Kontrolle | 00=24-Bit (einzeln), 10=53-Bit (doppelt), 11=64-Bit (erweitert)
5 | Ausnahme: Präzision | 0=maskiert, 1=demaskiert
6 | Ausnahme: Unterlauf |
7 | Ausnahme: Überlauf |
8 | Ausnahme: Nullteilung |
9 | Ausnahme: Denormal |
10 | Ausnahme: Ungültig |
; Set rounding to truncate (toward zero)
fstcw  [cw]               ; save current control word
mov    ax, [cw]
or     ax, 0x0C00         ; set RC bits to 11 (truncate)
mov    [cw_new], ax
fldcw  [cw_new]           ; load new control word

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

← AES / SHA / CLMUL / CRC32-Mnemonik Nach oben MMX-Mnemonik →

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes


BMI1/BMI2-Mnemonik

Bitmanipulationsbefehlssätze 1 und 2, eingeführt in Intel Haswell (2013) und AMD Jaguar/Piledriver. Diese Anweisungen beschleunigen Bitfeldoperationen und Arithmetik mit beliebiger Genauigkeit.

BMI1

Gedächtnisstütze | Beschreibung | Operanden | CPUID-Flag
ANDN | Bitweises UND-NICHT: dst = ~src1 & src2 | reg, reg, reg/mem | BMI1
BEXTR | Bitfeld-Extraktion: Aufeinanderfolgende Bits extrahieren | reg, reg/mem, reg/imm | BMI1
BLSI | Niedrigstes gesetztes Bit isolieren: dst = src & -src | reg, reg/mem | BMI1
BLSMSK | Maske bis zum niedrigsten gesetzten Bit: dst = src ^ (src-1) | reg, reg/mem | BMI1
BLSR | Niedrigstes gesetztes Bit zurücksetzen: dst = src & (src-1) | reg, reg/mem | BMI1
TZCNT | Nachgestellte Nullen zählen (verwendet im Gegensatz zu BSF das F3-Präfix) | reg, reg/mem | BMI1

BMI1-Beispiele

andn   eax, ebx, ecx      ; eax = ~ebx & ecx
bextr  eax, ecx, 8        ; eax = bits 15:8 of ecx (start=8, len=8)
blsi   eax, [var]         ; eax = [var] & -[var]
blsmsk eax, edx           ; eax = edx ^ (edx-1)
blsr   eax, ecx           ; eax = ecx & (ecx-1)  -- clears lowest set bit
tzcnt  eax, ebx           ; eax = count trailing zeros in ebx

BMI2

Gedächtnisstütze | Beschreibung | Operanden | CPUID-Flag
BZHI | Null hohe Bits: wenn index<operand_size, dst=src & mask | reg, reg/mem, reg | BMI2
MULX | Vorzeichenlose Multiplikation ohne Auswirkungen auf Flags | reg, reg, reg/mem | BMI2
PDEP | Parallele Biteinzahlung: Streuen Sie die Bits mithilfe einer Maske | reg, reg, reg/mem | BMI2
PEXT | Parallele Bits extrahieren: Bits mithilfe einer Maske sammeln | reg, reg, reg/mem | BMI2
RORX | Sofort nach rechts drehen (keine Flaggen betroffen) | reg, reg/mem, imm8 | BMI2
SARX | Arithmetik um Variable nach rechts verschieben (keine Flags) | reg, reg/mem, reg | BMI2
SHLX | Logische Verschiebung nach links durch Variable (keine Flags) | reg, reg/mem, reg | BMI2
SHRX | Logisch nach rechts verschieben nach Variable (keine Flags) | reg, reg/mem, reg | BMI2

BMI2-Beispiele

bzhi   eax, ebx, ecx       ; zero bits above position ecx in ebx
mulx   edx, eax, ecx       ; edx:eax = ecx * [implicit rdx:rax]
pdep   rax, rbx, rcx       ; deposit bits of rbx using mask in rcx
pext   rax, rbx, rcx       ; extract bits of rbx using mask in rcx
rorx   eax, [var], 8       ; rotate right by 8, no flags
sarx   eax, ebx, ecx       ; arithmetic shift right ebx by ecx
shlx   eax, ebx, ecx       ; logical shift left ebx by ecx
shrx   eax, ebx, ecx       ; logical shift right ebx by ecx

ADCX / ADOX – Add. mit beliebiger Präzision

Intel Haswell führte ADCX und ADOX für Multipräzisionsarithmetik mit unabhängigen Carry Chains ein.

Gedächtnisstütze | Beschreibung | Operanden
ADCX | Mit Carry hinzufügen (verwendet nur CF-Flag) | reg32/64, reg/mem
ADOX | Mit Überlauf hinzufügen (verwendet nur das OF-Flag) | reg32/64, reg/mem
; Multi-precision addition with dual carry chains
adcx  rcx, [rsi+0]         ; add with carry chain 1 (CF)
adox  rdx, [rsi+8]         ; add with carry chain 2 (OF)
adcx  r8,  [rsi+16]        ; continue chain 1
adox  r9,  [rsi+24]        ; continue chain 2
Notiz:ADCX verwendet ausschließlich das Carry Flag (CF). ADOX verwendet ausschließlich das Overflow Flag (OF). Dadurch können zwei unabhängige Übertragsketten parallel ablaufen, was den Durchsatz für die Arithmetik großer Ganzzahlen verdoppelt.

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

← AVX/AVX2/AVX-512/FMA-Mnemonik Nach oben Cache-Steuerung / Prefetch-Mnemonik →

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes


AES/SHA/CLMUL/CRC32-Mnemonik

Startseite› AES / SHA / CLMUL / CRC32-Mnemonik

Krypto-/Sicherheitsmnemonik

AES-NI (AES New Instructions), SHA-Erweiterungen, Carry-less Multiplication (CLMUL) und CRC32-Anweisungen für kryptografische und Prüfsummenbeschleunigung.

AES-NI – AES Neue Anweisungen

Eingeführt in Intel Westmere (2010). Hardwarebeschleunigte AES-Verschlüsselung/Entschlüsselung.

Gedächtnisstütze | Beschreibung | Operanden
AESENC | Führen Sie eine Runde der AES-Verschlüsselung durch | xmm, xmm/mem128
AESENCLAST | Führen Sie die letzte Runde der AES-Verschlüsselung durch | xmm, xmm/mem128
AESDEC | Führen Sie eine Runde der AES-Entschlüsselung durch | xmm, xmm/mem128
AESDECLAST | Führen Sie die letzte Runde der AES-Entschlüsselung durch | xmm, xmm/mem128
AESIMC | Inverse Mix-Spalten (zur Schlüsselerweiterung) | xmm, xmm/mem128
AESKEYGENASSIST | Unterstützung bei der Generierung von AES-Rundschlüsseln | xmm, xmm/mem128, imm8

AES-Beispiele

; AES-128 encryption of one block
aeskeygenassist xmm2, xmm1, 1  ; generate round key 1
aesenc          xmm0, xmm2      ; round 1
; ...
aesenclast      xmm0, xmmk10    ; final round

; AES decryption
aesdec          xmm0, xmm2      ; round 1
aesdeclast      xmm0, xmmk10    ; final round
aesimc          xmm1, xmm0      ; inverse mix columns

VAES – AES mit AVX/AVX-512

Gedächtnisstütze | Beschreibung | Operanden
VAESENC | VEX/EVEX AES-Rundverschlüsselung | xmm/ymm/zmm, xmm/ymm/zmm, mem
VAESENCLAST | VEX/EVEX AES-Last-Round-Verschlüsselung | xmm/ymm/zmm, xmm/ymm/zmm, mem
VAESDEC | VEX/EVEX AES-Rundenentschlüsselung | xmm/ymm/zmm, xmm/ymm/zmm, mem
VAESDECLAST | VEX/EVEX AES letzte Entschlüsselungsrunde | xmm/ymm/zmm, xmm/ymm/zmm, mem
VAESIMC | VEX AES Inverse-Mix-Säulen | xmm, xmm/mem
VAESKEYGENASSIST | VEX AES-Schlüsselgenerierungsunterstützung | xmm, xmm/mem, imm8

PCLMULQDQ – Multiplikation ohne Übertrag

Gedächtnisstütze | Beschreibung | Operanden
PCLMULQDQ | Übertragsfreie Multiplikation zweier 64-Bit-Hälften | xmm, xmm/mem128, imm8
VPCLMULQDQ | VEX/EVEX Carry-less-Multiplikation | xmm/ymm/zmm, xmm/ymm/zmm, mem, imm8

Der Operand imm8 wählt aus, welche 64-Bit-Hälften multipliziert werden sollen:

Bits | Feld | Wert
1:0 | SRC2 auswählen | 00 = niedriges Q-Wort, 01 = hohes Q-Wort
5:4 | SRC1 (erster Operand) auswählen | 00 = niedriges Q-Wort, 01 = hohes Q-Wort
; GF(2^128) multiplication for AES-GCM
pclmulqdq xmm1, xmm2, 0x00   ; low * low
pclmulqdq xmm1, xmm2, 0x01   ; low * high
pclmulqdq xmm1, xmm2, 0x10   ; high * low
pclmulqdq xmm1, xmm2, 0x11   ; high * high

SHA-Erweiterungen

Eingeführt in Intel Goldmont (2016) und Ice Lake. Hardwarebeschleunigtes SHA-1 und SHA-256.

SHA-1

Gedächtnisstütze | Beschreibung | Operanden
SHA1RNDS4 | SHA-1 vier Runden | xmm, xmm/mem128, imm8
SHA1NEXTE | SHA-1 nächste vier E-Werte | xmm, xmm/mem128
SHA1MSG1 | Aktualisierung des SHA-1-Nachrichtenplans 1 | xmm, xmm/mem128
SHA1MSG2 | Aktualisierung des SHA-1-Nachrichtenplans 2 | xmm, xmm/mem128

SHA-256

Gedächtnisstütze | Beschreibung | Operanden
SHA256RNDS2 | SHA-256 zwei Runden | xmm, xmm/mem128
SHA256MSG1 | Aktualisierung des SHA-256-Nachrichtenplans 1 | xmm, xmm/mem128
SHA256MSG2 | Aktualisierung des SHA-256-Nachrichtenplans 2 | xmm, xmm/mem128

CRC32 – Zyklische Redundanzprüfung

Eingeführt in SSE4.2 (Intel Nehalem, 2008). Hardwarebeschleunigter CRC-32C (Castagnoli-Polynom 0x1EDC6F41).

Gedächtnisstütze | Beschreibung | Operanden
CRC32 | Akkumulieren Sie den CRC32C-Wert im Ziel | reg32/64, reg/mem8/16/32/64

Der erste Operand (Ziel) enthält den akkumulierten CRC-Wert. Der zweite Operand (Quelle) sind die Eingabedaten. Die Quellgröße bestimmt, welche Kodierung verwendet wird.

; CRC32 examples - source size determines encoding
crc32 eax, byte  [ptr]      ; 8-bit input
crc32 eax, word  [ptr]      ; 16-bit input (66 prefix)
crc32 eax, dword [ptr]      ; 32-bit input (default)
crc32 rax, qword [ptr]      ; 64-bit input (REX.W prefix)

; Chained CRC32 computation
xor   eax, eax              ; start with CRC = 0
crc32 eax, byte [rsi]       ; CRC-32C of byte 0
crc32 eax, byte [rsi+1]     ; accumulate byte 1
crc32 eax, byte [rsi+2]     ; accumulate byte 2
; ... or use rep crc32 with larger operands

GFNI – Galois Field Neue Anweisungen

Eingeführt in Ice Lake (2020). Bietet SIMD GF(2^8)-Multiplikation und affine Transformationen für Kryptographie und Post-Quanten-Algorithmen.

Gedächtnisstütze | Beschreibung | Operanden
GF2P8AFFINEINVQB | Galois-Feld-Affintransformation invers (älteres SSE) | xmm, xmm/mem128, imm8
GF2P8AFFINEQB | Galois-Feld-Affintransformation (altes SSE) | xmm, xmm/mem128, imm8
GF2P8MULB | Galois-Feld multipliziert Bytes (älteres SSE) | xmm, xmm/mem128

SehenAVX-Mnemonikfür VEX/EVEX-kodierte Varianten (VGF2P8*) unterstützt 128/256/512-Bit-Operationen mit opmask.

SM3 / SM4 – Chinesische Krypto (optional)

Gedächtnisstütze | Beschreibung | Operanden
SM3MSG1 | Aktualisierung des SM3-Nachrichtenplans 1 | xmm, xmm/mem
SM3MSG2 | Aktualisierung des SM3-Nachrichtenplans 2 | xmm, xmm/mem
SM4ENC | SM4-Ein-Runden-Verschlüsselung | xmm, xmm/mem
SM4ENC4 | SM4 Vier-Runden-Verschlüsselung | xmm, xmm/mem

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

← Kern-GPR-Mnemonik Nach oben x87-FPU-Mnemonik →

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes


Cache-Steuerung/Prefetch-Mnemonik

Startseite› Cache-Kontrolle/Prefetch-Mnemonik

Cache-Steuerung und Prefetch-Anweisungen

Anweisungen zur Verwaltung der Cache-Hierarchie, zum Vorabruf, zu nicht-temporären Speichern und zu Barrieren bei der Speicherordnung.

Prefetch-Anweisungen

Gedächtnisstütze | Beschreibung | Operanden
PREFETCHh | Daten auf der angegebenen Hinweisebene vorab in den Cache abrufen | mem8
PREFETCHNTA | Vorababruf in den L1-Datencache (nicht temporär, minimale Verschmutzung) | mem8
PREFETCHT0 | Vorabruf in alle Cache-Ebenen (L1, L2, L3) | mem8
PREFETCHT1 | Prefetch in L2 und L3 (nicht L1) | mem8
PREFETCHT2 | Nur in L3 vorabholen | mem8
PREFETCHW | Prefetch zum Schreiben (RFO-Latenz reduzieren, AMD/Intel) | mem8
PREFETCHWT1 | Prefetch zum Schreiben in L2 (AVX-512) | mem8
; Prefetch data for read-intensive processing
prefetcht0 [rsi+64]       ; start loading cache line into L1
prefetcht1 [rsi+128]      ; prefetch into L2
prefetchnta [rsi+192]     ; non-temporal (don't pollute caches)

; Prefetch for write
prefetchw [rdi+64]        ; hint: we'll write here soon

Leeren/Rückschreiben der Cache-Zeile

Gedächtnisstütze | Beschreibung | Operanden
CLFLUSH | Cache-Zeile mit Adresse leeren (zurückschreiben + ungültig machen) | mem8
CLFLUSHOPT | Cache-Zeile leeren (optimiert, gepuffert) | mem8
CLWB | Zurückschreiben der Cache-Zeile (bei Bedarf im Cache behalten) | mem8
CLZERO | Keine Cache-Zeile (nur AMD, löscht 64 Bytes) | keine (verwendet [rax-Adresse])
CLDEMOTE | Cache-Zeile von L1 auf niedrigere Ebenen (L2/L3) herabstufen | mem8
; Write-back and flush a cache-aligned buffer
clflushopt [rdi]           ; optimized cache line flush
clwb       [rdi]           ; write-back but keep in cache

; Memory-mapped I/O: ensure write is visible to device
mov    DWORD PTR [mmio_reg], eax
clflush [mmio_reg]         ; flush write from cache to memory

Nicht-temporale (Streaming-)Speicher

Nicht-temporäre Speicherungen umgehen den Cache und schreiben direkt in den Speicher, wodurch eine Cache-Verschmutzung vermieden wird. Ideal für große Datenstrukturen, die einmal geschrieben werden.

Gedächtnisstütze | Beschreibung | Operanden
MOVNTI | Nicht-temporäre Speicherung von Ganzzahlen (dword/qword) | mem32/64, reg
MOVNTDQ | Nicht-temporärer Speicher von 128 Bit (SSE2) | mem128, xmm
MOVNTDQA | Nicht-temporäre Last (Streaming-Lasthinweis, SSE4.1) | xmm, mem128
MOVNTPD | Nichtzeitlicher Speicher von gepacktem Doppel (SSE2) | mem128, xmm
MOVNTPS | Nicht-temporäre Speicherung gepackter Singles (SSE) | mem128, xmm
VMOVNTDQ | VEX nicht-temporaler 128/256-Bit-Speicher (AVX) | mem, ymm/xmm
VMOVNTPD | VEX nichtzeitlicher Doppelspeicher (AVX) | mem, ymm/xmm
VMOVNTPS | VEX nicht-temporärer Einzelspeicher (AVX) | mem, ymm/xmm
VMOVNTDQA | Nichtzeitliche VEX-Last (AVX2) | ymm/xmm, mem
; Non-temporal memory copy (large blocks)
; AVX variant - streaming store avoids cache pollution
vmovntdq [rdi],   ymm0    ; write 32 bytes, bypass cache
vmovntdq [rdi+32], ymm1   ; next 32 bytes
; ... use sfence to ensure visibility
sfence

; Non-temporal integer store (for single values)
movnti [rdi], eax          ; atomic 32-bit streaming store
movnti [rdi], rax          ; 64-bit streaming store

Erinnerungsbarrieren und Zäune

Gedächtnisstütze | Beschreibung
SFENCE | Filialzaun (serialisiert alle Filialvorgänge)
LFENCE | Ladezaun (serialisiert alle Ladevorgänge)
MFENCE | Speicherzaun (serialisiert alle Lade- und Speichervorgänge)
SFENCE | Ladenzaun (stellt sicher, dass alle vorherigen Geschäfte weltweit sichtbar sind)
LFENCE | Ladezaun (stellt sicher, dass alle vorherigen Ladungen vor der nächsten Ladung abgeschlossen sind)
; Memory ordering: producer-consumer
; Thread 1 (producer):
mov    DWORD PTR [data], eax
sfence                       ; ensure data visible before flag
mov    DWORD PTR [flag], 1

; Thread 2 (consumer):
spin:
    mov    eax, DWORD PTR [flag]
    lfence                   ; ensure flag loaded before data
    test   eax, eax
    jz     spin
    mov    ebx, DWORD PTR [data]

; Full memory barrier (both loads and stores)
lock or DWORD PTR [rsp], 0  ; alternative full barrier
; or simply:
mfence

Nutzungsmuster der Cache-Kontrolle

Streaming Copy (memcpy mit NT-Stores)

; Copy 4096 bytes with non-temporal stores
mov    ecx, 128             ; 4096 / 32 (256-bit)
mov    rsi, src
mov    rdi, dst
loop:
    vmovdqa ymm0, [rsi]
    vmovntdq [rdi], ymm0
    add    rsi, 32
    add    rdi, 32
    dec    ecx
    jnz    loop
sfence                       ; ensure all NT stores are visible
vzeroupper

Cache-Line-Flush für NVDIMM-Persistenz

; Ensure data is persistent on NVDIMM
mov    DWORD PTR [journal], eax
clwb   [journal]            ; write-back cache line
sfence                       ; order CLWB before next barrier
; ... optionally wait for PCOMMIT (older platforms) ...
; With Intel eADR, CLWB + SFENCE is sufficient for persistency

Vorabruf für Strided-Zugriffsmuster

; Strided matrix access (column-major)
xor    ecx, ecx
loop_col:
    prefetcht0 [rsi+rdx*8]   ; prefetch column element
    movsd  xmm0, [rsi]
    addsd  xmm0, [rdi+rcx]
    movsd  [rsi], xmm0
    add    rsi, rdx           ; stride
    inc    ecx
    cmp    ecx, 64
    jb     loop_col

Zusammenfassung der Anweisungen nach Hinweisstufe

Anweisung | Cache-Auswirkungen | Anwendungsfall
PREFETCHNTA | Nur L1, nicht temporär | Einmaliges Lesen der Daten minimiert die L2/L3-Verschmutzung
PREFETCHT0 | L1, L2, L3 | Auf die Daten wird demnächst mehrmals zugegriffen
PREFETCHT1 | L2, L3 (L1 überspringen) | Auf die Daten wird bald zugegriffen, aber nicht sofort
PREFETCHT2 | Nur L3 | Auf die Daten wird in naher Zukunft zugegriffen
PREFETCHW | Alle Level, exklusiv | Zu schreibende Daten (exklusiver Zustand)
MOVNT* | Cache umgehen (Schreibkombination) | Große Streaming-Schreibvorgänge (Framebuffer, große Puffer)
CLFLUSH | Cache-Zeile leeren und ungültig machen | Cachekohärenter DMA, Persistenz
CLFLUSHOPT | Flush (gepuffert, schneller) | Wie CLFLUSH, aber höherer Durchsatz
CLWB | Zurückschreiben (Cache beibehalten) | NVDIMM-Persistenz, behält die Zeile im Cache bei
CLDEMOTE | Wechseln Sie von L1 zu L2/L3 | Reduzieren Sie den L1-Druck für Daten, die nicht sofort benötigt werden

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

← BMI1/BMI2-Mnemonik Nach oben Kern-GPR-Mnemonik →

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes


Systemanweisungen

Systemanweisungen bieten Zugriff auf CPU-Funktionen, Steuerregister, Speicherverwaltung, E/A-Ports und Leistungsüberwachung. Die meisten erfordern erhöhte Berechtigungen (Ring 0 / Kernel-Modus).

Warnung:Viele Systemanweisungen sind privilegiert und verursachen eine Ausnahme (#GP), wenn sie auf Ring 3 (Benutzermodus) ausgeführt werden. In PB-Programmen mit Vorsicht verwenden, normalerweise über einen Gerätetreiber oder einen Kernel-Dienst.

CPU-Identifikation und Funktionserkennung

Gedächtnisstütze | Beschreibung | Operanden | Privileg
CPUID | CPU-Identifikation (EAX=Leaf, ECX=Subleaf, gibt EAX/EBX/ECX/EDX zurück) | keiner | Benutzer
XGETBV | Erweitertes Steuerregister XCR lesen (ECX=index) | keiner | Benutzer
XSETBV | Erweitertes Steuerregister XCR schreiben (muss Ring 0 sein) | keiner | Rufen Sie 0 an
; CPUID example: check for AVX2 support
mov eax, 7               ; leaf 7 = extended features
mov ecx, 0               ; subleaf 0
cpuid
test ebx, 20             ; bit 5 = AVX2
jnz has_avx2

; XGETBV example: check XCR0 for AVX state
mov ecx, 0               ; XCR0
xgetbv                   ; returns EDX:EAX
test eax, 6              ; bits 1+2 = XMM + YMM state enabled
jnz avx_enabled

Zeitstempel und Leistungsindikatoren

Gedächtnisstütze | Beschreibung | Operanden | Privileg
RDTSC | Zeitstempelzähler lesen (gibt EDX:EAX zurück) | keiner | Benutzer
RDTSCP | TSC + Prozessor-ID lesen (gibt EDX:EAX, ECX=IA32_TSC_AUX zurück) | keiner | Benutzer
RDPMC | Leistungsüberwachungszähler lesen (ECX=Zähler) | keiner | Benutzer*
; High-resolution timing
rdtsc                    ; eax = TSC low, edx = TSC high
shl rdx, 32
or  rax, rdx             ; rax = 64-bit TSC value
; ...
rdtscp                   ; similar but with processor ID in ecx
mov [processor_id], ecx

Kontrollregister

Gedächtnisstütze | Beschreibung | Operanden | Privileg
MOV CR0, reg | Steuerregister CR0 schreiben | reg64 | Rufen Sie 0 an
MOV reg, CR0 | Steuerregister CR0 lesen | reg64 | Rufen Sie 0 an
MOV CR2, reg | Schreiben Sie CR2 (lineare Seitenfehleradresse) | reg64 | Rufen Sie 0 an
MOV reg, CR2 | Lesen Sie CR2 | reg64 | Rufen Sie 0 an
MOV CR3, reg | Schreiben Sie CR3 (Basisadresse der Seitentabelle) | reg64 | Rufen Sie 0 an
MOV reg, CR3 | Lesen Sie CR3 | reg64 | Rufen Sie 0 an
MOV CR4, reg | CR4 schreiben (Erweiterungssteuerung) | reg64 | Rufen Sie 0 an
MOV reg, CR4 | Lesen Sie CR4 | reg64 | Rufen Sie 0 an
MOV CR8, reg | CR8 schreiben (Aufgabenpriorität, nur x64) | reg64 | Rufen Sie 0 an
MOV reg, CR8 | Lesen Sie CR8 | reg64 | Rufen Sie 0 an

Debug-Register

Gedächtnisstütze | Beschreibung | Operanden | Privileg
MOV DR0-DR7, reg | Debug-Register schreiben | reg64 | Rufen Sie 0 an
MOV reg, DR0-DR7 | Debug-Register lesen | reg64 | Rufen Sie 0 an

Anweisungen zur Deskriptortabelle

Gedächtnisstütze | Beschreibung | Operanden | Privileg
SGDT | Speichern Sie das globale Deskriptortabellenregister | mem80 (Pseudo-Deskriptor) | Benutzer
SIDT | Speichern Sie das Interrupt-Deskriptortabellenregister | mem80 | Benutzer
SLDT | Lokales Deskriptortabellenregister speichern | reg/mem16/64 | Benutzer
SMSW | Speichern Sie das Maschinenstatuswort (CR0, niedrige 16 Bits) | reg/mem16/64 | Benutzer
STR | Aufgabenregister speichern | reg/mem16/64 | Benutzer
LGDT | Laden Sie das Global Descriptor Table-Register | mem80 (Pseudo-Deskriptor) | Rufen Sie 0 an
LIDT | Interrupt-Deskriptor-Tabellenregister laden | mem80 | Rufen Sie 0 an
LLDT | Laden Sie das Register der lokalen Deskriptortabelle | reg/mem16/64 | Rufen Sie 0 an
LMSW | Maschinenstatuswort laden | reg/mem16/64 | Rufen Sie 0 an
LTR | Aufgabenregister laden | reg/mem16/64 | Rufen Sie 0 an

Anweisungen zum Segmentregister

Gedächtnisstütze | Beschreibung | Operanden | Privileg
LAR | Zugriffsrechte laden (Segmentdeskriptor) | reg, reg/mem16 | Benutzer
LSL | Segmentlimit laden | reg, reg/mem16 | Benutzer
VERR | Segment zum Lesen überprüfen | reg/mem16 | Benutzer
VERW | Segment zum Schreiben überprüfen | reg/mem16 | Benutzer
MOV segment, reg | Segmentregister laden (CS/DS/ES/FS/GS/SS) | reg16/64 | Klingeln 0*
MOV reg, segment | Segmentregister lesen | reg16/64 | Benutzer

Anweisungen zum I/O-Port

Gedächtnisstütze | Beschreibung | Operanden | Privileg
IN | Eingabe vom I/O-Port | AL/AX/EAX, DX/imm8 | Klingeln 0*
OUT | Ausgabe an den I/O-Port | DX/imm8, AL/AX/EAX | Klingeln 0*
INS / INSB / INSW / INSD | Eingabezeichenfolge vom E/A-Port zum Speicher | keine (verwendet DX, RDI) | Klingeln 0*
OUTS / OUTSB / OUTSW / OUTSD | Ausgabezeichenfolge aus dem Speicher an den E/A-Port | keine (verwendet DX, RSI) | Klingeln 0*
Notiz:Auf I/O-Anweisungen kann über Ring 3 zugegriffen werden, wenn die I/O Permission Bitmap (IOPL) dies zulässt. Unter Windows ist der E/A-Zugriff im Benutzermodus generell blockiert.

Unterbrechung / Ausnahme

Gedächtnisstütze | Beschreibung | Operanden | Privileg
INT n | Software-Interrupt (löst Interrupt n aus) | imm8 | Benutzer
INT3 | Haltepunkt-Interrupt (#BP, Debugger-Trap) | keiner | Benutzer
INTO | Unterbrechung bei Überlauf (wenn OF=1, #OF) | keiner | Benutzer
BOUND | Array-Grenzen prüfen (nicht gültig in x64) | reg, mem | Benutzer
IRET / IRETD / IRETQ | Interrupt-Rückgabe (Pops CS:RIP, RFLAGS, Stack) | keiner | Rufen Sie 0 an
; Software interrupt
mov ah, 0x09             ; DOS: write string
mov dx, offset message
int 0x21                 ; DOS system call

; Debugger breakpoint
int3                     ; same as 'bp' in PB

; Simple system call (Linux x64)
mov eax, 60              ; sys_exit
xor edi, edi             ; exit code 0
syscall                  ; invoke kernel

Anweisungen zum Systemaufruf

Gedächtnisstütze | Beschreibung | Operanden | Privileg
SYSCALL | Schneller Systemaufruf (AMD/x64 Linux: RCX=RIP, R11=RFLAGS) | keiner | Benutzer
SYSRET | Rückkehr vom schnellen Systemaufruf | keiner | Rufen Sie 0 an
SYSENTER | Schneller Systemaufruf (Intel): setzt EIP=MSR SYSENTER_EIP | keiner | Benutzer
SYSEXIT | Schnelle Rückkehr von SYSENTER | keiner | Rufen Sie 0 an

TLS-/Segmentbasisanweisungen

Gedächtnisstütze | Beschreibung | Operanden | Privileg
SWAPGS | GS-Basisregister mit KernelGSBase (MSR C0000102) tauschen | keiner | Rufen Sie 0 an
RDFSBASE | FS-Basisadresse lesen | reg64 | Benutzer
RDGSBASE | GS-Basisadresse lesen | reg64 | Benutzer
WRFSBASE | Schreiben Sie die FS-Basisadresse | reg64 | Klingeln 0*
WRGSBASE | GS-Basisadresse schreiben | reg64 | Klingeln 0*
; Windows: get PEB via GS segment
mov rax, QWORD PTR gs:[0x60]   ; PEB address

; Linux x64: swap GS for kernel entry
swapgs                         ; exchange user GS with kernel GS
mov QWORD PTR gs:[0x10], rsp   ; save kernel stack pointer

Modellspezifische Register (MSR)

Gedächtnisstütze | Beschreibung | Operanden | Privileg
RDMSR | MSR lesen (ECX=MSR-Adresse, gibt EDX:EAX zurück) | keiner | Rufen Sie 0 an
WRMSR | MSR schreiben (ECX=Adresse, EDX:EAX=Wert) | keiner | Rufen Sie 0 an
; Read IA32_APIC_BASE MSR
mov ecx, 0x1B             ; IA32_APIC_BASE MSR
rdmsr                     ; edx:eax = APIC base address
; edx = high 32 bits, eax = low 32 bits
shl rdx, 32
or  rax, rdx              ; rax = full 64-bit value

Cache-/Speicherverwaltung

Gedächtnisstütze | Beschreibung | Operanden | Privileg
CLFLUSH | Cache-Zeile mit Adresse leeren | mem8 | Benutzer
CLFLUSHOPT | Optimierte Flush-Cache-Zeile | mem8 | Benutzer
CLWB | Zurückschreiben der Cache-Zeile (im Cache behalten) | mem8 | Benutzer
INVD | Interne Caches ungültig machen (kein Zurückschreiben) | keiner | Rufen Sie 0 an
WBINVD | Caches zurückschreiben und ungültig machen | keiner | Rufen Sie 0 an
INVLPG | TLB-Eintrag für Adresse ungültig machen | mem8 | Rufen Sie 0 an
INVPCID | TLB-Einträge mit PCID ungültig machen | reg, mem128 | Rufen Sie 0 an
INVEPT | Einträge in der erweiterten Seitentabelle ungültig machen | reg, mem128 | Rufen Sie 0 an
INVVPID | VPID-TLB-Einträge ungültig machen | reg, mem128 | Rufen Sie 0 an
WFENCE | Warten Sie auf SFENCE (no-op in modernen CPUs) | keiner | Benutzer

Energieverwaltung / Halt

Gedächtnisstütze | Beschreibung | Operanden | Privileg
HLT | Prozessor bis zum nächsten Interrupt anhalten | keiner | Rufen Sie 0 an
MWAIT | Überwachen und warten Sie auf Schreibvorgänge | keine (verwendet EAX/ECX) | Rufen Sie 0 an
MONITOR | Adressbereich für MWAIT einrichten | keine (verwendet RAX/RCX/RDX) | Rufen Sie 0 an
MWAITX | Erweitertes MWAIT mit Timing-Hinweis | keiner | Rufen Sie 0 an
MONITORX | Erweiterter MONITOR | keiner | Rufen Sie 0 an
CLZERO | Null-Cache-Zeile (nur AMD) | keiner | Benutzer
PAUSE | Spin-Wait-Hinweis (reduziert die Leistung/verbessert HT) | keiner | Benutzer
UMONITOR | MONITOR auf Benutzerebene | reg | Benutzer
UMWAIT | MWAIT auf Benutzerebene | reg, imm8 | Benutzer
TPAUSE | Zeitgesteuerte PAUSE | reg, imm8 | Benutzer
; Spin-wait loop with PAUSE
spin_loop:
    pause
    cmp DWORD PTR [lock_var], 0
    jne spin_loop

; Kernel halt
hlt                        ; stop CPU until interrupt

Verschiedenes / Veraltet

Gedächtnisstütze | Beschreibung | Operanden
SALC | AL basierend auf Übertrag festlegen (undokumentiert, CF→AL=0xFF/0x00) | keiner
UD0 | Undefinierte Anweisung (erhöht #UD) | keiner
UD1 | Undefinierte Anweisung (Formular mit zwei Operanden) | reg, reg/mem
UD2 | Undefinierte Anweisung (garantiert #UD, 2 Bytes: 0F 0B) | keiner
XLAT / XLATB | Byte übersetzen (AL = [RBX + AL]) | keiner
WAIT / FWAIT | Warten Sie auf den FPU/Math-Coprozessor | keiner
NOP | Keine Operation (einschließlich Multibyte-NOPs) | keiner

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

← SSE/SSE2/SSE3/SSSE3/SSE4-Mnemonik Nach oben PBXB64 Inline-Assembler-Übersicht →

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes


SGX / VMX / CET-Mnemonik

Startseite› SGX / VMX / CET-Mnemonik

SGX / VMX / CET-Anweisungen

SGX (Software Guard Extensions), VMX (Virtual Machine Extensions) und CET (Control-Flow Enforcement Technology). Hierbei handelt es sich um spezielle Sicherheits- und Virtualisierungsbefehlssätze, die auf neueren Intel-Prozessoren verfügbar sind.

SGX – Software Guard-Erweiterungen

SGX ermöglicht die Erstellung isolierter Enklaven innerhalb des Adressraums. Anweisungen sind in drei Berechtigungsstufen unterteilt:

ENCLS – Supervisor (Ring 0)

Gedächtnisstütze | Beschreibung
ENCLS[ECREATE] | Erstellen Sie eine Enklave
ENCLS[EADD] | Fügen Sie einer Enklave eine Seite hinzu
ENCLS[EEXTEND] | Erweitern Sie die Messung einer Enklavenseite
ENCLS[EINIT] | Enklave initialisieren (vollständige Messung)
ENCLS[ELDB] | Laden Sie eine Enclave-Seite als blockiert
ENCLS[ELDU] | Laden Sie eine Enclave-Seite als entsperrt
ENCLS[EPA] | Fügen Sie eine Versionsarray-Seite hinzu
ENCLS[EREMOVE] | Eine Seite aus einer Enklave entfernen
ENCLS[ETRACK] | Aktivieren Sie die Nachverfolgung von Enclave-Seitenänderungen
ENCLS[EWB] | Schreiben Sie zurück und entfernen Sie eine Enklavenseite
ENCLS[EAUG] | Fügen Sie eine Seite für dynamisches Wachstum hinzu (SGX2)
ENCLS[EMODPR] | Seitenberechtigungen/-einschränkungen ändern (SGX2)
ENCLS[EMODT] | Seitentyp ändern (SGX2)
ENCLS[EDECRD] | Seitenverweisanzahl verringern (SGX2)
ENCLS[ETRACKC] | Aktivieren Sie die Weiterleitungsverfolgung für untergeordnete Enklaven

ENCLU – Benutzer (Ring 3, innerhalb der Enklave)

Gedächtnisstütze | Beschreibung
ENCLU[EENTER] | Betreten Sie eine Enklave
ENCLU[ERESUME] | Setzen Sie eine Enklave nach einer Unterbrechung/Ausnahme fort
ENCLU[EEXIT] | Verlasse die Enklave
ENCLU[EGETKEY] | Holen Sie sich einen von der Hardware abgeleiteten Schlüssel von der Enklave
ENCLU[EREPORT] | Erstellen Sie einen kryptografischen Bericht
ENCLU[EACCEPT] | Akzeptieren Sie eine Seitenänderung (SGX2)
ENCLU[EMODPE] | Ändern Sie den zulässigen Seitenschutz (SGX2)
ENCLU[EACCEPTCOPY] | Akzeptieren Sie eine kopierte Seite (SGX2)

ENCLV – Virtualisierung (Ring 0, VMM)

Gedächtnisstütze | Beschreibung
ENCLV[EDECLASSIFY] | Löschen Sie die klassifizierten Attribute einer Seite
ENCLV[ETRACKC] | Verfolgen Sie Änderungen an der Seite der untergeordneten Enklave
; SGX enclave entry (inside host)
lea rcx, [secs]            ; SGX Enclave Control Structure
lea rdx, [base_address]
lea r8,  [source_page]
mov eax, 0                 ; ECREATE
ENCLS

; SGX enclave entry (inside enclave)
lea rax, [tcs]             ; Thread Control Structure
lea rbx, [aep]             ; Asynchronous Exit Pointer
mov rcx, [entry_address]   ; Entry point in enclave
ENCLU[EENTER]

VMX – Erweiterungen für virtuelle Maschinen

Hardware-Virtualisierungsunterstützung für Hypervisoren/VMMs.

VMX-Management

Gedächtnisstütze | Beschreibung | Operanden
VMXON | Geben Sie den VMX-Vorgang ein | mem64 (VMXON-Region ptr)
VMXOFF | Beenden Sie den VMX-Vorgang | keiner
VMPTRLD | Aktuellen VMCS-Zeiger laden | mem64
VMPTRST | Aktuellen VMCS-Zeiger speichern | mem64
VMCLEAR | VMCS löschen (Cache-Status leeren) | mem64
VMREAD | Feld aus VMCS lesen | reg, reg/mem
VMWRITE | Feld in VMCS schreiben | reg/mem, reg

VM-Ein-/Ausstieg

Gedächtnisstütze | Beschreibung
VMLAUNCH | Virtuelle Maschine starten (erster Eintrag)
VMRESUME | Virtuelle Maschine fortsetzen (nachfolgende Einträge)

VM-Exit-Behandlung

Gedächtnisstütze | Beschreibung | Operanden
VMCALL | Rufen Sie VMM vom Gast aus auf (VM-Exit) | keiner
VMFUNC | VM-Funktionsaufruf (Blatt in EAX) | keiner

VM-Schatten-/TLB-Steuerung

Gedächtnisstütze | Beschreibung | Operanden
INVEPT | EPT (Extended Page Table) ungültig machen | reg, mem128
INVVPID | VPID (Virtuelle Prozessor-ID) ungültig machen | reg, mem128
VMPTRLD | VMCS-Zeiger laden | mem64
; Basic VMM: launch a guest
vmxon [vmxon_region]       ; enter VMX operation
vmptrld [vmcs]             ; load VMCS
; ... set up VMCS fields ...
vmlaunch                   ; launch guest
; ... on VM exit ...
vmresume                   ; resume guest
vmxoff                     ; exit VMX operation

CET – Control-Flow-Enforcement-Technologie

CET bietet Shadow Stack (hardware-erzwungener Schutz der Rücksendeadresse) und indirekte Zweigverfolgung (Indirect Branch Tracking, IBT). Verfügbar auf Intel Tiger Lake+.

Schattenstapel (SS)

Gedächtnisstütze | Beschreibung | Operanden
RDSSP | Schattenstapelzeiger lesen | reg64
INCSSP | Erhöhen Sie den Shadow-Stack-Zeiger um N*8 | reg32
SAVEPREVSSP | Speichern Sie den vorherigen Schattenstapelzeiger | keiner
RSTORSSP | Schattenstapelzeiger wiederherstellen | mem64
WRSS | Auf Shadow Stack schreiben (Supervisor) | mem64, reg64
WRUSS | Auf Shadow Stack schreiben (Benutzer) | mem64, reg64
SETSSBSY | Markieren Sie den Schattenstapel als beschäftigt | keiner
CLRSSBSY | Löschen Sie die Besetzt-Flagge des Shadow-Stacks | mem64

Indirekte Filialverfolgung (IBT)

Gedächtnisstütze | Beschreibung | Codierung
ENDBR64 | Ende der Verzweigung (64-Bit, an Verzweigungszielen) | F3 0F 1E FA
ENDBR32 | Ende der Verzweigung (32-Bit) | F3 0F 1E FB
NOTRACK | Präfix: IBT-Prüfung für den nächsten JMP/CALL unterdrücken | F2-Präfix

CET-Beispiele

; Shadow stack save/restore
rdssp  rax                ; read current shadow stack pointer
mov    [saved_ssp], rax   ; save it for later restore

; Set up shadow stack for a new context
rstorssp [new_ss_frame]   ; restore shadow stack pointer
saveprevssp               ; save previous SSP
ret                       ; shadow stack will also pop

; IBT-compliant function
func:
    endbr64               ; required at every indirect branch target
    push rbp
    mov rbp, rsp
    ; ... function body ...
    pop rbp
    ret

; Indirect call through function pointer
call_func:
    endbr64
    mov rax, [pfn]        ; load function pointer
    notrack call rax       ; call without IBT check (NOTRACK prefix)
Notiz:Der CET-Shadow-Stack erfordert Betriebssystemunterstützung (Windows 10 20H1+ Kernel-Modus, Windows 11-Benutzermodus). Auf CPUs ohne CET lösen diese Anweisungen #UD aus.

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

← MMX-Mnemonik Nach oben SSE/SSE2/SSE3/SSSE3/SSE4-Mnemonik →

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes


MOVAPD - Move aligned packed double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › MOVAPD - Move aligned packed double
Hilfe zum PBXB64-Compiler

MOVAPD - Move aligned packed double

Category: Data Movement

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVAPD - Move aligned packed double. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128 / mem128, xmm.

Syntax

MOVAPD xmm, xmm/mem128 / mem128, xmm

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory
mem128, xmm | uses XMM vector/scalar registers; may read or write memory

Aligned memory forms require the alignment documented by the instruction family, commonly 16-byte alignment for 128-bit SSE packed operands.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    movapd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movapd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVAPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVAPD operand[, operand]

PBXB64-Verwendung

MOVAPD ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVAPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVDQU - Move unaligned double quadword - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › MOVDQU - Move unaligned double quadword
Hilfe zum PBXB64-Compiler

MOVDQU - Move unaligned double quadword

Category: Data Movement

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVDQU - Move unaligned double quadword. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128 / mem128, xmm.

Syntax

MOVDQU xmm, xmm/mem128 / mem128, xmm

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory
mem128, xmm | uses XMM vector/scalar registers; may read or write memory

Aligned memory forms require the alignment documented by the instruction family, commonly 16-byte alignment for 128-bit SSE packed operands.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    movdqu xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movdqu xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVDQU ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVDQU operand[, operand]

PBXB64-Verwendung

MOVDQU ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVDQU ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVHLPS - Move high to low packed single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › MOVHLPS - Move high to low packed single
Hilfe zum PBXB64-Compiler

MOVHLPS - Move high to low packed single

Category: Data Movement

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVHLPS - Move high to low packed single. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm.

Syntax

MOVHLPS xmm, xmm

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    movhlps xmm0, xmm1
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movhlps xmm0, xmm1
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVHLPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVHLPS operand[, operand]

PBXB64-Verwendung

MOVHLPS ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVHLPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVHPD - Move high packed double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › MOVHPD - Move high packed double
Hilfe zum PBXB64-Compiler

MOVHPD - Move high packed double

Category: Data Movement

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVHPD - Move high packed double. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, mem64 / mem64, xmm.

Syntax

MOVHPD xmm, mem64 / mem64, xmm

Operands and Sizes

Form | Meaning
xmm, mem64 | uses XMM vector/scalar registers; may read or write memory
mem64, xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 8
asm_data64:
    .quad 0

.text
.global main
main:
    movhpd xmm0, [rip + asm_data64]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movhpd xmm0, [rip + asm_data64]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVHPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVHPD operand[, operand]

PBXB64-Verwendung

MOVHPD ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVHPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVHPS - Move high packed single (upper 64 bits) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › MOVHPS - Move high packed single (upper 64 bits)
Hilfe zum PBXB64-Compiler

MOVHPS - Move high packed single (upper 64 bits)

Category: Data Movement

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVHPS - Move high packed single (upper 64 bits). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, mem64 / mem64, xmm.

Syntax

MOVHPS xmm, mem64 / mem64, xmm

Operands and Sizes

Form | Meaning
xmm, mem64 | uses XMM vector/scalar registers; may read or write memory
mem64, xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 8
asm_data64:
    .quad 0

.text
.global main
main:
    movhps xmm0, [rip + asm_data64]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movhps xmm0, [rip + asm_data64]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVHPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVHPS operand[, operand]

PBXB64-Verwendung

MOVHPS ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVHPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVLHPS - Move low to high packed single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › MOVLHPS - Move low to high packed single
Hilfe zum PBXB64-Compiler

MOVLHPS - Move low to high packed single

Category: Data Movement

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVLHPS - Move low to high packed single. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm.

Syntax

MOVLHPS xmm, xmm

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    movlhps xmm0, xmm1
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movlhps xmm0, xmm1
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVLHPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVLHPS operand[, operand]

PBXB64-Verwendung

MOVLHPS ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVLHPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVLPD - Move low packed double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › MOVLPD - Move low packed double
Hilfe zum PBXB64-Compiler

MOVLPD - Move low packed double

Category: Data Movement

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVLPD - Move low packed double. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, mem64 / mem64, xmm.

Syntax

MOVLPD xmm, mem64 / mem64, xmm

Operands and Sizes

Form | Meaning
xmm, mem64 | uses XMM vector/scalar registers; may read or write memory
mem64, xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 8
asm_data64:
    .quad 0

.text
.global main
main:
    movlpd xmm0, [rip + asm_data64]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movlpd xmm0, [rip + asm_data64]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVLPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVLPD operand[, operand]

PBXB64-Verwendung

MOVLPD ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVLPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVLPS - Move low packed single (lower 64 bits) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › MOVLPS - Move low packed single (lower 64 bits)
Hilfe zum PBXB64-Compiler

MOVLPS - Move low packed single (lower 64 bits)

Category: Data Movement

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVLPS - Move low packed single (lower 64 bits). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, mem64 / mem64, xmm.

Syntax

MOVLPS xmm, mem64 / mem64, xmm

Operands and Sizes

Form | Meaning
xmm, mem64 | uses XMM vector/scalar registers; may read or write memory
mem64, xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 8
asm_data64:
    .quad 0

.text
.global main
main:
    movlps xmm0, [rip + asm_data64]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movlps xmm0, [rip + asm_data64]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVLPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVLPS operand[, operand]

PBXB64-Verwendung

MOVLPS ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVLPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVMSKPS - Move sign mask to GPR (4 sign bits -> GPR) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › MOVMSKPS - Move sign mask to GPR (4 sign bits -&gt; GPR)
Hilfe zum PBXB64-Compiler

MOVMSKPS - Move sign mask to GPR (4 sign bits -> GPR)

Category: Data Movement

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVMSKPS - Move sign mask to GPR (4 sign bits -> GPR). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen reg, xmm.

Syntax

MOVMSKPS reg, xmm

Operands and Sizes

Form | Meaning
reg, xmm | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    movmskps eax, xmm0
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movmskps eax, xmm0
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVMSKPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVMSKPS operand[, operand]

PBXB64-Verwendung

MOVMSKPS ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVMSKPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVSHDUP - Move and duplicate high singles - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › MOVSHDUP - Move and duplicate high singles
Hilfe zum PBXB64-Compiler

MOVSHDUP - Move and duplicate high singles

Category: Data Movement

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVSHDUP - Move and duplicate high singles. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

MOVSHDUP xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    movshdup xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movshdup xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVSHDUP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVSHDUP operand[, operand]

PBXB64-Verwendung

MOVSHDUP ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVSHDUP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVSLDUP - Move and duplicate low singles - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › MOVSLDUP - Move and duplicate low singles
Hilfe zum PBXB64-Compiler

MOVSLDUP - Move and duplicate low singles

Category: Data Movement

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVSLDUP - Move and duplicate low singles. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

MOVSLDUP xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    movsldup xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movsldup xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVSLDUP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVSLDUP operand[, operand]

PBXB64-Verwendung

MOVSLDUP ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVSLDUP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVUPD - Move unaligned packed double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › MOVUPD - Move unaligned packed double
Hilfe zum PBXB64-Compiler

MOVUPD - Move unaligned packed double

Category: Data Movement

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVUPD - Move unaligned packed double. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128 / mem128, xmm.

Syntax

MOVUPD xmm, xmm/mem128 / mem128, xmm

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory
mem128, xmm | uses XMM vector/scalar registers; may read or write memory

Aligned memory forms require the alignment documented by the instruction family, commonly 16-byte alignment for 128-bit SSE packed operands.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    movupd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movupd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVUPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVUPD operand[, operand]

PBXB64-Verwendung

MOVUPD ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVUPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VBROADCASTF128 - Broadcast 128-bit to all lanes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VBROADCASTF128 - Broadcast 128-bit to all lanes
Hilfe zum PBXB64-Compiler

VBROADCASTF128 - Broadcast 128-bit to all lanes

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VBROADCASTF128 - Broadcast 128-bit to all lanes. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm, mem128.

Syntax

VBROADCASTF128 ymm, mem128

Operands and Sizes

Form | Meaning
ymm, mem128 | uses YMM vector registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vbroadcastf128 ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vbroadcastf128 ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VBROADCASTF128 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VBROADCASTF128 operand[, operand]

PBXB64-Verwendung

VBROADCASTF128 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VBROADCASTF128 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VBROADCASTI128 - Broadcast 128-bit to all lanes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VBROADCASTI128 - Broadcast 128-bit to all lanes
Hilfe zum PBXB64-Compiler

VBROADCASTI128 - Broadcast 128-bit to all lanes

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VBROADCASTI128 - Broadcast 128-bit to all lanes. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm, mem128.

Syntax

VBROADCASTI128 ymm, mem128

Operands and Sizes

Form | Meaning
ymm, mem128 | uses YMM vector registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vbroadcasti128 ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vbroadcasti128 ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VBROADCASTI128 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VBROADCASTI128 operand[, operand]

PBXB64-Verwendung

VBROADCASTI128 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VBROADCASTI128 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VBROADCASTSD - Broadcast double to all elements - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VBROADCASTSD - Broadcast double to all elements
Hilfe zum PBXB64-Compiler

VBROADCASTSD - Broadcast double to all elements

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VBROADCASTSD - Broadcast double to all elements. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm, mem64.

Syntax

VBROADCASTSD ymm, mem64

Operands and Sizes

Form | Meaning
ymm, mem64 | uses YMM vector registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vbroadcastsd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vbroadcastsd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VBROADCASTSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VBROADCASTSD operand[, operand]

PBXB64-Verwendung

VBROADCASTSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VBROADCASTSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VBROADCASTSS - Broadcast single to all elements - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VBROADCASTSS - Broadcast single to all elements
Hilfe zum PBXB64-Compiler

VBROADCASTSS - Broadcast single to all elements

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VBROADCASTSS - Broadcast single to all elements. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, mem32.

Syntax

VBROADCASTSS ymm/xmm, mem32

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, mem32 | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vbroadcastss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vbroadcastss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VBROADCASTSS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VBROADCASTSS operand[, operand]

PBXB64-Verwendung

VBROADCASTSS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VBROADCASTSS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VEXTRACTF128 - Extract 128-bit float lane (imm8) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VEXTRACTF128 - Extract 128-bit float lane (imm8)
Hilfe zum PBXB64-Compiler

VEXTRACTF128 - Extract 128-bit float lane (imm8)

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VEXTRACTF128 - Extract 128-bit float lane (imm8). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm/mem, ymm, imm8.

Syntax

VEXTRACTF128 xmm/mem, ymm, imm8

Operands and Sizes

Form | Meaning
xmm | uses XMM vector/scalar registers; may read or write memory
mem, ymm, imm8 | uses YMM vector registers; may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vextractf128 ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vextractf128 ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VEXTRACTF128 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VEXTRACTF128 operand[, operand]

PBXB64-Verwendung

VEXTRACTF128 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VEXTRACTF128 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VEXTRACTI128 - Extract 128-bit integer lane (imm8) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VEXTRACTI128 - Extract 128-bit integer lane (imm8)
Hilfe zum PBXB64-Compiler

VEXTRACTI128 - Extract 128-bit integer lane (imm8)

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VEXTRACTI128 - Extract 128-bit integer lane (imm8). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm/mem, ymm, imm8.

Syntax

VEXTRACTI128 xmm/mem, ymm, imm8

Operands and Sizes

Form | Meaning
xmm | uses XMM vector/scalar registers; may read or write memory
mem, ymm, imm8 | uses YMM vector registers; may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vextracti128 ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vextracti128 ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VEXTRACTI128 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VEXTRACTI128 operand[, operand]

PBXB64-Verwendung

VEXTRACTI128 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VEXTRACTI128 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VINSERTF128 - Insert 128-bit float lane (imm8) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VINSERTF128 - Insert 128-bit float lane (imm8)
Hilfe zum PBXB64-Compiler

VINSERTF128 - Insert 128-bit float lane (imm8)

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VINSERTF128 - Insert 128-bit float lane (imm8). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm, ymm, xmm/mem, imm8.

Syntax

VINSERTF128 ymm, ymm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
ymm, ymm, xmm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vinsertf128 ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vinsertf128 ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VINSERTF128 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VINSERTF128 operand[, operand]

PBXB64-Verwendung

VINSERTF128 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VINSERTF128 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VINSERTI128 - Insert 128-bit integer lane (imm8) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VINSERTI128 - Insert 128-bit integer lane (imm8)
Hilfe zum PBXB64-Compiler

VINSERTI128 - Insert 128-bit integer lane (imm8)

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VINSERTI128 - Insert 128-bit integer lane (imm8). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm, ymm, xmm/mem, imm8.

Syntax

VINSERTI128 ymm, ymm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
ymm, ymm, xmm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vinserti128 ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vinserti128 ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VINSERTI128 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VINSERTI128 operand[, operand]

PBXB64-Verwendung

VINSERTI128 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VINSERTI128 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVAPD - Move aligned packed double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VMOVAPD - Move aligned packed double
Hilfe zum PBXB64-Compiler

VMOVAPD - Move aligned packed double

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVAPD - Move aligned packed double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, mem / mem, ymm/xmm.

Syntax

VMOVAPD ymm/xmm, mem / mem, ymm/xmm

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, mem | uses XMM vector/scalar registers; may read or write memory
mem, ymm | uses YMM vector registers; may read or write memory
xmm | uses XMM vector/scalar registers; may read or write memory

Aligned memory forms require the alignment documented by the instruction family, commonly 16-byte alignment for 128-bit SSE packed operands.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovapd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovapd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVAPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVAPD operand[, operand]

PBXB64-Verwendung

VMOVAPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVAPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVD - Move doubleword to/from XMM - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VMOVD - Move doubleword to/from XMM
Hilfe zum PBXB64-Compiler

VMOVD - Move doubleword to/from XMM

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVD - Move doubleword to/from XMM. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, reg/mem / reg, xmm.

Syntax

VMOVD xmm, reg/mem / reg, xmm

Operands and Sizes

Form | Meaning
xmm, reg | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register
mem | may read or write memory
reg, xmm | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVD operand[, operand]

PBXB64-Verwendung

VMOVD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVDDUP - Move and duplicate one double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VMOVDDUP - Move and duplicate one double
Hilfe zum PBXB64-Compiler

VMOVDDUP - Move and duplicate one double

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVDDUP - Move and duplicate one double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/mem.

Syntax

VMOVDDUP ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovddup ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovddup ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVDDUP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVDDUP operand[, operand]

PBXB64-Verwendung

VMOVDDUP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVDDUP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVDQA - Move aligned double quadword - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VMOVDQA - Move aligned double quadword
Hilfe zum PBXB64-Compiler

VMOVDQA - Move aligned double quadword

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVDQA - Move aligned double quadword. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, mem / mem, ymm/xmm.

Syntax

VMOVDQA ymm/xmm, mem / mem, ymm/xmm

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, mem | uses XMM vector/scalar registers; may read or write memory
mem, ymm | uses YMM vector registers; may read or write memory
xmm | uses XMM vector/scalar registers; may read or write memory

Aligned memory forms require the alignment documented by the instruction family, commonly 16-byte alignment for 128-bit SSE packed operands.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovdqa ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovdqa ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVDQA ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVDQA operand[, operand]

PBXB64-Verwendung

VMOVDQA ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVDQA ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVDQU - Move unaligned double quadword - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VMOVDQU - Move unaligned double quadword
Hilfe zum PBXB64-Compiler

VMOVDQU - Move unaligned double quadword

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVDQU - Move unaligned double quadword. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, mem / mem, ymm/xmm.

Syntax

VMOVDQU ymm/xmm, mem / mem, ymm/xmm

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, mem | uses XMM vector/scalar registers; may read or write memory
mem, ymm | uses YMM vector registers; may read or write memory
xmm | uses XMM vector/scalar registers; may read or write memory

Aligned memory forms require the alignment documented by the instruction family, commonly 16-byte alignment for 128-bit SSE packed operands.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovdqu ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovdqu ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVDQU ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVDQU operand[, operand]

PBXB64-Verwendung

VMOVDQU ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVDQU ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVHPD - Move high packed double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VMOVHPD - Move high packed double
Hilfe zum PBXB64-Compiler

VMOVHPD - Move high packed double

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVHPD - Move high packed double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, mem64 / mem64, xmm.

Syntax

VMOVHPD xmm, xmm, mem64 / mem64, xmm

Operands and Sizes

Form | Meaning
xmm, xmm, mem64 | uses XMM vector/scalar registers; may read or write memory
mem64, xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovhpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovhpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVHPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVHPD operand[, operand]

PBXB64-Verwendung

VMOVHPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVHPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVHPS - Move high packed single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VMOVHPS - Move high packed single
Hilfe zum PBXB64-Compiler

VMOVHPS - Move high packed single

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVHPS - Move high packed single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, mem64 / mem64, xmm.

Syntax

VMOVHPS xmm, xmm, mem64 / mem64, xmm

Operands and Sizes

Form | Meaning
xmm, xmm, mem64 | uses XMM vector/scalar registers; may read or write memory
mem64, xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovhps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovhps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVHPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVHPS operand[, operand]

PBXB64-Verwendung

VMOVHPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVHPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVLPD - Move low packed double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VMOVLPD - Move low packed double
Hilfe zum PBXB64-Compiler

VMOVLPD - Move low packed double

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVLPD - Move low packed double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, mem64 / mem64, xmm.

Syntax

VMOVLPD xmm, xmm, mem64 / mem64, xmm

Operands and Sizes

Form | Meaning
xmm, xmm, mem64 | uses XMM vector/scalar registers; may read or write memory
mem64, xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovlpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovlpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVLPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVLPD operand[, operand]

PBXB64-Verwendung

VMOVLPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVLPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVLPS - Move low packed single (64-bit) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VMOVLPS - Move low packed single (64-bit)
Hilfe zum PBXB64-Compiler

VMOVLPS - Move low packed single (64-bit)

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVLPS - Move low packed single (64-bit). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, mem64 / mem64, xmm.

Syntax

VMOVLPS xmm, xmm, mem64 / mem64, xmm

Operands and Sizes

Form | Meaning
xmm, xmm, mem64 | uses XMM vector/scalar registers; may read or write memory
mem64, xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovlps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovlps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVLPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVLPS operand[, operand]

PBXB64-Verwendung

VMOVLPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVLPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVQ - Move quadword to/from XMM - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VMOVQ - Move quadword to/from XMM
Hilfe zum PBXB64-Compiler

VMOVQ - Move quadword to/from XMM

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVQ - Move quadword to/from XMM. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, reg/mem / reg, xmm.

Syntax

VMOVQ xmm, reg/mem / reg, xmm

Operands and Sizes

Form | Meaning
xmm, reg | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register
mem | may read or write memory
reg, xmm | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVQ operand[, operand]

PBXB64-Verwendung

VMOVQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVSD - Move scalar double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VMOVSD - Move scalar double
Hilfe zum PBXB64-Compiler

VMOVSD - Move scalar double

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVSD - Move scalar double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem / mem64, xmm.

Syntax

VMOVSD xmm, xmm/mem / mem64, xmm

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory
mem64, xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovsd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovsd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVSD operand[, operand]

PBXB64-Verwendung

VMOVSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVSHDUP - Move and duplicate high singles - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VMOVSHDUP - Move and duplicate high singles
Hilfe zum PBXB64-Compiler

VMOVSHDUP - Move and duplicate high singles

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVSHDUP - Move and duplicate high singles. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/mem.

Syntax

VMOVSHDUP ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovshdup ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovshdup ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVSHDUP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVSHDUP operand[, operand]

PBXB64-Verwendung

VMOVSHDUP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVSHDUP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVSLDUP - Move and duplicate low singles - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VMOVSLDUP - Move and duplicate low singles
Hilfe zum PBXB64-Compiler

VMOVSLDUP - Move and duplicate low singles

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVSLDUP - Move and duplicate low singles. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/mem.

Syntax

VMOVSLDUP ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovsldup ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovsldup ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVSLDUP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVSLDUP operand[, operand]

PBXB64-Verwendung

VMOVSLDUP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVSLDUP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVSS - Move scalar single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VMOVSS - Move scalar single
Hilfe zum PBXB64-Compiler

VMOVSS - Move scalar single

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVSS - Move scalar single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem / mem32, xmm.

Syntax

VMOVSS xmm, xmm/mem / mem32, xmm

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory
mem32, xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVSS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVSS operand[, operand]

PBXB64-Verwendung

VMOVSS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVSS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVUPD - Move unaligned packed double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VMOVUPD - Move unaligned packed double
Hilfe zum PBXB64-Compiler

VMOVUPD - Move unaligned packed double

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVUPD - Move unaligned packed double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, mem / mem, ymm/xmm.

Syntax

VMOVUPD ymm/xmm, mem / mem, ymm/xmm

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, mem | uses XMM vector/scalar registers; may read or write memory
mem, ymm | uses YMM vector registers; may read or write memory
xmm | uses XMM vector/scalar registers; may read or write memory

Aligned memory forms require the alignment documented by the instruction family, commonly 16-byte alignment for 128-bit SSE packed operands.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovupd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovupd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVUPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVUPD operand[, operand]

PBXB64-Verwendung

VMOVUPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVUPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVUPS - Move unaligned packed single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VMOVUPS - Move unaligned packed single
Hilfe zum PBXB64-Compiler

VMOVUPS - Move unaligned packed single

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVUPS - Move unaligned packed single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, mem / mem, ymm/xmm.

Syntax

VMOVUPS ymm/xmm, mem / mem, ymm/xmm

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, mem | uses XMM vector/scalar registers; may read or write memory
mem, ymm | uses YMM vector registers; may read or write memory
xmm | uses XMM vector/scalar registers; may read or write memory

Aligned memory forms require the alignment documented by the instruction family, commonly 16-byte alignment for 128-bit SSE packed operands.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovups ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovups ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVUPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVUPS operand[, operand]

PBXB64-Verwendung

VMOVUPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVUPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPBROADCASTB - Broadcast byte to all elements - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VPBROADCASTB - Broadcast byte to all elements
Hilfe zum PBXB64-Compiler

VPBROADCASTB - Broadcast byte to all elements

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPBROADCASTB - Broadcast byte to all elements. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, reg/mem.

Syntax

VPBROADCASTB ymm/xmm, reg/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, reg | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpbroadcastb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpbroadcastb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPBROADCASTB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPBROADCASTB operand[, operand]

PBXB64-Verwendung

VPBROADCASTB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPBROADCASTB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPBROADCASTD - Broadcast dword to all elements - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VPBROADCASTD - Broadcast dword to all elements
Hilfe zum PBXB64-Compiler

VPBROADCASTD - Broadcast dword to all elements

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPBROADCASTD - Broadcast dword to all elements. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, reg/mem.

Syntax

VPBROADCASTD ymm/xmm, reg/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, reg | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpbroadcastd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpbroadcastd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPBROADCASTD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPBROADCASTD operand[, operand]

PBXB64-Verwendung

VPBROADCASTD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPBROADCASTD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPBROADCASTQ - Broadcast qword to all elements - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VPBROADCASTQ - Broadcast qword to all elements
Hilfe zum PBXB64-Compiler

VPBROADCASTQ - Broadcast qword to all elements

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPBROADCASTQ - Broadcast qword to all elements. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, reg/mem.

Syntax

VPBROADCASTQ ymm/xmm, reg/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, reg | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpbroadcastq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpbroadcastq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPBROADCASTQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPBROADCASTQ operand[, operand]

PBXB64-Verwendung

VPBROADCASTQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPBROADCASTQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPBROADCASTW - Broadcast word to all elements - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VPBROADCASTW - Broadcast word to all elements
Hilfe zum PBXB64-Compiler

VPBROADCASTW - Broadcast word to all elements

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPBROADCASTW - Broadcast word to all elements. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, reg/mem.

Syntax

VPBROADCASTW ymm/xmm, reg/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, reg | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpbroadcastw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpbroadcastw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPBROADCASTW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPBROADCASTW operand[, operand]

PBXB64-Verwendung

VPBROADCASTW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPBROADCASTW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPEXTRB - Extract byte - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VPEXTRB - Extract byte
Hilfe zum PBXB64-Compiler

VPEXTRB - Extract byte

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPEXTRB - Extract byte. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen reg/mem, xmm, imm8.

Syntax

VPEXTRB reg/mem, xmm, imm8

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem, xmm, imm8 | uses XMM vector/scalar registers; may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpextrb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpextrb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPEXTRB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPEXTRB operand[, operand]

PBXB64-Verwendung

VPEXTRB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPEXTRB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPEXTRD - Extract dword - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VPEXTRD - Extract dword
Hilfe zum PBXB64-Compiler

VPEXTRD - Extract dword

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPEXTRD - Extract dword. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen reg/mem, xmm, imm8.

Syntax

VPEXTRD reg/mem, xmm, imm8

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem, xmm, imm8 | uses XMM vector/scalar registers; may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpextrd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpextrd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPEXTRD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPEXTRD operand[, operand]

PBXB64-Verwendung

VPEXTRD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPEXTRD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPEXTRQ - Extract qword - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VPEXTRQ - Extract qword
Hilfe zum PBXB64-Compiler

VPEXTRQ - Extract qword

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPEXTRQ - Extract qword. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen reg/mem, xmm, imm8.

Syntax

VPEXTRQ reg/mem, xmm, imm8

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem, xmm, imm8 | uses XMM vector/scalar registers; may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpextrq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpextrq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPEXTRQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPEXTRQ operand[, operand]

PBXB64-Verwendung

VPEXTRQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPEXTRQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPINSRB - Insert byte - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VPINSRB - Insert byte
Hilfe zum PBXB64-Compiler

VPINSRB - Insert byte

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPINSRB - Insert byte. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, reg/mem, imm8.

Syntax

VPINSRB xmm, xmm, reg/mem, imm8

Operands and Sizes

Form | Meaning
xmm, xmm, reg | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpinsrb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpinsrb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPINSRB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPINSRB operand[, operand]

PBXB64-Verwendung

VPINSRB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPINSRB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPINSRD - Insert dword - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VPINSRD - Insert dword
Hilfe zum PBXB64-Compiler

VPINSRD - Insert dword

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPINSRD - Insert dword. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, reg/mem, imm8.

Syntax

VPINSRD xmm, xmm, reg/mem, imm8

Operands and Sizes

Form | Meaning
xmm, xmm, reg | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpinsrd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpinsrd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPINSRD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPINSRD operand[, operand]

PBXB64-Verwendung

VPINSRD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPINSRD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPINSRQ - Insert qword - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VPINSRQ - Insert qword
Hilfe zum PBXB64-Compiler

VPINSRQ - Insert qword

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPINSRQ - Insert qword. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, reg/mem, imm8.

Syntax

VPINSRQ xmm, xmm, reg/mem, imm8

Operands and Sizes

Form | Meaning
xmm, xmm, reg | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpinsrq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpinsrq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPINSRQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPINSRQ operand[, operand]

PBXB64-Verwendung

VPINSRQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPINSRQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMASKMOVD - Masked move of dwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VPMASKMOVD - Masked move of dwords
Hilfe zum PBXB64-Compiler

VPMASKMOVD - Masked move of dwords

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMASKMOVD - Masked move of dwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, mem.

Syntax

VPMASKMOVD ymm/xmm, ymm/xmm, mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, mem | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmaskmovd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmaskmovd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMASKMOVD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMASKMOVD operand[, operand]

PBXB64-Verwendung

VPMASKMOVD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMASKMOVD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMASKMOVQ - Masked move of qwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VPMASKMOVQ - Masked move of qwords
Hilfe zum PBXB64-Compiler

VPMASKMOVQ - Masked move of qwords

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMASKMOVQ - Masked move of qwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, mem.

Syntax

VPMASKMOVQ ymm/xmm, ymm/xmm, mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, mem | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmaskmovq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmaskmovq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMASKMOVQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMASKMOVQ operand[, operand]

PBXB64-Verwendung

VPMASKMOVQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMASKMOVQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVMSKB - Move byte mask to GPR - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Data Movement › VPMOVMSKB - Move byte mask to GPR
Hilfe zum PBXB64-Compiler

VPMOVMSKB - Move byte mask to GPR

Category: Data Movement

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVMSKB - Move byte mask to GPR. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen reg, ymm/xmm.

Syntax

VPMOVMSKB reg, ymm/xmm

Operands and Sizes

Form | Meaning
reg, ymm | uses YMM vector registers; may read or write memory; uses a general-purpose register
xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovmskb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovmskb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVMSKB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVMSKB operand[, operand]

PBXB64-Verwendung

VPMOVMSKB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVMSKB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ADDSUBPD - Gepacktes Doppel addieren/subtrahieren (alternierend) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › ADDSUBPD - Gepacktes Doppel addieren/subtrahieren (alternierend)
Hilfe zum PBXB64-Compiler

ADDSUBPD - Gepacktes Doppel addieren/subtrahieren (alternierend)

Category: Arithmetic

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

ADDSUBPD - Gepacktes Doppel addieren/subtrahieren (alternierend). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

ADDSUBPD xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    addsubpd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! addsubpd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

ADDSUBPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

ADDSUBPD operand[, operand]

PBXB64-Verwendung

ADDSUBPD ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! ADDSUBPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ADDSUBPS - Gepackte Single addieren/subtrahieren (alternierend) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › ADDSUBPS - Gepackte Single addieren/subtrahieren (alternierend)
Hilfe zum PBXB64-Compiler

ADDSUBPS - Gepackte Single addieren/subtrahieren (alternierend)

Category: Arithmetic

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

ADDSUBPS - Gepackte Single addieren/subtrahieren (alternierend). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

ADDSUBPS xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    addsubps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! addsubps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

ADDSUBPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

ADDSUBPS operand[, operand]

PBXB64-Verwendung

ADDSUBPS ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! ADDSUBPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


DAA - Dezimalanpassung nach Addition (nicht gültig in x64) DAS - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › DAA - Dezimalanpassung nach Addition (nicht gültig in x64) DAS
Hilfe zum PBXB64-Compiler

DAA - Dezimalanpassung nach Addition (nicht gültig in x64) DAS

Category: Arithmetic

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

DAA - Dezimalanpassung nach Addition (nicht gültig in x64) DAS. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen Dezimalanpassung nach Subtraktion (nicht gültig in x64).

Syntax

DAA Dezimalanpassung nach Subtraktion (nicht gültig in x64)

Operands and Sizes

Form | Meaning
Dezimalanpassung nach Subtraktion (nicht gültig in x64) | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    daa operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! daa operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

DAA ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

DAA operand[, operand]

PBXB64-Verwendung

DAA ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! DAA ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FADD - Addieren (ST0 = ST0 + src) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › FADD - Addieren (ST0 = ST0 + src)
Hilfe zum PBXB64-Compiler

FADD - Addieren (ST0 = ST0 + src)

Category: Arithmetic

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FADD - Addieren (ST0 = ST0 + src). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem32/64 / ST(i).

Syntax

FADD mem32/64 / ST(i)

Operands and Sizes

Form | Meaning
mem32 | may read or write memory
64 | follow the operand order shown in the syntax
ST(i) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fadd [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fadd [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FADD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FADD operand[, operand]

PBXB64-Verwendung

FADD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FADD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FADDP - Addieren und Pop (ST(i) = ST(i)+ST0, dann Pop) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › FADDP - Addieren und Pop (ST(i) = ST(i)+ST0, dann Pop)
Hilfe zum PBXB64-Compiler

FADDP - Addieren und Pop (ST(i) = ST(i)+ST0, dann Pop)

Category: Arithmetic

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FADDP - Addieren und Pop (ST(i) = ST(i)+ST0, dann Pop). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen ST(i), ST(0).

Syntax

FADDP ST(i), ST(0)

Operands and Sizes

Form | Meaning
ST(i), ST(0) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    faddp operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! faddp operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FADDP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FADDP operand[, operand]

PBXB64-Verwendung

FADDP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FADDP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


HADDPD - Horizontal add packed double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › HADDPD - Horizontal add packed double
Hilfe zum PBXB64-Compiler

HADDPD - Horizontal add packed double

Category: Arithmetic

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

HADDPD - Horizontal add packed double. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

HADDPD xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    haddpd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! haddpd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

HADDPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

HADDPD operand[, operand]

PBXB64-Verwendung

HADDPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! HADDPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


HADDPS - Horizontal add packed single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › HADDPS - Horizontal add packed single
Hilfe zum PBXB64-Compiler

HADDPS - Horizontal add packed single

Category: Arithmetic

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

HADDPS - Horizontal add packed single. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

HADDPS xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    haddps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! haddps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

HADDPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

HADDPS operand[, operand]

PBXB64-Verwendung

HADDPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! HADDPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


HSUBPD - Horizontal subtract packed double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › HSUBPD - Horizontal subtract packed double
Hilfe zum PBXB64-Compiler

HSUBPD - Horizontal subtract packed double

Category: Arithmetic

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

HSUBPD - Horizontal subtract packed double. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

HSUBPD xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    hsubpd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! hsubpd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

HSUBPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

HSUBPD operand[, operand]

PBXB64-Verwendung

HSUBPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! HSUBPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


HSUBPS - Horizontal subtract packed single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › HSUBPS - Horizontal subtract packed single
Hilfe zum PBXB64-Compiler

HSUBPS - Horizontal subtract packed single

Category: Arithmetic

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

HSUBPS - Horizontal subtract packed single. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

HSUBPS xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    hsubps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! hsubps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

HSUBPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

HSUBPS operand[, operand]

PBXB64-Verwendung

HSUBPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! HSUBPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMADDUBSW - Multiply unsigned bytes, add adjacent, saturate - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › PMADDUBSW - Multiply unsigned bytes, add adjacent, saturate
Hilfe zum PBXB64-Compiler

PMADDUBSW - Multiply unsigned bytes, add adjacent, saturate

Category: Arithmetic

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMADDUBSW - Multiply unsigned bytes, add adjacent, saturate. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PMADDUBSW xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pmaddubsw xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmaddubsw xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMADDUBSW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMADDUBSW operand[, operand]

PBXB64-Verwendung

PMADDUBSW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMADDUBSW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMINSB - Minimum an gepackten signierten Bytes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › PMINSB - Minimum an gepackten signierten Bytes
Hilfe zum PBXB64-Compiler

PMINSB - Minimum an gepackten signierten Bytes

Category: Arithmetic

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMINSB - Minimum an gepackten signierten Bytes. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PMINSB xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pminsb xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pminsb xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMINSB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMINSB operand[, operand]

PBXB64-Verwendung

PMINSB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMINSB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMINUB - Minimum an gepackten vorzeichenlosen Bytes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › PMINUB - Minimum an gepackten vorzeichenlosen Bytes
Hilfe zum PBXB64-Compiler

PMINUB - Minimum an gepackten vorzeichenlosen Bytes

Category: Arithmetic

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMINUB - Minimum an gepackten vorzeichenlosen Bytes. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PMINUB xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pminub xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pminub xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMINUB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMINUB operand[, operand]

PBXB64-Verwendung

PMINUB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMINUB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMINUW - Minimum an gepackten Wörtern ohne Vorzeichen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › PMINUW - Minimum an gepackten Wörtern ohne Vorzeichen
Hilfe zum PBXB64-Compiler

PMINUW - Minimum an gepackten Wörtern ohne Vorzeichen

Category: Arithmetic

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMINUW - Minimum an gepackten Wörtern ohne Vorzeichen. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PMINUW xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pminuw xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pminuw xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMINUW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMINUW operand[, operand]

PBXB64-Verwendung

PMINUW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMINUW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VADDSUBPD - Add/subtract alternating packed double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VADDSUBPD - Add/subtract alternating packed double
Hilfe zum PBXB64-Compiler

VADDSUBPD - Add/subtract alternating packed double

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VADDSUBPD - Add/subtract alternating packed double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VADDSUBPD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vaddsubpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vaddsubpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VADDSUBPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VADDSUBPD operand[, operand]

PBXB64-Verwendung

VADDSUBPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VADDSUBPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VADDSUBPS - Add/subtract alternating packed single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VADDSUBPS - Add/subtract alternating packed single
Hilfe zum PBXB64-Compiler

VADDSUBPS - Add/subtract alternating packed single

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VADDSUBPS - Add/subtract alternating packed single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VADDSUBPS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vaddsubps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vaddsubps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VADDSUBPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VADDSUBPS operand[, operand]

PBXB64-Verwendung

VADDSUBPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VADDSUBPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VAESENCLAST - VEX/EVEX AES-Last-Round-Verschlüsselung - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VAESENCLAST - VEX/EVEX AES-Last-Round-Verschlüsselung
Hilfe zum PBXB64-Compiler

VAESENCLAST - VEX/EVEX AES-Last-Round-Verschlüsselung

Category: Arithmetic

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VAESENCLAST - VEX/EVEX AES-Last-Round-Verschlüsselung. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm/ymm/zmm, xmm/ymm/zmm, mem.

Syntax

VAESENCLAST xmm/ymm/zmm, xmm/ymm/zmm, mem

Operands and Sizes

Form | Meaning
xmm | uses XMM vector/scalar registers; may read or write memory
ymm | uses YMM vector registers; may read or write memory
zmm, xmm | uses XMM vector/scalar registers; may read or write memory
ymm | uses YMM vector registers; may read or write memory
zmm, mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vaesenclast ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vaesenclast ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VAESENCLAST ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VAESENCLAST operand[, operand]

PBXB64-Verwendung

VAESENCLAST ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VAESENCLAST ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VHADDPD - Horizontal add packed double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VHADDPD - Horizontal add packed double
Hilfe zum PBXB64-Compiler

VHADDPD - Horizontal add packed double

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VHADDPD - Horizontal add packed double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VHADDPD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vhaddpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vhaddpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VHADDPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VHADDPD operand[, operand]

PBXB64-Verwendung

VHADDPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VHADDPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VHADDPS - Horizontal add packed single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VHADDPS - Horizontal add packed single
Hilfe zum PBXB64-Compiler

VHADDPS - Horizontal add packed single

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VHADDPS - Horizontal add packed single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VHADDPS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vhaddps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vhaddps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VHADDPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VHADDPS operand[, operand]

PBXB64-Verwendung

VHADDPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VHADDPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VHSUBPD - Horizontal subtract packed double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VHSUBPD - Horizontal subtract packed double
Hilfe zum PBXB64-Compiler

VHSUBPD - Horizontal subtract packed double

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VHSUBPD - Horizontal subtract packed double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VHSUBPD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vhsubpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vhsubpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VHSUBPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VHSUBPD operand[, operand]

PBXB64-Verwendung

VHSUBPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VHSUBPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VHSUBPS - Horizontal subtract packed single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VHSUBPS - Horizontal subtract packed single
Hilfe zum PBXB64-Compiler

VHSUBPS - Horizontal subtract packed single

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VHSUBPS - Horizontal subtract packed single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VHSUBPS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vhsubps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vhsubps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VHSUBPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VHSUBPS operand[, operand]

PBXB64-Verwendung

VHSUBPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VHSUBPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPADDB - Add packed bytes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPADDB - Add packed bytes
Hilfe zum PBXB64-Compiler

VPADDB - Add packed bytes

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPADDB - Add packed bytes. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPADDB ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpaddb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpaddb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPADDB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPADDB operand[, operand]

PBXB64-Verwendung

VPADDB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPADDB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPADDD - Add packed doublewords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPADDD - Add packed doublewords
Hilfe zum PBXB64-Compiler

VPADDD - Add packed doublewords

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPADDD - Add packed doublewords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPADDD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpaddd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpaddd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPADDD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPADDD operand[, operand]

PBXB64-Verwendung

VPADDD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPADDD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPADDQ - Add packed quadwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPADDQ - Add packed quadwords
Hilfe zum PBXB64-Compiler

VPADDQ - Add packed quadwords

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPADDQ - Add packed quadwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPADDQ ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpaddq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpaddq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPADDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPADDQ operand[, operand]

PBXB64-Verwendung

VPADDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPADDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPADDW - Add packed words - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPADDW - Add packed words
Hilfe zum PBXB64-Compiler

VPADDW - Add packed words

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPADDW - Add packed words. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPADDW ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpaddw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpaddw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPADDW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPADDW operand[, operand]

PBXB64-Verwendung

VPADDW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPADDW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPHADDD - Horizontal add dwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPHADDD - Horizontal add dwords
Hilfe zum PBXB64-Compiler

VPHADDD - Horizontal add dwords

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPHADDD - Horizontal add dwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPHADDD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vphaddd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vphaddd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPHADDD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPHADDD operand[, operand]

PBXB64-Verwendung

VPHADDD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPHADDD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPHADDSW - Horizontal add words with saturation - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPHADDSW - Horizontal add words with saturation
Hilfe zum PBXB64-Compiler

VPHADDSW - Horizontal add words with saturation

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPHADDSW - Horizontal add words with saturation. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPHADDSW ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vphaddsw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vphaddsw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPHADDSW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPHADDSW operand[, operand]

PBXB64-Verwendung

VPHADDSW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPHADDSW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPHADDW - Horizontal add words - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPHADDW - Horizontal add words
Hilfe zum PBXB64-Compiler

VPHADDW - Horizontal add words

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPHADDW - Horizontal add words. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPHADDW ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vphaddw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vphaddw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPHADDW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPHADDW operand[, operand]

PBXB64-Verwendung

VPHADDW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPHADDW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPHSUBD - Horizontal subtract dwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPHSUBD - Horizontal subtract dwords
Hilfe zum PBXB64-Compiler

VPHSUBD - Horizontal subtract dwords

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPHSUBD - Horizontal subtract dwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPHSUBD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vphsubd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vphsubd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPHSUBD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPHSUBD operand[, operand]

PBXB64-Verwendung

VPHSUBD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPHSUBD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPHSUBSW - Horizontal subtract words with saturation - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPHSUBSW - Horizontal subtract words with saturation
Hilfe zum PBXB64-Compiler

VPHSUBSW - Horizontal subtract words with saturation

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPHSUBSW - Horizontal subtract words with saturation. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPHSUBSW ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vphsubsw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vphsubsw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPHSUBSW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPHSUBSW operand[, operand]

PBXB64-Verwendung

VPHSUBSW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPHSUBSW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPHSUBW - Horizontal subtract words - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPHSUBW - Horizontal subtract words
Hilfe zum PBXB64-Compiler

VPHSUBW - Horizontal subtract words

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPHSUBW - Horizontal subtract words. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPHSUBW ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vphsubw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vphsubw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPHSUBW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPHSUBW operand[, operand]

PBXB64-Verwendung

VPHSUBW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPHSUBW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← VPHSUBSW - Horizontal subtract words with saturation Top VPMADD52HUQ - Multiplizieren und addieren Sie 52-Bit-QWords ohne Vorzeichen mit hohem Wert →


VPMADD52HUQ - Multiplizieren und addieren Sie 52-Bit-QWords ohne Vorzeichen mit hohem Wert - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMADD52HUQ - Multiplizieren und addieren Sie 52-Bit-QWords ohne Vorzeichen mit hohem Wert
Hilfe zum PBXB64-Compiler

VPMADD52HUQ - Multiplizieren und addieren Sie 52-Bit-QWords ohne Vorzeichen mit hohem Wert

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMADD52HUQ - Multiplizieren und addieren Sie 52-Bit-QWords ohne Vorzeichen mit hohem Wert. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPMADD52HUQ zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmadd52huq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmadd52huq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMADD52HUQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMADD52HUQ operand[, operand]

PBXB64-Verwendung

VPMADD52HUQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMADD52HUQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMADD52LUQ - Multiplizieren und addieren Sie 52-Bit-Quoten ohne Vorzeichen mit niedrigem Wert - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMADD52LUQ - Multiplizieren und addieren Sie 52-Bit-Quoten ohne Vorzeichen mit niedrigem Wert
Hilfe zum PBXB64-Compiler

VPMADD52LUQ - Multiplizieren und addieren Sie 52-Bit-Quoten ohne Vorzeichen mit niedrigem Wert

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMADD52LUQ - Multiplizieren und addieren Sie 52-Bit-Quoten ohne Vorzeichen mit niedrigem Wert. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPMADD52LUQ zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmadd52luq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmadd52luq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMADD52LUQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMADD52LUQ operand[, operand]

PBXB64-Verwendung

VPMADD52LUQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMADD52LUQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← VPMADD52HUQ - Multiplizieren und addieren Sie 52-Bit-QWords ohne Vorzeichen mit hohem Wert Top VPMADDUBSW - Multiply unsigned bytes, add adjacent, saturate →


VPMADDUBSW - Multiply unsigned bytes, add adjacent, saturate - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMADDUBSW - Multiply unsigned bytes, add adjacent, saturate
Hilfe zum PBXB64-Compiler

VPMADDUBSW - Multiply unsigned bytes, add adjacent, saturate

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMADDUBSW - Multiply unsigned bytes, add adjacent, saturate. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPMADDUBSW ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmaddubsw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmaddubsw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMADDUBSW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMADDUBSW operand[, operand]

PBXB64-Verwendung

VPMADDUBSW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMADDUBSW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← VPMADD52LUQ - Multiplizieren und addieren Sie 52-Bit-Quoten ohne Vorzeichen mit niedrigem Wert Top VPMADDWD - Multiply and add words to doublewords →


VPMADDWD - Multiply and add words to doublewords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMADDWD - Multiply and add words to doublewords
Hilfe zum PBXB64-Compiler

VPMADDWD - Multiply and add words to doublewords

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMADDWD - Multiply and add words to doublewords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPMADDWD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmaddwd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmaddwd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMADDWD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMADDWD operand[, operand]

PBXB64-Verwendung

VPMADDWD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMADDWD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMAXSB - Maximum of signed bytes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMAXSB - Maximum of signed bytes
Hilfe zum PBXB64-Compiler

VPMAXSB - Maximum of signed bytes

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMAXSB - Maximum of signed bytes. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPMAXSB ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmaxsb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmaxsb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMAXSB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMAXSB operand[, operand]

PBXB64-Verwendung

VPMAXSB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMAXSB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMAXSD - Maximum of signed dwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMAXSD - Maximum of signed dwords
Hilfe zum PBXB64-Compiler

VPMAXSD - Maximum of signed dwords

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMAXSD - Maximum of signed dwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPMAXSD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmaxsd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmaxsd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMAXSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMAXSD operand[, operand]

PBXB64-Verwendung

VPMAXSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMAXSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMAXSW - Maximum of signed words - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMAXSW - Maximum of signed words
Hilfe zum PBXB64-Compiler

VPMAXSW - Maximum of signed words

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMAXSW - Maximum of signed words. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPMAXSW ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmaxsw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmaxsw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMAXSW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMAXSW operand[, operand]

PBXB64-Verwendung

VPMAXSW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMAXSW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMAXUB - Maximum of unsigned bytes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMAXUB - Maximum of unsigned bytes
Hilfe zum PBXB64-Compiler

VPMAXUB - Maximum of unsigned bytes

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMAXUB - Maximum of unsigned bytes. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPMAXUB ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmaxub ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmaxub ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMAXUB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMAXUB operand[, operand]

PBXB64-Verwendung

VPMAXUB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMAXUB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMAXUD - Maximum of unsigned dwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMAXUD - Maximum of unsigned dwords
Hilfe zum PBXB64-Compiler

VPMAXUD - Maximum of unsigned dwords

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMAXUD - Maximum of unsigned dwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPMAXUD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmaxud ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmaxud ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMAXUD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMAXUD operand[, operand]

PBXB64-Verwendung

VPMAXUD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMAXUD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMAXUW - Maximum of unsigned words - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMAXUW - Maximum of unsigned words
Hilfe zum PBXB64-Compiler

VPMAXUW - Maximum of unsigned words

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMAXUW - Maximum of unsigned words. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPMAXUW ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmaxuw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmaxuw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMAXUW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMAXUW operand[, operand]

PBXB64-Verwendung

VPMAXUW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMAXUW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMINSB - Minimum of signed bytes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMINSB - Minimum of signed bytes
Hilfe zum PBXB64-Compiler

VPMINSB - Minimum of signed bytes

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMINSB - Minimum of signed bytes. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPMINSB ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpminsb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpminsb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMINSB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMINSB operand[, operand]

PBXB64-Verwendung

VPMINSB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMINSB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMINSD - Minimum of signed dwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMINSD - Minimum of signed dwords
Hilfe zum PBXB64-Compiler

VPMINSD - Minimum of signed dwords

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMINSD - Minimum of signed dwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPMINSD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpminsd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpminsd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMINSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMINSD operand[, operand]

PBXB64-Verwendung

VPMINSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMINSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMINSW - Minimum of signed words - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMINSW - Minimum of signed words
Hilfe zum PBXB64-Compiler

VPMINSW - Minimum of signed words

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMINSW - Minimum of signed words. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPMINSW ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpminsw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpminsw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMINSW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMINSW operand[, operand]

PBXB64-Verwendung

VPMINSW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMINSW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMINUB - Minimum of unsigned bytes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMINUB - Minimum of unsigned bytes
Hilfe zum PBXB64-Compiler

VPMINUB - Minimum of unsigned bytes

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMINUB - Minimum of unsigned bytes. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPMINUB ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpminub ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpminub ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMINUB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMINUB operand[, operand]

PBXB64-Verwendung

VPMINUB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMINUB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMINUD - Minimum of unsigned dwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMINUD - Minimum of unsigned dwords
Hilfe zum PBXB64-Compiler

VPMINUD - Minimum of unsigned dwords

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMINUD - Minimum of unsigned dwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPMINUD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpminud ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpminud ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMINUD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMINUD operand[, operand]

PBXB64-Verwendung

VPMINUD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMINUD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMINUW - Minimum of unsigned words - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMINUW - Minimum of unsigned words
Hilfe zum PBXB64-Compiler

VPMINUW - Minimum of unsigned words

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMINUW - Minimum of unsigned words. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPMINUW ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpminuw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpminuw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMINUW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMINUW operand[, operand]

PBXB64-Verwendung

VPMINUW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMINUW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMULDQ - Multiply signed dword to qword - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMULDQ - Multiply signed dword to qword
Hilfe zum PBXB64-Compiler

VPMULDQ - Multiply signed dword to qword

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMULDQ - Multiply signed dword to qword. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPMULDQ ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmuldq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmuldq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMULDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMULDQ operand[, operand]

PBXB64-Verwendung

VPMULDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMULDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMULHRSW - Multiply high with round and scale - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMULHRSW - Multiply high with round and scale
Hilfe zum PBXB64-Compiler

VPMULHRSW - Multiply high with round and scale

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMULHRSW - Multiply high with round and scale. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPMULHRSW ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmulhrsw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmulhrsw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMULHRSW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMULHRSW operand[, operand]

PBXB64-Verwendung

VPMULHRSW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMULHRSW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMULHUW - Multiply packed words (high, unsigned) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMULHUW - Multiply packed words (high, unsigned)
Hilfe zum PBXB64-Compiler

VPMULHUW - Multiply packed words (high, unsigned)

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMULHUW - Multiply packed words (high, unsigned). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPMULHUW ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmulhuw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmulhuw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMULHUW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMULHUW operand[, operand]

PBXB64-Verwendung

VPMULHUW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMULHUW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMULHW - Multiply packed words (high) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMULHW - Multiply packed words (high)
Hilfe zum PBXB64-Compiler

VPMULHW - Multiply packed words (high)

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMULHW - Multiply packed words (high). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPMULHW ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmulhw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmulhw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMULHW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMULHW operand[, operand]

PBXB64-Verwendung

VPMULHW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMULHW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMULLD - Multiply packed doublewords (low) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMULLD - Multiply packed doublewords (low)
Hilfe zum PBXB64-Compiler

VPMULLD - Multiply packed doublewords (low)

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMULLD - Multiply packed doublewords (low). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPMULLD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmulld ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmulld ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMULLD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMULLD operand[, operand]

PBXB64-Verwendung

VPMULLD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMULLD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMULLW - Multiply packed words (low) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMULLW - Multiply packed words (low)
Hilfe zum PBXB64-Compiler

VPMULLW - Multiply packed words (low)

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMULLW - Multiply packed words (low). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPMULLW ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmullw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmullw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMULLW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMULLW operand[, operand]

PBXB64-Verwendung

VPMULLW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMULLW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMULUDQ - Multiply unsigned dword to qword - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPMULUDQ - Multiply unsigned dword to qword
Hilfe zum PBXB64-Compiler

VPMULUDQ - Multiply unsigned dword to qword

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMULUDQ - Multiply unsigned dword to qword. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPMULUDQ ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmuludq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmuludq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMULUDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMULUDQ operand[, operand]

PBXB64-Verwendung

VPMULUDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMULUDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSUBB - Subtract packed bytes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPSUBB - Subtract packed bytes
Hilfe zum PBXB64-Compiler

VPSUBB - Subtract packed bytes

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSUBB - Subtract packed bytes. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPSUBB ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsubb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsubb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSUBB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSUBB operand[, operand]

PBXB64-Verwendung

VPSUBB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSUBB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSUBD - Subtract packed doublewords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPSUBD - Subtract packed doublewords
Hilfe zum PBXB64-Compiler

VPSUBD - Subtract packed doublewords

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSUBD - Subtract packed doublewords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPSUBD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsubd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsubd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSUBD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSUBD operand[, operand]

PBXB64-Verwendung

VPSUBD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSUBD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSUBQ - Subtract packed quadwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPSUBQ - Subtract packed quadwords
Hilfe zum PBXB64-Compiler

VPSUBQ - Subtract packed quadwords

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSUBQ - Subtract packed quadwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPSUBQ ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsubq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsubq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSUBQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSUBQ operand[, operand]

PBXB64-Verwendung

VPSUBQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSUBQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSUBW - Subtract packed words - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VPSUBW - Subtract packed words
Hilfe zum PBXB64-Compiler

VPSUBW - Subtract packed words

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSUBW - Subtract packed words. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPSUBW ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsubw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsubw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSUBW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSUBW operand[, operand]

PBXB64-Verwendung

VPSUBW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSUBW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRSQRT14PD - 14-Bit reziprokes sqrt-gepacktes Doppel - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VRSQRT14PD - 14-Bit reziprokes sqrt-gepacktes Doppel
Hilfe zum PBXB64-Compiler

VRSQRT14PD - 14-Bit reziprokes sqrt-gepacktes Doppel

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRSQRT14PD - 14-Bit reziprokes sqrt-gepacktes Doppel. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VRSQRT14PD zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrsqrt14pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrsqrt14pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRSQRT14PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRSQRT14PD operand[, operand]

PBXB64-Verwendung

VRSQRT14PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRSQRT14PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRSQRT14PS - 14-Bit reziprokes sqrt-gepacktes Single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Arithmetic › VRSQRT14PS - 14-Bit reziprokes sqrt-gepacktes Single
Hilfe zum PBXB64-Compiler

VRSQRT14PS - 14-Bit reziprokes sqrt-gepacktes Single

Category: Arithmetic

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRSQRT14PS - 14-Bit reziprokes sqrt-gepacktes Single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VRSQRT14PS zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrsqrt14ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrsqrt14ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRSQRT14PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRSQRT14PS operand[, operand]

PBXB64-Verwendung

VRSQRT14PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRSQRT14PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


AAA - ASCII-Anpassung nach Hinzufügung (nicht gültig in x64) AAS - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › AAA - ASCII-Anpassung nach Hinzufügung (nicht gültig in x64) AAS
Hilfe zum PBXB64-Compiler

AAA - ASCII-Anpassung nach Hinzufügung (nicht gültig in x64) AAS

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

AAA - ASCII-Anpassung nach Hinzufügung (nicht gültig in x64) AAS. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen ASCII-Anpassung nach Subtraktion (nicht gültig in x64).

Syntax

AAA ASCII-Anpassung nach Subtraktion (nicht gültig in x64)

Operands and Sizes

Form | Meaning
ASCII-Anpassung nach Subtraktion (nicht gültig in x64) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    aaa operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! aaa operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

AAA ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

AAA operand[, operand]

PBXB64-Verwendung

AAA ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! AAA ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


AAM - ASCII-Anpassung nach Multiplikation (nicht gültig in x64) AAD - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › AAM - ASCII-Anpassung nach Multiplikation (nicht gültig in x64) AAD
Hilfe zum PBXB64-Compiler

AAM - ASCII-Anpassung nach Multiplikation (nicht gültig in x64) AAD

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

AAM - ASCII-Anpassung nach Multiplikation (nicht gültig in x64) AAD. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen ASCII-Anpassung vor der Division (nicht gültig in x64).

Syntax

AAM ASCII-Anpassung vor der Division (nicht gültig in x64)

Operands and Sizes

Form | Meaning
ASCII-Anpassung vor der Division (nicht gültig in x64) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    aam operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! aam operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

AAM ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

AAM operand[, operand]

PBXB64-Verwendung

AAM ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! AAM ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ANDN - Bitweises UND-NICHT: dst = ~src1 & src2 - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › ANDN - Bitweises UND-NICHT: dst = ~src1 & src2
Hilfe zum PBXB64-Compiler

ANDN - Bitweises UND-NICHT: dst = ~src1 & src2

Category: Bit Operations

Assembly Group: BMI

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

ANDN - Bitweises UND-NICHT: dst = ~src1 & src2. Diese Instruktion gehoert zur BMI-Familie und verwendet die dokumentierten Operandenformen reg, reg, reg/mem.

Syntax

ANDN reg, reg, reg/mem

Operands and Sizes

Form | Meaning
reg, reg, reg | uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    andn eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! andn eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_bmi.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

ANDN ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

ANDN operand[, operand]

PBXB64-Verwendung

ANDN ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! ANDN ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • BMI mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BEXTR - Bitfeld-Extraktion: Aufeinanderfolgende Bits extrahieren - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › BEXTR - Bitfeld-Extraktion: Aufeinanderfolgende Bits extrahieren
Hilfe zum PBXB64-Compiler

BEXTR - Bitfeld-Extraktion: Aufeinanderfolgende Bits extrahieren

Category: Bit Operations

Assembly Group: BMI

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

BEXTR - Bitfeld-Extraktion: Aufeinanderfolgende Bits extrahieren. Diese Instruktion gehoert zur BMI-Familie und verwendet die dokumentierten Operandenformen reg, reg/mem, reg/imm.

Syntax

BEXTR reg, reg/mem, reg/imm

Operands and Sizes

Form | Meaning
reg, reg | uses a general-purpose register
mem, reg | may read or write memory; uses a general-purpose register
imm | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    bextr eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! bextr eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_bmi.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

BEXTR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

BEXTR operand[, operand]

PBXB64-Verwendung

BEXTR ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! BEXTR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • BMI mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BLSI - Niedrigstes gesetztes Bit isolieren: dst = src & -src - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › BLSI - Niedrigstes gesetztes Bit isolieren: dst = src & -src
Hilfe zum PBXB64-Compiler

BLSI - Niedrigstes gesetztes Bit isolieren: dst = src & -src

Category: Bit Operations

Assembly Group: BMI

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

BLSI - Niedrigstes gesetztes Bit isolieren: dst = src & -src. Diese Instruktion gehoert zur BMI-Familie und verwendet die dokumentierten Operandenformen reg, reg/mem.

Syntax

BLSI reg, reg/mem

Operands and Sizes

Form | Meaning
reg, reg | uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    blsi eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! blsi eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_bmi.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

BLSI ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

BLSI operand[, operand]

PBXB64-Verwendung

BLSI ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! BLSI ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • BMI mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BLSR - Niedrigstes gesetztes Bit zurücksetzen: dst = src & (src-1) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › BLSR - Niedrigstes gesetztes Bit zurücksetzen: dst = src & (src-1)
Hilfe zum PBXB64-Compiler

BLSR - Niedrigstes gesetztes Bit zurücksetzen: dst = src & (src-1)

Category: Bit Operations

Assembly Group: BMI

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

BLSR - Niedrigstes gesetztes Bit zurücksetzen: dst = src & (src-1). Diese Instruktion gehoert zur BMI-Familie und verwendet die dokumentierten Operandenformen reg, reg/mem.

Syntax

BLSR reg, reg/mem

Operands and Sizes

Form | Meaning
reg, reg | uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    blsr eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! blsr eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_bmi.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

BLSR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

BLSR operand[, operand]

PBXB64-Verwendung

BLSR ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! BLSR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • BMI mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CDQE - Doppelwort (EAX) in Quadwort (RAX) mit Vorzeichenerweiterung umwandeln - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › CDQE - Doppelwort (EAX) in Quadwort (RAX) mit Vorzeichenerweiterung umwandeln
Hilfe zum PBXB64-Compiler

CDQE - Doppelwort (EAX) in Quadwort (RAX) mit Vorzeichenerweiterung umwandeln

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CDQE - Doppelwort (EAX) in Quadwort (RAX) mit Vorzeichenerweiterung umwandeln. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

CDQE keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    cdqe operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cdqe operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CDQE ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CDQE operand[, operand]

PBXB64-Verwendung

CDQE ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CDQE ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CMOVNO - Nicht überlaufen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › CMOVNO - Nicht überlaufen
Hilfe zum PBXB64-Compiler

CMOVNO - Nicht überlaufen

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CMOVNO - Nicht überlaufen. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen OF=0.

Syntax

CMOVNO OF=0

Operands and Sizes

Form | Meaning
OF=0 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    cmovno operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cmovno operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CMOVNO ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CMOVNO operand[, operand]

PBXB64-Verwendung

CMOVNO ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CMOVNO ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CMOVNS - Nicht signieren (nicht negativ) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › CMOVNS - Nicht signieren (nicht negativ)
Hilfe zum PBXB64-Compiler

CMOVNS - Nicht signieren (nicht negativ)

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CMOVNS - Nicht signieren (nicht negativ). Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen SF=0.

Syntax

CMOVNS SF=0

Operands and Sizes

Form | Meaning
SF=0 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    cmovns operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cmovns operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CMOVNS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CMOVNS operand[, operand]

PBXB64-Verwendung

CMOVNS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CMOVNS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CMOVO - Überlauf - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › CMOVO - Überlauf
Hilfe zum PBXB64-Compiler

CMOVO - Überlauf

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CMOVO - Überlauf. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen OF=1.

Syntax

CMOVO OF=1

Operands and Sizes

Form | Meaning
OF=1 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    cmovo operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cmovo operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CMOVO ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CMOVO operand[, operand]

PBXB64-Verwendung

CMOVO ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CMOVO ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CMOVS - Vorzeichen (negativ) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › CMOVS - Vorzeichen (negativ)
Hilfe zum PBXB64-Compiler

CMOVS - Vorzeichen (negativ)

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CMOVS - Vorzeichen (negativ). Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen SF=1.

Syntax

CMOVS SF=1

Operands and Sizes

Form | Meaning
SF=1 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    cmovs operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cmovs operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CMOVS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CMOVS operand[, operand]

PBXB64-Verwendung

CMOVS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CMOVS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CMPXCHG16B - Vergleichen und tauschen Sie 16 Bytes (atomar, benötigt LOCK) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › CMPXCHG16B - Vergleichen und tauschen Sie 16 Bytes (atomar, benötigt LOCK)
Hilfe zum PBXB64-Compiler

CMPXCHG16B - Vergleichen und tauschen Sie 16 Bytes (atomar, benötigt LOCK)

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CMPXCHG16B - Vergleichen und tauschen Sie 16 Bytes (atomar, benötigt LOCK). Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen mem128.

Syntax

CMPXCHG16B mem128

Operands and Sizes

Form | Meaning
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    cmpxchg16b [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cmpxchg16b [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CMPXCHG16B ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CMPXCHG16B operand[, operand]

PBXB64-Verwendung

CMPXCHG16B ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CMPXCHG16B ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CMPXCHG8B - Vergleichen und tauschen Sie 8 Bytes (atomar) aus - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › CMPXCHG8B - Vergleichen und tauschen Sie 8 Bytes (atomar) aus
Hilfe zum PBXB64-Compiler

CMPXCHG8B - Vergleichen und tauschen Sie 8 Bytes (atomar) aus

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CMPXCHG8B - Vergleichen und tauschen Sie 8 Bytes (atomar) aus. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen mem64.

Syntax

CMPXCHG8B mem64

Operands and Sizes

Form | Meaning
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    cmpxchg8b [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cmpxchg8b [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CMPXCHG8B ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CMPXCHG8B operand[, operand]

PBXB64-Verwendung

CMPXCHG8B ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CMPXCHG8B ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← CMPXCHG16B - Vergleichen und tauschen Sie 16 Bytes (atomar, benötigt LOCK) Top CWDE - Wandeln Sie Wort (AX) in Doppelwort (EAX) mit Vorzeichenerweiterung um →


CWDE - Wandeln Sie Wort (AX) in Doppelwort (EAX) mit Vorzeichenerweiterung um - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › CWDE - Wandeln Sie Wort (AX) in Doppelwort (EAX) mit Vorzeichenerweiterung um
Hilfe zum PBXB64-Compiler

CWDE - Wandeln Sie Wort (AX) in Doppelwort (EAX) mit Vorzeichenerweiterung um

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CWDE - Wandeln Sie Wort (AX) in Doppelwort (EAX) mit Vorzeichenerweiterung um. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

CWDE keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    cwde operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cwde operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CWDE ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CWDE operand[, operand]

PBXB64-Verwendung

CWDE ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CWDE ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


EMMS - Leerer MMX-Status (MMX/x87-Tag-Wort löschen) FEMMS - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › EMMS - Leerer MMX-Status (MMX/x87-Tag-Wort löschen) FEMMS
Hilfe zum PBXB64-Compiler

EMMS - Leerer MMX-Status (MMX/x87-Tag-Wort löschen) FEMMS

Category: Bit Operations

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

EMMS - Leerer MMX-Status (MMX/x87-Tag-Wort löschen) FEMMS. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen Schnelles EMMS (AMD, löscht weniger Register).

Syntax

EMMS Schnelles EMMS (AMD, löscht weniger Register)

Operands and Sizes

Form | Meaning
Schnelles EMMS (AMD, löscht weniger Register) | may read or write memory; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    emms eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! emms eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

EMMS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

EMMS operand[, operand]

PBXB64-Verwendung

EMMS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! EMMS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ENDBR32 - Ende der Verzweigung (32-Bit) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › ENDBR32 - Ende der Verzweigung (32-Bit)
Hilfe zum PBXB64-Compiler

ENDBR32 - Ende der Verzweigung (32-Bit)

Category: Bit Operations

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

ENDBR32 - Ende der Verzweigung (32-Bit). Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen F3 0F 1E FB.

Syntax

ENDBR32 F3 0F 1E FB

Operands and Sizes

Form | Meaning
F3 0F 1E FB | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    endbr32 operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! endbr32 operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

ENDBR32 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

ENDBR32 operand[, operand]

PBXB64-Verwendung

ENDBR32 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! ENDBR32 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ENDBR64 - Ende der Verzweigung (64-Bit, an Verzweigungszielen) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › ENDBR64 - Ende der Verzweigung (64-Bit, an Verzweigungszielen)
Hilfe zum PBXB64-Compiler

ENDBR64 - Ende der Verzweigung (64-Bit, an Verzweigungszielen)

Category: Bit Operations

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

ENDBR64 - Ende der Verzweigung (64-Bit, an Verzweigungszielen). Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen F3 0F 1E FA.

Syntax

ENDBR64 F3 0F 1E FA

Operands and Sizes

Form | Meaning
F3 0F 1E FA | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    endbr64 operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! endbr64 operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

ENDBR64 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

ENDBR64 operand[, operand]

PBXB64-Verwendung

ENDBR64 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! ENDBR64 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FCHS - Vorzeichen ändern (negieren) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › FCHS - Vorzeichen ändern (negieren)
Hilfe zum PBXB64-Compiler

FCHS - Vorzeichen ändern (negieren)

Category: Bit Operations

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FCHS - Vorzeichen ändern (negieren). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

FCHS keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fchs operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fchs operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FCHS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FCHS operand[, operand]

PBXB64-Verwendung

FCHS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FCHS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FCOM - Vergleichen Sie ST0 mit src (stellt das FPU-Statuswort C0/C2/C3 ein) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › FCOM - Vergleichen Sie ST0 mit src (stellt das FPU-Statuswort C0/C2/C3 ein)
Hilfe zum PBXB64-Compiler

FCOM - Vergleichen Sie ST0 mit src (stellt das FPU-Statuswort C0/C2/C3 ein)

Category: Bit Operations

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FCOM - Vergleichen Sie ST0 mit src (stellt das FPU-Statuswort C0/C2/C3 ein). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem32/64 / ST(i).

Syntax

FCOM mem32/64 / ST(i)

Operands and Sizes

Form | Meaning
mem32 | may read or write memory
64 | follow the operand order shown in the syntax
ST(i) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fcom [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fcom [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FCOM ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FCOM operand[, operand]

PBXB64-Verwendung

FCOM ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FCOM ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


FLDCW - FPU-Steuerwort laden - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › FLDCW - FPU-Steuerwort laden
Hilfe zum PBXB64-Compiler

FLDCW - FPU-Steuerwort laden

Category: Bit Operations

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FLDCW - FPU-Steuerwort laden. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem16.

Syntax

FLDCW mem16

Operands and Sizes

Form | Meaning
mem16 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fldcw [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fldcw [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FLDCW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FLDCW operand[, operand]

PBXB64-Verwendung

FLDCW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FLDCW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FSTCW - FPU-Steuerwort speichern - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › FSTCW - FPU-Steuerwort speichern
Hilfe zum PBXB64-Compiler

FSTCW - FPU-Steuerwort speichern

Category: Bit Operations

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FSTCW - FPU-Steuerwort speichern. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem16.

Syntax

FSTCW mem16

Operands and Sizes

Form | Meaning
mem16 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fstcw [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fstcw [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FSTCW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FSTCW operand[, operand]

PBXB64-Verwendung

FSTCW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FSTCW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FSTSW - FPU-Statuswort speichern - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › FSTSW - FPU-Statuswort speichern
Hilfe zum PBXB64-Compiler

FSTSW - FPU-Statuswort speichern

Category: Bit Operations

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FSTSW - FPU-Statuswort speichern. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem16 / AX.

Syntax

FSTSW mem16 / AX

Operands and Sizes

Form | Meaning
mem16 | may read or write memory
AX | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fstsw [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fstsw [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FSTSW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FSTSW operand[, operand]

PBXB64-Verwendung

FSTSW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FSTSW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FUCOM - Ungeordneter Vergleich (keine Ausnahme bei NaN) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › FUCOM - Ungeordneter Vergleich (keine Ausnahme bei NaN)
Hilfe zum PBXB64-Compiler

FUCOM - Ungeordneter Vergleich (keine Ausnahme bei NaN)

Category: Bit Operations

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FUCOM - Ungeordneter Vergleich (keine Ausnahme bei NaN). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen ST(i).

Syntax

FUCOM ST(i)

Operands and Sizes

Form | Meaning
ST(i) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fucom operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fucom operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FUCOM ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FUCOM operand[, operand]

PBXB64-Verwendung

FUCOM ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FUCOM ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


FUCOMP - Ungeordneter Vergleich und Pop - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › FUCOMP - Ungeordneter Vergleich und Pop
Hilfe zum PBXB64-Compiler

FUCOMP - Ungeordneter Vergleich und Pop

Category: Bit Operations

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FUCOMP - Ungeordneter Vergleich und Pop. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen ST(i).

Syntax

FUCOMP ST(i)

Operands and Sizes

Form | Meaning
ST(i) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fucomp operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fucomp operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FUCOMP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FUCOMP operand[, operand]

PBXB64-Verwendung

FUCOMP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FUCOMP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


FUCOMPP - Ungeordneter Vergleich und zweimal Pop - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › FUCOMPP - Ungeordneter Vergleich und zweimal Pop
Hilfe zum PBXB64-Compiler

FUCOMPP - Ungeordneter Vergleich und zweimal Pop

Category: Bit Operations

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FUCOMPP - Ungeordneter Vergleich und zweimal Pop. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

FUCOMPP keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fucompp operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fucompp operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FUCOMPP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FUCOMPP operand[, operand]

PBXB64-Verwendung

FUCOMPP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FUCOMPP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


FXAM - Untersuchen Sie ST0 (NaN, normal, denormal, Null usw.) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › FXAM - Untersuchen Sie ST0 (NaN, normal, denormal, Null usw.)
Hilfe zum PBXB64-Compiler

FXAM - Untersuchen Sie ST0 (NaN, normal, denormal, Null usw.)

Category: Bit Operations

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FXAM - Untersuchen Sie ST0 (NaN, normal, denormal, Null usw.). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

FXAM keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fxam operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fxam operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FXAM ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FXAM operand[, operand]

PBXB64-Verwendung

FXAM ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FXAM ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FXTRACT - Extrahieren Sie Exponent und Signifikand - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › FXTRACT - Extrahieren Sie Exponent und Signifikand
Hilfe zum PBXB64-Compiler

FXTRACT - Extrahieren Sie Exponent und Signifikand

Category: Bit Operations

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FXTRACT - Extrahieren Sie Exponent und Signifikand. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

FXTRACT keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fxtract operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fxtract operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FXTRACT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FXTRACT operand[, operand]

PBXB64-Verwendung

FXTRACT ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FXTRACT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GF2P8AFFINEINVQB - Galois-Feld-Affintransformation invers (älteres SSE) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › GF2P8AFFINEINVQB - Galois-Feld-Affintransformation invers (älteres SSE)
Hilfe zum PBXB64-Compiler

GF2P8AFFINEINVQB - Galois-Feld-Affintransformation invers (älteres SSE)

Category: Bit Operations

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

GF2P8AFFINEINVQB - Galois-Feld-Affintransformation invers (älteres SSE). Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

GF2P8AFFINEINVQB xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    gf2p8affineinvqb xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! gf2p8affineinvqb xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

GF2P8AFFINEINVQB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

GF2P8AFFINEINVQB operand[, operand]

PBXB64-Verwendung

GF2P8AFFINEINVQB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! GF2P8AFFINEINVQB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GF2P8AFFINEQB - Galois-Feld-Affintransformation (altes SSE) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › GF2P8AFFINEQB - Galois-Feld-Affintransformation (altes SSE)
Hilfe zum PBXB64-Compiler

GF2P8AFFINEQB - Galois-Feld-Affintransformation (altes SSE)

Category: Bit Operations

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

GF2P8AFFINEQB - Galois-Feld-Affintransformation (altes SSE). Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

GF2P8AFFINEQB xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    gf2p8affineqb xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! gf2p8affineqb xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

GF2P8AFFINEQB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

GF2P8AFFINEQB operand[, operand]

PBXB64-Verwendung

GF2P8AFFINEQB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! GF2P8AFFINEQB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


HLT - Prozessor bis zum nächsten Interrupt anhalten - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › HLT - Prozessor bis zum nächsten Interrupt anhalten
Hilfe zum PBXB64-Compiler

HLT - Prozessor bis zum nächsten Interrupt anhalten

Category: Bit Operations

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

HLT - Prozessor bis zum nächsten Interrupt anhalten. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

HLT keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    hlt operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! hlt operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

HLT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

HLT operand[, operand]

PBXB64-Verwendung

HLT ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! HLT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


IN - Eingabe vom I/O-Port - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › IN - Eingabe vom I/O-Port
Hilfe zum PBXB64-Compiler

IN - Eingabe vom I/O-Port

Category: Bit Operations

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

IN - Eingabe vom I/O-Port. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen AL/AX/EAX, DX/imm8.

Syntax

IN AL/AX/EAX, DX/imm8

Operands and Sizes

Form | Meaning
AL | follow the operand order shown in the syntax
AX | follow the operand order shown in the syntax
EAX, DX | follow the operand order shown in the syntax
imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    in operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! in operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

IN ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

IN operand[, operand]

PBXB64-Verwendung

IN ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! IN ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


INVVPID - VPID (Virtuelle Prozessor-ID) ungültig machen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › INVVPID - VPID (Virtuelle Prozessor-ID) ungültig machen
Hilfe zum PBXB64-Compiler

INVVPID - VPID (Virtuelle Prozessor-ID) ungültig machen

Category: Bit Operations

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

INVVPID - VPID (Virtuelle Prozessor-ID) ungültig machen. Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen reg, mem128.

Syntax

INVVPID reg, mem128

Operands and Sizes

Form | Meaning
reg, mem128 | may read or write memory; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    invvpid eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! invvpid eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

INVVPID ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

INVVPID operand[, operand]

PBXB64-Verwendung

INVVPID ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! INVVPID ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


JNO - Springe, wenn nicht überlaufen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › JNO - Springe, wenn nicht überlaufen
Hilfe zum PBXB64-Compiler

JNO - Springe, wenn nicht überlaufen

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

JNO - Springe, wenn nicht überlaufen. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen OF=0.

Syntax

JNO OF=0

Operands and Sizes

Form | Meaning
OF=0 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    jno operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! jno operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

JNO ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

JNO operand[, operand]

PBXB64-Verwendung

JNO ist eine control-transfer Instruktion fuer control flow. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! JNO ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


JNS - Springen Sie, wenn Sie nicht unterschreiben - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › JNS - Springen Sie, wenn Sie nicht unterschreiben
Hilfe zum PBXB64-Compiler

JNS - Springen Sie, wenn Sie nicht unterschreiben

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

JNS - Springen Sie, wenn Sie nicht unterschreiben. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen SF=0.

Syntax

JNS SF=0

Operands and Sizes

Form | Meaning
SF=0 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    jns operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! jns operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

JNS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

JNS operand[, operand]

PBXB64-Verwendung

JNS ist eine control-transfer Instruktion fuer control flow. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! JNS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


JO - Bei Überlauf springen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › JO - Bei Überlauf springen
Hilfe zum PBXB64-Compiler

JO - Bei Überlauf springen

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

JO - Bei Überlauf springen. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen OF=1.

Syntax

JO OF=1

Operands and Sizes

Form | Meaning
OF=1 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    jo operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! jo operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

JO ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

JO operand[, operand]

PBXB64-Verwendung

JO ist eine control-transfer Instruktion fuer control flow. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! JO ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


JS - Springe, wenn Vorzeichen (negativ) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › JS - Springe, wenn Vorzeichen (negativ)
Hilfe zum PBXB64-Compiler

JS - Springe, wenn Vorzeichen (negativ)

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

JS - Springe, wenn Vorzeichen (negativ). Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen SF=1.

Syntax

JS SF=1

Operands and Sizes

Form | Meaning
SF=1 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    js operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! js operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

JS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

JS operand[, operand]

PBXB64-Verwendung

JS ist eine control-transfer Instruktion fuer control flow. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! JS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LAR - Zugriffsrechte laden (Segmentdeskriptor) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › LAR - Zugriffsrechte laden (Segmentdeskriptor)
Hilfe zum PBXB64-Compiler

LAR - Zugriffsrechte laden (Segmentdeskriptor)

Category: Bit Operations

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

LAR - Zugriffsrechte laden (Segmentdeskriptor). Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen reg, reg/mem16.

Syntax

LAR reg, reg/mem16

Operands and Sizes

Form | Meaning
reg, reg | uses a general-purpose register
mem16 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    lar eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! lar eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

LAR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

LAR operand[, operand]

PBXB64-Verwendung

LAR ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! LAR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LDDQU - Laden Sie nicht ausgerichtete 128-Bit-Dateien (vermeidet die Aufteilung der Cache-Zeile) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › LDDQU - Laden Sie nicht ausgerichtete 128-Bit-Dateien (vermeidet die Aufteilung der Cache-Zeile)
Hilfe zum PBXB64-Compiler

LDDQU - Laden Sie nicht ausgerichtete 128-Bit-Dateien (vermeidet die Aufteilung der Cache-Zeile)

Category: Bit Operations

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

LDDQU - Laden Sie nicht ausgerichtete 128-Bit-Dateien (vermeidet die Aufteilung der Cache-Zeile). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, mem128.

Syntax

LDDQU xmm, mem128

Operands and Sizes

Form | Meaning
xmm, mem128 | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    lddqu xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! lddqu xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

LDDQU ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

LDDQU operand[, operand]

PBXB64-Verwendung

LDDQU ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! LDDQU ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LGDT - Laden Sie das Global Descriptor Table-Register - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › LGDT - Laden Sie das Global Descriptor Table-Register
Hilfe zum PBXB64-Compiler

LGDT - Laden Sie das Global Descriptor Table-Register

Category: Bit Operations

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

LGDT - Laden Sie das Global Descriptor Table-Register. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen mem80 (Pseudo-Deskriptor).

Syntax

LGDT mem80 (Pseudo-Deskriptor)

Operands and Sizes

Form | Meaning
mem80 (Pseudo-Deskriptor) | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    lgdt [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! lgdt [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

LGDT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

LGDT operand[, operand]

PBXB64-Verwendung

LGDT ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! LGDT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← LDDQU - Laden Sie nicht ausgerichtete 128-Bit-Dateien (vermeidet die Aufteilung der Cache-Zeile) Top LIDT - Interrupt-Deskriptor-Tabellenregister laden →


LIDT - Interrupt-Deskriptor-Tabellenregister laden - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › LIDT - Interrupt-Deskriptor-Tabellenregister laden
Hilfe zum PBXB64-Compiler

LIDT - Interrupt-Deskriptor-Tabellenregister laden

Category: Bit Operations

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

LIDT - Interrupt-Deskriptor-Tabellenregister laden. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen mem80.

Syntax

LIDT mem80

Operands and Sizes

Form | Meaning
mem80 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    lidt [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! lidt [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

LIDT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

LIDT operand[, operand]

PBXB64-Verwendung

LIDT ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! LIDT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LLDT - Laden Sie das Register der lokalen Deskriptortabelle - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › LLDT - Laden Sie das Register der lokalen Deskriptortabelle
Hilfe zum PBXB64-Compiler

LLDT - Laden Sie das Register der lokalen Deskriptortabelle

Category: Bit Operations

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

LLDT - Laden Sie das Register der lokalen Deskriptortabelle. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen reg/mem16/64.

Syntax

LLDT reg/mem16/64

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem16 | may read or write memory
64 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    lldt eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! lldt eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

LLDT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

LLDT operand[, operand]

PBXB64-Verwendung

LLDT ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! LLDT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LMSW - Maschinenstatuswort laden - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › LMSW - Maschinenstatuswort laden
Hilfe zum PBXB64-Compiler

LMSW - Maschinenstatuswort laden

Category: Bit Operations

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

LMSW - Maschinenstatuswort laden. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen reg/mem16/64.

Syntax

LMSW reg/mem16/64

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem16 | may read or write memory
64 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    lmsw eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! lmsw eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

LMSW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

LMSW operand[, operand]

PBXB64-Verwendung

LMSW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! LMSW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOOP - CX/ECX/RCX dekrementieren, springen, wenn nicht Null - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › LOOP - CX/ECX/RCX dekrementieren, springen, wenn nicht Null
Hilfe zum PBXB64-Compiler

LOOP - CX/ECX/RCX dekrementieren, springen, wenn nicht Null

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

LOOP - CX/ECX/RCX dekrementieren, springen, wenn nicht Null. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen Etikett.

Syntax

LOOP Etikett

Operands and Sizes

Form | Meaning
Etikett | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    loop operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! loop operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

LOOP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

LOOP operand[, operand]

PBXB64-Verwendung

LOOP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! LOOP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LZCNT - Führende Nullen zählen – BMI1 (über F3 0F BD) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › LZCNT - Führende Nullen zählen - BMI1 (über F3 0F BD)
Hilfe zum PBXB64-Compiler

LZCNT - Führende Nullen zählen – BMI1 (über F3 0F BD)

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

LZCNT - Führende Nullen zählen – BMI1 (über F3 0F BD). Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen reg, reg/mem.

Syntax

LZCNT reg, reg/mem

Operands and Sizes

Form | Meaning
reg, reg | uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    lzcnt eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! lzcnt eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

LZCNT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

LZCNT operand[, operand]

PBXB64-Verwendung

LZCNT ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! LZCNT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MONITORX - Erweiterter MONITOR - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › MONITORX - Erweiterter MONITOR
Hilfe zum PBXB64-Compiler

MONITORX - Erweiterter MONITOR

Category: Bit Operations

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MONITORX - Erweiterter MONITOR. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

MONITORX keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    monitorx operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! monitorx operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MONITORX ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MONITORX operand[, operand]

PBXB64-Verwendung

MONITORX ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MONITORX ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVABS - 64-Bit-Absolutwert verschieben (Alias ​​auf MOV mit imm64) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › MOVABS - 64-Bit-Absolutwert verschieben (Alias &#8203;&#8203;auf MOV mit imm64)
Hilfe zum PBXB64-Compiler

MOVABS - 64-Bit-Absolutwert verschieben (Alias ​​auf MOV mit imm64)

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVABS - 64-Bit-Absolutwert verschieben (Alias ​​auf MOV mit imm64). Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen reg64, imm64.

Syntax

MOVABS reg64, imm64

Operands and Sizes

Form | Meaning
reg64, imm64 | may read or write memory; uses an immediate control byte or value; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    movabs eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movabs eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVABS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVABS operand[, operand]

PBXB64-Verwendung

MOVABS ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVABS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVBE - Verschieben mit Big-Endian-Konvertierung (Laden/Speichern) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › MOVBE - Verschieben mit Big-Endian-Konvertierung (Laden/Speichern)
Hilfe zum PBXB64-Compiler

MOVBE - Verschieben mit Big-Endian-Konvertierung (Laden/Speichern)

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVBE - Verschieben mit Big-Endian-Konvertierung (Laden/Speichern). Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen reg, mem / mem, reg.

Syntax

MOVBE reg, mem / mem, reg

Operands and Sizes

Form | Meaning
reg, mem | may read or write memory; uses a general-purpose register
mem, reg | may read or write memory; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    movbe eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movbe eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVBE ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVBE operand[, operand]

PBXB64-Verwendung

MOVBE ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVBE ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← MOVABS - 64-Bit-Absolutwert verschieben (Alias &#8203;&#8203;auf MOV mit imm64) Top MOVDQ2Q - Verschieben Sie XMM in das MMX-Register (niedriges Quadwort). →


MOVDQ2Q - Verschieben Sie XMM in das MMX-Register (niedriges Quadwort). - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › MOVDQ2Q - Verschieben Sie XMM in das MMX-Register (niedriges Quadwort).
Hilfe zum PBXB64-Compiler

MOVDQ2Q - Verschieben Sie XMM in das MMX-Register (niedriges Quadwort).

Category: Bit Operations

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVDQ2Q - Verschieben Sie XMM in das MMX-Register (niedriges Quadwort).. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen mm, xmm.

Syntax

MOVDQ2Q mm, xmm

Operands and Sizes

Form | Meaning
mm, xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    movdq2q xmm0, xmm1
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movdq2q xmm0, xmm1
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVDQ2Q ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVDQ2Q operand[, operand]

PBXB64-Verwendung

MOVDQ2Q ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVDQ2Q ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVDQA - Ausgerichtetes Doppelquadwort verschieben (16-Byte-ausgerichtet) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › MOVDQA - Ausgerichtetes Doppelquadwort verschieben (16-Byte-ausgerichtet)
Hilfe zum PBXB64-Compiler

MOVDQA - Ausgerichtetes Doppelquadwort verschieben (16-Byte-ausgerichtet)

Category: Bit Operations

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVDQA - Ausgerichtetes Doppelquadwort verschieben (16-Byte-ausgerichtet). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128 / mem128, xmm.

Syntax

MOVDQA xmm, xmm/mem128 / mem128, xmm

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory
mem128, xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    movdqa xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movdqa xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVDQA ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVDQA operand[, operand]

PBXB64-Verwendung

MOVDQA ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVDQA ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVNTDQ - Nicht-temporärer Speicher von 128 Bit (SSE2) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › MOVNTDQ - Nicht-temporärer Speicher von 128 Bit (SSE2)
Hilfe zum PBXB64-Compiler

MOVNTDQ - Nicht-temporärer Speicher von 128 Bit (SSE2)

Category: Bit Operations

Assembly Group: CACHE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVNTDQ - Nicht-temporärer Speicher von 128 Bit (SSE2). Diese Instruktion gehoert zur CACHE-Familie und verwendet die dokumentierten Operandenformen mem128, xmm.

Syntax

MOVNTDQ mem128, xmm

Operands and Sizes

Form | Meaning
mem128, xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    movntdq xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movntdq xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_cache.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVNTDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVNTDQ operand[, operand]

PBXB64-Verwendung

MOVNTDQ ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVNTDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CACHE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVNTDQA - Nicht-temporäre Last (Streaming-Lasthinweis, SSE4.1) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › MOVNTDQA - Nicht-temporäre Last (Streaming-Lasthinweis, SSE4.1)
Hilfe zum PBXB64-Compiler

MOVNTDQA - Nicht-temporäre Last (Streaming-Lasthinweis, SSE4.1)

Category: Bit Operations

Assembly Group: CACHE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVNTDQA - Nicht-temporäre Last (Streaming-Lasthinweis, SSE4.1). Diese Instruktion gehoert zur CACHE-Familie und verwendet die dokumentierten Operandenformen xmm, mem128.

Syntax

MOVNTDQA xmm, mem128

Operands and Sizes

Form | Meaning
xmm, mem128 | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    movntdqa xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movntdqa xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_cache.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVNTDQA ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVNTDQA operand[, operand]

PBXB64-Verwendung

MOVNTDQA ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVNTDQA ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CACHE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVNTI - Nicht-temporäre Speicherung von Ganzzahlen (dword/qword) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › MOVNTI - Nicht-temporäre Speicherung von Ganzzahlen (dword/qword)
Hilfe zum PBXB64-Compiler

MOVNTI - Nicht-temporäre Speicherung von Ganzzahlen (dword/qword)

Category: Bit Operations

Assembly Group: CACHE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVNTI - Nicht-temporäre Speicherung von Ganzzahlen (dword/qword). Diese Instruktion gehoert zur CACHE-Familie und verwendet die dokumentierten Operandenformen mem32/64, reg.

Syntax

MOVNTI mem32/64, reg

Operands and Sizes

Form | Meaning
mem32 | may read or write memory
64, reg | uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    movnti eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movnti eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_cache.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVNTI ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVNTI operand[, operand]

PBXB64-Verwendung

MOVNTI ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVNTI ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CACHE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVQ2DQ - MMX in das XMM-Register verschieben (niedriges Quadword) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › MOVQ2DQ - MMX in das XMM-Register verschieben (niedriges Quadword)
Hilfe zum PBXB64-Compiler

MOVQ2DQ - MMX in das XMM-Register verschieben (niedriges Quadword)

Category: Bit Operations

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVQ2DQ - MMX in das XMM-Register verschieben (niedriges Quadword). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, mm.

Syntax

MOVQ2DQ xmm, mm

Operands and Sizes

Form | Meaning
xmm, mm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    movq2dq xmm0, xmm1
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movq2dq xmm0, xmm1
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVQ2DQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVQ2DQ operand[, operand]

PBXB64-Verwendung

MOVQ2DQ ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVQ2DQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVSXD - Mit Vorzeichenerweiterung verschieben (32-Bit auf 64-Bit) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › MOVSXD - Mit Vorzeichenerweiterung verschieben (32-Bit auf 64-Bit)
Hilfe zum PBXB64-Compiler

MOVSXD - Mit Vorzeichenerweiterung verschieben (32-Bit auf 64-Bit)

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVSXD - Mit Vorzeichenerweiterung verschieben (32-Bit auf 64-Bit). Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen reg64, reg/mem32.

Syntax

MOVSXD reg64, reg/mem32

Operands and Sizes

Form | Meaning
reg64, reg | uses a general-purpose register
mem32 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    movsxd eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movsxd eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVSXD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVSXD operand[, operand]

PBXB64-Verwendung

MOVSXD ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVSXD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVZX - Bewegen Sie sich ohne Verlängerung - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › MOVZX - Bewegen Sie sich ohne Verlängerung
Hilfe zum PBXB64-Compiler

MOVZX - Bewegen Sie sich ohne Verlängerung

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVZX - Bewegen Sie sich ohne Verlängerung. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen reg, reg/mem.

Syntax

MOVZX reg, reg/mem

Operands and Sizes

Form | Meaning
reg, reg | uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    movzx eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movzx eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVZX ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVZX operand[, operand]

PBXB64-Verwendung

MOVZX ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVZX ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MPSADBW - Mehrfachsumme absoluter Differenzen (8-Bit) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › MPSADBW - Mehrfachsumme absoluter Differenzen (8-Bit)
Hilfe zum PBXB64-Compiler

MPSADBW - Mehrfachsumme absoluter Differenzen (8-Bit)

Category: Bit Operations

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MPSADBW - Mehrfachsumme absoluter Differenzen (8-Bit). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

MPSADBW xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    mpsadbw xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! mpsadbw xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MPSADBW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MPSADBW operand[, operand]

PBXB64-Verwendung

MPSADBW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MPSADBW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MWAIT - Überwachen und warten Sie auf Schreibvorgänge - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › MWAIT - Überwachen und warten Sie auf Schreibvorgänge
Hilfe zum PBXB64-Compiler

MWAIT - Überwachen und warten Sie auf Schreibvorgänge

Category: Bit Operations

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MWAIT - Überwachen und warten Sie auf Schreibvorgänge. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen keine (verwendet EAX/ECX).

Syntax

MWAIT keine (verwendet EAX/ECX)

Operands and Sizes

Form | Meaning
keine (verwendet EAX | follow the operand order shown in the syntax
ECX) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    mwait operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! mwait operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MWAIT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MWAIT operand[, operand]

PBXB64-Verwendung

MWAIT ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MWAIT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


OUT - Ausgabe an den I/O-Port - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › OUT - Ausgabe an den I/O-Port
Hilfe zum PBXB64-Compiler

OUT - Ausgabe an den I/O-Port

Category: Bit Operations

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

OUT - Ausgabe an den I/O-Port. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen DX/imm8, AL/AX/EAX.

Syntax

OUT DX/imm8, AL/AX/EAX

Operands and Sizes

Form | Meaning
DX | follow the operand order shown in the syntax
imm8, AL | may read or write memory; uses an immediate control byte or value
AX | follow the operand order shown in the syntax
EAX | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    out operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! out operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

OUT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

OUT operand[, operand]

PBXB64-Verwendung

OUT ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! OUT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PCLMULQDQ - Übertragsfreie Multiplikation zweier 64-Bit-Hälften - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › PCLMULQDQ - Übertragsfreie Multiplikation zweier 64-Bit-Hälften
Hilfe zum PBXB64-Compiler

PCLMULQDQ - Übertragsfreie Multiplikation zweier 64-Bit-Hälften

Category: Bit Operations

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PCLMULQDQ - Übertragsfreie Multiplikation zweier 64-Bit-Hälften. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

PCLMULQDQ xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pclmulqdq xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pclmulqdq xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PCLMULQDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PCLMULQDQ operand[, operand]

PBXB64-Verwendung

PCLMULQDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PCLMULQDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PEXTRD - Doppelwort extrahieren - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › PEXTRD - Doppelwort extrahieren
Hilfe zum PBXB64-Compiler

PEXTRD - Doppelwort extrahieren

Category: Bit Operations

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PEXTRD - Doppelwort extrahieren. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen reg/mem32, xmm, imm8.

Syntax

PEXTRD reg/mem32, xmm, imm8

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem32, xmm, imm8 | uses XMM vector/scalar registers; may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 4
asm_data32:
    .long 0

.text
.global main
main:
    pextrd xmm0, [rip + asm_data32]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pextrd xmm0, [rip + asm_data32]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PEXTRD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PEXTRD operand[, operand]

PBXB64-Verwendung

PEXTRD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PEXTRD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PEXTRQ - Quadword extrahieren - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › PEXTRQ - Quadword extrahieren
Hilfe zum PBXB64-Compiler

PEXTRQ - Quadword extrahieren

Category: Bit Operations

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PEXTRQ - Quadword extrahieren. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen reg/mem64, xmm, imm8.

Syntax

PEXTRQ reg/mem64, xmm, imm8

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem64, xmm, imm8 | uses XMM vector/scalar registers; may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 8
asm_data64:
    .quad 0

.text
.global main
main:
    pextrq xmm0, [rip + asm_data64]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pextrq xmm0, [rip + asm_data64]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PEXTRQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PEXTRQ operand[, operand]

PBXB64-Verwendung

PEXTRQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PEXTRQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PINSRD - Doppelwort einfügen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › PINSRD - Doppelwort einfügen
Hilfe zum PBXB64-Compiler

PINSRD - Doppelwort einfügen

Category: Bit Operations

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PINSRD - Doppelwort einfügen. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, reg/mem32, imm8.

Syntax

PINSRD xmm, reg/mem32, imm8

Operands and Sizes

Form | Meaning
xmm, reg | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register
mem32, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 4
asm_data32:
    .long 0

.text
.global main
main:
    pinsrd xmm0, [rip + asm_data32]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pinsrd xmm0, [rip + asm_data32]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PINSRD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PINSRD operand[, operand]

PBXB64-Verwendung

PINSRD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PINSRD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PINSRQ - Quadword einfügen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › PINSRQ - Quadword einfügen
Hilfe zum PBXB64-Compiler

PINSRQ - Quadword einfügen

Category: Bit Operations

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PINSRQ - Quadword einfügen. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, reg/mem64, imm8.

Syntax

PINSRQ xmm, reg/mem64, imm8

Operands and Sizes

Form | Meaning
xmm, reg | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register
mem64, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 8
asm_data64:
    .quad 0

.text
.global main
main:
    pinsrq xmm0, [rip + asm_data64]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pinsrq xmm0, [rip + asm_data64]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PINSRQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PINSRQ operand[, operand]

PBXB64-Verwendung

PINSRQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PINSRQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMOVSXBD - Verschieben Sie mit Vorzeichenerweiterung Bytes in Doppelwörter - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › PMOVSXBD - Verschieben Sie mit Vorzeichenerweiterung Bytes in Doppelwörter
Hilfe zum PBXB64-Compiler

PMOVSXBD - Verschieben Sie mit Vorzeichenerweiterung Bytes in Doppelwörter

Category: Bit Operations

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMOVSXBD - Verschieben Sie mit Vorzeichenerweiterung Bytes in Doppelwörter. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem32.

Syntax

PMOVSXBD xmm, xmm/mem32

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem32 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 4
asm_data32:
    .long 0

.text
.global main
main:
    pmovsxbd xmm0, [rip + asm_data32]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmovsxbd xmm0, [rip + asm_data32]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMOVSXBD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMOVSXBD operand[, operand]

PBXB64-Verwendung

PMOVSXBD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMOVSXBD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMOVSXBQ - Verschieben Sie mit Vorzeichenerweiterung Bytes in Quadwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › PMOVSXBQ - Verschieben Sie mit Vorzeichenerweiterung Bytes in Quadwords
Hilfe zum PBXB64-Compiler

PMOVSXBQ - Verschieben Sie mit Vorzeichenerweiterung Bytes in Quadwords

Category: Bit Operations

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMOVSXBQ - Verschieben Sie mit Vorzeichenerweiterung Bytes in Quadwords. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem16.

Syntax

PMOVSXBQ xmm, xmm/mem16

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem16 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    pmovsxbq xmm0, xmm1
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmovsxbq xmm0, xmm1
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMOVSXBQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMOVSXBQ operand[, operand]

PBXB64-Verwendung

PMOVSXBQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMOVSXBQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← PMOVSXBD - Verschieben Sie mit Vorzeichenerweiterung Bytes in Doppelwörter Top PMOVSXBW - Bewegen Sie sich mit Vorzeichenerweiterung, Bytes zu Wörtern →


PMOVSXBW - Bewegen Sie sich mit Vorzeichenerweiterung, Bytes zu Wörtern - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › PMOVSXBW - Bewegen Sie sich mit Vorzeichenerweiterung, Bytes zu Wörtern
Hilfe zum PBXB64-Compiler

PMOVSXBW - Bewegen Sie sich mit Vorzeichenerweiterung, Bytes zu Wörtern

Category: Bit Operations

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMOVSXBW - Bewegen Sie sich mit Vorzeichenerweiterung, Bytes zu Wörtern. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem64.

Syntax

PMOVSXBW xmm, xmm/mem64

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 8
asm_data64:
    .quad 0

.text
.global main
main:
    pmovsxbw xmm0, [rip + asm_data64]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmovsxbw xmm0, [rip + asm_data64]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMOVSXBW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMOVSXBW operand[, operand]

PBXB64-Verwendung

PMOVSXBW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMOVSXBW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← PMOVSXBQ - Verschieben Sie mit Vorzeichenerweiterung Bytes in Quadwords Top PMOVSXDQ - Bewegen Sie sich mit Vorzeichenerweiterung, Doppelwörter zu Quadwörtern →


PMOVSXDQ - Bewegen Sie sich mit Vorzeichenerweiterung, Doppelwörter zu Quadwörtern - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › PMOVSXDQ - Bewegen Sie sich mit Vorzeichenerweiterung, Doppelwörter zu Quadwörtern
Hilfe zum PBXB64-Compiler

PMOVSXDQ - Bewegen Sie sich mit Vorzeichenerweiterung, Doppelwörter zu Quadwörtern

Category: Bit Operations

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMOVSXDQ - Bewegen Sie sich mit Vorzeichenerweiterung, Doppelwörter zu Quadwörtern. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem64.

Syntax

PMOVSXDQ xmm, xmm/mem64

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 8
asm_data64:
    .quad 0

.text
.global main
main:
    pmovsxdq xmm0, [rip + asm_data64]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmovsxdq xmm0, [rip + asm_data64]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMOVSXDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMOVSXDQ operand[, operand]

PBXB64-Verwendung

PMOVSXDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMOVSXDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMOVZXBQ - Verschieben Sie Bytes mit der Erweiterung Null in Quadwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › PMOVZXBQ - Verschieben Sie Bytes mit der Erweiterung Null in Quadwords
Hilfe zum PBXB64-Compiler

PMOVZXBQ - Verschieben Sie Bytes mit der Erweiterung Null in Quadwords

Category: Bit Operations

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMOVZXBQ - Verschieben Sie Bytes mit der Erweiterung Null in Quadwords. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem16.

Syntax

PMOVZXBQ xmm, xmm/mem16

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem16 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    pmovzxbq xmm0, xmm1
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmovzxbq xmm0, xmm1
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMOVZXBQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMOVZXBQ operand[, operand]

PBXB64-Verwendung

PMOVZXBQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMOVZXBQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← PMOVSXDQ - Bewegen Sie sich mit Vorzeichenerweiterung, Doppelwörter zu Quadwörtern Top PMULUDQ - Multiplizieren Sie ein vorzeichenloses Doppelwort mit einem Quadwort →


PMULUDQ - Multiplizieren Sie ein vorzeichenloses Doppelwort mit einem Quadwort - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › PMULUDQ - Multiplizieren Sie ein vorzeichenloses Doppelwort mit einem Quadwort
Hilfe zum PBXB64-Compiler

PMULUDQ - Multiplizieren Sie ein vorzeichenloses Doppelwort mit einem Quadwort

Category: Bit Operations

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMULUDQ - Multiplizieren Sie ein vorzeichenloses Doppelwort mit einem Quadwort. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PMULUDQ xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pmuludq xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmuludq xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMULUDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMULUDQ operand[, operand]

PBXB64-Verwendung

PMULUDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMULUDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← PMOVZXBQ - Verschieben Sie Bytes mit der Erweiterung Null in Quadwords Top PREFETCHH - Daten auf der angegebenen Hinweisebene vorab in den Cache abrufen →


PREFETCHH - Daten auf der angegebenen Hinweisebene vorab in den Cache abrufen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › PREFETCHH - Daten auf der angegebenen Hinweisebene vorab in den Cache abrufen
Hilfe zum PBXB64-Compiler

PREFETCHH - Daten auf der angegebenen Hinweisebene vorab in den Cache abrufen

Category: Bit Operations

Assembly Group: CACHE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PREFETCHH - Daten auf der angegebenen Hinweisebene vorab in den Cache abrufen. Diese Instruktion gehoert zur CACHE-Familie und verwendet die dokumentierten Operandenformen mem8.

Syntax

PREFETCHH mem8

Operands and Sizes

Form | Meaning
mem8 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    prefetchh [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! prefetchh [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_cache.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PREFETCHH ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PREFETCHH operand[, operand]

PBXB64-Verwendung

PREFETCHH ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PREFETCHH ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CACHE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← PMULUDQ - Multiplizieren Sie ein vorzeichenloses Doppelwort mit einem Quadwort Top PREFETCHNTA - Vorababruf in den L1-Datencache (nicht temporär, minimale Verschmutzung) →


PREFETCHNTA - Vorababruf in den L1-Datencache (nicht temporär, minimale Verschmutzung) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › PREFETCHNTA - Vorababruf in den L1-Datencache (nicht temporär, minimale Verschmutzung)
Hilfe zum PBXB64-Compiler

PREFETCHNTA - Vorababruf in den L1-Datencache (nicht temporär, minimale Verschmutzung)

Category: Bit Operations

Assembly Group: CACHE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PREFETCHNTA - Vorababruf in den L1-Datencache (nicht temporär, minimale Verschmutzung). Diese Instruktion gehoert zur CACHE-Familie und verwendet die dokumentierten Operandenformen mem8.

Syntax

PREFETCHNTA mem8

Operands and Sizes

Form | Meaning
mem8 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    prefetchnta [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! prefetchnta [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_cache.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PREFETCHNTA ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PREFETCHNTA operand[, operand]

PBXB64-Verwendung

PREFETCHNTA ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PREFETCHNTA ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CACHE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PREFETCHT0 - Vorabruf in alle Cache-Ebenen (L1, L2, L3) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › PREFETCHT0 - Vorabruf in alle Cache-Ebenen (L1, L2, L3)
Hilfe zum PBXB64-Compiler

PREFETCHT0 - Vorabruf in alle Cache-Ebenen (L1, L2, L3)

Category: Bit Operations

Assembly Group: CACHE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PREFETCHT0 - Vorabruf in alle Cache-Ebenen (L1, L2, L3). Diese Instruktion gehoert zur CACHE-Familie und verwendet die dokumentierten Operandenformen mem8.

Syntax

PREFETCHT0 mem8

Operands and Sizes

Form | Meaning
mem8 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    prefetcht0 [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! prefetcht0 [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_cache.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PREFETCHT0 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PREFETCHT0 operand[, operand]

PBXB64-Verwendung

PREFETCHT0 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PREFETCHT0 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CACHE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PREFETCHT2 - Nur in L3 vorabholen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › PREFETCHT2 - Nur in L3 vorabholen
Hilfe zum PBXB64-Compiler

PREFETCHT2 - Nur in L3 vorabholen

Category: Bit Operations

Assembly Group: CACHE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PREFETCHT2 - Nur in L3 vorabholen. Diese Instruktion gehoert zur CACHE-Familie und verwendet die dokumentierten Operandenformen mem8.

Syntax

PREFETCHT2 mem8

Operands and Sizes

Form | Meaning
mem8 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    prefetcht2 [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! prefetcht2 [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_cache.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PREFETCHT2 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PREFETCHT2 operand[, operand]

PBXB64-Verwendung

PREFETCHT2 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PREFETCHT2 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CACHE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PUSHQ - Push QWORD (impliziter 64-Bit-Push) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › PUSHQ - Push QWORD (impliziter 64-Bit-Push)
Hilfe zum PBXB64-Compiler

PUSHQ - Push QWORD (impliziter 64-Bit-Push)

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PUSHQ - Push QWORD (impliziter 64-Bit-Push). Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen imm32.

Syntax

PUSHQ imm32

Operands and Sizes

Form | Meaning
imm32 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    pushq operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pushq operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PUSHQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PUSHQ operand[, operand]

PBXB64-Verwendung

PUSHQ ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PUSHQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RCR - Nach rechts drehen durch Tragen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › RCR - Nach rechts drehen durch Tragen
Hilfe zum PBXB64-Compiler

RCR - Nach rechts drehen durch Tragen

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

RCR - Nach rechts drehen durch Tragen. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen reg/mem, imm8/CL.

Syntax

RCR reg/mem, imm8/CL

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem, imm8 | may read or write memory; uses an immediate control byte or value
CL | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    rcr eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! rcr eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

RCR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

RCR operand[, operand]

PBXB64-Verwendung

RCR ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! RCR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RDTSCP - TSC + Prozessor-ID lesen (gibt EDX:EAX, ECX=IA32_TSC_AUX zurück) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › RDTSCP - TSC + Prozessor-ID lesen (gibt EDX:EAX, ECX=IA32_TSC_AUX zurück)
Hilfe zum PBXB64-Compiler

RDTSCP - TSC + Prozessor-ID lesen (gibt EDX:EAX, ECX=IA32_TSC_AUX zurück)

Category: Bit Operations

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

RDTSCP - TSC + Prozessor-ID lesen (gibt EDX:EAX, ECX=IA32_TSC_AUX zurück). Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

RDTSCP keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    rdtscp operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! rdtscp operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

RDTSCP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

RDTSCP operand[, operand]

PBXB64-Verwendung

RDTSCP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! RDTSCP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RETF - Far Return (wird in x64 nicht verwendet) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › RETF - Far Return (wird in x64 nicht verwendet)
Hilfe zum PBXB64-Compiler

RETF - Far Return (wird in x64 nicht verwendet)

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

RETF - Far Return (wird in x64 nicht verwendet). Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen keine / imm16.

Syntax

RETF keine / imm16

Operands and Sizes

Form | Meaning
keine | follow the operand order shown in the syntax
imm16 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    retf operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! retf operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

RETF ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

RETF operand[, operand]

PBXB64-Verwendung

RETF ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! RETF ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ROL - Nach links drehen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › ROL - Nach links drehen
Hilfe zum PBXB64-Compiler

ROL - Nach links drehen

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

ROL - Nach links drehen. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen reg/mem, imm8/CL.

Syntax

ROL reg/mem, imm8/CL

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem, imm8 | may read or write memory; uses an immediate control byte or value
CL | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    rol eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! rol eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

ROL ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

ROL operand[, operand]

PBXB64-Verwendung

ROL ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! ROL ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ROR - Nach rechts drehen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › ROR - Nach rechts drehen
Hilfe zum PBXB64-Compiler

ROR - Nach rechts drehen

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

ROR - Nach rechts drehen. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen reg/mem, imm8/CL.

Syntax

ROR reg/mem, imm8/CL

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem, imm8 | may read or write memory; uses an immediate control byte or value
CL | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    ror eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! ror eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

ROR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

ROR operand[, operand]

PBXB64-Verwendung

ROR ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! ROR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SAVEPREVSSP - Speichern Sie den vorherigen Schattenstapelzeiger - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › SAVEPREVSSP - Speichern Sie den vorherigen Schattenstapelzeiger
Hilfe zum PBXB64-Compiler

SAVEPREVSSP - Speichern Sie den vorherigen Schattenstapelzeiger

Category: Bit Operations

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SAVEPREVSSP - Speichern Sie den vorherigen Schattenstapelzeiger. Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

SAVEPREVSSP keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    saveprevssp operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! saveprevssp operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SAVEPREVSSP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SAVEPREVSSP operand[, operand]

PBXB64-Verwendung

SAVEPREVSSP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SAVEPREVSSP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SGDT - Speichern Sie das globale Deskriptortabellenregister - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › SGDT - Speichern Sie das globale Deskriptortabellenregister
Hilfe zum PBXB64-Compiler

SGDT - Speichern Sie das globale Deskriptortabellenregister

Category: Bit Operations

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SGDT - Speichern Sie das globale Deskriptortabellenregister. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen mem80 (Pseudo-Deskriptor).

Syntax

SGDT mem80 (Pseudo-Deskriptor)

Operands and Sizes

Form | Meaning
mem80 (Pseudo-Deskriptor) | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    sgdt [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! sgdt [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SGDT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SGDT operand[, operand]

PBXB64-Verwendung

SGDT ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SGDT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SHLD - Doppelte Präzisionsverschiebung nach links - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › SHLD - Doppelte Präzisionsverschiebung nach links
Hilfe zum PBXB64-Compiler

SHLD - Doppelte Präzisionsverschiebung nach links

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SHLD - Doppelte Präzisionsverschiebung nach links. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen reg/mem, reg, imm8/CL.

Syntax

SHLD reg/mem, reg, imm8/CL

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem, reg, imm8 | may read or write memory; uses an immediate control byte or value; uses a general-purpose register
CL | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    shld eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! shld eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SHLD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SHLD operand[, operand]

PBXB64-Verwendung

SHLD ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SHLD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SHRD - Doppelte Präzisionsverschiebung nach rechts - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › SHRD - Doppelte Präzisionsverschiebung nach rechts
Hilfe zum PBXB64-Compiler

SHRD - Doppelte Präzisionsverschiebung nach rechts

Category: Bit Operations

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SHRD - Doppelte Präzisionsverschiebung nach rechts. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen reg/mem, reg, imm8/CL.

Syntax

SHRD reg/mem, reg, imm8/CL

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem, reg, imm8 | may read or write memory; uses an immediate control byte or value; uses a general-purpose register
CL | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    shrd eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! shrd eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SHRD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SHRD operand[, operand]

PBXB64-Verwendung

SHRD ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SHRD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SIDT - Speichern Sie das Interrupt-Deskriptortabellenregister - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › SIDT - Speichern Sie das Interrupt-Deskriptortabellenregister
Hilfe zum PBXB64-Compiler

SIDT - Speichern Sie das Interrupt-Deskriptortabellenregister

Category: Bit Operations

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SIDT - Speichern Sie das Interrupt-Deskriptortabellenregister. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen mem80.

Syntax

SIDT mem80

Operands and Sizes

Form | Meaning
mem80 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    sidt [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! sidt [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SIDT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SIDT operand[, operand]

PBXB64-Verwendung

SIDT ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SIDT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SLDT - Lokales Deskriptortabellenregister speichern - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › SLDT - Lokales Deskriptortabellenregister speichern
Hilfe zum PBXB64-Compiler

SLDT - Lokales Deskriptortabellenregister speichern

Category: Bit Operations

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SLDT - Lokales Deskriptortabellenregister speichern. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen reg/mem16/64.

Syntax

SLDT reg/mem16/64

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem16 | may read or write memory
64 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    sldt eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! sldt eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SLDT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SLDT operand[, operand]

PBXB64-Verwendung

SLDT ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SLDT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SMSW - Speichern Sie das Maschinenstatuswort (CR0, niedrige 16 Bits) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › SMSW - Speichern Sie das Maschinenstatuswort (CR0, niedrige 16 Bits)
Hilfe zum PBXB64-Compiler

SMSW - Speichern Sie das Maschinenstatuswort (CR0, niedrige 16 Bits)

Category: Bit Operations

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SMSW - Speichern Sie das Maschinenstatuswort (CR0, niedrige 16 Bits). Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen reg/mem16/64.

Syntax

SMSW reg/mem16/64

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem16 | may read or write memory
64 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    smsw eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! smsw eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SMSW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SMSW operand[, operand]

PBXB64-Verwendung

SMSW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SMSW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UD1 - Undefinierte Anweisung (Formular mit zwei Operanden) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › UD1 - Undefinierte Anweisung (Formular mit zwei Operanden)
Hilfe zum PBXB64-Compiler

UD1 - Undefinierte Anweisung (Formular mit zwei Operanden)

Category: Bit Operations

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

UD1 - Undefinierte Anweisung (Formular mit zwei Operanden). Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen reg, reg/mem.

Syntax

UD1 reg, reg/mem

Operands and Sizes

Form | Meaning
reg, reg | uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    ud1 eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! ud1 eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

UD1 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

UD1 operand[, operand]

PBXB64-Verwendung

UD1 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! UD1 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UMONITOR - MONITOR auf Benutzerebene - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › UMONITOR - MONITOR auf Benutzerebene
Hilfe zum PBXB64-Compiler

UMONITOR - MONITOR auf Benutzerebene

Category: Bit Operations

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

UMONITOR - MONITOR auf Benutzerebene. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen reg.

Syntax

UMONITOR reg

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    umonitor eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! umonitor eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

UMONITOR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

UMONITOR operand[, operand]

PBXB64-Verwendung

UMONITOR ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! UMONITOR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VALIGND - Dwords ausrichten (verketten und verschieben) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VALIGND - Dwords ausrichten (verketten und verschieben)
Hilfe zum PBXB64-Compiler

VALIGND - Dwords ausrichten (verketten und verschieben)

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VALIGND - Dwords ausrichten (verketten und verschieben). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem, imm8.

Syntax

VALIGND zmm, zmm, zmm/mem, imm8

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    valignd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! valignd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VALIGND ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VALIGND operand[, operand]

PBXB64-Verwendung

VALIGND ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VALIGND ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VALIGNQ - Qwords ausrichten (verketten und verschieben) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VALIGNQ - Qwords ausrichten (verketten und verschieben)
Hilfe zum PBXB64-Compiler

VALIGNQ - Qwords ausrichten (verketten und verschieben)

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VALIGNQ - Qwords ausrichten (verketten und verschieben). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem, imm8.

Syntax

VALIGNQ zmm, zmm, zmm/mem, imm8

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    valignq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! valignq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VALIGNQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VALIGNQ operand[, operand]

PBXB64-Verwendung

VALIGNQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VALIGNQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFIXUPIMMSD - Skalar-Double reparieren (NaN-Handhabung) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VFIXUPIMMSD - Skalar-Double reparieren (NaN-Handhabung)
Hilfe zum PBXB64-Compiler

VFIXUPIMMSD - Skalar-Double reparieren (NaN-Handhabung)

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFIXUPIMMSD - Skalar-Double reparieren (NaN-Handhabung). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/mem, imm8.

Syntax

VFIXUPIMMSD xmm, xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfixupimmsd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfixupimmsd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFIXUPIMMSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFIXUPIMMSD operand[, operand]

PBXB64-Verwendung

VFIXUPIMMSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFIXUPIMMSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFIXUPIMMSS - Skalar-Single reparieren (NaN-Handhabung) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VFIXUPIMMSS - Skalar-Single reparieren (NaN-Handhabung)
Hilfe zum PBXB64-Compiler

VFIXUPIMMSS - Skalar-Single reparieren (NaN-Handhabung)

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFIXUPIMMSS - Skalar-Single reparieren (NaN-Handhabung). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/mem, imm8.

Syntax

VFIXUPIMMSS xmm, xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfixupimmss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfixupimmss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFIXUPIMMSS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFIXUPIMMSS operand[, operand]

PBXB64-Verwendung

VFIXUPIMMSS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFIXUPIMMSS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VGATHERDPD - Gather double with dword indices - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VGATHERDPD - Gather double with dword indices
Hilfe zum PBXB64-Compiler

VGATHERDPD - Gather double with dword indices

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VGATHERDPD - Gather double with dword indices. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, mem, ymm/xmm.

Syntax

VGATHERDPD ymm/xmm, mem, ymm/xmm

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, mem, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vgatherdpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vgatherdpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VGATHERDPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VGATHERDPD operand[, operand]

PBXB64-Verwendung

VGATHERDPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VGATHERDPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VGATHERDPS - Gather single with dword indices - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VGATHERDPS - Gather single with dword indices
Hilfe zum PBXB64-Compiler

VGATHERDPS - Gather single with dword indices

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VGATHERDPS - Gather single with dword indices. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, mem, ymm/xmm.

Syntax

VGATHERDPS ymm/xmm, mem, ymm/xmm

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, mem, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vgatherdps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vgatherdps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VGATHERDPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VGATHERDPS operand[, operand]

PBXB64-Verwendung

VGATHERDPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VGATHERDPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VGATHERQPD - Gather double with qword indices - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VGATHERQPD - Gather double with qword indices
Hilfe zum PBXB64-Compiler

VGATHERQPD - Gather double with qword indices

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VGATHERQPD - Gather double with qword indices. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, mem, ymm/xmm.

Syntax

VGATHERQPD ymm/xmm, mem, ymm/xmm

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, mem, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vgatherqpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vgatherqpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VGATHERQPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VGATHERQPD operand[, operand]

PBXB64-Verwendung

VGATHERQPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VGATHERQPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VGATHERQPS - Gather single with qword indices - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VGATHERQPS - Gather single with qword indices
Hilfe zum PBXB64-Compiler

VGATHERQPS - Gather single with qword indices

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VGATHERQPS - Gather single with qword indices. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, mem, ymm/xmm.

Syntax

VGATHERQPS ymm/xmm, mem, ymm/xmm

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, mem, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vgatherqps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vgatherqps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VGATHERQPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VGATHERQPS operand[, operand]

PBXB64-Verwendung

VGATHERQPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VGATHERQPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VGETMANTPD - Extrahieren Sie die normalisierte Mantisse aus dem Doppelten - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VGETMANTPD - Extrahieren Sie die normalisierte Mantisse aus dem Doppelten
Hilfe zum PBXB64-Compiler

VGETMANTPD - Extrahieren Sie die normalisierte Mantisse aus dem Doppelten

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VGETMANTPD - Extrahieren Sie die normalisierte Mantisse aus dem Doppelten. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem, imm8.

Syntax

VGETMANTPD zmm, zmm/mem, imm8

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vgetmantpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vgetmantpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VGETMANTPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VGETMANTPD operand[, operand]

PBXB64-Verwendung

VGETMANTPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VGETMANTPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VGETMANTPS - Extrahieren Sie die normalisierte Mantisse aus einer einzelnen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VGETMANTPS - Extrahieren Sie die normalisierte Mantisse aus einer einzelnen
Hilfe zum PBXB64-Compiler

VGETMANTPS - Extrahieren Sie die normalisierte Mantisse aus einer einzelnen

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VGETMANTPS - Extrahieren Sie die normalisierte Mantisse aus einer einzelnen. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem, imm8.

Syntax

VGETMANTPS zmm, zmm/mem, imm8

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vgetmantps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vgetmantps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VGETMANTPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VGETMANTPS operand[, operand]

PBXB64-Verwendung

VGETMANTPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VGETMANTPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← VGETMANTPD - Extrahieren Sie die normalisierte Mantisse aus dem Doppelten Top VGETMANTSD - Extrahieren Sie das normalisierte Mantissen-Skalar-Double →


VGETMANTSD - Extrahieren Sie das normalisierte Mantissen-Skalar-Double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VGETMANTSD - Extrahieren Sie das normalisierte Mantissen-Skalar-Double
Hilfe zum PBXB64-Compiler

VGETMANTSD - Extrahieren Sie das normalisierte Mantissen-Skalar-Double

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VGETMANTSD - Extrahieren Sie das normalisierte Mantissen-Skalar-Double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/mem, imm8.

Syntax

VGETMANTSD xmm, xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vgetmantsd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vgetmantsd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VGETMANTSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VGETMANTSD operand[, operand]

PBXB64-Verwendung

VGETMANTSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VGETMANTSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← VGETMANTPS - Extrahieren Sie die normalisierte Mantisse aus einer einzelnen Top VGETMANTSS - Extrahieren Sie den normalisierten Mantissenskalar einzeln →


VGETMANTSS - Extrahieren Sie den normalisierten Mantissenskalar einzeln - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VGETMANTSS - Extrahieren Sie den normalisierten Mantissenskalar einzeln
Hilfe zum PBXB64-Compiler

VGETMANTSS - Extrahieren Sie den normalisierten Mantissenskalar einzeln

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VGETMANTSS - Extrahieren Sie den normalisierten Mantissenskalar einzeln. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/mem, imm8.

Syntax

VGETMANTSS xmm, xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vgetmantss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vgetmantss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VGETMANTSS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VGETMANTSS operand[, operand]

PBXB64-Verwendung

VGETMANTSS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VGETMANTSS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VGF2P8AFFINEINVQB - Galois-Feld-Affintransformation invers - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VGF2P8AFFINEINVQB - Galois-Feld-Affintransformation invers
Hilfe zum PBXB64-Compiler

VGF2P8AFFINEINVQB - Galois-Feld-Affintransformation invers

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VGF2P8AFFINEINVQB - Galois-Feld-Affintransformation invers. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm/xmm, zmm/xmm, zmm/mem, imm8.

Syntax

VGF2P8AFFINEINVQB zmm/xmm, zmm/xmm, zmm/mem, imm8

Operands and Sizes

Form | Meaning
zmm | may read or write memory
xmm, zmm | uses XMM vector/scalar registers; may read or write memory
xmm, zmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vgf2p8affineinvqb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vgf2p8affineinvqb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VGF2P8AFFINEINVQB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VGF2P8AFFINEINVQB operand[, operand]

PBXB64-Verwendung

VGF2P8AFFINEINVQB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VGF2P8AFFINEINVQB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VGF2P8AFFINEQB - Galoisfeldaffine Transformation - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VGF2P8AFFINEQB - Galoisfeldaffine Transformation
Hilfe zum PBXB64-Compiler

VGF2P8AFFINEQB - Galoisfeldaffine Transformation

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VGF2P8AFFINEQB - Galoisfeldaffine Transformation. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm/xmm, zmm/xmm, zmm/mem, imm8.

Syntax

VGF2P8AFFINEQB zmm/xmm, zmm/xmm, zmm/mem, imm8

Operands and Sizes

Form | Meaning
zmm | may read or write memory
xmm, zmm | uses XMM vector/scalar registers; may read or write memory
xmm, zmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vgf2p8affineqb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vgf2p8affineqb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VGF2P8AFFINEQB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VGF2P8AFFINEQB operand[, operand]

PBXB64-Verwendung

VGF2P8AFFINEQB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VGF2P8AFFINEQB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVNTDQ - VEX nicht-temporaler 128/256-Bit-Speicher (AVX) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VMOVNTDQ - VEX nicht-temporaler 128/256-Bit-Speicher (AVX)
Hilfe zum PBXB64-Compiler

VMOVNTDQ - VEX nicht-temporaler 128/256-Bit-Speicher (AVX)

Category: Bit Operations

Assembly Group: CACHE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVNTDQ - VEX nicht-temporaler 128/256-Bit-Speicher (AVX). Diese Instruktion gehoert zur CACHE-Familie und verwendet die dokumentierten Operandenformen mem, ymm/xmm.

Syntax

VMOVNTDQ mem, ymm/xmm

Operands and Sizes

Form | Meaning
mem, ymm | uses YMM vector registers; may read or write memory
xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovntdq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovntdq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_cache.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVNTDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVNTDQ operand[, operand]

PBXB64-Verwendung

VMOVNTDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVNTDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CACHE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVNTPS - VEX nicht-temporärer Einzelspeicher (AVX) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VMOVNTPS - VEX nicht-temporärer Einzelspeicher (AVX)
Hilfe zum PBXB64-Compiler

VMOVNTPS - VEX nicht-temporärer Einzelspeicher (AVX)

Category: Bit Operations

Assembly Group: CACHE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVNTPS - VEX nicht-temporärer Einzelspeicher (AVX). Diese Instruktion gehoert zur CACHE-Familie und verwendet die dokumentierten Operandenformen mem, ymm/xmm.

Syntax

VMOVNTPS mem, ymm/xmm

Operands and Sizes

Form | Meaning
mem, ymm | uses YMM vector registers; may read or write memory
xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovntps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovntps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_cache.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVNTPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVNTPS operand[, operand]

PBXB64-Verwendung

VMOVNTPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVNTPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CACHE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMXOFF - Beenden Sie den VMX-Vorgang - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VMXOFF - Beenden Sie den VMX-Vorgang
Hilfe zum PBXB64-Compiler

VMXOFF - Beenden Sie den VMX-Vorgang

Category: Bit Operations

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMXOFF - Beenden Sie den VMX-Vorgang. Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

VMXOFF keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmxoff ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmxoff ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMXOFF ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMXOFF operand[, operand]

PBXB64-Verwendung

VMXOFF ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMXOFF ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMXON - Geben Sie den VMX-Vorgang ein - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VMXON - Geben Sie den VMX-Vorgang ein
Hilfe zum PBXB64-Compiler

VMXON - Geben Sie den VMX-Vorgang ein

Category: Bit Operations

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMXON - Geben Sie den VMX-Vorgang ein. Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen mem64 (VMXON-Region ptr).

Syntax

VMXON mem64 (VMXON-Region ptr)

Operands and Sizes

Form | Meaning
mem64 (VMXON-Region ptr) | may read or write memory; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmxon ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmxon ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMXON ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMXON operand[, operand]

PBXB64-Verwendung

VMXON ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMXON ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPABSD - Absolute value of dwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPABSD - Absolute value of dwords
Hilfe zum PBXB64-Compiler

VPABSD - Absolute value of dwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPABSD - Absolute value of dwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/mem.

Syntax

VPABSD ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpabsd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpabsd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPABSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPABSD operand[, operand]

PBXB64-Verwendung

VPABSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPABSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPABSQ - Absoluter Wert von qwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPABSQ - Absoluter Wert von qwords
Hilfe zum PBXB64-Compiler

VPABSQ - Absoluter Wert von qwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPABSQ - Absoluter Wert von qwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VPABSQ zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpabsq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpabsq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPABSQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPABSQ operand[, operand]

PBXB64-Verwendung

VPABSQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPABSQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPABSW - Absolute value of words - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPABSW - Absolute value of words
Hilfe zum PBXB64-Compiler

VPABSW - Absolute value of words

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPABSW - Absolute value of words. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/mem.

Syntax

VPABSW ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpabsw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpabsw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPABSW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPABSW operand[, operand]

PBXB64-Verwendung

VPABSW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPABSW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPAND - Bitwise AND - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPAND - Bitwise AND
Hilfe zum PBXB64-Compiler

VPAND - Bitwise AND

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPAND - Bitwise AND. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPAND ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpand ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpand ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPAND ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPAND operand[, operand]

PBXB64-Verwendung

VPAND ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPAND ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPANDN - Bitwise AND-NOT - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPANDN - Bitwise AND-NOT
Hilfe zum PBXB64-Compiler

VPANDN - Bitwise AND-NOT

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPANDN - Bitwise AND-NOT. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPANDN ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpandn ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpandn ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPANDN ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPANDN operand[, operand]

PBXB64-Verwendung

VPANDN ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPANDN ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPANDQ - Bitweises UND von qwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPANDQ - Bitweises UND von qwords
Hilfe zum PBXB64-Compiler

VPANDQ - Bitweises UND von qwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPANDQ - Bitweises UND von qwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPANDQ zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpandq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpandq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPANDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPANDQ operand[, operand]

PBXB64-Verwendung

VPANDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPANDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPCONFLICTD - Erkennen Sie Konflikte im Dword-Vektor - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPCONFLICTD - Erkennen Sie Konflikte im Dword-Vektor
Hilfe zum PBXB64-Compiler

VPCONFLICTD - Erkennen Sie Konflikte im Dword-Vektor

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPCONFLICTD - Erkennen Sie Konflikte im Dword-Vektor. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VPCONFLICTD zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpconflictd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpconflictd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPCONFLICTD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPCONFLICTD operand[, operand]

PBXB64-Verwendung

VPCONFLICTD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPCONFLICTD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPCONFLICTQ - Erkennen Sie Konflikte im Qword-Vektor - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPCONFLICTQ - Erkennen Sie Konflikte im Qword-Vektor
Hilfe zum PBXB64-Compiler

VPCONFLICTQ - Erkennen Sie Konflikte im Qword-Vektor

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPCONFLICTQ - Erkennen Sie Konflikte im Qword-Vektor. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VPCONFLICTQ zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpconflictq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpconflictq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPCONFLICTQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPCONFLICTQ operand[, operand]

PBXB64-Verwendung

VPCONFLICTQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPCONFLICTQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPGATHERDD - Gather dwords with dword indices - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPGATHERDD - Gather dwords with dword indices
Hilfe zum PBXB64-Compiler

VPGATHERDD - Gather dwords with dword indices

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPGATHERDD - Gather dwords with dword indices. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, mem, ymm/xmm.

Syntax

VPGATHERDD ymm/xmm, mem, ymm/xmm

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, mem, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpgatherdd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpgatherdd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPGATHERDD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPGATHERDD operand[, operand]

PBXB64-Verwendung

VPGATHERDD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPGATHERDD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPGATHERDQ - Gather dwords with qword indices - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPGATHERDQ - Gather dwords with qword indices
Hilfe zum PBXB64-Compiler

VPGATHERDQ - Gather dwords with qword indices

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPGATHERDQ - Gather dwords with qword indices. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, mem, ymm/xmm.

Syntax

VPGATHERDQ ymm/xmm, mem, ymm/xmm

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, mem, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpgatherdq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpgatherdq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPGATHERDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPGATHERDQ operand[, operand]

PBXB64-Verwendung

VPGATHERDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPGATHERDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPGATHERQD - Gather qwords with dword indices - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPGATHERQD - Gather qwords with dword indices
Hilfe zum PBXB64-Compiler

VPGATHERQD - Gather qwords with dword indices

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPGATHERQD - Gather qwords with dword indices. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, mem, ymm/xmm.

Syntax

VPGATHERQD ymm/xmm, mem, ymm/xmm

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, mem, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpgatherqd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpgatherqd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPGATHERQD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPGATHERQD operand[, operand]

PBXB64-Verwendung

VPGATHERQD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPGATHERQD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPGATHERQQ - Gather qwords with qword indices - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPGATHERQQ - Gather qwords with qword indices
Hilfe zum PBXB64-Compiler

VPGATHERQQ - Gather qwords with qword indices

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPGATHERQQ - Gather qwords with qword indices. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, mem, ymm/xmm.

Syntax

VPGATHERQQ ymm/xmm, mem, ymm/xmm

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, mem, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpgatherqq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpgatherqq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPGATHERQQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPGATHERQQ operand[, operand]

PBXB64-Verwendung

VPGATHERQQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPGATHERQQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPLZCNTD - Zählen Sie führende Nullen im Dword-Vektor - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPLZCNTD - Zählen Sie führende Nullen im Dword-Vektor
Hilfe zum PBXB64-Compiler

VPLZCNTD - Zählen Sie führende Nullen im Dword-Vektor

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPLZCNTD - Zählen Sie führende Nullen im Dword-Vektor. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VPLZCNTD zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vplzcntd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vplzcntd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPLZCNTD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPLZCNTD operand[, operand]

PBXB64-Verwendung

VPLZCNTD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPLZCNTD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPLZCNTQ - Zählen Sie führende Nullen im Qword-Vektor - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPLZCNTQ - Zählen Sie führende Nullen im Qword-Vektor
Hilfe zum PBXB64-Compiler

VPLZCNTQ - Zählen Sie führende Nullen im Qword-Vektor

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPLZCNTQ - Zählen Sie führende Nullen im Qword-Vektor. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VPLZCNTQ zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vplzcntq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vplzcntq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPLZCNTQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPLZCNTQ operand[, operand]

PBXB64-Verwendung

VPLZCNTQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPLZCNTQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMAXSQ - Maximal vorzeichenbehaftete Qwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPMAXSQ - Maximal vorzeichenbehaftete Qwords
Hilfe zum PBXB64-Compiler

VPMAXSQ - Maximal vorzeichenbehaftete Qwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMAXSQ - Maximal vorzeichenbehaftete Qwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPMAXSQ zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmaxsq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmaxsq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMAXSQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMAXSQ operand[, operand]

PBXB64-Verwendung

VPMAXSQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMAXSQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMAXUQ - Maximal vorzeichenlose Qwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPMAXUQ - Maximal vorzeichenlose Qwords
Hilfe zum PBXB64-Compiler

VPMAXUQ - Maximal vorzeichenlose Qwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMAXUQ - Maximal vorzeichenlose Qwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPMAXUQ zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmaxuq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmaxuq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMAXUQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMAXUQ operand[, operand]

PBXB64-Verwendung

VPMAXUQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMAXUQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMINSQ - Mindestens signierte Qwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPMINSQ - Mindestens signierte Qwords
Hilfe zum PBXB64-Compiler

VPMINSQ - Mindestens signierte Qwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMINSQ - Mindestens signierte Qwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPMINSQ zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpminsq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpminsq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMINSQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMINSQ operand[, operand]

PBXB64-Verwendung

VPMINSQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMINSQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMINUQ - Mindestens vorzeichenlose Qwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPMINUQ - Mindestens vorzeichenlose Qwords
Hilfe zum PBXB64-Compiler

VPMINUQ - Mindestens vorzeichenlose Qwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMINUQ - Mindestens vorzeichenlose Qwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPMINUQ zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpminuq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpminuq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMINUQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMINUQ operand[, operand]

PBXB64-Verwendung

VPMINUQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMINUQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVSXBD - Sign-extend bytes to dwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPMOVSXBD - Sign-extend bytes to dwords
Hilfe zum PBXB64-Compiler

VPMOVSXBD - Sign-extend bytes to dwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVSXBD - Sign-extend bytes to dwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, xmm/mem.

Syntax

VPMOVSXBD ymm/xmm, xmm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovsxbd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovsxbd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVSXBD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVSXBD operand[, operand]

PBXB64-Verwendung

VPMOVSXBD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVSXBD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVSXBQ - Sign-extend bytes to qwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPMOVSXBQ - Sign-extend bytes to qwords
Hilfe zum PBXB64-Compiler

VPMOVSXBQ - Sign-extend bytes to qwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVSXBQ - Sign-extend bytes to qwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, xmm/mem.

Syntax

VPMOVSXBQ ymm/xmm, xmm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovsxbq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovsxbq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVSXBQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVSXBQ operand[, operand]

PBXB64-Verwendung

VPMOVSXBQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVSXBQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVSXBW - Sign-extend bytes to words - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPMOVSXBW - Sign-extend bytes to words
Hilfe zum PBXB64-Compiler

VPMOVSXBW - Sign-extend bytes to words

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVSXBW - Sign-extend bytes to words. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, xmm/mem.

Syntax

VPMOVSXBW ymm/xmm, xmm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovsxbw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovsxbw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVSXBW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVSXBW operand[, operand]

PBXB64-Verwendung

VPMOVSXBW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVSXBW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVSXDQ - Sign-extend dwords to qwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPMOVSXDQ - Sign-extend dwords to qwords
Hilfe zum PBXB64-Compiler

VPMOVSXDQ - Sign-extend dwords to qwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVSXDQ - Sign-extend dwords to qwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, xmm/mem.

Syntax

VPMOVSXDQ ymm/xmm, xmm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovsxdq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovsxdq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVSXDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVSXDQ operand[, operand]

PBXB64-Verwendung

VPMOVSXDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVSXDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVSXWD - Sign-extend words to dwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPMOVSXWD - Sign-extend words to dwords
Hilfe zum PBXB64-Compiler

VPMOVSXWD - Sign-extend words to dwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVSXWD - Sign-extend words to dwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, xmm/mem.

Syntax

VPMOVSXWD ymm/xmm, xmm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovsxwd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovsxwd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVSXWD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVSXWD operand[, operand]

PBXB64-Verwendung

VPMOVSXWD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVSXWD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVSXWQ - Sign-extend words to qwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPMOVSXWQ - Sign-extend words to qwords
Hilfe zum PBXB64-Compiler

VPMOVSXWQ - Sign-extend words to qwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVSXWQ - Sign-extend words to qwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, xmm/mem.

Syntax

VPMOVSXWQ ymm/xmm, xmm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovsxwq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovsxwq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVSXWQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVSXWQ operand[, operand]

PBXB64-Verwendung

VPMOVSXWQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVSXWQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVZXBD - Zero-extend bytes to dwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPMOVZXBD - Zero-extend bytes to dwords
Hilfe zum PBXB64-Compiler

VPMOVZXBD - Zero-extend bytes to dwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVZXBD - Zero-extend bytes to dwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, xmm/mem.

Syntax

VPMOVZXBD ymm/xmm, xmm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovzxbd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovzxbd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVZXBD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVZXBD operand[, operand]

PBXB64-Verwendung

VPMOVZXBD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVZXBD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVZXBQ - Zero-extend bytes to qwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPMOVZXBQ - Zero-extend bytes to qwords
Hilfe zum PBXB64-Compiler

VPMOVZXBQ - Zero-extend bytes to qwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVZXBQ - Zero-extend bytes to qwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, xmm/mem.

Syntax

VPMOVZXBQ ymm/xmm, xmm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovzxbq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovzxbq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVZXBQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVZXBQ operand[, operand]

PBXB64-Verwendung

VPMOVZXBQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVZXBQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVZXBW - Zero-extend bytes to words - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPMOVZXBW - Zero-extend bytes to words
Hilfe zum PBXB64-Compiler

VPMOVZXBW - Zero-extend bytes to words

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVZXBW - Zero-extend bytes to words. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, xmm/mem.

Syntax

VPMOVZXBW ymm/xmm, xmm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovzxbw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovzxbw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVZXBW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVZXBW operand[, operand]

PBXB64-Verwendung

VPMOVZXBW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVZXBW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVZXDQ - Zero-extend dwords to qwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPMOVZXDQ - Zero-extend dwords to qwords
Hilfe zum PBXB64-Compiler

VPMOVZXDQ - Zero-extend dwords to qwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVZXDQ - Zero-extend dwords to qwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, xmm/mem.

Syntax

VPMOVZXDQ ymm/xmm, xmm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovzxdq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovzxdq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVZXDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVZXDQ operand[, operand]

PBXB64-Verwendung

VPMOVZXDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVZXDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVZXWD - Zero-extend words to dwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPMOVZXWD - Zero-extend words to dwords
Hilfe zum PBXB64-Compiler

VPMOVZXWD - Zero-extend words to dwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVZXWD - Zero-extend words to dwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, xmm/mem.

Syntax

VPMOVZXWD ymm/xmm, xmm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovzxwd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovzxwd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVZXWD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVZXWD operand[, operand]

PBXB64-Verwendung

VPMOVZXWD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVZXWD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVZXWQ - Zero-extend words to qwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPMOVZXWQ - Zero-extend words to qwords
Hilfe zum PBXB64-Compiler

VPMOVZXWQ - Zero-extend words to qwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVZXWQ - Zero-extend words to qwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, xmm/mem.

Syntax

VPMOVZXWQ ymm/xmm, xmm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovzxwq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovzxwq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVZXWQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVZXWQ operand[, operand]

PBXB64-Verwendung

VPMOVZXWQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVZXWQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMULTISHIFTQB - Mehrfaches Verschieben und Verketten von Qwords zu Bytes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPMULTISHIFTQB - Mehrfaches Verschieben und Verketten von Qwords zu Bytes
Hilfe zum PBXB64-Compiler

VPMULTISHIFTQB - Mehrfaches Verschieben und Verketten von Qwords zu Bytes

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMULTISHIFTQB - Mehrfaches Verschieben und Verketten von Qwords zu Bytes. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPMULTISHIFTQB zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmultishiftqb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmultishiftqb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMULTISHIFTQB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMULTISHIFTQB operand[, operand]

PBXB64-Verwendung

VPMULTISHIFTQB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMULTISHIFTQB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPOPCNTB - Populationsanzahl der Bytes (Vektor) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPOPCNTB - Populationsanzahl der Bytes (Vektor)
Hilfe zum PBXB64-Compiler

VPOPCNTB - Populationsanzahl der Bytes (Vektor)

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPOPCNTB - Populationsanzahl der Bytes (Vektor). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VPOPCNTB zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpopcntb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpopcntb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPOPCNTB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPOPCNTB operand[, operand]

PBXB64-Verwendung

VPOPCNTB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPOPCNTB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPOPCNTD - Bevölkerungszahl von Dwords (Vektor) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPOPCNTD - Bevölkerungszahl von Dwords (Vektor)
Hilfe zum PBXB64-Compiler

VPOPCNTD - Bevölkerungszahl von Dwords (Vektor)

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPOPCNTD - Bevölkerungszahl von Dwords (Vektor). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VPOPCNTD zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpopcntd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpopcntd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPOPCNTD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPOPCNTD operand[, operand]

PBXB64-Verwendung

VPOPCNTD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPOPCNTD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPOPCNTQ - Bevölkerungszahl von qwords (Vektor) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPOPCNTQ - Bevölkerungszahl von qwords (Vektor)
Hilfe zum PBXB64-Compiler

VPOPCNTQ - Bevölkerungszahl von qwords (Vektor)

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPOPCNTQ - Bevölkerungszahl von qwords (Vektor). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VPOPCNTQ zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpopcntq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpopcntq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPOPCNTQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPOPCNTQ operand[, operand]

PBXB64-Verwendung

VPOPCNTQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPOPCNTQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPOPCNTW - Bevölkerungszahl von Wörtern (Vektor) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPOPCNTW - Bevölkerungszahl von Wörtern (Vektor)
Hilfe zum PBXB64-Compiler

VPOPCNTW - Bevölkerungszahl von Wörtern (Vektor)

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPOPCNTW - Bevölkerungszahl von Wörtern (Vektor). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VPOPCNTW zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpopcntw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpopcntw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPOPCNTW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPOPCNTW operand[, operand]

PBXB64-Verwendung

VPOPCNTW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPOPCNTW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPOR - Bitwise OR - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPOR - Bitwise OR
Hilfe zum PBXB64-Compiler

VPOR - Bitwise OR

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPOR - Bitwise OR. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPOR ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpor ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpor ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPOR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPOR operand[, operand]

PBXB64-Verwendung

VPOR ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPOR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPORQ - Bitweises ODER von qwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPORQ - Bitweises ODER von qwords
Hilfe zum PBXB64-Compiler

VPORQ - Bitweises ODER von qwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPORQ - Bitweises ODER von qwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPORQ zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vporq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vporq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPORQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPORQ operand[, operand]

PBXB64-Verwendung

VPORQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPORQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSIGND - Sign of dwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPSIGND - Sign of dwords
Hilfe zum PBXB64-Compiler

VPSIGND - Sign of dwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSIGND - Sign of dwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPSIGND ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsignd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsignd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSIGND ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSIGND operand[, operand]

PBXB64-Verwendung

VPSIGND ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSIGND ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSIGNW - Sign of words - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPSIGNW - Sign of words
Hilfe zum PBXB64-Compiler

VPSIGNW - Sign of words

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSIGNW - Sign of words. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPSIGNW ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsignw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsignw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSIGNW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSIGNW operand[, operand]

PBXB64-Verwendung

VPSIGNW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSIGNW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSLLD - Shift left logical doublewords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPSLLD - Shift left logical doublewords
Hilfe zum PBXB64-Compiler

VPSLLD - Shift left logical doublewords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSLLD - Shift left logical doublewords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, xmm/mem, imm8.

Syntax

VPSLLD ymm/xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpslld ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpslld ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSLLD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSLLD operand[, operand]

PBXB64-Verwendung

VPSLLD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSLLD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


VPSLLQ - Shift left logical quadwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPSLLQ - Shift left logical quadwords
Hilfe zum PBXB64-Compiler

VPSLLQ - Shift left logical quadwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSLLQ - Shift left logical quadwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, xmm/mem, imm8.

Syntax

VPSLLQ ymm/xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsllq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsllq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSLLQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSLLQ operand[, operand]

PBXB64-Verwendung

VPSLLQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSLLQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


VPSLLVD - Variable shift left logical dwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPSLLVD - Variable shift left logical dwords
Hilfe zum PBXB64-Compiler

VPSLLVD - Variable shift left logical dwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSLLVD - Variable shift left logical dwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPSLLVD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsllvd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsllvd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSLLVD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSLLVD operand[, operand]

PBXB64-Verwendung

VPSLLVD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSLLVD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


VPSLLVDQ - Variable logisches Dword/Qword nach links verschieben - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPSLLVDQ - Variable logisches Dword/Qword nach links verschieben
Hilfe zum PBXB64-Compiler

VPSLLVDQ - Variable logisches Dword/Qword nach links verschieben

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSLLVDQ - Variable logisches Dword/Qword nach links verschieben. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPSLLVDQ zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsllvdq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsllvdq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSLLVDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSLLVDQ operand[, operand]

PBXB64-Verwendung

VPSLLVDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSLLVDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


VPSLLVQ - Variable shift left logical qwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPSLLVQ - Variable shift left logical qwords
Hilfe zum PBXB64-Compiler

VPSLLVQ - Variable shift left logical qwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSLLVQ - Variable shift left logical qwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPSLLVQ ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsllvq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsllvq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSLLVQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSLLVQ operand[, operand]

PBXB64-Verwendung

VPSLLVQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSLLVQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


VPSLLW - Shift left logical words - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPSLLW - Shift left logical words
Hilfe zum PBXB64-Compiler

VPSLLW - Shift left logical words

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSLLW - Shift left logical words. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, xmm/mem, imm8.

Syntax

VPSLLW ymm/xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsllw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsllw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSLLW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSLLW operand[, operand]

PBXB64-Verwendung

VPSLLW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSLLW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


VPSRAD - Shift right arithmetic doublewords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPSRAD - Shift right arithmetic doublewords
Hilfe zum PBXB64-Compiler

VPSRAD - Shift right arithmetic doublewords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSRAD - Shift right arithmetic doublewords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, xmm/mem, imm8.

Syntax

VPSRAD ymm/xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsrad ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsrad ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSRAD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSRAD operand[, operand]

PBXB64-Verwendung

VPSRAD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSRAD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSRAVD - Variable shift right arith dwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPSRAVD - Variable shift right arith dwords
Hilfe zum PBXB64-Compiler

VPSRAVD - Variable shift right arith dwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSRAVD - Variable shift right arith dwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPSRAVD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsravd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsravd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSRAVD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSRAVD operand[, operand]

PBXB64-Verwendung

VPSRAVD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSRAVD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSRAVQ - Variable arithmetische Qwords nach rechts verschieben - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPSRAVQ - Variable arithmetische Qwords nach rechts verschieben
Hilfe zum PBXB64-Compiler

VPSRAVQ - Variable arithmetische Qwords nach rechts verschieben

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSRAVQ - Variable arithmetische Qwords nach rechts verschieben. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPSRAVQ zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsravq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsravq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSRAVQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSRAVQ operand[, operand]

PBXB64-Verwendung

VPSRAVQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSRAVQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSRAW - Shift right arithmetic words - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPSRAW - Shift right arithmetic words
Hilfe zum PBXB64-Compiler

VPSRAW - Shift right arithmetic words

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSRAW - Shift right arithmetic words. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, xmm/mem, imm8.

Syntax

VPSRAW ymm/xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsraw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsraw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSRAW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSRAW operand[, operand]

PBXB64-Verwendung

VPSRAW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSRAW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSRLD - Shift right logical doublewords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPSRLD - Shift right logical doublewords
Hilfe zum PBXB64-Compiler

VPSRLD - Shift right logical doublewords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSRLD - Shift right logical doublewords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, xmm/mem, imm8.

Syntax

VPSRLD ymm/xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsrld ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsrld ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSRLD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSRLD operand[, operand]

PBXB64-Verwendung

VPSRLD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSRLD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSRLQ - Shift right logical quadwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPSRLQ - Shift right logical quadwords
Hilfe zum PBXB64-Compiler

VPSRLQ - Shift right logical quadwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSRLQ - Shift right logical quadwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, xmm/mem, imm8.

Syntax

VPSRLQ ymm/xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsrlq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsrlq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSRLQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSRLQ operand[, operand]

PBXB64-Verwendung

VPSRLQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSRLQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSRLVD - Variable shift right logical dwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPSRLVD - Variable shift right logical dwords
Hilfe zum PBXB64-Compiler

VPSRLVD - Variable shift right logical dwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSRLVD - Variable shift right logical dwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPSRLVD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsrlvd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsrlvd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSRLVD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSRLVD operand[, operand]

PBXB64-Verwendung

VPSRLVD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSRLVD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSRLVDQ - Variables logisches Dword/Qword nach rechts verschieben - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPSRLVDQ - Variables logisches Dword/Qword nach rechts verschieben
Hilfe zum PBXB64-Compiler

VPSRLVDQ - Variables logisches Dword/Qword nach rechts verschieben

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSRLVDQ - Variables logisches Dword/Qword nach rechts verschieben. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPSRLVDQ zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsrlvdq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsrlvdq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSRLVDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSRLVDQ operand[, operand]

PBXB64-Verwendung

VPSRLVDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSRLVDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSRLVQ - Variable shift right logical qwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPSRLVQ - Variable shift right logical qwords
Hilfe zum PBXB64-Compiler

VPSRLVQ - Variable shift right logical qwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSRLVQ - Variable shift right logical qwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPSRLVQ ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsrlvq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsrlvq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSRLVQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSRLVQ operand[, operand]

PBXB64-Verwendung

VPSRLVQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSRLVQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSRLW - Shift right logical words - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPSRLW - Shift right logical words
Hilfe zum PBXB64-Compiler

VPSRLW - Shift right logical words

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSRLW - Shift right logical words. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, xmm/mem, imm8.

Syntax

VPSRLW ymm/xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsrlw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsrlw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSRLW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSRLW operand[, operand]

PBXB64-Verwendung

VPSRLW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSRLW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPTERNLOGD - Bitweise Operation mit drei Eingaben (Dword) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPTERNLOGD - Bitweise Operation mit drei Eingaben (Dword)
Hilfe zum PBXB64-Compiler

VPTERNLOGD - Bitweise Operation mit drei Eingaben (Dword)

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPTERNLOGD - Bitweise Operation mit drei Eingaben (Dword). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem, imm8.

Syntax

VPTERNLOGD zmm, zmm, zmm/mem, imm8

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpternlogd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpternlogd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPTERNLOGD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPTERNLOGD operand[, operand]

PBXB64-Verwendung

VPTERNLOGD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPTERNLOGD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPTERNLOGQ - Bitweise Operation mit drei Eingaben (qword) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPTERNLOGQ - Bitweise Operation mit drei Eingaben (qword)
Hilfe zum PBXB64-Compiler

VPTERNLOGQ - Bitweise Operation mit drei Eingaben (qword)

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPTERNLOGQ - Bitweise Operation mit drei Eingaben (qword). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem, imm8.

Syntax

VPTERNLOGQ zmm, zmm, zmm/mem, imm8

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpternlogq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpternlogq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPTERNLOGQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPTERNLOGQ operand[, operand]

PBXB64-Verwendung

VPTERNLOGQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPTERNLOGQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPXOR - Bitwise XOR - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPXOR - Bitwise XOR
Hilfe zum PBXB64-Compiler

VPXOR - Bitwise XOR

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPXOR - Bitwise XOR. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPXOR ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpxor ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpxor ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPXOR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPXOR operand[, operand]

PBXB64-Verwendung

VPXOR ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPXOR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPXORQ - Bitweises XOR von qwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VPXORQ - Bitweises XOR von qwords
Hilfe zum PBXB64-Compiler

VPXORQ - Bitweises XOR von qwords

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPXORQ - Bitweises XOR von qwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPXORQ zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpxorq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpxorq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPXORQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPXORQ operand[, operand]

PBXB64-Verwendung

VPXORQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPXORQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRCP14SD - 14-Bit reziprokes Skalar-Double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VRCP14SD - 14-Bit reziprokes Skalar-Double
Hilfe zum PBXB64-Compiler

VRCP14SD - 14-Bit reziprokes Skalar-Double

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRCP14SD - 14-Bit reziprokes Skalar-Double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VRCP14SD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrcp14sd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrcp14sd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRCP14SD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRCP14SD operand[, operand]

PBXB64-Verwendung

VRCP14SD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRCP14SD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRCP14SS - 14-Bit-reziproker Skalar-Single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VRCP14SS - 14-Bit-reziproker Skalar-Single
Hilfe zum PBXB64-Compiler

VRCP14SS - 14-Bit-reziproker Skalar-Single

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRCP14SS - 14-Bit-reziproker Skalar-Single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VRCP14SS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrcp14ss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrcp14ss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRCP14SS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRCP14SS operand[, operand]

PBXB64-Verwendung

VRCP14SS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRCP14SS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRCP28SD - 28-Bit-Reziproknäherung (doppelt, skalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VRCP28SD - 28-Bit-Reziproknäherung (doppelt, skalar)
Hilfe zum PBXB64-Compiler

VRCP28SD - 28-Bit-Reziproknäherung (doppelt, skalar)

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRCP28SD - 28-Bit-Reziproknäherung (doppelt, skalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VRCP28SD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrcp28sd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrcp28sd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRCP28SD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRCP28SD operand[, operand]

PBXB64-Verwendung

VRCP28SD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRCP28SD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRCP28SS - 28-Bit-Reziproknäherung (einfach, skalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VRCP28SS - 28-Bit-Reziproknäherung (einfach, skalar)
Hilfe zum PBXB64-Compiler

VRCP28SS - 28-Bit-Reziproknäherung (einfach, skalar)

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRCP28SS - 28-Bit-Reziproknäherung (einfach, skalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VRCP28SS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrcp28ss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrcp28ss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRCP28SS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRCP28SS operand[, operand]

PBXB64-Verwendung

VRCP28SS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRCP28SS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VREDUCESD - Skalar-Double reduzieren (auf N Bits runden) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VREDUCESD - Skalar-Double reduzieren (auf N Bits runden)
Hilfe zum PBXB64-Compiler

VREDUCESD - Skalar-Double reduzieren (auf N Bits runden)

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VREDUCESD - Skalar-Double reduzieren (auf N Bits runden). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/mem, imm8.

Syntax

VREDUCESD xmm, xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vreducesd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vreducesd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VREDUCESD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VREDUCESD operand[, operand]

PBXB64-Verwendung

VREDUCESD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VREDUCESD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VREDUCESS - Skalare Single reduzieren (auf N Bits runden) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VREDUCESS - Skalare Single reduzieren (auf N Bits runden)
Hilfe zum PBXB64-Compiler

VREDUCESS - Skalare Single reduzieren (auf N Bits runden)

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VREDUCESS - Skalare Single reduzieren (auf N Bits runden). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/mem, imm8.

Syntax

VREDUCESS xmm, xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vreducess ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vreducess ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VREDUCESS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VREDUCESS operand[, operand]

PBXB64-Verwendung

VREDUCESS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VREDUCESS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRSQRT28SD - 28-Bit reziproke Quadratnäherung (doppelt, skalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VRSQRT28SD - 28-Bit reziproke Quadratnäherung (doppelt, skalar)
Hilfe zum PBXB64-Compiler

VRSQRT28SD - 28-Bit reziproke Quadratnäherung (doppelt, skalar)

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRSQRT28SD - 28-Bit reziproke Quadratnäherung (doppelt, skalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VRSQRT28SD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrsqrt28sd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrsqrt28sd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRSQRT28SD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRSQRT28SD operand[, operand]

PBXB64-Verwendung

VRSQRT28SD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRSQRT28SD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRSQRT28SS - 28-Bit-Reziprok-Quadrat-Näherung (einfach, skalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VRSQRT28SS - 28-Bit-Reziprok-Quadrat-Näherung (einfach, skalar)
Hilfe zum PBXB64-Compiler

VRSQRT28SS - 28-Bit-Reziprok-Quadrat-Näherung (einfach, skalar)

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRSQRT28SS - 28-Bit-Reziprok-Quadrat-Näherung (einfach, skalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VRSQRT28SS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrsqrt28ss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrsqrt28ss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRSQRT28SS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRSQRT28SS operand[, operand]

PBXB64-Verwendung

VRSQRT28SS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRSQRT28SS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VSHUFI32X4 - Mischen Sie 128-Bit-Spuren mit 32-Bit-Elementen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VSHUFI32X4 - Mischen Sie 128-Bit-Spuren mit 32-Bit-Elementen
Hilfe zum PBXB64-Compiler

VSHUFI32X4 - Mischen Sie 128-Bit-Spuren mit 32-Bit-Elementen

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VSHUFI32X4 - Mischen Sie 128-Bit-Spuren mit 32-Bit-Elementen. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem, imm8.

Syntax

VSHUFI32X4 zmm, zmm, zmm/mem, imm8

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vshufi32x4 ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vshufi32x4 ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VSHUFI32X4 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VSHUFI32X4 operand[, operand]

PBXB64-Verwendung

VSHUFI32X4 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VSHUFI32X4 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VSHUFI64X2 - Mischen Sie 128-Bit-Spuren mit 64-Bit-Elementen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › VSHUFI64X2 - Mischen Sie 128-Bit-Spuren mit 64-Bit-Elementen
Hilfe zum PBXB64-Compiler

VSHUFI64X2 - Mischen Sie 128-Bit-Spuren mit 64-Bit-Elementen

Category: Bit Operations

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VSHUFI64X2 - Mischen Sie 128-Bit-Spuren mit 64-Bit-Elementen. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem, imm8.

Syntax

VSHUFI64X2 zmm, zmm, zmm/mem, imm8

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vshufi64x2 ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vshufi64x2 ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VSHUFI64X2 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VSHUFI64X2 operand[, operand]

PBXB64-Verwendung

VSHUFI64X2 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VSHUFI64X2 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


WRSS - Auf Shadow Stack schreiben (Supervisor) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Bit Operations › WRSS - Auf Shadow Stack schreiben (Supervisor)
Hilfe zum PBXB64-Compiler

WRSS - Auf Shadow Stack schreiben (Supervisor)

Category: Bit Operations

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

WRSS - Auf Shadow Stack schreiben (Supervisor). Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen mem64, reg64.

Syntax

WRSS mem64, reg64

Operands and Sizes

Form | Meaning
mem64, reg64 | may read or write memory; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    wrss eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! wrss eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

WRSS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

WRSS operand[, operand]

PBXB64-Verwendung

WRSS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! WRSS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ADCX - Mit Carry hinzufügen (verwendet nur CF-Flag) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › ADCX - Mit Carry hinzufügen (verwendet nur CF-Flag)
Hilfe zum PBXB64-Compiler

ADCX - Mit Carry hinzufügen (verwendet nur CF-Flag)

Category: Compare / Flags

Assembly Group: BMI

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

ADCX - Mit Carry hinzufügen (verwendet nur CF-Flag). Diese Instruktion gehoert zur BMI-Familie und verwendet die dokumentierten Operandenformen reg32/64, reg/mem.

Syntax

ADCX reg32/64, reg/mem

Operands and Sizes

Form | Meaning
reg32 | uses a general-purpose register
64, reg | uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    adcx eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! adcx eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_bmi.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

ADCX ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

ADCX operand[, operand]

PBXB64-Verwendung

ADCX ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! ADCX ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • BMI mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ADOX - Mit Überlauf hinzufügen (verwendet nur das OF-Flag) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › ADOX - Mit Überlauf hinzufügen (verwendet nur das OF-Flag)
Hilfe zum PBXB64-Compiler

ADOX - Mit Überlauf hinzufügen (verwendet nur das OF-Flag)

Category: Compare / Flags

Assembly Group: BMI

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

ADOX - Mit Überlauf hinzufügen (verwendet nur das OF-Flag). Diese Instruktion gehoert zur BMI-Familie und verwendet die dokumentierten Operandenformen reg32/64, reg/mem.

Syntax

ADOX reg32/64, reg/mem

Operands and Sizes

Form | Meaning
reg32 | uses a general-purpose register
64, reg | uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    adox eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! adox eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_bmi.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

ADOX ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

ADOX operand[, operand]

PBXB64-Verwendung

ADOX ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! ADOX ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • BMI mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BLENDPD - Mischung verpackt doppelt (sofortige Maske) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › BLENDPD - Mischung verpackt doppelt (sofortige Maske)
Hilfe zum PBXB64-Compiler

BLENDPD - Mischung verpackt doppelt (sofortige Maske)

Category: Compare / Flags

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

BLENDPD - Mischung verpackt doppelt (sofortige Maske). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

BLENDPD xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    blendpd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! blendpd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

BLENDPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

BLENDPD operand[, operand]

PBXB64-Verwendung

BLENDPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! BLENDPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BLENDPS - Blend verpackte Single (Sofortmaske) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › BLENDPS - Blend verpackte Single (Sofortmaske)
Hilfe zum PBXB64-Compiler

BLENDPS - Blend verpackte Single (Sofortmaske)

Category: Compare / Flags

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

BLENDPS - Blend verpackte Single (Sofortmaske). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

BLENDPS xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    blendps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! blendps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

BLENDPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

BLENDPS operand[, operand]

PBXB64-Verwendung

BLENDPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! BLENDPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BLENDVPD - Variable Mischung doppelt gepackt (durch XMM0-Maske) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › BLENDVPD - Variable Mischung doppelt gepackt (durch XMM0-Maske)
Hilfe zum PBXB64-Compiler

BLENDVPD - Variable Mischung doppelt gepackt (durch XMM0-Maske)

Category: Compare / Flags

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

BLENDVPD - Variable Mischung doppelt gepackt (durch XMM0-Maske). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

BLENDVPD xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    blendvpd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! blendvpd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

BLENDVPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

BLENDVPD operand[, operand]

PBXB64-Verwendung

BLENDVPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! BLENDVPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BLENDVPS - Variable Mischung gepackt einzeln (nach XMM0-Maske) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › BLENDVPS - Variable Mischung gepackt einzeln (nach XMM0-Maske)
Hilfe zum PBXB64-Compiler

BLENDVPS - Variable Mischung gepackt einzeln (nach XMM0-Maske)

Category: Compare / Flags

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

BLENDVPS - Variable Mischung gepackt einzeln (nach XMM0-Maske). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

BLENDVPS xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    blendvps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! blendvps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

BLENDVPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

BLENDVPS operand[, operand]

PBXB64-Verwendung

BLENDVPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! BLENDVPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BLSMSK - Maske bis zum niedrigsten gesetzten Bit: dst = src ^ (src-1) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › BLSMSK - Maske bis zum niedrigsten gesetzten Bit: dst = src ^ (src-1)
Hilfe zum PBXB64-Compiler

BLSMSK - Maske bis zum niedrigsten gesetzten Bit: dst = src ^ (src-1)

Category: Compare / Flags

Assembly Group: BMI

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

BLSMSK - Maske bis zum niedrigsten gesetzten Bit: dst = src ^ (src-1). Diese Instruktion gehoert zur BMI-Familie und verwendet die dokumentierten Operandenformen reg, reg/mem.

Syntax

BLSMSK reg, reg/mem

Operands and Sizes

Form | Meaning
reg, reg | uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    blsmsk eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! blsmsk eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_bmi.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

BLSMSK ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

BLSMSK operand[, operand]

PBXB64-Verwendung

BLSMSK ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! BLSMSK ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • BMI mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BTC - Bittest und Ergänzung - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › BTC - Bittest und Ergänzung
Hilfe zum PBXB64-Compiler

BTC - Bittest und Ergänzung

Category: Compare / Flags

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

BTC - Bittest und Ergänzung. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen reg/mem, reg/imm.

Syntax

BTC reg/mem, reg/imm

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem, reg | may read or write memory; uses a general-purpose register
imm | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    btc eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! btc eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

BTC ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

BTC operand[, operand]

PBXB64-Verwendung

BTC ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! BTC ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BTR - Bittest und Reset - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › BTR - Bittest und Reset
Hilfe zum PBXB64-Compiler

BTR - Bittest und Reset

Category: Compare / Flags

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

BTR - Bittest und Reset. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen reg/mem, reg/imm.

Syntax

BTR reg/mem, reg/imm

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem, reg | may read or write memory; uses a general-purpose register
imm | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    btr eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! btr eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

BTR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

BTR operand[, operand]

PBXB64-Verwendung

BTR ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! BTR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BTS - Bit testen und einstellen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › BTS - Bit testen und einstellen
Hilfe zum PBXB64-Compiler

BTS - Bit testen und einstellen

Category: Compare / Flags

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

BTS - Bit testen und einstellen. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen reg/mem, reg/imm.

Syntax

BTS reg/mem, reg/imm

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem, reg | may read or write memory; uses a general-purpose register
imm | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    bts eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! bts eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

BTS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

BTS operand[, operand]

PBXB64-Verwendung

BTS ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! BTS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BZHI - Null hohe Bits: wenn index<operand_size, dst=src & mask - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › BZHI - Null hohe Bits: wenn index&lt;operand_size, dst=src & mask
Hilfe zum PBXB64-Compiler

BZHI - Null hohe Bits: wenn index<operand_size, dst=src & mask

Category: Compare / Flags

Assembly Group: BMI

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

BZHI - Null hohe Bits: wenn index<operand_size, dst=src & mask. Diese Instruktion gehoert zur BMI-Familie und verwendet die dokumentierten Operandenformen reg, reg/mem, reg.

Syntax

BZHI reg, reg/mem, reg

Operands and Sizes

Form | Meaning
reg, reg | uses a general-purpose register
mem, reg | may read or write memory; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    bzhi eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! bzhi eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_bmi.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

BZHI ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

BZHI operand[, operand]

PBXB64-Verwendung

BZHI ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! BZHI ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • BMI mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CLI - Interrupt-Flag löschen (IF=0) LAHF - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › CLI - Interrupt-Flag löschen (IF=0) LAHF
Hilfe zum PBXB64-Compiler

CLI - Interrupt-Flag löschen (IF=0) LAHF

Category: Compare / Flags

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CLI - Interrupt-Flag löschen (IF=0) LAHF. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen Flags in AH laden (SF:ZF:0:AF:0:PF:1:CF).

Syntax

CLI Flags in AH laden (SF:ZF:0:AF:0:PF:1:CF)

Operands and Sizes

Form | Meaning
Flags in AH laden (SF:ZF:0:AF:0:PF:1:CF) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    cli operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cli operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CLI ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CLI operand[, operand]

PBXB64-Verwendung

CLI ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CLI ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CLRSSBSY - Löschen Sie die Besetzt-Flagge des Shadow-Stacks - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › CLRSSBSY - Löschen Sie die Besetzt-Flagge des Shadow-Stacks
Hilfe zum PBXB64-Compiler

CLRSSBSY - Löschen Sie die Besetzt-Flagge des Shadow-Stacks

Category: Compare / Flags

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CLRSSBSY - Löschen Sie die Besetzt-Flagge des Shadow-Stacks. Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen mem64.

Syntax

CLRSSBSY mem64

Operands and Sizes

Form | Meaning
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    clrssbsy [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! clrssbsy [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CLRSSBSY ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CLRSSBSY operand[, operand]

PBXB64-Verwendung

CLRSSBSY ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CLRSSBSY ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CMC - Komplement-Carry-Flag (CF=!CF) STD - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › CMC - Komplement-Carry-Flag (CF=!CF) STD
Hilfe zum PBXB64-Compiler

CMC - Komplement-Carry-Flag (CF=!CF) STD

Category: Compare / Flags

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CMC - Komplement-Carry-Flag (CF=!CF) STD. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen Richtungsflag setzen (DF=1).

Syntax

CMC Richtungsflag setzen (DF=1)

Operands and Sizes

Form | Meaning
Richtungsflag setzen (DF=1) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    cmc operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cmc operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CMC ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CMC operand[, operand]

PBXB64-Verwendung

CMC ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CMC ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


COMISD - Vergleichen Sie das geordnete Skalar-Double (Setzt Flags) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › COMISD - Vergleichen Sie das geordnete Skalar-Double (Setzt Flags)
Hilfe zum PBXB64-Compiler

COMISD - Vergleichen Sie das geordnete Skalar-Double (Setzt Flags)

Category: Compare / Flags

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

COMISD - Vergleichen Sie das geordnete Skalar-Double (Setzt Flags). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem64.

Syntax

COMISD xmm, xmm/mem64

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 8
asm_data64:
    .quad 0

.text
.global main
main:
    comisd xmm0, [rip + asm_data64]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! comisd xmm0, [rip + asm_data64]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

COMISD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

COMISD operand[, operand]

PBXB64-Verwendung

COMISD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! COMISD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


COMISS - Vergleichen Sie geordnete Skalar-Singles (Setzt Flags) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › COMISS - Vergleichen Sie geordnete Skalar-Singles (Setzt Flags)
Hilfe zum PBXB64-Compiler

COMISS - Vergleichen Sie geordnete Skalar-Singles (Setzt Flags)

Category: Compare / Flags

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

COMISS - Vergleichen Sie geordnete Skalar-Singles (Setzt Flags). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem32.

Syntax

COMISS xmm, xmm/mem32

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem32 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 4
asm_data32:
    .long 0

.text
.global main
main:
    comiss xmm0, [rip + asm_data32]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! comiss xmm0, [rip + asm_data32]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

COMISS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

COMISS operand[, operand]

PBXB64-Verwendung

COMISS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! COMISS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


FCOMI - Vergleichen und setzen Sie EFLAGS (P6+, ST0 mit ST[i]) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › FCOMI - Vergleichen und setzen Sie EFLAGS (P6+, ST0 mit ST[i])
Hilfe zum PBXB64-Compiler

FCOMI - Vergleichen und setzen Sie EFLAGS (P6+, ST0 mit ST[i])

Category: Compare / Flags

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FCOMI - Vergleichen und setzen Sie EFLAGS (P6+, ST0 mit ST[i]). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen ST(i).

Syntax

FCOMI ST(i)

Operands and Sizes

Form | Meaning
ST(i) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fcomi operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fcomi operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FCOMI ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FCOMI operand[, operand]

PBXB64-Verwendung

FCOMI ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FCOMI ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


FCOMIP - Vergleichen, EFLAGS setzen und Pop - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › FCOMIP - Vergleichen, EFLAGS setzen und Pop
Hilfe zum PBXB64-Compiler

FCOMIP - Vergleichen, EFLAGS setzen und Pop

Category: Compare / Flags

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FCOMIP - Vergleichen, EFLAGS setzen und Pop. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen ST(i).

Syntax

FCOMIP ST(i)

Operands and Sizes

Form | Meaning
ST(i) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fcomip operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fcomip operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FCOMIP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FCOMIP operand[, operand]

PBXB64-Verwendung

FCOMIP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FCOMIP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


FTST - Testen Sie ST0 gegen 0,0 - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › FTST - Testen Sie ST0 gegen 0,0
Hilfe zum PBXB64-Compiler

FTST - Testen Sie ST0 gegen 0,0

Category: Compare / Flags

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FTST - Testen Sie ST0 gegen 0,0. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

FTST keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    ftst operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! ftst operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FTST ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FTST operand[, operand]

PBXB64-Verwendung

FTST ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FTST ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FUCOMI - Ungeordneter Vergleich, EFLAGS setzen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › FUCOMI - Ungeordneter Vergleich, EFLAGS setzen
Hilfe zum PBXB64-Compiler

FUCOMI - Ungeordneter Vergleich, EFLAGS setzen

Category: Compare / Flags

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FUCOMI - Ungeordneter Vergleich, EFLAGS setzen. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen ST(i).

Syntax

FUCOMI ST(i)

Operands and Sizes

Form | Meaning
ST(i) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fucomi operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fucomi operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FUCOMI ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FUCOMI operand[, operand]

PBXB64-Verwendung

FUCOMI ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FUCOMI ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


FUCOMIP - Ungeordneter Vergleich, EFLAGS setzen, Pop - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › FUCOMIP - Ungeordneter Vergleich, EFLAGS setzen, Pop
Hilfe zum PBXB64-Compiler

FUCOMIP - Ungeordneter Vergleich, EFLAGS setzen, Pop

Category: Compare / Flags

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FUCOMIP - Ungeordneter Vergleich, EFLAGS setzen, Pop. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen ST(i).

Syntax

FUCOMIP ST(i)

Operands and Sizes

Form | Meaning
ST(i) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fucomip operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fucomip operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FUCOMIP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FUCOMIP operand[, operand]

PBXB64-Verwendung

FUCOMIP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FUCOMIP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


MASKMOVDQU - Maskierter Speicher gepackter Ganzzahlen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › MASKMOVDQU - Maskierter Speicher gepackter Ganzzahlen
Hilfe zum PBXB64-Compiler

MASKMOVDQU - Maskierter Speicher gepackter Ganzzahlen

Category: Compare / Flags

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MASKMOVDQU - Maskierter Speicher gepackter Ganzzahlen. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm.

Syntax

MASKMOVDQU xmm, xmm

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    maskmovdqu xmm0, xmm1
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! maskmovdqu xmm0, xmm1
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MASKMOVDQU ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MASKMOVDQU operand[, operand]

PBXB64-Verwendung

MASKMOVDQU ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MASKMOVDQU ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVMSKPD - Vorzeichenmaske nach GPR verschieben (2 Bits) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › MOVMSKPD - Vorzeichenmaske nach GPR verschieben (2 Bits)
Hilfe zum PBXB64-Compiler

MOVMSKPD - Vorzeichenmaske nach GPR verschieben (2 Bits)

Category: Compare / Flags

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVMSKPD - Vorzeichenmaske nach GPR verschieben (2 Bits). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen reg, xmm.

Syntax

MOVMSKPD reg, xmm

Operands and Sizes

Form | Meaning
reg, xmm | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    movmskpd xmm0, xmm1
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movmskpd xmm0, xmm1
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVMSKPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVMSKPD operand[, operand]

PBXB64-Verwendung

MOVMSKPD ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVMSKPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MULX - Vorzeichenlose Multiplikation ohne Auswirkungen auf Flags - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › MULX - Vorzeichenlose Multiplikation ohne Auswirkungen auf Flags
Hilfe zum PBXB64-Compiler

MULX - Vorzeichenlose Multiplikation ohne Auswirkungen auf Flags

Category: Compare / Flags

Assembly Group: BMI

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MULX - Vorzeichenlose Multiplikation ohne Auswirkungen auf Flags. Diese Instruktion gehoert zur BMI-Familie und verwendet die dokumentierten Operandenformen reg, reg, reg/mem.

Syntax

MULX reg, reg, reg/mem

Operands and Sizes

Form | Meaning
reg, reg, reg | uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    mulx eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! mulx eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_bmi.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MULX ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MULX operand[, operand]

PBXB64-Verwendung

MULX ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MULX ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • BMI mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PBLENDVB - Variable Mischung gepackter Bytes (nach XMM0-Maske) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › PBLENDVB - Variable Mischung gepackter Bytes (nach XMM0-Maske)
Hilfe zum PBXB64-Compiler

PBLENDVB - Variable Mischung gepackter Bytes (nach XMM0-Maske)

Category: Compare / Flags

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PBLENDVB - Variable Mischung gepackter Bytes (nach XMM0-Maske). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PBLENDVB xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pblendvb xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pblendvb xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PBLENDVB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PBLENDVB operand[, operand]

PBXB64-Verwendung

PBLENDVB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PBLENDVB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PBLENDW - Mischung aus gepackten Wörtern (Sofortmaske) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › PBLENDW - Mischung aus gepackten Wörtern (Sofortmaske)
Hilfe zum PBXB64-Compiler

PBLENDW - Mischung aus gepackten Wörtern (Sofortmaske)

Category: Compare / Flags

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PBLENDW - Mischung aus gepackten Wörtern (Sofortmaske). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

PBLENDW xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pblendw xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pblendw xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PBLENDW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PBLENDW operand[, operand]

PBXB64-Verwendung

PBLENDW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PBLENDW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PCMPESTRM - Gepackte Zeichenfolgen mit expliziter Länge vergleichen, Maske - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › PCMPESTRM - Gepackte Zeichenfolgen mit expliziter Länge vergleichen, Maske
Hilfe zum PBXB64-Compiler

PCMPESTRM - Gepackte Zeichenfolgen mit expliziter Länge vergleichen, Maske

Category: Compare / Flags

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PCMPESTRM - Gepackte Zeichenfolgen mit expliziter Länge vergleichen, Maske. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

PCMPESTRM xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pcmpestrm xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pcmpestrm xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PCMPESTRM ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PCMPESTRM operand[, operand]

PBXB64-Verwendung

PCMPESTRM ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PCMPESTRM ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


PCMPISTRM - Gepackte Zeichenfolgen mit impliziter Länge vergleichen, Maske - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › PCMPISTRM - Gepackte Zeichenfolgen mit impliziter Länge vergleichen, Maske
Hilfe zum PBXB64-Compiler

PCMPISTRM - Gepackte Zeichenfolgen mit impliziter Länge vergleichen, Maske

Category: Compare / Flags

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PCMPISTRM - Gepackte Zeichenfolgen mit impliziter Länge vergleichen, Maske. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

PCMPISTRM xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pcmpistrm xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pcmpistrm xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PCMPISTRM ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PCMPISTRM operand[, operand]

PBXB64-Verwendung

PCMPISTRM ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PCMPISTRM ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.

← PCMPESTRM - Gepackte Zeichenfolgen mit expliziter Länge vergleichen, Maske Top PDEP - Parallele Biteinzahlung: Streuen Sie die Bits mithilfe einer Maske →


PDEP - Parallele Biteinzahlung: Streuen Sie die Bits mithilfe einer Maske - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › PDEP - Parallele Biteinzahlung: Streuen Sie die Bits mithilfe einer Maske
Hilfe zum PBXB64-Compiler

PDEP - Parallele Biteinzahlung: Streuen Sie die Bits mithilfe einer Maske

Category: Compare / Flags

Assembly Group: BMI

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PDEP - Parallele Biteinzahlung: Streuen Sie die Bits mithilfe einer Maske. Diese Instruktion gehoert zur BMI-Familie und verwendet die dokumentierten Operandenformen reg, reg, reg/mem.

Syntax

PDEP reg, reg, reg/mem

Operands and Sizes

Form | Meaning
reg, reg, reg | uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    pdep eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pdep eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_bmi.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PDEP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PDEP operand[, operand]

PBXB64-Verwendung

PDEP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PDEP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • BMI mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← PCMPISTRM - Gepackte Zeichenfolgen mit impliziter Länge vergleichen, Maske Top PEXT - Parallele Bits extrahieren: Bits mithilfe einer Maske sammeln →


PEXT - Parallele Bits extrahieren: Bits mithilfe einer Maske sammeln - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › PEXT - Parallele Bits extrahieren: Bits mithilfe einer Maske sammeln
Hilfe zum PBXB64-Compiler

PEXT - Parallele Bits extrahieren: Bits mithilfe einer Maske sammeln

Category: Compare / Flags

Assembly Group: BMI

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PEXT - Parallele Bits extrahieren: Bits mithilfe einer Maske sammeln. Diese Instruktion gehoert zur BMI-Familie und verwendet die dokumentierten Operandenformen reg, reg, reg/mem.

Syntax

PEXT reg, reg, reg/mem

Operands and Sizes

Form | Meaning
reg, reg, reg | uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    pext eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pext eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_bmi.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PEXT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PEXT operand[, operand]

PBXB64-Verwendung

PEXT ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PEXT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • BMI mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMOVMSKB - Bytemaske nach GPR verschieben (MSB jedes Bytes) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › PMOVMSKB - Bytemaske nach GPR verschieben (MSB jedes Bytes)
Hilfe zum PBXB64-Compiler

PMOVMSKB - Bytemaske nach GPR verschieben (MSB jedes Bytes)

Category: Compare / Flags

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMOVMSKB - Bytemaske nach GPR verschieben (MSB jedes Bytes). Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen reg, mm.

Syntax

PMOVMSKB reg, mm

Operands and Sizes

Form | Meaning
reg, mm | may read or write memory; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    pmovmskb eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmovmskb eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMOVMSKB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMOVMSKB operand[, operand]

PBXB64-Verwendung

PMOVMSKB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMOVMSKB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RORX - Sofort nach rechts drehen (keine Flaggen betroffen) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › RORX - Sofort nach rechts drehen (keine Flaggen betroffen)
Hilfe zum PBXB64-Compiler

RORX - Sofort nach rechts drehen (keine Flaggen betroffen)

Category: Compare / Flags

Assembly Group: BMI

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

RORX - Sofort nach rechts drehen (keine Flaggen betroffen). Diese Instruktion gehoert zur BMI-Familie und verwendet die dokumentierten Operandenformen reg, reg/mem, imm8.

Syntax

RORX reg, reg/mem, imm8

Operands and Sizes

Form | Meaning
reg, reg | uses a general-purpose register
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    rorx eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! rorx eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_bmi.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

RORX ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

RORX operand[, operand]

PBXB64-Verwendung

RORX ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! RORX ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • BMI mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SAHF - Speichern Sie AH in Flags SAHF - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › SAHF - Speichern Sie AH in Flags SAHF
Hilfe zum PBXB64-Compiler

SAHF - Speichern Sie AH in Flags SAHF

Category: Compare / Flags

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SAHF - Speichern Sie AH in Flags SAHF. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen Speichern Sie AH im unteren RFLAGS-Byte.

Syntax

SAHF Speichern Sie AH im unteren RFLAGS-Byte

Operands and Sizes

Form | Meaning
Speichern Sie AH im unteren RFLAGS-Byte | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    sahf operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! sahf operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SAHF ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SAHF operand[, operand]

PBXB64-Verwendung

SAHF ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SAHF ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SARX - Arithmetik um Variable nach rechts verschieben (keine Flags) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › SARX - Arithmetik um Variable nach rechts verschieben (keine Flags)
Hilfe zum PBXB64-Compiler

SARX - Arithmetik um Variable nach rechts verschieben (keine Flags)

Category: Compare / Flags

Assembly Group: BMI

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SARX - Arithmetik um Variable nach rechts verschieben (keine Flags). Diese Instruktion gehoert zur BMI-Familie und verwendet die dokumentierten Operandenformen reg, reg/mem, reg.

Syntax

SARX reg, reg/mem, reg

Operands and Sizes

Form | Meaning
reg, reg | uses a general-purpose register
mem, reg | may read or write memory; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    sarx eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! sarx eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_bmi.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SARX ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SARX operand[, operand]

PBXB64-Verwendung

SARX ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SARX ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • BMI mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SHLX - Logische Verschiebung nach links durch Variable (keine Flags) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › SHLX - Logische Verschiebung nach links durch Variable (keine Flags)
Hilfe zum PBXB64-Compiler

SHLX - Logische Verschiebung nach links durch Variable (keine Flags)

Category: Compare / Flags

Assembly Group: BMI

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SHLX - Logische Verschiebung nach links durch Variable (keine Flags). Diese Instruktion gehoert zur BMI-Familie und verwendet die dokumentierten Operandenformen reg, reg/mem, reg.

Syntax

SHLX reg, reg/mem, reg

Operands and Sizes

Form | Meaning
reg, reg | uses a general-purpose register
mem, reg | may read or write memory; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    shlx eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! shlx eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_bmi.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SHLX ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SHLX operand[, operand]

PBXB64-Verwendung

SHLX ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SHLX ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • BMI mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SHRX - Logisch nach rechts verschieben nach Variable (keine Flags) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › SHRX - Logisch nach rechts verschieben nach Variable (keine Flags)
Hilfe zum PBXB64-Compiler

SHRX - Logisch nach rechts verschieben nach Variable (keine Flags)

Category: Compare / Flags

Assembly Group: BMI

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SHRX - Logisch nach rechts verschieben nach Variable (keine Flags). Diese Instruktion gehoert zur BMI-Familie und verwendet die dokumentierten Operandenformen reg, reg/mem, reg.

Syntax

SHRX reg, reg/mem, reg

Operands and Sizes

Form | Meaning
reg, reg | uses a general-purpose register
mem, reg | may read or write memory; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    shrx eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! shrx eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_bmi.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SHRX ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SHRX operand[, operand]

PBXB64-Verwendung

SHRX ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SHRX ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • BMI mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


STC - Carry-Flag setzen (CF=1) CLC - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › STC - Carry-Flag setzen (CF=1) CLC
Hilfe zum PBXB64-Compiler

STC - Carry-Flag setzen (CF=1) CLC

Category: Compare / Flags

Assembly Group: CORE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

STC - Carry-Flag setzen (CF=1) CLC. Diese Instruktion gehoert zur CORE-Familie und verwendet die dokumentierten Operandenformen Clear Carry Flag (CF=0).

Syntax

STC Clear Carry Flag (CF=0)

Operands and Sizes

Form | Meaning
Clear Carry Flag (CF=0) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    stc operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! stc operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_core.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

STC ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

STC operand[, operand]

PBXB64-Verwendung

STC ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! STC ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CORE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SYSCALL - Schneller Systemaufruf (AMD/x64 Linux: RCX=RIP, R11=RFLAGS) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › SYSCALL - Schneller Systemaufruf (AMD/x64 Linux: RCX=RIP, R11=RFLAGS)
Hilfe zum PBXB64-Compiler

SYSCALL - Schneller Systemaufruf (AMD/x64 Linux: RCX=RIP, R11=RFLAGS)

Category: Compare / Flags

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SYSCALL - Schneller Systemaufruf (AMD/x64 Linux: RCX=RIP, R11=RFLAGS). Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

SYSCALL keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    syscall operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! syscall operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SYSCALL ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SYSCALL operand[, operand]

PBXB64-Verwendung

SYSCALL ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SYSCALL ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UCOMISD - Ungeordnetes Skalar-Double vergleichen (setzt Flags) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › UCOMISD - Ungeordnetes Skalar-Double vergleichen (setzt Flags)
Hilfe zum PBXB64-Compiler

UCOMISD - Ungeordnetes Skalar-Double vergleichen (setzt Flags)

Category: Compare / Flags

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

UCOMISD - Ungeordnetes Skalar-Double vergleichen (setzt Flags). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem64.

Syntax

UCOMISD xmm, xmm/mem64

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 8
asm_data64:
    .quad 0

.text
.global main
main:
    ucomisd xmm0, [rip + asm_data64]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! ucomisd xmm0, [rip + asm_data64]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

UCOMISD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

UCOMISD operand[, operand]

PBXB64-Verwendung

UCOMISD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! UCOMISD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


UCOMISS - Ungeordnete Skalar-Single vergleichen (setzt Flags) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › UCOMISS - Ungeordnete Skalar-Single vergleichen (setzt Flags)
Hilfe zum PBXB64-Compiler

UCOMISS - Ungeordnete Skalar-Single vergleichen (setzt Flags)

Category: Compare / Flags

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

UCOMISS - Ungeordnete Skalar-Single vergleichen (setzt Flags). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem32.

Syntax

UCOMISS xmm, xmm/mem32

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem32 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 4
asm_data32:
    .long 0

.text
.global main
main:
    ucomiss xmm0, [rip + asm_data32]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! ucomiss xmm0, [rip + asm_data32]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

UCOMISS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

UCOMISS operand[, operand]

PBXB64-Verwendung

UCOMISS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! UCOMISS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


VBLENDMPD - Mischen Sie die Mischung doppelt aus der Maske - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VBLENDMPD - Mischen Sie die Mischung doppelt aus der Maske
Hilfe zum PBXB64-Compiler

VBLENDMPD - Mischen Sie die Mischung doppelt aus der Maske

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VBLENDMPD - Mischen Sie die Mischung doppelt aus der Maske. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VBLENDMPD zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vblendmpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vblendmpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VBLENDMPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VBLENDMPD operand[, operand]

PBXB64-Verwendung

VBLENDMPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VBLENDMPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VBLENDMPS - Mischung verpackt einzeln aus der Maske - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VBLENDMPS - Mischung verpackt einzeln aus der Maske
Hilfe zum PBXB64-Compiler

VBLENDMPS - Mischung verpackt einzeln aus der Maske

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VBLENDMPS - Mischung verpackt einzeln aus der Maske. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VBLENDMPS zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vblendmps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vblendmps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VBLENDMPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VBLENDMPS operand[, operand]

PBXB64-Verwendung

VBLENDMPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VBLENDMPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCMPPD - Compare packed double (imm8) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VCMPPD - Compare packed double (imm8)
Hilfe zum PBXB64-Compiler

VCMPPD - Compare packed double (imm8)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCMPPD - Compare packed double (imm8). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem, imm8.

Syntax

VCMPPD ymm/xmm, ymm/xmm, ymm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcmppd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcmppd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCMPPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCMPPD operand[, operand]

PBXB64-Verwendung

VCMPPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCMPPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCMPPS - Compare packed single (imm8) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VCMPPS - Compare packed single (imm8)
Hilfe zum PBXB64-Compiler

VCMPPS - Compare packed single (imm8)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCMPPS - Compare packed single (imm8). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem, imm8.

Syntax

VCMPPS ymm/xmm, ymm/xmm, ymm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcmpps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcmpps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCMPPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCMPPS operand[, operand]

PBXB64-Verwendung

VCMPPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCMPPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCMPSD - Compare scalar double (imm8) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VCMPSD - Compare scalar double (imm8)
Hilfe zum PBXB64-Compiler

VCMPSD - Compare scalar double (imm8)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCMPSD - Compare scalar double (imm8). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/mem, imm8.

Syntax

VCMPSD xmm, xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcmpsd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcmpsd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCMPSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCMPSD operand[, operand]

PBXB64-Verwendung

VCMPSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCMPSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCMPSS - Compare scalar single (imm8) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VCMPSS - Compare scalar single (imm8)
Hilfe zum PBXB64-Compiler

VCMPSS - Compare scalar single (imm8)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCMPSS - Compare scalar single (imm8). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/mem, imm8.

Syntax

VCMPSS xmm, xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcmpss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcmpss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCMPSS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCMPSS operand[, operand]

PBXB64-Verwendung

VCMPSS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCMPSS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCOMISD - Compare ordered scalar double (flags) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VCOMISD - Compare ordered scalar double (flags)
Hilfe zum PBXB64-Compiler

VCOMISD - Compare ordered scalar double (flags)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCOMISD - Compare ordered scalar double (flags). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem.

Syntax

VCOMISD xmm, xmm/mem

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcomisd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcomisd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCOMISD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCOMISD operand[, operand]

PBXB64-Verwendung

VCOMISD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCOMISD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


VCOMISS - Compare ordered scalar single (flags) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VCOMISS - Compare ordered scalar single (flags)
Hilfe zum PBXB64-Compiler

VCOMISS - Compare ordered scalar single (flags)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCOMISS - Compare ordered scalar single (flags). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem.

Syntax

VCOMISS xmm, xmm/mem

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcomiss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcomiss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCOMISS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCOMISS operand[, operand]

PBXB64-Verwendung

VCOMISS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCOMISS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


VCOMPRESS - Gepackte Elemente komprimieren (durch Maske) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VCOMPRESS - Gepackte Elemente komprimieren (durch Maske)
Hilfe zum PBXB64-Compiler

VCOMPRESS - Gepackte Elemente komprimieren (durch Maske)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCOMPRESS - Gepackte Elemente komprimieren (durch Maske). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VCOMPRESS zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcompress ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcompress ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCOMPRESS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCOMPRESS operand[, operand]

PBXB64-Verwendung

VCOMPRESS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCOMPRESS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


VCOMPRESSB - Gepackte Bytes komprimieren (durch Maske) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VCOMPRESSB - Gepackte Bytes komprimieren (durch Maske)
Hilfe zum PBXB64-Compiler

VCOMPRESSB - Gepackte Bytes komprimieren (durch Maske)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCOMPRESSB - Gepackte Bytes komprimieren (durch Maske). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VCOMPRESSB zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcompressb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcompressb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCOMPRESSB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCOMPRESSB operand[, operand]

PBXB64-Verwendung

VCOMPRESSB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCOMPRESSB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


VCOMPRESSD - Komprimieren Sie gepackte Dwords (durch Maske) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VCOMPRESSD - Komprimieren Sie gepackte Dwords (durch Maske)
Hilfe zum PBXB64-Compiler

VCOMPRESSD - Komprimieren Sie gepackte Dwords (durch Maske)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCOMPRESSD - Komprimieren Sie gepackte Dwords (durch Maske). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VCOMPRESSD zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcompressd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcompressd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCOMPRESSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCOMPRESSD operand[, operand]

PBXB64-Verwendung

VCOMPRESSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCOMPRESSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


VCOMPRESSPD - Komprimieren Sie das Doppelte (durch Maske) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VCOMPRESSPD - Komprimieren Sie das Doppelte (durch Maske)
Hilfe zum PBXB64-Compiler

VCOMPRESSPD - Komprimieren Sie das Doppelte (durch Maske)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCOMPRESSPD - Komprimieren Sie das Doppelte (durch Maske). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VCOMPRESSPD zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcompresspd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcompresspd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCOMPRESSPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCOMPRESSPD operand[, operand]

PBXB64-Verwendung

VCOMPRESSPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCOMPRESSPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


VCOMPRESSPS - Verpackte Single komprimieren (durch Maske) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VCOMPRESSPS - Verpackte Single komprimieren (durch Maske)
Hilfe zum PBXB64-Compiler

VCOMPRESSPS - Verpackte Single komprimieren (durch Maske)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCOMPRESSPS - Verpackte Single komprimieren (durch Maske). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VCOMPRESSPS zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcompressps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcompressps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCOMPRESSPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCOMPRESSPS operand[, operand]

PBXB64-Verwendung

VCOMPRESSPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCOMPRESSPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


VCOMPRESSQ - Komprimieren Sie gepackte Qwords (durch Maske) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VCOMPRESSQ - Komprimieren Sie gepackte Qwords (durch Maske)
Hilfe zum PBXB64-Compiler

VCOMPRESSQ - Komprimieren Sie gepackte Qwords (durch Maske)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCOMPRESSQ - Komprimieren Sie gepackte Qwords (durch Maske). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VCOMPRESSQ zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcompressq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcompressq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCOMPRESSQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCOMPRESSQ operand[, operand]

PBXB64-Verwendung

VCOMPRESSQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCOMPRESSQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


VCOMPRESSW - Komprimieren Sie gepackte Wörter (durch Maske) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VCOMPRESSW - Komprimieren Sie gepackte Wörter (durch Maske)
Hilfe zum PBXB64-Compiler

VCOMPRESSW - Komprimieren Sie gepackte Wörter (durch Maske)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCOMPRESSW - Komprimieren Sie gepackte Wörter (durch Maske). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VCOMPRESSW zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcompressw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcompressw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCOMPRESSW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCOMPRESSW operand[, operand]

PBXB64-Verwendung

VCOMPRESSW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCOMPRESSW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


VEXPAND - Gepackte Elemente erweitern (durch Maske) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VEXPAND - Gepackte Elemente erweitern (durch Maske)
Hilfe zum PBXB64-Compiler

VEXPAND - Gepackte Elemente erweitern (durch Maske)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VEXPAND - Gepackte Elemente erweitern (durch Maske). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VEXPAND zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vexpand ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vexpand ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VEXPAND ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VEXPAND operand[, operand]

PBXB64-Verwendung

VEXPAND ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VEXPAND ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VEXPANDB - Gepackte Bytes erweitern (nach Maske) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VEXPANDB - Gepackte Bytes erweitern (nach Maske)
Hilfe zum PBXB64-Compiler

VEXPANDB - Gepackte Bytes erweitern (nach Maske)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VEXPANDB - Gepackte Bytes erweitern (nach Maske). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VEXPANDB zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vexpandb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vexpandb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VEXPANDB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VEXPANDB operand[, operand]

PBXB64-Verwendung

VEXPANDB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VEXPANDB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VEXPANDD - Gepackte Dwords erweitern (nach Maske) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VEXPANDD - Gepackte Dwords erweitern (nach Maske)
Hilfe zum PBXB64-Compiler

VEXPANDD - Gepackte Dwords erweitern (nach Maske)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VEXPANDD - Gepackte Dwords erweitern (nach Maske). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VEXPANDD zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vexpandd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vexpandd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VEXPANDD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VEXPANDD operand[, operand]

PBXB64-Verwendung

VEXPANDD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VEXPANDD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VEXPANDPD - Gepacktes Doppel erweitern (durch Maske) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VEXPANDPD - Gepacktes Doppel erweitern (durch Maske)
Hilfe zum PBXB64-Compiler

VEXPANDPD - Gepacktes Doppel erweitern (durch Maske)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VEXPANDPD - Gepacktes Doppel erweitern (durch Maske). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VEXPANDPD zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vexpandpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vexpandpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VEXPANDPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VEXPANDPD operand[, operand]

PBXB64-Verwendung

VEXPANDPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VEXPANDPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VEXPANDPS - Gepackte Single erweitern (nach Maske) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VEXPANDPS - Gepackte Single erweitern (nach Maske)
Hilfe zum PBXB64-Compiler

VEXPANDPS - Gepackte Single erweitern (nach Maske)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VEXPANDPS - Gepackte Single erweitern (nach Maske). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VEXPANDPS zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vexpandps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vexpandps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VEXPANDPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VEXPANDPS operand[, operand]

PBXB64-Verwendung

VEXPANDPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VEXPANDPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VEXPANDQ - Gepackte QWords erweitern (nach Maske) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VEXPANDQ - Gepackte QWords erweitern (nach Maske)
Hilfe zum PBXB64-Compiler

VEXPANDQ - Gepackte QWords erweitern (nach Maske)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VEXPANDQ - Gepackte QWords erweitern (nach Maske). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VEXPANDQ zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vexpandq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vexpandq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VEXPANDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VEXPANDQ operand[, operand]

PBXB64-Verwendung

VEXPANDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VEXPANDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VEXPANDW - Gepackte Wörter erweitern (durch Maske) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VEXPANDW - Gepackte Wörter erweitern (durch Maske)
Hilfe zum PBXB64-Compiler

VEXPANDW - Gepackte Wörter erweitern (durch Maske)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VEXPANDW - Gepackte Wörter erweitern (durch Maske). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VEXPANDW zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vexpandw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vexpandw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VEXPANDW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VEXPANDW operand[, operand]

PBXB64-Verwendung

VEXPANDW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VEXPANDW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFPCLASSPD - Testpackung doppelt für den Unterricht - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VFPCLASSPD - Testpackung doppelt für den Unterricht
Hilfe zum PBXB64-Compiler

VFPCLASSPD - Testpackung doppelt für den Unterricht

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFPCLASSPD - Testpackung doppelt für den Unterricht. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem, imm8.

Syntax

VFPCLASSPD zmm, zmm/mem, imm8

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfpclasspd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfpclasspd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFPCLASSPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFPCLASSPD operand[, operand]

PBXB64-Verwendung

VFPCLASSPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFPCLASSPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFPCLASSPS - Testgepackte Single für die Klasse (NaN/Inf/Null) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VFPCLASSPS - Testgepackte Single für die Klasse (NaN/Inf/Null)
Hilfe zum PBXB64-Compiler

VFPCLASSPS - Testgepackte Single für die Klasse (NaN/Inf/Null)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFPCLASSPS - Testgepackte Single für die Klasse (NaN/Inf/Null). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem, imm8.

Syntax

VFPCLASSPS zmm, zmm/mem, imm8

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfpclassps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfpclassps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFPCLASSPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFPCLASSPS operand[, operand]

PBXB64-Verwendung

VFPCLASSPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFPCLASSPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVDQA32 - Ausgerichtetes Dword/Qword verschieben (mit Opmask) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VMOVDQA32 - Ausgerichtetes Dword/Qword verschieben (mit Opmask)
Hilfe zum PBXB64-Compiler

VMOVDQA32 - Ausgerichtetes Dword/Qword verschieben (mit Opmask)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVDQA32 - Ausgerichtetes Dword/Qword verschieben (mit Opmask). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, mem / mem, zmm.

Syntax

VMOVDQA32 zmm, mem / mem, zmm

Operands and Sizes

Form | Meaning
zmm, mem | may read or write memory
mem, zmm | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovdqa32 ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovdqa32 ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVDQA32 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVDQA32 operand[, operand]

PBXB64-Verwendung

VMOVDQA32 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVDQA32 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVDQA64 - Ausgerichtetes qword verschieben (mit opmask) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VMOVDQA64 - Ausgerichtetes qword verschieben (mit opmask)
Hilfe zum PBXB64-Compiler

VMOVDQA64 - Ausgerichtetes qword verschieben (mit opmask)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVDQA64 - Ausgerichtetes qword verschieben (mit opmask). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, mem / mem, zmm.

Syntax

VMOVDQA64 zmm, mem / mem, zmm

Operands and Sizes

Form | Meaning
zmm, mem | may read or write memory
mem, zmm | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovdqa64 ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovdqa64 ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVDQA64 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVDQA64 operand[, operand]

PBXB64-Verwendung

VMOVDQA64 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVDQA64 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVDQU32 - Nicht ausgerichtetes Dword/Qword verschieben (mit opmask) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VMOVDQU32 - Nicht ausgerichtetes Dword/Qword verschieben (mit opmask)
Hilfe zum PBXB64-Compiler

VMOVDQU32 - Nicht ausgerichtetes Dword/Qword verschieben (mit opmask)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVDQU32 - Nicht ausgerichtetes Dword/Qword verschieben (mit opmask). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, mem / mem, zmm.

Syntax

VMOVDQU32 zmm, mem / mem, zmm

Operands and Sizes

Form | Meaning
zmm, mem | may read or write memory
mem, zmm | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovdqu32 ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovdqu32 ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVDQU32 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVDQU32 operand[, operand]

PBXB64-Verwendung

VMOVDQU32 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVDQU32 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVDQU64 - Nicht ausgerichtetes qword verschieben (mit opmask) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VMOVDQU64 - Nicht ausgerichtetes qword verschieben (mit opmask)
Hilfe zum PBXB64-Compiler

VMOVDQU64 - Nicht ausgerichtetes qword verschieben (mit opmask)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVDQU64 - Nicht ausgerichtetes qword verschieben (mit opmask). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, mem / mem, zmm.

Syntax

VMOVDQU64 zmm, mem / mem, zmm

Operands and Sizes

Form | Meaning
zmm, mem | may read or write memory
mem, zmm | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovdqu64 ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovdqu64 ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVDQU64 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVDQU64 operand[, operand]

PBXB64-Verwendung

VMOVDQU64 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVDQU64 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPBLENDMD - Mischen Sie gepackte Dwords aus der Maske - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPBLENDMD - Mischen Sie gepackte Dwords aus der Maske
Hilfe zum PBXB64-Compiler

VPBLENDMD - Mischen Sie gepackte Dwords aus der Maske

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPBLENDMD - Mischen Sie gepackte Dwords aus der Maske. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPBLENDMD zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpblendmd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpblendmd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPBLENDMD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPBLENDMD operand[, operand]

PBXB64-Verwendung

VPBLENDMD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPBLENDMD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPBLENDMQ - Mischen Sie gepackte QWords aus der Maske - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPBLENDMQ - Mischen Sie gepackte QWords aus der Maske
Hilfe zum PBXB64-Compiler

VPBLENDMQ - Mischen Sie gepackte QWords aus der Maske

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPBLENDMQ - Mischen Sie gepackte QWords aus der Maske. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPBLENDMQ zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpblendmq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpblendmq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPBLENDMQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPBLENDMQ operand[, operand]

PBXB64-Verwendung

VPBLENDMQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPBLENDMQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPCMPEQB - Compare bytes for equality - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPCMPEQB - Compare bytes for equality
Hilfe zum PBXB64-Compiler

VPCMPEQB - Compare bytes for equality

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPCMPEQB - Compare bytes for equality. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPCMPEQB ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpcmpeqb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpcmpeqb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPCMPEQB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPCMPEQB operand[, operand]

PBXB64-Verwendung

VPCMPEQB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPCMPEQB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPCMPEQD - Compare dwords for equality - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPCMPEQD - Compare dwords for equality
Hilfe zum PBXB64-Compiler

VPCMPEQD - Compare dwords for equality

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPCMPEQD - Compare dwords for equality. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPCMPEQD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpcmpeqd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpcmpeqd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPCMPEQD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPCMPEQD operand[, operand]

PBXB64-Verwendung

VPCMPEQD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPCMPEQD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPCMPEQQ - Compare qwords for equality - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPCMPEQQ - Compare qwords for equality
Hilfe zum PBXB64-Compiler

VPCMPEQQ - Compare qwords for equality

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPCMPEQQ - Compare qwords for equality. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPCMPEQQ ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpcmpeqq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpcmpeqq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPCMPEQQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPCMPEQQ operand[, operand]

PBXB64-Verwendung

VPCMPEQQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPCMPEQQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPCMPEQW - Compare words for equality - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPCMPEQW - Compare words for equality
Hilfe zum PBXB64-Compiler

VPCMPEQW - Compare words for equality

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPCMPEQW - Compare words for equality. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPCMPEQW ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpcmpeqw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpcmpeqw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPCMPEQW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPCMPEQW operand[, operand]

PBXB64-Verwendung

VPCMPEQW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPCMPEQW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPCMPGTB - Compare bytes for greater than - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPCMPGTB - Compare bytes for greater than
Hilfe zum PBXB64-Compiler

VPCMPGTB - Compare bytes for greater than

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPCMPGTB - Compare bytes for greater than. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPCMPGTB ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpcmpgtb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpcmpgtb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPCMPGTB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPCMPGTB operand[, operand]

PBXB64-Verwendung

VPCMPGTB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPCMPGTB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPCMPGTD - Compare dwords for greater than - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPCMPGTD - Compare dwords for greater than
Hilfe zum PBXB64-Compiler

VPCMPGTD - Compare dwords for greater than

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPCMPGTD - Compare dwords for greater than. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPCMPGTD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpcmpgtd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpcmpgtd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPCMPGTD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPCMPGTD operand[, operand]

PBXB64-Verwendung

VPCMPGTD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPCMPGTD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPCMPGTQ - Compare qwords for greater than - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPCMPGTQ - Compare qwords for greater than
Hilfe zum PBXB64-Compiler

VPCMPGTQ - Compare qwords for greater than

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPCMPGTQ - Compare qwords for greater than. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPCMPGTQ ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpcmpgtq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpcmpgtq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPCMPGTQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPCMPGTQ operand[, operand]

PBXB64-Verwendung

VPCMPGTQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPCMPGTQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPCMPGTW - Compare words for greater than - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPCMPGTW - Compare words for greater than
Hilfe zum PBXB64-Compiler

VPCMPGTW - Compare words for greater than

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPCMPGTW - Compare words for greater than. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPCMPGTW ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpcmpgtw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpcmpgtw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPCMPGTW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPCMPGTW operand[, operand]

PBXB64-Verwendung

VPCMPGTW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPCMPGTW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPERMI2B - Permutieren Sie Bytes mit Index und Maske - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPERMI2B - Permutieren Sie Bytes mit Index und Maske
Hilfe zum PBXB64-Compiler

VPERMI2B - Permutieren Sie Bytes mit Index und Maske

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERMI2B - Permutieren Sie Bytes mit Index und Maske. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPERMI2B zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpermi2b ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpermi2b ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERMI2B ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERMI2B operand[, operand]

PBXB64-Verwendung

VPERMI2B ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERMI2B ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPERMI2D - Permutieren Sie Dwords mit Index und Maske - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPERMI2D - Permutieren Sie Dwords mit Index und Maske
Hilfe zum PBXB64-Compiler

VPERMI2D - Permutieren Sie Dwords mit Index und Maske

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERMI2D - Permutieren Sie Dwords mit Index und Maske. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPERMI2D zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpermi2d ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpermi2d ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERMI2D ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERMI2D operand[, operand]

PBXB64-Verwendung

VPERMI2D ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERMI2D ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPERMI2Q - Qwords mit Index und Maske permutieren - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPERMI2Q - Qwords mit Index und Maske permutieren
Hilfe zum PBXB64-Compiler

VPERMI2Q - Qwords mit Index und Maske permutieren

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERMI2Q - Qwords mit Index und Maske permutieren. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPERMI2Q zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpermi2q ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpermi2q ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERMI2Q ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERMI2Q operand[, operand]

PBXB64-Verwendung

VPERMI2Q ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERMI2Q ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPERMI2W - Permutieren Sie Wörter mit Index und Maske - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPERMI2W - Permutieren Sie Wörter mit Index und Maske
Hilfe zum PBXB64-Compiler

VPERMI2W - Permutieren Sie Wörter mit Index und Maske

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERMI2W - Permutieren Sie Wörter mit Index und Maske. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPERMI2W zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpermi2w ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpermi2w ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERMI2W ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERMI2W operand[, operand]

PBXB64-Verwendung

VPERMI2W ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERMI2W ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPERMT2B - Bytes mit Index und Maske permutieren (zwei Quellen) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPERMT2B - Bytes mit Index und Maske permutieren (zwei Quellen)
Hilfe zum PBXB64-Compiler

VPERMT2B - Bytes mit Index und Maske permutieren (zwei Quellen)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERMT2B - Bytes mit Index und Maske permutieren (zwei Quellen). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPERMT2B zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpermt2b ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpermt2b ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERMT2B ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERMT2B operand[, operand]

PBXB64-Verwendung

VPERMT2B ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERMT2B ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPERMT2D - Dwords mit Index und Maske permutieren (zwei Quellen) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPERMT2D - Dwords mit Index und Maske permutieren (zwei Quellen)
Hilfe zum PBXB64-Compiler

VPERMT2D - Dwords mit Index und Maske permutieren (zwei Quellen)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERMT2D - Dwords mit Index und Maske permutieren (zwei Quellen). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPERMT2D zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpermt2d ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpermt2d ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERMT2D ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERMT2D operand[, operand]

PBXB64-Verwendung

VPERMT2D ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERMT2D ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPERMT2Q - Qwords mit Index und Maske permutieren (zwei Quellen) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPERMT2Q - Qwords mit Index und Maske permutieren (zwei Quellen)
Hilfe zum PBXB64-Compiler

VPERMT2Q - Qwords mit Index und Maske permutieren (zwei Quellen)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERMT2Q - Qwords mit Index und Maske permutieren (zwei Quellen). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPERMT2Q zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpermt2q ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpermt2q ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERMT2Q ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERMT2Q operand[, operand]

PBXB64-Verwendung

VPERMT2Q ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERMT2Q ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPERMT2W - Wörter mit Index und Maske permutieren (zwei Quellen) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPERMT2W - Wörter mit Index und Maske permutieren (zwei Quellen)
Hilfe zum PBXB64-Compiler

VPERMT2W - Wörter mit Index und Maske permutieren (zwei Quellen)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERMT2W - Wörter mit Index und Maske permutieren (zwei Quellen). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPERMT2W zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpermt2w ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpermt2w ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERMT2W ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERMT2W operand[, operand]

PBXB64-Verwendung

VPERMT2W ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERMT2W ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVB2M - Verschieben Sie die Bytemaske vom Vektor in das k-Register - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPMOVB2M - Verschieben Sie die Bytemaske vom Vektor in das k-Register
Hilfe zum PBXB64-Compiler

VPMOVB2M - Verschieben Sie die Bytemaske vom Vektor in das k-Register

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVB2M - Verschieben Sie die Bytemaske vom Vektor in das k-Register. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen k, zmm.

Syntax

VPMOVB2M k, zmm

Operands and Sizes

Form | Meaning
k, zmm | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovb2m ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovb2m ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVB2M ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVB2M operand[, operand]

PBXB64-Verwendung

VPMOVB2M ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVB2M ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVD2M - Verschieben Sie die Dword-Maske vom Vektor in das k-Register - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPMOVD2M - Verschieben Sie die Dword-Maske vom Vektor in das k-Register
Hilfe zum PBXB64-Compiler

VPMOVD2M - Verschieben Sie die Dword-Maske vom Vektor in das k-Register

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVD2M - Verschieben Sie die Dword-Maske vom Vektor in das k-Register. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen k, zmm.

Syntax

VPMOVD2M k, zmm

Operands and Sizes

Form | Meaning
k, zmm | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovd2m ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovd2m ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVD2M ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVD2M operand[, operand]

PBXB64-Verwendung

VPMOVD2M ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVD2M ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVM2B - Maske vom k-Register in den Byte-Vektor verschieben - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPMOVM2B - Maske vom k-Register in den Byte-Vektor verschieben
Hilfe zum PBXB64-Compiler

VPMOVM2B - Maske vom k-Register in den Byte-Vektor verschieben

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVM2B - Maske vom k-Register in den Byte-Vektor verschieben. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, k.

Syntax

VPMOVM2B zmm, k

Operands and Sizes

Form | Meaning
zmm, k | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovm2b ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovm2b ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVM2B ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVM2B operand[, operand]

PBXB64-Verwendung

VPMOVM2B ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVM2B ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← VPMOVD2M - Verschieben Sie die Dword-Maske vom Vektor in das k-Register Top VPMOVM2D - Verschieben Sie die Maske vom k-Register in den dword-Vektor →


VPMOVM2D - Verschieben Sie die Maske vom k-Register in den dword-Vektor - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPMOVM2D - Verschieben Sie die Maske vom k-Register in den dword-Vektor
Hilfe zum PBXB64-Compiler

VPMOVM2D - Verschieben Sie die Maske vom k-Register in den dword-Vektor

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVM2D - Verschieben Sie die Maske vom k-Register in den dword-Vektor. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, k.

Syntax

VPMOVM2D zmm, k

Operands and Sizes

Form | Meaning
zmm, k | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovm2d ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovm2d ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVM2D ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVM2D operand[, operand]

PBXB64-Verwendung

VPMOVM2D ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVM2D ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVM2Q - Maske vom k-Register in den qword-Vektor verschieben - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPMOVM2Q - Maske vom k-Register in den qword-Vektor verschieben
Hilfe zum PBXB64-Compiler

VPMOVM2Q - Maske vom k-Register in den qword-Vektor verschieben

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVM2Q - Maske vom k-Register in den qword-Vektor verschieben. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, k.

Syntax

VPMOVM2Q zmm, k

Operands and Sizes

Form | Meaning
zmm, k | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovm2q ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovm2q ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVM2Q ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVM2Q operand[, operand]

PBXB64-Verwendung

VPMOVM2Q ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVM2Q ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVM2W - Maske vom k-Register in den Wortvektor verschieben - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPMOVM2W - Maske vom k-Register in den Wortvektor verschieben
Hilfe zum PBXB64-Compiler

VPMOVM2W - Maske vom k-Register in den Wortvektor verschieben

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVM2W - Maske vom k-Register in den Wortvektor verschieben. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, k.

Syntax

VPMOVM2W zmm, k

Operands and Sizes

Form | Meaning
zmm, k | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovm2w ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovm2w ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVM2W ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVM2W operand[, operand]

PBXB64-Verwendung

VPMOVM2W ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVM2W ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVQ2M - Verschieben Sie die qword-Maske vom Vektor in das k-Register - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPMOVQ2M - Verschieben Sie die qword-Maske vom Vektor in das k-Register
Hilfe zum PBXB64-Compiler

VPMOVQ2M - Verschieben Sie die qword-Maske vom Vektor in das k-Register

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVQ2M - Verschieben Sie die qword-Maske vom Vektor in das k-Register. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen k, zmm.

Syntax

VPMOVQ2M k, zmm

Operands and Sizes

Form | Meaning
k, zmm | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovq2m ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovq2m ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVQ2M ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVQ2M operand[, operand]

PBXB64-Verwendung

VPMOVQ2M ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVQ2M ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVW2M - Verschieben Sie die Wortmaske vom Vektor in das k-Register - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPMOVW2M - Verschieben Sie die Wortmaske vom Vektor in das k-Register
Hilfe zum PBXB64-Compiler

VPMOVW2M - Verschieben Sie die Wortmaske vom Vektor in das k-Register

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVW2M - Verschieben Sie die Wortmaske vom Vektor in das k-Register. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen k, zmm.

Syntax

VPMOVW2M k, zmm

Operands and Sizes

Form | Meaning
k, zmm | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovw2m ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovw2m ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVW2M ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVW2M operand[, operand]

PBXB64-Verwendung

VPMOVW2M ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVW2M ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSHUFBITQMB - Mischen Sie die Bits im Qword zur Byte-Maske - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPSHUFBITQMB - Mischen Sie die Bits im Qword zur Byte-Maske
Hilfe zum PBXB64-Compiler

VPSHUFBITQMB - Mischen Sie die Bits im Qword zur Byte-Maske

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSHUFBITQMB - Mischen Sie die Bits im Qword zur Byte-Maske. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen k, zmm, zmm/mem.

Syntax

VPSHUFBITQMB k, zmm, zmm/mem

Operands and Sizes

Form | Meaning
k, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpshufbitqmb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpshufbitqmb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSHUFBITQMB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSHUFBITQMB operand[, operand]

PBXB64-Verwendung

VPSHUFBITQMB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSHUFBITQMB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPTEST - Logical compare of integers (sets ZF/CF) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VPTEST - Logical compare of integers (sets ZF/CF)
Hilfe zum PBXB64-Compiler

VPTEST - Logical compare of integers (sets ZF/CF)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPTEST - Logical compare of integers (sets ZF/CF). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/mem.

Syntax

VPTEST ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vptest ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vptest ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPTEST ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPTEST operand[, operand]

PBXB64-Verwendung

VPTEST ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPTEST ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VTESTPD - Test packed double (sets ZF/CF) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VTESTPD - Test packed double (sets ZF/CF)
Hilfe zum PBXB64-Compiler

VTESTPD - Test packed double (sets ZF/CF)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VTESTPD - Test packed double (sets ZF/CF). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm.

Syntax

VTESTPD ymm/xmm, ymm/xmm

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vtestpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vtestpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VTESTPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VTESTPD operand[, operand]

PBXB64-Verwendung

VTESTPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VTESTPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VTESTPS - Test packed single (sets ZF/CF) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VTESTPS - Test packed single (sets ZF/CF)
Hilfe zum PBXB64-Compiler

VTESTPS - Test packed single (sets ZF/CF)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VTESTPS - Test packed single (sets ZF/CF). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm.

Syntax

VTESTPS ymm/xmm, ymm/xmm

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vtestps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vtestps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VTESTPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VTESTPS operand[, operand]

PBXB64-Verwendung

VTESTPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VTESTPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VUCOMISD - Compare unordered scalar double (flags) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VUCOMISD - Compare unordered scalar double (flags)
Hilfe zum PBXB64-Compiler

VUCOMISD - Compare unordered scalar double (flags)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VUCOMISD - Compare unordered scalar double (flags). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem.

Syntax

VUCOMISD xmm, xmm/mem

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vucomisd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vucomisd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VUCOMISD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VUCOMISD operand[, operand]

PBXB64-Verwendung

VUCOMISD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VUCOMISD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


VUCOMISS - Compare unordered scalar single (flags) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Compare / Flags › VUCOMISS - Compare unordered scalar single (flags)
Hilfe zum PBXB64-Compiler

VUCOMISS - Compare unordered scalar single (flags)

Category: Compare / Flags

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VUCOMISS - Compare unordered scalar single (flags). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem.

Syntax

VUCOMISS xmm, xmm/mem

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vucomiss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vucomiss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VUCOMISS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VUCOMISS operand[, operand]

PBXB64-Verwendung

VUCOMISS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VUCOMISS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


ADDPD - Fügen Sie das verpackte Doppel hinzu - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › ADDPD - Fügen Sie das verpackte Doppel hinzu
Hilfe zum PBXB64-Compiler

ADDPD - Fügen Sie das verpackte Doppel hinzu

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

ADDPD - Fügen Sie das verpackte Doppel hinzu. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

ADDPD xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    addpd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! addpd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

ADDPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

ADDPD operand[, operand]

PBXB64-Verwendung

ADDPD ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! ADDPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ANDNPS - Bitwise AND-NOT of packed singles - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › ANDNPS - Bitwise AND-NOT of packed singles
Hilfe zum PBXB64-Compiler

ANDNPS - Bitwise AND-NOT of packed singles

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

ANDNPS - Bitwise AND-NOT of packed singles. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

ANDNPS xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    andnps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! andnps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

ANDNPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

ANDNPS operand[, operand]

PBXB64-Verwendung

ANDNPS ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! ANDNPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ANDPS - Bitwise AND of packed singles - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › ANDPS - Bitwise AND of packed singles
Hilfe zum PBXB64-Compiler

ANDPS - Bitwise AND of packed singles

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

ANDPS - Bitwise AND of packed singles. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

ANDPS xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    andps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! andps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

ANDPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

ANDPS operand[, operand]

PBXB64-Verwendung

ANDPS ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! ANDPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CMPPD - Vergleichen Sie gepacktes Doppel (imm8-Prädikat) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › CMPPD - Vergleichen Sie gepacktes Doppel (imm8-Prädikat)
Hilfe zum PBXB64-Compiler

CMPPD - Vergleichen Sie gepacktes Doppel (imm8-Prädikat)

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CMPPD - Vergleichen Sie gepacktes Doppel (imm8-Prädikat). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

CMPPD xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    cmppd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cmppd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CMPPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CMPPD operand[, operand]

PBXB64-Verwendung

CMPPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CMPPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CMPPS - Vergleichen Sie gepackte Singles (imm8-Prädikat) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › CMPPS - Vergleichen Sie gepackte Singles (imm8-Prädikat)
Hilfe zum PBXB64-Compiler

CMPPS - Vergleichen Sie gepackte Singles (imm8-Prädikat)

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CMPPS - Vergleichen Sie gepackte Singles (imm8-Prädikat). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

CMPPS xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    cmpps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cmpps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CMPPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CMPPS operand[, operand]

PBXB64-Verwendung

CMPPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CMPPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CVTDQ2PD - Konvertieren Sie gepacktes Doppelwort in gepacktes Doppelwort - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › CVTDQ2PD - Konvertieren Sie gepacktes Doppelwort in gepacktes Doppelwort
Hilfe zum PBXB64-Compiler

CVTDQ2PD - Konvertieren Sie gepacktes Doppelwort in gepacktes Doppelwort

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CVTDQ2PD - Konvertieren Sie gepacktes Doppelwort in gepacktes Doppelwort. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem64.

Syntax

CVTDQ2PD xmm, xmm/mem64

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 8
asm_data64:
    .quad 0

.text
.global main
main:
    cvtdq2pd xmm0, [rip + asm_data64]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cvtdq2pd xmm0, [rip + asm_data64]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CVTDQ2PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CVTDQ2PD operand[, operand]

PBXB64-Verwendung

CVTDQ2PD ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CVTDQ2PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CVTDQ2PS - Konvertieren Sie ein gepacktes Doppelwort in ein gepacktes Einzelwort - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › CVTDQ2PS - Konvertieren Sie ein gepacktes Doppelwort in ein gepacktes Einzelwort
Hilfe zum PBXB64-Compiler

CVTDQ2PS - Konvertieren Sie ein gepacktes Doppelwort in ein gepacktes Einzelwort

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CVTDQ2PS - Konvertieren Sie ein gepacktes Doppelwort in ein gepacktes Einzelwort. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

CVTDQ2PS xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    cvtdq2ps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cvtdq2ps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CVTDQ2PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CVTDQ2PS operand[, operand]

PBXB64-Verwendung

CVTDQ2PS ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CVTDQ2PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CVTPD2DQ - Konvertieren Sie gepacktes Doppel in gepacktes Doppelwort - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › CVTPD2DQ - Konvertieren Sie gepacktes Doppel in gepacktes Doppelwort
Hilfe zum PBXB64-Compiler

CVTPD2DQ - Konvertieren Sie gepacktes Doppel in gepacktes Doppelwort

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CVTPD2DQ - Konvertieren Sie gepacktes Doppel in gepacktes Doppelwort. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

CVTPD2DQ xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    cvtpd2dq xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cvtpd2dq xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CVTPD2DQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CVTPD2DQ operand[, operand]

PBXB64-Verwendung

CVTPD2DQ ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CVTPD2DQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← CVTDQ2PS - Konvertieren Sie ein gepacktes Doppelwort in ein gepacktes Einzelwort Top CVTPD2PS - Wandeln Sie gepacktes Doppel in gepacktes Einzel um →


CVTPD2PS - Wandeln Sie gepacktes Doppel in gepacktes Einzel um - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › CVTPD2PS - Wandeln Sie gepacktes Doppel in gepacktes Einzel um
Hilfe zum PBXB64-Compiler

CVTPD2PS - Wandeln Sie gepacktes Doppel in gepacktes Einzel um

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CVTPD2PS - Wandeln Sie gepacktes Doppel in gepacktes Einzel um. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

CVTPD2PS xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    cvtpd2ps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cvtpd2ps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CVTPD2PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CVTPD2PS operand[, operand]

PBXB64-Verwendung

CVTPD2PS ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CVTPD2PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← CVTPD2DQ - Konvertieren Sie gepacktes Doppel in gepacktes Doppelwort Top CVTPS2DQ - Konvertieren Sie ein gepacktes Einzelwort in ein gepacktes Doppelwort →


CVTPS2DQ - Konvertieren Sie ein gepacktes Einzelwort in ein gepacktes Doppelwort - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › CVTPS2DQ - Konvertieren Sie ein gepacktes Einzelwort in ein gepacktes Doppelwort
Hilfe zum PBXB64-Compiler

CVTPS2DQ - Konvertieren Sie ein gepacktes Einzelwort in ein gepacktes Doppelwort

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CVTPS2DQ - Konvertieren Sie ein gepacktes Einzelwort in ein gepacktes Doppelwort. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

CVTPS2DQ xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    cvtps2dq xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cvtps2dq xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CVTPS2DQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CVTPS2DQ operand[, operand]

PBXB64-Verwendung

CVTPS2DQ ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CVTPS2DQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CVTPS2PD - Wandeln Sie gepacktes Einzel in gepacktes Doppel um - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › CVTPS2PD - Wandeln Sie gepacktes Einzel in gepacktes Doppel um
Hilfe zum PBXB64-Compiler

CVTPS2PD - Wandeln Sie gepacktes Einzel in gepacktes Doppel um

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CVTPS2PD - Wandeln Sie gepacktes Einzel in gepacktes Doppel um. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem64.

Syntax

CVTPS2PD xmm, xmm/mem64

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 8
asm_data64:
    .quad 0

.text
.global main
main:
    cvtps2pd xmm0, [rip + asm_data64]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cvtps2pd xmm0, [rip + asm_data64]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CVTPS2PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CVTPS2PD operand[, operand]

PBXB64-Verwendung

CVTPS2PD ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CVTPS2PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← CVTPS2DQ - Konvertieren Sie ein gepacktes Einzelwort in ein gepacktes Doppelwort Top CVTTPD2DQ - Gepacktes Doppel zu gepacktem Doppelwort abschneiden →


CVTTPD2DQ - Gepacktes Doppel zu gepacktem Doppelwort abschneiden - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › CVTTPD2DQ - Gepacktes Doppel zu gepacktem Doppelwort abschneiden
Hilfe zum PBXB64-Compiler

CVTTPD2DQ - Gepacktes Doppel zu gepacktem Doppelwort abschneiden

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CVTTPD2DQ - Gepacktes Doppel zu gepacktem Doppelwort abschneiden. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

CVTTPD2DQ xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    cvttpd2dq xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cvttpd2dq xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CVTTPD2DQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CVTTPD2DQ operand[, operand]

PBXB64-Verwendung

CVTTPD2DQ ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CVTTPD2DQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CVTTPS2DQ - Gepacktes Einzelwort in gepacktes Doppelwort kürzen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › CVTTPS2DQ - Gepacktes Einzelwort in gepacktes Doppelwort kürzen
Hilfe zum PBXB64-Compiler

CVTTPS2DQ - Gepacktes Einzelwort in gepacktes Doppelwort kürzen

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CVTTPS2DQ - Gepacktes Einzelwort in gepacktes Doppelwort kürzen. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

CVTTPS2DQ xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    cvttps2dq xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cvttps2dq xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CVTTPS2DQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CVTTPS2DQ operand[, operand]

PBXB64-Verwendung

CVTTPS2DQ ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CVTTPS2DQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


DIVPD - Doppelt verpackt teilen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › DIVPD - Doppelt verpackt teilen
Hilfe zum PBXB64-Compiler

DIVPD - Doppelt verpackt teilen

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

DIVPD - Doppelt verpackt teilen. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

DIVPD xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    divpd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! divpd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

DIVPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

DIVPD operand[, operand]

PBXB64-Verwendung

DIVPD ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! DIVPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


DPPD - Skalarprodukt des gepackten Doppels - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › DPPD - Skalarprodukt des gepackten Doppels
Hilfe zum PBXB64-Compiler

DPPD - Skalarprodukt des gepackten Doppels

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

DPPD - Skalarprodukt des gepackten Doppels. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

DPPD xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    dppd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! dppd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

DPPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

DPPD operand[, operand]

PBXB64-Verwendung

DPPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! DPPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


DPPS - Skalarprodukt der gepackten Einzelmenge - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › DPPS - Skalarprodukt der gepackten Einzelmenge
Hilfe zum PBXB64-Compiler

DPPS - Skalarprodukt der gepackten Einzelmenge

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

DPPS - Skalarprodukt der gepackten Einzelmenge. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

DPPS xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    dpps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! dpps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

DPPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

DPPS operand[, operand]

PBXB64-Verwendung

DPPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! DPPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


EXTRACTPS - Extrahieren Sie gepackte Singles in GPR/Speicher - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › EXTRACTPS - Extrahieren Sie gepackte Singles in GPR/Speicher
Hilfe zum PBXB64-Compiler

EXTRACTPS - Extrahieren Sie gepackte Singles in GPR/Speicher

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

EXTRACTPS - Extrahieren Sie gepackte Singles in GPR/Speicher. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen reg/mem32, xmm, imm8.

Syntax

EXTRACTPS reg/mem32, xmm, imm8

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem32, xmm, imm8 | uses XMM vector/scalar registers; may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 4
asm_data32:
    .long 0

.text
.global main
main:
    extractps xmm0, [rip + asm_data32]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! extractps xmm0, [rip + asm_data32]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

EXTRACTPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

EXTRACTPS operand[, operand]

PBXB64-Verwendung

EXTRACTPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! EXTRACTPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FBLD - BCD-Wert laden (18-stelliges gepacktes BCD) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › FBLD - BCD-Wert laden (18-stelliges gepacktes BCD)
Hilfe zum PBXB64-Compiler

FBLD - BCD-Wert laden (18-stelliges gepacktes BCD)

Category: Shuffle / Permute

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FBLD - BCD-Wert laden (18-stelliges gepacktes BCD). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem80 (TBYTE).

Syntax

FBLD mem80 (TBYTE)

Operands and Sizes

Form | Meaning
mem80 (TBYTE) | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fbld [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fbld [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FBLD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FBLD operand[, operand]

PBXB64-Verwendung

FBLD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FBLD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


INSERTPS - Gepackte Single einfügen (aus der Quelle zusammenführen) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › INSERTPS - Gepackte Single einfügen (aus der Quelle zusammenführen)
Hilfe zum PBXB64-Compiler

INSERTPS - Gepackte Single einfügen (aus der Quelle zusammenführen)

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

INSERTPS - Gepackte Single einfügen (aus der Quelle zusammenführen). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem32, imm8.

Syntax

INSERTPS xmm, xmm/mem32, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem32, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 4
asm_data32:
    .long 0

.text
.global main
main:
    insertps xmm0, [rip + asm_data32]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! insertps xmm0, [rip + asm_data32]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

INSERTPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

INSERTPS operand[, operand]

PBXB64-Verwendung

INSERTPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! INSERTPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MAXPD - Maximal doppelt bepackt - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › MAXPD - Maximal doppelt bepackt
Hilfe zum PBXB64-Compiler

MAXPD - Maximal doppelt bepackt

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MAXPD - Maximal doppelt bepackt. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

MAXPD xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    maxpd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! maxpd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MAXPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MAXPD operand[, operand]

PBXB64-Verwendung

MAXPD ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MAXPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MAXPS - Maximal gepacktes Einzelstück - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › MAXPS - Maximal gepacktes Einzelstück
Hilfe zum PBXB64-Compiler

MAXPS - Maximal gepacktes Einzelstück

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MAXPS - Maximal gepacktes Einzelstück. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

MAXPS xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    maxps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! maxps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MAXPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MAXPS operand[, operand]

PBXB64-Verwendung

MAXPS ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MAXPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MINPD - Mindestens doppelt verpackt - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › MINPD - Mindestens doppelt verpackt
Hilfe zum PBXB64-Compiler

MINPD - Mindestens doppelt verpackt

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MINPD - Mindestens doppelt verpackt. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

MINPD xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    minpd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! minpd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MINPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MINPD operand[, operand]

PBXB64-Verwendung

MINPD ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MINPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MINPS - Mindestens einzeln verpackt - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › MINPS - Mindestens einzeln verpackt
Hilfe zum PBXB64-Compiler

MINPS - Mindestens einzeln verpackt

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MINPS - Mindestens einzeln verpackt. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

MINPS xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    minps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! minps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MINPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MINPS operand[, operand]

PBXB64-Verwendung

MINPS ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MINPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVNTPD - Nichtzeitlicher Speicher von gepacktem Doppel (SSE2) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › MOVNTPD - Nichtzeitlicher Speicher von gepacktem Doppel (SSE2)
Hilfe zum PBXB64-Compiler

MOVNTPD - Nichtzeitlicher Speicher von gepacktem Doppel (SSE2)

Category: Shuffle / Permute

Assembly Group: CACHE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVNTPD - Nichtzeitlicher Speicher von gepacktem Doppel (SSE2). Diese Instruktion gehoert zur CACHE-Familie und verwendet die dokumentierten Operandenformen mem128, xmm.

Syntax

MOVNTPD mem128, xmm

Operands and Sizes

Form | Meaning
mem128, xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    movntpd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movntpd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_cache.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVNTPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVNTPD operand[, operand]

PBXB64-Verwendung

MOVNTPD ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVNTPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CACHE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVNTPS - Nicht-temporäre Speicherung gepackter Singles (SSE) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › MOVNTPS - Nicht-temporäre Speicherung gepackter Singles (SSE)
Hilfe zum PBXB64-Compiler

MOVNTPS - Nicht-temporäre Speicherung gepackter Singles (SSE)

Category: Shuffle / Permute

Assembly Group: CACHE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVNTPS - Nicht-temporäre Speicherung gepackter Singles (SSE). Diese Instruktion gehoert zur CACHE-Familie und verwendet die dokumentierten Operandenformen mem128, xmm.

Syntax

MOVNTPS mem128, xmm

Operands and Sizes

Form | Meaning
mem128, xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    movntps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movntps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_cache.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVNTPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVNTPS operand[, operand]

PBXB64-Verwendung

MOVNTPS ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVNTPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CACHE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MULPD - Mehrfach gepacktes Doppeltes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › MULPD - Mehrfach gepacktes Doppeltes
Hilfe zum PBXB64-Compiler

MULPD - Mehrfach gepacktes Doppeltes

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MULPD - Mehrfach gepacktes Doppeltes. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

MULPD xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    mulpd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! mulpd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MULPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MULPD operand[, operand]

PBXB64-Verwendung

MULPD ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MULPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ORPS - Bitwise OR of packed singles - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › ORPS - Bitwise OR of packed singles
Hilfe zum PBXB64-Compiler

ORPS - Bitwise OR of packed singles

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

ORPS - Bitwise OR of packed singles. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

ORPS xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    orps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! orps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

ORPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

ORPS operand[, operand]

PBXB64-Verwendung

ORPS ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! ORPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PABSB - Gepackter absoluter Bytewert - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PABSB - Gepackter absoluter Bytewert
Hilfe zum PBXB64-Compiler

PABSB - Gepackter absoluter Bytewert

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PABSB - Gepackter absoluter Bytewert. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PABSB xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pabsb xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pabsb xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PABSB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PABSB operand[, operand]

PBXB64-Verwendung

PABSB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PABSB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PABSD - Gepackter Absolutwert von Doppelwörtern - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PABSD - Gepackter Absolutwert von Doppelwörtern
Hilfe zum PBXB64-Compiler

PABSD - Gepackter Absolutwert von Doppelwörtern

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PABSD - Gepackter Absolutwert von Doppelwörtern. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PABSD xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pabsd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pabsd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PABSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PABSD operand[, operand]

PBXB64-Verwendung

PABSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PABSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PABSW - Verpackter absoluter Wortwert - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PABSW - Verpackter absoluter Wortwert
Hilfe zum PBXB64-Compiler

PABSW - Verpackter absoluter Wortwert

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PABSW - Verpackter absoluter Wortwert. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PABSW xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pabsw xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pabsw xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PABSW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PABSW operand[, operand]

PBXB64-Verwendung

PABSW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PABSW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PACKSSDW - Vorzeichenbehaftete Doppelwörter zu Wörtern packen (gesättigt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PACKSSDW - Vorzeichenbehaftete Doppelwörter zu Wörtern packen (gesättigt)
Hilfe zum PBXB64-Compiler

PACKSSDW - Vorzeichenbehaftete Doppelwörter zu Wörtern packen (gesättigt)

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PACKSSDW - Vorzeichenbehaftete Doppelwörter zu Wörtern packen (gesättigt). Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PACKSSDW mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    packssdw [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! packssdw [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PACKSSDW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PACKSSDW operand[, operand]

PBXB64-Verwendung

PACKSSDW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PACKSSDW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PACKSSWB - Vorzeichenbehaftete Wörter in Bytes packen (gesättigt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PACKSSWB - Vorzeichenbehaftete Wörter in Bytes packen (gesättigt)
Hilfe zum PBXB64-Compiler

PACKSSWB - Vorzeichenbehaftete Wörter in Bytes packen (gesättigt)

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PACKSSWB - Vorzeichenbehaftete Wörter in Bytes packen (gesättigt). Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PACKSSWB mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    packsswb [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! packsswb [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PACKSSWB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PACKSSWB operand[, operand]

PBXB64-Verwendung

PACKSSWB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PACKSSWB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← PACKSSDW - Vorzeichenbehaftete Doppelwörter zu Wörtern packen (gesättigt) Top PACKUSDW - Vorzeichenbehaftete Doppelwörter in vorzeichenlose Wörter packen (gesättigt) →


PACKUSDW - Vorzeichenbehaftete Doppelwörter in vorzeichenlose Wörter packen (gesättigt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PACKUSDW - Vorzeichenbehaftete Doppelwörter in vorzeichenlose Wörter packen (gesättigt)
Hilfe zum PBXB64-Compiler

PACKUSDW - Vorzeichenbehaftete Doppelwörter in vorzeichenlose Wörter packen (gesättigt)

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PACKUSDW - Vorzeichenbehaftete Doppelwörter in vorzeichenlose Wörter packen (gesättigt). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PACKUSDW xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    packusdw xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! packusdw xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PACKUSDW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PACKUSDW operand[, operand]

PBXB64-Verwendung

PACKUSDW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PACKUSDW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PACKUSWB - Packen Sie vorzeichenlose Wörter in Bytes (unsigned sat.) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PACKUSWB - Packen Sie vorzeichenlose Wörter in Bytes (unsigned sat.)
Hilfe zum PBXB64-Compiler

PACKUSWB - Packen Sie vorzeichenlose Wörter in Bytes (unsigned sat.)

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PACKUSWB - Packen Sie vorzeichenlose Wörter in Bytes (unsigned sat.). Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PACKUSWB mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    packuswb [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! packuswb [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PACKUSWB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PACKUSWB operand[, operand]

PBXB64-Verwendung

PACKUSWB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PACKUSWB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← PACKUSDW - Vorzeichenbehaftete Doppelwörter in vorzeichenlose Wörter packen (gesättigt) Top PADDB - Gepackte Bytes hinzufügen (bei Überlauf umbrechen) →


PADDB - Gepackte Bytes hinzufügen (bei Überlauf umbrechen) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PADDB - Gepackte Bytes hinzufügen (bei Überlauf umbrechen)
Hilfe zum PBXB64-Compiler

PADDB - Gepackte Bytes hinzufügen (bei Überlauf umbrechen)

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PADDB - Gepackte Bytes hinzufügen (bei Überlauf umbrechen). Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PADDB mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    paddb [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! paddb [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PADDB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PADDB operand[, operand]

PBXB64-Verwendung

PADDB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PADDB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PADDD - Gepackte Doppelwörter hinzufügen (Umbruch) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PADDD - Gepackte Doppelwörter hinzufügen (Umbruch)
Hilfe zum PBXB64-Compiler

PADDD - Gepackte Doppelwörter hinzufügen (Umbruch)

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PADDD - Gepackte Doppelwörter hinzufügen (Umbruch). Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PADDD mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    paddd [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! paddd [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PADDD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PADDD operand[, operand]

PBXB64-Verwendung

PADDD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PADDD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PADDQ - Fügen Sie gepackte Quadword-Ganzzahlen hinzu - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PADDQ - Fügen Sie gepackte Quadword-Ganzzahlen hinzu
Hilfe zum PBXB64-Compiler

PADDQ - Fügen Sie gepackte Quadword-Ganzzahlen hinzu

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PADDQ - Fügen Sie gepackte Quadword-Ganzzahlen hinzu. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PADDQ xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    paddq xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! paddq xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PADDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PADDQ operand[, operand]

PBXB64-Verwendung

PADDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PADDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PADDSB - Fügen Sie gepackte Bytes mit vorzeichenbehafteter Sättigung hinzu - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PADDSB - Fügen Sie gepackte Bytes mit vorzeichenbehafteter Sättigung hinzu
Hilfe zum PBXB64-Compiler

PADDSB - Fügen Sie gepackte Bytes mit vorzeichenbehafteter Sättigung hinzu

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PADDSB - Fügen Sie gepackte Bytes mit vorzeichenbehafteter Sättigung hinzu. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PADDSB mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    paddsb [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! paddsb [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PADDSB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PADDSB operand[, operand]

PBXB64-Verwendung

PADDSB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PADDSB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PADDSW - Fügen Sie gepackte Wörter mit vorzeichenbehafteter Sättigung hinzu - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PADDSW - Fügen Sie gepackte Wörter mit vorzeichenbehafteter Sättigung hinzu
Hilfe zum PBXB64-Compiler

PADDSW - Fügen Sie gepackte Wörter mit vorzeichenbehafteter Sättigung hinzu

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PADDSW - Fügen Sie gepackte Wörter mit vorzeichenbehafteter Sättigung hinzu. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PADDSW mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    paddsw [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! paddsw [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PADDSW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PADDSW operand[, operand]

PBXB64-Verwendung

PADDSW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PADDSW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← PADDSB - Fügen Sie gepackte Bytes mit vorzeichenbehafteter Sättigung hinzu Top PADDUSB - Fügen Sie gepackte Bytes mit vorzeichenloser Sättigung hinzu →


PADDUSB - Fügen Sie gepackte Bytes mit vorzeichenloser Sättigung hinzu - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PADDUSB - Fügen Sie gepackte Bytes mit vorzeichenloser Sättigung hinzu
Hilfe zum PBXB64-Compiler

PADDUSB - Fügen Sie gepackte Bytes mit vorzeichenloser Sättigung hinzu

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PADDUSB - Fügen Sie gepackte Bytes mit vorzeichenloser Sättigung hinzu. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PADDUSB mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    paddusb [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! paddusb [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PADDUSB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PADDUSB operand[, operand]

PBXB64-Verwendung

PADDUSB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PADDUSB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← PADDSW - Fügen Sie gepackte Wörter mit vorzeichenbehafteter Sättigung hinzu Top PADDUSW - Fügen Sie gepackte Wörter mit vorzeichenloser Sättigung hinzu →


PADDUSW - Fügen Sie gepackte Wörter mit vorzeichenloser Sättigung hinzu - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PADDUSW - Fügen Sie gepackte Wörter mit vorzeichenloser Sättigung hinzu
Hilfe zum PBXB64-Compiler

PADDUSW - Fügen Sie gepackte Wörter mit vorzeichenloser Sättigung hinzu

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PADDUSW - Fügen Sie gepackte Wörter mit vorzeichenloser Sättigung hinzu. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PADDUSW mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    paddusw [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! paddusw [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PADDUSW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PADDUSW operand[, operand]

PBXB64-Verwendung

PADDUSW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PADDUSW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PADDW - Gepackte Wörter hinzufügen (Umbruch) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PADDW - Gepackte Wörter hinzufügen (Umbruch)
Hilfe zum PBXB64-Compiler

PADDW - Gepackte Wörter hinzufügen (Umbruch)

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PADDW - Gepackte Wörter hinzufügen (Umbruch). Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PADDW mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    paddw [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! paddw [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PADDW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PADDW operand[, operand]

PBXB64-Verwendung

PADDW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PADDW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PALIGNR - Gepackt rechts ausrichten (verketten und verschieben) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PALIGNR - Gepackt rechts ausrichten (verketten und verschieben)
Hilfe zum PBXB64-Compiler

PALIGNR - Gepackt rechts ausrichten (verketten und verschieben)

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PALIGNR - Gepackt rechts ausrichten (verketten und verschieben). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

PALIGNR xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    palignr xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! palignr xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PALIGNR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PALIGNR operand[, operand]

PBXB64-Verwendung

PALIGNR ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PALIGNR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PCMPEQB - Vergleichen Sie gepackte Bytes auf Gleichheit - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PCMPEQB - Vergleichen Sie gepackte Bytes auf Gleichheit
Hilfe zum PBXB64-Compiler

PCMPEQB - Vergleichen Sie gepackte Bytes auf Gleichheit

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PCMPEQB - Vergleichen Sie gepackte Bytes auf Gleichheit. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PCMPEQB mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    pcmpeqb [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pcmpeqb [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PCMPEQB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PCMPEQB operand[, operand]

PBXB64-Verwendung

PCMPEQB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PCMPEQB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PCMPEQD - Vergleichen Sie gepackte Doppelwörter auf Gleichheit - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PCMPEQD - Vergleichen Sie gepackte Doppelwörter auf Gleichheit
Hilfe zum PBXB64-Compiler

PCMPEQD - Vergleichen Sie gepackte Doppelwörter auf Gleichheit

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PCMPEQD - Vergleichen Sie gepackte Doppelwörter auf Gleichheit. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PCMPEQD mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    pcmpeqd [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pcmpeqd [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PCMPEQD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PCMPEQD operand[, operand]

PBXB64-Verwendung

PCMPEQD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PCMPEQD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PCMPEQQ - Vergleichen Sie gepackte Quadwords auf Gleichheit - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PCMPEQQ - Vergleichen Sie gepackte Quadwords auf Gleichheit
Hilfe zum PBXB64-Compiler

PCMPEQQ - Vergleichen Sie gepackte Quadwords auf Gleichheit

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PCMPEQQ - Vergleichen Sie gepackte Quadwords auf Gleichheit. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PCMPEQQ xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pcmpeqq xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pcmpeqq xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PCMPEQQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PCMPEQQ operand[, operand]

PBXB64-Verwendung

PCMPEQQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PCMPEQQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PCMPEQW - Vergleichen Sie gepackte Wörter auf Gleichheit - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PCMPEQW - Vergleichen Sie gepackte Wörter auf Gleichheit
Hilfe zum PBXB64-Compiler

PCMPEQW - Vergleichen Sie gepackte Wörter auf Gleichheit

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PCMPEQW - Vergleichen Sie gepackte Wörter auf Gleichheit. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PCMPEQW mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    pcmpeqw [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pcmpeqw [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PCMPEQW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PCMPEQW operand[, operand]

PBXB64-Verwendung

PCMPEQW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PCMPEQW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PCMPESTRI - Gepackte Zeichenfolgen mit expliziter Länge und Index vergleichen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PCMPESTRI - Gepackte Zeichenfolgen mit expliziter Länge und Index vergleichen
Hilfe zum PBXB64-Compiler

PCMPESTRI - Gepackte Zeichenfolgen mit expliziter Länge und Index vergleichen

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PCMPESTRI - Gepackte Zeichenfolgen mit expliziter Länge und Index vergleichen. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

PCMPESTRI xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pcmpestri xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pcmpestri xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PCMPESTRI ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PCMPESTRI operand[, operand]

PBXB64-Verwendung

PCMPESTRI ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PCMPESTRI ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


PCMPGTB - Vergleichen Sie gepackte Bytes auf größer als (mit Vorzeichen) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PCMPGTB - Vergleichen Sie gepackte Bytes auf größer als (mit Vorzeichen)
Hilfe zum PBXB64-Compiler

PCMPGTB - Vergleichen Sie gepackte Bytes auf größer als (mit Vorzeichen)

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PCMPGTB - Vergleichen Sie gepackte Bytes auf größer als (mit Vorzeichen). Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PCMPGTB mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    pcmpgtb [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pcmpgtb [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PCMPGTB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PCMPGTB operand[, operand]

PBXB64-Verwendung

PCMPGTB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PCMPGTB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PCMPGTD - Vergleichen Sie gepackte Doppelwörter für größer als - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PCMPGTD - Vergleichen Sie gepackte Doppelwörter für größer als
Hilfe zum PBXB64-Compiler

PCMPGTD - Vergleichen Sie gepackte Doppelwörter für größer als

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PCMPGTD - Vergleichen Sie gepackte Doppelwörter für größer als. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PCMPGTD mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    pcmpgtd [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pcmpgtd [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PCMPGTD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PCMPGTD operand[, operand]

PBXB64-Verwendung

PCMPGTD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PCMPGTD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← PCMPGTB - Vergleichen Sie gepackte Bytes auf größer als (mit Vorzeichen) Top PCMPGTQ - Vergleichen Sie gepackte Quadwords für größer als (vorzeichenbehaftet) →


PCMPGTQ - Vergleichen Sie gepackte Quadwords für größer als (vorzeichenbehaftet) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PCMPGTQ - Vergleichen Sie gepackte Quadwords für größer als (vorzeichenbehaftet)
Hilfe zum PBXB64-Compiler

PCMPGTQ - Vergleichen Sie gepackte Quadwords für größer als (vorzeichenbehaftet)

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PCMPGTQ - Vergleichen Sie gepackte Quadwords für größer als (vorzeichenbehaftet). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PCMPGTQ xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pcmpgtq xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pcmpgtq xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PCMPGTQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PCMPGTQ operand[, operand]

PBXB64-Verwendung

PCMPGTQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PCMPGTQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PCMPGTW - Vergleichen Sie gepackte Wörter für größer als - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PCMPGTW - Vergleichen Sie gepackte Wörter für größer als
Hilfe zum PBXB64-Compiler

PCMPGTW - Vergleichen Sie gepackte Wörter für größer als

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PCMPGTW - Vergleichen Sie gepackte Wörter für größer als. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PCMPGTW mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    pcmpgtw [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pcmpgtw [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PCMPGTW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PCMPGTW operand[, operand]

PBXB64-Verwendung

PCMPGTW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PCMPGTW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← PCMPGTQ - Vergleichen Sie gepackte Quadwords für größer als (vorzeichenbehaftet) Top PCMPISTRI - Gepackte Zeichenfolgen mit impliziter Länge vergleichen, Index →


PCMPISTRI - Gepackte Zeichenfolgen mit impliziter Länge vergleichen, Index - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PCMPISTRI - Gepackte Zeichenfolgen mit impliziter Länge vergleichen, Index
Hilfe zum PBXB64-Compiler

PCMPISTRI - Gepackte Zeichenfolgen mit impliziter Länge vergleichen, Index

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PCMPISTRI - Gepackte Zeichenfolgen mit impliziter Länge vergleichen, Index. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

PCMPISTRI xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pcmpistri xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pcmpistri xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PCMPISTRI ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PCMPISTRI operand[, operand]

PBXB64-Verwendung

PCMPISTRI ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PCMPISTRI ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.


PHADDD - Gepackte horizontale Doppelwörter hinzufügen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PHADDD - Gepackte horizontale Doppelwörter hinzufügen
Hilfe zum PBXB64-Compiler

PHADDD - Gepackte horizontale Doppelwörter hinzufügen

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PHADDD - Gepackte horizontale Doppelwörter hinzufügen. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PHADDD xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    phaddd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! phaddd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PHADDD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PHADDD operand[, operand]

PBXB64-Verwendung

PHADDD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PHADDD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PHADDSW - Gepackte horizontale Wörter mit Sättigung hinzufügen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PHADDSW - Gepackte horizontale Wörter mit Sättigung hinzufügen
Hilfe zum PBXB64-Compiler

PHADDSW - Gepackte horizontale Wörter mit Sättigung hinzufügen

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PHADDSW - Gepackte horizontale Wörter mit Sättigung hinzufügen. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PHADDSW xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    phaddsw xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! phaddsw xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PHADDSW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PHADDSW operand[, operand]

PBXB64-Verwendung

PHADDSW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PHADDSW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PHADDW - Gepackte horizontale Wörter hinzufügen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PHADDW - Gepackte horizontale Wörter hinzufügen
Hilfe zum PBXB64-Compiler

PHADDW - Gepackte horizontale Wörter hinzufügen

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PHADDW - Gepackte horizontale Wörter hinzufügen. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PHADDW xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    phaddw xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! phaddw xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PHADDW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PHADDW operand[, operand]

PBXB64-Verwendung

PHADDW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PHADDW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PHMINPOSUW - Gepackte horizontale Min. vorzeichenloser Wörter, Speicherposition - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PHMINPOSUW - Gepackte horizontale Min. vorzeichenloser Wörter, Speicherposition
Hilfe zum PBXB64-Compiler

PHMINPOSUW - Gepackte horizontale Min. vorzeichenloser Wörter, Speicherposition

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PHMINPOSUW - Gepackte horizontale Min. vorzeichenloser Wörter, Speicherposition. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PHMINPOSUW xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    phminposuw xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! phminposuw xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PHMINPOSUW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PHMINPOSUW operand[, operand]

PBXB64-Verwendung

PHMINPOSUW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PHMINPOSUW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PHSUBD - Gepackte horizontale Subtraktionsdoppelwörter - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PHSUBD - Gepackte horizontale Subtraktionsdoppelwörter
Hilfe zum PBXB64-Compiler

PHSUBD - Gepackte horizontale Subtraktionsdoppelwörter

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PHSUBD - Gepackte horizontale Subtraktionsdoppelwörter. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PHSUBD xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    phsubd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! phsubd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PHSUBD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PHSUBD operand[, operand]

PBXB64-Verwendung

PHSUBD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PHSUBD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← PHMINPOSUW - Gepackte horizontale Min. vorzeichenloser Wörter, Speicherposition Top PHSUBSW - Gepackte horizontale subtrahierte vorzeichenbehaftete Wörter mit Sättigung →


PHSUBSW - Gepackte horizontale subtrahierte vorzeichenbehaftete Wörter mit Sättigung - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PHSUBSW - Gepackte horizontale subtrahierte vorzeichenbehaftete Wörter mit Sättigung
Hilfe zum PBXB64-Compiler

PHSUBSW - Gepackte horizontale subtrahierte vorzeichenbehaftete Wörter mit Sättigung

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PHSUBSW - Gepackte horizontale subtrahierte vorzeichenbehaftete Wörter mit Sättigung. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PHSUBSW xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    phsubsw xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! phsubsw xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PHSUBSW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PHSUBSW operand[, operand]

PBXB64-Verwendung

PHSUBSW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PHSUBSW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PHSUBW - Gepackte horizontale Subtraktionswörter - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PHSUBW - Gepackte horizontale Subtraktionswörter
Hilfe zum PBXB64-Compiler

PHSUBW - Gepackte horizontale Subtraktionswörter

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PHSUBW - Gepackte horizontale Subtraktionswörter. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PHSUBW xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    phsubw xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! phsubw xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PHSUBW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PHSUBW operand[, operand]

PBXB64-Verwendung

PHSUBW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PHSUBW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← PHSUBSW - Gepackte horizontale subtrahierte vorzeichenbehaftete Wörter mit Sättigung Top PMADDWD - Multiplizieren Sie gepackte Wörter und fügen Sie sie zu Doppelwörtern hinzu →


PMADDWD - Multiplizieren Sie gepackte Wörter und fügen Sie sie zu Doppelwörtern hinzu - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PMADDWD - Multiplizieren Sie gepackte Wörter und fügen Sie sie zu Doppelwörtern hinzu
Hilfe zum PBXB64-Compiler

PMADDWD - Multiplizieren Sie gepackte Wörter und fügen Sie sie zu Doppelwörtern hinzu

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMADDWD - Multiplizieren Sie gepackte Wörter und fügen Sie sie zu Doppelwörtern hinzu. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PMADDWD mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    pmaddwd [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmaddwd [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMADDWD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMADDWD operand[, operand]

PBXB64-Verwendung

PMADDWD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMADDWD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMAXSB - Maximale Anzahl gepackter signierter Bytes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PMAXSB - Maximale Anzahl gepackter signierter Bytes
Hilfe zum PBXB64-Compiler

PMAXSB - Maximale Anzahl gepackter signierter Bytes

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMAXSB - Maximale Anzahl gepackter signierter Bytes. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PMAXSB xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pmaxsb xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmaxsb xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMAXSB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMAXSB operand[, operand]

PBXB64-Verwendung

PMAXSB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMAXSB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMAXSD - Maximal gepackte signierte Doppelwörter - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PMAXSD - Maximal gepackte signierte Doppelwörter
Hilfe zum PBXB64-Compiler

PMAXSD - Maximal gepackte signierte Doppelwörter

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMAXSD - Maximal gepackte signierte Doppelwörter. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PMAXSD xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pmaxsd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmaxsd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMAXSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMAXSD operand[, operand]

PBXB64-Verwendung

PMAXSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMAXSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMAXSW - Maximal gepackte vorzeichenbehaftete Wörter - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PMAXSW - Maximal gepackte vorzeichenbehaftete Wörter
Hilfe zum PBXB64-Compiler

PMAXSW - Maximal gepackte vorzeichenbehaftete Wörter

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMAXSW - Maximal gepackte vorzeichenbehaftete Wörter. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PMAXSW xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pmaxsw xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmaxsw xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMAXSW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMAXSW operand[, operand]

PBXB64-Verwendung

PMAXSW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMAXSW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMAXUB - Maximal gepackte Bytes ohne Vorzeichen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PMAXUB - Maximal gepackte Bytes ohne Vorzeichen
Hilfe zum PBXB64-Compiler

PMAXUB - Maximal gepackte Bytes ohne Vorzeichen

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMAXUB - Maximal gepackte Bytes ohne Vorzeichen. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PMAXUB xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pmaxub xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmaxub xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMAXUB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMAXUB operand[, operand]

PBXB64-Verwendung

PMAXUB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMAXUB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMAXUD - Maximal gepackte vorzeichenlose Doppelwörter - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PMAXUD - Maximal gepackte vorzeichenlose Doppelwörter
Hilfe zum PBXB64-Compiler

PMAXUD - Maximal gepackte vorzeichenlose Doppelwörter

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMAXUD - Maximal gepackte vorzeichenlose Doppelwörter. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PMAXUD xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pmaxud xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmaxud xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMAXUD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMAXUD operand[, operand]

PBXB64-Verwendung

PMAXUD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMAXUD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMAXUW - Maximal gepackte Wörter ohne Vorzeichen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PMAXUW - Maximal gepackte Wörter ohne Vorzeichen
Hilfe zum PBXB64-Compiler

PMAXUW - Maximal gepackte Wörter ohne Vorzeichen

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMAXUW - Maximal gepackte Wörter ohne Vorzeichen. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PMAXUW xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pmaxuw xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmaxuw xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMAXUW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMAXUW operand[, operand]

PBXB64-Verwendung

PMAXUW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMAXUW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMINSD - Mindestens gepackte signierte Doppelwörter - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PMINSD - Mindestens gepackte signierte Doppelwörter
Hilfe zum PBXB64-Compiler

PMINSD - Mindestens gepackte signierte Doppelwörter

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMINSD - Mindestens gepackte signierte Doppelwörter. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PMINSD xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pminsd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pminsd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMINSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMINSD operand[, operand]

PBXB64-Verwendung

PMINSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMINSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMINSW - Mindestens gepackte vorzeichenbehaftete Wörter - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PMINSW - Mindestens gepackte vorzeichenbehaftete Wörter
Hilfe zum PBXB64-Compiler

PMINSW - Mindestens gepackte vorzeichenbehaftete Wörter

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMINSW - Mindestens gepackte vorzeichenbehaftete Wörter. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PMINSW xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pminsw xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pminsw xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMINSW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMINSW operand[, operand]

PBXB64-Verwendung

PMINSW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMINSW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMINUD - Mindestens gepackte, vorzeichenlose Doppelwörter - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PMINUD - Mindestens gepackte, vorzeichenlose Doppelwörter
Hilfe zum PBXB64-Compiler

PMINUD - Mindestens gepackte, vorzeichenlose Doppelwörter

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMINUD - Mindestens gepackte, vorzeichenlose Doppelwörter. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PMINUD xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pminud xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pminud xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMINUD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMINUD operand[, operand]

PBXB64-Verwendung

PMINUD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMINUD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMULDQ - Multiplizieren Sie gepackte vorzeichenbehaftete Doppelwörter zu Quadwörtern - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PMULDQ - Multiplizieren Sie gepackte vorzeichenbehaftete Doppelwörter zu Quadwörtern
Hilfe zum PBXB64-Compiler

PMULDQ - Multiplizieren Sie gepackte vorzeichenbehaftete Doppelwörter zu Quadwörtern

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMULDQ - Multiplizieren Sie gepackte vorzeichenbehaftete Doppelwörter zu Quadwörtern. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PMULDQ xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pmuldq xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmuldq xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMULDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMULDQ operand[, operand]

PBXB64-Verwendung

PMULDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMULDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMULHRSW - Verpackt mehrfach hoch mit Rundung und Skala - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PMULHRSW - Verpackt mehrfach hoch mit Rundung und Skala
Hilfe zum PBXB64-Compiler

PMULHRSW - Verpackt mehrfach hoch mit Rundung und Skala

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMULHRSW - Verpackt mehrfach hoch mit Rundung und Skala. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PMULHRSW xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pmulhrsw xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmulhrsw xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMULHRSW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMULHRSW operand[, operand]

PBXB64-Verwendung

PMULHRSW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMULHRSW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← PMULDQ - Multiplizieren Sie gepackte vorzeichenbehaftete Doppelwörter zu Quadwörtern Top PMULHUW - Mehrfach gepackte vorzeichenlose Wörter (hohe 16 Bit) →


PMULHUW - Mehrfach gepackte vorzeichenlose Wörter (hohe 16 Bit) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PMULHUW - Mehrfach gepackte vorzeichenlose Wörter (hohe 16 Bit)
Hilfe zum PBXB64-Compiler

PMULHUW - Mehrfach gepackte vorzeichenlose Wörter (hohe 16 Bit)

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMULHUW - Mehrfach gepackte vorzeichenlose Wörter (hohe 16 Bit). Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PMULHUW mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    pmulhuw [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmulhuw [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMULHUW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMULHUW operand[, operand]

PBXB64-Verwendung

PMULHUW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMULHUW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMULHW - Multiplizieren Sie gepackte Wörter (höhere 16 Bits des Produkts) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PMULHW - Multiplizieren Sie gepackte Wörter (höhere 16 Bits des Produkts)
Hilfe zum PBXB64-Compiler

PMULHW - Multiplizieren Sie gepackte Wörter (höhere 16 Bits des Produkts)

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMULHW - Multiplizieren Sie gepackte Wörter (höhere 16 Bits des Produkts). Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PMULHW mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    pmulhw [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmulhw [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMULHW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMULHW operand[, operand]

PBXB64-Verwendung

PMULHW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMULHW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMULLD - Mehrfach gepackte vorzeichenbehaftete Doppelwörter (niedrige 32 Bit) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PMULLD - Mehrfach gepackte vorzeichenbehaftete Doppelwörter (niedrige 32 Bit)
Hilfe zum PBXB64-Compiler

PMULLD - Mehrfach gepackte vorzeichenbehaftete Doppelwörter (niedrige 32 Bit)

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMULLD - Mehrfach gepackte vorzeichenbehaftete Doppelwörter (niedrige 32 Bit). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PMULLD xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pmulld xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmulld xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMULLD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMULLD operand[, operand]

PBXB64-Verwendung

PMULLD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMULLD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← PMULHW - Multiplizieren Sie gepackte Wörter (höhere 16 Bits des Produkts) Top PMULLW - Multiplizieren Sie gepackte Wörter (niedrige 16 Bits des Produkts) →


PMULLW - Multiplizieren Sie gepackte Wörter (niedrige 16 Bits des Produkts) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PMULLW - Multiplizieren Sie gepackte Wörter (niedrige 16 Bits des Produkts)
Hilfe zum PBXB64-Compiler

PMULLW - Multiplizieren Sie gepackte Wörter (niedrige 16 Bits des Produkts)

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMULLW - Multiplizieren Sie gepackte Wörter (niedrige 16 Bits des Produkts). Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PMULLW mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    pmullw [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmullw [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMULLW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMULLW operand[, operand]

PBXB64-Verwendung

PMULLW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMULLW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PSHUFB - Gepackte Bytes mischen (SSSE3) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSHUFB - Gepackte Bytes mischen (SSSE3)
Hilfe zum PBXB64-Compiler

PSHUFB - Gepackte Bytes mischen (SSSE3)

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSHUFB - Gepackte Bytes mischen (SSSE3). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PSHUFB xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pshufb xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pshufb xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSHUFB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSHUFB operand[, operand]

PBXB64-Verwendung

PSHUFB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSHUFB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PSHUFD - Mischen Sie gepackte Doppelwörter - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSHUFD - Mischen Sie gepackte Doppelwörter
Hilfe zum PBXB64-Compiler

PSHUFD - Mischen Sie gepackte Doppelwörter

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSHUFD - Mischen Sie gepackte Doppelwörter. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

PSHUFD xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pshufd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pshufd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSHUFD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSHUFD operand[, operand]

PBXB64-Verwendung

PSHUFD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSHUFD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PSHUFHW - Mischen Sie gepackte hohe Wörter - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSHUFHW - Mischen Sie gepackte hohe Wörter
Hilfe zum PBXB64-Compiler

PSHUFHW - Mischen Sie gepackte hohe Wörter

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSHUFHW - Mischen Sie gepackte hohe Wörter. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

PSHUFHW xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pshufhw xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pshufhw xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSHUFHW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSHUFHW operand[, operand]

PBXB64-Verwendung

PSHUFHW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSHUFHW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PSHUFLW - Mischen Sie gepackte niedrige Wörter - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSHUFLW - Mischen Sie gepackte niedrige Wörter
Hilfe zum PBXB64-Compiler

PSHUFLW - Mischen Sie gepackte niedrige Wörter

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSHUFLW - Mischen Sie gepackte niedrige Wörter. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

PSHUFLW xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    pshuflw xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pshuflw xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSHUFLW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSHUFLW operand[, operand]

PBXB64-Verwendung

PSHUFLW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSHUFLW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PSIGNB - Vorzeichen gepackter Bytes (negativ oder null) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSIGNB - Vorzeichen gepackter Bytes (negativ oder null)
Hilfe zum PBXB64-Compiler

PSIGNB - Vorzeichen gepackter Bytes (negativ oder null)

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSIGNB - Vorzeichen gepackter Bytes (negativ oder null). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PSIGNB xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    psignb xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! psignb xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSIGNB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSIGNB operand[, operand]

PBXB64-Verwendung

PSIGNB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSIGNB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PSIGND - Zeichen für gepackte Doppelwörter - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSIGND - Zeichen für gepackte Doppelwörter
Hilfe zum PBXB64-Compiler

PSIGND - Zeichen für gepackte Doppelwörter

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSIGND - Zeichen für gepackte Doppelwörter. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PSIGND xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    psignd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! psignd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSIGND ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSIGND operand[, operand]

PBXB64-Verwendung

PSIGND ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSIGND ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PSIGNW - Zeichen gepackter Wörter - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSIGNW - Zeichen gepackter Wörter
Hilfe zum PBXB64-Compiler

PSIGNW - Zeichen gepackter Wörter

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSIGNW - Zeichen gepackter Wörter. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PSIGNW xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    psignw xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! psignw xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSIGNW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSIGNW operand[, operand]

PBXB64-Verwendung

PSIGNW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSIGNW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PSLLD - Pack-Shift-Links-logische Doppelwörter - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSLLD - Pack-Shift-Links-logische Doppelwörter
Hilfe zum PBXB64-Compiler

PSLLD - Pack-Shift-Links-logische Doppelwörter

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSLLD - Pack-Shift-Links-logische Doppelwörter. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, imm8/mm.

Syntax

PSLLD mm, imm8/mm

Operands and Sizes

Form | Meaning
mm, imm8 | may read or write memory; uses an immediate control byte or value
mm | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    pslld operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pslld operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSLLD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSLLD operand[, operand]

PBXB64-Verwendung

PSLLD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSLLD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


PSLLQ - Packen Sie das logische Vierwort nach links - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSLLQ - Packen Sie das logische Vierwort nach links
Hilfe zum PBXB64-Compiler

PSLLQ - Packen Sie das logische Vierwort nach links

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSLLQ - Packen Sie das logische Vierwort nach links. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, imm8/mm.

Syntax

PSLLQ mm, imm8/mm

Operands and Sizes

Form | Meaning
mm, imm8 | may read or write memory; uses an immediate control byte or value
mm | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    psllq operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! psllq operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSLLQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSLLQ operand[, operand]

PBXB64-Verwendung

PSLLQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSLLQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


PSLLW - Pack verschiebt logische Wörter nach links - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSLLW - Pack verschiebt logische Wörter nach links
Hilfe zum PBXB64-Compiler

PSLLW - Pack verschiebt logische Wörter nach links

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSLLW - Pack verschiebt logische Wörter nach links. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, imm8/mm.

Syntax

PSLLW mm, imm8/mm

Operands and Sizes

Form | Meaning
mm, imm8 | may read or write memory; uses an immediate control byte or value
mm | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    psllw operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! psllw operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSLLW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSLLW operand[, operand]

PBXB64-Verwendung

PSLLW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSLLW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


PSRAD - Packen Sie arithmetische Doppelwörter mit Rechtsverschiebung - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSRAD - Packen Sie arithmetische Doppelwörter mit Rechtsverschiebung
Hilfe zum PBXB64-Compiler

PSRAD - Packen Sie arithmetische Doppelwörter mit Rechtsverschiebung

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSRAD - Packen Sie arithmetische Doppelwörter mit Rechtsverschiebung. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, imm8/mm.

Syntax

PSRAD mm, imm8/mm

Operands and Sizes

Form | Meaning
mm, imm8 | may read or write memory; uses an immediate control byte or value
mm | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    psrad operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! psrad operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSRAD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSRAD operand[, operand]

PBXB64-Verwendung

PSRAD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSRAD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PSRAW - Packen Sie arithmetische Wörter nach rechts - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSRAW - Packen Sie arithmetische Wörter nach rechts
Hilfe zum PBXB64-Compiler

PSRAW - Packen Sie arithmetische Wörter nach rechts

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSRAW - Packen Sie arithmetische Wörter nach rechts. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, imm8/mm.

Syntax

PSRAW mm, imm8/mm

Operands and Sizes

Form | Meaning
mm, imm8 | may read or write memory; uses an immediate control byte or value
mm | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    psraw operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! psraw operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSRAW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSRAW operand[, operand]

PBXB64-Verwendung

PSRAW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSRAW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PSRLD - Packen Sie logische Doppelwörter mit Rechtsverschiebung - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSRLD - Packen Sie logische Doppelwörter mit Rechtsverschiebung
Hilfe zum PBXB64-Compiler

PSRLD - Packen Sie logische Doppelwörter mit Rechtsverschiebung

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSRLD - Packen Sie logische Doppelwörter mit Rechtsverschiebung. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, imm8/mm.

Syntax

PSRLD mm, imm8/mm

Operands and Sizes

Form | Meaning
mm, imm8 | may read or write memory; uses an immediate control byte or value
mm | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    psrld operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! psrld operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSRLD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSRLD operand[, operand]

PBXB64-Verwendung

PSRLD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSRLD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PSRLQ - Packen Sie das logische Vierwort nach rechts - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSRLQ - Packen Sie das logische Vierwort nach rechts
Hilfe zum PBXB64-Compiler

PSRLQ - Packen Sie das logische Vierwort nach rechts

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSRLQ - Packen Sie das logische Vierwort nach rechts. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, imm8/mm.

Syntax

PSRLQ mm, imm8/mm

Operands and Sizes

Form | Meaning
mm, imm8 | may read or write memory; uses an immediate control byte or value
mm | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    psrlq operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! psrlq operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSRLQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSRLQ operand[, operand]

PBXB64-Verwendung

PSRLQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSRLQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PSRLW - Packen Sie logische Wörter nach rechts - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSRLW - Packen Sie logische Wörter nach rechts
Hilfe zum PBXB64-Compiler

PSRLW - Packen Sie logische Wörter nach rechts

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSRLW - Packen Sie logische Wörter nach rechts. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, imm8/mm.

Syntax

PSRLW mm, imm8/mm

Operands and Sizes

Form | Meaning
mm, imm8 | may read or write memory; uses an immediate control byte or value
mm | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    psrlw operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! psrlw operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSRLW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSRLW operand[, operand]

PBXB64-Verwendung

PSRLW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSRLW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PSUBB - Gepackte Bytes subtrahieren (Wrap) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSUBB - Gepackte Bytes subtrahieren (Wrap)
Hilfe zum PBXB64-Compiler

PSUBB - Gepackte Bytes subtrahieren (Wrap)

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSUBB - Gepackte Bytes subtrahieren (Wrap). Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PSUBB mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    psubb [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! psubb [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSUBB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSUBB operand[, operand]

PBXB64-Verwendung

PSUBB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSUBB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PSUBD - Gepackte Doppelwörter subtrahieren (Umbruch) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSUBD - Gepackte Doppelwörter subtrahieren (Umbruch)
Hilfe zum PBXB64-Compiler

PSUBD - Gepackte Doppelwörter subtrahieren (Umbruch)

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSUBD - Gepackte Doppelwörter subtrahieren (Umbruch). Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PSUBD mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    psubd [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! psubd [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSUBD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSUBD operand[, operand]

PBXB64-Verwendung

PSUBD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSUBD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PSUBQ - Subtrahieren Sie gepackte Quadword-Ganzzahlen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSUBQ - Subtrahieren Sie gepackte Quadword-Ganzzahlen
Hilfe zum PBXB64-Compiler

PSUBQ - Subtrahieren Sie gepackte Quadword-Ganzzahlen

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSUBQ - Subtrahieren Sie gepackte Quadword-Ganzzahlen. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PSUBQ xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    psubq xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! psubq xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSUBQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSUBQ operand[, operand]

PBXB64-Verwendung

PSUBQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSUBQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PSUBSB - Subtrahieren Sie gepackte Bytes mit vorzeichenbehafteter Sättigung - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSUBSB - Subtrahieren Sie gepackte Bytes mit vorzeichenbehafteter Sättigung
Hilfe zum PBXB64-Compiler

PSUBSB - Subtrahieren Sie gepackte Bytes mit vorzeichenbehafteter Sättigung

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSUBSB - Subtrahieren Sie gepackte Bytes mit vorzeichenbehafteter Sättigung. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PSUBSB mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    psubsb [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! psubsb [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSUBSB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSUBSB operand[, operand]

PBXB64-Verwendung

PSUBSB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSUBSB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PSUBSW - Subtrahieren Sie gepackte Wörter mit vorzeichenbehafteter Sättigung - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSUBSW - Subtrahieren Sie gepackte Wörter mit vorzeichenbehafteter Sättigung
Hilfe zum PBXB64-Compiler

PSUBSW - Subtrahieren Sie gepackte Wörter mit vorzeichenbehafteter Sättigung

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSUBSW - Subtrahieren Sie gepackte Wörter mit vorzeichenbehafteter Sättigung. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PSUBSW mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    psubsw [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! psubsw [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSUBSW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSUBSW operand[, operand]

PBXB64-Verwendung

PSUBSW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSUBSW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← PSUBSB - Subtrahieren Sie gepackte Bytes mit vorzeichenbehafteter Sättigung Top PSUBUSB - Subtrahieren Sie gepackte Bytes mit vorzeichenloser Sättigung →


PSUBUSB - Subtrahieren Sie gepackte Bytes mit vorzeichenloser Sättigung - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSUBUSB - Subtrahieren Sie gepackte Bytes mit vorzeichenloser Sättigung
Hilfe zum PBXB64-Compiler

PSUBUSB - Subtrahieren Sie gepackte Bytes mit vorzeichenloser Sättigung

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSUBUSB - Subtrahieren Sie gepackte Bytes mit vorzeichenloser Sättigung. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PSUBUSB mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    psubusb [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! psubusb [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSUBUSB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSUBUSB operand[, operand]

PBXB64-Verwendung

PSUBUSB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSUBUSB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← PSUBSW - Subtrahieren Sie gepackte Wörter mit vorzeichenbehafteter Sättigung Top PSUBUSW - Subtrahieren Sie gepackte Wörter mit vorzeichenloser Sättigung →


PSUBUSW - Subtrahieren Sie gepackte Wörter mit vorzeichenloser Sättigung - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSUBUSW - Subtrahieren Sie gepackte Wörter mit vorzeichenloser Sättigung
Hilfe zum PBXB64-Compiler

PSUBUSW - Subtrahieren Sie gepackte Wörter mit vorzeichenloser Sättigung

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSUBUSW - Subtrahieren Sie gepackte Wörter mit vorzeichenloser Sättigung. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PSUBUSW mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    psubusw [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! psubusw [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSUBUSW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSUBUSW operand[, operand]

PBXB64-Verwendung

PSUBUSW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSUBUSW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PSUBW - Gepackte Wörter subtrahieren (Umbruch) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PSUBW - Gepackte Wörter subtrahieren (Umbruch)
Hilfe zum PBXB64-Compiler

PSUBW - Gepackte Wörter subtrahieren (Umbruch)

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSUBW - Gepackte Wörter subtrahieren (Umbruch). Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PSUBW mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    psubw [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! psubw [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSUBW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSUBW operand[, operand]

PBXB64-Verwendung

PSUBW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSUBW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PTEST - Logischer Vergleich gepackter Ganzzahlen (setzt ZF/CF) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PTEST - Logischer Vergleich gepackter Ganzzahlen (setzt ZF/CF)
Hilfe zum PBXB64-Compiler

PTEST - Logischer Vergleich gepackter Ganzzahlen (setzt ZF/CF)

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PTEST - Logischer Vergleich gepackter Ganzzahlen (setzt ZF/CF). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PTEST xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    ptest xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! ptest xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PTEST ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PTEST operand[, operand]

PBXB64-Verwendung

PTEST ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PTEST ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PUNPCKHBW - Hohe Bytes entpacken (Interleave) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PUNPCKHBW - Hohe Bytes entpacken (Interleave)
Hilfe zum PBXB64-Compiler

PUNPCKHBW - Hohe Bytes entpacken (Interleave)

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PUNPCKHBW - Hohe Bytes entpacken (Interleave). Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PUNPCKHBW mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    punpckhbw [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! punpckhbw [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PUNPCKHBW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PUNPCKHBW operand[, operand]

PBXB64-Verwendung

PUNPCKHBW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PUNPCKHBW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PUNPCKHDQ - Hohe Doppelwörter auspacken - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PUNPCKHDQ - Hohe Doppelwörter auspacken
Hilfe zum PBXB64-Compiler

PUNPCKHDQ - Hohe Doppelwörter auspacken

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PUNPCKHDQ - Hohe Doppelwörter auspacken. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PUNPCKHDQ mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    punpckhdq [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! punpckhdq [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PUNPCKHDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PUNPCKHDQ operand[, operand]

PBXB64-Verwendung

PUNPCKHDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PUNPCKHDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PUNPCKHQDQ - Entpacken Sie hohe Quadwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PUNPCKHQDQ - Entpacken Sie hohe Quadwords
Hilfe zum PBXB64-Compiler

PUNPCKHQDQ - Entpacken Sie hohe Quadwords

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PUNPCKHQDQ - Entpacken Sie hohe Quadwords. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PUNPCKHQDQ xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    punpckhqdq xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! punpckhqdq xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PUNPCKHQDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PUNPCKHQDQ operand[, operand]

PBXB64-Verwendung

PUNPCKHQDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PUNPCKHQDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PUNPCKHWD - Packen Sie hohe Wörter aus - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PUNPCKHWD - Packen Sie hohe Wörter aus
Hilfe zum PBXB64-Compiler

PUNPCKHWD - Packen Sie hohe Wörter aus

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PUNPCKHWD - Packen Sie hohe Wörter aus. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PUNPCKHWD mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    punpckhwd [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! punpckhwd [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PUNPCKHWD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PUNPCKHWD operand[, operand]

PBXB64-Verwendung

PUNPCKHWD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PUNPCKHWD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PUNPCKLBW - Low-Bytes entpacken - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PUNPCKLBW - Low-Bytes entpacken
Hilfe zum PBXB64-Compiler

PUNPCKLBW - Low-Bytes entpacken

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PUNPCKLBW - Low-Bytes entpacken. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PUNPCKLBW mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    punpcklbw [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! punpcklbw [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PUNPCKLBW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PUNPCKLBW operand[, operand]

PBXB64-Verwendung

PUNPCKLBW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PUNPCKLBW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PUNPCKLDQ - Entpacken Sie niedrige Doppelwörter - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PUNPCKLDQ - Entpacken Sie niedrige Doppelwörter
Hilfe zum PBXB64-Compiler

PUNPCKLDQ - Entpacken Sie niedrige Doppelwörter

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PUNPCKLDQ - Entpacken Sie niedrige Doppelwörter. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PUNPCKLDQ mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    punpckldq [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! punpckldq [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PUNPCKLDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PUNPCKLDQ operand[, operand]

PBXB64-Verwendung

PUNPCKLDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PUNPCKLDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PUNPCKLQDQ - Entpacken Sie niedrige Quadwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PUNPCKLQDQ - Entpacken Sie niedrige Quadwords
Hilfe zum PBXB64-Compiler

PUNPCKLQDQ - Entpacken Sie niedrige Quadwords

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PUNPCKLQDQ - Entpacken Sie niedrige Quadwords. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PUNPCKLQDQ xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    punpcklqdq xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! punpcklqdq xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PUNPCKLQDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PUNPCKLQDQ operand[, operand]

PBXB64-Verwendung

PUNPCKLQDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PUNPCKLQDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PUNPCKLWD - Packen Sie niedrige Wörter aus - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › PUNPCKLWD - Packen Sie niedrige Wörter aus
Hilfe zum PBXB64-Compiler

PUNPCKLWD - Packen Sie niedrige Wörter aus

Category: Shuffle / Permute

Assembly Group: MMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PUNPCKLWD - Packen Sie niedrige Wörter aus. Diese Instruktion gehoert zur MMX-Familie und verwendet die dokumentierten Operandenformen mm, mm/mem64.

Syntax

PUNPCKLWD mm, mm/mem64

Operands and Sizes

Form | Meaning
mm, mm | may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    punpcklwd [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! punpcklwd [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_mmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PUNPCKLWD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PUNPCKLWD operand[, operand]

PBXB64-Verwendung

PUNPCKLWD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PUNPCKLWD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • MMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RCPPS - Reziprok gepacktes Single (ungefähr) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › RCPPS - Reziprok gepacktes Single (ungefähr)
Hilfe zum PBXB64-Compiler

RCPPS - Reziprok gepacktes Single (ungefähr)

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

RCPPS - Reziprok gepacktes Single (ungefähr). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

RCPPS xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    rcpps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! rcpps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

RCPPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

RCPPS operand[, operand]

PBXB64-Verwendung

RCPPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! RCPPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ROUNDPD - Rund verpackt, doppelt - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › ROUNDPD - Rund verpackt, doppelt
Hilfe zum PBXB64-Compiler

ROUNDPD - Rund verpackt, doppelt

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

ROUNDPD - Rund verpackt, doppelt. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

ROUNDPD xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    roundpd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! roundpd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

ROUNDPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

ROUNDPD operand[, operand]

PBXB64-Verwendung

ROUNDPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! ROUNDPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ROUNDPS - Rund verpackte Single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › ROUNDPS - Rund verpackte Single
Hilfe zum PBXB64-Compiler

ROUNDPS - Rund verpackte Single

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

ROUNDPS - Rund verpackte Single. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

ROUNDPS xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    roundps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! roundps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

ROUNDPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

ROUNDPS operand[, operand]

PBXB64-Verwendung

ROUNDPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! ROUNDPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RSQRTPS - Reziproke Quadratwurzel gepackte Einzelzahl (ungefähr) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › RSQRTPS - Reziproke Quadratwurzel gepackte Einzelzahl (ungefähr)
Hilfe zum PBXB64-Compiler

RSQRTPS - Reziproke Quadratwurzel gepackte Einzelzahl (ungefähr)

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

RSQRTPS - Reziproke Quadratwurzel gepackte Einzelzahl (ungefähr). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

RSQRTPS xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    rsqrtps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! rsqrtps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

RSQRTPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

RSQRTPS operand[, operand]

PBXB64-Verwendung

RSQRTPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! RSQRTPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SHUFPD - Shuffle packed double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › SHUFPD - Shuffle packed double
Hilfe zum PBXB64-Compiler

SHUFPD - Shuffle packed double

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SHUFPD - Shuffle packed double. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

SHUFPD xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    shufpd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! shufpd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SHUFPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SHUFPD operand[, operand]

PBXB64-Verwendung

SHUFPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SHUFPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SHUFPS - Shuffle packed single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › SHUFPS - Shuffle packed single
Hilfe zum PBXB64-Compiler

SHUFPS - Shuffle packed single

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SHUFPS - Shuffle packed single. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

SHUFPS xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    shufps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! shufps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SHUFPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SHUFPS operand[, operand]

PBXB64-Verwendung

SHUFPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SHUFPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SQRTPD - Quadratwurzel doppelt gepackt - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › SQRTPD - Quadratwurzel doppelt gepackt
Hilfe zum PBXB64-Compiler

SQRTPD - Quadratwurzel doppelt gepackt

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SQRTPD - Quadratwurzel doppelt gepackt. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

SQRTPD xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    sqrtpd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! sqrtpd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SQRTPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SQRTPD operand[, operand]

PBXB64-Verwendung

SQRTPD ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SQRTPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SQRTPS - Quadratwurzelgepackte Single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › SQRTPS - Quadratwurzelgepackte Single
Hilfe zum PBXB64-Compiler

SQRTPS - Quadratwurzelgepackte Single

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SQRTPS - Quadratwurzelgepackte Single. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

SQRTPS xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    sqrtps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! sqrtps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SQRTPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SQRTPS operand[, operand]

PBXB64-Verwendung

SQRTPS ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SQRTPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SUBPD - Subtrahieren Sie das gepackte Doppel - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › SUBPD - Subtrahieren Sie das gepackte Doppel
Hilfe zum PBXB64-Compiler

SUBPD - Subtrahieren Sie das gepackte Doppel

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SUBPD - Subtrahieren Sie das gepackte Doppel. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

SUBPD xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    subpd xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! subpd xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SUBPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SUBPD operand[, operand]

PBXB64-Verwendung

SUBPD ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SUBPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UNPCKHPS - Unpack high packed single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › UNPCKHPS - Unpack high packed single
Hilfe zum PBXB64-Compiler

UNPCKHPS - Unpack high packed single

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

UNPCKHPS - Unpack high packed single. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

UNPCKHPS xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    unpckhps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! unpckhps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

UNPCKHPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

UNPCKHPS operand[, operand]

PBXB64-Verwendung

UNPCKHPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! UNPCKHPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UNPCKLPS - Unpack low packed single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › UNPCKLPS - Unpack low packed single
Hilfe zum PBXB64-Compiler

UNPCKLPS - Unpack low packed single

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

UNPCKLPS - Unpack low packed single. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

UNPCKLPS xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    unpcklps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! unpcklps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

UNPCKLPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

UNPCKLPS operand[, operand]

PBXB64-Verwendung

UNPCKLPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! UNPCKLPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VADDPD - Doppelpack hinzufügen (128/256) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VADDPD - Doppelpack hinzufügen (128/256)
Hilfe zum PBXB64-Compiler

VADDPD - Doppelpack hinzufügen (128/256)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VADDPD - Doppelpack hinzufügen (128/256). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VADDPD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vaddpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vaddpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VADDPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VADDPD operand[, operand]

PBXB64-Verwendung

VADDPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VADDPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VADDPS - Gepackte Single hinzufügen (128/256) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VADDPS - Gepackte Single hinzufügen (128/256)
Hilfe zum PBXB64-Compiler

VADDPS - Gepackte Single hinzufügen (128/256)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VADDPS - Gepackte Single hinzufügen (128/256). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VADDPS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vaddps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vaddps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VADDPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VADDPS operand[, operand]

PBXB64-Verwendung

VADDPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VADDPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VANDNPD - Bitwise AND-NOT of packed doubles - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VANDNPD - Bitwise AND-NOT of packed doubles
Hilfe zum PBXB64-Compiler

VANDNPD - Bitwise AND-NOT of packed doubles

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VANDNPD - Bitwise AND-NOT of packed doubles. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VANDNPD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vandnpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vandnpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VANDNPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VANDNPD operand[, operand]

PBXB64-Verwendung

VANDNPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VANDNPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VANDNPS - Bitwise AND-NOT of packed singles - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VANDNPS - Bitwise AND-NOT of packed singles
Hilfe zum PBXB64-Compiler

VANDNPS - Bitwise AND-NOT of packed singles

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VANDNPS - Bitwise AND-NOT of packed singles. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VANDNPS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vandnps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vandnps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VANDNPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VANDNPS operand[, operand]

PBXB64-Verwendung

VANDNPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VANDNPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VANDPD - Bitwise AND of packed doubles - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VANDPD - Bitwise AND of packed doubles
Hilfe zum PBXB64-Compiler

VANDPD - Bitwise AND of packed doubles

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VANDPD - Bitwise AND of packed doubles. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VANDPD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vandpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vandpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VANDPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VANDPD operand[, operand]

PBXB64-Verwendung

VANDPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VANDPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VANDPS - Bitwise AND of packed singles - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VANDPS - Bitwise AND of packed singles
Hilfe zum PBXB64-Compiler

VANDPS - Bitwise AND of packed singles

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VANDPS - Bitwise AND of packed singles. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VANDPS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vandps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vandps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VANDPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VANDPS operand[, operand]

PBXB64-Verwendung

VANDPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VANDPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VBLENDPD - Blend packed double (imm8) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VBLENDPD - Blend packed double (imm8)
Hilfe zum PBXB64-Compiler

VBLENDPD - Blend packed double (imm8)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VBLENDPD - Blend packed double (imm8). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem, imm8.

Syntax

VBLENDPD ymm/xmm, ymm/xmm, ymm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vblendpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vblendpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VBLENDPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VBLENDPD operand[, operand]

PBXB64-Verwendung

VBLENDPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VBLENDPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VBLENDPS - Blend packed single (imm8) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VBLENDPS - Blend packed single (imm8)
Hilfe zum PBXB64-Compiler

VBLENDPS - Blend packed single (imm8)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VBLENDPS - Blend packed single (imm8). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem, imm8.

Syntax

VBLENDPS ymm/xmm, ymm/xmm, ymm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vblendps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vblendps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VBLENDPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VBLENDPS operand[, operand]

PBXB64-Verwendung

VBLENDPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VBLENDPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VBLENDVPD - Variable blend packed double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VBLENDVPD - Variable blend packed double
Hilfe zum PBXB64-Compiler

VBLENDVPD - Variable blend packed double

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VBLENDVPD - Variable blend packed double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VBLENDVPD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vblendvpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vblendvpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VBLENDVPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VBLENDVPD operand[, operand]

PBXB64-Verwendung

VBLENDVPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VBLENDVPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VBLENDVPS - Variable blend packed single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VBLENDVPS - Variable blend packed single
Hilfe zum PBXB64-Compiler

VBLENDVPS - Variable blend packed single

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VBLENDVPS - Variable blend packed single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VBLENDVPS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vblendvps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vblendvps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VBLENDVPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VBLENDVPS operand[, operand]

PBXB64-Verwendung

VBLENDVPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VBLENDVPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCPH2PS - Convert half precision to packed single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VCPH2PS - Convert half precision to packed single
Hilfe zum PBXB64-Compiler

VCPH2PS - Convert half precision to packed single

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCPH2PS - Convert half precision to packed single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, xmm/mem.

Syntax

VCPH2PS ymm/xmm, xmm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcph2ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcph2ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCPH2PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCPH2PS operand[, operand]

PBXB64-Verwendung

VCPH2PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCPH2PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCVTDQ2PD - Convert packed dword to double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VCVTDQ2PD - Convert packed dword to double
Hilfe zum PBXB64-Compiler

VCVTDQ2PD - Convert packed dword to double

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCVTDQ2PD - Convert packed dword to double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, xmm/mem.

Syntax

VCVTDQ2PD ymm/xmm, xmm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcvtdq2pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcvtdq2pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCVTDQ2PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCVTDQ2PD operand[, operand]

PBXB64-Verwendung

VCVTDQ2PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCVTDQ2PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCVTDQ2PS - Convert packed dword to single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VCVTDQ2PS - Convert packed dword to single
Hilfe zum PBXB64-Compiler

VCVTDQ2PS - Convert packed dword to single

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCVTDQ2PS - Convert packed dword to single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/mem.

Syntax

VCVTDQ2PS ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcvtdq2ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcvtdq2ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCVTDQ2PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCVTDQ2PS operand[, operand]

PBXB64-Verwendung

VCVTDQ2PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCVTDQ2PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCVTPD2DQ - Convert packed double to dword - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VCVTPD2DQ - Convert packed double to dword
Hilfe zum PBXB64-Compiler

VCVTPD2DQ - Convert packed double to dword

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCVTPD2DQ - Convert packed double to dword. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm/mem.

Syntax

VCVTPD2DQ ymm/xmm, ymm/xmm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcvtpd2dq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcvtpd2dq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCVTPD2DQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCVTPD2DQ operand[, operand]

PBXB64-Verwendung

VCVTPD2DQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCVTPD2DQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCVTPD2PS - Convert packed double to single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VCVTPD2PS - Convert packed double to single
Hilfe zum PBXB64-Compiler

VCVTPD2PS - Convert packed double to single

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCVTPD2PS - Convert packed double to single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm/mem.

Syntax

VCVTPD2PS ymm/xmm, ymm/xmm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcvtpd2ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcvtpd2ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCVTPD2PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCVTPD2PS operand[, operand]

PBXB64-Verwendung

VCVTPD2PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCVTPD2PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCVTPS2DQ - Convert packed single to dword - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VCVTPS2DQ - Convert packed single to dword
Hilfe zum PBXB64-Compiler

VCVTPS2DQ - Convert packed single to dword

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCVTPS2DQ - Convert packed single to dword. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/mem.

Syntax

VCVTPS2DQ ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcvtps2dq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcvtps2dq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCVTPS2DQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCVTPS2DQ operand[, operand]

PBXB64-Verwendung

VCVTPS2DQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCVTPS2DQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCVTPS2PD - Convert packed single to double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VCVTPS2PD - Convert packed single to double
Hilfe zum PBXB64-Compiler

VCVTPS2PD - Convert packed single to double

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCVTPS2PD - Convert packed single to double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm/mem.

Syntax

VCVTPS2PD ymm/xmm, ymm/xmm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcvtps2pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcvtps2pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCVTPS2PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCVTPS2PD operand[, operand]

PBXB64-Verwendung

VCVTPS2PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCVTPS2PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCVTPS2PH - Convert packed single to half precision - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VCVTPS2PH - Convert packed single to half precision
Hilfe zum PBXB64-Compiler

VCVTPS2PH - Convert packed single to half precision

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCVTPS2PH - Convert packed single to half precision. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm/mem, ymm/xmm, imm8.

Syntax

VCVTPS2PH xmm/mem, ymm/xmm, imm8

Operands and Sizes

Form | Meaning
xmm | uses XMM vector/scalar registers; may read or write memory
mem, ymm | uses YMM vector registers; may read or write memory
xmm, imm8 | uses XMM vector/scalar registers; may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcvtps2ph ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcvtps2ph ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCVTPS2PH ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCVTPS2PH operand[, operand]

PBXB64-Verwendung

VCVTPS2PH ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCVTPS2PH ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCVTTPD2DQ - Truncate packed double to dword - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VCVTTPD2DQ - Truncate packed double to dword
Hilfe zum PBXB64-Compiler

VCVTTPD2DQ - Truncate packed double to dword

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCVTTPD2DQ - Truncate packed double to dword. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/mem.

Syntax

VCVTTPD2DQ ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcvttpd2dq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcvttpd2dq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCVTTPD2DQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCVTTPD2DQ operand[, operand]

PBXB64-Verwendung

VCVTTPD2DQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCVTTPD2DQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCVTTPS2DQ - Truncate packed single to dword - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VCVTTPS2DQ - Truncate packed single to dword
Hilfe zum PBXB64-Compiler

VCVTTPS2DQ - Truncate packed single to dword

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCVTTPS2DQ - Truncate packed single to dword. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/mem.

Syntax

VCVTTPS2DQ ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcvttps2dq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcvttps2dq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCVTTPS2DQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCVTTPS2DQ operand[, operand]

PBXB64-Verwendung

VCVTTPS2DQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCVTTPS2DQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VDBPSADBW - Doppelblockgepackte Summe von ABS-Diffs (Wörtern) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VDBPSADBW - Doppelblockgepackte Summe von ABS-Diffs (Wörtern)
Hilfe zum PBXB64-Compiler

VDBPSADBW - Doppelblockgepackte Summe von ABS-Diffs (Wörtern)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VDBPSADBW - Doppelblockgepackte Summe von ABS-Diffs (Wörtern). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem, imm8.

Syntax

VDBPSADBW zmm, zmm, zmm/mem, imm8

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vdbpsadbw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vdbpsadbw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VDBPSADBW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VDBPSADBW operand[, operand]

PBXB64-Verwendung

VDBPSADBW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VDBPSADBW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VDIVPD - Doppelt verpackt teilen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VDIVPD - Doppelt verpackt teilen
Hilfe zum PBXB64-Compiler

VDIVPD - Doppelt verpackt teilen

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VDIVPD - Doppelt verpackt teilen. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VDIVPD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vdivpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vdivpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VDIVPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VDIVPD operand[, operand]

PBXB64-Verwendung

VDIVPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VDIVPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VDIVPS - Teilweise einzeln verpackt - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VDIVPS - Teilweise einzeln verpackt
Hilfe zum PBXB64-Compiler

VDIVPS - Teilweise einzeln verpackt

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VDIVPS - Teilweise einzeln verpackt. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VDIVPS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vdivps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vdivps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VDIVPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VDIVPS operand[, operand]

PBXB64-Verwendung

VDIVPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VDIVPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VDPPD - Dot product packed double (imm8) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VDPPD - Dot product packed double (imm8)
Hilfe zum PBXB64-Compiler

VDPPD - Dot product packed double (imm8)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VDPPD - Dot product packed double (imm8). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/mem, imm8.

Syntax

VDPPD xmm, xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vdppd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vdppd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VDPPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VDPPD operand[, operand]

PBXB64-Verwendung

VDPPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VDPPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VDPPS - Dot product packed single (imm8) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VDPPS - Dot product packed single (imm8)
Hilfe zum PBXB64-Compiler

VDPPS - Dot product packed single (imm8)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VDPPS - Dot product packed single (imm8). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem, imm8.

Syntax

VDPPS ymm/xmm, ymm/xmm, ymm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vdpps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vdpps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VDPPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VDPPS operand[, operand]

PBXB64-Verwendung

VDPPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VDPPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VEXP2PD - Exponentielle Näherung zur Basis 2 (doppelt, gepackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VEXP2PD - Exponentielle Näherung zur Basis 2 (doppelt, gepackt)
Hilfe zum PBXB64-Compiler

VEXP2PD - Exponentielle Näherung zur Basis 2 (doppelt, gepackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VEXP2PD - Exponentielle Näherung zur Basis 2 (doppelt, gepackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VEXP2PD zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vexp2pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vexp2pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VEXP2PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VEXP2PD operand[, operand]

PBXB64-Verwendung

VEXP2PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VEXP2PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VEXP2PS - Exponentielle Näherung zur Basis 2 (einfach, gepackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VEXP2PS - Exponentielle Näherung zur Basis 2 (einfach, gepackt)
Hilfe zum PBXB64-Compiler

VEXP2PS - Exponentielle Näherung zur Basis 2 (einfach, gepackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VEXP2PS - Exponentielle Näherung zur Basis 2 (einfach, gepackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VEXP2PS zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vexp2ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vexp2ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VEXP2PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VEXP2PS operand[, operand]

PBXB64-Verwendung

VEXP2PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VEXP2PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFIXUPIMMPD - Verpacktes Doppel reparieren (NaN-Handhabung) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFIXUPIMMPD - Verpacktes Doppel reparieren (NaN-Handhabung)
Hilfe zum PBXB64-Compiler

VFIXUPIMMPD - Verpacktes Doppel reparieren (NaN-Handhabung)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFIXUPIMMPD - Verpacktes Doppel reparieren (NaN-Handhabung). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem, imm8.

Syntax

VFIXUPIMMPD zmm, zmm, zmm/mem, imm8

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfixupimmpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfixupimmpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFIXUPIMMPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFIXUPIMMPD operand[, operand]

PBXB64-Verwendung

VFIXUPIMMPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFIXUPIMMPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFIXUPIMMPS - Verpackte Single reparieren (NaN-Handhabung) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFIXUPIMMPS - Verpackte Single reparieren (NaN-Handhabung)
Hilfe zum PBXB64-Compiler

VFIXUPIMMPS - Verpackte Single reparieren (NaN-Handhabung)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFIXUPIMMPS - Verpackte Single reparieren (NaN-Handhabung). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem, imm8.

Syntax

VFIXUPIMMPS zmm, zmm, zmm/mem, imm8

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfixupimmps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfixupimmps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFIXUPIMMPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFIXUPIMMPS operand[, operand]

PBXB64-Verwendung

VFIXUPIMMPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFIXUPIMMPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMADD132PD - FMA: a*b+c (double, packed) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFMADD132PD - FMA: a*b+c (double, packed)
Hilfe zum PBXB64-Compiler

VFMADD132PD - FMA: a*b+c (double, packed)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMADD132PD - FMA: a*b+c (double, packed). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFMADD132PD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmadd132pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmadd132pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMADD132PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMADD132PD operand[, operand]

PBXB64-Verwendung

VFMADD132PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMADD132PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMADD132PS - FMA: a*b+c (single, packed) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFMADD132PS - FMA: a*b+c (single, packed)
Hilfe zum PBXB64-Compiler

VFMADD132PS - FMA: a*b+c (single, packed)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMADD132PS - FMA: a*b+c (single, packed). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFMADD132PS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmadd132ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmadd132ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMADD132PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMADD132PS operand[, operand]

PBXB64-Verwendung

VFMADD132PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMADD132PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMADD213PD - FMA: a*b+c (double, packed) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFMADD213PD - FMA: a*b+c (double, packed)
Hilfe zum PBXB64-Compiler

VFMADD213PD - FMA: a*b+c (double, packed)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMADD213PD - FMA: a*b+c (double, packed). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFMADD213PD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmadd213pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmadd213pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMADD213PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMADD213PD operand[, operand]

PBXB64-Verwendung

VFMADD213PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMADD213PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMADD213PS - FMA: a*b+c (single, packed) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFMADD213PS - FMA: a*b+c (single, packed)
Hilfe zum PBXB64-Compiler

VFMADD213PS - FMA: a*b+c (single, packed)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMADD213PS - FMA: a*b+c (single, packed). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFMADD213PS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmadd213ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmadd213ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMADD213PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMADD213PS operand[, operand]

PBXB64-Verwendung

VFMADD213PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMADD213PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMADD231PD - FMA: a*b+c (double, packed) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFMADD231PD - FMA: a*b+c (double, packed)
Hilfe zum PBXB64-Compiler

VFMADD231PD - FMA: a*b+c (double, packed)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMADD231PD - FMA: a*b+c (double, packed). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFMADD231PD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmadd231pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmadd231pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMADD231PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMADD231PD operand[, operand]

PBXB64-Verwendung

VFMADD231PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMADD231PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMADD231PS - FMA: a*b+c (single, packed) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFMADD231PS - FMA: a*b+c (single, packed)
Hilfe zum PBXB64-Compiler

VFMADD231PS - FMA: a*b+c (single, packed)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMADD231PS - FMA: a*b+c (single, packed). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFMADD231PS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmadd231ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmadd231ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMADD231PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMADD231PS operand[, operand]

PBXB64-Verwendung

VFMADD231PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMADD231PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMADDSUB132PD - FMA: a*b+c / a*b-c (alternierend, doppelt gepackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFMADDSUB132PD - FMA: a*b+c / a*b-c (alternierend, doppelt gepackt)
Hilfe zum PBXB64-Compiler

VFMADDSUB132PD - FMA: a*b+c / a*b-c (alternierend, doppelt gepackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMADDSUB132PD - FMA: a*b+c / a*b-c (alternierend, doppelt gepackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFMADDSUB132PD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmaddsub132pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmaddsub132pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMADDSUB132PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMADDSUB132PD operand[, operand]

PBXB64-Verwendung

VFMADDSUB132PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMADDSUB132PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMADDSUB132PS - FMA: a*b+c / a*b-c (abwechselnd, einzeln gepackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFMADDSUB132PS - FMA: a*b+c / a*b-c (abwechselnd, einzeln gepackt)
Hilfe zum PBXB64-Compiler

VFMADDSUB132PS - FMA: a*b+c / a*b-c (abwechselnd, einzeln gepackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMADDSUB132PS - FMA: a*b+c / a*b-c (abwechselnd, einzeln gepackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFMADDSUB132PS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmaddsub132ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmaddsub132ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMADDSUB132PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMADDSUB132PS operand[, operand]

PBXB64-Verwendung

VFMADDSUB132PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMADDSUB132PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMADDSUB213PD - FMA: a*b+c / a*b-c (alternierend, doppelt gepackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFMADDSUB213PD - FMA: a*b+c / a*b-c (alternierend, doppelt gepackt)
Hilfe zum PBXB64-Compiler

VFMADDSUB213PD - FMA: a*b+c / a*b-c (alternierend, doppelt gepackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMADDSUB213PD - FMA: a*b+c / a*b-c (alternierend, doppelt gepackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFMADDSUB213PD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmaddsub213pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmaddsub213pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMADDSUB213PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMADDSUB213PD operand[, operand]

PBXB64-Verwendung

VFMADDSUB213PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMADDSUB213PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMADDSUB213PS - FMA: a*b+c / a*b-c (abwechselnd, einzeln gepackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFMADDSUB213PS - FMA: a*b+c / a*b-c (abwechselnd, einzeln gepackt)
Hilfe zum PBXB64-Compiler

VFMADDSUB213PS - FMA: a*b+c / a*b-c (abwechselnd, einzeln gepackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMADDSUB213PS - FMA: a*b+c / a*b-c (abwechselnd, einzeln gepackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFMADDSUB213PS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmaddsub213ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmaddsub213ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMADDSUB213PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMADDSUB213PS operand[, operand]

PBXB64-Verwendung

VFMADDSUB213PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMADDSUB213PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMADDSUB231PD - FMA: a*b+c / a*b-c (alternierend, doppelt gepackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFMADDSUB231PD - FMA: a*b+c / a*b-c (alternierend, doppelt gepackt)
Hilfe zum PBXB64-Compiler

VFMADDSUB231PD - FMA: a*b+c / a*b-c (alternierend, doppelt gepackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMADDSUB231PD - FMA: a*b+c / a*b-c (alternierend, doppelt gepackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFMADDSUB231PD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmaddsub231pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmaddsub231pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMADDSUB231PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMADDSUB231PD operand[, operand]

PBXB64-Verwendung

VFMADDSUB231PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMADDSUB231PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMADDSUB231PS - FMA: a*b+c / a*b-c (abwechselnd, einzeln gepackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFMADDSUB231PS - FMA: a*b+c / a*b-c (abwechselnd, einzeln gepackt)
Hilfe zum PBXB64-Compiler

VFMADDSUB231PS - FMA: a*b+c / a*b-c (abwechselnd, einzeln gepackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMADDSUB231PS - FMA: a*b+c / a*b-c (abwechselnd, einzeln gepackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFMADDSUB231PS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmaddsub231ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmaddsub231ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMADDSUB231PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMADDSUB231PS operand[, operand]

PBXB64-Verwendung

VFMADDSUB231PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMADDSUB231PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMSUB132PD - FMA: a*b-c (double, packed) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFMSUB132PD - FMA: a*b-c (double, packed)
Hilfe zum PBXB64-Compiler

VFMSUB132PD - FMA: a*b-c (double, packed)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMSUB132PD - FMA: a*b-c (double, packed). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFMSUB132PD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmsub132pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmsub132pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMSUB132PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMSUB132PD operand[, operand]

PBXB64-Verwendung

VFMSUB132PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMSUB132PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMSUB132PS - FMA: a*b-c (single, packed) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFMSUB132PS - FMA: a*b-c (single, packed)
Hilfe zum PBXB64-Compiler

VFMSUB132PS - FMA: a*b-c (single, packed)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMSUB132PS - FMA: a*b-c (single, packed). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFMSUB132PS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmsub132ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmsub132ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMSUB132PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMSUB132PS operand[, operand]

PBXB64-Verwendung

VFMSUB132PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMSUB132PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMSUB213PD - FMA: a*b-c (double, packed) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFMSUB213PD - FMA: a*b-c (double, packed)
Hilfe zum PBXB64-Compiler

VFMSUB213PD - FMA: a*b-c (double, packed)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMSUB213PD - FMA: a*b-c (double, packed). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFMSUB213PD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmsub213pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmsub213pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMSUB213PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMSUB213PD operand[, operand]

PBXB64-Verwendung

VFMSUB213PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMSUB213PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMSUB213PS - FMA: a*b-c (single, packed) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFMSUB213PS - FMA: a*b-c (single, packed)
Hilfe zum PBXB64-Compiler

VFMSUB213PS - FMA: a*b-c (single, packed)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMSUB213PS - FMA: a*b-c (single, packed). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFMSUB213PS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmsub213ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmsub213ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMSUB213PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMSUB213PS operand[, operand]

PBXB64-Verwendung

VFMSUB213PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMSUB213PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMSUB231PD - FMA: a*b-c (double, packed) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFMSUB231PD - FMA: a*b-c (double, packed)
Hilfe zum PBXB64-Compiler

VFMSUB231PD - FMA: a*b-c (double, packed)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMSUB231PD - FMA: a*b-c (double, packed). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFMSUB231PD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmsub231pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmsub231pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMSUB231PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMSUB231PD operand[, operand]

PBXB64-Verwendung

VFMSUB231PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMSUB231PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMSUB231PS - FMA: a*b-c (single, packed) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFMSUB231PS - FMA: a*b-c (single, packed)
Hilfe zum PBXB64-Compiler

VFMSUB231PS - FMA: a*b-c (single, packed)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMSUB231PS - FMA: a*b-c (single, packed). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFMSUB231PS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmsub231ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmsub231ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMSUB231PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMSUB231PS operand[, operand]

PBXB64-Verwendung

VFMSUB231PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMSUB231PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMADD132PD - FMA: -(a*b)+c (doppelt, gepackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFNMADD132PD - FMA: -(a*b)+c (doppelt, gepackt)
Hilfe zum PBXB64-Compiler

VFNMADD132PD - FMA: -(a*b)+c (doppelt, gepackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMADD132PD - FMA: -(a*b)+c (doppelt, gepackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFNMADD132PD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmadd132pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmadd132pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMADD132PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMADD132PD operand[, operand]

PBXB64-Verwendung

VFNMADD132PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMADD132PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMADD132PS - FMA: -(a*b)+c (einzeln, verpackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFNMADD132PS - FMA: -(a*b)+c (einzeln, verpackt)
Hilfe zum PBXB64-Compiler

VFNMADD132PS - FMA: -(a*b)+c (einzeln, verpackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMADD132PS - FMA: -(a*b)+c (einzeln, verpackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFNMADD132PS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmadd132ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmadd132ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMADD132PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMADD132PS operand[, operand]

PBXB64-Verwendung

VFNMADD132PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMADD132PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMADD213PD - FMA: -(a*b)+c (doppelt, gepackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFNMADD213PD - FMA: -(a*b)+c (doppelt, gepackt)
Hilfe zum PBXB64-Compiler

VFNMADD213PD - FMA: -(a*b)+c (doppelt, gepackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMADD213PD - FMA: -(a*b)+c (doppelt, gepackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFNMADD213PD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmadd213pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmadd213pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMADD213PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMADD213PD operand[, operand]

PBXB64-Verwendung

VFNMADD213PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMADD213PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMADD213PS - FMA: -(a*b)+c (einzeln, verpackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFNMADD213PS - FMA: -(a*b)+c (einzeln, verpackt)
Hilfe zum PBXB64-Compiler

VFNMADD213PS - FMA: -(a*b)+c (einzeln, verpackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMADD213PS - FMA: -(a*b)+c (einzeln, verpackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFNMADD213PS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmadd213ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmadd213ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMADD213PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMADD213PS operand[, operand]

PBXB64-Verwendung

VFNMADD213PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMADD213PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMADD231PD - FMA: -(a*b)+c (doppelt, gepackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFNMADD231PD - FMA: -(a*b)+c (doppelt, gepackt)
Hilfe zum PBXB64-Compiler

VFNMADD231PD - FMA: -(a*b)+c (doppelt, gepackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMADD231PD - FMA: -(a*b)+c (doppelt, gepackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFNMADD231PD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmadd231pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmadd231pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMADD231PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMADD231PD operand[, operand]

PBXB64-Verwendung

VFNMADD231PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMADD231PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMADD231PS - FMA: -(a*b)+c (einzeln, verpackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFNMADD231PS - FMA: -(a*b)+c (einzeln, verpackt)
Hilfe zum PBXB64-Compiler

VFNMADD231PS - FMA: -(a*b)+c (einzeln, verpackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMADD231PS - FMA: -(a*b)+c (einzeln, verpackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFNMADD231PS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmadd231ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmadd231ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMADD231PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMADD231PS operand[, operand]

PBXB64-Verwendung

VFNMADD231PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMADD231PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMSUB132PD - FMA: -(a*b)-c (doppelt, gepackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFNMSUB132PD - FMA: -(a*b)-c (doppelt, gepackt)
Hilfe zum PBXB64-Compiler

VFNMSUB132PD - FMA: -(a*b)-c (doppelt, gepackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMSUB132PD - FMA: -(a*b)-c (doppelt, gepackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFNMSUB132PD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmsub132pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmsub132pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMSUB132PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMSUB132PD operand[, operand]

PBXB64-Verwendung

VFNMSUB132PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMSUB132PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMSUB132PS - FMA: -(a*b)-c (einzeln, verpackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFNMSUB132PS - FMA: -(a*b)-c (einzeln, verpackt)
Hilfe zum PBXB64-Compiler

VFNMSUB132PS - FMA: -(a*b)-c (einzeln, verpackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMSUB132PS - FMA: -(a*b)-c (einzeln, verpackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFNMSUB132PS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmsub132ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmsub132ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMSUB132PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMSUB132PS operand[, operand]

PBXB64-Verwendung

VFNMSUB132PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMSUB132PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMSUB213PD - FMA: -(a*b)-c (doppelt, gepackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFNMSUB213PD - FMA: -(a*b)-c (doppelt, gepackt)
Hilfe zum PBXB64-Compiler

VFNMSUB213PD - FMA: -(a*b)-c (doppelt, gepackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMSUB213PD - FMA: -(a*b)-c (doppelt, gepackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFNMSUB213PD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmsub213pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmsub213pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMSUB213PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMSUB213PD operand[, operand]

PBXB64-Verwendung

VFNMSUB213PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMSUB213PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMSUB213PS - FMA: -(a*b)-c (einzeln, verpackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFNMSUB213PS - FMA: -(a*b)-c (einzeln, verpackt)
Hilfe zum PBXB64-Compiler

VFNMSUB213PS - FMA: -(a*b)-c (einzeln, verpackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMSUB213PS - FMA: -(a*b)-c (einzeln, verpackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFNMSUB213PS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmsub213ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmsub213ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMSUB213PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMSUB213PS operand[, operand]

PBXB64-Verwendung

VFNMSUB213PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMSUB213PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMSUB231PD - FMA: -(a*b)-c (doppelt, gepackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFNMSUB231PD - FMA: -(a*b)-c (doppelt, gepackt)
Hilfe zum PBXB64-Compiler

VFNMSUB231PD - FMA: -(a*b)-c (doppelt, gepackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMSUB231PD - FMA: -(a*b)-c (doppelt, gepackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFNMSUB231PD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmsub231pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmsub231pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMSUB231PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMSUB231PD operand[, operand]

PBXB64-Verwendung

VFNMSUB231PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMSUB231PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMSUB231PS - FMA: -(a*b)-c (einzeln, verpackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VFNMSUB231PS - FMA: -(a*b)-c (einzeln, verpackt)
Hilfe zum PBXB64-Compiler

VFNMSUB231PS - FMA: -(a*b)-c (einzeln, verpackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMSUB231PS - FMA: -(a*b)-c (einzeln, verpackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VFNMSUB231PS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmsub231ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmsub231ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMSUB231PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMSUB231PS operand[, operand]

PBXB64-Verwendung

VFNMSUB231PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMSUB231PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMAXPD - Maximal doppelt bepackt - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VMAXPD - Maximal doppelt bepackt
Hilfe zum PBXB64-Compiler

VMAXPD - Maximal doppelt bepackt

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMAXPD - Maximal doppelt bepackt. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VMAXPD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmaxpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmaxpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMAXPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMAXPD operand[, operand]

PBXB64-Verwendung

VMAXPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMAXPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMAXPS - Maximal gepacktes Einzelstück - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VMAXPS - Maximal gepacktes Einzelstück
Hilfe zum PBXB64-Compiler

VMAXPS - Maximal gepacktes Einzelstück

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMAXPS - Maximal gepacktes Einzelstück. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VMAXPS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmaxps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmaxps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMAXPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMAXPS operand[, operand]

PBXB64-Verwendung

VMAXPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMAXPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMINPD - Mindestens doppelt verpackt - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VMINPD - Mindestens doppelt verpackt
Hilfe zum PBXB64-Compiler

VMINPD - Mindestens doppelt verpackt

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMINPD - Mindestens doppelt verpackt. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VMINPD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vminpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vminpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMINPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMINPD operand[, operand]

PBXB64-Verwendung

VMINPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMINPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMINPS - Mindestens einzeln verpackt - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VMINPS - Mindestens einzeln verpackt
Hilfe zum PBXB64-Compiler

VMINPS - Mindestens einzeln verpackt

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMINPS - Mindestens einzeln verpackt. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VMINPS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vminps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vminps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMINPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMINPS operand[, operand]

PBXB64-Verwendung

VMINPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMINPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVAPS - Verschieben Sie ausgerichtete verpackte Einzelstücke - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VMOVAPS - Verschieben Sie ausgerichtete verpackte Einzelstücke
Hilfe zum PBXB64-Compiler

VMOVAPS - Verschieben Sie ausgerichtete verpackte Einzelstücke

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVAPS - Verschieben Sie ausgerichtete verpackte Einzelstücke. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, mem / mem, ymm/xmm.

Syntax

VMOVAPS ymm/xmm, mem / mem, ymm/xmm

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, mem | uses XMM vector/scalar registers; may read or write memory
mem, ymm | uses YMM vector registers; may read or write memory
xmm | uses XMM vector/scalar registers; may read or write memory

Aligned memory forms require the alignment documented by the instruction family, commonly 16-byte alignment for 128-bit SSE packed operands.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovaps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovaps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVAPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVAPS operand[, operand]

PBXB64-Verwendung

VMOVAPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVAPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMULPD - Mehrfach gepacktes Doppeltes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VMULPD - Mehrfach gepacktes Doppeltes
Hilfe zum PBXB64-Compiler

VMULPD - Mehrfach gepacktes Doppeltes

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMULPD - Mehrfach gepacktes Doppeltes. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VMULPD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmulpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmulpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMULPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMULPD operand[, operand]

PBXB64-Verwendung

VMULPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMULPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMULPS - Mehrfach gepackte Single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VMULPS - Mehrfach gepackte Single
Hilfe zum PBXB64-Compiler

VMULPS - Mehrfach gepackte Single

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMULPS - Mehrfach gepackte Single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VMULPS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmulps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmulps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMULPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMULPS operand[, operand]

PBXB64-Verwendung

VMULPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMULPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VORPD - Bitwise OR of packed doubles - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VORPD - Bitwise OR of packed doubles
Hilfe zum PBXB64-Compiler

VORPD - Bitwise OR of packed doubles

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VORPD - Bitwise OR of packed doubles. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VORPD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vorpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vorpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VORPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VORPD operand[, operand]

PBXB64-Verwendung

VORPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VORPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VORPS - Bitwise OR of packed singles - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VORPS - Bitwise OR of packed singles
Hilfe zum PBXB64-Compiler

VORPS - Bitwise OR of packed singles

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VORPS - Bitwise OR of packed singles. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VORPS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vorps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vorps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VORPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VORPS operand[, operand]

PBXB64-Verwendung

VORPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VORPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPALIGNR - Align right (concatenate and shift, imm8) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPALIGNR - Align right (concatenate and shift, imm8)
Hilfe zum PBXB64-Compiler

VPALIGNR - Align right (concatenate and shift, imm8)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPALIGNR - Align right (concatenate and shift, imm8). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem, imm8.

Syntax

VPALIGNR ymm/xmm, ymm/xmm, ymm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpalignr ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpalignr ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPALIGNR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPALIGNR operand[, operand]

PBXB64-Verwendung

VPALIGNR ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPALIGNR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPBLENDVB - Variable blend packed bytes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPBLENDVB - Variable blend packed bytes
Hilfe zum PBXB64-Compiler

VPBLENDVB - Variable blend packed bytes

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPBLENDVB - Variable blend packed bytes. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPBLENDVB ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpblendvb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpblendvb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPBLENDVB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPBLENDVB operand[, operand]

PBXB64-Verwendung

VPBLENDVB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPBLENDVB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPBLENDW - Blend packed words (imm8) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPBLENDW - Blend packed words (imm8)
Hilfe zum PBXB64-Compiler

VPBLENDW - Blend packed words (imm8)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPBLENDW - Blend packed words (imm8). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem, imm8.

Syntax

VPBLENDW ymm/xmm, ymm/xmm, ymm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpblendw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpblendw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPBLENDW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPBLENDW operand[, operand]

PBXB64-Verwendung

VPBLENDW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPBLENDW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPCOMPRESSD - Komprimieren Sie gepackte Dwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPCOMPRESSD - Komprimieren Sie gepackte Dwords
Hilfe zum PBXB64-Compiler

VPCOMPRESSD - Komprimieren Sie gepackte Dwords

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPCOMPRESSD - Komprimieren Sie gepackte Dwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VPCOMPRESSD zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpcompressd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpcompressd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPCOMPRESSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPCOMPRESSD operand[, operand]

PBXB64-Verwendung

VPCOMPRESSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPCOMPRESSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


VPCOMPRESSQ - Komprimieren Sie gepackte Qwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPCOMPRESSQ - Komprimieren Sie gepackte Qwords
Hilfe zum PBXB64-Compiler

VPCOMPRESSQ - Komprimieren Sie gepackte Qwords

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPCOMPRESSQ - Komprimieren Sie gepackte Qwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VPCOMPRESSQ zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpcompressq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpcompressq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPCOMPRESSQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPCOMPRESSQ operand[, operand]

PBXB64-Verwendung

VPCOMPRESSQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPCOMPRESSQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


VPERM2F128 - Permute 128-bit lanes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPERM2F128 - Permute 128-bit lanes
Hilfe zum PBXB64-Compiler

VPERM2F128 - Permute 128-bit lanes

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERM2F128 - Permute 128-bit lanes. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm, ymm, ymm/mem, imm8.

Syntax

VPERM2F128 ymm, ymm, ymm/mem, imm8

Operands and Sizes

Form | Meaning
ymm, ymm, ymm | uses YMM vector registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vperm2f128 ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vperm2f128 ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERM2F128 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERM2F128 operand[, operand]

PBXB64-Verwendung

VPERM2F128 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERM2F128 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPERM2I128 - Permute 128-bit integer lanes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPERM2I128 - Permute 128-bit integer lanes
Hilfe zum PBXB64-Compiler

VPERM2I128 - Permute 128-bit integer lanes

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERM2I128 - Permute 128-bit integer lanes. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm, ymm, ymm/mem, imm8.

Syntax

VPERM2I128 ymm, ymm, ymm/mem, imm8

Operands and Sizes

Form | Meaning
ymm, ymm, ymm | uses YMM vector registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vperm2i128 ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vperm2i128 ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERM2I128 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERM2I128 operand[, operand]

PBXB64-Verwendung

VPERM2I128 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERM2I128 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPERMD - Permute doublewords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPERMD - Permute doublewords
Hilfe zum PBXB64-Compiler

VPERMD - Permute doublewords

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERMD - Permute doublewords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm, ymm, ymm/mem.

Syntax

VPERMD ymm, ymm, ymm/mem

Operands and Sizes

Form | Meaning
ymm, ymm, ymm | uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpermd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpermd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERMD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERMD operand[, operand]

PBXB64-Verwendung

VPERMD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERMD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPERMIL2PD - Two-source permute of doubles - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPERMIL2PD - Two-source permute of doubles
Hilfe zum PBXB64-Compiler

VPERMIL2PD - Two-source permute of doubles

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERMIL2PD - Two-source permute of doubles. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem, imm4.

Syntax

VPERMIL2PD ymm/xmm, ymm/xmm, ymm/mem, imm4

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem, imm4 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpermil2pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpermil2pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERMIL2PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERMIL2PD operand[, operand]

PBXB64-Verwendung

VPERMIL2PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERMIL2PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPERMIL2PS - Two-source permute of singles - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPERMIL2PS - Two-source permute of singles
Hilfe zum PBXB64-Compiler

VPERMIL2PS - Two-source permute of singles

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERMIL2PS - Two-source permute of singles. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem, imm4.

Syntax

VPERMIL2PS ymm/xmm, ymm/xmm, ymm/mem, imm4

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem, imm4 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpermil2ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpermil2ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERMIL2PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERMIL2PS operand[, operand]

PBXB64-Verwendung

VPERMIL2PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERMIL2PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPERMILPD - Permute in-lane packed double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPERMILPD - Permute in-lane packed double
Hilfe zum PBXB64-Compiler

VPERMILPD - Permute in-lane packed double

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERMILPD - Permute in-lane packed double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/mem, imm8.

Syntax

VPERMILPD ymm/xmm, ymm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpermilpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpermilpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERMILPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERMILPD operand[, operand]

PBXB64-Verwendung

VPERMILPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERMILPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPERMILPS - Permute in-lane packed single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPERMILPS - Permute in-lane packed single
Hilfe zum PBXB64-Compiler

VPERMILPS - Permute in-lane packed single

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERMILPS - Permute in-lane packed single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/mem, imm8.

Syntax

VPERMILPS ymm/xmm, ymm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpermilps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpermilps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERMILPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERMILPS operand[, operand]

PBXB64-Verwendung

VPERMILPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERMILPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPERMPD - Permute double-precision floats - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPERMPD - Permute double-precision floats
Hilfe zum PBXB64-Compiler

VPERMPD - Permute double-precision floats

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERMPD - Permute double-precision floats. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm, ymm, ymm/mem, imm8.

Syntax

VPERMPD ymm, ymm, ymm/mem, imm8

Operands and Sizes

Form | Meaning
ymm, ymm, ymm | uses YMM vector registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpermpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpermpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERMPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERMPD operand[, operand]

PBXB64-Verwendung

VPERMPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERMPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPERMPS - Permute single-precision floats - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPERMPS - Permute single-precision floats
Hilfe zum PBXB64-Compiler

VPERMPS - Permute single-precision floats

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERMPS - Permute single-precision floats. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm, ymm, ymm/mem.

Syntax

VPERMPS ymm, ymm, ymm/mem

Operands and Sizes

Form | Meaning
ymm, ymm, ymm | uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpermps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpermps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERMPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERMPS operand[, operand]

PBXB64-Verwendung

VPERMPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERMPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPERMQ - Permute quadwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPERMQ - Permute quadwords
Hilfe zum PBXB64-Compiler

VPERMQ - Permute quadwords

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERMQ - Permute quadwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm, ymm/mem, imm8.

Syntax

VPERMQ ymm, ymm/mem, imm8

Operands and Sizes

Form | Meaning
ymm, ymm | uses YMM vector registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpermq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpermq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERMQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERMQ operand[, operand]

PBXB64-Verwendung

VPERMQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERMQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPEXPANDD - Erweitern Sie gepackte Dwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPEXPANDD - Erweitern Sie gepackte Dwords
Hilfe zum PBXB64-Compiler

VPEXPANDD - Erweitern Sie gepackte Dwords

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPEXPANDD - Erweitern Sie gepackte Dwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VPEXPANDD zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpexpandd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpexpandd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPEXPANDD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPEXPANDD operand[, operand]

PBXB64-Verwendung

VPEXPANDD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPEXPANDD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPEXPANDQ - Erweitern Sie gepackte Qwords - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPEXPANDQ - Erweitern Sie gepackte Qwords
Hilfe zum PBXB64-Compiler

VPEXPANDQ - Erweitern Sie gepackte Qwords

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPEXPANDQ - Erweitern Sie gepackte Qwords. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VPEXPANDQ zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpexpandq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpexpandq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPEXPANDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPEXPANDQ operand[, operand]

PBXB64-Verwendung

VPEXPANDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPEXPANDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVDB - Packen und kürzen Sie Dwords in Bytes (schmal) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPMOVDB - Packen und kürzen Sie Dwords in Bytes (schmal)
Hilfe zum PBXB64-Compiler

VPMOVDB - Packen und kürzen Sie Dwords in Bytes (schmal)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVDB - Packen und kürzen Sie Dwords in Bytes (schmal). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen mem, zmm / xmm, zmm.

Syntax

VPMOVDB mem, zmm / xmm, zmm

Operands and Sizes

Form | Meaning
mem, zmm | may read or write memory
xmm, zmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovdb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovdb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVDB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVDB operand[, operand]

PBXB64-Verwendung

VPMOVDB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVDB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVDW - Packen und kürzen Sie Dwords in Wörter (schmal) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPMOVDW - Packen und kürzen Sie Dwords in Wörter (schmal)
Hilfe zum PBXB64-Compiler

VPMOVDW - Packen und kürzen Sie Dwords in Wörter (schmal)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVDW - Packen und kürzen Sie Dwords in Wörter (schmal). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen mem, zmm / xmm, zmm.

Syntax

VPMOVDW mem, zmm / xmm, zmm

Operands and Sizes

Form | Meaning
mem, zmm | may read or write memory
xmm, zmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovdw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovdw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVDW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVDW operand[, operand]

PBXB64-Verwendung

VPMOVDW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVDW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVQB - Packen und kürzen Sie qwords in Bytes (schmal) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPMOVQB - Packen und kürzen Sie qwords in Bytes (schmal)
Hilfe zum PBXB64-Compiler

VPMOVQB - Packen und kürzen Sie qwords in Bytes (schmal)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVQB - Packen und kürzen Sie qwords in Bytes (schmal). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen mem, zmm / xmm, zmm.

Syntax

VPMOVQB mem, zmm / xmm, zmm

Operands and Sizes

Form | Meaning
mem, zmm | may read or write memory
xmm, zmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovqb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovqb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVQB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVQB operand[, operand]

PBXB64-Verwendung

VPMOVQB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVQB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVQD - Packen und kürzen Sie qwords in dwords (schmal) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPMOVQD - Packen und kürzen Sie qwords in dwords (schmal)
Hilfe zum PBXB64-Compiler

VPMOVQD - Packen und kürzen Sie qwords in dwords (schmal)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVQD - Packen und kürzen Sie qwords in dwords (schmal). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen mem, zmm / xmm, zmm.

Syntax

VPMOVQD mem, zmm / xmm, zmm

Operands and Sizes

Form | Meaning
mem, zmm | may read or write memory
xmm, zmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovqd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovqd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVQD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVQD operand[, operand]

PBXB64-Verwendung

VPMOVQD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVQD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVQW - Packen und kürzen Sie qwords in Wörter (schmal) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPMOVQW - Packen und kürzen Sie qwords in Wörter (schmal)
Hilfe zum PBXB64-Compiler

VPMOVQW - Packen und kürzen Sie qwords in Wörter (schmal)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVQW - Packen und kürzen Sie qwords in Wörter (schmal). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen mem, zmm / xmm, zmm.

Syntax

VPMOVQW mem, zmm / xmm, zmm

Operands and Sizes

Form | Meaning
mem, zmm | may read or write memory
xmm, zmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovqw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovqw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVQW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVQW operand[, operand]

PBXB64-Verwendung

VPMOVQW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVQW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMOVWB - Packen und kürzen Sie Wörter in Bytes (schmal) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPMOVWB - Packen und kürzen Sie Wörter in Bytes (schmal)
Hilfe zum PBXB64-Compiler

VPMOVWB - Packen und kürzen Sie Wörter in Bytes (schmal)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMOVWB - Packen und kürzen Sie Wörter in Bytes (schmal). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen mem, zmm / xmm, zmm.

Syntax

VPMOVWB mem, zmm / xmm, zmm

Operands and Sizes

Form | Meaning
mem, zmm | may read or write memory
xmm, zmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmovwb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmovwb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMOVWB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMOVWB operand[, operand]

PBXB64-Verwendung

VPMOVWB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMOVWB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPMULLQ - Multiplizieren Sie gepackte Qwords mit Vorzeichen (niedrige 64 Bit) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPMULLQ - Multiplizieren Sie gepackte Qwords mit Vorzeichen (niedrige 64 Bit)
Hilfe zum PBXB64-Compiler

VPMULLQ - Multiplizieren Sie gepackte Qwords mit Vorzeichen (niedrige 64 Bit)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPMULLQ - Multiplizieren Sie gepackte Qwords mit Vorzeichen (niedrige 64 Bit). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPMULLQ zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpmullq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpmullq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPMULLQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPMULLQ operand[, operand]

PBXB64-Verwendung

VPMULLQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPMULLQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSHUFB - Shuffle packed bytes (per-lane) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPSHUFB - Shuffle packed bytes (per-lane)
Hilfe zum PBXB64-Compiler

VPSHUFB - Shuffle packed bytes (per-lane)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSHUFB - Shuffle packed bytes (per-lane). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPSHUFB ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpshufb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpshufb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSHUFB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSHUFB operand[, operand]

PBXB64-Verwendung

VPSHUFB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSHUFB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSHUFD - Shuffle packed dwords (per-lane, imm8) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPSHUFD - Shuffle packed dwords (per-lane, imm8)
Hilfe zum PBXB64-Compiler

VPSHUFD - Shuffle packed dwords (per-lane, imm8)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSHUFD - Shuffle packed dwords (per-lane, imm8). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/mem, imm8.

Syntax

VPSHUFD ymm/xmm, ymm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpshufd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpshufd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSHUFD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSHUFD operand[, operand]

PBXB64-Verwendung

VPSHUFD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSHUFD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSHUFHW - Shuffle packed high words (imm8) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPSHUFHW - Shuffle packed high words (imm8)
Hilfe zum PBXB64-Compiler

VPSHUFHW - Shuffle packed high words (imm8)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSHUFHW - Shuffle packed high words (imm8). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/mem, imm8.

Syntax

VPSHUFHW ymm/xmm, ymm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpshufhw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpshufhw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSHUFHW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSHUFHW operand[, operand]

PBXB64-Verwendung

VPSHUFHW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSHUFHW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSHUFLW - Shuffle packed low words (imm8) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VPSHUFLW - Shuffle packed low words (imm8)
Hilfe zum PBXB64-Compiler

VPSHUFLW - Shuffle packed low words (imm8)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSHUFLW - Shuffle packed low words (imm8). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/mem, imm8.

Syntax

VPSHUFLW ymm/xmm, ymm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpshuflw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpshuflw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSHUFLW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSHUFLW operand[, operand]

PBXB64-Verwendung

VPSHUFLW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSHUFLW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRCP14PD - 14-Bit reziprokes gepacktes Double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VRCP14PD - 14-Bit reziprokes gepacktes Double
Hilfe zum PBXB64-Compiler

VRCP14PD - 14-Bit reziprokes gepacktes Double

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRCP14PD - 14-Bit reziprokes gepacktes Double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VRCP14PD zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrcp14pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrcp14pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRCP14PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRCP14PD operand[, operand]

PBXB64-Verwendung

VRCP14PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRCP14PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRCP14PS - 14-Bit reziproke gepackte Single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VRCP14PS - 14-Bit reziproke gepackte Single
Hilfe zum PBXB64-Compiler

VRCP14PS - 14-Bit reziproke gepackte Single

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRCP14PS - 14-Bit reziproke gepackte Single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VRCP14PS zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrcp14ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrcp14ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRCP14PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRCP14PS operand[, operand]

PBXB64-Verwendung

VRCP14PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRCP14PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRCP28PD - 28-Bit-Reziproknäherung (doppelt, gepackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VRCP28PD - 28-Bit-Reziproknäherung (doppelt, gepackt)
Hilfe zum PBXB64-Compiler

VRCP28PD - 28-Bit-Reziproknäherung (doppelt, gepackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRCP28PD - 28-Bit-Reziproknäherung (doppelt, gepackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VRCP28PD zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrcp28pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrcp28pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRCP28PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRCP28PD operand[, operand]

PBXB64-Verwendung

VRCP28PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRCP28PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRCP28PS - 28-Bit-Reziproknäherung (einzeln, gepackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VRCP28PS - 28-Bit-Reziproknäherung (einzeln, gepackt)
Hilfe zum PBXB64-Compiler

VRCP28PS - 28-Bit-Reziproknäherung (einzeln, gepackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRCP28PS - 28-Bit-Reziproknäherung (einzeln, gepackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VRCP28PS zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrcp28ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrcp28ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRCP28PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRCP28PS operand[, operand]

PBXB64-Verwendung

VRCP28PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRCP28PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRCPPS - Gegenseitig verpackte Single (ungefähr) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VRCPPS - Gegenseitig verpackte Single (ungefähr)
Hilfe zum PBXB64-Compiler

VRCPPS - Gegenseitig verpackte Single (ungefähr)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRCPPS - Gegenseitig verpackte Single (ungefähr). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VRCPPS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrcpps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrcpps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRCPPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRCPPS operand[, operand]

PBXB64-Verwendung

VRCPPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRCPPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VREDUCEPD - Packed Double reduzieren (auf N Bits runden) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VREDUCEPD - Packed Double reduzieren (auf N Bits runden)
Hilfe zum PBXB64-Compiler

VREDUCEPD - Packed Double reduzieren (auf N Bits runden)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VREDUCEPD - Packed Double reduzieren (auf N Bits runden). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem, imm8.

Syntax

VREDUCEPD zmm, zmm/mem, imm8

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vreducepd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vreducepd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VREDUCEPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VREDUCEPD operand[, operand]

PBXB64-Verwendung

VREDUCEPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VREDUCEPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VREDUCEPS - Gepackte Single reduzieren (auf N Bits runden) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VREDUCEPS - Gepackte Single reduzieren (auf N Bits runden)
Hilfe zum PBXB64-Compiler

VREDUCEPS - Gepackte Single reduzieren (auf N Bits runden)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VREDUCEPS - Gepackte Single reduzieren (auf N Bits runden). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem, imm8.

Syntax

VREDUCEPS zmm, zmm/mem, imm8

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vreduceps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vreduceps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VREDUCEPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VREDUCEPS operand[, operand]

PBXB64-Verwendung

VREDUCEPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VREDUCEPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRNDSCALEPD - Rund verpackt, doppelt mit Skala - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VRNDSCALEPD - Rund verpackt, doppelt mit Skala
Hilfe zum PBXB64-Compiler

VRNDSCALEPD - Rund verpackt, doppelt mit Skala

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRNDSCALEPD - Rund verpackt, doppelt mit Skala. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem, imm8.

Syntax

VRNDSCALEPD zmm, zmm/mem, imm8

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrndscalepd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrndscalepd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRNDSCALEPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRNDSCALEPD operand[, operand]

PBXB64-Verwendung

VRNDSCALEPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRNDSCALEPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRNDSCALEPS - Rund verpacktes Einzelstück mit Skala - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VRNDSCALEPS - Rund verpacktes Einzelstück mit Skala
Hilfe zum PBXB64-Compiler

VRNDSCALEPS - Rund verpacktes Einzelstück mit Skala

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRNDSCALEPS - Rund verpacktes Einzelstück mit Skala. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem, imm8.

Syntax

VRNDSCALEPS zmm, zmm/mem, imm8

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrndscaleps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrndscaleps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRNDSCALEPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRNDSCALEPS operand[, operand]

PBXB64-Verwendung

VRNDSCALEPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRNDSCALEPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VROUNDPD - Rund verpackt, doppelt - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VROUNDPD - Rund verpackt, doppelt
Hilfe zum PBXB64-Compiler

VROUNDPD - Rund verpackt, doppelt

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VROUNDPD - Rund verpackt, doppelt. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/mem, imm8.

Syntax

VROUNDPD ymm/xmm, ymm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vroundpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vroundpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VROUNDPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VROUNDPD operand[, operand]

PBXB64-Verwendung

VROUNDPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VROUNDPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VROUNDPS - Rund verpackte Single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VROUNDPS - Rund verpackte Single
Hilfe zum PBXB64-Compiler

VROUNDPS - Rund verpackte Single

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VROUNDPS - Rund verpackte Single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/mem, imm8.

Syntax

VROUNDPS ymm/xmm, ymm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vroundps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vroundps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VROUNDPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VROUNDPS operand[, operand]

PBXB64-Verwendung

VROUNDPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VROUNDPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRSQRT28PD - 28-Bit reziproke Quadratnäherung (doppelt, gepackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VRSQRT28PD - 28-Bit reziproke Quadratnäherung (doppelt, gepackt)
Hilfe zum PBXB64-Compiler

VRSQRT28PD - 28-Bit reziproke Quadratnäherung (doppelt, gepackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRSQRT28PD - 28-Bit reziproke Quadratnäherung (doppelt, gepackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VRSQRT28PD zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrsqrt28pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrsqrt28pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRSQRT28PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRSQRT28PD operand[, operand]

PBXB64-Verwendung

VRSQRT28PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRSQRT28PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRSQRT28PS - 28-Bit reziproke Quadratnäherung (einzeln, gepackt) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VRSQRT28PS - 28-Bit reziproke Quadratnäherung (einzeln, gepackt)
Hilfe zum PBXB64-Compiler

VRSQRT28PS - 28-Bit reziproke Quadratnäherung (einzeln, gepackt)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRSQRT28PS - 28-Bit reziproke Quadratnäherung (einzeln, gepackt). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm/mem.

Syntax

VRSQRT28PS zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrsqrt28ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrsqrt28ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRSQRT28PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRSQRT28PS operand[, operand]

PBXB64-Verwendung

VRSQRT28PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRSQRT28PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRSQRTPS - Reziproke quadratisch gepackte Single (ungefähr) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VRSQRTPS - Reziproke quadratisch gepackte Single (ungefähr)
Hilfe zum PBXB64-Compiler

VRSQRTPS - Reziproke quadratisch gepackte Single (ungefähr)

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRSQRTPS - Reziproke quadratisch gepackte Single (ungefähr). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VRSQRTPS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrsqrtps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrsqrtps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRSQRTPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRSQRTPS operand[, operand]

PBXB64-Verwendung

VRSQRTPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRSQRTPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VSCALEFPD - Skala doppelt gepackt durch Zweierpotenz - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VSCALEFPD - Skala doppelt gepackt durch Zweierpotenz
Hilfe zum PBXB64-Compiler

VSCALEFPD - Skala doppelt gepackt durch Zweierpotenz

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VSCALEFPD - Skala doppelt gepackt durch Zweierpotenz. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VSCALEFPD zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vscalefpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vscalefpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VSCALEFPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VSCALEFPD operand[, operand]

PBXB64-Verwendung

VSCALEFPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VSCALEFPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VSCATTERDPD - Scatter-gepacktes Doppel mit Dword-Indizes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VSCATTERDPD - Scatter-gepacktes Doppel mit Dword-Indizes
Hilfe zum PBXB64-Compiler

VSCATTERDPD - Scatter-gepacktes Doppel mit Dword-Indizes

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VSCATTERDPD - Scatter-gepacktes Doppel mit Dword-Indizes. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen mem, zmm.

Syntax

VSCATTERDPD mem, zmm

Operands and Sizes

Form | Meaning
mem, zmm | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vscatterdpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vscatterdpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VSCATTERDPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VSCATTERDPD operand[, operand]

PBXB64-Verwendung

VSCATTERDPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VSCATTERDPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VSCATTERDPS - Scatter-gepackte Single mit Dword-Indizes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VSCATTERDPS - Scatter-gepackte Single mit Dword-Indizes
Hilfe zum PBXB64-Compiler

VSCATTERDPS - Scatter-gepackte Single mit Dword-Indizes

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VSCATTERDPS - Scatter-gepackte Single mit Dword-Indizes. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen mem, zmm.

Syntax

VSCATTERDPS mem, zmm

Operands and Sizes

Form | Meaning
mem, zmm | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vscatterdps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vscatterdps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VSCATTERDPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VSCATTERDPS operand[, operand]

PBXB64-Verwendung

VSCATTERDPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VSCATTERDPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VSCATTERQPD - Scatter-gepacktes Doppel mit Qword-Indizes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VSCATTERQPD - Scatter-gepacktes Doppel mit Qword-Indizes
Hilfe zum PBXB64-Compiler

VSCATTERQPD - Scatter-gepacktes Doppel mit Qword-Indizes

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VSCATTERQPD - Scatter-gepacktes Doppel mit Qword-Indizes. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen mem, zmm.

Syntax

VSCATTERQPD mem, zmm

Operands and Sizes

Form | Meaning
mem, zmm | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vscatterqpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vscatterqpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VSCATTERQPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VSCATTERQPD operand[, operand]

PBXB64-Verwendung

VSCATTERQPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VSCATTERQPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VSCATTERQPS - Streugepackte Single mit Qword-Indizes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VSCATTERQPS - Streugepackte Single mit Qword-Indizes
Hilfe zum PBXB64-Compiler

VSCATTERQPS - Streugepackte Single mit Qword-Indizes

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VSCATTERQPS - Streugepackte Single mit Qword-Indizes. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen mem, zmm.

Syntax

VSCATTERQPS mem, zmm

Operands and Sizes

Form | Meaning
mem, zmm | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vscatterqps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vscatterqps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VSCATTERQPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VSCATTERQPS operand[, operand]

PBXB64-Verwendung

VSCATTERQPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VSCATTERQPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VSHUFPD - Shuffle packed double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VSHUFPD - Shuffle packed double
Hilfe zum PBXB64-Compiler

VSHUFPD - Shuffle packed double

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VSHUFPD - Shuffle packed double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem, imm8.

Syntax

VSHUFPD ymm/xmm, ymm/xmm, ymm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vshufpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vshufpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VSHUFPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VSHUFPD operand[, operand]

PBXB64-Verwendung

VSHUFPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VSHUFPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VSHUFPS - Shuffle packed single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VSHUFPS - Shuffle packed single
Hilfe zum PBXB64-Compiler

VSHUFPS - Shuffle packed single

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VSHUFPS - Shuffle packed single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem, imm8.

Syntax

VSHUFPS ymm/xmm, ymm/xmm, ymm/mem, imm8

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vshufps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vshufps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VSHUFPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VSHUFPS operand[, operand]

PBXB64-Verwendung

VSHUFPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VSHUFPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VSQRTPD - Quadratwurzel doppelt gepackt - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VSQRTPD - Quadratwurzel doppelt gepackt
Hilfe zum PBXB64-Compiler

VSQRTPD - Quadratwurzel doppelt gepackt

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VSQRTPD - Quadratwurzel doppelt gepackt. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VSQRTPD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vsqrtpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vsqrtpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VSQRTPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VSQRTPD operand[, operand]

PBXB64-Verwendung

VSQRTPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VSQRTPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VSQRTPS - Quadratwurzelgepackte Single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VSQRTPS - Quadratwurzelgepackte Single
Hilfe zum PBXB64-Compiler

VSQRTPS - Quadratwurzelgepackte Single

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VSQRTPS - Quadratwurzelgepackte Single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VSQRTPS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vsqrtps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vsqrtps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VSQRTPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VSQRTPS operand[, operand]

PBXB64-Verwendung

VSQRTPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VSQRTPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VSUBPD - Subtrahieren Sie das gepackte Doppel - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VSUBPD - Subtrahieren Sie das gepackte Doppel
Hilfe zum PBXB64-Compiler

VSUBPD - Subtrahieren Sie das gepackte Doppel

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VSUBPD - Subtrahieren Sie das gepackte Doppel. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VSUBPD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vsubpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vsubpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VSUBPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VSUBPD operand[, operand]

PBXB64-Verwendung

VSUBPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VSUBPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VSUBPS - Gepackte Single subtrahieren - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VSUBPS - Gepackte Single subtrahieren
Hilfe zum PBXB64-Compiler

VSUBPS - Gepackte Single subtrahieren

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VSUBPS - Gepackte Single subtrahieren. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VSUBPS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vsubps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vsubps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VSUBPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VSUBPS operand[, operand]

PBXB64-Verwendung

VSUBPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VSUBPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VUNPCKHPD - Unpack high packed double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VUNPCKHPD - Unpack high packed double
Hilfe zum PBXB64-Compiler

VUNPCKHPD - Unpack high packed double

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VUNPCKHPD - Unpack high packed double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VUNPCKHPD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vunpckhpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vunpckhpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VUNPCKHPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VUNPCKHPD operand[, operand]

PBXB64-Verwendung

VUNPCKHPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VUNPCKHPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VUNPCKHPS - Unpack high packed single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VUNPCKHPS - Unpack high packed single
Hilfe zum PBXB64-Compiler

VUNPCKHPS - Unpack high packed single

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VUNPCKHPS - Unpack high packed single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VUNPCKHPS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vunpckhps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vunpckhps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VUNPCKHPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VUNPCKHPS operand[, operand]

PBXB64-Verwendung

VUNPCKHPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VUNPCKHPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VUNPCKLPD - Unpack low packed double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VUNPCKLPD - Unpack low packed double
Hilfe zum PBXB64-Compiler

VUNPCKLPD - Unpack low packed double

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VUNPCKLPD - Unpack low packed double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VUNPCKLPD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vunpcklpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vunpcklpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VUNPCKLPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VUNPCKLPD operand[, operand]

PBXB64-Verwendung

VUNPCKLPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VUNPCKLPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VUNPCKLPS - Unpack low packed single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VUNPCKLPS - Unpack low packed single
Hilfe zum PBXB64-Compiler

VUNPCKLPS - Unpack low packed single

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VUNPCKLPS - Unpack low packed single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VUNPCKLPS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vunpcklps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vunpcklps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VUNPCKLPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VUNPCKLPS operand[, operand]

PBXB64-Verwendung

VUNPCKLPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VUNPCKLPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VXORPD - Bitwise XOR of packed doubles - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VXORPD - Bitwise XOR of packed doubles
Hilfe zum PBXB64-Compiler

VXORPD - Bitwise XOR of packed doubles

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VXORPD - Bitwise XOR of packed doubles. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VXORPD ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vxorpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vxorpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VXORPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VXORPD operand[, operand]

PBXB64-Verwendung

VXORPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VXORPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VXORPS - Bitwise XOR of packed singles - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › VXORPS - Bitwise XOR of packed singles
Hilfe zum PBXB64-Compiler

VXORPS - Bitwise XOR of packed singles

Category: Shuffle / Permute

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VXORPS - Bitwise XOR of packed singles. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VXORPS ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vxorps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vxorps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VXORPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VXORPS operand[, operand]

PBXB64-Verwendung

VXORPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VXORPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


XORPS - Bitwise XOR of packed singles - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Shuffle / Permute › XORPS - Bitwise XOR of packed singles
Hilfe zum PBXB64-Compiler

XORPS - Bitwise XOR of packed singles

Category: Shuffle / Permute

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

XORPS - Bitwise XOR of packed singles. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

XORPS xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    xorps xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! xorps xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

XORPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

XORPS operand[, operand]

PBXB64-Verwendung

XORPS ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! XORPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


NOTRACK - Präfix: IBT-Prüfung für den nächsten JMP/CALL unterdrücken - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Control Transfer › NOTRACK - Präfix: IBT-Prüfung für den nächsten JMP/CALL unterdrücken
Hilfe zum PBXB64-Compiler

NOTRACK - Präfix: IBT-Prüfung für den nächsten JMP/CALL unterdrücken

Category: Control Flow

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

NOTRACK - Präfix: IBT-Prüfung für den nächsten JMP/CALL unterdrücken. Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen F2-Präfix.

Syntax

NOTRACK F2-Präfix

Operands and Sizes

Form | Meaning
F2-Präfix | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    notrack operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! notrack operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

NOTRACK ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

NOTRACK operand[, operand]

PBXB64-Verwendung

NOTRACK ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! NOTRACK ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CMPSD - Skalar-Double vergleichen (imm8-Prädikat) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › CMPSD - Skalar-Double vergleichen (imm8-Prädikat)
Hilfe zum PBXB64-Compiler

CMPSD - Skalar-Double vergleichen (imm8-Prädikat)

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CMPSD - Skalar-Double vergleichen (imm8-Prädikat). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem64, imm8.

Syntax

CMPSD xmm, xmm/mem64, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem64, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 8
asm_data64:
    .quad 0

.text
.global main
main:
    cmpsd xmm0, [rip + asm_data64]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cmpsd xmm0, [rip + asm_data64]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CMPSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CMPSD operand[, operand]

PBXB64-Verwendung

CMPSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CMPSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CMPSS - Skalare Single vergleichen (imm8-Prädikat) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › CMPSS - Skalare Single vergleichen (imm8-Prädikat)
Hilfe zum PBXB64-Compiler

CMPSS - Skalare Single vergleichen (imm8-Prädikat)

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CMPSS - Skalare Single vergleichen (imm8-Prädikat). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem32, imm8.

Syntax

CMPSS xmm, xmm/mem32, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem32, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 4
asm_data32:
    .long 0

.text
.global main
main:
    cmpss xmm0, [rip + asm_data32]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cmpss xmm0, [rip + asm_data32]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CMPSS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CMPSS operand[, operand]

PBXB64-Verwendung

CMPSS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CMPSS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CVTSI2SS - Convert integer to scalar single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › CVTSI2SS - Convert integer to scalar single
Hilfe zum PBXB64-Compiler

CVTSI2SS - Convert integer to scalar single

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CVTSI2SS - Convert integer to scalar single. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, reg32/64/mem32.

Syntax

CVTSI2SS xmm, reg32/64/mem32

Operands and Sizes

Form | Meaning
xmm, reg32 | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register
64 | follow the operand order shown in the syntax
mem32 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 4
asm_data32:
    .long 0

.text
.global main
main:
    cvtsi2ss xmm0, [rip + asm_data32]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cvtsi2ss xmm0, [rip + asm_data32]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CVTSI2SS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CVTSI2SS operand[, operand]

PBXB64-Verwendung

CVTSI2SS ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CVTSI2SS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CVTSS2SI - Konvertieren Sie einen einzelnen Skalar in eine ganze Zahl (rund) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › CVTSS2SI - Konvertieren Sie einen einzelnen Skalar in eine ganze Zahl (rund)
Hilfe zum PBXB64-Compiler

CVTSS2SI - Konvertieren Sie einen einzelnen Skalar in eine ganze Zahl (rund)

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CVTSS2SI - Konvertieren Sie einen einzelnen Skalar in eine ganze Zahl (rund). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen reg32/64, xmm/mem32.

Syntax

CVTSS2SI reg32/64, xmm/mem32

Operands and Sizes

Form | Meaning
reg32 | uses a general-purpose register
64, xmm | uses XMM vector/scalar registers; may read or write memory
mem32 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 4
asm_data32:
    .long 0

.text
.global main
main:
    cvtss2si xmm0, [rip + asm_data32]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cvtss2si xmm0, [rip + asm_data32]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CVTSS2SI ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CVTSS2SI operand[, operand]

PBXB64-Verwendung

CVTSS2SI ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CVTSS2SI ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CVTTSI2SD - Ganzzahl auf Skalardoppel kürzen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › CVTTSI2SD - Ganzzahl auf Skalardoppel kürzen
Hilfe zum PBXB64-Compiler

CVTTSI2SD - Ganzzahl auf Skalardoppel kürzen

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CVTTSI2SD - Ganzzahl auf Skalardoppel kürzen. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, reg32/64/mem32.

Syntax

CVTTSI2SD xmm, reg32/64/mem32

Operands and Sizes

Form | Meaning
xmm, reg32 | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register
64 | follow the operand order shown in the syntax
mem32 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 4
asm_data32:
    .long 0

.text
.global main
main:
    cvttsi2sd xmm0, [rip + asm_data32]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cvttsi2sd xmm0, [rip + asm_data32]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CVTTSI2SD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CVTTSI2SD operand[, operand]

PBXB64-Verwendung

CVTTSI2SD ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CVTTSI2SD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CVTTSS2SI - Truncate scalar single to integer - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › CVTTSS2SI - Truncate scalar single to integer
Hilfe zum PBXB64-Compiler

CVTTSS2SI - Truncate scalar single to integer

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CVTTSS2SI - Truncate scalar single to integer. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen reg32/64, xmm/mem32.

Syntax

CVTTSS2SI reg32/64, xmm/mem32

Operands and Sizes

Form | Meaning
reg32 | uses a general-purpose register
64, xmm | uses XMM vector/scalar registers; may read or write memory
mem32 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 4
asm_data32:
    .long 0

.text
.global main
main:
    cvttss2si xmm0, [rip + asm_data32]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cvttss2si xmm0, [rip + asm_data32]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CVTTSS2SI ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CVTTSS2SI operand[, operand]

PBXB64-Verwendung

CVTTSS2SI ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CVTTSS2SI ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FXRSTOR - Stellen Sie den x87- und SSE-Status wieder her FXSAVE - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › FXRSTOR - Stellen Sie den x87- und SSE-Status wieder her FXSAVE
Hilfe zum PBXB64-Compiler

FXRSTOR - Stellen Sie den x87- und SSE-Status wieder her FXSAVE

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FXRSTOR - Stellen Sie den x87- und SSE-Status wieder her FXSAVE. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen Speichern Sie den x87- und SSE-Status.

Syntax

FXRSTOR Speichern Sie den x87- und SSE-Status

Operands and Sizes

Form | Meaning
Speichern Sie den x87- und SSE-Status | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fxrstor operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fxrstor operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FXRSTOR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FXRSTOR operand[, operand]

PBXB64-Verwendung

FXRSTOR ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FXRSTOR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVDDUP - Verschieben und duplizieren (eines auf beide Hälften von XMM) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › MOVDDUP - Verschieben und duplizieren (eines auf beide Hälften von XMM)
Hilfe zum PBXB64-Compiler

MOVDDUP - Verschieben und duplizieren (eines auf beide Hälften von XMM)

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MOVDDUP - Verschieben und duplizieren (eines auf beide Hälften von XMM). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem64.

Syntax

MOVDDUP xmm, xmm/mem64

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 8
asm_data64:
    .quad 0

.text
.global main
main:
    movddup xmm0, [rip + asm_data64]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! movddup xmm0, [rip + asm_data64]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVDDUP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVDDUP operand[, operand]

PBXB64-Verwendung

MOVDDUP ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVDDUP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PEXTRB - Byte in GPR oder Speicher extrahieren - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › PEXTRB - Byte in GPR oder Speicher extrahieren
Hilfe zum PBXB64-Compiler

PEXTRB - Byte in GPR oder Speicher extrahieren

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PEXTRB - Byte in GPR oder Speicher extrahieren. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen reg/mem8, xmm, imm8.

Syntax

PEXTRB reg/mem8, xmm, imm8

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem8, xmm, imm8 | uses XMM vector/scalar registers; may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    pextrb xmm0, xmm1
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pextrb xmm0, xmm1
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PEXTRB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PEXTRB operand[, operand]

PBXB64-Verwendung

PEXTRB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PEXTRB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PINSRB - Byte einfügen (aus GPR oder Speicher) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › PINSRB - Byte einfügen (aus GPR oder Speicher)
Hilfe zum PBXB64-Compiler

PINSRB - Byte einfügen (aus GPR oder Speicher)

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PINSRB - Byte einfügen (aus GPR oder Speicher). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, reg/mem32, imm8.

Syntax

PINSRB xmm, reg/mem32, imm8

Operands and Sizes

Form | Meaning
xmm, reg | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register
mem32, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 4
asm_data32:
    .long 0

.text
.global main
main:
    pinsrb xmm0, [rip + asm_data32]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pinsrb xmm0, [rip + asm_data32]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PINSRB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PINSRB operand[, operand]

PBXB64-Verwendung

PINSRB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PINSRB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMOVSXWD - Bewegen Sie sich mit Zeichenerweiterung, Wörter zu Doppelwörtern - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › PMOVSXWD - Bewegen Sie sich mit Zeichenerweiterung, Wörter zu Doppelwörtern
Hilfe zum PBXB64-Compiler

PMOVSXWD - Bewegen Sie sich mit Zeichenerweiterung, Wörter zu Doppelwörtern

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMOVSXWD - Bewegen Sie sich mit Zeichenerweiterung, Wörter zu Doppelwörtern. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem64.

Syntax

PMOVSXWD xmm, xmm/mem64

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 8
asm_data64:
    .quad 0

.text
.global main
main:
    pmovsxwd xmm0, [rip + asm_data64]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmovsxwd xmm0, [rip + asm_data64]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMOVSXWD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMOVSXWD operand[, operand]

PBXB64-Verwendung

PMOVSXWD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMOVSXWD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMOVSXWQ - Verschieben Sie Wörter mit Zeichenerweiterung in Quadwörter - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › PMOVSXWQ - Verschieben Sie Wörter mit Zeichenerweiterung in Quadwörter
Hilfe zum PBXB64-Compiler

PMOVSXWQ - Verschieben Sie Wörter mit Zeichenerweiterung in Quadwörter

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMOVSXWQ - Verschieben Sie Wörter mit Zeichenerweiterung in Quadwörter. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem32.

Syntax

PMOVSXWQ xmm, xmm/mem32

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem32 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 4
asm_data32:
    .long 0

.text
.global main
main:
    pmovsxwq xmm0, [rip + asm_data32]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmovsxwq xmm0, [rip + asm_data32]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMOVSXWQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMOVSXWQ operand[, operand]

PBXB64-Verwendung

PMOVSXWQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMOVSXWQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← PMOVSXWD - Bewegen Sie sich mit Zeichenerweiterung, Wörter zu Doppelwörtern Top PMOVZXBD - Verschieben Sie Bytes mit der Erweiterung Null in Doppelwörter →


PMOVZXBD - Verschieben Sie Bytes mit der Erweiterung Null in Doppelwörter - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › PMOVZXBD - Verschieben Sie Bytes mit der Erweiterung Null in Doppelwörter
Hilfe zum PBXB64-Compiler

PMOVZXBD - Verschieben Sie Bytes mit der Erweiterung Null in Doppelwörter

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMOVZXBD - Verschieben Sie Bytes mit der Erweiterung Null in Doppelwörter. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem32.

Syntax

PMOVZXBD xmm, xmm/mem32

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem32 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 4
asm_data32:
    .long 0

.text
.global main
main:
    pmovzxbd xmm0, [rip + asm_data32]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmovzxbd xmm0, [rip + asm_data32]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMOVZXBD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMOVZXBD operand[, operand]

PBXB64-Verwendung

PMOVZXBD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMOVZXBD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMOVZXBW - Verschieben Sie mit Null-Erweiterung, Bytes zu Wörtern - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › PMOVZXBW - Verschieben Sie mit Null-Erweiterung, Bytes zu Wörtern
Hilfe zum PBXB64-Compiler

PMOVZXBW - Verschieben Sie mit Null-Erweiterung, Bytes zu Wörtern

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMOVZXBW - Verschieben Sie mit Null-Erweiterung, Bytes zu Wörtern. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem64.

Syntax

PMOVZXBW xmm, xmm/mem64

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 8
asm_data64:
    .quad 0

.text
.global main
main:
    pmovzxbw xmm0, [rip + asm_data64]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmovzxbw xmm0, [rip + asm_data64]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMOVZXBW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMOVZXBW operand[, operand]

PBXB64-Verwendung

PMOVZXBW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMOVZXBW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← PMOVZXBD - Verschieben Sie Bytes mit der Erweiterung Null in Doppelwörter Top PMOVZXDQ - Verschieben Sie Doppelwörter mit Nullerweiterung in Quadwörter →


PMOVZXDQ - Verschieben Sie Doppelwörter mit Nullerweiterung in Quadwörter - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › PMOVZXDQ - Verschieben Sie Doppelwörter mit Nullerweiterung in Quadwörter
Hilfe zum PBXB64-Compiler

PMOVZXDQ - Verschieben Sie Doppelwörter mit Nullerweiterung in Quadwörter

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMOVZXDQ - Verschieben Sie Doppelwörter mit Nullerweiterung in Quadwörter. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem64.

Syntax

PMOVZXDQ xmm, xmm/mem64

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 8
asm_data64:
    .quad 0

.text
.global main
main:
    pmovzxdq xmm0, [rip + asm_data64]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmovzxdq xmm0, [rip + asm_data64]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMOVZXDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMOVZXDQ operand[, operand]

PBXB64-Verwendung

PMOVZXDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMOVZXDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMOVZXWD - Verschieben Sie Wörter ohne Erweiterung in Doppelwörter - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › PMOVZXWD - Verschieben Sie Wörter ohne Erweiterung in Doppelwörter
Hilfe zum PBXB64-Compiler

PMOVZXWD - Verschieben Sie Wörter ohne Erweiterung in Doppelwörter

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMOVZXWD - Verschieben Sie Wörter ohne Erweiterung in Doppelwörter. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem64.

Syntax

PMOVZXWD xmm, xmm/mem64

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 8
asm_data64:
    .quad 0

.text
.global main
main:
    pmovzxwd xmm0, [rip + asm_data64]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmovzxwd xmm0, [rip + asm_data64]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMOVZXWD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMOVZXWD operand[, operand]

PBXB64-Verwendung

PMOVZXWD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMOVZXWD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PMOVZXWQ - Verschieben Sie Wörter ohne Erweiterung in Quadwörter - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › PMOVZXWQ - Verschieben Sie Wörter ohne Erweiterung in Quadwörter
Hilfe zum PBXB64-Compiler

PMOVZXWQ - Verschieben Sie Wörter ohne Erweiterung in Quadwörter

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PMOVZXWQ - Verschieben Sie Wörter ohne Erweiterung in Quadwörter. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem32.

Syntax

PMOVZXWQ xmm, xmm/mem32

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem32 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 4
asm_data32:
    .long 0

.text
.global main
main:
    pmovzxwq xmm0, [rip + asm_data32]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! pmovzxwq xmm0, [rip + asm_data32]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PMOVZXWQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PMOVZXWQ operand[, operand]

PBXB64-Verwendung

PMOVZXWQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PMOVZXWQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PSADBW - Sum of absolute differences - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › PSADBW - Sum of absolute differences
Hilfe zum PBXB64-Compiler

PSADBW - Sum of absolute differences

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PSADBW - Sum of absolute differences. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

PSADBW xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    psadbw xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! psadbw xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PSADBW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PSADBW operand[, operand]

PBXB64-Verwendung

PSADBW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PSADBW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RCPSS - Reziproker Skalar Single (ungefähr) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › RCPSS - Reziproker Skalar Single (ungefähr)
Hilfe zum PBXB64-Compiler

RCPSS - Reziproker Skalar Single (ungefähr)

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

RCPSS - Reziproker Skalar Single (ungefähr). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem32.

Syntax

RCPSS xmm, xmm/mem32

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem32 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 4
asm_data32:
    .long 0

.text
.global main
main:
    rcpss xmm0, [rip + asm_data32]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! rcpss xmm0, [rip + asm_data32]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

RCPSS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

RCPSS operand[, operand]

PBXB64-Verwendung

RCPSS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! RCPSS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ROUNDSD - Rundes Skalardoppel - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › ROUNDSD - Rundes Skalardoppel
Hilfe zum PBXB64-Compiler

ROUNDSD - Rundes Skalardoppel

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

ROUNDSD - Rundes Skalardoppel. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem64, imm8.

Syntax

ROUNDSD xmm, xmm/mem64, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem64, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 8
asm_data64:
    .quad 0

.text
.global main
main:
    roundsd xmm0, [rip + asm_data64]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! roundsd xmm0, [rip + asm_data64]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

ROUNDSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

ROUNDSD operand[, operand]

PBXB64-Verwendung

ROUNDSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! ROUNDSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ROUNDSS - Runde Skalar-Single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › ROUNDSS - Runde Skalar-Single
Hilfe zum PBXB64-Compiler

ROUNDSS - Runde Skalar-Single

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

ROUNDSS - Runde Skalar-Single. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem32, imm8.

Syntax

ROUNDSS xmm, xmm/mem32, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem32, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 4
asm_data32:
    .long 0

.text
.global main
main:
    roundss xmm0, [rip + asm_data32]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! roundss xmm0, [rip + asm_data32]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

ROUNDSS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

ROUNDSS operand[, operand]

PBXB64-Verwendung

ROUNDSS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! ROUNDSS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RSQRTSS - Reziproker Quadratwurzelskalar einfach (ungefähr) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › RSQRTSS - Reziproker Quadratwurzelskalar einfach (ungefähr)
Hilfe zum PBXB64-Compiler

RSQRTSS - Reziproker Quadratwurzelskalar einfach (ungefähr)

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

RSQRTSS - Reziproker Quadratwurzelskalar einfach (ungefähr). Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem32.

Syntax

RSQRTSS xmm, xmm/mem32

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem32 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 4
asm_data32:
    .long 0

.text
.global main
main:
    rsqrtss xmm0, [rip + asm_data32]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! rsqrtss xmm0, [rip + asm_data32]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

RSQRTSS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

RSQRTSS operand[, operand]

PBXB64-Verwendung

RSQRTSS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! RSQRTSS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


STMXCSR - MXCSR-Register speichern (Steuerung/Status) LDMXCSR - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › STMXCSR - MXCSR-Register speichern (Steuerung/Status) LDMXCSR
Hilfe zum PBXB64-Compiler

STMXCSR - MXCSR-Register speichern (Steuerung/Status) LDMXCSR

Category: SSE Instruction

Assembly Group: SSE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

STMXCSR - MXCSR-Register speichern (Steuerung/Status) LDMXCSR. Diese Instruktion gehoert zur SSE-Familie und verwendet die dokumentierten Operandenformen MXCSR-Register laden.

Syntax

STMXCSR MXCSR-Register laden

Operands and Sizes

Form | Meaning
MXCSR-Register laden | may read or write memory; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    stmxcsr eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! stmxcsr eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sse.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

STMXCSR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

STMXCSR operand[, operand]

PBXB64-Verwendung

STMXCSR ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! STMXCSR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SSE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VADDSD - Skalardoppel hinzufügen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VADDSD - Skalardoppel hinzufügen
Hilfe zum PBXB64-Compiler

VADDSD - Skalardoppel hinzufügen

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VADDSD - Skalardoppel hinzufügen. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VADDSD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vaddsd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vaddsd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VADDSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VADDSD operand[, operand]

PBXB64-Verwendung

VADDSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VADDSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VADDSS - Skalare Single hinzufügen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VADDSS - Skalare Single hinzufügen
Hilfe zum PBXB64-Compiler

VADDSS - Skalare Single hinzufügen

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VADDSS - Skalare Single hinzufügen. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VADDSS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vaddss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vaddss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VADDSS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VADDSS operand[, operand]

PBXB64-Verwendung

VADDSS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VADDSS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCVTSD2SI - Convert scalar double to integer - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VCVTSD2SI - Convert scalar double to integer
Hilfe zum PBXB64-Compiler

VCVTSD2SI - Convert scalar double to integer

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCVTSD2SI - Convert scalar double to integer. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen reg, xmm/mem.

Syntax

VCVTSD2SI reg, xmm/mem

Operands and Sizes

Form | Meaning
reg, xmm | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcvtsd2si ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcvtsd2si ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCVTSD2SI ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCVTSD2SI operand[, operand]

PBXB64-Verwendung

VCVTSD2SI ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCVTSD2SI ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCVTSD2SS - Convert scalar double to single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VCVTSD2SS - Convert scalar double to single
Hilfe zum PBXB64-Compiler

VCVTSD2SS - Convert scalar double to single

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCVTSD2SS - Convert scalar double to single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VCVTSD2SS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcvtsd2ss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcvtsd2ss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCVTSD2SS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCVTSD2SS operand[, operand]

PBXB64-Verwendung

VCVTSD2SS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCVTSD2SS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCVTSI2SD - Convert integer to scalar double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VCVTSI2SD - Convert integer to scalar double
Hilfe zum PBXB64-Compiler

VCVTSI2SD - Convert integer to scalar double

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCVTSI2SD - Convert integer to scalar double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, reg/mem.

Syntax

VCVTSI2SD xmm, xmm, reg/mem

Operands and Sizes

Form | Meaning
xmm, xmm, reg | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcvtsi2sd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcvtsi2sd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCVTSI2SD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCVTSI2SD operand[, operand]

PBXB64-Verwendung

VCVTSI2SD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCVTSI2SD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCVTSI2SS - Convert integer to scalar single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VCVTSI2SS - Convert integer to scalar single
Hilfe zum PBXB64-Compiler

VCVTSI2SS - Convert integer to scalar single

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCVTSI2SS - Convert integer to scalar single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, reg/mem.

Syntax

VCVTSI2SS xmm, xmm, reg/mem

Operands and Sizes

Form | Meaning
xmm, xmm, reg | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcvtsi2ss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcvtsi2ss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCVTSI2SS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCVTSI2SS operand[, operand]

PBXB64-Verwendung

VCVTSI2SS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCVTSI2SS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCVTSS2SD - Convert scalar single to double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VCVTSS2SD - Convert scalar single to double
Hilfe zum PBXB64-Compiler

VCVTSS2SD - Convert scalar single to double

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCVTSS2SD - Convert scalar single to double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VCVTSS2SD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcvtss2sd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcvtss2sd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCVTSS2SD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCVTSS2SD operand[, operand]

PBXB64-Verwendung

VCVTSS2SD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCVTSS2SD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCVTSS2SI - Convert scalar single to integer - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VCVTSS2SI - Convert scalar single to integer
Hilfe zum PBXB64-Compiler

VCVTSS2SI - Convert scalar single to integer

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCVTSS2SI - Convert scalar single to integer. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen reg, xmm/mem.

Syntax

VCVTSS2SI reg, xmm/mem

Operands and Sizes

Form | Meaning
reg, xmm | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcvtss2si ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcvtss2si ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCVTSS2SI ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCVTSS2SI operand[, operand]

PBXB64-Verwendung

VCVTSS2SI ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCVTSS2SI ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCVTTSD2SI - Truncate scalar double to integer - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VCVTTSD2SI - Truncate scalar double to integer
Hilfe zum PBXB64-Compiler

VCVTTSD2SI - Truncate scalar double to integer

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCVTTSD2SI - Truncate scalar double to integer. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen reg, xmm/mem.

Syntax

VCVTTSD2SI reg, xmm/mem

Operands and Sizes

Form | Meaning
reg, xmm | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcvttsd2si ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcvttsd2si ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCVTTSD2SI ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCVTTSD2SI operand[, operand]

PBXB64-Verwendung

VCVTTSD2SI ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCVTTSD2SI ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VCVTTSS2SI - Truncate scalar single to integer - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VCVTTSS2SI - Truncate scalar single to integer
Hilfe zum PBXB64-Compiler

VCVTTSS2SI - Truncate scalar single to integer

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VCVTTSS2SI - Truncate scalar single to integer. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen reg, xmm/mem.

Syntax

VCVTTSS2SI reg, xmm/mem

Operands and Sizes

Form | Meaning
reg, xmm | uses XMM vector/scalar registers; may read or write memory; uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vcvttss2si ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vcvttss2si ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VCVTTSS2SI ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VCVTTSS2SI operand[, operand]

PBXB64-Verwendung

VCVTTSS2SI ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VCVTTSS2SI ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VDIVSD - Teilen Sie den Skalar durch das Doppelte - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VDIVSD - Teilen Sie den Skalar durch das Doppelte
Hilfe zum PBXB64-Compiler

VDIVSD - Teilen Sie den Skalar durch das Doppelte

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VDIVSD - Teilen Sie den Skalar durch das Doppelte. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VDIVSD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vdivsd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vdivsd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VDIVSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VDIVSD operand[, operand]

PBXB64-Verwendung

VDIVSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VDIVSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VDIVSS - Teilen Sie den Skalar einfach - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VDIVSS - Teilen Sie den Skalar einfach
Hilfe zum PBXB64-Compiler

VDIVSS - Teilen Sie den Skalar einfach

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VDIVSS - Teilen Sie den Skalar einfach. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VDIVSS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vdivss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vdivss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VDIVSS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VDIVSS operand[, operand]

PBXB64-Verwendung

VDIVSS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VDIVSS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMADD132SD - FMA: a*b+c (double, scalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFMADD132SD - FMA: a*b+c (double, scalar)
Hilfe zum PBXB64-Compiler

VFMADD132SD - FMA: a*b+c (double, scalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMADD132SD - FMA: a*b+c (double, scalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFMADD132SD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmadd132sd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmadd132sd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMADD132SD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMADD132SD operand[, operand]

PBXB64-Verwendung

VFMADD132SD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMADD132SD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMADD132SS - FMA: a*b+c (single, scalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFMADD132SS - FMA: a*b+c (single, scalar)
Hilfe zum PBXB64-Compiler

VFMADD132SS - FMA: a*b+c (single, scalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMADD132SS - FMA: a*b+c (single, scalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFMADD132SS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmadd132ss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmadd132ss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMADD132SS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMADD132SS operand[, operand]

PBXB64-Verwendung

VFMADD132SS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMADD132SS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMADD213SD - FMA: a*b+c (double, scalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFMADD213SD - FMA: a*b+c (double, scalar)
Hilfe zum PBXB64-Compiler

VFMADD213SD - FMA: a*b+c (double, scalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMADD213SD - FMA: a*b+c (double, scalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFMADD213SD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmadd213sd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmadd213sd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMADD213SD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMADD213SD operand[, operand]

PBXB64-Verwendung

VFMADD213SD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMADD213SD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMADD213SS - FMA: a*b+c (single, scalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFMADD213SS - FMA: a*b+c (single, scalar)
Hilfe zum PBXB64-Compiler

VFMADD213SS - FMA: a*b+c (single, scalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMADD213SS - FMA: a*b+c (single, scalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFMADD213SS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmadd213ss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmadd213ss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMADD213SS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMADD213SS operand[, operand]

PBXB64-Verwendung

VFMADD213SS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMADD213SS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMADD231SD - FMA: a*b+c (double, scalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFMADD231SD - FMA: a*b+c (double, scalar)
Hilfe zum PBXB64-Compiler

VFMADD231SD - FMA: a*b+c (double, scalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMADD231SD - FMA: a*b+c (double, scalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFMADD231SD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmadd231sd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmadd231sd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMADD231SD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMADD231SD operand[, operand]

PBXB64-Verwendung

VFMADD231SD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMADD231SD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMADD231SS - FMA: a*b+c (single, scalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFMADD231SS - FMA: a*b+c (single, scalar)
Hilfe zum PBXB64-Compiler

VFMADD231SS - FMA: a*b+c (single, scalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMADD231SS - FMA: a*b+c (single, scalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFMADD231SS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmadd231ss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmadd231ss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMADD231SS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMADD231SS operand[, operand]

PBXB64-Verwendung

VFMADD231SS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMADD231SS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMSUB132SD - FMA: a*b-c (doppelt, skalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFMSUB132SD - FMA: a*b-c (doppelt, skalar)
Hilfe zum PBXB64-Compiler

VFMSUB132SD - FMA: a*b-c (doppelt, skalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMSUB132SD - FMA: a*b-c (doppelt, skalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFMSUB132SD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmsub132sd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmsub132sd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMSUB132SD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMSUB132SD operand[, operand]

PBXB64-Verwendung

VFMSUB132SD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMSUB132SD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMSUB132SS - FMA: a*b-c (single, scalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFMSUB132SS - FMA: a*b-c (single, scalar)
Hilfe zum PBXB64-Compiler

VFMSUB132SS - FMA: a*b-c (single, scalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMSUB132SS - FMA: a*b-c (single, scalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFMSUB132SS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmsub132ss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmsub132ss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMSUB132SS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMSUB132SS operand[, operand]

PBXB64-Verwendung

VFMSUB132SS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMSUB132SS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMSUB213SD - FMA: a*b-c (doppelt, skalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFMSUB213SD - FMA: a*b-c (doppelt, skalar)
Hilfe zum PBXB64-Compiler

VFMSUB213SD - FMA: a*b-c (doppelt, skalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMSUB213SD - FMA: a*b-c (doppelt, skalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFMSUB213SD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmsub213sd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmsub213sd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMSUB213SD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMSUB213SD operand[, operand]

PBXB64-Verwendung

VFMSUB213SD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMSUB213SD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMSUB213SS - FMA: a*b-c (single, scalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFMSUB213SS - FMA: a*b-c (single, scalar)
Hilfe zum PBXB64-Compiler

VFMSUB213SS - FMA: a*b-c (single, scalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMSUB213SS - FMA: a*b-c (single, scalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFMSUB213SS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmsub213ss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmsub213ss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMSUB213SS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMSUB213SS operand[, operand]

PBXB64-Verwendung

VFMSUB213SS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMSUB213SS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMSUB231SD - FMA: a*b-c (doppelt, skalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFMSUB231SD - FMA: a*b-c (doppelt, skalar)
Hilfe zum PBXB64-Compiler

VFMSUB231SD - FMA: a*b-c (doppelt, skalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMSUB231SD - FMA: a*b-c (doppelt, skalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFMSUB231SD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmsub231sd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmsub231sd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMSUB231SD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMSUB231SD operand[, operand]

PBXB64-Verwendung

VFMSUB231SD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMSUB231SD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFMSUB231SS - FMA: a*b-c (single, scalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFMSUB231SS - FMA: a*b-c (single, scalar)
Hilfe zum PBXB64-Compiler

VFMSUB231SS - FMA: a*b-c (single, scalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFMSUB231SS - FMA: a*b-c (single, scalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFMSUB231SS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfmsub231ss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfmsub231ss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFMSUB231SS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFMSUB231SS operand[, operand]

PBXB64-Verwendung

VFMSUB231SS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFMSUB231SS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMADD132SD - FMA: -(a*b)+c (doppelt, skalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFNMADD132SD - FMA: -(a*b)+c (doppelt, skalar)
Hilfe zum PBXB64-Compiler

VFNMADD132SD - FMA: -(a*b)+c (doppelt, skalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMADD132SD - FMA: -(a*b)+c (doppelt, skalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFNMADD132SD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmadd132sd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmadd132sd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMADD132SD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMADD132SD operand[, operand]

PBXB64-Verwendung

VFNMADD132SD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMADD132SD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMADD132SS - FMA: -(a*b)+c (einzeln, skalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFNMADD132SS - FMA: -(a*b)+c (einzeln, skalar)
Hilfe zum PBXB64-Compiler

VFNMADD132SS - FMA: -(a*b)+c (einzeln, skalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMADD132SS - FMA: -(a*b)+c (einzeln, skalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFNMADD132SS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmadd132ss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmadd132ss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMADD132SS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMADD132SS operand[, operand]

PBXB64-Verwendung

VFNMADD132SS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMADD132SS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMADD213SD - FMA: -(a*b)+c (doppelt, skalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFNMADD213SD - FMA: -(a*b)+c (doppelt, skalar)
Hilfe zum PBXB64-Compiler

VFNMADD213SD - FMA: -(a*b)+c (doppelt, skalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMADD213SD - FMA: -(a*b)+c (doppelt, skalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFNMADD213SD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmadd213sd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmadd213sd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMADD213SD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMADD213SD operand[, operand]

PBXB64-Verwendung

VFNMADD213SD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMADD213SD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMADD213SS - FMA: -(a*b)+c (einzeln, skalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFNMADD213SS - FMA: -(a*b)+c (einzeln, skalar)
Hilfe zum PBXB64-Compiler

VFNMADD213SS - FMA: -(a*b)+c (einzeln, skalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMADD213SS - FMA: -(a*b)+c (einzeln, skalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFNMADD213SS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmadd213ss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmadd213ss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMADD213SS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMADD213SS operand[, operand]

PBXB64-Verwendung

VFNMADD213SS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMADD213SS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMADD231SD - FMA: -(a*b)+c (doppelt, skalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFNMADD231SD - FMA: -(a*b)+c (doppelt, skalar)
Hilfe zum PBXB64-Compiler

VFNMADD231SD - FMA: -(a*b)+c (doppelt, skalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMADD231SD - FMA: -(a*b)+c (doppelt, skalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFNMADD231SD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmadd231sd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmadd231sd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMADD231SD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMADD231SD operand[, operand]

PBXB64-Verwendung

VFNMADD231SD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMADD231SD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMADD231SS - FMA: -(a*b)+c (einzeln, skalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFNMADD231SS - FMA: -(a*b)+c (einzeln, skalar)
Hilfe zum PBXB64-Compiler

VFNMADD231SS - FMA: -(a*b)+c (einzeln, skalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMADD231SS - FMA: -(a*b)+c (einzeln, skalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFNMADD231SS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmadd231ss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmadd231ss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMADD231SS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMADD231SS operand[, operand]

PBXB64-Verwendung

VFNMADD231SS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMADD231SS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMSUB132SD - FMA: -(a*b)-c (doppelt, skalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFNMSUB132SD - FMA: -(a*b)-c (doppelt, skalar)
Hilfe zum PBXB64-Compiler

VFNMSUB132SD - FMA: -(a*b)-c (doppelt, skalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMSUB132SD - FMA: -(a*b)-c (doppelt, skalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFNMSUB132SD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmsub132sd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmsub132sd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMSUB132SD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMSUB132SD operand[, operand]

PBXB64-Verwendung

VFNMSUB132SD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMSUB132SD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMSUB132SS - FMA: -(a*b)-c (einzeln, skalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFNMSUB132SS - FMA: -(a*b)-c (einzeln, skalar)
Hilfe zum PBXB64-Compiler

VFNMSUB132SS - FMA: -(a*b)-c (einzeln, skalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMSUB132SS - FMA: -(a*b)-c (einzeln, skalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFNMSUB132SS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmsub132ss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmsub132ss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMSUB132SS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMSUB132SS operand[, operand]

PBXB64-Verwendung

VFNMSUB132SS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMSUB132SS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMSUB213SD - FMA: -(a*b)-c (doppelt, skalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFNMSUB213SD - FMA: -(a*b)-c (doppelt, skalar)
Hilfe zum PBXB64-Compiler

VFNMSUB213SD - FMA: -(a*b)-c (doppelt, skalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMSUB213SD - FMA: -(a*b)-c (doppelt, skalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFNMSUB213SD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmsub213sd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmsub213sd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMSUB213SD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMSUB213SD operand[, operand]

PBXB64-Verwendung

VFNMSUB213SD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMSUB213SD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMSUB213SS - FMA: -(a*b)-c (einzeln, skalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFNMSUB213SS - FMA: -(a*b)-c (einzeln, skalar)
Hilfe zum PBXB64-Compiler

VFNMSUB213SS - FMA: -(a*b)-c (einzeln, skalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMSUB213SS - FMA: -(a*b)-c (einzeln, skalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFNMSUB213SS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmsub213ss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmsub213ss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMSUB213SS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMSUB213SS operand[, operand]

PBXB64-Verwendung

VFNMSUB213SS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMSUB213SS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMSUB231SD - FMA: -(a*b)-c (doppelt, skalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFNMSUB231SD - FMA: -(a*b)-c (doppelt, skalar)
Hilfe zum PBXB64-Compiler

VFNMSUB231SD - FMA: -(a*b)-c (doppelt, skalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMSUB231SD - FMA: -(a*b)-c (doppelt, skalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFNMSUB231SD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmsub231sd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmsub231sd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMSUB231SD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMSUB231SD operand[, operand]

PBXB64-Verwendung

VFNMSUB231SD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMSUB231SD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VFNMSUB231SS - FMA: -(a*b)-c (einzeln, skalar) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VFNMSUB231SS - FMA: -(a*b)-c (einzeln, skalar)
Hilfe zum PBXB64-Compiler

VFNMSUB231SS - FMA: -(a*b)-c (einzeln, skalar)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VFNMSUB231SS - FMA: -(a*b)-c (einzeln, skalar). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VFNMSUB231SS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vfnmsub231ss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vfnmsub231ss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VFNMSUB231SS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VFNMSUB231SS operand[, operand]

PBXB64-Verwendung

VFNMSUB231SS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VFNMSUB231SS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VGATHERPF0DPD - Prefetch Gather Double, Intent Level 0 - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VGATHERPF0DPD - Prefetch Gather Double, Intent Level 0
Hilfe zum PBXB64-Compiler

VGATHERPF0DPD - Prefetch Gather Double, Intent Level 0

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VGATHERPF0DPD - Prefetch Gather Double, Intent Level 0. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen mem (VSIB).

Syntax

VGATHERPF0DPD mem (VSIB)

Operands and Sizes

Form | Meaning
mem (VSIB) | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vgatherpf0dpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vgatherpf0dpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VGATHERPF0DPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VGATHERPF0DPD operand[, operand]

PBXB64-Verwendung

VGATHERPF0DPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VGATHERPF0DPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VGATHERPF0DPS - Prefetch Gather Single, Intent Level 0 - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VGATHERPF0DPS - Prefetch Gather Single, Intent Level 0
Hilfe zum PBXB64-Compiler

VGATHERPF0DPS - Prefetch Gather Single, Intent Level 0

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VGATHERPF0DPS - Prefetch Gather Single, Intent Level 0. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen mem (VSIB).

Syntax

VGATHERPF0DPS mem (VSIB)

Operands and Sizes

Form | Meaning
mem (VSIB) | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vgatherpf0dps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vgatherpf0dps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VGATHERPF0DPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VGATHERPF0DPS operand[, operand]

PBXB64-Verwendung

VGATHERPF0DPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VGATHERPF0DPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VGATHERPF1DPD - Prefetch Gather Double, Intent Level 1 - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VGATHERPF1DPD - Prefetch Gather Double, Intent Level 1
Hilfe zum PBXB64-Compiler

VGATHERPF1DPD - Prefetch Gather Double, Intent Level 1

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VGATHERPF1DPD - Prefetch Gather Double, Intent Level 1. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen mem (VSIB).

Syntax

VGATHERPF1DPD mem (VSIB)

Operands and Sizes

Form | Meaning
mem (VSIB) | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vgatherpf1dpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vgatherpf1dpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VGATHERPF1DPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VGATHERPF1DPD operand[, operand]

PBXB64-Verwendung

VGATHERPF1DPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VGATHERPF1DPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VGATHERPF1DPS - Prefetch Gather Single, Intent Level 1 - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VGATHERPF1DPS - Prefetch Gather Single, Intent Level 1
Hilfe zum PBXB64-Compiler

VGATHERPF1DPS - Prefetch Gather Single, Intent Level 1

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VGATHERPF1DPS - Prefetch Gather Single, Intent Level 1. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen mem (VSIB).

Syntax

VGATHERPF1DPS mem (VSIB)

Operands and Sizes

Form | Meaning
mem (VSIB) | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vgatherpf1dps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vgatherpf1dps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VGATHERPF1DPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VGATHERPF1DPS operand[, operand]

PBXB64-Verwendung

VGATHERPF1DPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VGATHERPF1DPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VGETEXPSD - Exponenten-Skalar-Doppel extrahieren - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VGETEXPSD - Exponenten-Skalar-Doppel extrahieren
Hilfe zum PBXB64-Compiler

VGETEXPSD - Exponenten-Skalar-Doppel extrahieren

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VGETEXPSD - Exponenten-Skalar-Doppel extrahieren. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VGETEXPSD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vgetexpsd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vgetexpsd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VGETEXPSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VGETEXPSD operand[, operand]

PBXB64-Verwendung

VGETEXPSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VGETEXPSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VGETEXPSS - Exponentenskalar einzeln extrahieren - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VGETEXPSS - Exponentenskalar einzeln extrahieren
Hilfe zum PBXB64-Compiler

VGETEXPSS - Exponentenskalar einzeln extrahieren

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VGETEXPSS - Exponentenskalar einzeln extrahieren. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VGETEXPSS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vgetexpss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vgetexpss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VGETEXPSS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VGETEXPSS operand[, operand]

PBXB64-Verwendung

VGETEXPSS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VGETEXPSS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VGF2P8MULB - Galois-Feld multipliziert Bytes (GF(2^8)) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VGF2P8MULB - Galois-Feld multipliziert Bytes (GF(2^8))
Hilfe zum PBXB64-Compiler

VGF2P8MULB - Galois-Feld multipliziert Bytes (GF(2^8))

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VGF2P8MULB - Galois-Feld multipliziert Bytes (GF(2^8)). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm/xmm, zmm/xmm, zmm/mem.

Syntax

VGF2P8MULB zmm/xmm, zmm/xmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm | may read or write memory
xmm, zmm | uses XMM vector/scalar registers; may read or write memory
xmm, zmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vgf2p8mulb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vgf2p8mulb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VGF2P8MULB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VGF2P8MULB operand[, operand]

PBXB64-Verwendung

VGF2P8MULB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VGF2P8MULB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMAXSD - Maximales Skalar-Double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VMAXSD - Maximales Skalar-Double
Hilfe zum PBXB64-Compiler

VMAXSD - Maximales Skalar-Double

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMAXSD - Maximales Skalar-Double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VMAXSD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmaxsd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmaxsd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMAXSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMAXSD operand[, operand]

PBXB64-Verwendung

VMAXSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMAXSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMAXSS - Maximaler Skalar-Single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VMAXSS - Maximaler Skalar-Single
Hilfe zum PBXB64-Compiler

VMAXSS - Maximaler Skalar-Single

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMAXSS - Maximaler Skalar-Single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VMAXSS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmaxss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmaxss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMAXSS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMAXSS operand[, operand]

PBXB64-Verwendung

VMAXSS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMAXSS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMINSD - Minimales Skalardoppel - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VMINSD - Minimales Skalardoppel
Hilfe zum PBXB64-Compiler

VMINSD - Minimales Skalardoppel

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMINSD - Minimales Skalardoppel. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VMINSD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vminsd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vminsd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMINSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMINSD operand[, operand]

PBXB64-Verwendung

VMINSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMINSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMINSS - Minimaler Skalar-Single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VMINSS - Minimaler Skalar-Single
Hilfe zum PBXB64-Compiler

VMINSS - Minimaler Skalar-Single

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMINSS - Minimaler Skalar-Single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VMINSS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vminss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vminss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMINSS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMINSS operand[, operand]

PBXB64-Verwendung

VMINSS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMINSS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMULSD - Skalar mit dem Doppelten multiplizieren - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VMULSD - Skalar mit dem Doppelten multiplizieren
Hilfe zum PBXB64-Compiler

VMULSD - Skalar mit dem Doppelten multiplizieren

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMULSD - Skalar mit dem Doppelten multiplizieren. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VMULSD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmulsd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmulsd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMULSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMULSD operand[, operand]

PBXB64-Verwendung

VMULSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMULSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMULSS - Skalar-Single multiplizieren - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VMULSS - Skalar-Single multiplizieren
Hilfe zum PBXB64-Compiler

VMULSS - Skalar-Single multiplizieren

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMULSS - Skalar-Single multiplizieren. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VMULSS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmulss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmulss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMULSS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMULSS operand[, operand]

PBXB64-Verwendung

VMULSS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMULSS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPABSB - Absolute value of bytes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VPABSB - Absolute value of bytes
Hilfe zum PBXB64-Compiler

VPABSB - Absolute value of bytes

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPABSB - Absolute value of bytes. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/mem.

Syntax

VPABSB ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpabsb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpabsb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPABSB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPABSB operand[, operand]

PBXB64-Verwendung

VPABSB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPABSB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPERMB - Bytes über Lanes hinweg permutieren - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VPERMB - Bytes über Lanes hinweg permutieren
Hilfe zum PBXB64-Compiler

VPERMB - Bytes über Lanes hinweg permutieren

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERMB - Bytes über Lanes hinweg permutieren. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPERMB zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpermb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpermb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERMB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERMB operand[, operand]

PBXB64-Verwendung

VPERMB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERMB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPERMI2PD - Zwei-Quellen-Permutation von Doubles mit Index - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VPERMI2PD - Zwei-Quellen-Permutation von Doubles mit Index
Hilfe zum PBXB64-Compiler

VPERMI2PD - Zwei-Quellen-Permutation von Doubles mit Index

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERMI2PD - Zwei-Quellen-Permutation von Doubles mit Index. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPERMI2PD zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpermi2pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpermi2pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERMI2PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERMI2PD operand[, operand]

PBXB64-Verwendung

VPERMI2PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERMI2PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPERMI2PS - Permutation von Singles aus zwei Quellen mit Index - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VPERMI2PS - Permutation von Singles aus zwei Quellen mit Index
Hilfe zum PBXB64-Compiler

VPERMI2PS - Permutation von Singles aus zwei Quellen mit Index

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERMI2PS - Permutation von Singles aus zwei Quellen mit Index. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPERMI2PS zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpermi2ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpermi2ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERMI2PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERMI2PS operand[, operand]

PBXB64-Verwendung

VPERMI2PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERMI2PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPERMT2PD - Zwei-Quellen-Permutation von Doubles (Index im Ziel) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VPERMT2PD - Zwei-Quellen-Permutation von Doubles (Index im Ziel)
Hilfe zum PBXB64-Compiler

VPERMT2PD - Zwei-Quellen-Permutation von Doubles (Index im Ziel)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERMT2PD - Zwei-Quellen-Permutation von Doubles (Index im Ziel). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPERMT2PD zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpermt2pd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpermt2pd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERMT2PD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERMT2PD operand[, operand]

PBXB64-Verwendung

VPERMT2PD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERMT2PD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPERMT2PS - Zwei-Quellen-Permutation von Singles (Index im Ziel) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VPERMT2PS - Zwei-Quellen-Permutation von Singles (Index im Ziel)
Hilfe zum PBXB64-Compiler

VPERMT2PS - Zwei-Quellen-Permutation von Singles (Index im Ziel)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPERMT2PS - Zwei-Quellen-Permutation von Singles (Index im Ziel). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPERMT2PS zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpermt2ps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpermt2ps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPERMT2PS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPERMT2PS operand[, operand]

PBXB64-Verwendung

VPERMT2PS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPERMT2PS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSADBW - Sum of absolute differences - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VPSADBW - Sum of absolute differences
Hilfe zum PBXB64-Compiler

VPSADBW - Sum of absolute differences

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSADBW - Sum of absolute differences. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPSADBW ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsadbw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsadbw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSADBW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSADBW operand[, operand]

PBXB64-Verwendung

VPSADBW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSADBW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSHLDV - Variable Verschiebung nach links doppelt (verkettete Verschiebung) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VPSHLDV - Variable Verschiebung nach links doppelt (verkettete Verschiebung)
Hilfe zum PBXB64-Compiler

VPSHLDV - Variable Verschiebung nach links doppelt (verkettete Verschiebung)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSHLDV - Variable Verschiebung nach links doppelt (verkettete Verschiebung). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPSHLDV zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpshldv ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpshldv ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSHLDV ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSHLDV operand[, operand]

PBXB64-Verwendung

VPSHLDV ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSHLDV ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSHLDVW - Variable Doppelwörter nach links verschieben - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VPSHLDVW - Variable Doppelwörter nach links verschieben
Hilfe zum PBXB64-Compiler

VPSHLDVW - Variable Doppelwörter nach links verschieben

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSHLDVW - Variable Doppelwörter nach links verschieben. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPSHLDVW zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpshldvw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpshldvw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSHLDVW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSHLDVW operand[, operand]

PBXB64-Verwendung

VPSHLDVW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSHLDVW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← VPSHLDV - Variable Verschiebung nach links doppelt (verkettete Verschiebung) Top VPSHRDV - Variable Verschiebung nach rechts doppelt (verkettete Verschiebung) →


VPSHRDV - Variable Verschiebung nach rechts doppelt (verkettete Verschiebung) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VPSHRDV - Variable Verschiebung nach rechts doppelt (verkettete Verschiebung)
Hilfe zum PBXB64-Compiler

VPSHRDV - Variable Verschiebung nach rechts doppelt (verkettete Verschiebung)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSHRDV - Variable Verschiebung nach rechts doppelt (verkettete Verschiebung). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPSHRDV zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpshrdv ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpshrdv ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSHRDV ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSHRDV operand[, operand]

PBXB64-Verwendung

VPSHRDV ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSHRDV ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSHRDVW - Variable Doppelwörter nach rechts verschieben - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VPSHRDVW - Variable Doppelwörter nach rechts verschieben
Hilfe zum PBXB64-Compiler

VPSHRDVW - Variable Doppelwörter nach rechts verschieben

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSHRDVW - Variable Doppelwörter nach rechts verschieben. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPSHRDVW zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpshrdvw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpshrdvw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSHRDVW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSHRDVW operand[, operand]

PBXB64-Verwendung

VPSHRDVW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSHRDVW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSIGNB - Sign of bytes - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VPSIGNB - Sign of bytes
Hilfe zum PBXB64-Compiler

VPSIGNB - Sign of bytes

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSIGNB - Sign of bytes. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, ymm/xmm, ymm/mem.

Syntax

VPSIGNB ymm/xmm, ymm/xmm, ymm/mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
xmm, ymm | uses XMM vector/scalar registers; uses YMM vector registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsignb ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsignb ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSIGNB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSIGNB operand[, operand]

PBXB64-Verwendung

VPSIGNB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSIGNB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSLLVW - Variable logische Wörter nach links verschieben - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VPSLLVW - Variable logische Wörter nach links verschieben
Hilfe zum PBXB64-Compiler

VPSLLVW - Variable logische Wörter nach links verschieben

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSLLVW - Variable logische Wörter nach links verschieben. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPSLLVW zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsllvw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsllvw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSLLVW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSLLVW operand[, operand]

PBXB64-Verwendung

VPSLLVW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSLLVW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


VPSRAVW - Variable arithmetische Wörter nach rechts verschieben - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VPSRAVW - Variable arithmetische Wörter nach rechts verschieben
Hilfe zum PBXB64-Compiler

VPSRAVW - Variable arithmetische Wörter nach rechts verschieben

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSRAVW - Variable arithmetische Wörter nach rechts verschieben. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPSRAVW zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsravw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsravw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSRAVW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSRAVW operand[, operand]

PBXB64-Verwendung

VPSRAVW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSRAVW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPSRLVW - Variable logische Wörter nach rechts verschieben - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VPSRLVW - Variable logische Wörter nach rechts verschieben
Hilfe zum PBXB64-Compiler

VPSRLVW - Variable logische Wörter nach rechts verschieben

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPSRLVW - Variable logische Wörter nach rechts verschieben. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VPSRLVW zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpsrlvw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpsrlvw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPSRLVW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPSRLVW operand[, operand]

PBXB64-Verwendung

VPSRLVW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPSRLVW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRANGESD - Bereichseinschränkung Skalar Double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VRANGESD - Bereichseinschränkung Skalar Double
Hilfe zum PBXB64-Compiler

VRANGESD - Bereichseinschränkung Skalar Double

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRANGESD - Bereichseinschränkung Skalar Double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/mem, imm8.

Syntax

VRANGESD xmm, xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrangesd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrangesd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRANGESD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRANGESD operand[, operand]

PBXB64-Verwendung

VRANGESD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRANGESD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRANGESS - Bereichseinschränkung Skalar Single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VRANGESS - Bereichseinschränkung Skalar Single
Hilfe zum PBXB64-Compiler

VRANGESS - Bereichseinschränkung Skalar Single

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRANGESS - Bereichseinschränkung Skalar Single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/mem, imm8.

Syntax

VRANGESS xmm, xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrangess ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrangess ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRANGESS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRANGESS operand[, operand]

PBXB64-Verwendung

VRANGESS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRANGESS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRCPSS - Reziproker Skalar Single (ungefähr) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VRCPSS - Reziproker Skalar Single (ungefähr)
Hilfe zum PBXB64-Compiler

VRCPSS - Reziproker Skalar Single (ungefähr)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRCPSS - Reziproker Skalar Single (ungefähr). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VRCPSS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrcpss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrcpss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRCPSS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRCPSS operand[, operand]

PBXB64-Verwendung

VRCPSS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRCPSS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRNDSCALESD - Rundes Skalardoppel mit Skala - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VRNDSCALESD - Rundes Skalardoppel mit Skala
Hilfe zum PBXB64-Compiler

VRNDSCALESD - Rundes Skalardoppel mit Skala

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRNDSCALESD - Rundes Skalardoppel mit Skala. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/mem, imm8.

Syntax

VRNDSCALESD xmm, xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrndscalesd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrndscalesd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRNDSCALESD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRNDSCALESD operand[, operand]

PBXB64-Verwendung

VRNDSCALESD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRNDSCALESD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRNDSCALESS - Runder Skalar einzeln mit Skala - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VRNDSCALESS - Runder Skalar einzeln mit Skala
Hilfe zum PBXB64-Compiler

VRNDSCALESS - Runder Skalar einzeln mit Skala

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRNDSCALESS - Runder Skalar einzeln mit Skala. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/mem, imm8.

Syntax

VRNDSCALESS xmm, xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrndscaless ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrndscaless ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRNDSCALESS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRNDSCALESS operand[, operand]

PBXB64-Verwendung

VRNDSCALESS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRNDSCALESS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VROUNDSD - Rundes Skalardoppel - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VROUNDSD - Rundes Skalardoppel
Hilfe zum PBXB64-Compiler

VROUNDSD - Rundes Skalardoppel

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VROUNDSD - Rundes Skalardoppel. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem, imm8.

Syntax

VROUNDSD xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vroundsd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vroundsd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VROUNDSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VROUNDSD operand[, operand]

PBXB64-Verwendung

VROUNDSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VROUNDSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VROUNDSS - Runde Skalar-Single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VROUNDSS - Runde Skalar-Single
Hilfe zum PBXB64-Compiler

VROUNDSS - Runde Skalar-Single

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VROUNDSS - Runde Skalar-Single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem, imm8.

Syntax

VROUNDSS xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vroundss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vroundss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VROUNDSS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VROUNDSS operand[, operand]

PBXB64-Verwendung

VROUNDSS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VROUNDSS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VRSQRTSS - Reziproker quadratischer Skalar einzeln (ungefähr) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VRSQRTSS - Reziproker quadratischer Skalar einzeln (ungefähr)
Hilfe zum PBXB64-Compiler

VRSQRTSS - Reziproker quadratischer Skalar einzeln (ungefähr)

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VRSQRTSS - Reziproker quadratischer Skalar einzeln (ungefähr). Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VRSQRTSS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vrsqrtss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vrsqrtss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VRSQRTSS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VRSQRTSS operand[, operand]

PBXB64-Verwendung

VRSQRTSS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VRSQRTSS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VSCALEFPS - Skalieren Sie einzeln mit Zweierpotenzen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VSCALEFPS - Skalieren Sie einzeln mit Zweierpotenzen
Hilfe zum PBXB64-Compiler

VSCALEFPS - Skalieren Sie einzeln mit Zweierpotenzen

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VSCALEFPS - Skalieren Sie einzeln mit Zweierpotenzen. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen zmm, zmm, zmm/mem.

Syntax

VSCALEFPS zmm, zmm, zmm/mem

Operands and Sizes

Form | Meaning
zmm, zmm, zmm | may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vscalefps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vscalefps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VSCALEFPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VSCALEFPS operand[, operand]

PBXB64-Verwendung

VSCALEFPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VSCALEFPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VSCATTERPF0DPD - Prefetch-Scatter-Double, Absichtsstufe 0 - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VSCATTERPF0DPD - Prefetch-Scatter-Double, Absichtsstufe 0
Hilfe zum PBXB64-Compiler

VSCATTERPF0DPD - Prefetch-Scatter-Double, Absichtsstufe 0

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VSCATTERPF0DPD - Prefetch-Scatter-Double, Absichtsstufe 0. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen mem (VSIB).

Syntax

VSCATTERPF0DPD mem (VSIB)

Operands and Sizes

Form | Meaning
mem (VSIB) | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vscatterpf0dpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vscatterpf0dpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VSCATTERPF0DPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VSCATTERPF0DPD operand[, operand]

PBXB64-Verwendung

VSCATTERPF0DPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VSCATTERPF0DPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VSCATTERPF0DPS - Prefetch-Scatter einzeln, Absichtsebene 0 - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VSCATTERPF0DPS - Prefetch-Scatter einzeln, Absichtsebene 0
Hilfe zum PBXB64-Compiler

VSCATTERPF0DPS - Prefetch-Scatter einzeln, Absichtsebene 0

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VSCATTERPF0DPS - Prefetch-Scatter einzeln, Absichtsebene 0. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen mem (VSIB).

Syntax

VSCATTERPF0DPS mem (VSIB)

Operands and Sizes

Form | Meaning
mem (VSIB) | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vscatterpf0dps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vscatterpf0dps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VSCATTERPF0DPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VSCATTERPF0DPS operand[, operand]

PBXB64-Verwendung

VSCATTERPF0DPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VSCATTERPF0DPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VSCATTERPF1DPD - Prefetch-Scatter-Double, Absichtsstufe 1 - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VSCATTERPF1DPD - Prefetch-Scatter-Double, Absichtsstufe 1
Hilfe zum PBXB64-Compiler

VSCATTERPF1DPD - Prefetch-Scatter-Double, Absichtsstufe 1

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VSCATTERPF1DPD - Prefetch-Scatter-Double, Absichtsstufe 1. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen mem (VSIB).

Syntax

VSCATTERPF1DPD mem (VSIB)

Operands and Sizes

Form | Meaning
mem (VSIB) | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vscatterpf1dpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vscatterpf1dpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VSCATTERPF1DPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VSCATTERPF1DPD operand[, operand]

PBXB64-Verwendung

VSCATTERPF1DPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VSCATTERPF1DPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VSCATTERPF1DPS - Prefetch-Scatter einzeln, Absichtsebene 1 - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VSCATTERPF1DPS - Prefetch-Scatter einzeln, Absichtsebene 1
Hilfe zum PBXB64-Compiler

VSCATTERPF1DPS - Prefetch-Scatter einzeln, Absichtsebene 1

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VSCATTERPF1DPS - Prefetch-Scatter einzeln, Absichtsebene 1. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen mem (VSIB).

Syntax

VSCATTERPF1DPS mem (VSIB)

Operands and Sizes

Form | Meaning
mem (VSIB) | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vscatterpf1dps ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vscatterpf1dps ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VSCATTERPF1DPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VSCATTERPF1DPS operand[, operand]

PBXB64-Verwendung

VSCATTERPF1DPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VSCATTERPF1DPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VSQRTSD - Quadratwurzel-Skalar-Double - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VSQRTSD - Quadratwurzel-Skalar-Double
Hilfe zum PBXB64-Compiler

VSQRTSD - Quadratwurzel-Skalar-Double

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VSQRTSD - Quadratwurzel-Skalar-Double. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VSQRTSD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vsqrtsd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vsqrtsd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VSQRTSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VSQRTSD operand[, operand]

PBXB64-Verwendung

VSQRTSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VSQRTSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VSQRTSS - Quadratwurzel-Skalar-Single - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VSQRTSS - Quadratwurzel-Skalar-Single
Hilfe zum PBXB64-Compiler

VSQRTSS - Quadratwurzel-Skalar-Single

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VSQRTSS - Quadratwurzel-Skalar-Single. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VSQRTSS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vsqrtss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vsqrtss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VSQRTSS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VSQRTSS operand[, operand]

PBXB64-Verwendung

VSQRTSS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VSQRTSS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VSUBSD - Subtrahiere das Skalardoppel - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VSUBSD - Subtrahiere das Skalardoppel
Hilfe zum PBXB64-Compiler

VSUBSD - Subtrahiere das Skalardoppel

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VSUBSD - Subtrahiere das Skalardoppel. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VSUBSD xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vsubsd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vsubsd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VSUBSD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VSUBSD operand[, operand]

PBXB64-Verwendung

VSUBSD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VSUBSD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VSUBSS - Subtrahieren Sie den Skalar einzeln - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SSE / AVX › VSUBSS - Subtrahieren Sie den Skalar einzeln
Hilfe zum PBXB64-Compiler

VSUBSS - Subtrahieren Sie den Skalar einzeln

Category: AVX Instruction

Assembly Group: AVX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VSUBSS - Subtrahieren Sie den Skalar einzeln. Diese Instruktion gehoert zur AVX-Familie und verwendet die dokumentierten Operandenformen xmm, xmm, xmm/Speicher.

Syntax

VSUBSS xmm, xmm, xmm/Speicher

Operands and Sizes

Form | Meaning
xmm, xmm, xmm | uses XMM vector/scalar registers; may read or write memory
Speicher | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vsubss ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vsubss ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_avx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VSUBSS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VSUBSS operand[, operand]

PBXB64-Verwendung

VSUBSS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VSUBSS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • AVX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FABS - Absoluter Wert - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FABS - Absoluter Wert
Hilfe zum PBXB64-Compiler

FABS - Absoluter Wert

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FABS - Absoluter Wert. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

FABS keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fabs operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fabs operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FABS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FABS operand[, operand]

PBXB64-Verwendung

FABS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FABS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FBSTP - Speichern Sie den BCD-Wert und den Pop - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FBSTP - Speichern Sie den BCD-Wert und den Pop
Hilfe zum PBXB64-Compiler

FBSTP - Speichern Sie den BCD-Wert und den Pop

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FBSTP - Speichern Sie den BCD-Wert und den Pop. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem80 (TBYTE).

Syntax

FBSTP mem80 (TBYTE)

Operands and Sizes

Form | Meaning
mem80 (TBYTE) | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fbstp [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fbstp [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FBSTP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FBSTP operand[, operand]

PBXB64-Verwendung

FBSTP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FBSTP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FCLEX - FPU-Ausnahmen löschen (warten) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FCLEX - FPU-Ausnahmen löschen (warten)
Hilfe zum PBXB64-Compiler

FCLEX - FPU-Ausnahmen löschen (warten)

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FCLEX - FPU-Ausnahmen löschen (warten). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

FCLEX keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fclex operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fclex operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FCLEX ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FCLEX operand[, operand]

PBXB64-Verwendung

FCLEX ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FCLEX ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FCOMP - Vergleichen und Pop - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FCOMP - Vergleichen und Pop
Hilfe zum PBXB64-Compiler

FCOMP - Vergleichen und Pop

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FCOMP - Vergleichen und Pop. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem32/64 / ST(i).

Syntax

FCOMP mem32/64 / ST(i)

Operands and Sizes

Form | Meaning
mem32 | may read or write memory
64 | follow the operand order shown in the syntax
ST(i) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fcomp [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fcomp [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FCOMP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FCOMP operand[, operand]

PBXB64-Verwendung

FCOMP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FCOMP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


FCOMPP - Vergleichen und Pop zweimal - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FCOMPP - Vergleichen und Pop zweimal
Hilfe zum PBXB64-Compiler

FCOMPP - Vergleichen und Pop zweimal

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FCOMPP - Vergleichen und Pop zweimal. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

FCOMPP keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fcompp operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fcompp operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FCOMPP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FCOMPP operand[, operand]

PBXB64-Verwendung

FCOMPP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FCOMPP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


FDECSTP - Dekrementieren Sie den FPU-Stapelzeiger - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FDECSTP - Dekrementieren Sie den FPU-Stapelzeiger
Hilfe zum PBXB64-Compiler

FDECSTP - Dekrementieren Sie den FPU-Stapelzeiger

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FDECSTP - Dekrementieren Sie den FPU-Stapelzeiger. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

FDECSTP keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fdecstp operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fdecstp operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FDECSTP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FDECSTP operand[, operand]

PBXB64-Verwendung

FDECSTP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FDECSTP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FDIV - Teilen (ST0 = ST0 / src) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FDIV - Teilen (ST0 = ST0 / src)
Hilfe zum PBXB64-Compiler

FDIV - Teilen (ST0 = ST0 / src)

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FDIV - Teilen (ST0 = ST0 / src). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem32/64 / ST(i).

Syntax

FDIV mem32/64 / ST(i)

Operands and Sizes

Form | Meaning
mem32 | may read or write memory
64 | follow the operand order shown in the syntax
ST(i) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fdiv [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fdiv [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FDIV ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FDIV operand[, operand]

PBXB64-Verwendung

FDIV ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FDIV ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FDIVP - Teilen und platzen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FDIVP - Teilen und platzen
Hilfe zum PBXB64-Compiler

FDIVP - Teilen und platzen

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FDIVP - Teilen und platzen. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen ST(i), ST(0).

Syntax

FDIVP ST(i), ST(0)

Operands and Sizes

Form | Meaning
ST(i), ST(0) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fdivp operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fdivp operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FDIVP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FDIVP operand[, operand]

PBXB64-Verwendung

FDIVP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FDIVP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FDIVR - Rückwärts dividieren (ST0 = src / ST0) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FDIVR - Rückwärts dividieren (ST0 = src / ST0)
Hilfe zum PBXB64-Compiler

FDIVR - Rückwärts dividieren (ST0 = src / ST0)

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FDIVR - Rückwärts dividieren (ST0 = src / ST0). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem32/64 / ST(i).

Syntax

FDIVR mem32/64 / ST(i)

Operands and Sizes

Form | Meaning
mem32 | may read or write memory
64 | follow the operand order shown in the syntax
ST(i) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fdivr [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fdivr [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FDIVR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FDIVR operand[, operand]

PBXB64-Verwendung

FDIVR ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FDIVR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FDIVRP - Umgekehrt teilen und platzen lassen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FDIVRP - Umgekehrt teilen und platzen lassen
Hilfe zum PBXB64-Compiler

FDIVRP - Umgekehrt teilen und platzen lassen

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FDIVRP - Umgekehrt teilen und platzen lassen. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen ST(i), ST(0).

Syntax

FDIVRP ST(i), ST(0)

Operands and Sizes

Form | Meaning
ST(i), ST(0) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fdivrp operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fdivrp operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FDIVRP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FDIVRP operand[, operand]

PBXB64-Verwendung

FDIVRP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FDIVRP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FFREE - Freies FPU-Register ST(i) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FFREE - Freies FPU-Register ST(i)
Hilfe zum PBXB64-Compiler

FFREE - Freies FPU-Register ST(i)

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FFREE - Freies FPU-Register ST(i). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen ST(i).

Syntax

FFREE ST(i)

Operands and Sizes

Form | Meaning
ST(i) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    ffree operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! ffree operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FFREE ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FFREE operand[, operand]

PBXB64-Verwendung

FFREE ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FFREE ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FIADD - Fügen Sie eine Ganzzahl zu ST0 hinzu - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FIADD - Fügen Sie eine Ganzzahl zu ST0 hinzu
Hilfe zum PBXB64-Compiler

FIADD - Fügen Sie eine Ganzzahl zu ST0 hinzu

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FIADD - Fügen Sie eine Ganzzahl zu ST0 hinzu. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem16/32.

Syntax

FIADD mem16/32

Operands and Sizes

Form | Meaning
mem16 | may read or write memory
32 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fiadd [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fiadd [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FIADD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FIADD operand[, operand]

PBXB64-Verwendung

FIADD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FIADD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FICOM - Vergleichen Sie ST0 mit einer Ganzzahl - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FICOM - Vergleichen Sie ST0 mit einer Ganzzahl
Hilfe zum PBXB64-Compiler

FICOM - Vergleichen Sie ST0 mit einer Ganzzahl

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FICOM - Vergleichen Sie ST0 mit einer Ganzzahl. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem16/32.

Syntax

FICOM mem16/32

Operands and Sizes

Form | Meaning
mem16 | may read or write memory
32 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    ficom [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! ficom [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FICOM ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FICOM operand[, operand]

PBXB64-Verwendung

FICOM ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FICOM ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


FICOMP - Vergleichen Sie Integer und Pop - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FICOMP - Vergleichen Sie Integer und Pop
Hilfe zum PBXB64-Compiler

FICOMP - Vergleichen Sie Integer und Pop

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FICOMP - Vergleichen Sie Integer und Pop. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem16/32.

Syntax

FICOMP mem16/32

Operands and Sizes

Form | Meaning
mem16 | may read or write memory
32 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    ficomp [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! ficomp [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FICOMP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FICOMP operand[, operand]

PBXB64-Verwendung

FICOMP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FICOMP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

COM- und Objektprüfung

COM-, DLL-, SLL-, Objekt- und Interface-Seiten sollen Erzeugung, Lebensdauer, Referenzbesitz, HRESULT-Behandlung und Cleanup dokumentieren. Beispiele sollen die Komponente oder Bibliothek nennen, die registriert oder gelinkt werden muss.

x64-Interop-Hinweise

Verwenden Sie zeigergroße Interface-/Objektvariablen und deklarieren Sie Callbacks oder VTable-Einträge mit der korrekten Aufrufkonvention.

Fehlerpfade

Zeigen Sie fehlende Komponenten, fehlgeschlagene Erzeugung, fehlgeschlagene Methodenaufrufe und Cleanup-Verhalten, sofern zutreffend.

Grenzhinweise

Identifizieren Sie bei Uebersichtsseiten, ob der Eintrag ein Erzeugungs-, Abfrage-, Bereinigungs- oder Dispatch-Thema ist, und nennen Sie die konkreten Unterseiten, die das getestete Verhalten tragen. So ist sofort klar, welche Seite die Lebensdauerverwaltung belegt und welche Seite nur der Navigation dient.


FIDIV - Durch ganze Zahl dividieren - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FIDIV - Durch ganze Zahl dividieren
Hilfe zum PBXB64-Compiler

FIDIV - Durch ganze Zahl dividieren

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FIDIV - Durch ganze Zahl dividieren. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem16/32.

Syntax

FIDIV mem16/32

Operands and Sizes

Form | Meaning
mem16 | may read or write memory
32 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fidiv [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fidiv [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FIDIV ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FIDIV operand[, operand]

PBXB64-Verwendung

FIDIV ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FIDIV ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FILD - Ganzzahlwert auf Stapel laden (Push) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FILD - Ganzzahlwert auf Stapel laden (Push)
Hilfe zum PBXB64-Compiler

FILD - Ganzzahlwert auf Stapel laden (Push)

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FILD - Ganzzahlwert auf Stapel laden (Push). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem16/32/64.

Syntax

FILD mem16/32/64

Operands and Sizes

Form | Meaning
mem16 | may read or write memory
32 | follow the operand order shown in the syntax
64 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fild [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fild [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FILD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FILD operand[, operand]

PBXB64-Verwendung

FILD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FILD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FIMUL - Mit einer Ganzzahl multiplizieren - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FIMUL - Mit einer Ganzzahl multiplizieren
Hilfe zum PBXB64-Compiler

FIMUL - Mit einer Ganzzahl multiplizieren

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FIMUL - Mit einer Ganzzahl multiplizieren. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem16/32.

Syntax

FIMUL mem16/32

Operands and Sizes

Form | Meaning
mem16 | may read or write memory
32 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fimul [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fimul [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FIMUL ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FIMUL operand[, operand]

PBXB64-Verwendung

FIMUL ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FIMUL ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FINCSTP - Erhöhen Sie den FPU-Stapelzeiger - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FINCSTP - Erhöhen Sie den FPU-Stapelzeiger
Hilfe zum PBXB64-Compiler

FINCSTP - Erhöhen Sie den FPU-Stapelzeiger

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FINCSTP - Erhöhen Sie den FPU-Stapelzeiger. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

FINCSTP keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fincstp operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fincstp operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FINCSTP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FINCSTP operand[, operand]

PBXB64-Verwendung

FINCSTP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FINCSTP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FINIT - FPU initialisieren (warten) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FINIT - FPU initialisieren (warten)
Hilfe zum PBXB64-Compiler

FINIT - FPU initialisieren (warten)

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FINIT - FPU initialisieren (warten). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

FINIT keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    finit operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! finit operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FINIT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FINIT operand[, operand]

PBXB64-Verwendung

FINIT ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FINIT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FIST - Ganzzahligen Wert speichern - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FIST - Ganzzahligen Wert speichern
Hilfe zum PBXB64-Compiler

FIST - Ganzzahligen Wert speichern

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FIST - Ganzzahligen Wert speichern. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem16/32.

Syntax

FIST mem16/32

Operands and Sizes

Form | Meaning
mem16 | may read or write memory
32 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fist [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fist [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FIST ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FIST operand[, operand]

PBXB64-Verwendung

FIST ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FIST ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FISTP - Speichern Sie einen ganzzahligen Wert und Pop - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FISTP - Speichern Sie einen ganzzahligen Wert und Pop
Hilfe zum PBXB64-Compiler

FISTP - Speichern Sie einen ganzzahligen Wert und Pop

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FISTP - Speichern Sie einen ganzzahligen Wert und Pop. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem16/32/64.

Syntax

FISTP mem16/32/64

Operands and Sizes

Form | Meaning
mem16 | may read or write memory
32 | follow the operand order shown in the syntax
64 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fistp [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fistp [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FISTP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FISTP operand[, operand]

PBXB64-Verwendung

FISTP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FISTP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FISTTP - Ganzzahl abschneiden und speichern, Pop (SSE3) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FISTTP - Ganzzahl abschneiden und speichern, Pop (SSE3)
Hilfe zum PBXB64-Compiler

FISTTP - Ganzzahl abschneiden und speichern, Pop (SSE3)

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FISTTP - Ganzzahl abschneiden und speichern, Pop (SSE3). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem16/32/64.

Syntax

FISTTP mem16/32/64

Operands and Sizes

Form | Meaning
mem16 | may read or write memory
32 | follow the operand order shown in the syntax
64 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fisttp [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fisttp [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FISTTP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FISTTP operand[, operand]

PBXB64-Verwendung

FISTTP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FISTTP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FISUB - Ganzzahl subtrahieren - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FISUB - Ganzzahl subtrahieren
Hilfe zum PBXB64-Compiler

FISUB - Ganzzahl subtrahieren

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FISUB - Ganzzahl subtrahieren. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem16/32.

Syntax

FISUB mem16/32

Operands and Sizes

Form | Meaning
mem16 | may read or write memory
32 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fisub [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fisub [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FISUB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FISUB operand[, operand]

PBXB64-Verwendung

FISUB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FISUB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FLD - Echten Wert auf Stapel laden (Push) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FLD - Echten Wert auf Stapel laden (Push)
Hilfe zum PBXB64-Compiler

FLD - Echten Wert auf Stapel laden (Push)

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FLD - Echten Wert auf Stapel laden (Push). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem32/64/80 / ST(i).

Syntax

FLD mem32/64/80 / ST(i)

Operands and Sizes

Form | Meaning
mem32 | may read or write memory
64 | follow the operand order shown in the syntax
80 | follow the operand order shown in the syntax
ST(i) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fld [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fld [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FLD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FLD operand[, operand]

PBXB64-Verwendung

FLD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FLD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FLD1 - Laden Sie +1,0 - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FLD1 - Laden Sie +1,0
Hilfe zum PBXB64-Compiler

FLD1 - Laden Sie +1,0

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FLD1 - Laden Sie +1,0. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen +1,0.

Syntax

FLD1 +1,0

Operands and Sizes

Form | Meaning
+1,0 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fld1 operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fld1 operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FLD1 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FLD1 operand[, operand]

PBXB64-Verwendung

FLD1 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FLD1 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FLDENV - Laden Sie die FPU-Umgebung - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FLDENV - Laden Sie die FPU-Umgebung
Hilfe zum PBXB64-Compiler

FLDENV - Laden Sie die FPU-Umgebung

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FLDENV - Laden Sie die FPU-Umgebung. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem.

Syntax

FLDENV mem

Operands and Sizes

Form | Meaning
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fldenv [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fldenv [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FLDENV ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FLDENV operand[, operand]

PBXB64-Verwendung

FLDENV ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FLDENV ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FLDL2E - Log2(e) laden - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FLDL2E - Log2(e) laden
Hilfe zum PBXB64-Compiler

FLDL2E - Log2(e) laden

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FLDL2E - Log2(e) laden. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen 1.44269504088896341.

Syntax

FLDL2E 1.44269504088896341

Operands and Sizes

Form | Meaning
1.44269504088896341 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fldl2e operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fldl2e operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FLDL2E ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FLDL2E operand[, operand]

PBXB64-Verwendung

FLDL2E ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FLDL2E ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FLDL2T - Log2(10) laden - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FLDL2T - Log2(10) laden
Hilfe zum PBXB64-Compiler

FLDL2T - Log2(10) laden

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FLDL2T - Log2(10) laden. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen 3.32192809488736235.

Syntax

FLDL2T 3.32192809488736235

Operands and Sizes

Form | Meaning
3.32192809488736235 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fldl2t operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fldl2t operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FLDL2T ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FLDL2T operand[, operand]

PBXB64-Verwendung

FLDL2T ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FLDL2T ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FLDLG2 - Log10(2) laden - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FLDLG2 - Log10(2) laden
Hilfe zum PBXB64-Compiler

FLDLG2 - Log10(2) laden

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FLDLG2 - Log10(2) laden. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen 0,30102999566398120.

Syntax

FLDLG2 0,30102999566398120

Operands and Sizes

Form | Meaning
0,30102999566398120 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fldlg2 operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fldlg2 operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FLDLG2 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FLDLG2 operand[, operand]

PBXB64-Verwendung

FLDLG2 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FLDLG2 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FLDLN2 - Lade ln(2) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FLDLN2 - Lade ln(2)
Hilfe zum PBXB64-Compiler

FLDLN2 - Lade ln(2)

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FLDLN2 - Lade ln(2). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen 0,69314718055994531.

Syntax

FLDLN2 0,69314718055994531

Operands and Sizes

Form | Meaning
0,69314718055994531 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fldln2 operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fldln2 operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FLDLN2 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FLDLN2 operand[, operand]

PBXB64-Verwendung

FLDLN2 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FLDLN2 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FLDPI - Belastung pi (π) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FLDPI - Belastung pi (&#960;)
Hilfe zum PBXB64-Compiler

FLDPI - Belastung pi (π)

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FLDPI - Belastung pi (π). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen 3.14159265358979324.

Syntax

FLDPI 3.14159265358979324

Operands and Sizes

Form | Meaning
3.14159265358979324 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fldpi operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fldpi operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FLDPI ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FLDPI operand[, operand]

PBXB64-Verwendung

FLDPI ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FLDPI ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FLDZ - Laden Sie +0,0 - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FLDZ - Laden Sie +0,0
Hilfe zum PBXB64-Compiler

FLDZ - Laden Sie +0,0

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FLDZ - Laden Sie +0,0. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen +0,0.

Syntax

FLDZ +0,0

Operands and Sizes

Form | Meaning
+0,0 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fldz operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fldz operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FLDZ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FLDZ operand[, operand]

PBXB64-Verwendung

FLDZ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FLDZ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FMUL - Multiplizieren (ST0 = ST0 * src) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FMUL - Multiplizieren (ST0 = ST0 * src)
Hilfe zum PBXB64-Compiler

FMUL - Multiplizieren (ST0 = ST0 * src)

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FMUL - Multiplizieren (ST0 = ST0 * src). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem32/64 / ST(i).

Syntax

FMUL mem32/64 / ST(i)

Operands and Sizes

Form | Meaning
mem32 | may read or write memory
64 | follow the operand order shown in the syntax
ST(i) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fmul [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fmul [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FMUL ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FMUL operand[, operand]

PBXB64-Verwendung

FMUL ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FMUL ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FMULP - Multiplizieren und Pop - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FMULP - Multiplizieren und Pop
Hilfe zum PBXB64-Compiler

FMULP - Multiplizieren und Pop

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FMULP - Multiplizieren und Pop. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen ST(i), ST(0).

Syntax

FMULP ST(i), ST(0)

Operands and Sizes

Form | Meaning
ST(i), ST(0) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fmulp operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fmulp operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FMULP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FMULP operand[, operand]

PBXB64-Verwendung

FMULP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FMULP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FNCLEX - FPU-Ausnahmen löschen (keine Wartezeit) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FNCLEX - FPU-Ausnahmen löschen (keine Wartezeit)
Hilfe zum PBXB64-Compiler

FNCLEX - FPU-Ausnahmen löschen (keine Wartezeit)

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FNCLEX - FPU-Ausnahmen löschen (keine Wartezeit). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

FNCLEX keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fnclex operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fnclex operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FNCLEX ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FNCLEX operand[, operand]

PBXB64-Verwendung

FNCLEX ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FNCLEX ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FNINIT - FPU initialisieren (keine Wartezeit) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FNINIT - FPU initialisieren (keine Wartezeit)
Hilfe zum PBXB64-Compiler

FNINIT - FPU initialisieren (keine Wartezeit)

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FNINIT - FPU initialisieren (keine Wartezeit). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

FNINIT keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fninit operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fninit operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FNINIT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FNINIT operand[, operand]

PBXB64-Verwendung

FNINIT ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FNINIT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FNOP - FPU funktioniert nicht - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FNOP - FPU funktioniert nicht
Hilfe zum PBXB64-Compiler

FNOP - FPU funktioniert nicht

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FNOP - FPU funktioniert nicht. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

FNOP keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fnop operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fnop operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FNOP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FNOP operand[, operand]

PBXB64-Verwendung

FNOP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FNOP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FPATAN - Teilarkustangens (ST1/ST0 → ST1=atan, pop) F2XM1 - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FPATAN - Teilarkustangens (ST1/ST0 → ST1=atan, pop) F2XM1
Hilfe zum PBXB64-Compiler

FPATAN - Teilarkustangens (ST1/ST0 → ST1=atan, pop) F2XM1

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FPATAN - Teilarkustangens (ST1/ST0 → ST1=atan, pop) F2XM1. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen 2^ST0 - 1.

Syntax

FPATAN 2^ST0 - 1

Operands and Sizes

Form | Meaning
2^ST0 - 1 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fpatan operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fpatan operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FPATAN ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FPATAN operand[, operand]

PBXB64-Verwendung

FPATAN ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FPATAN ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FPREM - Teilweise Rest - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FPREM - Teilweise Rest
Hilfe zum PBXB64-Compiler

FPREM - Teilweise Rest

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FPREM - Teilweise Rest. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

FPREM keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fprem operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fprem operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FPREM ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FPREM operand[, operand]

PBXB64-Verwendung

FPREM ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FPREM ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FPREM1 - Teilweise Rest (IEEE) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FPREM1 - Teilweise Rest (IEEE)
Hilfe zum PBXB64-Compiler

FPREM1 - Teilweise Rest (IEEE)

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FPREM1 - Teilweise Rest (IEEE). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

FPREM1 keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fprem1 operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fprem1 operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FPREM1 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FPREM1 operand[, operand]

PBXB64-Verwendung

FPREM1 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FPREM1 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FRNDINT - Auf Ganzzahl runden (aktueller Rundungsmodus) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FRNDINT - Auf Ganzzahl runden (aktueller Rundungsmodus)
Hilfe zum PBXB64-Compiler

FRNDINT - Auf Ganzzahl runden (aktueller Rundungsmodus)

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FRNDINT - Auf Ganzzahl runden (aktueller Rundungsmodus). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

FRNDINT keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    frndint operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! frndint operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FRNDINT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FRNDINT operand[, operand]

PBXB64-Verwendung

FRNDINT ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FRNDINT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FRSTOR - FPU-Status wiederherstellen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FRSTOR - FPU-Status wiederherstellen
Hilfe zum PBXB64-Compiler

FRSTOR - FPU-Status wiederherstellen

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FRSTOR - FPU-Status wiederherstellen. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem.

Syntax

FRSTOR mem

Operands and Sizes

Form | Meaning
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    frstor [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! frstor [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FRSTOR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FRSTOR operand[, operand]

PBXB64-Verwendung

FRSTOR ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FRSTOR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FSAVE - FPU-Status speichern (94/108 Byte) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FSAVE - FPU-Status speichern (94/108 Byte)
Hilfe zum PBXB64-Compiler

FSAVE - FPU-Status speichern (94/108 Byte)

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FSAVE - FPU-Status speichern (94/108 Byte). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem.

Syntax

FSAVE mem

Operands and Sizes

Form | Meaning
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fsave [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fsave [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FSAVE ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FSAVE operand[, operand]

PBXB64-Verwendung

FSAVE ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FSAVE ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FSCALE - Skalierung durch Zweierpotenz (ST0 * 2^ST1) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FSCALE - Skalierung durch Zweierpotenz (ST0 * 2^ST1)
Hilfe zum PBXB64-Compiler

FSCALE - Skalierung durch Zweierpotenz (ST0 * 2^ST1)

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FSCALE - Skalierung durch Zweierpotenz (ST0 * 2^ST1). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

FSCALE keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fscale operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fscale operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FSCALE ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FSCALE operand[, operand]

PBXB64-Verwendung

FSCALE ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FSCALE ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FSIN - Sinus von ST0 (ST0 im Bogenmaß) FCOS - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FSIN - Sinus von ST0 (ST0 im Bogenmaß) FCOS
Hilfe zum PBXB64-Compiler

FSIN - Sinus von ST0 (ST0 im Bogenmaß) FCOS

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FSIN - Sinus von ST0 (ST0 im Bogenmaß) FCOS. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen Kosinus von ST0.

Syntax

FSIN Kosinus von ST0

Operands and Sizes

Form | Meaning
Kosinus von ST0 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fsin operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fsin operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FSIN ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FSIN operand[, operand]

PBXB64-Verwendung

FSIN ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FSIN ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FSINCOS - Sinus und Cosinus von ST0 (ST1=sin, ST0=cos) FPTAN - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FSINCOS - Sinus und Cosinus von ST0 (ST1=sin, ST0=cos) FPTAN
Hilfe zum PBXB64-Compiler

FSINCOS - Sinus und Cosinus von ST0 (ST1=sin, ST0=cos) FPTAN

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FSINCOS - Sinus und Cosinus von ST0 (ST1=sin, ST0=cos) FPTAN. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen Partielle Tangente (ST1=tan, ST0=1,0).

Syntax

FSINCOS Partielle Tangente (ST1=tan, ST0=1,0)

Operands and Sizes

Form | Meaning
Partielle Tangente (ST1=tan, ST0=1,0) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fsincos operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fsincos operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FSINCOS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FSINCOS operand[, operand]

PBXB64-Verwendung

FSINCOS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FSINCOS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FSQRT - Quadratwurzel - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FSQRT - Quadratwurzel
Hilfe zum PBXB64-Compiler

FSQRT - Quadratwurzel

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FSQRT - Quadratwurzel. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

FSQRT keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fsqrt operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fsqrt operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FSQRT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FSQRT operand[, operand]

PBXB64-Verwendung

FSQRT ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FSQRT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FST - Speichern Sie den tatsächlichen Wert (pop = FSTP) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FST - Speichern Sie den tatsächlichen Wert (pop = FSTP)
Hilfe zum PBXB64-Compiler

FST - Speichern Sie den tatsächlichen Wert (pop = FSTP)

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FST - Speichern Sie den tatsächlichen Wert (pop = FSTP). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem32/64 / ST(i).

Syntax

FST mem32/64 / ST(i)

Operands and Sizes

Form | Meaning
mem32 | may read or write memory
64 | follow the operand order shown in the syntax
ST(i) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fst [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fst [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FST ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FST operand[, operand]

PBXB64-Verwendung

FST ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FST ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FSTENV - Speichern Sie die FPU-Umgebung - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FSTENV - Speichern Sie die FPU-Umgebung
Hilfe zum PBXB64-Compiler

FSTENV - Speichern Sie die FPU-Umgebung

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FSTENV - Speichern Sie die FPU-Umgebung. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem (14/28 Byte).

Syntax

FSTENV mem (14/28 Byte)

Operands and Sizes

Form | Meaning
mem (14 | may read or write memory
28 Byte) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fstenv [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fstenv [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FSTENV ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FSTENV operand[, operand]

PBXB64-Verwendung

FSTENV ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FSTENV ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FSTP - Speichern Sie echten Wert und Pop - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FSTP - Speichern Sie echten Wert und Pop
Hilfe zum PBXB64-Compiler

FSTP - Speichern Sie echten Wert und Pop

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FSTP - Speichern Sie echten Wert und Pop. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem32/64/80 / ST(i).

Syntax

FSTP mem32/64/80 / ST(i)

Operands and Sizes

Form | Meaning
mem32 | may read or write memory
64 | follow the operand order shown in the syntax
80 | follow the operand order shown in the syntax
ST(i) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fstp [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fstp [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FSTP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FSTP operand[, operand]

PBXB64-Verwendung

FSTP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FSTP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FSUB - Subtrahieren (ST0 = ST0 - src) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FSUB - Subtrahieren (ST0 = ST0 - src)
Hilfe zum PBXB64-Compiler

FSUB - Subtrahieren (ST0 = ST0 - src)

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FSUB - Subtrahieren (ST0 = ST0 - src). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem32/64 / ST(i).

Syntax

FSUB mem32/64 / ST(i)

Operands and Sizes

Form | Meaning
mem32 | may read or write memory
64 | follow the operand order shown in the syntax
ST(i) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fsub [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fsub [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FSUB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FSUB operand[, operand]

PBXB64-Verwendung

FSUB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FSUB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FSUBP - Subtrahieren und Pop - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FSUBP - Subtrahieren und Pop
Hilfe zum PBXB64-Compiler

FSUBP - Subtrahieren und Pop

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FSUBP - Subtrahieren und Pop. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen ST(i), ST(0).

Syntax

FSUBP ST(i), ST(0)

Operands and Sizes

Form | Meaning
ST(i), ST(0) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fsubp operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fsubp operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FSUBP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FSUBP operand[, operand]

PBXB64-Verwendung

FSUBP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FSUBP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FSUBR - Rückwärts subtrahieren (ST0 = src - ST0) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FSUBR - Rückwärts subtrahieren (ST0 = src - ST0)
Hilfe zum PBXB64-Compiler

FSUBR - Rückwärts subtrahieren (ST0 = src - ST0)

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FSUBR - Rückwärts subtrahieren (ST0 = src - ST0). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen mem32/64 / ST(i).

Syntax

FSUBR mem32/64 / ST(i)

Operands and Sizes

Form | Meaning
mem32 | may read or write memory
64 | follow the operand order shown in the syntax
ST(i) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fsubr [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fsubr [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FSUBR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FSUBR operand[, operand]

PBXB64-Verwendung

FSUBR ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FSUBR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FSUBRP - Subtrahieren Sie Reverse und Pop - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FSUBRP - Subtrahieren Sie Reverse und Pop
Hilfe zum PBXB64-Compiler

FSUBRP - Subtrahieren Sie Reverse und Pop

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FSUBRP - Subtrahieren Sie Reverse und Pop. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen ST(i), ST(0).

Syntax

FSUBRP ST(i), ST(0)

Operands and Sizes

Form | Meaning
ST(i), ST(0) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fsubrp operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fsubrp operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FSUBRP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FSUBRP operand[, operand]

PBXB64-Verwendung

FSUBRP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FSUBRP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FWAIT - Warten auf FPU (Assembly: WAIT) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FWAIT - Warten auf FPU (Assembly: WAIT)
Hilfe zum PBXB64-Compiler

FWAIT - Warten auf FPU (Assembly: WAIT)

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FWAIT - Warten auf FPU (Assembly: WAIT). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

FWAIT keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fwait operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fwait operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FWAIT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FWAIT operand[, operand]

PBXB64-Verwendung

FWAIT ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FWAIT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FXCH - Tausche ST(0) mit ST(i) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FXCH - Tausche ST(0) mit ST(i)
Hilfe zum PBXB64-Compiler

FXCH - Tausche ST(0) mit ST(i)

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FXCH - Tausche ST(0) mit ST(i). Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen ST(i).

Syntax

FXCH ST(i)

Operands and Sizes

Form | Meaning
ST(i) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fxch operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fxch operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FXCH ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FXCH operand[, operand]

PBXB64-Verwendung

FXCH ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FXCH ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


FYL2X - ST1 * log2(ST0), pop FYL2XP1 - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › FPU / x87 › FYL2X - ST1 * log2(ST0), pop FYL2XP1
Hilfe zum PBXB64-Compiler

FYL2X - ST1 * log2(ST0), pop FYL2XP1

Category: FPU Instruction

Assembly Group: FPU

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

FYL2X - ST1 * log2(ST0), pop FYL2XP1. Diese Instruktion gehoert zur FPU-Familie und verwendet die dokumentierten Operandenformen ST1 * log2(ST0 + 1), pop.

Syntax

FYL2X ST1 * log2(ST0 + 1), pop

Operands and Sizes

Form | Meaning
ST1 * log2(ST0 + 1), pop | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    fyl2x operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! fyl2x operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_fpu.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

FYL2X ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

FYL2X operand[, operand]

PBXB64-Verwendung

FYL2X ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! FYL2X ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • FPU mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TZCNT - Nachgestellte Nullen zählen (verwendet im Gegensatz zu BSF das F3-Präfix) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › BMI › TZCNT - Nachgestellte Nullen zählen (verwendet im Gegensatz zu BSF das F3-Präfix)
Hilfe zum PBXB64-Compiler

TZCNT - Nachgestellte Nullen zählen (verwendet im Gegensatz zu BSF das F3-Präfix)

Category: BMI Instruction

Assembly Group: BMI

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

TZCNT - Nachgestellte Nullen zählen (verwendet im Gegensatz zu BSF das F3-Präfix). Diese Instruktion gehoert zur BMI-Familie und verwendet die dokumentierten Operandenformen reg, reg/mem.

Syntax

TZCNT reg, reg/mem

Operands and Sizes

Form | Meaning
reg, reg | uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    tzcnt eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! tzcnt eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_bmi.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

TZCNT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

TZCNT operand[, operand]

PBXB64-Verwendung

TZCNT ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! TZCNT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • BMI mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


AESDEC - Führen Sie eine Runde der AES-Entschlüsselung durch - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › AESDEC - Führen Sie eine Runde der AES-Entschlüsselung durch
Hilfe zum PBXB64-Compiler

AESDEC - Führen Sie eine Runde der AES-Entschlüsselung durch

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

AESDEC - Führen Sie eine Runde der AES-Entschlüsselung durch. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

AESDEC xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    aesdec xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! aesdec xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

AESDEC ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

AESDEC operand[, operand]

PBXB64-Verwendung

AESDEC ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! AESDEC ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← TZCNT - Nachgestellte Nullen zählen (verwendet im Gegensatz zu BSF das F3-Präfix) Top AESDECLAST - Führen Sie die letzte Runde der AES-Entschlüsselung durch →


AESDECLAST - Führen Sie die letzte Runde der AES-Entschlüsselung durch - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › AESDECLAST - Führen Sie die letzte Runde der AES-Entschlüsselung durch
Hilfe zum PBXB64-Compiler

AESDECLAST - Führen Sie die letzte Runde der AES-Entschlüsselung durch

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

AESDECLAST - Führen Sie die letzte Runde der AES-Entschlüsselung durch. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

AESDECLAST xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    aesdeclast xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! aesdeclast xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

AESDECLAST ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

AESDECLAST operand[, operand]

PBXB64-Verwendung

AESDECLAST ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! AESDECLAST ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


AESENC - Führen Sie eine Runde der AES-Verschlüsselung durch - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › AESENC - Führen Sie eine Runde der AES-Verschlüsselung durch
Hilfe zum PBXB64-Compiler

AESENC - Führen Sie eine Runde der AES-Verschlüsselung durch

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

AESENC - Führen Sie eine Runde der AES-Verschlüsselung durch. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

AESENC xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    aesenc xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! aesenc xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

AESENC ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

AESENC operand[, operand]

PBXB64-Verwendung

AESENC ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! AESENC ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


AESENCLAST - Führen Sie die letzte Runde der AES-Verschlüsselung durch - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › AESENCLAST - Führen Sie die letzte Runde der AES-Verschlüsselung durch
Hilfe zum PBXB64-Compiler

AESENCLAST - Führen Sie die letzte Runde der AES-Verschlüsselung durch

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

AESENCLAST - Führen Sie die letzte Runde der AES-Verschlüsselung durch. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

AESENCLAST xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    aesenclast xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! aesenclast xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

AESENCLAST ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

AESENCLAST operand[, operand]

PBXB64-Verwendung

AESENCLAST ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! AESENCLAST ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


AESIMC - Inverse Mix-Spalten (zur Schlüsselerweiterung) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › AESIMC - Inverse Mix-Spalten (zur Schlüsselerweiterung)
Hilfe zum PBXB64-Compiler

AESIMC - Inverse Mix-Spalten (zur Schlüsselerweiterung)

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

AESIMC - Inverse Mix-Spalten (zur Schlüsselerweiterung). Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

AESIMC xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    aesimc xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! aesimc xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

AESIMC ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

AESIMC operand[, operand]

PBXB64-Verwendung

AESIMC ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! AESIMC ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← AESENCLAST - Führen Sie die letzte Runde der AES-Verschlüsselung durch Top AESKEYGENASSIST - Unterstützung bei der Generierung von AES-Rundschlüsseln →


AESKEYGENASSIST - Unterstützung bei der Generierung von AES-Rundschlüsseln - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › AESKEYGENASSIST - Unterstützung bei der Generierung von AES-Rundschlüsseln
Hilfe zum PBXB64-Compiler

AESKEYGENASSIST - Unterstützung bei der Generierung von AES-Rundschlüsseln

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

AESKEYGENASSIST - Unterstützung bei der Generierung von AES-Rundschlüsseln. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

AESKEYGENASSIST xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    aeskeygenassist xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! aeskeygenassist xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

AESKEYGENASSIST ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

AESKEYGENASSIST operand[, operand]

PBXB64-Verwendung

AESKEYGENASSIST ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! AESKEYGENASSIST ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CRC32 - Akkumulieren Sie den CRC32C-Wert im Ziel - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › CRC32 - Akkumulieren Sie den CRC32C-Wert im Ziel
Hilfe zum PBXB64-Compiler

CRC32 - Akkumulieren Sie den CRC32C-Wert im Ziel

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CRC32 - Akkumulieren Sie den CRC32C-Wert im Ziel. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen reg32/64, reg/mem8/16/32/64.

Syntax

CRC32 reg32/64, reg/mem8/16/32/64

Operands and Sizes

Form | Meaning
reg32 | uses a general-purpose register
64, reg | uses a general-purpose register
mem8 | may read or write memory
16 | follow the operand order shown in the syntax
32 | follow the operand order shown in the syntax
64 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    crc32 eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! crc32 eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CRC32 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CRC32 operand[, operand]

PBXB64-Verwendung

CRC32 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CRC32 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


GF2P8MULB - Galois-Feld multipliziert Bytes (älteres SSE) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › GF2P8MULB - Galois-Feld multipliziert Bytes (älteres SSE)
Hilfe zum PBXB64-Compiler

GF2P8MULB - Galois-Feld multipliziert Bytes (älteres SSE)

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

GF2P8MULB - Galois-Feld multipliziert Bytes (älteres SSE). Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

GF2P8MULB xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    gf2p8mulb xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! gf2p8mulb xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

GF2P8MULB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

GF2P8MULB operand[, operand]

PBXB64-Verwendung

GF2P8MULB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! GF2P8MULB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SHA1MSG1 - Aktualisierung des SHA-1-Nachrichtenplans 1 - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › SHA1MSG1 - Aktualisierung des SHA-1-Nachrichtenplans 1
Hilfe zum PBXB64-Compiler

SHA1MSG1 - Aktualisierung des SHA-1-Nachrichtenplans 1

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SHA1MSG1 - Aktualisierung des SHA-1-Nachrichtenplans 1. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

SHA1MSG1 xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    sha1msg1 xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! sha1msg1 xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SHA1MSG1 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SHA1MSG1 operand[, operand]

PBXB64-Verwendung

SHA1MSG1 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SHA1MSG1 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SHA1MSG2 - Aktualisierung des SHA-1-Nachrichtenplans 2 - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › SHA1MSG2 - Aktualisierung des SHA-1-Nachrichtenplans 2
Hilfe zum PBXB64-Compiler

SHA1MSG2 - Aktualisierung des SHA-1-Nachrichtenplans 2

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SHA1MSG2 - Aktualisierung des SHA-1-Nachrichtenplans 2. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

SHA1MSG2 xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    sha1msg2 xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! sha1msg2 xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SHA1MSG2 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SHA1MSG2 operand[, operand]

PBXB64-Verwendung

SHA1MSG2 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SHA1MSG2 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SHA1NEXTE - SHA-1 nächste vier E-Werte - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › SHA1NEXTE - SHA-1 nächste vier E-Werte
Hilfe zum PBXB64-Compiler

SHA1NEXTE - SHA-1 nächste vier E-Werte

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SHA1NEXTE - SHA-1 nächste vier E-Werte. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

SHA1NEXTE xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    sha1nexte xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! sha1nexte xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SHA1NEXTE ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SHA1NEXTE operand[, operand]

PBXB64-Verwendung

SHA1NEXTE ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SHA1NEXTE ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SHA1RNDS4 - SHA-1 vier Runden - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › SHA1RNDS4 - SHA-1 vier Runden
Hilfe zum PBXB64-Compiler

SHA1RNDS4 - SHA-1 vier Runden

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SHA1RNDS4 - SHA-1 vier Runden. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128, imm8.

Syntax

SHA1RNDS4 xmm, xmm/mem128, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    sha1rnds4 xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! sha1rnds4 xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SHA1RNDS4 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SHA1RNDS4 operand[, operand]

PBXB64-Verwendung

SHA1RNDS4 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SHA1RNDS4 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SHA256MSG1 - Aktualisierung des SHA-256-Nachrichtenplans 1 - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › SHA256MSG1 - Aktualisierung des SHA-256-Nachrichtenplans 1
Hilfe zum PBXB64-Compiler

SHA256MSG1 - Aktualisierung des SHA-256-Nachrichtenplans 1

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SHA256MSG1 - Aktualisierung des SHA-256-Nachrichtenplans 1. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

SHA256MSG1 xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    sha256msg1 xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! sha256msg1 xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SHA256MSG1 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SHA256MSG1 operand[, operand]

PBXB64-Verwendung

SHA256MSG1 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SHA256MSG1 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SHA256MSG2 - Aktualisierung des SHA-256-Nachrichtenplans 2 - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › SHA256MSG2 - Aktualisierung des SHA-256-Nachrichtenplans 2
Hilfe zum PBXB64-Compiler

SHA256MSG2 - Aktualisierung des SHA-256-Nachrichtenplans 2

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SHA256MSG2 - Aktualisierung des SHA-256-Nachrichtenplans 2. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

SHA256MSG2 xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    sha256msg2 xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! sha256msg2 xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SHA256MSG2 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SHA256MSG2 operand[, operand]

PBXB64-Verwendung

SHA256MSG2 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SHA256MSG2 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SHA256RNDS2 - SHA-256 zwei Runden - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › SHA256RNDS2 - SHA-256 zwei Runden
Hilfe zum PBXB64-Compiler

SHA256RNDS2 - SHA-256 zwei Runden

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SHA256RNDS2 - SHA-256 zwei Runden. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem128.

Syntax

SHA256RNDS2 xmm, xmm/mem128

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem128 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.data
.align 16
asm_data128:
    .quad 0, 0

.text
.global main
main:
    sha256rnds2 xmm0, [rip + asm_data128]
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! sha256rnds2 xmm0, [rip + asm_data128]
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SHA256RNDS2 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SHA256RNDS2 operand[, operand]

PBXB64-Verwendung

SHA256RNDS2 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SHA256RNDS2 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SM3MSG1 - Aktualisierung des SM3-Nachrichtenplans 1 - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › SM3MSG1 - Aktualisierung des SM3-Nachrichtenplans 1
Hilfe zum PBXB64-Compiler

SM3MSG1 - Aktualisierung des SM3-Nachrichtenplans 1

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SM3MSG1 - Aktualisierung des SM3-Nachrichtenplans 1. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem.

Syntax

SM3MSG1 xmm, xmm/mem

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    sm3msg1 xmm0, xmm1
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! sm3msg1 xmm0, xmm1
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SM3MSG1 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SM3MSG1 operand[, operand]

PBXB64-Verwendung

SM3MSG1 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SM3MSG1 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SM3MSG2 - Aktualisierung des SM3-Nachrichtenplans 2 - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › SM3MSG2 - Aktualisierung des SM3-Nachrichtenplans 2
Hilfe zum PBXB64-Compiler

SM3MSG2 - Aktualisierung des SM3-Nachrichtenplans 2

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SM3MSG2 - Aktualisierung des SM3-Nachrichtenplans 2. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem.

Syntax

SM3MSG2 xmm, xmm/mem

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    sm3msg2 xmm0, xmm1
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! sm3msg2 xmm0, xmm1
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SM3MSG2 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SM3MSG2 operand[, operand]

PBXB64-Verwendung

SM3MSG2 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SM3MSG2 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SM4ENC - SM4-Ein-Runden-Verschlüsselung - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › SM4ENC - SM4-Ein-Runden-Verschlüsselung
Hilfe zum PBXB64-Compiler

SM4ENC - SM4-Ein-Runden-Verschlüsselung

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SM4ENC - SM4-Ein-Runden-Verschlüsselung. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem.

Syntax

SM4ENC xmm, xmm/mem

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    sm4enc xmm0, xmm1
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! sm4enc xmm0, xmm1
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SM4ENC ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SM4ENC operand[, operand]

PBXB64-Verwendung

SM4ENC ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SM4ENC ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SM4ENC4 - SM4 Vier-Runden-Verschlüsselung - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › SM4ENC4 - SM4 Vier-Runden-Verschlüsselung
Hilfe zum PBXB64-Compiler

SM4ENC4 - SM4 Vier-Runden-Verschlüsselung

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SM4ENC4 - SM4 Vier-Runden-Verschlüsselung. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem.

Syntax

SM4ENC4 xmm, xmm/mem

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    sm4enc4 xmm0, xmm1
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! sm4enc4 xmm0, xmm1
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SM4ENC4 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SM4ENC4 operand[, operand]

PBXB64-Verwendung

SM4ENC4 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SM4ENC4 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VAESDEC - VEX/EVEX AES-Rundenentschlüsselung - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › VAESDEC - VEX/EVEX AES-Rundenentschlüsselung
Hilfe zum PBXB64-Compiler

VAESDEC - VEX/EVEX AES-Rundenentschlüsselung

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VAESDEC - VEX/EVEX AES-Rundenentschlüsselung. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm/ymm/zmm, xmm/ymm/zmm, mem.

Syntax

VAESDEC xmm/ymm/zmm, xmm/ymm/zmm, mem

Operands and Sizes

Form | Meaning
xmm | uses XMM vector/scalar registers; may read or write memory
ymm | uses YMM vector registers; may read or write memory
zmm, xmm | uses XMM vector/scalar registers; may read or write memory
ymm | uses YMM vector registers; may read or write memory
zmm, mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vaesdec ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vaesdec ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VAESDEC ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VAESDEC operand[, operand]

PBXB64-Verwendung

VAESDEC ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VAESDEC ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VAESDECLAST - VEX/EVEX AES letzte Entschlüsselungsrunde - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › VAESDECLAST - VEX/EVEX AES letzte Entschlüsselungsrunde
Hilfe zum PBXB64-Compiler

VAESDECLAST - VEX/EVEX AES letzte Entschlüsselungsrunde

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VAESDECLAST - VEX/EVEX AES letzte Entschlüsselungsrunde. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm/ymm/zmm, xmm/ymm/zmm, mem.

Syntax

VAESDECLAST xmm/ymm/zmm, xmm/ymm/zmm, mem

Operands and Sizes

Form | Meaning
xmm | uses XMM vector/scalar registers; may read or write memory
ymm | uses YMM vector registers; may read or write memory
zmm, xmm | uses XMM vector/scalar registers; may read or write memory
ymm | uses YMM vector registers; may read or write memory
zmm, mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vaesdeclast ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vaesdeclast ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VAESDECLAST ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VAESDECLAST operand[, operand]

PBXB64-Verwendung

VAESDECLAST ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VAESDECLAST ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VAESENC - VEX/EVEX AES-Rundverschlüsselung - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › VAESENC - VEX/EVEX AES-Rundverschlüsselung
Hilfe zum PBXB64-Compiler

VAESENC - VEX/EVEX AES-Rundverschlüsselung

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VAESENC - VEX/EVEX AES-Rundverschlüsselung. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm/ymm/zmm, xmm/ymm/zmm, mem.

Syntax

VAESENC xmm/ymm/zmm, xmm/ymm/zmm, mem

Operands and Sizes

Form | Meaning
xmm | uses XMM vector/scalar registers; may read or write memory
ymm | uses YMM vector registers; may read or write memory
zmm, xmm | uses XMM vector/scalar registers; may read or write memory
ymm | uses YMM vector registers; may read or write memory
zmm, mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vaesenc ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vaesenc ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VAESENC ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VAESENC operand[, operand]

PBXB64-Verwendung

VAESENC ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VAESENC ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VAESIMC - VEX AES Inverse-Mix-Säulen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › VAESIMC - VEX AES Inverse-Mix-Säulen
Hilfe zum PBXB64-Compiler

VAESIMC - VEX AES Inverse-Mix-Säulen

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VAESIMC - VEX AES Inverse-Mix-Säulen. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem.

Syntax

VAESIMC xmm, xmm/mem

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vaesimc ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vaesimc ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VAESIMC ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VAESIMC operand[, operand]

PBXB64-Verwendung

VAESIMC ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VAESIMC ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VAESKEYGENASSIST - VEX AES-Schlüsselgenerierungsunterstützung - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › VAESKEYGENASSIST - VEX AES-Schlüsselgenerierungsunterstützung
Hilfe zum PBXB64-Compiler

VAESKEYGENASSIST - VEX AES-Schlüsselgenerierungsunterstützung

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VAESKEYGENASSIST - VEX AES-Schlüsselgenerierungsunterstützung. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm, xmm/mem, imm8.

Syntax

VAESKEYGENASSIST xmm, xmm/mem, imm8

Operands and Sizes

Form | Meaning
xmm, xmm | uses XMM vector/scalar registers; may read or write memory
mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vaeskeygenassist ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vaeskeygenassist ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VAESKEYGENASSIST ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VAESKEYGENASSIST operand[, operand]

PBXB64-Verwendung

VAESKEYGENASSIST ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VAESKEYGENASSIST ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VPCLMULQDQ - VEX/EVEX Carry-less-Multiplikation - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Crypto › VPCLMULQDQ - VEX/EVEX Carry-less-Multiplikation
Hilfe zum PBXB64-Compiler

VPCLMULQDQ - VEX/EVEX Carry-less-Multiplikation

Category: CRYPTO Instruction

Assembly Group: CRYPTO

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VPCLMULQDQ - VEX/EVEX Carry-less-Multiplikation. Diese Instruktion gehoert zur CRYPTO-Familie und verwendet die dokumentierten Operandenformen xmm/ymm/zmm, xmm/ymm/zmm, mem, imm8.

Syntax

VPCLMULQDQ xmm/ymm/zmm, xmm/ymm/zmm, mem, imm8

Operands and Sizes

Form | Meaning
xmm | uses XMM vector/scalar registers; may read or write memory
ymm | uses YMM vector registers; may read or write memory
zmm, xmm | uses XMM vector/scalar registers; may read or write memory
ymm | uses YMM vector registers; may read or write memory
zmm, mem, imm8 | may read or write memory; uses an immediate control byte or value

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vpclmulqdq ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vpclmulqdq ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_crypto.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VPCLMULQDQ ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VPCLMULQDQ operand[, operand]

PBXB64-Verwendung

VPCLMULQDQ ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VPCLMULQDQ ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CRYPTO mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CLDEMOTE - Cache-Zeile von L1 auf niedrigere Ebenen (L2/L3) herabstufen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Cache / Prefetch › CLDEMOTE - Cache-Zeile von L1 auf niedrigere Ebenen (L2/L3) herabstufen
Hilfe zum PBXB64-Compiler

CLDEMOTE - Cache-Zeile von L1 auf niedrigere Ebenen (L2/L3) herabstufen

Category: CACHE Instruction

Assembly Group: CACHE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CLDEMOTE - Cache-Zeile von L1 auf niedrigere Ebenen (L2/L3) herabstufen. Diese Instruktion gehoert zur CACHE-Familie und verwendet die dokumentierten Operandenformen mem8.

Syntax

CLDEMOTE mem8

Operands and Sizes

Form | Meaning
mem8 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    cldemote [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! cldemote [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_cache.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CLDEMOTE ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CLDEMOTE operand[, operand]

PBXB64-Verwendung

CLDEMOTE ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CLDEMOTE ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CACHE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CLFLUSH - Cache-Zeile mit Adresse leeren (zurückschreiben + ungültig machen) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Cache / Prefetch › CLFLUSH - Cache-Zeile mit Adresse leeren (zurückschreiben + ungültig machen)
Hilfe zum PBXB64-Compiler

CLFLUSH - Cache-Zeile mit Adresse leeren (zurückschreiben + ungültig machen)

Category: CACHE Instruction

Assembly Group: CACHE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CLFLUSH - Cache-Zeile mit Adresse leeren (zurückschreiben + ungültig machen). Diese Instruktion gehoert zur CACHE-Familie und verwendet die dokumentierten Operandenformen mem8.

Syntax

CLFLUSH mem8

Operands and Sizes

Form | Meaning
mem8 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    clflush [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! clflush [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_cache.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CLFLUSH ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CLFLUSH operand[, operand]

PBXB64-Verwendung

CLFLUSH ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CLFLUSH ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CACHE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CLFLUSHOPT - Cache-Zeile leeren (optimiert, gepuffert) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Cache / Prefetch › CLFLUSHOPT - Cache-Zeile leeren (optimiert, gepuffert)
Hilfe zum PBXB64-Compiler

CLFLUSHOPT - Cache-Zeile leeren (optimiert, gepuffert)

Category: CACHE Instruction

Assembly Group: CACHE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CLFLUSHOPT - Cache-Zeile leeren (optimiert, gepuffert). Diese Instruktion gehoert zur CACHE-Familie und verwendet die dokumentierten Operandenformen mem8.

Syntax

CLFLUSHOPT mem8

Operands and Sizes

Form | Meaning
mem8 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    clflushopt [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! clflushopt [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_cache.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CLFLUSHOPT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CLFLUSHOPT operand[, operand]

PBXB64-Verwendung

CLFLUSHOPT ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CLFLUSHOPT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CACHE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← CLFLUSH - Cache-Zeile mit Adresse leeren (zurückschreiben + ungültig machen) Top CLWB - Zurückschreiben der Cache-Zeile (bei Bedarf im Cache behalten) →


CLWB - Zurückschreiben der Cache-Zeile (bei Bedarf im Cache behalten) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Cache / Prefetch › CLWB - Zurückschreiben der Cache-Zeile (bei Bedarf im Cache behalten)
Hilfe zum PBXB64-Compiler

CLWB - Zurückschreiben der Cache-Zeile (bei Bedarf im Cache behalten)

Category: CACHE Instruction

Assembly Group: CACHE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CLWB - Zurückschreiben der Cache-Zeile (bei Bedarf im Cache behalten). Diese Instruktion gehoert zur CACHE-Familie und verwendet die dokumentierten Operandenformen mem8.

Syntax

CLWB mem8

Operands and Sizes

Form | Meaning
mem8 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    clwb [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! clwb [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_cache.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CLWB ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CLWB operand[, operand]

PBXB64-Verwendung

CLWB ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CLWB ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CACHE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CLZERO - Keine Cache-Zeile (nur AMD, löscht 64 Bytes) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Cache / Prefetch › CLZERO - Keine Cache-Zeile (nur AMD, löscht 64 Bytes)
Hilfe zum PBXB64-Compiler

CLZERO - Keine Cache-Zeile (nur AMD, löscht 64 Bytes)

Category: CACHE Instruction

Assembly Group: CACHE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

CLZERO - Keine Cache-Zeile (nur AMD, löscht 64 Bytes). Diese Instruktion gehoert zur CACHE-Familie und verwendet die dokumentierten Operandenformen keine (verwendet [rax-Adresse]).

Syntax

CLZERO keine (verwendet [rax-Adresse])

Operands and Sizes

Form | Meaning
keine (verwendet [rax-Adresse]) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    clzero operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! clzero operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_cache.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CLZERO ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CLZERO operand[, operand]

PBXB64-Verwendung

CLZERO ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CLZERO ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CACHE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PREFETCHT1 - Prefetch in L2 und L3 (nicht L1) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Cache / Prefetch › PREFETCHT1 - Prefetch in L2 und L3 (nicht L1)
Hilfe zum PBXB64-Compiler

PREFETCHT1 - Prefetch in L2 und L3 (nicht L1)

Category: CACHE Instruction

Assembly Group: CACHE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PREFETCHT1 - Prefetch in L2 und L3 (nicht L1). Diese Instruktion gehoert zur CACHE-Familie und verwendet die dokumentierten Operandenformen mem8.

Syntax

PREFETCHT1 mem8

Operands and Sizes

Form | Meaning
mem8 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    prefetcht1 [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! prefetcht1 [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_cache.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PREFETCHT1 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PREFETCHT1 operand[, operand]

PBXB64-Verwendung

PREFETCHT1 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PREFETCHT1 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CACHE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PREFETCHW - Prefetch zum Schreiben (RFO-Latenz reduzieren, AMD/Intel) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Cache / Prefetch › PREFETCHW - Prefetch zum Schreiben (RFO-Latenz reduzieren, AMD/Intel)
Hilfe zum PBXB64-Compiler

PREFETCHW - Prefetch zum Schreiben (RFO-Latenz reduzieren, AMD/Intel)

Category: CACHE Instruction

Assembly Group: CACHE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PREFETCHW - Prefetch zum Schreiben (RFO-Latenz reduzieren, AMD/Intel). Diese Instruktion gehoert zur CACHE-Familie und verwendet die dokumentierten Operandenformen mem8.

Syntax

PREFETCHW mem8

Operands and Sizes

Form | Meaning
mem8 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    prefetchw [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! prefetchw [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_cache.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PREFETCHW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PREFETCHW operand[, operand]

PBXB64-Verwendung

PREFETCHW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PREFETCHW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CACHE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PREFETCHWT1 - Prefetch zum Schreiben in L2 (AVX-512) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Cache / Prefetch › PREFETCHWT1 - Prefetch zum Schreiben in L2 (AVX-512)
Hilfe zum PBXB64-Compiler

PREFETCHWT1 - Prefetch zum Schreiben in L2 (AVX-512)

Category: CACHE Instruction

Assembly Group: CACHE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

PREFETCHWT1 - Prefetch zum Schreiben in L2 (AVX-512). Diese Instruktion gehoert zur CACHE-Familie und verwendet die dokumentierten Operandenformen mem8.

Syntax

PREFETCHWT1 mem8

Operands and Sizes

Form | Meaning
mem8 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    prefetchwt1 [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! prefetchwt1 [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_cache.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PREFETCHWT1 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PREFETCHWT1 operand[, operand]

PBXB64-Verwendung

PREFETCHWT1 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PREFETCHWT1 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CACHE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVNTDQA - Nichtzeitliche VEX-Last (AVX2) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Cache / Prefetch › VMOVNTDQA - Nichtzeitliche VEX-Last (AVX2)
Hilfe zum PBXB64-Compiler

VMOVNTDQA - Nichtzeitliche VEX-Last (AVX2)

Category: CACHE Instruction

Assembly Group: CACHE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVNTDQA - Nichtzeitliche VEX-Last (AVX2). Diese Instruktion gehoert zur CACHE-Familie und verwendet die dokumentierten Operandenformen ymm/xmm, mem.

Syntax

VMOVNTDQA ymm/xmm, mem

Operands and Sizes

Form | Meaning
ymm | uses YMM vector registers; may read or write memory
xmm, mem | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovntdqa ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovntdqa ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_cache.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVNTDQA ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVNTDQA operand[, operand]

PBXB64-Verwendung

VMOVNTDQA ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVNTDQA ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CACHE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMOVNTPD - VEX nichtzeitlicher Doppelspeicher (AVX) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › Cache / Prefetch › VMOVNTPD - VEX nichtzeitlicher Doppelspeicher (AVX)
Hilfe zum PBXB64-Compiler

VMOVNTPD - VEX nichtzeitlicher Doppelspeicher (AVX)

Category: CACHE Instruction

Assembly Group: CACHE

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMOVNTPD - VEX nichtzeitlicher Doppelspeicher (AVX). Diese Instruktion gehoert zur CACHE-Familie und verwendet die dokumentierten Operandenformen mem, ymm/xmm.

Syntax

VMOVNTPD mem, ymm/xmm

Operands and Sizes

Form | Meaning
mem, ymm | uses YMM vector registers; may read or write memory
xmm | uses XMM vector/scalar registers; may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmovntpd ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmovntpd ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_cache.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMOVNTPD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMOVNTPD operand[, operand]

PBXB64-Verwendung

VMOVNTPD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMOVNTPD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • CACHE mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


INCSSP - Erhöhen Sie den Shadow-Stack-Zeiger um N*8 - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SGX / VMX / CET › INCSSP - Erhöhen Sie den Shadow-Stack-Zeiger um N*8
Hilfe zum PBXB64-Compiler

INCSSP - Erhöhen Sie den Shadow-Stack-Zeiger um N*8

Category: SGX_VMX Instruction

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

INCSSP - Erhöhen Sie den Shadow-Stack-Zeiger um N*8. Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen reg32.

Syntax

INCSSP reg32

Operands and Sizes

Form | Meaning
reg32 | uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    incssp eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! incssp eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

INCSSP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

INCSSP operand[, operand]

PBXB64-Verwendung

INCSSP ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! INCSSP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


INVEPT - EPT (Extended Page Table) ungültig machen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SGX / VMX / CET › INVEPT - EPT (Extended Page Table) ungültig machen
Hilfe zum PBXB64-Compiler

INVEPT - EPT (Extended Page Table) ungültig machen

Category: SGX_VMX Instruction

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

INVEPT - EPT (Extended Page Table) ungültig machen. Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen reg, mem128.

Syntax

INVEPT reg, mem128

Operands and Sizes

Form | Meaning
reg, mem128 | may read or write memory; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    invept eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! invept eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

INVEPT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

INVEPT operand[, operand]

PBXB64-Verwendung

INVEPT ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! INVEPT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RDSSP - Schattenstapelzeiger lesen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SGX / VMX / CET › RDSSP - Schattenstapelzeiger lesen
Hilfe zum PBXB64-Compiler

RDSSP - Schattenstapelzeiger lesen

Category: SGX_VMX Instruction

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

RDSSP - Schattenstapelzeiger lesen. Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen reg64.

Syntax

RDSSP reg64

Operands and Sizes

Form | Meaning
reg64 | uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    rdssp eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! rdssp eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

RDSSP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

RDSSP operand[, operand]

PBXB64-Verwendung

RDSSP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! RDSSP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RSTORSSP - Schattenstapelzeiger wiederherstellen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SGX / VMX / CET › RSTORSSP - Schattenstapelzeiger wiederherstellen
Hilfe zum PBXB64-Compiler

RSTORSSP - Schattenstapelzeiger wiederherstellen

Category: SGX_VMX Instruction

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

RSTORSSP - Schattenstapelzeiger wiederherstellen. Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen mem64.

Syntax

RSTORSSP mem64

Operands and Sizes

Form | Meaning
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    rstorssp [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! rstorssp [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

RSTORSSP ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

RSTORSSP operand[, operand]

PBXB64-Verwendung

RSTORSSP ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! RSTORSSP ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SETSSBSY - Markieren Sie den Schattenstapel als beschäftigt - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SGX / VMX / CET › SETSSBSY - Markieren Sie den Schattenstapel als beschäftigt
Hilfe zum PBXB64-Compiler

SETSSBSY - Markieren Sie den Schattenstapel als beschäftigt

Category: SGX_VMX Instruction

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SETSSBSY - Markieren Sie den Schattenstapel als beschäftigt. Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

SETSSBSY keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    setssbsy operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! setssbsy operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SETSSBSY ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SETSSBSY operand[, operand]

PBXB64-Verwendung

SETSSBSY ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SETSSBSY ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMCALL - Rufen Sie VMM vom Gast aus auf (VM-Exit) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SGX / VMX / CET › VMCALL - Rufen Sie VMM vom Gast aus auf (VM-Exit)
Hilfe zum PBXB64-Compiler

VMCALL - Rufen Sie VMM vom Gast aus auf (VM-Exit)

Category: SGX_VMX Instruction

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMCALL - Rufen Sie VMM vom Gast aus auf (VM-Exit). Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

VMCALL keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmcall ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmcall ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMCALL ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMCALL operand[, operand]

PBXB64-Verwendung

VMCALL ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMCALL ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMCLEAR - VMCS löschen (Cache-Status leeren) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SGX / VMX / CET › VMCLEAR - VMCS löschen (Cache-Status leeren)
Hilfe zum PBXB64-Compiler

VMCLEAR - VMCS löschen (Cache-Status leeren)

Category: SGX_VMX Instruction

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMCLEAR - VMCS löschen (Cache-Status leeren). Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen mem64.

Syntax

VMCLEAR mem64

Operands and Sizes

Form | Meaning
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmclear ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmclear ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMCLEAR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMCLEAR operand[, operand]

PBXB64-Verwendung

VMCLEAR ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMCLEAR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMFUNC - VM-Funktionsaufruf (Blatt in EAX) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SGX / VMX / CET › VMFUNC - VM-Funktionsaufruf (Blatt in EAX)
Hilfe zum PBXB64-Compiler

VMFUNC - VM-Funktionsaufruf (Blatt in EAX)

Category: SGX_VMX Instruction

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMFUNC - VM-Funktionsaufruf (Blatt in EAX). Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

VMFUNC keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmfunc ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmfunc ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMFUNC ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMFUNC operand[, operand]

PBXB64-Verwendung

VMFUNC ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMFUNC ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMLAUNCH - Virtuelle Maschine starten (erster Eintrag) VMRESUME - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SGX / VMX / CET › VMLAUNCH - Virtuelle Maschine starten (erster Eintrag) VMRESUME
Hilfe zum PBXB64-Compiler

VMLAUNCH - Virtuelle Maschine starten (erster Eintrag) VMRESUME

Category: SGX_VMX Instruction

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMLAUNCH - Virtuelle Maschine starten (erster Eintrag) VMRESUME. Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen Virtuelle Maschine fortsetzen (nachfolgende Einträge).

Syntax

VMLAUNCH Virtuelle Maschine fortsetzen (nachfolgende Einträge)

Operands and Sizes

Form | Meaning
Virtuelle Maschine fortsetzen (nachfolgende Einträge) | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmlaunch ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmlaunch ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMLAUNCH ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMLAUNCH operand[, operand]

PBXB64-Verwendung

VMLAUNCH ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMLAUNCH ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMPTRLD - Aktuellen VMCS-Zeiger laden - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SGX / VMX / CET › VMPTRLD - Aktuellen VMCS-Zeiger laden
Hilfe zum PBXB64-Compiler

VMPTRLD - Aktuellen VMCS-Zeiger laden

Category: SGX_VMX Instruction

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMPTRLD - Aktuellen VMCS-Zeiger laden. Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen mem64.

Syntax

VMPTRLD mem64

Operands and Sizes

Form | Meaning
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmptrld ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmptrld ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMPTRLD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMPTRLD operand[, operand]

PBXB64-Verwendung

VMPTRLD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMPTRLD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


VMPTRST - Aktuellen VMCS-Zeiger speichern - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SGX / VMX / CET › VMPTRST - Aktuellen VMCS-Zeiger speichern
Hilfe zum PBXB64-Compiler

VMPTRST - Aktuellen VMCS-Zeiger speichern

Category: SGX_VMX Instruction

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMPTRST - Aktuellen VMCS-Zeiger speichern. Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen mem64.

Syntax

VMPTRST mem64

Operands and Sizes

Form | Meaning
mem64 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmptrst ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmptrst ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMPTRST ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMPTRST operand[, operand]

PBXB64-Verwendung

VMPTRST ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMPTRST ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

Typ- und Speicherprüfung

Typ- und Variablenseiten sollen Breite, Vorzeichen, Initialisierung, Gültigkeitsbereich, Suffixregeln und x64-Layout dokumentieren. Beispiele sollen gespeicherten Wert, ausgelesenen Wert und Konvertierungs- oder Überlaufverhalten belegen.

Deklarationsregeln

Nennen Sie, ob Deklarationen #DIM ALL, AS-Klauseln, Suffixe oder ausdrückliche Sichtbarkeit benötigen. Trennen Sie lokalen, statischen, globalen und thread-lokalen Speicher.

Migrationshinweise

Prüfen Sie Pointer-, Handle- und LONG-Annahmen beim Wechsel von 32-Bit-PB-Code zu PBXB64.

Umfangshinweise

Wenn eine Seite mehrere verwandte Formen gruppiert, sollte sie sagen, welche Form die Speicherbreite festlegt, welche nur die Deklarationssyntax ändert und welche nur historischen Charakter hat. Eine kleine Zuordnung von Familienbegriff zu den konkreten Typseiten macht die Seite beim Portieren deutlich nützlicher.


VMREAD - Feld aus VMCS lesen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SGX / VMX / CET › VMREAD - Feld aus VMCS lesen
Hilfe zum PBXB64-Compiler

VMREAD - Feld aus VMCS lesen

Category: SGX_VMX Instruction

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMREAD - Feld aus VMCS lesen. Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen reg, reg/mem.

Syntax

VMREAD reg, reg/mem

Operands and Sizes

Form | Meaning
reg, reg | uses a general-purpose register
mem | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmread ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmread ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMREAD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMREAD operand[, operand]

PBXB64-Verwendung

VMREAD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMREAD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VMWRITE - Feld in VMCS schreiben - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SGX / VMX / CET › VMWRITE - Feld in VMCS schreiben
Hilfe zum PBXB64-Compiler

VMWRITE - Feld in VMCS schreiben

Category: SGX_VMX Instruction

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VMWRITE - Feld in VMCS schreiben. Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen reg/mem, reg.

Syntax

VMWRITE reg/mem, reg

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem, reg | may read or write memory; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    vmwrite ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! vmwrite ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VMWRITE ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VMWRITE operand[, operand]

PBXB64-Verwendung

VMWRITE ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VMWRITE ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


WRUSS - Auf Shadow Stack schreiben (Benutzer) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › SGX / VMX / CET › WRUSS - Auf Shadow Stack schreiben (Benutzer)
Hilfe zum PBXB64-Compiler

WRUSS - Auf Shadow Stack schreiben (Benutzer)

Category: SGX_VMX Instruction

Assembly Group: SGX_VMX

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

WRUSS - Auf Shadow Stack schreiben (Benutzer). Diese Instruktion gehoert zur SGX_VMX-Familie und verwendet die dokumentierten Operandenformen mem64, reg64.

Syntax

WRUSS mem64, reg64

Operands and Sizes

Form | Meaning
mem64, reg64 | may read or write memory; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    wruss eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! wruss eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_sgx_vmx.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

WRUSS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

WRUSS operand[, operand]

PBXB64-Verwendung

WRUSS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! WRUSS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SGX_VMX mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BOUND - Array-Grenzen prüfen (nicht gültig in x64) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › BOUND - Array-Grenzen prüfen (nicht gültig in x64)
Hilfe zum PBXB64-Compiler

BOUND - Array-Grenzen prüfen (nicht gültig in x64)

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

BOUND - Array-Grenzen prüfen (nicht gültig in x64). Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen reg, mem.

Syntax

BOUND reg, mem

Operands and Sizes

Form | Meaning
reg, mem | may read or write memory; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    bound eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! bound eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

BOUND ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

BOUND operand[, operand]

PBXB64-Verwendung

BOUND ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! BOUND ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


INTO - Unterbrechung bei Überlauf (wenn OF=1, #OF) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › INTO - Unterbrechung bei Überlauf (wenn OF=1, #OF)
Hilfe zum PBXB64-Compiler

INTO - Unterbrechung bei Überlauf (wenn OF=1, #OF)

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

INTO - Unterbrechung bei Überlauf (wenn OF=1, #OF). Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

INTO keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    into operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! into operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

INTO ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

INTO operand[, operand]

PBXB64-Verwendung

INTO ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! INTO ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


INVD - Interne Caches ungültig machen (kein Zurückschreiben) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › INVD - Interne Caches ungültig machen (kein Zurückschreiben)
Hilfe zum PBXB64-Compiler

INVD - Interne Caches ungültig machen (kein Zurückschreiben)

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

INVD - Interne Caches ungültig machen (kein Zurückschreiben). Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

INVD keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    invd operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! invd operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

INVD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

INVD operand[, operand]

PBXB64-Verwendung

INVD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! INVD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


INVLPG - TLB-Eintrag für Adresse ungültig machen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › INVLPG - TLB-Eintrag für Adresse ungültig machen
Hilfe zum PBXB64-Compiler

INVLPG - TLB-Eintrag für Adresse ungültig machen

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

INVLPG - TLB-Eintrag für Adresse ungültig machen. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen mem8.

Syntax

INVLPG mem8

Operands and Sizes

Form | Meaning
mem8 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    invlpg [rsp], eax
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! invlpg [rsp], eax
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

INVLPG ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

INVLPG operand[, operand]

PBXB64-Verwendung

INVLPG ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! INVLPG ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


INVPCID - TLB-Einträge mit PCID ungültig machen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › INVPCID - TLB-Einträge mit PCID ungültig machen
Hilfe zum PBXB64-Compiler

INVPCID - TLB-Einträge mit PCID ungültig machen

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

INVPCID - TLB-Einträge mit PCID ungültig machen. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen reg, mem128.

Syntax

INVPCID reg, mem128

Operands and Sizes

Form | Meaning
reg, mem128 | may read or write memory; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    invpcid eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! invpcid eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

INVPCID ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

INVPCID operand[, operand]

PBXB64-Verwendung

INVPCID ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! INVPCID ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LSL - Segmentlimit laden - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › LSL - Segmentlimit laden
Hilfe zum PBXB64-Compiler

LSL - Segmentlimit laden

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

LSL - Segmentlimit laden. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen reg, reg/mem16.

Syntax

LSL reg, reg/mem16

Operands and Sizes

Form | Meaning
reg, reg | uses a general-purpose register
mem16 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    lsl eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! lsl eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

LSL ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

LSL operand[, operand]

PBXB64-Verwendung

LSL ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! LSL ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LTR - Aufgabenregister laden - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › LTR - Aufgabenregister laden
Hilfe zum PBXB64-Compiler

LTR - Aufgabenregister laden

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

LTR - Aufgabenregister laden. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen reg/mem16/64.

Syntax

LTR reg/mem16/64

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem16 | may read or write memory
64 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    ltr eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! ltr eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

LTR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

LTR operand[, operand]

PBXB64-Verwendung

LTR ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! LTR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MONITOR - Adressbereich für MWAIT einrichten - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › MONITOR - Adressbereich für MWAIT einrichten
Hilfe zum PBXB64-Compiler

MONITOR - Adressbereich für MWAIT einrichten

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MONITOR - Adressbereich für MWAIT einrichten. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen keine (verwendet RAX/RCX/RDX).

Syntax

MONITOR keine (verwendet RAX/RCX/RDX)

Operands and Sizes

Form | Meaning
keine (verwendet RAX | follow the operand order shown in the syntax
RCX | follow the operand order shown in the syntax
RDX) | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    monitor operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! monitor operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MONITOR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MONITOR operand[, operand]

PBXB64-Verwendung

MONITOR ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MONITOR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MWAITX - Erweitertes MWAIT mit Timing-Hinweis - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › MWAITX - Erweitertes MWAIT mit Timing-Hinweis
Hilfe zum PBXB64-Compiler

MWAITX - Erweitertes MWAIT mit Timing-Hinweis

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

MWAITX - Erweitertes MWAIT mit Timing-Hinweis. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

MWAITX keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    mwaitx operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! mwaitx operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MWAITX ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MWAITX operand[, operand]

PBXB64-Verwendung

MWAITX ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MWAITX ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RDFSBASE - FS-Basisadresse lesen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › RDFSBASE - FS-Basisadresse lesen
Hilfe zum PBXB64-Compiler

RDFSBASE - FS-Basisadresse lesen

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

RDFSBASE - FS-Basisadresse lesen. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen reg64.

Syntax

RDFSBASE reg64

Operands and Sizes

Form | Meaning
reg64 | uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    rdfsbase eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! rdfsbase eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

RDFSBASE ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

RDFSBASE operand[, operand]

PBXB64-Verwendung

RDFSBASE ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! RDFSBASE ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RDGSBASE - GS-Basisadresse lesen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › RDGSBASE - GS-Basisadresse lesen
Hilfe zum PBXB64-Compiler

RDGSBASE - GS-Basisadresse lesen

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

RDGSBASE - GS-Basisadresse lesen. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen reg64.

Syntax

RDGSBASE reg64

Operands and Sizes

Form | Meaning
reg64 | uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    rdgsbase eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! rdgsbase eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

RDGSBASE ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

RDGSBASE operand[, operand]

PBXB64-Verwendung

RDGSBASE ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! RDGSBASE ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RDMSR - MSR lesen (ECX=MSR-Adresse, gibt EDX:EAX zurück) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › RDMSR - MSR lesen (ECX=MSR-Adresse, gibt EDX:EAX zurück)
Hilfe zum PBXB64-Compiler

RDMSR - MSR lesen (ECX=MSR-Adresse, gibt EDX:EAX zurück)

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

RDMSR - MSR lesen (ECX=MSR-Adresse, gibt EDX:EAX zurück). Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

RDMSR keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    rdmsr operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! rdmsr operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

RDMSR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

RDMSR operand[, operand]

PBXB64-Verwendung

RDMSR ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! RDMSR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RDPMC - Leistungsüberwachungszähler lesen (ECX=Zähler) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › RDPMC - Leistungsüberwachungszähler lesen (ECX=Zähler)
Hilfe zum PBXB64-Compiler

RDPMC - Leistungsüberwachungszähler lesen (ECX=Zähler)

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

RDPMC - Leistungsüberwachungszähler lesen (ECX=Zähler). Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

RDPMC keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    rdpmc operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! rdpmc operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

RDPMC ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

RDPMC operand[, operand]

PBXB64-Verwendung

RDPMC ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! RDPMC ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SALC - AL basierend auf Übertrag festlegen (undokumentiert, CF→AL=0xFF/0x00) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › SALC - AL basierend auf Übertrag festlegen (undokumentiert, CF→AL=0xFF/0x00)
Hilfe zum PBXB64-Compiler

SALC - AL basierend auf Übertrag festlegen (undokumentiert, CF→AL=0xFF/0x00)

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SALC - AL basierend auf Übertrag festlegen (undokumentiert, CF→AL=0xFF/0x00). Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

SALC keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    salc operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! salc operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SALC ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SALC operand[, operand]

PBXB64-Verwendung

SALC ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SALC ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


STR - Aufgabenregister speichern - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › STR - Aufgabenregister speichern
Hilfe zum PBXB64-Compiler

STR - Aufgabenregister speichern

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

STR - Aufgabenregister speichern. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen reg/mem16/64.

Syntax

STR reg/mem16/64

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem16 | may read or write memory
64 | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    str eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! str eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

STR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

STR operand[, operand]

PBXB64-Verwendung

STR ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! STR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

String-Prüfung

String-Seiten sollen angeben, ob Daten dynamisch, festlängig, ASCIIZ, Unicode, UTF-8, ANSI oder rohe Bytes sind. Beispiele sollen leeren Text, nicht leeren Text und bei Kodierungsfragen mindestens ein Zeichen außerhalb einfacher A-Z-Eingaben enthalten.

Speicher und Kodierung

Dokumentieren Sie Besitz, Längeneinheiten, Terminatoren und Konvertierungsverlust. Bei x64-Interop sind String-Datenzeiger von Deskriptoren zu unterscheiden; 32-Bit-Zeigergrößen dürfen nicht vorausgesetzt werden.

Fehlerfälle

Nennen Sie Trunkierung, ungültige Kodierung, eingebettete NUL-Zeichen oder zu kleine Puffer, wenn der Befehl solche Fälle treffen kann.

← SALC - AL basierend auf Übertrag festlegen (undokumentiert, CF→AL=0xFF/0x00) Top SWAPGS - GS-Basisregister mit KernelGSBase (MSR C0000102) tauschen →


SWAPGS - GS-Basisregister mit KernelGSBase (MSR C0000102) tauschen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › SWAPGS - GS-Basisregister mit KernelGSBase (MSR C0000102) tauschen
Hilfe zum PBXB64-Compiler

SWAPGS - GS-Basisregister mit KernelGSBase (MSR C0000102) tauschen

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SWAPGS - GS-Basisregister mit KernelGSBase (MSR C0000102) tauschen. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

SWAPGS keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    swapgs operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! swapgs operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SWAPGS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SWAPGS operand[, operand]

PBXB64-Verwendung

SWAPGS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SWAPGS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SYSENTER - Schneller Systemaufruf (Intel): setzt EIP=MSR SYSENTER_EIP - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › SYSENTER - Schneller Systemaufruf (Intel): setzt EIP=MSR SYSENTER_EIP
Hilfe zum PBXB64-Compiler

SYSENTER - Schneller Systemaufruf (Intel): setzt EIP=MSR SYSENTER_EIP

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SYSENTER - Schneller Systemaufruf (Intel): setzt EIP=MSR SYSENTER_EIP. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

SYSENTER keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    sysenter operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! sysenter operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SYSENTER ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SYSENTER operand[, operand]

PBXB64-Verwendung

SYSENTER ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SYSENTER ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SYSEXIT - Schnelle Rückkehr von SYSENTER - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › SYSEXIT - Schnelle Rückkehr von SYSENTER
Hilfe zum PBXB64-Compiler

SYSEXIT - Schnelle Rückkehr von SYSENTER

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SYSEXIT - Schnelle Rückkehr von SYSENTER. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

SYSEXIT keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    sysexit operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! sysexit operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SYSEXIT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SYSEXIT operand[, operand]

PBXB64-Verwendung

SYSEXIT ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SYSEXIT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SYSRET - Rückkehr vom schnellen Systemaufruf - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › SYSRET - Rückkehr vom schnellen Systemaufruf
Hilfe zum PBXB64-Compiler

SYSRET - Rückkehr vom schnellen Systemaufruf

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

SYSRET - Rückkehr vom schnellen Systemaufruf. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

SYSRET keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    sysret operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! sysret operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SYSRET ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SYSRET operand[, operand]

PBXB64-Verwendung

SYSRET ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SYSRET ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TPAUSE - Zeitgesteuerte PAUSE - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › TPAUSE - Zeitgesteuerte PAUSE
Hilfe zum PBXB64-Compiler

TPAUSE - Zeitgesteuerte PAUSE

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

TPAUSE - Zeitgesteuerte PAUSE. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen reg, imm8.

Syntax

TPAUSE reg, imm8

Operands and Sizes

Form | Meaning
reg, imm8 | may read or write memory; uses an immediate control byte or value; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    tpause eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! tpause eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

TPAUSE ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

TPAUSE operand[, operand]

PBXB64-Verwendung

TPAUSE ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! TPAUSE ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UD0 - Undefinierte Anweisung (erhöht #UD) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › UD0 - Undefinierte Anweisung (erhöht #UD)
Hilfe zum PBXB64-Compiler

UD0 - Undefinierte Anweisung (erhöht #UD)

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

UD0 - Undefinierte Anweisung (erhöht #UD). Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

UD0 keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    ud0 operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! ud0 operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

UD0 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

UD0 operand[, operand]

PBXB64-Verwendung

UD0 ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! UD0 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UMWAIT - MWAIT auf Benutzerebene - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › UMWAIT - MWAIT auf Benutzerebene
Hilfe zum PBXB64-Compiler

UMWAIT - MWAIT auf Benutzerebene

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

UMWAIT - MWAIT auf Benutzerebene. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen reg, imm8.

Syntax

UMWAIT reg, imm8

Operands and Sizes

Form | Meaning
reg, imm8 | may read or write memory; uses an immediate control byte or value; uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    umwait eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! umwait eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

UMWAIT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

UMWAIT operand[, operand]

PBXB64-Verwendung

UMWAIT ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! UMWAIT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VERR - Segment zum Lesen überprüfen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › VERR - Segment zum Lesen überprüfen
Hilfe zum PBXB64-Compiler

VERR - Segment zum Lesen überprüfen

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VERR - Segment zum Lesen überprüfen. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen reg/mem16.

Syntax

VERR reg/mem16

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem16 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    verr ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! verr ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VERR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VERR operand[, operand]

PBXB64-Verwendung

VERR ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VERR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


VERW - Segment zum Schreiben überprüfen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › VERW - Segment zum Schreiben überprüfen
Hilfe zum PBXB64-Compiler

VERW - Segment zum Schreiben überprüfen

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

VERW - Segment zum Schreiben überprüfen. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen reg/mem16.

Syntax

VERW reg/mem16

Operands and Sizes

Form | Meaning
reg | uses a general-purpose register
mem16 | may read or write memory

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    verw ymm0, ymm1, ymm2
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! verw ymm0, ymm1, ymm2
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

VERW ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

VERW operand[, operand]

PBXB64-Verwendung

VERW ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! VERW ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


WBINVD - Caches zurückschreiben und ungültig machen - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › WBINVD - Caches zurückschreiben und ungültig machen
Hilfe zum PBXB64-Compiler

WBINVD - Caches zurückschreiben und ungültig machen

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

WBINVD - Caches zurückschreiben und ungültig machen. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

WBINVD keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    wbinvd operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! wbinvd operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

WBINVD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

WBINVD operand[, operand]

PBXB64-Verwendung

WBINVD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! WBINVD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


WFENCE - Warten Sie auf SFENCE (no-op in modernen CPUs) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › WFENCE - Warten Sie auf SFENCE (no-op in modernen CPUs)
Hilfe zum PBXB64-Compiler

WFENCE - Warten Sie auf SFENCE (no-op in modernen CPUs)

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

WFENCE - Warten Sie auf SFENCE (no-op in modernen CPUs). Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

WFENCE keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    wfence operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! wfence operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

WFENCE ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

WFENCE operand[, operand]

PBXB64-Verwendung

WFENCE ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! WFENCE ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


WRFSBASE - Schreiben Sie die FS-Basisadresse - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › WRFSBASE - Schreiben Sie die FS-Basisadresse
Hilfe zum PBXB64-Compiler

WRFSBASE - Schreiben Sie die FS-Basisadresse

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

WRFSBASE - Schreiben Sie die FS-Basisadresse. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen reg64.

Syntax

WRFSBASE reg64

Operands and Sizes

Form | Meaning
reg64 | uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    wrfsbase eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! wrfsbase eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

WRFSBASE ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

WRFSBASE operand[, operand]

PBXB64-Verwendung

WRFSBASE ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! WRFSBASE ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


WRGSBASE - GS-Basisadresse schreiben - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › WRGSBASE - GS-Basisadresse schreiben
Hilfe zum PBXB64-Compiler

WRGSBASE - GS-Basisadresse schreiben

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

WRGSBASE - GS-Basisadresse schreiben. Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen reg64.

Syntax

WRGSBASE reg64

Operands and Sizes

Form | Meaning
reg64 | uses a general-purpose register

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    wrgsbase eax, ebx
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! wrgsbase eax, ebx
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

WRGSBASE ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

WRGSBASE operand[, operand]

PBXB64-Verwendung

WRGSBASE ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! WRGSBASE ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


WRMSR - MSR schreiben (ECX=Adresse, EDX:EAX=Wert) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › WRMSR - MSR schreiben (ECX=Adresse, EDX:EAX=Wert)
Hilfe zum PBXB64-Compiler

WRMSR - MSR schreiben (ECX=Adresse, EDX:EAX=Wert)

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

WRMSR - MSR schreiben (ECX=Adresse, EDX:EAX=Wert). Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

WRMSR keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    wrmsr operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! wrmsr operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

WRMSR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

WRMSR operand[, operand]

PBXB64-Verwendung

WRMSR ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! WRMSR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


XGETBV - Erweitertes Steuerregister XCR lesen (ECX=index) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › XGETBV - Erweitertes Steuerregister XCR lesen (ECX=index)
Hilfe zum PBXB64-Compiler

XGETBV - Erweitertes Steuerregister XCR lesen (ECX=index)

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

XGETBV - Erweitertes Steuerregister XCR lesen (ECX=index). Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

XGETBV keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    xgetbv operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! xgetbv operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

XGETBV ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

XGETBV operand[, operand]

PBXB64-Verwendung

XGETBV ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! XGETBV ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


XSETBV - Erweitertes Steuerregister XCR schreiben (muss Ring 0 sein) - PBXB64 Help

Startseite › x64 Backend › Instruction Detail Pages › System & Atomic › XSETBV - Erweitertes Steuerregister XCR schreiben (muss Ring 0 sein)
Hilfe zum PBXB64-Compiler

XSETBV - Erweitertes Steuerregister XCR schreiben (muss Ring 0 sein)

Category: SYSTEM Instruction

Assembly Group: SYSTEM

PBXB64 Status: REFERENCE DETAIL - diese Seite beschreibt die Mnemonic-Form aus der ASM-Mnemonic-Tabelle. Ein eigener compile/link/run-Test ist erforderlich, bevor volle Laufzeitunterstuetzung behauptet wird.

Description

XSETBV - Erweitertes Steuerregister XCR schreiben (muss Ring 0 sein). Diese Instruktion gehoert zur SYSTEM-Familie und verwendet die dokumentierten Operandenformen keiner.

Syntax

XSETBV keiner

Operands and Sizes

Form | Meaning
keiner | follow the operand order shown in the syntax

Use the memory width implied by the operand form; add explicit size notation when the assembler cannot infer it.

Behavior

PBXB64 dokumentiert diese Instruktion als einzelne x64/ SIMD-Mnemonic-Seite, damit Syntax, Operandenreihenfolge und Seiteneffekte nicht nur in Familienuebersichten stehen. Die Instruktion veraendert die Zieloperanden nach der CPU-Semantik; Quelloperanden bleiben unveraendert, sofern die Form sie nicht zugleich als Ziel verwendet.

Flags and Side Effects

Pruefe fuer produktiven Code die CPU-Dokumentation und einen fokussierten PBXB64-Test. Viele reine Move-/Shuffle-/SIMD-Datenbewegungen veraendern EFLAGS nicht, waehrend Compare/Test-Formen Flags oder Maskenregister setzen koennen.

Sample Program 1 - Standalone ASM

.text
.global main
main:
    xsetbv operand
    xor eax, eax
    ret

Sample Program 2 - BASIC Inline ASM Pattern

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Use this pattern only after the inline ASM path proves this mnemonic.
    ' ! xsetbv operand
    FUNCTION = 0
END FUNCTION

Validation Evidence

Generated from cmd_asm_mnemonics_system.html. Promote this page from reference detail to certified tested only after adding a focused assembler validation file and rerunning the ASM lane.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

XSETBV ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

XSETBV operand[, operand]

PBXB64-Verwendung

XSETBV ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! XSETBV ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

  • SYSTEM mnemonic overview
  • ASM Language
  • ASM memory operands

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ADC – Mit Carry hinzufügen – PBXB64 Assembler-Hilfe

Startseite › Funktionen › ADC – Mit Carry hinzufügen

ADC – Mit Carry hinzufügen

Fügt den Quelloperanden und das Übertragsflag zum Zieloperanden hinzu.

Kategorie: Arithmetik | Gruppe: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ADC dst, src

Operanden

Formular | Beschreibung | Beispiel
ADC reg, reg | Register hinzufügen und zum Registrieren übertragen. | adc rax, rbx
ADC reg, mem | Speicherwert hinzufügen und in die Registrierung übertragen. | adc rax, [rsi]
ADC mem, reg | Register hinzufügen und in den Speicher übertragen. | adc [rsi], rax
ADC reg, imm | Sofort hinzufügen und zur Registrierung mitnehmen. | adc rax, 1
ADC mem, imm | Sofort hinzufügen und im Gedächtnis speichern. | adc qword [rsi], 1

Beschreibung

ADC führt dst = dst + src + CF, wo CF ist das Übertragsflag einer vorherigen Operation. Es ist das multipräzise Gegenstück zu ADD: nach Addition der unteren Teile einer großen Ganzzahl mit ADD, aufeinanderfolgende höhere Gliedmaßen werden mit hinzugefügt ADC so dass sich Überträge über den gesamten Wert ausbreiten.

Flaggen

Beeinflusst je nach Ergebnis OF, SF, ZF, AF, PF, CF.

Codierungsnotizen

  • Unterstützt 8-Bit-, 16-Bit-, 32-Bit- und 64-Bit-Operandengrößen.
  • Im 64-Bit-Modus erweitert der 32-Bit-Operand das Ergebnis auf Null und erweitert es auf das vollständige 64-Bit-Ziel. Bei 8-Bit- und 16-Bit-Formularen bleiben die oberen Bits unverändert.
  • Die Direktform kodiert eine vorzeichenerweiterte 8-Bit-Direktform, wenn der Wert passt, oder andernfalls eine Vollformat-Direktform.

Beispiele

; 128-bit addition: RDX:RAX = RDX:RAX + RCX:RBX
add rax, rbx                 ; add low qwords, CF captures overflow
adc rdx, rcx                 ; add high qwords plus carry

; Increment a big integer limb with carry propagation
adc rax, [rsi+8]             ; add next limb plus incoming carry

When to use

VerwendenADC für Arithmetik mit erweiterter Genauigkeit, Bibliotheken mit großen ganzen Zahlen, kryptografische Routinen oder alle Fälle, in denen ein Wert breiter als ein einzelnes Register ist und Überträge zwischen Gliedern übertragen werden müssen.

Siehe auch

  • HINZUFÜGEN
  • SBB
  • SUB
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

ADC – Mit Carry hinzufügen ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

ADC – Mit Carry hinzufügen operand[, operand]

PBXB64-Verwendung

ADC – Mit Carry hinzufügen ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! ADC – Mit Carry hinzufügen ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


HINZUFÜGEN – Hinzufügen – PBXB64 Assembler-Hilfe

Startseite › Funktionen › HINZUFÜGEN – Hinzufügen

HINZUFÜGEN – Hinzufügen

Fügt den Quelloperanden zum Zieloperanden hinzu und speichert das Ergebnis im Ziel.

Kategorie: Arithmetik | Gruppe: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ADD dst, src

Operanden

Formular | Beschreibung | Beispiel
ADD reg, reg | Register hinzufügen, um sich zu registrieren. | add rax, rbx
ADD reg, mem | Speicherwert zur Registrierung hinzufügen. | add rax, [rsi]
ADD mem, reg | Register zum Speicher hinzufügen. | add [rsi], rax
ADD reg, imm | Sofort hinzufügen, um sich zu registrieren. | add rax, 42
ADD mem, imm | Sofort zum Speicher hinzufügen. | add dword [rsi], 1

Beschreibung

ADD führt eine ganzzahlige Addition durch dst = dst + src. Es handelt sich um eine der am häufigsten verwendeten Rechenanweisungen. Das Ergebnis ersetzt den Zieloperanden; Der Quelloperand bleibt unverändert. Wenn das mathematische Ergebnis nicht in die Zielbreite passt, wird das Übertragsflag (CF) ist eingestellt.

Flaggen

Beeinflusst je nach Ergebnis OF, SF, ZF, AF, PF, CF.

Codierungsnotizen

  • Unterstützt 8-Bit-, 16-Bit-, 32-Bit- und 64-Bit-Operandengrößen.
  • Hinzufügen zu RSPoderRBP ist gültig, wird aber normalerweise zugunsten von vermieden SUB/ADD auf dem Stapelzeiger an Funktionsprolog-/Epiloggrenzen.
  • Unmittelbare Formen kodieren nach Möglichkeit eine vorzeichenerweiterte 8-Bit-Sofortform für eine kleinere Codegröße.

Beispiele

add rax, 5                   ; rax = rax + 5
add rbx, [count]             ; rbx = rbx + value at memory label 'count'
add [total], rax             ; memory at 'total' += rax

; Common loop counter idiom
add rcx, 1

When to use

VerwendenADD für gewöhnliche Ganzzahladdition, Zeigerarithmetik (mit entsprechender separater Behandlung der Skalierung), Schleifenzähler und Akkumulation.

Siehe auch

  • ADC
  • SUB
  • INC
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

HINZUFÜGEN – Hinzufügen ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

HINZUFÜGEN – Hinzufügen operand[, operand]

PBXB64-Verwendung

HINZUFÜGEN – Hinzufügen ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! HINZUFÜGEN – Hinzufügen ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ADDPS – Gepacktes Gleitkomma mit einfacher Genauigkeit hinzufügen – PBXB64 Assembler-Hilfe

Startseite › Funktionen › ADDPS – Gepackten Gleitkomma mit einfacher Genauigkeit hinzufügen
Hilfe zum PBXB64-Compiler

ADDPS – Gepacktes Gleitkomma mit einfacher Genauigkeit hinzufügen

Fügt vier Gleitkommawerte mit einfacher Genauigkeit (32 Bit) parallel hinzu.

Kategorie: SSE/AVX | Gruppe: SSE-Arithmetik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ADDPS xmm1, xmm2/m128

Operanden

Formular | Beschreibung | Beispiel
ADDPS xmm, xmm | Fügen Sie gepackte Floats von einem XMM-Register zu einem anderen hinzu. | addps xmm0, xmm1
ADDPS xmm, m128 | Fügen Sie gepackte Floats aus dem 128-Bit-Speicher hinzu. | addps xmm0, [rsi]

Beschreibung

ADDPS arbeitet mit 128-Bit-XMM-Registern. Es behandelt das Register als vier unabhängige 32-Bit-IEEE-754-Floats mit einfacher Genauigkeit und fügt die entsprechenden Elemente hinzu:

DST[31:0]   = SRC1[31:0]   + SRC2[31:0]
DST[63:32]  = SRC1[63:32]  + SRC2[63:32]
DST[95:64]  = SRC1[95:64]  + SRC2[95:64]
DST[127:96] = SRC1[127:96] + SRC2[127:96]

Das ist ein verpackt SSE-Betrieb: Alle vier Lanes werden gleichzeitig ausgeführt. PBXB64 gibt es aus, wenn Float-Arrays vektorisiert werden oder wenn intrinsische Funktionen parallele Mathematik mit einfacher Genauigkeit anfordern.

Flaggen

Keines der EFLAGS wird geändert.

Codierungsnotizen

  • Erfordert SSE1 (eingeführt mit Pentium III).
  • Für eine optimale Leistung muss der Speicheroperand auf 16 Byte ausgerichtet sein. Nicht ausgerichtete Zugriffe können auf älteren CPUs eine allgemeine Schutzausnahme auslösen, es sei denn ADDUPS verwendet wird.
  • Das ModR/M-Byte wählt die Quelle aus; Das Ziel ist immer ein XMM-Register.

Beispiele

; Add two aligned arrays of four floats
movaps xmm0, [vec_a]         ; load 4 floats from vec_a
addps  xmm0, [vec_b]         ; add 4 floats from vec_b
movaps [vec_r], xmm0         ; store 4 results

; Pairwise vector addition within registers
movaps xmm0, xmm1
addps  xmm0, xmm2

When to use

VerwendenADDPS für SIMD-Vektormathematik auf Gleitkommazahlen mit einfacher Genauigkeit, wie z. B. Grafiktransformationen, Audio-Sample-Mischung oder jede Arbeitslast, bei der vier unabhängige Additionen gleichzeitig durchgeführt werden können.

Siehe auch

  • ADDSS
  • HINZUFÜGEN
  • SUBPS
  • MULPS
  • SSE-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

ADDPS – Gepacktes Gleitkomma mit einfacher Genauigkeit hinzufügen ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

ADDPS – Gepacktes Gleitkomma mit einfacher Genauigkeit hinzufügen operand[, operand]

PBXB64-Verwendung

ADDPS – Gepacktes Gleitkomma mit einfacher Genauigkeit hinzufügen ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! ADDPS – Gepacktes Gleitkomma mit einfacher Genauigkeit hinzufügen ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ADDSD – Skalaren Gleitkomma mit doppelter Genauigkeit hinzufügen – PBXB64 Assembler-Hilfe

Startseite› Funktionen › ADDSD – Skalaren Gleitkomma mit doppelter Genauigkeit hinzufügen
Hilfe zum PBXB64-Compiler

ADDSD – Skalaren Gleitkomma mit doppelter Genauigkeit hinzufügen

Fügt den Gleitkommawert niedriger Ordnung mit doppelter Genauigkeit (64-Bit) in zwei XMM-Registern hinzu.

Kategorie: SSE/AVX | Gruppe: SSE-Arithmetik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ADDSD xmm1, xmm2/m64

Operanden

Formular | Beschreibung | Beispiel
ADDSD xmm, xmm | Skalar-Double von einem XMM-Register zu einem anderen hinzufügen. | addsd xmm0, xmm1
ADDSD xmm, m64 | Skalar-Double aus dem 64-Bit-Speicher hinzufügen. | addsd xmm0, [rsi]

Beschreibung

ADDSD ist ein Skalar SSE2-Anweisung. Es fügt nur die unteren 64 Bits des Quelloperanden zu den unteren 64 Bits des Ziel-XMM-Registers hinzu; Die oberen 64 Bits des Ziel-XMM-Registers bleiben unverändert. Dies entspricht einer einzelnen IEEE-754-Addition mit doppelter Genauigkeit.

PBXB64 verwendet ADDSD für DOUBLEUndEXTENDED (als Double emuliert) Gleitkomma-Additionen, die nicht vektorisiert sind.

Flaggen

Keines der EFLAGS wird geändert.

Codierungsnotizen

  • Erfordert SSE2.
  • Die Speicherform liest nur 8 Bytes; Die Ausrichtung wird empfohlen, ist jedoch bei modernen CPUs nicht erforderlich.
  • Die oberen 64 Bits des Ziel-XMM-Registers bleiben erhalten, im Gegensatz zu gepackten Operationen, die das gesamte Register überschreiben.

Beispiele

; Add two DOUBLE values
movsd xmm0, [a]              ; load double a into low xmm0
addsd xmm0, [b]              ; xmm0.low = a + b
movsd [r], xmm0              ; store result

; Register-to-register double add
movsd xmm0, xmm1
addsd xmm0, xmm2

When to use

VerwendenADDSD für skalare Gleitkommaarithmetik mit doppelter Genauigkeit: wissenschaftliche Berechnungen, finanzielle Näherungen oder andere DOUBLE Ausdruck in PBXB64, der direkt einem einzelnen SSE2-Zusatz zugeordnet ist.

Siehe auch

  • ADDSS
  • ADDPS
  • SUBSD
  • MULSD
  • SSE-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

ADDSD – Skalaren Gleitkomma mit doppelter Genauigkeit hinzufügen ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

ADDSD – Skalaren Gleitkomma mit doppelter Genauigkeit hinzufügen operand[, operand]

PBXB64-Verwendung

ADDSD – Skalaren Gleitkomma mit doppelter Genauigkeit hinzufügen ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! ADDSD – Skalaren Gleitkomma mit doppelter Genauigkeit hinzufügen ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ADDSS – Skalaren Gleitkomma mit einfacher Genauigkeit hinzufügen – PBXB64 Assembler-Hilfe

Startseite › Funktionen › ADDSS – Skalare Gleitkommazahl mit einfacher Genauigkeit hinzufügen
Hilfe zum PBXB64-Compiler

ADDSS – Skalares Gleitkomma mit einfacher Genauigkeit hinzufügen

Fügt den Gleitkommawert niedriger Ordnung mit einfacher Genauigkeit (32 Bit) in zwei XMM-Registern hinzu.

Kategorie: SSE/AVX | Gruppe: SSE-Arithmetik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ADDSS xmm1, xmm2/m32

Operanden

Formular | Beschreibung | Beispiel
ADDSS xmm, xmm | Fügen Sie Skalar-Float von einem XMM-Register zu einem anderen hinzu. | addss xmm0, xmm1
ADDSS xmm, m32 | Fügen Sie Skalar-Float aus dem 32-Bit-Speicher hinzu. | addss xmm0, [rsi]

Beschreibung

ADDSS ist ein Skalar SSE1-Anweisung. Es fügt nur die unteren 32 Bits des Quelloperanden zu den unteren 32 Bits des Ziel-XMM-Registers hinzu; Die oberen 96 Bits des Ziel-XMM-Registers bleiben unverändert. Dies entspricht einer einzelnen IEEE-754-Addition mit einfacher Genauigkeit.

PBXB64 verwendet ADDSS für SINGLE Gleitkomma-Ergänzungen und für Code mit gemischter Genauigkeit, bei dem 32-Bit-Floats ausreichend sind.

Flaggen

Keines der EFLAGS wird geändert.

Codierungsnotizen

  • Erfordert SSE1.
  • Die Speicherform liest nur 4 Bytes; Die Ausrichtung wird empfohlen, ist jedoch bei modernen CPUs nicht erforderlich.
  • Die oberen 96 Bits des Ziel-XMM-Registers bleiben erhalten.

Beispiele

; Add two SINGLE values
movss xmm0, [a]              ; load single a into low xmm0
addss xmm0, [b]              ; xmm0.low = a + b
movss [r], xmm0              ; store result

; Register-to-register single add
movss xmm0, xmm1
addss xmm0, xmm2

When to use

VerwendenADDSS für skalare Gleitkommaarithmetik mit einfacher Genauigkeit: schnelle Näherungsberechnung, zu skalarem SSE kompilierte Grafik-Shader oder beliebige andere SINGLE Ausdruck in PBXB64.

Siehe auch

  • HINZUFÜGEN
  • ADDPS
  • SUBSS
  • MULSS
  • SSE-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

ADDSS – Skalares Gleitkomma mit einfacher Genauigkeit hinzufügen ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

ADDSS – Skalares Gleitkomma mit einfacher Genauigkeit hinzufügen operand[, operand]

PBXB64-Verwendung

ADDSS – Skalares Gleitkomma mit einfacher Genauigkeit hinzufügen ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! ADDSS – Skalares Gleitkomma mit einfacher Genauigkeit hinzufügen ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UND – PBXB64 Assembler-Hilfe

Startseite › Funktionen › AND – PBXB64 Assembler-Hilfe

UND – Bitweises UND

Führt eine bitweise UND-Verknüpfung von Quelle und Ziel durch und speichert das Ergebnis im Ziel.

Kategorie: Logisch | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

AND dst, src

Beschreibung

Führt durch dst = dst & src. Setzt OF=0, CF=0, SF, ZF, PF entsprechend dem Ergebnis. CF wird immer gelöscht. Nützlich zum Maskieren von Bits.

Beispiele

and rax, 0xFF              ; mask lower 8 bits
and rax, rbx               ; bitwise AND
and [rbx], 0x0F            ; mask memory

Siehe auch

  • ODER
  • XOR
  • NICHT
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

UND – Bitweises UND ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

UND – Bitweises UND operand[, operand]

PBXB64-Verwendung

UND – Bitweises UND ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! UND – Bitweises UND ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BSF / BSR – PBXB64 Assembler-Hilfe

Startseite › Funktionen › BSF / BSR – PBXB64 Assembler-Hilfe

BSF / BSR – Bit-Scan

Sucht nach dem ersten oder letzten gesetzten Bit in einem Register oder Speicher.

Kategorie: Bitmanipulation | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

BSF reg, reg/mem             ; Bit Scan Forward (lowest set bit)
BSR reg, reg/mem             ; Bit Scan Reverse (highest set bit)

Beschreibung

  • BSF: Findet den Index des niedrigsten gesetzten Bits (Bit 0 ist LSB). Setzt ZF=1, wenn Quelle 0 ist.
  • BSR: Findet den Index des höchsten gesetzten Bits. Setzt ZF=1, wenn Quelle 0 ist.

Beispiele

bsf rax, rbx                 ; rax = index of lowest set bit in rbx
bsr rax, rbx                 ; rax = index of highest set bit in rbx

Siehe auch

  • BT
  • POPCNT
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

BSF / BSR – Bit-Scan ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

BSF / BSR – Bit-Scan operand[, operand]

PBXB64-Verwendung

BSF / BSR – Bit-Scan ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! BSF / BSR – Bit-Scan ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BSR – Bit Scan Reverse – PBXB64 Assembler-Hilfe

Startseite › Funktionen › BSR – Bit Scan Reverse

BSR – Bit-Scan-Reverse

Durchsucht einen Quelloperanden vom höchstwertigen Bit abwärts und gibt den Index des höchsten gesetzten Bits zurück.

Kategorie: Bitmanipulation | Gruppe: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

BSR reg, reg/mem

Operanden

Formular | Beschreibung | Beispiel
BSR reg16, reg16/mem16 | 16-Bit-Operanden scannen. | bsr ax, bx
BSR reg32, reg32/mem32 | 32-Bit-Operanden scannen. | bsr eax, ebx
BSR reg64, reg64/mem64 | 64-Bit-Operanden scannen. | bsr rax, rbx

Beschreibung

BSR scannt den Quelloperanden ab Bit n−1 bis Bit 0, wo n ist die Operandengröße und schreibt die Bitposition des ersten gesetzten Bits (d. h. die höchstwertige 1) in das Zielregister. Wenn die Quelle Null ist, ist das Ziel undefiniert und das Null-Flag (ZF) ist auf 1 gesetzt.

Für eine Quelle ungleich Null lautet das Ergebnis floor(log2(src)). PBXB64 verwendet BSR um ganzzahlige log2-Näherungen und Bitbreitenberechnungen zu implementieren.

Flaggen

Setzt ZF, wenn der Quelloperand Null ist; klärt ZF ansonsten. OF, SF, AF, PF, CF sind undefiniert.

Codierungsnotizen

  • Unterstützt 16-Bit-, 32-Bit- und 64-Bit-Operanden; Es existiert keine 8-Bit-Form.
  • Das Ziel muss ein GPR sein; Die Quelle kann ein GPR oder ein Speicher sein.
  • Auf Intel-CPUs, BSR hat je nach Eingabewert eine variable Latenz; für eine eingabeunabhängige Alternative berücksichtigen LZCNT auf CPUs, die BMI1 unterstützen.

Beispiele

bsr rax, rbx                 ; rax = index of highest set bit in rbx
jz  zero_value               ; source was zero

; Compute integer log2 of a 64-bit value
bsr rax, rdi
; rax now holds floor(log2(rdi)) for non-zero rdi

When to use

VerwendenBSR wenn Sie die Position des höchstwertigen gesetzten Bits, Ganzzahl log2, benötigen oder um zu bestimmen, wie viele Bits erforderlich sind, um einen vorzeichenlosen Wert darzustellen.

Siehe auch

  • BSF
  • BT
  • POPCNT
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

BSR – Bit-Scan-Reverse ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

BSR – Bit-Scan-Reverse operand[, operand]

PBXB64-Verwendung

BSR – Bit-Scan-Reverse ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! BSR – Bit-Scan-Reverse ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BSWAP – Byte-Swap – PBXB64 Assembler-Hilfe

Startseite › Funktionen › BSWAP – Byte Swap

BSWAP – Byte-Swap

Kehrt die Bytereihenfolge eines vorhandenen 32-Bit- oder 64-Bit-Registers um.

Kategorie: Datenbewegung | Gruppe: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

BSWAP reg

Operanden

Formular | Beschreibung | Beispiel
BSWAP r32 | Umkehrbytes eines 32-Bit-Registers. | bswap eax
BSWAP r64 | Umkehrbytes eines 64-Bit-Registers. | bswap rax

Beschreibung

BSWAP Konvertiert zwischen Little-Endian- und Big-Endian-Darstellungen durch Umkehren der Reihenfolge der Bytes im Zielregister. Bei einem 32-Bit-Operanden werden die Bits 7:0 mit den Bits 31:24 und die Bits 15:8 mit den Bits 23:16 vertauscht. Bei einem 64-Bit-Operanden wird Byte 0 mit Byte 7, Byte 1 mit Byte 6, Byte 2 mit Byte 5 und Byte 3 mit Byte 4 vertauscht.

PBXB64 verwendet BSWAP für Netzwerk-Byte-Reihenfolge-Konvertierungen und für Endianness-fähige Datenserialisierung.

Flaggen

Keines der EFLAGS wird geändert.

Codierungsnotizen

  • Gilt nur für 32-Bit- oder 64-Bit-GPR-Ziele.
  • Die 16-Bit-Form ist architektonisch nicht definiert; verwenden XCHG auf den Low- und High-Bytes von AX für 16-Bit-Byte-Swaps.
  • Es existiert keine Erinnerungsform; um einen Speicherort byteweise zu laden, auszutauschen und zu speichern.

Beispiele

; Convert a 32-bit little-endian value to big-endian
mov eax, 0x12345678
bswap eax                    ; eax = 0x78563412

; Convert a 64-bit value
mov rax, 0x0123456789ABCDEF
bswap rax                    ; rax = 0xEFCDAB8967452301

; Network-byte-order 32-bit store
mov eax, [host_order]
bswap eax
mov [net_order], eax

When to use

VerwendenBSWAP für die Endianness-Konvertierung, die Vorbereitung von Protokoll-Header-Feldern oder Hashing-Algorithmen, die Byte-umgekehrte Werte erfordern.

Siehe auch

  • MOV
  • XCHG
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

BSWAP – Byte-Swap ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

BSWAP – Byte-Swap operand[, operand]

PBXB64-Verwendung

BSWAP – Byte-Swap ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! BSWAP – Byte-Swap ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


BT / BTS / BTR / BTC – PBXB64 Assembler-Hilfe

Startseite › Funktionen › BT / BTS / BTR / BTC – PBXB64 Assembler-Hilfe
Hilfe zum PBXB64-Compiler

BT / BTS / BTR / BTC – Bittest

Testet, setzt, setzt oder ergänzt ein einzelnes Bit in einem Register oder Speicher.

Kategorie: Bitmanipulation | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

BT  reg/mem, reg/imm         ; Test bit (copy to CF)
BTS reg/mem, reg/imm         ; Test and set bit
BTR reg/mem, reg/imm         ; Test and reset bit
BTC reg/mem, reg/imm         ; Test and complement bit

Beschreibung

  • BT: Kopiert das angegebene Bit nach CF. Ändert das Bit nicht.
  • BTS: Kopiert das Bit nach CF und setzt es dann auf 1.
  • BTR: Kopiert das Bit nach CF und löscht es dann auf 0.
  • BTC: Kopiert das Bit nach CF und schaltet es dann um.

Beispiele

bt rax, 5                    ; CF = bit 5 of rax
bts [rbx], 0                 ; set bit 0, old value in CF
btc rax, 3                   ; toggle bit 3

Siehe auch

  • BSF
  • BSR
  • UND
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

BT / BTS / BTR / BTC – Bittest ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

BT / BTS / BTR / BTC – Bittest operand[, operand]

PBXB64-Verwendung

BT / BTS / BTR / BTC – Bittest ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! BT / BTS / BTR / BTC – Bittest ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CALL – PBXB64 Assembler-Hilfe

Startseite › Funktionen › CALL – PBXB64 Assembler-Hilfe

CALL – Aufrufprozedur

Schickt die Rücksprungadresse und überträgt die Kontrolle an eine Prozedur.

Kategorie: Kontrollübertragung | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CALL label
CALL reg
CALL [mem]

Beschreibung

Schiebt die Adresse des nächsten Befehls auf den Stapel (RSP wird um 8 dekrementiert) und springt dann zum Ziel. Die aufgerufene Prozedur sollte mit enden RET zurückkehren.

Beispiele

call my_function
...
my_function:
    mov rax, 42
    ret

Siehe auch

  • RET
  • JMP
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CALL – Aufrufprozedur ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CALL – Aufrufprozedur operand[, operand]

PBXB64-Verwendung

CALL – Aufrufprozedur ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CALL – Aufrufprozedur ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CBW / CWDE / CDQE / CWD / CDQ / CQO / CBTW – Sign Extension – PBXB64 Assembler-Hilfe

Startseite › Funktionen › CBW / CWDE / CDQE / CWD / CDQ / CQO / CBTW – Zeichenerweiterung
Hilfe zum PBXB64-Compiler

CBW / CWDE / CDQE / CWD / CDQ / CQO / CBTW – Zeichenerweiterung

Erweitert einen Wert im Akkumulator durch Vorzeichen in ein breiteres Register oder Registerpaar.

Kategorie: Datenbewegung | Gruppe: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CBW                          ; AL  -> AX        (byte to word)
CBTW                         ; AL  -> AX        (AT&T alias for CBW)
CWDE                         ; AX  -> EAX       (word to dword)
CDQE                         ; EAX -> RAX       (dword to qword)
CWD                          ; AX  -> DX:AX     (word to dword pair)
CDQ                          ; EAX -> EDX:EAX   (dword to qword pair)
CQO                          ; RAX -> RDX:RAX   (qword to dqword pair)

Operanden

Formular | Beschreibung | Beispiel
CBW / CBTW | Zeichen-erweitern AL hinein AX. | cbw
CWDE | Zeichen-erweitern AX hinein EAX. | cwde
CDQE | Zeichen-erweitern EAX hinein RAX. | cdqe
CWD | Zeichen-erweitern AX hinein DX:AX. | cwd
CDQ | Zeichen-erweitern EAX hinein EDX:EAX. | cdq
CQO | Zeichen-erweitern RAX hinein RDX:RAX. | cqo

Beschreibung

Diese Anweisungen kopieren das Vorzeichenbit eines kleineren Werts in jedes höhere Bit eines größeren Ziels. Die Einzelregisterformulare (CBW, CWDE, CDQE) den Akku erweitern. Das Registerpaar bildet (CWD, CDQ, CQO) Vorzeichenerweitern Sie den Akkumulator in ein zweites Register, sodass das Paar einen doppelt so breiten vorzeichenbehafteten Wert bildet.

CBTW ist der AT&T-Syntax-Alias für CBW; beide fügen sich zum gleichen Opcode zusammen und werden von PBXB64 akzeptiert.

Der Hauptzweck der Registerpaarformulare besteht darin, die Dividende vor der unterzeichneten Teilung vorzubereiten (IDIV). CQOUndCDQ werden automatisch vom Codegenerator von PBXB64 für 64-Bit- bzw. 32-Bit-Divisionen mit Vorzeichen ausgegeben.

Flaggen

Keines der EFLAGS wird geändert.

Codierungsnotizen

  • CBW, CWDE, UndCDQE sind Einzelbyte-Opcodes ohne explizite Operanden.
  • CWD, CDQ, UndCQO sind auch Einzelbyte-Opcodes; Das Zielregisterpaar ist implizit.
  • Im 64-Bit-Modus CDQE Null-Erweitert von 32-Bit EAX auf 64-Bit RAX Bewahrungszeichen; verwechseln Sie es nicht mit MOVSXD, das sich vorzeichenmäßig vom Speicher oder einem 32-Bit-Register in ein 64-Bit-Ziel erstreckt.

Beispiele

; 64-bit signed division: RAX / RBX
mov  rax, -500
cqo                          ; RDX = sign-extension of RAX (-1)
idiv rbx                     ; RAX = quotient, RDX = remainder

; 32-bit signed division
mov  eax, -200
cdq                          ; EDX = sign-extension of EAX
idiv ebx

; Widen a 32-bit signed result to 64 bits
cdqe                         ; RAX = sign-extended EAX

When to use

Verwenden Sie die Einzelregisterformen, wenn Sie einen vorzeichenbehafteten Wert für Vergleiche oder weitere Arithmetik erweitern müssen. Benutzen Sie vorher die Registerpaar-Formulare IDIV um die Volldividende zu bilden. PBXB64 fügt im Allgemeinen automatisch die richtige Form ein, aber die handschriftliche Assemblierung sollte sie beim Dividieren vorzeichenbehafteter Ganzzahlen explizit einschließen.

Siehe auch

  • IDIV
  • IMUL
  • MOVSX
  • MOVSXD
  • CDQ
  • CQO
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CBW / CWDE / CDQE / CWD / CDQ / CQO / CBTW – Zeichenerweiterung ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CBW / CWDE / CDQE / CWD / CDQ / CQO / CBTW – Zeichenerweiterung operand[, operand]

PBXB64-Verwendung

CBW / CWDE / CDQE / CWD / CDQ / CQO / CBTW – Zeichenerweiterung ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CBW / CWDE / CDQE / CWD / CDQ / CQO / CBTW – Zeichenerweiterung ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CLD – Flag „Richtung löschen“ – PBXB64 Assembler-Hilfe

Startseite › Funktionen › CLD – Clear Direction Flag

CLD – Markierung „Richtung löschen“.

Löscht das Richtungsflag (DF = 0), wodurch String-Anweisungen ihre Indexregister automatisch erhöhen.

Kategorie: Flaggen | Gruppe: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CLD

Operanden

Keine.

Beschreibung

Setzt das Richtungsflag auf 0. Nachher CLD, String-Anweisungen wie MOVS, STOS, LODS, UndSCAS Inkrement RSI/RDI. Dies ist die Standardrichtung, die von den meisten Codes erwartet wird.

Flaggen

DF ist gelöscht. Alle anderen Flags bleiben davon unberührt.

Beispiele

; Prepare for forward string operations
cld
mov rsi, source
mov rdi, dest
mov rcx, 100
rep movsb

When to use

VerwendenCLD vor jeder String-Operation, die Speicher von niedrigen zu hohen Adressen verarbeiten muss. Immer mit kombinieren STD wenn Sie vorübergehend auf Rückwärtsrichtung umgeschaltet haben.

Siehe auch

  • STD
  • REP-Präfix

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CLD – Markierung „Richtung löschen“. ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CLD – Markierung „Richtung löschen“. operand[, operand]

PBXB64-Verwendung

CLD – Markierung „Richtung löschen“. ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CLD – Markierung „Richtung löschen“. ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CLD / STD – PBXB64 Assembler-Hilfe

Startseite › Funktionen › CLD / STD – PBXB64 Assembler-Hilfe

CLD / STD – Richtungsflaggensteuerung

Steuert die Richtung von String-Operationen.

Kategorie: Flaggensteuerung | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CLD                          ; Clear Direction Flag (DF=0, forward)
STD                          ; Set Direction Flag (DF=1, backward)

Beschreibung

Steuert die Richtung von String-Operationen (MOVS, CMPS, SCAS, LODS, STOS). Wenn DF=0 (CLD), erhöht sich RSI/RDI. Wenn DF=1 (STD), dekrementiert RSI/RDI.

Notiz: Windows x64 ABI erfordert DF=0 beim Ein- und Ausstieg. Verwenden Sie CLD immer vor String-Operationen, es sei denn, Sie benötigen ausdrücklich eine Rückwärtsdurchquerung.

Beispiele

cld
rep movsb                    ; copy forward

std
rep movsb                    ; copy backward

Siehe auch

  • REP
  • MOVS
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CLD / STD – Richtungsflaggensteuerung ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CLD / STD – Richtungsflaggensteuerung operand[, operand]

PBXB64-Verwendung

CLD / STD – Richtungsflaggensteuerung ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CLD / STD – Richtungsflaggensteuerung ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CMOVcc – PBXB64 Assembler-Hilfe

Startseite › Funktionen › CMOVcc – PBXB64 Assembler-Hilfe

CMOVcc – Bedingter Umzug

Kopiert die Quelle basierend auf Flags bedingt zum Ziel. Verzweigt nicht.

Kategorie: Datenbewegung | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CMOVcc dst, src

Beschreibung

Wenn die Bedingung wahr ist, wird src nach dst kopiert. Bei „false“ bleibt dst unverändert. Nützlich zum Eliminieren von Verzweigungen in leistungskritischem Code.

Konditionsvarianten

Gedächtnisstütze | Zustand | Flaggen
CMOVA / CMOVNBE | Oben | CF=0 und ZF=0
CMOVAE / CMOVNB | Oben oder gleich | CF=0
CMOVB / CMOVNAE | Unten | CF=1
CMOVE / CMOVZ | Gleich | ZF=1
CMOVNE / CMOVNZ | Ungleich | ZF=0
CMOVG / CMOVNLE | Größer (signiert) | ZF=0 und SF=OF
CMOVGE / CMOVNL | Größer oder gleich (mit Vorzeichen) | SF=OF
CMOVL / CMOVNGE | Weniger (signiert) | SF!=OF
CMOVLE / CMOVNG | Kleiner oder gleich (mit Vorzeichen) | ZF=1 oder SF!=OF

Beispiele

cmovg rax, rbx              ; if greater, rax = rbx

Siehe auch

  • MOV
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CMOVcc – Bedingter Umzug ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CMOVcc – Bedingter Umzug operand[, operand]

PBXB64-Verwendung

CMOVcc – Bedingter Umzug ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CMOVcc – Bedingter Umzug ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CMP – PBXB64 Assembler-Hilfe

Startseite › Funktionen › CMP – PBXB64 Assembler-Hilfe

CMP – Vergleichen

Vergleicht zwei Operanden, indem die Quelle vom Ziel subtrahiert und Flags gesetzt werden (ohne das Ergebnis zu speichern).

Kategorie: Arithmetik | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CMP dst, src

Beschreibung

Führt durch dst - src intern, speichert das Ergebnis jedoch nicht. Setzt OF, SF, ZF, AF, PF, CF. Wird vor bedingten Sprüngen (Jcc) und bedingten Bewegungen (CMOVcc) verwendet.

Beispiele

cmp rax, rbx
je equal
jg greater
jl less

cmp rax, 0
jz zero

Siehe auch

  • TEST
  • SUB
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CMP – Vergleichen ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CMP – Vergleichen operand[, operand]

PBXB64-Verwendung

CMP – Vergleichen ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CMP – Vergleichen ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CMPS - Compare String Operands - PBXB64 Compiler Help

Startseite › x64 Backend › Instruction Detail Pages › Miscellaneous › CMPS - Compare String Operands
Hilfe zum PBXB64-Compiler

CMPS - Compare String Operands

Compares the memory item addressed by RSI with the item addressed by RDI and updates flags as if a subtraction occurred. Repeat prefixes can compare a sequence.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

Compares the memory item addressed by RSI with the item addressed by RDI and updates flags as if a subtraction occurred. Repeat prefixes can compare a sequence.

Verwendung in PBXB64

In x64 code, ensure RSI, RDI, RCX, and the direction flag are initialized. Use cld for forward comparison unless reverse traversal is intended.

Beispiel

cld
mov rcx, length
repe cmpsb

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CMPS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CMPS operand[, operand]

PBXB64-Verwendung

CMPS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CMPS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.


CMPXCHG / CMPXCHG8B / CMPXCHG16B – PBXB64 Assembler-Hilfe

Startseite › Funktionen › CMPXCHG / CMPXCHG8B / CMPXCHG16B – PBXB64 Assembler-Hilfe
Hilfe zum PBXB64-Compiler

CMPXCHG / CMPXCHG8B / CMPXCHG16B – Vergleichen und Austauschen

Atomare Vergleichs- und Austauschoperationen für sperrenfreie Programmierung.

Kategorie: Tauschen/Konvertieren | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CMPXCHG reg/mem, reg         ; Compare AL/AX/EAX/RAX with dst, exchange if equal
CMPXCHG8B mem64              ; Compare EDX:EAX with mem64, exchange if equal
CMPXCHG16B mem128            ; Compare RDX:RAX with mem128, exchange if equal

Beschreibung

  • CMPXCHG: Vergleicht Akku mit Ziel. Wenn gleich, wird die Quelle in das Ziel geschrieben. Wenn nicht, wird das Ziel in den Akkumulator geladen. ZF signalisiert Gleichberechtigung.
  • CMPXCHG8B: Vergleicht EDX:EAX mit 64-Bit-Speicher. Wenn gleich, wird ECX:EBX geschrieben.
  • CMPXCHG16B: Vergleicht RDX:RAX mit 128-Bit-Speicher. Wenn gleich, wird RCX:RBX geschrieben. Erfordert das Präfix LOCK für die Atomizität.

Beispiele

lock cmpxchg [rbx], rcx      ; atomic compare-exchange
lock cmpxchg16b [rbx]        ; atomic 128-bit compare-exchange

Siehe auch

  • SPERREN
  • XADD
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CMPXCHG / CMPXCHG8B / CMPXCHG16B – Vergleichen und Austauschen ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CMPXCHG / CMPXCHG8B / CMPXCHG16B – Vergleichen und Austauschen operand[, operand]

PBXB64-Verwendung

CMPXCHG / CMPXCHG8B / CMPXCHG16B – Vergleichen und Austauschen ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CMPXCHG / CMPXCHG8B / CMPXCHG16B – Vergleichen und Austauschen ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CPUID – CPU-Identifikation – PBXB64 Assembler-Hilfe

Startseite › Funktionen › CPUID – CPU-Identifikation

CPUID – CPU-Identifikation

Gibt Prozessormerkmals- und Identifikationsinformationen in Allzweckregistern zurück.

Kategorie: System/Atom | Gruppe: Systemanweisungen

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CPUID

Operanden

Formular | Beschreibung | Beispiel
CPUID | Keine Operanden; Eingabeblatt in EAX, Ausgabe in EAX:EBX:ECX:EDX. | cpuid

Beschreibung

CPUID ist eine Serialisierungsanweisung, die den Prozessor nach Hersteller, Familie, Modell, Schrittweite und unterstützten Funktionsflags abfragt. Vor der Ausführung CPUID, lädt die Software das gewünschte Informationsblatt hinein EAX (und manchmal ECX für Unterblätter). Nach der Ausführung erscheinen die Ergebnisse in EAX, EBX, ECX, UndEDX.

Zu den häufig vorkommenden Blättern gehören:

  • EAX=0: maximal unterstützte Basis-Blatt- und Anbieterzeichenfolge (in EBX, EDX, ECX).
  • EAX=1: Prozessorsignatur und Feature-Flags (SSE, APIC usw.) in EAX/EBX/ECX/EDX.
  • EAX=7, ECX=0: erweiterte Feature-Flags (AVX, BMI usw.) in EBX/ECX/EDX.
  • EAX=0x80000000: Maximal erweiterte Leaf- und Vendor-String-Fortsetzung.

PBXB64 unterstützt CPUID in der Inline-Assembly; Es wird am häufigsten von Laufzeiterkennungshelfern verwendet, um zwischen skalaren und vektorisierten Implementierungen zu wählen.

Flaggen

Keines der EFLAGS wird geändert.

Codierungsnotizen

  • Opcode ist 0F A2.
  • CPUID ist implizit serialisierend: Alle vorherigen Anweisungen sind vorher global sichtbar CPUID ausgeführt, und alle nachfolgenden Anweisungen beginnen, nachdem es abgeschlossen ist.
  • Überprüfen Sie immer das maximale Blatt in EAX, bevor Sie Blätter mit höherer Nummer anfordern, um undefinierte Ergebnisse zu vermeiden.
  • Einige Blätter erfordern einen Eingabewert in ECX; Behalten Sie ECX bei Bedarf im gesamten Befehl bei.

Beispiele

; Query vendor string (GenuineIntel, AuthenticAMD, ...)
mov eax, 0
cpuid
; EBX, EDX, ECX now hold the 12-byte vendor string

; Check for SSE2 support (bit 26 of EDX from leaf 1)
mov eax, 1
cpuid
test edx, 1 << 26
jz   no_sse2

; Query extended feature flags (leaf 7, sub-leaf 0)
mov eax, 7
xor ecx, ecx
cpuid
test ebx, 1 << 5          ; AVX2 bit
jnz  has_avx2

When to use

VerwendenCPUID um Prozessorfunktionen zur Laufzeit zu erkennen, die Verwendung neuerer Befehlssatzerweiterungen zu überwachen oder Prozessoridentifikationen für Diagnosezwecke zu sammeln. Vermeiden CPUID in engen Schleifen, da es relativ langsam und serialisierend ist.

Siehe auch

  • RDTSC
  • PAUSE
  • INT3
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CPUID – CPU-Identifikation ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CPUID – CPU-Identifikation operand[, operand]

PBXB64-Verwendung

CPUID – CPU-Identifikation ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CPUID – CPU-Identifikation ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


CQO - Sign Extend RAX into RDX:RAX - PBXB64 Compiler Help

Startseite › x64 Backend › Instruction Detail Pages › Miscellaneous › CQO - Sign Extend RAX into RDX:RAX
Hilfe zum PBXB64-Compiler

CQO - Sign Extend RAX into RDX:RAX

Sign-extends the 64-bit value in RAX into the 128-bit dividend RDX:RAX. It is normally used immediately before signed 64-bit division with idiv.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

Sign-extends the 64-bit value in RAX into the 128-bit dividend RDX:RAX. It is normally used immediately before signed 64-bit division with idiv.

Verwendung in PBXB64

Use cqo for signed 64-bit division. For unsigned division, clear RDX or prepare the high half manually.

Beispiel

mov rax, dividend
cqo
idiv rcx

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CQO ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CQO operand[, operand]

PBXB64-Verwendung

CQO ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CQO ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.


cvtsd2si – Scalar Double in Signed Integer konvertieren – PBXB64 Assembler-Hilfe

Startseite › Funktionen › cvtsd2si – Scalar Double in Signed Integer konvertieren
Hilfe zum PBXB64-Compiler

CVTSD2SI – Skalar Double in Signed Integer konvertieren

Konvertiert den Gleitkommawert niedriger Ordnung mit doppelter Genauigkeit in einem XMM-Register oder Speicheroperanden in eine vorzeichenbehaftete 32-Bit- oder 64-Bit-Ganzzahl in einem Allzweckregister.

Kategorie: SSE/AVX | Gruppe: Gleitkommakonvertierung

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CVTSD2SI reg, xmm/mem64

Operanden

Formular | Beschreibung | Beispiel
CVTSD2SI r32, xmm | Konvertieren Sie Low Double in XMM in eine vorzeichenbehaftete 32-Bit-Ganzzahl | cvtsd2si eax, xmm0
CVTSD2SI r32, mem64 | Konvertieren Sie das Speicherdouble in eine vorzeichenbehaftete 32-Bit-Ganzzahl | cvtsd2si eax, qword ptr [value]
CVTSD2SI r64, xmm | Konvertieren Sie Low Double in XMM in eine vorzeichenbehaftete 64-Bit-Ganzzahl | cvtsd2si rax, xmm0
CVTSD2SI r64, mem64 | Konvertieren Sie Memory Double in eine vorzeichenbehaftete 64-Bit-Ganzzahl | cvtsd2si rax, qword ptr [value]

Beschreibung

CVTSD2SI wandelt den skalaren Gleitkommawert mit doppelter Genauigkeit, der sich in den unteren 64 Bits des Quell-XMM-Operanden (oder einem 64-Bit-Speicherort) befindet, in eine vorzeichenbehaftete Ganzzahl um und speichert das Ergebnis im Ziel-Allzweckregister. Die Konvertierung verwendet den aktuellen Rundungsmodus, der durch die Rundungssteuerbits des MXCSR-Registers angegeben wird. Für die Kürzung unabhängig vom Rundungsmodus verwenden Sie CVTTSD2SI.

Dieser Befehl funktioniert nur auf dem Low-Double der XMM-Quelle; Die oberen Bits des XMM-Registers werden ignoriert und die oberen Bits des Zielregisters werden für 32-Bit-Formulare auf Null gesetzt.

Flaggen

Keiner betroffen.

Codierungsnotizen

  • Erfordert ein F2-Präfix für die skalare Doppelform; kodiert als F2 0F 2D /r.
  • Wenn das Ziel ein 64-Bit-Register ist, ist ein REX.W-Präfix erforderlich.
  • Wenn der Quellwert außerhalb des Bereichs des Ziel-Integer-Typs liegt, ist das Ergebnis der unbestimmte Integer-Wert (MIN_INT) und es wird eine Ausnahme wegen ungültigem Vorgang ausgelöst, wenn er nicht maskiert wird.

Beispiele

; Convert a double in xmm0 to a 32-bit signed integer in eax
movsd xmm0, qword ptr [pi]    ; xmm0 = 3.141592653589793
cvtsd2si eax, xmm0            ; eax = 3 (with default rounding mode)

; Convert a double to a 64-bit signed integer
movsd xmm1, qword ptr [large] ; xmm1 = 1.2345e12
cvtsd2si rax, xmm1            ; rax = 1234500000000

; Memory-to-register conversion
mov rbp, rsp
sub rsp, 8
mov qword ptr [rsp], 0x4049000000000000 ; 50.0
cvtsd2si ebx, qword ptr [rsp] ; ebx = 50
add rsp, 8

When to use

Verwenden Sie CVTSD2SI, wenn Sie ein Gleitkommaergebnis mit doppelter Genauigkeit im vorherrschenden Rundungsmodus wieder in die ganzzahlige Form bringen müssen. Zu den gängigen Szenarios gehört die Konvertierung berechneter Koordinaten, Skalierungsfaktoren oder Zeitwerte in ganzzahlige Indizes oder Pixelpositionen. Wenn Sie unabhängig vom Rundungsmodus eine Kürzung in Richtung Null benötigen, bevorzugen Sie CVTTSD2SI.

Siehe auch

  • CVTSI2SD
  • CVTTSD2SI
  • CVTSD2SS
  • CVTSS2SD

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CVTSD2SI – Skalar Double in Signed Integer konvertieren ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CVTSD2SI – Skalar Double in Signed Integer konvertieren operand[, operand]

PBXB64-Verwendung

CVTSD2SI – Skalar Double in Signed Integer konvertieren ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CVTSD2SI – Skalar Double in Signed Integer konvertieren ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


cvtsd2ss – Skalar Double in Skalar Single konvertieren – PBXB64 Assembler-Hilfe

Startseite › Funktionen › cvtsd2ss – Skalar Double in Skalar Single konvertieren
Hilfe zum PBXB64-Compiler

CVTSD2SS – Skalar Double in Skalar Single konvertieren

Konvertiert den niedrigwertigen Gleitkommawert mit doppelter Genauigkeit in der Quelle in einen Gleitkommawert mit einfacher Genauigkeit in den unteren 32 Bits des Ziel-XMM-Registers.

Kategorie: SSE/AVX | Gruppe: Gleitkommakonvertierung

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CVTSD2SS xmm1, xmm2/mem64

Operanden

Formular | Beschreibung | Beispiel
CVTSD2SS xmm, xmm | Konvertieren Sie Low Double im Quell-XMM in Single im Ziel-XMM | cvtsd2ss xmm0, xmm1
CVTSD2SS xmm, mem64 | Konvertieren Sie den doppelten Speicher im Ziel-XMM in einen einfachen Speicher | cvtsd2ss xmm0, qword ptr [val]

Beschreibung

CVTSD2SS konvertiert den skalaren Gleitkommawert mit doppelter Genauigkeit (64 Bit) im unteren Quadwort des Quelloperanden in einen Gleitkommawert mit einfacher Genauigkeit (32 Bit). Das konvertierte Ergebnis wird im unteren Doppelwort des Ziel-XMM-Registers gespeichert, während die Bits 127:32 des Ziels vom vorherigen Inhalt des Ziels erhalten bleiben. Dieses Verhalten unterscheidet sich von gepackten Konvertierungsanweisungen, die die oberen Spuren auf Null setzen.

Die Konvertierung berücksichtigt den aktuellen MXCSR-Rundungsmodus. Wenn das Ergebnis nicht exakt dargestellt werden kann, wird es entsprechend diesem Modus gerundet; Überlauf erzeugt ein IEEE-Unendlichkeitsergebnis und löst bei Demaskierung die entsprechende Ausnahme aus.

Flaggen

Keiner betroffen.

Codierungsnotizen

  • Codiert mit dem F2-Präfix als F2 0F 5A /r.
  • Die oberen 96 Bits des Ziel-XMM-Registers bleiben unverändert (Intel/AMD SSE-Verhalten), was dies nützlich macht, wenn skalare Einzel- und Doppeloperationen gemischt werden.
  • Erfordert mindestens SSE2.

Beispiele

; Reduce precision of a double to single precision
movsd xmm0, qword ptr [double_val] ; xmm0 low = 3.141592653589793
cvtsd2ss xmm1, xmm0                ; xmm1 low = 3.1415927f

; Store the single result to memory
movss dword ptr [float_result], xmm1

; Combine with existing packed singles: upper bits of xmm2 stay intact
cvtsd2ss xmm2, xmm3                ; xmm2[31:0] converted, xmm2[127:32] preserved

When to use

Verwenden Sie CVTSD2SS, wenn ein Algorithmus einen Wert mit doppelter Genauigkeit erzeugt hat, die nachgeschaltete Logik (z. B. eine Grafik-API oder DSP-Routine) jedoch eine Eingabe mit einfacher Genauigkeit erwartet. Dies ist auch nützlich, wenn Sie ein doppeltes Ergebnis in einen 32-Bit-Speicher komprimieren möchten, ohne eine vollständige Konvertierung durchzuführen.

Siehe auch

  • CVTSS2SD
  • CVTSD2SI
  • MOVSS
  • MOVSD

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CVTSD2SS – Skalar Double in Skalar Single konvertieren ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CVTSD2SS – Skalar Double in Skalar Single konvertieren operand[, operand]

PBXB64-Verwendung

CVTSD2SS – Skalar Double in Skalar Single konvertieren ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CVTSD2SS – Skalar Double in Skalar Single konvertieren ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


cvtsi2sd – Vorzeichenbehaftete Ganzzahl in Skalar-Double umwandeln – PBXB64 Assembler-Hilfe

Startseite › Funktionen › cvtsi2sd – Vorzeichenbehaftete Ganzzahl in Skalar-Double umwandeln
Hilfe zum PBXB64-Compiler

CVTSI2SD – Vorzeichenbehaftete Ganzzahl in Skalar-Double umwandeln

Konvertiert ein vorzeichenbehaftetes Ganzzahl-Allzweckregister oder einen Speicheroperanden in einen Gleitkommawert mit doppelter Genauigkeit in den unteren 64 Bits des Ziel-XMM-Registers.

Kategorie: SSE/AVX | Gruppe: Gleitkommakonvertierung

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CVTSI2SD xmm, reg/mem

Operanden

Formular | Beschreibung | Beispiel
CVTSI2SD xmm, r32 | Konvertieren Sie eine vorzeichenbehaftete 32-Bit-Ganzzahl in GPR in eine doppelte Zahl in XMM | cvtsi2sd xmm0, eax
CVTSI2SD xmm, mem32 | Konvertieren Sie eine vorzeichenbehaftete 32-Bit-Ganzzahl im Speicher in eine doppelte Zahl in XMM | cvtsi2sd xmm0, dword ptr [count]
CVTSI2SD xmm, r64 | Konvertieren Sie eine vorzeichenbehaftete 64-Bit-Ganzzahl in GPR in eine doppelte Zahl in XMM | cvtsi2sd xmm0, rax
CVTSI2SD xmm, mem64 | Konvertieren Sie vorzeichenbehaftete 64-Bit-Ganzzahlen im Speicher in Double in XMM | cvtsi2sd xmm0, qword ptr [ticks]

Beschreibung

CVTSI2SD konvertiert einen vorzeichenbehafteten ganzzahligen Quelloperanden in einen Gleitkommawert mit doppelter Genauigkeit. Das Ergebnis wird in die unteren 64 Bits des Ziel-XMM-Registers geschrieben. Die Bits 127:64 des Ziel-XMM-Registers bleiben gegenüber ihrem vorherigen Wert erhalten, sodass skalare Doppeloperationen mit anderen Daten im oberen Teil des Registers koexistieren können.

Diese Anweisung unterstützt sowohl 32-Bit- als auch 64-Bit-Ganzzahlquellen. Die 64-Bit-Form erfordert ein REX.W-Präfix. Da IEEE 754 mit doppelter Genauigkeit alle 32-Bit-Ganzzahlen und die meisten 64-Bit-Ganzzahlen bis zu 2^53 genau darstellen kann, sind 32-Bit-Konvertierungen immer präzise, ​​während 64-Bit-Konvertierungen bei sehr großen Größen möglicherweise runden.

Flaggen

Keiner betroffen.

Codierungsnotizen

  • Codiert mit dem F2-Präfix als F2 0F 2A /r.
  • Für 64-Bit-Integer-Quellen muss das REX.W-Bit in der Befehlscodierung festgelegt werden.
  • Die oberen 64 Bit des Ziels bleiben erhalten und werden nicht auf Null gesetzt.

Beispiele

; Convert a 32-bit loop counter to double for division
mov eax, 100
cvtsi2sd xmm0, eax        ; xmm0 low = 100.0

; Convert a 64-bit timestamp to double
rdtsc
shl rdx, 32
or rax, rdx
cvtsi2sd xmm1, rax        ; xmm1 low = (double)ticks

; Convert a memory integer to double, preserving upper xmm2 data
cvtsi2sd xmm2, dword ptr [score]

When to use

Verwenden Sie CVTSI2SD immer dann, wenn ganzzahlige Daten an der Gleitkommaarithmetik beteiligt sein müssen, z. B. beim Normalisieren von Array-Indizes, beim Konvertieren von Pixelkoordinaten oder beim Vorbereiten ganzzahliger Sensormesswerte für statistische Formeln. Für eine Ausgabe mit einfacher Genauigkeit verwenden Sie stattdessen CVTSI2SS.

Siehe auch

  • CVTSD2SI
  • CVTTSD2SI
  • CVTSS2SD

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CVTSI2SD – Vorzeichenbehaftete Ganzzahl in Skalar-Double umwandeln ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CVTSI2SD – Vorzeichenbehaftete Ganzzahl in Skalar-Double umwandeln operand[, operand]

PBXB64-Verwendung

CVTSI2SD – Vorzeichenbehaftete Ganzzahl in Skalar-Double umwandeln ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CVTSI2SD – Vorzeichenbehaftete Ganzzahl in Skalar-Double umwandeln ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


cvtss2sd – Scalar Single in Scalar Double konvertieren – PBXB64 Assembler-Hilfe

Startseite › Funktionen › cvtss2sd – Skalar Single in Skalar Double konvertieren
Hilfe zum PBXB64-Compiler

CVTSS2SD – Konvertieren Sie Skalar Single in Skalar Double

Konvertiert den niedrigwertigen Gleitkommawert mit einfacher Genauigkeit in der Quelle in einen Gleitkommawert mit doppelter Genauigkeit in den unteren 64 Bits des Ziel-XMM-Registers.

Kategorie: SSE/AVX | Gruppe: Gleitkommakonvertierung

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CVTSS2SD xmm1, xmm2/mem32

Operanden

Formular | Beschreibung | Beispiel
CVTSS2SD xmm, xmm | Konvertieren Sie Low Single im Quell-XMM in Double im Ziel-XMM | cvtss2sd xmm0, xmm1
CVTSS2SD xmm, mem32 | Konvertieren Sie den Speicher im Ziel-XMM einfach in doppelt | cvtss2sd xmm0, dword ptr [val]

Beschreibung

CVTSS2SD konvertiert den skalaren Gleitkommawert mit einfacher Genauigkeit (32 Bit), der sich im niedrigen Doppelwort des Quelloperanden befindet, in einen Gleitkommawert mit doppelter Genauigkeit (64 Bit). Das konvertierte Ergebnis wird im unteren Quadword des Ziel-XMM-Registers gespeichert. Die Bits 127:64 des Ziel-XMM-Registers bleiben von ihrem vorherigen Wert erhalten. Die Konvertierung ist exakt, wenn der Einzelwert normalisiert wird, da jeder normale Wert mit einfacher Genauigkeit in doppelter Genauigkeit genau darstellbar ist.

Flaggen

Keiner betroffen.

Codierungsnotizen

  • Codiert mit dem F3-Präfix als F3 0F 5A /r.
  • Nur die unteren 32 Bit der Quelle werden als Gleitkommazahl mit einfacher Genauigkeit interpretiert.
  • Die oberen 64 Bits des Ziel-XMM-Registers bleiben unverändert.

Beispiele

; Promote a single-precision input to double before precise math
movss xmm0, dword ptr [input_f] ; xmm0 low = 1.5f
cvtss2sd xmm1, xmm0             ; xmm1 low = 1.5 (exact)

; Promote a memory float to double
cvtss2sd xmm2, dword ptr [sensor]
addsd xmm2, qword ptr [calibration]

; Upper bits of xmm3 are preserved
cvtss2sd xmm3, xmm4

When to use

Verwenden Sie CVTSS2SD, um einen Wert mit einfacher Genauigkeit auf die doppelte Genauigkeit zu erweitern, bevor Sie Berechnungen durchführen, die den zusätzlichen Bereich oder die zusätzliche Genauigkeit erfordern. Dies ist häufig der Fall, wenn 32-Bit-Float-Daten aus Dateien, GPUs oder SIMD-Puffer in skalare x87/SSE-Algorithmen mit doppelter Genauigkeit geladen werden.

Siehe auch

  • CVTSD2SS
  • CVTSI2SD
  • MOVSS
  • MOVSD

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CVTSS2SD – Konvertieren Sie Skalar Single in Skalar Double ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CVTSS2SD – Konvertieren Sie Skalar Single in Skalar Double operand[, operand]

PBXB64-Verwendung

CVTSS2SD – Konvertieren Sie Skalar Single in Skalar Double ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CVTSS2SD – Konvertieren Sie Skalar Single in Skalar Double ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← cvtsi2sd – Vorzeichenbehaftete Ganzzahl in Skalar-Double umwandeln Nach oben cvttsd2si – Konvertieren mit Truncation Scalar Double in Signed Integer →


cvttsd2si – Konvertieren mit Truncation Scalar Double in Signed Integer – PBXB64 Assembler-Hilfe

Startseite › Funktionen › cvttsd2si – Konvertieren mit Truncation Scalar Double in Signed Integer
Hilfe zum PBXB64-Compiler

CVTTSD2SI – Konvertieren mit Truncation Scalar Double in Signed Integer

Konvertiert den Gleitkommawert niedriger Ordnung mit doppelter Genauigkeit in einem XMM-Register oder -Speicher in eine vorzeichenbehaftete Ganzzahl unter Verwendung einer Kürzung in Richtung Null.

Kategorie: SSE/AVX | Gruppe: Gleitkommakonvertierung

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

CVTTSD2SI reg, xmm/mem64

Operanden

Formular | Beschreibung | Beispiel
CVTTSD2SI r32, xmm | Low Double in XMM auf vorzeichenbehaftete 32-Bit-Ganzzahl abschneiden | cvttsd2si eax, xmm0
CVTTSD2SI r32, mem64 | Speicherdoppelt auf vorzeichenbehaftete 32-Bit-Ganzzahl kürzen | cvttsd2si eax, qword ptr [x]
CVTTSD2SI r64, xmm | Low Double in XMM auf vorzeichenbehaftete 64-Bit-Ganzzahl abschneiden | cvttsd2si rax, xmm0
CVTTSD2SI r64, mem64 | Speicherdoppelt auf vorzeichenbehaftete 64-Bit-Ganzzahl kürzen | cvttsd2si rax, qword ptr [x]

Beschreibung

CVTTSD2SI ist die verkürzte Variante von CVTSD2SI. Es wandelt den skalaren Gleitkommawert mit doppelter Genauigkeit in den unteren 64 Bits des Quelloperanden in eine vorzeichenbehaftete Ganzzahl im Ziel-Allzweckregister um. Im Gegensatz zu CVTSD2SI rundet dieser Befehl unabhängig vom MXCSR-Rundungsmodus immer gegen Null. Dies macht es ideal für Umwandlungen im C-Stil von Gleitkomma zu Ganzzahlen.

Wenn der Quellwert außerhalb des darstellbaren Bereichs des Ziel-Integer-Typs liegt, ist das Ergebnis der unbestimmte Integer-Wert (MIN_INT) und es wird eine Ausnahme wegen ungültiger Operation ausgelöst, wenn er nicht maskiert wird.

Flaggen

Keiner betroffen.

Codierungsnotizen

  • Codiert mit dem F2-Präfix als F2 0F 2C /r.
  • Das 64-Bit-Zielformular erfordert das Präfix REX.W.
  • Kürzung bedeutet, dass Bruchteile verworfen werden: 3,9 wird zu 3 und -3,9 wird zu -3.

Beispiele

; C-style (int) cast of a double
cvttsd2si eax, xmm0           ; eax = (int)(double)x

; Array index from a scaled double
movsd xmm0, qword ptr [pos_x]
cvttsd2si ebx, xmm0           ; ebx = floor toward zero of pos_x
mov rcx, qword ptr [array]
mov eax, dword ptr [rcx + rbx*4]

; 64-bit truncation
cvttsd2si rax, qword ptr [timestamp]

When to use

Verwenden Sie CVTTSD2SI, wenn Sie das Äquivalent einer Ganzzahlumwandlung in C benötigen oder wenn die Array-Indizierung und ähnliche Vorgänge eine Kürzung in Richtung Null erfordern. Verwenden Sie stattdessen CVTSD2SI, wenn Sie den aktuellen Gleitkomma-Rundungsmodus berücksichtigen möchten.

Siehe auch

  • CVTSD2SI
  • CVTSI2SD
  • CVTSD2SS

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

CVTTSD2SI – Konvertieren mit Truncation Scalar Double in Signed Integer ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

CVTTSD2SI – Konvertieren mit Truncation Scalar Double in Signed Integer operand[, operand]

PBXB64-Verwendung

CVTTSD2SI – Konvertieren mit Truncation Scalar Double in Signed Integer ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! CVTTSD2SI – Konvertieren mit Truncation Scalar Double in Signed Integer ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


DEC – PBXB64 Assembler-Hilfe

Startseite › Funktionen › DEC – PBXB64 Assembler-Hilfe

DEC – Dekrementieren um 1

Subtrahiert 1 vom Operanden. Hat keinen Einfluss auf das Carry Flag (CF).

Kategorie: Arithmetik | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DEC reg
DEC mem

Beschreibung

Führt durch operand = operand - 1. Legt OF, SF, ZF, AF, PF fest, ändert jedoch NICHT CF. Benutzen SUB dst, 1 wenn Sie CF aktualisieren müssen.

Beispiele

dec rax
dec DWORD PTR [rbx]

Siehe auch

  • INC
  • SUB
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

DEC – Dekrementieren um 1 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

DEC – Dekrementieren um 1 operand[, operand]

PBXB64-Verwendung

DEC – Dekrementieren um 1 ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! DEC – Dekrementieren um 1 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

← cvttsd2si – Konvertieren mit Truncation Scalar Double in Signed Integer Nach oben DIV – PBXB64 Assembler-Hilfe →

Assembler-Prüfung

Prüfen Sie diese Instruktion mit einem minimalen Inline-Assembler-Programm, das jedes Eingaberegister oder jeden Speicheroperanden initialisiert, die Instruktion einmal ausführt und das beobachtete Ergebnis zurückgibt oder ausgibt. Bei flagabhängigen Instruktionen sollen Carry-, Zero-, Sign- und Overflow-Verhalten dokumentiert werden, soweit die Instruktion es definiert.

Operandenregeln

Verwenden Sie die dokumentierte Operandenbreite ausdrücklich. In x64-Code sollen 32-Bit- und 64-Bit-Formen nur gemischt werden, wenn die Zero-Extension beabsichtigt ist. Speicheroperanden sollen Basisregister und Displacement-Annahmen des Beispiels benennen.

Fehlerfälle

Assembler-Seiten sollen ungültige Operanden-Kombinationen, Division-Überlauf oder Division durch Null und relevante Register-Clobber nennen, bevor in von PBXB64 erzeugten Code zurückgekehrt wird.


DIV – PBXB64 Assembler-Hilfe

Startseite › Funktionen › DIV – PBXB64 Assembler-Hilfe

DIV – Unsigned Divide

Dividiert einen impliziten Dividenden doppelter Breite durch den Quelloperanden.

Kategorie: Arithmetik | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIV reg/mem

Beschreibung

Dividiert den impliziten Dividenden (AX/DX:AX/EDX:EAX/RDX:RAX) durch den Quelloperanden. Quotient in AL/AX/EAX/RAX, Rest in AH/DX/EDX/RDX.

Beispiele

div rbx                      ; RAX = RDX:RAX / RBX, RDX = remainder

Siehe auch

  • IDIV
  • MUL
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

DIV – Unsigned Divide ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

DIV – Unsigned Divide operand[, operand]

PBXB64-Verwendung

DIV – Unsigned Divide ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! DIV – Unsigned Divide ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

← DEC – PBXB64 Assembler-Hilfe Nach oben divps – Gepackte Gleitkommawerte mit einfacher Genauigkeit dividieren →

Assembler-Prüfung

Prüfen Sie diese Instruktion mit einem minimalen Inline-Assembler-Programm, das jedes Eingaberegister oder jeden Speicheroperanden initialisiert, die Instruktion einmal ausführt und das beobachtete Ergebnis zurückgibt oder ausgibt. Bei flagabhängigen Instruktionen sollen Carry-, Zero-, Sign- und Overflow-Verhalten dokumentiert werden, soweit die Instruktion es definiert.

Operandenregeln

Verwenden Sie die dokumentierte Operandenbreite ausdrücklich. In x64-Code sollen 32-Bit- und 64-Bit-Formen nur gemischt werden, wenn die Zero-Extension beabsichtigt ist. Speicheroperanden sollen Basisregister und Displacement-Annahmen des Beispiels benennen.

Fehlerfälle

Assembler-Seiten sollen ungültige Operanden-Kombinationen, Division-Überlauf oder Division durch Null und relevante Register-Clobber nennen, bevor in von PBXB64 erzeugten Code zurückgekehrt wird.


divps – Gepackte Gleitkommawerte mit einfacher Genauigkeit dividieren – PBXB64 Assembler-Hilfe

Startseite › Funktionen › divps – Gepackte Gleitkommawerte mit einfacher Genauigkeit dividieren
Hilfe zum PBXB64-Compiler

DIVPS – Dividieren gepackter Gleitkommawerte mit einfacher Genauigkeit

Dividiert vier Gleitkommawerte mit einfacher Genauigkeit im Ziel-XMM-Register durch die entsprechenden vier Werte im Quell-XMM-Register oder im 128-Bit-Speicheroperanden.

Kategorie: SSE/AVX | Gruppe: Gepackte Gleitkomma-Arithmetik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIVPS xmm1, xmm2/mem128

Operanden

Formular | Beschreibung | Beispiel
DIVPS xmm, xmm | Teilen Sie vier gepackte Singles im Ziel durch vier gepackte Singles im Quell-XMM | divps xmm0, xmm1
DIVPS xmm, mem128 | Teilen Sie vier gepackte Singles am Zielort durch vier gepackte Singles im Speicher | divps xmm0, xmmword ptr [vec]

Beschreibung

DIVPS führt eine SIMD-Division (Single Instruction, Multiple Data) auf vier Gleitkommaspuren mit einfacher Genauigkeit parallel durch. Für jede Spur i von 0 bis 3 wird berechnet DEST[i] = DEST[i] / SRC[i]. Die Operation folgt den IEEE 754-Regeln: Division durch Null ergibt je nach Zähler +/-unendlich oder NaN, und Denormal-Ergebnisse werden gemäß den MXCSR-Flags „Flush-to-Zero“ und „Denormals-are-Zero“ behandelt.

Dies ist eine gepackte Anweisung, was bedeutet, dass alle vier Spuren aktiv sind. Es unterscheidet sich von skalaren SSE-Teilungsanweisungen wie DIVSS, die nur die untere Spur ändern und die oberen Spuren des Ziels unverändert lassen. AVX-Formulare (VDIVPS) arbeiten mit 256-Bit-YMM-Registern mit acht Spuren.

Flaggen

Keiner direkt betroffen. MXCSR-Ausnahmeflags (ungültig, Division durch Null, denormal, Überlauf, Unterlauf, Genauigkeit) können aktualisiert werden.

Codierungsnotizen

  • Codiert als 0F 5E /r.
  • Erfordert SSE1-Unterstützung.
  • Der Quellspeicheroperand muss 16-Byte-ausgerichtet sein, wenn es sich um einen Speicheroperanden handelt. Eine Fehlausrichtung löst eine allgemeine Schutzausnahme aus, es sei denn, der Prozessor unterstützt nicht ausgerichteten SSE-Zugriff mit dem entsprechenden Feature-Bit.

Beispiele

; Divide two 4-component vectors component-wise
movaps xmm0, [vec_a]     ; xmm0 = {a0, a1, a2, a3}
movaps xmm1, [vec_b]     ; xmm1 = {b0, b1, b2, b3}
divps xmm0, xmm1         ; xmm0 = {a0/b0, a1/b1, a2/b2, a3/b3}

; Scale a color/RGBA vector by per-channel factors
movaps xmm2, [rgba]
divps xmm2, [scale]
movaps [rgba], xmm2

When to use

Verwenden Sie DIVPS für die vektorisierte Gleitkommadivision, z. B. zum Normalisieren von Vektoren, zum Skalieren von Farbkanälen oder zum gleichzeitigen Berechnen reziproker Verhältnisse über mehrere Datenelemente hinweg. Für die skalare Doppeldivision verwenden Sie DIVSD; Für eine skalare Einzeldivision verwenden Sie DIVSS. Wenn keine exakte IEEE-Semantik erforderlich ist, sollten Sie für einen besseren Durchsatz die Multiplikation mit einem vorberechneten Kehrwert in Betracht ziehen.

Siehe auch

  • DIVSS
  • DIVSD
  • MULPS
  • SUBPS

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

DIVPS – Dividieren gepackter Gleitkommawerte mit einfacher Genauigkeit ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

DIVPS – Dividieren gepackter Gleitkommawerte mit einfacher Genauigkeit operand[, operand]

PBXB64-Verwendung

DIVPS – Dividieren gepackter Gleitkommawerte mit einfacher Genauigkeit ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! DIVPS – Dividieren gepackter Gleitkommawerte mit einfacher Genauigkeit ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


divsd – Skalaren Gleitkommawert mit doppelter Genauigkeit dividieren – PBXB64 Assembler-Hilfe

Startseite › Funktionen › divsd – Skalarer Gleitkommawert mit doppelter Genauigkeit dividieren
Hilfe zum PBXB64-Compiler

DIVSD – Skalarer Gleitkommawert mit doppelter Genauigkeit dividieren

Dividiert den Gleitkommawert niedriger Ordnung mit doppelter Genauigkeit im Ziel-XMM-Register durch das entsprechende skalare Double im Quell-XMM-Register oder Speicheroperanden.

Kategorie: SSE/AVX | Gruppe: Skalare Gleitkomma-Arithmetik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIVSD xmm1, xmm2/mem64

Operanden

Formular | Beschreibung | Beispiel
DIVSD xmm, xmm | Teilen Sie das Skalardouble im Ziel durch das Skalardouble im Quell-XMM | divsd xmm0, xmm1
DIVSD xmm, mem64 | Teilen Sie das Skalardouble im Ziel durch das Double im Speicher | divsd xmm0, qword ptr [divisor]

Beschreibung

DIVSD führt eine skalare Gleitkommadivision mit doppelter Genauigkeit durch. Es berechnet DEST[63:0] = DEST[63:0] / SRC[63:0] und speichert das Ergebnis in den unteren 64 Bits des Ziel-XMM-Registers. Die Bits 127:64 des Ziels bleiben von ihrem vorherigen Inhalt erhalten. Dies ist der Standard-x64-Befehl für die Division mit doppelter Genauigkeit bei Verwendung von SSE-Registern.

Die Operation folgt der IEEE 754-Semantik mit doppelter Genauigkeit. Division durch Null ergibt eine entsprechend vorzeichenbehaftete Unendlichkeit oder NaN. Denormale Behandlung und Rundung werden von MXCSR gesteuert.

Flaggen

Keiner direkt betroffen. MXCSR-Ausnahmeflags können aktualisiert werden.

Codierungsnotizen

  • Codiert mit dem F2-Präfix als F2 0F 5E /r.
  • Erfordert SSE2-Unterstützung.
  • Es werden nur die unteren 64 Bits des Quelloperanden gelesen; Die High-Bits der XMM-Quelle werden ignoriert.
  • Speicheroperanden erfordern für DIVSD keine 16-Byte-Ausrichtung, da nur 8 Byte gelesen werden.

Beispiele

; Compute a / b in double precision
movsd xmm0, qword ptr [a]
divsd xmm0, qword ptr [b]   ; xmm0 = a / b

; Divide by a register value
movsd xmm0, qword ptr [total]
divsd xmm0, xmm1            ; xmm0 = total / xmm1

; Average two double values
movsd xmm0, qword ptr [x]
addsd xmm0, qword ptr [y]
divsd xmm0, qword ptr [two] ; xmm0 = (x + y) / 2.0

When to use

Verwenden Sie DIVSD für skalare Divisionen mit doppelter Genauigkeit in numerischen Algorithmen, physikalischen Berechnungen, Statistiken und überall dort, wo präzise 64-Bit-Gleitkommaverhältnisse erforderlich sind. Sie ist erheblich langsamer als die Multiplikation. Erwägen Sie daher bei leistungskritischen Pfaden die Vorabberechnung von Kehrwerten und die Verwendung von MULSD, wenn nicht die volle Präzision erforderlich ist.

Siehe auch

  • MULSD
  • HINZUFÜGEN
  • SUBSD
  • DIVSS
  • DIVPS

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

DIVSD – Skalarer Gleitkommawert mit doppelter Genauigkeit dividieren ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

DIVSD – Skalarer Gleitkommawert mit doppelter Genauigkeit dividieren operand[, operand]

PBXB64-Verwendung

DIVSD – Skalarer Gleitkommawert mit doppelter Genauigkeit dividieren ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! DIVSD – Skalarer Gleitkommawert mit doppelter Genauigkeit dividieren ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← divps – Dividieren Sie gepackte Gleitkommawerte mit einfacher Genauigkeit Nach oben divss – Skalaren Gleitkommawert mit einfacher Genauigkeit dividieren →


divss – Skalaren Gleitkommawert mit einfacher Genauigkeit dividieren – PBXB64 Assembler-Hilfe

Startseite › Funktionen › divss – Skalaren Gleitkommawert mit einfacher Genauigkeit dividieren
Hilfe zum PBXB64-Compiler

DIVSS – Skalarer Gleitkommawert mit einfacher Genauigkeit dividieren

Dividiert den niedrigwertigen Gleitkommawert mit einfacher Genauigkeit im Ziel-XMM-Register durch den entsprechenden Skalar-Einzelwert im Quell-XMM-Register oder Speicheroperanden.

Kategorie: SSE/AVX | Gruppe: Skalare Gleitkomma-Arithmetik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

DIVSS xmm1, xmm2/mem32

Operanden

Formular | Beschreibung | Beispiel
DIVSS xmm, xmm | Teilen Sie den Skalar-Single im Ziel durch den Skalar-Single im Quell-XMM | divss xmm0, xmm1
DIVSS xmm, mem32 | Teilen Sie den Skalar-Einzelwert im Ziel durch den Einzelwert im Speicher | divss xmm0, dword ptr [divisor]

Beschreibung

DIVSS führt eine skalare Gleitkommadivision mit einfacher Genauigkeit durch. Es berechnet DEST[31:0] = DEST[31:0] / SRC[31:0] und speichert das Ergebnis in den unteren 32 Bits des Ziel-XMM-Registers. Die Bits 127:32 des Ziels bleiben von ihrem vorherigen Inhalt erhalten. Dies ist der Standard-SSE-Befehl für die 32-Bit-Gleitkomma-Skalardivision.

Die Operation folgt der IEEE 754-Semantik mit einfacher Genauigkeit. Eine Division durch Null ergibt eine entsprechend vorzeichenbehaftete Unendlichkeit oder NaN. Rundungs- und Ausnahmeverhalten werden durch MXCSR geregelt.

Flaggen

Keiner direkt betroffen. MXCSR-Ausnahmeflags können aktualisiert werden.

Codierungsnotizen

  • Codiert mit dem F3-Präfix als F3 0F 5E /r.
  • Erfordert SSE1-Unterstützung.
  • Es werden nur die unteren 32 Bit der Quelle gelesen.
  • Speicheroperanden erfordern keine 16-Byte-Ausrichtung, da nur 4 Byte gelesen werden.

Beispiele

; Compute x / y as 32-bit floats
movss xmm0, dword ptr [x]
divss xmm0, dword ptr [y]   ; xmm0 low = x / y

; Normalize a single component
movss xmm1, dword ptr [length]
divss xmm0, xmm1            ; xmm0 = component / length

; Divide accumulated sum by count
movss xmm0, dword ptr [sum]
divss xmm0, dword ptr [n]   ; xmm0 = sum / n

When to use

Verwenden Sie DIVSS für die skalare Division mit einfacher Genauigkeit, was bei Grafik-Shadern üblich ist, die CPU-SIMD, Audio-DSP und Spielcode zugeordnet sind, wo eine 32-Bit-Float-Präzision ausreichend ist. Wie bei allen x86-Divisionsanweisungen weist es eine relativ hohe Latenz auf; Erwägen Sie bei engen Schleifen die einmalige Berechnung der Kehrwerte und die Verwendung von MULSS.

Siehe auch

  • MULSS
  • ADDSS
  • SUBSS
  • DIVSD
  • DIVPS

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

DIVSS – Skalarer Gleitkommawert mit einfacher Genauigkeit dividieren ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

DIVSS – Skalarer Gleitkommawert mit einfacher Genauigkeit dividieren operand[, operand]

PBXB64-Verwendung

DIVSS – Skalarer Gleitkommawert mit einfacher Genauigkeit dividieren ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! DIVSS – Skalarer Gleitkommawert mit einfacher Genauigkeit dividieren ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


INPUT / VERLASSEN – PBXB64 Assembler-Hilfe

Startseite › Funktionen › INPUT / VERLASSEN – PBXB64 Assembler-Hilfe
Hilfe zum PBXB64-Compiler

EINGEBEN/VERLASSEN – Stapelrahmenverwaltung

Erstellt und zerstört Stapelrahmen für Prozeduren.

Kategorie: Stapeloperationen | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ENTER imm16, imm8            ; push rbp, mov rbp, rsp, sub rsp, imm16
LEAVE                        ; mov rsp, rbp, pop rbp

Beschreibung

  • GEBEN SIE EIN: Erstellt einen Stapelrahmen. Schiebt RBP, setzt RBP = RSP und weist dann lokalen Speicherplatz zu, indem imm16 von RSP abgezogen wird. Der zweite Operand (imm8) gibt die Verschachtelungsebene für verschachtelte Prozeduren an (normalerweise 0).
  • VERLASSEN: Zerstört den Stapelrahmen. Stellt RSP aus RBP wieder her und entfernt dann RBP.

Beispiele

enter 32, 0                  ; allocate 32 bytes of local space
...
leave
ret
Notiz: Die meisten Compiler generieren push rbp; mov rbp, rsp; sub rsp, N manuell statt mit ENTER, da ENTER langsamer ist als die manuelle Sequenz auf modernen CPUs. LEAVE wird häufig verwendet.

Siehe auch

  • DRÜCKEN
  • POP
  • RET
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

EINGEBEN/VERLASSEN – Stapelrahmenverwaltung ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

EINGEBEN/VERLASSEN – Stapelrahmenverwaltung operand[, operand]

PBXB64-Verwendung

EINGEBEN/VERLASSEN – Stapelrahmenverwaltung ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! EINGEBEN/VERLASSEN – Stapelrahmenverwaltung ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


IDIV – PBXB64 Assembler-Hilfe

Startseite › Funktionen › IDIV – PBXB64 Assembler-Hilfe

IDIV – Signierte Divide

Dividiert einen vorzeichenbehafteten Dividenden mit doppelter Breite durch den Quelloperanden.

Kategorie: Arithmetik | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

IDIV reg/mem

Beschreibung

Unterzeichnete Teilung. Gleiche Registerverwendung wie DIV. Das Vorzeichen des Restes folgt dem Vorzeichen des Dividenden (schneidet gegen Null).

Beispiele

idiv rbx                     ; signed divide RDX:RAX by RBX

Siehe auch

  • DIV
  • IMUL
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

IDIV – Signierte Divide ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

IDIV – Signierte Divide operand[, operand]

PBXB64-Verwendung

IDIV – Signierte Divide ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! IDIV – Signierte Divide ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

← INPUT / VERLASSEN – PBXB64 Assembler-Hilfe Nach oben IMUL – PBXB64 Assembler-Hilfe →

Assembler-Prüfung

Prüfen Sie diese Instruktion mit einem minimalen Inline-Assembler-Programm, das jedes Eingaberegister oder jeden Speicheroperanden initialisiert, die Instruktion einmal ausführt und das beobachtete Ergebnis zurückgibt oder ausgibt. Bei flagabhängigen Instruktionen sollen Carry-, Zero-, Sign- und Overflow-Verhalten dokumentiert werden, soweit die Instruktion es definiert.

Operandenregeln

Verwenden Sie die dokumentierte Operandenbreite ausdrücklich. In x64-Code sollen 32-Bit- und 64-Bit-Formen nur gemischt werden, wenn die Zero-Extension beabsichtigt ist. Speicheroperanden sollen Basisregister und Displacement-Annahmen des Beispiels benennen.

Fehlerfälle

Assembler-Seiten sollen ungültige Operanden-Kombinationen, Division-Überlauf oder Division durch Null und relevante Register-Clobber nennen, bevor in von PBXB64 erzeugten Code zurückgekehrt wird.


IMUL – PBXB64 Assembler-Hilfe

Startseite › Funktionen › IMUL – PBXB64 Assembler-Hilfe

IMUL – Vorzeichenbehaftete Multiplikation

Multipliziert ganze Zahlen mit Vorzeichen. Hat drei Formen für Flexibilität.

Kategorie: Arithmetik | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

IMUL reg/mem                    ; single operand (implicit result)
IMUL reg, reg/mem               ; two operand
IMUL reg, reg/mem, imm          ; three operand

Beschreibung

  • Einzelner Operand: Wie MUL, jedoch signiert. Ergebnis in RDX:RAX.
  • Zwei Operanden: reg = reg * reg/mem. Das Ergebnis wird auf die Registrierungsgröße gekürzt.
  • Drei Operanden: reg = reg/mem * imm. Das Ergebnis wird auf die Registrierungsgröße gekürzt.

Beispiele

imul rbx                     ; RDX:RAX = RAX * RBX (signed)
imul rax, rbx                ; RAX = RAX * RBX
imul rax, rbx, 10            ; RAX = RBX * 10

Siehe auch

  • MUL
  • IDIV
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

IMUL – Vorzeichenbehaftete Multiplikation ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

IMUL – Vorzeichenbehaftete Multiplikation operand[, operand]

PBXB64-Verwendung

IMUL – Vorzeichenbehaftete Multiplikation ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! IMUL – Vorzeichenbehaftete Multiplikation ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


INC – PBXB64 Assembler-Hilfe

Startseite › Funktionen › INC – PBXB64 Assembler-Hilfe

INC – Erhöhung um 1

Addiert 1 zum Operanden. Hat keinen Einfluss auf das Carry Flag (CF).

Kategorie: Arithmetik | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

INC reg
INC mem

Beschreibung

Führt durch operand = operand + 1. Legt OF, SF, ZF, AF, PF fest, ändert jedoch NICHT CF. Benutzen ADD dst, 1 wenn Sie CF aktualisieren müssen.

Beispiele

inc rax
inc DWORD PTR [rbx]

Siehe auch

  • DEZ
  • HINZUFÜGEN
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

INC – Erhöhung um 1 ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

INC – Erhöhung um 1 operand[, operand]

PBXB64-Verwendung

INC – Erhöhung um 1 ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! INC – Erhöhung um 1 ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

← IMUL – PBXB64 Assembler-Hilfe Nach oben int3 – Aufruf zum Interrupt 3 (Haltepunkt) →

Assembler-Prüfung

Prüfen Sie diese Instruktion mit einem minimalen Inline-Assembler-Programm, das jedes Eingaberegister oder jeden Speicheroperanden initialisiert, die Instruktion einmal ausführt und das beobachtete Ergebnis zurückgibt oder ausgibt. Bei flagabhängigen Instruktionen sollen Carry-, Zero-, Sign- und Overflow-Verhalten dokumentiert werden, soweit die Instruktion es definiert.

Operandenregeln

Verwenden Sie die dokumentierte Operandenbreite ausdrücklich. In x64-Code sollen 32-Bit- und 64-Bit-Formen nur gemischt werden, wenn die Zero-Extension beabsichtigt ist. Speicheroperanden sollen Basisregister und Displacement-Annahmen des Beispiels benennen.

Fehlerfälle

Assembler-Seiten sollen ungültige Operanden-Kombinationen, Division-Überlauf oder Division durch Null und relevante Register-Clobber nennen, bevor in von PBXB64 erzeugten Code zurückgekehrt wird.


int3 – Aufruf zum Interrupt 3 (Haltepunkt) – PBXB64 Assembler-Hilfe

Startseite › Funktionen › int3 – Aufruf zum Interrupt 3 (Haltepunkt)
Hilfe zum PBXB64-Compiler

INT3 – Aufruf zur Unterbrechung 3 (Haltepunkt)

Erzeugt einen speziellen Ein-Byte-Haltepunkt-Trap, der die Steuerung an den Debugger überträgt.

Kategorie: System/Atom | Gruppe: Debug/Spezial

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

INT3

Operanden

Formular | Beschreibung | Beispiel
INT3 | Ein-Byte-Breakpoint-Interrupt | int3

Beschreibung

INT3 generiert eine Breakpoint-Ausnahme (#BP, Vektor 3). Es ist als einzelnes Byte kodiert (0xCC) und ist die Standardmethode, mit der Software-Debugger Haltepunkte in ausführbaren Code einfügen. Wenn der Prozessor INT3 ausführt und Debug-Ausnahmen aktiviert sind, wird die Steuerung an den Debug-Ausnahmehandler des Betriebssystems übertragen, der das Ereignis normalerweise an den angeschlossenen Debugger weitergibt.

Im Gegensatz zum Zwei-Byte INT imm8 Formular (CD 03), verfügt INT3 über eine dedizierte Ein-Byte-Kodierung, die es Debuggern erleichtert, jede vorhandene Anweisung zu patchen. Es kann auch explizit in Assembler-Code geschrieben werden, um hartcodierte Trap-Punkte zu erstellen.

Flaggen

Vor der Ausnahme war keiner betroffen; EFLAGS wird als Teil des Ausnahmerahmens auf dem Stapel gespeichert.

Codierungsnotizen

  • Als einzelnes Byte kodiert CC.
  • Die Zwei-Byte-Form CD 03 ist architektonisch äquivalent zum Generieren von Interrupt 3, aber INT3 (CC) wird für Haltepunkte bevorzugt.
  • Im x64-Long-Modus ist das Verhalten identisch mit dem alten x86-Modus, mit der Ausnahme, dass der gespeicherte Befehlszeiger auf das Byte nach INT3 zeigt.

Beispiele

; Hard-coded breakpoint before a critical check
mov rax, qword ptr [handle]
test rax, rax
int3                    ; break here if debugger attached
jz error_no_handle

; Debugger-inserted patch: original first byte of an instruction
; is replaced with 0xCC, causing execution to trap at that location.

When to use

Verwenden Sie INT3 zum Debuggen: entweder durch manuelles Einfügen in den Quellcode, damit ein Debugger an dieser Stelle stoppt, oder als Byte, das ein Debugger schreibt, wenn Sie einen Software-Haltepunkt festlegen. Belassen Sie keine INT3-Anweisungen in Release-Builds, es sei denn, Sie beabsichtigen, eine Ausnahme auszulösen, da ein nicht behandelter Haltepunkt das Programm zum Absturz bringt, wenn kein Debugger vorhanden ist.

Siehe auch

  • UD2
  • NEIN
  • PAUSE

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

INT3 – Aufruf zur Unterbrechung 3 (Haltepunkt) ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

INT3 – Aufruf zur Unterbrechung 3 (Haltepunkt) operand[, operand]

PBXB64-Verwendung

INT3 – Aufruf zur Unterbrechung 3 (Haltepunkt) ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! INT3 – Aufruf zur Unterbrechung 3 (Haltepunkt) ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Jcc – PBXB64 Assembler-Hilfe

Startseite › Funktionen › Jcc – PBXB64 Assembler-Hilfe

Jcc – Bedingter Sprung

Überträgt die Kontrolle an ein Label, wenn die Bedingung erfüllt ist.

Kategorie: Kontrollübertragung | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

Jcc label

Beschreibung

Überprüft die Bedingungsflags und springt zur Zielbezeichnung, wenn die Bedingung wahr ist. Bei „false“ wird die Ausführung mit der nächsten Anweisung fortgesetzt.

Konditionsvarianten

Gedächtnisstütze | Zustand | Flaggen
JE / JZ | Gleich / Null | ZF=1
JNE / JNZ | Ungleich / Nicht Null | ZF=0
JA / JNBE | Oben | CF=0 und ZF=0
JAE / JNB | Oben oder gleich | CF=0
JB / JNAE | Unten | CF=1
JBE / JNA | Unten oder gleich | CF=1 oder ZF=1
JG / JNLE | Größer (signiert) | ZF=0 und SF=OF
JGE / JNL | Größer oder gleich (mit Vorzeichen) | SF=OF
JL / JNGE | Weniger (signiert) | SF!=OF
JLE / JNG | Kleiner oder gleich (mit Vorzeichen) | ZF=1 oder SF!=OF
JO / JNO | Überlauf / Nicht Überlauf | OF=1 / OF=0
JS / JNS | Unterschreiben / Nicht unterschreiben | SF=1 / SF=0
JP / JNP | Parität gerade / Parität ungerade | PF=1 / PF=0

Beispiele

cmp rax, rbx
je equal
jg greater
jl less

test rax, rax
jz zero

Siehe auch

  • JMP
  • CMP
  • TEST
  • CMOVcc
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

Jcc – Bedingter Sprung ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

Jcc – Bedingter Sprung operand[, operand]

PBXB64-Verwendung

Jcc – Bedingter Sprung ist eine control-transfer Instruktion fuer control flow. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! Jcc – Bedingter Sprung ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


JMP – PBXB64 Assembler-Hilfe

Startseite › Funktionen › JMP – PBXB64 Assembler-Hilfe

JMP – Bedingungsloser Sprung

Überträgt die Ausführung bedingungslos an einen neuen Ort.

Kategorie: Kontrollübertragung | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

JMP label
JMP reg
JMP [mem]

Beschreibung

Überträgt die Kontrolle an das Ziel. Das Ziel kann ein Label, ein Register (indirekter Sprung) oder ein Speicherort (indirekter Sprung) sein. Gibt keine Absenderadresse weiter.

Beispiele

jmp target
...
target:
    nop

jmp rax                    ; indirect jump
jmp [rbx]                  ; memory indirect

Siehe auch

  • CALL
  • RET
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

JMP – Bedingungsloser Sprung ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

JMP – Bedingungsloser Sprung operand[, operand]

PBXB64-Verwendung

JMP – Bedingungsloser Sprung ist eine control-transfer Instruktion fuer control flow. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! JMP – Bedingungsloser Sprung ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LEA – PBXB64 Assembler-Hilfe

Startseite › Funktionen › LEA – PBXB64 Assembler-Hilfe

LEA – Effektive Adresse laden

Berechnet die effektive Adresse eines Speicheroperanden und speichert sie in einem Register.

Kategorie: Datenbewegung | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

LEA reg, [mem]

Beschreibung

Berechnet die Adresse des Speicheroperanden (ohne auf den Speicher zuzugreifen) und speichert sie im Zielregister. Wird häufig für Zeigerarithmetik und schnelle Ganzzahlberechnung verwendet (z. B. lea rax, [rbx+rbx*4] berechnet rax = rbx * 5).

Beispiele

lea rax, [rbx+8]           ; rax = rbx + 8
lea rax, [rbx+rcx*4]       ; rax = rbx + rcx*4
lea rax, [rip+label]       ; RIP-relative addressing

Siehe auch

  • MOV
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

LEA – Effektive Adresse laden ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

LEA – Effektive Adresse laden operand[, operand]

PBXB64-Verwendung

LEA – Effektive Adresse laden ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! LEA – Effektive Adresse laden ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


verlassen – High-Level-Prozedur-Exit – PBXB64 Assembler-Hilfe

Startseite › Funktionen › verlassen – High-Level-Prozedur-Exit
Hilfe zum PBXB64-Compiler

LEAVE – High-Level-Prozedur-Exit

Gibt den Stapelrahmen frei, der durch eine vorangehende ENTER-Anweisung oder einen manuellen Prologcode eingerichtet wurde.

Kategorie: Stapel | Gruppe: Stack-Frame-Management

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

LEAVE

Operanden

Formular | Beschreibung | Beispiel
VERLASSEN | Stapelrahmen wiederherstellen und lokalen Speicher freigeben | leave

Beschreibung

LEAVE ist die standardmäßige x86/x64-Anweisung zum Abbau eines Stapelrahmens. Es führt nacheinander zwei Vorgänge aus:

  1. RSP := RBP – Stellen Sie den Stapelzeiger auf den im Rahmenzeiger gespeicherten Wert wieder her, wodurch alle lokalen Variablen und übergelaufenen Werte, die unterhalb des RBP zugewiesen sind, effektiv verworfen werden.
  2. RBP := POP() – Ziehen Sie den vorherigen Frame-Zeiger vom Stapel in RBP.

Dies ist genau das Gegenteil der üblichen Prologsequenz push rbp; mov rbp, rsp; sub rsp, N. Nach der Ausführung von LEAVE befindet sich der Stapel im gleichen Zustand wie vor dem Prolog, und ein nachfolgender RET-Befehl gibt die Kontrolle an den Aufrufer zurück.

Flaggen

Keiner betroffen.

Codierungsnotizen

  • Als einzelnes Byte kodiert C9.
  • Äquivalent zu mov rsp, rbp gefolgt von pop rbp.
  • Im x64-Code verwendet LEAVE die vollständigen 64-Bit-RSP/RBP-Register. Es hängt nicht vom Standardattribut für die Operandengröße ab, da RBP/RSP im 64-Bit-Modus immer 64-Bit sind.

Beispiele

; Standard function epilogue
my_function:
    push rbp
    mov rbp, rsp
    sub rsp, 32          ; allocate shadow space / locals
    ; ... function body ...
    leave                ; mov rsp, rbp ; pop rbp
    ret

; Manual equivalent (if LEAVE is unavailable)
mov rsp, rbp
pop rbp
ret

When to use

Verwenden Sie LEAVE am Ende jeder Funktion, mit der ein Frame-Zeiger erstellt wird push rbp; mov rbp, rsp. Es erzeugt kompakte, lesbare Epiloge und wird von Unwind-Info-Generatoren erkannt. Moderne optimierende Compiler lassen den Frame-Zeiger häufig vollständig weg (unter Verwendung von RBP als allgemeines Register) und verwenden stattdessenadd rsp, Ngefolgt von Pops von gespeicherten Registern, aber für handgeschriebene Assemblys oder debugging-freundliche Builds bleibt LEAVE üblich.

Siehe auch

  • EINGEBEN
  • DRÜCKEN
  • POP
  • RET
  • CALL

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

LEAVE – High-Level-Prozedur-Exit ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

LEAVE – High-Level-Prozedur-Exit operand[, operand]

PBXB64-Verwendung

LEAVE – High-Level-Prozedur-Exit ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! LEAVE – High-Level-Prozedur-Exit ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LFENCE – Lastzaun – PBXB64 Assembler-Hilfe

Startseite › Funktionen › LFENCE – Lastzaun

LFENCE – Lastzaun

LFENCE ist eine Speicherordnungsanweisung, die alle Ladevorgänge serialisiert, die vor dem Fencing ausgegeben wurden.

Kategorie: Erinnerungszaun | Gruppe: SSE2/Speicherbestellung

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

LFENCE

Operanden

Formular Beschreibung Beispiel
LFENCE Keine Operanden; Alle vorherigen Ladevorgänge werden global sichtbar, bevor nachfolgende Ladevorgänge ausgeführt werden.
lfence

Beschreibung

DerLFENCE Die Anweisung serialisiert keine Speicher, sondern lädt nur. Es wird typischerweise als leichte Barriere verwendet, um eine spekulative Neuordnung der Ladung über den Zaunpunkt hinweg zu verhindern. Auf modernen x64-CPUs LFENCE wird üblicherweise mit Opcode ausgegeben 0F AE /5. Es verändert keine Register, Bedingungscodes oder Speicherinhalte.

VerwendenLFENCE wenn Sie zwischen Ladevorgängen eine Reihenfolge benötigen, aber keine vollständige Store-Load-Serialisierung benötigen (die von bereitgestellt wird). MFENCE).

Flaggen

Alle Arithmetik- und Statusflags bleiben davon unberührt.

Codierungsnotizen

  • Opcode: 0F AE /5 (modr/m Byte mit Reg/Opcode-Feld = 101).
  • Kein Speicheroperand; Die Anleitung ist ein eigenständiger Zaun.
  • Innerhalb von PBXB64 gibt der Encoder die 3-Byte-Sequenz aus 0F AE E8 (modr/m = E8).

Beispiele

; Ensure a flag read cannot be reordered before the flag write is observed
mov     rax, [flag]
test    rax, rax
jz      .wait
lfence
mov     rbx, [payload]     ; payload load must occur after flag is observed

When to use

VerwendenLFENCE um eine Nur-Lade-Speicherbarriere in sperrfreien Algorithmen, beim Abfragen von Ereignisschleifen-Flags oder beim Koppeln mit zu erstellen SFENCE für Bestellungen im Laden ohne die höheren Kosten von MFENCE.

Siehe auch

  • MFENCE
  • SFENCE
  • SPERREN

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

LFENCE – Lastzaun ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

LFENCE – Lastzaun operand[, operand]

PBXB64-Verwendung

LFENCE – Lastzaun ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! LFENCE – Lastzaun ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


LOCK – PBXB64 Assembler-Hilfe

Startseite › Funktionen › LOCK – PBXB64 Assembler-Hilfe

LOCK – Präfix sperren

Macht bestimmte Anweisungen auf Multiprozessorsystemen atomar.

Kategorie: Atomar | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

LOCK instruction

Beschreibung

Präfix, das das LOCK#-Signal (oder eine entsprechende Bussperre) für die Dauer des Befehls aktiviert. Stellt sicher, dass der Lese-, Änderungs- und Schreibzyklus für alle CPUs atomar ist.

Unterstützte Anweisungen

lock add / lock adc / lock sub / lock sbb / lock and / lock or / lock xor
lock inc / lock dec / lock neg / lock not
lock xadd / lock cmpxchg / lock cmpxchg8b / lock cmpxchg16b
lock bts / lock btr / lock btc

Beispiele

lock inc DWORD PTR [counter]
lock cmpxchg [rbx], rcx

Siehe auch

  • CMPXCHG
  • XADD
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

LOCK – Präfix sperren ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

LOCK – Präfix sperren operand[, operand]

PBXB64-Verwendung

LOCK – Präfix sperren ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! LOCK – Präfix sperren ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MAXSD – Maximum Scalar Double-Precision Floating-Point – PBXB64 Assembler-Hilfe

Startseite › Funktionen › MAXSD – Maximaler skalarer Gleitkommawert mit doppelter Genauigkeit
Hilfe zum PBXB64-Compiler

MAXSD – Maximaler skalarer Gleitkommawert mit doppelter Genauigkeit

MAXSD gibt den größeren von zwei skalaren Gleitkommawerten mit doppelter Genauigkeit (64-Bit) zurück.

Kategorie: SSE/AVX | Gruppe: SSE2 Skalarer Gleitkommawert

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MAXSD xmm1, xmm2/m64

Operanden

Formular Beschreibung Beispiel
MAXSD xmm1, xmm2 Vergleichen Sie den Wert mit niedriger doppelter Genauigkeit in xmm1 mit niedrigem Wert in xmm2; Speichern Sie das Maximum im unteren Quadword von xmm1.
maxsd xmm0, xmm1
MAXSD xmm1, m64 Vergleichen Sie den Wert mit niedriger doppelter Genauigkeit in xmm1 mit 64-Bit-Speicherwert; Speichern Sie das Maximum im unteren Quadword von xmm1.
maxsd xmm0, qword [rbx]

Beschreibung

MAXSD Arbeitet auf den unteren 64 Bits des Ziels xmm Register und eine 64-Bit-Quelle (entweder eine andere xmm Register oder Speicherort). Die oberen Bits des Quelloperanden werden ignoriert. Die oberen 64 Bits (Bits 64–127) des Ziels xmm Register bleiben erhalten. Wenn einer der Operanden NaN ist, hängt das Ergebnis von den durch die SSE-Semantik definierten Ruhe-/Signalisierungs-NaN-Verarbeitungsregeln ab.

Flaggen

EFLAGS bleiben hiervon unberührt MAXSD.

Codierungsnotizen

  • Erfordert SSE2.
  • Opcode: F2 0F 5F /r für die Register-/Memory-Formulare.
  • DerF2 Präfix wählt Skalaroperation mit doppelter Genauigkeit aus.
  • Am Vergleich nimmt nur das Low-Quadword (Bits 0–63) teil; Die Bits 64–127 des Ziels bleiben unverändert.

Beispiele

; Clamp a double in xmm0 to a minimum of 0.0
movsd   xmm1, [zero]
maxsd   xmm0, xmm1          ; xmm0 = max(xmm0, 0.0)

; Find the larger of two doubles stored in memory
movsd   xmm0, [val_a]
maxsd   xmm0, [val_b]       ; xmm0 low = larger of val_a, val_b

When to use

VerwendenMAXSD für skalare Klemmung mit doppelter Genauigkeit, verzweigungslose Max-Operationen oder Normalisierungscode, bei dem Sie den größeren von zwei 64-Bit-Gleitkommawerten benötigen, ohne den Kontrollfluss zu ändern.

Siehe auch

  • MINSD
  • MAXSS
  • HINZUFÜGEN
  • SUBSD

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MAXSD – Maximaler skalarer Gleitkommawert mit doppelter Genauigkeit ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MAXSD – Maximaler skalarer Gleitkommawert mit doppelter Genauigkeit operand[, operand]

PBXB64-Verwendung

MAXSD – Maximaler skalarer Gleitkommawert mit doppelter Genauigkeit ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MAXSD – Maximaler skalarer Gleitkommawert mit doppelter Genauigkeit ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MAXSS – Maximum Scalar Single-Precision Floating-Point – PBXB64 Assembler-Hilfe

Startseite› Funktionen › MAXSS – Maximum Scalar Single-Precision Floating-Point
Hilfe zum PBXB64-Compiler

MAXSS – Maximaler skalarer Gleitkommawert mit einfacher Genauigkeit

MAXSS gibt den größeren von zwei skalaren Gleitkommawerten mit einfacher Genauigkeit (32 Bit) zurück.

Kategorie: SSE/AVX | Gruppe: SSE Skalarer Gleitkommawert

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MAXSS xmm1, xmm2/m32

Operanden

Formular Beschreibung Beispiel
MAXSS xmm1, xmm2 Vergleichen Sie den Wert mit niedriger einfacher Genauigkeit in xmm1 mit niedrigem Wert in xmm2; Speichern Sie das Maximum im niedrigen Dword von xmm1.
maxss xmm0, xmm1
MAXSS xmm1, m32 Vergleichen Sie den Wert mit niedriger einfacher Genauigkeit in xmm1 mit 32-Bit-Speicherwert; Speichern Sie das Maximum im niedrigen Dword von xmm1.
maxss xmm0, dword [rbx]

Beschreibung

MAXSS vergleicht die unteren 32 Bits des Ziels xmm Register mit einer 32-Bit-Gleitkommaquelle. Die Bits 32–127 des Ziels bleiben erhalten. Die Quelle kann eine andere sein xmm Register oder einen Speicherort. Die NaN-Ausbreitung folgt den Standard-SSE-Skalarregeln.

Flaggen

EFLAGS bleiben hiervon unberührt MAXSS.

Codierungsnotizen

  • Erfordert SSE.
  • Opcode: F3 0F 5F /r.
  • DerF3 Präfix wählt Skalaroperation mit einfacher Genauigkeit aus.
  • Nur das niedrige Dword (Bits 0–31) ist beteiligt; Die Bits 32–127 des Ziels bleiben erhalten.

Beispiele

; Clamp a float to a lower bound
movss   xmm1, [lower_bound]
maxss   xmm0, xmm1          ; xmm0 = max(xmm0, lower_bound)

; Select larger of two floats in memory
movss   xmm0, [a]
maxss   xmm0, [b]           ; xmm0 low = max(a, b)

When to use

VerwendenMAXSS für Skalar-Float-Spannung, schnell verzweigungslos maxoder Grafik-/Audiocode, der mit 32-Bit-Gleitkomma-Samples arbeitet.

Siehe auch

  • MINSS
  • MAXSD
  • ADDSS

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MAXSS – Maximaler skalarer Gleitkommawert mit einfacher Genauigkeit ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MAXSS – Maximaler skalarer Gleitkommawert mit einfacher Genauigkeit operand[, operand]

PBXB64-Verwendung

MAXSS – Maximaler skalarer Gleitkommawert mit einfacher Genauigkeit ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MAXSS – Maximaler skalarer Gleitkommawert mit einfacher Genauigkeit ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MFENCE – Memory Fence – PBXB64 Assembler-Hilfe

Startseite › Funktionen › MFENCE – Memory Fence

MFENCE – Erinnerungszaun

MFENCE führt einen vollständigen Speicher-Ordering-Fence durch und serialisiert alle Lade- und Speichervorgänge, die vor dem Fence ausgegeben wurden, relativ zu denen, die danach ausgegeben wurden.

Kategorie: Erinnerungszaun | Gruppe: SSE2/Speicherbestellung

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MFENCE

Operanden

Formular Beschreibung Beispiel
MFENCE Keine Operanden; Alle vorangegangenen Speicherzugriffe sind vor allen nachfolgenden Speicherzugriffen global sichtbar.
mfence

Beschreibung

MFENCE stellt sicher, dass alle Speicherladevorgänge und -speicherungen vor dem Zaun global sichtbar sind, bevor alle Ladevorgänge oder Speichervorgänge nach dem Zaun ausgeführt werden. Es ist stärker als LFENCE (nur Laden) und SFENCE (nur im Geschäft). Diese Anweisung wird häufig in sperrenfreien Datenstrukturen, Producer-Consumer-Warteschlangen und speicherabgebildeter E/A-Synchronisation verwendet.

Flaggen

Alle Arithmetik- und Statusflags bleiben davon unberührt.

Codierungsnotizen

  • Opcode: 0F AE /6 (modr/m Byte mit Reg/Opcode-Feld = 110).
  • Kein Speicheroperand; Anleitung für einen eigenständigen Zaun.
  • PBXB64 gibt die 3-Byte-Sequenz aus 0F AE F0 (modr/m = F0).

Beispiele

; Publish a message to a lock-free queue
mov     [msg_payload], rax
mov     [msg_ready], 1
mfence                      ; ensure payload is written before ready flag

When to use

VerwendenMFENCE Wenn Sie eine vollständige Speicherbarriere benötigen: Die Reihenfolge „Speichern-Speichern“, „Laden-Laden“, „Laden-Speichern“ und „Speichern-Laden“ wird erzwungen. Bevorzugen LFENCEoderSFENCE wenn Sie nur die Bestellung laden oder speichern möchten.

Siehe auch

  • LFENCE
  • SFENCE
  • SPERREN

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MFENCE – Erinnerungszaun ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MFENCE – Erinnerungszaun operand[, operand]

PBXB64-Verwendung

MFENCE – Erinnerungszaun ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MFENCE – Erinnerungszaun ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MINSD – Minimum Scalar Double-Precision Floating-Point – PBXB64 Assembler-Hilfe

Startseite › Funktionen › MINSD – Minimaler skalarer Gleitkommawert mit doppelter Genauigkeit
Hilfe zum PBXB64-Compiler

MINSD – Minimaler skalarer Gleitkommawert mit doppelter Genauigkeit

MINSD gibt den kleineren von zwei skalaren Gleitkommawerten mit doppelter Genauigkeit (64-Bit) zurück.

Kategorie: SSE/AVX | Gruppe: SSE2 Skalarer Gleitkommawert

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MINSD xmm1, xmm2/m64

Operanden

Formular Beschreibung Beispiel
MINSD xmm1, xmm2 Vergleichen Sie den Wert mit niedriger doppelter Genauigkeit in xmm1 mit niedrigem Wert in xmm2; Speichern Sie das Minimum im unteren Quadword von xmm1.
minsd xmm0, xmm1
MINSD xmm1, m64 Vergleichen Sie den Wert mit niedriger doppelter Genauigkeit in xmm1 mit 64-Bit-Speicherwert; Speichern Sie das Minimum im unteren Quadword von xmm1.
minsd xmm0, qword [rbx]

Beschreibung

MINSD vergleicht die unteren 64 Bits des Ziels xmm Registrieren Sie sich gegen eine 64-Bit-Gleitkommaquelle. Der kleinere Wert wird in das untere Quadword des Ziels geschrieben; Die Bits 64–127 des Ziels bleiben erhalten. Wenn einer der Operanden NaN ist, folgt das Ergebnis den SSE-Ruhe-/Signalisierungs-NaN-Regeln.

Flaggen

EFLAGS bleiben hiervon unberührt MINSD.

Codierungsnotizen

  • Erfordert SSE2.
  • Opcode: F2 0F 5D /r.
  • DerF2 Präfix wählt Skalaroperation mit doppelter Genauigkeit aus.
  • Nur das niedrige Quadword (Bits 0–63) ist beteiligt; Die Bits 64–127 des Ziels bleiben erhalten.

Beispiele

; Clamp a double to an upper bound
movsd   xmm1, [upper_bound]
minsd   xmm0, xmm1          ; xmm0 = min(xmm0, upper_bound)

; Choose smaller of two doubles
movsd   xmm0, [x]
minsd   xmm0, [y]           ; xmm0 low = min(x, y)

When to use

VerwendenMINSD für skalare Klemmung mit doppelter Genauigkeit, verzweigungslose Minimalauswahl oder jeden Algorithmus, der den kleineren von zwei 64-Bit-Floats erfordert.

Siehe auch

  • MAXSD
  • MINSS
  • HINZUFÜGEN

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MINSD – Minimaler skalarer Gleitkommawert mit doppelter Genauigkeit ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MINSD – Minimaler skalarer Gleitkommawert mit doppelter Genauigkeit operand[, operand]

PBXB64-Verwendung

MINSD – Minimaler skalarer Gleitkommawert mit doppelter Genauigkeit ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MINSD – Minimaler skalarer Gleitkommawert mit doppelter Genauigkeit ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MINSS – Minimum Scalar Single-Precision Floating-Point – PBXB64 Assembler-Hilfe

Startseite › Funktionen › MINSS – Minimaler skalarer Gleitkommawert mit einfacher Genauigkeit
Hilfe zum PBXB64-Compiler

MINSS – Minimaler skalarer Gleitkommawert mit einfacher Genauigkeit

MINSS gibt den kleineren von zwei skalaren Gleitkommawerten mit einfacher Genauigkeit (32 Bit) zurück.

Kategorie: SSE/AVX | Gruppe: SSE Skalarer Gleitkommawert

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MINSS xmm1, xmm2/m32

Operanden

Formular Beschreibung Beispiel
MINSS xmm1, xmm2 Vergleichen Sie den Wert mit niedriger einfacher Genauigkeit in xmm1 mit niedrigem Wert in xmm2; Speichern Sie das Minimum im unteren Dword von xmm1.
minss xmm0, xmm1
MINSS xmm1, m32 Vergleichen Sie den Wert mit niedriger einfacher Genauigkeit in xmm1 mit 32-Bit-Speicherwert; Speichern Sie das Minimum im unteren Dword von xmm1.
minss xmm0, dword [rbx]

Beschreibung

MINSS vergleicht die unteren 32 Bits des Ziels xmm Register mit einer 32-Bit-Gleitkommaquelle. Der kleinere Wert wird in das niedrige Dword des Ziels geschrieben; Die Bits 32–127 des Ziels bleiben erhalten. Das NaN-Verhalten folgt den SSE-Skalarregeln.

Flaggen

EFLAGS bleiben hiervon unberührt MINSS.

Codierungsnotizen

  • Erfordert SSE.
  • Opcode: F3 0F 5D /r.
  • DerF3 Präfix wählt Skalaroperation mit einfacher Genauigkeit aus.
  • Nur das niedrige Dword (Bits 0–31) ist beteiligt; Die Bits 32–127 des Ziels bleiben erhalten.

Beispiele

; Clamp a float to an upper bound
movss   xmm1, [upper]
minss   xmm0, xmm1          ; xmm0 = min(xmm0, upper)

; Find smaller of two floats
movss   xmm0, [u]
minss   xmm0, [v]           ; xmm0 low = min(u, v)

When to use

VerwendenMINSS für skalare Float-Klammerung, verzweigte Minimalauswahl oder Signalverarbeitungscode, der mit 32-Bit-Gleitkommawerten arbeitet.

Siehe auch

  • MAXSS
  • MINSD
  • ADDSS

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MINSS – Minimaler skalarer Gleitkommawert mit einfacher Genauigkeit ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MINSS – Minimaler skalarer Gleitkommawert mit einfacher Genauigkeit operand[, operand]

PBXB64-Verwendung

MINSS – Minimaler skalarer Gleitkommawert mit einfacher Genauigkeit ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MINSS – Minimaler skalarer Gleitkommawert mit einfacher Genauigkeit ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOV – PBXB64 Assembler-Hilfe

Startseite › Funktionen › MOV – PBXB64 Assembler-Hilfe

MOV – Daten verschieben

Kopiert Daten von der Quelle zum Ziel. Die am häufigsten verwendete x86-64-Anweisung.

Kategorie: Datenbewegung | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MOV dst, src

Operanden

Formular | Beschreibung | Beispiel
reg, reg | Registrieren Sie sich, um sich zu registrieren | mov rax, rbx
reg, mem | Speicher zum Registrieren | mov rax, [rbx]
mem, reg | Im Speicher registrieren | mov [rbx], rax
reg, imm | Sofortige Anmeldung | mov rax, 42
mem, imm | Unmittelbar im Gedächtnis | mov DWORD PTR [rbx], 42

Beschreibung

Kopiert den Quelloperanden in den Zieloperanden. Die Quelle wird nicht geändert. Das Ziel kann ein Register oder ein Speicherort sein. Die Quelle kann ein Register, ein Speicherort oder ein unmittelbarer Wert sein.

Codierungsnotizen

  • 64-Bit-Sofortnachrichten werden codiert als MOVABS (REX.W + B8+rd io) für Register.
  • Vorzeichenerweiterte 32-Bit-Sofortdaten zu 64-Bit-Registern verwenden den Standard mov reg64, imm32 Kodierung.
  • Speicheroperanden verwenden ModRM + SIB + Displacement-Codierung.

Beispiele

mov rax, 0x1234             ; immediate to register
mov rbx, [rbp-8]             ; load from stack
mov [rbp-16], rcx            ; store to stack
mov edx, eax                 ; 32-bit move (zero-extends to 64-bit implicitly)
mov al, [rsi]                ; 8-bit load

Siehe auch

  • Kern-GPR-Mnemonik
  • SSE-Mnemonik
  • Assembler-Referenz

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOV – Daten verschieben ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOV – Daten verschieben operand[, operand]

PBXB64-Verwendung

MOV – Daten verschieben ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOV – Daten verschieben ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← MINSS – Minimaler skalarer Gleitkommawert mit einfacher Genauigkeit Nach oben MOVAPS – Ausgerichtetes, gepacktes Gleitkomma mit einfacher Genauigkeit verschieben →


MOVAPS – Ausgerichtetes, gepacktes Gleitkomma mit einfacher Genauigkeit verschieben – PBXB64 Assembler-Hilfe

Startseite › Funktionen › MOVAPS – Ausgerichtetes, gepacktes Gleitkomma mit einfacher Genauigkeit verschieben
Hilfe zum PBXB64-Compiler

MOVAPS – Ausgerichtetes, gepacktes Gleitkomma mit einfacher Genauigkeit verschieben

MOVAPS verschiebt 128 Bit ausgerichteter gepackter Gleitkommadaten mit einfacher Genauigkeit zwischen zwei XMM-Registern oder zwischen einem XMM-Register und einem ausgerichteten 16-Byte-Speicherort.

Kategorie: Datenbewegung | Gruppe: SSE-gepackter Gleitkommawert

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MOVAPS xmm1, xmm2/m128
MOVAPS xmm1/m128, xmm2

Operanden

Formular Beschreibung Beispiel
MOVAPS xmm1, xmm2 Kopieren Sie 128 Bit vom Quell-XMM-Register in das Ziel-XMM-Register.
movaps xmm0, xmm1
MOVAPS xmm1, m128 Laden Sie 128 Bit von einem 16-Byte-ausgerichteten Speicherort in ein XMM-Register.
movaps xmm0, oword [rbx]
MOVAPS m128, xmm1 Speichern Sie 128 Bits aus einem XMM-Register an einem 16-Byte-ausgerichteten Speicherort.
movaps oword [rbx], xmm0

Beschreibung

MOVAPS Überträgt den gesamten 128-Bit-Inhalt eines xmm registrieren. Der Speicheroperand muss an einer 16-Byte-Grenze ausgerichtet sein; andernfalls tritt eine allgemeine Schutzausnahme (#GP) auf. Diese Anweisung behandelt die Bits als vier gepackte Gleitkommazahlen mit einfacher Genauigkeit, es wird jedoch keine Konvertierung oder Arithmetik durchgeführt. Dies ist der schnellste Weg, ausgerichtete 128-Bit-Daten zu verschieben, wenn die Ausrichtung gewährleistet werden kann.

Flaggen

EFLAGS bleiben hiervon unberührt MOVAPS.

Codierungsnotizen

  • Erfordert SSE.
  • Opcode: 0F 28 /r (Laden/Registrieren verschieben), 0F 29 /r (Laden).
  • Speicheroperanden müssen 16-Byte-ausgerichtet sein.
  • VerwendenMOVUPS wenn die Ausrichtung nicht garantiert werden kann.

Beispiele

; Copy a full XMM vector
movaps  xmm0, xmm1

; Load an aligned SIMD vector
movaps  xmm2, oword [matrix_row]

; Store an aligned SIMD vector
movaps  oword [result], xmm0

When to use

VerwendenMOVAPS für schnelle ausgerichtete 128-Bit-Datenübertragungen, das Speichern/Wiederherstellen von SSE-Registern oder das Verschieben gepackter Float-Vektoren zwischen XMM-Registern. Stellen Sie stets eine 16-Byte-Ausrichtung der Speicheradresse sicher.

Siehe auch

  • MOVUPS
  • MOVSS
  • ADDPS

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVAPS – Ausgerichtetes, gepacktes Gleitkomma mit einfacher Genauigkeit verschieben ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVAPS – Ausgerichtetes, gepacktes Gleitkomma mit einfacher Genauigkeit verschieben operand[, operand]

PBXB64-Verwendung

MOVAPS – Ausgerichtetes, gepacktes Gleitkomma mit einfacher Genauigkeit verschieben ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVAPS – Ausgerichtetes, gepacktes Gleitkomma mit einfacher Genauigkeit verschieben ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVD – Doppelwort verschieben – PBXB64 Assembler-Hilfe

Startseite › Funktionen › MOVD – Doppelwort verschieben

MOVD – Doppelwort verschieben

MOVD verschiebt einen 32-Bit-Wert zwischen einem Allzweckregister oder Speicherort und einem MMX/SSE-Register, wobei die Nullen bis in die oberen Bits des SIMD-Registers reichen.

Kategorie: Datenbewegung | Gruppe: MMX/SSE-Ganzzahlverschiebung

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MOVD xmm1, r/m32
MOVD r/m32, xmm1
MOVD mm, r/m32
MOVD r/m32, mm

Operanden

Formular Beschreibung Beispiel
MOVD xmm, r32 Verschieben Sie das 32-Bit-Allzweckregister in die unteren 32 Bit von XMM. Die oberen 96 Bits werden auf Null gelöscht.
movd xmm0, eax
MOVD xmm, m32 Laden Sie den 32-Bit-Speicherwert in die unteren 32 Bit von XMM. Die oberen 96 Bits wurden gelöscht.
movd xmm0, dword [rbx]
MOVD r32, xmm Extrahieren Sie die unteren 32 Bits von XMM in das Allzweckregister.
movd eax, xmm0
MOVD m32, xmm Speichern Sie niedrige 32 Bit XMM im Speicher.
movd dword [rbx], xmm0
MOVD mm, r32 Verschieben Sie den 32-Bit-Wert in die unteren 32 Bits des MMX-Registers. Die oberen 32 Bits wurden gelöscht.
movd mm0, eax

Beschreibung

MOVD (Move Doubleword) überträgt einen 32-Bit-Skalarwert zwischen den niedrigen Bits eines SIMD-Registers und einem Allzweckregister oder Speicher. Beim Schreiben in ein XMM-Register werden die oberen 96 Bits auf Null gesetzt. Beim Schreiben in ein MMX-Register werden die oberen 32 Bits auf Null gesetzt. Es führt keine Formatkonvertierung durch; die Bits werden einfach kopiert.

Flaggen

EFLAGS bleiben hiervon unberührt MOVD.

Codierungsnotizen

  • Erfordert SSE2 für XMM-Formulare, MMX für MMX-Formulare.
  • SSE2-XMM-Opcode: 66 0F 6E /r (XMM <- r/m32), 66 0F 7E /r (r/m32 <- XMM).
  • MMX-Opcode: 0F 6E /r (MM <- r/m32), 0F 7E /r (r/m32 <- MM).
  • Der66 Das Präfix „Operandengröße“ unterscheidet die XMM-Formulare von den älteren MMX-Formularen.

Beispiele

; Move an integer into the low 32 bits of an XMM register
movd    xmm0, ecx

; Extract the low 32-bit integer result from XMM
movd    eax, xmm0

; Move a DWORD from memory into MMX (legacy 32-bit path)
movd    mm0, dword [count]

When to use

VerwendenMOVD um 32-Bit-Ganzzahlwerte in oder aus SIMD-Registern zu marschieren, um ein XMM-Register mit einer skalaren Ganzzahl zu initialisieren oder um eine Schnittstelle zwischen Ganzzahl- und SSE-Codepfaden zu schaffen.

Siehe auch

  • MOVQ
  • MOVDQA
  • CVTSI2SS

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVD – Doppelwort verschieben ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVD – Doppelwort verschieben operand[, operand]

PBXB64-Verwendung

MOVD – Doppelwort verschieben ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVD – Doppelwort verschieben ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVQ – Quadword verschieben – PBXB64 Assembler-Hilfe

Startseite › Funktionen › MOVQ – Quadword verschieben

MOVQ – Quadword verschieben

MOVQ verschiebt einen 64-Bit-Wert zwischen einem XMM/MMX-Register und einem Allzweckregister, Speicherort oder einem anderen SIMD-Register.

Kategorie: Datenbewegung | Gruppe: MMX/SSE-Ganzzahlverschiebung

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MOVQ xmm1, xmm2/m64
MOVQ xmm1/m64, xmm2
MOVQ mm1, mm2/m64
MOVQ mm1/m64, mm2

Operanden

Formular Beschreibung Beispiel
MOVQ xmm1, xmm2 Niedrige 64 Bit vom Quell-XMM zum Ziel-XMM kopieren; Die oberen 64 Bits des Ziels wurden gelöscht.
movq xmm0, xmm1
MOVQ xmm, m64 Laden Sie 64 Bits aus dem Speicher in das niedrige Quadword von XMM. Die oberen 64 Bits wurden gelöscht.
movq xmm0, qword [rbx]
MOVQ m64, xmm Speichern Sie niedrige 64 Bit XMM im Speicher.
movq qword [rbx], xmm0
MOVQ mm, r/m64 64-Bit-Wert in MMX-Register verschieben (Legacy).
movq mm0, rax
MOVQ r/m64, mm Verschieben Sie den 64-Bit-Wert vom MMX-Register in den GPR/Speicher (Legacy).
movq rax, mm0

Beschreibung

MOVQ (Move Quadword) überträgt einen 64-Bit-Skalarwert. In den SSE2/XMM-Formularen werden die oberen 64 Bits des Ziels auf Null gelöscht, wenn das Ziel ein XMM-Register ist. Die MMX-Formulare verschieben das vollständige 64-Bit-MMX-Register. Es wird keine Formatkonvertierung durchgeführt; Die 64 Bit werden unverändert kopiert. Diese Anweisung wird üblicherweise zum Verschieben von Skalardoppelzahlen, 64-Bit-Ganzzahlen oder Zeigern zwischen GPR- und XMM-Domänen verwendet.

Flaggen

EFLAGS bleiben hiervon unberührt MOVQ.

Codierungsnotizen

  • Erfordert SSE2 für XMM-Formulare, MMX für MMX-Formulare.
  • SSE2-Opcodes: F3 0F 7E /r (XMM <- xmm/m64), 66 0F D6 /r (xmm/m64 <- XMM).
  • MMX-Opcodes: 0F 6F /r (MM <- mm/m64), 0F 7F /r (mm/m64 <- MM).
  • Beim Laden in XMM werden die oberen 64 Bits auf Null gesetzt.

Beispiele

; Load a 64-bit integer into the low quadword of an XMM register
movq    xmm0, rax

; Store the low 64 bits of an XMM register
movq    qword [result], xmm0

; Copy a scalar double between XMM registers (alias for movsd without preserving upper bits)
movq    xmm1, xmm0

When to use

VerwendenMOVQ um 64-Bit-Skalare zwischen GPR- und XMM-Registern zu übertragen, die obere Hälfte eines XMM-Registers auf Null zu setzen oder skalare Werte mit doppelter Genauigkeit zu kopieren, wenn die oberen Bits nicht erhalten bleiben müssen.

Siehe auch

  • MOVD
  • MOVSD
  • MOVDQ2Q

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVQ – Quadword verschieben ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVQ – Quadword verschieben operand[, operand]

PBXB64-Verwendung

MOVQ – Quadword verschieben ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVQ – Quadword verschieben ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVS – String verschieben – PBXB64 Assembler-Hilfe

Startseite › Funktionen › MOVS – String verschieben

MOVS – Zeichenfolge verschieben

Verschiebt ein Byte, Wort, Dword oder Qword aus dem Speicherort, auf den verwiesen wird RSI zu dem von angegebenen Ort RDIund aktualisiert dann die Indexregister.

Kategorie: Zeichenfolge | Gruppe: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MOVSB
MOVSW
MOVSD
MOVSQ

Operanden

Die Operanden sind implizit: [RSI] ist die Quelle und [RDI] ist das Ziel. RSIUndRDI werden durch die Operandengröße und das Richtungsflag angepasst.

Beschreibung

Kopiert Daten von der Quelle zum Ziel. Das Richtungsflag bestimmt, ob die Indexregister inkrementiert oder dekrementiert werden.

Flaggen

Es sind keine Flaggen betroffen.

Beispiele

cld
mov rsi, source
mov rdi, dest
mov rcx, 64
rep movsq       ; copy 64 qwords

When to use

VerwendenMOVS für Blockspeicherkopien, insbesondere innerhalb von Schleifen oder mit dem REP Präfix.

Siehe auch

  • REP-Präfix
  • STOS
  • MOV

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVS – Zeichenfolge verschieben ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVS – Zeichenfolge verschieben operand[, operand]

PBXB64-Verwendung

MOVS – Zeichenfolge verschieben ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVS – Zeichenfolge verschieben ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVSD – Skalare Gleitkommazahlen mit doppelter Genauigkeit verschieben – PBXB64 Assembler-Hilfe

Startseite › Funktionen › MOVSD – Skalare Gleitkommazahl mit doppelter Genauigkeit verschieben
Hilfe zum PBXB64-Compiler

MOVSD – Skalare Gleitkommazahl mit doppelter Genauigkeit verschieben

MOVSD verschiebt einen skalaren Gleitkommawert mit doppelter Genauigkeit (64 Bit) zwischen den unteren Quadwords zweier XMM-Register oder zwischen einem XMM-Register und einem 64-Bit-Speicherort.

Kategorie: Datenbewegung | Gruppe: SSE2 Skalarer Gleitkommawert

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MOVSD xmm1, xmm2/m64
MOVSD xmm1/m64, xmm2

Operanden

Formular Beschreibung Beispiel
MOVSD xmm1, xmm2 Niedrige 64 Bit vom Quell-XMM zum Ziel-XMM kopieren; Die oberen 64 Bits des Ziels bleiben erhalten.
movsd xmm0, xmm1
MOVSD xmm, m64 64-Bit-Double aus dem Speicher in das Low-Quadword von XMM laden; Die oberen 64 Bit bleiben erhalten.
movsd xmm0, qword [value]
MOVSD m64, xmm Speichern Sie niedrige 64 Bit XMM im 64-Bit-Speicher.
movsd qword [value], xmm0

Beschreibung

MOVSD (Move Scalar Double-Precision) überträgt einen einzelnen 64-Bit-IEEE-754-Gleitkommawert mit doppelter Genauigkeit. Wenn das Ziel ein XMM-Register ist, bleiben die oberen 64 Bits dieses Registers erhalten; nur das niedrige Quadword wird geändert. Wenn das Ziel ein Speicher ist, werden die unteren 64 Bits des Quell-XMM-Registers geschrieben. Diese Anweisung ist die primäre Methode zum Laden/Speichern von Skalaren DOUBLE Werte im SSE-Code.

Flaggen

EFLAGS bleiben hiervon unberührt MOVSD.

Codierungsnotizen

  • Erfordert SSE2.
  • Opcode: F2 0F 10 /r (XMM <- xmm/m64), F2 0F 11 /r (xmm/m64 <- XMM).
  • DerF2 Präfix wählt Skalaroperation mit doppelter Genauigkeit aus.
  • Für Skalarbewegungen ist keine Speicherausrichtung erforderlich.

Beispiele

; Load a double from memory
movsd   xmm0, qword [pi]

; Store a double to memory
movsd   qword [result], xmm0

; Copy a scalar double between XMM registers
movsd   xmm1, xmm0

When to use

VerwendenMOVSD wann immer Sie einen einzelnen 64-Bit-Gleitkommawert zwischen Speicher und einem XMM-Register oder zwischen XMM-Registern verschieben müssen, während die oberen 64 Bits des Zielregisters erhalten bleiben.

Siehe auch

  • MOVSS
  • HINZUFÜGEN
  • CVTSD2SI

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVSD – Skalare Gleitkommazahl mit doppelter Genauigkeit verschieben ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVSD – Skalare Gleitkommazahl mit doppelter Genauigkeit verschieben operand[, operand]

PBXB64-Verwendung

MOVSD – Skalare Gleitkommazahl mit doppelter Genauigkeit verschieben ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVSD – Skalare Gleitkommazahl mit doppelter Genauigkeit verschieben ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVSS – Skalare Gleitkommazahlen mit einfacher Genauigkeit verschieben – PBXB64 Assembler-Hilfe

Startseite › Funktionen › MOVSS – Skalare Gleitkommazahl mit einfacher Genauigkeit verschieben
Hilfe zum PBXB64-Compiler

MOVSS – Verschieben Sie skalare Gleitkommazahlen mit einfacher Genauigkeit

MOVSS verschiebt einen skalaren Gleitkommawert mit einfacher Genauigkeit (32 Bit) zwischen den unteren Dwords zweier XMM-Register oder zwischen einem XMM-Register und einem 32-Bit-Speicherort.

Kategorie: Datenbewegung | Gruppe: SSE Skalarer Gleitkommawert

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MOVSS xmm1, xmm2/m32
MOVSS xmm1/m32, xmm2

Operanden

Formular Beschreibung Beispiel
MOVSS xmm1, xmm2 Niedrige 32 Bits vom Quell-XMM zum Ziel-XMM kopieren; Die oberen 96 Bits des Ziels bleiben erhalten.
movss xmm0, xmm1
MOVSS xmm, m32 32-Bit-Float aus dem Speicher in das untere Dword von XMM laden; Die oberen 96 Bit bleiben erhalten.
movss xmm0, dword [value]
MOVSS m32, xmm Speichern Sie niedrige 32 Bit XMM im 32-Bit-Speicher.
movss dword [value], xmm0

Beschreibung

MOVSS (Move Scalar Single-Precision) überträgt einen einzelnen 32-Bit-IEEE-754-Gleitkommawert mit einfacher Genauigkeit. Wenn das Ziel ein XMM-Register ist, bleiben die Bits 32–127 des Ziels erhalten; Nur das niedrige Dword wird geändert. Wenn das Ziel ein Speicher ist, werden die unteren 32 Bits des Quell-XMM-Registers geschrieben. Dies ist die Standardanweisung zum Verschieben von Skalaren SINGLE / FLOAT Werte.

Flaggen

EFLAGS bleiben hiervon unberührt MOVSS.

Codierungsnotizen

  • Erfordert SSE.
  • Opcode: F3 0F 10 /r (XMM <- xmm/m32), F3 0F 11 /r (xmm/m32 <- XMM).
  • DerF3 Präfix wählt Skalaroperation mit einfacher Genauigkeit aus.
  • Für Skalarbewegungen ist keine Speicherausrichtung erforderlich.

Beispiele

; Load a float from memory
movss   xmm0, dword [scale]

; Store a float to memory
movss   dword [scale], xmm0

; Copy a scalar float between XMM registers
movss   xmm1, xmm0

When to use

VerwendenMOVSS zum Verschieben eines einzelnen 32-Bit-Gleitkommawerts zwischen Speicher und einem XMM-Register oder zwischen XMM-Registern unter Beibehaltung der oberen 96 Bits des Zielregisters.

Siehe auch

  • MOVSD
  • ADDSS
  • CVTSS2SD

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVSS – Verschieben Sie skalare Gleitkommazahlen mit einfacher Genauigkeit ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVSS – Verschieben Sie skalare Gleitkommazahlen mit einfacher Genauigkeit operand[, operand]

PBXB64-Verwendung

MOVSS – Verschieben Sie skalare Gleitkommazahlen mit einfacher Genauigkeit ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVSS – Verschieben Sie skalare Gleitkommazahlen mit einfacher Genauigkeit ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MOVZX / MOVSX – PBXB64 Assembler-Hilfe

Startseite › Funktionen › MOVZX / MOVSX – PBXB64 Assembler-Hilfe
Hilfe zum PBXB64-Compiler

MOVZX / MOVSX – Mit Erweiterung verschieben

Kopiert einen kleineren Operanden in ein größeres Register mit Null- oder Vorzeichenerweiterung.

Kategorie: Datenbewegung | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MOVZX reg, reg/mem           ; Move with zero-extension
MOVSX reg, reg/mem           ; Move with sign-extension
MOVSXD reg64, reg/mem32      ; Move with sign-extension (32-bit to 64-bit)

Beschreibung

  • MOVZX: Kopiert die Quelle zum Ziel und füllt die oberen Bits mit Nullen. Keine Schildererweiterung.
  • MOVSX: Kopiert die Quelle zum Ziel und erweitert die oberen Bits um ein Vorzeichen.
  • MOVSXD: Sign-extendiert eine 32-Bit-Quelle auf ein 64-Bit-Ziel. Dies ist das Standardverhalten für 32-Bit-MOV-zu-64-Bit-Register in x64.

Beispiele

movzx rax, bl                ; zero-extend BL to RAX
movsx rax, bl                ; sign-extend BL to RAX
movsx eax, bx                ; sign-extend BX to EAX
movsxd rax, [rbx]            ; sign-extend 32-bit memory to 64-bit

Siehe auch

  • MOV
  • CQO / CDQE
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVZX / MOVSX – Mit Erweiterung verschieben ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVZX / MOVSX – Mit Erweiterung verschieben operand[, operand]

PBXB64-Verwendung

MOVZX / MOVSX – Mit Erweiterung verschieben ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVZX / MOVSX – Mit Erweiterung verschieben ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← MOVSS – Skalare Gleitkommazahl mit einfacher Genauigkeit verschieben Nach oben MOVUPS – Verschieben Sie nicht ausgerichtete gepackte Gleitkommazahlen mit einfacher Genauigkeit →


MOVUPS – Nicht ausgerichtete gepackte Gleitkommazahlen mit einfacher Genauigkeit verschieben – PBXB64 Assembler-Hilfe

Startseite › Funktionen › MOVUPS – Verschieben Sie nicht ausgerichtete, gepackte Gleitkommazahlen mit einfacher Genauigkeit
Hilfe zum PBXB64-Compiler

MOVUPS – Verschieben Sie nicht ausgerichtete gepackte Gleitkommazahlen mit einfacher Genauigkeit

MOVUPS verschiebt 128 Bit gepackter Gleitkommadaten mit einfacher Genauigkeit zwischen XMM-Registern oder zwischen einem XMM-Register und dem Speicher, ohne dass eine 16-Byte-Ausrichtung erforderlich ist.

Kategorie: Datenbewegung | Gruppe: SSE-gepackter Gleitkommawert

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MOVUPS xmm1, xmm2/m128
MOVUPS xmm1/m128, xmm2

Operanden

Formular Beschreibung Beispiel
MOVUPS xmm1, xmm2 Kopieren Sie 128 Bit vom Quell-XMM-Register in das Ziel-XMM-Register.
movups xmm0, xmm1
MOVUPS xmm, m128 Laden Sie 128 Bit von einer beliebigen Speicheradresse (ausgerichtet oder nicht) in XMM.
movups xmm0, oword [unbuf]
MOVUPS m128, xmm Speichern Sie 128 Bit von XMM an einer beliebigen Speicheradresse.
movups oword [unbuf], xmm0

Beschreibung

MOVUPS ist das nicht ausgerichtete Gegenstück zu MOVAPS. Es überträgt den gesamten 128-Bit-Inhalt eines xmm Register, ohne dass der Speicheroperand an einer 16-Byte-Grenze ausgerichtet sein muss. Auf älteren CPUs kann dies langsamer sein als MOVAPS; Auf modernen x64-CPUs ist die Leistungseinbuße bei normalen Lasten normalerweise vernachlässigbar, ausgerichtete Speicher können jedoch immer noch Vorgänge mit geteilter Cache-Zeile ausführen. Verwenden Sie es, wenn die Ausrichtung nicht garantiert werden kann.

Flaggen

EFLAGS bleiben hiervon unberührt MOVUPS.

Codierungsnotizen

  • Erfordert SSE.
  • Opcode: 0F 10 /r (XMM <- xmm/m128), 0F 11 /r (xmm/m128 <- XMM).
  • Keine Ausrichtungsanforderung für Speicheroperanden.
  • Bei einigen älteren Prozessoren kann das Überschreiten einer Cache-Zeilengrenze zu einer kleinen Strafe führen.

Beispiele

; Copy an unaligned 128-bit vector
movups  xmm0, oword [user_buffer]
movups  oword [out_buffer], xmm0

; Move between XMM registers (alignment irrelevant)
movups  xmm1, xmm0

When to use

VerwendenMOVUPS beim Kopieren von 128-Bit-SIMD-Daten, deren Speicheradresse nicht bekanntermaßen 16-Byte-ausgerichtet ist. Bevorzugen MOVAPS wenn Sie die Zuordnung kontrollieren und die Ausrichtung für beste Leistung garantieren können.

Siehe auch

  • MOVAPS
  • MOVSS
  • ADDPS

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MOVUPS – Verschieben Sie nicht ausgerichtete gepackte Gleitkommazahlen mit einfacher Genauigkeit ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MOVUPS – Verschieben Sie nicht ausgerichtete gepackte Gleitkommazahlen mit einfacher Genauigkeit operand[, operand]

PBXB64-Verwendung

MOVUPS – Verschieben Sie nicht ausgerichtete gepackte Gleitkommazahlen mit einfacher Genauigkeit ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MOVUPS – Verschieben Sie nicht ausgerichtete gepackte Gleitkommazahlen mit einfacher Genauigkeit ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MUL – PBXB64 Assembler-Hilfe

Startseite › Funktionen › MUL – PBXB64 Assembler-Hilfe

MUL – Vorzeichenlose Multiplikation

Multipliziert einen impliziten Akkumulator mit dem Quelloperanden.

Kategorie: Arithmetik | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MUL reg/mem

Beschreibung

Multipliziert den impliziten Akkumulator (AL/AX/EAX/RAX) mit dem Quelloperanden. Das Ergebnis der doppelten Breite wird in AX/DX:AX/EDX:EAX/RDX:RAX gespeichert.

Größe | Multiplikand | Ergebnis
8-Bit | AL | AXT
16-Bit | AXT | DX:AX
32-Bit | EAX | EDX:EAX
64-Bit | RAX | RDX:RAX

Beispiele

mul rbx                     ; RDX:RAX = RAX * RBX

Siehe auch

  • IMUL
  • DIV
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MUL – Vorzeichenlose Multiplikation ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MUL – Vorzeichenlose Multiplikation operand[, operand]

PBXB64-Verwendung

MUL – Vorzeichenlose Multiplikation ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MUL – Vorzeichenlose Multiplikation ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← MOVUPS – Verschieben Sie nicht ausgerichtete, gepackte Gleitkommazahlen mit einfacher Genauigkeit Nach oben MULPS – Gepackte Gleitkomma-Multiplikation mit einfacher Genauigkeit →


MULPS – Gepackte Gleitkomma-Multiplikation mit einfacher Genauigkeit – PBXB64 Assembler-Hilfe

Startseite › Funktionen › MULPS – Gepackte Gleitkomma-Multiplikation mit einfacher Genauigkeit
Hilfe zum PBXB64-Compiler

MULPS – Gepackte Gleitkomma-Multiplikation mit einfacher Genauigkeit

Multipliziert vier Gleitkommawerte mit einfacher Genauigkeit parallel.

Kategorie: SSE/AVX | Gruppe: Gepackte Gleitkomma-Arithmetik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MULPS xmm1, xmm2/m128

Operanden

Formular | Beschreibung | Beispiel
MULPS xmm1, xmm2 | Multipliziert gepackte SP-Floats in zwei XMM-Registern. | mulps xmm0, xmm1
MULPS xmm1, m128 | Mehrfach gepackte SP-Floats aus einem XMM-Register und einem 128-Bit-Speicheroperanden. | mulps xmm0, [rbx]

Beschreibung

MULPS (Multiply Packed Single-Precision) führt eine elementweise Multiplikation von vier IEEE-754-Gleitkommawerten mit einfacher Genauigkeit (32 Bit) durch. Der Zieloperand ist ein XMM-Register; Die Quelle kann ein anderes XMM-Register oder ein 128-Bit-Speicherort sein.

Jedes der vier Float-Paare wird unabhängig multipliziert: DEST[i] = DEST[i] * SRC[i] für i = 0..3. Es gibt keine Interaktion zwischen den Spuren. Denormale, NaNs und vorzeichenbehaftete Nullen werden gemäß der SSE-Semantik behandelt.

Flaggen

Keiner betroffen.

Codierungsnotizen

  • Verwendet die 0F 59 /r Opcode mit weggelassenem obligatorischen 0x66-Präfix (dies ist ein XMM-SSE1-Befehl, nicht SSE2).
  • Erfordert einen 128-Bit-ausgerichteten Speicheroperanden auf älteren CPUs; nicht ausgerichteter Speicher sollte verwendet werden MULUPS wenn verfügbar.
  • Mit VEX/EVEX-Präfixen lautet die Anweisung VMULPS und unterstützt Drei-Operanden-Formulare und YMM/ZMM-Breiten; PBXB64 gibt das alte SSE-Formular aus, sofern AVX nicht aktiviert ist.

Beispiele

; Multiply two arrays of four floats
movaps xmm0, [vecA]    ; load 4 SP floats
mulps  xmm0, [vecB]    ; xmm0 = vecA * vecB (element-wise)
movaps [result], xmm0

; Register-only packed multiply
movaps xmm2, xmm0
mulps  xmm2, xmm1      ; xmm2 = xmm0 * xmm1

When to use

VerwendenMULPS für vektorisierte Mathematik mit einfacher Genauigkeit, wie z. B. 3D-Koordinatenskalierung, Farbkanalmultiplikation oder einen beliebigen SIMD-Kernel, der vier Gleitkommazahlen pro Befehl verarbeitet.

Siehe auch

  • MULSS
  • MULSD
  • ADDPS
  • SUBPS

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MULPS – Gepackte Gleitkomma-Multiplikation mit einfacher Genauigkeit ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MULPS – Gepackte Gleitkomma-Multiplikation mit einfacher Genauigkeit operand[, operand]

PBXB64-Verwendung

MULPS – Gepackte Gleitkomma-Multiplikation mit einfacher Genauigkeit ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MULPS – Gepackte Gleitkomma-Multiplikation mit einfacher Genauigkeit ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MULSD – Skalare Gleitkommamultiplikation mit doppelter Genauigkeit – PBXB64 Assembler-Hilfe

Startseite › Funktionen › MULSD – Skalare Gleitkommamultiplikation mit doppelter Genauigkeit
Hilfe zum PBXB64-Compiler

MULSD – Skalare Gleitkommamultiplikation mit doppelter Genauigkeit

Multipliziert den niedrigen Gleitkommawert mit doppelter Genauigkeit in zwei XMM-Operanden.

Kategorie: SSE/AVX | Gruppe: Skalare Gleitkomma-Arithmetik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MULSD xmm1, xmm2/m64

Operanden

Formular | Beschreibung | Beispiel
MULSD xmm1, xmm2 | Multiplizieren Sie den Float mit niedriger doppelter Genauigkeit in zwei XMM-Registern. | mulsd xmm0, xmm1
MULSD xmm1, m64 | Multiplizieren Sie den niedrigen Gleitkommawert mit doppelter Genauigkeit in einem XMM-Register mit einem 64-Bit-Speicheroperanden. | mulsd xmm0, qword [rbx]

Beschreibung

MULSD(Multiply Scalar Double-Precision) multipliziert nur den niedrigen 64-Bit-Gleitkommawert mit doppelter Genauigkeit im Ziel-XMM-Register mit dem entsprechenden niedrigen Wert in der Quelle. Die Bits 127:64 des Ziel-XMM-Registers bleiben unverändert erhalten.

Dies ist die primäre Anweisung, die von PBXB64 verwendet wird DOUBLE Multiplikation im kompilierten PB-Code sowie für Skalar float64 Operationen in den C- und B64-Frontends.

Flaggen

Keiner betroffen.

Codierungsnotizen

  • Opcode F2 0F 59 /r; Das Präfix F2 REPNE wählt die skalare Form mit doppelter Genauigkeit aus.
  • Der Speicheroperand ist 64 Bit, nicht 128 Bit.
  • Beim Legacy-SSE bleiben die oberen XMM-Bits unverändert. Bei VEX/EVEX lautet die Anweisung VMULSD und setzt die Bits 127:64 des Ergebnisses auf Null.

Beispiele

; Double-precision multiply
movsd xmm0, [a]     ; load a (double)
mulsd xmm0, [b]     ; xmm0.low = a * b
movsd [result], xmm0

; Register scalar multiply
movsd xmm2, xmm0
mulsd xmm2, xmm1    ; xmm2.low = xmm0.low * xmm1.low

When to use

VerwendenMULSD wann immer Sie eine einzelne IEEE-754-Multiplikation mit doppelter Genauigkeit benötigen. Es ist das SSE-Äquivalent von x87 FMUL Anweisung, lässt sich aber sauber in den XMM-Registercode integrieren.

Siehe auch

  • MULSS
  • MULPS
  • HINZUFÜGEN
  • SUBSD

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MULSD – Skalare Gleitkommamultiplikation mit doppelter Genauigkeit ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MULSD – Skalare Gleitkommamultiplikation mit doppelter Genauigkeit operand[, operand]

PBXB64-Verwendung

MULSD – Skalare Gleitkommamultiplikation mit doppelter Genauigkeit ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MULSD – Skalare Gleitkommamultiplikation mit doppelter Genauigkeit ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


MULSS – Skalare Gleitkommamultiplikation mit einfacher Genauigkeit – PBXB64 Assembler-Hilfe

Startseite › Funktionen › MULSS – Skalare Gleitkommamultiplikation mit einfacher Genauigkeit
Hilfe zum PBXB64-Compiler

MULSS – Skalare Gleitkommamultiplikation mit einfacher Genauigkeit

Multipliziert den niedrigen Gleitkommawert mit einfacher Genauigkeit in zwei XMM-Operanden.

Kategorie: SSE/AVX | Gruppe: Skalare Gleitkomma-Arithmetik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

MULSS xmm1, xmm2/m32

Operanden

Formular | Beschreibung | Beispiel
MULSS xmm1, xmm2 | Multiplizieren Sie den Float mit niedriger einfacher Genauigkeit in zwei XMM-Registern. | mulss xmm0, xmm1
MULSS xmm1, m32 | Multiplizieren Sie den niedrigen Float mit einfacher Genauigkeit in einem XMM-Register mit einem 32-Bit-Speicheroperanden. | mulss xmm0, dword [rbx]

Beschreibung

MULSS (Multiply Scalar Single-Precision) multipliziert nur den niedrigen 32-Bit-Gleitkommawert mit einfacher Genauigkeit im Ziel-XMM-Register mit dem niedrigen Wert in der Quelle. Die Bits 127:32 des Ziel-XMM-Registers bleiben im alten SSE unverändert erhalten.

Diese Anweisung wird für Skalare verwendet FLOAT/SINGLE Multiplikation in PBXB64-kompilierten PB-Programmen und für float32 Operationen in den C- und B64-Frontends.

Flaggen

Keiner betroffen.

Codierungsnotizen

  • Opcode F3 0F 59 /r; Das Präfix F3 REP wählt die skalare Form mit einfacher Genauigkeit aus.
  • Der Speicheroperand ist 32 Bit groß.
  • Beim Legacy-SSE bleiben die Bits 127:32 unverändert. Bei VEX/EVEX lautet die Anweisung VMULSS und setzt die Bits 127:32 des Ergebnisses auf Null.

Beispiele

; Single-precision multiply
movss xmm0, [x]     ; load x (float)
mulss xmm0, [y]     ; xmm0.low = x * y
movss [z], xmm0

; Register scalar multiply
movss xmm3, xmm0
mulss xmm3, xmm1    ; xmm3.low = xmm0.low * xmm1.low

When to use

VerwendenMULSS für skalare Gleitkommamultiplikation mit einfacher Genauigkeit. Bevorzugen MULPS wenn Sie vier Floats parallel verarbeiten können.

Siehe auch

  • MULPS
  • MULSD
  • ADDSS
  • SUBSS

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

MULSS – Skalare Gleitkommamultiplikation mit einfacher Genauigkeit ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

MULSS – Skalare Gleitkommamultiplikation mit einfacher Genauigkeit operand[, operand]

PBXB64-Verwendung

MULSS – Skalare Gleitkommamultiplikation mit einfacher Genauigkeit ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! MULSS – Skalare Gleitkommamultiplikation mit einfacher Genauigkeit ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


NEG – PBXB64 Assembler-Hilfe

Startseite › Funktionen › NEG – PBXB64 Assembler-Hilfe

NEG – Negieren (Zweierkomplement)

Ersetzt den Operanden durch seine arithmetische Negation (0 - Operand).

Kategorie: Arithmetik | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

NEG reg
NEG mem

Beschreibung

Führt durch operand = 0 - operand. Setzt OF, SF, ZF, AF, PF, CF. CF wird auf 1 gesetzt, es sei denn, der Operand ist Null. OF wird gesetzt, wenn das Ergebnis überläuft.

Beispiele

neg rax                     ; rax = -rax
neg DWORD PTR [rbx]

Siehe auch

  • SUB
  • NICHT
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

NEG – Negieren (Zweierkomplement) ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

NEG – Negieren (Zweierkomplement) operand[, operand]

PBXB64-Verwendung

NEG – Negieren (Zweierkomplement) ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! NEG – Negieren (Zweierkomplement) ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


NOP – PBXB64 Assembler-Hilfe

Startseite › Funktionen › NOP – PBXB64 Assembler-Hilfe

NOP – Kein Betrieb

Tut nichts. Belegt je nach Multibyte-Kodierungsvariante 1–9 Byte.

Kategorie: Legacy/Kompatibilität | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

NOP

Beschreibung

Führt keine Operation aus. Ändert keine Register, Flags oder Speicher. Wird für die Ausrichtungsauffüllung, das Befehlstiming oder als Platzhalter für Code-Patches verwendet.

Multi-Byte-Kodierungen

Größe | Codierung
1 Byte | 90
2 Bytes | 66 90
3 Bytes | 0F 1F 00
5 Bytes | 0F 1F 44 00 00
9 Bytes | 66 0F 1F 84 00 00 00 00 00

Beispiele

nop                          ; 1-byte alignment
nop [rax]                    ; 2-byte NOP with ModRM

Siehe auch

  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

NOP – Kein Betrieb ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

NOP – Kein Betrieb operand[, operand]

PBXB64-Verwendung

NOP – Kein Betrieb ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! NOP – Kein Betrieb ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


NOT – Bitweises logisches NOT – PBXB64 Assembler-Hilfe

Startseite › Funktionen › NOT – Bitweises logisches NOT

NOT – Bitweises logisches NOT

Führt eine Einserkomplementinvertierung jedes Bits im Operanden durch.

Kategorie: Logisch | Gruppe: Unäre bitweise Operation

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

NOT r/m8
NOT r/m16
NOT r/m32
NOT r/m64

Operanden

Formular | Beschreibung | Beispiel
NOT r64 | Invertieren Sie alle Bits eines 64-Bit-Allzweckregisters. | not rax
NOT r32 | Alle Bits eines 32-Bit-Registers invertieren; Die oberen 32 Bits von RAX werden auf Null gesetzt. | not eax
NOT r/m8 | Invertieren Sie alle Bits eines 8-Bit-Registers oder Speicherbytes. | not byte [mask]

Beschreibung

NOT ersetzt jedes Bit des Zieloperanden durch sein Komplement: 0 wird zu 1 und 1 wird zu 0. Es entspricht dem C/BASIC-Ausdruck~x. Der Operand kann ein Register oder ein Speicherort sein; es gibt keine unmittelbare Form.

Im Gegensatz zu den logischen Anweisungen mit zwei Operanden AND, OR, UndXOR, NOT ist eine unäre Operation und erfordert keinen Quelloperanden.

Flaggen

Keiner betroffen.

Codierungsnotizen

  • Opcode F6 /2 für 8-Bit-Operanden, F7 /2 für 16/32/64-Bit-Operanden.
  • Das REX-Präfix ist im 64-Bit-Modus für die Heraufstufung der Operandengröße und für den Zugriff auf R8-R15 oder SPL-BPL erforderlich.

Beispiele

; Invert a bitmask
mov rax, 0x0F0F0F0F0F0F0F0F
not rax              ; rax = 0xF0F0F0F0F0F0F0F0

; Toggle all bits in a byte
not byte [flags]

; Two's complement short form
neg rax              ; 0 - rax
not rax              ; alternative: ~rax

When to use

VerwendenNOT für Bitmasken, Flag-Umschaltung und Einserkomplementberechnungen. Kombinieren mit AND um ausgewählte Bits mithilfe einer invertierten Maske zu löschen.

Siehe auch

  • UND
  • ODER
  • XOR
  • NEG

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

NOT – Bitweises logisches NOT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

NOT – Bitweises logisches NOT operand[, operand]

PBXB64-Verwendung

NOT – Bitweises logisches NOT ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! NOT – Bitweises logisches NOT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


ODER – PBXB64 Assembler-Hilfe

Startseite › Funktionen › ODER – PBXB64 Assembler-Hilfe

ODER – Bitweises ODER

Führt eine bitweise ODER-Verknüpfung von Quelle und Ziel durch und speichert das Ergebnis im Ziel.

Kategorie: Logisch | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

OR dst, src

Beschreibung

Führt durch dst = dst | src. Setzt OF=0, CF=0, SF, ZF, PF entsprechend dem Ergebnis. CF wird immer gelöscht. Nützlich zum Setzen von Bits.

Beispiele

or rax, 0x10               ; set bit 4
or rax, rbx                ; bitwise OR

Siehe auch

  • UND
  • XOR
  • NICHT
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

ODER – Bitweises ODER ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

ODER – Bitweises ODER operand[, operand]

PBXB64-Verwendung

ODER – Bitweises ODER ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! ODER – Bitweises ODER ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PAND – Bitweises logisches UND für MMX/XMM – PBXB64 Assembler-Hilfe

Startseite › Funktionen › PAND – Bitweises logisches UND für MMX/XMM
Hilfe zum PBXB64-Compiler

PAND – Bitweises logisches UND für MMX/XMM

Führt eine bitweise UND-Verknüpfung gepackter ganzzahliger Operanden in MMX- oder XMM-Registern durch.

Kategorie: MMX/Logisch | Gruppe: Logisch verpackt

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

PAND mm1, mm2/m64
PAND xmm1, xmm2/m128

Operanden

Formular | Beschreibung | Beispiel
PAND mm1, mm2 | Bitweises UND von zwei 64-Bit-MMX-Registern. | pand mm0, mm1
PAND xmm1, xmm2 | Bitweises UND von zwei 128-Bit-XMM-Registern. | pand xmm0, xmm1
PAND xmm1, m128 | Bitweises UND eines XMM-Registers und eines 128-Bit-Speichers. | pand xmm0, [mask]

Beschreibung

PAND Berechnet das bitweise UND der gepackten Ganzzahloperanden des Ziels und der Quelle. Es ist das SIMD-Äquivalent der Ganzzahl AND Die Anweisung arbeitet jedoch mit 64-Bit-MMX- oder 128-Bit-XMM-Werten als Einzelbitfeld.

PBXB64 verwendet hauptsächlich die XMM-Form für 128-Bit-Vektormasken, boolesche Reduktion und das Löschen ausgewählter Bits über ein gesamtes SSE-Register.

Flaggen

Keiner betroffen.

Codierungsnotizen

  • Opcode 0F DB /r sowohl für MMX- als auch für XMM-Kodierungen.
  • Für XMM ist kein Operandengrößenpräfix erforderlich. Das Vorhandensein eines XMM-Registers in ModRM wählt die 128-Bit-Form aus.
  • Mit VEX/EVEX-Präfixen lautet die Anweisung VPAND; Das alte SSE-Formular wird von PBXB64 ausgegeben, sofern AVX nicht aktiviert ist.

Beispiele

; Mask off upper bits of four 32-bit integers
movdqa xmm0, [values]
pand   xmm0, [low16_mask]  ; keep only low 16 bits of each dword

; MMX register mask
pand   mm0, mm1

When to use

VerwendenPAND für SIMD-Maskierung, Bitlöschung und vektorisiertes boolesches UND. Benutzen PANDN wenn Sie AND-NOT benötigen (Maske mit invertiertem Ziel).

Siehe auch

  • PANDN
  • POR
  • PXOR
  • UND

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PAND – Bitweises logisches UND für MMX/XMM ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PAND – Bitweises logisches UND für MMX/XMM operand[, operand]

PBXB64-Verwendung

PAND – Bitweises logisches UND für MMX/XMM ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PAND – Bitweises logisches UND für MMX/XMM ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PANDN – Bitweises logisches UND-NICHT für MMX/XMM – PBXB64 Assembler-Hilfe

Startseite › Funktionen › PANDN – Bitweises logisches UND-NICHT für MMX/XMM
Hilfe zum PBXB64-Compiler

PANDN – Bitweises logisches UND-NICHT für MMX/XMM

Kehrt das Ziel um und verknüpft es dann mit dem gepackten Ganzzahloperanden der Quelle.

Kategorie: MMX/Logisch | Gruppe: Logisch verpackt

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

PANDN mm1, mm2/m64
PANDN xmm1, xmm2/m128

Operanden

Formular | Beschreibung | Beispiel
PANDN mm1, mm2 | 64-Bit-MMX UND-NICHT. | pandn mm0, mm1
PANDN xmm1, xmm2 | 128-Bit-XMM UND-NICHT. | pandn xmm0, xmm1
PANDN xmm1, m128 | 128-Bit-XMM AND-NOT mit Speicher. | pandn xmm0, [mask]

Beschreibung

PANDN Führt ein bitweises NOT für den Zieloperanden durch und verknüpft das Ergebnis dann mit dem Quelloperanden: DEST = (~DEST) & SRC. Es wird häufig für Maskierungsvorgänge verwendet, bei denen die Maske im Ziel und die Daten in der Quelle gespeichert werden.

Dieser Befehl ist nützlich, um Bits zu löschen, die in der Zielmaske gesetzt sind, und gleichzeitig Bits aus der Quelle beizubehalten, bei denen die Maske Null war.

Flaggen

Keiner betroffen.

Codierungsnotizen

  • Opcode 0F DF /r sowohl für MMX- als auch für XMM-Kodierungen.
  • Das Zielregister ist sowohl die Maske als auch das Ergebnisregister; Der Quelloperand wird nicht geändert.
  • Mit VEX/EVEX-Präfixen lautet die Anweisung VPANDN.

Beispiele

; Clear bits selected by mask (mask in xmm0)
pandn xmm0, xmm1       ; xmm0 = ~xmm0 & xmm1

; Mask out high bits from a 128-bit value
movdqa xmm0, [keep_low]
pandn  xmm0, [data]

When to use

VerwendenPANDN wenn Sie ein kombiniertes NICHT+UND in einem einzelnen SIMD-Befehl benötigen, z. B. zum Löschen ausgewählter Spuren oder zum Erstellen von Vektormasken.

Siehe auch

  • PAND
  • POR
  • PXOR

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PANDN – Bitweises logisches UND-NICHT für MMX/XMM ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PANDN – Bitweises logisches UND-NICHT für MMX/XMM operand[, operand]

PBXB64-Verwendung

PANDN – Bitweises logisches UND-NICHT für MMX/XMM ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PANDN – Bitweises logisches UND-NICHT für MMX/XMM ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PAUSE – Spin-Loop-Hinweis – PBXB64 Assembler-Hilfe

Startseite › Funktionen › PAUSE – Spin-Loop-Hinweis

PAUSE – Spin-Loop-Hinweis

Gibt einen Hinweis darauf, dass sich der aktuelle Code in einer Busy-Wait-Spin-Schleife befindet.

Kategorie: System/Atom | Gruppe: Hinweise zum Prozessor

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

PAUSE

Operanden

Formular | Beschreibung | Beispiel
PAUSE | Keine Operanden; implizierter Spin-Loop-Hinweis. | pause

Beschreibung

PAUSEist eine mit SSE2 eingeführte Hinweisanweisung. Es teilt der CPU mit, dass der aktuelle Thread eine Spin-Wait-Schleife ausführt, wodurch der Prozessor den Stromverbrauch optimieren und Strafen für Verstöße gegen die Speicherreihenfolge bei Hyper-Threading- und Out-of-Order-Kernen reduzieren kann.

PAUSE ändert weder den Programmstatus noch den Speicher oder die Flags. Es wird normalerweise am Ende einer Spin-Schleife platziert, die wiederholt eine atomare Variable liest, bis sie von einem anderen Thread aktualisiert wird.

Flaggen

Keiner betroffen.

Codierungsnotizen

  • Zwei-Byte-Opcode F3 90 (gleiche Bytes wie REP NOP, oft zerlegt als repz nop).
  • Unterstützt auf Pentium 4 und höher; wird auf älteren Prozessoren als NOP ausgeführt.

Beispiele

; Atomic spin lock acquire
spin:
    lock bts [lock_var], 0
    jnc  acquired
    pause
    test dword [lock_var], 1
    jnz  spin
    jmp  spin
acquired:

When to use

VerwendenPAUSE in engen Spin-Schleifen in Multithread-Code, sperrenfreien Algorithmen und Busy-Waits auf atomaren Flags. Es verbessert die Leistung auf Hyper-Threaded-CPUs und reduziert den Stromverbrauch.

Siehe auch

  • NEIN
  • SPERREN
  • CMPXCHG

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PAUSE – Spin-Loop-Hinweis ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PAUSE – Spin-Loop-Hinweis operand[, operand]

PBXB64-Verwendung

PAUSE – Spin-Loop-Hinweis ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PAUSE – Spin-Loop-Hinweis ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


POP – PBXB64 Assembler-Hilfe

Startseite › Funktionen › POP – PBXB64 Assembler-Hilfe

POP – Pop vom Stapel

Lädt den Wert bei [RSP] in den Operanden und erhöht RSP um 8.

Kategorie: Stapeloperationen | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

POP reg
POP mem

Beschreibung

Lädt den Wert bei [RSP] in das Ziel und erhöht RSP um 8 (im x64-Modus). In x64 arbeitet POP immer mit 64-Bit-Werten.

Beispiele

pop rax
pop [rbx]

Siehe auch

  • DRÜCKEN
  • RET
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

POP – Pop vom Stapel ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

POP – Pop vom Stapel operand[, operand]

PBXB64-Verwendung

POP – Pop vom Stapel ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! POP – Pop vom Stapel ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


POPA / POPAD – Alle Allzweckregister öffnen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › POPA / POPAD – Alle Allzweckregister öffnen
Hilfe zum PBXB64-Compiler

POPA / POPAD – Alle Allzweckregister öffnen

Stellt alle Allzweckregister vom Stapel in einem einzigen Befehl wieder her.

Typ: Anleitung | Kategorie: x64-Stack

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

POPA    ' 16-bit operands
POPAD   ' 32-bit operands

Betrieb

Legt Werte vom Stapel in DI, SI, BP, BX, DX, CX, AX (in dieser Reihenfolge für POPA). POPAD verwendet die 32-Bit-Äquivalente. Diese Anweisungen sind im 64-Bit-Modus nicht verfügbar. Verwenden Sie stattdessen einzelne POP-Anweisungen.

Flaggen

Es sind keine Flaggen betroffen.

Beispiel

FUNCTION PBMAIN() AS LONG
  ' Note: in x64 mode use individual pops
  ! pop rax
  ! pop rbx
  FUNCTION = 0
END FUNCTION

When to use

Verwenden Sie POPA/POPAD in 16-Bit- oder 32-Bit-Code, um den Registerkontext wiederherzustellen. Im x64-Code wird Pop einzeln registriert.

Siehe auch

  • PUSHA
  • POP
  • DRÜCKEN

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

POPA / POPAD – Alle Allzweckregister öffnen ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

POPA / POPAD – Alle Allzweckregister öffnen operand[, operand]

PBXB64-Verwendung

POPA / POPAD – Alle Allzweckregister öffnen ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! POPA / POPAD – Alle Allzweckregister öffnen ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


POPCNT - Count Set Bits - PBXB64 Compiler Help

Startseite › x64 Backend › Instruction Detail Pages › Miscellaneous › POPCNT - Count Set Bits
Hilfe zum PBXB64-Compiler

POPCNT - Count Set Bits

Counts the number of one bits in the source operand and writes the count to the destination register.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

Counts the number of one bits in the source operand and writes the count to the destination register.

Verwendung in PBXB64

POPCNT requires CPU support. For portable code, guard use with feature detection or provide a scalar fallback.

Beispiel

popcnt rax, rcx

Prfung

Prfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-bersicht
  • Befehlsindex

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-bersichten als Einstieg in fokussierte Assembler-Tests. Eine vollstndige Prfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gltig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausfhren und das exakte Ergebnis vergleichen. Bei featureabhngigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurckkehrt. Sichern Sie nichtflchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich vernderte Flags oder Register.

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

POPCNT ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

POPCNT operand[, operand]

PBXB64-Verwendung

POPCNT ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! POPCNT ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes

Zurck zum Befehlsindex


POR – Bitweises logisches ODER für MMX/XMM – PBXB64 Assembler-Hilfe

Startseite › Funktionen › POR – Bitweises logisches ODER für MMX/XMM
Hilfe zum PBXB64-Compiler

POR – Bitweises logisches ODER für MMX/XMM

Führt ein bitweises ODER von gepackten ganzzahligen Operanden in MMX- oder XMM-Registern durch.

Kategorie: MMX/Logisch | Gruppe: Logisch verpackt

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

POR mm1, mm2/m64
POR xmm1, xmm2/m128

Operanden

Formular | Beschreibung | Beispiel
POR mm1, mm2 | Bitweises ODER von zwei 64-Bit-MMX-Registern. | por mm0, mm1
POR xmm1, xmm2 | Bitweises ODER von zwei 128-Bit-XMM-Registern. | por xmm0, xmm1
POR xmm1, m128 | Bitweises ODER eines XMM-Registers und eines 128-Bit-Speichers. | por xmm0, [bits]

Beschreibung

POR Berechnet das bitweise ODER der gepackten Ganzzahloperanden des Ziels und der Quelle. Es ist das SIMD-Äquivalent der Ganzzahl OR Befehl, der mit 64-Bit-MMX- oder 128-Bit-XMM-Werten als einzelnes Bitfeld arbeitet.

Diese Anweisung ist nützlich zum Kombinieren von Bitmasken, zum Setzen ausgewählter Bits und für vektorisierte boolesche ODER-Operationen.

Flaggen

Keiner betroffen.

Codierungsnotizen

  • Opcode 0F EB /r sowohl für MMX- als auch für XMM-Kodierungen.
  • Mit VEX/EVEX-Präfixen lautet die Anweisung VPOR.

Beispiele

; Set bits selected by mask
movdqa xmm0, [flags]
por    xmm0, [enable_mask]

; MMX OR
por    mm0, mm1

When to use

VerwendenPOR für SIMD-Maskierung, Setzen von Bits und vektorisiertes boolesches ODER. Es wird oft mit kombiniert PANDUndPXOR für komplexe Bitfeldmanipulation.

Siehe auch

  • PAND
  • PANDN
  • PXOR
  • ODER

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

POR – Bitweises logisches ODER für MMX/XMM ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

POR – Bitweises logisches ODER für MMX/XMM operand[, operand]

PBXB64-Verwendung

POR – Bitweises logisches ODER für MMX/XMM ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! POR – Bitweises logisches ODER für MMX/XMM ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PUSH – PBXB64 Assembler-Hilfe

Startseite › Funktionen › PUSH – PBXB64 Assembler-Hilfe

PUSH – Auf den Stapel schieben

Dekrementiert RSP um 8 und speichert den Operanden auf dem Stapel.

Kategorie: Stapeloperationen | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

PUSH reg
PUSH mem
PUSH imm

Beschreibung

Dekrementiert RSP um 8 (im x64-Modus) und speichert den Operanden unter [RSP]. In x64 arbeitet PUSH immer mit 64-Bit-Werten. 32-Bit- und 16-Bit-PUSH sind nicht kodierbar.

Beispiele

push rax
push [rbx]
push 42

Siehe auch

  • POP
  • EINGEBEN
  • VERLASSEN
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PUSH – Auf den Stapel schieben ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PUSH – Auf den Stapel schieben operand[, operand]

PBXB64-Verwendung

PUSH – Auf den Stapel schieben ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PUSH – Auf den Stapel schieben ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PUSHA / PUSHAD – Alle Allzweckregister pushen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › PUSHA / PUSHAD – Alle Allzweckregister pushen
Hilfe zum PBXB64-Compiler

PUSHA / PUSHAD – Alle Allzweckregister pushen

Speichert alle Allzweckregister in einem einzigen Befehl auf dem Stapel.

Typ: Anleitung | Kategorie: x64-Stack

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

PUSHA    ' 16-bit operands
PUSHAD   ' 32-bit operands

Betrieb

Schiebt AX, CX, DX, BX, SP, BP, SI, DI auf den Stapel (in dieser Reihenfolge für PUSHA). PUSHAD verwendet die 32-Bit-Äquivalente. Diese Anweisungen sind im 64-Bit-Modus nicht verfügbar. Verwenden Sie stattdessen einzelne PUSH-Anweisungen.

Flaggen

Es sind keine Flaggen betroffen.

Beispiel

FUNCTION PBMAIN() AS LONG
  ' Note: in x64 mode use individual pushes
  ! push rax
  ! push rbx
  FUNCTION = 0
END FUNCTION

When to use

Verwenden Sie PUSHA/PUSHAD in 16-Bit- oder 32-Bit-Code, um den Registerkontext zu speichern. Pushen Sie im x64-Code die Register einzeln.

Siehe auch

  • POPA
  • DRÜCKEN
  • POP

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PUSHA / PUSHAD – Alle Allzweckregister pushen ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PUSHA / PUSHAD – Alle Allzweckregister pushen operand[, operand]

PBXB64-Verwendung

PUSHA / PUSHAD – Alle Allzweckregister pushen ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PUSHA / PUSHAD – Alle Allzweckregister pushen ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


PXOR – Bitweises logisches XOR für MMX/XMM – PBXB64 Assembler-Hilfe

Startseite › Funktionen › PXOR – Bitweises logisches XOR für MMX/XMM
Hilfe zum PBXB64-Compiler

PXOR – Bitweises logisches XOR für MMX/XMM

Führt ein bitweises XOR von gepackten ganzzahligen Operanden in MMX- oder XMM-Registern durch.

Kategorie: MMX/Logisch | Gruppe: Logisch verpackt

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

PXOR mm1, mm2/m64
PXOR xmm1, xmm2/m128

Operanden

Formular | Beschreibung | Beispiel
PXOR mm1, mm2 | Bitweises XOR von zwei 64-Bit-MMX-Registern. | pxor mm0, mm1
PXOR xmm1, xmm2 | Bitweises XOR von zwei 128-Bit-XMM-Registern. | pxor xmm0, xmm1
PXOR xmm1, m128 | Bitweises XOR eines XMM-Registers und eines 128-Bit-Speichers. | pxor xmm0, [key]

Beschreibung

PXOR Berechnet das bitweise XOR der gepackten Ganzzahloperanden des Ziels und der Quelle. Es ist das SIMD-Äquivalent der Ganzzahl XOR Anweisung und ist eine der am häufigsten verwendeten SSE-Anweisungen zum Löschen von Registern und zum Kombinieren von Daten.

Eine klassische Redewendung ist pxor xmm0, xmm0, wodurch ein XMM-Register in weniger Bytes und mit weniger Abhängigkeiten auf Null gesetzt wird als mov von einem auf Null gesetzten Speicherort.

Flaggen

Keiner betroffen.

Codierungsnotizen

  • Opcode 0F EF /r sowohl für MMX- als auch für XMM-Kodierungen.
  • Mit VEX/EVEX-Präfixen lautet die Anweisung VPXOR.

Beispiele

; Clear an XMM register
pxor xmm0, xmm0

; XOR 128 bits of data with a key
movdqa xmm0, [plaintext]
pxor   xmm0, [key]
movdqa [ciphertext], xmm0

; MMX XOR
pxor mm0, mm1

When to use

VerwendenPXOR für SIMD XOR, Registernullung, Kryptografieprimitive und Umschaltbits. Dies ist die bevorzugte Methode zum Nullsetzen eines XMM-Registers.

Siehe auch

  • PAND
  • PANDN
  • POR
  • XOR

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

PXOR – Bitweises logisches XOR für MMX/XMM ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

PXOR – Bitweises logisches XOR für MMX/XMM operand[, operand]

PBXB64-Verwendung

PXOR – Bitweises logisches XOR für MMX/XMM ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! PXOR – Bitweises logisches XOR für MMX/XMM ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RCL/RCR/ROL/ROR – Anweisungen zum Drehen – PBXB64 Assembler-Hilfe

Startseite › Funktionen › RCL/RCR/ROL/ROR – Anweisungen zum Drehen
Hilfe zum PBXB64-Compiler

RCL/RCR/ROL/ROR – Anweisungen zum Drehen

Dreht die Bits des Zieloperanden nach links oder rechts, optional über das Übertragsflag.

Kategorie: Verschieben/Drehen | Gruppe: Drehen

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

ROL  r/m8, 1
ROL  r/m8, CL
ROL  r/m8, imm8
ROL  r/m16|32|64, 1
ROL  r/m16|32|64, CL
ROL  r/m16|32|64, imm8

ROR  r/m, ...      ; same forms as ROL
RCL  r/m, ...      ; same forms as ROL
RCR  r/m, ...      ; same forms as ROL

Operanden

Formular | Beschreibung | Beispiel
ROL r64, 1 | 64-Bit-Register um 1 Bit nach links drehen. | rol rax, 1
ROR r32, CL | Rotiert das 32-Bit-Register um die Anzahl in CL nach rechts. | ror eax, cl
RCL r8, imm8 | 8-Bit-Register sofort durch Übertrag nach links drehen. | rcl al, 3
RCR m16, 1 | Rotieren Sie den 16-Bit-Speicher durch den Übertrag um 1. | rcr word [val], 1

Beschreibung

Die Rotationsanweisungen verschieben die Bits des Zieloperanden zirkulär. Bits, die ein Ende verlassen, treten am anderen Ende wieder ein, sodass keine Informationen verloren gehen.

  • ROL (Nach links drehen): Bits verschieben sich zu höherwertigen Positionen; Das MSB wird zum LSB und zum CF umgeschaltet.
  • ROR (Nach rechts drehen): Bits werden in Richtung weniger signifikanter Positionen verschoben; das LSB wickelt sich um zum MSB und zum CF.
  • RCL (Rotate through Carry Left): Behandelt CF als eine Ein-Bit-Erweiterung über dem MSB. Der Operand und CF rotieren zusammen als 9-, 17-, 33- oder 65-Bit-Feld.
  • RCR (Rotate through Carry Right): Behandelt CF als eine Ein-Bit-Erweiterung unterhalb des LSB. Der Operand und CF rotieren zusammen.

Der Schiebezähler kann 1, der Inhalt des CL-Registers oder ein 8-Bit-Direktwert sein. Bei 64-Bit-Operanden wird die Anzahl modulo der Operandengröße maskiert.

Flaggen

CF wird auf das letzte herausrotierte Bit gesetzt. OF ist nur für 1-Bit-Rotationen definiert: Es wird auf das XOR der beiden höchstwertigen Bits nach einer Linksrotation oder auf das XOR der beiden höchstwertigen Bits nach einer Rechtsrotation gesetzt. Für Multibit-Rotationen ist OF undefiniert. SF, ZF, AF, PF sind bei Multi-Bit-Rotationen nicht betroffen; für 1-Bit-Rotationen sind sie undefiniert.

Codierungsnotizen

  • ROL/RCL: Opcode D0 /0 (8-Bit, Anzahl=1), D1 /0 (32.16.64, Anzahl=1), D2 /0 (8-Bit, CL), D3 /0 (32.16.64, CL), C0 /0 ib (8-Bit, imm), C1 /0 ib (32.16.64, imm).
  • ROR/RCR: Gleiche Opcodes mit ModR/M-Registrierungsfeld /1 statt /0.
  • REX.W ist für die 64-Bit-Operandengröße erforderlich.

Beispiele

; Rotate left by 1
rol rax, 1

; Rotate right by count in CL
mov cl, 4
ror ebx, cl

; 9-bit rotate through carry
stc
rcl al, 1        ; CF becomes old bit 7, bit 0 becomes old CF

; 65-bit rotate through carry
rcr rax, 1

When to use

VerwendenROL/ROR für Bitpermutationen, Hashing und Extrahieren von Bitfeldern ohne Datenverlust. Benutzen RCL/RCR für Multipräzisionsverschiebungen und Algorithmen, die den Übertrag über eine Kette von Operanden weitergeben müssen.

Siehe auch

  • SHL
  • SHR
  • SAR
  • ADC

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

RCL/RCR/ROL/ROR – Anweisungen zum Drehen ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

RCL/RCR/ROL/ROR – Anweisungen zum Drehen operand[, operand]

PBXB64-Verwendung

RCL/RCR/ROL/ROR – Anweisungen zum Drehen ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! RCL/RCR/ROL/ROR – Anweisungen zum Drehen ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RDTSC – Zeitstempelzähler lesen – PBXB64 Assembler-Hilfe

Startseite › Funktionen › RDTSC – Zeitstempelzähler lesen

RDTSC – Zeitstempelzähler lesen

Liest den Zeitstempelzähler des 64-Bit-Prozessors in EDX:EAX.

Kategorie: System/Atom | Gruppe: Systemanweisungen

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

RDTSC

Operanden

Formular | Beschreibung | Beispiel
RDTSC | Keine Operanden; liest den TSC in EDX:EAX. | rdtsc

Beschreibung

RDTSC (Zeitstempelzähler lesen) lädt den aktuellen Wert des 64-Bit-Zeitstempelzählers in das EDX:EAX-Registerpaar. EAX empfängt die Bits 31:0 des TSC und EDX empfängt die Bits 63:32. Der TSC erhöht sich mit einer festen Rate (historisch die Nennfrequenz des Prozessors) und wird häufig für Timing, Profilerstellung und Benchmarking verwendet.

Auf modernen Prozessoren ist der TSC über alle Kerne und Energiezustände hinweg unveränderlich, auf älteren Systemen hingegen ist die Software-Serialisierung (z. B. CPUID vorher und nachher, oder die RDTSCP Für genaue Messungen über Kernmigrationen hinweg kann eine Anleitung erforderlich sein.

Flaggen

Keiner betroffen.

Codierungsnotizen

  • Zwei-Byte-Opcode 0F 31.
  • Der Befehl ist nicht privilegiert, es sei denn, das TSD-Bit (CR4.TSD) ist gesetzt und CPL > 0; Im normalen Benutzermoduscode wird es fehlerfrei ausgeführt.
  • Bei 64-Bit-Code wird das Ergebnis weiterhin in EDX:EAX abgelegt; RDX und RAX werden nicht gekürzt, aber die oberen 32 Bits von jedem werden durch das implizite 32-Bit-Registerschreiben auf Null gesetzt.

Beispiele

; Simple timing of a code block
cpuid              ; serialize
rdtsc
mov  [tsc_start], eax
mov  [tsc_start+4], edx

; ... code to benchmark ...

cpuid              ; serialize
rdtsc
sub  eax, [tsc_start]
sbb  edx, [tsc_start+4]   ; edx:eax = elapsed TSC ticks

When to use

VerwendenRDTSC für hochauflösendes Timing, Profilierung von Hot Loops und Seeding von Zufallszahlengeneratoren. Für tragbares Benchmarking bevorzugen Sie RDTSCP oder die QueryPerformanceCounter Windows-API zur Vermeidung von Problemen mit Ausführung außerhalb der Reihenfolge und Kernmigration.

Siehe auch

  • CPUID
  • PAUSE
  • INT3

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

RDTSC – Zeitstempelzähler lesen ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

RDTSC – Zeitstempelzähler lesen operand[, operand]

PBXB64-Verwendung

RDTSC – Zeitstempelzähler lesen ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! RDTSC – Zeitstempelzähler lesen ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


REP – PBXB64 Assembler-Hilfe

Startseite › Funktionen › REP – PBXB64 Assembler-Hilfe

REP / REPE / REPNE – Präfix wiederholen

Wiederholt einen String-Befehl RCX-mal (oder bis die Bedingung erfüllt ist).

Kategorie: String-Operationen | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

REP string_instruction
REPE / REPZ string_instruction
REPNE / REPNZ string_instruction

Beschreibung

  • REP: Wiederholen, bis RCX=0. Wird mit MOVS, STOS verwendet.
  • REPE/REPZ: Wiederholen, während gleich/null und RCX!=0. Wird mit CMPS, SCAS verwendet.
  • REPNE/REPNZ: Wiederholen, solange ungleich/ungleich Null und RCX!=0. Wird mit CMPS, SCAS verwendet.

Beispiele

rep movsb                    ; copy RCX bytes from RSI to RDI
rep stosd                    ; fill RCX dwords with EAX
repne scasb                  ; scan for AL in [RDI]

Siehe auch

  • MOVS
  • STOS
  • SCAS
  • CMPS
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

REP / REPE / REPNE – Präfix wiederholen ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

REP / REPE / REPNE – Präfix wiederholen operand[, operand]

PBXB64-Verwendung

REP / REPE / REPNE – Präfix wiederholen ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! REP / REPE / REPNE – Präfix wiederholen ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


RET – PBXB64 Assembler-Hilfe

Startseite › Funktionen › RET – PBXB64 Assembler-Hilfe

RET – Rückkehr vom Verfahren

Entfernt die Rücksprungadresse vom Stapel und setzt die Ausführung beim Aufrufer fort.

Kategorie: Kontrollübertragung | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

RET
RET imm16

Beschreibung

Entnimmt die Rücksprungadresse vom Stapel (RSP wird um 8 erhöht) und springt dorthin. Der optionale Direktoperand gibt zusätzliche Bytes an, die vom Stapel entfernt werden sollen (zum Bereinigen von Argumenten in Callee-Cleanup-Konventionen).

Beispiele

ret
ret 32                    ; pop 32 extra bytes after return

Siehe auch

  • CALL
  • JMP
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

RET – Rückkehr vom Verfahren ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

RET – Rückkehr vom Verfahren operand[, operand]

PBXB64-Verwendung

RET – Rückkehr vom Verfahren ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! RET – Rückkehr vom Verfahren ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SAR – PBXB64 Assembler-Hilfe

Startseite › Funktionen › SAR – PBXB64 Assembler-Hilfe

SAR – Arithmetische Verschiebung nach rechts

Verschiebt den Operanden nach rechts, wobei das Vorzeichenbit (MSB) erhalten bleibt.

Kategorie: Verschieben/Drehen | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SAR dst, imm8
SAR dst, CL

Beschreibung

Verschiebt Bits nach rechts. Die frei gewordenen High-Bits werden mit dem ursprünglichen Vorzeichenbit gefüllt (Bit 63 für 64-Bit, Bit 31 für 32-Bit). Zur vorzeichenbehafteten Division durch Zweierpotenzen verwenden.

Beispiele

sar rax, 1                  ; signed divide by 2
sar eax, 2                  ; signed divide by 4 (32-bit)

Siehe auch

  • SHR
  • SHL
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SAR – Arithmetische Verschiebung nach rechts ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SAR – Arithmetische Verschiebung nach rechts operand[, operand]

PBXB64-Verwendung

SAR – Arithmetische Verschiebung nach rechts ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SAR – Arithmetische Verschiebung nach rechts ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SBB – Subtrahieren mit Ausleihen – PBXB64 Assembler-Hilfe

Startseite › Funktionen › SBB – Subtrahieren mit Ausleihen

SBB – Subtrahieren mit Ausleihen

Subtrahiert den Quelloperanden und das Übertragsflag (CF) vom Zieloperanden.

Kategorie: Arithmetik | Gruppe: Ganzzahlige binäre Arithmetik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SBB dest, src

Operanden

Formular | Beschreibung | Beispiel
r/m64, r64 | Subtrahieren Sie Register und CF vom 64-Bit-R/M-Operanden | sbb rax, rbx
r/m32, r32 | Subtrahieren Sie Register und CF vom 32-Bit-R/M-Operanden | sbb eax, ecx
R/M16, R16 | Subtrahieren Sie Register und CF vom 16-Bit-R/M-Operanden | sbb Axt, dx
r/m8, r8 | Subtrahieren Sie Register und CF vom 8-Bit-R/M-Operanden | sbb al, cl
R64, R/M64 | Subtrahieren Sie r/m und CF vom 64-Bit-Register | sbb rax, [rsi]
R32, R/M32 | Subtrahieren Sie r/m und CF vom 32-Bit-Register | sbb eax, [mem]
r/m64, imm32 | Subtrahieren Sie vorzeichenerweiterte Sofortwerte und CF | sbb rax, 1
r/m32, imm32 | Subtrahieren Sie Sofort und CF | sbb eax, 100
r/m16, imm16 | Subtrahieren Sie 16-Bit-Sofortwert und CF | sbb Axt, 0x10
r/m8, imm8 | Subtrahieren Sie 8-Bit-Sofortwert und CF | sbb bl, 5

Beschreibung

DerSBB Der Befehl (Subtract with Borrow) führt eine ganzzahlige Subtraktion des Quelloperanden und des Übertragsflags vom Zieloperanden durch. Das Ergebnis wird im Ziel gespeichert. Mathematisch gesehen, dest = dest - src - CF. Es ist für die Multipräzisionssubtraktion (Mehrwortsubtraktion) konzipiert, bei der die Anleihe aus einer vorherigen Subtraktion niedrigerer Ordnung in das Wort nächsthöherer Ordnung übertragen werden muss.

Für jede Operandengröße verwendet die Operation die natürliche Breite: 8, 16, 32 oder 64 Bit. Wenn ein 32-Bit-Registerziel im 64-Bit-Modus verwendet wird, werden die oberen 32 Bits des Ziels auf Null gesetzt.

Flaggen

Beeinflusst OF, SF, ZF, AF, PF, UndCF entsprechend dem Ergebnis. CF wird gesetzt, wenn eine Ausleihe erforderlich ist (dest < src + CF), andernfalls gelöscht.

Codierungsnotizen

  • Verwendet Opcode 0x1B (reg von r/m), 0x19 (r/m von reg), oder 0x1C/0x1D (Akkumulator-Sofortformen).
  • Unmittelbare Formen mit kleinen Kodierungen bevorzugen die Kurzformen, wenn das Ziel AL/AX/EAX/RAX ist.
  • Das REX-Präfix ist für die 64-Bit-Operandengröße und für erweiterte Register (R8–R15) erforderlich.

Beispiele

; 128-bit subtraction: high:low = high:low - yh:yl
mov rax, [low]
mov rdx, [high]
sub rax, [yl]      ; subtract low parts
sbb rdx, [yh]      ; subtract high parts with borrow
mov [low], rax
mov [high], rdx

When to use

VerwendenSBB bei der Durchführung einer Subtraktion mit erweiterter Genauigkeit über die native Registerbreite hinaus, z. B. 128-Bit-Ganzzahlarithmetik oder Bibliotheken für große Zahlen. Es wird selten für die gewöhnliche Skalarsubtraktion verwendet; verwenden SUB stattdessen, wenn keine Kreditausbreitung erforderlich ist.

Siehe auch

  • SUB
  • ADC
  • HINZUFÜGEN

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SBB – Subtrahieren mit Ausleihen ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SBB – Subtrahieren mit Ausleihen operand[, operand]

PBXB64-Verwendung

SBB – Subtrahieren mit Ausleihen ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SBB – Subtrahieren mit Ausleihen ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SCAS - Scan String - PBXB64 Compiler Help

Startseite › x64 Backend › Instruction Detail Pages › Miscellaneous › SCAS - Scan String
Hilfe zum PBXB64-Compiler

SCAS - Scan String

Compares AL, AX, EAX, or RAX with the memory item addressed by RDI and advances or decrements RDI based on the direction flag.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

Compares AL, AX, EAX, or RAX with the memory item addressed by RDI and advances or decrements RDI based on the direction flag.

Verwendung in PBXB64

SCAS is commonly used with repeat prefixes for byte or word searches. Initialize RDI, RCX, the accumulator register, and the direction flag.

Beispiel

cld
mov al, 0
repne scasb

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SCAS ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SCAS operand[, operand]

PBXB64-Verwendung

SCAS ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SCAS ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.


SETcc – Byte auf Bedingung setzen – PBXB64 Assembler-Hilfe

Startseite › Funktionen › SETcc – Byte auf Bedingung setzen

SETcc – Byte auf Bedingung setzen

Setzt das Zielbyte auf 1, wenn die angegebene Bedingung wahr ist, andernfalls 0.

Kategorie: Datenbewegung | Gruppe: Bedingter Bytesatz

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SETcc r/m8

Operanden

Formular | Beschreibung | Beispiel
r/m8 | 8-Bit-Register oder Speicherort zum Empfang von 0 oder 1 | sete al
r8 | Low-Byte eines Allzweckregisters | setnz bl
m8 | Byte im Speicher | setg [Flagge]

Beschreibung

DerSETcc Die Familie speichert ein boolesches Byte (0 oder 1) basierend auf dem aktuellen Status des EFLAGS-Registers im Ziel. Der Bedingungscode cc ist das gleiche Suffix, das von bedingten Sprüngen verwendet wird (Jcc) und bedingte Züge. Das Ziel wird nie über das Low-Byte hinaus geändert; Hohe Bytes eines 16/32/64-Bit-Registers bleiben erhalten.

Von dieser Seite abgedeckte Aliase:

  • SETO, SETNO – Überlauf / nicht Überlauf
  • SETB, SETC, SETNAE / SETAE, SETNB, SETNC – Übertrag / über-oder-gleich (ohne Vorzeichen)
  • SETE, SETZ / SETNE, SETNZ – gleich / ungleich
  • SETBE, SETNA / SETA, SETNBE – unter-oder-gleich / darüber (ohne Vorzeichen)
  • SETS / SETNS – unterschreiben / nicht unterschreiben
  • SETP, SETPE / SETNP, SETPO — Parität / nicht Parität
  • SETL, SETNGE / SETGE, SETNL — kleiner/größer-gleich (mit Vorzeichen)
  • SETLE, SETNG / SETG, SETNLE — kleiner oder gleich / größer (mit Vorzeichen)

Flaggen

Keines davon SETcc Anweisungen ändern EFLAGS.

Codierungsnotizen

  • Der primäre Opcode ist 0x0F 0x90 + cc, wo cc ist der 4-Bit-Bedingungsindex.
  • Speicherziele verwenden das Standard-ModR/M-Byte; Das REX-Präfix ist für erweiterte Register oder den 64-Bit-Modus SPL/BPL/SIL/DIL erforderlich.
  • Es gibt keine unmittelbare oder Register-zu-Register-Kurzform; Alle Formen sind Zwei-Byte-Opcode + ModR/M.

Beispiele

; Convert signed comparison result to a boolean byte
cmp eax, ebx
setg al          ; al = 1 if eax > ebx (signed), else 0

; Unsigned bounds check
movzx eax, byte [count]
cmp eax, 100
setbe [valid]    ; valid = 1 if count <= 100 (unsigned)

; Zero test without destroying operand
test rcx, rcx
setnz [has_data]

When to use

VerwendenSETcc wenn Sie ein Vergleichsergebnis als 0/1-Byte für die Speicherung, Bitpackung oder spätere Arithmetik materialisieren müssen. Dies ist die kanonische Methode, Flags ohne Verzweigung in einen booleschen Wert im C-Stil umzuwandeln.

Siehe auch

  • Jcc
  • CMOVcc
  • CMP
  • TEST

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SETcc – Byte auf Bedingung setzen ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SETcc – Byte auf Bedingung setzen operand[, operand]

PBXB64-Verwendung

SETcc – Byte auf Bedingung setzen ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SETcc – Byte auf Bedingung setzen ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SFENCE – Store Fence – PBXB64 Assembler-Hilfe

Startseite › Funktionen › SFENCE – Store Fence

SFENCE – Ladenzaun

Bestellt alle vorherigen Filialvorgänge vor allen nachfolgenden Filialvorgängen.

Kategorie: Erinnerungszaun | Gruppe:Anweisungen zur Speicherbestellung

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SFENCE

Operanden

Formular | Beschreibung | Beispiel
keiner | Keine Operanden; Arbeitet global an der Speicherordnung | Zaun

Beschreibung

DerSFENCE Die Anweisung garantiert, dass jeder Speicherzugriff, der in der Programmreihenfolge logisch vor dem Zaun liegt, global vor jedem Speicher sichtbar ist, der dem Zaun logisch folgt. Es ist ein von Laden zu Laden nur Zaun; Es werden keine Ladungen gegen Lager oder Ladungen gegen Ladungen angeordnet.

Auf x86 verfügen gewöhnliche Speicher bereits über eine stark geordnete Sichtbarkeit für zwischenspeicherbaren Speicher, nicht-temporale Speicher (wie z. B. die von generierten). MOVNT* Streaming-Store-Anweisungen) sind schwach geordnet. SFENCE ist in erster Linie nach nicht temporären Geschäften erforderlich, um sicherzustellen, dass sie vor nachfolgenden Geschäften sichtbar werden. Für normale gesperrte oder atomare Operationen sind stärkere Zäune (MFENCE oder gesperrte Anweisungen) erforderlich sein.

Flaggen

Es sind keine Flaggen betroffen.

Codierungsnotizen

  • Codiert als 0x0F 0xAE /7 mit ModR/M-Byte 0xF8 (mod=11, reg=111, r/m=000).
  • Nicht verwechseln mit MFENCE (0F AE F0) oder LFENCE (0F AE E8), die unterschiedliche ModR/M-Registrierungsfelder verwenden.

Beispiele

; Ensure streaming stores are visible before continuing
movntdq [rdi], xmm0
movntdq [rdi+16], xmm1
sfence

; Producer flag publication after a buffer fill
mov [buffer], rax
mov [ready], 1
sfence

When to use

VerwendenSFENCE nach nicht vorübergehenden Streaming-Shops oder wenn Sie eine Shop-Bestellung ohne die vollen Kosten sicherstellen müssen MFENCE. Für die allgemeine Inter-Thread-Synchronisierung auf x86 bevorzugen Sie gesperrte atomare Anweisungen (z. B. LOCK XADD, LOCK CMPXCHG), die eine vollständige Speicherbestellung ermöglichen.

Siehe auch

  • MFENCE
  • LFENCE
  • SPERREN

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SFENCE – Ladenzaun ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SFENCE – Ladenzaun operand[, operand]

PBXB64-Verwendung

SFENCE – Ladenzaun ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SFENCE – Ladenzaun ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SHL – PBXB64 Assembler-Hilfe

Startseite › Funktionen › SHL – PBXB64 Assembler-Hilfe

SHL / SAL – Nach links verschieben

Verschiebt den Operanden um die angegebene Anzahl von Bits nach links und verschiebt dabei Nullen von rechts.

Kategorie: Verschieben/Drehen | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SHL dst, imm8
SHL dst, CL

Beschreibung

Verschiebt Bits nach links. Das letzte herausgeschobene Bit geht in CF. Die frei gewordenen Low-Bits werden mit Nullen aufgefüllt. OF wird nur für 1-Bit-Verschiebungen gesetzt. SF, ZF, PF werden entsprechend dem Ergebnis eingestellt.

Beispiele

shl rax, 1                  ; multiply by 2
shl rax, 3                  ; multiply by 8
shl rax, cl                 ; shift by CL

Siehe auch

  • SHR
  • SAR
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SHL / SAL – Nach links verschieben ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SHL / SAL – Nach links verschieben operand[, operand]

PBXB64-Verwendung

SHL / SAL – Nach links verschieben ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SHL / SAL – Nach links verschieben ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SHR – PBXB64 Assembler-Hilfe

Startseite › Funktionen › SHR – PBXB64 Assembler-Hilfe

SHR – Logische Rechtsverschiebung

Verschiebt den Operanden um die angegebene Anzahl von Bits nach rechts und verschiebt dabei Nullen von links.

Kategorie: Verschieben/Drehen | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SHR dst, imm8
SHR dst, CL

Beschreibung

Verschiebt Bits nach rechts. Das letzte herausgeschobene Bit geht in CF. Die frei gewordenen High-Bits werden mit Nullen aufgefüllt. Zur vorzeichenlosen Division durch Zweierpotenzen verwenden.

Beispiele

shr rax, 1                  ; unsigned divide by 2
shr rax, 4                  ; unsigned divide by 16

Siehe auch

  • SAR
  • SHL
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SHR – Logische Rechtsverschiebung ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SHR – Logische Rechtsverschiebung operand[, operand]

PBXB64-Verwendung

SHR – Logische Rechtsverschiebung ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SHR – Logische Rechtsverschiebung ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SQRTSD – Skalare Gleitkomma-Quadratwurzel mit doppelter Genauigkeit – PBXB64 Assembler-Hilfe

Startseite › Funktionen › SQRTSD – Skalare Gleitkomma-Quadratwurzel mit doppelter Genauigkeit
Hilfe zum PBXB64-Compiler

SQRTSD – Skalare Gleitkomma-Quadratwurzel mit doppelter Genauigkeit

Berechnet die Quadratwurzel des Gleitkommawerts mit niedriger doppelter Genauigkeit.

Kategorie: SSE/AVX | Gruppe: SSE2 Skalare Gleitkomma-Arithmetik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SQRTSD xmm1, xmm2/m64

Operanden

Formular | Beschreibung | Beispiel
xmm, xmm | Quelle und Ziel sind 128-Bit-XMM-Register | sqrtsd xmm0, xmm1
xmm, m64 | Ziel ist das XMM-Register; Quelle ist 64-Bit-Speicher | sqrtsd xmm0, [x]

Beschreibung

SQRTSD berechnet die Quadratwurzel des niedrigen 64-Bit-Gleitkommawerts mit doppelter Genauigkeit aus dem Quelloperanden und speichert das Ergebnis im niedrigen Quadword des Ziel-XMM-Registers. Das obere Quadwort (Bits 64–127) des Ziels bleibt erhalten. Das ist ein Skalar Bedienung: nur eine double Wert wird verarbeitet.

Sonderfälle folgen den IEEE-754-Regeln: sqrt(+0)=+0, sqrt(-0)=-0, sqrt(+inf)=+inf, sqrt einer negativen endlichen Zahl gibt ein stilles NaN zurück und setzt das Ausnahmeflag für ungültige Operationen.

Flaggen

Es sind keine EFLAGS betroffen. MXCSR-Flags (IE, DE, ZE, OE, UE, PE) können entsprechend dem Ergebnis aktualisiert werden.

Codierungsnotizen

  • SSE2-Kodierung: F2 0F 51 /r.
  • DerF2 Präfix wählt skalare Semantik mit doppelter Genauigkeit aus.
  • VEX/EVEX-Formulare (AVX/AVX-512) existieren als VSQRTSD mit drei Operanden und Zusammenführung/Maskierung; PBXB64 zielt auf das SSE2-Basisformular ab.

Beispiele

; Compute sqrt(x) where x is a double in memory
movsd xmm0, [x]
sqrtsd xmm0, xmm0
movsd [result], xmm0

; sqrt of one value into another register, preserving upper bits
movsd xmm2, xmm0
sqrtsd xmm1, xmm2     ; xmm1[63:0] = sqrt(xmm2[63:0]); upper bits unchanged

When to use

VerwendenSQRTSD für Skalar double (64-Bit) Gleitkomma-Quadratwurzeln, z. B. zur Berechnung von Abständen, Normen oder anderen mathematischen Routinen, die erforderlich sind sqrt(double). Für skalare Quadratwurzeln mit einfacher Genauigkeit verwendenSQRTSS; für den gepackten Einsatz mit doppelter Genauigkeit SQRTPD.

Siehe auch

  • SQRTSS
  • HINZUFÜGEN
  • MULSD
  • DIVSD

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SQRTSD – Skalare Gleitkomma-Quadratwurzel mit doppelter Genauigkeit ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SQRTSD – Skalare Gleitkomma-Quadratwurzel mit doppelter Genauigkeit operand[, operand]

PBXB64-Verwendung

SQRTSD – Skalare Gleitkomma-Quadratwurzel mit doppelter Genauigkeit ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SQRTSD – Skalare Gleitkomma-Quadratwurzel mit doppelter Genauigkeit ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SQRTSS – Skalare Gleitkomma-Quadratwurzel mit einfacher Genauigkeit – PBXB64 Assembler-Hilfe

Startseite › Funktionen › SQRTSS – Skalare Gleitkomma-Quadratwurzel mit einfacher Genauigkeit
Hilfe zum PBXB64-Compiler

SQRTSS – Skalare Gleitkomma-Quadratwurzel mit einfacher Genauigkeit

Berechnet die Quadratwurzel des Gleitkommawerts mit niedriger einfacher Genauigkeit.

Kategorie: SSE/AVX | Gruppe: SSE Skalare Gleitkomma-Arithmetik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SQRTSS xmm1, xmm2/m32

Operanden

Formular | Beschreibung | Beispiel
xmm, xmm | Quelle und Ziel sind 128-Bit-XMM-Register | sqrtss xmm0, xmm1
xmm, m32 | Ziel ist das XMM-Register; Quelle ist 32-Bit-Speicher | sqrtss xmm0, [x]

Beschreibung

SQRTSS Berechnet die Quadratwurzel des niedrigen 32-Bit-Gleitkommawerts mit einfacher Genauigkeit aus dem Quelloperanden und speichert das Ergebnis im niedrigen Dword des Ziel-XMM-Registers. Die Bits 32–127 des Ziel-XMM-Registers bleiben erhalten. Das ist ein Skalar Bedienung: nur eine float Wert wird verarbeitet.

IEEE-754-Sonderfallverhaltensübereinstimmungen SQRTSD: Positive Null und positive Unendlichkeit sind Identitätswerte, negative Eingaben erzeugen ein ruhiges NaN und denormale Eingaben werden gemäß den aktuellen MXCSR DAZ/FTZ-Einstellungen behandelt.

Flaggen

Es sind keine EFLAGS betroffen. MXCSR-Ausnahmeflags können aktualisiert werden.

Codierungsnotizen

  • SSE-Kodierung: F3 0F 51 /r.
  • DerF3 Präfix wählt skalare Semantik mit einfacher Genauigkeit aus.
  • Nicht mit verpackt verwechseln SQRTPS (0F 51 /r), der vier Floats verarbeitet.

Beispiele

; Compute sqrt(x) where x is a float in memory
movss xmm0, [x]
sqrtss xmm0, xmm0
movss [result], xmm0

; Scalar sqrt into a different register
sqrtss xmm1, xmm0    ; xmm1[31:0] = sqrt(xmm0[31:0]); upper bits unchanged

When to use

VerwendenSQRTSS für Skalar float (32-Bit) Gleitkomma-Quadratwurzeln. Es ist schneller und kleiner als die Konvertierung in Double SQRTSDund Rückkonvertierung, wenn einfache Genauigkeit ausreicht.

Siehe auch

  • SQRTSD
  • ADDSS
  • MULSS
  • DIVSS

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SQRTSS – Skalare Gleitkomma-Quadratwurzel mit einfacher Genauigkeit ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SQRTSS – Skalare Gleitkomma-Quadratwurzel mit einfacher Genauigkeit operand[, operand]

PBXB64-Verwendung

SQRTSS – Skalare Gleitkomma-Quadratwurzel mit einfacher Genauigkeit ist eine SIMD/FPU Instruktion fuer floating-point or vector code. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SQRTSS – Skalare Gleitkomma-Quadratwurzel mit einfacher Genauigkeit ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


STC / CLC / CMC – PBXB64 Assembler-Hilfe

Startseite › Funktionen › STC / CLC / CMC – PBXB64 Assembler-Hilfe
Hilfe zum PBXB64-Compiler

STC / CLC / CMC – Carry Flag Control

Manipuliert das Carry Flag (CF) direkt.

Kategorie: Flaggensteuerung | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

STC                          ; Set Carry Flag (CF=1)
CLC                          ; Clear Carry Flag (CF=0)
CMC                          ; Complement Carry Flag (CF=!CF)

Beschreibung

Manipuliert direkt die Carry-Flagge. Wird vor ADC/SBB zum Einrichten des Carry-Ins oder nach arithmetischen Operationen zum Testen/Manipulieren von CF verwendet.

Beispiele

clc
adc rax, rbx                 ; rax = rax + rbx + 0

stc
sbb rax, rbx                 ; rax = rax - rbx - 1

Siehe auch

  • ADC
  • SBB
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

STC / CLC / CMC – Carry Flag Control ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

STC / CLC / CMC – Carry Flag Control operand[, operand]

PBXB64-Verwendung

STC / CLC / CMC – Carry Flag Control ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! STC / CLC / CMC – Carry Flag Control ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


STD – Richtungsflag setzen – PBXB64-Compiler-Hilfe

Startseite › Funktionen › STD – Richtungsflagge setzen

STD – Richtungsflagge setzen

Setzt das Richtungsflag (DF = 1), wodurch String-Anweisungen ihre Indexregister dekrementieren.

Typ: Anleitung | Kategorie: x64-Flags

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

STD

Betrieb

DF = 1. Nach STD dekrementieren String-Anweisungen wie MOVS, STOS und SCAS RSI/RDI und ermöglichen so eine Verarbeitung in umgekehrter Richtung.

Flaggen

DF ist eingestellt; Alle anderen Flags bleiben davon unberührt.

Beispiel

FUNCTION PBMAIN() AS LONG
  ! std
  ' Now string operations will auto-decrement
  FUNCTION = 0
END FUNCTION

When to use

Verwenden Sie STD, wenn Sie Zeichenfolgen oder Puffer von hohen Adressen bis zu niedrigen Adressen verarbeiten. Wenn Sie fertig sind, koppeln Sie es immer mit CLD, um die Standardvorwärtsrichtung wiederherzustellen.

Siehe auch

  • CLD
  • MOVS
  • STOS

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

STD – Richtungsflagge setzen ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

STD – Richtungsflagge setzen operand[, operand]

PBXB64-Verwendung

STD – Richtungsflagge setzen ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! STD – Richtungsflagge setzen ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


STOS – Store String – PBXB64 Assembler-Hilfe

Startseite › Funktionen › STOS – String speichern

STOS – Zeichenfolge speichern

Speichert das Akkumulatorregister (AL, AX, EAX, oderRAX) auf den Speicherort, auf den verwiesen wird RDI, dann Updates RDI.

Kategorie: Zeichenfolge | Gruppe: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

STOSB
STOSW
STOSD
STOSQ

Operanden

Das Ziel ist implizit: [RDI]. Die Quelle ist implizit in AL/AX/EAX/RAX.

Beschreibung

Schreibt den Akkumulator in den Speicher und schreitet fort RDI entsprechend der Operandengröße und dem Richtungsflag.

Flaggen

Es sind keine Flaggen betroffen.

Beispiele

cld
mov rdi, buffer
mov rcx, 256
xor rax, rax
rep stosq       ; zero 256 qwords

When to use

VerwendenSTOS um den Speicher mit einem wiederholten Wert zu füllen, z. B. durch das Nullsetzen von Puffern oder das Initialisieren von Arrays.

Siehe auch

  • REP-Präfix
  • MOVS
  • MOV

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

STOS – Zeichenfolge speichern ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

STOS – Zeichenfolge speichern operand[, operand]

PBXB64-Verwendung

STOS – Zeichenfolge speichern ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! STOS – Zeichenfolge speichern ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SUB – PBXB64 Assembler-Hilfe

Startseite › Funktionen › SUB – PBXB64 Assembler-Hilfe

SUB – Ganzzahlige Subtraktion

Subtrahiert den Quelloperanden vom Zieloperanden und speichert das Ergebnis im Ziel.

Kategorie: Arithmetik | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SUB dst, src

Beschreibung

Führt durch dst = dst - src. Legt OF, SF, ZF, AF, PF, CF entsprechend dem Ergebnis fest. CF wird gesetzt, wenn eine Ausleihe erforderlich ist.

Beispiele

sub rax, rbx                ; rax = rax - rbx
sub rax, 1                  ; decrement
sub [rbp-8], 10             ; subtract from stack

Siehe auch

  • HINZUFÜGEN
  • SBB
  • DEZ
  • NEG
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SUB – Ganzzahlige Subtraktion ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SUB – Ganzzahlige Subtraktion operand[, operand]

PBXB64-Verwendung

SUB – Ganzzahlige Subtraktion ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SUB – Ganzzahlige Subtraktion ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SUBPS – Gepackte Gleitkommawerte mit einfacher Genauigkeit subtrahieren – PBXB64 Assembler-Hilfe

Startseite › Funktionen › SUBPS – Subtrahieren gepackter Gleitkommawerte mit einfacher Genauigkeit
Hilfe zum PBXB64-Compiler

SUBPS – Subtrahieren gepackter Gleitkommawerte mit einfacher Genauigkeit

Subtrahiert vier gepackte Gleitkommawerte mit einfacher Genauigkeit elementweise.

Kategorie: SSE/AVX | Gruppe: SSE-Arithmetik mit gepacktem Gleitkomma

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SUBPS xmm1, xmm2/m128

Operanden

Formular | Beschreibung | Beispiel
xmm, xmm | Zwei 128-Bit-XMM-Register mit jeweils 4 Floats | subps xmm0, xmm1
xmm, m128 | Ziel-XMM, Quelle ist 128-Bit-ausgerichteter Speicher | subps xmm0, [vec]

Beschreibung

SUBPS führt eine SIMD-Subtraktion (Single Instruction, Multiple Data) von vier Gleitkommawerten mit einfacher Genauigkeit (32 Bit) parallel durch. Jedes Element des Quelloperanden wird vom entsprechenden Element des Zieloperanden subtrahiert und die vier Ergebnisse werden in das Ziel zurückgeschrieben.

Für jede Spur i in 0..3: dest[i] = dest[i] - src[i]. Es gibt keine spurübergreifende Interaktion. Die spezielle Arithmetik folgt IEEE-754 mit MXCSR-Rundung und Ausnahmekontrollen.

Flaggen

Es sind keine EFLAGS betroffen. MXCSR-Ausnahmeflags können aktualisiert werden.

Codierungsnotizen

  • SSE-Kodierung: 0F 5C /r.
  • Der Quellspeicheroperand sollte auf 16 Byte ausgerichtet sein, um die beste Leistung auf älteren CPUs zu erzielen. Ein falsch ausgerichteter Zugriff kann je nach Implementierung und Ausrichtungsprüfungseinstellungen zu Strafen oder Fehlern führen.
  • Nicht mit Skalar verwechseln SUBSS (F3 0F 5C /r), wodurch nur der niedrige Float subtrahiert wird.

Beispiele

; Subtract two 4-float vectors
movaps xmm0, [a]     ; a0 a1 a2 a3
movaps xmm1, [b]     ; b0 b1 b2 b3
subps xmm0, xmm1     ; xmm0 = a0-b0, a1-b1, a2-b2, a3-b3
movaps [result], xmm0

When to use

VerwendenSUBPS beim Subtrahieren entsprechender Komponenten von 4-Element-Float-Vektoren, z. B. in 3D/4D-Grafiken, Audioverarbeitung oder wissenschaftlichen Arrays. Verwenden Sie für die Skalar-Float-Subtraktion SUBSS; für Vektoren mit doppelter Genauigkeit verwenden Sie SUBPD.

Siehe auch

  • SUBSS
  • ADDPS
  • MULPS
  • DIVPS

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SUBPS – Subtrahieren gepackter Gleitkommawerte mit einfacher Genauigkeit ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SUBPS – Subtrahieren gepackter Gleitkommawerte mit einfacher Genauigkeit operand[, operand]

PBXB64-Verwendung

SUBPS – Subtrahieren gepackter Gleitkommawerte mit einfacher Genauigkeit ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SUBPS – Subtrahieren gepackter Gleitkommawerte mit einfacher Genauigkeit ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


SUBSD – Skalaren Gleitkommawert mit doppelter Genauigkeit subtrahieren – PBXB64 Assembler-Hilfe

Startseite › Funktionen › SUBSD – Skalaren Gleitkommawert mit doppelter Genauigkeit subtrahieren
Hilfe zum PBXB64-Compiler

SUBSD – Skalaren Gleitkommawert mit doppelter Genauigkeit subtrahieren

Subtrahiert den niedrigen Gleitkommawert mit doppelter Genauigkeit von einem anderen.

Kategorie: SSE/AVX | Gruppe: SSE2 Skalare Gleitkomma-Arithmetik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SUBSD xmm1, xmm2/m64

Operanden

Formular | Beschreibung | Beispiel
xmm, xmm | Quelle und Ziel sind 128-Bit-XMM-Register | subsd xmm0, xmm1
xmm, m64 | Ziel ist das XMM-Register; Quelle ist 64-Bit-Speicher | subsd xmm0, [y]

Beschreibung

SUBSD subtrahiert den niedrigen 64-Bit-Gleitkommawert mit doppelter Genauigkeit des Quelloperanden vom niedrigen Wert mit doppelter Genauigkeit des Zieloperanden. Das Ergebnis wird im unteren Quadword des Ziel-XMM-Registers gespeichert. Die oberen 64 Bit des Ziels bleiben erhalten. Das ist ein Skalar Operation an einem double Wert.

Berechnung ist dest[63:0] = dest[63:0] - src[63:0]. Das IEEE-754-Rundungs- und Ausnahmeverhalten wird von MXCSR gesteuert.

Flaggen

Es sind keine EFLAGS betroffen. MXCSR-Ausnahmeflags können aktualisiert werden.

Codierungsnotizen

  • SSE2-Kodierung: F2 0F 5C /r.
  • DerF2 Präfix wählt Skalaroperation mit doppelter Genauigkeit aus.
  • Für AVX-Formulare mit drei Operanden verwenden VSUBSD; PBXB64 gibt das Basis-SSE2-Formular aus.

Beispiele

; double result = a - b
movsd xmm0, [a]
subsd xmm0, [b]
movsd [result], xmm0

; xmm0 = xmm1 - xmm2, preserving upper bits of xmm0
movsd xmm0, xmm1
subsd xmm0, xmm2

When to use

VerwendenSUBSD für Skalar double Subtraktion. Es handelt sich um das zugrunde liegende Grundelement auf SSE-Ebene double Arithmetik in generiertem Code und Mathematikbibliotheken, wenn SIMD-Vektorisierung nicht anwendbar ist.

Siehe auch

  • SUBSS
  • SUBPS
  • HINZUFÜGEN
  • MULSD

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SUBSD – Skalaren Gleitkommawert mit doppelter Genauigkeit subtrahieren ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SUBSD – Skalaren Gleitkommawert mit doppelter Genauigkeit subtrahieren operand[, operand]

PBXB64-Verwendung

SUBSD – Skalaren Gleitkommawert mit doppelter Genauigkeit subtrahieren ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SUBSD – Skalaren Gleitkommawert mit doppelter Genauigkeit subtrahieren ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← SUBPS – Subtrahieren gepackter Gleitkommawerte mit einfacher Genauigkeit Nach oben SUBSS – Skalaren Gleitkommawert mit einfacher Genauigkeit subtrahieren →


SUBSS – Skalaren Gleitkommawert mit einfacher Genauigkeit subtrahieren – PBXB64 Assembler-Hilfe

Startseite › Funktionen › SUBSS – Skalaren Gleitkommawert mit einfacher Genauigkeit subtrahieren
Hilfe zum PBXB64-Compiler

SUBSS – Skalaren Gleitkommawert mit einfacher Genauigkeit subtrahieren

Subtrahiert den niedrigen Gleitkommawert mit einfacher Genauigkeit von einem anderen.

Kategorie: SSE/AVX | Gruppe: SSE Skalare Gleitkomma-Arithmetik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

SUBSS xmm1, xmm2/m32

Operanden

Formular | Beschreibung | Beispiel
xmm, xmm | Quelle und Ziel sind 128-Bit-XMM-Register | subss xmm0, xmm1
xmm, m32 | Ziel ist das XMM-Register; Quelle ist 32-Bit-Speicher | subss xmm0, [y]

Beschreibung

SUBSS subtrahiert den niedrigen 32-Bit-Gleitkommawert mit einfacher Genauigkeit des Quelloperanden vom niedrigen Wert mit einfacher Genauigkeit des Zieloperanden. Das Ergebnis wird im unteren Dword des Ziel-XMM-Registers gespeichert. Die Bits 32–127 des Ziels bleiben erhalten. Das ist ein Skalar Operation an einem float Wert.

Berechnung ist dest[31:0] = dest[31:0] - src[31:0]. Rundungs- und Ausnahmeverhalten folgen MXCSR.

Flaggen

Es sind keine EFLAGS betroffen. MXCSR-Ausnahmeflags können aktualisiert werden.

Codierungsnotizen

  • SSE-Kodierung: F3 0F 5C /r.
  • DerF3 Präfix wählt Skalaroperation mit einfacher Genauigkeit aus.
  • Nicht mit verpackt verwechseln SUBPS (0F 5C /r), wodurch vier Floats subtrahiert werden.

Beispiele

; float result = a - b
movss xmm0, [a]
subss xmm0, [b]
movss [result], xmm0

; xmm0 = xmm1 - xmm2, preserving upper bits
movss xmm0, xmm1
subss xmm0, xmm2

When to use

VerwendenSUBSS für Skalar float Subtraktion. Es handelt sich um den natürlichen SSE-Befehl für 32-Bit-Gleitkomma-Arithmetik, wenn nur ein Wert beteiligt ist.

Siehe auch

  • SUBPS
  • SUBSD
  • ADDSS
  • MULSS

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

SUBSS – Skalaren Gleitkommawert mit einfacher Genauigkeit subtrahieren ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

SUBSS – Skalaren Gleitkommawert mit einfacher Genauigkeit subtrahieren operand[, operand]

PBXB64-Verwendung

SUBSS – Skalaren Gleitkommawert mit einfacher Genauigkeit subtrahieren ist eine arithmetic Instruktion fuer integer arithmetic. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! SUBSS – Skalaren Gleitkommawert mit einfacher Genauigkeit subtrahieren ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


TEST – PBXB64 Assembler-Hilfe

Startseite› Funktionen › TEST – PBXB64 Assembler-Hilfe

TEST – Logischer Vergleich

Führt eine bitweise UND-Verknüpfung durch und setzt Flags, ohne das Ergebnis zu speichern.

Kategorie: Arithmetik | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

TEST dst, src

Beschreibung

Führt durch dst & src intern, speichert das Ergebnis jedoch nicht. Setzt SF, ZF, PF. Löscht OF und CF. Nützlich zum Testen, ob bestimmte Bits gesetzt sind, ohne das Ziel zu ändern.

Beispiele

test rax, 0x01              ; test bit 0
jz bit_not_set
test rax, rax               ; test if zero (idiomatic, smaller than cmp rax, 0)

Siehe auch

  • CMP
  • UND
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

TEST – Logischer Vergleich ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

TEST – Logischer Vergleich operand[, operand]

PBXB64-Verwendung

TEST – Logischer Vergleich ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! TEST – Logischer Vergleich ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


UD2 – Undefinierte Anweisung – PBXB64 Assembler-Hilfe

Startseite › Funktionen › UD2 – Undefinierte Anweisung

UD2 – Undefinierte Anweisung

Garantiert bei der Ausführung eine Ausnahme wegen ungültigem Opcode (#UD).

Kategorie: System/Atom | Gruppe: Kontroll- und Debug-Anweisungen

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

UD2

Operanden

Formular | Beschreibung | Beispiel
keiner | Keine Operanden; löst immer #UD aus | ud2

Beschreibung

UD2 ist eine definierte Anweisung, die eine Ausnahme wegen undefiniertem Opcode (#UD) erzeugt. Es dient speziell dazu, eine zuverlässige, dokumentierte Möglichkeit zum Auslösen einer Prozessorausnahme für Zwecke wie absichtliche Programmbeendigung, nicht erreichbare Codepfadmarkierungen oder selbsttestende Ausnahmehandler bereitzustellen.

Im Gegensatz zu einer willkürlichen ungültigen Bytefolge UD2 Die Architektur garantiert, dass #UD auf allen x86-64-Prozessoren ausgelöst wird, und wird von Disassemblern und Debuggern erkannt. Compiler geben es oft danach aus __builtin_unreachable(), unreachable IR oder Behauptungen, die niemals scheitern sollten.

Flaggen

Es sind keine Flags betroffen; Die Anweisung löst eine Ausnahme aus, bevor sich der Architekturzustand ändert.

Codierungsnotizen

  • Codiert als 0F 0B.
  • Wird garantiert nicht zu einer gültigen Anweisung in zukünftigen Prozessoren.
  • Einige Assembler akzeptieren UD2A (die Zwei-Byte-Form) und UD2B (ein ModR/M-Formular 0F B9 /r), aber UD2 allein ist der kanonische Opcode.

Beispiele

; Mark a switch default that should never be reached
switch_done:
    jmp table[rax*8]
default_case:
    ud2              ; crash immediately if reached

; Halt on critical invariant failure
cmp [initialized], 1
je  ok
ud2              ; panic if not initialized
ok:

When to use

VerwendenUD2 um die Ausführung an nicht erreichbaren oder völlig ungültigen Codepfaden explizit abzufangen. Bevorzugen Sie es gegenüber einem zufälligen ungültigen Byte, da es selbstdokumentierend und über Prozessorgenerationen hinweg stabil ist. Vermeiden Sie die Verwendung im Benutzercode als normalen Kontrollflussmechanismus. Es ist für das Debuggen und für katastrophale Fehlerpfade gedacht.

Siehe auch

  • INT3
  • NEIN
  • HLT

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

UD2 – Undefinierte Anweisung ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

UD2 – Undefinierte Anweisung operand[, operand]

PBXB64-Verwendung

UD2 – Undefinierte Anweisung ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! UD2 – Undefinierte Anweisung ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


XADD - Exchange and Add - PBXB64 Compiler Help

Startseite › x64 Backend › Instruction Detail Pages › Miscellaneous › XADD - Exchange and Add
Hilfe zum PBXB64-Compiler

XADD - Exchange and Add

Adds the source operand to the destination operand and stores the original destination value in the source. With LOCK it can implement atomic fetch-add.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

Adds the source operand to the destination operand and stores the original destination value in the source. With LOCK it can implement atomic fetch-add.

Verwendung in PBXB64

Use a memory destination with lock xadd for inter-thread counters. Match operand size to the counter storage.

Beispiel

mov rax, 1
lock xadd qword ptr [counter], rax

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

XADD ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

XADD operand[, operand]

PBXB64-Verwendung

XADD ist eine x64 assembler Instruktion fuer inline assembler. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! XADD ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.


XCHG – PBXB64 Assembler-Hilfe

Startseite › Funktionen › XCHG – PBXB64 Assembler-Hilfe

XCHG – Austausch

Tauscht den Inhalt zweier Operanden aus.

Kategorie: Datenbewegung | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XCHG reg, reg/mem

Beschreibung

Vertauscht den Inhalt der beiden Operanden. Wenn ein Operand Speicher ist, ist die Operation implizit gesperrt (atomar).

Beispiele

xchg rax, rbx                ; swap rax and rbx
xchg [rbx], eax              ; swap memory with register

Siehe auch

  • MOV
  • CMP
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

XCHG – Austausch ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

XCHG – Austausch operand[, operand]

PBXB64-Verwendung

XCHG – Austausch ist eine data movement Instruktion fuer data movement. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! XCHG – Austausch ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

← UD2 – Undefinierte Anweisung Nach oben XOR – PBXB64 Assembler-Hilfe →

Assembler-Prüfung

Prüfen Sie diese Instruktion mit einem minimalen Inline-Assembler-Programm, das jedes Eingaberegister oder jeden Speicheroperanden initialisiert, die Instruktion einmal ausführt und das beobachtete Ergebnis zurückgibt oder ausgibt. Bei flagabhängigen Instruktionen sollen Carry-, Zero-, Sign- und Overflow-Verhalten dokumentiert werden, soweit die Instruktion es definiert.

Operandenregeln

Verwenden Sie die dokumentierte Operandenbreite ausdrücklich. In x64-Code sollen 32-Bit- und 64-Bit-Formen nur gemischt werden, wenn die Zero-Extension beabsichtigt ist. Speicheroperanden sollen Basisregister und Displacement-Annahmen des Beispiels benennen.

Fehlerfälle

Assembler-Seiten sollen ungültige Operanden-Kombinationen, Division-Überlauf oder Division durch Null und relevante Register-Clobber nennen, bevor in von PBXB64 erzeugten Code zurückgekehrt wird.


XOR – PBXB64 Assembler-Hilfe

Startseite › Funktionen › XOR – PBXB64 Assembler-Hilfe

XOR – Bitweises XOR

Führt eine bitweise XOR-Verknüpfung der Quelle und des Ziels durch und speichert das Ergebnis im Ziel.

Kategorie: Logisch | Kategorie: Kern-GPR-Mnemonik

PBXB64-Status: VOLLSTÄNDIG UMGESETZT

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Syntax

XOR dst, src

Beschreibung

Führt durch dst = dst ^ src. Setzt OF=0, CF=0, SF, ZF, PF entsprechend dem Ergebnis. Die klassische Redewendung xor reg, reg löscht ein Register und setzt ZF=1, mit kleinerer Codierung als mov reg, 0.

Beispiele

xor rax, rax               ; clear register (idiomatic)
xor rax, rbx               ; toggle bits
xor rax, 0xFF              ; toggle lower 8 bits

Siehe auch

  • UND
  • ODER
  • NICHT
  • Kern-GPR-Mnemonik

Category: Assembly

PBXB64 Status: Reference topic with assembler syntax and a verification pattern; prove CPU-specific behavior with a focused test before claiming full runtime support.

Beschreibung

XOR – Bitweises XOR ist eine x64-Assembler-Instruktion, die in PBXB64-Assemblerseiten dokumentiert wird. Verwenden Sie diese Seite zusammen mit einem kleinen Inline-Assembler- oder Objekt-Assembler-Test, damit Operanden, Registerbreiten, Flags und beobachtbare Ergebnisse aus der aktuellen Toolchain belegt sind.

Syntax

XOR – Bitweises XOR operand[, operand]

PBXB64-Verwendung

XOR – Bitweises XOR ist eine bit and flag Instruktion fuer bit operations. In PBXB64 wird die Instruktion im Inline-Assembler oder in assemblernahen Routinen verwendet, wenn der generierte Hochsprachen-Code bewusst durch eine konkrete x64-Operation ergaenzt werden soll. Halten Sie Eingabe- und Ergebnisregister im Kommentar fest, damit der umgebende BASIC-, C-, B64- oder Rust-Code nachvollziehbar bleibt.

Operanden und Groessen

Die zulaessigen Operanden richten sich nach der Syntax auf dieser Seite. Register-, Speicher- und Immediate-Formen duerfen nicht beliebig gemischt werden; die Operandenbreite muss zur Instruktion passen. Verwenden Sie explizite Groessenangaben bei Speicheroperanden, wenn die Breite nicht eindeutig aus einem Register oder der Instruktionsform hervorgeht.

Nebenwirkungen und Flags

Pruefen Sie vor der Verwendung, ob die Instruktion Flags, Speicher, Stackzeiger oder implizite Register veraendert. Besonders bedingte Spruenge, Vergleichsoperationen, Stackbefehle und Multiplikation/Division haben Abhaengigkeiten, die nicht in der Operandenliste sichtbar sind. Speichern Sie Werte, die nach dem Assemblerblock weiterhin benoetigt werden.

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vorbereiten.
    ' ! XOR – Bitweises XOR ...
    ' Ergebnis pruefen und beobachtbare Seiteneffekte dokumentieren.
    FUNCTION = 0
END FUNCTION

Validation evidence: Use this sample pattern as a focused assembler validation program and cite the exact test file when the instruction is promoted from reference syntax to tested support.

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.


Assembler Addressing Modes - PBXB64 Compiler Help

Startseite › asm_addressing_modes.html

Assembler Addressing Modes

PBXB64 x64 assembly accepts register, immediate, label, and memory operands. Memory operands use Intel-style base/index/scale/displacement forms such as [rax], [rbp-8], and [rcx+rdx*4+16].

PBXB64-Status: Referenzthema

Syntax und Bedeutung

PBXB64 x64 assembly accepts register, immediate, label, and memory operands. Memory operands use Intel-style base/index/scale/displacement forms such as [rax], [rbp-8], and [rcx+rdx*4+16].

Verwendung in PBXB64

Use explicit operand sizes when the instruction does not imply one: byte ptr, word ptr, dword ptr, or qword ptr.

Beispiel

mov rax, [rbp-8]
lea rcx, [rax+rdx*8+32]
mov qword ptr [rcx], 1234

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Zurück zum Befehlsindex

← Top →


Assembler Directives - PBXB64 Compiler Help

Startseite › asm_directives.html

Assembler Directives

Directives describe sections, public symbols, data objects, and assembly-time layout. PBXB64 emits and consumes directives such as section, .globl, labels, and data declarations.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

Directives describe sections, public symbols, data objects, and assembly-time layout. PBXB64 emits and consumes directives such as section, .globl, labels, and data declarations.

Verwendung in PBXB64

Keep directives close to the code or data they describe. In mixed frontend output, generated directives are normally produced by the backend rather than handwritten source.

Beispiel

section .text
.globl main
main:
    xor rax, rax
    ret

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

Datei- und Geräteprüfung

Datei-, Verzeichnis-, Drucker- und Ressourcenseiten sollen das benötigte Windows-Objekt, Berechtigungen, erwartetes Pfadformat und Cleanup nennen. Beispiele sollen nach Möglichkeit temporäre Eingaben erzeugen und nicht von einem benutzerspezifischen Drucker oder Laufwerk abhängen.

Fehlerbehandlung

Dokumentieren Sie Nicht-gefunden, Zugriff-verweigert, ungültigen Handle, volle Datenträger, abgebrochene Dialoge und nicht verfügbare Geräte, sofern zutreffend.

Portabilitätshinweise

Verwenden Sie ausdrückliche Unicode/ANSI-Erwartungen und x64-sichere Handles. Vermeiden Sie fest kodierte absolute Pfade, sofern die Seite nicht speziell Pfadbehandlung beschreibt.

Zurück zum Befehlsindex

← Top →


AVX Mnemonics - PBXB64 Compiler Help

Startseite › asm_mnemonics_avx.html

AVX Mnemonics

AVX mnemonics extend SIMD operations with VEX-encoded forms and wider YMM registers. They are useful for vectorized numeric code and explicit assembly blocks.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

AVX mnemonics extend SIMD operations with VEX-encoded forms and wider YMM registers. They are useful for vectorized numeric code and explicit assembly blocks.

Verwendung in PBXB64

Confirm CPU availability before using AVX-specific code in distributable programs. Keep fallback paths when targeting older Windows systems.

Beispiel

vzeroupper
vaddps ymm0, ymm1, ymm2
vmovups ymmword ptr [rcx], ymm0

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

Assembler-Integration

Assembler-Konzeptseiten sollen Registerbreite, Stack-Alignment, erhaltene Register, Flag-Nutzung und User-Mode-Gültigkeit unter Windows nennen. Inline-Schnipsel müssen mit intakter x64-Aufrufkonvention zurückkehren.

Prüfung

Verwenden Sie kleine Programme, die Register oder Speicher initialisieren, jeweils ein Konzept ausführen und das exakte Ergebnis vergleichen. Bei Stack-Beispielen muss gezeigt werden, dass Aufrufe nach dem Schnipsel weiter korrekt laufen.

Migrationshinweise

Prüfen Sie 32-Bit-Beispiele auf ESP/EBP-Annahmen, PUSHAD/POPAD, Pointer-Trunkierung und x87/MMX-Zustandswechsel.

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Zurück zum Befehlsindex

← Top →


BMI Mnemonics - PBXB64 Compiler Help

Startseite › asm_mnemonics_bmi.html

BMI Mnemonics

BMI and BMI2 instructions provide bit-manipulation operations such as bit extraction, population transforms, and parallel bit deposit/extract operations.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

BMI and BMI2 instructions provide bit-manipulation operations such as bit extraction, population transforms, and parallel bit deposit/extract operations.

Verwendung in PBXB64

These instructions are CPU-feature dependent. Use them only when the deployment target is known or guarded by feature checks.

Beispiel

andn rax, rcx, rdx
bextr rax, rcx, rdx
pext rax, rcx, rdx

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Zurück zum Befehlsindex

← Top →


Cache and Memory Ordering Mnemonics - PBXB64 Compiler Help

Startseite › asm_mnemonics_cache.html

Cache and Memory Ordering Mnemonics

Cache-oriented instructions control prefetching, cache-line flushes, fences, and memory-ordering boundaries. They are normally used in low-level runtime code.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

Cache-oriented instructions control prefetching, cache-line flushes, fences, and memory-ordering boundaries. They are normally used in low-level runtime code.

Verwendung in PBXB64

Use these instructions sparingly. Incorrect fences or flushes can make code slower without improving correctness.

Beispiel

prefetcht0 [rcx]
clflush [rcx]
mfence

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Zurück zum Befehlsindex

← Top →


Core x64 Mnemonics - PBXB64 Compiler Help

Startseite › asm_mnemonics_core.html

Core x64 Mnemonics

Core mnemonics cover integer arithmetic, data movement, stack operations, calls, returns, comparisons, branches, shifts, rotates, and flag operations.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

Core mnemonics cover integer arithmetic, data movement, stack operations, calls, returns, comparisons, branches, shifts, rotates, and flag operations.

Verwendung in PBXB64

These instructions are the normal backend target for BASIC, C, B64, COBOL, Rust, and PILOT lowering when scalar integer code is emitted.

Beispiel

mov rax, rcx
add rax, rdx
cmp rax, 10
jge done

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Zurück zum Befehlsindex

← Top →


Crypto Mnemonics - PBXB64 Compiler Help

Startseite › asm_mnemonics_crypto.html

Crypto Mnemonics

Crypto mnemonics include AES, carry-less multiply, and hash-assist instructions used by optimized cryptographic routines.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

Crypto mnemonics include AES, carry-less multiply, and hash-assist instructions used by optimized cryptographic routines.

Verwendung in PBXB64

Do not assume crypto instructions exist on every x64 CPU. Runtime feature detection is required for general-purpose binaries.

Beispiel

aesenc xmm0, xmm1
pclmulqdq xmm0, xmm1, 0
sha256rnds2 xmm0, xmm1, xmm2

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Zurück zum Befehlsindex

← Top →


x87 FPU Mnemonics - PBXB64 Compiler Help

Startseite › asm_mnemonics_fpu.html

x87 FPU Mnemonics

x87 mnemonics operate on the legacy floating-point stack. PBXB64 primarily targets SSE2+ for floating-point code, but x87 remains relevant for old inline assembly.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

x87 mnemonics operate on the legacy floating-point stack. PBXB64 primarily targets SSE2+ for floating-point code, but x87 remains relevant for old inline assembly.

Verwendung in PBXB64

Prefer SSE scalar instructions for new x64 code unless compatibility with an existing x87 sequence is required.

Beispiel

fld qword ptr [rbp-8]
fadd qword ptr [rbp-16]
fstp qword ptr [rbp-24]

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Zurück zum Befehlsindex

← Top →


MMX Mnemonics - PBXB64 Compiler Help

Startseite › asm_mnemonics_mmx.html

MMX Mnemonics

MMX instructions operate on legacy MM registers. They share state with the x87 FPU and require cleanup with emms before returning to floating-point code.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

MMX instructions operate on legacy MM registers. They share state with the x87 FPU and require cleanup with emms before returning to floating-point code.

Verwendung in PBXB64

Prefer XMM/SSE instructions for new code. Use MMX only when maintaining old assembly fragments.

Beispiel

movq mm0, qword ptr [rcx]
paddb mm0, mm1
emms

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Zurück zum Befehlsindex

← Top →


SGX and VMX Mnemonics - PBXB64 Compiler Help

Startseite › asm_mnemonics_sgx_vmx.html

SGX and VMX Mnemonics

SGX and VMX instructions belong to enclave and virtualization support. They are privileged or feature-dependent and are not ordinary application instructions.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

SGX and VMX instructions belong to enclave and virtualization support. They are privileged or feature-dependent and are not ordinary application instructions.

Verwendung in PBXB64

Application code should treat these as specialist system-programming instructions and document required CPU, OS, and privilege assumptions.

Beispiel

vmcall
vmlaunch
encls

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Zurück zum Befehlsindex

← Top →


SSE Mnemonics - PBXB64 Compiler Help

Startseite › asm_mnemonics_sse.html

SSE Mnemonics

SSE instructions operate on XMM registers and are used for scalar and packed floating-point operations. Common scalar forms include movss, movsd, addss, addsd, mulss, and mulsd.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

SSE instructions operate on XMM registers and are used for scalar and packed floating-point operations. Common scalar forms include movss, movsd, addss, addsd, mulss, and mulsd.

Verwendung in PBXB64

Use the single-precision suffix ss for 32-bit floats and the double-precision suffix sd for 64-bit floats.

Beispiel

movsd xmm0, qword ptr [rbp-8]
addsd xmm0, xmm1
movsd qword ptr [rbp-16], xmm0

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Zurück zum Befehlsindex

← Top →


System Mnemonics - PBXB64 Compiler Help

Startseite › asm_mnemonics_system.html

System Mnemonics

System mnemonics include control-register access, timestamp reads, CPU identification, interrupts, and other low-level machine operations.

PBXB64-Status: Referenzthema

Syntax und Bedeutung

System mnemonics include control-register access, timestamp reads, CPU identification, interrupts, and other low-level machine operations.

Verwendung in PBXB64

Many system instructions are privileged or have strict runtime constraints. In normal user-mode PBXB64 programs, use only safe instructions such as cpuid and rdtsc when appropriate.

Beispiel

cpuid
rdtsc
int3

Prüfung

Prüfen Sie Beispiele mit dem aktuellen PBXB64-Compiler und dokumentieren Sie CPU-, Windows- oder Bibliotheksvoraussetzungen direkt im Beispiel.

Siehe auch

  • Assembler-Übersicht
  • Befehlsindex

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Category: Assembly

PBXB64 Status: Referenzthema fuer Assembler-Syntax und Familienhinweise; untergeordnete Instruktionsseiten und registrierte Tests liefern den endgueltigen Support-Nachweis.

Beschreibung

Dieses Assembler-Thema gruppiert PBXB64-x64-Assembler-Syntax, Direktiven, Adressierungsregeln oder Mnemonik-Familien. Behandeln Sie es als Navigation plus Nutzungshinweis, sofern keine Unterseite oder kein registrierter Test eine konkrete Instruktionsform belegt.

Syntax

! mnemonic operand[, operand]
#ASM
    mnemonic operand[, operand]
#END ASM

Example

#COMPILE EXE
#DIM ALL

FUNCTION PBMAIN() AS LONG
    ' Eingaben vor der Assembler-Instruktion initialisieren.
    ' ! nop
    FUNCTION = 0
END FUNCTION

Validation evidence: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Prüfung der Instruktionsfamilie

Verwenden Sie diese Mnemonik-Übersichten als Einstieg in fokussierte Assembler-Tests. Eine vollständige Prüfung nennt CPU-Feature-Bit, Operandenbreite, Register- oder Speicherform, Flag-Auswirkungen und ob die Instruktion im Windows-x64-User-Mode gültig ist.

Beispieldisziplin

Assembler-Beispiele sollen alle Eingaben initialisieren, die Instruktion isoliert ausführen und das exakte Ergebnis vergleichen. Bei featureabhängigen Familien wie BMI, Crypto, SGX, VMX oder Cache-Management ist ein Feature-Check oder die Prozessorvoraussetzung zu nennen.

PBXB64-Integrationshinweise

Inline-Assembler muss die Windows-x64-Aufrufkonvention erhalten, wenn die Kontrolle zu compilererzeugtem Code zurückkehrt. Sichern Sie nichtflüchtige Register, halten Sie Stack-Alignment bei Aufrufen ein und dokumentieren Sie absichtlich veränderte Flags oder Register.

See Also

PBXB64 Inline Assembler | Assembler Directives | Addressing Modes

Validierungsbeleg

Validierungsbeleg: Verwenden Sie die registrierten Inline-Assembler- und Standalone-Assembler-Validierungsprogramme als Nachweis fuer konkrete unterstuetzte Instruktionsformen und nennen Sie die genaue Testdatei auf der Unterseite, wenn vorhanden.

Zurück zum Befehlsindex

← Top →


B64 Operatoren — PBXB64 Help

Startseite › b64_ref_operators.html

B64 Operatoren

Kind: Reference hub | Category: B64-Frontend

PBXB64-Status: AVAILABLE

PBXB64-Zertifizierung: [CERTIFIED TESTED] Uebersichtsseite fuer die getestete B64-Frontend-Teilmenge; die verlinkten Unterseiten und examples/b64-Proben liefern den konkreten Nachweis.

Arithmetik, Bitoperationen, Logik, Vergleiche, Casts und Groessenabfragen sind auf der Operator-Befehlsseite dokumentiert.

  • Operatoren - Arithmetik, Bitoperationen, Vergleiche, Casts und zusammengesetzte Zuweisungen

Syntax

#B64
// Verwenden Sie die verlinkten B64-Konstrukte in einer vollstaendigen B64-Quelldatei.
#B64 END

Beschreibung

Diese Seite ist die Uebersicht fuer eine B64-Funktionsgruppe. Die untergeordneten Seiten enthalten die konkrete Befehlssyntax, fokussierte Verhaltenshinweise und das Getestetes Beispiel, welches die Implementierung in der Validierungsmatrix belegt.

Beispiel

fn main(): i64 {
    let answer: i64 = 42;
    return answer;
}

Verifiziertes Beispiel

Repraesentative B64-Beispiele liegen unter examples/b64 und werden von der b64_linkrun-Validierungsspur kompiliert und ausgefuehrt.

Verwendung dieses Unterkapitels

Diese Seite ist die Uebersicht fuer eine B64-Funktionsgruppe. Die untergeordneten Seiten enthalten die konkrete Befehlssyntax, fokussierte Verhaltenshinweise und das Getestetes Beispiel, welches die Implementierung in der Validierungsmatrix belegt.

Verifizierungsmodell

Die verlinkten Befehlsseiten nennen Beispiele aus examples/b64. Diese Programme werden von der b64_linkrun-Spur kompiliert und ausgefuehrt, damit die Dokumentation an das aktuelle Compilerverhalten gebunden bleibt und keine statische Sprachskizze ist.

Frontend-Grenze

B64 ist das native System-Frontend von PBXB64. Diese Seiten beschreiben die getestete PBXB64-Teilmenge und ihre Senkung in native IR; sie versprechen keine Kompatibilitaet mit einer separaten externen Sprache oder Runtime.

Grenzen

Nur Konstrukte, die durch aktuelle B64-Quellen und registrierte Validierungstests belegt sind, sollen als zertifiziert beschrieben werden. Nicht unterstuetzte Sprachideen bleiben Backlog, bis Quellcode-, Test- und Hilfenachweis vorhanden sind.

Siehe auch

B64-Sprachuebersicht | fn | Operatoren

← Back

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

← Top →


Breite Ganzzahltypen – Hilfe zum PBXB64-Compiler

Startseite › wide_integers.html

Breite Ganzzahltypen

PBXB64 fügt über die standardmäßigen numerischen 8/16/32/64-Bit-Typen hinaus breite Ganzzahltypen mit fester Breite hinzu. Diese Typen werden mit nativem x64-Inline-Code für arithmetische, bitweise und Vergleichsoperationen implementiert.

Typ: Datentypfamilie | Kategorie: Numerische Typen

PBXB64-Status:VERFÜGBAR

PBXB64-Zertifizierung: [ZERTIFIZIERT GETESTET]

Unterstützte Typen

Typ | Alias | Größe | Signiert | Reichweite
INT128 | I128 | 16 Byte | Ja | -2127 .. 2127-1
UINT128 | U128 | 16 Byte | Nein | 0 .. 2128-1
INT256 | I256 | 32 Byte | Ja | -2255 .. 2255-1
UINT256 | U256 | 32 Byte | Nein | 0 .. 2256-1
INT512 | I512 | 64 Byte | Ja | -2511 .. 2511-1
UINT512 | U512 | 64 Byte | Nein | 0 .. 2512-1

Erklärung

LOCAL a AS INT128
LOCAL b AS U128
LOCAL c AS INT256
LOCAL d AS UINT512

Operationen

Alle Vorgänge sind nativer x64-Inline-Code ohne Laufzeitbibliotheksaufrufe:

  • Arithmetik: ADD, SUB, MUL, DIV, REM
  • Bitweise: UND, ODER, XOR, NICHT, SHL, SHR, SAR
  • Vergleich: EQ, NE, LT, LE, GT, GE

Siehe auch

  • INT128 / I128
  • UINT128 / U128
  • INT256 / I256
  • UINT256 / U256
  • INT512 / I512
  • UINT512 / U512

PBXB64-Prüfung

Diese Referenzseite soll durch ein fokussiertes Compile- oder Laufzeitbeispiel belegt sein. Das Beispiel soll Eingaben, erwartete Ausgabe oder Exit-Code und erforderliche Windows-Ressourcen oder Include-Dateien nennen.

Nutzungsgrenzen

Trennen Sie implementiertes PBXB64-Verhalten von historischem PowerBASIC-Kontext, Migrationshinweisen und konzeptionellem Hintergrund. Laufzeitunterstützung darf nicht behauptet werden, wenn Verhalten nur historisch beschrieben ist.

Verwandte Workflows

Wenn ein Thema breit ist, verlinken Sie auf die konkreten Befehlsseiten, die die Arbeit ausführen, und prüfen Sie diese Befehlsseiten separat.

Übersichtshinweise

Allgemeine Übersichtsseiten sollten trotzdem sagen, welche Familie gemeint ist, welche konkreten Befehlsseiten die Implementierung tragen und welche Formen nur der Navigation dienen. So bleibt die Seite detailliert genug, ohne so zu tun, als wäre sie eine vollständige Befehlsreferenz.

Zurück zum Befehlsindex

← Nach oben →